Revit API Reference

[image]

Revit 2011 API
Revit API Reference
Send Feedback

Namespaces

Namespace | Description
Autodesk.Revit.ApplicationServices |
Autodesk.Revit.Attributes |
Autodesk.Revit.Collections |
Autodesk.Revit.Creation |
Autodesk.Revit.DB |
Autodesk.Revit.DB.Analysis |
Autodesk.Revit.DB.Architecture |
Autodesk.Revit.DB.Electrical |
Autodesk.Revit.DB.Events |
Autodesk.Revit.DB.Mechanical |
Autodesk.Revit.DB.Plumbing |
Autodesk.Revit.DB.Structure |
Autodesk.Revit.Exceptions |
Autodesk.Revit.UI |
Autodesk.Revit.UI.Events |
Autodesk.Revit.UI.Selection |
Autodesk.Revit.Utility |
Autodesk.Revit.VSTA |

Send comments on this topic to Autodesk


Autodesk.Revit.ApplicationServices Namespace

[image]

Revit 2011 API
Autodesk.Revit.ApplicationServices Namespace
Send Feedback

Classes

Class | Description
Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Enumerations

Enumeration | Description
LanguageType | An enumerated type containing the supported Revit product languages.
ProductType | An enumerated type containing the possible Revit product types.


Application Class

[image]

Revit 2011 API
Application Class
Members Example See Also Send Feedback
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Application : IDisposable
Visual Basic (Declaration)
Public Class Application _
    Implements IDisposable
Visual C++
public ref class Application : IDisposable

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = application.VersionBuild + vbLf + application.VersionName + vbLf + application.VersionNumber

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.ApplicationServices..::.Application

See Also

Application Members
Autodesk.Revit.ApplicationServices Namespace


Application Members

[image] [image]

Revit 2011 API
Application Members
Application Class Constructors Methods Properties Events See Also Send Feedback

The Application type exposes the following members.

Constructors

Name | Description
Application | Initializes a new instance of the Application class

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

Properties

Name | Description
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
FamilyTemplatePath | Default path for family template files
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Constructor

[image]

Revit 2011 API
Application Constructor
Application Class See Also Send Feedback
Initializes a new instance of the Application class

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Application()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Application()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Methods

[image] [image]

Revit 2011 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
NewProjectDocument | New project document
NewProjectTemplateDocument | New project template document
OpenDocumentFile | Opens a document from disk.
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Dispose Method

[image]

Revit 2011 API
Application..::.Dispose Method
Application Class See Also Send Feedback

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ExtractPartAtomFromFamilyFile Method

[image]

Revit 2011 API
Application..::.ExtractPartAtomFromFamilyFile Method
Application Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Visual Basic (Declaration)
Public Sub ExtractPartAtomFromFamilyFile ( _
    familyFilePath As String, _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)

Parameters

familyFilePath
Type: System..::.String
The family file to be processed.
xmlFilePath
Type: System..::.String
The xml file to be saved.

Remarks

If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom. To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'familyFilePath' or 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string or if the family file doesn't exist on disk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2011 API
Application..::.GetFailureDefinitionRegistry Method
Application Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic (Declaration)
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewFamilyDocument Method

[image]

Revit 2011 API
Application..::.NewFamilyDocument Method
Application Class Example See Also Send Feedback
New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

It is correspond to the File->New->Family.../TitleBlock.../Annotation Symbol....

Examples

CopyC#
// create a new family document using Generic Model.rft template
string templateFileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft";
Document familyDocument = application.NewFamilyDocument(templateFileName);
if (null == familyDocument)
{
    throw new Exception("Cannot open family document");
}
CopyVB.NET
' create a new family document using Generic Model.rft template
Dim templateFileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft"
Dim familyDocument As Document = application.NewFamilyDocument(templateFileName)
If familyDocument Is Nothing Then
    Throw New Exception("Cannot open family document")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the new family document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewProjectDocument Method

[image]

Revit 2011 API
Application..::.NewProjectDocument Method
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic (Declaration)
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::.String
The template file name.

Remarks

This command corresponds to the New->Project command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the new project document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewProjectTemplateDocument Method

[image]

Revit 2011 API
Application..::.NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic (Declaration)
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::.String
The template file name.

Remarks

This corresponds to the New->Project->Project Template command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the project template document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method

[image]

Revit 2011 API
Application..::.OpenDocumentFile Method
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic (Declaration)
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file to be opened.

Remarks

It is correspond to the File->Open....

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'fileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the file cannot be opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenSharedParameterFile Method

[image]

Revit 2011 API
Application..::.OpenSharedParameterFile Method
Application Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


RegisterFailuresProcessor Method

[image]

Revit 2011 API
Application..::.RegisterFailuresProcessor Method
Application Class See Also Send Feedback
Registers Revit application-wide instance of Failures Processor.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic (Declaration)
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::.IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear. If you want to handle only specific failures but not all types of failures in your application, subscribe to the FailuresProcessing event instead, or use FailuresPreprocessor interface for the specific transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2011 API
Application..::.WriteJournalComment Method
Application Class See Also Send Feedback
Writes a comment to the Revit journal file

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic (Declaration)
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::.String
Text for journal comment
timeStamp
Type: System..::.Boolean
If a time stamp should be included in the journal comment

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Properties

[image] [image]

Revit 2011 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
Assets |
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Documents | Returns a set of documents within Revit.
FamilyTemplatePath | Default path for family template files
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Assets Property

[image]

Revit 2011 API
Application..::.Assets Property
Application Class See Also Send Feedback

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetSet Assets[
    AssetType
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Assets ( _
     As AssetType _
) As AssetSet
Visual C++
public:
property AssetSet^ Assets[AssetType ] {
    AssetSet^ get (AssetType );
}

Parameters

Type: Autodesk.Revit.Utility..::.AssetType

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2011 API
Application..::.Cities Property
Application Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2011 API
Application..::.Create Property
Application Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Documents Property

[image]

Revit 2011 API
Application..::.Documents Property
Application Class See Also Send Feedback
Returns a set of documents within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DocumentSet Documents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Documents As DocumentSet
Visual C++
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}

Remarks

This property can be used for the user to find all the document inside Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FamilyTemplatePath Property

[image]

Revit 2011 API
Application..::.FamilyTemplatePath Property
Application Class See Also Send Feedback
Default path for family template files

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string FamilyTemplatePath { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyTemplatePath As String
Visual C++
public:
property String^ FamilyTemplatePath {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsQuiescent Property

[image]

Revit 2011 API
Application..::.IsQuiescent Property
Application Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2011 API
Application..::.Language Property
Application Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As LanguageType
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


LibraryPaths Property

[image]

Revit 2011 API
Application..::.LibraryPaths Property
Application Class Example See Also Send Feedback
Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap LibraryPaths { get; set; }
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.LibraryPaths)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.LibraryPaths
    strLibPaths += path + vbLf
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ObjectFactory Property

[image]

Revit 2011 API
Application..::.ObjectFactory Property
Application Class See Also Send Feedback
Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ObjectFactory ObjectFactory { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectFactory As ObjectFactory
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2011 API
Application..::.Product Property
Application Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic (Declaration)
Public ReadOnly Property Product As ProductType
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2011 API
Application..::.RecordingJournalFilename Property
Application Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordingJournalFilename As String
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file.These files are useful for providing information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SharedParametersFilename Property

[image]

Revit 2011 API
Application..::.SharedParametersFilename Property
Application Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic (Declaration)
Public Property SharedParametersFilename As String
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2011 API
Application..::.VersionBuild Property
Application Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2011 API
Application..::.VersionName Property
Application Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2011 API
Application..::.VersionNumber Property
Application Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Events

[image] [image]

Revit 2011 API
Application Events
Application Class See Also Send Feedback

The Application type exposes the following members.

Events

Name | Description
DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentChanged Event

[image]

Revit 2011 API
Application..::.DocumentChanged Event
Application Class See Also Send Feedback
Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Visual Basic (Declaration)
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
Visual C++
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}

Remarks

This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosed Event

[image]

Revit 2011 API
Application..::.DocumentClosed Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic (Declaration)
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The closed document cannot be modified, in fact, user has no way to access it in the event handler.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosing Event

[image]

Revit 2011 API
Application..::.DocumentClosing Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentClosed event will be raised immediately after document is closed.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2011 API
Application..::.DocumentCreated Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic (Declaration)
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2011 API
Application..::.DocumentCreating Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic (Declaration)
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2011 API
Application..::.DocumentOpened Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        Transaction transaction = new Transaction(doc, "Edit Address");
        if (transaction.Start() == TransactionStatus.Started)
        {
            doc.ProjectInformation.Address =
                "United States - Massachusetts - Waltham - 1560 Trapelo Road";
            transaction.Commit();
        }
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Dim transaction As New Transaction(doc, "Edit Address")
        If transaction.Start() = TransactionStatus.Started Then
            doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
            transaction.Commit()
        End If
    End Sub

    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpening Event

[image]

Revit 2011 API
Application..::.DocumentOpening Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic (Declaration)
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2011 API
Application..::.DocumentPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (null == args.FailedViews || 0 == args.PrintedViews.Size)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(args.PrintedViews, "      ", ref info);
        }
        //
        // FailedViews
        if (null == args.FailedViews || 0 == args.FailedViews.Size)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(args.FailedViews, "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.DB.View curView = vsi.Current as Autodesk.Revit.DB.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " + args.Status.ToString())
        info.AppendLine("    Event Cancellable : " + args.Cancellable)
        '
        ' PrintedViews
        If args.FailedViews Is Nothing OrElse 0 = args.PrintedViews.Size Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(args.PrintedViews, "      ", info)
        End If
        '
        ' FailedViews
        If args.FailedViews Is Nothing OrElse 0 = args.FailedViews.Size Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(args.FailedViews, "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2011 API
Application..::.DocumentPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        DumpViewsInfo(args.Views, "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(ViewSet views, String prefix, ref StringBuilder info)
    {
        int index = 0;
        ViewSetIterator vsi = views.ForwardIterator();
        vsi.Reset();
        while (vsi.MoveNext())
        {
            Autodesk.Revit.DB.View curView = vsi.Current as Autodesk.Revit.DB.View;
            if (null != curView)
            {
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
            }
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " + args.Cancellable)
        info.AppendLine("    Views to be printed : ")
        ' Views
        DumpViewsInfo(args.Views, "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2011 API
Application..::.DocumentSaved Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2011 API
Application..::.DocumentSavedAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2011 API
Application..::.DocumentSaving Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavingAs Event

[image]

Revit 2011 API
Application..::.DocumentSavingAs Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel = true;
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(ByVal sender As [Object], ByVal args As Autodesk.Revit.DB.Events.DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel = True
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2011 API
Application..::.DocumentSynchronizedWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central file. It is raised even when document synchronizing with central file failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2011 API
Application..::.DocumentSynchronizingWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2011 API
Application..::.FailuresProcessing Event
Application Class Example See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic (Declaration)
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using provided restricted failures accessor interface.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)]
[Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)]
public class NoUnenclosedRoomWarnings : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

    public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication uiControlledApplication)
    {
        //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
        return Result.Succeeded;
    }

    public Autodesk.Revit.UI.Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
    {
        FailuresAccessor fa = e.GetFailuresAccessor();
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                fa.DeleteWarning(failure);
            }
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)> _
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(ByVal uiControlledApplication As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += New EventHandler < FailuresProcessingEventArgs > (CheckWarnings)
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(ByVal sender As Object, ByVal e As Autodesk.Revit.DB.Events.FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2011 API
Application..::.FileExported Event
Application Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic (Declaration)
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileExporting Event

[image]

Revit 2011 API
Application..::.FileExporting Event
Application Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileImported Event

[image]

Revit 2011 API
Application..::.FileImported Event
Application Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic (Declaration)
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2011 API
Application..::.FileImporting Event
Application Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2011 API
Application..::.ViewPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " + args.Status)
        info.AppendLine("    TotalViews          : " + args.TotalViews)
        info.AppendLine("    View Index          : " + args.Index)
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2011 API
Application..::.ViewPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & args.Cancellable.ToString())
        info.AppendLine("    TotalViews          : " & args.TotalViews.ToString())
        info.AppendLine("    View Index          : " & args.Index.ToString())
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Class

[image]

Revit 2011 API
ControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ControlledApplication
Visual Basic (Declaration)
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.ApplicationServices..::.ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Members

[image] [image]

Revit 2011 API
ControlledApplication Members
ControlledApplication Class Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

Events

Name | Description
DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Methods

[image] [image]

Revit 2011 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteJournalComment | Writes a comment to the Revit journal file

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2011 API
ControlledApplication..::.GetFailureDefinitionRegistry Method
ControlledApplication Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic (Declaration)
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


OpenSharedParameterFile Method

[image]

Revit 2011 API
ControlledApplication..::.OpenSharedParameterFile Method
ControlledApplication Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic (Declaration)
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file.

Remarks

This function is used to return an object that represents a Revit shared parameters file that exists on disk. Revit can use only one shared parameters file at any one time. The filename for the shared parameters file can be set in the Revit Application Options object. If the file does not exist and error will be created and an empty reference will be returned.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RegisterFailuresProcessor Method

[image]

Revit 2011 API
ControlledApplication..::.RegisterFailuresProcessor Method
ControlledApplication Class See Also Send Feedback
Registers Revit application-wide instance of Failures Processor.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic (Declaration)
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::.IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear. If you want to handle only specific failures but not all types of failures in your application, subscribe to the FailuresProcessing event instead, or use FailuresPreprocessor interface for the specific transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2011 API
ControlledApplication..::.WriteJournalComment Method
ControlledApplication Class See Also Send Feedback
Writes a comment to the Revit journal file

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic (Declaration)
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::.String
Text for journal comment
timeStamp
Type: System..::.Boolean
If a time stamp should be included in the journal comment

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Properties

[image] [image]

Revit 2011 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

Name | Description
Cities | Returns a set of all the known city locations within Revit.
Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
IsQuiescent | Returns if the current application is quiescent.
Language | The language used in the current session of Revit.
LibraryPaths | Retrieves path information for where content is stored on disk.
Product | The product type for the current session of Revit.
RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
VersionBuild | Returns the internal build number of the Autodesk Revit application.
VersionName | Returns the name of the Revit application.
VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2011 API
ControlledApplication..::.Cities Property
ControlledApplication Class See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cities As CitySet
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2011 API
ControlledApplication..::.Create Property
ControlledApplication Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Application
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


IsQuiescent Property

[image]

Revit 2011 API
ControlledApplication..::.IsQuiescent Property
ControlledApplication Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsQuiescent As Boolean
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in of the current application is in editing mode or the In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2011 API
ControlledApplication..::.Language Property
ControlledApplication Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As LanguageType
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LibraryPaths Property

[image]

Revit 2011 API
ControlledApplication..::.LibraryPaths Property
ControlledApplication Class See Also Send Feedback
Retrieves path information for where content is stored on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap LibraryPaths { get; set; }
Visual Basic (Declaration)
Public Property LibraryPaths As StringStringMap
Visual C++
public:
property StringStringMap^ LibraryPaths {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

This property is used to control where Autodesk Revit searches for content. The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2011 API
ControlledApplication..::.Product Property
ControlledApplication Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic (Declaration)
Public ReadOnly Property Product As ProductType
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2011 API
ControlledApplication..::.RecordingJournalFilename Property
ControlledApplication Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordingJournalFilename As String
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file.These files are useful for providing information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SharedParametersFilename Property

[image]

Revit 2011 API
ControlledApplication..::.SharedParametersFilename Property
ControlledApplication Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic (Declaration)
Public Property SharedParametersFilename As String
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2011 API
ControlledApplication..::.VersionBuild Property
ControlledApplication Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionBuild As String
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2011 API
ControlledApplication..::.VersionName Property
ControlledApplication Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionName As String
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2011 API
ControlledApplication..::.VersionNumber Property
ControlledApplication Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionNumber As String
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Events

[image] [image]

Revit 2011 API
ControlledApplication Events
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Events

Name | Description
DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
DocumentClosed | Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.
DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.
FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentChanged Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentChanged Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Visual Basic (Declaration)
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
Visual C++
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}

Remarks

This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosed Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentClosed Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosed event to be notified immediately after Revit has finished closing a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic (Declaration)
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The closed document cannot be modified, in fact, user has no way to access it in the event handler.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosing Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentClosing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentClosed event will be raised immediately after document is closed.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentCreated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic (Declaration)
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentCreating Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic (Declaration)
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentOpened Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic (Declaration)
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpening Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentOpening Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic (Declaration)
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentPrinted Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentPrinting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSaved Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSaving Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavingAs Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSavingAs Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSynchronizedWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central file. It is raised even when document synchronizing with central file failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2011 API
ControlledApplication..::.DocumentSynchronizingWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic (Declaration)
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central file is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2011 API
ControlledApplication..::.FailuresProcessing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic (Declaration)
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using provided restricted failures accessor interface.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2011 API
ControlledApplication..::.FileExported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic (Declaration)
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExporting Event

[image]

Revit 2011 API
ControlledApplication..::.FileExporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic (Declaration)
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImported Event

[image]

Revit 2011 API
ControlledApplication..::.FileImported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic (Declaration)
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2011 API
ControlledApplication..::.FileImporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic (Declaration)
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2011 API
ControlledApplication..::.ViewPrinted Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2011 API
ControlledApplication..::.ViewPrinting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LanguageType Enumeration

[image]

Revit 2011 API
LanguageType Enumeration
See Also Send Feedback
An enumerated type containing the supported Revit product languages.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum LanguageType
Visual Basic (Declaration)
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown | Unknown.
English_USA | English USA.
German | German.
Spanish | Spanish.
French | French.
Italian | Italian.
Dutch | Dutch.
Chinese_Simplified | Chinese simplified.
Chinese_Traditional | Chinese traditional.
Japanese | Japanese.
Korean | Korean.
Russian | Russian.

See Also

Autodesk.Revit.ApplicationServices Namespace


ProductType Enumeration

[image]

Revit 2011 API
ProductType Enumeration
See Also Send Feedback
An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ProductType
Visual Basic (Declaration)
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture | Architecture.
Structure | Structure.
MEP | MEP.
Unknown | Unknown.

See Also

Autodesk.Revit.ApplicationServices Namespace


Autodesk.Revit.Attributes Namespace

[image]

Revit 2011 API
Autodesk.Revit.Attributes Namespace
Send Feedback

Classes

Class | Description
JournalingAttribute | The custom journaling attribute to control the journaling behavior of the external command.
RegenerationAttribute | The custom regeneration attribute to control the regeneration behavior of the external command or external application.
TransactionAttribute | The custom transaction attribute to control the transaction behavior of the external command.

Enumerations

Enumeration | Description
JournalingMode | All journaling modes supported by Revit external commands.
RegenerationOption | All regeneration options supported by Revit external commands and external applications.
TransactionMode | All transaction modes supported by Revit external commands.


JournalingAttribute Class

[image]

Revit 2011 API
JournalingAttribute Class
Members See Also Send Feedback
The custom journaling attribute to control the journaling behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class JournalingAttribute : Attribute
Visual Basic (Declaration)
Public Class JournalingAttribute _
    Inherits Attribute
Visual C++
public ref class JournalingAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Autodesk.Revit.Attributes..::.JournalingAttribute

See Also

JournalingAttribute Members
Autodesk.Revit.Attributes Namespace


JournalingAttribute Members

[image] [image]

Revit 2011 API
JournalingAttribute Members
JournalingAttribute Class Constructors Methods Properties See Also Send Feedback

The JournalingAttribute type exposes the following members.

Constructors

Name | Description
JournalingAttribute | Constructs a new JournalingAttribute.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Mode | Journaling mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Constructor

[image]

Revit 2011 API
JournalingAttribute Constructor
JournalingAttribute Class See Also Send Feedback
Constructs a new JournalingAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public JournalingAttribute(
    JournalingMode mode
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As JournalingMode _
)
Visual C++
public:
JournalingAttribute(
    JournalingMode mode
)

Parameters

mode
Type: Autodesk.Revit.Attributes..::.JournalingMode

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Methods

[image] [image]

Revit 2011 API
JournalingAttribute Methods
JournalingAttribute Class See Also Send Feedback

The JournalingAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Properties

[image] [image]

Revit 2011 API
JournalingAttribute Properties
JournalingAttribute Class See Also Send Feedback

The JournalingAttribute type exposes the following members.

Properties

Name | Description
Mode | Journaling mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


Mode Property

[image]

Revit 2011 API
JournalingAttribute..::.Mode Property
JournalingAttribute Class See Also Send Feedback
Journaling mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public JournalingMode Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As JournalingMode
Visual C++
public:
property JournalingMode Mode {
    JournalingMode get ();
}

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingMode Enumeration

[image]

Revit 2011 API
JournalingMode Enumeration
See Also Send Feedback
All journaling modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum JournalingMode
Visual Basic (Declaration)
Public Enumeration JournalingMode
Visual C++
public enum class JournalingMode

Members

Member name | Description
UsingCommandData | Uses the “StringStringMap” supplied in the command data. Hides all Revit journal entries in between the external command invocation and the StringStringMap entry. Commands which invoke the Revit UI for selection or for responses to task dialogs may not replay correctly.
NoCommandData | Does not write contents of the ExternalCommandData.Data map to the Revit journal. But does allow Revit API calls to write to the journal as needed. This option should allow commands which invoke the Revit UI for selection or for responses to task dialogs to replay correctly.

See Also

Autodesk.Revit.Attributes Namespace


RegenerationAttribute Class

[image]

Revit 2011 API
RegenerationAttribute Class
Members See Also Send Feedback
The custom regeneration attribute to control the regeneration behavior of the external command or external application.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RegenerationAttribute : Attribute
Visual Basic (Declaration)
Public Class RegenerationAttribute _
    Inherits Attribute
Visual C++
public ref class RegenerationAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Autodesk.Revit.Attributes..::.RegenerationAttribute

See Also

RegenerationAttribute Members
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Members

[image] [image]

Revit 2011 API
RegenerationAttribute Members
RegenerationAttribute Class Constructors Methods Properties See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Constructors

Name | Description
RegenerationAttribute | Constructs a new RegenerationAttribute.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Option | Regeneration option.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Constructor

[image]

Revit 2011 API
RegenerationAttribute Constructor
RegenerationAttribute Class See Also Send Feedback
Constructs a new RegenerationAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public RegenerationAttribute(
    RegenerationOption option
)
Visual Basic (Declaration)
Public Sub New ( _
    option As RegenerationOption _
)
Visual C++
public:
RegenerationAttribute(
    RegenerationOption option
)

Parameters

option
Type: Autodesk.Revit.Attributes..::.RegenerationOption

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Methods

[image] [image]

Revit 2011 API
RegenerationAttribute Methods
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Properties

[image] [image]

Revit 2011 API
RegenerationAttribute Properties
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Properties

Name | Description
Option | Regeneration option.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


Option Property

[image]

Revit 2011 API
RegenerationAttribute..::.Option Property
RegenerationAttribute Class See Also Send Feedback
Regeneration option.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public RegenerationOption Option { get; }
Visual Basic (Declaration)
Public ReadOnly Property Option As RegenerationOption
Visual C++
public:
property RegenerationOption Option {
    RegenerationOption get ();
}

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationOption Enumeration

[image]

Revit 2011 API
RegenerationOption Enumeration
See Also Send Feedback
All regeneration options supported by Revit external commands and external applications.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum RegenerationOption
Visual Basic (Declaration)
Public Enumeration RegenerationOption
Visual C++
public enum class RegenerationOption

Members

Member name | Description
Manual | The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.
Automatic | Obsolete. The API framework will regenerate after every model level change (equivalent behavior with Revit 2010 and earlier). Regeneration and update can be suspended using SuspendUpdating for some operations, but in general the performance of multiple modifications within the same file will be slower than RegenerationOption.Manual. This mode is provided for behavioral equivalence with Revit 2010 and earlier; it is obsolete and will be removed in a future release.

See Also

Autodesk.Revit.Attributes Namespace


TransactionAttribute Class

[image]

Revit 2011 API
TransactionAttribute Class
Members See Also Send Feedback
The custom transaction attribute to control the transaction behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TransactionAttribute : Attribute
Visual Basic (Declaration)
Public Class TransactionAttribute _
    Inherits Attribute
Visual C++
public ref class TransactionAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Autodesk.Revit.Attributes..::.TransactionAttribute

See Also

TransactionAttribute Members
Autodesk.Revit.Attributes Namespace


TransactionAttribute Members

[image] [image]

Revit 2011 API
TransactionAttribute Members
TransactionAttribute Class Constructors Methods Properties See Also Send Feedback

The TransactionAttribute type exposes the following members.

Constructors

Name | Description
TransactionAttribute | Constructs a new TransactionAttribute.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Mode | Transaction mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Constructor

[image]

Revit 2011 API
TransactionAttribute Constructor
TransactionAttribute Class See Also Send Feedback
Constructs a new TransactionAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionAttribute(
    TransactionMode mode
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As TransactionMode _
)
Visual C++
public:
TransactionAttribute(
    TransactionMode mode
)

Parameters

mode
Type: Autodesk.Revit.Attributes..::.TransactionMode

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Methods

[image] [image]

Revit 2011 API
TransactionAttribute Methods
TransactionAttribute Class See Also Send Feedback

The TransactionAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Properties

[image] [image]

Revit 2011 API
TransactionAttribute Properties
TransactionAttribute Class See Also Send Feedback

The TransactionAttribute type exposes the following members.

Properties

Name | Description
Mode | Transaction mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


Mode Property

[image]

Revit 2011 API
TransactionAttribute..::.Mode Property
TransactionAttribute Class See Also Send Feedback
Transaction mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionMode Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As TransactionMode
Visual C++
public:
property TransactionMode Mode {
    TransactionMode get ();
}

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionMode Enumeration

[image]

Revit 2011 API
TransactionMode Enumeration
See Also Send Feedback
All transaction modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TransactionMode
Visual Basic (Declaration)
Public Enumeration TransactionMode
Visual C++
public enum class TransactionMode

Members

Member name | Description
Automatic | The API framework will create a transaction on the active document before the external command is executed and the transaction will be committed or rolled back after the command is completed (based upon the return value of the ExternalCommand callback).
Manual | The API framework will not create a transaction (but will create an outer group to roll back all changes if the external command returns a failure status). Instead, you may use combinations of transactions, sub-transactions, and groups. You will have to follow all rules regarding use of transactions and related classes. You will have to give your transactions names, which will then appear in the undo menu. Revit will check that all transactions (also groups and sub-transaction) are properly closed upon return from an external command. If not, it will discard all changes to the model.
ReadOnly | No transaction (nor group) will be created, and no transaction may be created for the lifetime of the command. The External command may use methods that only read from the model, but not methods that write anything to it. Exceptions will be thrown if the command either tries to start a transaction (or group) or attempts to write to the model.

See Also

Autodesk.Revit.Attributes Namespace


Autodesk.Revit.Collections Namespace

[image]

Revit 2011 API
Autodesk.Revit.Collections Namespace
Send Feedback

Classes

Class | Description
Array | An array that can contain any type of object.
ArrayIterator | An iterator to a array.
Map | A map that can contain a mapping of any type of object to any other type of object.
MapIterator | An iterator to a map.
Set | A set that can contain any type of object.
SetIterator | An iterator to a set.
StringStringMap | A map that can contain a mapping of a string to another string.
StringStringMapIterator | An iterator to a string to string map.


Array Class

[image]

Revit 2011 API
Array Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Array : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Array _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Array : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.Array

See Also

Array Members
Autodesk.Revit.Collections Namespace


Array Members

[image] [image]

Revit 2011 API
Array Members
Array Class Constructors Methods Properties See Also Send Feedback

The Array type exposes the following members.

Constructors

Name | Description
Array | Initializes a new instance of the Array class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Constructor

[image]

Revit 2011 API
Array Constructor
Array Class See Also Send Feedback
Initializes a new instance of the Array class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Array()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Array()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Methods

[image] [image]

Revit 2011 API
Array Methods
Array Class See Also Send Feedback

The Array type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Array Class
Autodesk.Revit.Collections Namespace


Append Method

[image]

Revit 2011 API
Array..::.Append Method
Array Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Object item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Object _
)
Visual C++
public:
virtual void Append(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be added.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2011 API
Array..::.Clear Method
Array Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Array Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2011 API
Array..::.ForwardIterator Method
Array Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2011 API
Array..::.GetEnumerator Method
Array Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Array Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2011 API
Array..::.Insert Method
Array Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Object item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Object, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Object^ item,
    int index
)

Parameters

item
Type: System..::.Object
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2011 API
Array..::.ReverseIterator Method
Array Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ArrayIterator
Visual C++
public:
virtual ArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Array Properties

[image] [image]

Revit 2011 API
Array Properties
Array Class See Also Send Feedback

The Array type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

Array Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2011 API
Array..::.IsEmpty Property
Array Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2011 API
Array..::.Item Property
Array Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
virtual property Object^ Item[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

Array Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2011 API
Array..::.Size Property
Array Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Array Class
Autodesk.Revit.Collections Namespace


ArrayIterator Class

[image]

Revit 2011 API
ArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.ArrayIterator

See Also

ArrayIterator Members
Autodesk.Revit.Collections Namespace


ArrayIterator Members

[image] [image]

Revit 2011 API
ArrayIterator Members
ArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ArrayIterator type exposes the following members.

Constructors

Name | Description
ArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Constructor

[image]

Revit 2011 API
ArrayIterator Constructor
ArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Methods

[image] [image]

Revit 2011 API
ArrayIterator Methods
ArrayIterator Class See Also Send Feedback

The ArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2011 API
ArrayIterator..::.MoveNext Method
ArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2011 API
ArrayIterator..::.Reset Method
ArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


ArrayIterator Properties

[image] [image]

Revit 2011 API
ArrayIterator Properties
ArrayIterator Class See Also Send Feedback

The ArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2011 API
ArrayIterator..::.Current Property
ArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ArrayIterator Class
Autodesk.Revit.Collections Namespace


Map Class

[image]

Revit 2011 API
Map Class
Members See Also Send Feedback
A map that can contain a mapping of any type of object to any other type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Map : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Map _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Map : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.Map

See Also

Map Members
Autodesk.Revit.Collections Namespace


Map Members

[image] [image]

Revit 2011 API
Map Members
Map Class Constructors Methods Properties See Also Send Feedback

The Map type exposes the following members.

Constructors

Name | Description
Map | Initializes a new instance of the Map class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Constructor

[image]

Revit 2011 API
Map Constructor
Map Class See Also Send Feedback
Initializes a new instance of the Map class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Map()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Map()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Methods

[image] [image]

Revit 2011 API
Map Methods
Map Class See Also Send Feedback

The Map type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Map Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2011 API
Map..::.Clear Method
Map Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2011 API
Map..::.Contains Method
Map Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
)

Parameters

key
Type: System..::.Object
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2011 API
Map..::.Erase Method
Map Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Object key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Object _
) As Integer
Visual C++
public:
virtual int Erase(
    Object^ key
)

Parameters

key
Type: System..::.Object
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2011 API
Map..::.ForwardIterator Method
Map Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2011 API
Map..::.GetEnumerator Method
Map Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Map Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2011 API
Map..::.Insert Method
Map Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Object key,
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Object, _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Object^ key,
    Object^ item
)

Parameters

key
Type: System..::.Object
The key to be used for inserting the item into the map.
item
Type: System..::.Object
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2011 API
Map..::.ReverseIterator Method
Map Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MapIterator
Visual C++
public:
virtual MapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Map Properties

[image] [image]

Revit 2011 API
Map Properties
Map Class See Also Send Feedback

The Map type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

Map Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2011 API
Map..::.IsEmpty Property
Map Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2011 API
Map..::.Item Property
Map Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Item[
    Object key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Object _
) As Object
Visual C++
public:
virtual property Object^ Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::.Object
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

Map Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2011 API
Map..::.Size Property
Map Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Map Class
Autodesk.Revit.Collections Namespace


MapIterator Class

[image]

Revit 2011 API
MapIterator Class
Members See Also Send Feedback
An iterator to a map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class MapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.MapIterator

See Also

MapIterator Members
Autodesk.Revit.Collections Namespace


MapIterator Members

[image] [image]

Revit 2011 API
MapIterator Members
MapIterator Class Constructors Methods Properties See Also Send Feedback

The MapIterator type exposes the following members.

Constructors

Name | Description
MapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Constructor

[image]

Revit 2011 API
MapIterator Constructor
MapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Methods

[image] [image]

Revit 2011 API
MapIterator Methods
MapIterator Class See Also Send Feedback

The MapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2011 API
MapIterator..::.MoveNext Method
MapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2011 API
MapIterator..::.Reset Method
MapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


MapIterator Properties

[image] [image]

Revit 2011 API
MapIterator Properties
MapIterator Class See Also Send Feedback

The MapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2011 API
MapIterator..::.Current Property
MapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2011 API
MapIterator..::.Key Property
MapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Object
Visual C++
public:
virtual property Object^ Key {
    Object^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

MapIterator Class
Autodesk.Revit.Collections Namespace


Set Class

[image]

Revit 2011 API
Set Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Set : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class Set _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class Set : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.Set

See Also

Set Members
Autodesk.Revit.Collections Namespace


Set Members

[image] [image]

Revit 2011 API
Set Members
Set Class Constructors Methods Properties See Also Send Feedback

The Set type exposes the following members.

Constructors

Name | Description
Set | Initializes a new instance of the Set class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Constructor

[image]

Revit 2011 API
Set Constructor
Set Class See Also Send Feedback
Initializes a new instance of the Set class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Set()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Set()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Methods

[image] [image]

Revit 2011 API
Set Methods
Set Class See Also Send Feedback

The Set type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Set Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2011 API
Set..::.Clear Method
Set Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2011 API
Set..::.Contains Method
Set Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2011 API
Set..::.Erase Method
Set Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Erase(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2011 API
Set..::.ForwardIterator Method
Set Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2011 API
Set..::.GetEnumerator Method
Set Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Set Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2011 API
Set..::.Insert Method
Set Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Object^ item
)

Parameters

item
Type: System..::.Object
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2011 API
Set..::.ReverseIterator Method
Set Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SetIterator
Visual C++
public:
virtual SetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Set Properties

[image] [image]

Revit 2011 API
Set Properties
Set Class See Also Send Feedback

The Set type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

Set Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2011 API
Set..::.IsEmpty Property
Set Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

Set Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2011 API
Set..::.Size Property
Set Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

Set Class
Autodesk.Revit.Collections Namespace


SetIterator Class

[image]

Revit 2011 API
SetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.SetIterator

See Also

SetIterator Members
Autodesk.Revit.Collections Namespace


SetIterator Members

[image] [image]

Revit 2011 API
SetIterator Members
SetIterator Class Constructors Methods Properties See Also Send Feedback

The SetIterator type exposes the following members.

Constructors

Name | Description
SetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Constructor

[image]

Revit 2011 API
SetIterator Constructor
SetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Methods

[image] [image]

Revit 2011 API
SetIterator Methods
SetIterator Class See Also Send Feedback

The SetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2011 API
SetIterator..::.MoveNext Method
SetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2011 API
SetIterator..::.Reset Method
SetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


SetIterator Properties

[image] [image]

Revit 2011 API
SetIterator Properties
SetIterator Class See Also Send Feedback

The SetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2011 API
SetIterator..::.Current Property
SetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SetIterator Class
Autodesk.Revit.Collections Namespace


StringStringMap Class

[image]

Revit 2011 API
StringStringMap Class
Members See Also Send Feedback
A map that can contain a mapping of a string to another string.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class StringStringMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class StringStringMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class StringStringMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.StringStringMap

See Also

StringStringMap Members
Autodesk.Revit.Collections Namespace


StringStringMap Members

[image] [image]

Revit 2011 API
StringStringMap Members
StringStringMap Class Constructors Methods Properties See Also Send Feedback

The StringStringMap type exposes the following members.

Constructors

Name | Description
StringStringMap | Initializes a new instance of the StringStringMap class

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a string item at a specified string key within the map.
Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Constructor

[image]

Revit 2011 API
StringStringMap Constructor
StringStringMap Class See Also Send Feedback
Initializes a new instance of the StringStringMap class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMap()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Methods

[image] [image]

Revit 2011 API
StringStringMap Methods
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Methods

Name | Description
Clear | Removes every string from the map, rendering it empty.
Contains | Tests for the existence of a string key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes an item with the specified string key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2011 API
StringStringMap..::.Clear Method
StringStringMap Class See Also Send Feedback
Removes every string from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2011 API
StringStringMap..::.Contains Method
StringStringMap Class See Also Send Feedback
Tests for the existence of a string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The key to be searched for.

Return Value

The Contains method returns True if the string key is within the map, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2011 API
StringStringMap..::.Erase Method
StringStringMap Class See Also Send Feedback
Removes an item with the specified string key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The string key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2011 API
StringStringMap..::.ForwardIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual StringStringMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2011 API
StringStringMap..::.GetEnumerator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2011 API
StringStringMap..::.Insert Method
StringStringMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    string item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As String _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    String^ item
)

Parameters

key
Type: System..::.String
The key to be used for inserting the item into the map.
item
Type: System..::.String
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2011 API
StringStringMap..::.ReverseIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual StringStringMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Properties

[image] [image]

Revit 2011 API
StringStringMap Properties
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a string item at a specified string key within the map.
Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2011 API
StringStringMap..::.IsEmpty Property
StringStringMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2011 API
StringStringMap..::.Item Property
StringStringMap Class See Also Send Feedback
Gets or sets a string item at a specified string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As String
Visual C++
public:
virtual property String^ Item[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::.String
The string key of the string item to be set or retrieved.

Return Value

Returns the string item at the specified string key.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2011 API
StringStringMap..::.Size Property
StringStringMap Class See Also Send Feedback
Returns the number of strings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Class

[image]

Revit 2011 API
StringStringMapIterator Class
Members See Also Send Feedback
An iterator to a string to string map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class StringStringMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class StringStringMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class StringStringMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.StringStringMapIterator

See Also

StringStringMapIterator Members
Autodesk.Revit.Collections Namespace


StringStringMapIterator Members

[image] [image]

Revit 2011 API
StringStringMapIterator Members
StringStringMapIterator Class Constructors Methods Properties See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Constructors

Name | Description
StringStringMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the string item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Constructor

[image]

Revit 2011 API
StringStringMapIterator Constructor
StringStringMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringStringMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Methods

[image] [image]

Revit 2011 API
StringStringMapIterator Methods
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2011 API
StringStringMapIterator..::.MoveNext Method
StringStringMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2011 API
StringStringMapIterator..::.Reset Method
StringStringMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Properties

[image] [image]

Revit 2011 API
StringStringMapIterator Properties
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the string item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2011 API
StringStringMapIterator..::.Current Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2011 API
StringStringMapIterator..::.Key Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Autodesk.Revit.Creation Namespace

[image]

Revit 2011 API
Autodesk.Revit.Creation Namespace
Send Feedback

Classes

Class | Description
Application | The Application Creation object is used to create new instances of utility objects.
AreaCreationData | A class which wraps the arguments of Area for batch creation
Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
FamilyItemFactory | The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
ItemFactoryBase | The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
ProfiledWallCreationData | A class which wraps the arguments of Wall for batch creation
RectangularWallCreationData | A class which wraps the arguments of Wall for batch creation
RoomCreationData | A class which wraps the arguments of Room for batch creation.
TextNoteCreationData | A class which wraps the arguments of TextNote for batch creation

Enumerations

Enumeration | Description
eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.


Application Class

[image]

Revit 2011 API
Application Class
Members See Also Send Feedback
The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic (Declaration)
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.Application

See Also

Application Members
Autodesk.Revit.Creation Namespace


Application Members

[image] [image]

Revit 2011 API
Application Members
Application Class Methods Properties See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewArc | Overloaded. Creates a new geometric arc object.
NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
NewArray | Creates a new instance of a generic Array.
NewBoundingBoxUV | Overloaded. Creates a two-dimensional rectangle.
NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
NewBuildingSiteExportOptions | Creates Building Site Export options.
NewCategorySet | Creates a new instance of a set specifically for holding category objects.
NewColor | Returns a new color object.
NewCombinableElementArray | Returns an array that can hold combinable element objects.
NewCurveArrArray | Creates an empty array that can store geometric curve loops.
NewCurveArray | Creates an empty array that can store geometric curves.
NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
NewDGNExportOptions | Creates DGN Export options.
NewDoubleArray | Creates a new instance of a double array.
NewDWFExportOptions | Creates DWF Export options.
NewDWFXExportOptions | Creates DWFX Export options.
NewDWGExportOptions | Creates DWG Export options.
NewDWGImportOptions | Creates DWG Import options.
NewDXFExportOptions | Creates DXF Export options.
NewElementArray | Returns an array that can hold element objects.
NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
NewElementSet | Creates a new instance of a set specifically for holding elements.
NewEllipse | Creates a new geometric ellipse object.
NewFaceArray | Creates a new instance of a face array.
NewFamilyInstanceCreationData | Overloaded. Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
NewFillPatternSet | Returns a set that can hold fill pattern objects.
NewGBXMLExportOptions | Creates Green-Building XML Export options.
NewGBXMLImportOptions | Creates Green-Building XML Import options.
NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
NewHermiteSpline | Creates a new geometric Hermite spline object.
NewImageImportOptions | Creates Image Import options.
NewInstanceBinding | Overloaded. Creates a new instance binding object.
NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
NewInventorImportOptions | Creates Inventor Import options.
NewLine | Creates a new bound or unbounded geometric line object.
NewLineBound | Creates a new bounded geometric line object.
NewLinePatternSet | Returns a set that can hold line pattern objects.
NewLineUnbound | Creates a new unbounded geometric line object.
NewLoadCaseArray | Creates a new instance of a LoadCase array.
NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
NewLoadUsageArray | Creates a new instance of a LoadUsage array.
NewMap | Creates a new instance of a generic Map.
NewMaterialSet | Create a new instance of MaterialSet.
NewNurbSpline | Creates a new geometric nurbSpline object.
NewPlane | Overloaded. Creates a new geometric plane object.
NewPoint | Creates a new geometric point object.
NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
NewProfiledWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewProjectPosition | Creates a new project position object.
NewRectangularWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewReferenceArray | Creates a new instance of a reference array.
NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
NewSATExportOptions | Creates SAT Export options.
NewSet | Creates a new instance of a generic Set.
NewSpaceSet | Creates a new instance of a space set.
NewStringStringMap | Creates a new map that maps one string to another string.
NewSuspendUpdating | Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.
NewTextNoteCreationData | Overloaded. Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTypeBinding | Overloaded. Creates a new type binding object.
NewUV | Overloaded. Creates a UV object representing coordinates in 2-space.
NewVertexIndexPair | Creates a new VertexIndexPair object.
NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
NewViewSet | Creates a new instance of a View set.
NewVolumeCalculationOptions | Creates options related to room volume and area computations.
NewXYZ | Overloaded. Creates a XYZ object representing coordinates in 3-space.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Methods

[image] [image]

Revit 2011 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewArc | Overloaded. Creates a new geometric arc object.
NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
NewArray | Creates a new instance of a generic Array.
NewBoundingBoxUV | Overloaded. Creates a two-dimensional rectangle.
NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
NewBuildingSiteExportOptions | Creates Building Site Export options.
NewCategorySet | Creates a new instance of a set specifically for holding category objects.
NewColor | Returns a new color object.
NewCombinableElementArray | Returns an array that can hold combinable element objects.
NewCurveArrArray | Creates an empty array that can store geometric curve loops.
NewCurveArray | Creates an empty array that can store geometric curves.
NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
NewDGNExportOptions | Creates DGN Export options.
NewDoubleArray | Creates a new instance of a double array.
NewDWFExportOptions | Creates DWF Export options.
NewDWFXExportOptions | Creates DWFX Export options.
NewDWGExportOptions | Creates DWG Export options.
NewDWGImportOptions | Creates DWG Import options.
NewDXFExportOptions | Creates DXF Export options.
NewElementArray | Returns an array that can hold element objects.
NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
NewElementSet | Creates a new instance of a set specifically for holding elements.
NewEllipse | Creates a new geometric ellipse object.
NewFaceArray | Creates a new instance of a face array.
NewFamilyInstanceCreationData | Overloaded. Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
NewFillPatternSet | Returns a set that can hold fill pattern objects.
NewGBXMLExportOptions | Creates Green-Building XML Export options.
NewGBXMLImportOptions | Creates Green-Building XML Import options.
NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
NewHermiteSpline | Creates a new geometric Hermite spline object.
NewImageImportOptions | Creates Image Import options.
NewInstanceBinding | Overloaded. Creates a new instance binding object.
NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
NewInventorImportOptions | Creates Inventor Import options.
NewLine | Creates a new bound or unbounded geometric line object.
NewLineBound | Creates a new bounded geometric line object.
NewLinePatternSet | Returns a set that can hold line pattern objects.
NewLineUnbound | Creates a new unbounded geometric line object.
NewLoadCaseArray | Creates a new instance of a LoadCase array.
NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
NewLoadUsageArray | Creates a new instance of a LoadUsage array.
NewMap | Creates a new instance of a generic Map.
NewMaterialSet | Create a new instance of MaterialSet.
NewNurbSpline | Creates a new geometric nurbSpline object.
NewPlane | Overloaded. Creates a new geometric plane object.
NewPoint | Creates a new geometric point object.
NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
NewProfiledWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewProjectPosition | Creates a new project position object.
NewRectangularWallCreationData | Overloaded. Creates an object which wraps the arguments of NewWall() for batch creation.
NewReferenceArray | Creates a new instance of a reference array.
NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
NewSATExportOptions | Creates SAT Export options.
NewSet | Creates a new instance of a generic Set.
NewSpaceSet | Creates a new instance of a space set.
NewStringStringMap | Creates a new map that maps one string to another string.
NewSuspendUpdating | Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.
NewTextNoteCreationData | Overloaded. Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTypeBinding | Overloaded. Creates a new type binding object.
NewUV | Overloaded. Creates a UV object representing coordinates in 2-space.
NewVertexIndexPair | Creates a new VertexIndexPair object.
NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
NewViewSet | Creates a new instance of a View set.
NewVolumeCalculationOptions | Creates options related to room volume and area computations.
NewXYZ | Overloaded. Creates a XYZ object representing coordinates in 3-space.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArc Method

[image] [image]

Revit 2011 API
Application..::.NewArc Method
Application Class See Also Send Feedback
Creates a new geometric arc object.

Overload List

Name | Description
NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, XYZ, XYZ)

[image]

Revit 2011 API
Application..::.NewArc Method (XYZ, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic (Declaration)
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
Type: Autodesk.Revit.DB..::.XYZ
The start point of the arc.
end1
Type: Autodesk.Revit.DB..::.XYZ
The end point of the arc.
pointOnCurve
Type: Autodesk.Revit.DB..::.XYZ
A point on the arc.

Remarks

Examples

CopyC#
// Create a new arc using two ends and a point on the curve
XYZ end0 = new XYZ(1, 0, 0);    // start point of the arc
XYZ end1 = new XYZ(10, 10, 10); // end point of the arc
XYZ pointOnCurve = new XYZ(10, 0, 0);   // point along arc

Arc arc = application.Create.NewArc(end0, end1, pointOnCurve);
CopyVB.NET
' Create a new arc using two ends and a point on the curve
Dim end0 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' start point of the arc
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 10, 10)
' end point of the arc
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(10, 0, 0)
' point along arc
Dim arc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (Plane, Double, Double, Double)

[image]

Revit 2011 API
Application..::.NewArc Method (Plane, Double, Double, Double)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc(
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Type: Autodesk.Revit.DB..::.Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Type: System..::.Double
startAngle
Type: System..::.Double
The start angle of the arc (in radians).
endAngle
Type: System..::.Double
The end angle of the arc (in radians).

Remarks

Examples

CopyC#
Arc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
    // Create an arc which is placed on the plane and whose center is the plane's origin
    double radius = 10;
    double startAngle = 0;      // The unit is radian
    double endAngle = 2 * Math.PI;        // this arc will be a circle
    return application.Create.NewArc(plane, radius, startAngle, endAngle);
}
CopyVB.NET
Function CreateArcByGivingPlane(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal plane As Plane) As Arc
    ' Create an arc which is placed on the plane and whose center is the plane's origin
    Dim radius As Double = 10
    Dim startAngle As Double = 0
    ' The unit is radian
    Dim endAngle As Double = 2 * Math.PI
    ' this arc will be a circle
    Return application.Create.NewArc(plane, radius, startAngle, endAngle)
End Function

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)

[image]

Revit 2011 API
Application..::.NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic (Declaration)
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
Type: Autodesk.Revit.DB..::.XYZ
The center of the arc.
radius
Type: System..::.Double
The radius of the arc.
startAngle
Type: System..::.Double
The start angle of the arc (in radians).
endAngle
Type: System..::.Double
The end angle of the arc (in radians).
xAxis
Type: Autodesk.Revit.DB..::.XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
Type: Autodesk.Revit.DB..::.XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

Examples

CopyC#
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis);
CopyVB.NET
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New Autodesk.Revit.DB.XYZ(5, 0, 0)
Dim xAxis As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New Autodesk.Revit.DB.XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc As Arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewAreaCreationData Method

[image]

Revit 2011 API
Application..::.NewAreaCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::.UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArray Method

[image]

Revit 2011 API
Application..::.NewArray Method
Application Class See Also Send Feedback
Creates a new instance of a generic Array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Array NewArray()
Visual Basic (Declaration)
Public Function NewArray As Array
Visual C++
public:
Array^ NewArray()

Return Value

A new instance of a generic Array.

Remarks

Generic arrays can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image] [image]

Revit 2011 API
Application..::.NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates a two-dimensional rectangle.

Overload List

Name | Description
NewBoundingBoxUV()()() | Creates an empty two-dimensional rectangle.
NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image]

Revit 2011 API
Application..::.NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates an empty two-dimensional rectangle.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV()
Visual Basic (Declaration)
Public Function NewBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV()

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method (Double, Double, Double, Double)

[image]

Revit 2011 API
Application..::.NewBoundingBoxUV Method (Double, Double, Double, Double)
Application Class See Also Send Feedback
Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Function NewBoundingBoxUV ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::.Double
The first coordinate of min.
min_v
Type: System..::.Double
The second coordinate of min.
max_u
Type: System..::.Double
The first coordinate of max.
max_v
Type: System..::.Double
The second coordinate of max.

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxXYZ Method

[image]

Revit 2011 API
Application..::.NewBoundingBoxXYZ Method
Application Class See Also Send Feedback
Creates a three-dimensional rectangular box.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ NewBoundingBoxXYZ()
Visual Basic (Declaration)
Public Function NewBoundingBoxXYZ As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ NewBoundingBoxXYZ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBuildingSiteExportOptions Method

[image]

Revit 2011 API
Application..::.NewBuildingSiteExportOptions Method
Application Class See Also Send Feedback
Creates Building Site Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BuildingSiteExportOptions NewBuildingSiteExportOptions()
Visual Basic (Declaration)
Public Function NewBuildingSiteExportOptions As BuildingSiteExportOptions
Visual C++
public:
BuildingSiteExportOptions^ NewBuildingSiteExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCategorySet Method

[image]

Revit 2011 API
Application..::.NewCategorySet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategorySet NewCategorySet()
Visual Basic (Declaration)
Public Function NewCategorySet As CategorySet
Visual C++
public:
CategorySet^ NewCategorySet()

Return Value

A new instance of a Category Set.

Remarks

This type of set is used during the creation of instance and type bindings.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewColor Method

[image]

Revit 2011 API
Application..::.NewColor Method
Application Class Example See Also Send Feedback
Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color NewColor()
Visual Basic (Declaration)
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor()

Return Value

The new color object.

Examples

CopyC#
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.DB.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    TaskDialog.Show("Revit",info.ToString());

    return color;
}
CopyVB.NET
Function NewColorInfo(ByVal appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.DB.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab + color.Red.ToString())
    info.AppendLine("Green:" & vbTab + color.Green.ToString())
    info.AppendLine("Blue:" & vbTab + color.Blue.ToString())

    TaskDialog.Show("Revit", info.ToString())

    Return color
End Function

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCombinableElementArray Method

[image]

Revit 2011 API
Application..::.NewCombinableElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold combinable element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CombinableElementArray NewCombinableElementArray()
Visual Basic (Declaration)
Public Function NewCombinableElementArray As CombinableElementArray
Visual C++
public:
CombinableElementArray^ NewCombinableElementArray()

Return Value

An empty array that can contain any CombinableElement derived objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArrArray Method

[image]

Revit 2011 API
Application..::.NewCurveArrArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curve loops.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray NewCurveArrArray()
Visual Basic (Declaration)
Public Function NewCurveArrArray As CurveArrArray
Visual C++
public:
CurveArrArray^ NewCurveArrArray()

Return Value

The empty array of curve loops.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArray Method

[image]

Revit 2011 API
Application..::.NewCurveArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray NewCurveArray()
Visual Basic (Declaration)
Public Function NewCurveArray As CurveArray
Visual C++
public:
CurveArray^ NewCurveArray()

Return Value

An empty array that can hold geometric curves.

Remarks

This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveLoopsProfile Method

[image]

Revit 2011 API
Application..::.NewCurveLoopsProfile Method
Application Class See Also Send Feedback
Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Visual Basic (Declaration)
Public Function NewCurveLoopsProfile ( _
    curveLoops As CurveArrArray _
) As CurveLoopsProfile
Visual C++
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)

Parameters

curveLoops
Type: Autodesk.Revit.DB..::.CurveArrArray
The curve loops of the Profile.

Return Value

The new CurveLoopsProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDGNExportOptions Method

[image]

Revit 2011 API
Application..::.NewDGNExportOptions Method
Application Class See Also Send Feedback
Creates DGN Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DGNExportOptions NewDGNExportOptions()
Visual Basic (Declaration)
Public Function NewDGNExportOptions As DGNExportOptions
Visual C++
public:
DGNExportOptions^ NewDGNExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDoubleArray Method

[image]

Revit 2011 API
Application..::.NewDoubleArray Method
Application Class See Also Send Feedback
Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray NewDoubleArray()
Visual Basic (Declaration)
Public Function NewDoubleArray As DoubleArray
Visual C++
public:
DoubleArray^ NewDoubleArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFExportOptions Method

[image]

Revit 2011 API
Application..::.NewDWFExportOptions Method
Application Class See Also Send Feedback
Creates DWF Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFExportOptions NewDWFExportOptions()
Visual Basic (Declaration)
Public Function NewDWFExportOptions As DWFExportOptions
Visual C++
public:
DWFExportOptions^ NewDWFExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFXExportOptions Method

[image]

Revit 2011 API
Application..::.NewDWFXExportOptions Method
Application Class See Also Send Feedback
Creates DWFX Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFXExportOptions NewDWFXExportOptions()
Visual Basic (Declaration)
Public Function NewDWFXExportOptions As DWFXExportOptions
Visual C++
public:
DWFXExportOptions^ NewDWFXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWGExportOptions Method

[image]

Revit 2011 API
Application..::.NewDWGExportOptions Method
Application Class See Also Send Feedback
Creates DWG Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWGExportOptions NewDWGExportOptions()
Visual Basic (Declaration)
Public Function NewDWGExportOptions As DWGExportOptions
Visual C++
public:
DWGExportOptions^ NewDWGExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWGImportOptions Method

[image]

Revit 2011 API
Application..::.NewDWGImportOptions Method
Application Class See Also Send Feedback
Creates DWG Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWGImportOptions NewDWGImportOptions()
Visual Basic (Declaration)
Public Function NewDWGImportOptions As DWGImportOptions
Visual C++
public:
DWGImportOptions^ NewDWGImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDXFExportOptions Method

[image]

Revit 2011 API
Application..::.NewDXFExportOptions Method
Application Class See Also Send Feedback
Creates DXF Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DXFExportOptions NewDXFExportOptions()
Visual Basic (Declaration)
Public Function NewDXFExportOptions As DXFExportOptions
Visual C++
public:
DXFExportOptions^ NewDXFExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementArray Method

[image]

Revit 2011 API
Application..::.NewElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray NewElementArray()
Visual Basic (Declaration)
Public Function NewElementArray As ElementArray
Visual C++
public:
ElementArray^ NewElementArray()

Return Value

An empty array that can contain any Autodesk Revit element derived objects.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered lists of any type of element.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementId Method

[image]

Revit 2011 API
Application..::.NewElementId Method
Application Class See Also Send Feedback
Creates a new Autodesk::Revit::DB::ElementId^ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId NewElementId()
Visual Basic (Declaration)
Public Function NewElementId As ElementId
Visual C++
public:
ElementId^ NewElementId()

Return Value

The new Autodesk::Revit::DB::ElementId^ object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementSet Method

[image]

Revit 2011 API
Application..::.NewElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewElementSet()
Visual Basic (Declaration)
Public Function NewElementSet As ElementSet
Visual C++
public:
ElementSet^ NewElementSet()

Return Value

A new Element Set.

Remarks

This is a general purpose set for passing elements to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewEllipse Method

[image]

Revit 2011 API
Application..::.NewEllipse Method
Application Class See Also Send Feedback
Creates a new geometric ellipse object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Ellipse NewEllipse(
    XYZ center,
    double radX,
    double radY,
    XYZ xVec,
    XYZ yVec,
    double param0,
    double param1
)
Visual Basic (Declaration)
Public Function NewEllipse ( _
    center As XYZ, _
    radX As Double, _
    radY As Double, _
    xVec As XYZ, _
    yVec As XYZ, _
    param0 As Double, _
    param1 As Double _
) As Ellipse
Visual C++
public:
Ellipse^ NewEllipse(
    XYZ^ center,
    double radX,
    double radY,
    XYZ^ xVec,
    XYZ^ yVec,
    double param0,
    double param1
)

Parameters

center
Type: Autodesk.Revit.DB..::.XYZ
The center of the ellipse.
radX
Type: System..::.Double
The x vector radius of the ellipse. Should be > 0.
radY
Type: System..::.Double
The y vector radius of the ellipse. Should be > 0.
xVec
Type: Autodesk.Revit.DB..::.XYZ
The x axis to define the ellipse plane.
yVec
Type: Autodesk.Revit.DB..::.XYZ
The y axis to define the ellipse plane. xVec must be orthogonal with yVec.
param0
Type: System..::.Double
The raw parameter value at the start of the ellipse. Should be greater than or equal to -2PI and less than Param1.
param1
Type: System..::.Double
The raw parameter value at the end of the ellipse. Should be greater than Param0 and less than or equal to 2*PI.

Remarks

PI represents the value used in Revit internal code: 3.14159265358979.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFaceArray Method

[image]

Revit 2011 API
Application..::.NewFaceArray Method
Application Class See Also Send Feedback
Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FaceArray NewFaceArray()
Visual Basic (Declaration)
Public Function NewFaceArray As FaceArray
Visual C++
public:
FaceArray^ NewFaceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method

[image] [image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Overload List

Name | Description
NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
Specify if the family instance is structural.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the family instance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2011 API
Application..::.NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilySymbolProfile Method

[image]

Revit 2011 API
Application..::.NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::.FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument fmailySymbol is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFBXExportOptions Method

[image]

Revit 2011 API
Application..::.NewFBXExportOptions Method
Application Class See Also Send Feedback
Creates 3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FBXExportOptions NewFBXExportOptions()
Visual Basic (Declaration)
Public Function NewFBXExportOptions As FBXExportOptions
Visual C++
public:
FBXExportOptions^ NewFBXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFillPatternSet Method

[image]

Revit 2011 API
Application..::.NewFillPatternSet Method
Application Class See Also Send Feedback
Returns a set that can hold fill pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPatternSet NewFillPatternSet()
Visual Basic (Declaration)
Public Function NewFillPatternSet As FillPatternSet
Visual C++
public:
FillPatternSet^ NewFillPatternSet()

Return Value

An empty set that can contain fill pattern objects.

Remarks

The set returned by this method can be used as a container for holding fill patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLExportOptions Method

[image]

Revit 2011 API
Application..::.NewGBXMLExportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GBXMLExportOptions NewGBXMLExportOptions()
Visual Basic (Declaration)
Public Function NewGBXMLExportOptions As GBXMLExportOptions
Visual C++
public:
GBXMLExportOptions^ NewGBXMLExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLImportOptions Method

[image]

Revit 2011 API
Application..::.NewGBXMLImportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GBXMLImportOptions NewGBXMLImportOptions()
Visual Basic (Declaration)
Public Function NewGBXMLImportOptions As GBXMLImportOptions
Visual C++
public:
GBXMLImportOptions^ NewGBXMLImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGeometryOptions Method

[image]

Revit 2011 API
Application..::.NewGeometryOptions Method
Application Class Example See Also Send Feedback
Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Options NewGeometryOptions()
Visual Basic (Declaration)
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions()

Return Value

Examples

CopyC#
Autodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.DB.DetailLevels.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.");
}
CopyVB.NET
Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.DB.DetailLevels.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewHermiteSpline Method

[image]

Revit 2011 API
Application..::.NewHermiteSpline Method
Application Class See Also Send Feedback
Creates a new geometric Hermite spline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    IList<XYZ> ctrlPoints,
    bool bPeriodic
)
Visual Basic (Declaration)
Public Function NewHermiteSpline ( _
    ctrlPoints As IList(Of XYZ), _
    bPeriodic As Boolean _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    IList<XYZ^>^ ctrlPoints,
    bool bPeriodic
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The control points of the Hermite spline.
bPeriodic
Type: System..::.Boolean
True if the Hermite spline is to be periodic.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewImageImportOptions Method

[image]

Revit 2011 API
Application..::.NewImageImportOptions Method
Application Class See Also Send Feedback
Creates Image Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageImportOptions NewImageImportOptions()
Visual Basic (Declaration)
Public Function NewImageImportOptions As ImageImportOptions
Visual C++
public:
ImageImportOptions^ NewImageImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image] [image]

Revit 2011 API
Application..::.NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new instance binding object.

Overload List

Name | Description
NewInstanceBinding()()() | Creates a new empty instance binding object.
NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image]

Revit 2011 API
Application..::.NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic (Declaration)
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding()

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method (CategorySet)

[image]

Revit 2011 API
Application..::.NewInstanceBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::.CategorySet
A set of categories that will be added to the binding.

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewIntersectionResultArray Method

[image]

Revit 2011 API
Application..::.NewIntersectionResultArray Method
Application Class See Also Send Feedback
Creates a new instance of an IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResultArray NewIntersectionResultArray()
Visual Basic (Declaration)
Public Function NewIntersectionResultArray As IntersectionResultArray
Visual C++
public:
IntersectionResultArray^ NewIntersectionResultArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInventorImportOptions Method

[image]

Revit 2011 API
Application..::.NewInventorImportOptions Method
Application Class See Also Send Feedback
Creates Inventor Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InventorImportOptions NewInventorImportOptions()
Visual Basic (Declaration)
Public Function NewInventorImportOptions As InventorImportOptions
Visual C++
public:
InventorImportOptions^ NewInventorImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLine Method

[image]

Revit 2011 API
Application..::.NewLine Method
Application Class Example See Also Send Feedback
Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic (Declaration)
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine(
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
A start point or a point through which the line will pass.
endOrDirection
Type: Autodesk.Revit.DB..::.XYZ
An end point of a vector for the direction of the line.
bound
Type: System..::.Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

A new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

Examples

CopyC#
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// Create unbound line
Line line1 = application.Create.NewLine(startPoint, endPoint, false);

// Create bound line
Line line2 = application.Create.NewLine(startPoint, endPoint, true);
CopyVB.NET
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' Create unbound line
Dim line1 As Line = application.Create.NewLine(startPoint, endPoint, False)

' Create bound line
Dim line2 As Line = application.Create.NewLine(startPoint, endPoint, True)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineBound Method

[image]

Revit 2011 API
Application..::.NewLineBound Method
Application Class Example See Also Send Feedback
Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic (Declaration)
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound(
    XYZ^ start,
    XYZ^ end
)

Parameters

start
Type: Autodesk.Revit.DB..::.XYZ
A start point for the line.
end
Type: Autodesk.Revit.DB..::.XYZ
An end point for the line.

Return Value

A new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

Examples

CopyC#
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineBound(startPoint, endPoint);
CopyVB.NET
' define start and end for bound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineBound(startPoint, endPoint)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLinePatternSet Method

[image]

Revit 2011 API
Application..::.NewLinePatternSet Method
Application Class See Also Send Feedback
Returns a set that can hold line pattern objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePatternSet NewLinePatternSet()
Visual Basic (Declaration)
Public Function NewLinePatternSet As LinePatternSet
Visual C++
public:
LinePatternSet^ NewLinePatternSet()

Return Value

An empty set that can contain line pattern objects.

Remarks

The set returned by this method can be used as a container for holding line patterns.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineUnbound Method

[image]

Revit 2011 API
Application..::.NewLineUnbound Method
Application Class Example See Also Send Feedback
Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound(
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
A point through which the line will pass.
direction
Type: Autodesk.Revit.DB..::.XYZ
A vector for the direction of the line.

Return Value

A new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

Examples

CopyC#
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineUnbound(startPoint, directionPt);
CopyVB.NET
' define start point and direction for unbound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim directionPt As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineUnbound(startPoint, directionPt)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCaseArray Method

[image]

Revit 2011 API
Application..::.NewLoadCaseArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCase array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCaseArray NewLoadCaseArray()
Visual Basic (Declaration)
Public Function NewLoadCaseArray As LoadCaseArray
Visual C++
public:
LoadCaseArray^ NewLoadCaseArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCombinationArray Method

[image]

Revit 2011 API
Application..::.NewLoadCombinationArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCombination array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCombinationArray NewLoadCombinationArray()
Visual Basic (Declaration)
Public Function NewLoadCombinationArray As LoadCombinationArray
Visual C++
public:
LoadCombinationArray^ NewLoadCombinationArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadUsageArray Method

[image]

Revit 2011 API
Application..::.NewLoadUsageArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadUsage array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadUsageArray NewLoadUsageArray()
Visual Basic (Declaration)
Public Function NewLoadUsageArray As LoadUsageArray
Visual C++
public:
LoadUsageArray^ NewLoadUsageArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMap Method

[image]

Revit 2011 API
Application..::.NewMap Method
Application Class See Also Send Feedback
Creates a new instance of a generic Map.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Map NewMap()
Visual Basic (Declaration)
Public Function NewMap As Map
Visual C++
public:
Map^ NewMap()

Return Value

A new instance of a generic Map.

Remarks

Generic maps can link any type of object to any other type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMaterialSet Method

[image]

Revit 2011 API
Application..::.NewMaterialSet Method
Application Class See Also Send Feedback
Create a new instance of MaterialSet.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialSet NewMaterialSet()
Visual Basic (Declaration)
Public Function NewMaterialSet As MaterialSet
Visual C++
public:
MaterialSet^ NewMaterialSet()

Return Value

The newly created MaterialSet instance.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewNurbSpline Method

[image]

Revit 2011 API
Application..::.NewNurbSpline Method
Application Class See Also Send Feedback
Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    IList<XYZ> ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic (Declaration)
Public Function NewNurbSpline ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The control points of the nurbSpline.
weights
Type: Autodesk.Revit.DB..::.DoubleArray
The weights of the nurbSpline.
knots
Type: Autodesk.Revit.DB..::.DoubleArray
The knots of the nurbSpline.
nDegree
Type: System..::.Int32
The degree of the nurbSpline.
bClosed
Type: System..::.Boolean
The nurbSpline is closed or not.
bRational
Type: System..::.Boolean
The nurbSpline is rational or no rational.

Remarks

If bRational is true,the size of ctrlPoints must equal to weights's,otherwise throw ArgumentException. There is a rule like that the size of knots equals to the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPlane Method

[image] [image]

Revit 2011 API
Application..::.NewPlane Method
Application Class See Also Send Feedback
Creates a new geometric plane object.

Overload List

Name | Description
NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewPlane Method (CurveArray)

[image]

Revit 2011 API
Application..::.NewPlane Method (CurveArray)
Application Class See Also Send Feedback
Creates a new geometric plane from a loop of planar curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane NewPlane(
    CurveArray curveloop
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    curveloop As CurveArray _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    CurveArray^ curveloop
)

Parameters

curveloop
Type: Autodesk.Revit.DB..::.CurveArray
The closed loop of planar curves to locate plane.

Return Value

If successful a new geometric plane will be returned. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input curve loop is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input curve loop does not lie in a plane.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input curve loop is not closed.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ)

[image]

Revit 2011 API
Application..::.NewPlane Method (XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric plane object based on a normal vector and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.DB..::.XYZ
Z vector of the plane coordinate system.
origin
Type: Autodesk.Revit.DB..::.XYZ
Origin of the plane coordinate system.

Return Value

A new plane object.

Examples

CopyC#
 // Create a geometry plane in Revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
 Plane geomPlane = application.Create.NewPlane(normal, origin);
CopyVB.NET
' Create a geometry plane in Revit application
Dim normal As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.BasisZ
' use basis of the z-axis (0,0,1) for normal vector
Dim origin As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
' origin is (0,0,0)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ, XYZ)

[image]

Revit 2011 API
Application..::.NewPlane Method (XYZ, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a new geometric plane object based on two coordinate vectors and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.DB..::.XYZ
X vector of the plane coordinate system.
yVec
Type: Autodesk.Revit.DB..::.XYZ
Y vector of the plane coordinate system.
origin
Type: Autodesk.Revit.DB..::.XYZ
Origin of the plane coordinate system.

Return Value

A new plane object.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPoint Method

[image]

Revit 2011 API
Application..::.NewPoint Method
Application Class See Also Send Feedback
Creates a new geometric point object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Point NewPoint(
    XYZ coord
)
Visual Basic (Declaration)
Public Function NewPoint ( _
    coord As XYZ _
) As Point
Visual C++
public:
Point^ NewPoint(
    XYZ^ coord
)

Parameters

coord
Type: Autodesk.Revit.DB..::.XYZ
The coordinates of the point.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdge Method

[image]

Revit 2011 API
Application..::.NewPointOnEdge Method
Application Class See Also Send Feedback
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    double edgeParam
)
Visual Basic (Declaration)
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    edgeParam As Double _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    double edgeParam
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The reference whose edge the object will be created on.
edgeParam
Type: System..::.Double
The parameter on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument edgeReference is nullNothingnullptra null reference (Nothing in Visual Basic) or edgeParam is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeEdgeIntersection Method

[image]

Revit 2011 API
Application..::.NewPointOnEdgeEdgeIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
    Reference edgeReference1,
    Reference edgeReference2
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeEdgeIntersection ( _
    edgeReference1 As Reference, _
    edgeReference2 As Reference _
) As PointOnEdgeEdgeIntersection
Visual C++
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
    Reference^ edgeReference1,
    Reference^ edgeReference2
)

Parameters

edgeReference1
Type: Autodesk.Revit.DB..::.Reference
The first edge reference.
edgeReference2
Type: Autodesk.Revit.DB..::.Reference
The second edge reference.

Return Value

A new PointOnEdgeEdgeIntersection object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument edgeReference1 or edgeReference2 is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeFaceIntersection Method

[image]

Revit 2011 API
Application..::.NewPointOnEdgeFaceIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Visual Basic (Declaration)
Public Function NewPointOnEdgeFaceIntersection ( _
    edgeReference As Reference, _
    faceReference As Reference, _
    orientWithEdge As Boolean _
) As PointOnEdgeFaceIntersection
Visual C++
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The edge reference.
faceReference
Type: Autodesk.Revit.DB..::.Reference
The face reference.
orientWithEdge
Type: System..::.Boolean

Return Value

A new PointOnEdgeFaceIntersection object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument edgeReference or faceReference is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnFace Method

[image]

Revit 2011 API
Application..::.NewPointOnFace Method
Application Class See Also Send Feedback
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic (Declaration)
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.DB..::.UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument faceReference or uv is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnPlane Method

[image]

Revit 2011 API
Application..::.NewPointOnPlane Method
Application Class See Also Send Feedback
Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointOnPlane NewPointOnPlane(
    Reference planeReference,
    UV position,
    UV xvec,
    double offset
)
Visual Basic (Declaration)
Public Function NewPointOnPlane ( _
    planeReference As Reference, _
    position As UV, _
    xvec As UV, _
    offset As Double _
) As PointOnPlane
Visual C++
public:
PointOnPlane^ NewPointOnPlane(
    Reference^ planeReference,
    UV^ position,
    UV^ xvec,
    double offset
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::.Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
position
Type: Autodesk.Revit.DB..::.UV
Coordinates of the point's projection onto the plane; see the Position property.
xvec
Type: Autodesk.Revit.DB..::.UV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
offset
Type: System..::.Double
Signed offset from the plane; see the Offset property.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument planeReference or position or xvec is nullNothingnullptra null reference (Nothing in Visual Basic) or offset is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method

[image] [image]

Revit 2011 API
Application..::.NewProfiledWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

Name | Description
NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, Boolean)

[image]

Revit 2011 API
Application..::.NewProfiledWallCreationData Method (CurveArray, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2011 API
Application..::.NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2011 API
Application..::.NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProjectPosition Method

[image]

Revit 2011 API
Application..::.NewProjectPosition Method
Application Class See Also Send Feedback
Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::.Double
East to West offset in feet.
ns
Type: System..::.Double
North to South offset in feet.
elevation
Type: System..::.Double
Elevation above sea level in feet.
angle
Type: System..::.Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method

[image] [image]

Revit 2011 API
Application..::.NewRectangularWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

Name | Description
NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, Level, Boolean)

[image]

Revit 2011 API
Application..::.NewRectangularWallCreationData Method (Curve, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2011 API
Application..::.NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall.
offset
Type: System..::.Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewReferenceArray Method

[image]

Revit 2011 API
Application..::.NewReferenceArray Method
Application Class See Also Send Feedback
Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray NewReferenceArray()
Visual Basic (Declaration)
Public Function NewReferenceArray As ReferenceArray
Visual C++
public:
ReferenceArray^ NewReferenceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewReferencePointArray Method

[image]

Revit 2011 API
Application..::.NewReferencePointArray Method
Application Class See Also Send Feedback
Creates an empty array that can store ReferencePoint objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePointArray NewReferencePointArray()
Visual Basic (Declaration)
Public Function NewReferencePointArray As ReferencePointArray
Visual C++
public:
ReferencePointArray^ NewReferencePointArray()

Return Value

An empty array that can hold ReferencePoint objects.

Remarks

This method can be used to create an array that can hold ReferencePoint objects. This array can be then passed to methods, such as NewCurveByPoints, to represent two or more PointElements.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRoomCreationData Method

[image]

Revit 2011 API
Application..::.NewRoomCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewRoom() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomCreationData NewRoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoomCreationData ( _
    level As Level, _
    point As UV _
) As RoomCreationData
Visual C++
public:
RoomCreationData^ NewRoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point the dictates the location on that specified level.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSATExportOptions Method

[image]

Revit 2011 API
Application..::.NewSATExportOptions Method
Application Class See Also Send Feedback
Creates SAT Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SATExportOptions NewSATExportOptions()
Visual Basic (Declaration)
Public Function NewSATExportOptions As SATExportOptions
Visual C++
public:
SATExportOptions^ NewSATExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSet Method

[image]

Revit 2011 API
Application..::.NewSet Method
Application Class See Also Send Feedback
Creates a new instance of a generic Set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Set NewSet()
Visual Basic (Declaration)
Public Function NewSet As Set
Visual C++
public:
Set^ NewSet()

Return Value

A new instance of a generic Set.

Remarks

Generic sets can hold any type of object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSpaceSet Method

[image]

Revit 2011 API
Application..::.NewSpaceSet Method
Application Class See Also Send Feedback
Creates a new instance of a space set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceSet NewSpaceSet()
Visual Basic (Declaration)
Public Function NewSpaceSet As SpaceSet
Visual C++
public:
SpaceSet^ NewSpaceSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewStringStringMap Method

[image]

Revit 2011 API
Application..::.NewStringStringMap Method
Application Class See Also Send Feedback
Creates a new map that maps one string to another string.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap NewStringStringMap()
Visual Basic (Declaration)
Public Function NewStringStringMap As StringStringMap
Visual C++
public:
StringStringMap^ NewStringStringMap()

Return Value

A map that maps one string to another.

Remarks

This is a general purpose string to string mapping which can be used for generating Autodesk Revit library paths.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSuspendUpdating Method

[image]

Revit 2011 API
Application..::.NewSuspendUpdating Method
Application Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begin suspension of consistency updates.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating NewSuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Function NewSuspendUpdating ( _
    document As Document _
) As SuspendUpdating
Visual C++
public:
SuspendUpdating^ NewSuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument document is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method

[image] [image]

Revit 2011 API
Application..::.NewTextNoteCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Overload List

Name | Description
NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2011 API
Application..::.NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::.TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.DB..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2011 API
Application..::.NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image] [image]

Revit 2011 API
Application..::.NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new type binding object.

Overload List

Name | Description
NewTypeBinding()()() | Creates a new empty type binding object.
NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image]

Revit 2011 API
Application..::.NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic (Declaration)
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding()

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method (CategorySet)

[image]

Revit 2011 API
Application..::.NewTypeBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic (Declaration)
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::.CategorySet
A set of categories that will be added to the binding.

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewUV Method

[image] [image]

Revit 2011 API
Application..::.NewUV Method
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space.

Overload List

Name | Description
NewUV()()() | Creates a UV object at the origin.
NewUV(UV) | Creates a UV object by copying the supplied UV object.
NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewUV Method

[image]

Revit 2011 API
Application..::.NewUV Method
Application Class See Also Send Feedback
Creates a UV object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV NewUV()
Visual Basic (Declaration)
Public Function NewUV As UV
Visual C++
public:
UV^ NewUV()

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (UV)

[image]

Revit 2011 API
Application..::.NewUV Method (UV)
Application Class See Also Send Feedback
Creates a UV object by copying the supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV NewUV(
    UV uv
)
Visual Basic (Declaration)
Public Function NewUV ( _
    uv As UV _
) As UV
Visual C++
public:
UV^ NewUV(
    UV^ uv
)

Parameters

uv
Type: Autodesk.Revit.DB..::.UV
The supplied UV object

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (Double, Double)

[image]

Revit 2011 API
Application..::.NewUV Method (Double, Double)
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV NewUV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Function NewUV ( _
    u As Double, _
    v As Double _
) As UV
Visual C++
public:
UV^ NewUV(
    double u,
    double v
)

Parameters

u
Type: System..::.Double
The first coordinate.
v
Type: System..::.Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewVertexIndexPair Method

[image]

Revit 2011 API
Application..::.NewVertexIndexPair Method
Application Class See Also Send Feedback
Creates a new VertexIndexPair object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPair NewVertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic (Declaration)
Public Function NewVertexIndexPair ( _
    iTop As Integer, _
    iBottom As Integer _
) As VertexIndexPair
Visual C++
public:
VertexIndexPair^ NewVertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::.Int32
The index of the vertex pair from the top profile of a blend.
iBottom
Type: System..::.Int32
The index of the vertex pair from the bottom profile of a blend.

Return Value

The new VertexIndexPair object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVertexIndexPairArray Method

[image]

Revit 2011 API
Application..::.NewVertexIndexPairArray Method
Application Class See Also Send Feedback
Returns an array that can hold VertexIndexPair objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPairArray NewVertexIndexPairArray()
Visual Basic (Declaration)
Public Function NewVertexIndexPairArray As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ NewVertexIndexPairArray()

Return Value

The new VertexIndexPairArray objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewViewSet Method

[image]

Revit 2011 API
Application..::.NewViewSet Method
Application Class See Also Send Feedback
Creates a new instance of a View set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet NewViewSet()
Visual Basic (Declaration)
Public Function NewViewSet As ViewSet
Visual C++
public:
ViewSet^ NewViewSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVolumeCalculationOptions Method

[image]

Revit 2011 API
Application..::.NewVolumeCalculationOptions Method
Application Class See Also Send Feedback
Creates options related to room volume and area computations.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VolumeCalculationOptions NewVolumeCalculationOptions()
Visual Basic (Declaration)
Public Function NewVolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
VolumeCalculationOptions^ NewVolumeCalculationOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image] [image]

Revit 2011 API
Application..::.NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space.

Overload List

Name | Description
NewXYZ()()() | Creates a XYZ object at the origin.
NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image]

Revit 2011 API
Application..::.NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ NewXYZ()
Visual Basic (Declaration)
Public Function NewXYZ As XYZ
Visual C++
public:
XYZ^ NewXYZ()

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (XYZ)

[image]

Revit 2011 API
Application..::.NewXYZ Method (XYZ)
Application Class See Also Send Feedback
Creates a XYZ object by copying the supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ NewXYZ(
    XYZ xyz
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    xyz As XYZ _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.DB..::.XYZ
The supplied XYZ object

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (Double, Double, Double)

[image]

Revit 2011 API
Application..::.NewXYZ Method (Double, Double, Double)
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::.Double
The first coordinate.
y
Type: System..::.Double
The second coordinate.
z
Type: System..::.Double
The third coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


Application Properties

[image] [image]

Revit 2011 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


AreaCreationData Class

[image]

Revit 2011 API
AreaCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Area for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaCreationData
Visual Basic (Declaration)
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.AreaCreationData

See Also

AreaCreationData Members
Autodesk.Revit.Creation Namespace


AreaCreationData Members

[image] [image]

Revit 2011 API
AreaCreationData Members
AreaCreationData Class Constructors Methods Properties See Also Send Feedback

The AreaCreationData type exposes the following members.

Constructors

Name | Description
AreaCreationData | The data needed to create a new area

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor

[image]

Revit 2011 API
AreaCreationData Constructor
AreaCreationData Class See Also Send Feedback
The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    areaView As ViewPlan, _
    point As UV _
)
Visual C++
public:
AreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::.UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Methods

[image] [image]

Revit 2011 API
AreaCreationData Methods
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Properties

[image] [image]

Revit 2011 API
AreaCreationData Properties
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Properties

Name | Description
TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2011 API
AreaCreationData..::.TagPoint Property
AreaCreationData Class See Also Send Feedback
Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class

[image]

Revit 2011 API
Document Class
Members See Also Send Feedback
The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Document : ItemFactoryBase
Visual Basic (Declaration)
Public Class Document _
    Inherits ItemFactoryBase
Visual C++
public ref class Document : public ItemFactoryBase

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document

See Also

Document Members
Autodesk.Revit.Creation Namespace


Document Members

[image] [image]

Revit 2011 API
Document Members
Document Class Methods Properties See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new flexible duct into the document.
NewFlexPipe | Overloaded. Adds a new flexible pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewGutter | Overloaded. Creates a gutter.
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
NewRebarCoverType | Create a new instance of Rebar Cover Type, which defines the cover setting of the rebar host.
NewRebarHookType | Creates a new instance of Rebar Hook Type, which defines the hook style of the rebar.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewDrafting | Creates a new drafting view.
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Methods

[image] [image]

Revit 2011 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewArea | Creates a new area
NewAreaBoundaryConditions | Overloaded. Creates a new Area BoundaryConditions element.
NewAreaBoundaryLine | Creates a new boundary line as an Area border.
NewAreaLoad | Overloaded. Creates a new area load in the project.
NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
NewAreas | Creates new areas
NewAreaTag | Creates a new area tag.
NewAreaViewPlan | Creates a new view for the new area.
NewBeamSystem | Overloaded. Creates a new BeamSystem.
NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
NewCurtainSystem | Overloaded. Creates a new CurtainSystem element.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDuct | Overloaded. Adds a new duct into the document.
NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
NewElectricalSystem | Overloaded. Creates a new MEP Electrical System element.
NewExtrusionRoof | Creates a new Extrusion Roof.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFascia | Overloaded. Creates a fascia.
NewFlexDuct | Overloaded. Adds a new flexible duct into the document.
NewFlexPipe | Overloaded. Adds a new flexible pipe into the document.
NewFloor | Overloaded. Creates a floor within the project.
NewFootPrintRoof | Creates a new FootPrintRoof element.
NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
NewFoundationWall | Creates a new continuous footing object.
NewGrid | Overloaded. Creates a new grid line.
NewGrids | Creates new grid lines.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewGutter | Overloaded. Creates a gutter.
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLineBoundaryConditions | Overloaded. Creates a new Line BoundaryConditions element.
NewLineLoad | Overloaded. Creates a new line load within the project.
NewLoadCase | Creates a new instance of a LoadCase element within the project.
NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
NewLoadNature | Creates a new instance of a LoadNature element within the project.
NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
NewMechanicalSystem | Creates a new MEP mechanical system element.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewOpening | Overloaded. Creates a new opening.
NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
NewPipe | Overloaded. Adds a new pipe into the document.
NewPipingSystem | Creates a new MEP piping system element.
NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
NewPointLoad | Overloaded. Creates a new point load within the project.
NewRebar | Overloaded. Creates a new instance of a Rebar element within the project.
NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
NewRebarCoverType | Create a new instance of Rebar Cover Type, which defines the cover setting of the rebar host.
NewRebarHookType | Creates a new instance of Rebar Hook Type, which defines the hook style of the rebar.
NewRebarShape | Creates a new instance of a Rebar Shape, which defines the shape of the rebar.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewRoom | Overloaded. Creates a new room.
NewRoomBoundaryLines | Creates a new boundary line as an Room border.
NewRooms | Overloaded. Creates one or more rooms.
NewRoomTag | Creates a new RoomTag.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
NewSlabEdge | Overloaded. Creates a slab edge.
NewSpace | Overloaded. Creates a new space.
NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
NewSpaces | Overloaded. Creates one or more spaces.
NewSpaceTag | Creates a new SpaceTag.
NewSpotCoordinate | Generate a new spot coordinate object within the project.
NewSpotElevation | Generate a new spot elevation object within the project.
NewTag | Creates a new IndependentTag Element.
NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
NewTruss | Creates a New Truss.
NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewDrafting | Creates a new drafting view.
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
NewViewSheet | Creates a new sheet view.
NewWall | Overloaded. Creates a new wall within the project.
NewWalls | Overloaded. Creates walls within the project.
NewWire | Creates a new wire element.
NewZone | Creates a new Zone element.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewArea Method

[image]

Revit 2011 API
Document..::.NewArea Method
Document Class See Also Send Feedback
Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Visual Basic (Declaration)
Public Function NewArea ( _
    areaView As ViewPlan, _
    point As UV _
) As Area
Visual C++
public:
Area^ NewArea(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::.UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method

[image] [image]

Revit 2011 API
Document..::.NewAreaBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Area BoundaryConditions element.

Overload List

Name | Description
NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2011 API
Document..::.NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::.Element
A Wall, Slab or Slab Foundation to host the boundary conditions.
X_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateAreaConditionWithElement(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    BoundaryConditions condition = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateAreaConditionWithElement(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    Dim condition As BoundaryConditions = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2011 API
Document..::.NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
The Geometry reference obtained from a Wall, Slab or Slab Foundation.
X_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
 bool CreateAreaConditionWithReference(Wall wall, Autodesk.Revit.Creation.Document docCreation)
 {
     // Get the Geometry reference to the wall
     Reference profileReference = null;
     AnalyticalModel analytical = wall.GetAnalyticalModel() as AnalyticalModel;
     if (null == analytical)
     {
         return false; // the profile reference can't be retrieved.
     }

     // loop through the curves of the wall and get the first one as a reference
     foreach (Curve curve in analytical.GetCurves(AnalyticalCurveType.ActiveCurves))
     {
         profileReference = curve.Reference;
         if (null != profileReference)
         {
             break;
         }
     }

     BoundaryConditions condition = null;
     // Create the Area Boundary Conditions if we have a profileReference
     if (null != profileReference)
     {
         // Create Area Boundary Conditions with profile reference.
         condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0);
     }
     return (null != condition);
}
CopyVB.NET
Function CreateAreaConditionWithReference(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Get the Geometry reference to the wall
    Dim profileReference As Reference = Nothing
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(wall.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    If analytical Is Nothing Then
        ' the profile reference can't be retrieved.
        Return False
    End If

    ' loop through the curves of the wall and get the first one as a reference
    For Each curve As Curve In analytical.GetCurves(Autodesk.Revit.DB.Structure.AnalyticalCurveType.ActiveCurves)
        profileReference = curve.Reference
        If profileReference IsNot Nothing Then
            Exit For
        End If
    Next

    Dim condition As BoundaryConditions = Nothing
    ' Create the Area Boundary Conditions if we have a profileReference
    If profileReference IsNot Nothing Then
        ' Create Area Boundary Conditions with profile reference.
        condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
         0)
    End If
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryLine Method

[image]

Revit 2011 API
Document..::.NewAreaBoundaryLine Method
Document Class See Also Send Feedback
Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic (Declaration)
Public Function NewAreaBoundaryLine ( _
    sketchPlane As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.DB..::.Curve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method

[image] [image]

Revit 2011 API
Document..::.NewAreaLoad Method
Document Class See Also Send Feedback
Creates a new area load in the project.

Overload List

Name | Description
NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
NewAreaLoad(IList<(Of <(XYZ>)>), XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
NewAreaLoad(CurveArray, array<Int32>[]()[], array<Int32>[]()[], IList<(Of <(XYZ>)>), Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
NewAreaLoad(CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)

[image]

Revit 2011 API
Document..::.NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform hosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
The host element (Floor or Wall) of the AreaLoad application.
force
Type: Autodesk.Revit.DB..::.XYZ
The 3d area force applied to the first reference point.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (IList(XYZ), XYZ, Boolean, AreaLoadType)

[image]

Revit 2011 API
Document..::.NewAreaLoad Method (IList<(Of <(XYZ>)>), XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform unhosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    IList<XYZ> points,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    points As IList(Of XYZ), _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    IList<XYZ^>^ points,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
Vertexes of AreaLoad shape polygon.
force
Type: Autodesk.Revit.DB..::.XYZ
The applied 3d area force.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], IList(XYZ), Boolean, AreaLoadType)

[image]

Revit 2011 API
Document..::.NewAreaLoad Method (CurveArray, array<Int32>[]()[], array<Int32>[]()[], IList<(Of <(XYZ>)>), Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    IList<XYZ> forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As IList(Of XYZ), _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    IList<XYZ^>^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
Type: array< System..::.Int32 >[]()[]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array< System..::.Int32 >[]()[]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)

[image]

Revit 2011 API
Document..::.NewAreaLoad Method (CurveArray, array<Int32>[]()[], array<Int32>[]()[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZ force0,
    XYZ force1,
    XYZ force2,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic (Declaration)
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    force0 As XYZ, _
    force1 As XYZ, _
    force2 As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZ^ force0,
    XYZ^ force1,
    XYZ^ force2,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves that define the shape of the area load.
refPntIdxs
Type: array< System..::.Int32 >[]()[]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array< System..::.Int32 >[]()[]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
force0
Type: Autodesk.Revit.DB..::.XYZ
The 3d area force applied to the first reference point.
force1
Type: Autodesk.Revit.DB..::.XYZ
The 3d area force applied to the second reference point. Ignored if only one or two reference points are supplied.
force2
Type: Autodesk.Revit.DB..::.XYZ
The 3d area force applied to the third reference point. Ignored if only one or two reference points are supplied.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

The size of the refPntIdxs and ends arrays must be the same, and a maximum of 3 values is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaReinforcement Method

[image]

Revit 2011 API
Document..::.NewAreaReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement(
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
Type: Autodesk.Revit.DB..::.XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
AreaReinforcement CreateAreaReinforcementInWall(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    AnalyticalModel analytical = wall.GetAnalyticalModel() as AnalyticalModel;
    if (null == analytical)
    {
        throw new Exception("Can't get AnalyticalModel from the selected wall");
    }

    CurveArray curves = analytical.GetCurves(AnalyticalCurveType.ActiveCurves) as CurveArray;

    //define the Major Direction of AreaReinforcement,
    //we get direction of first Line on the Wall as the Major Direction
    Line firstLine = (Line)(curves.get_Item(0));
    XYZ majorDirection = new XYZ(
        firstLine.get_EndPoint(1).X - firstLine.get_EndPoint(0).X,
        firstLine.get_EndPoint(1).Y - firstLine.get_EndPoint(0).Y,
        firstLine.get_EndPoint(1).Z - firstLine.get_EndPoint(0).Z);

    // Create the area reinforcement
    AreaReinforcement rein = docCreation.NewAreaReinforcement(wall, curves, majorDirection);

    return rein;
}
CopyVB.NET
Function CreateAreaReinforcementInWall(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Autodesk.Revit.DB.Structure.AreaReinforcement
    ' Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(wall.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    If analytical Is Nothing Then
        Throw New Exception("Can't get AnalyticalModel from the selected wall")
    End If

    Dim curves As CurveArray = TryCast(analytical.GetCurves(Autodesk.Revit.DB.Structure.AnalyticalCurveType.ActiveCurves), CurveArray)

    'define the Major Direction of AreaReinforcement,
    'we get direction of first Line on the Wall as the Major Direction
    Dim firstLine As Line = DirectCast((curves.Item(0)), Line)
    Dim majorDirection As New Autodesk.Revit.DB.XYZ(firstLine.EndPoint(1).X - firstLine.EndPoint(0).X, firstLine.EndPoint(1).Y - firstLine.EndPoint(0).Y, firstLine.EndPoint(1).Z - firstLine.EndPoint(0).Z)

    ' Create the area reinforcement
    Dim rein As Autodesk.Revit.DB.Structure.AreaReinforcement = docCreation.NewAreaReinforcement(wall, curves, majorDirection)

    Return rein
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreas Method

[image]

Revit 2011 API
Document..::.NewAreas Method
Document Class See Also Send Feedback
Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( AreaCreationData >)>)
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | If AreaCreationData's areaPoint is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaTag Method

[image]

Revit 2011 API
Document..::.NewAreaTag Method
Document Class See Also Send Feedback
Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Visual Basic (Declaration)
Public Function NewAreaTag ( _
    areaView As ViewPlan, _
    room As Area, _
    point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag(
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::.ViewPlan
The area view
room
Type: Autodesk.Revit.DB..::.Area
point
Type: Autodesk.Revit.DB..::.UV
The position of the area tag

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaViewPlan Method

[image]

Revit 2011 API
Document..::.NewAreaViewPlan Method
Document Class See Also Send Feedback
Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic (Declaration)
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewAreaViewPlan(
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
Type: System..::.String
The name of new created view
pLevel
Type: Autodesk.Revit.DB..::.Level
areaElemType
Type: Autodesk.Revit.DB..::.AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method

[image] [image]

Revit 2011 API
Document..::.NewBeamSystem Method
Document Class See Also Send Feedback
Creates a new BeamSystem.

Overload List

Name | Description
NewBeamSystem(CurveArray) | Creates a new BeamSystem with specified profile curves.
NewBeamSystem(CurveArray, XYZ) | Creates a new BeamSystem with specified profile curves and direction.
NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray)

[image]

Revit 2011 API
Document..::.NewBeamSystem Method (CurveArray)
Document Class Example See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile is the profile of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
CurveArray profile = new CurveArray();
profile.Append(Line.get_Bound(first, second));
profile.Append(Line.get_Bound(second, third));
profile.Append(Line.get_Bound(third, fourth));
profile.Append(Line.get_Bound(fourth, first));

// Create a beam system
BeamSystem beamSystem = document.Create.NewBeamSystem(profile);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim second As New Autodesk.Revit.DB.XYZ(40, 0, 0)
Dim third As New Autodesk.Revit.DB.XYZ(40, 25, 0)
Dim fourth As New Autodesk.Revit.DB.XYZ(0, 25, 0)
Dim profile As New CurveArray()
profile.Append(Line.Bound(first, second))
profile.Append(Line.Bound(second, third))
profile.Append(Line.Bound(third, fourth))
profile.Append(Line.Bound(fourth, first))

' Create a beam system
Dim beamSystem As BeamSystem = document.Create.NewBeamSystem(profile)
If beamSystem IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10)
    End If
End If

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, XYZ)

[image]

Revit 2011 API
Document..::.NewBeamSystem Method (CurveArray, XYZ)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves and direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    direction As XYZ _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    XYZ^ direction
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile is the profile of the BeamSystem.
direction
Type: Autodesk.Revit.DB..::.XYZ
The direction is the direction of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

[image]

Revit 2011 API
Document..::.NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic (Declaration)
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The work plane of the BeamSystem.
direction
Type: Autodesk.Revit.DB..::.XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::.Boolean
If the BeamSystem is 3D, the sketchPlane must be a level, or an exception will be thrown.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewCrossFitting Method

[image]

Revit 2011 API
Document..::.NewCrossFitting Method
Document Class See Also Send Feedback
Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewCrossFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic (Declaration)
Public Function NewCrossFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewCrossFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the cross.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the cross.
connector3
Type: Autodesk.Revit.DB..::.Connector
The third connector to be connected to the cross.
connector4
Type: Autodesk.Revit.DB..::.Connector
The fourth connector to be connected to the cross.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1, connector2, connector3, or connector4 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connectors cannot be used for cross creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when cross fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method

[image] [image]

Revit 2011 API
Document..::.NewCurtainSystem Method
Document Class See Also Send Feedback
Creates a new CurtainSystem element.

Overload List

Name | Description
NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
NewCurtainSystem(ReferenceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of face references.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (FaceArray, CurtainSystemType)

[image]

Revit 2011 API
Document..::.NewCurtainSystem Method (FaceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::.FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::.CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (ReferenceArray, CurtainSystemType)

[image]

Revit 2011 API
Document..::.NewCurtainSystem Method (ReferenceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewCurtainSystem(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic (Declaration)
Public Function NewCurtainSystem ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ElementSet
Visual C++
public:
ElementSet^ NewCurtainSystem(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::.ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::.CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2011 API
Document..::.NewDimension Method
Document Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method

[image] [image]

Revit 2011 API
Document..::.NewDuct Method
Document Class See Also Send Feedback
Adds a new duct into the document.

Overload List

Name | Description
NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.
NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method (Connector, Connector, DuctType)

[image]

Revit 2011 API
Document..::.NewDuct Method (Connector, Connector, DuctType)
Document Class Example See Also Send Feedback
Adds a new duct into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Duct NewDuct(
    Connector connector1,
    Connector connector2,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    Connector^ connector1,
    Connector^ connector2,
    DuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the duct, but no connection will be established.

Examples

CopyC#
public Duct CreateDuctBetweenConnectors(UIDocument uiDocument)
{
    // prior to running this example
    // select some mechanical equipment with a supply air connector
    // and an elbow duct fitting with a connector in line with that connector
    Connector connector1 = null, connector2 = null;
    ConnectorSetIterator csi = null;
    ElementSet selection = uiDocument.Selection.Elements;
    // First find the selected equipment and get the correct connector
    foreach (Element e in selection)
    {
        if (e is FamilyInstance)
        {
            FamilyInstance fi = e as FamilyInstance;
            Family family = fi.Symbol.Family;
            if (family.FamilyCategory.Name == "Mechanical Equipment")
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    Connector conn = csi.Current as Connector;
                    if (conn.Direction == FlowDirectionType.Out &&
                        conn.DuctSystemType == DuctSystemType.SupplyAir)
                    {
                        connector1 = conn;
                        break;
                    }
                }
            }
        }
    }
    // next find the second selected item to connect to
    foreach(Element e in selection)
    {
        if (e is FamilyInstance)
        {
            FamilyInstance fi = e as FamilyInstance;
            Family family = fi.Symbol.Family;
            if (family.FamilyCategory.Name != "Mechanical Equipment")
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    if (null == connector2)
                    {
                        Connector conn = csi.Current as Connector;

                        // make sure to choose the connector in line with the first connector
                        if (Math.Abs(conn.Origin.Y - connector1.Origin.Y) < 0.001)
                        {
                            connector2 = conn;
                            break;
                        }
                    }
                }
            }
        }
    }

    Duct duct = null;
    if (null != connector1 && null != connector2)
    {
        // find a duct type
        FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
        collector.OfClass(typeof(DuctType));

        // Use Linq query to make sure it is one of the rectangular duct types
        var query = from element in collector
                    where element.Name.Contains("Mitered Elbows") == true
                    select element;

        // use extension methods to get first duct type
        DuctType ductType = collector.Cast<DuctType>().First<DuctType>();

        if (null != ductType)
        {
            duct = uiDocument.Document.Create.NewDuct(connector1, connector2, ductType);
        }
    }

    return duct;
}
CopyVB.NET
Public Function CreateDuctBetweenConnectors(ByVal uiDocument As UIDocument) As Duct
    ' prior to running this example
    ' select some mechanical equipment with a supply air connector
    ' and an elbow duct fitting with a connector in line with that connector
    Dim connector1 As Connector = Nothing, connector2 As Connector = Nothing
    Dim csi As ConnectorSetIterator = Nothing
    Dim selection As ElementSet = uiDocument.Selection.Elements
    ' First find the selected equipment and get the correct connector
    For Each e As Element In selection
        If TypeOf e Is FamilyInstance Then
            Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
            Dim family As Family = fi.Symbol.Family
            If family.FamilyCategory.Name = "Mechanical Equipment" Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    Dim conn As Connector = TryCast(csi.Current, Connector)
                    If conn.Direction = FlowDirectionType.Out AndAlso conn.DuctSystemType = DuctSystemType.SupplyAir Then
                        connector1 = conn
                        Exit While
                    End If
                End While
            End If
        End If
    Next
    ' next find the second selected item to connect to
    For Each e As Element In selection
        If TypeOf e Is FamilyInstance Then
            Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
            Dim family As Family = fi.Symbol.Family
            If family.FamilyCategory.Name <> "Mechanical Equipment" Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    If connector2 Is Nothing Then
                        Dim conn As Connector = TryCast(csi.Current, Connector)

                        ' make sure to choose the connector in line with the first connector
                        If Math.Abs(conn.Origin.Y - connector1.Origin.Y) < 0.001 Then
                            connector2 = conn
                            Exit While
                        End If
                    End If
                End While
            End If
        End If
    Next

    Dim duct As Duct = Nothing
    If connector1 IsNot Nothing AndAlso connector2 IsNot Nothing Then
        ' find a duct type
        Dim collector As New FilteredElementCollector(uiDocument.Document)
        collector.OfClass(GetType(DuctType))

        ' Use Linq query to make sure it is one of the rectangular duct types
        Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
        query = From element In collector _
         Where element.Name.Contains("Mitered Elbows") = True _
         Select element

        ' use extension methods to get first duct type
        Dim ductType As DuctType = collector.Cast(Of DuctType)().First()

        If ductType IsNot Nothing Then
            duct = uiDocument.Document.Create.NewDuct(connector1, connector2, ductType)
        End If
    End If

    Return duct
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, Connector, DuctType)

[image]

Revit 2011 API
Document..::.NewDuct Method (XYZ, Connector, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using a point, connector and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point,
    Connector connector,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point As XYZ, _
    connector As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point,
    Connector^ connector,
    DuctType^ ductType
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The first point of the duct.
connector
Type: Autodesk.Revit.DB..::.Connector
The connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the duct, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument point or connector is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, XYZ, DuctType)

[image]

Revit 2011 API
Document..::.NewDuct Method (XYZ, XYZ, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using two points and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point1,
    XYZ point2,
    DuctType ductType
)
Visual Basic (Declaration)
Public Function NewDuct ( _
    point1 As XYZ, _
    point2 As XYZ, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point1,
    XYZ^ point2,
    DuctType^ ductType
)

Parameters

point1
Type: Autodesk.Revit.DB..::.XYZ
The first point of the duct.
point2
Type: Autodesk.Revit.DB..::.XYZ
The second point of the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument point1 or point2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewElbowFitting Method

[image]

Revit 2011 API
Document..::.NewElbowFitting Method
Document Class See Also Send Feedback
Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewElbowFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the elbow.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the elbow.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when elbow fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method

[image] [image]

Revit 2011 API
Document..::.NewElectricalSystem Method
Document Class See Also Send Feedback
Creates a new MEP Electrical System element.

Overload List

Name | Description
NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
NewElectricalSystem(ElementSet, ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (Connector, ElectricalSystemType)

[image]

Revit 2011 API
Document..::.NewElectricalSystem Method (Connector, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    Connector connector,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    connector As Connector, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    Connector^ connector,
    ElectricalSystemType elecSysType
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
The Connector to create this Electrical System.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input connector.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (ElementSet, ElectricalSystemType)

[image]

Revit 2011 API
Document..::.NewElectricalSystem Method (ElementSet, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic (Declaration)
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: Autodesk.Revit.DB..::.ElementSet
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewExtrusionRoof Method

[image]

Revit 2011 API
Document..::.NewExtrusionRoof Method
Document Class See Also Send Feedback
Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic (Declaration)
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof(
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile of the extrusion roof.
refPlane
Type: Autodesk.Revit.DB..::.ReferencePlane
The work plane for the extrusion roof.
level
Type: Autodesk.Revit.DB..::.Level
The level of the extrusion roof.
roofType
Type: Autodesk.Revit.DB..::.RoofType
Type of the extrusion roof.
extrusionStart
Type: System..::.Double
Start the extrusion.
extrusionEnd
Type: System..::.Double
End the extrusion.

Remarks

This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2011 API
Document..::.NewFamilyInstance Method
Document Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
Document..::.NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
// get the active view's level for beam creation
 Level level = document.ActiveView.Level;

 // load a family symbol from file
 FamilySymbol gotSymbol = null;
 String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa";
 String name = "W10X54";

 FamilyInstance instance = null;

 if (document.LoadFamilySymbol(fileName, name, out gotSymbol))
 {
     // look for a model line in the list of selected elements
     UIDocument uidoc = new UIDocument(document);
     ElementSet sel = uidoc.Selection.Elements;
     ModelLine modelLine = null;
     foreach (Autodesk.Revit.DB.Element elem in sel)
     {
         if (elem is ModelLine)
         {
             modelLine = elem as ModelLine;
             break;
         }
     }
     if (null != modelLine)
     {
         // create a new beam
         instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol,
                                                       level, StructuralType.Beam);
     }
     else
     {
         throw new Exception("Please select a model line before invoking this command");
     }

 }
 else
 {
     throw new Exception("Couldn't load " + fileName);
 }
CopyVB.NET
' get the active view's level for beam creation
Dim level As Level = document.ActiveView.Level

' load a family symbol from file
Dim gotSymbol As FamilySymbol = Nothing
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa"
Dim name As [String] = "W10X54"

Dim instance As Autodesk.Revit.DB.FamilyInstance = Nothing

If document.LoadFamilySymbol(fileName, name, gotSymbol) Then
    ' look for a model line in the list of selected elements
    Dim uidoc As New UIDocument(document)
    Dim sel As ElementSet = uidoc.Selection.Elements
    Dim modelLine As ModelLine = Nothing
    For Each elem As Autodesk.Revit.DB.Element In sel
        If TypeOf elem Is ModelLine Then
            modelLine = TryCast(elem, ModelLine)
            Exit For
        End If
    Next
    If modelLine IsNot Nothing Then
        ' create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol, level, Autodesk.Revit.DB.Structure.StructuralType.Beam)
    Else
        Throw New Exception("Please select a model line before invoking this command")

    End If
Else
    Throw New Exception("Couldn't load " + fileName)
End If

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
FamilyInstance CreateColumn(Autodesk.Revit.DB.Document document, Level level)
{
    // Get a Column type from Revit
    FamilySymbol columnType = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        columnType = e as FamilySymbol;
        if (null != columnType && null != columnType.Category)
        {
            if ("Structural Columns" == columnType.Category.Name)
            {
                break;
            }
        }
    }

    FamilyInstance instance;
    if (null != columnType)
    {
        // Create a column at the origin
        XYZ origin = new XYZ(0, 0, 0);

        instance = document.Create.NewFamilyInstance(origin, columnType, level,
                                                      StructuralType.Column);
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return instance;
}
CopyVB.NET
Function CreateColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Autodesk.Revit.DB.FamilyInstance
    ' Get a Column type from Revit
    Dim columnType As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        columnType = TryCast(e, FamilySymbol)
        If columnType IsNot Nothing AndAlso columnType.Category IsNot Nothing Then
            If "Structural Columns" = columnType.Category.Name Then
                Exit For
            End If
        End If
    Next

    Dim instance As Autodesk.Revit.DB.FamilyInstance
    If columnType IsNot Nothing Then
        ' Create a column at the origin
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)

        instance = document.Create.NewFamilyInstance(origin, columnType, level, Autodesk.Revit.DB.Structure.StructuralType.Column)
    Else
        Throw New Exception("No column types found.")
    End If

    Return instance
End Function

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2011 API
Document..::.NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa";

    Family family = null;
    if (!document.LoadFamily(fileName, out family))
    {
        throw new Exception("Unable to load " + fileName);
    }

    // get the active view's level for beam creation
    Level level = document.ActiveView.Level;

    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Sub CreateDoorsInWall(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa"

    Dim family As Family = Nothing
    If Not document.LoadFamily(fileName, family) Then
        Throw New Exception("Unable to load " + fileName)
    End If

    ' get the active view's level for beam creation
    Dim level As Level = document.ActiveView.Level

    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New Autodesk.Revit.DB.XYZ(x, y, z)
        Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFascia Method

[image] [image]

Revit 2011 API
Document..::.NewFascia Method
Document Class See Also Send Feedback
Creates a fascia.

Overload List

Name | Description
NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, Reference)

[image]

Revit 2011 API
Document..::.NewFascia Method (FasciaType, Reference)
Document Class See Also Send Feedback
Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The type of the fascia to create
reference
Type: Autodesk.Revit.DB..::.Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, ReferenceArray)

[image]

Revit 2011 API
Document..::.NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also Send Feedback
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method

[image] [image]

Revit 2011 API
Document..::.NewFlexDuct Method
Document Class See Also Send Feedback
Adds a new flexible duct into the document.

Overload List

Name | Description
NewFlexDuct(IList<(Of <(XYZ>)>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
NewFlexDuct(Connector, IList<(Of <(XYZ>)>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (IList(XYZ), FlexDuctType)

[image]

Revit 2011 API
Document..::.NewFlexDuct Method (IList<(Of <(XYZ>)>), FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The point array indicating the path of the flexible duct, including the end points.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]

Revit 2011 API
Document..::.NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, IList(XYZ), FlexDuctType)

[image]

Revit 2011 API
Document..::.NewFlexDuct Method (Connector, IList<(Of <(XYZ>)>), FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic (Declaration)
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
The connector to be connected to the duct, including the end points.
points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The point array indicating the path of the flexible duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::.FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method

[image] [image]

Revit 2011 API
Document..::.NewFlexPipe Method
Document Class See Also Send Feedback
Adds a new flexible pipe into the document.

Overload List

Name | Description
NewFlexPipe(IList<(Of <(XYZ>)>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
NewFlexPipe(Connector, IList<(Of <(XYZ>)>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (IList(XYZ), FlexPipeType)

[image]

Revit 2011 API
Document..::.NewFlexPipe Method (IList<(Of <(XYZ>)>), FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The point array indicating the path of the flexible pipe, including the end points.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, Connector, FlexPipeType)

[image]

Revit 2011 API
Document..::.NewFlexPipe Method (Connector, Connector, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using two connector, and flexible pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, IList(XYZ), FlexPipeType)

[image]

Revit 2011 API
Document..::.NewFlexPipe Method (Connector, IList<(Of <(XYZ>)>), FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic (Declaration)
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
The connector to be connected to the flexible pipe, including the end points.
points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The point array indicating the path of the flexible pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFloor Method

[image] [image]

Revit 2011 API
Document..::.NewFloor Method
Document Class See Also Send Feedback
Creates a floor within the project.

Overload List

Name | Description
NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, Boolean)

[image]

Revit 2011 API
Document..::.NewFloor Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean)

[image]

Revit 2011 API
Document..::.NewFloor Method (CurveArray, FloorType, Level, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

if successful, a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.DB..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

Examples

CopyC#
Floor CreateFloor(UIApplication application, Level level)
{
    // Get the Revit document
    Autodesk.Revit.DB.Document document = application.ActiveUIDocument.Document;

    // Get the application creation object
    Autodesk.Revit.Creation.Application appCreation = application.Application.Create;

    // Get a floor type for floor creation
    FloorType floorType = null;
    FloorTypeSet floorTypes = document.FloorTypes;
    FloorTypeSetIterator iter = floorTypes.ForwardIterator();
    iter.Reset();
    while (iter.MoveNext())
    {
        floorType = iter.Current as FloorType;
        if (null != floorType)
        {
            break;
        }
    }

    // Build a floor profile for the floor creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 15, 0);
    XYZ fourth = new XYZ(0, 15, 0);
    CurveArray profile = new CurveArray();
    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    // The normal vector (0,0,1) that must be perpendicular to the profile.
    XYZ normal = XYZ.BasisZ;

    return document.Create.NewFloor(profile, floorType, level, true, normal);
}
CopyVB.NET
Function CreateFloor(ByVal application As UIApplication, ByVal level As Level) As Autodesk.Revit.DB.Floor
    ' Get the Revit document
    Dim document As Autodesk.Revit.DB.Document = application.ActiveUIDocument.Document

    ' Get the application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = application.Application.Create

    ' Get a floor type for floor creation
    Dim floorType As FloorType = Nothing
    Dim floorTypes As FloorTypeSet = document.FloorTypes
    Dim iter As FloorTypeSetIterator = floorTypes.ForwardIterator()
    iter.Reset()
    While iter.MoveNext()
        floorType = TryCast(iter.Current, FloorType)
        If floorType IsNot Nothing Then
            Exit While
        End If
    End While

    ' Build a floor profile for the floor creation
    Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.DB.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.DB.XYZ(20, 15, 0)
    Dim fourth As New Autodesk.Revit.DB.XYZ(0, 15, 0)
    Dim profile As New CurveArray()
    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    ' The normal vector (0,0,1) that must be perpendicular to the profile.
    Dim normal As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.BasisZ

    Return document.Create.NewFloor(profile, floorType, level, True, normal)
End Function

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFootPrintRoof Method

[image]

Revit 2011 API
Document..::.NewFootPrintRoof Method
Document Class Example See Also Send Feedback
Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    out ModelCurveArray footPrintToModelCurvesMapping
)
Visual Basic (Declaration)
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    <OutAttribute> ByRef footPrintToModelCurvesMapping As ModelCurveArray _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    [OutAttribute] ModelCurveArray^% footPrintToModelCurvesMapping
)

Parameters

footPrint
Type: Autodesk.Revit.DB..::.CurveArray
The footprint of the FootPrintRoof.
level
Type: Autodesk.Revit.DB..::.Level
The level of the FootPrintRoof.
roofType
Type: Autodesk.Revit.DB..::.RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
Type: Autodesk.Revit.DB..::.ModelCurveArray %
An array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(new ElementClassFilter(typeof(Level)));
var elements = from element in collector where element.Name == "Roof" select element;
Level level = elements.Cast<Level>().ElementAt<Level>(0);

RoofType rooftype = null;
// select the first rooftype
foreach (RoofType rt in document.RoofTypes)
{
    rooftype = rt;
    break;
}

// Get the handle of the application
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();
UIDocument uidoc = new UIDocument(document);
if (uidoc.Selection.Elements.Size != 0)
{
    foreach (Autodesk.Revit.DB.Element element in uidoc.Selection.Elements)
    {
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

ModelCurveArray footPrintToModelCurveMapping = new ModelCurveArray();
FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, out footPrintToModelCurveMapping);
ModelCurveArrayIterator iterator = footPrintToModelCurveMapping.ForwardIterator();
iterator.Reset();
while (iterator.MoveNext())
{
    ModelCurve modelCurve = iterator.Current as ModelCurve;
    footprintRoof.set_DefinesSlope(modelCurve, true);
    footprintRoof.set_SlopeAngle(modelCurve, 0.5);
}
CopyVB.NET
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(New ElementClassFilter(GetType(Autodesk.Revit.DB.Level)))
Dim elements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
elements = From element In collector _
            Where element.Name = "Roof" _
            Select element
Dim level As Level = elements.Cast(Of Autodesk.Revit.DB.Level)().ElementAt(0)

Dim rooftype As RoofType = Nothing
' select the first rooftype
For Each rt As RoofType In document.RoofTypes
    rooftype = rt
    Exit For
Next

' Get the handle of the application
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()
Dim uidoc As New UIDocument(document)
If uidoc.Selection.Elements.Size <> 0 Then
    For Each element As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If

    Next
Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footPrintToModelCurveMapping As New ModelCurveArray()
Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, footPrintToModelCurveMapping)
Dim iterator As ModelCurveArrayIterator = footPrintToModelCurveMapping.ForwardIterator()
iterator.Reset()
While iterator.MoveNext()
    Dim modelCurve As ModelCurve = TryCast(iterator.Current, ModelCurve)
    footprintRoof.DefinesSlope(modelCurve) = True
    footprintRoof.SlopeAngle(modelCurve) = 0.5
End While

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationSlab Method

[image]

Revit 2011 API
Document..::.NewFoundationSlab Method
Document Class See Also Send Feedback
Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Floor NewFoundationSlab(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewFoundationSlab ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFoundationSlab(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::.FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the floor is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.DB..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new foundation slab object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationWall Method

[image]

Revit 2011 API
Document..::.NewFoundationWall Method
Document Class See Also Send Feedback
Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic (Declaration)
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall(
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
Type: Autodesk.Revit.DB..::.ContFootingType
The ContFooting type.
wall
Type: Autodesk.Revit.DB..::.Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrid Method

[image] [image]

Revit 2011 API
Document..::.NewGrid Method
Document Class See Also Send Feedback
Creates a new grid line.

Overload List

Name | Description
NewGrid(Arc) | Creates a new radial grid line.
NewGrid(Line) | Creates a new linear grid line.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGrid Method (Arc)

[image]

Revit 2011 API
Document..::.NewGrid Method (Arc)
Document Class Example See Also Send Feedback
Creates a new radial grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Arc^ arc
)

Parameters

arc
Type: Autodesk.Revit.DB..::.Arc
An arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

Examples

CopyC#
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = document.Application.Create.NewArc(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = document.Create.NewGrid(geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
CopyVB.NET
' Create the geometry arc which the grid locates
Dim end0 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 40, 0)
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(5, 7, 0)
Dim geomArc As Arc = document.Application.Create.NewArc(end0, end1, pointOnCurve)

' Create a grid using the geometry arc
Dim arcGrid As Grid = document.Create.NewGrid(geomArc)

If arcGrid Is Nothing Then
    Throw New Exception("Create a new curved grid failed.")
End If

' Modify the name of the created grid
arcGrid.Name = "New Name2"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrid Method (Line)

[image]

Revit 2011 API
Document..::.NewGrid Method (Line)
Document Class Example See Also Send Feedback
Creates a new linear grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Grid NewGrid(
    Line line
)
Visual Basic (Declaration)
Public Function NewGrid ( _
    line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Line^ line
)

Parameters

line
Type: Autodesk.Revit.DB..::.Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

Examples

CopyC#
// Create the geometry line which the grid locates
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(30, 30, 0);
Line geomLine = Line.get_Bound(start, end);

// Create a grid using the geometry line
Grid lineGrid = document.Create.NewGrid(geomLine);

if (null == lineGrid)
{
    throw new Exception("Create a new straight grid failed.");
}

// Modify the name of the created grid
lineGrid.Name = "New Name1";
CopyVB.NET
' Create the geometry line which the grid locates
Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim [end] As New Autodesk.Revit.DB.XYZ(30, 30, 0)
Dim geomLine As Line = Line.Bound(start, [end])

' Create a grid using the geometry line
Dim lineGrid As Grid = document.Create.NewGrid(geomLine)

If lineGrid Is Nothing Then
    Throw New Exception("Create a new straight grid failed.")
End If

' Modify the name of the created grid
lineGrid.Name = "New Name1"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrids Method

[image]

Revit 2011 API
Document..::.NewGrids Method
Document Class See Also Send Feedback
Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic (Declaration)
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids(
    CurveArray^ curves
)

Parameters

curves
Type: Autodesk.Revit.DB..::.CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If the curve is an unbounded arc (a circle).
Autodesk.Revit.Exceptions..::.ArgumentNullException | If any curve supplied in the input is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGutter Method

[image] [image]

Revit 2011 API
Document..::.NewGutter Method
Document Class See Also Send Feedback
Creates a gutter.

Overload List

Name | Description
NewGutter(GutterType, Reference) | Creates a gutter along a reference.
NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, Reference)

[image]

Revit 2011 API
Document..::.NewGutter Method (GutterType, Reference)
Document Class See Also Send Feedback
Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The type of the gutter to create
reference
Type: Autodesk.Revit.DB..::.Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, ReferenceArray)

[image]

Revit 2011 API
Document..::.NewGutter Method (GutterType, ReferenceArray)
Document Class See Also Send Feedback
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method

[image] [image]

Revit 2011 API
Document..::.NewLineBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Line BoundaryConditions element.

Overload List

Name | Description
NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2011 API
Document..::.NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::.Element
A Beam.
X_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionsWithElement(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only works for columns.");
    }

    // Create the new line boundary conditions
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateLineConditionsWithElement(ByVal column As Autodesk.Revit.DB.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.DB.Structure.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2011 API
Document..::.NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewLineBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
The Geometry reference to a Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical line.
X_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionWithReference(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only work for columns.");
    }

    // Get the line reference for the column analytical model
    Reference lineReference = null;
    AnalyticalModel analytical = column.GetAnalyticalModel() as AnalyticalModel;
    lineReference = analytical.GetCurve().Reference;
    if (null == lineReference)
    {
        throw new Exception("Unable to get reference line for selected column.");
    }

    // Create line Boundary Conditions for the column
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateLineConditionWithReference(ByVal column As Autodesk.Revit.DB.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.DB.Structure.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only work for columns.")
    End If

    ' Get the line reference for the column analytical model
    Dim lineReference As Reference = Nothing
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    lineReference = analytical.GetCurve().Reference
    If lineReference Is Nothing Then
        Throw New Exception("Unable to get reference line for selected column.")
    End If

    ' Create line Boundary Conditions for the column
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method

[image] [image]

Revit 2011 API
Document..::.NewLineLoad Method
Document Class See Also Send Feedback
Creates a new line load within the project.

Overload List

Name | Description
NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.
NewLineLoad(Element, IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
NewLineLoad(Reference, IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
NewLineLoad(IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The first point of the LineLoad application.
force
Type: Autodesk.Revit.DB..::.XYZ
The applied 3d linear force in the first point.
moment
Type: Autodesk.Revit.DB..::.XYZ
The applied 3d linear moment in the first point.
point1
Type: Autodesk.Revit.DB..::.XYZ
The second point of the LineLoad application.
force1
Type: Autodesk.Revit.DB..::.XYZ
The applied 3d linear force in the second point.
moment1
Type: Autodesk.Revit.DB..::.XYZ
The applied 3d linear moment in the second point.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Element, IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewLineLoad Method (Element, IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Element host,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    host As Element, _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Element^ host,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
The host element (Beam, Brace or Column) of the LineLoad application.
forces
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Reference, IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewLineLoad Method (Reference, IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Reference reference,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    reference As Reference, _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Reference^ reference,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
forces
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLOad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (IList(XYZ), IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewLineLoad Method (IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), IList<(Of <(XYZ>)>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    IList<XYZ> points,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewLineLoad ( _
    points As IList(Of XYZ), _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    IList<XYZ^>^ points,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The end points of the LineLoad application.
forces
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
The applied 3d linear moments in the end points.
uniform
Type: System..::.Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::.Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLoadCase Method

[image]

Revit 2011 API
Document..::.NewLoadCase Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic (Declaration)
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase(
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
Type: System..::.String
The not empty name for the Load Case Element to create.
nature
Type: Autodesk.Revit.DB.Structure..::.LoadNature
The Load Case nature.
category
Type: Autodesk.Revit.DB..::.Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn't the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Examples

CopyC#
LoadCase CreateLoadCase(Autodesk.Revit.DB.Document document, Category category, LoadNature nature)
{
    // Create a load case
    // Category should be of type OST_LoadCases
    LoadCase loadCase = document.Create.NewLoadCase("new case", nature, category);
    if (null == loadCase)
    {
        throw new Exception("Create a new load case failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Successfully created a load case.");

    return loadCase;
}
CopyVB.NET
Function CreateLoadCase(ByVal document As Autodesk.Revit.DB.Document, ByVal category As Category, ByVal nature As LoadNature) As LoadCase
    ' Create a load case
    ' Category should be of type OST_LoadCases
    Dim loadCase As LoadCase = document.Create.NewLoadCase("new case", nature, category)
    If loadCase Is Nothing Then
        Throw New Exception("Create a new load case failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Successfully created a load case.")

    Return loadCase
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadCombination Method

[image]

Revit 2011 API
Document..::.NewLoadCombination Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCombination element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCombination NewLoadCombination(
    string name,
    int typeInd,
    int stateInd,
    double[] factors,
    LoadCaseArray cases,
    LoadCombinationArray combinations,
    LoadUsageArray usages
)
Visual Basic (Declaration)
Public Function NewLoadCombination ( _
    name As String, _
    typeInd As Integer, _
    stateInd As Integer, _
    factors As Double(), _
    cases As LoadCaseArray, _
    combinations As LoadCombinationArray, _
    usages As LoadUsageArray _
) As LoadCombination
Visual C++
public:
LoadCombination^ NewLoadCombination(
    String^ name,
    int typeInd,
    int stateInd,
    array<double>^ factors,
    LoadCaseArray^ cases,
    LoadCombinationArray^ combinations,
    LoadUsageArray^ usages
)

Parameters

name
Type: System..::.String
The not empty name for the Load Combination Element to create.
typeInd
Type: System..::.Int32
LoadCombination Type Index: 0-Combination, 1-Envelope.
stateInd
Type: System..::.Int32
LoadCombination State Index: 0-Servicebility, 1-Ultimate.
factors
Type: array< System..::.Double >[]()[]
Factors array for Load Combination formula.
cases
Type: Autodesk.Revit.DB.Structure..::.LoadCaseArray
Load Cases array for Load Combination formula.
combinations
Type: Autodesk.Revit.DB.Structure..::.LoadCombinationArray
Load Combinations array for Load Combination formula.
usages
Type: Autodesk.Revit.DB.Structure..::.LoadUsageArray
Load Usages array.

Return Value

If successful, NewLoadCombination and there isn't the Load Combination Element with the same name returns an object for the newly created LoadCombination. If such element exist and match desired one (has the same formula and the same usages set), returns existing element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Remarks

Factors and Load Combinations arrays have the same dimension (n). The Load Combination formula is equal to: factors[0]*cases[0]*factors[1]*cases[1]*. . . factors[n]*cases[n].

Examples

CopyC#
LoadCombination CreateLoadCombination(Autodesk.Revit.DB.Document document, LoadCaseArray loadCases, LoadUsageArray loadUsages)
{
    // Create the factor array for load combination creation
    double[] factorArray = new double[loadCases.Size];
    for (int ii = 0; ii < loadCases.Size; ii++)
    {
        factorArray[ii] = ii + 1;
    }

    // Create a new load combination
    int typeInd = 0;    // Combination
    int stateInd = 0;   // Servicebility
    LoadCombinationArray combinations = new LoadCombinationArray();

    LoadCombination loadCombination = document.Create.NewLoadCombination("New combination",
                                                        typeInd, stateInd, factorArray, loadCases,
                                                        combinations, loadUsages);
    if (null == loadCombination)
    {
        throw new Exception("Create a load combination failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Load combination created successfully.");

    return loadCombination;
}
CopyVB.NET
Function CreateLoadCombination(ByVal document As Autodesk.Revit.DB.Document, ByVal loadCases As LoadCaseArray, ByVal loadUsages As LoadUsageArray) As LoadCombination
    ' Create the factor array for load combination creation
    Dim factorArray As Double() = New Double(loadCases.Size) {}
    Dim ii As Integer = 0
    While ii < loadCases.Size
        factorArray(ii) = ii + 1
        System.Math.Max(System.Threading.Interlocked.Increment(ii), ii - 1)
    End While

    ' Create a new load combination
    Dim typeInd As Integer = 0
    ' Combination
    Dim stateInd As Integer = 0
    ' Servicebility
    Dim combinations As New LoadCombinationArray()

    Dim loadCombination As LoadCombination = document.Create.NewLoadCombination("New combination", typeInd, stateInd, factorArray, loadCases, combinations, _
     loadUsages)
    If loadCombination Is Nothing Then
        Throw New Exception("Create a load combination failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Load combination created successfully.")

    Return loadCombination
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadNature Method

[image]

Revit 2011 API
Document..::.NewLoadNature Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature(
    String^ name
)

Parameters

name
Type: System..::.String
The name for the Load Nature Element to create.

Return Value

If successful and there isn't the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
// Create a new load nature.
LoadNature nature = document.Create.NewLoadNature("New Nature");
if (null == nature)
{
    throw new Exception("Create a new load nature failed.");
}
CopyVB.NET
' Create a new load nature.
Dim nature As LoadNature = document.Create.NewLoadNature("New Nature")
If nature Is Nothing Then
    Throw New Exception("Create a new load nature failed.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadUsage Method

[image]

Revit 2011 API
Document..::.NewLoadUsage Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadUsage element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadUsage NewLoadUsage(
    string name
)
Visual Basic (Declaration)
Public Function NewLoadUsage ( _
    name As String _
) As LoadUsage
Visual C++
public:
LoadUsage^ NewLoadUsage(
    String^ name
)

Parameters

name
Type: System..::.String
The not empty name for the Load Usage Element to create.

Return Value

If successful and there isn't the Load Usage Element with the same name NewLoadUsage returns an object for the newly created LoadUsage. If such element exist it returns existing element. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
// Create some Load usages and add them into an array
LoadUsage usage1 = document.Create.NewLoadUsage("Usage one");
LoadUsage usage2 = document.Create.NewLoadUsage("Usage two");

if (null == usage1 || null == usage2)
{
    throw new Exception("Create new load usage failed.");
}

LoadUsageArray loadUsages = new LoadUsageArray();
loadUsages.Append(usage1);
loadUsages.Append(usage2);
CopyVB.NET
' Create some Load usages and add them into an array
Dim usage1 As LoadUsage = document.Create.NewLoadUsage("Usage one")
Dim usage2 As LoadUsage = document.Create.NewLoadUsage("Usage two")

If usage1 Is Nothing OrElse usage2 Is Nothing Then
    Throw New Exception("Create new load usage failed.")
End If

Dim loadUsages As New LoadUsageArray()
loadUsages.Append(usage1)
loadUsages.Append(usage2)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewMechanicalSystem Method

[image]

Revit 2011 API
Document..::.NewMechanicalSystem Method
Document Class Example See Also Send Feedback
Creates a new MEP mechanical system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MechanicalSystem NewMechanicalSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    DuctSystemType ductSystemType
)
Visual Basic (Declaration)
Public Function NewMechanicalSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    ductSystemType As DuctSystemType _
) As MechanicalSystem
Visual C++
public:
MechanicalSystem^ NewMechanicalSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    DuctSystemType ductSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.DB..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be nullNothingnullptra null reference (Nothing in Visual Basic). The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.DB..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
ductSystemType
Type: Autodesk.Revit.DB.Mechanical..::.DuctSystemType
The system type.

Return Value

If creation was successful then an instance of mechanical system is returned, otherwise an exception with information will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
// create a connector set for new mechanical system
ConnectorSet connectorSet = new ConnectorSet();
// Base equipment connector
Connector baseConnector = null;

// Select a Parallel Fan Powered VAV and some Supply Diffusers
// prior to running this example
ConnectorSetIterator csi = null;
ElementSet selection = uiDocument.Selection.Elements;
foreach (Element e in selection)
{
    if (e is FamilyInstance)
    {
        FamilyInstance fi = e as FamilyInstance;
        Family family = fi.Symbol.Family;
        // Assume the selected Mechanical Equipment is the base equipment for new system
        if (family.FamilyCategory.Name == "Mechanical Equipment")
        {
            //Find the "Out" and "SupplyAir" connector on the base equipment
            if (null != fi.MEPModel)
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    Connector conn = csi.Current as Connector;
                    if (conn.Direction == FlowDirectionType.Out && conn.DuctSystemType == DuctSystemType.SupplyAir)
                    {
                        baseConnector = conn;
                        break;
                    }
                }
            }
        }
        else if (family.FamilyCategory.Name == "Air Terminals")
        {
            // add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
            csi.MoveNext();
            connectorSet.Insert(csi.Current as Connector);
        }
    }
}

MechanicalSystem mechanicalSys = null;
if (null != baseConnector && connectorSet.Size > 0)
{
    // create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir);
}
CopyVB.NET
' create a connector set for new mechanical system
Dim connectorSet As New ConnectorSet()
' Base equipment connector
Dim baseConnector As Connector = Nothing

' Select a Parallel Fan Powered VAV and some Supply Diffusers
' prior to running this example
Dim csi As ConnectorSetIterator = Nothing
Dim selection As ElementSet = uiDocument.Selection.Elements
For Each e As Element In selection
    If TypeOf e Is FamilyInstance Then
        Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
        Dim family As Family = fi.Symbol.Family
        ' Assume the selected Mechanical Equipment is the base equipment for new system
        If family.FamilyCategory.Name = "Mechanical Equipment" Then
            'Find the "Out" and "SupplyAir" connector on the base equipment
            If fi.MEPModel IsNot Nothing Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    Dim conn As Connector = TryCast(csi.Current, Connector)
                    If conn.Direction = FlowDirectionType.Out AndAlso conn.DuctSystemType = DuctSystemType.SupplyAir Then
                        baseConnector = conn
                        Exit While
                    End If
                End While
            End If
        ElseIf family.FamilyCategory.Name = "Air Terminals" Then
            ' add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
            csi.MoveNext()
            connectorSet.Insert(TryCast(csi.Current, Connector))
        End If
    End If
Next

Dim mechanicalSys As MechanicalSystem = Nothing
If baseConnector IsNot Nothing AndAlso connectorSet.Size > 0 Then
    ' create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input connectors parameter value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the ductSystemType parameter is out of permitted scope.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system. The owner of BaseConnector should be a mechanical equipment, and the owner of other connectors should be a mechanical equipment or air terminal.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the mechanical system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image] [image]

Revit 2011 API
Document..::.NewOpening Method
Document Class See Also Send Feedback
Creates a new opening.

Overload List

Name | Description
NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, eRefFace)

[image]

Revit 2011 API
Document..::.NewOpening Method (Element, CurveArray, eRefFace)
Document Class See Also Send Feedback
Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    eRefFace iFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    eRefFace iFace
)

Parameters

famInstElement
Type: Autodesk.Revit.DB..::.Element
host element of the opening, can be a beam, brace and column.
profile
Type: Autodesk.Revit.DB..::.CurveArray
profile of the opening.
iFace
Type: Autodesk.Revit.Creation..::.eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Boolean)

[image]

Revit 2011 API
Document..::.NewOpening Method (Element, CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::.Element
Host element of the opening, can be a roof,floor or ceiling.
profile
Type: Autodesk.Revit.DB..::.CurveArray
Profile of the opening.
bPerpendicularFace
Type: System..::.Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Level, Level, CurveArray)

[image]

Revit 2011 API
Document..::.NewOpening Method (Level, Level, CurveArray)
Document Class See Also Send Feedback
Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.DB..::.Level
bottom level
topLevel
Type: Autodesk.Revit.DB..::.Level
top level
profile
Type: Autodesk.Revit.DB..::.CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Wall, XYZ, XYZ)

[image]

Revit 2011 API
Document..::.NewOpening Method (Wall, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Type: Autodesk.Revit.DB..::.Wall
Host element of the opening.
pntStart
Type: Autodesk.Revit.DB..::.XYZ
One corner of the rectangle.
pntEnd
Type: Autodesk.Revit.DB..::.XYZ
The opposite corner of the rectangle.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewPathReinforcement Method

[image]

Revit 2011 API
Document..::.NewPathReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic (Declaration)
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement(
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Type: System..::.Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
PathReinforcement CreatePathReinforcement(Autodesk.Revit.DB.Document document, Wall wall)
{
    // Create a geometry line in the selected wall as the path
    CurveArray curves = new CurveArray();
    LocationCurve location = wall.Location as LocationCurve;
    XYZ start = location.Curve.get_EndPoint(0);
    XYZ end = location.Curve.get_EndPoint(1);
    curves.Append(document.Application.Create.NewLineBound(start, end));

    // Begin to create the path reinforcement
    PathReinforcement rein = document.Create.NewPathReinforcement(wall, curves, true);
    if (null == rein)
    {
        throw new Exception("Create path reinforcement failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Create path reinforcement succeed.");

    return rein;
}
CopyVB.NET
Function CreatePathReinforcement(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall) As Autodesk.Revit.DB.Structure.PathReinforcement
    ' Create a geometry line in the selected wall as the path
    Dim curves As New CurveArray()
    Dim location As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim start As Autodesk.Revit.DB.XYZ = location.Curve.EndPoint(0)
    Dim [end] As Autodesk.Revit.DB.XYZ = location.Curve.EndPoint(1)
    curves.Append(document.Application.Create.NewLineBound(start, [end]))

    ' Begin to create the path reinforcement
    Dim rein As Autodesk.Revit.DB.Structure.PathReinforcement = document.Create.NewPathReinforcement(wall, curves, True)
    If rein Is Nothing Then
        Throw New Exception("Create path reinforcement failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Create path reinforcement succeed.")

    Return rein
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPipe Method

[image] [image]

Revit 2011 API
Document..::.NewPipe Method
Document Class See Also Send Feedback
Adds a new pipe into the document.

Overload List

Name | Description
NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.
NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPipe Method (Connector, Connector, PipeType)

[image]

Revit 2011 API
Document..::.NewPipe Method (Connector, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Pipe NewPipe(
    Connector connector1,
    Connector connector2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    Connector^ connector1,
    Connector^ connector2,
    PipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, Connector, PipeType)

[image]

Revit 2011 API
Document..::.NewPipe Method (XYZ, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using a point, connector and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point,
    Connector connector,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point As XYZ, _
    connector As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point,
    Connector^ connector,
    PipeType^ pipeType
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The first point of the pipe.
connector
Type: Autodesk.Revit.DB..::.Connector
The connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument point or connector is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, XYZ, PipeType)

[image]

Revit 2011 API
Document..::.NewPipe Method (XYZ, XYZ, PipeType)
Document Class Example See Also Send Feedback
Adds a new pipe into the document, using two points and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point1,
    XYZ point2,
    PipeType pipeType
)
Visual Basic (Declaration)
Public Function NewPipe ( _
    point1 As XYZ, _
    point2 As XYZ, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point1,
    XYZ^ point2,
    PipeType^ pipeType
)

Parameters

point1
Type: Autodesk.Revit.DB..::.XYZ
The first point of the pipe.
point2
Type: Autodesk.Revit.DB..::.XYZ
The second point of the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::.PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Examples

CopyC#
public Pipe CreateNewPipe(Document document)
{
    // find a pipe type

    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(PipeType));
    PipeType pipeType = collector.FirstElement() as PipeType;

    Pipe pipe = null;
    if (null != pipeType)
    {
        // create pipe between 2 points
        XYZ p1 = new XYZ(0, 0, 0);
        XYZ p2 = new XYZ(10, 0, 0);

        pipe = document.Create.NewPipe(p1, p2, pipeType);
    }

    return pipe;
}
CopyVB.NET
Public Function CreateNewPipe(ByVal document As Document) As Pipe
    ' find a pipe type

    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(PipeType))
    Dim pipeType As PipeType = TryCast(collector.FirstElement(), PipeType)

    Dim pipe As Pipe = Nothing
    If pipeType IsNot Nothing Then
        ' create pipe between 2 points
        Dim p1 As New XYZ(0, 0, 0)
        Dim p2 As New XYZ(10, 0, 0)

        pipe = document.Create.NewPipe(p1, p2, pipeType)
    End If

    Return pipe
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument point1 or point2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipingSystem Method

[image]

Revit 2011 API
Document..::.NewPipingSystem Method
Document Class See Also Send Feedback
Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipingSystem NewPipingSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    PipeSystemType pipingSystemType
)
Visual Basic (Declaration)
Public Function NewPipingSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    pipingSystemType As PipeSystemType _
) As PipingSystem
Visual C++
public:
PipingSystem^ NewPipingSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    PipeSystemType pipingSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.DB..::.Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be nullNothingnullptra null reference (Nothing in Visual Basic). The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.DB..::.ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType
Type: Autodesk.Revit.DB.Plumbing..::.PipeSystemType
The System type.

Return Value

If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the connectors parameter value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the pipingSystemType parameter value is out of permitted scope.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the piping system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointBoundaryConditions Method

[image]

Revit 2011 API
Document..::.NewPointBoundaryConditions Method
Document Class Example See Also Send Feedback
Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Visual Basic (Declaration)
Public Function NewPointBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double, _
    Y_Rotation As TranslationRotationValue, _
    Y_RotationSpringModulus As Double, _
    Z_Rotation As TranslationRotationValue, _
    Z_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewPointBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A Geometry reference to a Beam's, Brace's or Column's analytical line end.
X_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::.Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring".
Y_Rotation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the option for rotation about the Y axis.
Y_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for Y axis. Ignored if Y_Rotation is not "Spring".
Z_Rotation
Type: Autodesk.Revit.DB.Structure..::.TranslationRotationValue
A value indicating the option for rotation about the Z axis.
Z_RotationSpringModulus
Type: System..::.Double
Rotation Spring Modulus for Z axis. Ignored if Y_Rotation is not "Spring".

Return Value

If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreatePointBoundaryCondition(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // Get the start point reference of the column
    Reference startReference = null;
    AnalyticalModel analyticalModel = column.GetAnalyticalModel() as AnalyticalModel;

    if (null != analyticalModel)
    {
        startReference = analyticalModel.GetCurve().get_EndPointReference(0);
    }
    else
    {
        throw new Exception("Cannot get end point for selected column");
    }

    // Get the Revit creation document
    Autodesk.Revit.Creation.Document docCreation = document.Create;

    // Create the Point Boundary Conditions for the start point
    BoundaryConditions condition = docCreation.NewPointBoundaryConditions(startReference,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0);
    if (null == condition)
    {
        throw new Exception("Can't create the point boundary condition for selected column start point.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Point boundary condition created successfully.");

    return (null != condition);
}
CopyVB.NET
Function CreatePointBoundaryCondition(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance) As Boolean
    ' Get the start point reference of the column
    Dim startReference As Reference = Nothing
    Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)

    If analyticalModel IsNot Nothing Then
        startReference = analyticalModel.GetCurve().EndPointReference(0)
    Else
        Throw New Exception("Cannot get end point for selected column")
    End If

    ' Get the Revit creation document
    Dim docCreation As Autodesk.Revit.Creation.Document = document.Create

    ' Create the Point Boundary Conditions for the start point
    Dim condition As BoundaryConditions = docCreation.NewPointBoundaryConditions(startReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0)
    If condition Is Nothing Then
        Throw New Exception("Can't create the point boundary condition for selected column start point.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Point boundary condition created successfully.")

    Return (condition IsNot Nothing)
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointLoad Method

[image] [image]

Revit 2011 API
Document..::.NewPointLoad Method
Document Class See Also Send Feedback
Creates a new point load within the project.

Overload List

Name | Description
NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
Type: Autodesk.Revit.DB..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.DB..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2011 API
Document..::.NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class Example See Also Send Feedback
Creates a new unhosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic (Declaration)
Public Function NewPointLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point of the PointLoad application.
force
Type: Autodesk.Revit.DB..::.XYZ
The 3d force.
moment
Type: Autodesk.Revit.DB..::.XYZ
The 3d moment.
isReaction
Type: System..::.Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::.PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.DB..::.SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
//Define the location at which the PointLoad is applied.
 XYZ point = new XYZ(0, 0, 4);
 //Define the 3d force.
 XYZ force = new XYZ(0, 0, -1);
 //Define the 3d moment.
 XYZ moment = new XYZ(0, 0, 0);
 //Set to True if you wish to create the reaction
 System.Boolean isReaction = true;

 PointLoad pointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, null, null);
CopyVB.NET
'Define the location at which the PointLoad is applied.
Dim point As New Autodesk.Revit.DB.XYZ(0, 0, 4)
'Define the 3d force.
Dim force As New Autodesk.Revit.DB.XYZ(0, 0, -1)
'Define the 3d moment.
Dim moment As New Autodesk.Revit.DB.XYZ(0, 0, 0)
'Set to True if you wish to create the reaction
Dim isReaction As System.Boolean = True

Dim pointLoad As Autodesk.Revit.DB.Structure.PointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, Nothing, Nothing)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewRebar Method

[image] [image]

Revit 2011 API
Document..::.NewRebar Method
Document Class See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Overload List

Name | Description
NewRebar(RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean) | Creates a new instance of a Rebar element within the project.
NewRebar(RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ) | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean)

[image]

Revit 2011 API
Document..::.NewRebar Method (RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, CurveArray, RebarHookOrientation, RebarHookOrientation, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Rebar NewRebar(
    RebarStyle style,
    RebarBarType rebarType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    CurveArray curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    style As RebarStyle, _
    rebarType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As CurveArray, _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
Rebar^ NewRebar(
    RebarStyle style,
    RebarBarType^ rebarType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    CurveArray^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

style
Type: Autodesk.Revit.DB.Structure..::.RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
rebarType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted before the first curve of the rebar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with NONE hook type.
endHook
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The element of RebarHookType that defines the hook angle and radius to be inserted after the last curve segment of the rebar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with NONE hook type.
host
Type: Autodesk.Revit.DB..::.Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
norm
Type: Autodesk.Revit.DB..::.XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: Autodesk.Revit.DB..::.CurveArray
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::.RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::.RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Type: System..::.Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns nullNothingnullptra null reference (Nothing in Visual Basic) or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Type: System..::.Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

If successful, NewRebar returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
 Rebar CreateRebar(Autodesk.Revit.DB.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
    // Define the rebar geometry information - Line rebar
    LocationPoint location = column.Location as LocationPoint;
    XYZ origin = location.Point;
    XYZ normal = new XYZ(1, 0, 0);
    XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
    Line rebarLine = document.Application.Create.NewLineBound(origin, rebarLineEnd);

    // Create the line rebar
    CurveArray curves = new CurveArray();
    curves.Append(rebarLine);

    Rebar rebar = document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, hookType, hookType,
                        column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);

    if (null != rebar)
    {
        // set specific layout for new rebar
        Parameter paramLayout = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE);
        paramLayout.Set(1); // 1 = Fixed Number
        Parameter paramNum = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS);
        paramNum.Set(10);
        rebar.ArrayLength = 1.5;
    }

    return rebar;
}
CopyVB.NET
Function CreateRebar(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance, _
                     ByVal barType As Autodesk.Revit.DB.Structure.RebarBarType, _
                     ByVal hookType As Autodesk.Revit.DB.Structure.RebarHookType) _
                     As Autodesk.Revit.DB.Structure.Rebar
    ' Define the rebar geometry information - Line rebar
    Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
    Dim origin As Autodesk.Revit.DB.XYZ = location.Point
    Dim normal As New Autodesk.Revit.DB.XYZ(1, 0, 0)
    Dim rebarLineEnd As New Autodesk.Revit.DB.XYZ(origin.X, origin.Y, origin.Z + 9)
    Dim rebarLine As Line = document.Application.Create.NewLineBound(origin, rebarLineEnd)

    ' Create the line rebar
    Dim curves As New CurveArray()
    curves.Append(rebarLine)

    Dim rebar As Autodesk.Revit.DB.Structure.Rebar = _
        document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, _
                                 hookType, hookType, column, origin, curves, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Right, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Left, True, True)

    If rebar IsNot Nothing Then
        ' set specific layout for new rebar
        Dim paramLayout As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE)
        paramLayout.[Set](1)
        ' 1 = Fixed Number
        Dim paramNum As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS)
        paramNum.[Set](10)
        rebar.ArrayLength = 1.5
    End If

    Return rebar
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewRebar Overload
Autodesk.Revit.Creation Namespace


NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)

[image]

Revit 2011 API
Document..::.NewRebar Method (RebarShape, RebarBarType, Element, XYZ, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Rebar NewRebar(
    RebarShape rebarShape,
    RebarBarType rebarType,
    Element host,
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Function NewRebar ( _
    rebarShape As RebarShape, _
    rebarType As RebarBarType, _
    host As Element, _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
) As Rebar
Visual C++
public:
Rebar^ NewRebar(
    RebarShape^ rebarShape,
    RebarBarType^ rebarType,
    Element^ host,
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

rebarShape
Type: Autodesk.Revit.DB.Structure..::.RebarShape
The shape type of the Rebar.
rebarType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The element of RebarBarType that defines bar diameter, bend radius and material of the rebar.
host
Type: Autodesk.Revit.DB..::.Element
The element to which the rebar belongs. The element must be a structural wall, floor, beam, brace, foundation or structural column.
origin
Type: Autodesk.Revit.DB..::.XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
Type: Autodesk.Revit.DB..::.XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
Type: Autodesk.Revit.DB..::.XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewRebar Overload
Autodesk.Revit.Creation Namespace


NewRebarBarType Method

[image]

Revit 2011 API
Document..::.NewRebarBarType Method
Document Class See Also Send Feedback
Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarType NewRebarBarType()
Visual Basic (Declaration)
Public Function NewRebarBarType As RebarBarType
Visual C++
public:
RebarBarType^ NewRebarBarType()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebarCoverType Method

[image]

Revit 2011 API
Document..::.NewRebarCoverType Method
Document Class See Also Send Feedback
Create a new instance of Rebar Cover Type, which defines the cover setting of the rebar host.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverType NewRebarCoverType(
    string name,
    double length
)
Visual Basic (Declaration)
Public Function NewRebarCoverType ( _
    name As String, _
    length As Double _
) As RebarCoverType
Visual C++
public:
RebarCoverType^ NewRebarCoverType(
    String^ name,
    double length
)

Parameters

name
Type: System..::.String
The not empty name for Rebar Cover Type.
length
Type: System..::.Double
The cover length of Rebar Cover Type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebarHookType Method

[image]

Revit 2011 API
Document..::.NewRebarHookType Method
Document Class See Also Send Feedback
Creates a new instance of Rebar Hook Type, which defines the hook style of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookType NewRebarHookType(
    double angle,
    double multiplier
)
Visual Basic (Declaration)
Public Function NewRebarHookType ( _
    angle As Double, _
    multiplier As Double _
) As RebarHookType
Visual C++
public:
RebarHookType^ NewRebarHookType(
    double angle,
    double multiplier
)

Parameters

angle
Type: System..::.Double
The bending angle of rebar hook.
multiplier
Type: System..::.Double
The extension multiplier of rebar hook.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRebarShape Method

[image]

Revit 2011 API
Document..::.NewRebarShape Method
Document Class See Also Send Feedback
Creates a new instance of a Rebar Shape, which defines the shape of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShape NewRebarShape()
Visual Basic (Declaration)
Public Function NewRebarShape As RebarShape
Visual C++
public:
RebarShape^ NewRebarShape()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method

[image] [image]

Revit 2011 API
Document..::.NewRoom Method
Document Class See Also Send Feedback
Creates a new room.

Overload List

Name | Description
NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
NewRoom(Level, UV) | Creates a new room on a level at a specified point.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRoom Method (Phase)

[image]

Revit 2011 API
Document..::.NewRoom Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Room, PlanCircuit)

[image]

Revit 2011 API
Document..::.NewRoom Method (Room, PlanCircuit)
Document Class Example See Also Send Feedback
Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom(
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::.Room
The room which you want to locate in the circuit. Pass nullNothingnullptra null reference (Nothing in Visual Basic) to create a new room.
circuit
Type: Autodesk.Revit.DB..::.PlanCircuit
The circuit in which you want to locate a room.

Return Value

If successful the room is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room InsertNewRoomInPlanCircuit(Autodesk.Revit.DB.Document document, Level level, Phase newConstructionPhase)
{
    // create room using Phase
    Room newScheduleRoom = document.Create.NewRoom(newConstructionPhase);

    // set the Room Number and Name
    string newRoomNumber = "101";
    string newRoomName = "Class Room 1";
    newScheduleRoom.Name = newRoomName;
    newScheduleRoom.Number = newRoomNumber;

    // Get a PlanCircuit
    PlanCircuit planCircuit = null;
    // first get the plan topology for given level
    PlanTopology planTopology = document.get_PlanTopology(level);

    // Iterate circuits in this plan topology
    foreach (PlanCircuit circuit in planTopology.Circuits)
    {
        // get the first circuit we find
        if (null != circuit)
        {
            planCircuit = circuit;
            break;
        }
    }

    Room newRoom2 = null;
    if (null != planCircuit)
    {
        Transaction transaction = new Transaction(document, "Create Room");
        if (transaction.Start() == TransactionStatus.Started)
        {
            // The input room must exist only in the room schedule,
            // meaning that it does not display in any plan view.
            newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit);
            // a model room with the same name and number is created in the
            // view where the PlanCircuit is located
            if (null != newRoom2)
            {
                // Give the user some information
                TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.");
            }
            transaction.Commit();
        }
    }

    return newRoom2;
}
CopyVB.NET
Function InsertNewRoomInPlanCircuit(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal newConstructionPhase As Phase) As Room
    ' create room using Phase
    Dim newScheduleRoom As Room = document.Create.NewRoom(newConstructionPhase)

    ' set the Room Number and Name
    Dim newRoomNumber As String = "101"
    Dim newRoomName As String = "Class Room 1"
    newScheduleRoom.Name = newRoomName
    newScheduleRoom.Number = newRoomNumber

    ' Get a PlanCircuit
    Dim planCircuit As PlanCircuit = Nothing
    ' first get the plan topology for given level
    Dim planTopology As PlanTopology = document.PlanTopology(level)

    ' Iterate circuits in this plan topology
    For Each circuit As PlanCircuit In planTopology.Circuits
        ' get the first circuit we find
        If circuit IsNot Nothing Then
            planCircuit = circuit
            Exit For
        End If
    Next

    Dim newRoom2 As Room = Nothing
    If planCircuit IsNot Nothing Then
        Dim transaction As New Transaction(document, "Create Room")
        If transaction.Start() = TransactionStatus.Started Then
            ' The input room must exist only in the room schedule,
            ' meaning that it does not display in any plan view.
            newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit)
            ' a model room with the same name and number is created in the
            ' view where the PlanCircuit is located
            If newRoom2 IsNot Nothing Then
                ' Give the user some information
                TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.")
            End If
            transaction.Commit()
        End If
    End If

    Return newRoom2
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the existing room is already placed.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Level, UV)

[image]

Revit 2011 API
Document..::.NewRoom Method (Level, UV)
Document Class Example See Also Send Feedback
Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point that dictates the location of the room on that specified level.

Return Value

If successful a the new room will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room CreateRoom(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a UV structure which determines the room location
   UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
CopyVB.NET
Function CreateRoom(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New Autodesk.Revit.DB.UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoomBoundaryLines Method

[image]

Revit 2011 API
Document..::.NewRoomBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewRoomBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::.CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::.View
The View for the new Room

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method

[image] [image]

Revit 2011 API
Document..::.NewRooms Method
Document Class See Also Send Feedback
Creates one or more rooms.

Overload List

Name | Description
NewRooms(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
NewRooms(List<(Of <(RoomCreationData>)>)) | Creates new rooms using the specified placement data.
NewRooms(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
NewRooms(Phase, Int32) | Creates new unplaced rooms in the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRooms Method (Level)

[image]

Revit 2011 API
Document..::.NewRooms Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level from which the circuits are found.

Return Value

If successful an Element set which contain the rooms created should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (List(RoomCreationData))

[image]

Revit 2011 API
Document..::.NewRooms Method (List<(Of <(RoomCreationData>)>))
Document Class See Also Send Feedback
Creates new rooms using the specified placement data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RoomCreationData >)>)
A list of RoomCreationData which wraps the creation arguments of the rooms to be created.

Return Value

If successful an ElementSet contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | One or more of the RoomCreationData's level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | The relevant room tag is not created successfully, or regeneration fails at the end of the batch creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Level, Phase)

[image]

Revit 2011 API
Document..::.NewRooms Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.DB..::.Phase
The phase on which the room is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Phase, Int32)

[image]

Revit 2011 API
Document..::.NewRooms Method (Phase, Int32)
Document Class See Also Send Feedback
Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewRooms(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase on which the rooms are to exist.
count
Type: System..::.Int32
The number of the rooms to be created.

Return Value

If successful an Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRoomTag Method

[image]

Revit 2011 API
Document..::.NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::.Room
The Room which the tag refers.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point that dictates the location on the level of the room.
view
Type: Autodesk.Revit.DB..::.View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.DB.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
   UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    RoomTag roomTag = document.Create.NewRoomTag(room, roomTagLocation, null);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Room tag created successfully.");

    return roomTag;
}
CopyVB.NET
Function CreateRoomTag(ByVal document As Autodesk.Revit.DB.Document, ByVal room As Room) As Autodesk.Revit.DB.Architecture.RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New Autodesk.Revit.DB.UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomTag As Autodesk.Revit.DB.Architecture.RoomTag = document.Create.NewRoomTag(room, roomTagLocation, Nothing)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Room tag created successfully.")

    Return roomTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2011 API
Document..::.NewSketchPlane Method
Document Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlab Method

[image]

Revit 2011 API
Document..::.NewSlab Method
Document Class See Also Send Feedback
Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Floor NewSlab(
    CurveArray profile,
    Level level,
    Line slopedArrow,
    double slope,
    bool isStructural
)
Visual Basic (Declaration)
Public Function NewSlab ( _
    profile As CurveArray, _
    level As Level, _
    slopedArrow As Line, _
    slope As Double, _
    isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab(
    CurveArray^ profile,
    Level^ level,
    Line^ slopedArrow,
    double slope,
    bool isStructural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the horizontal profile of the slab.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the slab is to be placed.
slopedArrow
Type: Autodesk.Revit.DB..::.Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Type: System..::.Double
The slope.
isStructural
Type: System..::.Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlabEdge Method

[image] [image]

Revit 2011 API
Document..::.NewSlabEdge Method
Document Class See Also Send Feedback
Creates a slab edge.

Overload List

Name | Description
NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, Reference)

[image]

Revit 2011 API
Document..::.NewSlabEdge Method (SlabEdgeType, Reference)
Document Class See Also Send Feedback
Creates a slab edge along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    reference As Reference _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.DB..::.SlabEdgeType
The type of the slab edge to create
reference
Type: Autodesk.Revit.DB..::.Reference
A planar line or arc that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, ReferenceArray)

[image]

Revit 2011 API
Document..::.NewSlabEdge Method (SlabEdgeType, ReferenceArray)
Document Class See Also Send Feedback
Creates a slab edge along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.DB..::.SlabEdgeType
The type of the slab edge to create
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSpace Method

[image] [image]

Revit 2011 API
Document..::.NewSpace Method
Document Class See Also Send Feedback
Creates a new space.

Overload List

Name | Description
NewSpace(Phase) | Creates a new unplaced space on a given phase.
NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpace Method (Phase)

[image]

Revit 2011 API
Document..::.NewSpace Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced space on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the space is to exist.

Return Value

If successful the new space should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, UV)

[image]

Revit 2011 API
Document..::.NewSpace Method (Level, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level on which the space is to exist.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point that dictates the location on that specified level.

Return Value

If successful the new space element is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, Phase, UV)

[image]

Revit 2011 API
Document..::.NewSpace Method (Level, Phase, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic (Declaration)
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level on which the room is to exist.
phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the room is to exist.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when level, phase or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpaceBoundaryLines Method

[image]

Revit 2011 API
Document..::.NewSpaceBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::.CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::.View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaces Method

[image] [image]

Revit 2011 API
Document..::.NewSpaces Method
Document Class See Also Send Feedback
Creates one or more spaces.

Overload List

Name | Description
NewSpaces(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
NewSpaces(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces Method (Phase, Int32)

[image]

Revit 2011 API
Document..::.NewSpaces Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the spaces are to exist.
count
Type: System..::.Int32

Return Value

If successful, a set if new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaces Method (Level, Phase, View)

[image]

Revit 2011 API
Document..::.NewSpaces Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
public:
ElementSet^ NewSpaces(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.DB..::.Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.DB..::.View
The view on which the space tags for the spaces are to display.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaceTag Method

[image]

Revit 2011 API
Document..::.NewSpaceTag Method
Document Class See Also Send Feedback
Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic (Declaration)
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Type: Autodesk.Revit.DB.Mechanical..::.Space
The Space which the tag refers.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.DB..::.View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotCoordinate Method

[image]

Revit 2011 API
Document..::.NewSpotCoordinate Method
Document Class See Also Send Feedback
Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the spot coordinate is to be visible.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference to which the spot coordinate is to be bound.
origin
Type: Autodesk.Revit.DB..::.XYZ
The point which the spot coordinate evaluate.
bend
Type: Autodesk.Revit.DB..::.XYZ
The bend point for the spot coordinate.
end
Type: Autodesk.Revit.DB..::.XYZ
The end point for the spot coordinate.
refPt
Type: Autodesk.Revit.DB..::.XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Type: System..::.Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotElevation Method

[image]

Revit 2011 API
Document..::.NewSpotElevation Method
Document Class See Also Send Feedback
Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic (Declaration)
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the spot elevation is to be visible.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference to which the spot elevation is to be bound.
origin
Type: Autodesk.Revit.DB..::.XYZ
The point which the spot elevation evaluate.
bend
Type: Autodesk.Revit.DB..::.XYZ
The bend point for the spot elevation.
end
Type: Autodesk.Revit.DB..::.XYZ
The end point for the spot elevation.
refPt
Type: Autodesk.Revit.DB..::.XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Type: System..::.Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTag Method

[image]

Revit 2011 API
Document..::.NewTag Method
Document Class Example See Also Send Feedback
Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ pnt
)
Visual Basic (Declaration)
Public Function NewTag ( _
    dbview As View, _
    elemToTag As Element, _
    addLeader As Boolean, _
    tagMode As TagMode, _
    tagOrientation As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag(
    View^ dbview,
    Element^ elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ^ pnt
)

Parameters

dbview
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
elemToTag
Type: Autodesk.Revit.DB..::.Element
The host object of tag.
addLeader
Type: System..::.Boolean
Whether there will be a leader.
tagMode
Type: Autodesk.Revit.DB..::.TagMode
The mode of the tag. Add by Category, add by Multi-Category, or add by material.
tagOrientation
Type: Autodesk.Revit.DB..::.TagOrientation
The orientation of the tag.
pnt
Type: Autodesk.Revit.DB..::.XYZ
The position of the tag.

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms a tag relationship to the host object.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.DB.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.DB.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.TAG_HORIZONTAL;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.get_EndPoint(0);
    XYZ wallEnd = wallLoc.Curve.get_EndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);

    IndependentTag newTag = document.Create.NewTag(view, wall, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.get_Parameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.LeaderElbow = elbowPnt;
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall) As IndependentTag
    ' make sure active view is not a 3D view
    Dim view As Autodesk.Revit.DB.View = document.ActiveView

    ' define tag mode and tag orientation for new tag
    Dim tagMode As TagMode = tagMode.TM_ADDBY_CATEGORY
    Dim tagorn As TagOrientation = TagOrientation.TAG_HORIZONTAL

    ' Add the tag to the middle of the wall
    Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim wallStart As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(0)
    Dim wallEnd As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(1)
    Dim wallMid As Autodesk.Revit.DB.XYZ = wallLoc.Curve.Evaluate(0.5, True)

    Dim newTag As IndependentTag = document.Create.NewTag(view, wall, True, tagMode, tagorn, wallMid)
    If newTag Is Nothing Then
        Throw New Exception("Create IndependentTag Failed.")
    End If

    ' newTag.TagText is read-only, so we change the Type Mark type parameter to
    ' set the tag text.  The label parameter for the tag family determines
    ' what type parameter is used for the tag text.

    Dim type As WallType = wall.WallType

    Dim foundParameter As Parameter = type.Parameter("Type Mark")
    Dim result As Boolean = foundParameter.[Set]("Hello")

    ' set leader mode free
    ' otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE
    Dim elbowPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(5, 5, 0)
    newTag.LeaderElbow = elbowPnt
    Dim headerPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(10, 10, 0)
    newTag.TagHeadPosition = headerPnt

    Return newTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTakeoffFitting Method

[image]

Revit 2011 API
Document..::.NewTakeoffFitting Method
Document Class See Also Send Feedback
Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewTakeoffFitting(
    Connector connector,
    MEPCurve curve
)
Visual Basic (Declaration)
Public Function NewTakeoffFitting ( _
    connector As Connector, _
    curve As MEPCurve _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTakeoffFitting(
    Connector^ connector,
    MEPCurve^ curve
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
The connector to be connected to the takeoff.
curve
Type: Autodesk.Revit.DB..::.MEPCurve
The duct or pipe which is the trunk for the takeoff.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connector and the curve cannot be used for takeoff creation. For example, they must be of the same domain, the curve must be a duct or pipe, and the owner of the connector should be (flex) duct or pipe.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when takeoff fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTeeFitting Method

[image]

Revit 2011 API
Document..::.NewTeeFitting Method
Document Class See Also Send Feedback
Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewTeeFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic (Declaration)
Public Function NewTeeFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTeeFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the tee.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the tee.
connector3
Type: Autodesk.Revit.DB..::.Connector
The third connector to be connected to the tee. This should be connected to the branch of the tee.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when tee fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2011 API
Document..::.NewTextNote Method
Document Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewTopographySurface Method

[image]

Revit 2011 API
Document..::.NewTopographySurface Method
Document Class See Also Send Feedback
Creates a new TopographySurface element in the document, and initializes it with a set of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TopographySurface NewTopographySurface(
    IList<XYZ> points
)
Visual Basic (Declaration)
Public Function NewTopographySurface ( _
    points As IList(Of XYZ) _
) As TopographySurface
Visual C++
public:
TopographySurface^ NewTopographySurface(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
An array of initial points for the surface.

Return Value

The TopographySurface element.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when input argument 'points' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when points.Size is less than 3, to create a TopographySurface needs at least 3 points.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTransitionFitting Method

[image]

Revit 2011 API
Document..::.NewTransitionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewTransitionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewTransitionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTransitionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the transition.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the transition.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connectors cannot be used for transition creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when transition fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTruss Method

[image]

Revit 2011 API
Document..::.NewTruss Method
Document Class Example See Also Send Feedback
Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve,
    View dbView
)
Visual Basic (Declaration)
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve, _
    dbView As View _
) As Truss
Visual C++
public:
Truss^ NewTruss(
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve,
    View^ dbView
)

Parameters

trussType
Type: Autodesk.Revit.DB.Structure..::.TrussType
The type for truss.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane where the truss is going to reside. It could be nullNothingnullptra null reference (Nothing in Visual Basic).
baseCurve
Type: Autodesk.Revit.DB..::.Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, and must be within the sketch plane if sketchPlane is valid.
dbView
Type: Autodesk.Revit.DB..::.View
The DBView where the truss's tag will be placed. A valid dbViewId must be a Plan view, an RPlan view, or an elevation view parallel to the truss base curve.

Examples

CopyC#
Truss CreateTruss(Autodesk.Revit.DB.Document document,
    FamilyInstance column1, FamilyInstance column2)
{
    Truss truss = null;
    Transaction transaction = new Transaction(document, "Add Truss");
    if (transaction.Start() == TransactionStatus.Started)
    {
        //sketchPlane
        XYZ origin = new XYZ(0, 0, 0);
        XYZ xDirection = new XYZ(1, 0, 0);
        XYZ yDirection = new XYZ(0, 1, 0);
        Plane plane = document.Application.Create.NewPlane(xDirection, yDirection, origin);
        SketchPlane sketchPlane = document.Create.NewSketchPlane(plane);

        //new base Line - use line that spans two selected columns
        AnalyticalModel frame1 = column1.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint1 = (frame1.GetCurve() as Line).get_EndPoint(0);

        AnalyticalModel frame2 = column2.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint2 = (frame2.GetCurve() as Line).get_EndPoint(0);

        XYZ startPoint = new XYZ(centerPoint1.X, centerPoint1.Y, 0);
        XYZ endPoint = new XYZ(centerPoint2.X, centerPoint2.Y, 0);
        Autodesk.Revit.DB.Line baseLine = null;

        try
        {
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint);
        }
        catch (System.ArgumentException)
        {
            throw new Exception("Selected columns are too close to create truss.");
        }

        // use the active view for where the truss's tag will be placed; View used in
        // NewTruss should be plan or elevation view parallel to the truss's base line
        Autodesk.Revit.DB.View view = document.ActiveView;

        // Get a truss type for the truss
        TrussType trussType = null;
        foreach (TrussType currentType in document.TrussTypes)
        {
            if (null != currentType)
            {
                trussType = currentType;
                break;
            }
        }

        if (null != trussType)
        {
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view);
            transaction.Commit();
        }
        else
        {
            transaction.RollBack();
            throw new Exception("No truss types found in document.");
        }
    }

    return truss;
}
CopyVB.NET
Function CreateTruss(ByVal document As Autodesk.Revit.DB.Document, ByVal column1 As Autodesk.Revit.DB.FamilyInstance, ByVal column2 As Autodesk.Revit.DB.FamilyInstance) As Truss
    Dim truss As Truss = Nothing
    Dim transaction As New Transaction(document, "Add Truss")
    If transaction.Start() = TransactionStatus.Started Then
        'sketchPlane
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim xDirection As New Autodesk.Revit.DB.XYZ(1, 0, 0)
        Dim yDirection As New Autodesk.Revit.DB.XYZ(0, 1, 0)
        Dim plane As Plane = document.Application.Create.NewPlane(xDirection, yDirection, origin)
        Dim sketchPlane As SketchPlane = document.Create.NewSketchPlane(plane)

        'new base Line - use line that spans two selected columns
        Dim frame1 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column1.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint1 As Autodesk.Revit.DB.XYZ = (TryCast(frame1.GetCurve(), Line)).EndPoint(0)

        Dim frame2 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column2.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint2 As Autodesk.Revit.DB.XYZ = (TryCast(frame2.GetCurve(), Line)).EndPoint(0)

        Dim startPoint As New Autodesk.Revit.DB.XYZ(centerPoint1.X, centerPoint1.Y, 0)
        Dim endPoint As New Autodesk.Revit.DB.XYZ(centerPoint2.X, centerPoint2.Y, 0)
        Dim baseLine As Autodesk.Revit.DB.Line = Nothing

        Try
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint)
        Catch generatedExceptionName As System.ArgumentException
            Throw New Exception("Selected columns are too close to create truss.")
        End Try

        ' use the active view for where the truss's tag will be placed; View used in
        ' NewTruss should be plan or elevation view parallel to the truss's base line
        Dim view As Autodesk.Revit.DB.View = document.ActiveView

        ' Get a truss type for the truss
        Dim trussType As TrussType = Nothing
        For Each currentType As TrussType In document.TrussTypes
            If currentType IsNot Nothing Then
                trussType = currentType
                Exit For
            End If
        Next

        If trussType IsNot Nothing Then
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view)
            transaction.Commit()
        Else
            transaction.RollBack()
            Throw New Exception("No truss types found in document.")
        End If
    End If

    Return truss
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewUnionFitting Method

[image]

Revit 2011 API
Document..::.NewUnionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic (Declaration)
Public Function NewUnionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::.Connector
The first connector to be connected to the union.
connector2
Type: Autodesk.Revit.DB..::.Connector
The second connector to be connected to the union.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when union fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewDrafting Method

[image]

Revit 2011 API
Document..::.NewViewDrafting Method
Document Class Example See Also Send Feedback
Creates a new drafting view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewDrafting NewViewDrafting()
Visual Basic (Declaration)
Public Function NewViewDrafting As ViewDrafting
Visual C++
public:
ViewDrafting^ NewViewDrafting()

Return Value

The newly created drafting view.

Examples

CopyC#
// Create a new ViewDrafting instance
ViewDrafting view = document.Create.NewViewDrafting();
view.ViewName = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;

// Use current view as template
view.ApplyTemplate(document.ActiveView);
CopyVB.NET
' Create a new ViewDrafting instance
Dim view As ViewDrafting = document.Create.NewViewDrafting()
view.ViewName = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New Autodesk.Revit.DB.XYZ(100, 100, 50)
boundingBox.Min = New Autodesk.Revit.DB.XYZ(-100, -100, -50)
view.CropBox = boundingBox

' Use current view as template
view.ApplyTemplate(document.ActiveView)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewSheet Method

[image]

Revit 2011 API
Document..::.NewViewSheet Method
Document Class Example See Also Send Feedback
Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic (Declaration)
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet(
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
Type: Autodesk.Revit.DB..::.FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

Examples

CopyC#
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    FamilySymbolSet fsSet = document.TitleBlocks;
    if (fsSet.Size == 0)
    {
        throw new Exception("No title blocks");
    }

    FamilySymbol fs = null;
    foreach (FamilySymbol f in fsSet)
    {
        if (null != f)
        {
            fs = f;
            break;
        }
    }

    // Create a sheet view
    ViewSheet viewSheet = document.Create.NewViewSheet(fs);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                         (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

    viewSheet.AddView(view3D, location);

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
       TaskDialog taskDialog = new TaskDialog("Revit");
       taskDialog.MainContent = "Print the sheet?";
       TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
       taskDialog.CommonButtons = buttons;
       TaskDialogResult result = taskDialog.Show();

        if (result == TaskDialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
CopyVB.NET
Private Sub CreateSheetView(ByVal document As Autodesk.Revit.DB.Document, ByVal view3D As View3D)

    ' Get an available title block from document
    Dim fsSet As FamilySymbolSet = document.TitleBlocks
    If fsSet.Size = 0 Then
        Throw New Exception("No title blocks")
    End If

    Dim fs As FamilySymbol = Nothing
    For Each f As FamilySymbol In fsSet
        If f IsNot Nothing Then
            fs = f
            Exit For
        End If
    Next

    ' Create a sheet view
    Dim viewSheet As ViewSheet = document.Create.NewViewSheet(fs)
    If viewSheet Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    Dim location As New Autodesk.Revit.DB.UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2, (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2)

    viewSheet.AddView(view3D, location)

    ' Print the sheet out
    If viewSheet.CanBePrinted Then
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = "Print the sheet?"
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()

        If result = TaskDialogResult.Yes Then
            viewSheet.Print()
        End If
    End If
End Sub

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method

[image] [image]

Revit 2011 API
Document..::.NewWall Method
Document Class See Also Send Feedback
Creates a new wall within the project.

Overload List

Name | Description
NewWall(CurveArray, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
NewWall(Curve, Level, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
NewWall(CurveArray, WallType, Level, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, Boolean)

[image]

Revit 2011 API
Document..::.NewWall Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, Level, Boolean)

[image]

Revit 2011 API
Document..::.NewWall Method (Curve, Level, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Create a wall using the location line
    return document.Create.NewWall(geomLine, level, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Create a wall using the location line
    Return document.Create.NewWall(geomLine, level, True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2011 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingProfile(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    CurveArray profile = new CurveArray();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return document.Create.NewWall(profile, wallType, level, true, normal);
}
CopyVB.NET
Public Function CreateWallUsingProfile(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal wallType As WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.DB.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.DB.XYZ(20, 0, 15)
    Dim fourth As New Autodesk.Revit.DB.XYZ(0, 0, 15)
    Dim profile As New CurveArray()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    Dim normal As New Autodesk.Revit.DB.XYZ(0, 1, 0)

    ' Create a wall
    Return document.Create.NewWall(profile, wallType, level, True, normal)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2011 API
Document..::.NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wall NewWall(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Function NewWall ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
Wall^ NewWall(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall other than the default height.
offset
Type: System..::.Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve2(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return document.Create.NewWall(geomLine, wallType, level, height, offset, true, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve2(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal wallType As WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return document.Create.NewWall(geomLine, wallType, level, height, offset, True, _
     True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWalls Method

[image] [image]

Revit 2011 API
Document..::.NewWalls Method
Document Class See Also Send Feedback
Creates walls within the project.

Overload List

Name | Description
NewWalls(List<(Of <(ProfiledWallCreationData>)>)) | Creates profile walls within the project.
NewWalls(List<(Of <(RectangularWallCreationData>)>)) | Creates rectangular walls within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWalls Method (List(ProfiledWallCreationData))

[image]

Revit 2011 API
Document..::.NewWalls Method (List<(Of <(ProfiledWallCreationData>)>))
Document Class See Also Send Feedback
Creates profile walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( ProfiledWallCreationData >)>)
A list of ProfiledWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If ProfiledWallCreationData's profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWalls Method (List(RectangularWallCreationData))

[image]

Revit 2011 API
Document..::.NewWalls Method (List<(Of <(RectangularWallCreationData>)>))
Document Class See Also Send Feedback
Creates rectangular walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewWalls(
    List<RectangularWallCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewWalls ( _
    dataList As List(Of RectangularWallCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewWalls(
    List<RectangularWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( RectangularWallCreationData >)>)
A list of RectangularWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Either of 'curve', 'wallType', 'level' or 'height' is less than 0, or the 'curve' is not horizontal, or the neither of the curve's type is CURVE_TYPE_LINE or CURVE_TYPE_ARC.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWire Method

[image]

Revit 2011 API
Document..::.NewWire Method
Document Class See Also Send Feedback
Creates a new wire element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Wire NewWire(
    Curve curve,
    View view,
    Connector startConnector,
    Connector endConnector,
    WireType wireType,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWire ( _
    curve As Curve, _
    view As View, _
    startConnector As Connector, _
    endConnector As Connector, _
    wireType As WireType, _
    wiringType As WiringType _
) As Wire
Visual C++
public:
Wire^ NewWire(
    Curve^ curve,
    View^ view,
    Connector^ startConnector,
    Connector^ endConnector,
    WireType^ wireType,
    WiringType wiringType
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The base line of the wire.
view
Type: Autodesk.Revit.DB..::.View
The view in which the wire is to be visible.
startConnector
Type: Autodesk.Revit.DB..::.Connector
The connector which connects with the start point connector of wire, if it is nullNothingnullptra null reference (Nothing in Visual Basic), the start point connects with nothing.
endConnector
Type: Autodesk.Revit.DB..::.Connector
The connector which connects with the end point connector of wire, if it is nullNothingnullptra null reference (Nothing in Visual Basic), the end point connects with nothing.
wireType
Type: Autodesk.Revit.DB.Electrical..::.WireType
Specify wire type of new created wire.
wiringType
Type: Autodesk.Revit.DB.Electrical..::.WiringType
Specify wiring type(Arc or chamfer) of new created wire.

Return Value

If successful a new wire element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | An InvalidOperationException will to be thrown when Revit MEP product is unavailable.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewZone Method

[image]

Revit 2011 API
Document..::.NewZone Method
Document Class See Also Send Feedback
Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic (Declaration)
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.DB..::.Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Properties

[image] [image]

Revit 2011 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


eRefFace Enumeration

[image]

Revit 2011 API
eRefFace Enumeration
See Also Send Feedback
Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum eRefFace
Visual Basic (Declaration)
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class

[image]

Revit 2011 API
FamilyInstanceCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic (Declaration)
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.FamilyInstanceCreationData

See Also

FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Members

[image] [image]

Revit 2011 API
FamilyInstanceCreationData Members
FamilyInstanceCreationData Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Constructors

Name | Description
FamilyInstanceCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Axis | Get or set the axis of the FamilyInstance
RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor

[image] [image]

Revit 2011 API
FamilyInstanceCreationData Constructor
FamilyInstanceCreationData Class See Also Send Feedback

Overload List

Name | Description
FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
Specify if the family instance is structural.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Sub New ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.DB..::.Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2011 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Methods

[image] [image]

Revit 2011 API
FamilyInstanceCreationData Methods
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties

[image] [image]

Revit 2011 API
FamilyInstanceCreationData Properties
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Properties

Name | Description
Axis | Get or set the axis of the FamilyInstance
RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


Axis Property

[image]

Revit 2011 API
FamilyInstanceCreationData..::.Axis Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Line Axis { get; set; }
Visual Basic (Declaration)
Public Property Axis As Line
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


RotateAngle Property

[image]

Revit 2011 API
FamilyInstanceCreationData..::.RotateAngle Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double RotateAngle { get; set; }
Visual Basic (Declaration)
Public Property RotateAngle As Double
Visual C++
public:
property double RotateAngle {
    double get ();
    void set (double value);
}

Remarks

The FamilyInstance will rotate this angle when the instance is created.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Class

[image]

Revit 2011 API
FamilyItemFactory Class
Members See Also Send Feedback
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic (Declaration)
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Members

[image] [image]

Revit 2011 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Methods

[image] [image]

Revit 2011 API
FamilyItemFactory Methods
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
NewAngularDimension | Overloaded. Creates a new angular dimension object.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewArcLengthDimension | Overloaded. Creates a new arc length dimension object.
NewBlend | Add a new Blend instance into the Autodesk Revit family document.
NewControl | Add a new control into the Autodesk Revit family document.
NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
NewDimension | Overloaded. Creates a new linear dimension object.
NewDividedSurface | Create a DividedSurface element on one surface of another element.
NewDuctConnector | Add a new duct connector into the Autodesk Revit family document.
NewElectricalConnector | Add a new Electrical connector into the Autodesk Revit family document.
NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
NewLinearDimension | Overloaded. Creates a new linear dimension object.
NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
NewModelText | Create a model text in the Autodesk Revit family document.
NewOpening | Create an opening to cut the wall or ceiling.
NewPipeConnector | Add a new pipe connector into the Autodesk Revit family document.
NewRadialDimension | Overloaded. Creates a new radial dimension object.
NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
NewReferencePoint | Overloaded. Creates a reference point.
NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewSweep | Overloaded. Adds a new sweep form to the family document.
NewSweptBlend | Overloaded. Adds a new swept blend into the family document.
NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
NewView3D | Creates a new 3D view. (Inherited from ItemFactoryBase.)
NewViewPlan | Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
NewViewSection | Creates a new section view. (Inherited from ItemFactoryBase.)
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewAngularDimension Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewAngularDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object.

Overload List

Name | Description
NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference)

[image]

Revit 2011 API
FamilyItemFactory..::.NewAngularDimension Method (View, Arc, Reference, Reference)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef
)
Visual Basic (Declaration)
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::.Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::.Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::.Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)

[image]

Revit 2011 API
FamilyItemFactory..::.NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::.Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::.Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::.Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType
Type: Autodesk.Revit.DB..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewArcLengthDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object.

Overload List

Name | Description
NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)

[image]

Revit 2011 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)
FamilyItemFactory Class Example See Also Send Feedback
Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 2, 0), true);
    Line gLine2 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 4, 0), true);
    Arc arctoDim = appCreate.NewArc(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = appCreate.NewArc(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
CopyVB.NET
Public Function CreateArcDimension(ByVal document As Document, ByVal sketchPlane As SketchPlane) As Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = appCreate.NewLine(New Autodesk.Revit.DB.XYZ(0, 2, 0), New Autodesk.Revit.DB.XYZ(2, 2, 0), True)
    Dim gLine2 As Line = appCreate.NewLine(New Autodesk.Revit.DB.XYZ(0, 2, 0), New Autodesk.Revit.DB.XYZ(2, 4, 0), True)
    Dim arctoDim As Arc = appCreate.NewArc(New Autodesk.Revit.DB.XYZ(1, 2, 0), New Autodesk.Revit.DB.XYZ(-1, 2, 0), New Autodesk.Revit.DB.XYZ(0, 3, 0))
    Dim arcofDim As Arc = appCreate.NewArc(New Autodesk.Revit.DB.XYZ(0, 3, 0), New Autodesk.Revit.DB.XYZ(1, 2, 0), New Autodesk.Revit.DB.XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)

[image]

Revit 2011 API
FamilyItemFactory..::.NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::.Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::.Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::.Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::.Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.DB..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewBlend Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewBlend Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Blend instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Blend NewBlend(
    bool isSolid,
    CurveArray topProfile,
    CurveArray baseProfile,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewBlend ( _
    isSolid As Boolean, _
    topProfile As CurveArray, _
    baseProfile As CurveArray, _
    sketchPlane As SketchPlane _
) As Blend
Visual C++
public:
Blend^ NewBlend(
    bool isSolid,
    CurveArray^ topProfile,
    CurveArray^ baseProfile,
    SketchPlane^ sketchPlane
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Blend is Solid or Void.
topProfile
Type: Autodesk.Revit.DB..::.CurveArray
The top blend section. It should consist of only one curve loop. The input profile must be in one plane.
baseProfile
Type: Autodesk.Revit.DB..::.CurveArray
The base blend section. It should consist of only one curve loop. The input profile must be in one plane.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the base profile. Use this to associate the base of the blend to geometry from another element. Optional, it can be nullNothingnullptra null reference (Nothing in Visual Basic) if you want Revit to derive a new sketch plane from the geometry of the base profile.

Return Value

If creation was successful the new blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a blend in a family document. The blend will be extended between the two independent pieces of geometry. Revit will determine an appropriate default mapping for the vertices of the two profiles. The two input profiles must be parallel. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the blend.

Examples

CopyC#
private Blend CreateBlend(UIApplication application, SketchPlane sketchPlane)
{
    Blend blend = null;

    // make sure we have a family document
    Document familyDocument = application.ActiveUIDocument.Document;
    if (true == familyDocument.IsFamilyDocument)
    {
        // Define top and base profiles for the blend
        CurveArray topProfile = new CurveArray();
        CurveArray baseProfile = new CurveArray();

        // create rectangular base profile
        XYZ p00 = XYZ.Zero;
        XYZ p01 = new XYZ(10, 0, 0);
        XYZ p02 = new XYZ(10, 10, 0);
        XYZ p03 = new XYZ(0, 10, 0);
        Line line01 = application.Application.Create.NewLineBound(p00, p01);
        Line line02 = application.Application.Create.NewLineBound(p01, p02);
        Line line03 = application.Application.Create.NewLineBound(p02, p03);
        Line line04 = application.Application.Create.NewLineBound(p03, p00);

        baseProfile.Append(line01);
        baseProfile.Append(line02);
        baseProfile.Append(line03);
        baseProfile.Append(line04);

        // create rectangular top profile
        XYZ p10 = new XYZ(5, 2, 10);
        XYZ p11 = new XYZ(8, 5, 10);
        XYZ p12 = new XYZ(5, 8, 10);
        XYZ p13 = new XYZ(2, 5, 10);
        Line line11 = application.Application.Create.NewLineBound(p10, p11);
        Line line12 = application.Application.Create.NewLineBound(p11, p12);
        Line line13 = application.Application.Create.NewLineBound(p12, p13);
        Line line14 = application.Application.Create.NewLineBound(p13, p10);

        topProfile.Append(line11);
        topProfile.Append(line12);
        topProfile.Append(line13);
        topProfile.Append(line14);

        // now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(true, topProfile, baseProfile, sketchPlane);

        if (null != blend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 11, 0);
            familyDocument.Move(blend, transPoint1);
        }
        else
        {
            throw new Exception("Create new Blend failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return blend;
}
CopyVB.NET
Private Function CreateBlend(ByVal application As UIApplication, ByVal sketchPlane As SketchPlane) As Blend
    Dim blend As Blend = Nothing

    ' make sure we have a family document
    Dim familyDocument As Document = application.ActiveUIDocument.Document
    If True = familyDocument.IsFamilyDocument Then
        ' Define top and base profiles for the blend
        Dim topProfile As New CurveArray()
        Dim baseProfile As New CurveArray()

        ' create rectangular base profile
        Dim p00 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p01 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p02 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p03 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line01 As Line = application.Application.Create.NewLineBound(p00, p01)
        Dim line02 As Line = application.Application.Create.NewLineBound(p01, p02)
        Dim line03 As Line = application.Application.Create.NewLineBound(p02, p03)
        Dim line04 As Line = application.Application.Create.NewLineBound(p03, p00)

        baseProfile.Append(line01)
        baseProfile.Append(line02)
        baseProfile.Append(line03)
        baseProfile.Append(line04)

        ' create rectangular top profile
        Dim p10 As New Autodesk.Revit.DB.XYZ(5, 2, 10)
        Dim p11 As New Autodesk.Revit.DB.XYZ(8, 5, 10)
        Dim p12 As New Autodesk.Revit.DB.XYZ(5, 8, 10)
        Dim p13 As New Autodesk.Revit.DB.XYZ(2, 5, 10)
        Dim line11 As Line = application.Application.Create.NewLineBound(p10, p11)
        Dim line12 As Line = application.Application.Create.NewLineBound(p11, p12)
        Dim line13 As Line = application.Application.Create.NewLineBound(p12, p13)
        Dim line14 As Line = application.Application.Create.NewLineBound(p13, p10)

        topProfile.Append(line11)
        topProfile.Append(line12)
        topProfile.Append(line13)
        topProfile.Append(line14)

        ' now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(True, topProfile, baseProfile, sketchPlane)

        If blend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(0, 11, 0)
            familyDocument.Move(blend, transPoint1)
        Else
            Throw New Exception("Create new Blend failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return blend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where blends cannot be created.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewControl Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewControl Method
FamilyItemFactory Class See Also Send Feedback
Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewControl ( _
    controlShape As ControlShape, _
    view As View, _
    origin As XYZ _
) As Control
Visual C++
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)

Parameters

controlShape
Type: Autodesk.Revit.DB..::.ControlShape
The shape of the control.
view
Type: Autodesk.Revit.DB..::.View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the control.

Return Value

If successful, the newly created control is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"view" or "position"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"view"-is invalid.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when control creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewCurveByPoints Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewCurveByPoints Method
FamilyItemFactory Class Example See Also Send Feedback
Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Function NewCurveByPoints ( _
    points As ReferencePointArray _
) As CurveByPoints
Visual C++
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::.ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

The newly created curve.

Examples

CopyC#
ReferencePointArray rpa = new ReferencePointArray();

XYZ xyz = document.Application.Create.NewXYZ(0, 0, 0);
ReferencePoint rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 30, 10);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 60, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 100, 30);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 150, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

curve = document.FamilyCreate.NewCurveByPoints(rpa);
CopyVB.NET
Dim rpa As New ReferencePointArray()

Dim xyz As Autodesk.Revit.DB.XYZ = document.Application.Create.NewXYZ(0, 0, 0)
Dim rp As ReferencePoint = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 30, 10)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 60, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 100, 30)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 150, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

curve = document.FamilyCreate.NewCurveByPoints(rpa)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when points does not contain at least two PointElements.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewDividedSurface Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewDividedSurface Method
FamilyItemFactory Class Example See Also Send Feedback
Create a DividedSurface element on one surface of another element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DividedSurface NewDividedSurface(
    Reference hostReference
)
Visual Basic (Declaration)
Public Function NewDividedSurface ( _
    hostReference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ NewDividedSurface(
    Reference^ hostReference
)

Parameters

hostReference
Type: Autodesk.Revit.DB..::.Reference
Reference to a surface on an existing element. The element must be one of the following: Form, GeomCombination, FamilyInstance, or ImportInstance.

Return Value

The newly created DividedSurface element.

Examples

CopyC#
public void DivideSurface(Document document, Form form)
{
    Autodesk.Revit.ApplicationServices.Application application = document.Application;
    Options opt = application.Create.NewGeometryOptions();
    opt.ComputeReferences = true;

    Autodesk.Revit.DB.GeometryElement geomElem = form.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid solid = geomObj as Solid;
        foreach (Face face in solid.Faces)
        {
            if (face.Reference != null)
            {
                DividedSurface ds = document.FamilyCreate.NewDividedSurface(face.Reference);
                // create a divided surface with fixed number of U and V grid lines
                SpacingRule srU = ds.USpacingRule;
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0);

                SpacingRule srV = ds.VSpacingRule;
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0);

                break;  // just divide one face of form
            }
        }
    }
}
CopyVB.NET
Public Sub DivideSurface(ByVal document As Document, ByVal form As Form)
    Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application
    Dim opt As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
    opt.ComputeReferences = True

    Dim geomElem As Autodesk.Revit.DB.GeometryElement = form.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim solid As Solid = TryCast(geomObj, Solid)
        For Each face As Autodesk.Revit.DB.Face In solid.Faces
            If face.Reference IsNot Nothing Then
                Dim ds As DividedSurface = document.FamilyCreate.NewDividedSurface(face.Reference)
                ' create a divided surface with fixed number of U and V grid lines
                Dim srU As SpacingRule = ds.USpacingRule
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0)

                Dim srV As SpacingRule = ds.VSpacingRule
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0)

                ' just divide one face of form
                Exit For
            End If
        Next
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when surface is not a reference to a surface, or when the referenced element does not support divided surfaces.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDuctConnector Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewDuctConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new duct connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctConnector NewDuctConnector(
    Reference planarFaceReference,
    DuctSystemType systemType
)
Visual Basic (Declaration)
Public Function NewDuctConnector ( _
    planarFaceReference As Reference, _
    systemType As DuctSystemType _
) As DuctConnector
Visual C++
public:
DuctConnector^ NewDuctConnector(
    Reference^ planarFaceReference,
    DuctSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Mechanical..::.DuctSystemType
Indicates the system type of this new duct connector.

Return Value

If creation was successful the new Duct Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a duct connector in a family document. The duct connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewElectricalConnector Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewElectricalConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new Electrical connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalConnector NewElectricalConnector(
    Reference planarFaceReference,
    ElectricalSystemType systemType
)
Visual Basic (Declaration)
Public Function NewElectricalConnector ( _
    planarFaceReference As Reference, _
    systemType As ElectricalSystemType _
) As ElectricalConnector
Visual C++
public:
ElectricalConnector^ NewElectricalConnector(
    Reference^ planarFaceReference,
    ElectricalSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystemType
Indicates the system type of this new Electrical connector.

Return Value

If creation was successful the new Electrical Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Electrical Connector in a family document. The electrical connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusion Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewExtrusion Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Extrusion instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Extrusion NewExtrusion(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    double end
)
Visual Basic (Declaration)
Public Function NewExtrusion ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    end As Double _
) As Extrusion
Visual C++
public:
Extrusion^ NewExtrusion(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    double end
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Extrusion is Solid or Void.
profile
Type: Autodesk.Revit.DB..::.CurveArrArray
The profile of the newly created Extrusion. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. All input curves must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the extrusion. The direction of extrusion is determined by the normal for the sketch plane. To extrude in the other direction set the end value to negative.
end
Type: System..::.Double
The length of the extrusion.

Return Value

If creation was successful the new Extrusion is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an extrusion in a family document. The extrusion will be extended perpendicular to the sketch plane of the extrusion profile.

Examples

CopyC#
private Extrusion CreateExtrusion(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Extrusion rectExtrusion = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // define the profile for the extrusion
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray1 = new CurveArray();
        CurveArray curveArray2 = new CurveArray();
        CurveArray curveArray3 = new CurveArray();

        // create a rectangular profile
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);
        curveArray1.Append(line1);
        curveArray1.Append(line2);
        curveArray1.Append(line3);
        curveArray1.Append(line4);

        curveArrArray.Append(curveArray1);

        // create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(true, curveArrArray, sketchPlane, 10);

        if (null != rectExtrusion)
        {
            // move extrusion to proper place
            XYZ transPoint1 = new XYZ(-16, 0, 0);
            document.Move(rectExtrusion, transPoint1);
        }
        else
        {
            throw new Exception("Create new Extrusion failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return rectExtrusion;
}
CopyVB.NET
Private Function CreateExtrusion(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Extrusion
    Dim rectExtrusion As Extrusion = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' define the profile for the extrusion
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray1 As New CurveArray()
        Dim curveArray2 As New CurveArray()
        Dim curveArray3 As New CurveArray()

        ' create a rectangular profile
        Dim p0 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p1 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)
        curveArray1.Append(line1)
        curveArray1.Append(line2)
        curveArray1.Append(line3)
        curveArray1.Append(line4)

        curveArrArray.Append(curveArray1)

        ' create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(True, curveArrArray, sketchPlane, 10)

        If rectExtrusion IsNot Nothing Then
            ' move extrusion to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(-16, 0, 0)
            document.Move(rectExtrusion, transPoint1)
        Else
            Throw New Exception("Create new Extrusion failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return rectExtrusion
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty array.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-sketchPlane-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusionForm Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewExtrusionForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Visual Basic (Declaration)
Public Function NewExtrusionForm ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    direction As XYZ _
) As Form
Visual C++
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::.ReferenceArray
The profile of extrusion. It should consist of only one curve loop. The input profile must be in one plane.
direction
Type: Autodesk.Revit.DB..::.XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

If creation was successful new form is returned.

Examples

CopyC#
private Form CreateExtrusionForm(Autodesk.Revit.DB.Document document)
{
    Form extrusionForm = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(10, 10, 0);
    XYZ ptB = new XYZ(90, 10, 0);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(90, 10, 0);
    ptB = new XYZ(10, 90, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(10, 90, 0);
    ptB = new XYZ(10, 10, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // The extrusion form direction
    XYZ direction = new XYZ(0, 0, 50);

    extrusionForm = document.FamilyCreate.NewExtrusionForm(true, ref_ar, direction);

    int profileCount = extrusionForm.ProfileCount;

    return extrusionForm;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = app.Create.NewLine(ptA, ptB, true);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = app.Create.NewPlane(norm, ptB);
    SketchPlane skplane = doc.FamilyCreate.NewSketchPlane(plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateExtrusionForm(ByVal document As Autodesk.Revit.DB.Document) As Form
    Dim extrusionForm As Form = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim ptB As New Autodesk.Revit.DB.XYZ(90, 10, 0)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(90, 10, 0)
    ptB = New Autodesk.Revit.DB.XYZ(10, 90, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(10, 90, 0)
    ptB = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' The extrusion form direction
    Dim direction As New Autodesk.Revit.DB.XYZ(0, 0, 50)

    extrusionForm = document.FamilyCreate.NewExtrusionForm(True, ref_ar, direction)

    Dim profileCount As Integer = extrusionForm.ProfileCount

    Return extrusionForm
End Function

Public Function MakeLine(ByVal doc As Document, ByVal ptA As Autodesk.Revit.DB.XYZ, ByVal ptB As Autodesk.Revit.DB.XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line As Line = app.Create.NewLine(ptA, ptB, True)
    Dim norm As Autodesk.Revit.DB.XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = Autodesk.Revit.DB.XYZ.BasisZ
    End If
    Dim plane As Plane = app.Create.NewPlane(norm, ptB)
    Dim skplane As SketchPlane = doc.FamilyCreate.NewSketchPlane(plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line, skplane)
    Return modelcurve
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where extrusions cannot be created.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewFamilyInstance Method
FamilyItemFactory Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewFormByCap Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewFormByCap Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Visual Basic (Declaration)
Public Function NewFormByCap ( _
    isSolid As Boolean, _
    profile As ReferenceArray _
) As Form
Visual C++
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::.ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFormByThickenSingleSurface Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewFormByThickenSingleSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Form NewFormByThickenSingleSurface(
    bool isSolid,
    Form singleSurfaceForm,
    XYZ thickenDir
)
Visual Basic (Declaration)
Public Function NewFormByThickenSingleSurface ( _
    isSolid As Boolean, _
    singleSurfaceForm As Form, _
    thickenDir As XYZ _
) As Form
Visual C++
public:
Form^ NewFormByThickenSingleSurface(
    bool isSolid,
    Form^ singleSurfaceForm,
    XYZ^ thickenDir
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
singleSurfaceForm
Type: Autodesk.Revit.DB..::.Form
The single-surface form element. It can have one top/bottom face or one side face.
thickenDir
Type: Autodesk.Revit.DB..::.XYZ
The offset of capped solid.

Return Value

This function will modify the input singleSurfaceForm and return the same element.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewLinearDimension Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewLinearDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray)

[image]

Revit 2011 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray)
FamilyItemFactory Class Example See Also Send Feedback
Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = document.Application.Create.NewLine(pt1, pt2, true);
    Plane plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2);
    SketchPlane skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);
    plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2);
    skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        BuiltInParameterGroup.PG_CONSTRAINTS,
        ParameterType.Length, false);

    dim.Label = param;

    return dim;
}
CopyVB.NET
Public Function CreateLinearDimension(ByVal document As Document) As Dimension
    ' first create two lines
    Dim pt1 As New Autodesk.Revit.DB.XYZ(5, 5, 0)
    Dim pt2 As New Autodesk.Revit.DB.XYZ(5, 10, 0)
    Dim line As Line = document.Application.Create.NewLine(pt1, pt2, True)
    Dim plane As Plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2)
    Dim skplane As SketchPlane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    pt1 = New Autodesk.Revit.DB.XYZ(10, 5, 0)
    pt2 = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)
    plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2)
    skplane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New Autodesk.Revit.DB.XYZ(5, 10, 0)
    pt2 = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)

    Dim [dim] As Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", BuiltInParameterGroup.PG_CONSTRAINTS, ParameterType.Length, False)

    [dim].Label = param

    Return [dim]
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument "references" is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2011 API
FamilyItemFactory..::.NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::.Line
The extension line of the dimension.
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType
Type: Autodesk.Revit.DB..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLoftForm Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewLoftForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewLoftForm ( _
    isSolid As Boolean, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profiles
Type: Autodesk.Revit.DB..::.ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful form is are returned.

Examples

CopyC#
private Form CreateLoftForm(Autodesk.Revit.DB.Document document)
{
    Form loftForm = null;

    ReferencePointArray rpa = new ReferencePointArray();
    ReferenceArrayArray ref_ar_ar = new ReferenceArrayArray();
    ReferenceArray ref_ar = new ReferenceArray();
    ReferencePoint rp = null;
    XYZ xyz = null;

    // make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 50, 10);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    CurveByPoints cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 50, 30);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 50, 5);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);

    loftForm = document.FamilyCreate.NewLoftForm(true, ref_ar_ar);

    return loftForm;
}
CopyVB.NET
Private Function CreateLoftForm(ByVal document As Autodesk.Revit.DB.Document) As Form
    Dim loftForm As Form = Nothing

    Dim rpa As New ReferencePointArray()
    Dim ref_ar_ar As New ReferenceArrayArray()
    Dim ref_ar As New ReferenceArray()
    Dim rp As ReferencePoint = Nothing
    Dim xyz As Autodesk.Revit.DB.XYZ = Nothing

    ' make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 50, 10)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    Dim cbp As CurveByPoints = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 50, 30)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 50, 5)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)

    loftForm = document.FamilyCreate.NewLoftForm(True, ref_ar_ar)

    Return loftForm
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewModelText Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewModelText Method
FamilyItemFactory Class See Also Send Feedback
Create a model text in the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelText NewModelText(
    string text,
    ModelTextType modelTextType,
    SketchPlane sketchPlane,
    XYZ position,
    HorizontalAlign horizontalAlign,
    double depth
)
Visual Basic (Declaration)
Public Function NewModelText ( _
    text As String, _
    modelTextType As ModelTextType, _
    sketchPlane As SketchPlane, _
    position As XYZ, _
    horizontalAlign As HorizontalAlign, _
    depth As Double _
) As ModelText
Visual C++
public:
ModelText^ NewModelText(
    String^ text,
    ModelTextType^ modelTextType,
    SketchPlane^ sketchPlane,
    XYZ^ position,
    HorizontalAlign horizontalAlign,
    double depth
)

Parameters

text
Type: System..::.String
The text to be displayed.
modelTextType
Type: Autodesk.Revit.DB..::.ModelTextType
The type of model text. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), the default type will be used.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane of the model text. The direction of model text is determined by the normal of the sketch plane. To extrude in the other direction set the depth value to negative.
position
Type: Autodesk.Revit.DB..::.XYZ
The position of the model text. The position must lie in the sketch plane.
horizontalAlign
Type: Autodesk.Revit.DB..::.HorizontalAlign
The horizontal alignment.
depth
Type: System..::.Double
The depth of the model text.

Return Value

If successful, the newly created model text is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument text, sketchPlane or XYZ is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when input argument text is an empty string. Thrown when input argument horizontalAlign or depth is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when model text creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewOpening Method
FamilyItemFactory Class See Also Send Feedback
Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Opening NewOpening(
    Element host,
    CurveArray profile
)
Visual Basic (Declaration)
Public Function NewOpening ( _
    host As Element, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ host,
    CurveArray^ profile
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile
Type: Autodesk.Revit.DB..::.CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument host or profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when opening creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewPipeConnector Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewPipeConnector Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new pipe connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeConnector NewPipeConnector(
    Reference planarFaceReference,
    PipeSystemType systemType
)
Visual Basic (Declaration)
Public Function NewPipeConnector ( _
    planarFaceReference As Reference, _
    systemType As PipeSystemType _
) As PipeConnector
Visual C++
public:
PipeConnector^ NewPipeConnector(
    Reference^ planarFaceReference,
    PipeSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::.Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Plumbing..::.PipeSystemType
Indicates the system type of this new Pipe connector.

Return Value

If creation was successful the new pipe connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a Pipe Connector in a family document. The pipe connector will be placed at the centroid of the planar face.

Examples

CopyC#
public void CreatePipeConnectors(UIDocument uiDocument, Extrusion extrusion)
{
    // get the faces of the extrusion
    Options geoOptions = uiDocument.Document.Application.Create.NewGeometryOptions();
    geoOptions.View = uiDocument.Document.ActiveView;
    geoOptions.ComputeReferences = true;

    List<PlanarFace> planarFaces = new List<PlanarFace>();
    Autodesk.Revit.DB.GeometryElement geoElement = extrusion.get_Geometry(geoOptions);
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        Solid geoSolid = geoObject as Solid;
        if (null != geoSolid)
        {
            foreach (Face geoFace in geoSolid.Faces)
            {
                if (geoFace is PlanarFace)
                {
                    planarFaces.Add(geoFace as PlanarFace);
                }
            }
        }
    }

    if (planarFaces.Count > 1)
    {
        // Create the Supply Hydronic pipe connector
        PipeConnector connSupply =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
                                                   PipeSystemType.SupplyHydronic);
        Parameter param = connSupply.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(1.0); // 1' radius
        param = connSupply.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(2);

        // Create the Return Hydronic pipe connector
        PipeConnector connReturn =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
                                                   PipeSystemType.ReturnHydronic);

        param = connReturn.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(0.5); // 6" radius
        param = connReturn.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(1);
    }
}
CopyVB.NET
Public Sub CreatePipeConnectors(ByVal uiDocument As UIDocument, ByVal extrusion As Extrusion)
    ' get the faces of the extrusion
    Dim geoOptions As Options = uiDocument.Document.Application.Create.NewGeometryOptions()
    geoOptions.View = uiDocument.Document.ActiveView
    geoOptions.ComputeReferences = True

    Dim planarFaces As New List(Of PlanarFace)()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = extrusion.Geometry(geoOptions)
    For Each geoObject As GeometryObject In geoElement.Objects
        Dim geoSolid As Solid = TryCast(geoObject, Solid)
        If geoSolid IsNot Nothing Then
            For Each geoFace As Face In geoSolid.Faces
                If TypeOf geoFace Is PlanarFace Then
                    planarFaces.Add(TryCast(geoFace, PlanarFace))
                End If
            Next
        End If
    Next

    If planarFaces.Count > 1 Then
        ' Create the Supply Hydronic pipe connector
        Dim connSupply As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(0).Reference, PipeSystemType.SupplyHydronic)
        Dim param As Parameter = connSupply.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](1)
        ' 1' radius
        param = connSupply.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](2)

        ' Create the Return Hydronic pipe connector
        Dim connReturn As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(1).Reference, PipeSystemType.ReturnHydronic)

        param = connReturn.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](0.5)
        ' 6" radius
        param = connReturn.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](1)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRadialDimension Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewRadialDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object.

Overload List

Name | Description
NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ)

[image]

Revit 2011 API
FamilyItemFactory..::.NewRadialDimension Method (View, Reference, XYZ)
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic (Declaration)
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::.Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::.XYZ
The point where the witness line of the radial dimension will lie.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument arcRef is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ, DimensionType)

[image]

Revit 2011 API
FamilyItemFactory..::.NewRadialDimension Method (View, Reference, XYZ, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::.Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::.XYZ
The point where the witness line of the radial dimension will lie.
dimensionType
Type: Autodesk.Revit.DB..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument arcRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewReferencePoint Method
FamilyItemFactory Class See Also Send Feedback
Creates a reference point.

Overload List

Name | Description
NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (PointElementReference)

[image]

Revit 2011 API
FamilyItemFactory..::.NewReferencePoint Method (PointElementReference)
FamilyItemFactory Class See Also Send Feedback
Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    PointElementReference
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^
)

Parameters

Type: Autodesk.Revit.DB..::.PointElementReference

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (Transform)

[image]

Revit 2011 API
FamilyItemFactory..::.NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^
)

Parameters

Type: Autodesk.Revit.DB..::.Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (XYZ)

[image]

Revit 2011 API
FamilyItemFactory..::.NewReferencePoint Method (XYZ)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    XYZ
)
Visual Basic (Declaration)
Public Function NewReferencePoint ( _
     As XYZ _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    XYZ^
)

Parameters

Type: Autodesk.Revit.DB..::.XYZ

Return Value

The newly created ReferencePoint.

Remarks

The ReferencePoint will have a default coordinate system corresponding to the global coordinate system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewRevolution Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewRevolution Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Revolution instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Revolution NewRevolution(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    Line axis,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewRevolution ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    axis As Line, _
    startAngle As Double, _
    endAngle As Double _
) As Revolution
Visual C++
public:
Revolution^ NewRevolution(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    Line^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Revolution is Solid or Void.
profile
Type: Autodesk.Revit.DB..::.CurveArrArray
The profile of the newly created revolution. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the revolution. The direction of revolution is determined by the normal for the sketch plane.
axis
Type: Autodesk.Revit.DB..::.Line
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::.Double
The start angle of Revolution in radians.
endAngle
Type: System..::.Double
The end angle of Revolution in radians.

Return Value

If creation was successful the new revolution is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Revolution in a family document. The Revolution will be rotated the plane of the Revolution profile about the Axis.

Examples

CopyC#
private Revolution CreateRevolution(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Revolution revolution = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the revolution
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray = new CurveArray();

        // create a rectangular profile for the revolution
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);

        XYZ pp = new XYZ(1, -1, 0);
        Line axis1 = document.Application.Create.NewLineBound(XYZ.Zero, pp);
        curveArray.Append(line1);
        curveArray.Append(line2);
        curveArray.Append(line3);
        curveArray.Append(line4);

        curveArrArray.Append(curveArray);

        // create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(true, curveArrArray, sketchPlane, axis1, -Math.PI, 0);

        if (null != revolution)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 32, 0);
            document.Move(revolution, transPoint1);
        }
        else
        {
            throw new Exception("Create a new Revolution failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return revolution;
}
CopyVB.NET
Private Function CreateRevolution(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Revolution
    Dim revolution As Revolution = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the revolution
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray As New CurveArray()

        ' create a rectangular profile for the revolution
        Dim p0 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p1 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)

        Dim pp As New Autodesk.Revit.DB.XYZ(1, -1, 0)
        Dim axis1 As Line = document.Application.Create.NewLineBound(XYZ.Zero, pp)
        curveArray.Append(line1)
        curveArray.Append(line2)
        curveArray.Append(line3)
        curveArray.Append(line4)

        curveArrArray.Append(curveArray)

        ' create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(True, curveArrArray, sketchPlane, axis1, -Math.PI, 0)

        If revolution IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(0, 32, 0)
            document.Move(revolution, transPoint1)
        Else
            Throw New Exception("Create a new Revolution failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return revolution
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty array.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-sketchPlane-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-axis-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where revolutions cannot be created.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRevolveForms Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewRevolveForms Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Visual Basic (Declaration)
Public Function NewRevolveForms ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    axis As Reference, _
    startAngle As Double, _
    endAngle As Double _
) As FormArray
Visual C++
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::.ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The input profile must be in one plane.
axis
Type: Autodesk.Revit.DB..::.Reference
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::.Double
The start angle of Revolution in radians.
endAngle
Type: System..::.Double
The end angle of Revolution in radians.

Return Value

If creation was successful new forms are returned.

Remarks

Typically this operation produces only a single form, but some combinations of arguments will create multiple forms from a single profile.

Examples

CopyC#
private FormArray CreateRevolveForm(Document document)
{
    FormArray revolveForms = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(0, 0, 10);
    XYZ ptB = new XYZ(100, 0, 10);
    Line line = document.Application.Create.NewLine(ptA, ptB, true);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 0, 10);
    ptB = new XYZ(100, 100, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 100, 10);
    ptB = new XYZ(0, 0, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // Create axis for revolve form
    ptA = new XYZ(-5, 0, 10);
    ptB = new XYZ(-5, 10, 10);
    ModelCurve axis = MakeLine(document, ptA, ptB);

    // make axis a Reference Line
    axis.ChangeToReferenceLine();

    // Typically this operation produces only a single form,
    // but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(true, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4);

    return revolveForms;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = app.Create.NewLine(ptA, ptB, true);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = app.Create.NewPlane(norm, ptB);
    SketchPlane skplane = doc.FamilyCreate.NewSketchPlane(plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateRevolveForm(ByVal document As Document) As FormArray
    Dim revolveForms As FormArray = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New Autodesk.Revit.DB.XYZ(0, 0, 10)
    Dim ptB As New Autodesk.Revit.DB.XYZ(100, 0, 10)
    Dim line As Line = document.Application.Create.NewLine(ptA, ptB, True)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(100, 0, 10)
    ptB = New Autodesk.Revit.DB.XYZ(100, 100, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(100, 100, 10)
    ptB = New Autodesk.Revit.DB.XYZ(0, 0, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' Create axis for revolve form
    ptA = New Autodesk.Revit.DB.XYZ(-5, 0, 10)
    ptB = New Autodesk.Revit.DB.XYZ(-5, 10, 10)
    Dim axis As ModelCurve = MakeLine(document, ptA, ptB)

    ' make axis a Reference Line
    axis.ChangeToReferenceLine()

    ' Typically this operation produces only a single form,
    ' but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(True, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4)

    Return revolveForms
End Function

Public Function MakeLine(ByVal doc As Document, ByVal ptA As Autodesk.Revit.DB.XYZ, ByVal ptB As Autodesk.Revit.DB.XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line As Line = app.Create.NewLine(ptA, ptB, True)
    Dim norm As Autodesk.Revit.DB.XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = Autodesk.Revit.DB.XYZ.BasisZ
    End If
    Dim plane As Plane = app.Create.NewPlane(norm, ptB)
    Dim skplane As SketchPlane = doc.FamilyCreate.NewSketchPlane(plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line, skplane)
    Return modelcurve
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewSketchPlane Method
FamilyItemFactory Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewSweep Method
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form to the family document.

Overload List

Name | Description
NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2011 API
FamilyItemFactory..::.NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic (Declaration)
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::.ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile
Type: Autodesk.Revit.DB..::.SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::.Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::.ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2011 API
FamilyItemFactory..::.NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class Example See Also Send Feedback
Adds a new sweep form to the family document, using a path of curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    CurveArray path,
    SketchPlane pathPlane,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic (Declaration)
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As CurveArray, _
    pathPlane As SketchPlane, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    CurveArray^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::.CurveArray
The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for 3D paths or for 2D paths where the path should not reference an existing face.
profile
Type: Autodesk.Revit.DB..::.SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::.Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::.ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Examples

CopyC#
private Sweep CreateSweep(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Sweep sweep = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the sweep
        CurveArrArray arrarr = new CurveArrArray();
        CurveArray arr = new CurveArray();

        // Create an ovoid profile
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(2, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        arr.Append(document.Application.Create.NewArc(pnt2, 1.0d, 0.0d, 180.0d, XYZ.BasisX, XYZ.BasisY));
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2));
        arrarr.Append(arr);
        SweepProfile profile = document.Application.Create.NewCurveLoopsProfile(arrarr);

        // Create a path for the sweep
        XYZ pnt4 = new XYZ(10, 0, 0);
        XYZ pnt5 = new XYZ(0, 10, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt4, pnt5);

        CurveArray curves = new CurveArray();
        curves.Append(curve);

        // create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(true, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start);

        if (null != sweep)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 0, 0);
            document.Move(sweep, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create a new Sweep.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return sweep;
}
CopyVB.NET
Private Function CreateSweep(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Sweep
    Dim sweep As Sweep = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the sweep
        Dim arrarr As New CurveArrArray()
        Dim arr As New CurveArray()

        ' Create an ovoid profile
        Dim pnt1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.DB.XYZ(2, 0, 0)
        Dim pnt3 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
        arr.Append(document.Application.Create.NewArc(pnt2, 1, 0, 180, Autodesk.Revit.DB.XYZ.BasisX, Autodesk.Revit.DB.XYZ.BasisY))
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2))
        arrarr.Append(arr)
        Dim profile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr)

        ' Create a path for the sweep
        Dim pnt4 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim pnt5 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt4, pnt5)

        Dim curves As New CurveArray()
        curves.Append(curve)

        ' create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(True, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start)

        If sweep IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(11, 0, 0)
            document.Move(sweep, transPoint1)
        Else
            Throw New Exception("Failed to create a new Sweep.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return sweep
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where sweeps cannot be created.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewSweptBlend Method
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document.

Overload List

Name | Description
NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)

[image]

Revit 2011 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Reference, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::.Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile
Type: Autodesk.Revit.DB..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit.DB..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)

[image]

Revit 2011 API
FamilyItemFactory..::.NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)
FamilyItemFactory Class Example See Also Send Feedback
Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic (Declaration)
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Curve, _
    pathPlane As SketchPlane, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::.Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile
Type: Autodesk.Revit.DB..::.SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit.DB..::.SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Examples

CopyC#
private SweptBlend CreateSweptBlend(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2));
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3));
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4));
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7));
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8));
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9));
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            document.Move(newSweptBlend, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
CopyVB.NET
Private Function CreateSweptBlend(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
        Dim pnt3 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
        Dim pnt4 As New Autodesk.Revit.DB.XYZ(0, 1, 0)
        Dim pnt5 As New Autodesk.Revit.DB.XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2))
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3))
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4))
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New Autodesk.Revit.DB.XYZ(0.5, 0, 0)
        Dim pnt7 As New Autodesk.Revit.DB.XYZ(1, 0.5, 0)
        Dim pnt8 As New Autodesk.Revit.DB.XYZ(0.5, 1, 0)
        Dim pnt9 As New Autodesk.Revit.DB.XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7))
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8))
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9))
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New Autodesk.Revit.DB.XYZ(5, 0, 0)
        Dim pnt11 As New Autodesk.Revit.DB.XYZ(0, 20, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(11, 32, 0)
            document.Move(newSweptBlend, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where swept blends cannot be created.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlendForm Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewSweptBlendForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Visual Basic (Declaration)
Public Function NewSweptBlendForm ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::.Boolean
Indicates if the Form is Solid or Void.
path
Type: Autodesk.Revit.DB..::.ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there’s more than one profile, the path should be a single curve. It’s required to reference existing geometry.
profiles
Type: Autodesk.Revit.DB..::.ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSymbolicCurve Method

[image]

Revit 2011 API
FamilyItemFactory..::.NewSymbolicCurve Method
FamilyItemFactory Class See Also Send Feedback
Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewSymbolicCurve ( _
    curve As Curve, _
    sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2011 API
FamilyItemFactory..::.NewTextNote Method
FamilyItemFactory Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Properties

[image] [image]

Revit 2011 API
FamilyItemFactory Properties
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Class

[image]

Revit 2011 API
ItemFactoryBase Class
Members See Also Send Feedback
The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ItemFactoryBase : APIObject
Visual Basic (Declaration)
Public Class ItemFactoryBase _
    Inherits APIObject
Visual C++
public ref class ItemFactoryBase : public APIObject

Remarks

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. this class hold common methods used in both project document and family document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.Creation..::.Document
Autodesk.Revit.Creation..::.FamilyItemFactory

See Also

ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


ItemFactoryBase Members

[image] [image]

Revit 2011 API
ItemFactoryBase Members
ItemFactoryBase Class Methods Properties See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
NewDetailCurve | Creates a new detail curve element.
NewDetailCurveArray | Creates an array of new detail curve elements.
NewDimension | Overloaded. Creates a new linear dimension object.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document.
NewGroup | Creates a new type of group.
NewLevel | Creates a new level.
NewModelCurve | Creates a new model line element.
NewModelCurveArray | Creates an array of new model line elements.
NewReferencePlane | Creates a new instance of ReferencePlane.
NewReferencePlane2 | Creates a new instance of ReferencePlane.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data.
NewView3D | Creates a new 3D view.
NewViewPlan | Creates a plan view based on the specified level.
NewViewSection | Creates a new section view.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Methods

[image] [image]

Revit 2011 API
ItemFactoryBase Methods
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewAlignment | Add a new locked alignment into the Autodesk Revit document.
NewAnnotationSymbol | Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
NewDetailCurve | Creates a new detail curve element.
NewDetailCurveArray | Creates an array of new detail curve elements.
NewDimension | Overloaded. Creates a new linear dimension object.
NewFamilyInstance | Overloaded. Inserts a new instance of a family into the document.
NewFamilyInstances | Creates Family instances within the document.
NewGroup | Creates a new type of group.
NewLevel | Creates a new level.
NewModelCurve | Creates a new model line element.
NewModelCurveArray | Creates an array of new model line elements.
NewReferencePlane | Creates a new instance of ReferencePlane.
NewReferencePlane2 | Creates a new instance of ReferencePlane.
NewSketchPlane | Overloaded. Creates a new sketch plane.
NewTextNote | Overloaded. Creates a new TextNote object.
NewTextNotes | Creates TextNotes with the specified data.
NewView3D | Creates a new 3D view.
NewViewPlan | Creates a plan view based on the specified level.
NewViewSection | Creates a new section view.
PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAlignment Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewAlignment Method
ItemFactoryBase Class See Also Send Feedback
Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Visual Basic (Declaration)
Public Function NewAlignment ( _
    view As View, _
    reference1 As Reference, _
    reference2 As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view that determines the orientation of the alignment.
reference1
Type: Autodesk.Revit.DB..::.Reference
The first reference.
reference2
Type: Autodesk.Revit.DB..::.Reference
The second reference.

Return Value

If creation was successful the new locked alignment dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

These two references must be one of the following combinations:
  • 2 planar faces
  • 2 lines
  • line and point
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAnnotationSymbol Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewAnnotationSymbol Method
ItemFactoryBase Class See Also Send Feedback
Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbol NewAnnotationSymbol(
    XYZ origin,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic (Declaration)
Public Function NewAnnotationSymbol ( _
    origin As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ NewAnnotationSymbol(
    XYZ^ origin,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the annotation symbol. If created on ViewPlan, the origin will be projected onto the ViewPlan.
annotationSymbolType
Type: Autodesk.Revit.DB..::.AnnotationSymbolType
An annotation symbol type that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::.View
A 2D view in which to display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods. The location may be different from its origin on ViewPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::.ArgumentException | The input view was not 2D.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurve Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewDetailCurve Method
ItemFactoryBase Class See Also Send Feedback
Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Visual Basic (Declaration)
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the detail curve is to be visible.
geometryCurve
Type: Autodesk.Revit.DB..::.Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

If successful a new detail curve element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when curve is not in plane of the view

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurveArray Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewDetailCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray
)
Visual Basic (Declaration)
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray(
    View^ view,
    CurveArray^ geometryCurveArray
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the detail curves are to be visible.
geometryCurveArray
Type: Autodesk.Revit.DB..::.CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

If successful an array of new detail curve elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when curve is not in plane of the view

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2011 API
ItemFactoryBase..::.NewDimension Method
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

Name | Description
NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray)

[image]

Revit 2011 API
ItemFactoryBase..::.NewDimension Method (View, Line, ReferenceArray)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::.Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
Dimension CreateNewDimensionAlongLine(Autodesk.Revit.DB.Document document, Line line)
{
    // Use the Start and End points of our line as the references
    // Line must come from something in Revit, such as a beam
    ReferenceArray references = new ReferenceArray();
    references.Append(line.get_EndPointReference(0));
    references.Append(line.get_EndPointReference(1));

    // create the new dimension
    Dimension dimension = document.Create.NewDimension(document.ActiveView,
                                                        line, references);
    return dimension;
}
CopyVB.NET
Function CreateNewDimensionAlongLine(ByVal document As Autodesk.Revit.DB.Document, ByVal line As Line) As Dimension
    ' Use the Start and End points of our line as the references
    ' Line must come from something in Revit, such as a beam
    Dim references As New ReferenceArray()
    references.Append(line.EndPointReference(0))
    references.Append(line.EndPointReference(1))

    ' create the new dimension
    Dim dimension As Dimension = document.Create.NewDimension(document.ActiveView, line, references)
    Return dimension
End Function

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2011 API
ItemFactoryBase..::.NewDimension Method (View, Line, ReferenceArray, DimensionType)
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic (Declaration)
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::.Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::.ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
Type: Autodesk.Revit.DB..::.DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

Name | Description
NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, Line, FamilySymbol)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, Line, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::.Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert a family instance that does not require a host element or level.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa";

 // try to load family
 Family family = null;
 if (!document.LoadFamily(fileName, out family))
 {
     throw new Exception("Unable to load " + fileName);
 }

 // Loop through table symbols and add a new table for each
 FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
 double x = 0.0, y = 0.0;
 while (symbolItor.MoveNext())
 {
     FamilySymbol symbol = symbolItor.Current as FamilySymbol;
     XYZ location = new XYZ(x, y, 10.0);
     // Do not use the overloaded NewFamilyInstance() method that contains
     // the Level argument, otherwise Revit cannot show the instances
     // correctly in 3D View, for the table is not level-based component.
     FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, StructuralType.NonStructural);
     x += 10.0;
 }
CopyVB.NET
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa"

' try to load family
Dim family As Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Unable to load " + fileName)
End If

' Loop through table symbols and add a new table for each
Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
Dim x As Double = 0, y As Double = 0
While symbolItor.MoveNext()
    Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
    Dim location As New Autodesk.Revit.DB.XYZ(x, y, 10)
    ' Do not use the overloaded NewFamilyInstance() method that contains
    ' the Level argument, otherwise Revit cannot show the instances
    ' correctly in 3D View, for the table is not level-based component.
    Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
    x += 10
End While

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, View)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ origin,
    FamilySymbol symbol,
    View specView
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    origin As XYZ, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ origin,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of family instance. If created on ViewPlan, the origin will be projected onto the ViewPlan.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::.View
A 2D view in which to display the family instance.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

The location may be different from its origin on ViewPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::.ArgumentException | The input view or family was not 2D, or the input family is not permitted in this view.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::.XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::.Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::.XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::.Element
A host object into which the instance will be embedded
structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa";

 Autodesk.Revit.DB.Family family = null;
 if (!document.LoadFamily(fileName, out family))
 {
     throw new Exception("Couldn't load " + fileName);
 }

 FilteredElementCollector collector = new FilteredElementCollector(document);
 Floor floor = collector.OfClass(typeof(Floor)).FirstElement() as Floor;
 if (floor != null)
 {
     FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
     int x = 0, y = 0;
     int i = 0;
     while (symbolItor.MoveNext())
     {
         FamilySymbol symbol = symbolItor.Current as FamilySymbol;
         XYZ location = new XYZ(x, y, 0);
         XYZ direction = new XYZ();
         switch (i % 3)
         {
             case 0:
                 direction = new XYZ(1, 1, 0);
                 break;
             case 1:
                 direction = new XYZ(0, 1, 1);
                 break;
             case 2:
                 direction = new XYZ(1, 0, 1);
                 break;
         }
         FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
         x += 10;
         i++;
     }
 }
 else
 {
     throw new Exception("Please open a model with at least one floor element before invoking this command.");
 }
CopyVB.NET
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa"

Dim family As Autodesk.Revit.DB.Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Couldn't load " + fileName)
End If

Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim floor As Autodesk.Revit.DB.Floor = TryCast(collector.OfClass(GetType(Floor)).FirstElement(), Autodesk.Revit.DB.Floor)
If floor IsNot Nothing Then
    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Integer = 0, y As Integer = 0
    Dim i As Integer = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New Autodesk.Revit.DB.XYZ(x, y, 0)
        Dim direction As New Autodesk.Revit.DB.XYZ()
        Select Case i Mod 3
            Case 0
                direction = New Autodesk.Revit.DB.XYZ(1, 1, 0)
                Exit Select
            Case 1
                direction = New Autodesk.Revit.DB.XYZ(0, 1, 1)
                Exit Select
            Case 2
                direction = New Autodesk.Revit.DB.XYZ(1, 0, 1)
                Exit Select
        End Select
        Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
        x += 10
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
Else
    Throw New Exception("Please open a model with at least one floor element before invoking this command.")
End If

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstances Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewFamilyInstances Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewFamilyInstances(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( FamilyInstanceCreationData >)>)
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful an ElementSet which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
ElementSet BatchCreateColumns(Autodesk.Revit.DB.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    ElementSet elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        familySymbol = e as FamilySymbol;
        if (null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level,  StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Function BatchCreateColumns(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As ElementSet
    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    Dim elementSet As ElementSet = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        familySymbol = TryCast(e, FamilySymbol)
        If familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit For
            End If
        End If
    Next

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        Dim i As Integer = 1
        While i < 11
            Dim location As New Autodesk.Revit.DB.XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.DB.Structure.StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
            System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
        End While

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewGroup Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Group NewGroup(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
public:
Group^ NewGroup(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.

Examples

CopyC#
Group group = null;
UIDocument uidoc = new UIDocument(document);
ElementSet selection = uidoc.Selection.Elements;
if (selection.Size > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selection);

}
CopyVB.NET
Dim group As Group = Nothing
Dim uidoc As New UIDocument(document)
Dim selection As ElementSet = uidoc.Selection.Elements
If selection.Size > 0 Then
    ' Group all selected elements

    group = document.Create.NewGroup(selection)
Else

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewLevel Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewLevel Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level NewLevel(
    double elevation
)
Visual Basic (Declaration)
Public Function NewLevel ( _
    elevation As Double _
) As Level
Visual C++
public:
Level^ NewLevel(
    double elevation
)

Parameters

elevation
Type: System..::.Double
The elevation to apply to the new level.

Return Value

The newly created level.

Remarks

Default level attributes will apply to this new model.

Examples

CopyC#
Level CreateLevel(Autodesk.Revit.DB.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0;

    // Begin to create a level
    Level level = document.Create.NewLevel(elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
CopyVB.NET
Function CreateLevel(ByVal document As Autodesk.Revit.DB.Document) As Level
    ' The elevation to apply to the new level
    Dim elevation As Double = 20

    ' Begin to create a level
    Dim level As Level = document.Create.NewLevel(elevation)
    If level Is Nothing Then
        Throw New Exception("Create a new level failed.")
    End If

    ' Change the level name
    level.Name = "New level"

    Return level
End Function

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurve Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewModelCurve Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Type: Autodesk.Revit.DB..::.Curve
The internal geometry curve for model line.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

Examples

CopyC#
// get handle to application from document
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Create a geometry line in Revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = application.Create.NewLine(startPoint, endPoint, true);

// Create a geometry arc in Revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = application.Create.NewArc(end0, end1, pointOnCurve);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
CopyVB.NET
' get handle to application from document
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Create a geometry line in Revit application
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 0)
Dim geomLine As Line = application.Create.NewLine(startPoint, endPoint, True)

' Create a geometry arc in Revit application
Dim end0 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 10, 10)
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(10, 0, 0)
Dim geomArc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

' Create a geometry plane in Revit application
Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.DB.XYZ(1, 1, 0)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As SketchPlane = document.Create.NewSketchPlane(geomPlane)

' Create a ModelLine element using the created geometry line and sketch plane
Dim line As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

' Create a ModelArc element using the created geometry arc and sketch plane
Dim arc As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurveArray Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewModelCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic (Declaration)
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
Type: Autodesk.Revit.DB..::.CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane

Return Value

If successful an array of new model line elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewReferencePlane Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::.XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::.XYZ
The free end applied to reference plane.
cutVec
Type: Autodesk.Revit.DB..::.XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
Type: Autodesk.Revit.DB..::.View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
CopyVB.NET
' Define data for reference plane creation
Dim bubbleEnd As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.DB.XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New Autodesk.Revit.DB.XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane2 Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewReferencePlane2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic (Declaration)
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::.XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::.XYZ
The free end applied to reference plane.
thirdPnt
Type: Autodesk.Revit.DB..::.XYZ
A third point needed to define the reference plane.
pView
Type: Autodesk.Revit.DB..::.View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
CopyVB.NET
' Build now data before creation
Dim bubbleEnd As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.DB.XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New Autodesk.Revit.DB.XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2011 API
ItemFactoryBase..::.NewSketchPlane Method
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane.

Overload List

Name | Description
NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (PlanarFace)

[image]

Revit 2011 API
ItemFactoryBase..::.NewSketchPlane Method (PlanarFace)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a planar face of existing geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    PlanarFace planarFace
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    planarFace As PlanarFace _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    PlanarFace^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.DB..::.PlanarFace
The geometry planar face to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is nullNothingnullptra null reference (Nothing in Visual Basic), or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (Plane)

[image]

Revit 2011 API
ItemFactoryBase..::.NewSketchPlane Method (Plane)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new sketch plane from an arbitrary geometric plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic (Declaration)
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Plane^ geometryPlane
)

Parameters

geometryPlane
Type: Autodesk.Revit.DB..::.Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Examples

CopyC#
public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
CopyVB.NET
Public Shared Function CreateSketchPlane(ByVal document As Autodesk.Revit.DB.Document, ByVal plane As Plane) As SketchPlane
    Dim sketchPlane As SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane)

    ' throw exception if creation failed
    If sketchPlane Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane
End Function

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2011 API
ItemFactoryBase..::.NewTextNote Method
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object.

Overload List

Name | Description
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.
NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2011 API
ItemFactoryBase..::.NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new text note with a single leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::.TextNoteLeaderStyles
The style of the leader for the note.
leaderEnd
Type: Autodesk.Revit.DB..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when (1) Any one of pView, origin, baseVec, upVec, strText is nullNothingnullptra null reference (Nothing in Visual Basic). (2)leaderEnd is nullNothingnullptra null reference (Nothing in Visual Basic) when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE. (3)leaderElbow is nullNothingnullptra null reference (Nothing in Visual Basic) when leaderStyle == Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when lineWidth is not a finite number.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when (1) textAlign is not a valid TextAlignFlags or it is not a valid bitwise OR of TextAlignFlags. (2) leaderStyle is not a valid TextNoteLeaderTypes or leaderType is not a valid TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2011 API
ItemFactoryBase..::.NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object without a leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when any one of pView, origin, baseVec, upVec, strText is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input lineWidth is not a finite number.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input textAlign is not a valid TextAlignFlags or it is not a valid bitwise OR of the align flags.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNotes Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewTextNotes Method
ItemFactoryBase Class See Also Send Feedback
Creates TextNotes with the specified data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic (Declaration)
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewTextNotes(
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::.List <(Of <( TextNoteCreationData >)>)
A list of TextNoteCreationData which wraps the creation arguments of the TextNotes to be created.

Return Value

If the creation is successful an ElementSet which contains the TextNotes should be returned, otherwise Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when (1) Any one of theView, origin, baseVec, upVec, strText in TextNoteCreationData is nullNothingnullptra null reference (Nothing in Visual Basic). (2) Any one of leaderEnd is nullNothingnullptra null reference (Nothing in Visual Basic) in TextNoteCreationData when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE . (3) Any one of leaderElbow is nullNothingnullptra null reference (Nothing in Visual Basic) TextNoteCreationData when leaderStyle == Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when one lineWidth in textNoteCreationData is not a finite number.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when (1) Any one textAlign in TextNoteCreationData is not a valid TextAlignFlags or it is not a valid bitwise OR of TextAlignFlags. (2) Any one leaderStyle in TextNoteCreationData is not a valid TextNoteLeaderTypes or any one leaderType in TextNoteCreationData is not a valid TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewView3D Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewView3D Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new 3D view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View3D NewView3D(
    XYZ viewDirection
)
Visual Basic (Declaration)
Public Function NewView3D ( _
    viewDirection As XYZ _
) As View3D
Visual C++
public:
View3D^ NewView3D(
    XYZ^ viewDirection
)

Parameters

viewDirection
Type: Autodesk.Revit.DB..::.XYZ
The view direction - the vector pointing towards the eye.

Return Value

The newly created 3D view.

Examples

CopyC#
// Create a new View3D
XYZ direction = new XYZ(1, 1, 1);
View3D view3D = document.Create.NewView3D(direction);
if (null == view3D)
{
    throw new Exception("Failed to create new View3D");
}
CopyVB.NET
' Create a new View3D
Dim direction As New Autodesk.Revit.DB.XYZ(1, 1, 1)
Dim view3D As View3D = document.Create.NewView3D(direction)
If view3D Is Nothing Then
    Throw New Exception("Failed to create new View3D")
End If

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewPlan Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewViewPlan Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewPlanType viewType
)
Visual Basic (Declaration)
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewPlanType _
) As ViewPlan
Visual C++
public:
ViewPlan^ NewViewPlan(
    String^ pViewName,
    Level^ pLevel,
    ViewPlanType viewType
)

Parameters

pViewName
Type: System..::.String
The name for the new plan view, must be unique or nullNothingnullptra null reference (Nothing in Visual Basic).
pLevel
Type: Autodesk.Revit.DB..::.Level
The level on which the plan view is to be associated.
viewType
Type: Autodesk.Revit.DB..::.ViewPlanType
The type of plan view to be created.

Return Value

if successful, a new plan view object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

if pViewName is nullNothingnullptra null reference (Nothing in Visual Basic), the pLevel's name will be use as new plan view's name.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
 double elevation = 10.0;
 Level level1 = document.Create.NewLevel(elevation);
 ViewPlan floorView = document.Create.NewViewPlan(null, level1, ViewPlanType.FloorPlan);

 // Create another Level and a Ceiling Plan based on it
 elevation += 10.0;
 Level level2 = document.Create.NewLevel(elevation);
 ViewPlan ceilingView = document.Create.NewViewPlan(null, level2, ViewPlanType.CeilingPlan);
CopyVB.NET
' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10
Dim level1 As Level = document.Create.NewLevel(elevation)
Dim floorView As ViewPlan = document.Create.NewViewPlan(Nothing, level1, ViewPlanType.FloorPlan)

' Create another Level and a Ceiling Plan based on it
elevation += 10
Dim level2 As Level = document.Create.NewLevel(elevation)
Dim ceilingView As ViewPlan = document.Create.NewViewPlan(Nothing, level2, ViewPlanType.CeilingPlan)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the name is not unique

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewSection Method

[image]

Revit 2011 API
ItemFactoryBase..::.NewViewSection Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic (Declaration)
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
ViewSection^ NewViewSection(
    BoundingBoxXYZ^ box
)

Parameters

box
Type: Autodesk.Revit.DB..::.BoundingBoxXYZ
The view volume of the section will correspond geometrically to the specified bounding box.

Return Value

The newly created section view.

Remarks

The view's forward direction will correspond to the Z direction of the box, and the view's up direction will correspond to the Y direction of the box. The right hand direction of the view will be computed so that (right, up, forward) will form a left-handed coordinate system. The resulting view will be cropped, and far clipping will be active. The resulting view will be cropped, and far clipping will be active.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from Revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ViewSection viewSection = document.Create.NewViewSection(box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from Revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim viewSection As ViewSection = document.Create.NewViewSection(box)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


PlaceGroup Method

[image]

Revit 2011 API
ItemFactoryBase..::.PlaceGroup Method
ItemFactoryBase Class See Also Send Feedback
Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic (Declaration)
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The physical location where the group is to be placed.
groupType
Type: Autodesk.Revit.DB..::.GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Properties

[image] [image]

Revit 2011 API
ItemFactoryBase Properties
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Class

[image]

Revit 2011 API
ProfiledWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProfiledWallCreationData
Visual Basic (Declaration)
Public Class ProfiledWallCreationData
Visual C++
public ref class ProfiledWallCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.ProfiledWallCreationData

See Also

ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Members

[image] [image]

Revit 2011 API
ProfiledWallCreationData Members
ProfiledWallCreationData Class Constructors Methods See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Constructors

Name | Description
ProfiledWallCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor

[image] [image]

Revit 2011 API
ProfiledWallCreationData Constructor
ProfiledWallCreationData Class See Also Send Feedback

Overload List

Name | Description
ProfiledWallCreationData(CurveArray, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
ProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
ProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Initializes a new instance of the ProfiledWallCreationData class

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, Boolean)

[image]

Revit 2011 API
ProfiledWallCreationData Constructor (CurveArray, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)

[image]

Revit 2011 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2011 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic (Declaration)
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::.CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::.XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Methods

[image] [image]

Revit 2011 API
ProfiledWallCreationData Methods
ProfiledWallCreationData Class See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Class

[image]

Revit 2011 API
RectangularWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RectangularWallCreationData
Visual Basic (Declaration)
Public Class RectangularWallCreationData
Visual C++
public ref class RectangularWallCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.RectangularWallCreationData

See Also

RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Members

[image] [image]

Revit 2011 API
RectangularWallCreationData Members
RectangularWallCreationData Class Constructors Methods See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Constructors

Name | Description
RectangularWallCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor

[image] [image]

Revit 2011 API
RectangularWallCreationData Constructor
RectangularWallCreationData Class See Also Send Feedback

Overload List

Name | Description
RectangularWallCreationData(Curve, Level, Boolean) | Initializes a new instance of the RectangularWallCreationData class
RectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Initializes a new instance of the RectangularWallCreationData class

See Also

RectangularWallCreationData Class
RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, Level, Boolean)

[image]

Revit 2011 API
RectangularWallCreationData Constructor (Curve, Level, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2011 API
RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::.WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::.Level
The level on which the wall is to be placed.
height
Type: System..::.Double
The height of the wall.
offset
Type: System..::.Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::.Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::.Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Methods

[image] [image]

Revit 2011 API
RectangularWallCreationData Methods
RectangularWallCreationData Class See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Class

[image]

Revit 2011 API
RoomCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Room for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomCreationData
Visual Basic (Declaration)
Public Class RoomCreationData
Visual C++
public ref class RoomCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.RoomCreationData

See Also

RoomCreationData Members
Autodesk.Revit.Creation Namespace


RoomCreationData Members

[image] [image]

Revit 2011 API
RoomCreationData Members
RoomCreationData Class Constructors Methods Properties See Also Send Feedback

The RoomCreationData type exposes the following members.

Constructors

Name | Description
RoomCreationData | Initializes a new instance of the RoomCreationData class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Constructor

[image]

Revit 2011 API
RoomCreationData Constructor
RoomCreationData Class See Also Send Feedback
Initializes a new instance of the RoomCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomCreationData(
    Level level,
    UV point
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Level, _
    point As UV _
)
Visual C++
public:
RoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::.Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::.UV
A 2D point the dictates the location on that specified level.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Methods

[image] [image]

Revit 2011 API
RoomCreationData Methods
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Properties

[image] [image]

Revit 2011 API
RoomCreationData Properties
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Properties

Name | Description
TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2011 API
RoomCreationData..::.TagPoint Property
RoomCreationData Class See Also Send Feedback
Get or set the location of room tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic (Declaration)
Public Property TagPoint As UV
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Class

[image]

Revit 2011 API
TextNoteCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextNoteCreationData
Visual Basic (Declaration)
Public Class TextNoteCreationData
Visual C++
public ref class TextNoteCreationData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Creation..::.TextNoteCreationData

See Also

TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Members

[image] [image]

Revit 2011 API
TextNoteCreationData Members
TextNoteCreationData Class Constructors Methods See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Constructors

Name | Description
TextNoteCreationData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor

[image] [image]

Revit 2011 API
TextNoteCreationData Constructor
TextNoteCreationData Class See Also Send Feedback

Overload List

Name | Description
TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Initializes a new instance of the TextNoteCreationData class
TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Initializes a new instance of the TextNoteCreationData class

See Also

TextNoteCreationData Class
TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2011 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::.TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::.TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.DB..::.XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::.XYZ
The elbow point for the leader.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2011 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic (Declaration)
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::.View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::.XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::.XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::.Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::.TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::.String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Methods

[image] [image]

Revit 2011 API
TextNoteCreationData Methods
TextNoteCreationData Class See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.DB Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB Namespace
Send Feedback

Classes

Class Description
ACADExportOptions
Export options specific to AutoCAD file formats.
ACADImportOptions
Import options specific to AutoCAD file formats.
AddInId
Identifies an AddIn registered with Revit
AnnotationSymbol
This object represents a symbol of the Generic Annotation.
AnnotationSymbolType
An object that represents an annotation style.
AnnotationSymbolTypeSet
A set that contains AnnotationSymbol types.
AnnotationSymbolTypeSetIterator
An iterator to a AnnotationSymbol type set.
APIObject
Supports all objects in the Autodesk Revit API hierarchy.
Arc
A circular arc.
Area
Provides access to the area topology in Autodesk Revit.
AreaFilter
A filter used to match areas.
AreaScheme
The area scheme associated with a particular area plan.
AreaTag
Provides access to the area topology in Autodesk Revit.
AreaTagFilter
A filter used to match area tags.
AreaTagType
An object that represents an Area Tag style.
AreaTagTypeSet
A set that contains areatag types.
AreaTagTypeSetIterator
An iterator to a areatag type set.
BaseArray
An abstract base class that represents an array within the Revit project.
BasePoint
Represents kinds of BasePoints.
BeamSystem
An object that represents a BeamSystem within the Autodesk Revit project.
BeamSystemType
An object that specifies the type of a beam system in Autodesk Revit.
BeamSystemTypeSet
BeamSystemTypeSetIterator
Binding
Binding objects are used to take a parameter definition and bind it to one or more categories.
BindingMap
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Blend
A blend solid or void form.
BoundaryConditions
An object that represents a force applied across an area.
BoundarySegment
An object that represents a segment of an area boundary.
BoundarySegmentArray
An array that contains boundary segments.
BoundarySegmentArrayArray
An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator
An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator
An iterator to a boundary segment array.
BoundingBoxContainsPointFilter
A filter used to match elements with a bounding box that contains the given point.
BoundingBoxIntersectsFilter
A filter used to match elements with a bounding box that intersects the given Outline.
BoundingBoxIsInsideFilter
A filter used to match elements with a bounding box that is contained by the given Outline.
BoundingBoxUV
A two-dimensional rectangle, parallel to the coordinate axes.
BoundingBoxXYZ
A three-dimensional rectangular box.
BuildingSiteExportOptions
Building Site Export options.
BuiltInFailures
Provides a container of all Revit built-in FailureDefinitionId instances.
BuiltInFailures..::.AnalyticalModelFailures
Failures about AnalyticalModel.
BuiltInFailures..::.ArrayFailures
Failures about Arrays.
BuiltInFailures..::.AutoJoinFailures
Failures about AutoJoin.
BuiltInFailures..::.AutoRouteFailures
Failures about AutoRoute.
BuiltInFailures..::.BeamFailures
Failures about Beams.
BuiltInFailures..::.BeamSystemFailures
Failures about BeamSystem.
BuiltInFailures..::.BendFailures
Failures about Bends.
BuiltInFailures..::.BlendFailures
Failures about Blend.
BuiltInFailures..::.ColorFillFailures
Failures about ColorFill.
BuiltInFailures..::.ColumnFailures
Failures about Columns.
BuiltInFailures..::.ColumnInsideWallFailures
Failures description ColumnInsideWall
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures
Failures about ConceptualEnergyAnalysisDB.
BuiltInFailures..::.ConnectorFailures
Failures about Connector.
BuiltInFailures..::.ConstraintFailures
Failures about Constraint.
BuiltInFailures..::.ConversionFailures
Failures about conversion of data to a different format.
BuiltInFailures..::.CopyMonitorFailures
Failures about CopyWatch.
BuiltInFailures..::.CopyPasteFailures
Failures about CopyPasteFailures.
BuiltInFailures..::.CreationFailures
Failures about CreationFailures.
BuiltInFailures..::.CurtainGridFamilyFailures
Failures about CurtainGrid Family.
BuiltInFailures..::.CurtainWallFailures
Failures about CurtainWall.
BuiltInFailures..::.CurveByPointFailures
Failures about Curve By Point Element
BuiltInFailures..::.CurveFailures
Failures about Curves and Curve-Driven Elements.
BuiltInFailures..::.CutFailures
Failures about Cut.
BuiltInFailures..::.CutterFailures
Failures about Cutter.
BuiltInFailures..::.CuttingFailures
Failures about Cutting.
BuiltInFailures..::.DatumPlaneFailures
Failures about DatumPlane.
BuiltInFailures..::.DecalFailures
Failures about Decal.
BuiltInFailures..::.DesignOptionFailures
Failures about DesignOptionFailures.
BuiltInFailures..::.DetailFailures
Failures about Detail.
BuiltInFailures..::.DimensionFailures
Failures about DimensionFailures.
BuiltInFailures..::.DividedSurfaceFailures
Failures about DividedSurface.
BuiltInFailures..::.DocumentFailures
Failures about DocumentFailures.
BuiltInFailures..::.DuctFailures
Failures about Duct.
BuiltInFailures..::.EditingFailures
Failures about EditingFailures.
BuiltInFailures..::.ElectricalFailures
Failures about Electricity.
BuiltInFailures..::.ElectricityFailures
BuiltInFailures..::.ElementFailures
Failures about Elements.
BuiltInFailures..::.ElementTypeFailures
Failures about ElementTypeFailures.
BuiltInFailures..::.ElevationFailures
Failures about Elevation.
BuiltInFailures..::.EnergyAnalysisFailures
Failures about EnergyAnalysis.
BuiltInFailures..::.ExtrusionFailures
Failures about Extrusions.
BuiltInFailures..::.FaceSplitterFailures
Failures about FaceSplitter.
BuiltInFailures..::.FamilyFailures
Failures about FamilyFailures.
BuiltInFailures..::.FilledRegionFailures
Failures about FilledRegion.
BuiltInFailures..::.FloorFailures
BuiltInFailures..::.FluidFailures
Failures about Fluid.
BuiltInFailures..::.FormFailures
Failures about Form.
BuiltInFailures..::.GeneralFailures
Failures about GeneralFailures.
BuiltInFailures..::.GenericFailures
Generic failures that may apply to any Revit Element
BuiltInFailures..::.GenericMEPFailures
Failures applicable to different mechanical, electrical and piping Elements.
BuiltInFailures..::.GeometryFailures
Failures about GeometryFailures.
BuiltInFailures..::.GridFailures
Failures about Grid.
BuiltInFailures..::.GroupFailures
Failures related to groups and their behavior.
BuiltInFailures..::.HostFinishFailures
Failures about HostFinish.
BuiltInFailures..::.HostObjFailures
Failures about HostObj.
BuiltInFailures..::.HvacFailures
BuiltInFailures..::.IlluminationFailures
Failures about Illumination.
BuiltInFailures..::.ImageFailures
Failures about Image.
BuiltInFailures..::.ImportFailures
Failures about ImportFailures.
BuiltInFailures..::.InaccurateFailures
Failures about Inaccurate.
BuiltInFailures..::.InfillFailures
Failures about Infill.
BuiltInFailures..::.InterferenceFailures
Failures about Interference.
BuiltInFailures..::.JoinElementsFailures
Failures about JoinElements.
BuiltInFailures..::.KeynoteFailures
Failures about KeynoteFailures.
BuiltInFailures..::.LegendFailures
Failures about Legend.
BuiltInFailures..::.LevelFailures
Failures about Level.
BuiltInFailures..::.LinkFailures
Failures about LinkFailures.
BuiltInFailures..::.LoadFailures
Failures about Load.
BuiltInFailures..::.LooseDimensionFailures
Failures about LooseDemision.
BuiltInFailures..::.MassFailures
Failures about Mass.
BuiltInFailures..::.MatchlineFailures
Failures about Matchline.
BuiltInFailures..::.MechanicalFailures
Failures about Hvac.
BuiltInFailures..::.MirrorFailures
Failures about Mirror.
BuiltInFailures..::.OpeningFailures
Failures about Opening.
BuiltInFailures..::.OverlapFailure
BuiltInFailures..::.OverlapFailures
Failures detected by overlap check.
BuiltInFailures..::.PathFailures
Failures about Path.
BuiltInFailures..::.PipingFailures
Failures about Pipes.
BuiltInFailures..::.PlanRegionFailures
Failures about PlanRegion.
BuiltInFailures..::.PointFailures
Failures about Point Element.
BuiltInFailures..::.ProfileFailures
Failures about Profile.
BuiltInFailures..::.RebarFailures
Failures about Rebar.
BuiltInFailures..::.RebarShapeFailures
Failures about RebarShape.
BuiltInFailures..::.RebarSystemFailures
Failures about RebarSystem.
BuiltInFailures..::.RefPlaneFailures
Failures about RefPlane.
BuiltInFailures..::.RegenFailures
Failures about RegenFailures.
BuiltInFailures..::.RenderFailures
Failures about Render.
BuiltInFailures..::.RevisionCloudFailures
Failures about RevisionCloud.
BuiltInFailures..::.RevolutionFailures
Failures about Revolution.
BuiltInFailures..::.RoofFailures
Failures about Roof.
BuiltInFailures..::.RoomFailures
Failures about Room.
BuiltInFailures..::.ScheduleViewFailures
Failures about Schedule.
BuiltInFailures..::.SculptingFailures
Failures about Sculpting.
BuiltInFailures..::.SectionViewFailures
Failures about Section.
BuiltInFailures..::.SelectionFailures
Failures about Selections.
BuiltInFailures..::.SheetFailures
Failures about Sheet.
BuiltInFailures..::.SiteFailures
Failures about Site.
BuiltInFailures..::.SiteImportFailures
Failures about SiteImport.
BuiltInFailures..::.SketchFailures
Failures about Sketch.
BuiltInFailures..::.SkylightFailures
Failures about Skylight.
BuiltInFailures..::.SlabFailures
Failures about Slab.
BuiltInFailures..::.SlantedColumnFailures
Failures about SlantedColumn.
BuiltInFailures..::.SlapShapeFailures
Failures about SlapShape.
BuiltInFailures..::.SpanDirectionSymbolFailures
Failures about SpanDirectionSymbol.
BuiltInFailures..::.SplineFailures
Failures about Spline.
BuiltInFailures..::.StairRampFailures
Failures about StairRamp.
BuiltInFailures..::.SweepFailures
Failures about Sweep.
BuiltInFailures..::.SweptBlendFailures
Failures about SweptBlend.
BuiltInFailures..::.SystemsFailures
Failures about System.
BuiltInFailures..::.TagFailures
Failures about Tag.
BuiltInFailures..::.TextFailures
Failures about Text.
BuiltInFailures..::.TrussFailures
Failures about Truss.
BuiltInFailures..::.ViewFailures
Failures about ViewFailures.
BuiltInFailures..::.WallFailures
Failures about Wall.
BuiltInFailures..::.WallJoinRoofFailures
Failures about WallJoinRoof.
BuiltInFailures..::.WorksharingFailures
Failures about WorksharingFailures.
CADExportOptions
Generic CAD Export options.
CADImportOptions
Generic CAD Import options.
Categories
The Categories object is a map that contains all the top-level Category objects within the Document.
Category
Represents the category or subcategory to which an element belongs.
CategoryNameMap
A map that contains a mapping of category name to its category object.
CategoryNameMapIterator
An iterator to a category name map.
CategorySet
A set that can contains Category objects.
CategorySetIterator
An iterator to a category set.
CeilingAndFloor
A base class that provides support for all ceiling and floor objects.
ChangeType
City
An object that contains geographical location information for a known city.
CitySet
An set that contains cities.
CitySetIterator
An iterator to a city set.
Color
Represents a color in Autodesk Revit.
CombinableElement
An element that can be added to a geometry combination.
CombinableElementArray
An array that contains CombinableElement objects.
CombinableElementArrayIterator
An iterator to an CombinableElement array.
CompoundStructure
An object that describes the multi layered construction of walls or floors.
CompoundStructureLayer
An object that describes a single layer of multi-layered object.
CompoundStructureLayerArray
An array that contains layer objects.
CompoundStructureLayerArrayIterator
An iterator to a layer array.
ConicalFace
A cone face of a 3d solid.
Connector
A connector in an Autodesk Revit MEP project document.
ConnectorElement
A base class that provides support for all connector elements occurring in families.
ConnectorManager
Provides access to the Connector Manager in Autodesk Revit MEP.
ConnectorSet
A set that can contain any type of object.
ConnectorSetIterator
An iterator to a set.
Construction
Construction definition for Project Information.
ContFooting
An object that represents a Continuous Footing within Autodesk Revit.
ContFootingType
An object that specifies the type of a continuous footing in Autodesk Revit.
ContFootingTypeSet
A set that contains ContFooting types.
ContFootingTypeSetIterator
An iterator to a ContFooting type set.
Control
A control in Autodesk Revit family document.
CurtainCell
Represents a CurtainCell within Autodesk Revit.
CurtainCellSet
A set that can contain any type of object.
CurtainCellSetIterator
An iterator to a set.
CurtainGrid
Represents a curtain grid element within Autodesk Revit.
CurtainGridLine
Represents a CurtainGridLine within Autodesk Revit.
CurtainGridSet
A set that can contain any type of object.
CurtainGridSetIterator
An iterator to a set.
CurtainSystem
Provides access to the CurtainSystem object in Autodesk Revit.
CurtainSystemBase
Provides access to the CurtainSystemBase object in Autodesk Revit.
CurtainSystemType
An object that represents CurtainSystem type.
CurtainSystemTypeSet
A set that contains CurtainSystem types.
CurtainSystemTypeSetIterator
An iterator to a CurtainSystem type set.
Curve
A parametric curve.
CurveArrArray
An array that can contain any type of object.
CurveArrArrayIterator
An iterator to a array.
CurveArray
An array that can contain curves.
CurveArrayIterator
An iterator to a curve array.
CurveByPoints
A curve interpolating two or more points.
CurveByPointsArray
CurveByPointsArrayIterator
CurveByPointsUtils
A static class that contains methods for processing curves driven by points.
CurveElement
CurveElementFilter
CurveLoopsProfile
Represents a curve loop based profile for sweep or swept blend elements.
CylindricalFace
A cylinder face of a 3d solid.
Definition
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
DefinitionBindingMap
A map that contains mappings of parameter definitions to parameter bindings.
DefinitionBindingMapIterator
An iterator to a parameter definition to parameter bindings map.
DefinitionFile
The DefinitionFile object represents a shared parameters file on disk.
DefinitionGroup
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
DefinitionGroups
A specialized set of definition groups that allows creation of new groups.
DefinitionGroupsBase
A set that contains definition groups.
DefinitionGroupsBaseIterator
An iterator to a definition group set.
Definitions
A base class that supports the addition of new parameter definitions.
DefinitionsBase
A set that contains definitions.
DefinitionsBaseIterator
An iterator to a definition set.
DeleteElements
Deletes element(s) related to the failure.
DesignOption
An element that represents a design alternative.
DetailArc
Represents a DetailArc within Autodesk Revit.
DetailCurve
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
DetailCurveArray
An array that can contain any type of object.
DetailCurveArrayIterator
An iterator to a array.
DetailEllipse
Represents a DetailEllipse within Autodesk Revit.
DetailLine
Represents a DetailLine within Autodesk Revit.
DetailNurbSpline
Represents a DetailNurbSpline within Autodesk Revit.
DGNExportOptions
DGN Export options.
Dimension
An object that represents a dimension within the Revit project.
DimensionSegment
A segment of a dimension within the Autodesk Revit project.
DimensionSegmentArray
An array that can contain any number of DimensionSegment objects.
DimensionSegmentArrayIterator
An iterator to an array of DimensionSegment objects..
DimensionType
An object that represents a dimension style.
DimensionTypeSet
A set that contains dimension types.
DimensionTypeSetIterator
An iterator to a dimension type set.
DividedSurface
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
DividedSurfaceData
An interface to the divided surfaces on an element.
Document
An object that represents an open Autodesk Revit project.
DocumentPreviewSettings
Contains the settings related to the saving of preview images for a given document.
DocumentSet
A set that can contain any documents.
DocumentSetIterator
An iterator to a set of documents.
DoubleArray
An array that contains doubles.
DoubleArrayIterator
An iterator to an array of doubles.
DWFExportOptions
DWF Export options.
DWFXExportOptions
DWFX Export options.
DWGExportOptions
DWG Export options.
DWGImportOptions
Import options specific to AutoCAD's DWG file formats.
DXFExportOptions
DXF Export options.
Edge
An edge of a 3d solid.
EdgeArray
An array that contains edges.
EdgeArrayArray
An array of edge arrays.
EdgeArrayArrayIterator
An iterator to an array or edge arrays.
EdgeArrayIterator
An iterator to an edge array.
Element
Base class for most persistent data within a Revit document.
ElementArray
An array that contains element objects.
ElementArrayIterator
An iterator to an element array.
ElementBinding
A base class for all types of binding that attach to an element.
ElementCategoryFilter
A filter used to match elements by their category.
ElementClassFilter
A filter used to match elements by their class.
ElementDesignOptionFilter
A filter used to find elements contained within a particular design option.
ElementFilter
A base class for a type of filter that accepts or rejects elements based upon criteria.
ElementId
The ElementId object is used as a unique identification for an element within a single project.
ElementIsCurveDrivenFilter
A filter used to match elements which are curve driven.
ElementIsElementTypeFilter
A filter used to match elements which are ElementTypes.
ElementLevelFilter
A filter used to match elements by their associated level.
ElementLogicalFilter
A filter used to logically combine two or more filters.
ElementOwnerViewFilter
A filter used to match elements which are owned by a particular view.
ElementParameterFilter
A filter used to match elements by one or more parameter filter rules.
ElementQuickFilter
A base class for a type of filter that operates on element records.
ElementRecord
A record in the Revit database representing an element.
ElementSet
A set that contains element objects.
ElementSetIterator
An iterator to an element set.
ElementSlowFilter
A base class for a type of filter that operates on expanded elements.
ElementStructuralTypeFilter
A filter used to find elements matching a structural type.
ElementType
Base class for all Types within Autodesk Revit.
Ellipse
A whole or partial ellipse.
Enclosure
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.
EnclosureTag
A tag attached to an Enclosure (room, space or area) in Autodesk Revit.
ExclusionFilter
A filter used to exclude a set of elements automatically.
ExportUtils
This class provides utilities related to document export.
ExternalDefinition
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
ExternalDefinitions
Supports the creation of new shared parameters definitions.
Extrusion
A extrusion solid or void form.
ExtrusionRoof
Represents some kinds of Extrusion Roofs.
Face
A face of a 3d solid.
FaceArray
An array that contains faces.
FaceArrayIterator
An iterator to a face array.
FaceWall
A wall attached to a non-vertical massing face.
FailureDefinition
Defines persistent information about a failure.
FailureDefinitionAccessor
FailureDefinitionId
The unique identifier of a FailureDefinition.
FailureDefinitionRegistry
The global registry for all FailureDefinitions in the Revit session.
FailureHandlingOptions
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended
FailureMessage
Represents a message describing a failure of an operation in Revit.
FailureMessageAccessor
Restricted accessor for FailureMessage.
FailureMessageKey
A unique key assigned to each posted failure message
FailureResolution
Defines a resolution for a failure.
FailuresAccessor
An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Family
The Family object defines an entire family.
FamilyBase
A base class for all Family objects.
FamilyElementVisibility
Provides access to the visibility parameters of family elements in family document.
FamilyInstance
This object represents a single instance of a family type, such as a single I beam.
FamilyInstanceFilter
A filter used to find elements that are family instances of the given family symbol.
FamilyManager
The family manager object to manage the family types and parameters in family document.
FamilyParameter
The family parameter object.
FamilyParameterSet
A set that contains FamilyParameter objects.
FamilyParameterSetIterator
An iterator to a FamilyParameter set.
FamilyPointLocation
This object represents a data corresponding to the point locations in a certain types Family Symbols (see examples listed below).
FamilyPointPlacementReference
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
FamilySymbol
Represents a single Type within a Family.
FamilySymbolFilter
A filter used to find all family symbols of the given family.
FamilySymbolProfile
Represents a family symbol based profile for sweep or swept blend elements.
FamilySymbolSet
A set that can contain family symbols.
FamilySymbolSetIterator
An iterator to a family symbol set.
FamilyType
The family type object provides read access to the values of family parameters for this type.
FamilyTypeSet
A set that contains FamilyType objects.
FamilyTypeSetIterator
An iterator to a FamilyType set.
FamilyUtils
FBXExportOptions
3D-Studio Max (FBX) Export options.
FillPattern
Represents a fill pattern element within an Autodesk Revit project.
FillPatternSet
A set that contains FillPatterns.
FillPatternSetIterator
An iterator to a FillPattern set.
FilterableValueProvider
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
FilterDoubleRule
A filter rule that operates on double-precision numeric values in a Revit project.
FilteredElementCollector
This class is used to search, filter and iterate through a set of elements.
FilteredElementIdIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
FilteredElementIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
FilterElement
FilterElementIdRule
A filter rule that operates on ElementId values in a Revit project.
FilterIntegerRule
A filter rule that operates on integer values in a Revit project.
FilterInverseRule
A filter rule that inverts the boolean values returned by the rule it contains.
FilterNumericEquals
Tests whether numeric values from the document are equal to a certain value
FilterNumericGreater
Tests whether numeric values from the document are greater than a certain value
FilterNumericGreaterOrEqual
Tests whether numeric values from the document are greater than or equal to a certain value
FilterNumericLess
Tests whether numeric values from the document are less than a certain value
FilterNumericLessOrEqual
Tests whether numeric values from the document are less than or equal to a certain value
FilterNumericRuleEvaluator
Base for all classes that compare numeric values from Revit to a user-supplied filter value.
FilterNumericValueRule
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
FilterRule
Defines a boolean operation that can be used to cull elements from a document.
FilterStringBeginsWith
Tests whether string values from the document begin with a certain string.
FilterStringContains
Tests whether string values from the document contain a certain string.
FilterStringEndsWith
Tests whether string values from the document end with a certain string.
FilterStringEquals
Tests whether string values from the document match a certain string.
FilterStringGreater
Tests whether string values from the document would sort after a certain string.
FilterStringGreaterOrEqual
Tests whether string values from the document would sort after or match a certain string.
FilterStringLess
Tests whether string values from the document would sort before a certain string.
FilterStringLessOrEqual
Tests whether string values from the document would sort before or match a certain string.
FilterStringRule
A filter rule that operates on string values in a Revit project.
FilterStringRuleEvaluator
Base for all classes that compare string values from Revit to a user-supplied filter value
FilterValueRule
A rule that filters on a particular value of an element.
Floor
An object that represents a Floor within the Autodesk Revit project.
FloorType
An object that specifies the type of a floor in Autodesk Revit.
FloorTypeSet
A set that contains floor types.
FloorTypeSetIterator
An iterator to a floor type set.
FootPrintRoof
Represents kinds of FootPrintRoofs.
Form
An object that represents a Form within the Autodesk Revit Massing Family.
FormArray
An array that contains form objects.
FormArrayIterator
An iterator to a form array.
FormatOptions
Contains the Unit information of current user selection of Unit within the project.
FormUtils
Define Form utility functions
GBXMLExportOptions
Green-Building XML Export options.
GBXMLImportOptions
Import options for Green-Building XML format.
GenericForm
Provides access to the Generic Form model in Autodesk Revit.
GenericFormSet
A set that can contain any type of object.
GenericFormSetIterator
An iterator to a set.
GenericImportOptions
Generic Import options.
GeomCombination
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
GeomCombinationSet
A set that contains GeomCombination objects.
GeomCombinationSetIterator
An iterator to a GeomCombination set.
GeometryElement
Geometric representation of an element.
GeometryInstance
An instance of another element (symbol), specially positioned by this element.
GeometryObject
The common base class for all geometric primitives.
GeometryObjectArray
An array that contains geometry objects.
GeometryObjectArrayIterator
An iterator to a geometry object array.
GraphicsStyle
The graphics style instance in Autodesk Revit document.
Grid
Represents a single grid line within Autodesk Revit.
GridType
An object that represents a grid type.
GridTypeSet
A set that contains grid types.
GridTypeSetIterator
An iterator to a grid type set.
Group
This object represents a group of elements within the project.
GroupSet
An set that contains groups.
GroupSetIterator
An iterator to a group set.
GroupType
Represents a type of a user defined group.
GuidEnum
Base class of all GUID-based enum classes.
HermiteFace
A cubic hermite spline face of a 3d solid.
HermiteSpline
A Hermite spline.
HostedSweep
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
HostedSweepType
An object that represents the attributes for sweep host objects in Autodesk Revit.
HostObjAttributes
An object that represents characteristics of several kinds of type.
HostObject
A base class that provides support for all objects that can host other objects, such as a wall.
IFCExportOptions
IFC Export options.
ImageExportOptions
This class defines options for exporting views and sheets as an image.
ImageImportOptions
Import options specific image (bitmap) formats.
ImportInstance
An element created during either import or link operation in Autodesk Revit.
IndependentTag
Represents an IndependentTag within Autodesk Revit.
InsertableObject
A base class you all types that are insertable.
InSessionPrintSetting
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
InSessionViewSheetSet
Represents the in-session ViewSheetSet.
Instance
A base class for all instance objects.
InstanceArray
An array that contains instances.
InstanceArrayIterator
An iterator to an instance array.
InstanceBinding
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
InternalDefinition
This object represents a parameter definition in Autodesk Revit.
InternalDefinitions
This object blocks attempts to create new internal definitions as they are not permitted.
IntersectionResult
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
IntersectionResultArray
An array that can contain any type of object.
IntersectionResultArrayIterator
An iterator to a array.
InventorImportOptions
Import options for Inventor format.
LabelUtils
Used to obtain user-visible name for certain enums.
LayoutRule
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
LayoutRuleClearSpacing
This class indicate the layout rule of a Beam System is Clear-Spacing.
LayoutRuleFixedDistance
This class indicate the layout rule of a Beam System is Fixed-Distance.
LayoutRuleFixedNumber
This class indicate the layout rule of a Beam System is Fixed-Number.
LayoutRuleMaximumSpacing
This class indicate the layout rule of a Beam System is Max-Spacing.
Leader
An object that represents a Leader within the Autodesk Revit project.
LeaderArray
An array that can contain any number of leaders.
LeaderArrayIterator
An iterator to an array of leaders.
Level
Represents a Level line within Autodesk Revit.
LevelType
An object that represents a Level type.
LevelTypeSet
A set that contains level types.
LevelTypeSetIterator
An iterator to a level type set.
Line
A line in space.
LineAndTextAttrSymbol
An object that represents a dimension style.
LinearArray
An object that represents an Array created linearly within the Revit project.
LinePattern
Represents a line pattern element within an Autodesk Revit project.
LinePatternSet
A set that can contain any number of line patterns.
LinePatternSetIterator
An iterator to a set.
LinkElementId
LinkElementId represents an element in a linked document.
Location
Provides location functionality for all elements.
LocationCurve
Provides location functionality for all elements that are based upon a curve.
LocationPoint
Provides location functionality for all elements that have a single insertion point.
LogicalAndFilter
A filter that contains a set of filters. The filter passes when all filters in the set pass.
LogicalOrFilter
A filter that contains a set of filters. The filter passes when any filter in the set passes.
MassInstanceUtils
A static class that contains extra methods for processing curves driven by points.
Material
Represents a material element within an Autodesk Revit project.
MaterialConcrete
Represents a concrete material element in an Autodesk Revit project.
MaterialGeneric
Represents a generic material element in an Autodesk Revit project.
MaterialOther
Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.
Materials
A set of materials that provides access to the materials in an Autodesk Revit project.
MaterialSet
An set that contains materials.
MaterialSetIterator
An iterator to a material set.
MaterialSteel
Represents a steel material element in an Autodesk Revit project.
MaterialWood
Represents a wood material element in an Autodesk Revit project.
MEPCurve
A curve object for duct or pipe blend elements.
MEPCurveType
A curve type for duct type or pipe type.
MEPModel
Supports all MEP models that are persistent within the Autodesk Revit project
MEPSystem
A system in the Autodesk Revit MEP product.
Mesh
A triangular mesh.
MeshArray
An array that contains meshes.
MeshArrayIterator
An iterator to a mesh array.
MeshTriangle
One triangle of a mesh.
ModelArc
Represents a ModelArc within Autodesk Revit.
ModelCurve
A model element that exists in 3D space and is visible in all views of a Revit project.
ModelCurveArrArray
An array that can contain any type of object.
ModelCurveArrArrayIterator
An iterator to a array.
ModelCurveArray
An array that contains model curves.
ModelCurveArrayIterator
An iterator to a model curve array.
ModelEllipse
Represents a ModelEllipse within Autodesk Revit.
ModelHermiteSpline
Represents a ModelHermiteSpline within Autodesk Revit.
ModelLine
Represents a ModelLine within Autodesk Revit.
ModelNurbSpline
Represents a ModelNurbSpline within Autodesk Revit.
ModelText
A model text element in an Autodesk Revit family document.
ModelTextType
A model text type symbol in the Autodesk Revit Family document.
Mullion
Represents a CurtainGrid within Autodesk Revit.
MullionType
An object that represents a mullion type.
MullionTypeSet
A set that contains mullion types.
MullionTypeSetIterator
An iterator to a mullion type set.
NurbSpline
A nurb spline.
ObjectFactory
For Internal Use Only.
Opening
An opening in an Autodesk Revit project or family document.
Options
User preferences for parsing of geometry.
Outline
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Panel
This object represents a curtain panel.
PanelType
An object that represents a curtain panel type.
PanelTypeSet
A set that contains panel types.
PanelTypeSetIterator
An iterator to a panel type set.
PaperSize
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
PaperSizeSet
A set that can contain any number of paper size objects.
PaperSizeSetIterator
An iterator to a set of paper size objects.
PaperSource
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
PaperSourceSet
A set that can contain any number of paper source objects.
PaperSourceSetIterator
An iterator to a set of paper source objects.
Parameter
The parameter object contains the value data assigned to that parameter.
ParameterFilterElement
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
ParameterFilterRuleFactory
Contains functions that create appropriate FilterRule objects based on the parameters given.
ParameterFilterUtilities
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
ParameterMap
A map that can contain a mapping of a parameter name (a String) to a parameter.
ParameterMapIterator
An iterator to a map relating a parameter name (the key, a String) to a parameter.
ParameterSet
A set that contains parameters.
ParameterSetIterator
An iterator to a parameter set.
ParameterValueProvider
Gets the value of a parameter from any element passed to getStringValue, getDoubleValue, getIntegerValue, or getElementIdValue.
Path3d
Provides access to the Generic 3D path object in Autodesk Revit.
Phase
Represents a phase in the life of a building.
PhaseArray
An array that contains phase objects.
PhaseArrayIterator
An iterator to a phase array.
PlanarFace
A planar face of a 3d solid.
PlanCircuit
An object that represents an enclosed area in a plan view within the Autodesk Revit project.
PlanCircuitSet
A set that can contain any number of plan circuit objects.
PlanCircuitSetIterator
An iterator to a set of plan circuit objects.
Plane
Provides access to the geometry plane object.
PlanTopology
An object that represents a Plan Topology within the Autodesk Revit project.
PlanTopologySet
A set that can contain any number of plan topology objects.
PlanTopologySetIterator
An iterator to a set of plan topology objects.
Point
A 3D point.
PointElementReference
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
PointOnEdge
Define a ReferencePoint relative to a referenceable edge or curve on another element.
PointOnEdgeEdgeIntersection
Define a ReferencePoint at the intersection of two referenceable lines.
PointOnEdgeFaceIntersection
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
PointOnFace
Define a ReferencePoint relative to a Face.
PointOnPlane
Define a ReferencePoint relative to a planar reference.
PrimaryDesignOptionMemberFilter
A filter used to find elements contained in any primary design option of any design option set.
PrintManager
The PrintManager object is used to configure the global print settings.
PrintParameters
An object that contains settings used for printing the document.
PrintSetting
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
PrintSetup
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Profile
A geometric profile consisting of a loop of curves.
ProjectInfo
An object that represents a Project Information within the Autodesk Revit project.
ProjectLocation
An object that represents a named location in a project.
ProjectLocationSet
An set that contains project locations.
ProjectLocationSetIterator
An iterator to a project location set.
ProjectPosition
An object that is used to represent a geographical offset and rotation.
ProjectUnit
Provides access to the Project Unit... in Autodesk Revit.
PropertyLine
Represents kinds of PropertyLines.
RadialArray
An object that represents a Radial Array in the Revit project.
Rectangle
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Reference
A stable reference to a geometric object in a Revit model.
ReferenceArray
ReferenceArrayArray
An array that contains ReferenceArray objects.
ReferenceArrayArrayIterator
An iterator to a ReferenceArray array.
ReferenceArrayIterator
An iterator to a reference array.
ReferencePlane
Represents a reference plane of Autodesk Revit.
ReferencePoint
A reference point in an Autodesk Revit family.
ReferencePointArray
ReferencePointArrayIterator
RevitUIFamilyLoadOptions
Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Revolution
A revolution solid or void form.
RevolvedFace
A revolved face of a 3d solid.
RoofBase
Represents all kinds of Roofs.
RoofType
Represents a specific type of roof.
RoofTypeSet
A set that contains roof types.
RoofTypeSetIterator
An iterator to a roof type set.
RuledFace
A ruled face of a 3d solid.
SATExportOptions
SAT Export options.
Settings
The settings object provides access to general components of the Autodesk Revit application, such as Categories.
SharedParameterApplicableRule
Tests whether an element supports a shared parameter.
SiteLocation
Contains the geographical location information for the project's site.
Sketch
Provides access to the Sketch in Autodesk Revit.
SketchBase
Provides access to the SketchBase in Autodesk Revit.
SketchPlane
Represents a sketch plane or work plane within Autodesk Revit.
SlabEdge
An object that represents a slab edge within the Autodesk Revit project.
SlabEdgeType
An object that represents the slab edge type in Autodesk Revit.
SlabEdgeTypeSet
A set that contains slab edge types.
SlabEdgeTypeSetIterator
An iterator to a slab edge type set.
SlabShapeCrease
A crease used in Slab Shape Editing.
SlabShapeCreaseArray
An array that can contain any number of creases used in Slab Shape Editing.
SlabShapeCreaseArrayIterator
An iterator to an array of creases used for Slab Shape Editing.
SlabShapeEditor
An object used for Slab Shape Editing.
SlabShapeVertex
A vertex used in Slab Shape Editing.
SlabShapeVertexArray
An array that can contain any number of vertices used in Slab Shape Editing.
SlabShapeVertexArrayIterator
An iterator to an array of vertices used for Slab Shape Editing.
Solid
A 3d solid.
SolidArray
An array that contains solids.
SolidArrayIterator
An iterator to a solids array.
SolidSolidCutUtils
These utilities are applicable for the generic forms, geometry combinations and family instances in editor situations
SpacingRule
A rule for specifying a set of equidistant, parallel gridlines within a region.
SpotDimension
An object that represents a spot dimension within the Revit project.
SpotDimensionType
An object that specifies the type of a spot dimension in Autodesk Revit.
SpotDimensionTypeSet
A set that contains spotdimension types.
SpotDimensionTypeSetIterator
An iterator to a spotdimension type set.
SubTransaction
Sub-transactions are objects that allow controlling a subset of changes in a document
SunAndShadowSettings
The SunAndShadowSettings class represents the sun control.
SuspendUpdating
Temporarily delay Revit's automatic updating and consistency operations.
Sweep
A sweep solid or void form.
SweepProfile
Represents a profile for sweep or swept blend elements.
SweptBlend
A swept blend solid or void form.
SymbolicCurve
A curve that provides information but is not intended to represent actual geometry in an element.
SymbolicCurveArray
An array that contains model curves.
SymbolicCurveArrayIterator
An iterator to a model curve array.
TableCellCalculatedValueData
The TableCellCalculatedValueData stores the data for calculated value
TableCellCombinedParameterData
The TableCellCombinedParameterData stores the data for combined parameters
TableCellStyle
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
TableData
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
TableMergedCell
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
TableSectionData
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
TableView
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
TextElement
Represents the TextElment.
TextElementType
An object that represents a text style.
TextNote
Provides access to the TextNote object in Autodesk Revit.
TextNoteType
An object that represents a text note style.
TextNoteTypeSet
A set that contains textnote types.
TextNoteTypeSetIterator
An iterator to a textnote type set.
TilePattern
An object representing a tile pattern that may be applied to a DividedSurface.
TilePatterns
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
TopographySurface
An object that is used to represent a topography surface.
Transaction
Transactions are context-like objects that guard any changes made to a Revit model
TransactionGroup
This class is introduced to group a set of transactions
Transform
A transformation of the affine 3-space.
TypeBinding
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
UpdaterData
Service class that is passed to an Updater to prove access to update execution context
UpdaterId
A unique identifier of an Updater
UpdaterRegistry
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.
UV
Object representing coordinates in 2-dimensional space.
VertexIndexPair
Represents a connection between vertices in the top and bottom profile of a blend.
VertexIndexPairArray
An array that contains VertexIndex pairs.
VertexIndexPairArrayIterator
An iterator to an array of VertexIndex pairs.
View
Base class for all types of views in Autodesk Revit.
View3D
A freely-oriented orthographic or perspective view of the model.
ViewDrafting
A drafting view allows the user to draw graphics without including them in the model.
ViewPlan
A plan represents for floor plan or ceiling plan.
ViewSection
A section view cuts through the model to expose its interior structure.
ViewSet
A set that contains views.
ViewSetIterator
An iterator to a view set.
ViewSheet
A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.
ViewSheetSet
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
ViewSheetSets
A set that can contain any type of object.
ViewSheetSetsIterator
An iterator to a set.
ViewSheetSetting
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
VolumeCalculationOptions
This class provides access to options related to room volume and area computations.
VolumeCalculationSetting
This class provides access to settings related to room volume and area computations.
Wall
Represents all of the different kinds of walls Autodesk Revit.
WallType
Represents a specific type of wall, such as 'Generic -8" '.
WallTypeSet
A set that contains wall types.
WallTypeSetIterator
An iterator to a wall type set.
XYZ
Object representing coordinates in 3-dimensional space.

Structures

Structure | Description
GridNode |

Interfaces

Interface | Description
IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
IExtension | An interface that supports the additional operation for Extension Status
IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
IFamilyLoadOptions | An interface class which provide the callback for family load options.
IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.

Enumerations

Enumeration | Description
ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
AreaElemType | An enumerated type to store type of AreaElement.
BeamSystemJustifyType | Describes the justify method of beamsystem.
BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
BoxPlacement | An enumerated type listing possible placement of a box (an object of rectangular shape.)
BuildingType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
BuiltInCategory | A list of all the built in categories within Revit.
BuiltInParameter | An enumerated type listing all of the built-in parameter ids supported by Autodesk Revit.
BuiltInParameterGroup | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
CellType | Declares the cell data type.
ChangePriority | Enum used to specify the priority of an Updater during execution.
ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
ConnectorProfileType | An enumerated type listing all the connector profile types for a connection.
ConnectorType | An enumerated type listing all the connector types for a connection.
ConstructionType | Obsolete. An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
CurveElementType |
CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
CutFailureReason | The reason why a solid/solid cut cannot be created.
DecimalSymbolType | An enumerated type listing two types of the Decimal Symbol types that Autodesk Revit supports.
DetailLevels | Chooses the detail level of an element's representation.
DigitGroupingAmount | An enumerated type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
DigitGroupingSymbolType | An enumerated type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
DimensionShape | An enumerated type to list dimension type.
DimensionStyleType | An enumerated type containing possible style types of dimensions.
DisplayUnit | Describes the type of Revit display unit, metric or imperial.
DisplayUnitType | An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.
DocumentType | Types of Revit documents.
Domain | An enumerated type listing all the possible domain types that can be assigned to a connector.
DWFImageFormat | An enumerated type listing possible image format for DWF Export.
DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
EaveCutterType | An enumerated type to store type of EaveCutter.
ElementReferenceType | Element reference types.
ExportColorMode | An enumerated type listing export color mode.
ExportPaperFormat | Paper formats supported by DWF export
ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
ExportUnit | An enumerated type listing possible target units for CAD Export.
FailureProcessingResult | Enum represents result of failure processing by FailuresPreprocessor, handler of FailuresProcessing event or by FailuresProcessor.
FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
FailureSeverity | Enum represents severity of a failure.
FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
FamilySource | Describes which version of the family to be loaded.
FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
FloorFace | An enumerated type listing floor face types (top or bottom)
FlowDirectionType | An enumerated type listing direction types for a connector.
GraphicsStyleType | Describes the type of graphics style.
GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
HorizontalAlign | Horizontal alignment of model text.
HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
ImageFileType | This enum is used to define exported file type.
ImageResolution | This enum is used to define image resolution in order to calculate the image size.
ImportColorMode | An enumerated type listing how colors are handled in an import process.
ImportExportFileFormat | Formats supported import / export
ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
ImportUnit | An enumerated type listing possible target units for CAD Export.
JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
JunctionType | An enumerated type listing all the junction types for MEP curve types.
LeaderEndCondition | An enumerated type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.
LineScaling | An enumerated type listing possible LineType scaling modes.
MarginType | An enumerated type listing all Margin types of Print Setting.
MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
MaterialBehaviourType | An enumerated type listing all the material behavior type.
PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting.
PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
ParameterType | An enumerated type listing all of the data type interpretation that Autodesk Revit supports.
PartType | An enumerated type listing all the possible part types for a fitting.
PrintRange | An enumerated type listing all Print Range types of Print.
ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
RasterQualityType |
ReferenceType | Reference types of curve element.
SectionType | Declares the section data type.
ServiceType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
SlabShapeCreaseType | An enumerated type listing all Crease types of Slab Shape Edit.
SlabShapeVertexType | An enumerated type listing all Vertex types of Slab Shape Edit.
SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
SpacingRuleJustification | Justification property of a spacing rule. See SpacingRule.
SpacingRuleLayout | Rules for laying out a series of equidistant parallel lines. See SpacingRule.
StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
SunAndShadowType | Sun study type enum of SunAndShadowSettings.
SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
TagMode | An enumerated type listing Tag Mode when user adding tag that Autodesk Revit supports.
TagOrientation | An enumerated type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.
TextAlignFlags | An enumerated type listing all the Text align flags.
TextAlignMask | An enumerated type listing all the Text align mask.
TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
TextNoteLeaderTypes | An enumerated type listing all the Leader types.
TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
TransactionStatus |
UnitGroup | An enumerated type listing Discipline of the Unit types that Autodesk Revit supports.
UnitSymbolType | An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.
UnitType | An enumerated type listing all the Unit types that Autodesk Revit supports.
VerticalAlignmentStyle | Declares the vertical alignment style of font.
ViewPlanType | An enumerated type listing plan view types.
ViewType | An enumerated type listing available view types.)
VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Visibility | Describes the visibility of a particular geometry object.
WallFunction | Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.
WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
ZoomFitType | This enum is used to define type of zoom.
ZoomType | An enumerated type listing all Zoom types of Print Setting.


ACADExportOptions Class

[image]

Revit 2011 API
ACADExportOptions Class
Members See Also Send Feedback
Export options specific to AutoCAD file formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ACADExportOptions : CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class ACADExportOptions abstract : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.ACADExportOptions
Autodesk.Revit.DB..::.DWGExportOptions
Autodesk.Revit.DB..::.DXFExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit.DB Namespace


ACADExportOptions Members

[image] [image]

Revit 2011 API
ACADExportOptions Members
ACADExportOptions Class Methods Properties See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Export color mode.
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportOfSolids | Mode of exporting solids in 3D views.
FileVersion | AutoCAD file version.
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
LineScaling | LineType scaling mode.
PropOverrides | How to export overridden object styles.
SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
TargetUnit | Type of units in the target CAD format.

See Also

ACADExportOptions Class


ACADExportOptions Methods

[image] [image]

Revit 2011 API
ACADExportOptions Methods
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ACADExportOptions Class


ACADExportOptions Properties

[image] [image]

Revit 2011 API
ACADExportOptions Properties
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Properties

Name | Description
Colors | Export color mode.
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportOfSolids | Mode of exporting solids in 3D views.
FileVersion | AutoCAD file version.
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
LineScaling | LineType scaling mode.
PropOverrides | How to export overridden object styles.
SharedCoords | Whether to use shared coordinate system or a project's. internal origin.
TargetUnit | Type of units in the target CAD format.

See Also

ACADExportOptions Class


Colors Property

[image]

Revit 2011 API
ACADExportOptions..::.Colors Property
ACADExportOptions Class See Also Send Feedback
Export color mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ExportColorMode Colors { get; set; }
Visual Basic (Declaration)
Public Property Colors As ExportColorMode
Visual C++
public:
property ExportColorMode Colors {
    ExportColorMode get ();
    void set (ExportColorMode value);
}

See Also

ACADExportOptions Class


ExportingAreas Property

[image]

Revit 2011 API
ACADExportOptions..::.ExportingAreas Property
ACADExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic (Declaration)
Public Property ExportingAreas As Boolean
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


ExportOfSolids Property

[image]

Revit 2011 API
ACADExportOptions..::.ExportOfSolids Property
ACADExportOptions Class See Also Send Feedback
Mode of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic (Declaration)
Public Property ExportOfSolids As SolidGeometry
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

See Also

ACADExportOptions Class


FileVersion Property

[image]

Revit 2011 API
ACADExportOptions..::.FileVersion Property
ACADExportOptions Class See Also Send Feedback
AutoCAD file version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ACADVersion FileVersion { get; set; }
Visual Basic (Declaration)
Public Property FileVersion As ACADVersion
Visual C++
public:
property ACADVersion FileVersion {
    ACADVersion get ();
    void set (ACADVersion value);
}

See Also

ACADExportOptions Class


ForcedHLR Property

[image]

Revit 2011 API
ACADExportOptions..::.ForcedHLR Property
ACADExportOptions Class See Also Send Feedback
Whether to enforce Hidden Lines Removal in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ForcedHLR { get; set; }
Visual Basic (Declaration)
Public Property ForcedHLR As Boolean
Visual C++
public:
property bool ForcedHLR {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


LayerMapping Property

[image]

Revit 2011 API
ACADExportOptions..::.LayerMapping Property
ACADExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic (Declaration)
Public Property LayerMapping As String
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Remarks

Valid standards are: AIA, CP83, BS1192, and ISO13567.

See Also

ACADExportOptions Class


LineScaling Property

[image]

Revit 2011 API
ACADExportOptions..::.LineScaling Property
ACADExportOptions Class See Also Send Feedback
LineType scaling mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineScaling LineScaling { get; set; }
Visual Basic (Declaration)
Public Property LineScaling As LineScaling
Visual C++
public:
property LineScaling LineScaling {
    LineScaling get ();
    void set (LineScaling value);
}

See Also

ACADExportOptions Class


PropOverrides Property

[image]

Revit 2011 API
ACADExportOptions..::.PropOverrides Property
ACADExportOptions Class See Also Send Feedback
How to export overridden object styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PropOverrideMode PropOverrides { get; set; }
Visual Basic (Declaration)
Public Property PropOverrides As PropOverrideMode
Visual C++
public:
property PropOverrideMode PropOverrides {
    PropOverrideMode get ();
    void set (PropOverrideMode value);
}

See Also

ACADExportOptions Class


SharedCoords Property

[image]

Revit 2011 API
ACADExportOptions..::.SharedCoords Property
ACADExportOptions Class See Also Send Feedback
Whether to use shared coordinate system or a project's. internal origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SharedCoords { get; set; }
Visual Basic (Declaration)
Public Property SharedCoords As Boolean
Visual C++
public:
property bool SharedCoords {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


TargetUnit Property

[image]

Revit 2011 API
ACADExportOptions..::.TargetUnit Property
ACADExportOptions Class See Also Send Feedback
Type of units in the target CAD format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic (Declaration)
Public Property TargetUnit As ExportUnit
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

See Also

ACADExportOptions Class


ACADImportOptions Class

[image]

Revit 2011 API
ACADImportOptions Class
Members See Also Send Feedback
Import options specific to AutoCAD file formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ACADImportOptions : CADImportOptions
Visual Basic (Declaration)
Public MustInherit Class ACADImportOptions _
    Inherits CADImportOptions
Visual C++
public ref class ACADImportOptions abstract : public CADImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GenericImportOptions
Autodesk.Revit.DB..::.CADImportOptions
Autodesk.Revit.DB..::.ACADImportOptions
Autodesk.Revit.DB..::.DWGImportOptions

See Also

ACADImportOptions Members


ACADImportOptions Members

[image] [image]

Revit 2011 API
ACADImportOptions Members
ACADImportOptions Class Methods Properties See Also Send Feedback

The ACADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class


ACADImportOptions Methods

[image] [image]

Revit 2011 API
ACADImportOptions Methods
ACADImportOptions Class See Also Send Feedback

The ACADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ACADImportOptions Class


ACADImportOptions Properties

[image] [image]

Revit 2011 API
ACADImportOptions Properties
ACADImportOptions Class See Also Send Feedback

The ACADImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import.
LineWeights | A Byte array of line weights for the DWG/DXF Color number.
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers.

See Also

ACADImportOptions Class


LayerSelection Property

[image]

Revit 2011 API
ACADImportOptions..::.LayerSelection Property
ACADImportOptions Class See Also Send Feedback
The layers collection for import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StringCollection LayerSelection { get; set; }
Visual Basic (Declaration)
Public Property LayerSelection As StringCollection
Visual C++
public:
property StringCollection^ LayerSelection {
    StringCollection^ get ();
    void set (StringCollection^ value);
}

Remarks

Specify the names of layers and levels to import.

See Also

ACADImportOptions Class


LineWeights Property

[image]

Revit 2011 API
ACADImportOptions..::.LineWeights Property
ACADImportOptions Class See Also Send Feedback
A Byte array of line weights for the DWG/DXF Color number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte[] LineWeights { get; set; }
Visual Basic (Declaration)
Public Property LineWeights As Byte()
Visual C++
public:
property array<unsigned char>^ LineWeights {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Import pen numbers from a DWG or DXF file and map them to a line weight.

See Also

ACADImportOptions Class


VisibleLayersOnly Property

[image]

Revit 2011 API
ACADImportOptions..::.VisibleLayersOnly Property
ACADImportOptions Class See Also Send Feedback
Only import the visible layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool VisibleLayersOnly { get; set; }
Visual Basic (Declaration)
Public Property VisibleLayersOnly As Boolean
Visual C++
public:
property bool VisibleLayersOnly {
    bool get ();
    void set (bool value);
}

Remarks

If this option is set to true, only visible layers are imported.

See Also

ACADImportOptions Class


ACADVersion Enumeration

[image]

Revit 2011 API
ACADVersion Enumeration
See Also Send Feedback
An enumerated type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ACADVersion
Visual Basic (Declaration)
Public Enumeration ACADVersion
Visual C++
public enum class ACADVersion

Members

Member name | Description
Default | The Autodesk Revit application's default export format.
R2000 | AutoCAD 2000 file format.
R2004 | AutoCAD 2004 file format.
R2007 | AutoCAD 2007 file format.

See Also


AddInId Class

[image]

Revit 2011 API
AddInId Class
Members See Also Send Feedback
Identifies an AddIn registered with Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AddInId : IDisposable
Visual Basic (Declaration)
Public Class AddInId _
    Implements IDisposable
Visual C++
public ref class AddInId : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.AddInId

See Also

AddInId Members


AddInId Members

[image] [image]

Revit 2011 API
AddInId Members
AddInId Class Constructors Methods See Also Send Feedback

The AddInId type exposes the following members.

Constructors

Name | Description
AddInId | creates an AddInId object with a given GUID

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
GetGUID | value of the AddInId as a GUID
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class


AddInId Constructor

[image]

Revit 2011 API
AddInId Constructor
AddInId Class See Also Send Feedback
creates an AddInId object with a given GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AddInId(
    Guid val
)
Visual Basic (Declaration)
Public Sub New ( _
    val As Guid _
)
Visual C++
public:
AddInId(
    Guid val
)

Parameters

val
Type: System..::.Guid
GUID value

See Also

AddInId Class


AddInId Methods

[image] [image]

Revit 2011 API
AddInId Methods
AddInId Class See Also Send Feedback

The AddInId type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
GetGUID | value of the AddInId as a GUID
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class


Dispose Method

[image]

Revit 2011 API
AddInId..::.Dispose Method
AddInId Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AddInId Class


GetAddInName Method

[image]

Revit 2011 API
AddInId..::.GetAddInName Method
AddInId Class See Also Send Feedback
name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetAddInName()
Visual Basic (Declaration)
Public Function GetAddInName As String
Visual C++
public:
String^ GetAddInName()

Return Value

name of addin

See Also

AddInId Class


GetAddInNameFromDocument Method

[image]

Revit 2011 API
AddInId..::.GetAddInNameFromDocument Method
AddInId Class See Also Send Feedback
name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetAddInNameFromDocument(
    Document aDoc
)
Visual Basic (Declaration)
Public Function GetAddInNameFromDocument ( _
    aDoc As Document _
) As String
Visual C++
public:
String^ GetAddInNameFromDocument(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
target document

Return Value

name of application

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AddInId Class


GetGUID Method

[image]

Revit 2011 API
AddInId..::.GetGUID Method
AddInId Class See Also Send Feedback
value of the AddInId as a GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Guid GetGUID()
Visual Basic (Declaration)
Public Function GetGUID As Guid
Visual C++
public:
Guid GetGUID()

Return Value

GUID value of the AddInId

See Also

AddInId Class


AnalyzesAsType Enumeration

[image]

Revit 2011 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyzesAsType
Visual Basic (Declaration)
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Hanger |
AA_Gravity |
AA_Lateral |
AA_Slab |
AA_Mat |
AA_SlabOnGrade |
AA_Not_For_Analysis |

See Also


AnnotationSymbol Class

[image]

Revit 2011 API
AnnotationSymbol Class
Members See Also Send Feedback
This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AnnotationSymbol : FamilyInstance
Visual Basic (Declaration)
Public Class AnnotationSymbol _
    Inherits FamilyInstance
Visual C++
public ref class AnnotationSymbol : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.FamilyInstance
Autodesk.Revit.DB..::.AnnotationSymbol

See Also

AnnotationSymbol Members


AnnotationSymbol Members

[image] [image]

Revit 2011 API
AnnotationSymbol Members
AnnotationSymbol Class Methods Properties See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
removeLeader | remove a leader of this annotation symbol.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbol Class


AnnotationSymbol Methods

[image] [image]

Revit 2011 API
AnnotationSymbol Methods
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
addLeader | add a leader to this annotation symbol.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
duplicate | Duplicate this annotation symbol.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
removeLeader | remove a leader of this annotation symbol.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbol Class


addLeader Method

[image]

Revit 2011 API
AnnotationSymbol..::.addLeader Method
AnnotationSymbol Class See Also Send Feedback
add a leader to this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void addLeader()
Visual Basic (Declaration)
Public Sub addLeader
Visual C++
public:
void addLeader()

See Also

AnnotationSymbol Class


duplicate Method

[image]

Revit 2011 API
AnnotationSymbol..::.duplicate Method
AnnotationSymbol Class See Also Send Feedback
Duplicate this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbol duplicate()
Visual Basic (Declaration)
Public Function duplicate As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ duplicate()

Return Value

Pointer to the new annotation symbol.

See Also

AnnotationSymbol Class


removeLeader Method

[image]

Revit 2011 API
AnnotationSymbol..::.removeLeader Method
AnnotationSymbol Class See Also Send Feedback
remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void removeLeader()
Visual Basic (Declaration)
Public Sub removeLeader
Visual C++
public:
void removeLeader()

See Also

AnnotationSymbol Class


AnnotationSymbol Properties

[image] [image]

Revit 2011 API
AnnotationSymbol Properties
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Properties

Name | Description
AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Leaders | Get all the leaders of this annotation symbol.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbol Class


AnnotationSymbolType Property

[image]

Revit 2011 API
AnnotationSymbol..::.AnnotationSymbolType Property
AnnotationSymbol Class See Also Send Feedback
The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Visual Basic (Declaration)
Public Property AnnotationSymbolType As AnnotationSymbolType
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the wall. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class


AsFamilyInstance Property

[image]

Revit 2011 API
AnnotationSymbol..::.AsFamilyInstance Property
AnnotationSymbol Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")]
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")> _
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
[ObsoleteAttribute(L"This property is no longer needed because AnnotationSymbol now derives from FamilyInstance.")]
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

This property is obsolete because AnnotationSymbol now derives from FamilyInstance.

See Also

AnnotationSymbol Class


FromRoom Property

[image] [image]

Revit 2011 API
AnnotationSymbol..::.FromRoom Property
AnnotationSymbol Class See Also Send Feedback
The room from which the door or window is opened.

Overload List

Name | Description
FromRoom | The room from which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
FromRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Leaders Property

[image]

Revit 2011 API
AnnotationSymbol..::.Leaders Property
AnnotationSymbol Class See Also Send Feedback
Get all the leaders of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Return Value

The Leaders property returns a leader array that contains all the leaders of this annotation symbol.

See Also

AnnotationSymbol Class


Parameter Property

[image] [image]

Revit 2011 API
AnnotationSymbol..::.Parameter Property
AnnotationSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Room Property

[image] [image]

Revit 2011 API
AnnotationSymbol..::.Room Property
AnnotationSymbol Class See Also Send Feedback
The room in which the instance is located.

Overload List

Name | Description
Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Room[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Space Property

[image] [image]

Revit 2011 API
AnnotationSymbol..::.Space Property
AnnotationSymbol Class See Also Send Feedback
The space in which the instance is located.

Overload List

Name | Description
Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Space[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


ToRoom Property

[image] [image]

Revit 2011 API
AnnotationSymbol..::.ToRoom Property
AnnotationSymbol Class See Also Send Feedback
The room to which the door or window is opened.

Overload List

Name | Description
ToRoom | The room to which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
ToRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


AnnotationSymbolType Class

[image]

Revit 2011 API
AnnotationSymbolType Class
Members See Also Send Feedback
An object that represents an annotation style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AnnotationSymbolType : FamilySymbol
Visual Basic (Declaration)
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB..::.AnnotationSymbolType

See Also

AnnotationSymbolType Members


AnnotationSymbolType Members

[image] [image]

Revit 2011 API
AnnotationSymbolType Members
AnnotationSymbolType Class Methods Properties See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbolType Class


AnnotationSymbolType Methods

[image] [image]

Revit 2011 API
AnnotationSymbolType Methods
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolType Class


AnnotationSymbolType Properties

[image] [image]

Revit 2011 API
AnnotationSymbolType Properties
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnnotationSymbolType Class


Parameter Property

[image] [image]

Revit 2011 API
AnnotationSymbolType..::.Parameter Property
AnnotationSymbolType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnnotationSymbolType Class
AnnotationSymbolType Members


AnnotationSymbolTypeSet Class

[image]

Revit 2011 API
AnnotationSymbolTypeSet Class
Members See Also Send Feedback
A set that contains AnnotationSymbol types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AnnotationSymbolTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AnnotationSymbolTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AnnotationSymbolTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.AnnotationSymbolTypeSet

See Also

AnnotationSymbolTypeSet Members


AnnotationSymbolTypeSet Members

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSet Members
AnnotationSymbolTypeSet Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Constructors

Name | Description
AnnotationSymbolTypeSet | Initializes a new instance of the AnnotationSymbolTypeSet class

Methods

Name | Description
Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Contains | Tests for the existence of a AnnotationSymbol type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified AnnotationSymbol type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified AnnotationSymbol type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Constructor

[image]

Revit 2011 API
AnnotationSymbolTypeSet Constructor
AnnotationSymbolTypeSet Class See Also Send Feedback
Initializes a new instance of the AnnotationSymbolTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSet()

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Methods

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSet Methods
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Contains | Tests for the existence of a AnnotationSymbol type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified AnnotationSymbol type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified AnnotationSymbol type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSet Class


Clear Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.Clear Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes every AnnotationSymbol type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AnnotationSymbolTypeSet Class


Contains Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.Contains Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Tests for the existence of a AnnotationSymbol type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AnnotationSymbolType
The AnnotationSymbol type to be searched for.

Return Value

The Contains method returns True if the AnnotationSymbol type is within the set, otherwise False.

See Also

AnnotationSymbolTypeSet Class


Erase Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.Erase Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes a specified AnnotationSymbol type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AnnotationSymbolType _
) As Integer
Visual C++
public:
virtual int Erase(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AnnotationSymbolType
The AnnotationSymbol type to be erased.

Return Value

The number of AnnotationSymbol types that were erased from the set.

See Also

AnnotationSymbolTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.ForwardIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.GetEnumerator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AnnotationSymbolTypeSet Class


Insert Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.Insert Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Insert the specified AnnotationSymbol type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    AnnotationSymbolType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AnnotationSymbolType
The AnnotationSymbol type to be inserted into the set.

Return Value

Returns whether the AnnotationSymbol type was inserted into the set.

See Also

AnnotationSymbolTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.ReverseIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Properties

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSet Properties
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.IsEmpty Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AnnotationSymbolTypeSet Class


Size Property

[image]

Revit 2011 API
AnnotationSymbolTypeSet..::.Size Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Returns the number of AnnotationSymbol types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSetIterator Class

[image]

Revit 2011 API
AnnotationSymbolTypeSetIterator Class
Members See Also Send Feedback
An iterator to a AnnotationSymbol type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AnnotationSymbolTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.AnnotationSymbolTypeSetIterator

See Also

AnnotationSymbolTypeSetIterator Members


AnnotationSymbolTypeSetIterator Members

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSetIterator Members
AnnotationSymbolTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Constructors

Name | Description
AnnotationSymbolTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Constructor

[image]

Revit 2011 API
AnnotationSymbolTypeSetIterator Constructor
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbolTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Methods

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSetIterator Methods
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
AnnotationSymbolTypeSetIterator..::.MoveNext Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
AnnotationSymbolTypeSetIterator..::.Reset Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Properties

[image] [image]

Revit 2011 API
AnnotationSymbolTypeSetIterator Properties
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class


Current Property

[image]

Revit 2011 API
AnnotationSymbolTypeSetIterator..::.Current Property
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class


APIObject Class

[image]

Revit 2011 API
APIObject Class
Members See Also Send Feedback
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class APIObject : IDisposable
Visual Basic (Declaration)
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Collections..::.Array
Autodesk.Revit.Collections..::.ArrayIterator
Autodesk.Revit.Collections..::.Map
Autodesk.Revit.Collections..::.MapIterator
Autodesk.Revit.Collections..::.Set
Autodesk.Revit.Collections..::.SetIterator
Autodesk.Revit.Collections..::.StringStringMap
Autodesk.Revit.Collections..::.StringStringMapIterator
Autodesk.Revit.Creation..::.Application
Autodesk.Revit.Creation..::.ItemFactoryBase
Autodesk.Revit.DB..::.AnnotationSymbolTypeSet
Autodesk.Revit.DB..::.AnnotationSymbolTypeSetIterator
Autodesk.Revit.DB.Architecture..::.BoundarySegment
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArray
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArray
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB.Architecture..::.FasciaTypeSet
Autodesk.Revit.DB.Architecture..::.FasciaTypeSetIterator
Autodesk.Revit.DB.Architecture..::.GutterTypeSet
Autodesk.Revit.DB.Architecture..::.GutterTypeSetIterator
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSet
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSetIterator
Autodesk.Revit.DB..::.AreaTagTypeSet
Autodesk.Revit.DB..::.AreaTagTypeSetIterator
Autodesk.Revit.DB..::.BeamSystemTypeSet
Autodesk.Revit.DB..::.BeamSystemTypeSetIterator
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.BoundarySegment
Autodesk.Revit.DB..::.BoundarySegmentArray
Autodesk.Revit.DB..::.BoundarySegmentArrayArray
Autodesk.Revit.DB..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB..::.BoundingBoxXYZ
Autodesk.Revit.DB..::.Category
Autodesk.Revit.DB..::.CategoryNameMap
Autodesk.Revit.DB..::.CategoryNameMapIterator
Autodesk.Revit.DB..::.CategorySet
Autodesk.Revit.DB..::.CategorySetIterator
Autodesk.Revit.DB..::.City
Autodesk.Revit.DB..::.CitySet
Autodesk.Revit.DB..::.CitySetIterator
Autodesk.Revit.DB..::.Color
Autodesk.Revit.DB..::.CombinableElementArray
Autodesk.Revit.DB..::.CombinableElementArrayIterator
Autodesk.Revit.DB..::.CompoundStructure
Autodesk.Revit.DB..::.CompoundStructureLayer
Autodesk.Revit.DB..::.CompoundStructureLayerArray
Autodesk.Revit.DB..::.CompoundStructureLayerArrayIterator
Autodesk.Revit.DB..::.Connector
Autodesk.Revit.DB..::.ConnectorManager
Autodesk.Revit.DB..::.ConnectorSet
Autodesk.Revit.DB..::.ConnectorSetIterator
Autodesk.Revit.DB..::.ContFootingTypeSet
Autodesk.Revit.DB..::.ContFootingTypeSetIterator
Autodesk.Revit.DB..::.CurtainCell
Autodesk.Revit.DB..::.CurtainCellSet
Autodesk.Revit.DB..::.CurtainCellSetIterator
Autodesk.Revit.DB..::.CurtainGrid
Autodesk.Revit.DB..::.CurtainGridSet
Autodesk.Revit.DB..::.CurtainGridSetIterator
Autodesk.Revit.DB..::.CurtainSystemTypeSet
Autodesk.Revit.DB..::.CurtainSystemTypeSetIterator
Autodesk.Revit.DB..::.CurveArrArray
Autodesk.Revit.DB..::.CurveArrArrayIterator
Autodesk.Revit.DB..::.CurveArray
Autodesk.Revit.DB..::.CurveArrayIterator
Autodesk.Revit.DB..::.CurveByPointsArray
Autodesk.Revit.DB..::.CurveByPointsArrayIterator
Autodesk.Revit.DB..::.Definition
Autodesk.Revit.DB..::.DefinitionBindingMap
Autodesk.Revit.DB..::.DefinitionBindingMapIterator
Autodesk.Revit.DB..::.DefinitionFile
Autodesk.Revit.DB..::.DefinitionGroup
Autodesk.Revit.DB..::.DefinitionGroupsBase
Autodesk.Revit.DB..::.DefinitionGroupsBaseIterator
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.DefinitionsBaseIterator
Autodesk.Revit.DB..::.DetailCurveArray
Autodesk.Revit.DB..::.DetailCurveArrayIterator
Autodesk.Revit.DB..::.DimensionSegment
Autodesk.Revit.DB..::.DimensionSegmentArray
Autodesk.Revit.DB..::.DimensionSegmentArrayIterator
Autodesk.Revit.DB..::.DimensionTypeSet
Autodesk.Revit.DB..::.DimensionTypeSetIterator
Autodesk.Revit.DB..::.DividedSurfaceData
Autodesk.Revit.DB..::.DocumentSet
Autodesk.Revit.DB..::.DocumentSetIterator
Autodesk.Revit.DB..::.DoubleArray
Autodesk.Revit.DB..::.DoubleArrayIterator
Autodesk.Revit.DB..::.EdgeArray
Autodesk.Revit.DB..::.EdgeArrayArray
Autodesk.Revit.DB..::.EdgeArrayArrayIterator
Autodesk.Revit.DB..::.EdgeArrayIterator
Autodesk.Revit.DB.Electrical..::.CorrectionFactor
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSet
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSetIterator
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSet
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSetIterator
Autodesk.Revit.DB.Electrical..::.ElectricalSetting
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSet
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSetIterator
Autodesk.Revit.DB.Electrical..::.GroundConductorSize
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSet
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSetIterator
Autodesk.Revit.DB.Electrical..::.InsulationTypeSet
Autodesk.Revit.DB.Electrical..::.InsulationTypeSetIterator
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSet
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSetIterator
Autodesk.Revit.DB.Electrical..::.VoltageTypeSet
Autodesk.Revit.DB.Electrical..::.VoltageTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireConduitType
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSet
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSet
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSetIterator
Autodesk.Revit.DB.Electrical..::.WireSet
Autodesk.Revit.DB.Electrical..::.WireSetIterator
Autodesk.Revit.DB.Electrical..::.WireSize
Autodesk.Revit.DB.Electrical..::.WireSizeSet
Autodesk.Revit.DB.Electrical..::.WireSizeSetIterator
Autodesk.Revit.DB.Electrical..::.WireTypeSet
Autodesk.Revit.DB.Electrical..::.WireTypeSetIterator
Autodesk.Revit.DB..::.ElementArray
Autodesk.Revit.DB..::.ElementArrayIterator
Autodesk.Revit.DB..::.ElementSet
Autodesk.Revit.DB..::.ElementSetIterator
Autodesk.Revit.DB..::.FaceArray
Autodesk.Revit.DB..::.FaceArrayIterator
Autodesk.Revit.DB..::.FamilyElementVisibility
Autodesk.Revit.DB..::.FamilyManager
Autodesk.Revit.DB..::.FamilyParameter
Autodesk.Revit.DB..::.FamilyParameterSet
Autodesk.Revit.DB..::.FamilyParameterSetIterator
Autodesk.Revit.DB..::.FamilyPointLocation
Autodesk.Revit.DB..::.FamilyPointPlacementReference
Autodesk.Revit.DB..::.FamilySymbolSet
Autodesk.Revit.DB..::.FamilySymbolSetIterator
Autodesk.Revit.DB..::.FamilyType
Autodesk.Revit.DB..::.FamilyTypeSet
Autodesk.Revit.DB..::.FamilyTypeSetIterator
Autodesk.Revit.DB..::.FillPatternSet
Autodesk.Revit.DB..::.FillPatternSetIterator
Autodesk.Revit.DB..::.FloorTypeSet
Autodesk.Revit.DB..::.FloorTypeSetIterator
Autodesk.Revit.DB..::.FormArray
Autodesk.Revit.DB..::.FormArrayIterator
Autodesk.Revit.DB..::.FormatOptions
Autodesk.Revit.DB..::.GenericFormSet
Autodesk.Revit.DB..::.GenericFormSetIterator
Autodesk.Revit.DB..::.GeomCombinationSet
Autodesk.Revit.DB..::.GeomCombinationSetIterator
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.GeometryObjectArray
Autodesk.Revit.DB..::.GeometryObjectArrayIterator
Autodesk.Revit.DB..::.GridTypeSet
Autodesk.Revit.DB..::.GridTypeSetIterator
Autodesk.Revit.DB..::.GroupSet
Autodesk.Revit.DB..::.GroupSetIterator
Autodesk.Revit.DB..::.InstanceArray
Autodesk.Revit.DB..::.InstanceArrayIterator
Autodesk.Revit.DB..::.IntersectionResult
Autodesk.Revit.DB..::.IntersectionResultArray
Autodesk.Revit.DB..::.IntersectionResultArrayIterator
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.Leader
Autodesk.Revit.DB..::.LeaderArray
Autodesk.Revit.DB..::.LeaderArrayIterator
Autodesk.Revit.DB..::.LevelTypeSet
Autodesk.Revit.DB..::.LevelTypeSetIterator
Autodesk.Revit.DB..::.LinePatternSet
Autodesk.Revit.DB..::.LinePatternSetIterator
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.MaterialSet
Autodesk.Revit.DB..::.MaterialSetIterator
Autodesk.Revit.DB.Mechanical..::.BoundarySegment
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArray
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArray
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayIterator
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSet
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSetIterator
Autodesk.Revit.DB.Mechanical..::.SpaceSet
Autodesk.Revit.DB.Mechanical..::.SpaceSetIterator
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSet
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSetIterator
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB..::.MeshArray
Autodesk.Revit.DB..::.MeshArrayIterator
Autodesk.Revit.DB..::.MeshTriangle
Autodesk.Revit.DB..::.ModelCurveArrArray
Autodesk.Revit.DB..::.ModelCurveArrArrayIterator
Autodesk.Revit.DB..::.ModelCurveArray
Autodesk.Revit.DB..::.ModelCurveArrayIterator
Autodesk.Revit.DB..::.MullionTypeSet
Autodesk.Revit.DB..::.MullionTypeSetIterator
Autodesk.Revit.DB..::.Options
Autodesk.Revit.DB..::.PanelTypeSet
Autodesk.Revit.DB..::.PanelTypeSetIterator
Autodesk.Revit.DB..::.PaperSize
Autodesk.Revit.DB..::.PaperSizeSet
Autodesk.Revit.DB..::.PaperSizeSetIterator
Autodesk.Revit.DB..::.PaperSource
Autodesk.Revit.DB..::.PaperSourceSet
Autodesk.Revit.DB..::.PaperSourceSetIterator
Autodesk.Revit.DB..::.Parameter
Autodesk.Revit.DB..::.ParameterMap
Autodesk.Revit.DB..::.ParameterMapIterator
Autodesk.Revit.DB..::.ParameterSet
Autodesk.Revit.DB..::.ParameterSetIterator
Autodesk.Revit.DB..::.PhaseArray
Autodesk.Revit.DB..::.PhaseArrayIterator
Autodesk.Revit.DB..::.PlanCircuit
Autodesk.Revit.DB..::.PlanCircuitSet
Autodesk.Revit.DB..::.PlanCircuitSetIterator
Autodesk.Revit.DB..::.Plane
Autodesk.Revit.DB..::.PlanTopology
Autodesk.Revit.DB..::.PlanTopologySet
Autodesk.Revit.DB..::.PlanTopologySetIterator
Autodesk.Revit.DB..::.PrintManager
Autodesk.Revit.DB..::.PrintParameters
Autodesk.Revit.DB..::.PrintSetup
Autodesk.Revit.DB..::.ProjectLocationSet
Autodesk.Revit.DB..::.ProjectLocationSetIterator
Autodesk.Revit.DB..::.ProjectPosition
Autodesk.Revit.DB..::.Reference
Autodesk.Revit.DB..::.ReferenceArray
Autodesk.Revit.DB..::.ReferenceArrayArray
Autodesk.Revit.DB..::.ReferenceArrayArrayIterator
Autodesk.Revit.DB..::.ReferenceArrayIterator
Autodesk.Revit.DB..::.ReferencePointArray
Autodesk.Revit.DB..::.ReferencePointArrayIterator
Autodesk.Revit.DB..::.RoofTypeSet
Autodesk.Revit.DB..::.RoofTypeSetIterator
Autodesk.Revit.DB..::.Settings
Autodesk.Revit.DB..::.SlabEdgeTypeSet
Autodesk.Revit.DB..::.SlabEdgeTypeSetIterator
Autodesk.Revit.DB..::.SlabShapeCreaseArray
Autodesk.Revit.DB..::.SlabShapeCreaseArrayIterator
Autodesk.Revit.DB..::.SlabShapeVertexArray
Autodesk.Revit.DB..::.SlabShapeVertexArrayIterator
Autodesk.Revit.DB..::.SolidArray
Autodesk.Revit.DB..::.SolidArrayIterator
Autodesk.Revit.DB..::.SpacingRule
Autodesk.Revit.DB..::.SpotDimensionTypeSet
Autodesk.Revit.DB..::.SpotDimensionTypeSetIterator
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSet
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.BarDescription
Autodesk.Revit.DB.Structure..::.LineLoadTypeSet
Autodesk.Revit.DB.Structure..::.LineLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.LoadCaseArray
Autodesk.Revit.DB.Structure..::.LoadCaseArrayIterator
Autodesk.Revit.DB.Structure..::.LoadCaseSet
Autodesk.Revit.DB.Structure..::.LoadCaseSetIterator
Autodesk.Revit.DB.Structure..::.LoadCombinationArray
Autodesk.Revit.DB.Structure..::.LoadCombinationArrayIterator
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSet
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSetIterator
Autodesk.Revit.DB.Structure..::.LoadUsageArray
Autodesk.Revit.DB.Structure..::.LoadUsageArrayIterator
Autodesk.Revit.DB.Structure..::.PointLoadTypeSet
Autodesk.Revit.DB.Structure..::.PointLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarBarTypeSet
Autodesk.Revit.DB.Structure..::.RebarBarTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSet
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarHookTypeSet
Autodesk.Revit.DB.Structure..::.RebarHookTypeSetIterator
Autodesk.Revit.DB.Structure..::.RebarHostData
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeSet
Autodesk.Revit.DB.Structure..::.RebarShapeSetIterator
Autodesk.Revit.DB.Structure..::.TrussTypeSet
Autodesk.Revit.DB.Structure..::.TrussTypeSetIterator
Autodesk.Revit.DB..::.SuspendUpdating
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.SymbolicCurveArray
Autodesk.Revit.DB..::.SymbolicCurveArrayIterator
Autodesk.Revit.DB..::.TextNoteTypeSet
Autodesk.Revit.DB..::.TextNoteTypeSetIterator
Autodesk.Revit.DB..::.TilePatterns
Autodesk.Revit.DB..::.Transform
Autodesk.Revit.DB..::.VertexIndexPairArray
Autodesk.Revit.DB..::.VertexIndexPairArrayIterator
Autodesk.Revit.DB..::.ViewSet
Autodesk.Revit.DB..::.ViewSetIterator
Autodesk.Revit.DB..::.ViewSheetSets
Autodesk.Revit.DB..::.ViewSheetSetsIterator
Autodesk.Revit.DB..::.ViewSheetSetting
Autodesk.Revit.DB..::.WallTypeSet
Autodesk.Revit.DB..::.WallTypeSetIterator
Autodesk.Revit.UI.Events..::.DialogBoxData
Autodesk.Revit.UI..::.ExternalApplicationArray
Autodesk.Revit.UI..::.ExternalApplicationArrayIterator
Autodesk.Revit.UI..::.ExternalCommandData
Autodesk.Revit.UI.Selection..::.Selection
Autodesk.Revit.UI..::.TaskDialog
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetSet
Autodesk.Revit.Utility..::.AssetSetIterator

See Also

APIObject Members


APIObject Members

[image] [image]

Revit 2011 API
APIObject Members
APIObject Class Methods Properties See Also Send Feedback

The APIObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


APIObject Methods

[image] [image]

Revit 2011 API
APIObject Methods
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

APIObject Class


Dispose Method

[image]

Revit 2011 API
APIObject..::.Dispose Method
APIObject Class See Also Send Feedback
Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class


APIObject Properties

[image] [image]

Revit 2011 API
APIObject Properties
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


IsReadOnly Property

[image]

Revit 2011 API
APIObject..::.IsReadOnly Property
APIObject Class Example See Also Send Feedback
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

Examples

CopyC#
Document project = uiApplication.ActiveUIDocument.Document;
Settings settings = project.Settings;
TaskDialog.Show("Revit","Categories: " + settings.Categories.IsReadOnly.ToString());
TaskDialog.Show("Revit","Materials: " + settings.Materials.IsReadOnly.ToString());
CopyVB.NET
Dim project As Document = uiApplication.ActiveUIDocument.Document
Dim settings As Settings = project.Settings
TaskDialog.Show("Revit", "Categories: " + settings.Categories.IsReadOnly.ToString())
TaskDialog.Show("Revit", "Materials: " + settings.Materials.IsReadOnly.ToString())

See Also

APIObject Class


Arc Class

[image]

Revit 2011 API
Arc Class
Members See Also Send Feedback
A circular arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Arc : Curve
Visual Basic (Declaration)
Public Class Arc _
    Inherits Curve
Visual C++
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Arc

See Also

Arc Members


Arc Members

[image] [image]

Revit 2011 API
Arc Members
Arc Class Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the arc.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the arc is defined.
Period | The period of this curve. (Inherited from Curve.)
Radius | Returns the radius of the arc.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Arc Class


Arc Methods

[image] [image]

Revit 2011 API
Arc Methods
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Arc Class


Intersect Method

[image] [image]

Revit 2011 API
Arc..::.Intersect Method
Arc Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Arc Class
Arc Members


IsInside Method

[image] [image]

Revit 2011 API
Arc..::.IsInside Method
Arc Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Arc Class
Arc Members


Arc Properties

[image] [image]

Revit 2011 API
Arc Properties
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the arc.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the arc is defined.
Period | The period of this curve. (Inherited from Curve.)
Radius | Returns the radius of the arc.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Arc Class


Center Property

[image]

Revit 2011 API
Arc..::.Center Property
Arc Class See Also Send Feedback
Returns the center of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Arc Class


Normal Property

[image]

Revit 2011 API
Arc..::.Normal Property
Arc Class See Also Send Feedback
Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Arc Class


Radius Property

[image]

Revit 2011 API
Arc..::.Radius Property
Arc Class See Also Send Feedback
Returns the radius of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Radius { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
}

See Also

Arc Class


Area Class

[image]

Revit 2011 API
Area Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Area : Enclosure
Visual Basic (Declaration)
Public Class Area _
    Inherits Enclosure
Visual C++
public ref class Area : public Enclosure

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB..::.Area

See Also

Area Members


Area Members

[image] [image]

Revit 2011 API
Area Members
Area Class Methods Properties See Also Send Feedback

The Area type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The area. (Inherited from Enclosure.)
AreaScheme | The area scheme.
Boundary | Returns the boundary of the area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Area Class


Area Methods

[image] [image]

Revit 2011 API
Area Methods
Area Class See Also Send Feedback

The Area type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Area Class


Area Properties

[image] [image]

Revit 2011 API
Area Properties
Area Class See Also Send Feedback

The Area type exposes the following members.

Properties

Name | Description
Area | The area. (Inherited from Enclosure.)
AreaScheme | The area scheme.
Boundary | Returns the boundary of the area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Area Class


AreaScheme Property

[image]

Revit 2011 API
Area..::.AreaScheme Property
Area Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaScheme As AreaScheme
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

See Also

Area Class


Boundary Property

[image]

Revit 2011 API
Area..::.Boundary Property
Area Class See Also Send Feedback
Returns the boundary of the area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the area. Each area may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Area.BoundarySegment object for more details about the segments that make up the area topology.

See Also

Area Class


Parameter Property

[image] [image]

Revit 2011 API
Area..::.Parameter Property
Area Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Area Class
Area Members


AreaElemType Enumeration

[image]

Revit 2011 API
AreaElemType Enumeration
See Also Send Feedback
An enumerated type to store type of AreaElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AreaElemType
Visual Basic (Declaration)
Public Enumeration AreaElemType
Visual C++
public enum class AreaElemType

Members

Member name | Description
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.

See Also


AreaFilter Class

[image]

Revit 2011 API
AreaFilter Class
Members Example See Also Send Feedback
A filter used to match areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class AreaFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
// supported by those methods.
AreaFilter filter = new AreaFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> areas = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
' supported by those methods.
Dim filter As New AreaFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim areas As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.AreaFilter

See Also

AreaFilter Members


AreaFilter Members

[image] [image]

Revit 2011 API
AreaFilter Members
AreaFilter Class Constructors Methods Properties See Also Send Feedback

The AreaFilter type exposes the following members.

Constructors

Name | Description
AreaFilter | Constructs a filter which matches only areas.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaFilter Constructor

[image]

Revit 2011 API
AreaFilter Constructor
AreaFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaFilter()

See Also

AreaFilter Class


AreaFilter Methods

[image] [image]

Revit 2011 API
AreaFilter Methods
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaFilter Class


AreaFilter Properties

[image] [image]

Revit 2011 API
AreaFilter Properties
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaScheme Class

[image]

Revit 2011 API
AreaScheme Class
Members See Also Send Feedback
The area scheme associated with a particular area plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaScheme : Element
Visual Basic (Declaration)
Public Class AreaScheme _
    Inherits Element
Visual C++
public ref class AreaScheme : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.AreaScheme

See Also

AreaScheme Members


AreaScheme Members

[image] [image]

Revit 2011 API
AreaScheme Members
AreaScheme Class Methods Properties See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaScheme Class


AreaScheme Methods

[image] [image]

Revit 2011 API
AreaScheme Methods
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaScheme Class


AreaScheme Properties

[image] [image]

Revit 2011 API
AreaScheme Properties
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaScheme Class


IsGrossBuildingArea Property

[image]

Revit 2011 API
AreaScheme..::.IsGrossBuildingArea Property
AreaScheme Class See Also Send Feedback
Indicates if the area scheme is a Gross Building Area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsGrossBuildingArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsGrossBuildingArea As Boolean
Visual C++
public:
property bool IsGrossBuildingArea {
    bool get ();
}

See Also

AreaScheme Class


Parameter Property

[image] [image]

Revit 2011 API
AreaScheme..::.Parameter Property
AreaScheme Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaScheme Class
AreaScheme Members


AreaTag Class

[image]

Revit 2011 API
AreaTag Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaTag : EnclosureTag
Visual Basic (Declaration)
Public Class AreaTag _
    Inherits EnclosureTag
Visual C++
public ref class AreaTag : public EnclosureTag

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB..::.AreaTag

See Also

AreaTag Members


AreaTag Members

[image] [image]

Revit 2011 API
AreaTag Members
AreaTag Class Methods Properties See Also Send Feedback

The AreaTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The area that the tag is associated with.
AreaTagType | The tag type.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaTag Class


AreaTag Methods

[image] [image]

Revit 2011 API
AreaTag Methods
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTag Class


AreaTag Properties

[image] [image]

Revit 2011 API
AreaTag Properties
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Properties

Name | Description
Area | The area that the tag is associated with.
AreaTagType | The tag type.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaTag Class


Area Property

[image]

Revit 2011 API
AreaTag..::.Area Property
AreaTag Class See Also Send Feedback
The area that the tag is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Area Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Area
Visual C++
public:
property Area^ Area {
    Area^ get ();
}

Remarks

In rare cases, the tag may not be associated to a area. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

AreaTag Class


AreaTagType Property

[image]

Revit 2011 API
AreaTag..::.AreaTagType Property
AreaTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaTagType AreaTagType { get; set; }
Visual Basic (Declaration)
Public Property AreaTagType As AreaTagType
Visual C++
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}

See Also

AreaTag Class


Parameter Property

[image] [image]

Revit 2011 API
AreaTag..::.Parameter Property
AreaTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaTag Class
AreaTag Members


AreaTagFilter Class

[image]

Revit 2011 API
AreaTagFilter Class
Members See Also Send Feedback
A filter used to match area tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaTagFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class AreaTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.AreaTagFilter

See Also

AreaTagFilter Members


AreaTagFilter Members

[image] [image]

Revit 2011 API
AreaTagFilter Members
AreaTagFilter Class Constructors Methods Properties See Also Send Feedback

The AreaTagFilter type exposes the following members.

Constructors

Name | Description
AreaTagFilter | Constructs a filter which matches only areas.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagFilter Constructor

[image]

Revit 2011 API
AreaTagFilter Constructor
AreaTagFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaTagFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagFilter()

See Also

AreaTagFilter Class


AreaTagFilter Methods

[image] [image]

Revit 2011 API
AreaTagFilter Methods
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagFilter Class


AreaTagFilter Properties

[image] [image]

Revit 2011 API
AreaTagFilter Properties
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagType Class

[image]

Revit 2011 API
AreaTagType Class
Members See Also Send Feedback
An object that represents an Area Tag style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaTagType : FamilySymbol
Visual Basic (Declaration)
Public Class AreaTagType _
    Inherits FamilySymbol
Visual C++
public ref class AreaTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB..::.AreaTagType

See Also

AreaTagType Members


AreaTagType Members

[image] [image]

Revit 2011 API
AreaTagType Members
AreaTagType Class Methods Properties See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaTagType Class


AreaTagType Methods

[image] [image]

Revit 2011 API
AreaTagType Methods
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagType Class


AreaTagType Properties

[image] [image]

Revit 2011 API
AreaTagType Properties
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaTagType Class


Parameter Property

[image] [image]

Revit 2011 API
AreaTagType..::.Parameter Property
AreaTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaTagType Class
AreaTagType Members


AreaTagTypeSet Class

[image]

Revit 2011 API
AreaTagTypeSet Class
Members See Also Send Feedback
A set that contains areatag types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AreaTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.AreaTagTypeSet

See Also

AreaTagTypeSet Members


AreaTagTypeSet Members

[image] [image]

Revit 2011 API
AreaTagTypeSet Members
AreaTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Constructors

Name | Description
AreaTagTypeSet | Initializes a new instance of the AreaTagTypeSet class

Methods

Name | Description
Clear | Removes every areatag type from the set, rendering it empty.
Contains | Tests for the existence of a areatag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areatag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areatag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class


AreaTagTypeSet Constructor

[image]

Revit 2011 API
AreaTagTypeSet Constructor
AreaTagTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaTagTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSet()

See Also

AreaTagTypeSet Class


AreaTagTypeSet Methods

[image] [image]

Revit 2011 API
AreaTagTypeSet Methods
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every areatag type from the set, rendering it empty.
Contains | Tests for the existence of a areatag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areatag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areatag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSet Class


Clear Method

[image]

Revit 2011 API
AreaTagTypeSet..::.Clear Method
AreaTagTypeSet Class See Also Send Feedback
Removes every areatag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaTagTypeSet Class


Contains Method

[image]

Revit 2011 API
AreaTagTypeSet..::.Contains Method
AreaTagTypeSet Class See Also Send Feedback
Tests for the existence of a areatag type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AreaTagType
The areatag type to be searched for.

Return Value

The Contains method returns True if the areatag type is within the set, otherwise False.

See Also

AreaTagTypeSet Class


Erase Method

[image]

Revit 2011 API
AreaTagTypeSet..::.Erase Method
AreaTagTypeSet Class See Also Send Feedback
Removes a specified areatag type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AreaTagType
The areatag type to be erased.

Return Value

The number of areatag types that were erased from the set.

See Also

AreaTagTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
AreaTagTypeSet..::.ForwardIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaTagTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
AreaTagTypeSet..::.GetEnumerator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AreaTagTypeSet Class


Insert Method

[image]

Revit 2011 API
AreaTagTypeSet..::.Insert Method
AreaTagTypeSet Class See Also Send Feedback
Insert the specified areatag type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.AreaTagType
The areatag type to be inserted into the set.

Return Value

Returns whether the areatag type was inserted into the set.

See Also

AreaTagTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
AreaTagTypeSet..::.ReverseIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaTagTypeSet Class


AreaTagTypeSet Properties

[image] [image]

Revit 2011 API
AreaTagTypeSet Properties
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
AreaTagTypeSet..::.IsEmpty Property
AreaTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaTagTypeSet Class


Size Property

[image]

Revit 2011 API
AreaTagTypeSet..::.Size Property
AreaTagTypeSet Class See Also Send Feedback
Returns the number of areatag types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaTagTypeSet Class


AreaTagTypeSetIterator Class

[image]

Revit 2011 API
AreaTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areatag type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class AreaTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AreaTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.AreaTagTypeSetIterator

See Also

AreaTagTypeSetIterator Members


AreaTagTypeSetIterator Members

[image] [image]

Revit 2011 API
AreaTagTypeSetIterator Members
AreaTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
AreaTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Constructor

[image]

Revit 2011 API
AreaTagTypeSetIterator Constructor
AreaTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Methods

[image] [image]

Revit 2011 API
AreaTagTypeSetIterator Methods
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
AreaTagTypeSetIterator..::.MoveNext Method
AreaTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
AreaTagTypeSetIterator..::.Reset Method
AreaTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Properties

[image] [image]

Revit 2011 API
AreaTagTypeSetIterator Properties
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class


Current Property

[image]

Revit 2011 API
AreaTagTypeSetIterator..::.Current Property
AreaTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class


BaseArray Class

[image]

Revit 2011 API
BaseArray Class
Members See Also Send Feedback
An abstract base class that represents an array within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BaseArray : Element
Visual Basic (Declaration)
Public MustInherit Class BaseArray _
    Inherits Element
Visual C++
public ref class BaseArray abstract : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BaseArray
Autodesk.Revit.DB..::.LinearArray
Autodesk.Revit.DB..::.RadialArray

See Also

BaseArray Members


BaseArray Members

[image] [image]

Revit 2011 API
BaseArray Members
BaseArray Class Methods Properties See Also Send Feedback

The BaseArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
NumMembers | Retrieve or Change the number of the arrayed members.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BaseArray Class


BaseArray Methods

[image] [image]

Revit 2011 API
BaseArray Methods
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseArray Class


BaseArray Properties

[image] [image]

Revit 2011 API
BaseArray Properties
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
NumMembers | Retrieve or Change the number of the arrayed members.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BaseArray Class


CopyMembers Property

[image]

Revit 2011 API
BaseArray..::.CopyMembers Property
BaseArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class


Label Property

[image]

Revit 2011 API
BaseArray..::.Label Property
BaseArray Class See Also Send Feedback
The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to label the BaseArray out of family document.

See Also

BaseArray Class


Name Property

[image]

Revit 2011 API
BaseArray..::.Name Property
BaseArray Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.

See Also

BaseArray Class


NumMembers Property

[image]

Revit 2011 API
BaseArray..::.NumMembers Property
BaseArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract int NumMembers { get; set; }
Visual Basic (Declaration)
Public MustOverride Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}

See Also

BaseArray Class


OrigMembers Property

[image]

Revit 2011 API
BaseArray..::.OrigMembers Property
BaseArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class


Parameter Property

[image] [image]

Revit 2011 API
BaseArray..::.Parameter Property
BaseArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BaseArray Class
BaseArray Members


BasePoint Class

[image]

Revit 2011 API
BasePoint Class
Members See Also Send Feedback
Represents kinds of BasePoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BasePoint : Element
Visual Basic (Declaration)
Public Class BasePoint _
    Inherits Element
Visual C++
public ref class BasePoint : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BasePoint

See Also

BasePoint Members


BasePoint Members

[image] [image]

Revit 2011 API
BasePoint Members
BasePoint Class Methods Properties See Also Send Feedback

The BasePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsShared | Indicates whether the base point is shared.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BasePoint Class


BasePoint Methods

[image] [image]

Revit 2011 API
BasePoint Methods
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePoint Class


BasePoint Properties

[image] [image]

Revit 2011 API
BasePoint Properties
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsShared | Indicates whether the base point is shared.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BasePoint Class


IsShared Property

[image]

Revit 2011 API
BasePoint..::.IsShared Property
BasePoint Class See Also Send Feedback
Indicates whether the base point is shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsShared As Boolean
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

BasePoint Class


Parameter Property

[image] [image]

Revit 2011 API
BasePoint..::.Parameter Property
BasePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BasePoint Class
BasePoint Members


BeamSystem Class

[image]

Revit 2011 API
BeamSystem Class
Members Example See Also Send Feedback
An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BeamSystem : Element
Visual Basic (Declaration)
Public Class BeamSystem _
    Inherits Element
Visual C++
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " + beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " + beamSystem.BeamSystemType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BeamSystem

See Also

BeamSystem Members


BeamSystem Members

[image] [image]

Revit 2011 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

Name | Description
BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllBeams | Get all the beams of the BeamSystem.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeamSystemType | Retrieve or change the type of the BeamSystem.
BeamType | Retrieve or change the Beam Type of the BeamSystem.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Direction of the BeamSystem.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the Elevation of the BeamSystem.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Retrieve or set the profile of the BeamSystem.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BeamSystem Class


BeamSystem Methods

[image] [image]

Revit 2011 API
BeamSystem Methods
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

Name | Description
BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllBeams | Get all the beams of the BeamSystem.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystem Class


BeamBelongsTo Method

[image]

Revit 2011 API
BeamSystem..::.BeamBelongsTo Method
BeamSystem Class See Also Send Feedback
Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic (Declaration)
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)

Parameters

beam
Type: Autodesk.Revit.DB..::.FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class


DropBeamSystem Method

[image]

Revit 2011 API
BeamSystem..::.DropBeamSystem Method
BeamSystem Class See Also Send Feedback
Drop beam system, it will disassociate all members from the beam system and delete the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void DropBeamSystem(
    BeamSystem beamSystem
)
Visual Basic (Declaration)
Public Shared Sub DropBeamSystem ( _
    beamSystem As BeamSystem _
)
Visual C++
public:
static void DropBeamSystem(
    BeamSystem^ beamSystem
)

Parameters

beamSystem
Type: Autodesk.Revit.DB..::.BeamSystem
The beam system to be deleted.

See Also

BeamSystem Class


GetAllBeams Method

[image]

Revit 2011 API
BeamSystem..::.GetAllBeams Method
BeamSystem Class See Also Send Feedback
Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet GetAllBeams()
Visual Basic (Declaration)
Public Function GetAllBeams As ElementSet
Visual C++
public:
ElementSet^ GetAllBeams()

Return Value

The beams.

Remarks

Beam is a FamilyInstance.

See Also

BeamSystem Class


BeamSystem Properties

[image] [image]

Revit 2011 API
BeamSystem Properties
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Properties

Name | Description
BeamSystemType | Retrieve or change the type of the BeamSystem.
BeamType | Retrieve or change the Beam Type of the BeamSystem.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Direction of the BeamSystem.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the Elevation of the BeamSystem.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
LayoutRule | Retrieve or change the LayoutRule of the BeamSystem.
Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Retrieve or set the profile of the BeamSystem.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BeamSystem Class


BeamSystemType Property

[image]

Revit 2011 API
BeamSystem..::.BeamSystemType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemType BeamSystemType { get; set; }
Visual Basic (Declaration)
Public Property BeamSystemType As BeamSystemType
Visual C++
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " + beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " + beamSystem.BeamSystemType.Name

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class


BeamType Property

[image]

Revit 2011 API
BeamSystem..::.BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieve or change the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic (Declaration)
Public Property BeamType As FamilySymbol
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    foreach (Material material in beamSystem.BeamType.Materials)
    {
       message += "\nBeam type material : " + material.Name;
    }
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " + beamSystem.BeamType.Name
    ' Get BeamSystem type material
    For Each material As Autodesk.Revit.DB.Material In beamSystem.BeamType.Materials
        message += vbLf & "Beam type material : " + material.Name
    Next
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " + beamSystem.BeamType.Family.Name

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " + beamSystem.BeamType.Name
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " + beamSystem.BeamType.Family.Name

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class


Direction Property

[image]

Revit 2011 API
BeamSystem..::.Direction Property
BeamSystem Class See Also Send Feedback
Retrieve or change the Direction of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

BeamSystem Class


Elevation Property

[image]

Revit 2011 API
BeamSystem..::.Elevation Property
BeamSystem Class See Also Send Feedback
Retrieve or change the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

See Also

BeamSystem Class


LayoutRule Property

[image]

Revit 2011 API
BeamSystem..::.LayoutRule Property
BeamSystem Class See Also Send Feedback
Retrieve or change the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRule LayoutRule { get; set; }
Visual Basic (Declaration)
Public Property LayoutRule As LayoutRule
Visual C++
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}

See Also

BeamSystem Class


Level Property

[image]

Revit 2011 API
BeamSystem..::.Level Property
BeamSystem Class See Also Send Feedback
Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}

See Also

BeamSystem Class


Parameter Property

[image] [image]

Revit 2011 API
BeamSystem..::.Parameter Property
BeamSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BeamSystem Class
BeamSystem Members


Profile Property

[image]

Revit 2011 API
BeamSystem..::.Profile Property
BeamSystem Class See Also Send Feedback
Retrieve or set the profile of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As CurveArray
Visual C++
public:
property CurveArray^ Profile {
    CurveArray^ get ();
    void set (CurveArray^ value);
}

See Also

BeamSystem Class


BeamSystemJustifyType Enumeration

[image]

Revit 2011 API
BeamSystemJustifyType Enumeration
See Also Send Feedback
Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BeamSystemJustifyType
Visual Basic (Declaration)
Public Enumeration BeamSystemJustifyType
Visual C++
public enum class BeamSystemJustifyType

Members

Member name | Description
Center | Center.
End | End.
Beginning | Beginning.
DirectionLine | DirectionLine.

See Also


BeamSystemType Class

[image]

Revit 2011 API
BeamSystemType Class
Members See Also Send Feedback
An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BeamSystemType : ElementType
Visual Basic (Declaration)
Public Class BeamSystemType _
    Inherits ElementType
Visual C++
public ref class BeamSystemType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.BeamSystemType

See Also

BeamSystemType Members


BeamSystemType Members

[image] [image]

Revit 2011 API
BeamSystemType Members
BeamSystemType Class Methods Properties See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BeamSystemType Class


BeamSystemType Methods

[image] [image]

Revit 2011 API
BeamSystemType Methods
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemType Class


BeamSystemType Properties

[image] [image]

Revit 2011 API
BeamSystemType Properties
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BeamSystemType Class


Parameter Property

[image] [image]

Revit 2011 API
BeamSystemType..::.Parameter Property
BeamSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BeamSystemType Class
BeamSystemType Members


BeamSystemTypeSet Class

[image]

Revit 2011 API
BeamSystemTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BeamSystemTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BeamSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BeamSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BeamSystemTypeSet

See Also

BeamSystemTypeSet Members


BeamSystemTypeSet Members

[image] [image]

Revit 2011 API
BeamSystemTypeSet Members
BeamSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSet | Initializes a new instance of the BeamSystemTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Constructor

[image]

Revit 2011 API
BeamSystemTypeSet Constructor
BeamSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the BeamSystemTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSet()

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Methods

[image] [image]

Revit 2011 API
BeamSystemTypeSet Methods
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSet Class


Clear Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.Clear Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BeamSystemTypeSet Class


Contains Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.Contains Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.BeamSystemType

See Also

BeamSystemTypeSet Class


Erase Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.Erase Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As BeamSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.BeamSystemType

See Also

BeamSystemTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.ForwardIterator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ForwardIterator()

See Also

BeamSystemTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.GetEnumerator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BeamSystemTypeSet Class


Insert Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.Insert Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    BeamSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.BeamSystemType

See Also

BeamSystemTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
BeamSystemTypeSet..::.ReverseIterator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ReverseIterator()

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Properties

[image] [image]

Revit 2011 API
BeamSystemTypeSet Properties
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

BeamSystemTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
BeamSystemTypeSet..::.IsEmpty Property
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

BeamSystemTypeSet Class


Size Property

[image]

Revit 2011 API
BeamSystemTypeSet..::.Size Property
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BeamSystemTypeSet Class


BeamSystemTypeSetIterator Class

[image]

Revit 2011 API
BeamSystemTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BeamSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BeamSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BeamSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BeamSystemTypeSetIterator

See Also

BeamSystemTypeSetIterator Members


BeamSystemTypeSetIterator Members

[image] [image]

Revit 2011 API
BeamSystemTypeSetIterator Members
BeamSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Constructors

Name | Description
BeamSystemTypeSetIterator | Initializes a new instance of the BeamSystemTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Constructor

[image]

Revit 2011 API
BeamSystemTypeSetIterator Constructor
BeamSystemTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the BeamSystemTypeSetIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BeamSystemTypeSetIterator()

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Methods

[image] [image]

Revit 2011 API
BeamSystemTypeSetIterator Methods
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
BeamSystemTypeSetIterator..::.MoveNext Method
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

BeamSystemTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
BeamSystemTypeSetIterator..::.Reset Method
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Properties

[image] [image]

Revit 2011 API
BeamSystemTypeSetIterator Properties
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class


Current Property

[image]

Revit 2011 API
BeamSystemTypeSetIterator..::.Current Property
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

BeamSystemTypeSetIterator Class


Binding Class

[image]

Revit 2011 API
Binding Class
Members See Also Send Feedback
Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class Binding : APIObject
Visual Basic (Declaration)
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binging objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not effect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding

See Also

Binding Members


Binding Members

[image] [image]

Revit 2011 API
Binding Members
Binding Class Methods Properties See Also Send Feedback

The Binding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class


Binding Methods

[image] [image]

Revit 2011 API
Binding Methods
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Binding Class


Binding Properties

[image] [image]

Revit 2011 API
Binding Properties
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class


BindingMap Class

[image]

Revit 2011 API
BindingMap Class
Members See Also Send Feedback
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BindingMap : DefinitionBindingMap
Visual Basic (Declaration)
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionBindingMap
Autodesk.Revit.DB..::.BindingMap

See Also

BindingMap Members


BindingMap Members

[image] [image]

Revit 2011 API
BindingMap Members
BindingMap Class Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.
ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::.Item[([(Definition])]).)
Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


BindingMap Methods

[image] [image]

Revit 2011 API
BindingMap Methods
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Methods

Name | Description
Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::.Clear()()().)
Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::.Contains(Definition).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::.Erase(Definition).)
ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Overloaded. Creates a new parameter binding.
ReInsert | Overloaded. Removes an existing parameter and creates a new binding for a given parameter.
Remove | The Remove method is used to remove a parameter binding.
ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingMap Class


Clear Method

[image]

Revit 2011 API
BindingMap..::.Clear Method
BindingMap Class See Also Send Feedback
This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

The method Clear inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

BindingMap Class


Contains Method

[image]

Revit 2011 API
BindingMap..::.Contains Method
BindingMap Class See Also Send Feedback
The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


Erase Method

[image]

Revit 2011 API
BindingMap..::.Erase Method
BindingMap Class See Also Send Feedback
This method is used to erase one item in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.DB..::.Definition

Remarks

The method Erase inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Use Remove() instead to remove the binding from the Revit session and from the map.

See Also

BindingMap Class


Insert Method

[image] [image]

Revit 2011 API
BindingMap..::.Insert Method
BindingMap Class See Also Send Feedback
Creates a new parameter binding.

Overload List

Name | Description
Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::.Insert(Definition, Binding).)
Insert(Definition, Binding, BuiltInParameterGroup) | Creates a new parameter binding between a parameter and a set of categories in a specified group.

See Also

BindingMap Class
BindingMap Members


Insert Method (Definition, Binding)

[image]

Revit 2011 API
BindingMap..::.Insert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
) override

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.

See Also

BindingMap Class
Insert Overload


Insert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2011 API
BindingMap..::.Insert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Insert Overload


ReInsert Method

[image] [image]

Revit 2011 API
BindingMap..::.ReInsert Method
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Overload List

Name | Description
ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
ReInsert(Definition, Binding, BuiltInParameterGroup) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.

See Also

BindingMap Class
BindingMap Members


ReInsert Method (Definition, Binding)

[image]

Revit 2011 API
BindingMap..::.ReInsert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.

See Also

BindingMap Class
ReInsert Overload


ReInsert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2011 API
BindingMap..::.ReInsert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic (Declaration)
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::.Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload


Remove Method

[image]

Revit 2011 API
BindingMap..::.Remove Method
BindingMap Class See Also Send Feedback
The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Remove(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Remove ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


BindingMap Properties

[image] [image]

Revit 2011 API
BindingMap Properties
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::.Item[([(Definition])]).)
Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


Item Property

[image]

Revit 2011 API
BindingMap..::.Item Property
BindingMap Class See Also Send Feedback
The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Binding Item[
    Definition key
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class


Blend Class

[image]

Revit 2011 API
Blend Class
Members See Also Send Feedback
A blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Blend : GenericForm
Visual Basic (Declaration)
Public Class Blend _
    Inherits GenericForm
Visual C++
public ref class Blend : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Blend

See Also

Blend Members


Blend Members

[image] [image]

Revit 2011 API
Blend Members
Blend Class Methods Properties See Also Send Feedback

The Blend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomSketch | Returns the Bottom Sketch of the Blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | The offset of the top end of the blend relative to the sketch plane.
TopProfile | The curves which make up the top profile of the sketch.
TopSketch | Returns the Top Sketch of the Blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend Class


Blend Methods

[image] [image]

Revit 2011 API
Blend Methods
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blend Class


GetVertexConnectionMap Method

[image]

Revit 2011 API
Blend..::.GetVertexConnectionMap Method
Blend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic (Declaration)
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

Blend Class


SetVertexConnectionMap Method

[image]

Revit 2011 API
Blend..::.SetVertexConnectionMap Method
Blend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic (Declaration)
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::.VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the document failed to regenerate.

See Also

Blend Class


Blend Properties

[image] [image]

Revit 2011 API
Blend Properties
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Properties

Name | Description
BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomSketch | Returns the Bottom Sketch of the Blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | The offset of the top end of the blend relative to the sketch plane.
TopProfile | The curves which make up the top profile of the sketch.
TopSketch | Returns the Top Sketch of the Blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Blend Class


BottomOffset Property

[image]

Revit 2011 API
Blend..::.BottomOffset Property
Blend Class See Also Send Feedback
The offset of the bottom end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BottomOffset { get; set; }
Visual Basic (Declaration)
Public Property BottomOffset As Double
Visual C++
public:
property double BottomOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


BottomProfile Property

[image]

Revit 2011 API
Blend..::.BottomProfile Property
Blend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


BottomSketch Property

[image]

Revit 2011 API
Blend..::.BottomSketch Property
Blend Class See Also Send Feedback
Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomSketch As Sketch
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Bottom Sketch of the Blend.

See Also

Blend Class


Parameter Property

[image] [image]

Revit 2011 API
Blend..::.Parameter Property
Blend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Blend Class
Blend Members


TopOffset Property

[image]

Revit 2011 API
Blend..::.TopOffset Property
Blend Class See Also Send Feedback
The offset of the top end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


TopProfile Property

[image]

Revit 2011 API
Blend..::.TopProfile Property
Blend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


TopSketch Property

[image]

Revit 2011 API
Blend..::.TopSketch Property
Blend Class See Also Send Feedback
Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopSketch As Sketch
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Top Sketch of the Blend.

See Also

Blend Class


BorderTile Enumeration

[image]

Revit 2011 API
BorderTile Enumeration
See Also Send Feedback
Options for controlling tiles that overlap the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BorderTile
Visual Basic (Declaration)
Public Enumeration BorderTile
Visual C++
public enum class BorderTile

Members

Member name | Description
Empty |
Partial |
Overhanging |

See Also


BoundaryConditions Class

[image]

Revit 2011 API
BoundaryConditions Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundaryConditions : Element
Visual Basic (Declaration)
Public Class BoundaryConditions _
    Inherits Element
Visual C++
public ref class BoundaryConditions : public Element

Examples

CopyC#
public void GetInfo_BoundaryConditions(BoundaryConditions boundaryConditions)
{
    string message = "BoundaryConditions : ";

    Parameter param = boundaryConditions.get_Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE);
    switch (param.AsInteger())
    {
        case 0:
          XYZ point = boundaryConditions.Point;
            message += "\nThis BoundaryConditions is a Point Boundary Conditions.";
            message += "\nLocation point: (" + point.X + ", "
                        + point.Y + ", " + point.Z + ")";
            break;
        case 1:
            message += "\nThis BoundaryConditions is a Line Boundary Conditions.";
            Curve curve = boundaryConditions.get_Curve(0);
            // Get curve start point
            message += "\nLocation Line: start point: (" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += ";  end point:(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
            break;
        case 2:
            message += "\nThis BoundaryConditions is an Area Boundary Conditions.";
            for (int i = 0; i < boundaryConditions.NumCurves; i++)
            {
                Autodesk.Revit.DB.Curve areaCurve = boundaryConditions.get_Curve(i);
                // Get curve start point
                message += "\nCurve start point:(" + areaCurve.get_EndPoint(0).X + ", "
                     + areaCurve.get_EndPoint(0).Y + ", " + areaCurve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + areaCurve.get_EndPoint(1).X + ", "
                     + areaCurve.get_EndPoint(1).Y + ", " + areaCurve.get_EndPoint(1).Z + ")";
            }
            break;
        default:
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BoundaryConditions(ByVal boundaryConditions As Autodesk.Revit.DB.BoundaryConditions)
    Dim message As String = "BoundaryConditions : "

    Dim param As Parameter = boundaryConditions.Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE)
    Select Case param.AsInteger()
        Case 0
            Dim point As Autodesk.Revit.DB.XYZ = boundaryConditions.Point
            message += vbLf & "This BoundaryConditions is a Point Boundary Conditions."
            message += vbLf & "Location point: (" + point.X + ", " + point.Y + ", " + point.Z + ")"
            Exit Select
        Case 1
            message += vbLf & "This BoundaryConditions is a Line Boundary Conditions."
            Dim curve As Curve = boundaryConditions.Curve(0)
            ' Get curve start point
            message += vbLf & "Location Line: start point: (" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += ";  end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            Exit Select
        Case 2
            message += vbLf & "This BoundaryConditions is an Area Boundary Conditions."
            Dim i As Integer = 0
            While i < boundaryConditions.NumCurves
                Dim areaCurve As Autodesk.Revit.DB.Curve = boundaryConditions.Curve(i)
                ' Get curve start point
                message += vbLf & "Curve start point:(" + areaCurve.EndPoint(0).X + ", " + areaCurve.EndPoint(0).Y + ", " + areaCurve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + areaCurve.EndPoint(1).X + ", " + areaCurve.EndPoint(1).Y + ", " + areaCurve.EndPoint(1).Z + ")"
                System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
            End While
            Exit Select
        Case Else
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BoundaryConditions

See Also

BoundaryConditions Members


BoundaryConditions Members

[image] [image]

Revit 2011 API
BoundaryConditions Members
BoundaryConditions Class Methods Properties See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

Name | Description
associateWithLoad | Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | Retrieve the HostElementId.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | If successful, returns the point represents Boundary Conditions.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BoundaryConditions Class


BoundaryConditions Methods

[image] [image]

Revit 2011 API
BoundaryConditions Methods
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

Name | Description
associateWithLoad | Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundaryConditions Class


associateWithLoad Method

[image]

Revit 2011 API
BoundaryConditions..::.associateWithLoad Method
BoundaryConditions Class See Also Send Feedback
Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool associateWithLoad(
    ElementId elementToAssociateId
)
Visual Basic (Declaration)
Public Function associateWithLoad ( _
    elementToAssociateId As ElementId _
) As Boolean
Visual C++
public:
bool associateWithLoad(
    ElementId^ elementToAssociateId
)

Parameters

elementToAssociateId
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ of Load to associate.

Return Value

If the Autodesk::Revit::DB::ElementId^ was set returns true. Otherwise returns false.

Remarks

Autodesk::Revit::DB::ElementId^ may be set if the internal Load with the elementToAssociateId exist and it's type fit the BoundaryConditions type only.

See Also

BoundaryConditions Class


BoundaryConditions Properties

[image] [image]

Revit 2011 API
BoundaryConditions Properties
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Properties

Name | Description
AssociatedLoad | Retrieve the AssociatedLoad.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | Retrieve the HostElementId.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves represent the Boundary Conditions Element.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | If successful, returns the point represents Boundary Conditions.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

BoundaryConditions Class


AssociatedLoad Property

[image]

Revit 2011 API
BoundaryConditions..::.AssociatedLoad Property
BoundaryConditions Class See Also Send Feedback
Retrieve the AssociatedLoad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element AssociatedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssociatedLoad As Element
Visual C++
public:
property Element^ AssociatedLoad {
    Element^ get ();
}

See Also

BoundaryConditions Class


Curve Property

[image]

Revit 2011 API
BoundaryConditions..::.Curve Property
BoundaryConditions Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve[
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::.Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class


HostElement Property

[image]

Revit 2011 API
BoundaryConditions..::.HostElement Property
BoundaryConditions Class See Also Send Feedback
Retrieve the HostElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

See Also

BoundaryConditions Class


NumCurves Property

[image]

Revit 2011 API
BoundaryConditions..::.NumCurves Property
BoundaryConditions Class See Also Send Feedback
Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurves As Integer
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class


Parameter Property

[image] [image]

Revit 2011 API
BoundaryConditions..::.Parameter Property
BoundaryConditions Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

BoundaryConditions Class
BoundaryConditions Members


Point Property

[image]

Revit 2011 API
BoundaryConditions..::.Point Property
BoundaryConditions Class See Also Send Feedback
If successful, returns the point represents Boundary Conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

Returns the point if the BoundaryConditionsType == 0 - point. Otherwise returns default XYZ().

See Also

BoundaryConditions Class


BoundarySegment Class

[image]

Revit 2011 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegment

See Also

BoundarySegment Members


BoundarySegment Members

[image] [image]

Revit 2011 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class


BoundarySegment Methods

[image] [image]

Revit 2011 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class


BoundarySegment Properties

[image] [image]

Revit 2011 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class


Curve Property

[image]

Revit 2011 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class


Document Property

[image]

Revit 2011 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class


Element Property

[image]

Revit 2011 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class


BoundarySegmentArray Class

[image]

Revit 2011 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members


BoundarySegmentArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class


BoundarySegmentArray Constructor

[image]

Revit 2011 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class


BoundarySegmentArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class


Append Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class


Clear Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class


Insert Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class


BoundarySegmentArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class


Item Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class


Size Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class


BoundarySegmentArrayArray Class

[image]

Revit 2011 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members


BoundarySegmentArrayArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class


Append Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class


Clear Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class


Insert Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::.Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class


Item Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class


Size Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class


BoundingBoxContainsPointFilter Class

[image]

Revit 2011 API
BoundingBoxContainsPointFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxContainsPointFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class BoundingBoxContainsPointFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxContainsPointFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
// given point in the document.

// Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
XYZ basePnt = new XYZ(0, 0, 0);
BoundingBoxContainsPointFilter filter = new BoundingBoxContainsPointFilter(basePnt);

// Apply the filter to the elements in the active document
// This filter will excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls that do not contain the given point: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxContainsPointFilter notContainFilter =
    new BoundingBoxContainsPointFilter(basePnt, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notContainFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notContainFilter).ToElements();
CopyVB.NET
' Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
' given point in the document.

' Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
Dim basePnt As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim filter As New BoundingBoxContainsPointFilter(basePnt)

' Apply the filter to the elements in the active document
' This filter will excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find walls that do not contain the given point: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim notContainFilter As New BoundingBoxContainsPointFilter(basePnt, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notContainFounds As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(notContainFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.BoundingBoxContainsPointFilter

See Also

BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Members

[image] [image]

Revit 2011 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

Name | Description
BoundingBoxContainsPointFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Point | The XYZ point to use when matching element bounding boxes.
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter Constructor

[image] [image]

Revit 2011 API
BoundingBoxContainsPointFilter Constructor
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

Name | Description
BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Constructor (XYZ)

[image]

Revit 2011 API
BoundingBoxContainsPointFilter Constructor (XYZ)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point
)
Visual Basic (Declaration)
Public Sub New ( _
    point As XYZ _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point used to find elements with a bounding box that contains it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)

[image]

Revit 2011 API
BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    point As XYZ, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point used to find elements with a bounding box containing it.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Double)

[image]

Revit 2011 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance
)
Visual Basic (Declaration)
Public Sub New ( _
    point As XYZ, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point used to find elements with a bounding box that contains it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)

[image]

Revit 2011 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    point As XYZ, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point used to find elements with a bounding box containing it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Methods

[image] [image]

Revit 2011 API
BoundingBoxContainsPointFilter Methods
BoundingBoxContainsPointFilter Class See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter Properties

[image] [image]

Revit 2011 API
BoundingBoxContainsPointFilter Properties
BoundingBoxContainsPointFilter Class See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Point | The XYZ point to use when matching element bounding boxes.
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class


Point Property

[image]

Revit 2011 API
BoundingBoxContainsPointFilter..::.Point Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
The XYZ point to use when matching element bounding boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ Point { get; set; }
Visual Basic (Declaration)
Public Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

See Also

BoundingBoxContainsPointFilter Class


Tolerance Property

[image]

Revit 2011 API
BoundingBoxContainsPointFilter..::.Tolerance Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic (Declaration)
Public Property Tolerance As Double
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the point may lie up to the tolerance amount outside the outline to be matched. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline to be matched.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxIntersectsFilter Class

[image]

Revit 2011 API
BoundingBoxIntersectsFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class BoundingBoxIntersectsFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
// given Outline in the document.

// Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIntersects filter with this Outline
BoundingBoxIntersectsFilter filter = new BoundingBoxIntersectsFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIntersectsFilter invertFilter = new BoundingBoxIntersectsFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notIntersectWalls =
    collector.OfClass(typeof(Wall)).WherePasses(invertFilter).ToElements();
CopyVB.NET
' Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
' given Outline in the document.

' Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New Autodesk.Revit.DB.XYZ(0, 0, 0), New Autodesk.Revit.DB.XYZ(100, 100, 100))

' Create a BoundingBoxIntersects filter with this Outline
Dim filter As New BoundingBoxIntersectsFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim invertFilter As New BoundingBoxIntersectsFilter(myOutLn, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notIntersectWalls As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(invertFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.BoundingBoxIntersectsFilter

See Also

BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Members

[image] [image]

Revit 2011 API
BoundingBoxIntersectsFilter Members
BoundingBoxIntersectsFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors

Name | Description
BoundingBoxIntersectsFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the outline being used for this filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter Constructor

[image] [image]

Revit 2011 API
BoundingBoxIntersectsFilter Constructor
BoundingBoxIntersectsFilter Class See Also Send Feedback

Overload List

Name | Description
BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Constructor (Outline)

[image]

Revit 2011 API
BoundingBoxIntersectsFilter Constructor (Outline)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that intersect it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Boolean)

[image]

Revit 2011 API
BoundingBoxIntersectsFilter Constructor (Outline, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that intersect it.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double)

[image]

Revit 2011 API
BoundingBoxIntersectsFilter Constructor (Outline, Double)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)

[image]

Revit 2011 API
BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Methods

[image] [image]

Revit 2011 API
BoundingBoxIntersectsFilter Methods
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the outline being used for this filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxIntersectsFilter Class


GetBoundingBox Method

[image]

Revit 2011 API
BoundingBoxIntersectsFilter..::.GetBoundingBox Method
BoundingBoxIntersectsFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic (Declaration)
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter Properties

[image] [image]

Revit 2011 API
BoundingBoxIntersectsFilter Properties
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


Tolerance Property

[image]

Revit 2011 API
BoundingBoxIntersectsFilter..::.Tolerance Property
BoundingBoxIntersectsFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic (Declaration)
Public Property Tolerance As Double
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIsInsideFilter Class

[image]

Revit 2011 API
BoundingBoxIsInsideFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxIsInsideFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class BoundingBoxIsInsideFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxIsInsideFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
// by the given Outline in the document.

// Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIsInside filter for Outline
BoundingBoxIsInsideFilter filter = new BoundingBoxIsInsideFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls outside BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIsInsideFilter outsideFilter = new BoundingBoxIsInsideFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> outsideFounds = collector.OfClass(typeof(Wall)).WherePasses(outsideFilter).ToElements();
CopyVB.NET
' Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
' by the given Outline in the document.

' Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New Autodesk.Revit.DB.XYZ(0, 0, 0), New Autodesk.Revit.DB.XYZ(100, 100, 100))

' Create a BoundingBoxIsInside filter for Outline
Dim filter As New BoundingBoxIsInsideFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find walls outside BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim outsideFilter As New BoundingBoxIsInsideFilter(myOutLn, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim outsideFounds As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(outsideFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.BoundingBoxIsInsideFilter

See Also

BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Members

[image] [image]

Revit 2011 API
BoundingBoxIsInsideFilter Members
BoundingBoxIsInsideFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Constructors

Name | Description
BoundingBoxIsInsideFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the outline being used for this filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter Constructor

[image] [image]

Revit 2011 API
BoundingBoxIsInsideFilter Constructor
BoundingBoxIsInsideFilter Class See Also Send Feedback

Overload List

Name | Description
BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Constructor (Outline)

[image]

Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Boolean)

[image]

Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Double)

[image]

Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline, Double)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Double, Boolean)

[image]

Revit 2011 API
BoundingBoxIsInsideFilter Constructor (Outline, Double, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::.Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::.Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The outline is empty. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Methods

[image] [image]

Revit 2011 API
BoundingBoxIsInsideFilter Methods
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the outline being used for this filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxIsInsideFilter Class


GetBoundingBox Method

[image]

Revit 2011 API
BoundingBoxIsInsideFilter..::.GetBoundingBox Method
BoundingBoxIsInsideFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic (Declaration)
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter Properties

[image] [image]

Revit 2011 API
BoundingBoxIsInsideFilter Properties
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class


Tolerance Property

[image]

Revit 2011 API
BoundingBoxIsInsideFilter..::.Tolerance Property
BoundingBoxIsInsideFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic (Declaration)
Public Property Tolerance As Double
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the iterated element's Outline may extend the tolerance distance outside of the given Outline in each coordinate to be a match. If the tolerance is negative, the iterated element's Outline must lie at least the tolerance distance inside the given Outline in each coordinate to be a match.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxUV Class

[image]

Revit 2011 API
BoundingBoxUV Class
Members Example See Also Send Feedback
A two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundingBoxUV
Visual Basic (Declaration)
Public Class BoundingBoxUV
Visual C++
public ref class BoundingBoxUV

Examples

CopyC#
Document doc = application.ActiveUIDocument.Document;
FilteredElementCollector collector = new FilteredElementCollector(doc);
ICollection<Element> collection = collector.OfClass(typeof(Autodesk.Revit.DB.View)).ToElements();
foreach (Element element in collection)

{
    Autodesk.Revit.DB.View view = element as Autodesk.Revit.DB.View;
    if (null != view)
    {
        string messageInfo = "BoundingBoxUV : ";
        messageInfo += "\nView name : " + view.Name;
        BoundingBoxUV boundingBox = view.Outline;
        // Get max bounding box
        UV max = boundingBox.Max;
        messageInfo += "\nMax boundingbox : (" + max.U + "," + max.V + ")";
        // Get min bounding box
        UV min = boundingBox.Min;
        messageInfo += "\nMin boundingbox : (" + min.U + "," + min.V + ")";
        // Get bounds,
        // Use 0 for Min and 1 for Max
        UV bound = boundingBox.get_Bounds(0);
        messageInfo += "\nBoundingbox bounds : (" + bound.U + "," + bound.V + ")";
        TaskDialog.Show("Revit",messageInfo);
    }
}
CopyVB.NET
Dim doc As Document = application.ActiveUIDocument.Document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Autodesk.Revit.DB.View)).ToElements()
For Each element As Autodesk.Revit.DB.Element In collection

    Dim view As Autodesk.Revit.DB.View = TryCast(element, Autodesk.Revit.DB.View)
    If view IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxUV : "
        messageInfo += vbLf & "View name : " + view.Name
        Dim boundingBox As BoundingBoxUV = view.Outline
        ' Get max bounding box
        Dim max As Autodesk.Revit.DB.UV = boundingBox.Max
        messageInfo += vbLf & "Max boundingbox : (" + max.U + "," + max.V + ")"
        ' Get min bounding box
        Dim min As Autodesk.Revit.DB.UV = boundingBox.Min
        messageInfo += vbLf & "Min boundingbox : (" + min.U + "," + min.V + ")"
        ' Get bounds,
        ' Use 0 for Min and 1 for Max
        Dim bound As Autodesk.Revit.DB.UV = boundingBox.Bounds(0)
        messageInfo += vbLf & "Boundingbox bounds : (" + bound.U + "," + bound.V + ")"
        TaskDialog.Show("Revit", messageInfo)
    End If
Next

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BoundingBoxUV

See Also

BoundingBoxUV Members


BoundingBoxUV Members

[image] [image]

Revit 2011 API
BoundingBoxUV Members
BoundingBoxUV Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Constructors

Name | Description
BoundingBoxUV | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Max | Maximum coordinates (upper-right corner of the box).
Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


BoundingBoxUV Constructor

[image] [image]

Revit 2011 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback

Overload List

Name | Description
BoundingBoxUV()()() | default constructor
BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

See Also

BoundingBoxUV Class
BoundingBoxUV Members


BoundingBoxUV Constructor

[image]

Revit 2011 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback
default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxUV()

See Also

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Constructor (Double, Double, Double, Double)

[image]

Revit 2011 API
BoundingBoxUV Constructor (Double, Double, Double, Double)
BoundingBoxUV Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic (Declaration)
Public Sub New ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
)
Visual C++
public:
BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::.Double
The first coordinate of min.
min_v
Type: System..::.Double
The second coordinate of min.
max_u
Type: System..::.Double
The first coordinate of max.
max_v
Type: System..::.Double
The second coordinate of max.

See Also

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Methods

[image] [image]

Revit 2011 API
BoundingBoxUV Methods
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxUV Class


BoundingBoxUV Properties

[image] [image]

Revit 2011 API
BoundingBoxUV Properties
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Properties

Name | Description
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Max | Maximum coordinates (upper-right corner of the box).
Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


Bounds Property

[image]

Revit 2011 API
BoundingBoxUV..::.Bounds Property
BoundingBoxUV Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Bounds[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds ( _
    idx As Integer _
) As UV
Visual C++
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Type: System..::.Int32

See Also

BoundingBoxUV Class


Max Property

[image]

Revit 2011 API
BoundingBoxUV..::.Max Property
BoundingBoxUV Class See Also Send Feedback
Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Max { get; set; }
Visual Basic (Declaration)
Public Property Max As UV
Visual C++
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


Min Property

[image]

Revit 2011 API
BoundingBoxUV..::.Min Property
BoundingBoxUV Class See Also Send Feedback
Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Min { get; set; }
Visual Basic (Declaration)
Public Property Min As UV
Visual C++
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


BoundingBoxXYZ Class

[image]

Revit 2011 API
BoundingBoxXYZ Class
Members Example See Also Send Feedback
A three-dimensional rectangular box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundingBoxXYZ : APIObject
Visual Basic (Declaration)
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
public ref class BoundingBoxXYZ : public APIObject

Remarks

The box is defined as follows. A Transform specifies the coordinate system in which the box is defined. The minimum and maximum values for each coordinate in that system are specified. An alternative way to construct the box is: for each basis vector of the transform, there are two planes that are orthogonal to the vector and have their origins given by Transform.Origin + BasisVector * Bound. The entire box and each face may be turned on or off.

Examples

CopyC#
Document doc = uiApplication.ActiveUIDocument.Document;
View3D view3D = null;
FilteredElementCollector collector = new FilteredElementCollector(doc);
ICollection<Element> collection = collector.OfClass(typeof(View3D)).ToElements();
foreach (Element element in collection)
 {
    view3D = element as View3D;
    if (null != view3D)
    {
        string messageInfo = "BoundingBoxXYZ : ";
        messageInfo += "\nView name : " + view3D.Name;
        BoundingBoxXYZ boundingBox = view3D.SectionBox;
        if (!boundingBox.Enabled)
        {
            boundingBox.Enabled = true;
        }
        if (boundingBox.Enabled)
        {
            // Get max boundingbox
           XYZ max = boundingBox.Max;
            messageInfo += "\nMax boundingbox : (" + max.X + ","
                + max.Y + "," + max.Z + ")";
            // Get min boundingbox
            XYZ min = boundingBox.Min;
            messageInfo += "\nMin boundingbox : (" + min.X + ","
                + min.Y + "," + min.Z + ")";
            // Get if max boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMaxEnabledX = boundingBox.get_MaxEnabled(0);
            // Get if min boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMinEnabledX = boundingBox.get_MinEnabled(0);
            // Get if bound boundingbox enabled
            // For bound, use 0 for Min and 1 for Max.
            // For dimension, use 0 for X, 1 for Y and 2 for Z
            bool bBoundEnabled = boundingBox.get_BoundEnabled(0, 0);
            // Get minimum bound of boundingbox
            XYZ minBound = boundingBox.get_Bounds(0);
            // Get maximum bound of boundingbox
            XYZ maxBound = boundingBox.get_Bounds(1);
        }
        TaskDialog.Show("Revit",messageInfo);
    }
}
CopyVB.NET
Dim doc As Document = uiApplication.ActiveUIDocument.Document
Dim view3D As View3D = Nothing
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(View3D)).ToElements()
For Each element As Autodesk.Revit.DB.Element In collection
    view3D = TryCast(element, View3D)
    If view3D IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxXYZ : "
        messageInfo += vbLf & "View name : " + view3D.Name
        Dim boundingBox As BoundingBoxXYZ = view3D.SectionBox
        If Not boundingBox.Enabled Then
            boundingBox.Enabled = True
        End If
        If boundingBox.Enabled Then
            ' Get max boundingbox
            Dim max As Autodesk.Revit.DB.XYZ = boundingBox.Max
            messageInfo += vbLf & "Max boundingbox : (" + max.X + "," + max.Y + "," + max.Z + ")"
            ' Get min boundingbox
            Dim min As Autodesk.Revit.DB.XYZ = boundingBox.Min
            messageInfo += vbLf & "Min boundingbox : (" + min.X + "," + min.Y + "," + min.Z + ")"
            ' Get if max boundingbox enabled,
            ' use 0 for X, 1 for Y and 2 for Z
            Dim bMaxEnabledX As Boolean = boundingBox.MaxEnabled(0)
            ' Get if min boundingbox enabled,
            ' use 0 for X, 1 for Y and 2 for Z
            Dim bMinEnabledX As Boolean = boundingBox.MinEnabled(0)
            ' Get if bound boundingbox enabled
            ' For bound, use 0 for Min and 1 for Max.
            ' For dimension, use 0 for X, 1 for Y and 2 for Z
            Dim bBoundEnabled As Boolean = boundingBox.BoundEnabled(0, 0)
            ' Get minimum bound of boundingbox
            Dim minBound As Autodesk.Revit.DB.XYZ = boundingBox.Bounds(0)
            ' Get maximum bound of boundingbox
            Dim maxBound As Autodesk.Revit.DB.XYZ = boundingBox.Bounds(1)
        End If
        TaskDialog.Show("Revit", messageInfo)
    End If
Next

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.BoundingBoxXYZ

See Also

BoundingBoxXYZ Members


BoundingBoxXYZ Members

[image] [image]

Revit 2011 API
BoundingBoxXYZ Members
BoundingBoxXYZ Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Constructors

Name | Description
BoundingBoxXYZ | Initializes a new instance of the BoundingBoxXYZ class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundEnabled | Indexed access for loops.
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Enabled | Defines whether bounding box is turned on.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Max | Maximum coordinates (upper-right-front corner of the box).
MaxEnabled | Defines whether the maximum bound is active for given dimension.
Min | Minimum coordinates (lower-left-rear corner of the box).
MinEnabled | Defines whether the minimum bound is active for given dimension.
Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Constructor

[image]

Revit 2011 API
BoundingBoxXYZ Constructor
BoundingBoxXYZ Class See Also Send Feedback
Initializes a new instance of the BoundingBoxXYZ class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBoxXYZ()

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Methods

[image] [image]

Revit 2011 API
BoundingBoxXYZ Methods
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Properties

[image] [image]

Revit 2011 API
BoundingBoxXYZ Properties
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Properties

Name | Description
BoundEnabled | Indexed access for loops.
Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Enabled | Defines whether bounding box is turned on.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Max | Maximum coordinates (upper-right-front corner of the box).
MaxEnabled | Defines whether the maximum bound is active for given dimension.
Min | Minimum coordinates (lower-left-rear corner of the box).
MinEnabled | Defines whether the minimum bound is active for given dimension.
Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class


BoundEnabled Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.BoundEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool BoundEnabled[
    int bound,
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Type: System..::.Int32
dim
Type: System..::.Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class


Bounds Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.Bounds Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Bounds[
    int bound
] { get; set; }
Visual Basic (Declaration)
Public Property Bounds ( _
    bound As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}

Parameters

bound
Type: System..::.Int32

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class


Enabled Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.Enabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether bounding box is turned on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

BoundingBoxXYZ Class


Max Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.Max Property
BoundingBoxXYZ Class See Also Send Feedback
Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Max { get; set; }
Visual Basic (Declaration)
Public Property Max As XYZ
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class


MaxEnabled Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.MaxEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool MaxEnabled[
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::.Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class


Min Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.Min Property
BoundingBoxXYZ Class See Also Send Feedback
Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Min { get; set; }
Visual Basic (Declaration)
Public Property Min As XYZ
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box!

See Also

BoundingBoxXYZ Class


MinEnabled Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.MinEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool MinEnabled[
    int dim
] { get; set; }
Visual Basic (Declaration)
Public Property MinEnabled ( _
    dim As Integer _
) As Boolean
Visual C++
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::.Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds!

See Also

BoundingBoxXYZ Class


Transform Property

[image]

Revit 2011 API
BoundingBoxXYZ..::.Transform Property
BoundingBoxXYZ Class Example See Also Send Feedback
The transform FROM the coordinate space of the box TO the model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Transform { get; set; }
Visual Basic (Declaration)
Public Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

Examples

CopyC#
private void RotateBoundingBox(View3D view3d)
{
    BoundingBoxXYZ box = view3d.SectionBox;
    if (false == box.Enabled)
    {
        TaskDialog.Show("Revit","The section box for View3D isn't Enable.");
        return;
    }
    // Create a rotation transform,
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);
    Transform rotate = Transform.get_Rotation(origin, axis, 2);
    // Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate);
    view3d.SectionBox = box;
}
CopyVB.NET
Private Sub RotateBoundingBox(ByVal view3d As View3D)
    Dim box As BoundingBoxXYZ = view3d.SectionBox
    If False = box.Enabled Then
        TaskDialog.Show("Revit", "The section box for View3D isn't Enable.")
        Return
    End If
    ' Create a rotation transform,
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim axis As New Autodesk.Revit.DB.XYZ(0, 0, 1)
    Dim rotate As Transform = Transform.Rotation(origin, axis, 2)
    ' Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate)
    view3d.SectionBox = box
End Sub

See Also

BoundingBoxXYZ Class


BoxPlacement Enumeration

[image]

Revit 2011 API
BoxPlacement Enumeration
See Also Send Feedback
An enumerated type listing possible placement of a box (an object of rectangular shape.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BoxPlacement
Visual Basic (Declaration)
Public Enumeration BoxPlacement
Visual C++
public enum class BoxPlacement

Members

Member name | Description
Center | Placement of a box by its center point.
TopLeft | Placement of a box by its top left corner.
TopRight | Placement of a box by its top right corner.
BottomRight | Placement of a box by its bottom right corner.
BottomLeft | Placement of a box by its bottom left corner.

See Also


BuildingSiteExportOptions Class

[image]

Revit 2011 API
BuildingSiteExportOptions Class
Members See Also Send Feedback
Building Site Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BuildingSiteExportOptions
Visual Basic (Declaration)
Public Class BuildingSiteExportOptions
Visual C++
public ref class BuildingSiteExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuildingSiteExportOptions

See Also

BuildingSiteExportOptions Members


BuildingSiteExportOptions Members

[image] [image]

Revit 2011 API
BuildingSiteExportOptions Members
BuildingSiteExportOptions Class Constructors Methods Properties See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Constructors

Name | Description
BuildingSiteExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaPerPerson | Custom value for Area Per Person value.
PropertyLine | Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).
PropertyLineOffset | Property Line Offset. Default is 0.0.
TotalGrossArea | Custom value for the total area.
TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Constructor

[image]

Revit 2011 API
BuildingSiteExportOptions Constructor
BuildingSiteExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BuildingSiteExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BuildingSiteExportOptions()

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Methods

[image] [image]

Revit 2011 API
BuildingSiteExportOptions Methods
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Properties

[image] [image]

Revit 2011 API
BuildingSiteExportOptions Properties
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Properties

Name | Description
AreaPerPerson | Custom value for Area Per Person value.
PropertyLine | Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).
PropertyLineOffset | Property Line Offset. Default is 0.0.
TotalGrossArea | Custom value for the total area.
TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class


AreaPerPerson Property

[image]

Revit 2011 API
BuildingSiteExportOptions..::.AreaPerPerson Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for Area Per Person value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AreaPerPerson { get; set; }
Visual Basic (Declaration)
Public Property AreaPerPerson As Double
Visual C++
public:
property double AreaPerPerson {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


PropertyLine Property

[image]

Revit 2011 API
BuildingSiteExportOptions..::.PropertyLine Property
BuildingSiteExportOptions Class See Also Send Feedback
Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PropertyLine PropertyLine { get; set; }
Visual Basic (Declaration)
Public Property PropertyLine As PropertyLine
Visual C++
public:
property PropertyLine^ PropertyLine {
    PropertyLine^ get ();
    void set (PropertyLine^ value);
}

See Also

BuildingSiteExportOptions Class


PropertyLineOffset Property

[image]

Revit 2011 API
BuildingSiteExportOptions..::.PropertyLineOffset Property
BuildingSiteExportOptions Class See Also Send Feedback
Property Line Offset. Default is 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PropertyLineOffset { get; set; }
Visual Basic (Declaration)
Public Property PropertyLineOffset As Double
Visual C++
public:
property double PropertyLineOffset {
    double get ();
    void set (double value);
}

Remarks

Is only used if property line is also specified.

See Also

BuildingSiteExportOptions Class


TotalGrossArea Property

[image]

Revit 2011 API
BuildingSiteExportOptions..::.TotalGrossArea Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TotalGrossArea { get; set; }
Visual Basic (Declaration)
Public Property TotalGrossArea As Double
Visual C++
public:
property double TotalGrossArea {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


TotalOccupancy Property

[image]

Revit 2011 API
BuildingSiteExportOptions..::.TotalOccupancy Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total occupancy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TotalOccupancy { get; set; }
Visual Basic (Declaration)
Public Property TotalOccupancy As Integer
Visual C++
public:
property int TotalOccupancy {
    int get ();
    void set (int value);
}

Remarks

If specified value > 0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


BuildingType Enumeration

[image]

Revit 2011 API
BuildingType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BuildingType
Visual Basic (Declaration)
Public Enumeration BuildingType
Visual C++
public enum class BuildingType

Members

Member name | Description
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kConventionCenter | Building Type is ConventionCenter.
kCourthouse | Building Type is Courthouse.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningFamily | Building Type is DiningFamily.
kDormitory | Building Type is Dormitory.
kExerciseCenter | Building Type is ExerciseCenter.
kFireStation | Building Type is FireStation.
kGymnasium | Building Type is Gymnasium.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kHotel | Building Type is Hotel.
kLibrary | Building Type is Library.
kManufacturing | Building Type is Manufacturing.
kMotel | Building Type is Motel.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMultiFamily | Building Type is MultiFamily.
kMuseum | Building Type is Museum.
kOffice | Building Type is Office.
kParkingGarage | Building Type is ParkingGarage.
kPenitentiary | Building Type is Penitentiary.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPoliceStation | Building Type is PoliceStation.
kPostOffice | Building Type is PostOffice.
kReligiousBuilding | Building Type is ReligiousBuilding.
kRetail | Building Type is Retail.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kSportsArena | Building Type is SportsArena.
kTownHall | Building Type is TownHall.
kTransportation | Building Type is Transportation.
kWarehouse | Building Type is Warehouse.
kWorkshop | Building Type is Workshop.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also


BuiltInCategory Enumeration

[image]

Revit 2011 API
BuiltInCategory Enumeration
See Also Send Feedback
A list of all the built in categories within Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BuiltInCategory
Visual Basic (Declaration)
Public Enumeration BuiltInCategory
Visual C++
public enum class BuiltInCategory

Members

Member name | Description
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassFloor_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_CompassSecondaryMonth |
OST_CompassPrimaryMonth |
OST_CompassSectionFilled |
OST_LightLine |
OST_MultiSurface |
OST_SunSurface |
OST_Analemma |
OST_SunsetText |
OST_CompassSection |
OST_CompassOuter |
OST_SunriseText |
OST_CompassInner |
OST_SunPath2 |
OST_SunPath1 |
OST_Sun |
OST_SunStudy |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionTags |
OST_StructWeldLines |
OST_StructConnections |
OST_RebarSetToggle |
OST_AreaReinTags |
OST_RebarTags |
OST_RebarCover |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_ElectricalInternalCircuits |
OST_PanelScheduleGraphics |
OST_CableTrayRun |
OST_ConduitRun |
OST_ParamElemElectricalLoadClassification |
OST_DataPanelScheduleTemplates |
OST_SwitchboardScheduleTemplates |
OST_BranchPanelScheduleTemplates |
OST_ConduitStandards |
OST_ElectricalLoadClassifications |
OST_ElectricalDemandFactorDefinitions |
OST_ConduitFittingCenterLine |
OST_CableTrayFittingCenterLine |
OST_ConduitCenterLine |
OST_ConduitDrop |
OST_ConduitRiseDrop |
OST_CableTrayCenterLine |
OST_CableTrayDrop |
OST_CableTrayRiseDrop |
OST_ConduitTags |
OST_Conduit |
OST_CableTrayTags |
OST_CableTray |
OST_ConduitFittingTags |
OST_ConduitFitting |
OST_CableTrayFittingTags |
OST_CableTrayFitting |
OST_DuctLinings |
OST_DuctInsulations |
OST_PipeInsulations |
OST_HVAC_Load_Schedules |
OST_HVAC_Load_Building_Types |
OST_HVAC_Load_Space_Types |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_DuctColorFills |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructConnectionSymbols |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_ElevationMarks |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_MassGlazingAll |
OST_MassFloorsAll |
OST_MassWallsAll |
OST_MassExteriorWallUnderground |
OST_MassSlab |
OST_MassShade |
OST_MassOpening |
OST_MassSkylights |
OST_MassWindow |
OST_MassRoof |
OST_MassExteriorWall |
OST_MassInteriorWall |
OST_MassZone |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassForm |
OST_MassFloor |
OST_Mass |
OST_DividedSurface_DiscardedDivisionLines |
OST_DividedSurfaceBelt |
OST_TilePatterns |
OST_AlwaysExcludedInAllViews |
OST_DividedSurface_TransparentFace |
OST_DividedSurface_PreDividedSurface |
OST_DividedSurface_PatternFill |
OST_DividedSurface_PatternLines |
OST_DividedSurface_Gridlines |
OST_DividedSurface_Nodes |
OST_DividedSurface |
OST_RepeatingDetailLines |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_TrussDummy |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_Sheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_BasePointAxisZ |
OST_BasePointAxisY |
OST_BasePointAxisX |
OST_SharedBasePoint |
OST_ProjectBasePoint |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_HiddenBuildingUnitLines |
OST_BuildingUnits |
OST_Sewer |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_FurnitureSystems |
OST_ElectricalFixtures |
OST_ElectricalEquipment |
OST_Casework |
OST_ArcWallRectOpening |
OST_DormerOpeningIncomplete |
OST_SWallRectOpening |
OST_ShaftOpening |
OST_StructuralFramingOpening |
OST_ColumnOpening |
OST_AdaptivePoints_HiddenLines |
OST_AdaptivePoints_Lines |
OST_AdaptivePoints_Planes |
OST_AdaptivePoints_Points |
OST_AdaptivePoints |
OST_CeilingOpening |
OST_FloorOpening |
OST_RoofOpening |
OST_WallRefPlanes |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_RemovedGridSeg |
OST_IOSOpening |
OST_IOSTilePatternGrid |
OST_ControlLocal |
OST_ControlAxisZ |
OST_ControlAxisY |
OST_ControlAxisX |
OST_XRayConstrainedProfileEdge |
OST_XRayImplicitPathCurve |
OST_XRayPathPoint |
OST_XRayPathCurve |
OST_XRaySideEdge |
OST_XRayProfileEdge |
OST_ReferencePoints_HiddenLines |
OST_ReferencePoints_Lines |
OST_ReferencePoints_Planes |
OST_ReferencePoints_Points |
OST_ReferencePoints |
OST_Materials |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_PreviewLegendComponents |
OST_LegendComponents |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_FloorsAnalyticalGeometry |
OST_WallsAnalyticalGeometry |
OST_CalloutLeaderLine |
OST_CeilingsSurfacePattern |
OST_RoofsSurfacePattern |
OST_FloorsSurfacePattern |
OST_WallsSurfacePattern |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_DetailArray |
OST_ModelArray |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_AnalysisDisplayStyle |
OST_AnalysisResults |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_DatumLevels |
OST_Levels |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_GenericModel |
OST_GenericAnnotation |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsDownArrow |
OST_StairsUpArrow |
OST_StairsDownText |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsUpText |
OST_StairsStringerAboveCut |
OST_StairsStringer |
OST_StairsAboveCut |
OST_StairsIncomplete |
OST_Stairs |
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_GuideGrid |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_Columns |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_ReferenceLines |
OST_IOSNotSilhouette |
OST_FillPatterns |
OST_Furniture |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_StairsLandingCenterLines |
OST_StairsRunLines |
OST_StairsRiserLines |
OST_StairsBoundaryLines |
OST_AreaSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_Extrusions |
OST_IOS |
OST_CutOutlines |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_Lines |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_IOSRegenerationFailure |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also


BuiltInFailures Class

[image]

Revit 2011 API
BuiltInFailures Class
See Also Send Feedback
Provides a container of all Revit built-in FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class BuiltInFailures
Visual Basic (Declaration)
Public NotInheritable Class BuiltInFailures
Visual C++
public ref class BuiltInFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures

See Also


BuiltInFailures.AnalyticalModelFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AnalyticalModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class AnalyticalModelFailures
Visual Basic (Declaration)
Public NotInheritable Class AnalyticalModelFailures
Visual C++
public ref class AnalyticalModelFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.AnalyticalModelFailures

See Also

BuiltInFailures..::.AnalyticalModelFailures Members


BuiltInFailures.AnalyticalModelFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures Members
BuiltInFailures..::.AnalyticalModelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
CannotCreateAnalyticalGeometry | Can not construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Can not construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.
ZeroAreaAnalyticalModel | Zero-area Analytical Model Detected
ZeroLengthAnalyticalModel | Zero-length Analytical Model Detected

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures Properties
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback

The BuiltInFailures..::.AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
CannotCreateAnalyticalGeometry | Can not construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Can not construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.
ZeroAreaAnalyticalModel | Zero-area Analytical Model Detected
ZeroLengthAnalyticalModel | Zero-length Analytical Model Detected

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalBeamSlabWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalBeamSlabWarning Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Beam and Slab Analytical Models do not have the same Analytical Projection Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalBeamSlabWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalBeamSlabWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalBeamSlabWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalDiscrepancyWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalDiscrepancyWarning Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalDiscrepancyWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalDiscrepancyWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalDiscrepancyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalGapWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalGapWarning Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Detected physical connection between Structural Elements, but did not detect Analytical intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalGapWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalGapWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalGapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalMemberInstability Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalMemberInstability Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Possible Member Instability, based on Release Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalMemberInstability { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalMemberInstability As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalMemberInstability {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalModelInstability Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalModelInstability Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Possible Model Instability

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalModelInstability { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalModelInstability As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalModelInstability {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalPhysicalCheckDone Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalPhysicalCheckDone Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Analytical / Physical Model Consistency check is complete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalPhysicalCheckDone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalPhysicalCheckDone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalPhysicalCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalSupportCycleWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalSupportCycleWarning Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Circular support chain detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalSupportCycleWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalSupportCycleWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalSupportCycleWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AnalyticalTopBottomPlanesReversed Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AnalyticalTopBottomPlanesReversed Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalTopBottomPlanesReversed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AnalyticalTopBottomPlanesReversed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AnalyticalTopBottomPlanesReversed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


AutoDetectIgnoreLeaderWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.AutoDetectIgnoreLeaderWarning Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Analytical Model for Structural Element has reset to its default location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AutoDetectIgnoreLeaderWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AutoDetectIgnoreLeaderWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AutoDetectIgnoreLeaderWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


CannotCreateAnalyticalGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.CannotCreateAnalyticalGeometry Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Can not construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateAnalyticalGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateAnalyticalGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateAnalyticalGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


CannotKeepAnalyticalAdjustment Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.CannotKeepAnalyticalAdjustment Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepAnalyticalAdjustment { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotKeepAnalyticalAdjustment As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotKeepAnalyticalAdjustment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


CannotMakeAnalyticalGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.CannotMakeAnalyticalGeometry Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Can not construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeAnalyticalGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeAnalyticalGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeAnalyticalGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


LoadsMayBeNotUpToDate Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.LoadsMayBeNotUpToDate Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Some of reactions may be not up-to-date

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoadsMayBeNotUpToDate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoadsMayBeNotUpToDate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoadsMayBeNotUpToDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


StructAnalyticalErrorProjection Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.StructAnalyticalErrorProjection Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model to Analytical Projection Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructAnalyticalErrorProjection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructAnalyticalErrorProjection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructAnalyticalErrorProjection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


StructuralElementMayNotBeSupported Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.StructuralElementMayNotBeSupported Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Structural Element may not be supported -- verify support for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructuralElementMayNotBeSupported { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructuralElementMayNotBeSupported As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructuralElementMayNotBeSupported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


StructWallAnalyticalErrorAlign Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.StructWallAnalyticalErrorAlign Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Can't align Analytical Model with joined Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructWallAnalyticalErrorAlign { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructWallAnalyticalErrorAlign As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorAlign {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


StructWallAnalyticalErrorConversion Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.StructWallAnalyticalErrorConversion Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Can't convert Edges to Analytical Model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructWallAnalyticalErrorConversion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructWallAnalyticalErrorConversion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorConversion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


SupportCheckDone Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.SupportCheckDone Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Member support check is complete. No unsupported elements detected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SupportCheckDone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SupportCheckDone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SupportCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


ZeroAreaAnalyticalModel Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.ZeroAreaAnalyticalModel Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Zero-area Analytical Model Detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroAreaAnalyticalModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroAreaAnalyticalModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroAreaAnalyticalModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


ZeroLengthAnalyticalModel Property

[image]

Revit 2011 API
BuiltInFailures..::.AnalyticalModelFailures..::.ZeroLengthAnalyticalModel Property
BuiltInFailures..::.AnalyticalModelFailures Class See Also Send Feedback
Zero-length Analytical Model Detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthAnalyticalModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroLengthAnalyticalModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthAnalyticalModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AnalyticalModelFailures Class


BuiltInFailures.ArrayFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ArrayFailures
Visual Basic (Declaration)
Public NotInheritable Class ArrayFailures
Visual C++
public ref class ArrayFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ArrayFailures

See Also

BuiltInFailures..::.ArrayFailures Members


BuiltInFailures.ArrayFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures Members
BuiltInFailures..::.ArrayFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
InvalidPath3dIsAssignedToArray | Invalid Path3d is assigned to the Array.
OnlyGroupsAndInstancesShouldBePlaced | Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::.ArrayFailures Class


BuiltInFailures.ArrayFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures Properties
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback

The BuiltInFailures..::.ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
InvalidPath3dIsAssignedToArray | Invalid Path3d is assigned to the Array.
OnlyGroupsAndInstancesShouldBePlaced | Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::.ArrayFailures Class


ArrayingNotSupportedForElements Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.ArrayingNotSupportedForElements Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Arraying is not currently supported for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayingNotSupportedForElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArrayingNotSupportedForElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArrayingNotSupportedForElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


ArrayMixedModAndViewSpecElemsCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.ArrayMixedModAndViewSpecElemsCorruption Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Unable to array this mixture of modeling and view specific elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


ArrayMixedModAndViewSpecElemsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.ArrayMixedModAndViewSpecElemsWarning Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


CannotCreateArraySelectionIsGrouped Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.CannotCreateArraySelectionIsGrouped Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Can't create an array because the selection cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateArraySelectionIsGrouped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateArraySelectionIsGrouped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateArraySelectionIsGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


ConstraintsNotSatisfied Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.ConstraintsNotSatisfied Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConstraintsNotSatisfied { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConstraintsNotSatisfied As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConstraintsNotSatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


CouldntFindNewHostsForElements Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.CouldntFindNewHostsForElements Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Couldn't find new hosts for elements in array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CouldntFindNewHostsForElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CouldntFindNewHostsForElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CouldntFindNewHostsForElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


IdenticalGeometryCopiesInArray Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.IdenticalGeometryCopiesInArray Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IdenticalGeometryCopiesInArray { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IdenticalGeometryCopiesInArray As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IdenticalGeometryCopiesInArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


InvalidPath3dIsAssignedToArray Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.InvalidPath3dIsAssignedToArray Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Invalid Path3d is assigned to the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPath3dIsAssignedToArray { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPath3dIsAssignedToArray As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPath3dIsAssignedToArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


OnlyGroupsAndInstancesShouldBePlaced Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.OnlyGroupsAndInstancesShouldBePlaced Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyGroupsAndInstancesShouldBePlaced { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyGroupsAndInstancesShouldBePlaced As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyGroupsAndInstancesShouldBePlaced {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


RadiusTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.ArrayFailures..::.RadiusTooSmall Property
BuiltInFailures..::.ArrayFailures Class See Also Send Feedback
Radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RadiusTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RadiusTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ArrayFailures Class


BuiltInFailures.AutoJoinFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoJoin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class AutoJoinFailures
Visual Basic (Declaration)
Public NotInheritable Class AutoJoinFailures
Visual C++
public ref class AutoJoinFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.AutoJoinFailures

See Also

BuiltInFailures..::.AutoJoinFailures Members


BuiltInFailures.AutoJoinFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures Members
BuiltInFailures..::.AutoJoinFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.AutoJoinFailures type exposes the following members.

Properties

Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.

See Also

BuiltInFailures..::.AutoJoinFailures Class


BuiltInFailures.AutoJoinFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures Properties
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback

The BuiltInFailures..::.AutoJoinFailures type exposes the following members.

Properties

Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.

See Also

BuiltInFailures..::.AutoJoinFailures Class


DesignOptionAndWorksetViolation Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.DesignOptionAndWorksetViolation Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Can't make the expected join because of editability and design option restrictions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionAndWorksetViolation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DesignOptionAndWorksetViolation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DesignOptionAndWorksetViolation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


DesignOptionCannotReference Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.DesignOptionCannotReference Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Design Option ' [Name] ' cannot reference Design Option ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionCannotReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DesignOptionCannotReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DesignOptionCannotReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


OtherNonEditJoinFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.OtherNonEditJoinFailure Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because other elements at join are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OtherNonEditJoinFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OtherNonEditJoinFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OtherNonEditJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


UnexpectedJoinFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.UnexpectedJoinFailure Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Join failure caused by editability or design option related problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedJoinFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnexpectedJoinFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnexpectedJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


Unknown Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.Unknown Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Unknown

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId Unknown { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Unknown As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ Unknown {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


WorksetJoinWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoJoinFailures..::.WorksetJoinWarn Property
BuiltInFailures..::.AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because one or both is not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetJoinWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WorksetJoinWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WorksetJoinWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoJoinFailures Class


BuiltInFailures.AutoRouteFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoRoute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class AutoRouteFailures
Visual Basic (Declaration)
Public NotInheritable Class AutoRouteFailures
Visual C++
public ref class AutoRouteFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.AutoRouteFailures

See Also

BuiltInFailures..::.AutoRouteFailures Members


BuiltInFailures.AutoRouteFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures Members
BuiltInFailures..::.AutoRouteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToComnnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToComnnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::.AutoRouteFailures Class


BuiltInFailures.AutoRouteFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures Properties
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback

The BuiltInFailures..::.AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToComnnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToComnnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::.AutoRouteFailures Class


AttemptToComnnectNonSlopingElementToSlopedPipeError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.AttemptToComnnectNonSlopingElementToSlopedPipeError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToComnnectNonSlopingElementToSlopedPipeError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AttemptToComnnectNonSlopingElementToSlopedPipeError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AttemptToComnnectNonSlopingElementToSlopedPipeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


AttemptToComnnectNonSlopingElementToSlopedPipeWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.AttemptToComnnectNonSlopingElementToSlopedPipeWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToComnnectNonSlopingElementToSlopedPipeWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AttemptToComnnectNonSlopingElementToSlopedPipeWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AttemptToComnnectNonSlopingElementToSlopedPipeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


DesignOptionConflictError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.DesignOptionConflictError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionConflictError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DesignOptionConflictError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


DesignOptionConflictWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.DesignOptionConflictWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionConflictWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DesignOptionConflictWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


DistributionTypeInvalid Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.DistributionTypeInvalid Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
Selected distribution system type is invalid!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DistributionTypeInvalid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DistributionTypeInvalid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DistributionTypeInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


ElementHasFlowCalculation Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.ElementHasFlowCalculation Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementHasFlowCalculation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementHasFlowCalculation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementHasFlowCalculation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


ElementHasOpenConnection Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.ElementHasOpenConnection Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementHasOpenConnection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementHasOpenConnection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementHasOpenConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailedDowngradeCrossToElbow Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailedDowngradeCrossToElbow Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
Failed to downgrade tee type to elbow type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeCrossToElbow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedDowngradeCrossToElbow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeCrossToElbow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailedDowngradeCrossToTee Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailedDowngradeCrossToTee Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
Failed to downgrade cross type to tee type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeCrossToTee { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedDowngradeCrossToTee As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeCrossToTee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailedDowngradeTeeToCross Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailedDowngradeTeeToCross Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
Failed to upgrade tee type to cross type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeTeeToCross { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedDowngradeTeeToCross As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeTeeToCross {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailToDoCompatiblePhaseError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailToDoCompatiblePhaseError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailToDoCompatiblePhaseError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailToDoCompatiblePhaseWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailToDoCompatiblePhaseWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailToDoCompatiblePhaseWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailToIntersectParallelSegmentsError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailToIntersectParallelSegmentsError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailToIntersectParallelSegmentsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FailToIntersectParallelSegmentsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FailToIntersectParallelSegmentsWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailToIntersectParallelSegmentsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FittingParamsCauseGeometryToFailError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FittingParamsCauseGeometryToFailError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FittingParamsCauseGeometryToFailError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


FittingParamsCauseGeometryToFailWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.FittingParamsCauseGeometryToFailWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FittingParamsCauseGeometryToFailWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


HighlightedElementDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.HighlightedElementDisconnected Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The highlighted element has been disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HighlightedElementDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


InappropriateSlopeForPipe Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.InappropriateSlopeForPipe Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InappropriateSlopeForPipe { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InappropriateSlopeForPipe As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InappropriateSlopeForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoAutoRouteSolutionFoundError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoAutoRouteSolutionFoundError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoAutoRouteSolutionFoundError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoAutoRouteSolutionFoundError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoAutoRouteSolutionFoundWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoAutoRouteSolutionFoundWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoAutoRouteSolutionFoundWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoAutoRouteSolutionFoundWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoFittingInProjectError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoFittingInProjectError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingInProjectError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFittingInProjectError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoFittingInProjectWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoFittingInProjectWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingInProjectWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFittingInProjectWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoSolutionInView Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoSolutionInView Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSolutionInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSolutionInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSolutionInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NotEnoughRoomForFittingsError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NotEnoughRoomForFittingsError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotEnoughRoomForFittingsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NotEnoughRoomForFittingsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NotEnoughRoomForFittingsWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotEnoughRoomForFittingsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


NoValidSolutionAtSelectedPoint Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.NoValidSolutionAtSelectedPoint Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
No valid auto-route solution at selected point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoValidSolutionAtSelectedPoint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoValidSolutionAtSelectedPoint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoValidSolutionAtSelectedPoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SegmentDrawnFromWrongSideError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SegmentDrawnFromWrongSideError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentDrawnFromWrongSideError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentDrawnFromWrongSideError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SegmentDrawnFromWrongSideWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SegmentDrawnFromWrongSideWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentDrawnFromWrongSideWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentDrawnFromWrongSideWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SegmentsAngleTooGreatError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SegmentsAngleTooGreatError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentsAngleTooGreatError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SegmentsAngleTooGreatWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SegmentsAngleTooGreatWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentsAngleTooGreatWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SolutionIsOppositeToConnectionError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SolutionIsOppositeToConnectionError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SolutionIsOppositeToConnectionError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


SolutionIsOppositeToConnectionWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.SolutionIsOppositeToConnectionWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SolutionIsOppositeToConnectionWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


UnableToMakeConnectionInDirection Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.UnableToMakeConnectionInDirection Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMakeConnectionInDirection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToMakeConnectionInDirection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeConnectionInDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


UtilizationCoefficientOutOfRange Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.UtilizationCoefficientOutOfRange Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The value for Coefficient of Utilization must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UtilizationCoefficientOutOfRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UtilizationCoefficientOutOfRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UtilizationCoefficientOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


ZeroLengthSegmentError Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.ZeroLengthSegmentError Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroLengthSegmentError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


ZeroLengthSegmentWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.AutoRouteFailures..::.ZeroLengthSegmentWarning Property
BuiltInFailures..::.AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroLengthSegmentWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.AutoRouteFailures Class


BuiltInFailures.BeamFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.BeamFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class BeamFailures
Visual Basic (Declaration)
Public NotInheritable Class BeamFailures
Visual C++
public ref class BeamFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.BeamFailures

See Also

BuiltInFailures..::.BeamFailures Members


BuiltInFailures.BeamFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.BeamFailures Members
BuiltInFailures..::.BeamFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::.BeamFailures Class


BuiltInFailures.BeamFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.BeamFailures Properties
BuiltInFailures..::.BeamFailures Class See Also Send Feedback

The BuiltInFailures..::.BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::.BeamFailures Class


CannotBendBeamType Property

[image]

Revit 2011 API
BuiltInFailures..::.BeamFailures..::.CannotBendBeamType Property
BuiltInFailures..::.BeamFailures Class See Also Send Feedback
Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotBendBeamType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotBendBeamType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotBendBeamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BeamFailures Class


BuiltInFailures.BeamSystemFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class BeamSystemFailures
Visual Basic (Declaration)
Public NotInheritable Class BeamSystemFailures
Visual C++
public ref class BeamSystemFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.BeamSystemFailures

See Also

BuiltInFailures..::.BeamSystemFailures Members


BuiltInFailures.BeamSystemFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures Members
BuiltInFailures..::.BeamSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.BeamSystemFailures type exposes the following members.

Properties

Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.

See Also

BuiltInFailures..::.BeamSystemFailures Class


BuiltInFailures.BeamSystemFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures Properties
BuiltInFailures..::.BeamSystemFailures Class See Also Send Feedback

The BuiltInFailures..::.BeamSystemFailures type exposes the following members.

Properties

Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.

See Also

BuiltInFailures..::.BeamSystemFailures Class


BeamSystemEdgeBeamTooWide Property

[image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures..::.BeamSystemEdgeBeamTooWide Property
BuiltInFailures..::.BeamSystemFailures Class See Also Send Feedback
Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemEdgeBeamTooWide { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BeamSystemEdgeBeamTooWide As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BeamSystemEdgeBeamTooWide {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BeamSystemFailures Class


BeamSystemHasTooManyBeams Property

[image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures..::.BeamSystemHasTooManyBeams Property
BuiltInFailures..::.BeamSystemFailures Class See Also Send Feedback
A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemHasTooManyBeams { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BeamSystemHasTooManyBeams As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BeamSystemHasTooManyBeams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BeamSystemFailures Class


BeamSystemTagBadView Property

[image]

Revit 2011 API
BuiltInFailures..::.BeamSystemFailures..::.BeamSystemTagBadView Property
BuiltInFailures..::.BeamSystemFailures Class See Also Send Feedback
Beam System Tags can only be placed in plan , elevation and 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemTagBadView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BeamSystemTagBadView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BeamSystemTagBadView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BeamSystemFailures Class


BuiltInFailures.BendFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Bends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class BendFailures
Visual Basic (Declaration)
Public NotInheritable Class BendFailures
Visual C++
public ref class BendFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.BendFailures

See Also

BuiltInFailures..::.BendFailures Members


BuiltInFailures.BendFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.BendFailures Members
BuiltInFailures..::.BendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/eblow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::.BendFailures Class


BuiltInFailures.BendFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.BendFailures Properties
BuiltInFailures..::.BendFailures Class See Also Send Feedback

The BuiltInFailures..::.BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/eblow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::.BendFailures Class


BendAngleIsUnacceptable Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.BendAngleIsUnacceptable Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
The angle of the bend/eblow is unacceptable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BendAngleIsUnacceptable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BendAngleIsUnacceptable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BendAngleIsUnacceptable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


DeleteMiddleBendNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.DeleteMiddleBendNotAllowed Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
Delete a middle bend in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteMiddleBendNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeleteMiddleBendNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeleteMiddleBendNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


DeleteSegmentInBankNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.DeleteSegmentInBankNotAllowed Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
Delete a segment in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteSegmentInBankNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeleteSegmentInBankNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeleteSegmentInBankNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentControl Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentControl Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Control elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentControl { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentControl As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentControl {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentDetailComponent Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentDetailComponent Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" 2D Detail Component elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentDetailComponent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentDetailComponent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentDetailComponent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentFilledRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentFilledRegion Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Filled Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentFilledRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentFilledRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentFilledRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentImage Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentImage Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Image elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentImage { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentImage As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentImage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentImport Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentImport Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" CAD File elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentImport { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentImport As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentImport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentMaskingRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentMaskingRegion Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Masking Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentMaskingRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentMaskingRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentMaskingRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentModelLine Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentModelLine Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Model Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentModelLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentModelLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentModelLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentOpening Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentOpening Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Opening elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentOpening { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentOpening As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentRefLine Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentRefLine Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Reference Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentRefLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentRefLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentRefLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentRefPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentRefPlane Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Reference Plane elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentRefPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentRefPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentSharedFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentSharedFamily Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Shared Family Instances were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSharedFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentSharedFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentSharedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentSymbol Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentSymbol Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Symbol elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSymbol { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentSymbol As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


NotBentSymbolicLine Property

[image]

Revit 2011 API
BuiltInFailures..::.BendFailures..::.NotBentSymbolicLine Property
BuiltInFailures..::.BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Symbolic Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSymbolicLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotBentSymbolicLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbolicLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BendFailures Class


BuiltInFailures.BlendFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.BlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class BlendFailures
Visual Basic (Declaration)
Public NotInheritable Class BlendFailures
Visual C++
public ref class BlendFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.BlendFailures

See Also

BuiltInFailures..::.BlendFailures Members


BuiltInFailures.BlendFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.BlendFailures Members
BuiltInFailures..::.BlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.BlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawBlend | Can't create blend.

See Also

BuiltInFailures..::.BlendFailures Class


BuiltInFailures.BlendFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.BlendFailures Properties
BuiltInFailures..::.BlendFailures Class See Also Send Feedback

The BuiltInFailures..::.BlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawBlend | Can't create blend.

See Also

BuiltInFailures..::.BlendFailures Class


CannotDrawBlend Property

[image]

Revit 2011 API
BuiltInFailures..::.BlendFailures..::.CannotDrawBlend Property
BuiltInFailures..::.BlendFailures Class See Also Send Feedback
Can't create blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawBlend { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawBlend As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawBlend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.BlendFailures Class


BuiltInFailures.ColorFillFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ColorFillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ColorFill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ColorFillFailures
Visual Basic (Declaration)
Public NotInheritable Class ColorFillFailures
Visual C++
public ref class ColorFillFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ColorFillFailures

See Also

BuiltInFailures..::.ColorFillFailures Members


BuiltInFailures.ColorFillFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColorFillFailures Members
BuiltInFailures..::.ColorFillFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::.ColorFillFailures Class


BuiltInFailures.ColorFillFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColorFillFailures Properties
BuiltInFailures..::.ColorFillFailures Class See Also Send Feedback

The BuiltInFailures..::.ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::.ColorFillFailures Class


OnlyOneColorFillNonPlan Property

[image]

Revit 2011 API
BuiltInFailures..::.ColorFillFailures..::.OnlyOneColorFillNonPlan Property
BuiltInFailures..::.ColorFillFailures Class See Also Send Feedback
A Color Fill Legend can only be placed in a Floor Plan View or a Section View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyOneColorFillNonPlan { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyOneColorFillNonPlan As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyOneColorFillNonPlan {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColorFillFailures Class


SymtemColorFillLegendNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.ColorFillFailures..::.SymtemColorFillLegendNotAllowed Property
BuiltInFailures..::.ColorFillFailures Class See Also Send Feedback
[Category name] Color Fill Legend can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SymtemColorFillLegendNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SymtemColorFillLegendNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SymtemColorFillLegendNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColorFillFailures Class


BuiltInFailures.ColumnFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ColumnFailures
Visual Basic (Declaration)
Public NotInheritable Class ColumnFailures
Visual C++
public ref class ColumnFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ColumnFailures

See Also

BuiltInFailures..::.ColumnFailures Members


BuiltInFailures.ColumnFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures Members
BuiltInFailures..::.ColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ColumnFailures type exposes the following members.

Properties

Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height

See Also

BuiltInFailures..::.ColumnFailures Class


BuiltInFailures.ColumnFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures Properties
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback

The BuiltInFailures..::.ColumnFailures type exposes the following members.

Properties

Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnAndTargetAreConcrete Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnAndTargetAreConcrete Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
Column and target are both concrete. Geometries have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAreConcrete { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnAndTargetAreConcrete As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAreConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnBaseAboveTopError Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnBaseAboveTopError Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnBaseAboveTopError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnBaseAboveTopFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnBaseAboveTopFailure Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnBaseAboveTopFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnJoinNonhitFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnJoinNonhitFailure Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnJoinNonhitFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnJoinNonhitFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnJoinNonhitFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnTopBelowBaseError Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnTopBelowBaseError Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnTopBelowBaseError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnTopBelowBaseFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnTopBelowBaseFailure Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnTopBelowBaseFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnZeroHeightError Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnZeroHeightError Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnZeroHeightError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


ColumnZeroHeightFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnFailures..::.ColumnZeroHeightFailure Property
BuiltInFailures..::.ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnZeroHeightFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnFailures Class


BuiltInFailures.ColumnInsideWallFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures description ColumnInsideWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ColumnInsideWallFailures
Visual Basic (Declaration)
Public NotInheritable Class ColumnInsideWallFailures
Visual C++
public ref class ColumnInsideWallFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ColumnInsideWallFailures

See Also

BuiltInFailures..::.ColumnInsideWallFailures Members


BuiltInFailures.ColumnInsideWallFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures Members
BuiltInFailures..::.ColumnInsideWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ColumnInsideWallFailures type exposes the following members.

Properties

Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StairJoinGeometryWarning | Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures Properties
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback

The BuiltInFailures..::.ColumnInsideWallFailures type exposes the following members.

Properties

Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StairJoinGeometryWarning | Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


ColumnInsideWall Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.ColumnInsideWall Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
One element is completely inside another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnInsideWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnInsideWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnInsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


CopingWarningExtension Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.CopingWarningExtension Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningExtension { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopingWarningExtension As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopingWarningExtension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


CopingWarningIgnored Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.CopingWarningIgnored Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Cuts on concrete members are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningIgnored { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopingWarningIgnored As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopingWarningIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


CopingWarningMedium Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.CopingWarningMedium Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but only in Medium Detail Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningMedium { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopingWarningMedium As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopingWarningMedium {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


CopingWarningOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.CopingWarningOffset Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopingWarningOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopingWarningOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


StairJoinGeometryWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.StairJoinGeometryWarning Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairJoinGeometryWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairJoinGeometryWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairJoinGeometryWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


StartCutShadowJoin Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.StartCutShadowJoin Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are in a position to allow automatic insert copying.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StartCutShadowJoin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StartCutShadowJoin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StartCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


StopCutShadowJoin Property

[image]

Revit 2011 API
BuiltInFailures..::.ColumnInsideWallFailures..::.StopCutShadowJoin Property
BuiltInFailures..::.ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StopCutShadowJoin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StopCutShadowJoin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StopCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ColumnInsideWallFailures Class


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ConceptualEnergyAnalysisDB.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ConceptualEnergyAnalysisDBFailures
Visual Basic (Declaration)
Public NotInheritable Class ConceptualEnergyAnalysisDBFailures
Visual C++
public ref class ConceptualEnergyAnalysisDBFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures

See Also

BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Members


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Members
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures type exposes the following members.

Properties

Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

See Also

BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Properties
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class See Also Send Feedback

The BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures type exposes the following members.

Properties

Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

See Also

BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class


AimErrEmptyName Property

[image]

Revit 2011 API
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures..::.AimErrEmptyName Property
BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class See Also Send Feedback
MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AimErrEmptyName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AimErrEmptyName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AimErrEmptyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConceptualEnergyAnalysisDBFailures Class


BuiltInFailures.ConnectorFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ConnectorFailures
Visual Basic (Declaration)
Public NotInheritable Class ConnectorFailures
Visual C++
public ref class ConnectorFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ConnectorFailures

See Also

BuiltInFailures..::.ConnectorFailures Members


BuiltInFailures.ConnectorFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures Members
BuiltInFailures..::.ConnectorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ConnectorFailures type exposes the following members.

Properties

Name | Description
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
AlwaysVertical | [Family Name] - 'Always vertical' should be checked:\n [Description]
DisconnectedElements | Elements are disconnected!
DuctPipeOpositDirection | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements can not be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ElementsNotAlignment | [Family Name] - The following Elements don't align at (0,0,0) :\n [Description]
ExistsForSelectedElement | Connections already exits for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size can not be determined from the connector.
InvalidIESParamValue | [Family Name] - The value of IES parameter is invalid:\n [Description]
InvalidPartType | [Family Name] - The part type is invalid:\n [Description]
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoShapeHandle | [Family Name] - RME family should not have shape handle:\n [Description]
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
NotWellConnected | [Element Name] is not "Well Connected".
OverConstrainParams | [Family Name] - Change following parameters will cause over constrain :\n [Description]
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingFailed | Sizing failed.
TransitionDoesNotFitOrConnectorsMismatch | Can not place transition. The transition does not fit or the connectors mis-match.
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
UnLockedDimensions | [Family Name] - Dimensions should be locked or labeled:\n [Description]
WrongConnector | [Family Name] - Connector is wrong:\n [Description]
WrongConnectorDomain | [Family Name] - Connector Domain is wrong:\n [Description]
WrongConnectorLink | [Family Name] - Connector link is wrong:\n [Description]
WrongConnectorMappingParam | [Family Name] - connector mapping parameter is wrong:\n [Description]
WrongConnectorNumber | [Family Name] - The number of connector is wrong:\n [Description]
WrongConnectorParamValue | [Family Name] - connector parameter value is wrong:\n [Description]
WrongFamilyName | [Family Name] - Family name is wrong:\n [Description]
WrongPrimaryConnector | [Family Name] - Primary connector is wrong:\n [Description]
WrongPrimaryConnectorSystemType | [Family Name] - System Type of primary connector is wrong:\n [Description]

See Also

BuiltInFailures..::.ConnectorFailures Class


BuiltInFailures.ConnectorFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures Properties
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback

The BuiltInFailures..::.ConnectorFailures type exposes the following members.

Properties

Name | Description
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
AlwaysVertical | [Family Name] - 'Always vertical' should be checked:\n [Description]
DisconnectedElements | Elements are disconnected!
DuctPipeOpositDirection | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements can not be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ElementsNotAlignment | [Family Name] - The following Elements don't align at (0,0,0) :\n [Description]
ExistsForSelectedElement | Connections already exits for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size can not be determined from the connector.
InvalidIESParamValue | [Family Name] - The value of IES parameter is invalid:\n [Description]
InvalidPartType | [Family Name] - The part type is invalid:\n [Description]
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoShapeHandle | [Family Name] - RME family should not have shape handle:\n [Description]
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
NotWellConnected | [Element Name] is not "Well Connected".
OverConstrainParams | [Family Name] - Change following parameters will cause over constrain :\n [Description]
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingFailed | Sizing failed.
TransitionDoesNotFitOrConnectorsMismatch | Can not place transition. The transition does not fit or the connectors mis-match.
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
UnLockedDimensions | [Family Name] - Dimensions should be locked or labeled:\n [Description]
WrongConnector | [Family Name] - Connector is wrong:\n [Description]
WrongConnectorDomain | [Family Name] - Connector Domain is wrong:\n [Description]
WrongConnectorLink | [Family Name] - Connector link is wrong:\n [Description]
WrongConnectorMappingParam | [Family Name] - connector mapping parameter is wrong:\n [Description]
WrongConnectorNumber | [Family Name] - The number of connector is wrong:\n [Description]
WrongConnectorParamValue | [Family Name] - connector parameter value is wrong:\n [Description]
WrongFamilyName | [Family Name] - Family name is wrong:\n [Description]
WrongPrimaryConnector | [Family Name] - Primary connector is wrong:\n [Description]
WrongPrimaryConnectorSystemType | [Family Name] - System Type of primary connector is wrong:\n [Description]

See Also

BuiltInFailures..::.ConnectorFailures Class


AllElementsRemovedFromCircuitGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.AllElementsRemovedFromCircuitGroup Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[System] is empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllElementsRemovedFromCircuitGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllElementsRemovedFromCircuitGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllElementsRemovedFromCircuitGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


AlwaysVertical Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.AlwaysVertical Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - 'Always vertical' should be checked:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AlwaysVertical { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlwaysVertical As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AlwaysVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


DisconnectedElements Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.DisconnectedElements Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Elements are disconnected!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DisconnectedElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DisconnectedElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DisconnectedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


DuctPipeOpositDirection Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.DuctPipeOpositDirection Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuctPipeOpositDirection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuctPipeOpositDirection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuctPipeOpositDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ElementAssignedToDefaultSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ElementAssignedToDefaultSystem Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementAssignedToDefaultSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementAssignedToDefaultSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementAssignedToDefaultSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ElementsAreDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ElementsAreDisconnected Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsAreDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsAreDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsAreDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ElementsConnectedToParent Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ElementsConnectedToParent Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
You have selected elements that are connected to a parent object in a System. These elements can not be removed from the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsConnectedToParent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsConnectedToParent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsConnectedToParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ElementsNeedToBeDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ElementsNeedToBeDisconnected Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNeedToBeDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsNeedToBeDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsNeedToBeDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ElementsNotAlignment Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ElementsNotAlignment Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - The following Elements don't align at (0,0,0) :\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNotAlignment { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsNotAlignment As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsNotAlignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ExistsForSelectedElement Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ExistsForSelectedElement Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Connections already exits for selected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExistsForSelectedElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExistsForSelectedElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExistsForSelectedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


FittingMustBeOnDuct Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.FittingMustBeOnDuct Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnDuct { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FittingMustBeOnDuct As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


FittingMustBeOnPipe Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.FittingMustBeOnPipe Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnPipe { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FittingMustBeOnPipe As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


InvalidConnectionRef Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.InvalidConnectionRef Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The selected fitting has invalid connections and must be deleted to continue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidConnectionRef { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidConnectionRef As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidConnectionRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


InvalidConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.InvalidConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The connector is invalid, the size can not be determined from the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


InvalidIESParamValue Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.InvalidIESParamValue Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - The value of IES parameter is invalid:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidIESParamValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidIESParamValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidIESParamValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


InvalidPartType Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.InvalidPartType Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - The part type is invalid:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPartType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPartType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPartType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


InvalidPowerFactorValue Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.InvalidPowerFactorValue Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The value for Power Factor must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPowerFactorValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPowerFactorValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPowerFactorValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


LayoutConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.LayoutConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Unassigned System Type] on Connector [Index Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LayoutConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LayoutConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LayoutConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


MismatchNoAvailableConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.MismatchNoAvailableConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNoAvailableConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchNoAvailableConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchNoAvailableConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NetworkValidityError Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NetworkValidityError Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NetworkValidityError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NetworkValidityError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NetworkValidityErrorWasDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NetworkValidityErrorWasDisconnected Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NetworkValidityErrorWasDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NetworkValidityErrorWasDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NetworkValidityErrorWasDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NoLossDefined Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NoLossDefined Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
No Loss Defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLossDefined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLossDefined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLossDefined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NoShapeHandle Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NoShapeHandle Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - RME family should not have shape handle:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoShapeHandle { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoShapeHandle As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoShapeHandle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NotAllowedToModifyGroupElementsError Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NotAllowedToModifyGroupElementsError Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToModifyGroupElementsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NotAllowedToModifyGroupElementsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NotAllowedToModifyGroupElementsWarning Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToModifyGroupElementsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


NotWellConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.NotWellConnected Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Element Name] is not "Well Connected".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotWellConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotWellConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotWellConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


OverConstrainParams Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.OverConstrainParams Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Change following parameters will cause over constrain :\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OverConstrainParams { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OverConstrainParams As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OverConstrainParams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


RbsNetworkValidityError Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.RbsNetworkValidityError Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RbsNetworkValidityError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RbsNetworkValidityError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RbsNetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


RemoveConnectorLinksWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.RemoveConnectorLinksWarn Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinksWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemoveConnectorLinksWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinksWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


RemoveConnectorLinkWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.RemoveConnectorLinkWarn Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
The link between connector [Index] and connector [Index] is removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinkWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemoveConnectorLinkWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinkWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


ShapesNotMatch Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.ShapesNotMatch Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Shapes do not match. A connection could not be made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShapesNotMatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShapesNotMatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShapesNotMatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


SizingFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.SizingFailed Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SizingFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SizingFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


TransitionDoesNotFitOrConnectorsMismatch Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.TransitionDoesNotFitOrConnectorsMismatch Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Can not place transition. The transition does not fit or the connectors mis-match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TransitionDoesNotFitOrConnectorsMismatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TransitionDoesNotFitOrConnectorsMismatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TransitionDoesNotFitOrConnectorsMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


UnconnectedDevice Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.UnconnectedDevice Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Device has an unconnected [Type Name] connector (index = [Index Number]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnconnectedDevice { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnconnectedDevice As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnconnectedDevice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


UndefinedConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.UndefinedConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


UnLockedDimensions Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.UnLockedDimensions Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Dimensions should be locked or labeled:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnLockedDimensions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnLockedDimensions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnLockedDimensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnectorDomain Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnectorDomain Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector Domain is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorDomain { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnectorDomain As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorDomain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnectorLink Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnectorLink Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector link is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnectorLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnectorMappingParam Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnectorMappingParam Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - connector mapping parameter is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorMappingParam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnectorMappingParam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorMappingParam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnectorNumber Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnectorNumber Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - The number of connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorNumber { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnectorNumber As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongConnectorParamValue Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongConnectorParamValue Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - connector parameter value is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorParamValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConnectorParamValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorParamValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongFamilyName Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongFamilyName Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Family name is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFamilyName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongFamilyName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongFamilyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongPrimaryConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongPrimaryConnector Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - Primary connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongPrimaryConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongPrimaryConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongPrimaryConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


WrongPrimaryConnectorSystemType Property

[image]

Revit 2011 API
BuiltInFailures..::.ConnectorFailures..::.WrongPrimaryConnectorSystemType Property
BuiltInFailures..::.ConnectorFailures Class See Also Send Feedback
[Family Name] - System Type of primary connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongPrimaryConnectorSystemType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongPrimaryConnectorSystemType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongPrimaryConnectorSystemType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConnectorFailures Class


BuiltInFailures.ConstraintFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ConstraintFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ConstraintFailures
Visual Basic (Declaration)
Public NotInheritable Class ConstraintFailures
Visual C++
public ref class ConstraintFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ConstraintFailures

See Also

BuiltInFailures..::.ConstraintFailures Members


BuiltInFailures.ConstraintFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConstraintFailures Members
BuiltInFailures..::.ConstraintFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

See Also

BuiltInFailures..::.ConstraintFailures Class


BuiltInFailures.ConstraintFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConstraintFailures Properties
BuiltInFailures..::.ConstraintFailures Class See Also Send Feedback

The BuiltInFailures..::.ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

See Also

BuiltInFailures..::.ConstraintFailures Class


UndeletedConstraints Property

[image]

Revit 2011 API
BuiltInFailures..::.ConstraintFailures..::.UndeletedConstraints Property
BuiltInFailures..::.ConstraintFailures Class See Also Send Feedback
A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndeletedConstraints { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndeletedConstraints As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndeletedConstraints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConstraintFailures Class


BuiltInFailures.ConversionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about conversion of data to a different format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ConversionFailures
Visual Basic (Declaration)
Public NotInheritable Class ConversionFailures
Visual C++
public ref class ConversionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ConversionFailures

See Also

BuiltInFailures..::.ConversionFailures Members


BuiltInFailures.ConversionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures Members
BuiltInFailures..::.ConversionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ConversionFailures type exposes the following members.

Properties

Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'

See Also

BuiltInFailures..::.ConversionFailures Class


BuiltInFailures.ConversionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures Properties
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback

The BuiltInFailures..::.ConversionFailures type exposes the following members.

Properties

Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'

See Also

BuiltInFailures..::.ConversionFailures Class


CannotConvertPercentToDouble Property

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures..::.CannotConvertPercentToDouble Property
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback
Cannot convert concentration percent ' [Percentage Value] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertPercentToDouble { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertPercentToDouble As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertPercentToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConversionFailures Class


CannotConvertTempToDouble Property

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures..::.CannotConvertTempToDouble Property
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback
Cannot convert temperature '[Temperate Value]' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertTempToDouble { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertTempToDouble As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertTempToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConversionFailures Class


CannotConvertToDouble Property

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures..::.CannotConvertToDouble Property
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback
Cannot convert '[Text] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertToDouble { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertToDouble As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConversionFailures Class


UndefinedFluidUnit Property

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures..::.UndefinedFluidUnit Property
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback
Undefined fluid unit: '[Fluid Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidUnit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConversionFailures Class


UndefinedTemperatureUnit Property

[image]

Revit 2011 API
BuiltInFailures..::.ConversionFailures..::.UndefinedTemperatureUnit Property
BuiltInFailures..::.ConversionFailures Class See Also Send Feedback
Undefined temperature unit: '[Temperature Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedTemperatureUnit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedTemperatureUnit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedTemperatureUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ConversionFailures Class


BuiltInFailures.CopyMonitorFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CopyWatch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CopyMonitorFailures
Visual Basic (Declaration)
Public NotInheritable Class CopyMonitorFailures
Visual C++
public ref class CopyMonitorFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CopyMonitorFailures

See Also

BuiltInFailures..::.CopyMonitorFailures Members


BuiltInFailures.CopyMonitorFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures Members
BuiltInFailures..::.CopyMonitorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid can not be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level can not be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::.CopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures Properties
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback

The BuiltInFailures..::.CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid can not be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level can not be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::.CopyMonitorFailures Class


AlreadyCopiedAndStopWatch Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.AlreadyCopiedAndStopWatch Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Element has already been copied. Stop existing monitoring to copy again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyCopiedAndStopWatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlreadyCopiedAndStopWatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AlreadyCopiedAndStopWatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


AlreadyWatched Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.AlreadyWatched Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Elements already monitored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyWatched { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlreadyWatched As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AlreadyWatched {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


CannotCopyCuttingInsert Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.CannotCopyCuttingInsert Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyCuttingInsert { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyCuttingInsert As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyCuttingInsert {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


CopyWatchAlert Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.CopyWatchAlert Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Coordination Monitor alert : [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopyWatchAlert { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyWatchAlert As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopyWatchAlert {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


GridDeletedSameName Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.GridDeletedSameName Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Grid can not be copied because grid with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridDeletedSameName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridDeletedSameName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridDeletedSameName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


LevelDeletedSameName Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyMonitorFailures..::.LevelDeletedSameName Property
BuiltInFailures..::.CopyMonitorFailures Class See Also Send Feedback
Level can not be copied because level with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LevelDeletedSameName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LevelDeletedSameName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LevelDeletedSameName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyMonitorFailures Class


BuiltInFailures.CopyPasteFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CopyPasteFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CopyPasteFailures
Visual Basic (Declaration)
Public NotInheritable Class CopyPasteFailures
Visual C++
public ref class CopyPasteFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CopyPasteFailures

See Also

BuiltInFailures..::.CopyPasteFailures Members


BuiltInFailures.CopyPasteFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures Members
BuiltInFailures..::.CopyPasteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopy | Cannot copy selection.
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDependentViewWarn | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyError | Cannot copy selection.
CannotCopyFaceHostedMonitoringElements | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFaceHostedMonitoringElementsWarn | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotCopyHostedLoadWarn | Can't copy Load based on the Host Element.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueViewport | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueViewportWarn | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyProfile | Can't copy Profile.
CannotCopyProfileWarn | Can't copy Profile.
CannotCopyReferencePlane | Can't copy reference plane.
CannotCopyReferencePlaneWarn | Can't copy reference plane.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWarn | Cannot copy selection.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteInViewError | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source can not be copied!
CopyImposterLightWarn | Light source can not be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
PasteInvisibleInViewWarn | The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)

See Also

BuiltInFailures..::.CopyPasteFailures Class


BuiltInFailures.CopyPasteFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures Properties
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback

The BuiltInFailures..::.CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopy | Cannot copy selection.
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDependentViewWarn | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyError | Cannot copy selection.
CannotCopyFaceHostedMonitoringElements | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFaceHostedMonitoringElementsWarn | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotCopyHostedLoadWarn | Can't copy Load based on the Host Element.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueViewport | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueViewportWarn | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyProfile | Can't copy Profile.
CannotCopyProfileWarn | Can't copy Profile.
CannotCopyReferencePlane | Can't copy reference plane.
CannotCopyReferencePlaneWarn | Can't copy reference plane.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWarn | Cannot copy selection.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteInViewError | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source can not be copied!
CopyImposterLightWarn | Light source can not be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
PasteInvisibleInViewWarn | The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopy Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopy Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopy { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopy As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopy {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyAttachedType Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyAttachedType Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyAttachedType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyAttachedTypeWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyAttachedTypeWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedTypeWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyAttachedTypeWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyBetweenFamilyAndProjectCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyBetweenFamilyAndProjectCorruption Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyBetweenFamilyAndProjectError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyBetweenFamilyAndProjectError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyCurtainWallGridLines Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyCurtainWallGridLines Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Curtain wall grid lines currently cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyCurtainWallGridLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyCurtainWallGridLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyCurtainWallGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyDependentView Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyDependentView Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDependentView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyDependentView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDependentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyDependentViewWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyDependentViewWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDependentViewWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyDependentViewWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDependentViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyDetails Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyDetails Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy some or all of the detailing with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDetails { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyDetails As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDetails {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyDuplicates Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyDuplicates Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste duplicate types. Only non duplicate types will be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDuplicates { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyDuplicates As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyElevationArrow Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyElevationArrow Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyElevationArrow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyElevationArrowWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyElevationArrowWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrowWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyElevationArrowWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrowWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyFaceHostedMonitoringElements Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyFaceHostedMonitoringElements Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFaceHostedMonitoringElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyFaceHostedMonitoringElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFaceHostedMonitoringElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyFaceHostedMonitoringElementsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyFaceHostedMonitoringElementsWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFaceHostedMonitoringElementsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyFaceHostedMonitoringElementsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFaceHostedMonitoringElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyFamilyName Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyFamilyName Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFamilyName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyFamilyName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFamilyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyFromProjectAndLink Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyFromProjectAndLink Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFromProjectAndLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyFromProjectAndLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromProjectAndLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyGridLines Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyGridLines Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGridLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyGridLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyGridLinesWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyGridLinesWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGridLinesWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyGridLinesWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGridLinesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyHostedLoad Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyHostedLoad Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyHostedLoad { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyHostedLoad As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyHostedLoadWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyHostedLoadWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyHostedLoadWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyHostedLoadWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyHostedLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyImportInstancesAcrossProjects Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyImportInstancesAcrossProjects Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyImportInstancesAcrossProjects { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyImportInstancesAcrossProjects As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyImportInstancesAcrossProjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyIncompleteElement Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyIncompleteElement Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyIncompleteElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyIncompleteElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyIncompleteElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyIncompleteElementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyIncompleteElementWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyIncompleteElementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyIncompleteElementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyIncompleteElementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyJoinedGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyJoinedGeometry Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyJoinedGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyJoinedGeometryWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyJoinedGeometryWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometryWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyJoinedGeometryWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyLocked Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyLocked Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLocked { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyLocked As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyLockedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyLockedWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLockedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyLockedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLockedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMassing Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMassingWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMassingWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMassingWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMassingWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMullions Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMullions Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMullions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMullionsError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMullionsError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMullionsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMullionsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMullionsWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMullionsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMultipleSketchParents Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMultipleSketchParents Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMultipleSketchParents { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMultipleSketchParents As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMultipleSketchParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMustBeUnique Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMustBeUnique Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUnique { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMustBeUnique As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMustBeUniqueViewport Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMustBeUniqueViewport Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Multiple instances of the same view in sheets not supported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueViewport { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMustBeUniqueViewport As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueViewport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMustBeUniqueViewportWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMustBeUniqueViewportWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Multiple instances of the same view in sheets not supported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueViewportWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMustBeUniqueViewportWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueViewportWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyMustBeUniqueWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyMustBeUniqueWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyMustBeUniqueWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyNestedLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyNestedLinks Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
To copy a nested link, use Copy to Clipboard or Move Copy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNestedLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyNestedLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNestedLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyNoAttachedParent Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyNoAttachedParent Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can’t be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyNoAttachedParent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyNoAttachedParentWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyNoAttachedParentWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can’t be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParentWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyNoAttachedParentWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyNoParents Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyNoParents Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Copy to Clipboard because of relationships between Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoParents { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyNoParents As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyNoReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyNoReferences Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements can't be copied because they will lose their References.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyNoReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyProfile Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyProfileWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyProfileWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyProfileWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyProfileWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyProfileWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyReferencePlane Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyReferencePlane Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyReferencePlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyReferencePlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyReferencePlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyReferencePlaneWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyReferencePlaneWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyReferencePlaneWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyReferencePlaneWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyReferencePlaneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyRevolveAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyRevolveAxis Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyRevolveAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyRevolveAxisWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyRevolveAxisWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxisWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyRevolveAxisWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxisWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopySelectedPick Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopySelectedPick Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The element being dragged can't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySelectedPick { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopySelectedPick As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopySelectedPick {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopySketchGrid Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopySketchGrid Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySketchGrid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopySketchGrid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopySketchGridWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopySketchGridWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySketchGridWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopySketchGridWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGridWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopySunAndShadowSettings Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopySunAndShadowSettings Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySunAndShadowSettings { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopySunAndShadowSettings As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopySunAndShadowSettingsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopySunAndShadowSettingsWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySunAndShadowSettingsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopySunAndShadowSettingsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettingsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyWallPanels Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyWallPanels Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanels { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyWallPanels As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyWallPanelsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyWallPanelsWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanelsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyWallPanelsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanelsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyZone Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyZone Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyZone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyZone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotCopyZoneWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotCopyZoneWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyZoneWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyZoneWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyZoneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicate Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicate Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicateDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicateDesignOption Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't duplicate Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicateInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicateInOption Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicateInOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicateInOptionWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateInOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicateType Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicateType Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot Duplicate Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotDuplicateWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotDuplicateWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotFinalizeClusterInconsistency Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotFinalizeClusterInconsistency Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't finalize because dependent element failed to finalize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinalizeClusterInconsistency { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFinalizeClusterInconsistency As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeClusterInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotFinalizeOrphanSerf Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotFinalizeOrphanSerf Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't finalize Group member without finalizing the entire Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinalizeOrphanSerf { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFinalizeOrphanSerf As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeOrphanSerf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteAlignedAny Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteAlignedAny Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedAny { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteAlignedAny As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedAny {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteAlignedCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteAlignedCorruption Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteAlignedCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteAlignedError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteAlignedError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Paste Align these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteAlignedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteAlignedSomeLevels Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteAlignedSomeLevels Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned to some views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedSomeLevels { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteAlignedSomeLevels As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedSomeLevels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteCircularLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteCircularLinks Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteCircularLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteCircularLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCircularLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteCurtainGridLine Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteCurtainGridLine Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste Curtain Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteCurtainGridLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteCurtainGridLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCurtainGridLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteDifferentViewSpecificElements Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteDifferentViewSpecificElements Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteDifferentViewSpecificElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteDifferentViewSpecificElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteDifferentViewSpecificElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteInSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteInSketch Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste elements into sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteInSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteInView Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteInView Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteInViewError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteInViewError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInViewError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteInViewError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteModelPlusViewSpecificElementsIntoView Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteModelPlusViewSpecificElementsIntoView Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific model plus into view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteModelPlusViewSpecificElementsIntoView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteModelPlusViewSpecificElementsIntoView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteModelPlusViewSpecificElementsIntoView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteNoLevelAbove Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteNoLevelAbove Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste these elements at this height because there is no Level above to Reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoLevelAbove { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteNoLevelAbove As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoLevelAbove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteNoLevelBelow Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteNoLevelBelow Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste these elements at this height because there is no Level below to reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoLevelBelow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteNoLevelBelow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoLevelBelow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteNoWorkplane Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteNoWorkplane Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoWorkplane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteNoWorkplane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteToSheet Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteToSheet Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Elements copied to Sheets can only be copied from other Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteToSheet { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteToSheet As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteToSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CannotPasteViewSpecElemsFromDiffViews Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CannotPasteViewSpecElemsFromDiffViews Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteViewSpecElemsFromDiffViews { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteViewSpecElemsFromDiffViews As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteViewSpecElemsFromDiffViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyBetweenModelAndAnnotFam Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyBetweenModelAndAnnotFam Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy element(s) between Model and Annotation families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyBetweenModelAndAnnotFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyBetweenModelAndAnnotFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyBetweenModelAndAnnotFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyElemsToInplaceFam Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyElemsToInplaceFam Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy element(s) to In Place family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyElemsToInplaceFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyElemsToInplaceFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyElemsToInplaceFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyFrom2dTo3dFam Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyFrom2dTo3dFam Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy 2D element(s) into a 3D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFrom2dTo3dFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyFrom2dTo3dFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom2dTo3dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyFrom3dTo2dFam Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyFrom3dTo2dFam Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy 3D element(s) into a 2D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFrom3dTo2dFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyFrom3dTo2dFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom3dTo2dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyFromDetailToProfileFam Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyFromDetailToProfileFam Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy Detail element(s) into a Profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFromDetailToProfileFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyFromDetailToProfileFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyFromDetailToProfileFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CantCopyLevelsOrRefPlanesToNonMassFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CantCopyLevelsOrRefPlanesToNonMassFamily Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't copy levels or reference planes to families that are not Mass families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyLevelsOrRefPlanesToNonMassFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopyLevelsOrRefPlanesToNonMassFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopyLevelsOrRefPlanesToNonMassFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CopingColumnBeamFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CopingColumnBeamFailure Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopingColumnBeamFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopingColumnBeamFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopingColumnBeamFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CopyImposterContentError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CopyImposterContentError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterContentError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyImposterContentError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CopyImposterContentWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CopyImposterContentWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterContentWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyImposterContentWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CopyImposterLightError Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CopyImposterLightError Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Light source can not be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterLightError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyImposterLightError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopyImposterLightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


CopyImposterLightWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.CopyImposterLightWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Light source can not be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterLightWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyImposterLightWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CopyImposterLightWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


ElementRenamedOnPaste Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.ElementRenamedOnPaste Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementRenamedOnPaste { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementRenamedOnPaste As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementRenamedOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


FinalizedElementsWillBeDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.FinalizedElementsWillBeDeleted Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FinalizedElementsWillBeDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


FinalizedElementsWillBeDeletedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.FinalizedElementsWillBeDeletedWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeDeletedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FinalizedElementsWillBeDeletedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeletedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


FinalizedElementsWillBeModified Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.FinalizedElementsWillBeModified Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeModified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FinalizedElementsWillBeModified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


FinalizedElementsWillBeModifiedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.FinalizedElementsWillBeModifiedWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeModifiedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FinalizedElementsWillBeModifiedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModifiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


LostReference Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.LostReference Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LostReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LostReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LostReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


NoSketchPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.NoSketchPlane Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Can't paste because no Work Plane is defined in the View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSketchPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSketchPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


PasteInvisibleInView Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.PasteInvisibleInView Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
Selection is invisible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PasteInvisibleInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PasteInvisibleInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PasteInvisibleInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


PasteInvisibleInViewWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CopyPasteFailures..::.PasteInvisibleInViewWarn Property
BuiltInFailures..::.CopyPasteFailures Class See Also Send Feedback
The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PasteInvisibleInViewWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PasteInvisibleInViewWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PasteInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CopyPasteFailures Class


BuiltInFailures.CreationFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CreationFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CreationFailures
Visual Basic (Declaration)
Public NotInheritable Class CreationFailures
Visual C++
public ref class CreationFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CreationFailures

See Also

BuiltInFailures..::.CreationFailures Members


BuiltInFailures.CreationFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CreationFailures Members
BuiltInFailures..::.CreationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CreationFailures type exposes the following members.

Properties

Name | Description
CannotCreateCornerFinish | Could not create Corner Finish.
CannotCreateCornerFinishError | Could not create Corner Finish.
CannotCreateCornerFinishWarn | Could not create Corner Finish.
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateHostFinish | Can't create Host Finish.
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Can not create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeWall | Can't make Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

See Also

BuiltInFailures..::.CreationFailures Class


BuiltInFailures.CreationFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CreationFailures Properties
BuiltInFailures..::.CreationFailures Class See Also Send Feedback

The BuiltInFailures..::.CreationFailures type exposes the following members.

Properties

Name | Description
CannotCreateCornerFinish | Could not create Corner Finish.
CannotCreateCornerFinishError | Could not create Corner Finish.
CannotCreateCornerFinishWarn | Could not create Corner Finish.
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateHostFinish | Can't create Host Finish.
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Can not create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeWall | Can't make Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCornerFinish Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCornerFinish Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinish { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornerFinish As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinish {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCornerFinishError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCornerFinishError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinishError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornerFinishError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinishError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCornerFinishWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCornerFinishWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinishWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornerFinishWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinishWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCornice Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCornice Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornice { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornice As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCorniceError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCorniceError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCorniceError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCorniceIntegral Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCorniceIntegral Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegral { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCorniceIntegral As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCorniceIntegralError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCorniceIntegralError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCorniceIntegralError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCorniceIntegralWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCorniceIntegralWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCorniceIntegralWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCorniceWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCorniceWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCorniceWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCurtainGrid Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCurtainGrid Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainGrid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCurtainGrid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCutout Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCutout Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutout { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCutout As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutout {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCutoutError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCutoutError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutoutError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCutoutError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutoutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateCutoutWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateCutoutWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutoutWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCutoutWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutoutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateElementInFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateElementInFamily Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create element in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateElementInFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateElementInFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateElementInView Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateElementInView Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create this kind of element in this view in the current mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateElementInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateElementInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateExplicitCrease Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateExplicitCrease Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Cannot create a new split line based on the picked support.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateExplicitCrease { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateExplicitCrease As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateExplicitCrease {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateFascia Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateFascia Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFascia { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateFascia As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFascia {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateFasciaError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateFasciaError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateFasciaError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateFasciaWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateFasciaWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateFasciaWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateGutter Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateGutter Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGutter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateGutterError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateGutterError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutterError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGutterError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutterError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateGutterWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateGutterWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutterWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGutterWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutterWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateHostFinish Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateHostFinish Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Host Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateHostFinish { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateHostFinish As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateHostFinish {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateMullion Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateMullion Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMullion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateMullionError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateMullionError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMullionError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateMullionReference Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateMullionReference Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMullionReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateMullionReferenceNoGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateMullionReferenceNoGeometry Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReferenceNoGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMullionReferenceNoGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReferenceNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateNewDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateNewDesignOption Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Cannot create a new empty design option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateNewDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateNewDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNewDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateOldCornerMullion Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateOldCornerMullion Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOldCornerMullion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOldCornerMullion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOldCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateOpening Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateOpening Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can not create opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpening { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOpening As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateOpeningCutOut Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateOpeningCutOut Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Opening cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpeningCutOut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOpeningCutOut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpeningCutOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateOpeningRectangularArcWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateOpeningRectangularArcWall Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Creation of a Rectangular Arc Wall Opening failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpeningRectangularArcWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOpeningRectangularArcWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpeningRectangularArcWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateReveal Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateReveal Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateReveal { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateReveal As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateReveal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateRevealError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateRevealError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRevealError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateRevealIntegral Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateRevealIntegral Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegral { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRevealIntegral As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateRevealIntegralError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateRevealIntegralError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRevealIntegralError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateRevealIntegralWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateRevealIntegralWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRevealIntegralWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateRevealWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateRevealWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRevealWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateSlabEdge Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateSlabEdge Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSlabEdge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateSlabEdgeError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateSlabEdgeError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSlabEdgeError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateSlabEdgeWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateSlabEdgeWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSlabEdgeWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateSystemPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateSystemPanel Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSystemPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSystemPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSystemPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotCreateThis Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotCreateThis Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't create [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateThis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateThis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateThis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawProfileRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawProfileRoof Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawRoof Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawRoofError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawRoofError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoofError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawRoofError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawRoofWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawRoofWall Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoofWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawRoofWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawWalls Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawWalls Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawWalls { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawWalls As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotDrawWallsError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotDrawWallsError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawWallsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawWallsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWallsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeRoofFromVerticalFace Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeRoofFromVerticalFace Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeRoofFromVerticalFaceError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeRoofFromVerticalFaceError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFaceError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFaceError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeSurface Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeSurface Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeSurfaceError Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeSurfaceError Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeSurfaceError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeSurfaceWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeSurfaceWarn Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeSurfaceWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


CannotMakeWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.CannotMakeWall Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


SwitchFromLegendBeforeCreateSimilar Property

[image]

Revit 2011 API
BuiltInFailures..::.CreationFailures..::.SwitchFromLegendBeforeCreateSimilar Property
BuiltInFailures..::.CreationFailures Class See Also Send Feedback
To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SwitchFromLegendBeforeCreateSimilar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SwitchFromLegendBeforeCreateSimilar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SwitchFromLegendBeforeCreateSimilar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CreationFailures Class


BuiltInFailures.CurtainGridFamilyFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainGrid Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CurtainGridFamilyFailures
Visual Basic (Declaration)
Public NotInheritable Class CurtainGridFamilyFailures
Visual C++
public ref class CurtainGridFamilyFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CurtainGridFamilyFailures

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Members


BuiltInFailures.CurtainGridFamilyFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures Members
BuiltInFailures..::.CurtainGridFamilyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
EnterValueBetween | Please enter a value between [Value] and [Value].
FailedMarkingAtomsAfterExecute | Unable to regenerate all necessary elements.
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures Properties
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback

The BuiltInFailures..::.CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
EnterValueBetween | Please enter a value between [Value] and [Value].
FailedMarkingAtomsAfterExecute | Unable to regenerate all necessary elements.
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


AllMullionsAreTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.AllMullionsAreTooShort Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllMullionsAreTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllMullionsAreTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotCreateCornerMullionDueAngle Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotCreateCornerMullionDueAngle Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerMullionDueAngle { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornerMullionDueAngle As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerMullionDueAngle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotCreateCurtainPanelCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotCreateCurtainPanelCorruption Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel. A Panel or a Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCurtainPanelCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotCreateCurtainPanelError Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotCreateCurtainPanelError Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCurtainPanelError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotCreateCurtainPanelInOpeningCorruption Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotCreateCurtainPanelInOpeningWarning Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotPlaceSystemMullionFamilyOnCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotPlaceSystemMullionFamilyOnCurtainWall Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Mullion Family on this Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemMullionFamilyOnCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceSystemMullionFamilyOnCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemMullionFamilyOnCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CannotPlaceSystemPanelsInOldArcedCurtainWalls Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CannotPlaceSystemPanelsInOldArcedCurtainWalls Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemPanelsInOldArcedCurtainWalls { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceSystemPanelsInOldArcedCurtainWalls As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemPanelsInOldArcedCurtainWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullion overlaps Mullion placed on neighboring Curtain region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CornerMullionsNeighborsMustBeTangent Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CornerMullionsNeighborsMustBeTangent Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CornerMullionsNeighborsMustBeTangent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CornerMullionsNeighborsMustBeTangent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CornerMullionsNeighborsMustBeTangent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CurtainPanelNotBelongsToElement Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CurtainPanelNotBelongsToElement Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainPanelNotBelongsToElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainPanelNotBelongsToElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelNotBelongsToElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CurtainPanelsParamDefinedTypeDefinedCirculary Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CurtainPanelsParamDefinedTypeDefinedCirculary Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainPanelsParamDefinedTypeDefinedCirculary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainPanelsParamDefinedTypeDefinedCirculary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelsParamDefinedTypeDefinedCirculary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


CurtainSystemCouldnotReacquireFaces Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.CurtainSystemCouldnotReacquireFaces Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Curtain System could not reacquire [Number] faces out of [Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainSystemCouldnotReacquireFaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainSystemCouldnotReacquireFaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainSystemCouldnotReacquireFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


EnterValueBetween Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.EnterValueBetween Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueBetween { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


FailedMarkingAtomsAfterExecute Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.FailedMarkingAtomsAfterExecute Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Unable to regenerate all necessary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedMarkingAtomsAfterExecute { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedMarkingAtomsAfterExecute As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedMarkingAtomsAfterExecute {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


InvalidCurtainPanelInModel Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.InvalidCurtainPanelInModel Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCurtainPanelInModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidCurtainPanelInModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidCurtainPanelInModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


MullionProfileContainsMoreThanOneOrOpenLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.MullionProfileContainsMoreThanOneOrOpenLoop Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MullionProfileContainsMoreThanOneOrOpenLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MullionProfileContainsMoreThanOneOrOpenLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MullionProfileContainsMoreThanOneOrOpenLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


NonSystemPanelFamiliesCannotBeUsed Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.NonSystemPanelFamiliesCannotBeUsed Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonSystemPanelFamiliesCannotBeUsed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonSystemPanelFamiliesCannotBeUsed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonSystemPanelFamiliesCannotBeUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


PanelsSlightlyMalformedCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.PanelsSlightlyMalformedCorruption Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelsSlightlyMalformedCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelsSlightlyMalformedCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


PanelsSlightlyMalformedWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.PanelsSlightlyMalformedWarning Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelsSlightlyMalformedWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelsSlightlyMalformedWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


SomeMullionsAreTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainGridFamilyFailures..::.SomeMullionsAreTooShort Property
BuiltInFailures..::.CurtainGridFamilyFailures Class See Also Send Feedback
Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeMullionsAreTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeMullionsAreTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainGridFamilyFailures Class


BuiltInFailures.CurtainWallFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainWall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CurtainWallFailures
Visual Basic (Declaration)
Public NotInheritable Class CurtainWallFailures
Visual C++
public ref class CurtainWallFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CurtainWallFailures

See Also

BuiltInFailures..::.CurtainWallFailures Members


BuiltInFailures.CurtainWallFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures Members
BuiltInFailures..::.CurtainWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push"Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::.CurtainWallFailures Class


BuiltInFailures.CurtainWallFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures Properties
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback

The BuiltInFailures..::.CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push"Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::.CurtainWallFailures Class


AdjustEndCurtainWallParameterNoCorners Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.AdjustEndCurtainWallParameterNoCorners Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Can't put Corner Mullion at end joined to non-Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AdjustEndCurtainWallParameterNoCorners { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AdjustEndCurtainWallParameterNoCorners As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AdjustEndCurtainWallParameterNoCorners {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


AllGridSegmentsRemoved Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.AllGridSegmentsRemoved Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain grid lines must have at least one segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllGridSegmentsRemoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllGridSegmentsRemoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllGridSegmentsRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotApplyGridSpecification Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotApplyGridSpecification Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
It is not possible to apply the host family's grid specification to this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotApplyGridSpecification { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotApplyGridSpecification As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotApplyGridSpecification {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotDivideCurtainGrid Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotDivideCurtainGrid Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Can't divide Curtain Grid by Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDivideCurtainGrid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDivideCurtainGrid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDivideCurtainGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotGroupCurtainGridHost Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotGroupCurtainGridHost Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain grid based elements cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGroupCurtainGridHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGroupCurtainGridHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGroupCurtainGridHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotHaveIndependentOverlappingGrids Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotHaveIndependentOverlappingGrids Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Overlapping independent type associated gridlines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveIndependentOverlappingGrids { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotHaveIndependentOverlappingGrids As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotHaveIndependentOverlappingGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotPlaceSplitMullions Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotPlaceSplitMullions Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Could not determine how to place the highlighted mullions after the wall was split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSplitMullions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceSplitMullions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSplitMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotSplitOldMullions Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotSplitOldMullions Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitOldMullions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSplitOldMullions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSplitOldMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotSwitchToCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotSwitchToCurtainWall Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Can't switch type to Curtain Wall after Edit Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSwitchToCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSwitchToCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSwitchToCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CannotUseCornerMullion Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CannotUseCornerMullion Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUseCornerMullion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotUseCornerMullion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotUseCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CurtainGridFaceCannotBeReparamForGridRotation Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CurtainGridFaceCannotBeReparamForGridRotation Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain grids cannot be rotated exactly as requested. Push"Adjust Grids" to get the nearest valid rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainGridFaceCannotBeReparamForGridRotation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainGridFaceCannotBeReparamForGridRotation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainGridFaceCannotBeReparamForGridRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CurtainGridOffHost Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CurtainGridOffHost Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain grid has left its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainGridOffHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainGridOffHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainGridOffHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


CurtainSystemHostInvisible Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.CurtainSystemHostInvisible Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Element defining the Curtain System is invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainSystemHostInvisible { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurtainSystemHostInvisible As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurtainSystemHostInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


DanglingCurtainWallCorner Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.DanglingCurtainWallCorner Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DanglingCurtainWallCorner { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DanglingCurtainWallCorner As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DanglingCurtainWallCorner {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


DeletingCurtainSystemFaceGridLines Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.DeletingCurtainSystemFaceGridLines Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Deleting Grid Lines residing on faces that no longer are part of a Curtain System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingCurtainSystemFaceGridLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletingCurtainSystemFaceGridLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletingCurtainSystemFaceGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


DependentGridlineMayBeDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.DependentGridlineMayBeDeleted Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DependentGridlineMayBeDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DependentGridlineMayBeDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DependentGridlineMayBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


ExceedMaxDrivenGridlines Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.ExceedMaxDrivenGridlines Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExceedMaxDrivenGridlines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExceedMaxDrivenGridlines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExceedMaxDrivenGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


ExessiveBeltDistance Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.ExessiveBeltDistance Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExessiveBeltDistance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExessiveBeltDistance As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExessiveBeltDistance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridlinesOutOfBounds Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridlinesOutOfBounds Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBounds { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlinesOutOfBounds As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBounds {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridlinesOutOfBoundsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridlinesOutOfBoundsWarn Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBoundsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlinesOutOfBoundsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBoundsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridlinesOutsideWillBeRedependent Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridlinesOutsideWillBeRedependent Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutsideWillBeRedependent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlinesOutsideWillBeRedependent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutsideWillBeRedependent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridlinesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridlinesOverlap Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlinesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridlinesWerePushed Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridlinesWerePushed Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Panels and mullions created by a curtain grid were created with slight inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesWerePushed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlinesWerePushed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlinesWerePushed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridOutOfOrder Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridOutOfOrder Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutOfOrder { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridOutOfOrder As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridOutOfOrderError Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridOutOfOrderError Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutOfOrderError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridOutOfOrderError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrderError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


GridOutsideWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.GridOutsideWall Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutsideWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridOutsideWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridOutsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


InvalidSkipSegments Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.InvalidSkipSegments Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSkipSegments { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSkipSegments As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSkipSegments {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


MullionLostRefReorder Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.MullionLostRefReorder Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MullionLostRefReorder { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MullionLostRefReorder As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MullionLostRefReorder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


MullionsWillBeDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.MullionsWillBeDeleted Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
The Mullions between the Panels being joined will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MullionsWillBeDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MullionsWillBeDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MullionsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


MultipleDominatingMullions Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.MultipleDominatingMullions Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleDominatingMullions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultipleDominatingMullions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultipleDominatingMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


MultipleIdsInCurtainSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.MultipleIdsInCurtainSystem Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
A Curtain System cannot be based on faces from multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleIdsInCurtainSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultipleIdsInCurtainSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultipleIdsInCurtainSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


MustReplacePanels Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.MustReplacePanels Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Missing Curtain Panels will be replaced with System Panels to complete command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MustReplacePanels { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MustReplacePanels As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MustReplacePanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


NegativeBeltDistance Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.NegativeBeltDistance Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Measurement Line Offset cannot be negative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NegativeBeltDistance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NegativeBeltDistance As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NegativeBeltDistance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


NonSupportedCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.NonSupportedCurtainWall Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonSupportedCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonSupportedCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonSupportedCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


NoPanelsLoaded Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.NoPanelsLoaded Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
No Curtain Panel Families loaded. Can't make arced Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoPanelsLoaded { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoPanelsLoaded As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoPanelsLoaded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


RequestOrphanMullionDeletion Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.RequestOrphanMullionDeletion Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Due to the changes in parameters of their hosts some mullions became non-type driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RequestOrphanMullionDeletion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RequestOrphanMullionDeletion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RequestOrphanMullionDeletion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


RuledCurtainElementLostCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.RuledCurtainElementLostCurves Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RuledCurtainElementLostCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RuledCurtainElementLostCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RuledCurtainElementLostCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


TypePanelsFronNonRectCellsUnlocked Property

[image]

Revit 2011 API
BuiltInFailures..::.CurtainWallFailures..::.TypePanelsFronNonRectCellsUnlocked Property
BuiltInFailures..::.CurtainWallFailures Class See Also Send Feedback
Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TypePanelsFronNonRectCellsUnlocked { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TypePanelsFronNonRectCellsUnlocked As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TypePanelsFronNonRectCellsUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurtainWallFailures Class


BuiltInFailures.CurveByPointFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CurveByPointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Curve By Point Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CurveByPointFailures
Visual Basic (Declaration)
Public NotInheritable Class CurveByPointFailures
Visual C++
public ref class CurveByPointFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CurveByPointFailures

See Also

BuiltInFailures..::.CurveByPointFailures Members


BuiltInFailures.CurveByPointFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurveByPointFailures Members
BuiltInFailures..::.CurveByPointFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CurveByPointFailures type exposes the following members.

Properties

Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

See Also

BuiltInFailures..::.CurveByPointFailures Class


BuiltInFailures.CurveByPointFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurveByPointFailures Properties
BuiltInFailures..::.CurveByPointFailures Class See Also Send Feedback

The BuiltInFailures..::.CurveByPointFailures type exposes the following members.

Properties

Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

See Also

BuiltInFailures..::.CurveByPointFailures Class


UnableToGenerateCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveByPointFailures..::.UnableToGenerateCurve Property
BuiltInFailures..::.CurveByPointFailures Class See Also Send Feedback
Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToGenerateCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToGenerateCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToGenerateCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveByPointFailures Class


BuiltInFailures.CurveFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Curves and Curve-Driven Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CurveFailures
Visual Basic (Declaration)
Public NotInheritable Class CurveFailures
Visual C++
public ref class CurveFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CurveFailures

See Also

BuiltInFailures..::.CurveFailures Members


BuiltInFailures.CurveFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurveFailures Members
BuiltInFailures..::.CurveFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.

See Also

BuiltInFailures..::.CurveFailures Class


BuiltInFailures.CurveFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CurveFailures Properties
BuiltInFailures..::.CurveFailures Class See Also Send Feedback

The BuiltInFailures..::.CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.

See Also

BuiltInFailures..::.CurveFailures Class


CannotFindAreaScheme Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.CannotFindAreaScheme Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Can't find new Area Scheme for Area Boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindAreaScheme { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFindAreaScheme As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFindAreaScheme {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


CurveNotEditable Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.CurveNotEditable Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveNotEditable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveNotEditable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


CurveNotEditableWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.CurveNotEditableWarn Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveNotEditableWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveNotEditableWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditableWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


InvalidCurveForElement Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.InvalidCurveForElement Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCurveForElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidCurveForElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidCurveForElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


LineTooShortError Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.LineTooShortError Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LineTooShortError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LineTooShortError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LineTooShortError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


LineTooShortWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.LineTooShortWarning Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LineTooShortWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LineTooShortWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LineTooShortWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


PeriodicCurveBadParams Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.PeriodicCurveBadParams Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PeriodicCurveBadParams { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PeriodicCurveBadParams As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PeriodicCurveBadParams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


SelfIntersectingSpline Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.SelfIntersectingSpline Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Self intersecting splines are not allowed in sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SelfIntersectingSpline { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SelfIntersectingSpline As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SelfIntersectingSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


TooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.CurveFailures..::.TooShort Property
BuiltInFailures..::.CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CurveFailures Class


BuiltInFailures.CutFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CutFailures
Visual Basic (Declaration)
Public NotInheritable Class CutFailures
Visual C++
public ref class CutFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CutFailures

See Also

BuiltInFailures..::.CutFailures Members


BuiltInFailures.CutFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CutFailures Members
BuiltInFailures..::.CutFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CutFailures type exposes the following members.

Properties

Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutHostFinishOut | Cannot cut Host Finish out.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.

See Also

BuiltInFailures..::.CutFailures Class


BuiltInFailures.CutFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CutFailures Properties
BuiltInFailures..::.CutFailures Class See Also Send Feedback

The BuiltInFailures..::.CutFailures type exposes the following members.

Properties

Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutHostFinishOut | Cannot cut Host Finish out.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.

See Also

BuiltInFailures..::.CutFailures Class


CannotCutGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutGeometry Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutHostFinishOut Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutHostFinishOut Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Cannot cut Host Finish out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutHostFinishOut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutHostFinishOut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutHostFinishOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOut Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOut Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOutError Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOutError Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOutError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOutGen Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOutGen Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGen { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOutGen As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOutGenError Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOutGenError Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOutGenError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOutGenWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOutGenWarn Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOutGenWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutInstanceOutWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutInstanceOutWarn Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutInstanceOutWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutJoinedElement Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutJoinedElement Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutJoinedElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutJoinedElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutRoof Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CannotCutRoofError Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CannotCutRoofError Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRoofError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutRoofError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CutExactlyHalf Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CutExactlyHalf Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut in half. Move plane towards either end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CutExactlyHalf { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CutExactlyHalf As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CutExactlyHalf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CutoutNotCuttingAnything Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CutoutNotCuttingAnything Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnything { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CutoutNotCuttingAnything As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


CutoutNotCuttingAnythingDeleteOpening Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.CutoutNotCuttingAnythingDeleteOpening Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnythingDeleteOpening { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CutoutNotCuttingAnythingDeleteOpening As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnythingDeleteOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


DormerCutProblem Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.DormerCutProblem Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DormerCutProblem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DormerCutProblem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


DormerCutProblemWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.DormerCutProblemWarn Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DormerCutProblemWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DormerCutProblemWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblemWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


HostCutoutForInsertionFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.HostCutoutForInsertionFailure Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Can't cut host for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostCutoutForInsertionFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostCutoutForInsertionFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


InstanceNotCuttingAnything Property

[image]

Revit 2011 API
BuiltInFailures..::.CutFailures..::.InstanceNotCuttingAnything Property
BuiltInFailures..::.CutFailures Class See Also Send Feedback
Instance(s) of [Symbol] not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InstanceNotCuttingAnything { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InstanceNotCuttingAnything As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InstanceNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutFailures Class


BuiltInFailures.CutterFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CutterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CutterFailures
Visual Basic (Declaration)
Public NotInheritable Class CutterFailures
Visual C++
public ref class CutterFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CutterFailures

See Also

BuiltInFailures..::.CutterFailures Members


BuiltInFailures.CutterFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CutterFailures Members
BuiltInFailures..::.CutterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::.CutterFailures Class


BuiltInFailures.CutterFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CutterFailures Properties
BuiltInFailures..::.CutterFailures Class See Also Send Feedback

The BuiltInFailures..::.CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::.CutterFailures Class


MakeCutterForPlanRegionsGStepFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.CutterFailures..::.MakeCutterForPlanRegionsGStepFailed Property
BuiltInFailures..::.CutterFailures Class See Also Send Feedback
Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MakeCutterForPlanRegionsGStepFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MakeCutterForPlanRegionsGStepFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForPlanRegionsGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutterFailures Class


MakeCutterForSectionGStepFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.CutterFailures..::.MakeCutterForSectionGStepFailed Property
BuiltInFailures..::.CutterFailures Class See Also Send Feedback
Attempt to create or manipulate a segmented section has failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MakeCutterForSectionGStepFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MakeCutterForSectionGStepFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForSectionGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CutterFailures Class


BuiltInFailures.CuttingFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class CuttingFailures
Visual Basic (Declaration)
Public NotInheritable Class CuttingFailures
Visual C++
public ref class CuttingFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.CuttingFailures

See Also

BuiltInFailures..::.CuttingFailures Members


BuiltInFailures.CuttingFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures Members
BuiltInFailures..::.CuttingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::.CuttingFailures Class


BuiltInFailures.CuttingFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures Properties
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback

The BuiltInFailures..::.CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::.CuttingFailures Class


CannotCopyFromMultipleLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.CannotCopyFromMultipleLinks Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
Elements cannot be copied from multiple links at the same time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFromMultipleLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyFromMultipleLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromMultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


ElementsWithNotCopiedParentsDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.ElementsWithNotCopiedParentsDeleted Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
Some elements were deleted because elements that they require for references were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWithNotCopiedParentsDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsWithNotCopiedParentsDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsWithNotCopiedParentsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


NoFileSaved Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.NoFileSaved Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
No file has been saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFileSaved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFileSaved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFileSaved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


NoSupported2DElementsToCopyFromView Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.NoSupported2DElementsToCopyFromView Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
None of the elements in the view you have selected are supported for the insert 2D operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSupported2DElementsToCopyFromView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSupported2DElementsToCopyFromView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSupported2DElementsToCopyFromView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


UnableToCopyElementsFromFile Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.UnableToCopyElementsFromFile Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
Unable to copy elements from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCopyElementsFromFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToCopyElementsFromFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToCopyElementsFromFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


UnableToPasteToFile Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.UnableToPasteToFile Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
Unable to paste current clipboard contents to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToPasteToFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToPasteToFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToPasteToFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


UnableToReplaceWithLink Property

[image]

Revit 2011 API
BuiltInFailures..::.CuttingFailures..::.UnableToReplaceWithLink Property
BuiltInFailures..::.CuttingFailures Class See Also Send Feedback
Selected elements were copied to new file but Revit was unable to replace them with link to that file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToReplaceWithLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToReplaceWithLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToReplaceWithLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.CuttingFailures Class


BuiltInFailures.DatumPlaneFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DatumPlaneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DatumPlane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DatumPlaneFailures
Visual Basic (Declaration)
Public NotInheritable Class DatumPlaneFailures
Visual C++
public ref class DatumPlaneFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DatumPlaneFailures

See Also

BuiltInFailures..::.DatumPlaneFailures Members


BuiltInFailures.DatumPlaneFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DatumPlaneFailures Members
BuiltInFailures..::.DatumPlaneFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DatumPlaneFailures type exposes the following members.

Properties

Name | Description
ScopeBoxWrongPosition | The Highlighted Datum can not be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

See Also

BuiltInFailures..::.DatumPlaneFailures Class


BuiltInFailures.DatumPlaneFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DatumPlaneFailures Properties
BuiltInFailures..::.DatumPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::.DatumPlaneFailures type exposes the following members.

Properties

Name | Description
ScopeBoxWrongPosition | The Highlighted Datum can not be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

See Also

BuiltInFailures..::.DatumPlaneFailures Class


ScopeBoxWrongPosition Property

[image]

Revit 2011 API
BuiltInFailures..::.DatumPlaneFailures..::.ScopeBoxWrongPosition Property
BuiltInFailures..::.DatumPlaneFailures Class See Also Send Feedback
The Highlighted Datum can not be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ScopeBoxWrongPosition { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ScopeBoxWrongPosition As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ScopeBoxWrongPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DatumPlaneFailures Class


BuiltInFailures.DecalFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DecalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Decal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DecalFailures
Visual Basic (Declaration)
Public NotInheritable Class DecalFailures
Visual C++
public ref class DecalFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DecalFailures

See Also

BuiltInFailures..::.DecalFailures Members


BuiltInFailures.DecalFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DecalFailures Members
BuiltInFailures..::.DecalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer then the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::.DecalFailures Class


BuiltInFailures.DecalFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DecalFailures Properties
BuiltInFailures..::.DecalFailures Class See Also Send Feedback

The BuiltInFailures..::.DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer then the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::.DecalFailures Class


CannotPaste Property

[image]

Revit 2011 API
BuiltInFailures..::.DecalFailures..::.CannotPaste Property
BuiltInFailures..::.DecalFailures Class See Also Send Feedback
Can't place Decal at new position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPaste { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPaste As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DecalFailures Class


LongerThanPossible Property

[image]

Revit 2011 API
BuiltInFailures..::.DecalFailures..::.LongerThanPossible Property
BuiltInFailures..::.DecalFailures Class See Also Send Feedback
Decal element is longer then the circumference of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LongerThanPossible { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LongerThanPossible As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LongerThanPossible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DecalFailures Class


OutsideHost Property

[image]

Revit 2011 API
BuiltInFailures..::.DecalFailures..::.OutsideHost Property
BuiltInFailures..::.DecalFailures Class See Also Send Feedback
Decal does not lie on host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OutsideHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OutsideHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OutsideHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DecalFailures Class


BuiltInFailures.DesignOptionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DesignOptionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DesignOptionFailures
Visual Basic (Declaration)
Public NotInheritable Class DesignOptionFailures
Visual C++
public ref class DesignOptionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DesignOptionFailures

See Also

BuiltInFailures..::.DesignOptionFailures Members


BuiltInFailures.DesignOptionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures Members
BuiltInFailures..::.DesignOptionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutLinkedRoomInOption | Linked Rooms must be in the Main Model
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ElementsWillBeDeletedNoOption | Elements will be deleted
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::.DesignOptionFailures Class


BuiltInFailures.DesignOptionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures Properties
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback

The BuiltInFailures..::.DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutLinkedRoomInOption | Linked Rooms must be in the Main Model
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ElementsWillBeDeletedNoOption | Elements will be deleted
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::.DesignOptionFailures Class


AreaTagLineCannotBeInDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.AreaTagLineCannotBeInDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaTagLineCannotBeInDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaTagLineCannotBeInDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaTagLineCannotBeInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


BadReferenceBetweenOptions Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.BadReferenceBetweenOptions Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceBetweenOptions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadReferenceBetweenOptions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadReferenceBetweenOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


BadReferenceBetweenOptionsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.BadReferenceBetweenOptionsWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceBetweenOptionsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadReferenceBetweenOptionsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadReferenceBetweenOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


BadReferenceToSecondary Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.BadReferenceToSecondary Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadReferenceToSecondary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


BadReferenceToSecondaryWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.BadReferenceToSecondaryWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondaryWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadReferenceToSecondaryWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondaryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


CannotAddToOptions Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.CannotAddToOptions Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToOptions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddToOptions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


CannotAddToOptionsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.CannotAddToOptionsWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToOptionsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddToOptionsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


CannotPutLinkedRoomInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.CannotPutLinkedRoomInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Linked Rooms must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutLinkedRoomInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPutLinkedRoomInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPutLinkedRoomInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


CannotPutSpaceInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.CannotPutSpaceInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
MEP space must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutSpaceInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPutSpaceInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPutSpaceInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


CannotPutZoneInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.CannotPutZoneInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
HVAC Zones must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutZoneInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPutZoneInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPutZoneInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInAnotherDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInMainModel Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInMainModel Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInMainModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingHostByElementsInMainModelWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingHostByElementsInMainModelWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModelWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingHostByElementsInMainModelWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInAnotherDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInMainModel Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInMainModel Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInMainModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingPadByElementsInMainModelWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingPadByElementsInMainModelWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModelWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingPadByElementsInMainModelWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInAnotherDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInDesignOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInDesignOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInDesignOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInDesignOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInMainModel Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInMainModel Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInMainModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ConfusingSweepByElementsInMainModelWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ConfusingSweepByElementsInMainModelWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInMainModelWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModelWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


ElementsWillBeDeletedNoOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.ElementsWillBeDeletedNoOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Elements will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWillBeDeletedNoOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsWillBeDeletedNoOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsWillBeDeletedNoOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


KingNeverInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.KingNeverInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId KingNeverInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property KingNeverInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ KingNeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


KingNeverInOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.KingNeverInOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId KingNeverInOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property KingNeverInOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ KingNeverInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


MustAddKing Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.MustAddKing Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MustAddKing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MustAddKing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MustAddKing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


MustAddKingWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.MustAddKingWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MustAddKingWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MustAddKingWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MustAddKingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


MustBeInMainModel Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.MustBeInMainModel Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Element must be in Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MustBeInMainModel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MustBeInMainModel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MustBeInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


NeverInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.NeverInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NeverInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NeverInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


NeverInOptionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.NeverInOptionWarn Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NeverInOptionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NeverInOptionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NeverInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


NoSelectedInOption Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.NoSelectedInOption Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
None of the selected elements can be added to this Option Set. The following warnings provide additional information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSelectedInOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSelectedInOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSelectedInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


OptionElementsDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.OptionElementsDeleted Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Elements in [option] were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionElementsDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionElementsDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


SelectionIncludesOptionItems Property

[image]

Revit 2011 API
BuiltInFailures..::.DesignOptionFailures..::.SelectionIncludesOptionItems Property
BuiltInFailures..::.DesignOptionFailures Class See Also Send Feedback
Elements that were already in a Design Option were selected. These will not be added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SelectionIncludesOptionItems { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SelectionIncludesOptionItems As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SelectionIncludesOptionItems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DesignOptionFailures Class


BuiltInFailures.DetailFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DetailFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DetailFailures
Visual Basic (Declaration)
Public NotInheritable Class DetailFailures
Visual C++
public ref class DetailFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DetailFailures

See Also

BuiltInFailures..::.DetailFailures Members


BuiltInFailures.DetailFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DetailFailures Members
BuiltInFailures..::.DetailFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::.DetailFailures Class


BuiltInFailures.DetailFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DetailFailures Properties
BuiltInFailures..::.DetailFailures Class See Also Send Feedback

The BuiltInFailures..::.DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::.DetailFailures Class


EavesAreAligned Property

[image]

Revit 2011 API
BuiltInFailures..::.DetailFailures..::.EavesAreAligned Property
BuiltInFailures..::.DetailFailures Class See Also Send Feedback
All eaves are already aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EavesAreAligned { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EavesAreAligned As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EavesAreAligned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DetailFailures Class


NeedsTwoToAlignEaves Property

[image]

Revit 2011 API
BuiltInFailures..::.DetailFailures..::.NeedsTwoToAlignEaves Property
BuiltInFailures..::.DetailFailures Class See Also Send Feedback
At least two Slope Defining Lines are needed to perform Align Eaves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NeedsTwoToAlignEaves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NeedsTwoToAlignEaves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NeedsTwoToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DetailFailures Class


RepeatingDetailSpacingZeroError Property

[image]

Revit 2011 API
BuiltInFailures..::.DetailFailures..::.RepeatingDetailSpacingZeroError Property
BuiltInFailures..::.DetailFailures Class See Also Send Feedback
Spacing must be greater than 0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RepeatingDetailSpacingZeroError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RepeatingDetailSpacingZeroError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RepeatingDetailSpacingZeroError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DetailFailures Class


BuiltInFailures.DimensionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DimensionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DimensionFailures
Visual Basic (Declaration)
Public NotInheritable Class DimensionFailures
Visual C++
public ref class DimensionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DimensionFailures

See Also

BuiltInFailures..::.DimensionFailures Members


BuiltInFailures.DimensionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures Members
BuiltInFailures..::.DimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DimensionOverconstrained | The Dimension would overconstraint the Sketch.
DimensionOverconstrainedError | The Dimension would overconstraint the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionReferencesInvalid | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to it's beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::.DimensionFailures Class


BuiltInFailures.DimensionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures Properties
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback

The BuiltInFailures..::.DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DimensionOverconstrained | The Dimension would overconstraint the Sketch.
DimensionOverconstrainedError | The Dimension would overconstraint the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionReferencesInvalid | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to it's beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::.DimensionFailures Class


AngularDimensionRegenFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.AngularDimensionRegenFailed Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't form Angular Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AngularDimensionRegenFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AngularDimensionRegenFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AngularDimensionRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ArcAlignmentRegenFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ArcAlignmentRegenFailed Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't form arc alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArcAlignmentRegenFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArcAlignmentRegenFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArcAlignmentRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ArcLengthDimensionNoReferencesOnArc Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ArcLengthDimensionNoReferencesOnArc Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArcLengthDimensionNoReferencesOnArc { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArcLengthDimensionNoReferencesOnArc As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArcLengthDimensionNoReferencesOnArc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ArcLengthDimensionReferencesNotIntersect Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ArcLengthDimensionReferencesNotIntersect Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArcLengthDimensionReferencesNotIntersect { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArcLengthDimensionReferencesNotIntersect As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArcLengthDimensionReferencesNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


AssocpropNeedJog Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.AssocpropNeedJog Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Need to add jog in order to satisfy constraints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AssocpropNeedJog { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AssocpropNeedJog As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AssocpropNeedJog {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotConstrainBasePointAlignments Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotConstrainBasePointAlignments Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Alignments to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointAlignments { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConstrainBasePointAlignments As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointAlignments {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotConstrainBasePointDimensions Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotConstrainBasePointDimensions Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Dimensions to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointDimensions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConstrainBasePointDimensions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointDimensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotCreateDimensionNotParallel Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotCreateDimensionNotParallel Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't create dimension. Highlighted references are not parallel to first selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateDimensionNotParallel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateDimensionNotParallel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateDimensionNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotDragWitnessLine Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotDragWitnessLine Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Moving the Witness Line conflicts with other Constraints in the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDragWitnessLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDragWitnessLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDragWitnessLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotLockThisDimension Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotLockThisDimension Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't lock this Dimension because it breaks formulas

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLockThisDimension { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotLockThisDimension As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotLockThisDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


CannotToggleDimensionEquality Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.CannotToggleDimensionEquality Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Toggling the dimension's equality constraint would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotToggleDimensionEquality { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotToggleDimensionEquality As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotToggleDimensionEquality {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ChangeDimensionSegmentFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ChangeDimensionSegmentFailed Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't change dimension segment to this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ChangeDimensionSegmentFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ChangeDimensionSegmentFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ChangeDimensionSegmentFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ChangeSpotElevationFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ChangeSpotElevationFailed Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't change Spot Elevation to the desired value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ChangeSpotElevationFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ChangeSpotElevationFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ChangeSpotElevationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionOverconstrained Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The Dimension would overconstraint the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionOverconstrainedError Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionOverconstrainedError Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The Dimension would overconstraint the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverconstrainedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionOverconstrainedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionOverconstrainedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionOverrideNearByIsLost Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionOverrideNearByIsLost Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverrideNearByIsLost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionOverrideNearByIsLost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionOverrideNearByIsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionPerpendicularToView Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionPerpendicularToView Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The Dimension is perpendicular to the current view, and no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionPerpendicularToView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionPerpendicularToView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionPerpendicularToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionReferencesInvalid Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionReferencesInvalid Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
One or more dimension references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionReferencesInvalid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionReferencesInvalid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionReferencesInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionUnequaled Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionUnequaled Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnequaled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionUnequaled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionUnequaled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionUnlocked Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionUnlocked Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Dimension had to be un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnlocked { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionUnlocked As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


DimensionUnlockedAndUnequaled Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.DimensionUnlockedAndUnequaled Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Dimension had to be unlocked in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnlockedAndUnequaled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionUnlockedAndUnequaled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionUnlockedAndUnequaled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


EqualityConstraintsUnsatisfied Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.EqualityConstraintsUnsatisfied Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfied { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EqualityConstraintsUnsatisfied As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


EqualityConstraintsUnsatisfiedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.EqualityConstraintsUnsatisfiedWarn Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfiedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EqualityConstraintsUnsatisfiedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


ForbiddenGroupConstraint Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.ForbiddenGroupConstraint Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
You may not create sketch or family constraints between group members and elements which are not members of the same group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ForbiddenGroupConstraint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ForbiddenGroupConstraint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ForbiddenGroupConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LabelOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LabelOverconstrained Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Labeling this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LabelOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LabelOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LabelOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LinearConstraintBadDirection Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LinearConstraintBadDirection Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Bad direction vector in dimension element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinearConstraintBadDirection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinearConstraintBadDirection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinearConstraintBadDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LinearConstraintNotParallel Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LinearConstraintNotParallel Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The References of the highlighted Dimension are no longer parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinearConstraintNotParallel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinearConstraintNotParallel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinearConstraintNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LinearDimensionReferenceNotOrthogonalToView Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LinearDimensionReferenceNotOrthogonalToView Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinearDimensionReferenceNotOrthogonalToView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinearDimensionReferenceNotOrthogonalToView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinearDimensionReferenceNotOrthogonalToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LockOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LockOverconstrained Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Locking this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LockOverconstrainedAlignment Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LockOverconstrainedAlignment Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Locking this alignment would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockOverconstrainedAlignment { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockOverconstrainedAlignment As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockOverconstrainedAlignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


LooseLabeledDimensionRegenFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.LooseLabeledDimensionRegenFailure Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Failed to Regenerate Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseLabeledDimensionRegenFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseLabeledDimensionRegenFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseLabeledDimensionRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


NoConstraintsInProperSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.NoConstraintsInProperSketch Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsInProperSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoConstraintsInProperSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsInProperSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


NoConstraintsToLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.NoConstraintsToLinks Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Constraints may not be created to linked instances using Shared Locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsToLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoConstraintsToLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsToLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


RadialDimensionCannotProjectToArc Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.RadialDimensionCannotProjectToArc Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Cannot form radial dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RadialDimensionCannotProjectToArc { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RadialDimensionCannotProjectToArc As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RadialDimensionCannotProjectToArc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


RadialDimensionChangeRadiusFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.RadialDimensionChangeRadiusFailed Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Can't change radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RadialDimensionChangeRadiusFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RadialDimensionChangeRadiusFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RadialDimensionChangeRadiusFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


RegenConstraintUnsatisfied Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.RegenConstraintUnsatisfied Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfied { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegenConstraintUnsatisfied As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


RegenConstraintUnsatisfiedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.RegenConstraintUnsatisfiedWarn Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfiedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegenConstraintUnsatisfiedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SomeDimensionsLostOnPaste Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SomeDimensionsLostOnPaste Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Some Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostOnPaste { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeDimensionsLostOnPaste As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SomeDimensionsLostWitnessLines Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SomeDimensionsLostWitnessLines Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Some Dimensions lost some of their References on paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostWitnessLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeDimensionsLostWitnessLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostWitnessLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SomeSpotDimensionsLostOnPaste Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SomeSpotDimensionsLostOnPaste Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Some Spot Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeSpotDimensionsLostOnPaste { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeSpotDimensionsLostOnPaste As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeSpotDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SpotDimensionReferencesInvalid Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SpotDimensionReferencesInvalid Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpotDimensionReferencesInvalid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpotDimensionReferencesInvalid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionReferencesInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SpotElevationLostEdgeReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SpotElevationLostEdgeReferences Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpotElevationLostEdgeReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpotElevationLostEdgeReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpotElevationLostEdgeReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SpotElevationMissesReference Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SpotElevationMissesReference Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Spot Dimension does not lie on its reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpotElevationMissesReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpotElevationMissesReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpotElevationMissesReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SpotSlopeReferenceIsVertical Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SpotSlopeReferenceIsVertical Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element that is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpotSlopeReferenceIsVertical { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpotSlopeReferenceIsVertical As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferenceIsVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


SpotSlopeReferencePointIsSingular Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.SpotSlopeReferencePointIsSingular Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element point that is singular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpotSlopeReferencePointIsSingular { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpotSlopeReferencePointIsSingular As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferencePointIsSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


WrongConstraintInJoistSystemSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.WrongConstraintInJoistSystemSketch Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Structural Beam System sketch can't be constrained to it's beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInJoistSystemSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConstraintInJoistSystemSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInJoistSystemSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


WrongConstraintInSkeletonSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.WrongConstraintInSkeletonSketch Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInSkeletonSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConstraintInSkeletonSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInSkeletonSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


WrongConstraintInTrussSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.DimensionFailures..::.WrongConstraintInTrussSketch Property
BuiltInFailures..::.DimensionFailures Class See Also Send Feedback
Structural Truss sketch can't be constrained to its members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInTrussSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongConstraintInTrussSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInTrussSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DimensionFailures Class


BuiltInFailures.DividedSurfaceFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DividedSurfaceFailures
Visual Basic (Declaration)
Public NotInheritable Class DividedSurfaceFailures
Visual C++
public ref class DividedSurfaceFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DividedSurfaceFailures

See Also

BuiltInFailures..::.DividedSurfaceFailures Members


BuiltInFailures.DividedSurfaceFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures Members
BuiltInFailures..::.DividedSurfaceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
AttemptToCreateMultipleDividedSurfacesOnTheSameFace | Creation of a Divided Surface on a face already hosting another one was requested.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual spllitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual spllitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures Properties
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback

The BuiltInFailures..::.DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
AttemptToCreateMultipleDividedSurfacesOnTheSameFace | Creation of a Divided Surface on a face already hosting another one was requested.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual spllitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual spllitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


AttemptToCreateMultipleDividedSurfacesOnTheSameFace Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.AttemptToCreateMultipleDividedSurfacesOnTheSameFace Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Creation of a Divided Surface on a face already hosting another one was requested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToCreateMultipleDividedSurfacesOnTheSameFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AttemptToCreateMultipleDividedSurfacesOnTheSameFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AttemptToCreateMultipleDividedSurfacesOnTheSameFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCoincidingSplittingWorkplanes Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCoincidingSplittingWorkplanes Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Coinciding splitting workplanes are encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCoincidingSplittingWorkplanes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCoincidingSplittingWorkplanes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCoincidingSplittingWorkplanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainBelongsToMultipleBeltIntervals { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainBelongsToMultipleBeltIntervals As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBelongsToMultipleBeltIntervals {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainBothUandV Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainBothUandV Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements is trying to be both U- and V- splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainBothUandV { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainBothUandV As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBothUandV {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainDoesNotEngageUorV Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainDoesNotEngageUorV Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainDoesNotEngageUorV { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainDoesNotEngageUorV As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainDoesNotEngageUorV {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainGeneralProblem Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainGeneralProblem Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements cannot be processed and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainGeneralProblem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainGeneralProblem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainIntersection Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainIntersection Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainIsTooClosedToGridlines Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainIsTooClosedToGridlines Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIsTooClosedToGridlines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainIsTooClosedToGridlines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIsTooClosedToGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainMultipleSeqIntersWithDivLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainMultipleSeqIntersWithDivLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainMultipleSeqIntersWithDivLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainNonSeqIntersWithDivLines Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainNonSeqIntersWithDivLines Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainNonSeqIntersWithDivLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainNonSeqIntersWithDivLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainNonSeqIntersWithDivLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveChainUnsortableBucket Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveChainUnsortableBucket Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainUnsortableBucket { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveChainUnsortableBucket As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainUnsortableBucket {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveFromChainMultipleIntersWithDivLine Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveFromChainMultipleIntersWithDivLine Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveFromChainMultipleIntersWithDivLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveFromChainMultipleIntersWithDivLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveFromChainMultipleIntersWithDivLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCurveLoopChainIntersectedByExtensions Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCurveLoopChainIntersectedByExtensions Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveLoopChainIntersectedByExtensions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCurveLoopChainIntersectedByExtensions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveLoopChainIntersectedByExtensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The surface-based splitter does not intersect a face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceDoesNotCutMeshFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceDoesNotCutMeshFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceDoesNotCutMeshFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceGeneralProblem Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCuttingSurfaceGeneralProblem Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Cannot process a surface-based splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceGeneralProblem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceGeneralProblem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceMakesMultipleCuts Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceCuttingSurfaceMakesMultipleCuts Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceMakesMultipleCuts { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceMakesMultipleCuts As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceMakesMultipleCuts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceDidNotRegenerateProperly Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceDidNotRegenerateProperly Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Divided Surface gridlines could not be generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceDidNotRegenerateProperly { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceDidNotRegenerateProperly As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceDidNotRegenerateProperly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceDiscardedSplittersWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceDiscardedSplittersWarning Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceDiscardedSplittersWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceDiscardedSplittersWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceDiscardedSplittersWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceIgnoresSplitters Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceIgnoresSplitters Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceIgnoresSplitters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceIgnoresSplitters As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceIgnoresSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceInvalidSpacing Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceInvalidSpacing Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Constraints not satisfied, cannot generate gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceInvalidSpacing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceInvalidSpacing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceInvalidSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceLoopsOfSplittingCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceLoopsOfSplittingCurves Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a closed loop currently cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceLoopsOfSplittingCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceLoopsOfSplittingCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceLoopsOfSplittingCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
There are multiple intersections between splitting chain of virtual spllitters defined by these elements and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSelfIntersectingCurveLoopChain Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSelfIntersectingCurveLoopChain Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSelfIntersectingCurveLoopChain { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSelfIntersectingCurveLoopChain As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSelfIntersectingCurveLoopChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSingleCurveLoopsAsSplitters Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSingleCurveLoopsAsSplitters Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a single curve loop cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveLoopsAsSplitters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSingleCurveLoopsAsSplitters As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveLoopsAsSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
There are curves in splitting chain of virtual spllitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSplitManagerProblem1dNonWPCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSplitManagerProblem1dNonWPCurve Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Divided Surface cannot be split by a one dimensional curve without workplane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitManagerProblem1dNonWPCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblem1dNonWPCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblem1dNonWPCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Divided Surface cannot be split by a closed arc or ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitManagerProblemClosedArcOrEllipse { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblemClosedArcOrEllipse As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblemClosedArcOrEllipse {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSplitRefInvisible Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSplitRefInvisible Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Some of the splitting references of this Divided Surface are invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitRefInvisible { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSplitRefInvisible As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitRefInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve elements which form chains connecting points shared by more than two curve elements are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceSplittingCurvesWithMultipleNeighbors Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceSplittingCurvesWithMultipleNeighbors Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurvesWithMultipleNeighbors { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceSplittingCurvesWithMultipleNeighbors As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurvesWithMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


DividedSurfaceZeroLengthSplittingCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.DividedSurfaceZeroLengthSplittingCurve Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Curve element with zero length cannot be used as a splitter and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceZeroLengthSplittingCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividedSurfaceZeroLengthSplittingCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceZeroLengthSplittingCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


MeshTopologicalSortFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DividedSurfaceFailures..::.MeshTopologicalSortFailed Property
BuiltInFailures..::.DividedSurfaceFailures Class See Also Send Feedback
Splitters and grids do not define a consistent rectangular mesh on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MeshTopologicalSortFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MeshTopologicalSortFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MeshTopologicalSortFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DividedSurfaceFailures Class


BuiltInFailures.DocumentFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DocumentFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DocumentFailures
Visual Basic (Declaration)
Public NotInheritable Class DocumentFailures
Visual C++
public ref class DocumentFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DocumentFailures

See Also

BuiltInFailures..::.DocumentFailures Members


BuiltInFailures.DocumentFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures Members
BuiltInFailures..::.DocumentFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DocumentFailures type exposes the following members.

Properties

Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DeniedBorrowing | You have been denied permission to edit these elements.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.
GrantedBorrowing | You have been granted permission to edit these elements.
RequestedBorrowing | Another user requests your permission to edit these elements.

See Also

BuiltInFailures..::.DocumentFailures Class


BuiltInFailures.DocumentFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures Properties
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback

The BuiltInFailures..::.DocumentFailures type exposes the following members.

Properties

Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DeniedBorrowing | You have been denied permission to edit these elements.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.
GrantedBorrowing | You have been granted permission to edit these elements.
RequestedBorrowing | Another user requests your permission to edit these elements.

See Also

BuiltInFailures..::.DocumentFailures Class


ApiDelayedUpdateFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.ApiDelayedUpdateFailed Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Delayed Updating Failed. Please contact the 3rd Party Application vendor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ApiDelayedUpdateFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ApiDelayedUpdateFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ApiDelayedUpdateFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


CannotAutoUpdate Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.CannotAutoUpdate Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Coordination Monitor can't update element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAutoUpdate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAutoUpdate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAutoUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


CannotLoadLink Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.CannotLoadLink Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotLoadLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotLoadLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


DeniedBorrowing Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.DeniedBorrowing Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
You have been denied permission to edit these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeniedBorrowing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeniedBorrowing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeniedBorrowing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


DUExcessiveRegeneration Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.DUExcessiveRegeneration Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DUExcessiveRegeneration { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DUExcessiveRegeneration As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DUExcessiveRegeneration {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


DUMisbehavingUpdater Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.DUMisbehavingUpdater Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Third party updater '[Name]' has experienced a problem and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DUMisbehavingUpdater { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DUMisbehavingUpdater As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DUMisbehavingUpdater {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


GrantedBorrowing Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.GrantedBorrowing Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
You have been granted permission to edit these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GrantedBorrowing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GrantedBorrowing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GrantedBorrowing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


RequestedBorrowing Property

[image]

Revit 2011 API
BuiltInFailures..::.DocumentFailures..::.RequestedBorrowing Property
BuiltInFailures..::.DocumentFailures Class See Also Send Feedback
Another user requests your permission to edit these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RequestedBorrowing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RequestedBorrowing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RequestedBorrowing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DocumentFailures Class


BuiltInFailures.DuctFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.DuctFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class DuctFailures
Visual Basic (Declaration)
Public NotInheritable Class DuctFailures
Visual C++
public ref class DuctFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.DuctFailures

See Also

BuiltInFailures..::.DuctFailures Members


BuiltInFailures.DuctFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.DuctFailures Members
BuiltInFailures..::.DuctFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
InvalidDuctFittingKfactorDatabase | Invalid Duct Fitting K-Factor Database
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.

See Also

BuiltInFailures..::.DuctFailures Class


BuiltInFailures.DuctFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.DuctFailures Properties
BuiltInFailures..::.DuctFailures Class See Also Send Feedback

The BuiltInFailures..::.DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
InvalidDuctFittingKfactorDatabase | Invalid Duct Fitting K-Factor Database
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.

See Also

BuiltInFailures..::.DuctFailures Class


CannotCreateGeometryForDuct Property

[image]

Revit 2011 API
BuiltInFailures..::.DuctFailures..::.CannotCreateGeometryForDuct Property
BuiltInFailures..::.DuctFailures Class See Also Send Feedback
Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForDuct { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGeometryForDuct As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DuctFailures Class


FlexDuctLengthOutOfLimits Property

[image]

Revit 2011 API
BuiltInFailures..::.DuctFailures..::.FlexDuctLengthOutOfLimits Property
BuiltInFailures..::.DuctFailures Class See Also Send Feedback
The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FlexDuctLengthOutOfLimits { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FlexDuctLengthOutOfLimits As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FlexDuctLengthOutOfLimits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DuctFailures Class


InvalidDuctFittingKfactorDatabase Property

[image]

Revit 2011 API
BuiltInFailures..::.DuctFailures..::.InvalidDuctFittingKfactorDatabase Property
BuiltInFailures..::.DuctFailures Class See Also Send Feedback
Invalid Duct Fitting K-Factor Database

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidDuctFittingKfactorDatabase { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidDuctFittingKfactorDatabase As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidDuctFittingKfactorDatabase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DuctFailures Class


NoDuctFittingsInProject Property

[image]

Revit 2011 API
BuiltInFailures..::.DuctFailures..::.NoDuctFittingsInProject Property
BuiltInFailures..::.DuctFailures Class See Also Send Feedback
There are no duct fittings defined in project. The default duct type for fittings will be set to none.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoDuctFittingsInProject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoDuctFittingsInProject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoDuctFittingsInProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.DuctFailures Class


BuiltInFailures.EditingFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EditingFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class EditingFailures
Visual Basic (Declaration)
Public NotInheritable Class EditingFailures
Visual C++
public ref class EditingFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.EditingFailures

See Also

BuiltInFailures..::.EditingFailures Members


BuiltInFailures.EditingFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.EditingFailures Members
BuiltInFailures..::.EditingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central File is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central File is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central File.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central File is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | No work plane while editing unconstrained element in 3d view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletePreventedByElemArray | Elements managed by Element Arrays can be deleted only if explicitly unlocked.
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherFailure | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherFailureError | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedByElementArray | Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.
LockedByGroup | Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.
LockedByMassing | To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central File is inaccessible or being accessed by another user.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central File. Please Reload Latest before making this workset editable.
WorksetNoneditableCozAdvanced | This workset has changed in the Central File. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::.EditingFailures Class


BuiltInFailures.EditingFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.EditingFailures Properties
BuiltInFailures..::.EditingFailures Class See Also Send Feedback

The BuiltInFailures..::.EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central File is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central File is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central File.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central File is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | No work plane while editing unconstrained element in 3d view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletePreventedByElemArray | Elements managed by Element Arrays can be deleted only if explicitly unlocked.
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherFailure | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherFailureError | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedByElementArray | Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.
LockedByGroup | Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.
LockedByMassing | To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central File is inaccessible or being accessed by another user.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central File. Please Reload Latest before making this workset editable.
WorksetNoneditableCozAdvanced | This workset has changed in the Central File. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::.EditingFailures Class


AllInvisibleInPlanViewWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.AllInvisibleInPlanViewWarn Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllInvisibleInPlanViewWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllInvisibleInPlanViewWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInPlanViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


AllInvisibleInViewWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.AllInvisibleInViewWarn Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllInvisibleInViewWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllInvisibleInViewWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


BorrowElementsAtRisk Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.BorrowElementsAtRisk Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central File is inaccessible. You can check out worksets at risk, but consider carefully!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BorrowElementsAtRisk { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BorrowElementsAtRisk As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BorrowElementsAtRisk {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotBorrowBusyContention Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotBorrowBusyContention Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element. The Central File is busy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotBorrowBusyContention { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotBorrowBusyContention As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotBorrowBusyContention {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotCheckoutWorksets Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotCheckoutWorksets Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't make workset editable. User '[Borrowers]' has already checked it out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCheckoutWorksets { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCheckoutWorksets As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCheckoutWorksets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotDeleteEditedElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotDeleteEditedElement Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDeleteEditedElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotDeleteEditedElementError Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotDeleteEditedElementError Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElementError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDeleteEditedElementError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotDeletePredefinedFamilyElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotDeletePredefinedFamilyElement Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Element is a built-in part of the family definition and cannot be deleted or added to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeletePredefinedFamilyElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDeletePredefinedFamilyElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDeletePredefinedFamilyElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotDrawInCurrentView Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotDrawInCurrentView Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawInCurrentView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawInCurrentView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotDuplicateType Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotDuplicateType Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Cannot Duplicate Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotEditDeletedElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotEditDeletedElements Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't edit the element. It was deleted in the Central File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditDeletedElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEditDeletedElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEditDeletedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotEditDeletedWorkset Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotEditDeletedWorkset Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
This action has caused deletion of non-editable Workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditDeletedWorkset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEditDeletedWorkset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEditDeletedWorkset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotEditEditingElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotEditEditingElements Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central File is inaccessible and another user is editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditEditingElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEditEditingElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEditEditingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotEditElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotEditElements Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEditElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEditElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotEditRenamedWorkset Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotEditRenamedWorkset Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't edit workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditRenamedWorkset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEditRenamedWorkset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEditRenamedWorkset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMirrorInView Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMirrorInView Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Must specify Work Plane to mirror in a 3d View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMirrorInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveElement Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveElementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveElementWarn Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveElementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveElementWithoutWorkplane Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveElementWithoutWorkplane Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
No work plane while editing unconstrained element in 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElementWithoutWorkplane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveElementWithoutWorkplane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWithoutWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveInView Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveInView Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveInViewError Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveInViewError Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveInViewError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveInViewError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveLocked Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveLocked Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveLocked { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveLocked As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotMoveTogether Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotMoveTogether Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveTogether { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveTogether As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveTogether {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotRotateLocked Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotRotateLocked Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't rotate pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateLocked { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRotateLocked As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


CannotScaleInView Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.CannotScaleInView Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotScaleInView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotScaleInView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotScaleInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


DeletePreventedByElemArray Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.DeletePreventedByElemArray Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements managed by Element Arrays can be deleted only if explicitly unlocked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletePreventedByElemArray { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletePreventedByElemArray As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletePreventedByElemArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


DeletePreventedByGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.DeletePreventedByGroup Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletePreventedByGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletePreventedByGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletePreventedByGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementNotEditable Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementNotEditable Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
One or more elements are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementNotEditable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementNotEditable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementReversed Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementReversed Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Element is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementReversed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementReversed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementReversed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementsDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementsDeleted Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementsDeletedPastedToKeep Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementsDeletedPastedToKeep Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements were deleted. Use Edit Pasted Elements to keep them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsDeletedPastedToKeep { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsDeletedPastedToKeep As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsDeletedPastedToKeep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementsNotInPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementsNotInPlane Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements don't lie on the same plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNotInPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsNotInPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsNotInPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ElementsWillBeDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ElementsWillBeDeleted Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements in [Design Option] will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWillBeDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsWillBeDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ExtendToOtherFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ExtendToOtherFailure Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendToOtherFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExtendToOtherFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExtendToOtherFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ExtendToOtherFailureError Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ExtendToOtherFailureError Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendToOtherFailureError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExtendToOtherFailureError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExtendToOtherFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


GeneratedByMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.GeneratedByMassing Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GeneratedByMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GeneratedByMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GeneratedByMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


HaveNoPermissionToEdit Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.HaveNoPermissionToEdit Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
You do not have permission to edit the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HaveNoPermissionToEdit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HaveNoPermissionToEdit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HaveNoPermissionToEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


HiddenBeamsEditingWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.HiddenBeamsEditingWarning Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HiddenBeamsEditingWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HiddenBeamsEditingWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HiddenBeamsEditingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


InvalidArrayObject Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.InvalidArrayObject Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidArrayObject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidArrayObject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidArrayObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


InvalidElemsInSelection Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.InvalidElemsInSelection Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't scale elements together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElemsInSelection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidElemsInSelection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidElemsInSelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


LockedByElementArray Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.LockedByElementArray Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByElementArray { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockedByElementArray As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockedByElementArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


LockedByGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.LockedByGroup Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockedByGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockedByGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


LockedByMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.LockedByMassing Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockedByMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockedByMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


LockedDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.LockedDeleted Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockedDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockedDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockedDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


LockedDeletedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.LockedDeletedWarn Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LockedDeletedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LockedDeletedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LockedDeletedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


MirrorProjectSuccess Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.MirrorProjectSuccess Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
[Action] command has successfully processed [Number] elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MirrorProjectSuccess { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MirrorProjectSuccess As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MirrorProjectSuccess {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


NElementsDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.NElementsDeleted Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
[Number] elements were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NElementsDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NElementsDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


NElementsWrongPosition Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.NElementsWrongPosition Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Review [Number] elements for correct position and shape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NElementsWrongPosition { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NElementsWrongPosition As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NElementsWrongPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


NoRotateMirrorZ Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.NoRotateMirrorZ Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZ { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRotateMirrorZ As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZ {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


NoRotateMirrorZError Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.NoRotateMirrorZError Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRotateMirrorZError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


OutOfDateElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.OutOfDateElements Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Workset is editable, but you must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OutOfDateElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OutOfDateElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OutOfDateElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


OwnedByOther Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.OwnedByOther Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OwnedByOther { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OwnedByOther As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OwnedByOther {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


OwnElementsOutOfDate Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.OwnElementsOutOfDate Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
You now own the element, but your file is out of date. You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OwnElementsOutOfDate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OwnElementsOutOfDate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OwnElementsOutOfDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


PressShowToSee Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.PressShowToSee Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Press Show to see the element(s); then Ignore or Cancel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PressShowToSee { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PressShowToSee As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PressShowToSee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ReloadBeforeMakeEditable Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ReloadBeforeMakeEditable Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadBeforeMakeEditable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReloadBeforeMakeEditable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReloadBeforeMakeEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


ReloadNoGood Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.ReloadNoGood Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element, but the Central File is inaccessible or being accessed by another user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadNoGood { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReloadNoGood As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReloadNoGood {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


SourceInEditMode Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.SourceInEditMode Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SourceInEditMode { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SourceInEditMode As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SourceInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


TargetInEditMode Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.TargetInEditMode Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TargetInEditMode { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TargetInEditMode As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TargetInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


TemporaryChangesOutOfDate Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.TemporaryChangesOutOfDate Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TemporaryChangesOutOfDate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TemporaryChangesOutOfDate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TemporaryChangesOutOfDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


TemporaryChangesTransparentPermissions Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.TemporaryChangesTransparentPermissions Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TemporaryChangesTransparentPermissions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TemporaryChangesTransparentPermissions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TemporaryChangesTransparentPermissions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


UnableFilletSpecifiedRadius Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.UnableFilletSpecifiedRadius Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Unable to create Fillet with the specified radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableFilletSpecifiedRadius { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableFilletSpecifiedRadius As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableFilletSpecifiedRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


UnableToMakeSourceWorksetEditable Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.UnableToMakeSourceWorksetEditable Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMakeSourceWorksetEditable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToMakeSourceWorksetEditable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeSourceWorksetEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


UnableToTransformElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.UnableToTransformElement Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransformElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToTransformElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


UnableToTransformElementError Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.UnableToTransformElementError Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransformElementError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToTransformElementError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


WorksetHasChangedInCentralFile Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.WorksetHasChangedInCentralFile Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
This workset has changed in the Central File. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetHasChangedInCentralFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WorksetHasChangedInCentralFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WorksetHasChangedInCentralFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


WorksetNoneditableCozAdvanced Property

[image]

Revit 2011 API
BuiltInFailures..::.EditingFailures..::.WorksetNoneditableCozAdvanced Property
BuiltInFailures..::.EditingFailures Class See Also Send Feedback
This workset has changed in the Central File. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetNoneditableCozAdvanced { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WorksetNoneditableCozAdvanced As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WorksetNoneditableCozAdvanced {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EditingFailures Class


BuiltInFailures.ElectricalFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Electricity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ElectricalFailures
Visual Basic (Declaration)
Public NotInheritable Class ElectricalFailures
Visual C++
public ref class ElectricalFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ElectricalFailures

See Also

BuiltInFailures..::.ElectricalFailures Members


BuiltInFailures.ElectricalFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures Members
BuiltInFailures..::.ElectricalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElectricalFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToCircuit | You have selected elements that are connected to other elements. These elements will also be added to the Circuit.
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements can not be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected can not be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsOnPanel | There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

See Also

BuiltInFailures..::.ElectricalFailures Class


BuiltInFailures.ElectricalFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures Properties
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback

The BuiltInFailures..::.ElectricalFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToCircuit | You have selected elements that are connected to other elements. These elements will also be added to the Circuit.
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements can not be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected can not be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsOnPanel | There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

See Also

BuiltInFailures..::.ElectricalFailures Class


AddingOtherConnectedMembersToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.AddingOtherConnectedMembersToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
You have selected elements that are connected to other elements. These elements will also be added to the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AddingOtherConnectedMembersToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AddingOtherConnectedMembersToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


AllSlotsOnPanelOccupied Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.AllSlotsOnPanelOccupied Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllSlotsOnPanelOccupied { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllSlotsOnPanelOccupied As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllSlotsOnPanelOccupied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


BankDistanceSmallerThanDiameter Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.BankDistanceSmallerThanDiameter Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
The distance value is smaller than the conduit diameter, please enter a larger value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BankDistanceSmallerThanDiameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BankDistanceSmallerThanDiameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BankDistanceSmallerThanDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


CableTrayModified Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.CableTrayModified Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CableTrayModified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CableTrayModified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CableTrayModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


CannotAssignSecondaryDistSysToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.CannotAssignSecondaryDistSysToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAssignSecondaryDistSysToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAssignSecondaryDistSysToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAssignSecondaryDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


CannotConnectDifferentDesignOptsObjects Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.CannotConnectDifferentDesignOptsObjects Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConnectDifferentDesignOptsObjects { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConnectDifferentDesignOptsObjects As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConnectDifferentDesignOptsObjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


CannotRemoveMembersInCircuitHavingParent Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.CannotRemoveMembersInCircuitHavingParent Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
You have selected elements that are connected to a Panel object in a Circuit. These elements can not be removed from the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveMembersInCircuitHavingParent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRemoveMembersInCircuitHavingParent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveMembersInCircuitHavingParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


CircuitOverload Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.CircuitOverload Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircuitOverload { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircuitOverload As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircuitOverload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


ConduitModified Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.ConduitModified Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConduitModified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConduitModified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConduitModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


ElementsBelongToOtherCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.ElementsBelongToOtherCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected can not be added to this Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsBelongToOtherCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsBelongToOtherCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsBelongToOtherCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


FamilyMismatchCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.FamilyMismatchCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyMismatchCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


InvalidNumwiresSinglephase Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.InvalidNumwiresSinglephase Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Invalid number of wires for single phase, only 2 and 3 are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidNumwiresSinglephase { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidNumwiresSinglephase As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidNumwiresSinglephase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


InvalidPathOfParallelConduits Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.InvalidPathOfParallelConduits Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Invalid path of parallel conduits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPathOfParallelConduits { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPathOfParallelConduits As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPathOfParallelConduits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchConnectorDistSysToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchConnectorDistSysToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchConnectorDistSysToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchConnectorDistSysToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchConnectorDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchNmbAssignedDistSysToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchNmbAssignedDistSysToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNmbAssignedDistSysToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchNmbAssignedDistSysToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbAssignedDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchNmbOfPolesToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchNmbOfPolesToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNmbOfPolesToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchNmbOfPolesToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbOfPolesToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchPoleBrakesSlotsNumbers Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchPoleBrakesSlotsNumbers Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
The number of pole breakers may not be less than the number of occupied slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchPoleBrakesSlotsNumbers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchPoleBrakesSlotsNumbers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchPoleBrakesSlotsNumbers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchVoltageLineToLine Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchVoltageLineToLine Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchVoltageLineToLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchVoltageLineToLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchVoltageLineToLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MismatchVoltageToCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MismatchVoltageToCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchVoltageToCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchVoltageToCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchVoltageToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


MissingOrInvalidWireSizeTable Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.MissingOrInvalidWireSizeTable Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissingOrInvalidWireSizeTable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissingOrInvalidWireSizeTable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissingOrInvalidWireSizeTable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


NoAvailableMatchingConnector Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.NoAvailableMatchingConnector Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoAvailableMatchingConnector { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoAvailableMatchingConnector As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoAvailableMatchingConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


NotAllowedCableTrayConduitRotation Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.NotAllowedCableTrayConduitRotation Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Don't allow to rotate a horizontal cable tray/conduit like this

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedCableTrayConduitRotation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllowedCableTrayConduitRotation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllowedCableTrayConduitRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


NotEnoughAvailSlotsOnPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.NotEnoughAvailSlotsOnPanel Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughAvailSlotsOnPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotEnoughAvailSlotsOnPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsOnPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


ObjsDemolished Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.ObjsDemolished Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ObjsDemolished { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ObjsDemolished As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ObjsDemolished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


PanelMismatchCircuitType Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.PanelMismatchCircuitType Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelMismatchCircuitType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelMismatchCircuitType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelMismatchCircuitType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


SelectedElementsArePartOfOtherCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.SelectedElementsArePartOfOtherCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SelectedElementsArePartOfOtherCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


UnsignedCircuit Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.UnsignedCircuit Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Circuit is not assigned to a panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnsignedCircuit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnsignedCircuit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnsignedCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


VoltageIsOutOfRange Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricalFailures..::.VoltageIsOutOfRange Property
BuiltInFailures..::.ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VoltageIsOutOfRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VoltageIsOutOfRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VoltageIsOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricalFailures Class


BuiltInFailures.ElectricityFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ElectricityFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ElectricityFailures
Visual Basic (Declaration)
Public NotInheritable Class ElectricityFailures
Visual C++
public ref class ElectricityFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ElectricityFailures

See Also

BuiltInFailures..::.ElectricityFailures Members


BuiltInFailures.ElectricityFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElectricityFailures Members
BuiltInFailures..::.ElectricityFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElectricityFailures type exposes the following members.

Properties

Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

See Also

BuiltInFailures..::.ElectricityFailures Class


BuiltInFailures.ElectricityFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElectricityFailures Properties
BuiltInFailures..::.ElectricityFailures Class See Also Send Feedback

The BuiltInFailures..::.ElectricityFailures type exposes the following members.

Properties

Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

See Also

BuiltInFailures..::.ElectricityFailures Class


FamilyMismatchCircuitDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.ElectricityFailures..::.FamilyMismatchCircuitDisconnected Property
BuiltInFailures..::.ElectricityFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuitDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyMismatchCircuitDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuitDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElectricityFailures Class


BuiltInFailures.ElementFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ElementFailures
Visual Basic (Declaration)
Public NotInheritable Class ElementFailures
Visual C++
public ref class ElementFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ElementFailures

See Also

BuiltInFailures..::.ElementFailures Members


BuiltInFailures.ElementFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElementFailures Members
BuiltInFailures..::.ElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElementFailures type exposes the following members.

Properties

Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.

See Also

BuiltInFailures..::.ElementFailures Class


BuiltInFailures.ElementFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElementFailures Properties
BuiltInFailures..::.ElementFailures Class See Also Send Feedback

The BuiltInFailures..::.ElementFailures type exposes the following members.

Properties

Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.

See Also

BuiltInFailures..::.ElementFailures Class


FailedToRemoveElement Property

[image]

Revit 2011 API
BuiltInFailures..::.ElementFailures..::.FailedToRemoveElement Property
BuiltInFailures..::.ElementFailures Class See Also Send Feedback
Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToRemoveElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToRemoveElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToRemoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementFailures Class


NotAllowedToRemoveAllElements Property

[image]

Revit 2011 API
BuiltInFailures..::.ElementFailures..::.NotAllowedToRemoveAllElements Property
BuiltInFailures..::.ElementFailures Class See Also Send Feedback
You cannot removed all the elements from current solution. At least there should be two elements in the solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToRemoveAllElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllowedToRemoveAllElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToRemoveAllElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementFailures Class


SplitElementHasTagsWithoutLeaders Property

[image]

Revit 2011 API
BuiltInFailures..::.ElementFailures..::.SplitElementHasTagsWithoutLeaders Property
BuiltInFailures..::.ElementFailures Class See Also Send Feedback
The split element has one or more Tags without Leaders enabled and needs to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SplitElementHasTagsWithoutLeaders { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SplitElementHasTagsWithoutLeaders As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SplitElementHasTagsWithoutLeaders {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementFailures Class


BuiltInFailures.ElementTypeFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ElementTypeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ElementTypeFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ElementTypeFailures
Visual Basic (Declaration)
Public NotInheritable Class ElementTypeFailures
Visual C++
public ref class ElementTypeFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ElementTypeFailures

See Also

BuiltInFailures..::.ElementTypeFailures Members


BuiltInFailures.ElementTypeFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElementTypeFailures Members
BuiltInFailures..::.ElementTypeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::.ElementTypeFailures Class


BuiltInFailures.ElementTypeFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElementTypeFailures Properties
BuiltInFailures..::.ElementTypeFailures Class See Also Send Feedback

The BuiltInFailures..::.ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::.ElementTypeFailures Class


NoDefaultType Property

[image]

Revit 2011 API
BuiltInFailures..::.ElementTypeFailures..::.NoDefaultType Property
BuiltInFailures..::.ElementTypeFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoDefaultType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoDefaultType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoDefaultType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementTypeFailures Class


WarnLastType1 Property

[image]

Revit 2011 API
BuiltInFailures..::.ElementTypeFailures..::.WarnLastType1 Property
BuiltInFailures..::.ElementTypeFailures Class See Also Send Feedback
Last type in system family '[Name]' cannot be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WarnLastType1 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WarnLastType1 As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WarnLastType1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElementTypeFailures Class


BuiltInFailures.ElevationFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ElevationFailures
Visual Basic (Declaration)
Public NotInheritable Class ElevationFailures
Visual C++
public ref class ElevationFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ElevationFailures

See Also

BuiltInFailures..::.ElevationFailures Members


BuiltInFailures.ElevationFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures Members
BuiltInFailures..::.ElevationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ElevationFailures type exposes the following members.

Properties

Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

See Also

BuiltInFailures..::.ElevationFailures Class


BuiltInFailures.ElevationFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures Properties
BuiltInFailures..::.ElevationFailures Class See Also Send Feedback

The BuiltInFailures..::.ElevationFailures type exposes the following members.

Properties

Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

See Also

BuiltInFailures..::.ElevationFailures Class


ElevationDetach Property

[image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures..::.ElevationDetach Property
BuiltInFailures..::.ElevationFailures Class See Also Send Feedback
An Elevation arrow can't keep its Crop Region extents attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElevationDetach { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElevationDetach As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElevationDetach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElevationFailures Class


IncompatibleElevationTagFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures..::.IncompatibleElevationTagFamily Property
BuiltInFailures..::.ElevationFailures Class See Also Send Feedback
Attempt to change elevation tag families to one with incompatible view directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IncompatibleElevationTagFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IncompatibleElevationTagFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IncompatibleElevationTagFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElevationFailures Class


WarnElevSheet Property

[image]

Revit 2011 API
BuiltInFailures..::.ElevationFailures..::.WarnElevSheet Property
BuiltInFailures..::.ElevationFailures Class See Also Send Feedback
An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WarnElevSheet { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WarnElevSheet As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WarnElevSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ElevationFailures Class


BuiltInFailures.EnergyAnalysisFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EnergyAnalysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class EnergyAnalysisFailures
Visual Basic (Declaration)
Public NotInheritable Class EnergyAnalysisFailures
Visual C++
public ref class EnergyAnalysisFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.EnergyAnalysisFailures

See Also

BuiltInFailures..::.EnergyAnalysisFailures Members


BuiltInFailures.EnergyAnalysisFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures Members
BuiltInFailures..::.EnergyAnalysisFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.EnergyAnalysisFailures type exposes the following members.

Properties

Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures Properties
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback

The BuiltInFailures..::.EnergyAnalysisFailures type exposes the following members.

Properties

Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ComputeRoomVolumeNotCheckedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ComputeRoomVolumeNotCheckedWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ComputeRoomVolumeNotCheckedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ComputeRoomVolumeNotCheckedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ComputeRoomVolumeNotCheckedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ModelWithNoConditionedSpacesWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ModelWithNoConditionedSpacesWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
The model has no conditioned spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModelWithNoConditionedSpacesWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModelWithNoConditionedSpacesWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModelWithNoConditionedSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ModelWithNoOccupiedSpacesWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ModelWithNoOccupiedSpacesWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
The model has no occupiable spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModelWithNoOccupiedSpacesWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModelWithNoOccupiedSpacesWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModelWithNoOccupiedSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoRoofsRoomBoundingWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoRoofsRoomBoundingWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoofsRoomBoundingWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRoofsRoomBoundingWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRoofsRoomBoundingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoRoofsSpacesBoundingWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoRoofsSpacesBoundingWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoofsSpacesBoundingWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRoofsSpacesBoundingWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRoofsSpacesBoundingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoRoomBoundingElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoRoomBoundingElements Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomBoundingElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRoomBoundingElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRoomBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoRoomBoundingElementsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoRoomBoundingElementsWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomBoundingElementsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRoomBoundingElementsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRoomBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoRoomsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoRoomsWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRoomsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRoomsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoSpaceBoundingElements Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoSpaceBoundingElements Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSpaceBoundingElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoSpaceBoundingElementsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoSpaceBoundingElementsWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElementsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSpaceBoundingElementsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


NoSpacesWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.NoSpacesWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpacesWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSpacesWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


PlenumWithNoCeilingWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.PlenumWithNoCeilingWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PlenumWithNoCeilingWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PlenumWithNoCeilingWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PlenumWithNoCeilingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ProblemWithLightingLoadWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ProblemWithLightingLoadWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithLightingLoadWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProblemWithLightingLoadWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProblemWithLightingLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ProblemWithPeopleLoadWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ProblemWithPeopleLoadWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithPeopleLoadWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProblemWithPeopleLoadWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPeopleLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ProblemWithPowerLoadWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ProblemWithPowerLoadWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithPowerLoadWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProblemWithPowerLoadWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPowerLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomGeometryCannotFindFreeFacesBoundingElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomGeometryCannotFindFreeFacesBoundingElement Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotFindFreeFacesBoundingElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomGeometryCannotFindFreeFacesBoundingElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotFindFreeFacesBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomGeometryCannotOverlapBoundingElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomGeometryCannotOverlapBoundingElement Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotOverlapBoundingElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomGeometryCannotOverlapBoundingElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotOverlapBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomGeometryCannotTrimBoundingElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomGeometryCannotTrimBoundingElement Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotTrimBoundingElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomGeometryCannotTrimBoundingElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotTrimBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomNotPlacedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomNotPlacedWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotPlacedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotPlacedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotPlacedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomNotUpperBoundedByElement Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomNotUpperBoundedByElement Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotUpperBoundedByElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotUpperBoundedByElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotUpperBoundedByElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


RoomVolumeNotComputedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.RoomVolumeNotComputedWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
[Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomVolumeNotComputedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomVolumeNotComputedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomVolumeNotComputedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


UndefinedRooms Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.UndefinedRooms Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedRooms { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedRooms As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


UndefinedSpaces Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.UndefinedSpaces Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedSpaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedSpaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


ZoneWithoutSpacesWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.EnergyAnalysisFailures..::.ZoneWithoutSpacesWarn Property
BuiltInFailures..::.EnergyAnalysisFailures Class See Also Send Feedback
This zone has no spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZoneWithoutSpacesWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZoneWithoutSpacesWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZoneWithoutSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.EnergyAnalysisFailures Class


BuiltInFailures.ExtrusionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Extrusions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ExtrusionFailures
Visual Basic (Declaration)
Public NotInheritable Class ExtrusionFailures
Visual C++
public ref class ExtrusionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ExtrusionFailures

See Also

BuiltInFailures..::.ExtrusionFailures Members


BuiltInFailures.ExtrusionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures Members
BuiltInFailures..::.ExtrusionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::.ExtrusionFailures Class


BuiltInFailures.ExtrusionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures Properties
BuiltInFailures..::.ExtrusionFailures Class See Also Send Feedback

The BuiltInFailures..::.ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::.ExtrusionFailures Class


CannotDrawExtrusions Property

[image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures..::.CannotDrawExtrusions Property
BuiltInFailures..::.ExtrusionFailures Class See Also Send Feedback
Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawExtrusions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ExtrusionFailures Class


CannotDrawExtrusionsError Property

[image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures..::.CannotDrawExtrusionsError Property
BuiltInFailures..::.ExtrusionFailures Class See Also Send Feedback
Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusionsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawExtrusionsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ExtrusionFailures Class


InvalidExtrusionCurveloop Property

[image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures..::.InvalidExtrusionCurveloop Property
BuiltInFailures..::.ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidExtrusionCurveloop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ExtrusionFailures Class


InvalidExtrusionCurveloopError Property

[image]

Revit 2011 API
BuiltInFailures..::.ExtrusionFailures..::.InvalidExtrusionCurveloopError Property
BuiltInFailures..::.ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloopError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidExtrusionCurveloopError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ExtrusionFailures Class


BuiltInFailures.FaceSplitterFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FaceSplitter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FaceSplitterFailures
Visual Basic (Declaration)
Public NotInheritable Class FaceSplitterFailures
Visual C++
public ref class FaceSplitterFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FaceSplitterFailures

See Also

BuiltInFailures..::.FaceSplitterFailures Members


BuiltInFailures.FaceSplitterFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures Members
BuiltInFailures..::.FaceSplitterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::.FaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures Properties
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback

The BuiltInFailures..::.FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::.FaceSplitterFailures Class


CannotUseCurvesForFaceSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.CannotUseCurvesForFaceSplit Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
The sketch cannot split the face of the highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUseCurvesForFaceSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotUseCurvesForFaceSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotUseCurvesForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


EndsNotOnEdgeError Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.EndsNotOnEdgeError Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnEdgeError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndsNotOnEdgeError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


InvalidClosedLoopsForFaceSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.InvalidClosedLoopsForFaceSplit Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidClosedLoopsForFaceSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidClosedLoopsForFaceSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidClosedLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


InvalidOpenLoopsForFaceSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.InvalidOpenLoopsForFaceSplit Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidOpenLoopsForFaceSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidOpenLoopsForFaceSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidOpenLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


LoopsDoNotSubdivideFace Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.LoopsDoNotSubdivideFace Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
Sketched loops must sub-divide the face into two or more completely enclosed regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsDoNotSubdivideFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopsDoNotSubdivideFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopsDoNotSubdivideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


LoopsOutsideFaceSplitError Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.LoopsOutsideFaceSplitError Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopsOutsideFaceSplitError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


NoFaceForSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.FaceSplitterFailures..::.NoFaceForSplit Property
BuiltInFailures..::.FaceSplitterFailures Class See Also Send Feedback
The highlighted element no longer contains a face that has been split by highlighted sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFaceForSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFaceForSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFaceForSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FaceSplitterFailures Class


BuiltInFailures.FamilyFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FamilyFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FamilyFailures
Visual Basic (Declaration)
Public NotInheritable Class FamilyFailures
Visual C++
public ref class FamilyFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FamilyFailures

See Also

BuiltInFailures..::.FamilyFailures Members


BuiltInFailures.FamilyFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures Members
BuiltInFailures..::.FamilyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FamilyFailures type exposes the following members.

Properties

Name | Description
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyNoExternalParametersCorruption | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeChangeTrackerSymbolGone | This change cannot be reverted because the previous type no longer exists.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParameterssForType | While loading Type '[Name]', parameter '[Name]': [Description]

See Also

BuiltInFailures..::.FamilyFailures Class


BuiltInFailures.FamilyFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures Properties
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback

The BuiltInFailures..::.FamilyFailures type exposes the following members.

Properties

Name | Description
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyNoExternalParametersCorruption | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeChangeTrackerSymbolGone | This change cannot be reverted because the previous type no longer exists.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParameterssForType | While loading Type '[Name]', parameter '[Name]': [Description]

See Also

BuiltInFailures..::.FamilyFailures Class


CannotChangeCategory Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotChangeCategory Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't change category of Family Instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeCategory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeCategory As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotChangeInstFam Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotChangeInstFam Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't change Instance's Family. Try changing Instance's Host to a Level first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeInstFam { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeInstFam As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeInstFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotConvertInstHostToWorkPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotConvertInstHostToWorkPlane Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertInstHostToWorkPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertInstHostToWorkPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstHostToWorkPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotConvertInstWorkPlaneToHost Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotConvertInstWorkPlaneToHost Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertInstWorkPlaneToHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertInstWorkPlaneToHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstWorkPlaneToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotCopyByPatternFamilies Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotCopyByPatternFamilies Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyByPatternFamilies { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyByPatternFamilies As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyByPatternFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotCopyInplaceFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotCopyInplaceFamily Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
In-place family groups cannot be copied between in-place families of the same project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyInplaceFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyInplaceFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyInplaceFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotCutRefPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotCutRefPlane Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't cut reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRefPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutRefPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotFindHost Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotFindHost Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFindHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFindHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotLoadImperialFamilyToMetricProject Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotLoadImperialFamilyToMetricProject Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't load an imperial Family into a metric Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadImperialFamilyToMetricProject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotLoadImperialFamilyToMetricProject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotLoadImperialFamilyToMetricProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotLoadMetricFamilyToImperialProject Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotLoadMetricFamilyToImperialProject Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't load a metric Family into an imperial Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadMetricFamilyToImperialProject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotLoadMetricFamilyToImperialProject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotLoadMetricFamilyToImperialProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotMakeType Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotMakeType Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotMakeTypeCB Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotMakeTypeCB Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeTypeCB { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeTypeCB As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeTypeCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotMakeTypeFamilySaved Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotMakeTypeFamilySaved Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeTypeFamilySaved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeTypeFamilySaved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeTypeFamilySaved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotPasteLabelsAcrossFamilies Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotPasteLabelsAcrossFamilies Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't paste Labels across Families of different Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteLabelsAcrossFamilies { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteLabelsAcrossFamilies As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteLabelsAcrossFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotPasteObject Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotPasteObject Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't paste some or all of the selected objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteObject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteObject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotRotateElement Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotRotateElement Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't rotate element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRotateElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRotateElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotSetFamilyTypeToNone Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotSetFamilyTypeToNone Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Cannot set Family Type to 'None';.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSetFamilyTypeToNone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSetFamilyTypeToNone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSetFamilyTypeToNone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CannotUnlockFamilyTemplate Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CannotUnlockFamilyTemplate Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't unlock alignments from Family Template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUnlockFamilyTemplate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotUnlockFamilyTemplate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotUnlockFamilyTemplate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantCopySelectionToNonStory Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantCopySelectionToNonStory Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't copy this selection to a non-story Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopySelectionToNonStory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantCopySelectionToNonStory As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantCopySelectionToNonStory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantEditWhileGrouped Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantEditWhileGrouped Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
You may not edit this parameter while the element is grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantEditWhileGrouped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantEditWhileGrouped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantEditWhileGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantMirrorInstWoHost Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantMirrorInstWoHost Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't mirror an instance without its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantMirrorInstWoHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantMirrorInstWoHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantMirrorInstWoHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantMoveFrozenInstance Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantMoveFrozenInstance Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantMoveFrozenInstance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantMoveFrozenInstance As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantMoveFrozenInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantPasteSelection Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantPasteSelection Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't paste selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantPasteSelection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantPasteSelection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantPasteSelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantPlaceInsertsError Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantPlaceInsertsError Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInsertsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantPlaceInsertsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInsertsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantPlaceInsertsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantPlaceInsertsWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInsertsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantPlaceInsertsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantPlaceInstanceError Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantPlaceInstanceError Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInstanceError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantPlaceInstanceError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInstanceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantPlaceInstanceWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantPlaceInstanceWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInstanceWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantPlaceInstanceWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInstanceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantSetSlantedColumnEndPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantSetSlantedColumnEndPlane Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Unable to determine slanted column end cut plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantSetSlantedColumnEndPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantSetSlantedColumnEndPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantSetSlantedColumnEndPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CantSolve Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CantSolve Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't find solution for formulas for Type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantSolve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantSolve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantSolve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ColumnAlreadyAttachedWillBeReattached Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ColumnAlreadyAttachedWillBeReattached Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The column is already attached. It will be detached and attached to the new target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAlreadyAttachedWillBeReattached { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnAlreadyAttachedWillBeReattached As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnAlreadyAttachedWillBeReattached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ColumnAndTargetAlreadyJoined Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ColumnAndTargetAlreadyJoined Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The column and target are joined, remove that join before attaching them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAlreadyJoined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnAndTargetAlreadyJoined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAlreadyJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ColumnHeightZeroBecauseOfInvalidOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ColumnHeightZeroBecauseOfInvalidOffset Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Change Offset Value so that Column height is not 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnHeightZeroBecauseOfInvalidOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnHeightZeroBecauseOfInvalidOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnHeightZeroBecauseOfInvalidOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ColumnTooLong Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ColumnTooLong Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
This column is too long. Maximum length is 30,000 ft.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTooLong { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnTooLong As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ContainsSharedSameNameFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ContainsSharedSameNameFamily Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContainsSharedSameNameFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContainsSharedSameNameFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContainsSharedSameNameFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CouldNotPlaceAdaptiveFamInst Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CouldNotPlaceAdaptiveFamInst Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Could not place Adaptive Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotPlaceAdaptiveFamInst { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CouldNotPlaceAdaptiveFamInst As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CouldNotPlaceAdaptiveFamInst {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


CustomFittingCreated Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.CustomFittingCreated Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Custom fitting was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CustomFittingCreated { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CustomFittingCreated As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CustomFittingCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


DeletingBadFamType Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.DeletingBadFamType Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingBadFamType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletingBadFamType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


DeletingBadFamTypeDumped Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.DeletingBadFamTypeDumped Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingBadFamTypeDumped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletingBadFamTypeDumped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamTypeDumped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


DummyHostMustBePerpendicularToXY Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.DummyHostMustBePerpendicularToXY Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Dummy host must be perpendicular to Z or Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DummyHostMustBePerpendicularToXY { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DummyHostMustBePerpendicularToXY As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DummyHostMustBePerpendicularToXY {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


DuplicateFamilyParameterNameWithSharedParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.DuplicateFamilyParameterNameWithSharedParameter Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Parameter '[Parameter]' has the same name with an existing shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateFamilyParameterNameWithSharedParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateFamilyParameterNameWithSharedParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateFamilyParameterNameWithSharedParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


DuplicateParamName Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.DuplicateParamName Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family parameters have duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateParamName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateParamName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateParamName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ElementTypeParameterized Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ElementTypeParameterized Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementTypeParameterized { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementTypeParameterized As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementTypeParameterized {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FailedToBecomeNonParametric Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FailedToBecomeNonParametric Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family failed to become non-parametric!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToBecomeNonParametric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToBecomeNonParametric As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToBecomeNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FailedToSetParameters Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FailedToSetParameters Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Failed to apply family parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetParameters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToSetParameters As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToSetParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FailedWhenLoadingFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FailedWhenLoadingFamily Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedWhenLoadingFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedWhenLoadingFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedWhenLoadingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyConnectorDeletedWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyConnectorDeletedWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyConnectorDeletedWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyConnectorDeletedWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyConnectorDeletedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyDoesntMatchSystemPropertiesDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyDoesntMatchSystemPropertiesDisconnected Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyNoExternalParametersCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyNoExternalParametersCorruption Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyNoExternalParametersCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyNoExternalParametersError Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyNoExternalParametersError Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyNoExternalParametersError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyNoExternalParametersWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyNoExternalParametersWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyNoExternalParametersWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyNotFitHostShape Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyNotFitHostShape Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The host shape has changed and the family is no longer appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNotFitHostShape { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyNotFitHostShape As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyNotFitHostShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyOverconstraint Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyOverconstraint Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family. Cannot set Family Type to <None>.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyOverconstraint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyOverconstraint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyOverconstraintCB Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyOverconstraintCB Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyOverconstraintCB { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyOverconstraintCB As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraintCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FamilyParameterNoExist Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FamilyParameterNoExist Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The parameter [Name] doesn't exist in the Family. It will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyParameterNoExist { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyParameterNoExist As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyParameterNoExist {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FormulaBasedParameterCannotBeChanged Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FormulaBasedParameterCannotBeChanged Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormulaBasedParameterCannotBeChanged { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormulaBasedParameterCannotBeChanged As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormulaBasedParameterCannotBeChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FormulasFailedForType Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FormulasFailedForType Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
"Can't satisfy formulas for type [Family Symbol].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormulasFailedForType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormulasFailedForType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormulasFailedForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FrozenBecauseFaceGone Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FrozenBecauseFaceGone Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FrozenBecauseFaceGone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FrozenBecauseFaceGone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseFaceGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


FrozenBecauseMonitorRelationshipGone Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.FrozenBecauseMonitorRelationshipGone Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FrozenBecauseMonitorRelationshipGone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FrozenBecauseMonitorRelationshipGone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseMonitorRelationshipGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


HighlightedElementFamRefsInvalidError Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.HighlightedElementFamRefsInvalidError Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


HighlightedElementFamRefsInvalidWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.HighlightedElementFamRefsInvalidWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


InstMayCutMoreOrFewerHosts Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.InstMayCutMoreOrFewerHosts Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InstMayCutMoreOrFewerHosts { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InstMayCutMoreOrFewerHosts As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InstMayCutMoreOrFewerHosts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


InstOutsideFaceBoundary Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.InstOutsideFaceBoundary Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Instance origin does not lie on host face. Instance will lose association to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InstOutsideFaceBoundary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InstOutsideFaceBoundary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InstOutsideFaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


InvalidContextForAdaptivePlacement Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.InvalidContextForAdaptivePlacement Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidContextForAdaptivePlacement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidContextForAdaptivePlacement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidContextForAdaptivePlacement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


InvalidParameterValue Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.InvalidParameterValue Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Parameter [Caption] has an invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidParameterValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidParameterValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidParameterValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


InvalidSlantedColumnOffsets Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.InvalidSlantedColumnOffsets Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSlantedColumnOffsets { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSlantedColumnOffsets As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSlantedColumnOffsets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


NoInstparamFormulas Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.NoInstparamFormulas Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoInstparamFormulas { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoInstparamFormulas As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoInstparamFormulas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


NonGenericAnnotationsOutsideLegend Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.NonGenericAnnotationsOutsideLegend Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Only Generic Annotations may be copied between Legends and other Views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonGenericAnnotationsOutsideLegend { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonGenericAnnotationsOutsideLegend As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonGenericAnnotationsOutsideLegend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


NotFamilyFile Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.NotFamilyFile Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The selected file is not a Family File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotFamilyFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotFamilyFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotFamilyFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ProfileContainsNoLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ProfileContainsNoLoops Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Profile type '[Family Symbol]' contains no loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileContainsNoLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProfileContainsNoLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProfileContainsNoLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ReferencePlanesOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ReferencePlanesOverconstrained Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Reference Planes are overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencePlanesOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReferencePlanesOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReferencePlanesOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


SetbackTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.SetbackTooLarge Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Setback computations are too large for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SetbackTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SetbackTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SetbackTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


SharedParameterReplacedByBuiltInOne Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.SharedParameterReplacedByBuiltInOne Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SharedParameterReplacedByBuiltInOne { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SharedParameterReplacedByBuiltInOne As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SharedParameterReplacedByBuiltInOne {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


SketchCannotBeAutomaticallyDimensioned Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.SketchCannotBeAutomaticallyDimensioned Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchCannotBeAutomaticallyDimensioned { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchCannotBeAutomaticallyDimensioned As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchCannotBeAutomaticallyDimensioned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


SlantedColumnEndCutPlaneIsParallelToGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.SlantedColumnEndCutPlaneIsParallelToGeometry Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnEndCutPlaneIsParallelToGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlantedColumnEndCutPlaneIsParallelToGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndCutPlaneIsParallelToGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


SlantedColumnEndPlanesHaveFlipped Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.SlantedColumnEndPlanesHaveFlipped Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Position of end cut planes has resulted in a slanted column without any geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnEndPlanesHaveFlipped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlantedColumnEndPlanesHaveFlipped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndPlanesHaveFlipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


StructuralColumnAttachedToNonStructuralTarget Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.StructuralColumnAttachedToNonStructuralTarget Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The structural column is attached to a non-structural target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructuralColumnAttachedToNonStructuralTarget { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructuralColumnAttachedToNonStructuralTarget As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructuralColumnAttachedToNonStructuralTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


TitleblockBadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.TitleblockBadViewType Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Titleblocks can only be placed on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TitleblockBadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TitleblockBadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TitleblockBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


TryingToAttachWhenJoined Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.TryingToAttachWhenJoined Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The column and target are joined. The attachment has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TryingToAttachWhenJoined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TryingToAttachWhenJoined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TryingToAttachWhenJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


TypeChangeTrackerSymbolGone Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.TypeChangeTrackerSymbolGone Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
This change cannot be reverted because the previous type no longer exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TypeChangeTrackerSymbolGone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TypeChangeTrackerSymbolGone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TypeChangeTrackerSymbolGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


TypeRecursiveElementIdParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.TypeRecursiveElementIdParameter Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Type's parameter cannot recursively point to the type itself.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TypeRecursiveElementIdParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TypeRecursiveElementIdParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TypeRecursiveElementIdParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


UnableGenerateTrussByFamilyAndOrientation Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.UnableGenerateTrussByFamilyAndOrientation Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Revit is unable to generate a truss using the current Layout Family and Truss orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableGenerateTrussByFamilyAndOrientation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableGenerateTrussByFamilyAndOrientation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableGenerateTrussByFamilyAndOrientation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


UnexpectedFamilyChangeResultsError Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.UnexpectedFamilyChangeResultsError Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


UnexpectedFamilyChangeResultsWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.UnexpectedFamilyChangeResultsWarning Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


ValueOutOfRange Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.ValueOutOfRange Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
The value must be from 0.0 to 1.0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ValueOutOfRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


WhileLoadingFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.WhileLoadingFamily Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
While loading family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WhileLoadingFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WhileLoadingFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


WhileLoadingFamilyShared Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.WhileLoadingFamilyShared Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
While loading shared family '[Family Name]' from family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WhileLoadingFamilyShared { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WhileLoadingFamilyShared As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamilyShared {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


WhileScanningParameterssForType Property

[image]

Revit 2011 API
BuiltInFailures..::.FamilyFailures..::.WhileScanningParameterssForType Property
BuiltInFailures..::.FamilyFailures Class See Also Send Feedback
While loading Type '[Name]', parameter '[Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WhileScanningParameterssForType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WhileScanningParameterssForType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WhileScanningParameterssForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FamilyFailures Class


BuiltInFailures.FilledRegionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FilledRegion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FilledRegionFailures
Visual Basic (Declaration)
Public NotInheritable Class FilledRegionFailures
Visual C++
public ref class FilledRegionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FilledRegionFailures

See Also

BuiltInFailures..::.FilledRegionFailures Members


BuiltInFailures.FilledRegionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures Members
BuiltInFailures..::.FilledRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::.FilledRegionFailures Class


BuiltInFailures.FilledRegionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures Properties
BuiltInFailures..::.FilledRegionFailures Class See Also Send Feedback

The BuiltInFailures..::.FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::.FilledRegionFailures Class


BadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures..::.BadViewType Property
BuiltInFailures..::.FilledRegionFailures Class See Also Send Feedback
[Filled Region Name] can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FilledRegionFailures Class


CannotDrawFilledRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures..::.CannotDrawFilledRegion Property
BuiltInFailures..::.FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawFilledRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FilledRegionFailures Class


CannotDrawFilledRegionError Property

[image]

Revit 2011 API
BuiltInFailures..::.FilledRegionFailures..::.CannotDrawFilledRegionError Property
BuiltInFailures..::.FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegionError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawFilledRegionError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FilledRegionFailures Class


BuiltInFailures.FloorFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FloorFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FloorFailures
Visual Basic (Declaration)
Public NotInheritable Class FloorFailures
Visual C++
public ref class FloorFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FloorFailures

See Also

BuiltInFailures..::.FloorFailures Members


BuiltInFailures.FloorFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FloorFailures Members
BuiltInFailures..::.FloorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::.FloorFailures Class


BuiltInFailures.FloorFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FloorFailures Properties
BuiltInFailures..::.FloorFailures Class See Also Send Feedback

The BuiltInFailures..::.FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::.FloorFailures Class


FloorSlopeExceedsThreshold Property

[image]

Revit 2011 API
BuiltInFailures..::.FloorFailures..::.FloorSlopeExceedsThreshold Property
BuiltInFailures..::.FloorFailures Class See Also Send Feedback
Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorSlopeExceedsThreshold { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorSlopeExceedsThreshold As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FloorFailures Class


BuiltInFailures.FluidFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FluidFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fluid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FluidFailures
Visual Basic (Declaration)
Public NotInheritable Class FluidFailures
Visual C++
public ref class FluidFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FluidFailures

See Also

BuiltInFailures..::.FluidFailures Members


BuiltInFailures.FluidFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FluidFailures Members
BuiltInFailures..::.FluidFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FluidFailures type exposes the following members.

Properties

Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
UndefinedFluidUnit | Undefined fluid unit: '[Unit Type Name]'

See Also

BuiltInFailures..::.FluidFailures Class


BuiltInFailures.FluidFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FluidFailures Properties
BuiltInFailures..::.FluidFailures Class See Also Send Feedback

The BuiltInFailures..::.FluidFailures type exposes the following members.

Properties

Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
UndefinedFluidUnit | Undefined fluid unit: '[Unit Type Name]'

See Also

BuiltInFailures..::.FluidFailures Class


UndefinedFluidType Property

[image]

Revit 2011 API
BuiltInFailures..::.FluidFailures..::.UndefinedFluidType Property
BuiltInFailures..::.FluidFailures Class See Also Send Feedback
The fluid type '[Type Name]' is not defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedFluidType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FluidFailures Class


UndefinedFluidUnit Property

[image]

Revit 2011 API
BuiltInFailures..::.FluidFailures..::.UndefinedFluidUnit Property
BuiltInFailures..::.FluidFailures Class See Also Send Feedback
Undefined fluid unit: '[Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidUnit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FluidFailures Class


BuiltInFailures.FormFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class FormFailures
Visual Basic (Declaration)
Public NotInheritable Class FormFailures
Visual C++
public ref class FormFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.FormFailures

See Also

BuiltInFailures..::.FormFailures Members


BuiltInFailures.FormFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.FormFailures Members
BuiltInFailures..::.FormFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
NoSoludGeometryForVoidFormsInMass | This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::.FormFailures Class


BuiltInFailures.FormFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.FormFailures Properties
BuiltInFailures..::.FormFailures Class See Also Send Feedback

The BuiltInFailures..::.FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
NoSoludGeometryForVoidFormsInMass | This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::.FormFailures Class


AddProfileFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.AddProfileFailure Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Failed to Add Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AddProfileFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AddProfileFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AddProfileFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


DissolveNoValidInputs Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.DissolveNoValidInputs Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
No form elements selected to dissolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DissolveNoValidInputs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DissolveNoValidInputs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DissolveNoValidInputs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


DissolveUnableToDissolveForm Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.DissolveUnableToDissolveForm Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Unable to dissolve form element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DissolveUnableToDissolveForm { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DissolveUnableToDissolveForm As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DissolveUnableToDissolveForm {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormCreationInvalidGeomCombination Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormCreationInvalidGeomCombination Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormCreationInvalidGeomCombination { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormCreationInvalidGeomCombination As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormCreationInvalidGeomCombination {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormElemRegenFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormElemRegenFailure Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormElemRegenFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormElemRegenFailureError Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormElemRegenFailureError Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenFailureError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormElemRegenFailureError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormElemRegenSelfIntersection Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormElemRegenSelfIntersection Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Unable to create form element: self-intersecting or singular geometry would result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormElemRegenSelfIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormElemRegenSelfIntersectionReorderProfiles Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormElemRegenSelfIntersectionReorderProfiles Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersectionReorderProfiles { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormElemRegenSelfIntersectionReorderProfiles As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionReorderProfiles {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


FormElemRegenSelfIntersectionResetConnections Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.FormElemRegenSelfIntersectionResetConnections Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersectionResetConnections { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormElemRegenSelfIntersectionResetConnections As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionResetConnections {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


NoSoludGeometryForVoidFormsInMass Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.NoSoludGeometryForVoidFormsInMass Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSoludGeometryForVoidFormsInMass { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSoludGeometryForVoidFormsInMass As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSoludGeometryForVoidFormsInMass {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


OpenProfileMultiSegmentSweepsNotSupported Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.OpenProfileMultiSegmentSweepsNotSupported Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
An open profile cannot be swept along a multi-segment path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenProfileMultiSegmentSweepsNotSupported { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenProfileMultiSegmentSweepsNotSupported As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenProfileMultiSegmentSweepsNotSupported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


VoidFormsNotUsed Property

[image]

Revit 2011 API
BuiltInFailures..::.FormFailures..::.VoidFormsNotUsed Property
BuiltInFailures..::.FormFailures Class See Also Send Feedback
Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VoidFormsNotUsed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VoidFormsNotUsed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VoidFormsNotUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.FormFailures Class


BuiltInFailures.GeneralFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about GeneralFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GeneralFailures
Visual Basic (Declaration)
Public NotInheritable Class GeneralFailures
Visual C++
public ref class GeneralFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GeneralFailures

See Also

BuiltInFailures..::.GeneralFailures Members


BuiltInFailures.GeneralFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures Members
BuiltInFailures..::.GeneralFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GeneralFailures type exposes the following members.

Properties

Name | Description
ActionCancelled | A serious error has occurred. The current action has been cancelled.
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
DuplicateValue | Elements have duplicate '[Value]' values.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidValue | Invalid value.
LicenseLostFatalError | The connection to your network license server has been lost and the 2 hour grace period for your network license has expired. The application will be closed. You have the opportunity to save recovery files for all of your changed projects. Choose “SaveAs and Exit” to save a recovery file of the open project(s), or choose “Exit Program” to proceed without saving any files.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].

See Also

BuiltInFailures..::.GeneralFailures Class


BuiltInFailures.GeneralFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures Properties
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback

The BuiltInFailures..::.GeneralFailures type exposes the following members.

Properties

Name | Description
ActionCancelled | A serious error has occurred. The current action has been cancelled.
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
DuplicateValue | Elements have duplicate '[Value]' values.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidValue | Invalid value.
LicenseLostFatalError | The connection to your network license server has been lost and the 2 hour grace period for your network license has expired. The application will be closed. You have the opportunity to save recovery files for all of your changed projects. Choose “SaveAs and Exit” to save a recovery file of the open project(s), or choose “Exit Program” to proceed without saving any files.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].

See Also

BuiltInFailures..::.GeneralFailures Class


ActionCancelled Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.ActionCancelled Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A serious error has occurred. The current action has been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ActionCancelled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ActionCancelled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ActionCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


CannotFixProblem Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.CannotFixProblem Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Failed to fix problem. Action has to be cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFixProblem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFixProblem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFixProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


CannotSetParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.CannotSetParameter Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Cant set parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSetParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSetParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSetParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


CharactersNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.CharactersNotAllowed Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CharactersNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CharactersNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CharactersNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


ConvertingOldAxisToNormal Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.ConvertingOldAxisToNormal Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
This operation will convert the existing axis of revolution to a normal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertingOldAxisToNormal { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConvertingOldAxisToNormal As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConvertingOldAxisToNormal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


DuplicateValue Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.DuplicateValue Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Elements have duplicate '[Value]' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


EnterValidRealGreaterThan Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.EnterValidRealGreaterThan Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Enter a number greater than [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValidRealGreaterThan { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EnterValidRealGreaterThan As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EnterValidRealGreaterThan {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


EnterValueBetween Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.EnterValueBetween Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueBetween { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


ErrorResolved Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.ErrorResolved Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Error "[Text]" was automatically resolved by "[Resolution]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ErrorResolved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ErrorResolved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ErrorResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


FailedToOpenFile Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.FailedToOpenFile Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Failed to open file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToOpenFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToOpenFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToOpenFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


FailedToReadLine Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.FailedToReadLine Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Failed to read line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToReadLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToReadLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToReadLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericCorruption Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericError Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericErrorNone Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericErrorNone Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericErrorNone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericErrorNone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericErrorNone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericFatalError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericFatalError Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericFatalError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericFatalError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericNonFatalError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericNonFatalError Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericNonFatalError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericNonFatalError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericNonFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


GenericWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.GenericWarning Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GenericWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GenericWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GenericWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


InaccuracyDetected Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.InaccuracyDetected Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
A geometric inaccuracy was found in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccuracyDetected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccuracyDetected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccuracyDetected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


InternalProblemsParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.InternalProblemsParameter Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Parameter cannot be changed due to internal problems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InternalProblemsParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InternalProblemsParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InternalProblemsParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


InvalidInput Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.InvalidInput Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidInput { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidInput As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidInput {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


InvalidInputWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.InvalidInputWarn Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidInputWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidInputWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidInputWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


InvalidValue Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.InvalidValue Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidValue { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidValue As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


LicenseLostFatalError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.LicenseLostFatalError Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
The connection to your network license server has been lost and the 2 hour grace period for your network license has expired. The application will be closed. You have the opportunity to save recovery files for all of your changed projects. Choose “SaveAs and Exit” to save a recovery file of the open project(s), or choose “Exit Program” to proceed without saving any files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LicenseLostFatalError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LicenseLostFatalError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LicenseLostFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


NameInUse Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.NameInUse Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
The name "[Name]" is already in use.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NameInUse { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NameInUse As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NameInUse {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


NameIsEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.NameIsEmpty Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Name is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NameIsEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NameIsEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NameIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


NameNotUnique Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.NameNotUnique Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
The name entered is already in use. Enter a unique name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NameNotUnique { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NameNotUnique As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NameNotUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


NewElementInvisibleInCurrentView Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.NewElementInvisibleInCurrentView Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
The newly created object is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NewElementInvisibleInCurrentView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NewElementInvisibleInCurrentView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NewElementInvisibleInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


NoRelatedWarnings Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.NoRelatedWarnings Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Document doesn't contain any warnings related to these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRelatedWarnings { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRelatedWarnings As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRelatedWarnings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


ParameterValueNotInRange Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.ParameterValueNotInRange Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
The value for [Parameter Name] must be between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ParameterValueNotInRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ParameterValueNotInRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ParameterValueNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


SeriousElementReferenceCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.SeriousElementReferenceCorruption Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


TransactionFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.TransactionFailed Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TransactionFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TransactionFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TransactionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


TransactionFailedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.TransactionFailedWarn Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TransactionFailedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TransactionFailedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TransactionFailedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


UnspecifiedError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.UnspecifiedError Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnspecifiedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnspecifiedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnspecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


ValueOutOfRange Property

[image]

Revit 2011 API
BuiltInFailures..::.GeneralFailures..::.ValueOutOfRange Property
BuiltInFailures..::.GeneralFailures Class See Also Send Feedback
Value is out of range ! Please enter a number between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ValueOutOfRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeneralFailures Class


BuiltInFailures.GenericFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GenericFailures Class
BuiltInFailures Class Members See Also Send Feedback
Generic failures that may apply to any Revit Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GenericFailures
Visual Basic (Declaration)
Public NotInheritable Class GenericFailures
Visual C++
public ref class GenericFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GenericFailures

See Also

BuiltInFailures..::.GenericFailures Members


BuiltInFailures.GenericFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GenericFailures Members
BuiltInFailures..::.GenericFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GenericFailures type exposes the following members.

Properties

Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

See Also

BuiltInFailures..::.GenericFailures Class


BuiltInFailures.GenericFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GenericFailures Properties
BuiltInFailures..::.GenericFailures Class See Also Send Feedback

The BuiltInFailures..::.GenericFailures type exposes the following members.

Properties

Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

See Also

BuiltInFailures..::.GenericFailures Class


ElementsInInvalidContext Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericFailures..::.ElementsInInvalidContext Property
BuiltInFailures..::.GenericFailures Class See Also Send Feedback
There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsInInvalidContext { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsInInvalidContext As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsInInvalidContext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericFailures Class


BuiltInFailures.GenericMEPFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures applicable to different mechanical, electrical and piping Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GenericMEPFailures
Visual Basic (Declaration)
Public NotInheritable Class GenericMEPFailures
Visual C++
public ref class GenericMEPFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GenericMEPFailures

See Also

BuiltInFailures..::.GenericMEPFailures Members


BuiltInFailures.GenericMEPFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures Members
BuiltInFailures..::.GenericMEPFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GenericMEPFailures type exposes the following members.

Properties

Name | Description
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.

See Also

BuiltInFailures..::.GenericMEPFailures Class


BuiltInFailures.GenericMEPFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures Properties
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback

The BuiltInFailures..::.GenericMEPFailures type exposes the following members.

Properties

Name | Description
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.

See Also

BuiltInFailures..::.GenericMEPFailures Class


FlowConfigMismatch Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures..::.FlowConfigMismatch Property
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FlowConfigMismatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FlowConfigMismatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FlowConfigMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericMEPFailures Class


FlowDirectionMismatch Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures..::.FlowDirectionMismatch Property
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FlowDirectionMismatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FlowDirectionMismatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FlowDirectionMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericMEPFailures Class


MaxWidthAndHeightReached Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures..::.MaxWidthAndHeightReached Property
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback
Maximum width and height reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MaxWidthAndHeightReached { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MaxWidthAndHeightReached As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MaxWidthAndHeightReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericMEPFailures Class


SegmentIsTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures..::.SegmentIsTooShort Property
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback
The segment is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentIsTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentIsTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentIsTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericMEPFailures Class


SizingFailedZeroFlow Property

[image]

Revit 2011 API
BuiltInFailures..::.GenericMEPFailures..::.SizingFailedZeroFlow Property
BuiltInFailures..::.GenericMEPFailures Class See Also Send Feedback
Sizing failed. Flow for section is 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SizingFailedZeroFlow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SizingFailedZeroFlow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SizingFailedZeroFlow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GenericMEPFailures Class


BuiltInFailures.GeometryFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about GeometryFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GeometryFailures
Visual Basic (Declaration)
Public NotInheritable Class GeometryFailures
Visual C++
public ref class GeometryFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GeometryFailures

See Also

BuiltInFailures..::.GeometryFailures Members


BuiltInFailures.GeometryFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures Members
BuiltInFailures..::.GeometryFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CreateCoreGeometryFailed | Failed to create core geometries.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
PolygonSegmentTooShort | Polygon segment too short
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::.GeometryFailures Class


BuiltInFailures.GeometryFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures Properties
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback

The BuiltInFailures..::.GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CreateCoreGeometryFailed | Failed to create core geometries.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
PolygonSegmentTooShort | Polygon segment too short
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::.GeometryFailures Class


CannotFindClosest Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.CannotFindClosest Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Cannot find closest points within lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindClosest { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFindClosest As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFindClosest {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


ConvertFaceRegionsToFacesCrashed Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.ConvertFaceRegionsToFacesCrashed Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesCrashed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConvertFaceRegionsToFacesCrashed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


ConvertFaceRegionsToFacesFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.ConvertFaceRegionsToFacesFailed Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConvertFaceRegionsToFacesFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


CreateCoreGeometryFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.CreateCoreGeometryFailed Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


CurveAndSurfaceDoNotIntersect Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.CurveAndSurfaceDoNotIntersect Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Curve and Surface do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveAndSurfaceDoNotIntersect { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveAndSurfaceDoNotIntersect As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveAndSurfaceDoNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


CurveDriverError Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.CurveDriverError Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Element's internal join data is corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveDriverError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveDriverError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveDriverError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


CurveProjectTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.CurveProjectTooShort Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
The projection of the line in this view is too short to create a new Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveProjectTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveProjectTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveProjectTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


ElementIsTooThin Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.ElementIsTooThin Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
[Element] is too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementIsTooThin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementIsTooThin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementIsTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


ElementTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.ElementTooSmall Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Element is too small on screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


FailedReplaceCurveElemCurveDriver Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.FailedReplaceCurveElemCurveDriver Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Failed to replace curve elem curve driver.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedReplaceCurveElemCurveDriver { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedReplaceCurveElemCurveDriver As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedReplaceCurveElemCurveDriver {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


FailedUpdateCurveChain Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.FailedUpdateCurveChain Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Failed to update curve chain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedUpdateCurveChain { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedUpdateCurveChain As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedUpdateCurveChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


FailToConvertLine Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.FailToConvertLine Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Unable to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailToConvertLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailToConvertLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailToConvertLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


LineArcTangentFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.LineArcTangentFailure Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Can't keep arc element and straight line element tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LineArcTangentFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LineArcTangentFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LineArcTangentFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


PolygonSegmentTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.PolygonSegmentTooShort Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Polygon segment too short

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PolygonSegmentTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PolygonSegmentTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PolygonSegmentTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


SymbolicLineInvalidPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.SymbolicLineInvalidPlane Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
Symbolic Element refers to a Work Plane with unacceptable normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SymbolicLineInvalidPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SymbolicLineInvalidPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SymbolicLineInvalidPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


TooManyFacesEdges Property

[image]

Revit 2011 API
BuiltInFailures..::.GeometryFailures..::.TooManyFacesEdges Property
BuiltInFailures..::.GeometryFailures Class See Also Send Feedback
This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyFacesEdges { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManyFacesEdges As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManyFacesEdges {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GeometryFailures Class


BuiltInFailures.GridFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GridFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GridFailures
Visual Basic (Declaration)
Public NotInheritable Class GridFailures
Visual C++
public ref class GridFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GridFailures

See Also

BuiltInFailures..::.GridFailures Members


BuiltInFailures.GridFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GridFailures Members
BuiltInFailures..::.GridFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::.GridFailures Class


BuiltInFailures.GridFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GridFailures Properties
BuiltInFailures..::.GridFailures Class See Also Send Feedback

The BuiltInFailures..::.GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::.GridFailures Class


GridEndSegmentsLengthTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.GridFailures..::.GridEndSegmentsLengthTooShort Property
BuiltInFailures..::.GridFailures Class See Also Send Feedback
The end segment length for a grid must be at least [Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridEndSegmentsLengthTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridEndSegmentsLengthTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridEndSegmentsLengthTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GridFailures Class


GridlineAxisTooClose Property

[image]

Revit 2011 API
BuiltInFailures..::.GridFailures..::.GridlineAxisTooClose Property
BuiltInFailures..::.GridFailures Class See Also Send Feedback
Axis of gridlines should not change order or be closer than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlineAxisTooClose { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlineAxisTooClose As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GridFailures Class


GridlineAxisTooFar Property

[image]

Revit 2011 API
BuiltInFailures..::.GridFailures..::.GridlineAxisTooFar Property
BuiltInFailures..::.GridFailures Class See Also Send Feedback
Axis of gridlines should not be further than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GridlineAxisTooFar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GridlineAxisTooFar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooFar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GridFailures Class


BuiltInFailures.GroupFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to groups and their behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class GroupFailures
Visual Basic (Declaration)
Public NotInheritable Class GroupFailures
Visual C++
public ref class GroupFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.GroupFailures

See Also

BuiltInFailures..::.GroupFailures Members


BuiltInFailures.GroupFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.GroupFailures Members
BuiltInFailures..::.GroupFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddDeletedElementToGroup | Elements that are already members of one group cannot be added to another group.
CannotAddDetailBackgroundToNon | Cannot add detail element displayed in background to group with details displayed in foreground.
CannotAddDetailNonToBackground | Cannot add detail element displayed in foreground to group with detail elements displayed in background.
CannotAddGroupedInplaceFamElemToGroup | Cannot add elements that are grouped inside in-place families directly to project groups.
CannotAddGroupSubordinate | This element requires another element that cannot be added to the group.
CannotAddHost | The host element cannot be added to the group.
CannotAddLabeledDimToGroup | Cannot add view specific labeled family dimensions to attached groups.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetMasterGroupId | Unable to set master id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotMixBackAndForegroundDetailUngroup | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupPropagationWarning | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationWarningSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroupError | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::.GroupFailures Class


BuiltInFailures.GroupFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.GroupFailures Properties
BuiltInFailures..::.GroupFailures Class See Also Send Feedback

The BuiltInFailures..::.GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddDeletedElementToGroup | Elements that are already members of one group cannot be added to another group.
CannotAddDetailBackgroundToNon | Cannot add detail element displayed in background to group with details displayed in foreground.
CannotAddDetailNonToBackground | Cannot add detail element displayed in foreground to group with detail elements displayed in background.
CannotAddGroupedInplaceFamElemToGroup | Cannot add elements that are grouped inside in-place families directly to project groups.
CannotAddGroupSubordinate | This element requires another element that cannot be added to the group.
CannotAddHost | The host element cannot be added to the group.
CannotAddLabeledDimToGroup | Cannot add view specific labeled family dimensions to attached groups.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetMasterGroupId | Unable to set master id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotMixBackAndForegroundDetailUngroup | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupPropagationWarning | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationWarningSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroupError | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::.GroupFailures Class


AdditionalElementsRequired Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AdditionalElementsRequired Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequired { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AdditionalElementsRequired As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequired {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AdditionalElementsRequiredRemove Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AdditionalElementsRequiredRemove Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequiredRemove { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AdditionalElementsRequiredRemove As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequiredRemove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AllElementsRemovedFromGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AllElementsRemovedFromGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group "[Type Name]" is now empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AllElementsRemovedFromGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllElementsRemovedFromGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AllElementsRemovedFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AtomTouchedNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AtomTouchedNotAllowed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AtomTouchedNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AtomTouchedNotAllowedDelete Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AtomTouchedNotAllowedDelete Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowedDelete { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AtomTouchedNotAllowedDelete As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowedDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AtomViolationWhenMultiPlacedInstances Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AtomViolationWhenMultiPlacedInstances Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AtomViolationWhenMultiPlacedInstances { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AtomViolationWhenMultiPlacedInstances As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AtomViolationWhenMultiPlacedInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AtomViolationWhenOnePlaceInstance Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AtomViolationWhenOnePlaceInstance Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AtomViolationWhenOnePlaceInstance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AtomViolationWhenOnePlaceInstance As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AtomViolationWhenOnePlaceInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AttachedGroupNoMirror Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AttachedGroupNoMirror Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Attached detail groups cannot be mirrored without also mirroring their parent group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AttachedGroupNoMirror { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AttachedGroupNoMirror As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AttachedGroupNoMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


AttachedGroupNoPasteToView Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.AttachedGroupNoPasteToView Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AttachedGroupNoPasteToView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AttachedGroupNoPasteToView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AttachedGroupNoPasteToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


BadProblemWithGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.BadProblemWithGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The operation performed affects groups in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadProblemWithGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadProblemWithGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadProblemWithGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


BadViewForAttachedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.BadViewForAttachedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewForAttachedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


BadViewForAttachedGroupWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.BadViewForAttachedGroupWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroupWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewForAttachedGroupWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddAlreadyMemberToDiffGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddAlreadyMemberToDiffGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Elements that are already members of one group cannot be added to another group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddAlreadyMemberToDiffGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddAlreadyMemberToDiffGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddAlreadyMemberToDiffGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddDeletedElementToGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddDeletedElementToGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Elements that are already members of one group cannot be added to another group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddDeletedElementToGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddDeletedElementToGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddDeletedElementToGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddDetailBackgroundToNon Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddDetailBackgroundToNon Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot add detail element displayed in background to group with details displayed in foreground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddDetailBackgroundToNon { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddDetailBackgroundToNon As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddDetailBackgroundToNon {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddDetailNonToBackground Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddDetailNonToBackground Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot add detail element displayed in foreground to group with detail elements displayed in background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddDetailNonToBackground { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddDetailNonToBackground As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddDetailNonToBackground {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddGroupedInplaceFamElemToGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddGroupedInplaceFamElemToGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot add elements that are grouped inside in-place families directly to project groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddGroupedInplaceFamElemToGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddGroupedInplaceFamElemToGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddGroupedInplaceFamElemToGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddGroupSubordinate Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddGroupSubordinate Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
This element requires another element that cannot be added to the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddGroupSubordinate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddGroupSubordinate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddGroupSubordinate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddHost Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddHost Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The host element cannot be added to the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddLabeledDimToGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddLabeledDimToGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot add view specific labeled family dimensions to attached groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddLabeledDimToGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddLabeledDimToGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddLabeledDimToGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddToGroupFormat Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddToGroupFormat Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddToGroupFormat As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormat {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotAddToGroupFormatWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotAddToGroupFormatWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormatWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotAddToGroupFormatWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormatWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotCopyGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotCopyGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to copy the selected group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotCreateGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotCreateGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot create group of these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotCreateGroupWithInvalidReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotCreateGroupWithInvalidReferences Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGroupWithInvalidReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGroupWithInvalidReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroupWithInvalidReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotFinishGroupInSketchMode Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotFinishGroupInSketchMode Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't Finish Group while in Sketch Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinishGroupInSketchMode { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotFinishGroupInSketchMode As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotFinishGroupInSketchMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotLinkAnnotationsForSomeViews Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotLinkAnnotationsForSomeViews Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Annotations for some views cannot be displayed from linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLinkAnnotationsForSomeViews { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotLinkAnnotationsForSomeViews As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotLinkAnnotationsForSomeViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotPlaceGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotPlaceGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't place Group from browser. Try copy/pasting existing copy of the Group instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotReloadWithFile Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotReloadWithFile Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group [Type Name] cannot be reloaded from file [File Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotReloadWithFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotReloadWithFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotReloadWithFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotRemoveGroupMemberConstraint Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotRemoveGroupMemberConstraint Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveGroupMemberConstraint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotRemoveGroupMemberConstraintWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotRemoveGroupMemberConstraintWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveGroupMemberConstraintWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraintWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraintWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotRemoveSubordFromGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotRemoveSubordFromGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRemoveSubordFromGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotRemoveSubordFromGroupWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotRemoveSubordFromGroupWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroupWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRemoveSubordFromGroupWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotSaveGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotSaveGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't save Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSaveGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSaveGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSaveGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


CannotSwapNestedGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.CannotSwapNestedGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't replace because one Group is contained in the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSwapNestedGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSwapNestedGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSwapNestedGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ChildrenDeletedOnGroupSwap Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ChildrenDeletedOnGroupSwap Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Some dependent elements were deleted by changing group type and cannot be retained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ChildrenDeletedOnGroupSwap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ChildrenDeletedOnGroupSwap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ChildrenDeletedOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ChildrenLostOnGroupSwap Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ChildrenLostOnGroupSwap Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Some elements could not find new hosts after changing group type and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ChildrenLostOnGroupSwap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ChildrenLostOnGroupSwap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ChildrenLostOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


DetailsOfNestedGroupsLost Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.DetailsOfNestedGroupsLost Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Details will be deleted if they reference group members being ungrouped in other instances of this containing group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DetailsOfNestedGroupsLost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DetailsOfNestedGroupsLost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DetailsOfNestedGroupsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


DimensionsOrTagsReferecedRemoved Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.DimensionsOrTagsReferecedRemoved Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Dimensions or Tags that reference non-group members have been removed from group [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionsOrTagsReferecedRemoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionsOrTagsReferecedRemoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionsOrTagsReferecedRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


DimRefsGroupMemberSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.DimRefsGroupMemberSketch Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimRefsGroupMemberSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimRefsGroupMemberSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimRefsGroupMemberSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


DontEditNestedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.DontEditNestedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DontEditNestedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DontEditNestedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DontEditNestedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ElementChangedMoreThanAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ElementChangedMoreThanAllowed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementChangedMoreThanAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementChangedMoreThanAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementChangedMoreThanAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ExcludedElementsRestoredInLink Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ExcludedElementsRestoredInLink Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Excluded elements restored in the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExcludedElementsRestoredInLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExcludedElementsRestoredInLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExcludedElementsRestoredInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


FailedToChangeGroupLevelRef Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.FailedToChangeGroupLevelRef Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to change group level ref.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToChangeGroupLevelRef { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToChangeGroupLevelRef As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeGroupLevelRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


FailedToSetMasterGroupId Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.FailedToSetMasterGroupId Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to set master id of group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetMasterGroupId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToSetMasterGroupId As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToSetMasterGroupId {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


FailedToTransformAttachedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.FailedToTransformAttachedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Attached group could not be properly relocated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToTransformAttachedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToTransformAttachedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToTransformAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupAmongstLoadedRenamed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupAmongstLoadedRenamed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupAmongstLoadedRenamed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupAmongstLoadedRenamed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupAmongstLoadedRenamed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupCannotMixBackAndForegroundDetail Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupCannotMixBackAndForegroundDetail Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotMixBackAndForegroundDetail { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupCannotMixBackAndForegroundDetail As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupCannotMixBackAndForegroundDetail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupCannotMixBackAndForegroundDetailUngroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupCannotMixBackAndForegroundDetailUngroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotMixBackAndForegroundDetailUngroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupCannotMixBackAndForegroundDetailUngroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupCannotMixBackAndForegroundDetailUngroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupCannotSave Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupCannotSave Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotSave { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupCannotSave As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSave {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupCannotSaveWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupCannotSaveWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotSaveWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupCannotSaveWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSaveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupChangeNoPlaceElements Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupChangeNoPlaceElements Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Elements cannot be placed as a result of changes to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupChangeNoPlaceElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupChangeNoPlaceElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupChangeNoPlaceElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupEditModeNoDuplicates Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupEditModeNoDuplicates Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't create duplicates in Edit Group mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupEditModeNoDuplicates { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupEditModeNoDuplicates As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupEditModeNoDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupedModelElemHasViewSpecificSubordinates Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupedModelElemHasViewSpecificSubordinates Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupedModelElemHasViewSpecificSubordinates { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupedModelElemHasViewSpecificSubordinates As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupedModelElemHasViewSpecificSubordinates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupHadFailedElementsWhileUpdating Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupHadFailedElementsWhileUpdating Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group members failed while updating group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupHadFailedElementsWhileUpdating { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupHadFailedElementsWhileUpdating As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupHadFailedElementsWhileUpdating {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupPropagationUserCancelled Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupPropagationUserCancelled Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Changes to Group "[Type Name]" have been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationUserCancelled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupPropagationUserCancelled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationUserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupPropagationWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupPropagationWarning Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupPropagationWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupPropagationWarningSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupPropagationWarningSketch Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationWarningSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupPropagationWarningSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationWarningSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupsHasCycle Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupsHasCycle Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Can't create Group because it contains multiple copies of same Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsHasCycle { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupsHasCycle As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupsHasCycle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupsHaveDifferentMembers Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupsHaveDifferentMembers Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsHaveDifferentMembers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupsHaveDifferentMembers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupsHaveDifferentMembers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupsNotCompatibleForTypeChange Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupsNotCompatibleForTypeChange Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Some of the selected groups are not compatible with the new group type that was chosen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsNotCompatibleForTypeChange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupsNotCompatibleForTypeChange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupsNotCompatibleForTypeChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


GroupViewSpecificDiffViews Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.GroupViewSpecificDiffViews Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
You may not create a detail group with view specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GroupViewSpecificDiffViews { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupViewSpecificDiffViews As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GroupViewSpecificDiffViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


InvalidGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.InvalidGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
This group is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


LastCopyOfGroupDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.LastCopyOfGroupDeleted Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Last copy of Group "[Name]" deleted. Group type removed from project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LastCopyOfGroupDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LastCopyOfGroupDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LastCopyOfGroupDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


LastGroupMemberExcluded Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.LastGroupMemberExcluded Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LastGroupMemberExcluded { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LastGroupMemberExcluded As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LastGroupMemberExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


LinkVisibilityLost Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.LinkVisibilityLost Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Link visibility overrides will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinkVisibilityLost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinkVisibilityLost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinkVisibilityLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


LoadOfGroupAbortedByUser Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.LoadOfGroupAbortedByUser Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
You have aborted loading file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoadOfGroupAbortedByUser { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoadOfGroupAbortedByUser As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoadOfGroupAbortedByUser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


MembersExcluded Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.MembersExcluded Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MembersExcluded { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MembersExcluded As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MembersExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


MembersExcludedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.MembersExcludedWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MembersExcludedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MembersExcludedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MembersExcludedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


MembersMovedToProjectToMakeConsistent Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.MembersMovedToProjectToMakeConsistent Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MembersMovedToProjectToMakeConsistent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MembersMovedToProjectToMakeConsistent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MembersMovedToProjectToMakeConsistent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ModifyingMultiGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ModifyingMultiGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingMultiGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModifyingMultiGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModifyingMultiGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


MoveElemFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.MoveElemFailed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MoveElemFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MoveElemFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MoveElemFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NoAppropriateGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NoAppropriateGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
There is no Group that can be placed in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoAppropriateGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoAppropriateGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoAppropriateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NoDetailGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NoDetailGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
There are no Detail Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoDetailGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoDetailGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoDetailGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NoModelGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NoModelGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
There are no Model Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoModelGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoModelGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoModelGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NoneOfSelElemsGroupable Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NoneOfSelElemsGroupable Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoneOfSelElemsGroupable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoneOfSelElemsGroupable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoneOfSelElemsGroupable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NoSwapGroupBeingEdited Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NoSwapGroupBeingEdited Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
You may not change the type of the group that is currently being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSwapGroupBeingEdited { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSwapGroupBeingEdited As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSwapGroupBeingEdited {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NotAGroupFile Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NotAGroupFile Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
This is not a Group File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAGroupFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAGroupFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAGroupFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


NotAllGroupsFullyRestored Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.NotAllGroupsFullyRestored Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllGroupsFullyRestored { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAllGroupsFullyRestored As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAllGroupsFullyRestored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


PlaceGroupFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.PlaceGroupFailed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to place group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PlaceGroupFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PlaceGroupFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PlaceGroupFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ProblemRegeneratingInGroupUpdate Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ProblemRegeneratingInGroupUpdate Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to regenerate while updating groups at end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemRegeneratingInGroupUpdate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProblemRegeneratingInGroupUpdate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProblemRegeneratingInGroupUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


ReferencesOutsideGroupAreNotAllowed Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.ReferencesOutsideGroupAreNotAllowed Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencesOutsideGroupAreNotAllowed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReferencesOutsideGroupAreNotAllowed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReferencesOutsideGroupAreNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


RemoveGroupSketchConstraintParent Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.RemoveGroupSketchConstraintParent Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveGroupSketchConstraintParent { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemoveGroupSketchConstraintParent As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemoveGroupSketchConstraintParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


RemovingElemCannotBeGrouped Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.RemovingElemCannotBeGrouped Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Elements that cannot be grouped were removed from groups of type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingElemCannotBeGrouped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemovingElemCannotBeGrouped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemovingElemCannotBeGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


RemovingReferencesFromGroupedCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.RemovingReferencesFromGroupedCurve Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
References to elements outside the group were removed from a grouped curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingReferencesFromGroupedCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemovingReferencesFromGroupedCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemovingReferencesFromGroupedCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


RevitUnableToUpadateGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.RevitUnableToUpadateGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to update groups for changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RevitUnableToUpadateGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RevitUnableToUpadateGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RevitUnableToUpadateGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


SomeGroupInstsBecameEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.SomeGroupInstsBecameEmpty Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Group instances have had all their group members deleted and will also be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeGroupInstsBecameEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeGroupInstsBecameEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeGroupInstsBecameEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


SomeMembersNotRestored Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.SomeMembersNotRestored Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeMembersNotRestored { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeMembersNotRestored As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeMembersNotRestored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToBindLink Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToBindLink Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to bind the selected links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToBindLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToBindLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToBindLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToBindLinkInstances Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToBindLinkInstances Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToBindLinkInstances { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToBindLinkInstances As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToBindLinkInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToConvertGroupsToLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToConvertGroupsToLinks Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to convert the selected groups to links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToConvertGroupsToLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToConvertGroupsToLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToConvertGroupsToLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToCreateAttachedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToCreateAttachedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCreateAttachedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToCreateAttachedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToDetachGroupError Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToDetachGroupError Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to detach the selected attached detail group(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToDetachGroupError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToDetachGroupError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToDetachGroupError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToExcludeElems Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToExcludeElems Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to exclude the selected group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToExcludeElems { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToExcludeElems As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToExcludeElems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToGroupElems Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToGroupElems Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToGroupElems { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToGroupElems As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToGroupElems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToLoadAttachedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToLoadAttachedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to load attached detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadAttachedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToLoadAttachedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToLoadDetailGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToLoadDetailGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to load detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadDetailGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToLoadDetailGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadDetailGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToLoadGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToLoadGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to load file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToLoadGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToMaintainExclusions Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToMaintainExclusions Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToMaintainExclusions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToMaintainExclusionsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToMaintainExclusionsWarn Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusionsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToMaintainExclusionsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToMoveElemsToProject Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToMoveElemsToProject Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Revit is unable to move the selected group members to the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMoveElemsToProject { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToMoveElemsToProject As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToMoveElemsToProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToReplaceSelectedGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToReplaceSelectedGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToReplaceSelectedGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToReplaceSelectedGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToReplaceSelectedGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToRestoreAllMembersOfGroups Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToRestoreAllMembersOfGroups Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Revit is unable to restore the members of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToRestoreAllMembersOfGroups { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToRestoreAllMembersOfGroups As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToRestoreAllMembersOfGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToSaveGroupType Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToSaveGroupType Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to save group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToSaveGroupType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToSaveGroupType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToSaveGroupType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


UnableToTransferAttachedGroup Property

[image]

Revit 2011 API
BuiltInFailures..::.GroupFailures..::.UnableToTransferAttachedGroup Property
BuiltInFailures..::.GroupFailures Class See Also Send Feedback
Unable to load attached group [Type Name] of model group [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransferAttachedGroup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToTransferAttachedGroup As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToTransferAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.GroupFailures Class


BuiltInFailures.HostFinishFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HostFinish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class HostFinishFailures
Visual Basic (Declaration)
Public NotInheritable Class HostFinishFailures
Visual C++
public ref class HostFinishFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.HostFinishFailures

See Also

BuiltInFailures..::.HostFinishFailures Members


BuiltInFailures.HostFinishFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures Members
BuiltInFailures..::.HostFinishFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.HostFinishFailures type exposes the following members.

Properties

Name | Description
HostFinishFailedBoolean | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanError | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanWarn | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedFaceActive | Host Finish does not have any volume
HostFinishFailedFaceActiveError | Host Finish does not have any volume
HostFinishFailedFaceActiveWarn | Host Finish does not have any volume
HostFinishFailedHostHow | Host Finish cannot be hosted by such host
HostFinishFailedHostHowError | Host Finish cannot be hosted by such host
HostFinishFailedHostHowWarn | Host Finish cannot be hosted by such host
HostFinishFailedNotSet | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetError | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetWarn | Host Finish is not set properly and cannot be created.
HostFinishFailedOffsetRadius | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusError | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusWarn | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedSketch | Hast Finish cannot be based on this sketch
HostFinishFailedSketchError | Hast Finish cannot be based on this sketch
HostFinishFailedSketchWarn | Hast Finish cannot be based on this sketch
HostFinishTooThin | Host Finish too thin.

See Also

BuiltInFailures..::.HostFinishFailures Class


BuiltInFailures.HostFinishFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures Properties
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback

The BuiltInFailures..::.HostFinishFailures type exposes the following members.

Properties

Name | Description
HostFinishFailedBoolean | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanError | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanWarn | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedFaceActive | Host Finish does not have any volume
HostFinishFailedFaceActiveError | Host Finish does not have any volume
HostFinishFailedFaceActiveWarn | Host Finish does not have any volume
HostFinishFailedHostHow | Host Finish cannot be hosted by such host
HostFinishFailedHostHowError | Host Finish cannot be hosted by such host
HostFinishFailedHostHowWarn | Host Finish cannot be hosted by such host
HostFinishFailedNotSet | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetError | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetWarn | Host Finish is not set properly and cannot be created.
HostFinishFailedOffsetRadius | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusError | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusWarn | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedSketch | Hast Finish cannot be based on this sketch
HostFinishFailedSketchError | Hast Finish cannot be based on this sketch
HostFinishFailedSketchWarn | Hast Finish cannot be based on this sketch
HostFinishTooThin | Host Finish too thin.

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedBoolean Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedBoolean Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBoolean { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedBoolean As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBoolean {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedBooleanError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedBooleanError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBooleanError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedBooleanError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBooleanError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedBooleanWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedBooleanWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBooleanWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedBooleanWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBooleanWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedFaceActive Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedFaceActive Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActive { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedFaceActive As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActive {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedFaceActiveError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedFaceActiveError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActiveError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedFaceActiveError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActiveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedFaceActiveWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedFaceActiveWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActiveWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedFaceActiveWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActiveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedHostHow Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedHostHow Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedHostHow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedHostHowError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedHostHowError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHowError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedHostHowError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHowError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedHostHowWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedHostHowWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHowWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedHostHowWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHowWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedNotSet Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedNotSet Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSet { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedNotSet As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedNotSetError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedNotSetError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSetError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedNotSetError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSetError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedNotSetWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedNotSetWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSetWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedNotSetWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSetWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedOffsetRadius Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedOffsetRadius Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadius { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedOffsetRadius As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedOffsetRadiusError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedOffsetRadiusError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadiusError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedOffsetRadiusError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadiusError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedOffsetRadiusWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedOffsetRadiusWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadiusWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedOffsetRadiusWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadiusWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedSketch Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedSketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedSketchError Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedSketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishFailedSketchWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishFailedSketchWarn Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketchWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishFailedSketchWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketchWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


HostFinishTooThin Property

[image]

Revit 2011 API
BuiltInFailures..::.HostFinishFailures..::.HostFinishTooThin Property
BuiltInFailures..::.HostFinishFailures Class See Also Send Feedback
Host Finish too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishTooThin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishTooThin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostFinishFailures Class


BuiltInFailures.HostObjFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.HostObjFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HostObj.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class HostObjFailures
Visual Basic (Declaration)
Public NotInheritable Class HostObjFailures
Visual C++
public ref class HostObjFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.HostObjFailures

See Also

BuiltInFailures..::.HostObjFailures Members


BuiltInFailures.HostObjFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.HostObjFailures Members
BuiltInFailures..::.HostObjFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::.HostObjFailures Class


BuiltInFailures.HostObjFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.HostObjFailures Properties
BuiltInFailures..::.HostObjFailures Class See Also Send Feedback

The BuiltInFailures..::.HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::.HostObjFailures Class


HostMismatch Property

[image]

Revit 2011 API
BuiltInFailures..::.HostObjFailures..::.HostMismatch Property
BuiltInFailures..::.HostObjFailures Class See Also Send Feedback
Can't use this type in this host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostMismatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostMismatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostObjFailures Class


ReferencesNulled Property

[image]

Revit 2011 API
BuiltInFailures..::.HostObjFailures..::.ReferencesNulled Property
BuiltInFailures..::.HostObjFailures Class See Also Send Feedback
One or more references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencesNulled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReferencesNulled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReferencesNulled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HostObjFailures Class


BuiltInFailures.HvacFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.HvacFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class HvacFailures
Visual Basic (Declaration)
Public NotInheritable Class HvacFailures
Visual C++
public ref class HvacFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.HvacFailures

See Also

BuiltInFailures..::.HvacFailures Members


BuiltInFailures.HvacFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.HvacFailures Members
BuiltInFailures..::.HvacFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::.HvacFailures Class


BuiltInFailures.HvacFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.HvacFailures Properties
BuiltInFailures..::.HvacFailures Class See Also Send Feedback

The BuiltInFailures..::.HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::.HvacFailures Class


PanelDoesntMatchCircuitPropertiesDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.HvacFailures..::.PanelDoesntMatchCircuitPropertiesDisconnected Property
BuiltInFailures..::.HvacFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitPropertiesDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelDoesntMatchCircuitPropertiesDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitPropertiesDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.HvacFailures Class


BuiltInFailures.IlluminationFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Illumination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class IlluminationFailures
Visual Basic (Declaration)
Public NotInheritable Class IlluminationFailures
Visual C++
public ref class IlluminationFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.IlluminationFailures

See Also

BuiltInFailures..::.IlluminationFailures Members


BuiltInFailures.IlluminationFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures Members
BuiltInFailures..::.IlluminationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::.IlluminationFailures Class


BuiltInFailures.IlluminationFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures Properties
BuiltInFailures..::.IlluminationFailures Class See Also Send Feedback

The BuiltInFailures..::.IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::.IlluminationFailures Class


IESFileNotFoundWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures..::.IESFileNotFoundWarning Property
BuiltInFailures..::.IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. IES file not found for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IESFileNotFoundWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IESFileNotFoundWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IESFileNotFoundWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.IlluminationFailures Class


LightingFixtureLumensWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures..::.LightingFixtureLumensWarning Property
BuiltInFailures..::.IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Lumens not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LightingFixtureLumensWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LightingFixtureLumensWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LightingFixtureLumensWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.IlluminationFailures Class


RoomCoefficientUtilizationWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures..::.RoomCoefficientUtilizationWarning Property
BuiltInFailures..::.IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomCoefficientUtilizationWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomCoefficientUtilizationWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomCoefficientUtilizationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.IlluminationFailures Class


RoomLightLossFactorWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.IlluminationFailures..::.RoomLightLossFactorWarning Property
BuiltInFailures..::.IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Light Loss factor not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomLightLossFactorWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomLightLossFactorWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomLightLossFactorWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.IlluminationFailures Class


BuiltInFailures.ImageFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ImageFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ImageFailures
Visual Basic (Declaration)
Public NotInheritable Class ImageFailures
Visual C++
public ref class ImageFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ImageFailures

See Also

BuiltInFailures..::.ImageFailures Members


BuiltInFailures.ImageFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ImageFailures Members
BuiltInFailures..::.ImageFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.

See Also

BuiltInFailures..::.ImageFailures Class


BuiltInFailures.ImageFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ImageFailures Properties
BuiltInFailures..::.ImageFailures Class See Also Send Feedback

The BuiltInFailures..::.ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.

See Also

BuiltInFailures..::.ImageFailures Class


BadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.ImageFailures..::.BadViewType Property
BuiltInFailures..::.ImageFailures Class See Also Send Feedback
Image Instances can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImageFailures Class


BuiltInFailures.ImportFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ImportFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ImportFailures
Visual Basic (Declaration)
Public NotInheritable Class ImportFailures
Visual C++
public ref class ImportFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ImportFailures

See Also

BuiltInFailures..::.ImportFailures Members


BuiltInFailures.ImportFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ImportFailures Members
BuiltInFailures..::.ImportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ImportFailures type exposes the following members.

Properties

Name | Description
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
CannotRelinkWrapper | [Description]
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained 3D data or points which can't be exploded. Only 2D data was exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

See Also

BuiltInFailures..::.ImportFailures Class


BuiltInFailures.ImportFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ImportFailures Properties
BuiltInFailures..::.ImportFailures Class See Also Send Feedback

The BuiltInFailures..::.ImportFailures type exposes the following members.

Properties

Name | Description
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
CannotRelinkWrapper | [Description]
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained 3D data or points which can't be exploded. Only 2D data was exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

See Also

BuiltInFailures..::.ImportFailures Class


BadFaceFoundInDwg Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.BadFaceFoundInDwg Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadFaceFoundInDwg { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadFaceFoundInDwg As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadFaceFoundInDwg {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


CannotChangeImportSymbol Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.CannotChangeImportSymbol Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Can't change an imported or linked element's symbol type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeImportSymbol { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeImportSymbol As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeImportSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


CannotExplodeElement Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.CannotExplodeElement Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Can't explode the imported object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotExplodeElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotExplodeElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotExplodeElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


CannotImportFile Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.CannotImportFile Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Can't import file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotImportFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotImportFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotImportFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


CannotRelinkWrapper Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.CannotRelinkWrapper Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRelinkWrapper { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRelinkWrapper As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRelinkWrapper {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


FailedToSetWorkplane Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.FailedToSetWorkplane Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetWorkplane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToSetWorkplane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToSetWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


IFCGenericImportWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.IFCGenericImportWarning Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
The following problems were encountered in the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IFCGenericImportWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IFCGenericImportWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IFCGenericImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


IFCGenericRevitImportWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.IFCGenericRevitImportWarning Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Revit had the following problems importing the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IFCGenericRevitImportWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IFCGenericRevitImportWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IFCGenericRevitImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


ImportTooFarAway Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.ImportTooFarAway Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ImportTooFarAway { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ImportTooFarAway As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ImportTooFarAway {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


ImportTooManyElmentsToExplode Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.ImportTooManyElmentsToExplode Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ImportTooManyElmentsToExplode { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ImportTooManyElmentsToExplode As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ImportTooManyElmentsToExplode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


LostAcisObjectsOnImport Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.LostAcisObjectsOnImport Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LostAcisObjectsOnImport { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LostAcisObjectsOnImport As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LostAcisObjectsOnImport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


SomeObjectsNotExploded Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.SomeObjectsNotExploded Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Import contained 3D data or points which can't be exploded. Only 2D data was exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SomeObjectsNotExploded { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SomeObjectsNotExploded As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SomeObjectsNotExploded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


TextNotImported Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.TextNotImported Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TextNotImported { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TextNotImported As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TextNotImported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


TooManyPickFaces Property

[image]

Revit 2011 API
BuiltInFailures..::.ImportFailures..::.TooManyPickFaces Property
BuiltInFailures..::.ImportFailures Class See Also Send Feedback
Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyPickFaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManyPickFaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManyPickFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ImportFailures Class


BuiltInFailures.InaccurateFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class InaccurateFailures
Visual Basic (Declaration)
Public NotInheritable Class InaccurateFailures
Visual C++
public ref class InaccurateFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.InaccurateFailures

See Also

BuiltInFailures..::.InaccurateFailures Members


BuiltInFailures.InaccurateFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures Members
BuiltInFailures..::.InaccurateFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::.InaccurateFailures Class


BuiltInFailures.InaccurateFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures Properties
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback

The BuiltInFailures..::.InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateAreaLine Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateAreaLine Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Area separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateAreaLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateAreaLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateAreaLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateBeamOrBrace Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateBeamOrBrace Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Beam or Brace is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateBeamOrBrace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateBeamOrBrace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateBeamOrBrace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateCurveBasedFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateCurveBasedFamily Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Curve-Based Family is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateCurveBasedFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateCurveBasedFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateCurveBasedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateDriveCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateDriveCurve Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Element is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateDriveCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateDriveCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateDriveCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateGrid Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateGrid Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Grid is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateGrid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateGrid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateLevel Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Level is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateLine Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateLine Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateMassingSketchLine Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateMassingSketchLine Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Line in Massing Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateMassingSketchLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateMassingSketchLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateMassingSketchLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateRefPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateRefPlane Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Ref Plane is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateRefPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateRefPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateRoomSeparation Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateRoomSeparation Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Room separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateRoomSeparation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateRoomSeparation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateRoomSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateSketchLine Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateSketchLine Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Line in Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateSketchLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateSketchLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateSketchLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateSpaceSeparation Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateSpaceSeparation Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Space separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateSpaceSeparation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateSpaceSeparation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateSpaceSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


InaccurateWall Property

[image]

Revit 2011 API
BuiltInFailures..::.InaccurateFailures..::.InaccurateWall Property
BuiltInFailures..::.InaccurateFailures Class See Also Send Feedback
Wall is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InaccurateWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InaccurateWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InaccurateFailures Class


BuiltInFailures.InfillFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Infill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class InfillFailures
Visual Basic (Declaration)
Public NotInheritable Class InfillFailures
Visual C++
public ref class InfillFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.InfillFailures

See Also

BuiltInFailures..::.InfillFailures Members


BuiltInFailures.InfillFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.InfillFailures Members
BuiltInFailures..::.InfillFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.InfillFailures type exposes the following members.

Properties

Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.

See Also

BuiltInFailures..::.InfillFailures Class


BuiltInFailures.InfillFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.InfillFailures Properties
BuiltInFailures..::.InfillFailures Class See Also Send Feedback

The BuiltInFailures..::.InfillFailures type exposes the following members.

Properties

Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.

See Also

BuiltInFailures..::.InfillFailures Class


CannotDeleteInfill Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.CannotDeleteInfill Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Can't delete infilling element without deleting its insert or host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteInfill { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDeleteInfill As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteInfill {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


FamilyInstanceIsNotCuttingHost Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.FamilyInstanceIsNotCuttingHost Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Instance is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyInstanceIsNotCuttingHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyInstanceIsNotCuttingHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyInstanceIsNotCuttingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillCannotChangeType Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillCannotChangeType Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Infilling element replaced by a later phase insert must be the same type as the insert's host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillCannotChangeType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillCannotChangeType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillCannotChangeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillCannotHaveDiffThickness Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillCannotHaveDiffThickness Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
This infilling element must have the same thickness as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillCannotHaveDiffThickness { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillCannotHaveDiffThickness As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillCannotHaveDiffThickness {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillDifferentPhase Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillDifferentPhase Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillDifferentPhase { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillDifferentPhase As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillDifferentPhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillLost Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillLost Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Standalone infilling Wall is separated from its insert.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillLost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillLost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillNoSlopeGlazing Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillNoSlopeGlazing Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoSlopeGlazing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillNoSlopeGlazing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillNoSlopeGlazing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillNoThicknessCeiling Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillNoThicknessCeiling Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoThicknessCeiling { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillNoThicknessCeiling As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillNoThicknessCeiling {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InfillNoThicknessMultiface Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InfillNoThicknessMultiface Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Highlighted infilling element could not have thickness different from its host because it spans multiple faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoThicknessMultiface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InfillNoThicknessMultiface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InfillNoThicknessMultiface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InPlaceFamilyNotCuttingHost Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InPlaceFamilyNotCuttingHost Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Instance of in-place family is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InPlaceFamilyNotCuttingHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InPlaceFamilyNotCuttingHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InPlaceFamilyNotCuttingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InsertJoinedWall Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InsertJoinedWall Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Insert conflicts with joined Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertJoinedWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertJoinedWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertJoinedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


InsertOverlapsOrOut Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.InsertOverlapsOrOut Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Highlighted inserts overlap with other inserts or completely miss their hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertOverlapsOrOut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertOverlapsOrOut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertOverlapsOrOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


MovedInfillToHost Property

[image]

Revit 2011 API
BuiltInFailures..::.InfillFailures..::.MovedInfillToHost Property
BuiltInFailures..::.InfillFailures Class See Also Send Feedback
Infilling element was automatically moved to keep it aligned to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MovedInfillToHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MovedInfillToHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MovedInfillToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InfillFailures Class


BuiltInFailures.InterferenceFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.InterferenceFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Interference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class InterferenceFailures
Visual Basic (Declaration)
Public NotInheritable Class InterferenceFailures
Visual C++
public ref class InterferenceFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.InterferenceFailures

See Also

BuiltInFailures..::.InterferenceFailures Members


BuiltInFailures.InterferenceFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.InterferenceFailures Members
BuiltInFailures..::.InterferenceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryError | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::.InterferenceFailures Class


BuiltInFailures.InterferenceFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.InterferenceFailures Properties
BuiltInFailures..::.InterferenceFailures Class See Also Send Feedback

The BuiltInFailures..::.InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryError | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::.InterferenceFailures Class


GeometryError Property

[image]

Revit 2011 API
BuiltInFailures..::.InterferenceFailures..::.GeometryError Property
BuiltInFailures..::.InterferenceFailures Class See Also Send Feedback
A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GeometryError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GeometryError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GeometryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.InterferenceFailures Class


BuiltInFailures.JoinElementsFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about JoinElements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class JoinElementsFailures
Visual Basic (Declaration)
Public NotInheritable Class JoinElementsFailures
Visual C++
public ref class JoinElementsFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.JoinElementsFailures

See Also

BuiltInFailures..::.JoinElementsFailures Members


BuiltInFailures.JoinElementsFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures Members
BuiltInFailures..::.JoinElementsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.

See Also

BuiltInFailures..::.JoinElementsFailures Class


BuiltInFailures.JoinElementsFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures Properties
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback

The BuiltInFailures..::.JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotCope Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotCope Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't apply Coping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCope { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCope As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCope {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotCutJoinedGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotCutJoinedGeometry Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Element could not be cut by joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutJoinedGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutJoinedGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinDesignOptions Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinDesignOptions Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinDesignOptions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinDesignOptions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinDesignOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinElements Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinElements Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinElementsError Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinElementsError Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinElementsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinElementsStructural Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinElementsStructural Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructural { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinElementsStructural As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinElementsStructuralError Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinElementsStructuralError Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructuralError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinElementsStructuralError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructuralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinElementsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinElementsWarn Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinElementsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinRoof Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotJoinRoofError Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotJoinRoofError Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinRoofError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotJoinRoofError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotKeepJoined Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotKeepJoined Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepJoined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotKeepJoined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotKeepJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotKeepTrussJoined Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotKeepTrussJoined Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep the highlighted [Element]s joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepTrussJoined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotKeepTrussJoined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotKeepTrussJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotKeepWallJoinToRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotKeepWallJoinToRoof Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotKeepWallJoinToRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


CannotKeepWallJoinToRoofError Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.CannotKeepWallJoinToRoofError Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoofError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotKeepWallJoinToRoofError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


ElementWillBeDetachedFromPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.ElementWillBeDetachedFromPlane Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Element will be detached from its associated plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementWillBeDetachedFromPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementWillBeDetachedFromPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementWillBeDetachedFromPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


FootingWillMoveToBottom Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.FootingWillMoveToBottom Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
An attached Structural Foundation will be moved to the bottom of the Column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FootingWillMoveToBottom { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FootingWillMoveToBottom As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FootingWillMoveToBottom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


JoiningDisjoint Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.JoiningDisjoint Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId JoiningDisjoint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JoiningDisjoint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


JoiningDisjointWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.JoiningDisjointWarn Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId JoiningDisjointWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JoiningDisjointWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjointWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


StructGroupMemberWillDetachFromGrid Property

[image]

Revit 2011 API
BuiltInFailures..::.JoinElementsFailures..::.StructGroupMemberWillDetachFromGrid Property
BuiltInFailures..::.JoinElementsFailures Class See Also Send Feedback
A structural element will be detached from grid(s) due to inconsistent group membership.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StructGroupMemberWillDetachFromGrid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StructGroupMemberWillDetachFromGrid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StructGroupMemberWillDetachFromGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.JoinElementsFailures Class


BuiltInFailures.KeynoteFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about KeynoteFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class KeynoteFailures
Visual Basic (Declaration)
Public NotInheritable Class KeynoteFailures
Visual C++
public ref class KeynoteFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.KeynoteFailures

See Also

BuiltInFailures..::.KeynoteFailures Members


BuiltInFailures.KeynoteFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures Members
BuiltInFailures..::.KeynoteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.KeynoteFailures type exposes the following members.

Properties

Name | Description
CyclicalKeynote | A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'
DuplicateKeynote | Duplicate key value '[Value]', text: '[Text]'
MissingKeynote | No parent keynote '[Value]' for '[Value]'
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
WrongKeynote | Cannot understand keynote line '[Number]'

See Also

BuiltInFailures..::.KeynoteFailures Class


BuiltInFailures.KeynoteFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures Properties
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback

The BuiltInFailures..::.KeynoteFailures type exposes the following members.

Properties

Name | Description
CyclicalKeynote | A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'
DuplicateKeynote | Duplicate key value '[Value]', text: '[Text]'
MissingKeynote | No parent keynote '[Value]' for '[Value]'
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
WrongKeynote | Cannot understand keynote line '[Number]'

See Also

BuiltInFailures..::.KeynoteFailures Class


CyclicalKeynote Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.CyclicalKeynote Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CyclicalKeynote { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CyclicalKeynote As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CyclicalKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


DuplicateKeynote Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.DuplicateKeynote Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
Duplicate key value '[Value]', text: '[Text]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateKeynote { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateKeynote As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


MissingKeynote Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.MissingKeynote Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
No parent keynote '[Value]' for '[Value]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissingKeynote { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissingKeynote As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissingKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


MissKeynoteParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.MissKeynoteParameter Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissKeynoteParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissKeynoteParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


MissKeynotingSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.MissKeynotingSystem Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissKeynotingSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissKeynotingSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissKeynotingSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


NotAssociatedKeynoteParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.NotAssociatedKeynoteParameter Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotAssociatedKeynoteParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotAssociatedKeynoteParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotAssociatedKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


WrongKeynote Property

[image]

Revit 2011 API
BuiltInFailures..::.KeynoteFailures..::.WrongKeynote Property
BuiltInFailures..::.KeynoteFailures Class See Also Send Feedback
Cannot understand keynote line '[Number]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongKeynote { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongKeynote As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.KeynoteFailures Class


BuiltInFailures.LegendFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.LegendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class LegendFailures
Visual Basic (Declaration)
Public NotInheritable Class LegendFailures
Visual C++
public ref class LegendFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.LegendFailures

See Also

BuiltInFailures..::.LegendFailures Members


BuiltInFailures.LegendFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.LegendFailures Members
BuiltInFailures..::.LegendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::.LegendFailures Class


BuiltInFailures.LegendFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.LegendFailures Properties
BuiltInFailures..::.LegendFailures Class See Also Send Feedback

The BuiltInFailures..::.LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::.LegendFailures Class


LegendComponentBadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.LegendFailures..::.LegendComponentBadViewType Property
BuiltInFailures..::.LegendFailures Class See Also Send Feedback
Legend Components may only be placed in Legends

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LegendComponentBadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LegendComponentBadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LegendComponentBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LegendFailures Class


LegendComponentNotVisible Property

[image]

Revit 2011 API
BuiltInFailures..::.LegendFailures..::.LegendComponentNotVisible Property
BuiltInFailures..::.LegendFailures Class See Also Send Feedback
The component you have selected is not visible in the selected view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LegendComponentNotVisible { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LegendComponentNotVisible As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LegendComponentNotVisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LegendFailures Class


BuiltInFailures.LevelFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.LevelFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class LevelFailures
Visual Basic (Declaration)
Public NotInheritable Class LevelFailures
Visual C++
public ref class LevelFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.LevelFailures

See Also

BuiltInFailures..::.LevelFailures Members


BuiltInFailures.LevelFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.LevelFailures Members
BuiltInFailures..::.LevelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
NoLevelsLeft2 | There are no levels or plan views remaining in the project.

See Also

BuiltInFailures..::.LevelFailures Class


BuiltInFailures.LevelFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.LevelFailures Properties
BuiltInFailures..::.LevelFailures Class See Also Send Feedback

The BuiltInFailures..::.LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
NoLevelsLeft2 | There are no levels or plan views remaining in the project.

See Also

BuiltInFailures..::.LevelFailures Class


NoLevelsLeft Property

[image]

Revit 2011 API
BuiltInFailures..::.LevelFailures..::.NoLevelsLeft Property
BuiltInFailures..::.LevelFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLevelsLeft { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLevelsLeft As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeft {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LevelFailures Class


NoLevelsLeft2 Property

[image]

Revit 2011 API
BuiltInFailures..::.LevelFailures..::.NoLevelsLeft2 Property
BuiltInFailures..::.LevelFailures Class See Also Send Feedback
There are no levels or plan views remaining in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLevelsLeft2 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLevelsLeft2 As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeft2 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LevelFailures Class


BuiltInFailures.LinkFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LinkFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class LinkFailures
Visual Basic (Declaration)
Public NotInheritable Class LinkFailures
Visual C++
public ref class LinkFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.LinkFailures

See Also

BuiltInFailures..::.LinkFailures Members


BuiltInFailures.LinkFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.LinkFailures Members
BuiltInFailures..::.LinkFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.LinkFailures type exposes the following members.

Properties

Name | Description
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::.LinkFailures Class


BuiltInFailures.LinkFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.LinkFailures Properties
BuiltInFailures..::.LinkFailures Class See Also Send Feedback

The BuiltInFailures..::.LinkFailures type exposes the following members.

Properties

Name | Description
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::.LinkFailures Class


CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Shared coordinates cannot be published to mirrored, non Revit, links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPublishSharedCoordinatesToMirroredNonRevitLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPublishSharedCoordinatesToMirroredNonRevitLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPublishSharedCoordinatesToMirroredNonRevitLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


CannotReloadFile Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.CannotReloadFile Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Can't reload file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotReloadFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotReloadFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotReloadFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


CannotUnlinkFile Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.CannotUnlinkFile Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Can't unlink file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUnlinkFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotUnlinkFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotUnlinkFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


DataDictionaryDifferentInLink Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.DataDictionaryDifferentInLink Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DataDictionaryDifferentInLink { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DataDictionaryDifferentInLink As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DataDictionaryDifferentInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


DeleteLinkSymbolPrompt Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.DeleteLinkSymbolPrompt Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteLinkSymbolPrompt { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeleteLinkSymbolPrompt As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeleteLinkSymbolPrompt {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


LinkedFileOpenInOtherDoc Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.LinkedFileOpenInOtherDoc Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Linked file cannot be reloaded because it is loaded into another open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinkedFileOpenInOtherDoc { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinkedFileOpenInOtherDoc As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinkedFileOpenInOtherDoc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


LinkInstanceNeedsReconcile Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.LinkInstanceNeedsReconcile Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Instance of linked .rvt file needs Coordination Review

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinkInstanceNeedsReconcile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinkInstanceNeedsReconcile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinkInstanceNeedsReconcile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


ModifyingLinkedFile Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.ModifyingLinkedFile Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingLinkedFile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModifyingLinkedFile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModifyingLinkedFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


MultipleLinks Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.MultipleLinks Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Can't complete operation. Linked Files have the same name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleLinks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultipleLinks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


NoConstraintsToLinks1 Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.NoConstraintsToLinks1 Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsToLinks1 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoConstraintsToLinks1 As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsToLinks1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


SourceFileDrivenByOtherTarget Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.SourceFileDrivenByOtherTarget Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SourceFileDrivenByOtherTarget { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SourceFileDrivenByOtherTarget As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SourceFileDrivenByOtherTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


WatchedLinkMoved Property

[image]

Revit 2011 API
BuiltInFailures..::.LinkFailures..::.WatchedLinkMoved Property
BuiltInFailures..::.LinkFailures Class See Also Send Feedback
Monitored Link moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WatchedLinkMoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WatchedLinkMoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WatchedLinkMoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LinkFailures Class


BuiltInFailures.LoadFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class LoadFailures
Visual Basic (Declaration)
Public NotInheritable Class LoadFailures
Visual C++
public ref class LoadFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.LoadFailures

See Also

BuiltInFailures..::.LoadFailures Members


BuiltInFailures.LoadFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.LoadFailures Members
BuiltInFailures..::.LoadFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.LoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotPlaceBoundaryConditions | Can't find a host for Boundary Conditions
CannotPlaceBoundaryConditionsWarn | Can't find a host for Boundary Conditions
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.

See Also

BuiltInFailures..::.LoadFailures Class


BuiltInFailures.LoadFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.LoadFailures Properties
BuiltInFailures..::.LoadFailures Class See Also Send Feedback

The BuiltInFailures..::.LoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotPlaceBoundaryConditions | Can't find a host for Boundary Conditions
CannotPlaceBoundaryConditionsWarn | Can't find a host for Boundary Conditions
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.

See Also

BuiltInFailures..::.LoadFailures Class


CannotMirrorBoundaryCondition Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotMirrorBoundaryCondition Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't mirror Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorBoundaryCondition { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMirrorBoundaryCondition As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorBoundaryCondition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


CannotMirrorHostedLoad Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotMirrorHostedLoad Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't mirror Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorHostedLoad { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMirrorHostedLoad As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


CannotMirrorLoad Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotMirrorLoad Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't mirror Load because mirror plane is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorLoad { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMirrorLoad As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


CannotPlaceBoundaryConditions Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotPlaceBoundaryConditions Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't find a host for Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBoundaryConditions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceBoundaryConditions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


CannotPlaceBoundaryConditionsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotPlaceBoundaryConditionsWarn Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't find a host for Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBoundaryConditionsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceBoundaryConditionsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


CannotRotateLoad Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.CannotRotateLoad Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Can't rotate Load because rotation axis is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateLoad { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRotateLoad As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


HostChangeDisallowsLoadOrBoundaryConditions Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.HostChangeDisallowsLoadOrBoundaryConditions Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostChangeDisallowsLoadOrBoundaryConditions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostChangeDisallowsLoadOrBoundaryConditions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostChangeDisallowsLoadOrBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


LineLoadAllZero Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.LineLoadAllZero Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Line Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LineLoadAllZero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LineLoadAllZero As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LineLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


PointLoadAllZero Property

[image]

Revit 2011 API
BuiltInFailures..::.LoadFailures..::.PointLoadAllZero Property
BuiltInFailures..::.LoadFailures Class See Also Send Feedback
Point Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PointLoadAllZero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PointLoadAllZero As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PointLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LoadFailures Class


BuiltInFailures.LooseDimensionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LooseDemision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class LooseDimensionFailures
Visual Basic (Declaration)
Public NotInheritable Class LooseDimensionFailures
Visual C++
public ref class LooseDimensionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.LooseDimensionFailures

See Also

BuiltInFailures..::.LooseDimensionFailures Members


BuiltInFailures.LooseDimensionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures Members
BuiltInFailures..::.LooseDimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::.LooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures Properties
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback

The BuiltInFailures..::.LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::.LooseDimensionFailures Class


LooseCurtainWallData Property

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures..::.LooseCurtainWallData Property
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback
Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseCurtainWallData { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseCurtainWallData As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseCurtainWallData {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LooseDimensionFailures Class


LooseDimensionsForCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures..::.LooseDimensionsForCurtainWall Property
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback
Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseDimensionsForCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseDimensionsForCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseDimensionsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LooseDimensionFailures Class


LooseFaceSplitsForCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures..::.LooseFaceSplitsForCurtainWall Property
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseFaceSplitsForCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseFaceSplitsForCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseFaceSplitsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LooseDimensionFailures Class


LooseInsertsForCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures..::.LooseInsertsForCurtainWall Property
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain element. All inserts in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseInsertsForCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseInsertsForCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseInsertsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LooseDimensionFailures Class


LooseWallsweepsForCurtainWall Property

[image]

Revit 2011 API
BuiltInFailures..::.LooseDimensionFailures..::.LooseWallsweepsForCurtainWall Property
BuiltInFailures..::.LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LooseWallsweepsForCurtainWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LooseWallsweepsForCurtainWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LooseWallsweepsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.LooseDimensionFailures Class


BuiltInFailures.MassFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class MassFailures
Visual Basic (Declaration)
Public NotInheritable Class MassFailures
Visual C++
public ref class MassFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.MassFailures

See Also

BuiltInFailures..::.MassFailures Members


BuiltInFailures.MassFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.MassFailures Members
BuiltInFailures..::.MassFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.MassFailures type exposes the following members.

Properties

Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Files.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

See Also

BuiltInFailures..::.MassFailures Class


BuiltInFailures.MassFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.MassFailures Properties
BuiltInFailures..::.MassFailures Class See Also Send Feedback

The BuiltInFailures..::.MassFailures type exposes the following members.

Properties

Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Files.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

See Also

BuiltInFailures..::.MassFailures Class


AutoGlazingFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.AutoGlazingFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AutoGlazingFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AutoGlazingFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


AutoGlazingFailedError Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.AutoGlazingFailedError Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AutoGlazingFailedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AutoGlazingFailedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


BooleanUnionFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.BooleanUnionFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to merge overlapping solids

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BooleanUnionFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BooleanUnionFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BooleanUnionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


CannotIntegrate Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.CannotIntegrate Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotIntegrate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotIntegrate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotIntegrate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


CannotMergeGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.CannotMergeGeometry Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMergeGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMergeGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMergeGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


CannotMoveMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.CannotMoveMassing Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Can't move whole Massing. Move the elements within the Massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMoveMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMoveMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


CreateCoreGeometryFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.CreateCoreGeometryFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


DividePerimeterZoneFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.DividePerimeterZoneFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to divide perimeter zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DividePerimeterZoneFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DividePerimeterZoneFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DividePerimeterZoneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


FaceRegionCreationFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.FaceRegionCreationFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failure in face region creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceRegionCreationFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceRegionCreationFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceRegionCreationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


FaceSplitFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.FaceSplitFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSplitFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceSplitFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceSplitFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


FloorAreaFaceFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.FloorAreaFaceFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to create a Mass Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorAreaFaceFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorAreaFaceFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorAreaFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


FloorMightLookWrong Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.FloorMightLookWrong Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorMightLookWrong { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorMightLookWrong As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorMightLookWrong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


MinSkylightWidthImperial Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.MinSkylightWidthImperial Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.MinSkylightWidthMetric Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


MultipleMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.MultipleMassing Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultipleMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultipleMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


NoCurtainRoofsInMassing Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.NoCurtainRoofsInMassing Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Massing cannot be created with a curtain roof. Please change the default roof type and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoCurtainRoofsInMassing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoCurtainRoofsInMassing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoCurtainRoofsInMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


NonOccupiableMassZone Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.NonOccupiableMassZone Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonOccupiableMassZone { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonOccupiableMassZone As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonOccupiableMassZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


NoSolidInMass Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.NoSolidInMass Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSolidInMass { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSolidInMass As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSolidInMass {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


OpenAndSolidGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.OpenAndSolidGeometry Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAndSolidGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenAndSolidGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenAndSolidGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


OpenGeometryOnly Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.OpenGeometryOnly Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenGeometryOnly { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenGeometryOnly As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenGeometryOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


OverlappingSolids Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.OverlappingSolids Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Found volumetric overlap between solids. They will be merged into one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OverlappingSolids { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OverlappingSolids As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OverlappingSolids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


SketchCurveNotModelable Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.SketchCurveNotModelable Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchCurveNotModelable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchCurveNotModelable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchCurveNotModelable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


SplitFacesByGroundPlaneCrashed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.SplitFacesByGroundPlaneCrashed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneCrashed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SplitFacesByGroundPlaneCrashed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


SplitFacesByGroundPlaneFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.SplitFacesByGroundPlaneFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SplitFacesByGroundPlaneFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


SplitOverlappingFacesFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.SplitOverlappingFacesFailed Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SplitOverlappingFacesFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SplitOverlappingFacesFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SplitOverlappingFacesFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


TooManyGeometries Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.TooManyGeometries Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyGeometries { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManyGeometries As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManyGeometries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


UpgradedMassingWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.MassFailures..::.UpgradedMassingWarning Property
BuiltInFailures..::.MassFailures Class See Also Send Feedback
Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UpgradedMassingWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UpgradedMassingWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UpgradedMassingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MassFailures Class


BuiltInFailures.MatchlineFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.MatchlineFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Matchline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class MatchlineFailures
Visual Basic (Declaration)
Public NotInheritable Class MatchlineFailures
Visual C++
public ref class MatchlineFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.MatchlineFailures

See Also

BuiltInFailures..::.MatchlineFailures Members


BuiltInFailures.MatchlineFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.MatchlineFailures Members
BuiltInFailures..::.MatchlineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::.MatchlineFailures Class


BuiltInFailures.MatchlineFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.MatchlineFailures Properties
BuiltInFailures..::.MatchlineFailures Class See Also Send Feedback

The BuiltInFailures..::.MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::.MatchlineFailures Class


CreationFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MatchlineFailures..::.CreationFailed Property
BuiltInFailures..::.MatchlineFailures Class See Also Send Feedback
Matchline top extent should be higher than its bottom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CreationFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CreationFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CreationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MatchlineFailures Class


BuiltInFailures.MechanicalFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Hvac.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class MechanicalFailures
Visual Basic (Declaration)
Public NotInheritable Class MechanicalFailures
Visual C++
public ref class MechanicalFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.MechanicalFailures

See Also

BuiltInFailures..::.MechanicalFailures Members


BuiltInFailures.MechanicalFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures Members
BuiltInFailures..::.MechanicalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.MechanicalFailures type exposes the following members.

Properties

Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.

See Also

BuiltInFailures..::.MechanicalFailures Class


BuiltInFailures.MechanicalFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures Properties
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback

The BuiltInFailures..::.MechanicalFailures type exposes the following members.

Properties

Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.

See Also

BuiltInFailures..::.MechanicalFailures Class


InitialEqualFrictionSizingFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.InitialEqualFrictionSizingFailed Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
Initial Equal Friction Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InitialEqualFrictionSizingFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InitialEqualFrictionSizingFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InitialEqualFrictionSizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


LiningThicknessIsLargeForDiameter Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.LiningThicknessIsLargeForDiameter Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForDiameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LiningThicknessIsLargeForDiameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


LiningThicknessIsLargeForHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.LiningThicknessIsLargeForHeight Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LiningThicknessIsLargeForHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


LiningThicknessIsLargeForWidth Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.LiningThicknessIsLargeForWidth Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForWidth { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LiningThicknessIsLargeForWidth As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForWidth {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


PanelDoesntMatchCircuitProperties Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.PanelDoesntMatchCircuitProperties Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitProperties { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelDoesntMatchCircuitProperties As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


TwoPointsSelectedBeforeEdit Property

[image]

Revit 2011 API
BuiltInFailures..::.MechanicalFailures..::.TwoPointsSelectedBeforeEdit Property
BuiltInFailures..::.MechanicalFailures Class See Also Send Feedback
Two points have to be selected before existing the edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TwoPointsSelectedBeforeEdit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TwoPointsSelectedBeforeEdit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TwoPointsSelectedBeforeEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MechanicalFailures Class


BuiltInFailures.MirrorFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.MirrorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Mirror.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class MirrorFailures
Visual Basic (Declaration)
Public NotInheritable Class MirrorFailures
Visual C++
public ref class MirrorFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.MirrorFailures

See Also

BuiltInFailures..::.MirrorFailures Members


BuiltInFailures.MirrorFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.MirrorFailures Members
BuiltInFailures..::.MirrorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.
BadMirrorWithResolution | Can't mirror element into this position.

See Also

BuiltInFailures..::.MirrorFailures Class


BuiltInFailures.MirrorFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.MirrorFailures Properties
BuiltInFailures..::.MirrorFailures Class See Also Send Feedback

The BuiltInFailures..::.MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.
BadMirrorWithResolution | Can't mirror element into this position.

See Also

BuiltInFailures..::.MirrorFailures Class


BadMirror Property

[image]

Revit 2011 API
BuiltInFailures..::.MirrorFailures..::.BadMirror Property
BuiltInFailures..::.MirrorFailures Class See Also Send Feedback
Can't mirror element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadMirror { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadMirror As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MirrorFailures Class


BadMirrorWithResolution Property

[image]

Revit 2011 API
BuiltInFailures..::.MirrorFailures..::.BadMirrorWithResolution Property
BuiltInFailures..::.MirrorFailures Class See Also Send Feedback
Can't mirror element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadMirrorWithResolution { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadMirrorWithResolution As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadMirrorWithResolution {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.MirrorFailures Class


BuiltInFailures.OpeningFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class OpeningFailures
Visual Basic (Declaration)
Public NotInheritable Class OpeningFailures
Visual C++
public ref class OpeningFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.OpeningFailures

See Also

BuiltInFailures..::.OpeningFailures Members


BuiltInFailures.OpeningFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures Members
BuiltInFailures..::.OpeningFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.OpeningFailures type exposes the following members.

Properties

Name | Description
CannotMakeCutoutCorruption | Can't make cut-out.
CannotMakeCutoutError | Can't make cut-out.
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryOld | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::.OpeningFailures Class


BuiltInFailures.OpeningFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures Properties
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback

The BuiltInFailures..::.OpeningFailures type exposes the following members.

Properties

Name | Description
CannotMakeCutoutCorruption | Can't make cut-out.
CannotMakeCutoutError | Can't make cut-out.
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryOld | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::.OpeningFailures Class


CannotMakeCutoutCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.CannotMakeCutoutCorruption Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeCutoutCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeCutoutCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeCutoutCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


CannotMakeCutoutError Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.CannotMakeCutoutError Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeCutoutError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeCutoutError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeCutoutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


HostForCutHasNoGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.HostForCutHasNoGeometry Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostForCutHasNoGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


HostForCutHasNoGeometryOld Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.HostForCutHasNoGeometryOld Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometryOld { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostForCutHasNoGeometryOld As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometryOld {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


InvalidComplexCut Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.InvalidComplexCut Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidComplexCut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidComplexCut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidComplexCut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningCutAll Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningCutAll Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Opening completely removes its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningCutAll { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningCutAll As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningCutAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningDoesnotCutHost Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningDoesnotCutHost Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningDoesnotCutHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningDoesnotCutHostDelete Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningDoesnotCutHostDelete Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHostDelete { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningDoesnotCutHostDelete As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHostDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningNegativeHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningNegativeHeight Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
The top of the Opening is lower than the bottom of the Opening or coincident with it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningNegativeHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningNegativeHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningPartiallyCutsHost Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningPartiallyCutsHost Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Opening partially cuts its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningPartiallyCutsHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningPartiallyCutsHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningPartiallyCutsHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningRectDoesnotCutHost Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningRectDoesnotCutHost Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Rectangular opening doesn't cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningRectDoesnotCutHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningRectDoesnotCutHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningRectDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpeningRemovesHost Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpeningRemovesHost Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Opening completely removes its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningRemovesHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpeningRemovesHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpeningRemovesHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


OpenStringerConflictNosing Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.OpenStringerConflictNosing Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenStringerConflictNosing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenStringerConflictNosing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenStringerConflictNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


PropertyNotClosed Property

[image]

Revit 2011 API
BuiltInFailures..::.OpeningFailures..::.PropertyNotClosed Property
BuiltInFailures..::.OpeningFailures Class See Also Send Feedback
Property lines do not form a closed loop. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PropertyNotClosed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PropertyNotClosed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PropertyNotClosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OpeningFailures Class


BuiltInFailures.OverlapFailure Class

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailure Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class OverlapFailure
Visual Basic (Declaration)
Public NotInheritable Class OverlapFailure
Visual C++
public ref class OverlapFailure abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.OverlapFailure

See Also

BuiltInFailures..::.OverlapFailure Members


BuiltInFailures.OverlapFailure Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.OverlapFailure Members
BuiltInFailures..::.OverlapFailure Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.OverlapFailure type exposes the following members.

Properties

Name | Description
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

See Also

BuiltInFailures..::.OverlapFailure Class


BuiltInFailures.OverlapFailure Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.OverlapFailure Properties
BuiltInFailures..::.OverlapFailure Class See Also Send Feedback

The BuiltInFailures..::.OverlapFailure type exposes the following members.

Properties

Name | Description
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

See Also

BuiltInFailures..::.OverlapFailure Class


OverlappingElementsTest Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailure..::.OverlappingElementsTest Property
BuiltInFailures..::.OverlapFailure Class See Also Send Feedback
There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OverlappingElementsTest { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OverlappingElementsTest As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OverlappingElementsTest {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailure Class


BuiltInFailures.OverlapFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures detected by overlap check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class OverlapFailures
Visual Basic (Declaration)
Public NotInheritable Class OverlapFailures
Visual C++
public ref class OverlapFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.OverlapFailures

See Also

BuiltInFailures..::.OverlapFailures Members


BuiltInFailures.OverlapFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures Members
BuiltInFailures..::.OverlapFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
LevelsOverlap | Highlighted levels overlap.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::.OverlapFailures Class


BuiltInFailures.OverlapFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures Properties
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback

The BuiltInFailures..::.OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
LevelsOverlap | Highlighted levels overlap.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::.OverlapFailures Class


AreaBoundaryLinesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.AreaBoundaryLinesOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaBoundaryLinesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaBoundaryLinesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaBoundaryLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


CurvesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.CurvesOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted lines overlap. Lines may not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurvesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurvesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


DuplicateInstances Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.DuplicateInstances Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
There are identical instances in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateInstances { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


DuplicatePoints Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.DuplicatePoints Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
There are identical points in the same place. Lines created from points may not work as expected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicatePoints { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicatePoints As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicatePoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


DuplicateRebar Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.DuplicateRebar Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
There are identical rebar in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateRebar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateRebar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


LevelsOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.LevelsOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted levels overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LevelsOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LevelsOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LevelsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


RoomSeparationLinesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.RoomSeparationLinesOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomSeparationLinesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomSeparationLinesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


SpaceSeparationLinesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.SpaceSeparationLinesOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpaceSeparationLinesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpaceSeparationLinesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpaceSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


WallAreaBoundaryOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.WallAreaBoundaryOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallAreaBoundaryOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallAreaBoundaryOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallAreaBoundaryOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


WallRoomSeparationOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.WallRoomSeparationOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallRoomSeparationOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallRoomSeparationOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallRoomSeparationOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


WallsOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.WallsOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallsOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


WallSpaceSeparationOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.OverlapFailures..::.WallSpaceSeparationOverlap Property
BuiltInFailures..::.OverlapFailures Class See Also Send Feedback
A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallSpaceSeparationOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallSpaceSeparationOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallSpaceSeparationOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.OverlapFailures Class


BuiltInFailures.PathFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.PathFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class PathFailures
Visual Basic (Declaration)
Public NotInheritable Class PathFailures
Visual C++
public ref class PathFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.PathFailures

See Also

BuiltInFailures..::.PathFailures Members


BuiltInFailures.PathFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.PathFailures Members
BuiltInFailures..::.PathFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::.PathFailures Class


BuiltInFailures.PathFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.PathFailures Properties
BuiltInFailures..::.PathFailures Class See Also Send Feedback

The BuiltInFailures..::.PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::.PathFailures Class


Path3dRegenError Property

[image]

Revit 2011 API
BuiltInFailures..::.PathFailures..::.Path3dRegenError Property
BuiltInFailures..::.PathFailures Class See Also Send Feedback
Picked Path could not be regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId Path3dRegenError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Path3dRegenError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ Path3dRegenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PathFailures Class


BuiltInFailures.PipingFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Pipes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class PipingFailures
Visual Basic (Declaration)
Public NotInheritable Class PipingFailures
Visual C++
public ref class PipingFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.PipingFailures

See Also

BuiltInFailures..::.PipingFailures Members


BuiltInFailures.PipingFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.PipingFailures Members
BuiltInFailures..::.PipingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
InvalidPipeFittingKfactorDatabase | Invalid Pipe Fitting K-Factor Database
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing

See Also

BuiltInFailures..::.PipingFailures Class


BuiltInFailures.PipingFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.PipingFailures Properties
BuiltInFailures..::.PipingFailures Class See Also Send Feedback

The BuiltInFailures..::.PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
InvalidPipeFittingKfactorDatabase | Invalid Pipe Fitting K-Factor Database
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing

See Also

BuiltInFailures..::.PipingFailures Class


CannotCreateGeometryForPipe Property

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures..::.CannotCreateGeometryForPipe Property
BuiltInFailures..::.PipingFailures Class See Also Send Feedback
Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForPipe { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateGeometryForPipe As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PipingFailures Class


DuctPipeModified Property

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures..::.DuctPipeModified Property
BuiltInFailures..::.PipingFailures Class See Also Send Feedback
The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuctPipeModified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuctPipeModified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuctPipeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PipingFailures Class


InvalidPipeFittingKfactorDatabase Property

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures..::.InvalidPipeFittingKfactorDatabase Property
BuiltInFailures..::.PipingFailures Class See Also Send Feedback
Invalid Pipe Fitting K-Factor Database

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPipeFittingKfactorDatabase { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPipeFittingKfactorDatabase As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPipeFittingKfactorDatabase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PipingFailures Class


InvalidPipeSize Property

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures..::.InvalidPipeSize Property
BuiltInFailures..::.PipingFailures Class See Also Send Feedback
Pipe Size Table "[File Name]" is missing or invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPipeSize { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPipeSize As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPipeSize {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PipingFailures Class


MaxPipeSizeReached Property

[image]

Revit 2011 API
BuiltInFailures..::.PipingFailures..::.MaxPipeSizeReached Property
BuiltInFailures..::.PipingFailures Class See Also Send Feedback
Maximum pipe size diameter reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MaxPipeSizeReached { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MaxPipeSizeReached As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MaxPipeSizeReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PipingFailures Class


BuiltInFailures.PlanRegionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about PlanRegion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class PlanRegionFailures
Visual Basic (Declaration)
Public NotInheritable Class PlanRegionFailures
Visual C++
public ref class PlanRegionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.PlanRegionFailures

See Also

BuiltInFailures..::.PlanRegionFailures Members


BuiltInFailures.PlanRegionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures Members
BuiltInFailures..::.PlanRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.PlanRegionFailures type exposes the following members.

Properties

Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.

See Also

BuiltInFailures..::.PlanRegionFailures Class


BuiltInFailures.PlanRegionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures Properties
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback

The BuiltInFailures..::.PlanRegionFailures type exposes the following members.

Properties

Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.

See Also

BuiltInFailures..::.PlanRegionFailures Class


DeletedViewRangeLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures..::.DeletedViewRangeLevel Property
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback
Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DeletedViewRangeLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DeletedViewRangeLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DeletedViewRangeLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PlanRegionFailures Class


Intersecting Property

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures..::.Intersecting Property
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback
The boundaries of the highlighted Plan Regions overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId Intersecting { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Intersecting As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ Intersecting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PlanRegionFailures Class


InvalidPlanRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures..::.InvalidPlanRegion Property
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback
Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPlanRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPlanRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPlanRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PlanRegionFailures Class


InvalidPlanRegionError Property

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures..::.InvalidPlanRegionError Property
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback
Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPlanRegionError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidPlanRegionError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidPlanRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PlanRegionFailures Class


Nested Property

[image]

Revit 2011 API
BuiltInFailures..::.PlanRegionFailures..::.Nested Property
BuiltInFailures..::.PlanRegionFailures Class See Also Send Feedback
Cannot have nested Plan Regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId Nested { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Nested As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ Nested {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PlanRegionFailures Class


BuiltInFailures.PointFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Point Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class PointFailures
Visual Basic (Declaration)
Public NotInheritable Class PointFailures
Visual C++
public ref class PointFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.PointFailures

See Also

BuiltInFailures..::.PointFailures Members


BuiltInFailures.PointFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.PointFailures Members
BuiltInFailures..::.PointFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::.PointFailures Class


BuiltInFailures.PointFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.PointFailures Properties
BuiltInFailures..::.PointFailures Class See Also Send Feedback

The BuiltInFailures..::.PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::.PointFailures Class


CannotMakePointHostedByIntersection Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.CannotMakePointHostedByIntersection Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Cannot make point hosted by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakePointHostedByIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakePointHostedByIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakePointHostedByIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


CantChangeParamFlip Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.CantChangeParamFlip Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Can't flip Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamFlip { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantChangeParamFlip As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamFlip {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


CantChangeParamMirror Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.CantChangeParamMirror Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Can't mirror Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamMirror { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantChangeParamMirror As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


CantChangeParamRotate Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.CantChangeParamRotate Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Can't rotate Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamRotate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantChangeParamRotate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamRotate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


EdgeHostedPointToBeUnhosted Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.EdgeHostedPointToBeUnhosted Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EdgeHostedPointToBeUnhosted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EdgeHostedPointToBeUnhosted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EdgeHostedPointToBeUnhosted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


HostParameterRangeError Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.HostParameterRangeError Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Hosted Parameter must be between 0 and 1

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostParameterRangeError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostParameterRangeError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostParameterRangeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


RegenFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.PointFailures..::.RegenFailure Property
BuiltInFailures..::.PointFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.PointFailures Class


BuiltInFailures.ProfileFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ProfileFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ProfileFailures
Visual Basic (Declaration)
Public NotInheritable Class ProfileFailures
Visual C++
public ref class ProfileFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ProfileFailures

See Also

BuiltInFailures..::.ProfileFailures Members


BuiltInFailures.ProfileFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ProfileFailures Members
BuiltInFailures..::.ProfileFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::.ProfileFailures Class


BuiltInFailures.ProfileFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ProfileFailures Properties
BuiltInFailures..::.ProfileFailures Class See Also Send Feedback

The BuiltInFailures..::.ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::.ProfileFailures Class


SketchNotEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.ProfileFailures..::.SketchNotEmpty Property
BuiltInFailures..::.ProfileFailures Class See Also Send Feedback
Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchNotEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchNotEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchNotEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ProfileFailures Class


BuiltInFailures.RebarFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RebarFailures
Visual Basic (Declaration)
Public NotInheritable Class RebarFailures
Visual C++
public ref class RebarFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RebarFailures

See Also

BuiltInFailures..::.RebarFailures Members


BuiltInFailures.RebarFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarFailures Members
BuiltInFailures..::.RebarFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HookAngleMustBePositive | Rebar Hook angle is negative. Ignoring hook.
HookAngleMustBePositiveWarn | Rebar Hook angle is negative. Ignoring hook.
HookAngleTooBig | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookAngleTooBigWarn | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookLengthTooSmall | Rebar Hook Length is too small.
HookLengthTooSmallWarn | Rebar Hook Length is too small.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1000 Bars when layout is Fixed Number or Number With Spacing
TooSmallNumberOfBars | Rebar Set must contain at least two Bars.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::.RebarFailures Class


BuiltInFailures.RebarFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarFailures Properties
BuiltInFailures..::.RebarFailures Class See Also Send Feedback

The BuiltInFailures..::.RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HookAngleMustBePositive | Rebar Hook angle is negative. Ignoring hook.
HookAngleMustBePositiveWarn | Rebar Hook angle is negative. Ignoring hook.
HookAngleTooBig | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookAngleTooBigWarn | Rebar Hook angle is greater than 180 degrees. Ignoring hook.
HookLengthTooSmall | Rebar Hook Length is too small.
HookLengthTooSmallWarn | Rebar Hook Length is too small.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1000 Bars when layout is Fixed Number or Number With Spacing
TooSmallNumberOfBars | Rebar Set must contain at least two Bars.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::.RebarFailures Class


BarDiameterTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.BarDiameterTooLarge Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bar Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarDiameterTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarDiameterTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


BarTypeDoesNotAllowHooksOfCurrentShape Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.BarTypeDoesNotAllowHooksOfCurrentShape Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarTypeDoesNotAllowHooksOfCurrentShape { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarTypeDoesNotAllowHooksOfCurrentShape As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarTypeDoesNotAllowHooksOfCurrentShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


BendDiameterTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.BendDiameterTooLarge Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BendDiameterTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BendDiameterTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


BendDiameterTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.BendDiameterTooSmall Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BendDiameterTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BendDiameterTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


CannotPlaceRebar Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.CannotPlaceRebar Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceRebar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceRebar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


CannotPlaceRebarWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.CannotPlaceRebarWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceRebarWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceRebarWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebarWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


CoverTooLong Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.CoverTooLong Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Cover length is too large for host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CoverTooLong { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CoverTooLong As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CoverTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HideAllBarsInRebarSet Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HideAllBarsInRebarSet Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
All Bars in Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HideAllBarsInRebarSet { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HideAllBarsInRebarSet As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HideAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookAngleMustBePositive Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookAngleMustBePositive Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook angle is negative. Ignoring hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookAngleMustBePositive { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookAngleMustBePositive As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookAngleMustBePositive {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookAngleMustBePositiveWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookAngleMustBePositiveWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook angle is negative. Ignoring hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookAngleMustBePositiveWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookAngleMustBePositiveWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookAngleMustBePositiveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookAngleTooBig Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookAngleTooBig Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook angle is greater than 180 degrees. Ignoring hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookAngleTooBig { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookAngleTooBig As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookAngleTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookAngleTooBigWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookAngleTooBigWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook angle is greater than 180 degrees. Ignoring hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookAngleTooBigWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookAngleTooBigWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookAngleTooBigWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookLengthTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookLengthTooSmall Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook Length is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookLengthTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookLengthTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookLengthTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HookLengthTooSmallWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HookLengthTooSmallWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Hook Length is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HookLengthTooSmallWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HookLengthTooSmallWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HookLengthTooSmallWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


HostTopologyChange Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.HostTopologyChange Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
A reinforced host has undergone a major change. The reinforcement must be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostTopologyChange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostTopologyChange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostTopologyChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


IncompleteShape Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.IncompleteShape Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IncompleteShape { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IncompleteShape As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IncompleteShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


InvalidRebarHost Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.InvalidRebarHost Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar can be placed only in Concrete Structural elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRebarHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


InvalidRebarHostNonConcrete Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.InvalidRebarHostNonConcrete Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonConcrete { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRebarHostNonConcrete As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


InvalidRebarHostNonStructural Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.InvalidRebarHostNonStructural Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar can't be placed in a non-structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonStructural { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRebarHostNonStructural As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


InvalidRebarHostWrongCategory Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.InvalidRebarHostWrongCategory Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar can't be placed in a family of category [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostWrongCategory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRebarHostWrongCategory As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostWrongCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


MaxHookExtensionMultiplierWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.MaxHookExtensionMultiplierWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
The maximum Hook Extension Multiplier value permitted is 99.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MaxHookExtensionMultiplierWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MaxHookExtensionMultiplierWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MaxHookExtensionMultiplierWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


NoSurfPatternOnRebar Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.NoSurfPatternOnRebar Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnRebar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSurfPatternOnRebar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


OutSideOfHost Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.OutSideOfHost Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OutSideOfHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OutSideOfHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarArrayTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarArrayTooShort Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Set can't have coincident Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarArrayTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarArrayTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarArrayTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarBendRadiusTooBig Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarBendRadiusTooBig Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarBendRadiusTooBig { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarBendRadiusTooBig As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarBendRadiusTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarBendRadiusTooBigWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarBendRadiusTooBigWarn Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarBendRadiusTooBigWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarBendRadiusTooBigWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarBendRadiusTooBigWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarConstraintWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarConstraintWarning Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarConstraintWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarConstraintWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarConstraintWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarHooksDontMatchShape Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarHooksDontMatchShape Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
The Rebar's hooks do not match its Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarHooksDontMatchShape { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarHooksDontMatchShape As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarHooksDontMatchShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarIllegalBarType Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarIllegalBarType Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarIllegalBarType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarIllegalBarType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarIllegalBarType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarNoMatchingHooks Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarNoMatchingHooks Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
The Rebar Shape '[Family Name]' has no matching hooks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarNoMatchingHooks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarNoMatchingHooks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarNoMatchingHooks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarShapeFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarShapeFailure Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Can't solve Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarShapeFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarShapeFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarSpacingTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarSpacingTooSmall Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Bar Spacing is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSpacingTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarSpacingTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarSpacingTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarTooShortImperial Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarTooShortImperial Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 1 inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarTooShortImperial { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarTooShortImperial As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


RebarTooShortMetric Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.RebarTooShortMetric Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 25 mm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarTooShortMetric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarTooShortMetric As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


StandardHookBendDiameterTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.StandardHookBendDiameterTooLarge Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StandardHookBendDiameterTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


StandardHookBendDiameterTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.StandardHookBendDiameterTooSmall Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StandardHookBendDiameterTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


TooLargeNumberOfBars Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.TooLargeNumberOfBars Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Set must contain at most 1000 Bars when layout is Fixed Number or Number With Spacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooLargeNumberOfBars { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooLargeNumberOfBars As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooLargeNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


TooSmallNumberOfBars Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.TooSmallNumberOfBars Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Set must contain at least two Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooSmallNumberOfBars { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooSmallNumberOfBars As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooSmallNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


TrySmallerBarType Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarFailures..::.TrySmallerBarType Property
BuiltInFailures..::.RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large. Try a smaller Bar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrySmallerBarType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrySmallerBarType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrySmallerBarType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarFailures Class


BuiltInFailures.RebarShapeFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RebarShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RebarShapeFailures
Visual Basic (Declaration)
Public NotInheritable Class RebarShapeFailures
Visual C++
public ref class RebarShapeFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RebarShapeFailures

See Also

BuiltInFailures..::.RebarShapeFailures Members


BuiltInFailures.RebarShapeFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures Members
BuiltInFailures..::.RebarShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RebarShapeFailures type exposes the following members.

Properties

Name | Description
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

See Also

BuiltInFailures..::.RebarShapeFailures Class


BuiltInFailures.RebarShapeFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures Properties
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback

The BuiltInFailures..::.RebarShapeFailures type exposes the following members.

Properties

Name | Description
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

See Also

BuiltInFailures..::.RebarShapeFailures Class


CurveOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.CurveOverconstrained Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


CurvesCollinear Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.CurvesCollinear Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Collinear segments are not allowed in a Rebar Shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesCollinear { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurvesCollinear As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurvesCollinear {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


CurvesUnlooped Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.CurvesUnlooped Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Segments defining the Rebar Shape must be in a continuous loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesUnlooped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurvesUnlooped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurvesUnlooped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


CurveUnderconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.CurveUnderconstrained Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Segment is underconstrained. It requires additional parameterized dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveUnderconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveUnderconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveUnderconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


DimensionLoose Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.DimensionLoose Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
This dimension cannot be used to parameterize the Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionLoose { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionLoose As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionLoose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


DimensionWithoutParameter Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.DimensionWithoutParameter Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Dimension has no parameter assigned to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionWithoutParameter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DimensionWithoutParameter As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DimensionWithoutParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


FormulaDrivenDimension Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.FormulaDrivenDimension Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
Dimension can't be driven by a formula parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FormulaDrivenDimension { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FormulaDrivenDimension As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FormulaDrivenDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


ShapeFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarShapeFailures..::.ShapeFailure Property
BuiltInFailures..::.RebarShapeFailures Class See Also Send Feedback
The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShapeFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShapeFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarShapeFailures Class


BuiltInFailures.RebarSystemFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RebarSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RebarSystemFailures
Visual Basic (Declaration)
Public NotInheritable Class RebarSystemFailures
Visual C++
public ref class RebarSystemFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RebarSystemFailures

See Also

BuiltInFailures..::.RebarSystemFailures Members


BuiltInFailures.RebarSystemFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures Members
BuiltInFailures..::.RebarSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::.RebarSystemFailures Class


BuiltInFailures.RebarSystemFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures Properties
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback

The BuiltInFailures..::.RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::.RebarSystemFailures Class


AreaReinforcementOutSideOfHost Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.AreaReinforcementOutSideOfHost Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Area Reinforcement is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementOutSideOfHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaReinforcementOutSideOfHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementOutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


AreaReinforcementRegenFail Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.AreaReinforcementRegenFail Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't regenerate Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementRegenFail { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaReinforcementRegenFail As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementRegenFail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


AreaReinforcementsCollision Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.AreaReinforcementsCollision Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementsCollision { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaReinforcementsCollision As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementsCollision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


AreaReinforcementWrongHost Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.AreaReinforcementWrongHost Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementWrongHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaReinforcementWrongHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


BarsTooCloseNumber Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.BarsTooCloseNumber Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Bars are too close together. Decrease the Number Of Lines parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooCloseNumber { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarsTooCloseNumber As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarsTooCloseNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


BarsTooCloseSpacing Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.BarsTooCloseSpacing Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Bars are too close together. Increase the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooCloseSpacing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarsTooCloseSpacing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarsTooCloseSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


BarsTooSparseSpacing Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.BarsTooSparseSpacing Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooSparseSpacing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BarsTooSparseSpacing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BarsTooSparseSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlaceAreaReinforcement Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlaceAreaReinforcement Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceAreaReinforcement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlaceAreaReinforcementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlaceAreaReinforcementWarn Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceAreaReinforcementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlaceAreaReininforcement Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlaceAreaReininforcement Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReininforcement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceAreaReininforcement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlaceAreaReininforcementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlaceAreaReininforcementWarn Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReininforcementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceAreaReininforcementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlacePathReinforcement Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlacePathReinforcement Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReinforcement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlacePathReinforcement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlacePathReinforcementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlacePathReinforcementWarn Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReinforcementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlacePathReinforcementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReinforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlacePathReininforcement Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlacePathReininforcement Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlacePathReininforcement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


CannotPlacePathReininforcementWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.CannotPlacePathReininforcementWarn Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcementWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlacePathReininforcementWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


PathReinforcementWrongHost Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.PathReinforcementWrongHost Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementWrongHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathReinforcementWrongHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


RebarSystemOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.RebarSystemOffset Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarSystemOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarSystemOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


ThinHostFloor Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.ThinHostFloor Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostFloor { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ThinHostFloor As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


ThinHostFloorError Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.ThinHostFloorError Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostFloorError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ThinHostFloorError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloorError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


ThinHostWall Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.ThinHostWall Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ThinHostWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ThinHostWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


ThinHostWallError Property

[image]

Revit 2011 API
BuiltInFailures..::.RebarSystemFailures..::.ThinHostWallError Property
BuiltInFailures..::.RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostWallError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ThinHostWallError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ThinHostWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RebarSystemFailures Class


BuiltInFailures.RefPlaneFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RefPlaneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RefPlane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RefPlaneFailures
Visual Basic (Declaration)
Public NotInheritable Class RefPlaneFailures
Visual C++
public ref class RefPlaneFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RefPlaneFailures

See Also

BuiltInFailures..::.RefPlaneFailures Members


BuiltInFailures.RefPlaneFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RefPlaneFailures Members
BuiltInFailures..::.RefPlaneFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RefPlaneFailures type exposes the following members.

Properties

Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.

See Also

BuiltInFailures..::.RefPlaneFailures Class


BuiltInFailures.RefPlaneFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RefPlaneFailures Properties
BuiltInFailures..::.RefPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::.RefPlaneFailures type exposes the following members.

Properties

Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.

See Also

BuiltInFailures..::.RefPlaneFailures Class


AlreadyHaveTwoClosurePlanes Property

[image]

Revit 2011 API
BuiltInFailures..::.RefPlaneFailures..::.AlreadyHaveTwoClosurePlanes Property
BuiltInFailures..::.RefPlaneFailures Class See Also Send Feedback
No more than two closure planes are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyHaveTwoClosurePlanes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlreadyHaveTwoClosurePlanes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AlreadyHaveTwoClosurePlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RefPlaneFailures Class


BuiltInFailures.RegenFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RegenFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RegenFailures
Visual Basic (Declaration)
Public NotInheritable Class RegenFailures
Visual C++
public ref class RegenFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RegenFailures

See Also

BuiltInFailures..::.RegenFailures Members


BuiltInFailures.RegenFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RegenFailures Members
BuiltInFailures..::.RegenFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::.RegenFailures Class


BuiltInFailures.RegenFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RegenFailures Properties
BuiltInFailures..::.RegenFailures Class See Also Send Feedback

The BuiltInFailures..::.RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::.RegenFailures Class


CannotRegenFamily Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CannotRegenFamily Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Can't regenerate Family [Family Name]. Edit Family to modify it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRegenFamily { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRegenFamily As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRegenFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependency Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependency Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependency { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependency As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyAssocProp Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyAssocProp Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocProp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyAssocProp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyAssocPropError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyAssocPropError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocPropError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyAssocPropError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocPropError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyConstraint Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyConstraint Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraint { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyConstraint As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyConstraintError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyConstraintError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraintError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyConstraintError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraintError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencySketch Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencySketch Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Constraints in sketches of highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencySketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencySketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencySketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencySketchError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencySketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencySketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyUncut Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyUncut Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyUncut { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyUncut As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyUncutError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyUncutError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyUncutError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyUncutError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyWall Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyWall Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


CircularDependencyWallError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.CircularDependencyWallError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyWallError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CircularDependencyWallError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


ForceRegenSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.ForceRegenSketch Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Regen Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ForceRegenSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ForceRegenSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ForceRegenSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


GeomStepFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.GeomStepFailed Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GeomStepFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GeomStepFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GeomStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


GeomStepFailedError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.GeomStepFailedError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GeomStepFailedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GeomStepFailedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GeomStepFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


RegenElements Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.RegenElements Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Regenerating elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegenElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegenElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegenElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


RegeneratedElements Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.RegeneratedElements Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Elements regenerated in pass [Regen Index]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegeneratedElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegeneratedElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegeneratedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


RegenFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.RegenFailure Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


UserCancelled Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.UserCancelled Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelled { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UserCancelled As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


UserCancelledError Property

[image]

Revit 2011 API
BuiltInFailures..::.RegenFailures..::.UserCancelledError Property
BuiltInFailures..::.RegenFailures Class See Also Send Feedback
Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelledError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UserCancelledError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UserCancelledError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RegenFailures Class


BuiltInFailures.RenderFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RenderFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RenderFailures
Visual Basic (Declaration)
Public NotInheritable Class RenderFailures
Visual C++
public ref class RenderFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RenderFailures

See Also

BuiltInFailures..::.RenderFailures Members


BuiltInFailures.RenderFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RenderFailures Members
BuiltInFailures..::.RenderFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::.RenderFailures Class


BuiltInFailures.RenderFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RenderFailures Properties
BuiltInFailures..::.RenderFailures Class See Also Send Feedback

The BuiltInFailures..::.RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::.RenderFailures Class


LightParametersNotInRange Property

[image]

Revit 2011 API
BuiltInFailures..::.RenderFailures..::.LightParametersNotInRange Property
BuiltInFailures..::.RenderFailures Class See Also Send Feedback
The value should be in range of [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LightParametersNotInRange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LightParametersNotInRange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LightParametersNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RenderFailures Class


LightSourceInsideGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.RenderFailures..::.LightSourceInsideGeometry Property
BuiltInFailures..::.RenderFailures Class See Also Send Feedback
Light source is inside solid geometry. No light will be emitted during rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LightSourceInsideGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LightSourceInsideGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LightSourceInsideGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RenderFailures Class


ProhibitDeletionLightSource Property

[image]

Revit 2011 API
BuiltInFailures..::.RenderFailures..::.ProhibitDeletionLightSource Property
BuiltInFailures..::.RenderFailures Class See Also Send Feedback
The light source cannot be deleted with UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitDeletionLightSource { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitDeletionLightSource As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitDeletionLightSource {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RenderFailures Class


RenderLibNotInstalledWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RenderFailures..::.RenderLibNotInstalledWarn Property
BuiltInFailures..::.RenderFailures Class See Also Send Feedback
Rendering library has not been installed, so the third party geometry cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RenderLibNotInstalledWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RenderLibNotInstalledWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RenderLibNotInstalledWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RenderFailures Class


BuiltInFailures.RevisionCloudFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RevisionCloudFailures
Visual Basic (Declaration)
Public NotInheritable Class RevisionCloudFailures
Visual C++
public ref class RevisionCloudFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RevisionCloudFailures

See Also

BuiltInFailures..::.RevisionCloudFailures Members


BuiltInFailures.RevisionCloudFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures Members
BuiltInFailures..::.RevisionCloudFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitDeletionInIssued | The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::.RevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures Properties
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback

The BuiltInFailures..::.RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitDeletionInIssued | The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ModifyingIssuedRevisionCloudOnUpgrade Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ModifyingIssuedRevisionCloudOnUpgrade Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingIssuedRevisionCloudOnUpgrade { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModifyingIssuedRevisionCloudOnUpgrade As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModifyingIssuedRevisionCloudOnUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ProhibitCreationInIssued Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ProhibitCreationInIssued Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitCreationInIssued { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitCreationInIssued As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitCreationInIssued {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ProhibitDeletionInIssued Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ProhibitDeletionInIssued Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitDeletionInIssued { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitDeletionInIssued As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitDeletionInIssued {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ProhibitModificationOfIssuedRevisionCloud Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ProhibitModificationOfIssuedRevisionCloud Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
Issued Revision Clouds can't be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitModificationOfIssuedRevisionCloud { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitModificationOfIssuedRevisionCloud As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitModificationOfIssuedRevisionCloud {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ProhibitSwitchFromIssuedRevision Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ProhibitSwitchFromIssuedRevision Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
Can't remove cloud from an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitSwitchFromIssuedRevision { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitSwitchFromIssuedRevision As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitSwitchFromIssuedRevision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


ProhibitSwitchToIssuedRevision Property

[image]

Revit 2011 API
BuiltInFailures..::.RevisionCloudFailures..::.ProhibitSwitchToIssuedRevision Property
BuiltInFailures..::.RevisionCloudFailures Class See Also Send Feedback
Can't add cloud to an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitSwitchToIssuedRevision { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProhibitSwitchToIssuedRevision As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProhibitSwitchToIssuedRevision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevisionCloudFailures Class


BuiltInFailures.RevolutionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RevolutionFailures
Visual Basic (Declaration)
Public NotInheritable Class RevolutionFailures
Visual C++
public ref class RevolutionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RevolutionFailures

See Also

BuiltInFailures..::.RevolutionFailures Members


BuiltInFailures.RevolutionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures Members
BuiltInFailures..::.RevolutionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::.RevolutionFailures Class


BuiltInFailures.RevolutionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures Properties
BuiltInFailures..::.RevolutionFailures Class See Also Send Feedback

The BuiltInFailures..::.RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::.RevolutionFailures Class


CannotDrawRevolution Property

[image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures..::.CannotDrawRevolution Property
BuiltInFailures..::.RevolutionFailures Class See Also Send Feedback
Can't create surface of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRevolution { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawRevolution As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRevolution {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevolutionFailures Class


ProfileCrossesRevolutionAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures..::.ProfileCrossesRevolutionAxis Property
BuiltInFailures..::.RevolutionFailures Class See Also Send Feedback
The profile must not cross the axis of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileCrossesRevolutionAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProfileCrossesRevolutionAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProfileCrossesRevolutionAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevolutionFailures Class


ProfileNotPlanar Property

[image]

Revit 2011 API
BuiltInFailures..::.RevolutionFailures..::.ProfileNotPlanar Property
BuiltInFailures..::.RevolutionFailures Class See Also Send Feedback
The Profile must lie in a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileNotPlanar { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProfileNotPlanar As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProfileNotPlanar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RevolutionFailures Class


BuiltInFailures.RoofFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RoofFailures
Visual Basic (Declaration)
Public NotInheritable Class RoofFailures
Visual C++
public ref class RoofFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RoofFailures

See Also

BuiltInFailures..::.RoofFailures Members


BuiltInFailures.RoofFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RoofFailures Members
BuiltInFailures..::.RoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
HoleInRoofFailedError | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::.RoofFailures Class


BuiltInFailures.RoofFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RoofFailures Properties
BuiltInFailures..::.RoofFailures Class See Also Send Feedback

The BuiltInFailures..::.RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
HoleInRoofFailedError | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::.RoofFailures Class


CurveRoofSkippedLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.CurveRoofSkippedLoops Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveRoofSkippedLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


CurveRoofSkippedLoopsError Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.CurveRoofSkippedLoopsError Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveRoofSkippedLoopsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


CurveRoofSkippedLoopsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.CurveRoofSkippedLoopsWarn Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveRoofSkippedLoopsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


ExtrudedRoofCutBySketch Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.ExtrudedRoofCutBySketch Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Entire extruded Roof is cut by cut Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExtrudedRoofCutBySketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExtrudedRoofCutBySketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExtrudedRoofCutBySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


HadToAlignEaves Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.HadToAlignEaves Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HadToAlignEaves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HadToAlignEaves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HadToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


HoleInRoofFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.HoleInRoofFailed Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HoleInRoofFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HoleInRoofFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HoleInRoofFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


HoleInRoofFailedError Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.HoleInRoofFailedError Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HoleInRoofFailedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HoleInRoofFailedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HoleInRoofFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


InvalidArcSegmentation Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.InvalidArcSegmentation Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
A segmented slope-defining arc has too few segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidArcSegmentation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidArcSegmentation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidArcSegmentation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


JoinedRoofMissesTarget Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.JoinedRoofMissesTarget Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId JoinedRoofMissesTarget { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JoinedRoofMissesTarget As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ JoinedRoofMissesTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


JoinedRoofMissesTargetError Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.JoinedRoofMissesTargetError Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId JoinedRoofMissesTargetError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JoinedRoofMissesTargetError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ JoinedRoofMissesTargetError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


NoFlatCurtainRoofs Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.NoFlatCurtainRoofs Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
A Sloped Glazing with no slope is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFlatCurtainRoofs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFlatCurtainRoofs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFlatCurtainRoofs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


OnlyOneSlopeCurtainRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.OnlyOneSlopeCurtainRoof Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Only one slope in curtain roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyOneSlopeCurtainRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyOneSlopeCurtainRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyOneSlopeCurtainRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


OnlyUpwardFacesUsed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.OnlyUpwardFacesUsed Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyUpwardFacesUsed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyUpwardFacesUsed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyUpwardFacesUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofCutoffRemoved Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofCutoffRemoved Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofCutoffRemoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofCutoffRemoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofCutoffRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofExceedsMaxHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofExceedsMaxHeight Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Roof exceeds user-specified maximum height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofExceedsMaxHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofExceedsMaxHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofExceedsMaxHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofMeetsRoofTangentially Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofMeetsRoofTangentially Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentially { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofMeetsRoofTangentially As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofMeetsRoofTangentiallyError Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofMeetsRoofTangentiallyError Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentiallyError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofMeetsRoofTangentiallyError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentiallyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofSlopeExceedsThreshold Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofSlopeExceedsThreshold Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofSlopeExceedsThreshold { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofSlopeExceedsThreshold As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofToRefPlanes Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofToRefPlanes Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofToRefPlanes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofToRefPlanes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofToRefPlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


RoofToRefPlanesError Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.RoofToRefPlanesError Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoofToRefPlanesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoofToRefPlanesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoofToRefPlanesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


UnusedSlopeArrow Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.UnusedSlopeArrow Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
The tails of all slope arrows must lie on the roof boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnusedSlopeArrow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnusedSlopeArrow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnusedSlopeArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


UptoHeightTooLow Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.UptoHeightTooLow Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Cutoff Level cannot be below bottom of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UptoHeightTooLow { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UptoHeightTooLow As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UptoHeightTooLow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


UserCancelledRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.UserCancelledRoof Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelledRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UserCancelledRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UserCancelledRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


WorkplaneShouldBeLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.RoofFailures..::.WorkplaneShouldBeLevel Property
BuiltInFailures..::.RoofFailures Class See Also Send Feedback
Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WorkplaneShouldBeLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WorkplaneShouldBeLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WorkplaneShouldBeLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoofFailures Class


BuiltInFailures.RoomFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class RoomFailures
Visual Basic (Declaration)
Public NotInheritable Class RoomFailures
Visual C++
public ref class RoomFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.RoomFailures

See Also

BuiltInFailures..::.RoomFailures Members


BuiltInFailures.RoomFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.RoomFailures Members
BuiltInFailures..::.RoomFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | A Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotCopyLinkedRooms | Linked Rooms may not be pasted
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] Volumes Overlap, adjust Upper Limit and Upper Offset.
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::.RoomFailures Class


BuiltInFailures.RoomFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.RoomFailures Properties
BuiltInFailures..::.RoomFailures Class See Also Send Feedback

The BuiltInFailures..::.RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | A Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotCopyLinkedRooms | Linked Rooms may not be pasted
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] Volumes Overlap, adjust Upper Limit and Upper Offset.
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::.RoomFailures Class


AreaTagBadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.AreaTagBadViewType Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaTagBadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaTagBadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaTagBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


AreaUnplaceWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.AreaUnplaceWarning Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
A Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaUnplaceWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaUnplaceWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


CannotCopyLinkedRooms Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.CannotCopyLinkedRooms Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Linked Rooms may not be pasted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLinkedRooms { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyLinkedRooms As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLinkedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


CannotMakeRoomsGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.CannotMakeRoomsGeometry Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Could not create geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoomsGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeRoomsGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoomsGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


ExtensionsOverlapWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.ExtensionsOverlapWarning Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ExtensionsOverlapWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExtensionsOverlapWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ExtensionsOverlapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


InvalidReflectivityPercentage Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.InvalidReflectivityPercentage Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
The value for Reflectivity must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidReflectivityPercentage { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidReflectivityPercentage As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidReflectivityPercentage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


InvisibleRoomBoundElemement Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.InvisibleRoomBoundElemement Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Bounding element is invisible in current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvisibleRoomBoundElemement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvisibleRoomBoundElemement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvisibleRoomBoundElemement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


OptionConflictBoundariesVaryMainAddToOptionSet Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.OptionConflictBoundariesVaryMainAddToOptionSet Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryMainAddToOptionSet { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainAddToOptionSet As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


OptionConflictBoundariesVaryMainSeparate Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.OptionConflictBoundariesVaryMainSeparate Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryMainSeparate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainSeparate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


OptionConflictBoundariesVaryOptionSeparate Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.OptionConflictBoundariesVaryOptionSeparate Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryOptionSeparate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionConflictBoundariesVaryOptionSeparate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


OptionConflictRoomOverlapMain Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.OptionConflictRoomOverlapMain Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapMain { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionConflictRoomOverlapMain As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapMain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


OptionConflictRoomOverlapOption Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.OptionConflictRoomOverlapOption Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapOption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OptionConflictRoomOverlapOption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomBaseAboveComputationHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomBaseAboveComputationHeight Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[RoomBase]'s lower offset is above the Computation Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBaseAboveComputationHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomBaseAboveComputationHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomBaseAboveComputationHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomBelowCompHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomBelowCompHeight Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBelowCompHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomBelowCompHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomBelowCompHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomBoundaryMisalignment Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomBoundaryMisalignment Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] bounding element might be misaligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBoundaryMisalignment { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomBoundaryMisalignment As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomBoundaryMisalignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomHeightNegative Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomHeightNegative Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] must have a height greater than 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomHeightNegative { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomHeightNegative As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomHeightNegative {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomLevelElevs Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomLevelElevs Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
A [Room]s Upper Limit must be above its Base Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomLevelElevs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomLevelElevs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomLevelElevs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomNotEnclosed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomNotEnclosed Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotEnclosed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomNotEnclosedAreas Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomNotEnclosedAreas Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedAreas { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotEnclosedAreas As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomNotEnclosedRooms Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomNotEnclosedRooms Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedRooms { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotEnclosedRooms As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomNotEnclosedSpaces Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomNotEnclosedSpaces Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedSpaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomNotEnclosedSpaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsCreatedAutomatically Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsCreatedAutomatically Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] [Room] created automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsCreatedAutomatically { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsCreatedAutomatically As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsCreatedAutomatically {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsFailed Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] computations only succeeded without considering the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsInSameRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsInSameRegion Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsInSameRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsInSameRegionAreas Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsInSameRegionAreas Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionAreas { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsInSameRegionAreas As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsInSameRegionRooms Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsInSameRegionRooms Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionRooms { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsInSameRegionRooms As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsInSameRegionSpaces Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsInSameRegionSpaces Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionSpaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsInSameRegionSpaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsOverlapInHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsOverlapInHeight Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Volumes Overlap, adjust Upper Limit and Upper Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsOverlapInHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsOverlapInHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsOverlapInHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomsReallyFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomsReallyFailed Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] computations failed. Try to modify the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsReallyFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomsReallyFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomsReallyFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagBadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagBadViewType Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagBadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagBadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagDeleted Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagNotInRoom Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagNotInRoom Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoom { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagNotInRoom As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagNotInRoomToArea Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagNotInRoomToArea Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToArea { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagNotInRoomToArea As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagNotInRoomToRoom Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagNotInRoomToRoom Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToRoom { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagNotInRoomToRoom As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagNotInRoomToSpace Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagNotInRoomToSpace Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToSpace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagNotInRoomToSpace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToSpace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTagVolumeNotComputed Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTagVolumeNotComputed Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Tag is displaying volume that can't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagVolumeNotComputed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTagVolumeNotComputed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTagVolumeNotComputed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomTooShort Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] is very short. If this is not intended, change its Upper Limit and Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


RoomUnplaceWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.RoomUnplaceWarning Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RoomUnplaceWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RoomUnplaceWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RoomUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


ShowRoomBoundingElements Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.ShowRoomBoundingElements Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
[Room] Bounding elements are highlighted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShowRoomBoundingElements { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShowRoomBoundingElements As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShowRoomBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


SpaceUnplaceWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.RoomFailures..::.SpaceUnplaceWarning Property
BuiltInFailures..::.RoomFailures Class See Also Send Feedback
A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SpaceUnplaceWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpaceUnplaceWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SpaceUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.RoomFailures Class


BuiltInFailures.ScheduleViewFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ScheduleViewFailures
Visual Basic (Declaration)
Public NotInheritable Class ScheduleViewFailures
Visual C++
public ref class ScheduleViewFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ScheduleViewFailures

See Also

BuiltInFailures..::.ScheduleViewFailures Members


BuiltInFailures.ScheduleViewFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures Members
BuiltInFailures..::.ScheduleViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::.ScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures Properties
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback

The BuiltInFailures..::.ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::.ScheduleViewFailures Class


BadViewType Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.BadViewType Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


CannotResizeColumn Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.CannotResizeColumn Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Can't resize column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotResizeColumn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotResizeColumn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotResizeColumn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


ColumnsExceedSegment Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.ColumnsExceedSegment Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnsExceedSegment { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnsExceedSegment As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnsExceedSegment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


ColumnsExcluded Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.ColumnsExcluded Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Some columns in the project are excluded from the graphical column schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnsExcluded { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColumnsExcluded As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ColumnsExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


DuplicateFieldRemovedFromKeySchedule Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.DuplicateFieldRemovedFromKeySchedule Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Duplicate fields across key schedules will be removed after paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateFieldRemovedFromKeySchedule { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateFieldRemovedFromKeySchedule As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateFieldRemovedFromKeySchedule {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


NoColumnsJoinedToGridLines Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.NoColumnsJoinedToGridLines Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
No columns are joined to grid lines, or view parameters exclude all columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoColumnsJoinedToGridLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoColumnsJoinedToGridLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoColumnsJoinedToGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


NotGridName Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.NotGridName Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
'[Text]' is not a Grid line name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotGridName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotGridName As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotGridName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


PanelScheduleLoadClassInconsistency Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.PanelScheduleLoadClassInconsistency Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelScheduleLoadClassInconsistency { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelScheduleLoadClassInconsistency As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleLoadClassInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


PanelScheduleSlotInconsistency Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.PanelScheduleSlotInconsistency Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PanelScheduleSlotInconsistency { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PanelScheduleSlotInconsistency As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleSlotInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


SchedulesCanBePlacedOnSheetsOnly Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.SchedulesCanBePlacedOnSheetsOnly Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SchedulesCanBePlacedOnSheetsOnly { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SchedulesCanBePlacedOnSheetsOnly As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SchedulesCanBePlacedOnSheetsOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


SegmentsStartIsGreaterThanSegmentsEnd Property

[image]

Revit 2011 API
BuiltInFailures..::.ScheduleViewFailures..::.SegmentsStartIsGreaterThanSegmentsEnd Property
BuiltInFailures..::.ScheduleViewFailures Class See Also Send Feedback
Change values so Segments End is greater than or equal to Segments Start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsStartIsGreaterThanSegmentsEnd { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SegmentsStartIsGreaterThanSegmentsEnd As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SegmentsStartIsGreaterThanSegmentsEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ScheduleViewFailures Class


BuiltInFailures.SculptingFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SculptingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sculpting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SculptingFailures
Visual Basic (Declaration)
Public NotInheritable Class SculptingFailures
Visual C++
public ref class SculptingFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SculptingFailures

See Also

BuiltInFailures..::.SculptingFailures Members


BuiltInFailures.SculptingFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SculptingFailures Members
BuiltInFailures..::.SculptingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::.SculptingFailures Class


BuiltInFailures.SculptingFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SculptingFailures Properties
BuiltInFailures..::.SculptingFailures Class See Also Send Feedback

The BuiltInFailures..::.SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::.SculptingFailures Class


FaceSculptEditFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SculptingFailures..::.FaceSculptEditFailed Property
BuiltInFailures..::.SculptingFailures Class See Also Send Feedback
Face Sculpt Edit failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSculptEditFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceSculptEditFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceSculptEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SculptingFailures Class


FaceSculptingFaceLoss Property

[image]

Revit 2011 API
BuiltInFailures..::.SculptingFailures..::.FaceSculptingFaceLoss Property
BuiltInFailures..::.SculptingFailures Class See Also Send Feedback
The original sculpted face is lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSculptingFaceLoss { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceSculptingFaceLoss As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceSculptingFaceLoss {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SculptingFailures Class


BuiltInFailures.SectionViewFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SectionViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SectionViewFailures
Visual Basic (Declaration)
Public NotInheritable Class SectionViewFailures
Visual C++
public ref class SectionViewFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SectionViewFailures

See Also

BuiltInFailures..::.SectionViewFailures Members


BuiltInFailures.SectionViewFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SectionViewFailures Members
BuiltInFailures..::.SectionViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
SectionAndScopeBoxNotOrtho | Section must be parallel to one side of the associated scope box.

See Also

BuiltInFailures..::.SectionViewFailures Class


BuiltInFailures.SectionViewFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SectionViewFailures Properties
BuiltInFailures..::.SectionViewFailures Class See Also Send Feedback

The BuiltInFailures..::.SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
SectionAndScopeBoxNotOrtho | Section must be parallel to one side of the associated scope box.

See Also

BuiltInFailures..::.SectionViewFailures Class


ScopeBoxBehindSection Property

[image]

Revit 2011 API
BuiltInFailures..::.SectionViewFailures..::.ScopeBoxBehindSection Property
BuiltInFailures..::.SectionViewFailures Class See Also Send Feedback
Section may not be associated to a scope box which lies behind it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ScopeBoxBehindSection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ScopeBoxBehindSection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ScopeBoxBehindSection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SectionViewFailures Class


SectionAndScopeBoxNotOrtho Property

[image]

Revit 2011 API
BuiltInFailures..::.SectionViewFailures..::.SectionAndScopeBoxNotOrtho Property
BuiltInFailures..::.SectionViewFailures Class See Also Send Feedback
Section must be parallel to one side of the associated scope box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SectionAndScopeBoxNotOrtho { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SectionAndScopeBoxNotOrtho As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SectionAndScopeBoxNotOrtho {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SectionViewFailures Class


BuiltInFailures.SelectionFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SelectionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Selections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SelectionFailures
Visual Basic (Declaration)
Public NotInheritable Class SelectionFailures
Visual C++
public ref class SelectionFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SelectionFailures

See Also

BuiltInFailures..::.SelectionFailures Members


BuiltInFailures.SelectionFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SelectionFailures Members
BuiltInFailures..::.SelectionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::.SelectionFailures Class


BuiltInFailures.SelectionFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SelectionFailures Properties
BuiltInFailures..::.SelectionFailures Class See Also Send Feedback

The BuiltInFailures..::.SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::.SelectionFailures Class


NoElementSelected Property

[image]

Revit 2011 API
BuiltInFailures..::.SelectionFailures..::.NoElementSelected Property
BuiltInFailures..::.SelectionFailures Class See Also Send Feedback
No element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoElementSelected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoElementSelected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SelectionFailures Class


NoValidElementSelected Property

[image]

Revit 2011 API
BuiltInFailures..::.SelectionFailures..::.NoValidElementSelected Property
BuiltInFailures..::.SelectionFailures Class See Also Send Feedback
No valid element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoValidElementSelected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoValidElementSelected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoValidElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SelectionFailures Class


BuiltInFailures.SheetFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SheetFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SheetFailures
Visual Basic (Declaration)
Public NotInheritable Class SheetFailures
Visual C++
public ref class SheetFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SheetFailures

See Also

BuiltInFailures..::.SheetFailures Members


BuiltInFailures.SheetFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SheetFailures Members
BuiltInFailures..::.SheetFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::.SheetFailures Class


BuiltInFailures.SheetFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SheetFailures Properties
BuiltInFailures..::.SheetFailures Class See Also Send Feedback

The BuiltInFailures..::.SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::.SheetFailures Class


SheetNumberDuplicated Property

[image]

Revit 2011 API
BuiltInFailures..::.SheetFailures..::.SheetNumberDuplicated Property
BuiltInFailures..::.SheetFailures Class See Also Send Feedback
Sheet Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SheetNumberDuplicated { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SheetNumberDuplicated As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SheetNumberDuplicated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SheetFailures Class


SheetNumberEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.SheetFailures..::.SheetNumberEmpty Property
BuiltInFailures..::.SheetFailures Class See Also Send Feedback
Sheet Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SheetNumberEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SheetNumberEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SheetNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SheetFailures Class


BuiltInFailures.SiteFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SiteFailures
Visual Basic (Declaration)
Public NotInheritable Class SiteFailures
Visual C++
public ref class SiteFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SiteFailures

See Also

BuiltInFailures..::.SiteFailures Members


BuiltInFailures.SiteFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SiteFailures Members
BuiltInFailures..::.SiteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForRegion | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoHostForRegionWarn | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoSurfPatternOnSite | Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.

See Also

BuiltInFailures..::.SiteFailures Class


BuiltInFailures.SiteFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SiteFailures Properties
BuiltInFailures..::.SiteFailures Class See Also Send Feedback

The BuiltInFailures..::.SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForRegion | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoHostForRegionWarn | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoSurfPatternOnSite | Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.

See Also

BuiltInFailures..::.SiteFailures Class


BuildingPadNotConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.BuildingPadNotConnected Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Can't create a single Pad with several connected regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNotConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildingPadNotConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


BuildingPadOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.BuildingPadOverlap Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Pads can't overlap (but can share edges).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildingPadOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BuildingPadOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


CannotComputeProperArea Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.CannotComputeProperArea Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Property Lines must close. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeProperArea { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotComputeProperArea As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotComputeProperArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


CannotIntersectSiteRegions Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.CannotIntersectSiteRegions Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Subregions cannot intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotIntersectSiteRegions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotIntersectSiteRegions As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotIntersectSiteRegions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


CannotMakeSurface Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.CannotMakeSurface Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


ContourLabelEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.ContourLabelEmpty Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Contour Label doesn't intersect any contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContourLabelEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContourLabelEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContourLabelEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


EnterValueOrFormula Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.EnterValueOrFormula Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Enter a value or a formula starting with '='.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueOrFormula { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EnterValueOrFormula As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EnterValueOrFormula {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


GradingInSamePhase Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.GradingInSamePhase Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId GradingInSamePhase { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GradingInSamePhase As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ GradingInSamePhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


NoHostForRegion Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.NoHostForRegion Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoHostForRegion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoHostForRegion As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoHostForRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


NoHostForRegionWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.NoHostForRegionWarn Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoHostForRegionWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoHostForRegionWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoHostForRegionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


NoSurfPatternOnSite Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.NoSurfPatternOnSite Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnSite { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoSurfPatternOnSite As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnSite {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


NotEnoughPointsInSurface Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.NotEnoughPointsInSurface Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The surface must have at least three distinct Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughPointsInSurface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotEnoughPointsInSurface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotEnoughPointsInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


PointNotInSurface Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.PointNotInSurface Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PointNotInSurface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PointNotInSurface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PointNotInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


PointRelativeOutside Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.PointRelativeOutside Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PointRelativeOutside { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PointRelativeOutside As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PointRelativeOutside {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


PropertyIntersect Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.PropertyIntersect Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Property lines intersect. Area calculations will not be precise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PropertyIntersect { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PropertyIntersect As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PropertyIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


RegionPhaseMismatch Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.RegionPhaseMismatch Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RegionPhaseMismatch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegionPhaseMismatch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RegionPhaseMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


ResetToposurfacePhaseCreated Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.ResetToposurfacePhaseCreated Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ResetToposurfacePhaseCreated { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ResetToposurfacePhaseCreated As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ResetToposurfacePhaseCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SiteEditPointsClipped Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SiteEditPointsClipped Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SiteEditPointsClipped { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SiteEditPointsClipped As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsClipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SiteEditPointsInvisible Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SiteEditPointsInvisible Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SiteEditPointsInvisible { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SiteEditPointsInvisible As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SiteMergeDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SiteMergeDisconnected Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SiteMergeDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SiteMergeDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SiteMergeDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SitePhasesDontOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SitePhasesDontOverlap Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SitePhasesDontOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SitePhasesDontOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SitePhasesDontOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SiteRegionOptionConflict Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SiteRegionOptionConflict Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
Subregions must be in the same Design Option as their Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SiteRegionOptionConflict { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SiteRegionOptionConflict As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SiteRegionOptionConflict {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SurfaceSelfIntersection Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceSelfIntersection Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSelfIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceSelfIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SurfaceSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceSplit Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SurfaceSplitError Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceSplitError Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplitError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceSplitError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SurfaceSplitNoIntersection Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceSplitNoIntersection Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplitNoIntersection { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceSplitNoIntersection As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitNoIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


SurfaceTriangulationFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteFailures..::.SurfaceTriangulationFailed Property
BuiltInFailures..::.SiteFailures Class See Also Send Feedback
The Site Surface failed to triangulate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceTriangulationFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceTriangulationFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceTriangulationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteFailures Class


BuiltInFailures.SiteImportFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SiteImport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SiteImportFailures
Visual Basic (Declaration)
Public NotInheritable Class SiteImportFailures
Visual C++
public ref class SiteImportFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SiteImportFailures

See Also

BuiltInFailures..::.SiteImportFailures Members


BuiltInFailures.SiteImportFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures Members
BuiltInFailures..::.SiteImportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooLarge | There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::.SiteImportFailures Class


BuiltInFailures.SiteImportFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures Properties
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback

The BuiltInFailures..::.SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooLarge | There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::.SiteImportFailures Class


BoundaryDetectError Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.BoundaryDetectError Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BoundaryDetectError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BoundaryDetectError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BoundaryDetectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


ContoursNoncontours Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.ContoursNoncontours Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContoursNoncontours { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContoursNoncontours As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContoursNoncontours {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


DifferentEntityTypes Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.DifferentEntityTypes Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DifferentEntityTypes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DifferentEntityTypes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DifferentEntityTypes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


NoPoints Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.NoPoints Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
No points were found in the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoPoints { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoPoints As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


NoViewSpecificSiteImports Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.NoViewSpecificSiteImports Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
Can't make Toposurface from View Specific Imports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoViewSpecificSiteImports { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoViewSpecificSiteImports As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoViewSpecificSiteImports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


SurfaceExists Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.SurfaceExists Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceExists { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SurfaceExists As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SurfaceExists {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


TooFarAway Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.TooFarAway Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooFarAway { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooFarAway As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooFarAway {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


TooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.TooLarge Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


TooManyMeshes Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.TooManyMeshes Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyMeshes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManyMeshes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManyMeshes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


UnusedPoints Property

[image]

Revit 2011 API
BuiltInFailures..::.SiteImportFailures..::.UnusedPoints Property
BuiltInFailures..::.SiteImportFailures Class See Also Send Feedback
Some rows from the file could not be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnusedPoints { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnusedPoints As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnusedPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SiteImportFailures Class


BuiltInFailures.SketchFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SketchFailures
Visual Basic (Declaration)
Public NotInheritable Class SketchFailures
Visual C++
public ref class SketchFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SketchFailures

See Also

BuiltInFailures..::.SketchFailures Members


BuiltInFailures.SketchFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SketchFailures Members
BuiltInFailures..::.SketchFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
HostFinishOverlapOld | Host Finish overlapped.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForBuildingpadError | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MoreThanOneAxis | More than one axes of revolution.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path can not be a closed loop.
PathCannotBeClosedLoopPath3d | Path can not be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::.SketchFailures Class


BuiltInFailures.SketchFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SketchFailures Properties
BuiltInFailures..::.SketchFailures Class See Also Send Feedback

The BuiltInFailures..::.SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
HostFinishOverlapOld | Host Finish overlapped.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForBuildingpadError | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MoreThanOneAxis | More than one axes of revolution.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path can not be a closed loop.
PathCannotBeClosedLoopPath3d | Path can not be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::.SketchFailures Class


AreaLoadNoForce Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.AreaLoadNoForce Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Load can't have all force components equal to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaLoadNoForce { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaLoadNoForce As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaLoadNoForce {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


AreaReinforcementWrongHost Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.AreaReinforcementWrongHost Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementWrongHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AreaReinforcementWrongHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


AxisNotSpecified Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.AxisNotSpecified Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Axis of revolution not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AxisNotSpecified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AxisNotSpecified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AxisNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BadNosingProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BadNosingProfile Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadNosingProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadNosingProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadNosingProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BadRailingsProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BadRailingsProfile Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailingsProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadRailingsProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadRailingsProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BeamDirectionNotSpecified Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BeamDirectionNotSpecified Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BeamDirectionNotSpecified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BeamDirectionNotSpecified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BeamDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BeamDirectionNotSpecifiedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BeamDirectionNotSpecifiedError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BeamDirectionNotSpecifiedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BeamDirectionNotSpecifiedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BeamDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BuildingPadNoSurface Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BuildingPadNoSurface Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurface { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildingPadNoSurface As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BuildingPadNoSurfaceError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.BuildingPadNoSurfaceError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurfaceError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildingPadNoSurfaceError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotChangeUserSketchPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotChangeUserSketchPlane Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeUserSketchPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotChangeUserSketchPlaneError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotChangeUserSketchPlaneError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlaneError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeUserSketchPlaneError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlaneError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotChangeWorkplaneVisibility Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotChangeWorkplaneVisibility Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't change Work Plane Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeWorkplaneVisibility { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeWorkplaneVisibility As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeWorkplaneVisibility {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotComputeRailingsElevation Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotComputeRailingsElevation Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotComputeRailingsElevation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotComputeRailingsElevationError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotComputeRailingsElevationError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotComputeRailingsElevationError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotComputeRailingsElevationWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotComputeRailingsElevationWarn Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotComputeRailingsElevationWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotConvertSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotConvertSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't convert Sketch to Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotConvertSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotConvertSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotDrawExtrusionRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotDrawExtrusionRoof Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't make extruded roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusionRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawExtrusionRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusionRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotDrawProfileRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotDrawProfileRoof Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotGetSketchReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotGetSketchReferences Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot find references to dimension sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGetSketchReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGetSketchReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGetSketchReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotHaveArcs Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotHaveArcs Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveArcs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotHaveArcs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotHaveArcs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CannotHaveArcsPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CannotHaveArcsPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveArcsPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotHaveArcsPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotHaveArcsPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ClosedProfileRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ClosedProfileRoof Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedProfileRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ClosedProfileRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ClosedProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ConstantHeightNotParallel Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ConstantHeightNotParallel Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConstantHeightNotParallel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConstantHeightNotParallel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConstantHeightNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ConstantHeightNotParallelError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ConstantHeightNotParallelError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConstantHeightNotParallelError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConstantHeightNotParallelError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConstantHeightNotParallelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ContainedInOtherLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ContainedInOtherLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContainedInOtherLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContainedInOtherLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContainedInOtherLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ConvertSplineToLineFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ConvertSplineToLineFailed Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Failed to convert spline to straight line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertSplineToLineFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConvertSplineToLineFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConvertSplineToLineFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CurveFromPickedFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CurveFromPickedFailed Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Can't create boundary from pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveFromPickedFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveFromPickedFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveFromPickedFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CurveIntersectsCutFace Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CurveIntersectsCutFace Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveIntersectsCutFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveIntersectsCutFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsCutFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CurveIntersectsSplitFace Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CurveIntersectsSplitFace Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveIntersectsSplitFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveIntersectsSplitFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsSplitFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


CurveTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.CurveTooShort Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CurveTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CurveTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


DifferentOffsets Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.DifferentOffsets Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DifferentOffsets { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DifferentOffsets As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DifferentOffsets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ElementsSketchTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ElementsSketchTooLarge Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The sketch defining the highlighted element is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsSketchTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsSketchTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsSketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


EndsNotOnCutFace Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.EndsNotOnCutFace Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Ends of the sketched loop do not lie on the boundary of the face being modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnCutFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndsNotOnCutFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnCutFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


EndsNotOnEdge Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.EndsNotOnEdge Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnEdge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndsNotOnEdge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


FloorCannotAddDirectionCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.FloorCannotAddDirectionCurve Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorCannotAddDirectionCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


FloorCannotAddDirectionCurveError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.FloorCannotAddDirectionCurveError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurveError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorCannotAddDirectionCurveError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


FloorDirectionNotSpecified Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.FloorDirectionNotSpecified Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Structural floor span direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorDirectionNotSpecified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorDirectionNotSpecified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


FloorManyDirectionCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.FloorManyDirectionCurves Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one span direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FloorManyDirectionCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FloorManyDirectionCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FloorManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


HostFinishOverlapOld Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.HostFinishOverlapOld Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Host Finish overlapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishOverlapOld { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostFinishOverlapOld As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ HostFinishOverlapOld {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidAreaLoadSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidAreaLoadSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidAreaLoadSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidAreaLoadSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidAreaLoadSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidAreaLoadSketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidAreaLoadSketchError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidAreaLoadSketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidAreaLoadSketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidAreaLoadSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidElevationSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidElevationSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElevationSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidElevationSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidElevationSketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidElevationSketchError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElevationSketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidElevationSketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidProfile Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidProfileError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidProfileError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidProfileError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidProfileError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidProfileError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidRoofCurveloop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidRoofCurveloop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRoofCurveloop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidRoofCurveloopError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidRoofCurveloopError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRoofCurveloopError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidRoofCurveloopFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidRoofCurveloopFailure Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRoofCurveloopFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchForBuildingpad Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchForBuildingpad Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Pad sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForBuildingpad { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchForBuildingpad As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForBuildingpad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchForBuildingpadError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchForBuildingpadError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Pad sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForBuildingpadError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchForBuildingpadError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForBuildingpadError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchForCeiling Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchForCeiling Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Ceiling sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForCeiling { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchForCeiling As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForCeiling {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchForFloor Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchForFloor Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Floor sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForFloor { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchForFloor As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForFloor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchForRoofsoffit Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchForRoofsoffit Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Roof Soffit sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForRoofsoffit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchForRoofsoffit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForRoofsoffit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


InvalidSketchPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.InvalidSketchPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidSketchPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LinesOverlap Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LinesOverlap Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlap { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinesOverlap As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LinesOverlapError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LinesOverlapError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlapError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinesOverlapError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LinesOverlapPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LinesOverlapPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlapPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LinesOverlapPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LoopIntersect Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LoopIntersect Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersect { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopIntersect As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LoopIntersectError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LoopIntersectError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersectError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopIntersectError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LoopIntersectPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LoopIntersectPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersectPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopIntersectPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LoopsOutsideFaceSplit Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LoopsOutsideFaceSplit Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopsOutsideFaceSplit As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


LoopsOutsideFaceSplitterTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.LoopsOutsideFaceSplitterTooShort Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitterTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoopsOutsideFaceSplitterTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitterTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ManyCCWLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ManyCCWLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ManyCCWLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ManyCCWLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ManyCCWLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ManyCCWLoopsError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ManyCCWLoopsError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ManyCCWLoopsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ManyCCWLoopsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ManyCCWLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ManyDirectionCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ManyDirectionCurves Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ManyDirectionCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ManyDirectionCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ManyDirectionCurvesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ManyDirectionCurvesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ManyDirectionCurvesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ManyDirectionCurvesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


MoreThanOneAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.MoreThanOneAxis Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one axes of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MoreThanOneAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MoreThanOneAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NestedLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NestedLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot have nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NestedLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NestedLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NestedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NoLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NoLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NoLoopsError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NoLoopsError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoopsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLoopsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NoLoopsPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NoLoopsPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoopsPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoLoopsPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoLoopsPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NonMonotoneRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NonMonotoneRoof Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonMonotoneRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonMonotoneRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NoPlane Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NoPlane Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Highlighted geometry no longer determines a plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoPlane { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoPlane As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneCCWLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneCCWLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCCWLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneCCWLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneCCWLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneCurve Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneCurveError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneCurveError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurveError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneCurveError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneCurvePath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneCurvePath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurvePath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneCurvePath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneCurvePath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


NotOneLoopPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.NotOneLoopPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneLoopPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotOneLoopPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotOneLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


OpenAreaLoadLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.OpenAreaLoadLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenAreaLoadLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


OpenAreaLoadLoopError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.OpenAreaLoadLoopError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoopError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenAreaLoadLoopError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


OpenLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.OpenLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


OpenLoopError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.OpenLoopError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoopError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenLoopError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


OpenLoopPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.OpenLoopPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoopPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OpenLoopPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OpenLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathCannotBeClosedLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathCannotBeClosedLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Path can not be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathCannotBeClosedLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathCannotBeClosedLoopPath3d Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathCannotBeClosedLoopPath3d Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Path can not be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoopPath3d { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathCannotBeClosedLoopPath3d As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathReinforcementClosedLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathReinforcementClosedLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch contains a closed loop. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementClosedLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathReinforcementClosedLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathReinforcementEmptySketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathReinforcementEmptySketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is empty. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementEmptySketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathReinforcementEmptySketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathReinforcementManyLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathReinforcementManyLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch contains more than one chain. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementManyLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathReinforcementManyLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


PathReinforcementWrongHost Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.PathReinforcementWrongHost Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementWrongHost { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PathReinforcementWrongHost As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RailingDoublyConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RailingDoublyConnected Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RailingDoublyConnectedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RailingDoublyConnectedError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnectedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingDoublyConnectedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RailingNotConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RailingNotConnected Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RailingNotConnectedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RailingNotConnectedError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnectedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingNotConnectedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarEmptySketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarEmptySketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarEmptySketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarEmptySketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarEmptySketchError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarEmptySketchError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarEmptySketchError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarEmptySketchError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarManyLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarManyLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarManyLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarManyLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarManyLoopsError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarManyLoopsError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarManyLoopsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarManyLoopsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarManyLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarSystemDirectionNotSpecified Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarSystemDirectionNotSpecified Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarSystemDirectionNotSpecified As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


RebarSystemDirectionNotSpecifiedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.RebarSystemDirectionNotSpecifiedError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecifiedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RebarSystemDirectionNotSpecifiedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SculptingCurvesCannotFormClosedLoop Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SculptingCurvesCannotFormClosedLoop Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Curves cannot form a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesCannotFormClosedLoop { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SculptingCurvesCannotFormClosedLoop As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCannotFormClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SculptingCurvesCrossAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SculptingCurvesCrossAxis Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The highlighted curves cross the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesCrossAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SculptingCurvesCrossAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCrossAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SculptingCurvesTouchAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SculptingCurvesTouchAxis Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The highlighted curves touch the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesTouchAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SculptingCurvesTouchAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesTouchAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SculptingLoopsOnBothSidesOfAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SculptingLoopsOnBothSidesOfAxis Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
All curves must be on the same side of the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingLoopsOnBothSidesOfAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SculptingLoopsOnBothSidesOfAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SculptingLoopsOnBothSidesOfAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SculptingSingleLineLoopLiesOnAxis Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SculptingSingleLineLoopLiesOnAxis Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The highlighted lines lie on the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingSingleLineLoopLiesOnAxis { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SculptingSingleLineLoopLiesOnAxis As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SculptingSingleLineLoopLiesOnAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ShortCurveInSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ShortCurveInSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShortCurveInSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShortCurveInSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


ShortCurveInSketchRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.ShortCurveInSketchRoof Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShortCurveInSketchRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShortCurveInSketchRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketchRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SiteCannotDrawSurfaceBoundary Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SiteCannotDrawSurfaceBoundary Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Cannot make surface with specified boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SiteCannotDrawSurfaceBoundary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SiteCannotDrawSurfaceBoundary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SiteCannotDrawSurfaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchFailurePlanes Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchFailurePlanes Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is no longer parallel to its defining plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchFailurePlanes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchFailurePlanes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchFailurePlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchingInTheWrongView Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchingInTheWrongView Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Detail sketch is only editable in [View Type].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchingInTheWrongView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchingInTheWrongView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchingInTheWrongView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchingInWrongView Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchingInWrongView Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Detail sketch is not editable in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchingInWrongView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchingInWrongView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchingInWrongView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchOverconstrained Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchOverconstrained Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrained { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchOverconstrained As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchOverconstrainedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchOverconstrainedError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrainedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchOverconstrainedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrainedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchOverconstrainedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchOverconstrainedWarn Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrainedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchOverconstrainedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrainedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchTooLarge Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchTooLarge Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchTooLarge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchTooLarge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SketchWasDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SketchWasDeleted Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SketchWasDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SketchWasDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SketchWasDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairClosedBoundaries Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairClosedBoundaries Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairClosedBoundaries { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairClosedBoundaries As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairClosedBoundariesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairClosedBoundariesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairClosedBoundariesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairClosedBoundariesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairNotEnoughBoundaryCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairNotEnoughBoundaryCurves Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairNotEnoughBoundaryCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairNotEnoughBoundaryCurvesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairNotEnoughBoundaryCurvesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurvesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairNotEnoughBoundaryCurvesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairNotEnoughRiserCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairNotEnoughRiserCurves Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairNotEnoughRiserCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairNotEnoughRiserCurvesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairNotEnoughRiserCurvesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurvesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairNotEnoughRiserCurvesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairOnlyOneConnectedBoundary Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairOnlyOneConnectedBoundary Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs require no less than two boundaries (chains of one or more Boundary Lines)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairOnlyOneConnectedBoundary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairOnlyOneConnectedBoundary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairRiserDoesntIntersectBoundary Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairRiserDoesntIntersectBoundary Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairRiserDoesntIntersectBoundary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairTooManyConnectedBoundaries Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairTooManyConnectedBoundaries Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundaries { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairTooManyConnectedBoundaries As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


StairTooManyConnectedBoundariesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.StairTooManyConnectedBoundariesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundariesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairTooManyConnectedBoundariesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SuggestMakingFamilyNonParametric Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SuggestMakingFamilyNonParametric Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SuggestMakingFamilyNonParametric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SuggestMakingFamilyNonParametric As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SuggestMakingFamilyNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


SuspendedSketchWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.SuspendedSketchWarn Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SuspendedSketchWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SuspendedSketchWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SuspendedSketchWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TooFewParamsForSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TooFewParamsForSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooFewParamsForSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooFewParamsForSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooFewParamsForSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TooManyElementsInSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TooManyElementsInSketch Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
This sketch is large. Performance will improve if constructed as several independent sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyElementsInSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TooManySlopes Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TooManySlopes Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManySlopes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManySlopes As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManySlopes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TooManySlopesError Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TooManySlopesError Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooManySlopesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooManySlopesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooManySlopesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussClosedReference Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussClosedReference Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) should not form closed loops."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussClosedReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussClosedReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussClosedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussCrossingReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussCrossingReferences Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss top and bottom references cannot cross.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussCrossingReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussCrossingReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussCrossingReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussMissingReference Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussMissingReference Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Trusses require both a top and a bottom chord reference (chain of one or more reference lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussMissingReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussMissingReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussMissingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussOverlappingReference Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussOverlappingReference Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussOverlappingReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussOverlappingReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussOverlappingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussSegmentedReference Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussSegmentedReference Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss reference must form a continuous chain of one or more sketch lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussSegmentedReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussSegmentedReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussSegmentedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussShiftedReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussShiftedReferences Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussShiftedReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussShiftedReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussShiftedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


TrussSwappedReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.TrussSwappedReferences Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Truss top reference must be above the bottom reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussSwappedReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussSwappedReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussSwappedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


UnsatisfiedSupportAssocProp Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.UnsatisfiedSupportAssocProp Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Support and the Support is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnsatisfiedSupportAssocProp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnsatisfiedSupportAssocProp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedSupportAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


UnsatisfiedWallAssocProp Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.UnsatisfiedWallAssocProp Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Wall and the Wall is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnsatisfiedWallAssocProp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnsatisfiedWallAssocProp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedWallAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


VarSketchFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.VarSketchFailure Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Constraints defined by highlighted Lines and Dimensions can't be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VarSketchFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VarSketchFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VarSketchFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


VarSketchInElementFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.VarSketchInElementFailure Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
The constraints of the sketch defining the highlighted element cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VarSketchInElementFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VarSketchInElementFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VarSketchInElementFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


WrongCutBoundaryLoops Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.WrongCutBoundaryLoops Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongCutBoundaryLoops { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongCutBoundaryLoops As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongCutBoundaryLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


WrongFaceSplitterLoopTypesNum Property

[image]

Revit 2011 API
BuiltInFailures..::.SketchFailures..::.WrongFaceSplitterLoopTypesNum Property
BuiltInFailures..::.SketchFailures Class See Also Send Feedback
Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFaceSplitterLoopTypesNum { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WrongFaceSplitterLoopTypesNum As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WrongFaceSplitterLoopTypesNum {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SketchFailures Class


BuiltInFailures.SkylightFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SkylightFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Skylight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SkylightFailures
Visual Basic (Declaration)
Public NotInheritable Class SkylightFailures
Visual C++
public ref class SkylightFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SkylightFailures

See Also

BuiltInFailures..::.SkylightFailures Members


BuiltInFailures.SkylightFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SkylightFailures Members
BuiltInFailures..::.SkylightFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::.SkylightFailures Class


BuiltInFailures.SkylightFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SkylightFailures Properties
BuiltInFailures..::.SkylightFailures Class See Also Send Feedback

The BuiltInFailures..::.SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::.SkylightFailures Class


MinSkylightWidthImperial Property

[image]

Revit 2011 API
BuiltInFailures..::.SkylightFailures..::.MinSkylightWidthImperial Property
BuiltInFailures..::.SkylightFailures Class See Also Send Feedback
The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SkylightFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2011 API
BuiltInFailures..::.SkylightFailures..::.MinSkylightWidthMetric Property
BuiltInFailures..::.SkylightFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SkylightFailures Class


BuiltInFailures.SlabFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SlabFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SlabFailures
Visual Basic (Declaration)
Public NotInheritable Class SlabFailures
Visual C++
public ref class SlabFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SlabFailures

See Also

BuiltInFailures..::.SlabFailures Members


BuiltInFailures.SlabFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlabFailures Members
BuiltInFailures..::.SlabFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::.SlabFailures Class


BuiltInFailures.SlabFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlabFailures Properties
BuiltInFailures..::.SlabFailures Class See Also Send Feedback

The BuiltInFailures..::.SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::.SlabFailures Class


CantileverValueTooBig Property

[image]

Revit 2011 API
BuiltInFailures..::.SlabFailures..::.CantileverValueTooBig Property
BuiltInFailures..::.SlabFailures Class See Also Send Feedback
Cantilever value is too big.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CantileverValueTooBig { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CantileverValueTooBig As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CantileverValueTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlabFailures Class


BuiltInFailures.SlantedColumnFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlantedColumn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SlantedColumnFailures
Visual Basic (Declaration)
Public NotInheritable Class SlantedColumnFailures
Visual C++
public ref class SlantedColumnFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SlantedColumnFailures

See Also

BuiltInFailures..::.SlantedColumnFailures Members


BuiltInFailures.SlantedColumnFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures Members
BuiltInFailures..::.SlantedColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::.SlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures Properties
BuiltInFailures..::.SlantedColumnFailures Class See Also Send Feedback

The BuiltInFailures..::.SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::.SlantedColumnFailures Class


CannotCutParallelToLocationCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures..::.CannotCutParallelToLocationCurve Property
BuiltInFailures..::.SlantedColumnFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutParallelToLocationCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCutParallelToLocationCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCutParallelToLocationCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlantedColumnFailures Class


SlantedColumnCannotCutEnd Property

[image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures..::.SlantedColumnCannotCutEnd Property
BuiltInFailures..::.SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEnd { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlantedColumnCannotCutEnd As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlantedColumnFailures Class


SlantedColumnCannotCutEndWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.SlantedColumnFailures..::.SlantedColumnCannotCutEndWarn Property
BuiltInFailures..::.SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEndWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlantedColumnCannotCutEndWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEndWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlantedColumnFailures Class


BuiltInFailures.SlapShapeFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlapShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SlapShapeFailures
Visual Basic (Declaration)
Public NotInheritable Class SlapShapeFailures
Visual C++
public ref class SlapShapeFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SlapShapeFailures

See Also

BuiltInFailures..::.SlapShapeFailures Members


BuiltInFailures.SlapShapeFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures Members
BuiltInFailures..::.SlapShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SlapShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Roof or Floor is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Roof or Floor may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof is too thin for its given type.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::.SlapShapeFailures Class


BuiltInFailures.SlapShapeFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures Properties
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback

The BuiltInFailures..::.SlapShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Roof or Floor is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Roof or Floor may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof is too thin for its given type.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeEditFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeEditFailed Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeEditFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeEditFailedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeEditFailedError Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeEditFailedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeFailedNotHorz Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeFailedNotHorz Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
The Roof or Floor is no longer horizontal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotHorz { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeFailedNotHorz As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotHorz {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeFailedNotOnlyLines Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeFailedNotOnlyLines Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
The Roof or Floor may only contain straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotOnlyLines { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeFailedNotOnlyLines As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotOnlyLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeFailedTooThin Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeFailedTooThin Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
The Floor or Roof is too thin for its given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedTooThin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeFailedTooThin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlabShapeWarnVerticesDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlabShapeWarnVerticesDeleted Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeWarnVerticesDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlabShapeWarnVerticesDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlabShapeWarnVerticesDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlopedInnerEdge Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlopedInnerEdge Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
Inner loops of a footprint sketch may not have slope-defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlopedInnerEdge { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlopedInnerEdge As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlopedInnerEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlopeTailInsideSlopeLine Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlopeTailInsideSlopeLine Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
The tails of slope arrows must not lie in interior of slope defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlopeTailInsideSlopeLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlopeTailInsideSlopeLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlopeTailInsideSlopeLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


SlopeZero Property

[image]

Revit 2011 API
BuiltInFailures..::.SlapShapeFailures..::.SlopeZero Property
BuiltInFailures..::.SlapShapeFailures Class See Also Send Feedback
Adjusting this Line's Overhang will not affect its height because its slope is zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SlopeZero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SlopeZero As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SlopeZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SlapShapeFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SpanDirectionSymbolFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SpanDirectionSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SpanDirectionSymbolFailures
Visual Basic (Declaration)
Public NotInheritable Class SpanDirectionSymbolFailures
Visual C++
public ref class SpanDirectionSymbolFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SpanDirectionSymbolFailures

See Also

BuiltInFailures..::.SpanDirectionSymbolFailures Members


BuiltInFailures.SpanDirectionSymbolFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SpanDirectionSymbolFailures Members
BuiltInFailures..::.SpanDirectionSymbolFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SpanDirectionSymbolFailures type exposes the following members.

Properties

Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::.SpanDirectionSymbolFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SpanDirectionSymbolFailures Properties
BuiltInFailures..::.SpanDirectionSymbolFailures Class See Also Send Feedback

The BuiltInFailures..::.SpanDirectionSymbolFailures type exposes the following members.

Properties

Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::.SpanDirectionSymbolFailures Class


NonPlanView Property

[image]

Revit 2011 API
BuiltInFailures..::.SpanDirectionSymbolFailures..::.NonPlanView Property
BuiltInFailures..::.SpanDirectionSymbolFailures Class See Also Send Feedback
Span Direction Symbol can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NonPlanView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NonPlanView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NonPlanView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SpanDirectionSymbolFailures Class


BuiltInFailures.SplineFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SplineFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SplineFailures
Visual Basic (Declaration)
Public NotInheritable Class SplineFailures
Visual C++
public ref class SplineFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SplineFailures

See Also

BuiltInFailures..::.SplineFailures Members


BuiltInFailures.SplineFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SplineFailures Members
BuiltInFailures..::.SplineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::.SplineFailures Class


BuiltInFailures.SplineFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SplineFailures Properties
BuiltInFailures..::.SplineFailures Class See Also Send Feedback

The BuiltInFailures..::.SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::.SplineFailures Class


CannotCreateSpline Property

[image]

Revit 2011 API
BuiltInFailures..::.SplineFailures..::.CannotCreateSpline Property
BuiltInFailures..::.SplineFailures Class See Also Send Feedback
Can't make Spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSpline { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSpline As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SplineFailures Class


ClosedSpline Property

[image]

Revit 2011 API
BuiltInFailures..::.SplineFailures..::.ClosedSpline Property
BuiltInFailures..::.SplineFailures Class See Also Send Feedback
Closed or self-intersecting splines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedSpline { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ClosedSpline As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ClosedSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SplineFailures Class


BuiltInFailures.StairRampFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about StairRamp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class StairRampFailures
Visual Basic (Declaration)
Public NotInheritable Class StairRampFailures
Visual C++
public ref class StairRampFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.StairRampFailures

See Also

BuiltInFailures..::.StairRampFailures Members


BuiltInFailures.StairRampFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures Members
BuiltInFailures..::.StairRampFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
OnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserDoesntIntersectBoundry | The line representing the top of a riser does not intersect one or both of the boundary lines.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
StairsIllegalDesNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

See Also

BuiltInFailures..::.StairRampFailures Class


BuiltInFailures.StairRampFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures Properties
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback

The BuiltInFailures..::.StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
OnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserDoesntIntersectBoundry | The line representing the top of a riser does not intersect one or both of the boundary lines.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
StairsIllegalDesNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

See Also

BuiltInFailures..::.StairRampFailures Class


ActualRiserHeightChanged Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.ActualRiserHeightChanged Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The actual riser height for one or more stairs violates the maximum set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ActualRiserHeightChanged { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ActualRiserHeightChanged As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ActualRiserHeightChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


AntiparallelRampRisers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.AntiparallelRampRisers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AntiparallelRampRisers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


AntiparallelRampRisersError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.AntiparallelRampRisersError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisersError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AntiparallelRampRisersError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


ArcRunRadiusTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.ArcRunRadiusTooSmall Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Run. Run radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ArcRunRadiusTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ArcRunRadiusTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ArcRunRadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BadBalustersPerTread Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BadBalustersPerTread Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Number of Balusters per Tread must be an integer greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadBalustersPerTread { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadBalustersPerTread As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadBalustersPerTread {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BadFillingSpacing Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BadFillingSpacing Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Spacing for Excess Length Fill is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadFillingSpacing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadFillingSpacing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadFillingSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BadRailings Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BadRailings Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailings { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadRailings As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadRailings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BadRailingsError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BadRailingsError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailingsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadRailingsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadRailingsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BadRailProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BadRailProfile Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
One or more Profile Loops are invalid, probably because of self-intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadRailProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BalustersTooClose Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BalustersTooClose Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Baluster Separation must be equal to or greater than the Baluster widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BalustersTooClose { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BalustersTooClose As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BalustersTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BalustersTooCloseAbsolute Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BalustersTooCloseAbsolute Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Baluster Separation is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BalustersTooCloseAbsolute { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BalustersTooCloseAbsolute As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BalustersTooCloseAbsolute {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BalusterUpsideDown Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.BalusterUpsideDown Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BalusterUpsideDown { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BalusterUpsideDown As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BalusterUpsideDown {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotComputeRailElevation Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotComputeRailElevation Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't compute elevation profile for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailElevation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotComputeRailElevation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateBaluster Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateBaluster Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Balusters for given Width and Height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateBaluster { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateBaluster As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBaluster {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateBalusterPatterns Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateBalusterPatterns Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Baluster Patterns for Railings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateBalusterPatterns { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateBalusterPatterns As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateCornerBalusters Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateCornerBalusters Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create corner Baluster

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerBalusters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateCornerBalusters As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerBalusters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateLandingStringer Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateLandingStringer Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create stringer at landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateLandingStringer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateLandingStringer As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateLandingStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateMiddleStringer Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateMiddleStringer Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create one or more Middle Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMiddleStringer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMiddleStringer As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMiddleStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateMonolithicStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateMonolithicStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't make monolithic Stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMonolithicStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateMonolithicStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateNosing Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateNosing Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create nosing on one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateNosing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateNosing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateOneOrMoreBaluster Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateOneOrMoreBaluster Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create one or more Balusters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOneOrMoreBaluster { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOneOrMoreBaluster As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreBaluster {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateOneOrMoreTreads Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateOneOrMoreTreads Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOneOrMoreTreads { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOneOrMoreTreads As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreTreads {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateOpenMiddleStringers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateOpenMiddleStringers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't cut open/middle stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpenMiddleStringers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateOpenMiddleStringers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpenMiddleStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateRail Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateRail Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRail { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRail As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateRailGeom Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateRailGeom Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRailGeom { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRailGeom As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateRailWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateRailWarn Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRailWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRailWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateRiser Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateRiser Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRiser { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateRiser As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateSideStringer Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateSideStringer Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create one or more Side Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSideStringer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateSideStringer As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSideStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotCreateStringers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotCreateStringers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateStringers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateStringers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotDrawStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotDrawStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotDrawStairsError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotDrawStairsError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawStairsError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawStairsError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawStairsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotEndWithZeroRiser Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotEndWithZeroRiser Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't end Stairs with Riser because Riser Thickness is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEndWithZeroRiser { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotEndWithZeroRiser As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotEndWithZeroRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotGenerateFaces Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotGenerateFaces Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateFaces { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGenerateFaces As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotGenerateFacesError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotGenerateFacesError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateFacesError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGenerateFacesError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateFacesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotGenerateRamp Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotGenerateRamp Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateRamp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGenerateRamp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotGenerateRampError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotGenerateRampError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateRampError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotGenerateRampError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotOffsetBoundary Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotOffsetBoundary Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create Boundary as an offset of Run Curve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotOffsetBoundary { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotOffsetBoundary As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotOffsetBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotOffsetRail Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotOffsetRail Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't create one or more Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotOffsetRail { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotOffsetRail As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotOffsetRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotPlaceBalusterOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotPlaceBalusterOffset Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't place Balusters and/or Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceBalusterOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


CannotPlaceBalusterPatterns Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.CannotPlaceBalusterPatterns Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Can't place Baluster Patterns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterPatterns { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPlaceBalusterPatterns As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


InvalidBalustersPattern Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.InvalidBalustersPattern Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Invalid Balusters Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidBalustersPattern { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidBalustersPattern As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidBalustersPattern {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


InvalidRailProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.InvalidRailProfile Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRailProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidRailProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


InvalidStartLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.InvalidStartLevel Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The start level and end level for this staircase must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidStartLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidStartLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


InvalidStartLevelRamp Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.InvalidStartLevelRamp Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The start level and end level for this ramp must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidStartLevelRamp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidStartLevelRamp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevelRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


MultistoryLevelBelowTopbottomLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.MultistoryLevelBelowTopbottomLevel Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


MultistoryStairDoesntReach Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.MultistoryStairDoesntReach Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultistoryStairDoesntReach { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultistoryStairDoesntReach As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultistoryStairDoesntReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


MultusegmentRampRiser Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.MultusegmentRampRiser Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiser { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultusegmentRampRiser As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


MultusegmentRampRiserError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.MultusegmentRampRiserError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiserError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultusegmentRampRiserError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiserError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoCurvesInRailing Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoCurvesInRailing Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Railing Sketch has no Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoCurvesInRailing { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoCurvesInRailing As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoCurvesInRailing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoProfileForRail Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoProfileForRail Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Must specify Profiles for every Rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoProfileForRail { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoProfileForRail As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoProfileForRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoRailingsStringer Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoRailingsStringer Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRailingsStringer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRailingsStringer As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRailingsStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoRisersInPureMonolithicStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoRisersInPureMonolithicStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Monolithic Stairs with zero tread thickness can't have risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRisersInPureMonolithicStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRisersInPureMonolithicStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRisersInPureMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoRunsRamp Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoRunsRamp Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRunsRamp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRunsRamp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRunsRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NoRunsRampError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NoRunsRampError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoRunsRampError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoRunsRampError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoRunsRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NotALineRiserRamp Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NotALineRiserRamp Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotALineRiserRamp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotALineRiserRamp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NotALineRiserRampError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NotALineRiserRampError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotALineRiserRampError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotALineRiserRampError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


NotEnoughRisers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.NotEnoughRisers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRisers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotEnoughRisers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


OnlyMonolithicStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.OnlyMonolithicStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Tread thickness can't be zero for non-monolithic stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyMonolithicStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyMonolithicStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


OnlyOneConnectedBoundaryError Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.OnlyOneConnectedBoundaryError Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Stairs require no less than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyOneConnectedBoundaryError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OnlyOneConnectedBoundaryError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ OnlyOneConnectedBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailCurveTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailCurveTooShort Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Curve in rail sketch is too short for rail creation and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailCurveTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailCurveTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailingBadOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingBadOffset Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingBadOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingBadOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingBadOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailingCurvesNotSplitRamp Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingCurvesNotSplitRamp Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitRamp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingCurvesNotSplitRamp As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailingCurvesNotSplitStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingCurvesNotSplitStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingCurvesNotSplitStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailingDoublyConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingDoublyConnected Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailingNotConnected Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailingNotConnected Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RailProfileOpen Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RailProfileOpen Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Open Profile Loop can't be used as a Rail Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RailProfileOpen { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RailProfileOpen As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RailProfileOpen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RampDoesntReach Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampDoesntReach Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampDoesntReach { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampDoesntReach As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RampDoesntReachOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampDoesntReachOffset Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampDoesntReachOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampDoesntReachOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReachOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RampLandingNotCreated Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampLandingNotCreated Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Beginning of run coincide with the end of previous run. Landing is not created between runs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampLandingNotCreated { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampLandingNotCreated As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampLandingNotCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RampRunTooComplex Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampRunTooComplex Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampRunTooComplex { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampRunTooComplex As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampRunTooComplex {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RampStartHigherThanEnd Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RampStartHigherThanEnd Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The ramp's base (base level + base offset) must be below its top (top level + top offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RampStartHigherThanEnd { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RampStartHigherThanEnd As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RampStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RiserCurveTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RiserCurveTooShort Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Riser curve is too short to create nosing on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RiserCurveTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RiserCurveTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RiserCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RiserDoesntIntersectBoundry Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RiserDoesntIntersectBoundry Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RiserDoesntIntersectBoundry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RiserDoesntIntersectBoundry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RiserDoesntIntersectBoundry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RisersAtSameLocation Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RisersAtSameLocation Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The highlighted risers have the same location along the boundary line. Please move one of the two risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RisersAtSameLocation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RisersAtSameLocation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RisersAtSameLocation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


RiserThicknesssResetToZero Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.RiserThicknesssResetToZero Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RiserThicknesssResetToZero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RiserThicknesssResetToZero As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RiserThicknesssResetToZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StairsIllegalDesNumRisers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StairsIllegalDesNumRisers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairsIllegalDesNumRisers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairsIllegalDesNumRisers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairsIllegalDesNumRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StairsStartHigherThanEnd Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StairsStartHigherThanEnd Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairsStartHigherThanEnd { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairsStartHigherThanEnd As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairsStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StairStringerCantOffset Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StairStringerCantOffset Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairStringerCantOffset { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairStringerCantOffset As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairStringerCantOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StairsZeroDesiredRisers Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StairsZeroDesiredRisers Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The number of desired risers for a staircase cannot be 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StairsZeroDesiredRisers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StairsZeroDesiredRisers As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StairsZeroDesiredRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StringerCurvesNotSplitStairs Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StringerCurvesNotSplitStairs Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StringerCurvesNotSplitStairs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StringerCurvesNotSplitStairs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StringerCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


StringerCurveTooShort Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.StringerCurveTooShort Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
A piece of boundary is too short to create stringer on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StringerCurveTooShort { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StringerCurveTooShort As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StringerCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


TreadDepthBelowMin Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.TreadDepthBelowMin Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TreadDepthBelowMin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TreadDepthBelowMin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TreadDepthBelowMin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


TreadDepthFailsEq Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.TreadDepthFailsEq Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
The actual tread depth and riser height for one or more stairs of this type violates the stair equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TreadDepthFailsEq { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TreadDepthFailsEq As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TreadDepthFailsEq {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


TreadFrontProfileInvalid Property

[image]

Revit 2011 API
BuiltInFailures..::.StairRampFailures..::.TreadFrontProfileInvalid Property
BuiltInFailures..::.StairRampFailures Class See Also Send Feedback
This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TreadFrontProfileInvalid { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TreadFrontProfileInvalid As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TreadFrontProfileInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.StairRampFailures Class


BuiltInFailures.SweepFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SweepFailures
Visual Basic (Declaration)
Public NotInheritable Class SweepFailures
Visual C++
public ref class SweepFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SweepFailures

See Also

BuiltInFailures..::.SweepFailures Members


BuiltInFailures.SweepFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SweepFailures Members
BuiltInFailures..::.SweepFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.

See Also

BuiltInFailures..::.SweepFailures Class


BuiltInFailures.SweepFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SweepFailures Properties
BuiltInFailures..::.SweepFailures Class See Also Send Feedback

The BuiltInFailures..::.SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.

See Also

BuiltInFailures..::.SweepFailures Class


CannotDrawSweep Property

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures..::.CannotDrawSweep Property
BuiltInFailures..::.SweepFailures Class See Also Send Feedback
Can't create sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawSweep { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawSweep As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSweep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweepFailures Class


ComplexPathWithComplexProfile Property

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures..::.ComplexPathWithComplexProfile Property
BuiltInFailures..::.SweepFailures Class See Also Send Feedback
Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ComplexPathWithComplexProfile { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ComplexPathWithComplexProfile As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ComplexPathWithComplexProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweepFailures Class


ProfileLoopEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures..::.ProfileLoopEmpty Property
BuiltInFailures..::.SweepFailures Class See Also Send Feedback
Profile sketch is empty!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileLoopEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ProfileLoopEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ProfileLoopEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweepFailures Class


SweepFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures..::.SweepFailed Property
BuiltInFailures..::.SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SweepFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SweepFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SweepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweepFailures Class


SweepFailedError Property

[image]

Revit 2011 API
BuiltInFailures..::.SweepFailures..::.SweepFailedError Property
BuiltInFailures..::.SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SweepFailedError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SweepFailedError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SweepFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweepFailures Class


BuiltInFailures.SweptBlendFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SweptBlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SweptBlend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SweptBlendFailures
Visual Basic (Declaration)
Public NotInheritable Class SweptBlendFailures
Visual C++
public ref class SweptBlendFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SweptBlendFailures

See Also

BuiltInFailures..::.SweptBlendFailures Members


BuiltInFailures.SweptBlendFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SweptBlendFailures Members
BuiltInFailures..::.SweptBlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::.SweptBlendFailures Class


BuiltInFailures.SweptBlendFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SweptBlendFailures Properties
BuiltInFailures..::.SweptBlendFailures Class See Also Send Feedback

The BuiltInFailures..::.SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::.SweptBlendFailures Class


CannotDrawSweptblend Property

[image]

Revit 2011 API
BuiltInFailures..::.SweptBlendFailures..::.CannotDrawSweptblend Property
BuiltInFailures..::.SweptBlendFailures Class See Also Send Feedback
Can't create swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawSweptblend { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotDrawSweptblend As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSweptblend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SweptBlendFailures Class


BuiltInFailures.SystemsFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class SystemsFailures
Visual Basic (Declaration)
Public NotInheritable Class SystemsFailures
Visual C++
public ref class SystemsFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.SystemsFailures

See Also

BuiltInFailures..::.SystemsFailures Members


BuiltInFailures.SystemsFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures Members
BuiltInFailures..::.SystemsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected can not be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::.SystemsFailures Class


BuiltInFailures.SystemsFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures Properties
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback

The BuiltInFailures..::.SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected can not be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::.SystemsFailures Class


AddingOtherConnectedMembersToSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.AddingOtherConnectedMembersToSystem Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
"You have selected elements that are connected to other elements. These elements will also be added to the System."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId AddingOtherConnectedMembersToSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AddingOtherConnectedMembersToSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


DefaultSystemOver50Elems Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.DefaultSystemOver50Elems Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DefaultSystemOver50Elems { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultSystemOver50Elems As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DefaultSystemOver50Elems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


ElementsBelongToOtherSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.ElementsBelongToOtherSystem Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected can not be added to this System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsBelongToOtherSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementsBelongToOtherSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementsBelongToOtherSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


FamilyDoesntMatchSystemProperties Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.FamilyDoesntMatchSystemProperties Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemProperties { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyDoesntMatchSystemProperties As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


FamilyDoesntMatchSystemPropertiesWasDisconnected Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.FamilyDoesntMatchSystemPropertiesWasDisconnected Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesWasDisconnected { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesWasDisconnected As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesWasDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


MismatchSystemType Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.MismatchSystemType Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchSystemType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MismatchSystemType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MismatchSystemType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


SelectedElementsArePartOfOtherSystem Property

[image]

Revit 2011 API
BuiltInFailures..::.SystemsFailures..::.SelectedElementsArePartOfOtherSystem Property
BuiltInFailures..::.SystemsFailures Class See Also Send Feedback
You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherSystem { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SelectedElementsArePartOfOtherSystem As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.SystemsFailures Class


BuiltInFailures.TagFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class TagFailures
Visual Basic (Declaration)
Public NotInheritable Class TagFailures
Visual C++
public ref class TagFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.TagFailures

See Also

BuiltInFailures..::.TagFailures Members


BuiltInFailures.TagFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.TagFailures Members
BuiltInFailures..::.TagFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
TagsCannotBePlacedIn3dViews | Tags can't be pasted into 3D views.

See Also

BuiltInFailures..::.TagFailures Class


BuiltInFailures.TagFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.TagFailures Properties
BuiltInFailures..::.TagFailures Class See Also Send Feedback

The BuiltInFailures..::.TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
TagsCannotBePlacedIn3dViews | Tags can't be pasted into 3D views.

See Also

BuiltInFailures..::.TagFailures Class


CannotCopyTag Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.CannotCopyTag Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyTag { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyTag As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


CannotCopyTagWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.CannotCopyTagWarn Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyTagWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCopyTagWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTagWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


CannotPasteOrphanTags Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.CannotPasteOrphanTags Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTags { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteOrphanTags As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTags {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


CannotPasteOrphanTagsWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.CannotPasteOrphanTagsWarn Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTagsWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteOrphanTagsWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTagsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


CannotPasteTag Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.CannotPasteTag Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
Can't find new element to tag. Tag won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteTag { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteTag As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


ElementCategoryChangeInvalidatesTag Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.ElementCategoryChangeInvalidatesTag Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesTag { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTag As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


ElementCategoryChangeInvalidatesTagUpgrade Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.ElementCategoryChangeInvalidatesTagUpgrade Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesTagUpgrade { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTagUpgrade As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTagUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


MultiCategoryTagFilterParamNotFoundInElement Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.MultiCategoryTagFilterParamNotFoundInElement Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
The filter specified by Multi-Category Tag can't be used with the tagged object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MultiCategoryTagFilterParamNotFoundInElement { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MultiCategoryTagFilterParamNotFoundInElement As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MultiCategoryTagFilterParamNotFoundInElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


TagsCannotBePlacedIn3dViews Property

[image]

Revit 2011 API
BuiltInFailures..::.TagFailures..::.TagsCannotBePlacedIn3dViews Property
BuiltInFailures..::.TagFailures Class See Also Send Feedback
Tags can't be pasted into 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TagsCannotBePlacedIn3dViews { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TagsCannotBePlacedIn3dViews As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TagsCannotBePlacedIn3dViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TagFailures Class


BuiltInFailures.TextFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.TextFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class TextFailures
Visual Basic (Declaration)
Public NotInheritable Class TextFailures
Visual C++
public ref class TextFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.TextFailures

See Also

BuiltInFailures..::.TextFailures Members


BuiltInFailures.TextFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.TextFailures Members
BuiltInFailures..::.TextFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.TextFailures type exposes the following members.

Properties

Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.

See Also

BuiltInFailures..::.TextFailures Class


BuiltInFailures.TextFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.TextFailures Properties
BuiltInFailures..::.TextFailures Class See Also Send Feedback

The BuiltInFailures..::.TextFailures type exposes the following members.

Properties

Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.

See Also

BuiltInFailures..::.TextFailures Class


CannotCreateModeltext Property

[image]

Revit 2011 API
BuiltInFailures..::.TextFailures..::.CannotCreateModeltext Property
BuiltInFailures..::.TextFailures Class See Also Send Feedback
Can't create Model Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateModeltext { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotCreateModeltext As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotCreateModeltext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TextFailures Class


ModeltextIsEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.TextFailures..::.ModeltextIsEmpty Property
BuiltInFailures..::.TextFailures Class See Also Send Feedback
Model Text deleted because it consists entirely of spaces and/or carriage returns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ModeltextIsEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ModeltextIsEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ModeltextIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TextFailures Class


BuiltInFailures.TrussFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class TrussFailures
Visual Basic (Declaration)
Public NotInheritable Class TrussFailures
Visual C++
public ref class TrussFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.TrussFailures

See Also

BuiltInFailures..::.TrussFailures Members


BuiltInFailures.TrussFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.TrussFailures Members
BuiltInFailures..::.TrussFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit can not transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit can not attach to the chosen Roof/Slab. The truss can not project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::.TrussFailures Class


BuiltInFailures.TrussFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.TrussFailures Properties
BuiltInFailures..::.TrussFailures Class See Also Send Feedback

The BuiltInFailures..::.TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit can not transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit can not attach to the chosen Roof/Slab. The truss can not project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::.TrussFailures Class


IncorrectWallUsageWithAttachedStruct Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.IncorrectWallUsageWithAttachedStruct Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
A structural framing element is attached to a wall whose Structural Usage is set to [Usage].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId IncorrectWallUsageWithAttachedStruct { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IncorrectWallUsageWithAttachedStruct As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ IncorrectWallUsageWithAttachedStruct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


InvalidWorkplaneForStructuralFraming Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.InvalidWorkplaneForStructuralFraming Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Workplane not valid for Structural Framing component "[Family Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidWorkplaneForStructuralFraming { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidWorkplaneForStructuralFraming As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidWorkplaneForStructuralFraming {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


RemoveTrussSketch Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.RemoveTrussSketch Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Remove Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveTrussSketch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemoveTrussSketch As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemoveTrussSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussBadTransformation Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussBadTransformation Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Revit can not transform the truss Layout Family to the Truss as oriented in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussBadTransformation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussBadTransformation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussBadTransformation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussChordUntransformable Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussChordUntransformable Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussChordUntransformable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussChordUntransformable As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussChordUntransformable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussDuplicateEngineeringType Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussDuplicateEngineeringType Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Elements have duplicate 'Engineering Type' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussDuplicateEngineeringType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussDuplicateEngineeringType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussDuplicateEngineeringType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussInvalidSymbolGeom Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussInvalidSymbolGeom Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Truss is unable to generate any members due to layout family error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussInvalidSymbolGeom { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussInvalidSymbolGeom As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussInvalidSymbolGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussIsAttachedTo Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussIsAttachedTo Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Revit can not attach to the chosen Roof/Slab. The truss can not project to a surface or the attachment creates an invalid profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussIsAttachedTo { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussIsAttachedTo As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussIsAttachedTo {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussLayoutNonSympleTopChord Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussLayoutNonSympleTopChord Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussLayoutNonSympleTopChord { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussLayoutNonSympleTopChord As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussLayoutNonSympleTopChord {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussLayoutOverlapedCurves Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussLayoutOverlapedCurves Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
The current transformation of this specific truss layout will some sub members to overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussLayoutOverlapedCurves { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussLayoutOverlapedCurves As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussLayoutOverlapedCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussNotJoinedWebs Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussNotJoinedWebs Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussNotJoinedWebs { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussNotJoinedWebs As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussNotJoinedWebs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussUserDefinedMemberDeleted Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussUserDefinedMemberDeleted Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
A user-defined structural member was deleted due to missing or deleted references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberDeleted { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussUserDefinedMemberDeleted As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


TrussUserDefinedMemberNotJoined Property

[image]

Revit 2011 API
BuiltInFailures..::.TrussFailures..::.TrussUserDefinedMemberNotJoined Property
BuiltInFailures..::.TrussFailures Class See Also Send Feedback
Both start and end of web must intersect the truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberNotJoined { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TrussUserDefinedMemberNotJoined As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberNotJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.TrussFailures Class


BuiltInFailures.ViewFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ViewFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class ViewFailures
Visual Basic (Declaration)
Public NotInheritable Class ViewFailures
Visual C++
public ref class ViewFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.ViewFailures

See Also

BuiltInFailures..::.ViewFailures Members


BuiltInFailures.ViewFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.ViewFailures Members
BuiltInFailures..::.ViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | Can't construct View Clipping and Cropping from Scope Box.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central File. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::.ViewFailures Class


BuiltInFailures.ViewFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.ViewFailures Properties
BuiltInFailures..::.ViewFailures Class See Also Send Feedback

The BuiltInFailures..::.ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | Can't construct View Clipping and Cropping from Scope Box.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central File. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::.ViewFailures Class


BadViewDirectionSetting Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.BadViewDirectionSetting Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Plan view DBViewType has invalid view direction parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewDirectionSetting { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BadViewDirectionSetting As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ BadViewDirectionSetting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


CanNotDeleteLastOpenView Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.CanNotDeleteLastOpenView Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Deleting of all open views in a project is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CanNotDeleteLastOpenView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CanNotDeleteLastOpenView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CanNotDeleteLastOpenView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


CannotPasteViewReferences Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.CannotPasteViewReferences Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Cannot paste view references into the view they reference or into unrelated views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteViewReferences { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotPasteViewReferences As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotPasteViewReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


DetailNumberDuplicate Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.DetailNumberDuplicate Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Detail Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DetailNumberDuplicate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DetailNumberDuplicate As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DetailNumberDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


DetailNumberEmpty Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.DetailNumberEmpty Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Detail Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DetailNumberEmpty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DetailNumberEmpty As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DetailNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


InsertColumnViewError Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.InsertColumnViewError Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertColumnViewError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertColumnViewError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertColumnViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


InsertColumnViewFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.InsertColumnViewFailure Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertColumnViewFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertColumnViewFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertColumnViewFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


InsertComponentViewError Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.InsertComponentViewError Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertComponentViewError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertComponentViewError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertComponentViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


InsertComponentViewFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.InsertComponentViewFailure Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InsertComponentViewFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InsertComponentViewFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InsertComponentViewFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


InvalidDBviewScopeBox Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.InvalidDBviewScopeBox Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Can't construct View Clipping and Cropping from Scope Box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidDBviewScopeBox { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidDBviewScopeBox As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidDBviewScopeBox {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


NewElementInvisibleInCurrentView Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.NewElementInvisibleInCurrentView Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
The newly created object is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NewElementInvisibleInCurrentView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NewElementInvisibleInCurrentView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NewElementInvisibleInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


NoTargetsForDependentViewPropagation Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.NoTargetsForDependentViewPropagation Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
There are no valid views. Only views without dependents can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoTargetsForDependentViewPropagation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoTargetsForDependentViewPropagation As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoTargetsForDependentViewPropagation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


NothingToApplyError Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.NothingToApplyError Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NothingToApplyError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NothingToApplyError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


NothingToApplyWarning Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.NothingToApplyWarning Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NothingToApplyWarning { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NothingToApplyWarning As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


ReloadLatestDeletedLastOpenView Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.ReloadLatestDeletedLastOpenView Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
The only open view has been deleted because of changes from the Central File. Open another view and Reload Latest or Synchronize with Central again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadLatestDeletedLastOpenView { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReloadLatestDeletedLastOpenView As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ReloadLatestDeletedLastOpenView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


TurnCropRegionOffRemovesViewBreaks Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.TurnCropRegionOffRemovesViewBreaks Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TurnCropRegionOffRemovesViewBreaks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TurnCropRegionOffRemovesViewBreaks As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TurnCropRegionOffRemovesViewBreaks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


ViewPublishFailed Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.ViewPublishFailed Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
The following views could not be published.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ViewPublishFailed { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ViewPublishFailed As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ViewPublishFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


ZeroLengthViewBreaksRemoved Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.ZeroLengthViewBreaksRemoved Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthViewBreaksRemoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroLengthViewBreaksRemoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthViewBreaksRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


ZeroLengthViewRegionsRemoved Property

[image]

Revit 2011 API
BuiltInFailures..::.ViewFailures..::.ZeroLengthViewRegionsRemoved Property
BuiltInFailures..::.ViewFailures Class See Also Send Feedback
Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthViewRegionsRemoved { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ZeroLengthViewRegionsRemoved As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthViewRegionsRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.ViewFailures Class


BuiltInFailures.WallFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class WallFailures
Visual Basic (Declaration)
Public NotInheritable Class WallFailures
Visual C++
public ref class WallFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.WallFailures

See Also

BuiltInFailures..::.WallFailures Members


BuiltInFailures.WallFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.WallFailures Members
BuiltInFailures..::.WallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than it's type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to it's type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press"Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

See Also

BuiltInFailures..::.WallFailures Class


BuiltInFailures.WallFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.WallFailures Properties
BuiltInFailures..::.WallFailures Class See Also Send Feedback

The BuiltInFailures..::.WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than it's type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to it's type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press"Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

See Also

BuiltInFailures..::.WallFailures Class


CannotChangeSubwall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotChangeSubwall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Changing the type of a subwall is not allowed. Edit the stacked wall type instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeSubwall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeSubwall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeSubwall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotChangeTypeOfOldCurtainPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotChangeTypeOfOldCurtainPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeTypeOfOldCurtainPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotChangeTypeOfOldCurtainPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotChangeTypeOfOldCurtainPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotMaintainKeyReference Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotMaintainKeyReference Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't maintain the position of the Location Line in this Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMaintainKeyReference { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMaintainKeyReference As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMaintainKeyReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotMirrorWallPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotMirrorWallPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Cannot mirror wall panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorWallPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotMirrorWallPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotRedoFaceBased Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotRedoFaceBased Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceBased { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRedoFaceBased As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceBased {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotRedoFaceBasedWarn Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotRedoFaceBasedWarn Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceBasedWarn { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRedoFaceBasedWarn As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceBasedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotRedoFaceRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotRedoFaceRoof Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
"Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotRedoFaceRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotSplitJoinHostsInplaceFamilies Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotSplitJoinHostsInplaceFamilies Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitJoinHostsInplaceFamilies { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSplitJoinHostsInplaceFamilies As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSplitJoinHostsInplaceFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotSplitVerticallyCompoundWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotSplitVerticallyCompoundWall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't divide Wall's face to assign different materials to a vertically compound Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitVerticallyCompoundWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotSplitVerticallyCompoundWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotSplitVerticallyCompoundWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotToSplitWallPanels Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotToSplitWallPanels Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Unable to split wall panel(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotToSplitWallPanels { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotToSplitWallPanels As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotToSplitWallPanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


CannotUpdateWallPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.CannotUpdateWallPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Unable to update wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUpdateWallPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CannotUpdateWallPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ CannotUpdateWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ChangingWallsweepType Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ChangingWallsweepType Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
This wall sweep instance has different profile or material than it's type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to it's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ChangingWallsweepType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ChangingWallsweepType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ChangingWallsweepType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ConstrainedToWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ConstrainedToWall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConstrainedToWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConstrainedToWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ConstrainedToWallError Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ConstrainedToWallError Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ConstrainedToWallError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConstrainedToWallError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ContFootingCannotJoin Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ContFootingCannotJoin Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContFootingCannotJoin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContFootingCannotJoin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContFootingCannotJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ContFootingRadiusTooSmall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ContFootingRadiusTooSmall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ContFootingRadiusTooSmall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ContFootingRadiusTooSmall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ContFootingRadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


EmbeddedButShouldNotBe Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.EmbeddedButShouldNotBe Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Conditions for wall embedding are no longer satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId EmbeddedButShouldNotBe { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmbeddedButShouldNotBe As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ EmbeddedButShouldNotBe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceBecameVertical Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceBecameVertical Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Face defining this non-vertical Wall is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceBecameVertical { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceBecameVertical As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceBecameVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceIsNoGoodForWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceIsNoGoodForWall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Defining face is not suitable for walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceIsNoGoodForWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceIsNoGoodForWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoGoodForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceIsNoLongerVertical Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceIsNoLongerVertical Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Face defining this vertical Wall is no longer vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceIsNoLongerVertical { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceIsNoLongerVertical As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoLongerVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceWallBadType Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceWallBadType Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallBadType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceWallBadType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceWallBadType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceWallComplexType Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceWallComplexType Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallComplexType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceWallComplexType As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceWallComplexType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceWallFailedToMake Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceWallFailedToMake Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't make Face Wall shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallFailedToMake { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceWallFailedToMake As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceWallFailedToMake {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FaceWallMissingFace Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FaceWallMissingFace Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
No picked face found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallMissingFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FaceWallMissingFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FaceWallMissingFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FailedConvertWallToPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FailedConvertWallToPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Unable to convert wall to panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedConvertWallToPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedConvertWallToPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedConvertWallToPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FailedToChangeInstSymbol Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FailedToChangeInstSymbol Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Failed to change symbol of instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToChangeInstSymbol { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToChangeInstSymbol As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeInstSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


FailedToStoreSideFace Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.FailedToStoreSideFace Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToStoreSideFace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FailedToStoreSideFace As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ FailedToStoreSideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


InvalidBaseConstraintForLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.InvalidBaseConstraintForLevel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Base Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidBaseConstraintForLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidBaseConstraintForLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidBaseConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


InvalidCompoundStructure Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.InvalidCompoundStructure Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Invalid compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCompoundStructure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidCompoundStructure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidCompoundStructure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


InvalidTargetPosition Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.InvalidTargetPosition Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTargetPosition { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidTargetPosition As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidTargetPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


InvalidTargetPositionError Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.InvalidTargetPositionError Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTargetPositionError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidTargetPositionError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidTargetPositionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


InvalidTopConstraintForLevel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.InvalidTopConstraintForLevel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Top Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTopConstraintForLevel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidTopConstraintForLevel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ InvalidTopConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


LostEditsJoinsRedoFaceBased Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.LostEditsJoinsRedoFaceBased Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Previous edits and /or wall joins will not be preserved on this operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId LostEditsJoinsRedoFaceBased { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LostEditsJoinsRedoFaceBased As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ LostEditsJoinsRedoFaceBased {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ParameterChangeNotAffectingGeometry Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ParameterChangeNotAffectingGeometry Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ParameterChangeNotAffectingGeometry { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ParameterChangeNotAffectingGeometry As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ParameterChangeNotAffectingGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


RecursionParameterIgnored Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.RecursionParameterIgnored Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RecursionParameterIgnored { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RecursionParameterIgnored As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RecursionParameterIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


RemapConstrainLocationLine Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.RemapConstrainLocationLine Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press"Unconstrain" to remove the constraint rather than transferring it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId RemapConstrainLocationLine { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RemapConstrainLocationLine As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ RemapConstrainLocationLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ShorterThanMinWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ShorterThanMinWall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShorterThanMinWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ShorterThanMinWallError Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ShorterThanMinWallError Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShorterThanMinWallError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ShorterThanMinWallFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ShorterThanMinWallFailure Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShorterThanMinWallFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


ShouldAdjustWallParameters Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.ShouldAdjustWallParameters Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId ShouldAdjustWallParameters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShouldAdjustWallParameters As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ ShouldAdjustWallParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


StackedWallNeedsUnjoin Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.StackedWallNeedsUnjoin Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId StackedWallNeedsUnjoin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StackedWallNeedsUnjoin As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ StackedWallNeedsUnjoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


TooShortStackedWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.TooShortStackedWall Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Stacked wall instance is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId TooShortStackedWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TooShortStackedWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ TooShortStackedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


UnableToCreateWallForPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.UnableToCreateWallForPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Unable to create wall for curtain wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCreateWallForPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToCreateWallForPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateWallForPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


UnableToDeleteWallForPanel Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.UnableToDeleteWallForPanel Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Unable to delete curtain panel wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToDeleteWallForPanel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnableToDeleteWallForPanel As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnableToDeleteWallForPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


UnjoinOnEditWallChange Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.UnjoinOnEditWallChange Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId UnjoinOnEditWallChange { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UnjoinOnEditWallChange As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ UnjoinOnEditWallChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


VerticalLayerExtensionFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.VerticalLayerExtensionFailure Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VerticalLayerExtensionFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VerticalLayerExtensionFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


VerticalLayerExtensionFailureError Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.VerticalLayerExtensionFailureError Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId VerticalLayerExtensionFailureError { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VerticalLayerExtensionFailureError As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


WallCutoutForInsertionFailure Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.WallCutoutForInsertionFailure Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Can't cut wall for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallCutoutForInsertionFailure { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallCutoutForInsertionFailure As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


WallLacksCurve Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.WallLacksCurve Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Wall does not have both a curve driver and a curve!!!!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallLacksCurve { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallLacksCurve As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallLacksCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


WallNegativeHeight Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.WallNegativeHeight Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
The top of the Wall is lower than the base of the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallNegativeHeight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallNegativeHeight As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


WallSettingsChanged Property

[image]

Revit 2011 API
BuiltInFailures..::.WallFailures..::.WallSettingsChanged Property
BuiltInFailures..::.WallFailures Class See Also Send Feedback
Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallSettingsChanged { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallSettingsChanged As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallSettingsChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallFailures Class


BuiltInFailures.WallJoinRoofFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WallJoinRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class WallJoinRoofFailures
Visual Basic (Declaration)
Public NotInheritable Class WallJoinRoofFailures
Visual C++
public ref class WallJoinRoofFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.WallJoinRoofFailures

See Also

BuiltInFailures..::.WallJoinRoofFailures Members


BuiltInFailures.WallJoinRoofFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures Members
BuiltInFailures..::.WallJoinRoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures Properties
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback

The BuiltInFailures..::.WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


NoFromRoofForWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.NoFromRoofForWall Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "From roof", however there is no roof below it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoFromRoofForWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoFromRoofForWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoFromRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


NotCoveredAtAllByTarget Property

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.NotCoveredAtAllByTarget Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
Highlighted walls are attached to, but miss, the highlighted targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NotCoveredAtAllByTarget { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NotCoveredAtAllByTarget As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NotCoveredAtAllByTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


NoUptoRoofForWall Property

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.NoUptoRoofForWall Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId NoUptoRoofForWall { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoUptoRoofForWall As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ NoUptoRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


WallMeetsRoofTangentially Property

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.WallMeetsRoofTangentially Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallMeetsRoofTangentially { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallMeetsRoofTangentially As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


WallNotCoveredByRoof Property

[image]

Revit 2011 API
BuiltInFailures..::.WallJoinRoofFailures..::.WallNotCoveredByRoof Property
BuiltInFailures..::.WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId WallNotCoveredByRoof { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WallNotCoveredByRoof As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ WallNotCoveredByRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WallJoinRoofFailures Class


BuiltInFailures.WorksharingFailures Class

[image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WorksharingFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static class WorksharingFailures
Visual Basic (Declaration)
Public NotInheritable Class WorksharingFailures
Visual C++
public ref class WorksharingFailures abstract sealed

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.BuiltInFailures..::.WorksharingFailures

See Also

BuiltInFailures..::.WorksharingFailures Members


BuiltInFailures.WorksharingFailures Members

[image] [image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures Members
BuiltInFailures..::.WorksharingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::.WorksharingFailures type exposes the following members.

Properties

Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [File Name] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [File Name] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.

See Also

BuiltInFailures..::.WorksharingFailures Class


BuiltInFailures.WorksharingFailures Properties

[image] [image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures Properties
BuiltInFailures..::.WorksharingFailures Class See Also Send Feedback

The BuiltInFailures..::.WorksharingFailures type exposes the following members.

Properties

Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [File Name] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [File Name] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.

See Also

BuiltInFailures..::.WorksharingFailures Class


DuplicateNamesChanged Property

[image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures..::.DuplicateNamesChanged Property
BuiltInFailures..::.WorksharingFailures Class See Also Send Feedback
These elements' names were automatically changed to eliminate duplicates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateNamesChanged { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DuplicateNamesChanged As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ DuplicateNamesChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WorksharingFailures Class


MissingUpdaterLatestOrCentralPlural Property

[image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures..::.MissingUpdaterLatestOrCentralPlural Property
BuiltInFailures..::.WorksharingFailures Class See Also Send Feedback
The file [File Name] you are trying to synchronize was modified by the third-party updaters [File Name] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] are present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissingUpdaterLatestOrCentralPlural { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralPlural As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralPlural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WorksharingFailures Class


MissingUpdaterLatestOrCentralSingular Property

[image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures..::.MissingUpdaterLatestOrCentralSingular Property
BuiltInFailures..::.WorksharingFailures Class See Also Send Feedback
The file [File Name] you are trying to synchronize was modified by the third-party updater [File Name] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by [File Name] will not be updated properly. This may create problems when [File Name] is later opened when [File Name] is present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId MissingUpdaterLatestOrCentralSingular { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralSingular As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WorksharingFailures Class


SeriousElementReferenceCorruption Property

[image]

Revit 2011 API
BuiltInFailures..::.WorksharingFailures..::.SeriousElementReferenceCorruption Property
BuiltInFailures..::.WorksharingFailures Class See Also Send Feedback
Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
Visual C++
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::.WorksharingFailures Class


BuiltInParameter Enumeration

[image]

Revit 2011 API
BuiltInParameter Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter ids supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BuiltInParameter
Visual Basic (Declaration)
Public Enumeration BuiltInParameter
Visual C++
public enum class BuiltInParameter

Members

Member name | Description
POINT_ELEMENT_ROTATION_ANGLE |
FLEXIBLE_INSTANCE_FLIP |
POINT_FLEXIBLE_ORIENTATION_TYPE |
DEFAULT_CONSTRUCTION_MASS_EXTERIOR_FLOOR_OBSOLETE |
DEFAULT_CONSTRUCTION_MASS_INTERIOR_SLAB_OBSOLETE |
DEFAULT_CONSTRUCTION_MASS_FLOOR |
DEFAULT_CONSTRUCTION_MASS_OPENING |
DEFAULT_CONSTRUCTION_MASS_ROOF_UNDERGROUND_OBSOLETE |
DEFAULT_CONSTRUCTION_MASS_SKYLIGHT |
DEFAULT_CONSTRUCTION_MASS_GLAZING |
DEFAULT_CONSTRUCTION_EXT_WALL_UNDERGROUND |
DEFAULT_CONSTRUCTION_MASS_SLAB |
DEFAULT_CONSTRUCTION_MASS_SHADE |
DEFAULT_CONSTRUCTION_MASS_ROOF |
DEFAULT_CONSTRUCTION_MASS_INTERIOR_WALL |
DEFAULT_CONSTRUCTION_MASS_EXTERIOR_WALL |
LEADER_RIGHT_ATTACHMENT |
LEADER_LEFT_ATTACHMENT |
STRUCTURAL_BEAM_END_ATTACHMENT_REFCOLUMN_END |
STRUCTURAL_BEAM_START_ATTACHMENT_REFCOLUMN_END |
STRUCTURAL_BEAM_END_ATTACHMENT_DISTANCE |
STRUCTURAL_BEAM_START_ATTACHMENT_DISTANCE |
STRUCTURAL_BEAM_END_ATTACHMENT_TYPE |
STRUCTURAL_BEAM_START_ATTACHMENT_TYPE |
TEXT_BOX_VISIBILITY |
CURVE_BY_POINTS_PROJECTION_TYPE |
FOLLOW_SURFACE |
POINT_FLEXIBLE_NUM_PARAM |
FRAMING_LENGTH_ROUNDOFF |
SLANTED_COLUMN_BASE_EXTENSION |
SLANTED_COLUMN_TOP_EXTENSION |
SLANTED_COLUMN_BASE_CUT_STYLE |
SLANTED_COLUMN_TOP_CUT_STYLE |
RBS_BUILDING_USELOADCREDITS |
TILE_PATTERN_FAMREF_COMPONENT_EXTENTS |
TILE_PATTERN_GRID_CELLS_Y |
TILE_PATTERN_GRID_CELLS_X |
TILE_PATTERN_GRID_UNIT_Y |
TILE_PATTERN_GRID_UNIT_X |
POINT_ELEMENT_SHOW_NORMAL_PLANE_ONLY |
LEVEL_GROUND_PLANE |
LEVEL_IS_GROUND_PLANE |
BASEPOINT_ANGLETON_PARAM |
BASEPOINT_ELEVATION_PARAM |
BASEPOINT_EASTWEST_PARAM |
BASEPOINT_NORTHSOUTH_PARAM |
SLANTED_COLUMN_GEOMETRY_TREATMENT_BASE |
SLANTED_COLUMN_GEOMETRY_TREATMENT_TOP |
ROOM_PLENUM_LIGHTING_PARAM |
SC_BOTTOM_LEVEL_ID_RECORD |
SC_TOP_LEVEL_ID_RECORD |
SC_BOTTOM_LEVEL_OFFSET_RECORD |
SC_TOP_LEVEL_OFFSET_RECORD |
STRUCTURAL_ATTACHMENT_TOP_REFERENCEDEND |
STRUCTURAL_ATTACHMENT_TOP_RATIO |
STRUCTURAL_ATTACHMENT_TOP_DISTANCE |
STRUCTURAL_ATTACHMENT_TOP_TYPE |
STRUCTURAL_ATTACHMENT_BASE_REFERENCEDEND |
STRUCTURAL_ATTACHMENT_BASE_RATIO |
STRUCTURAL_ATTACHMENT_BASE_DISTANCE |
STRUCTURAL_ATTACHMENT_BASE_TYPE |
SLANTED_COLUMN_LEVEL_OFFSET_TOP |
SLANTED_COLUMN_LEVEL_OFFSET_BASE |
INSTANCE_MOVE_BASE_WITH_GRIDS |
INSTANCE_MOVE_TOP_WITH_GRIDS |
SLANTED_COLUMN_TYPE_PARAM |
VIEW_SLANTED_COLUMN_SYMBOL_OFFSET |
POINT_ELEMENT_MIRRORED |
POINT_ELEMENT_ZFLIPPED |
POINT_ELEMENT_HOSTED_ON_FACE_V_PARAM |
POINT_ELEMENT_HOSTED_ON_FACE_U_PARAM |
LOCKED_END_OFFSET |
LOCKED_START_OFFSET |
LOCKED_BASE_OFFSET |
LOCKED_TOP_OFFSET |
RBS_PROJECT_REPORTTYPE_PARAM |
RBS_BUILDING_CONSTRUCTIONCLASS |
CONNECTOR_UTILITY_PARAM |
POINT_FLEXIBLE_SHOW_NUMBER |
POINT_FLEXIBLE_CONSTRAINED |
POINT_NAME_PARAM |
POINT_ADAPTIVE_TYPE_PARAM |
SPOT_DIM_STYLE_SLOPE_UNITS |
POINT_ELEMENT_DRIVING |
SPOT_SLOPE_LEADER_LENGTH |
SPOT_SLOPE_SUFFIX |
SPOT_SLOPE_PREFIX |
POINT_VISIBILITY_PARAM |
POINT_ELEMENT_SHOW_PLANES |
CURVE_IS_REFERENCE_LINE |
POINT_ELEMENT_HOSTED_PARAM |
POINT_ELEMENT_DRIVEN |
POINT_ELEMENT_OFFSET |
FBX_LIGHT_PHOTOMETRIC_FILE_CACHE |
FBX_LIGHT_PHOTOMETRICS_FAM |
FAMILY_CURVE_ATTACHMENT_PROPORTION |
FBX_LIGHT_LOSS_FACTOR_CTRL |
FBX_LIGHT_INITIAL_COLOR_CTRL |
FBX_LIGHT_LOSS_FACTOR_METHOD |
FBX_LIGHT_INITIAL_COLOR_NAME |
FBX_LIGHT_AT_A_DISTANCE |
FBX_LIGHT_INITIAL_INTENSITY_INPUT_METHOD |
FBX_LIGHT_SOURCE_LENGTH |
FBX_LIGHT_SOURCE_DIAMETER |
FBX_LIGHT_EMIT_CIRCLE_DIAMETER |
FBX_LIGHT_EMIT_RECTANGLE_LENGTH |
FBX_LIGHT_EMIT_RECTANGLE_WIDTH |
FBX_LIGHT_EMIT_LINE_LENGTH |
FBX_LIGHT_Z_ROTATION_OFFSET_OOPS |
FBX_LIGHT_Y_ROTATION_OFFSET_OOPS |
FBX_LIGHT_X_ROTATION_OFFSET_OOPS |
FBX_LIGHT_PHOTOMETRIC_FILE_OOPS |
FBX_LIGHT_SPOT_TILT_ANGLE_OOPS |
FBX_LIGHT_SPOT_FIELD_ANGLE_OOPS |
FBX_LIGHT_SPOT_BEAM_ANGLE_OOPS |
FBX_LIGHT_EMIT_SHAPE_VISIBLE |
FBX_LIGHT_DIMMING_LIGHT_COLOR |
FBX_LIGHT_TOTAL_LIGHT_LOSS_OOPS |
FBX_LIGHT_LUMENAIRE_DIRT |
FBX_LIGHT_LAMP_LUMEN_DEPR |
FBX_LIGHT_SURFACE_LOSS |
FBX_LIGHT_LAMP_TILT_LOSS |
FBX_LIGHT_BALLAST_LOSS_OOPS |
FBX_LIGHT_VOLTAGE_LOSS |
FBX_LIGHT_TEMPERATURE_LOSS |
FBX_LIGHT_COLOR_FILTER |
FBX_LIGHT_INITIAL_COLOR_TEMPERATURE |
FBX_LIGHT_ILLUMINANCE |
FBX_LIGHT_LIMUNOUS_INTENSITY |
FBX_LIGHT_EFFICACY |
FBX_LIGHT_WATTAGE |
FBX_LIGHT_INITIAL_INTENSITY |
FBX_LIGHT_PHOTOMETRICS |
FBX_ASSET_TYPE |
DIVIDED_SURFACE_GRID_OPTION_PARAM_2 |
DIVIDED_SURFACE_GRID_OPTION_PARAM_1 |
DIVIDED_SURFACE_DISPLAY_DISCARDEDDIVISIONLINES |
DIVIDED_SURFACE_COMPONENT_TRIM_TYPE |
DIVIDED_SURFACE_PATTERN_MIRROR |
DIVIDED_SURFACE_RULE_2_SUSPENSION |
DIVIDED_SURFACE_RULE_1_SUSPENSION |
DIVIDED_SURFACE_DISPLAY_COMPONENTS |
DIVIDED_SURFACE_PATTERN_FILL_MATERIAL |
DIVIDED_SURFACE_DISPLAY_PATTERN_FILL |
DIVIDED_SURFACE_PATTERN_LINES_STYLE |
DIVIDED_SURFACE_DISPLAY_PATTERN_LINES |
DIVIDED_SURFACE_GRIDLINES_STYLE |
DIVIDED_SURFACE_DISPLAY_GRIDLINES |
DIVIDED_SURFACE_DISPLAY_NODES |
DIVIDED_SURFACE_ORIGINAL_SURFACE_MATERIAL |
DIVIDED_SURFACE_DISPLAY_ORIGINAL_SURFACE |
DIVIDED_SURFACE_DISPLAY_SURFACE_OPTION |
DIVIDED_SURFACE_ALL_GRID_ROTATION |
DIVIDED_SURFACE_TILE_BORDER |
CURTAIN_MESH_SYSTEM_PANEL_FLIP |
CURTAIN_MESH_SYSTEM_PANEL_FAILURE |
CURTAIN_MESH_SYSTEM_PANEL_INCOMPLETE |
CURTAIN_MESH_SYSTEM_PANEL_PRIMARY |
DIVIDED_SURFACE_ALL_POINTS |
DIVIDED_SURFACE_PATTERN |
DIVIDED_SURFACE_PATTERN_FLIP |
DIVIDED_SURFACE_PATTERN_ROTATION_ANGLE |
DIVIDED_SURFACE_PATTERN_INDENT_2 |
DIVIDED_SURFACE_PATTERN_INDENT_1 |
DIVIDED_SURFACE_COVER_FACE_COMPLETELY |
DIVIDED_SURFACE_OFFSET_FROM_SURFACE |
DIVIDED_SURFACE_TOTAL_EDGE_LENGTH |
DIVIDED_SURFACE_EDGE_NUMBER |
DIVIDED_SURFACE_POINT_NUMBER |
DIVIDED_SURFACE_FACET_NUMBER |
DIVIDED_SURFACE_SURFACE_AREA |
GB_RECYCLED_HOST_ASSEMBLY |
GB_RENEWABLE_ENERGY_SOURCE |
GB_RECYCLED_COMPONENT |
GB_FCS_CERTIFIED_WOOD |
GB_GREEN_SEAL_PAINT_STD |
GB_GREEN_LABEL_PLUS_STD |
GB_OUTGAS_FORMALDEHYDE |
GB_RAPIDLY_RENEWABLE_PLANT_MATERIAL |
GB_LINK_TO_COMPONENT_DOCUMENTATION |
GB_LINK_TO_MATERIAL_DOCUMENTATION |
GB_FIXTURE_FLOW_RATE |
GB_EQUIPMENT_REFRIGERANT_LIFESPAN |
GB_REFRIGERANT_LB_PER_COOLING_TON |
GB_MINIMUM_EFFICIENCY_REPORTING_VALUE |
GB_SOLAR_REFLECTIVE_INDEX |
GB_GLOBAL_WARMING_POTENTIAL |
GB_ATMOSPHERIC_LIFETIME |
GB_OZONE_DEPLETION_POTENTIAL |
GB_VISIBLE_LIGHT_TRANSMITTANCE |
GB_NEW_MATERIAL_COST |
GB_RECYCLED_MATERIAL_COST |
GB_R_VALUE |
GB_RECYCLED_MATERIAL_PERCENT |
GB_U_VALUE |
GB_SOURCE_DISTANCE |
GB_REFRIGERANT_USED |
GB_OPERATIONAL_RECYCLED_MATERIAL |
GB_WASTE_WATER_TYPE_GENERATED |
GB_BUILDING_OCCUPANCY |
GB_ANNUAL_RENEWABLE_ENERGY_PRODUCED |
GB_ANNUAL_RAINFALL |
GB_ANNUAL_ELECTICAL_CONSUMPTION |
LABEL_MULTI_PARAMETER |
TRUSS_FAMILY_BOTTOM_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_BOTTOM_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_BOTTOM_CHORD_END_RELEASE_TYPE |
JOIST_SYSTEM_ELEM_TAG_NEW_MEMBERS_VIEW |
REFERENCE_VIEWER_ATTR_TAG |
REFERENCE_VIEWER_TARGET_VIEW |
MATCHLINE_BOTTOM_PLANE |
MATCHLINE_TOP_PLANE |
MATCHLINE_BOTTOM_OFFSET |
MATCHLINE_TOP_OFFSET |
TRUSS_FAMILY_TOP_CHORD_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_TOP_CHORD_ANGLE_PARAM |
TRUSS_FAMILY_TOP_CHORD_VERTICAL_PROJECTION_PARAM |
TRUSS_FAMILY_TOP_CHORD_START_RELEASE_TYPE |
TRUSS_FAMILY_TOP_CHORD_END_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_DIAG_WEB_ANGLE_PARAM |
TRUSS_FAMILY_DIAG_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_DIAG_WEB_END_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_STRUCTURAL_TYPES_PARAM |
TRUSS_FAMILY_VERT_WEB_ANGLE_PARAM |
TRUSS_FAMILY_VERT_WEB_START_RELEASE_TYPE |
TRUSS_FAMILY_VERT_WEB_END_RELEASE_TYPE |
TRUSS_ELEMENT_TAG_NEW_MEMBERS_VIEW |
TRUSS_NON_BEARING_OFFSET_PARAM |
TRUSS_BEARING_CHORD_TOP_BOTTOM_PARAM |
TRUSS_ELEMENT_SPAN_PARAM |
TRUSS_ELEMENT_STICK_JUST_PARAM |
TRUSS_FAMILY_WEBS_HAVE_SYMBOLIC_CUTBACK_PARAM |
TRUSS_HEIGHT |
TRUSS_FAMILY_TRANSFORMATION_PARAM |
TRUSS_ELEMENT_REFERENCE_LEVEL_PARAM |
TRUSS_ELEMENT_END1_ELEVATION |
TRUSS_ELEMENT_END0_ELEVATION |
TRUSS_ELEMENT_BEARING_JUST_PARAM |
TRUSS_ELEMENT_CREATE_BOTTOM_PARAM |
TRUSS_ELEMENT_CREATE_TOP_PARAM |
TRUSS_ELEMENT_ANGLE_PARAM |
TRUSS_ELEMENT_CLASS_PARAM |
TRUSS_FAMILY_SYMBOL_ID |
TRUSS_LENGTH |
BOUNDARY_PARAM_PRESET_AREA |
BOUNDARY_PARAM_PRESET_LINEAR |
BOUNDARY_PARAM_PRESET |
BOUNDARY_Z_TRANSLATION_SPRING |
BOUNDARY_Z_TRANSLATION_FIXED |
BOUNDARY_Z_ROTATION_SPRING |
BOUNDARY_Z_ROTATION_FIXED |
BOUNDARY_Y_TRANSLATION_SPRING |
BOUNDARY_Y_TRANSLATION_FIXED |
BOUNDARY_Y_ROTATION_SPRING |
BOUNDARY_Y_ROTATION_FIXED |
BOUNDARY_X_TRANSLATION_SPRING |
BOUNDARY_X_TRANSLATION_FIXED |
BOUNDARY_X_ROTATION_SPRING |
BOUNDARY_X_ROTATION_FIXED |
BOUNDARY_AREA_RESTRAINT_Z |
BOUNDARY_AREA_RESTRAINT_Y |
BOUNDARY_AREA_RESTRAINT_X |
BOUNDARY_LINEAR_RESTRAINT_ROT_X |
BOUNDARY_LINEAR_RESTRAINT_Z |
BOUNDARY_LINEAR_RESTRAINT_Y |
BOUNDARY_LINEAR_RESTRAINT_X |
BOUNDARY_RESTRAINT_ROT_Z |
BOUNDARY_RESTRAINT_ROT_Y |
BOUNDARY_RESTRAINT_ROT_X |
BOUNDARY_RESTRAINT_Z |
BOUNDARY_RESTRAINT_Y |
BOUNDARY_RESTRAINT_X |
BOUNDARY_DIRECTION_ROT_Z |
BOUNDARY_DIRECTION_ROT_Y |
BOUNDARY_DIRECTION_ROT_X |
BOUNDARY_DIRECTION_Z |
BOUNDARY_DIRECTION_Y |
BOUNDARY_DIRECTION_X |
BOUNDARY_CONDITIONS_IS_EXT |
BOUNDARY_CONDITIONS_TYPE |
KEYNOTE_SYSTEM |
KEY_SOURCE_PARAM |
KEYNOTE_PARAM |
KEYNOTE_NUMBER |
SHEET_KEY_NUMBER |
KEYNOTE_TEXT |
KEY_VALUE |
PHY_MATERIAL_PARAM_GRADE |
PHY_MATERIAL_PARAM_SPECIES |
PHY_MATERIAL_PARAM_EXP_COEFF |
PHY_MATERIAL_PARAM_BENDING |
PHY_MATERIAL_PARAM_SHEAR_MOD |
PHY_MATERIAL_PARAM_POISSON_MOD |
PHY_MATERIAL_PARAM_SHEAR_PERPENDICULAR |
PHY_MATERIAL_PARAM_SHEAR_PARALLEL |
PHY_MATERIAL_PARAM_COMPRESSION_PERPENDICULAR |
PHY_MATERIAL_PARAM_COMPRESSION_PARALLEL |
PHY_MATERIAL_PARAM_YOUNG_MOD |
PHY_MATERIAL_PARAM_TYPE |
ELEM_CATEGORY_PARAM_MT |
ELEM_CATEGORY_PARAM |
MATERIAL_VOLUME |
MATERIAL_AREA |
MATERIAL_NAME |
RBS_SYSTEM_FLOW_CONVERSION_METHOD_PARAM |
RBS_SYSTEM_NUM_ELEMENTS_PARAM |
RBS_SYSTEM_BASE_ELEMENT_PARAM |
RBS_SYSTEM_TYPE_PARAM |
RBS_SYSTEM_NAME_PARAM |
PHY_MATERIAL_PARAM_LIGHT_WEIGHT |
PHY_MATERIAL_PARAM_BEHAVIOR |
PHY_MATERIAL_PARAM_RESISTANCE_CALC_STRENGTH |
PHY_MATERIAL_PARAM_REDUCTION_FACTOR |
PHY_MATERIAL_PARAM_MINIMUM_TENSILE_STRENGTH |
PHY_MATERIAL_PARAM_MINIMUM_YIELD_STRESS |
PHY_MATERIAL_PARAM_SHEAR_STRENGTH_REDUCTION |
PHY_MATERIAL_PARAM_SHEAR_REINFORCEMENT |
PHY_MATERIAL_PARAM_BENDING_REINFORCEMENT |
PHY_MATERIAL_PARAM_CONCRETE_COMPRESSION |
PHY_MATERIAL_PARAM_DAMPING_RATIO |
PHY_MATERIAL_PARAM_EXP_COEFF3 |
PHY_MATERIAL_PARAM_EXP_COEFF2 |
PHY_MATERIAL_PARAM_EXP_COEFF1 |
PHY_MATERIAL_PARAM_UNIT_WEIGHT |
PHY_MATERIAL_PARAM_SHEAR_MOD3 |
PHY_MATERIAL_PARAM_SHEAR_MOD2 |
PHY_MATERIAL_PARAM_SHEAR_MOD1 |
PHY_MATERIAL_PARAM_POISSON_MOD3 |
PHY_MATERIAL_PARAM_POISSON_MOD2 |
PHY_MATERIAL_PARAM_POISSON_MOD1 |
PHY_MATERIAL_PARAM_YOUNG_MOD3 |
PHY_MATERIAL_PARAM_YOUNG_MOD2 |
PHY_MATERIAL_PARAM_YOUNG_MOD1 |
RBS_FP_SPRINKLER_ORIFICE_SIZE_PARAM |
RBS_FP_SPRINKLER_TEMPERATURE_RATING_PARAM |
RBS_FP_SPRINKLER_K_FACTOR_PARAM |
RBS_FP_SPRINKLER_PRESSURE_CLASS_PARAM |
RBS_FP_SPRINKLER_ORIFICE_PARAM |
RBS_FP_SPRINKLER_COVERAGE_PARAM |
RBS_FP_SPRINKLER_RESPONSE_PARAM |
RBS_SHOW_PROFILE_TYPE |
RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM |
RBS_PIPE_SLOPE |
RBS_DUCT_SLOPE |
RBS_CURVE_UTSLOPE |
RBS_PIPE_VOLUME_PARAM |
RBS_PIPE_WFU_PARAM |
RBS_PIPE_HWFU_PARAM |
RBS_PIPE_CWFU_PARAM |
RBS_PIPE_FLOW_CONFIGURATION_PARAM |
RBS_PIPE_FLOW_DIRECTION_PARAM |
RBS_PIPE_TOTAL_FIXTURE_UNITS_PARAM_OBSOLETE |
RBS_PIPE_FIXTURE_UNITS_PARAM |
RBS_CURVE_SLOPE_RISE_RUN_METRIC |
RBS_CURVE_SLOPE_RISE_RUN_IMPERIAL |
RBS_CURVE_SLOPE_ANGLE |
RBS_PIPE_STATIC_PRESSURE |
RBS_PIPE_INSULATION_THICKNESS |
RBS_DUCT_BOTTOM_ELEVATION |
RBS_DUCT_TOP_ELEVATION |
RBS_PIPE_OUTER_DIAMETER |
RBS_PIPE_INVERT_ELEVATION |
RBS_PIPE_TYPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_TYPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_TYPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_FITTING_LOSS_METHOD_PARAM |
RBS_PIPE_FITTING_LOSS_TABLE_PARAM |
RBS_PIPE_FITTING_LOSS_KFACTOR_PARAM |
RBS_PIPE_VALVE_LOSS_CVFACTOR_PARAM |
RBS_PIPE_ADDITIONAL_FLOW_PARAM |
RBS_PIPE_DIAMETER_PARAM |
RBS_CURVE_SLOPE |
RBS_ADJUSTABLE_CONNECTOR |
RBS_FLOW_FACTOR_PARAM |
RBS_DUCT_FLOW_CONFIGURATION_PARAM |
RBS_DUCT_FLOW_DIRECTION_PARAM |
RBS_PIPE_FLUID_TYPE_PARAM |
RBS_PIPE_FLUID_TEMPERATURE_PARAM |
RBS_PIPE_FLUID_VISCOSITY_PARAM |
RBS_PIPE_FLUID_DENSITY_PARAM |
RBS_PIPE_FLOW_PARAM |
RBS_PIPE_INNER_DIAM_PARAM |
RBS_PIPE_REYNOLDS_NUMBER_PARAM |
RBS_PIPE_RELATIVE_ROUGHNESS_PARAM |
RBS_PIPE_FLOW_STATE_PARAM |
RBS_PIPE_FRICTION_FACTOR_PARAM |
RBS_PIPE_VELOCITY_PARAM |
RBS_PIPE_FRICTION_PARAM |
RBS_PIPE_PRESSUREDROP_PARAM |
RBS_PIPE_ROUGHNESS_PARAM |
RBS_SYSTEM_PARAM |
RBS_PIPE_MATERIAL_PARAM |
RBS_PIPE_CONNECTIONTYPE_PARAM |
RBS_PIPE_CLASS_PARAM |
RBS_ELEC_PANEL_CONFIGURATION_PARAM |
RBS_ELEC_PANEL_LOCATION_PARAM |
PANEL_SCHEDULE_NAME |
TEMPLATE_NAME |
RBS_ELEC_PANEL_CURRENT_PHASEC_PARAM |
RBS_ELEC_PANEL_CURRENT_PHASEB_PARAM |
RBS_ELEC_PANEL_CURRENT_PHASEA_PARAM |
RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_RULE_PARAM |
RBS_ELEC_LOADSUMMARY_DEMAND_CURRENT_PARAM |
RBS_ELEC_LOADSUMMARY_CONNECTED_CURRENT_PARAM |
RBS_ELEC_LOADSUMMARY_DEMAND_LOAD_PARAM |
RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_PARAM |
RBS_ELEC_LOADSUMMARY_CONNECTED_LOAD_PARAM |
RBS_ELEC_LOADSUMMARY_LOADCLASSIFICATION_PARAM |
RBS_ELEC_CIRCUIT_NOTES_PARAM |
RBS_ELEC_CIRCUIT_NUMBER_OF_ELEMENTS_PARAM |
RBS_ELEC_CIRCUIT_FRAME_PARAM |
RBS_ELEC_PANEL_TOTAL_DEMAND_CURRENT_PARAM |
RBS_ELEC_PANEL_TOTAL_CONNECTED_CURRENT_PARAM |
RBS_ELEC_PANEL_TOTAL_DEMAND_FACTOR_PARAM |
RBS_ELEC_PANEL_SCHEDULE_FOOTER_NOTES_PARAM |
RBS_ELEC_PANEL_SCHEDULE_HEADER_NOTES_PARAM |
RBS_ELEC_PANEL_NUMWIRES_PARAM |
RBS_ELEC_PANEL_NUMPHASES_PARAM |
RBS_ELEC_PANEL_NEUTRAL_RATING_PARAM |
RBS_ELEC_PANEL_NEUTRAL_BUS_PARAM |
RBS_ELEC_PANEL_GROUND_BUS_PARAM |
RBS_ELEC_PANEL_BUSSING_PARAM |
RBS_ELEC_PANEL_SUBFEED_LUGS_PARAM |
RBS_ELEC_PANEL_SUPPLY_FROM_PARAM |
RBS_ELEC_PANEL_MCB_RATING_PARAM |
RBS_ELEC_PANEL_MAINSTYPE_PARAM |
RBS_ELEC_PANEL_FEED_PARAM |
RBS_CONDUITRUN_OUTER_DIAM_PARAM |
RBS_CONDUITRUN_INNER_DIAM_PARAM |
RBS_CONDUITRUN_DIAMETER_PARAM |
RBS_CABLETRAYRUN_WIDTH_PARAM |
RBS_CABLETRAYRUN_HEIGHT_PARAM |
RBS_CABLETRAYCONDUITRUN_LENGTH_PARAM |
RBS_LOAD_SUB_CLASSIFICATION_MOTOR |
RBS_CABLETRAY_SHAPETYPE |
RBS_CABLETRAYCONDUIT_BENDORFITTING |
RBS_CTC_SERVICE_TYPE |
RBS_CONDUIT_OUTER_DIAM_PARAM |
RBS_CONDUIT_INNER_DIAM_PARAM |
RBS_CTC_BOTTOM_ELEVATION |
RBS_CTC_TOP_ELEVATION |
RBS_CONDUIT_DIAMETER_PARAM |
RBS_CABLETRAY_WIDTH_PARAM |
RBS_CABLETRAY_HEIGHT_PARAM |
CIRCUIT_LOAD_CLASSIFICATION_PARAM |
CABLETRAY_MINBENDMULTIPLIER_PARAM |
CONDUIT_STANDARD_TYPE_PARAM |
RBS_CONDUIT_TRADESIZE |
RBS_CONDUIT_BENDRADIUS |
RBS_CABLETRAY_BENDRADIUS |
RBS_CABLETRAY_RUNGHEIGHT |
RBS_CABLETRAY_RUNGWIDTH |
RBS_CABLETRAY_RUNGSPACE |
RBS_CABLETRAY_THICKNESS |
RBS_ELEC_SWITCH_ID_PARAM |
RBS_WIRE_CIRCUIT_DESCRIPTION |
RBS_WIRE_CIRCUIT_LOAD_NAME |
RBS_WIRE_NUM_CONDUCTORS_PARAM |
RBS_ELEC_WIRE_TICKMARK_STATE |
RBS_CIRCUIT_DIRECTION |
RBS_ELEC_CIRCUIT_PANEL_PARAM |
RBS_ELEC_CIRCUIT_NUMBER |
RBS_ELEC_WIRE_CIRCUITS |
RBS_ELEC_CIRCUIT_WIRE_NUM_RUNS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_HOTS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_NEUTRALS_PARAM |
RBS_ELEC_CIRCUIT_WIRE_NUM_GROUNDS_PARAM |
RBS_ELEC_WIRE_TYPE |
RBS_ELEC_WIRE_ELEVATION |
RBS_ELEC_WIRE_SHOW_TICKMARKS |
RBS_ELEC_WIRE_HOT_ADJUSTMENT |
RBS_ELEC_WIRE_NEUTRAL_ADJUSTMENT |
RBS_ELEC_WIRE_GROUND_ADJUSTMENT |
RBS_ELEC_WIRE_SHARE_NEUTRAL |
RBS_ELEC_WIRE_SHARE_GROUND |
RBS_ELEC_CIRCUIT_NAME |
RBS_FAMILY_CONTENT_SECONDARY_DISTRIBSYS |
RBS_ELEC_CIRCUIT_NAMING |
RBS_ELEC_CIRCUIT_PREFIX_SEPARATOR |
RBS_ELEC_CIRCUIT_PREFIX |
RBS_ELEC_MODIFICATIONS |
RBS_ELEC_ENCLOSURE |
RBS_ELEC_MAINS |
RBS_ELEC_MOUNTING |
RBS_ELEC_SHORT_CIRCUIT_RATING |
RBS_ELEC_MAX_POLE_BREAKERS |
RBS_ELEC_PANEL_NAME |
RBS_ELEC_PANEL_TOTALESTLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_HVAC_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_LIGHT_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_POWER_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_POWER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_OTHER_PARAM |
RBS_ELEC_PANEL_TOTALESTLOAD_PARAM |
RBS_ELEC_PANEL_TOTALLOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_LOADCLASSIFICATION_PARAM |
RBS_ELEC_DEMANDFACTOR_LOAD_PARAM |
RBS_ELEC_DEMANDFACTOR_DEMANDLOAD_PARAM |
RBS_FAMILY_CONTENT_DISTRIBUTION_SYSTEM |
RBS_DISTRIBUTIONSYS_VLL_PARAM |
RBS_DISTRIBUTIONSYS_VLG_PARAM |
RBS_DISTRIBUTIONSYS_PHASE_PARAM |
RBS_DISTRIBUTIONSYS_CONFIG_PARAM |
RBS_DISTRIBUTIONSYS_NUMWIRES_PARAM |
RBS_VOLTAGETYPE_VOLTAGE_PARAM |
RBS_VOLTAGETYPE_MINVOLTAGE_PARAM |
RBS_VOLTAGETYPE_MAXVOLTAGE_PARAM |
RBS_ELEC_APPARENT_LOAD_PHASEC |
RBS_ELEC_APPARENT_LOAD_PHASEB |
RBS_ELEC_APPARENT_LOAD_PHASEA |
RBS_ELEC_TRUE_LOAD_PHASEC |
RBS_ELEC_TRUE_LOAD_PHASEB |
RBS_ELEC_TRUE_LOAD_PHASEA |
RBS_ELEC_TRUE_CURRENT_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEA_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEB_PARAM |
RBS_ELEC_TRUE_CURRENT_PHASEC_PARAM |
RBS_ELEC_APPARENT_CURRENT_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM |
RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM |
RBS_ELEC_VOLTAGE_DROP_PARAM |
RBS_ELEC_CALC_COEFFICIENT_UTILIZATION |
RBS_ELEC_CIRCUIT_LENGTH_PARAM |
RBS_ELEC_CIRCUIT_RATING_PARAM |
RBS_ELEC_CIRCUIT_WIRE_SIZE_PARAM |
RBS_ELEC_CIRCUIT_WIRE_TYPE_PARAM |
RBS_ELEC_ROOM_CAVITY_RATIO |
FBX_LIGHT_PHOTOMETRIC_FILE |
RBS_ELEC_ROOM_AVERAGE_ILLUMINATION |
RBS_ELEC_ROOM_REFLECTIVITY_FLOOR |
RBS_ELEC_ROOM_REFLECTIVITY_WALLS |
RBS_ELEC_ROOM_REFLECTIVITY_CEILING |
RBS_ELEC_ROOM_LIGHTING_CALC_WORKPLANE |
RBS_WIRE_MATERIAL_PARAM |
RBS_WIRE_TEMPERATURE_RATING_PARAM |
RBS_WIRE_INSULATION_PARAM |
RBS_WIRE_MAX_CONDUCTOR_SIZE_PARAM |
RBS_WIRE_NEUTRAL_MULTIPLIER_PARAM |
RBS_WIRE_NEUTRAL_INCLUDED_IN_BALANCED_LOAD_PARAM |
RBS_WIRE_NEUTRAL_MODE_PARAM |
RBS_WIRE_CONDUIT_TYPE_PARAM |
RBS_ELEC_AMBIENT_TEMPERATURE |
RBS_EDIT_CIRCUITS_PARAM |
RBS_ELEC_CIRCUIT_TYPE |
RBS_ELEC_SERVICE |
RBS_ELEC_PANEL |
RBS_ELEC_CIRCUIT |
RBS_ELEC_LOAD_CLASSIFICATION |
RBS_ELEC_TRUE_LOAD_PHASE3 |
RBS_ELEC_TRUE_LOAD_PHASE2 |
RBS_ELEC_TRUE_LOAD_PHASE1 |
RBS_ELEC_TRUE_LOAD |
RBS_ELEC_POWER_FACTOR_STATE |
RBS_ELEC_POWER_FACTOR |
RBS_ELEC_APPARENT_LOAD_PHASE3 |
RBS_ELEC_APPARENT_LOAD_PHASE2 |
RBS_ELEC_APPARENT_LOAD_PHASE1 |
RBS_ELEC_APPARENT_LOAD |
RBS_ELEC_BALANCED_LOAD |
RBS_ELEC_VOLTAGE |
RBS_ELEC_NUMBER_OF_POLES |
RBS_CONNECTOR_DESCRIPTION |
MARKUPS_PRIVATE |
MARKUPS_NOTES |
MARKUPS_HISTORY |
MARKUPS_STATUS |
MARKUPS_LABEL |
MARKUPS_CREATOR |
MARKUPS_CREATED |
MARKUPS_MODIFIED |
LEGEND_COMPONENT_DETAIL_LEVEL |
LEGEND_COMPONENT_LENGTH |
LEGEND_COMPONENT_VIEW |
LEGEND_COMPONENT |
OPTION_SET_ID |
OPTION_NAME |
PRIMARY_OPTION_ID |
OPTION_SET_NAME |
GROUP_ATTACHED_PARENT_NAME |
GROUP_ALLOWED_VIEW_TYPES |
GROUP_OFFSET_FROM_LEVEL |
GROUP_LEVEL |
RBS_CABLETRAYCONDUIT_CONNECTORELEM_TYPE |
RBS_CABLETRAYCONDUIT_SYSTEM_TYPE |
RBS_CONNECTOR_ISPRIMARY |
CONNECTOR_REFERENCE_INDEX |
RBS_PIPE_SYSTEM_TYPE |
CONNECTOR_ANGLE |
RBS_DUCT_SYSTEM_TYPE |
CONNECTOR_IS_EDGELOOP_CENTERED_OBSOLETE |
CONNECTOR_INDEX |
CONNECTOR_VISIBLE_SIZE |
CONNECTOR_HEIGHT |
CONNECTOR_WIDTH |
CONNECTOR_SIZE |
CONNECTOR_RADIUS |
CONNECTOR_PROFILE_TYPE |
GRID_BANK_COL_WIDTH |
GRID_BANK_ROW_HEIGHT |
GRID_BANK_COL_NUM |
GRID_BANK_ROW_NUM |
RBS_CURVETYPE_DEFAULT_BEND_PARAM |
RBS_CURVETYPE_DEFAULT_HORIZONTAL_BEND_PARAM |
RBS_CURVETYPE_MULTISHAPE_TRANSITION_OVALROUND_PARAM |
RBS_CURVETYPE_MULTISHAPE_TRANSITION_RECTOVAL_PARAM |
RBS_CURVETYPE_DEFAULT_TEEDOWN_PARAM |
RBS_CURVETYPE_DEFAULT_TEEUP_PARAM |
RBS_CURVETYPE_DEFAULT_ELBOWDOWN_PARAM |
RBS_CURVETYPE_DEFAULT_ELBOWUP_PARAM |
RBS_ENERGY_ANALYSIS_EXPORT_CATEGORY_PARAM |
RBS_ENERGY_ANALYSIS_EXPORT_COMPLEXITY_PARAM |
SPACE_ZONE_NAME |
RBS_ENERGY_ANALYSIS_EXPORT_GBXML_DEFAULTS_PARAM |
RBS_HVACLOAD_PLENUM_COOLING_LOAD_PARAM |
RBS_HVACLOAD_SKYLIGHT_COOLING_LOAD_PARAM |
RBS_HVACLOAD_PARTITION_COOLING_LOAD_PARAM |
RBS_HVACLOAD_DOOR_COOLING_LOAD_PARAM |
RBS_HVACLOAD_WINDOW_COOLING_LOAD_PARAM |
RBS_HVACLOAD_WALL_COOLING_LOAD_PARAM |
RBS_HVACLOAD_ROOF_COOLING_LOAD_PARAM |
RBS_HVACLOAD_SKYLIGHT_AREA_PARAM |
RBS_HVACLOAD_PARTITION_AREA_PARAM |
RBS_HVACLOAD_FLOOR_AREA_PARAM |
RBS_HVACLOAD_DOOR_AREA_PARAM |
RBS_HVACLOAD_WINDOW_AREA_PARAM |
RBS_HVACLOAD_WALL_AREA_PARAM |
RBS_HVACLOAD_ROOF_AREA_PARAM |
RBS_ENERGY_ANALYSIS_VIEW_COORD_AXIS_MODE |
RBS_ENERGY_ANALYSIS_VIEW_RBE_MODE |
RBS_ENERGY_ANALYSIS_VIEW_SHADING_SURFACES_MODE |
RBS_ENERGY_ANALYSIS_VIEW_TRANSPARENT_MODE |
RBS_ENERGY_ANALYSIS_VIEW_SURFACES_MODE |
RBS_ENERGY_ANALYSIS_VIEW_INNER_SHELL_MODE |
RBS_ENERGY_ANALYSIS_VIEW_OUTER_SHELL_MODE |
RBS_ENERGY_ANALYSIS_VIEW_BUILDING_SHELL_MODE |
RBS_LINING_THICKNESS_FOR_DUCT |
RBS_INSULATION_THICKNESS_FOR_PIPE |
RBS_INSULATION_THICKNESS_FOR_DUCT |
BUILDING_UNOCCUPIED_COOLING_SET_POINT_PARAM |
BUILDING_CLOSING_TIME_PARAM |
BUILDING_OPENING_TIME_PARAM |
SPACE_PEOPLE_ACTIVITY_LEVEL_PARAM |
SPACE_ELEC_EQUIPMENT_RADIANT_PERCENTAGE_PARAM |
SPACE_CONSTRUCTION_WEIGHT_PARAM |
SPACE_POWER_SCHEDULE_PARAM |
SPACE_LIGHTING_SCHEDULE_PARAM |
SPACE_OCCUPANCY_SCHEDULE_PARAM |
SPACE_INFILTRATION_PARAM |
SPACE_CARPETING_PARAM |
SPACE_LIGHTING_TYPE_PARAM |
ZONE_AIR_VOLUME_CALCULATION_TYPE_PARAM |
ZONE_COIL_BYPASS_PERCENTAGE_PARAM |
ZONE_CALCULATED_AREA_PER_COOLING_LOAD_PARAM |
ZONE_CALCULATED_AREA_PER_HEATING_LOAD_PARAM |
ZONE_USE_AIR_CHANGES_PER_HOUR_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_USE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_USE_DEHUMIDIFICATION_SETPOINT_PARAM |
ZONE_USE_HUMIDIFICATION_SETPOINT_PARAM |
ZONE_OUTDOOR_AIR_INFORMATION_PARAM |
ZONE_COOLING_INFORMATION_PARAM |
ZONE_HEATING_INFORMATION_PARAM |
RBS_ENERGY_ANALYSIS_SLIVER_SPACE_TOLERANCE |
ZONE_AREA_GROSS |
ZONE_VOLUME_GROSS |
SPACE_IS_PLENUM |
SPACE_IS_OCCUPIABLE |
SPACE_ASSOC_ROOM_NUMBER |
SPACE_ASSOC_ROOM_NAME |
ZONE_PHASE |
ZONE_PHASE_ID |
RBS_ENERGY_ANALYSIS_PROJECT_PHASE_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PER_AREA_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PER_AREA_PARAM |
ZONE_LEVEL_ID |
ZONE_OA_RATE_PER_ACH_PARAM |
ZONE_OUTSIDE_AIR_PER_AREA_PARAM |
ZONE_OUTSIDE_AIR_PER_PERSON_PARAM |
ZONE_DEHUMIDIFICATION_SET_POINT_PARAM |
ZONE_HUMIDIFICATION_SET_POINT_PARAM |
ZONE_COOLING_AIR_TEMPERATURE_PARAM |
ZONE_HEATING_AIR_TEMPERATURE_PARAM |
ZONE_COOLING_SET_POINT_PARAM |
ZONE_HEATING_SET_POINT_PARAM |
ZONE_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ZONE_CALCULATED_COOLING_LOAD_PARAM |
ZONE_CALCULATED_HEATING_LOAD_PARAM |
ZONE_SERVICE_TYPE_PARAM |
ZONE_VOLUME |
ZONE_PERIMETER |
ZONE_AREA |
ZONE_NAME |
RBS_PROJECT_CONSTRUCTION_TYPE_FLOOR_PARAM |
RBS_CONSTRUCTION_TYPE_FLOOR_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM |
RBS_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM |
RBS_ENERGY_ANALYSIS_SHADING_SURFACES_PARAM |
RBS_ENERGY_ANALYSIS_GROUND_PLANE_PARAM |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Z |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Y |
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_X |
RBS_ENERGY_ANALYSIS_SURFACE_AZIMUTH |
RBS_ENERGY_ANALYSIS_SURFACE_TILT |
RBS_ENERGY_ANALYSIS_SURFACE_CADOBJECTID |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID2 |
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID1 |
ROOM_EDIT_ELECTRICAL_LOADS_PARAM |
ROOM_EDIT_PEOPLE_LOADS_PARAM |
RBS_PROJECT_LOCATION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_PROJECT_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
RBS_CONSTRUCTION_TYPE_ROOFLIGHT_PARAM |
RBS_CONSTRUCTION_TYPE_INTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WINDOW_PARAM |
RBS_CONSTRUCTION_TYPE_PARTITION_PARAM |
RBS_CONSTRUCTION_TYPE_DOOR_PARAM |
RBS_CONSTRUCTION_TYPE_CEILING_PARAM |
RBS_CONSTRUCTION_TYPE_ROOF_PARAM |
RBS_CONSTRUCTION_TYPE_SOLID_GROUND_PARAM |
RBS_CONSTRUCTION_TYPE_EXTERNAL_WALL_PARAM |
ROOM_ACTUAL_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_ACTUAL_POWER_LOAD_PER_AREA_PARAM |
ROOM_BASE_HEAT_LOAD_ON_PARAM |
ROOM_LIGHTING_LOAD_UNITS_PARAM |
ROOM_POWER_LOAD_UNITS_PARAM |
ROOM_DESIGN_COOLING_LOAD_PARAM |
ROOM_CALCULATED_COOLING_LOAD_PARAM |
ROOM_DESIGN_HEATING_LOAD_PARAM |
ROOM_CALCULATED_HEATING_LOAD_PARAM |
ROOM_BASE_RETURN_AIRFLOW_ON_PARAM |
ROOM_CONSTRUCTION_SET_PARAM |
ROOM_SERVICE_TYPE_PARAM_OBSOLETE |
RBS_CONSTRUCTION_SET_PARAM |
RBS_SERVICE_TYPE_PARAM |
RBS_GBXML_SURFACE_AREA |
RBS_GBXML_SURFACE_TYPE |
RBS_GBXML_SURFACE_NAME |
FAMILY_ELECTRICAL_MAINTAIN_ANNOTATION_ORIENTATION |
RBS_FAMILY_CONTENT_ANNOTATION_DISPLAY |
RBS_ELECTRICAL_DATA |
RBS_CALCULATED_SIZE |
ROOM_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM |
RBS_IS_CUSTOM_FITTING |
RBS_CONNECTOR_OFFSET_OBSOLETE |
RBS_LOOKUP_TABLE_NAME |
GBXML_PREDEF_CONSTRUCTION_SLABS_ON_GRADE_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_SHADE_WALLS_PARAM |
RBS_COLOR_FILL_CONTOUR_AT_SIZE_PARAM |
RBS_COLOR_FILL_WIDTH_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PARAM |
ROOM_DESIGN_POWER_LOAD_PARAM |
ROOM_ACTUAL_OTHER_LOAD_PARAM_OBSOLETE |
ROOM_ACTUAL_MECHANICAL_LOAD_PARAM_OBSOLETE |
ROOM_ACTUAL_LIGHTING_LOAD_PARAM |
ROOM_ACTUAL_POWER_LOAD_PARAM |
ROOM_BASE_LIGHTING_LOAD_ON_PARAM |
ROOM_BASE_POWER_LOAD_ON_PARAM |
ROOM_DESIGN_OTHER_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_MECHANICAL_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_LIGHTING_LOAD_PER_AREA_PARAM |
ROOM_DESIGN_POWER_LOAD_PER_AREA_PARAM |
FBX_LIGHT_BALLAST_LOSS |
FBX_LIGHT_TOTAL_LIGHT_LOSS |
RBS_ROOM_COEFFICIENT_UTILIZATION |
RBS_FAMILY_CONTENT_TAKEOFF_FIXED_LENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_PROJLENGTH |
RBS_FAMILY_CONTENT_TAKEOFF_LENGTH |
RBS_FAMILY_CONTENT_OFFSET_HEIGHT |
RBS_FAMILY_CONTENT_OFFSET_WIDTH |
FAMILY_TABLE_OBSOLETE |
FAMILY_INLINE_FITTING_CALCULATION_MODE_OBSOLETE |
FAMILY_CONTENT_PART_TYPE |
GBXML_PREDEF_CONSTRUCTION_OPERABLE_WINDOWS_PARAM |
GBXML_PREDEF_CONSTRUCTION_NON_SLIDING_DOOR_PARAM |
GBXML_PREDEF_CONSTRUCTION_UNDERGROUND_SLABS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_FLOORS_PARAM |
GBXML_PREDEF_CONSTRUCTION_INTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_EXTERIOR_WALLS_PARAM |
GBXML_PREDEF_CONSTRUCTION_CEILINGS_PARAM |
GBXML_PREDEF_CONSTRUCTION_ROOFS_PARAM |
GBXML_EDIT_DATA_PARAM |
ROOM_ACTUAL_EXHAUST_AIRFLOW_PARAM |
ROOM_ACTUAL_RETURN_AIRFLOW_PARAM |
ROOM_ACTUAL_SUPPLY_AIRFLOW_PARAM |
ROOM_RETURN_EQUAL_SUPPLY_AIRFLOW_PARAM_OBSOLETE |
ROOM_TEMPERATURE_PARAM_OBSOLETE |
ROOM_DESIGN_COOLING_TEMP_PARAM_OBSOLETE |
ROOM_DESIGN_HEATING_TEMP_PARAM_OBSOLETE |
ROOM_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_PEOPLE_TOTAL_HEAT_GAIN_PER_PERSON_PARAM |
ROOM_LIGHTING_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_EQUIPMENT_POWER_PER_AREA_PARAM_OBSOLETE |
ROOM_USE_DATA_IN_ENERGY_ANALYSIS_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_PERSON_PARAM_OBSOLETE |
ROOM_OUTSIDE_AIR_PER_AREA_PARAM_OBSOLETE |
ROOM_AIR_CHANGES_PARAM_OBSOLETE |
ROOM_CALCULATED_EXHAUST_AIRFLOW_PARAM |
ROOM_CALCULATED_SUPPLY_AIRFLOW_PARAM |
ROOM_BASE_SUPPLY_AIRFLOW_ON_PARAM_OBSOLETE |
ROOM_DESIGN_EXHAUST_AIRFLOW_PARAM |
ROOM_DESIGN_RETURN_AIRFLOW_PARAM |
ROOM_DESIGN_SUPPLY_AIRFLOW_PARAM |
ROOM_AREA_PER_PERSON_PARAM |
ROOM_NUMBER_OF_PEOPLE_PARAM |
ROOM_OCCUPANCY_UNIT_PARAM |
ROOM_SPACE_TYPE_PARAM |
ROOM_CONDITION_TYPE_PARAM |
PROJECT_POSTAL_CODE |
PROJECT_BUILDING_TYPE |
RBS_SIZE_LOCK |
RBS_ADDITIONAL_FLOW |
RBS_CURVETYPE_MAX_WIDTH_PARAM |
ROOM_ZONE_PARAM_OBSOLETE |
RBS_CURVETYPE_DEFAULT_MECHJOINT_PARAM |
RBS_PIPE_SIZE_FORMATTED_PARAM |
RBS_DUCT_SIZE_FORMATTED_PARAM |
RBS_DUCT_STATIC_PRESSURE |
RBS_FLEX_PIPE_TYPE_PARAM |
RBS_PIPE_TYPE_PARAM |
RBS_FLEX_DUCT_TYPE_PARAM |
RBS_DUCT_TYPE_PARAM |
RBS_DUCT_FITTING_LOSS_TABLE_PARAM |
RBS_DUCT_FITTING_LOSS_METHOD_PARAM |
RBS_FLEXDUCT_ROUNDTYPE_PARAM |
RBS_CURVETYPE_PREFERRED_BRANCH_PARAM |
RBS_CURVETYPE_DEFAULT_TAKEOFF_PARAM |
RBS_OFFSET_PARAM |
RBS_CURVETYPE_DEFAULT_UNION_PARAM |
RBS_REQUIRED_FLOW |
RBS_HYDRAULIC_DIAMETER_PARAM |
RBS_REYNOLDSNUMBER_PARAM |
RBS_EQ_DIAMETER_PARAM |
RBS_CURVETYPE_MULTISHAPE_TRANSITION_PARAM |
RBS_SECTION |
RBS_LOSS_COEFFICIENT |
RBS_MAX_FLOW |
RBS_MIN_FLOW |
RBS_VELOCITY_PRESSURE |
RBS_CURVE_SURFACE_AREA |
RBS_CURVETYPE_MAX_HEIGHT_PARAM |
RBS_LINING_THICKNESS |
RBS_INSULATION_THICKNESS |
RBS_FRICTION |
RBS_CURVETYPE_RISEDROP_TYPE_PARAM |
RBS_CURVETYPE_ROUGHNESS_PARAM |
RBS_CURVETYPE_DEFAULT_TRANSITION_PARAM |
RBS_CURVETYPE_DEFAULT_CROSS_PARAM |
RBS_CURVETYPE_DEFAULT_TEE_PARAM |
RBS_CURVETYPE_DEFAULT_ELBOW_PARAM |
RBS_FLOW_DIRECTION_OBSOLETE |
RBS_PRESSURE_DROP |
RBS_VELOCITY |
RBS_CURVE_VERT_OFFSET_PARAM |
RBS_CURVE_HOR_OFFSET_PARAM |
RBS_FLOW_OBSOLETE |
RBS_CURVE_DIAMETER_PARAM |
RBS_CURVE_HEIGHT_PARAM |
RBS_CURVE_WIDTH_PARAM |
RBS_CURVETYPE_PROFILE_PARAM |
RBS_FLEX_PATTERN_PARAM |
RBS_SYSTEM_CATEGORY_PARAM |
RBS_END_OFFSET_PARAM |
RBS_START_OFFSET_PARAM |
RBS_END_LEVEL_PARAM |
RBS_START_LEVEL_PARAM |
ANALYSIS_DISPLAY_LEGEND_HEIGHT |
ANALYSIS_DISPLAY_LEGEND_WIDTH |
IFC_TYPE_GUID |
IFC_GUID |
STRUCT_CONNECTION_TYPE_NAME |
STRUCT_CONNECTION_CUTBACK |
STRUCT_CONNECTION_COLUMN_BASE |
STRUCT_CONNECTION_COLUMN_TOP |
STRUCT_CONNECTION_BEAM_END |
STRUCT_CONNECTION_BEAM_START |
STRUCT_CONNECTION_APPLY_TO |
REIN_EST_BAR_VOLUME |
REIN_EST_BAR_LENGTH |
REIN_EST_NUMBER_OF_BARS |
PATH_REIN_SPANLENGTH_ALT_OFFSET |
PATH_REIN_SPANLENGTH_BARLENGTH_ALT |
PATH_REIN_SPANLENGTH_BARLENGTH_PRIM |
PATH_REIN_SPANLENGTH_TOP_ALT |
PATH_REIN_END_SPANHOOK_ALT |
PATH_REIN_END_SPANHOOK_PRIM |
PATH_REIN_SUMMARY |
PATH_REIN_SPANLENGTH_BOTTOM_ALT |
PATH_REIN_SPANLENGTH_BOTTOM_PRIM |
PATH_REIN_SPANHOOK_ALT |
PATH_REIN_SPANHOOK_PRIM |
PATH_REIN_ADDL_OFFSET |
PATH_REIN_ALT_OFFSET |
PATH_REIN_END_HOOK_ORIENT_2_WALL |
PATH_REIN_END_HOOK_ORIENT_1_WALL |
PATH_REIN_END_HOOK_ORIENT_2_SLAB |
PATH_REIN_END_HOOK_ORIENT_1_SLAB |
PATH_REIN_END_HOOK_TYPE_2 |
PATH_REIN_END_HOOK_TYPE_1 |
PATH_REIN_HOOK_ORIENT_2_WALL |
PATH_REIN_HOOK_ORIENT_1_WALL |
PATH_REIN_HOOK_ORIENT_2_SLAB |
PATH_REIN_HOOK_ORIENT_1_SLAB |
PATH_REIN_HOOK_TYPE_2 |
PATH_REIN_HOOK_TYPE_1 |
PATH_REIN_LENGTH_2 |
PATH_REIN_LENGTH_1 |
PATH_REIN_TYPE_2 |
PATH_REIN_TYPE_1 |
PATH_REIN_ALTERNATING |
PATH_REIN_NUMBER_OF_BARS |
PATH_REIN_SPACING |
PATH_REIN_FACE_WALL |
PATH_REIN_FACE_SLAB |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_SPACING_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_SPACING_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2_GENERIC |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1_GENERIC |
REBAR_SYSTEM_SPACING_BACK_DIR_2 |
REBAR_SYSTEM_SPACING_BACK_DIR_1 |
REBAR_SYSTEM_SPACING_FRONT_DIR_2 |
REBAR_SYSTEM_SPACING_FRONT_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_1 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_2 |
REBAR_SYSTEM_ACTIVE_BACK_DIR_1 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_2 |
REBAR_SYSTEM_ACTIVE_FRONT_DIR_1 |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2 |
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1 |
REBAR_SYSTEM_SPACING_TOP_DIR_2 |
REBAR_SYSTEM_SPACING_TOP_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2 |
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_1 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_2 |
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2 |
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2 |
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_2 |
REBAR_SYSTEM_ACTIVE_TOP_DIR_1 |
REBAR_SYSTEM_SPANHOOK_TOP_DIR_2 |
REBAR_SYSTEM_SPANHOOK_BOTTOM_DIR_2 |
REBAR_SYSTEM_SPANHOOK_RIGHT_DIR_1 |
REBAR_SYSTEM_SPANHOOK_LEFT_DIR_1 |
REBAR_SYSTEM_SPANACTIVE_DIR_2 |
REBAR_SYSTEM_SPANACTIVE_DIR_1 |
REBAR_SYSTEM_ADDL_BOTTOM_OFFSET |
REBAR_SYSTEM_ADDL_TOP_OFFSET |
REBAR_SYSTEM_TOP_MINOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_BOTTOM_MAJOR |
REBAR_SYSTEM_BOTTOM_MAJOR_MATCHES_BOTTOM_MINOR |
REBAR_SYSTEM_TOP_MAJOR_MATCHES_TOP_MINOR |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_WITH_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_WITH_SPACING |
REBAR_SYSTEM_COVER_BOTTOM |
REBAR_SYSTEM_COVER_TOP |
REBAR_SYSTEM_OVERRIDE |
REBAR_SYSTEM_LAYER_SUMMARY_NO_SPACING |
REBAR_SYSTEM_LAYER_SUMMARY_WITH_SPACING |
REBAR_SYSTEM_LAYOUT_RULE |
REBAR_SYSTEM_COVER_SIDE |
REBAR_SHAPE_SPIRAL_BASE_FINISHING_TURNS |
REBAR_SHAPE_SPIRAL_TOP_FINISHING_TURNS |
REBAR_SHAPE_SPIRAL_HEIGHT |
REBAR_SHAPE_SPIRAL_PITCH |
REBAR_STANDARD_HOOK_BEND_DIAMETER |
REBAR_INCLUDE_LAST_BAR |
REBAR_INCLUDE_FIRST_BAR |
REBAR_INSTANCE_BEND_DIAMETER |
REBAR_INSTANCE_BAR_DIAMETER |
REBAR_SHAPE_END_HOOK_OFFSET |
REBAR_SHAPE_END_HOOK_LENGTH |
REBAR_SHAPE_START_HOOK_OFFSET |
REBAR_SHAPE_START_HOOK_LENGTH |
REBAR_ELEM_SCHEDULE_MARK |
REBAR_ELEM_HOOK_STYLE |
REBAR_ELEM_SHAPE |
REBAR_SHAPE_HOOK_END_TYPE |
REBAR_SHAPE_HOOK_START_TYPE |
REBAR_SHAPE_HOOK_STYLE |
REBAR_BAR_ALLOWED_BAR_TYPES |
REBAR_BAR_MAXIMUM_BEND_RADIUS |
REBAR_BAR_STIRRUP_BEND_DIAMETER |
REBAR_BAR_HOOK_LENGTHS |
REBAR_HOOK_STYLE |
REBAR_ELEM_LENGTH |
REBAR_SHAPE |
REBAR_ELEMENT_VISIBILITY |
REBAR_ELEM_BAR_SPACING |
REBAR_ELEM_QUANTITY_OF_BARS |
REBAR_ELEM_LAYOUT_RULE |
REBAR_STANDARD_BEND_DIAMETER |
REBAR_ELEM_HOOK_END_ORIENT |
REBAR_ELEM_HOOK_END_TYPE |
REBAR_ELEM_HOOK_START_ORIENT |
REBAR_ELEM_HOOK_START_TYPE |
REBAR_ELEM_TOTAL_LENGTH |
REBAR_HOOK_LINE_LEN_FACTOR |
REBAR_HOOK_ANGLE |
REBAR_BAR_STYLE |
REBAR_BAR_BEND_RADIUS |
REBAR_BAR_DIAMETER |
CWP_COPY_ROOF_INSERTS |
CWP_COPY_FLOOR_INSERTS |
CWP_COPY_WALL_INSERTS |
CWP_LINKED_ROOM_PARAMS |
CWP_LINKED_ROOM_PHASES |
CWP_ORIG_Z |
CWP_ORIG_Y |
CWP_ORIG_X |
CWP_REUSE_GRIDS_SAME_NAME |
CWP_REUSE_LEVELS_SAME_NAME |
CWP_SPLIT_COLUMNS_AT_LEVELS |
CWP_REUSE_EXISTING_GRIDS |
CWP_REUSE_EXISTING_LEVELS |
CWP_LEVEL_OFFSET |
CWP_ADD_LEVEL_SUFFIX |
CWP_ADD_LEVEL_PREFIX |
CWP_ADD_GRID_SUFFIX |
CWP_ADD_GRID_PREFIX |
CWP_DONT_COPY_TYPE |
CWP_COPY_ORIGINAL_TYPE |
LOAD_USAGE_NAME |
LOAD_COMBINATION_STATE |
LOAD_COMBINATION_TYPE |
LOAD_COMBINATION_FACTOR |
LOAD_COMBINATION_NAME |
LOAD_NATURE_NAME |
LOAD_CASE_CATEGORY |
LOAD_CASE_NATURE |
LOAD_CASE_NUMBER |
LOAD_CASE_NAME |
LOAD_ATTR_AREA_FORCE_SCALE_FACTOR |
LOAD_ATTR_LINEAR_FORCE_SCALE_FACTOR |
LOAD_ARROW_SEPARATION |
LOAD_ATTR_MOMENT_SCALE_FACTOR |
LOAD_ATTR_MOMENT_ARROW_LINE |
LOAD_ATTR_MOMENT_ARROW_ARC |
LOAD_ATTR_FORCE_SCALE_FACTOR |
LOAD_ATTR_FORCE_ARROW_TYPE |
LOAD_DESCRIPTION |
LOAD_COMMENTS |
LOAD_CASE_NATURE_TEXT |
LOAD_COMMENT_TEXT |
LOAD_ALL_NON_0_LOADS |
LOAD_AREA_AREA |
LOAD_AREA_FORCE_FZ3 |
LOAD_AREA_FORCE_FY3 |
LOAD_AREA_FORCE_FX3 |
LOAD_AREA_FORCE_FZ2 |
LOAD_AREA_FORCE_FY2 |
LOAD_AREA_FORCE_FX2 |
LOAD_AREA_FORCE_FZ1 |
LOAD_AREA_FORCE_FY1 |
LOAD_AREA_FORCE_FX1 |
LOAD_LINEAR_LENGTH |
LOAD_IS_PROJECTED |
LOAD_MOMENT_MZ2 |
LOAD_MOMENT_MY2 |
LOAD_MOMENT_MX2 |
LOAD_MOMENT_MZ1 |
LOAD_MOMENT_MY1 |
LOAD_MOMENT_MX1 |
LOAD_LINEAR_FORCE_FZ2 |
LOAD_LINEAR_FORCE_FY2 |
LOAD_LINEAR_FORCE_FX2 |
LOAD_LINEAR_FORCE_FZ1 |
LOAD_LINEAR_FORCE_FY1 |
LOAD_LINEAR_FORCE_FX1 |
LOAD_MOMENT_MZ |
LOAD_MOMENT_MY |
LOAD_MOMENT_MX |
LOAD_FORCE_FZ |
LOAD_FORCE_FY |
LOAD_FORCE_FX |
LOAD_IS_REACTION |
LOAD_IS_CREATED_BY_API |
LOAD_IS_UNIFORM |
LOAD_USE_LOCAL_COORDINATE_SYSTEM_HOSTED |
LOAD_USE_LOCAL_COORDINATE_SYSTEM |
LOAD_CASE_ID |
SPAN_DIR_SYM_PARAM_RIGHT |
SPAN_DIR_SYM_PARAM_LEFT |
SPAN_DIR_SYM_PARAM_BOTTOM |
SPAN_DIR_SYM_PARAM_TOP |
SPAN_DIR_INST_PARAM_ANGLE |
CLEAR_COVER |
CLEAR_COVER_BOTTOM |
CLEAR_COVER_TOP |
CLEAR_COVER_OTHER |
CLEAR_COVER_INTERIOR |
CLEAR_COVER_EXTERIOR |
COVER_TYPE_LENGTH |
COVER_TYPE_NAME |
JOIST_SYSTEM_CLEAR_SPACING_PARAM |
JOIST_SYSTEM_FIXED_SPACING_PARAM |
JOIST_SYSTEM_MAXIMUM_SPACING_PARAM |
CURVE_EDGE_OFFSET |
TRUSS_TYPE_EDIT |
BEAM_SYSTEM_3D_PARAM |
TRUSS_BEAM_TYPE_FOR_TRAN_PAR |
TRUSS_BEAM_TYPE_FOR_DIAG_PAR |
TRUSS_BEAM_TYPE_FOR_VERT_PAR |
TRUSS_BEAM_TYPE_FOR_BOT_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_TOP_CHORD_PAR |
TRUSS_BEAM_TYPE_FOR_CHORDS_PAR |
TRUSS_HEIGHT_PARAM |
JOIST_SYSTEM_NEW_BEAM_TYPE_NO_FAM_NAME_PARAM |
BEAM_SYSTEM_TAG_INST_PARAM_ANGLE |
BEAM_SYSTEM_TAG_PARAM_RIGHT |
BEAM_SYSTEM_TAG_PARAM_LEFT |
JOIST_SYSTEM_NUM_BEAMS_SAME_TYPE |
BEAM_H_JUSTIFICATION |
BEAM_V_JUSTIFICATION |
CURVE_SUPPORT_OFFSET |
JOIST_SYSTEM_NEW_BEAM_TYPE_PARAM |
JOIST_SYSTEM_LAYOUT_RULE_PARAM |
JOIST_SYSTEM_JUSTIFICATION_PARAM |
JOIST_SYSTEM_SPACING_PARAM |
JOIST_SYSTEM_NUMBER_OF_LINES_PARAM |
RBS_DUCT_FLOW_PARAM |
CURTAINGRID_BELT_RATIO_V |
CURTAINGRID_BELT_RATIO_U |
CURTAINGRID_USE_CURVE_DIST_V |
CURTAINGRID_USE_CURVE_DIST_U |
CURTAINGRID_ADJUST_BORDER_V |
CURTAINGRID_ADJUST_BORDER_U |
CURTAINGRID_BELT_V |
CURTAINGRID_BELT_U |
CURTAINGRID_ORIGIN_V |
CURTAINGRID_ORIGIN_U |
CURTAINGRID_ANGLE_V |
CURTAINGRID_ANGLE_U |
SPACING_NUM_DIVISIONS_V |
SPACING_NUM_DIVISIONS_U |
SPACING_JUSTIFICATION_V |
SPACING_JUSTIFICATION_U |
SPACING_LENGTH_V |
SPACING_LENGTH_U |
SPACING_LAYOUT_V |
SPACING_LAYOUT_U |
CURTAINGRID_BELT_RATIO_2 |
CURTAINGRID_BELT_RATIO_1 |
CURTAIN_VERSION_PARAM |
PADDING_LENGTH |
ELEM_ARRAY_ROLL |
ELEM_ARRAY_PITCH |
ELEM_ARRAY_ROTATION |
ELEM_ARRAY_Z_OFFSET |
ELEM_ARRAY_Y_OFFSET |
ELEM_ARRAY_X_OFFSET |
ELEM_ARRAY_ROLL_PROG |
ELEM_ARRAY_PITCH_PROG |
ELEM_ARRAY_ROTATION_PROG |
ELEM_ARRAY_ALWAYS_VERTICAL |
ELEM_ARRAY_ANCHORS_VISIBLE |
CURTAINGRID_USE_CURVE_DIST |
SPACING_JUSTIFICATION |
SPACING_NUM_DIVISIONS |
SPACING_LENGTH |
SPACING_LAYOUT |
CURTAINGRID_USE_CURVE_DIST_2 |
CURTAINGRID_USE_CURVE_DIST_1 |
CURTAINGRID_ADJUST_BORDER_2 |
CURTAINGRID_ADJUST_BORDER_1 |
CURTAINGRID_BELT_2 |
CURTAINGRID_BELT_1 |
CURTAINGRID_ORIGIN_2 |
CURTAINGRID_ORIGIN_1 |
CURTAINGRID_ANGLE_2 |
CURTAINGRID_ANGLE_1 |
SPACING_NUM_DIVISIONS_2 |
SPACING_NUM_DIVISIONS_1 |
SPACING_JUSTIFICATION_2 |
SPACING_JUSTIFICATION_1 |
SPACING_LENGTH_2 |
SPACING_LENGTH_1 |
SPACING_LAYOUT_2 |
SPACING_LAYOUT_1 |
CURTAINGRID_USE_CURVE_DIST_HORIZ |
CURTAINGRID_USE_CURVE_DIST_VERT |
CURTAINGRID_ADJUST_BORDER_HORIZ |
CURTAINGRID_ADJUST_BORDER_VERT |
CURTAINGRID_BELT_HORIZ |
CURTAINGRID_BELT_VERT |
CURTAINGRID_ORIGIN_HORIZ |
CURTAINGRID_ORIGIN_VERT |
CURTAINGRID_ANGLE_HORIZ |
CURTAINGRID_ANGLE_VERT |
GRIDLINE_SPEC_STATUS |
SPACING_NUM_DIVISIONS_HORIZ |
SPACING_NUM_DIVISIONS_VERT |
SPACING_JUSTIFICATION_HORIZ |
SPACING_JUSTIFICATION_VERT |
SPACING_LENGTH_HORIZ |
SPACING_LENGTH_VERT |
SPACING_LAYOUT_HORIZ |
SPACING_LAYOUT_VERT |
SCHEDULE_VISIBLE_DESIGN_OPTION_PARAM |
DESIGN_OPTION_ID |
DESIGN_OPTION_PARAM |
PLAN_REGION_VIEW_RANGE |
PLAN_REGION_TOP_CLIP_PLANE_OFFSET |
PLAN_REGION_BOTTOM_CLIP_PLANE_OFFSET |
PLAN_REGION_CUT_PLANE_OFFSET |
GUIDE_GRID_NAME_PARAM |
GUIDE_GRID_SPACING_PARAM |
SKETCH_GRID_SPACING_PARAM |
HOSTFIN_PARAM_VOLUME_COMPUTED |
HOSTFIN_PARAM_AREA_COMPUTED |
HOSTFIN_PARAM_MATERIAL |
HOSTFIN_PARAM_THICKNESS |
HOSTFIN_PARAM_OFFSET |
JOIN_STRENGTH_ORDER |
FAMILY_HOSTING_BEHAVIOR |
FAMILY_IS_ELEVATION_MARK_BODY |
FAMILY_USE_PRECUT_SHAPE |
WALL_SWEEP_DEFAULT_SETBACK_PARAM |
WALL_SWEEP_CUTS_WALL_PARAM |
WALL_SWEEP_CUT_BY_INSERTS_PARAM |
SLAB_EDGE_PROFILE_PARAM |
GUTTER_PROFILE_PARAM |
REVEAL_PROFILE_PARAM |
FAMILY_SHARED |
FAMILY_WORK_PLANE_BASED |
FAMILY_AUTOJOIN |
FAMILY_IS_PARAMETRIC |
FAMILY_KEEP_TEXT_READABLE |
WALL_BOTTOM_EXTENSION_DIST_PARAM |
WALL_TOP_EXTENSION_DIST_PARAM |
SWEEP_BASE_VERT_OFFSET |
SWEEP_BASE_ROTATION_ANGLE |
SWEEP_BASE_OFFSET |
SLAB_EDGE_MATERIAL_PARAM |
GUTTER_MATERIAL_PARAM |
FASCIA_MATERIAL_PARAM |
SWEEP_BASE_FLOOR_SUBCATEGORY_ID |
SWEEP_BASE_ROOF_SUBCATEGORY_ID |
FASCIA_PROFILE_PARAM |
DECAL_SUBCATEGORY_ID |
DECAL_HEIGHT_PIXELS |
DECAL_WIDTH_PIXELS |
DECAL_HEIGHT |
DECAL_WIDTH |
DECAL_LOCK_PROPORTIONS |
DECAL_ATTRIBUTES |
FAMILY_KEY_EXT_PARAM |
WALL_SWEEP_WALL_SUBCATEGORY_ID |
FAMILY_ALWAYS_VERTICAL |
FAMILY_ROTATE_WITH_COMPONENT |
HOST_VOLUME_COMPUTED |
HOST_AREA_COMPUTED |
WALL_SWEEP_WALL_OFFSET_PARAM |
CORNICE_MATERIAL_PARAM |
WALL_SWEEP_OFFSET_PARAM |
WALL_SWEEP_LEVEL_PARAM |
WALL_SWEEP_PROFILE_PARAM |
AREA_SCHEME_NAME |
AREA_SCHEME_ID |
AREA_TYPE_TEXT |
AREA_TYPE_NAME |
AREA_TYPE |
VIEW_AREA_SCHEME |
CONTOUR_LABELS_RELATIVE_BASE |
CONTOUR_LABELS_ELEV_BASE_TYPE |
PROPERTY_SEGMENT_SUBCATEGORY_ID |
PROPERTY_SEGMENT_L_R |
PROPERTY_SEGMENT_RADIUS |
PROPERTY_SEGMENT_E_W |
PROPERTY_SEGMENT_BEARING |
PROPERTY_SEGMENT_N_S |
PROPERTY_SEGMENT_DISTANCE |
PROPERTY_LENGTH_UNITS |
PROPERTY_AREA_UNITS |
VOLUME_NET |
PROJECTED_SURFACE_AREA |
CONTOUR_LABELS_LINEAR_UNITS |
CONTOUR_LABELS_PRIMARY_ONLY |
PROPERTY_SUBCATEGORY_ID |
PROPERTY_AREA_OPEN |
POCHE_DEPTH |
VOLUME_FILL |
VOLUME_CUT |
SURFACE_PERIMETER |
SURFACE_AREA |
PROPERTY_AREA |
BUILDINGPAD_HEIGHTABOVELEVEL_PARAM |
BUILDINGPAD_THICKNESS |
BOUNDARY_RADIUS |
BOUNDARY_INC_ANGLE |
CONTOUR_SUBCATEGORY_ID |
BOUNDARY_BEARING |
BOUNDARY_DISTANCE |
CONTOUR_ELEVATION_STEP |
CONTOUR_ELEVATION |
POINT_ELEVATION |
VOLUME_OF_INTEREST_NAME |
VIEWER_VOLUME_OF_INTEREST_3D |
VOLUME_OF_INTEREST_VIEWS_VISIBLE |
VIEWER_VOLUME_OF_INTEREST_CROP |
DATUM_VOLUME_OF_INTEREST |
ORIENT_BY_VIEW |
ROOM_PHASE |
ROOM_PHASE_ID |
PHASE_SEQUENCE_NUMBER |
PHASE_NAME |
VIEW_FAMILY |
ROOM_PHASE_NAME |
PRINT_SET |
VIEW_TYPE |
PHASE_DEMOLISHED_NAME |
PHASE_CREATED_NAME |
VIEW_PHASE_FILTER |
VIEW_PHASE |
PHASE_DEMOLISHED |
PHASE_CREATED |
MASS_DATA_SLAB |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_SLAB |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_FLOOR |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_OPENING |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_SKYLIGHT |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_WINDOW |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_ROOF |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_INTERIOR_WALL |
MASS_DATA_CONCEPTUAL_CONSTRUCTION_EXTERIOR_WALL |
ENERGY_ANALYSIS_HVAC_SYSTEM |
ENERGY_ANALYSIS_OUTDOOR_AIR_INFORMATION_PARAM |
ENERGY_ANALYSIS_MASSZONE_USEENERGYDATASETTINGS |
ENERGY_ANALYSIS_MASSZONE_DIVIDEPERIMETER |
ENERGY_ANALYSIS_MASSZONE_COREOFFSET |
ENERGY_ANALYSIS_SHADE_DEPTH |
ENERGY_ANALYSIS_CONCEPTUAL_CONSTRUCTION |
ENERGY_ANALYSIS_SKYLIGHT_WIDTH |
ENERGY_ANALYSIS_PERCENTAGE_SKYLIGHTS |
ENERGY_ANALYSIS_GLAZING_IS_SHADED |
ENERGY_ANALYSIS_SILL_HEIGHT |
ENERGY_ANALYSIS_PERCENTAGE_GLAZING |
ENERGY_ANALYSIS_MASS_ZONING |
ENERGY_ANALYSIS_UTILITY_RATES |
ENERGY_ANALYSIS_UTILITY_RATES_CALCULATION |
ENERGY_ANALYSIS_BUILDING_OPERATING_SCHEDULE |
ENERGY_ANALYSIS_CREATE_ANALYTICAL_MODEL |
MASS_DATA_SURFACE_DATA_SOURCE |
MASS_DATA_SKYLIGHT_WIDTH |
MASS_DATA_PERCENTAGE_SKYLIGHTS |
MASS_DATA_SILL_HEIGHT |
MASS_DATA_SHADE_DEPTH |
MASS_DATA_GLAZING_IS_SHADED |
MASS_DATA_PERCENTAGE_GLAZING |
MASS_DATA_UNDERGROUND |
MASS_DATA_MASS_OPENING_AREA |
MASS_DATA_MASS_SKYLIGHT_AREA |
MASS_DATA_MASS_WINDOW_AREA |
MASS_DATA_MASS_ROOF_AREA |
MASS_DATA_MASS_INTERIOR_WALL_AREA |
MASS_DATA_MASS_EXTERIOR_WALL_AREA |
MASS_DATA_SUBCATEGORY |
MASS_DATA_CONCEPTUAL_CONSTRUCTION |
MASS_ZONE_CONDITION_TYPE_PARAM |
MASS_ZONE_SPACE_TYPE_PARAM |
MASS_ZONE_FLOOR_AREA |
CONCEPTUAL_CONSTRUCTION_MATERIAL |
MASS_SURFACEDATA_MATERIAL |
MASS_ZONE_MATERIAL |
MASS_ZONE_VOLUME |
LEVEL_DATA_MASS_TYPE_DESCRIPTION |
LEVEL_DATA_MASS_INSTANCE_COMMENTS |
LEVEL_DATA_MASS_TYPE_COMMENTS |
LEVEL_DATA_MASS_FAMILY_AND_TYPE_PARAM |
LEVEL_DATA_MASS_FAMILY_PARAM |
LEVEL_DATA_SPACE_USAGE |
LEVEL_DATA_OWNING_LEVEL |
LEVEL_DATA_MASS_TYPE_PARAM |
LEVEL_DATA_VOLUME |
LEVEL_DATA_SURFACE_AREA |
LEVEL_DATA_FLOOR_AREA |
LEVEL_DATA_FLOOR_PERIMETER |
MASS_FUNCTION |
MASS_GROSS_VOLUME |
MASS_GROSS_SURFACE_AREA |
MASS_FLOOR_AREA_LEVELS |
MASS_GROSS_AREA |
MASSING_DEFAULT_ROOF_TYPE |
MASSING_DEFAULT_WALL_TYPE |
MASSING_DEFAULT_FLOOR_TYPE |
MASSING_INTEGRATION_LEVEL |
PROJECT_REVISION_REVISION_ISSUED |
PROJECT_REVISION_ENUMERATION |
PROJECT_REVISION_REVISION_ISSUED_BY |
PROJECT_REVISION_REVISION_ISSUED_TO |
PROJECT_REVISION_REVISION_DATE |
PROJECT_REVISION_REVISION_DESCRIPTION |
PROJECT_REVISION_REVISION_NUM |
PROJECT_REVISION_SEQUENCE_NUM |
REVISION_CLOUD_REVISION_ISSUED_BY |
REVISIONS_ARE_BY_SHEET |
REVISION_CLOUD_REVISION_ISSUED_TO |
REVISION_CLOUD_REVISION_DATE |
REVISION_CLOUD_REVISION_DESCRIPTION |
REVISION_CLOUD_REVISION_NUM |
REVISION_CLOUD_REVISION |
HELIX_PITCH |
HELIX_LENGTH |
CURVE_PATTERN_CLOUD |
REPEATING_DETAIL_ROTATION |
CURVE_PATTERN_REPEATING_DETAIL |
REPEATING_DETAIL_INSIDE |
REPEATING_DETAIL_ELEMENT |
REPEATING_DETAIL_LAYOUT |
REPEATING_DETAIL_SPACING |
REPEATING_DETAIL_NUMBER |
CURVE_PATTERN_INSULATION |
INSULATION_SCALE |
INSULATION_WIDTH |
VIEW_DETAIL_LEVEL |
DETAIL_LEVEL_PULLDOWN_IMPERIAL |
DETAIL_LEVEL_PULLDOWN_METRIC |
TAG_SELECT_END |
TAG_SELECT_START |
PLUMBING_FIXTURES_VENT_CONNECTION |
PLUMBING_FIXTURES_WASTE_CONNECTION |
PLUMBING_FIXTURES_CW_CONNECTION |
PLUMBING_FIXTURES_HW_CONNECTION |
PLUMBING_FIXTURES_TRAP |
PLUMBING_FIXTURES_DRAIN |
PLUMBING_FIXTURES_SUPPLY_PIPE |
PLUMBING_FIXTURES_SUPPLY_FITTING |
LIGHTING_FIXTURE_LIGHT_EMITTER |
FBX_LIGHT_SPOT_FIELD_ANGLE |
FBX_LIGHT_SPOT_BEAM_ANGLE |
FBX_LIGHT_SPOT_TILT_ANGLE |
LIGHTING_FIXTURE_DIMMER |
FBX_LIGHT_LIMUNOUS_FLUX |
LIGHTING_FIXTURE_ON |
LIGHTING_FIXTURE_LAMP |
LIGHTING_FIXTURE_WATTAGE |
ELECTICAL_EQUIP_VOLTAGE |
ELECTICAL_EQUIP_WATTAGE |
CURTAIN_WALL_SYSPANEL_THICKNESS |
CURTAIN_WALL_PANEL_HOST_ID |
CURTAIN_WALL_SYSPANEL_OFFSET |
CURTAIN_WALL_PANELS_WIDTH |
CURTAIN_WALL_PANELS_HEIGHT |
ALL_MODEL_SYSTEM |
ALL_MODEL_MODEL |
ALL_MODEL_MANUFACTURER |
ALL_MODEL_INSTANCE_COMMENTS |
ALL_MODEL_TYPE_COMMENTS |
ALL_MODEL_URL |
ALL_MODEL_DESCRIPTION |
CASEWORK_DEPTH |
GENERIC_DEPTH |
ELEMENT_LOCKED_PARAM |
STAIRS_RAILING_BALUSTER_IS_POST |
STAIRS_RAILING_CONNECTION |
STAIRS_RAILING_ANGLED_CONNECTION |
STAIRS_RAILING_TANGENT_CONNECTION |
STAIRS_RAILING_HEIGHT_SHIFT_VAL |
STAIRS_RAILING_HEIGHT_SHIFT_TYPE |
STAIRS_RAILING_RAIL_NAME |
STAIRS_RAILING_BALUSTER_PLACEMENT |
STAIRS_RAILING_BALUSTER_SLOPE_ANGLE |
STAIRS_RAILING_BALUSTER_BOTTOM_ANGLE |
STAIRS_RAILING_BALUSTER_TOP_ANGLE |
STAIRS_RAILING_BALUSTER_HEIGHT |
STAIRS_RAILING_HEIGHT_OFFSET |
STAIRS_RAILING_BASE_LEVEL_PARAM |
STAIRS_RAILING_BALUSTER_OFFSET |
STAIRS_RAILING_BALUSTER_FAMILY |
STAIRS_RAILING_RAIL_OFFSET |
STAIRS_RAILING_RAIL_HEIGHT |
STAIRS_RAILING_RAIL_STRUCTURE |
STAIRS_RAILING_SHAPE |
STAIRS_RAILING_BALUSTER_TREAD_OFFSET |
STAIRS_RAILING_BALUSTER_LENGTH |
STAIRS_RAILING_BALUSTER_WIDTH |
STAIRS_RAILING_BALUSTERS_PER_TREAD |
STAIRS_RAILING_BALUSTER_SPACING |
STAIRS_RAILING_BALUSTER_SPACING_TYPE |
STAIRS_RAILING_BOTTOM_EXT |
STAIRS_RAILING_TOP_EXT |
STAIRS_RAILING_BALUSTER_SHAPE |
STAIRS_RAILING_THICKNESS |
STAIRS_RAILING_WIDTH |
STAIRS_RAILING_HEIGHT |
STAIRS_RAILING_BALUSTER_ATTACH_PT |
STAIRS_RAILING_NUM_BALUSTERS |
PARAMS_TITLE_LAST |
SWEPTBLEND_PARAMS_TITLE |
ELEM_ARRAY_PARAMS_TITLE |
AREA_LOAD_PARAMS_TITLE |
REBAR_PARAMS_TITLE |
HOSTFIN_PARAMS_TITLE |
BUILDINGPAD_PARAMS_TITLE |
STAIRS_RAILING_PARAMS_TITLE |
RAMP_PARAMS_TITLE |
RAILING_PARAMS_TITLE |
OPENING_PARAMS_TITLE |
REVOLUTION_PARAMS_TITLE |
BLEND_PARAMS_TITLE |
SWEEP_PARAMS_TITLE |
EXTRUSION_PARAMS_TITLE |
REGION_PARAMS_TITLE |
WALL_PARAMS_TITLE |
CEILING_PARAMS_TITLE |
FLOOR_PARAMS_TITLE |
ROOF_PARAMS_TITLE |
STAIRS_PARAMS_TITLE |
CURVE_PARAMS_TITLE |
DEFAULT_PARAMS_TITLE |
PARAMS_TITLE_FIRST |
RAMP_ATTR_TEXT_SIZE |
RAMP_ATTR_TEXT_FONT |
RAMP_ATTR_MATERIAL |
RAMP_ATTR_RIGHT_BALUSTER_ATTACH_PT |
RAMP_ATTR_LEFT_BALUSTER_ATTACH_PT |
RAMP_ATTR_SHAPE |
RAMP_ATTR_THICKNESS |
RAMP_MAX_RUN_LENGTH |
RAMP_SLOPE |
RAMP_ATTR_MIN_INV_SLOPE |
RAMP_ATTR_WIDTH |
PLAN_VIEW_VIEW_DIR |
POCHE_MAT_ID |
ELEVATN_TAG |
CALLOUT_TAG |
SECTION_TAG |
CALLOUT_SYNCRONIZE_VIEW_DEPTH |
CALLOUT_SYNCRONIZE_BOUND_OFFSET_FAR |
LEADER_LINE_PEN |
CALLOUT_CORNER_SHEET_RADIUS |
CALLOUT_ATTR_HEAD_TAG |
SYMBOL_USER_PARAM_LAST |
SYMBOL_USER_PARAM_FIRST |
ELEMENT_USER_PARAM_LAST |
ELEMENT_USER_PARAM_FIRST |
GRID_BUBBLE_END_2 |
GRID_BUBBLE_END_1 |
DATUM_BUBBLE_LOCATION_IN_ELEV |
DATUM_BUBBLE_END_1 |
DATUM_BUBBLE_END_2 |
DATUM_TEXT |
ELLIPSE_FOCUS_MRK_VISIBLE |
UNBOUND_CURVE_SPLIT_PARAM |
ARC_CURVE_CNTR_MRK_SZ_PARAM |
ARC_CURVE_CNTR_MRK_VISIBLE_OBSOLETE |
ARC_WALL_CNTR_MRK_SZ_PARAM |
ARC_CURVE_CNTR_MRK_VISIBLE |
ARC_WALL_CNTR_MRK_VISIBLE |
REF_TABLE_PARAM_NAME |
REF_TABLE_ELEM_NAME |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_INST_PARAM |
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_EMBEDDED_PARAM |
SCHEDULE_SHEET_APPEARANCE_PARAM |
SCHEDULE_FORMAT_PARAM |
SCHEDULE_GROUP_PARAM |
SCHEDULE_SORT_PARAM |
SCHEDULE_FILTER_PARAM |
SCHEDULE_FIELDS_PARAM |
RASTER_HORIZONTAL_SCALE |
RASTER_VERTICAL_SCALE |
RASTER_SYMBOL_HEIGHT |
RASTER_SYMBOL_WIDTH |
RASTER_SYMBOL_RESOLUTION |
RASTER_SYMBOL_FILENAME |
RASTER_SYMBOL_VIEWNAME |
RASTER_SYMBOL_PIXELHEIGHT |
RASTER_SYMBOL_PIXELWIDTH |
RASTER_MAINTAIN_ASPECT_RATIO |
RASTER_SHEETHEIGHT |
RASTER_SHEETWIDTH |
IMPORT_ADT_ENTITY_ROLL |
IMPORT_ADT_ENTITY_THICKNESS |
IMPORT_ADT_ENTITY_LENGTH |
IMPORT_ADT_ENTITY_WIDTH |
IMPORT_ADT_ENTITY_HEIGHT |
IMPORT_ADT_COMPONENTS_DESC |
IMPORT_ADT_ENTITY_STYLE |
IMPORT_ADT_ENTITY_STRUCT_TYPE |
IMPORT_ADT_ENTITY_TYPE |
RVT_LINK_PHASE_MAP |
RVT_LINK_REFERENCE_TYPE |
RVT_LINK_FILE_NAME_WITHOUT_EXT |
RVT_LEVEL_OFFSET |
RVT_HOST_LEVEL |
RVT_SOURCE_LEVEL |
RVT_LEVEL_MAP |
RVT_LINK_INSTANCE_NAME |
GEO_LOCATION |
IMPORT_INSTANCE_SCALE |
IMPORT_BACKGROUND |
IMPORT_DISPLAY_UNITS |
IMPORT_BASE_LEVEL_OFFSET |
IMPORT_BASE_LEVEL |
IMPORT_SCALE |
IMPORT_SYMBOL_NAME |
ELEV_SYMBOL_ID |
ELEV_REFERENCE_LABEL_POS |
ELEV_ASSOC_DATUM |
ELEV_VIEW_NAME_POS |
ELEV_SHOW_VIEW_NAME |
ELEV_TEXT_POS |
ELEV_ARROW_FILLED |
ELEV_ARROW_ANGLE |
ELEV_SHAPE |
ELEV_WIDTH |
COLOR_FILL_SWATCH_HEIGHT_PARAM |
COLOR_FILL_SWATCH_WIDTH_PARAM |
COLOR_FILL_FILTERED_PARAM |
COLOR_FILL_SYMBOL_SIZE_PARAM |
COLOR_FILL_SCHEMA_PARAM |
DETAIL_ARRAY_GROUP_ELEMENT_INST |
DETAIL_ARRAY_GROUP_ELEMENT |
SPACING_ORIENTATION_STEP_ALL |
SPACING_INITIAL_ROTATION |
SPACING_ORIENTATION_STEP2 |
SPACING_ORIENTATION_STEP1_INST |
SHEET_GUIDE_GRID |
SHEET_CURRENT_REVISION_ISSUED |
SHEET_CURRENT_REVISION_ISSUED_BY |
SHEET_CURRENT_REVISION_ISSUED_TO |
SHEET_CURRENT_REVISION_DATE |
SHEET_CURRENT_REVISION_DESCRIPTION |
SHEET_REVISIONS_ON_SHEET |
SHEET_CURRENT_REVISION |
SHEET_HEIGHT |
SHEET_WIDTH |
SHEET_FILE_PATH |
SHEET_APPROVED_BY |
SHEET_DESIGNED_BY |
SHEET_SCHEDULED |
SHEET_CHECKED_BY |
SHEET_DRAWN_BY |
SHEET_DATE |
SHEET_SCALE |
SHEET_NUMBER |
SHEET_NAME |
MODEL_ARRAY_GROUP_ELEMENT_INST |
SPACING_APPEND |
SPACING_ORIENTATION_STEP1 |
MODEL_ARRAY_GROUP_ELEMENT |
AUTO_JOIN_CONDITION_WALL |
AUTO_MULLION_BORDER2_HORIZ |
AUTO_MULLION_BORDER1_HORIZ |
AUTO_MULLION_BORDER2_VERT |
AUTO_MULLION_BORDER1_VERT |
AUTO_MULLION_INTERIOR_HORIZ |
AUTO_MULLION_INTERIOR_VERT |
AUTO_PANEL_WALL |
AUTO_JOIN_CONDITION |
AUTO_PANEL |
AUTO_MULLION_BORDER2_GRID2 |
AUTO_MULLION_BORDER1_GRID2 |
AUTO_MULLION_BORDER2_GRID1 |
AUTO_MULLION_BORDER1_GRID1 |
AUTO_MULLION_INTERIOR_GRID2 |
AUTO_MULLION_INTERIOR_GRID1 |
CURTAIN_GRID_BASE_ORIENTATION |
MULLION_ANGLE |
MULLION_POSITION |
MULLION_PROFILE |
MAXIMUM_MULLION_LENGTH |
TRAP_MULL_WIDTH |
MULLION_DEPTH2 |
MULLION_DEPTH1 |
MULLION_DEPTH |
LV_MULLION_LEG2 |
LV_MULLION_LEG1 |
MULLION_CORNER_TYPE |
MULLION_FAM_TYPE |
MULLION_OFFSET |
CIRC_MULLION_RADIUS |
CUST_MULLION_THICK |
CUST_MULLION_WIDTH2 |
CUST_MULLION_WIDTH1 |
RECT_MULLION_THICK |
RECT_MULLION_BACK |
RECT_MULLION_FRONT |
RECT_MULLION_WIDTH2 |
RECT_MULLION_WIDTH1 |
STAIRS_RAILINGS_TYPE_NONE |
STAIRS_RAILINGS_TYPE_SYSTEM_DEFAULT |
STAIRS_INST_ALWAYS_UP |
STAIRS_ATTR_TRIM_TOP |
STAIRS_INST_DOWN_ARROW_ON |
STAIRS_INST_DOWN_LABEL_TEXT |
STAIRS_INST_DOWN_LABEL_ON |
STAIRS_INST_UP_ARROW_ON |
STAIRS_INST_UP_LABEL_TEXT |
STAIRS_INST_UP_LABEL_ON |
STAIRS_ATTR_TEXT_SIZE |
STAIRS_ATTR_TEXT_FONT |
STAIRS_ATTR_BODY_MATERIAL |
STAIRS_ATTR_LANDING_CARRIAGE |
STAIRS_ATTR_LANDINGS_OVERLAPPING |
STAIRS_ATTR_RIGHT_SIDE_STRINGER |
STAIRS_ATTR_LEFT_SIDE_STRINGER |
STAIRS_ATTR_NOSING_PLACEMENT |
STAIRS_ATTR_RISER_TREAD_CONNECT |
STAIRS_ATTR_RISER_THICKNESS |
STAIRS_ATTR_NUM_MID_STRINGERS |
STAIRS_ATTR_STAIRS_CUT_OFFSET |
STAIRS_ATTR_LAST_RISER |
STAIRS_ATTR_FIRST_RISER |
STAIRS_ATTR_STAIRS_BOTTOM |
STAIRS_ATTR_MONOLITHIC_STAIRS |
STAIRS_ATTR_CALC_ENABLED |
STAIRS_ATTR_CALC_MAX |
STAIRS_ATTR_CALC_MIN |
STAIRS_ATTR_EQ_RESULT |
STAIRS_ACTUAL_TREAD_DEPTH |
STAIRS_ATTR_TREAD_MULT |
STAIRS_ATTR_RISER_MULT |
STAIRS_ATTR_STAIR_CALCULATOR |
STAIRS_ACTUAL_NUM_RISERS |
STAIRS_ATTR_BREAK_SYM_IN_CUTLINE |
STAIRS_ATTR_RISER_MATERIAL |
STAIRS_ATTR_RISER_TYPE |
STAIRS_ATTR_TREAD_MATERIAL |
STAIRS_ATTR_NOSING_LENGTH |
STAIRS_ATTR_TREAD_FRONT_PROFILE |
STAIRS_ATTR_STRINGER_MATERIAL |
STAIRS_ATTR_STRINGER_OFFSET |
STAIRS_ATTR_STRINGER_CARRIAGE |
STAIRS_ATTR_SIDE_STRINGER_TYPE_PARAM |
STAIRS_MULTISTORY_TOP_LEVEL_PARAM |
STAIRS_STRINGERS_PRESENT |
STAIRS_BALUSTER_TREAD_OFFSET |
STAIRS_RIGHT_RAIL_BOTTOM_EXT |
STAIRS_RIGHT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_LENGTH |
STAIRS_ATTR_BALUSTER_WIDTH |
STAIRS_ATTR_BALUSTERS_PER_TREAD |
STAIRS_ATTR_BALUSTER_SPACING |
STAIRS_ATTR_BALUSTER_SPACING_TYPE |
STAIRS_LEFT_RAIL_BOTTOM_EXT |
STAIRS_LEFT_RAIL_TOP_EXT |
STAIRS_ATTR_BALUSTER_SHAPE |
STAIRS_RIGHT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_RIGHT_RAILING_PRESENT |
STAIRS_ATTR_LEFT_RAILING_PRESENT |
STAIRS_TOP_OFFSET |
STAIRS_BASE_OFFSET |
STAIRS_ATTR_RAILING_THICKNESS |
STAIRS_ATTR_RAILING_WIDTH |
STAIRS_ATTR_RAILING_HEIGHT |
STAIRS_ATTR_LEFT_BALUSTER_ATTACH_PT |
STAIRS_ATTR_BALUSTER_ATTACH_PT |
STAIRS_ATTR_NUM_BALUSTERS |
STAIRS_ATTR_RISER_ANGLE |
STAIRS_ATTR_TREAD_THICKNESS |
STAIRS_ATTR_STRINGER_THICKNESS |
STAIRS_ATTR_STRINGER_HEIGHT |
STAIRS_ATTR_RISERS_PRESENT |
STAIRS_TREAD_LENGTH |
STAIRS_ACTUAL_RISER_HEIGHT |
STAIRS_DESIRED_NUM_RISERS |
STAIRS_ATTR_TREAD_WIDTH |
STAIRS_ATTR_TREAD_LENGTH |
STAIRS_ATTR_MAX_RISER_HEIGHT |
STAIRS_TOP_LEVEL_PARAM |
STAIRS_BASE_LEVEL_PARAM |
LEVEL_RELATIVE_BASE_TYPE |
LEVEL_HORIZONTAL_TEXT_OFFSET |
LEVEL_VERTICAL_ELEV_OFFSET |
LEVEL_VERTICAL_TEXT_OFFSET |
LEVEL_IS_DATUM |
LEVEL_MAKE_PLAN_VIEW |
LEVEL_HEAD_RADIUS |
LEVEL_ELEV |
LEVEL_NAME |
LEVEL_HEAD_TAG |
TAG_NO_BREAK_PARAM_STRINGS |
ROOM_TAG_ORIENTATION_PARAM |
TAG_ORIENTATION_PARAM |
TAG_FORMAT_OPTIONS |
TAG_SAMPLE_TEXT |
TAG_TAG |
VIS_GRAPHICS_DESIGNOPTIONS |
VIS_GRAPHICS_RVT_LINKS |
VIS_GRAPHICS_FILTERS |
VIS_GRAPHICS_IMPORT |
VIS_GRAPHICS_ANNOTATION |
VIS_GRAPHICS_MODEL |
ROOM_USER_PARAM_LAST |
ROOM_USER_PARAM_FIRST |
LEVEL_ATTR_ROOM_COMPUTATION_AUTOMATIC |
LEVEL_ATTR_ROOM_COMPUTATION_HEIGHT |
ALWAYS_ZERO_LENGTH |
ROOM_COMPUTATION_METHOD |
ROOM_LOWER_OFFSET |
ROOM_UPPER_OFFSET |
ROOM_UPPER_LEVEL |
ROOM_VOLUME |
ROOM_HEIGHT |
TO_ROOM_NAME |
FROM_ROOM_NAME |
ROOM_PERIMETER |
ROOM_LEVEL_ID |
TO_WHICH_ROOM |
FROM_WHICH_ROOM |
TO_ROOM_ID |
FROM_ROOM_ID |
TO_ROOM_NUMBER |
FROM_ROOM_NUMBER |
ROOM_OCCUPANCY |
ROOM_OCCUPANT |
ROOM_DEPARTMENT |
ROOM_FINISH_BASE |
ROOM_FINISH_CEILING |
ROOM_FINISH_WALL |
ROOM_FINISH_FLOOR |
ROOM_AREA |
ROOM_NUMBER |
ROOM_NAME |
SPATIAL_FIELD_MGR_MIN |
SPATIAL_FIELD_MGR_MAX |
SPATIAL_FIELD_MGR_UNITS |
SPATIAL_FIELD_MGR_DESCRIPTION |
SPATIAL_FIELD_MGR_CURRENT_NAME |
SPATIAL_FIELD_MGR_RANGE |
FILLED_REGION_BACKGROUND |
GRID_END_SEGMENTS_LENGTH |
GRID_END_SEGMENT_PATTERN |
GRID_END_SEGMENT_COLOR |
GRID_END_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_PATTERN |
GRID_CENTER_SEGMENT_COLOR |
GRID_CENTER_SEGMENT_WEIGHT |
GRID_CENTER_SEGMENT_STYLE |
GRID_BUBBLE_LINE_PEN |
GRID_BUBBLE_RADIUS |
GRID_LABEL |
GRID_HEAD_TAG |
SECTION_BROKEN_DISPLAY_STYLE |
SECTION_COARSER_SCALE_PULLDOWN_IMPERIAL |
SECTION_COARSER_SCALE_PULLDOWN_METRIC |
SECTION_PARENT_VIEW_NAME |
SECTION_SHOW_IN_ONE_VIEW_ONLY |
SECTION_ATTR_TAIL_TAG |
SECTION_HIDE_LINE_PARAM |
SECTION_END2_MARK_PARAM |
SECTION_END1_MARK_PARAM |
SECTION_ATTR_TAIL_WIDTH |
SECTION_ATTR_TAIL_LENGTH |
VIEWER_DETAIL_NUMBER |
VIEWER_SHEET_NUMBER |
SECTION_ATTR_HEAD_TAG |
FIXED_ROTATION |
KEEP_READABLE |
LEADER_LINE |
LEADER_OFFSET_SHEET |
SPOT_SLOPE_OFFSET_FROM_REFERENCE |
SPOT_SLOPE_SLOPE_REPRESENTATION |
SPOT_SLOPE_SLOPE_DIRECTION |
SPOT_ELEV_LOWER_VALUE |
SPOT_ELEV_SINGLE_OR_UPPER_VALUE |
SPOT_ELEV_IND_TYPE_ELEVATION |
SPOT_COORDINATE_INCLUDE_ELEVATION |
SPOT_COORDINATE_ELEVATION_SUFFIX |
SPOT_COORDINATE_ELEVATION_PREFIX |
SPOT_COORDINATE_BOTTOM_SUFFIX |
SPOT_COORDINATE_BOTTOM_PREFIX |
SPOT_COORDINATE_TOP_SUFFIX |
SPOT_COORDINATE_TOP_PREFIX |
SPOT_ELEV_LOWER_SUFFIX |
SPOT_ELEV_LOWER_PREFIX |
SPOT_ELEV_SINGLE_OR_UPPER_SUFFIX |
SPOT_ELEV_SINGLE_OR_UPPER_PREFIX |
BASELINE_DIM_OFFSET |
SPOT_ELEV_BEND_LEADER |
SPOT_ELEV_IND_TYPE_BOTTOM |
SPOT_ELEV_IND_TYPE_TOP |
SPOT_ELEV_IND_BOTTOM |
SPOT_ELEV_IND_TOP |
SPOT_ELEV_TEXT_LOCATION |
SPOT_ELEV_ROTATE_WITH_COMPONENT |
SPOT_ELEV_DISPLAY_ELEVATIONS |
ORDINATE_DIM_SETTING |
LINEAR_DIM_TYPE |
SPOT_DIM_LEADER |
DIM_STYLE_FLIPPED_DIM_LINE_EXTENSION |
DIM_STYLE_INTERIOR_TICK_MARK |
SPOT_COORDINATE_TEXT_ORIENTATION |
SPOT_TEXT_FROM_LEADER |
SPOT_COORDINATE_BASE |
SPOT_ELEV_READ_CONVENTION |
SPOT_ELEV_IND_TYPE |
SPOT_ELEV_BOT_VALUE |
SPOT_ELEV_TOP_VALUE |
SPOT_ELEV_TEXT_ORIENTATION |
SPOT_ELEV_IND_ELEVATION |
SPOT_ELEV_IND_EW |
SPOT_ELEV_IND_NS |
DIM_STYLE_READ_CONVENTION |
HEAVY_END_PEN |
DIM_STYLE_DIM_LINE_SNAP_DIST |
DIM_STYLE_CENTERLINE_TICK_MARK |
SPOT_ELEV_LINE_PEN |
SPOT_ELEV_TICK_MARK_PEN |
SPOT_ELEV_LEADER_ARROWHEAD |
SPOT_ELEV_RELATIVE_BASE |
SPOT_ELEV_FLIP_TEXT_VERT |
SPOT_ELEV_TEXT_HORIZ_OFFSET |
SPOT_ELEV_LEADER |
SPOT_ELEV_BASE |
SPOT_ELEV_SYMBOL |
DIM_STYLE_SHOW_OPENING_HT |
DIM_STYLE_CENTERLINE_PATTERN |
DIM_WITNS_LINE_EXTENSION_BELOW |
DIM_WITNS_LINE_CNTRL |
DIM_LINE_EXTENSION |
DIM_STYLE_CENTERLINE_SYMBOL |
DIM_TEXT_BACKGROUND |
DIM_STYLE_ANGULAR_UNITS |
DIM_STYLE_LINEAR_UNITS |
LEADER_ARROW_WIDTH |
ARROW_FILLED |
RADIAL_FILLED_TICK |
LINEAR_FILLED_TICK |
RADIAL_ARROW_WIDTH |
LINEAR_ARROW_WIDTH |
HEAVY_TICK_MARK_PEN |
DIM_VISIBLE |
RADIAL_TICK_SIZE |
LINEAR_TICK_SIZE |
RADIAL_TICK_TYPE |
LINEAR_TICK_TYPE |
ARROW_SIZE |
ARROW_TYPE |
TICK_MARK_PEN |
TEXT_POSITION |
SUPPRESS_0_IN |
SUPPRESS_0_FT |
RADIUS_PREFIX |
CENTER_MARK_SIZE |
ARC_CENTER_MARK |
WITNS_LINE_GAP_TO_ELT |
WITNS_LINE_EXTENSION |
TICK_SIZE |
TICK_TYPE |
TEXT_DIST_TO_LINE |
TEXT_ALIGNMENT |
MODEL_TEXT_SIZE |
TEXT_STYLE_SIZE |
TEXT_STYLE_FONT |
SHOW_TITLE |
TITLE_STYLE_UNDERLINE |
TITLE_STYLE_ITALIC |
TITLE_STYLE_BOLD |
TITLE_SIZE |
TITLE_FONT |
TEXT_WIDTH_SCALE |
TEXT_TAB_SIZE |
ARC_LEADER_PARAM |
TEXT_MODEL_TEXT |
DIM_LEADER_ARROWHEAD |
SHEET_ISSUE_DATE |
PROJECT_ISSUE_DATE |
PROJECT_STATUS |
CLIENT_NAME |
PROJECT_ADDRESS |
PROJECT_NAME |
PROJECT_NUMBER |
LEADER_ARROWHEAD |
TEXT_BACKGROUND |
TEXT_STYLE_UNDERLINE |
TEXT_STYLE_ITALIC |
TEXT_STYLE_BOLD |
CURVE_IS_FILLED |
TEXT_ALIGN_VERT |
TEXT_ALIGN_HORZ |
TEXT_TEXT |
HEAD_STYLE |
LINE_PATTERN |
LINE_COLOR |
LINE_PEN |
TEXT_COLOR |
TEXT_SIZE |
TEXT_FONT |
FACE_TYPE_NON_CAPPED_END |
FACE_TYPE_CAPPED_END |
FACE_TYPE_INTERIOR |
FACE_TYPE_EXTERIOR |
FACE_TYPE |
CLINE_SUBCATEGORY |
EDGE_LINEWORK |
BUILDING_CURVE_GSTYLE_PLUS_INVISIBLE |
BUILDING_CURVE_GSTYLE |
FAMILY_CURVE_GSTYLE_FOR_2010_MASS |
HEAD_ON_PLACEMENT_METHOD |
IS_VISIBLE_PARAM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_MINUS_ANALYTICAL |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM |
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE |
FAMILY_ELEM_SUBCATEGORY |
STAIRS_CURVE_TAG |
STAIRS_CURVE_FACE_TAG |
STAIRS_CURVE_RISER_SEGMENT_NUM |
STAIRS_CURVE_ORIENTATION |
STAIRS_CURVE_BOUNDARY_SIDE |
STAIRS_CURVE_RISER_NUM |
STAIRS_CURVE_RUN_ID2 |
STAIRS_CURVE_RUN_ID1 |
STAIRS_CURVE_TYPE |
ROOF_SLOPE |
CURVE_PARAM_STEEL_CANTILEVER |
CURVE_PARAM_CONCRETE_CANTILEVER |
CURVE_NUMBER_OF_SEGMENTS |
SPECIFY_SLOPE_OR_OFFSET |
SLOPE_ARROW_LEVEL_END |
SLOPE_ARROW_LEVEL_START |
CURVE_LEVEL |
CURVE_HEIGHT_OFFSET |
CURVE_IS_SLOPE_DEFINING |
DEFINES_CONSTANT_HEIGHT |
ROOF_CURVE_HEIGHT_AT_WALL |
ROOF_RISE_RUN_IMPERIAL |
ROOF_RISE_RUN_METRIC |
ROOF_SLOPE_ANGLE |
ROOF_CURVE_HEIGHT_OFFSET |
ROOF_CURVE_IS_SLOPE_DEFINING |
VIEW_DESIGN_OPTIONS_CONFIG |
VIEW_GRAPH_SUN_PATH_SIZE |
VIEW_GRAPH_SUN_PATH |
VIEW_ANALYSIS_DISPLAY_STYLE |
VIEW_GRAPH_SCHED_LEVEL_RELATIVE_BASE_TYPE |
VIEW_GRAPH_SCHED_HIDDEN_LEVELS |
VIEW_GRAPH_SCHED_TOTAL_ROWS |
VIEW_GRAPH_SCHED_ROWS_COUNT |
VIEW_GRAPH_SCHED_GRID_APPEARANCE |
VIEW_GRAPH_SCHED_TEXT_APPEARANCE |
VIEW_GRAPH_SCHED_TITLE |
VIEW_GRAPH_SCHED_HEIGHT_BETWEEN |
VIEW_GRAPH_SCHED_HEIGHT_BELOW |
VIEW_GRAPH_SCHED_HEIGHT_ABOVE |
VIEW_GRAPH_SCHED_SIDE_WIDTH |
VIEW_GRAPH_SCHED_ROWS_FROM |
VIEW_GRAPH_SCHED_GROUP_SIMILAR |
VIEW_GRAPH_SCHED_MATERIAL_TYPES |
VIEW_GRAPH_SCHED_LOCATIONS_HIGH |
VIEW_GRAPH_SCHED_LOCATIONS_LOW |
VIEW_GRAPH_SCHED_BOTTOM_LEVEL |
VIEW_GRAPH_SCHED_TOP_LEVEL |
LIGHT_POS_Z |
LIGHT_POS_Y |
LIGHT_POS_X |
LIGHT_ON |
VIEWPORT_ATTR_ORIENTATION_ON_SHEET |
VIEWPORT_ATTR_SHOW_BOX |
VIEWPORT_ATTR_SHOW_EXTENSION_LINE |
VIEWPORT_ATTR_SHOW_LABEL |
VIEWPORT_ATTR_LABEL_TAG |
VIEW_SCALE_HAVENAME |
VIEW_SCALE_CUSTOMNAME |
VIEW_GRAPH_SCHED_OFF_GRID |
VIEW_GRAPH_SCHED_UNITS_FORMAT |
VIEWPORT_SHEET_NAME |
VIEWPORT_SHEET_NUMBER |
VIEWPORT_STRETCH_FACTOR |
VIEWPORT_SCALE |
VIEWPORT_VIEW_NAME |
VIEWPORT_DETAIL_NUMBER |
VIEWPORT_CLIPPING |
RENDER_RPC_PROPERTIES |
FAMILY_SYMBOLIC_REP |
FAMILY_RENDERING_TYPE |
RENDER_RPC_FILENAME |
RENDER_PLANT_TRIM_HEIGHT |
RENDER_PLANT_HEIGHT |
RENDER_PLANT_NAME |
RENDER_ENVIRONMENT |
RENDER_TIMEDATEPLACE |
RENDER_SETTING_UPGRADE_USER_SET |
RENDER_SETTING_UPGRADE_DPI |
RENDER_SETTING_UPGRADE_SIZEY |
RENDER_SETTING_UPGRADE_SIZEX |
RENDER_SETTING_UPGRADE_BTYPE |
COLOR_SCHEME_LOCATION |
VIEW_DEPENDENCY |
VIEW_BACK_CLIPPING |
VIEW_GRAPH_SCHED_TOTAL_COLUMNS |
VIEW_UNDERLAY_ORIENTATION |
VIEW_DEFAULT_TEMPLATE |
VIEW_GRAPH_SCHED_NUMBER_COLUMNS |
VIEW_GRAPH_SCHED_GRID_WIDTH |
GRAPHIC_DISPLAY_OPTIONS |
MODEL_GRAPHICS_STYLE_ANON_DRAFT |
VIEW_REFERENCING_DETAIL |
VIEW_REFERENCING_SHEET |
VIEW_CAMERA_POSITION |
PLAN_VIEW_NORTH |
WALKTHROUGH_FRAMES_COUNT |
PLAN_VIEW_LEVEL |
MODEL_GRAPHICS_STYLE |
VIEW_VISIBLE_CATEGORIES |
VIEW_DISCIPLINE |
PLAN_VIEW_RANGE |
VIEW_MODEL_DISPLAY_MODE |
VIEW_SHOW_MASSING |
PLAN_VIEW_TOP_CLIP_HEIGHT |
VIEW_CLEAN_JOINS |
VIEW_SHEET_VIEWPORT_INFO |
PLAN_VIEW_SHOW_ELEMS_ABOVE |
PLAN_VIEW_CUT_PLANE_HEIGHT |
VIEW_DEPTH |
VIEW_UNDERLAY_ID |
VIEW_SCALE_PULLDOWN_IMPERIAL |
VIEW_SCALE_PULLDOWN_METRIC |
VIEW_SCALE |
VIEW_SCHEMA_SETTING_FOR_SYSTEM |
VIEW_SCHEMA_SETTING_FOR_BUILDING |
VIEW_FIXED_SKETCH_PLANE |
VIEWER3D_RENDER_SETTINGS |
VIEWER_BOUND_FAR_CLIPPING |
VIEWER_REFERENCE_LABEL_TEXT |
VIEWER_IS_REFERENCE |
VIEWER_REFERENCE_LABEL |
VIEWER3D_IMAGE_SETTINGS |
VIEWER3D_RAY_QUALITY_UPGRADE |
VIEWER3D_ARE_ELEMENT_UPGRADE |
VIEWER3D_TDP_ELEMENT_UPGRADE |
VIEW_NAME_DISABLED |
VIEW_DESCRIPTION |
VIEWER_MODEL_CLIP_BOX_ACTIVE |
VIEW_NAME |
VIEWER_BOUND_ACTIVE_NEAR |
VIEWER_BOUND_ACTIVE_FAR |
VIEWER_BOUND_ACTIVE_BOTTOM |
VIEWER_BOUND_ACTIVE_TOP |
VIEWER_BOUND_ACTIVE_LEFT |
VIEWER_BOUND_ACTIVE_RIGHT |
VIEWER_BOUND_OFFSET_NEAR |
VIEWER_BOUND_OFFSET_FAR |
VIEWER_BOUND_OFFSET_BOTTOM |
VIEWER_BOUND_OFFSET_TOP |
VIEWER_BOUND_OFFSET_LEFT |
VIEWER_BOUND_OFFSET_RIGHT |
VIEWER_ANNOTATION_CROP_ACTIVE |
VIEWER_SHOW_UNCROPPED |
VIEWER_CROP_REGION_DISABLED |
VIEWER_CROP_REGION_VISIBLE |
VIEWER_CROP_REGION |
VIEWER_PERSPECTIVE_DISABLED |
VIEWER_PERSPECTIVE |
VIEWER_TARGET_ELEVATION |
VIEWER_OPTION_VISIBILITY |
VIEWER_EYE_ELEVATION |
DIM_DISPLAY_EQ |
DIM_NOT_MODIFIABLE |
DIM_SUFFIX |
DIM_PREFIX |
DIM_LABEL |
DIM_VALUE_ANGLE |
DIM_VALUE_LENGTH |
ELEM_REFERENCE_NAME_2D_XZ |
CURVE_ELEM_DEFINES_SLOPE |
RADIAL_ARRAY_ARC_RADIUS |
CURVE_DETERMINES_ORIENTATION |
DATUM_PLANE_DEFINES_WALL_CLOSURE |
CURVE_IS_DETAIL |
CURVE_ELEM_ARC_RADIUS |
CURVE_ELEM_ARC_RANGE |
CURVE_ELEM_ARC_END_ANGLE |
CURVE_ELEM_ARC_START_ANGLE |
CURVE_ELEM_LINE_ANGLE |
CURVE_ELEM_LENGTH |
ELEM_DELETABLE_IN_FAMILY |
ELEM_REFERENCE_NAME |
DATUM_PLANE_DEFINES_ORIGIN |
ELEM_IS_REFERENCE |
CURVE_ELEM_VISIBLE_TYPE |
FAMILY_PARAM_END |
FAMILY_PARAM_START |
COLUMN_LOCATION_MARK |
COLUMN_TOP_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACH_CUT_PARAM |
COLUMN_BASE_ATTACHED_PARAM |
COLUMN_TOP_ATTACHED_PARAM |
COLUMN_BASE_ATTACHMENT_OFFSET_PARAM |
COLUMN_TOP_ATTACHMENT_OFFSET_PARAM |
COLUMN_BASE_ATTACH_JUSTIFICATION_PARAM |
COLUMN_TOP_ATTACH_JUSTIFICATION_PARAM |
MATERIAL_PARAM_SHININESS |
MATERIAL_PARAM_SMOOTHNESS |
MATERIAL_PARAM_GLOW |
MATERIAL_PARAM_TRANSPARENCY |
MATERIAL_PARAM_COLOR |
SEEK_ITEM_ID |
OMNICLASS_DESCRIPTION |
OMNICLASS_CODE |
UNIFORMAT_DESCRIPTION |
UNIFORMAT_CODE |
CONTOUR_HEIGHT |
SLOPE_END_HEIGHT |
SLOPE_START_HEIGHT |
CEILING_HAS_THICKNESS_PARAM |
CEILING_THICKNESS_PARAM |
CEILING_HEIGHTABOVELEVEL_PARAM |
CEILING_THICKNESS |
CEILING_ATTR_COST_PARAM |
CEILING_ATTR_SYSTEMNAME_PARAM |
CEILING_ATTR_SPACING2_PARAM |
CEILING_ATTR_SPACING1_PARAM |
CEILING_ATTR_PATTERN_PARAM |
CEILING_ATTR_DEFAULT_HEIGHT_PARAM |
ANY_PATTERN_ID_PARAM_NO_NO |
FILL_PATTERN_ID_PARAM_NO_NO |
OBJECT_STYLE_MATERIAL_ID_PARAM |
WRAPPING_AT_INSERTS_PARAM |
WRAPPING_AT_ENDS_PARAM |
COARSE_SCALE_FILL_PATTERN_COLOR |
MODEL_CATEGORY_ID_PARAM |
HOST_ID_PARAM |
MATERIAL_ID_PARAM |
COARSE_SCALE_FILL_PATTERN_ID_PARAM |
ANY_PATTERN_ID_PARAM |
FILL_PATTERN_TYPE_PARAM |
WALL_STRUCTURE_ID_PARAM |
SURFACE_PATTERN_ID_PARAM |
FILL_PATTERN_ID_PARAM |
ID_PARAM |
ELEM_FAMILY_AND_TYPE_NAMES_PARAM |
ELEM_FAMILY_NAME_PARAM |
ELEM_TYPE_NAME_PARAM |
SCHEDULE_ROOM_PHASE_PARAM |
EDITED_BY |
SCHEDULE_TOP_LEVEL_OFFSET_PARAM |
SCHEDULE_BASE_LEVEL_OFFSET_PARAM |
SCHEDULE_TOP_LEVEL_PARAM |
SCHEDULE_BASE_LEVEL_PARAM |
SCHEDULE_LEVEL_PARAM |
ELEM_ROOM_ID |
ELEM_ROOM_NAME |
ELEM_ROOM_NUMBER |
ROOM_PARTITION_PARAM_DISABLED |
ROOM_PARTITION_PARAM |
ROOM_TAG_PARTITION_PARAM_DISABLED |
ROOM_TAG_PARTITION_PARAM |
ELEM_PARTITION_PARAM_DISABLED |
ELEM_PARTITION_PARAM |
ELEM_FAMILY_AND_TYPE_PARAM |
ELEM_FAMILY_PARAM |
ELEM_TYPE_PARAM |
ELEM_TYPE_LABEL |
BR_ORG_FILTER |
BR_ORG_FOLDERS |
ELEM_NAME_READONLY_PARAM |
ELEM_NAME_PARAM |
SYMBOL_FAMILY_AND_TYPE_NAMES_PARAM |
SYMBOL_FAMILY_NAME_PARAM |
ALL_MODEL_FAMILY_NAME |
SYMBOL_NAME_PARAM |
ALL_MODEL_TYPE_NAME |
SYMBOL_ID_PARAM |
FLOOR_PARAM_SPAN_DIRECTION |
FLOOR_PARAM_IS_STRUCTURAL |
HOST_PERIMETER_COMPUTED |
LEVEL_PARAM |
FLOOR_HEIGHTABOVELEVEL_PARAM |
FLOOR_THICKNESS_PARAM |
FLOOR_ATTR_SCALLOP_EDGES_PARAM |
FLOOR_ATTR_DEFAULT_HEIGHT_PARAM |
FLOOR_ATTR_DEFAULT_THICKNESS_PARAM |
FLOOR_ATTR_HEIGHTABOVELEVEL_PARAM |
FLOOR_ATTR_THICKNESS_PARAM |
PROFILE_PARAM_ALONG_PATH |
PROFILE_FAM_TYPE_PLUS_NONE |
PROFILE2_ANGLE |
PROFILE2_FAM_TYPE |
PROFILE2_FLIPPED_HOR |
PROFILE2_OFFSET_Y |
PROFILE2_OFFSET_X |
PROFILE1_ANGLE |
PROFILE1_FAM_TYPE |
PROFILE1_FLIPPED_HOR |
PROFILE1_OFFSET_Y |
PROFILE1_OFFSET_X |
FAM_PROFILE_USAGE |
SWEEP_TRAJ_SEGMENTED |
SWEEP_MAX_SEG_ANGLE |
MODEL_OR_SYMBOLIC |
PROFILE_ANGLE |
PROFILE_FAM_TYPE |
PROFILE_FLIPPED_HOR |
PROFILE_OFFSET_Y |
PROFILE_OFFSET_X |
EXTRUSION_LENGTH |
MATERIAL_OR_PARAM_ID |
ELEMENT_IS_CUTTING_DISABLED |
CURVE_VISIBILITY_PARAM |
GEOM_VISIBILITY_PARAM |
ELEMENT_IS_CUTTING |
EXTRUSION_AUTO_PARAMS |
BLEND_END_PARAM |
BLEND_START_PARAM |
REVOLUTION_END_ANGLE |
REVOLUTION_START_ANGLE |
EXTRUSION_END_PARAM |
EXTRUSION_START_PARAM |
FACEROOF_OFFSET_PARAM |
FACEROOF_LEVEL_PARAM |
ROOF_FACES_LOCATION |
RELATED_TO_MASS |
ROOF_RAFTER_OR_TRUSS_TEXT_PARAM |
FASCIA_DEPTH_PARAM |
ROOF_EAVE_CUT_PARAM |
ROOF_RAFTER_OR_TRUSS_PARAM |
ROOF_BASE_LEVEL_PARAM |
CURVE_WALL_OFFSET_ROOFS |
CURVE_WALL_OFFSET |
ACTUAL_MAX_RIDGE_HEIGHT_PARAM |
ALLOW_MAX_RIDGE_HEIGHT_PARAM |
ROOF_UPTO_LEVEL_OFFSET_PARAM |
ROOF_UPTO_LEVEL_PARAM |
ROOF_LEVEL_OFFSET_PARAM |
ROOF_WIDTH_PARAM |
ROOF_CONSTRAINT_OFFSET_PARAM |
ROOF_CONSTRAINT_LEVEL_PARAM |
HOST_SSE_CURVED_EDGE_CONDITION_PARAM |
ROOF_ATTR_SCALLOP_EDGES_PARAM |
ROOF_ATTR_THICKNESS_PARAM |
ROOF_ATTR_DEFAULT_THICKNESS_PARAM |
STRUCTURAL_ANALYTICAL_BEAM_RIGID_LINK |
STRUCTURAL_ANALYTICAL_COLUMN_HORIZONTAL_PROJECTION_PLANE |
STRUCTURAL_ANALYTICAL_BEAM_HORIZONTAL_PROJECTION_PLANE |
CONTINUOUS_FOOTING_BREAK_AT_INSERTS_DISABLE |
CONTINUOUS_FOOTING_DEFAULT_END_EXTENSION_LENGTH |
STRUCTURAL_ANALYTICAL_TESSELLATE |
STRUCTURAL_ANALYTICAL_TESS_DEVIATION |
STRUCTURAL_ANALYTICAL_HARD_POINTS |
STRUCTURAL_BEND_DIR_ANGLE |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_COLUMN |
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_FRAMING |
STRUCTURAL_ANALYTICAL_SKETCH_XY_AUTODETECT |
STRUCTURAL_ANALYTICAL_AUTODETECT |
STRUCTURAL_CONT_FOOTING_ANALYZES_AS |
STRUCTURAL_FOOTING_ANALYZES_AS |
STRUCTURAL_BRACE_ANALYZES_AS |
STRUCTURAL_BEAM_ANALYZES_AS |
STRUCTURAL_FLOOR_ANALYZES_AS |
STRUCTURAL_ANALYZES_AS |
STRUCTURAL_BEAM_CUTBACK_FOR_COLUMN |
BEAM_V_JUSTIFICATION_OTHER_VALUE |
STRUCTURAL_BEAM_ORIENTATION |
STRUCTURAL_BEAM_END1_ELEVATION |
STRUCTURAL_BEAM_END0_ELEVATION |
FAMILY_EXPORT_AS_GEOMETRY |
STRUCTURAL_FOUNDATION_LENGTH |
STRUCTURAL_FOUNDATION_WIDTH |
CONTINUOUS_FOOTING_LENGTH |
STRUCTURAL_PLATE_CONNECTION |
STRUCTURAL_WELD_CONNECTION |
CONTINUOUS_FOOTING_ECCENTRICITY |
CONTINUOUS_FOOTING_STRUCTURAL_USAGE |
CONTINUOUS_FOOTING_BEARING_WIDTH |
STRUCTURAL_FOOTING_BOTTOM_ELEVATION |
FAMILY_STRUCT_FOOTING_USE_CAP_TOP |
STRUCTURAL_COPING_DISTANCE |
CONTINUOUS_FOOTING_WIDTH |
CONTINUOUS_FOOTING_THICKNESS |
CONTINUOUS_FOOTING_BOTTOM_HEEL |
CONTINUOUS_FOOTING_TOP_HEEL |
CONTINUOUS_FOOTING_BOTTOM_TOE |
CONTINUOUS_FOOTING_TOP_TOE |
STRUCTURAL_ANALYTICAL_MODEL |
STRUCTURAL_ANALYTICAL_COLUMN_RIGID_LINK |
FAMILY_STRUCT_MATERIAL_TYPE |
STRUCTURAL_BOTTOM_RELEASE_MZ |
STRUCTURAL_BOTTOM_RELEASE_MY |
STRUCTURAL_BOTTOM_RELEASE_MX |
STRUCTURAL_BOTTOM_RELEASE_FZ |
STRUCTURAL_BOTTOM_RELEASE_FY |
STRUCTURAL_BOTTOM_RELEASE_FX |
STRUCTURAL_TOP_RELEASE_MZ |
STRUCTURAL_TOP_RELEASE_MY |
STRUCTURAL_TOP_RELEASE_MX |
STRUCTURAL_TOP_RELEASE_FZ |
STRUCTURAL_TOP_RELEASE_FY |
STRUCTURAL_TOP_RELEASE_FX |
STRUCTURAL_BOTTOM_RELEASE_TYPE |
STRUCTURAL_TOP_RELEASE_TYPE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_TOP |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_WALL_TOP |
STRUCTURAL_MATERIAL_TYPE |
STRUCTURAL_CAMBER |
STRUCTURAL_NUMBER_OF_STUDS |
STRUCTURAL_END_RELEASE_MZ |
STRUCTURAL_END_RELEASE_MY |
STRUCTURAL_END_RELEASE_MX |
STRUCTURAL_END_RELEASE_FZ |
STRUCTURAL_END_RELEASE_FY |
STRUCTURAL_END_RELEASE_FX |
STRUCTURAL_START_RELEASE_MZ |
STRUCTURAL_START_RELEASE_MY |
STRUCTURAL_START_RELEASE_MX |
STRUCTURAL_START_RELEASE_FZ |
STRUCTURAL_START_RELEASE_FY |
STRUCTURAL_START_RELEASE_FX |
STRUCTURAL_END_RELEASE_TYPE |
STRUCTURAL_START_RELEASE_TYPE |
STRUCTURAL_WALL_BOTTOM_PROJECTION_PLANE |
STRUCTURAL_WALL_TOP_PROJECTION_PLANE |
STRUCTURAL_WALL_PROJECTION_SURFACE |
STRUCTURAL_COLUMN_ANALYTICAL_OFFSET |
STRUCTURAL_ANALYTICAL_PROJECT_FLOOR_PLANE |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_BOTTOM |
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE |
STRUCTURAL_BRACE_REPRESENTATION |
STRUCTURAL_CONNECTION_TYPE |
STRUCTURAL_MOMENT_CONN_END |
STRUCTURAL_MOMENT_CONN_START |
STRUCTURAL_STICK_SYMBOL_LOCATION |
STRUCTURAL_BEAM_END_SUPPORT |
STRUCTURAL_BEAM_START_SUPPORT |
WINDOW_INSET_PARAM |
WINDOW_TYPE_USER_PARAM_LAST |
WINDOW_TYPE_USER_PARAM_FIRST |
ALL_MODEL_TYPE_MARK |
WINDOW_TYPE_ID |
WINDOW_DEFAULT_SILL_HEIGHT_PARAM |
WINDOW_OPENING_HEIGHT_PARAM |
WINDOW_JAMB_DEPTH_PARAM |
WINDOW_JAMB_WIDTH_PARAM |
WINDOW_OPENING_WIDTH_PARAM |
STRUCTURAL_ATTACHMENT_END_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_START_VALUE_ELEVATION |
STRUCTURAL_ATTACHMENT_END_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_START_LEVEL_REFERENCE |
STRUCTURAL_ATTACHMENT_END_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_START_VALUE_RATIO |
STRUCTURAL_ATTACHMENT_END_REFELEMENT_END |
TYPE_WALL_CLOSURE |
STRUCTURAL_ATTACHMENT_START_REFELEMENT_END |
STRUCTURAL_ATTACHMENT_END_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_START_VALUE_DISTANCE |
STRUCTURAL_ATTACHMENT_END_TYPE |
STRUCTURAL_ATTACHMENT_START_TYPE |
STRUCTURAL_FRAME_CUT_LENGTH |
INSTANCE_REFERENCE_LEVEL_PARAM |
INSTANCE_STRUCT_USAGE_TEXT_PARAM |
INSTANCE_STRUCT_USAGE_PARAM |
SKETCH_PLANE_PARAM |
INSTANCE_STRUCT_INSERTION_PARAM |
INSTANCE_STRUCT_SETBACK1_PARAM |
INSTANCE_STRUCT_SETBACK0_PARAM |
INSTANCE_LENGTH_PARAM |
INSTANCE_MOVES_WITH_GRID_PARAM |
INSTANCE_OFFSET_POS_PARAM |
INSTANCE_SCHEDULE_ONLY_LEVEL_PARAM |
INSTANCE_FREE_HOST_OFFSET_PARAM |
INSTANCE_FREE_HOST_PARAM |
INSTANCE_HEAD_HEIGHT_PARAM |
INSTANCE_SILL_HEIGHT_PARAM |
INSTANCE_ELEVATION_PARAM |
FAMILY_TOP_LEVEL_OFFSET_PARAM_DISABLED |
FAMILY_TOP_LEVEL_OFFSET_PARAM |
FAMILY_BASE_LEVEL_OFFSET_PARAM |
TEMP_SCHEDULE_CATEGORY_PARAM |
FAMILY_LEVEL_PARAM_DISABLED |
FAMILY_TOP_LEVEL_PARAM_DISABLED |
FAMILY_BASE_LEVEL_PARAM_DISABLED |
FAMILY_LEVEL_PARAM |
FAMILY_TOP_LEVEL_PARAM |
FAMILY_BASE_LEVEL_PARAM |
FAMILY_RFA_PATH_PSEUDO_PARAM |
FAMILY_CATEGORY_PSEUDO_PARAM |
FAMILY_NAME_PSEUDO_PARAM |
FAMILY_USAGE_PSEUDO_PARAM |
FAMILY_KEYWORD2 |
FAMILY_KEYWORD1 |
FAMILY_CLASS_CODE |
FAMILY_DESCRIPTION |
FAMILY_MANUFACTURER |
FAMILY_WPB_DEFAULT_ELEVATION |
FAMILY_LINE_LENGTH_PARAM |
FAMILY_ROUGH_WIDTH_PARAM |
FAMILY_ROUGH_HEIGHT_PARAM |
WINDOW_INSET |
FAMILY_WINDOW_INSET_PARAM |
FURNITURE_THICKNESS |
GENERIC_THICKNESS |
WINDOW_THICKNESS |
FAMILY_THICKNESS_PARAM |
DOOR_THICKNESS |
FURNITURE_WIDTH |
CASEWORK_WIDTH |
GENERIC_WIDTH |
WINDOW_WIDTH |
FAMILY_WIDTH_PARAM |
DOOR_WIDTH |
FURNITURE_HEIGHT |
CASEWORK_HEIGHT |
GENERIC_HEIGHT |
WINDOW_HEIGHT |
FAMILY_HEIGHT_PARAM |
DOOR_HEIGHT |
DOOR_USER_PARAM_LAST |
DOOR_USER_PARAM_FIRST |
WINDOW_OPERATION_TYPE |
DOOR_OPERATION_TYPE |
DOOR_FRAME_MATERIAL |
DOOR_FRAME_TYPE |
CURTAIN_WALL_PANELS_FINISH |
CASEWORK_FINISH |
GENERIC_FINISH |
DOOR_FINISH |
CURTAIN_WALL_PANELS_CONSTRUCTION_TYPE |
CASEWORK_CONSTRUCTION_TYPE |
GENERIC_CONSTRUCTION_TYPE |
WINDOW_CONSTRUCTION_TYPE |
DOOR_CONSTRUCTION_TYPE |
DOOR_FIRE_RATING |
ALL_MODEL_COST |
DOOR_COST |
DOOR_SYMBOL_ID |
ALL_MODEL_MARK |
DOOR_NUMBER |
DOOR_HEIGHT_PARAM_OBSOLETE |
DOOR_THICKNESS_PARAM_OBSOLETE |
DOOR_WIDTH_PARAM_OBSOLETE |
HOST_PANEL_SCHEDULE_AS_PANEL_PARAM |
WALL_LOCATION_LINE_OFFSET_PARAM |
WALL_KEY_REF_PARAM |
WALL_STRUCTURAL_USAGE_TEXT_PARAM |
MEASURE_FROM_STRUCTURE |
WALL_STRUCTURAL_USAGE_PARAM |
WALL_BOTTOM_IS_ATTACHED |
WALL_TOP_IS_ATTACHED |
CWALL_FAKE_END_PARAM_1 |
CWALL_FAKE_END_PARAM_0 |
WALL_ADDITIONAL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_HEIGHT_CONSTRAINT_UPGRADE |
WALL_BASE_CONSTRAINT_UPGRADE |
WALL_BASE_OFFSET_COMPUTED |
WALL_ADDITIONAL_TOP_REF |
WALL_TOP_OFFSET |
WALL_BASE_OFFSET |
WALL_BASE_CONSTRAINT |
WALL_TYPE_ID |
WALL_USER_HEIGHT_PARAM |
WALL_UP_TO_LEVEL_ID |
WALL_HEIGHT_TYPE |
WALL_BASE_HEIGHT_PARAM |
WALL_HEIGHT_PARAM |
WALL_WIDTH_PARAM |
ALLOW_AUTO_EMBED |
WALL_FLOOR_ATTACHMENT_TYPE |
WALL_ATTR_ROOM_BOUNDING |
FUNCTION_PARAM |
WALL_DEF_CNSTR_HEIGHT_TYPE_ALT |
WALL_DEF_CNSTR_HEIGHT_TYPE |
WALL_ATTR_HEIGHT_TYPE |
WALL_ATTR_DEFHEIGHT_PARAM |
WALL_ATTR_HEIGHT_PARAM |
WALL_ATTR_WIDTH_PARAM |
RENDER_STYLE_PARAM |
INVALID |

Remarks

Revit has a large number of built-in parameters. Given the large number of built in parameters, contact Autodesk ADN support for details on a particular parameter. The ID of the parameter can be used to retrieve the specific parameter from an Element, if it exists, by using the Element.Parameter property.

See Also


BuiltInParameterGroup Enumeration

[image]

Revit 2011 API
BuiltInParameterGroup Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BuiltInParameterGroup
Visual Basic (Declaration)
Public Enumeration BuiltInParameterGroup
Visual C++
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_CONCEPTUAL_ENERGY_DATA_BUILDING_SERVICES |
PG_DATA |
PG_ELECTRICAL_CIRCUITING |
PG_GENERAL |
PG_FLEXIBLE |
PG_ENERGY_ANALYSIS_CONCEPTUAL_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_AND_CONCEPTUAL_MODELS |
PG_FITTING |
PG_CONCEPTUAL_ENERGY_DATA |
PG_AREA |
PG_ADSK_MODEL_PROPERTIES |
PG_PATTERN_GRID_V |
PG_PATTERN_GRID_U |
PG_DISPLAY |
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PATTERN_APPLICATION |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also


CADExportOptions Class

[image]

Revit 2011 API
CADExportOptions Class
Members See Also Send Feedback
Generic CAD Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CADExportOptions
Visual Basic (Declaration)
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.ACADExportOptions
Autodesk.Revit.DB..::.DGNExportOptions
Autodesk.Revit.DB..::.DWFExportOptions
Autodesk.Revit.DB..::.SATExportOptions

See Also

CADExportOptions Members


CADExportOptions Members

[image] [image]

Revit 2011 API
CADExportOptions Members
CADExportOptions Class Methods See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class


CADExportOptions Methods

[image] [image]

Revit 2011 API
CADExportOptions Methods
CADExportOptions Class See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class


CADImportOptions Class

[image]

Revit 2011 API
CADImportOptions Class
Members See Also Send Feedback
Generic CAD Import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CADImportOptions : GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class CADImportOptions _
    Inherits GenericImportOptions
Visual C++
public ref class CADImportOptions abstract : public GenericImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GenericImportOptions
Autodesk.Revit.DB..::.CADImportOptions
Autodesk.Revit.DB..::.ACADImportOptions

See Also

CADImportOptions Members


CADImportOptions Members

[image] [image]

Revit 2011 API
CADImportOptions Members
CADImportOptions Class Methods Properties See Also Send Feedback

The CADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import.
CustomScale | Scaling the import.
OrientToView | Place the import at the same orientation as the current view.
Placement | Where to place the import.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Unit | The unit of measure for imported geometry.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions Class


CADImportOptions Methods

[image] [image]

Revit 2011 API
CADImportOptions Methods
CADImportOptions Class See Also Send Feedback

The CADImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADImportOptions Class


CADImportOptions Properties

[image] [image]

Revit 2011 API
CADImportOptions Properties
CADImportOptions Class See Also Send Feedback

The CADImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import.
CustomScale | Scaling the import.
OrientToView | Place the import at the same orientation as the current view.
Placement | Where to place the import.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only.
Unit | The unit of measure for imported geometry.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

CADImportOptions Class


ColorMode Property

[image]

Revit 2011 API
CADImportOptions..::.ColorMode Property
CADImportOptions Class See Also Send Feedback
Color mode for the import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportColorMode ColorMode { get; set; }
Visual Basic (Declaration)
Public Property ColorMode As ImportColorMode
Visual C++
public:
property ImportColorMode ColorMode {
    ImportColorMode get ();
    void set (ImportColorMode value);
}

Remarks

Three modes are supported. Black and White, Preserve Colors, and Invert Colors.

See Also

CADImportOptions Class


CustomScale Property

[image]

Revit 2011 API
CADImportOptions..::.CustomScale Property
CADImportOptions Class See Also Send Feedback
Scaling the import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CustomScale { get; set; }
Visual Basic (Declaration)
Public Property CustomScale As Double
Visual C++
public:
property double CustomScale {
    double get ();
    void set (double value);
}

Remarks

If this is defined and a valid value (> 0.0), it takes preference over units.

See Also

CADImportOptions Class


OrientToView Property

[image]

Revit 2011 API
CADImportOptions..::.OrientToView Property
CADImportOptions Class See Also Send Feedback
Place the import at the same orientation as the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool OrientToView { get; set; }
Visual Basic (Declaration)
Public Property OrientToView As Boolean
Visual C++
public:
property bool OrientToView {
    bool get ();
    void set (bool value);
}

Remarks

This option is available only for non-view-specific imports.

See Also

CADImportOptions Class


Placement Property

[image]

Revit 2011 API
CADImportOptions..::.Placement Property
CADImportOptions Class See Also Send Feedback
Where to place the import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportPlacement Placement { get; set; }
Visual Basic (Declaration)
Public Property Placement As ImportPlacement
Visual C++
public:
property ImportPlacement Placement {
    ImportPlacement get ();
    void set (ImportPlacement value);
}

Remarks

Set this option to place the view at the origin or the center, or a shared coordinates.

See Also

CADImportOptions Class


ThisViewOnly Property

[image]

Revit 2011 API
CADImportOptions..::.ThisViewOnly Property
CADImportOptions Class See Also Send Feedback
Imports dwg, dgn, and dxf drawings into the active view only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ThisViewOnly { get; set; }
Visual Basic (Declaration)
Public Property ThisViewOnly As Boolean
Visual C++
public:
property bool ThisViewOnly {
    bool get ();
    void set (bool value);
}

Remarks

This option is not available in 3D views.

See Also

CADImportOptions Class


Unit Property

[image]

Revit 2011 API
CADImportOptions..::.Unit Property
CADImportOptions Class See Also Send Feedback
The unit of measure for imported geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportUnit Unit { get; set; }
Visual Basic (Declaration)
Public Property Unit As ImportUnit
Visual C++
public:
property ImportUnit Unit {
    ImportUnit get ();
    void set (ImportUnit value);
}

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored.

Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.

See Also

CADImportOptions Class


Categories Class

[image]

Revit 2011 API
Categories Class
Members Example See Also Send Feedback
The Categories object is a map that contains all the top-level Category objects within the Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Categories : CategoryNameMap
Visual Basic (Declaration)
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
public ref class Categories : public CategoryNameMap

Remarks

Use this object to retrieve categories by name or by BuiltInCategory id.

Examples

CopyC#
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As [String] = "Number of all categories in current Revit document:" + groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CategoryNameMap
Autodesk.Revit.DB..::.Categories

See Also

Categories Members


Categories Members

[image] [image]

Revit 2011 API
Categories Members
Categories Class Methods Properties See Also Send Feedback

The Categories type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class


Categories Methods

[image] [image]

Revit 2011 API
Categories Methods
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::.Contains(String).)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.ForwardIterator()()().)
GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::.Insert(String, Category).)
NewSubcategory | Add a new subcategory into the Autodesk Revit document.
ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::.ReverseIterator()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Categories Class


Contains Method

[image]

Revit 2011 API
Categories..::.Contains Method
Categories Class See Also Send Feedback
Identifies if a category which has the specified name is in the list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Contains(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ name
) override

Parameters

name
Type: System..::.String
The name of the category to be retrieved.

Field Value

Whether the category exists in the list of top-level categories.

See Also

Categories Class


ForwardIterator Method

[image]

Revit 2011 API
Categories..::.ForwardIterator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override CategoryNameMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overrides Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator() override

Return Value

A forward moving iterator to the map.

See Also

Categories Class


GetEnumerator Method

[image]

Revit 2011 API
Categories..::.GetEnumerator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() override

Return Value

A forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Categories Class


Insert Method

[image]

Revit 2011 API
Categories..::.Insert Method
Categories Class See Also Send Feedback
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::.String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::.Category
The category to be inserted into the map.

Return Value

Whether or not the category was inserted into the map.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class


NewSubcategory Method

[image]

Revit 2011 API
Categories..::.NewSubcategory Method
Categories Class Example See Also Send Feedback
Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Visual Basic (Declaration)
Public Function NewSubcategory ( _
    parentCategory As Category, _
    name As String _
) As Category
Visual C++
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)

Parameters

parentCategory
Type: Autodesk.Revit.DB..::.Category
The parent category.
name
Type: System..::.String
The new category name.

Return Value

If successful, the newly created subcategory.

Examples

CopyC#
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    MaterialWood woodMaterial = document.Settings.Materials.AddWood("Wood Material");
    subCat.Material = woodMaterial;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
CopyVB.NET
Public Sub AssignSubCategory(ByVal document As Document, ByVal extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim woodMaterial As MaterialWood = document.Settings.Materials.AddWood("Wood Material")
    subCat.Material = woodMaterial

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when subcategory creation failed.

See Also

Categories Class


ReverseIterator Method

[image]

Revit 2011 API
Categories..::.ReverseIterator Method
Categories Class See Also Send Feedback
Retrieves a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override CategoryNameMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overrides Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator() override

Return Value

A backward moving iterator to the map.

See Also

Categories Class


Categories Properties

[image] [image]

Revit 2011 API
Categories Properties
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Properties

Name | Description
IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::.IsEmpty.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Retrieves a category object matching an identifier.
Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::.Size.)

See Also

Categories Class


IsEmpty Property

[image]

Revit 2011 API
Categories..::.IsEmpty Property
Categories Class See Also Send Feedback
Whether or not the list of top-level categories is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get () override;
}

See Also

Categories Class


Item Property

[image] [image]

Revit 2011 API
Categories..::.Item Property
Categories Class See Also Send Feedback
Retrieves a category object matching an identifier.

Overload List

Name | Description
Item[([(BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Item[([(String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::.Item[([(String])]).)

See Also

Categories Class
Categories Members


Item Property (BuiltInCategory)

[image]

Revit 2011 API
Categories..::.Item Property (BuiltInCategory)
Categories Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Category Item[
    BuiltInCategory categoryId
] { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
Type: Autodesk.Revit.DB..::.BuiltInCategory

Remarks

Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories.

See Also

Categories Class
Item Overload


Item Property (String)

[image]

Revit 2011 API
Categories..::.Item Property (String)
Categories Class See Also Send Feedback
Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Category Item[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Overrides Property Item ( _
    name As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}

Parameters

name
Type: System..::.String
The name of the category to be retrieved.

Field Value

The category with the specified name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.

See Also

Categories Class
Item Overload


Size Property

[image]

Revit 2011 API
Categories..::.Size Property
Categories Class See Also Send Feedback
The total number of top-level categories in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int Size { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get () override;
}

See Also

Categories Class


Category Class

[image]

Revit 2011 API
Category Class
Members Example See Also Send Feedback
Represents the category or subcategory to which an element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Category : APIObject
Visual Basic (Declaration)
Public Class Category _
    Inherits APIObject
Visual C++
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Examples

CopyC#
Element selectedElement = null;
foreach (Element e in uidoc.Selection.Elements)
{
    selectedElement = e;
    break;  // just get one selected element
}

// Get the category instance from the Category property
Category category = selectedElement.Category;

BuiltInCategory enumCategory = (BuiltInCategory)category.Id.IntegerValue;

// Format the prompt string, which contains the category information
String prompt = "The category information of the selected element is: ";
prompt += "\n\tName:\t" + category.Name;   // Name information

prompt += "\n\tId:\t" + enumCategory.ToString();    // Id information
prompt += "\n\tParent:\t";
if (null == category.Parent)
{
    prompt += "No Parent Category";   // Parent information, it may be null
}
else
{
    prompt += category.Parent.Name;
}

prompt += "\n\tSubCategories:"; // SubCategories information,
CategoryNameMap subCategories = category.SubCategories;
if (null == subCategories || 0 == subCategories.Size) // It may be null or has no item in it
{
    prompt += "No SubCategories;";
}
else
{
    foreach (Category ii in subCategories)
    {
        prompt += "\n\t\t" + ii.Name;
    }
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
Dim selectedElement As Autodesk.Revit.DB.Element = Nothing
For Each e As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
    selectedElement = e
    ' just get one selected element
    Exit For
Next

' Get the category instance from the Category property
Dim category As Category = selectedElement.Category

Dim enumCategory As BuiltInCategory = DirectCast(category.Id.IntegerValue, BuiltInCategory)

' Format the prompt string, which contains the category information
Dim prompt As [String] = "The category information of the selected element is: "
prompt += vbLf & vbTab & "Name:" & vbTab + category.Name
' Name information
prompt += vbLf & vbTab & "Id:" & vbTab + enumCategory.ToString()
' Id information
prompt += vbLf & vbTab & "Parent:" & vbTab
If category.Parent Is Nothing Then
    ' Parent information, it may be null
    prompt += "No Parent Category"
Else
    prompt += category.Parent.Name
End If

prompt += vbLf & vbTab & "SubCategories:"
' SubCategories information,
Dim subCategories As CategoryNameMap = category.SubCategories
If subCategories Is Nothing OrElse 0 = subCategories.Size Then
    ' It may be null or has no item in it
    prompt += "No SubCategories;"
Else
    For Each ii As Category In subCategories
        prompt += vbLf & vbTab & vbTab + ii.Name
    Next
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Category

See Also

Category Members


Category Members

[image] [image]

Revit 2011 API
Category Members
Category Class Methods Properties See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLineWeight | Sets the line weight for the given graphics style type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowsBoundParameters | To check if the category can have project parameters.
AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
CanAddSubcategory | Indicates if subcategories can be assigned to the category.
HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Id | Returns the category id associated with the category object.
IsCuttable | Indicates if the category is cuttable or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LineColor | The color of lines shown for elements of this category.
Material | Retrieve or change the material of the category.
Name | The category name.
Parent | Returns the parent category of this category.
SubCategories | Returns a map containing all of the subcategories of this category.
Visible | Retrieve or change the visibility of the category in the active view.

See Also

Category Class


Category Methods

[image] [image]

Revit 2011 API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLineWeight | Sets the line weight for the given graphics style type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Category Class


GetGraphicsStyle Method

[image]

Revit 2011 API
Category..::.GetGraphicsStyle Method
Category Class See Also Send Feedback
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


GetHashCode Method

[image]

Revit 2011 API
Category..::.GetHashCode Method
Category Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Category Class


GetLineWeight Method

[image]

Revit 2011 API
Category..::.GetLineWeight Method
Category Class See Also Send Feedback
Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Function GetLineWeight ( _
    graphicsStyleType As GraphicsStyleType _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


SetLineWeight Method

[image]

Revit 2011 API
Category..::.SetLineWeight Method
Category Class See Also Send Feedback
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic (Declaration)
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::.Int32
graphicsStyleType
Type: Autodesk.Revit.DB..::.GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"lineWeigh" or "graphicsStyleType"-is out of range.

See Also

Category Class


Category Properties

[image] [image]

Revit 2011 API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

Name | Description
AllowsBoundParameters | To check if the category can have project parameters.
AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
CanAddSubcategory | Indicates if subcategories can be assigned to the category.
HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Id | Returns the category id associated with the category object.
IsCuttable | Indicates if the category is cuttable or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LineColor | The color of lines shown for elements of this category.
Material | Retrieve or change the material of the category.
Name | The category name.
Parent | Returns the parent category of this category.
SubCategories | Returns a map containing all of the subcategories of this category.
Visible | Retrieve or change the visibility of the category in the active view.

See Also

Category Class


AllowsBoundParameters Property

[image]

Revit 2011 API
Category..::.AllowsBoundParameters Property
Category Class See Also Send Feedback
To check if the category can have project parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AllowsBoundParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowsBoundParameters As Boolean
Visual C++
public:
property bool AllowsBoundParameters {
    bool get ();
}

See Also

Category Class


AllowsVisibilityControl Property

[image]

Revit 2011 API
Category..::.AllowsVisibilityControl Property
Category Class See Also Send Feedback
Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AllowsVisibilityControl[
    View view
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowsVisibilityControl ( _
    view As View _
) As Boolean
Visual C++
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view where visibility control might be allowed.

Remarks

There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).

See Also

Category Class


CanAddSubcategory Property

[image]

Revit 2011 API
Category..::.CanAddSubcategory Property
Category Class See Also Send Feedback
Indicates if subcategories can be assigned to the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanAddSubcategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanAddSubcategory As Boolean
Visual C++
public:
property bool CanAddSubcategory {
    bool get ();
}

See Also

Category Class


HasMaterialQuantities Property

[image]

Revit 2011 API
Category..::.HasMaterialQuantities Property
Category Class See Also Send Feedback
Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasMaterialQuantities { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMaterialQuantities As Boolean
Visual C++
public:
property bool HasMaterialQuantities {
    bool get ();
}

Remarks

Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.

See Also

Category Class


Id Property

[image]

Revit 2011 API
Category..::.Id Property
Category Class See Also Send Feedback
Returns the category id associated with the category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Category Class


IsCuttable Property

[image]

Revit 2011 API
Category..::.IsCuttable Property
Category Class See Also Send Feedback
Indicates if the category is cuttable or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCuttable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCuttable As Boolean
Visual C++
public:
property bool IsCuttable {
    bool get ();
}

See Also

Category Class


LineColor Property

[image]

Revit 2011 API
Category..::.LineColor Property
Category Class See Also Send Feedback
The color of lines shown for elements of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color LineColor { get; set; }
Visual Basic (Declaration)
Public Property LineColor As Color
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

Category Class


Material Property

[image]

Revit 2011 API
Category..::.Material Property
Category Class See Also Send Feedback
Retrieve or change the material of the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category does not have a material.

See Also

Category Class


Name Property

[image]

Revit 2011 API
Category..::.Name Property
Category Class See Also Send Feedback
The category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Category Class


Parent Property

[image]

Revit 2011 API
Category..::.Parent Property
Category Class See Also Send Feedback
Returns the parent category of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As Category
Visual C++
public:
property Category^ Parent {
    Category^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category a not a subcategory

See Also

Category Class


SubCategories Property

[image]

Revit 2011 API
Category..::.SubCategories Property
Category Class See Also Send Feedback
Returns a map containing all of the subcategories of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategoryNameMap SubCategories { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubCategories As CategoryNameMap
Visual C++
public:
property CategoryNameMap^ SubCategories {
    CategoryNameMap^ get ();
}

Return Value

An empty map if the category has no subcategories.

See Also

Category Class


Visible Property

[image]

Revit 2011 API
Category..::.Visible Property
Category Class See Also Send Feedback
Retrieve or change the visibility of the category in the active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Visible[
    View view
] { get; set; }
Visual Basic (Declaration)
Public Property Visible ( _
    view As View _
) As Boolean
Visual C++
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}

Parameters

view
Type: Autodesk.Revit.DB..::.View
Check if the category is visible in this view.

See Also

Category Class


CategoryNameMap Class

[image]

Revit 2011 API
CategoryNameMap Class
Members See Also Send Feedback
A map that contains a mapping of category name to its category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CategoryNameMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CategoryNameMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategoryNameMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CategoryNameMap
Autodesk.Revit.DB..::.Categories

See Also

CategoryNameMap Members


CategoryNameMap Members

[image] [image]

Revit 2011 API
CategoryNameMap Members
CategoryNameMap Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMap type exposes the following members.

Constructors

Name | Description
CategoryNameMap | Initializes a new instance of the CategoryNameMap class

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty.
Contains | Tests for the existence of a category with that name within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category with the specified name into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a category at a specified name within the map.
Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


CategoryNameMap Constructor

[image]

Revit 2011 API
CategoryNameMap Constructor
CategoryNameMap Class See Also Send Feedback
Initializes a new instance of the CategoryNameMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategoryNameMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMap()

See Also

CategoryNameMap Class


CategoryNameMap Methods

[image] [image]

Revit 2011 API
CategoryNameMap Methods
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Methods

Name | Description
Clear | Removes every category from the map, rendering it empty.
Contains | Tests for the existence of a category with that name within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a category with the specified name from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category with the specified name into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMap Class


Clear Method

[image]

Revit 2011 API
CategoryNameMap..::.Clear Method
CategoryNameMap Class See Also Send Feedback
Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategoryNameMap Class


Contains Method

[image]

Revit 2011 API
CategoryNameMap..::.Contains Method
CategoryNameMap Class See Also Send Feedback
Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The category name to be searched for.

Return Value

The Contains method returns True if the name is within the map, otherwise False.

See Also

CategoryNameMap Class


Erase Method

[image]

Revit 2011 API
CategoryNameMap..::.Erase Method
CategoryNameMap Class See Also Send Feedback
Removes a category with the specified name from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The name of the category to be erased.

Return Value

The number of categories that were erased from the map.

See Also

CategoryNameMap Class


ForwardIterator Method

[image]

Revit 2011 API
CategoryNameMap..::.ForwardIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class


GetEnumerator Method

[image]

Revit 2011 API
CategoryNameMap..::.GetEnumerator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategoryNameMap Class


Insert Method

[image]

Revit 2011 API
CategoryNameMap..::.Insert Method
CategoryNameMap Class See Also Send Feedback
Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
)

Parameters

key
Type: System..::.String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::.Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class


ReverseIterator Method

[image]

Revit 2011 API
CategoryNameMap..::.ReverseIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

CategoryNameMap Class


CategoryNameMap Properties

[image] [image]

Revit 2011 API
CategoryNameMap Properties
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a category at a specified name within the map.
Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


IsEmpty Property

[image]

Revit 2011 API
CategoryNameMap..::.IsEmpty Property
CategoryNameMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

CategoryNameMap Class


Item Property

[image]

Revit 2011 API
CategoryNameMap..::.Item Property
CategoryNameMap Class See Also Send Feedback
Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Category Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Category
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
Type: System..::.String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class


Size Property

[image]

Revit 2011 API
CategoryNameMap..::.Size Property
CategoryNameMap Class See Also Send Feedback
Returns the number of categories that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategoryNameMap Class


CategoryNameMapIterator Class

[image]

Revit 2011 API
CategoryNameMapIterator Class
Members See Also Send Feedback
An iterator to a category name map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CategoryNameMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CategoryNameMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CategoryNameMapIterator

See Also

CategoryNameMapIterator Members


CategoryNameMapIterator Members

[image] [image]

Revit 2011 API
CategoryNameMapIterator Members
CategoryNameMapIterator Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Constructors

Name | Description
CategoryNameMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the category that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Constructor

[image]

Revit 2011 API
CategoryNameMapIterator Constructor
CategoryNameMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategoryNameMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategoryNameMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Methods

[image] [image]

Revit 2011 API
CategoryNameMapIterator Methods
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMapIterator Class


MoveNext Method

[image]

Revit 2011 API
CategoryNameMapIterator..::.MoveNext Method
CategoryNameMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


Reset Method

[image]

Revit 2011 API
CategoryNameMapIterator..::.Reset Method
CategoryNameMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Properties

[image] [image]

Revit 2011 API
CategoryNameMapIterator Properties
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the category that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


Current Property

[image]

Revit 2011 API
CategoryNameMapIterator..::.Current Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


Key Property

[image]

Revit 2011 API
CategoryNameMapIterator..::.Key Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


CategorySet Class

[image]

Revit 2011 API
CategorySet Class
Members See Also Send Feedback
A set that can contains Category objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CategorySet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CategorySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategorySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CategorySet

See Also

CategorySet Members


CategorySet Members

[image] [image]

Revit 2011 API
CategorySet Members
CategorySet Class Constructors Methods Properties See Also Send Feedback

The CategorySet type exposes the following members.

Constructors

Name | Description
CategorySet | Initializes a new instance of the CategorySet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of a category within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified category from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


CategorySet Constructor

[image]

Revit 2011 API
CategorySet Constructor
CategorySet Class See Also Send Feedback
Initializes a new instance of the CategorySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategorySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySet()

See Also

CategorySet Class


CategorySet Methods

[image] [image]

Revit 2011 API
CategorySet Methods
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of a category within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified category from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified category into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySet Class


Clear Method

[image]

Revit 2011 API
CategorySet..::.Clear Method
CategorySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategorySet Class


Contains Method

[image]

Revit 2011 API
CategorySet..::.Contains Method
CategorySet Class See Also Send Feedback
Tests for the existence of a category within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Category
The category to be searched for.

Return Value

The Contains method returns True if the category is within the set, otherwise False.

See Also

CategorySet Class


Erase Method

[image]

Revit 2011 API
CategorySet..::.Erase Method
CategorySet Class See Also Send Feedback
Removes a specified category from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Category _
) As Integer
Visual C++
public:
virtual int Erase(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Category
The category to be erased.

Return Value

The number of items that were erased from the set.

See Also

CategorySet Class


ForwardIterator Method

[image]

Revit 2011 API
CategorySet..::.ForwardIterator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CategorySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class


GetEnumerator Method

[image]

Revit 2011 API
CategorySet..::.GetEnumerator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CategorySet Class


Insert Method

[image]

Revit 2011 API
CategorySet..::.Insert Method
CategorySet Class See Also Send Feedback
Insert the specified category into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Category item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Category
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

CategorySet Class


ReverseIterator Method

[image]

Revit 2011 API
CategorySet..::.ReverseIterator Method
CategorySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CategorySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CategorySet Class


CategorySet Properties

[image] [image]

Revit 2011 API
CategorySet Properties
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


IsEmpty Property

[image]

Revit 2011 API
CategorySet..::.IsEmpty Property
CategorySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CategorySet Class


Size Property

[image]

Revit 2011 API
CategorySet..::.Size Property
CategorySet Class See Also Send Feedback
Returns the number of categories that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategorySet Class


CategorySetIterator Class

[image]

Revit 2011 API
CategorySetIterator Class
Members See Also Send Feedback
An iterator to a category set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CategorySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CategorySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CategorySetIterator

See Also

CategorySetIterator Members


CategorySetIterator Members

[image] [image]

Revit 2011 API
CategorySetIterator Members
CategorySetIterator Class Constructors Methods Properties See Also Send Feedback

The CategorySetIterator type exposes the following members.

Constructors

Name | Description
CategorySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


CategorySetIterator Constructor

[image]

Revit 2011 API
CategorySetIterator Constructor
CategorySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategorySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CategorySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategorySetIterator Class


CategorySetIterator Methods

[image] [image]

Revit 2011 API
CategorySetIterator Methods
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySetIterator Class


MoveNext Method

[image]

Revit 2011 API
CategorySetIterator..::.MoveNext Method
CategorySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategorySetIterator Class


Reset Method

[image]

Revit 2011 API
CategorySetIterator..::.Reset Method
CategorySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategorySetIterator Class


CategorySetIterator Properties

[image] [image]

Revit 2011 API
CategorySetIterator Properties
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


Current Property

[image]

Revit 2011 API
CategorySetIterator..::.Current Property
CategorySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategorySetIterator Class


CeilingAndFloor Class

[image]

Revit 2011 API
CeilingAndFloor Class
Members See Also Send Feedback
A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CeilingAndFloor : HostObject
Visual Basic (Declaration)
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CeilingAndFloor

See Also

CeilingAndFloor Members


CeilingAndFloor Members

[image] [image]

Revit 2011 API
CeilingAndFloor Members
CeilingAndFloor Class Methods Properties See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CeilingAndFloor Class


CeilingAndFloor Methods

[image] [image]

Revit 2011 API
CeilingAndFloor Methods
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CeilingAndFloor Class


CeilingAndFloor Properties

[image] [image]

Revit 2011 API
CeilingAndFloor Properties
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CeilingAndFloor Class


Parameter Property

[image] [image]

Revit 2011 API
CeilingAndFloor..::.Parameter Property
CeilingAndFloor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CeilingAndFloor Class
CeilingAndFloor Members


CellType Enumeration

[image]

Revit 2011 API
CellType Enumeration
See Also Send Feedback
Declares the cell data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum CellType
Visual Basic (Declaration)
Public Enumeration CellType
Visual C++
public enum class CellType

Members

Member name | Description
Text | Simple text
Graphic | Embedded graphic
Parameter | Data bound parameter
Inherited | the type is inherited from the column or section if appropriate
CombinedParameter | the type is combined parameter
CalculatedValue | the type is a calculated value

See Also


ChangePriority Enumeration

[image]

Revit 2011 API
ChangePriority Enumeration
See Also Send Feedback
Enum used to specify the priority of an Updater during execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ChangePriority
Visual Basic (Declaration)
Public Enumeration ChangePriority
Visual C++
public enum class ChangePriority

Members

Member name | Description
GridsLevelsReferencePlanes | Updater will modify core datums and major reference planes
Masses | Updater will modify masses
FloorsRoofsStructuralWalls | Updater will modify exterior shell of the building or floor slabs
Structure | Updater will modify structural elements like beams, braces, columns and trusses
InteriorWalls | Updater will modify interior/partition walls
DoorsOpeningsWindows | Updater will modify family instances that cut their hosts like doors and windows
MEPFixtures | Updater will modify MEP fixtures such as lights, sinks, equipment, etc.
RoomsSpacesZones | Updater will modify Rooms, MEP spaces or zones
MEPCalculations | Updater will update MEP calculated values
FreeStandingComponents | Updater will modify standalone components
Connections | Updater will modify connections
Rebar | Updater will modify rebar
MEPAccessoriesFittingsSegmentsWires | Updater will modify MEP elements such as segments, fittings and wires
MEPSystems | Updater will modify MEP systems or circuits
Views | Updater will modify views
DetailComponents | Updater will modify detail components and symbolic lines
Annotations | Updater will modify annotations

Remarks

The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.

See Also


ChangeType Class

[image]

Revit 2011 API
ChangeType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ChangeType : IDisposable
Visual Basic (Declaration)
Public Class ChangeType _
    Implements IDisposable
Visual C++
public ref class ChangeType : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ChangeType

See Also

ChangeType Members


ChangeType Members

[image] [image]

Revit 2011 API
ChangeType Members
ChangeType Class Methods See Also Send Feedback

The ChangeType type exposes the following members.

Methods

Name | Description
ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Contains | Checks whether this ChangeType contains the input ChangeType
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsIdentical | Compares if two ChangeTypes are identical
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeType Class


ChangeType Methods

[image] [image]

Revit 2011 API
ChangeType Methods
ChangeType Class See Also Send Feedback

The ChangeType type exposes the following members.

Methods

Name | Description
ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Contains | Checks whether this ChangeType contains the input ChangeType
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsIdentical | Compares if two ChangeTypes are identical
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeType Class


ConcatenateChangeTypes Method

[image]

Revit 2011 API
ChangeType..::.ConcatenateChangeTypes Method
ChangeType Class See Also Send Feedback
Creates a ChangeType that is a union of the two input ChangeTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ChangeType ConcatenateChangeTypes(
    ChangeType changeType1,
    ChangeType changeType2
)
Visual Basic (Declaration)
Public Shared Function ConcatenateChangeTypes ( _
    changeType1 As ChangeType, _
    changeType2 As ChangeType _
) As ChangeType
Visual C++
public:
static ChangeType^ ConcatenateChangeTypes(
    ChangeType^ changeType1,
    ChangeType^ changeType2
)

Parameters

changeType1
Type: Autodesk.Revit.DB..::.ChangeType
First input ChangeType to be concatenated
changeType2
Type: Autodesk.Revit.DB..::.ChangeType
Second input ChangeType to be concatenated

Return Value

A new ChangeType that is a concatenation/union of the input change types

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


Contains Method

[image]

Revit 2011 API
ChangeType..::.Contains Method
ChangeType Class See Also Send Feedback
Checks whether this ChangeType contains the input ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Contains(
    ChangeType changeType
)
Visual Basic (Declaration)
Public Function Contains ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool Contains(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::.ChangeType

Return Value

True if input changeType is contained by this ChangeType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


Dispose Method

[image]

Revit 2011 API
ChangeType..::.Dispose Method
ChangeType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ChangeType Class


IsIdentical Method

[image]

Revit 2011 API
ChangeType..::.IsIdentical Method
ChangeType Class See Also Send Feedback
Compares if two ChangeTypes are identical

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsIdentical(
    ChangeType changeType
)
Visual Basic (Declaration)
Public Function IsIdentical ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool IsIdentical(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::.ChangeType
Input ChangeType to be compared

Return Value

True if the this ChangeType and input ChangeType are identical

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


City Class

[image]

Revit 2011 API
City Class
Members Example See Also Send Feedback
An object that contains geographical location information for a known city.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class City : APIObject
Visual Basic (Declaration)
Public Class City _
    Inherits APIObject
Visual C++
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Examples

CopyC#
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
CopyVB.NET
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As [String] = "Latitude:      " + latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As [String] = "Longitude:   " + longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As [String] = "TimeZone:   " + city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = latiudeInfo + vbLf + longitudeInfo + vbLf + timeZoneInfo

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.City

See Also

City Members


City Members

[image] [image]

Revit 2011 API
City Members
City Class Methods Properties See Also Send Feedback

The City type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | Latitude of the city
Longitude | Longitude of the city
Name | The name of the city
TimeZone | Time-zone in which the city resides
WeatherStation | An identifier for the nearest weather station

See Also

City Class


City Methods

[image] [image]

Revit 2011 API
City Methods
City Class See Also Send Feedback

The City type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

City Class


City Properties

[image] [image]

Revit 2011 API
City Properties
City Class See Also Send Feedback

The City type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Latitude | Latitude of the city
Longitude | Longitude of the city
Name | The name of the city
TimeZone | Time-zone in which the city resides
WeatherStation | An identifier for the nearest weather station

See Also

City Class


Latitude Property

[image]

Revit 2011 API
City..::.Latitude Property
City Class See Also Send Feedback
Latitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Latitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
}

Remarks

A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class


Longitude Property

[image]

Revit 2011 API
City..::.Longitude Property
City Class See Also Send Feedback
Longitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Longitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
}

Remarks

A read only property that contains the longitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class


Name Property

[image]

Revit 2011 API
City..::.Name Property
City Class See Also Send Feedback
The name of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

A read only string property that contains the name of the city, such as Boston.

See Also

City Class


TimeZone Property

[image]

Revit 2011 API
City..::.TimeZone Property
City Class See Also Send Feedback
Time-zone in which the city resides

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

City Class


WeatherStation Property

[image]

Revit 2011 API
City..::.WeatherStation Property
City Class See Also Send Feedback
An identifier for the nearest weather station

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string WeatherStation { get; }
Visual Basic (Declaration)
Public ReadOnly Property WeatherStation As String
Visual C++
public:
property String^ WeatherStation {
    String^ get ();
}

Remarks

A read only string property that contains an identifier of the nearest weather station.

See Also

City Class


CitySet Class

[image]

Revit 2011 API
CitySet Class
Members See Also Send Feedback
An set that contains cities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CitySet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class CitySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CitySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CitySet

See Also

CitySet Members


CitySet Members

[image] [image]

Revit 2011 API
CitySet Members
CitySet Class Constructors Methods Properties See Also Send Feedback

The CitySet type exposes the following members.

Constructors

Name | Description
CitySet | Initializes a new instance of the CitySet class

Methods

Name | Description
Clear | Removes every city from the set, rendering it empty.
Contains | Tests for the existence of a city within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified city from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified city into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of cities that are in the set.

See Also

CitySet Class


CitySet Constructor

[image]

Revit 2011 API
CitySet Constructor
CitySet Class See Also Send Feedback
Initializes a new instance of the CitySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CitySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySet()

See Also

CitySet Class


CitySet Methods

[image] [image]

Revit 2011 API
CitySet Methods
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Methods

Name | Description
Clear | Removes every city from the set, rendering it empty.
Contains | Tests for the existence of a city within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified city from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified city into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySet Class


Clear Method

[image]

Revit 2011 API
CitySet..::.Clear Method
CitySet Class See Also Send Feedback
Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CitySet Class


Contains Method

[image]

Revit 2011 API
CitySet..::.Contains Method
CitySet Class See Also Send Feedback
Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Contains(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.City
The city to be searched for.

Return Value

The Contains method returns True if the city is within the set, otherwise False.

See Also

CitySet Class


Erase Method

[image]

Revit 2011 API
CitySet..::.Erase Method
CitySet Class See Also Send Feedback
Removes a specified city from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As City _
) As Integer
Visual C++
public:
virtual int Erase(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.City
The city to be erased.

Return Value

The number of cities that were erased from the set.

See Also

CitySet Class


ForwardIterator Method

[image]

Revit 2011 API
CitySet..::.ForwardIterator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CitySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class


GetEnumerator Method

[image]

Revit 2011 API
CitySet..::.GetEnumerator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CitySet Class


Insert Method

[image]

Revit 2011 API
CitySet..::.Insert Method
CitySet Class See Also Send Feedback
Insert the specified city into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    City item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Insert(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.City
The city to be inserted into the set.

Return Value

Returns whether the city was inserted into the set.

See Also

CitySet Class


ReverseIterator Method

[image]

Revit 2011 API
CitySet..::.ReverseIterator Method
CitySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CitySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CitySet Class


CitySet Properties

[image] [image]

Revit 2011 API
CitySet Properties
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of cities that are in the set.

See Also

CitySet Class


IsEmpty Property

[image]

Revit 2011 API
CitySet..::.IsEmpty Property
CitySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CitySet Class


Size Property

[image]

Revit 2011 API
CitySet..::.Size Property
CitySet Class See Also Send Feedback
Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CitySet Class


CitySetIterator Class

[image]

Revit 2011 API
CitySetIterator Class
Members See Also Send Feedback
An iterator to a city set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CitySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CitySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CitySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CitySetIterator

See Also

CitySetIterator Members


CitySetIterator Members

[image] [image]

Revit 2011 API
CitySetIterator Members
CitySetIterator Class Constructors Methods Properties See Also Send Feedback

The CitySetIterator type exposes the following members.

Constructors

Name | Description
CitySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


CitySetIterator Constructor

[image]

Revit 2011 API
CitySetIterator Constructor
CitySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CitySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CitySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CitySetIterator Class


CitySetIterator Methods

[image] [image]

Revit 2011 API
CitySetIterator Methods
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySetIterator Class


MoveNext Method

[image]

Revit 2011 API
CitySetIterator..::.MoveNext Method
CitySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CitySetIterator Class


Reset Method

[image]

Revit 2011 API
CitySetIterator..::.Reset Method
CitySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class


CitySetIterator Properties

[image] [image]

Revit 2011 API
CitySetIterator Properties
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


Current Property

[image]

Revit 2011 API
CitySetIterator..::.Current Property
CitySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CitySetIterator Class


Color Class

[image]

Revit 2011 API
Color Class
Members See Also Send Feedback
Represents a color in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Color : APIObject
Visual Basic (Declaration)
Public Class Color _
    Inherits APIObject
Visual C++
public ref class Color : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Color

See Also

Color Members


Color Members

[image] [image]

Revit 2011 API
Color Members
Color Class Constructors Methods Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

Name | Description
Color | Constructor that takes the red, green and blue channels of the color.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Blue | Get or set the blue channel of the color.
Green | Get or set the green channel of the color.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Red | Get or set the red channel of the color.

See Also

Color Class


Color Constructor

[image]

Revit 2011 API
Color Constructor
Color Class See Also Send Feedback
Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color(
    byte red,
    byte green,
    byte blue
)
Visual Basic (Declaration)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

Parameters

red
Type: System..::.Byte
The red channel of the color that ranges from 0 to 255.
green
Type: System..::.Byte
The green channel of the color that ranges from 0 to 255.
blue
Type: System..::.Byte
The blue channel of the color that ranges from 0 to 255.

See Also

Color Class


Color Methods

[image] [image]

Revit 2011 API
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class


Color Properties

[image] [image]

Revit 2011 API
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

Name | Description
Blue | Get or set the blue channel of the color.
Green | Get or set the green channel of the color.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Red | Get or set the red channel of the color.

See Also

Color Class


Blue Property

[image]

Revit 2011 API
Color..::.Blue Property
Color Class See Also Send Feedback
Get or set the blue channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte Blue { get; set; }
Visual Basic (Declaration)
Public Property Blue As Byte
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the blue channel.

See Also

Color Class


Green Property

[image]

Revit 2011 API
Color..::.Green Property
Color Class See Also Send Feedback
Get or set the green channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte Green { get; set; }
Visual Basic (Declaration)
Public Property Green As Byte
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the green channel.

See Also

Color Class


Red Property

[image]

Revit 2011 API
Color..::.Red Property
Color Class See Also Send Feedback
Get or set the red channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public byte Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Remarks

If the color is read-only, InvalidOperationException will be thrown if trying to set the red channel.

See Also

Color Class


ColorDepthType Enumeration

[image]

Revit 2011 API
ColorDepthType Enumeration
See Also Send Feedback
An enumerated type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ColorDepthType
Visual Basic (Declaration)
Public Enumeration ColorDepthType
Visual C++
public enum class ColorDepthType

Members

Member name | Description
BlackLine | The type of Color Depth is Black Line.
GrayScale | The type of Color Depth is Gray Scale.
Color | The type of Color Depth is Color.

See Also


CombinableElement Class

[image]

Revit 2011 API
CombinableElement Class
Members See Also Send Feedback
An element that can be added to a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CombinableElement : Element
Visual Basic (Declaration)
Public Class CombinableElement _
    Inherits Element
Visual C++
public ref class CombinableElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.GeomCombination

See Also

CombinableElement Members


CombinableElement Members

[image] [image]

Revit 2011 API
CombinableElement Members
CombinableElement Class Methods Properties See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CombinableElement Class


CombinableElement Methods

[image] [image]

Revit 2011 API
CombinableElement Methods
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElement Class


CombinableElement Properties

[image] [image]

Revit 2011 API
CombinableElement Properties
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CombinableElement Class


Combinations Property

[image]

Revit 2011 API
CombinableElement..::.Combinations Property
CombinableElement Class See Also Send Feedback
The geometry combinations that this element belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeomCombinationSet Combinations { get; }
Visual Basic (Declaration)
Public ReadOnly Property Combinations As GeomCombinationSet
Visual C++
public:
property GeomCombinationSet^ Combinations {
    GeomCombinationSet^ get ();
}

Remarks

If this combinable element does not belong to any geometry combination, this value is an empty collection. A solid combinable element may belong to at most one combination, while a void combinable element may belong to multiple combinations.

See Also

CombinableElement Class


Parameter Property

[image] [image]

Revit 2011 API
CombinableElement..::.Parameter Property
CombinableElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CombinableElement Class
CombinableElement Members


CombinableElementArray Class

[image]

Revit 2011 API
CombinableElementArray Class
Members See Also Send Feedback
An array that contains CombinableElement objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CombinableElementArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CombinableElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CombinableElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CombinableElementArray

See Also

CombinableElementArray Members


CombinableElementArray Members

[image] [image]

Revit 2011 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArray type exposes the following members.

Constructors

Name | Description
CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every CombinableElement from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a CombinableElement at a specified index within the array.
Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class


CombinableElementArray Constructor

[image]

Revit 2011 API
CombinableElementArray Constructor
CombinableElementArray Class See Also Send Feedback
Initializes a new instance of the CombinableElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CombinableElementArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CombinableElementArray()

See Also

CombinableElementArray Class


CombinableElementArray Methods

[image] [image]

Revit 2011 API
CombinableElementArray Methods
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every CombinableElement from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArray Class


Append Method

[image]

Revit 2011 API
CombinableElementArray..::.Append Method
CombinableElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    CombinableElement item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CombinableElement _
)
Visual C++
public:
virtual void Append(
    CombinableElement^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CombinableElement
The CombinableElement to be added.

See Also

CombinableElementArray Class


Clear Method

[image]

Revit 2011 API
CombinableElementArray..::.Clear Method
CombinableElementArray Class See Also Send Feedback
Removes every CombinableElement from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CombinableElementArray Class


ForwardIterator Method

[image]

Revit 2011 API
CombinableElementArray..::.ForwardIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CombinableElementArray Class


GetEnumerator Method

[image]

Revit 2011 API
CombinableElementArray..::.GetEnumerator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CombinableElementArray Class


Insert Method

[image]

Revit 2011 API
CombinableElementArray..::.Insert Method
CombinableElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    CombinableElement item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CombinableElement, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CombinableElement^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.CombinableElement
The CombinableElement to be inserted into the array.
index
Type: System..::.Int32
The CombinableElement will be inserted before this index.

Return Value

Returns whether the CombinableElement was inserted into the array.

See Also

CombinableElementArray Class


ReverseIterator Method

[image]

Revit 2011 API
CombinableElementArray..::.ReverseIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CombinableElementArray Class


CombinableElementArray Properties

[image] [image]

Revit 2011 API
CombinableElementArray Properties
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a CombinableElement at a specified index within the array.
Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class


IsEmpty Property

[image]

Revit 2011 API
CombinableElementArray..::.IsEmpty Property
CombinableElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CombinableElementArray Class


Item Property

[image]

Revit 2011 API
CombinableElementArray..::.Item Property
CombinableElementArray Class See Also Send Feedback
Gets or sets a CombinableElement at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CombinableElement Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CombinableElement
Visual C++
public:
virtual property CombinableElement^ Item[int index] {
    CombinableElement^ get (int index);
    void set (int index, CombinableElement^ value);
}

Parameters

index
Type: System..::.Int32
The index of the CombinableElement to be set or retrieved.

Return Value

Returns the CombinableElement at the specified index.

See Also

CombinableElementArray Class


Size Property

[image]

Revit 2011 API
CombinableElementArray..::.Size Property
CombinableElementArray Class See Also Send Feedback
Returns the number of CombinableElements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CombinableElementArray Class


CombinableElementArrayIterator Class

[image]

Revit 2011 API
CombinableElementArrayIterator Class
Members See Also Send Feedback
An iterator to an CombinableElement array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CombinableElementArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CombinableElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CombinableElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CombinableElementArrayIterator

See Also

CombinableElementArrayIterator Members


CombinableElementArrayIterator Members

[image] [image]

Revit 2011 API
CombinableElementArrayIterator Members
CombinableElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Constructors

Name | Description
CombinableElementArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Constructor

[image]

Revit 2011 API
CombinableElementArrayIterator Constructor
CombinableElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CombinableElementArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CombinableElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Methods

[image] [image]

Revit 2011 API
CombinableElementArrayIterator Methods
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
CombinableElementArrayIterator..::.MoveNext Method
CombinableElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


Reset Method

[image]

Revit 2011 API
CombinableElementArrayIterator..::.Reset Method
CombinableElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Properties

[image] [image]

Revit 2011 API
CombinableElementArrayIterator Properties
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


Current Property

[image]

Revit 2011 API
CombinableElementArrayIterator..::.Current Property
CombinableElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


ComponentRotation Enumeration

[image]

Revit 2011 API
ComponentRotation Enumeration
See Also Send Feedback
ComponentRotation property of DividedSurface. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ComponentRotation
Visual Basic (Declaration)
Public Enumeration ComponentRotation
Visual C++
public enum class ComponentRotation

Members

Member name | Description
Angle0 |
Angle90 |
Angle180 |
Angle270 |

See Also


CompoundStructure Class

[image]

Revit 2011 API
CompoundStructure Class
Members See Also Send Feedback
An object that describes the multi layered construction of walls or floors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CompoundStructure : APIObject
Visual Basic (Declaration)
Public Class CompoundStructure _
    Inherits APIObject
Visual C++
public ref class CompoundStructure : public APIObject

Remarks

The CompoundStructure object exposes the layers of elements, such as walls. These layers can be of varying thickness and material, each of which has a dedicated function.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructure

See Also

CompoundStructure Members


CompoundStructure Members

[image] [image]

Revit 2011 API
CompoundStructure Members
CompoundStructure Class Methods Properties See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure Class


CompoundStructure Methods

[image] [image]

Revit 2011 API
CompoundStructure Methods
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructure Class


CompoundStructure Properties

[image] [image]

Revit 2011 API
CompoundStructure Properties
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layers | Returns the layers that make up the compound structure of the object.

See Also

CompoundStructure Class


Layers Property

[image]

Revit 2011 API
CompoundStructure..::.Layers Property
CompoundStructure Class See Also Send Feedback
Returns the layers that make up the compound structure of the object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureLayerArray Layers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layers As CompoundStructureLayerArray
Visual C++
public:
property CompoundStructureLayerArray^ Layers {
    CompoundStructureLayerArray^ get ();
}

Remarks

For walls, the layers are ordered from exterior to interior. For floors, the layers are ordered from top to bottom.

See Also

CompoundStructure Class


CompoundStructureDeckUsage Enumeration

[image]

Revit 2011 API
CompoundStructureDeckUsage Enumeration
See Also Send Feedback
Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CompoundStructureDeckUsage
Visual Basic (Declaration)
Public Enumeration CompoundStructureDeckUsage
Visual C++
public enum class CompoundStructureDeckUsage

Members

Member name | Description
Invalid | Invalid.
MergeWithLayerAbove | Deck is merged with the layer above.
Standalone | Deck is independent of other layers.
MergeWithLayerBelow | Deck is merged with the layer below.

See Also


CompoundStructureLayer Class

[image]

Revit 2011 API
CompoundStructureLayer Class
Members See Also Send Feedback
An object that describes a single layer of multi-layered object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CompoundStructureLayer : APIObject
Visual Basic (Declaration)
Public Class CompoundStructureLayer _
    Inherits APIObject
Visual C++
public ref class CompoundStructureLayer : public APIObject

Remarks

A wall or floor may have several layers. Each layer contains information about its thickness, intended purpose (function), and the material from which it is made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructureLayer

See Also

CompoundStructureLayer Members


CompoundStructureLayer Members

[image] [image]

Revit 2011 API
CompoundStructureLayer Members
CompoundStructureLayer Class Methods Properties See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeckProfile | Returns or sets the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or sets the variability of the layer's thickness.

See Also

CompoundStructureLayer Class


CompoundStructureLayer Methods

[image] [image]

Revit 2011 API
CompoundStructureLayer Methods
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayer Class


CompoundStructureLayer Properties

[image] [image]

Revit 2011 API
CompoundStructureLayer Properties
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Properties

Name | Description
DeckProfile | Returns or sets the family symbol of the deck profile of the layer within the structure.
DeckUsage | Returns usage of the deck layer within the structure.
Function | Returns the purpose/function of the layer within the structure.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Material | Get or set the material from which the layer is made.
Thickness | Retrieve or modify the thickness of the layer.
Variable | Returns or sets the variability of the layer's thickness.

See Also

CompoundStructureLayer Class


DeckProfile Property

[image]

Revit 2011 API
CompoundStructureLayer..::.DeckProfile Property
CompoundStructureLayer Class See Also Send Feedback
Returns or sets the family symbol of the deck profile of the layer within the structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol DeckProfile { get; set; }
Visual Basic (Declaration)
Public Property DeckProfile As FamilySymbol
Visual C++
public:
property FamilySymbol^ DeckProfile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

See Also

CompoundStructureLayer Class


DeckUsage Property

[image]

Revit 2011 API
CompoundStructureLayer..::.DeckUsage Property
CompoundStructureLayer Class See Also Send Feedback
Returns usage of the deck layer within the structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureDeckUsage DeckUsage { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeckUsage As CompoundStructureDeckUsage
Visual C++
public:
property CompoundStructureDeckUsage DeckUsage {
    CompoundStructureDeckUsage get ();
}

See Also

CompoundStructureLayer Class


Function Property

[image]

Revit 2011 API
CompoundStructureLayer..::.Function Property
CompoundStructureLayer Class See Also Send Feedback
Returns the purpose/function of the layer within the structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureLayerFunction Function { get; }
Visual Basic (Declaration)
Public ReadOnly Property Function As CompoundStructureLayerFunction
Visual C++
public:
property CompoundStructureLayerFunction Function {
    CompoundStructureLayerFunction get ();
}

See Also

CompoundStructureLayer Class


Material Property

[image]

Revit 2011 API
CompoundStructureLayer..::.Material Property
CompoundStructureLayer Class Example See Also Send Feedback
Get or set the material from which the layer is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Examples

CopyC#
public void GetWallLayerMaterial(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.CompoundStructure;
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.DB.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.Layers)
        {
            Autodesk.Revit.DB.Material layerMaterial = structLayer.Material;
            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case CompoundStructureLayerFunction.Finish1:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case CompoundStructureLayerFunction.Finish2:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case CompoundStructureLayerFunction.MembraneLayer:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case CompoundStructureLayerFunction.Structure:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case CompoundStructureLayerFunction.Substrate:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case CompoundStructureLayerFunction.ThermalOrAir:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            TaskDialog.Show("Revit","Layer Material: " + layerMaterial);
        }
    }
}
CopyVB.NET
Public Sub GetWallLayerMaterial(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    ' get WallType of wall
    Dim aWallType As Autodesk.Revit.DB.WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As Autodesk.Revit.DB.CompoundStructure = aWallType.CompoundStructure
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Autodesk.Revit.DB.Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.DB.Material = wallCategory.Material

        For Each structLayer As Autodesk.Revit.DB.CompoundStructureLayer In comStruct.Layers
            Dim layerMaterial As Autodesk.Revit.DB.Material = structLayer.Material
            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case CompoundStructureLayerFunction.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.MembraneLayer
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.ThermalOrAir
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            TaskDialog.Show("Revit", "Layer Material: " & layerMaterial.ToString())
        Next
    End If
End Sub

See Also

CompoundStructureLayer Class


Thickness Property

[image]

Revit 2011 API
CompoundStructureLayer..::.Thickness Property
CompoundStructureLayer Class See Also Send Feedback
Retrieve or modify the thickness of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Thickness { get; set; }
Visual Basic (Declaration)
Public Property Thickness As Double
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument thickness is invalid for the layer in set method.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument thickness is less than 0 in set method.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when set operation failed.

See Also

CompoundStructureLayer Class


Variable Property

[image]

Revit 2011 API
CompoundStructureLayer..::.Variable Property
CompoundStructureLayer Class See Also Send Feedback
Returns or sets the variability of the layer's thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Variable { get; set; }
Visual Basic (Declaration)
Public Property Variable As Boolean
Visual C++
public:
property bool Variable {
    bool get ();
    void set (bool value);
}

See Also

CompoundStructureLayer Class


CompoundStructureLayerArray Class

[image]

Revit 2011 API
CompoundStructureLayerArray Class
Members See Also Send Feedback
An array that contains layer objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CompoundStructureLayerArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CompoundStructureLayerArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CompoundStructureLayerArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructureLayerArray

See Also

CompoundStructureLayerArray Members


CompoundStructureLayerArray Members

[image] [image]

Revit 2011 API
CompoundStructureLayerArray Members
CompoundStructureLayerArray Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArray | Initializes a new instance of the CompoundStructureLayerArray class

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class


CompoundStructureLayerArray Constructor

[image]

Revit 2011 API
CompoundStructureLayerArray Constructor
CompoundStructureLayerArray Class See Also Send Feedback
Initializes a new instance of the CompoundStructureLayerArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureLayerArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArray()

See Also

CompoundStructureLayerArray Class


CompoundStructureLayerArray Methods

[image] [image]

Revit 2011 API
CompoundStructureLayerArray Methods
CompoundStructureLayerArray Class See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Methods

Name | Description
Append | Add the layer to the end of the array.
Clear | Removes every layer from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified layer into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayerArray Class


Append Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.Append Method
CompoundStructureLayerArray Class See Also Send Feedback
Add the layer to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    CompoundStructureLayer item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CompoundStructureLayer _
)
Visual C++
public:
virtual void Append(
    CompoundStructureLayer^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CompoundStructureLayer
The phase to be added.

See Also

CompoundStructureLayerArray Class


Clear Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.Clear Method
CompoundStructureLayerArray Class See Also Send Feedback
Removes every layer from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CompoundStructureLayerArray Class


ForwardIterator Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.ForwardIterator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CompoundStructureLayerArray Class


GetEnumerator Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.GetEnumerator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CompoundStructureLayerArray Class


Insert Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.Insert Method
CompoundStructureLayerArray Class See Also Send Feedback
Insert the specified layer into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    CompoundStructureLayer item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CompoundStructureLayer, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CompoundStructureLayer^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.CompoundStructureLayer
The layer to be inserted into the array.
index
Type: System..::.Int32
The layer will be inserted before this index.

Return Value

Returns whether the layer was inserted into the array.

See Also

CompoundStructureLayerArray Class


ReverseIterator Method

[image]

Revit 2011 API
CompoundStructureLayerArray..::.ReverseIterator Method
CompoundStructureLayerArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CompoundStructureLayerArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CompoundStructureLayerArrayIterator
Visual C++
public:
virtual CompoundStructureLayerArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CompoundStructureLayerArray Class


CompoundStructureLayerArray Properties

[image] [image]

Revit 2011 API
CompoundStructureLayerArray Properties
CompoundStructureLayerArray Class See Also Send Feedback

The CompoundStructureLayerArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a layer at a specified index within the array.
Size | Returns the number of layers that are in the array.

See Also

CompoundStructureLayerArray Class


IsEmpty Property

[image]

Revit 2011 API
CompoundStructureLayerArray..::.IsEmpty Property
CompoundStructureLayerArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CompoundStructureLayerArray Class


Item Property

[image]

Revit 2011 API
CompoundStructureLayerArray..::.Item Property
CompoundStructureLayerArray Class See Also Send Feedback
Gets or sets a layer at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CompoundStructureLayer Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CompoundStructureLayer
Visual C++
public:
virtual property CompoundStructureLayer^ Item[int index] {
    CompoundStructureLayer^ get (int index);
    void set (int index, CompoundStructureLayer^ value);
}

Parameters

index
Type: System..::.Int32
The index of the layer to be set or retrieved.

Return Value

Returns the layer at the specified index.

See Also

CompoundStructureLayerArray Class


Size Property

[image]

Revit 2011 API
CompoundStructureLayerArray..::.Size Property
CompoundStructureLayerArray Class See Also Send Feedback
Returns the number of layers that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CompoundStructureLayerArray Class


CompoundStructureLayerArrayIterator Class

[image]

Revit 2011 API
CompoundStructureLayerArrayIterator Class
Members See Also Send Feedback
An iterator to a layer array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CompoundStructureLayerArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CompoundStructureLayerArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CompoundStructureLayerArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CompoundStructureLayerArrayIterator

See Also

CompoundStructureLayerArrayIterator Members


CompoundStructureLayerArrayIterator Members

[image] [image]

Revit 2011 API
CompoundStructureLayerArrayIterator Members
CompoundStructureLayerArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Constructors

Name | Description
CompoundStructureLayerArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator Class


CompoundStructureLayerArrayIterator Constructor

[image]

Revit 2011 API
CompoundStructureLayerArrayIterator Constructor
CompoundStructureLayerArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructureLayerArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompoundStructureLayerArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CompoundStructureLayerArrayIterator Class


CompoundStructureLayerArrayIterator Methods

[image] [image]

Revit 2011 API
CompoundStructureLayerArrayIterator Methods
CompoundStructureLayerArrayIterator Class See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayerArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
CompoundStructureLayerArrayIterator..::.MoveNext Method
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class


Reset Method

[image]

Revit 2011 API
CompoundStructureLayerArrayIterator..::.Reset Method
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CompoundStructureLayerArrayIterator Class


CompoundStructureLayerArrayIterator Properties

[image] [image]

Revit 2011 API
CompoundStructureLayerArrayIterator Properties
CompoundStructureLayerArrayIterator Class See Also Send Feedback

The CompoundStructureLayerArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CompoundStructureLayerArrayIterator Class


Current Property

[image]

Revit 2011 API
CompoundStructureLayerArrayIterator..::.Current Property
CompoundStructureLayerArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CompoundStructureLayerArrayIterator Class


CompoundStructureLayerFunction Enumeration

[image]

Revit 2011 API
CompoundStructureLayerFunction Enumeration
See Also Send Feedback
Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CompoundStructureLayerFunction
Visual Basic (Declaration)
Public Enumeration CompoundStructureLayerFunction
Visual C++
public enum class CompoundStructureLayerFunction

Members

Member name | Description
Structure | A structural layer.
Substrate | A substrate layer.
ThermalOrAir | A thermal or air insulating layer.
Finish1 | A finish layer.
Finish2 | A finish layer.
MembraneLayer | A membrane layer.
StructuralDeck | A special layer considered to be structural decking.

See Also


ConicalFace Class

[image]

Revit 2011 API
ConicalFace Class
Members Example See Also Send Feedback
A cone face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConicalFace : Face
Visual Basic (Declaration)
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = conicalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As Autodesk.Revit.DB.XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.ConicalFace

See Also

ConicalFace Members


ConicalFace Members

[image] [image]

Revit 2011 API
ConicalFace Members
ConicalFace Class Methods Properties See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
HalfAngle | Half angle of the surface.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


ConicalFace Methods

[image] [image]

Revit 2011 API
ConicalFace Methods
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

ConicalFace Class


Intersect Method

[image] [image]

Revit 2011 API
ConicalFace..::.Intersect Method
ConicalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


IsInside Method

[image] [image]

Revit 2011 API
ConicalFace..::.IsInside Method
ConicalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


ConicalFace Properties

[image] [image]

Revit 2011 API
ConicalFace Properties
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
HalfAngle | Half angle of the surface.
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


Axis Property

[image]

Revit 2011 API
ConicalFace..::.Axis Property
ConicalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalFace Class


HalfAngle Property

[image]

Revit 2011 API
ConicalFace..::.HalfAngle Property
ConicalFace Class See Also Send Feedback
Half angle of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double HalfAngle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HalfAngle As Double
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalFace Class


Origin Property

[image]

Revit 2011 API
ConicalFace..::.Origin Property
ConicalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalFace Class


Radius Property

[image]

Revit 2011 API
ConicalFace..::.Radius Property
ConicalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ConicalFace Class


Connector Class

[image]

Revit 2011 API
Connector Class
Members Example See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Connector : APIObject, IConnector
Visual Basic (Declaration)
Public Class Connector _
    Inherits APIObject _
    Implements IConnector
Visual C++
public ref class Connector : public APIObject,
    IConnector

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment). This connector does not represent the connector element that can be created inside a family; for that element, refer to DuctConnector, PipeConnector and ElectricalConnector.

Examples

CopyC#
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.EndConn ||
                        connected.ConnectorType == ConnectorType.CurveConn ||
                        connected.ConnectorType == ConnectorType.PhysicalConn)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        TaskDialog.Show("Revit", message);
    }
}
CopyVB.NET
Public Sub GetElementAtConnector(ByVal connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.EndConn OrElse connected.ConnectorType = ConnectorType.CurveConn OrElse connected.ConnectorType = ConnectorType.PhysicalConn Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Connector

See Also

Connector Members


Connector Members

[image] [image]

Revit 2011 API
Connector Members
Connector Class Methods Properties See Also Send Feedback

The Connector type exposes the following members.

Methods

Name | Description
ConnectTo | Make connection between two connectors.
DisconnectFrom | Remove connection between two connectors.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsConnectedTo | Identifies if the connector is connected to the specified connector.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllRefs | All references of the connector.
Angle | The angle of the Connector.
AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
AssignedDuctLossMethod | The duct loss method of the connector.
AssignedFixtureUnits | The assigned fixture units of the connector.
AssignedFlow | The assigned flow of the connector.
AssignedFlowDirection | The assigned flow direction of the connector.
AssignedFlowFactor | The assigned flow factor of this connector.
AssignedKCoefficient | The assigned kCoefficient of the connector.
AssignedLossCoefficient | The assigned loss coefficient of the connector.
AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
AssignedPipeLossMethod | The pipe loss method of the connector.
AssignedPressureDrop | The assigned pressure drop of the connector.
Coefficient | The coefficient of the connector.
ConnectorManager | The connector manager of the connector.
ConnectorType | The connector type of the connector.
CoordinateSystem | The coordinate system of the connector.
Demand | The demand of the connector.
Direction | The direction of the connector.
Domain | The domain of the connector.
DuctSystemType | The duct system type of the connector.
ElectricalSystemType | The electrical system type of the connector.
Flow | The flow of the connector.
Height | The height of the connector.
IsConnected | Identifies if the connector is physically connected to a connector on another element.
IsMovable | whether the connector can be moved.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MEPSystem | The system of the connector belong to.
Origin | The location of the connector.
Owner | The host of the connector.
PipeSystemType | The pipe system type of the connector.
PressureDrop | The pressure drop of the connector.
Radius | The radius of the connector.
Shape | The shape of the connector.
VelocityPressure | The velocity pressure of the connector.
Width | The width of the connector.

See Also

Connector Class


Connector Methods

[image] [image]

Revit 2011 API
Connector Methods
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Methods

Name | Description
ConnectTo | Make connection between two connectors.
DisconnectFrom | Remove connection between two connectors.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsConnectedTo | Identifies if the connector is connected to the specified connector.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Connector Class


ConnectTo Method

[image]

Revit 2011 API
Connector..::.ConnectTo Method
Connector Class See Also Send Feedback
Make connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ConnectTo(
    Connector connector
)
Visual Basic (Declaration)
Public Sub ConnectTo ( _
    connector As Connector _
)
Visual C++
public:
void ConnectTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
Indicate the connector will be connected to.

Remarks

Connection success may create a new Fitting between two connectors, if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.

See Also

Connector Class


DisconnectFrom Method

[image]

Revit 2011 API
Connector..::.DisconnectFrom Method
Connector Class See Also Send Feedback
Remove connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DisconnectFrom(
    Connector connector
)
Visual Basic (Declaration)
Public Sub DisconnectFrom ( _
    connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector
Indicate the connector, connection will be removed from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also

Connector Class


IsConnectedTo Method

[image]

Revit 2011 API
Connector..::.IsConnectedTo Method
Connector Class See Also Send Feedback
Identifies if the connector is connected to the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsConnectedTo(
    Connector connector
)
Visual Basic (Declaration)
Public Function IsConnectedTo ( _
    connector As Connector _
) As Boolean
Visual C++
public:
bool IsConnectedTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::.Connector

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Connector Class


Connector Properties

[image] [image]

Revit 2011 API
Connector Properties
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Properties

Name | Description
AllRefs | All references of the connector.
Angle | The angle of the Connector.
AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
AssignedDuctLossMethod | The duct loss method of the connector.
AssignedFixtureUnits | The assigned fixture units of the connector.
AssignedFlow | The assigned flow of the connector.
AssignedFlowDirection | The assigned flow direction of the connector.
AssignedFlowFactor | The assigned flow factor of this connector.
AssignedKCoefficient | The assigned kCoefficient of the connector.
AssignedLossCoefficient | The assigned loss coefficient of the connector.
AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
AssignedPipeLossMethod | The pipe loss method of the connector.
AssignedPressureDrop | The assigned pressure drop of the connector.
Coefficient | The coefficient of the connector.
ConnectorManager | The connector manager of the connector.
ConnectorType | The connector type of the connector.
CoordinateSystem | The coordinate system of the connector.
Demand | The demand of the connector.
Direction | The direction of the connector.
Domain | The domain of the connector.
DuctSystemType | The duct system type of the connector.
ElectricalSystemType | The electrical system type of the connector.
Flow | The flow of the connector.
Height | The height of the connector.
IsConnected | Identifies if the connector is physically connected to a connector on another element.
IsMovable | whether the connector can be moved.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MEPSystem | The system of the connector belong to.
Origin | The location of the connector.
Owner | The host of the connector.
PipeSystemType | The pipe system type of the connector.
PressureDrop | The pressure drop of the connector.
Radius | The radius of the connector.
Shape | The shape of the connector.
VelocityPressure | The velocity pressure of the connector.
Width | The width of the connector.

See Also

Connector Class


AllRefs Property

[image]

Revit 2011 API
Connector..::.AllRefs Property
Connector Class See Also Send Feedback
All references of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorSet AllRefs { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllRefs As ConnectorSet
Visual C++
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}

Remarks

A set of connectors that the connectors is connected to, including both physical connection and logical connection.

See Also

Connector Class


Angle Property

[image]

Revit 2011 API
Connector..::.Angle Property
Connector Class See Also Send Feedback
The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some family instances, for more information, refer to PipeConnector or DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class


AssignedDuctFlowConfiguration Property

[image]

Revit 2011 API
Connector..::.AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class


AssignedDuctLossMethod Property

[image]

Revit 2011 API
Connector..::.AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class


AssignedFixtureUnits Property

[image]

Revit 2011 API
Connector..::.AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic (Declaration)
Public Property AssignedFixtureUnits As Double
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class


AssignedFlow Property

[image]

Revit 2011 API
Connector..::.AssignedFlow Property
Connector Class See Also Send Feedback
The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlow As Double
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some family instances, for more information, refer to PipeConnector, DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class


AssignedFlowDirection Property

[image]

Revit 2011 API
Connector..::.AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some family instances. For more information, seeDuctConnector, PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class


AssignedFlowFactor Property

[image]

Revit 2011 API
Connector..::.AssignedFlowFactor Property
Connector Class See Also Send Feedback
The assigned flow factor of this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedFlowFactor { get; set; }
Visual Basic (Declaration)
Public Property AssignedFlowFactor As Double
Visual C++
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}

Remarks

Assigned flow factor may be assigned for connectors of some family instances, for more information, refer to DuctConnector, PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.ArgumentException | Throw when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned flow factor.

See Also

Connector Class


AssignedKCoefficient Property

[image]

Revit 2011 API
Connector..::.AssignedKCoefficient Property
Connector Class See Also Send Feedback
The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedKCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedKCoefficient As Double
Visual C++
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned kCoefficient may be assigned for connectors of some family instances, for more information, refer to PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set kCoefficient.

See Also

Connector Class


AssignedLossCoefficient Property

[image]

Revit 2011 API
Connector..::.AssignedLossCoefficient Property
Connector Class See Also Send Feedback
The assigned loss coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedLossCoefficient { get; set; }
Visual Basic (Declaration)
Public Property AssignedLossCoefficient As Double
Visual C++
public:
property double AssignedLossCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned loss coefficient may be assigned for connectors of some family instances, for more information, refer to DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned loss coefficient.

See Also

Connector Class


AssignedPipeFlowConfiguration Property

[image]

Revit 2011 API
Connector..::.AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class


AssignedPipeLossMethod Property

[image]

Revit 2011 API
Connector..::.AssignedPipeLossMethod Property
Connector Class See Also Send Feedback
The pipe loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class


AssignedPressureDrop Property

[image]

Revit 2011 API
Connector..::.AssignedPressureDrop Property
Connector Class See Also Send Feedback
The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AssignedPressureDrop { get; set; }
Visual Basic (Declaration)
Public Property AssignedPressureDrop As Double
Visual C++
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}

Remarks

Assigned pressure drop may be assigned for connectors of some family instances, for more information, refer to PipeConnector, DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get or set assigned pressure drop.

See Also

Connector Class


Coefficient Property

[image]

Revit 2011 API
Connector..::.Coefficient Property
Connector Class See Also Send Feedback
The coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Coefficient { get; }
Visual Basic (Declaration)
Public ReadOnly Property Coefficient As Double
Visual C++
public:
property double Coefficient {
    double get ();
}

Remarks

Instantaneous coefficient of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


ConnectorManager Property

[image]

Revit 2011 API
Connector..::.ConnectorManager Property
Connector Class See Also Send Feedback
The connector manager of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get connector manager.

See Also

Connector Class


ConnectorType Property

[image]

Revit 2011 API
Connector..::.ConnectorType Property
Connector Class See Also Send Feedback
The connector type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorType ConnectorType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorType As ConnectorType
Visual C++
public:
property ConnectorType ConnectorType {
    ConnectorType get ();
}

See Also

Connector Class


CoordinateSystem Property

[image]

Revit 2011 API
Connector..::.CoordinateSystem Property
Connector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector is of logical type.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get coordinate system.

See Also

Connector Class


Demand Property

[image]

Revit 2011 API
Connector..::.Demand Property
Connector Class See Also Send Feedback
The demand of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Demand { get; }
Visual Basic (Declaration)
Public ReadOnly Property Demand As Double
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class


Direction Property

[image]

Revit 2011 API
Connector..::.Direction Property
Connector Class See Also Send Feedback
The direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As FlowDirectionType
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get direction.

See Also

Connector Class


Domain Property

[image]

Revit 2011 API
Connector..::.Domain Property
Connector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

See Also

Connector Class


DuctSystemType Property

[image]

Revit 2011 API
Connector..::.DuctSystemType Property
Connector Class See Also Send Feedback
The duct system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctSystemType As DuctSystemType
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class


ElectricalSystemType Property

[image]

Revit 2011 API
Connector..::.ElectricalSystemType Property
Connector Class See Also Send Feedback
The electrical system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemType ElectricalSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not of DomainElectrical.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get electrical system type.

See Also

Connector Class


Flow Property

[image]

Revit 2011 API
Connector..::.Flow Property
Connector Class See Also Send Feedback
The flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Remarks

Instantaneous flow at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac.

See Also

Connector Class


Height Property

[image]

Revit 2011 API
Connector..::.Height Property
Connector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Height

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set height.

See Also

Connector Class


IsConnected Property

[image]

Revit 2011 API
Connector..::.IsConnected Property
Connector Class See Also Send Feedback
Identifies if the connector is physically connected to a connector on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConnected As Boolean
Visual C++
public:
property bool IsConnected {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's type is LogicalConn.

See Also

Connector Class


IsMovable Property

[image]

Revit 2011 API
Connector..::.IsMovable Property
Connector Class See Also Send Feedback
whether the connector can be moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsMovable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMovable As Boolean
Visual C++
public:
property bool IsMovable {
    bool get ();
}

Remarks

Only connectors of type EndConn can be moved.

See Also

Connector Class


MEPSystem Property

[image]

Revit 2011 API
Connector..::.MEPSystem Property
Connector Class See Also Send Feedback
The system of the connector belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPSystem As MEPSystem
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get system.

See Also

Connector Class


Origin Property

[image]

Revit 2011 API
Connector..::.Origin Property
Connector Class See Also Send Feedback
The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Implements

IConnector..::.Origin

Remarks

Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the assigned origin is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set origin.

See Also

Connector Class


Owner Property

[image]

Revit 2011 API
Connector..::.Owner Property
Connector Class See Also Send Feedback
The host of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

The element that contains this connector. It may also contain other connectors.

See Also

Connector Class


PipeSystemType Property

[image]

Revit 2011 API
Connector..::.PipeSystemType Property
Connector Class See Also Send Feedback
The pipe system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeSystemType PipeSystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipeSystemType As PipeSystemType
Visual C++
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to get pipe system type.

See Also

Connector Class


PressureDrop Property

[image]

Revit 2011 API
Connector..::.PressureDrop Property
Connector Class See Also Send Feedback
The pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PressureDrop { get; }
Visual Basic (Declaration)
Public ReadOnly Property PressureDrop As Double
Visual C++
public:
property double PressureDrop {
    double get ();
}

Remarks

Instantaneous pressure drop of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


Radius Property

[image]

Revit 2011 API
Connector..::.Radius Property
Connector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Radius { get; set; }
Visual Basic (Declaration)
Public Overridable Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Radius

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not round.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set radius.

See Also

Connector Class


Shape Property

[image]

Revit 2011 API
Connector..::.Shape Property
Connector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

See Also

Connector Class


VelocityPressure Property

[image]

Revit 2011 API
Connector..::.VelocityPressure Property
Connector Class See Also Send Feedback
The velocity pressure of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double VelocityPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property VelocityPressure As Double
Visual C++
public:
property double VelocityPressure {
    double get ();
}

Remarks

Instantaneous velocity pressure of this connector,calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


Width Property

[image]

Revit 2011 API
Connector..::.Width Property
Connector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::.Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class


ConnectorElement Class

[image]

Revit 2011 API
ConnectorElement Class
Members See Also Send Feedback
A base class that provides support for all connector elements occurring in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConnectorElement : Element
Visual Basic (Declaration)
Public Class ConnectorElement _
    Inherits Element
Visual C++
public ref class ConnectorElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Electrical..::.ElectricalConnector
Autodesk.Revit.DB.Mechanical..::.DuctConnector
Autodesk.Revit.DB.Plumbing..::.PipeConnector

See Also

ConnectorElement Members


ConnectorElement Members

[image] [image]

Revit 2011 API
ConnectorElement Members
ConnectorElement Class Methods Properties See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConnectorElement Class


ConnectorElement Methods

[image] [image]

Revit 2011 API
ConnectorElement Methods
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorElement Class


ConnectorElement Properties

[image] [image]

Revit 2011 API
ConnectorElement Properties
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConnectorElement Class


Parameter Property

[image] [image]

Revit 2011 API
ConnectorElement..::.Parameter Property
ConnectorElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ConnectorElement Class
ConnectorElement Members


ConnectorManager Class

[image]

Revit 2011 API
ConnectorManager Class
Members See Also Send Feedback
Provides access to the Connector Manager in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConnectorManager : APIObject
Visual Basic (Declaration)
Public Class ConnectorManager _
    Inherits APIObject
Visual C++
public ref class ConnectorManager : public APIObject

Remarks

The Connector Manager object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ConnectorManager

See Also

ConnectorManager Members


ConnectorManager Members

[image] [image]

Revit 2011 API
ConnectorManager Members
ConnectorManager Class Methods Properties See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connectors | Return all the Connectors of the Connector Manager.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Owner | Return the owner of the Connector Manager.
UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


ConnectorManager Methods

[image] [image]

Revit 2011 API
ConnectorManager Methods
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorManager Class


ConnectorManager Properties

[image] [image]

Revit 2011 API
ConnectorManager Properties
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Properties

Name | Description
Connectors | Return all the Connectors of the Connector Manager.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Owner | Return the owner of the Connector Manager.
UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


Connectors Property

[image]

Revit 2011 API
ConnectorManager..::.Connectors Property
ConnectorManager Class See Also Send Feedback
Return all the Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorSet Connectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ Connectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the Connectors from the Connector Manager.

See Also

ConnectorManager Class


Owner Property

[image]

Revit 2011 API
ConnectorManager..::.Owner Property
ConnectorManager Class See Also Send Feedback
Return the owner of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As Element
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

This property is used to retrieve the owner of the Connector Manager.

See Also

ConnectorManager Class


UnusedConnectors Property

[image]

Revit 2011 API
ConnectorManager..::.UnusedConnectors Property
ConnectorManager Class See Also Send Feedback
Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorSet UnusedConnectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnusedConnectors As ConnectorSet
Visual C++
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the unused Connectors from the Connector Manager.

See Also

ConnectorManager Class


ConnectorProfileType Enumeration

[image]

Revit 2011 API
ConnectorProfileType Enumeration
See Also Send Feedback
An enumerated type listing all the connector profile types for a connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConnectorProfileType
Visual Basic (Declaration)
Public Enumeration ConnectorProfileType
Visual C++
public enum class ConnectorProfileType

Members

Member name | Description
InvalidProfile | Connection Profile Type is Invalid.
RoundProfile | Connection Profile Type is Round.
RectProfile | Connection Profile Type is Rect.
OvalProfile | Connection Profile Type is Oval.

See Also


ConnectorSet Class

[image]

Revit 2011 API
ConnectorSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConnectorSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ConnectorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ConnectorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ConnectorSet

See Also

ConnectorSet Members


ConnectorSet Members

[image] [image]

Revit 2011 API
ConnectorSet Members
ConnectorSet Class Constructors Methods Properties See Also Send Feedback

The ConnectorSet type exposes the following members.

Constructors

Name | Description
ConnectorSet | Initializes a new instance of the ConnectorSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


ConnectorSet Constructor

[image]

Revit 2011 API
ConnectorSet Constructor
ConnectorSet Class See Also Send Feedback
Initializes a new instance of the ConnectorSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSet()

See Also

ConnectorSet Class


ConnectorSet Methods

[image] [image]

Revit 2011 API
ConnectorSet Methods
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSet Class


Clear Method

[image]

Revit 2011 API
ConnectorSet..::.Clear Method
ConnectorSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ConnectorSet Class


Contains Method

[image]

Revit 2011 API
ConnectorSet..::.Contains Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Connector

See Also

ConnectorSet Class


Erase Method

[image]

Revit 2011 API
ConnectorSet..::.Erase Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Connector _
) As Integer
Visual C++
public:
virtual int Erase(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Connector

See Also

ConnectorSet Class


ForwardIterator Method

[image]

Revit 2011 API
ConnectorSet..::.ForwardIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class


GetEnumerator Method

[image]

Revit 2011 API
ConnectorSet..::.GetEnumerator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ConnectorSet Class


Insert Method

[image]

Revit 2011 API
ConnectorSet..::.Insert Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Connector item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Connector

See Also

ConnectorSet Class


ReverseIterator Method

[image]

Revit 2011 API
ConnectorSet..::.ReverseIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ConnectorSet Class


ConnectorSet Properties

[image] [image]

Revit 2011 API
ConnectorSet Properties
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


IsEmpty Property

[image]

Revit 2011 API
ConnectorSet..::.IsEmpty Property
ConnectorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConnectorSet Class


Size Property

[image]

Revit 2011 API
ConnectorSet..::.Size Property
ConnectorSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConnectorSet Class


ConnectorSetIterator Class

[image]

Revit 2011 API
ConnectorSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ConnectorSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ConnectorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ConnectorSetIterator

See Also

ConnectorSetIterator Members


ConnectorSetIterator Members

[image] [image]

Revit 2011 API
ConnectorSetIterator Members
ConnectorSetIterator Class Constructors Methods Properties See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Constructors

Name | Description
ConnectorSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


ConnectorSetIterator Constructor

[image]

Revit 2011 API
ConnectorSetIterator Constructor
ConnectorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConnectorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConnectorSetIterator Class


ConnectorSetIterator Methods

[image] [image]

Revit 2011 API
ConnectorSetIterator Methods
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ConnectorSetIterator..::.MoveNext Method
ConnectorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


Reset Method

[image]

Revit 2011 API
ConnectorSetIterator..::.Reset Method
ConnectorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConnectorSetIterator Class


ConnectorSetIterator Properties

[image] [image]

Revit 2011 API
ConnectorSetIterator Properties
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


Current Property

[image]

Revit 2011 API
ConnectorSetIterator..::.Current Property
ConnectorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


ConnectorType Enumeration

[image]

Revit 2011 API
ConnectorType Enumeration
See Also Send Feedback
An enumerated type listing all the connector types for a connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic (Declaration)
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
InvalidConnectorType | Connection Type is Invalid.
EndConn | Connection Type is End Connection.
CurveConn | Connection Type is Curve Connection.
LogicalConn | Connection Type is Logical Connection.
PhysicalConn | Connection Type is Physical Connection.
NonEndConn | Connection Type is Non End Connection.
AllConnectorModes | Connection Type is All Connector Modes.

See Also


Construction Class

[image]

Revit 2011 API
Construction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Construction
Visual Basic (Declaration)
Public Class Construction
Visual C++
public ref class Construction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Construction

See Also

Construction Members


Construction Members

[image] [image]

Revit 2011 API
Construction Members
Construction Class Methods Properties See Also Send Feedback

The Construction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | Get the id of the Construction.
Name | Get the name of the Construction.

See Also

Construction Class


Construction Methods

[image] [image]

Revit 2011 API
Construction Methods
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Construction Class


Construction Properties

[image] [image]

Revit 2011 API
Construction Properties
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Properties

Name | Description
Id | Get the id of the Construction.
Name | Get the name of the Construction.

See Also

Construction Class


Id Property

[image]

Revit 2011 API
Construction..::.Id Property
Construction Class See Also Send Feedback
Get the id of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This property is used to get the id of the Construction.

See Also

Construction Class


Name Property

[image]

Revit 2011 API
Construction..::.Name Property
Construction Class See Also Send Feedback
Get the name of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This property is used to get the name of the Construction.

See Also

Construction Class


ConstructionType Enumeration

[image]

Revit 2011 API
ConstructionType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")]
public enum ConstructionType
Visual Basic (Declaration)
<ObsoleteAttribute("Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")> _
Public Enumeration ConstructionType
Visual C++
[ObsoleteAttribute(L"Use Autodesk.Revit.DB.Analysis.ConstructionType instead.")]
public enum class ConstructionType

Members

Member name | Description
ExteriorWalls | Construction Type is ExteriorWalls.
InteriorWalls | Construction Type is InteriorWalls.
Slabs | Construction Type is Slabs.
Roofs | Construction Type is Roofs.
Floors | Construction Type is Floors.
Doors | Construction Type is Doors.
ExteriorWindows | Construction Type is ExteriorWindows.
InteriorWindows | Construction Type is InteriorWindows.
Skylights | Construction Type is Skylights.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also


ContFooting Class

[image]

Revit 2011 API
ContFooting Class
Members Example See Also Send Feedback
An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ContFooting : HostObject
Visual Basic (Declaration)
Public Class ContFooting _
    Inherits HostObject
Visual C++
public ref class ContFooting : public HostObject

Examples

CopyC#
public void GetInfo_ContFooting(ContFooting contFooting)
{
    string message = "Wall Foundation : ";

    // Get Analytical model
    if (null != contFooting.GetAnalyticalModel())
    {
        message += "\nAnalytical model : " + contFooting.GetAnalyticalModel();
    }

    // Get Footing type name
    message += "\nFooting type name is : " + contFooting.FootingType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_ContFooting(ByVal contFooting As Autodesk.Revit.DB.ContFooting)
    Dim message As String = "Wall Foundation : "

    ' Get Analytical model
    If contFooting.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "Analytical model : " & contFooting.GetAnalyticalModel().ToString()
    End If

    ' Get Footing type name
    message += vbLf & "Footing type name is : " + contFooting.FootingType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.ContFooting

See Also

ContFooting Members


ContFooting Members

[image] [image]

Revit 2011 API
ContFooting Members
ContFooting Class Methods Properties See Also Send Feedback

The ContFooting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FootingType | Retrieves an object that represents the type of the footing.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ContFooting Class


ContFooting Methods

[image] [image]

Revit 2011 API
ContFooting Methods
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFooting Class


ContFooting Properties

[image] [image]

Revit 2011 API
ContFooting Properties
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FootingType | Retrieves an object that represents the type of the footing.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ContFooting Class


FootingType Property

[image]

Revit 2011 API
ContFooting..::.FootingType Property
ContFooting Class See Also Send Feedback
Retrieves an object that represents the type of the footing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ContFootingType FootingType { get; set; }
Visual Basic (Declaration)
Public Property FootingType As ContFootingType
Visual C++
public:
property ContFootingType^ FootingType {
    ContFootingType^ get ();
    void set (ContFootingType^ value);
}

Remarks

The footing type can be used to access the multi layered structure of a footing.

See Also

ContFooting Class


Parameter Property

[image] [image]

Revit 2011 API
ContFooting..::.Parameter Property
ContFooting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ContFooting Class
ContFooting Members


ContFootingType Class

[image]

Revit 2011 API
ContFootingType Class
Members See Also Send Feedback
An object that specifies the type of a continuous footing in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ContFootingType : HostObjAttributes
Visual Basic (Declaration)
Public Class ContFootingType _
    Inherits HostObjAttributes
Visual C++
public ref class ContFootingType : public HostObjAttributes

Remarks

The structural layers of the continuous footing can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.ContFootingType

See Also

ContFootingType Members


ContFootingType Members

[image] [image]

Revit 2011 API
ContFootingType Members
ContFootingType Class Methods Properties See Also Send Feedback

The ContFootingType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ContFootingType Class


ContFootingType Methods

[image] [image]

Revit 2011 API
ContFootingType Methods
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingType Class


ContFootingType Properties

[image] [image]

Revit 2011 API
ContFootingType Properties
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ContFootingType Class


Parameter Property

[image] [image]

Revit 2011 API
ContFootingType..::.Parameter Property
ContFootingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ContFootingType Class
ContFootingType Members


ContFootingTypeSet Class

[image]

Revit 2011 API
ContFootingTypeSet Class
Members See Also Send Feedback
A set that contains ContFooting types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ContFootingTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ContFootingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ContFootingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ContFootingTypeSet

See Also

ContFootingTypeSet Members


ContFootingTypeSet Members

[image] [image]

Revit 2011 API
ContFootingTypeSet Members
ContFootingTypeSet Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Constructors

Name | Description
ContFootingTypeSet | Initializes a new instance of the ContFootingTypeSet class

Methods

Name | Description
Clear | Removes every ContFooting type from the set, rendering it empty.
Contains | Tests for the existence of a ContFooting type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified ContFooting type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified ContFooting type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class


ContFootingTypeSet Constructor

[image]

Revit 2011 API
ContFootingTypeSet Constructor
ContFootingTypeSet Class See Also Send Feedback
Initializes a new instance of the ContFootingTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ContFootingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSet()

See Also

ContFootingTypeSet Class


ContFootingTypeSet Methods

[image] [image]

Revit 2011 API
ContFootingTypeSet Methods
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every ContFooting type from the set, rendering it empty.
Contains | Tests for the existence of a ContFooting type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified ContFooting type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified ContFooting type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSet Class


Clear Method

[image]

Revit 2011 API
ContFootingTypeSet..::.Clear Method
ContFootingTypeSet Class See Also Send Feedback
Removes every ContFooting type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ContFootingTypeSet Class


Contains Method

[image]

Revit 2011 API
ContFootingTypeSet..::.Contains Method
ContFootingTypeSet Class See Also Send Feedback
Tests for the existence of a ContFooting type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ContFootingType
The ContFooting type to be searched for.

Return Value

The Contains method returns True if the ContFooting type is within the set, otherwise False.

See Also

ContFootingTypeSet Class


Erase Method

[image]

Revit 2011 API
ContFootingTypeSet..::.Erase Method
ContFootingTypeSet Class See Also Send Feedback
Removes a specified ContFooting type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ContFootingType _
) As Integer
Visual C++
public:
virtual int Erase(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ContFootingType
The ContFooting type to be erased.

Return Value

The number of ContFooting types that were erased from the set.

See Also

ContFootingTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
ContFootingTypeSet..::.ForwardIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ContFootingTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
ContFootingTypeSet..::.GetEnumerator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ContFootingTypeSet Class


Insert Method

[image]

Revit 2011 API
ContFootingTypeSet..::.Insert Method
ContFootingTypeSet Class See Also Send Feedback
Insert the specified ContFooting type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    ContFootingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ContFootingType
The ContFooting type to be inserted into the set.

Return Value

Returns whether the ContFooting type was inserted into the set.

See Also

ContFootingTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
ContFootingTypeSet..::.ReverseIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ContFootingTypeSet Class


ContFootingTypeSet Properties

[image] [image]

Revit 2011 API
ContFootingTypeSet Properties
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
ContFootingTypeSet..::.IsEmpty Property
ContFootingTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ContFootingTypeSet Class


Size Property

[image]

Revit 2011 API
ContFootingTypeSet..::.Size Property
ContFootingTypeSet Class See Also Send Feedback
Returns the number of ContFooting types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ContFootingTypeSet Class


ContFootingTypeSetIterator Class

[image]

Revit 2011 API
ContFootingTypeSetIterator Class
Members See Also Send Feedback
An iterator to a ContFooting type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ContFootingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ContFootingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ContFootingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ContFootingTypeSetIterator

See Also

ContFootingTypeSetIterator Members


ContFootingTypeSetIterator Members

[image] [image]

Revit 2011 API
ContFootingTypeSetIterator Members
ContFootingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Constructors

Name | Description
ContFootingTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Constructor

[image]

Revit 2011 API
ContFootingTypeSetIterator Constructor
ContFootingTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ContFootingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContFootingTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Methods

[image] [image]

Revit 2011 API
ContFootingTypeSetIterator Methods
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ContFootingTypeSetIterator..::.MoveNext Method
ContFootingTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
ContFootingTypeSetIterator..::.Reset Method
ContFootingTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Properties

[image] [image]

Revit 2011 API
ContFootingTypeSetIterator Properties
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class


Current Property

[image]

Revit 2011 API
ContFootingTypeSetIterator..::.Current Property
ContFootingTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class


Control Class

[image]

Revit 2011 API
Control Class
Members See Also Send Feedback
A control in Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Control : Element
Visual Basic (Declaration)
Public Class Control _
    Inherits Element
Visual C++
public ref class Control : public Element

Remarks

The object represents a variety of different shapes of controls in family document. The different shapes of controls can handle the family instance in different ways.
  • A vertical/horizontal arrow control rotates the instance by 180 degrees.
  • A double vertical arrow control mirrors the instance geometry vertically.
  • A double horizontal arrow control mirrors the instance geometry horizontally.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Control

See Also

Control Members


Control Members

[image] [image]

Revit 2011 API
Control Members
Control Class Methods Properties See Also Send Feedback

The Control type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The control origin.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Shape | The control shape.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Control Class


Control Methods

[image] [image]

Revit 2011 API
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Control Class


Control Properties

[image] [image]

Revit 2011 API
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The control origin.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Shape | The control shape.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Control Class


Origin Property

[image]

Revit 2011 API
Control..::.Origin Property
Control Class See Also Send Feedback
The control origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Control Class


Parameter Property

[image] [image]

Revit 2011 API
Control..::.Parameter Property
Control Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Control Class
Control Members


Shape Property

[image]

Revit 2011 API
Control..::.Shape Property
Control Class See Also Send Feedback
The control shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ControlShape Shape { get; }
Visual Basic (Declaration)
Public ReadOnly Property Shape As ControlShape
Visual C++
public:
property ControlShape Shape {
    ControlShape get ();
}

See Also

Control Class


View Property

[image]

Revit 2011 API
Control..::.View Property
Control Class See Also Send Feedback
The view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Control Class


ControlShape Enumeration

[image]

Revit 2011 API
ControlShape Enumeration
See Also Send Feedback
An enumerated type listing four shapes of control that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ControlShape
Visual Basic (Declaration)
Public Enumeration ControlShape
Visual C++
public enum class ControlShape

Members

Member name | Description
VerticalArrow | Vertical arrow.
HorizontalArrow | Horizontal arrow.
DoubleVerticalArrow | Double vertical arrow.
DoubleHorizontalArrow | Double horizontal arrow.

See Also


CoordinatePlaneVisibility Enumeration

[image]

Revit 2011 API
CoordinatePlaneVisibility Enumeration
See Also Send Feedback
Visibility settings for ReferencePoint element's coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CoordinatePlaneVisibility
Visual Basic (Declaration)
Public Enumeration CoordinatePlaneVisibility
Visual C++
public enum class CoordinatePlaneVisibility

Members

Member name | Description
Never |
WhenSelected |
Always |

See Also


CurtainCell Class

[image]

Revit 2011 API
CurtainCell Class
Members See Also Send Feedback
Represents a CurtainCell within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainCell : APIObject
Visual Basic (Declaration)
Public Class CurtainCell _
    Inherits APIObject
Visual C++
public ref class CurtainCell : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainCell

See Also

CurtainCell Members


CurtainCell Members

[image] [image]

Revit 2011 API
CurtainCell Members
CurtainCell Class Methods Properties See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


CurtainCell Methods

[image] [image]

Revit 2011 API
CurtainCell Methods
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCell Class


CurtainCell Properties

[image] [image]

Revit 2011 API
CurtainCell Properties
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Properties

Name | Description
CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


CurveLoops Property

[image]

Revit 2011 API
CurtainCell..::.CurveLoops Property
CurtainCell Class See Also Send Feedback
The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray CurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ CurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class


PlanarizedCurveLoops Property

[image]

Revit 2011 API
CurtainCell..::.PlanarizedCurveLoops Property
CurtainCell Class See Also Send Feedback
The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray PlanarizedCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class


CurtainCellSet Class

[image]

Revit 2011 API
CurtainCellSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainCellSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainCellSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainCellSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainCellSet

See Also

CurtainCellSet Members


CurtainCellSet Members

[image] [image]

Revit 2011 API
CurtainCellSet Members
CurtainCellSet Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSet type exposes the following members.

Constructors

Name | Description
CurtainCellSet | Initializes a new instance of the CurtainCellSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

CurtainCellSet Class


CurtainCellSet Constructor

[image]

Revit 2011 API
CurtainCellSet Constructor
CurtainCellSet Class See Also Send Feedback
Initializes a new instance of the CurtainCellSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainCellSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSet()

See Also

CurtainCellSet Class


CurtainCellSet Methods

[image] [image]

Revit 2011 API
CurtainCellSet Methods
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSet Class


Clear Method

[image]

Revit 2011 API
CurtainCellSet..::.Clear Method
CurtainCellSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainCellSet Class


Contains Method

[image]

Revit 2011 API
CurtainCellSet..::.Contains Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainCell

See Also

CurtainCellSet Class


Erase Method

[image]

Revit 2011 API
CurtainCellSet..::.Erase Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainCell _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainCell

See Also

CurtainCellSet Class


ForwardIterator Method

[image]

Revit 2011 API
CurtainCellSet..::.ForwardIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainCellSet Class


GetEnumerator Method

[image]

Revit 2011 API
CurtainCellSet..::.GetEnumerator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainCellSet Class


Insert Method

[image]

Revit 2011 API
CurtainCellSet..::.Insert Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainCell item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainCell

See Also

CurtainCellSet Class


ReverseIterator Method

[image]

Revit 2011 API
CurtainCellSet..::.ReverseIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainCellSet Class


CurtainCellSet Properties

[image] [image]

Revit 2011 API
CurtainCellSet Properties
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

CurtainCellSet Class


IsEmpty Property

[image]

Revit 2011 API
CurtainCellSet..::.IsEmpty Property
CurtainCellSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainCellSet Class


Size Property

[image]

Revit 2011 API
CurtainCellSet..::.Size Property
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainCellSet Class


CurtainCellSetIterator Class

[image]

Revit 2011 API
CurtainCellSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurtainCellSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainCellSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainCellSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainCellSetIterator

See Also

CurtainCellSetIterator Members


CurtainCellSetIterator Members

[image] [image]

Revit 2011 API
CurtainCellSetIterator Members
CurtainCellSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Constructors

Name | Description
CurtainCellSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Constructor

[image]

Revit 2011 API
CurtainCellSetIterator Constructor
CurtainCellSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainCellSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainCellSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Methods

[image] [image]

Revit 2011 API
CurtainCellSetIterator Methods
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSetIterator Class


MoveNext Method

[image]

Revit 2011 API
CurtainCellSetIterator..::.MoveNext Method
CurtainCellSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class


Reset Method

[image]

Revit 2011 API
CurtainCellSetIterator..::.Reset Method
CurtainCellSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Properties

[image] [image]

Revit 2011 API
CurtainCellSetIterator Properties
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class


Current Property

[image]

Revit 2011 API
CurtainCellSetIterator..::.Current Property
CurtainCellSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class


CurtainGrid Class

[image]

Revit 2011 API
CurtainGrid Class
Members See Also Send Feedback
Represents a curtain grid element within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainGrid : APIObject
Visual Basic (Declaration)
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
public ref class CurtainGrid : public APIObject

Remarks

This element is obtained from a curtain wall,curtain system or curtain roof. A curtain wall has only one curtain grid, while a curtain system or curtain roof may have several curtain grids.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainGrid

See Also

CurtainGrid Members


CurtainGrid Members

[image] [image]

Revit 2011 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

Name | Description
AddGridLine | Add a grid line to the curtain grid.
ChangePanelType | Change the type of a curtain panel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCell | Get the specified cell located by the intersection of the grid lines.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPanel | Get the specified panel located by the intersection of the grid lines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cells | Get all the cells owned by this curtain grid.
Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Grid2Angle | The angle for V grid line pattern of the curtain grid.
Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Grid2Offset | The offset for V grid line pattern of the curtain grid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Mullions | Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
NumPanels | The number of panels.
NumULines | Get the number of grid lines in the U direction.
NumVLines | Get the number of grid lines in the V direction.
Panels | All the panels of the curtain grid.
UGridLines | All grid lines in the U direction.
UnlockedMullions | Get all the unlocked mullions of the curtain grid.
UnlockedPanels | Get all the unlocked panels of the curtain grid.
VGridLines | All grid lines in the V direction.

See Also

CurtainGrid Class


CurtainGrid Methods

[image] [image]

Revit 2011 API
CurtainGrid Methods
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

Name | Description
AddGridLine | Add a grid line to the curtain grid.
ChangePanelType | Change the type of a curtain panel.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCell | Get the specified cell located by the intersection of the grid lines.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPanel | Get the specified panel located by the intersection of the grid lines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGrid Class


AddGridLine Method

[image]

Revit 2011 API
CurtainGrid..::.AddGridLine Method
CurtainGrid Class See Also Send Feedback
Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Type: System..::.Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.DB..::.XYZ
The position of the grid line.
oneSegmentOnly
Type: System..::.Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if the position for the grid line is out of range.

See Also

CurtainGrid Class


ChangePanelType Method

[image]

Revit 2011 API
CurtainGrid..::.ChangePanelType Method
CurtainGrid Class See Also Send Feedback
Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element ChangePanelType(
    Element panel,
    ElementType newSymbol
)
Visual Basic (Declaration)
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As ElementType _
) As Element
Visual C++
public:
Element^ ChangePanelType(
    Element^ panel,
    ElementType^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit.DB..::.Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit.DB..::.ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input symbol can't be used for the panel.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the type change failed.

See Also

CurtainGrid Class


GetCell Method

[image]

Revit 2011 API
CurtainGrid..::.GetCell Method
CurtainGrid Class See Also Send Feedback
Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainCell GetCell(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetCell ( _
    uGridLineId As ElementId, _
    vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::.ElementId
The id of a grid line in the U-direction used to locate the cell.
vGridLineId
Type: Autodesk.Revit.DB..::.ElementId
The id of a grid line in the V-direction used to locate the cell.

Return Value

The cell.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the grid line ids are not part of this curtain grid.

See Also

CurtainGrid Class


GetPanel Method

[image]

Revit 2011 API
CurtainGrid..::.GetPanel Method
CurtainGrid Class See Also Send Feedback
Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Panel GetPanel(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Visual Basic (Declaration)
Public Function GetPanel ( _
    uGridLineId As ElementId, _
    vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::.ElementId
The id of a grid line in the U-direction used to locate the panel.
vGridLineId
Type: Autodesk.Revit.DB..::.ElementId
The id of a grid line in the V-direction used to locate the panel.

Return Value

The panel, or nullNothingnullptra null reference (Nothing in Visual Basic) if the panel cannot be found at this intersection.

See Also

CurtainGrid Class


CurtainGrid Properties

[image] [image]

Revit 2011 API
CurtainGrid Properties
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Properties

Name | Description
Cells | Get all the cells owned by this curtain grid.
Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Grid2Angle | The angle for V grid line pattern of the curtain grid.
Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Grid2Offset | The offset for V grid line pattern of the curtain grid.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Mullions | Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
NumPanels | The number of panels.
NumULines | Get the number of grid lines in the U direction.
NumVLines | Get the number of grid lines in the V direction.
Panels | All the panels of the curtain grid.
UGridLines | All grid lines in the U direction.
UnlockedMullions | Get all the unlocked mullions of the curtain grid.
UnlockedPanels | Get all the unlocked panels of the curtain grid.
VGridLines | All grid lines in the V direction.

See Also

CurtainGrid Class


Cells Property

[image]

Revit 2011 API
CurtainGrid..::.Cells Property
CurtainGrid Class See Also Send Feedback
Get all the cells owned by this curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainCellSet Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As CurtainCellSet
Visual C++
public:
property CurtainCellSet^ Cells {
    CurtainCellSet^ get ();
}

See Also

CurtainGrid Class


Grid1Angle Property

[image]

Revit 2011 API
CurtainGrid..::.Grid1Angle Property
CurtainGrid Class See Also Send Feedback
The angle for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Grid1Angle { get; set; }
Visual Basic (Declaration)
Public Property Grid1Angle As Double
Visual C++
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid1Justification Property

[image]

Revit 2011 API
CurtainGrid..::.Grid1Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridAlignType Grid1Justification { get; set; }
Visual Basic (Declaration)
Public Property Grid1Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid1Offset Property

[image]

Revit 2011 API
CurtainGrid..::.Grid1Offset Property
CurtainGrid Class See Also Send Feedback
The offset for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Grid1Offset { get; set; }
Visual Basic (Declaration)
Public Property Grid1Offset As Double
Visual C++
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Angle Property

[image]

Revit 2011 API
CurtainGrid..::.Grid2Angle Property
CurtainGrid Class See Also Send Feedback
The angle for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Grid2Angle { get; set; }
Visual Basic (Declaration)
Public Property Grid2Angle As Double
Visual C++
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Justification Property

[image]

Revit 2011 API
CurtainGrid..::.Grid2Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridAlignType Grid2Justification { get; set; }
Visual Basic (Declaration)
Public Property Grid2Justification As CurtainGridAlignType
Visual C++
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid2Offset Property

[image]

Revit 2011 API
CurtainGrid..::.Grid2Offset Property
CurtainGrid Class See Also Send Feedback
The offset for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Grid2Offset { get; set; }
Visual Basic (Declaration)
Public Property Grid2Offset As Double
Visual C++
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Mullions Property

[image]

Revit 2011 API
CurtainGrid..::.Mullions Property
CurtainGrid Class See Also Send Feedback
Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Mullions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mullions As ElementSet
Visual C++
public:
property ElementSet^ Mullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


NumPanels Property

[image]

Revit 2011 API
CurtainGrid..::.NumPanels Property
CurtainGrid Class See Also Send Feedback
The number of panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumPanels { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumPanels As Integer
Visual C++
public:
property int NumPanels {
    int get ();
}

See Also

CurtainGrid Class


NumULines Property

[image]

Revit 2011 API
CurtainGrid..::.NumULines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumULines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumULines As Integer
Visual C++
public:
property int NumULines {
    int get ();
}

See Also

CurtainGrid Class


NumVLines Property

[image]

Revit 2011 API
CurtainGrid..::.NumVLines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumVLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumVLines As Integer
Visual C++
public:
property int NumVLines {
    int get ();
}

See Also

CurtainGrid Class


Panels Property

[image]

Revit 2011 API
CurtainGrid..::.Panels Property
CurtainGrid Class See Also Send Feedback
All the panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Panels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panels As ElementSet
Visual C++
public:
property ElementSet^ Panels {
    ElementSet^ get ();
}

Remarks

For curtain walls, the element in this set is either an instance of Panel or Wall. For curtain systems, the set contains only instances of Panel.

See Also

CurtainGrid Class


UGridLines Property

[image]

Revit 2011 API
CurtainGrid..::.UGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet UGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property UGridLines As ElementSet
Visual C++
public:
property ElementSet^ UGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


UnlockedMullions Property

[image]

Revit 2011 API
CurtainGrid..::.UnlockedMullions Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet UnlockedMullions { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnlockedMullions As ElementSet
Visual C++
public:
property ElementSet^ UnlockedMullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


UnlockedPanels Property

[image]

Revit 2011 API
CurtainGrid..::.UnlockedPanels Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet UnlockedPanels { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnlockedPanels As ElementSet
Visual C++
public:
property ElementSet^ UnlockedPanels {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


VGridLines Property

[image]

Revit 2011 API
CurtainGrid..::.VGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet VGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property VGridLines As ElementSet
Visual C++
public:
property ElementSet^ VGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


CurtainGridAlignType Enumeration

[image]

Revit 2011 API
CurtainGridAlignType Enumeration
See Also Send Feedback
An enumerated to list CurtainGrid patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CurtainGridAlignType
Visual Basic (Declaration)
Public Enumeration CurtainGridAlignType
Visual C++
public enum class CurtainGridAlignType

Members

Member name | Description
NoJustify | NoJustify.
Beginning | Beginning pattern of CurtainGrid.
Center | Center pattern of CurtainGrid.
End | End pattern of CurtainGrid.

See Also


CurtainGridLine Class

[image]

Revit 2011 API
CurtainGridLine Class
Members See Also Send Feedback
Represents a CurtainGridLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainGridLine : HostObject
Visual Basic (Declaration)
Public Class CurtainGridLine _
    Inherits HostObject
Visual C++
public ref class CurtainGridLine : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CurtainGridLine

See Also

CurtainGridLine Members


CurtainGridLine Members

[image] [image]

Revit 2011 API
CurtainGridLine Members
CurtainGridLine Class Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | Retrieve or change the lock state of the curtain grid line.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainGridLine Class


CurtainGridLine Methods

[image] [image]

Revit 2011 API
CurtainGridLine Methods
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

Name | Description
AddAllSegments | All the segments on this grid line will be added.
AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
AddSegment | Add a segment based on the specified segment curve of the gridline.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
RemoveSegment | Remove the segment specified by the input curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridLine Class


AddAllSegments Method

[image]

Revit 2011 API
CurtainGridLine..::.AddAllSegments Method
CurtainGridLine Class See Also Send Feedback
All the segments on this grid line will be added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddAllSegments()
Visual Basic (Declaration)
Public Sub AddAllSegments
Visual C++
public:
void AddAllSegments()

See Also

CurtainGridLine Class


AddMullions Method

[image]

Revit 2011 API
CurtainGridLine..::.AddMullions Method
CurtainGridLine Class See Also Send Feedback
Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic (Declaration)
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.DB..::.Curve
Curve of the segment.
mullionType
Type: Autodesk.Revit.DB..::.MullionType
The type of the mullion.
oneSegmentOnly
Type: System..::.Boolean
If it is true, we only add one mullion to the specified segment, otherwise we add mullions to all the segments of the grid line.

Return Value

If operation succeeds, the created mullion will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If one of the segments are not the tagged edge of the host element, this exception will be thrown.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The operation fails to create one or several mullions as required or regeneration fails.

See Also

CurtainGridLine Class


AddSegment Method

[image]

Revit 2011 API
CurtainGridLine..::.AddSegment Method
CurtainGridLine Class See Also Send Feedback
Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve used to locate the segment to be removed.

See Also

CurtainGridLine Class


Move Method

[image]

Revit 2011 API
CurtainGridLine..::.Move Method
CurtainGridLine Class See Also Send Feedback
It is used to move unlocked type-driven grid lines or user defined grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Move ( _
    moveVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ moveVec
)

Parameters

moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return true, otherwise false.

Remarks

Grid line can only move within its surface and U line can only be moved along V direction. So the move distance on grid surface will be calculated from moveVec.

See Also

CurtainGridLine Class


RemoveSegment Method

[image]

Revit 2011 API
CurtainGridLine..::.RemoveSegment Method
CurtainGridLine Class See Also Send Feedback
Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel.

See Also

CurtainGridLine Class


CurtainGridLine Properties

[image] [image]

Revit 2011 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

Name | Description
AllSegmentCurves | Retrieve the curves of all segments.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
FullCurve | Retrieve the geometry curve of the curtain grid line.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Lock | Retrieve or change the lock state of the curtain grid line.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainGridLine Class


AllSegmentCurves Property

[image]

Revit 2011 API
CurtainGridLine..::.AllSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also

CurtainGridLine Class


ExistingSegmentCurves Property

[image]

Revit 2011 API
CurtainGridLine..::.ExistingSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray ExistingSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExistingSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.

See Also

CurtainGridLine Class


FullCurve Property

[image]

Revit 2011 API
CurtainGridLine..::.FullCurve Property
CurtainGridLine Class See Also Send Feedback
Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve FullCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullCurve As Curve
Visual C++
public:
property Curve^ FullCurve {
    Curve^ get ();
}

See Also

CurtainGridLine Class


IsUGridLine Property

[image]

Revit 2011 API
CurtainGridLine..::.IsUGridLine Property
CurtainGridLine Class See Also Send Feedback
Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsUGridLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUGridLine As Boolean
Visual C++
public:
property bool IsUGridLine {
    bool get ();
}

See Also

CurtainGridLine Class


Lock Property

[image]

Revit 2011 API
CurtainGridLine..::.Lock Property
CurtainGridLine Class See Also Send Feedback
Retrieve or change the lock state of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

CurtainGridLine Class


Parameter Property

[image] [image]

Revit 2011 API
CurtainGridLine..::.Parameter Property
CurtainGridLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainGridLine Class
CurtainGridLine Members


SkippedSegmentCurves Property

[image]

Revit 2011 API
CurtainGridLine..::.SkippedSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray SkippedSegmentCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property SkippedSegmentCurves As CurveArray
Visual C++
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() to add the segments to the grid line.

See Also

CurtainGridLine Class


CurtainGridSet Class

[image]

Revit 2011 API
CurtainGridSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainGridSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainGridSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainGridSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainGridSet

See Also

CurtainGridSet Members


CurtainGridSet Members

[image] [image]

Revit 2011 API
CurtainGridSet Members
CurtainGridSet Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSet type exposes the following members.

Constructors

Name | Description
CurtainGridSet | Initializes a new instance of the CurtainGridSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


CurtainGridSet Constructor

[image]

Revit 2011 API
CurtainGridSet Constructor
CurtainGridSet Class See Also Send Feedback
Initializes a new instance of the CurtainGridSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSet()

See Also

CurtainGridSet Class


CurtainGridSet Methods

[image] [image]

Revit 2011 API
CurtainGridSet Methods
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSet Class


Clear Method

[image]

Revit 2011 API
CurtainGridSet..::.Clear Method
CurtainGridSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainGridSet Class


Contains Method

[image]

Revit 2011 API
CurtainGridSet..::.Contains Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainGrid

See Also

CurtainGridSet Class


Erase Method

[image]

Revit 2011 API
CurtainGridSet..::.Erase Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainGrid _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainGrid

See Also

CurtainGridSet Class


ForwardIterator Method

[image]

Revit 2011 API
CurtainGridSet..::.ForwardIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainGridSet Class


GetEnumerator Method

[image]

Revit 2011 API
CurtainGridSet..::.GetEnumerator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainGridSet Class


Insert Method

[image]

Revit 2011 API
CurtainGridSet..::.Insert Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainGrid item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainGrid

See Also

CurtainGridSet Class


ReverseIterator Method

[image]

Revit 2011 API
CurtainGridSet..::.ReverseIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainGridSet Class


CurtainGridSet Properties

[image] [image]

Revit 2011 API
CurtainGridSet Properties
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


IsEmpty Property

[image]

Revit 2011 API
CurtainGridSet..::.IsEmpty Property
CurtainGridSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainGridSet Class


Size Property

[image]

Revit 2011 API
CurtainGridSet..::.Size Property
CurtainGridSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainGridSet Class


CurtainGridSetIterator Class

[image]

Revit 2011 API
CurtainGridSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurtainGridSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainGridSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainGridSetIterator

See Also

CurtainGridSetIterator Members


CurtainGridSetIterator Members

[image] [image]

Revit 2011 API
CurtainGridSetIterator Members
CurtainGridSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Constructors

Name | Description
CurtainGridSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Constructor

[image]

Revit 2011 API
CurtainGridSetIterator Constructor
CurtainGridSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainGridSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Methods

[image] [image]

Revit 2011 API
CurtainGridSetIterator Methods
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSetIterator Class


MoveNext Method

[image]

Revit 2011 API
CurtainGridSetIterator..::.MoveNext Method
CurtainGridSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


Reset Method

[image]

Revit 2011 API
CurtainGridSetIterator..::.Reset Method
CurtainGridSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Properties

[image] [image]

Revit 2011 API
CurtainGridSetIterator Properties
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class


Current Property

[image]

Revit 2011 API
CurtainGridSetIterator..::.Current Property
CurtainGridSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


CurtainSystem Class

[image]

Revit 2011 API
CurtainSystem Class
Members See Also Send Feedback
Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainSystem : CurtainSystemBase
Visual Basic (Declaration)
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CurtainSystemBase
Autodesk.Revit.DB..::.CurtainSystem

See Also

CurtainSystem Members


CurtainSystem Members

[image] [image]

Revit 2011 API
CurtainSystem Members
CurtainSystem Class Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

Name | Description
AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
CurtainSystemType | get or set the type of the CurtainSystem.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainSystem Methods

[image] [image]

Revit 2011 API
CurtainSystem Methods
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

Name | Description
AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystem Class


AddCurtainGrid Method

[image]

Revit 2011 API
CurtainSystem..::.AddCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class


RemoveCurtainGrid Method

[image]

Revit 2011 API
CurtainSystem..::.RemoveCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveCurtainGrid(
    Reference face
)
Visual Basic (Declaration)
Public Sub RemoveCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void RemoveCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
The face CurtainGrid will be removed from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input parameter face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.

See Also

CurtainSystem Class


CurtainSystem Properties

[image] [image]

Revit 2011 API
CurtainSystem Properties
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
CurtainSystemType | get or set the type of the CurtainSystem.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainGrids Property

[image]

Revit 2011 API
CurtainSystem..::.CurtainGrids Property
CurtainSystem Class See Also Send Feedback
Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Return Value

A CurtainGrid set will be returned if the operation succeeds. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the CurtainSystem doesn't include any CurtainGrid.

See Also

CurtainSystem Class


CurtainSystemType Property

[image]

Revit 2011 API
CurtainSystem..::.CurtainSystemType Property
CurtainSystem Class See Also Send Feedback
get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic (Declaration)
Public Property CurtainSystemType As CurtainSystemType
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class


Parameter Property

[image] [image]

Revit 2011 API
CurtainSystem..::.Parameter Property
CurtainSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystem Class
CurtainSystem Members


CurtainSystemBase Class

[image]

Revit 2011 API
CurtainSystemBase Class
Members See Also Send Feedback
Provides access to the CurtainSystemBase object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainSystemBase : HostObject
Visual Basic (Declaration)
Public Class CurtainSystemBase _
    Inherits HostObject
Visual C++
public ref class CurtainSystemBase : public HostObject

Remarks

This is the base class of CurtainSystem.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CurtainSystemBase
Autodesk.Revit.DB..::.CurtainSystem

See Also

CurtainSystemBase Members


CurtainSystemBase Members

[image] [image]

Revit 2011 API
CurtainSystemBase Members
CurtainSystemBase Class Methods Properties See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystemBase Class


CurtainSystemBase Methods

[image] [image]

Revit 2011 API
CurtainSystemBase Methods
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemBase Class


CurtainSystemBase Properties

[image] [image]

Revit 2011 API
CurtainSystemBase Properties
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystemBase Class


Parameter Property

[image] [image]

Revit 2011 API
CurtainSystemBase..::.Parameter Property
CurtainSystemBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystemBase Class
CurtainSystemBase Members


CurtainSystemType Class

[image]

Revit 2011 API
CurtainSystemType Class
Members See Also Send Feedback
An object that represents CurtainSystem type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainSystemType : HostObjAttributes
Visual Basic (Declaration)
Public Class CurtainSystemType _
    Inherits HostObjAttributes
Visual C++
public ref class CurtainSystemType : public HostObjAttributes

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.CurtainSystemType

See Also

CurtainSystemType Members


CurtainSystemType Members

[image] [image]

Revit 2011 API
CurtainSystemType Members
CurtainSystemType Class Methods Properties See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystemType Class


CurtainSystemType Methods

[image] [image]

Revit 2011 API
CurtainSystemType Methods
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemType Class


CurtainSystemType Properties

[image] [image]

Revit 2011 API
CurtainSystemType Properties
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurtainSystemType Class


Parameter Property

[image] [image]

Revit 2011 API
CurtainSystemType..::.Parameter Property
CurtainSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurtainSystemType Class
CurtainSystemType Members


CurtainSystemTypeSet Class

[image]

Revit 2011 API
CurtainSystemTypeSet Class
Members See Also Send Feedback
A set that contains CurtainSystem types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurtainSystemTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurtainSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainSystemTypeSet

See Also

CurtainSystemTypeSet Members


CurtainSystemTypeSet Members

[image] [image]

Revit 2011 API
CurtainSystemTypeSet Members
CurtainSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Constructors

Name | Description
CurtainSystemTypeSet | Initializes a new instance of the CurtainSystemTypeSet class

Methods

Name | Description
Clear | Removes every CurtainSystem type from the set, rendering it empty.
Contains | Tests for the existence of a CurtainSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified CurtainSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified CurtainSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Constructor

[image]

Revit 2011 API
CurtainSystemTypeSet Constructor
CurtainSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the CurtainSystemTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystemTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSet()

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Methods

[image] [image]

Revit 2011 API
CurtainSystemTypeSet Methods
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every CurtainSystem type from the set, rendering it empty.
Contains | Tests for the existence of a CurtainSystem type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified CurtainSystem type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified CurtainSystem type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSet Class


Clear Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.Clear Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes every CurtainSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainSystemTypeSet Class


Contains Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.Contains Method
CurtainSystemTypeSet Class See Also Send Feedback
Tests for the existence of a CurtainSystem type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainSystemType
The CurtainSystem type to be searched for.

Return Value

The Contains method returns True if the CurtainSystem type is within the set, otherwise False.

See Also

CurtainSystemTypeSet Class


Erase Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.Erase Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes a specified CurtainSystem type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CurtainSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainSystemType
The CurtainSystem type to be erased.

Return Value

The number of CurtainSystem types that were erased from the set.

See Also

CurtainSystemTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.ForwardIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainSystemTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.GetEnumerator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurtainSystemTypeSet Class


Insert Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.Insert Method
CurtainSystemTypeSet Class See Also Send Feedback
Insert the specified CurtainSystem type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainSystemType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurtainSystemType
The CurtainSystem type to be inserted into the set.

Return Value

Returns whether the CurtainSystem type was inserted into the set.

See Also

CurtainSystemTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
CurtainSystemTypeSet..::.ReverseIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Properties

[image] [image]

Revit 2011 API
CurtainSystemTypeSet Properties
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
CurtainSystemTypeSet..::.IsEmpty Property
CurtainSystemTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainSystemTypeSet Class


Size Property

[image]

Revit 2011 API
CurtainSystemTypeSet..::.Size Property
CurtainSystemTypeSet Class See Also Send Feedback
Returns the number of CurtainSystem types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSetIterator Class

[image]

Revit 2011 API
CurtainSystemTypeSetIterator Class
Members See Also Send Feedback
An iterator to a CurtainSystem type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurtainSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurtainSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurtainSystemTypeSetIterator

See Also

CurtainSystemTypeSetIterator Members


CurtainSystemTypeSetIterator Members

[image] [image]

Revit 2011 API
CurtainSystemTypeSetIterator Members
CurtainSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Constructors

Name | Description
CurtainSystemTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Constructor

[image]

Revit 2011 API
CurtainSystemTypeSetIterator Constructor
CurtainSystemTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystemTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurtainSystemTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Methods

[image] [image]

Revit 2011 API
CurtainSystemTypeSetIterator Methods
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
CurtainSystemTypeSetIterator..::.MoveNext Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
CurtainSystemTypeSetIterator..::.Reset Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Properties

[image] [image]

Revit 2011 API
CurtainSystemTypeSetIterator Properties
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class


Current Property

[image]

Revit 2011 API
CurtainSystemTypeSetIterator..::.Current Property
CurtainSystemTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class


Curve Class

[image]

Revit 2011 API
Curve Class
Members See Also Send Feedback
A parametric curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Curve : GeometryObject
Visual Basic (Declaration)
Public Class Curve _
    Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Arc
Autodesk.Revit.DB..::.Ellipse
Autodesk.Revit.DB..::.HermiteSpline
Autodesk.Revit.DB..::.Line
Autodesk.Revit.DB..::.NurbSpline

See Also

Curve Members


Curve Members

[image] [image]

Revit 2011 API
Curve Members
Curve Class Methods Properties See Also Send Feedback

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


Curve Methods

[image] [image]

Revit 2011 API
Curve Methods
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve.
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter.
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values.
MakeUnbound | Makes this curve unbound.
Project | Projects the specified point on this curve.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Curve Class


Clone Method

[image]

Revit 2011 API
Curve..::.Clone Method
Curve Class See Also Send Feedback
Returns a copy of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Clone()
Visual Basic (Declaration)
Public Function Clone As Curve
Visual C++
public:
Curve^ Clone()

See Also

Curve Class


ComputeDerivatives Method

[image]

Revit 2011 API
Curve..::.ComputeDerivatives Method
Curve Class See Also Send Feedback
Returns the moving frame around the curve at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::.Double
The parameter to be evaluated.
normalized
Type: System..::.Boolean
Indicates that the specified parameter is normalized.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the curve is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified parameter is infinite.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when normalized is true and this curve is unbound or the parameter is not within [0, 1] interval.

See Also

Curve Class


ComputeNormalizedParameter Method

[image]

Revit 2011 API
Curve..::.ComputeNormalizedParameter Method
Curve Class See Also Send Feedback
Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic (Declaration)
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter(
    double rawParameter
)

Parameters

rawParameter
Type: System..::.Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when rawParameter is infinite.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class


ComputeRawParameter Method

[image]

Revit 2011 API
Curve..::.ComputeRawParameter Method
Curve Class See Also Send Feedback
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic (Declaration)
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::.Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when normalizedParameter is infinite.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class


Distance Method

[image]

Revit 2011 API
Curve..::.Distance Method
Curve Class See Also Send Feedback
Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic (Declaration)
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class


Evaluate Method

[image]

Revit 2011 API
Curve..::.Evaluate Method
Curve Class See Also Send Feedback
Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param,
    bool normalized
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated.
normalized
Type: System..::.Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class


Intersect Method

[image] [image]

Revit 2011 API
Curve..::.Intersect Method
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.

See Also

Curve Class
Curve Members


Intersect Method (Curve)

[image]

Revit 2011 API
Curve..::.Intersect Method (Curve)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The specified curve to intersect with this curve.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | The specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2011 API
Curve..::.Intersect Method (Curve, IntersectionResultArray%)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray resultArray
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% resultArray
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The specified curve to intersect with this curve.
resultArray
Type: Autodesk.Revit.DB..::.IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve. If the former, the output argument has the details of the intersection point.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members:
  • XYZPoint is the evaluated intersection point
  • UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
  • UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2011 API
Curve..::.IsInside Method
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

See Also

Curve Class
Curve Members


IsInside Method (Double)

[image]

Revit 2011 API
Curve..::.IsInside Method (Double)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified parameter is infinite.

See Also

Curve Class
IsInside Overload


IsInside Method (Double, Int32)

[image]

Revit 2011 API
Curve..::.IsInside Method (Double, Int32%)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInside(
    double parameter,
    out int end
)
Visual Basic (Declaration)
Public Function IsInside ( _
    parameter As Double, _
    <OutAttribute> ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)

Parameters

parameter
Type: System..::.Double
The raw curve parameter to be evaluated.
end
Type: System..::.Int32 %
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
IsInside Overload


MakeBound Method

[image]

Revit 2011 API
Curve..::.MakeBound Method
Curve Class See Also Send Feedback
Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic (Declaration)
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound(
    double startParameter,
    double endParameter
)

Parameters

startParameter
Type: System..::.Double
The new parameter of the start point.
endParameter
Type: System..::.Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified values are infinite.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class


MakeUnbound Method

[image]

Revit 2011 API
Curve..::.MakeUnbound Method
Curve Class See Also Send Feedback
Makes this curve unbound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeUnbound()
Visual Basic (Declaration)
Public Sub MakeUnbound
Visual C++
public:
void MakeUnbound()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the object is internally marked as read-only.

See Also

Curve Class


Project Method

[image]

Revit 2011 API
Curve..::.Project Method
Curve Class See Also Send Feedback
Projects the specified point on this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class


Tessellate Method

[image]

Revit 2011 API
Curve..::.Tessellate Method
Curve Class See Also Send Feedback
Valid only if the curve is bound. Returns a polyline approximation to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Curve Class


Curve Properties

[image] [image]

Revit 2011 API
Curve Properties
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve.
EndParameter | The parameter of the start or the end point of the curve.
EndPoint | The start or the end point of this curve.
EndPointReference | Returns a stable reference to the start point or the end point of the curve.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
IsCyclic | The boolean value that indicates whether this curve is cyclic.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve.
Period | The period of this curve.
Reference | Returns a stable reference to the curve.
Transformed | Applies the specified transformation to this curve and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


ApproximateLength Property

[image]

Revit 2011 API
Curve..::.ApproximateLength Property
Curve Class See Also Send Feedback
The approximate length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


EndParameter Property

[image]

Revit 2011 API
Curve..::.EndParameter Property
Curve Class See Also Send Feedback
The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EndParameter[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property EndParameter ( _
    index As Integer _
) As Double
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class


EndPoint Property

[image]

Revit 2011 API
Curve..::.EndPoint Property
Curve Class See Also Send Feedback
The start or the end point of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ EndPoint[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this curve is unbound.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class


EndPointReference Property

[image]

Revit 2011 API
Curve..::.EndPointReference Property
Curve Class See Also Send Feedback
Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference EndPointReference[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class


IsBound Property

[image]

Revit 2011 API
Curve..::.IsBound Property
Curve Class See Also Send Feedback
Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBound As Boolean
Visual C++
public:
property bool IsBound {
    bool get ();
}

See Also

Curve Class


IsCyclic Property

[image]

Revit 2011 API
Curve..::.IsCyclic Property
Curve Class See Also Send Feedback
The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCyclic { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic As Boolean
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class


Length Property

[image]

Revit 2011 API
Curve..::.Length Property
Curve Class See Also Send Feedback
The exact length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


Period Property

[image]

Revit 2011 API
Curve..::.Period Property
Curve Class See Also Send Feedback
The period of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Period { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class


Reference Property

[image]

Revit 2011 API
Curve..::.Reference Property
Curve Class See Also Send Feedback
Returns a stable reference to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Curve Class


Transformed Property

[image]

Revit 2011 API
Curve..::.Transformed Property
Curve Class Example See Also Send Feedback
Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation to be applied.

Return Value

The transformed curve.

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.ApplicationServices.Application app,
    Autodesk.Revit.DB.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
       Autodesk.Revit.DB.GeometryInstance instance =
           geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry.Objects)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.get_Transformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry.Objects
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.Transformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class


CurveArrArray Class

[image]

Revit 2011 API
CurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveArrArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveArrArray

See Also

CurveArrArray Members


CurveArrArray Members

[image] [image]

Revit 2011 API
CurveArrArray Members
CurveArrArray Class Constructors Methods Properties See Also Send Feedback

The CurveArrArray type exposes the following members.

Constructors

Name | Description
CurveArrArray | Initializes a new instance of the CurveArrArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class


CurveArrArray Constructor

[image]

Revit 2011 API
CurveArrArray Constructor
CurveArrArray Class See Also Send Feedback
Initializes a new instance of the CurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArray()

See Also

CurveArrArray Class


CurveArrArray Methods

[image] [image]

Revit 2011 API
CurveArrArray Methods
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArray Class


Append Method

[image]

Revit 2011 API
CurveArrArray..::.Append Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    CurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CurveArray _
)
Visual C++
public:
virtual void Append(
    CurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurveArray

See Also

CurveArrArray Class


Clear Method

[image]

Revit 2011 API
CurveArrArray..::.Clear Method
CurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArrArray Class


ForwardIterator Method

[image]

Revit 2011 API
CurveArrArray..::.ForwardIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArrArray Class


GetEnumerator Method

[image]

Revit 2011 API
CurveArrArray..::.GetEnumerator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveArrArray Class


Insert Method

[image]

Revit 2011 API
CurveArrArray..::.Insert Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    CurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurveArray
index
Type: System..::.Int32

See Also

CurveArrArray Class


ReverseIterator Method

[image]

Revit 2011 API
CurveArrArray..::.ReverseIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArrArray Class


CurveArrArray Properties

[image] [image]

Revit 2011 API
CurveArrArray Properties
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class


IsEmpty Property

[image]

Revit 2011 API
CurveArrArray..::.IsEmpty Property
CurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArrArray Class


Item Property

[image]

Revit 2011 API
CurveArrArray..::.Item Property
CurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CurveArray
Visual C++
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

CurveArrArray Class


Size Property

[image]

Revit 2011 API
CurveArrArray..::.Size Property
CurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArrArray Class


CurveArrArrayIterator Class

[image]

Revit 2011 API
CurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveArrArrayIterator

See Also

CurveArrArrayIterator Members


CurveArrArrayIterator Members

[image] [image]

Revit 2011 API
CurveArrArrayIterator Members
CurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Constructors

Name | Description
CurveArrArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Constructor

[image]

Revit 2011 API
CurveArrArrayIterator Constructor
CurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Methods

[image] [image]

Revit 2011 API
CurveArrArrayIterator Methods
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
CurveArrArrayIterator..::.MoveNext Method
CurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


Reset Method

[image]

Revit 2011 API
CurveArrArrayIterator..::.Reset Method
CurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Properties

[image] [image]

Revit 2011 API
CurveArrArrayIterator Properties
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class


Current Property

[image]

Revit 2011 API
CurveArrArrayIterator..::.Current Property
CurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


CurveArray Class

[image]

Revit 2011 API
CurveArray Class
Members See Also Send Feedback
An array that can contain curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveArray

See Also

CurveArray Members


CurveArray Members

[image] [image]

Revit 2011 API
CurveArray Members
CurveArray Class Constructors Methods Properties See Also Send Feedback

The CurveArray type exposes the following members.

Constructors

Name | Description
CurveArray | Initializes a new instance of the CurveArray class

Methods

Name | Description
Append | Add the curve to the end of the array.
Clear | Removes every curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a curve at a specified index within the array.
Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


CurveArray Constructor

[image]

Revit 2011 API
CurveArray Constructor
CurveArray Class See Also Send Feedback
Initializes a new instance of the CurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArray()

See Also

CurveArray Class


CurveArray Methods

[image] [image]

Revit 2011 API
CurveArray Methods
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Methods

Name | Description
Append | Add the curve to the end of the array.
Clear | Removes every curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArray Class


Append Method

[image]

Revit 2011 API
CurveArray..::.Append Method
CurveArray Class See Also Send Feedback
Add the curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Curve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Curve _
)
Visual C++
public:
virtual void Append(
    Curve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Curve
The curve to be added.

See Also

CurveArray Class


Clear Method

[image]

Revit 2011 API
CurveArray..::.Clear Method
CurveArray Class See Also Send Feedback
Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArray Class


ForwardIterator Method

[image]

Revit 2011 API
CurveArray..::.ForwardIterator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class


GetEnumerator Method

[image]

Revit 2011 API
CurveArray..::.GetEnumerator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveArray Class


Insert Method

[image]

Revit 2011 API
CurveArray..::.Insert Method
CurveArray Class See Also Send Feedback
Insert the specified curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Curve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Curve
The curve to be inserted into the array.
index
Type: System..::.Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class


ReverseIterator Method

[image]

Revit 2011 API
CurveArray..::.ReverseIterator Method
CurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArray Class


CurveArray Properties

[image] [image]

Revit 2011 API
CurveArray Properties
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a curve at a specified index within the array.
Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


IsEmpty Property

[image]

Revit 2011 API
CurveArray..::.IsEmpty Property
CurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArray Class


Item Property

[image]

Revit 2011 API
CurveArray..::.Item Property
CurveArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Curve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Curve
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class


Size Property

[image]

Revit 2011 API
CurveArray..::.Size Property
CurveArray Class See Also Send Feedback
Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArray Class


CurveArrayIterator Class

[image]

Revit 2011 API
CurveArrayIterator Class
Members See Also Send Feedback
An iterator to a curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveArrayIterator

See Also

CurveArrayIterator Members


CurveArrayIterator Members

[image] [image]

Revit 2011 API
CurveArrayIterator Members
CurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Constructors

Name | Description
CurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class


CurveArrayIterator Constructor

[image]

Revit 2011 API
CurveArrayIterator Constructor
CurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrayIterator Class


CurveArrayIterator Methods

[image] [image]

Revit 2011 API
CurveArrayIterator Methods
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
CurveArrayIterator..::.MoveNext Method
CurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


Reset Method

[image]

Revit 2011 API
CurveArrayIterator..::.Reset Method
CurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class


CurveArrayIterator Properties

[image] [image]

Revit 2011 API
CurveArrayIterator Properties
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class


Current Property

[image]

Revit 2011 API
CurveArrayIterator..::.Current Property
CurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


CurveByPoints Class

[image]

Revit 2011 API
CurveByPoints Class
Members See Also Send Feedback
A curve interpolating two or more points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic (Declaration)
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.CurveByPoints

See Also

CurveByPoints Members


CurveByPoints Members

[image] [image]

Revit 2011 API
CurveByPoints Members
CurveByPoints Class Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPoints | Get the sequence of points interpolated by this curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine |
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class


CurveByPoints Methods

[image] [image]

Revit 2011 API
CurveByPoints Methods
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPoints | Get the sequence of points interpolated by this curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetPoints | Change the sequence of points interpolated by this curve.
SetVisibility | Sets the visibility.
SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPoints Class


GetPoints Method

[image]

Revit 2011 API
CurveByPoints..::.GetPoints Method
CurveByPoints Class See Also Send Feedback
Get the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePointArray GetPoints()
Visual Basic (Declaration)
Public Function GetPoints As ReferencePointArray
Visual C++
public:
ReferencePointArray^ GetPoints()

See Also

CurveByPoints Class


GetVisibility Method

[image]

Revit 2011 API
CurveByPoints..::.GetVisibility Method
CurveByPoints Class See Also Send Feedback
Gets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the curve.

See Also

CurveByPoints Class


SetPoints Method

[image]

Revit 2011 API
CurveByPoints..::.SetPoints Method
CurveByPoints Class See Also Send Feedback
Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetPoints(
    ReferencePointArray points
)
Visual Basic (Declaration)
Public Sub SetPoints ( _
    points As ReferencePointArray _
)
Visual C++
public:
void SetPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::.ReferencePointArray
An array of 2 or more ReferencePoints.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.

See Also

CurveByPoints Class


SetVisibility Method

[image]

Revit 2011 API
CurveByPoints..::.SetVisibility Method
CurveByPoints Class See Also Send Feedback
Sets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SortPoints Method

[image]

Revit 2011 API
CurveByPoints..::.SortPoints Method
CurveByPoints Class See Also Send Feedback
Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool SortPoints(
    ReferencePointArray arr
)
Visual Basic (Declaration)
Public Shared Function SortPoints ( _
    arr As ReferencePointArray _
) As Boolean
Visual C++
public:
static bool SortPoints(
    ReferencePointArray^ arr
)

Parameters

arr
Type: Autodesk.Revit.DB..::.ReferencePointArray
An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.

Return Value

False if the least-squares method is unable to find a solution; true otherwise.

Remarks

Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.

See Also

CurveByPoints Class


CurveByPoints Properties

[image] [image]

Revit 2011 API
CurveByPoints Properties
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine |
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::.SketchPlane.)
Subcategory | The subcategory, or graphics style, of the CurveByPoints.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

CurveByPoints Class


IsReferenceLine Property

[image]

Revit 2011 API
CurveByPoints..::.IsReferenceLine Property
CurveByPoints Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReferenceLine { get; set; }
Visual Basic (Declaration)
Public Property IsReferenceLine As Boolean
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class


Parameter Property

[image] [image]

Revit 2011 API
CurveByPoints..::.Parameter Property
CurveByPoints Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurveByPoints Class
CurveByPoints Members


ReferenceType Property

[image]

Revit 2011 API
CurveByPoints..::.ReferenceType Property
CurveByPoints Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SketchPlane Property

[image]

Revit 2011 API
CurveByPoints..::.SketchPlane Property
CurveByPoints Class See Also Send Feedback
Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Overrides Property SketchPlane As SketchPlane
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns nullNothingnullptra null reference (Nothing in Visual Basic). Setting it causes an InvalidOperationException.

See Also

CurveByPoints Class


Subcategory Property

[image]

Revit 2011 API
CurveByPoints..::.Subcategory Property
CurveByPoints Class See Also Send Feedback
The subcategory, or graphics style, of the CurveByPoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

CurveByPoints Class


Visible Property

[image]

Revit 2011 API
CurveByPoints..::.Visible Property
CurveByPoints Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class


CurveByPointsArray Class

[image]

Revit 2011 API
CurveByPointsArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveByPointsArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CurveByPointsArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveByPointsArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveByPointsArray

See Also

CurveByPointsArray Members


CurveByPointsArray Members

[image] [image]

Revit 2011 API
CurveByPointsArray Members
CurveByPointsArray Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Constructors

Name | Description
CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

CurveByPointsArray Class


CurveByPointsArray Constructor

[image]

Revit 2011 API
CurveByPointsArray Constructor
CurveByPointsArray Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveByPointsArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveByPointsArray()

See Also

CurveByPointsArray Class


CurveByPointsArray Methods

[image] [image]

Revit 2011 API
CurveByPointsArray Methods
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArray Class


Append Method

[image]

Revit 2011 API
CurveByPointsArray..::.Append Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    CurveByPoints item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As CurveByPoints _
)
Visual C++
public:
virtual void Append(
    CurveByPoints^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurveByPoints

See Also

CurveByPointsArray Class


Clear Method

[image]

Revit 2011 API
CurveByPointsArray..::.Clear Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveByPointsArray Class


ForwardIterator Method

[image]

Revit 2011 API
CurveByPointsArray..::.ForwardIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ForwardIterator()

See Also

CurveByPointsArray Class


GetEnumerator Method

[image]

Revit 2011 API
CurveByPointsArray..::.GetEnumerator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CurveByPointsArray Class


Insert Method

[image]

Revit 2011 API
CurveByPointsArray..::.Insert Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    CurveByPoints item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As CurveByPoints, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveByPoints^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.CurveByPoints
index
Type: System..::.Int32

See Also

CurveByPointsArray Class


ReverseIterator Method

[image]

Revit 2011 API
CurveByPointsArray..::.ReverseIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ReverseIterator()

See Also

CurveByPointsArray Class


CurveByPointsArray Properties

[image] [image]

Revit 2011 API
CurveByPointsArray Properties
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

CurveByPointsArray Class


IsEmpty Property

[image]

Revit 2011 API
CurveByPointsArray..::.IsEmpty Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

CurveByPointsArray Class


Item Property

[image]

Revit 2011 API
CurveByPointsArray..::.Item Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CurveByPoints Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As CurveByPoints
Visual C++
public:
virtual property CurveByPoints^ Item[int index] {
    CurveByPoints^ get (int index);
    void set (int index, CurveByPoints^ value);
}

Parameters

index
Type: System..::.Int32

See Also

CurveByPointsArray Class


Size Property

[image]

Revit 2011 API
CurveByPointsArray..::.Size Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveByPointsArray Class


CurveByPointsArrayIterator Class

[image]

Revit 2011 API
CurveByPointsArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CurveByPointsArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CurveByPointsArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveByPointsArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.CurveByPointsArrayIterator

See Also

CurveByPointsArrayIterator Members


CurveByPointsArrayIterator Members

[image] [image]

Revit 2011 API
CurveByPointsArrayIterator Members
CurveByPointsArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Constructors

Name | Description
CurveByPointsArrayIterator | Initializes a new instance of the CurveByPointsArrayIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Constructor

[image]

Revit 2011 API
CurveByPointsArrayIterator Constructor
CurveByPointsArrayIterator Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArrayIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveByPointsArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CurveByPointsArrayIterator()

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Methods

[image] [image]

Revit 2011 API
CurveByPointsArrayIterator Methods
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
CurveByPointsArrayIterator..::.MoveNext Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

CurveByPointsArrayIterator Class


Reset Method

[image]

Revit 2011 API
CurveByPointsArrayIterator..::.Reset Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Properties

[image] [image]

Revit 2011 API
CurveByPointsArrayIterator Properties
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


Current Property

[image]

Revit 2011 API
CurveByPointsArrayIterator..::.Current Property
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

CurveByPointsArrayIterator Class


CurveByPointsUtils Class

[image]

Revit 2011 API
CurveByPointsUtils Class
Members See Also Send Feedback
A static class that contains methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class CurveByPointsUtils : IDisposable
Visual Basic (Declaration)
Public Class CurveByPointsUtils _
    Implements IDisposable
Visual C++
public ref class CurveByPointsUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CurveByPointsUtils

See Also

CurveByPointsUtils Members


CurveByPointsUtils Members

[image] [image]

Revit 2011 API
CurveByPointsUtils Members
CurveByPointsUtils Class Methods See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Methods

Name | Description
AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceRegions | Gets the FaceRegions in the existing face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHostFace | Gets the host face to which the CurveElement is added.
GetProjectionType | Gets the projection type of the CurveElement.
GetSketchOnSurface | Gets the relationship between the CurveElement and face.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetProjectionType | Sets the projection type of the CurveElement.
SetSketchOnSurface | Sets the relationship between the CurveElement and face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added the the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class


CurveByPointsUtils Methods

[image] [image]

Revit 2011 API
CurveByPointsUtils Methods
CurveByPointsUtils Class See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Methods

Name | Description
AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceRegions | Gets the FaceRegions in the existing face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHostFace | Gets the host face to which the CurveElement is added.
GetProjectionType | Gets the projection type of the CurveElement.
GetSketchOnSurface | Gets the relationship between the CurveElement and face.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetProjectionType | Sets the projection type of the CurveElement.
SetSketchOnSurface | Sets the relationship between the CurveElement and face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added the the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class


AddCurvesToFaceRegion Method

[image]

Revit 2011 API
CurveByPointsUtils..::.AddCurvesToFaceRegion Method
CurveByPointsUtils Class See Also Send Feedback
Adds The CurveElements to one or more FaceRegions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void AddCurvesToFaceRegion(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic (Declaration)
Public Shared Sub AddCurvesToFaceRegion ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
)
Visual C++
public:
static void AddCurvesToFaceRegion(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
curveElemIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The ElementIds of CurveElements which are to define the FaceRegion.

Remarks

The CurveElements that are input may produce an arbitrary number of regions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to add curves to FaceRegion.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


CreateRectangle Method

[image]

Revit 2011 API
CurveByPointsUtils..::.CreateRectangle Method
CurveByPointsUtils Class See Also Send Feedback
Creates rectangle on face or sketchplane for two given diagonal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void CreateRectangle(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    out IList<ElementId> createdCurvesIds,
    out IList<ElementId> createdCornersIds
)
Visual Basic (Declaration)
Public Shared Sub CreateRectangle ( _
    document As Document, _
    startPoint As ReferencePoint, _
    endPoint As ReferencePoint, _
    projectionType As CurveProjectionType, _
    boundaryReferenceLines As Boolean, _
    boundaryCurvesFollowSurface As Boolean, _
    <OutAttribute> ByRef createdCurvesIds As IList(Of ElementId), _
    <OutAttribute> ByRef createdCornersIds As IList(Of ElementId) _
)
Visual C++
public:
static void CreateRectangle(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    [OutAttribute] IList<ElementId^>^% createdCurvesIds,
    [OutAttribute] IList<ElementId^>^% createdCornersIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
startPoint
Type: Autodesk.Revit.DB..::.ReferencePoint
First diagonal point of rectangle.
endPoint
Type: Autodesk.Revit.DB..::.ReferencePoint
Second diagonal point of rectangle.
projectionType
Type: Autodesk.Revit.DB..::.CurveProjectionType
Projection type of rectangle's boundary curves. If the rectangle input points are Face hosted, and CurveProjectionType::ParallelToLevel is requested, and the Face normal at the location of the start point is at a less than 45 degree angle with the level planes, then the projectionType will be set to FromTopDown, even if ParallelToLevel was requested.
boundaryReferenceLines
Type: System..::.Boolean
True if rectangle's boundary curves should be reference lines, false otherwise.
boundaryCurvesFollowSurface
Type: System..::.Boolean
True if rectangle's boundary curves should follow surface, false otherwise.
createdCurvesIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>) %
Created rectangle's boundary curves ids.
createdCornersIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>) %
Ids of two newly created corner points.

Remarks

This array containts the ElementIds of the two additional corner points that are created to complete the rectangle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Unable to create rectangle.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Unexpected projection type.

See Also

CurveByPointsUtils Class


Dispose Method

[image]

Revit 2011 API
CurveByPointsUtils..::.Dispose Method
CurveByPointsUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

CurveByPointsUtils Class


GetFaceRegions Method

[image]

Revit 2011 API
CurveByPointsUtils..::.GetFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<Reference> GetFaceRegions(
    Document cda,
    Reference referenceOfFace
)
Visual Basic (Declaration)
Public Shared Function GetFaceRegions ( _
    cda As Document, _
    referenceOfFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetFaceRegions(
    Document^ cda,
    Reference^ referenceOfFace
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceOfFace
Type: Autodesk.Revit.DB..::.Reference
The Reference of the existing face.

Return Value

The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face Reference.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetHostFace Method

[image]

Revit 2011 API
CurveByPointsUtils..::.GetHostFace Method
CurveByPointsUtils Class See Also Send Feedback
Gets the host face to which the CurveElement is added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static Reference GetHostFace(
    CurveElement curveElem
)
Visual Basic (Declaration)
Public Shared Function GetHostFace ( _
    curveElem As CurveElement _
) As Reference
Visual C++
public:
static Reference^ GetHostFace(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.

Return Value

The host face to which the CurveElement is added, or an empty Reference if the host is not a face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetProjectionType Method

[image]

Revit 2011 API
CurveByPointsUtils..::.GetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Gets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static CurveProjectionType GetProjectionType(
    CurveElement curveElem
)
Visual Basic (Declaration)
Public Shared Function GetProjectionType ( _
    curveElem As CurveElement _
) As CurveProjectionType
Visual C++
public:
static CurveProjectionType GetProjectionType(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.

Return Value

The projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetSketchOnSurface Method

[image]

Revit 2011 API
CurveByPointsUtils..::.GetSketchOnSurface Method
CurveByPointsUtils Class See Also Send Feedback
Gets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool GetSketchOnSurface(
    CurveElement curveElem
)
Visual Basic (Declaration)
Public Shared Function GetSketchOnSurface ( _
    curveElem As CurveElement _
) As Boolean
Visual C++
public:
static bool GetSketchOnSurface(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.

Return Value

Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


SetProjectionType Method

[image]

Revit 2011 API
CurveByPointsUtils..::.SetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void SetProjectionType(
    CurveElement curveElem,
    CurveProjectionType value
)
Visual Basic (Declaration)
Public Shared Sub SetProjectionType ( _
    curveElem As CurveElement, _
    value As CurveProjectionType _
)
Visual C++
public:
static void SetProjectionType(
    CurveElement^ curveElem,
    CurveProjectionType value
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.
value
Type: Autodesk.Revit.DB..::.CurveProjectionType
The input projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


SetSketchOnSurface Method

[image]

Revit 2011 API
CurveByPointsUtils..::.SetSketchOnSurface Method
CurveByPointsUtils Class See Also Send Feedback
Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void SetSketchOnSurface(
    CurveElement curveElem,
    bool sketchOnSurface
)
Visual Basic (Declaration)
Public Shared Sub SetSketchOnSurface ( _
    curveElem As CurveElement, _
    sketchOnSurface As Boolean _
)
Visual C++
public:
static void SetSketchOnSurface(
    CurveElement^ curveElem,
    bool sketchOnSurface
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::.CurveElement
The CurveElement.
sketchOnSurface
Type: System..::.Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


ValidateCurveElementIdArrayForFaceRegions Method

[image]

Revit 2011 API
CurveByPointsUtils..::.ValidateCurveElementIdArrayForFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added the the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool ValidateCurveElementIdArrayForFaceRegions(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic (Declaration)
Public Shared Function ValidateCurveElementIdArrayForFaceRegions ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
curveElemIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The CurveElements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


CurveElement Class

[image]

Revit 2011 API
CurveElement Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveElement : Element
Visual Basic (Declaration)
Public Class CurveElement _
    Inherits Element
Visual C++
public ref class CurveElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.CurveByPoints
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB.Structure..::.AreaReinforcementCurve
Autodesk.Revit.DB..::.SymbolicCurve

See Also

CurveElement Members


CurveElement Members

[image] [image]

Revit 2011 API
CurveElement Members
CurveElement Class Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element.
LineStyles | All available line styles.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurveElement Class


CurveElement Methods

[image] [image]

Revit 2011 API
CurveElement Methods
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveElement Class


CurveElement Properties

[image] [image]

Revit 2011 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element.
LineStyles | All available line styles.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CurveElement Class


CurveElementType Property

[image]

Revit 2011 API
CurveElement..::.CurveElementType Property
CurveElement Class See Also Send Feedback
The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveElementType As CurveElementType
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElement Class


GeometryCurve Property

[image]

Revit 2011 API
CurveElement..::.GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic (Declaration)
Public Property GeometryCurve As Curve
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

Because there are no corresponding geometry curve type for HermiteSpline, for this type only general Autodesk::Revit::DB::Curve object will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class


LineStyle Property

[image]

Revit 2011 API
CurveElement..::.LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As Element
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class


LineStyles Property

[image]

Revit 2011 API
CurveElement..::.LineStyles Property
CurveElement Class See Also Send Feedback
All available line styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray LineStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineStyles As ElementArray
Visual C++
public:
property ElementArray^ LineStyles {
    ElementArray^ get ();
}

See Also

CurveElement Class


Parameter Property

[image] [image]

Revit 2011 API
CurveElement..::.Parameter Property
CurveElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CurveElement Class
CurveElement Members


SketchPlane Property

[image]

Revit 2011 API
CurveElement..::.SketchPlane Property
CurveElement Class See Also Send Feedback
The sketch plane the curve element lies in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Overridable Property SketchPlane As SketchPlane
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

The new sketch plane must be parallel to the existing sketch plane. Setting this property is not permitted for detail curves because they must be placed only on view-specific planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the modification failed, when the sketch plane is not parallel to the existing plane, or when this property is set on a DetailCurve.

See Also

CurveElement Class


CurveElementFilter Class

[image]

Revit 2011 API
CurveElementFilter Class
Members Example See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class CurveElementFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class CurveElementFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class CurveElementFilter : public ElementSlowFilter

Examples

CopyC#
// Create a CurveElement filter to find CurveByPoints elements.
// It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
// method OfClass() because subclasses of CurveElement are not supported by those methods.
CurveElementFilter filter = new CurveElementFilter(CurveElementType.CurveByPoints);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> founds = collector.WherePasses(filter).ToElements();

// Find all curve elements: use inverted filter with invalid CurveElementType to match elements
CurveElementFilter notCurveByPntFilter = new CurveElementFilter(CurveElementType.Invalid, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveByPntFounds = collector.WherePasses(notCurveByPntFilter).ToElements();
CopyVB.NET
' Create a CurveElement filter to find CurveByPoints elements.
' It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
' method OfClass() because subclasses of CurveElement are not supported by those methods.
Dim filter As New CurveElementFilter(CurveElementType.CurveByPoints)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim founds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find all curve elements: use inverted filter with invalid CurveElementType to match elements
Dim notCurveByPntFilter As New CurveElementFilter(CurveElementType.Invalid, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notCurveByPntFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notCurveByPntFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.CurveElementFilter

See Also

CurveElementFilter Members


CurveElementFilter Members

[image] [image]

Revit 2011 API
CurveElementFilter Members
CurveElementFilter Class Constructors Methods Properties See Also Send Feedback

The CurveElementFilter type exposes the following members.

Constructors

Name | Description
CurveElementFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveElementType | The curve element type.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class


CurveElementFilter Constructor

[image] [image]

Revit 2011 API
CurveElementFilter Constructor
CurveElementFilter Class See Also Send Feedback

Overload List

Name | Description
CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Members


CurveElementFilter Constructor (CurveElementType)

[image]

Revit 2011 API
CurveElementFilter Constructor (CurveElementType)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType
)
Visual Basic (Declaration)
Public Sub New ( _
    curveElementType As CurveElementType _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::.CurveElementType
The curve element type to match.

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Constructor (CurveElementType, Boolean)

[image]

Revit 2011 API
CurveElementFilter Constructor (CurveElementType, Boolean)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    curveElementType As CurveElementType, _
    inverted As Boolean _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::.CurveElementType
The curve element type to match.
inverted
Type: System..::.Boolean
True if the filter should match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Methods

[image] [image]

Revit 2011 API
CurveElementFilter Methods
CurveElementFilter Class See Also Send Feedback

The CurveElementFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveElementFilter Class


CurveElementFilter Properties

[image] [image]

Revit 2011 API
CurveElementFilter Properties
CurveElementFilter Class See Also Send Feedback

The CurveElementFilter type exposes the following members.

Properties

Name | Description
CurveElementType | The curve element type.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class


CurveElementType Property

[image]

Revit 2011 API
CurveElementFilter..::.CurveElementType Property
CurveElementFilter Class See Also Send Feedback
The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveElementType As CurveElementType
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElementFilter Class


CurveElementType Enumeration

[image]

Revit 2011 API
CurveElementType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum CurveElementType
Visual Basic (Declaration)
Public Enumeration CurveElementType
Visual C++
public enum class CurveElementType

Members

Member name | Description
Invalid | An invalid curve element type.
ModelCurve | A model curve.
DetailCurve | A detail curve.
SymbolicCurve | A symbolic curve.
ReferenceLine | A reference line.
SpaceSeparation | A space separation curve.
RoomSeparation | An room separation curve.
AreaSeparation | An area separation curve.
CurveByPoints | A curve created by connecting a set of points.
RepeatingDetail | The profile of a repeating detail set.
Insulation | A detail curve representing insulation.
Cloud | A portion of a revision cloud.

See Also


CurveLoopsProfile Class

[image]

Revit 2011 API
CurveLoopsProfile Class
Members See Also Send Feedback
Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic (Declaration)
Public Class CurveLoopsProfile _
    Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.CurveLoopsProfile

See Also

CurveLoopsProfile Members


CurveLoopsProfile Members

[image] [image]

Revit 2011 API
CurveLoopsProfile Members
CurveLoopsProfile Class Methods Properties See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


CurveLoopsProfile Methods

[image] [image]

Revit 2011 API
CurveLoopsProfile Methods
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoopsProfile Class


CurveLoopsProfile Properties

[image] [image]

Revit 2011 API
CurveLoopsProfile Properties
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


Profile Property

[image]

Revit 2011 API
CurveLoopsProfile..::.Profile Property
CurveLoopsProfile Class See Also Send Feedback
Returns the curve loops of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As CurveArrArray
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
    void set (CurveArrArray^ value);
}

Remarks

This property is used to retrieve the curve loops of profile.

See Also

CurveLoopsProfile Class


CurveProjectionType Enumeration

[image]

Revit 2011 API
CurveProjectionType Enumeration
See Also Send Feedback
This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum CurveProjectionType
Visual Basic (Declaration)
Public Enumeration CurveProjectionType
Visual C++
public enum class CurveProjectionType

Members

Member name | Description
FromTopDown | Projects curve in a direction parallel to the height of the project or family (projects in an upwardly or downwardly direction). For example, would be used to project curves to a surface that represented a roof or site, where the goal was for the curves to look from above as they were sketched, even though they are being mapped to the surface.
ParallelToLevel | The curves are projected to their target surface in a projection direction that is parallel to level. The exact vector of projection also considers the endpoints of the curve being projected or endpoints in a loop of curves it belongs to (if any). But the vector is always parallel to the level. This is used to create curves on the building that retain a particular sketched shape based on elevation perspective, regardless of target surface contours. Sketching windows is an example where this is useful.
FollowSurfaceUV | The curve is generated on to lie on the surface based on its endpoints/control points on the surface, its curve type, and depending on the surface type, either projecting to the surface based on projecting tesselation points of the curve to the target surface, or by interpreting the equation produced by the curve type and user defined control points in the surface uv. In some ways, this is the most robust way to generate the curve on the surface, but for some surface shapes, it can make it difficult to obtain the desired appearance from a particular perspective in the model.

See Also


CutFailureReason Enumeration

[image]

Revit 2011 API
CutFailureReason Enumeration
See Also Send Feedback
The reason why a solid/solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum CutFailureReason
Visual Basic (Declaration)
Public Enumeration CutFailureReason
Visual C++
public enum class CutFailureReason

Members

Member name | Description
CutAllowed | Yes, the making cut element can add cut to the getting cut element.
CutAlreadyExists | No, the making cut element has cut the getting cut element already.
OppositeCutExists | No, the getting cut element has cut the making cut element already.
CutNotAppropriateForElements | No, the cut is not appropriate for the two elements.

See Also


CylindricalFace Class

[image]

Revit 2011 API
CylindricalFace Class
Members Example See Also Send Feedback
A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CylindricalFace : Face
Visual Basic (Declaration)
Public Class CylindricalFace _
    Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Examples

CopyC#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetCylindricalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = cylindricalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = cylindricalFace.Origin
        Dim radius As Autodesk.Revit.DB.XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.CylindricalFace

See Also

CylindricalFace Members


CylindricalFace Members

[image] [image]

Revit 2011 API
CylindricalFace Members
CylindricalFace Class Methods Properties See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class


CylindricalFace Methods

[image] [image]

Revit 2011 API
CylindricalFace Methods
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class


Intersect Method

[image] [image]

Revit 2011 API
CylindricalFace..::.Intersect Method
CylindricalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


IsInside Method

[image] [image]

Revit 2011 API
CylindricalFace..::.IsInside Method
CylindricalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


CylindricalFace Properties

[image] [image]

Revit 2011 API
CylindricalFace Properties
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radii of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class


Axis Property

[image]

Revit 2011 API
CylindricalFace..::.Axis Property
CylindricalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Origin Property

[image]

Revit 2011 API
CylindricalFace..::.Origin Property
CylindricalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Radius Property

[image]

Revit 2011 API
CylindricalFace..::.Radius Property
CylindricalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

CylindricalFace Class


DecimalSymbolType Enumeration

[image]

Revit 2011 API
DecimalSymbolType Enumeration
See Also Send Feedback
An enumerated type listing two types of the Decimal Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DecimalSymbolType
Visual Basic (Declaration)
Public Enumeration DecimalSymbolType
Visual C++
public enum class DecimalSymbolType

Members

Member name | Description
DST_DOT |
DST_COMMA |

See Also


Definition Class

[image]

Revit 2011 API
Definition Class
Members See Also Send Feedback
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class Definition : APIObject
Visual Basic (Declaration)
Public MustInherit Class Definition _
    Inherits APIObject
Visual C++
public ref class Definition abstract : public APIObject

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilize this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Definition
Autodesk.Revit.DB..::.ExternalDefinition
Autodesk.Revit.DB..::.InternalDefinition

See Also

Definition Members


Definition Members

[image] [image]

Revit 2011 API
Definition Members
Definition Class Methods Properties See Also Send Feedback

The Definition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter.
ParameterGroup | Returns the group ID of the parameter definition.
ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class


Definition Methods

[image] [image]

Revit 2011 API
Definition Methods
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definition Class


Definition Properties

[image] [image]

Revit 2011 API
Definition Properties
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter.
ParameterGroup | Returns the group ID of the parameter definition.
ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class


Name Property

[image]

Revit 2011 API
Definition..::.Name Property
Definition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract string Name { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

See Also

Definition Class


ParameterGroup Property

[image]

Revit 2011 API
Definition..::.ParameterGroup Property
Definition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () abstract;
}

See Also

Definition Class


ParameterType Property

[image]

Revit 2011 API
Definition..::.ParameterType Property
Definition Class Example See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

Examples

CopyC#
//Find parameter using the Parameter�s definition type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.ParameterType == ParameterType.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
CopyVB.NET
'Find parameter using the Parameter's definition type.
Public Function FindParameter(ByVal element As Autodesk.Revit.DB.Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.ParameterType = ParameterType.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

See Also

Definition Class


DefinitionBindingMap Class

[image]

Revit 2011 API
DefinitionBindingMap Class
Members See Also Send Feedback
A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionBindingMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionBindingMap
Autodesk.Revit.DB..::.BindingMap

See Also

DefinitionBindingMap Members


DefinitionBindingMap Members

[image] [image]

Revit 2011 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

Name | Description
DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Constructor

[image]

Revit 2011 API
DefinitionBindingMap Constructor
DefinitionBindingMap Class See Also Send Feedback
Initializes a new instance of the DefinitionBindingMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionBindingMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMap()

See Also

DefinitionBindingMap Class


DefinitionBindingMap Methods

[image] [image]

Revit 2011 API
DefinitionBindingMap Methods
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Methods

Name | Description
Clear | Removes every binding from the map, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMap Class


Clear Method

[image]

Revit 2011 API
DefinitionBindingMap..::.Clear Method
DefinitionBindingMap Class See Also Send Feedback
Removes every binding from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionBindingMap Class


Contains Method

[image]

Revit 2011 API
DefinitionBindingMap..::.Contains Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition

See Also

DefinitionBindingMap Class


Erase Method

[image]

Revit 2011 API
DefinitionBindingMap..::.Erase Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Definition key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition

See Also

DefinitionBindingMap Class


ForwardIterator Method

[image]

Revit 2011 API
DefinitionBindingMap..::.ForwardIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class


GetEnumerator Method

[image]

Revit 2011 API
DefinitionBindingMap..::.GetEnumerator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionBindingMap Class


Insert Method

[image]

Revit 2011 API
DefinitionBindingMap..::.Insert Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::.Definition
item
Type: Autodesk.Revit.DB..::.Binding

See Also

DefinitionBindingMap Class


ReverseIterator Method

[image]

Revit 2011 API
DefinitionBindingMap..::.ReverseIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Properties

[image] [image]

Revit 2011 API
DefinitionBindingMap Properties
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


IsEmpty Property

[image]

Revit 2011 API
DefinitionBindingMap..::.IsEmpty Property
DefinitionBindingMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

DefinitionBindingMap Class


Item Property

[image]

Revit 2011 API
DefinitionBindingMap..::.Item Property
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Binding Item[
    Definition key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As Definition _
) As Binding
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Type: Autodesk.Revit.DB..::.Definition

See Also

DefinitionBindingMap Class


Size Property

[image]

Revit 2011 API
DefinitionBindingMap..::.Size Property
DefinitionBindingMap Class See Also Send Feedback
Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionBindingMap Class


DefinitionBindingMapIterator Class

[image]

Revit 2011 API
DefinitionBindingMapIterator Class
Members See Also Send Feedback
An iterator to a parameter definition to parameter bindings map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DefinitionBindingMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionBindingMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionBindingMapIterator

See Also

DefinitionBindingMapIterator Members


DefinitionBindingMapIterator Members

[image] [image]

Revit 2011 API
DefinitionBindingMapIterator Members
DefinitionBindingMapIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Constructors

Name | Description
DefinitionBindingMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the binding that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Constructor

[image]

Revit 2011 API
DefinitionBindingMapIterator Constructor
DefinitionBindingMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionBindingMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionBindingMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Methods

[image] [image]

Revit 2011 API
DefinitionBindingMapIterator Methods
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMapIterator Class


MoveNext Method

[image]

Revit 2011 API
DefinitionBindingMapIterator..::.MoveNext Method
DefinitionBindingMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


Reset Method

[image]

Revit 2011 API
DefinitionBindingMapIterator..::.Reset Method
DefinitionBindingMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Properties

[image] [image]

Revit 2011 API
DefinitionBindingMapIterator Properties
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the binding that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class


Current Property

[image]

Revit 2011 API
DefinitionBindingMapIterator..::.Current Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


Key Property

[image]

Revit 2011 API
DefinitionBindingMapIterator..::.Key Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the definition that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Definition Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As Definition
Visual C++
public:
virtual property Definition^ Key {
    Definition^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


DefinitionFile Class

[image]

Revit 2011 API
DefinitionFile Class
Members Example See Also Send Feedback
The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionFile : APIObject
Visual Basic (Declaration)
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Application.OpenSharedParameterFile method.

Examples

CopyC#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    TaskDialog.Show("Revit",fileInformation.ToString());
}
CopyVB.NET
Private Sub ShowDefinitionFileInfo(ByVal myDefinitionFile As DefinitionFile)
    Dim fileInformation As New StringBuilder(500)

    ' get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename)

    ' iterate the Definition groups of this file
    For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
        ' get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name)

        ' iterate the difinitions
        For Each definition As Definition In myGroup.Definitions
            ' get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name)
        Next
    Next
    TaskDialog.Show("Revit", fileInformation.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionFile

See Also

DefinitionFile Members


DefinitionFile Members

[image] [image]

Revit 2011 API
DefinitionFile Members
DefinitionFile Class Methods Properties See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filename | This property returns the physical filename of the shared parameters file on disk.
Groups | Return a map of shared parameter definition groups contained within the file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class


DefinitionFile Methods

[image] [image]

Revit 2011 API
DefinitionFile Methods
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionFile Class


DefinitionFile Properties

[image] [image]

Revit 2011 API
DefinitionFile Properties
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Properties

Name | Description
Filename | This property returns the physical filename of the shared parameters file on disk.
Groups | Return a map of shared parameter definition groups contained within the file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class


Filename Property

[image]

Revit 2011 API
DefinitionFile..::.Filename Property
DefinitionFile Class See Also Send Feedback
This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
}

See Also

DefinitionFile Class


Groups Property

[image]

Revit 2011 API
DefinitionFile..::.Groups Property
DefinitionFile Class See Also Send Feedback
Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroups Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As DefinitionGroups
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class


DefinitionGroup Class

[image]

Revit 2011 API
DefinitionGroup Class
Members See Also Send Feedback
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionGroup : APIObject
Visual Basic (Declaration)
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionGroup

See Also

DefinitionGroup Members


DefinitionGroup Members

[image] [image]

Revit 2011 API
DefinitionGroup Members
DefinitionGroup Class Methods Properties See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


DefinitionGroup Methods

[image] [image]

Revit 2011 API
DefinitionGroup Methods
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroup Class


DefinitionGroup Properties

[image] [image]

Revit 2011 API
DefinitionGroup Properties
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Properties

Name | Description
Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


Definitions Property

[image]

Revit 2011 API
DefinitionGroup..::.Definitions Property
DefinitionGroup Class See Also Send Feedback
The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definitions Definitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definitions As Definitions
Visual C++
public:
property Definitions^ Definitions {
    Definitions^ get ();
}

Remarks

A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.

See Also

DefinitionGroup Class


Name Property

[image]

Revit 2011 API
DefinitionGroup..::.Name Property
DefinitionGroup Class See Also Send Feedback
Returns the name of the parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

DefinitionGroup Class


DefinitionGroups Class

[image]

Revit 2011 API
DefinitionGroups Class
Members See Also Send Feedback
A specialized set of definition groups that allows creation of new groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionGroups : DefinitionGroupsBase
Visual Basic (Declaration)
Public Class DefinitionGroups _
    Inherits DefinitionGroupsBase
Visual C++
public ref class DefinitionGroups : public DefinitionGroupsBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionGroupsBase
Autodesk.Revit.DB..::.DefinitionGroups

See Also

DefinitionGroups Members


DefinitionGroups Members

[image] [image]

Revit 2011 API
DefinitionGroups Members
DefinitionGroups Class Methods Properties See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Create | Create a new parameter definition group using the name provided.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition group by name.
Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups Class


DefinitionGroups Methods

[image] [image]

Revit 2011 API
DefinitionGroups Methods
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty. (Inherited from DefinitionGroupsBase.)
Contains | Tests for the existence of a definition group within the set. (Inherited from DefinitionGroupsBase.)
Create | Create a new parameter definition group using the name provided.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionGroupsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroups Class


Create Method

[image]

Revit 2011 API
DefinitionGroups..::.Create Method
DefinitionGroups Class See Also Send Feedback
Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class


DefinitionGroups Properties

[image] [image]

Revit 2011 API
DefinitionGroups Properties
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionGroupsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition group by name.
Size | Returns the number of definition groups that are in the set. (Inherited from DefinitionGroupsBase.)

See Also

DefinitionGroups Class


Item Property

[image]

Revit 2011 API
DefinitionGroups..::.Item Property
DefinitionGroups Class See Also Send Feedback
Retrieve a definition group by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroup Item[
    string groupName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    groupName As String _
) As DefinitionGroup
Visual C++
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}

Parameters

groupName
Type: System..::.String
The name of the group for which to search.

Remarks

If the group is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

DefinitionGroups Class


DefinitionGroupsBase Class

[image]

Revit 2011 API
DefinitionGroupsBase Class
Members See Also Send Feedback
A set that contains definition groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionGroupsBase : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionGroupsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionGroupsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionGroupsBase
Autodesk.Revit.DB..::.DefinitionGroups

See Also

DefinitionGroupsBase Members


DefinitionGroupsBase Members

[image] [image]

Revit 2011 API
DefinitionGroupsBase Members
DefinitionGroupsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Constructors

Name | Description
DefinitionGroupsBase | Initializes a new instance of the DefinitionGroupsBase class

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty.
Contains | Tests for the existence of a definition group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase Class


DefinitionGroupsBase Constructor

[image]

Revit 2011 API
DefinitionGroupsBase Constructor
DefinitionGroupsBase Class See Also Send Feedback
Initializes a new instance of the DefinitionGroupsBase class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroupsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBase()

See Also

DefinitionGroupsBase Class


DefinitionGroupsBase Methods

[image] [image]

Revit 2011 API
DefinitionGroupsBase Methods
DefinitionGroupsBase Class See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Methods

Name | Description
Clear | Removes every definition group from the set, rendering it empty.
Contains | Tests for the existence of a definition group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroupsBase Class


Clear Method

[image]

Revit 2011 API
DefinitionGroupsBase..::.Clear Method
DefinitionGroupsBase Class See Also Send Feedback
Removes every definition group from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionGroupsBase Class


Contains Method

[image]

Revit 2011 API
DefinitionGroupsBase..::.Contains Method
DefinitionGroupsBase Class See Also Send Feedback
Tests for the existence of a definition group within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    DefinitionGroup item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DefinitionGroup _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DefinitionGroup^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DefinitionGroup
The definition group to be searched for.

Return Value

The Contains method returns True if the definition group is within the set, otherwise False.

See Also

DefinitionGroupsBase Class


ForwardIterator Method

[image]

Revit 2011 API
DefinitionGroupsBase..::.ForwardIterator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionGroupsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionGroupsBase Class


GetEnumerator Method

[image]

Revit 2011 API
DefinitionGroupsBase..::.GetEnumerator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionGroupsBase Class


ReverseIterator Method

[image]

Revit 2011 API
DefinitionGroupsBase..::.ReverseIterator Method
DefinitionGroupsBase Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionGroupsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionGroupsBaseIterator
Visual C++
public:
virtual DefinitionGroupsBaseIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionGroupsBase Class


DefinitionGroupsBase Properties

[image] [image]

Revit 2011 API
DefinitionGroupsBase Properties
DefinitionGroupsBase Class See Also Send Feedback

The DefinitionGroupsBase type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definition groups that are in the set.

See Also

DefinitionGroupsBase Class


IsEmpty Property

[image]

Revit 2011 API
DefinitionGroupsBase..::.IsEmpty Property
DefinitionGroupsBase Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionGroupsBase Class


Size Property

[image]

Revit 2011 API
DefinitionGroupsBase..::.Size Property
DefinitionGroupsBase Class See Also Send Feedback
Returns the number of definition groups that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionGroupsBase Class


DefinitionGroupsBaseIterator Class

[image]

Revit 2011 API
DefinitionGroupsBaseIterator Class
Members See Also Send Feedback
An iterator to a definition group set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DefinitionGroupsBaseIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionGroupsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionGroupsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionGroupsBaseIterator

See Also

DefinitionGroupsBaseIterator Members


DefinitionGroupsBaseIterator Members

[image] [image]

Revit 2011 API
DefinitionGroupsBaseIterator Members
DefinitionGroupsBaseIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Constructors

Name | Description
DefinitionGroupsBaseIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator Class


DefinitionGroupsBaseIterator Constructor

[image]

Revit 2011 API
DefinitionGroupsBaseIterator Constructor
DefinitionGroupsBaseIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionGroupsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionGroupsBaseIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionGroupsBaseIterator Class


DefinitionGroupsBaseIterator Methods

[image] [image]

Revit 2011 API
DefinitionGroupsBaseIterator Methods
DefinitionGroupsBaseIterator Class See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroupsBaseIterator Class


MoveNext Method

[image]

Revit 2011 API
DefinitionGroupsBaseIterator..::.MoveNext Method
DefinitionGroupsBaseIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class


Reset Method

[image]

Revit 2011 API
DefinitionGroupsBaseIterator..::.Reset Method
DefinitionGroupsBaseIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionGroupsBaseIterator Class


DefinitionGroupsBaseIterator Properties

[image] [image]

Revit 2011 API
DefinitionGroupsBaseIterator Properties
DefinitionGroupsBaseIterator Class See Also Send Feedback

The DefinitionGroupsBaseIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionGroupsBaseIterator Class


Current Property

[image]

Revit 2011 API
DefinitionGroupsBaseIterator..::.Current Property
DefinitionGroupsBaseIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionGroupsBaseIterator Class


Definitions Class

[image]

Revit 2011 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Definitions : DefinitionsBase
Visual Basic (Declaration)
Public Class Definitions _
    Inherits DefinitionsBase
Visual C++
public ref class Definitions : public DefinitionsBase

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.Definitions
Autodesk.Revit.DB..::.ExternalDefinitions
Autodesk.Revit.DB..::.InternalDefinitions

See Also

Definitions Members


Definitions Members

[image] [image]

Revit 2011 API
Definitions Members
Definitions Class Constructors Methods Properties See Also Send Feedback

The Definitions type exposes the following members.

Constructors

Name | Description
Definitions | Construct an empty set of parameter definitions.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name.
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions Class


Definitions Constructor

[image]

Revit 2011 API
Definitions Constructor
Definitions Class See Also Send Feedback
Construct an empty set of parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Definitions()

See Also

Definitions Class


Definitions Methods

[image] [image]

Revit 2011 API
Definitions Methods
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definitions Class


Create Method

[image] [image]

Revit 2011 API
Definitions..::.Create Method
Definitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type.

See Also

Definitions Class
Definitions Members


Create Method (String, ParameterType)

[image]

Revit 2011 API
Definitions..::.Create Method (String, ParameterType)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name, type and visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type
)

Parameters

name
Type: System..::.String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB..::.ParameterType
The name of the parameter type for the new definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload


Create Method (String, ParameterType, Boolean)

[image]

Revit 2011 API
Definitions..::.Create Method (String, ParameterType, Boolean)
Definitions Class See Also Send Feedback
Creates a new user visible parameter definition using name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic (Declaration)
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
Type: System..::.String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB..::.ParameterType
The name of the parameter type for the new definition.
visible
Type: System..::.Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload


Definitions Properties

[image] [image]

Revit 2011 API
Definitions Properties
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name.
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

Definitions Class


Item Property

[image]

Revit 2011 API
Definitions..::.Item Property
Definitions Class See Also Send Feedback
Retrieve a definition by a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Item[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Definition
Visual C++
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}

Parameters

name
Type: System..::.String
The name of the parameter definition for which to search.

Remarks

If the definition is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

Definitions Class


DefinitionsBase Class

[image]

Revit 2011 API
DefinitionsBase Class
Members See Also Send Feedback
A set that contains definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DefinitionsBase : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DefinitionsBase _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionsBase : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.Definitions

See Also

DefinitionsBase Members


DefinitionsBase Members

[image] [image]

Revit 2011 API
DefinitionsBase Members
DefinitionsBase Class Constructors Methods Properties See Also Send Feedback

The DefinitionsBase type exposes the following members.

Constructors

Name | Description
DefinitionsBase | Initializes a new instance of the DefinitionsBase class

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class


DefinitionsBase Constructor

[image]

Revit 2011 API
DefinitionsBase Constructor
DefinitionsBase Class See Also Send Feedback
Initializes a new instance of the DefinitionsBase class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionsBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBase()

See Also

DefinitionsBase Class


DefinitionsBase Methods

[image] [image]

Revit 2011 API
DefinitionsBase Methods
DefinitionsBase Class See Also Send Feedback

The DefinitionsBase type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty.
Contains | Tests for the existence of a definition within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionsBase Class


Clear Method

[image]

Revit 2011 API
DefinitionsBase..::.Clear Method
DefinitionsBase Class See Also Send Feedback
Removes every definition from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionsBase Class


Contains Method

[image]

Revit 2011 API
DefinitionsBase..::.Contains Method
DefinitionsBase Class See Also Send Feedback
Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Definition
The definition to be searched for.

Return Value

The Contains method returns True if the definition is within the set, otherwise False.

See Also

DefinitionsBase Class


Erase Method

[image]

Revit 2011 API
DefinitionsBase..::.Erase Method
DefinitionsBase Class See Also Send Feedback
Removes a specified definition from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Definition
The definition to be erased.

Return Value

The number of definitions that were erased from the set.

See Also

DefinitionsBase Class


ForwardIterator Method

[image]

Revit 2011 API
DefinitionsBase..::.ForwardIterator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionsBaseIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DefinitionsBase Class


GetEnumerator Method

[image]

Revit 2011 API
DefinitionsBase..::.GetEnumerator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DefinitionsBase Class


Insert Method

[image]

Revit 2011 API
DefinitionsBase..::.Insert Method
DefinitionsBase Class See Also Send Feedback
Insert the specified definition into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Definition _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Definition
The definition to be inserted into the set.

Return Value

Returns whether the definition was inserted into the set.

See Also

DefinitionsBase Class


ReverseIterator Method

[image]

Revit 2011 API
DefinitionsBase..::.ReverseIterator Method
DefinitionsBase Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionsBaseIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DefinitionsBaseIterator
Visual C++
public:
virtual DefinitionsBaseIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DefinitionsBase Class


DefinitionsBase Properties

[image] [image]

Revit 2011 API
DefinitionsBase Properties
DefinitionsBase Class See Also Send Feedback

The DefinitionsBase type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of definitions that are in the set.

See Also

DefinitionsBase Class


IsEmpty Property

[image]

Revit 2011 API
DefinitionsBase..::.IsEmpty Property
DefinitionsBase Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DefinitionsBase Class


Size Property

[image]

Revit 2011 API
DefinitionsBase..::.Size Property
DefinitionsBase Class See Also Send Feedback
Returns the number of definitions that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionsBase Class


DefinitionsBaseIterator Class

[image]

Revit 2011 API
DefinitionsBaseIterator Class
Members See Also Send Feedback
An iterator to a definition set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DefinitionsBaseIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DefinitionsBaseIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionsBaseIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBaseIterator

See Also

DefinitionsBaseIterator Members


DefinitionsBaseIterator Members

[image] [image]

Revit 2011 API
DefinitionsBaseIterator Members
DefinitionsBaseIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Constructors

Name | Description
DefinitionsBaseIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator Class


DefinitionsBaseIterator Constructor

[image]

Revit 2011 API
DefinitionsBaseIterator Constructor
DefinitionsBaseIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DefinitionsBaseIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefinitionsBaseIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionsBaseIterator Class


DefinitionsBaseIterator Methods

[image] [image]

Revit 2011 API
DefinitionsBaseIterator Methods
DefinitionsBaseIterator Class See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionsBaseIterator Class


MoveNext Method

[image]

Revit 2011 API
DefinitionsBaseIterator..::.MoveNext Method
DefinitionsBaseIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class


Reset Method

[image]

Revit 2011 API
DefinitionsBaseIterator..::.Reset Method
DefinitionsBaseIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionsBaseIterator Class


DefinitionsBaseIterator Properties

[image] [image]

Revit 2011 API
DefinitionsBaseIterator Properties
DefinitionsBaseIterator Class See Also Send Feedback

The DefinitionsBaseIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionsBaseIterator Class


Current Property

[image]

Revit 2011 API
DefinitionsBaseIterator..::.Current Property
DefinitionsBaseIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionsBaseIterator Class


DeleteElements Class

[image]

Revit 2011 API
DeleteElements Class
Members See Also Send Feedback
Deletes element(s) related to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class DeleteElements : FailureResolution
Visual Basic (Declaration)
Public Class DeleteElements _
    Inherits FailureResolution
Visual C++
public ref class DeleteElements : public FailureResolution

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureResolution
Autodesk.Revit.DB..::.DeleteElements

See Also

DeleteElements Members


DeleteElements Members

[image] [image]

Revit 2011 API
DeleteElements Members
DeleteElements Class Methods See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

Name | Description
Create | Overloaded.
Dispose | (Inherited from FailureResolution.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteElements Class


DeleteElements Methods

[image] [image]

Revit 2011 API
DeleteElements Methods
DeleteElements Class See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

Name | Description
Create | Overloaded.
Dispose | (Inherited from FailureResolution.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteElements Class


Create Method

[image] [image]

Revit 2011 API
DeleteElements..::.Create Method
DeleteElements Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
Create(Document, IList<(Of <(ElementId>)>)) | Creates an instance of the DeleteElements resolution.

See Also

DeleteElements Class
DeleteElements Members


Create Method (Document, ElementId)

[image]

Revit 2011 API
DeleteElements..::.Create Method (Document, ElementId)
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    ElementId id
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    id As ElementId _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document which owns the element to delete.
id
Type: Autodesk.Revit.DB..::.ElementId
The id of the element that will be deleted when this resolution is chosen.

Return Value

The instance of the DeletedElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input id is not valid for deletion.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DeleteElements Class
Create Overload


Create Method (Document, IList(ElementId))

[image]

Revit 2011 API
DeleteElements..::.Create Method (Document, IList<(Of <(ElementId>)>))
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    IList<ElementId> ids
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    ids As IList(Of ElementId) _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    IList<ElementId^>^ ids
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document which owns the elements to delete.
ids
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

The instance of the DeleteElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input ids is empty or contains an invalid element id.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DeleteElements Class
Create Overload


DesignOption Class

[image]

Revit 2011 API
DesignOption Class
Members See Also Send Feedback
An element that represents a design alternative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DesignOption : Element
Visual Basic (Declaration)
Public Class DesignOption _
    Inherits Element
Visual C++
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.DesignOption

See Also

DesignOption Members


DesignOption Members

[image] [image]

Revit 2011 API
DesignOption Members
DesignOption Class Methods Properties See Also Send Feedback

The DesignOption type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetActiveDesignOptionId | Gets the active design option id for the current design option set.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Determines whether this is a primary design option.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DesignOption Class


DesignOption Methods

[image] [image]

Revit 2011 API
DesignOption Methods
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetActiveDesignOptionId | Gets the active design option id for the current design option set.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignOption Class


GetActiveDesignOptionId Method

[image]

Revit 2011 API
DesignOption..::.GetActiveDesignOptionId Method
DesignOption Class See Also Send Feedback
Gets the active design option id for the current design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetActiveDesignOptionId(
    Document document
)
Visual Basic (Declaration)
Public Shared Function GetActiveDesignOptionId ( _
    document As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetActiveDesignOptionId(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

The active design option id. It can be invalid id if there is no active design option in the model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DesignOption Class


DesignOption Properties

[image] [image]

Revit 2011 API
DesignOption Properties
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Determines whether this is a primary design option.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DesignOption Class


IsPrimary Property

[image]

Revit 2011 API
DesignOption..::.IsPrimary Property
DesignOption Class See Also Send Feedback
Determines whether this is a primary design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

DesignOption Class


Parameter Property

[image] [image]

Revit 2011 API
DesignOption..::.Parameter Property
DesignOption Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DesignOption Class
DesignOption Members


DetailArc Class

[image]

Revit 2011 API
DetailArc Class
Members See Also Send Feedback
Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailArc : DetailCurve
Visual Basic (Declaration)
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailArc

See Also

DetailArc Members


DetailArc Members

[image] [image]

Revit 2011 API
DetailArc Members
DetailArc Class Methods Properties See Also Send Feedback

The DetailArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailArc Class


DetailArc Methods

[image] [image]

Revit 2011 API
DetailArc Methods
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailArc Class


DetailArc Properties

[image] [image]

Revit 2011 API
DetailArc Properties
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailArc Class


Parameter Property

[image] [image]

Revit 2011 API
DetailArc..::.Parameter Property
DetailArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailArc Class
DetailArc Members


DetailCurve Class

[image]

Revit 2011 API
DetailCurve Class
Members See Also Send Feedback
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailCurve : CurveElement
Visual Basic (Declaration)
Public Class DetailCurve _
    Inherits CurveElement
Visual C++
public ref class DetailCurve : public CurveElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailArc
Autodesk.Revit.DB..::.DetailEllipse
Autodesk.Revit.DB..::.DetailLine
Autodesk.Revit.DB..::.DetailNurbSpline

See Also

DetailCurve Members


DetailCurve Members

[image] [image]

Revit 2011 API
DetailCurve Members
DetailCurve Class Methods Properties See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailCurve Class


DetailCurve Methods

[image] [image]

Revit 2011 API
DetailCurve Methods
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurve Class


DetailCurve Properties

[image] [image]

Revit 2011 API
DetailCurve Properties
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailCurve Class


Parameter Property

[image] [image]

Revit 2011 API
DetailCurve..::.Parameter Property
DetailCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailCurve Class
DetailCurve Members


DetailCurveArray Class

[image]

Revit 2011 API
DetailCurveArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailCurveArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DetailCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DetailCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DetailCurveArray

See Also

DetailCurveArray Members


DetailCurveArray Members

[image] [image]

Revit 2011 API
DetailCurveArray Members
DetailCurveArray Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArray type exposes the following members.

Constructors

Name | Description
DetailCurveArray | Initializes a new instance of the DetailCurveArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


DetailCurveArray Constructor

[image]

Revit 2011 API
DetailCurveArray Constructor
DetailCurveArray Class See Also Send Feedback
Initializes a new instance of the DetailCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArray()

See Also

DetailCurveArray Class


DetailCurveArray Methods

[image] [image]

Revit 2011 API
DetailCurveArray Methods
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArray Class


Append Method

[image]

Revit 2011 API
DetailCurveArray..::.Append Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    DetailCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As DetailCurve _
)
Visual C++
public:
virtual void Append(
    DetailCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DetailCurve

See Also

DetailCurveArray Class


Clear Method

[image]

Revit 2011 API
DetailCurveArray..::.Clear Method
DetailCurveArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DetailCurveArray Class


ForwardIterator Method

[image]

Revit 2011 API
DetailCurveArray..::.ForwardIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class


GetEnumerator Method

[image]

Revit 2011 API
DetailCurveArray..::.GetEnumerator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DetailCurveArray Class


Insert Method

[image]

Revit 2011 API
DetailCurveArray..::.Insert Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    DetailCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DetailCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DetailCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.DetailCurve
index
Type: System..::.Int32

See Also

DetailCurveArray Class


ReverseIterator Method

[image]

Revit 2011 API
DetailCurveArray..::.ReverseIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DetailCurveArray Class


DetailCurveArray Properties

[image] [image]

Revit 2011 API
DetailCurveArray Properties
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


IsEmpty Property

[image]

Revit 2011 API
DetailCurveArray..::.IsEmpty Property
DetailCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DetailCurveArray Class


Item Property

[image]

Revit 2011 API
DetailCurveArray..::.Item Property
DetailCurveArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DetailCurve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As DetailCurve
Visual C++
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DetailCurveArray Class


Size Property

[image]

Revit 2011 API
DetailCurveArray..::.Size Property
DetailCurveArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DetailCurveArray Class


DetailCurveArrayIterator Class

[image]

Revit 2011 API
DetailCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DetailCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DetailCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DetailCurveArrayIterator

See Also

DetailCurveArrayIterator Members


DetailCurveArrayIterator Members

[image] [image]

Revit 2011 API
DetailCurveArrayIterator Members
DetailCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Constructors

Name | Description
DetailCurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Constructor

[image]

Revit 2011 API
DetailCurveArrayIterator Constructor
DetailCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Methods

[image] [image]

Revit 2011 API
DetailCurveArrayIterator Methods
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
DetailCurveArrayIterator..::.MoveNext Method
DetailCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


Reset Method

[image]

Revit 2011 API
DetailCurveArrayIterator..::.Reset Method
DetailCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Properties

[image] [image]

Revit 2011 API
DetailCurveArrayIterator Properties
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


Current Property

[image]

Revit 2011 API
DetailCurveArrayIterator..::.Current Property
DetailCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


DetailEllipse Class

[image]

Revit 2011 API
DetailEllipse Class
Members See Also Send Feedback
Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailEllipse : DetailCurve
Visual Basic (Declaration)
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailEllipse

See Also

DetailEllipse Members


DetailEllipse Members

[image] [image]

Revit 2011 API
DetailEllipse Members
DetailEllipse Class Methods Properties See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailEllipse Class


DetailEllipse Methods

[image] [image]

Revit 2011 API
DetailEllipse Methods
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailEllipse Class


DetailEllipse Properties

[image] [image]

Revit 2011 API
DetailEllipse Properties
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailEllipse Class


Parameter Property

[image] [image]

Revit 2011 API
DetailEllipse..::.Parameter Property
DetailEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailEllipse Class
DetailEllipse Members


DetailLevels Enumeration

[image]

Revit 2011 API
DetailLevels Enumeration
See Also Send Feedback
Chooses the detail level of an element's representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DetailLevels
Visual Basic (Declaration)
Public Enumeration DetailLevels
Visual C++
public enum class DetailLevels

Members

Member name | Description
Undefined | May produce all or none of the available representations.
Coarse | Corresponds to the coarse view detail setting.
Medium | Corresponds to the medium view detail setting.
Fine | Corresponds to the fine view detail setting.
MAX | The value is used to check whether the enum is the same size as the internal one.

Remarks

This corresponds to detail levels in Revit's views and families.

See Also


DetailLine Class

[image]

Revit 2011 API
DetailLine Class
Members See Also Send Feedback
Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailLine : DetailCurve
Visual Basic (Declaration)
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailLine

See Also

DetailLine Members


DetailLine Members

[image] [image]

Revit 2011 API
DetailLine Members
DetailLine Class Methods Properties See Also Send Feedback

The DetailLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailLine Class


DetailLine Methods

[image] [image]

Revit 2011 API
DetailLine Methods
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailLine Class


DetailLine Properties

[image] [image]

Revit 2011 API
DetailLine Properties
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailLine Class


Parameter Property

[image] [image]

Revit 2011 API
DetailLine..::.Parameter Property
DetailLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailLine Class
DetailLine Members


DetailNurbSpline Class

[image]

Revit 2011 API
DetailNurbSpline Class
Members See Also Send Feedback
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic (Declaration)
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DetailCurve
Autodesk.Revit.DB..::.DetailNurbSpline

See Also

DetailNurbSpline Members


DetailNurbSpline Members

[image] [image]

Revit 2011 API
DetailNurbSpline Members
DetailNurbSpline Class Methods Properties See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailNurbSpline Class


DetailNurbSpline Methods

[image] [image]

Revit 2011 API
DetailNurbSpline Methods
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailNurbSpline Class


DetailNurbSpline Properties

[image] [image]

Revit 2011 API
DetailNurbSpline Properties
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DetailNurbSpline Class


Parameter Property

[image] [image]

Revit 2011 API
DetailNurbSpline..::.Parameter Property
DetailNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DetailNurbSpline Class
DetailNurbSpline Members


DGNExportOptions Class

[image]

Revit 2011 API
DGNExportOptions Class
Members See Also Send Feedback
DGN Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DGNExportOptions : CADExportOptions
Visual Basic (Declaration)
Public Class DGNExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class DGNExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.DGNExportOptions

See Also

DGNExportOptions Members


DGNExportOptions Members

[image] [image]

Revit 2011 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNExportOptions type exposes the following members.

Constructors

Name | Description
DGNExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportOfSolids | Mode of exporting solids in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
TemplateFile | The template file for DGN export.

See Also

DGNExportOptions Class


DGNExportOptions Constructor

[image]

Revit 2011 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DGNExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DGNExportOptions()

See Also

DGNExportOptions Class


DGNExportOptions Methods

[image] [image]

Revit 2011 API
DGNExportOptions Methods
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DGNExportOptions Class


DGNExportOptions Properties

[image] [image]

Revit 2011 API
DGNExportOptions Properties
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Properties

Name | Description
ExportOfSolids | Mode of exporting solids in 3D views.
LayerMapping | Name of a layer settings standard or filename (with custom layer settings).
TemplateFile | The template file for DGN export.

See Also

DGNExportOptions Class


ExportOfSolids Property

[image]

Revit 2011 API
DGNExportOptions..::.ExportOfSolids Property
DGNExportOptions Class See Also Send Feedback
Mode of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic (Declaration)
Public Property ExportOfSolids As SolidGeometry
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

See Also

DGNExportOptions Class


LayerMapping Property

[image]

Revit 2011 API
DGNExportOptions..::.LayerMapping Property
DGNExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic (Declaration)
Public Property LayerMapping As String
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Remarks

Valid standards are: AIA, CP83, BS1192, and ISO13567.

See Also

DGNExportOptions Class


TemplateFile Property

[image]

Revit 2011 API
DGNExportOptions..::.TemplateFile Property
DGNExportOptions Class See Also Send Feedback
The template file for DGN export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string TemplateFile { get; set; }
Visual Basic (Declaration)
Public Property TemplateFile As String
Visual C++
public:
property String^ TemplateFile {
    String^ get ();
    void set (String^ value);
}

Remarks

It must be a .dgn template, and it's optional, can be empty.

See Also

DGNExportOptions Class


DigitGroupingAmount Enumeration

[image]

Revit 2011 API
DigitGroupingAmount Enumeration
See Also Send Feedback
An enumerated type listing the types of the Digit Grouping Amount that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DigitGroupingAmount
Visual Basic (Declaration)
Public Enumeration DigitGroupingAmount
Visual C++
public enum class DigitGroupingAmount

Members

Member name | Description
DGA_TWO |
DGA_THREE |

See Also


DigitGroupingSymbolType Enumeration

[image]

Revit 2011 API
DigitGroupingSymbolType Enumeration
See Also Send Feedback
An enumerated type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DigitGroupingSymbolType
Visual Basic (Declaration)
Public Enumeration DigitGroupingSymbolType
Visual C++
public enum class DigitGroupingSymbolType

Members

Member name | Description
DGST_DOT |
DGST_COMMA |
DGST_SPACE |
DGST_TICK |

See Also


Dimension Class

[image]

Revit 2011 API
Dimension Class
Members Example See Also Send Feedback
An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Dimension : Element
Visual Basic (Declaration)
Public Class Dimension _
    Inherits Element
Visual C++
public ref class Dimension : public Element

Examples

CopyC#
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
             + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
             + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.ViewName;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if ((int)BuiltInCategory.OST_Dimensions == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if ((int)BuiltInCategory.OST_Constraints == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a constraint element.";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Dimension(ByVal dimension As Autodesk.Revit.DB.Dimension)
    Dim message As String = "Dimension : "
    ' Get Dimension name
    message += vbLf & "Dimension name is : " + dimension.Name

    ' Get Dimension Curve
    Dim curve As Autodesk.Revit.DB.Curve = dimension.Curve
    If curve IsNot Nothing AndAlso curve.IsBound Then
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    End If

    ' Get Dimension type name
    message += vbLf & "Dimension type name is : " + dimension.DimensionType.Name

    ' Get Dimension view name
    message += vbLf & "Dimension view name is : " + dimension.View.ViewName

    ' Get Dimension reference count
    message += vbLf & "Dimension references count is " + dimension.References.Size

    If DirectCast(BuiltInCategory.OST_Dimensions, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a permanent dimension."
    ElseIf DirectCast(BuiltInCategory.OST_Constraints, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a constraint element."
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Dimension
Autodesk.Revit.DB..::.SpotDimension

See Also

Dimension Members


Dimension Members

[image] [image]

Revit 2011 API
Dimension Members
Dimension Class Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked.
Label | The family parameter label of the dimension.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Dimension Class


Dimension Methods

[image] [image]

Revit 2011 API
Dimension Methods
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dimension Class


Dimension Properties

[image] [image]

Revit 2011 API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension.
DimensionType | The dimension style of this dimension.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked.
Label | The family parameter label of the dimension.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension.
NumberOfSegments | The number of segments for the dimension.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached.
Segments | The segments in the dimension.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension.
ValueString | The dimension value as a user visible string.
View | Supplies the view that contains the dimension if the dimension is view specific.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Dimension Class


AreSegmentsEqual Property

[image]

Revit 2011 API
Dimension..::.AreSegmentsEqual Property
Dimension Class See Also Send Feedback
Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AreSegmentsEqual { get; set; }
Visual Basic (Declaration)
Public Property AreSegmentsEqual As Boolean
Visual C++
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}

Remarks

This property is usable only for linear dimensions with more than one segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.

See Also

Dimension Class


Curve Property

[image]

Revit 2011 API
Dimension..::.Curve Property
Dimension Class See Also Send Feedback
A curve that represents the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

Dimension Class


DimensionShape Property

[image]

Revit 2011 API
Dimension..::.DimensionShape Property
Dimension Class See Also Send Feedback
The shape of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionShape DimensionShape { get; }
Visual Basic (Declaration)
Public ReadOnly Property DimensionShape As DimensionShape
Visual C++
public:
property DimensionShape DimensionShape {
    DimensionShape get ();
}

See Also

Dimension Class


DimensionType Property

[image]

Revit 2011 API
Dimension..::.DimensionType Property
Dimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionType DimensionType { get; set; }
Visual Basic (Declaration)
Public Property DimensionType As DimensionType
Visual C++
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}

See Also

Dimension Class


IsLocked Property

[image]

Revit 2011 API
Dimension..::.IsLocked Property
Dimension Class See Also Send Feedback
Indicates if this dimension is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is radial or spot, or if the dimension is linear with more than one segment.

See Also

Dimension Class


Label Property

[image]

Revit 2011 API
Dimension..::.Label Property
Dimension Class See Also Send Feedback
The family parameter label of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic (Declaration)
Public Property Label As FamilyParameter
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

A dimension only can be labeled in a family document. Multi-segmented linear dimensions cannot be labeled. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when dimension can not be labeled.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.

See Also

Dimension Class


Name Property

[image]

Revit 2011 API
Dimension..::.Name Property
Dimension Class See Also Send Feedback
Retrieve or Change the name associated with the Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

Dimension Class


NumberOfSegments Property

[image]

Revit 2011 API
Dimension..::.NumberOfSegments Property
Dimension Class See Also Send Feedback
The number of segments for the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

Dimension Class


Parameter Property

[image] [image]

Revit 2011 API
Dimension..::.Parameter Property
Dimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Dimension Class
Dimension Members


References Property

[image]

Revit 2011 API
Dimension..::.References Property
Dimension Class See Also Send Feedback
Returns an array of geometric references to which the dimension is attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray References { get; }
Visual Basic (Declaration)
Public ReadOnly Property References As ReferenceArray
Visual C++
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}

See Also

Dimension Class


Segments Property

[image]

Revit 2011 API
Dimension..::.Segments Property
Dimension Class See Also Send Feedback
The segments in the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionSegmentArray Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As DimensionSegmentArray
Visual C++
public:
property DimensionSegmentArray^ Segments {
    DimensionSegmentArray^ get ();
}

Remarks

Returns a read only array of segments in the dimension. The references of the dimension can be mapped to segments in order. The first segment here wrapped by first and second references; the nth segment is wrapped by nth and n+1st references.

See Also

Dimension Class


Value Property

[image]

Revit 2011 API
Dimension..::.Value Property
Dimension Class See Also Send Feedback
The value of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Nullable(Of Double)
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

Remarks

This nullable property will not have a value for spot dimensions or for linear dimensions with more than one segment.

See Also

Dimension Class


ValueString Property

[image]

Revit 2011 API
Dimension..::.ValueString Property
Dimension Class See Also Send Feedback
The dimension value as a user visible string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueString As String
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

Remarks

This property always return nullNothingnullptra null reference (Nothing in Visual Basic) if this is a spot dimension, or it is a linear dimension with more than one segments.

See Also

Dimension Class


View Property

[image]

Revit 2011 API
Dimension..::.View Property
Dimension Class See Also Send Feedback
Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Dimension Class


DimensionSegment Class

[image]

Revit 2011 API
DimensionSegment Class
Members See Also Send Feedback
A segment of a dimension within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DimensionSegment : APIObject
Visual Basic (Declaration)
Public Class DimensionSegment _
    Inherits APIObject
Visual C++
public ref class DimensionSegment : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DimensionSegment

See Also

DimensionSegment Members


DimensionSegment Members

[image] [image]

Revit 2011 API
DimensionSegment Members
DimensionSegment Class Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsLocked | Indicates if this segment is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Origin | The segment origin.
Value | The length of the segment.
ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


DimensionSegment Methods

[image] [image]

Revit 2011 API
DimensionSegment Methods
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegment Class


DimensionSegment Properties

[image] [image]

Revit 2011 API
DimensionSegment Properties
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Properties

Name | Description
IsLocked | Indicates if this segment is locked.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Origin | The segment origin.
Value | The length of the segment.
ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


IsLocked Property

[image]

Revit 2011 API
DimensionSegment..::.IsLocked Property
DimensionSegment Class See Also Send Feedback
Indicates if this segment is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the segment has been labeled, or the dimension shape is a radial or spot dimension.

See Also

DimensionSegment Class


Origin Property

[image]

Revit 2011 API
DimensionSegment..::.Origin Property
DimensionSegment Class See Also Send Feedback
The segment origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

The origin will be the midpoint of the line that makes up the segment.

See Also

DimensionSegment Class


Value Property

[image]

Revit 2011 API
DimensionSegment..::.Value Property
DimensionSegment Class See Also Send Feedback
The length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Nullable(Of Double)
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

See Also

DimensionSegment Class


ValueString Property

[image]

Revit 2011 API
DimensionSegment..::.ValueString Property
DimensionSegment Class See Also Send Feedback
The displayed value shown for the dimension segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValueString As String
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

See Also

DimensionSegment Class


DimensionSegmentArray Class

[image]

Revit 2011 API
DimensionSegmentArray Class
Members See Also Send Feedback
An array that can contain any number of DimensionSegment objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DimensionSegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DimensionSegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionSegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DimensionSegmentArray

See Also

DimensionSegmentArray Members


DimensionSegmentArray Members

[image] [image]

Revit 2011 API
DimensionSegmentArray Members
DimensionSegmentArray Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Constructors

Name | Description
DimensionSegmentArray | Initializes a new instance of the DimensionSegmentArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class


DimensionSegmentArray Constructor

[image]

Revit 2011 API
DimensionSegmentArray Constructor
DimensionSegmentArray Class See Also Send Feedback
Initializes a new instance of the DimensionSegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionSegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionSegmentArray()

See Also

DimensionSegmentArray Class


DimensionSegmentArray Methods

[image] [image]

Revit 2011 API
DimensionSegmentArray Methods
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArray Class


Append Method

[image]

Revit 2011 API
DimensionSegmentArray..::.Append Method
DimensionSegmentArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    DimensionSegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As DimensionSegment _
)
Visual C++
public:
virtual void Append(
    DimensionSegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DimensionSegment
The item to be added.

See Also

DimensionSegmentArray Class


Clear Method

[image]

Revit 2011 API
DimensionSegmentArray..::.Clear Method
DimensionSegmentArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionSegmentArray Class


ForwardIterator Method

[image]

Revit 2011 API
DimensionSegmentArray..::.ForwardIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DimensionSegmentArray Class


GetEnumerator Method

[image]

Revit 2011 API
DimensionSegmentArray..::.GetEnumerator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DimensionSegmentArray Class


Insert Method

[image]

Revit 2011 API
DimensionSegmentArray..::.Insert Method
DimensionSegmentArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    DimensionSegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As DimensionSegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.DimensionSegment
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

DimensionSegmentArray Class


ReverseIterator Method

[image]

Revit 2011 API
DimensionSegmentArray..::.ReverseIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DimensionSegmentArray Class


DimensionSegmentArray Properties

[image] [image]

Revit 2011 API
DimensionSegmentArray Properties
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class


IsEmpty Property

[image]

Revit 2011 API
DimensionSegmentArray..::.IsEmpty Property
DimensionSegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DimensionSegmentArray Class


Item Property

[image]

Revit 2011 API
DimensionSegmentArray..::.Item Property
DimensionSegmentArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DimensionSegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As DimensionSegment
Visual C++
public:
virtual property DimensionSegment^ Item[int index] {
    DimensionSegment^ get (int index);
    void set (int index, DimensionSegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DimensionSegmentArray Class


Size Property

[image]

Revit 2011 API
DimensionSegmentArray..::.Size Property
DimensionSegmentArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionSegmentArray Class


DimensionSegmentArrayIterator Class

[image]

Revit 2011 API
DimensionSegmentArrayIterator Class
Members See Also Send Feedback
An iterator to an array of DimensionSegment objects..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DimensionSegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DimensionSegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionSegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DimensionSegmentArrayIterator

See Also

DimensionSegmentArrayIterator Members


DimensionSegmentArrayIterator Members

[image] [image]

Revit 2011 API
DimensionSegmentArrayIterator Members
DimensionSegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Constructors

Name | Description
DimensionSegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Constructor

[image]

Revit 2011 API
DimensionSegmentArrayIterator Constructor
DimensionSegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionSegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionSegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Methods

[image] [image]

Revit 2011 API
DimensionSegmentArrayIterator Methods
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
DimensionSegmentArrayIterator..::.MoveNext Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


Reset Method

[image]

Revit 2011 API
DimensionSegmentArrayIterator..::.Reset Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Properties

[image] [image]

Revit 2011 API
DimensionSegmentArrayIterator Properties
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class


Current Property

[image]

Revit 2011 API
DimensionSegmentArrayIterator..::.Current Property
DimensionSegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


DimensionShape Enumeration

[image]

Revit 2011 API
DimensionShape Enumeration
See Also Send Feedback
An enumerated type to list dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DimensionShape
Visual Basic (Declaration)
Public Enumeration DimensionShape
Visual C++
public enum class DimensionShape

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
Spot | Spot dimension.
Unknown | Unknown type dimension.

See Also


DimensionStyleType Enumeration

[image]

Revit 2011 API
DimensionStyleType Enumeration
See Also Send Feedback
An enumerated type containing possible style types of dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DimensionStyleType
Visual Basic (Declaration)
Public Enumeration DimensionStyleType
Visual C++
public enum class DimensionStyleType

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
SpotElevation | SpotElevation
SpotCoordinate | SpotCoordinate
LinearFixed | LinearFixed dimension, which is linear dimension whose direction is parallel to X or Y.
SpotSlope | SpotSlope

See Also


DimensionType Class

[image]

Revit 2011 API
DimensionType Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DimensionType : ElementType
Visual Basic (Declaration)
Public Class DimensionType _
    Inherits ElementType
Visual C++
public ref class DimensionType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.DimensionType
Autodesk.Revit.DB..::.SpotDimensionType

See Also

DimensionType Members


DimensionType Members

[image] [image]

Revit 2011 API
DimensionType Members
DimensionType Class Methods Properties See Also Send Feedback

The DimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StyleType | The dimension style type of this DimensionType.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DimensionType Class


DimensionType Methods

[image] [image]

Revit 2011 API
DimensionType Methods
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionType Class


DimensionType Properties

[image] [image]

Revit 2011 API
DimensionType Properties
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StyleType | The dimension style type of this DimensionType.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DimensionType Class


Parameter Property

[image] [image]

Revit 2011 API
DimensionType..::.Parameter Property
DimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DimensionType Class
DimensionType Members


StyleType Property

[image]

Revit 2011 API
DimensionType..::.StyleType Property
DimensionType Class See Also Send Feedback
The dimension style type of this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionStyleType StyleType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StyleType As DimensionStyleType
Visual C++
public:
property DimensionStyleType StyleType {
    DimensionStyleType get ();
}

See Also

DimensionType Class


DimensionTypeSet Class

[image]

Revit 2011 API
DimensionTypeSet Class
Members See Also Send Feedback
A set that contains dimension types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DimensionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DimensionTypeSet

See Also

DimensionTypeSet Members


DimensionTypeSet Members

[image] [image]

Revit 2011 API
DimensionTypeSet Members
DimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Constructors

Name | Description
DimensionTypeSet | Initializes a new instance of the DimensionTypeSet class

Methods

Name | Description
Clear | Removes every dimension type from the set, rendering it empty.
Contains | Tests for the existence of a dimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified dimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified dimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class


DimensionTypeSet Constructor

[image]

Revit 2011 API
DimensionTypeSet Constructor
DimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the DimensionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSet()

See Also

DimensionTypeSet Class


DimensionTypeSet Methods

[image] [image]

Revit 2011 API
DimensionTypeSet Methods
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every dimension type from the set, rendering it empty.
Contains | Tests for the existence of a dimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified dimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified dimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSet Class


Clear Method

[image]

Revit 2011 API
DimensionTypeSet..::.Clear Method
DimensionTypeSet Class See Also Send Feedback
Removes every dimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionTypeSet Class


Contains Method

[image]

Revit 2011 API
DimensionTypeSet..::.Contains Method
DimensionTypeSet Class See Also Send Feedback
Tests for the existence of a dimension type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DimensionType
The dimension type to be searched for.

Return Value

The Contains method returns True if the dimension type is within the set, otherwise False.

See Also

DimensionTypeSet Class


Erase Method

[image]

Revit 2011 API
DimensionTypeSet..::.Erase Method
DimensionTypeSet Class See Also Send Feedback
Removes a specified dimension type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DimensionType
The dimension type to be erased.

Return Value

The number of dimension types that were erased from the set.

See Also

DimensionTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
DimensionTypeSet..::.ForwardIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DimensionTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
DimensionTypeSet..::.GetEnumerator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DimensionTypeSet Class


Insert Method

[image]

Revit 2011 API
DimensionTypeSet..::.Insert Method
DimensionTypeSet Class See Also Send Feedback
Insert the specified dimension type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    DimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.DimensionType
The dimension type to be inserted into the set.

Return Value

Returns whether the dimension type was inserted into the set.

See Also

DimensionTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
DimensionTypeSet..::.ReverseIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DimensionTypeSet Class


DimensionTypeSet Properties

[image] [image]

Revit 2011 API
DimensionTypeSet Properties
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
DimensionTypeSet..::.IsEmpty Property
DimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DimensionTypeSet Class


Size Property

[image]

Revit 2011 API
DimensionTypeSet..::.Size Property
DimensionTypeSet Class See Also Send Feedback
Returns the number of dimension types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionTypeSet Class


DimensionTypeSetIterator Class

[image]

Revit 2011 API
DimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a dimension type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DimensionTypeSetIterator

See Also

DimensionTypeSetIterator Members


DimensionTypeSetIterator Members

[image] [image]

Revit 2011 API
DimensionTypeSetIterator Members
DimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Constructors

Name | Description
DimensionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Constructor

[image]

Revit 2011 API
DimensionTypeSetIterator Constructor
DimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Methods

[image] [image]

Revit 2011 API
DimensionTypeSetIterator Methods
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
DimensionTypeSetIterator..::.MoveNext Method
DimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
DimensionTypeSetIterator..::.Reset Method
DimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Properties

[image] [image]

Revit 2011 API
DimensionTypeSetIterator Properties
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class


Current Property

[image]

Revit 2011 API
DimensionTypeSetIterator..::.Current Property
DimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class


DisplayUnit Enumeration

[image]

Revit 2011 API
DisplayUnit Enumeration
See Also Send Feedback
Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DisplayUnit
Visual Basic (Declaration)
Public Enumeration DisplayUnit
Visual C++
public enum class DisplayUnit

Members

Member name | Description
METRIC |
IMPERIAL |

See Also


DisplayUnitType Enumeration

[image]

Revit 2011 API
DisplayUnitType Enumeration
See Also Send Feedback
An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DisplayUnitType
Visual Basic (Declaration)
Public Enumeration DisplayUnitType
Visual C++
public enum class DisplayUnitType

Members

Member name | Description
DUT_METERS |
DUT_CENTIMETERS |
DUT_MILLIMETERS |
DUT_DECIMAL_FEET |
DUT_FEET_FRACTIONAL_INCHES |
DUT_FRACTIONAL_INCHES |
DUT_DECIMAL_INCHES |
DUT_ACRES |
DUT_HECTARES |
DUT_METERS_CENTIMETERS |
DUT_CUBIC_YARDS |
DUT_SQUARE_FEET |
DUT_SQUARE_METERS |
DUT_CUBIC_FEET |
DUT_CUBIC_METERS |
DUT_DECIMAL_DEGREES |
DUT_DEGREES_AND_MINUTES |
DUT_GENERAL |
DUT_FIXED |
DUT_PERCENTAGE |
DUT_SQUARE_INCHES |
DUT_SQUARE_CENTIMETERS |
DUT_SQUARE_MILLIMETERS |
DUT_CUBIC_INCHES |
DUT_CUBIC_CENTIMETERS |
DUT_CUBIC_MILLIMETERS |
DUT_LITERS |
DUT_GALLONS_US |
DUT_KILOGRAMS_PER_CUBIC_METER |
DUT_POUNDS_MASS_PER_CUBIC_FOOT |
DUT_POUNDS_MASS_PER_CUBIC_INCH |
DUT_BRITISH_THERMAL_UNITS |
DUT_CALORIES |
DUT_KILOCALORIES |
DUT_JOULES |
DUT_KILOWATT_HOURS |
DUT_THERMS |
DUT_INCHES_OF_WATER_PER_100FT |
DUT_PASCALS_PER_METER |
DUT_WATTS |
DUT_KILOWATTS |
DUT_BRITISH_THERMAL_UNITS_PER_SECOND |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_CALORIES_PER_SECOND |
DUT_KILOCALORIES_PER_SECOND |
DUT_WATTS_PER_SQUARE_FOOT |
DUT_WATTS_PER_SQUARE_METER |
DUT_INCHES_OF_WATER |
DUT_PASCALS |
DUT_KILOPASCALS |
DUT_MEGAPASCALS |
DUT_POUNDS_FORCE_PER_SQUARE_INCH |
DUT_INCHES_OF_MERCURY |
DUT_MILLIMETERS_OF_MERCURY |
DUT_ATMOSPHERES |
DUT_BARS |
DUT_FAHRENHEIT |
DUT_CELSIUS |
DUT_KELVIN |
DUT_RANKINE |
DUT_FEET_PER_MINUTE |
DUT_METERS_PER_SECOND |
DUT_CENTIMETERS_PER_MINUTE |
DUT_CUBIC_FEET_PER_MINUTE |
DUT_LITERS_PER_SECOND |
DUT_CUBIC_METERS_PER_SECOND |
DUT_CUBIC_METERS_PER_HOUR |
DUT_GALLONS_US_PER_MINUTE |
DUT_GALLONS_US_PER_HOUR |
DUT_AMPERES |
DUT_KILOAMPERES |
DUT_MILLIAMPERES |
DUT_VOLTS |
DUT_KILOVOLTS |
DUT_MILLIVOLTS |
DUT_HERTZ |
DUT_CYCLES_PER_SECOND |
DUT_LUX |
DUT_FOOTCANDLES |
DUT_FOOTLAMBERTS |
DUT_CANDELAS_PER_SQUARE_METER |
DUT_CANDELAS |
DUT_CANDLEPOWER |
DUT_LUMENS |
DUT_VOLT_AMPERES |
DUT_KILOVOLT_AMPERES |
DUT_HORSEPOWER |
DUT_NEWTONS |
DUT_DECANEWTONS |
DUT_KILONEWTONS |
DUT_MEGANEWTONS |
DUT_KIPS |
DUT_KILOGRAMS_FORCE |
DUT_TONNES_FORCE |
DUT_POUNDS_FORCE |
DUT_NEWTONS_PER_METER |
DUT_DECANEWTONS_PER_METER |
DUT_KILONEWTONS_PER_METER |
DUT_MEGANEWTONS_PER_METER |
DUT_KIPS_PER_FOOT |
DUT_KILOGRAMS_FORCE_PER_METER |
DUT_TONNES_FORCE_PER_METER |
DUT_POUNDS_FORCE_PER_FOOT |
DUT_NEWTONS_PER_SQUARE_METER |
DUT_DECANEWTONS_PER_SQUARE_METER |
DUT_KILONEWTONS_PER_SQUARE_METER |
DUT_MEGANEWTONS_PER_SQUARE_METER |
DUT_KIPS_PER_SQUARE_FOOT |
DUT_KILOGRAMS_FORCE_PER_SQUARE_METER |
DUT_TONNES_FORCE_PER_SQUARE_METER |
DUT_POUNDS_FORCE_PER_SQUARE_FOOT |
DUT_NEWTON_METERS |
DUT_DECANEWTON_METERS |
DUT_KILONEWTON_METERS |
DUT_MEGANEWTON_METERS |
DUT_KIP_FEET |
DUT_KILOGRAM_FORCE_METERS |
DUT_TONNE_FORCE_METERS |
DUT_POUND_FORCE_FEET |
DUT_METERS_PER_KILONEWTON |
DUT_FEET_PER_KIP |
DUT_SQUARE_METERS_PER_KILONEWTON |
DUT_SQUARE_FEET_PER_KIP |
DUT_CUBIC_METERS_PER_KILONEWTON |
DUT_CUBIC_FEET_PER_KIP |
DUT_INV_KILONEWTONS |
DUT_INV_KIPS |
DUT_FEET_OF_WATER_PER_100FT |
DUT_FEET_OF_WATER |
DUT_PASCAL_SECONDS |
DUT_POUNDS_MASS_PER_FOOT_SECOND |
DUT_CENTIPOISES |
DUT_FEET_PER_SECOND |
DUT_KIPS_PER_SQUARE_INCH |
DUT_KILONEWTONS_PER_CUBIC_METER |
DUT_POUNDS_FORCE_PER_CUBIC_FOOT |
DUT_KIPS_PER_CUBIC_INCH |
DUT_INV_FAHRENHEIT |
DUT_INV_CELSIUS |
DUT_NEWTON_METERS_PER_METER |
DUT_DECANEWTON_METERS_PER_METER |
DUT_KILONEWTON_METERS_PER_METER |
DUT_MEGANEWTON_METERS_PER_METER |
DUT_KIP_FEET_PER_FOOT |
DUT_KILOGRAM_FORCE_METERS_PER_METER |
DUT_TONNE_FORCE_METERS_PER_METER |
DUT_POUND_FORCE_FEET_PER_FOOT |
DUT_POUNDS_MASS_PER_FOOT_HOUR |
DUT_KIPS_PER_INCH |
DUT_KIPS_PER_CUBIC_FOOT |
DUT_KIP_FEET_PER_DEGREE |
DUT_KILONEWTON_METERS_PER_DEGREE |
DUT_KIP_FEET_PER_DEGREE_PER_FOOT |
DUT_KILONEWTON_METERS_PER_DEGREE_PER_METER |
DUT_WATTS_PER_SQUARE_METER_KELVIN |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT_FAHRENHEIT |
DUT_CUBIC_FEET_PER_MINUTE_SQUARE_FOOT |
DUT_LITERS_PER_SECOND_SQUARE_METER |
DUT_RATIO_10 |
DUT_RATIO_12 |
DUT_SLOPE_DEGREES |
DUT_RISE_OVER_INCHES |
DUT_RISE_OVER_FOOT |
DUT_RISE_OVER_MMS |
DUT_WATTS_PER_CUBIC_FOOT |
DUT_WATTS_PER_CUBIC_METER |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT |
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_CUBIC_FOOT |
DUT_TON_OF_REFRIGERATION |
DUT_CUBIC_FEET_PER_MINUTE_CUBIC_FOOT |
DUT_LITERS_PER_SECOND_CUBIC_METER |
DUT_CUBIC_FEET_PER_MINUTE_TON_OF_REFRIGERATION |
DUT_LITERS_PER_SECOND_KILOWATTS |
DUT_SQUARE_FEET_PER_TON_OF_REFRIGERATION |
DUT_SQUARE_METERS_PER_KILOWATTS |
DUT_CURRENCY |
DUT_LUMENS_PER_WATT |
DUT_SQUARE_FEET_PER_THOUSAND_BRITISH_THERMAL_UNITS_PER_HOUR |
DUT_KILONEWTONS_PER_SQUARE_CENTIMETER |
DUT_NEWTONS_PER_SQUARE_MILLIMETER |
DUT_KILONEWTONS_PER_SQUARE_MILLIMETER |

See Also


DividedSurface Class

[image]

Revit 2011 API
DividedSurface Class
Members Example See Also Send Feedback
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DividedSurface : Element
Visual Basic (Declaration)
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The type of this element may be set to: a TilePattern element, a FamilySymbol element from a Curtain Panel family.

Examples

CopyC#
public void TileSurface(Document document, Form form)
{
    // cover surface with OctagonRotate tile pattern
    TilePatterns tilePatterns = document.Settings.TilePatterns;
    DividedSurfaceData dsData = form.GetDividedSurfaceData();
    if (dsData != null)
    {
        foreach (Reference r in dsData.GetReferencesWithDividedSurfaces())
        {
            DividedSurface ds = dsData.GetDividedSurfaceForReference(r);
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id);
        }
    }
}
CopyVB.NET
Public Sub TileSurface(ByVal document As Document, ByVal form As Form)
    ' cover surface with OctagonRotate tile pattern
    Dim tilePatterns As TilePatterns = document.Settings.TilePatterns
    Dim dsData As DividedSurfaceData = form.GetDividedSurfaceData()
    If dsData IsNot Nothing Then
        For Each r As Reference In dsData.GetReferencesWithDividedSurfaces()
            Dim ds As Autodesk.Revit.DB.DividedSurface = dsData.GetDividedSurfaceForReference(r)
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id)
        Next
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.DividedSurface

See Also

DividedSurface Members


DividedSurface Members

[image] [image]

Revit 2011 API
DividedSurface Members
DividedSurface Class Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

Name | Description
AddIntersectionElement | Adds an intersection element to the divided surface.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanBeIntersectionElement | Checks if the element can be an intersection reference.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllIntersectionElements | Gets all intersection elements which produce division lines.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
RemoveIntersectionElement | Removes an intersection element from a divided surface.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class


DividedSurface Methods

[image] [image]

Revit 2011 API
DividedSurface Methods
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

Name | Description
AddIntersectionElement | Adds an intersection element to the divided surface.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanBeIntersectionElement | Checks if the element can be an intersection reference.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllIntersectionElements | Gets all intersection elements which produce division lines.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
RemoveIntersectionElement | Removes an intersection element from a divided surface.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurface Class


AddIntersectionElement Method

[image]

Revit 2011 API
DividedSurface..::.AddIntersectionElement Method
DividedSurface Class See Also Send Feedback
Adds an intersection element to the divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddIntersectionElement(
    ElementId newIntersectionElemId
)
Visual Basic (Declaration)
Public Sub AddIntersectionElement ( _
    newIntersectionElemId As ElementId _
)
Visual C++
public:
void AddIntersectionElement(
    ElementId^ newIntersectionElemId
)

Parameters

newIntersectionElemId
Type: Autodesk.Revit.DB..::.ElementId
The intersection element to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


CanBeIntersectionElement Method

[image]

Revit 2011 API
DividedSurface..::.CanBeIntersectionElement Method
DividedSurface Class See Also Send Feedback
Checks if the element can be an intersection reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanBeIntersectionElement(
    ElementId id
)
Visual Basic (Declaration)
Public Function CanBeIntersectionElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool CanBeIntersectionElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The element to be checked.

Return Value

True if the element can be an intersection reference., false otherwise.

Remarks

The element must be a level, grid, reference plane, or a curve element whose category is lines and reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


GetAllIntersectionElements Method

[image]

Revit 2011 API
DividedSurface..::.GetAllIntersectionElements Method
DividedSurface Class See Also Send Feedback
Gets all intersection elements which produce division lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAllIntersectionElements()
Visual Basic (Declaration)
Public Function GetAllIntersectionElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllIntersectionElements()

Return Value

The intersection elements.

See Also

DividedSurface Class


GetGridNodeLocation Method

[image]

Revit 2011 API
DividedSurface..::.GetGridNodeLocation Method
DividedSurface Class See Also Send Feedback
Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeLocation ( _
    gridNode As GridNode _
) As GridNodeLocation
Visual C++
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeReference Method

[image]

Revit 2011 API
DividedSurface..::.GetGridNodeReference Method
DividedSurface Class See Also Send Feedback
Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetGridNodeReference(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeReference ( _
    gridNode As GridNode _
) As Reference
Visual C++
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeUV Method

[image]

Revit 2011 API
DividedSurface..::.GetGridNodeUV Method
DividedSurface Class See Also Send Feedback
Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV GetGridNodeUV(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function GetGridNodeUV ( _
    gridNode As GridNode _
) As UV
Visual C++
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridSegmentReference Method

[image]

Revit 2011 API
DividedSurface..::.GetGridSegmentReference Method
DividedSurface Class See Also Send Feedback
Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Visual Basic (Declaration)
Public Function GetGridSegmentReference ( _
    gridNode As GridNode, _
    gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode
gridSegmentDirection
Type: Autodesk.Revit.DB..::.GridSegmentDirection

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also

DividedSurface Class


GetTileFamilyInstance Method

[image]

Revit 2011 API
DividedSurface..::.GetTileFamilyInstance Method
DividedSurface Class See Also Send Feedback
Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Visual Basic (Declaration)
Public Function GetTileFamilyInstance ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode
tileIndex
Type: System..::.Int32

Return Value

A FamilyInstance object. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the ObjectType property is not a FamilySymbol. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


GetTileReference Method

[image]

Revit 2011 API
DividedSurface..::.GetTileReference Method
DividedSurface Class See Also Send Feedback
Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Visual Basic (Declaration)
Public Function GetTileReference ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As Reference
Visual C++
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode
tileIndex
Type: System..::.Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

A reference to a Face (surface). Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


IsSeedNode Method

[image]

Revit 2011 API
DividedSurface..::.IsSeedNode Method
DividedSurface Class See Also Send Feedback
Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSeedNode(
    GridNode gridNode
)
Visual Basic (Declaration)
Public Function IsSeedNode ( _
    gridNode As GridNode _
) As Boolean
Visual C++
public:
bool IsSeedNode(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::.GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


RemoveAllIntersectionElements Method

[image]

Revit 2011 API
DividedSurface..::.RemoveAllIntersectionElements Method
DividedSurface Class See Also Send Feedback
Removes all the intersection elements from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void RemoveAllIntersectionElements()
Visual Basic (Declaration)
Public Sub RemoveAllIntersectionElements
Visual C++
public:
void RemoveAllIntersectionElements()

See Also

DividedSurface Class


RemoveIntersectionElement Method

[image]

Revit 2011 API
DividedSurface..::.RemoveIntersectionElement Method
DividedSurface Class See Also Send Feedback
Removes an intersection element from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void RemoveIntersectionElement(
    ElementId referenceElemIdToRemove
)
Visual Basic (Declaration)
Public Sub RemoveIntersectionElement ( _
    referenceElemIdToRemove As ElementId _
)
Visual C++
public:
void RemoveIntersectionElement(
    ElementId^ referenceElemIdToRemove
)

Parameters

referenceElemIdToRemove
Type: Autodesk.Revit.DB..::.ElementId
The intersection element to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


DividedSurface Properties

[image] [image]

Revit 2011 API
DividedSurface Properties
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Properties

Name | Description
AllGridRotation | Angle of rotation applied to the U- and V- directions together.
BorderTile | Determines the handling of tiles that overlap the surface's boundary.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Host | The element whose surface has been divided.
HostReference | A reference to the divided face on the host.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsComponentFlipped | Whether the pattern is flipped.
IsComponentMirrored | Whether the pattern is mirror-imaged.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfUGridlines | Get the number of U-gridlines used on the surface.
NumberOfVGridlines | Get the number of V-gridlines used on the surface.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.

See Also

DividedSurface Class


AllGridRotation Property

[image]

Revit 2011 API
DividedSurface..::.AllGridRotation Property
DividedSurface Class See Also Send Feedback
Angle of rotation applied to the U- and V- directions together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AllGridRotation { get; set; }
Visual Basic (Declaration)
Public Property AllGridRotation As Double
Visual C++
public:
property double AllGridRotation {
    double get ();
    void set (double value);
}

See Also

DividedSurface Class


BorderTile Property

[image]

Revit 2011 API
DividedSurface..::.BorderTile Property
DividedSurface Class See Also Send Feedback
Determines the handling of tiles that overlap the surface's boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BorderTile BorderTile { get; set; }
Visual Basic (Declaration)
Public Property BorderTile As BorderTile
Visual C++
public:
property BorderTile BorderTile {
    BorderTile get ();
    void set (BorderTile value);
}

See Also

DividedSurface Class


ComponentRotation Property

[image]

Revit 2011 API
DividedSurface..::.ComponentRotation Property
DividedSurface Class See Also Send Feedback
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic (Declaration)
Public Property ComponentRotation As ComponentRotation
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

DividedSurface Class


Host Property

[image]

Revit 2011 API
DividedSurface..::.Host Property
DividedSurface Class See Also Send Feedback
The element whose surface has been divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

DividedSurface Class


HostReference Property

[image]

Revit 2011 API
DividedSurface..::.HostReference Property
DividedSurface Class See Also Send Feedback
A reference to the divided face on the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference HostReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostReference As Reference
Visual C++
public:
property Reference^ HostReference {
    Reference^ get ();
}

Remarks

This is the same as the hostReference argument to the NewDividedSurface method of FamilyItemFactory.

See Also

DividedSurface Class


IsComponentFlipped Property

[image]

Revit 2011 API
DividedSurface..::.IsComponentFlipped Property
DividedSurface Class See Also Send Feedback
Whether the pattern is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsComponentFlipped { get; set; }
Visual Basic (Declaration)
Public Property IsComponentFlipped As Boolean
Visual C++
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.

See Also

DividedSurface Class


IsComponentMirrored Property

[image]

Revit 2011 API
DividedSurface..::.IsComponentMirrored Property
DividedSurface Class See Also Send Feedback
Whether the pattern is mirror-imaged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsComponentMirrored { get; set; }
Visual Basic (Declaration)
Public Property IsComponentMirrored As Boolean
Visual C++
public:
property bool IsComponentMirrored {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)). Changing this flag effectively reflects the component through its YZ-plane.

See Also

DividedSurface Class


NumberOfUGridlines Property

[image]

Revit 2011 API
DividedSurface..::.NumberOfUGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of U-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfUGridlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUGridlines As Integer
Visual C++
public:
property int NumberOfUGridlines {
    int get ();
}

See Also

DividedSurface Class


NumberOfVGridlines Property

[image]

Revit 2011 API
DividedSurface..::.NumberOfVGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of V-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfVGridlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfVGridlines As Integer
Visual C++
public:
property int NumberOfVGridlines {
    int get ();
}

See Also

DividedSurface Class


Parameter Property

[image] [image]

Revit 2011 API
DividedSurface..::.Parameter Property
DividedSurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DividedSurface Class
DividedSurface Members


UPatternIndent Property

[image]

Revit 2011 API
DividedSurface..::.UPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the U-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int UPatternIndent { get; set; }
Visual Basic (Declaration)
Public Property UPatternIndent As Integer
Visual C++
public:
property int UPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


USpacingRule Property

[image]

Revit 2011 API
DividedSurface..::.USpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the first series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpacingRule USpacingRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property USpacingRule As SpacingRule
Visual C++
public:
property SpacingRule^ USpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


VPatternIndent Property

[image]

Revit 2011 API
DividedSurface..::.VPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the V-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int VPatternIndent { get; set; }
Visual Basic (Declaration)
Public Property VPatternIndent As Integer
Visual C++
public:
property int VPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


VSpacingRule Property

[image]

Revit 2011 API
DividedSurface..::.VSpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the second series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpacingRule VSpacingRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property VSpacingRule As SpacingRule
Visual C++
public:
property SpacingRule^ VSpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


DividedSurfaceData Class

[image]

Revit 2011 API
DividedSurfaceData Class
Members See Also Send Feedback
An interface to the divided surfaces on an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DividedSurfaceData : APIObject
Visual Basic (Declaration)
Public Class DividedSurfaceData _
    Inherits APIObject
Visual C++
public ref class DividedSurfaceData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DividedSurfaceData

See Also

DividedSurfaceData Members


DividedSurfaceData Members

[image] [image]

Revit 2011 API
DividedSurfaceData Members
DividedSurfaceData Class Methods Properties See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class


DividedSurfaceData Methods

[image] [image]

Revit 2011 API
DividedSurfaceData Methods
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurfaceData Class


GetDividedSurfaceForReference Method

[image]

Revit 2011 API
DividedSurfaceData..::.GetDividedSurfaceForReference Method
DividedSurfaceData Class See Also Send Feedback
Find the DividedSurface element that is associated with a surface of this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DividedSurface GetDividedSurfaceForReference(
    Reference reference
)
Visual Basic (Declaration)
Public Function GetDividedSurfaceForReference ( _
    reference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ GetDividedSurfaceForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference

Return Value

A DividedSurface element, if there is one associated with this face; null if the reference is to a face without a DividedSurface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when reference is not a face (surface) reference.

See Also

DividedSurfaceData Class


GetReferencesWithDividedSurfaces Method

[image]

Revit 2011 API
DividedSurfaceData..::.GetReferencesWithDividedSurfaces Method
DividedSurfaceData Class See Also Send Feedback
Find the set of references that have associated DividedSurface elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray GetReferencesWithDividedSurfaces()
Visual Basic (Declaration)
Public Function GetReferencesWithDividedSurfaces As ReferenceArray
Visual C++
public:
ReferenceArray^ GetReferencesWithDividedSurfaces()

See Also

DividedSurfaceData Class


DividedSurfaceData Properties

[image] [image]

Revit 2011 API
DividedSurfaceData Properties
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class


Document Class

[image]

Revit 2011 API
Document Class
Members See Also Send Feedback
An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Document : IDisposable
Visual Basic (Declaration)
Public Class Document _
    Implements IDisposable
Visual C++
public ref class Document : IDisposable

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Document

See Also

Document Members


Document Members

[image] [image]

Revit 2011 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose |
EditFamily | Edits a family loaded in the document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded. Exports the document to another file format.
ExportImage | Exports a view or set of views into an image file.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetDocumentPreviewSettings | Returns the preview settings for the given document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import | Overloaded. Imports the contents of an external file into the document.
Link | Links a DWG file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Print | Overloaded. Prints a set of views.
Regenerate | Updates the elements in the Revit document to reflect all changes.
Rotate | Overloaded. Rotates one or more elements within the document by a specified angle around a given axis.
Save | Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SaveToProjectAsImage | Creates an image view from the currently active view.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the document is read-only or can possibly be modified
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified BuiltInParameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


Document Methods

[image] [image]

Revit 2011 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Array | Overloaded. Creates an array of one or more elements.
ArrayWithoutAssociate | Overloaded. Creates an array of one or more elements where the elements created will not be grouped and associated.
AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Close | Overloaded. Closes the document.
CombineElements | Combine a set of combinable elements into a geometry combination.
ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Delete | Overloaded. Deletes one or more elements from the document.
Dispose |
EditFamily | Edits a family loaded in the document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded. Exports the document to another file format.
ExportImage | Exports a view or set of views into an image file.
FindReferencesByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
GetDocumentPreviewSettings | Returns the preview settings for the given document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRoomAtPoint | Overloaded. Gets a room containing the point.
GetSpaceAtPoint | Overloaded. Gets a space containing the point.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import | Overloaded. Imports the contents of an external file into the document.
Link | Links a DWG file into the document.
LoadFamily | Overloaded. Loads a family and all its types/symbols.
LoadFamilySymbol | Overloaded. Loads only a specified family type/symbol from a family file into the document.
Mirror | Overloaded. Mirrors one or more elements.
Move | Overloaded. Moves one or more elements within the document by a specified vector.
PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Print | Overloaded. Prints a set of views.
Regenerate | Updates the elements in the Revit document to reflect all changes.
Rotate | Overloaded. Rotates one or more elements within the document by a specified angle around a given axis.
Save | Saves the document.
SaveAs | Overloaded. Saves the document to a new file name.
SaveToProjectAsImage | Creates an image view from the currently active view.
SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

See Also

Document Class


Array Method

[image] [image]

Revit 2011 API
Document..::.Array Method
Document Class See Also Send Feedback
Creates an array of one or more elements.

Overload List

Name | Description
Array(Element, Int32, Boolean, XYZ) | Creates an array of an element using a specified number.
Array(Element, Int32, Boolean, Double) | Creates a radial array of an element using a specified angle.
Array(ElementId, Int32, Boolean, XYZ) | Creates an array of an element, specified by id, using a specified number.
Array(ElementId, Int32, Boolean, Double) | Creates a radial array of an element, specified by id, using a specified angle.
Array(ElementSet, Int32, Boolean, XYZ) | Creates an array of several elements using a specified number.
Array(ElementSet, Int32, Boolean, Double) | Creates a radial array of several elements using a specified angle.
Array(ICollection<(Of <(ElementId>)>), Int32, Boolean, XYZ) | Creates an array of several elements, specified by ids, using a specified number.
Array(ICollection<(Of <(ElementId>)>), Int32, Boolean, Double) | Creates a radial array of several elements, specified by id, using a specified angle.

See Also

Document Class
Document Members


Array Method (Element, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.Array Method (Element, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element using a specified number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinearArray Array(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (Element, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.Array Method (Element, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element using a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RadialArray Array(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ElementId, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.Array Method (ElementId, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element, specified by id, using a specified number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinearArray Array(
    ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementId^ elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a LinearArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ElementId, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.Array Method (ElementId, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element, specified by id, using a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RadialArray Array(
    ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementId^ elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ElementSet, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.Array Method (ElementSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements using a specified number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinearArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

A LinearArray element if the elements are arrayed successfully and groupAndAssociate is set to True. nullNothingnullptra null reference (Nothing in Visual Basic) if the elements are arrayed successfully and groupAndAssociate is set to False. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ElementSet, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.Array Method (ElementSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements using a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RadialArray Array(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ICollection(ElementId), Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.Array Method (ICollection<(Of <(ElementId>)>), Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements, specified by ids, using a specified number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinearArray Array(
    ICollection<ElementId> elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ICollection(Of ElementId), _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As LinearArray
Visual C++
public:
LinearArray^ Array(
    ICollection<ElementId^>^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

A LinearArray element if the elements are arrayed successfully and groupAndAssociate is set to True. nullNothingnullptra null reference (Nothing in Visual Basic) if the elements are arrayed successfully and groupAndAssociate is set to False. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


Array Method (ICollection(ElementId), Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.Array Method (ICollection<(Of <(ElementId>)>), Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements, specified by id, using a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RadialArray Array(
    ICollection<ElementId> elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function Array ( _
    elementIds As ICollection(Of ElementId), _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As RadialArray
Visual C++
public:
RadialArray^ Array(
    ICollection<ElementId^>^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully and groupAndAssociate is set to True then the method returns a RadialArray element. If the elements are arrayed successfully and groupAndAssociate is set to False then the method returns nullNothingnullptra null reference (Nothing in Visual Basic). If the elements are arrayed failed then an Exception will be thrown.

Remarks

The Array method is used to array several elements within the project. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Array Overload


ArrayWithoutAssociate Method

[image] [image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method
Document Class See Also Send Feedback
Creates an array of one or more elements where the elements created will not be grouped and associated.

Overload List

Name | Description
ArrayWithoutAssociate(Element, Int32, Boolean, XYZ) | Creates an array of an element using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(Element, Int32, Boolean, Double) | Creates a radial array of an element using a specified angle where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementId, Int32, Boolean, XYZ) | Creates an array of an element, specified by id, using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementId, Int32, Boolean, Double) | Creates a radial array of an element, specified by id, using a specified angle where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementSet, Int32, Boolean, XYZ) | Creates an array of several elements using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ElementSet, Int32, Boolean, Double) | Creates a radial array of several elements using a specified angle where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ICollection<(Of <(ElementId>)>), Int32, Boolean, XYZ) | Creates an array of several elements, specified by ids, using a specified number where the elements created will not be grouped and associated.
ArrayWithoutAssociate(ICollection<(Of <(ElementId>)>), Int32, Boolean, Double) | Creates a radial array of several elements, specified by id, using a specified angle where the elements created will not be grouped and associated.

See Also

Document Class
Document Members


ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (Element, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    Element^ element,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (Element, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element using a specified angle where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    Element element,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    element As Element, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    Element^ element,
    int number,
    bool moveToLast,
    double angle
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ElementId, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of an element, specified by id, using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementId elementId,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementId^ elementId,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ElementId, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ElementId, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of an element, specified by id, using a specified angle where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementId elementId,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementId As ElementId, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementId^ elementId,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
The id for an element that is to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ElementSet, Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements using a specified angle where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ElementSet elements,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elements As ElementSet, _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ElementSet^ elements,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ICollection(ElementId), Int32, Boolean, XYZ)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ICollection<(Of <(ElementId>)>), Int32, Boolean, XYZ)
Document Class See Also Send Feedback
Creates an array of several elements, specified by ids, using a specified number where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ICollection<ElementId> elementIds,
    int number,
    bool moveToLast,
    XYZ moveVec
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ICollection(Of ElementId), _
    number As Integer, _
    moveToLast As Boolean, _
    moveVec As XYZ _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ICollection<ElementId^>^ elementIds,
    int number,
    bool moveToLast,
    XYZ^ moveVec
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
moveVec
Type: Autodesk.Revit.DB..::.XYZ
The vector to which the elements will move.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


ArrayWithoutAssociate Method (ICollection(ElementId), Int32, Boolean, Double)

[image]

Revit 2011 API
Document..::.ArrayWithoutAssociate Method (ICollection<(Of <(ElementId>)>), Int32, Boolean, Double)
Document Class See Also Send Feedback
Creates a radial array of several elements, specified by id, using a specified angle where the elements created will not be grouped and associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet ArrayWithoutAssociate(
    ICollection<ElementId> elementIds,
    int number,
    bool moveToLast,
    double angle
)
Visual Basic (Declaration)
Public Function ArrayWithoutAssociate ( _
    elementIds As ICollection(Of ElementId), _
    number As Integer, _
    moveToLast As Boolean, _
    angle As Double _
) As ElementSet
Visual C++
public:
ElementSet^ ArrayWithoutAssociate(
    ICollection<ElementId^>^ elementIds,
    int number,
    bool moveToLast,
    double angle
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of ids for elements that are to be arrayed.
number
Type: System..::.Int32
The number of the array.
moveToLast
Type: System..::.Boolean
A boolean value. True indicate moving the last set of elements. False indicate moving the second set of elements.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be arrayed around the center of the elements.

Return Value

If the elements are arrayed successfully then the method returns the created element set. If the elements are arrayed failed then an Exception will be thrown.

Remarks

The ArrayWithoutAssociate method is used to array several elements within the project without being grouped and associated. Other elements may also be arrayed when these elements are arrayed because they are dependent upon the elements being arrayed. Some elements cannot be arrayed such as section because they cannot be grouped. This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
ArrayWithoutAssociate Overload


AutoJoinElements Method

[image]

Revit 2011 API
Document..::.AutoJoinElements Method
Document Class See Also Send Feedback
Forces the elements in the Revit document to automatically join to their neighbors where appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AutoJoinElements()
Visual Basic (Declaration)
Public Sub AutoJoinElements
Visual C++
public:
void AutoJoinElements()

Remarks

Use this method to force elements in the document to automatically join to their neighbors. Note that when a transaction is committed there is an automatic call to automatically join elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.AutoJoinFailedException | Thrown when the regeneration option is automatic or the operation fails.

See Also

Document Class


Close Method

[image] [image]

Revit 2011 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document.

Overload List

Name | Description
Close()()() | Closes the document with the possibility to ask the user whether or not to save.
Close(Boolean) | Closes the document with the option to save.

See Also

Document Class
Document Members


Close Method

[image]

Revit 2011 API
Document..::.Close Method
Document Class See Also Send Feedback
Closes the document with the possibility to ask the user whether or not to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Close()
Visual Basic (Declaration)
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

False if either closing procedure fails or if saving of a modified document failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

This function can not be called on the active document.

If the document is modified, the user will be asked if the document should be saved.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.

See Also

Document Class
Close Overload


Close Method (Boolean)

[image]

Revit 2011 API
Document..::.Close Method (Boolean)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic (Declaration)
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified
)

Parameters

saveModified
Type: System..::.Boolean
Indicates if the current document should be saved before close operation.

Return Value

False if closing procedure fails or if saving of a modified document was requested (saveModified = True) but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

This function can not be called on the active document. If the user tries to close the active document with this function, it will return False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.

See Also

Document Class
Close Overload


CombineElements Method

[image]

Revit 2011 API
Document..::.CombineElements Method
Document Class See Also Send Feedback
Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeomCombination CombineElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Function CombineElements ( _
    members As CombinableElementArray _
) As GeomCombination
Visual C++
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::.CombinableElementArray
A list of combinable elements to be combined.

Return Value

If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Remarks

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when members contains less than two elements. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when creation of the combination failed.

See Also

Document Class


ConvertDetailToModelCurves Method

[image]

Revit 2011 API
Document..::.ConvertDetailToModelCurves Method
Document Class See Also Send Feedback
Converts a group of DetailCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray ConvertDetailToModelCurves(
    View view,
    DetailCurveArray detailCurves
)
Visual Basic (Declaration)
Public Function ConvertDetailToModelCurves ( _
    view As View, _
    detailCurves As DetailCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertDetailToModelCurves(
    View^ view,
    DetailCurveArray^ detailCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
detailCurves
Type: Autodesk.Revit.DB..::.DetailCurveArray
The detail curve array to be converted.

Remarks

This operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::.ArgumentException | Thrown when the given detail lines are not visible in the given view. Thrown when the detail lines are not in the same view or not parallel to the given view.
System..::.InvalidOperationException | Thrown when one or more curves could not be successfully converted.

See Also

Document Class


ConvertModelToDetailCurves Method

[image]

Revit 2011 API
Document..::.ConvertModelToDetailCurves Method
Document Class See Also Send Feedback
Converts a group of ModelCurves to equivalent DetailCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailCurveArray ConvertModelToDetailCurves(
    View view,
    ModelCurveArray modelCurves
)
Visual Basic (Declaration)
Public Function ConvertModelToDetailCurves ( _
    view As View, _
    modelCurves As ModelCurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ ConvertModelToDetailCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view where the new lines will be created. The lines are projected on the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves
Type: Autodesk.Revit.DB..::.ModelCurveArray
The model curve array to be converted.

Remarks

This operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document. If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::.ArgumentException | Thrown when view is invalid to create DetailCurves on it.
System..::.InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.

See Also

Document Class


ConvertModelToSymbolicCurves Method

[image]

Revit 2011 API
Document..::.ConvertModelToSymbolicCurves Method
Document Class See Also Send Feedback
Converts a group of ModelCurves to equivalent SymbolicCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SymbolicCurveArray ConvertModelToSymbolicCurves(
    View view,
    ModelCurveArray modelCurves
)
Visual Basic (Declaration)
Public Function ConvertModelToSymbolicCurves ( _
    view As View, _
    modelCurves As ModelCurveArray _
) As SymbolicCurveArray
Visual C++
public:
SymbolicCurveArray^ ConvertModelToSymbolicCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves
Type: Autodesk.Revit.DB..::.ModelCurveArray
The model curve array to be converted.

Remarks

This operation will create new SymbolicCurves with the modelCurves' geometry curves and delete the ModelCurve in the array. If modelCurves are not parallel to the workplane, they will be projected to the workplane and create new SymbolicCurves with the projected curves.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::.ArgumentException | Thrown when view is invalid to create SymbolicCurves on it.
System..::.InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.

See Also

Document Class


ConvertSymbolicToModelCurves Method

[image]

Revit 2011 API
Document..::.ConvertSymbolicToModelCurves Method
Document Class See Also Send Feedback
Converts a group of SymbolicCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray ConvertSymbolicToModelCurves(
    View view,
    SymbolicCurveArray symbolicCurve
)
Visual Basic (Declaration)
Public Function ConvertSymbolicToModelCurves ( _
    view As View, _
    symbolicCurve As SymbolicCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertSymbolicToModelCurves(
    View^ view,
    SymbolicCurveArray^ symbolicCurve
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
symbolicCurve
Type: Autodesk.Revit.DB..::.SymbolicCurveArray
The symbolic curve array to be converted.

Remarks

This operation will create new ModelCurves with the symbolicCurves' geometry curves and delete the SymbolicCurve in the array.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::.InvalidOperationException | Thrown when one or more curves could not be successfully converted.

See Also

Document Class


Delete Method

[image] [image]

Revit 2011 API
Document..::.Delete Method
Document Class See Also Send Feedback
Deletes one or more elements from the document.

Overload List

Name | Description
Delete(Element) | Deletes an element from the document.
Delete(ElementId) | Deletes an element from the document given the id of that element.
Delete(ElementSet) | Deletes several elements from the document.
Delete(ICollection<(Of <(ElementId>)>)) | Deletes several elements from the document given their ids.

See Also

Document Class
Document Members


Delete Method (Element)

[image]

Revit 2011 API
Document..::.Delete Method (Element)
Document Class Example See Also Send Feedback
Deletes an element from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    Element element
)
Visual Basic (Declaration)
Public Function Delete ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete a selected element.
   ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(element);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit",prompt);

}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Delete a selected element.
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(element)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)

End Sub

See Also

Document Class
Delete Overload


Delete Method (ElementId)

[image]

Revit 2011 API
Document..::.Delete Method (ElementId)
Document Class Example See Also Send Feedback
Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ElementId id
)
Visual Basic (Declaration)
Public Function Delete ( _
    id As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete an element via its id
    Autodesk.Revit.DB.ElementId elementId = element.Id;
    ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementId);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit", prompt);
}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Delete an element via its id
    Dim elementId As Autodesk.Revit.DB.ElementId = element.Id
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementId)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Document Class
Delete Overload


Delete Method (ElementSet)

[image]

Revit 2011 API
Document..::.Delete Method (ElementSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ElementSet elements
)
Visual Basic (Declaration)
Public Function Delete ( _
    elements As ElementSet _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of elements
UIDocument uidoc = new UIDocument(document);
ElementSet elementSet = uidoc.Selection.Elements;
ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementSet);

if (0 == deletedIdSet.Count)
{
    throw new Exception("Deleting the selected elements in Revit failed.");
}

TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of elements
Dim uidoc As New UIDocument(document)
Dim elementSet As ElementSet = uidoc.Selection.Elements
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementSet)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload


Delete Method (ICollection(ElementId))

[image]

Revit 2011 API
Document..::.Delete Method (ICollection<(Of <(ElementId>)>))
Document Class Example See Also Send Feedback
Deletes several elements from the document given their ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ICollection<ElementId> ids
)
Visual Basic (Declaration)
Public Function Delete ( _
    ids As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of element ids.
ICollection<Autodesk.Revit.DB.ElementId> idSelection = null ;
 UIDocument uidoc = new UIDocument(document);
 foreach (Autodesk.Revit.DB.Element elem in uidoc.Selection.Elements)
 {
     Autodesk.Revit.DB.ElementId id = elem.Id;
     idSelection.Add(id);
 }
 ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(idSelection);

 if (0 == deletedIdSet.Count)
 {
     throw new Exception("Deleting the selected elements in Revit failed.");
 }

 TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of element ids.
Dim idSelection As ICollection(Of Autodesk.Revit.DB.ElementId) = Nothing
Dim uidoc As New UIDocument(document)
For Each elem As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
    Dim id As Autodesk.Revit.DB.ElementId = elem.Id
    idSelection.Add(id)
Next
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(idSelection)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload


Dispose Method

[image]

Revit 2011 API
Document..::.Dispose Method
Document Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Document Class


EditFamily Method

[image]

Revit 2011 API
Document..::.EditFamily Method
Document Class Example See Also Send Feedback
Edits a family loaded in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic (Declaration)
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.DB..::.Family
The loaded family in current document.

Return Value

Reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes back to the family stored in the document, use the LoadFamily overload accepting IFamilyLoadOptions. Note: This method may not be called during dynamic update.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.DB.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";
            FilteredElementCollector collector = new FilteredElementCollector(document);
            ICollection<Element> collection =
                collector.OfClass(typeof(FamilySymbol)).ToElements();
            foreach (Element e in collection)
            {
                FamilySymbol fs = e as FamilySymbol;
                loadedFamilies += "\t" + fs.Name + "\n";
            }

            TaskDialog.Show("Revit",loadedFamilies);
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(ByVal document As Autodesk.Revit.DB.Document, ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As [String] = "FamilySymbols in " + family.Name + ":" & vbLf
            Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
            Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
            For Each e As Autodesk.Revit.DB.Element In collection
                Dim fs As FamilySymbol = TryCast(e, FamilySymbol)
                loadedFamilies += vbTab + fs.Name + vbLf
            Next

            TaskDialog.Show("Revit", loadedFamilies)
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"loadedFamily"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family or a non-editable family. (This can be checked with the IsInPlace and IsEditable properties of the Family class.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family is already being edited.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class


Export Method

[image] [image]

Revit 2011 API
Document..::.Export Method
Document Class See Also Send Feedback
Exports the document to another file format.

Overload List

Name | Description
Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Export(String, String, ViewSet, DGNExportOptions) | Exports the current view or a selection of views in DGN format.
Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Export(String, String, ViewSet, DWGExportOptions) | Exports the current view or a selection of views in DWG format.
Export(String, String, ViewSet, DXFExportOptions) | Exports the current view or a selection of views in DXF format.
Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members


Export Method (String, String, MassGBXMLExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, MassGBXMLExportOptions)
Document Class See Also Send Feedback
Exports a gbXML file from a mass model document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Export(
    string folder,
    string name,
    MassGBXMLExportOptions options
)
Visual Basic (Declaration)
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As MassGBXMLExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    MassGBXMLExportOptions^ options
)

Parameters

folder
Type: System..::.String
Indicates the path of a folder where to export the gbXML file.
name
Type: System..::.String
Indicates the name of the gbXML file to export. If it doesn't end with ".xml", extension ".xml" will be added automaticly. Empty name is not acceptable.
options
Type: Autodesk.Revit.DB.Analysis..::.MassGBXMLExportOptions
Options which control the contents of the export.

Remarks

This is only available for projects containing one or more instances of Conceptual Mass families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The path is not valid for exporting gbXML files. -or- The name is empty or not valid for exporting gbXML files. -or- options object is invalid: There should be at least one Id in MassZoneIds, the MassIds should be for masses without mass floors.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The weather station name is not valid for exporting gbXML files. -or- Cannot export gbXML files, because the energy model setting is off. -or- Failed to export gbxml files due to internal errors.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Document Class
Export Overload


Export Method (String, String, GBXMLExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, GBXMLExportOptions)
Document Class See Also Send Feedback
Exports the document in Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::.GBXMLExportOptions
Options applicable to the gbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

Document Class
Export Overload


Export Method (String, String, IFCExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, IFCExportOptions)
Document Class See Also Send Feedback
Exports the document to the Industry Standard Classes (IFC) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    IFCExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    options As IFCExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    IFCExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
The name of the file to be exported to. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::.IFCExportOptions
Options applicable to the IFC format. If nullNothingnullptra null reference (Nothing in Visual Basic), default options will be used

Return Value

Function returns true only if the model has been exported successfully. Otherwise it return False.

Remarks

Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.

This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DGNExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DGNExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DGN format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DGNExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DGNExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DGNExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DGNExportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWFExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DWFExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DWFExportOptions
Various options applicable to the DWF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is not modifiable.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWFXExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DWFXExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWFX format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFXExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DWFXExportOptions
Various options applicable to the DWFX format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is not modifiable.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWGExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DWGExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWGExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DWGExportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DXFExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, DXFExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DXF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DXFExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DXFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DXFExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.DXFExportOptions
Various options applicable to the DXF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, FBXExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, FBXExportOptions)
Document Class See Also Send Feedback
Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
options
Type: Autodesk.Revit.DB..::.FBXExportOptions
Options applicable to the FBX format.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, SATExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, ViewSet, SATExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in SAT format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    SATExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As SATExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    SATExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::.String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::.ViewSet
Selection of views to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, only the active view will be exported.
options
Type: Autodesk.Revit.DB..::.SATExportOptions
Various options applicable to the SAT format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload


Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)

[image]

Revit 2011 API
Document..::.Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)
Document Class See Also Send Feedback
Exports the document in the format of Civil Engineering design applications.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    View3D view,
    ViewPlan grossAreaPlan,
    BuildingSiteExportOptions options
)
Visual Basic (Declaration)
Public Function Export ( _
    folder As String, _
    name As String, _
    view As View3D, _
    grossAreaPlan As ViewPlan, _
    options As BuildingSiteExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    View3D^ view,
    ViewPlan^ grossAreaPlan,
    BuildingSiteExportOptions^ options
)

Parameters

folder
Type: System..::.String
Output folder, into which file will be exported. The folder must exist.
name
Type: System..::.String
The name for the exported civil file. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used."
view
Type: Autodesk.Revit.DB..::.View3D
3D View to be exported. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, the active view will be exported. If the active view is not a 3D view, an ArgumentException will be thrown.
grossAreaPlan
Type: Autodesk.Revit.DB..::.ViewPlan
All the areas on the view plan will be exported, it must be 'Gross Building' area plan. It must not be nullNothingnullptra null reference (Nothing in Visual Basic). To check whether its area scheme is Gross Building, use IsGrossBuildingArea property of AreaScheme.
options
Type: Autodesk.Revit.DB..::.BuildingSiteExportOptions
Various options applicable to the format of Civil Engineering design applications. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

See Also

Document Class
Export Overload


ExportImage Method

[image]

Revit 2011 API
Document..::.ExportImage Method
Document Class See Also Send Feedback
Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ExportImage(
    ImageExportOptions options
)
Visual Basic (Declaration)
Public Sub ExportImage ( _
    options As ImageExportOptions _
)
Visual C++
public:
void ExportImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.ImageExportOptions
The options which govern the image export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.FileNotFoundException | The path indicated could not be found.
Autodesk.Revit.Exceptions..::.FileAccessException | The path indicated could not be accessed.

See Also

Document Class


FindReferencesByDirection Method

[image]

Revit 2011 API
Document..::.FindReferencesByDirection Method
Document Class See Also Send Feedback
Finds the references that intersect a line extended in a certain direction from an origin point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray FindReferencesByDirection(
    XYZ pOrigin,
    XYZ pDirection,
    View3D pView
)
Visual Basic (Declaration)
Public Function FindReferencesByDirection ( _
    pOrigin As XYZ, _
    pDirection As XYZ, _
    pView As View3D _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ FindReferencesByDirection(
    XYZ^ pOrigin,
    XYZ^ pDirection,
    View3D^ pView
)

Parameters

pOrigin
Type: Autodesk.Revit.DB..::.XYZ
The origin of the line.
pDirection
Type: Autodesk.Revit.DB..::.XYZ
The direction.
pView
Type: Autodesk.Revit.DB..::.View3D
The 3D view used to determine the geometry for intersection. If the view has specific geometry (section cuts, visibility changes due to detail level or hidden categories) this will affect the results.

Return Value

An array of references for items the line intersects.

Remarks

This method finds both elements and geometric references which intersect the ray. Some element references returned will not have a corresponding geometric object which is also intersected (for example, rays passing through openings in walls will intersect the wall and the opening element). If you are interested only in true physical intersections you should discard all references whose GeometryObject is of type Element.

References will be found and returned from either the positive or negative direction along the line. Use the reference's ProximityParameter to sort the results or exclude references found in the opposite direction to the given direction.

This method will return intersections encountered only in the main document. Intersections in linked files will not be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when pOrigin, pDirection or pView is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class


GetDocumentPreviewSettings Method

[image]

Revit 2011 API
Document..::.GetDocumentPreviewSettings Method
Document Class See Also Send Feedback
Returns the preview settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentPreviewSettings GetDocumentPreviewSettings()
Visual Basic (Declaration)
Public Function GetDocumentPreviewSettings As DocumentPreviewSettings
Visual C++
public:
DocumentPreviewSettings^ GetDocumentPreviewSettings()

Return Value

The preview settings.

See Also

Document Class


GetRoomAtPoint Method

[image] [image]

Revit 2011 API
Document..::.GetRoomAtPoint Method
Document Class See Also Send Feedback
Gets a room containing the point.

Overload List

Name | Description
GetRoomAtPoint(XYZ) | Gets a room containing the point.
GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.

See Also

Document Class
Document Members


GetRoomAtPoint Method (XYZ)

[image]

Revit 2011 API
Document..::.GetRoomAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.

Return Value

The room containing the point.

Remarks

Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetRoomAtPoint Method (XYZ, Phase)

[image]

Revit 2011 API
Document..::.GetRoomAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetRoomAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::.Phase
Phase in which the room exists.

Return Value

The room containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetSpaceAtPoint Method

[image] [image]

Revit 2011 API
Document..::.GetSpaceAtPoint Method
Document Class See Also Send Feedback
Gets a space containing the point.

Overload List

Name | Description
GetSpaceAtPoint(XYZ) | Gets a space containing the point.
GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.

See Also

Document Class
Document Members


GetSpaceAtPoint Method (XYZ)

[image]

Revit 2011 API
Document..::.GetSpaceAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.

Return Value

The space containing the point.

Remarks

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


GetSpaceAtPoint Method (XYZ, Phase)

[image]

Revit 2011 API
Document..::.GetSpaceAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic (Declaration)
Public Function GetSpaceAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::.Phase
Phase in which the space exists.

Return Value

The space containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


Import Method

[image] [image]

Revit 2011 API
Document..::.Import Method
Document Class See Also Send Feedback
Imports the contents of an external file into the document.

Overload List

Name | Description
Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Import(String, InventorImportOptions) | Imports an Inventor file into the document.
Import(String, DWGImportOptions, Element%) | Imports a DWG file into the document.
Import(String, ImageImportOptions, Element%) | Imports an image (a bitmap) into the document.

See Also

Document Class
Document Members


Import Method (String, GBXMLImportOptions)

[image]

Revit 2011 API
Document..::.Import Method (String, GBXMLImportOptions)
Document Class See Also Send Feedback
Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    GBXMLImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As GBXMLImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.GBXMLImportOptions
Various options applicable to GBXml import. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)). The method will return False if not succeed. e.g when the input xml file does not contain any result elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when file argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.FileNotFoundException | Thrown when the file specified does not exist.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.

See Also

Document Class
Import Overload


Import Method (String, InventorImportOptions)

[image]

Revit 2011 API
Document..::.Import Method (String, InventorImportOptions)
Document Class See Also Send Feedback
Imports an Inventor file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    InventorImportOptions options
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As InventorImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    InventorImportOptions^ options
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.InventorImportOptions
Various options applicable to Inventor import. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

A file with "adsk" extension is expected. Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when 'file' argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.FileNotFoundException | Thrown when the file specified does not exist.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the file is not an inventor file.

See Also

Document Class
Import Overload


Import Method (String, DWGImportOptions, Element)

[image]

Revit 2011 API
Document..::.Import Method (String, DWGImportOptions, Element%)
Document Class See Also Send Feedback
Imports a DWG file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.DWGImportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when importing into 3D view but ThisViewOnly property is set to True in options. Thrown when the file to be imported is not an existing DWG file.

See Also

Document Class
Import Overload


Import Method (String, ImageImportOptions, Element)

[image]

Revit 2011 API
Document..::.Import Method (String, ImageImportOptions, Element%)
Document Class See Also Send Feedback
Imports an image (a bitmap) into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    ImageImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::.ImageImportOptions
Various options applicable to an image. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

See Also

Document Class
Import Overload


Link Method

[image]

Revit 2011 API
Document..::.Link Method
Document Class See Also Send Feedback
Links a DWG file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Link(
    string file,
    DWGImportOptions options,
    out Element element
)
Visual Basic (Declaration)
Public Function Link ( _
    file As String, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Link(
    String^ file,
    DWGImportOptions^ options,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::.String
Full path of the DWG file to link. File must exist.
options
Type: Autodesk.Revit.DB..::.DWGImportOptions
Various import options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
element
Type: Autodesk.Revit.DB..::.Element %
The linked instance after a successful link. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when linking into 3D view but ThisViewOnly property is set to True in options. Thrown when the file to be linked is not an existing DWG file.

See Also

Document Class


LoadFamily Method

[image] [image]

Revit 2011 API
Document..::.LoadFamily Method
Document Class See Also Send Feedback
Loads a family and all its types/symbols.

Overload List

Name | Description
LoadFamily(Document) | Loads the contents of this family document into another document.
LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

See Also

Document Class
Document Members


LoadFamily Method (Document)

[image]

Revit 2011 API
Document..::.LoadFamily Method (Document)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::.Document
The target document where the family will be loaded.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, this method will always fail. This is because this method automatically suppresses the prompts Revit typically uses to deal with conflicts between families, and assumes that any such conflict should prevent the loading. If you want to be able to reload the same family into the source document, you should use the LoadFamily overload accepting IFamilyLoadOptions.

Note: this method may not be called during dynamic update.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"targetDocument"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is not a family document, or when the target document doesn't support load of this family, or when this family was found in the target document already and the conflict caused an automatic abort of the load operation, or when a shared family in this family was found in the target document already and the conflict caused an automatic abort of the load operation.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String)

[image]

Revit 2011 API
Document..::.LoadFamily Method (String)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (Document, IFamilyLoadOptions)

[image]

Revit 2011 API
Document..::.LoadFamily Method (Document, IFamilyLoadOptions)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument,
    IFamilyLoadOptions familyLoadOptions
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    targetDocument As Document, _
    familyLoadOptions As IFamilyLoadOptions _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument,
    IFamilyLoadOptions^ familyLoadOptions
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::.Document
The target document which the family will be loaded into.
familyLoadOptions
Type: Autodesk.Revit.DB..::.IFamilyLoadOptions
The interface implementation to use when responding to conflicts during the load operation.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, use this overload. This is because this overload allows you to respond to possible conflicts due to families already being present in the target document. The Revit API offers one automatic overload: RevitUIFamilyLoadOptions, which will show the same prompts to the user as seen during an interactive load. Note: this method may not be called during dynamic update.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"targetDocument" or "familyLoadOptions"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is not a family document, or the target document doesn't support load of this family. or the load was cancelled due to a conflict and a False return from one of the interface methods.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, Family)

[image]

Revit 2011 API
Document..::.LoadFamily Method (String, Family%)
Document Class Example See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename,
    out Family family
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Type: Autodesk.Revit.DB..::.Family %
A reference to the family that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Examples

CopyC#
// Get the Revit library path.
String libraryPath = application.Application.LibraryPaths.get_Item("Imperial Library");
if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.DB.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        TaskDialog.Show("Revit","Family file has been loaded. Its name is " + name);
    }
    else
    {
        TaskDialog.Show("Revit","Can't load the family file.");
    }
}
CopyVB.NET
' Get the Revit library path.
Dim libraryPath As [String] = application.Application.LibraryPaths.Item("Imperial Library")
If [String].IsNullOrEmpty(libraryPath) Then
    ' If not have, use a default path.
    libraryPath = "c:\"
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.DB.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As [String] = family.Name
        TaskDialog.Show("Revit", "Family file has been loaded. Its name is " + name)
    Else
        TaskDialog.Show("Revit", "Can't load the family file.")
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, IFamilyLoadOptions, Family)

[image]

Revit 2011 API
Document..::.LoadFamily Method (String, IFamilyLoadOptions, Family%)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename,
    IFamilyLoadOptions familyLoadOptions,
    out Family family
)
Visual Basic (Declaration)
Public Function LoadFamily ( _
    filename As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
familyLoadOptions
Type: Autodesk.Revit.DB..::.IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
family
Type: Autodesk.Revit.DB..::.Family %
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument "familyLoadOptions" is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
LoadFamily Overload


LoadFamilySymbol Method

[image] [image]

Revit 2011 API
Document..::.LoadFamilySymbol Method
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Overload List

Name | Description
LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

See Also

Document Class
Document Members


LoadFamilySymbol Method (String, String)

[image]

Revit 2011 API
Document..::.LoadFamilySymbol Method (String, String)
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, FamilySymbol)

[image]

Revit 2011 API
Document..::.LoadFamilySymbol Method (String, String, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol)

[image]

Revit 2011 API
Document..::.LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    IFamilyLoadOptions familyLoadOptions,
    out FamilySymbol symbol
)
Visual Basic (Declaration)
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::.String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::.String
The name of the type/symbol to be loaded, such as "W11x14".
familyLoadOptions
Type: Autodesk.Revit.DB..::.IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
symbol
Type: Autodesk.Revit.DB..::.FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


Mirror Method

[image] [image]

Revit 2011 API
Document..::.Mirror Method
Document Class See Also Send Feedback
Mirrors one or more elements.

Overload List

Name | Description
Mirror(Element, Reference) | Mirrors an element about a reference.
Mirror(ElementId, Reference) | Mirrors an element, specified by id, about a reference.
Mirror(ElementSet, Line) | Mirrors several elements about an arbitrary geometric line.
Mirror(ElementSet, Reference) | Mirrors several elements about a reference.
Mirror(ICollection<(Of <(ElementId>)>), Reference) | Mirrors several elements, specified by ids, about a reference.

See Also

Document Class
Document Members


Mirror Method (Element, Reference)

[image]

Revit 2011 API
Document..::.Mirror Method (Element, Reference)
Document Class Example See Also Send Feedback
Mirrors an element about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    Element element,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    element As Element, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    Element^ element,
    Reference^ reference
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
A element that is to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

Examples

CopyC#
public void MirrorColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    UIDocument uidoc = new UIDocument(document);
    AnalyticalModel analytical = column.GetAnalyticalModel() as AnalyticalModel;
    Reference lineReference = analytical.GetCurve().Reference;
    document.Mirror(column, lineReference);

    //The selected element is changed after the Mirror operation.
    foreach (Autodesk.Revit.DB.FamilyInstance newColumn in uidoc.Selection.Elements)
    {
        bool isMirror = newColumn.Mirrored;

        TaskDialog.Show("Revit","Column is mirrored: " + isMirror);

        //Offset the new column
        XYZ translationVec = new XYZ(10, 20, 30);
        newColumn.Location.Move(translationVec);
    }
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim uidoc As New UIDocument(document)
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    Dim lineReference As Reference = analytical.GetCurve().Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.DB.FamilyInstance In uidoc.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        TaskDialog.Show("Revit", "Column is mirrored: " + isMirror)

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

See Also

Document Class
Mirror Overload


Mirror Method (ElementId, Reference)

[image]

Revit 2011 API
Document..::.Mirror Method (ElementId, Reference)
Document Class See Also Send Feedback
Mirrors an element, specified by id, about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementId id,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    id As ElementId, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementId^ id,
    Reference^ reference
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload


Mirror Method (ElementSet, Line)

[image]

Revit 2011 API
Document..::.Mirror Method (ElementSet, Line)
Document Class See Also Send Feedback
Mirrors several elements about an arbitrary geometric line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Line line
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    line As Line _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Line^ line
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be mirrored.
line
Type: Autodesk.Revit.DB..::.Line
The line by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload


Mirror Method (ElementSet, Reference)

[image]

Revit 2011 API
Document..::.Mirror Method (ElementSet, Reference)
Document Class See Also Send Feedback
Mirrors several elements about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ElementSet elements,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    elements As ElementSet, _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ElementSet^ elements,
    Reference^ reference
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload


Mirror Method (ICollection(ElementId), Reference)

[image]

Revit 2011 API
Document..::.Mirror Method (ICollection<(Of <(ElementId>)>), Reference)
Document Class See Also Send Feedback
Mirrors several elements, specified by ids, about a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirror(
    ICollection<ElementId> ids,
    Reference reference
)
Visual Basic (Declaration)
Public Function Mirror ( _
    ids As ICollection(Of ElementId), _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Mirror(
    ICollection<ElementId^>^ ids,
    Reference^ reference
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of elements that are to be mirrored.
reference
Type: Autodesk.Revit.DB..::.Reference
The reference by which the elements will mirror.

Return Value

True if the elements are mirrored successfully.

See Also

Document Class
Mirror Overload


Move Method

[image] [image]

Revit 2011 API
Document..::.Move Method
Document Class See Also Send Feedback
Moves one or more elements within the document by a specified vector.

Overload List

Name | Description
Move(Element, XYZ) | Moves an element within the document by a specified vector.
Move(ElementId, XYZ) | Moves an element, specified by id, within the document by a specified vector.
Move(ElementSet, XYZ) | Moves several elements within the document by a specified vector.
Move(ICollection<(Of <(ElementId>)>), XYZ) | Moves several elements, specified by a set of ids, within the document by a specified vector.

See Also

Document Class
Document Members


Move Method (Element, XYZ)

[image]

Revit 2011 API
Document..::.Move Method (Element, XYZ)
Document Class Example See Also Send Feedback
Moves an element within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    Element element,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    element As Element, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    Element^ element,
    XYZ^ translationVec
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

True if the element is moved successfully, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved. For example, if the element is level, all the elements on that level will also move.

Examples

CopyC#
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    document.Move(column, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Public Sub MoveColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As Autodesk.Revit.DB.XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New Autodesk.Revit.DB.XYZ(10, 20, 30)
    document.Move(column, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As Autodesk.Revit.DB.XYZ = columnLocation.Point

    Dim info As String = "Original Z location: " + oldPlace.Z + vbLf & "New Z location: " + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

See Also

Document Class
Move Overload


Move Method (ElementId, XYZ)

[image]

Revit 2011 API
Document..::.Move Method (ElementId, XYZ)
Document Class See Also Send Feedback
Moves an element, specified by id, within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    ElementId id,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    id As ElementId, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementId^ id,
    XYZ^ translationVec
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

True if the element is moved successfully, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved. For example, if the element is wall and it contains windows, the windows will also move.

See Also

Document Class
Move Overload


Move Method (ElementSet, XYZ)

[image]

Revit 2011 API
Document..::.Move Method (ElementSet, XYZ)
Document Class See Also Send Feedback
Moves several elements within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    ElementSet elements,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    elements As ElementSet, _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ElementSet^ elements,
    XYZ^ translationVec
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of element which are to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the elements are to be moved.

Return Value

True if the elements are moved successfully, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved. For example, if the elements are floors, the openings within those floors will also move.

See Also

Document Class
Move Overload


Move Method (ICollection(ElementId), XYZ)

[image]

Revit 2011 API
Document..::.Move Method (ICollection<(Of <(ElementId>)>), XYZ)
Document Class See Also Send Feedback
Moves several elements, specified by a set of ids, within the document by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    ICollection<ElementId> ids,
    XYZ translationVec
)
Visual Basic (Declaration)
Public Function Move ( _
    ids As ICollection(Of ElementId), _
    translationVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    ICollection<ElementId^>^ ids,
    XYZ^ translationVec
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids specifying which elements are to be moved.
translationVec
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the elements are to be moved.

Return Value

True if the elements are moved successfully, otherwise False.

Remarks

The move method is used to move several elements within the project. Other elements may also be moved when these elements are moved. For example, if the elements are structural columns, all the beams joined to those columns will also move or resize.

See Also

Document Class
Move Overload


PostFailure Method

[image]

Revit 2011 API
Document..::.PostFailure Method
Document Class Example See Also Send Feedback
Posts a failure to be displayed to the user at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessageKey PostFailure(
    FailureMessage failure
)
Visual Basic (Declaration)
Public Function PostFailure ( _
    failure As FailureMessage _
) As FailureMessageKey
Visual C++
public:
FailureMessageKey^ PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessage
The failure to be posted.

Return Value

A unique key that identifies posted failure message in a document. If exactly the same error is posted more than once, and not removed between the postings, returned key will be the same every time.

Remarks

If code inside transaction detects a problem that needs to be communicated to the user, it should report these conditions via this method. Failures will be validated and possibly resolved at the end of transaction. Warnings posted via this method will not be stored in the document after they are resolved. A unique key returned by postFailure can be stored for the lifetime of transaction and used to remove failure message if it is no longer relevant.

Examples

CopyC#
// Execute function for an Updater triggered when new FamilyInstances are added
public void Execute(UpdaterData data)
{
    Document doc = data.GetDocument();
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    foreach (ElementId id in data.GetModifiedElementIds())
    {
        FamilyInstance fi = doc.get_Element(id) as FamilyInstance;
        if (fi.StructuralType == StructuralType.Beam)
        {
            AnalyticalModel analyticalModel = fi.GetAnalyticalModel();
            if (analyticalModel.IsSingleCurve() == true)
            {
                Curve beamCurve = analyticalModel.GetCurve();
                // enforce beam length minimum of 12 inches
                if (beamCurve.Length < 12.0)
                {
                    FailureMessage failMessage =
                        new FailureMessage(BuiltInFailures.CurveFailures.TooShort);
                    failMessage.SetFailingElement(id);
                    doc.PostFailure(failMessage);
                }
            }
        }
    }
}
CopyVB.NET
' Execute function for an Updater triggered when new FamilyInstances are added
Public Sub Execute(ByVal data As UpdaterData) Implements IUpdater.Execute
    Dim doc As Document = data.GetDocument()
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    For Each id As ElementId In data.GetModifiedElementIds()
        Dim fi As Autodesk.Revit.DB.FamilyInstance = TryCast(doc.Element(id), Autodesk.Revit.DB.FamilyInstance)
        If fi.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Beam Then
            Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalModel = fi.GetAnalyticalModel()
            If analyticalModel.IsSingleCurve() = True Then
                Dim beamCurve As Curve = analyticalModel.GetCurve()
                ' enforce beam length minimum of 12 inches
                If beamCurve.Length < 12 Then
                    Dim failMessage As New FailureMessage(BuiltInFailures.CurveFailures.TooShort)
                    failMessage.SetFailingElement(id)
                    doc.PostFailure(failMessage)
                End If
            End If
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Print Method

[image] [image]

Revit 2011 API
Document..::.Print Method
Document Class See Also Send Feedback
Prints a set of views.

Overload List

Name | Description
Print(ViewSet) | Prints a set of views with default view template and default print settings.
Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.

See Also

Document Class
Document Members


Print Method (ViewSet)

[image]

Revit 2011 API
Document..::.Print Method (ViewSet)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    ViewSet views
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet _
)
Visual C++
public:
void Print(
    ViewSet^ views
)

Parameters

views
Type: Autodesk.Revit.DB..::.ViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, View)

[image]

Revit 2011 API
Document..::.Print Method (ViewSet, View)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
Type: Autodesk.Revit.DB..::.ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.DB..::.View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, Boolean)

[image]

Revit 2011 API
Document..::.Print Method (ViewSet, Boolean)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.DB..::.ViewSet
The set of views which need to be printed.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, View, Boolean)

[image]

Revit 2011 API
Document..::.Print Method (ViewSet, View, Boolean)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.DB..::.ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.DB..::.View
The view template which apply to the set of views.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Regenerate Method

[image]

Revit 2011 API
Document..::.Regenerate Method
Document Class See Also Send Feedback
Updates the elements in the Revit document to reflect all changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Regenerate()
Visual Basic (Declaration)
Public Sub Regenerate
Visual C++
public:
void Regenerate()

Remarks

Use this method to force update to the document after a group of changes. Note that when a transaction is committed there is an automatic call to regenerate the document.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions..::.RegenerationFailedException Thrown when the regeneration option is automatic or the operation fails.
  • If regeneration fails, there is posted error of severity DocumentCorruption that will be delivered to the end user at the end of transaction explaining what specifically has happened.
  • If regeneration has failed, document is corrupted and even reading from it is illegal.
  • Code that called regeneration and got this exception should not catch and ignore it - instead, it should do nothing but internal cleanup and return control to the owner of currently active transaction/subtransaction, which must be aborted.

See Also

Document Class


Rotate Method

[image] [image]

Revit 2011 API
Document..::.Rotate Method
Document Class See Also Send Feedback
Rotates one or more elements within the document by a specified angle around a given axis.

Overload List

Name | Description
Rotate(Element, Line, Double) | Rotates an element within the document by a specified angle around a given axis.
Rotate(ElementId, Line, Double) | Rotates an element, specified by id, within the document by a specified angle around a given axis.
Rotate(ElementSet, Line, Double) | Rotates several elements within the document by a specified angle around a given axis.
Rotate(ICollection<(Of <(ElementId>)>), Line, Double) | Rotates several elements, specified by a set of ids, within the document by a specified angle around a given axis.

See Also

Document Class
Document Members


Rotate Method (Element, Line, Double)

[image]

Revit 2011 API
Document..::.Rotate Method (Element, Line, Double)
Document Class Example See Also Send Feedback
Rotates an element within the document by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    Element element,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    element As Element, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Element^ element,
    Line^ axis,
    double angle
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element that is to be rotated.
axis
Type: Autodesk.Revit.DB..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

True if the element is rotated successfully, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
public bool RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    // The axis should be a bound line.
    Line axis = document.Application.Create.NewLineBound(point1, point2);
    bool successful = document.Rotate(element, axis, Math.PI / 3.0);

    return successful;
}
CopyVB.NET
Public Function RotateColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim point1 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Dim point2 As New Autodesk.Revit.DB.XYZ(10, 20, 30)
    ' The axis should be a bound line.
    Dim axis As Line = document.Application.Create.NewLineBound(point1, point2)
    Dim successful As Boolean = document.Rotate(element, axis, Math.PI / 3)

    Return successful
End Function

See Also

Document Class
Rotate Overload


Rotate Method (ElementId, Line, Double)

[image]

Revit 2011 API
Document..::.Rotate Method (ElementId, Line, Double)
Document Class See Also Send Feedback
Rotates an element, specified by id, within the document by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    ElementId id,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    id As ElementId, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementId^ id,
    Line^ axis,
    double angle
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId for the element that is to be rotated.
axis
Type: Autodesk.Revit.DB..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

True if the element is rotated successfully, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. The line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload


Rotate Method (ElementSet, Line, Double)

[image]

Revit 2011 API
Document..::.Rotate Method (ElementSet, Line, Double)
Document Class See Also Send Feedback
Rotates several elements within the document by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    ElementSet elements,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    elements As ElementSet, _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ElementSet^ elements,
    Line^ axis,
    double angle
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements that are to be rotated.
axis
Type: Autodesk.Revit.DB..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be rotated around the specified axis.

Return Value

True if the elements are rotated successfully, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload


Rotate Method (ICollection(ElementId), Line, Double)

[image]

Revit 2011 API
Document..::.Rotate Method (ICollection<(Of <(ElementId>)>), Line, Double)
Document Class See Also Send Feedback
Rotates several elements, specified by a set of ids, within the document by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    ICollection<ElementId> ids,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    ids As ICollection(Of ElementId), _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    ICollection<ElementId^>^ ids,
    Line^ axis,
    double angle
)

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of ids for the elements that are to be rotated.
axis
Type: Autodesk.Revit.DB..::.Line
A line that represents the axis of rotation, which can be either bounded or unbounded line.
angle
Type: System..::.Double
The angle, in radians, by which the elements are to be rotated around the specified axis.

Return Value

True if the elements are rotated successfully, otherwise False.

Remarks

The rotate method is used to rotate several elements within the project. Other elements may also be rotated when these elements are rotated because they are dependent upon the elements being rotated. A line used as the axis can be created by using the Application.Create object and its methods.

See Also

Document Class
Rotate Overload


Save Method

[image]

Revit 2011 API
Document..::.Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails. Also returns False if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, True is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class


SaveAs Method

[image] [image]

Revit 2011 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a new file name.

Overload List

Name | Description
SaveAs()()() | Saves the document to a file name obtained from the Revit user.
SaveAs(String) | Saves the document to a given file name.
SaveAs(String, Boolean) | Saves the document to a given file name with the option to change the document's name in Revit.

See Also

Document Class
Document Members


SaveAs Method

[image]

Revit 2011 API
Document..::.SaveAs Method
Document Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic (Declaration)
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload


SaveAs Method (String)

[image]

Revit 2011 API
Document..::.SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
File name to be saved as. Either a relative or absolute path can be provided.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the specified fileName is null or empty in UI-less mode. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters).
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload


SaveAs Method (String, Boolean)

[image]

Revit 2011 API
Document..::.SaveAs Method (String, Boolean)
Document Class See Also Send Feedback
Saves the document to a given file name with the option to change the document's name in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    bool changeDocumentFilename
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    fileName As String, _
    changeDocumentFilename As Boolean _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    bool changeDocumentFilename
)

Parameters

fileName
Type: System..::.String
File name and path to be saved as. Either a relative or absolute path can be provided.
changeDocumentFilename
Type: System..::.Boolean
Indicates if the current file name on the title bar of Revit will be changed accordingly.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the specified fileName is null or empty in UI-less mode. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters).
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload


SaveToProjectAsImage Method

[image]

Revit 2011 API
Document..::.SaveToProjectAsImage Method
Document Class See Also Send Feedback
Creates an image view from the currently active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId SaveToProjectAsImage(
    ImageExportOptions options
)
Visual Basic (Declaration)
Public Function SaveToProjectAsImage ( _
    options As ImageExportOptions _
) As ElementId
Visual C++
public:
ElementId^ SaveToProjectAsImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.ImageExportOptions
The options which govern the image creation.

Return Value

Id of the newly created view if the operation succeeded, invalid element id otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | options object is invalid: the ExportRange is invalid, must be CurrentView or VisibleRegionOfCurrentView, or the ViewName is invalid, must be non-empty, unique and should not contain prohibited characters.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Document Class


SeparateElements Method

[image]

Revit 2011 API
Document..::.SeparateElements Method
Document Class See Also Send Feedback
Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SeparateElements(
    CombinableElementArray members
)
Visual Basic (Declaration)
Public Sub SeparateElements ( _
    members As CombinableElementArray _
)
Visual C++
public:
void SeparateElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::.CombinableElementArray
A list of combinable elements to be separated.

Remarks

If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when members is empty. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when separation failed.

See Also

Document Class


UnpostFailure Method

[image]

Revit 2011 API
Document..::.UnpostFailure Method
Document Class See Also Send Feedback
Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void UnpostFailure(
    FailureMessageKey messageKey
)
Visual Basic (Declaration)
Public Sub UnpostFailure ( _
    messageKey As FailureMessageKey _
)
Visual C++
public:
void UnpostFailure(
    FailureMessageKey^ messageKey
)

Parameters

messageKey
Type: Autodesk.Revit.DB..::.FailureMessageKey
The key of the FailureMessage to be deleted.

Remarks

If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist any more and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | messageKey is invalid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Document Properties

[image] [image]

Revit 2011 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
ActiveProjectLocation | Retrieve the active project location.
ActiveView | The document's active view.
AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Application | Returns the Application in which the Document resides.
BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
DisplayUnitSystem | Provides access to display unit type with in the document.
ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Element | Overloaded. Retrieves an element from the document given an identifier.
FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
FamilyManager | The family manager object provides access to family types and parameters.
FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
IsFamilyDocument | Identifies if the current document is a family document.
IsModifiable | The document's state of modifiability.
IsModified | The state of changes made to the document.
IsReadOnly | Identifies if the document is read-only or can possibly be modified
IsReadOnlyFile | Signals whether the document was opened in read-only mode or not.
IsWorkshared | Identifies if worksets have been enabled in the document.
LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
MullionTypes | This property is used to retrieve all the mullion types in current system.
OwnerFamily | Get the Family of this Family Document.
PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
PathName | Call this function to get the fully qualified path of the document's disk file.
Phases | Retrieves all the object that represent phases within the project.
PlanTopologies | Overloaded. Gets the PlanTopologies of the current project.
PlanTopology | Overloaded. Gets the PlanTopology of a given level.
PrintManager | Retrieve the PrintManager of current project.
PrintSettings | Retrieve all Print Settings of current project.
ProjectInformation | Return the Project Information of the current project.
ProjectLocations | Retrieve all the project locations associated with this project
ProjectUnit | Provides access to Project Unit Setting with in the document.
ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Settings | Provides access to general application settings, such as Categories.
SiteLocation | Returns the site location information.
SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Title | Call this function to get the project's title, which is usually derived from the project's filename.
TitleBlocks | Titleblocks currently loaded into the document.
TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
TypeOfStorage | Get the storage type of the specified BuiltInParameter.
ViewSheetSets | The view sheet sets stored in the document.
WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
WorksharingCentralFilename | The name and path of the central file name for a workshared document.

See Also

Document Class


ActiveProjectLocation Property

[image]

Revit 2011 API
Document..::.ActiveProjectLocation Property
Document Class See Also Send Feedback
Retrieve the active project location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectLocation ActiveProjectLocation { get; set; }
Visual Basic (Declaration)
Public Property ActiveProjectLocation As ProjectLocation
Visual C++
public:
property ProjectLocation^ ActiveProjectLocation {
    ProjectLocation^ get ();
    void set (ProjectLocation^ value);
}

Remarks

Getting this property returns the currently active project location that the user is currently working with. Setting this property can be used to change the active project location.

See Also

Document Class


ActiveView Property

[image]

Revit 2011 API
Document..::.ActiveView Property
Document Class Example See Also Send Feedback
The document's active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View ActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveView As View
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. nullNothingnullptra null reference (Nothing in Visual Basic) if no view is considered active.

Examples

CopyC#
// Get the active view of the current document.
Autodesk.Revit.DB.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.DB.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.DB.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.DB.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.DB.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get the active view of the current document.
Dim view As Autodesk.Revit.DB.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As [String] = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.DB.View3D Then
    prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSection Then
    prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSheet Then
    prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewDrafting Then
    prompt += "drafting view."
Else
    prompt += "normal view, the view name is " + view.Name
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

See Also

Document Class


AnnotationSymbolTypes Property

[image]

Revit 2011 API
Document..::.AnnotationSymbolTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the annotation types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet AnnotationSymbolTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnnotationSymbolTypes As AnnotationSymbolTypeSet
Visual C++
public:
property AnnotationSymbolTypeSet^ AnnotationSymbolTypes {
    AnnotationSymbolTypeSet^ get ();
}

Remarks

This property returns a set of AnnotationSymbol objects. These objects can be used change the type of an Annotation from one type to another.

See Also

Document Class


Application Property

[image]

Revit 2011 API
Document..::.Application Property
Document Class See Also Send Feedback
Returns the Application in which the Document resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

Document Class


BeamSystemTypes Property

[image]

Revit 2011 API
Document..::.BeamSystemTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of beam system types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemTypeSet BeamSystemTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property BeamSystemTypes As BeamSystemTypeSet
Visual C++
public:
property BeamSystemTypeSet^ BeamSystemTypes {
    BeamSystemTypeSet^ get ();
}

Remarks

This property returns a set of BeamSystemType objects. These objects can be used change the type of a BeamSystem from one type to another.

See Also

Document Class


ContFootingTypes Property

[image]

Revit 2011 API
Document..::.ContFootingTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of continuous footing types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ContFootingTypeSet ContFootingTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContFootingTypes As ContFootingTypeSet
Visual C++
public:
property ContFootingTypeSet^ ContFootingTypes {
    ContFootingTypeSet^ get ();
}

Remarks

This property returns a set of ContFootingType objects. These objects can be used change the type of a ContFooting from one type to another.

See Also

Document Class


Create Property

[image]

Revit 2011 API
Document..::.Create Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Document
Visual C++
public:
property Document^ Create {
    Document^ get ();
}

Field Value

This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is family document.

See Also

Document Class


CurtainSystemTypes Property

[image]

Revit 2011 API
Document..::.CurtainSystemTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the CurtainSystem types in current system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainSystemTypeSet CurtainSystemTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainSystemTypes As CurtainSystemTypeSet
Visual C++
public:
property CurtainSystemTypeSet^ CurtainSystemTypes {
    CurtainSystemTypeSet^ get ();
}

Remarks

This property returns a set of CurtainSystemType objects. These objects can be used change the type of a CurtainSystem from one type to another.

See Also

Document Class


DeckProfiles Property

[image]

Revit 2011 API
Document..::.DeckProfiles Property
Document Class See Also Send Feedback
Returns an object that contains all of the available deck profiles currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet DeckProfiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeckProfiles As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ DeckProfiles {
    FamilySymbolSet^ get ();
}

Remarks

The DeckProfiles property returns an object that contains the deck profiles which can be used to change the profile of a layer within a compound structure object.

See Also

Document Class


DimensionTypes Property

[image]

Revit 2011 API
Document..::.DimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of dimension types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DimensionTypeSet DimensionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DimensionTypes As DimensionTypeSet
Visual C++
public:
property DimensionTypeSet^ DimensionTypes {
    DimensionTypeSet^ get ();
}

Remarks

This property returns a set of DimensionType objects. These objects can be used change the type of a Dimension from one type to another.

See Also

Document Class


DisplayUnitSystem Property

[image]

Revit 2011 API
Document..::.DisplayUnitSystem Property
Document Class See Also Send Feedback
Provides access to display unit type with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DisplayUnit DisplayUnitSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
Visual C++
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}

Remarks

Return the display unit type, metric or imperial.

See Also

Document Class


ElectricalEquipmentTypes Property

[image]

Revit 2011 API
Document..::.ElectricalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available electrical equipment types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet ElectricalEquipmentTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ ElectricalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The ElectricalEquipmentTypes property returns an object that contains the electrical equipment types which can be used to change the type of an electrical equipment from one type to another.

See Also

Document Class


Element Property

[image] [image]

Revit 2011 API
Document..::.Element Property
Document Class See Also Send Feedback
Retrieves an element from the document given an identifier.

Overload List

Name | Description
Element[([(ElementId])]) | Retrieves an element from the document given a Revit element id.
Element[([(String])]) | Retrieves an element from the document given a unique id string.

See Also

Document Class
Document Members


Element Property (ElementId)

[image]

Revit 2011 API
Document..::.Element Property (ElementId)
Document Class See Also Send Feedback
Retrieves an element from the document given a Revit element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element[
    ElementId id
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
    id As ElementId _
) As Element
Visual C++
public:
property Element^ Element[ElementId^ id] {
    Element^ get (ElementId^ id);
}

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The Autodesk::Revit::DB::ElementId^ of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the Autodesk::Revit::DB::ElementId^ does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload


Element Property (String)

[image]

Revit 2011 API
Document..::.Element Property (String)
Document Class See Also Send Feedback
Retrieves an element from the document given a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element[
    string
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element ( _
     As String _
) As Element
Visual C++
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

Type: System..::.String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload


FamilyCreate Property

[image]

Revit 2011 API
Document..::.FamilyCreate Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyItemFactory FamilyCreate { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCreate As FamilyItemFactory
Visual C++
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}

Field Value

This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


FamilyManager Property

[image]

Revit 2011 API
Document..::.FamilyManager Property
Document Class See Also Send Feedback
The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyManager FamilyManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyManager As FamilyManager
Visual C++
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}

Remarks

This property is available when the document is a family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


FasciaTypes Property

[image]

Revit 2011 API
Document..::.FasciaTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Fascia types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FasciaTypeSet FasciaTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property FasciaTypes As FasciaTypeSet
Visual C++
public:
property FasciaTypeSet^ FasciaTypes {
    FasciaTypeSet^ get ();
}

Remarks

This property returns a set of FasciaType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


FloorTypes Property

[image]

Revit 2011 API
Document..::.FloorTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the floor types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FloorTypeSet FloorTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property FloorTypes As FloorTypeSet
Visual C++
public:
property FloorTypeSet^ FloorTypes {
    FloorTypeSet^ get ();
}

Remarks

This property returns a set of FloorType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


GridTypes Property

[image]

Revit 2011 API
Document..::.GridTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of Grid types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridTypeSet GridTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GridTypes As GridTypeSet
Visual C++
public:
property GridTypeSet^ GridTypes {
    GridTypeSet^ get ();
}

Remarks

This property returns a set of Grid objects. These objects can be used change the type of a Grid from one type to another.

See Also

Document Class


GutterTypes Property

[image]

Revit 2011 API
Document..::.GutterTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Gutter types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GutterTypeSet GutterTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GutterTypes As GutterTypeSet
Visual C++
public:
property GutterTypeSet^ GutterTypes {
    GutterTypeSet^ get ();
}

Remarks

This property returns a set of GutterType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


IsFamilyDocument Property

[image]

Revit 2011 API
Document..::.IsFamilyDocument Property
Document Class See Also Send Feedback
Identifies if the current document is a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFamilyDocument { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFamilyDocument As Boolean
Visual C++
public:
property bool IsFamilyDocument {
    bool get ();
}

See Also

Document Class


IsModifiable Property

[image]

Revit 2011 API
Document..::.IsModifiable Property
Document Class See Also Send Feedback
The document's state of modifiability.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsModifiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModifiable As Boolean
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Value of this property changes dynamically multiple times within the life-time of an open document. Regardless of the mode a document is opened with, the model can only be modified inside an open transaction. Furthermore, even with a transaction open, the model is not always modifiable. Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events. An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException. See also IsReadOnly

See Also

Document Class


IsModified Property

[image]

Revit 2011 API
Document..::.IsModified Property
Document Class See Also Send Feedback
The state of changes made to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsModified { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModified As Boolean
Visual C++
public:
property bool IsModified {
    bool get ();
}

Field Value

True if the document has been modified since it was opened or saved, False otherwise.

See Also

Document Class


IsReadOnly Property

[image]

Revit 2011 API
Document..::.IsReadOnly Property
Document Class See Also Send Feedback
Identifies if the document is read-only or can possibly be modified

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

Remarks

Like the IsModifiable, IsReadOnly is also a dynamic property. It’s value can change depending on the state a document is currently in. There are various factors that may affect this property. The most probable reason for this property to return 'true' is when Revit is currently processing failures (recoverable or not). Another possibility is when an external command is executed in read-only mode. If a document is in a read-only state, then not only the model cannot be modified at the moment, but even a new transaction may not be started. Attempting to do so will raise an InvalidOperationException.

See Also

Document Class


IsReadOnlyFile Property

[image]

Revit 2011 API
Document..::.IsReadOnlyFile Property
Document Class See Also Send Feedback
Signals whether the document was opened in read-only mode or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnlyFile As Boolean
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Remarks

A document would be opened in read-only mode when, for example, at the time of opening it was already being used by another Revit user.

Although it is still possible to modify documents opened in read-only mode, any attempt to save them would naturally fail. Therefore any changes to the document would have to be saved using the SaveAs method.

See Also

Document Class


IsWorkshared Property

[image]

Revit 2011 API
Document..::.IsWorkshared Property
Document Class See Also Send Feedback
Identifies if worksets have been enabled in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWorkshared As Boolean
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

Field Value

True if the document is using worksets, False if it is working with a local file.

See Also

Document Class


LevelTypes Property

[image]

Revit 2011 API
Document..::.LevelTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the level types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LevelTypeSet LevelTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LevelTypes As LevelTypeSet
Visual C++
public:
property LevelTypeSet^ LevelTypes {
    LevelTypeSet^ get ();
}

Remarks

This property returns a set of level objects. These objects can be used change the type of a level from one type to another.

See Also

Document Class


LightingDeviceTypes Property

[image]

Revit 2011 API
Document..::.LightingDeviceTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting device types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet LightingDeviceTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class


LightingFixtureTypes Property

[image]

Revit 2011 API
Document..::.LightingFixtureTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting fixture types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet LightingFixtureTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LightingFixtureTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ LightingFixtureTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingFixtureTypes property returns an object that contains the lighting fixture types which can be used to change the type of a lighting fixture from one type to another.

See Also

Document Class


MassDisplayTemporaryOverride Property

[image]

Revit 2011 API
Document..::.MassDisplayTemporaryOverride Property
Document Class See Also Send Feedback
This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }
Visual Basic (Declaration)
Public Property MassDisplayTemporaryOverride As MassDisplayTemporaryOverrideType
Visual C++
public:
property MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride {
    MassDisplayTemporaryOverrideType get ();
    void set (MassDisplayTemporaryOverrideType value);
}

Remarks

This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.

See Also

Document Class


MechanicalEquipmentTypes Property

[image]

Revit 2011 API
Document..::.MechanicalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class


MullionTypes Property

[image]

Revit 2011 API
Document..::.MullionTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the mullion types in current system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MullionTypeSet MullionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MullionTypes As MullionTypeSet
Visual C++
public:
property MullionTypeSet^ MullionTypes {
    MullionTypeSet^ get ();
}

Remarks

This property returns a set of MullionType objects. These objects can be used change the type of a mullion from one type to another.

See Also

Document Class


OwnerFamily Property

[image]

Revit 2011 API
Document..::.OwnerFamily Property
Document Class Example See Also Send Feedback
Get the Family of this Family Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwnerFamily As Family
Visual C++
public:
property Family^ OwnerFamily {
    Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also

Document Class


PanelTypes Property

[image]

Revit 2011 API
Document..::.PanelTypes Property
Document Class See Also Send Feedback
Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelTypeSet PanelTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelTypes As PanelTypeSet
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class


ParameterBindings Property

[image]

Revit 2011 API
Document..::.ParameterBindings Property
Document Class See Also Send Feedback
Retrieves an object from which mappings between parameter definitions and categories can be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BindingMap ParameterBindings { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParameterBindings As BindingMap
Visual C++
public:
property BindingMap^ ParameterBindings {
    BindingMap^ get ();
}

Remarks

Returns a mapping between parameter definitions and parameter bindings. New bindings can be added to the Revit Document by using this object.

See Also

Document Class


PathName Property

[image]

Revit 2011 API
Document..::.PathName Property
Document Class Example See Also Send Feedback
Call this function to get the fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

The project's fully qualified path. This string is empty if the project has not been saved or does not have a disk file associated with it.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class


Phases Property

[image]

Revit 2011 API
Document..::.Phases Property
Document Class Example See Also Send Feedback
Retrieves all the object that represent phases within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PhaseArray Phases { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phases As PhaseArray
Visual C++
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}

Remarks

The phases returned are in order of earliest phase first, through to latest phase last.

Examples

CopyC#
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Sub Getinfo_Phase(ByVal doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As [String] = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab + ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Document Class


PlanTopologies Property

[image] [image]

Revit 2011 API
Document..::.PlanTopologies Property
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project.

Overload List

Name | Description
PlanTopologies | Get the PlanTopologies of the current project in the last phase.
PlanTopologies[([(Phase])]) | Gets the PlanTopologies of the current project in a given phase.

See Also

Document Class
Document Members


PlanTopologies Property

[image]

Revit 2011 API
Document..::.PlanTopologies Property
Document Class See Also Send Feedback
Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopologies Property (Phase)

[image]

Revit 2011 API
Document..::.PlanTopologies Property (Phase)
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase
The phase of the Plan Topology.

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopology Property

[image] [image]

Revit 2011 API
Document..::.PlanTopology Property
Document Class See Also Send Feedback
Gets the PlanTopology of a given level.

Overload List

Name | Description
PlanTopology[([(Level])]) | Get the PlanTopology of a given level in the last phase.
PlanTopology[([(Level, Phase])]) | Get the PlanTopology of a given level in a given phase.

See Also

Document Class
Document Members


PlanTopology Property (Level)

[image]

Revit 2011 API
Document..::.PlanTopology Property (Level)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopology PlanTopology[
    Level level
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level] {
    PlanTopology^ get (Level^ level);
}

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level of the Plan Topology.

Remarks

Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopology Overload


PlanTopology Property (Level, Phase)

[image]

Revit 2011 API
Document..::.PlanTopology Property (Level, Phase)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopology PlanTopology[
    Level level,
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Type: Autodesk.Revit.DB..::.Level
The level of the Plan Topology.
phase
Type: Autodesk.Revit.DB..::.Phase
The phase of the Plan Topology.

Remarks

Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopology Overload


PrintManager Property

[image]

Revit 2011 API
Document..::.PrintManager Property
Document Class See Also Send Feedback
Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PrintManager PrintManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintManager As PrintManager
Visual C++
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}

See Also

Document Class


PrintSettings Property

[image]

Revit 2011 API
Document..::.PrintSettings Property
Document Class See Also Send Feedback
Retrieve all Print Settings of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet PrintSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSettings As ElementSet
Visual C++
public:
property ElementSet^ PrintSettings {
    ElementSet^ get ();
}

See Also

Document Class


ProjectInformation Property

[image]

Revit 2011 API
Document..::.ProjectInformation Property
Document Class See Also Send Feedback
Return the Project Information of the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectInfo ProjectInformation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectInformation As ProjectInfo
Visual C++
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}

Return Value

Autodesk::Revit::DB::ProjectInfo

See Also

Document Class


ProjectLocations Property

[image]

Revit 2011 API
Document..::.ProjectLocations Property
Document Class See Also Send Feedback
Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectLocationSet ProjectLocations { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocations As ProjectLocationSet
Visual C++
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}

Remarks

This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.

See Also

Document Class


ProjectUnit Property

[image]

Revit 2011 API
Document..::.ProjectUnit Property
Document Class See Also Send Feedback
Provides access to Project Unit Setting with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectUnit ProjectUnit { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectUnit As ProjectUnit
Visual C++
public:
property ProjectUnit^ ProjectUnit {
    ProjectUnit^ get ();
}

Remarks

Return the Project Unit Setting items.

See Also

Document Class


ReactionsAreUpToDate Property

[image]

Revit 2011 API
Document..::.ReactionsAreUpToDate Property
Document Class See Also Send Feedback
Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ReactionsAreUpToDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReactionsAreUpToDate As Boolean
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.

See Also

Document Class


RebarBarTypes Property

[image]

Revit 2011 API
Document..::.RebarBarTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarTypeSet RebarBarTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class


RebarCoverTypes Property

[image]

Revit 2011 API
Document..::.RebarCoverTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar cover types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverTypeSet RebarCoverTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarCoverTypes As RebarCoverTypeSet
Visual C++
public:
property RebarCoverTypeSet^ RebarCoverTypes {
    RebarCoverTypeSet^ get ();
}

Remarks

This property returns a set of RebarCoverType objects.

See Also

Document Class


RebarHookTypes Property

[image]

Revit 2011 API
Document..::.RebarHookTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar hook types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookTypeSet RebarHookTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarHookTypes As RebarHookTypeSet
Visual C++
public:
property RebarHookTypeSet^ RebarHookTypes {
    RebarHookTypeSet^ get ();
}

Remarks

This property returns a set of rebarhooktype objects.

See Also

Document Class


RebarShapes Property

[image]

Revit 2011 API
Document..::.RebarShapes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar shape types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeSet RebarShapes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RebarShapes As RebarShapeSet
Visual C++
public:
property RebarShapeSet^ RebarShapes {
    RebarShapeSet^ get ();
}

Remarks

This property returns a set of RebarShape objects.

See Also

Document Class


RoofTypes Property

[image]

Revit 2011 API
Document..::.RoofTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the roof types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoofTypeSet RoofTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoofTypes As RoofTypeSet
Visual C++
public:
property RoofTypeSet^ RoofTypes {
    RoofTypeSet^ get ();
}

Remarks

This property returns a set of RoofType objects.

See Also

Document Class


RoomTagTypes Property

[image]

Revit 2011 API
Document..::.RoomTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTagTypeSet RoomTagTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RoomTagTypes As RoomTagTypeSet
Visual C++
public:
property RoomTagTypeSet^ RoomTagTypes {
    RoomTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class


Settings Property

[image]

Revit 2011 API
Document..::.Settings Property
Document Class See Also Send Feedback
Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Settings Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As Settings
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

Remarks

Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.

See Also

Document Class


SiteLocation Property

[image]

Revit 2011 API
Document..::.SiteLocation Property
Document Class See Also Send Feedback
Returns the site location information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The SiteLocation property returns an object that contains the site location for the entire project.

See Also

Document Class


SlabEdgeTypes Property

[image]

Revit 2011 API
Document..::.SlabEdgeTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdgeTypeSet SlabEdgeTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabEdgeTypes As SlabEdgeTypeSet
Visual C++
public:
property SlabEdgeTypeSet^ SlabEdgeTypes {
    SlabEdgeTypeSet^ get ();
}

Remarks

This property returns a set of SlabEdgeType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


SpaceTagTypes Property

[image]

Revit 2011 API
Document..::.SpaceTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTagTypeSet SpaceTagTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceTagTypes As SpaceTagTypeSet
Visual C++
public:
property SpaceTagTypeSet^ SpaceTagTypes {
    SpaceTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class


SpotDimensionTypes Property

[image]

Revit 2011 API
Document..::.SpotDimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimensionTypeSet SpotDimensionTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpotDimensionTypes As SpotDimensionTypeSet
Visual C++
public:
property SpotDimensionTypeSet^ SpotDimensionTypes {
    SpotDimensionTypeSet^ get ();
}

Remarks

This property returns a set of SpotDimensionType objects. These objects can be used change the type of a SpotDimension from one type to another.

See Also

Document Class


TextNoteTypes Property

[image]

Revit 2011 API
Document..::.TextNoteTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of TextNote types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteTypeSet TextNoteTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextNoteTypes As TextNoteTypeSet
Visual C++
public:
property TextNoteTypeSet^ TextNoteTypes {
    TextNoteTypeSet^ get ();
}

Remarks

This property returns a set of TextNote objects. These objects can be used change the type of a TextNote from one type to another.

See Also

Document Class


Title Property

[image]

Revit 2011 API
Document..::.Title Property
Document Class See Also Send Feedback
Call this function to get the project's title, which is usually derived from the project's filename.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

Remarks

Returns the document's title.

See Also

Document Class


TitleBlocks Property

[image]

Revit 2011 API
Document..::.TitleBlocks Property
Document Class See Also Send Feedback
Titleblocks currently loaded into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet TitleBlocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleBlocks As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ TitleBlocks {
    FamilySymbolSet^ get ();
}

Remarks

A titleblock is a symbol that defines the layout of a drafting sheet.

See Also

Document Class


TrussTypes Property

[image]

Revit 2011 API
Document..::.TrussTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the truss types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussTypeSet TrussTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrussTypes As TrussTypeSet
Visual C++
public:
property TrussTypeSet^ TrussTypes {
    TrussTypeSet^ get ();
}

Remarks

This property returns a set of TrussType objects.

See Also

Document Class


TypeOfStorage Property

[image]

Revit 2011 API
Document..::.TypeOfStorage Property
Document Class See Also Send Feedback
Get the storage type of the specified BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StorageType TypeOfStorage[
    BuiltInParameter
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeOfStorage ( _
     As BuiltInParameter _
) As StorageType
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter ] {
    StorageType get (BuiltInParameter );
}

Parameters

Type: Autodesk.Revit.DB..::.BuiltInParameter

See Also

Document Class


ViewSheetSets Property

[image]

Revit 2011 API
Document..::.ViewSheetSets Property
Document Class See Also Send Feedback
The view sheet sets stored in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSheetSets ViewSheetSets { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSets As ViewSheetSets
Visual C++
public:
property ViewSheetSets^ ViewSheetSets {
    ViewSheetSets^ get ();
}

Field Value

A group of the available view sheet sets.

See Also

Document Class


WallTypes Property

[image]

Revit 2011 API
Document..::.WallTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the wall types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WallTypeSet WallTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WallTypes As WallTypeSet
Visual C++
public:
property WallTypeSet^ WallTypes {
    WallTypeSet^ get ();
}

Remarks

This property returns a set of WallType objects. These objects can be used change the type of a wall from one type to another.

See Also

Document Class


WorksharingCentralFilename Property

[image]

Revit 2011 API
Document..::.WorksharingCentralFilename Property
Document Class See Also Send Feedback
The name and path of the central file name for a workshared document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string WorksharingCentralFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property WorksharingCentralFilename As String
Visual C++
public:
property String^ WorksharingCentralFilename {
    String^ get ();
}

Field Value

The name and path of the central file, or "" if the file is not workshared.

See Also

Document Class


Document Events

[image] [image]

Revit 2011 API
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

Name | Description
DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.
DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.
DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


DocumentClosing Event

[image]

Revit 2011 API
Document..::.DocumentClosing Event
Document Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic (Declaration)
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document. This document-level event precedes the application-level event of the same name.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Revit::ApplicationServices::Application::DocumentClosed event will be raised immediately after document is closed.

See Also

Document Class


DocumentPrinted Event

[image]

Revit 2011 API
Document..::.DocumentPrinted Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic (Declaration)
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. This document-level event precedes the application-level event of the same name. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentPrinting Event

[image]

Revit 2011 API
Document..::.DocumentPrinting Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic (Declaration)
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document. This document-level event precedes the application-level event of the same name.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, set the 'Cancel' property in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event,for each view being printed,Autodesk::Revit::ApplicationServices::Application::ViewPrinting and Autodesk::Revit::ApplicationServices::Application::ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

Document Class


DocumentSaved Event

[image]

Revit 2011 API
Document..::.DocumentSaved Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic (Declaration)
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSavedAs Event

[image]

Revit 2011 API
Document..::.DocumentSavedAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic (Declaration)
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSaving Event

[image]

Revit 2011 API
Document..::.DocumentSaving Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic (Declaration)
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Document Class


DocumentSavingAs Event

[image]

Revit 2011 API
Document..::.DocumentSavingAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic (Declaration)
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. This document-level event precedes the application-level event of the same name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, set the 'Cancel' property in event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

See Also

Document Class


ViewPrinted Event

[image]

Revit 2011 API
Document..::.ViewPrinted Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic (Declaration)
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. This document-level event precedes the application-level event of the same name. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


ViewPrinting Event

[image]

Revit 2011 API
Document..::.ViewPrinting Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic (Declaration)
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once. This document-level event precedes the application-level event of the same name.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()() and similar overloads.
  • SubmitPrint()()() and similar overloads.
  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

Document Class


DocumentPreviewSettings Class

[image]

Revit 2011 API
DocumentPreviewSettings Class
Members See Also Send Feedback
Contains the settings related to the saving of preview images for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_UR2

Syntax

C#
public class DocumentPreviewSettings : IDisposable
Visual Basic (Declaration)
Public Class DocumentPreviewSettings _
    Implements IDisposable
Visual C++
public ref class DocumentPreviewSettings : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.DocumentPreviewSettings

See Also

DocumentPreviewSettings Members


DocumentPreviewSettings Members

[image] [image]

Revit 2011 API
DocumentPreviewSettings Members
DocumentPreviewSettings Class Methods Properties See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForceViewUpdate | Sets Revit to update the preview view if necessary.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Methods

[image] [image]

Revit 2011 API
DocumentPreviewSettings Methods
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForceViewUpdate | Sets Revit to update the preview view if necessary.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPreviewSettings Class


Dispose Method

[image]

Revit 2011 API
DocumentPreviewSettings..::.Dispose Method
DocumentPreviewSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DocumentPreviewSettings Class


ForceViewUpdate Method

[image]

Revit 2011 API
DocumentPreviewSettings..::.ForceViewUpdate Method
DocumentPreviewSettings Class See Also Send Feedback
Sets Revit to update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_UR2

Syntax

C#
public void ForceViewUpdate(
    bool forceViewUpdate
)
Visual Basic (Declaration)
Public Sub ForceViewUpdate ( _
    forceViewUpdate As Boolean _
)
Visual C++
public:
void ForceViewUpdate(
    bool forceViewUpdate
)

Parameters

forceViewUpdate
Type: System..::.Boolean
True to force update of the preview view. False to skip update if necessary (the default).

Remarks

An update is necessary if the view has never been displayed, or if the model has been changed and the view has not been updated or accessed. If the preview view has not been updated, the preview may not be properly saved.

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Properties

[image] [image]

Revit 2011 API
DocumentPreviewSettings Properties
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Properties

Name | Description
PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


PreviewViewId Property

[image]

Revit 2011 API
DocumentPreviewSettings..::.PreviewViewId Property
DocumentPreviewSettings Class See Also Send Feedback
The view id that will be used to generate the preview.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_UR2

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic (Declaration)
Public Property PreviewViewId As ElementId
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

InvalidElementId signals that there is no permanent preview view for the document; where possible the active view will be used to generate the preview upon save.

Remarks

This view will always be saved as the preview view for the document. It will always be used to generate the preview, even if the active view is different, unless it is changed or removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

DocumentPreviewSettings Class


DocumentSet Class

[image]

Revit 2011 API
DocumentSet Class
Members See Also Send Feedback
A set that can contain any documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DocumentSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DocumentSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DocumentSet

See Also

DocumentSet Members


DocumentSet Members

[image] [image]

Revit 2011 API
DocumentSet Members
DocumentSet Class Constructors Methods Properties See Also Send Feedback

The DocumentSet type exposes the following members.

Constructors

Name | Description
DocumentSet | Initializes a new instance of the DocumentSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class


DocumentSet Constructor

[image]

Revit 2011 API
DocumentSet Constructor
DocumentSet Class See Also Send Feedback
Initializes a new instance of the DocumentSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSet()

See Also

DocumentSet Class


DocumentSet Methods

[image] [image]

Revit 2011 API
DocumentSet Methods
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSet Class


Clear Method

[image]

Revit 2011 API
DocumentSet..::.Clear Method
DocumentSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DocumentSet Class


Contains Method

[image]

Revit 2011 API
DocumentSet..::.Contains Method
DocumentSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Document
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

DocumentSet Class


Erase Method

[image]

Revit 2011 API
DocumentSet..::.Erase Method
DocumentSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Document _
) As Integer
Visual C++
public:
virtual int Erase(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Document
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

DocumentSet Class


ForwardIterator Method

[image]

Revit 2011 API
DocumentSet..::.ForwardIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DocumentSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class


GetEnumerator Method

[image]

Revit 2011 API
DocumentSet..::.GetEnumerator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DocumentSet Class


Insert Method

[image]

Revit 2011 API
DocumentSet..::.Insert Method
DocumentSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Document item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Document
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

DocumentSet Class


ReverseIterator Method

[image]

Revit 2011 API
DocumentSet..::.ReverseIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DocumentSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DocumentSet Class


DocumentSet Properties

[image] [image]

Revit 2011 API
DocumentSet Properties
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class


IsEmpty Property

[image]

Revit 2011 API
DocumentSet..::.IsEmpty Property
DocumentSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DocumentSet Class


Size Property

[image]

Revit 2011 API
DocumentSet..::.Size Property
DocumentSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DocumentSet Class


DocumentSetIterator Class

[image]

Revit 2011 API
DocumentSetIterator Class
Members See Also Send Feedback
An iterator to a set of documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DocumentSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DocumentSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DocumentSetIterator

See Also

DocumentSetIterator Members


DocumentSetIterator Members

[image] [image]

Revit 2011 API
DocumentSetIterator Members
DocumentSetIterator Class Constructors Methods Properties See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Constructors

Name | Description
DocumentSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class


DocumentSetIterator Constructor

[image]

Revit 2011 API
DocumentSetIterator Constructor
DocumentSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DocumentSetIterator Class


DocumentSetIterator Methods

[image] [image]

Revit 2011 API
DocumentSetIterator Methods
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSetIterator Class


MoveNext Method

[image]

Revit 2011 API
DocumentSetIterator..::.MoveNext Method
DocumentSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


Reset Method

[image]

Revit 2011 API
DocumentSetIterator..::.Reset Method
DocumentSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DocumentSetIterator Class


DocumentSetIterator Properties

[image] [image]

Revit 2011 API
DocumentSetIterator Properties
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class


Current Property

[image]

Revit 2011 API
DocumentSetIterator..::.Current Property
DocumentSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


DocumentType Enumeration

[image]

Revit 2011 API
DocumentType Enumeration
See Also Send Feedback
Types of Revit documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DocumentType
Visual Basic (Declaration)
Public Enumeration DocumentType
Visual C++
public enum class DocumentType

Members

Member name | Description
Project |
Family |
Template |

See Also


Domain Enumeration

[image]

Revit 2011 API
Domain Enumeration
See Also Send Feedback
An enumerated type listing all the possible domain types that can be assigned to a connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum Domain
Visual Basic (Declaration)
Public Enumeration Domain
Visual C++
public enum class Domain

Members

Member name | Description
DomainUndefined | Domain is Undefined.
DomainHvac | Domain is Hvac.
DomainElectrical | Domain is Electrical.
DomainPiping | Domain is Piping.
DomainCableTrayConduit | Domain is cable tray/conduit.

See Also


DoubleArray Class

[image]

Revit 2011 API
DoubleArray Class
Members See Also Send Feedback
An array that contains doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DoubleArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DoubleArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DoubleArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DoubleArray

See Also

DoubleArray Members


DoubleArray Members

[image] [image]

Revit 2011 API
DoubleArray Members
DoubleArray Class Constructors Methods Properties See Also Send Feedback

The DoubleArray type exposes the following members.

Constructors

Name | Description
DoubleArray | Initializes a new instance of the DoubleArray class

Methods

Name | Description
Append |
Clear | Removes every double from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a double at a specified index within the array.
Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


DoubleArray Constructor

[image]

Revit 2011 API
DoubleArray Constructor
DoubleArray Class See Also Send Feedback
Initializes a new instance of the DoubleArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArray()

See Also

DoubleArray Class


DoubleArray Methods

[image] [image]

Revit 2011 API
DoubleArray Methods
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every double from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArray Class


Append Method

[image]

Revit 2011 API
DoubleArray..::.Append Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    ref double item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    ByRef item As Double _
)
Visual C++
public:
virtual void Append(
    double% item
)

Parameters

item
Type: System..::.Double %

See Also

DoubleArray Class


Clear Method

[image]

Revit 2011 API
DoubleArray..::.Clear Method
DoubleArray Class See Also Send Feedback
Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DoubleArray Class


ForwardIterator Method

[image]

Revit 2011 API
DoubleArray..::.ForwardIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DoubleArray Class


GetEnumerator Method

[image]

Revit 2011 API
DoubleArray..::.GetEnumerator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DoubleArray Class


Insert Method

[image]

Revit 2011 API
DoubleArray..::.Insert Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    ref double item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    ByRef item As Double, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    double% item,
    int index
)

Parameters

item
Type: System..::.Double %
index
Type: System..::.Int32

See Also

DoubleArray Class


ReverseIterator Method

[image]

Revit 2011 API
DoubleArray..::.ReverseIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DoubleArray Class


DoubleArray Properties

[image] [image]

Revit 2011 API
DoubleArray Properties
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a double at a specified index within the array.
Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


IsEmpty Property

[image]

Revit 2011 API
DoubleArray..::.IsEmpty Property
DoubleArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DoubleArray Class


Item Property

[image]

Revit 2011 API
DoubleArray..::.Item Property
DoubleArray Class See Also Send Feedback
Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Double
Visual C++
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::.Int32
The index of the double to be set or retrieved.

Return Value

Returns the double at the specified index.

See Also

DoubleArray Class


Size Property

[image]

Revit 2011 API
DoubleArray..::.Size Property
DoubleArray Class See Also Send Feedback
Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DoubleArray Class


DoubleArrayIterator Class

[image]

Revit 2011 API
DoubleArrayIterator Class
Members See Also Send Feedback
An iterator to an array of doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DoubleArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DoubleArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DoubleArrayIterator

See Also

DoubleArrayIterator Members


DoubleArrayIterator Members

[image] [image]

Revit 2011 API
DoubleArrayIterator Members
DoubleArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Constructors

Name | Description
DoubleArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class


DoubleArrayIterator Constructor

[image]

Revit 2011 API
DoubleArrayIterator Constructor
DoubleArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DoubleArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Methods

[image] [image]

Revit 2011 API
DoubleArrayIterator Methods
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
DoubleArrayIterator..::.MoveNext Method
DoubleArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


Reset Method

[image]

Revit 2011 API
DoubleArrayIterator..::.Reset Method
DoubleArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Properties

[image] [image]

Revit 2011 API
DoubleArrayIterator Properties
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class


Current Property

[image]

Revit 2011 API
DoubleArrayIterator..::.Current Property
DoubleArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


DWFExportOptions Class

[image]

Revit 2011 API
DWFExportOptions Class
Members See Also Send Feedback
DWF Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DWFExportOptions : CADExportOptions
Visual Basic (Declaration)
Public Class DWFExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class DWFExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.DWFExportOptions
Autodesk.Revit.DB..::.DWFXExportOptions

See Also

DWFExportOptions Members


DWFExportOptions Members

[image] [image]

Revit 2011 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFExportOptions type exposes the following members.

Constructors

Name | Description
DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportObjectData | Whether to include properties associated with elements.
ImageFormat | Controls the compression level of images embedded.
ImageQuality | Image quality level when compressed raster format(JPEG) is used.
MergedViews | Whether to merge all views in one file.
PaperFormat | Standard paper format.
PortraitLayout | Paper orientation - Portrait/Landscape.
StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


DWFExportOptions Constructor

[image]

Revit 2011 API
DWFExportOptions Constructor
DWFExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFExportOptions()

See Also

DWFExportOptions Class


DWFExportOptions Methods

[image] [image]

Revit 2011 API
DWFExportOptions Methods
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFExportOptions Class


DWFExportOptions Properties

[image] [image]

Revit 2011 API
DWFExportOptions Properties
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry.
ExportObjectData | Whether to include properties associated with elements.
ImageFormat | Controls the compression level of images embedded.
ImageQuality | Image quality level when compressed raster format(JPEG) is used.
MergedViews | Whether to merge all views in one file.
PaperFormat | Standard paper format.
PortraitLayout | Paper orientation - Portrait/Landscape.
StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


ExportingAreas Property

[image]

Revit 2011 API
DWFExportOptions..::.ExportingAreas Property
DWFExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic (Declaration)
Public Property ExportingAreas As Boolean
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


ExportObjectData Property

[image]

Revit 2011 API
DWFExportOptions..::.ExportObjectData Property
DWFExportOptions Class See Also Send Feedback
Whether to include properties associated with elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExportObjectData { get; set; }
Visual Basic (Declaration)
Public Property ExportObjectData As Boolean
Visual C++
public:
property bool ExportObjectData {
    bool get ();
    void set (bool value);
}

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWFExportOptions Class


ImageFormat Property

[image]

Revit 2011 API
DWFExportOptions..::.ImageFormat Property
DWFExportOptions Class See Also Send Feedback
Controls the compression level of images embedded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As DWFImageFormat
Visual C++
public:
property DWFImageFormat ImageFormat {
    DWFImageFormat get ();
    void set (DWFImageFormat value);
}

Remarks

ImageQuality is ignored when ImageFormat is set to "PNG"-the standard format.

See Also

DWFExportOptions Class


ImageQuality Property

[image]

Revit 2011 API
DWFExportOptions..::.ImageQuality Property
DWFExportOptions Class See Also Send Feedback
Image quality level when compressed raster format(JPEG) is used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFImageQuality ImageQuality { get; set; }
Visual Basic (Declaration)
Public Property ImageQuality As DWFImageQuality
Visual C++
public:
property DWFImageQuality ImageQuality {
    DWFImageQuality get ();
    void set (DWFImageQuality value);
}

Remarks

The default value is Default.

See Also

DWFExportOptions Class


MergedViews Property

[image]

Revit 2011 API
DWFExportOptions..::.MergedViews Property
DWFExportOptions Class See Also Send Feedback
Whether to merge all views in one file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic (Declaration)
Public Property MergedViews As Boolean
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


PaperFormat Property

[image]

Revit 2011 API
DWFExportOptions..::.PaperFormat Property
DWFExportOptions Class See Also Send Feedback
Standard paper format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ExportPaperFormat PaperFormat { get; set; }
Visual Basic (Declaration)
Public Property PaperFormat As ExportPaperFormat
Visual C++
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}

See Also

DWFExportOptions Class


PortraitLayout Property

[image]

Revit 2011 API
DWFExportOptions..::.PortraitLayout Property
DWFExportOptions Class See Also Send Feedback
Paper orientation - Portrait/Landscape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool PortraitLayout { get; set; }
Visual Basic (Declaration)
Public Property PortraitLayout As Boolean
Visual C++
public:
property bool PortraitLayout {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


StopOnError Property

[image]

Revit 2011 API
DWFExportOptions..::.StopOnError Property
DWFExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic (Declaration)
Public Property StopOnError As Boolean
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

DWFExportOptions Class


DWFImageFormat Enumeration

[image]

Revit 2011 API
DWFImageFormat Enumeration
See Also Send Feedback
An enumerated type listing possible image format for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DWFImageFormat
Visual Basic (Declaration)
Public Enumeration DWFImageFormat
Visual C++
public enum class DWFImageFormat

Members

Member name | Description
Lossless |
Lossy |

See Also


DWFImageQuality Enumeration

[image]

Revit 2011 API
DWFImageQuality Enumeration
See Also Send Feedback
An enumerated type listing possible image quality for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DWFImageQuality
Visual Basic (Declaration)
Public Enumeration DWFImageQuality
Visual C++
public enum class DWFImageQuality

Members

Member name | Description
Default |
Low |
Medium |
High |

See Also


DWFXExportOptions Class

[image]

Revit 2011 API
DWFXExportOptions Class
Members See Also Send Feedback
DWFX Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DWFXExportOptions : DWFExportOptions
Visual Basic (Declaration)
Public Class DWFXExportOptions _
    Inherits DWFExportOptions
Visual C++
public ref class DWFXExportOptions : public DWFExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.DWFExportOptions
Autodesk.Revit.DB..::.DWFXExportOptions

See Also

DWFXExportOptions Members


DWFXExportOptions Members

[image] [image]

Revit 2011 API
DWFXExportOptions Members
DWFXExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Constructors

Name | Description
DWFXExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class


DWFXExportOptions Constructor

[image]

Revit 2011 API
DWFXExportOptions Constructor
DWFXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWFXExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWFXExportOptions()

See Also

DWFXExportOptions Class


DWFXExportOptions Methods

[image] [image]

Revit 2011 API
DWFXExportOptions Methods
DWFXExportOptions Class See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFXExportOptions Class


DWFXExportOptions Properties

[image] [image]

Revit 2011 API
DWFXExportOptions Properties
DWFXExportOptions Class See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Properties

Name | Description
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class


DWGExportOptions Class

[image]

Revit 2011 API
DWGExportOptions Class
Members See Also Send Feedback
DWG Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DWGExportOptions : ACADExportOptions
Visual Basic (Declaration)
Public Class DWGExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DWGExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.ACADExportOptions
Autodesk.Revit.DB..::.DWGExportOptions

See Also

DWGExportOptions Members


DWGExportOptions Members

[image] [image]

Revit 2011 API
DWGExportOptions Members
DWGExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGExportOptions type exposes the following members.

Constructors

Name | Description
DWGExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Export color mode. (Inherited from ACADExportOptions.)
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
MergedViews | Whether to merge all views in one file (via XRefs).
PropOverrides | How to export overridden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


DWGExportOptions Constructor

[image]

Revit 2011 API
DWGExportOptions Constructor
DWGExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWGExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGExportOptions()

See Also

DWGExportOptions Class


DWGExportOptions Methods

[image] [image]

Revit 2011 API
DWGExportOptions Methods
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGExportOptions Class


DWGExportOptions Properties

[image] [image]

Revit 2011 API
DWGExportOptions Properties
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Properties

Name | Description
Colors | Export color mode. (Inherited from ACADExportOptions.)
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
MergedViews | Whether to merge all views in one file (via XRefs).
PropOverrides | How to export overridden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


MergedViews Property

[image]

Revit 2011 API
DWGExportOptions..::.MergedViews Property
DWGExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic (Declaration)
Public Property MergedViews As Boolean
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWGExportOptions Class


DWGImportOptions Class

[image]

Revit 2011 API
DWGImportOptions Class
Members See Also Send Feedback
Import options specific to AutoCAD's DWG file formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DWGImportOptions : ACADImportOptions
Visual Basic (Declaration)
Public Class DWGImportOptions _
    Inherits ACADImportOptions
Visual C++
public ref class DWGImportOptions : public ACADImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GenericImportOptions
Autodesk.Revit.DB..::.CADImportOptions
Autodesk.Revit.DB..::.ACADImportOptions
Autodesk.Revit.DB..::.DWGImportOptions

See Also

DWGImportOptions Members


DWGImportOptions Members

[image] [image]

Revit 2011 API
DWGImportOptions Members
DWGImportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGImportOptions type exposes the following members.

Constructors

Name | Description
DWGImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions Class


DWGImportOptions Constructor

[image]

Revit 2011 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DWGImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DWGImportOptions()

See Also

DWGImportOptions Class


DWGImportOptions Methods

[image] [image]

Revit 2011 API
DWGImportOptions Methods
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGImportOptions Class


DWGImportOptions Properties

[image] [image]

Revit 2011 API
DWGImportOptions Properties
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Properties

Name | Description
ColorMode | Color mode for the import. (Inherited from CADImportOptions.)
CustomScale | Scaling the import. (Inherited from CADImportOptions.)
LayerSelection | The layers collection for import. (Inherited from ACADImportOptions.)
LineWeights | A Byte array of line weights for the DWG/DXF Color number. (Inherited from ACADImportOptions.)
OrientToView | Place the import at the same orientation as the current view. (Inherited from CADImportOptions.)
Placement | Where to place the import. (Inherited from CADImportOptions.)
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
ThisViewOnly | Imports dwg, dgn, and dxf drawings into the active view only. (Inherited from CADImportOptions.)
Unit | The unit of measure for imported geometry. (Inherited from CADImportOptions.)
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)
VisibleLayersOnly | Only import the visible layers. (Inherited from ACADImportOptions.)

See Also

DWGImportOptions Class


DXFExportOptions Class

[image]

Revit 2011 API
DXFExportOptions Class
Members See Also Send Feedback
DXF Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DXFExportOptions : ACADExportOptions
Visual Basic (Declaration)
Public Class DXFExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DXFExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.ACADExportOptions
Autodesk.Revit.DB..::.DXFExportOptions

See Also

DXFExportOptions Members


DXFExportOptions Members

[image] [image]

Revit 2011 API
DXFExportOptions Members
DXFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DXFExportOptions type exposes the following members.

Constructors

Name | Description
DXFExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Export color mode. (Inherited from ACADExportOptions.)
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
PropOverrides | How to export overridden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


DXFExportOptions Constructor

[image]

Revit 2011 API
DXFExportOptions Constructor
DXFExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DXFExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DXFExportOptions()

See Also

DXFExportOptions Class


DXFExportOptions Methods

[image] [image]

Revit 2011 API
DXFExportOptions Methods
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DXFExportOptions Class


DXFExportOptions Properties

[image] [image]

Revit 2011 API
DXFExportOptions Properties
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Properties

Name | Description
Colors | Export color mode. (Inherited from ACADExportOptions.)
ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from ACADExportOptions.)
ExportOfSolids | Mode of exporting solids in 3D views. (Inherited from ACADExportOptions.)
FileVersion | AutoCAD file version. (Inherited from ACADExportOptions.)
ForcedHLR | Whether to enforce Hidden Lines Removal in 3D views. (Inherited from ACADExportOptions.)
LayerMapping | Name of a layer settings standard or filename (with custom layer settings). (Inherited from ACADExportOptions.)
LineScaling | LineType scaling mode. (Inherited from ACADExportOptions.)
PropOverrides | How to export overridden object styles. (Inherited from ACADExportOptions.)
SharedCoords | Whether to use shared coordinate system or a project's. internal origin. (Inherited from ACADExportOptions.)
TargetUnit | Type of units in the target CAD format. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


EaveCutterType Enumeration

[image]

Revit 2011 API
EaveCutterType Enumeration
See Also Send Feedback
An enumerated type to store type of EaveCutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum EaveCutterType
Visual Basic (Declaration)
Public Enumeration EaveCutterType
Visual C++
public enum class EaveCutterType

Members

Member name | Description
PlumbCut | Plumb Cut type of Eave.
TwoCutSquare | Two Cut Square type of Eave.
TwoCutPlumb | Two Cut Plumb type of Eave.

See Also


Edge Class

[image]

Revit 2011 API
Edge Class
Members See Also Send Feedback
An edge of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Edge : GeometryObject
Visual Basic (Declaration)
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Edge

See Also

Edge Members


Edge Members

[image] [image]

Revit 2011 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the edge.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class


Edge Methods

[image] [image]

Revit 2011 API
Edge Methods
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the edge at the parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the edge.
EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Tessellate | Returns a polyline approximation to the edge.
TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Edge Class


ComputeDerivatives Method

[image]

Revit 2011 API
Edge..::.ComputeDerivatives Method
Edge Class See Also Send Feedback
Returns the moving frame around the edge at the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter
)

Parameters

parameter
Type: System..::.Double
The parameter is the natural (or "raw") edge parameter.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the normal vector (the second derivative); BasisZ is the binormal vector (tangent x normal). Normal and binormal are zero if the edge is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when parameter is an infinite number.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to compute derivatives.

See Also

Edge Class


Evaluate Method

[image]

Revit 2011 API
Edge..::.Evaluate Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated, in [0,1].

See Also

Edge Class


EvaluateOnFace Method

[image]

Revit 2011 API
Edge..::.EvaluateOnFace Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV EvaluateOnFace(
    double param,
    Face face
)
Visual Basic (Declaration)
Public Function EvaluateOnFace ( _
    param As Double, _
    face As Face _
) As UV
Visual C++
public:
UV^ EvaluateOnFace(
    double param,
    Face^ face
)

Parameters

param
Type: System..::.Double
The parameter to be evaluated, in [0,1].
face
Type: Autodesk.Revit.DB..::.Face
The face on which to perform the evaluation. Must belong to the edge.

See Also

Edge Class


Tessellate Method

[image]

Revit 2011 API
Edge..::.Tessellate Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Tessellate()
Visual Basic (Declaration)
Public Function Tessellate As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class


TessellateOnFace Method

[image]

Revit 2011 API
Edge..::.TessellateOnFace Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<UV> TessellateOnFace(
    Face face
)
Visual Basic (Declaration)
Public Function TessellateOnFace ( _
    face As Face _
) As IList(Of UV)
Visual C++
public:
IList<UV^>^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class


Edge Properties

[image] [image]

Revit 2011 API
Edge Properties
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Properties

Name | Description
ApproximateLength | Returns the approximate length of the edge.
EndPointReference | Returns a stable reference to the start or the end point of the edge.
Face | Returns one of the two faces that meet at the edge.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the edge.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class


ApproximateLength Property

[image]

Revit 2011 API
Edge..::.ApproximateLength Property
Edge Class See Also Send Feedback
Returns the approximate length of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApproximateLength As Double
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Estimates the length of the edge by adding together tessellated segments, Will underestimate when the surface is curved.

See Also

Edge Class


EndPointReference Property

[image]

Revit 2011 API
Edge..::.EndPointReference Property
Edge Class See Also Send Feedback
Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference EndPointReference[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::.Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class


Face Property

[image]

Revit 2011 API
Edge..::.Face Property
Edge Class See Also Send Feedback
Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Face Face[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Face ( _
    idx As Integer _
) As Face
Visual C++
public:
property Face^ Face[int idx] {
    Face^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
The index of the face (0 or 1).

See Also

Edge Class


Reference Property

[image]

Revit 2011 API
Edge..::.Reference Property
Edge Class See Also Send Feedback
Returns a stable reference to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Edge Class


EdgeArray Class

[image]

Revit 2011 API
EdgeArray Class
Members See Also Send Feedback
An array that contains edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class EdgeArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class EdgeArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.EdgeArray

See Also

EdgeArray Members


EdgeArray Members

[image] [image]

Revit 2011 API
EdgeArray Members
EdgeArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArray type exposes the following members.

Constructors

Name | Description
EdgeArray | Initializes a new instance of the EdgeArray class

Methods

Name | Description
Append | Add the edge to the end of the array.
Clear | Removes every edge from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge at a specified index within the array.
Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class


EdgeArray Constructor

[image]

Revit 2011 API
EdgeArray Constructor
EdgeArray Class See Also Send Feedback
Initializes a new instance of the EdgeArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArray()

See Also

EdgeArray Class


EdgeArray Methods

[image] [image]

Revit 2011 API
EdgeArray Methods
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Methods

Name | Description
Append | Add the edge to the end of the array.
Clear | Removes every edge from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArray Class


Append Method

[image]

Revit 2011 API
EdgeArray..::.Append Method
EdgeArray Class See Also Send Feedback
Add the edge to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Edge item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Edge _
)
Visual C++
public:
virtual void Append(
    Edge^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Edge
The edge to be added.

See Also

EdgeArray Class


Clear Method

[image]

Revit 2011 API
EdgeArray..::.Clear Method
EdgeArray Class See Also Send Feedback
Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArray Class


ForwardIterator Method

[image]

Revit 2011 API
EdgeArray..::.ForwardIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class


GetEnumerator Method

[image]

Revit 2011 API
EdgeArray..::.GetEnumerator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EdgeArray Class


Insert Method

[image]

Revit 2011 API
EdgeArray..::.Insert Method
EdgeArray Class See Also Send Feedback
Insert the specified edge into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Edge^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Edge
The edge to be inserted into the array.
index
Type: System..::.Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class


ReverseIterator Method

[image]

Revit 2011 API
EdgeArray..::.ReverseIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArray Class


EdgeArray Properties

[image] [image]

Revit 2011 API
EdgeArray Properties
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge at a specified index within the array.
Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class


IsEmpty Property

[image]

Revit 2011 API
EdgeArray..::.IsEmpty Property
EdgeArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArray Class


Item Property

[image]

Revit 2011 API
EdgeArray..::.Item Property
EdgeArray Class See Also Send Feedback
Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Edge Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Edge
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Type: System..::.Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class


Size Property

[image]

Revit 2011 API
EdgeArray..::.Size Property
EdgeArray Class See Also Send Feedback
Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArray Class


EdgeArrayArray Class

[image]

Revit 2011 API
EdgeArrayArray Class
Members Example See Also Send Feedback
An array of edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class EdgeArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Examples

CopyC#
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement.Objects)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetEdgeArrayArray(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Autodesk.Revit.DB.Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement.Objects
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Autodesk.Revit.DB.Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Autodesk.Revit.DB.Edge In edges
                            ' Get one test point
                            Dim testPoint As Autodesk.Revit.DB.XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            TaskDialog.Show("Revit", edgeInfo)
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.EdgeArrayArray

See Also

EdgeArrayArray Members


EdgeArrayArray Members

[image] [image]

Revit 2011 API
EdgeArrayArray Members
EdgeArrayArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Constructors

Name | Description
EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class

Methods

Name | Description
Append | Add the edge array to the end of the array.
Clear | Removes every edge array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge array at a specified index within the array.
Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


EdgeArrayArray Constructor

[image]

Revit 2011 API
EdgeArrayArray Constructor
EdgeArrayArray Class See Also Send Feedback
Initializes a new instance of the EdgeArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArray()

See Also

EdgeArrayArray Class


EdgeArrayArray Methods

[image] [image]

Revit 2011 API
EdgeArrayArray Methods
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the edge array to the end of the array.
Clear | Removes every edge array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified edge array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArray Class


Append Method

[image]

Revit 2011 API
EdgeArrayArray..::.Append Method
EdgeArrayArray Class See Also Send Feedback
Add the edge array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    EdgeArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As EdgeArray _
)
Visual C++
public:
virtual void Append(
    EdgeArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.EdgeArray
The edge array to be added.

See Also

EdgeArrayArray Class


Clear Method

[image]

Revit 2011 API
EdgeArrayArray..::.Clear Method
EdgeArrayArray Class See Also Send Feedback
Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArrayArray Class


ForwardIterator Method

[image]

Revit 2011 API
EdgeArrayArray..::.ForwardIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class


GetEnumerator Method

[image]

Revit 2011 API
EdgeArrayArray..::.GetEnumerator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EdgeArrayArray Class


Insert Method

[image]

Revit 2011 API
EdgeArrayArray..::.Insert Method
EdgeArrayArray Class See Also Send Feedback
Insert the specified edge array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    EdgeArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As EdgeArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    EdgeArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.EdgeArray
The edge array to be inserted into the array.
index
Type: System..::.Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.

See Also

EdgeArrayArray Class


ReverseIterator Method

[image]

Revit 2011 API
EdgeArrayArray..::.ReverseIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArrayArray Class


EdgeArrayArray Properties

[image] [image]

Revit 2011 API
EdgeArrayArray Properties
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an edge array at a specified index within the array.
Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


IsEmpty Property

[image]

Revit 2011 API
EdgeArrayArray..::.IsEmpty Property
EdgeArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArrayArray Class


Item Property

[image]

Revit 2011 API
EdgeArrayArray..::.Item Property
EdgeArrayArray Class See Also Send Feedback
Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual EdgeArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As EdgeArray
Visual C++
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the edge array to be set or retrieved.

Return Value

Returns the edge array at the specified index.

See Also

EdgeArrayArray Class


Size Property

[image]

Revit 2011 API
EdgeArrayArray..::.Size Property
EdgeArrayArray Class See Also Send Feedback
Returns the number of edge arrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArrayArray Class


EdgeArrayArrayIterator Class

[image]

Revit 2011 API
EdgeArrayArrayIterator Class
Members See Also Send Feedback
An iterator to an array or edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class EdgeArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.EdgeArrayArrayIterator

See Also

EdgeArrayArrayIterator Members


EdgeArrayArrayIterator Members

[image] [image]

Revit 2011 API
EdgeArrayArrayIterator Members
EdgeArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Constructors

Name | Description
EdgeArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Constructor

[image]

Revit 2011 API
EdgeArrayArrayIterator Constructor
EdgeArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Methods

[image] [image]

Revit 2011 API
EdgeArrayArrayIterator Methods
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
EdgeArrayArrayIterator..::.MoveNext Method
EdgeArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class


Reset Method

[image]

Revit 2011 API
EdgeArrayArrayIterator..::.Reset Method
EdgeArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Properties

[image] [image]

Revit 2011 API
EdgeArrayArrayIterator Properties
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


Current Property

[image]

Revit 2011 API
EdgeArrayArrayIterator..::.Current Property
EdgeArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class


EdgeArrayIterator Class

[image]

Revit 2011 API
EdgeArrayIterator Class
Members See Also Send Feedback
An iterator to an edge array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class EdgeArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.EdgeArrayIterator

See Also

EdgeArrayIterator Members


EdgeArrayIterator Members

[image] [image]

Revit 2011 API
EdgeArrayIterator Members
EdgeArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Constructors

Name | Description
EdgeArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class


EdgeArrayIterator Constructor

[image]

Revit 2011 API
EdgeArrayIterator Constructor
EdgeArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EdgeArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayIterator Class


EdgeArrayIterator Methods

[image] [image]

Revit 2011 API
EdgeArrayIterator Methods
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
EdgeArrayIterator..::.MoveNext Method
EdgeArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class


Reset Method

[image]

Revit 2011 API
EdgeArrayIterator..::.Reset Method
EdgeArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayIterator Class


EdgeArrayIterator Properties

[image] [image]

Revit 2011 API
EdgeArrayIterator Properties
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class


Current Property

[image]

Revit 2011 API
EdgeArrayIterator..::.Current Property
EdgeArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class


Element Class

[image]

Revit 2011 API
Element Class
Members See Also Send Feedback
Base class for most persistent data within a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Element : IDisposable
Visual Basic (Declaration)
Public Class Element _
    Implements IDisposable
Visual C++
public ref class Element : IDisposable

Remarks

The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegend
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayStyle
Autodesk.Revit.DB.Analysis..::.MassEnergyAnalyticalModel
Autodesk.Revit.DB.Analysis..::.MassLevelData
Autodesk.Revit.DB.Analysis..::.MassSurfaceData
Autodesk.Revit.DB.Analysis..::.MassZone
Autodesk.Revit.DB.Analysis..::.SpatialFieldManager
Autodesk.Revit.DB..::.AreaScheme
Autodesk.Revit.DB..::.BaseArray
Autodesk.Revit.DB..::.BasePoint
Autodesk.Revit.DB..::.BeamSystem
Autodesk.Revit.DB..::.BoundaryConditions
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB..::.Control
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.DesignOption
Autodesk.Revit.DB..::.Dimension
Autodesk.Revit.DB..::.DividedSurface
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorDefinition
Autodesk.Revit.DB.Electrical..::.ElectricalLoadClassification
Autodesk.Revit.DB.Electrical..::.PanelScheduleSheetInstance
Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB..::.FamilyBase
Autodesk.Revit.DB..::.FillPattern
Autodesk.Revit.DB..::.FilterElement
Autodesk.Revit.DB..::.GraphicsStyle
Autodesk.Revit.DB..::.Grid
Autodesk.Revit.DB..::.Group
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.ImportInstance
Autodesk.Revit.DB..::.IndependentTag
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.Level
Autodesk.Revit.DB..::.LinePattern
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB.Mechanical..::.Zone
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB..::.ModelText
Autodesk.Revit.DB..::.Opening
Autodesk.Revit.DB..::.Phase
Autodesk.Revit.DB..::.PrintSetting
Autodesk.Revit.DB..::.ProjectInfo
Autodesk.Revit.DB..::.ProjectUnit
Autodesk.Revit.DB..::.PropertyLine
Autodesk.Revit.DB..::.ReferencePlane
Autodesk.Revit.DB..::.ReferencePoint
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.SketchPlane
Autodesk.Revit.DB.Structure..::.AreaReinforcement
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.LoadCase
Autodesk.Revit.DB.Structure..::.LoadCombination
Autodesk.Revit.DB.Structure..::.LoadNature
Autodesk.Revit.DB.Structure..::.LoadUsage
Autodesk.Revit.DB.Structure..::.PathReinforcement
Autodesk.Revit.DB.Structure..::.Rebar
Autodesk.Revit.DB.Structure..::.Truss
Autodesk.Revit.DB..::.SunAndShadowSettings
Autodesk.Revit.DB..::.TextElement
Autodesk.Revit.DB..::.TopographySurface
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewSheetSet

See Also

Element Members


Element Members

[image] [image]

Revit 2011 API
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
CanHaveTypeAssigned | Overloaded.
ChangeTypeId | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
GetChangeTypeAny | Returns ChangeType associated with any change in an element.
GetChangeTypeElementAddition | Returns ChangeType associated with element addition
GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
GetChangeTypeGeometry | summary: Returns ChangeType associated with a change in the geometry of an element
GetChangeTypeParameter | Overloaded.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type.
GetValidTypes | Overloaded.
IsHidden | Identifies if the element has been permanently hidden in the view.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
IsValidType | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | A human readable name for the Element.
ObjectType | Obsolete. Returns the instance type of this object.
OwnerViewId | The id of the view that owns the element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.
ViewSpecific | Identifies if the element is owned by a view.

See Also

Element Class


Element Methods

[image] [image]

Revit 2011 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view.
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
CanHaveTypeAssigned | Overloaded.
ChangeTypeId | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
GetChangeTypeAny | Returns ChangeType associated with any change in an element.
GetChangeTypeElementAddition | Returns ChangeType associated with element addition
GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
GetChangeTypeGeometry | summary: Returns ChangeType associated with a change in the geometry of an element
GetChangeTypeParameter | Overloaded.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element.
GetMaterialVolume | Get the volume of the given material on this element.
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type.
GetValidTypes | Overloaded.
IsHidden | Identifies if the element has been permanently hidden in the view.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
IsValidType | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class


CanBeHidden Method

[image]

Revit 2011 API
Element..::.CanBeHidden Method
Element Class See Also Send Feedback
Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanBeHidden(
    View pView
)
Visual Basic (Declaration)
Public Function CanBeHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool CanBeHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::.View

Return Value

If the element is not permitted to be hidden, false is returned.

Remarks

See discussion for some types of elements which may not be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


CanHaveAnalyticalModel Method

[image]

Revit 2011 API
Element..::.CanHaveAnalyticalModel Method
Element Class See Also Send Feedback
Indicates whether the Element can have an Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveAnalyticalModel()
Visual Basic (Declaration)
Public Function CanHaveAnalyticalModel As Boolean
Visual C++
public:
bool CanHaveAnalyticalModel()

Return Value

True if the Element can have an Analytical Model, false otherwise.

See Also

Element Class


CanHaveTypeAssigned Method

[image] [image]

Revit 2011 API
Element..::.CanHaveTypeAssigned Method
Element Class See Also Send Feedback

Overload List

Name | Description
CanHaveTypeAssigned()()() | Identifies if the element can have a type assigned.
CanHaveTypeAssigned(Document, ICollection<(Of <(ElementId>)>)) | Checks if all elements in the set can have a type assigned.

See Also

Element Class
Element Members


CanHaveTypeAssigned Method

[image]

Revit 2011 API
Element..::.CanHaveTypeAssigned Method
Element Class See Also Send Feedback
Identifies if the element can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveTypeAssigned()
Visual Basic (Declaration)
Public Function CanHaveTypeAssigned As Boolean
Visual C++
public:
bool CanHaveTypeAssigned()

Return Value

True if element can have a type assigned, false otherwise.

Remarks

Some elements can not have type assigned, in which case invalid element id is considered to be their type id.

See Also

Element Class
CanHaveTypeAssigned Overload


CanHaveTypeAssigned Method (Document, ICollection(ElementId))

[image]

Revit 2011 API
Element..::.CanHaveTypeAssigned Method (Document, ICollection<(Of <(ElementId>)>))
Element Class See Also Send Feedback
Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CanHaveTypeAssigned(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Shared Function CanHaveTypeAssigned ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanHaveTypeAssigned(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs.

Return Value

True if all elements in the set can have a type assigned, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
CanHaveTypeAssigned Overload


ChangeTypeId Method

[image] [image]

Revit 2011 API
Element..::.ChangeTypeId Method
Element Class See Also Send Feedback

Overload List

Name | Description
ChangeTypeId(ElementId) | Changes type of the element.
ChangeTypeId(Document, ICollection<(Of <(ElementId>)>), ElementId) | Changes the type of all elements in the given set.

See Also

Element Class
Element Members


ChangeTypeId Method (ElementId)

[image]

Revit 2011 API
Element..::.ChangeTypeId Method (ElementId)
Element Class See Also Send Feedback
Changes type of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ChangeTypeId(
    ElementId typeId
)
Visual Basic (Declaration)
Public Function ChangeTypeId ( _
    typeId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ ChangeTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::.ElementId
Identifier of the type to assign to this element.

Return Value

The new element id if new element is created, or invalid element id.

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. Then new element id is returned. Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The type typeId is not valid for this element.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This Element can not have type assigned.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
ChangeTypeId Overload


ChangeTypeId Method (Document, ICollection(ElementId), ElementId)

[image]

Revit 2011 API
Element..::.ChangeTypeId Method (Document, ICollection<(Of <(ElementId>)>), ElementId)
Element Class See Also Send Feedback
Changes the type of all elements in the given set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static IDictionary<ElementId, ElementId> ChangeTypeId(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic (Declaration)
Public Shared Function ChangeTypeId ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As IDictionary(Of ElementId, ElementId)
Visual C++
public:
static IDictionary<ElementId^, ElementId^>^ ChangeTypeId(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::.ElementId
Identifier of the type to assign to this element.

Return Value

The map of original element IDs to the new element IDs if some elements were replaced by new elements (the map is empty if no elements were replaced)

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. Then return map would have (original element id, new element id) pair(s). Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | At least one of the elements in elementIds does not exist in the document -or- Not all elements elementIds can have a type assigned. -or- The type typeId is not valid for at least one of the elements in elementIds.
Autodesk.Revit.Exceptions..::.InvalidOperationException | One or more elements in elementIds is a member of a loaded family. -or- One or more elements in elementIds is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
ChangeTypeId Overload


Dispose Method

[image]

Revit 2011 API
Element..::.Dispose Method
Element Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Element Class


GetAnalyticalModel Method

[image]

Revit 2011 API
Element..::.GetAnalyticalModel Method
Element Class See Also Send Feedback
Retrieves writeable Analytical Model for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModel GetAnalyticalModel()
Visual Basic (Declaration)
Public Function GetAnalyticalModel As AnalyticalModel
Visual C++
public:
AnalyticalModel^ GetAnalyticalModel()

Return Value

Writeable Analytical Model.

Remarks

If the Element does not have an Analytical Model, the returned value will be NULL. This may occur even if the Element can have an Analytical Model, but does not for some reason.

See Also

Element Class


GetChangeTypeAny Method

[image]

Revit 2011 API
Element..::.GetChangeTypeAny Method
Element Class See Also Send Feedback
Returns ChangeType associated with any change in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeAny()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeAny As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeAny()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on any change in an element

Remarks

Use this change type to trigger an Updater when elements change in any way. For maximum efficiency, we recommend the use of ChangeTypeParameter and ChangeTypeGeometry, if applicable, instead. Caution: Changes to an element by an Updater using this trigger will result in re-triggering of the Updater. For example, Updater1 triggers on ChangeTypeAny on Element X. A Revit user modifies parameter A of X. Updater1 is triggered and modifies X's parameter B. The change in parameter B, triggers another call to Updater1::execute(). If Updater1 continues to modify X, it can run into an infinite loop. Infinite loops are detected by Revit and result in the Updater being disabled. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeElementAddition Method

[image]

Revit 2011 API
Element..::.GetChangeTypeElementAddition Method
Element Class See Also Send Feedback
Returns ChangeType associated with element addition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementAddition()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeElementAddition As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementAddition()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element addition.

Remarks

Use this change type to trigger an Updater on the addition of elements to a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeElementDeletion Method

[image]

Revit 2011 API
Element..::.GetChangeTypeElementDeletion Method
Element Class See Also Send Feedback
Returns ChangeType associated with element deletion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementDeletion()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeElementDeletion As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementDeletion()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element deletion.

Remarks

ChangeType that can be used to define a trigger for an Updater, Use this change type to trigger an Updater on the deletion of elements from a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeGeometry Method

[image]

Revit 2011 API
Element..::.GetChangeTypeGeometry Method
Element Class See Also Send Feedback
summary: Returns ChangeType associated with a change in the geometry of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeGeometry()
Visual Basic (Declaration)
Public Shared Function GetChangeTypeGeometry As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeGeometry()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on a geometry change in an element

Remarks

Use this change type to trigger an Updater when the geometry of an element changes. Only physical changes to shape of the element(s) will trigger the updater. For example, changes like cutting a hole in a wall or adjusting its height are considered to be geometric changes. However, moving a wall to a different location without modifying its shape is not considered to be a change in geometry and will not trigger the Updater. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeParameter Method

[image] [image]

Revit 2011 API
Element..::.GetChangeTypeParameter Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value

See Also

Element Class
Element Members


GetChangeTypeParameter Method (ElementId)

[image]

Revit 2011 API
Element..::.GetChangeTypeParameter Method (ElementId)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    ElementId parameterId
)
Visual Basic (Declaration)
Public Shared Function GetChangeTypeParameter ( _
    parameterId As ElementId _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.

Remarks

remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetChangeTypeParameter Overload


GetChangeTypeParameter Method (Parameter)

[image]

Revit 2011 API
Element..::.GetChangeTypeParameter Method (Parameter)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    Parameter param
)
Visual Basic (Declaration)
Public Shared Function GetChangeTypeParameter ( _
    param As Parameter _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
Parameter for the ChangeType to trigger on

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change

Remarks

Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

Element Class
GetChangeTypeParameter Overload


GetDividedSurfaceData Method

[image]

Revit 2011 API
Element..::.GetDividedSurfaceData Method
Element Class See Also Send Feedback
Get an interface to the divided surfaces on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DividedSurfaceData GetDividedSurfaceData()
Visual Basic (Declaration)
Public Function GetDividedSurfaceData As DividedSurfaceData
Visual C++
public:
DividedSurfaceData^ GetDividedSurfaceData()

Return Value

An object that can be used to find information about this element's divided surfaces. Divided surfaces are only supported in Conceptual Massing families; outside of that environment, this method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Divided surfaces are supported on the following element types: Form, GeomCombination, FamilyInstance, and ImportInstance.

See Also

Element Class


GetMaterialArea Method

[image]

Revit 2011 API
Element..::.GetMaterialArea Method
Element Class See Also Send Feedback
Get the area of the given material on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetMaterialArea(
    Material material
)
Visual Basic (Declaration)
Public Function GetMaterialArea ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialArea(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.DB..::.Material

Return Value

The area, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | The input material was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | The material comes from a different document than this element.

See Also

Element Class


GetMaterialVolume Method

[image]

Revit 2011 API
Element..::.GetMaterialVolume Method
Element Class See Also Send Feedback
Get the volume of the given material on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetMaterialVolume(
    Material material
)
Visual Basic (Declaration)
Public Function GetMaterialVolume ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialVolume(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.DB..::.Material

Return Value

The volume, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | The input material was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | The material comes from a different document than this element.

See Also

Element Class


GetMonitoredLinkElementIds Method

[image]

Revit 2011 API
Element..::.GetMonitoredLinkElementIds Method
Element Class See Also Send Feedback
Provides the link instance IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLinkElementIds()
Visual Basic (Declaration)
Public Function GetMonitoredLinkElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLinkElementIds()

Return Value

The IDs of linked instances.

See Also

Element Class


GetMonitoredLocalElementIds Method

[image]

Revit 2011 API
Element..::.GetMonitoredLocalElementIds Method
Element Class See Also Send Feedback
Provides the local element IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLocalElementIds()
Visual Basic (Declaration)
Public Function GetMonitoredLocalElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLocalElementIds()

Return Value

The IDs of local element IDs being monitored by this element.

See Also

Element Class


GetTypeId Method

[image]

Revit 2011 API
Element..::.GetTypeId Method
Element Class Example See Also Send Feedback
Returns the identifier of this element's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetTypeId()
Visual Basic (Declaration)
Public Function GetTypeId As ElementId
Visual C++
public:
ElementId^ GetTypeId()

Return Value

The id of the element's type, or invalid element id if the element can not have type assigned.

Remarks

Some elements can not have type assigned, in which case this method returns invalid element id.

Examples

CopyC#
void GetStairType(Autodesk.Revit.DB.Document document)
{
   FilteredElementCollector collector = new FilteredElementCollector(document);
   ICollection<Element> stairs = collector.OfClass(typeof(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements();
   foreach (Element stair in stairs)
    {
        if (null == stair.GetTypeId())
        {
            TaskDialog.Show("Revit","No symbol found in stair element: " + stair.Name);
        }
        else
        {
            Element elemType = document.get_Element(stair.GetTypeId());
            string info = "Stair type is: " + elemType.Name;
            TaskDialog.Show("Revit",info);
        }
    }
}
CopyVB.NET
Sub GetStairType(ByVal document As Autodesk.Revit.DB.Document)
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim stairs As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements()
    For Each stair As Autodesk.Revit.DB.Element In stairs
        If stair.GetTypeId() Is Nothing Then
            TaskDialog.Show("Revit", "No symbol found in stair element: " + stair.Name)
        Else
            Dim elemType As Autodesk.Revit.DB.Element = document.Element(stair.GetTypeId())
            Dim info As String = "Stair type is: " + elemType.Name
            TaskDialog.Show("Revit", info)
        End If
    Next
End Sub

See Also

Element Class


GetValidTypes Method

[image] [image]

Revit 2011 API
Element..::.GetValidTypes Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetValidTypes()()() | Obtains a set of types that are valid for this element.
GetValidTypes(Document, ICollection<(Of <(ElementId>)>)) | Obtains a set of types that are valid for all given elements.

See Also

Element Class
Element Members


GetValidTypes Method

[image]

Revit 2011 API
Element..::.GetValidTypes Method
Element Class See Also Send Feedback
Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetValidTypes()
Visual Basic (Declaration)
Public Function GetValidTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidTypes()

Return Value

A set of element IDs of types that are valid for this element.

Remarks

Returns an empty set if element can not have type assigned.

See Also

Element Class
GetValidTypes Overload


GetValidTypes Method (Document, ICollection(ElementId))

[image]

Revit 2011 API
Element..::.GetValidTypes Method (Document, ICollection<(Of <(ElementId>)>))
Element Class See Also Send Feedback
Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Shared Function GetValidTypes ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs.

Return Value

A set of element IDs of types that are valid for these elements.

Remarks

Returns an empty set if any element can not have a type assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetValidTypes Overload


IsHidden Method

[image]

Revit 2011 API
Element..::.IsHidden Method
Element Class See Also Send Feedback
Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsHidden(
    View pView
)
Visual Basic (Declaration)
Public Function IsHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::.View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


IsMonitoringLinkElement Method

[image]

Revit 2011 API
Element..::.IsMonitoringLinkElement Method
Element Class See Also Send Feedback
Indicate whether an element is monitoring any elements in any linked models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsMonitoringLinkElement()
Visual Basic (Declaration)
Public Function IsMonitoringLinkElement As Boolean
Visual C++
public:
bool IsMonitoringLinkElement()

Return Value

True if this element is monitoring elements in a linked models. Otherwise, false will be returned.

See Also

Element Class


IsMonitoringLocalElement Method

[image]

Revit 2011 API
Element..::.IsMonitoringLocalElement Method
Element Class See Also Send Feedback
Indicate whether an element is monitoring other local elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsMonitoringLocalElement()
Visual Basic (Declaration)
Public Function IsMonitoringLocalElement As Boolean
Visual C++
public:
bool IsMonitoringLocalElement()

Return Value

True if this element is monitoring other elements in same project. Otherwise, false will be returned.

See Also

Element Class


IsValidType Method

[image] [image]

Revit 2011 API
Element..::.IsValidType Method
Element Class See Also Send Feedback

Overload List

Name | Description
IsValidType(ElementId) | Checks if given type is valid for this element.
IsValidType(Document, ICollection<(Of <(ElementId>)>), ElementId) | Checks if given type is valid for the set of elements.

See Also

Element Class
Element Members


IsValidType Method (ElementId)

[image]

Revit 2011 API
Element..::.IsValidType Method (ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidType(
    ElementId typeId
)
Visual Basic (Declaration)
Public Function IsValidType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of the type to check.

Return Value

True if element can have a type assigned and this type is valid for this element, false otherwise.

Remarks

A type is valid for an element if it can be assigned to the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
IsValidType Overload


IsValidType Method (Document, ICollection(ElementId), ElementId)

[image]

Revit 2011 API
Element..::.IsValidType Method (Document, ICollection<(Of <(ElementId>)>), ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidType(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic (Declaration)
Public Shared Function IsValidType ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidType(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of the type to check.

Return Value

True if all elements can have a type assigned and this type is valid for all elements, false otherwise.

Remarks

A type is valid for the set of elements if it is valid for each and every element in the set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
IsValidType Overload


Element Properties

[image] [image]

Revit 2011 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Category | Retrieves a Category object that represents the category or sub category in which the element resides.
DesignOption | Returns the design option to which the element belongs.
Document | Returns the Document in which the Element resides.
Geometry | Retrieves the geometric representation of the element.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Level | If the element is level based then level to which the element is assigned is returned.
Location | This property is used to find the physical location of an element within a project.
Materials | Get all materials present in the element.
Name | A human readable name for the Element.
ObjectType | Obsolete. Returns the instance type of this object.
OwnerViewId | The id of the view that owns the element.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element.
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
PhaseCreated | An object representing the phase when the element is created.
PhaseDemolished | An object representing the phase for when the element is to be demolished.
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance.
UniqueId | A stable unique identifier for an element within the document.
ViewSpecific | Identifies if the element is owned by a view.

See Also

Element Class


BoundingBox Property

[image]

Revit 2011 API
Element..::.BoundingBox Property
Element Class Example See Also Send Feedback
Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ BoundingBox[
    View
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

Type: Autodesk.Revit.DB..::.View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry. If view box is not known, will return model box; if model box is not known, will return nullNothingnullptra null reference (Nothing in Visual Basic). Also note that this bounding box value may include geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.

Examples

CopyC#
private void GetElementBoundingBox(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the BoundingBox instance for current view.
    BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
    if (null == box)
    {
        throw new Exception("Selected element doesn't contain a bounding box.");
    }

    string info = "Bounding box is enabled: " + box.Enabled.ToString();

    // Give the user some information.
    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Private Sub GetElementBoundingBox(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get the BoundingBox instance for current view.
    Dim box As BoundingBoxXYZ = element.BoundingBox(document.ActiveView)
    If box Is Nothing Then
        Throw New Exception("Selected element doesn't contain a bounding box.")
    End If

    Dim info As String = "Bounding box is enabled: " + box.Enabled.ToString()

    ' Give the user some information.
    TaskDialog.Show("Revit", info)
End Sub

See Also

Element Class


Category Property

[image]

Revit 2011 API
Element..::.Category Property
Element Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category Category { get; }
Visual Basic (Declaration)
Public ReadOnly Property Category As Category
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class


DesignOption Property

[image]

Revit 2011 API
Element..::.DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic (Declaration)
Public ReadOnly Property DesignOption As DesignOption
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    UIDocument uidoc = new UIDocument(document);
    ElementSet selection = uidoc.Selection.Elements;

    foreach (Autodesk.Revit.DB.Element element in selection)
    {
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Sub Getinfo_DesignOption(ByVal document As Document)
    ' Get the selected Elements in the Active Document
    Dim uidoc As New UIDocument(document)
    Dim selection As ElementSet = uidoc.Selection.Elements

    For Each element As Autodesk.Revit.DB.Element In selection
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class


Document Property

[image]

Revit 2011 API
Element..::.Document Property
Element Class See Also Send Feedback
Returns the Document in which the Element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class


Geometry Property

[image]

Revit 2011 API
Element..::.Geometry Property
Element Class Example See Also Send Feedback
Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement Geometry[
    Options options
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Geometry ( _
    options As Options _
) As GeometryElement
Visual C++
public:
property GeometryElement^ Geometry[Options^ options] {
    GeometryElement^ get (Options^ options);
}

Parameters

options
Type: Autodesk.Revit.DB..::.Options
User preferences for parsing of geometry.

Field Value

An element that provides access to the geometry of the element.

Remarks

This call will retrieve 3d representation of the element. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

Geometry objects provided from this method are obtained directly from the element. When the element is changed for any reason, the geometry will be recalculated by Revit and geometry objects obtained before the change are likely to no longer be valid. If you need to preserve geometry information obtained an element even after changes to that element, you should copy the geometry objects or save the properties independently.

If you require that the geometry items obtained contain valid Reference objects, be sure to set the CalculateReferences property of the options.

Examples

CopyC#
public void GetCurvesFromABeam(Autodesk.Revit.DB.FamilyInstance beam,
                               Autodesk.Revit.DB.Options options)
{
    Autodesk.Revit.DB.GeometryElement geomElem = beam.get_Geometry(options);

    Autodesk.Revit.DB.CurveArray curves = new CurveArray();
    Autodesk.Revit.DB.SolidArray solids = new SolidArray();

    //Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, ref curves, ref solids);
}

private void AddCurvesAndSolids(Autodesk.Revit.DB.GeometryElement geomElem,
                                ref Autodesk.Revit.DB.CurveArray curves,
                                ref Autodesk.Revit.DB.SolidArray solids)
{
    foreach (Autodesk.Revit.DB.GeometryObject geomObj in geomElem.Objects)
    {
        Autodesk.Revit.DB.Curve curve = geomObj as Autodesk.Revit.DB.Curve;
        if (null != curve)
        {
            curves.Append(curve);
            continue;
        }
        Autodesk.Revit.DB.Solid solid = geomObj as Autodesk.Revit.DB.Solid;
        if (null != solid)
        {
            solids.Append(solid);
            continue;
        }
        //If this GeometryObject is Instance, call AddCurvesAndSolids
        Autodesk.Revit.DB.GeometryInstance geomInst = geomObj as Autodesk.Revit.DB.GeometryInstance;
        if (null != geomInst)
        {
            Autodesk.Revit.DB.GeometryElement transformedGeomElem
              = geomInst.GetInstanceGeometry(geomInst.Transform);
            AddCurvesAndSolids(transformedGeomElem, ref curves, ref solids);
        }
    }
}
CopyVB.NET
Public Sub GetCurvesFromABeam(ByVal beam As Autodesk.Revit.DB.FamilyInstance, ByVal options As Autodesk.Revit.DB.Options)
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = beam.Geometry(options)

    Dim curves As Autodesk.Revit.DB.CurveArray = New CurveArray()
    Dim solids As Autodesk.Revit.DB.SolidArray = New SolidArray()

    'Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, curves, solids)
End Sub

Private Sub AddCurvesAndSolids(ByVal geomElem As Autodesk.Revit.DB.GeometryElement, ByRef curves As Autodesk.Revit.DB.CurveArray, ByRef solids As Autodesk.Revit.DB.SolidArray)
    For Each geomObj As Autodesk.Revit.DB.GeometryObject In geomElem.Objects
        Dim curve As Autodesk.Revit.DB.Curve = TryCast(geomObj, Autodesk.Revit.DB.Curve)
        If curve IsNot Nothing Then
            curves.Append(curve)
            Continue For
        End If
        Dim solid As Autodesk.Revit.DB.Solid = TryCast(geomObj, Autodesk.Revit.DB.Solid)
        If solid IsNot Nothing Then
            solids.Append(solid)
            Continue For
        End If
        'If this GeometryObject is Instance, call AddCurvesAndSolids
        Dim geomInst As Autodesk.Revit.DB.GeometryInstance = TryCast(geomObj, Autodesk.Revit.DB.GeometryInstance)
        If geomInst IsNot Nothing Then
            Dim transformedGeomElem As Autodesk.Revit.DB.GeometryElement = geomInst.GetInstanceGeometry(geomInst.Transform)
            AddCurvesAndSolids(transformedGeomElem, curves, solids)
        End If
    Next
End Sub

See Also

Element Class


Group Property

[image]

Revit 2011 API
Element..::.Group Property
Element Class Example See Also Send Feedback
Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Group Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As Group
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

Examples

CopyC#
private void ShowGroupInformation(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    Autodesk.Revit.DB.Group group = element.Group;
    if (null == group)
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
        prompt = "The element " + element.Id.IntegerValue + " is in a group.";
        prompt += "\nThe group id is " + group.Id.IntegerValue;
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        Autodesk.Revit.DB.ElementArray groupMembers = group.Members;
        foreach (Autodesk.Revit.DB.Element e in groupMembers)
        {
           prompt += "\n\t" + e.Id.IntegerValue;
        }
    }

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub ShowGroupInformation(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get group information for the selected element
    Dim prompt As [String] = Nothing
    Dim group As Autodesk.Revit.DB.Group = element.Group
    If group Is Nothing Then
        prompt = "The element isn't in any group."
    Else
        prompt = "The element " + element.Id.IntegerValue + " is in a group."
        prompt += vbLf & "The group id is " + group.Id.IntegerValue
        prompt += vbLf & "The group's category is " + group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim groupMembers As Autodesk.Revit.DB.ElementArray = group.Members
        For Each e As Autodesk.Revit.DB.Element In groupMembers
            prompt += vbLf & vbTab + e.Id.IntegerValue
        Next
    End If

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class


Id Property

[image]

Revit 2011 API
Element..::.Id Property
Element Class Example See Also Send Feedback
Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

Remarks

Returns an object containing the project wide unique identifier for this Element. The identifier with this id is only unique for the project, it is not unique across separate Autodesk Revit projects.

Examples

CopyC#
private void CheckElementId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the id of the element
    Autodesk.Revit.DB.ElementId selectedId = element.Id;
    int idInteger = selectedId.IntegerValue;

    // create a new id and set the value
    Autodesk.Revit.DB.ElementId id = new Autodesk.Revit.DB.ElementId(idInteger);

    // Get the element
    Autodesk.Revit.DB.Element first = document.get_Element(id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.DB.Element second = document.get_Element(selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub CheckElementId(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.DB.ElementId = element.Id
    Dim idInteger As Integer = selectedId.IntegerValue

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.DB.ElementId(idInteger)

    ' Get the element
    Dim first As Autodesk.Revit.DB.Element = document.Element(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.DB.Element = document.Element(selectedId)

    Dim prompt As [String] = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " + isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " + isSame

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class


Level Property

[image]

Revit 2011 API
Element..::.Level Property
Element Class Example See Also Send Feedback
If the element is level based then level to which the element is assigned is returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.DB.Element element)
{
    // Get the level object to which the element is assigned.
    Level level = element.Level;
    if (null == level)
    {
        TaskDialog.Show("Revit","The element isn't based on a level.");
    }
    else
    {
        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub GetLevelInformation(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the level object to which the element is assigned.
    Dim level As Level = element.Level
    If level Is Nothing Then
        TaskDialog.Show("Revit", "The element isn't based on a level.")
    Else
        ' Format the prompt information(Name and elevation)
        Dim prompt As [String] = "The element is based on a level."
        prompt += vbLf & "The level name is:  " + level.Name
        prompt += vbLf & "The level elevation is:  " + level.Elevation

        ' Show the information to the user.
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Location Property

[image]

Revit 2011 API
Element..::.Location Property
Element Class Example See Also Send Feedback
This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Location Location { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

Examples

CopyC#
void GetLocationInformation(Autodesk.Revit.DB.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.DB.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.DB.LocationPoint positionPoint = position as Autodesk.Revit.DB.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.DB.LocationCurve positionCurve = position as Autodesk.Revit.DB.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub GetLocationInformation(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.DB.Location = element.Location

    Dim prompt As [String] = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.DB.LocationPoint = TryCast(position, Autodesk.Revit.DB.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.DB.LocationCurve = TryCast(position, Autodesk.Revit.DB.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Materials Property

[image]

Revit 2011 API
Element..::.Materials Property
Element Class See Also Send Feedback
Get all materials present in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialSet Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As MaterialSet
Visual C++
public:
property MaterialSet^ Materials {
    MaterialSet^ get ();
}

Remarks

The set will be empty for elements where the HasMaterialQuantities property of the element's Category is false. The set will also be empty for elements whose category supports material quantities (the HasMaterialQuantities property of the element's Category is true), but where the element has not been assigned materials.

See Also

Element Class


Name Property

[image]

Revit 2011 API
Element..::.Name Property
Element Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

Element Class


ObjectType Property

[image]

Revit 2011 API
Element..::.ObjectType Property
Element Class See Also Send Feedback
Returns the instance type of this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Element.GetTypeId() and Element.ChangeTypeId() instead.")]
public ElementType ObjectType { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use Element.GetTypeId() and Element.ChangeTypeId() instead.")> _
Public Property ObjectType As ElementType
Visual C++
[ObsoleteAttribute(L"Use Element.GetTypeId() and Element.ChangeTypeId() instead.")]
public:
property ElementType^ ObjectType {
    ElementType^ get ();
    void set (ElementType^ value);
}

Remarks

The type of the object returned by this method depends upon the type of this instance, for example - if this object is a wall then a wall type object will be returned. Not all objects have an instance type in which case nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

Element Class


OwnerViewId Property

[image]

Revit 2011 API
Element..::.OwnerViewId Property
Element Class See Also Send Feedback
The id of the view that owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId OwnerViewId { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwnerViewId As ElementId
Visual C++
public:
property ElementId^ OwnerViewId {
    ElementId^ get ();
}

Field Value

The owner view id, or InvalidElementId if there is no owner view.

See Also

Element Class


Parameter Property

[image] [image]

Revit 2011 API
Element..::.Parameter Property
Element Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition.
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Parameter[([(String])]) | Retrieves a parameter from the element given its name.

See Also

Element Class
Element Members


Parameter Property (BuiltInParameter)

[image]

Revit 2011 API
Element..::.Parameter Property (BuiltInParameter)
Element Class Example See Also Send Feedback
Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::.BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

Examples

CopyC#
public Parameter FindWithBuiltinParameterID(Wall wall)
{
    //Use the WALL_BASE_OFFSET paramametId
    // to get the base offset parameter of the wall.
    BuiltInParameter paraIndex = BuiltInParameter.WALL_BASE_OFFSET;
    Parameter parameter = wall.get_Parameter(paraIndex);

    return parameter;
}
CopyVB.NET
Public Function FindWithBuiltinParameterID(ByVal wall As Wall) As Parameter
    'Use the WALL_BASE_OFFSET paramametId
    ' to get the base offset parameter of the wall.
    Dim paraIndex As BuiltInParameter = BuiltInParameter.WALL_BASE_OFFSET
    Dim parameter As Parameter = wall.Parameter(paraIndex)

    Return parameter
End Function

See Also

Element Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2011 API
Element..::.Parameter Property (Definition)
Element Class See Also Send Feedback
Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::.Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Parameter Overload


Parameter Property (Guid)

[image]

Revit 2011 API
Element..::.Parameter Property (Guid)
Element Class See Also Send Feedback
Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter Parameter[
    Guid guid
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Type: System..::.Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Parameter Overload


Parameter Property (String)

[image]

Revit 2011 API
Element..::.Parameter Property (String)
Element Class See Also Send Feedback
Retrieves a parameter from the element given its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter Parameter[
    string paramName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    paramName As String _
) As Parameter
Visual C++
public:
property Parameter^ Parameter[String^ paramName] {
    Parameter^ get (String^ paramName);
}

Parameters

paramName
Type: System..::.String
The name of the parameter to be retrieved.

See Also

Element Class
Parameter Overload


Parameters Property

[image]

Revit 2011 API
Element..::.Parameters Property
Element Class Example See Also Send Feedback
Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterSet
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

Examples

CopyC#
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element:";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + @"\t";
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defName += " : " + para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            Autodesk.Revit.DB.ElementId id = para.AsElementId();
            if (id.IntegerValue >= 0)
            {
                defName += " : " + document.get_Element(id).Name;
            }
            else
            {
               defName += " : " + id.IntegerValue.ToString();
            }
            break;
        case StorageType.Integer:
            if (ParameterType.YesNo == para.Definition.ParameterType)
            {
                if (para.AsInteger() == 0)
                {
                    defName += " : " + "False";
                }
                else
                {
                    defName += " : " + "True";
                }
            }
            else
            {
                defName += " : " + para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defName += " : " + para.AsString();
            break;
        default:
            defName = "Unexposed parameter.";
            break;
    }

    return defName;
}
CopyVB.NET
Sub GetElementParameterInformation(ByVal document As Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Format the prompt information string
    Dim prompt As [String] = "Show parameters in selected Element:"

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Function GetParameterInformation(ByVal para As Parameter, ByVal document As Document) As [String]
    Dim defName As String = para.Definition.Name + "\t"
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defName += " : " + para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.DB.ElementId = para.AsElementId()
            If id.IntegerValue >= 0 Then
                defName += " : " + document.Element(id).Name
            Else
                defName += " : " + id.IntegerValue.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If ParameterType.YesNo = para.Definition.ParameterType Then
                If para.AsInteger() = 0 Then
                    defName += " : " + "False"
                Else
                    defName += " : " + "True"
                End If
            Else
                defName += " : " + para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defName += " : " + para.AsString()
            Exit Select
        Case Else
            defName = "Unexposed parameter."
            Exit Select
    End Select

    Return defName
End Function

See Also

Element Class


ParametersMap Property

[image]

Revit 2011 API
Element..::.ParametersMap Property
Element Class See Also Send Feedback
Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterMap ParametersMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParametersMap As ParameterMap
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class


PhaseCreated Property

[image]

Revit 2011 API
Element..::.PhaseCreated Property
Element Class Example See Also Send Feedback
An object representing the phase when the element is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Phase PhaseCreated { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseCreated As Phase
Visual C++
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.DB.Phase phaseCreated = element.PhaseCreated;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseCreatedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.DB.Phase = element.PhaseCreated
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As [String] = "The phase created is: " + phaseCreated.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


PhaseDemolished Property

[image]

Revit 2011 API
Element..::.PhaseDemolished Property
Element Class Example See Also Send Feedback
An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Phase PhaseDemolished { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseDemolished As Phase
Visual C++
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolition phase. If it does not then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.DB.Phase phaseDemolished = element.PhaseDemolished;
    if (null == phaseDemolished)
    {
        TaskDialog.Show("Revit","This Element doesn't have Phase Demolished parameter.");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseDemolishedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.DB.Phase = element.PhaseDemolished
    If phaseDemolished Is Nothing Then
        TaskDialog.Show("Revit", "This Element doesn't have Phase Demolished parameter.")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As [String] = "The phase demolished is: " + phaseDemolished.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Pinned Property

[image]

Revit 2011 API
Element..::.Pinned Property
Element Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Pinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

Element Class


SimilarObjectTypes Property

[image]

Revit 2011 API
Element..::.SimilarObjectTypes Property
Element Class See Also Send Feedback
Returns the types being similar to the current instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use Element.GetValidTypes() instead.")]
public virtual ElementSet SimilarObjectTypes { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use Element.GetValidTypes() instead.")> _
Public Overridable ReadOnly Property SimilarObjectTypes As ElementSet
Visual C++
[ObsoleteAttribute(L"Use Element.GetValidTypes() instead.")]
public:
virtual property ElementSet^ SimilarObjectTypes {
    ElementSet^ get ();
}

Remarks

The returned types include all the similar types to current instance, which means the type of the current instance can be swapped to the type included in the returned set.

See Also

Element Class


UniqueId Property

[image]

Revit 2011 API
Element..::.UniqueId Property
Element Class Example See Also Send Feedback
A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string UniqueId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in and external database and then be used to retrieve the exact same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as save to central whereas the Autodesk::Revit::DB::ElementId^ property may change.

Examples

CopyC#
private void CheckElementUniqueId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    String uniqueId = element.UniqueId;

    // Get the element using the UniqueId
    Autodesk.Revit.DB.Element elem = document.get_Element(uniqueId);

    String prompt = "UniqueId of element is: " + uniqueId;
    prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
CopyVB.NET
Private Sub CheckElementUniqueId(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    Dim uniqueId As [String] = element.UniqueId

    ' Get the element using the UniqueId
    Dim elem As Autodesk.Revit.DB.Element = document.Element(uniqueId)

    Dim prompt As [String] = "UniqueId of element is: " + uniqueId
    prompt += vbLf & "UniqueID of elem is: " + elem.UniqueId
End Sub

See Also

Element Class


ViewSpecific Property

[image]

Revit 2011 API
Element..::.ViewSpecific Property
Element Class See Also Send Feedback
Identifies if the element is owned by a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ViewSpecific { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSpecific As Boolean
Visual C++
public:
property bool ViewSpecific {
    bool get ();
}

Field Value

True if the element is owned by a view.

See Also

Element Class


ElementArray Class

[image]

Revit 2011 API
ElementArray Class
Members See Also Send Feedback
An array that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ElementArray

See Also

ElementArray Members


ElementArray Members

[image] [image]

Revit 2011 API
ElementArray Members
ElementArray Class Constructors Methods Properties See Also Send Feedback

The ElementArray type exposes the following members.

Constructors

Name | Description
ElementArray | Initializes a new instance of the ElementArray class

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every element from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an element at a specified index within the array.
Size | Returns the number of elements that are in the array.

See Also

ElementArray Class


ElementArray Constructor

[image]

Revit 2011 API
ElementArray Constructor
ElementArray Class See Also Send Feedback
Initializes a new instance of the ElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArray()

See Also

ElementArray Class


ElementArray Methods

[image] [image]

Revit 2011 API
ElementArray Methods
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Methods

Name | Description
Append | Add the element to the end of the array.
Clear | Removes every element from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArray Class


Append Method

[image]

Revit 2011 API
ElementArray..::.Append Method
ElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Element item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Element _
)
Visual C++
public:
virtual void Append(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Element
The element to be added.

See Also

ElementArray Class


Clear Method

[image]

Revit 2011 API
ElementArray..::.Clear Method
ElementArray Class See Also Send Feedback
Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementArray Class


ForwardIterator Method

[image]

Revit 2011 API
ElementArray..::.ForwardIterator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class


GetEnumerator Method

[image]

Revit 2011 API
ElementArray..::.GetEnumerator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementArray Class


Insert Method

[image]

Revit 2011 API
ElementArray..::.Insert Method
ElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Element^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Element
The element to be inserted into the array.
index
Type: System..::.Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class


ReverseIterator Method

[image]

Revit 2011 API
ElementArray..::.ReverseIterator Method
ElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElementArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ElementArray Class


ElementArray Properties

[image] [image]

Revit 2011 API
ElementArray Properties
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an element at a specified index within the array.
Size | Returns the number of elements that are in the array.

See Also

ElementArray Class


IsEmpty Property

[image]

Revit 2011 API
ElementArray..::.IsEmpty Property
ElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ElementArray Class


Item Property

[image]

Revit 2011 API
ElementArray..::.Item Property
ElementArray Class See Also Send Feedback
Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Element Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::.Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class


Size Property

[image]

Revit 2011 API
ElementArray..::.Size Property
ElementArray Class See Also Send Feedback
Returns the number of elements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementArray Class


ElementArrayIterator Class

[image]

Revit 2011 API
ElementArrayIterator Class
Members See Also Send Feedback
An iterator to an element array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ElementArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ElementArrayIterator

See Also

ElementArrayIterator Members


ElementArrayIterator Members

[image] [image]

Revit 2011 API
ElementArrayIterator Members
ElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Constructors

Name | Description
ElementArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class


ElementArrayIterator Constructor

[image]

Revit 2011 API
ElementArrayIterator Constructor
ElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementArrayIterator Class


ElementArrayIterator Methods

[image] [image]

Revit 2011 API
ElementArrayIterator Methods
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ElementArrayIterator..::.MoveNext Method
ElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


Reset Method

[image]

Revit 2011 API
ElementArrayIterator..::.Reset Method
ElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementArrayIterator Class


ElementArrayIterator Properties

[image] [image]

Revit 2011 API
ElementArrayIterator Properties
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class


Current Property

[image]

Revit 2011 API
ElementArrayIterator..::.Current Property
ElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


ElementBinding Class

[image]

Revit 2011 API
ElementBinding Class
Members See Also Send Feedback
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic (Declaration)
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding
Autodesk.Revit.DB..::.InstanceBinding
Autodesk.Revit.DB..::.TypeBinding

See Also

ElementBinding Members


ElementBinding Members

[image] [image]

Revit 2011 API
ElementBinding Members
ElementBinding Class Methods Properties See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


ElementBinding Methods

[image] [image]

Revit 2011 API
ElementBinding Methods
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementBinding Class


ElementBinding Properties

[image] [image]

Revit 2011 API
ElementBinding Properties
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


Categories Property

[image]

Revit 2011 API
ElementBinding..::.Categories Property
ElementBinding Class See Also Send Feedback
Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CategorySet Categories { get; set; }
Visual Basic (Declaration)
Public Property Categories As CategorySet
Visual C++
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}

Remarks

The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.

See Also

ElementBinding Class


ElementCategoryFilter Class

[image]

Revit 2011 API
ElementCategoryFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementCategoryFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementCategoryFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementCategoryFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);

// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
    prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);
CopyVB.NET
' Find all Wall instances in the document by using category filter
Dim filter As New ElementCategoryFilter(BuiltInCategory.OST_Walls)

' Apply the filter to the elements in the active document,
' Use shortcut WhereElementIsNotElementType() to find wall instances only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim walls As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements()
Dim prompt As [String] = "The walls in the current document are:" & vbLf
For Each e As Autodesk.Revit.DB.Element In walls
    prompt += e.Name + vbLf
Next
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementCategoryFilter

See Also

ElementCategoryFilter Members


ElementCategoryFilter Members

[image] [image]

Revit 2011 API
ElementCategoryFilter Members
ElementCategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Constructors

Name | Description
ElementCategoryFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CategoryId | The category id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


ElementCategoryFilter Constructor

[image] [image]

Revit 2011 API
ElementCategoryFilter Constructor
ElementCategoryFilter Class See Also Send Feedback

Overload List

Name | Description
ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Members


ElementCategoryFilter Constructor (BuiltInCategory)

[image]

Revit 2011 API
ElementCategoryFilter Constructor (BuiltInCategory)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category
)
Visual Basic (Declaration)
Public Sub New ( _
    category As BuiltInCategory _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category to match.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId)

[image]

Revit 2011 API
ElementCategoryFilter Constructor (ElementId)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As ElementId _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.ElementId
The category id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (BuiltInCategory, Boolean)

[image]

Revit 2011 API
ElementCategoryFilter Constructor (BuiltInCategory, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    category As BuiltInCategory, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId, Boolean)

[image]

Revit 2011 API
ElementCategoryFilter Constructor (ElementId, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId,
    bool inverted
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.ElementId
The category id to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Methods

[image] [image]

Revit 2011 API
ElementCategoryFilter Methods
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementCategoryFilter Class


ElementCategoryFilter Properties

[image] [image]

Revit 2011 API
ElementCategoryFilter Properties
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Properties

Name | Description
CategoryId | The category id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


CategoryId Property

[image]

Revit 2011 API
ElementCategoryFilter..::.CategoryId Property
ElementCategoryFilter Class See Also Send Feedback
The category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryId As ElementId
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

See Also

ElementCategoryFilter Class


ElementClassFilter Class

[image]

Revit 2011 API
ElementClassFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementClassFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementClassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementClassFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

This filter will match elements whose class is an exact match to the input class, or elements whose class is derived from the input class.

There is a small subset of Element subclasses in the API which are not supported by this filter. These types exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subtype. The following types are affected by this restriction:

  • Subclasses of Autodesk.Revit.DB.Material
  • Subclasses of Autodesk.Revit.DB.CurveElement
  • Subclasses of Autodesk.Revit.DB.ConnectorElement
  • Subclasses of Autodesk.Revit.DB.HostedSweep
  • Autodesk.Revit.DB.Architecture.Room
  • Autodesk.Revit.DB.Mechanical.Space
  • Autodesk.Revit.DB.Area
  • Autodesk.Revit.DB.Architecture.RoomTag
  • Autodesk.Revit.DB.Mechanical.SpaceTag
  • Autodesk.Revit.DB.AreaTag
  • Autodesk.Revit.DB.CombinableElement
  • Autodesk.Revit.DB.Mullion
  • Autodesk.Revit.DB.Panel
  • Autodesk.Revit.DB.AnnotationSymbol
  • Autodesk.Revit.DB.Structure.AreaReinforcementType
  • Autodesk.Revit.DB.Structure.PathReinforcementType
  • Autodesk.Revit.DB.AnnotationSymbolType
  • Autodesk.Revit.DB.Architecture.RoomTagType
  • Autodesk.Revit.DB.Mechanical.SpaceTagType
  • Autodesk.Revit.DB.AreaTagType
  • Autodesk.Revit.DB.Structure.TrussType

Examples

CopyC#
// Use ElementClassFilter to find family instances whose name is 60" x 30" Student
ElementClassFilter filter = new ElementClassFilter(typeof(FamilyInstance));

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Use Linq query to find family instances whose name is 60" x 30" Student
var query = from element in collector
            where element.Name == "60\" x 30\" Student"
            select element;

// Cast found elements to family instances,
// this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
List<FamilyInstance> familyInstances = query.Cast<FamilyInstance>().ToList<FamilyInstance>();
CopyVB.NET
' Use ElementClassFilter to find family instances whose name is 60" x 30" Student
Dim filter As New ElementClassFilter(GetType(FamilyInstance))

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(filter)

' Use Linq query to find family instances whose name is 60" x 30" Student
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "60"" x 30"" Student" _
 Select element

' Cast found elements to family instances,
' this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
Dim familyInstances As List(Of Autodesk.Revit.DB.FamilyInstance) = query.Cast(Of Autodesk.Revit.DB.FamilyInstance)().ToList()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementClassFilter

See Also

ElementClassFilter Members


ElementClassFilter Members

[image] [image]

Revit 2011 API
ElementClassFilter Members
ElementClassFilter Class Constructors Methods Properties See Also Send Feedback

The ElementClassFilter type exposes the following members.

Constructors

Name | Description
ElementClassFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetElementClass | The class for the filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class


ElementClassFilter Constructor

[image] [image]

Revit 2011 API
ElementClassFilter Constructor
ElementClassFilter Class See Also Send Feedback

Overload List

Name | Description
ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are of the given class.

See Also

ElementClassFilter Class
ElementClassFilter Members


ElementClassFilter Constructor (Type)

[image]

Revit 2011 API
ElementClassFilter Constructor (Type)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ElementClassFilter(
    Type^ type
)

Parameters

type
Type: System..::.Type
The type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Constructor (Type, Boolean)

[image]

Revit 2011 API
ElementClassFilter Constructor (Type, Boolean)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class, with the option to match all elements which are of the given class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type, _
    inverted As Boolean _
)
Visual C++
public:
ElementClassFilter(
    Type^ type,
    bool inverted
)

Parameters

type
Type: System..::.Type
The type to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Methods

[image] [image]

Revit 2011 API
ElementClassFilter Methods
ElementClassFilter Class See Also Send Feedback

The ElementClassFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetElementClass | The class for the filter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementClassFilter Class


GetElementClass Method

[image]

Revit 2011 API
ElementClassFilter..::.GetElementClass Method
ElementClassFilter Class See Also Send Feedback
The class for the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Type GetElementClass()
Visual Basic (Declaration)
Public Function GetElementClass As Type
Visual C++
public:
Type^ GetElementClass()

Return Value

The class.

See Also

ElementClassFilter Class


ElementClassFilter Properties

[image] [image]

Revit 2011 API
ElementClassFilter Properties
ElementClassFilter Class See Also Send Feedback

The ElementClassFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class


ElementDesignOptionFilter Class

[image]

Revit 2011 API
ElementDesignOptionFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementDesignOptionFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementDesignOptionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementDesignOptionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Create an ElementDesignOption filter to find all walls in the active design option.
// Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
// ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
ElementId activeOptId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document);

// Create an ElementDesignOption filter
ElementDesignOptionFilter filter = new ElementDesignOptionFilter(activeOptId);

// Apply the filter to the elements in the active document,
// use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfDesignOpt = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();

// Find all walls that are not contained within active design option: use inverted filter to match elements
ElementDesignOptionFilter notActiveOptFilter = new ElementDesignOptionFilter(activeOptId, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notActiveOptWalls =
    collector.WherePasses(notActiveOptFilter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Create an ElementDesignOption filter to find all walls in the active design option.
' Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
' ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
Dim activeOptId As ElementId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document)

' Create an ElementDesignOption filter
Dim filter As New ElementDesignOptionFilter(activeOptId)

' Apply the filter to the elements in the active document,
' use shortcut method OfClass() to find Walls only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim wallsOfDesignOpt As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

' Find all walls that are not contained within active design option: use inverted filter to match elements
Dim notActiveOptFilter As New ElementDesignOptionFilter(activeOptId, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notActiveOptWalls As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notActiveOptFilter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementDesignOptionFilter

See Also

ElementDesignOptionFilter Members


ElementDesignOptionFilter Members

[image] [image]

Revit 2011 API
ElementDesignOptionFilter Members
ElementDesignOptionFilter Class Constructors Methods Properties See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Constructors

Name | Description
ElementDesignOptionFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DesignOptionId | The design option id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


ElementDesignOptionFilter Constructor

[image] [image]

Revit 2011 API
ElementDesignOptionFilter Constructor
ElementDesignOptionFilter Class See Also Send Feedback

Overload List

Name | Description
ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Members


ElementDesignOptionFilter Constructor (ElementId)

[image]

Revit 2011 API
ElementDesignOptionFilter Constructor (ElementId)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId
)
Visual Basic (Declaration)
Public Sub New ( _
    designOptionId As ElementId _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::.ElementId
The design option id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Constructor (ElementId, Boolean)

[image]

Revit 2011 API
ElementDesignOptionFilter Constructor (ElementId, Boolean)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    designOptionId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId,
    bool inverted
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::.ElementId
The design option id to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not contained within a particular design option.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Methods

[image] [image]

Revit 2011 API
ElementDesignOptionFilter Methods
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementDesignOptionFilter Class


ElementDesignOptionFilter Properties

[image] [image]

Revit 2011 API
ElementDesignOptionFilter Properties
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Properties

Name | Description
DesignOptionId | The design option id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


DesignOptionId Property

[image]

Revit 2011 API
ElementDesignOptionFilter..::.DesignOptionId Property
ElementDesignOptionFilter Class See Also Send Feedback
The design option id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId DesignOptionId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DesignOptionId As ElementId
Visual C++
public:
property ElementId^ DesignOptionId {
    ElementId^ get ();
}

See Also

ElementDesignOptionFilter Class


ElementFilter Class

[image]

Revit 2011 API
ElementFilter Class
Members See Also Send Feedback
A base class for a type of filter that accepts or rejects elements based upon criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementFilter : IDisposable
Visual Basic (Declaration)
Public Class ElementFilter _
    Implements IDisposable
Visual C++
public ref class ElementFilter : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementSlowFilter

See Also

ElementFilter Members


ElementFilter Members

[image] [image]

Revit 2011 API
ElementFilter Members
ElementFilter Class Methods Properties See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

See Also

ElementFilter Class


ElementFilter Methods

[image] [image]

Revit 2011 API
ElementFilter Methods
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementFilter Class


Dispose Method

[image]

Revit 2011 API
ElementFilter..::.Dispose Method
ElementFilter Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ElementFilter Class


ElementFilter Properties

[image] [image]

Revit 2011 API
ElementFilter Properties
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

See Also

ElementFilter Class


Inverted Property

[image]

Revit 2011 API
ElementFilter..::.Inverted Property
ElementFilter Class See Also Send Feedback
True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Inverted { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inverted As Boolean
Visual C++
public:
property bool Inverted {
    bool get ();
}

See Also

ElementFilter Class


ElementId Class

[image]

Revit 2011 API
ElementId Class
Members See Also Send Feedback
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementId
Visual Basic (Declaration)
Public Class ElementId
Visual C++
public ref class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementId

See Also

ElementId Members


ElementId Members

[image] [image]

Revit 2011 API
ElementId Members
ElementId Class Constructors Methods Properties See Also Send Feedback

The ElementId type exposes the following members.

Constructors

Name | Description
ElementId | Overloaded.

Methods

Name | Description
Compare | Compares two element ids.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Gets a String representation of the integer value of the id. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

Properties

Name | Description
IntegerValue | Provides the value of the element id as an integer.
InvalidElementId | Get the invalid ElementId whose IntegerValue is -1.

See Also

ElementId Class


ElementId Constructor

[image] [image]

Revit 2011 API
ElementId Constructor
ElementId Class See Also Send Feedback

Overload List

Name | Description
ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.
ElementId(Int32) | Create an ElementId handle with the given integer id.

See Also

ElementId Class
ElementId Members


ElementId Constructor (BuiltInCategory)

[image]

Revit 2011 API
ElementId Constructor (BuiltInCategory)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId(
    BuiltInCategory categoryId
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryId As BuiltInCategory _
)
Visual C++
public:
ElementId(
    BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.BuiltInCategory
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (BuiltInParameter)

[image]

Revit 2011 API
ElementId Constructor (BuiltInParameter)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given BuiltInParameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId(
    BuiltInParameter parameterId
)
Visual Basic (Declaration)
Public Sub New ( _
    parameterId As BuiltInParameter _
)
Visual C++
public:
ElementId(
    BuiltInParameter parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::.BuiltInParameter
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (Int32)

[image]

Revit 2011 API
ElementId Constructor (Int32)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId(
    int id
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer _
)
Visual C++
public:
ElementId(
    int id
)

Parameters

id
Type: System..::.Int32
The id.

See Also

ElementId Class
ElementId Overload


ElementId Methods

[image] [image]

Revit 2011 API
ElementId Methods
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Methods

Name | Description
Compare | Compares two element ids.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Gets a String representation of the integer value of the id. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

See Also

ElementId Class


Compare Method

[image]

Revit 2011 API
ElementId..::.Compare Method
ElementId Class See Also Send Feedback
Compares two element ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Compare(
    ElementId id
)
Visual Basic (Declaration)
Public Function Compare ( _
    id As ElementId _
) As Integer
Visual C++
public:
int Compare(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be compared with this ElementId.

Return Value

-1 if this element id is less than id, 0 if equal, 1 if greater.

See Also

ElementId Class


Equality Operator

[image]

Revit 2011 API
ElementId..::.Equality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator ==(
    ElementId first,
    ElementId second
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the ElementIds are the same; otherwise, false.

See Also

ElementId Class


Equals Method

[image]

Revit 2011 API
ElementId..::.Equals Method
ElementId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another object.

See Also

ElementId Class


GetHashCode Method

[image]

Revit 2011 API
ElementId..::.GetHashCode Method
ElementId Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ElementId Class


GreaterThan Operator

[image]

Revit 2011 API
ElementId..::.GreaterThan Operator
ElementId Class See Also Send Feedback
Determines whether one element id is greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator >(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the first element id is greater than the second element id, otherwise, false.

See Also

ElementId Class


GreaterThanOrEqual Operator

[image]

Revit 2011 API
ElementId..::.GreaterThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator >=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the first element id is not less than the second element id, otherwise, false.

See Also

ElementId Class


Inequality Operator

[image]

Revit 2011 API
ElementId..::.Inequality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator !=(
    ElementId first,
    ElementId second
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the ElementIds are different; otherwise, false.

See Also

ElementId Class


LessThan Operator

[image]

Revit 2011 API
ElementId..::.LessThan Operator
ElementId Class See Also Send Feedback
Determines whether this element id is less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator <(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the first element id is less than the second element id, otherwise, false.

See Also

ElementId Class


LessThanOrEqual Operator

[image]

Revit 2011 API
ElementId..::.LessThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator <=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::.ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::.ElementId
The second ElementId.

Return Value

True if the first element id is not greater than the second element id, otherwise, false.

See Also

ElementId Class


ToString Method

[image]

Revit 2011 API
ElementId..::.ToString Method
ElementId Class See Also Send Feedback
Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ElementId Class


ElementId Properties

[image] [image]

Revit 2011 API
ElementId Properties
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Properties

Name | Description
IntegerValue | Provides the value of the element id as an integer.
InvalidElementId | Get the invalid ElementId whose IntegerValue is -1.

See Also

ElementId Class


IntegerValue Property

[image]

Revit 2011 API
ElementId..::.IntegerValue Property
ElementId Class See Also Send Feedback
Provides the value of the element id as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int IntegerValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property IntegerValue As Integer
Visual C++
public:
property int IntegerValue {
    int get ();
}

See Also

ElementId Class


InvalidElementId Property

[image]

Revit 2011 API
ElementId..::.InvalidElementId Property
ElementId Class See Also Send Feedback
Get the invalid ElementId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ElementId InvalidElementId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvalidElementId As ElementId
Visual C++
public:
static property ElementId^ InvalidElementId {
    ElementId^ get ();
}

See Also

ElementId Class


ElementIsCurveDrivenFilter Class

[image]

Revit 2011 API
ElementIsCurveDrivenFilter Class
Members Example See Also Send Feedback
A filter used to match elements which are curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementIsCurveDrivenFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementIsCurveDrivenFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsCurveDrivenFilter : public ElementQuickFilter

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
// The term "curve driven" indicates that the element's Location property is a LocationCurve
ElementIsCurveDrivenFilter filter = new ElementIsCurveDrivenFilter();

// Apply the filter to the elements in the active document,
// Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
// are placed at a single point).
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> slantColumns = collector
    .WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements();

// Find elements of not curve driven: use inverted filter to match elements
ElementIsCurveDrivenFilter notCurveDrivenFilter = new ElementIsCurveDrivenFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveDrivenFounds = collector.WherePasses(notCurveDrivenFilter).ToElements();
CopyVB.NET
' Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
' The term "curve driven" indicates that the element's Location property is a LocationCurve
Dim filter As New ElementIsCurveDrivenFilter()

' Apply the filter to the elements in the active document,
' Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
' are placed at a single point).
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim slantColumns As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements()

' Find elements of not curve driven: use inverted filter to match elements
Dim notCurveDrivenFilter As New ElementIsCurveDrivenFilter(True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notCurveDrivenFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notCurveDrivenFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementIsCurveDrivenFilter

See Also

ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Members

[image] [image]

Revit 2011 API
ElementIsCurveDrivenFilter Members
ElementIsCurveDrivenFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors

Name | Description
ElementIsCurveDrivenFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsCurveDrivenFilter Constructor

[image] [image]

Revit 2011 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback

Overload List

Name | Description
ElementIsCurveDrivenFilter()()() | Constructs a new instance of a filter to match only curve driven elements.
ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Constructor

[image]

Revit 2011 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIsCurveDrivenFilter()

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter Constructor (Boolean)

[image]

Revit 2011 API
ElementIsCurveDrivenFilter Constructor (Boolean)
ElementIsCurveDrivenFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter(
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
ElementIsCurveDrivenFilter(
    bool inverted
)

Parameters

inverted
Type: System..::.Boolean
True if the filter should match all elements which are not curve driven elements.

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter Methods

[image] [image]

Revit 2011 API
ElementIsCurveDrivenFilter Methods
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsCurveDrivenFilter Properties

[image] [image]

Revit 2011 API
ElementIsCurveDrivenFilter Properties
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsElementTypeFilter Class

[image]

Revit 2011 API
ElementIsElementTypeFilter Class
Members See Also Send Feedback
A filter used to match elements which are ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementIsElementTypeFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementIsElementTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsElementTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementIsElementTypeFilter

See Also

ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Members

[image] [image]

Revit 2011 API
ElementIsElementTypeFilter Members
ElementIsElementTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Constructors

Name | Description
ElementIsElementTypeFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Constructor

[image] [image]

Revit 2011 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback

Overload List

Name | Description
ElementIsElementTypeFilter()()() | Constructs a new instance of a filter to match only ElementTypes.
ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Constructor

[image]

Revit 2011 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementIsElementTypeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementIsElementTypeFilter()

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Constructor (Boolean)

[image]

Revit 2011 API
ElementIsElementTypeFilter Constructor (Boolean)
ElementIsElementTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementIsElementTypeFilter(
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
ElementIsElementTypeFilter(
    bool inverted
)

Parameters

inverted
Type: System..::.Boolean
True if the filter should match all elements which are not ElementTypes.

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Methods

[image] [image]

Revit 2011 API
ElementIsElementTypeFilter Methods
ElementIsElementTypeFilter Class See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Properties

[image] [image]

Revit 2011 API
ElementIsElementTypeFilter Properties
ElementIsElementTypeFilter Class See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class


ElementLevelFilter Class

[image]

Revit 2011 API
ElementLevelFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementLevelFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class ElementLevelFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementLevelFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Use ElementLevel filter to find elements by their associated level in the document

// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query

// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;

// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();

// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();
CopyVB.NET
' Use ElementLevel filter to find elements by their associated level in the document

' Find the level whose Name is "Level 1"
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim levels As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Level)).ToElements()
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element
' Linq query
' Get the level id which will be used to match elements
Dim level1 As List(Of Autodesk.Revit.DB.Element) = query.ToList()
Dim levelId As ElementId = level1(0).Id

' Find all walls on level one
Dim level1Filter As New ElementLevelFilter(levelId)
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim allWallsOnLevel1 As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(level1Filter).ToElements()

' Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
Dim notOnLevel1Filter As New ElementLevelFilter(levelId, True)
' Inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim allRoomsNotOnLevel1 As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(New Autodesk.Revit.DB.Architecture.RoomFilter()).WherePasses(notOnLevel1Filter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.ElementLevelFilter

See Also

ElementLevelFilter Members


ElementLevelFilter Members

[image] [image]

Revit 2011 API
ElementLevelFilter Members
ElementLevelFilter Class Constructors Methods Properties See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Constructors

Name | Description
ElementLevelFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


ElementLevelFilter Constructor

[image] [image]

Revit 2011 API
ElementLevelFilter Constructor
ElementLevelFilter Class See Also Send Feedback

Overload List

Name | Description
ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

See Also

ElementLevelFilter Class
ElementLevelFilter Members


ElementLevelFilter Constructor (ElementId)

[image]

Revit 2011 API
ElementLevelFilter Constructor (ElementId)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId
)
Visual Basic (Declaration)
Public Sub New ( _
    levelId As ElementId _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::.ElementId
The id of the level that will be matched to elements' associated level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Constructor (ElementId, Boolean)

[image]

Revit 2011 API
ElementLevelFilter Constructor (ElementId, Boolean)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    levelId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId,
    bool inverted
)

Parameters

levelId
Type: Autodesk.Revit.DB..::.ElementId
The id of the level that will be matched to elements' associated level.
inverted
Type: System..::.Boolean
True if the filter should match all elements not associated to the given level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Methods

[image] [image]

Revit 2011 API
ElementLevelFilter Methods
ElementLevelFilter Class See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementLevelFilter Class


ElementLevelFilter Properties

[image] [image]

Revit 2011 API
ElementLevelFilter Properties
ElementLevelFilter Class See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


LevelId Property

[image]

Revit 2011 API
ElementLevelFilter..::.LevelId Property
ElementLevelFilter Class See Also Send Feedback
The id of the level that will be matched to elements' associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId LevelId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LevelId As ElementId
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

ElementLevelFilter Class


ElementLogicalFilter Class

[image]

Revit 2011 API
ElementLogicalFilter Class
Members See Also Send Feedback
A filter used to logically combine two or more filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementLogicalFilter : ElementFilter
Visual Basic (Declaration)
Public Class ElementLogicalFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementLogicalFilter : public ElementFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.LogicalAndFilter
Autodesk.Revit.DB..::.LogicalOrFilter

See Also

ElementLogicalFilter Members


ElementLogicalFilter Members

[image] [image]

Revit 2011 API
ElementLogicalFilter Members
ElementLogicalFilter Class Methods Properties See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementLogicalFilter Methods

[image] [image]

Revit 2011 API
ElementLogicalFilter Methods
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementLogicalFilter Class


ElementLogicalFilter Properties

[image] [image]

Revit 2011 API
ElementLogicalFilter Properties
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementOwnerViewFilter Class

[image]

Revit 2011 API
ElementOwnerViewFilter Class
Members Example See Also Send Feedback
A filter used to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementOwnerViewFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementOwnerViewFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementOwnerViewFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use ElementOwnerView filter to find TextNotes in the active view

// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
    collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();

// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
    collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
CopyVB.NET
' Use ElementOwnerView filter to find TextNotes in the active view

' Create an ElementOwnerView filter with id of active view
Dim elementOwnerViewFilter As New ElementOwnerViewFilter(document.ActiveView.Id)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find TextNotes only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim textNotesOfActiveView As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(elementOwnerViewFilter).OfClass(GetType(TextNote)).ToElements()

' Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
Dim notOwnedFilter As New ElementOwnerViewFilter(document.ActiveView.Id, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notOwnedByViewFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notOwnedFilter).OfClass(GetType(TextNote)).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementOwnerViewFilter

See Also

ElementOwnerViewFilter Members


ElementOwnerViewFilter Members

[image] [image]

Revit 2011 API
ElementOwnerViewFilter Members
ElementOwnerViewFilter Class Constructors Methods Properties See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Constructors

Name | Description
ElementOwnerViewFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ElementOwnerViewFilter Constructor

[image] [image]

Revit 2011 API
ElementOwnerViewFilter Constructor
ElementOwnerViewFilter Class See Also Send Feedback

Overload List

Name | Description
ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Members


ElementOwnerViewFilter Constructor (ElementId)

[image]

Revit 2011 API
ElementOwnerViewFilter Constructor (ElementId)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId
)
Visual Basic (Declaration)
Public Sub New ( _
    viewId As ElementId _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Constructor (ElementId, Boolean)

[image]

Revit 2011 API
ElementOwnerViewFilter Constructor (ElementId, Boolean)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    viewId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId,
    bool inverted
)

Parameters

viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not owned by the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Methods

[image] [image]

Revit 2011 API
ElementOwnerViewFilter Methods
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementOwnerViewFilter Class


ElementOwnerViewFilter Properties

[image] [image]

Revit 2011 API
ElementOwnerViewFilter Properties
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ViewId Property

[image]

Revit 2011 API
ElementOwnerViewFilter..::.ViewId Property
ElementOwnerViewFilter Class See Also Send Feedback
The view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId ViewId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewId As ElementId
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

See Also

ElementOwnerViewFilter Class


ElementParameterFilter Class

[image]

Revit 2011 API
ElementParameterFilter Class
Members Example See Also Send Feedback
A filter used to match elements by one or more parameter filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementParameterFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class ElementParameterFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementParameterFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
CopyVB.NET
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
Dim areaParam As BuiltInParameter = BuiltInParameter.ROOM_AREA
' provider
Dim pvp As New ParameterValueProvider(New ElementId(DirectCast(areaParam, Integer)))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim rooms As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.ElementParameterFilter

See Also

ElementParameterFilter Members


ElementParameterFilter Members

[image] [image]

Revit 2011 API
ElementParameterFilter Members
ElementParameterFilter Class Constructors Methods Properties See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Constructors

Name | Description
ElementParameterFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRules | Returns the set of rules contained in this filter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementParameterFilter Constructor

[image] [image]

Revit 2011 API
ElementParameterFilter Constructor
ElementParameterFilter Class See Also Send Feedback

Overload List

Name | Description
ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
ElementParameterFilter(IList<(Of <(FilterRule>)>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
ElementParameterFilter(IList<(Of <(FilterRule>)>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

See Also

ElementParameterFilter Class
ElementParameterFilter Members


ElementParameterFilter Constructor (FilterRule)

[image]

Revit 2011 API
ElementParameterFilter Constructor (FilterRule)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a single rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRule As FilterRule _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule))

[image]

Revit 2011 API
ElementParameterFilter Constructor (IList<(Of <(FilterRule>)>))
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a set of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRules As IList(Of FilterRule) _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules
)

Parameters

filterRules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)
The rules applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (FilterRule, Boolean)

[image]

Revit 2011 API
ElementParameterFilter Constructor (FilterRule, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRule As FilterRule, _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule,
    bool inverted
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule applied to test if the element passes this filter.
inverted
Type: System..::.Boolean
True if the filter should match all elements which do not pass the filter rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule), Boolean)

[image]

Revit 2011 API
ElementParameterFilter Constructor (IList<(Of <(FilterRule>)>), Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    filterRules As IList(Of FilterRule), _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules,
    bool inverted
)

Parameters

filterRules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)
The rules applied to test if the element passes this filter.
inverted
Type: System..::.Boolean
True if the filter should match all elements which do not pass the filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Methods

[image] [image]

Revit 2011 API
ElementParameterFilter Methods
ElementParameterFilter Class See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRules | Returns the set of rules contained in this filter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementParameterFilter Class


GetRules Method

[image]

Revit 2011 API
ElementParameterFilter..::.GetRules Method
ElementParameterFilter Class See Also Send Feedback
Returns the set of rules contained in this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FilterRule> GetRules()
Visual Basic (Declaration)
Public Function GetRules As IList(Of FilterRule)
Visual C++
public:
IList<FilterRule^>^ GetRules()

Return Value

A copy of the set of rules.

See Also

ElementParameterFilter Class


ElementParameterFilter Properties

[image] [image]

Revit 2011 API
ElementParameterFilter Properties
ElementParameterFilter Class See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementQuickFilter Class

[image]

Revit 2011 API
ElementQuickFilter Class
Members See Also Send Feedback
A base class for a type of filter that operates on element records.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementQuickFilter : ElementFilter
Visual Basic (Declaration)
Public Class ElementQuickFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementQuickFilter : public ElementFilter

Remarks

Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.BoundingBoxContainsPointFilter
Autodesk.Revit.DB..::.BoundingBoxIntersectsFilter
Autodesk.Revit.DB..::.BoundingBoxIsInsideFilter
Autodesk.Revit.DB..::.ElementCategoryFilter
Autodesk.Revit.DB..::.ElementClassFilter
Autodesk.Revit.DB..::.ElementDesignOptionFilter
Autodesk.Revit.DB..::.ElementIsCurveDrivenFilter
Autodesk.Revit.DB..::.ElementIsElementTypeFilter
Autodesk.Revit.DB..::.ElementOwnerViewFilter
Autodesk.Revit.DB..::.ElementStructuralTypeFilter
Autodesk.Revit.DB..::.ExclusionFilter
Autodesk.Revit.DB..::.FamilySymbolFilter

See Also

ElementQuickFilter Members


ElementQuickFilter Members

[image] [image]

Revit 2011 API
ElementQuickFilter Members
ElementQuickFilter Class Methods Properties See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class


ElementQuickFilter Methods

[image] [image]

Revit 2011 API
ElementQuickFilter Methods
ElementQuickFilter Class See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementQuickFilter Class


ElementQuickFilter Properties

[image] [image]

Revit 2011 API
ElementQuickFilter Properties
ElementQuickFilter Class See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class


ElementRecord Class

[image]

Revit 2011 API
ElementRecord Class
Members See Also Send Feedback
A record in the Revit database representing an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementRecord : IDisposable
Visual Basic (Declaration)
Public Class ElementRecord _
    Implements IDisposable
Visual C++
public ref class ElementRecord : IDisposable

Remarks

The record is used to extract basic information about an element before the element is fully expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementRecord

See Also

ElementRecord Members


ElementRecord Members

[image] [image]

Revit 2011 API
ElementRecord Members
ElementRecord Class Methods See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the bounding box of the element record.
GetCategoryId | Gets the category id of the element record.
GetDesignOptionId | Gets the design option id of the element record.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Gets the id of the element record.
GetOwnerViewId | Gets the element id of the owner view record.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasBoundingBox | Determines whether this element record has a bounding box.
IsAnElementType | Identifies if the element record represents an ElementType.
IsCurveDriven | Identifies if the element is curve driven.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementRecord Class


ElementRecord Methods

[image] [image]

Revit 2011 API
ElementRecord Methods
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBoundingBox | Gets the bounding box of the element record.
GetCategoryId | Gets the category id of the element record.
GetDesignOptionId | Gets the design option id of the element record.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Gets the id of the element record.
GetOwnerViewId | Gets the element id of the owner view record.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasBoundingBox | Determines whether this element record has a bounding box.
IsAnElementType | Identifies if the element record represents an ElementType.
IsCurveDriven | Identifies if the element is curve driven.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementRecord Class


Dispose Method

[image]

Revit 2011 API
ElementRecord..::.Dispose Method
ElementRecord Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ElementRecord Class


GetBoundingBox Method

[image]

Revit 2011 API
ElementRecord..::.GetBoundingBox Method
ElementRecord Class See Also Send Feedback
Gets the bounding box of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic (Declaration)
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The bounding box outline. NULL if there is no bounding box for this element.

See Also

ElementRecord Class


GetCategoryId Method

[image]

Revit 2011 API
ElementRecord..::.GetCategoryId Method
ElementRecord Class See Also Send Feedback
Gets the category id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCategoryId()
Visual Basic (Declaration)
Public Function GetCategoryId As ElementId
Visual C++
public:
ElementId^ GetCategoryId()

Return Value

The category id.

See Also

ElementRecord Class


GetDesignOptionId Method

[image]

Revit 2011 API
ElementRecord..::.GetDesignOptionId Method
ElementRecord Class See Also Send Feedback
Gets the design option id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetDesignOptionId()
Visual Basic (Declaration)
Public Function GetDesignOptionId As ElementId
Visual C++
public:
ElementId^ GetDesignOptionId()

Return Value

The design option id.

See Also

ElementRecord Class


GetId Method

[image]

Revit 2011 API
ElementRecord..::.GetId Method
ElementRecord Class See Also Send Feedback
Gets the id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetId()
Visual Basic (Declaration)
Public Function GetId As ElementId
Visual C++
public:
ElementId^ GetId()

Return Value

The element id.

See Also

ElementRecord Class


GetOwnerViewId Method

[image]

Revit 2011 API
ElementRecord..::.GetOwnerViewId Method
ElementRecord Class See Also Send Feedback
Gets the element id of the owner view record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetOwnerViewId()
Visual Basic (Declaration)
Public Function GetOwnerViewId As ElementId
Visual C++
public:
ElementId^ GetOwnerViewId()

Return Value

The view record element id.

See Also

ElementRecord Class


HasBoundingBox Method

[image]

Revit 2011 API
ElementRecord..::.HasBoundingBox Method
ElementRecord Class See Also Send Feedback
Determines whether this element record has a bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasBoundingBox()
Visual Basic (Declaration)
Public Function HasBoundingBox As Boolean
Visual C++
public:
bool HasBoundingBox()

Return Value

True if the element record has a bounding box or false otherwise.

See Also

ElementRecord Class


IsAnElementType Method

[image]

Revit 2011 API
ElementRecord..::.IsAnElementType Method
ElementRecord Class See Also Send Feedback
Identifies if the element record represents an ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAnElementType()
Visual Basic (Declaration)
Public Function IsAnElementType As Boolean
Visual C++
public:
bool IsAnElementType()

Return Value

True if the element record represents an ElementType.

See Also

ElementRecord Class


IsCurveDriven Method

[image]

Revit 2011 API
ElementRecord..::.IsCurveDriven Method
ElementRecord Class See Also Send Feedback
Identifies if the element is curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsCurveDriven()
Visual Basic (Declaration)
Public Function IsCurveDriven As Boolean
Visual C++
public:
bool IsCurveDriven()

Return Value

True if the element is curve driven.

See Also

ElementRecord Class


ElementReferenceType Enumeration

[image]

Revit 2011 API
ElementReferenceType Enumeration
See Also Send Feedback
Element reference types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ElementReferenceType
Visual Basic (Declaration)
Public Enumeration ElementReferenceType
Visual C++
public enum class ElementReferenceType

Members

Member name | Description
REFERENCE_TYPE_NONE |
REFERENCE_TYPE_LINEAR | The reference is to a curve of edge.
REFERENCE_TYPE_SURFACE | The reference is to a face or face region.
REFERENCE_TYPE_FOREIGN | The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_INSTANCE | The reference is an instance of a symbol.
REFERENCE_TYPE_CUT_EDGE | The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_MESH | The reference is to a mesh.

See Also


ElementSet Class

[image]

Revit 2011 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ElementSet elems = uidoc.Selection.Elements;

string info = "Selected elements:\n";
foreach (Autodesk.Revit.DB.Element elem in elems)
{
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
CopyVB.NET
Dim elems As ElementSet = uidoc.Selection.Elements

Dim info As String = "Selected elements:" & vbLf
For Each elem As Autodesk.Revit.DB.Element In elems
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ElementSet
Autodesk.Revit.UI.Selection..::.SelElementSet

See Also

ElementSet Members


ElementSet Members

[image] [image]

Revit 2011 API
ElementSet Members
ElementSet Class Constructors Methods Properties See Also Send Feedback

The ElementSet type exposes the following members.

Constructors

Name | Description
ElementSet | Initializes a new instance of the ElementSet class

Methods

Name | Description
Clear | Removes every item element the set, rendering it empty.
Contains | Tests for the existence of an element within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set.

See Also

ElementSet Class


ElementSet Constructor

[image]

Revit 2011 API
ElementSet Constructor
ElementSet Class See Also Send Feedback
Initializes a new instance of the ElementSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSet()

See Also

ElementSet Class


ElementSet Methods

[image] [image]

Revit 2011 API
ElementSet Methods
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item element the set, rendering it empty.
Contains | Tests for the existence of an element within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified element from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSet Class


Clear Method

[image]

Revit 2011 API
ElementSet..::.Clear Method
ElementSet Class See Also Send Feedback
Removes every item element the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementSet Class


Contains Method

[image]

Revit 2011 API
ElementSet..::.Contains Method
ElementSet Class See Also Send Feedback
Tests for the existence of an element within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Element
The element to be searched for.

Return Value

The Contains method returns True if the element is within the set, otherwise False.

See Also

ElementSet Class


Erase Method

[image]

Revit 2011 API
ElementSet..::.Erase Method
ElementSet Class See Also Send Feedback
Removes a specified element from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Element
The element to be erased.

Return Value

The number of elements that were erased from the set.

See Also

ElementSet Class


ForwardIterator Method

[image]

Revit 2011 API
ElementSet..::.ForwardIterator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElementSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class


GetEnumerator Method

[image]

Revit 2011 API
ElementSet..::.GetEnumerator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementSet Class


Insert Method

[image]

Revit 2011 API
ElementSet..::.Insert Method
ElementSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Element item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Element
The element to be inserted into the set.

Return Value

Returns whether the element was inserted into the set.

See Also

ElementSet Class


ReverseIterator Method

[image]

Revit 2011 API
ElementSet..::.ReverseIterator Method
ElementSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElementSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementSet Class


ElementSet Properties

[image] [image]

Revit 2011 API
ElementSet Properties
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set.

See Also

ElementSet Class


IsEmpty Property

[image]

Revit 2011 API
ElementSet..::.IsEmpty Property
ElementSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementSet Class


Size Property

[image]

Revit 2011 API
ElementSet..::.Size Property
ElementSet Class See Also Send Feedback
Returns the number of elements that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementSet Class


ElementSetIterator Class

[image]

Revit 2011 API
ElementSetIterator Class
Members See Also Send Feedback
An iterator to an element set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ElementSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElementSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ElementSetIterator

See Also

ElementSetIterator Members


ElementSetIterator Members

[image] [image]

Revit 2011 API
ElementSetIterator Members
ElementSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElementSetIterator type exposes the following members.

Constructors

Name | Description
ElementSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class


ElementSetIterator Constructor

[image]

Revit 2011 API
ElementSetIterator Constructor
ElementSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementSetIterator Class


ElementSetIterator Methods

[image] [image]

Revit 2011 API
ElementSetIterator Methods
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ElementSetIterator..::.MoveNext Method
ElementSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementSetIterator Class


Reset Method

[image]

Revit 2011 API
ElementSetIterator..::.Reset Method
ElementSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementSetIterator Class


ElementSetIterator Properties

[image] [image]

Revit 2011 API
ElementSetIterator Properties
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class


Current Property

[image]

Revit 2011 API
ElementSetIterator..::.Current Property
ElementSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementSetIterator Class


ElementSlowFilter Class

[image]

Revit 2011 API
ElementSlowFilter Class
Members See Also Send Feedback
A base class for a type of filter that operates on expanded elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementSlowFilter : ElementFilter
Visual Basic (Declaration)
Public Class ElementSlowFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementSlowFilter : public ElementFilter

Remarks

Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Architecture..::.RoomFilter
Autodesk.Revit.DB.Architecture..::.RoomTagFilter
Autodesk.Revit.DB..::.AreaFilter
Autodesk.Revit.DB..::.AreaTagFilter
Autodesk.Revit.DB..::.CurveElementFilter
Autodesk.Revit.DB..::.ElementLevelFilter
Autodesk.Revit.DB..::.ElementParameterFilter
Autodesk.Revit.DB..::.FamilyInstanceFilter
Autodesk.Revit.DB.Mechanical..::.SpaceFilter
Autodesk.Revit.DB.Mechanical..::.SpaceTagFilter
Autodesk.Revit.DB..::.PrimaryDesignOptionMemberFilter
Autodesk.Revit.DB.Structure..::.FamilyStructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::.StructuralInstanceUsageFilter
Autodesk.Revit.DB.Structure..::.StructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::.StructuralWallUsageFilter

See Also

ElementSlowFilter Members


ElementSlowFilter Members

[image] [image]

Revit 2011 API
ElementSlowFilter Members
ElementSlowFilter Class Methods Properties See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class


ElementSlowFilter Methods

[image] [image]

Revit 2011 API
ElementSlowFilter Methods
ElementSlowFilter Class See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSlowFilter Class


ElementSlowFilter Properties

[image] [image]

Revit 2011 API
ElementSlowFilter Properties
ElementSlowFilter Class See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class


ElementStructuralTypeFilter Class

[image]

Revit 2011 API
ElementStructuralTypeFilter Class
Members See Also Send Feedback
A filter used to find elements matching a structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElementStructuralTypeFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ElementStructuralTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementStructuralTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ElementStructuralTypeFilter

See Also

ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Members

[image] [image]

Revit 2011 API
ElementStructuralTypeFilter Members
ElementStructuralTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Constructors

Name | Description
ElementStructuralTypeFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter Constructor

[image] [image]

Revit 2011 API
ElementStructuralTypeFilter Constructor
ElementStructuralTypeFilter Class See Also Send Feedback

Overload List

Name | Description
ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Constructor (StructuralType)

[image]

Revit 2011 API
ElementStructuralTypeFilter Constructor (StructuralType)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralType As StructuralType _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
The structural type to match.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Constructor (StructuralType, Boolean)

[image]

Revit 2011 API
ElementStructuralTypeFilter Constructor (StructuralType, Boolean)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralType As StructuralType, _
    inverted As Boolean _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::.StructuralType
The structural type to match.
inverted
Type: System..::.Boolean
True if the filter should match all elements which are not of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Methods

[image] [image]

Revit 2011 API
ElementStructuralTypeFilter Methods
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter Properties

[image] [image]

Revit 2011 API
ElementStructuralTypeFilter Properties
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


StructuralType Property

[image]

Revit 2011 API
ElementStructuralTypeFilter..::.StructuralType Property
ElementStructuralTypeFilter Class See Also Send Feedback
The structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

See Also

ElementStructuralTypeFilter Class


ElementType Class

[image]

Revit 2011 API
ElementType Class
Members See Also Send Feedback
Base class for all Types within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElementType : Element
Visual Basic (Declaration)
Public Class ElementType _
    Inherits Element
Visual C++
public ref class ElementType : public Element

Remarks

Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Analysis..::.ConceptualConstructionType
Autodesk.Revit.DB..::.BeamSystemType
Autodesk.Revit.DB..::.DimensionType
Autodesk.Revit.DB.Electrical..::.DistributionSysType
Autodesk.Revit.DB.Electrical..::.InsulationType
Autodesk.Revit.DB.Electrical..::.TemperatureRatingType
Autodesk.Revit.DB.Electrical..::.VoltageType
Autodesk.Revit.DB.Electrical..::.WireMaterialType
Autodesk.Revit.DB.Electrical..::.WireType
Autodesk.Revit.DB..::.GroupType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB..::.ModelTextType
Autodesk.Revit.DB.Plumbing..::.FluidType
Autodesk.Revit.DB.Plumbing..::.PipeConnectionType
Autodesk.Revit.DB.Plumbing..::.PipeMaterialType
Autodesk.Revit.DB.Plumbing..::.PipeScheduleType
Autodesk.Revit.DB..::.SiteLocation
Autodesk.Revit.DB.Structure..::.AreaReinforcementType
Autodesk.Revit.DB.Structure..::.LoadTypeBase
Autodesk.Revit.DB.Structure..::.PathReinforcementType
Autodesk.Revit.DB.Structure..::.RebarBarType
Autodesk.Revit.DB.Structure..::.RebarCoverType
Autodesk.Revit.DB.Structure..::.RebarHookType
Autodesk.Revit.DB.Structure..::.RebarShape
Autodesk.Revit.DB.Structure..::.StructuralConnectionType
Autodesk.Revit.DB..::.TilePattern

See Also

ElementType Members


ElementType Members

[image] [image]

Revit 2011 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
GetSimilarTypes | Obtains a set of types that are similar to this type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElementType Class


ElementType Methods

[image] [image]

Revit 2011 API
ElementType Methods
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
GetSimilarTypes | Obtains a set of types that are similar to this type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementType Class


Duplicate Method

[image]

Revit 2011 API
ElementType..::.Duplicate Method
ElementType Class See Also Send Feedback
Duplicate this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementType Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As ElementType
Visual C++
public:
ElementType^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::.String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not unique, a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a ApplicationException will be thrown.

See Also

ElementType Class


GetPreviewImage Method

[image]

Revit 2011 API
ElementType..::.GetPreviewImage Method
ElementType Class See Also Send Feedback
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual Bitmap GetPreviewImage(
    Size size
)
Visual Basic (Declaration)
Public Overridable Function GetPreviewImage ( _
    size As Size _
) As Bitmap
Visual C++
public:
virtual Bitmap^ GetPreviewImage(
    Size size
)

Parameters

size
Type: System.Drawing..::.Size
The width and height of the preview image in pixels.

Return Value

System::Drawing::Bitmap represents the preview image. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no preview image.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The width or height of the size is equal or less than zero.

See Also

ElementType Class


GetSimilarTypes Method

[image]

Revit 2011 API
ElementType..::.GetSimilarTypes Method
ElementType Class See Also Send Feedback
Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetSimilarTypes()
Visual Basic (Declaration)
Public Function GetSimilarTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSimilarTypes()

Return Value

A set of element IDs of types that are similar to this type.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

See Also

ElementType Class


IsSimilarType Method

[image]

Revit 2011 API
ElementType..::.IsSimilarType Method
ElementType Class See Also Send Feedback
Checks if given type is similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSimilarType(
    ElementId typeId
)
Visual Basic (Declaration)
Public Function IsSimilarType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsSimilarType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of the type to check.

Return Value

True if given type is similar to this type, false otherwise.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElementType Class


ElementType Properties

[image] [image]

Revit 2011 API
ElementType Properties
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElementType Class


Name Property

[image]

Revit 2011 API
ElementType..::.Name Property
ElementType Class See Also Send Feedback
Set the name for the ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This method will assign the element type a new name.

See Also

ElementType Class


Parameter Property

[image] [image]

Revit 2011 API
ElementType..::.Parameter Property
ElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElementType Class
ElementType Members


Ellipse Class

[image]

Revit 2011 API
Ellipse Class
Members See Also Send Feedback
A whole or partial ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Ellipse : Curve
Visual Basic (Declaration)
Public Class Ellipse _
    Inherits Curve
Visual C++
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Ellipse

See Also

Ellipse Members


Ellipse Members

[image] [image]

Revit 2011 API
Ellipse Members
Ellipse Class Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the ellipse.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the ellipse is defined.
Period | The period of this curve. (Inherited from Curve.)
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Ellipse Class


Ellipse Methods

[image] [image]

Revit 2011 API
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ellipse Class


Intersect Method

[image] [image]

Revit 2011 API
Ellipse..::.Intersect Method
Ellipse Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members


IsInside Method

[image] [image]

Revit 2011 API
Ellipse..::.IsInside Method
Ellipse Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members


Ellipse Properties

[image] [image]

Revit 2011 API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Center | Returns the center of the ellipse.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Normal | Returns the normal to the plane in which the ellipse is defined.
Period | The period of this curve. (Inherited from Curve.)
RadiusX | Returns the X vector radius of the ellipse.
RadiusY | Returns the Y vector radius of the ellipse.
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Ellipse Class


Center Property

[image]

Revit 2011 API
Ellipse..::.Center Property
Ellipse Class See Also Send Feedback
Returns the center of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic (Declaration)
Public ReadOnly Property Center As XYZ
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Ellipse Class


Normal Property

[image]

Revit 2011 API
Ellipse..::.Normal Property
Ellipse Class See Also Send Feedback
Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Ellipse Class


RadiusX Property

[image]

Revit 2011 API
Ellipse..::.RadiusX Property
Ellipse Class See Also Send Feedback
Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double RadiusX { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadiusX As Double
Visual C++
public:
property double RadiusX {
    double get ();
}

See Also

Ellipse Class


RadiusY Property

[image]

Revit 2011 API
Ellipse..::.RadiusY Property
Ellipse Class See Also Send Feedback
Returns the Y vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double RadiusY { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadiusY As Double
Visual C++
public:
property double RadiusY {
    double get ();
}

See Also

Ellipse Class


Enclosure Class

[image]

Revit 2011 API
Enclosure Class
Members See Also Send Feedback
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Enclosure : Element
Visual Basic (Declaration)
Public Class Enclosure _
    Inherits Element
Visual C++
public ref class Enclosure : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB.Architecture..::.Room
Autodesk.Revit.DB..::.Area
Autodesk.Revit.DB.Mechanical..::.Space

See Also

Enclosure Members


Enclosure Members

[image] [image]

Revit 2011 API
Enclosure Members
Enclosure Class Methods Properties See Also Send Feedback

The Enclosure type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the element. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Overrides Element..::.Name.)
Number | The number.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Enclosure Class


Enclosure Methods

[image] [image]

Revit 2011 API
Enclosure Methods
Enclosure Class See Also Send Feedback

The Enclosure type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Enclosure Class


Enclosure Properties

[image] [image]

Revit 2011 API
Enclosure Properties
Enclosure Class See Also Send Feedback

The Enclosure type exposes the following members.

Properties

Name | Description
Area | The area.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the element. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Overrides Element..::.Name.)
Number | The number.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Enclosure Class


Area Property

[image]

Revit 2011 API
Enclosure..::.Area Property
Enclosure Class See Also Send Feedback
The area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

See Also

Enclosure Class


Location Property

[image]

Revit 2011 API
Enclosure..::.Location Property
Enclosure Class See Also Send Feedback
The location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

See Also

Enclosure Class


Name Property

[image]

Revit 2011 API
Enclosure..::.Name Property
Enclosure Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

Enclosure Class


Number Property

[image]

Revit 2011 API
Enclosure..::.Number Property
Enclosure Class See Also Send Feedback
The number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

Enclosure Class


Parameter Property

[image] [image]

Revit 2011 API
Enclosure..::.Parameter Property
Enclosure Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Enclosure Class
Enclosure Members


Perimeter Property

[image]

Revit 2011 API
Enclosure..::.Perimeter Property
Enclosure Class See Also Send Feedback
The perimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

See Also

Enclosure Class


EnclosureTag Class

[image]

Revit 2011 API
EnclosureTag Class
Members See Also Send Feedback
A tag attached to an Enclosure (room, space or area) in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class EnclosureTag : Element
Visual Basic (Declaration)
Public Class EnclosureTag _
    Inherits Element
Visual C++
public ref class EnclosureTag : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB.Architecture..::.RoomTag
Autodesk.Revit.DB..::.AreaTag
Autodesk.Revit.DB.Mechanical..::.SpaceTag

See Also

EnclosureTag Members


EnclosureTag Members

[image] [image]

Revit 2011 API
EnclosureTag Members
EnclosureTag Class Methods Properties See Also Send Feedback

The EnclosureTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

EnclosureTag Class


EnclosureTag Methods

[image] [image]

Revit 2011 API
EnclosureTag Methods
EnclosureTag Class See Also Send Feedback

The EnclosureTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnclosureTag Class


EnclosureTag Properties

[image] [image]

Revit 2011 API
EnclosureTag Properties
EnclosureTag Class See Also Send Feedback

The EnclosureTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

EnclosureTag Class


HasLeader Property

[image]

Revit 2011 API
EnclosureTag..::.HasLeader Property
EnclosureTag Class See Also Send Feedback
Identifies if a leader is displayed for the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasLeader { get; set; }
Visual Basic (Declaration)
Public Property HasLeader As Boolean
Visual C++
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}

Field Value

True if a leader is displayed, otherwise false.

See Also

EnclosureTag Class


Location Property

[image]

Revit 2011 API
EnclosureTag..::.Location Property
EnclosureTag Class See Also Send Feedback
The location of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

Allows you to get and set the location of the tag within the level. The Z location should be the elevation of the level and is not changeable.

See Also

EnclosureTag Class


Name Property

[image]

Revit 2011 API
EnclosureTag..::.Name Property
EnclosureTag Class See Also Send Feedback
The name associated with the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the tag's name (because this is not permitted to be modified in the Autodesk Revit UI).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to set this property, as the name of the tag may not be changed.

See Also

EnclosureTag Class


Parameter Property

[image] [image]

Revit 2011 API
EnclosureTag..::.Parameter Property
EnclosureTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

EnclosureTag Class
EnclosureTag Members


View Property

[image]

Revit 2011 API
EnclosureTag..::.View Property
EnclosureTag Class See Also Send Feedback
The view in which the tag was placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

EnclosureTag Class


ExclusionFilter Class

[image]

Revit 2011 API
ExclusionFilter Class
Members Example See Also Send Feedback
A filter used to exclude a set of elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ExclusionFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class ExclusionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ExclusionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use Exclusion filter to find exclude a set of elements in the document automatically

// Find all walls that are not currently selected,
// Get all element ids which are current selected by users, exclude these ids when filtering
ICollection<ElementId> excludes = new List<ElementId>();
ElementSetIterator elemIter = uiDocument.Selection.Elements.ForwardIterator();
elemIter.Reset();
while (elemIter.MoveNext())
{
    Element curElem = elemIter.Current as Element;
    excludes.Add(curElem.Id);
}

// Create filter to exclude all selected element ids
ExclusionFilter filter = new ExclusionFilter(excludes);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
IList<Element> walls = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Use Exclusion filter to find exclude a set of elements in the document automatically

' Find all walls that are not currently selected,
' Get all element ids which are current selected by users, exclude these ids when filtering
Dim excludes As ICollection(Of ElementId) = New List(Of ElementId)()
Dim elemIter As ElementSetIterator = uiDocument.Selection.Elements.ForwardIterator()
elemIter.Reset()
While elemIter.MoveNext()
    Dim curElem As Autodesk.Revit.DB.Element = TryCast(elemIter.Current, Autodesk.Revit.DB.Element)
    excludes.Add(curElem.Id)
End While

' Create filter to exclude all selected element ids
Dim filter As New ExclusionFilter(excludes)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find Walls only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(uiDocument.Document)
Dim walls As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.ExclusionFilter

See Also

ExclusionFilter Members


ExclusionFilter Members

[image] [image]

Revit 2011 API
ExclusionFilter Members
ExclusionFilter Class Constructors Methods Properties See Also Send Feedback

The ExclusionFilter type exposes the following members.

Constructors

Name | Description
ExclusionFilter | Constructs a new instance of a filter to exclude elements automatically.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIdsToExclude | Returns the ids to be excluded by this filter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExclusionFilter Constructor

[image]

Revit 2011 API
ExclusionFilter Constructor
ExclusionFilter Class See Also Send Feedback
Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ExclusionFilter(
    ICollection<ElementId> idsToExclude
)
Visual Basic (Declaration)
Public Sub New ( _
    idsToExclude As ICollection(Of ElementId) _
)
Visual C++
public:
ExclusionFilter(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The ids to exclude from the results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ExclusionFilter Class


ExclusionFilter Methods

[image] [image]

Revit 2011 API
ExclusionFilter Methods
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIdsToExclude | Returns the ids to be excluded by this filter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExclusionFilter Class


GetIdsToExclude Method

[image]

Revit 2011 API
ExclusionFilter..::.GetIdsToExclude Method
ExclusionFilter Class See Also Send Feedback
Returns the ids to be excluded by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetIdsToExclude()
Visual Basic (Declaration)
Public Function GetIdsToExclude As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetIdsToExclude()

Return Value

The collection of ids to exclude.

See Also

ExclusionFilter Class


ExclusionFilter Properties

[image] [image]

Revit 2011 API
ExclusionFilter Properties
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExportColorMode Enumeration

[image]

Revit 2011 API
ExportColorMode Enumeration
See Also Send Feedback
An enumerated type listing export color mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ExportColorMode
Visual Basic (Declaration)
Public Enumeration ExportColorMode
Visual C++
public enum class ExportColorMode

Members

Member name | Description
IndexColors | All colors from the Revit project will be set to the closest of the 255 AutoCAD Color Index colors.
TrueColor | All colors from the Revit project will be exported as 24-bit RGB values.

See Also


ExportPaperFormat Enumeration

[image]

Revit 2011 API
ExportPaperFormat Enumeration
See Also Send Feedback
Paper formats supported by DWF export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ExportPaperFormat
Visual Basic (Declaration)
Public Enumeration ExportPaperFormat
Visual C++
public enum class ExportPaperFormat

Members

Member name | Description
Default | Default paper format.
ANSI_A | ANSI A, 8.5 x 11 in
ANSI_B | ANSI B, 11 x 17 in
ANSI_C | ANSI C, 17 x 22 in
ANSI_D | ANSI D, 22 x 34 in
ANSI_E | ANSI E, 34 x 44 in
ISO_A4 | ISO A4, 210 x 297 mm
ISO_A3 | ISO A3, 297 x 420 mm
ISO_A2 | ISO A2, 420 x 594 mm
ISO_A1 | ISO A1, 594 x 841 mm
ISO_A0 | ISO A0, 841 x 1189 mm
ISO_B4 | ISO B4, 250 x 353 mm
ISO_B3 | ISO B3, 353 x 500 mm
ISO_B2 | ISO B2, 500 x 707 mm
ISO_B1 | ISO B1, 707 x 1000 mm
ARCH_A | ARCH A, 9 x 12 in
ARCH_B | ARCH B, 12 x 18 in
ARCH_C | ARCH C, 18 x 24 in
ARCH_D | ARCH D, 24 x 36 in
ARCH_E | ARCH E, 36 x 48 in
ARCH_E1 | ARCH E1, 30 x 42 in
ARCH_E2 | ARCH E2, 26 x 38 in
ARCH_E3 | ARCH E3, 27 x 39 in

See Also


ExportRange Enumeration

[image]

Revit 2011 API
ExportRange Enumeration
See Also Send Feedback
This enum is used to define what view, part of the view, or list of views will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ExportRange
Visual Basic (Declaration)
Public Enumeration ExportRange
Visual C++
public enum class ExportRange

Members

Member name | Description
CurrentView | Export the current view only (zoom to fit of the current view).
VisibleRegionOfCurrentView | Export the visible region of the current view.
SetOfViews | Export a set of views (set in ViewsAndSheets).

See Also


ExportUnit Enumeration

[image]

Revit 2011 API
ExportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ExportUnit
Visual Basic (Declaration)
Public Enumeration ExportUnit
Visual C++
public enum class ExportUnit

Members

Member name | Description
Default | Default export unit. Depends on Revit's current units.
Inch | Inches in fractional notation.
Foot | Feet and Inches in fractional notation.
Millimeter | Millimeters as decimal values.
Centimeter | Centimeters as decimal values.
Meter | Meters as decimal values.

See Also


ExportUtils Class

[image]

Revit 2011 API
ExportUtils Class
Members See Also Send Feedback
This class provides utilities related to document export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ExportUtils : IDisposable
Visual Basic (Declaration)
Public Class ExportUtils _
    Implements IDisposable
Visual C++
public ref class ExportUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ExportUtils

See Also

ExportUtils Members


ExportUtils Members

[image] [image]

Revit 2011 API
ExportUtils Members
ExportUtils Class Methods See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetExportId | Retrieves the GUID representing this element in DWF and IFC export.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportUtils Class


ExportUtils Methods

[image] [image]

Revit 2011 API
ExportUtils Methods
ExportUtils Class See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetExportId | Retrieves the GUID representing this element in DWF and IFC export.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportUtils Class


Dispose Method

[image]

Revit 2011 API
ExportUtils..::.Dispose Method
ExportUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ExportUtils Class


GetExportId Method

[image]

Revit 2011 API
ExportUtils..::.GetExportId Method
ExportUtils Class See Also Send Feedback
Retrieves the GUID representing this element in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static Guid GetExportId(
    Document document,
    ElementId elementId
)
Visual Basic (Declaration)
Public Shared Function GetExportId ( _
    document As Document, _
    elementId As ElementId _
) As Guid
Visual C++
public:
static Guid GetExportId(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document to get the element GUID from
elementId
Type: Autodesk.Revit.DB..::.ElementId
The id of element whose GUID to be retrieved

Return Value

GUID value of the element

Remarks

This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element elementId does not exist in the document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ExportUtils Class


ExternalDefinition Class

[image]

Revit 2011 API
ExternalDefinition Class
Members Example See Also Send Feedback
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExternalDefinition : Definition
Visual Basic (Declaration)
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Examples

CopyC#
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (null == myGroup)
        return;

    Definitions myDefinitions = myGroup.Definitions;
    ExternalDefinition myExtDef =
        myDefinitions.get_Item("MyParam") as ExternalDefinition;
    if (null == myExtDef)
        return;

    StringBuilder strBuilder = new StringBuilder();
    // iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString())
        .AppendLine("Name: " + myExtDef.Name)
        .AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name)
        .AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString())
        .AppendLine("Parameter Type" + myExtDef.ParameterType.ToString())
        .AppendLine("Is Visible: " + myExtDef.Visible.ToString());

    TaskDialog.Show("Revit",strBuilder.ToString());

    // change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.get_Item("AnotherGroup");
}
CopyVB.NET
Private Sub ReadEditExternalParam(ByVal file As DefinitionFile)
    ' get ExternalDefinition from shared parameter file
    Dim myGroups As DefinitionGroups = file.Groups
    Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
    If myGroup Is Nothing Then
        Return
    End If

    Dim myDefinitions As Definitions = myGroup.Definitions
    Dim myExtDef As ExternalDefinition = TryCast(myDefinitions.Item("MyParam"), ExternalDefinition)
    If myExtDef Is Nothing Then
        Return
    End If

    Dim strBuilder As New StringBuilder()
    ' iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString()).AppendLine("Name: " + myExtDef.Name).AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name).AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString()).AppendLine("Parameter Type" + myExtDef.ParameterType.ToString()).AppendLine("Is Visible: " + myExtDef.Visible.ToString())

    TaskDialog.Show("Revit", strBuilder.ToString())

    ' change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.Item("AnotherGroup")
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Definition
Autodesk.Revit.DB..::.ExternalDefinition

See Also

ExternalDefinition Members


ExternalDefinition Members

[image] [image]

Revit 2011 API
ExternalDefinition Members
ExternalDefinition Class Methods Properties See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition Class


ExternalDefinition Methods

[image] [image]

Revit 2011 API
ExternalDefinition Methods
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinition Class


ExternalDefinition Properties

[image] [image]

Revit 2011 API
ExternalDefinition Properties
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Properties

Name | Description
GUID | Returns the GUID associated with the shared parameter definition.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user visible name for the parameter. (Overrides Definition..::.Name.)
OwnerGroup | Returns or change the group ID of the external parameter definition.
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)
Visible | Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

See Also

ExternalDefinition Class


GUID Property

[image]

Revit 2011 API
ExternalDefinition..::.GUID Property
ExternalDefinition Class See Also Send Feedback
Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property GUID As Guid
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class


Name Property

[image]

Revit 2011 API
ExternalDefinition..::.Name Property
ExternalDefinition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ExternalDefinition Class


OwnerGroup Property

[image]

Revit 2011 API
ExternalDefinition..::.OwnerGroup Property
ExternalDefinition Class See Also Send Feedback
Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DefinitionGroup OwnerGroup { get; set; }
Visual Basic (Declaration)
Public Overridable Property OwnerGroup As DefinitionGroup
Visual C++
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}

Remarks

If failed When set the group, an InvalidOperationException will be thrown.

See Also

ExternalDefinition Class


ParameterGroup Property

[image]

Revit 2011 API
ExternalDefinition..::.ParameterGroup Property
ExternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

ExternalDefinition Class


ParameterType Property

[image]

Revit 2011 API
ExternalDefinition..::.ParameterType Property
ExternalDefinition Class See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

ExternalDefinition Class


Visible Property

[image]

Revit 2011 API
ExternalDefinition..::.Visible Property
ExternalDefinition Class See Also Send Feedback
Tells the developer is the parameter should be visible within the user interface of their application or Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Visible { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class


ExternalDefinitions Class

[image]

Revit 2011 API
ExternalDefinitions Class
Members See Also Send Feedback
Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExternalDefinitions : Definitions
Visual Basic (Declaration)
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.Definitions
Autodesk.Revit.DB..::.ExternalDefinitions

See Also

ExternalDefinitions Members


ExternalDefinitions Members

[image] [image]

Revit 2011 API
ExternalDefinitions Members
ExternalDefinitions Class Methods Properties See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions Class


ExternalDefinitions Methods

[image] [image]

Revit 2011 API
ExternalDefinitions Methods
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinitions Class


Create Method

[image] [image]

Revit 2011 API
ExternalDefinitions..::.Create Method
ExternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type. (Inherited from Definitions.)

See Also

ExternalDefinitions Class
ExternalDefinitions Members


ExternalDefinitions Properties

[image] [image]

Revit 2011 API
ExternalDefinitions Properties
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

ExternalDefinitions Class


Extrusion Class

[image]

Revit 2011 API
Extrusion Class
Members See Also Send Feedback
A extrusion solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Extrusion : GenericForm
Visual Basic (Declaration)
Public Class Extrusion _
    Inherits GenericForm
Visual C++
public ref class Extrusion : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Extrusion

See Also

Extrusion Members


Extrusion Members

[image] [image]

Revit 2011 API
Extrusion Members
Extrusion Class Methods Properties See Also Send Feedback

The Extrusion type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Extrusion.
StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion Class


Extrusion Methods

[image] [image]

Revit 2011 API
Extrusion Methods
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Extrusion Class


Extrusion Properties

[image] [image]

Revit 2011 API
Extrusion Properties
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Extrusion.
StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Extrusion Class


EndOffset Property

[image]

Revit 2011 API
Extrusion..::.EndOffset Property
Extrusion Class See Also Send Feedback
The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EndOffset { get; set; }
Visual Basic (Declaration)
Public Property EndOffset As Double
Visual C++
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class


Parameter Property

[image] [image]

Revit 2011 API
Extrusion..::.Parameter Property
Extrusion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Extrusion Class
Extrusion Members


Sketch Property

[image]

Revit 2011 API
Extrusion..::.Sketch Property
Extrusion Class See Also Send Feedback
Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketches of the Extrusion.

See Also

Extrusion Class


StartOffset Property

[image]

Revit 2011 API
Extrusion..::.StartOffset Property
Extrusion Class See Also Send Feedback
The offset of the start of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StartOffset { get; set; }
Visual Basic (Declaration)
Public Property StartOffset As Double
Visual C++
public:
property double StartOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class


ExtrusionRoof Class

[image]

Revit 2011 API
ExtrusionRoof Class
Members See Also Send Feedback
Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExtrusionRoof : RoofBase
Visual Basic (Declaration)
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extruded roofs in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.ExtrusionRoof

See Also

ExtrusionRoof Members


ExtrusionRoof Members

[image] [image]

Revit 2011 API
ExtrusionRoof Members
ExtrusionRoof Class Methods Properties See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetProfile | Retrieve the Profile of ExtrusionRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ExtrusionRoof Class


ExtrusionRoof Methods

[image] [image]

Revit 2011 API
ExtrusionRoof Methods
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetProfile | Retrieve the Profile of ExtrusionRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtrusionRoof Class


GetProfile Method

[image]

Revit 2011 API
ExtrusionRoof..::.GetProfile Method
ExtrusionRoof Class See Also Send Feedback
Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray GetProfile()
Visual Basic (Declaration)
Public Function GetProfile As ModelCurveArray
Visual C++
public:
ModelCurveArray^ GetProfile()

See Also

ExtrusionRoof Class


ExtrusionRoof Properties

[image] [image]

Revit 2011 API
ExtrusionRoof Properties
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ExtrusionRoof Class


CurtainGrids Property

[image]

Revit 2011 API
ExtrusionRoof..::.CurtainGrids Property
ExtrusionRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a CurtainRoof, this property makes sense.

See Also

ExtrusionRoof Class


Parameter Property

[image] [image]

Revit 2011 API
ExtrusionRoof..::.Parameter Property
ExtrusionRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ExtrusionRoof Class
ExtrusionRoof Members


Face Class

[image]

Revit 2011 API
Face Class
Members See Also Send Feedback
A face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Face : GeometryObject
Visual Basic (Declaration)
Public Class Face _
    Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.ConicalFace
Autodesk.Revit.DB..::.CylindricalFace
Autodesk.Revit.DB..::.HermiteFace
Autodesk.Revit.DB..::.PlanarFace
Autodesk.Revit.DB..::.RevolvedFace
Autodesk.Revit.DB..::.RuledFace

See Also

Face Members


Face Members

[image] [image]

Revit 2011 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
ComputeNormal | Returns the normal vector for the face at the given point.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face.
GetBoundingBox | Returns the UV bounding box of the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed.
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class


Face Methods

[image] [image]

Revit 2011 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters.
ComputeNormal | Returns the normal vector for the face at the given point.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face.
GetBoundingBox | Returns the UV bounding box of the face.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face.

See Also

Face Class


ComputeDerivatives Method

[image]

Revit 2011 API
Face..::.ComputeDerivatives Method
Face Class See Also Send Feedback
Returns the moving frame around the face at the specified parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic (Declaration)
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The transformation that represents the moving frame.

Remarks

The following is the meaning of the transformation members: Origin is the point on the face; (equivalent to Evaluate);BasisX is the tangent vector along the U coordinate; (partial derivative with respect to U).BasisY is the tangent vector along the V coordinate; (partial derivative with respect to V).BasisZ is the "surface normal" vector. This is not necessarily the normal vector pointing out of the solid that contains the face, to get that value use ComputeNormal(UV). None of the vectors are normalized.

See Also

Face Class


ComputeNormal Method

[image]

Revit 2011 API
Face..::.ComputeNormal Method
Face Class See Also Send Feedback
Returns the normal vector for the face at the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ ComputeNormal(
    UV point
)
Visual Basic (Declaration)
Public Function ComputeNormal ( _
    point As UV _
) As XYZ
Visual C++
public:
XYZ^ ComputeNormal(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The normal vector. This vector will be normalized.

Remarks

Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of the solid that contains the face.

See Also

Face Class


Evaluate Method

[image]

Revit 2011 API
Face..::.Evaluate Method
Face Class See Also Send Feedback
Evaluates parameters on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Evaluate(
    UV params
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    params As UV _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    UV^ params
)

Parameters

params
Type: Autodesk.Revit.DB..::.UV
The parameters to be evaluated, in natural parameterization of the face.

See Also

Face Class


GetBoundingBox Method

[image]

Revit 2011 API
Face..::.GetBoundingBox Method
Face Class See Also Send Feedback
Returns the UV bounding box of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV GetBoundingBox()
Visual Basic (Declaration)
Public Function GetBoundingBox As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetBoundingBox()

Return Value

A BoundingBoxUV with the extents of the parameterization of the face.

See Also

Face Class


Intersect Method

[image] [image]

Revit 2011 API
Face..::.Intersect Method
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.

See Also

Face Class
Face Members


Intersect Method (Curve)

[image]

Revit 2011 API
Face..::.Intersect Method (Curve)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2011 API
Face..::.Intersect Method (Curve, IntersectionResultArray%)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray results
)
Visual Basic (Declaration)
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% results
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The specified curve to intersect with this face.
results
Type: Autodesk.Revit.DB..::.IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
  • XYZPoint is the evaluated intersection point.
  • UVPoint is the intersection parameters on the face.
  • Parameter is the raw intersection parameter on the curve.
  • EdgeObject is the edge if the intersection happens to be near an edge of the face.
  • EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2011 API
Face..::.IsInside Method
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face.
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.

See Also

Face Class
Face Members


IsInside Method (UV)

[image]

Revit 2011 API
Face..::.IsInside Method (UV)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

True if point is within this face, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload


IsInside Method (UV, IntersectionResult)

[image]

Revit 2011 API
Face..::.IsInside Method (UV, IntersectionResult%)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face and outputs additional results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInside(
    UV point,
    out IntersectionResult result
)
Visual Basic (Declaration)
Public Function IsInside ( _
    point As UV, _
    <OutAttribute> ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point,
    [OutAttribute] IntersectionResult^% result
)

Parameters

point
Type: Autodesk.Revit.DB..::.UV
The parameters to be evaluated, in natural parameterization of the face.
result
Type: Autodesk.Revit.DB..::.IntersectionResult %
Provides more information when the point is on the edge; otherwise, nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if within this face, otherwise False.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload


Project Method

[image]

Revit 2011 API
Face..::.Project Method
Face Class See Also Send Feedback
Projects the specified point on this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic (Declaration)
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class


Triangulate Method

[image]

Revit 2011 API
Face..::.Triangulate Method
Face Class Example See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Mesh Triangulate()
Visual Basic (Declaration)
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

Examples

CopyC#
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
CopyVB.NET
Private Sub TriangulateFace(ByVal face As Autodesk.Revit.DB.Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    Dim i As Integer = 0
    While i < mesh.NumTriangles
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As Autodesk.Revit.DB.XYZ = triangle.Vertex(0)
        Dim vertex2 As Autodesk.Revit.DB.XYZ = triangle.Vertex(1)
        Dim vertex3 As Autodesk.Revit.DB.XYZ = triangle.Vertex(2)
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
End Sub

See Also

Face Class


Face Properties

[image] [image]

Revit 2011 API
Face Properties
Face Class See Also Send Feedback

The Face type exposes the following members.

Properties

Name | Description
Area | The area of this face.
EdgeLoops | Each edge loop is a closed boundary of the face.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate)
MaterialElement | Element describing the material from which this face is composed.
Period | The period of this face in the specified parametric direction.
Reference | Returns a stable reference to the face.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class


Area Property

[image]

Revit 2011 API
Face..::.Area Property
Face Class See Also Send Feedback
The area of this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

Returns zero if fails to compute the area. Estimates the area of this face by integrating tessellated edges. Will slightly underestimate when the edges are curved.

See Also

Face Class


EdgeLoops Property

[image]

Revit 2011 API
Face..::.EdgeLoops Property
Face Class See Also Send Feedback
Each edge loop is a closed boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArrayArray EdgeLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property EdgeLoops As EdgeArrayArray
Visual C++
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}

See Also

Face Class


IsCyclic Property

[image]

Revit 2011 API
Face..::.IsCyclic Property
Face Class See Also Send Feedback
The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCyclic[
    int paramIdx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Type: System..::.Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class


IsTwoSided Property

[image]

Revit 2011 API
Face..::.IsTwoSided Property
Face Class See Also Send Feedback
Determines if a face is two-sided (degenerate)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsTwoSided { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTwoSided As Boolean
Visual C++
public:
virtual property bool IsTwoSided {
    bool get ();
}

See Also

Face Class


MaterialElement Property

[image]

Revit 2011 API
Face..::.MaterialElement Property
Face Class See Also Send Feedback
Element describing the material from which this face is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material MaterialElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialElement As Material
Visual C++
public:
property Material^ MaterialElement {
    Material^ get ();
}

See Also

Face Class


Period Property

[image]

Revit 2011 API
Face..::.Period Property
Face Class See Also Send Feedback
The period of this face in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Period[
    int paramIdx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Type: System..::.Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

The real number equal to the period of this face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class


Reference Property

[image]

Revit 2011 API
Face..::.Reference Property
Face Class See Also Send Feedback
Returns a stable reference to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Face Class


FaceArray Class

[image]

Revit 2011 API
FaceArray Class
Members See Also Send Feedback
An array that contains faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FaceArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class FaceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FaceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FaceArray

See Also

FaceArray Members


FaceArray Members

[image] [image]

Revit 2011 API
FaceArray Members
FaceArray Class Constructors Methods Properties See Also Send Feedback

The FaceArray type exposes the following members.

Constructors

Name | Description
FaceArray | Initializes a new instance of the FaceArray class

Methods

Name | Description
Append | Add the face to the end of the array.
Clear | Removes every face from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified face into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a face at a specified index within the array.
Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


FaceArray Constructor

[image]

Revit 2011 API
FaceArray Constructor
FaceArray Class See Also Send Feedback
Initializes a new instance of the FaceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FaceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArray()

See Also

FaceArray Class


FaceArray Methods

[image] [image]

Revit 2011 API
FaceArray Methods
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Methods

Name | Description
Append | Add the face to the end of the array.
Clear | Removes every face from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified face into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArray Class


Append Method

[image]

Revit 2011 API
FaceArray..::.Append Method
FaceArray Class See Also Send Feedback
Add the face to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Face item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Face _
)
Visual C++
public:
virtual void Append(
    Face^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Face
The face to be added.

See Also

FaceArray Class


Clear Method

[image]

Revit 2011 API
FaceArray..::.Clear Method
FaceArray Class See Also Send Feedback
Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FaceArray Class


ForwardIterator Method

[image]

Revit 2011 API
FaceArray..::.ForwardIterator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FaceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class


GetEnumerator Method

[image]

Revit 2011 API
FaceArray..::.GetEnumerator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FaceArray Class


Insert Method

[image]

Revit 2011 API
FaceArray..::.Insert Method
FaceArray Class See Also Send Feedback
Insert the specified face into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Face^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Face
The face to be inserted into the array.
index
Type: System..::.Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class


ReverseIterator Method

[image]

Revit 2011 API
FaceArray..::.ReverseIterator Method
FaceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FaceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FaceArray Class


FaceArray Properties

[image] [image]

Revit 2011 API
FaceArray Properties
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a face at a specified index within the array.
Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


IsEmpty Property

[image]

Revit 2011 API
FaceArray..::.IsEmpty Property
FaceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FaceArray Class


Item Property

[image]

Revit 2011 API
FaceArray..::.Item Property
FaceArray Class See Also Send Feedback
Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Face Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Face
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Type: System..::.Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class


Size Property

[image]

Revit 2011 API
FaceArray..::.Size Property
FaceArray Class See Also Send Feedback
Returns the number of faces that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FaceArray Class


FaceArrayIterator Class

[image]

Revit 2011 API
FaceArrayIterator Class
Members See Also Send Feedback
An iterator to a face array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FaceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FaceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FaceArrayIterator

See Also

FaceArrayIterator Members


FaceArrayIterator Members

[image] [image]

Revit 2011 API
FaceArrayIterator Members
FaceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Constructors

Name | Description
FaceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


FaceArrayIterator Constructor

[image]

Revit 2011 API
FaceArrayIterator Constructor
FaceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FaceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FaceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FaceArrayIterator Class


FaceArrayIterator Methods

[image] [image]

Revit 2011 API
FaceArrayIterator Methods
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
FaceArrayIterator..::.MoveNext Method
FaceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


Reset Method

[image]

Revit 2011 API
FaceArrayIterator..::.Reset Method
FaceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FaceArrayIterator Class


FaceArrayIterator Properties

[image] [image]

Revit 2011 API
FaceArrayIterator Properties
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


Current Property

[image]

Revit 2011 API
FaceArrayIterator..::.Current Property
FaceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


FaceWall Class

[image]

Revit 2011 API
FaceWall Class
Members See Also Send Feedback
A wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FaceWall : HostObject
Visual Basic (Declaration)
Public Class FaceWall _
    Inherits HostObject
Visual C++
public ref class FaceWall : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.FaceWall

See Also

FaceWall Members


FaceWall Members

[image] [image]

Revit 2011 API
FaceWall Members
FaceWall Class Methods Properties See Also Send Feedback

The FaceWall type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of a wall attached to a non-vertical massing face.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FaceWall Class


FaceWall Methods

[image] [image]

Revit 2011 API
FaceWall Methods
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of a wall attached to a non-vertical massing face.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceWall Class


Create Method

[image]

Revit 2011 API
FaceWall..::.Create Method
FaceWall Class See Also Send Feedback
Creates a new instance of a wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FaceWall Create(
    Document document,
    ElementId wallType,
    WallLocationLine locationLine,
    Reference faceReference
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    wallType As ElementId, _
    locationLine As WallLocationLine, _
    faceReference As Reference _
) As FaceWall
Visual C++
public:
static FaceWall^ Create(
    Document^ document,
    ElementId^ wallType,
    WallLocationLine locationLine,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
wallType
Type: Autodesk.Revit.DB..::.ElementId
The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
locationLine
Type: Autodesk.Revit.DB..::.WallLocationLine
The alignment of the wall location line.
faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()

Return Value

The newly created face wall.

Remarks

This method will regenerate the document.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the newly created face wall is going to be joined to surrounding structures.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element wallType does not exist in the document -or- The document does not allow creation of a face wall. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.

See Also

FaceWall Class


IsValidFaceReferenceForFaceWall Method

[image]

Revit 2011 API
FaceWall..::.IsValidFaceReferenceForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a reference may be used as the parent of a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidFaceReferenceForFaceWall(
    Document document,
    Reference faceReference
)
Visual Basic (Declaration)
Public Shared Function IsValidFaceReferenceForFaceWall ( _
    document As Document, _
    faceReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidFaceReferenceForFaceWall(
    Document^ document,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference.

Return Value

True if the reference is valid as a parent to a face wall, false otherwise.

Remarks

The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FaceWall Class


IsWallTypeValidForFaceWall Method

[image]

Revit 2011 API
FaceWall..::.IsWallTypeValidForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a wall type may be applied to a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsWallTypeValidForFaceWall(
    Document document,
    ElementId wallType
)
Visual Basic (Declaration)
Public Shared Function IsWallTypeValidForFaceWall ( _
    document As Document, _
    wallType As ElementId _
) As Boolean
Visual C++
public:
static bool IsWallTypeValidForFaceWall(
    Document^ document,
    ElementId^ wallType
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
wallType
Type: Autodesk.Revit.DB..::.ElementId
The wall type.

Return Value

True if the wall type is valid for face wall, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FaceWall Class


FaceWall Properties

[image] [image]

Revit 2011 API
FaceWall Properties
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FaceWall Class


Parameter Property

[image] [image]

Revit 2011 API
FaceWall..::.Parameter Property
FaceWall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FaceWall Class
FaceWall Members


FailureDefinition Class

[image]

Revit 2011 API
FailureDefinition Class
Members See Also Send Feedback
Defines persistent information about a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinition : IDisposable
Visual Basic (Declaration)
Public Class FailureDefinition _
    Implements IDisposable
Visual C++
public ref class FailureDefinition : IDisposable

Remarks

Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureDefinition

See Also

FailureDefinition Members


FailureDefinition Members

[image] [image]

Revit 2011 API
FailureDefinition Members
FailureDefinition Class Methods Properties See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

Name | Description
AddResolutionType | Adds a type of possible resolution for the failure.
CreateFailureDefinition | Creates an instance of a FailureDefinition.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Severity | The severity of the failure.

See Also

FailureDefinition Class


FailureDefinition Methods

[image] [image]

Revit 2011 API
FailureDefinition Methods
FailureDefinition Class See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

Name | Description
AddResolutionType | Adds a type of possible resolution for the failure.
CreateFailureDefinition | Creates an instance of a FailureDefinition.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinition Class


AddResolutionType Method

[image]

Revit 2011 API
FailureDefinition..::.AddResolutionType Method
FailureDefinition Class See Also Send Feedback
Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition AddResolutionType(
    FailureResolutionType type,
    string caption,
    Type classOfResolution
)
Visual Basic (Declaration)
Public Function AddResolutionType ( _
    type As FailureResolutionType, _
    caption As String, _
    classOfResolution As Type _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ AddResolutionType(
    FailureResolutionType type,
    String^ caption,
    Type^ classOfResolution
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption
Type: System..::.String
A simple description of the resolution.
classOfResolution
Type: System..::.Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

The FailureDefinition.

Remarks

In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class


CreateFailureDefinition Method

[image]

Revit 2011 API
FailureDefinition..::.CreateFailureDefinition Method
FailureDefinition Class Example See Also Send Feedback
Creates an instance of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinition CreateFailureDefinition(
    FailureDefinitionId id,
    FailureSeverity severity,
    string messageString
)
Visual Basic (Declaration)
Public Shared Function CreateFailureDefinition ( _
    id As FailureDefinitionId, _
    severity As FailureSeverity, _
    messageString As String _
) As FailureDefinition
Visual C++
public:
static FailureDefinition^ CreateFailureDefinition(
    FailureDefinitionId^ id,
    FailureSeverity severity,
    String^ messageString
)

Parameters

id
Type: Autodesk.Revit.DB..::.FailureDefinitionId
Unique identifier of the failure.
severity
Type: Autodesk.Revit.DB..::.FailureSeverity
The severity of the failure. Can not be FailureSeverity::None.
messageString
Type: System..::.String
A user-visible string describing the failure.

Return Value

The created FailureDefinition instance.

Remarks

The newly created FailureDefinition will be added to the FailureDefinitionRegistry. Because FailureDefinition could only be registered when Revit starting up, this function cannot be used after Revit has already started. Throws InvalidOperationException if invoked after Revit start-up is completed.

Examples

CopyC#
// define a new failure id for a warning about walls
FailureDefinitionId warnId =
    new FailureDefinitionId(new Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"));

// register the new warning using FailureDefinition
FailureDefinition failDef = FailureDefinition.CreateFailureDefinition(warnId,
    FailureSeverity.Warning,
    "Wall is too big (>100'). Performance problems may result.");
CopyVB.NET
' define a new failure id for a warning about walls
Dim warnId As New FailureDefinitionId(New Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"))

' register the new warning using FailureDefinition
Dim failDef As FailureDefinition = FailureDefinition.CreateFailureDefinition(warnId, FailureSeverity.Warning, "Wall is too big (>100'). Performance problems may result.")

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The id of failure definition is not valid. -or- The id of failure definition is already used to register another FailureDefinition. -or- The severity of failures cannot be FailureSeverity::None. -or- Message string is empty or contains invalid characters.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class


Dispose Method

[image]

Revit 2011 API
FailureDefinition..::.Dispose Method
FailureDefinition Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureDefinition Class


GetApplicableResolutionTypes Method

[image]

Revit 2011 API
FailureDefinition..::.GetApplicableResolutionTypes Method
FailureDefinition Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic (Declaration)
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

See Also

FailureDefinition Class


GetDefaultResolutionType Method

[image]

Revit 2011 API
FailureDefinition..::.GetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic (Declaration)
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The Default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


GetDescriptionText Method

[image]

Revit 2011 API
FailureDefinition..::.GetDescriptionText Method
FailureDefinition Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic (Declaration)
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Remarks

Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"

See Also

FailureDefinition Class


GetResolutionCaption Method

[image]

Revit 2011 API
FailureDefinition..::.GetResolutionCaption Method
FailureDefinition Class See Also Send Feedback
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::.InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


HasResolutions Method

[image]

Revit 2011 API
FailureDefinition..::.HasResolutions Method
FailureDefinition Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic (Declaration)
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

See Also

FailureDefinition Class


IsResolutionApplicable Method

[image]

Revit 2011 API
FailureDefinition..::.IsResolutionApplicable Method
FailureDefinition Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

See Also

FailureDefinition Class


SetDefaultResolutionType Method

[image]

Revit 2011 API
FailureDefinition..::.SetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function SetDefaultResolutionType ( _
    type As FailureResolutionType _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of resolution to be used as default.

Return Value

The FailureDefinition.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::.InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


FailureDefinition Properties

[image] [image]

Revit 2011 API
FailureDefinition Properties
FailureDefinition Class See Also Send Feedback

The FailureDefinition type exposes the following members.

Properties

Name | Description
Severity | The severity of the failure.

See Also

FailureDefinition Class


Severity Property

[image]

Revit 2011 API
FailureDefinition..::.Severity Property
FailureDefinition Class See Also Send Feedback
The severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity Severity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Severity As FailureSeverity
Visual C++
public:
property FailureSeverity Severity {
    FailureSeverity get ();
}

See Also

FailureDefinition Class


FailureDefinitionAccessor Class

[image]

Revit 2011 API
FailureDefinitionAccessor Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionAccessor : IDisposable
Visual Basic (Declaration)
Public Class FailureDefinitionAccessor _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionAccessor : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureDefinitionAccessor

See Also

FailureDefinitionAccessor Members


FailureDefinitionAccessor Members

[image] [image]

Revit 2011 API
FailureDefinitionAccessor Members
FailureDefinitionAccessor Class Methods See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Retrieves the unique identifier of the FailureDefinition.
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetSeverity | Retrieves severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class


FailureDefinitionAccessor Methods

[image] [image]

Revit 2011 API
FailureDefinitionAccessor Methods
FailureDefinitionAccessor Class See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
GetDefaultResolutionType | Retrieves the default resolution type for the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetId | Retrieves the unique identifier of the FailureDefinition.
GetResolutionCaption | Retrieves the caption for a specific resolution type.
GetSeverity | Retrieves severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutions | Checks if the FailureDefinition has at least one resolution.
IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
SetDefaultResolutionType | Sets the default resolution type for the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class


Dispose Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.Dispose Method
FailureDefinitionAccessor Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureDefinitionAccessor Class


GetApplicableResolutionTypes Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetApplicableResolutionTypes Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic (Declaration)
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetDefaultResolutionType Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic (Declaration)
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


GetDescriptionText Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetDescriptionText Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic (Declaration)
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Remarks

Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetId Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetId Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the unique identifier of the FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetId()
Visual Basic (Declaration)
Public Function GetId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetId()

Return Value

The unique identifier of the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetResolutionCaption Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetResolutionCaption Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


GetSeverity Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.GetSeverity Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


HasResolutions Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.HasResolutions Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic (Declaration)
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


IsResolutionApplicable Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.IsResolutionApplicable Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


SetDefaultResolutionType Method

[image]

Revit 2011 API
FailureDefinitionAccessor..::.SetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Sub SetDefaultResolutionType ( _
    type As FailureResolutionType _
)
Visual C++
public:
void SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of resolution to be used as default.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


FailureDefinitionId Class

[image]

Revit 2011 API
FailureDefinitionId Class
Members See Also Send Feedback
The unique identifier of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionId : GuidEnum
Visual Basic (Declaration)
Public Class FailureDefinitionId _
    Inherits GuidEnum
Visual C++
public ref class FailureDefinitionId : public GuidEnum

Remarks

Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GuidEnum
Autodesk.Revit.DB..::.FailureDefinitionId

See Also

FailureDefinitionId Members


FailureDefinitionId Members

[image] [image]

Revit 2011 API
FailureDefinitionId Members
FailureDefinitionId Class Constructors Methods Properties See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Constructors

Name | Description
FailureDefinitionId | Creates a new FailureDefinitionId instance.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

Properties

Name | Description
Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionId Constructor

[image]

Revit 2011 API
FailureDefinitionId Constructor
FailureDefinitionId Class See Also Send Feedback
Creates a new FailureDefinitionId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FailureDefinitionId(
    Guid guid
)
Visual Basic (Declaration)
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
FailureDefinitionId(
    Guid guid
)

Parameters

guid
Type: System..::.Guid
The identifier for the FailureDefinitionId.

See Also

FailureDefinitionId Class


FailureDefinitionId Methods

[image] [image]

Revit 2011 API
FailureDefinitionId Methods
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

See Also

FailureDefinitionId Class


Equality Operator

[image]

Revit 2011 API
FailureDefinitionId..::.Equality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator ==(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator ==(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::.FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are identical, false if they are different.

See Also

FailureDefinitionId Class


Inequality Operator

[image]

Revit 2011 API
FailureDefinitionId..::.Inequality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator !=(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::.FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are different, false if they are identical.

See Also

FailureDefinitionId Class


FailureDefinitionId Properties

[image] [image]

Revit 2011 API
FailureDefinitionId Properties
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Properties

Name | Description
Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionRegistry Class

[image]

Revit 2011 API
FailureDefinitionRegistry Class
Members See Also Send Feedback
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionRegistry : IDisposable
Visual Basic (Declaration)
Public Class FailureDefinitionRegistry _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionRegistry : IDisposable

Remarks

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry()()()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureDefinitionRegistry

See Also

FailureDefinitionRegistry Members


FailureDefinitionRegistry Members

[image] [image]

Revit 2011 API
FailureDefinitionRegistry Members
FailureDefinitionRegistry Class Methods See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class


FailureDefinitionRegistry Methods

[image] [image]

Revit 2011 API
FailureDefinitionRegistry Methods
FailureDefinitionRegistry Class See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class


Dispose Method

[image]

Revit 2011 API
FailureDefinitionRegistry..::.Dispose Method
FailureDefinitionRegistry Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureDefinitionRegistry Class


FindFailureDefinition Method

[image]

Revit 2011 API
FailureDefinitionRegistry..::.FindFailureDefinition Method
FailureDefinitionRegistry Class See Also Send Feedback
Finds a specific FailureDefinition by a given FailureDefinitionId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionAccessor FindFailureDefinition(
    FailureDefinitionId id
)
Visual Basic (Declaration)
Public Function FindFailureDefinition ( _
    id As FailureDefinitionId _
) As FailureDefinitionAccessor
Visual C++
public:
FailureDefinitionAccessor^ FindFailureDefinition(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.FailureDefinitionId
The id of the FailureDefinition.

Return Value

The accessor of the found FailureDefinition, or null, if the FailureDefinition was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinitionRegistry Class


ListAllFailureDefinitions Method

[image]

Revit 2011 API
FailureDefinitionRegistry..::.ListAllFailureDefinitions Method
FailureDefinitionRegistry Class See Also Send Feedback
Retrieves all the registered FailureDefinitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureDefinitionAccessor> ListAllFailureDefinitions()
Visual Basic (Declaration)
Public Function ListAllFailureDefinitions As IList(Of FailureDefinitionAccessor)
Visual C++
public:
IList<FailureDefinitionAccessor^>^ ListAllFailureDefinitions()

Return Value

All the registered FailureDefinitions.

See Also

FailureDefinitionRegistry Class


FailureHandlingOptions Class

[image]

Revit 2011 API
FailureHandlingOptions Class
Members See Also Send Feedback
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureHandlingOptions : IDisposable
Visual Basic (Declaration)
Public Class FailureHandlingOptions _
    Implements IDisposable
Visual C++
public ref class FailureHandlingOptions : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureHandlingOptions

See Also

FailureHandlingOptions Members


FailureHandlingOptions Members

[image] [image]

Revit 2011 API
FailureHandlingOptions Members
FailureHandlingOptions Class Methods See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetClearAfterRollback |
GetDelayedMiniWarnings |
GetFailuresPreprocessor |
GetForcedModalHandling |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTransactionFinalizer |
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetClearAfterRollback |
SetDelayedMiniWarnings |
SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing
SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish
SetTransactionFinalizer | Setting a callback to be executed after transaction is completed
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class


FailureHandlingOptions Methods

[image] [image]

Revit 2011 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetClearAfterRollback |
GetDelayedMiniWarnings |
GetFailuresPreprocessor |
GetForcedModalHandling |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTransactionFinalizer |
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetClearAfterRollback |
SetDelayedMiniWarnings |
SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing
SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish
SetTransactionFinalizer | Setting a callback to be executed after transaction is completed
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class


Dispose Method

[image]

Revit 2011 API
FailureHandlingOptions..::.Dispose Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureHandlingOptions Class


GetClearAfterRollback Method

[image]

Revit 2011 API
FailureHandlingOptions..::.GetClearAfterRollback Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool GetClearAfterRollback()
Visual Basic (Declaration)
Public Function GetClearAfterRollback As Boolean
Visual C++
public:
bool GetClearAfterRollback()

See Also

FailureHandlingOptions Class


GetDelayedMiniWarnings Method

[image]

Revit 2011 API
FailureHandlingOptions..::.GetDelayedMiniWarnings Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool GetDelayedMiniWarnings()
Visual Basic (Declaration)
Public Function GetDelayedMiniWarnings As Boolean
Visual C++
public:
bool GetDelayedMiniWarnings()

See Also

FailureHandlingOptions Class


GetFailuresPreprocessor Method

[image]

Revit 2011 API
FailureHandlingOptions..::.GetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IFailuresPreprocessor GetFailuresPreprocessor()
Visual Basic (Declaration)
Public Function GetFailuresPreprocessor As IFailuresPreprocessor
Visual C++
public:
IFailuresPreprocessor^ GetFailuresPreprocessor()

See Also

FailureHandlingOptions Class


GetForcedModalHandling Method

[image]

Revit 2011 API
FailureHandlingOptions..::.GetForcedModalHandling Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool GetForcedModalHandling()
Visual Basic (Declaration)
Public Function GetForcedModalHandling As Boolean
Visual C++
public:
bool GetForcedModalHandling()

See Also

FailureHandlingOptions Class


GetTransactionFinalizer Method

[image]

Revit 2011 API
FailureHandlingOptions..::.GetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ITransactionFinalizer GetTransactionFinalizer()
Visual Basic (Declaration)
Public Function GetTransactionFinalizer As ITransactionFinalizer
Visual C++
public:
ITransactionFinalizer^ GetTransactionFinalizer()

See Also

FailureHandlingOptions Class


SetClearAfterRollback Method

[image]

Revit 2011 API
FailureHandlingOptions..::.SetClearAfterRollback Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetClearAfterRollback(
    bool bFlag
)
Visual Basic (Declaration)
Public Function SetClearAfterRollback ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetClearAfterRollback(
    bool bFlag
)

Parameters

bFlag
Type: System..::.Boolean

See Also

FailureHandlingOptions Class


SetDelayedMiniWarnings Method

[image]

Revit 2011 API
FailureHandlingOptions..::.SetDelayedMiniWarnings Method
FailureHandlingOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetDelayedMiniWarnings(
    bool bFlag
)
Visual Basic (Declaration)
Public Function SetDelayedMiniWarnings ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetDelayedMiniWarnings(
    bool bFlag
)

Parameters

bFlag
Type: System..::.Boolean

Remarks

This controls mini-warnings only; does not make sense in modal mode setting it to true will postpone clearing mini-warning dialogs until the next transaction is finished

See Also

FailureHandlingOptions Class


SetFailuresPreprocessor Method

[image]

Revit 2011 API
FailureHandlingOptions..::.SetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback
Setting a callback to be invoked in the beginning of failure processing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
    IFailuresPreprocessor preprocessor
)
Visual Basic (Declaration)
Public Function SetFailuresPreprocessor ( _
    preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
    IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DB..::.IFailuresPreprocessor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class


SetForcedModalHandling Method

[image]

Revit 2011 API
FailureHandlingOptions..::.SetForcedModalHandling Method
FailureHandlingOptions Class See Also Send Feedback
Set the flag whether it pops modal error dialog if the transaction failed to finish

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetForcedModalHandling(
    bool bFlag
)
Visual Basic (Declaration)
Public Function SetForcedModalHandling ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetForcedModalHandling(
    bool bFlag
)

Parameters

bFlag
Type: System..::.Boolean

See Also

FailureHandlingOptions Class


SetTransactionFinalizer Method

[image]

Revit 2011 API
FailureHandlingOptions..::.SetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback
Setting a callback to be executed after transaction is completed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetTransactionFinalizer(
    ITransactionFinalizer finalizer
)
Visual Basic (Declaration)
Public Function SetTransactionFinalizer ( _
    finalizer As ITransactionFinalizer _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetTransactionFinalizer(
    ITransactionFinalizer^ finalizer
)

Parameters

finalizer
Type: Autodesk.Revit.DB..::.ITransactionFinalizer

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class


FailureMessage Class

[image]

Revit 2011 API
FailureMessage Class
Members See Also Send Feedback
Represents a message describing a failure of an operation in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureMessage : IDisposable
Visual Basic (Declaration)
Public Class FailureMessage _
    Implements IDisposable
Visual C++
public ref class FailureMessage : IDisposable

Remarks

Failure messages are typically shown to the user in the Revit error dialog. This class contains the following information about the failures:
  1. The basic description of the failure (retrieved from the FailureDefinition)
  2. The available resolutions for the failure.
  3. The elements related to the failure.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureMessage

See Also

FailureMessage Members


FailureMessage Members

[image] [image]

Revit 2011 API
FailureMessage Members
FailureMessage Class Constructors Methods See Also Send Feedback

The FailureMessage type exposes the following members.

Constructors

Name | Description
FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.

Methods

Name | Description
AddResolution | Adds a resolution for the failure.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetFailingElements | Retrieves list of the elements that have caused the failure.
GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetAdditionalElement | Sets the additional reference element for the failure.
SetAdditionalElements | Sets the additional reference elements for the failure.
SetFailingElement | Sets the element that has caused the failure.
SetFailingElements | Sets elements that have caused the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessage Class


FailureMessage Constructor

[image]

Revit 2011 API
FailureMessage Constructor
FailureMessage Class See Also Send Feedback
Creates a new FailureMessage related to a given FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage(
    FailureDefinitionId id
)
Visual Basic (Declaration)
Public Sub New ( _
    id As FailureDefinitionId _
)
Visual C++
public:
FailureMessage(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.FailureDefinitionId
Id of FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


FailureMessage Methods

[image] [image]

Revit 2011 API
FailureMessage Methods
FailureMessage Class See Also Send Feedback

The FailureMessage type exposes the following members.

Methods

Name | Description
AddResolution | Adds a resolution for the failure.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
GetDescriptionText | Retrieves the description text of the failure.
GetFailingElements | Retrieves list of the elements that have caused the failure.
GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetAdditionalElement | Sets the additional reference element for the failure.
SetAdditionalElements | Sets the additional reference elements for the failure.
SetFailingElement | Sets the element that has caused the failure.
SetFailingElements | Sets elements that have caused the failure.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessage Class


AddResolution Method

[image]

Revit 2011 API
FailureMessage..::.AddResolution Method
FailureMessage Class See Also Send Feedback
Adds a resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage AddResolution(
    FailureResolutionType type,
    FailureResolution resolution
)
Visual Basic (Declaration)
Public Function AddResolution ( _
    type As FailureResolutionType, _
    resolution As FailureResolution _
) As FailureMessage
Visual C++
public:
FailureMessage^ AddResolution(
    FailureResolutionType type,
    FailureResolution^ resolution
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of the resolution.
resolution
Type: Autodesk.Revit.DB..::.FailureResolution
The resolution.

Return Value

The FailureMessage.

Remarks

Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


Dispose Method

[image]

Revit 2011 API
FailureMessage..::.Dispose Method
FailureMessage Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureMessage Class


GetAdditionalElements Method

[image]

Revit 2011 API
FailureMessage..::.GetAdditionalElements Method
FailureMessage Class See Also Send Feedback
Retrieves list of the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElements()
Visual Basic (Declaration)
Public Function GetAdditionalElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElements()

Return Value

The additional elements.

See Also

FailureMessage Class


GetDefaultResolutionCaption Method

[image]

Revit 2011 API
FailureMessage..::.GetDefaultResolutionCaption Method
FailureMessage Class See Also Send Feedback
Retrieves the caption of the default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic (Declaration)
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of the default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage does not have any resolutions.

See Also

FailureMessage Class


GetDescriptionText Method

[image]

Revit 2011 API
FailureMessage..::.GetDescriptionText Method
FailureMessage Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic (Declaration)
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

See Also

FailureMessage Class


GetFailingElements Method

[image]

Revit 2011 API
FailureMessage..::.GetFailingElements Method
FailureMessage Class See Also Send Feedback
Retrieves list of the elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElements()
Visual Basic (Declaration)
Public Function GetFailingElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElements()

Return Value

The elements that have caused the failure.

See Also

FailureMessage Class


GetFailureDefinitionId Method

[image]

Revit 2011 API
FailureMessage..::.GetFailureDefinitionId Method
FailureMessage Class See Also Send Feedback
Retrieves the id of the failure definition for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic (Declaration)
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The id of the FailureDefinition for the failure.

See Also

FailureMessage Class


GetSeverity Method

[image]

Revit 2011 API
FailureMessage..::.GetSeverity Method
FailureMessage Class See Also Send Feedback
Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

See Also

FailureMessage Class


HasResolutionOfType Method

[image]

Revit 2011 API
FailureMessage..::.HasResolutionOfType Method
FailureMessage Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of resolution.

Return Value

True if the failure has a type of resolutions, else false.

See Also

FailureMessage Class


HasResolutions Method

[image]

Revit 2011 API
FailureMessage..::.HasResolutions Method
FailureMessage Class See Also Send Feedback
Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic (Declaration)
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if the failure has any resolutions, false otherwise.

See Also

FailureMessage Class


SetAdditionalElement Method

[image]

Revit 2011 API
FailureMessage..::.SetAdditionalElement Method
FailureMessage Class See Also Send Feedback
Sets the additional reference element for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElement(
    ElementId additionalElement
)
Visual Basic (Declaration)
Public Function SetAdditionalElement ( _
    additionalElement As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElement(
    ElementId^ additionalElement
)

Parameters

additionalElement
Type: Autodesk.Revit.DB..::.ElementId
The additional element.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User can not delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


SetAdditionalElements Method

[image]

Revit 2011 API
FailureMessage..::.SetAdditionalElements Method
FailureMessage Class See Also Send Feedback
Sets the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElements(
    ICollection<ElementId> additionalElements
)
Visual Basic (Declaration)
Public Function SetAdditionalElements ( _
    additionalElements As ICollection(Of ElementId) _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElements(
    ICollection<ElementId^>^ additionalElements
)

Parameters

additionalElements
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The additional elements.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User can not delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


SetFailingElement Method

[image]

Revit 2011 API
FailureMessage..::.SetFailingElement Method
FailureMessage Class See Also Send Feedback
Sets the element that has caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElement(
    ElementId id
)
Visual Basic (Declaration)
Public Function SetFailingElement ( _
    id As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The element that has caused the failure.

Return Value

The FailureMessage.

Remarks

In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


SetFailingElements Method

[image]

Revit 2011 API
FailureMessage..::.SetFailingElements Method
FailureMessage Class See Also Send Feedback
Sets elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElements(
    ICollection<ElementId> idsToShow
)
Visual Basic (Declaration)
Public Function SetFailingElements ( _
    idsToShow As ICollection(Of ElementId) _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElements(
    ICollection<ElementId^>^ idsToShow
)

Parameters

idsToShow
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The elements that have caused the failure.

Return Value

The FailureMessage.

Remarks

In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessage is already posted to a document
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


FailureMessageAccessor Class

[image]

Revit 2011 API
FailureMessageAccessor Class
Members See Also Send Feedback
Restricted accessor for FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureMessageAccessor : IDisposable
Visual Basic (Declaration)
Public Class FailureMessageAccessor _
    Implements IDisposable
Visual C++
public ref class FailureMessageAccessor : IDisposable

Remarks

Provides access to a FailureMessage stored in a Document. Reading of the information from the FailureMessage is allowed, changing of information is generally not allowed, except setting of the current resolution type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureMessageAccessor

See Also

FailureMessageAccessor Members


FailureMessageAccessor Members

[image] [image]

Revit 2011 API
FailureMessageAccessor Members
FailureMessageAccessor Class Methods See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

Name | Description
CloneFailureMessage | Creates a copy of the FailureMessage.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
GetDescriptionText | Retrieves the description of the failure.
GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageAccessor Class


FailureMessageAccessor Methods

[image] [image]

Revit 2011 API
FailureMessageAccessor Methods
FailureMessageAccessor Class See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

Name | Description
CloneFailureMessage | Creates a copy of the FailureMessage.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
GetDescriptionText | Retrieves the description of the failure.
GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
GetSeverity | Retrieves the severity of the failure.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasResolutionOfType | Checks if failure has a resolution of a given type.
HasResolutions | Checks if the failure has any resolutions.
SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageAccessor Class


CloneFailureMessage Method

[image]

Revit 2011 API
FailureMessageAccessor..::.CloneFailureMessage Method
FailureMessageAccessor Class See Also Send Feedback
Creates a copy of the FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessage CloneFailureMessage()
Visual Basic (Declaration)
Public Function CloneFailureMessage As FailureMessage
Visual C++
public:
FailureMessage^ CloneFailureMessage()

Return Value

Copy of the FailureMesassge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


Dispose Method

[image]

Revit 2011 API
FailureMessageAccessor..::.Dispose Method
FailureMessageAccessor Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureMessageAccessor Class


GetAdditionalElementIds Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetAdditionalElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElementIds()
Visual Basic (Declaration)
Public Function GetAdditionalElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElementIds()

Return Value

Ids of Elements related to the failure

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetCurrentResolutionType Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the type of resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetCurrentResolutionType()
Visual Basic (Declaration)
Public Function GetCurrentResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetCurrentResolutionType()

Return Value

The type of failure resolution to be used to resolve the failure.

Remarks

If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


GetDefaultResolutionCaption Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetDefaultResolutionCaption Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the caption of default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic (Declaration)
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetDescriptionText Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetDescriptionText Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the description of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic (Declaration)
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetFailingElementIds Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetFailingElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElementIds()
Visual Basic (Declaration)
Public Function GetFailingElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElementIds()

Return Value

Ids of Elements that have caused the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetFailureDefinitionId Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetFailureDefinitionId Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the Id of the FailureDefinition of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic (Declaration)
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The Id of the FailureDefinition of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetNumberOfResolutions Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetNumberOfResolutions Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves number of resolutions that can be used to resolve failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int GetNumberOfResolutions()
Visual Basic (Declaration)
Public Function GetNumberOfResolutions As Integer
Visual C++
public:
int GetNumberOfResolutions()

Return Value

Number of resolutions that can be used to resolve failure

Remarks

If number of resolutions is zero, the failure can not be resolved. If severity of the failure is Warning, it can be deleted. Otherwise, the only option is to cancel current operation and roll back the transaction

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetSeverity Method

[image]

Revit 2011 API
FailureMessageAccessor..::.GetSeverity Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


HasResolutionOfType Method

[image]

Revit 2011 API
FailureMessageAccessor..::.HasResolutionOfType Method
FailureMessageAccessor Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic (Declaration)
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of resolution.

Return Value

True if failure has a resolution of a given type, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


HasResolutions Method

[image]

Revit 2011 API
FailureMessageAccessor..::.HasResolutions Method
FailureMessageAccessor Class See Also Send Feedback
Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic (Declaration)
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if the failure has any resolutions, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


SetCurrentResolutionType Method

[image]

Revit 2011 API
FailureMessageAccessor..::.SetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Sets the type of a resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)
Visual Basic (Declaration)
Public Sub SetCurrentResolutionType ( _
    resolutionType As FailureResolutionType _
)
Visual C++
public:
void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::.FailureResolutionType
The type of failure resolution to be used to resolve the failure.

Remarks

When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type. If no current resolution type is set, the default resolution type will be used. Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | This FailureMessageAccessor has no resolution of resolutionType.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


ShouldMergeWithMessage Method

[image]

Revit 2011 API
FailureMessageAccessor..::.ShouldMergeWithMessage Method
FailureMessageAccessor Class See Also Send Feedback
Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShouldMergeWithMessage(
    FailureMessageAccessor messageToMergeWith
)
Visual Basic (Declaration)
Public Function ShouldMergeWithMessage ( _
    messageToMergeWith As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool ShouldMergeWithMessage(
    FailureMessageAccessor^ messageToMergeWith
)

Parameters

messageToMergeWith
Type: Autodesk.Revit.DB..::.FailureMessageAccessor

Return Value

True if messages should be merged

Remarks

Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | messageToMergeWith has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessageAccessor Class


FailureMessageKey Class

[image]

Revit 2011 API
FailureMessageKey Class
Members See Also Send Feedback
A unique key assigned to each posted failure message

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureMessageKey : IDisposable
Visual Basic (Declaration)
Public Class FailureMessageKey _
    Implements IDisposable
Visual C++
public ref class FailureMessageKey : IDisposable

Remarks

When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureMessageKey

See Also

FailureMessageKey Members


FailureMessageKey Members

[image] [image]

Revit 2011 API
FailureMessageKey Members
FailureMessageKey Class Constructors Methods See Also Send Feedback

The FailureMessageKey type exposes the following members.

Constructors

Name | Description
FailureMessageKey | Initializes a new instance of the FailureMessageKey class

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks it this key is equal to the other.
IsValid | Checks if the failure message key is valid
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class


FailureMessageKey Constructor

[image]

Revit 2011 API
FailureMessageKey Constructor
FailureMessageKey Class See Also Send Feedback
Initializes a new instance of the FailureMessageKey class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureMessageKey()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FailureMessageKey()

See Also

FailureMessageKey Class


FailureMessageKey Methods

[image] [image]

Revit 2011 API
FailureMessageKey Methods
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks it this key is equal to the other.
IsValid | Checks if the failure message key is valid
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class


Dispose Method

[image]

Revit 2011 API
FailureMessageKey..::.Dispose Method
FailureMessageKey Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureMessageKey Class


Equality Operator

[image]

Revit 2011 API
FailureMessageKey..::.Equality Operator
FailureMessageKey Class See Also Send Feedback
Determines whether two FailureMessageKeys are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator ==(
    FailureMessageKey first,
    FailureMessageKey second
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    first As FailureMessageKey, _
    second As FailureMessageKey _
) As Boolean
Visual C++
public:
static bool operator ==(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.FailureMessageKey
The first FailureMessageKey.
second
Type: Autodesk.Revit.DB..::.FailureMessageKey
The second FailureMessageKey.

Return Value

True if the FailureMessageKeys are the same; otherwise, false.

See Also

FailureMessageKey Class


Equals Method

[image]

Revit 2011 API
FailureMessageKey..::.Equals Method
FailureMessageKey Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another object.

See Also

FailureMessageKey Class


GetHashCode Method

[image]

Revit 2011 API
FailureMessageKey..::.GetHashCode Method
FailureMessageKey Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

FailureMessageKey Class


Inequality Operator

[image]

Revit 2011 API
FailureMessageKey..::.Inequality Operator
FailureMessageKey Class See Also Send Feedback
Determines whether two FailureMessageKeys are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool operator !=(
    FailureMessageKey first,
    FailureMessageKey second
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    first As FailureMessageKey, _
    second As FailureMessageKey _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.FailureMessageKey
The first FailureMessageKey.
second
Type: Autodesk.Revit.DB..::.FailureMessageKey
The second FailureMessageKey.

Return Value

True if the FailureMessageKeys are different; otherwise, false.

See Also

FailureMessageKey Class


IsEqual Method

[image]

Revit 2011 API
FailureMessageKey..::.IsEqual Method
FailureMessageKey Class See Also Send Feedback
Checks it this key is equal to the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    FailureMessageKey other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As FailureMessageKey _
) As Boolean
Visual C++
public:
bool IsEqual(
    FailureMessageKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::.FailureMessageKey
The key to compare with.

Return Value

True if keys are equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessageKey Class


IsValid Method

[image]

Revit 2011 API
FailureMessageKey..::.IsValid Method
FailureMessageKey Class See Also Send Feedback
Checks if the failure message key is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValid()
Visual Basic (Declaration)
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the failure message key is valid

See Also

FailureMessageKey Class


FailureProcessingResult Enumeration

[image]

Revit 2011 API
FailureProcessingResult Enumeration
See Also Send Feedback
Enum represents result of failure processing by FailuresPreprocessor, handler of FailuresProcessing event or by FailuresProcessor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FailureProcessingResult
Visual Basic (Declaration)
Public Enumeration FailureProcessingResult
Visual C++
public enum class FailureProcessingResult

Members

Member name | Description
Continue | Should be returned if no action was taken and/or caller should continue with default failure processing. If FailuresProcessor returns "Continue" with unresolved failures, Revit will instead act as if "ProceedWithRollBack" was returned.
ProceedWithCommit | Should be returned if some failures were resolved and instructs failure processing/transaction mechanism to try to repeat end of transaction checks and commit transaction again. There is no guarantee that such commit will succeed. "ProceedWithCommit" can not be returned if transaction is already being rolled back, and will be treated as "ProceedWithRollBack" in this case.
ProceedWithRollBack | Should be returned if transaction was requested to be committed and failure (pre)processor requires it to be rolled back instead. If before ProceedWithRollBack is returned FailureHandlingOptions are set to clear errors after rollback, no further error processing will take place, all failures will be deleted and transaction is rolled back silently. Otherwise default failure processing will continue, failures may be delivered to the user, but transaction is guaranteed to be rolled back.
WaitForUserInput | Can be returned only by FailuresProcessor if it is waiting for external event (typically user input) to complete failures processing.

Remarks

The ability to return certain values may be restricted for certain methods or for certain contexts.

See Also


FailureResolution Class

[image]

Revit 2011 API
FailureResolution Class
Members See Also Send Feedback
Defines a resolution for a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailureResolution : IDisposable
Visual Basic (Declaration)
Public Class FailureResolution _
    Implements IDisposable
Visual C++
public ref class FailureResolution : IDisposable

Remarks

A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailureResolution
Autodesk.Revit.DB..::.DeleteElements

See Also

FailureResolution Members


FailureResolution Members

[image] [image]

Revit 2011 API
FailureResolution Members
FailureResolution Class Methods See Also Send Feedback

The FailureResolution type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureResolution Class


FailureResolution Methods

[image] [image]

Revit 2011 API
FailureResolution Methods
FailureResolution Class See Also Send Feedback

The FailureResolution type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureResolution Class


Dispose Method

[image]

Revit 2011 API
FailureResolution..::.Dispose Method
FailureResolution Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailureResolution Class


FailureResolutionType Enumeration

[image]

Revit 2011 API
FailureResolutionType Enumeration
See Also Send Feedback
Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FailureResolutionType
Visual Basic (Declaration)
Public Enumeration FailureResolutionType
Visual C++
public enum class FailureResolutionType

Members

Member name | Description
Invalid | Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default | Special (reserved) type. It can not be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements | Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements | Defnes a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements | Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements | Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements | Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements | Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode | Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints | Defines a resolution of a failure by unconstraining Element(s).
SetValue | Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument | Save the current document to avoid losing more if something serious occurs.
ShowElements | The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others | Resolution type does not match any of the above.

See Also


FailuresAccessor Class

[image]

Revit 2011 API
FailuresAccessor Class
Members See Also Send Feedback
An interface class that provides access to failure information posted in a document and methods to resolve these failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailuresAccessor : IDisposable
Visual Basic (Declaration)
Public Class FailuresAccessor _
    Implements IDisposable
Visual C++
public ref class FailuresAccessor : IDisposable

Remarks

An instance of this class can be obtained only as an argument passed to interfaces used in the process of failure resolution and is the only available interface to fetch information about failures in a document. While reading from a document during failure processing is allowed, the only way to modify document during failure resolution is via methods provided by this class. After returning from failure processing,the instance of the class is deactivated and cannot be used any longer.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FailuresAccessor

See Also

FailuresAccessor Members


FailuresAccessor Members

[image] [image]

Revit 2011 API
FailuresAccessor Members
FailuresAccessor Class Methods See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

Name | Description
CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
DeleteElements | Resolves failures by deletion of elements related to the failures.
DeleteWarning | Deletes one specific failure message of severity "Warning".
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
GetDocument | Provides access to a document for which failures are being processed or preprocessed.
GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
GetFailureMessages | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeverity | Provides access to the current failure severity.
GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsActive | Method allows to check if this instance of the accessor is currently active.
IsElementsDeletionPermitted | Overloaded.
IsFailureResolutionPermitted | Overloaded.
IsPending | Checks if the failure processing is pending.
IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
JournalFailures | Allows to record information about failures in the journal.
PostFailure | Posts an additional failure message to be processed for the current transaction.
ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
ResolveFailure | Resolves one failure using the failure resolution type last set for it.
ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
SetTransactionName | Changes the name of the transaction for which failures are being processed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresAccessor Class


FailuresAccessor Methods

[image] [image]

Revit 2011 API
FailuresAccessor Methods
FailuresAccessor Class See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

Name | Description
CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
DeleteElements | Resolves failures by deletion of elements related to the failures.
DeleteWarning | Deletes one specific failure message of severity "Warning".
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
GetDocument | Provides access to a document for which failures are being processed or preprocessed.
GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
GetFailureMessages | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeverity | Provides access to the current failure severity.
GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsActive | Method allows to check if this instance of the accessor is currently active.
IsElementsDeletionPermitted | Overloaded.
IsFailureResolutionPermitted | Overloaded.
IsPending | Checks if the failure processing is pending.
IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
JournalFailures | Allows to record information about failures in the journal.
PostFailure | Posts an additional failure message to be processed for the current transaction.
ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
ResolveFailure | Resolves one failure using the failure resolution type last set for it.
ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
SetTransactionName | Changes the name of the transaction for which failures are being processed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresAccessor Class


CanCommitPendingTransaction Method

[image]

Revit 2011 API
FailuresAccessor..::.CanCommitPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Checks if pending failure processing can be finished by committing a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanCommitPendingTransaction()
Visual Basic (Declaration)
Public Function CanCommitPendingTransaction As Boolean
Visual C++
public:
bool CanCommitPendingTransaction()

Return Value

True if there is a pending transaction and this transaction is allowed to be committed.

Remarks

Check makes sense only if the failure processing is pending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


CanRollBackPendingTransaction Method

[image]

Revit 2011 API
FailuresAccessor..::.CanRollBackPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Checks if pending failure processing can be finished by rolling back a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanRollBackPendingTransaction()
Visual Basic (Declaration)
Public Function CanRollBackPendingTransaction As Boolean
Visual C++
public:
bool CanRollBackPendingTransaction()

Return Value

True if there is a pending transaction and this transaction is allowed to be rolled back

Remarks

Check makes sense only if the failure processing is pending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


CommitPendingTransaction Method

[image]

Revit 2011 API
FailuresAccessor..::.CommitPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Finishes pending failures processing by committing the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus CommitPendingTransaction()
Visual Basic (Declaration)
Public Function CommitPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus CommitPendingTransaction()

Return Value

Result of attempt to commit the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state. -or- There is no pending transaction or transaction is not allowed to be committed.

See Also

FailuresAccessor Class


DeleteAllWarnings Method

[image]

Revit 2011 API
FailuresAccessor..::.DeleteAllWarnings Method
FailuresAccessor Class See Also Send Feedback
Deletes all FailureMessages of severity "Warning" currently posted in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteAllWarnings()
Visual Basic (Declaration)
Public Sub DeleteAllWarnings
Visual C++
public:
void DeleteAllWarnings()

Remarks

Warnings are deleted immediately and will not be accessible by any further failures processing. Any accessors for these failure messages become invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteElements Method

[image]

Revit 2011 API
FailuresAccessor..::.DeleteElements Method
FailuresAccessor Class See Also Send Feedback
Resolves failures by deletion of elements related to the failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteElements(
    IList<ElementId> idsToDelete
)
Visual Basic (Declaration)
Public Sub DeleteElements ( _
    idsToDelete As IList(Of ElementId) _
)
Visual C++
public:
void DeleteElements(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Ids of elements to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


DeleteWarning Method

[image]

Revit 2011 API
FailuresAccessor..::.DeleteWarning Method
FailuresAccessor Class See Also Send Feedback
Deletes one specific failure message of severity "Warning".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void DeleteWarning(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Sub DeleteWarning ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void DeleteWarning(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The accessor to the warning to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized. -or- Severity of failure is not FailureSeverity::Warning.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


Dispose Method

[image]

Revit 2011 API
FailuresAccessor..::.Dispose Method
FailuresAccessor Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FailuresAccessor Class


GetAttemptedResolutionTypes Method

[image]

Revit 2011 API
FailuresAccessor..::.GetAttemptedResolutionTypes Method
FailuresAccessor Class See Also Send Feedback
Returns list of the failure resolution types attempted for the failure in the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetAttemptedResolutionTypes(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Function GetAttemptedResolutionTypes ( _
    failure As FailureMessageAccessor _
) As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetAttemptedResolutionTypes(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The failure.

Return Value

The list of the types of failure resolutions attempted for the failure.

Remarks

In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


GetDocument Method

[image]

Revit 2011 API
FailuresAccessor..::.GetDocument Method
FailuresAccessor Class See Also Send Feedback
Provides access to a document for which failures are being processed or preprocessed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic (Declaration)
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

The document for which failures preprocessing or processing is being performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetFailureHandlingOptions Method

[image]

Revit 2011 API
FailuresAccessor..::.GetFailureHandlingOptions Method
FailuresAccessor Class See Also Send Feedback
Provides access to the failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions GetFailureHandlingOptions()
Visual Basic (Declaration)
Public Function GetFailureHandlingOptions As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ GetFailureHandlingOptions()

Return Value

The failure handling options for transaction currently being finished.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetFailureMessages Method

[image] [image]

Revit 2011 API
FailuresAccessor..::.GetFailureMessages Method
FailuresAccessor Class See Also Send Feedback

Overload List

Name | Description
GetFailureMessages()()() | Provides access to the individual failure messages currently posted in the document.
GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.

See Also

FailuresAccessor Class
FailuresAccessor Members


GetFailureMessages Method

[image]

Revit 2011 API
FailuresAccessor..::.GetFailureMessages Method
FailuresAccessor Class See Also Send Feedback
Provides access to the individual failure messages currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages()
Visual Basic (Declaration)
Public Function GetFailureMessages As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages()

Return Value

The accessors to the individual failure messages posted in the document.

Remarks

Returned set of messages will be ordered from more severe to less severe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload


GetFailureMessages Method (FailureSeverity)

[image]

Revit 2011 API
FailuresAccessor..::.GetFailureMessages Method (FailureSeverity)
FailuresAccessor Class See Also Send Feedback
Provides access to the individual failure messages if a given severity currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages(
    FailureSeverity severity
)
Visual Basic (Declaration)
Public Function GetFailureMessages ( _
    severity As FailureSeverity _
) As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages(
    FailureSeverity severity
)

Parameters

severity
Type: Autodesk.Revit.DB..::.FailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.

Return Value

Accessors to the individual failure messages of a given severity posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload


GetSeverity Method

[image]

Revit 2011 API
FailuresAccessor..::.GetSeverity Method
FailuresAccessor Class See Also Send Feedback
Provides access to the current failure severity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic (Declaration)
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The highest severity of a failure message currently posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetTransactionName Method

[image]

Revit 2011 API
FailuresAccessor..::.GetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Retrieves the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetTransactionName()
Visual Basic (Declaration)
Public Function GetTransactionName As String
Visual C++
public:
String^ GetTransactionName()

Return Value

The name of the transaction for which failures are being processed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsActive Method

[image]

Revit 2011 API
FailuresAccessor..::.IsActive Method
FailuresAccessor Class See Also Send Feedback
Method allows to check if this instance of the accessor is currently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsActive()
Visual Basic (Declaration)
Public Function IsActive As Boolean
Visual C++
public:
bool IsActive()

Return Value

True if this instance is currently active and can be used.

Remarks

Generally, this instance is active when it is passed to any of interfaces used in the process of failure resolution, and becomes inactive after returning control to Revit. The only special case is if failures processor returns WaitForUserInput, in which case document stays in the FailureMode and instance of failures accessor stays active till FailureMode is ended.

See Also

FailuresAccessor Class


IsElementsDeletionPermitted Method

[image] [image]

Revit 2011 API
FailuresAccessor..::.IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

Name | Description
IsElementsDeletionPermitted()()() | Checks if resolution of the failures by deleting failure elements is permitted.
IsElementsDeletionPermitted(IList<(Of <(ElementId>)>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
IsElementsDeletionPermitted(IList<(Of <(ElementId>)>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsElementsDeletionPermitted Method

[image]

Revit 2011 API
FailuresAccessor..::.IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting failure elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted()
Visual Basic (Declaration)
Public Function IsElementsDeletionPermitted As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted()

Return Value

True if resolution of the failures by deleting failure elements is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsElementsDeletionPermitted Method (IList(ElementId))

[image]

Revit 2011 API
FailuresAccessor..::.IsElementsDeletionPermitted Method (IList<(Of <(ElementId>)>))
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete
)
Visual Basic (Declaration)
Public Function IsElementsDeletionPermitted ( _
    idsToDelete As IList(Of ElementId) _
) As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The Ids of elements to be deleted.

Return Value

True if resolution of the failures by deleting given elements is permitted.

Remarks

Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements exist and can be deleted in the current state of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsElementsDeletionPermitted Method (IList(ElementId), String)

[image]

Revit 2011 API
FailuresAccessor..::.IsElementsDeletionPermitted Method (IList<(Of <(ElementId>)>), String%)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete,
    out string reason
)
Visual Basic (Declaration)
Public Function IsElementsDeletionPermitted ( _
    idsToDelete As IList(Of ElementId), _
    <OutAttribute> ByRef reason As String _
) As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete,
    [OutAttribute] String^% reason
)

Parameters

idsToDelete
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The Ids of elements to be deleted.
reason
Type: System..::.String %
A localized string explaining reason why the elements can not be deleted.

Return Value

True if resolution of the failures by deleting given elements is permitted

Remarks

Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements can be deleted in the current state of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsFailureResolutionPermitted Method

[image] [image]

Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

Name | Description
IsFailureResolutionPermitted()()() | Checks if resolution of failures is permitted.
IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsFailureResolutionPermitted Method

[image]

Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of failures is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted()
Visual Basic (Declaration)
Public Function IsFailureResolutionPermitted As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted()

Return Value

True if resolutions of failures is permitted.

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor)

[image]

Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method (FailureMessageAccessor)
FailuresAccessor Class See Also Send Feedback
Checks if default resolution of the failure is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The accessor to the failure to be resolved.

Return Value

True if default resolution of the failure is permitted

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)

[image]

Revit 2011 API
FailuresAccessor..::.IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure,
    FailureResolutionType resolutionType
)
Visual Basic (Declaration)
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor, _
    resolutionType As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure,
    FailureResolutionType resolutionType
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType
Type: Autodesk.Revit.DB..::.FailureResolutionType
Type of the failure resolution to be used.

Return Value

True if resolution of the failure using given resolution type is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsPending Method

[image]

Revit 2011 API
FailuresAccessor..::.IsPending Method
FailuresAccessor Class See Also Send Feedback
Checks if the failure processing is pending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsPending()
Visual Basic (Declaration)
Public Function IsPending As Boolean
Visual C++
public:
bool IsPending()

Return Value

True if the failures processing is in the pending state.

Remarks

The failure processing is pending after failures processor has returned WaitForUserInput and until pending state is finished by either committing or rolling back of the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsTransactionBeingCommitted Method

[image]

Revit 2011 API
FailuresAccessor..::.IsTransactionBeingCommitted Method
FailuresAccessor Class See Also Send Feedback
Checks if the transaction for which failures are processed is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsTransactionBeingCommitted()
Visual Basic (Declaration)
Public Function IsTransactionBeingCommitted As Boolean
Visual C++
public:
bool IsTransactionBeingCommitted()

Return Value

True if current transaction is being committed, false if the transaction is being rolled back.

Remarks

A transaction is considered as "being committed" if a caller has requested the transaction to be committed and no previous failure processing operation requested the transaction to be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


JournalFailures Method

[image]

Revit 2011 API
FailuresAccessor..::.JournalFailures Method
FailuresAccessor Class See Also Send Feedback
Allows to record information about failures in the journal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void JournalFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic (Declaration)
Public Sub JournalFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void JournalFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::.IList <(Of <( FailureMessageAccessor >)>)
Accessors to the failures to journal.

Remarks

Records information about failure messages and elements involved in the failures. If this method not invoked, journal does not contain any information about failures resolved by (pre)processing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


PostFailure Method

[image]

Revit 2011 API
FailuresAccessor..::.PostFailure Method
FailuresAccessor Class See Also Send Feedback
Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void PostFailure(
    FailureMessage failure
)
Visual Basic (Declaration)
Public Sub PostFailure ( _
    failure As FailureMessage _
)
Visual C++
public:
void PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessage
Failure message to post.

Remarks

Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


ReplaceFailures Method

[image]

Revit 2011 API
FailuresAccessor..::.ReplaceFailures Method
FailuresAccessor Class See Also Send Feedback
Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ReplaceFailures(
    FailureMessage failure
)
Visual Basic (Declaration)
Public Sub ReplaceFailures ( _
    failure As FailureMessage _
)
Visual C++
public:
void ReplaceFailures(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.

Remarks

If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Severity of failure must be FailureSeverity::DocumentCorruption.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


ResolveFailure Method

[image]

Revit 2011 API
FailuresAccessor..::.ResolveFailure Method
FailuresAccessor Class See Also Send Feedback
Resolves one failure using the failure resolution type last set for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ResolveFailure(
    FailureMessageAccessor failure
)
Visual Basic (Declaration)
Public Sub ResolveFailure ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void ResolveFailure(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::.FailureMessageAccessor
The accessor to the failure to be resolved.

Remarks

If failure resolution type was not set, the default failure resolution type will be used. After execution of the failure resolution the failure will not be removed from the document automatically. To prevent the failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | failure has not been properly initialized. -or- failure does not have any resolutions. -or- Default resolution of failure is not permitted or not applicable. -or- The failure was already attempted to resolve twice with that resolution type.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


ResolveFailures Method

[image]

Revit 2011 API
FailuresAccessor..::.ResolveFailures Method
FailuresAccessor Class See Also Send Feedback
Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ResolveFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic (Declaration)
Public Sub ResolveFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void ResolveFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::.IList <(Of <( FailureMessageAccessor >)>)
The accessors to the failures to be resolved.

Remarks

After execution of the failure resolutions the failures will not be removed from the document automatically. To prevent failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Default resolution of one of the failures is not permitted or not applicable. -or- One of the failures was already attempted to resolve twice with that resolution type.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


RollBackPendingTransaction Method

[image]

Revit 2011 API
FailuresAccessor..::.RollBackPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Finishes pending failures processing by rolling back the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBackPendingTransaction()
Visual Basic (Declaration)
Public Function RollBackPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus RollBackPendingTransaction()

Return Value

Result of attempt to roll back the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state.

See Also

FailuresAccessor Class


SetFailureHandlingOptions Method

[image]

Revit 2011 API
FailuresAccessor..::.SetFailureHandlingOptions Method
FailuresAccessor Class See Also Send Feedback
Sets failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic (Declaration)
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.FailureHandlingOptions
The failure handling options to be set for the transaction currently being finished.

Remarks

If used with returning ProceedWithRollback from (pre)processing, allows to dismiss errors and roll back transaction without any further failures processing and silently for the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


SetTransactionName Method

[image]

Revit 2011 API
FailuresAccessor..::.SetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Changes the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetTransactionName(
    string transactionName
)
Visual Basic (Declaration)
Public Sub SetTransactionName ( _
    transactionName As String _
)
Visual C++
public:
void SetTransactionName(
    String^ transactionName
)

Parameters

transactionName
Type: System..::.String
The name of the transaction to set.

Remarks

If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved dy deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The transactionName is empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FailuresAccessor Class


FailureSeverity Enumeration

[image]

Revit 2011 API
FailureSeverity Enumeration
See Also Send Feedback
Enum represents severity of a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FailureSeverity
Visual Basic (Declaration)
Public Enumeration FailureSeverity
Visual C++
public enum class FailureSeverity

Members

Member name | Description
None | Represents a failure-free state of a document. This value cannot be used as an argument to construct FailureMesasage.
Warning | Failure that can be ignored by end-user. Failures of this severity do not prevent transactions from being committed.
Error | Failure that cannot be ignored. If FailureMeassage of this severity is posted, the current transaction cannot be committed unless failure is resolved via appropriate FailureResolution.
DocumentCorruption | Failure that forces Transaction to be rolled back as soon as possible due to known corruption to a document. When failure of this severity is posted, reading of information from a document is not allowed. The current transaction has to be rolled back first in order to work with the document.

See Also


Family Class

[image]

Revit 2011 API
Family Class
Members Example See Also Send Feedback
The Family object defines an entire family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Family : FamilyBase
Visual Basic (Declaration)
Public Class Family _
    Inherits FamilyBase
Visual C++
public ref class Family : public FamilyBase

Remarks

This object gets the family symbols that belong to the family so that instances can be swapped from one symbol to another. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Examples

CopyC#
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);

    if (family.Symbols.IsEmpty)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (FamilySymbol familySymbol in family.Symbols)
        {
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
           foreach (Material material in familySymbol.Materials)
           {
            message.AppendLine("\tMaterial: " + material.Name);
           }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Public Sub GetInfoForSymbols(ByVal family As Autodesk.Revit.DB.Family)
    Dim message As New StringBuilder("Selected element's family name is : " + family.Name)

    If family.Symbols.IsEmpty Then
        message.AppendLine("Contains no family symbols.")
    Else
        message.AppendLine("The family symbols contained in this family are : ")

        ' Get family symbols which is contained in this family
        For Each familySymbol As Autodesk.Revit.DB.FamilySymbol In family.Symbols
            ' Get family symbol name
            message.AppendLine(vbLf & "Name: " + familySymbol.Name)
            For Each material As Autodesk.Revit.DB.Material In familySymbol.Materials
                message.AppendLine(vbTab & "Material: " + material.Name)
            Next
        Next
    End If

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.FamilyBase
Autodesk.Revit.DB..::.Family

See Also

Family Members


Family Members

[image] [image]

Revit 2011 API
Family Members
Family Class Methods Properties See Also Send Feedback

The Family type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsEditable | Indicates if this family supports editing.
IsInPlace | Indicates if this family is an in-place family or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | Gets the family's structural material type. (Inherited from FamilyBase.)
Symbols | A set of all symbols (types) that belong to a Family.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Family Class


Family Methods

[image] [image]

Revit 2011 API
Family Methods
Family Class See Also Send Feedback

The Family type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Family Class


ExtractPartAtom Method

[image]

Revit 2011 API
Family..::.ExtractPartAtom Method
Family Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ExtractPartAtom(
    string xmlFilePath
)
Visual Basic (Declaration)
Public Sub ExtractPartAtom ( _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtom(
    String^ xmlFilePath
)

Parameters

xmlFilePath
Type: System..::.String
The xml file to be saved.

Remarks

This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.

See Also

Family Class


Family Properties

[image] [image]

Revit 2011 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
IsEditable | Indicates if this family supports editing.
IsInPlace | Indicates if this family is an in-place family or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | Gets the family's structural material type. (Inherited from FamilyBase.)
Symbols | A set of all symbols (types) that belong to a Family.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Family Class


CurtainPanelHorizontalSpacing Property

[image]

Revit 2011 API
Family..::.CurtainPanelHorizontalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the horizontal spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CurtainPanelHorizontalSpacing { get; set; }
Visual Basic (Declaration)
Public Property CurtainPanelHorizontalSpacing As Double
Visual C++
public:
property double CurtainPanelHorizontalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


CurtainPanelTilePattern Property

[image]

Revit 2011 API
Family..::.CurtainPanelTilePattern Property
Family Class See Also Send Feedback
For Curtain Panel families, the choice of tile pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TilePatternsBuiltIn CurtainPanelTilePattern { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainPanelTilePattern As TilePatternsBuiltIn
Visual C++
public:
property TilePatternsBuiltIn CurtainPanelTilePattern {
    TilePatternsBuiltIn get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


CurtainPanelVerticalSpacing Property

[image]

Revit 2011 API
Family..::.CurtainPanelVerticalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the vertical spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CurtainPanelVerticalSpacing { get; set; }
Visual Basic (Declaration)
Public Property CurtainPanelVerticalSpacing As Double
Visual C++
public:
property double CurtainPanelVerticalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


IsConceptualMassFamily Property

[image]

Revit 2011 API
Family..::.IsConceptualMassFamily Property
Family Class See Also Send Feedback
Whether the Family is a Conceptual Mass family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsConceptualMassFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConceptualMassFamily As Boolean
Visual C++
public:
property bool IsConceptualMassFamily {
    bool get ();
}

See Also

Family Class


IsCurtainPanelFamily Property

[image]

Revit 2011 API
Family..::.IsCurtainPanelFamily Property
Family Class See Also Send Feedback
Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCurtainPanelFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurtainPanelFamily As Boolean
Visual C++
public:
property bool IsCurtainPanelFamily {
    bool get ();
}

See Also

Family Class


IsEditable Property

[image]

Revit 2011 API
Family..::.IsEditable Property
Family Class See Also Send Feedback
Indicates if this family supports editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEditable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
}

See Also

Family Class


IsInPlace Property

[image]

Revit 2011 API
Family..::.IsInPlace Property
Family Class See Also Send Feedback
Indicates if this family is an in-place family or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInPlace { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInPlace As Boolean
Visual C++
public:
property bool IsInPlace {
    bool get ();
}

See Also

Family Class


Parameter Property

[image] [image]

Revit 2011 API
Family..::.Parameter Property
Family Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Family Class
Family Members


Symbols Property

[image]

Revit 2011 API
Family..::.Symbols Property
Family Class See Also Send Feedback
A set of all symbols (types) that belong to a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet Symbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbols As FamilySymbolSet
Visual C++
public:
property FamilySymbolSet^ Symbols {
    FamilySymbolSet^ get ();
}

Remarks

Returns a read only set of all the symbols that belong to a particular family. The family symbol objects within this set can be used to swap an instance from one type to another.

See Also

Family Class


FamilyBase Class

[image]

Revit 2011 API
FamilyBase Class
Members See Also Send Feedback
A base class for all Family objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyBase : Element
Visual Basic (Declaration)
Public Class FamilyBase _
    Inherits Element
Visual C++
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.FamilyBase
Autodesk.Revit.DB..::.Family

See Also

FamilyBase Members


FamilyBase Members

[image] [image]

Revit 2011 API
FamilyBase Members
FamilyBase Class Methods Properties See Also Send Feedback

The FamilyBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | Gets the family's structural material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilyBase Class


FamilyBase Methods

[image] [image]

Revit 2011 API
FamilyBase Methods
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyBase Class


FamilyBase Properties

[image] [image]

Revit 2011 API
FamilyBase Properties
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | Gets the family's structural material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilyBase Class


FamilyCategory Property

[image]

Revit 2011 API
FamilyBase..::.FamilyCategory Property
FamilyBase Class Example See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category FamilyCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyCategory As Category
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

Examples

CopyC#
public void GetBeamAndColumnSymbols(Document document)
{
    FamilySymbolSet columnTypes = new FamilySymbolSet();
    FamilySymbolSet framingTypes = new FamilySymbolSet();
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> elements = collector.OfClass(typeof(Family)).ToElements();

    foreach(Element element in elements)
    {
        Family tmpFamily = element as Family;
        Category category = tmpFamily.FamilyCategory;
        if (null != category)
        {
            if ((int)BuiltInCategory.OST_StructuralColumns == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    columnTypes.Insert(tmpSymbol);
                }
            }
            else if ((int)BuiltInCategory.OST_StructuralFraming == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    framingTypes.Insert(tmpSymbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    FamilySymbolSetIterator fsItor = columnTypes.ForwardIterator();
    fsItor.Reset();
    while (fsItor.MoveNext())
    {
        FamilySymbol familySybmol = fsItor.Current as FamilySymbol;
        message += "\n" + familySybmol.Name;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetBeamAndColumnSymbols(ByVal document As Document)
    Dim columnTypes As New FamilySymbolSet()
    Dim framingTypes As New FamilySymbolSet()
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim elements As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Family)).ToElements()

    For Each element As Autodesk.Revit.DB.Element In elements
        Dim tmpFamily As Family = TryCast(element, Family)
        Dim category As Category = tmpFamily.FamilyCategory
        If category IsNot Nothing Then
            If DirectCast(BuiltInCategory.OST_StructuralColumns, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    columnTypes.Insert(tmpSymbol)
                Next
            ElseIf DirectCast(BuiltInCategory.OST_StructuralFraming, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    framingTypes.Insert(tmpSymbol)
                Next
            End If
        End If
    Next

    Dim message As String = "Column Types: "
    Dim fsItor As FamilySymbolSetIterator = columnTypes.ForwardIterator()
    fsItor.Reset()
    While fsItor.MoveNext()
        Dim familySybmol As FamilySymbol = TryCast(fsItor.Current, FamilySymbol)
        message += vbLf + familySybmol.Name
    End While

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyBase Class


Parameter Property

[image] [image]

Revit 2011 API
FamilyBase..::.Parameter Property
FamilyBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilyBase Class
FamilyBase Members


StructuralMaterialType Property

[image]

Revit 2011 API
FamilyBase..::.StructuralMaterialType Property
FamilyBase Class See Also Send Feedback
Gets the family's structural material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

FamilyBase Class


FamilyElementVisibility Class

[image]

Revit 2011 API
FamilyElementVisibility Class
Members Example See Also Send Feedback
Provides access to the visibility parameters of family elements in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyElementVisibility : APIObject
Visual Basic (Declaration)
Public Class FamilyElementVisibility _
    Inherits APIObject
Visual C++
public ref class FamilyElementVisibility : public APIObject

Examples

CopyC#
public void CreateAndSetVisibility(Autodesk.Revit.DB.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = familyDocument.Application.Create.NewLineBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
CopyVB.NET
Public Sub CreateAndSetVisibility(ByVal familyDocument As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
    Dim p1 As New Autodesk.Revit.DB.XYZ(5, 1, 0)
    Dim line1 As Line = familyDocument.Application.Create.NewLineBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyElementVisibility

See Also

FamilyElementVisibility Members


FamilyElementVisibility Members

[image] [image]

Revit 2011 API
FamilyElementVisibility Members
FamilyElementVisibility Class Constructors Methods Properties See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Constructors

Name | Description
FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


FamilyElementVisibility Constructor

[image]

Revit 2011 API
FamilyElementVisibility Constructor
FamilyElementVisibility Class See Also Send Feedback
Initializes a new instance of the FamilyElementVisibility class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
Visual Basic (Declaration)
Public Sub New ( _
    visibilityType As FamilyElementVisibilityType _
)
Visual C++
public:
FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)

Parameters

visibilityType
Type: Autodesk.Revit.DB..::.FamilyElementVisibilityType

See Also

FamilyElementVisibility Class


FamilyElementVisibility Methods

[image] [image]

Revit 2011 API
FamilyElementVisibility Methods
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyElementVisibility Class


FamilyElementVisibility Properties

[image] [image]

Revit 2011 API
FamilyElementVisibility Properties
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


IsShownInCoarse Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInCoarse Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Coarse detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInCoarse { get; set; }
Visual Basic (Declaration)
Public Property IsShownInCoarse As Boolean
Visual C++
public:
property bool IsShownInCoarse {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInFine Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInFine Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Fine detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInFine { get; set; }
Visual Basic (Declaration)
Public Property IsShownInFine As Boolean
Visual C++
public:
property bool IsShownInFine {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInFrontBack Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInFrontBack Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Front/Back view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInFrontBack { get; set; }
Visual Basic (Declaration)
Public Property IsShownInFrontBack As Boolean
Visual C++
public:
property bool IsShownInFrontBack {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownInLeftRight Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInLeftRight Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Left/Right view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInLeftRight { get; set; }
Visual Basic (Declaration)
Public Property IsShownInLeftRight As Boolean
Visual C++
public:
property bool IsShownInLeftRight {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownInMedium Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInMedium Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Medium detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInMedium { get; set; }
Visual Basic (Declaration)
Public Property IsShownInMedium As Boolean
Visual C++
public:
property bool IsShownInMedium {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInPlanRCPCut Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInPlanRCPCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInPlanRCPCut { get; set; }
Visual Basic (Declaration)
Public Property IsShownInPlanRCPCut As Boolean
Visual C++
public:
property bool IsShownInPlanRCPCut {
    bool get ();
    void set (bool value);
}

Remarks

controls whether the Model Family Element is shown when a FamilyInstance of that Family is cut in a Plan/RCP view, i.e. the cut plane passes through the bounding box of the instance. It only has a meaning for categories that are "cut in the symbol". For non-cuttable categories it is always false and for ones that are "cuttable in the instance" it is the same as the IsShownInTopBottom.

See Also

FamilyElementVisibility Class


IsShownInTopBottom Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownInTopBottom Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Plan/RCP view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownInTopBottom { get; set; }
Visual Basic (Declaration)
Public Property IsShownInTopBottom As Boolean
Visual C++
public:
property bool IsShownInTopBottom {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownOnlyWhenCut Property

[image]

Revit 2011 API
FamilyElementVisibility..::.IsShownOnlyWhenCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed only if it has been cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShownOnlyWhenCut { get; set; }
Visual Basic (Declaration)
Public Property IsShownOnlyWhenCut As Boolean
Visual C++
public:
property bool IsShownOnlyWhenCut {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects which visibility type is ViewSpecific.

See Also

FamilyElementVisibility Class


VisibilityType Property

[image]

Revit 2011 API
FamilyElementVisibility..::.VisibilityType Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is Model or View specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibilityType VisibilityType { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibilityType As FamilyElementVisibilityType
Visual C++
public:
property FamilyElementVisibilityType VisibilityType {
    FamilyElementVisibilityType get ();
}

See Also

FamilyElementVisibility Class


FamilyElementVisibilityType Enumeration

[image]

Revit 2011 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visibility type of generic forms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic (Declaration)
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum to indicate the visibility type of new forms.

See Also


FamilyHostingBehavior Enumeration

[image]

Revit 2011 API
FamilyHostingBehavior Enumeration
See Also Send Feedback
Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FamilyHostingBehavior
Visual Basic (Declaration)
Public Enumeration FamilyHostingBehavior
Visual C++
public enum class FamilyHostingBehavior

Members

Member name | Description
None |
Wall |
Floor |
Ceiling |
Roof |
Face |

See Also


FamilyInstance Class

[image]

Revit 2011 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyInstance : Instance
Visual Basic (Declaration)
Public Class FamilyInstance _
    Inherits Instance
Visual C++
public ref class FamilyInstance : public Instance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance AnalyticalModel type
    if (null != familyInstance.GetAnalyticalModel())
    {
        message += "\nFamilyInstance AnalyticalModel is : " + familyInstance.GetAnalyticalModel();
    }

    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    // Get FamilyInstance Material
    foreach (Material material in familyInstance.Materials)
    {
       message += "\nFamilyInstance Material is : " + material.Name;
    }
    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = "FamilyInstance : "
    ' Get FamilyInstance AnalyticalModel type
    If familyInstance.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "FamilyInstance AnalyticalModel is : " & familyInstance.GetAnalyticalModel().ToString()
    End If

    ' Get FamilyInstance host name
    If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " + familyInstance.Host.Name
    End If

    ' Get FamilyInstance Material
    For Each material As Autodesk.Revit.DB.Material In familyInstance.Materials
        message += vbLf & "FamilyInstance Material is : " + material.Name
    Next
    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " + familyInstance.Room.Name
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " + familyInstance.StructuralType

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " + familyInstance.StructuralUsage

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.FamilyInstance
Autodesk.Revit.DB..::.AnnotationSymbol
Autodesk.Revit.DB..::.Mullion
Autodesk.Revit.DB..::.Panel

See Also

FamilyInstance Members


FamilyInstance Members

[image] [image]

Revit 2011 API
FamilyInstance Members
FamilyInstance Class Methods Properties See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub components of current family instance.
SuperComponent | Property to get the super component of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilyInstance Class


FamilyInstance Methods

[image] [image]

Revit 2011 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
FlipFromToRoom | Change the room to which the door or window is opened.
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam.
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.
SetCopings | Specify the set of coping cutters on this element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstance Class


AddCoping Method

[image]

Revit 2011 API
FamilyInstance..::.AddCoping Method
FamilyInstance Class See Also Send Feedback
Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::.FamilyInstance
A steel beam or column. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


flipFacing Method

[image]

Revit 2011 API
FamilyInstance..::.flipFacing Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool flipFacing()
Visual Basic (Declaration)
Public Function flipFacing As Boolean
Visual C++
public:
bool flipFacing()

See Also

FamilyInstance Class


FlipFromToRoom Method

[image]

Revit 2011 API
FamilyInstance..::.FlipFromToRoom Method
FamilyInstance Class See Also Send Feedback
Change the room to which the door or window is opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void FlipFromToRoom()
Visual Basic (Declaration)
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom()

Remarks

The FromRoom and ToRoom properties of current family instance's swap after calling this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when current family instance is neither door nor window.

See Also

FamilyInstance Class


flipHand Method

[image]

Revit 2011 API
FamilyInstance..::.flipHand Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool flipHand()
Visual Basic (Declaration)
Public Function flipHand As Boolean
Visual C++
public:
bool flipHand()

See Also

FamilyInstance Class


GetCopings Method

[image]

Revit 2011 API
FamilyInstance..::.GetCopings Method
FamilyInstance Class See Also Send Feedback
Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet GetCopings()
Visual Basic (Declaration)
Public Function GetCopings As ElementSet
Visual C++
public:
ElementSet^ GetCopings()

See Also

FamilyInstance Class


GetFamilyPointPlacementReferences Method

[image]

Revit 2011 API
FamilyInstance..::.GetFamilyPointPlacementReferences Method
FamilyInstance Class See Also Send Feedback
Returns the Point Placement References for the Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<FamilyPointPlacementReference> GetFamilyPointPlacementReferences()
Visual Basic (Declaration)
Public Function GetFamilyPointPlacementReferences As IList(Of FamilyPointPlacementReference)
Visual C++
public:
IList<FamilyPointPlacementReference^>^ GetFamilyPointPlacementReferences()

Remarks

If a family instance has point placement references then they are returned by this method, otherwise an empty collection is returned. Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

See Also

FamilyInstance Class


RemoveCoping Method

[image]

Revit 2011 API
FamilyInstance..::.RemoveCoping Method
FamilyInstance Class See Also Send Feedback
Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic (Declaration)
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::.FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


rotate Method

[image]

Revit 2011 API
FamilyInstance..::.rotate Method
FamilyInstance Class See Also Send Feedback
The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool rotate()
Visual Basic (Declaration)
Public Function rotate As Boolean
Visual C++
public:
bool rotate()

See Also

FamilyInstance Class


SetCopings Method

[image]

Revit 2011 API
FamilyInstance..::.SetCopings Method
FamilyInstance Class See Also Send Feedback
Specify the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SetCopings(
    ElementSet cutters
)
Visual Basic (Declaration)
Public Function SetCopings ( _
    cutters As ElementSet _
) As Boolean
Visual C++
public:
bool SetCopings(
    ElementSet^ cutters
)

Parameters

cutters
Type: Autodesk.Revit.DB..::.ElementSet
A set of coping cutters (steel beams and steel columns).

Remarks

The set must contain elements of FamilyInstance type only. The set may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when 'cutters' contains this instance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


FamilyInstance Properties

[image] [image]

Revit 2011 API
FamilyInstance Properties
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
CanRotate | Property to test whether the family instance can be rotated by 180 degree.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
FacingOrientation | Property to get the orientation of family instance facing.
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped.
HandOrientation | Property to get the orientation of family instance hand.
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance.
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made.
StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
SubComponents | Property to get the sub components of current family instance.
SuperComponent | Property to get the super component of current family instance.
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilyInstance Class


CanFlipFacing Property

[image]

Revit 2011 API
FamilyInstance..::.CanFlipFacing Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanFlipFacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFlipFacing As Boolean
Visual C++
public:
property bool CanFlipFacing {
    bool get ();
}

See Also

FamilyInstance Class


CanFlipHand Property

[image]

Revit 2011 API
FamilyInstance..::.CanFlipHand Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanFlipHand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFlipHand As Boolean
Visual C++
public:
property bool CanFlipHand {
    bool get ();
}

See Also

FamilyInstance Class


CanRotate Property

[image]

Revit 2011 API
FamilyInstance..::.CanRotate Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance can be rotated by 180 degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanRotate { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanRotate As Boolean
Visual C++
public:
property bool CanRotate {
    bool get ();
}

See Also

FamilyInstance Class


ExtensionUtility Property

[image]

Revit 2011 API
FamilyInstance..::.ExtensionUtility Property
FamilyInstance Class See Also Send Feedback
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtensionUtility As IExtension
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


FacingFlipped Property

[image]

Revit 2011 API
FamilyInstance..::.FacingFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool FacingFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property FacingFlipped As Boolean
Visual C++
public:
property bool FacingFlipped {
    bool get ();
}

See Also

FamilyInstance Class


FacingOrientation Property

[image]

Revit 2011 API
FamilyInstance..::.FacingOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ FacingOrientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property FacingOrientation As XYZ
Visual C++
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


FromRoom Property

[image] [image]

Revit 2011 API
FamilyInstance..::.FromRoom Property
FamilyInstance Class See Also Send Feedback
The room from which the door or window is opened.

Overload List

Name | Description
FromRoom | The room from which the door is opened at the last phase of the project.
FromRoom[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


FromRoom Property

[image]

Revit 2011 API
FamilyInstance..::.FromRoom Property
FamilyInstance Class See Also Send Feedback
The room from which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room FromRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property FromRoom As Room
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
FromRoom Overload


FromRoom Property (Phase)

[image]

Revit 2011 API
FamilyInstance..::.FromRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room FromRoom[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FromRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase

See Also

FamilyInstance Class
FromRoom Overload


HandFlipped Property

[image]

Revit 2011 API
FamilyInstance..::.HandFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HandFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property HandFlipped As Boolean
Visual C++
public:
property bool HandFlipped {
    bool get ();
}

See Also

FamilyInstance Class


HandOrientation Property

[image]

Revit 2011 API
FamilyInstance..::.HandOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ HandOrientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property HandOrientation As XYZ
Visual C++
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


Host Property

[image]

Revit 2011 API
FamilyInstance..::.Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained. Another example is an instance that is hosted to a planar or curved face in a Mass element will return the Mass element.

See Also

FamilyInstance Class


IsSlantedColumn Property

[image]

Revit 2011 API
FamilyInstance..::.IsSlantedColumn Property
FamilyInstance Class See Also Send Feedback
Indicates if the family instance is a slanted column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSlantedColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSlantedColumn As Boolean
Visual C++
public:
property bool IsSlantedColumn {
    bool get ();
}

Remarks

If the family instance is a slanted column, it returns true, otherwise returns false.

See Also

FamilyInstance Class


Location Property

[image]

Revit 2011 API
FamilyInstance..::.Location Property
FamilyInstance Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.

See Also

FamilyInstance Class


MEPModel Property

[image]

Revit 2011 API
FamilyInstance..::.MEPModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPModel MEPModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPModel As MEPModel
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class


Mirrored Property

[image]

Revit 2011 API
FamilyInstance..::.Mirrored Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Mirrored { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mirrored As Boolean
Visual C++
public:
property bool Mirrored {
    bool get ();
}

See Also

FamilyInstance Class


Parameter Property

[image] [image]

Revit 2011 API
FamilyInstance..::.Parameter Property
FamilyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image] [image]

Revit 2011 API
FamilyInstance..::.Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located.

Overload List

Name | Description
Room | The room in which the instance is located (during the last phase of the project).
Room[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image]

Revit 2011 API
FamilyInstance..::.Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
Room Overload


Room Property (Phase)

[image]

Revit 2011 API
FamilyInstance..::.Room Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room Room[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase

See Also

FamilyInstance Class
Room Overload


Space Property

[image] [image]

Revit 2011 API
FamilyInstance..::.Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located.

Overload List

Name | Description
Space | The space in which the instance is located (during the last phase of the project).
Space[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Space Property

[image]

Revit 2011 API
FamilyInstance..::.Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
Space Overload


Space Property (Phase)

[image]

Revit 2011 API
FamilyInstance..::.Space Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space Space[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space ( _
    phase As Phase _
) As Space
Visual C++
public:
property Space^ Space[Phase^ phase] {
    Space^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase

See Also

FamilyInstance Class
Space Overload


StructuralMaterialType Property

[image]

Revit 2011 API
FamilyInstance..::.StructuralMaterialType Property
FamilyInstance Class See Also Send Feedback
This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class


StructuralType Property

[image]

Revit 2011 API
FamilyInstance..::.StructuralType Property
FamilyInstance Class Example See Also Send Feedback
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralType As StructuralType
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetStructuralType(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case Autodesk.Revit.DB.Structure.StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


StructuralUsage Property

[image]

Revit 2011 API
FamilyInstance..::.StructuralUsage Property
FamilyInstance Class See Also Send Feedback
Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As StructuralInstanceUsage
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
    void set (StructuralInstanceUsage value);
}

See Also

FamilyInstance Class


SubComponents Property

[image]

Revit 2011 API
FamilyInstance..::.SubComponents Property
FamilyInstance Class Example See Also Send Feedback
Property to get the sub components of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet SubComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property SubComponents As ElementSet
Visual C++
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When current familyinstance has no sub component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ElementSet subElemSet = familyInstance.SubComponents;
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.DB.Element ee in subElemSet)
        {
            FamilyInstance f = ee as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        TaskDialog.Show("Revit","Subcomponent count = " + subElemSet.Size + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        TaskDialog.Show("Revit","SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim subElemSet As ElementSet = familyInstance.SubComponents
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.DB.Element In subElemSet
            Dim f As Autodesk.Revit.DB.FamilyInstance = TryCast(ee, Autodesk.Revit.DB.FamilyInstance)
            subElems = subElems + f.Name + vbLf
        Next
        TaskDialog.Show("Revit", "Subcomponent count = " + subElemSet.Size + vbLf + subElems)
    End If
    Dim super As Autodesk.Revit.DB.FamilyInstance = TryCast(familyInstance.SuperComponent, Autodesk.Revit.DB.FamilyInstance)
    If super IsNot Nothing Then
        TaskDialog.Show("Revit", "SUPER component: " + super.Name)
    End If
End Sub

See Also

FamilyInstance Class


SuperComponent Property

[image]

Revit 2011 API
FamilyInstance..::.SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element SuperComponent { get; }
Visual Basic (Declaration)
Public ReadOnly Property SuperComponent As Element
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When current familyinstance has no super component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


Symbol Property

[image]

Revit 2011 API
FamilyInstance..::.Symbol Property
FamilyInstance Class Example See Also Send Feedback
Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As FamilySymbol
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

Examples

CopyC#
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance_Symbol(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " + familyInstance.Symbol.Name

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name
    End If
    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


ToRoom Property

[image] [image]

Revit 2011 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door or window is opened.

Overload List

Name | Description
ToRoom | The room to which the door is opened at the last phase of the project.
ToRoom[([(Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


ToRoom Property

[image]

Revit 2011 API
FamilyInstance..::.ToRoom Property
FamilyInstance Class See Also Send Feedback
The room to which the door is opened at the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom As Room
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Remarks

When current familyinstance is neither door nor window, this property will always return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
ToRoom Overload


ToRoom Property (Phase)

[image]

Revit 2011 API
FamilyInstance..::.ToRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room ToRoom[
    Phase phase
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::.Phase

See Also

FamilyInstance Class
ToRoom Overload


FamilyInstanceFilter Class

[image]

Revit 2011 API
FamilyInstanceFilter Class
Members Example See Also Send Feedback
A filter used to find elements that are family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FamilyInstanceFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class FamilyInstanceFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class FamilyInstanceFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

// Find all family symbols whose name is "W10X49"
FilteredElementCollector collector = new FilteredElementCollector(document);
collector = collector.OfClass(typeof(FamilySymbol));

// Get Element Id for family symbol which will be used to find family instances
var query = from element in collector where element.Name == "W10X49" select element;
List<Element> famSyms = query.ToList<Element>();
ElementId symbolId = famSyms[0].Id;

// Create a FamilyInstance filter with the FamilySymbol Id
FamilyInstanceFilter filter = new FamilyInstanceFilter(document, symbolId);

// Apply the filter to the elements in the active document
collector = new FilteredElementCollector(document);
ICollection<Element> familyInstances = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

' Find all family symbols whose name is "W10X49"
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector = collector.OfClass(GetType(FamilySymbol))

' Get Element Id for family symbol which will be used to find family instances
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "W10X49" _
 Select element
Dim famSyms As List(Of Autodesk.Revit.DB.Element) = query.ToList()
Dim symbolId As ElementId = famSyms(0).Id

' Create a FamilyInstance filter with the FamilySymbol Id
Dim filter As New FamilyInstanceFilter(document, symbolId)

' Apply the filter to the elements in the active document
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim familyInstances As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.FamilyInstanceFilter

See Also

FamilyInstanceFilter Members


FamilyInstanceFilter Members

[image] [image]

Revit 2011 API
FamilyInstanceFilter Members
FamilyInstanceFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Constructors

Name | Description
FamilyInstanceFilter | Constructs a new instance of a filter to match family instances of the given family symbol.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FamilySymbolId | The family symbol id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Constructor

[image]

Revit 2011 API
FamilyInstanceFilter Constructor
FamilyInstanceFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilyInstanceFilter(
    Document document,
    ElementId familySymbolId
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    familySymbolId As ElementId _
)
Visual C++
public:
FamilyInstanceFilter(
    Document^ document,
    ElementId^ familySymbolId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId
Type: Autodesk.Revit.DB..::.ElementId
The family symbol id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The familySymbolId does not represent a valid FamilySymbol record in the document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Methods

[image] [image]

Revit 2011 API
FamilyInstanceFilter Methods
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Properties

[image] [image]

Revit 2011 API
FamilyInstanceFilter Properties
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Properties

Name | Description
FamilySymbolId | The family symbol id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilySymbolId Property

[image]

Revit 2011 API
FamilyInstanceFilter..::.FamilySymbolId Property
FamilyInstanceFilter Class See Also Send Feedback
The family symbol id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId FamilySymbolId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilySymbolId As ElementId
Visual C++
public:
property ElementId^ FamilySymbolId {
    ElementId^ get ();
}

See Also

FamilyInstanceFilter Class


FamilyManager Class

[image]

Revit 2011 API
FamilyManager Class
Members See Also Send Feedback
The family manager object to manage the family types and parameters in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyManager : APIObject
Visual Basic (Declaration)
Public Class FamilyManager _
    Inherits APIObject
Visual C++
public ref class FamilyManager : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyManager

See Also

FamilyManager Members


FamilyManager Members

[image] [image]

Revit 2011 API
FamilyManager Members
FamilyManager Class Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

Name | Description
AddParameter | Overloaded. Add a new parameter to the family.
AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
DeleteCurrentType | Remove the current family type.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
MakeInstance | Set the family parameter as an instance parameter.
MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
MakeReporting | Set the family parameter as a reporting parameter.
MakeType | Set the family parameter as a type parameter.
NewType | Add a new family type with a given name and makes it be the current type.
RemoveParameter | Remove an existing family parameter from the family.
RenameCurrentType | Rename the current family type.
RenameParameter | Rename a family parameter.
ReplaceParameter | Overloaded.
Set | Overloaded. Set the value of a family parameter of the current family type.
SetFormula | Set the formula of a family parameter.
SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
SetValueString | Set the string value of a family parameter of the current family type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentType | The current family type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Overloaded. Obtains a parameter based on an identifier.
Parameters | All family parameters in this family.
Types | All family types in the family.

See Also

FamilyManager Class


FamilyManager Methods

[image] [image]

Revit 2011 API
FamilyManager Methods
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

Name | Description
AddParameter | Overloaded. Add a new parameter to the family.
AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
DeleteCurrentType | Remove the current family type.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
MakeInstance | Set the family parameter as an instance parameter.
MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
MakeReporting | Set the family parameter as a reporting parameter.
MakeType | Set the family parameter as a type parameter.
NewType | Add a new family type with a given name and makes it be the current type.
RemoveParameter | Remove an existing family parameter from the family.
RenameCurrentType | Rename the current family type.
RenameParameter | Rename a family parameter.
ReplaceParameter | Overloaded.
Set | Overloaded. Set the value of a family parameter of the current family type.
SetFormula | Set the formula of a family parameter.
SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
SetValueString | Set the string value of a family parameter of the current family type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyManager Class


AddParameter Method

[image] [image]

Revit 2011 API
FamilyManager..::.AddParameter Method
FamilyManager Class See Also Send Feedback
Add a new parameter to the family.

Overload List

Name | Description
AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.

See Also

FamilyManager Class
FamilyManager Members


AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2011 API
FamilyManager..::.AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.DB..::.ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The group to which the family parameter belongs.
isInstance
Type: System..::.Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the shared family parameter creation is not supported.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)

[image]

Revit 2011 API
FamilyManager..::.AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family type parameter to control the type of a nested family within another family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    Category familyCategory,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    familyCategory As Category, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    Category^ familyCategory,
    bool isInstance
)

Parameters

parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The group to which the family parameter belongs.
familyCategory
Type: Autodesk.Revit.DB..::.Category
The category to which the new family parameter binds.
isInstance
Type: System..::.Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input argument-"familyCategory"-is illegal to bind with parameter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)

[image]

Revit 2011 API
FamilyManager..::.AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family parameter with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    parameterType As ParameterType, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)

Parameters

parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The group to which the family parameter belongs.
parameterType
Type: Autodesk.Revit.DB..::.ParameterType
The type of new family parameter.
isInstance
Type: System..::.Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"parameterType" is an invalid type. Also thrown when "parameterType" is FamilyType; to add a parameter of this type use the AddParameter method that accepts a category instead.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter creation failed.

See Also

FamilyManager Class
AddParameter Overload


AssociateElementParameterToFamilyParameter Method

[image]

Revit 2011 API
FamilyManager..::.AssociateElementParameterToFamilyParameter Method
FamilyManager Class See Also Send Feedback
Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub AssociateElementParameterToFamilyParameter ( _
    elementParameter As Parameter, _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::.Parameter
The parameter of an element in family.
familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The existing family parameter. If the input to this argument is nullNothingnullptra null reference (Nothing in Visual Basic), it will disassociate the element parameter from any family parameters.

Remarks

The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter binding failed.

See Also

FamilyManager Class


CanElementParameterBeAssociated Method

[image]

Revit 2011 API
FamilyManager..::.CanElementParameterBeAssociated Method
FamilyManager Class See Also Send Feedback
Indicates if this element parameter can be associated with a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanElementParameterBeAssociated(
    Parameter elementParameter
)
Visual Basic (Declaration)
Public Function CanElementParameterBeAssociated ( _
    elementParameter As Parameter _
) As Boolean
Visual C++
public:
bool CanElementParameterBeAssociated(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::.Parameter

See Also

FamilyManager Class


DeleteCurrentType Method

[image]

Revit 2011 API
FamilyManager..::.DeleteCurrentType Method
FamilyManager Class See Also Send Feedback
Remove the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DeleteCurrentType()
Visual Basic (Declaration)
Public Sub DeleteCurrentType
Visual C++
public:
void DeleteCurrentType()

Remarks

If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is only one family type in current document.

See Also

FamilyManager Class


GetAssociatedFamilyParameter Method

[image]

Revit 2011 API
FamilyManager..::.GetAssociatedFamilyParameter Method
FamilyManager Class See Also Send Feedback
Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Visual Basic (Declaration)
Public Function GetAssociatedFamilyParameter ( _
    elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::.Parameter
The parameter of an element in family.

Return Value

The associated family parameter if there is an association between them, returns nullNothingnullptra null reference (Nothing in Visual Basic) if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyManager Class


IsParameterLockable Method

[image]

Revit 2011 API
FamilyManager..::.IsParameterLockable Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLockable ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.

See Also

FamilyManager Class


IsParameterLocked Method

[image]

Revit 2011 API
FamilyManager..::.IsParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function IsParameterLocked ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

True if the parameter is lockable and is locked; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.

See Also

FamilyManager Class


MakeInstance Method

[image]

Revit 2011 API
FamilyManager..::.MakeInstance Method
FamilyManager Class See Also Send Feedback
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is Type family parameter driven by this parameter.

See Also

FamilyManager Class


MakeNonReporting Method

[image]

Revit 2011 API
FamilyManager..::.MakeNonReporting Method
FamilyManager Class See Also Send Feedback
Set the reporting family parameter as a regular/driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeNonReporting(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeNonReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeNonReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to make a parameter which is labeled to an arc length dimension non-reporting.

See Also

FamilyManager Class


MakeReporting Method

[image]

Revit 2011 API
FamilyManager..::.MakeReporting Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeReporting(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter can not be changed to a reporting parameter.

See Also

FamilyManager Class


MakeType Method

[image]

Revit 2011 API
FamilyManager..::.MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class


NewType Method

[image]

Revit 2011 API
FamilyManager..::.NewType Method
FamilyManager Class Example See Also Send Feedback
Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyType NewType(
    string typeName
)
Visual Basic (Declaration)
Public Function NewType ( _
    typeName As String _
) As FamilyType
Visual C++
public:
FamilyType^ NewType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The name of new family type.

Examples

CopyC#
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc)
        {
            FamilyManager familyManager = familyDoc.FamilyManager;

            // add a new type and edit its parameters
            FamilyType newFamilyType = familyManager.NewType("2X2");

            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }
            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }

            // now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document);
            // find the new type and assign it to FamilyInstance
            FamilySymbolSetIterator symbolsItor = family.Symbols.ForwardIterator();
            symbolsItor.Reset();
            while (symbolsItor.MoveNext())
            {
                FamilySymbol familySymbol = symbolsItor.Current as FamilySymbol;
                if (familySymbol.Name == "2X2")
                {
                    familyInstance.Symbol = familySymbol;
                    break;
                }
            }
        }
    }
}
CopyVB.NET
Public Sub EditFamilyTypes(ByVal document As Document, ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing Then
            Dim familyManager As FamilyManager = familyDoc.FamilyManager

            ' add a new type and edit its parameters
            Dim newFamilyType As FamilyType = familyManager.NewType("2X2")

            ' look for 'b' and 'h' parameters and set them to 2 feet
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2)
            End If
            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2)
            End If

            ' now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document)
            ' find the new type and assign it to FamilyInstance
            Dim symbolsItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
            symbolsItor.Reset()
            While symbolsItor.MoveNext()
                Dim familySymbol As FamilySymbol = TryCast(symbolsItor.Current, FamilySymbol)
                If familySymbol.Name = "2X2" Then
                    familyInstance.Symbol = familySymbol
                    Exit While
                End If
            End While
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family type creation failed.

See Also

FamilyManager Class


RemoveParameter Method

[image]

Revit 2011 API
FamilyManager..::.RemoveParameter Method
FamilyManager Class See Also Send Feedback
Remove an existing family parameter from the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveParameter(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Sub RemoveParameter ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void RemoveParameter(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter.

Remarks

Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter deletion failed.

See Also

FamilyManager Class


RenameCurrentType Method

[image]

Revit 2011 API
FamilyManager..::.RenameCurrentType Method
FamilyManager Class See Also Send Feedback
Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RenameCurrentType(
    string typeName
)
Visual Basic (Declaration)
Public Sub RenameCurrentType ( _
    typeName As String _
)
Visual C++
public:
void RenameCurrentType(
    String^ typeName
)

Parameters

typeName
Type: System..::.String
The new name of the current family type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family type rename failed.

See Also

FamilyManager Class


RenameParameter Method

[image]

Revit 2011 API
FamilyManager..::.RenameParameter Method
FamilyManager Class See Also Send Feedback
Rename a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RenameParameter(
    FamilyParameter familyParameter,
    string name
)
Visual Basic (Declaration)
Public Sub RenameParameter ( _
    familyParameter As FamilyParameter, _
    name As String _
)
Visual C++
public:
void RenameParameter(
    FamilyParameter^ familyParameter,
    String^ name
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter.
name
Type: System..::.String
The new name.

Remarks

This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter.

See Also

FamilyManager Class


ReplaceParameter Method

[image] [image]

Revit 2011 API
FamilyManager..::.ReplaceParameter Method
FamilyManager Class See Also Send Feedback

Overload List

Name | Description
ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Replace a family parameter with a shared parameter.
ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Replace a shared family parameter with a new non-shared family parameter.

See Also

FamilyManager Class
FamilyManager Members


ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2011 API
FamilyManager..::.ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a family parameter with a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic (Declaration)
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The current family parameter.
familyDefinition
Type: Autodesk.Revit.DB..::.ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The group to which the new shared parameter belongs.
isInstance
Type: System..::.Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This operation is invalid for Built-in Parameters. The formulas and labels which in reference to this parameter will be updated to the new parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input argument-"parameterGroup"-is illegal, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to replace a built-in parameter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error.

See Also

FamilyManager Class
ReplaceParameter Overload


ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)

[image]

Revit 2011 API
FamilyManager..::.ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a shared family parameter with a new non-shared family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic (Declaration)
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The current family parameter.
parameterName
Type: System..::.String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The group to which the new family parameter belongs.
isInstance
Type: System..::.Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input argument-"parameterGroup"-is illegal, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error.

See Also

FamilyManager Class
ReplaceParameter Overload


Set Method

[image] [image]

Revit 2011 API
FamilyManager..::.Set Method
FamilyManager Class See Also Send Feedback
Set the value of a family parameter of the current family type.

Overload List

Name | Description
Set(FamilyParameter, ElementId) | Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.
Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.

See Also

FamilyManager Class
FamilyManager Members


Set Method (FamilyParameter, ElementId)

[image]

Revit 2011 API
FamilyManager..::.Set Method (FamilyParameter, ElementId)
FamilyManager Class See Also Send Feedback
Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    ElementId value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As ElementId _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    ElementId^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter of current type.
value
Type: Autodesk.Revit.DB..::.ElementId
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, Double)

[image]

Revit 2011 API
FamilyManager..::.Set Method (FamilyParameter, Double)
FamilyManager Class See Also Send Feedback
Set the double value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    double value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Double _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    double value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.Double
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, Int32)

[image]

Revit 2011 API
FamilyManager..::.Set Method (FamilyParameter, Int32)
FamilyManager Class See Also Send Feedback
Set the integer value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    int value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Integer _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    int value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.Int32
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, String)

[image]

Revit 2011 API
FamilyManager..::.Set Method (FamilyParameter, String)
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


SetFormula Method

[image]

Revit 2011 API
FamilyManager..::.SetFormula Method
FamilyManager Class See Also Send Feedback
Set the formula of a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetFormula(
    FamilyParameter familyParameter,
    string formula
)
Visual Basic (Declaration)
Public Sub SetFormula ( _
    familyParameter As FamilyParameter, _
    formula As String _
)
Visual C++
public:
void SetFormula(
    FamilyParameter^ familyParameter,
    String^ formula
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter.
formula
Type: System..::.String
The formula string, input nullNothingnullptra null reference (Nothing in Visual Basic) to clean the formula of the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is no valid family type, or the parameter cannot be assigned a formula, or the operation make a circular chain of references among the formulas.

See Also

FamilyManager Class


SetParameterLocked Method

[image]

Revit 2011 API
FamilyManager..::.SetParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Visual Basic (Declaration)
Public Sub SetParameterLocked ( _
    familyParameter As FamilyParameter, _
    locked As Boolean _
)
Visual C++
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
locked
Type: System..::.Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the parameter is not lockable.

See Also

FamilyManager Class


SetValueString Method

[image]

Revit 2011 API
FamilyManager..::.SetValueString Method
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Visual Basic (Declaration)
Public Sub SetValueString ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter
The family parameter of current type.
value
Type: System..::.String
The new value string for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.

See Also

FamilyManager Class


FamilyManager Properties

[image] [image]

Revit 2011 API
FamilyManager Properties
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Properties

Name | Description
CurrentType | The current family type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | Overloaded. Obtains a parameter based on an identifier.
Parameters | All family parameters in this family.
Types | All family types in the family.

See Also

FamilyManager Class


CurrentType Property

[image]

Revit 2011 API
FamilyManager..::.CurrentType Property
FamilyManager Class See Also Send Feedback
The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyType CurrentType { get; set; }
Visual Basic (Declaration)
Public Property CurrentType As FamilyType
Visual C++
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}

Remarks

Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).

See Also

FamilyManager Class


Parameter Property

[image] [image]

Revit 2011 API
FamilyManager..::.Parameter Property
FamilyManager Class See Also Send Feedback
Obtains a parameter based on an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Parameter[([(Definition])]) | Obtains the parameter of this type with a given definition.
Parameter[([(Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Parameter[([(String])]) | Obtains the parameter of this type with a given name.

See Also

FamilyManager Class
FamilyManager Members


Parameter Property (BuiltInParameter)

[image]

Revit 2011 API
FamilyManager..::.Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    BuiltInParameter parameterId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::.BuiltInParameter

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2011 API
FamilyManager..::.Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Definition definition
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::.Definition

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (Guid)

[image]

Revit 2011 API
FamilyManager..::.Parameter Property (Guid)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    Guid guid
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System..::.Guid

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (String)

[image]

Revit 2011 API
FamilyManager..::.Parameter Property (String)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameter Parameter[
    string parameterName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameter ( _
    parameterName As String _
) As FamilyParameter
Visual C++
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}

Parameters

parameterName
Type: System..::.String

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameters Property

[image]

Revit 2011 API
FamilyManager..::.Parameters Property
FamilyManager Class See Also Send Feedback
All family parameters in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameterSet Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As FamilyParameterSet
Visual C++
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}

Remarks

These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.

See Also

FamilyManager Class


Types Property

[image]

Revit 2011 API
FamilyManager..::.Types Property
FamilyManager Class Example See Also Send Feedback
All family types in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyTypeSet Types { get; }
Visual Basic (Declaration)
Public ReadOnly Property Types As FamilyTypeSet
Visual C++
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}

Examples

CopyC#
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument == true)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        TaskDialog.Show("Revit",types);
    }
}
CopyVB.NET
Public Sub GetFamilyTypesInFamily(ByVal familyDoc As Document)
    If familyDoc.IsFamilyDocument = True Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf + familyType.Name
        End While
        TaskDialog.Show("Revit", types)
    End If
End Sub

See Also

FamilyManager Class


FamilyParameter Class

[image]

Revit 2011 API
FamilyParameter Class
Members See Also Send Feedback
The family parameter object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyParameter : APIObject
Visual Basic (Declaration)
Public Class FamilyParameter _
    Inherits APIObject
Visual C++
public ref class FamilyParameter : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyParameter

See Also

FamilyParameter Members


FamilyParameter Members

[image] [image]

Revit 2011 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
Id | The id of the family parameter.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReporting | Indicates if the parameter is a reporting parameter.
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class


FamilyParameter Methods

[image] [image]

Revit 2011 API
FamilyParameter Methods
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameter Class


FamilyParameter Properties

[image] [image]

Revit 2011 API
FamilyParameter Properties
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Properties

Name | Description
AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
CanAssignFormula | Indicates if this parameter can be assigned a formula.
Definition | The definition.
DisplayUnitType | The display unit type.
Formula | The formula.
Id | The id of the family parameter.
IsDeterminedByFormula | Indicates if the parameter is determined by formula.
IsInstance | Indicates if the parameter is instance or type.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsReporting | Indicates if the parameter is a reporting parameter.
StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class


AssociatedParameters Property

[image]

Revit 2011 API
FamilyParameter..::.AssociatedParameters Property
FamilyParameter Class See Also Send Feedback
The parameters from elements in the family which are associated to this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterSet AssociatedParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssociatedParameters As ParameterSet
Visual C++
public:
property ParameterSet^ AssociatedParameters {
    ParameterSet^ get ();
}

See Also

FamilyParameter Class


CanAssignFormula Property

[image]

Revit 2011 API
FamilyParameter..::.CanAssignFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if this parameter can be assigned a formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanAssignFormula { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanAssignFormula As Boolean
Visual C++
public:
property bool CanAssignFormula {
    bool get ();
}

See Also

FamilyParameter Class


Definition Property

[image]

Revit 2011 API
FamilyParameter..::.Definition Property
FamilyParameter Class See Also Send Feedback
The definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

FamilyParameter Class


DisplayUnitType Property

[image]

Revit 2011 API
FamilyParameter..::.DisplayUnitType Property
FamilyParameter Class See Also Send Feedback
The display unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this parameter is not of value type.

See Also

FamilyParameter Class


Formula Property

[image]

Revit 2011 API
FamilyParameter..::.Formula Property
FamilyParameter Class See Also Send Feedback
The formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Formula { get; }
Visual Basic (Declaration)
Public ReadOnly Property Formula As String
Visual C++
public:
property String^ Formula {
    String^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no formula governing this parameter.

See Also

FamilyParameter Class


Id Property

[image]

Revit 2011 API
FamilyParameter..::.Id Property
FamilyParameter Class See Also Send Feedback
The id of the family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

FamilyParameter Class


IsDeterminedByFormula Property

[image]

Revit 2011 API
FamilyParameter..::.IsDeterminedByFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is determined by formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDeterminedByFormula { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDeterminedByFormula As Boolean
Visual C++
public:
property bool IsDeterminedByFormula {
    bool get ();
}

Remarks

The parameter is read only if it is determined by formula.

See Also

FamilyParameter Class


IsInstance Property

[image]

Revit 2011 API
FamilyParameter..::.IsInstance Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is instance or type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInstance As Boolean
Visual C++
public:
property bool IsInstance {
    bool get ();
}

See Also

FamilyParameter Class


IsReporting Property

[image]

Revit 2011 API
FamilyParameter..::.IsReporting Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReporting { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReporting As Boolean
Visual C++
public:
property bool IsReporting {
    bool get ();
}

Remarks

If true, the parameter is a reporting parameter associated to a dimension value, and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.

See Also

FamilyParameter Class


StorageType Property

[image]

Revit 2011 API
FamilyParameter..::.StorageType Property
FamilyParameter Class See Also Send Feedback
The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

FamilyParameter Class


FamilyParameterSet Class

[image]

Revit 2011 API
FamilyParameterSet Class
Members See Also Send Feedback
A set that contains FamilyParameter objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyParameterSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilyParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyParameterSet

See Also

FamilyParameterSet Members


FamilyParameterSet Members

[image] [image]

Revit 2011 API
FamilyParameterSet Members
FamilyParameterSet Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Constructors

Name | Description
FamilyParameterSet | Initializes a new instance of the FamilyParameterSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Constructor

[image]

Revit 2011 API
FamilyParameterSet Constructor
FamilyParameterSet Class See Also Send Feedback
Initializes a new instance of the FamilyParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameterSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyParameterSet()

See Also

FamilyParameterSet Class


FamilyParameterSet Methods

[image] [image]

Revit 2011 API
FamilyParameterSet Methods
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSet Class


Clear Method

[image]

Revit 2011 API
FamilyParameterSet..::.Clear Method
FamilyParameterSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyParameterSet Class


Contains Method

[image]

Revit 2011 API
FamilyParameterSet..::.Contains Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyParameter

See Also

FamilyParameterSet Class


Erase Method

[image]

Revit 2011 API
FamilyParameterSet..::.Erase Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilyParameter _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyParameter

See Also

FamilyParameterSet Class


ForwardIterator Method

[image]

Revit 2011 API
FamilyParameterSet..::.ForwardIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyParameterSet Class


GetEnumerator Method

[image]

Revit 2011 API
FamilyParameterSet..::.GetEnumerator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilyParameterSet Class


Insert Method

[image]

Revit 2011 API
FamilyParameterSet..::.Insert Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyParameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyParameter

See Also

FamilyParameterSet Class


ReverseIterator Method

[image]

Revit 2011 API
FamilyParameterSet..::.ReverseIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Properties

[image] [image]

Revit 2011 API
FamilyParameterSet Properties
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


IsEmpty Property

[image]

Revit 2011 API
FamilyParameterSet..::.IsEmpty Property
FamilyParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyParameterSet Class


Size Property

[image]

Revit 2011 API
FamilyParameterSet..::.Size Property
FamilyParameterSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyParameterSet Class


FamilyParameterSetIterator Class

[image]

Revit 2011 API
FamilyParameterSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyParameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FamilyParameterSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilyParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyParameterSetIterator

See Also

FamilyParameterSetIterator Members


FamilyParameterSetIterator Members

[image] [image]

Revit 2011 API
FamilyParameterSetIterator Members
FamilyParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Constructors

Name | Description
FamilyParameterSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Constructor

[image]

Revit 2011 API
FamilyParameterSetIterator Constructor
FamilyParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyParameterSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Methods

[image] [image]

Revit 2011 API
FamilyParameterSetIterator Methods
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSetIterator Class


MoveNext Method

[image]

Revit 2011 API
FamilyParameterSetIterator..::.MoveNext Method
FamilyParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class


Reset Method

[image]

Revit 2011 API
FamilyParameterSetIterator..::.Reset Method
FamilyParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Properties

[image] [image]

Revit 2011 API
FamilyParameterSetIterator Properties
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


Current Property

[image]

Revit 2011 API
FamilyParameterSetIterator..::.Current Property
FamilyParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class


FamilyPointLocation Class

[image]

Revit 2011 API
FamilyPointLocation Class
Members See Also Send Feedback
This object represents a data corresponding to the point locations in a certain types Family Symbols (see examples listed below).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyPointLocation : APIObject
Visual Basic (Declaration)
Public Class FamilyPointLocation _
    Inherits APIObject
Visual C++
public ref class FamilyPointLocation : public APIObject

Remarks

Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyPointLocation

See Also

FamilyPointLocation Members


FamilyPointLocation Members

[image] [image]

Revit 2011 API
FamilyPointLocation Members
FamilyPointLocation Class Methods Properties See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Location | The location of the point.
Name | The name of the corresponding reference point in the Family document.

See Also

FamilyPointLocation Class


FamilyPointLocation Methods

[image] [image]

Revit 2011 API
FamilyPointLocation Methods
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyPointLocation Class


FamilyPointLocation Properties

[image] [image]

Revit 2011 API
FamilyPointLocation Properties
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Location | The location of the point.
Name | The name of the corresponding reference point in the Family document.

See Also

FamilyPointLocation Class


Location Property

[image]

Revit 2011 API
FamilyPointLocation..::.Location Property
FamilyPointLocation Class See Also Send Feedback
The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As Transform
Visual C++
public:
property Transform^ Location {
    Transform^ get ();
}

See Also

FamilyPointLocation Class


Name Property

[image]

Revit 2011 API
FamilyPointLocation..::.Name Property
FamilyPointLocation Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointLocation Class


FamilyPointPlacementReference Class

[image]

Revit 2011 API
FamilyPointPlacementReference Class
Members See Also Send Feedback
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyPointPlacementReference : APIObject
Visual Basic (Declaration)
Public Class FamilyPointPlacementReference _
    Inherits APIObject
Visual C++
public ref class FamilyPointPlacementReference : public APIObject

Remarks

Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyPointPlacementReference

See Also

FamilyPointPlacementReference Members


FamilyPointPlacementReference Members

[image] [image]

Revit 2011 API
FamilyPointPlacementReference Members
FamilyPointPlacementReference Class Methods Properties See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Location | The location of the point.
Name | The name of the corresponding reference point in the Family document.
PointReference | The reference on which the point depends on.

See Also

FamilyPointPlacementReference Class


FamilyPointPlacementReference Methods

[image] [image]

Revit 2011 API
FamilyPointPlacementReference Methods
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyPointPlacementReference Class


FamilyPointPlacementReference Properties

[image] [image]

Revit 2011 API
FamilyPointPlacementReference Properties
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Location | The location of the point.
Name | The name of the corresponding reference point in the Family document.
PointReference | The reference on which the point depends on.

See Also

FamilyPointPlacementReference Class


Location Property

[image]

Revit 2011 API
FamilyPointPlacementReference..::.Location Property
FamilyPointPlacementReference Class See Also Send Feedback
The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As Transform
Visual C++
public:
property Transform^ Location {
    Transform^ get ();
}

See Also

FamilyPointPlacementReference Class


Name Property

[image]

Revit 2011 API
FamilyPointPlacementReference..::.Name Property
FamilyPointPlacementReference Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointPlacementReference Class


PointReference Property

[image]

Revit 2011 API
FamilyPointPlacementReference..::.PointReference Property
FamilyPointPlacementReference Class See Also Send Feedback
The reference on which the point depends on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PointReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointReference As Reference
Visual C++
public:
property Reference^ PointReference {
    Reference^ get ();
}

See Also

FamilyPointPlacementReference Class


FamilySource Enumeration

[image]

Revit 2011 API
FamilySource Enumeration
See Also Send Feedback
Describes which version of the family to be loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum FamilySource
Visual Basic (Declaration)
Public Enumeration FamilySource
Visual C++
public enum class FamilySource

Members

Member name | Description
Project | Loading the family from target project document.
Family | Loading the family from current family document.

See Also


FamilySymbol Class

[image]

Revit 2011 API
FamilySymbol Class
Members Example See Also Send Feedback
Represents a single Type within a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic (Declaration)
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol material is : " + familySymbol.Materials.GetEnumerator();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(ByVal familySymbol As FamilySymbol)
    Dim message As String
    ' Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name

    ' Get FamilySymbol material
    message += vbLf & "FamilySymbol material is : " & familySymbol.Materials.GetEnumerator().ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB..::.AnnotationSymbolType
Autodesk.Revit.DB.Architecture..::.RoomTagType
Autodesk.Revit.DB..::.AreaTagType
Autodesk.Revit.DB.Mechanical..::.SpaceTagType
Autodesk.Revit.DB..::.MullionType
Autodesk.Revit.DB..::.PanelType
Autodesk.Revit.DB.Structure..::.TrussType

See Also

FamilySymbol Members


FamilySymbol Members

[image] [image]

Revit 2011 API
FamilySymbol Members
FamilySymbol Class Methods Properties See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilySymbol Class


FamilySymbol Methods

[image] [image]

Revit 2011 API
FamilySymbol Methods
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbol Class


GetFamilyPointLocations Method

[image]

Revit 2011 API
FamilySymbol..::.GetFamilyPointLocations Method
FamilySymbol Class See Also Send Feedback
Returns the Point Locations for the Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<FamilyPointLocation> GetFamilyPointLocations()
Visual Basic (Declaration)
Public Function GetFamilyPointLocations As IList(Of FamilyPointLocation)
Visual C++
public:
IList<FamilyPointLocation^>^ GetFamilyPointLocations()

Remarks

If a family symbol has point references then their locations are returned by this method, otherwise an empty collection is returned. Examples of FamilySymbol objects that contain point location are Panels and Flexible Components.

See Also

FamilySymbol Class


FamilySymbol Properties

[image] [image]

Revit 2011 API
FamilySymbol Properties
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FamilySymbol Class


Family Property

[image]

Revit 2011 API
FamilySymbol..::.Family Property
FamilySymbol Class See Also Send Feedback
Returns the Family object to which the symbol belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Family Family { get; }
Visual Basic (Declaration)
Public ReadOnly Property Family As Family
Visual C++
public:
property Family^ Family {
    Family^ get ();
}

See Also

FamilySymbol Class


Parameter Property

[image] [image]

Revit 2011 API
FamilySymbol..::.Parameter Property
FamilySymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FamilySymbol Class
FamilySymbol Members


StructuralMaterialType Property

[image]

Revit 2011 API
FamilySymbol..::.StructuralMaterialType Property
FamilySymbol Class See Also Send Feedback
This property returns the physical material from which the type is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material.

See Also

FamilySymbol Class


FamilySymbolFilter Class

[image]

Revit 2011 API
FamilySymbolFilter Class
Members See Also Send Feedback
A filter used to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FamilySymbolFilter : ElementQuickFilter
Visual Basic (Declaration)
Public Class FamilySymbolFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class FamilySymbolFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementQuickFilter
Autodesk.Revit.DB..::.FamilySymbolFilter

See Also

FamilySymbolFilter Members


FamilySymbolFilter Members

[image] [image]

Revit 2011 API
FamilySymbolFilter Members
FamilySymbolFilter Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Constructors

Name | Description
FamilySymbolFilter | Constructs a new instance of a filter to find all family symbols of the given family.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FamilyId | The family id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilySymbolFilter Constructor

[image]

Revit 2011 API
FamilySymbolFilter Constructor
FamilySymbolFilter Class See Also Send Feedback
Constructs a new instance of a filter to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilySymbolFilter(
    ElementId familyId
)
Visual Basic (Declaration)
Public Sub New ( _
    familyId As ElementId _
)
Visual C++
public:
FamilySymbolFilter(
    ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB..::.ElementId
The family id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The familyId is invalid.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilySymbolFilter Class


FamilySymbolFilter Methods

[image] [image]

Revit 2011 API
FamilySymbolFilter Methods
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolFilter Class


FamilySymbolFilter Properties

[image] [image]

Revit 2011 API
FamilySymbolFilter Properties
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Properties

Name | Description
FamilyId | The family id.
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilyId Property

[image]

Revit 2011 API
FamilySymbolFilter..::.FamilyId Property
FamilySymbolFilter Class See Also Send Feedback
The family id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FamilyId As ElementId
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

See Also

FamilySymbolFilter Class


FamilySymbolProfile Class

[image]

Revit 2011 API
FamilySymbolProfile Class
Members See Also Send Feedback
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic (Declaration)
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.FamilySymbolProfile

See Also

FamilySymbolProfile Members


FamilySymbolProfile Members

[image] [image]

Revit 2011 API
FamilySymbolProfile Members
FamilySymbolProfile Class Methods Properties See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | The angle of the rotation of the profile in radians.
IsFlipped | Indicates if the symbol profile is flipped or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the family symbol of the profile.
XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class


FamilySymbolProfile Methods

[image] [image]

Revit 2011 API
FamilySymbolProfile Methods
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolProfile Class


FamilySymbolProfile Properties

[image] [image]

Revit 2011 API
FamilySymbolProfile Properties
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Properties

Name | Description
Angle | The angle of the rotation of the profile in radians.
IsFlipped | Indicates if the symbol profile is flipped or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Profile | Returns the family symbol of the profile.
XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class


Angle Property

[image]

Revit 2011 API
FamilySymbolProfile..::.Angle Property
FamilySymbolProfile Class See Also Send Feedback
The angle of the rotation of the profile in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


IsFlipped Property

[image]

Revit 2011 API
FamilySymbolProfile..::.IsFlipped Property
FamilySymbolProfile Class See Also Send Feedback
Indicates if the symbol profile is flipped or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFlipped { get; set; }
Visual Basic (Declaration)
Public Property IsFlipped As Boolean
Visual C++
public:
property bool IsFlipped {
    bool get ();
    void set (bool value);
}

See Also

FamilySymbolProfile Class


Profile Property

[image]

Revit 2011 API
FamilySymbolProfile..::.Profile Property
FamilySymbolProfile Class See Also Send Feedback
Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As FamilySymbol
Visual C++
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory.OST_ProfileFamilies.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.

See Also

FamilySymbolProfile Class


XOffset Property

[image]

Revit 2011 API
FamilySymbolProfile..::.XOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double XOffset { get; set; }
Visual Basic (Declaration)
Public Property XOffset As Double
Visual C++
public:
property double XOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


YOffset Property

[image]

Revit 2011 API
FamilySymbolProfile..::.YOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YOffset { get; set; }
Visual Basic (Declaration)
Public Property YOffset As Double
Visual C++
public:
property double YOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


FamilySymbolSet Class

[image]

Revit 2011 API
FamilySymbolSet Class
Members See Also Send Feedback
A set that can contain family symbols.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilySymbolSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilySymbolSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilySymbolSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilySymbolSet

See Also

FamilySymbolSet Members


FamilySymbolSet Members

[image] [image]

Revit 2011 API
FamilySymbolSet Members
FamilySymbolSet Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Constructors

Name | Description
FamilySymbolSet | Initializes a new instance of the FamilySymbolSet class

Methods

Name | Description
Clear | Removes every symbol from the set, rendering it empty.
Contains | Tests for the existence of a family symbol within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified family symbol from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified family symbol into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class


FamilySymbolSet Constructor

[image]

Revit 2011 API
FamilySymbolSet Constructor
FamilySymbolSet Class See Also Send Feedback
Initializes a new instance of the FamilySymbolSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSet()

See Also

FamilySymbolSet Class


FamilySymbolSet Methods

[image] [image]

Revit 2011 API
FamilySymbolSet Methods
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Methods

Name | Description
Clear | Removes every symbol from the set, rendering it empty.
Contains | Tests for the existence of a family symbol within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified family symbol from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified family symbol into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSet Class


Clear Method

[image]

Revit 2011 API
FamilySymbolSet..::.Clear Method
FamilySymbolSet Class See Also Send Feedback
Removes every symbol from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilySymbolSet Class


Contains Method

[image]

Revit 2011 API
FamilySymbolSet..::.Contains Method
FamilySymbolSet Class See Also Send Feedback
Tests for the existence of a family symbol within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilySymbol
The symbol to be searched for.

Return Value

The Contains method returns True if the symbol is within the set, otherwise False.

See Also

FamilySymbolSet Class


Erase Method

[image]

Revit 2011 API
FamilySymbolSet..::.Erase Method
FamilySymbolSet Class See Also Send Feedback
Removes a specified family symbol from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilySymbol _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilySymbol
The symbol to be erased.

Return Value

The number of symbols that were erased from the set.

See Also

FamilySymbolSet Class


ForwardIterator Method

[image]

Revit 2011 API
FamilySymbolSet..::.ForwardIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilySymbolSet Class


GetEnumerator Method

[image]

Revit 2011 API
FamilySymbolSet..::.GetEnumerator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilySymbolSet Class


Insert Method

[image]

Revit 2011 API
FamilySymbolSet..::.Insert Method
FamilySymbolSet Class See Also Send Feedback
Insert the specified family symbol into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilySymbol item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilySymbol
The symbol to be inserted into the set.

Return Value

Returns whether the symbol was inserted into the set.

See Also

FamilySymbolSet Class


ReverseIterator Method

[image]

Revit 2011 API
FamilySymbolSet..::.ReverseIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilySymbolSet Class


FamilySymbolSet Properties

[image] [image]

Revit 2011 API
FamilySymbolSet Properties
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class


IsEmpty Property

[image]

Revit 2011 API
FamilySymbolSet..::.IsEmpty Property
FamilySymbolSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilySymbolSet Class


Size Property

[image]

Revit 2011 API
FamilySymbolSet..::.Size Property
FamilySymbolSet Class See Also Send Feedback
Returns the number of family symbols that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilySymbolSet Class


FamilySymbolSetIterator Class

[image]

Revit 2011 API
FamilySymbolSetIterator Class
Members See Also Send Feedback
An iterator to a family symbol set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FamilySymbolSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilySymbolSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilySymbolSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilySymbolSetIterator

See Also

FamilySymbolSetIterator Members


FamilySymbolSetIterator Members

[image] [image]

Revit 2011 API
FamilySymbolSetIterator Members
FamilySymbolSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Constructors

Name | Description
FamilySymbolSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Constructor

[image]

Revit 2011 API
FamilySymbolSetIterator Constructor
FamilySymbolSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilySymbolSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Methods

[image] [image]

Revit 2011 API
FamilySymbolSetIterator Methods
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSetIterator Class


MoveNext Method

[image]

Revit 2011 API
FamilySymbolSetIterator..::.MoveNext Method
FamilySymbolSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class


Reset Method

[image]

Revit 2011 API
FamilySymbolSetIterator..::.Reset Method
FamilySymbolSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Properties

[image] [image]

Revit 2011 API
FamilySymbolSetIterator Properties
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class


Current Property

[image]

Revit 2011 API
FamilySymbolSetIterator..::.Current Property
FamilySymbolSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class


FamilyType Class

[image]

Revit 2011 API
FamilyType Class
Members See Also Send Feedback
The family type object provides read access to the values of family parameters for this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyType : APIObject
Visual Basic (Declaration)
Public Class FamilyType _
    Inherits APIObject
Visual C++
public ref class FamilyType : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyType

See Also

FamilyType Members


FamilyType Members

[image] [image]

Revit 2011 API
FamilyType Members
FamilyType Class Methods Properties See Also Send Feedback

The FamilyType type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number of the given family parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
AsInteger | Provides access to the integer number of the given family parameter.
AsString | Provides access to the string contents of the given family parameter.
AsValueString | Provides access to value as a string with unit in the given family parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Indicates if this family parameter has an assigned value or not.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The name of the family type.

See Also

FamilyType Class


FamilyType Methods

[image] [image]

Revit 2011 API
FamilyType Methods
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number of the given family parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
AsInteger | Provides access to the integer number of the given family parameter.
AsString | Provides access to the string contents of the given family parameter.
AsValueString | Provides access to value as a string with unit in the given family parameter.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Indicates if this family parameter has an assigned value or not.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyType Class


AsDouble Method

[image]

Revit 2011 API
FamilyType..::.AsDouble Method
FamilyType Class See Also Send Feedback
Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Nullable<double> AsDouble(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsDouble ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The double value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsElementId Method

[image]

Revit 2011 API
FamilyType..::.AsElementId Method
FamilyType Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsElementId ( _
    familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId^ AsElementId(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsInteger Method

[image]

Revit 2011 API
FamilyType..::.AsInteger Method
FamilyType Class See Also Send Feedback
Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Nullable<int> AsInteger(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsInteger ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> AsInteger(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The integer value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not integer type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsString Method

[image]

Revit 2011 API
FamilyType..::.AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The string contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsValueString Method

[image]

Revit 2011 API
FamilyType..::.AsValueString Method
FamilyType Class See Also Send Feedback
Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string AsValueString(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function AsValueString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


HasValue Method

[image]

Revit 2011 API
FamilyType..::.HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic (Declaration)
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::.FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


FamilyType Properties

[image] [image]

Revit 2011 API
FamilyType Properties
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The name of the family type.

See Also

FamilyType Class


Name Property

[image]

Revit 2011 API
FamilyType..::.Name Property
FamilyType Class See Also Send Feedback
The name of the family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyType Class


FamilyTypeSet Class

[image]

Revit 2011 API
FamilyTypeSet Class
Members See Also Send Feedback
A set that contains FamilyType objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FamilyTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyTypeSet

See Also

FamilyTypeSet Members


FamilyTypeSet Members

[image] [image]

Revit 2011 API
FamilyTypeSet Members
FamilyTypeSet Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Constructors

Name | Description
FamilyTypeSet | Initializes a new instance of the FamilyTypeSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class


FamilyTypeSet Constructor

[image]

Revit 2011 API
FamilyTypeSet Constructor
FamilyTypeSet Class See Also Send Feedback
Initializes a new instance of the FamilyTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyTypeSet()

See Also

FamilyTypeSet Class


FamilyTypeSet Methods

[image] [image]

Revit 2011 API
FamilyTypeSet Methods
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSet Class


Clear Method

[image]

Revit 2011 API
FamilyTypeSet..::.Clear Method
FamilyTypeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyTypeSet Class


Contains Method

[image]

Revit 2011 API
FamilyTypeSet..::.Contains Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyType

See Also

FamilyTypeSet Class


Erase Method

[image]

Revit 2011 API
FamilyTypeSet..::.Erase Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FamilyType _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyType

See Also

FamilyTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
FamilyTypeSet..::.ForwardIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
FamilyTypeSet..::.GetEnumerator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FamilyTypeSet Class


Insert Method

[image]

Revit 2011 API
FamilyTypeSet..::.Insert Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FamilyType

See Also

FamilyTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
FamilyTypeSet..::.ReverseIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyTypeSet Class


FamilyTypeSet Properties

[image] [image]

Revit 2011 API
FamilyTypeSet Properties
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
FamilyTypeSet..::.IsEmpty Property
FamilyTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyTypeSet Class


Size Property

[image]

Revit 2011 API
FamilyTypeSet..::.Size Property
FamilyTypeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyTypeSet Class


FamilyTypeSetIterator Class

[image]

Revit 2011 API
FamilyTypeSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyType set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FamilyTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FamilyTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FamilyTypeSetIterator

See Also

FamilyTypeSetIterator Members


FamilyTypeSetIterator Members

[image] [image]

Revit 2011 API
FamilyTypeSetIterator Members
FamilyTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Constructors

Name | Description
FamilyTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Constructor

[image]

Revit 2011 API
FamilyTypeSetIterator Constructor
FamilyTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FamilyTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Methods

[image] [image]

Revit 2011 API
FamilyTypeSetIterator Methods
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
FamilyTypeSetIterator..::.MoveNext Method
FamilyTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
FamilyTypeSetIterator..::.Reset Method
FamilyTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Properties

[image] [image]

Revit 2011 API
FamilyTypeSetIterator Properties
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


Current Property

[image]

Revit 2011 API
FamilyTypeSetIterator..::.Current Property
FamilyTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class


FamilyUtils Class

[image]

Revit 2011 API
FamilyUtils Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FamilyUtils : IDisposable
Visual Basic (Declaration)
Public Class FamilyUtils _
    Implements IDisposable
Visual C++
public ref class FamilyUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FamilyUtils

See Also

FamilyUtils Members


FamilyUtils Members

[image] [image]

Revit 2011 API
FamilyUtils Members
FamilyUtils Class Methods See Also Send Feedback

The FamilyUtils type exposes the following members.

Methods

Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyUtils Class


FamilyUtils Methods

[image] [image]

Revit 2011 API
FamilyUtils Methods
FamilyUtils Class See Also Send Feedback

The FamilyUtils type exposes the following members.

Methods

Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyUtils Class


ConvertFamilyToFaceHostBased Method

[image]

Revit 2011 API
FamilyUtils..::.ConvertFamilyToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void ConvertFamilyToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic (Declaration)
Public Shared Sub ConvertFamilyToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
)
Visual C++
public:
static void ConvertFamilyToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
The document containing the family to be converted.
famId
Type: Autodesk.Revit.DB..::.ElementId
The family id.

Remarks

This function converts an entire family (including all its types) to be face host based. There can be no instances of any of the types of the family already in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input famId cannot be converted to face host based.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The family is already unhosted. -or- Failed to convert the family to face host based.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class


Dispose Method

[image]

Revit 2011 API
FamilyUtils..::.Dispose Method
FamilyUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FamilyUtils Class


FamilyCanConvertToFaceHostBased Method

[image]

Revit 2011 API
FamilyUtils..::.FamilyCanConvertToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool FamilyCanConvertToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic (Declaration)
Public Shared Function FamilyCanConvertToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
) As Boolean
Visual C++
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
famId
Type: Autodesk.Revit.DB..::.ElementId

Return Value

True will be returned if the family can be converted to face host based. Otherwise, false will be returned, for example, in the following cases: - There are some instances related to the family in the project. - The operation cannot be applied for some families of certain categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class


FBXExportOptions Class

[image]

Revit 2011 API
FBXExportOptions Class
Members See Also Send Feedback
3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FBXExportOptions
Visual Basic (Declaration)
Public Class FBXExportOptions
Visual C++
public ref class FBXExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FBXExportOptions

See Also

FBXExportOptions Members


FBXExportOptions Members

[image] [image]

Revit 2011 API
FBXExportOptions Members
FBXExportOptions Class Constructors Methods Properties See Also Send Feedback

The FBXExportOptions type exposes the following members.

Constructors

Name | Description
FBXExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
StopOnError | Whether export process should stop when a view fails to export.

See Also

FBXExportOptions Class


FBXExportOptions Constructor

[image]

Revit 2011 API
FBXExportOptions Constructor
FBXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FBXExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FBXExportOptions()

See Also

FBXExportOptions Class


FBXExportOptions Methods

[image] [image]

Revit 2011 API
FBXExportOptions Methods
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FBXExportOptions Class


FBXExportOptions Properties

[image] [image]

Revit 2011 API
FBXExportOptions Properties
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Properties

Name | Description
StopOnError | Whether export process should stop when a view fails to export.

See Also

FBXExportOptions Class


StopOnError Property

[image]

Revit 2011 API
FBXExportOptions..::.StopOnError Property
FBXExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic (Declaration)
Public Property StopOnError As Boolean
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

FBXExportOptions Class


FillPattern Class

[image]

Revit 2011 API
FillPattern Class
Members See Also Send Feedback
Represents a fill pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FillPattern : Element
Visual Basic (Declaration)
Public Class FillPattern _
    Inherits Element
Visual C++
public ref class FillPattern : public Element

Remarks

Currently the details of the fill patterns are not exposed but all the fill patterns can be found on the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.FillPattern

See Also

FillPattern Members


FillPattern Members

[image] [image]

Revit 2011 API
FillPattern Members
FillPattern Class Methods Properties See Also Send Feedback

The FillPattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FillPattern Class


FillPattern Methods

[image] [image]

Revit 2011 API
FillPattern Methods
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPattern Class


FillPattern Properties

[image] [image]

Revit 2011 API
FillPattern Properties
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FillPattern Class


Parameter Property

[image] [image]

Revit 2011 API
FillPattern..::.Parameter Property
FillPattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FillPattern Class
FillPattern Members


FillPatternSet Class

[image]

Revit 2011 API
FillPatternSet Class
Members See Also Send Feedback
A set that contains FillPatterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FillPatternSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FillPatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FillPatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FillPatternSet

See Also

FillPatternSet Members


FillPatternSet Members

[image] [image]

Revit 2011 API
FillPatternSet Members
FillPatternSet Class Constructors Methods Properties See Also Send Feedback

The FillPatternSet type exposes the following members.

Constructors

Name | Description
FillPatternSet | Initializes a new instance of the FillPatternSet class

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class


FillPatternSet Constructor

[image]

Revit 2011 API
FillPatternSet Constructor
FillPatternSet Class See Also Send Feedback
Initializes a new instance of the FillPatternSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSet()

See Also

FillPatternSet Class


FillPatternSet Methods

[image] [image]

Revit 2011 API
FillPatternSet Methods
FillPatternSet Class See Also Send Feedback

The FillPatternSet type exposes the following members.

Methods

Name | Description
Clear | Removes every fill pattern from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPatternSet Class


Clear Method

[image]

Revit 2011 API
FillPatternSet..::.Clear Method
FillPatternSet Class See Also Send Feedback
Removes every fill pattern from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FillPatternSet Class


Contains Method

[image]

Revit 2011 API
FillPatternSet..::.Contains Method
FillPatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FillPattern

See Also

FillPatternSet Class


Erase Method

[image]

Revit 2011 API
FillPatternSet..::.Erase Method
FillPatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FillPattern _
) As Integer
Visual C++
public:
virtual int Erase(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FillPattern

See Also

FillPatternSet Class


ForwardIterator Method

[image]

Revit 2011 API
FillPatternSet..::.ForwardIterator Method
FillPatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FillPatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FillPatternSet Class


GetEnumerator Method

[image]

Revit 2011 API
FillPatternSet..::.GetEnumerator Method
FillPatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FillPatternSet Class


Insert Method

[image]

Revit 2011 API
FillPatternSet..::.Insert Method
FillPatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FillPattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FillPattern _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FillPattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FillPattern

See Also

FillPatternSet Class


ReverseIterator Method

[image]

Revit 2011 API
FillPatternSet..::.ReverseIterator Method
FillPatternSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FillPatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FillPatternSetIterator
Visual C++
public:
virtual FillPatternSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FillPatternSet Class


FillPatternSet Properties

[image] [image]

Revit 2011 API
FillPatternSet Properties
FillPatternSet Class See Also Send Feedback

The FillPatternSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fill patterns that are in the set.

See Also

FillPatternSet Class


IsEmpty Property

[image]

Revit 2011 API
FillPatternSet..::.IsEmpty Property
FillPatternSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FillPatternSet Class


Size Property

[image]

Revit 2011 API
FillPatternSet..::.Size Property
FillPatternSet Class See Also Send Feedback
Returns the number of fill patterns that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FillPatternSet Class


FillPatternSetIterator Class

[image]

Revit 2011 API
FillPatternSetIterator Class
Members See Also Send Feedback
An iterator to a FillPattern set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FillPatternSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FillPatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FillPatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FillPatternSetIterator

See Also

FillPatternSetIterator Members


FillPatternSetIterator Members

[image] [image]

Revit 2011 API
FillPatternSetIterator Members
FillPatternSetIterator Class Constructors Methods Properties See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Constructors

Name | Description
FillPatternSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator Class


FillPatternSetIterator Constructor

[image]

Revit 2011 API
FillPatternSetIterator Constructor
FillPatternSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillPatternSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FillPatternSetIterator Class


FillPatternSetIterator Methods

[image] [image]

Revit 2011 API
FillPatternSetIterator Methods
FillPatternSetIterator Class See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPatternSetIterator Class


MoveNext Method

[image]

Revit 2011 API
FillPatternSetIterator..::.MoveNext Method
FillPatternSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class


Reset Method

[image]

Revit 2011 API
FillPatternSetIterator..::.Reset Method
FillPatternSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FillPatternSetIterator Class


FillPatternSetIterator Properties

[image] [image]

Revit 2011 API
FillPatternSetIterator Properties
FillPatternSetIterator Class See Also Send Feedback

The FillPatternSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FillPatternSetIterator Class


Current Property

[image]

Revit 2011 API
FillPatternSetIterator..::.Current Property
FillPatternSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FillPatternSetIterator Class


FilterableValueProvider Class

[image]

Revit 2011 API
FilterableValueProvider Class
Members See Also Send Feedback
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterableValueProvider : IDisposable
Visual Basic (Declaration)
Public Class FilterableValueProvider _
    Implements IDisposable
Visual C++
public ref class FilterableValueProvider : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterableValueProvider
Autodesk.Revit.DB..::.ParameterValueProvider

See Also

FilterableValueProvider Members


FilterableValueProvider Members

[image] [image]

Revit 2011 API
FilterableValueProvider Members
FilterableValueProvider Class Methods See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element.
GetElementIdValue | Gets an ElementId value from the given element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element.
GetStringValue | Gets a string value from the given element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterableValueProvider Class


FilterableValueProvider Methods

[image] [image]

Revit 2011 API
FilterableValueProvider Methods
FilterableValueProvider Class See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element.
GetElementIdValue | Gets an ElementId value from the given element.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element.
GetStringValue | Gets a string value from the given element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterableValueProvider Class


Dispose Method

[image]

Revit 2011 API
FilterableValueProvider..::.Dispose Method
FilterableValueProvider Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FilterableValueProvider Class


GetDoubleValue Method

[image]

Revit 2011 API
FilterableValueProvider..::.GetDoubleValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a double-precision numeric value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetDoubleValue(
    Element element
)
Visual Basic (Declaration)
Public Function GetDoubleValue ( _
    element As Element _
) As Double
Visual C++
public:
double GetDoubleValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

The double-precision numeric value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetElementIdValue Method

[image]

Revit 2011 API
FilterableValueProvider..::.GetElementIdValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an ElementId value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetElementIdValue(
    Element element
)
Visual Basic (Declaration)
Public Function GetElementIdValue ( _
    element As Element _
) As ElementId
Visual C++
public:
ElementId^ GetElementIdValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

The ElementId value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetIntegerValue Method

[image]

Revit 2011 API
FilterableValueProvider..::.GetIntegerValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an integer value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int GetIntegerValue(
    Element element
)
Visual Basic (Declaration)
Public Function GetIntegerValue ( _
    element As Element _
) As Integer
Visual C++
public:
int GetIntegerValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

The integer value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetStringValue Method

[image]

Revit 2011 API
FilterableValueProvider..::.GetStringValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a string value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetStringValue(
    Element element
)
Visual Basic (Declaration)
Public Function GetStringValue ( _
    element As Element _
) As String
Visual C++
public:
String^ GetStringValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

The string value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsDoubleValueSupported Method

[image]

Revit 2011 API
FilterableValueProvider..::.IsDoubleValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a double-precision numeric value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsDoubleValueSupported(
    Element element
)
Visual Basic (Declaration)
Public Function IsDoubleValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsDoubleValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

True if the provider can return a double-precision numeric value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsElementIdValueSupported Method

[image]

Revit 2011 API
FilterableValueProvider..::.IsElementIdValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an ElementId value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsElementIdValueSupported(
    Element element
)
Visual Basic (Declaration)
Public Function IsElementIdValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsElementIdValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

True if the provider can return an ElementId value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsIntegerValueSupported Method

[image]

Revit 2011 API
FilterableValueProvider..::.IsIntegerValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an integer value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsIntegerValueSupported(
    Element element
)
Visual Basic (Declaration)
Public Function IsIntegerValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsIntegerValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

True if the provider can return an integer value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsStringValueSupported Method

[image]

Revit 2011 API
FilterableValueProvider..::.IsStringValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a string value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsStringValueSupported(
    Element element
)
Visual Basic (Declaration)
Public Function IsStringValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsStringValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query.

Return Value

True if the provider can return a string value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


FilterDoubleRule Class

[image]

Revit 2011 API
FilterDoubleRule Class
Members See Also Send Feedback
A filter rule that operates on double-precision numeric values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterDoubleRule : FilterNumericValueRule
Visual Basic (Declaration)
Public Class FilterDoubleRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterDoubleRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterNumericValueRule
Autodesk.Revit.DB..::.FilterDoubleRule

See Also

FilterDoubleRule Members


FilterDoubleRule Members

[image] [image]

Revit 2011 API
FilterDoubleRule Members
FilterDoubleRule Class Constructors Methods Properties See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Constructors

Name | Description
FilterDoubleRule | Constructs an instance of FilterDoubleRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Epsilon | The tolerance within which two floating-point values may be considered equal.
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class


FilterDoubleRule Constructor

[image]

Revit 2011 API
FilterDoubleRule Constructor
FilterDoubleRule Class See Also Send Feedback
Constructs an instance of FilterDoubleRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterDoubleRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    double ruleValue,
    double epsilon
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Double, _
    epsilon As Double _
)
Visual C++
public:
FilterDoubleRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    double ruleValue,
    double epsilon
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::.Double
The user-supplied value against which values from a Revit document will be tested.
epsilon
Type: System..::.Double
The tolerance within which two floating-point values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterDoubleRule Class


FilterDoubleRule Methods

[image] [image]

Revit 2011 API
FilterDoubleRule Methods
FilterDoubleRule Class See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDoubleRule Class


FilterDoubleRule Properties

[image] [image]

Revit 2011 API
FilterDoubleRule Properties
FilterDoubleRule Class See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Properties

Name | Description
Epsilon | The tolerance within which two floating-point values may be considered equal.
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class


Epsilon Property

[image]

Revit 2011 API
FilterDoubleRule..::.Epsilon Property
FilterDoubleRule Class See Also Send Feedback
The tolerance within which two floating-point values may be considered equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Epsilon { get; set; }
Visual Basic (Declaration)
Public Property Epsilon As Double
Visual C++
public:
property double Epsilon {
    double get ();
    void set (double value);
}

See Also

FilterDoubleRule Class


RuleValue Property

[image]

Revit 2011 API
FilterDoubleRule..::.RuleValue Property
FilterDoubleRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double RuleValue { get; set; }
Visual Basic (Declaration)
Public Property RuleValue As Double
Visual C++
public:
property double RuleValue {
    double get ();
    void set (double value);
}

See Also

FilterDoubleRule Class


FilteredElementCollector Class

[image]

Revit 2011 API
FilteredElementCollector Class
Members See Also Send Feedback
This class is used to search, filter and iterate through a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementCollector : IEnumerable<Element>,
    IDisposable
Visual Basic (Declaration)
Public Class FilteredElementCollector _
    Implements IEnumerable(Of Element), IDisposable
Visual C++
public ref class FilteredElementCollector : IEnumerable<Element^>,
    IDisposable

Remarks

Developers can assign a variety of conditions to filter the elements which are returned. This class requires that at least one condition be set before making the attempt to access the elements.

Revit will attempt to organize the filters in order to minimize expansion of elements regardless of the order in which conditions and filters are applied.

There are three groups of methods which you can use on a given collector once you have applied filter(s) to it. One group provides collections of all passing elements, a second finds the first match of the given filter(s), and a third provides an iterator which is evaluated lazily (each element is tested by the filter only when the iterator reaches it). You should only use one of the methods from these group at a time; the collector will reset if you call another method to extract elements. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more elements if you call another method to extract elements.

In .NET, this class supports the IEnumerable interface for Elements. You can use this class with LINQ queries and operations to process lists of elements. Note that because the ElementFilters and the shortcut methods offered by this class process elements in native code before their managed wrappers are generated, better performance will be obtained by using as many native filters as possible on the collector before attempting to process the results using LINQ queries.

One special consideration when using this class in .NET: the debugger will attempt to traverse the members of the collector because of its implementation of IEnumerable. You may see strange results if you also attempt to extract the first element or all elements from the collector while the debugger is also looking at the contents of the collector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilteredElementCollector

See Also

FilteredElementCollector Members


FilteredElementCollector Members

[image] [image]

Revit 2011 API
FilteredElementCollector Members
FilteredElementCollector Class Constructors Methods See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Constructors

Name | Description
FilteredElementCollector | Overloaded.

Methods

Name | Description
ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Excluding | Applies an ExclusionFilter to the collector.
FirstElement | Returns the first element to pass the filter(s).
FirstElementId | Returns the id of the first element to pass the filter(s).
GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
GetElementIterator | Returns an element iterator to the elements passing the filters.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
OfCategory | Applies an ElementCategoryFilter to the collector.
OfCategoryId | Applies an ElementCategoryFilter to the collector.
OfClass | Applies an ElementClassFilter to the collector.
OwnedByView | Applies an ElementOwnerViewFilter to the collector.
ToElementIds | Returns the complete set of element ids which pass the filter(s).
ToElements | Returns the complete set of elements which pass the filter(s).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class


FilteredElementCollector Constructor

[image] [image]

Revit 2011 API
FilteredElementCollector Constructor
FilteredElementCollector Class See Also Send Feedback

Overload List

Name | Description
FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
FilteredElementCollector(Document, ICollection<(Of <(ElementId>)>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

See Also

FilteredElementCollector Class
FilteredElementCollector Members


FilteredElementCollector Constructor (Document)

[image]

Revit 2011 API
FilteredElementCollector Constructor (Document)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ElementId)

[image]

Revit 2011 API
FilteredElementCollector Constructor (Document, ElementId)
FilteredElementCollector Class Example See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ElementId viewId
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    viewId As ElementId _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id.

Remarks

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements. Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Examples

CopyC#
private void CountElements(Autodesk.Revit.DB.Document document)
{
    StringBuilder message = new StringBuilder();
    FilteredElementCollector viewCollector =
        new FilteredElementCollector(document, document.ActiveView.Id);
    viewCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within active View: "
       + viewCollector.ToElementIds().Count);

    FilteredElementCollector docCollector = new FilteredElementCollector(document);
    docCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within document: "
       + docCollector.ToElementIds().Count);

    TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub CountElements(ByVal document As Autodesk.Revit.DB.Document)
    Dim message As New StringBuilder()
    Dim viewCollector As New Autodesk.Revit.DB.FilteredElementCollector(document, document.ActiveView.Id)
    viewCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within active View: " + viewCollector.ToElementIds().Count)

    Dim docCollector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    docCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within document: " + docCollector.ToElementIds().Count)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ICollection(ElementId))

[image]

Revit 2011 API
FilteredElementCollector Constructor (Document, ICollection<(Of <(ElementId>)>))
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document that owns the elements matching the element ids.
elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The input set of element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Methods

[image] [image]

Revit 2011 API
FilteredElementCollector Methods
FilteredElementCollector Class See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Methods

Name | Description
ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Excluding | Applies an ExclusionFilter to the collector.
FirstElement | Returns the first element to pass the filter(s).
FirstElementId | Returns the id of the first element to pass the filter(s).
GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
GetElementIterator | Returns an element iterator to the elements passing the filters.
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
OfCategory | Applies an ElementCategoryFilter to the collector.
OfCategoryId | Applies an ElementCategoryFilter to the collector.
OfClass | Applies an ElementClassFilter to the collector.
OwnedByView | Applies an ElementOwnerViewFilter to the collector.
ToElementIds | Returns the complete set of element ids which pass the filter(s).
ToElements | Returns the complete set of elements which pass the filter(s).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class


ContainedInDesignOption Method

[image]

Revit 2011 API
FilteredElementCollector..::.ContainedInDesignOption Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementDesignOptionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector ContainedInDesignOption(
    ElementId designOptionId
)
Visual Basic (Declaration)
Public Function ContainedInDesignOption ( _
    designOptionId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ ContainedInDesignOption(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::.ElementId
The design option id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are contained by this particular design option will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


Dispose Method

[image]

Revit 2011 API
FilteredElementCollector..::.Dispose Method
FilteredElementCollector Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FilteredElementCollector Class


Excluding Method

[image]

Revit 2011 API
FilteredElementCollector..::.Excluding Method
FilteredElementCollector Class See Also Send Feedback
Applies an ExclusionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector Excluding(
    ICollection<ElementId> idsToExclude
)
Visual Basic (Declaration)
Public Function Excluding ( _
    idsToExclude As ICollection(Of ElementId) _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ Excluding(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The ids to exclude from the results.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Elements passed to this filter will be automatically excluded from the results. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


FirstElement Method

[image]

Revit 2011 API
FilteredElementCollector..::.FirstElement Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Element FirstElement()
Visual Basic (Declaration)
Public Function FirstElement As Element
Visual C++
public:
Element^ FirstElement()

Return Value

The first element.

Remarks

This will reset the collector to the beginning and find the first element which passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
    // Create a filter to find all columns
    StructuralInstanceUsageFilter columnFilter =
        new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);

    // Apply the filter to the elements in the active document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.WherePasses(columnFilter);

    // Get the first column from the filtered results
    // Element will be a FamilyInstance
    FamilyInstance column = collector.FirstElement() as FamilyInstance;

    return column;
}
CopyVB.NET
Public Function GetAColumn(ByVal document As Autodesk.Revit.DB.Document) As Autodesk.Revit.DB.FamilyInstance
    ' Create a filter to find all columns
    Dim columnFilter As New Autodesk.Revit.DB.Structure.StructuralInstanceUsageFilter(Autodesk.Revit.DB.Structure.StructuralInstanceUsage.Column)

    ' Apply the filter to the elements in the active document
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    collector.WherePasses(columnFilter)

    ' Get the first column from the filtered results
    ' Element will be a FamilyInstance
    Dim column As Autodesk.Revit.DB.FamilyInstance = TryCast(collector.FirstElement(), Autodesk.Revit.DB.FamilyInstance)

    Return column
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


FirstElementId Method

[image]

Revit 2011 API
FilteredElementCollector..::.FirstElementId Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the id of the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId FirstElementId()
Visual Basic (Declaration)
Public Function FirstElementId As ElementId
Visual C++
public:
ElementId^ FirstElementId()

Return Value

The first element id.

Remarks

This will reset the collector to the beginning and find the first element which passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Use shortcut OfClass to get View elements
collector.OfClass(typeof(View3D));

// Get the Id of the first view
ElementId viewId = collector.FirstElementId();

// Test if the view is valid for element filtering
if (FilteredElementCollector.IsViewValidForElementIteration(document, viewId))
{
    FilteredElementCollector viewCollector = new FilteredElementCollector(document, viewId);

    // Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(typeof(FamilyInstance));
    ICollection<ElementId> familyInstanceIds = viewCollector.ToElementIds();

    document.Delete(familyInstanceIds);
}
CopyVB.NET
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)

' Use shortcut OfClass to get View elements
collector.OfClass(GetType(View3D))

' Get the Id of the first view
Dim viewId As ElementId = collector.FirstElementId()

' Test if the view is valid for element filtering
If Autodesk.Revit.DB.FilteredElementCollector.IsViewValidForElementIteration(document, viewId) Then
    Dim viewCollector As New Autodesk.Revit.DB.FilteredElementCollector(document, viewId)

    ' Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(GetType(FamilyInstance))
    Dim familyInstanceIds As ICollection(Of ElementId) = viewCollector.ToElementIds()

    document.Delete(familyInstanceIds)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetBasicIEnumerator Method

[image]

Revit 2011 API
FilteredElementCollector..::.GetBasicIEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic (Declaration)
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FilteredElementCollector Class


GetElementIdIterator Method

[image]

Revit 2011 API
FilteredElementCollector..::.GetElementIdIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element id iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementIdIterator GetElementIdIterator()
Visual Basic (Declaration)
Public Function GetElementIdIterator As FilteredElementIdIterator
Visual C++
public:
FilteredElementIdIterator^ GetElementIdIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
// Use a RoomFilter to find all room elements in the document.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Get results as ElementId iterator
FilteredElementIdIterator roomIdItr = collector.GetElementIdIterator();
roomIdItr.Reset();
while (roomIdItr.MoveNext())
{
    ElementId roomId = roomIdItr.Current;
    // Warn rooms smaller than 50 SF
    Room room = document.get_Element(roomId) as Room;
    if (room.Area < 50.0)
    {
        String prompt = "Room is too small: id = " + roomId.ToString();
        TaskDialog.Show("Revit", prompt);
        break;
    }
}
CopyVB.NET
' Use a RoomFilter to find all room elements in the document.
Dim filter As New Autodesk.Revit.DB.Architecture.RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(filter)

' Get results as ElementId iterator
Dim roomIdItr As FilteredElementIdIterator = collector.GetElementIdIterator()
roomIdItr.Reset()
While roomIdItr.MoveNext()
    Dim roomId As ElementId = roomIdItr.Current
    ' Warn rooms smaller than 50 SF
    Dim room As Room = TryCast(document.Element(roomId), Room)
    If room.Area < 50 Then
        Dim prompt As [String] = "Room is too small: id = " + roomId.ToString()
        TaskDialog.Show("Revit", prompt)
        Exit While
    End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetElementIterator Method

[image]

Revit 2011 API
FilteredElementCollector..::.GetElementIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementIterator GetElementIterator()
Visual Basic (Declaration)
Public Function GetElementIterator As FilteredElementIterator
Visual C++
public:
FilteredElementIterator^ GetElementIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Apply a filter to get all pipes in the document
collector.OfClass(typeof(Autodesk.Revit.DB.Plumbing.Pipe));

// Get results as an element iterator and look for a pipe with
// a specific flow state
FilteredElementIterator elemItr = collector.GetElementIterator();
elemItr.Reset();
while (elemItr.MoveNext())
{
    Pipe pipe = elemItr.Current as Pipe;
    if (pipe.FlowState == PipeFlowState.LaminarState)
    {
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.");
        break;
    }
}
CopyVB.NET
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)

' Apply a filter to get all pipes in the document
collector.OfClass(GetType(Autodesk.Revit.DB.Plumbing.Pipe))

' Get results as an element iterator and look for a pipe with
' a specific flow state
Dim elemItr As FilteredElementIterator = collector.GetElementIterator()
elemItr.Reset()
While elemItr.MoveNext()
    Dim pipe As Pipe = TryCast(elemItr.Current, Pipe)
    If pipe.FlowState = PipeFlowState.LaminarState Then
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.")
        Exit While
    End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetEnumerator Method

[image]

Revit 2011 API
FilteredElementCollector..::.GetEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator<Element> GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator(Of Element)
Visual C++
public:
virtual IEnumerator<Element^>^ GetEnumerator()

Return Value

An IEnumerator(Autodesk.Revit.DB.Element) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FilteredElementCollector Class


IntersectWith Method

[image]

Revit 2011 API
FilteredElementCollector..::.IntersectWith Method
FilteredElementCollector Class See Also Send Feedback
Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector IntersectWith(
    FilteredElementCollector other
)
Visual Basic (Declaration)
Public Function IntersectWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ IntersectWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::.FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalAndFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


IsViewValidForElementIteration Method

[image]

Revit 2011 API
FilteredElementCollector..::.IsViewValidForElementIteration Method
FilteredElementCollector Class See Also Send Feedback
Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsViewValidForElementIteration(
    Document document,
    ElementId viewId
)
Visual Basic (Declaration)
Public Shared Function IsViewValidForElementIteration ( _
    document As Document, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewValidForElementIteration(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id.

Return Value

True if the element is valid for iteration.

Remarks

Views which have no way of representing drawn elements, such as many view templates, fail this check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OfCategory Method

[image]

Revit 2011 API
FilteredElementCollector..::.OfCategory Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Visual Basic (Declaration)
Public Function OfCategory ( _
    category As BuiltInCategory _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::.BuiltInCategory
The category.

Return Value

This collector.

Remarks

Only elements of this category id will pass the collector.

Examples

CopyC#
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
CopyVB.NET
' Use OfCategory method to apply an ElementCategoryFilter and find Levels in the document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim doors As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

See Also

FilteredElementCollector Class


OfCategoryId Method

[image]

Revit 2011 API
FilteredElementCollector..::.OfCategoryId Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OfCategoryId(
    ElementId categoryId
)
Visual Basic (Declaration)
Public Function OfCategoryId ( _
    categoryId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategoryId(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::.ElementId
The category id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements of this category id will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OfClass Method

[image]

Revit 2011 API
FilteredElementCollector..::.OfClass Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementClassFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OfClass(
    Type type
)
Visual Basic (Declaration)
Public Function OfClass ( _
    type As Type _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfClass(
    Type^ type
)

Parameters

type
Type: System..::.Type
The element type.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API which are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

If you have an active iterator to this collector it will be stopped by this call.

Examples

CopyC#
// Use OfClass method to apply an ElementClassFilter and find Levels in the document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
CopyVB.NET
' Use OfClass method to apply an ElementClassFilter and find Levels in the document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim levels As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Level)).ToElements()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element type that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OwnedByView Method

[image]

Revit 2011 API
FilteredElementCollector..::.OwnedByView Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OwnedByView(
    ElementId viewId
)
Visual Basic (Declaration)
Public Function OwnedByView ( _
    viewId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OwnedByView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::.ElementId
The view id of the owner view.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


ToElementIds Method

[image]

Revit 2011 API
FilteredElementCollector..::.ToElementIds Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of element ids which pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> ToElementIds()
Visual Basic (Declaration)
Public Function ToElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ ToElementIds()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements which pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


ToElements Method

[image]

Revit 2011 API
FilteredElementCollector..::.ToElements Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of elements which pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<Element> ToElements()
Visual Basic (Declaration)
Public Function ToElements As IList(Of Element)
Visual C++
public:
IList<Element^>^ ToElements()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements which pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


UnionWith Method

[image]

Revit 2011 API
FilteredElementCollector..::.UnionWith Method
FilteredElementCollector Class See Also Send Feedback
Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector UnionWith(
    FilteredElementCollector other
)
Visual Basic (Declaration)
Public Function UnionWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ UnionWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::.FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


WhereElementIsCurveDriven Method

[image]

Revit 2011 API
FilteredElementCollector..::.WhereElementIsCurveDriven Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsCurveDrivenFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsCurveDriven()
Visual Basic (Declaration)
Public Function WhereElementIsCurveDriven As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsCurveDriven()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are curve driven will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsElementType Method

[image]

Revit 2011 API
FilteredElementCollector..::.WhereElementIsElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsElementType()
Visual Basic (Declaration)
Public Function WhereElementIsElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsNotElementType Method

[image]

Revit 2011 API
FilteredElementCollector..::.WhereElementIsNotElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an inverted ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsNotElementType()
Visual Basic (Declaration)
Public Function WhereElementIsNotElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsNotElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are not element types will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsViewIndependent Method

[image]

Revit 2011 API
FilteredElementCollector..::.WhereElementIsViewIndependent Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsViewIndependent()
Visual Basic (Declaration)
Public Function WhereElementIsViewIndependent As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsViewIndependent()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements which are view independent will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WherePasses Method

[image]

Revit 2011 API
FilteredElementCollector..::.WherePasses Method
FilteredElementCollector Class See Also Send Feedback
Applies an element filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WherePasses(
    ElementFilter filter
)
Visual Basic (Declaration)
Public Function WherePasses ( _
    filter As ElementFilter _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WherePasses(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::.ElementFilter
The element filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition which all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


FilteredElementIdIterator Class

[image]

Revit 2011 API
FilteredElementIdIterator Class
Members See Also Send Feedback
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementIdIterator : IEnumerator<ElementId>
Visual Basic (Declaration)
Public Class FilteredElementIdIterator _
    Implements IEnumerator(Of ElementId)
Visual C++
public ref class FilteredElementIdIterator : IEnumerator<ElementId^>

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilteredElementIdIterator

See Also

FilteredElementIdIterator Members


FilteredElementIdIterator Members

[image] [image]

Revit 2011 API
FilteredElementIdIterator Members
FilteredElementIdIterator Class Methods Properties See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurrent | The current element id found by the iterator.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element id passing the filter.
Reset | Resets the iterator to the beginning.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
CurrentObject |

See Also

FilteredElementIdIterator Class


FilteredElementIdIterator Methods

[image] [image]

Revit 2011 API
FilteredElementIdIterator Methods
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurrent | The current element id found by the iterator.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element id passing the filter.
Reset | Resets the iterator to the beginning.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredElementIdIterator Class


Dispose Method

[image]

Revit 2011 API
FilteredElementIdIterator..::.Dispose Method
FilteredElementIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIdIterator Class


GetCurrent Method

[image]

Revit 2011 API
FilteredElementIdIterator..::.GetCurrent Method
FilteredElementIdIterator Class See Also Send Feedback
The current element id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCurrent()
Visual Basic (Declaration)
Public Function GetCurrent As ElementId
Visual C++
public:
ElementId^ GetCurrent()

Return Value

The element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


IsDone Method

[image]

Revit 2011 API
FilteredElementIdIterator..::.IsDone Method
FilteredElementIdIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic (Declaration)
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


MoveNext Method

[image]

Revit 2011 API
FilteredElementIdIterator..::.MoveNext Method
FilteredElementIdIterator Class See Also Send Feedback
Increments the iterator to the next element id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element id passing the filter in this iterator. False if the iterator has completed all available element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


Reset Method

[image]

Revit 2011 API
FilteredElementIdIterator..::.Reset Method
FilteredElementIdIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


FilteredElementIdIterator Properties

[image] [image]

Revit 2011 API
FilteredElementIdIterator Properties
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Properties

Name | Description
Current |
CurrentObject |

See Also

FilteredElementIdIterator Class


Current Property

[image]

Revit 2011 API
FilteredElementIdIterator..::.Current Property
FilteredElementIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElementId Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As ElementId
Visual C++
public:
virtual property ElementId^ Current {
    ElementId^ get ();
}

Implements

IEnumerator<(Of <(T>)>)..::.Current

See Also

FilteredElementIdIterator Class


CurrentObject Property

[image]

Revit 2011 API
FilteredElementIdIterator..::.CurrentObject Property
FilteredElementIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Object CurrentObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentObject As Object
Visual C++
public:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::.Current

See Also

FilteredElementIdIterator Class


FilteredElementIterator Class

[image]

Revit 2011 API
FilteredElementIterator Class
Members See Also Send Feedback
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementIterator : IEnumerator<Element>
Visual Basic (Declaration)
Public Class FilteredElementIterator _
    Implements IEnumerator(Of Element)
Visual C++
public ref class FilteredElementIterator : IEnumerator<Element^>

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilteredElementIterator

See Also

FilteredElementIterator Members


FilteredElementIterator Members

[image] [image]

Revit 2011 API
FilteredElementIterator Members
FilteredElementIterator Class Methods Properties See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurrent | The current element found by the iterator.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element passing the filter.
Reset | Resets the iterator to the beginning.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
CurrentObject |

See Also

FilteredElementIterator Class


FilteredElementIterator Methods

[image] [image]

Revit 2011 API
FilteredElementIterator Methods
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurrent | The current element found by the iterator.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDone | Identifies if the iteration has completed.
MoveNext | Increments the iterator to the next element passing the filter.
Reset | Resets the iterator to the beginning.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredElementIterator Class


Dispose Method

[image]

Revit 2011 API
FilteredElementIterator..::.Dispose Method
FilteredElementIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIterator Class


GetCurrent Method

[image]

Revit 2011 API
FilteredElementIterator..::.GetCurrent Method
FilteredElementIterator Class See Also Send Feedback
The current element found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Element GetCurrent()
Visual Basic (Declaration)
Public Function GetCurrent As Element
Visual C++
public:
Element^ GetCurrent()

Return Value

The element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There are no more elements in the iterator. -or- The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


IsDone Method

[image]

Revit 2011 API
FilteredElementIterator..::.IsDone Method
FilteredElementIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic (Declaration)
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


MoveNext Method

[image]

Revit 2011 API
FilteredElementIterator..::.MoveNext Method
FilteredElementIterator Class See Also Send Feedback
Increments the iterator to the next element passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element passing the filter in this iterator. False if the iterator has completed all available elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


Reset Method

[image]

Revit 2011 API
FilteredElementIterator..::.Reset Method
FilteredElementIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The FilteredElementCollector which yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


FilteredElementIterator Properties

[image] [image]

Revit 2011 API
FilteredElementIterator Properties
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Properties

Name | Description
Current |
CurrentObject |

See Also

FilteredElementIterator Class


Current Property

[image]

Revit 2011 API
FilteredElementIterator..::.Current Property
FilteredElementIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Element Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Element
Visual C++
public:
virtual property Element^ Current {
    Element^ get ();
}

Implements

IEnumerator<(Of <(T>)>)..::.Current

See Also

FilteredElementIterator Class


CurrentObject Property

[image]

Revit 2011 API
FilteredElementIterator..::.CurrentObject Property
FilteredElementIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Object CurrentObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentObject As Object
Visual C++
public:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::.Current

See Also

FilteredElementIterator Class


FilterElement Class

[image]

Revit 2011 API
FilterElement Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterElement : Element
Visual Basic (Declaration)
Public Class FilterElement _
    Inherits Element
Visual C++
public ref class FilterElement : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.FilterElement
Autodesk.Revit.DB..::.ParameterFilterElement

See Also

FilterElement Members


FilterElement Members

[image] [image]

Revit 2011 API
FilterElement Members
FilterElement Class Methods Properties See Also Send Feedback

The FilterElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameNotEmpty |
IsNameUnique | Determines whether a potential filter element name is unique.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FilterElement Class


FilterElement Methods

[image] [image]

Revit 2011 API
FilterElement Methods
FilterElement Class See Also Send Feedback

The FilterElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameNotEmpty |
IsNameUnique | Determines whether a potential filter element name is unique.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterElement Class


IsNameNotEmpty Method

[image]

Revit 2011 API
FilterElement..::.IsNameNotEmpty Method
FilterElement Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsNameNotEmpty(
    string name
)
Visual Basic (Declaration)
Public Shared Function IsNameNotEmpty ( _
    name As String _
) As Boolean
Visual C++
public:
static bool IsNameNotEmpty(
    String^ name
)

Parameters

name
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterElement Class


IsNameUnique Method

[image]

Revit 2011 API
FilterElement..::.IsNameUnique Method
FilterElement Class See Also Send Feedback
Determines whether a potential filter element name is unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsNameUnique(
    string name
)
Visual Basic (Declaration)
Public Function IsNameUnique ( _
    name As String _
) As Boolean
Visual C++
public:
bool IsNameUnique(
    String^ name
)

Parameters

name
Type: System..::.String
The candidate name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterElement Class


FilterElement Properties

[image] [image]

Revit 2011 API
FilterElement Properties
FilterElement Class See Also Send Feedback

The FilterElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FilterElement Class


Parameter Property

[image] [image]

Revit 2011 API
FilterElement..::.Parameter Property
FilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FilterElement Class
FilterElement Members


FilterElementIdRule Class

[image]

Revit 2011 API
FilterElementIdRule Class
Members See Also Send Feedback
A filter rule that operates on ElementId values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterElementIdRule : FilterNumericValueRule
Visual Basic (Declaration)
Public Class FilterElementIdRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterElementIdRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterNumericValueRule
Autodesk.Revit.DB..::.FilterElementIdRule

See Also

FilterElementIdRule Members


FilterElementIdRule Members

[image] [image]

Revit 2011 API
FilterElementIdRule Members
FilterElementIdRule Class Constructors Methods Properties See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Constructors

Name | Description
FilterElementIdRule | Constructs an instance of FilterElementIdRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


FilterElementIdRule Constructor

[image]

Revit 2011 API
FilterElementIdRule Constructor
FilterElementIdRule Class See Also Send Feedback
Constructs an instance of FilterElementIdRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterElementIdRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As ElementId _
)
Visual C++
public:
FilterElementIdRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterElementIdRule Class


FilterElementIdRule Methods

[image] [image]

Revit 2011 API
FilterElementIdRule Methods
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterElementIdRule Class


FilterElementIdRule Properties

[image] [image]

Revit 2011 API
FilterElementIdRule Properties
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Properties

Name | Description
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


RuleValue Property

[image]

Revit 2011 API
FilterElementIdRule..::.RuleValue Property
FilterElementIdRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId RuleValue { get; set; }
Visual Basic (Declaration)
Public Property RuleValue As ElementId
Visual C++
public:
property ElementId^ RuleValue {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

FilterElementIdRule Class


FilterIntegerRule Class

[image]

Revit 2011 API
FilterIntegerRule Class
Members See Also Send Feedback
A filter rule that operates on integer values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterIntegerRule : FilterNumericValueRule
Visual Basic (Declaration)
Public Class FilterIntegerRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterIntegerRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterNumericValueRule
Autodesk.Revit.DB..::.FilterIntegerRule

See Also

FilterIntegerRule Members


FilterIntegerRule Members

[image] [image]

Revit 2011 API
FilterIntegerRule Members
FilterIntegerRule Class Constructors Methods Properties See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Constructors

Name | Description
FilterIntegerRule | Constructs an instance of FilterIntegerRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


FilterIntegerRule Constructor

[image]

Revit 2011 API
FilterIntegerRule Constructor
FilterIntegerRule Class See Also Send Feedback
Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterIntegerRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    int ruleValue
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Integer _
)
Visual C++
public:
FilterIntegerRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    int ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::.Int32
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterIntegerRule Class


FilterIntegerRule Methods

[image] [image]

Revit 2011 API
FilterIntegerRule Methods
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterIntegerRule Class


FilterIntegerRule Properties

[image] [image]

Revit 2011 API
FilterIntegerRule Properties
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Properties

Name | Description
RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


RuleValue Property

[image]

Revit 2011 API
FilterIntegerRule..::.RuleValue Property
FilterIntegerRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int RuleValue { get; set; }
Visual Basic (Declaration)
Public Property RuleValue As Integer
Visual C++
public:
property int RuleValue {
    int get ();
    void set (int value);
}

See Also

FilterIntegerRule Class


FilterInverseRule Class

[image]

Revit 2011 API
FilterInverseRule Class
Members See Also Send Feedback
A filter rule that inverts the boolean values returned by the rule it contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterInverseRule : FilterRule
Visual Basic (Declaration)
Public Class FilterInverseRule _
    Inherits FilterRule
Visual C++
public ref class FilterInverseRule : public FilterRule

Remarks

FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterInverseRule

See Also

FilterInverseRule Members


FilterInverseRule Members

[image] [image]

Revit 2011 API
FilterInverseRule Members
FilterInverseRule Class Constructors Methods See Also Send Feedback

The FilterInverseRule type exposes the following members.

Constructors

Name | Description
FilterInverseRule | Constructs a new instance of FilterInverseRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInnerRule | Gets the rule being inverted.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetInnerRule | Gets the rule being inverted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterInverseRule Class


FilterInverseRule Constructor

[image]

Revit 2011 API
FilterInverseRule Constructor
FilterInverseRule Class See Also Send Feedback
Constructs a new instance of FilterInverseRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterInverseRule(
    FilterRule innerRule
)
Visual Basic (Declaration)
Public Sub New ( _
    innerRule As FilterRule _
)
Visual C++
public:
FilterInverseRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterInverseRule Class


FilterInverseRule Methods

[image] [image]

Revit 2011 API
FilterInverseRule Methods
FilterInverseRule Class See Also Send Feedback

The FilterInverseRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInnerRule | Gets the rule being inverted.
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetInnerRule | Gets the rule being inverted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterInverseRule Class


GetInnerRule Method

[image]

Revit 2011 API
FilterInverseRule..::.GetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterRule GetInnerRule()
Visual Basic (Declaration)
Public Function GetInnerRule As FilterRule
Visual C++
public:
FilterRule^ GetInnerRule()

See Also

FilterInverseRule Class


SetInnerRule Method

[image]

Revit 2011 API
FilterInverseRule..::.SetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetInnerRule(
    FilterRule innerRule
)
Visual Basic (Declaration)
Public Sub SetInnerRule ( _
    innerRule As FilterRule _
)
Visual C++
public:
void SetInnerRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::.FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterInverseRule Class


FilterNumericEquals Class

[image]

Revit 2011 API
FilterNumericEquals Class
Members See Also Send Feedback
Tests whether numeric values from the document are equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericEquals : FilterNumericRuleEvaluator
Visual Basic (Declaration)
Public Class FilterNumericEquals _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericEquals : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericEquals

See Also

FilterNumericEquals Members


FilterNumericEquals Members

[image] [image]

Revit 2011 API
FilterNumericEquals Members
FilterNumericEquals Class Constructors Methods See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Constructors

Name | Description
FilterNumericEquals | Constructs an instance of FilterNumericEquals.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericEquals Class


FilterNumericEquals Constructor

[image]

Revit 2011 API
FilterNumericEquals Constructor
FilterNumericEquals Class See Also Send Feedback
Constructs an instance of FilterNumericEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericEquals()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNumericEquals()

See Also

FilterNumericEquals Class


FilterNumericEquals Methods

[image] [image]

Revit 2011 API
FilterNumericEquals Methods
FilterNumericEquals Class See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericEquals Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericEquals..::.Evaluate Method
FilterNumericEquals Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericEquals Class
FilterNumericEquals Members


FilterNumericGreater Class

[image]

Revit 2011 API
FilterNumericGreater Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericGreater : FilterNumericRuleEvaluator
Visual Basic (Declaration)
Public Class FilterNumericGreater _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreater : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericGreater

See Also

FilterNumericGreater Members


FilterNumericGreater Members

[image] [image]

Revit 2011 API
FilterNumericGreater Members
FilterNumericGreater Class Constructors Methods See Also Send Feedback

The FilterNumericGreater type exposes the following members.

Constructors

Name | Description
FilterNumericGreater | Constructs an instance of FilterNumericGreater.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreater Class


FilterNumericGreater Constructor

[image]

Revit 2011 API
FilterNumericGreater Constructor
FilterNumericGreater Class See Also Send Feedback
Constructs an instance of FilterNumericGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericGreater()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNumericGreater()

See Also

FilterNumericGreater Class


FilterNumericGreater Methods

[image] [image]

Revit 2011 API
FilterNumericGreater Methods
FilterNumericGreater Class See Also Send Feedback

The FilterNumericGreater type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreater Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericGreater..::.Evaluate Method
FilterNumericGreater Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreater Class
FilterNumericGreater Members


FilterNumericGreaterOrEqual Class

[image]

Revit 2011 API
FilterNumericGreaterOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericGreaterOrEqual : FilterNumericRuleEvaluator
Visual Basic (Declaration)
Public Class FilterNumericGreaterOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreaterOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericGreaterOrEqual

See Also

FilterNumericGreaterOrEqual Members


FilterNumericGreaterOrEqual Members

[image] [image]

Revit 2011 API
FilterNumericGreaterOrEqual Members
FilterNumericGreaterOrEqual Class Constructors Methods See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Constructors

Name | Description
FilterNumericGreaterOrEqual | Constructs an instance of FilterNumericGreaterOrEqual.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Constructor

[image]

Revit 2011 API
FilterNumericGreaterOrEqual Constructor
FilterNumericGreaterOrEqual Class See Also Send Feedback
Constructs an instance of FilterNumericGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericGreaterOrEqual()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNumericGreaterOrEqual()

See Also

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Methods

[image] [image]

Revit 2011 API
FilterNumericGreaterOrEqual Methods
FilterNumericGreaterOrEqual Class See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreaterOrEqual Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericGreaterOrEqual..::.Evaluate Method
FilterNumericGreaterOrEqual Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreaterOrEqual Class
FilterNumericGreaterOrEqual Members


FilterNumericLess Class

[image]

Revit 2011 API
FilterNumericLess Class
Members See Also Send Feedback
Tests whether numeric values from the document are less than a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericLess : FilterNumericRuleEvaluator
Visual Basic (Declaration)
Public Class FilterNumericLess _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericLess : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericLess

See Also

FilterNumericLess Members


FilterNumericLess Members

[image] [image]

Revit 2011 API
FilterNumericLess Members
FilterNumericLess Class Constructors Methods See Also Send Feedback

The FilterNumericLess type exposes the following members.

Constructors

Name | Description
FilterNumericLess | Constructs an instance of FilterNumericLess.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLess Class


FilterNumericLess Constructor

[image]

Revit 2011 API
FilterNumericLess Constructor
FilterNumericLess Class See Also Send Feedback
Constructs an instance of FilterNumericLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericLess()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNumericLess()

See Also

FilterNumericLess Class


FilterNumericLess Methods

[image] [image]

Revit 2011 API
FilterNumericLess Methods
FilterNumericLess Class See Also Send Feedback

The FilterNumericLess type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLess Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericLess..::.Evaluate Method
FilterNumericLess Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLess Class
FilterNumericLess Members


FilterNumericLessOrEqual Class

[image]

Revit 2011 API
FilterNumericLessOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are less than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericLessOrEqual : FilterNumericRuleEvaluator
Visual Basic (Declaration)
Public Class FilterNumericLessOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericLessOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericLessOrEqual

See Also

FilterNumericLessOrEqual Members


FilterNumericLessOrEqual Members

[image] [image]

Revit 2011 API
FilterNumericLessOrEqual Members
FilterNumericLessOrEqual Class Constructors Methods See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Constructors

Name | Description
FilterNumericLessOrEqual | Constructs an instance of FilterNumericLessOrEqual.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Constructor

[image]

Revit 2011 API
FilterNumericLessOrEqual Constructor
FilterNumericLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterNumericLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericLessOrEqual()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterNumericLessOrEqual()

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Methods

[image] [image]

Revit 2011 API
FilterNumericLessOrEqual Methods
FilterNumericLessOrEqual Class See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterNumericRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLessOrEqual Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericLessOrEqual..::.Evaluate Method
FilterNumericLessOrEqual Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLessOrEqual Class
FilterNumericLessOrEqual Members


FilterNumericRuleEvaluator Class

[image]

Revit 2011 API
FilterNumericRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericRuleEvaluator : IDisposable
Visual Basic (Declaration)
Public Class FilterNumericRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterNumericRuleEvaluator : IDisposable

Remarks

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterNumericRuleEvaluator
Autodesk.Revit.DB..::.FilterNumericEquals
Autodesk.Revit.DB..::.FilterNumericGreater
Autodesk.Revit.DB..::.FilterNumericGreaterOrEqual
Autodesk.Revit.DB..::.FilterNumericLess
Autodesk.Revit.DB..::.FilterNumericLessOrEqual

See Also

FilterNumericRuleEvaluator Members


FilterNumericRuleEvaluator Members

[image] [image]

Revit 2011 API
FilterNumericRuleEvaluator Members
FilterNumericRuleEvaluator Class Methods See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator Methods

[image] [image]

Revit 2011 API
FilterNumericRuleEvaluator Methods
FilterNumericRuleEvaluator Class See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericRuleEvaluator Class


Dispose Method

[image]

Revit 2011 API
FilterNumericRuleEvaluator..::.Dispose Method
FilterNumericRuleEvaluator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FilterNumericRuleEvaluator Class


Evaluate Method

[image] [image]

Revit 2011 API
FilterNumericRuleEvaluator..::.Evaluate Method
FilterNumericRuleEvaluator Class See Also Send Feedback

Overload List

Name | Description
Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test.
Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

See Also

FilterNumericRuleEvaluator Class
FilterNumericRuleEvaluator Members


Evaluate Method (Int32, Int32)

[image]

Revit 2011 API
FilterNumericRuleEvaluator..::.Evaluate Method (Int32, Int32)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    int lhs,
    int rhs
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    lhs As Integer, _
    rhs As Integer _
) As Boolean
Visual C++
public:
bool Evaluate(
    int lhs,
    int rhs
)

Parameters

lhs
Type: System..::.Int32
A value from an element in the document.
rhs
Type: System..::.Int32
The user-supplied value against which values from the document are tested.

Return Value

True if lhs, rhs satisfy the condition implemented by this evaluator.

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


Evaluate Method (Double, Double, Double)

[image]

Revit 2011 API
FilterNumericRuleEvaluator..::.Evaluate Method (Double, Double, Double)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    lhs As Double, _
    rhs As Double, _
    epsilon As Double _
) As Boolean
Visual C++
public:
bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)

Parameters

lhs
Type: System..::.Double
A value from an element in the document.
rhs
Type: System..::.Double
The user-supplied value against which values from the document are tested.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Return Value

True if the given arguments satisfy the condition, otherwise false.

Remarks

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for lhs is not finite -or- The given value for lhs is not a number -or- The given value for rhs is not finite -or- The given value for rhs is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericValueRule Class

[image]

Revit 2011 API
FilterNumericValueRule Class
Members See Also Send Feedback
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericValueRule : FilterValueRule
Visual Basic (Declaration)
Public Class FilterNumericValueRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterNumericValueRule : public FilterValueRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterNumericValueRule
Autodesk.Revit.DB..::.FilterDoubleRule
Autodesk.Revit.DB..::.FilterElementIdRule
Autodesk.Revit.DB..::.FilterIntegerRule

See Also

FilterNumericValueRule Members


FilterNumericValueRule Members

[image] [image]

Revit 2011 API
FilterNumericValueRule Members
FilterNumericValueRule Class Methods See Also Send Feedback

The FilterNumericValueRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericValueRule Class


FilterNumericValueRule Methods

[image] [image]

Revit 2011 API
FilterNumericValueRule Methods
FilterNumericValueRule Class See Also Send Feedback

The FilterNumericValueRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericValueRule Class


GetEvaluator Method

[image]

Revit 2011 API
FilterNumericValueRule..::.GetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterNumericRuleEvaluator GetEvaluator()
Visual Basic (Declaration)
Public Function GetEvaluator As FilterNumericRuleEvaluator
Visual C++
public:
FilterNumericRuleEvaluator^ GetEvaluator()

See Also

FilterNumericValueRule Class


SetEvaluator Method

[image]

Revit 2011 API
FilterNumericValueRule..::.SetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterNumericRuleEvaluator evaluator
)
Visual Basic (Declaration)
Public Sub SetEvaluator ( _
    evaluator As FilterNumericRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterNumericRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::.FilterNumericRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterNumericValueRule Class


FilterRule Class

[image]

Revit 2011 API
FilterRule Class
Members See Also Send Feedback
Defines a boolean operation that can be used to cull elements from a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterRule : IDisposable
Visual Basic (Declaration)
Public Class FilterRule _
    Implements IDisposable
Visual C++
public ref class FilterRule : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterInverseRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.SharedParameterApplicableRule

See Also

FilterRule Members


FilterRule Members

[image] [image]

Revit 2011 API
FilterRule Members
FilterRule Class Methods See Also Send Feedback

The FilterRule type exposes the following members.

Methods

Name | Description
Dispose |
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterRule Class


FilterRule Methods

[image] [image]

Revit 2011 API
FilterRule Methods
FilterRule Class See Also Send Feedback

The FilterRule type exposes the following members.

Methods

Name | Description
Dispose |
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterRule Class


Dispose Method

[image]

Revit 2011 API
FilterRule..::.Dispose Method
FilterRule Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FilterRule Class


ElementPasses Method

[image]

Revit 2011 API
FilterRule..::.ElementPasses Method
FilterRule Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the given element passes this rule or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ElementPasses(
    Element element
)
Visual Basic (Declaration)
Public Function ElementPasses ( _
    element As Element _
) As Boolean
Visual C++
public:
bool ElementPasses(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to test against the rule.

Return Value

True if the element satisfies the rule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterRule Class


FilterStringBeginsWith Class

[image]

Revit 2011 API
FilterStringBeginsWith Class
Members See Also Send Feedback
Tests whether string values from the document begin with a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringBeginsWith : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringBeginsWith _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringBeginsWith : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringBeginsWith

See Also

FilterStringBeginsWith Members


FilterStringBeginsWith Members

[image] [image]

Revit 2011 API
FilterStringBeginsWith Members
FilterStringBeginsWith Class Constructors Methods See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Constructors

Name | Description
FilterStringBeginsWith | Constructs an instance of FilterStringBeginsWith.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Constructor

[image]

Revit 2011 API
FilterStringBeginsWith Constructor
FilterStringBeginsWith Class See Also Send Feedback
Constructs an instance of FilterStringBeginsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringBeginsWith()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringBeginsWith()

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Methods

[image] [image]

Revit 2011 API
FilterStringBeginsWith Methods
FilterStringBeginsWith Class See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringBeginsWith Class


FilterStringContains Class

[image]

Revit 2011 API
FilterStringContains Class
Members See Also Send Feedback
Tests whether string values from the document contain a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringContains : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringContains _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringContains : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringContains

See Also

FilterStringContains Members


FilterStringContains Members

[image] [image]

Revit 2011 API
FilterStringContains Members
FilterStringContains Class Constructors Methods See Also Send Feedback

The FilterStringContains type exposes the following members.

Constructors

Name | Description
FilterStringContains | Constructs an instance of FilterStringContains.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringContains Class


FilterStringContains Constructor

[image]

Revit 2011 API
FilterStringContains Constructor
FilterStringContains Class See Also Send Feedback
Constructs an instance of FilterStringContains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringContains()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringContains()

See Also

FilterStringContains Class


FilterStringContains Methods

[image] [image]

Revit 2011 API
FilterStringContains Methods
FilterStringContains Class See Also Send Feedback

The FilterStringContains type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringContains Class


FilterStringEndsWith Class

[image]

Revit 2011 API
FilterStringEndsWith Class
Members See Also Send Feedback
Tests whether string values from the document end with a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringEndsWith : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringEndsWith _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringEndsWith : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringEndsWith

See Also

FilterStringEndsWith Members


FilterStringEndsWith Members

[image] [image]

Revit 2011 API
FilterStringEndsWith Members
FilterStringEndsWith Class Constructors Methods See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Constructors

Name | Description
FilterStringEndsWith | Constructs an instance of FilterStringEndsWith.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEndsWith Class


FilterStringEndsWith Constructor

[image]

Revit 2011 API
FilterStringEndsWith Constructor
FilterStringEndsWith Class See Also Send Feedback
Constructs an instance of FilterStringEndsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringEndsWith()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringEndsWith()

See Also

FilterStringEndsWith Class


FilterStringEndsWith Methods

[image] [image]

Revit 2011 API
FilterStringEndsWith Methods
FilterStringEndsWith Class See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEndsWith Class


FilterStringEquals Class

[image]

Revit 2011 API
FilterStringEquals Class
Members See Also Send Feedback
Tests whether string values from the document match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringEquals : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringEquals _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringEquals : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringEquals

See Also

FilterStringEquals Members


FilterStringEquals Members

[image] [image]

Revit 2011 API
FilterStringEquals Members
FilterStringEquals Class Constructors Methods See Also Send Feedback

The FilterStringEquals type exposes the following members.

Constructors

Name | Description
FilterStringEquals | Constructs an instance of FilterStringEquals.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEquals Class


FilterStringEquals Constructor

[image]

Revit 2011 API
FilterStringEquals Constructor
FilterStringEquals Class See Also Send Feedback
Constructs an instance of FilterStringEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringEquals()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringEquals()

See Also

FilterStringEquals Class


FilterStringEquals Methods

[image] [image]

Revit 2011 API
FilterStringEquals Methods
FilterStringEquals Class See Also Send Feedback

The FilterStringEquals type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEquals Class


FilterStringGreater Class

[image]

Revit 2011 API
FilterStringGreater Class
Members See Also Send Feedback
Tests whether string values from the document would sort after a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringGreater : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringGreater _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreater : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringGreater

See Also

FilterStringGreater Members


FilterStringGreater Members

[image] [image]

Revit 2011 API
FilterStringGreater Members
FilterStringGreater Class Constructors Methods See Also Send Feedback

The FilterStringGreater type exposes the following members.

Constructors

Name | Description
FilterStringGreater | Constructs an instance of FilterStringGreater.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreater Class


FilterStringGreater Constructor

[image]

Revit 2011 API
FilterStringGreater Constructor
FilterStringGreater Class See Also Send Feedback
Constructs an instance of FilterStringGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringGreater()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringGreater()

See Also

FilterStringGreater Class


FilterStringGreater Methods

[image] [image]

Revit 2011 API
FilterStringGreater Methods
FilterStringGreater Class See Also Send Feedback

The FilterStringGreater type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreater Class


FilterStringGreaterOrEqual Class

[image]

Revit 2011 API
FilterStringGreaterOrEqual Class
Members See Also Send Feedback
Tests whether string values from the document would sort after or match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringGreaterOrEqual : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringGreaterOrEqual _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreaterOrEqual : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringGreaterOrEqual

See Also

FilterStringGreaterOrEqual Members


FilterStringGreaterOrEqual Members

[image] [image]

Revit 2011 API
FilterStringGreaterOrEqual Members
FilterStringGreaterOrEqual Class Constructors Methods See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Constructors

Name | Description
FilterStringGreaterOrEqual | Constructs an instance of FilterStringGreaterOrEqual.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Constructor

[image]

Revit 2011 API
FilterStringGreaterOrEqual Constructor
FilterStringGreaterOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringGreaterOrEqual()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringGreaterOrEqual()

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Methods

[image] [image]

Revit 2011 API
FilterStringGreaterOrEqual Methods
FilterStringGreaterOrEqual Class See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreaterOrEqual Class


FilterStringLess Class

[image]

Revit 2011 API
FilterStringLess Class
Members See Also Send Feedback
Tests whether string values from the document would sort before a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringLess : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringLess _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringLess : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringLess

See Also

FilterStringLess Members


FilterStringLess Members

[image] [image]

Revit 2011 API
FilterStringLess Members
FilterStringLess Class Constructors Methods See Also Send Feedback

The FilterStringLess type exposes the following members.

Constructors

Name | Description
FilterStringLess | Constructs an instance of FilterStringLess.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLess Class


FilterStringLess Constructor

[image]

Revit 2011 API
FilterStringLess Constructor
FilterStringLess Class See Also Send Feedback
Constructs an instance of FilterStringLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringLess()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringLess()

See Also

FilterStringLess Class


FilterStringLess Methods

[image] [image]

Revit 2011 API
FilterStringLess Methods
FilterStringLess Class See Also Send Feedback

The FilterStringLess type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLess Class


FilterStringLessOrEqual Class

[image]

Revit 2011 API
FilterStringLessOrEqual Class
Members See Also Send Feedback
Tests whether string values from the document would sort before or match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringLessOrEqual : FilterStringRuleEvaluator
Visual Basic (Declaration)
Public Class FilterStringLessOrEqual _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringLessOrEqual : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringLessOrEqual

See Also

FilterStringLessOrEqual Members


FilterStringLessOrEqual Members

[image] [image]

Revit 2011 API
FilterStringLessOrEqual Members
FilterStringLessOrEqual Class Constructors Methods See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Constructors

Name | Description
FilterStringLessOrEqual | Constructs an instance of FilterStringLessOrEqual.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Constructor

[image]

Revit 2011 API
FilterStringLessOrEqual Constructor
FilterStringLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringLessOrEqual()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterStringLessOrEqual()

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Methods

[image] [image]

Revit 2011 API
FilterStringLessOrEqual Methods
FilterStringLessOrEqual Class See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterStringRuleEvaluator.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLessOrEqual Class


FilterStringRule Class

[image]

Revit 2011 API
FilterStringRule Class
Members See Also Send Feedback
A filter rule that operates on string values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringRule : FilterValueRule
Visual Basic (Declaration)
Public Class FilterStringRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterStringRule : public FilterValueRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterStringRule

See Also

FilterStringRule Members


FilterStringRule Members

[image] [image]

Revit 2011 API
FilterStringRule Members
FilterStringRule Class Constructors Methods Properties See Also Send Feedback

The FilterStringRule type exposes the following members.

Constructors

Name | Description
FilterStringRule | Constructs an instance of FilterStringRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | The boolean flag that determines whether or not the filter rule respects case when comparing strings.
RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class


FilterStringRule Constructor

[image]

Revit 2011 API
FilterStringRule Constructor
FilterStringRule Class See Also Send Feedback
Constructs an instance of FilterStringRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringRule(
    FilterableValueProvider valueProvider,
    FilterStringRuleEvaluator evaluator,
    string ruleString,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterStringRuleEvaluator, _
    ruleString As String, _
    caseSensitive As Boolean _
)
Visual C++
public:
FilterStringRule(
    FilterableValueProvider^ valueProvider,
    FilterStringRuleEvaluator^ evaluator,
    String^ ruleString,
    bool caseSensitive
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::.FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::.FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
ruleString
Type: System..::.String
The user-supplied string against which strings from a Revit document will be tested.
caseSensitive
Type: System..::.Boolean
If true, string comparisons will be done case-sensitively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRule Class


FilterStringRule Methods

[image] [image]

Revit 2011 API
FilterStringRule Methods
FilterStringRule Class See Also Send Feedback

The FilterStringRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEvaluator | Gets the evaluator that implements the test for this rule.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEvaluator | Sets the evaluator that implements the test for this rule.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRule Class


GetEvaluator Method

[image]

Revit 2011 API
FilterStringRule..::.GetEvaluator Method
FilterStringRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FilterStringRuleEvaluator GetEvaluator()
Visual Basic (Declaration)
Public Function GetEvaluator As FilterStringRuleEvaluator
Visual C++
public:
FilterStringRuleEvaluator^ GetEvaluator()

See Also

FilterStringRule Class


SetEvaluator Method

[image]

Revit 2011 API
FilterStringRule..::.SetEvaluator Method
FilterStringRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterStringRuleEvaluator evaluator
)
Visual Basic (Declaration)
Public Sub SetEvaluator ( _
    evaluator As FilterStringRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterStringRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::.FilterStringRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRule Class


FilterStringRule Properties

[image] [image]

Revit 2011 API
FilterStringRule Properties
FilterStringRule Class See Also Send Feedback

The FilterStringRule type exposes the following members.

Properties

Name | Description
CaseSensitive | The boolean flag that determines whether or not the filter rule respects case when comparing strings.
RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class


CaseSensitive Property

[image]

Revit 2011 API
FilterStringRule..::.CaseSensitive Property
FilterStringRule Class See Also Send Feedback
The boolean flag that determines whether or not the filter rule respects case when comparing strings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CaseSensitive { get; set; }
Visual Basic (Declaration)
Public Property CaseSensitive As Boolean
Visual C++
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

FilterStringRule Class


RuleString Property

[image]

Revit 2011 API
FilterStringRule..::.RuleString Property
FilterStringRule Class See Also Send Feedback
The user-supplied string against which strings from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string RuleString { get; set; }
Visual Basic (Declaration)
Public Property RuleString As String
Visual C++
public:
property String^ RuleString {
    String^ get ();
    void set (String^ value);
}

See Also

FilterStringRule Class


FilterStringRuleEvaluator Class

[image]

Revit 2011 API
FilterStringRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare string values from Revit to a user-supplied filter value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterStringRuleEvaluator : IDisposable
Visual Basic (Declaration)
Public Class FilterStringRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterStringRuleEvaluator : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterStringRuleEvaluator
Autodesk.Revit.DB..::.FilterStringBeginsWith
Autodesk.Revit.DB..::.FilterStringContains
Autodesk.Revit.DB..::.FilterStringEndsWith
Autodesk.Revit.DB..::.FilterStringEquals
Autodesk.Revit.DB..::.FilterStringGreater
Autodesk.Revit.DB..::.FilterStringGreaterOrEqual
Autodesk.Revit.DB..::.FilterStringLess
Autodesk.Revit.DB..::.FilterStringLessOrEqual

See Also

FilterStringRuleEvaluator Members


FilterStringRuleEvaluator Members

[image] [image]

Revit 2011 API
FilterStringRuleEvaluator Members
FilterStringRuleEvaluator Class Methods See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator Methods

[image] [image]

Revit 2011 API
FilterStringRuleEvaluator Methods
FilterStringRuleEvaluator Class See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRuleEvaluator Class


Dispose Method

[image]

Revit 2011 API
FilterStringRuleEvaluator..::.Dispose Method
FilterStringRuleEvaluator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FilterStringRuleEvaluator Class


Evaluate Method

[image]

Revit 2011 API
FilterStringRuleEvaluator..::.Evaluate Method
FilterStringRuleEvaluator Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    string lhs,
    string rhs,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Function Evaluate ( _
    lhs As String, _
    rhs As String, _
    caseSensitive As Boolean _
) As Boolean
Visual C++
public:
bool Evaluate(
    String^ lhs,
    String^ rhs,
    bool caseSensitive
)

Parameters

lhs
Type: System..::.String
A value from an element in the document.
rhs
Type: System..::.String
The user-supplied value against which values from the document are tested.
caseSensitive
Type: System..::.Boolean
If true, string comparisons are done case-sensitively.

Return Value

True if the given arguments satisfy the condition, otherwise false.

Remarks

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRuleEvaluator Class


FilterValueRule Class

[image]

Revit 2011 API
FilterValueRule Class
Members See Also Send Feedback
A rule that filters on a particular value of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FilterValueRule : FilterRule
Visual Basic (Declaration)
Public Class FilterValueRule _
    Inherits FilterRule
Visual C++
public ref class FilterValueRule : public FilterRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.FilterValueRule
Autodesk.Revit.DB..::.FilterNumericValueRule
Autodesk.Revit.DB..::.FilterStringRule

See Also

FilterValueRule Members


FilterValueRule Members

[image] [image]

Revit 2011 API
FilterValueRule Members
FilterValueRule Class Methods See Also Send Feedback

The FilterValueRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterValueRule Class


FilterValueRule Methods

[image] [image]

Revit 2011 API
FilterValueRule Methods
FilterValueRule Class See Also Send Feedback

The FilterValueRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterValueRule Class


FitDirectionType Enumeration

[image]

Revit 2011 API
FitDirectionType Enumeration
See Also Send Feedback
This enum is used to define the direction to fit the number of pixels defined by PixelSize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum FitDirectionType
Visual Basic (Declaration)
Public Enumeration FitDirectionType
Visual C++
public enum class FitDirectionType

Members

Member name | Description
Horizontal | Fit a specific number of pixels in horizontal direction.
Vertical | Fit a specific number of pixels in vertical direction.

See Also


Floor Class

[image]

Revit 2011 API
Floor Class
Members Example See Also Send Feedback
An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Floor : HostObject
Visual Basic (Declaration)
Public Class Floor _
    Inherits HostObject
Visual C++
public ref class Floor : public HostObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor AnalyticalModel
    message += "\nFloor AnalyticalModel is : " + floor.GetAnalyticalModel();

    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Public Sub ShowFloorInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim message As String = "Floor : "
    ' Get Floor AnalyticalModel
    message += vbLf & "Floor AnalyticalModel is : " & floor.GetAnalyticalModel().ToString()

    ' Get Floor type name
    message += vbLf & "Floor type name is : " & floor.FloorType.Name.ToString()
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " + floor.SpanDirectionAngle
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.Floor

See Also

Floor Members


Floor Members

[image] [image]

Revit 2011 API
Floor Members
Floor Class Methods Properties See Also Send Feedback

The Floor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorType | Retrieves/set an object that represents the type of the floor.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Floor Class


Floor Methods

[image] [image]

Revit 2011 API
Floor Methods
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Floor Class


GetNormalAtVerticalProjectionPoint Method

[image]

Revit 2011 API
Floor..::.GetNormalAtVerticalProjectionPoint Method
Floor Class See Also Send Feedback
Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ GetNormalAtVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Visual Basic (Declaration)
Public Function GetNormalAtVerticalProjectionPoint ( _
    modelLocation As XYZ, _
    floorFace As FloorFace _
) As XYZ
Visual C++
public:
XYZ^ GetNormalAtVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)

Parameters

modelLocation
Type: Autodesk.Revit.DB..::.XYZ
A point in project coordinates whose vertical projection will determine the location at which the normal will be taken.
floorFace
Type: Autodesk.Revit.DB..::.FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

Normal vector on the slab at the projection point.

Remarks

If the floor is shape edited, the floor location at which we attempt to take the normal must be within the boundaries of a face on the slab. Otherwise the method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


GetVerticalProjectionPoint Method

[image]

Revit 2011 API
Floor..::.GetVerticalProjectionPoint Method
Floor Class See Also Send Feedback
Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ GetVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Visual Basic (Declaration)
Public Function GetVerticalProjectionPoint ( _
    modelLocation As XYZ, _
    floorFace As FloorFace _
) As XYZ
Visual C++
public:
XYZ^ GetVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)

Parameters

modelLocation
Type: Autodesk.Revit.DB..::.XYZ
A point in project coordinates that will be projected to the slab top or bottom face.
floorFace
Type: Autodesk.Revit.DB..::.FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

Slab surface point for the vertically projected model point.

Remarks

If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


Floor Properties

[image] [image]

Revit 2011 API
Floor Properties
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorType | Retrieves/set an object that represents the type of the floor.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
SpanDirectionAngle | Retrieve the span direction angle of the floor
SpanDirectionSymbols | An array of span direction symbols associated with this floor.
StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Floor Class


FloorType Property

[image]

Revit 2011 API
Floor..::.FloorType Property
Floor Class See Also Send Feedback
Retrieves/set an object that represents the type of the floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FloorType FloorType { get; set; }
Visual Basic (Declaration)
Public Property FloorType As FloorType
Visual C++
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}

Remarks

The floor type can be used to access the multi layered structure of a floor.

See Also

Floor Class


Parameter Property

[image] [image]

Revit 2011 API
Floor..::.Parameter Property
Floor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Floor Class
Floor Members


SlabShapeEditor Property

[image]

Revit 2011 API
Floor..::.SlabShapeEditor Property
Floor Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit.Otherwise, ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


SpanDirectionAngle Property

[image]

Revit 2011 API
Floor..::.SpanDirectionAngle Property
Floor Class See Also Send Feedback
Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SpanDirectionAngle { get; set; }
Visual Basic (Declaration)
Public Property SpanDirectionAngle As Double
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class


SpanDirectionSymbols Property

[image]

Revit 2011 API
Floor..::.SpanDirectionSymbols Property
Floor Class Example See Also Send Feedback
An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray SpanDirectionSymbols { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpanDirectionSymbols As ElementArray
Visual C++
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjectType property of these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

Examples

CopyC#
public void SpanDirectionSymbolsInfo(Floor floor)
{
    string msg = "";
    if (0 == floor.SpanDirectionSymbols.Size)
    {
        msg = "No span direction symbol!";
    }
    foreach (Element element in floor.SpanDirectionSymbols)
    {
        msg += "Span direction symbol name is : " + element.Name;
    }

    // Give the user some information.
    TaskDialog.Show("Revit",msg);
}
CopyVB.NET
Public Sub SpanDirectionSymbolsInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim msg As String = ""
    If 0 = floor.SpanDirectionSymbols.Size Then
        msg = "No span direction symbol!"
    End If
    For Each element As Autodesk.Revit.DB.Element In floor.SpanDirectionSymbols
        msg += "Span direction symbol name is : " + element.Name
    Next

    ' Give the user some information.
    TaskDialog.Show("Revit", msg)
End Sub

See Also

Floor Class


StructuralUsage Property

[image]

Revit 2011 API
Floor..::.StructuralUsage Property
Floor Class See Also Send Feedback
The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabFoundationType StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As SlabFoundationType
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class


FloorFace Enumeration

[image]

Revit 2011 API
FloorFace Enumeration
See Also Send Feedback
An enumerated type listing floor face types (top or bottom)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum FloorFace
Visual Basic (Declaration)
Public Enumeration FloorFace
Visual C++
public enum class FloorFace

Members

Member name | Description
Top |
Bottom |

See Also


FloorType Class

[image]

Revit 2011 API
FloorType Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic (Declaration)
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FloorType(ByVal floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & floorType.IsFoundationSlab.ToString()
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.FloorType

See Also

FloorType Members


FloorType Members

[image] [image]

Revit 2011 API
FloorType Members
FloorType Class Methods Properties See Also Send Feedback

The FloorType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FloorType Class


FloorType Methods

[image] [image]

Revit 2011 API
FloorType Methods
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorType Class


FloorType Properties

[image] [image]

Revit 2011 API
FloorType Properties
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FloorType Class


IsFoundationSlab Property

[image]

Revit 2011 API
FloorType..::.IsFoundationSlab Property
FloorType Class See Also Send Feedback
Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFoundationSlab { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFoundationSlab As Boolean
Visual C++
public:
property bool IsFoundationSlab {
    bool get ();
}

See Also

FloorType Class


Parameter Property

[image] [image]

Revit 2011 API
FloorType..::.Parameter Property
FloorType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FloorType Class
FloorType Members


FloorTypeSet Class

[image]

Revit 2011 API
FloorTypeSet Class
Members See Also Send Feedback
A set that contains floor types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FloorTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FloorTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FloorTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FloorTypeSet

See Also

FloorTypeSet Members


FloorTypeSet Members

[image] [image]

Revit 2011 API
FloorTypeSet Members
FloorTypeSet Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSet type exposes the following members.

Constructors

Name | Description
FloorTypeSet | Initializes a new instance of the FloorTypeSet class

Methods

Name | Description
Clear | Removes every floor type from the set, rendering it empty.
Contains | Tests for the existence of a floor type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified floor type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified floor type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class


FloorTypeSet Constructor

[image]

Revit 2011 API
FloorTypeSet Constructor
FloorTypeSet Class See Also Send Feedback
Initializes a new instance of the FloorTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FloorTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSet()

See Also

FloorTypeSet Class


FloorTypeSet Methods

[image] [image]

Revit 2011 API
FloorTypeSet Methods
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every floor type from the set, rendering it empty.
Contains | Tests for the existence of a floor type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified floor type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified floor type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSet Class


Clear Method

[image]

Revit 2011 API
FloorTypeSet..::.Clear Method
FloorTypeSet Class See Also Send Feedback
Removes every floor type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FloorTypeSet Class


Contains Method

[image]

Revit 2011 API
FloorTypeSet..::.Contains Method
FloorTypeSet Class See Also Send Feedback
Tests for the existence of a floor type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FloorType
The floor type to be searched for.

Return Value

The Contains method returns True if the floor type is within the set, otherwise False.

See Also

FloorTypeSet Class


Erase Method

[image]

Revit 2011 API
FloorTypeSet..::.Erase Method
FloorTypeSet Class See Also Send Feedback
Removes a specified floor type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FloorType _
) As Integer
Visual C++
public:
virtual int Erase(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FloorType
The floor type to be erased.

Return Value

The number of floor types that were erased from the set.

See Also

FloorTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
FloorTypeSet..::.ForwardIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FloorTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
FloorTypeSet..::.GetEnumerator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FloorTypeSet Class


Insert Method

[image]

Revit 2011 API
FloorTypeSet..::.Insert Method
FloorTypeSet Class See Also Send Feedback
Insert the specified floor type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FloorType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.FloorType
The floor type to be inserted into the set.

Return Value

Returns whether the floor type was inserted into the set.

See Also

FloorTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
FloorTypeSet..::.ReverseIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FloorTypeSet Class


FloorTypeSet Properties

[image] [image]

Revit 2011 API
FloorTypeSet Properties
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
FloorTypeSet..::.IsEmpty Property
FloorTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FloorTypeSet Class


Size Property

[image]

Revit 2011 API
FloorTypeSet..::.Size Property
FloorTypeSet Class See Also Send Feedback
Returns the number of floor types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FloorTypeSet Class


FloorTypeSetIterator Class

[image]

Revit 2011 API
FloorTypeSetIterator Class
Members See Also Send Feedback
An iterator to a floor type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FloorTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FloorTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FloorTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FloorTypeSetIterator

See Also

FloorTypeSetIterator Members


FloorTypeSetIterator Members

[image] [image]

Revit 2011 API
FloorTypeSetIterator Members
FloorTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Constructors

Name | Description
FloorTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Constructor

[image]

Revit 2011 API
FloorTypeSetIterator Constructor
FloorTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FloorTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FloorTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Methods

[image] [image]

Revit 2011 API
FloorTypeSetIterator Methods
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
FloorTypeSetIterator..::.MoveNext Method
FloorTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
FloorTypeSetIterator..::.Reset Method
FloorTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Properties

[image] [image]

Revit 2011 API
FloorTypeSetIterator Properties
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class


Current Property

[image]

Revit 2011 API
FloorTypeSetIterator..::.Current Property
FloorTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class


FlowDirectionType Enumeration

[image]

Revit 2011 API
FlowDirectionType Enumeration
See Also Send Feedback
An enumerated type listing direction types for a connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum FlowDirectionType
Visual Basic (Declaration)
Public Enumeration FlowDirectionType
Visual C++
public enum class FlowDirectionType

Members

Member name | Description
Bidirectional | flow bidirectional
In | flow in
Out | flow out

See Also


FootPrintRoof Class

[image]

Revit 2011 API
FootPrintRoof Class
Members See Also Send Feedback
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic (Declaration)
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.FootPrintRoof

See Also

FootPrintRoof Members


FootPrintRoof Members

[image] [image]

Revit 2011 API
FootPrintRoof Members
FootPrintRoof Class Methods Properties See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
SlopeAngle | Retrieve or set the SlopeAngle of the curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FootPrintRoof Class


FootPrintRoof Methods

[image] [image]

Revit 2011 API
FootPrintRoof Methods
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FootPrintRoof Class


GetProfiles Method

[image]

Revit 2011 API
FootPrintRoof..::.GetProfiles Method
FootPrintRoof Class See Also Send Feedback
Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArrArray GetProfiles()
Visual Basic (Declaration)
Public Function GetProfiles As ModelCurveArrArray
Visual C++
public:
ModelCurveArrArray^ GetProfiles()

See Also

FootPrintRoof Class


FootPrintRoof Properties

[image] [image]

Revit 2011 API
FootPrintRoof Properties
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
DefinesSlope | Retrieve or set the DefinesSlope of the curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
ExtendIntoWall | Retrieve or set whether extend into wall the curve.
FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Offset | Retrieve or set the Offset of the curve.
Overhang | Retrieve or set the Overhang of the curve.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
SlopeAngle | Retrieve or set the SlopeAngle of the curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FootPrintRoof Class


CurtainGrids Property

[image]

Revit 2011 API
FootPrintRoof..::.CurtainGrids Property
FootPrintRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrids As CurtainGridSet
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a Curtain FootPrintRoof, this property makes sense.

See Also

FootPrintRoof Class


DefinesSlope Property

[image]

Revit 2011 API
FootPrintRoof..::.DefinesSlope Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool DefinesSlope[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property DefinesSlope ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

See Also

FootPrintRoof Class


ExtendIntoWall Property

[image]

Revit 2011 API
FootPrintRoof..::.ExtendIntoWall Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExtendIntoWall[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class


Offset Property

[image]

Revit 2011 API
FootPrintRoof..::.Offset Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Offset[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

See Also

FootPrintRoof Class


Overhang Property

[image]

Revit 2011 API
FootPrintRoof..::.Overhang Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Overhang[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

Remarks

Only when the FootPrintRoof is created by pick walls, this property makes sense.

See Also

FootPrintRoof Class


Parameter Property

[image] [image]

Revit 2011 API
FootPrintRoof..::.Parameter Property
FootPrintRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FootPrintRoof Class
FootPrintRoof Members


SlopeAngle Property

[image]

Revit 2011 API
FootPrintRoof..::.SlopeAngle Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SlopeAngle[
    ModelCurve pCurve
] { get; set; }
Visual Basic (Declaration)
Public Property SlopeAngle ( _
    pCurve As ModelCurve _
) As Double
Visual C++
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::.ModelCurve

See Also

FootPrintRoof Class


Form Class

[image]

Revit 2011 API
Form Class
Members See Also Send Feedback
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Form : GenericForm
Visual Basic (Declaration)
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Form

See Also

Form Members


Form Members

[image] [image]

Revit 2011 API
Form Members
Form Class Methods Properties See Also Send Feedback

The Form type exposes the following members.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Rehost | Overloaded.
RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class


Form Methods

[image] [image]

Revit 2011 API
Form Methods
Form Class See Also Send Feedback

The Form type exposes the following members.

Methods

Name | Description
AddEdge | Overloaded.
AddProfile | Add a profile into the form, by a specified edge/param.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
DeleteProfile | Delete a profile of the form.
DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
IsBeginningFace | Given a face, tell if it is a beginning cap face.
IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
IsCurveReference | Tell if the pick is the reference to a curve of the form.
IsEdgeReference | Tell if the pick is the reference to an edge of the form.
IsEndFace | Given a face, tell if it is an end cap face.
IsFaceReference | Tell if the pick is the reference to a face of the form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsProfileEdge | Tell if an edge or curve is generated from a profile.
IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
IsSideFace | Given a face, tell if it is a side face.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsVertexReference | Tell if the pick is the reference to a vertex of the form.
MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Rehost | Overloaded.
RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Form Class


AddEdge Method

[image] [image]

Revit 2011 API
Form..::.AddEdge Method
Form Class See Also Send Feedback

Overload List

Name | Description
AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

See Also

Form Class
Form Members


AddEdge Method (Reference, Reference)

[image]

Revit 2011 API
Form..::.AddEdge Method (Reference, Reference)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddEdge(
    Reference startPointReference,
    Reference endPointReference
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    startPointReference As Reference, _
    endPointReference As Reference _
)
Visual C++
public:
void AddEdge(
    Reference^ startPointReference,
    Reference^ endPointReference
)

Parameters

startPointReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of start point
endPointReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of end point

See Also

Form Class
AddEdge Overload


AddEdge Method (Reference, XYZ)

[image]

Revit 2011 API
Form..::.AddEdge Method (Reference, XYZ)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    faceReference As Reference, _
    point As XYZ _
)
Visual C++
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face
point
Type: Autodesk.Revit.DB..::.XYZ
A point on the face, defining the position of edge to be created.

See Also

Form Class
AddEdge Overload


AddEdge Method (Reference, Double, Reference, Double)

[image]

Revit 2011 API
Form..::.AddEdge Method (Reference, Double, Reference, Double)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Visual Basic (Declaration)
Public Sub AddEdge ( _
    startEdgeReference As Reference, _
    startParam As Double, _
    endEdgeReference As Reference, _
    endParam As Double _
)
Visual C++
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)

Parameters

startEdgeReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of start edge
startParam
Type: System..::.Double
The param on start edge to specify the location.
endEdgeReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of end edge
endParam
Type: System..::.Double
The param on end edge to specify the location.

See Also

Form Class
AddEdge Overload


AddProfile Method

[image]

Revit 2011 API
Form..::.AddProfile Method
Form Class See Also Send Feedback
Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int AddProfile(
    Reference edgeReference,
    double param
)
Visual Basic (Declaration)
Public Function AddProfile ( _
    edgeReference As Reference, _
    param As Double _
) As Integer
Visual C++
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of edge.
param
Type: System..::.Double
The param on edge to specify the location.

Return Value

Index of newly created profile.

See Also

Form Class


CanManipulateProfile Method

[image]

Revit 2011 API
Form..::.CanManipulateProfile Method
Form Class See Also Send Feedback
Tell if a profile can be deleted/moved/rotated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanManipulateProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Function CanManipulateProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool CanManipulateProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.

See Also

Form Class


CanManipulateSubElement Method

[image]

Revit 2011 API
Form..::.CanManipulateSubElement Method
Form Class See Also Send Feedback
Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanManipulateSubElement(
    Reference subElementReference
)
Visual Basic (Declaration)
Public Function CanManipulateSubElement ( _
    subElementReference As Reference _
) As Boolean
Visual C++
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


ConstrainProfiles Method

[image]

Revit 2011 API
Form..::.ConstrainProfiles Method
Form Class See Also Send Feedback
Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ConstrainProfiles(
    int masterProfileIndex
)
Visual Basic (Declaration)
Public Sub ConstrainProfiles ( _
    masterProfileIndex As Integer _
)
Visual C++
public:
void ConstrainProfiles(
    int masterProfileIndex
)

Parameters

masterProfileIndex
Type: System..::.Int32
Index to specify the profile used as master profile.

See Also

Form Class


DeleteProfile Method

[image]

Revit 2011 API
Form..::.DeleteProfile Method
Form Class See Also Send Feedback
Delete a profile of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DeleteProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Sub DeleteProfile ( _
    profileIndex As Integer _
)
Visual C++
public:
void DeleteProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.

See Also

Form Class


DeleteSubElement Method

[image]

Revit 2011 API
Form..::.DeleteSubElement Method
Form Class See Also Send Feedback
Delete a face/edge/curve/vertex of the form, specified by a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DeleteSubElement(
    Reference subElementReference
)
Visual Basic (Declaration)
Public Sub DeleteSubElement ( _
    subElementReference As Reference _
)
Visual C++
public:
void DeleteSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


GetControlPoints Method

[image]

Revit 2011 API
Form..::.GetControlPoints Method
Form Class See Also Send Feedback
Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Visual Basic (Declaration)
Public Function GetControlPoints ( _
    curveOrEdgeOrFaceReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference
Type: Autodesk.Revit.DB..::.Reference
The reference of an edge or curve or face.

Return Value

Reference array containing all control points lying on it.

See Also

Form Class


GetCurvesAndEdgesReference Method

[image]

Revit 2011 API
Form..::.GetCurvesAndEdgesReference Method
Form Class See Also Send Feedback
Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Visual Basic (Declaration)
Public Function GetCurvesAndEdgesReference ( _
    pointReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)

Parameters

pointReference
Type: Autodesk.Revit.DB..::.Reference
The reference of a point.

Return Value

Reference array containing all edges and curves that the point is lying on.

See Also

Form Class


GetPathCurveIndexByCurveReference Method

[image]

Revit 2011 API
Form..::.GetPathCurveIndexByCurveReference Method
Form Class See Also Send Feedback
Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Visual Basic (Declaration)
Public Function GetPathCurveIndexByCurveReference ( _
    curveReference As Reference _
) As Integer
Visual C++
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::.Reference
Reference to the curve in path

See Also

Form Class


GetProfileAndCurveLoopIndexFromReference Method

[image]

Revit 2011 API
Form..::.GetProfileAndCurveLoopIndexFromReference Method
Form Class See Also Send Feedback
Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Visual Basic (Declaration)
Public Sub GetProfileAndCurveLoopIndexFromReference ( _
    curveOrEdgeReference As Reference, _
    ByRef profileIndex As Integer, _
    ByRef curveLoopIndex As Integer _
)
Visual C++
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::.Reference
Reference to a curve/edge that is part of one profile
profileIndex
Type: System..::.Int32 %
Profile index for output
curveLoopIndex
Type: System..::.Int32 %
Curve loop index for output

See Also

Form Class


IsAutoCreaseEdge Method

[image]

Revit 2011 API
Form..::.IsAutoCreaseEdge Method
Form Class See Also Send Feedback
Tell if an edge is an auto-crease on a top/bottom cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsAutoCreaseEdge(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsAutoCreaseEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsAutoCreaseEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the edge to be checked.

See Also

Form Class


IsBeginningFace Method

[image]

Revit 2011 API
Form..::.IsBeginningFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a beginning cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsBeginningFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsBeginningFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsBeginningFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the face to be checked.

See Also

Form Class


IsConnectingEdge Method

[image]

Revit 2011 API
Form..::.IsConnectingEdge Method
Form Class See Also Send Feedback
Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsConnectingEdge(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsConnectingEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsConnectingEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the edge to be checked.

See Also

Form Class


IsCurveReference Method

[image]

Revit 2011 API
Form..::.IsCurveReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a curve of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCurveReference(
    Reference curveReference
)
Visual Basic (Declaration)
Public Function IsCurveReference ( _
    curveReference As Reference _
) As Boolean
Visual C++
public:
bool IsCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::.Reference
Reference to be checked.

See Also

Form Class


IsEdgeReference Method

[image]

Revit 2011 API
Form..::.IsEdgeReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to an edge of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEdgeReference(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Function IsEdgeReference ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference
Reference to be checked.

See Also

Form Class


IsEndFace Method

[image]

Revit 2011 API
Form..::.IsEndFace Method
Form Class See Also Send Feedback
Given a face, tell if it is an end cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEndFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsEndFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsEndFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the face to be checked.

See Also

Form Class


IsFaceReference Method

[image]

Revit 2011 API
Form..::.IsFaceReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a face of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFaceReference(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsFaceReference ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsFaceReference(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
Reference to be checked.

See Also

Form Class


IsProfileEdge Method

[image]

Revit 2011 API
Form..::.IsProfileEdge Method
Form Class See Also Send Feedback
Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Visual Basic (Declaration)
Public Function IsProfileEdge ( _
    curveOrEdgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the edge or curve to be checked.

See Also

Form Class


IsReferenceOnlyProfile Method

[image]

Revit 2011 API
Form..::.IsReferenceOnlyProfile Method
Form Class See Also Send Feedback
Tell if the profile is made by referencing existing geometry in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReferenceOnlyProfile(
    int profileIndex
)
Visual Basic (Declaration)
Public Function IsReferenceOnlyProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool IsReferenceOnlyProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile to be checked.

See Also

Form Class


IsSideFace Method

[image]

Revit 2011 API
Form..::.IsSideFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSideFace(
    Reference faceReference
)
Visual Basic (Declaration)
Public Function IsSideFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsSideFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::.Reference
The reference of the face to be checked.

See Also

Form Class


IsVertexReference Method

[image]

Revit 2011 API
Form..::.IsVertexReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a vertex of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsVertexReference(
    Reference vertexReference
)
Visual Basic (Declaration)
Public Function IsVertexReference ( _
    vertexReference As Reference _
) As Boolean
Visual C++
public:
bool IsVertexReference(
    Reference^ vertexReference
)

Parameters

vertexReference
Type: Autodesk.Revit.DB..::.Reference
Reference to be checked.

See Also

Form Class


MoveProfile Method

[image]

Revit 2011 API
Form..::.MoveProfile Method
Form Class Example See Also Send Feedback
Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveProfile ( _
    profileIndex As Integer, _
    offset As XYZ _
)
Visual C++
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
offset
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Examples

CopyC#
public void MoveForm(Form form)
{
    int profileCount = form.ProfileCount;
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // modify the first form only
        if (form.CanManipulateProfile(profileIndex))
        {
            XYZ offset = new XYZ(-25, 0, 0);
            form.MoveProfile(profileIndex, offset);
        }
    }
}
CopyVB.NET
Public Sub MoveForm(ByVal form As Form)
    Dim profileCount As Integer = form.ProfileCount
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' modify the first form only
        If form.CanManipulateProfile(profileIndex) Then
            Dim offset As New Autodesk.Revit.DB.XYZ(-25, 0, 0)
            form.MoveProfile(profileIndex, offset)
        End If
    End If
End Sub

See Also

Form Class


MoveSubElement Method

[image]

Revit 2011 API
Form..::.MoveSubElement Method
Form Class Example See Also Send Feedback
Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MoveSubElement(
    Reference subElementReference,
    XYZ offset
)
Visual Basic (Declaration)
Public Sub MoveSubElement ( _
    subElementReference As Reference, _
    offset As XYZ _
)
Visual C++
public:
void MoveSubElement(
    Reference^ subElementReference,
    XYZ^ offset
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face/edge/curve/vertex
offset
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Examples

CopyC#
public void MoveSubElement(Form form)
{
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // get first profile
        ReferenceArray ra = form.get_CurveLoopReferencesOnProfile(profileIndex, 0);
        foreach (Reference r in ra)
        {
            ReferenceArray ra2 = form.GetControlPoints(r);
            foreach (Reference r2 in ra2)
            {
                Point vertex = r2.GeometryObject as Point;

                XYZ offset = new XYZ(0, 15, 0);
                form.MoveSubElement(r2, offset);
                break;  // just move the first point
            }
        }
    }
}
CopyVB.NET
Public Sub MoveSubElement(ByVal form As Form)
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' get first profile
        Dim ra As ReferenceArray = form.CurveLoopReferencesOnProfile(profileIndex, 0)
        For Each r As Reference In ra
            Dim ra2 As ReferenceArray = form.GetControlPoints(r)
            For Each r2 As Reference In ra2
                Dim vertex As Point = TryCast(r2.GeometryObject, Point)

                Dim offset As New Autodesk.Revit.DB.XYZ(0, 15, 0)
                form.MoveSubElement(r2, offset)
                ' just move the first point
                Exit For
            Next
        Next
    End If
End Sub

See Also

Form Class


Rehost Method

[image] [image]

Revit 2011 API
Form..::.Rehost Method
Form Class See Also Send Feedback

Overload List

Name | Description
Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane

See Also

Form Class
Form Members


Rehost Method (Reference, XYZ)

[image]

Revit 2011 API
Form..::.Rehost Method (Reference, XYZ)
Form Class See Also Send Feedback
Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Rehost(
    Reference hostRef,
    XYZ location
)
Visual Basic (Declaration)
Public Sub Rehost ( _
    hostRef As Reference, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    Reference^ hostRef,
    XYZ^ location
)

Parameters

hostRef
Type: Autodesk.Revit.DB..::.Reference
The geometry reference on which to rehost the form.
location
Type: Autodesk.Revit.DB..::.XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the hostRef or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


Rehost Method (SketchPlane, XYZ)

[image]

Revit 2011 API
Form..::.Rehost Method (SketchPlane, XYZ)
Form Class See Also Send Feedback
Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Rehost(
    SketchPlane sketchPlane,
    XYZ location
)
Visual Basic (Declaration)
Public Sub Rehost ( _
    sketchPlane As SketchPlane, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    SketchPlane^ sketchPlane,
    XYZ^ location
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::.SketchPlane
The sketch plane on which to rehost the form.
location
Type: Autodesk.Revit.DB..::.XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the sketchPlane or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


RotateProfile Method

[image]

Revit 2011 API
Form..::.RotateProfile Method
Form Class See Also Send Feedback
Rotate a profile of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.DB..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class


RotateSubElement Method

[image]

Revit 2011 API
Form..::.RotateSubElement Method
Form Class See Also Send Feedback
Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RotateSubElement(
    Reference subElementReference,
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Sub RotateSubElement ( _
    subElementReference As Reference, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateSubElement(
    Reference^ subElementReference,
    Line^ axis,
    double angle
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face/edge/curve/vertex
axis
Type: Autodesk.Revit.DB..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class


ScaleProfile Method

[image]

Revit 2011 API
Form..::.ScaleProfile Method
Form Class See Also Send Feedback
Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub ScaleProfile ( _
    profileIndex As Integer, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile.
factor
Type: System..::.Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin where scale happens.

See Also

Form Class


ScaleSubElement Method

[image]

Revit 2011 API
Form..::.ScaleSubElement Method
Form Class See Also Send Feedback
Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub ScaleSubElement ( _
    subElementReference As Reference, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::.Reference
The geometry reference of face/edge/curve/vertex
factor
Type: System..::.Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::.XYZ
The origin where scale happens.

See Also

Form Class


Form Properties

[image] [image]

Revit 2011 API
Form Properties
Form Class See Also Send Feedback

The Form type exposes the following members.

Properties

Name | Description
AreProfilesConstrained | Get/set if the form's profiles are constrained.
BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
HasOpenGeometry | Tell if the form has an open geometry.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInXRayMode | Get/set if the form is in X-Ray mode.
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathCurveCount | The number of curves in the form path.
PathCurveReference | The curve reference in the path, specified by curve index.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileCount | The number of profiles in the form.
ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Form Class


AreProfilesConstrained Property

[image]

Revit 2011 API
Form..::.AreProfilesConstrained Property
Form Class See Also Send Feedback
Get/set if the form's profiles are constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AreProfilesConstrained { get; set; }
Visual Basic (Declaration)
Public Property AreProfilesConstrained As Boolean
Visual C++
public:
property bool AreProfilesConstrained {
    bool get ();
    void set (bool value);
}

See Also

Form Class


BaseOffset Property

[image]

Revit 2011 API
Form..::.BaseOffset Property
Form Class See Also Send Feedback
Retrieve/set the base offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when it fail to get/set BaseOffset.

See Also

Form Class


CurveLoopReferencesOnProfile Property

[image]

Revit 2011 API
Form..::.CurveLoopReferencesOnProfile Property
Form Class See Also Send Feedback
The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray CurveLoopReferencesOnProfile[
    int profileIndex,
    int curveLoopIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoopReferencesOnProfile ( _
    profileIndex As Integer, _
    curveLoopIndex As Integer _
) As ReferenceArray
Visual C++
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}

Parameters

profileIndex
Type: System..::.Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex
Type: System..::.Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

See Also

Form Class


HasOneOrMoreReferenceProfiles Property

[image]

Revit 2011 API
Form..::.HasOneOrMoreReferenceProfiles Property
Form Class See Also Send Feedback
Tell if the form has any reference profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasOneOrMoreReferenceProfiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOneOrMoreReferenceProfiles As Boolean
Visual C++
public:
property bool HasOneOrMoreReferenceProfiles {
    bool get ();
}

See Also

Form Class


HasOpenGeometry Property

[image]

Revit 2011 API
Form..::.HasOpenGeometry Property
Form Class See Also Send Feedback
Tell if the form has an open geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasOpenGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOpenGeometry As Boolean
Visual C++
public:
property bool HasOpenGeometry {
    bool get ();
}

See Also

Form Class


IsInXRayMode Property

[image]

Revit 2011 API
Form..::.IsInXRayMode Property
Form Class See Also Send Feedback
Get/set if the form is in X-Ray mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInXRayMode { get; set; }
Visual Basic (Declaration)
Public Property IsInXRayMode As Boolean
Visual C++
public:
property bool IsInXRayMode {
    bool get ();
    void set (bool value);
}

See Also

Form Class


Parameter Property

[image] [image]

Revit 2011 API
Form..::.Parameter Property
Form Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Form Class
Form Members


PathCurveCount Property

[image]

Revit 2011 API
Form..::.PathCurveCount Property
Form Class See Also Send Feedback
The number of curves in the form path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int PathCurveCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathCurveCount As Integer
Visual C++
public:
property int PathCurveCount {
    int get ();
}

See Also

Form Class


PathCurveReference Property

[image]

Revit 2011 API
Form..::.PathCurveReference Property
Form Class See Also Send Feedback
The curve reference in the path, specified by curve index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PathCurveReference[
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathCurveReference ( _
    curveIndex As Integer _
) As Reference
Visual C++
public:
property Reference^ PathCurveReference[int curveIndex] {
    Reference^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::.Int32
Index to specify the curve in path

See Also

Form Class


ProfileCount Property

[image]

Revit 2011 API
Form..::.ProfileCount Property
Form Class See Also Send Feedback
The number of profiles in the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int ProfileCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileCount As Integer
Visual C++
public:
property int ProfileCount {
    int get ();
}

See Also

Form Class


ProfileCurveLoopCount Property

[image]

Revit 2011 API
Form..::.ProfileCurveLoopCount Property
Form Class See Also Send Feedback
The number of curve loops in certain profile, specified by profile index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int ProfileCurveLoopCount[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileCurveLoopCount ( _
    index As Integer _
) As Integer
Visual C++
public:
property int ProfileCurveLoopCount[int index] {
    int get (int index);
}

Parameters

index
Type: System..::.Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).

See Also

Form Class


TopOffset Property

[image]

Revit 2011 API
Form..::.TopOffset Property
Form Class See Also Send Feedback
Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::.ApplicationException | Thrown when it fail to get/set TopOffset.

See Also

Form Class


FormArray Class

[image]

Revit 2011 API
FormArray Class
Members See Also Send Feedback
An array that contains form objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FormArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class FormArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FormArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FormArray

See Also

FormArray Members


FormArray Members

[image] [image]

Revit 2011 API
FormArray Members
FormArray Class Constructors Methods Properties See Also Send Feedback

The FormArray type exposes the following members.

Constructors

Name | Description
FormArray | Initializes a new instance of the FormArray class

Methods

Name | Description
Append |
Clear | Removes every form from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a form at a specified index within the array.
Size | Returns the number of forms that are in the array.

See Also

FormArray Class


FormArray Constructor

[image]

Revit 2011 API
FormArray Constructor
FormArray Class See Also Send Feedback
Initializes a new instance of the FormArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FormArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormArray()

See Also

FormArray Class


FormArray Methods

[image] [image]

Revit 2011 API
FormArray Methods
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every form from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArray Class


Append Method

[image]

Revit 2011 API
FormArray..::.Append Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Form item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Form _
)
Visual C++
public:
virtual void Append(
    Form^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Form

See Also

FormArray Class


Clear Method

[image]

Revit 2011 API
FormArray..::.Clear Method
FormArray Class See Also Send Feedback
Removes every form from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FormArray Class


ForwardIterator Method

[image]

Revit 2011 API
FormArray..::.ForwardIterator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FormArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FormArray Class


GetEnumerator Method

[image]

Revit 2011 API
FormArray..::.GetEnumerator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FormArray Class


Insert Method

[image]

Revit 2011 API
FormArray..::.Insert Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Form item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Form, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Form^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Form
index
Type: System..::.Int32

See Also

FormArray Class


ReverseIterator Method

[image]

Revit 2011 API
FormArray..::.ReverseIterator Method
FormArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FormArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FormArray Class


FormArray Properties

[image] [image]

Revit 2011 API
FormArray Properties
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a form at a specified index within the array.
Size | Returns the number of forms that are in the array.

See Also

FormArray Class


IsEmpty Property

[image]

Revit 2011 API
FormArray..::.IsEmpty Property
FormArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FormArray Class


Item Property

[image]

Revit 2011 API
FormArray..::.Item Property
FormArray Class See Also Send Feedback
Gets or sets a form at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Form Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Form
Visual C++
public:
virtual property Form^ Item[int index] {
    Form^ get (int index);
    void set (int index, Form^ value);
}

Parameters

index
Type: System..::.Int32
The index of the form to be set or retrieved.

Return Value

Returns the form at the specified index.

See Also

FormArray Class


Size Property

[image]

Revit 2011 API
FormArray..::.Size Property
FormArray Class See Also Send Feedback
Returns the number of forms that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FormArray Class


FormArrayIterator Class

[image]

Revit 2011 API
FormArrayIterator Class
Members See Also Send Feedback
An iterator to a form array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FormArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FormArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FormArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FormArrayIterator

See Also

FormArrayIterator Members


FormArrayIterator Members

[image] [image]

Revit 2011 API
FormArrayIterator Members
FormArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FormArrayIterator type exposes the following members.

Constructors

Name | Description
FormArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class


FormArrayIterator Constructor

[image]

Revit 2011 API
FormArrayIterator Constructor
FormArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FormArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FormArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormArrayIterator Class


FormArrayIterator Methods

[image] [image]

Revit 2011 API
FormArrayIterator Methods
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
FormArrayIterator..::.MoveNext Method
FormArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FormArrayIterator Class


Reset Method

[image]

Revit 2011 API
FormArrayIterator..::.Reset Method
FormArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FormArrayIterator Class


FormArrayIterator Properties

[image] [image]

Revit 2011 API
FormArrayIterator Properties
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class


Current Property

[image]

Revit 2011 API
FormArrayIterator..::.Current Property
FormArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FormArrayIterator Class


FormatOptions Class

[image]

Revit 2011 API
FormatOptions Class
Members See Also Send Feedback
Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FormatOptions : APIObject
Visual Basic (Declaration)
Public Class FormatOptions _
    Inherits APIObject
Visual C++
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units propery.All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.FormatOptions

See Also

FormatOptions Members


FormatOptions Members

[image] [image]

Revit 2011 API
FormatOptions Members
FormatOptions Class Methods Properties See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Group | Retrieves the Group of Units Type that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieves the Name of Units Type that are currently selected.
Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Units | Retrieves the Units Type that are currently selected.
Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class


FormatOptions Methods

[image] [image]

Revit 2011 API
FormatOptions Methods
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatOptions Class


FormatOptions Properties

[image] [image]

Revit 2011 API
FormatOptions Properties
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Properties

Name | Description
Group | Retrieves the Group of Units Type that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieves the Name of Units Type that are currently selected.
Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Units | Retrieves the Units Type that are currently selected.
Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class


Group Property

[image]

Revit 2011 API
FormatOptions..::.Group Property
FormatOptions Class See Also Send Feedback
Retrieves the Group of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UnitGroup Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As UnitGroup
Visual C++
public:
property UnitGroup Group {
    UnitGroup get ();
}

Remarks

Common, Structural, etc.

See Also

FormatOptions Class


Name Property

[image]

Revit 2011 API
FormatOptions..::.Name Property
FormatOptions Class See Also Send Feedback
Retrieves the Name of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Get the Name of Units Type that are currently selected.

See Also

FormatOptions Class


Rounding Property

[image]

Revit 2011 API
FormatOptions..::.Rounding Property
FormatOptions Class See Also Send Feedback
Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI ComboBox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class


Units Property

[image]

Revit 2011 API
FormatOptions..::.Units Property
FormatOptions Class See Also Send Feedback
Retrieves the Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DisplayUnitType Units { get; set; }
Visual Basic (Declaration)
Public Property Units As DisplayUnitType
Visual C++
public:
property DisplayUnitType Units {
    DisplayUnitType get ();
    void set (DisplayUnitType value);
}

Remarks

The Units property returns the Units Type that were selected at the Format Options Dialog.

See Also

FormatOptions Class


Unitsymbol Property

[image]

Revit 2011 API
FormatOptions..::.Unitsymbol Property
FormatOptions Class See Also Send Feedback
Retrieves the Unit Symbol of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UnitSymbolType Unitsymbol { get; set; }
Visual Basic (Declaration)
Public Property Unitsymbol As UnitSymbolType
Visual C++
public:
property UnitSymbolType Unitsymbol {
    UnitSymbolType get ();
    void set (UnitSymbolType value);
}

Remarks

You can set or get Unit Symbol of Units Type that are currently selected. If current DisplayUnitType does NOT support Unit Symbol and you have inputted as well, it will throw an InvalidOperationException. If current DisplayUnitType support, and you set a unfit enum value, it will throw an ArgumentOutOfRangeException.

See Also

FormatOptions Class


FormUtils Class

[image]

Revit 2011 API
FormUtils Class
Members See Also Send Feedback
Define Form utility functions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FormUtils : IDisposable
Visual Basic (Declaration)
Public Class FormUtils _
    Implements IDisposable
Visual C++
public ref class FormUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FormUtils

See Also

FormUtils Members


FormUtils Members

[image] [image]

Revit 2011 API
FormUtils Members
FormUtils Class Methods See Also Send Feedback

The FormUtils type exposes the following members.

Methods

Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
Dispose |
DissolveForms | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormUtils Class


FormUtils Methods

[image] [image]

Revit 2011 API
FormUtils Methods
FormUtils Class See Also Send Feedback

The FormUtils type exposes the following members.

Methods

Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
Dispose |
DissolveForms | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormUtils Class


CanBeDissolved Method

[image]

Revit 2011 API
FormUtils..::.CanBeDissolved Method
FormUtils Class See Also Send Feedback
Validates that input contains one or more form elements or geom combinations containing form elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool CanBeDissolved(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic (Declaration)
Public Shared Function CanBeDissolved ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanBeDissolved(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document.
elements
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of elements.

Return Value

True if inputs contain one or more form elements. Non-form element inputs are ignored. False if none of the inputs are form elements or do not contain form elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class


Dispose Method

[image]

Revit 2011 API
FormUtils..::.Dispose Method
FormUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FormUtils Class


DissolveForms Method

[image] [image]

Revit 2011 API
FormUtils..::.DissolveForms Method
FormUtils Class See Also Send Feedback

Overload List

Name | Description
DissolveForms(Document, ICollection<(Of <(ElementId>)>)) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollection<(Of <(ElementId>)>), ICollection<(Of <(ElementId>)>)%) | Dissolves a collection of form elements into their defining elements.

See Also

FormUtils Class
FormUtils Members


DissolveForms Method (Document, ICollection(ElementId))

[image]

Revit 2011 API
FormUtils..::.DissolveForms Method (Document, ICollection<(Of <(ElementId>)>))
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic (Declaration)
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document
elements
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class
DissolveForms Overload


DissolveForms Method (Document, ICollection(ElementId), ICollection(ElementId))

[image]

Revit 2011 API
FormUtils..::.DissolveForms Method (Document, ICollection<(Of <(ElementId>)>), ICollection<(Of <(ElementId>)>)%)
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements,
    out ICollection<ElementId> BondingPointSet
)
Visual Basic (Declaration)
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId), _
    <OutAttribute> ByRef BondingPointSet As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements,
    [OutAttribute] ICollection<ElementId^>^% BondingPointSet
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document
elements
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
BondingPointSet
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>) %
A collection of the point element ids called "bonding points" (see below for description of "bonding points")

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Remarks

Bonding points define the workplane of form profiles and paths and their curves. The bonding point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Bonding points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class
DissolveForms Overload


GBXMLExportOptions Class

[image]

Revit 2011 API
GBXMLExportOptions Class
Members See Also Send Feedback
Green-Building XML Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GBXMLExportOptions
Visual Basic (Declaration)
Public Class GBXMLExportOptions
Visual C++
public ref class GBXMLExportOptions

Remarks

Not used currently. Reserved for future use

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GBXMLExportOptions

See Also

GBXMLExportOptions Members


GBXMLExportOptions Members

[image] [image]

Revit 2011 API
GBXMLExportOptions Members
GBXMLExportOptions Class Constructors Methods See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Constructors

Name | Description
GBXMLExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class


GBXMLExportOptions Constructor

[image]

Revit 2011 API
GBXMLExportOptions Constructor
GBXMLExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GBXMLExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GBXMLExportOptions()

See Also

GBXMLExportOptions Class


GBXMLExportOptions Methods

[image] [image]

Revit 2011 API
GBXMLExportOptions Methods
GBXMLExportOptions Class See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class


GBXMLImportOptions Class

[image]

Revit 2011 API
GBXMLImportOptions Class
Members See Also Send Feedback
Import options for Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GBXMLImportOptions
Visual Basic (Declaration)
Public Class GBXMLImportOptions
Visual C++
public ref class GBXMLImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GBXMLImportOptions

See Also

GBXMLImportOptions Members


GBXMLImportOptions Members

[image] [image]

Revit 2011 API
GBXMLImportOptions Members
GBXMLImportOptions Class Constructors Methods See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Constructors

Name | Description
GBXMLImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GBXMLImportOptions Constructor

[image]

Revit 2011 API
GBXMLImportOptions Constructor
GBXMLImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GBXMLImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GBXMLImportOptions()

See Also

GBXMLImportOptions Class


GBXMLImportOptions Methods

[image] [image]

Revit 2011 API
GBXMLImportOptions Methods
GBXMLImportOptions Class See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GenericForm Class

[image]

Revit 2011 API
GenericForm Class
Members See Also Send Feedback
Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GenericForm : CombinableElement
Visual Basic (Declaration)
Public Class GenericForm _
    Inherits CombinableElement
Visual C++
public ref class GenericForm : public CombinableElement

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing.it is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Blend
Autodesk.Revit.DB..::.Extrusion
Autodesk.Revit.DB..::.Form
Autodesk.Revit.DB..::.Revolution
Autodesk.Revit.DB..::.Sweep
Autodesk.Revit.DB..::.SweptBlend

See Also

GenericForm Members


GenericForm Members

[image] [image]

Revit 2011 API
GenericForm Members
GenericForm Class Methods Properties See Also Send Feedback

The GenericForm type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm.

See Also

GenericForm Class


GenericForm Methods

[image] [image]

Revit 2011 API
GenericForm Methods
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericForm Class


GetVisibility Method

[image]

Revit 2011 API
GenericForm..::.GetVisibility Method
GenericForm Class See Also Send Feedback
Gets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the generic form.

See Also

GenericForm Class


SetVisibility Method

[image]

Revit 2011 API
GenericForm..::.SetVisibility Method
GenericForm Class See Also Send Feedback
Sets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the generic form geometry can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

GenericForm Class


GenericForm Properties

[image] [image]

Revit 2011 API
GenericForm Properties
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm.

See Also

GenericForm Class


IsSolid Property

[image]

Revit 2011 API
GenericForm..::.IsSolid Property
GenericForm Class See Also Send Feedback
Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSolid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSolid As Boolean
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class


Name Property

[image]

Revit 2011 API
GenericForm..::.Name Property
GenericForm Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class


Parameter Property

[image] [image]

Revit 2011 API
GenericForm..::.Parameter Property
GenericForm Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GenericForm Class
GenericForm Members


Subcategory Property

[image]

Revit 2011 API
GenericForm..::.Subcategory Property
GenericForm Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As Category
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

GenericForm Class


Visible Property

[image]

Revit 2011 API
GenericForm..::.Visible Property
GenericForm Class See Also Send Feedback
The visibility of the GenericForm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
}

Field Value

True if the form is visible, false if it is hidden.

See Also

GenericForm Class


GenericFormSet Class

[image]

Revit 2011 API
GenericFormSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GenericFormSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GenericFormSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GenericFormSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GenericFormSet

See Also

GenericFormSet Members


GenericFormSet Members

[image] [image]

Revit 2011 API
GenericFormSet Members
GenericFormSet Class Constructors Methods Properties See Also Send Feedback

The GenericFormSet type exposes the following members.

Constructors

Name | Description
GenericFormSet | Initializes a new instance of the GenericFormSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class


GenericFormSet Constructor

[image]

Revit 2011 API
GenericFormSet Constructor
GenericFormSet Class See Also Send Feedback
Initializes a new instance of the GenericFormSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GenericFormSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSet()

See Also

GenericFormSet Class


GenericFormSet Methods

[image] [image]

Revit 2011 API
GenericFormSet Methods
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSet Class


Clear Method

[image]

Revit 2011 API
GenericFormSet..::.Clear Method
GenericFormSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GenericFormSet Class


Contains Method

[image]

Revit 2011 API
GenericFormSet..::.Contains Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GenericForm

See Also

GenericFormSet Class


Erase Method

[image]

Revit 2011 API
GenericFormSet..::.Erase Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GenericForm _
) As Integer
Visual C++
public:
virtual int Erase(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GenericForm

See Also

GenericFormSet Class


ForwardIterator Method

[image]

Revit 2011 API
GenericFormSet..::.ForwardIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GenericFormSet Class


GetEnumerator Method

[image]

Revit 2011 API
GenericFormSet..::.GetEnumerator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GenericFormSet Class


Insert Method

[image]

Revit 2011 API
GenericFormSet..::.Insert Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    GenericForm item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GenericForm

See Also

GenericFormSet Class


ReverseIterator Method

[image]

Revit 2011 API
GenericFormSet..::.ReverseIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GenericFormSet Class


GenericFormSet Properties

[image] [image]

Revit 2011 API
GenericFormSet Properties
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class


IsEmpty Property

[image]

Revit 2011 API
GenericFormSet..::.IsEmpty Property
GenericFormSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GenericFormSet Class


Size Property

[image]

Revit 2011 API
GenericFormSet..::.Size Property
GenericFormSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GenericFormSet Class


GenericFormSetIterator Class

[image]

Revit 2011 API
GenericFormSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GenericFormSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GenericFormSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GenericFormSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GenericFormSetIterator

See Also

GenericFormSetIterator Members


GenericFormSetIterator Members

[image] [image]

Revit 2011 API
GenericFormSetIterator Members
GenericFormSetIterator Class Constructors Methods Properties See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Constructors

Name | Description
GenericFormSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class


GenericFormSetIterator Constructor

[image]

Revit 2011 API
GenericFormSetIterator Constructor
GenericFormSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GenericFormSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericFormSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericFormSetIterator Class


GenericFormSetIterator Methods

[image] [image]

Revit 2011 API
GenericFormSetIterator Methods
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSetIterator Class


MoveNext Method

[image]

Revit 2011 API
GenericFormSetIterator..::.MoveNext Method
GenericFormSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class


Reset Method

[image]

Revit 2011 API
GenericFormSetIterator..::.Reset Method
GenericFormSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GenericFormSetIterator Class


GenericFormSetIterator Properties

[image] [image]

Revit 2011 API
GenericFormSetIterator Properties
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class


Current Property

[image]

Revit 2011 API
GenericFormSetIterator..::.Current Property
GenericFormSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class


GenericImportOptions Class

[image]

Revit 2011 API
GenericImportOptions Class
Members See Also Send Feedback
Generic Import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GenericImportOptions
Visual Basic (Declaration)
Public MustInherit Class GenericImportOptions
Visual C++
public ref class GenericImportOptions abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GenericImportOptions
Autodesk.Revit.DB..::.CADImportOptions
Autodesk.Revit.DB..::.ImageImportOptions

See Also

GenericImportOptions Members


GenericImportOptions Members

[image] [image]

Revit 2011 API
GenericImportOptions Members
GenericImportOptions Class Methods Properties See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RefPoint | Reference point (in Revit) to which the image is going to be inserted.
View | A view into which the image is going to be imported.

See Also

GenericImportOptions Class


GenericImportOptions Methods

[image] [image]

Revit 2011 API
GenericImportOptions Methods
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericImportOptions Class


GenericImportOptions Properties

[image] [image]

Revit 2011 API
GenericImportOptions Properties
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Properties

Name | Description
RefPoint | Reference point (in Revit) to which the image is going to be inserted.
View | A view into which the image is going to be imported.

See Also

GenericImportOptions Class


RefPoint Property

[image]

Revit 2011 API
GenericImportOptions..::.RefPoint Property
GenericImportOptions Class See Also Send Feedback
Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ RefPoint { get; set; }
Visual Basic (Declaration)
Public Property RefPoint As XYZ
Visual C++
public:
property XYZ^ RefPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the image will be inserted to the Revit's origin.

See Also

GenericImportOptions Class


View Property

[image]

Revit 2011 API
GenericImportOptions..::.View Property
GenericImportOptions Class See Also Send Feedback
A view into which the image is going to be imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the document's active view will be used.

See Also

GenericImportOptions Class


GeomCombination Class

[image]

Revit 2011 API
GeomCombination Class
Members See Also Send Feedback
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeomCombination : CombinableElement
Visual Basic (Declaration)
Public Class GeomCombination _
    Inherits CombinableElement
Visual C++
public ref class GeomCombination : public CombinableElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GeomCombination

See Also

GeomCombination Members


GeomCombination Members

[image] [image]

Revit 2011 API
GeomCombination Members
GeomCombination Class Methods Properties See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllMembers | All elements that are joined in this geometry combination.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GeomCombination Class


GeomCombination Methods

[image] [image]

Revit 2011 API
GeomCombination Methods
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombination Class


GeomCombination Properties

[image] [image]

Revit 2011 API
GeomCombination Properties
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Properties

Name | Description
AllMembers | All elements that are joined in this geometry combination.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GeomCombination Class


AllMembers Property

[image]

Revit 2011 API
GeomCombination..::.AllMembers Property
GeomCombination Class See Also Send Feedback
All elements that are joined in this geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CombinableElementArray AllMembers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllMembers As CombinableElementArray
Visual C++
public:
property CombinableElementArray^ AllMembers {
    CombinableElementArray^ get ();
}

Remarks

All members are generic forms, for more information, refer toGenericForm.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this geometry combination has already been deleted.

See Also

GeomCombination Class


Parameter Property

[image] [image]

Revit 2011 API
GeomCombination..::.Parameter Property
GeomCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GeomCombination Class
GeomCombination Members


GeomCombinationSet Class

[image]

Revit 2011 API
GeomCombinationSet Class
Members See Also Send Feedback
A set that contains GeomCombination objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeomCombinationSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GeomCombinationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeomCombinationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeomCombinationSet

See Also

GeomCombinationSet Members


GeomCombinationSet Members

[image] [image]

Revit 2011 API
GeomCombinationSet Members
GeomCombinationSet Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Constructors

Name | Description
GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class

Methods

Name | Description
Clear | Removes every item GeomCombination the set, rendering it empty.
Contains | Tests for the existence of an GeomCombination within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GeomCombination from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Constructor

[image]

Revit 2011 API
GeomCombinationSet Constructor
GeomCombinationSet Class See Also Send Feedback
Initializes a new instance of the GeomCombinationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeomCombinationSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeomCombinationSet()

See Also

GeomCombinationSet Class


GeomCombinationSet Methods

[image] [image]

Revit 2011 API
GeomCombinationSet Methods
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item GeomCombination the set, rendering it empty.
Contains | Tests for the existence of an GeomCombination within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GeomCombination from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSet Class


Clear Method

[image]

Revit 2011 API
GeomCombinationSet..::.Clear Method
GeomCombinationSet Class See Also Send Feedback
Removes every item GeomCombination the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeomCombinationSet Class


Contains Method

[image]

Revit 2011 API
GeomCombinationSet..::.Contains Method
GeomCombinationSet Class See Also Send Feedback
Tests for the existence of an GeomCombination within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeomCombination
The element to be searched for.

Return Value

The Contains method returns True if the GeomCombination is within the set, otherwise False.

See Also

GeomCombinationSet Class


Erase Method

[image]

Revit 2011 API
GeomCombinationSet..::.Erase Method
GeomCombinationSet Class See Also Send Feedback
Removes a specified GeomCombination from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GeomCombination _
) As Integer
Visual C++
public:
virtual int Erase(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeomCombination
The GeomCombination to be erased.

Return Value

The number of GeomCombinations that were erased from the set.

See Also

GeomCombinationSet Class


ForwardIterator Method

[image]

Revit 2011 API
GeomCombinationSet..::.ForwardIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GeomCombinationSet Class


GetEnumerator Method

[image]

Revit 2011 API
GeomCombinationSet..::.GetEnumerator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GeomCombinationSet Class


Insert Method

[image]

Revit 2011 API
GeomCombinationSet..::.Insert Method
GeomCombinationSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    GeomCombination item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeomCombination
The GeomCombination to be inserted into the set.

Return Value

Returns whether the GeomCombination was inserted into the set.

See Also

GeomCombinationSet Class


ReverseIterator Method

[image]

Revit 2011 API
GeomCombinationSet..::.ReverseIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Properties

[image] [image]

Revit 2011 API
GeomCombinationSet Properties
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


IsEmpty Property

[image]

Revit 2011 API
GeomCombinationSet..::.IsEmpty Property
GeomCombinationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GeomCombinationSet Class


Size Property

[image]

Revit 2011 API
GeomCombinationSet..::.Size Property
GeomCombinationSet Class See Also Send Feedback
Returns the number of GeomCombinations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeomCombinationSet Class


GeomCombinationSetIterator Class

[image]

Revit 2011 API
GeomCombinationSetIterator Class
Members See Also Send Feedback
An iterator to a GeomCombination set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GeomCombinationSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GeomCombinationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeomCombinationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeomCombinationSetIterator

See Also

GeomCombinationSetIterator Members


GeomCombinationSetIterator Members

[image] [image]

Revit 2011 API
GeomCombinationSetIterator Members
GeomCombinationSetIterator Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Constructors

Name | Description
GeomCombinationSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Constructor

[image]

Revit 2011 API
GeomCombinationSetIterator Constructor
GeomCombinationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeomCombinationSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeomCombinationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Methods

[image] [image]

Revit 2011 API
GeomCombinationSetIterator Methods
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSetIterator Class


MoveNext Method

[image]

Revit 2011 API
GeomCombinationSetIterator..::.MoveNext Method
GeomCombinationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


Reset Method

[image]

Revit 2011 API
GeomCombinationSetIterator..::.Reset Method
GeomCombinationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Properties

[image] [image]

Revit 2011 API
GeomCombinationSetIterator Properties
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


Current Property

[image]

Revit 2011 API
GeomCombinationSetIterator..::.Current Property
GeomCombinationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


GeometryElement Class

[image]

Revit 2011 API
GeometryElement Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryElement : GeometryObject
Visual Basic (Declaration)
Public Class GeometryElement _
    Inherits GeometryObject
Visual C++
public ref class GeometryElement : public GeometryObject

Remarks

This class contains geometric primitives that are generated from the parametric description of the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.GeometryElement

See Also

GeometryElement Members


GeometryElement Members

[image] [image]

Revit 2011 API
GeometryElement Members
GeometryElement Class Methods Properties See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialElement | Element describing the material from which this element is composed.
Objects | All geometric primitives contained in the element.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


GeometryElement Methods

[image] [image]

Revit 2011 API
GeometryElement Methods
GeometryElement Class See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryElement Class


GeometryElement Properties

[image] [image]

Revit 2011 API
GeometryElement Properties
GeometryElement Class See Also Send Feedback

The GeometryElement type exposes the following members.

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialElement | Element describing the material from which this element is composed.
Objects | All geometric primitives contained in the element.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


MaterialElement Property

[image]

Revit 2011 API
GeometryElement..::.MaterialElement Property
GeometryElement Class See Also Send Feedback
Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material MaterialElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialElement As Material
Visual C++
public:
property Material^ MaterialElement {
    Material^ get ();
}

See Also

GeometryElement Class


Objects Property

[image]

Revit 2011 API
GeometryElement..::.Objects Property
GeometryElement Class See Also Send Feedback
All geometric primitives contained in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryObjectArray Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As GeometryObjectArray
Visual C++
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

GeometryElement Class


GeometryInstance Class

[image]

Revit 2011 API
GeometryInstance Class
Members See Also Send Feedback
An instance of another element (symbol), specially positioned by this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryInstance : GeometryObject
Visual Basic (Declaration)
Public Class GeometryInstance _
    Inherits GeometryObject
Visual C++
public ref class GeometryInstance : public GeometryObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.GeometryInstance

See Also

GeometryInstance Members


GeometryInstance Members

[image] [image]

Revit 2011 API
GeometryInstance Members
GeometryInstance Class Methods Properties See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


GeometryInstance Methods

[image] [image]

Revit 2011 API
GeometryInstance Methods
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstanceGeometry | Overloaded.
GetSymbolGeometry | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryInstance Class


GetInstanceGeometry Method

[image] [image]

Revit 2011 API
GeometryInstance..::.GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

Name | Description
GetInstanceGeometry()()() | Computes the geometric representation of the instance.
GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetInstanceGeometry Method

[image]

Revit 2011 API
GeometryInstance..::.GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetInstanceGeometry()
Visual Basic (Declaration)
Public Function GetInstanceGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry()

Return Value

An element which contains the computed geometry for the instance.

Remarks

The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

GeometryInstance Class
GetInstanceGeometry Overload


GetInstanceGeometry Method (Transform)

[image]

Revit 2011 API
GeometryInstance..::.GetInstanceGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetInstanceGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetInstanceGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed instance.

Remarks

The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

GeometryInstance Class
GetInstanceGeometry Overload


GetSymbolGeometry Method

[image] [image]

Revit 2011 API
GeometryInstance..::.GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

Name | Description
GetSymbolGeometry()()() | Computes the geometric representation of the symbol which generates this instance.
GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetSymbolGeometry Method

[image]

Revit 2011 API
GeometryInstance..::.GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetSymbolGeometry()
Visual Basic (Declaration)
Public Function GetSymbolGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical.

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GetSymbolGeometry Method (Transform)

[image]

Revit 2011 API
GeometryInstance..::.GetSymbolGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement GetSymbolGeometry(
    Transform transform
)
Visual Basic (Declaration)
Public Function GetSymbolGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed symbol.

Remarks

The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved.

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GeometryInstance Properties

[image] [image]

Revit 2011 API
GeometryInstance Properties
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Symbol | The symbol element that this object is referring to.
SymbolGeometry | The geometric representation of the symbol which generates this instance.
Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


Symbol Property

[image]

Revit 2011 API
GeometryInstance..::.Symbol Property
GeometryInstance Class See Also Send Feedback
The symbol element that this object is referring to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Symbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbol As Element
Visual C++
public:
property Element^ Symbol {
    Element^ get ();
}

See Also

GeometryInstance Class


SymbolGeometry Property

[image]

Revit 2011 API
GeometryInstance..::.SymbolGeometry Property
GeometryInstance Class See Also Send Feedback
The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement SymbolGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property SymbolGeometry As GeometryElement
Visual C++
public:
property GeometryElement^ SymbolGeometry {
    GeometryElement^ get ();
}

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.

See Also

GeometryInstance Class


Transform Property

[image]

Revit 2011 API
GeometryInstance..::.Transform Property
GeometryInstance Class See Also Send Feedback
The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

See Also

GeometryInstance Class


GeometryObject Class

[image]

Revit 2011 API
GeometryObject Class
Members See Also Send Feedback
The common base class for all geometric primitives.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryObject : APIObject
Visual Basic (Declaration)
Public Class GeometryObject _
    Inherits APIObject
Visual C++
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Edge
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.GeometryElement
Autodesk.Revit.DB..::.GeometryInstance
Autodesk.Revit.DB..::.Mesh
Autodesk.Revit.DB..::.Point
Autodesk.Revit.DB..::.Profile
Autodesk.Revit.DB..::.Solid

See Also

GeometryObject Members


GeometryObject Members

[image] [image]

Revit 2011 API
GeometryObject Members
GeometryObject Class Methods Properties See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Visibility | The visibility.

See Also

GeometryObject Class


GeometryObject Methods

[image] [image]

Revit 2011 API
GeometryObject Methods
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObject Class


GeometryObject Properties

[image] [image]

Revit 2011 API
GeometryObject Properties
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Visibility | The visibility.

See Also

GeometryObject Class


GraphicsStyleId Property

[image]

Revit 2011 API
GeometryObject..::.GraphicsStyleId Property
GeometryObject Class Example See Also Send Feedback
The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId GraphicsStyleId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicsStyleId As ElementId
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
}

Remarks

This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.

Examples

CopyC#
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
        Options options = app.Create.NewGeometryOptions();
        GeometryElement geomElem = element.get_Geometry(options);
        foreach (GeometryObject geomObj in geomElem.Objects)
        {
            GeometryInstance geomInst = geomObj as GeometryInstance;
            if (geomInst != null)
            {
                foreach (Object obj in geomInst.SymbolGeometry.Objects)
                {
                    GeometryObject geomObject = obj as GeometryObject;
                    GraphicsStyle gStyle = doc.get_Element(geomObject.GraphicsStyleId) as GraphicsStyle;
                    if (gStyle != null)
                    {
                        string gstyleName = gStyle.GraphicsStyleCategory.Name;
                    }
                }
            }
        }

See Also

GeometryObject Class


Visibility Property

[image]

Revit 2011 API
GeometryObject..::.Visibility Property
GeometryObject Class See Also Send Feedback
The visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Visibility Visibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visibility As Visibility
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
}

Remarks

The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.

See Also

GeometryObject Class


GeometryObjectArray Class

[image]

Revit 2011 API
GeometryObjectArray Class
Members See Also Send Feedback
An array that contains geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GeometryObjectArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GeometryObjectArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeometryObjectArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObjectArray

See Also

GeometryObjectArray Members


GeometryObjectArray Members

[image] [image]

Revit 2011 API
GeometryObjectArray Members
GeometryObjectArray Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Constructors

Name | Description
GeometryObjectArray | Initializes a new instance of the GeometryObjectArray class

Methods

Name | Description
Append | Add the geometry object to the end of the array.
Clear | Removes every geometry object from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified geometry object into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a geometry object at a specified index within the array.
Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class


GeometryObjectArray Constructor

[image]

Revit 2011 API
GeometryObjectArray Constructor
GeometryObjectArray Class See Also Send Feedback
Initializes a new instance of the GeometryObjectArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryObjectArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArray()

See Also

GeometryObjectArray Class


GeometryObjectArray Methods

[image] [image]

Revit 2011 API
GeometryObjectArray Methods
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Methods

Name | Description
Append | Add the geometry object to the end of the array.
Clear | Removes every geometry object from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified geometry object into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArray Class


Append Method

[image]

Revit 2011 API
GeometryObjectArray..::.Append Method
GeometryObjectArray Class See Also Send Feedback
Add the geometry object to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    GeometryObject item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As GeometryObject _
)
Visual C++
public:
virtual void Append(
    GeometryObject^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeometryObject
The geometry object to be added.

See Also

GeometryObjectArray Class


Clear Method

[image]

Revit 2011 API
GeometryObjectArray..::.Clear Method
GeometryObjectArray Class See Also Send Feedback
Removes every geometry object from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeometryObjectArray Class


ForwardIterator Method

[image]

Revit 2011 API
GeometryObjectArray..::.ForwardIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

GeometryObjectArray Class


GetEnumerator Method

[image]

Revit 2011 API
GeometryObjectArray..::.GetEnumerator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GeometryObjectArray Class


Insert Method

[image]

Revit 2011 API
GeometryObjectArray..::.Insert Method
GeometryObjectArray Class See Also Send Feedback
Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryObject^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeometryObject
The geometry object to be inserted into the array.
index
Type: System..::.Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class


ReverseIterator Method

[image]

Revit 2011 API
GeometryObjectArray..::.ReverseIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

GeometryObjectArray Class


GeometryObjectArray Properties

[image] [image]

Revit 2011 API
GeometryObjectArray Properties
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a geometry object at a specified index within the array.
Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class


IsEmpty Property

[image]

Revit 2011 API
GeometryObjectArray..::.IsEmpty Property
GeometryObjectArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

GeometryObjectArray Class


Item Property

[image]

Revit 2011 API
GeometryObjectArray..::.Item Property
GeometryObjectArray Class See Also Send Feedback
Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeometryObject Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Type: System..::.Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class


Size Property

[image]

Revit 2011 API
GeometryObjectArray..::.Size Property
GeometryObjectArray Class See Also Send Feedback
Returns the number of geometry objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeometryObjectArray Class


GeometryObjectArrayIterator Class

[image]

Revit 2011 API
GeometryObjectArrayIterator Class
Members See Also Send Feedback
An iterator to a geometry object array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GeometryObjectArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GeometryObjectArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeometryObjectArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObjectArrayIterator

See Also

GeometryObjectArrayIterator Members


GeometryObjectArrayIterator Members

[image] [image]

Revit 2011 API
GeometryObjectArrayIterator Members
GeometryObjectArrayIterator Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Constructors

Name | Description
GeometryObjectArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Constructor

[image]

Revit 2011 API
GeometryObjectArrayIterator Constructor
GeometryObjectArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryObjectArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeometryObjectArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Methods

[image] [image]

Revit 2011 API
GeometryObjectArrayIterator Methods
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
GeometryObjectArrayIterator..::.MoveNext Method
GeometryObjectArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class


Reset Method

[image]

Revit 2011 API
GeometryObjectArrayIterator..::.Reset Method
GeometryObjectArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Properties

[image] [image]

Revit 2011 API
GeometryObjectArrayIterator Properties
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class


Current Property

[image]

Revit 2011 API
GeometryObjectArrayIterator..::.Current Property
GeometryObjectArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class


GraphicsStyle Class

[image]

Revit 2011 API
GraphicsStyle Class
Members See Also Send Feedback
The graphics style instance in Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GraphicsStyle : Element
Visual Basic (Declaration)
Public Class GraphicsStyle _
    Inherits Element
Visual C++
public ref class GraphicsStyle : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.GraphicsStyle

See Also

GraphicsStyle Members


GraphicsStyle Members

[image] [image]

Revit 2011 API
GraphicsStyle Members
GraphicsStyle Class Methods Properties See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GraphicsStyleCategory | The graphics style category.
GraphicsStyleType | The graphics style type.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyle Methods

[image] [image]

Revit 2011 API
GraphicsStyle Methods
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsStyle Class


GraphicsStyle Properties

[image] [image]

Revit 2011 API
GraphicsStyle Properties
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GraphicsStyleCategory | The graphics style category.
GraphicsStyleType | The graphics style type.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyleCategory Property

[image]

Revit 2011 API
GraphicsStyle..::.GraphicsStyleCategory Property
GraphicsStyle Class See Also Send Feedback
The graphics style category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category GraphicsStyleCategory { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicsStyleCategory As Category
Visual C++
public:
property Category^ GraphicsStyleCategory {
    Category^ get ();
}

See Also

GraphicsStyle Class


GraphicsStyleType Property

[image]

Revit 2011 API
GraphicsStyle..::.GraphicsStyleType Property
GraphicsStyle Class See Also Send Feedback
The graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyleType GraphicsStyleType { get; }
Visual Basic (Declaration)
Public ReadOnly Property GraphicsStyleType As GraphicsStyleType
Visual C++
public:
property GraphicsStyleType GraphicsStyleType {
    GraphicsStyleType get ();
}

See Also

GraphicsStyle Class


Parameter Property

[image] [image]

Revit 2011 API
GraphicsStyle..::.Parameter Property
GraphicsStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GraphicsStyle Class
GraphicsStyle Members


GraphicsStyleType Enumeration

[image]

Revit 2011 API
GraphicsStyleType Enumeration
See Also Send Feedback
Describes the type of graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum GraphicsStyleType
Visual Basic (Declaration)
Public Enumeration GraphicsStyleType
Visual C++
public enum class GraphicsStyleType

Members

Member name | Description
Projection | Projection.
Cut | Cut.

See Also


Grid Class

[image]

Revit 2011 API
Grid Class
Members Example See Also Send Feedback
Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Grid : Element
Visual Basic (Declaration)
Public Class Grid _
    Inherits Element
Visual C++
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Name property can be used to retrieve the contents of the grid line's bubble.

Examples

CopyC#
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.DB.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.DB.Arc arc = curve as Autodesk.Revit.DB.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.DB.Line line = curve as Autodesk.Revit.DB.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.get_EndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.get_EndPoint(0));

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub GetInfo_Grid(ByVal grid As Autodesk.Revit.DB.Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " + grid.IsCurved

    ' Show Curve information
    Dim curve As Autodesk.Revit.DB.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.DB.Arc = TryCast(curve, Autodesk.Revit.DB.Arc)
        message += vbLf & "Arc's radius: " + arc.Radius
        message += vbLf & "Arc's center:  (" + XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.DB.Line = TryCast(curve, Autodesk.Revit.DB.Line)
        message += vbLf & "Line's Length: " + line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " + XYZToString(curve.EndPoint(0))
    ' Get curve end point
    message += "; End point: " + XYZToString(curve.EndPoint(0))

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Grid

See Also

Grid Members


Grid Members

[image] [image]

Revit 2011 API
Grid Members
Grid Class Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtendToAllLevels | Adjust the grid to cut all levels.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Retrieves an object that represents the geometry of the grid line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GridType | Get and Set the type of the grid object.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsCurved | Test to see if the grid line is curved or straight.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Grid Class


Grid Methods

[image] [image]

Revit 2011 API
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtendToAllLevels | Adjust the grid to cut all levels.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Grid Class


ExtendToAllLevels Method

[image]

Revit 2011 API
Grid..::.ExtendToAllLevels Method
Grid Class See Also Send Feedback
Adjust the grid to cut all levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ExtendToAllLevels()
Visual Basic (Declaration)
Public Sub ExtendToAllLevels
Visual C++
public:
void ExtendToAllLevels()

Remarks

Requires that at least one plan view exists in the document. If not, this will throw a Autodesk::Revit::Exceptions::InvalidOperationException.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | There is no plan view in the document.

See Also

Grid Class


Grid Properties

[image] [image]

Revit 2011 API
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Retrieves an object that represents the geometry of the grid line.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GridType | Get and Set the type of the grid object.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsCurved | Test to see if the grid line is curved or straight.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Grid Class


Curve Property

[image]

Revit 2011 API
Grid..::.Curve Property
Grid Class See Also Send Feedback
Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Remarks

The geometry can either be an arc of a curve. The IsCurved property can be used to test which.

See Also

Grid Class


GridType Property

[image]

Revit 2011 API
Grid..::.GridType Property
Grid Class See Also Send Feedback
Get and Set the type of the grid object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridType GridType { get; set; }
Visual Basic (Declaration)
Public Property GridType As GridType
Visual C++
public:
property GridType^ GridType {
    GridType^ get ();
    void set (GridType^ value);
}

Remarks

When nullNothingnullptra null reference (Nothing in Visual Basic) is input for the method set, ArgumentNullException will be thrown.

See Also

Grid Class


IsCurved Property

[image]

Revit 2011 API
Grid..::.IsCurved Property
Grid Class See Also Send Feedback
Test to see if the grid line is curved or straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCurved { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurved As Boolean
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class


Parameter Property

[image] [image]

Revit 2011 API
Grid..::.Parameter Property
Grid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Grid Class
Grid Members


GridNode Structure

[image]

Revit 2011 API
GridNode Structure
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public struct GridNode
Visual Basic (Declaration)
Public Structure GridNode
Visual C++
public value class GridNode

See Also

GridNode Members


GridNode Members

[image] [image]

Revit 2011 API
GridNode Members
GridNode Structure Constructors Methods Properties See Also Send Feedback

The GridNode type exposes the following members.

Constructors

Name | Description
GridNode | Initializes a new instance of the GridNode class

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
UIndex | The node's index along the U axis.
VIndex | The node's index along the V axis.

See Also

GridNode Structure


GridNode Constructor

[image]

Revit 2011 API
GridNode Constructor
GridNode Structure See Also Send Feedback
Initializes a new instance of the GridNode class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridNode(
    int uIndex,
    int vIndex
)
Visual Basic (Declaration)
Public Sub New ( _
    uIndex As Integer, _
    vIndex As Integer _
)
Visual C++
public:
GridNode(
    int uIndex,
    int vIndex
)

Parameters

uIndex
Type: System..::.Int32
vIndex
Type: System..::.Int32

See Also

GridNode Structure


GridNode Methods

[image] [image]

Revit 2011 API
GridNode Methods
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

GridNode Structure


GridNode Properties

[image] [image]

Revit 2011 API
GridNode Properties
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Properties

Name | Description
UIndex | The node's index along the U axis.
VIndex | The node's index along the V axis.

See Also

GridNode Structure


UIndex Property

[image]

Revit 2011 API
GridNode..::.UIndex Property
GridNode Structure See Also Send Feedback
The node's index along the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int UIndex { get; set; }
Visual Basic (Declaration)
Public Property UIndex As Integer
Visual C++
public:
property int UIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure


VIndex Property

[image]

Revit 2011 API
GridNode..::.VIndex Property
GridNode Structure See Also Send Feedback
The node's index along the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int VIndex { get; set; }
Visual Basic (Declaration)
Public Property VIndex As Integer
Visual C++
public:
property int VIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure


GridNodeLocation Enumeration

[image]

Revit 2011 API
GridNodeLocation Enumeration
See Also Send Feedback
Location of a grid node relative to the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum GridNodeLocation
Visual Basic (Declaration)
Public Enumeration GridNodeLocation
Visual C++
public enum class GridNodeLocation

Members

Member name | Description
Interior |
Boundary |
Exterior |

See Also


GridSegmentDirection Enumeration

[image]

Revit 2011 API
GridSegmentDirection Enumeration
See Also Send Feedback
Specify one of the four adjacent segments to a GridNode. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum GridSegmentDirection
Visual Basic (Declaration)
Public Enumeration GridSegmentDirection
Visual C++
public enum class GridSegmentDirection

Members

Member name | Description
PositiveU |
NegativeU |
PositiveV |
NegativeV |

See Also


GridType Class

[image]

Revit 2011 API
GridType Class
Members See Also Send Feedback
An object that represents a grid type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GridType : LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class GridType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class GridType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB..::.GridType

See Also

GridType Members


GridType Members

[image] [image]

Revit 2011 API
GridType Members
GridType Class Methods Properties See Also Send Feedback

The GridType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GridType Class


GridType Methods

[image] [image]

Revit 2011 API
GridType Methods
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridType Class


GridType Properties

[image] [image]

Revit 2011 API
GridType Properties
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GridType Class


Parameter Property

[image] [image]

Revit 2011 API
GridType..::.Parameter Property
GridType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GridType Class
GridType Members


GridTypeSet Class

[image]

Revit 2011 API
GridTypeSet Class
Members See Also Send Feedback
A set that contains grid types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GridTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GridTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GridTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GridTypeSet

See Also

GridTypeSet Members


GridTypeSet Members

[image] [image]

Revit 2011 API
GridTypeSet Members
GridTypeSet Class Constructors Methods Properties See Also Send Feedback

The GridTypeSet type exposes the following members.

Constructors

Name | Description
GridTypeSet | Initializes a new instance of the GridTypeSet class

Methods

Name | Description
Clear | Removes every grid type from the set, rendering it empty.
Contains | Tests for the existence of a grid type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified grid type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified grid type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class


GridTypeSet Constructor

[image]

Revit 2011 API
GridTypeSet Constructor
GridTypeSet Class See Also Send Feedback
Initializes a new instance of the GridTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSet()

See Also

GridTypeSet Class


GridTypeSet Methods

[image] [image]

Revit 2011 API
GridTypeSet Methods
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every grid type from the set, rendering it empty.
Contains | Tests for the existence of a grid type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified grid type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified grid type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSet Class


Clear Method

[image]

Revit 2011 API
GridTypeSet..::.Clear Method
GridTypeSet Class See Also Send Feedback
Removes every grid type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GridTypeSet Class


Contains Method

[image]

Revit 2011 API
GridTypeSet..::.Contains Method
GridTypeSet Class See Also Send Feedback
Tests for the existence of a grid type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GridType
The grid type to be searched for.

Return Value

The Contains method returns True if the grid type is within the set, otherwise False.

See Also

GridTypeSet Class


Erase Method

[image]

Revit 2011 API
GridTypeSet..::.Erase Method
GridTypeSet Class See Also Send Feedback
Removes a specified grid type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GridType _
) As Integer
Visual C++
public:
virtual int Erase(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GridType
The grid type to be erased.

Return Value

The number of grid types that were erased from the set.

See Also

GridTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
GridTypeSet..::.ForwardIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GridTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
GridTypeSet..::.GetEnumerator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GridTypeSet Class


Insert Method

[image]

Revit 2011 API
GridTypeSet..::.Insert Method
GridTypeSet Class See Also Send Feedback
Insert the specified grid type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    GridType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GridType
The grid type to be inserted into the set.

Return Value

Returns whether the grid type was inserted into the set.

See Also

GridTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
GridTypeSet..::.ReverseIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GridTypeSet Class


GridTypeSet Properties

[image] [image]

Revit 2011 API
GridTypeSet Properties
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
GridTypeSet..::.IsEmpty Property
GridTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GridTypeSet Class


Size Property

[image]

Revit 2011 API
GridTypeSet..::.Size Property
GridTypeSet Class See Also Send Feedback
Returns the number of grid types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GridTypeSet Class


GridTypeSetIterator Class

[image]

Revit 2011 API
GridTypeSetIterator Class
Members See Also Send Feedback
An iterator to a grid type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GridTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GridTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GridTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GridTypeSetIterator

See Also

GridTypeSetIterator Members


GridTypeSetIterator Members

[image] [image]

Revit 2011 API
GridTypeSetIterator Members
GridTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Constructors

Name | Description
GridTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class


GridTypeSetIterator Constructor

[image]

Revit 2011 API
GridTypeSetIterator Constructor
GridTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GridTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridTypeSetIterator Class


GridTypeSetIterator Methods

[image] [image]

Revit 2011 API
GridTypeSetIterator Methods
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
GridTypeSetIterator..::.MoveNext Method
GridTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
GridTypeSetIterator..::.Reset Method
GridTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GridTypeSetIterator Class


GridTypeSetIterator Properties

[image] [image]

Revit 2011 API
GridTypeSetIterator Properties
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class


Current Property

[image]

Revit 2011 API
GridTypeSetIterator..::.Current Property
GridTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class


Group Class

[image]

Revit 2011 API
Group Class
Members Example See Also Send Feedback
This object represents a group of elements within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Group : Element
Visual Basic (Declaration)
Public Class Group _
    Inherits Element
Visual C++
public ref class Group : public Element

Examples

CopyC#
// Change the default group name to a new name �MyGroup�
group.GroupType.Name = "MyGroup";
CopyC#
public void GetInfo_Group(Group group)
{
    string message = "Group : ";

    // Show the group type name
    message += "\nGroup type name is : " + group.GroupType.Name;

    // Show the name of the elements contained in the group
    message += "\nThe members contained in this group are:";
    foreach (Element member in group.Members)
    {
        message += "\n\tGroup member id : " + member.Id.IntegerValue;
    }

    message += "\nAll member will now be removed from group.";
    group.Ungroup();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
' Change the default group name to a new name "MyGroup"
group.GroupType.Name = "MyGroup"
CopyVB.NET
Public Sub GetInfo_Group(ByVal group As Group)
    Dim message As String = "Group : "

    ' Show the group type name
    message += vbLf & "Group type name is : " + group.GroupType.Name

    ' Show the name of the elements contained in the group
    message += vbLf & "The members contained in this group are:"
    For Each member As Autodesk.Revit.DB.Element In group.Members
        message += vbLf & vbTab & "Group member id : " + member.Id.IntegerValue
    Next

    message += vbLf & "All member will now be removed from group."
    group.Ungroup()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Group

See Also

Group Members


Group Members

[image] [image]

Revit 2011 API
Group Members
Group Class Methods Properties See Also Send Feedback

The Group type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Ungroup | Ungroup the group.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
GroupType | Get or set the type of the group.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of a group within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Returns all the members of the group.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Group Class


Group Methods

[image] [image]

Revit 2011 API
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Ungroup | Ungroup the group.

See Also

Group Class


Ungroup Method

[image]

Revit 2011 API
Group..::.Ungroup Method
Group Class See Also Send Feedback
Ungroup the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Ungroup()
Visual Basic (Declaration)
Public Function Ungroup As ElementSet
Visual C++
public:
ElementSet^ Ungroup()

Return Value

If successful the removed group elements are returned in this set.

Remarks

Ungroup removed all the members from the group and then causes the group itself to be deleted. Note that the reference to this group object will become invalid once this method is called. If the group cannot be ungrouped a System.InvalidOperationException will be thrown.

See Also

Group Class


Group Properties

[image] [image]

Revit 2011 API
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
GroupType | Get or set the type of the group.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of a group within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Returns all the members of the group.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Group Class


GroupType Property

[image]

Revit 2011 API
Group..::.GroupType Property
Group Class See Also Send Feedback
Get or set the type of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GroupType GroupType { get; set; }
Visual Basic (Declaration)
Public Overridable Property GroupType As GroupType
Visual C++
public:
virtual property GroupType^ GroupType {
    GroupType^ get ();
    void set (GroupType^ value);
}

Remarks

By setting this property the group can be swapped to a different kind of group.

See Also

Group Class


Location Property

[image]

Revit 2011 API
Group..::.Location Property
Group Class See Also Send Feedback
This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.

See Also

Group Class


Members Property

[image]

Revit 2011 API
Group..::.Members Property
Group Class See Also Send Feedback
Returns all the members of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As ElementArray
Visual C++
public:
property ElementArray^ Members {
    ElementArray^ get ();
}

Remarks

This property returns an ordered array of the members within the group. The order of this array can be used to match members between other instances of the group.

See Also

Group Class


Parameter Property

[image] [image]

Revit 2011 API
Group..::.Parameter Property
Group Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Group Class
Group Members


GroupSet Class

[image]

Revit 2011 API
GroupSet Class
Members See Also Send Feedback
An set that contains groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GroupSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class GroupSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroupSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GroupSet

See Also

GroupSet Members


GroupSet Members

[image] [image]

Revit 2011 API
GroupSet Members
GroupSet Class Constructors Methods Properties See Also Send Feedback

The GroupSet type exposes the following members.

Constructors

Name | Description
GroupSet | Initializes a new instance of the GroupSet class

Methods

Name | Description
Clear | Removes every group from the set, rendering it empty.
Contains | Tests for the existence of a group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified group from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified group into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


GroupSet Constructor

[image]

Revit 2011 API
GroupSet Constructor
GroupSet Class See Also Send Feedback
Initializes a new instance of the GroupSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroupSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSet()

See Also

GroupSet Class


GroupSet Methods

[image] [image]

Revit 2011 API
GroupSet Methods
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Methods

Name | Description
Clear | Removes every group from the set, rendering it empty.
Contains | Tests for the existence of a group within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified group from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified group into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSet Class


Clear Method

[image]

Revit 2011 API
GroupSet..::.Clear Method
GroupSet Class See Also Send Feedback
Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroupSet Class


Contains Method

[image]

Revit 2011 API
GroupSet..::.Contains Method
GroupSet Class See Also Send Feedback
Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Group
The group to be searched for.

Return Value

The Contains method returns True if the group is within the set, otherwise False.

See Also

GroupSet Class


Erase Method

[image]

Revit 2011 API
GroupSet..::.Erase Method
GroupSet Class See Also Send Feedback
Removes a specified group from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Group _
) As Integer
Visual C++
public:
virtual int Erase(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Group
The group to be erased.

Return Value

The number of groups that were erased from the set.

See Also

GroupSet Class


ForwardIterator Method

[image]

Revit 2011 API
GroupSet..::.ForwardIterator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GroupSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class


GetEnumerator Method

[image]

Revit 2011 API
GroupSet..::.GetEnumerator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GroupSet Class


Insert Method

[image]

Revit 2011 API
GroupSet..::.Insert Method
GroupSet Class See Also Send Feedback
Insert the specified group into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Group item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Group
The group to be inserted into the set.

Return Value

Returns whether the group was inserted into the set.

See Also

GroupSet Class


ReverseIterator Method

[image]

Revit 2011 API
GroupSet..::.ReverseIterator Method
GroupSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GroupSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroupSet Class


GroupSet Properties

[image] [image]

Revit 2011 API
GroupSet Properties
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


IsEmpty Property

[image]

Revit 2011 API
GroupSet..::.IsEmpty Property
GroupSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroupSet Class


Size Property

[image]

Revit 2011 API
GroupSet..::.Size Property
GroupSet Class See Also Send Feedback
Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroupSet Class


GroupSetIterator Class

[image]

Revit 2011 API
GroupSetIterator Class
Members See Also Send Feedback
An iterator to a group set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GroupSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GroupSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroupSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GroupSetIterator

See Also

GroupSetIterator Members


GroupSetIterator Members

[image] [image]

Revit 2011 API
GroupSetIterator Members
GroupSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroupSetIterator type exposes the following members.

Constructors

Name | Description
GroupSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class


GroupSetIterator Constructor

[image]

Revit 2011 API
GroupSetIterator Constructor
GroupSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroupSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupSetIterator Class


GroupSetIterator Methods

[image] [image]

Revit 2011 API
GroupSetIterator Methods
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSetIterator Class


MoveNext Method

[image]

Revit 2011 API
GroupSetIterator..::.MoveNext Method
GroupSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroupSetIterator Class


Reset Method

[image]

Revit 2011 API
GroupSetIterator..::.Reset Method
GroupSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroupSetIterator Class


GroupSetIterator Properties

[image] [image]

Revit 2011 API
GroupSetIterator Properties
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class


Current Property

[image]

Revit 2011 API
GroupSetIterator..::.Current Property
GroupSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroupSetIterator Class


GroupType Class

[image]

Revit 2011 API
GroupType Class
Members Example See Also Send Feedback
Represents a type of a user defined group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GroupType : ElementType
Visual Basic (Declaration)
Public Class GroupType _
    Inherits ElementType
Visual C++
public ref class GroupType : public ElementType

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Examples

CopyC#
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        foreach (Element element in group.Members)
        {
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + element.Id.IntegerValue;
        }
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_GroupType(ByVal groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & groupType.Name.ToString()
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        For Each element As Autodesk.Revit.DB.Element In group.Members
            ' Get GroupType group element id
            message += vbLf & vbTab + element.[GetType]().Name & " : " + element.Id.ToString()
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.GroupType

See Also

GroupType Members


GroupType Members

[image] [image]

Revit 2011 API
GroupType Members
GroupType Class Methods Properties See Also Send Feedback

The GroupType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Groups | Retrieve a set of all the groups that have this type.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GroupType Class


GroupType Methods

[image] [image]

Revit 2011 API
GroupType Methods
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupType Class


GroupType Properties

[image] [image]

Revit 2011 API
GroupType Properties
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Groups | Retrieve a set of all the groups that have this type.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GroupType Class


Groups Property

[image]

Revit 2011 API
GroupType..::.Groups Property
GroupType Class See Also Send Feedback
Retrieve a set of all the groups that have this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroupSet Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupSet
Visual C++
public:
property GroupSet^ Groups {
    GroupSet^ get ();
}

Return Value

A set of group objects that all share this group type.

Remarks

All groups returned by this property belong to this group type. A groups type can be changed by using the GroupType property on the group object, in which case it will no longer belong to this type but it will belong to the new type instead.

See Also

GroupType Class


Parameter Property

[image] [image]

Revit 2011 API
GroupType..::.Parameter Property
GroupType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GroupType Class
GroupType Members


GuidEnum Class

[image]

Revit 2011 API
GuidEnum Class
Members See Also Send Feedback
Base class of all GUID-based enum classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GuidEnum
Visual Basic (Declaration)
Public Class GuidEnum
Visual C++
public ref class GuidEnum

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GuidEnum
Autodesk.Revit.DB..::.FailureDefinitionId

See Also

GuidEnum Members


GuidEnum Members

[image] [image]

Revit 2011 API
GuidEnum Members
GuidEnum Class Constructors Methods Properties See Also Send Feedback

The GuidEnum type exposes the following members.

Constructors

Name | Description
GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class


GuidEnum Constructor

[image]

Revit 2011 API
GuidEnum Constructor
GuidEnum Class See Also Send Feedback
Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GuidEnum(
    Guid guid
)
Visual Basic (Declaration)
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
GuidEnum(
    Guid guid
)

Parameters

guid
Type: System..::.Guid
The GUID of this GUID-based enum.

See Also

GuidEnum Class


GuidEnum Methods

[image] [image]

Revit 2011 API
GuidEnum Methods
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GuidEnum Class


GuidEnum Properties

[image] [image]

Revit 2011 API
GuidEnum Properties
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Properties

Name | Description
Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class


Guid Property

[image]

Revit 2011 API
GuidEnum..::.Guid Property
GuidEnum Class See Also Send Feedback
The Guid of GUID-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Guid Guid { get; }
Visual Basic (Declaration)
Public ReadOnly Property Guid As Guid
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

GuidEnum Class


HermiteFace Class

[image]

Revit 2011 API
HermiteFace Class
Members Example See Also Send Feedback
A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HermiteFace : Face
Visual Basic (Declaration)
Public Class HermiteFace _
    Inherits Face
Visual C++
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

CopyC#
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        IList<XYZ> points = hermiteFace.Points;
        IList<XYZ> derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        IList<XYZ> tangents = hermiteFace.get_Tangents(0);
    }
}
CopyVB.NET
Private Sub GetHermiteFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Points
        Dim derivs As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Tangents(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.HermiteFace

See Also

HermiteFace Members


HermiteFace Members

[image] [image]

Revit 2011 API
HermiteFace Members
HermiteFace Class Methods Properties See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
MixedDerivs | Mixed derivatives of the surface.
Params | Parameters of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Points | Interpolation points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Tangents | Tangents of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


HermiteFace Methods

[image] [image]

Revit 2011 API
HermiteFace Methods
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class


Intersect Method

[image] [image]

Revit 2011 API
HermiteFace..::.Intersect Method
HermiteFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


IsInside Method

[image] [image]

Revit 2011 API
HermiteFace..::.IsInside Method
HermiteFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


HermiteFace Properties

[image] [image]

Revit 2011 API
HermiteFace Properties
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
MixedDerivs | Mixed derivatives of the surface.
Params | Parameters of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Points | Interpolation points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Tangents | Tangents of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


MixedDerivs Property

[image]

Revit 2011 API
HermiteFace..::.MixedDerivs Property
HermiteFace Class See Also Send Feedback
Mixed derivatives of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> MixedDerivs { get; }
Visual Basic (Declaration)
Public ReadOnly Property MixedDerivs As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ MixedDerivs {
    IList<XYZ^>^ get ();
}

See Also

HermiteFace Class


Params Property

[image]

Revit 2011 API
HermiteFace..::.Params Property
HermiteFace Class See Also Send Feedback
Parameters of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Params[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Params ( _
    index As Integer _
) As DoubleArray
Visual C++
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

HermiteFace Class


Points Property

[image]

Revit 2011 API
HermiteFace..::.Points Property
HermiteFace Class See Also Send Feedback
Interpolation points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
}

See Also

HermiteFace Class


Tangents Property

[image]

Revit 2011 API
HermiteFace..::.Tangents Property
HermiteFace Class See Also Send Feedback
Tangents of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Tangents[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tangents ( _
    index As Integer _
) As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Tangents[int index] {
    IList<XYZ^>^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

HermiteFace Class


HermiteSpline Class

[image]

Revit 2011 API
HermiteSpline Class
Members See Also Send Feedback
A Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HermiteSpline : Curve
Visual Basic (Declaration)
Public Class HermiteSpline _
    Inherits Curve
Visual C++
public ref class HermiteSpline : public Curve

Remarks

The Hermite spline lies in the plane defined by control points.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.HermiteSpline

See Also

HermiteSpline Members


HermiteSpline Members

[image] [image]

Revit 2011 API
HermiteSpline Members
HermiteSpline Class Methods Properties See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


HermiteSpline Methods

[image] [image]

Revit 2011 API
HermiteSpline Methods
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HermiteSpline Class


Intersect Method

[image] [image]

Revit 2011 API
HermiteSpline..::.Intersect Method
HermiteSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


IsInside Method

[image] [image]

Revit 2011 API
HermiteSpline..::.IsInside Method
HermiteSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


HermiteSpline Properties

[image] [image]

Revit 2011 API
HermiteSpline Properties
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
ControlPoints | The control points of the Hermite spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsPeriodic | Returns whether the Hermite spline is periodic or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Parameters | Returns the params of the Hermite spline.
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Tangents | Returns the tangents of the Hermite spline.
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


ControlPoints Property

[image]

Revit 2011 API
HermiteSpline..::.ControlPoints Property
HermiteSpline Class See Also Send Feedback
The control points of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> ControlPoints { get; set; }
Visual Basic (Declaration)
Public Property ControlPoints As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ ControlPoints {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

See Also

HermiteSpline Class


IsPeriodic Property

[image]

Revit 2011 API
HermiteSpline..::.IsPeriodic Property
HermiteSpline Class See Also Send Feedback
Returns whether the Hermite spline is periodic or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPeriodic { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPeriodic As Boolean
Visual C++
public:
property bool IsPeriodic {
    bool get ();
}

See Also

HermiteSpline Class


Parameters Property

[image]

Revit 2011 API
HermiteSpline..::.Parameters Property
HermiteSpline Class See Also Send Feedback
Returns the params of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As DoubleArray
Visual C++
public:
property DoubleArray^ Parameters {
    DoubleArray^ get ();
}

See Also

HermiteSpline Class


Tangents Property

[image]

Revit 2011 API
HermiteSpline..::.Tangents Property
HermiteSpline Class See Also Send Feedback
Returns the tangents of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Tangents { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tangents As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Tangents {
    IList<XYZ^>^ get ();
}

See Also

HermiteSpline Class


HiddenLineViewsType Enumeration

[image]

Revit 2011 API
HiddenLineViewsType Enumeration
See Also Send Feedback
An enumerated type listing all Hidden Line Views types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum HiddenLineViewsType
Visual Basic (Declaration)
Public Enumeration HiddenLineViewsType
Visual C++
public enum class HiddenLineViewsType

Members

Member name | Description
VectorProcessing | The type of Hidden Line Views is Vector Processing (fast).
RasterProcessing | The type of Hidden Line Views is Raster Processing.

See Also


HorizontalAlign Enumeration

[image]

Revit 2011 API
HorizontalAlign Enumeration
See Also Send Feedback
Horizontal alignment of model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum HorizontalAlign
Visual Basic (Declaration)
Public Enumeration HorizontalAlign
Visual C++
public enum class HorizontalAlign

Members

Member name | Description
Left |
Center |
Right |

See Also


HorizontalAlignmentStyle Enumeration

[image]

Revit 2011 API
HorizontalAlignmentStyle Enumeration
See Also Send Feedback
Declares the horizontal alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum HorizontalAlignmentStyle
Visual Basic (Declaration)
Public Enumeration HorizontalAlignmentStyle
Visual C++
public enum class HorizontalAlignmentStyle

Members

Member name | Description
Left | Alignment to left
Center | Alignment to center
Right | Alignment to right

See Also


HostedSweep Class

[image]

Revit 2011 API
HostedSweep Class
Members See Also Send Feedback
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class HostedSweep : HostObject
Visual Basic (Declaration)
Public MustInherit Class HostedSweep _
    Inherits HostObject
Visual C++
public ref class HostedSweep abstract : public HostObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB.Architecture..::.Fascia
Autodesk.Revit.DB.Architecture..::.Gutter
Autodesk.Revit.DB..::.SlabEdge

See Also

HostedSweep Members


HostedSweep Members

[image] [image]

Revit 2011 API
HostedSweep Members
HostedSweep Class Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostedSweep Class


HostedSweep Methods

[image] [image]

Revit 2011 API
HostedSweep Methods
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the hosted sweep object.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object.
SetEndPointParameter | Set segment's start point or end point parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line.

See Also

HostedSweep Class


AddSegment Method

[image]

Revit 2011 API
HostedSweep..::.AddSegment Method
HostedSweep Class See Also Send Feedback
Add segments to the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public MustOverride Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) abstract

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference

See Also

HostedSweep Class


GetEndPointParameter Method

[image]

Revit 2011 API
HostedSweep..::.GetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic (Declaration)
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


HorizontalFlip Method

[image]

Revit 2011 API
HostedSweep..::.HorizontalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void HorizontalFlip()
Visual Basic (Declaration)
Public Sub HorizontalFlip
Visual C++
public:
void HorizontalFlip()

See Also

HostedSweep Class


RemoveSegment Method

[image]

Revit 2011 API
HostedSweep..::.RemoveSegment Method
HostedSweep Class See Also Send Feedback
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


SetEndPointParameter Method

[image]

Revit 2011 API
HostedSweep..::.SetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic (Declaration)
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference whose parameter want to be set.
endIdx
Type: System..::.Int32
Start point (=0) or end point (=1).
param
Type: System..::.Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlip Method

[image]

Revit 2011 API
HostedSweep..::.VerticalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void VerticalFlip()
Visual Basic (Declaration)
Public Sub VerticalFlip
Visual C++
public:
void VerticalFlip()

See Also

HostedSweep Class


HostedSweep Properties

[image] [image]

Revit 2011 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostedSweep Class


Angle Property

[image]

Revit 2011 API
HostedSweep..::.Angle Property
HostedSweep Class See Also Send Feedback
Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HorizontalFlipped Property

[image]

Revit 2011 API
HostedSweep..::.HorizontalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HorizontalFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalFlipped As Boolean
Visual C++
public:
property bool HorizontalFlipped {
    bool get ();
}

See Also

HostedSweep Class


HorizontalOffset Property

[image]

Revit 2011 API
HostedSweep..::.HorizontalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


Length Property

[image]

Revit 2011 API
HostedSweep..::.Length Property
HostedSweep Class See Also Send Feedback
Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

HostedSweep Class


Parameter Property

[image] [image]

Revit 2011 API
HostedSweep..::.Parameter Property
HostedSweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostedSweep Class
HostedSweep Members


ReferenceCurve Property

[image]

Revit 2011 API
HostedSweep..::.ReferenceCurve Property
HostedSweep Class See Also Send Feedback
The curve on which the hosted sweep segment is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve ReferenceCurve[
    Reference targetRef
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Reference of the curve that hosts the object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlipped Property

[image]

Revit 2011 API
HostedSweep..::.VerticalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool VerticalFlipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalFlipped As Boolean
Visual C++
public:
property bool VerticalFlipped {
    bool get ();
}

See Also

HostedSweep Class


VerticalOffset Property

[image]

Revit 2011 API
HostedSweep..::.VerticalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HostedSweepType Class

[image]

Revit 2011 API
HostedSweepType Class
Members See Also Send Feedback
An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HostedSweepType : HostObjAttributes
Visual Basic (Declaration)
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB.Architecture..::.FasciaType
Autodesk.Revit.DB.Architecture..::.GutterType
Autodesk.Revit.DB..::.SlabEdgeType

See Also

HostedSweepType Members


HostedSweepType Members

[image] [image]

Revit 2011 API
HostedSweepType Members
HostedSweepType Class Methods Properties See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostedSweepType Class


HostedSweepType Methods

[image] [image]

Revit 2011 API
HostedSweepType Methods
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostedSweepType Class


HostedSweepType Properties

[image] [image]

Revit 2011 API
HostedSweepType Properties
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostedSweepType Class


Parameter Property

[image] [image]

Revit 2011 API
HostedSweepType..::.Parameter Property
HostedSweepType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostedSweepType Class
HostedSweepType Members


HostObjAttributes Class

[image]

Revit 2011 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HostObjAttributes : ElementType
Visual Basic (Declaration)
Public Class HostObjAttributes _
    Inherits ElementType
Visual C++
public ref class HostObjAttributes : public ElementType

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.ContFootingType
Autodesk.Revit.DB..::.CurtainSystemType
Autodesk.Revit.DB..::.FloorType
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB..::.RoofType
Autodesk.Revit.DB..::.WallType

See Also

HostObjAttributes Members


HostObjAttributes Members

[image] [image]

Revit 2011 API
HostObjAttributes Members
HostObjAttributes Class Methods Properties See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostObjAttributes Class


HostObjAttributes Methods

[image] [image]

Revit 2011 API
HostObjAttributes Methods
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObjAttributes Class


HostObjAttributes Properties

[image] [image]

Revit 2011 API
HostObjAttributes Properties
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostObjAttributes Class


CompoundStructure Property

[image]

Revit 2011 API
HostObjAttributes..::.CompoundStructure Property
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CompoundStructure CompoundStructure { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompoundStructure As CompoundStructure
Visual C++
public:
property CompoundStructure^ CompoundStructure {
    CompoundStructure^ get ();
}

Remarks

From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

HostObjAttributes Class


Parameter Property

[image] [image]

Revit 2011 API
HostObjAttributes..::.Parameter Property
HostObjAttributes Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostObjAttributes Class
HostObjAttributes Members


HostObject Class

[image]

Revit 2011 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as a wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic (Declaration)
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.CeilingAndFloor
Autodesk.Revit.DB..::.ContFooting
Autodesk.Revit.DB..::.CurtainGridLine
Autodesk.Revit.DB..::.CurtainSystemBase
Autodesk.Revit.DB.Electrical..::.Wire
Autodesk.Revit.DB..::.FaceWall
Autodesk.Revit.DB..::.Floor
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.Wall

See Also

HostObject Members


HostObject Members

[image] [image]

Revit 2011 API
HostObject Members
HostObject Class Methods Properties See Also Send Feedback

The HostObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostObject Class


HostObject Methods

[image] [image]

Revit 2011 API
HostObject Methods
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObject Class


HostObject Properties

[image] [image]

Revit 2011 API
HostObject Properties
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

HostObject Class


Parameter Property

[image] [image]

Revit 2011 API
HostObject..::.Parameter Property
HostObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

HostObject Class
HostObject Members


IConnector Interface

[image]

Revit 2011 API
IConnector Interface
Members See Also Send Feedback
An interface which provides access to connector in Autodesk Revit MEP document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IConnector
Visual Basic (Declaration)
Public Interface IConnector
Visual C++
public interface class IConnector

Remarks

This interface is shared by Connector, DuctConnector,ElectricalConnector and PipeConnector.

See Also

IConnector Members


IConnector Members

[image] [image]

Revit 2011 API
IConnector Members
IConnector Interface Properties See Also Send Feedback

The IConnector type exposes the following members.

Properties

Name | Description
CoordinateSystem | The coordinate system of the connector.
Domain | The domain of the connector.
Height | The height of the connector.
Origin | The location of the connector in family document.
Radius | The radius of the connector.
Shape | The shape of the connector.
Width | The width of the connector.

See Also

IConnector Interface


IConnector Properties

[image] [image]

Revit 2011 API
IConnector Properties
IConnector Interface See Also Send Feedback

The IConnector type exposes the following members.

Properties

Name | Description
CoordinateSystem | The coordinate system of the connector.
Domain | The domain of the connector.
Height | The height of the connector.
Origin | The location of the connector in family document.
Radius | The radius of the connector.
Shape | The shape of the connector.
Width | The width of the connector.

See Also

IConnector Interface


CoordinateSystem Property

[image]

Revit 2011 API
IConnector..::.CoordinateSystem Property
IConnector Interface See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
Transform CoordinateSystem { get; }
Visual Basic (Declaration)
ReadOnly Property CoordinateSystem As Transform
Visual C++
property Transform^ CoordinateSystem {
    Transform^ get ();
}

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

IConnector Interface


Domain Property

[image]

Revit 2011 API
IConnector..::.Domain Property
IConnector Interface See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
Domain Domain { get; }
Visual Basic (Declaration)
ReadOnly Property Domain As Domain
Visual C++
property Domain Domain {
    Domain get ();
}

Remarks

This property is used to retrieve the domain of the connector.

See Also

IConnector Interface


Height Property

[image]

Revit 2011 API
IConnector..::.Height Property
IConnector Interface See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
double Height { get; }
Visual Basic (Declaration)
ReadOnly Property Height As Double
Visual C++
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


Origin Property

[image]

Revit 2011 API
IConnector..::.Origin Property
IConnector Interface See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
XYZ Origin { get; }
Visual Basic (Declaration)
ReadOnly Property Origin As XYZ
Visual C++
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to retrieve the origin of the connector.

See Also

IConnector Interface


Radius Property

[image]

Revit 2011 API
IConnector..::.Radius Property
IConnector Interface See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
double Radius { get; }
Visual Basic (Declaration)
ReadOnly Property Radius As Double
Visual C++
property double Radius {
    double get ();
}

Remarks

This property is used to retrieve the radius of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not round.

See Also

IConnector Interface


Shape Property

[image]

Revit 2011 API
IConnector..::.Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
ReadOnly Property Shape As ConnectorProfileType
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface


Width Property

[image]

Revit 2011 API
IConnector..::.Width Property
IConnector Interface See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
double Width { get; }
Visual Basic (Declaration)
ReadOnly Property Width As Double
Visual C++
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


IExtension Interface

[image]

Revit 2011 API
IExtension Interface
Members See Also Send Feedback
An interface that supports the additional operation for Extension Status

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

Remarks

See Also

IExtension Members


IExtension Members

[image] [image]

Revit 2011 API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Extended | Retrieves or set the extension status at the end
HasMiter | Retrieves the miter status at the end
IsMiterLocked | Retrieves or set the miter locked status at the end.
SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface


IExtension Properties

[image] [image]

Revit 2011 API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Extended | Retrieves or set the extension status at the end
HasMiter | Retrieves the miter status at the end
IsMiterLocked | Retrieves or set the miter locked status at the end.
SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface


Extended Property

[image]

Revit 2011 API
IExtension..::.Extended Property
IExtension Interface See Also Send Feedback
Retrieves or set the extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool Extended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property Extended ( _
    index As Integer _
) As Boolean
Visual C++
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.

See Also

IExtension Interface


HasMiter Property

[image]

Revit 2011 API
IExtension..::.HasMiter Property
IExtension Interface See Also Send Feedback
Retrieves the miter status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool HasMiter[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface


IsMiterLocked Property

[image]

Revit 2011 API
IExtension..::.IsMiterLocked Property
IExtension Interface See Also Send Feedback
Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool IsMiterLocked[
    int index
] { get; set; }
Visual Basic (Declaration)
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface


SymbolicExtended Property

[image]

Revit 2011 API
IExtension..::.SymbolicExtended Property
IExtension Interface See Also Send Feedback
Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool SymbolicExtended[
    int index
] { get; set; }
Visual Basic (Declaration)
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::.Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface


IFailuresPreprocessor Interface

[image]

Revit 2011 API
IFailuresPreprocessor Interface
Members Example See Also Send Feedback
An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public interface IFailuresPreprocessor
Visual Basic (Declaration)
Public Interface IFailuresPreprocessor
Visual C++
public interface class IFailuresPreprocessor

Remarks

This interface, if provided, is invoked when there are failures found at the end of a transaction. An instance of this interface can be set in the failure handling options of transaction object.

Examples

CopyC#
public class RoomWarningSwallower : IFailuresPreprocessor
{
    public FailureProcessingResult PreprocessFailures(FailuresAccessor failuresAccessor)
    {
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        // Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages();
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                failuresAccessor.DeleteWarning(failure);
            }
        }

        return FailureProcessingResult.Continue;
    }
}
CopyVB.NET
Public Class RoomWarningSwallower
    Implements IFailuresPreprocessor
    Public Function PreprocessFailures(ByVal failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresPreprocessor.PreprocessFailures
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        ' Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages()
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                failuresAccessor.DeleteWarning(failure)
            End If
        Next

        Return FailureProcessingResult.[Continue]
    End Function
End Class

See Also

IFailuresPreprocessor Members


IFailuresPreprocessor Members

[image] [image]

Revit 2011 API
IFailuresPreprocessor Members
IFailuresPreprocessor Interface Methods See Also Send Feedback

The IFailuresPreprocessor type exposes the following members.

Methods

Name | Description
PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

See Also

IFailuresPreprocessor Interface


IFailuresPreprocessor Methods

[image] [image]

Revit 2011 API
IFailuresPreprocessor Methods
IFailuresPreprocessor Interface See Also Send Feedback

The IFailuresPreprocessor type exposes the following members.

Methods

Name | Description
PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

See Also

IFailuresPreprocessor Interface


PreprocessFailures Method

[image]

Revit 2011 API
IFailuresPreprocessor..::.PreprocessFailures Method
IFailuresPreprocessor Interface See Also Send Feedback
This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
FailureProcessingResult PreprocessFailures(
    FailuresAccessor failuresAccessor
)
Visual Basic (Declaration)
Function PreprocessFailures ( _
    failuresAccessor As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult PreprocessFailures(
    FailuresAccessor^ failuresAccessor
)

Parameters

failuresAccessor
Type: Autodesk.Revit.DB..::.FailuresAccessor
The Interface class that provides access to the failure information.

Return Value

Notifies end of transaction code about further actions required. Return values are interpreted as follows:
  • Continue - the failure processing will continue. Failures will be shown to the user, even if they were addressed by this method.
  • ProceedWithCommit - end of transaction checks and failure processing will restart from the beginning. If some failures were resolved here, they will be removed and not delivered to the user. ProceedWithCommit can not be returned if transaction is being rolled back.
  • ProceedWithRollBack - the failure processing will continue. Failures will be shown to the user, but user will have no option to resolve or ignore them - only cancel option will be available. If intent is to roll back transaction without showing failures to the user, it can be achieved by setting failure handling option to remove failures before returning ProceedWithRollBack.
Other return values are not allowed.

See Also

IFailuresPreprocessor Interface


IFailuresProcessor Interface

[image]

Revit 2011 API
IFailuresProcessor Interface
Members Example See Also Send Feedback
To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IFailuresProcessor
Visual Basic (Declaration)
Public Interface IFailuresProcessor
Visual C++
public interface class IFailuresProcessor

Remarks

To override Revit default Failures Processing UI, instantiate your own processor derived from this interface and register it in Revit application.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)]
[Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)]
public class MyFailuresUI : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"));
    public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication uiControlledApplication)
    {
        IFailuresProcessor myFailUI = new FailUI();
        //Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        return Result.Succeeded;
    }

    public Autodesk.Revit.UI.Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    public class FailUI : IFailuresProcessor
    {
        public void Dismiss(Document document)
        {
            // This method is being called in case of exception or document destruction to
            // dismiss any possible pending failure UI that may have left on the screen
        }

        public FailureProcessingResult ProcessFailures(FailuresAccessor failuresAccessor)
        {
            IList<FailureResolutionType> resolutionTypeList = new List<FailureResolutionType>();
            IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
            // Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages();
            string errorString = "";
            bool hasFailures = false;
            foreach (FailureMessageAccessor failure in failList)
            {
                // check how many resolutions types were attempted to try to prevent
                // entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure);
                if (resolutionTypeList.Count >= 3)
                {
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.");
                    return FailureProcessingResult.ProceedWithRollBack;
                }

                errorString += "IDs ";
                foreach (ElementId id in failure.GetFailingElementIds())
                {
                    errorString += id + ", ";
                    hasFailures = true;
                }
                errorString += "\nWill be deleted because: " + failure.GetDescriptionText() + "\n";
                failuresAccessor.DeleteElements(failure.GetFailingElementIds() as IList<ElementId>);
            }
            if (hasFailures)
            {
                TaskDialog.Show("Error", errorString);
                return FailureProcessingResult.ProceedWithCommit;
            }

            return FailureProcessingResult.Continue;
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)> _
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class MyFailuresUI
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"))
    Public Function OnStartup(ByVal uiControlledApplication As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Dim myFailUI As IFailuresProcessor = New FailUI()
        'Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Public Class FailUI
        Implements IFailuresProcessor
        Public Sub Dismiss(ByVal document As Document) Implements IFailuresProcessor.Dismiss
            ' This method is being called in case of exception or document destruction to
            ' dismiss any possible pending failure UI that may have left on the screen
        End Sub

        Public Function ProcessFailures(ByVal failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresProcessor.ProcessFailures
            Dim resolutionTypeList As IList(Of FailureResolutionType) = New List(Of FailureResolutionType)()
            Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
            ' Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages()
            Dim errorString As String = ""
            Dim hasFailures As Boolean = False
            For Each failure As FailureMessageAccessor In failList
                ' check how many resolutions types were attempted to try to prevent
                ' entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure)
                If resolutionTypeList.Count >= 3 Then
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.")
                    Return FailureProcessingResult.ProceedWithRollBack
                End If

                errorString += "IDs "
                For Each id As ElementId In failure.GetFailingElementIds()
                    errorString += id.ToString() + ", "
                    hasFailures = True
                Next
                errorString += vbLf & "Will be deleted because: " + failure.GetDescriptionText() + vbLf
                failuresAccessor.DeleteElements(TryCast(failure.GetFailingElementIds(), IList(Of ElementId)))
            Next
            If hasFailures Then
                TaskDialog.Show("Error", errorString)
                Return FailureProcessingResult.ProceedWithCommit
            End If

            Return FailureProcessingResult.[Continue]
        End Function
    End Class
End Class

See Also

IFailuresProcessor Members


IFailuresProcessor Members

[image] [image]

Revit 2011 API
IFailuresProcessor Members
IFailuresProcessor Interface Methods See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

Name | Description
Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


IFailuresProcessor Methods

[image] [image]

Revit 2011 API
IFailuresProcessor Methods
IFailuresProcessor Interface See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

Name | Description
Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


Dismiss Method

[image]

Revit 2011 API
IFailuresProcessor..::.Dismiss Method
IFailuresProcessor Interface See Also Send Feedback
This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
void Dismiss(
    Document document
)
Visual Basic (Declaration)
Sub Dismiss ( _
    document As Document _
)
Visual C++
void Dismiss(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document for which pending failures processing UI should be dismissed

See Also

IFailuresProcessor Interface


ProcessFailures Method

[image]

Revit 2011 API
IFailuresProcessor..::.ProcessFailures Method
IFailuresProcessor Interface See Also Send Feedback
Method that Revit will invoke to process failures at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
FailureProcessingResult ProcessFailures(
    FailuresAccessor data
)
Visual Basic (Declaration)
Function ProcessFailures ( _
    data As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult ProcessFailures(
    FailuresAccessor^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::.FailuresAccessor
Provides all necessary data to perform the resolution of failures.

Return Value

The result of the failures processing.
  • Continue - Should be returned if there were no failures or highest failure severity was "Warning" and all warnings were deleted. If some failures are still present and "Continue" is returned, it will be treated as "ProceedWithRollback". Note: If this method has attempted to resolve failures, it should return "ProceedWithCommit" to repeat end of transaction checks and failures processing.
  • ProceedWithCommit - End of transaction checks and failure processing will restart from the beginning. If some failures were resolved, they will be removed and not delivered to the user. ProceedWithCommit can not be returned if transaction is being rolled back.
  • ProceedWithRollBack - Transaction will be rolled back even if Commit was originally requested.
  • WaitForUserInput - Should be returned if method has activated modeless user interaction and is waiting for an external event (typically user input) to complete failures processing.

Remarks

This method is invoked after some failures may have been handled by any FailuresPreprocessor and/or FailureProcessing event subscribers.

See Also

IFailuresProcessor Interface


IFamilyLoadOptions Interface

[image]

Revit 2011 API
IFamilyLoadOptions Interface
Members See Also Send Feedback
An interface class which provide the callback for family load options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IFamilyLoadOptions
Visual Basic (Declaration)
Public Interface IFamilyLoadOptions
Visual C++
public interface class IFamilyLoadOptions

See Also

IFamilyLoadOptions Members


IFamilyLoadOptions Members

[image] [image]

Revit 2011 API
IFamilyLoadOptions Members
IFamilyLoadOptions Interface Methods See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

Name | Description
OnFamilyFound | This is the method called when the family was found in the target document already.
OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface


IFamilyLoadOptions Methods

[image] [image]

Revit 2011 API
IFamilyLoadOptions Methods
IFamilyLoadOptions Interface See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

Name | Description
OnFamilyFound | This is the method called when the family was found in the target document already.
OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface


OnFamilyFound Method

[image]

Revit 2011 API
IFamilyLoadOptions..::.OnFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the family was found in the target document already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool OnFamilyFound(
    bool familyInUse,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Function OnFamilyFound ( _
    familyInUse As Boolean, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnFamilyFound(
    bool familyInUse,
    bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::.Boolean
Indicates if at least one instance of the family is placed in the project or not.
overwriteParameterValues
Type: System..::.Boolean %
This is a boolean argument by reference which determines if overwrite the parameter values of existing types or not. The default value is false, and it can be overwritten if you want to change the behavior.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface


OnSharedFamilyFound Method

[image]

Revit 2011 API
IFamilyLoadOptions..::.OnSharedFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the shared family was found in the target document already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.DB..::.Family
The shared family in the current family document.
familyInUse
Type: System..::.Boolean
Indicates if at least one instance of the family is placed in the project or not.
source
Type: Autodesk.Revit.DB..::.FamilySource %
This is an output enum argument which indicates if the family will load from the project or the current family.
overwriteParameterValues
Type: System..::.Boolean %
This is an output boolean argument which indicates if overwrite the parameter values of existing types.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface


IFCExportOptions Class

[image]

Revit 2011 API
IFCExportOptions Class
Members See Also Send Feedback
IFC Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class IFCExportOptions
Visual Basic (Declaration)
Public Class IFCExportOptions
Visual C++
public ref class IFCExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.IFCExportOptions

See Also

IFCExportOptions Members


IFCExportOptions Members

[image] [image]

Revit 2011 API
IFCExportOptions Members
IFCExportOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExportOptions type exposes the following members.

Constructors

Name | Description
IFCExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentViewOnly | Option to export only the parts of a model that are visible in the current view.
ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
FamilyMappingFile | Path to a file containing family mapping.
FileVersion | IFC file version.
WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


IFCExportOptions Constructor

[image]

Revit 2011 API
IFCExportOptions Constructor
IFCExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IFCExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IFCExportOptions()

See Also

IFCExportOptions Class


IFCExportOptions Methods

[image] [image]

Revit 2011 API
IFCExportOptions Methods
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExportOptions Class


IFCExportOptions Properties

[image] [image]

Revit 2011 API
IFCExportOptions Properties
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Properties

Name | Description
CurrentViewOnly | Option to export only the parts of a model that are visible in the current view.
ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
FamilyMappingFile | Path to a file containing family mapping.
FileVersion | IFC file version.
WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


CurrentViewOnly Property

[image]

Revit 2011 API
IFCExportOptions..::.CurrentViewOnly Property
IFCExportOptions Class See Also Send Feedback
Option to export only the parts of a model that are visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CurrentViewOnly { get; set; }
Visual Basic (Declaration)
Public Property CurrentViewOnly As Boolean
Visual C++
public:
property bool CurrentViewOnly {
    bool get ();
    void set (bool value);
}

Remarks

Visible elements include those that are hidden by hidden lines or shaded mode, any underlays in the view, and elements that are cropped from view by the crop region. Elements temporarily hidden using temporary hide/isolate will not be exported.

See Also

IFCExportOptions Class


ExportBaseQuantities Property

[image]

Revit 2011 API
IFCExportOptions..::.ExportBaseQuantities Property
IFCExportOptions Class See Also Send Feedback
Option to export IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ExportBaseQuantities { get; set; }
Visual Basic (Declaration)
Public Property ExportBaseQuantities As Boolean
Visual C++
public:
property bool ExportBaseQuantities {
    bool get ();
    void set (bool value);
}

Remarks

IFC has created a list of common quantities (e.g. length, area, volume, etc.) that can optionally be exported along with the 3D representation for many element types (e.g. walls, columns, doors). Setting this option to true will cause the export procedure to include the set of IFC quantities that Revit currently supports.

See Also

IFCExportOptions Class


FamilyMappingFile Property

[image]

Revit 2011 API
IFCExportOptions..::.FamilyMappingFile Property
IFCExportOptions Class See Also Send Feedback
Path to a file containing family mapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string FamilyMappingFile { get; set; }
Visual Basic (Declaration)
Public Property FamilyMappingFile As String
Visual C++
public:
property String^ FamilyMappingFile {
    String^ get ();
    void set (String^ value);
}

Remarks

The file, if specified, contains data describing how to map generic family instances to IFC containers (element types). This property may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, in which case the current mapping will be used.

See Also

IFCExportOptions Class


FileVersion Property

[image]

Revit 2011 API
IFCExportOptions..::.FileVersion Property
IFCExportOptions Class See Also Send Feedback
IFC file version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IFCVersion FileVersion { get; set; }
Visual Basic (Declaration)
Public Property FileVersion As IFCVersion
Visual C++
public:
property IFCVersion FileVersion {
    IFCVersion get ();
    void set (IFCVersion value);
}

See Also

IFCExportOptions Class


WallAndColumnSplitting Property

[image]

Revit 2011 API
IFCExportOptions..::.WallAndColumnSplitting Property
IFCExportOptions Class See Also Send Feedback
Option to allow division of multi-level walls and columns by levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool WallAndColumnSplitting { get; set; }
Visual Basic (Declaration)
Public Property WallAndColumnSplitting As Boolean
Visual C++
public:
property bool WallAndColumnSplitting {
    bool get ();
    void set (bool value);
}

Remarks

This option will always be considered true when FileVersion is IFC-BCA.

See Also

IFCExportOptions Class


IFCVersion Enumeration

[image]

Revit 2011 API
IFCVersion Enumeration
See Also Send Feedback
An enumerated type listing available IFC file versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum IFCVersion
Visual Basic (Declaration)
Public Enumeration IFCVersion
Visual C++
public enum class IFCVersion

Members

Member name | Description
Default | The Autodesk Revit application's default export format.
IFCBCA | IFC BCA file format.
IFC2x2 | IFC 2x2 file format.
IFC2x3 | IFC 2x3 file format.

See Also


ImageExportOptions Class

[image]

Revit 2011 API
ImageExportOptions Class
Members See Also Send Feedback
This class defines options for exporting views and sheets as an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ImageExportOptions : IDisposable
Visual Basic (Declaration)
Public Class ImageExportOptions _
    Implements IDisposable
Visual C++
public ref class ImageExportOptions : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ImageExportOptions

See Also

ImageExportOptions Members


ImageExportOptions Members

[image] [image]

Revit 2011 API
ImageExportOptions Members
ImageExportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageExportOptions type exposes the following members.

Constructors

Name | Description
ImageExportOptions | Constructs a new instance of the options class used to produce images.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportRange | The export range, which defines which view(s) will be exported.
FilePath | The file name and path for the exported file.
FitDirection | The fit direction. Used only if ZoomType is FitToPage.
HLRandWFViewsFileType | File type for exported HLR and wireframe views.
ImageResolution | The image resolution in dots per inch.
PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
ShadowViewsFileType | The file type for exported shadow views.
ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
ViewName | The name of the view to be created.
Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ImageExportOptions Constructor

[image]

Revit 2011 API
ImageExportOptions Constructor
ImageExportOptions Class See Also Send Feedback
Constructs a new instance of the options class used to produce images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageExportOptions()

See Also

ImageExportOptions Class


ImageExportOptions Methods

[image] [image]

Revit 2011 API
ImageExportOptions Methods
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageExportOptions Class


Dispose Method

[image]

Revit 2011 API
ImageExportOptions..::.Dispose Method
ImageExportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ImageExportOptions Class


GetViewsAndSheets Method

[image]

Revit 2011 API
ImageExportOptions..::.GetViewsAndSheets Method
ImageExportOptions Class See Also Send Feedback
Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetViewsAndSheets()
Visual Basic (Declaration)
Public Function GetViewsAndSheets As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetViewsAndSheets()

Return Value

The ids of the views and sheets.

See Also

ImageExportOptions Class


IsValidForSaveToProjectAsImage Method

[image]

Revit 2011 API
ImageExportOptions..::.IsValidForSaveToProjectAsImage Method
ImageExportOptions Class See Also Send Feedback
Verify if ImageExportOptions object is valid for calling saveToProjectAsImage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions options,
    Document doc
)
Visual Basic (Declaration)
Public Shared Function IsValidForSaveToProjectAsImage ( _
    options As ImageExportOptions, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions^ options,
    Document^ doc
)

Parameters

options
Type: Autodesk.Revit.DB..::.ImageExportOptions
ImageExportOptions object to be validated
doc
Type: Autodesk.Revit.DB..::.Document
Document for view name verification

Return Value

True if ImageExportOptions object is valid for calling saveToProjectAsImage; false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ImageExportOptions Class


SetViewsAndSheets Method

[image]

Revit 2011 API
ImageExportOptions..::.SetViewsAndSheets Method
ImageExportOptions Class See Also Send Feedback
Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetViewsAndSheets(
    IList<ElementId> viewsAndSheets
)
Visual Basic (Declaration)
Public Sub SetViewsAndSheets ( _
    viewsAndSheets As IList(Of ElementId) _
)
Visual C++
public:
void SetViewsAndSheets(
    IList<ElementId^>^ viewsAndSheets
)

Parameters

viewsAndSheets
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The ids of the views and sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ImageExportOptions Class


ImageExportOptions Properties

[image] [image]

Revit 2011 API
ImageExportOptions Properties
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Properties

Name | Description
ExportRange | The export range, which defines which view(s) will be exported.
FilePath | The file name and path for the exported file.
FitDirection | The fit direction. Used only if ZoomType is FitToPage.
HLRandWFViewsFileType | File type for exported HLR and wireframe views.
ImageResolution | The image resolution in dots per inch.
PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
ShadowViewsFileType | The file type for exported shadow views.
ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
ViewName | The name of the view to be created.
Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ExportRange Property

[image]

Revit 2011 API
ImageExportOptions..::.ExportRange Property
ImageExportOptions Class See Also Send Feedback
The export range, which defines which view(s) will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ExportRange ExportRange { get; set; }
Visual Basic (Declaration)
Public Property ExportRange As ExportRange
Visual C++
public:
property ExportRange ExportRange {
    ExportRange get ();
    void set (ExportRange value);
}

Remarks

The default is CurrentView. Note that SetOfViews is not an acceptable value if these options are used to save an image to a project as a new view.

See Also

ImageExportOptions Class


FilePath Property

[image]

Revit 2011 API
ImageExportOptions..::.FilePath Property
ImageExportOptions Class See Also Send Feedback
The file name and path for the exported file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string FilePath { get; set; }
Visual Basic (Declaration)
Public Property FilePath As String
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Remarks

If ExportRange is SetOfViews, the name of each view or sheet will be appended to the name provided for each exported file. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


FitDirection Property

[image]

Revit 2011 API
ImageExportOptions..::.FitDirection Property
ImageExportOptions Class See Also Send Feedback
The fit direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FitDirectionType FitDirection { get; set; }
Visual Basic (Declaration)
Public Property FitDirection As FitDirectionType
Visual C++
public:
property FitDirectionType FitDirection {
    FitDirectionType get ();
    void set (FitDirectionType value);
}

Remarks

The default is Horizontal.

See Also

ImageExportOptions Class


HLRandWFViewsFileType Property

[image]

Revit 2011 API
ImageExportOptions..::.HLRandWFViewsFileType Property
ImageExportOptions Class See Also Send Feedback
File type for exported HLR and wireframe views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageFileType HLRandWFViewsFileType { get; set; }
Visual Basic (Declaration)
Public Property HLRandWFViewsFileType As ImageFileType
Visual C++
public:
property ImageFileType HLRandWFViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ImageResolution Property

[image]

Revit 2011 API
ImageExportOptions..::.ImageResolution Property
ImageExportOptions Class See Also Send Feedback
The image resolution in dots per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageResolution ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As ImageResolution
Visual C++
public:
property ImageResolution ImageResolution {
    ImageResolution get ();
    void set (ImageResolution value);
}

Remarks

The default is DPI_72.

See Also

ImageExportOptions Class


PixelSize Property

[image]

Revit 2011 API
ImageExportOptions..::.PixelSize Property
ImageExportOptions Class See Also Send Feedback
The pixel size of an image in one direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int PixelSize { get; set; }
Visual Basic (Declaration)
Public Property PixelSize As Integer
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

Remarks

The default is 512 pixels.

See Also

ImageExportOptions Class


ShadowViewsFileType Property

[image]

Revit 2011 API
ImageExportOptions..::.ShadowViewsFileType Property
ImageExportOptions Class See Also Send Feedback
The file type for exported shadow views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageFileType ShadowViewsFileType { get; set; }
Visual Basic (Declaration)
Public Property ShadowViewsFileType As ImageFileType
Visual C++
public:
property ImageFileType ShadowViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ShouldCreateWebSite Property

[image]

Revit 2011 API
ImageExportOptions..::.ShouldCreateWebSite Property
ImageExportOptions Class See Also Send Feedback
Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShouldCreateWebSite { get; set; }
Visual Basic (Declaration)
Public Property ShouldCreateWebSite As Boolean
Visual C++
public:
property bool ShouldCreateWebSite {
    bool get ();
    void set (bool value);
}

Remarks

The default is false. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ViewName Property

[image]

Revit 2011 API
ImageExportOptions..::.ViewName Property
ImageExportOptions Class See Also Send Feedback
The name of the view to be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string ViewName { get; set; }
Visual Basic (Declaration)
Public Property ViewName As String
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Remarks

This field is used only to save an image to a project as a new view.

See Also

ImageExportOptions Class


Zoom Property

[image]

Revit 2011 API
ImageExportOptions..::.Zoom Property
ImageExportOptions Class See Also Send Feedback
The value for Zoom (as a percentage). Used only when ZoomType is Zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Remarks

The default is 50.

See Also

ImageExportOptions Class


ZoomType Property

[image]

Revit 2011 API
ImageExportOptions..::.ZoomType Property
ImageExportOptions Class See Also Send Feedback
The zoom type, which defines how the image size is determined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ZoomFitType ZoomType { get; set; }
Visual Basic (Declaration)
Public Property ZoomType As ZoomFitType
Visual C++
public:
property ZoomFitType ZoomType {
    ZoomFitType get ();
    void set (ZoomFitType value);
}

Remarks

The default is FitToPage.

See Also

ImageExportOptions Class


ImageFileType Enumeration

[image]

Revit 2011 API
ImageFileType Enumeration
See Also Send Feedback
This enum is used to define exported file type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ImageFileType
Visual Basic (Declaration)
Public Enumeration ImageFileType
Visual C++
public enum class ImageFileType

Members

Member name | Description
BMP | BMP
JPEGLossless | JPEG with high quality picture
JPEGMedium | JPEG with medium quality picture
JPEGSmallest | JPEG with lower quality picture and small file size
PNG | PNG
TARGA | TARGA
TIFF | TIFF

See Also


ImageImportOptions Class

[image]

Revit 2011 API
ImageImportOptions Class
Members See Also Send Feedback
Import options specific image (bitmap) formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ImageImportOptions : GenericImportOptions
Visual Basic (Declaration)
Public Class ImageImportOptions _
    Inherits GenericImportOptions
Visual C++
public ref class ImageImportOptions : public GenericImportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.GenericImportOptions
Autodesk.Revit.DB..::.ImageImportOptions

See Also

ImageImportOptions Members


ImageImportOptions Members

[image] [image]

Revit 2011 API
ImageImportOptions Members
ImageImportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageImportOptions type exposes the following members.

Constructors

Name | Description
ImageImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Placement | Placement mode defines by which point is the image going to be inserted.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Resolution | Resolution [ppi] of the image to be imported.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions Class


ImageImportOptions Constructor

[image]

Revit 2011 API
ImageImportOptions Constructor
ImageImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageImportOptions()

See Also

ImageImportOptions Class


ImageImportOptions Methods

[image] [image]

Revit 2011 API
ImageImportOptions Methods
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageImportOptions Class


ImageImportOptions Properties

[image] [image]

Revit 2011 API
ImageImportOptions Properties
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Properties

Name | Description
Placement | Placement mode defines by which point is the image going to be inserted.
RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Resolution | Resolution [ppi] of the image to be imported.
View | A view into which the image is going to be imported. (Inherited from GenericImportOptions.)

See Also

ImageImportOptions Class


Placement Property

[image]

Revit 2011 API
ImageImportOptions..::.Placement Property
ImageImportOptions Class See Also Send Feedback
Placement mode defines by which point is the image going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoxPlacement Placement { get; set; }
Visual Basic (Declaration)
Public Property Placement As BoxPlacement
Visual C++
public:
property BoxPlacement Placement {
    BoxPlacement get ();
    void set (BoxPlacement value);
}

See Also

ImageImportOptions Class


Resolution Property

[image]

Revit 2011 API
ImageImportOptions..::.Resolution Property
ImageImportOptions Class See Also Send Feedback
Resolution [ppi] of the image to be imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ushort Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As UShort
Visual C++
public:
property unsigned short Resolution {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

ImageImportOptions Class


ImageResolution Enumeration

[image]

Revit 2011 API
ImageResolution Enumeration
See Also Send Feedback
This enum is used to define image resolution in order to calculate the image size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ImageResolution
Visual Basic (Declaration)
Public Enumeration ImageResolution
Visual C++
public enum class ImageResolution

Members

Member name | Description
DPI_72 | 72 dpi
DPI_150 | 150 dpi
DPI_300 | 300 dpi
DPI_600 | 600 dpi

Remarks

This is used only if the Zoom option for ZoomType is set.

See Also


ImportColorMode Enumeration

[image]

Revit 2011 API
ImportColorMode Enumeration
See Also Send Feedback
An enumerated type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ImportColorMode
Visual Basic (Declaration)
Public Enumeration ImportColorMode
Visual C++
public enum class ImportColorMode

Members

Member name | Description
Preserved | Colors in the imported drawing are preserved.
Inverted | Colors in the imported drawing are inverted.
BlackAndWhite | Colors in the imported drawing are converted to Black and White.

See Also


ImportExportFileFormat Enumeration

[image]

Revit 2011 API
ImportExportFileFormat Enumeration
See Also Send Feedback
Formats supported import / export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ImportExportFileFormat
Visual Basic (Declaration)
Public Enumeration ImportExportFileFormat
Visual C++
public enum class ImportExportFileFormat

Members

Member name | Description
DWG |
DWF |
DWFX |
GBXML |
FBX |
Image |
DGN |
Civil3D |
Inventor |
DXF |
SAT |
IFC |

See Also


ImportInstance Class

[image]

Revit 2011 API
ImportInstance Class
Members See Also Send Feedback
An element created during either import or link operation in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ImportInstance : Element
Visual Basic (Declaration)
Public Class ImportInstance _
    Inherits Element
Visual C++
public ref class ImportInstance : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ImportInstance

See Also

ImportInstance Members


ImportInstance Members

[image] [image]

Revit 2011 API
ImportInstance Members
ImportInstance Class Methods Properties See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the import instance in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the import instance in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLinked | Identifies whether this instance is a linked object rather than imported one.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ImportInstance Class


ImportInstance Methods

[image] [image]

Revit 2011 API
ImportInstance Methods
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the import instance in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the import instance in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImportInstance Class


GetVisibility Method

[image]

Revit 2011 API
ImportInstance..::.GetVisibility Method
ImportInstance Class See Also Send Feedback
Gets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the import instance in a family document.

See Also

ImportInstance Class


SetVisibility Method

[image]

Revit 2011 API
ImportInstance..::.SetVisibility Method
ImportInstance Class See Also Send Feedback
Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.

See Also

ImportInstance Class


ImportInstance Properties

[image] [image]

Revit 2011 API
ImportInstance Properties
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLinked | Identifies whether this instance is a linked object rather than imported one.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ImportInstance Class


IsLinked Property

[image]

Revit 2011 API
ImportInstance..::.IsLinked Property
ImportInstance Class See Also Send Feedback
Identifies whether this instance is a linked object rather than imported one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsLinked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLinked As Boolean
Visual C++
public:
property bool IsLinked {
    bool get ();
}

Remarks

True if the instance was imported as a link to an external file. False if the instance was imported as a copy of data from an external file.

See Also

ImportInstance Class


Parameter Property

[image] [image]

Revit 2011 API
ImportInstance..::.Parameter Property
ImportInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ImportInstance Class
ImportInstance Members


Pinned Property

[image]

Revit 2011 API
ImportInstance..::.Pinned Property
ImportInstance Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Pinned { get; set; }
Visual Basic (Declaration)
Public Property Pinned As Boolean
Visual C++
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

ImportInstance Class


ImportPlacement Enumeration

[image]

Revit 2011 API
ImportPlacement Enumeration
See Also Send Feedback
An enumerated type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ImportPlacement
Visual Basic (Declaration)
Public Enumeration ImportPlacement
Visual C++
public enum class ImportPlacement

Members

Member name | Description
Origin | Placement at the Origin.
Centered | Placement at the Center.
Shared | Placement with respect to the shared coordinates.

See Also


ImportUnit Enumeration

[image]

Revit 2011 API
ImportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ImportUnit
Visual Basic (Declaration)
Public Enumeration ImportUnit
Visual C++
public enum class ImportUnit

Members

Member name | Description
Default | Unit (if available) from the document that is getting imported.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.
Meter | Meters as decimal values.
Decimeter | Centimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.

See Also


IndependentTag Class

[image]

Revit 2011 API
IndependentTag Class
Members See Also Send Feedback
Represents an IndependentTag within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class IndependentTag : Element
Visual Basic (Declaration)
Public Class IndependentTag _
    Inherits Element
Visual C++
public ref class IndependentTag : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.IndependentTag

See Also

IndependentTag Members


IndependentTag Members

[image] [image]

Revit 2011 API
IndependentTag Members
IndependentTag Class Methods Properties See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Leader | Returns whether the tag has a Leader, and can add a leader to tag via set function.
LeaderElbow | Returns the position of the elbow of leader.
LeaderEnd | Returns the position of the end of leader.
LeaderMode | Returns the Leader End Condition of tag.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TagHeadPosition | Returns the position of the head of tag.
TagMode | Returns the Tag Mode of tag.
TagOrientation | Returns the Tag Orientation of tag.
TagText | Returns the text of the Tag.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

IndependentTag Class


IndependentTag Methods

[image] [image]

Revit 2011 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndependentTag Class


IndependentTag Properties

[image] [image]

Revit 2011 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Leader | Returns whether the tag has a Leader, and can add a leader to tag via set function.
LeaderElbow | Returns the position of the elbow of leader.
LeaderEnd | Returns the position of the end of leader.
LeaderMode | Returns the Leader End Condition of tag.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TagHeadPosition | Returns the position of the head of tag.
TagMode | Returns the Tag Mode of tag.
TagOrientation | Returns the Tag Orientation of tag.
TagText | Returns the text of the Tag.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

IndependentTag Class


Leader Property

[image]

Revit 2011 API
IndependentTag..::.Leader Property
IndependentTag Class See Also Send Feedback
Returns whether the tag has a Leader, and can add a leader to tag via set function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Leader { get; set; }
Visual Basic (Declaration)
Public Property Leader As Boolean
Visual C++
public:
property bool Leader {
    bool get ();
    void set (bool value);
}

Return Value

If the tag hold a Leader, return true; if not, return false.

Remarks

This property retrieves the Leader of tag.

See Also

IndependentTag Class


LeaderElbow Property

[image]

Revit 2011 API
IndependentTag..::.LeaderElbow Property
IndependentTag Class See Also Send Feedback
Returns the position of the elbow of leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ LeaderElbow { get; set; }
Visual Basic (Declaration)
Public Property LeaderElbow As XYZ
Visual C++
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Elbow of the Tag Leader.

Remarks

This property retrieves the elbow position of Tag Leader.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | If there is no leader for this tag or the leader is straight, the InvalidOperationException will be thrown.

See Also

IndependentTag Class


LeaderEnd Property

[image]

Revit 2011 API
IndependentTag..::.LeaderEnd Property
IndependentTag Class See Also Send Feedback
Returns the position of the end of leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ LeaderEnd { get; set; }
Visual Basic (Declaration)
Public Property LeaderEnd As XYZ
Visual C++
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the end of the Tag Leader.

Remarks

This property retrieves the end position of Tag Leader, which tie to the Host obj. And ONLY Material Tag support Set operation!

See Also

IndependentTag Class


LeaderMode Property

[image]

Revit 2011 API
IndependentTag..::.LeaderMode Property
IndependentTag Class See Also Send Feedback
Returns the Leader End Condition of tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LeaderEndCondition LeaderMode { get; set; }
Visual Basic (Declaration)
Public Property LeaderMode As LeaderEndCondition
Visual C++
public:
property LeaderEndCondition LeaderMode {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}

Return Value

Return the End Condition of the Tag Leader.

Remarks

This property retrieves the Leader Mode of tag.

See Also

IndependentTag Class


Parameter Property

[image] [image]

Revit 2011 API
IndependentTag..::.Parameter Property
IndependentTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

IndependentTag Class
IndependentTag Members


TagHeadPosition Property

[image]

Revit 2011 API
IndependentTag..::.TagHeadPosition Property
IndependentTag Class See Also Send Feedback
Returns the position of the head of tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic (Declaration)
Public Property TagHeadPosition As XYZ
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Head Position of the Tag.

Remarks

This property retrieves the head position of tag head.

See Also

IndependentTag Class


TagMode Property

[image]

Revit 2011 API
IndependentTag..::.TagMode Property
IndependentTag Class See Also Send Feedback
Returns the Tag Mode of tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TagMode TagMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TagMode As TagMode
Visual C++
public:
property TagMode TagMode {
    TagMode get ();
}

Return Value

Return the Tag Mode of the Tag.

Remarks

This read only property retrieves the Mode of tag.

See Also

IndependentTag Class


TagOrientation Property

[image]

Revit 2011 API
IndependentTag..::.TagOrientation Property
IndependentTag Class See Also Send Feedback
Returns the Tag Orientation of tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TagOrientation TagOrientation { get; set; }
Visual Basic (Declaration)
Public Property TagOrientation As TagOrientation
Visual C++
public:
property TagOrientation TagOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

Return Value

Return the Orientation of the Tag.

Remarks

This property retrieves the Tag Orientation of tag.

See Also

IndependentTag Class


TagText Property

[image]

Revit 2011 API
IndependentTag..::.TagText Property
IndependentTag Class See Also Send Feedback
Returns the text of the Tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string TagText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TagText As String
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Return Value

Return the text of the Tag.

Remarks

This property retrieves the text of the Tag.

See Also

IndependentTag Class


InsertableObject Class

[image]

Revit 2011 API
InsertableObject Class
Members See Also Send Feedback
A base class you all types that are insertable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InsertableObject : ElementType
Visual Basic (Declaration)
Public Class InsertableObject _
    Inherits ElementType
Visual C++
public ref class InsertableObject : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol

See Also

InsertableObject Members


InsertableObject Members

[image] [image]

Revit 2011 API
InsertableObject Members
InsertableObject Class Methods Properties See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

InsertableObject Class


InsertableObject Methods

[image] [image]

Revit 2011 API
InsertableObject Methods
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertableObject Class


InsertableObject Properties

[image] [image]

Revit 2011 API
InsertableObject Properties
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

InsertableObject Class


Parameter Property

[image] [image]

Revit 2011 API
InsertableObject..::.Parameter Property
InsertableObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

InsertableObject Class
InsertableObject Members


InSessionPrintSetting Class

[image]

Revit 2011 API
InSessionPrintSetting Class
Members See Also Send Feedback
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InSessionPrintSetting : IPrintSetting
Visual Basic (Declaration)
Public Class InSessionPrintSetting _
    Implements IPrintSetting
Visual C++
public ref class InSessionPrintSetting : IPrintSetting

Remarks

The in-session PrintSetting can't be stored in document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.InSessionPrintSetting

See Also

InSessionPrintSetting Members


InSessionPrintSetting Members

[image] [image]

Revit 2011 API
InSessionPrintSetting Members
InSessionPrintSetting Class Methods Properties See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


InSessionPrintSetting Methods

[image] [image]

Revit 2011 API
InSessionPrintSetting Methods
InSessionPrintSetting Class See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InSessionPrintSetting Class


InSessionPrintSetting Properties

[image] [image]

Revit 2011 API
InSessionPrintSetting Properties
InSessionPrintSetting Class See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Properties

Name | Description
PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


PrintParameters Property

[image]

Revit 2011 API
InSessionPrintSetting..::.PrintParameters Property
InSessionPrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PrintParameters PrintParameters { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property PrintParameters As PrintParameters
Visual C++
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Implements

IPrintSetting..::.PrintParameters

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

InSessionPrintSetting Class


InSessionViewSheetSet Class

[image]

Revit 2011 API
InSessionViewSheetSet Class
Members See Also Send Feedback
Represents the in-session ViewSheetSet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InSessionViewSheetSet : IViewSheetSet
Visual Basic (Declaration)
Public Class InSessionViewSheetSet _
    Implements IViewSheetSet
Visual C++
public ref class InSessionViewSheetSet : IViewSheetSet

Remarks

The in-session ViewSheetSet can't be stored in document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.InSessionViewSheetSet

See Also

InSessionViewSheetSet Members


InSessionViewSheetSet Members

[image] [image]

Revit 2011 API
InSessionViewSheetSet Members
InSessionViewSheetSet Class Methods Properties See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Views | The views.

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Methods

[image] [image]

Revit 2011 API
InSessionViewSheetSet Methods
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Properties

[image] [image]

Revit 2011 API
InSessionViewSheetSet Properties
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Properties

Name | Description
Views | The views.

See Also

InSessionViewSheetSet Class


Views Property

[image]

Revit 2011 API
InSessionViewSheetSet..::.Views Property
InSessionViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic (Declaration)
Public Overridable Property Views As ViewSet
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::.Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

InSessionViewSheetSet Class


Instance Class

[image]

Revit 2011 API
Instance Class
Members See Also Send Feedback
A base class for all instance objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Instance : Element
Visual Basic (Declaration)
Public Class Instance _
    Inherits Element
Visual C++
public ref class Instance : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.FamilyInstance
Autodesk.Revit.DB..::.ProjectLocation

See Also

Instance Members


Instance Members

[image] [image]

Revit 2011 API
Instance Members
Instance Class Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Instance Class


Instance Methods

[image] [image]

Revit 2011 API
Instance Methods
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Instance Class


Instance Properties

[image] [image]

Revit 2011 API
Instance Properties
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Instance Class


Parameter Property

[image] [image]

Revit 2011 API
Instance..::.Parameter Property
Instance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Instance Class
Instance Members


InstanceArray Class

[image]

Revit 2011 API
InstanceArray Class
Members See Also Send Feedback
An array that contains instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InstanceArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class InstanceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InstanceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.InstanceArray

See Also

InstanceArray Members


InstanceArray Members

[image] [image]

Revit 2011 API
InstanceArray Members
InstanceArray Class Constructors Methods Properties See Also Send Feedback

The InstanceArray type exposes the following members.

Constructors

Name | Description
InstanceArray | Initializes a new instance of the InstanceArray class

Methods

Name | Description
Append |
Clear | Removes every instance from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an instance at a specified index within the array.
Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class


InstanceArray Constructor

[image]

Revit 2011 API
InstanceArray Constructor
InstanceArray Class See Also Send Feedback
Initializes a new instance of the InstanceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArray()

See Also

InstanceArray Class


InstanceArray Methods

[image] [image]

Revit 2011 API
InstanceArray Methods
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every instance from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArray Class


Append Method

[image]

Revit 2011 API
InstanceArray..::.Append Method
InstanceArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    GeometryInstance item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As GeometryInstance _
)
Visual C++
public:
virtual void Append(
    GeometryInstance^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeometryInstance

See Also

InstanceArray Class


Clear Method

[image]

Revit 2011 API
InstanceArray..::.Clear Method
InstanceArray Class See Also Send Feedback
Removes every instance from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InstanceArray Class


ForwardIterator Method

[image]

Revit 2011 API
InstanceArray..::.ForwardIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

InstanceArray Class


GetEnumerator Method

[image]

Revit 2011 API
InstanceArray..::.GetEnumerator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

InstanceArray Class


Insert Method

[image]

Revit 2011 API
InstanceArray..::.Insert Method
InstanceArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryInstance item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As GeometryInstance, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryInstance^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.GeometryInstance
index
Type: System..::.Int32

See Also

InstanceArray Class


ReverseIterator Method

[image]

Revit 2011 API
InstanceArray..::.ReverseIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

InstanceArray Class


InstanceArray Properties

[image] [image]

Revit 2011 API
InstanceArray Properties
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an instance at a specified index within the array.
Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class


IsEmpty Property

[image]

Revit 2011 API
InstanceArray..::.IsEmpty Property
InstanceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

InstanceArray Class


Item Property

[image]

Revit 2011 API
InstanceArray..::.Item Property
InstanceArray Class See Also Send Feedback
Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GeometryInstance Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As GeometryInstance
Visual C++
public:
virtual property GeometryInstance^ Item[int index] {
    GeometryInstance^ get (int index);
    void set (int index, GeometryInstance^ value);
}

Parameters

index
Type: System..::.Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class


Size Property

[image]

Revit 2011 API
InstanceArray..::.Size Property
InstanceArray Class See Also Send Feedback
Returns the number of instances that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InstanceArray Class


InstanceArrayIterator Class

[image]

Revit 2011 API
InstanceArrayIterator Class
Members See Also Send Feedback
An iterator to an instance array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class InstanceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class InstanceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InstanceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.InstanceArrayIterator

See Also

InstanceArrayIterator Members


InstanceArrayIterator Members

[image] [image]

Revit 2011 API
InstanceArrayIterator Members
InstanceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Constructors

Name | Description
InstanceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class


InstanceArrayIterator Constructor

[image]

Revit 2011 API
InstanceArrayIterator Constructor
InstanceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceArrayIterator Class


InstanceArrayIterator Methods

[image] [image]

Revit 2011 API
InstanceArrayIterator Methods
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
InstanceArrayIterator..::.MoveNext Method
InstanceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class


Reset Method

[image]

Revit 2011 API
InstanceArrayIterator..::.Reset Method
InstanceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

InstanceArrayIterator Class


InstanceArrayIterator Properties

[image] [image]

Revit 2011 API
InstanceArrayIterator Properties
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class


Current Property

[image]

Revit 2011 API
InstanceArrayIterator..::.Current Property
InstanceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class


InstanceBinding Class

[image]

Revit 2011 API
InstanceBinding Class
Members Example See Also Send Feedback
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InstanceBinding : ElementBinding
Visual Basic (Declaration)
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Examples

CopyC#
public bool SetNewParameterToInsanceWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    Definition myDefinition_ProductDate =
       myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveUIDocument.Document.Settings.Categories.get_Item(
                                BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Application.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, BuiltInParameterGroup.PG_TEXT);
    return instanceBindOK;
}
CopyVB.NET
Public Function SetNewParameterToInsanceWall(ByVal app As UIApplication, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

    ' create an instance definition in definition group MyParameters
    Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text)

    ' create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
    ' use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.DB.Category = app.ActiveUIDocument.Document.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an instance of InstanceBinding
    Dim instanceBinding As InstanceBinding = app.Application.Create.NewInstanceBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

    ' Bind the definitions to the document
    Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, BuiltInParameterGroup.PG_TEXT)
    Return instanceBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding
Autodesk.Revit.DB..::.InstanceBinding

See Also

InstanceBinding Members


InstanceBinding Members

[image] [image]

Revit 2011 API
InstanceBinding Members
InstanceBinding Class Constructors Methods Properties See Also Send Feedback

The InstanceBinding type exposes the following members.

Constructors

Name | Description
InstanceBinding | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InstanceBinding Constructor

[image] [image]

Revit 2011 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback

Overload List

Name | Description
InstanceBinding()()() | Constructs an empty instance binding.
InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

See Also

InstanceBinding Class
InstanceBinding Members


InstanceBinding Constructor

[image]

Revit 2011 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback
Constructs an empty instance binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InstanceBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Constructor (CategorySet)

[image]

Revit 2011 API
InstanceBinding Constructor (CategorySet)
InstanceBinding Class See Also Send Feedback
Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InstanceBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
InstanceBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit.DB..::.CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Methods

[image] [image]

Revit 2011 API
InstanceBinding Methods
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceBinding Class


InstanceBinding Properties

[image] [image]

Revit 2011 API
InstanceBinding Properties
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InternalDefinition Class

[image]

Revit 2011 API
InternalDefinition Class
Members See Also Send Feedback
This object represents a parameter definition in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InternalDefinition : Definition
Visual Basic (Declaration)
Public Class InternalDefinition _
    Inherits Definition
Visual C++
public ref class InternalDefinition : public Definition

Remarks

This object adds no properties or methods and is used purely for type identification.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Definition
Autodesk.Revit.DB..::.InternalDefinition

See Also

InternalDefinition Members


InternalDefinition Members

[image] [image]

Revit 2011 API
InternalDefinition Members
InternalDefinition Class Methods Properties See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class


InternalDefinition Methods

[image] [image]

Revit 2011 API
InternalDefinition Methods
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinition Class


InternalDefinition Properties

[image] [image]

Revit 2011 API
InternalDefinition Properties
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Properties

Name | Description
BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | The user-visible name for the parameter. (Overrides Definition..::.Name.)
ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::.ParameterGroup.)
ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::.ParameterType.)

See Also

InternalDefinition Class


BuiltInParameter Property

[image]

Revit 2011 API
InternalDefinition..::.BuiltInParameter Property
InternalDefinition Class See Also Send Feedback
Identifies if the parameter is a BuiltIn parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BuiltInParameter BuiltInParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuiltInParameter As BuiltInParameter
Visual C++
public:
property BuiltInParameter BuiltInParameter {
    BuiltInParameter get ();
}

Remarks

If the parameter is not a BuiltIn parameter (e.g. it is a shared parameter or family parameter), BuiltInParameter.INVALID will be returned.

See Also

InternalDefinition Class


Name Property

[image]

Revit 2011 API
InternalDefinition..::.Name Property
InternalDefinition Class See Also Send Feedback
The user-visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

InternalDefinition Class


ParameterGroup Property

[image]

Revit 2011 API
InternalDefinition..::.ParameterGroup Property
InternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

InternalDefinition Class


ParameterType Property

[image]

Revit 2011 API
InternalDefinition..::.ParameterType Property
InternalDefinition Class See Also Send Feedback
Returns the user-visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As ParameterType
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored as an integer, double, string or an element id. To the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

InternalDefinition Class


InternalDefinitions Class

[image]

Revit 2011 API
InternalDefinitions Class
Members See Also Send Feedback
This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InternalDefinitions : Definitions
Visual Basic (Declaration)
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.DefinitionsBase
Autodesk.Revit.DB..::.Definitions
Autodesk.Revit.DB..::.InternalDefinitions

See Also

InternalDefinitions Members


InternalDefinitions Members

[image] [image]

Revit 2011 API
InternalDefinitions Members
InternalDefinitions Class Constructors Methods Properties See Also Send Feedback

The InternalDefinitions type exposes the following members.

Constructors

Name | Description
InternalDefinitions | Initializes a new instance of the InternalDefinitions class

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions Class


InternalDefinitions Constructor

[image]

Revit 2011 API
InternalDefinitions Constructor
InternalDefinitions Class See Also Send Feedback
Initializes a new instance of the InternalDefinitions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InternalDefinitions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InternalDefinitions()

See Also

InternalDefinitions Class


InternalDefinitions Methods

[image] [image]

Revit 2011 API
InternalDefinitions Methods
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Methods

Name | Description
Clear | Removes every definition from the set, rendering it empty. (Inherited from DefinitionsBase.)
Contains | Tests for the existence of a definition within the set. (Inherited from DefinitionsBase.)
Create | Overloaded. Creates a new parameter definition.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified definition from the set. (Inherited from DefinitionsBase.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from DefinitionsBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified definition into the set. (Inherited from DefinitionsBase.)
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from DefinitionsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinitions Class


Create Method

[image] [image]

Revit 2011 API
InternalDefinitions..::.Create Method
InternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

Name | Description
Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Create(String, ParameterType, Boolean) | Creates a new user visible parameter definition using name and type. (Inherited from Definitions.)

See Also

InternalDefinitions Class
InternalDefinitions Members


InternalDefinitions Properties

[image] [image]

Revit 2011 API
InternalDefinitions Properties
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from DefinitionsBase.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Retrieve a definition by a given name. (Inherited from Definitions.)
Size | Returns the number of definitions that are in the set. (Inherited from DefinitionsBase.)

See Also

InternalDefinitions Class


IntersectionResult Class

[image]

Revit 2011 API
IntersectionResult Class
Members See Also Send Feedback
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class IntersectionResult : APIObject
Visual Basic (Declaration)
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.IntersectionResult

See Also

IntersectionResult Members


IntersectionResult Members

[image] [image]

Revit 2011 API
IntersectionResult Members
IntersectionResult Class Constructors Methods Properties See Also Send Feedback

The IntersectionResult type exposes the following members.

Constructors

Name | Description
IntersectionResult | Initializes a new instance of the IntersectionResult class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Distance | Distance from the original object to located point.
EdgeObject | Edge of the face close to the point of intersection.
EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | 1d parameter of the point of intersection.
UVPoint | 2d (or two 1d) parameters of the point of intersection.
XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


IntersectionResult Constructor

[image]

Revit 2011 API
IntersectionResult Constructor
IntersectionResult Class See Also Send Feedback
Initializes a new instance of the IntersectionResult class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResult()

See Also

IntersectionResult Class


IntersectionResult Methods

[image] [image]

Revit 2011 API
IntersectionResult Methods
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResult Class


IntersectionResult Properties

[image] [image]

Revit 2011 API
IntersectionResult Properties
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Properties

Name | Description
Distance | Distance from the original object to located point.
EdgeObject | Edge of the face close to the point of intersection.
EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Parameter | 1d parameter of the point of intersection.
UVPoint | 2d (or two 1d) parameters of the point of intersection.
XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


Distance Property

[image]

Revit 2011 API
IntersectionResult..::.Distance Property
IntersectionResult Class See Also Send Feedback
Distance from the original object to located point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Distance { get; internal set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


EdgeObject Property

[image]

Revit 2011 API
IntersectionResult..::.EdgeObject Property
IntersectionResult Class See Also Send Feedback
Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Edge EdgeObject { get; internal set; }
Visual Basic (Declaration)
Public Property EdgeObject As Edge
Visual C++
public:
property Edge^ EdgeObject {
    Edge^ get ();
    void set (Edge^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


EdgeParameter Property

[image]

Revit 2011 API
IntersectionResult..::.EdgeParameter Property
IntersectionResult Class See Also Send Feedback
Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EdgeParameter { get; internal set; }
Visual Basic (Declaration)
Public Property EdgeParameter As Double
Visual C++
public:
property double EdgeParameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


Parameter Property

[image]

Revit 2011 API
IntersectionResult..::.Parameter Property
IntersectionResult Class See Also Send Feedback
1d parameter of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Parameter { get; internal set; }
Visual Basic (Declaration)
Public Property Parameter As Double
Visual C++
public:
property double Parameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


UVPoint Property

[image]

Revit 2011 API
IntersectionResult..::.UVPoint Property
IntersectionResult Class See Also Send Feedback
2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV UVPoint { get; internal set; }
Visual Basic (Declaration)
Public Property UVPoint As UV
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


XYZPoint Property

[image]

Revit 2011 API
IntersectionResult..::.XYZPoint Property
IntersectionResult Class See Also Send Feedback
Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ XYZPoint { get; internal set; }
Visual Basic (Declaration)
Public Property XYZPoint As XYZ
Visual C++
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


IntersectionResultArray Class

[image]

Revit 2011 API
IntersectionResultArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class IntersectionResultArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class IntersectionResultArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class IntersectionResultArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.IntersectionResultArray

See Also

IntersectionResultArray Members


IntersectionResultArray Members

[image] [image]

Revit 2011 API
IntersectionResultArray Members
IntersectionResultArray Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Constructors

Name | Description
IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Constructor

[image]

Revit 2011 API
IntersectionResultArray Constructor
IntersectionResultArray Class See Also Send Feedback
Initializes a new instance of the IntersectionResultArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResultArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArray()

See Also

IntersectionResultArray Class


IntersectionResultArray Methods

[image] [image]

Revit 2011 API
IntersectionResultArray Methods
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArray Class


Append Method

[image]

Revit 2011 API
IntersectionResultArray..::.Append Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    IntersectionResult item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IntersectionResult _
)
Visual C++
public:
virtual void Append(
    IntersectionResult^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.IntersectionResult

See Also

IntersectionResultArray Class


Clear Method

[image]

Revit 2011 API
IntersectionResultArray..::.Clear Method
IntersectionResultArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

IntersectionResultArray Class


ForwardIterator Method

[image]

Revit 2011 API
IntersectionResultArray..::.ForwardIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class


GetEnumerator Method

[image]

Revit 2011 API
IntersectionResultArray..::.GetEnumerator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

IntersectionResultArray Class


Insert Method

[image]

Revit 2011 API
IntersectionResultArray..::.Insert Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    IntersectionResult item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IntersectionResult, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IntersectionResult^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.IntersectionResult
index
Type: System..::.Int32

See Also

IntersectionResultArray Class


ReverseIterator Method

[image]

Revit 2011 API
IntersectionResultArray..::.ReverseIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Properties

[image] [image]

Revit 2011 API
IntersectionResultArray Properties
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IsEmpty Property

[image]

Revit 2011 API
IntersectionResultArray..::.IsEmpty Property
IntersectionResultArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

IntersectionResultArray Class


Item Property

[image]

Revit 2011 API
IntersectionResultArray..::.Item Property
IntersectionResultArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IntersectionResult Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IntersectionResult
Visual C++
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

IntersectionResultArray Class


Size Property

[image]

Revit 2011 API
IntersectionResultArray..::.Size Property
IntersectionResultArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

IntersectionResultArray Class


IntersectionResultArrayIterator Class

[image]

Revit 2011 API
IntersectionResultArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class IntersectionResultArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class IntersectionResultArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.IntersectionResultArrayIterator

See Also

IntersectionResultArrayIterator Members


IntersectionResultArrayIterator Members

[image] [image]

Revit 2011 API
IntersectionResultArrayIterator Members
IntersectionResultArrayIterator Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Constructors

Name | Description
IntersectionResultArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Constructor

[image]

Revit 2011 API
IntersectionResultArrayIterator Constructor
IntersectionResultArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IntersectionResultArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IntersectionResultArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Methods

[image] [image]

Revit 2011 API
IntersectionResultArrayIterator Methods
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
IntersectionResultArrayIterator..::.MoveNext Method
IntersectionResultArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


Reset Method

[image]

Revit 2011 API
IntersectionResultArrayIterator..::.Reset Method
IntersectionResultArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Properties

[image] [image]

Revit 2011 API
IntersectionResultArrayIterator Properties
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


Current Property

[image]

Revit 2011 API
IntersectionResultArrayIterator..::.Current Property
IntersectionResultArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


InventorImportOptions Class

[image]

Revit 2011 API
InventorImportOptions Class
Members See Also Send Feedback
Import options for Inventor format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InventorImportOptions
Visual Basic (Declaration)
Public Class InventorImportOptions
Visual C++
public ref class InventorImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.InventorImportOptions

See Also

InventorImportOptions Members


InventorImportOptions Members

[image] [image]

Revit 2011 API
InventorImportOptions Members
InventorImportOptions Class Constructors Methods See Also Send Feedback

The InventorImportOptions type exposes the following members.

Constructors

Name | Description
InventorImportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorImportOptions Class


InventorImportOptions Constructor

[image]

Revit 2011 API
InventorImportOptions Constructor
InventorImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InventorImportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InventorImportOptions()

See Also

InventorImportOptions Class


InventorImportOptions Methods

[image] [image]

Revit 2011 API
InventorImportOptions Methods
InventorImportOptions Class See Also Send Feedback

The InventorImportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventorImportOptions Class


IPrintSetting Interface

[image]

Revit 2011 API
IPrintSetting Interface
Members See Also Send Feedback
An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IPrintSetting
Visual Basic (Declaration)
Public Interface IPrintSetting
Visual C++
public interface class IPrintSetting

See Also

IPrintSetting Members


IPrintSetting Members

[image] [image]

Revit 2011 API
IPrintSetting Members
IPrintSetting Interface Properties See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

Name | Description
PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


IPrintSetting Properties

[image] [image]

Revit 2011 API
IPrintSetting Properties
IPrintSetting Interface See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

Name | Description
PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


PrintParameters Property

[image]

Revit 2011 API
IPrintSetting..::.PrintParameters Property
IPrintSetting Interface See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
PrintParameters PrintParameters { get; }
Visual Basic (Declaration)
ReadOnly Property PrintParameters As PrintParameters
Visual C++
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

IPrintSetting Interface


ITransactionFinalizer Interface

[image]

Revit 2011 API
ITransactionFinalizer Interface
Members See Also Send Feedback
An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public interface ITransactionFinalizer
Visual Basic (Declaration)
Public Interface ITransactionFinalizer
Visual C++
public interface class ITransactionFinalizer

See Also

ITransactionFinalizer Members


ITransactionFinalizer Members

[image] [image]

Revit 2011 API
ITransactionFinalizer Members
ITransactionFinalizer Interface Methods See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

Name | Description
OnCommitted | This method is called at the end of committing a transaction
OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


ITransactionFinalizer Methods

[image] [image]

Revit 2011 API
ITransactionFinalizer Methods
ITransactionFinalizer Interface See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

Name | Description
OnCommitted | This method is called at the end of committing a transaction
OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


OnCommitted Method

[image]

Revit 2011 API
ITransactionFinalizer..::.OnCommitted Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of committing a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
void OnCommitted(
    Document document,
    string strTransactionName
)
Visual Basic (Declaration)
Sub OnCommitted ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnCommitted(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document associated with the transaction
strTransactionName
Type: System..::.String
The transaction's name

See Also

ITransactionFinalizer Interface


OnRolledBack Method

[image]

Revit 2011 API
ITransactionFinalizer..::.OnRolledBack Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of rolling back a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
void OnRolledBack(
    Document document,
    string strTransactionName
)
Visual Basic (Declaration)
Sub OnRolledBack ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnRolledBack(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document associated with the transaction
strTransactionName
Type: System..::.String
The transaction's name

See Also

ITransactionFinalizer Interface


IUpdater Interface

[image]

Revit 2011 API
IUpdater Interface
Members Example See Also Send Feedback
The interface used to create an updater capable of reacting to changes in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public interface IUpdater
Visual Basic (Declaration)
Public Interface IUpdater
Visual C++
public interface class IUpdater

Remarks

Implement this interface and register an instance of the derived class with the UpdaterRegistry.

Examples

CopyC#
[Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)]
public class WallUpdaterApplication : Autodesk.Revit.UI.IExternalApplication
{
    public Result OnStartup(Autodesk.Revit.UI.UIControlledApplication application)
    {
        // Register wall updater with Revit
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.RegisterUpdater(updater);

        // Change Scope = any Wall element
        ElementClassFilter wallFilter = new ElementClassFilter(typeof(Wall));

        // Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter,
                                    Element.GetChangeTypeElementAddition());
        return Result.Succeeded;
    }

    public Result OnShutdown(Autodesk.Revit.UI.UIControlledApplication application)
    {
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId());
        return Result.Succeeded;
    }
}

public class WallUpdater : IUpdater
{
    static AddInId m_appId;
    static UpdaterId m_updaterId;
    WallType m_wallType = null;

    // constructor takes the AddInId for the add-in associated with this updater
    public WallUpdater(AddInId id)
    {
        m_appId = id;
        m_updaterId = new UpdaterId(m_appId, new Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"));
    }

    public void Execute(UpdaterData data)
    {
        Document doc = data.GetDocument();

        // Cache the wall type
        if (m_wallType == null)
        {
            FilteredElementCollector collector = new FilteredElementCollector(doc);
            collector.OfClass(typeof(WallType));
            var wallTypes = from element in collector
                            where
                                element.Name == "Exterior - Brick on CMU"
                            select element;
            if (wallTypes.Count<Element>() > 0)
            {
                m_wallType = wallTypes.Cast<WallType>().ElementAt<WallType>(0);
            }
        }

        if (m_wallType != null)
        {
            // Change the wall to the cached wall type.
            foreach (ElementId addedElemId in data.GetAddedElementIds())
            {
                Wall wall = doc.get_Element(addedElemId) as Wall;
                if (wall != null)
                {
                    wall.WallType = m_wallType;
                }
            }
        }
    }

    public string GetAdditionalInformation()
    {
        return "Wall type updater example: updates all newly created walls to a special wall";
    }

    public ChangePriority GetChangePriority()
    {
        return ChangePriority.FloorsRoofsStructuralWalls;
    }

    public UpdaterId GetUpdaterId()
    {
        return m_updaterId;
    }

    public string GetUpdaterName()
    {
        return "Wall Type Updater";
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class WallUpdaterApplication
    Implements Autodesk.Revit.UI.IExternalApplication
    Public Function OnStartup(ByVal application As Autodesk.Revit.UI.UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register wall updater with Revit
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.RegisterUpdater(updater)

        ' Change Scope = any Wall element
        Dim wallFilter As New ElementClassFilter(GetType(Wall))

        ' Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter, Autodesk.Revit.DB.Element.GetChangeTypeElementAddition())
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As Autodesk.Revit.UI.UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId())
        Return Result.Succeeded
    End Function
End Class

Public Class WallUpdater
    Implements IUpdater
    Shared m_appId As AddInId
    Shared m_updaterId As UpdaterId
    Private m_wallType As WallType = Nothing

    ' constructor takes the AddInId for the add-in associated with this updater
    Public Sub New(ByVal id As AddInId)
        m_appId = id
        m_updaterId = New UpdaterId(m_appId, New Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"))
    End Sub

    Public Sub Execute(ByVal data As UpdaterData) Implements IUpdater.Execute
        Dim doc As Document = data.GetDocument()

        ' Cache the wall type
        If m_wallType Is Nothing Then
            Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
            collector.OfClass(GetType(WallType))
            Dim wallTypes As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
            wallTypes = From element In collector _
             Where element.Name = "Exterior - Brick on CMU" _
             Select element
            If wallTypes.Count() > 0 Then
                m_wallType = wallTypes.Cast(Of WallType)().ElementAt(0)
            End If
        End If

        If m_wallType IsNot Nothing Then
            ' Change the wall to the cached wall type.
            For Each addedElemId As ElementId In data.GetAddedElementIds()
                Dim wall As Wall = TryCast(doc.Element(addedElemId), Wall)
                If wall IsNot Nothing Then
                    wall.WallType = m_wallType
                End If
            Next
        End If
    End Sub

    Public Function GetAdditionalInformation() As String Implements IUpdater.GetAdditionalInformation
        Return "Wall type updater example: updates all newly created walls to a special wall"
    End Function

    Public Function GetChangePriority() As ChangePriority Implements IUpdater.GetChangePriority
        Return ChangePriority.FloorsRoofsStructuralWalls
    End Function

    Public Function GetUpdaterId() As UpdaterId Implements IUpdater.GetUpdaterId
        Return m_updaterId
    End Function

    Public Function GetUpdaterName() As String Implements IUpdater.GetUpdaterName
        Return "Wall Type Updater"
    End Function
End Class

See Also

IUpdater Members


IUpdater Members

[image] [image]

Revit 2011 API
IUpdater Members
IUpdater Interface Methods See Also Send Feedback

The IUpdater type exposes the following members.

Methods

Name | Description
Execute | The method that Revit will invoke to perform an update.
GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface


IUpdater Methods

[image] [image]

Revit 2011 API
IUpdater Methods
IUpdater Interface See Also Send Feedback

The IUpdater type exposes the following members.

Methods

Name | Description
Execute | The method that Revit will invoke to perform an update.
GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface


Execute Method

[image]

Revit 2011 API
IUpdater..::.Execute Method
IUpdater Interface See Also Send Feedback
The method that Revit will invoke to perform an update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
void Execute(
    UpdaterData data
)
Visual Basic (Declaration)
Sub Execute ( _
    data As UpdaterData _
)
Visual C++
void Execute(
    UpdaterData^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::.UpdaterData
Provides all necessary data needed to perform the update, including the document and information about the changes that triggered the update.

Remarks

The purpose of this method is to allow your updater to react to changes that have been made to the document, and make appropriate related changes to the same document. Although it can be used to also update data outside of the document, such changes will not become part of the original transaction and will not be subject to undo or redo when the original transaction is undone or redone. If you do use this method to modify data outside of the document, you should also subscribe to the DocumentChanged event to update your data when the original transaction is undone or redone.

The method is invoked by Revit at the end of a document transaction in which elements that matched the UpdateTrigger for this Updater were added, changed or deleted. The method may be invoked more than once for the same transaction due to changes made by other Updaters.

All changes to the document made during the invocation of this method will become a part of the invoking transaction, and maintained for undo and redo operations. When implementing this method you may not open any new transactions (an exception will be thrown), but you may use sub-transactions as required.

The following methods may not be called while executing an Updater, because they introduce cross references between elements. A ForbiddenForDynamicUpdateException will be thrown when an updater attempts to call any of these methods:

  • void Autodesk.Revit.DB.ViewSheet.AddView(Autodesk.Revit.DB.View, Autodesk.Revit.DB.UV)
  • Autodesk.Revit.DB.Family Autodesk.Revit.DB.Document.LoadFamily(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.IFamilyLoadOptions)
  • Autodesk.Revit.DB.Structure.AreaReinforcement Autodesk.Revit.Creation.Document.NewAreaReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, Autodesk.Revit.DB.XYZ)
  • Autodesk.Revit.DB.Structure.PathReinforcement Autodesk.Revit.Creation.Document.NewPathReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, bool)

Although the following methods are allowed during execution of an updater, they can also throw ForbiddenForDynamicUpdateException when cross-references between elements are established as a result of the call. One such example could be creating a face wall that intersect with an existing face wall, so those two would have to be joined together. Apply caution when calling these methods from an updater:

  • Autodesk.Revit.DB.ElementSet Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstances(System.Collections.Generic.List<Autodesk.Revit.Creation.FamilyInstanceCreationData>)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.Document.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element, Autodesk.Revit.DB.Level, Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FaceWall Autodesk.Revit.DB.FaceWall.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.WallLocationLine, Autodesk.Revit.DB.Reference)

Some UI methods may not be called while executing an Updater too, otherwise ForbiddenForDynamicUpdateException will be thrown. Such methods include: PickObject, PickObjects, PickElementsByRectangle, PickPoint, PickOne and WindowSelect.

In addition to the forbidden methods listed above, other API methods that require documents to be in transaction-free state may not be called either. Such methods include but are not limited to Save, SaveAs, Close, LoadFamily, etc. Please refer to the documentation of the respective methods for more information.

See Also

IUpdater Interface


GetAdditionalInformation Method

[image]

Revit 2011 API
IUpdater..::.GetAdditionalInformation Method
IUpdater Interface See Also Send Feedback
Auxiliary text that Revit will use to inform the end user when the Updater is not loaded

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
string GetAdditionalInformation()
Visual Basic (Declaration)
Function GetAdditionalInformation As String
Visual C++
String^ GetAdditionalInformation()

See Also

IUpdater Interface


GetChangePriority Method

[image]

Revit 2011 API
IUpdater..::.GetChangePriority Method
IUpdater Interface See Also Send Feedback
Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
ChangePriority GetChangePriority()
Visual Basic (Declaration)
Function GetChangePriority As ChangePriority
Visual C++
ChangePriority GetChangePriority()

See Also

IUpdater Interface


GetUpdaterId Method

[image]

Revit 2011 API
IUpdater..::.GetUpdaterId Method
IUpdater Interface See Also Send Feedback
Returns globally unique updater id - used to identify the Updater Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
UpdaterId GetUpdaterId()
Visual Basic (Declaration)
Function GetUpdaterId As UpdaterId
Visual C++
UpdaterId^ GetUpdaterId()

See Also

IUpdater Interface


GetUpdaterName Method

[image]

Revit 2011 API
IUpdater..::.GetUpdaterName Method
IUpdater Interface See Also Send Feedback
Returns a name that the Updater can be identified by to the user

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
string GetUpdaterName()
Visual Basic (Declaration)
Function GetUpdaterName As String
Visual C++
String^ GetUpdaterName()

See Also

IUpdater Interface


IViewSheetSet Interface

[image]

Revit 2011 API
IViewSheetSet Interface
Members See Also Send Feedback
This interface represents a selected set of views/sheets which will be used for printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IViewSheetSet
Visual Basic (Declaration)
Public Interface IViewSheetSet
Visual C++
public interface class IViewSheetSet

See Also

IViewSheetSet Members


IViewSheetSet Members

[image] [image]

Revit 2011 API
IViewSheetSet Members
IViewSheetSet Interface Properties See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

Name | Description
Views | The views.

See Also

IViewSheetSet Interface


IViewSheetSet Properties

[image] [image]

Revit 2011 API
IViewSheetSet Properties
IViewSheetSet Interface See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

Name | Description
Views | The views.

See Also

IViewSheetSet Interface


Views Property

[image]

Revit 2011 API
IViewSheetSet..::.Views Property
IViewSheetSet Interface See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
ViewSet Views { get; set; }
Visual Basic (Declaration)
Property Views As ViewSet
Visual C++
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

IViewSheetSet Interface


JoinType Enumeration

[image]

Revit 2011 API
JoinType Enumeration
See Also Send Feedback
The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum JoinType
Visual Basic (Declaration)
Public Enumeration JoinType
Visual C++
public enum class JoinType

Members

Member name | Description
None | No join type
Abut | Abut Join
Miter | Miter Join
SquareOff | Square-off Join
Extension | Extension Join

See Also


JunctionType Enumeration

[image]

Revit 2011 API
JunctionType Enumeration
See Also Send Feedback
An enumerated type listing all the junction types for MEP curve types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum JunctionType
Visual Basic (Declaration)
Public Enumeration JunctionType
Visual C++
public enum class JunctionType

Members

Member name | Description
Tap | The junction type is tap.
Tee | The junction type is tee.

See Also


LabelUtils Class

[image]

Revit 2011 API
LabelUtils Class
Members See Also Send Feedback
Used to obtain user-visible name for certain enums.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class LabelUtils
Visual Basic (Declaration)
Public Class LabelUtils
Visual C++
public ref class LabelUtils

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.LabelUtils

See Also

LabelUtils Members


LabelUtils Members

[image] [image]

Revit 2011 API
LabelUtils Members
LabelUtils Class Constructors Methods See Also Send Feedback

The LabelUtils type exposes the following members.

Constructors

Name | Description
LabelUtils | Initializes a new instance of the LabelUtils class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelFor | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelUtils Class


LabelUtils Constructor

[image]

Revit 2011 API
LabelUtils Constructor
LabelUtils Class See Also Send Feedback
Initializes a new instance of the LabelUtils class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LabelUtils()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LabelUtils()

See Also

LabelUtils Class


LabelUtils Methods

[image] [image]

Revit 2011 API
LabelUtils Methods
LabelUtils Class See Also Send Feedback

The LabelUtils type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelFor | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelUtils Class


GetLabelFor Method

[image] [image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method
LabelUtils Class See Also Send Feedback

Overload List

Name | Description
GetLabelFor(BuiltInParameter) | Gets user-visible name for BuiltInParameter.
GetLabelFor(BuiltInParameterGroup) | Gets user-visible name for BuiltInParameterGroup.
GetLabelFor(DisplayUnitType) | Gets user-visible name for DisplayUnitType.
GetLabelFor(ParameterType) | Gets user-visible name for ParameterType.
GetLabelFor(UnitType) | Gets user-visible name for UnitType.
GetLabelFor(gbXMLBuildingType, Document) | Gets user-visible name for gbXMLBuildingType.

See Also

LabelUtils Class
LabelUtils Members


GetLabelFor Method (BuiltInParameter)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (BuiltInParameter)
LabelUtils Class See Also Send Feedback
Gets user-visible name for BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    BuiltInParameter builtInParam
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    builtInParam As BuiltInParameter _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::.BuiltInParameter
The BuiltInParameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the BuiltInParameter cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (BuiltInParameterGroup)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (BuiltInParameterGroup)
LabelUtils Class See Also Send Feedback
Gets user-visible name for BuiltInParameterGroup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    builtInParamGroup As BuiltInParameterGroup _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)

Parameters

builtInParamGroup
Type: Autodesk.Revit.DB..::.BuiltInParameterGroup
The BuiltInParameterGroup to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (DisplayUnitType)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (DisplayUnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for DisplayUnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    DisplayUnitType displayUnitType
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    displayUnitType As DisplayUnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    DisplayUnitType displayUnitType
)

Parameters

displayUnitType
Type: Autodesk.Revit.DB..::.DisplayUnitType
The DisplayUnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when information for the input DisplayUnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (ParameterType)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (ParameterType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for ParameterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    ParameterType paramType
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    paramType As ParameterType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    ParameterType paramType
)

Parameters

paramType
Type: Autodesk.Revit.DB..::.ParameterType
The ParameterType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to get user-visible name for the input ParameterType.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (UnitType)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (UnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for UnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    UnitType unitType
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    unitType As UnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    UnitType unitType
)

Parameters

unitType
Type: Autodesk.Revit.DB..::.UnitType
The UnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when information for the input UnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (gbXMLBuildingType, Document)

[image]

Revit 2011 API
LabelUtils..::.GetLabelFor Method (gbXMLBuildingType, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible name for gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetLabelFor ( _
    gbXMLBuildingType As gbXMLBuildingType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document^ doc
)

Parameters

gbXMLBuildingType
Type: Autodesk.Revit.DB.Analysis..::.gbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::.Document
The document from which to get the gbXMLBuildingType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"doc"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the gbXMLBuildingType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


LayoutRule Class

[image]

Revit 2011 API
LayoutRule Class
Members See Also Send Feedback
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic (Declaration)
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.LayoutRuleClearSpacing
Autodesk.Revit.DB..::.LayoutRuleFixedDistance
Autodesk.Revit.DB..::.LayoutRuleFixedNumber
Autodesk.Revit.DB..::.LayoutRuleMaximumSpacing

See Also

LayoutRule Members


LayoutRule Members

[image] [image]

Revit 2011 API
LayoutRule Members
LayoutRule Class Methods Properties See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class


LayoutRule Methods

[image] [image]

Revit 2011 API
LayoutRule Methods
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRule Class


LayoutRule Properties

[image] [image]

Revit 2011 API
LayoutRule Properties
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class


LayoutRuleClearSpacing Class

[image]

Revit 2011 API
LayoutRuleClearSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleClearSpacing myLayoutRuleClearSpacing =
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleClearSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleClearSpacing As New LayoutRuleClearSpacing(10, BeamSystemJustifyType.Beginning)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing

    Dim clearSpacing As LayoutRuleClearSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleClearSpacing)
    If clearSpacing Is Nothing Then
        Return False
    End If

    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = clearSpacing.JustifyType

    Dim spacing As Double = clearSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & clearSpacing.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing.ToString()
    message += vbLf & "New BeamSystem justification: " & justifyType.ToString()

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members


LayoutRuleClearSpacing Members

[image] [image]

Revit 2011 API
LayoutRuleClearSpacing Members
LayoutRuleClearSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Constructors

Name | Description
LayoutRuleClearSpacing | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Constructor

[image]

Revit 2011 API
LayoutRuleClearSpacing Constructor
LayoutRuleClearSpacing Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in [0, 30000).
justifyType
Type: Autodesk.Revit.DB..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Methods

[image] [image]

Revit 2011 API
LayoutRuleClearSpacing Methods
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Properties

[image] [image]

Revit 2011 API
LayoutRuleClearSpacing Properties
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


JustifyType Property

[image]

Revit 2011 API
LayoutRuleClearSpacing..::.JustifyType Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleClearSpacing Class


Spacing Property

[image]

Revit 2011 API
LayoutRuleClearSpacing..::.Spacing Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleFixedDistance Class

[image]

Revit 2011 API
LayoutRuleFixedDistance Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleFixedDistanceInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedDistance myLayoutRuleFixedDistance =
                new LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.End);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance;

    LayoutRuleFixedDistance fixedDistance = beamSystem.LayoutRule as LayoutRuleFixedDistance;
    if (null == fixedDistance)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = fixedDistance.JustifyType;

    double spacing = fixedDistance.Spacing;

    message += "\nNew BeamSystem layout rule: " + fixedDistance;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedDistanceInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedDistance As New LayoutRuleFixedDistance(10, BeamSystemJustifyType.[End])

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance

    Dim fixedDistance As LayoutRuleFixedDistance = TryCast(beamSystem.LayoutRule, LayoutRuleFixedDistance)
    If fixedDistance Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = fixedDistance.JustifyType

    Dim spacing As Double = fixedDistance.Spacing

    message += vbLf & "New BeamSystem layout rule: " & fixedDistance.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing.ToString()
    message += vbLf & "New BeamSystem justification: " & justifyType.ToString()

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members


LayoutRuleFixedDistance Members

[image] [image]

Revit 2011 API
LayoutRuleFixedDistance Members
LayoutRuleFixedDistance Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Constructors

Name | Description
LayoutRuleFixedDistance | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Constructor

[image]

Revit 2011 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be between 0 and 30000.
justifyType
Type: Autodesk.Revit.DB..::.BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Methods

[image] [image]

Revit 2011 API
LayoutRuleFixedDistance Methods
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Properties

[image] [image]

Revit 2011 API
LayoutRuleFixedDistance Properties
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JustifyType | Get or set the type of justification.
Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class


JustifyType Property

[image]

Revit 2011 API
LayoutRuleFixedDistance..::.JustifyType Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic (Declaration)
Public Property JustifyType As BeamSystemJustifyType
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleFixedDistance Class


Spacing Property

[image]

Revit 2011 API
LayoutRuleFixedDistance..::.Spacing Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be between 0 and 30000.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedNumber Class

[image]

Revit 2011 API
LayoutRuleFixedNumber Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Examples

CopyC#
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedNumberInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString()
    message += vbLf & "New BeamSystem number of beams: " + numberOfLines

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members


LayoutRuleFixedNumber Members

[image] [image]

Revit 2011 API
LayoutRuleFixedNumber Members
LayoutRuleFixedNumber Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Constructors

Name | Description
LayoutRuleFixedNumber | Constructor of LayoutRuleFixedNumber.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Constructor

[image]

Revit 2011 API
LayoutRuleFixedNumber Constructor
LayoutRuleFixedNumber Class See Also Send Feedback
Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRuleFixedNumber(
    int numberOfLines
)
Visual Basic (Declaration)
Public Sub New ( _
    numberOfLines As Integer _
)
Visual C++
public:
LayoutRuleFixedNumber(
    int numberOfLines
)

Parameters

numberOfLines
Type: System..::.Int32
The value of numberOfLines must be positive.

Remarks

Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Methods

[image] [image]

Revit 2011 API
LayoutRuleFixedNumber Methods
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Properties

[image] [image]

Revit 2011 API
LayoutRuleFixedNumber Properties
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class


NumberOfLines Property

[image]

Revit 2011 API
LayoutRuleFixedNumber..::.NumberOfLines Property
LayoutRuleFixedNumber Class See Also Send Feedback
Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfLines { get; set; }
Visual Basic (Declaration)
Public Property NumberOfLines As Integer
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

Remarks

The number must be positive.

See Also

LayoutRuleFixedNumber Class


LayoutRuleMaximumSpacing Class

[image]

Revit 2011 API
LayoutRuleMaximumSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Max-Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LayoutRuleMaximumSpacing : LayoutRule
Visual Basic (Declaration)
Public Class LayoutRuleMaximumSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleMaximumSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).

Examples

CopyC#
private bool LayoutRuleMaximumSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleMaximumSpacing myLayoutRuleMaximumSpacing =
                        new LayoutRuleMaximumSpacing(10.0);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing;

    LayoutRuleMaximumSpacing maximunSpacing = beamSystem.LayoutRule as LayoutRuleMaximumSpacing;
    if (null == maximunSpacing)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    double spacing = maximunSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + maximunSpacing;
    message += "\nNew BeamSystem maximum spacing: " + spacing;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleMaximumSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleMaximumSpacing As New LayoutRuleMaximumSpacing(10)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing

    Dim maximunSpacing As LayoutRuleMaximumSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleMaximumSpacing)
    If maximunSpacing Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim spacing As Double = maximunSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & maximunSpacing.ToString()
    message += vbLf & "New BeamSystem maximum spacing: " + spacing

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LayoutRule
Autodesk.Revit.DB..::.LayoutRuleMaximumSpacing

See Also

LayoutRuleMaximumSpacing Members


LayoutRuleMaximumSpacing Members

[image] [image]

Revit 2011 API
LayoutRuleMaximumSpacing Members
LayoutRuleMaximumSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors

Name | Description
LayoutRuleMaximumSpacing | Constructor of LayoutRuleMaximumSpacing.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Constructor

[image]

Revit 2011 API
LayoutRuleMaximumSpacing Constructor
LayoutRuleMaximumSpacing Class See Also Send Feedback
Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LayoutRuleMaximumSpacing(
    double spacing
)
Visual Basic (Declaration)
Public Sub New ( _
    spacing As Double _
)
Visual C++
public:
LayoutRuleMaximumSpacing(
    double spacing
)

Parameters

spacing
Type: System..::.Double
The value of spacing must be in (0, 30000).

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Methods

[image] [image]

Revit 2011 API
LayoutRuleMaximumSpacing Methods
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Properties

[image] [image]

Revit 2011 API
LayoutRuleMaximumSpacing Properties
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


Spacing Property

[image]

Revit 2011 API
LayoutRuleMaximumSpacing..::.Spacing Property
LayoutRuleMaximumSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Double
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


Leader Class

[image]

Revit 2011 API
Leader Class
Members See Also Send Feedback
An object that represents a Leader within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Leader : APIObject
Visual Basic (Declaration)
Public Class Leader _
    Inherits APIObject
Visual C++
public ref class Leader : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Leader.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Leader

See Also

Leader Members


Leader Members

[image] [image]

Revit 2011 API
Leader Members
Leader Class Methods Properties See Also Send Feedback

The Leader type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Elbow | Retrieves and sets the Elbow point of the Leader.
End | Retrieves and sets the End point of the Leader.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class


Leader Methods

[image] [image]

Revit 2011 API
Leader Methods
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Leader Class


Leader Properties

[image] [image]

Revit 2011 API
Leader Properties
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Properties

Name | Description
Elbow | Retrieves and sets the Elbow point of the Leader.
End | Retrieves and sets the End point of the Leader.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class


Elbow Property

[image]

Revit 2011 API
Leader..::.Elbow Property
Leader Class See Also Send Feedback
Retrieves and sets the Elbow point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Elbow { get; set; }
Visual Basic (Declaration)
Public Property Elbow As XYZ
Visual C++
public:
property XYZ^ Elbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Elbow point of the specified Leader object can be taken and set with this Elbow property.

See Also

Leader Class


End Property

[image]

Revit 2011 API
Leader..::.End Property
Leader Class See Also Send Feedback
Retrieves and sets the End point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ End { get; set; }
Visual Basic (Declaration)
Public Property End As XYZ
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The End point of the specified Leader object can be taken and set with this End property.

See Also

Leader Class


LeaderArray Class

[image]

Revit 2011 API
LeaderArray Class
Members See Also Send Feedback
An array that can contain any number of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LeaderArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LeaderArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LeaderArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LeaderArray

See Also

LeaderArray Members


LeaderArray Members

[image] [image]

Revit 2011 API
LeaderArray Members
LeaderArray Class Constructors Methods Properties See Also Send Feedback

The LeaderArray type exposes the following members.

Constructors

Name | Description
LeaderArray | Initializes a new instance of the LeaderArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class


LeaderArray Constructor

[image]

Revit 2011 API
LeaderArray Constructor
LeaderArray Class See Also Send Feedback
Initializes a new instance of the LeaderArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LeaderArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArray()

See Also

LeaderArray Class


LeaderArray Methods

[image] [image]

Revit 2011 API
LeaderArray Methods
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArray Class


Append Method

[image]

Revit 2011 API
LeaderArray..::.Append Method
LeaderArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Leader item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Leader _
)
Visual C++
public:
virtual void Append(
    Leader^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Leader
The item to be added.

See Also

LeaderArray Class


Clear Method

[image]

Revit 2011 API
LeaderArray..::.Clear Method
LeaderArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LeaderArray Class


ForwardIterator Method

[image]

Revit 2011 API
LeaderArray..::.ForwardIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class


GetEnumerator Method

[image]

Revit 2011 API
LeaderArray..::.GetEnumerator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LeaderArray Class


Insert Method

[image]

Revit 2011 API
LeaderArray..::.Insert Method
LeaderArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Leader item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Leader, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Leader^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Leader
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

LeaderArray Class


ReverseIterator Method

[image]

Revit 2011 API
LeaderArray..::.ReverseIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LeaderArray Class


LeaderArray Properties

[image] [image]

Revit 2011 API
LeaderArray Properties
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class


IsEmpty Property

[image]

Revit 2011 API
LeaderArray..::.IsEmpty Property
LeaderArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LeaderArray Class


Item Property

[image]

Revit 2011 API
LeaderArray..::.Item Property
LeaderArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Leader Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Leader
Visual C++
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LeaderArray Class


Size Property

[image]

Revit 2011 API
LeaderArray..::.Size Property
LeaderArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LeaderArray Class


LeaderArrayIterator Class

[image]

Revit 2011 API
LeaderArrayIterator Class
Members See Also Send Feedback
An iterator to an array of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LeaderArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LeaderArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LeaderArrayIterator

See Also

LeaderArrayIterator Members


LeaderArrayIterator Members

[image] [image]

Revit 2011 API
LeaderArrayIterator Members
LeaderArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Constructors

Name | Description
LeaderArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class


LeaderArrayIterator Constructor

[image]

Revit 2011 API
LeaderArrayIterator Constructor
LeaderArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LeaderArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaderArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LeaderArrayIterator Class


LeaderArrayIterator Methods

[image] [image]

Revit 2011 API
LeaderArrayIterator Methods
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
LeaderArrayIterator..::.MoveNext Method
LeaderArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class


Reset Method

[image]

Revit 2011 API
LeaderArrayIterator..::.Reset Method
LeaderArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LeaderArrayIterator Class


LeaderArrayIterator Properties

[image] [image]

Revit 2011 API
LeaderArrayIterator Properties
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class


Current Property

[image]

Revit 2011 API
LeaderArrayIterator..::.Current Property
LeaderArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class


LeaderEndCondition Enumeration

[image]

Revit 2011 API
LeaderEndCondition Enumeration
See Also Send Feedback
An enumerated type listing Leader End Condition which tie to the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum LeaderEndCondition
Visual Basic (Declaration)
Public Enumeration LeaderEndCondition
Visual C++
public enum class LeaderEndCondition

Members

Member name | Description
LEC_ATTACHED | The Leader of the tag is attached.
LEC_FREE | The Leader of the tag is free.

See Also


Level Class

[image]

Revit 2011 API
Level Class
Members Example See Also Send Feedback
Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Level : Element
Visual Basic (Declaration)
Public Class Level _
    Inherits Element
Visual C++
public ref class Level : public Element

Remarks

The Name property can be used to retrieve the user visible name of the level that appears in the level bubble.

Examples

CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(Level)).ToElements();
    foreach (Element e in collection)
    {
        Level level = e as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    TaskDialog.Show("Revit",levelInformation.ToString());
}
CopyVB.NET
Private Sub Getinfo_Level(ByVal document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Autodesk.Revit.DB.Level)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        Dim level As Autodesk.Revit.DB.Level = TryCast(e, Autodesk.Revit.DB.Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            System.Math.Max(System.Threading.Interlocked.Increment(levelNumber), levelNumber - 1)

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " + level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " + level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " + level.ProjectElevation)
        End If
    Next

    'number of total levels in current document
    levelInformation.Append(vbLf & vbLf & " There are " + levelNumber + " levels in the document!")

    'show the level information in the messagebox
    TaskDialog.Show("Revit", levelInformation.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Level

See Also

Level Members


Level Members

[image] [image]

Revit 2011 API
Level Members
Level Class Methods Properties See Also Send Feedback

The Level type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the elevation above or below the ground level.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelType | The level style of this level.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PlaneReference | Returns a reference to this element as a plane.
ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Level Class


Level Methods

[image] [image]

Revit 2011 API
Level Methods
Level Class See Also Send Feedback

The Level type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Level Class


Level Properties

[image] [image]

Revit 2011 API
Level Properties
Level Class See Also Send Feedback

The Level type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elevation | Retrieve or change the elevation above or below the ground level.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelType | The level style of this level.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PlaneReference | Returns a reference to this element as a plane.
ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Level Class


Elevation Property

[image]

Revit 2011 API
Level..::.Elevation Property
Level Class See Also Send Feedback
Retrieve or change the elevation above or below the ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

This property Retrieve or change the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.

See Also

Level Class


LevelType Property

[image]

Revit 2011 API
Level..::.LevelType Property
Level Class See Also Send Feedback
The level style of this level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LevelType LevelType { get; set; }
Visual Basic (Declaration)
Public Property LevelType As LevelType
Visual C++
public:
property LevelType^ LevelType {
    LevelType^ get ();
    void set (LevelType^ value);
}

See Also

Level Class


Parameter Property

[image] [image]

Revit 2011 API
Level..::.Parameter Property
Level Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Level Class
Level Members


PlaneReference Property

[image]

Revit 2011 API
Level..::.PlaneReference Property
Level Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlaneReference As Reference
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

Level Class


ProjectElevation Property

[image]

Revit 2011 API
Level..::.ProjectElevation Property
Level Class See Also Send Feedback
Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ProjectElevation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectElevation As Double
Visual C++
public:
property double ProjectElevation {
    double get ();
}

Remarks

This read only property returns the elevation relative to project origin.

See Also

Level Class


LevelType Class

[image]

Revit 2011 API
LevelType Class
Members See Also Send Feedback
An object that represents a Level type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LevelType : LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class LevelType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class LevelType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB..::.LevelType

See Also

LevelType Members


LevelType Members

[image] [image]

Revit 2011 API
LevelType Members
LevelType Class Methods Properties See Also Send Feedback

The LevelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LevelType Class


LevelType Methods

[image] [image]

Revit 2011 API
LevelType Methods
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelType Class


LevelType Properties

[image] [image]

Revit 2011 API
LevelType Properties
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LevelType Class


Parameter Property

[image] [image]

Revit 2011 API
LevelType..::.Parameter Property
LevelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LevelType Class
LevelType Members


LevelTypeSet Class

[image]

Revit 2011 API
LevelTypeSet Class
Members See Also Send Feedback
A set that contains level types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LevelTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LevelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LevelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LevelTypeSet

See Also

LevelTypeSet Members


LevelTypeSet Members

[image] [image]

Revit 2011 API
LevelTypeSet Members
LevelTypeSet Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSet type exposes the following members.

Constructors

Name | Description
LevelTypeSet | Initializes a new instance of the LevelTypeSet class

Methods

Name | Description
Clear | Removes every level type from the set, rendering it empty.
Contains | Tests for the existence of a level type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified level type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified level type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class


LevelTypeSet Constructor

[image]

Revit 2011 API
LevelTypeSet Constructor
LevelTypeSet Class See Also Send Feedback
Initializes a new instance of the LevelTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LevelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSet()

See Also

LevelTypeSet Class


LevelTypeSet Methods

[image] [image]

Revit 2011 API
LevelTypeSet Methods
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every level type from the set, rendering it empty.
Contains | Tests for the existence of a level type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified level type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified level type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSet Class


Clear Method

[image]

Revit 2011 API
LevelTypeSet..::.Clear Method
LevelTypeSet Class See Also Send Feedback
Removes every level type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LevelTypeSet Class


Contains Method

[image]

Revit 2011 API
LevelTypeSet..::.Contains Method
LevelTypeSet Class See Also Send Feedback
Tests for the existence of a level type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LevelType
The level type to be searched for.

Return Value

The Contains method returns True if the level type is within the set, otherwise False.

See Also

LevelTypeSet Class


Erase Method

[image]

Revit 2011 API
LevelTypeSet..::.Erase Method
LevelTypeSet Class See Also Send Feedback
Removes a specified level type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LevelType _
) As Integer
Visual C++
public:
virtual int Erase(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LevelType
The level type to be erased.

Return Value

The number of level types that were erased from the set.

See Also

LevelTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
LevelTypeSet..::.ForwardIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LevelTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
LevelTypeSet..::.GetEnumerator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LevelTypeSet Class


Insert Method

[image]

Revit 2011 API
LevelTypeSet..::.Insert Method
LevelTypeSet Class See Also Send Feedback
Insert the specified level type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    LevelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LevelType
The level type to be inserted into the set.

Return Value

Returns whether the level type was inserted into the set.

See Also

LevelTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
LevelTypeSet..::.ReverseIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LevelTypeSet Class


LevelTypeSet Properties

[image] [image]

Revit 2011 API
LevelTypeSet Properties
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
LevelTypeSet..::.IsEmpty Property
LevelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LevelTypeSet Class


Size Property

[image]

Revit 2011 API
LevelTypeSet..::.Size Property
LevelTypeSet Class See Also Send Feedback
Returns the number of level types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LevelTypeSet Class


LevelTypeSetIterator Class

[image]

Revit 2011 API
LevelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a level type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LevelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LevelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LevelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LevelTypeSetIterator

See Also

LevelTypeSetIterator Members


LevelTypeSetIterator Members

[image] [image]

Revit 2011 API
LevelTypeSetIterator Members
LevelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Constructors

Name | Description
LevelTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Constructor

[image]

Revit 2011 API
LevelTypeSetIterator Constructor
LevelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LevelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Methods

[image] [image]

Revit 2011 API
LevelTypeSetIterator Methods
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
LevelTypeSetIterator..::.MoveNext Method
LevelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
LevelTypeSetIterator..::.Reset Method
LevelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Properties

[image] [image]

Revit 2011 API
LevelTypeSetIterator Properties
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class


Current Property

[image]

Revit 2011 API
LevelTypeSetIterator..::.Current Property
LevelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class


Line Class

[image]

Revit 2011 API
Line Class
Members See Also Send Feedback
A line in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Line : Curve
Visual Basic (Declaration)
Public Class Line _
    Inherits Curve
Visual C++
public ref class Line : public Curve

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.Line

See Also

Line Members


Line Members

[image] [image]

Revit 2011 API
Line Members
Line Class Methods Properties See Also Send Feedback

The Line type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Bound | Returns the bounded line between the specified points.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Line Methods

[image] [image]

Revit 2011 API
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class


Intersect Method

[image] [image]

Revit 2011 API
Line..::.Intersect Method
Line Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Line Class
Line Members


IsInside Method

[image] [image]

Revit 2011 API
Line..::.IsInside Method
Line Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Line Class
Line Members


Line Properties

[image] [image]

Revit 2011 API
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Bound | Returns the bounded line between the specified points.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Bound Property

[image]

Revit 2011 API
Line..::.Bound Property
Line Class See Also Send Feedback
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Line Bound[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.DB..::.XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.DB..::.XYZ
The end point of the line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class


Unbound Property

[image]

Revit 2011 API
Line..::.Unbound Property
Line Class See Also Send Feedback
Returns the unbounded line that passes through the specified point in the direction of the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Line Unbound[
    XYZ origin,
    XYZ vector
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Unbound ( _
    origin As XYZ, _
    vector As XYZ _
) As Line
Visual C++
public:
static property Line^ Unbound[XYZ^ origin, XYZ^ vector] {
    Line^ get (XYZ^ origin, XYZ^ vector);
}

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
The start point of the line.
vector
Type: Autodesk.Revit.DB..::.XYZ
The direction vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified vector is almost zero and cannot be normalized.

See Also

Line Class


LineAndTextAttrSymbol Class

[image]

Revit 2011 API
LineAndTextAttrSymbol Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LineAndTextAttrSymbol : ElementType
Visual Basic (Declaration)
Public Class LineAndTextAttrSymbol _
    Inherits ElementType
Visual C++
public ref class LineAndTextAttrSymbol : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB..::.GridType
Autodesk.Revit.DB..::.LevelType
Autodesk.Revit.DB..::.TextElementType

See Also

LineAndTextAttrSymbol Members


LineAndTextAttrSymbol Members

[image] [image]

Revit 2011 API
LineAndTextAttrSymbol Members
LineAndTextAttrSymbol Class Methods Properties See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Methods

[image] [image]

Revit 2011 API
LineAndTextAttrSymbol Methods
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Properties

[image] [image]

Revit 2011 API
LineAndTextAttrSymbol Properties
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class


Parameter Property

[image] [image]

Revit 2011 API
LineAndTextAttrSymbol..::.Parameter Property
LineAndTextAttrSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
LineAndTextAttrSymbol Members


LinearArray Class

[image]

Revit 2011 API
LinearArray Class
Members See Also Send Feedback
An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LinearArray : BaseArray
Visual Basic (Declaration)
Public Class LinearArray _
    Inherits BaseArray
Visual C++
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BaseArray
Autodesk.Revit.DB..::.LinearArray

See Also

LinearArray Members


LinearArray Members

[image] [image]

Revit 2011 API
LinearArray Members
LinearArray Class Methods Properties See Also Send Feedback

The LinearArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LinearArray Class


LinearArray Methods

[image] [image]

Revit 2011 API
LinearArray Methods
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearArray Class


LinearArray Properties

[image] [image]

Revit 2011 API
LinearArray Properties
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LinearArray Class


CopyMembers Property

[image]

Revit 2011 API
LinearArray..::.CopyMembers Property
LinearArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class


NumMembers Property

[image]

Revit 2011 API
LinearArray..::.NumMembers Property
LinearArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

LinearArray Class


OrigMembers Property

[image]

Revit 2011 API
LinearArray..::.OrigMembers Property
LinearArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class


Parameter Property

[image] [image]

Revit 2011 API
LinearArray..::.Parameter Property
LinearArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LinearArray Class
LinearArray Members


LinePattern Class

[image]

Revit 2011 API
LinePattern Class
Members See Also Send Feedback
Represents a line pattern element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LinePattern : Element
Visual Basic (Declaration)
Public Class LinePattern _
    Inherits Element
Visual C++
public ref class LinePattern : public Element

Remarks

Currently the details of the line patterns are not exposed but all the line patterns can be found on the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.LinePattern

See Also

LinePattern Members


LinePattern Members

[image] [image]

Revit 2011 API
LinePattern Members
LinePattern Class Methods Properties See Also Send Feedback

The LinePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LinePattern Class


LinePattern Methods

[image] [image]

Revit 2011 API
LinePattern Methods
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePattern Class


LinePattern Properties

[image] [image]

Revit 2011 API
LinePattern Properties
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LinePattern Class


Parameter Property

[image] [image]

Revit 2011 API
LinePattern..::.Parameter Property
LinePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LinePattern Class
LinePattern Members


LinePatternSet Class

[image]

Revit 2011 API
LinePatternSet Class
Members See Also Send Feedback
A set that can contain any number of line patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LinePatternSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LinePatternSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LinePatternSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LinePatternSet

See Also

LinePatternSet Members


LinePatternSet Members

[image] [image]

Revit 2011 API
LinePatternSet Members
LinePatternSet Class Constructors Methods Properties See Also Send Feedback

The LinePatternSet type exposes the following members.

Constructors

Name | Description
LinePatternSet | Initializes a new instance of the LinePatternSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

LinePatternSet Class


LinePatternSet Constructor

[image]

Revit 2011 API
LinePatternSet Constructor
LinePatternSet Class See Also Send Feedback
Initializes a new instance of the LinePatternSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePatternSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSet()

See Also

LinePatternSet Class


LinePatternSet Methods

[image] [image]

Revit 2011 API
LinePatternSet Methods
LinePatternSet Class See Also Send Feedback

The LinePatternSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternSet Class


Clear Method

[image]

Revit 2011 API
LinePatternSet..::.Clear Method
LinePatternSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LinePatternSet Class


Contains Method

[image]

Revit 2011 API
LinePatternSet..::.Contains Method
LinePatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LinePattern

See Also

LinePatternSet Class


Erase Method

[image]

Revit 2011 API
LinePatternSet..::.Erase Method
LinePatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LinePattern _
) As Integer
Visual C++
public:
virtual int Erase(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LinePattern

See Also

LinePatternSet Class


ForwardIterator Method

[image]

Revit 2011 API
LinePatternSet..::.ForwardIterator Method
LinePatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LinePatternSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LinePatternSet Class


GetEnumerator Method

[image]

Revit 2011 API
LinePatternSet..::.GetEnumerator Method
LinePatternSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LinePatternSet Class


Insert Method

[image]

Revit 2011 API
LinePatternSet..::.Insert Method
LinePatternSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    LinePattern item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LinePattern _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LinePattern^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.LinePattern

See Also

LinePatternSet Class


ReverseIterator Method

[image]

Revit 2011 API
LinePatternSet..::.ReverseIterator Method
LinePatternSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LinePatternSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LinePatternSetIterator
Visual C++
public:
virtual LinePatternSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LinePatternSet Class


LinePatternSet Properties

[image] [image]

Revit 2011 API
LinePatternSet Properties
LinePatternSet Class See Also Send Feedback

The LinePatternSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

LinePatternSet Class


IsEmpty Property

[image]

Revit 2011 API
LinePatternSet..::.IsEmpty Property
LinePatternSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LinePatternSet Class


Size Property

[image]

Revit 2011 API
LinePatternSet..::.Size Property
LinePatternSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LinePatternSet Class


LinePatternSetIterator Class

[image]

Revit 2011 API
LinePatternSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LinePatternSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LinePatternSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LinePatternSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.LinePatternSetIterator

See Also

LinePatternSetIterator Members


LinePatternSetIterator Members

[image] [image]

Revit 2011 API
LinePatternSetIterator Members
LinePatternSetIterator Class Constructors Methods Properties See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Constructors

Name | Description
LinePatternSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator Class


LinePatternSetIterator Constructor

[image]

Revit 2011 API
LinePatternSetIterator Constructor
LinePatternSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePatternSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinePatternSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LinePatternSetIterator Class


LinePatternSetIterator Methods

[image] [image]

Revit 2011 API
LinePatternSetIterator Methods
LinePatternSetIterator Class See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternSetIterator Class


MoveNext Method

[image]

Revit 2011 API
LinePatternSetIterator..::.MoveNext Method
LinePatternSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class


Reset Method

[image]

Revit 2011 API
LinePatternSetIterator..::.Reset Method
LinePatternSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LinePatternSetIterator Class


LinePatternSetIterator Properties

[image] [image]

Revit 2011 API
LinePatternSetIterator Properties
LinePatternSetIterator Class See Also Send Feedback

The LinePatternSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LinePatternSetIterator Class


Current Property

[image]

Revit 2011 API
LinePatternSetIterator..::.Current Property
LinePatternSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LinePatternSetIterator Class


LineScaling Enumeration

[image]

Revit 2011 API
LineScaling Enumeration
See Also Send Feedback
An enumerated type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum LineScaling
Visual Basic (Declaration)
Public Enumeration LineScaling
Visual C++
public enum class LineScaling

Members

Member name | Description
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.

Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also


LinkElementId Class

[image]

Revit 2011 API
LinkElementId Class
Members See Also Send Feedback
LinkElementId represents an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class LinkElementId
Visual Basic (Declaration)
Public Class LinkElementId
Visual C++
public ref class LinkElementId

Remarks

The id contains two element ids:
  1. The id of the linked model element in host document.
  2. The id of the element in the linked model document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.LinkElementId

See Also

LinkElementId Members


LinkElementId Members

[image] [image]

Revit 2011 API
LinkElementId Members
LinkElementId Class Constructors Methods Properties See Also Send Feedback

The LinkElementId type exposes the following members.

Constructors

Name | Description
LinkElementId | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ElementId | The id of the element in the linked model document.
LinkInstanceId | The id of the linked model element in the host document.

See Also

LinkElementId Class


LinkElementId Constructor

[image] [image]

Revit 2011 API
LinkElementId Constructor
LinkElementId Class See Also Send Feedback

Overload List

Name | Description
LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.

See Also

LinkElementId Class
LinkElementId Members


LinkElementId Constructor (ElementId)

[image]

Revit 2011 API
LinkElementId Constructor (ElementId)
LinkElementId Class See Also Send Feedback
Creates a new LinkElementId representing an element in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId elementId
)
Visual Basic (Declaration)
Public Sub New ( _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
The id of the element in the host document.

See Also

LinkElementId Class
LinkElementId Overload


LinkElementId Constructor (ElementId, ElementId)

[image]

Revit 2011 API
LinkElementId Constructor (ElementId, ElementId)
LinkElementId Class See Also Send Feedback
Creates a new LinkElementId representing an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId linkInstanceId,
    ElementId elementId
)
Visual Basic (Declaration)
Public Sub New ( _
    linkInstanceId As ElementId, _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ linkInstanceId,
    ElementId^ elementId
)

Parameters

linkInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The id of the linked model element in the host document.
elementId
Type: Autodesk.Revit.DB..::.ElementId
The id of the element in the linked model document.

See Also

LinkElementId Class
LinkElementId Overload


LinkElementId Methods

[image] [image]

Revit 2011 API
LinkElementId Methods
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkElementId Class


LinkElementId Properties

[image] [image]

Revit 2011 API
LinkElementId Properties
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Properties

Name | Description
ElementId | The id of the element in the linked model document.
LinkInstanceId | The id of the linked model element in the host document.

See Also

LinkElementId Class


ElementId Property

[image]

Revit 2011 API
LinkElementId..::.ElementId Property
LinkElementId Class See Also Send Feedback
The id of the element in the linked model document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ElementId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementId As ElementId
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkInstanceId Property

[image]

Revit 2011 API
LinkElementId..::.LinkInstanceId Property
LinkElementId Class See Also Send Feedback
The id of the linked model element in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId LinkInstanceId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkInstanceId As ElementId
Visual C++
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}

See Also

LinkElementId Class


Location Class

[image]

Revit 2011 API
Location Class
Members Example See Also Send Feedback
Provides location functionality for all elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Location : APIObject
Visual Basic (Declaration)
Public Class Location _
    Inherits APIObject
Visual C++
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Examples

CopyC#
void ShowLocationUsage(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.DB.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same fuction as Move method of Document class.
    XYZ direction = new XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same fuction as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = application.Create.NewLineUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
CopyVB.NET
Sub ShowLocationUsage(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.DB.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same fuction as Move method of Document class.
    Dim direction As New Autodesk.Revit.DB.XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same fuction as Rotate method of Document class.
    Dim axisStart As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim axisEnd As New Autodesk.Revit.DB.XYZ(0, 0, 1)
    Dim axis As Line = application.Create.NewLineUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.LocationCurve
Autodesk.Revit.DB..::.LocationPoint

See Also

Location Members


Location Members

[image] [image]

Revit 2011 API
Location Members
Location Class Methods Properties See Also Send Feedback

The Location type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector.
Rotate | Rotate the element within the project by a specified angle around a given axis.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


Location Methods

[image] [image]

Revit 2011 API
Location Methods
Location Class See Also Send Feedback

The Location type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector.
Rotate | Rotate the element within the project by a specified angle around a given axis.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Location Class


Move Method

[image]

Revit 2011 API
Location..::.Move Method
Location Class Example See Also Send Feedback
Move the element within the project by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic (Declaration)
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ translation
)

Parameters

translation
Type: Autodesk.Revit.DB..::.XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

Examples

CopyC#
bool MoveUsingLocationCurve(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
CopyVB.NET
Function MoveUsingLocationCurve(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

See Also

Location Class


Rotate Method

[image]

Revit 2011 API
Location..::.Rotate Method
Location Class Example See Also Send Feedback
Rotate the element within the project by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rotate(
    Line axis,
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Line^ axis,
    double angle
)

Parameters

axis
Type: Autodesk.Revit.DB..::.Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::.Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    // Rotate the element via its location curve.
    LocationCurve curve = element.Location as LocationCurve;
    if (null != curve)
    {
        Curve line = curve.Curve;
        XYZ aa = line.get_EndPoint(0);
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = curve.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Function LocationRotate(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    ' Rotate the element via its location curve.
    Dim curve As LocationCurve = TryCast(element.Location, LocationCurve)
    If curve IsNot Nothing Then
        Dim line As Curve = curve.Curve
        Dim aa As Autodesk.Revit.DB.XYZ = line.EndPoint(0)
        Dim cc As New Autodesk.Revit.DB.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = curve.Rotate(axis, Math.PI / 2)
    End If

    Return rotated
End Function

See Also

Location Class


Location Properties

[image] [image]

Revit 2011 API
Location Properties
Location Class See Also Send Feedback

The Location type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


LocationCurve Class

[image]

Revit 2011 API
LocationCurve Class
Members See Also Send Feedback
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LocationCurve : Location
Visual Basic (Declaration)
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.LocationCurve

See Also

LocationCurve Members


LocationCurve Members

[image] [image]

Revit 2011 API
LocationCurve Members
LocationCurve Class Methods Properties See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Provides the ability to get and set the curve of a curve based element.
ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


LocationCurve Methods

[image] [image]

Revit 2011 API
LocationCurve Methods
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationCurve Class


LocationCurve Properties

[image] [image]

Revit 2011 API
LocationCurve Properties
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Properties

Name | Description
Curve | Provides the ability to get and set the curve of a curve based element.
ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


Curve Property

[image]

Revit 2011 API
LocationCurve..::.Curve Property
LocationCurve Class Example See Also Send Feedback
Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; set; }
Visual Basic (Declaration)
Public Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

Examples

CopyC#
void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = application.Create.NewLineBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
CopyVB.NET
Sub MoveUsingCurveParam(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
    Dim p2 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Dim newWallLine As Line = application.Create.NewLineBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

See Also

LocationCurve Class


ElementsAtJoin Property

[image]

Revit 2011 API
LocationCurve..::.ElementsAtJoin Property
LocationCurve Class See Also Send Feedback
Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray ElementsAtJoin[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property ElementsAtJoin ( _
    end As Integer _
) As ElementArray
Visual C++
public:
property ElementArray^ ElementsAtJoin[int end] {
    ElementArray^ get (int end);
    void set (int end, ElementArray^ value);
}

Parameters

end
Type: System..::.Int32
The end at which the join occurs.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class


JoinType Property

[image]

Revit 2011 API
LocationCurve..::.JoinType Property
LocationCurve Class See Also Send Feedback
Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public JoinType JoinType[
    int end
] { get; set; }
Visual Basic (Declaration)
Public Property JoinType ( _
    end As Integer _
) As JoinType
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Type: System..::.Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
Autodesk.Revit.Exceptions..::.InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class


LocationPoint Class

[image]

Revit 2011 API
LocationPoint Class
Members Example See Also Send Feedback
Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LocationPoint : Location
Visual Basic (Declaration)
Public Class LocationPoint _
    Inherits Location
Visual C++
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point.

Examples

CopyC#
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    TaskDialog.Show("Revit",prompt);
}

bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Sub LocationInformation(ByVal position As LocationPoint)
    Dim prompt As [String] = "The selected column location information:"
    prompt += vbLf & "Point:  (" + position.Point.X + ", " + position.Point.Y + ", " + position.Point.Z + ")"
    prompt += vbLf & "Rotation: " + position.Rotation

    TaskDialog.Show("Revit", prompt)
End Sub

Function LocationRotate(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As Autodesk.Revit.DB.XYZ = location.Point
        Dim cc As New Autodesk.Revit.DB.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2)
    End If

    Return rotated
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Location
Autodesk.Revit.DB..::.LocationPoint

See Also

LocationPoint Members


LocationPoint Members

[image] [image]

Revit 2011 API
LocationPoint Members
LocationPoint Class Methods Properties See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Get and set the physical location of the element.
Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class


LocationPoint Methods

[image] [image]

Revit 2011 API
LocationPoint Methods
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Move | Move the element within the project by a specified vector. (Inherited from Location.)
Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationPoint Class


LocationPoint Properties

[image] [image]

Revit 2011 API
LocationPoint Properties
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Point | Get and set the physical location of the element.
Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class


Point Property

[image]

Revit 2011 API
LocationPoint..::.Point Property
LocationPoint Class Example See Also Send Feedback
Get and set the physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Point { get; set; }
Visual Basic (Declaration)
Public Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Sub LocationMove(ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New Autodesk.Revit.DB.XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class


Rotation Property

[image]

Revit 2011 API
LocationPoint..::.Rotation Property
LocationPoint Class See Also Send Feedback
Retrieve the angle of rotation around the insertion point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Rotation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rotation As Double
Visual C++
public:
property double Rotation {
    double get ();
}

See Also

LocationPoint Class


LogicalAndFilter Class

[image]

Revit 2011 API
LogicalAndFilter Class
Members Example See Also Send Feedback
A filter that contains a set of filters. The filter passes when all filters in the set pass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class LogicalAndFilter : ElementLogicalFilter
Visual Basic (Declaration)
Public Class LogicalAndFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalAndFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Examples

CopyC#
// Find all door instances in the project by finding all elements that both belong to the door
// category and are family instances.
ElementClassFilter familyInstanceFilter = new ElementClassFilter(typeof(FamilyInstance));

// Create a category filter for Doors
ElementCategoryFilter doorsCategoryfilter = new ElementCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
LogicalAndFilter doorInstancesFilter = new LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> doors = collector.WherePasses(doorInstancesFilter).ToElements();
CopyVB.NET
' Find all door instances in the project by finding all elements that both belong to the door
' category and are family instances.
Dim familyInstanceFilter As New ElementClassFilter(GetType(FamilyInstance))

' Create a category filter for Doors
Dim doorsCategoryfilter As New ElementCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As New LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim doors As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(doorInstancesFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.LogicalAndFilter

See Also

LogicalAndFilter Members


LogicalAndFilter Members

[image] [image]

Revit 2011 API
LogicalAndFilter Members
LogicalAndFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Constructors

Name | Description
LogicalAndFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalAndFilter Constructor

[image] [image]

Revit 2011 API
LogicalAndFilter Constructor
LogicalAndFilter Class See Also Send Feedback

Overload List

Name | Description
LogicalAndFilter(IList<(Of <(ElementFilter>)>)) | Constructs a new instance of the logical filter with any number of input filters.
LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalAndFilter Class
LogicalAndFilter Members


LogicalAndFilter Constructor (IList(ElementFilter))

[image]

Revit 2011 API
LogicalAndFilter Constructor (IList<(Of <(ElementFilter>)>))
LogicalAndFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LogicalAndFilter(
    IList<ElementFilter> filters
)
Visual Basic (Declaration)
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalAndFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::.IList <(Of <( ElementFilter >)>)
A collection of input filters.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter Constructor (ElementFilter, ElementFilter)

[image]

Revit 2011 API
LogicalAndFilter Constructor (ElementFilter, ElementFilter)
LogicalAndFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LogicalAndFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic (Declaration)
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalAndFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::.ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::.ElementFilter
The second filter.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter Methods

[image] [image]

Revit 2011 API
LogicalAndFilter Methods
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalAndFilter Class


LogicalAndFilter Properties

[image] [image]

Revit 2011 API
LogicalAndFilter Properties
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalOrFilter Class

[image]

Revit 2011 API
LogicalOrFilter Class
Members See Also Send Feedback
A filter that contains a set of filters. The filter passes when any filter in the set passes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class LogicalOrFilter : ElementLogicalFilter
Visual Basic (Declaration)
Public Class LogicalOrFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalOrFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementLogicalFilter
Autodesk.Revit.DB..::.LogicalOrFilter

See Also

LogicalOrFilter Members


LogicalOrFilter Members

[image] [image]

Revit 2011 API
LogicalOrFilter Members
LogicalOrFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Constructors

Name | Description
LogicalOrFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


LogicalOrFilter Constructor

[image] [image]

Revit 2011 API
LogicalOrFilter Constructor
LogicalOrFilter Class See Also Send Feedback

Overload List

Name | Description
LogicalOrFilter(IList<(Of <(ElementFilter>)>)) | Constructs a new instance of the logical filter with any number of input filters.
LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalOrFilter Class
LogicalOrFilter Members


LogicalOrFilter Constructor (IList(ElementFilter))

[image]

Revit 2011 API
LogicalOrFilter Constructor (IList<(Of <(ElementFilter>)>))
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LogicalOrFilter(
    IList<ElementFilter> filters
)
Visual Basic (Declaration)
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalOrFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::.IList <(Of <( ElementFilter >)>)
A collection of input filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Constructor (ElementFilter, ElementFilter)

[image]

Revit 2011 API
LogicalOrFilter Constructor (ElementFilter, ElementFilter)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public LogicalOrFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic (Declaration)
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalOrFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::.ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::.ElementFilter
The second filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Methods

[image] [image]

Revit 2011 API
LogicalOrFilter Methods
LogicalOrFilter Class See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalOrFilter Class


LogicalOrFilter Properties

[image] [image]

Revit 2011 API
LogicalOrFilter Properties
LogicalOrFilter Class See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


MarginType Enumeration

[image]

Revit 2011 API
MarginType Enumeration
See Also Send Feedback
An enumerated type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum MarginType
Visual Basic (Declaration)
Public Enumeration MarginType
Visual C++
public enum class MarginType

Members

Member name | Description
NoMargin | The type of Margin is No Margin.
PrinterLimit | The type of Margin is Printer Limit.
UserDefined | The type of Margin is User Defined .

See Also


MassDisplayTemporaryOverrideType Enumeration

[image]

Revit 2011 API
MassDisplayTemporaryOverrideType Enumeration
See Also Send Feedback
This enum identifies the mass display overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassDisplayTemporaryOverrideType
Visual Basic (Declaration)
Public Enumeration MassDisplayTemporaryOverrideType
Visual C++
public enum class MassDisplayTemporaryOverrideType

Members

Member name | Description
ShowMassByViewSettings | Mass will be displayed in each view based on the visibility settings of that view.
ShowMassFormAndFloors | Mass form and mass floor subcategories will be displayed in all views.
ShowMassSurfaceTypes | Mass energy analysis surface subcategories (and Mass Floors) will be displayed.
ShowMassZonesAndShades | Mass zone and mass shade subcategories will be displayed.

See Also


MassInstanceUtils Class

[image]

Revit 2011 API
MassInstanceUtils Class
Members See Also Send Feedback
A static class that contains extra methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassInstanceUtils : IDisposable
Visual Basic (Declaration)
Public Class MassInstanceUtils _
    Implements IDisposable
Visual C++
public ref class MassInstanceUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.MassInstanceUtils

See Also

MassInstanceUtils Members


MassInstanceUtils Members

[image] [image]

Revit 2011 API
MassInstanceUtils Members
MassInstanceUtils Class Methods See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

Name | Description
AddMassLevelDataToMassInstance | Create a MassLevelData to associate a Level with a mass instance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
GetGrossVolume | Get the total building volume represented by a mass instance.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas associated with a mass instance.
GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveMassLevelDataFromMassInstance | Delete the MassLevelData that associates a Level with a mass instance.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassInstanceUtils Class


MassInstanceUtils Methods

[image] [image]

Revit 2011 API
MassInstanceUtils Methods
MassInstanceUtils Class See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

Name | Description
AddMassLevelDataToMassInstance | Create a MassLevelData to associate a Level with a mass instance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
GetGrossVolume | Get the total building volume represented by a mass instance.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas associated with a mass instance.
GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveMassLevelDataFromMassInstance | Delete the MassLevelData that associates a Level with a mass instance.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassInstanceUtils Class


AddMassLevelDataToMassInstance Method

[image]

Revit 2011 API
MassInstanceUtils..::.AddMassLevelDataToMassInstance Method
MassInstanceUtils Class See Also Send Feedback
Create a MassLevelData to associate a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId AddMassLevelDataToMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Function AddMassLevelDataToMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ AddMassLevelDataToMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Level to associate with the mass instance.

Return Value

The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


Dispose Method

[image]

Revit 2011 API
MassInstanceUtils..::.Dispose Method
MassInstanceUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

MassInstanceUtils Class


GetGrossFloorArea Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetGrossFloorArea Method
MassInstanceUtils Class See Also Send Feedback
Get the total occupiable floor area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static double GetGrossFloorArea(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetGrossFloorArea ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossFloorArea(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The gross floor area in square feet.

Remarks

The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetGrossSurfaceArea Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetGrossSurfaceArea Method
MassInstanceUtils Class See Also Send Feedback
Get the total exterior building surface area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static double GetGrossSurfaceArea(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetGrossSurfaceArea ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossSurfaceArea(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The gross surface area in square feet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetGrossVolume Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetGrossVolume Method
MassInstanceUtils Class See Also Send Feedback
Get the total building volume represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static double GetGrossVolume(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetGrossVolume ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossVolume(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The gross volume in cubic feet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetJoinedElementIds Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetJoinedElementIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of Elements that are joined to a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetJoinedElementIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetJoinedElementIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetJoinedElementIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

ElementIds of Elements joined to the mass instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetMassLevelDataIds Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetMassLevelDataIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the MassLevelDatas associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetMassLevelDataIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetMassLevelDataIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelDataIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the MassLevelDatas.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetMassLevelIds Method

[image]

Revit 2011 API
MassInstanceUtils..::.GetMassLevelIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the Levels associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetMassLevelIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetMassLevelIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the Levels

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


RemoveMassLevelDataFromMassInstance Method

[image]

Revit 2011 API
MassInstanceUtils..::.RemoveMassLevelDataFromMassInstance Method
MassInstanceUtils Class See Also Send Feedback
Delete the MassLevelData that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static void RemoveMassLevelDataFromMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Sub RemoveMassLevelDataFromMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
static void RemoveMassLevelDataFromMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Level to disassociate from the mass instance.

Remarks

Alternatively, you could just delete the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


Material Class

[image]

Revit 2011 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class Material : Element
Visual Basic (Declaration)
Public MustInherit Class Material _
    Inherits Element
Visual C++
public ref class Material abstract : public Element

Remarks

This is the abstract parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
    StringBuilder message = new StringBuilder("Material : " + material.Name);
    //color of the material
    message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                    material.Color.Red, material.Color.Green, material.Color.Blue));

    //cut pattern and pattern color of the material
    if (null != material.CutPattern)
    {
        message.Append("\nCut Pattern: " + material.CutPattern.Name);
        message.Append(string.Format("\nCut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue));
    }

    //surface pattern and pattern color of the material
    if (null != material.SurfacePattern)
    {
        message.Append("\nSurface Pattern: " + material.SurfacePattern.Name);
        message.Append(string.Format("\nSurface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue));
    }

    //some shading property of the material
    bool glow = material.Glow;
    message.Append("\nMaterial can glow: " + glow);
    int shininess = material.Shininess;
    message.Append("\nShininess: " + shininess);
    int smoothness = material.Smoothness;
    message.Append("\nSmoothness: " + smoothness);
    int transparency = material.Transparency;
    message.Append("\nTransparency: " + transparency);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub GetMaterialInformation(ByVal material As Autodesk.Revit.DB.Material)
    Dim message As New StringBuilder("Material : " + material.Name)
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'cut pattern and pattern color of the material
    If material.CutPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Pattern: " + material.CutPattern.Name)
        message.Append(String.Format(vbLf & "Cut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue))
    End If

    'surface pattern and pattern color of the material
    If material.SurfacePattern IsNot Nothing Then
        message.Append(vbLf & "Surface Pattern: " + material.SurfacePattern.Name)
        message.Append(String.Format(vbLf & "Surface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue))
    End If

    'some shading property of the material
    Dim glow As Boolean = material.Glow
    message.Append(vbLf & "Material can glow: " + glow)
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " + shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " + smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " + transparency)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialConcrete
Autodesk.Revit.DB..::.MaterialGeneric
Autodesk.Revit.DB..::.MaterialOther
Autodesk.Revit.DB..::.MaterialSteel
Autodesk.Revit.DB..::.MaterialWood

See Also

Material Members


Material Members

[image] [image]

Revit 2011 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicates the material.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material.
CutPattern | The cut pattern of the material.
CutPatternColor | The cut pattern color of the material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material.
Shininess | The shininess of the material.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material.
SurfacePattern | The surface pattern of the material.
SurfacePatternColor | The surface pattern color of the material.
Transparency | The transparency of the material.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Material Class


Material Methods

[image] [image]

Revit 2011 API
Material Methods
Material Class See Also Send Feedback

The Material type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicates the material.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Material Class


Duplicate Method

[image]

Revit 2011 API
Material..::.Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public MustOverride Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) abstract

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
    bool duplicated = false;
    //try to duplicate a new instance of Material class using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + material.Name;
    Material myMaterial = material.Duplicate(newName);
    if (null == myMaterial)
    {
        TaskDialog.Show("Revit","Failed to duplicate a material!");
    }
    else
    {
        duplicated = true;
    }

    return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(ByVal material As Autodesk.Revit.DB.Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" + material.Name
    Dim myMaterial As Autodesk.Revit.DB.Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

See Also

Material Class


Material Properties

[image] [image]

Revit 2011 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material.
CutPattern | The cut pattern of the material.
CutPatternColor | The cut pattern color of the material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material.
Shininess | The shininess of the material.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material.
SurfacePattern | The surface pattern of the material.
SurfacePatternColor | The surface pattern color of the material.
Transparency | The transparency of the material.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Material Class


Color Property

[image]

Revit 2011 API
Material..::.Color Property
Material Class See Also Send Feedback
The color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

Material Class


CutPattern Property

[image]

Revit 2011 API
Material..::.CutPattern Property
Material Class See Also Send Feedback
The cut pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPattern CutPattern { get; set; }
Visual Basic (Declaration)
Public Property CutPattern As FillPattern
Visual C++
public:
property FillPattern^ CutPattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The cut pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated cut pattern.

See Also

Material Class


CutPatternColor Property

[image]

Revit 2011 API
Material..::.CutPatternColor Property
Material Class See Also Send Feedback
The cut pattern color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color CutPatternColor { get; set; }
Visual Basic (Declaration)
Public Property CutPatternColor As Color
Visual C++
public:
property Color^ CutPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the cut pattern color for this material.

See Also

Material Class


Glow Property

[image]

Revit 2011 API
Material..::.Glow Property
Material Class See Also Send Feedback
Whether the material can glow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Glow { get; set; }
Visual Basic (Declaration)
Public Property Glow As Boolean
Visual C++
public:
property bool Glow {
    bool get ();
    void set (bool value);
}

Field Value

True if the material can glow, false if it cannot.

Remarks

This value is obsolete in Autodesk Revit 2009 due to a similar change in the UI.

See Also

Material Class


Parameter Property

[image] [image]

Revit 2011 API
Material..::.Parameter Property
Material Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Material Class
Material Members


RenderAppearance Property

[image]

Revit 2011 API
Material..::.RenderAppearance Property
Material Class See Also Send Feedback
The rendering appearance property of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Asset RenderAppearance { get; set; }
Visual Basic (Declaration)
Public Property RenderAppearance As Asset
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or nullNothingnullptra null reference (Nothing in Visual Basic), if the render library isn't available.

See Also

Material Class


Shininess Property

[image]

Revit 2011 API
Material..::.Shininess Property
Material Class See Also Send Feedback
The shininess of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Shininess { get; set; }
Visual Basic (Declaration)
Public Property Shininess As Integer
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class


Smoothness Property

[image]

Revit 2011 API
Material..::.Smoothness Property
Material Class See Also Send Feedback
The smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Smoothness { get; set; }
Visual Basic (Declaration)
Public Property Smoothness As Integer
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class


SurfacePattern Property

[image]

Revit 2011 API
Material..::.SurfacePattern Property
Material Class See Also Send Feedback
The surface pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPattern SurfacePattern { get; set; }
Visual Basic (Declaration)
Public Property SurfacePattern As FillPattern
Visual C++
public:
property FillPattern^ SurfacePattern {
    FillPattern^ get ();
    void set (FillPattern^ value);
}

Field Value

The surface pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated surface pattern.

See Also

Material Class


SurfacePatternColor Property

[image]

Revit 2011 API
Material..::.SurfacePatternColor Property
Material Class See Also Send Feedback
The surface pattern color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color SurfacePatternColor { get; set; }
Visual Basic (Declaration)
Public Property SurfacePatternColor As Color
Visual C++
public:
property Color^ SurfacePatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the surface pattern color for this material

See Also

Material Class


Transparency Property

[image]

Revit 2011 API
Material..::.Transparency Property
Material Class See Also Send Feedback
The transparency of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Transparency { get; set; }
Visual Basic (Declaration)
Public Property Transparency As Integer
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class


MaterialBehaviourType Enumeration

[image]

Revit 2011 API
MaterialBehaviourType Enumeration
See Also Send Feedback
An enumerated type listing all the material behavior type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum MaterialBehaviourType
Visual Basic (Declaration)
Public Enumeration MaterialBehaviourType
Visual C++
public enum class MaterialBehaviourType

Members

Member name | Description
Isotropic | Isotropic material
Orthotropic | Orthotropic material
Undefined | Undefined material

See Also


MaterialConcrete Class

[image]

Revit 2011 API
MaterialConcrete Class
Members Example See Also Send Feedback
Represents a concrete material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialConcrete : Material
Visual Basic (Declaration)
Public Class MaterialConcrete _
    Inherits Material
Visual C++
public ref class MaterialConcrete : public Material

Remarks

MaterialConcrete is a child class of Material.

Examples

CopyC#
private void MaterialConcreteInformation(MaterialConcrete myConcrete)
{
    StringBuilder message = new StringBuilder("Material Concrete : " + myConcrete.Name);

    //behaviour of the material
    MaterialBehaviourType behaviour = myConcrete.Behavior;
    message.Append("Behavior: " + behaviour);
    double compression = myConcrete.ConcreteCompression;
    message.Append("Concrete Compression: " + compression);
    double dampingRatio = myConcrete.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    bool lightWeight = myConcrete.LightWeight;
    string weight = lightWeight == true ? "Yes" : "No";
    message.Append("Lightweight: " + weight);

    double poissonModulusX = myConcrete.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myConcrete.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myConcrete.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double shearModulusX = myConcrete.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myConcrete.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myConcrete.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);
    double shearStrengthReduction = myConcrete.ShearStrengthReduction;
    message.Append("Shear strength modification: " + shearStrengthReduction);

    double thermalExpansionCoefficientX = myConcrete.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myConcrete.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myConcrete.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myConcrete.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myConcrete.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myConcrete.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myConcrete.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialConcreteInformation(ByVal myConcrete As MaterialConcrete)
    Dim message As New StringBuilder("Material Concrete : " + myConcrete.Name)

    'behaviour of the material
    Dim behaviour As MaterialBehaviourType = myConcrete.Behavior
    message.Append("Behavior: " + behaviour)
    Dim compression As Double = myConcrete.ConcreteCompression
    message.Append("Concrete Compression: " + compression)
    Dim dampingRatio As Double = myConcrete.DampingRatio
    message.Append("Damping Ratio: " + dampingRatio)
    Dim lightWeight As Boolean = myConcrete.LightWeight
    Dim weight As String = If(lightWeight = True, "Yes", "No")
    message.Append("Lightweight: " + weight)

    Dim poissonModulusX As Double = myConcrete.PoissonModulusX
    message.Append("Poisson Ratio X: " + poissonModulusX)
    Dim poissonModulusY As Double = myConcrete.PoissonModulusY
    message.Append("Poisson Ratio Y: " + poissonModulusY)
    Dim poissonModulusZ As Double = myConcrete.PoissonModulusZ
    message.Append("Poisson Ratio Z: " + poissonModulusZ)

    Dim shearModulusX As Double = myConcrete.ShearModulusX
    message.Append("Shear modulus X: " + shearModulusX)
    Dim shearModulusY As Double = myConcrete.ShearModulusY
    message.Append("Shear modulus Y: " + shearModulusY)
    Dim shearModulusZ As Double = myConcrete.ShearModulusZ
    message.Append("Shear modulus Z: " + shearModulusZ)
    Dim shearStrengthReduction As Double = myConcrete.ShearStrengthReduction
    message.Append("Shear strength modification: " + shearStrengthReduction)

    Dim thermalExpansionCoefficientX As Double = myConcrete.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myConcrete.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myConcrete.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myConcrete.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulusX As Double = myConcrete.YoungModulusX
    message.Append("Young modulus X: " + youngModulusX)
    Dim youngModulusY As Double = myConcrete.YoungModulusY
    message.Append("Young modulus Y: " + youngModulusY)
    Dim youngModulusZ As Double = myConcrete.YoungModulusZ
    message.Append("Young modulus Z: " + youngModulusZ)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialConcrete

See Also

MaterialConcrete Members


MaterialConcrete Members

[image] [image]

Revit 2011 API
MaterialConcrete Members
MaterialConcrete Class Methods Properties See Also Send Feedback

The MaterialConcrete type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this concrete material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the concrete material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
ConcreteCompression | Get or set the concrete compression of the concrete material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the concrete material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightWeight | Get or set whether the concrete material is lightweight.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the concrete material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete Class


MaterialConcrete Methods

[image] [image]

Revit 2011 API
MaterialConcrete Methods
MaterialConcrete Class See Also Send Feedback

The MaterialConcrete type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this concrete material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialConcrete Class


Duplicate Method

[image]

Revit 2011 API
MaterialConcrete..::.Duplicate Method
MaterialConcrete Class See Also Send Feedback
Duplicate this concrete material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialConcrete Class


MaterialConcrete Properties

[image] [image]

Revit 2011 API
MaterialConcrete Properties
MaterialConcrete Class See Also Send Feedback

The MaterialConcrete type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the concrete material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
ConcreteCompression | Get or set the concrete compression of the concrete material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the concrete material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightWeight | Get or set whether the concrete material is lightweight.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the concrete material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the concrete material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the concrete material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the concrete material.
ShearModulusY | Get or set the y component of the shear modulus of the concrete material.
ShearModulusZ | Get or set the z component of the shear modulus of the concrete material.
ShearStrengthReduction | Get or set the shear strength reduction of the concrete material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the concrete material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the concrete material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the concrete material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the concrete material.
YoungModulusY | Get or set the y component of the Young modulus of the concrete material.
YoungModulusZ | Get or set the z component of the Young modulus of the concrete material.

See Also

MaterialConcrete Class


Behavior Property

[image]

Revit 2011 API
MaterialConcrete..::.Behavior Property
MaterialConcrete Class See Also Send Feedback
Get or set the material behavior type of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialConcrete Class


ConcreteCompression Property

[image]

Revit 2011 API
MaterialConcrete..::.ConcreteCompression Property
MaterialConcrete Class See Also Send Feedback
Get or set the concrete compression of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ConcreteCompression { get; set; }
Visual Basic (Declaration)
Public Property ConcreteCompression As Double
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set the concrete compression to an invalid value.

See Also

MaterialConcrete Class


DampingRatio Property

[image]

Revit 2011 API
MaterialConcrete..::.DampingRatio Property
MaterialConcrete Class See Also Send Feedback
Get or set the damping ratio of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialConcrete Class


LightWeight Property

[image]

Revit 2011 API
MaterialConcrete..::.LightWeight Property
MaterialConcrete Class See Also Send Feedback
Get or set whether the concrete material is lightweight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool LightWeight { get; set; }
Visual Basic (Declaration)
Public Property LightWeight As Boolean
Visual C++
public:
property bool LightWeight {
    bool get ();
    void set (bool value);
}

See Also

MaterialConcrete Class


Parameter Property

[image] [image]

Revit 2011 API
MaterialConcrete..::.Parameter Property
MaterialConcrete Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialConcrete Class
MaterialConcrete Members


PoissonModulusX Property

[image]

Revit 2011 API
MaterialConcrete..::.PoissonModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class


PoissonModulusY Property

[image]

Revit 2011 API
MaterialConcrete..::.PoissonModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


PoissonModulusZ Property

[image]

Revit 2011 API
MaterialConcrete..::.PoissonModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


ShearModulusX Property

[image]

Revit 2011 API
MaterialConcrete..::.ShearModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class


ShearModulusY Property

[image]

Revit 2011 API
MaterialConcrete..::.ShearModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


ShearModulusZ Property

[image]

Revit 2011 API
MaterialConcrete..::.ShearModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the shear modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


ShearStrengthReduction Property

[image]

Revit 2011 API
MaterialConcrete..::.ShearStrengthReduction Property
MaterialConcrete Class See Also Send Feedback
Get or set the shear strength reduction of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearStrengthReduction { get; set; }
Visual Basic (Declaration)
Public Property ShearStrengthReduction As Double
Visual C++
public:
property double ShearStrengthReduction {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the shear strength reduction to an invalid value. InvalidOperationException will be thrown if lightweight is false

See Also

MaterialConcrete Class


ThermalExpansionCoefficientX Property

[image]

Revit 2011 API
MaterialConcrete..::.ThermalExpansionCoefficientX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class


ThermalExpansionCoefficientY Property

[image]

Revit 2011 API
MaterialConcrete..::.ThermalExpansionCoefficientY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


ThermalExpansionCoefficientZ Property

[image]

Revit 2011 API
MaterialConcrete..::.ThermalExpansionCoefficientZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


UnitWeight Property

[image]

Revit 2011 API
MaterialConcrete..::.UnitWeight Property
MaterialConcrete Class See Also Send Feedback
Get or set the unit weight of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialConcrete Class


YoungModulusX Property

[image]

Revit 2011 API
MaterialConcrete..::.YoungModulusX Property
MaterialConcrete Class See Also Send Feedback
Get or set the x component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialConcrete Class


YoungModulusY Property

[image]

Revit 2011 API
MaterialConcrete..::.YoungModulusY Property
MaterialConcrete Class See Also Send Feedback
Get or set the y component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


YoungModulusZ Property

[image]

Revit 2011 API
MaterialConcrete..::.YoungModulusZ Property
MaterialConcrete Class See Also Send Feedback
Get or set the z component of the Young modulus of the concrete material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialConcrete Class


MaterialGeneric Class

[image]

Revit 2011 API
MaterialGeneric Class
Members Example See Also Send Feedback
Represents a generic material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialGeneric : Material
Visual Basic (Declaration)
Public Class MaterialGeneric _
    Inherits Material
Visual C++
public ref class MaterialGeneric : public Material

Remarks

MaterialGeneric is a child class of Material.

Examples

CopyC#
private void MaterialGenericInformation(MaterialGeneric myGeneric)
{
    StringBuilder message = new StringBuilder("Material Generic : " + myGeneric.Name);

    //behaviour of the material
    MaterialBehaviourType behaviour = myGeneric.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = myGeneric.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumYieldStress = myGeneric.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = myGeneric.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = myGeneric.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = myGeneric.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = myGeneric.ReductionFactor;
    message.Append("Reduction factor for shear: " + reductionFactor);

    double shearModulusX = myGeneric.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = myGeneric.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = myGeneric.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = myGeneric.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = myGeneric.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = myGeneric.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = myGeneric.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = myGeneric.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = myGeneric.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = myGeneric.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialGenericInformation(ByVal myGeneric As MaterialGeneric)
    Dim message As New StringBuilder("Material Generic : " + myGeneric.Name)

    'behaviour of the material
    Dim behaviour As MaterialBehaviourType = myGeneric.Behavior
    message.Append("Behavior: " + behaviour)
    Dim dampingRatio As Double = myGeneric.DampingRatio
    message.Append("Damping Ratio: " + dampingRatio)
    Dim minimumYieldStress As Double = myGeneric.MinimumYieldStress
    message.Append("Minimum yield stress: " + minimumYieldStress)

    Dim poissonModulusX As Double = myGeneric.PoissonModulusX
    message.Append("Poisson Ratio X: " + poissonModulusX)
    Dim poissonModulusY As Double = myGeneric.PoissonModulusY
    message.Append("Poisson Ratio Y: " + poissonModulusY)
    Dim poissonModulusZ As Double = myGeneric.PoissonModulusZ
    message.Append("Poisson Ratio Z: " + poissonModulusZ)

    Dim reductionFactor As Double = myGeneric.ReductionFactor
    message.Append("Reduction factor for shear: " + reductionFactor)

    Dim shearModulusX As Double = myGeneric.ShearModulusX
    message.Append("Shear modulus X: " + shearModulusX)
    Dim shearModulusY As Double = myGeneric.ShearModulusY
    message.Append("Shear modulus Y: " + shearModulusY)
    Dim shearModulusZ As Double = myGeneric.ShearModulusZ
    message.Append("Shear modulus Z: " + shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = myGeneric.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = myGeneric.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = myGeneric.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ)

    Dim unitWeight As Double = myGeneric.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulusX As Double = myGeneric.YoungModulusX
    message.Append("Young modulus X: " + youngModulusX)
    Dim youngModulusY As Double = myGeneric.YoungModulusY
    message.Append("Young modulus Y: " + youngModulusY)
    Dim youngModulusZ As Double = myGeneric.YoungModulusZ
    message.Append("Young modulus Z: " + youngModulusZ)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialGeneric

See Also

MaterialGeneric Members


MaterialGeneric Members

[image] [image]

Revit 2011 API
MaterialGeneric Members
MaterialGeneric Class Methods Properties See Also Send Feedback

The MaterialGeneric type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this generic material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the generic material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the generic material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class


MaterialGeneric Methods

[image] [image]

Revit 2011 API
MaterialGeneric Methods
MaterialGeneric Class See Also Send Feedback

The MaterialGeneric type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this generic material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialGeneric Class


Duplicate Method

[image]

Revit 2011 API
MaterialGeneric..::.Duplicate Method
MaterialGeneric Class See Also Send Feedback
Duplicate this generic material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialGeneric Class


MaterialGeneric Properties

[image] [image]

Revit 2011 API
MaterialGeneric Properties
MaterialGeneric Class See Also Send Feedback

The MaterialGeneric type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the generic material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the generic material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumYieldStress | Get or set the minimum yield stress of the generic material.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the generic material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the generic material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the generic material.
ReductionFactor | Get or set the reduction factor for shear of the generic material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the generic material.
ShearModulusY | Get or set the y component of the shear modulus of the generic material.
ShearModulusZ | Get or set the z component of the shear modulus of the generic material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the generic material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the generic material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the generic material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the generic material.
YoungModulusY | Get or set the y component of the Young modulus of the generic material.
YoungModulusZ | Get or set the z component of the Young modulus of the generic material.

See Also

MaterialGeneric Class


Behavior Property

[image]

Revit 2011 API
MaterialGeneric..::.Behavior Property
MaterialGeneric Class See Also Send Feedback
Get or set the material behavior type of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialGeneric Class


DampingRatio Property

[image]

Revit 2011 API
MaterialGeneric..::.DampingRatio Property
MaterialGeneric Class See Also Send Feedback
Get or set the damping ratio of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialGeneric Class


MinimumYieldStress Property

[image]

Revit 2011 API
MaterialGeneric..::.MinimumYieldStress Property
MaterialGeneric Class See Also Send Feedback
Get or set the minimum yield stress of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum yield stress to an invalid value.

See Also

MaterialGeneric Class


Parameter Property

[image] [image]

Revit 2011 API
MaterialGeneric..::.Parameter Property
MaterialGeneric Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialGeneric Class
MaterialGeneric Members


PoissonModulusX Property

[image]

Revit 2011 API
MaterialGeneric..::.PoissonModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class


PoissonModulusY Property

[image]

Revit 2011 API
MaterialGeneric..::.PoissonModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


PoissonModulusZ Property

[image]

Revit 2011 API
MaterialGeneric..::.PoissonModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


ReductionFactor Property

[image]

Revit 2011 API
MaterialGeneric..::.ReductionFactor Property
MaterialGeneric Class See Also Send Feedback
Get or set the reduction factor for shear of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid value.

See Also

MaterialGeneric Class


ShearModulusX Property

[image]

Revit 2011 API
MaterialGeneric..::.ShearModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class


ShearModulusY Property

[image]

Revit 2011 API
MaterialGeneric..::.ShearModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


ShearModulusZ Property

[image]

Revit 2011 API
MaterialGeneric..::.ShearModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the shear modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


ThermalExpansionCoefficientX Property

[image]

Revit 2011 API
MaterialGeneric..::.ThermalExpansionCoefficientX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class


ThermalExpansionCoefficientY Property

[image]

Revit 2011 API
MaterialGeneric..::.ThermalExpansionCoefficientY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


ThermalExpansionCoefficientZ Property

[image]

Revit 2011 API
MaterialGeneric..::.ThermalExpansionCoefficientZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


UnitWeight Property

[image]

Revit 2011 API
MaterialGeneric..::.UnitWeight Property
MaterialGeneric Class See Also Send Feedback
Get or set the unit weight of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialGeneric Class


YoungModulusX Property

[image]

Revit 2011 API
MaterialGeneric..::.YoungModulusX Property
MaterialGeneric Class See Also Send Feedback
Get or set the x component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialGeneric Class


YoungModulusY Property

[image]

Revit 2011 API
MaterialGeneric..::.YoungModulusY Property
MaterialGeneric Class See Also Send Feedback
Get or set the y component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


YoungModulusZ Property

[image]

Revit 2011 API
MaterialGeneric..::.YoungModulusZ Property
MaterialGeneric Class See Also Send Feedback
Get or set the z component of the Young modulus of the generic material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialGeneric Class


MaterialOther Class

[image]

Revit 2011 API
MaterialOther Class
Members See Also Send Feedback
Represents a material element other than concrete, generic, wood and steel in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialOther : Material
Visual Basic (Declaration)
Public Class MaterialOther _
    Inherits Material
Visual C++
public ref class MaterialOther : public Material

Remarks

MaterialOther is a child class of Material.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialOther

See Also

MaterialOther Members


MaterialOther Members

[image] [image]

Revit 2011 API
MaterialOther Members
MaterialOther Class Methods Properties See Also Send Feedback

The MaterialOther type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this other material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MaterialOther Class


MaterialOther Methods

[image] [image]

Revit 2011 API
MaterialOther Methods
MaterialOther Class See Also Send Feedback

The MaterialOther type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this other material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialOther Class


Duplicate Method

[image]

Revit 2011 API
MaterialOther..::.Duplicate Method
MaterialOther Class See Also Send Feedback
Duplicate this other material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialOther Class


MaterialOther Properties

[image] [image]

Revit 2011 API
MaterialOther Properties
MaterialOther Class See Also Send Feedback

The MaterialOther type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MaterialOther Class


Parameter Property

[image] [image]

Revit 2011 API
MaterialOther..::.Parameter Property
MaterialOther Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialOther Class
MaterialOther Members


Materials Class

[image]

Revit 2011 API
Materials Class
Members See Also Send Feedback
A set of materials that provides access to the materials in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Materials : MaterialSet
Visual Basic (Declaration)
Public Class Materials _
    Inherits MaterialSet
Visual C++
public ref class Materials : public MaterialSet

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MaterialSet
Autodesk.Revit.DB..::.Materials

See Also

Materials Members


Materials Members

[image] [image]

Revit 2011 API
Materials Members
Materials Class Methods Properties See Also Send Feedback

The Materials type exposes the following members.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | (Inherited from MaterialSet.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | (Inherited from MaterialSet.)
Remove | Remove the material with the specified name .
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets the material with the specified identifier.
Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials Class


Materials Methods

[image] [image]

Revit 2011 API
Materials Methods
Materials Class See Also Send Feedback

The Materials type exposes the following members.

Methods

Name | Description
AddConcrete | Add a concrete material with the given name .
AddGeneric | Add a generic material with the given name .
AddOther | Add an other material with the given name .
AddSteel | Add a steel material with the given name .
AddWood | Add a wood material with the given name .
Clear | Removes every material from the set, rendering it empty. (Inherited from MaterialSet.)
Contains | Overloaded. Checks if the material set contains the material with the specified identifier.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | (Inherited from MaterialSet.)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from MaterialSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | (Inherited from MaterialSet.)
Remove | Remove the material with the specified name .
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from MaterialSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Materials Class


AddConcrete Method

[image]

Revit 2011 API
Materials..::.AddConcrete Method
Materials Class Example See Also Send Feedback
Add a concrete material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialConcrete AddConcrete(
    string name
)
Visual Basic (Declaration)
Public Function AddConcrete ( _
    name As String _
) As MaterialConcrete
Visual C++
public:
MaterialConcrete^ AddConcrete(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the concrete material to be added.

Return Value

The pointer to the added concrete material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialConcrete AddConcrete(Document document)
{
    string newName = "myConcreteMaterial";
    MaterialConcrete myConcrete = document.Settings.Materials.AddConcrete(newName);

    if (document.Settings.Materials.Contains(newName) == true)
    {
        TaskDialog.Show("Revit","Concrete material added successfully!");
    }

    return myConcrete;
}
CopyVB.NET
Private Function AddConcrete(ByVal document As Document) As MaterialConcrete
    Dim newName As String = "myConcreteMaterial"
    Dim myConcrete As MaterialConcrete = document.Settings.Materials.AddConcrete(newName)

    If document.Settings.Materials.Contains(newName) = True Then
        TaskDialog.Show("Revit", "Concrete material added successfully!")
    End If

    Return myConcrete
End Function

See Also

Materials Class


AddGeneric Method

[image]

Revit 2011 API
Materials..::.AddGeneric Method
Materials Class Example See Also Send Feedback
Add a generic material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialGeneric AddGeneric(
    string name
)
Visual Basic (Declaration)
Public Function AddGeneric ( _
    name As String _
) As MaterialGeneric
Visual C++
public:
MaterialGeneric^ AddGeneric(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the generic material to be added.

Return Value

The pointer to the added generic material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialGeneric AddGeneric(Document document)
{
    string newName = "myGenericMaterial";
    MaterialGeneric myGeneric = document.Settings.Materials.AddGeneric(newName);

    if (null != myGeneric)
    {
        TaskDialog.Show("Revit","Generic material added successfully!");
    }

    return myGeneric;
}
CopyVB.NET
Private Function AddGeneric(ByVal document As Document) As MaterialGeneric
    Dim newName As String = "myGenericMaterial"
    Dim myGeneric As MaterialGeneric = document.Settings.Materials.AddGeneric(newName)

    If myGeneric IsNot Nothing Then
        TaskDialog.Show("Revit", "Generic material added successfully!")
    End If

    Return myGeneric
End Function

See Also

Materials Class


AddOther Method

[image]

Revit 2011 API
Materials..::.AddOther Method
Materials Class Example See Also Send Feedback
Add an other material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialOther AddOther(
    string name
)
Visual Basic (Declaration)
Public Function AddOther ( _
    name As String _
) As MaterialOther
Visual C++
public:
MaterialOther^ AddOther(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the other material to be added.

Return Value

The pointer to the added other material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private bool CreateOtherMaterial(Autodesk.Revit.DB.Document document)
{
    string oldName = "myOtherMaterial";
    MaterialOther myOther = document.Settings.Materials.AddOther(oldName);
    if (null == myOther)
    {
        return false;
    }

    //try to duplicate a new instance using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + myOther.Name;
    MaterialOther newOther = myOther.Duplicate(newName) as MaterialOther;
    if (null == newOther)
    {
        TaskDialog.Show("Revit","Failed to duplicate an other material!");
        return false;
    }
    else
    {
        TaskDialog.Show("Revit","Duplicated other material.");
    }

    // Remove the original created material
    document.Settings.Materials.Remove(oldName);

    if (document.Settings.Materials.Contains(oldName) == false)
    {
        TaskDialog.Show("Revit","Material (myOtherMaterial) removed successfully!");
    }

    return true;
}
CopyVB.NET
Private Function CreateOtherMaterial(ByVal document As Autodesk.Revit.DB.Document) As Boolean
    Dim oldName As String = "myOtherMaterial"
    Dim myOther As MaterialOther = document.Settings.Materials.AddOther(oldName)
    If myOther Is Nothing Then
        Return False
    End If

    'try to duplicate a new instance using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" + myOther.Name
    Dim newOther As MaterialOther = TryCast(myOther.Duplicate(newName), MaterialOther)
    If newOther Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate an other material!")
        Return False
    Else
        TaskDialog.Show("Revit", "Duplicated other material.")
    End If

    ' Remove the original created material
    document.Settings.Materials.Remove(oldName)

    If document.Settings.Materials.Contains(oldName) = False Then
        TaskDialog.Show("Revit", "Material (myOtherMaterial) removed successfully!")
    End If

    Return True
End Function

See Also

Materials Class


AddSteel Method

[image]

Revit 2011 API
Materials..::.AddSteel Method
Materials Class Example See Also Send Feedback
Add a steel material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialSteel AddSteel(
    string name
)
Visual Basic (Declaration)
Public Function AddSteel ( _
    name As String _
) As MaterialSteel
Visual C++
public:
MaterialSteel^ AddSteel(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the steel material to be added.

Return Value

The pointer to the added steel material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialSteel AddSteel(Document document)
{
    string newName = "mySteelMaterial";
    MaterialSteel mySteel = document.Settings.Materials.AddSteel(newName);

    if (null != mySteel)
    {
        TaskDialog.Show("Revit","Steel material added successfully!");
    }

    return mySteel;
}
CopyVB.NET
Private Function AddSteel(ByVal document As Document) As MaterialSteel
    Dim newName As String = "mySteelMaterial"
    Dim mySteel As MaterialSteel = document.Settings.Materials.AddSteel(newName)

    If mySteel IsNot Nothing Then
        TaskDialog.Show("Revit", "Steel material added successfully!")
    End If

    Return mySteel
End Function

See Also

Materials Class


AddWood Method

[image]

Revit 2011 API
Materials..::.AddWood Method
Materials Class Example See Also Send Feedback
Add a wood material with the given name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialWood AddWood(
    string name
)
Visual Basic (Declaration)
Public Function AddWood ( _
    name As String _
) As MaterialWood
Visual C++
public:
MaterialWood^ AddWood(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the wood material to be added.

Return Value

The pointer to the added wood material.

Remarks

If the given name contains invalid characters or the name has already been used by other materials, an ArgumentException will be thrown.

Examples

CopyC#
private MaterialWood AddWood(Document document)
{
    string newName = "myWoodMaterial";
    MaterialWood myWood = document.Settings.Materials.AddWood(newName);

    if (null != myWood)
    {
        TaskDialog.Show("Revit","Wood material added successfully!");
    }

    return myWood;
}
CopyVB.NET
Private Function AddWood(ByVal document As Document) As MaterialWood
    Dim newName As String = "myWoodMaterial"
    Dim myWood As MaterialWood = document.Settings.Materials.AddWood(newName)

    If myWood IsNot Nothing Then
        TaskDialog.Show("Revit", "Wood material added successfully!")
    End If

    Return myWood
End Function

See Also

Materials Class


Contains Method

[image] [image]

Revit 2011 API
Materials..::.Contains Method
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified identifier.

Overload List

Name | Description
Contains(ElementId) | Checks if the material set contains the material with the specified ID.
Contains(String) | Checks if the material set contains the material with the specified name .
Contains(Material) | (Inherited from MaterialSet.)

See Also

Materials Class
Materials Members


Contains Method (ElementId)

[image]

Revit 2011 API
Materials..::.Contains Method (ElementId)
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified ID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Contains(
    ElementId itemId
)
Visual Basic (Declaration)
Public Function Contains ( _
    itemId As ElementId _
) As Boolean
Visual C++
public:
bool Contains(
    ElementId^ itemId
)

Parameters

itemId
Type: Autodesk.Revit.DB..::.ElementId
The ID of the material to be found.

Return Value

True if the material set contains the material with the specified ID, and False if not.

See Also

Materials Class
Contains Overload


Contains Method (String)

[image]

Revit 2011 API
Materials..::.Contains Method (String)
Materials Class See Also Send Feedback
Checks if the material set contains the material with the specified name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the material to found.

Return Value

True if the material set contains the material with the specified name, and returns False if not.

See Also

Materials Class
Contains Overload


Remove Method

[image]

Revit 2011 API
Materials..::.Remove Method
Materials Class See Also Send Feedback
Remove the material with the specified name .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Remove(
    string matName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    matName As String _
)
Visual C++
public:
void Remove(
    String^ matName
)

Parameters

matName
Type: System..::.String
The name of the material to be removed.

See Also

Materials Class


Materials Properties

[image] [image]

Revit 2011 API
Materials Properties
Materials Class See Also Send Feedback

The Materials type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from MaterialSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets the material with the specified identifier.
Size | Returns the number of materials that are in the set. (Inherited from MaterialSet.)

See Also

Materials Class


Item Property

[image] [image]

Revit 2011 API
Materials..::.Item Property
Materials Class See Also Send Feedback
Gets the material with the specified identifier.

Overload List

Name | Description
Item[([(ElementId])]) |
Item[([(String])]) | Gets the material with the specified name.

See Also

Materials Class
Materials Members


Item Property (ElementId)

[image]

Revit 2011 API
Materials..::.Item Property (ElementId)
Materials Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Item[
    ElementId itemId
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    itemId As ElementId _
) As Material
Visual C++
public:
property Material^ Item[ElementId^ itemId] {
    Material^ get (ElementId^ itemId);
}

Parameters

itemId
Type: Autodesk.Revit.DB..::.ElementId

See Also

Materials Class
Item Overload


Item Property (String)

[image]

Revit 2011 API
Materials..::.Item Property (String)
Materials Class Example See Also Send Feedback
Gets the material with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Material Item[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    name As String _
) As Material
Visual C++
public:
property Material^ Item[String^ name] {
    Material^ get (String^ name);
}

Parameters

name
Type: System..::.String
The name of the material to be found.

Remarks

If the material with the specified name does not exist, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
Materials materials = document.Settings.Materials;
Material floorMaterial = null;
string floorMaterialName = "Default Floor";
floorMaterial = materials.get_Item(floorMaterialName);
if (null != floorMaterial)
{
    TaskDialog.Show("Revit","Material found.");
}
CopyVB.NET
Dim materials As Materials = document.Settings.Materials
Dim floorMaterial As Material = Nothing
Dim floorMaterialName As String = "Default Floor"
floorMaterial = materials.Item(floorMaterialName)
If floorMaterial IsNot Nothing Then
    TaskDialog.Show("Revit", "Material found.")
End If

See Also

Materials Class
Item Overload


MaterialSet Class

[image]

Revit 2011 API
MaterialSet Class
Members See Also Send Feedback
An set that contains materials.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MaterialSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MaterialSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MaterialSet
Autodesk.Revit.DB..::.Materials

See Also

MaterialSet Members


MaterialSet Members

[image] [image]

Revit 2011 API
MaterialSet Members
MaterialSet Class Constructors Methods Properties See Also Send Feedback

The MaterialSet type exposes the following members.

Constructors

Name | Description
MaterialSet | Initializes a new instance of the MaterialSet class

Methods

Name | Description
Clear | Removes every material from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class


MaterialSet Constructor

[image]

Revit 2011 API
MaterialSet Constructor
MaterialSet Class See Also Send Feedback
Initializes a new instance of the MaterialSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSet()

See Also

MaterialSet Class


MaterialSet Methods

[image] [image]

Revit 2011 API
MaterialSet Methods
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Methods

Name | Description
Clear | Removes every material from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSet Class


Clear Method

[image]

Revit 2011 API
MaterialSet..::.Clear Method
MaterialSet Class See Also Send Feedback
Removes every material from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MaterialSet Class


Contains Method

[image]

Revit 2011 API
MaterialSet..::.Contains Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Material

See Also

MaterialSet Class


Erase Method

[image]

Revit 2011 API
MaterialSet..::.Erase Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Material _
) As Integer
Visual C++
public:
virtual int Erase(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Material

See Also

MaterialSet Class


ForwardIterator Method

[image]

Revit 2011 API
MaterialSet..::.ForwardIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MaterialSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MaterialSet Class


GetEnumerator Method

[image]

Revit 2011 API
MaterialSet..::.GetEnumerator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MaterialSet Class


Insert Method

[image]

Revit 2011 API
MaterialSet..::.Insert Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Material item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Material

See Also

MaterialSet Class


ReverseIterator Method

[image]

Revit 2011 API
MaterialSet..::.ReverseIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MaterialSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MaterialSet Class


MaterialSet Properties

[image] [image]

Revit 2011 API
MaterialSet Properties
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class


IsEmpty Property

[image]

Revit 2011 API
MaterialSet..::.IsEmpty Property
MaterialSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MaterialSet Class


Size Property

[image]

Revit 2011 API
MaterialSet..::.Size Property
MaterialSet Class See Also Send Feedback
Returns the number of materials that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MaterialSet Class


MaterialSetIterator Class

[image]

Revit 2011 API
MaterialSetIterator Class
Members See Also Send Feedback
An iterator to a material set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class MaterialSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MaterialSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MaterialSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MaterialSetIterator

See Also

MaterialSetIterator Members


MaterialSetIterator Members

[image] [image]

Revit 2011 API
MaterialSetIterator Members
MaterialSetIterator Class Constructors Methods Properties See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Constructors

Name | Description
MaterialSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class


MaterialSetIterator Constructor

[image]

Revit 2011 API
MaterialSetIterator Constructor
MaterialSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSetIterator Class


MaterialSetIterator Methods

[image] [image]

Revit 2011 API
MaterialSetIterator Methods
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSetIterator Class


MoveNext Method

[image]

Revit 2011 API
MaterialSetIterator..::.MoveNext Method
MaterialSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MaterialSetIterator Class


Reset Method

[image]

Revit 2011 API
MaterialSetIterator..::.Reset Method
MaterialSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MaterialSetIterator Class


MaterialSetIterator Properties

[image] [image]

Revit 2011 API
MaterialSetIterator Properties
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class


Current Property

[image]

Revit 2011 API
MaterialSetIterator..::.Current Property
MaterialSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MaterialSetIterator Class


MaterialSteel Class

[image]

Revit 2011 API
MaterialSteel Class
Members Example See Also Send Feedback
Represents a steel material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialSteel : Material
Visual Basic (Declaration)
Public Class MaterialSteel _
    Inherits Material
Visual C++
public ref class MaterialSteel : public Material

Remarks

MaterialSteel is a child class of Material.

Examples

CopyC#
private void MaterialSteelInformation(MaterialSteel mySteel)
{
    StringBuilder message = new StringBuilder("Material Steel : " + mySteel.Name);

    //behaviour of the material
    MaterialBehaviourType behaviour = mySteel.Behavior;
    message.Append("Behavior: " + behaviour);
    double dampingRatio = mySteel.DampingRatio;
    message.Append("Damping Ratio: " + dampingRatio);
    double minimumTensileStrength = mySteel.MinimumTensileStrength;
    message.Append("Minimum tensile strength: " + minimumTensileStrength);
    double minimumYieldStress = mySteel.MinimumYieldStress;
    message.Append("Minimum yield stress: " + minimumYieldStress);

    double poissonModulusX = mySteel.PoissonModulusX;
    message.Append("Poisson Ratio X: " + poissonModulusX);
    double poissonModulusY = mySteel.PoissonModulusY;
    message.Append("Poisson Ratio Y: " + poissonModulusY);
    double poissonModulusZ = mySteel.PoissonModulusZ;
    message.Append("Poisson Ratio Z: " + poissonModulusZ);

    double reductionFactor = mySteel.ReductionFactor;

    double shearModulusX = mySteel.ShearModulusX;
    message.Append("Shear modulus X: " + shearModulusX);
    double shearModulusY = mySteel.ShearModulusY;
    message.Append("Shear modulus Y: " + shearModulusY);
    double shearModulusZ = mySteel.ShearModulusZ;
    message.Append("Shear modulus Z: " + shearModulusZ);

    double thermalExpansionCoefficientX = mySteel.ThermalExpansionCoefficientX;
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX);
    double thermalExpansionCoefficientY = mySteel.ThermalExpansionCoefficientY;
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY);
    double thermalExpansionCoefficientZ = mySteel.ThermalExpansionCoefficientZ;
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ);

    double unitWeight = mySteel.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulusX = mySteel.YoungModulusX;
    message.Append("Young modulus X: " + youngModulusX);
    double youngModulusY = mySteel.YoungModulusY;
    message.Append("Young modulus Y: " + youngModulusY);
    double youngModulusZ = mySteel.YoungModulusZ;
    message.Append("Young modulus Z: " + youngModulusZ);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialSteelInformation(ByVal mySteel As MaterialSteel)
    Dim message As New StringBuilder("Material Steel : " + mySteel.Name)

    'behaviour of the material
    Dim behaviour As MaterialBehaviourType = mySteel.Behavior
    message.Append("Behavior: " + behaviour)
    Dim dampingRatio As Double = mySteel.DampingRatio
    message.Append("Damping Ratio: " + dampingRatio)
    Dim minimumTensileStrength As Double = mySteel.MinimumTensileStrength
    message.Append("Minimum tensile strength: " + minimumTensileStrength)
    Dim minimumYieldStress As Double = mySteel.MinimumYieldStress
    message.Append("Minimum yield stress: " + minimumYieldStress)

    Dim poissonModulusX As Double = mySteel.PoissonModulusX
    message.Append("Poisson Ratio X: " + poissonModulusX)
    Dim poissonModulusY As Double = mySteel.PoissonModulusY
    message.Append("Poisson Ratio Y: " + poissonModulusY)
    Dim poissonModulusZ As Double = mySteel.PoissonModulusZ
    message.Append("Poisson Ratio Z: " + poissonModulusZ)

    Dim reductionFactor As Double = mySteel.ReductionFactor

    Dim shearModulusX As Double = mySteel.ShearModulusX
    message.Append("Shear modulus X: " + shearModulusX)
    Dim shearModulusY As Double = mySteel.ShearModulusY
    message.Append("Shear modulus Y: " + shearModulusY)
    Dim shearModulusZ As Double = mySteel.ShearModulusZ
    message.Append("Shear modulus Z: " + shearModulusZ)

    Dim thermalExpansionCoefficientX As Double = mySteel.ThermalExpansionCoefficientX
    message.Append("Thermal Expansion coefficient X: " + thermalExpansionCoefficientX)
    Dim thermalExpansionCoefficientY As Double = mySteel.ThermalExpansionCoefficientY
    message.Append("Thermal Expansion coefficient Y: " + thermalExpansionCoefficientY)
    Dim thermalExpansionCoefficientZ As Double = mySteel.ThermalExpansionCoefficientZ
    message.Append("Thermal Expansion coefficient Z: " + thermalExpansionCoefficientZ)

    Dim unitWeight As Double = mySteel.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulusX As Double = mySteel.YoungModulusX
    message.Append("Young modulus X: " + youngModulusX)
    Dim youngModulusY As Double = mySteel.YoungModulusY
    message.Append("Young modulus Y: " + youngModulusY)
    Dim youngModulusZ As Double = mySteel.YoungModulusZ
    message.Append("Young modulus Z: " + youngModulusZ)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialSteel

See Also

MaterialSteel Members


MaterialSteel Members

[image] [image]

Revit 2011 API
MaterialSteel Members
MaterialSteel Class Methods Properties See Also Send Feedback

The MaterialSteel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this steel material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the steel material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the steel material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class


MaterialSteel Methods

[image] [image]

Revit 2011 API
MaterialSteel Methods
MaterialSteel Class See Also Send Feedback

The MaterialSteel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this steel material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSteel Class


Duplicate Method

[image]

Revit 2011 API
MaterialSteel..::.Duplicate Method
MaterialSteel Class See Also Send Feedback
Duplicate this steel material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialSteel Class


MaterialSteel Properties

[image] [image]

Revit 2011 API
MaterialSteel Properties
MaterialSteel Class See Also Send Feedback

The MaterialSteel type exposes the following members.

Properties

Name | Description
Behavior | Get or set the material behavior type of the steel material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DampingRatio | Get or set the damping ratio of the steel material.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumTensileStrength | Get or set the minimum tensile strength of the steel material.
MinimumYieldStress | Get or set the minimum yield stress of the steel material.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulusX | Get or set the x component of the Poisson modulus of the steel material.
PoissonModulusY | Get or set the y component of the Poisson modulus of the steel material.
PoissonModulusZ | Get or set the z component of the Poisson modulus of the steel material.
ReductionFactor | Get or set the reduction factor for shear of the steel material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulusX | Get or set the x component of the shear modulus of the steel material.
ShearModulusY | Get or set the y component of the shear modulus of the steel material.
ShearModulusZ | Get or set the z component of the shear modulus of the steel material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficientX | Get or set the x component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientY | Get or set the y component of the thermal expansion coefficient of the steel material.
ThermalExpansionCoefficientZ | Get or set the z component of the thermal expansion coefficient of the steel material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the steel material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulusX | Get or set the x component of the Young modulus of the steel material.
YoungModulusY | Get or set the y component of the Young modulus of the steel material.
YoungModulusZ | Get or set the z component of the Young modulus of the steel material.

See Also

MaterialSteel Class


Behavior Property

[image]

Revit 2011 API
MaterialSteel..::.Behavior Property
MaterialSteel Class See Also Send Feedback
Get or set the material behavior type of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MaterialBehaviourType Behavior { get; set; }
Visual Basic (Declaration)
Public Property Behavior As MaterialBehaviourType
Visual C++
public:
property MaterialBehaviourType Behavior {
    MaterialBehaviourType get ();
    void set (MaterialBehaviourType value);
}

Remarks

ArgumentException will be thrown if trying to set the behavior to Undefined. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

See Also

MaterialSteel Class


DampingRatio Property

[image]

Revit 2011 API
MaterialSteel..::.DampingRatio Property
MaterialSteel Class See Also Send Feedback
Get or set the damping ratio of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic (Declaration)
Public Property DampingRatio As Double
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the damping ratio to an invalid value.

See Also

MaterialSteel Class


MinimumTensileStrength Property

[image]

Revit 2011 API
MaterialSteel..::.MinimumTensileStrength Property
MaterialSteel Class See Also Send Feedback
Get or set the minimum tensile strength of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MinimumTensileStrength { get; set; }
Visual Basic (Declaration)
Public Property MinimumTensileStrength As Double
Visual C++
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the minimum tensile strength to an invalid value.

See Also

MaterialSteel Class


MinimumYieldStress Property

[image]

Revit 2011 API
MaterialSteel..::.MinimumYieldStress Property
MaterialSteel Class See Also Send Feedback
Get or set the minimum yield stress of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic (Declaration)
Public Property MinimumYieldStress As Double
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class


Parameter Property

[image] [image]

Revit 2011 API
MaterialSteel..::.Parameter Property
MaterialSteel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialSteel Class
MaterialSteel Members


PoissonModulusX Property

[image]

Revit 2011 API
MaterialSteel..::.PoissonModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusX { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusX As Double
Visual C++
public:
property double PoissonModulusX {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the x component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Poisson modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class


PoissonModulusY Property

[image]

Revit 2011 API
MaterialSteel..::.PoissonModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusY { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusY As Double
Visual C++
public:
property double PoissonModulusY {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the y component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


PoissonModulusZ Property

[image]

Revit 2011 API
MaterialSteel..::.PoissonModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the Poisson modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulusZ { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulusZ As Double
Visual C++
public:
property double PoissonModulusZ {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the z component of the Poisson modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


ReductionFactor Property

[image]

Revit 2011 API
MaterialSteel..::.ReductionFactor Property
MaterialSteel Class See Also Send Feedback
Get or set the reduction factor for shear of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ReductionFactor { get; set; }
Visual Basic (Declaration)
Public Property ReductionFactor As Double
Visual C++
public:
property double ReductionFactor {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the reduction factor for shear to an invalid value.

See Also

MaterialSteel Class


ShearModulusX Property

[image]

Revit 2011 API
MaterialSteel..::.ShearModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusX { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusX As Double
Visual C++
public:
property double ShearModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the shear modulus to an invalid value. If the behavior is Isotropic, then the y and z components of shear modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class


ShearModulusY Property

[image]

Revit 2011 API
MaterialSteel..::.ShearModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusY { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusY As Double
Visual C++
public:
property double ShearModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


ShearModulusZ Property

[image]

Revit 2011 API
MaterialSteel..::.ShearModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the shear modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulusZ { get; set; }
Visual Basic (Declaration)
Public Property ShearModulusZ As Double
Visual C++
public:
property double ShearModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the shear modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


ThermalExpansionCoefficientX Property

[image]

Revit 2011 API
MaterialSteel..::.ThermalExpansionCoefficientX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientX { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientX As Double
Visual C++
public:
property double ThermalExpansionCoefficientX {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the x component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then the y and z components of thermal expansion coefficient will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class


ThermalExpansionCoefficientY Property

[image]

Revit 2011 API
MaterialSteel..::.ThermalExpansionCoefficientY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientY { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientY As Double
Visual C++
public:
property double ThermalExpansionCoefficientY {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the y component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


ThermalExpansionCoefficientZ Property

[image]

Revit 2011 API
MaterialSteel..::.ThermalExpansionCoefficientZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the thermal expansion coefficient of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficientZ { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficientZ As Double
Visual C++
public:
property double ThermalExpansionCoefficientZ {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the z component of the thermal expansion coefficient to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


UnitWeight Property

[image]

Revit 2011 API
MaterialSteel..::.UnitWeight Property
MaterialSteel Class See Also Send Feedback
Get or set the unit weight of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialSteel Class


YoungModulusX Property

[image]

Revit 2011 API
MaterialSteel..::.YoungModulusX Property
MaterialSteel Class See Also Send Feedback
Get or set the x component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusX { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusX As Double
Visual C++
public:
property double YoungModulusX {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the x component of the Young modulus to an invalid value. If the behavior is Isotropic, then the y and z components of Young modulus will be changed to the value the same as the specified x component.

See Also

MaterialSteel Class


YoungModulusY Property

[image]

Revit 2011 API
MaterialSteel..::.YoungModulusY Property
MaterialSteel Class See Also Send Feedback
Get or set the y component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusY { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusY As Double
Visual C++
public:
property double YoungModulusY {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the y component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


YoungModulusZ Property

[image]

Revit 2011 API
MaterialSteel..::.YoungModulusZ Property
MaterialSteel Class See Also Send Feedback
Get or set the z component of the Young modulus of the steel material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulusZ { get; set; }
Visual Basic (Declaration)
Public Property YoungModulusZ As Double
Visual C++
public:
property double YoungModulusZ {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the z component of the Young modulus to an invalid value. If the behavior is Isotropic, then an InvalidOperationException will be thrown if trying to set the value.

See Also

MaterialSteel Class


MaterialWood Class

[image]

Revit 2011 API
MaterialWood Class
Members Example See Also Send Feedback
Represents a wood material element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MaterialWood : Material
Visual Basic (Declaration)
Public Class MaterialWood _
    Inherits Material
Visual C++
public ref class MaterialWood : public Material

Remarks

MaterialWood is a child class of Material.

Examples

CopyC#
private void MaterialWoodInformation(MaterialWood myWood)
{
    StringBuilder message = new StringBuilder("Material Wood : " + myWood.Name);

    double bending = myWood.Bending;
    message.Append("Bending: " + bending);

    double compressionParallel = myWood.CompressionParallel;
    message.Append("Compression parallel to grain: " + compressionParallel);
    double compressionPerpendicular = myWood.CompressionPerpendicular;
    message.Append("Compression perpendicular to grain: " + compressionPerpendicular);
    string grade = myWood.Grade;
    message.Append("Grade: " + grade);

    double poissonModulus = myWood.PoissonModulus;
    message.Append("Poisson Ratio: " + poissonModulus);

    double shearModulus = myWood.ShearModulus;
    message.Append("Shear modulus: " + shearModulus);
    double shearParallel = myWood.ShearParallel;
    message.Append("Shear parallel to grain: " + shearParallel);
    double shearPerpendicular = myWood.ShearPerpendicular;
    message.Append("Shear perpendicular to grain: " + shearPerpendicular);

    string species = myWood.Species;
    message.Append("Species: " + species);

    double thermalExpansionCoefficient = myWood.ThermalExpansionCoefficient;
    message.Append("Thermal Expansion coefficient: " + thermalExpansionCoefficient);

    double unitWeight = myWood.UnitWeight;
    message.Append("Unit Weight: " + unitWeight);

    double youngModulus = myWood.YoungModulus;
    message.Append("Young modulus: " + youngModulus);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub MaterialWoodInformation(ByVal myWood As MaterialWood)
    Dim message As New StringBuilder("Material Wood : " + myWood.Name)

    Dim bending As Double = myWood.Bending
    message.Append("Bending: " + bending)

    Dim compressionParallel As Double = myWood.CompressionParallel
    message.Append("Compression parallel to grain: " + compressionParallel)
    Dim compressionPerpendicular As Double = myWood.CompressionPerpendicular
    message.Append("Compression perpendicular to grain: " + compressionPerpendicular)
    Dim grade As String = myWood.Grade
    message.Append("Grade: " + grade)

    Dim poissonModulus As Double = myWood.PoissonModulus
    message.Append("Poisson Ratio: " + poissonModulus)

    Dim shearModulus As Double = myWood.ShearModulus
    message.Append("Shear modulus: " + shearModulus)
    Dim shearParallel As Double = myWood.ShearParallel
    message.Append("Shear parallel to grain: " + shearParallel)
    Dim shearPerpendicular As Double = myWood.ShearPerpendicular
    message.Append("Shear perpendicular to grain: " + shearPerpendicular)

    Dim species As String = myWood.Species
    message.Append("Species: " + species)

    Dim thermalExpansionCoefficient As Double = myWood.ThermalExpansionCoefficient
    message.Append("Thermal Expansion coefficient: " + thermalExpansionCoefficient)

    Dim unitWeight As Double = myWood.UnitWeight
    message.Append("Unit Weight: " + unitWeight)

    Dim youngModulus As Double = myWood.YoungModulus
    message.Append("Young modulus: " + youngModulus)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Material
Autodesk.Revit.DB..::.MaterialWood

See Also

MaterialWood Members


MaterialWood Members

[image] [image]

Revit 2011 API
MaterialWood Members
MaterialWood Class Methods Properties See Also Send Feedback

The MaterialWood type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this wood material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bending | Get or set the bending of the wood material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Grade | Get or set the grade of the wood material.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulus | Get or set the Poisson modulus of the wood material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
Species | Get or set the species of the wood material.
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the wood material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class


MaterialWood Methods

[image] [image]

Revit 2011 API
MaterialWood Methods
MaterialWood Class See Also Send Feedback

The MaterialWood type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this wood material element. (Overrides Material..::.Duplicate(String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialWood Class


Duplicate Method

[image]

Revit 2011 API
MaterialWood..::.Duplicate Method
MaterialWood Class See Also Send Feedback
Duplicate this wood material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Material Duplicate(
    string name
)
Visual Basic (Declaration)
Public Overrides Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
) override

Parameters

name
Type: System..::.String
Name of the new material.

Return Value

Pointer to the new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

MaterialWood Class


MaterialWood Properties

[image] [image]

Revit 2011 API
MaterialWood Properties
MaterialWood Class See Also Send Feedback

The MaterialWood type exposes the following members.

Properties

Name | Description
Bending | Get or set the bending of the wood material.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Color | The color of the material. (Inherited from Material.)
CompressionParallel | Get or set the compression parallel to grain of the wood material.
CompressionPerpendicular | Get or set the compression perpendicular to grain of the wood material.
CutPattern | The cut pattern of the material. (Inherited from Material.)
CutPatternColor | The cut pattern color of the material. (Inherited from Material.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Glow | Whether the material can glow. (Inherited from Material.)
Grade | Get or set the grade of the wood material.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PoissonModulus | Get or set the Poisson modulus of the wood material.
RenderAppearance | The rendering appearance property of the material. (Inherited from Material.)
ShearModulus | Get or set the shear modulus of the wood material.
ShearParallel | Get or set the shear parallel to grain of the wood material.
ShearPerpendicular | Get or set the tension perpendicular to grain of the wood material.
Shininess | The shininess of the material. (Inherited from Material.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Smoothness | The smoothness of the material. (Inherited from Material.)
Species | Get or set the species of the wood material.
SurfacePattern | The surface pattern of the material. (Inherited from Material.)
SurfacePatternColor | The surface pattern color of the material. (Inherited from Material.)
ThermalExpansionCoefficient | Get or set the thermal expansion coefficient of the wood material.
Transparency | The transparency of the material. (Inherited from Material.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UnitWeight | Get or set the unit weight of the wood material.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
YoungModulus | Get or set the Young modulus of the wood material.

See Also

MaterialWood Class


Bending Property

[image]

Revit 2011 API
MaterialWood..::.Bending Property
MaterialWood Class See Also Send Feedback
Get or set the bending of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Bending { get; set; }
Visual Basic (Declaration)
Public Property Bending As Double
Visual C++
public:
property double Bending {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the bending to an invalid value.

See Also

MaterialWood Class


CompressionParallel Property

[image]

Revit 2011 API
MaterialWood..::.CompressionParallel Property
MaterialWood Class See Also Send Feedback
Get or set the compression parallel to grain of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CompressionParallel { get; set; }
Visual Basic (Declaration)
Public Property CompressionParallel As Double
Visual C++
public:
property double CompressionParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression parallel to grain to an invalid value.

See Also

MaterialWood Class


CompressionPerpendicular Property

[image]

Revit 2011 API
MaterialWood..::.CompressionPerpendicular Property
MaterialWood Class See Also Send Feedback
Get or set the compression perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CompressionPerpendicular { get; set; }
Visual Basic (Declaration)
Public Property CompressionPerpendicular As Double
Visual C++
public:
property double CompressionPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the compression perpendicular to grain to an invalid value.

See Also

MaterialWood Class


Grade Property

[image]

Revit 2011 API
MaterialWood..::.Grade Property
MaterialWood Class See Also Send Feedback
Get or set the grade of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Grade { get; set; }
Visual Basic (Declaration)
Public Property Grade As String
Visual C++
public:
property String^ Grade {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class


Parameter Property

[image] [image]

Revit 2011 API
MaterialWood..::.Parameter Property
MaterialWood Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MaterialWood Class
MaterialWood Members


PoissonModulus Property

[image]

Revit 2011 API
MaterialWood..::.PoissonModulus Property
MaterialWood Class See Also Send Feedback
Get or set the Poisson modulus of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PoissonModulus { get; set; }
Visual Basic (Declaration)
Public Property PoissonModulus As Double
Visual C++
public:
property double PoissonModulus {
    double get ();
    void set (double value);
}

Remarks

ArgumentException will be thrown if trying to set the Poisson modulus to an invalid value.

See Also

MaterialWood Class


ShearModulus Property

[image]

Revit 2011 API
MaterialWood..::.ShearModulus Property
MaterialWood Class See Also Send Feedback
Get or set the shear modulus of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearModulus { get; set; }
Visual Basic (Declaration)
Public Property ShearModulus As Double
Visual C++
public:
property double ShearModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear modulus to an invalid value.

See Also

MaterialWood Class


ShearParallel Property

[image]

Revit 2011 API
MaterialWood..::.ShearParallel Property
MaterialWood Class See Also Send Feedback
Get or set the shear parallel to grain of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearParallel { get; set; }
Visual Basic (Declaration)
Public Property ShearParallel As Double
Visual C++
public:
property double ShearParallel {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the shear parallel to grain to an invalid value.

See Also

MaterialWood Class


ShearPerpendicular Property

[image]

Revit 2011 API
MaterialWood..::.ShearPerpendicular Property
MaterialWood Class See Also Send Feedback
Get or set the tension perpendicular to grain of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ShearPerpendicular { get; set; }
Visual Basic (Declaration)
Public Property ShearPerpendicular As Double
Visual C++
public:
property double ShearPerpendicular {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the tension perpendicular to grain to an invalid value.

See Also

MaterialWood Class


Species Property

[image]

Revit 2011 API
MaterialWood..::.Species Property
MaterialWood Class See Also Send Feedback
Get or set the species of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Species { get; set; }
Visual Basic (Declaration)
Public Property Species As String
Visual C++
public:
property String^ Species {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialWood Class


ThermalExpansionCoefficient Property

[image]

Revit 2011 API
MaterialWood..::.ThermalExpansionCoefficient Property
MaterialWood Class See Also Send Feedback
Get or set the thermal expansion coefficient of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ThermalExpansionCoefficient { get; set; }
Visual Basic (Declaration)
Public Property ThermalExpansionCoefficient As Double
Visual C++
public:
property double ThermalExpansionCoefficient {
    double get ();
    void set (double value);
}

Remarks

The value is in inverse degrees Celsius (1/°C). ArgumentException will be thrown if trying to set the thermal expansion coefficient to an invalid value.

See Also

MaterialWood Class


UnitWeight Property

[image]

Revit 2011 API
MaterialWood..::.UnitWeight Property
MaterialWood Class See Also Send Feedback
Get or set the unit weight of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnitWeight { get; set; }
Visual Basic (Declaration)
Public Property UnitWeight As Double
Visual C++
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in newtons per square foot meter (N/(ft²m)). ArgumentException will be thrown if trying to set the unit weight to an invalid value.

See Also

MaterialWood Class


YoungModulus Property

[image]

Revit 2011 API
MaterialWood..::.YoungModulus Property
MaterialWood Class See Also Send Feedback
Get or set the Young modulus of the wood material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double YoungModulus { get; set; }
Visual Basic (Declaration)
Public Property YoungModulus As Double
Visual C++
public:
property double YoungModulus {
    double get ();
    void set (double value);
}

Remarks

The value is in Newtons per foot meter (N/(ft*m)). ArgumentException will be thrown if trying to set the Young modulus to an invalid value.

See Also

MaterialWood Class


MEPCurve Class

[image]

Revit 2011 API
MEPCurve Class
Members See Also Send Feedback
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPCurve : HostObject
Visual Basic (Declaration)
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Mechanical..::.Duct
Autodesk.Revit.DB.Mechanical..::.FlexDuct
Autodesk.Revit.DB.Plumbing..::.FlexPipe
Autodesk.Revit.DB.Plumbing..::.Pipe

See Also

MEPCurve Members


MEPCurve Members

[image] [image]

Revit 2011 API
MEPCurve Members
MEPCurve Class Methods Properties See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve.

See Also

MEPCurve Class


MEPCurve Methods

[image] [image]

Revit 2011 API
MEPCurve Methods
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurve Class


MEPCurve Properties

[image] [image]

Revit 2011 API
MEPCurve Properties
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve.

See Also

MEPCurve Class


ConnectorManager Property

[image]

Revit 2011 API
MEPCurve..::.ConnectorManager Property
MEPCurve Class See Also Send Feedback
The connector manager of this MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

MEPCurve Class


Diameter Property

[image]

Revit 2011 API
MEPCurve..::.Diameter Property
MEPCurve Class See Also Send Feedback
The diameter of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

Remarks

This property is used to retrieve the diameter of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the MEP curve's Shape is not round.

See Also

MEPCurve Class


Height Property

[image]

Revit 2011 API
MEPCurve..::.Height Property
MEPCurve Class See Also Send Feedback
The height of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual C++
public:
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the MEP curve's Shape is not rectangular.

See Also

MEPCurve Class


LevelOffset Property

[image]

Revit 2011 API
MEPCurve..::.LevelOffset Property
MEPCurve Class See Also Send Feedback
The offset of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double LevelOffset { get; set; }
Visual Basic (Declaration)
Public Property LevelOffset As Double
Visual C++
public:
property double LevelOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the offset of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's offset.

See Also

MEPCurve Class


MEPSystem Property

[image]

Revit 2011 API
MEPCurve..::.MEPSystem Property
MEPCurve Class See Also Send Feedback
The system of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property MEPSystem As MEPSystem
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Remarks

Returns the system of this MEP curve. If the curve does not belong to any systems, the value will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

MEPCurve Class


Parameter Property

[image] [image]

Revit 2011 API
MEPCurve..::.Parameter Property
MEPCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPCurve Class
MEPCurve Members


ReferenceLevel Property

[image]

Revit 2011 API
MEPCurve..::.ReferenceLevel Property
MEPCurve Class See Also Send Feedback
The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level ReferenceLevel { get; set; }
Visual Basic (Declaration)
Public Property ReferenceLevel As Level
Visual C++
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.

See Also

MEPCurve Class


Width Property

[image]

Revit 2011 API
MEPCurve..::.Width Property
MEPCurve Class See Also Send Feedback
The width of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.

See Also

MEPCurve Class


MEPCurveType Class

[image]

Revit 2011 API
MEPCurveType Class
Members See Also Send Feedback
A curve type for duct type or pipe type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPCurveType : ElementType
Visual Basic (Declaration)
Public Class MEPCurveType _
    Inherits ElementType
Visual C++
public ref class MEPCurveType : public ElementType

Remarks

The curve type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Electrical..::.CableTrayType
Autodesk.Revit.DB.Electrical..::.ConduitType
Autodesk.Revit.DB.Mechanical..::.DuctType
Autodesk.Revit.DB.Mechanical..::.FlexDuctType
Autodesk.Revit.DB.Plumbing..::.FlexPipeType
Autodesk.Revit.DB.Plumbing..::.PipeType

See Also

MEPCurveType Members


MEPCurveType Members

[image] [image]

Revit 2011 API
MEPCurveType Members
MEPCurveType Class Methods Properties See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type.
Roughness | The roughness of the MEP curve type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type.
Tee | The default tee fitting of the MEP curve type.
Transition | The default transition fitting of the MEP curve type.
Union | The default union fitting of the MEP curve type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPCurveType Class


MEPCurveType Methods

[image] [image]

Revit 2011 API
MEPCurveType Methods
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurveType Class


MEPCurveType Properties

[image] [image]

Revit 2011 API
MEPCurveType Properties
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type.
Roughness | The roughness of the MEP curve type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type.
Tee | The default tee fitting of the MEP curve type.
Transition | The default transition fitting of the MEP curve type.
Union | The default union fitting of the MEP curve type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPCurveType Class


Cross Property

[image]

Revit 2011 API
MEPCurveType..::.Cross Property
MEPCurveType Class See Also Send Feedback
The default cross fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Cross { get; set; }
Visual Basic (Declaration)
Public Property Cross As FamilySymbol
Visual C++
public:
property FamilySymbol^ Cross {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default cross fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


Elbow Property

[image]

Revit 2011 API
MEPCurveType..::.Elbow Property
MEPCurveType Class See Also Send Feedback
The default elbow fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Elbow { get; set; }
Visual Basic (Declaration)
Public Property Elbow As FamilySymbol
Visual C++
public:
property FamilySymbol^ Elbow {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default elbow fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


MultiShapeTransition Property

[image]

Revit 2011 API
MEPCurveType..::.MultiShapeTransition Property
MEPCurveType Class See Also Send Feedback
The default multi shape transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol MultiShapeTransition { get; set; }
Visual Basic (Declaration)
Public Property MultiShapeTransition As FamilySymbol
Visual C++
public:
property FamilySymbol^ MultiShapeTransition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default multi shape transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


Parameter Property

[image] [image]

Revit 2011 API
MEPCurveType..::.Parameter Property
MEPCurveType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPCurveType Class
MEPCurveType Members


PreferredJunctionType Property

[image]

Revit 2011 API
MEPCurveType..::.PreferredJunctionType Property
MEPCurveType Class See Also Send Feedback
The preferred junction type of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public JunctionType PreferredJunctionType { get; set; }
Visual Basic (Declaration)
Public Property PreferredJunctionType As JunctionType
Visual C++
public:
property JunctionType PreferredJunctionType {
    JunctionType get ();
    void set (JunctionType value);
}

See Also

MEPCurveType Class


Roughness Property

[image]

Revit 2011 API
MEPCurveType..::.Roughness Property
MEPCurveType Class See Also Send Feedback
The roughness of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Roughness { get; set; }
Visual Basic (Declaration)
Public Property Roughness As Double
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

See Also

MEPCurveType Class


Tap Property

[image]

Revit 2011 API
MEPCurveType..::.Tap Property
MEPCurveType Class See Also Send Feedback
The default tap fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Tap { get; set; }
Visual Basic (Declaration)
Public Property Tap As FamilySymbol
Visual C++
public:
property FamilySymbol^ Tap {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tap fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


Tee Property

[image]

Revit 2011 API
MEPCurveType..::.Tee Property
MEPCurveType Class See Also Send Feedback
The default tee fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Tee { get; set; }
Visual Basic (Declaration)
Public Property Tee As FamilySymbol
Visual C++
public:
property FamilySymbol^ Tee {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tee fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


Transition Property

[image]

Revit 2011 API
MEPCurveType..::.Transition Property
MEPCurveType Class See Also Send Feedback
The default transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Transition { get; set; }
Visual Basic (Declaration)
Public Property Transition As FamilySymbol
Visual C++
public:
property FamilySymbol^ Transition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


Union Property

[image]

Revit 2011 API
MEPCurveType..::.Union Property
MEPCurveType Class See Also Send Feedback
The default union fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbol Union { get; set; }
Visual Basic (Declaration)
Public Property Union As FamilySymbol
Visual C++
public:
property FamilySymbol^ Union {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default union fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there are no default value.

See Also

MEPCurveType Class


MEPModel Class

[image]

Revit 2011 API
MEPModel Class
Members See Also Send Feedback
Supports all MEP models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPModel : APIObject
Visual Basic (Declaration)
Public Class MEPModel _
    Inherits APIObject
Visual C++
public ref class MEPModel : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.ElectricalEquipment
Autodesk.Revit.DB.Electrical..::.LightingDevice
Autodesk.Revit.DB.Electrical..::.LightingFixture
Autodesk.Revit.DB.Mechanical..::.MechanicalEquipment
Autodesk.Revit.DB.Mechanical..::.MechanicalFitting

See Also

MEPModel Members


MEPModel Members

[image] [image]

Revit 2011 API
MEPModel Members
MEPModel Class Methods Properties See Also Send Feedback

The MEPModel type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class


MEPModel Methods

[image] [image]

Revit 2011 API
MEPModel Methods
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPModel Class


MEPModel Properties

[image] [image]

Revit 2011 API
MEPModel Properties
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class


ConnectorManager Property

[image]

Revit 2011 API
MEPModel..::.ConnectorManager Property
MEPModel Class See Also Send Feedback
Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

This property returns Connector Manager from this MEPModel.

See Also

MEPModel Class


ElectricalSystems Property

[image]

Revit 2011 API
MEPModel..::.ElectricalSystems Property
MEPModel Class See Also Send Feedback
Retrieves the electrical systems that are currently created using this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemSet ElectricalSystems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSystems As ElectricalSystemSet
Visual C++
public:
property ElectricalSystemSet^ ElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class


MEPSystem Class

[image]

Revit 2011 API
MEPSystem Class
Members See Also Send Feedback
A system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPSystem : Element
Visual Basic (Declaration)
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Electrical..::.ElectricalSystem
Autodesk.Revit.DB.Mechanical..::.MechanicalSystem
Autodesk.Revit.DB.Plumbing..::.PipingSystem

See Also

MEPSystem Members


MEPSystem Members

[image] [image]

Revit 2011 API
MEPSystem Members
MEPSystem Class Methods Properties See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system.
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPSystem Class


MEPSystem Methods

[image] [image]

Revit 2011 API
MEPSystem Methods
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSystem Class


Add Method

[image]

Revit 2011 API
MEPSystem..::.Add Method
MEPSystem Class See Also Send Feedback
Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Add(
    ConnectorSet connectors
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    connectors As ConnectorSet _
)
Visual C++
public:
virtual void Add(
    ConnectorSet^ connectors
)

Parameters

connectors
Type: Autodesk.Revit.DB..::.ConnectorSet
Connectors which are used to connect with the system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument connectors is nullNothingnullptra null reference (Nothing in Visual Basic), or any connector in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class


Remove Method

[image]

Revit 2011 API
MEPSystem..::.Remove Method
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Remove(
    ElementSet elements
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    elements As ElementSet _
)
Visual C++
public:
virtual void Remove(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class


MEPSystem Properties

[image] [image]

Revit 2011 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system.
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPSystem Class


BaseEquipment Property

[image]

Revit 2011 API
MEPSystem..::.BaseEquipment Property
MEPSystem Class See Also Send Feedback
The base panel or equipment of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyInstance BaseEquipment { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseEquipment As FamilyInstance
Visual C++
public:
property FamilyInstance^ BaseEquipment {
    FamilyInstance^ get ();
}

See Also

MEPSystem Class


BaseEquipmentConnector Property

[image]

Revit 2011 API
MEPSystem..::.BaseEquipmentConnector Property
MEPSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
}

Return Value

Returns the connector which connects with the system within base equipment if base equipment has been assigned to system, otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

MEPSystem Class


ConnectorManager Property

[image]

Revit 2011 API
MEPSystem..::.ConnectorManager Property
MEPSystem Class See Also Send Feedback
Connector manager of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

The connector manager includes connectors which are used to connect with terminal elements and base equipment.

See Also

MEPSystem Class


Elements Property

[image]

Revit 2011 API
MEPSystem..::.Elements Property
MEPSystem Class See Also Send Feedback
Terminal elements in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementSet
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

The return value is a read only collection and doesn't include the base equipment or panel.

See Also

MEPSystem Class


IsDefaultSystem Property

[image]

Revit 2011 API
MEPSystem..::.IsDefaultSystem Property
MEPSystem Class See Also Send Feedback
Indicates if the system is a default system or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDefaultSystem { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDefaultSystem As Boolean
Visual C++
public:
property bool IsDefaultSystem {
    bool get ();
}

Return Value

True if the system is default, otherwise returns false.

Remarks

Terminals which are not assigned to a system manually in mechanical and piping system are in default systems.

See Also

MEPSystem Class


Parameter Property

[image] [image]

Revit 2011 API
MEPSystem..::.Parameter Property
MEPSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPSystem Class
MEPSystem Members


Mesh Class

[image]

Revit 2011 API
Mesh Class
Members See Also Send Feedback
A triangular mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Mesh : GeometryObject
Visual Basic (Declaration)
Public Class Mesh _
    Inherits GeometryObject
Visual C++
public ref class Mesh : public GeometryObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Mesh

See Also

Mesh Members


Mesh Members

[image] [image]

Revit 2011 API
Mesh Members
Mesh Class Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumTriangles | The number of triangles that the mesh contains.
Transformed | Transforms this mesh and returns the result.
Triangle | Retrieves a specific triangle.
Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


Mesh Methods

[image] [image]

Revit 2011 API
Mesh Methods
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mesh Class


Mesh Properties

[image] [image]

Revit 2011 API
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

Name | Description
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumTriangles | The number of triangles that the mesh contains.
Transformed | Transforms this mesh and returns the result.
Triangle | Retrieves a specific triangle.
Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


NumTriangles Property

[image]

Revit 2011 API
Mesh..::.NumTriangles Property
Mesh Class See Also Send Feedback
The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumTriangles { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumTriangles As Integer
Visual C++
public:
property int NumTriangles {
    int get ();
}

See Also

Mesh Class


Transformed Property

[image]

Revit 2011 API
Mesh..::.Transformed Property
Mesh Class See Also Send Feedback
Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Mesh Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Mesh Class


Triangle Property

[image]

Revit 2011 API
Mesh..::.Triangle Property
Mesh Class See Also Send Feedback
Retrieves a specific triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MeshTriangle Triangle[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Triangle ( _
    idx As Integer _
) As MeshTriangle
Visual C++
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the triangle, must be in [0, NumTriangles).

See Also

Mesh Class


Vertices Property

[image]

Revit 2011 API
Mesh..::.Vertices Property
Mesh Class See Also Send Feedback
Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Vertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertices As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Vertices {
    IList<XYZ^>^ get ();
}

See Also

Mesh Class


MeshArray Class

[image]

Revit 2011 API
MeshArray Class
Members See Also Send Feedback
An array that contains meshes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MeshArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class MeshArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MeshArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MeshArray

See Also

MeshArray Members


MeshArray Members

[image] [image]

Revit 2011 API
MeshArray Members
MeshArray Class Constructors Methods Properties See Also Send Feedback

The MeshArray type exposes the following members.

Constructors

Name | Description
MeshArray | Initializes a new instance of the MeshArray class

Methods

Name | Description
Append | Add the mesh to the end of the array.
Clear | Removes every mesh from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mesh into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a mesh at a specified index within the array.
Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class


MeshArray Constructor

[image]

Revit 2011 API
MeshArray Constructor
MeshArray Class See Also Send Feedback
Initializes a new instance of the MeshArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MeshArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArray()

See Also

MeshArray Class


MeshArray Methods

[image] [image]

Revit 2011 API
MeshArray Methods
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Methods

Name | Description
Append | Add the mesh to the end of the array.
Clear | Removes every mesh from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mesh into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArray Class


Append Method

[image]

Revit 2011 API
MeshArray..::.Append Method
MeshArray Class See Also Send Feedback
Add the mesh to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Mesh item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Mesh _
)
Visual C++
public:
virtual void Append(
    Mesh^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Mesh
The mesh to be added.

See Also

MeshArray Class


Clear Method

[image]

Revit 2011 API
MeshArray..::.Clear Method
MeshArray Class See Also Send Feedback
Removes every mesh from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MeshArray Class


ForwardIterator Method

[image]

Revit 2011 API
MeshArray..::.ForwardIterator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MeshArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

MeshArray Class


GetEnumerator Method

[image]

Revit 2011 API
MeshArray..::.GetEnumerator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MeshArray Class


Insert Method

[image]

Revit 2011 API
MeshArray..::.Insert Method
MeshArray Class See Also Send Feedback
Insert the specified mesh into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Mesh item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Mesh, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Mesh^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Mesh
The mesh to be inserted into the array.
index
Type: System..::.Int32
The mesh will be inserted before this index.

Return Value

Returns whether the mesh was inserted into the array.

See Also

MeshArray Class


ReverseIterator Method

[image]

Revit 2011 API
MeshArray..::.ReverseIterator Method
MeshArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MeshArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

MeshArray Class


MeshArray Properties

[image] [image]

Revit 2011 API
MeshArray Properties
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a mesh at a specified index within the array.
Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class


IsEmpty Property

[image]

Revit 2011 API
MeshArray..::.IsEmpty Property
MeshArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

MeshArray Class


Item Property

[image]

Revit 2011 API
MeshArray..::.Item Property
MeshArray Class See Also Send Feedback
Gets or sets a mesh at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Mesh Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Mesh
Visual C++
public:
virtual property Mesh^ Item[int index] {
    Mesh^ get (int index);
    void set (int index, Mesh^ value);
}

Parameters

index
Type: System..::.Int32
The index of the mesh to be set or retrieved.

Return Value

Returns the mesh at the specified index.

See Also

MeshArray Class


Size Property

[image]

Revit 2011 API
MeshArray..::.Size Property
MeshArray Class See Also Send Feedback
Returns the number of meshes that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MeshArray Class


MeshArrayIterator Class

[image]

Revit 2011 API
MeshArrayIterator Class
Members See Also Send Feedback
An iterator to a mesh array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class MeshArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MeshArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MeshArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MeshArrayIterator

See Also

MeshArrayIterator Members


MeshArrayIterator Members

[image] [image]

Revit 2011 API
MeshArrayIterator Members
MeshArrayIterator Class Constructors Methods Properties See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Constructors

Name | Description
MeshArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class


MeshArrayIterator Constructor

[image]

Revit 2011 API
MeshArrayIterator Constructor
MeshArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MeshArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeshArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshArrayIterator Class


MeshArrayIterator Methods

[image] [image]

Revit 2011 API
MeshArrayIterator Methods
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
MeshArrayIterator..::.MoveNext Method
MeshArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MeshArrayIterator Class


Reset Method

[image]

Revit 2011 API
MeshArrayIterator..::.Reset Method
MeshArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MeshArrayIterator Class


MeshArrayIterator Properties

[image] [image]

Revit 2011 API
MeshArrayIterator Properties
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class


Current Property

[image]

Revit 2011 API
MeshArrayIterator..::.Current Property
MeshArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MeshArrayIterator Class


MeshTriangle Class

[image]

Revit 2011 API
MeshTriangle Class
Members See Also Send Feedback
One triangle of a mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MeshTriangle : APIObject
Visual Basic (Declaration)
Public Class MeshTriangle _
    Inherits APIObject
Visual C++
public ref class MeshTriangle : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MeshTriangle

See Also

MeshTriangle Members


MeshTriangle Members

[image] [image]

Revit 2011 API
MeshTriangle Members
MeshTriangle Class Methods Properties See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


MeshTriangle Methods

[image] [image]

Revit 2011 API
MeshTriangle Methods
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshTriangle Class


MeshTriangle Properties

[image] [image]

Revit 2011 API
MeshTriangle Properties
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Properties

Name | Description
Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


Index Property

[image]

Revit 2011 API
MeshTriangle..::.Index Property
MeshTriangle Class See Also Send Feedback
The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public uint Index[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index ( _
    idx As Integer _
) As UInteger
Visual C++
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


Vertex Property

[image]

Revit 2011 API
MeshTriangle..::.Vertex Property
MeshTriangle Class See Also Send Feedback
A vertex of the triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Vertex[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertex ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


ModelArc Class

[image]

Revit 2011 API
ModelArc Class
Members See Also Send Feedback
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic (Declaration)
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelArc

See Also

ModelArc Members


ModelArc Members

[image] [image]

Revit 2011 API
ModelArc Members
ModelArc Class Methods Properties See Also Send Feedback

The ModelArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelArc Class


ModelArc Methods

[image] [image]

Revit 2011 API
ModelArc Methods
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelArc Class


ModelArc Properties

[image] [image]

Revit 2011 API
ModelArc Properties
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelArc Class


Parameter Property

[image] [image]

Revit 2011 API
ModelArc..::.Parameter Property
ModelArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelArc Class
ModelArc Members


ModelCurve Class

[image]

Revit 2011 API
ModelCurve Class
Members See Also Send Feedback
A model element that exists in 3D space and is visible in all views of a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelCurve : CurveElement
Visual Basic (Declaration)
Public Class ModelCurve _
    Inherits CurveElement
Visual C++
public ref class ModelCurve : public CurveElement

Remarks

You can use model curves to represent 3D geometry in a building design, such as cords or cables that secure a tarp.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelArc
Autodesk.Revit.DB..::.ModelEllipse
Autodesk.Revit.DB..::.ModelHermiteSpline
Autodesk.Revit.DB..::.ModelLine
Autodesk.Revit.DB..::.ModelNurbSpline

See Also

ModelCurve Members


ModelCurve Members

[image] [image]

Revit 2011 API
ModelCurve Members
ModelCurve Class Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve.
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
TrussCurveType | The truss curve type of this model curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelCurve Class


ModelCurve Methods

[image] [image]

Revit 2011 API
ModelCurve Methods
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve.
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurve Class


ChangeToReferenceLine Method

[image]

Revit 2011 API
ModelCurve..::.ChangeToReferenceLine Method
ModelCurve Class See Also Send Feedback
Changes this curve to reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ChangeToReferenceLine()
Visual Basic (Declaration)
Public Sub ChangeToReferenceLine
Visual C++
public:
void ChangeToReferenceLine()

Remarks

This method is applicable only to curves in conceptual mass families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to change model curves to reference curves in non-conceptual mass families.

See Also

ModelCurve Class


GetVisibility Method

[image]

Revit 2011 API
ModelCurve..::.GetVisibility Method
ModelCurve Class See Also Send Feedback
Gets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model curve in a family document.

See Also

ModelCurve Class


SetVisibility Method

[image]

Revit 2011 API
ModelCurve..::.SetVisibility Method
ModelCurve Class See Also Send Feedback
Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelCurve Class


ModelCurve Properties

[image] [image]

Revit 2011 API
ModelCurve Properties
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
TrussCurveType | The truss curve type of this model curve.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelCurve Class


IsReferenceLine Property

[image]

Revit 2011 API
ModelCurve..::.IsReferenceLine Property
ModelCurve Class See Also Send Feedback
Indicates if this curve is a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReferenceLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReferenceLine As Boolean
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
}

See Also

ModelCurve Class


Parameter Property

[image] [image]

Revit 2011 API
ModelCurve..::.Parameter Property
ModelCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelCurve Class
ModelCurve Members


Subcategory Property

[image]

Revit 2011 API
ModelCurve..::.Subcategory Property
ModelCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

ModelCurve Class


TrussCurveType Property

[image]

Revit 2011 API
ModelCurve..::.TrussCurveType Property
ModelCurve Class See Also Send Feedback
The truss curve type of this model curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussCurveType TrussCurveType { get; set; }
Visual Basic (Declaration)
Public Property TrussCurveType As TrussCurveType
Visual C++
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}

Remarks

This property is applicable only to curves in Truss families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to set this property to a curve not in a truss family.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).

See Also

ModelCurve Class


ModelCurveArrArray Class

[image]

Revit 2011 API
ModelCurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelCurveArrArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ModelCurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ModelCurveArrArray

See Also

ModelCurveArrArray Members


ModelCurveArrArray Members

[image] [image]

Revit 2011 API
ModelCurveArrArray Members
ModelCurveArrArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Constructors

Name | Description
ModelCurveArrArray | Initializes a new instance of the ModelCurveArrArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class


ModelCurveArrArray Constructor

[image]

Revit 2011 API
ModelCurveArrArray Constructor
ModelCurveArrArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArrArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArray()

See Also

ModelCurveArrArray Class


ModelCurveArrArray Methods

[image] [image]

Revit 2011 API
ModelCurveArrArray Methods
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArray Class


Append Method

[image]

Revit 2011 API
ModelCurveArrArray..::.Append Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurveArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurveArray _
)
Visual C++
public:
virtual void Append(
    ModelCurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ModelCurveArray

See Also

ModelCurveArrArray Class


Clear Method

[image]

Revit 2011 API
ModelCurveArrArray..::.Clear Method
ModelCurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArrArray Class


ForwardIterator Method

[image]

Revit 2011 API
ModelCurveArrArray..::.ForwardIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class


GetEnumerator Method

[image]

Revit 2011 API
ModelCurveArrArray..::.GetEnumerator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ModelCurveArrArray Class


Insert Method

[image]

Revit 2011 API
ModelCurveArrArray..::.Insert Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurveArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.ModelCurveArray
index
Type: System..::.Int32

See Also

ModelCurveArrArray Class


ReverseIterator Method

[image]

Revit 2011 API
ModelCurveArrArray..::.ReverseIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArrArray Class


ModelCurveArrArray Properties

[image] [image]

Revit 2011 API
ModelCurveArrArray Properties
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class


IsEmpty Property

[image]

Revit 2011 API
ModelCurveArrArray..::.IsEmpty Property
ModelCurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArrArray Class


Item Property

[image]

Revit 2011 API
ModelCurveArrArray..::.Item Property
ModelCurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurveArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurveArray
Visual C++
public:
virtual property ModelCurveArray^ Item[int index] {
    ModelCurveArray^ get (int index);
    void set (int index, ModelCurveArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ModelCurveArrArray Class


Size Property

[image]

Revit 2011 API
ModelCurveArrArray..::.Size Property
ModelCurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArrArray Class


ModelCurveArrArrayIterator Class

[image]

Revit 2011 API
ModelCurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ModelCurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ModelCurveArrArrayIterator

See Also

ModelCurveArrArrayIterator Members


ModelCurveArrArrayIterator Members

[image] [image]

Revit 2011 API
ModelCurveArrArrayIterator Members
ModelCurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Constructors

Name | Description
ModelCurveArrArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Constructor

[image]

Revit 2011 API
ModelCurveArrArrayIterator Constructor
ModelCurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArrArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Methods

[image] [image]

Revit 2011 API
ModelCurveArrArrayIterator Methods
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ModelCurveArrArrayIterator..::.MoveNext Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class


Reset Method

[image]

Revit 2011 API
ModelCurveArrArrayIterator..::.Reset Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Properties

[image] [image]

Revit 2011 API
ModelCurveArrArrayIterator Properties
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class


Current Property

[image]

Revit 2011 API
ModelCurveArrArrayIterator..::.Current Property
ModelCurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArray Class

[image]

Revit 2011 API
ModelCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelCurveArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ModelCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ModelCurveArray

See Also

ModelCurveArray Members


ModelCurveArray Members

[image] [image]

Revit 2011 API
ModelCurveArray Members
ModelCurveArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArray type exposes the following members.

Constructors

Name | Description
ModelCurveArray | Initializes a new instance of the ModelCurveArray class

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class


ModelCurveArray Constructor

[image]

Revit 2011 API
ModelCurveArray Constructor
ModelCurveArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArray()

See Also

ModelCurveArray Class


ModelCurveArray Methods

[image] [image]

Revit 2011 API
ModelCurveArray Methods
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArray Class


Append Method

[image]

Revit 2011 API
ModelCurveArray..::.Append Method
ModelCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ModelCurve _
)
Visual C++
public:
virtual void Append(
    ModelCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ModelCurve
The model curve to be added.

See Also

ModelCurveArray Class


Clear Method

[image]

Revit 2011 API
ModelCurveArray..::.Clear Method
ModelCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArray Class


ForwardIterator Method

[image]

Revit 2011 API
ModelCurveArray..::.ForwardIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class


GetEnumerator Method

[image]

Revit 2011 API
ModelCurveArray..::.GetEnumerator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ModelCurveArray Class


Insert Method

[image]

Revit 2011 API
ModelCurveArray..::.Insert Method
ModelCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.ModelCurve
The model curve to be inserted into the array.
index
Type: System..::.Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class


ReverseIterator Method

[image]

Revit 2011 API
ModelCurveArray..::.ReverseIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArray Class


ModelCurveArray Properties

[image] [image]

Revit 2011 API
ModelCurveArray Properties
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class


IsEmpty Property

[image]

Revit 2011 API
ModelCurveArray..::.IsEmpty Property
ModelCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArray Class


Item Property

[image]

Revit 2011 API
ModelCurveArray..::.Item Property
ModelCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ModelCurve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class


Size Property

[image]

Revit 2011 API
ModelCurveArray..::.Size Property
ModelCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArray Class


ModelCurveArrayIterator Class

[image]

Revit 2011 API
ModelCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ModelCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ModelCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ModelCurveArrayIterator

See Also

ModelCurveArrayIterator Members


ModelCurveArrayIterator Members

[image] [image]

Revit 2011 API
ModelCurveArrayIterator Members
ModelCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Constructors

Name | Description
ModelCurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Constructor

[image]

Revit 2011 API
ModelCurveArrayIterator Constructor
ModelCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ModelCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Methods

[image] [image]

Revit 2011 API
ModelCurveArrayIterator Methods
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ModelCurveArrayIterator..::.MoveNext Method
ModelCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


Reset Method

[image]

Revit 2011 API
ModelCurveArrayIterator..::.Reset Method
ModelCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Properties

[image] [image]

Revit 2011 API
ModelCurveArrayIterator Properties
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


Current Property

[image]

Revit 2011 API
ModelCurveArrayIterator..::.Current Property
ModelCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


ModelEllipse Class

[image]

Revit 2011 API
ModelEllipse Class
Members See Also Send Feedback
Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelEllipse : ModelCurve
Visual Basic (Declaration)
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelEllipse

See Also

ModelEllipse Members


ModelEllipse Members

[image] [image]

Revit 2011 API
ModelEllipse Members
ModelEllipse Class Methods Properties See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelEllipse Class


ModelEllipse Methods

[image] [image]

Revit 2011 API
ModelEllipse Methods
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelEllipse Class


ModelEllipse Properties

[image] [image]

Revit 2011 API
ModelEllipse Properties
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelEllipse Class


Parameter Property

[image] [image]

Revit 2011 API
ModelEllipse..::.Parameter Property
ModelEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelEllipse Class
ModelEllipse Members


ModelHermiteSpline Class

[image]

Revit 2011 API
ModelHermiteSpline Class
Members See Also Send Feedback
Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelHermiteSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelHermiteSpline

See Also

ModelHermiteSpline Members


ModelHermiteSpline Members

[image] [image]

Revit 2011 API
ModelHermiteSpline Members
ModelHermiteSpline Class Methods Properties See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Methods

[image] [image]

Revit 2011 API
ModelHermiteSpline Methods
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Properties

[image] [image]

Revit 2011 API
ModelHermiteSpline Properties
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelHermiteSpline Class


Parameter Property

[image] [image]

Revit 2011 API
ModelHermiteSpline..::.Parameter Property
ModelHermiteSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelHermiteSpline Class
ModelHermiteSpline Members


ModelLine Class

[image]

Revit 2011 API
ModelLine Class
Members See Also Send Feedback
Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelLine : ModelCurve
Visual Basic (Declaration)
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelLine

See Also

ModelLine Members


ModelLine Members

[image] [image]

Revit 2011 API
ModelLine Members
ModelLine Class Methods Properties See Also Send Feedback

The ModelLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelLine Class


ModelLine Methods

[image] [image]

Revit 2011 API
ModelLine Methods
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelLine Class


ModelLine Properties

[image] [image]

Revit 2011 API
ModelLine Properties
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelLine Class


Parameter Property

[image] [image]

Revit 2011 API
ModelLine..::.Parameter Property
ModelLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelLine Class
ModelLine Members


ModelNurbSpline Class

[image]

Revit 2011 API
ModelNurbSpline Class
Members See Also Send Feedback
Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelNurbSpline : ModelCurve
Visual Basic (Declaration)
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.ModelCurve
Autodesk.Revit.DB..::.ModelNurbSpline

See Also

ModelNurbSpline Members


ModelNurbSpline Members

[image] [image]

Revit 2011 API
ModelNurbSpline Members
ModelNurbSpline Class Methods Properties See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelNurbSpline Class


ModelNurbSpline Methods

[image] [image]

Revit 2011 API
ModelNurbSpline Methods
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeToReferenceLine | Changes this curve to reference curve. (Inherited from ModelCurve.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelNurbSpline Class


ModelNurbSpline Properties

[image] [image]

Revit 2011 API
ModelNurbSpline Properties
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory. (Inherited from ModelCurve.)
TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelNurbSpline Class


Parameter Property

[image] [image]

Revit 2011 API
ModelNurbSpline..::.Parameter Property
ModelNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelNurbSpline Class
ModelNurbSpline Members


ModelText Class

[image]

Revit 2011 API
ModelText Class
Members See Also Send Feedback
A model text element in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelText : Element
Visual Basic (Declaration)
Public Class ModelText _
    Inherits Element
Visual C++
public ref class ModelText : public Element

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ModelText

See Also

ModelText Members


ModelText Members

[image] [image]

Revit 2011 API
ModelText Members
ModelText Class Methods Properties See Also Send Feedback

The ModelText type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model text in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model text in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Depth | The depth of the model text.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalAlignment | The horizontal alignment.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
ModelTextType | The type for the model text.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
Text | The text string in the model text.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelText Class


ModelText Methods

[image] [image]

Revit 2011 API
ModelText Methods
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the model text in a family document.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the model text in a family document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelText Class


GetVisibility Method

[image]

Revit 2011 API
ModelText..::.GetVisibility Method
ModelText Class See Also Send Feedback
Gets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model text in a family document.

See Also

ModelText Class


SetVisibility Method

[image]

Revit 2011 API
ModelText..::.SetVisibility Method
ModelText Class See Also Send Feedback
Sets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the model text geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelText Class


ModelText Properties

[image] [image]

Revit 2011 API
ModelText Properties
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Depth | The depth of the model text.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalAlignment | The horizontal alignment.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
ModelTextType | The type for the model text.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory.
Text | The text string in the model text.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelText Class


Depth Property

[image]

Revit 2011 API
ModelText..::.Depth Property
ModelText Class See Also Send Feedback
The depth of the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Double
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

ModelText Class


HorizontalAlignment Property

[image]

Revit 2011 API
ModelText..::.HorizontalAlignment Property
ModelText Class See Also Send Feedback
The horizontal alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public HorizontalAlign HorizontalAlignment { get; set; }
Visual Basic (Declaration)
Public Property HorizontalAlignment As HorizontalAlign
Visual C++
public:
property HorizontalAlign HorizontalAlignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an invalid value is assigned to the property.

See Also

ModelText Class


Location Property

[image]

Revit 2011 API
ModelText..::.Location Property
ModelText Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

ModelText Class


ModelTextType Property

[image]

Revit 2011 API
ModelText..::.ModelTextType Property
ModelText Class See Also Send Feedback
The type for the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelTextType ModelTextType { get; set; }
Visual Basic (Declaration)
Public Property ModelTextType As ModelTextType
Visual C++
public:
property ModelTextType^ ModelTextType {
    ModelTextType^ get ();
    void set (ModelTextType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to this property.

See Also

ModelText Class


Parameter Property

[image] [image]

Revit 2011 API
ModelText..::.Parameter Property
ModelText Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelText Class
ModelText Members


Subcategory Property

[image]

Revit 2011 API
ModelText..::.Subcategory Property
ModelText Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As Category
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

ModelText Class


Text Property

[image]

Revit 2011 API
ModelText..::.Text Property
ModelText Class See Also Send Feedback
The text string in the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to text.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is assigned to text.

See Also

ModelText Class


ModelTextType Class

[image]

Revit 2011 API
ModelTextType Class
Members See Also Send Feedback
A model text type symbol in the Autodesk Revit Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ModelTextType : ElementType
Visual Basic (Declaration)
Public Class ModelTextType _
    Inherits ElementType
Visual C++
public ref class ModelTextType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.ModelTextType

See Also

ModelTextType Members


ModelTextType Members

[image] [image]

Revit 2011 API
ModelTextType Members
ModelTextType Class Methods Properties See Also Send Feedback

The ModelTextType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelTextType Class


ModelTextType Methods

[image] [image]

Revit 2011 API
ModelTextType Methods
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelTextType Class


ModelTextType Properties

[image] [image]

Revit 2011 API
ModelTextType Properties
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ModelTextType Class


Parameter Property

[image] [image]

Revit 2011 API
ModelTextType..::.Parameter Property
ModelTextType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ModelTextType Class
ModelTextType Members


Mullion Class

[image]

Revit 2011 API
Mullion Class
Members See Also Send Feedback
Represents a CurtainGrid within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Mullion : FamilyInstance
Visual Basic (Declaration)
Public Class Mullion _
    Inherits FamilyInstance
Visual C++
public ref class Mullion : public FamilyInstance

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.FamilyInstance
Autodesk.Revit.DB..::.Mullion

See Also

Mullion Members


Mullion Members

[image] [image]

Revit 2011 API
Mullion Members
Mullion Class Methods Properties See Also Send Feedback

The Mullion type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Mullion Class


Mullion Methods

[image] [image]

Revit 2011 API
Mullion Methods
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mullion Class


BreakMullion Method

[image]

Revit 2011 API
Mullion..::.BreakMullion Method
Mullion Class See Also Send Feedback
This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void BreakMullion()
Visual Basic (Declaration)
Public Sub BreakMullion
Visual C++
public:
void BreakMullion()

Remarks

The mullions being perpendicular to it will be joined accordingly.

See Also

Mullion Class


JoinMullion Method

[image]

Revit 2011 API
Mullion..::.JoinMullion Method
Mullion Class See Also Send Feedback
This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void JoinMullion()
Visual Basic (Declaration)
Public Sub JoinMullion
Visual C++
public:
void JoinMullion()

Remarks

The mullions being perpendicular to it will be broken accordingly.

See Also

Mullion Class


Mullion Properties

[image] [image]

Revit 2011 API
Mullion Properties
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
LocationCurve | This method get the curve location of the current Mullion.
Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Lockable | Get - to get whether the Mullion can be lock or unlock.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Mullion Class


AsFamilyInstance Property

[image]

Revit 2011 API
Mullion..::.AsFamilyInstance Property
Mullion Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is no longer needed because Mullion now derives from FamilyInstance.")]
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("This property is no longer needed because Mullion now derives from FamilyInstance.")> _
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
[ObsoleteAttribute(L"This property is no longer needed because Mullion now derives from FamilyInstance.")]
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

This property is obsolete because Mullion now derives from FamilyInstance.

See Also

Mullion Class


FromRoom Property

[image] [image]

Revit 2011 API
Mullion..::.FromRoom Property
Mullion Class See Also Send Feedback
The room from which the door or window is opened.

Overload List

Name | Description
FromRoom | The room from which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
FromRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


LocationCurve Property

[image]

Revit 2011 API
Mullion..::.LocationCurve Property
Mullion Class See Also Send Feedback
This method get the curve location of the current Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve LocationCurve { get; }
Visual Basic (Declaration)
Public ReadOnly Property LocationCurve As Curve
Visual C++
public:
property Curve^ LocationCurve {
    Curve^ get ();
}

See Also

Mullion Class


Lock Property

[image]

Revit 2011 API
Mullion..::.Lock Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

Mullion Class


Lockable Property

[image]

Revit 2011 API
Mullion..::.Lockable Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

See Also

Mullion Class


MullionType Property

[image]

Revit 2011 API
Mullion..::.MullionType Property
Mullion Class See Also Send Feedback
The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MullionType MullionType { get; set; }
Visual Basic (Declaration)
Public Property MullionType As MullionType
Visual C++
public:
property MullionType^ MullionType {
    MullionType^ get ();
    void set (MullionType^ value);
}

See Also

Mullion Class


Parameter Property

[image] [image]

Revit 2011 API
Mullion..::.Parameter Property
Mullion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Mullion Class
Mullion Members


Room Property

[image] [image]

Revit 2011 API
Mullion..::.Room Property
Mullion Class See Also Send Feedback
The room in which the instance is located.

Overload List

Name | Description
Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Room[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


Space Property

[image] [image]

Revit 2011 API
Mullion..::.Space Property
Mullion Class See Also Send Feedback
The space in which the instance is located.

Overload List

Name | Description
Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Space[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


ToRoom Property

[image] [image]

Revit 2011 API
Mullion..::.ToRoom Property
Mullion Class See Also Send Feedback
The room to which the door or window is opened.

Overload List

Name | Description
ToRoom | The room to which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
ToRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


MullionType Class

[image]

Revit 2011 API
MullionType Class
Members See Also Send Feedback
An object that represents a mullion type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MullionType : FamilySymbol
Visual Basic (Declaration)
Public Class MullionType _
    Inherits FamilySymbol
Visual C++
public ref class MullionType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB..::.MullionType

See Also

MullionType Members


MullionType Members

[image] [image]

Revit 2011 API
MullionType Members
MullionType Class Methods Properties See Also Send Feedback

The MullionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MullionType Class


MullionType Methods

[image] [image]

Revit 2011 API
MullionType Methods
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionType Class


MullionType Properties

[image] [image]

Revit 2011 API
MullionType Properties
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MullionType Class


Parameter Property

[image] [image]

Revit 2011 API
MullionType..::.Parameter Property
MullionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MullionType Class
MullionType Members


MullionTypeSet Class

[image]

Revit 2011 API
MullionTypeSet Class
Members See Also Send Feedback
A set that contains mullion types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MullionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MullionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MullionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MullionTypeSet

See Also

MullionTypeSet Members


MullionTypeSet Members

[image] [image]

Revit 2011 API
MullionTypeSet Members
MullionTypeSet Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSet type exposes the following members.

Constructors

Name | Description
MullionTypeSet | Initializes a new instance of the MullionTypeSet class

Methods

Name | Description
Clear | Removes every mullion type from the set, rendering it empty.
Contains | Tests for the existence of a mullion type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified mullion type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mullion type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class


MullionTypeSet Constructor

[image]

Revit 2011 API
MullionTypeSet Constructor
MullionTypeSet Class See Also Send Feedback
Initializes a new instance of the MullionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MullionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSet()

See Also

MullionTypeSet Class


MullionTypeSet Methods

[image] [image]

Revit 2011 API
MullionTypeSet Methods
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every mullion type from the set, rendering it empty.
Contains | Tests for the existence of a mullion type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified mullion type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified mullion type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSet Class


Clear Method

[image]

Revit 2011 API
MullionTypeSet..::.Clear Method
MullionTypeSet Class See Also Send Feedback
Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MullionTypeSet Class


Contains Method

[image]

Revit 2011 API
MullionTypeSet..::.Contains Method
MullionTypeSet Class See Also Send Feedback
Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.MullionType
The mullion type to be searched for.

Return Value

The Contains method returns True if the mullion type is within the set, otherwise False.

See Also

MullionTypeSet Class


Erase Method

[image]

Revit 2011 API
MullionTypeSet..::.Erase Method
MullionTypeSet Class See Also Send Feedback
Removes a specified mullion type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MullionType _
) As Integer
Visual C++
public:
virtual int Erase(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.MullionType
The mullion type to be erased.

Return Value

The number of mullion types that were erased from the set.

See Also

MullionTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
MullionTypeSet..::.ForwardIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MullionTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
MullionTypeSet..::.GetEnumerator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MullionTypeSet Class


Insert Method

[image]

Revit 2011 API
MullionTypeSet..::.Insert Method
MullionTypeSet Class See Also Send Feedback
Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    MullionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.MullionType
The mullion type to be inserted into the set.

Return Value

Returns whether the mullion type was inserted into the set.

See Also

MullionTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
MullionTypeSet..::.ReverseIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MullionTypeSet Class


MullionTypeSet Properties

[image] [image]

Revit 2011 API
MullionTypeSet Properties
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
MullionTypeSet..::.IsEmpty Property
MullionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MullionTypeSet Class


Size Property

[image]

Revit 2011 API
MullionTypeSet..::.Size Property
MullionTypeSet Class See Also Send Feedback
Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MullionTypeSet Class


MullionTypeSetIterator Class

[image]

Revit 2011 API
MullionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a mullion type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class MullionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MullionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MullionTypeSetIterator

See Also

MullionTypeSetIterator Members


MullionTypeSetIterator Members

[image] [image]

Revit 2011 API
MullionTypeSetIterator Members
MullionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Constructors

Name | Description
MullionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Constructor

[image]

Revit 2011 API
MullionTypeSetIterator Constructor
MullionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MullionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MullionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Methods

[image] [image]

Revit 2011 API
MullionTypeSetIterator Methods
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
MullionTypeSetIterator..::.MoveNext Method
MullionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
MullionTypeSetIterator..::.Reset Method
MullionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Properties

[image] [image]

Revit 2011 API
MullionTypeSetIterator Properties
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class


Current Property

[image]

Revit 2011 API
MullionTypeSetIterator..::.Current Property
MullionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


NurbSpline Class

[image]

Revit 2011 API
NurbSpline Class
Members See Also Send Feedback
A nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class NurbSpline : Curve
Visual Basic (Declaration)
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Curve
Autodesk.Revit.DB..::.NurbSpline

See Also

NurbSpline Members


NurbSpline Members

[image] [image]

Revit 2011 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
SetControlPointsAndWeights | Set the control points, weights simultaneously.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
isClosed | Return/set the nurb spline's isClosed property.
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
isRational | Returns whether the nurb spline is rational or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Knots | Return/set the knots of the nurb spline.
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class


NurbSpline Methods

[image] [image]

Revit 2011 API
NurbSpline Methods
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this curve. (Inherited from Curve.)
ComputeDerivatives | Returns the moving frame around the curve at the specified parameter. (Inherited from Curve.)
ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of this curve with the specified curve.
IsInside | Overloaded. Indicates whether the specified parameter value is within this curve's bounds.
MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Project | Projects the specified point on this curve. (Inherited from Curve.)
SetControlPointsAndWeights | Set the control points, weights simultaneously.
Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NurbSpline Class


Intersect Method

[image] [image]

Revit 2011 API
NurbSpline..::.Intersect Method
NurbSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


IsInside Method

[image] [image]

Revit 2011 API
NurbSpline..::.IsInside Method
NurbSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

Name | Description
IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


SetControlPointsAndWeights Method

[image]

Revit 2011 API
NurbSpline..::.SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetControlPointsAndWeights(
    IList<XYZ> ctrlPoints,
    DoubleArray weights
)
Visual Basic (Declaration)
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
weights
Type: Autodesk.Revit.DB..::.DoubleArray

See Also

NurbSpline Class


NurbSpline Properties

[image] [image]

Revit 2011 API
NurbSpline Properties
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Properties

Name | Description
ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
CtrlPoints | Returns the control points of the nurb spline.
Degree | Returns the degree of the nurb spline.
EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
EndPoint | The start or the end point of this curve. (Inherited from Curve.)
EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
isClosed | Return/set the nurb spline's isClosed property.
IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
isRational | Returns whether the nurb spline is rational or not.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Knots | Return/set the knots of the nurb spline.
Length | The exact length of the curve. (Inherited from Curve.)
Period | The period of this curve. (Inherited from Curve.)
Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Visibility | The visibility. (Inherited from GeometryObject.)
Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class


CtrlPoints Property

[image]

Revit 2011 API
NurbSpline..::.CtrlPoints Property
NurbSpline Class See Also Send Feedback
Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> CtrlPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property CtrlPoints As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ CtrlPoints {
    IList<XYZ^>^ get ();
}

See Also

NurbSpline Class


Degree Property

[image]

Revit 2011 API
NurbSpline..::.Degree Property
NurbSpline Class See Also Send Feedback
Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Degree { get; }
Visual Basic (Declaration)
Public ReadOnly Property Degree As Integer
Visual C++
public:
property int Degree {
    int get ();
}

See Also

NurbSpline Class


isClosed Property

[image]

Revit 2011 API
NurbSpline..::.isClosed Property
NurbSpline Class See Also Send Feedback
Return/set the nurb spline's isClosed property.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool isClosed { get; set; }
Visual Basic (Declaration)
Public Property isClosed As Boolean
Visual C++
public:
property bool isClosed {
    bool get ();
    void set (bool value);
}

See Also

NurbSpline Class


isRational Property

[image]

Revit 2011 API
NurbSpline..::.isRational Property
NurbSpline Class See Also Send Feedback
Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool isRational { get; }
Visual Basic (Declaration)
Public ReadOnly Property isRational As Boolean
Visual C++
public:
property bool isRational {
    bool get ();
}

See Also

NurbSpline Class


Knots Property

[image]

Revit 2011 API
NurbSpline..::.Knots Property
NurbSpline Class See Also Send Feedback
Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Knots { get; set; }
Visual Basic (Declaration)
Public Property Knots As DoubleArray
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class


Weights Property

[image]

Revit 2011 API
NurbSpline..::.Weights Property
NurbSpline Class See Also Send Feedback
Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Weights { get; }
Visual Basic (Declaration)
Public ReadOnly Property Weights As DoubleArray
Visual C++
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}

See Also

NurbSpline Class


ObjectFactory Class

[image]

Revit 2011 API
ObjectFactory Class
Members See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ObjectFactory : IDisposable
Visual Basic (Declaration)
Public Class ObjectFactory _
    Implements IDisposable
Visual C++
public ref class ObjectFactory : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ObjectFactory

See Also

ObjectFactory Members


ObjectFactory Members

[image] [image]

Revit 2011 API
ObjectFactory Members
ObjectFactory Class Constructors Methods See Also Send Feedback

The ObjectFactory type exposes the following members.

Constructors

Name | Description
ObjectFactory | For Internal Use Only.

Methods

Name | Description
CreateInstance | For Internal Use Only.
Dispose | For Internal Use Only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstance | For Internal Use Only.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveInstance | For Internal Use Only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class


ObjectFactory Constructor

[image]

Revit 2011 API
ObjectFactory Constructor
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ObjectFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectFactory()

Return Value

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ObjectFactory Class


ObjectFactory Methods

[image] [image]

Revit 2011 API
ObjectFactory Methods
ObjectFactory Class See Also Send Feedback

The ObjectFactory type exposes the following members.

Methods

Name | Description
CreateInstance | For Internal Use Only.
Dispose | For Internal Use Only.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInstance | For Internal Use Only.
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveInstance | For Internal Use Only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class


CreateInstance Method

[image]

Revit 2011 API
ObjectFactory..::.CreateInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Object CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As Object
Visual C++
public:
Object^ CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::.IntPtr
pData
Type: System..::.IntPtr
tag
Type: System..::.IntPtr

Return Value

See Also

ObjectFactory Class


Dispose Method

[image]

Revit 2011 API
ObjectFactory..::.Dispose Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ObjectFactory Class


GetInstance Method

[image]

Revit 2011 API
ObjectFactory..::.GetInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Object GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic (Declaration)
Public Function GetInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As Object
Visual C++
public:
Object^ GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::.IntPtr
pData
Type: System..::.IntPtr
tag
Type: System..::.IntPtr

Return Value

See Also

ObjectFactory Class


RemoveInstance Method

[image]

Revit 2011 API
ObjectFactory..::.RemoveInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveInstance(
    IntPtr tag
)
Visual Basic (Declaration)
Public Sub RemoveInstance ( _
    tag As IntPtr _
)
Visual C++
public:
void RemoveInstance(
    IntPtr tag
)

Parameters

tag
Type: System..::.IntPtr

See Also

ObjectFactory Class


Opening Class

[image]

Revit 2011 API
Opening Class
Members Example See Also Send Feedback
An opening in an Autodesk Revit project or family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Opening : Element
Visual Basic (Declaration)
Public Class Opening _
    Inherits Element
Visual C++
public ref class Opening : public Element

Remarks

The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available.

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.IntegerValue;

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        IList<XYZ> boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect[0];
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect[1];
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.DB.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.get_EndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.get_EndPoint(1));
        }
    }
    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Opening(ByVal opening As Autodesk.Revit.DB.Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " + opening.Host.Id.IntegerValue

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As IList(Of Autodesk.Revit.DB.XYZ) = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As Autodesk.Revit.DB.XYZ = opening.BoundaryRect(0)
        message += vbLf & "Min coordinate point:(" + point.X + ", " + point.Y + ", " + point.Z + ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect(1)
        message += vbLf & "Max coordinate point: (" + point.X + ", " + point.Y + ", " + point.Z + ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " + curves
        Dim i As Integer = 0
        While i < curves
            Dim curve As Autodesk.Revit.DB.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " + XYZToString(curve.EndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " + XYZToString(curve.EndPoint(1))
            System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
        End While
    End If
    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Opening

See Also

Opening Members


Opening Members

[image] [image]

Revit 2011 API
Opening Members
Opening Class Methods Properties See Also Send Feedback

The Opening type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Host | Retrieves the host element of this opening.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Opening Class


Opening Methods

[image] [image]

Revit 2011 API
Opening Methods
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Opening Class


Opening Properties

[image] [image]

Revit 2011 API
Opening Properties
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Properties

Name | Description
BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Host | Retrieves the host element of this opening.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Opening Class


BoundaryCurves Property

[image]

Revit 2011 API
Opening..::.BoundaryCurves Property
Opening Class See Also Send Feedback
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryCurves As CurveArray
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


BoundaryRect Property

[image]

Revit 2011 API
Opening..::.BoundaryRect Property
Opening Class See Also Send Feedback
Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> BoundaryRect { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoundaryRect As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ BoundaryRect {
    IList<XYZ^>^ get ();
}

Remarks

If IsRectBoundary is false, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


Host Property

[image]

Revit 2011 API
Opening..::.Host Property
Opening Class See Also Send Feedback
Retrieves the host element of this opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic (Declaration)
Public ReadOnly Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

Opening Class


IsRectBoundary Property

[image]

Revit 2011 API
Opening..::.IsRectBoundary Property
Opening Class See Also Send Feedback
Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsRectBoundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRectBoundary As Boolean
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class


IsTransparentIn3D Property

[image]

Revit 2011 API
Opening..::.IsTransparentIn3D Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in 3D view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsTransparentIn3D { get; set; }
Visual Basic (Declaration)
Public Property IsTransparentIn3D As Boolean
Visual C++
public:
property bool IsTransparentIn3D {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class


IsTransparentInElevation Property

[image]

Revit 2011 API
Opening..::.IsTransparentInElevation Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in elevation view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsTransparentInElevation { get; set; }
Visual Basic (Declaration)
Public Property IsTransparentInElevation As Boolean
Visual C++
public:
property bool IsTransparentInElevation {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class


Parameter Property

[image] [image]

Revit 2011 API
Opening..::.Parameter Property
Opening Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Opening Class
Opening Members


Options Class

[image]

Revit 2011 API
Options Class
Members See Also Send Feedback
User preferences for parsing of geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Options : APIObject
Visual Basic (Declaration)
Public Class Options _
    Inherits APIObject
Visual C++
public ref class Options : public APIObject

Remarks

This class determines the output of the Element.Geometry property.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Options

See Also

Options Members


Options Members

[image] [image]

Revit 2011 API
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

Name | Description
Options | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class


Options Constructor

[image] [image]

Revit 2011 API
Options Constructor
Options Class See Also Send Feedback

Overload List

Name | Description
Options()()() | Creates a default Options object.
Options(Options) | Copy constructor.

See Also

Options Class
Options Members


Options Constructor

[image]

Revit 2011 API
Options Constructor
Options Class See Also Send Feedback
Creates a default Options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Options()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Options()

Remarks

Defaults to medium detail, no references and no view.

See Also

Options Class
Options Overload


Options Constructor (Options)

[image]

Revit 2011 API
Options Constructor (Options)
Options Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Options(
    Options pOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    pOptions As Options _
)
Visual C++
public:
Options(
    Options^ pOptions
)

Parameters

pOptions
Type: Autodesk.Revit.DB..::.Options

See Also

Options Class
Options Overload


Options Methods

[image] [image]

Revit 2011 API
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Options Class


Options Properties

[image] [image]

Revit 2011 API
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

Name | Description
ComputeReferences | Determines whether or not references to geometric objects are computed.
DetailLevel | The detail level for the geometry extracted with these options.
IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | The view used for geometry extraction.

See Also

Options Class


ComputeReferences Property

[image]

Revit 2011 API
Options..::.ComputeReferences Property
Options Class See Also Send Feedback
Determines whether or not references to geometric objects are computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ComputeReferences { get; set; }
Visual Basic (Declaration)
Public Property ComputeReferences As Boolean
Visual C++
public:
property bool ComputeReferences {
    bool get ();
    void set (bool value);
}

See Also

Options Class


DetailLevel Property

[image]

Revit 2011 API
Options..::.DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DetailLevels DetailLevel { get; set; }
Visual Basic (Declaration)
Public Property DetailLevel As DetailLevels
Visual C++
public:
property DetailLevels DetailLevel {
    DetailLevels get ();
    void set (DetailLevels value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class


IncludeNonVisibleObjects Property

[image]

Revit 2011 API
Options..::.IncludeNonVisibleObjects Property
Options Class See Also Send Feedback
Whether to extract element geometry objects not set as Visible. The default is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IncludeNonVisibleObjects { get; set; }
Visual Basic (Declaration)
Public Property IncludeNonVisibleObjects As Boolean
Visual C++
public:
property bool IncludeNonVisibleObjects {
    bool get ();
    void set (bool value);
}

See Also

Options Class


View Property

[image]

Revit 2011 API
Options..::.View Property
Options Class See Also Send Feedback
The view used for geometry extraction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.

See Also

Options Class


Outline Class

[image]

Revit 2011 API
Outline Class
Members See Also Send Feedback
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class Outline : IDisposable
Visual Basic (Declaration)
Public Class Outline _
    Implements IDisposable
Visual C++
public ref class Outline : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Outline

See Also

Outline Members


Outline Members

[image] [image]

Revit 2011 API
Outline Members
Outline Class Constructors Methods Properties See Also Send Feedback

The Outline type exposes the following members.

Constructors

Name | Description
Outline | Overloaded.

Methods

Name | Description
AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Contains | Determine if this Outline contains the specified point to within a tolerance.
ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Scale | Scales the bounding box by given scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MaximumPoint | The maximum point of the bounding box.
MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


Outline Constructor

[image] [image]

Revit 2011 API
Outline Constructor
Outline Class See Also Send Feedback

Overload List

Name | Description
Outline(Outline) | The copy constructor.
Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

See Also

Outline Class
Outline Members


Outline Constructor (Outline)

[image]

Revit 2011 API
Outline Constructor (Outline)
Outline Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline(
    Outline OtherOutline
)
Visual Basic (Declaration)
Public Sub New ( _
    OtherOutline As Outline _
)
Visual C++
public:
Outline(
    Outline^ OtherOutline
)

Parameters

OtherOutline
Type: Autodesk.Revit.DB..::.Outline
The outline to copy into this one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class
Outline Overload


Outline Constructor (XYZ, XYZ)

[image]

Revit 2011 API
Outline Constructor (XYZ, XYZ)
Outline Class See Also Send Feedback
Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Outline(
    XYZ minimumPoint,
    XYZ maximumPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    minimumPoint As XYZ, _
    maximumPoint As XYZ _
)
Visual C++
public:
Outline(
    XYZ^ minimumPoint,
    XYZ^ maximumPoint
)

Parameters

minimumPoint
Type: Autodesk.Revit.DB..::.XYZ
The minimum point
maximumPoint
Type: Autodesk.Revit.DB..::.XYZ
The maximum point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class
Outline Overload


Outline Methods

[image] [image]

Revit 2011 API
Outline Methods
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Methods

Name | Description
AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Contains | Determine if this Outline contains the specified point to within a tolerance.
ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Scale | Scales the bounding box by given scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Outline Class


AddPoint Method

[image]

Revit 2011 API
Outline..::.AddPoint Method
Outline Class See Also Send Feedback
Adds a point to the bounding box, expanding it if the point is outside the existing boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Sub AddPoint ( _
    point As XYZ _
)
Visual C++
public:
void AddPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


Contains Method

[image]

Revit 2011 API
Outline..::.Contains Method
Outline Class See Also Send Feedback
Determine if this Outline contains the specified point to within a tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Contains(
    XYZ point,
    double tolerance
)
Visual Basic (Declaration)
Public Function Contains ( _
    point As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Contains(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to test for containment.
tolerance
Type: System..::.Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given point, or false otherwise.

Remarks

If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


ContainsOtherOutline Method

[image]

Revit 2011 API
Outline..::.ContainsOtherOutline Method
Outline Class See Also Send Feedback
Determine if this Outline contains another Outline to within tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ContainsOtherOutline(
    Outline otherOutline,
    double tolerance
)
Visual Basic (Declaration)
Public Function ContainsOtherOutline ( _
    otherOutline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool ContainsOtherOutline(
    Outline^ otherOutline,
    double tolerance
)

Parameters

otherOutline
Type: Autodesk.Revit.DB..::.Outline
The outline to test for containment.
tolerance
Type: System..::.Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given outline, or false otherwise.

Remarks

If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate. If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


Dispose Method

[image]

Revit 2011 API
Outline..::.Dispose Method
Outline Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Outline Class


Intersects Method

[image]

Revit 2011 API
Outline..::.Intersects Method
Outline Class See Also Send Feedback
Determine if this Outline intersects the input Outline to within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Intersects(
    Outline outline,
    double tolerance
)
Visual Basic (Declaration)
Public Function Intersects ( _
    outline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Intersects(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::.Outline
The outline to test for intersection with this one.
tolerance
Type: System..::.Double
The tolerance to use when determining intersection. Defaults to zero.

Return Value

True if the given outline intersects this outline.

Remarks

If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


IsScaleValid Method

[image]

Revit 2011 API
Outline..::.IsScaleValid Method
Outline Class See Also Send Feedback
Checks if given scale is valid. Should be greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsScaleValid(
    double scale
)
Visual Basic (Declaration)
Public Function IsScaleValid ( _
    scale As Double _
) As Boolean
Visual C++
public:
bool IsScaleValid(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale.

Return Value

True if the scale is valid, false otherwise.

See Also

Outline Class


Scale Method

[image]

Revit 2011 API
Outline..::.Scale Method
Outline Class See Also Send Feedback
Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Scale(
    double scale
)
Visual Basic (Declaration)
Public Sub Scale ( _
    scale As Double _
)
Visual C++
public:
void Scale(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value. It should be greater than zero.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The scale is invalid.

See Also

Outline Class


Outline Properties

[image] [image]

Revit 2011 API
Outline Properties
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Properties

Name | Description
MaximumPoint | The maximum point of the bounding box.
MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


MaximumPoint Property

[image]

Revit 2011 API
Outline..::.MaximumPoint Property
Outline Class See Also Send Feedback
The maximum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ MaximumPoint { get; set; }
Visual Basic (Declaration)
Public Property MaximumPoint As XYZ
Visual C++
public:
property XYZ^ MaximumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Outline Class


MinimumPoint Property

[image]

Revit 2011 API
Outline..::.MinimumPoint Property
Outline Class See Also Send Feedback
The minimum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ MinimumPoint { get; set; }
Visual Basic (Declaration)
Public Property MinimumPoint As XYZ
Visual C++
public:
property XYZ^ MinimumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Outline Class


PageOrientationType Enumeration

[image]

Revit 2011 API
PageOrientationType Enumeration
See Also Send Feedback
An enumerated type listing all Page Orientation types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PageOrientationType
Visual Basic (Declaration)
Public Enumeration PageOrientationType
Visual C++
public enum class PageOrientationType

Members

Member name | Description
Portrait | The type of Page Orientation is Portrait.
Landscape | The type of Page Orientation is Landscape.

See Also


Panel Class

[image]

Revit 2011 API
Panel Class
Members See Also Send Feedback
This object represents a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Panel : FamilyInstance
Visual Basic (Declaration)
Public Class Panel _
    Inherits FamilyInstance
Visual C++
public ref class Panel : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.FamilyInstance
Autodesk.Revit.DB..::.Panel

See Also

Panel Members


Panel Members

[image] [image]

Revit 2011 API
Panel Members
Panel Class Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetRefGridLines | This method is used to get the reference gridlines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
Transform | This property is used to find the transform of a curtain panel within project.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Panel Class


Panel Methods

[image] [image]

Revit 2011 API
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
FlipFromToRoom | Change the room to which the door or window is opened. (Inherited from FamilyInstance.)
flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCopings | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetRefGridLines | This method is used to get the reference gridlines.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
rotate | The family instance will be flipped by 180 degree. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
SetCopings | Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Panel Class


GetRefGridLines Method

[image]

Revit 2011 API
Panel..::.GetRefGridLines Method
Panel Class See Also Send Feedback
This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic (Declaration)
Public Sub GetRefGridLines ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
)
Visual C++
public:
void GetRefGridLines(
    ElementId^% uGridLineId,
    ElementId^% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::.ElementId %
vGridLineId
Type: Autodesk.Revit.DB..::.ElementId %

See Also

Panel Class


Panel Properties

[image] [image]

Revit 2011 API
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

Name | Description
AsFamilyInstance | Obsolete. This property is used to get family instance within project.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
CanRotate | Property to test whether the family instance can be rotated by 180 degree. (Inherited from FamilyInstance.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
FromRoom | Overloaded. The room from which the door or window is opened.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Lock | This property is used to know whether a panel is locked and lock or unlock a panel.
Lockable | This property is used to know whether a panel can be locked.
Materials | Get all materials present in the element. (Inherited from Element.)
MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
PanelType | The Panel style of this Panel.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | Overloaded. The room in which the instance is located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | Overloaded. The space in which the instance is located.
StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
SubComponents | Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
ToRoom | Overloaded. The room to which the door or window is opened.
Transform | This property is used to find the transform of a curtain panel within project.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Panel Class


AsFamilyInstance Property

[image]

Revit 2011 API
Panel..::.AsFamilyInstance Property
Panel Class See Also Send Feedback
This property is used to get family instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is no longer needed because Panel now derives from FamilyInstance.")]
public FamilyInstance AsFamilyInstance { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("This property is no longer needed because Panel now derives from FamilyInstance.")> _
Public ReadOnly Property AsFamilyInstance As FamilyInstance
Visual C++
[ObsoleteAttribute(L"This property is no longer needed because Panel now derives from FamilyInstance.")]
public:
property FamilyInstance^ AsFamilyInstance {
    FamilyInstance^ get ();
}

Remarks

This property is obsolete because Panel now derives from FamilyInstance.

See Also

Panel Class


FromRoom Property

[image] [image]

Revit 2011 API
Panel..::.FromRoom Property
Panel Class See Also Send Feedback
The room from which the door or window is opened.

Overload List

Name | Description
FromRoom | The room from which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
FromRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Lock Property

[image]

Revit 2011 API
Panel..::.Lock Property
Panel Class See Also Send Feedback
This property is used to know whether a panel is locked and lock or unlock a panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic (Declaration)
Public Property Lock As Boolean
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

Remarks

If the panel is locked, get() returns true, else false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this panel can't be locked.

See Also

Panel Class


Lockable Property

[image]

Revit 2011 API
Panel..::.Lockable Property
Panel Class See Also Send Feedback
This property is used to know whether a panel can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockable As Boolean
Visual C++
public:
property bool Lockable {
    bool get ();
}

Remarks

If the panel can be locked, return true, else false.

See Also

Panel Class


PanelType Property

[image]

Revit 2011 API
Panel..::.PanelType Property
Panel Class See Also Send Feedback
The Panel style of this Panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelType PanelType { get; set; }
Visual Basic (Declaration)
Public Property PanelType As PanelType
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CutainPanelTypes property.

See Also

Panel Class


Parameter Property

[image] [image]

Revit 2011 API
Panel..::.Parameter Property
Panel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Panel Class
Panel Members


Room Property

[image] [image]

Revit 2011 API
Panel..::.Room Property
Panel Class See Also Send Feedback
The room in which the instance is located.

Overload List

Name | Description
Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Room[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Space Property

[image] [image]

Revit 2011 API
Panel..::.Space Property
Panel Class See Also Send Feedback
The space in which the instance is located.

Overload List

Name | Description
Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Space[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


ToRoom Property

[image] [image]

Revit 2011 API
Panel..::.ToRoom Property
Panel Class See Also Send Feedback
The room to which the door or window is opened.

Overload List

Name | Description
ToRoom | The room to which the door is opened at the last phase of the project. (Inherited from FamilyInstance.)
ToRoom[([(Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Transform Property

[image]

Revit 2011 API
Panel..::.Transform Property
Panel Class See Also Send Feedback
This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

The Transform property returns a Autodesk::Revit::DB::Transform object that can be used to find the transfer matrix of a curtain panel within the project.

See Also

Panel Class


PanelType Class

[image]

Revit 2011 API
PanelType Class
Members See Also Send Feedback
An object that represents a curtain panel type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PanelType : FamilySymbol
Visual Basic (Declaration)
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB..::.PanelType

See Also

PanelType Members


PanelType Members

[image] [image]

Revit 2011 API
PanelType Members
PanelType Class Methods Properties See Also Send Feedback

The PanelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelType Class


PanelType Methods

[image] [image]

Revit 2011 API
PanelType Methods
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelType Class


PanelType Properties

[image] [image]

Revit 2011 API
PanelType Properties
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelType Class


Parameter Property

[image] [image]

Revit 2011 API
PanelType..::.Parameter Property
PanelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PanelType Class
PanelType Members


PanelTypeSet Class

[image]

Revit 2011 API
PanelTypeSet Class
Members See Also Send Feedback
A set that contains panel types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PanelTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PanelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PanelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PanelTypeSet

See Also

PanelTypeSet Members


PanelTypeSet Members

[image] [image]

Revit 2011 API
PanelTypeSet Members
PanelTypeSet Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSet type exposes the following members.

Constructors

Name | Description
PanelTypeSet | Initializes a new instance of the PanelTypeSet class

Methods

Name | Description
Clear | Removes every panel type from the set, rendering it empty.
Contains | Tests for the existence of a panel type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified panel type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified panel type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


PanelTypeSet Constructor

[image]

Revit 2011 API
PanelTypeSet Constructor
PanelTypeSet Class See Also Send Feedback
Initializes a new instance of the PanelTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSet()

See Also

PanelTypeSet Class


PanelTypeSet Methods

[image] [image]

Revit 2011 API
PanelTypeSet Methods
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every panel type from the set, rendering it empty.
Contains | Tests for the existence of a panel type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified panel type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified panel type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSet Class


Clear Method

[image]

Revit 2011 API
PanelTypeSet..::.Clear Method
PanelTypeSet Class See Also Send Feedback
Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PanelTypeSet Class


Contains Method

[image]

Revit 2011 API
PanelTypeSet..::.Contains Method
PanelTypeSet Class See Also Send Feedback
Tests for the existence of a panel type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PanelType
The panel type to be searched for.

Return Value

The Contains method returns True if the panel type is within the set, otherwise False.

See Also

PanelTypeSet Class


Erase Method

[image]

Revit 2011 API
PanelTypeSet..::.Erase Method
PanelTypeSet Class See Also Send Feedback
Removes a specified panel type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PanelType _
) As Integer
Visual C++
public:
virtual int Erase(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PanelType
The panel type to be erased.

Return Value

The number of panel types that were erased from the set.

See Also

PanelTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
PanelTypeSet..::.ForwardIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PanelTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
PanelTypeSet..::.GetEnumerator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PanelTypeSet Class


Insert Method

[image]

Revit 2011 API
PanelTypeSet..::.Insert Method
PanelTypeSet Class See Also Send Feedback
Insert the specified panel type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PanelType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PanelType
The panel type to be inserted into the set.

Return Value

Returns whether the panel type was inserted into the set.

See Also

PanelTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
PanelTypeSet..::.ReverseIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PanelTypeSet Class


PanelTypeSet Properties

[image] [image]

Revit 2011 API
PanelTypeSet Properties
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
PanelTypeSet..::.IsEmpty Property
PanelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PanelTypeSet Class


Size Property

[image]

Revit 2011 API
PanelTypeSet..::.Size Property
PanelTypeSet Class See Also Send Feedback
Returns the number of panel types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PanelTypeSet Class


PanelTypeSetIterator Class

[image]

Revit 2011 API
PanelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a panel type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PanelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PanelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PanelTypeSetIterator

See Also

PanelTypeSetIterator Members


PanelTypeSetIterator Members

[image] [image]

Revit 2011 API
PanelTypeSetIterator Members
PanelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Constructors

Name | Description
PanelTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Constructor

[image]

Revit 2011 API
PanelTypeSetIterator Constructor
PanelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Methods

[image] [image]

Revit 2011 API
PanelTypeSetIterator Methods
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
PanelTypeSetIterator..::.MoveNext Method
PanelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
PanelTypeSetIterator..::.Reset Method
PanelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Properties

[image] [image]

Revit 2011 API
PanelTypeSetIterator Properties
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class


Current Property

[image]

Revit 2011 API
PanelTypeSetIterator..::.Current Property
PanelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class


PaperPlacementType Enumeration

[image]

Revit 2011 API
PaperPlacementType Enumeration
See Also Send Feedback
An enumerated type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PaperPlacementType
Visual Basic (Declaration)
Public Enumeration PaperPlacementType
Visual C++
public enum class PaperPlacementType

Members

Member name | Description
Center | The type of Paper Placement is Center.
Margins | The type of Paper Placement is Margins.

See Also


PaperSize Class

[image]

Revit 2011 API
PaperSize Class
Members See Also Send Feedback
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PaperSize : APIObject
Visual Basic (Declaration)
Public Class PaperSize _
    Inherits APIObject
Visual C++
public ref class PaperSize : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSize

See Also

PaperSize Members


PaperSize Members

[image] [image]

Revit 2011 API
PaperSize Members
PaperSize Class Methods Properties See Also Send Feedback

The PaperSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper size name of current project.

See Also

PaperSize Class


PaperSize Methods

[image] [image]

Revit 2011 API
PaperSize Methods
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSize Class


PaperSize Properties

[image] [image]

Revit 2011 API
PaperSize Properties
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper size name of current project.

See Also

PaperSize Class


Name Property

[image]

Revit 2011 API
PaperSize..::.Name Property
PaperSize Class See Also Send Feedback
Retrieve the paper size name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSize Class


PaperSizeSet Class

[image]

Revit 2011 API
PaperSizeSet Class
Members See Also Send Feedback
A set that can contain any number of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PaperSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PaperSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSizeSet

See Also

PaperSizeSet Members


PaperSizeSet Members

[image] [image]

Revit 2011 API
PaperSizeSet Members
PaperSizeSet Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSet type exposes the following members.

Constructors

Name | Description
PaperSizeSet | Initializes a new instance of the PaperSizeSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


PaperSizeSet Constructor

[image]

Revit 2011 API
PaperSizeSet Constructor
PaperSizeSet Class See Also Send Feedback
Initializes a new instance of the PaperSizeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSet()

See Also

PaperSizeSet Class


PaperSizeSet Methods

[image] [image]

Revit 2011 API
PaperSizeSet Methods
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSet Class


Clear Method

[image]

Revit 2011 API
PaperSizeSet..::.Clear Method
PaperSizeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSizeSet Class


Contains Method

[image]

Revit 2011 API
PaperSizeSet..::.Contains Method
PaperSizeSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSize
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSizeSet Class


Erase Method

[image]

Revit 2011 API
PaperSizeSet..::.Erase Method
PaperSizeSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSize _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSize
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSizeSet Class


ForwardIterator Method

[image]

Revit 2011 API
PaperSizeSet..::.ForwardIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class


GetEnumerator Method

[image]

Revit 2011 API
PaperSizeSet..::.GetEnumerator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PaperSizeSet Class


Insert Method

[image]

Revit 2011 API
PaperSizeSet..::.Insert Method
PaperSizeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSize

See Also

PaperSizeSet Class


ReverseIterator Method

[image]

Revit 2011 API
PaperSizeSet..::.ReverseIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSizeSet Class


PaperSizeSet Properties

[image] [image]

Revit 2011 API
PaperSizeSet Properties
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


IsEmpty Property

[image]

Revit 2011 API
PaperSizeSet..::.IsEmpty Property
PaperSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSizeSet Class


Size Property

[image]

Revit 2011 API
PaperSizeSet..::.Size Property
PaperSizeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSizeSet Class


PaperSizeSetIterator Class

[image]

Revit 2011 API
PaperSizeSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PaperSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PaperSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSizeSetIterator

See Also

PaperSizeSetIterator Members


PaperSizeSetIterator Members

[image] [image]

Revit 2011 API
PaperSizeSetIterator Members
PaperSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Constructors

Name | Description
PaperSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Constructor

[image]

Revit 2011 API
PaperSizeSetIterator Constructor
PaperSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Methods

[image] [image]

Revit 2011 API
PaperSizeSetIterator Methods
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
PaperSizeSetIterator..::.MoveNext Method
PaperSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


Reset Method

[image]

Revit 2011 API
PaperSizeSetIterator..::.Reset Method
PaperSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Properties

[image] [image]

Revit 2011 API
PaperSizeSetIterator Properties
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class


Current Property

[image]

Revit 2011 API
PaperSizeSetIterator..::.Current Property
PaperSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


PaperSource Class

[image]

Revit 2011 API
PaperSource Class
Members See Also Send Feedback
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PaperSource : APIObject
Visual Basic (Declaration)
Public Class PaperSource _
    Inherits APIObject
Visual C++
public ref class PaperSource : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSource

See Also

PaperSource Members


PaperSource Members

[image] [image]

Revit 2011 API
PaperSource Members
PaperSource Class Methods Properties See Also Send Feedback

The PaperSource type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


PaperSource Methods

[image] [image]

Revit 2011 API
PaperSource Methods
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSource Class


PaperSource Properties

[image] [image]

Revit 2011 API
PaperSource Properties
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


Name Property

[image]

Revit 2011 API
PaperSource..::.Name Property
PaperSource Class See Also Send Feedback
Retrieve the paper source name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSource Class


PaperSourceSet Class

[image]

Revit 2011 API
PaperSourceSet Class
Members See Also Send Feedback
A set that can contain any number of paper source objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PaperSourceSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PaperSourceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSourceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSourceSet

See Also

PaperSourceSet Members


PaperSourceSet Members

[image] [image]

Revit 2011 API
PaperSourceSet Members
PaperSourceSet Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSet type exposes the following members.

Constructors

Name | Description
PaperSourceSet | Initializes a new instance of the PaperSourceSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class


PaperSourceSet Constructor

[image]

Revit 2011 API
PaperSourceSet Constructor
PaperSourceSet Class See Also Send Feedback
Initializes a new instance of the PaperSourceSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSourceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSet()

See Also

PaperSourceSet Class


PaperSourceSet Methods

[image] [image]

Revit 2011 API
PaperSourceSet Methods
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSet Class


Clear Method

[image]

Revit 2011 API
PaperSourceSet..::.Clear Method
PaperSourceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSourceSet Class


Contains Method

[image]

Revit 2011 API
PaperSourceSet..::.Contains Method
PaperSourceSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSource
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSourceSet Class


Erase Method

[image]

Revit 2011 API
PaperSourceSet..::.Erase Method
PaperSourceSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PaperSource _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSource
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSourceSet Class


ForwardIterator Method

[image]

Revit 2011 API
PaperSourceSet..::.ForwardIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class


GetEnumerator Method

[image]

Revit 2011 API
PaperSourceSet..::.GetEnumerator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PaperSourceSet Class


Insert Method

[image]

Revit 2011 API
PaperSourceSet..::.Insert Method
PaperSourceSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSource item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PaperSource
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PaperSourceSet Class


ReverseIterator Method

[image]

Revit 2011 API
PaperSourceSet..::.ReverseIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSourceSet Class


PaperSourceSet Properties

[image] [image]

Revit 2011 API
PaperSourceSet Properties
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class


IsEmpty Property

[image]

Revit 2011 API
PaperSourceSet..::.IsEmpty Property
PaperSourceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSourceSet Class


Size Property

[image]

Revit 2011 API
PaperSourceSet..::.Size Property
PaperSourceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSourceSet Class


PaperSourceSetIterator Class

[image]

Revit 2011 API
PaperSourceSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper source objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PaperSourceSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PaperSourceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSourceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PaperSourceSetIterator

See Also

PaperSourceSetIterator Members


PaperSourceSetIterator Members

[image] [image]

Revit 2011 API
PaperSourceSetIterator Members
PaperSourceSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Constructors

Name | Description
PaperSourceSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Constructor

[image]

Revit 2011 API
PaperSourceSetIterator Constructor
PaperSourceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSourceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaperSourceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Methods

[image] [image]

Revit 2011 API
PaperSourceSetIterator Methods
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSetIterator Class


MoveNext Method

[image]

Revit 2011 API
PaperSourceSetIterator..::.MoveNext Method
PaperSourceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Reset Method

[image]

Revit 2011 API
PaperSourceSetIterator..::.Reset Method
PaperSourceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Properties

[image] [image]

Revit 2011 API
PaperSourceSetIterator Properties
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


Current Property

[image]

Revit 2011 API
PaperSourceSetIterator..::.Current Property
PaperSourceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Parameter Class

[image]

Revit 2011 API
Parameter Class
Members See Also Send Feedback
The parameter object contains the value data assigned to that parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Parameter : APIObject
Visual Basic (Declaration)
Public Class Parameter _
    Inherits APIObject
Visual C++
public ref class Parameter : public APIObject

Remarks

The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Parameter

See Also

Parameter Members


Parameter Members

[image] [image]

Revit 2011 API
Parameter Members
Parameter Class Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
GUID | The Guid for a shared parameter.
Id | The id of the parameter.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
IsShared | Identifies if the parameter is a shared parameter.
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class


Parameter Methods

[image] [image]

Revit 2011 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
AsDouble | Provides access to the double precision number within the parameter.
AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
AsInteger | Provides access to the integer number within the parameter.
AsString | Provides access to the string contents of the parameter.
AsValueString | Get the parameter value as a string with unit.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Set | Overloaded. Sets the parameter to a new value.
SetValueString | Set the parameter value according to the input string.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class


AsDouble Method

[image]

Revit 2011 API
Parameter..::.AsDouble Method
Parameter Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AsDouble()
Visual Basic (Declaration)
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

See Also

Parameter Class


AsElementId Method

[image]

Revit 2011 API
Parameter..::.AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId AsElementId()
Visual Basic (Declaration)
Public Function AsElementId As ElementId
Visual C++
public:
ElementId^ AsElementId()

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.

Remarks

The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class


AsInteger Method

[image]

Revit 2011 API
Parameter..::.AsInteger Method
Parameter Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int AsInteger()
Visual Basic (Declaration)
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

See Also

Parameter Class


AsString Method

[image]

Revit 2011 API
Parameter..::.AsString Method
Parameter Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string AsString()
Visual Basic (Declaration)
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

See Also

Parameter Class


AsValueString Method

[image]

Revit 2011 API
Parameter..::.AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string AsValueString()
Visual Basic (Declaration)
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case StorageType.Integer:
            if (ParameterType.YesNo
                                == attribute.Definition.ParameterType)
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Function ShowValueParameterInformation(ByVal attribute As Parameter) As [String]
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case StorageType.[Integer]
            If ParameterType.YesNo = attribute.Definition.ParameterType Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class


Set Method

[image] [image]

Revit 2011 API
Parameter..::.Set Method
Parameter Class See Also Send Feedback
Sets the parameter to a new value.

Overload List

Name | Description
Set(ElementId) | Sets the parameter to a new element id.
Set(Double) | Sets the parameter to a new real number value.
Set(Int32) | Sets the parameter to a new integer value.
Set(String) | Sets the parameter to a new string of text.

See Also

Parameter Class
Parameter Members


Set Method (ElementId)

[image]

Revit 2011 API
Parameter..::.Set Method (ElementId)
Parameter Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Set(
    ElementId value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::.ElementId
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Set Overload


Set Method (Double)

[image]

Revit 2011 API
Parameter..::.Set Method (Double)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Set(
    double value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
bool Set(
    double value
)

Parameters

value
Type: System..::.Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Examples

CopyC#
public bool SetParameter(Parameter parameter, double value)
{
    bool result = false;
    //if the parameter is readonly, you can�t change the value of it
    if (null != parameter && !parameter.IsReadOnly)
    {
        StorageType parameterType = parameter.StorageType;
        if (StorageType.Double != parameterType)
        {
            throw new Exception("The storagetypes of value and parameter are different!");
        }
        //If successful, the result is true
        result = parameter.Set(value);
    }

    return result;
}
CopyVB.NET
Public Function SetParameter(ByVal parameter As Parameter, ByVal value As Double) As Boolean
    Dim result As Boolean = False
    'if the parameter is readonly, you can't change the value of it
    If parameter IsNot Nothing AndAlso Not parameter.IsReadOnly Then
        Dim parameterType As StorageType = parameter.StorageType
        If StorageType.[Double] <> parameterType Then
            Throw New Exception("The storagetypes of value and parameter are different!")
        End If
        'If successful, the result is true
        result = parameter.[Set](value)
    End If

    Return result
End Function

See Also

Parameter Class
Set Overload


Set Method (Int32)

[image]

Revit 2011 API
Parameter..::.Set Method (Int32)
Parameter Class See Also Send Feedback
Sets the parameter to a new integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Set(
    int value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool Set(
    int value
)

Parameters

value
Type: System..::.Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an integer.

See Also

Parameter Class
Set Overload


Set Method (String)

[image]

Revit 2011 API
Parameter..::.Set Method (String)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Set(
    string value
)
Visual Basic (Declaration)
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set(
    String^ value
)

Parameters

value
Type: System..::.String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Examples

CopyC#
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
CopyVB.NET
Sub AddInstanceComment(ByVal wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

See Also

Parameter Class
Set Overload


SetValueString Method

[image]

Revit 2011 API
Parameter..::.SetValueString Method
Parameter Class Example See Also Send Feedback
Set the parameter value according to the input string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic (Declaration)
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString(
    String^ valueString
)

Parameters

valueString
Type: System..::.String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

Examples

CopyC#
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
CopyVB.NET
Public Function SetWithValueString(ByVal foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

See Also

Parameter Class


Parameter Properties

[image] [image]

Revit 2011 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
DisplayUnitType | Get the display unit type of the parameter object.
Element | The element to which this parameter belongs.
GUID | The Guid for a shared parameter.
Id | The id of the parameter.
IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::.IsReadOnly.)
IsShared | Identifies if the parameter is a shared parameter.
StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class


Definition Property

[image]

Revit 2011 API
Parameter..::.Definition Property
Parameter Class See Also Send Feedback
Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As Definition
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

Remarks

This will always be an InternalDefinition object. If you want the Guid for a shared parameter, use GUID.

See Also

Parameter Class


DisplayUnitType Property

[image]

Revit 2011 API
Parameter..::.DisplayUnitType Property
Parameter Class See Also Send Feedback
Get the display unit type of the parameter object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Return Value

The display unit type of the parameter.

Remarks

The property only applies to parameters of value types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if this parameter is not of value type.

See Also

Parameter Class


Element Property

[image]

Revit 2011 API
Parameter..::.Element Property
Parameter Class See Also Send Feedback
The element to which this parameter belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

Parameter Class


GUID Property

[image]

Revit 2011 API
Parameter..::.GUID Property
Parameter Class See Also Send Feedback
The Guid for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Guid GUID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GUID As Guid
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

Parameter Class


Id Property

[image]

Revit 2011 API
Parameter..::.Id Property
Parameter Class See Also Send Feedback
The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As ElementId
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Parameter Class


IsReadOnly Property

[image]

Revit 2011 API
Parameter..::.IsReadOnly Property
Parameter Class See Also Send Feedback
Get the readonly property of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Remarks

This function can be used to check if the parameter is read-only.

See Also

Parameter Class


IsShared Property

[image]

Revit 2011 API
Parameter..::.IsShared Property
Parameter Class See Also Send Feedback
Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsShared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsShared As Boolean
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

Parameter Class


StorageType Property

[image]

Revit 2011 API
Parameter..::.StorageType Property
Parameter Class See Also Send Feedback
Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StorageType As StorageType
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class


ParameterFilterElement Class

[image]

Revit 2011 API
ParameterFilterElement Class
Members See Also Send Feedback
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterElement : FilterElement
Visual Basic (Declaration)
Public Class ParameterFilterElement _
    Inherits FilterElement
Visual C++
public ref class ParameterFilterElement : public FilterElement

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.FilterElement
Autodesk.Revit.DB..::.ParameterFilterElement

See Also

ParameterFilterElement Members


ParameterFilterElement Members

[image] [image]

Revit 2011 API
ParameterFilterElement Members
ParameterFilterElement Class Methods Properties See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

Name | Description
AllCategoriesFilterable | Checks that all of the given categories are filterable.
AllRuleParametersApplicable | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ClearRules | Removes all rules from this filter.
Create | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCategories | Gets the categories admitted by this filter.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetRuleParameter | Returns the parameter for a given filter rule.
GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
GetRules | Returns the rules of this filter, in the order in which they are applied.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCategories | Sets the categories admitted by this filter.
SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ParameterFilterElement Class


ParameterFilterElement Methods

[image] [image]

Revit 2011 API
ParameterFilterElement Methods
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

Name | Description
AllCategoriesFilterable | Checks that all of the given categories are filterable.
AllRuleParametersApplicable | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ClearRules | Removes all rules from this filter.
Create | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCategories | Gets the categories admitted by this filter.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetRuleParameter | Returns the parameter for a given filter rule.
GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
GetRules | Returns the rules of this filter, in the order in which they are applied.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCategories | Sets the categories admitted by this filter.
SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterElement Class


AllCategoriesFilterable Method

[image]

Revit 2011 API
ParameterFilterElement..::.AllCategoriesFilterable Method
ParameterFilterElement Class See Also Send Feedback
Checks that all of the given categories are filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool AllCategoriesFilterable(
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function AllCategoriesFilterable ( _
    categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AllCategoriesFilterable(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


AllRuleParametersApplicable Method

[image] [image]

Revit 2011 API
ParameterFilterElement..::.AllRuleParametersApplicable Method
ParameterFilterElement Class See Also Send Feedback

Overload List

Name | Description
AllRuleParametersApplicable(IList<(Of <(FilterRule>)>)) | Checks that the parameters of the given rules are valid for this filter's categories.
AllRuleParametersApplicable(Document, ICollection<(Of <(ElementId>)>), IList<(Of <(FilterRule>)>)) | Checks that the parameters of the given rules are valid for the given set of categories.

See Also

ParameterFilterElement Class
ParameterFilterElement Members


AllRuleParametersApplicable Method (IList(FilterRule))

[image]

Revit 2011 API
ParameterFilterElement..::.AllRuleParametersApplicable Method (IList<(Of <(FilterRule>)>))
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AllRuleParametersApplicable(
    IList<FilterRule> rules
)
Visual Basic (Declaration)
Public Function AllRuleParametersApplicable ( _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
bool AllRuleParametersApplicable(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


AllRuleParametersApplicable Method (Document, ICollection(ElementId), IList(FilterRule))

[image]

Revit 2011 API
ParameterFilterElement..::.AllRuleParametersApplicable Method (Document, ICollection<(Of <(ElementId>)>), IList<(Of <(FilterRule>)>))
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    IList<FilterRule> rules
)
Visual Basic (Declaration)
Public Shared Function AllRuleParametersApplicable ( _
    aDocument As Document, _
    categories As ICollection(Of ElementId), _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document containing the filter, categories, and parameters involved in this validation.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of categories against which to check the rule parameters.
rules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


ClearRules Method

[image]

Revit 2011 API
ParameterFilterElement..::.ClearRules Method
ParameterFilterElement Class See Also Send Feedback
Removes all rules from this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ClearRules()
Visual Basic (Declaration)
Public Sub ClearRules
Visual C++
public:
void ClearRules()

See Also

ParameterFilterElement Class


Create Method

[image] [image]

Revit 2011 API
ParameterFilterElement..::.Create Method
ParameterFilterElement Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String, ICollection<(Of <(ElementId>)>)) | Creates a new ParameterFilterElement in the given document.
Create(Document, String, ICollection<(Of <(ElementId>)>), IList<(Of <(FilterRule>)>)) | Creates a new ParameterFilterElement in the given document.

See Also

ParameterFilterElement Class
ParameterFilterElement Members


Create Method (Document, String, ICollection(ElementId))

[image]

Revit 2011 API
ParameterFilterElement..::.Create Method (Document, String, ICollection<(Of <(ElementId>)>))
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document in which to create the ParameterFilterElement.
name
Type: System..::.String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The categories for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for name is an empty string -or- The given value for name is already in use as a filter element name -or- One of the given categories is not filterable
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
Create Overload


Create Method (Document, String, ICollection(ElementId), IList(FilterRule))

[image]

Revit 2011 API
ParameterFilterElement..::.Create Method (Document, String, ICollection<(Of <(ElementId>)>), IList<(Of <(FilterRule>)>))
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories,
    IList<FilterRule> rules
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId), _
    rules As IList(Of FilterRule) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories,
    IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document in which to create the ParameterFilterElement.
name
Type: System..::.String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The categories for the new ParameterFilterElement.
rules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)
The rules for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for name is an empty string -or- The given value for name is already in use as a filter element name -or- One of the given categories is not filterable -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
Create Overload


GetCategories Method

[image]

Revit 2011 API
ParameterFilterElement..::.GetCategories Method
ParameterFilterElement Class See Also Send Feedback
Gets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetCategories()
Visual Basic (Declaration)
Public Function GetCategories As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategories()

See Also

ParameterFilterElement Class


GetRuleParameter Method

[image]

Revit 2011 API
ParameterFilterElement..::.GetRuleParameter Method
ParameterFilterElement Class See Also Send Feedback
Returns the parameter for a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetRuleParameter(
    FilterRule rule
)
Visual Basic (Declaration)
Public Shared Function GetRuleParameter ( _
    rule As FilterRule _
) As ElementId
Visual C++
public:
static ElementId^ GetRuleParameter(
    FilterRule^ rule
)

Parameters

rule
Type: Autodesk.Revit.DB..::.FilterRule
The rule to query.

Return Value

The identifier of the rule's parameter.

Remarks

If the given rule is a FilterInverseRule, then getRuleParameter will return the parameter of its inner rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given rule is not parameter-based.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


GetRuleParameters Method

[image]

Revit 2011 API
ParameterFilterElement..::.GetRuleParameters Method
ParameterFilterElement Class See Also Send Feedback
Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetRuleParameters()
Visual Basic (Declaration)
Public Function GetRuleParameters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRuleParameters()

Return Value

An array of parameter identifiers.

See Also

ParameterFilterElement Class


GetRules Method

[image]

Revit 2011 API
ParameterFilterElement..::.GetRules Method
ParameterFilterElement Class See Also Send Feedback
Returns the rules of this filter, in the order in which they are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<FilterRule> GetRules()
Visual Basic (Declaration)
Public Function GetRules As IList(Of FilterRule)
Visual C++
public:
IList<FilterRule^>^ GetRules()

See Also

ParameterFilterElement Class


SetCategories Method

[image]

Revit 2011 API
ParameterFilterElement..::.SetCategories Method
ParameterFilterElement Class See Also Send Feedback
Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetCategories(
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Sub SetCategories ( _
    categories As ICollection(Of ElementId) _
)
Visual C++
public:
void SetCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)

Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear the element's filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | One of the given categories is not filterable
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


SetRules Method

[image]

Revit 2011 API
ParameterFilterElement..::.SetRules Method
ParameterFilterElement Class See Also Send Feedback
Sets the rules, all of which must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetRules(
    IList<FilterRule> rules
)
Visual Basic (Declaration)
Public Sub SetRules ( _
    rules As IList(Of FilterRule) _
)
Visual C++
public:
void SetRules(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::.IList <(Of <( FilterRule >)>)

Remarks

The rules are applied in the order given. If an element fails to pass a certain rule, no further testing is done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | One of the given rules refers to a parameter that does not apply to this filter's categories. -or- One of the rules in the given array is NULL
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


ParameterFilterElement Properties

[image] [image]

Revit 2011 API
ParameterFilterElement Properties
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ParameterFilterElement Class


Parameter Property

[image] [image]

Revit 2011 API
ParameterFilterElement..::.Parameter Property
ParameterFilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ParameterFilterElement Class
ParameterFilterElement Members


ParameterFilterRuleFactory Class

[image]

Revit 2011 API
ParameterFilterRuleFactory Class
Members See Also Send Feedback
Contains functions that create appropriate FilterRule objects based on the parameters given.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterRuleFactory : IDisposable
Visual Basic (Declaration)
Public Class ParameterFilterRuleFactory _
    Implements IDisposable
Visual C++
public ref class ParameterFilterRuleFactory : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ParameterFilterRuleFactory

See Also

ParameterFilterRuleFactory Members


ParameterFilterRuleFactory Members

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory Members
ParameterFilterRuleFactory Class Methods See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Methods

Name | Description
CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
CreateEqualsRule | Overloaded.
CreateGreaterOrEqualRule | Overloaded.
CreateGreaterRule | Overloaded.
CreateLessOrEqualRule | Overloaded.
CreateLessRule | Overloaded.
CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
CreateNotEqualsRule | Overloaded.
CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory Methods

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory Methods
ParameterFilterRuleFactory Class See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Methods

Name | Description
CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
CreateEqualsRule | Overloaded.
CreateGreaterOrEqualRule | Overloaded.
CreateGreaterRule | Overloaded.
CreateLessOrEqualRule | Overloaded.
CreateLessRule | Overloaded.
CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
CreateNotEqualsRule | Overloaded.
CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterRuleFactory Class


CreateBeginsWithRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateContainsRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateContainsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateEndsWithRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateEqualsRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
CreateEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateEqualsRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEqualsRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateGreaterOrEqualRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values less than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than value but within epsilon are considered equal, not greater.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateGreaterRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateLessOrEqualRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateLessOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
CreateLessRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateLessRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values less than the user-supplied value but within epsilon are considered equal, not less.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateLessRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateNotBeginsWithRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateNotBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotContainsRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotContainsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateNotContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotEndsWithRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateNotEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotEqualsRule Method

[image] [image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document do not equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotEqualsRule Method (ElementId, ElementId)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEqualsRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    ElementId value
)
Visual Basic (Declaration)
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::.ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, Int32)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic (Declaration)
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::.Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic (Declaration)
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::.Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::.Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateNotEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::.String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::.Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateSharedParameterApplicableRule Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.CreateSharedParameterApplicableRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateSharedParameterApplicableRule(
    string parameterName
)
Visual Basic (Declaration)
Public Shared Function CreateSharedParameterApplicableRule ( _
    parameterName As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateSharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::.String
The name of the parameter that elements must support to satisfy this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


Dispose Method

[image]

Revit 2011 API
ParameterFilterRuleFactory..::.Dispose Method
ParameterFilterRuleFactory Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ParameterFilterRuleFactory Class


ParameterFilterUtilities Class

[image]

Revit 2011 API
ParameterFilterUtilities Class
Members See Also Send Feedback
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterUtilities : IDisposable
Visual Basic (Declaration)
Public Class ParameterFilterUtilities _
    Implements IDisposable
Visual C++
public ref class ParameterFilterUtilities : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ParameterFilterUtilities

See Also

ParameterFilterUtilities Members


ParameterFilterUtilities Members

[image] [image]

Revit 2011 API
ParameterFilterUtilities Members
ParameterFilterUtilities Class Methods See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class


ParameterFilterUtilities Methods

[image] [image]

Revit 2011 API
ParameterFilterUtilities Methods
ParameterFilterUtilities Class See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class


Dispose Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.Dispose Method
ParameterFilterUtilities Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ParameterFilterUtilities Class


GetAllFilterableCategories Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.GetAllFilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the set of categories that may be used in a ParameterFilterElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetAllFilterableCategories()
Visual Basic (Declaration)
Public Shared Function GetAllFilterableCategories As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllFilterableCategories()

Return Value

The set of all filterable categories.

See Also

ParameterFilterUtilities Class


GetFilterableParametersInCommon Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.GetFilterableParametersInCommon Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetFilterableParametersInCommon(
    Document aDoc,
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function GetFilterableParametersInCommon ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetFilterableParametersInCommon(
    Document^ aDoc,
    ICollection<ElementId^>^ categories
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The categories for which to determine the common parameters.

Return Value

The set of filterable parameters common to the given categories.

Remarks

A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.

This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


GetInapplicableParameters Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.GetInapplicableParameters Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the parameters that are not among the set of filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static IList<ElementId> GetInapplicableParameters(
    Document aDoc,
    ICollection<ElementId> categories,
    IList<ElementId> parameters
)
Visual Basic (Declaration)
Public Shared Function GetInapplicableParameters ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId), _
    parameters As IList(Of ElementId) _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInapplicableParameters(
    Document^ aDoc,
    ICollection<ElementId^>^ categories,
    IList<ElementId^>^ parameters
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::.Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The categories that define the set of possibly filterable parameters.
parameters
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
The parameters desired for use in a parameter filter.

Return Value

A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


IsParameterApplicable Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.IsParameterApplicable Method
ParameterFilterUtilities Class See Also Send Feedback
Used to determine whether the element supports the given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsParameterApplicable(
    Element element,
    ElementId parameter
)
Visual Basic (Declaration)
Public Shared Function IsParameterApplicable ( _
    element As Element, _
    parameter As ElementId _
) As Boolean
Visual C++
public:
static bool IsParameterApplicable(
    Element^ element,
    ElementId^ parameter
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to query for support of the given parameter.
parameter
Type: Autodesk.Revit.DB..::.ElementId
The parameter for which to query support.

Return Value

True if the element supports the given parameter, false otherwise.

Remarks

This operation is supported for external (e.g., shared, project) parameters only.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


RemoveUnfilterableCategories Method

[image]

Revit 2011 API
ParameterFilterUtilities..::.RemoveUnfilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> RemoveUnfilterableCategories(
    ICollection<ElementId> categories
)
Visual Basic (Declaration)
Public Shared Function RemoveUnfilterableCategories ( _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


ParameterMap Class

[image]

Revit 2011 API
ParameterMap Class
Members See Also Send Feedback
A map that can contain a mapping of a parameter name (a String) to a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ParameterMap : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ParameterMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ParameterMap

See Also

ParameterMap Members


ParameterMap Members

[image] [image]

Revit 2011 API
ParameterMap Members
ParameterMap Class Constructors Methods Properties See Also Send Feedback

The ParameterMap type exposes the following members.

Constructors

Name | Description
ParameterMap | Initializes a new instance of the ParameterMap class

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


ParameterMap Constructor

[image]

Revit 2011 API
ParameterMap Constructor
ParameterMap Class See Also Send Feedback
Initializes a new instance of the ParameterMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMap()

See Also

ParameterMap Class


ParameterMap Methods

[image] [image]

Revit 2011 API
ParameterMap Methods
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the map, rendering it empty.
Contains | Tests for the existence of a key within the map.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a object with the specified key from the map.
ForwardIterator | Retrieve a forward moving iterator to the map.
GetEnumerator | Retrieve a forward moving iterator to the map.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item with the specified key into the map.
ReverseIterator | Retrieve a backward moving iterator to the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMap Class


Clear Method

[image]

Revit 2011 API
ParameterMap..::.Clear Method
ParameterMap Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterMap Class


Contains Method

[image]

Revit 2011 API
ParameterMap..::.Contains Method
ParameterMap Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

ParameterMap Class


Erase Method

[image]

Revit 2011 API
ParameterMap..::.Erase Method
ParameterMap Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class


ForwardIterator Method

[image]

Revit 2011 API
ParameterMap..::.ForwardIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ParameterMapIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class


GetEnumerator Method

[image]

Revit 2011 API
ParameterMap..::.GetEnumerator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ParameterMap Class


Insert Method

[image]

Revit 2011 API
ParameterMap..::.Insert Method
ParameterMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)

Parameters

key
Type: System..::.String
The key to be used for inserting the item into the map.
item
Type: Autodesk.Revit.DB..::.Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class


ReverseIterator Method

[image]

Revit 2011 API
ParameterMap..::.ReverseIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ParameterMapIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

ParameterMap Class


ParameterMap Properties

[image] [image]

Revit 2011 API
ParameterMap Properties
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the map is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified key within the map.
Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


IsEmpty Property

[image]

Revit 2011 API
ParameterMap..::.IsEmpty Property
ParameterMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

ParameterMap Class


Item Property

[image]

Revit 2011 API
ParameterMap..::.Item Property
ParameterMap Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Parameter Item[
    string key
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    key As String _
) As Parameter
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
Type: System..::.String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class


Size Property

[image]

Revit 2011 API
ParameterMap..::.Size Property
ParameterMap Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterMap Class


ParameterMapIterator Class

[image]

Revit 2011 API
ParameterMapIterator Class
Members See Also Send Feedback
An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ParameterMapIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ParameterMapIterator

See Also

ParameterMapIterator Members


ParameterMapIterator Members

[image] [image]

Revit 2011 API
ParameterMapIterator Members
ParameterMapIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Constructors

Name | Description
ParameterMapIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


ParameterMapIterator Constructor

[image]

Revit 2011 API
ParameterMapIterator Constructor
ParameterMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterMapIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterMapIterator Class


ParameterMapIterator Methods

[image] [image]

Revit 2011 API
ParameterMapIterator Methods
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the map.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMapIterator Class


MoveNext Method

[image]

Revit 2011 API
ParameterMapIterator..::.MoveNext Method
ParameterMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Reset Method

[image]

Revit 2011 API
ParameterMapIterator..::.Reset Method
ParameterMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterMapIterator Class


ParameterMapIterator Properties

[image] [image]

Revit 2011 API
ParameterMapIterator Properties
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


Current Property

[image]

Revit 2011 API
ParameterMapIterator..::.Current Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Key Property

[image]

Revit 2011 API
ParameterMapIterator..::.Key Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Key As String
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


ParameterSet Class

[image]

Revit 2011 API
ParameterSet Class
Members See Also Send Feedback
A set that contains parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ParameterSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ParameterSet

See Also

ParameterSet Members


ParameterSet Members

[image] [image]

Revit 2011 API
ParameterSet Members
ParameterSet Class Constructors Methods Properties See Also Send Feedback

The ParameterSet type exposes the following members.

Constructors

Name | Description
ParameterSet | Initializes a new instance of the ParameterSet class

Methods

Name | Description
Clear | Removes every parameter from the set, rendering it empty.
Contains | Tests for the existence of a parameter within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified parameter from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified parameter into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class


ParameterSet Constructor

[image]

Revit 2011 API
ParameterSet Constructor
ParameterSet Class See Also Send Feedback
Initializes a new instance of the ParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSet()

See Also

ParameterSet Class


ParameterSet Methods

[image] [image]

Revit 2011 API
ParameterSet Methods
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Methods

Name | Description
Clear | Removes every parameter from the set, rendering it empty.
Contains | Tests for the existence of a parameter within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified parameter from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified parameter into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSet Class


Clear Method

[image]

Revit 2011 API
ParameterSet..::.Clear Method
ParameterSet Class See Also Send Feedback
Removes every parameter from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterSet Class


Contains Method

[image]

Revit 2011 API
ParameterSet..::.Contains Method
ParameterSet Class See Also Send Feedback
Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Parameter
The parameter to be searched for.

Return Value

The Contains method returns True if the parameter is within the set, otherwise False.

See Also

ParameterSet Class


Erase Method

[image]

Revit 2011 API
ParameterSet..::.Erase Method
ParameterSet Class See Also Send Feedback
Removes a specified parameter from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Parameter _
) As Integer
Visual C++
public:
virtual int Erase(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Parameter
The parameter to be erased.

Return Value

The number of parameters that were erased from the set.

See Also

ParameterSet Class


ForwardIterator Method

[image]

Revit 2011 API
ParameterSet..::.ForwardIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ParameterSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ParameterSet Class


GetEnumerator Method

[image]

Revit 2011 API
ParameterSet..::.GetEnumerator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ParameterSet Class


Insert Method

[image]

Revit 2011 API
ParameterSet..::.Insert Method
ParameterSet Class See Also Send Feedback
Insert the specified parameter into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Parameter item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Parameter
The parameter to be inserted into the set.

Return Value

Returns whether the parameter was inserted into the set.

See Also

ParameterSet Class


ReverseIterator Method

[image]

Revit 2011 API
ParameterSet..::.ReverseIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ParameterSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ParameterSet Class


ParameterSet Properties

[image] [image]

Revit 2011 API
ParameterSet Properties
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class


IsEmpty Property

[image]

Revit 2011 API
ParameterSet..::.IsEmpty Property
ParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ParameterSet Class


Size Property

[image]

Revit 2011 API
ParameterSet..::.Size Property
ParameterSet Class See Also Send Feedback
Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterSet Class


ParameterSetIterator Class

[image]

Revit 2011 API
ParameterSetIterator Class
Members See Also Send Feedback
An iterator to a parameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ParameterSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ParameterSetIterator

See Also

ParameterSetIterator Members


ParameterSetIterator Members

[image] [image]

Revit 2011 API
ParameterSetIterator Members
ParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Constructors

Name | Description
ParameterSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class


ParameterSetIterator Constructor

[image]

Revit 2011 API
ParameterSetIterator Constructor
ParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ParameterSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterSetIterator Class


ParameterSetIterator Methods

[image] [image]

Revit 2011 API
ParameterSetIterator Methods
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ParameterSetIterator..::.MoveNext Method
ParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


Reset Method

[image]

Revit 2011 API
ParameterSetIterator..::.Reset Method
ParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterSetIterator Class


ParameterSetIterator Properties

[image] [image]

Revit 2011 API
ParameterSetIterator Properties
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class


Current Property

[image]

Revit 2011 API
ParameterSetIterator..::.Current Property
ParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


ParameterType Enumeration

[image]

Revit 2011 API
ParameterType Enumeration
See Also Send Feedback
An enumerated type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ParameterType
Visual Basic (Declaration)
Public Enumeration ParameterType
Visual C++
public enum class ParameterType

Members

Member name | Description
Invalid | The parameter type is invalid. This value should not be used.
Text | The parameter data should be interpreted as a string of text.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.
Length | The parameter data represents a length.
Area | The parameter data represents an area.
Volume | The parameter data represents a volume.
Angle | The parameter data represents an angle.
URL | A text string that represents a web address.
Material | The value of this property is considered to be a material.
YesNo | A boolean value that will be represented as Yes or No.
Force | The data value will be represented as a force.
LinearForce | The data value will be represented as a linear force.
AreaForce | The data value will be represented as an area force.
Moment | The data value will be represented as a moment.
NumberOfPoles | A parameter value that represents the number of poles, as used in electrical disciplines.
FixtureUnit | A parameter value that represents the fixture units, as used in piping disciplines.
FamilyType | A parameter used to control the type of a family nested within another family.
LoadClassification | A parameter value that represents the load classification units, as used in electrical disciplines.
HVACDensity | The data value will be represented as a HVACDensity.
HVACEnergy | The data value will be represented as a HVACEnergy.
HVACFriction | The data value will be represented as a HVACFriction.
HVACPower | The data value will be represented as a HVACPower.
HVACPowerDensity | The data value will be represented as a HVACPowerDensity.
HVACPressure | The data value will be represented as a HVACPressure.
HVACTemperature | The data value will be represented as a HVACTemperature.
HVACVelocity | The data value will be represented as a HVACVelocity.
HVACAirflow | The data value will be represented as a HVACAirflow.
HVACDuctSize | The data value will be represented as a HVACDuctSize.
HVACCrossSection | The data value will be represented as a HVACCrossSection.
HVACHeatGain | The data value will be represented as a HVACHeatGain.
ElectricalCurrent | The data value will be represented as an ElectricalCurrent.
ElectricalPotential | The data value will be represented as an ElectricalPotential.
ElectricalFrequency | The data value will be represented as an ElectricalFrequency.
ElectricalIlluminance | The data value will be represented as an ElectricalIlluminance.
ElectricalLuminousFlux | The data value will be represented as an ElectricalLuminousFlux.
ElectricalPower | The data value will be represented as an ElectricalPower.
HVACRoughness | The data value will be represented as a HVACRoughness.
ElectricalApparentPower | The data value will be represented as an ElectricalApparentPower.
ElectricalPowerDensity | The data value will be represented as an ElectricalPowerDensity.
PipingDensity | The data value will be represented as a PipingDensity.
PipingFlow | The data value will be represented as a PipingFlow.
PipingFriction | The data value will be represented as a PipingFriction.
PipingPressure | The data value will be represented as a PipingPressure.
PipingTemperature | The data value will be represented as a PipingTemperature.
PipingVelocity | The data value will be represented as a PipingVelocity.
PipingViscosity | The data value will be represented as a PipingViscosity.
PipeSize | The data value will be represented as a PipeSize.
PipingRoughness | The data value will be represented as a PipingRoughness.
Stress | The data value will be represented as a Stress.
UnitWeight | The data value will be represented as a UnitWeight.
TemperalExp | The data value will be represented as a TemperalExp.
LinearMoment | The data value will be represented as a LinearMoment.
ForcePerLength | The data value will be represented as a ForcePerLength.
ForceLengthPerAngle | The data value will be represented as a ForceLengthPerAngle.
LinearForcePerLength | The data value will be represented as a LinearForcePerLength.
LinearForceLengthPerAngle | The data value will be represented as a LinearForceLengthPerAngle.
AreaForcePerLength | The data value will be represented as an AreaForcePerLength.
PipingVolume | The data value will be represented as a PipingVolume.
HVACViscosity | The data value will be represented as a HVACViscosity.
HVACCoefficientOfHeatTransfer | The data value will be represented as a HVACCoefficientOfHeatTransfer.
HVACAirflowDensity | The data value will be represented as a HVACAirflowDensity.
Slope | The data value will be represented as a Slope.
HVACCoolingLoad | The data value will be represented as a HVACCoolingLoad.
HVACCoolingLoadDividedByArea | The data value will be represented as a HVACCoolingLoadDividedByArea.
HVACCoolingLoadDividedByVolume | The data value will be represented as a HVACCoolingLoadDividedByVolume.
HVACHeatingLoad | The data value will be represented as a HVACHeatingLoad.
HVACHeatingLoadDividedByArea | The data value will be represented as a HVACHeatingLoadDividedByArea.
HVACHeatingLoadDividedByVolume | The data value will be represented as a HVACHeatingLoadDividedByVolume.
HVACAirflowDividedByVolume | The data value will be represented as a HVACAirflowDividedByVolume.
HVACAirflowDividedByCoolingLoad | The data value will be represented as a HVACAirflowDividedByCoolingLoad.
HVACAreaDividedByCoolingLoad | The data value will be represented as a HVACAreaDividedByCoolingLoad.
WireSize | The data value will be represented as a WireSize.
HVACSlope | The data value will be represented as a HVACSlope.
PipingSlope | The data value will be represented as a PipingSlope.
Currency | The data value will be represented as a Currency.
ElectricalEfficacy | The data value will be represented as an ElectricalEfficacy.
ElectricalWattage | The data value will be represented as an ElectricalWattage.
ColorTemperature | The data value will be represented as a ColorTemperature.
ElectricalLuminousIntensity | The data value will be represented as an ElectricalLuminousIntensity.
ElectricalLuminance | The data value will be represented as an ElectricalLuminance.
HVACAreaDividedByHeatingLoad | The data value will be represented as a HVACAreaDividedByHeatingLoad.
HVACFactor | The data value will be represented as a HVACFactor.
ElectricalTemperature | The data value will be represented as a ElectricalTemperature.
ElectricalCableTraySize | The data value will be represented as a ElectricalCableTraySize.
ElectricalConduitSize | The data value will be represented as a ElectricalConduitSize.
ReinforcementVolume | The data value will be represented as a ReinforcementVolume.
ReinforcementLength | The data value will be represented as a ReinforcementLength.
ElectricalDemandFactor | The data value will be represented as a ElectricalDemandFactor.

See Also


ParameterValueProvider Class

[image]

Revit 2011 API
ParameterValueProvider Class
Members See Also Send Feedback
Gets the value of a parameter from any element passed to getStringValue, getDoubleValue, getIntegerValue, or getElementIdValue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ParameterValueProvider : FilterableValueProvider
Visual Basic (Declaration)
Public Class ParameterValueProvider _
    Inherits FilterableValueProvider
Visual C++
public ref class ParameterValueProvider : public FilterableValueProvider

Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling getStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterableValueProvider
Autodesk.Revit.DB..::.ParameterValueProvider

See Also

ParameterValueProvider Members


ParameterValueProvider Members

[image] [image]

Revit 2011 API
ParameterValueProvider Members
ParameterValueProvider Class Constructors Methods Properties See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Constructors

Name | Description
ParameterValueProvider | Constructs an instance of ParameterValueProvider.

Methods

Name | Description
Dispose | (Inherited from FilterableValueProvider.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Parameter | The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class


ParameterValueProvider Constructor

[image]

Revit 2011 API
ParameterValueProvider Constructor
ParameterValueProvider Class See Also Send Feedback
Constructs an instance of ParameterValueProvider.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ParameterValueProvider(
    ElementId parameter
)
Visual Basic (Declaration)
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
ParameterValueProvider(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::.ElementId
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ParameterValueProvider Class


ParameterValueProvider Methods

[image] [image]

Revit 2011 API
ParameterValueProvider Methods
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterableValueProvider.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValueProvider Class


ParameterValueProvider Properties

[image] [image]

Revit 2011 API
ParameterValueProvider Properties
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Properties

Name | Description
Parameter | The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class


Parameter Property

[image]

Revit 2011 API
ParameterValueProvider..::.Parameter Property
ParameterValueProvider Class See Also Send Feedback
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic (Declaration)
Public Property Parameter As ElementId
Visual C++
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ParameterValueProvider Class


PartType Enumeration

[image]

Revit 2011 API
PartType Enumeration
See Also Send Feedback
An enumerated type listing all the possible part types for a fitting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PartType
Visual Basic (Declaration)
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
UndefinedPartType | The part type is undefined.
Normal | The part type is normal.
DuctMounted | The part type is duct mounted.
JunctionBox | The part type is junction box.
AttachesTo | The part type is attaches to.
BreaksInto | The part type is breaks into.
Elbow | The part type is elbow.
Tee | The part type is tee.
Transition | The part type is transition.
Cross | The part type is cross.
Cap | The part type is cap.
TapPerpendicular | The part type is tap perpendicular.
TapAdjustable | The part type is tap adjustable.
Offset | The part type is offset.
Union | The part type is union.
PanelBoard | The part type is panel board.
Transformer | The part type is transformer.
SwitchBoard | The part type is switch board.
OtherPanel | The part type is other panel.
EquipmentSwitch | The part type is equipment switch.
Switch | The part type is switch.
ValveBreaksInto | The part type is valve breaks into.
SpudPerpendicular | The part type is spud perpendicular.
SpudAdjustable | The part type is spud adjustable.
Damper | The part type is damper.
Wye | The part type is wye.
LateralTee | The part type is lateral tee.
LateralCross | The part type is lateral cross.
Pants | The part type is pants.
MultiPort | The part type is multi port.
ValveNormal | The part type is valve normal.
JunctionBoxTee | The part type is junction box tee.
JunctionBoxCross | The part type is junction box cross.
PipeFlange | The part type is pipe flange.
VerticalElbow | The part type is vertical elbow for cable tray.
JunctionBoxElbow | The part type is junction box elbow.
ChannelCableTrayElbow | The part type is channel cable tray elbow.
ChannelCableTrayVerticalElbow | The part type is channel cable tray vertical elbow.
ChannelCableTrayCross | The part type is channel cable tray cross.
ChannelCableTrayTee | The part type is channel cable tray tee.
ChannelCableTrayTransition | The part type is channel cable tray transition.
ChannelCableTrayUnion | The part type is channel cable tray union.
ChannelCableTrayOffset | The part type is channel cable tray offset.
ChannelCableTrayMultiPort | The part type is channel cable tray multi-port.
LadderCableTrayElbow | The part type is ladder cable tray elbow.
LadderCableTrayVerticalElbow | The part type is ladder cable tray vertical elbow.
LadderCableTrayCross | The part type is ladder cable tray cross.
LadderCableTrayTee | The part type is ladder cable tee.
LadderCableTrayTransition | The part type is ladder cable tray transition.
LadderCableTrayUnion | The part type is ladder cable tray union.
LadderCableTrayOffset | The part type is ladder cable tray offset.
LadderCableTrayMultiPort | The part type is ladder cable tray multi-port.
InlineSensor | The part type is inline sensor.
Sensor | The part type is sensor.

See Also


Path3d Class

[image]

Revit 2011 API
Path3d Class
Members See Also Send Feedback
Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Path3d : SketchBase
Visual Basic (Declaration)
Public Class Path3d _
    Inherits SketchBase
Visual C++
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.Path3d

See Also

Path3d Members


Path3d Members

[image] [image]

Revit 2011 API
Path3d Members
Path3d Class Methods Properties See Also Send Feedback

The Path3d type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllCurveLoops | Get all the Curve Loops of Path3d.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveLoop | Get the Curve Loop of Path3d via index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurveLoops | Get the Number of Curve Loops of Path3d.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Path3d Class


Path3d Methods

[image] [image]

Revit 2011 API
Path3d Methods
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Path3d Class


Path3d Properties

[image] [image]

Revit 2011 API
Path3d Properties
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Properties

Name | Description
AllCurveLoops | Get all the Curve Loops of Path3d.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveLoop | Get the Curve Loop of Path3d via index.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurveLoops | Get the Number of Curve Loops of Path3d.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Path3d Class


AllCurveLoops Property

[image]

Revit 2011 API
Path3d..::.AllCurveLoops Property
Path3d Class See Also Send Feedback
Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray AllCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllCurveLoops As CurveArrArray
Visual C++
public:
property CurveArrArray^ AllCurveLoops {
    CurveArrArray^ get ();
}

Remarks

Returns all the Curve Loops of Path3d.

See Also

Path3d Class


CurveLoop Property

[image]

Revit 2011 API
Path3d..::.CurveLoop Property
Path3d Class See Also Send Feedback
Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray CurveLoop[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Type: System..::.Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class


NumCurveLoops Property

[image]

Revit 2011 API
Path3d..::.NumCurveLoops Property
Path3d Class See Also Send Feedback
Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumCurveLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurveLoops As Integer
Visual C++
public:
property int NumCurveLoops {
    int get ();
}

Remarks

Returns the Number of Curve Loops of Path3d.

See Also

Path3d Class


Parameter Property

[image] [image]

Revit 2011 API
Path3d..::.Parameter Property
Path3d Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Path3d Class
Path3d Members


Phase Class

[image]

Revit 2011 API
Phase Class
Members See Also Send Feedback
Represents a phase in the life of a building.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Phase : Element
Visual Basic (Declaration)
Public Class Phase _
    Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Phase

See Also

Phase Members


Phase Members

[image] [image]

Revit 2011 API
Phase Members
Phase Class Methods Properties See Also Send Feedback

The Phase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Phase Class


Phase Methods

[image] [image]

Revit 2011 API
Phase Methods
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Phase Class


Phase Properties

[image] [image]

Revit 2011 API
Phase Properties
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Phase Class


Parameter Property

[image] [image]

Revit 2011 API
Phase..::.Parameter Property
Phase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Phase Class
Phase Members


PhaseArray Class

[image]

Revit 2011 API
PhaseArray Class
Members See Also Send Feedback
An array that contains phase objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PhaseArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class PhaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PhaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PhaseArray

See Also

PhaseArray Members


PhaseArray Members

[image] [image]

Revit 2011 API
PhaseArray Members
PhaseArray Class Constructors Methods Properties See Also Send Feedback

The PhaseArray type exposes the following members.

Constructors

Name | Description
PhaseArray | Initializes a new instance of the PhaseArray class

Methods

Name | Description
Append | Add the phase to the end of the array.
Clear | Removes every phase from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified phase into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a phase at a specified index within the array.
Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class


PhaseArray Constructor

[image]

Revit 2011 API
PhaseArray Constructor
PhaseArray Class See Also Send Feedback
Initializes a new instance of the PhaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PhaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArray()

See Also

PhaseArray Class


PhaseArray Methods

[image] [image]

Revit 2011 API
PhaseArray Methods
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Methods

Name | Description
Append | Add the phase to the end of the array.
Clear | Removes every phase from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified phase into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArray Class


Append Method

[image]

Revit 2011 API
PhaseArray..::.Append Method
PhaseArray Class See Also Send Feedback
Add the phase to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Phase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Phase _
)
Visual C++
public:
virtual void Append(
    Phase^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Phase
The phase to be added.

See Also

PhaseArray Class


Clear Method

[image]

Revit 2011 API
PhaseArray..::.Clear Method
PhaseArray Class See Also Send Feedback
Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PhaseArray Class


ForwardIterator Method

[image]

Revit 2011 API
PhaseArray..::.ForwardIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class


GetEnumerator Method

[image]

Revit 2011 API
PhaseArray..::.GetEnumerator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PhaseArray Class


Insert Method

[image]

Revit 2011 API
PhaseArray..::.Insert Method
PhaseArray Class See Also Send Feedback
Insert the specified phase into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Phase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Phase
The phase to be inserted into the array.
index
Type: System..::.Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class


ReverseIterator Method

[image]

Revit 2011 API
PhaseArray..::.ReverseIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

PhaseArray Class


PhaseArray Properties

[image] [image]

Revit 2011 API
PhaseArray Properties
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a phase at a specified index within the array.
Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class


IsEmpty Property

[image]

Revit 2011 API
PhaseArray..::.IsEmpty Property
PhaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PhaseArray Class


Item Property

[image]

Revit 2011 API
PhaseArray..::.Item Property
PhaseArray Class See Also Send Feedback
Gets or sets a phase at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Phase Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Phase
Visual C++
public:
virtual property Phase^ Item[int index] {
    Phase^ get (int index);
    void set (int index, Phase^ value);
}

Parameters

index
Type: System..::.Int32
The index of the phase to be set or retrieved.

Return Value

Returns the phase at the specified index.

See Also

PhaseArray Class


Size Property

[image]

Revit 2011 API
PhaseArray..::.Size Property
PhaseArray Class See Also Send Feedback
Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PhaseArray Class


PhaseArrayIterator Class

[image]

Revit 2011 API
PhaseArrayIterator Class
Members See Also Send Feedback
An iterator to a phase array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PhaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PhaseArrayIterator

See Also

PhaseArrayIterator Members


PhaseArrayIterator Members

[image] [image]

Revit 2011 API
PhaseArrayIterator Members
PhaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Constructors

Name | Description
PhaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class


PhaseArrayIterator Constructor

[image]

Revit 2011 API
PhaseArrayIterator Constructor
PhaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PhaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PhaseArrayIterator Class


PhaseArrayIterator Methods

[image] [image]

Revit 2011 API
PhaseArrayIterator Methods
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
PhaseArrayIterator..::.MoveNext Method
PhaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


Reset Method

[image]

Revit 2011 API
PhaseArrayIterator..::.Reset Method
PhaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PhaseArrayIterator Class


PhaseArrayIterator Properties

[image] [image]

Revit 2011 API
PhaseArrayIterator Properties
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class


Current Property

[image]

Revit 2011 API
PhaseArrayIterator..::.Current Property
PhaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


PlanarFace Class

[image]

Revit 2011 API
PlanarFace Class
Members Example See Also Send Feedback
A planar face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PlanarFace : Face
Visual Basic (Declaration)
Public Class PlanarFace _
    Inherits Face
Visual C++
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parameterization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Examples

CopyC#
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
       XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.Normal;
        XYZ vector = planarFace.get_Vector(0);
    }
}
CopyVB.NET
Private Sub GetPlanarFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
    If planarFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = planarFace.Origin
        Dim normal As Autodesk.Revit.DB.XYZ = planarFace.Normal
        Dim vector As Autodesk.Revit.DB.XYZ = planarFace.Vector(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.PlanarFace

See Also

PlanarFace Members


PlanarFace Members

[image] [image]

Revit 2011 API
PlanarFace Members
PlanarFace Class Methods Properties See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Normal | Normal of the surface.
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Reference | Returns a stable reference to the face. (Inherited from Face.)
Vector | Defining vectors of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class


PlanarFace Methods

[image] [image]

Revit 2011 API
PlanarFace Methods
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

PlanarFace Class


Intersect Method

[image] [image]

Revit 2011 API
PlanarFace..::.Intersect Method
PlanarFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


IsInside Method

[image] [image]

Revit 2011 API
PlanarFace..::.IsInside Method
PlanarFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


PlanarFace Properties

[image] [image]

Revit 2011 API
PlanarFace Properties
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Normal | Normal of the surface.
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Reference | Returns a stable reference to the face. (Inherited from Face.)
Vector | Defining vectors of the surface.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class


Normal Property

[image]

Revit 2011 API
PlanarFace..::.Normal Property
PlanarFace Class See Also Send Feedback
Normal of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

PlanarFace Class


Origin Property

[image]

Revit 2011 API
PlanarFace..::.Origin Property
PlanarFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

PlanarFace Class


Vector Property

[image]

Revit 2011 API
PlanarFace..::.Vector Property
PlanarFace Class See Also Send Feedback
Defining vectors of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Vector[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vector ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Vector[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PlanarFace Class


PlanCircuit Class

[image]

Revit 2011 API
PlanCircuit Class
Members See Also Send Feedback
An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PlanCircuit : APIObject
Visual Basic (Declaration)
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanCircuit

See Also

PlanCircuit Members


PlanCircuit Members

[image] [image]

Revit 2011 API
PlanCircuit Members
PlanCircuit Class Methods Properties See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | The enclosed area of the circuit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRoomLocated | Reports whether there is a room located in this circuit.
SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


PlanCircuit Methods

[image] [image]

Revit 2011 API
PlanCircuit Methods
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuit Class


PlanCircuit Properties

[image] [image]

Revit 2011 API
PlanCircuit Properties
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Properties

Name | Description
Area | The enclosed area of the circuit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsRoomLocated | Reports whether there is a room located in this circuit.
SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


Area Property

[image]

Revit 2011 API
PlanCircuit..::.Area Property
PlanCircuit Class See Also Send Feedback
The enclosed area of the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

See Also

PlanCircuit Class


IsRoomLocated Property

[image]

Revit 2011 API
PlanCircuit..::.IsRoomLocated Property
PlanCircuit Class See Also Send Feedback
Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsRoomLocated { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRoomLocated As Boolean
Visual C++
public:
property bool IsRoomLocated {
    bool get ();
}

Field Value

True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.

See Also

PlanCircuit Class


SideNum Property

[image]

Revit 2011 API
PlanCircuit..::.SideNum Property
PlanCircuit Class See Also Send Feedback
The number of sides in the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int SideNum { get; }
Visual Basic (Declaration)
Public ReadOnly Property SideNum As Integer
Visual C++
public:
property int SideNum {
    int get ();
}

See Also

PlanCircuit Class


PlanCircuitSet Class

[image]

Revit 2011 API
PlanCircuitSet Class
Members See Also Send Feedback
A set that can contain any number of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PlanCircuitSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PlanCircuitSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanCircuitSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanCircuitSet

See Also

PlanCircuitSet Members


PlanCircuitSet Members

[image] [image]

Revit 2011 API
PlanCircuitSet Members
PlanCircuitSet Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Constructors

Name | Description
PlanCircuitSet | Initializes a new instance of the PlanCircuitSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Constructor

[image]

Revit 2011 API
PlanCircuitSet Constructor
PlanCircuitSet Class See Also Send Feedback
Initializes a new instance of the PlanCircuitSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanCircuitSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSet()

See Also

PlanCircuitSet Class


PlanCircuitSet Methods

[image] [image]

Revit 2011 API
PlanCircuitSet Methods
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSet Class


Clear Method

[image]

Revit 2011 API
PlanCircuitSet..::.Clear Method
PlanCircuitSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanCircuitSet Class


Contains Method

[image]

Revit 2011 API
PlanCircuitSet..::.Contains Method
PlanCircuitSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanCircuit
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanCircuitSet Class


Erase Method

[image]

Revit 2011 API
PlanCircuitSet..::.Erase Method
PlanCircuitSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanCircuit _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanCircuit
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanCircuitSet Class


ForwardIterator Method

[image]

Revit 2011 API
PlanCircuitSet..::.ForwardIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class


GetEnumerator Method

[image]

Revit 2011 API
PlanCircuitSet..::.GetEnumerator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PlanCircuitSet Class


Insert Method

[image]

Revit 2011 API
PlanCircuitSet..::.Insert Method
PlanCircuitSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanCircuit item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanCircuit
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanCircuitSet Class


ReverseIterator Method

[image]

Revit 2011 API
PlanCircuitSet..::.ReverseIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Properties

[image] [image]

Revit 2011 API
PlanCircuitSet Properties
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


IsEmpty Property

[image]

Revit 2011 API
PlanCircuitSet..::.IsEmpty Property
PlanCircuitSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanCircuitSet Class


Size Property

[image]

Revit 2011 API
PlanCircuitSet..::.Size Property
PlanCircuitSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanCircuitSet Class


PlanCircuitSetIterator Class

[image]

Revit 2011 API
PlanCircuitSetIterator Class
Members See Also Send Feedback
An iterator to a set of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PlanCircuitSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanCircuitSetIterator

See Also

PlanCircuitSetIterator Members


PlanCircuitSetIterator Members

[image] [image]

Revit 2011 API
PlanCircuitSetIterator Members
PlanCircuitSetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Constructors

Name | Description
PlanCircuitSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Constructor

[image]

Revit 2011 API
PlanCircuitSetIterator Constructor
PlanCircuitSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanCircuitSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanCircuitSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Methods

[image] [image]

Revit 2011 API
PlanCircuitSetIterator Methods
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSetIterator Class


MoveNext Method

[image]

Revit 2011 API
PlanCircuitSetIterator..::.MoveNext Method
PlanCircuitSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class


Reset Method

[image]

Revit 2011 API
PlanCircuitSetIterator..::.Reset Method
PlanCircuitSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Properties

[image] [image]

Revit 2011 API
PlanCircuitSetIterator Properties
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


Current Property

[image]

Revit 2011 API
PlanCircuitSetIterator..::.Current Property
PlanCircuitSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class


Plane Class

[image]

Revit 2011 API
Plane Class
Members Example See Also Send Feedback
Provides access to the geometry plane object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Plane : APIObject
Visual Basic (Declaration)
Public Class Plane _
    Inherits APIObject
Visual C++
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Examples

CopyC#
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    TaskDialog.Show("Revit",info.ToString());
}
CopyVB.NET
Public Sub GetPlaneInfo(ByVal plane As Autodesk.Revit.DB.Plane)
    Dim origin As Autodesk.Revit.DB.XYZ = plane.Origin
    Dim normal As Autodesk.Revit.DB.XYZ = plane.Normal
    Dim xVec As Autodesk.Revit.DB.XYZ = plane.XVec
    Dim yVec As Autodesk.Revit.DB.XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    TaskDialog.Show("Revit", info.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Plane

See Also

Plane Members


Plane Members

[image] [image]

Revit 2011 API
Plane Members
Plane Class Constructors Methods Properties See Also Send Feedback

The Plane type exposes the following members.

Constructors

Name | Description
Plane | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Normal | Get the Normal of the plane.
Origin | Get the Origin of the plane.
XVec | Get the XVec of the plane.
YVec | Get the YVec of the plane.

See Also

Plane Class


Plane Constructor

[image] [image]

Revit 2011 API
Plane Constructor
Plane Class See Also Send Feedback

Overload List

Name | Description
Plane(XYZ, XYZ) | Constructor for geometry plane.
Plane(XYZ, XYZ, XYZ) | Constructor for geometry plane.

See Also

Plane Class
Plane Members


Plane Constructor (XYZ, XYZ)

[image]

Revit 2011 API
Plane Constructor (XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.DB..::.XYZ
The normal vector of the plane.
origin
Type: Autodesk.Revit.DB..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload


Plane Constructor (XYZ, XYZ, XYZ)

[image]

Revit 2011 API
Plane Constructor (XYZ, XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic (Declaration)
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.DB..::.XYZ
The vector for x-axis.
yVec
Type: Autodesk.Revit.DB..::.XYZ
The vector for y-axis.
origin
Type: Autodesk.Revit.DB..::.XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload


Plane Methods

[image] [image]

Revit 2011 API
Plane Methods
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Plane Class


Plane Properties

[image] [image]

Revit 2011 API
Plane Properties
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Normal | Get the Normal of the plane.
Origin | Get the Origin of the plane.
XVec | Get the XVec of the plane.
YVec | Get the YVec of the plane.

See Also

Plane Class


Normal Property

[image]

Revit 2011 API
Plane..::.Normal Property
Plane Class See Also Send Feedback
Get the Normal of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is used to get the Normal of the plane.

See Also

Plane Class


Origin Property

[image]

Revit 2011 API
Plane..::.Origin Property
Plane Class See Also Send Feedback
Get the Origin of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to get the Origin of the plane.

See Also

Plane Class


XVec Property

[image]

Revit 2011 API
Plane..::.XVec Property
Plane Class See Also Send Feedback
Get the XVec of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ XVec { get; }
Visual Basic (Declaration)
Public ReadOnly Property XVec As XYZ
Visual C++
public:
property XYZ^ XVec {
    XYZ^ get ();
}

Remarks

This property is used to get the XVec of the plane.

See Also

Plane Class


YVec Property

[image]

Revit 2011 API
Plane..::.YVec Property
Plane Class See Also Send Feedback
Get the YVec of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ YVec { get; }
Visual Basic (Declaration)
Public ReadOnly Property YVec As XYZ
Visual C++
public:
property XYZ^ YVec {
    XYZ^ get ();
}

Remarks

This property is used to get the YVec of the plane.

See Also

Plane Class


PlanTopology Class

[image]

Revit 2011 API
PlanTopology Class
Members See Also Send Feedback
An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PlanTopology : APIObject
Visual Basic (Declaration)
Public Class PlanTopology _
    Inherits APIObject
Visual C++
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanTopology

See Also

PlanTopology Members


PlanTopology Members

[image] [image]

Revit 2011 API
PlanTopology Members
PlanTopology Class Methods Properties See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Circuits | Retrieves Circuits of the PlanTopology.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | Retrieves Level of the PlanTopology.
Phase | Retrieves the phase of the PlanTopology.
Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class


PlanTopology Methods

[image] [image]

Revit 2011 API
PlanTopology Methods
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopology Class


PlanTopology Properties

[image] [image]

Revit 2011 API
PlanTopology Properties
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Properties

Name | Description
Circuits | Retrieves Circuits of the PlanTopology.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Level | Retrieves Level of the PlanTopology.
Phase | Retrieves the phase of the PlanTopology.
Rooms | Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class


Circuits Property

[image]

Revit 2011 API
PlanTopology..::.Circuits Property
PlanTopology Class See Also Send Feedback
Retrieves Circuits of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanCircuitSet Circuits { get; }
Visual Basic (Declaration)
Public ReadOnly Property Circuits As PlanCircuitSet
Visual C++
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}

See Also

PlanTopology Class


Level Property

[image]

Revit 2011 API
PlanTopology..::.Level Property
PlanTopology Class See Also Send Feedback
Retrieves Level of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Level
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

See Also

PlanTopology Class


Phase Property

[image]

Revit 2011 API
PlanTopology..::.Phase Property
PlanTopology Class See Also Send Feedback
Retrieves the phase of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

See Also

PlanTopology Class


Rooms Property

[image]

Revit 2011 API
PlanTopology..::.Rooms Property
PlanTopology Class See Also Send Feedback
Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet Rooms { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rooms As ElementSet
Visual C++
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms you get here is in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class


PlanTopologySet Class

[image]

Revit 2011 API
PlanTopologySet Class
Members See Also Send Feedback
A set that can contain any number of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PlanTopologySet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PlanTopologySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanTopologySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanTopologySet

See Also

PlanTopologySet Members


PlanTopologySet Members

[image] [image]

Revit 2011 API
PlanTopologySet Members
PlanTopologySet Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySet type exposes the following members.

Constructors

Name | Description
PlanTopologySet | Initializes a new instance of the PlanTopologySet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


PlanTopologySet Constructor

[image]

Revit 2011 API
PlanTopologySet Constructor
PlanTopologySet Class See Also Send Feedback
Initializes a new instance of the PlanTopologySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySet()

See Also

PlanTopologySet Class


PlanTopologySet Methods

[image] [image]

Revit 2011 API
PlanTopologySet Methods
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains | Tests for the existence of an item within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified object from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySet Class


Clear Method

[image]

Revit 2011 API
PlanTopologySet..::.Clear Method
PlanTopologySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanTopologySet Class


Contains Method

[image]

Revit 2011 API
PlanTopologySet..::.Contains Method
PlanTopologySet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanTopology
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanTopologySet Class


Erase Method

[image]

Revit 2011 API
PlanTopologySet..::.Erase Method
PlanTopologySet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PlanTopology _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanTopology
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanTopologySet Class


ForwardIterator Method

[image]

Revit 2011 API
PlanTopologySet..::.ForwardIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class


GetEnumerator Method

[image]

Revit 2011 API
PlanTopologySet..::.GetEnumerator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PlanTopologySet Class


Insert Method

[image]

Revit 2011 API
PlanTopologySet..::.Insert Method
PlanTopologySet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanTopology item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.PlanTopology
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanTopologySet Class


ReverseIterator Method

[image]

Revit 2011 API
PlanTopologySet..::.ReverseIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanTopologySet Class


PlanTopologySet Properties

[image] [image]

Revit 2011 API
PlanTopologySet Properties
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


IsEmpty Property

[image]

Revit 2011 API
PlanTopologySet..::.IsEmpty Property
PlanTopologySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanTopologySet Class


Size Property

[image]

Revit 2011 API
PlanTopologySet..::.Size Property
PlanTopologySet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanTopologySet Class


PlanTopologySetIterator Class

[image]

Revit 2011 API
PlanTopologySetIterator Class
Members See Also Send Feedback
An iterator to a set of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PlanTopologySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PlanTopologySetIterator

See Also

PlanTopologySetIterator Members


PlanTopologySetIterator Members

[image] [image]

Revit 2011 API
PlanTopologySetIterator Members
PlanTopologySetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Constructors

Name | Description
PlanTopologySetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Constructor

[image]

Revit 2011 API
PlanTopologySetIterator Constructor
PlanTopologySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PlanTopologySetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlanTopologySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Methods

[image] [image]

Revit 2011 API
PlanTopologySetIterator Methods
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySetIterator Class


MoveNext Method

[image]

Revit 2011 API
PlanTopologySetIterator..::.MoveNext Method
PlanTopologySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


Reset Method

[image]

Revit 2011 API
PlanTopologySetIterator..::.Reset Method
PlanTopologySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Properties

[image] [image]

Revit 2011 API
PlanTopologySetIterator Properties
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


Current Property

[image]

Revit 2011 API
PlanTopologySetIterator..::.Current Property
PlanTopologySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


Point Class

[image]

Revit 2011 API
Point Class
Members See Also Send Feedback
A 3D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Point : GeometryObject
Visual Basic (Declaration)
Public Class Point _
    Inherits GeometryObject
Visual C++
public ref class Point : public GeometryObject

Remarks

The point lies at a given XYZ coordinate location.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Point

See Also

Point Members


Point Members

[image] [image]

Revit 2011 API
Point Members
Point Class Methods Properties See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Coord | Returns the coordinates of the point.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the point.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class


Point Methods

[image] [image]

Revit 2011 API
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class


Point Properties

[image] [image]

Revit 2011 API
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

Name | Description
Coord | Returns the coordinates of the point.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Reference | Returns a stable reference to the point.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class


Coord Property

[image]

Revit 2011 API
Point..::.Coord Property
Point Class See Also Send Feedback
Returns the coordinates of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Coord { get; }
Visual Basic (Declaration)
Public ReadOnly Property Coord As XYZ
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
}

See Also

Point Class


Reference Property

[image]

Revit 2011 API
Point..::.Reference Property
Point Class See Also Send Feedback
Returns a stable reference to the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Point Class


PointElementReference Class

[image]

Revit 2011 API
PointElementReference Class
Members See Also Send Feedback
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PointElementReference
Visual Basic (Declaration)
Public MustInherit Class PointElementReference
Visual C++
public ref class PointElementReference abstract

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnEdge
Autodesk.Revit.DB..::.PointOnEdgeEdgeIntersection
Autodesk.Revit.DB..::.PointOnEdgeFaceIntersection
Autodesk.Revit.DB..::.PointOnFace
Autodesk.Revit.DB..::.PointOnPlane

See Also

PointElementReference Members


PointElementReference Members

[image] [image]

Revit 2011 API
PointElementReference Members
PointElementReference Class Constructors Methods See Also Send Feedback

The PointElementReference type exposes the following members.

Constructors

Name | Description
PointElementReference | Initializes a new instance of the PointElementReference class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class


PointElementReference Constructor

[image]

Revit 2011 API
PointElementReference Constructor
PointElementReference Class See Also Send Feedback
Initializes a new instance of the PointElementReference class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointElementReference()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointElementReference()

See Also

PointElementReference Class


PointElementReference Methods

[image] [image]

Revit 2011 API
PointElementReference Methods
PointElementReference Class See Also Send Feedback

The PointElementReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class


PointOnEdge Class

[image]

Revit 2011 API
PointOnEdge Class
Members See Also Send Feedback
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdge _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnEdge

See Also

PointOnEdge Members


PointOnEdge Members

[image] [image]

Revit 2011 API
PointOnEdge Members
PointOnEdge Class Methods Properties See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveParameter | Parameter along the curve.

See Also

PointOnEdge Class


PointOnEdge Methods

[image] [image]

Revit 2011 API
PointOnEdge Methods
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdge Class


GetEdgeReference Method

[image]

Revit 2011 API
PointOnEdge..::.GetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic (Declaration)
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdge Class


SetEdgeReference Method

[image]

Revit 2011 API
PointOnEdge..::.SetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference ( _
    reference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdge Class


PointOnEdge Properties

[image] [image]

Revit 2011 API
PointOnEdge Properties
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Properties

Name | Description
CurveParameter | Parameter along the curve.

See Also

PointOnEdge Class


CurveParameter Property

[image]

Revit 2011 API
PointOnEdge..::.CurveParameter Property
PointOnEdge Class See Also Send Feedback
Parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CurveParameter { get; set; }
Visual Basic (Declaration)
Public Property CurveParameter As Double
Visual C++
public:
property double CurveParameter {
    double get ();
    void set (double value);
}

Remarks

Ranges from 0.0 to 1.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if CurveParameter is less than 0.0 or greater than 1.0.

See Also

PointOnEdge Class


PointOnEdgeEdgeIntersection Class

[image]

Revit 2011 API
PointOnEdgeEdgeIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnEdgeEdgeIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeEdgeIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeEdgeIntersection : public PointElementReference

Remarks

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnEdgeEdgeIntersection

See Also

PointOnEdgeEdgeIntersection Members


PointOnEdgeEdgeIntersection Members

[image] [image]

Revit 2011 API
PointOnEdgeEdgeIntersection Members
PointOnEdgeEdgeIntersection Class Methods See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference1 | Get a copy of the first edge or curve reference.
GetEdgeReference2 | Get a copy of the second edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference1 | Change the first edge or curve reference.
SetEdgeReference2 | Change the second edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection Methods

[image] [image]

Revit 2011 API
PointOnEdgeEdgeIntersection Methods
PointOnEdgeEdgeIntersection Class See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference1 | Get a copy of the first edge or curve reference.
GetEdgeReference2 | Get a copy of the second edge or curve reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference1 | Change the first edge or curve reference.
SetEdgeReference2 | Change the second edge or curve reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class


GetEdgeReference1 Method

[image]

Revit 2011 API
PointOnEdgeEdgeIntersection..::.GetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetEdgeReference1()
Visual Basic (Declaration)
Public Function GetEdgeReference1 As Reference
Visual C++
public:
Reference^ GetEdgeReference1()

See Also

PointOnEdgeEdgeIntersection Class


GetEdgeReference2 Method

[image]

Revit 2011 API
PointOnEdgeEdgeIntersection..::.GetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetEdgeReference2()
Visual Basic (Declaration)
Public Function GetEdgeReference2 As Reference
Visual C++
public:
Reference^ GetEdgeReference2()

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference1 Method

[image]

Revit 2011 API
PointOnEdgeEdgeIntersection..::.SetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetEdgeReference1(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference1 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference1(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference2 Method

[image]

Revit 2011 API
PointOnEdgeEdgeIntersection..::.SetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetEdgeReference2(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference2 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference2(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


PointOnEdgeFaceIntersection Class

[image]

Revit 2011 API
PointOnEdgeFaceIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnEdgeFaceIntersection : PointElementReference
Visual Basic (Declaration)
Public Class PointOnEdgeFaceIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeFaceIntersection : public PointElementReference

Remarks

The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnEdgeFaceIntersection

See Also

PointOnEdgeFaceIntersection Members


PointOnEdgeFaceIntersection Members

[image] [image]

Revit 2011 API
PointOnEdgeFaceIntersection Members
PointOnEdgeFaceIntersection Class Methods Properties See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Methods

[image] [image]

Revit 2011 API
PointOnEdgeFaceIntersection Methods
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEdgeReference | Get a copy of the edge or curve reference.
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetEdgeReference | Change the edge or curve reference.
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeFaceIntersection Class


GetEdgeReference Method

[image]

Revit 2011 API
PointOnEdgeFaceIntersection..::.GetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic (Declaration)
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdgeFaceIntersection Class


GetFaceReference Method

[image]

Revit 2011 API
PointOnEdgeFaceIntersection..::.GetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic (Declaration)
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnEdgeFaceIntersection Class


SetEdgeReference Method

[image]

Revit 2011 API
PointOnEdgeFaceIntersection..::.SetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference edgeReference
)
Visual Basic (Declaration)
Public Sub SetEdgeReference ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdgeFaceIntersection Class


SetFaceReference Method

[image]

Revit 2011 API
PointOnEdgeFaceIntersection..::.SetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Properties

[image] [image]

Revit 2011 API
PointOnEdgeFaceIntersection Properties
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Properties

Name | Description
OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


OrientWithEdge Property

[image]

Revit 2011 API
PointOnEdgeFaceIntersection..::.OrientWithEdge Property
PointOnEdgeFaceIntersection Class See Also Send Feedback
Whether to orient the ReferencePoint to the edge or the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool OrientWithEdge { get; set; }
Visual Basic (Declaration)
Public Property OrientWithEdge As Boolean
Visual C++
public:
property bool OrientWithEdge {
    bool get ();
    void set (bool value);
}

Remarks

If true, the X basis vector will be parallel to the edge. If false, the X and Y basis vectors will be parallel to the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnFace Class

[image]

Revit 2011 API
PointOnFace Class
Members See Also Send Feedback
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic (Declaration)
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnFace

See Also

PointOnFace Members


PointOnFace Members

[image] [image]

Revit 2011 API
PointOnFace Members
PointOnFace Class Methods Properties See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


PointOnFace Methods

[image] [image]

Revit 2011 API
PointOnFace Methods
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFaceReference | Get a copy of the face reference.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetFaceReference | Change the face reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnFace Class


GetFaceReference Method

[image]

Revit 2011 API
PointOnFace..::.GetFaceReference Method
PointOnFace Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic (Declaration)
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnFace Class


SetFaceReference Method

[image]

Revit 2011 API
PointOnFace..::.SetFaceReference Method
PointOnFace Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic (Declaration)
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnFace Class


PointOnFace Properties

[image] [image]

Revit 2011 API
PointOnFace Properties
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Properties

Name | Description
UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


UV Property

[image]

Revit 2011 API
PointOnFace..::.UV Property
PointOnFace Class See Also Send Feedback
The location of the point in the surface's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV UV { get; set; }
Visual Basic (Declaration)
Public Property UV As UV
Visual C++
public:
property UV^ UV {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnFace Class


PointOnPlane Class

[image]

Revit 2011 API
PointOnPlane Class
Members See Also Send Feedback
Define a ReferencePoint relative to a planar reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointOnPlane : PointElementReference
Visual Basic (Declaration)
Public Class PointOnPlane _
    Inherits PointElementReference
Visual C++
public ref class PointOnPlane : public PointElementReference

Remarks

A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.PointElementReference
Autodesk.Revit.DB..::.PointOnPlane

See Also

PointOnPlane Members


PointOnPlane Members

[image] [image]

Revit 2011 API
PointOnPlane Members
PointOnPlane Class Methods Properties See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPlaneReference | The geometric plane reference.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
SetPlaneReference | Change the geometric plane reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Offset | Signed offset from the plane.
Position | The coordinates of the point (or its projection) on the plane.
XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


PointOnPlane Methods

[image] [image]

Revit 2011 API
PointOnPlane Methods
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPlaneReference | The geometric plane reference.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
SetPlaneReference | Change the geometric plane reference.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnPlane Class


GetPlaneReference Method

[image]

Revit 2011 API
PointOnPlane..::.GetPlaneReference Method
PointOnPlane Class See Also Send Feedback
The geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetPlaneReference()
Visual Basic (Declaration)
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

Return Value

A copy of the reference stored in the PointOnPlane object.

See Also

PointOnPlane Class


IsValidPlaneReference Method

[image]

Revit 2011 API
PointOnPlane..::.IsValidPlaneReference Method
PointOnPlane Class See Also Send Feedback
Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Visual Basic (Declaration)
Public Shared Function IsValidPlaneReference ( _
    doc As Document, _
    planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
planeReference
Type: Autodesk.Revit.DB..::.Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.

See Also

PointOnPlane Class


NewPointOnPlane Method

[image]

Revit 2011 API
PointOnPlane..::.NewPointOnPlane Method
PointOnPlane Class See Also Send Feedback
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic (Declaration)
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.DB..::.Reference
position
Type: Autodesk.Revit.DB..::.XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.DB..::.XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class


SetPlaneReference Method

[image]

Revit 2011 API
PointOnPlane..::.SetPlaneReference Method
PointOnPlane Class See Also Send Feedback
Change the geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetPlaneReference(
    Reference planeReference
)
Visual Basic (Declaration)
Public Sub SetPlaneReference ( _
    planeReference As Reference _
)
Visual C++
public:
void SetPlaneReference(
    Reference^ planeReference
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::.Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)

See Also

PointOnPlane Class


PointOnPlane Properties

[image] [image]

Revit 2011 API
PointOnPlane Properties
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Properties

Name | Description
Offset | Signed offset from the plane.
Position | The coordinates of the point (or its projection) on the plane.
XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


Offset Property

[image]

Revit 2011 API
PointOnPlane..::.Offset Property
PointOnPlane Class See Also Send Feedback
Signed offset from the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

The point's position is offset in the direction of the normal vector returned by the Plane.Normal property.

See Also

PointOnPlane Class


Position Property

[image]

Revit 2011 API
PointOnPlane..::.Position Property
PointOnPlane Class See Also Send Feedback
The coordinates of the point (or its projection) on the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Position { get; set; }
Visual Basic (Declaration)
Public Property Position As UV
Visual C++
public:
property UV^ Position {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


XVec Property

[image]

Revit 2011 API
PointOnPlane..::.XVec Property
PointOnPlane Class See Also Send Feedback
The X-coordinate vector of the point, in the plane's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV XVec { get; set; }
Visual Basic (Declaration)
Public Property XVec As UV
Visual C++
public:
property UV^ XVec {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


PrimaryDesignOptionMemberFilter Class

[image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class PrimaryDesignOptionMemberFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter();

// Apply the filter to the elements in the active document
// Use shortcut command OfClass() to only find wall instances
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements();

// Find walls not contained within primary design options: Use inverted filter to match walls
PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notPrimaryDesignOptFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();
CopyVB.NET
' Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
Dim filter As New PrimaryDesignOptionMemberFilter()

' Apply the filter to the elements in the active document
' Use shortcut command OfClass() to only find wall instances
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim wallsOfPrimaryOpt As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(filter).ToElements()

' Find walls not contained within primary design options: Use inverted filter to match walls
Dim notPrimaryOptFilter As New PrimaryDesignOptionMemberFilter(True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notPrimaryDesignOptFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(notPrimaryOptFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB..::.PrimaryDesignOptionMemberFilter

See Also

PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Members

[image] [image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Members
PrimaryDesignOptionMemberFilter Class Constructors Methods Properties See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors

Name | Description
PrimaryDesignOptionMemberFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Constructor

[image] [image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

Overload List

Name | Description
PrimaryDesignOptionMemberFilter()()() | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Constructor

[image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrimaryDesignOptionMemberFilter()

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Constructor (Boolean)

[image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Constructor (Boolean)
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter(
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
PrimaryDesignOptionMemberFilter(
    bool inverted
)

Parameters

inverted
Type: System..::.Boolean
True if the filter should match all elements which are not contained within a particular design option.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Methods

[image] [image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Methods
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Properties

[image] [image]

Revit 2011 API
PrimaryDesignOptionMemberFilter Properties
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrintManager Class

[image]

Revit 2011 API
PrintManager Class
Members See Also Send Feedback
The PrintManager object is used to configure the global print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PrintManager : APIObject
Visual Basic (Declaration)
Public Class PrintManager _
    Inherits APIObject
Visual C++
public ref class PrintManager : public APIObject

Remarks

Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PrintManager

See Also

PrintManager Members


PrintManager Members

[image] [image]

Revit 2011 API
PrintManager Members
PrintManager Class Methods Properties See Also Send Feedback

The PrintManager type exposes the following members.

Methods

Name | Description
Apply | Apply the local print settings to global for all documents.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SelectNewPrintDriver | Select a new printer.
SubmitPrint | Overloaded. Print with the current PrintManager settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current document.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class


PrintManager Methods

[image] [image]

Revit 2011 API
PrintManager Methods
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Methods

Name | Description
Apply | Apply the local print settings to global for all documents.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SelectNewPrintDriver | Select a new printer.
SubmitPrint | Overloaded. Print with the current PrintManager settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintManager Class


Apply Method

[image]

Revit 2011 API
PrintManager..::.Apply Method
PrintManager Class See Also Send Feedback
Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Apply()
Visual Basic (Declaration)
Public Sub Apply
Visual C++
public:
void Apply()

Remarks

This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class


SelectNewPrintDriver Method

[image]

Revit 2011 API
PrintManager..::.SelectNewPrintDriver Method
PrintManager Class See Also Send Feedback
Select a new printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic (Declaration)
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)

Parameters

strPrinterName
Type: System..::.String
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-strPrinterName-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also

PrintManager Class


SubmitPrint Method

[image] [image]

Revit 2011 API
PrintManager..::.SubmitPrint Method
PrintManager Class See Also Send Feedback
Print with the current PrintManager settings.

Overload List

Name | Description
SubmitPrint()()() | Print the views and sheets defined in the current local PrintManager settings.
SubmitPrint(View) | Print a view with the current PrintManager settings.

See Also

PrintManager Class
PrintManager Members


SubmitPrint Method

[image]

Revit 2011 API
PrintManager..::.SubmitPrint Method
PrintManager Class See Also Send Feedback
Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SubmitPrint()
Visual Basic (Declaration)
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


SubmitPrint Method (View)

[image]

Revit 2011 API
PrintManager..::.SubmitPrint Method (View)
PrintManager Class See Also Send Feedback
Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic (Declaration)
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The User-assigned view.

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the user-assigned view with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


PrintManager Properties

[image] [image]

Revit 2011 API
PrintManager Properties
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Properties

Name | Description
Collate | Indicates whether to collate of the current print.
CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
CopyNumber | The copy number.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsVirtual | The virtual type in Autodesk Revit.
PaperSizes | Get all print sizes of current printer.
PaperSources | Get all print sources of current printer.
PrinterName | The name of the current printer.
PrintOrderReverse | Indicates whether to reverse the print order of the current print.
PrintRange | The print range.
PrintSetup | The PrintSetup which manages the print settings of current document.
PrintToFile | Indicates whether to print to file.
PrintToFileName | The file name when printing to file.
ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class


Collate Property

[image]

Revit 2011 API
PrintManager..::.Collate Property
PrintManager Class See Also Send Feedback
Indicates whether to collate of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Collate { get; set; }
Visual Basic (Declaration)
Public Property Collate As Boolean
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is only one view or only one copy in the current settings.

See Also

PrintManager Class


CombinedFile Property

[image]

Revit 2011 API
PrintManager..::.CombinedFile Property
PrintManager Class See Also Send Feedback
Indicates whether to combine multiple selected views/sheets into a single file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CombinedFile { get; set; }
Visual Basic (Declaration)
Public Property CombinedFile As Boolean
Visual C++
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current printer is not a virtual printer.

See Also

PrintManager Class


CopyNumber Property

[image]

Revit 2011 API
PrintManager..::.CopyNumber Property
PrintManager Class See Also Send Feedback
The copy number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int CopyNumber { get; set; }
Visual Basic (Declaration)
Public Property CopyNumber As Integer
Visual C++
public:
property int CopyNumber {
    int get ();
    void set (int value);
}

Remarks

Returns 0 if current printer does not support CopyNumber property. The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


IsVirtual Property

[image]

Revit 2011 API
PrintManager..::.IsVirtual Property
PrintManager Class See Also Send Feedback
The virtual type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VirtualPrinterType IsVirtual { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVirtual As VirtualPrinterType
Visual C++
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}

See Also

PrintManager Class


PaperSizes Property

[image]

Revit 2011 API
PrintManager..::.PaperSizes Property
PrintManager Class See Also Send Feedback
Get all print sizes of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSizeSet PaperSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PaperSizeSet
Visual C++
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}

Remarks

These are the valid paper sizes for the current printer.

See Also

PrintManager Class


PaperSources Property

[image]

Revit 2011 API
PrintManager..::.PaperSources Property
PrintManager Class See Also Send Feedback
Get all print sources of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSourceSet PaperSources { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaperSources As PaperSourceSet
Visual C++
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}

Remarks

These are the valid paper source for the current printer.

See Also

PrintManager Class


PrinterName Property

[image]

Revit 2011 API
PrintManager..::.PrinterName Property
PrintManager Class See Also Send Feedback
The name of the current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PrinterName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrinterName As String
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

See Also

PrintManager Class


PrintOrderReverse Property

[image]

Revit 2011 API
PrintManager..::.PrintOrderReverse Property
PrintManager Class See Also Send Feedback
Indicates whether to reverse the print order of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool PrintOrderReverse { get; set; }
Visual Basic (Declaration)
Public Property PrintOrderReverse As Boolean
Visual C++
public:
property bool PrintOrderReverse {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


PrintRange Property

[image]

Revit 2011 API
PrintManager..::.PrintRange Property
PrintManager Class See Also Send Feedback
The print range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PrintRange PrintRange { get; set; }
Visual Basic (Declaration)
Public Property PrintRange As PrintRange
Visual C++
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the argument is out of range.

See Also

PrintManager Class


PrintSetup Property

[image]

Revit 2011 API
PrintManager..::.PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintSetup As PrintSetup
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class


PrintToFile Property

[image]

Revit 2011 API
PrintManager..::.PrintToFile Property
PrintManager Class See Also Send Feedback
Indicates whether to print to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool PrintToFile { get; set; }
Visual Basic (Declaration)
Public Property PrintToFile As Boolean
Visual C++
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


PrintToFileName Property

[image]

Revit 2011 API
PrintManager..::.PrintToFileName Property
PrintManager Class See Also Send Feedback
The file name when printing to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PrintToFileName { get; set; }
Visual Basic (Declaration)
Public Property PrintToFileName As String
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input file name is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input file name is an invalid string.

See Also

PrintManager Class


ViewSheetSetting Property

[image]

Revit 2011 API
PrintManager..::.ViewSheetSetting Property
PrintManager Class See Also Send Feedback
The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSheetSetting ViewSheetSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the print range is not selected views/sheets.

See Also

PrintManager Class


PrintParameters Class

[image]

Revit 2011 API
PrintParameters Class
Members See Also Send Feedback
An object that contains settings used for printing the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PrintParameters : APIObject
Visual Basic (Declaration)
Public Class PrintParameters _
    Inherits APIObject
Visual C++
public ref class PrintParameters : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PrintParameters

See Also

PrintParameters Members


PrintParameters Members

[image] [image]

Revit 2011 API
PrintParameters Members
PrintParameters Class Methods Properties See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorDepth | The color depth type.
HiddenLineViews | The hidden line views type.
HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
HideReforWorkPlanes | Indicates whether to hide referenc/work planes when printing.
HideScopeBoxes | Indicates whether to hide scope boxes when printing.
HideUnreferencedViewTages | Indicates whether to hide unreferenced view tags when printing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MarginType | The print margin type.
PageOrientation | The Page Orientation of the Print Setting.
PaperPlacement | The paper placement type.
PaperSize | The page size.
PaperSource | The page source.
RasterQuality | The raster quality type.
ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
UserDefinedMarginX | The User defined X value of offset from left bottom corner.
UserDefinedMarginY | The User defined Y value of offset from left bottom corner
ViewLinksinBlue | Indicates whether to view links in blue when printing.
Zoom | The zoom value to a percentage of the original size.
ZoomType | The zoom type.

See Also

PrintParameters Class


PrintParameters Methods

[image] [image]

Revit 2011 API
PrintParameters Methods
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintParameters Class


PrintParameters Properties

[image] [image]

Revit 2011 API
PrintParameters Properties
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Properties

Name | Description
ColorDepth | The color depth type.
HiddenLineViews | The hidden line views type.
HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
HideReforWorkPlanes | Indicates whether to hide referenc/work planes when printing.
HideScopeBoxes | Indicates whether to hide scope boxes when printing.
HideUnreferencedViewTages | Indicates whether to hide unreferenced view tags when printing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MarginType | The print margin type.
PageOrientation | The Page Orientation of the Print Setting.
PaperPlacement | The paper placement type.
PaperSize | The page size.
PaperSource | The page source.
RasterQuality | The raster quality type.
ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
UserDefinedMarginX | The User defined X value of offset from left bottom corner.
UserDefinedMarginY | The User defined Y value of offset from left bottom corner
ViewLinksinBlue | Indicates whether to view links in blue when printing.
Zoom | The zoom value to a percentage of the original size.
ZoomType | The zoom type.

See Also

PrintParameters Class


ColorDepth Property

[image]

Revit 2011 API
PrintParameters..::.ColorDepth Property
PrintParameters Class See Also Send Feedback
The color depth type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ColorDepthType ColorDepth { get; set; }
Visual Basic (Declaration)
Public Property ColorDepth As ColorDepthType
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

See Also

PrintParameters Class


HiddenLineViews Property

[image]

Revit 2011 API
PrintParameters..::.HiddenLineViews Property
PrintParameters Class See Also Send Feedback
The hidden line views type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public HiddenLineViewsType HiddenLineViews { get; set; }
Visual Basic (Declaration)
Public Property HiddenLineViews As HiddenLineViewsType
Visual C++
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}

See Also

PrintParameters Class


HideCropBoundaries Property

[image]

Revit 2011 API
PrintParameters..::.HideCropBoundaries Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide crop boundaries when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HideCropBoundaries { get; set; }
Visual Basic (Declaration)
Public Property HideCropBoundaries As Boolean
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideReforWorkPlanes Property

[image]

Revit 2011 API
PrintParameters..::.HideReforWorkPlanes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide referenc/work planes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HideReforWorkPlanes { get; set; }
Visual Basic (Declaration)
Public Property HideReforWorkPlanes As Boolean
Visual C++
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideScopeBoxes Property

[image]

Revit 2011 API
PrintParameters..::.HideScopeBoxes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide scope boxes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HideScopeBoxes { get; set; }
Visual Basic (Declaration)
Public Property HideScopeBoxes As Boolean
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideUnreferencedViewTages Property

[image]

Revit 2011 API
PrintParameters..::.HideUnreferencedViewTages Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide unreferenced view tags when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HideUnreferencedViewTages { get; set; }
Visual Basic (Declaration)
Public Property HideUnreferencedViewTages As Boolean
Visual C++
public:
property bool HideUnreferencedViewTages {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


MarginType Property

[image]

Revit 2011 API
PrintParameters..::.MarginType Property
PrintParameters Class See Also Send Feedback
The print margin type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MarginType MarginType { get; set; }
Visual Basic (Declaration)
Public Property MarginType As MarginType
Visual C++
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if the PaperPlacement is not Margins type.

See Also

PrintParameters Class


PageOrientation Property

[image]

Revit 2011 API
PrintParameters..::.PageOrientation Property
PrintParameters Class See Also Send Feedback
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientationType
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperPlacement Property

[image]

Revit 2011 API
PrintParameters..::.PaperPlacement Property
PrintParameters Class See Also Send Feedback
The paper placement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperPlacementType PaperPlacement { get; set; }
Visual Basic (Declaration)
Public Property PaperPlacement As PaperPlacementType
Visual C++
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperSize Property

[image]

Revit 2011 API
PrintParameters..::.PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic (Declaration)
Public Property PaperSize As PaperSize
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class


PaperSource Property

[image]

Revit 2011 API
PrintParameters..::.PaperSource Property
PrintParameters Class See Also Send Feedback
The page source.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PaperSource PaperSource { get; set; }
Visual Basic (Declaration)
Public Property PaperSource As PaperSource
Visual C++
public:
property PaperSource^ PaperSource {
    PaperSource^ get ();
    void set (PaperSource^ value);
}

Remarks

User can select the candidate via PaperSources and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class


RasterQuality Property

[image]

Revit 2011 API
PrintParameters..::.RasterQuality Property
PrintParameters Class See Also Send Feedback
The raster quality type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RasterQualityType RasterQuality { get; set; }
Visual Basic (Declaration)
Public Property RasterQuality As RasterQualityType
Visual C++
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}

See Also

PrintParameters Class


ReplaceHalftoneWithThinLines Property

[image]

Revit 2011 API
PrintParameters..::.ReplaceHalftoneWithThinLines Property
PrintParameters Class See Also Send Feedback
Indicates whether to replace halftone with thin lines when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ReplaceHalftoneWithThinLines { get; set; }
Visual Basic (Declaration)
Public Property ReplaceHalftoneWithThinLines As Boolean
Visual C++
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


UserDefinedMarginX Property

[image]

Revit 2011 API
PrintParameters..::.UserDefinedMarginX Property
PrintParameters Class See Also Send Feedback
The User defined X value of offset from left bottom corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UserDefinedMarginX { get; set; }
Visual Basic (Declaration)
Public Property UserDefinedMarginX As Double
Visual C++
public:
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


UserDefinedMarginY Property

[image]

Revit 2011 API
PrintParameters..::.UserDefinedMarginY Property
PrintParameters Class See Also Send Feedback
The User defined Y value of offset from left bottom corner

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UserDefinedMarginY { get; set; }
Visual Basic (Declaration)
Public Property UserDefinedMarginY As Double
Visual C++
public:
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


ViewLinksinBlue Property

[image]

Revit 2011 API
PrintParameters..::.ViewLinksinBlue Property
PrintParameters Class See Also Send Feedback
Indicates whether to view links in blue when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ViewLinksinBlue { get; set; }
Visual Basic (Declaration)
Public Property ViewLinksinBlue As Boolean
Visual C++
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


Zoom Property

[image]

Revit 2011 API
PrintParameters..::.Zoom Property
PrintParameters Class See Also Send Feedback
The zoom value to a percentage of the original size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Integer
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if current ZoomType is not Zoom type.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown if input zoom value less than 1.

See Also

PrintParameters Class


ZoomType Property

[image]

Revit 2011 API
PrintParameters..::.ZoomType Property
PrintParameters Class See Also Send Feedback
The zoom type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ZoomType ZoomType { get; set; }
Visual Basic (Declaration)
Public Property ZoomType As ZoomType
Visual C++
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PrintRange Enumeration

[image]

Revit 2011 API
PrintRange Enumeration
See Also Send Feedback
An enumerated type listing all Print Range types of Print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PrintRange
Visual Basic (Declaration)
Public Enumeration PrintRange
Visual C++
public enum class PrintRange

Members

Member name | Description
Current | The type of Print Range is Current.
Visible | The type of Print Range is Visible.
Select | The type of Print Range is Select.

See Also


PrintSetting Class

[image]

Revit 2011 API
PrintSetting Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PrintSetting : Element,
    IPrintSetting
Visual Basic (Declaration)
Public Class PrintSetting _
    Inherits Element _
    Implements IPrintSetting
Visual C++
public ref class PrintSetting : public Element,
    IPrintSetting

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.PrintSetting

See Also

PrintSetting Members


PrintSetting Members

[image] [image]

Revit 2011 API
PrintSetting Members
PrintSetting Class Methods Properties See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of Print Setup. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PrintParameters | Returns the Parameters of Print Setup.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PrintSetting Class


PrintSetting Methods

[image] [image]

Revit 2011 API
PrintSetting Methods
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetting Class


PrintSetting Properties

[image] [image]

Revit 2011 API
PrintSetting Properties
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of Print Setup. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PrintParameters | Returns the Parameters of Print Setup.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PrintSetting Class


Name Property

[image]

Revit 2011 API
PrintSetting..::.Name Property
PrintSetting Class See Also Send Feedback
Returns the Name of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the name of Print Setup.

See Also

PrintSetting Class


Parameter Property

[image] [image]

Revit 2011 API
PrintSetting..::.Parameter Property
PrintSetting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PrintSetting Class
PrintSetting Members


PrintParameters Property

[image]

Revit 2011 API
PrintSetting..::.PrintParameters Property
PrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PrintParameters PrintParameters { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property PrintParameters As PrintParameters
Visual C++
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Implements

IPrintSetting..::.PrintParameters

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

PrintSetting Class


PrintSetup Class

[image]

Revit 2011 API
PrintSetup Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PrintSetup : APIObject
Visual Basic (Declaration)
Public Class PrintSetup _
    Inherits APIObject
Visual C++
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.PrintSetup

See Also

PrintSetup Members


PrintSetup Members

[image] [image]

Revit 2011 API
PrintSetup Members
PrintSetup Class Methods Properties See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

Name | Description
Delete | Delete the current print setting, and make the In-Session setting as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current print setting with the specified name.
Revert | Revert the current print setting.
Save | Save the changes for the current print setting.
SaveAs | Save the current print setting to another print setting with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentPrintSetting | The current Print Setting of Print Setup.
InSession | The in-session Print Setting of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class


PrintSetup Methods

[image] [image]

Revit 2011 API
PrintSetup Methods
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

Name | Description
Delete | Delete the current print setting, and make the In-Session setting as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current print setting with the specified name.
Revert | Revert the current print setting.
Save | Save the changes for the current print setting.
SaveAs | Save the current print setting to another print setting with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetup Class


Delete Method

[image]

Revit 2011 API
PrintSetup..::.Delete Method
PrintSetup Class See Also Send Feedback
Delete the current print setting, and make the In-Session setting as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class


Rename Method

[image]

Revit 2011 API
PrintSetup..::.Rename Method
PrintSetup Class See Also Send Feedback
Rename the current print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be renamed as.

Return Value

False if Rename operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class


Revert Method

[image]

Revit 2011 API
PrintSetup..::.Revert Method
PrintSetup Class See Also Send Feedback
Revert the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class


Save Method

[image]

Revit 2011 API
PrintSetup..::.Save Method
PrintSetup Class See Also Send Feedback
Save the changes for the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current print setting is In-Session or the current print setting has not changed.

See Also

PrintSetup Class


SaveAs Method

[image]

Revit 2011 API
PrintSetup..::.SaveAs Method
PrintSetup Class See Also Send Feedback
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
print setting name to be saved as.

Return Value

False if saveas operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class


PrintSetup Properties

[image] [image]

Revit 2011 API
PrintSetup Properties
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Properties

Name | Description
CurrentPrintSetting | The current Print Setting of Print Setup.
InSession | The in-session Print Setting of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class


CurrentPrintSetting Property

[image]

Revit 2011 API
PrintSetup..::.CurrentPrintSetting Property
PrintSetup Class See Also Send Feedback
The current Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IPrintSetting CurrentPrintSetting { get; set; }
Visual Basic (Declaration)
Public Property CurrentPrintSetting As IPrintSetting
Visual C++
public:
property IPrintSetting^ CurrentPrintSetting {
    IPrintSetting^ get ();
    void set (IPrintSetting^ value);
}

See Also

PrintSetup Class


InSession Property

[image]

Revit 2011 API
PrintSetup..::.InSession Property
PrintSetup Class See Also Send Feedback
The in-session Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InSessionPrintSetting InSession { get; }
Visual Basic (Declaration)
Public ReadOnly Property InSession As InSessionPrintSetting
Visual C++
public:
property InSessionPrintSetting^ InSession {
    InSessionPrintSetting^ get ();
}

See Also

PrintSetup Class


Profile Class

[image]

Revit 2011 API
Profile Class
Members Example See Also Send Feedback
A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Profile : GeometryObject
Visual Basic (Declaration)
Public Class Profile _
    Inherits GeometryObject
Visual C++
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Examples

CopyC#
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == StructuralType.Beam)
        {
            AnalyticalModel modelFrame = beam.GetAnalyticalModel() as AnalyticalModel;
            Autodesk.Revit.DB.Curve curve = modelFrame.GetCurve();
            // Get AnalyticalModel swept profile

           //HARRY
            Autodesk.Revit.DB.Structure.AnalyticalModelSweptProfile sweptProfile = modelFrame.GetSweptProfile();
            Autodesk.Revit.DB.Profile profile = sweptProfile.GetSweptProfile();
            // Get AnalyticalModel swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            TaskDialog.Show("Revit",messageInfo);
        }
    }
}
CopyVB.NET
Public Sub GetProfile(ByVal element As Autodesk.Revit.DB.Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is Autodesk.Revit.DB.FamilyInstance Then
        Dim beam As Autodesk.Revit.DB.FamilyInstance = TryCast(element, Autodesk.Revit.DB.FamilyInstance)
        If beam.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Beam Then
            Dim modelFrame As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(beam.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
            Dim curve As Autodesk.Revit.DB.Curve = modelFrame.GetCurve()
            ' Get AnalyticalModel swept profile

            'HARRY
            Dim sweptProfile As Autodesk.Revit.DB.Structure.AnalyticalModelSweptProfile = modelFrame.GetSweptProfile()
            Dim profile As Autodesk.Revit.DB.Profile = sweptProfile.GetSweptProfile()
            ' Get AnalyticalModel swept profile curves size
            messageInfo += vbLf & "Selection name : " + beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " + profile.Curves.Size
            messageInfo += vbLf & "Profile is filled :  " + profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting:  " + profile.Filled
            End If
            TaskDialog.Show("Revit", messageInfo)
        End If
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Profile

See Also

Profile Members


Profile Members

[image] [image]

Revit 2011 API
Profile Members
Profile Class Methods Properties See Also Send Feedback

The Profile type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this profile.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Profile Methods

[image] [image]

Revit 2011 API
Profile Methods
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Methods

Name | Description
Clone | Returns a copy of this profile.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profile Class


Clone Method

[image]

Revit 2011 API
Profile..::.Clone Method
Profile Class See Also Send Feedback
Returns a copy of this profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Profile Clone()
Visual Basic (Declaration)
Public Function Clone As Profile
Visual C++
public:
Profile^ Clone()

See Also

Profile Class


Profile Properties

[image] [image]

Revit 2011 API
Profile Properties
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Properties

Name | Description
Curves | Retrieve the curves that make up the boundary of the profile.
Filled | Get or set whether the profile is filled.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Transformed | Transforms this profile and returns the result.
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Curves Property

[image]

Revit 2011 API
Profile..::.Curves Property
Profile Class See Also Send Feedback
Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class


Filled Property

[image]

Revit 2011 API
Profile..::.Filled Property
Profile Class See Also Send Feedback
Get or set whether the profile is filled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Filled { get; set; }
Visual Basic (Declaration)
Public Property Filled As Boolean
Visual C++
public:
property bool Filled {
    bool get ();
    void set (bool value);
}

See Also

Profile Class


Transformed Property

[image]

Revit 2011 API
Profile..::.Transformed Property
Profile Class See Also Send Feedback
Transforms this profile and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Profile Transformed[
    Transform transform
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::.Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class


ProfilePlaneLocation Enumeration

[image]

Revit 2011 API
ProfilePlaneLocation Enumeration
See Also Send Feedback
Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ProfilePlaneLocation
Visual Basic (Declaration)
Public Enumeration ProfilePlaneLocation
Visual C++
public enum class ProfilePlaneLocation

Members

Member name | Description
Start | Indicates the profile plane located at the start of the path curve.
MidPoint | Indicates the profile plane located at the Middle point of the path curve.
End | Indicates the profile plane located at the End of the path curve.

Remarks

Use this enum in the NewSweep() method to create generic forms.

See Also


ProjectInfo Class

[image]

Revit 2011 API
ProjectInfo Class
Members Example See Also Send Feedback
An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProjectInfo : Element
Visual Basic (Declaration)
Public Class ProjectInfo _
    Inherits Element
Visual C++
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
ProjectInfo projectInfo = document.ProjectInformation;

if (null != projectInfo)
{
    string message = "Project information:";
    //get the project name
    message += "\nName: " + projectInfo.Name;
    string newName = "My project";
    //set the project name
    projectInfo.Name = newName;
    message += "\nProject Name after set: " + projectInfo.Name;

    //get the project number
    message += "\nNumber: " + projectInfo.Number;
    string newNumber = "TestNumber";
    //set the project number
    projectInfo.Number = newNumber;
    message += "\nProject Number after set: " + projectInfo.Number;

    //get the status of the project
    message += "\nStatus: " + projectInfo.Status;
    string newStatus = "TestStatus";
    //set the project status
    projectInfo.Status = newStatus;
    message += "\nProject status after set: " + projectInfo.Status;

    //get the address of the project
    message += "\nAddress: " + projectInfo.Address;
    string newAddress = "TestAddress";
    //set the project address
    projectInfo.Address = newAddress;
    message += "\nProject address after set: " + projectInfo.Address;

    //get the client name of the project
    message += "\nClient Name: " + projectInfo.ClientName;
    string newClient = "TestClientName";
    //set the client name
    projectInfo.ClientName = newClient;
    message += "\nProject client name after set: " + projectInfo.ClientName;

    //get the gbXmlSetting of the project
    EnergyDataSettings energyDataSetting = EnergyDataSettings.GetFromDocument(document);
    message += "\nBuilding type: " + energyDataSetting.BuildingType.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Dim projectInfo As Autodesk.Revit.DB.ProjectInfo = document.ProjectInformation

If projectInfo IsNot Nothing Then
    Dim message As String = "Project information:"
    'get the project name
    message += vbLf & "Name: " + projectInfo.Name
    Dim newName As String = "My project"
    'set the project name
    projectInfo.Name = newName
    message += vbLf & "Project Name after set: " + projectInfo.Name

    'get the project number
    message += vbLf & "Number: " + projectInfo.Number
    Dim newNumber As String = "TestNumber"
    'set the project number
    projectInfo.Number = newNumber
    message += vbLf & "Project Number after set: " + projectInfo.Number

    'get the status of the project
    message += vbLf & "Status: " + projectInfo.Status
    Dim newStatus As String = "TestStatus"
    'set the project status
    projectInfo.Status = newStatus
    message += vbLf & "Project status after set: " + projectInfo.Status

    'get the address of the project
    message += vbLf & "Address: " + projectInfo.Address
    Dim newAddress As String = "TestAddress"
    'set the project address
    projectInfo.Address = newAddress
    message += vbLf & "Project address after set: " + projectInfo.Address

    'get the client name of the project
    message += vbLf & "Client Name: " + projectInfo.ClientName
    Dim newClient As String = "TestClientName"
    'set the client name
    projectInfo.ClientName = newClient
    message += vbLf & "Project client name after set: " + projectInfo.ClientName

    'get the gbXmlSetting of the project
    Dim energyDataSetting As Autodesk.Revit.DB.Analysis.EnergyDataSettings = Autodesk.Revit.DB.Analysis.EnergyDataSettings.GetFromDocument(document)
    message += vbLf & "Building type: " + energyDataSetting.BuildingType.ToString()

    TaskDialog.Show("Revit", message)
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ProjectInfo

See Also

ProjectInfo Members


ProjectInfo Members

[image] [image]

Revit 2011 API
ProjectInfo Members
ProjectInfo Class Methods Properties See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Get or Set the Project Address of the Project Information.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClientName | Get or Set the Client Name of the Project Information.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IssueDate | Get or Set the Project Issue Date of the Project Information.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Project Name of the Project Information.
Number | Get or Set the Project Number of the Project Information.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Status | Get or Set the Project Status of the Project Information.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectInfo Class


ProjectInfo Methods

[image] [image]

Revit 2011 API
ProjectInfo Methods
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectInfo Class


ProjectInfo Properties

[image] [image]

Revit 2011 API
ProjectInfo Properties
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Properties

Name | Description
Address | Get or Set the Project Address of the Project Information.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClientName | Get or Set the Client Name of the Project Information.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IssueDate | Get or Set the Project Issue Date of the Project Information.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Project Name of the Project Information.
Number | Get or Set the Project Number of the Project Information.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Status | Get or Set the Project Status of the Project Information.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectInfo Class


Address Property

[image]

Revit 2011 API
ProjectInfo..::.Address Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Address { get; set; }
Visual Basic (Declaration)
Public Property Address As String
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Address of the Project Information.

See Also

ProjectInfo Class


ClientName Property

[image]

Revit 2011 API
ProjectInfo..::.ClientName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ClientName { get; set; }
Visual Basic (Declaration)
Public Property ClientName As String
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Client Name of the Project Information.

See Also

ProjectInfo Class


IssueDate Property

[image]

Revit 2011 API
ProjectInfo..::.IssueDate Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Issue Date of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string IssueDate { get; set; }
Visual Basic (Declaration)
Public Property IssueDate As String
Visual C++
public:
property String^ IssueDate {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Issue Date of the Project Information.

See Also

ProjectInfo Class


Name Property

[image]

Revit 2011 API
ProjectInfo..::.Name Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Name of the Project Information.

See Also

ProjectInfo Class


Number Property

[image]

Revit 2011 API
ProjectInfo..::.Number Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic (Declaration)
Public Property Number As String
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


Parameter Property

[image] [image]

Revit 2011 API
ProjectInfo..::.Parameter Property
ProjectInfo Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectInfo Class
ProjectInfo Members


Status Property

[image]

Revit 2011 API
ProjectInfo..::.Status Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Status of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Status of the Project Information.

See Also

ProjectInfo Class


ProjectLocation Class

[image]

Revit 2011 API
ProjectLocation Class
Members Example See Also Send Feedback
An object that represents a named location in a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProjectLocation : Instance
Visual Basic (Declaration)
Public Class ProjectLocation _
    Inherits Instance
Visual C++
public ref class ProjectLocation : public Instance

Remarks

Revit Architecture projects can have named locations. A named location is the position of a model instance in a Revit Architecture project. By default, each Revit Architecture project contains at least one named location, called Internal. Existing ProjectLocation objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating an existing project location using the Duplicate method, and modifying the location's project position.

Examples

CopyC#
public void ShowActiveProjectLocationUsage(Autodesk.Revit.DB.Document document)
{
    // Get the project location handle
    ProjectLocation projectLocation = document.ActiveProjectLocation;

    // Show the information of current project location
    XYZ origin = new XYZ(0, 0, 0);
    ProjectPosition position = projectLocation.get_ProjectPosition(origin);
    if (null == position)
    {
        throw new Exception("No project position in origin point.");
    }

    // Format the prompt string to show the message.
    String prompt = "Current project location information:\n";
    prompt += "\n\t" + "Origin point position:";
    prompt += "\n\t\t" + "Angle: " + position.Angle;
    prompt += "\n\t\t" + "East to West offset: " + position.EastWest;
    prompt += "\n\t\t" + "Elevation: " + position.Elevation;
    prompt += "\n\t\t" + "North to South offset: " + position.NorthSouth;

    // Angles are in radians when coming from Revit API, so we
    // convert to degrees for display
    const double angleRatio = Math.PI / 180;   // angle conversion factor

    SiteLocation site = projectLocation.SiteLocation;
    prompt += "\n\t" + "Site location:";
    prompt += "\n\t\t" + "Latitude: " + site.Latitude / angleRatio + "��";
    prompt += "\n\t\t" + "Longitude: " + site.Longitude / angleRatio + "��";
    prompt += "\n\t\t" + "TimeZone: " + site.TimeZone;

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub ShowActiveProjectLocationUsage(ByVal document As Autodesk.Revit.DB.Document)
    ' Get the project location handle
    Dim projectLocation As ProjectLocation = document.ActiveProjectLocation

    ' Show the information of current project location
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim position As ProjectPosition = projectLocation.ProjectPosition(origin)
    If position Is Nothing Then
        Throw New Exception("No project position in origin point.")
    End If

    ' Format the prompt string to show the message.
    Dim prompt As [String] = "Current project location information:" & vbLf
    prompt += vbLf & vbTab + "Origin point position:"
    prompt += vbLf & vbTab & vbTab + "Angle: " + position.Angle
    prompt += vbLf & vbTab & vbTab + "East to West offset: " + position.EastWest
    prompt += vbLf & vbTab & vbTab + "Elevation: " + position.Elevation
    prompt += vbLf & vbTab & vbTab + "North to South offset: " + position.NorthSouth

    ' Angles are in radians when coming from Revit API, so we
    ' convert to degrees for display
    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim site As SiteLocation = projectLocation.SiteLocation
    prompt += vbLf & vbTab + "Site location:"
    prompt += vbLf & vbTab & vbTab + "Latitude: " + site.Latitude / angleRatio + "¡ã"
    prompt += vbLf & vbTab & vbTab + "Longitude: " + site.Longitude / angleRatio + "¡ã"
    prompt += vbLf & vbTab & vbTab + "TimeZone: " + site.TimeZone

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Instance
Autodesk.Revit.DB..::.ProjectLocation

See Also

ProjectLocation Members


ProjectLocation Members

[image] [image]

Revit 2011 API
ProjectLocation Members
ProjectLocation Class Methods Properties See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Generate a copy of this project location with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name of the project location. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SiteLocation | The site location to which this project location refers.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectLocation Class


ProjectLocation Methods

[image] [image]

Revit 2011 API
ProjectLocation Methods
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Generate a copy of this project location with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocation Class


Duplicate Method

[image]

Revit 2011 API
ProjectLocation..::.Duplicate Method
ProjectLocation Class Example See Also Send Feedback
Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::.String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

Examples

CopyC#
public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
CopyVB.NET
Public Function DuplicateLocation(ByVal document As Autodesk.Revit.DB.Document, ByVal newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

See Also

ProjectLocation Class


ProjectLocation Properties

[image] [image]

Revit 2011 API
ProjectLocation Properties
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name of the project location. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SiteLocation | The site location to which this project location refers.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectLocation Class


Name Property

[image]

Revit 2011 API
ProjectLocation..::.Name Property
ProjectLocation Class See Also Send Feedback
The name of the project location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This property is used to get or set the name of the project location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when failing to set the name (for example, because it is not unique).

See Also

ProjectLocation Class


Parameter Property

[image] [image]

Revit 2011 API
ProjectLocation..::.Parameter Property
ProjectLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectLocation Class
ProjectLocation Members


ProjectPosition Property

[image]

Revit 2011 API
ProjectLocation..::.ProjectPosition Property
ProjectLocation Class Example See Also Send Feedback
Gets or sets the coordinates of a point in the project location coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectPosition ProjectPosition[
    XYZ point
] { get; set; }
Visual Basic (Declaration)
Public Property ProjectPosition ( _
    point As XYZ _
) As ProjectPosition
Visual C++
public:
property ProjectPosition^ ProjectPosition[XYZ^ point] {
    ProjectPosition^ get (XYZ^ point);
    void set (XYZ^ point, ProjectPosition^ value);
}

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point in model coordinates.

Remarks

When getting this property, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

When setting this property, the transformations applied to the location are modified such that the passed point becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated angular rotation. This is similar to the Revit command "Specify Coordinates at Point".

Examples

CopyC#
//get and set the value of the projectlocation
public ProjectLocation GetProjectLocation(Autodesk.Revit.DB.Document document)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;

    //get the project position
    XYZ origin = new XYZ(0, 0, 0);

    const double angleRatio = Math.PI / 180;   // angle conversion factor

    ProjectPosition projectPosition = currentLocation.get_ProjectPosition(origin);
    //Angle from True North
    double angle = 30.0 * angleRatio;   // convert degrees to radian
    double eastWest = 30.0;     //East to West offset
    double northSouth = 23.32;   //North to South offset
    double elevation = 22.14;    //Elevation above ground level

    //create a new project position
    ProjectPosition newPosition =
      document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle);

    if (null != newPosition)
    {
        //set the value of the project position
        currentLocation.set_ProjectPosition(origin, newPosition);
    }

    return currentLocation;
}
CopyVB.NET
'get and set the value of the projectlocation
Public Function GetProjectLocation(ByVal document As Autodesk.Revit.DB.Document) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation

    'get the project position
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)

    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim projectPosition As ProjectPosition = currentLocation.ProjectPosition(origin)
    'Angle from True North
    Dim angle As Double = 30 * angleRatio
    ' convert degrees to radian
    Dim eastWest As Double = 30
    'East to West offset
    Dim northSouth As Double = 23.32
    'North to South offset
    Dim elevation As Double = 22.14
    'Elevation above ground level
    'create a new project position
    Dim newPosition As ProjectPosition = document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle)

    If newPosition IsNot Nothing Then
        'set the value of the project position
        currentLocation.ProjectPosition(origin) = newPosition
    End If

    Return currentLocation
End Function

See Also

ProjectLocation Class


SiteLocation Property

[image]

Revit 2011 API
ProjectLocation..::.SiteLocation Property
ProjectLocation Class See Also Send Feedback
The site location to which this project location refers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property SiteLocation As SiteLocation
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The site location object contains the longitude, latitude and time-zone of the entire project site.

See Also

ProjectLocation Class


ProjectLocationSet Class

[image]

Revit 2011 API
ProjectLocationSet Class
Members See Also Send Feedback
An set that contains project locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProjectLocationSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ProjectLocationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ProjectLocationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ProjectLocationSet

See Also

ProjectLocationSet Members


ProjectLocationSet Members

[image] [image]

Revit 2011 API
ProjectLocationSet Members
ProjectLocationSet Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Constructors

Name | Description
ProjectLocationSet | Initializes a new instance of the ProjectLocationSet class

Methods

Name | Description
Clear | Removes every project location from the set, rendering it empty.
Contains | Tests for the existence of a project location within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified project location from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified project location into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class


ProjectLocationSet Constructor

[image]

Revit 2011 API
ProjectLocationSet Constructor
ProjectLocationSet Class See Also Send Feedback
Initializes a new instance of the ProjectLocationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectLocationSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSet()

See Also

ProjectLocationSet Class


ProjectLocationSet Methods

[image] [image]

Revit 2011 API
ProjectLocationSet Methods
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Methods

Name | Description
Clear | Removes every project location from the set, rendering it empty.
Contains | Tests for the existence of a project location within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified project location from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified project location into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSet Class


Clear Method

[image]

Revit 2011 API
ProjectLocationSet..::.Clear Method
ProjectLocationSet Class See Also Send Feedback
Removes every project location from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ProjectLocationSet Class


Contains Method

[image]

Revit 2011 API
ProjectLocationSet..::.Contains Method
ProjectLocationSet Class See Also Send Feedback
Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ProjectLocation
The project location to be searched for.

Return Value

The Contains method returns True if the project location is within the set, otherwise False.

See Also

ProjectLocationSet Class


Erase Method

[image]

Revit 2011 API
ProjectLocationSet..::.Erase Method
ProjectLocationSet Class See Also Send Feedback
Removes a specified project location from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ProjectLocation _
) As Integer
Visual C++
public:
virtual int Erase(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ProjectLocation
The project location to be erased.

Return Value

The number of project locations that were erased from the set.

See Also

ProjectLocationSet Class


ForwardIterator Method

[image]

Revit 2011 API
ProjectLocationSet..::.ForwardIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class


GetEnumerator Method

[image]

Revit 2011 API
ProjectLocationSet..::.GetEnumerator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ProjectLocationSet Class


Insert Method

[image]

Revit 2011 API
ProjectLocationSet..::.Insert Method
ProjectLocationSet Class See Also Send Feedback
Insert the specified project location into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    ProjectLocation item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ProjectLocation
The project location to be inserted into the set.

Return Value

Returns whether the project location was inserted into the set.

See Also

ProjectLocationSet Class


ReverseIterator Method

[image]

Revit 2011 API
ProjectLocationSet..::.ReverseIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ProjectLocationSet Class


ProjectLocationSet Properties

[image] [image]

Revit 2011 API
ProjectLocationSet Properties
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class


IsEmpty Property

[image]

Revit 2011 API
ProjectLocationSet..::.IsEmpty Property
ProjectLocationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ProjectLocationSet Class


Size Property

[image]

Revit 2011 API
ProjectLocationSet..::.Size Property
ProjectLocationSet Class See Also Send Feedback
Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ProjectLocationSet Class


ProjectLocationSetIterator Class

[image]

Revit 2011 API
ProjectLocationSetIterator Class
Members See Also Send Feedback
An iterator to a project location set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ProjectLocationSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ProjectLocationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ProjectLocationSetIterator

See Also

ProjectLocationSetIterator Members


ProjectLocationSetIterator Members

[image] [image]

Revit 2011 API
ProjectLocationSetIterator Members
ProjectLocationSetIterator Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Constructors

Name | Description
ProjectLocationSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Constructor

[image]

Revit 2011 API
ProjectLocationSetIterator Constructor
ProjectLocationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectLocationSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectLocationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Methods

[image] [image]

Revit 2011 API
ProjectLocationSetIterator Methods
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ProjectLocationSetIterator..::.MoveNext Method
ProjectLocationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


Reset Method

[image]

Revit 2011 API
ProjectLocationSetIterator..::.Reset Method
ProjectLocationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Properties

[image] [image]

Revit 2011 API
ProjectLocationSetIterator Properties
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class


Current Property

[image]

Revit 2011 API
ProjectLocationSetIterator..::.Current Property
ProjectLocationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


ProjectPosition Class

[image]

Revit 2011 API
ProjectPosition Class
Members See Also Send Feedback
An object that is used to represent a geographical offset and rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProjectPosition : APIObject
Visual Basic (Declaration)
Public Class ProjectPosition _
    Inherits APIObject
Visual C++
public ref class ProjectPosition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ProjectPosition

See Also

ProjectPosition Members


ProjectPosition Members

[image] [image]

Revit 2011 API
ProjectPosition Members
ProjectPosition Class Constructors Methods Properties See Also Send Feedback

The ProjectPosition type exposes the following members.

Constructors

Name | Description
ProjectPosition | Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Angle from True North
EastWest | East/West offset
Elevation | Elevation above ground level.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NorthSouth | North/South offset

See Also

ProjectPosition Class


ProjectPosition Constructor

[image]

Revit 2011 API
ProjectPosition Constructor
ProjectPosition Class See Also Send Feedback
Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::.Double
East/West offset
ns
Type: System..::.Double
North/South offset
elevation
Type: System..::.Double
Elevation offset
angle
Type: System..::.Double
Rotation from true north, in radians.

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class


ProjectPosition Methods

[image] [image]

Revit 2011 API
ProjectPosition Methods
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectPosition Class


ProjectPosition Properties

[image] [image]

Revit 2011 API
ProjectPosition Properties
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Properties

Name | Description
Angle | Angle from True North
EastWest | East/West offset
Elevation | Elevation above ground level.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NorthSouth | North/South offset

See Also

ProjectPosition Class


Angle Property

[image]

Revit 2011 API
ProjectPosition..::.Angle Property
ProjectPosition Class See Also Send Feedback
Angle from True North

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

This is the angle difference between project north and true north measured in radians. It can have a value from -PI to +PI.

See Also

ProjectPosition Class


EastWest Property

[image]

Revit 2011 API
ProjectPosition..::.EastWest Property
ProjectPosition Class See Also Send Feedback
East/West offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EastWest { get; set; }
Visual Basic (Declaration)
Public Property EastWest As Double
Visual C++
public:
property double EastWest {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the east/west direction. Measured in decimal feet.

See Also

ProjectPosition Class


Elevation Property

[image]

Revit 2011 API
ProjectPosition..::.Elevation Property
ProjectPosition Class See Also Send Feedback
Elevation above ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Double
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

Measured in decimal feet.

See Also

ProjectPosition Class


NorthSouth Property

[image]

Revit 2011 API
ProjectPosition..::.NorthSouth Property
ProjectPosition Class See Also Send Feedback
North/South offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double NorthSouth { get; set; }
Visual Basic (Declaration)
Public Property NorthSouth As Double
Visual C++
public:
property double NorthSouth {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the north/south direction. Measured in decimal feet.

See Also

ProjectPosition Class


ProjectUnit Class

[image]

Revit 2011 API
ProjectUnit Class
Members Example See Also Send Feedback
Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ProjectUnit : Element
Visual Basic (Declaration)
Public Class ProjectUnit _
    Inherits Element
Visual C++
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Examples

CopyC#
ProjectUnit projectUnit = document.ProjectUnit;

if (null != projectUnit)
{
    string message = "Project Unit: ";

    //get the DecimalSymbolType
    message += "\nDecimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString();

    //show the usage for FormatOptions property
    message += "\nFormat Options: ";
    FormatOptions formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Length);
    message += "\n\tLength : " + formatOptions.Name;
    formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Volume);
    message += "\n\tVolume : " + formatOptions.Name;

    //get the Digit Grouping Amount of the project
    DigitGroupingAmount dga = projectUnit.DigitGroupingAmount;
    message += "\nDigit Grouping Amount: " + dga.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Dim projectUnit As ProjectUnit = document.ProjectUnit

If projectUnit IsNot Nothing Then
    Dim message As String = "Project Unit: "

    'get the DecimalSymbolType
    message += vbLf & "Decimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString()

    'show the usage for FormatOptions property
    message += vbLf & "Format Options: "
    Dim formatOptions As Autodesk.Revit.DB.FormatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Length)
    message += vbLf & vbTab & "Length : " + formatOptions.Name
    formatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Volume)
    message += vbLf & vbTab & "Volume : " + formatOptions.Name

    'get the Digit Grouping Amount of the project
    Dim dga As Autodesk.Revit.DB.DigitGroupingAmount = projectUnit.DigitGroupingAmount
    message += vbLf & "Digit Grouping Amount: " + dga.ToString()

    TaskDialog.Show("Revit", message)
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ProjectUnit

See Also

ProjectUnit Members


ProjectUnit Members

[image] [image]

Revit 2011 API
ProjectUnit Members
ProjectUnit Class Methods Properties See Also Send Feedback

The ProjectUnit type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
setDigitGroupingType | Set the Digit Grouping Amount, using the three types
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FormatOptions | Get the Format Options of the Project Unit Settings.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectUnit Class


ProjectUnit Methods

[image] [image]

Revit 2011 API
ProjectUnit Methods
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
setDigitGroupingType | Set the Digit Grouping Amount, using the three types
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectUnit Class


setDigitGroupingType Method

[image]

Revit 2011 API
ProjectUnit..::.setDigitGroupingType Method
ProjectUnit Class See Also Send Feedback
Set the Digit Grouping Amount, using the three types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)
Visual Basic (Declaration)
Public Sub setDigitGroupingType ( _
    dst As DecimalSymbolType, _
    dgst As DigitGroupingSymbolType, _
    dga As DigitGroupingAmount _
)
Visual C++
public:
void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)

Parameters

dst
Type: Autodesk.Revit.DB..::.DecimalSymbolType
dgst
Type: Autodesk.Revit.DB..::.DigitGroupingSymbolType
dga
Type: Autodesk.Revit.DB..::.DigitGroupingAmount

See Also

ProjectUnit Class


ProjectUnit Properties

[image] [image]

Revit 2011 API
ProjectUnit Properties
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FormatOptions | Get the Format Options of the Project Unit Settings.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ProjectUnit Class


DecimalSymbolType Property

[image]

Revit 2011 API
ProjectUnit..::.DecimalSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Decimal Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DecimalSymbolType DecimalSymbolType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DecimalSymbolType As DecimalSymbolType
Visual C++
public:
property DecimalSymbolType DecimalSymbolType {
    DecimalSymbolType get ();
}

Return Value

The type of the Decimal Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DecimalSymbolType::DST_DOT.

See Also

ProjectUnit Class


DigitGroupingAmount Property

[image]

Revit 2011 API
ProjectUnit..::.DigitGroupingAmount Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Amount of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DigitGroupingAmount DigitGroupingAmount { get; }
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingAmount As DigitGroupingAmount
Visual C++
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
}

Return Value

The type of the Digit Grouping Amount.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DigitGroupingAmount::DGA_THREE.

See Also

ProjectUnit Class


DigitGroupingSymbolType Property

[image]

Revit 2011 API
ProjectUnit..::.DigitGroupingSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DigitGroupingSymbolType DigitGroupingSymbolType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DigitGroupingSymbolType As DigitGroupingSymbolType
Visual C++
public:
property DigitGroupingSymbolType DigitGroupingSymbolType {
    DigitGroupingSymbolType get ();
}

Return Value

The type of the Digit Grouping Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DigitGroupingSymbolType::DGST_COMMA.

See Also

ProjectUnit Class


FormatOptions Property

[image]

Revit 2011 API
ProjectUnit..::.FormatOptions Property
ProjectUnit Class See Also Send Feedback
Get the Format Options of the Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FormatOptions FormatOptions[
    UnitType ut
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property FormatOptions ( _
    ut As UnitType _
) As FormatOptions
Visual C++
public:
property FormatOptions^ FormatOptions[UnitType ut] {
    FormatOptions^ get (UnitType ut);
}

Parameters

ut
Type: Autodesk.Revit.DB..::.UnitType

Remarks

.

See Also

ProjectUnit Class


Name Property

[image]

Revit 2011 API
ProjectUnit..::.Name Property
ProjectUnit Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for ProjectUnit object, an InvalidOperationException will be thrown.

See Also

ProjectUnit Class


Parameter Property

[image] [image]

Revit 2011 API
ProjectUnit..::.Parameter Property
ProjectUnit Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ProjectUnit Class
ProjectUnit Members


PropertyLine Class

[image]

Revit 2011 API
PropertyLine Class
Members See Also Send Feedback
Represents kinds of PropertyLines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PropertyLine : Element
Visual Basic (Declaration)
Public Class PropertyLine _
    Inherits Element
Visual C++
public ref class PropertyLine : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.PropertyLine

See Also

PropertyLine Members


PropertyLine Members

[image] [image]

Revit 2011 API
PropertyLine Members
PropertyLine Class Methods Properties See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PropertyLine Class


PropertyLine Methods

[image] [image]

Revit 2011 API
PropertyLine Methods
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyLine Class


PropertyLine Properties

[image] [image]

Revit 2011 API
PropertyLine Properties
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PropertyLine Class


Parameter Property

[image] [image]

Revit 2011 API
PropertyLine..::.Parameter Property
PropertyLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PropertyLine Class
PropertyLine Members


PropOverrideMode Enumeration

[image]

Revit 2011 API
PropOverrideMode Enumeration
See Also Send Feedback
An enumerated type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PropOverrideMode
Visual Basic (Declaration)
Public Enumeration PropOverrideMode
Visual C++
public enum class PropOverrideMode

Members

Member name | Description
ByEntity | Category properties BYLAYER, overrides BYENTITY.
ByLayer | All properties BYLAYER, no overrides.
NewLayer | All properties BYLAYER, New Layers for overrides.

See Also


RadialArray Class

[image]

Revit 2011 API
RadialArray Class
Members See Also Send Feedback
An object that represents a Radial Array in the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RadialArray : BaseArray
Visual Basic (Declaration)
Public Class RadialArray _
    Inherits BaseArray
Visual C++
public ref class RadialArray : public BaseArray

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.BaseArray
Autodesk.Revit.DB..::.RadialArray

See Also

RadialArray Members


RadialArray Members

[image] [image]

Revit 2011 API
RadialArray Members
RadialArray Class Methods Properties See Also Send Feedback

The RadialArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RadialArray Class


RadialArray Methods

[image] [image]

Revit 2011 API
RadialArray Methods
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadialArray Class


RadialArray Properties

[image] [image]

Revit 2011 API
RadialArray Properties
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CopyMembers | Retrieve the copied members of the Array. (Overrides BaseArray..::.CopyMembers.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from BaseArray.)
NumMembers | Retrieve or Change the number of the arrayed members. (Overrides BaseArray..::.NumMembers.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OrigMembers | Retrieve the original members of the Array. (Overrides BaseArray..::.OrigMembers.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RadialArray Class


CopyMembers Property

[image]

Revit 2011 API
RadialArray..::.CopyMembers Property
RadialArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ElementArray CopyMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CopyMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class


NumMembers Property

[image]

Revit 2011 API
RadialArray..::.NumMembers Property
RadialArray Class See Also Send Feedback
Retrieve or Change the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic (Declaration)
Public Overrides Property NumMembers As Integer
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

RadialArray Class


OrigMembers Property

[image]

Revit 2011 API
RadialArray..::.OrigMembers Property
RadialArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override ElementArray OrigMembers { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property OrigMembers As ElementArray
Visual C++
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class


Parameter Property

[image] [image]

Revit 2011 API
RadialArray..::.Parameter Property
RadialArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RadialArray Class
RadialArray Members


RasterQualityType Enumeration

[image]

Revit 2011 API
RasterQualityType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RasterQualityType
Visual Basic (Declaration)
Public Enumeration RasterQualityType
Visual C++
public enum class RasterQualityType

Members

Member name | Description
Low | The type of Raster Quality is Low.
Medium | The type of Raster Quality is Medium.
High | The type of Raster Quality is High.
Presentation | The type of Raster Quality is Presentation.

See Also


Rectangle Class

[image]

Revit 2011 API
Rectangle Class
Members See Also Send Feedback
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Rectangle
Visual Basic (Declaration)
Public Class Rectangle
Visual C++
public ref class Rectangle

Remarks

It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Rectangle

See Also

Rectangle Members


Rectangle Members

[image] [image]

Revit 2011 API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

Name | Description
Rectangle | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Left | Gets x-coordinate of the top-left corner of the rectangle.
Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


Rectangle Constructor

[image]

Revit 2011 API
Rectangle Constructor
Rectangle Class See Also Send Feedback
Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Rectangle(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
Rectangle(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::.Int32
The x-coordinate of the top-left corner.
top
Type: System..::.Int32
The y-coordinate of the top-left corner.
right
Type: System..::.Int32
The x-coordinate of the bottom-right corner.
bottom
Type: System..::.Int32
The y-coordinate of the bottom-right corner.

See Also

Rectangle Class


Rectangle Methods

[image] [image]

Revit 2011 API
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rectangle Class


Rectangle Properties

[image] [image]

Revit 2011 API
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

Name | Description
Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Left | Gets x-coordinate of the top-left corner of the rectangle.
Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


Bottom Property

[image]

Revit 2011 API
Rectangle..::.Bottom Property
Rectangle Class See Also Send Feedback
Gets y-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Integer
Visual C++
public:
property int Bottom {
    int get ();
}

See Also

Rectangle Class


Left Property

[image]

Revit 2011 API
Rectangle..::.Left Property
Rectangle Class See Also Send Feedback
Gets x-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
}

See Also

Rectangle Class


Right Property

[image]

Revit 2011 API
Rectangle..::.Right Property
Rectangle Class See Also Send Feedback
Gets x-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Integer
Visual C++
public:
property int Right {
    int get ();
}

See Also

Rectangle Class


Top Property

[image]

Revit 2011 API
Rectangle..::.Top Property
Rectangle Class See Also Send Feedback
Gets y-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
}

See Also

Rectangle Class


Reference Class

[image]

Revit 2011 API
Reference Class
Members See Also Send Feedback
A stable reference to a geometric object in a Revit model.
An array that contains reference objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Reference : APIObject
Visual Basic (Declaration)
Public Class Reference _
    Inherits APIObject
Visual C++
public ref class Reference : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Reference

See Also

Reference Members


Reference Members

[image] [image]

Revit 2011 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

Name | Description
Reference | Creates a Reference with the supplied element.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ProximityParameter | The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


Reference Constructor

[image]

Revit 2011 API
Reference Constructor
Reference Class See Also Send Feedback
Creates a Reference with the supplied element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Reference(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
Reference(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to create a reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Reference Class


Reference Methods

[image] [image]

Revit 2011 API
Reference Methods
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reference Class


Reference Properties

[image] [image]

Revit 2011 API
Reference Properties
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Properties

Name | Description
Element | The element for this reference.
ElementReferenceType | The type of reference referred to.
GeometryObject | The geometry item referred to by this reference.
GlobalPoint | The position on which the reference is hit.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
ProximityParameter | The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).
Transform | The transformation of the geometry item into the coordinates of the document.
UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


Element Property

[image]

Revit 2011 API
Reference..::.Element Property
Reference Class See Also Send Feedback
The element for this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned for references that don't refer to a particular element.

See Also

Reference Class


ElementReferenceType Property

[image]

Revit 2011 API
Reference..::.ElementReferenceType Property
Reference Class See Also Send Feedback
The type of reference referred to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementReferenceType ElementReferenceType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementReferenceType As ElementReferenceType
Visual C++
public:
property ElementReferenceType ElementReferenceType {
    ElementReferenceType get ();
}

See Also

Reference Class


GeometryObject Property

[image]

Revit 2011 API
Reference..::.GeometryObject Property
Reference Class See Also Send Feedback
The geometry item referred to by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryObject GeometryObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property GeometryObject As GeometryObject
Visual C++
public:
property GeometryObject^ GeometryObject {
    GeometryObject^ get ();
}

See Also

Reference Class


GlobalPoint Property

[image]

Revit 2011 API
Reference..::.GlobalPoint Property
Reference Class See Also Send Feedback
The position on which the reference is hit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ GlobalPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalPoint As XYZ
Visual C++
public:
property XYZ^ GlobalPoint {
    XYZ^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the reference doesn't have global point.

Remarks

When using a plan view, the Z-value of a GlobalPoint is not meaningful.

See Also

Reference Class


ProximityParameter Property

[image]

Revit 2011 API
Reference..::.ProximityParameter Property
Reference Class See Also Send Feedback
The proximity value to the ray's origin when the reference is returned by FindReferencesByDirection(XYZ, XYZ, View3D).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ProximityParameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProximityParameter As Double
Visual C++
public:
property double ProximityParameter {
    double get ();
}

Return Value

The parameter for the reference relative to the ray input.

Remarks

This value is valid only for References returned from FindReferencesByDirection(XYZ, XYZ, View3D). The value increases the further away the reference is from the origin point for the ray.

See Also

Reference Class


Transform Property

[image]

Revit 2011 API
Reference..::.Transform Property
Reference Class See Also Send Feedback
The transformation of the geometry item into the coordinates of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transform As Transform
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

If the reference doesn't contain any instances this will be the default transform.

See Also

Reference Class


UVPoint Property

[image]

Revit 2011 API
Reference..::.UVPoint Property
Reference Class See Also Send Feedback
The UV parameters of the reference, if the reference contains a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV UVPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property UVPoint As UV
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
}

Remarks

This value is valid only for references of type REFERENCE_TYPE_SURFACE. It is nullNothingnullptra null reference (Nothing in Visual Basic) for all other types.

See Also

Reference Class


ReferenceArray Class

[image]

Revit 2011 API
ReferenceArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferenceArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferenceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferenceArray

See Also

ReferenceArray Members


ReferenceArray Members

[image] [image]

Revit 2011 API
ReferenceArray Members
ReferenceArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArray type exposes the following members.

Constructors

Name | Description
ReferenceArray | Initializes a new instance of the ReferenceArray class

Methods

Name | Description
Append | Add the reference to the end of the array.
Clear | Removes every reference from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified reference into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a reference at a specified index within the array.
Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class


ReferenceArray Constructor

[image]

Revit 2011 API
ReferenceArray Constructor
ReferenceArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArray()

See Also

ReferenceArray Class


ReferenceArray Methods

[image] [image]

Revit 2011 API
ReferenceArray Methods
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Methods

Name | Description
Append | Add the reference to the end of the array.
Clear | Removes every reference from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified reference into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArray Class


Append Method

[image]

Revit 2011 API
ReferenceArray..::.Append Method
ReferenceArray Class See Also Send Feedback
Add the reference to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Reference item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Reference _
)
Visual C++
public:
virtual void Append(
    Reference^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Reference
The reference to be added.

See Also

ReferenceArray Class


Clear Method

[image]

Revit 2011 API
ReferenceArray..::.Clear Method
ReferenceArray Class See Also Send Feedback
Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArray Class


ForwardIterator Method

[image]

Revit 2011 API
ReferenceArray..::.ForwardIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class


GetEnumerator Method

[image]

Revit 2011 API
ReferenceArray..::.GetEnumerator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferenceArray Class


Insert Method

[image]

Revit 2011 API
ReferenceArray..::.Insert Method
ReferenceArray Class See Also Send Feedback
Insert the specified reference into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Reference^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Reference
The reference to be inserted into the array.
index
Type: System..::.Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class


ReverseIterator Method

[image]

Revit 2011 API
ReferenceArray..::.ReverseIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArray Class


ReferenceArray Properties

[image] [image]

Revit 2011 API
ReferenceArray Properties
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a reference at a specified index within the array.
Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class


IsEmpty Property

[image]

Revit 2011 API
ReferenceArray..::.IsEmpty Property
ReferenceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArray Class


Item Property

[image]

Revit 2011 API
ReferenceArray..::.Item Property
ReferenceArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Reference Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Reference
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Type: System..::.Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class


Size Property

[image]

Revit 2011 API
ReferenceArray..::.Size Property
ReferenceArray Class See Also Send Feedback
Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArray Class


ReferenceArrayArray Class

[image]

Revit 2011 API
ReferenceArrayArray Class
Members See Also Send Feedback
An array that contains ReferenceArray objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferenceArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferenceArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferenceArrayArray

See Also

ReferenceArrayArray Members


ReferenceArrayArray Members

[image] [image]

Revit 2011 API
ReferenceArrayArray Members
ReferenceArrayArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Constructors

Name | Description
ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class

Methods

Name | Description
Append |
Clear | Removes every ReferenceArray from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a ReferenceArray at a specified index within the array.
Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class


ReferenceArrayArray Constructor

[image]

Revit 2011 API
ReferenceArrayArray Constructor
ReferenceArrayArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayArray()

See Also

ReferenceArrayArray Class


ReferenceArrayArray Methods

[image] [image]

Revit 2011 API
ReferenceArrayArray Methods
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every ReferenceArray from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArray Class


Append Method

[image]

Revit 2011 API
ReferenceArrayArray..::.Append Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    ReferenceArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ReferenceArray _
)
Visual C++
public:
virtual void Append(
    ReferenceArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ReferenceArray

See Also

ReferenceArrayArray Class


Clear Method

[image]

Revit 2011 API
ReferenceArrayArray..::.Clear Method
ReferenceArrayArray Class See Also Send Feedback
Removes every ReferenceArray from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArrayArray Class


ForwardIterator Method

[image]

Revit 2011 API
ReferenceArrayArray..::.ForwardIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArrayArray Class


GetEnumerator Method

[image]

Revit 2011 API
ReferenceArrayArray..::.GetEnumerator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferenceArrayArray Class


Insert Method

[image]

Revit 2011 API
ReferenceArrayArray..::.Insert Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    ReferenceArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ReferenceArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferenceArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.ReferenceArray
index
Type: System..::.Int32

See Also

ReferenceArrayArray Class


ReverseIterator Method

[image]

Revit 2011 API
ReferenceArrayArray..::.ReverseIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArrayArray Class


ReferenceArrayArray Properties

[image] [image]

Revit 2011 API
ReferenceArrayArray Properties
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a ReferenceArray at a specified index within the array.
Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class


IsEmpty Property

[image]

Revit 2011 API
ReferenceArrayArray..::.IsEmpty Property
ReferenceArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArrayArray Class


Item Property

[image]

Revit 2011 API
ReferenceArrayArray..::.Item Property
ReferenceArrayArray Class See Also Send Feedback
Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferenceArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ReferenceArray
Visual C++
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

Returns the ReferenceArray at the specified index.

See Also

ReferenceArrayArray Class


Size Property

[image]

Revit 2011 API
ReferenceArrayArray..::.Size Property
ReferenceArrayArray Class See Also Send Feedback
Returns the number of ReferenceArrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArrayArray Class


ReferenceArrayArrayIterator Class

[image]

Revit 2011 API
ReferenceArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a ReferenceArray array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ReferenceArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferenceArrayArrayIterator

See Also

ReferenceArrayArrayIterator Members


ReferenceArrayArrayIterator Members

[image] [image]

Revit 2011 API
ReferenceArrayArrayIterator Members
ReferenceArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Constructors

Name | Description
ReferenceArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Constructor

[image]

Revit 2011 API
ReferenceArrayArrayIterator Constructor
ReferenceArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Methods

[image] [image]

Revit 2011 API
ReferenceArrayArrayIterator Methods
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ReferenceArrayArrayIterator..::.MoveNext Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


Reset Method

[image]

Revit 2011 API
ReferenceArrayArrayIterator..::.Reset Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Properties

[image] [image]

Revit 2011 API
ReferenceArrayArrayIterator Properties
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


Current Property

[image]

Revit 2011 API
ReferenceArrayArrayIterator..::.Current Property
ReferenceArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayIterator Class

[image]

Revit 2011 API
ReferenceArrayIterator Class
Members See Also Send Feedback
An iterator to a reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferenceArrayIterator

See Also

ReferenceArrayIterator Members


ReferenceArrayIterator Members

[image] [image]

Revit 2011 API
ReferenceArrayIterator Members
ReferenceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Constructors

Name | Description
ReferenceArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Constructor

[image]

Revit 2011 API
ReferenceArrayIterator Constructor
ReferenceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferenceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Methods

[image] [image]

Revit 2011 API
ReferenceArrayIterator Methods
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ReferenceArrayIterator..::.MoveNext Method
ReferenceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


Reset Method

[image]

Revit 2011 API
ReferenceArrayIterator..::.Reset Method
ReferenceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Properties

[image] [image]

Revit 2011 API
ReferenceArrayIterator Properties
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


Current Property

[image]

Revit 2011 API
ReferenceArrayIterator..::.Current Property
ReferenceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


ReferencePlane Class

[image]

Revit 2011 API
ReferencePlane Class
Members Example See Also Send Feedback
Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferencePlane : Element
Visual Basic (Declaration)
Public Class ReferencePlane _
    Inherits Element
Visual C++
public ref class ReferencePlane : public Element

Examples

CopyC#
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.DB.Plane plane = refPlane.Plane;
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ReferencePlane(ByVal refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As Autodesk.Revit.DB.XYZ = refPlane.BubbleEnd
    message += vbLf & "Bubble end: (" + bubbleEnd.X + ", " + bubbleEnd.Y + ", " + bubbleEnd.Z + ")"

    'get the direction of the reference plane
    Dim direction As Autodesk.Revit.DB.XYZ = refPlane.Direction
    message += vbLf & "Direction: (" + direction.X + ", " + direction.Y + ", " + direction.Z + ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As Autodesk.Revit.DB.XYZ = refPlane.FreeEnd
    message += vbLf & "Free End: (" + freeEnd.X + ", " + freeEnd.Y + ", " + freeEnd.Z + ")"

    'get the name of the reference plane
    message += vbLf & "Name: " + refPlane.Name

    'get the normal vector of the reference plane
    Dim normal As Autodesk.Revit.DB.XYZ = refPlane.Normal
    message += vbLf & "Normal vector: (" + normal.X + ", " + normal.Y + ", " + normal.Z + ")"

    'get the geometry plane to which the reference plane assigned
    Dim plane As Autodesk.Revit.DB.Plane = refPlane.Plane
    message += vbLf & "origin of the plane: (" + plane.Origin.X + ", " + plane.Origin.Y + ", " + plane.Origin.Z + ")"

    message += vbLf & "normal of the plane: (" + plane.Normal.X + ", " + plane.Normal.Y + ", " + plane.Normal.Z + ")"

    message += vbLf & "Xvec of the plane: (" + plane.XVec.X + ", " + plane.XVec.Y + ", " + plane.XVec.Z + ")"

    message += vbLf & "Yvec of the plane: (" + plane.YVec.X + ", " + plane.YVec.Y + ", " + plane.YVec.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ReferencePlane

See Also

ReferencePlane Members


ReferencePlane Members

[image] [image]

Revit 2011 API
ReferencePlane Members
ReferencePlane Class Methods Properties See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Flip | Flips the orientation of the reference plane.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BubbleEnd | The bubble end of the reference plane.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | The direction of the reference plane.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FreeEnd | The free end of the reference plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name property of the reference plane.
Normal | The normal vector of the reference plane.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | The geometry plane to which the reference plane is assigned.
Reference | The geometry reference of the reference plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ReferencePlane Class


ReferencePlane Methods

[image] [image]

Revit 2011 API
ReferencePlane Methods
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Flip | Flips the orientation of the reference plane.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePlane Class


Flip Method

[image]

Revit 2011 API
ReferencePlane..::.Flip Method
ReferencePlane Class See Also Send Feedback
Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Flip()
Visual Basic (Declaration)
Public Sub Flip
Visual C++
public:
void Flip()

See Also

ReferencePlane Class


ReferencePlane Properties

[image] [image]

Revit 2011 API
ReferencePlane Properties
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BubbleEnd | The bubble end of the reference plane.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | The direction of the reference plane.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FreeEnd | The free end of the reference plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name property of the reference plane.
Normal | The normal vector of the reference plane.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | The geometry plane to which the reference plane is assigned.
Reference | The geometry reference of the reference plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ReferencePlane Class


BubbleEnd Property

[image]

Revit 2011 API
ReferencePlane..::.BubbleEnd Property
ReferencePlane Class See Also Send Feedback
The bubble end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ BubbleEnd { get; set; }
Visual Basic (Declaration)
Public Property BubbleEnd As XYZ
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class


Direction Property

[image]

Revit 2011 API
ReferencePlane..::.Direction Property
ReferencePlane Class See Also Send Feedback
The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class


FreeEnd Property

[image]

Revit 2011 API
ReferencePlane..::.FreeEnd Property
ReferencePlane Class See Also Send Feedback
The free end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ FreeEnd { get; set; }
Visual Basic (Declaration)
Public Property FreeEnd As XYZ
Visual C++
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class


Name Property

[image]

Revit 2011 API
ReferencePlane..::.Name Property
ReferencePlane Class See Also Send Feedback
The name property of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property overrides Element's default implementation.

See Also

ReferencePlane Class


Normal Property

[image]

Revit 2011 API
ReferencePlane..::.Normal Property
ReferencePlane Class See Also Send Feedback
The normal vector of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As XYZ
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

ReferencePlane Class


Parameter Property

[image] [image]

Revit 2011 API
ReferencePlane..::.Parameter Property
ReferencePlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ReferencePlane Class
ReferencePlane Members


Plane Property

[image]

Revit 2011 API
ReferencePlane..::.Plane Property
ReferencePlane Class See Also Send Feedback
The geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

See Also

ReferencePlane Class


Reference Property

[image]

Revit 2011 API
ReferencePlane..::.Reference Property
ReferencePlane Class See Also Send Feedback
The geometry reference of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reference As Reference
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

ReferencePlane Class


ReferencePoint Class

[image]

Revit 2011 API
ReferencePoint Class
Members See Also Send Feedback
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferencePoint : Element
Visual Basic (Declaration)
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ReferencePoint

See Also

ReferencePoint Members


ReferencePoint Members

[image] [image]

Revit 2011 API
ReferencePoint Members
ReferencePoint Class Methods Properties See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Position | The position of the ReferencePoint.
ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class


ReferencePoint Methods

[image] [image]

Revit 2011 API
ReferencePoint Methods
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
GetCoordinateSystem | The position and orientation of the ReferencePoint.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the point.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetCoordinateSystem | The position and orientation of the ReferencePoint.
SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
SetVisibility | Sets the visibility for the point.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceXY Method

[image]

Revit 2011 API
ReferencePoint..::.GetCoordinatePlaneReferenceXY Method
ReferencePoint Class See Also Send Feedback
A reference for the XY plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXY()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceXY As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXY()

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceXZ Method

[image]

Revit 2011 API
ReferencePoint..::.GetCoordinatePlaneReferenceXZ Method
ReferencePoint Class See Also Send Feedback
A reference for the XZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXZ()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceXZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXZ()

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceYZ Method

[image]

Revit 2011 API
ReferencePoint..::.GetCoordinatePlaneReferenceYZ Method
ReferencePoint Class See Also Send Feedback
A reference for the YZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceYZ()
Visual Basic (Declaration)
Public Function GetCoordinatePlaneReferenceYZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceYZ()

See Also

ReferencePoint Class


GetCoordinateSystem Method

[image]

Revit 2011 API
ReferencePoint..::.GetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic (Declaration)
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class


GetInterpolatingCurves Method

[image]

Revit 2011 API
ReferencePoint..::.GetInterpolatingCurves Method
ReferencePoint Class See Also Send Feedback
The set of CurveByPoints elements that interpolate a ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveByPointsArray GetInterpolatingCurves()
Visual Basic (Declaration)
Public Function GetInterpolatingCurves As CurveByPointsArray
Visual C++
public:
CurveByPointsArray^ GetInterpolatingCurves()

Remarks

A CurveByPoints is in the GetInterpolatingCurves()()() array if and only if the ReferencePoint is in the Points array of CurveByPoints.

See Also

ReferencePoint Class


GetPointElementReference Method

[image]

Revit 2011 API
ReferencePoint..::.GetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointElementReference GetPointElementReference()
Visual Basic (Declaration)
Public Function GetPointElementReference As PointElementReference
Visual C++
public:
PointElementReference^ GetPointElementReference()

Return Value

A PointElementReference object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the ReferencePoint does not have a reference.

See Also

ReferencePoint Class


GetVisibility Method

[image]

Revit 2011 API
ReferencePoint..::.GetVisibility Method
ReferencePoint Class See Also Send Feedback
Gets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the ReferencePoint.

See Also

ReferencePoint Class


SetCoordinateSystem Method

[image]

Revit 2011 API
ReferencePoint..::.SetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Visual Basic (Declaration)
Public Sub SetCoordinateSystem ( _
    coordinateSystem As Transform _
)
Visual C++
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)

Parameters

coordinateSystem
Type: Autodesk.Revit.DB..::.Transform

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


SetPointElementReference Method

[image]

Revit 2011 API
ReferencePoint..::.SetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Visual Basic (Declaration)
Public Sub SetPointElementReference ( _
    pointElementReference As PointElementReference _
)
Visual C++
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)

Parameters

pointElementReference
Type: Autodesk.Revit.DB..::.PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)

Remarks

pointElementReference may be nullNothingnullptra null reference (Nothing in Visual Basic), in which case the ReferencePoint does not follow any other element. When Reference is changed from nullNothingnullptra null reference (Nothing in Visual Basic) to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to nullNothingnullptra null reference (Nothing in Visual Basic), the point does not move or rotate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.

See Also

ReferencePoint Class


SetVisibility Method

[image]

Revit 2011 API
ReferencePoint..::.SetVisibility Method
ReferencePoint Class See Also Send Feedback
Sets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the point can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

ReferencePoint Class


ReferencePoint Properties

[image] [image]

Revit 2011 API
ReferencePoint Properties
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Position | The position of the ReferencePoint.
ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Whether the point is visible when the family is loaded into a project.

See Also

ReferencePoint Class


CoordinatePlaneVisibility Property

[image]

Revit 2011 API
ReferencePoint..::.CoordinatePlaneVisibility Property
ReferencePoint Class See Also Send Feedback
Visibility settings for the coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CoordinatePlaneVisibility CoordinatePlaneVisibility { get; set; }
Visual Basic (Declaration)
Public Property CoordinatePlaneVisibility As CoordinatePlaneVisibility
Visual C++
public:
property CoordinatePlaneVisibility CoordinatePlaneVisibility {
    CoordinatePlaneVisibility get ();
    void set (CoordinatePlaneVisibility value);
}

See Also

ReferencePoint Class


Name Property

[image]

Revit 2011 API
ReferencePoint..::.Name Property
ReferencePoint Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

See Also

ReferencePoint Class


Parameter Property

[image] [image]

Revit 2011 API
ReferencePoint..::.Parameter Property
ReferencePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ReferencePoint Class
ReferencePoint Members


Position Property

[image]

Revit 2011 API
ReferencePoint..::.Position Property
ReferencePoint Class See Also Send Feedback
The position of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Position { get; set; }
Visual Basic (Declaration)
Public Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


ShowNormalReferencePlaneOnly Property

[image]

Revit 2011 API
ReferencePoint..::.ShowNormalReferencePlaneOnly Property
ReferencePoint Class See Also Send Feedback
Whether all three coordinate planes are shown, or only the normal (XY) plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ShowNormalReferencePlaneOnly { get; set; }
Visual Basic (Declaration)
Public Property ShowNormalReferencePlaneOnly As Boolean
Visual C++
public:
property bool ShowNormalReferencePlaneOnly {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class


Visible Property

[image]

Revit 2011 API
ReferencePoint..::.Visible Property
ReferencePoint Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class


ReferencePointArray Class

[image]

Revit 2011 API
ReferencePointArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ReferencePointArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ReferencePointArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferencePointArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferencePointArray

See Also

ReferencePointArray Members


ReferencePointArray Members

[image] [image]

Revit 2011 API
ReferencePointArray Members
ReferencePointArray Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArray type exposes the following members.

Constructors

Name | Description
ReferencePointArray | Initializes a new instance of the ReferencePointArray class

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

ReferencePointArray Class


ReferencePointArray Constructor

[image]

Revit 2011 API
ReferencePointArray Constructor
ReferencePointArray Class See Also Send Feedback
Initializes a new instance of the ReferencePointArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePointArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePointArray()

See Also

ReferencePointArray Class


ReferencePointArray Methods

[image] [image]

Revit 2011 API
ReferencePointArray Methods
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Methods

Name | Description
Append |
Clear |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArray Class


Append Method

[image]

Revit 2011 API
ReferencePointArray..::.Append Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    ReferencePoint item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As ReferencePoint _
)
Visual C++
public:
virtual void Append(
    ReferencePoint^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ReferencePoint

See Also

ReferencePointArray Class


Clear Method

[image]

Revit 2011 API
ReferencePointArray..::.Clear Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferencePointArray Class


ForwardIterator Method

[image]

Revit 2011 API
ReferencePointArray..::.ForwardIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ForwardIterator()

See Also

ReferencePointArray Class


GetEnumerator Method

[image]

Revit 2011 API
ReferencePointArray..::.GetEnumerator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ReferencePointArray Class


Insert Method

[image]

Revit 2011 API
ReferencePointArray..::.Insert Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    ReferencePoint item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As ReferencePoint, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferencePoint^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.ReferencePoint
index
Type: System..::.Int32

See Also

ReferencePointArray Class


ReverseIterator Method

[image]

Revit 2011 API
ReferencePointArray..::.ReverseIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ReverseIterator()

See Also

ReferencePointArray Class


ReferencePointArray Properties

[image] [image]

Revit 2011 API
ReferencePointArray Properties
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item |
Size |

See Also

ReferencePointArray Class


IsEmpty Property

[image]

Revit 2011 API
ReferencePointArray..::.IsEmpty Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

ReferencePointArray Class


Item Property

[image]

Revit 2011 API
ReferencePointArray..::.Item Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ReferencePoint Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As ReferencePoint
Visual C++
public:
virtual property ReferencePoint^ Item[int index] {
    ReferencePoint^ get (int index);
    void set (int index, ReferencePoint^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ReferencePointArray Class


Size Property

[image]

Revit 2011 API
ReferencePointArray..::.Size Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferencePointArray Class


ReferencePointArrayIterator Class

[image]

Revit 2011 API
ReferencePointArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ReferencePointArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ReferencePointArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferencePointArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ReferencePointArrayIterator

See Also

ReferencePointArrayIterator Members


ReferencePointArrayIterator Members

[image] [image]

Revit 2011 API
ReferencePointArrayIterator Members
ReferencePointArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Constructors

Name | Description
ReferencePointArrayIterator | Initializes a new instance of the ReferencePointArrayIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Constructor

[image]

Revit 2011 API
ReferencePointArrayIterator Constructor
ReferencePointArrayIterator Class See Also Send Feedback
Initializes a new instance of the ReferencePointArrayIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferencePointArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReferencePointArrayIterator()

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Methods

[image] [image]

Revit 2011 API
ReferencePointArrayIterator Methods
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
ReferencePointArrayIterator..::.MoveNext Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

ReferencePointArrayIterator Class


Reset Method

[image]

Revit 2011 API
ReferencePointArrayIterator..::.Reset Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Properties

[image] [image]

Revit 2011 API
ReferencePointArrayIterator Properties
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


Current Property

[image]

Revit 2011 API
ReferencePointArrayIterator..::.Current Property
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

ReferencePointArrayIterator Class


ReferenceType Enumeration

[image]

Revit 2011 API
ReferenceType Enumeration
See Also Send Feedback
Reference types of curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ReferenceType
Visual Basic (Declaration)
Public Enumeration ReferenceType
Visual C++
public enum class ReferenceType

Members

Member name | Description
None |
WeakReference |
StrongReference |

See Also


RevitUIFamilyLoadOptions Class

[image]

Revit 2011 API
RevitUIFamilyLoadOptions Class
Members See Also Send Feedback
Allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitUIFamilyLoadOptions : IFamilyLoadOptions
Visual Basic (Declaration)
Public Class RevitUIFamilyLoadOptions _
    Implements IFamilyLoadOptions
Visual C++
public ref class RevitUIFamilyLoadOptions : IFamilyLoadOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.RevitUIFamilyLoadOptions

See Also

RevitUIFamilyLoadOptions Members


RevitUIFamilyLoadOptions Members

[image] [image]

Revit 2011 API
RevitUIFamilyLoadOptions Members
RevitUIFamilyLoadOptions Class Constructors Methods See Also Send Feedback

The RevitUIFamilyLoadOptions type exposes the following members.

Constructors

Name | Description
RevitUIFamilyLoadOptions | Initializes a new instance of the RevitUIFamilyLoadOptions class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
OnSharedFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitUIFamilyLoadOptions Class


RevitUIFamilyLoadOptions Constructor

[image]

Revit 2011 API
RevitUIFamilyLoadOptions Constructor
RevitUIFamilyLoadOptions Class See Also Send Feedback
Initializes a new instance of the RevitUIFamilyLoadOptions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RevitUIFamilyLoadOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RevitUIFamilyLoadOptions()

See Also

RevitUIFamilyLoadOptions Class


RevitUIFamilyLoadOptions Methods

[image] [image]

Revit 2011 API
RevitUIFamilyLoadOptions Methods
RevitUIFamilyLoadOptions Class See Also Send Feedback

The RevitUIFamilyLoadOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OnFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
OnSharedFamilyFound | Implements the interface method by using the Revit dialog box to handle this situation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitUIFamilyLoadOptions Class


OnFamilyFound Method

[image]

Revit 2011 API
RevitUIFamilyLoadOptions..::.OnFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool OnFamilyFound(
    bool familyInUse,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnFamilyFound ( _
    familyInUse As Boolean, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnFamilyFound(
    bool familyInUse,
    bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::.Boolean
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnFamilyFound(Boolean, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between families. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class


OnSharedFamilyFound Method

[image]

Revit 2011 API
RevitUIFamilyLoadOptions..::.OnSharedFamilyFound Method
RevitUIFamilyLoadOptions Class See Also Send Feedback
Implements the interface method by using the Revit dialog box to handle this situation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    ref FamilySource source,
    ref bool overwriteParameterValues
)
Visual Basic (Declaration)
Public Overridable Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    ByRef source As FamilySource, _
    ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
public:
virtual bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    FamilySource% source,
    bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.DB..::.Family
familyInUse
Type: System..::.Boolean
source
Type: Autodesk.Revit.DB..::.FamilySource %
overwriteParameterValues
Type: System..::.Boolean %

Implements

IFamilyLoadOptions..::.OnSharedFamilyFound(Family, Boolean, FamilySource%, Boolean%)

Remarks

A Revit dialog box will be shown with the question about the conflict between shared families versions in target document and current family. The user may choose the response. If the response is to cancel the load of the family, an exception will be thrown from LoadFamily

See Also

RevitUIFamilyLoadOptions Class


Revolution Class

[image]

Revit 2011 API
Revolution Class
Members See Also Send Feedback
A revolution solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Revolution : GenericForm
Visual Basic (Declaration)
Public Class Revolution _
    Inherits GenericForm
Visual C++
public ref class Revolution : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Revolution

See Also

Revolution Members


Revolution Members

[image] [image]

Revit 2011 API
Revolution Members
Revolution Class Methods Properties See Also Send Feedback

The Revolution type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Axis | Returns the Axis of the Revolution.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndAngle | The end angle of the revolution relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Revolution.
StartAngle | The start angle of the revolution relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution Class


Revolution Methods

[image] [image]

Revit 2011 API
Revolution Methods
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Revolution Class


Revolution Properties

[image] [image]

Revit 2011 API
Revolution Properties
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Properties

Name | Description
Axis | Returns the Axis of the Revolution.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndAngle | The end angle of the revolution relative to the sketch plane.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Sketch | Returns the Sketch of the Revolution.
StartAngle | The start angle of the revolution relative to the sketch plane.
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Revolution Class


Axis Property

[image]

Revit 2011 API
Revolution..::.Axis Property
Revolution Class See Also Send Feedback
Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ModelLine Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As ModelLine
Visual C++
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}

Remarks

This property is used to retrieve the Axis of the Revolution.

See Also

Revolution Class


EndAngle Property

[image]

Revit 2011 API
Revolution..::.EndAngle Property
Revolution Class See Also Send Feedback
The end angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double EndAngle { get; set; }
Visual Basic (Declaration)
Public Property EndAngle As Double
Visual C++
public:
property double EndAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


Parameter Property

[image] [image]

Revit 2011 API
Revolution..::.Parameter Property
Revolution Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Revolution Class
Revolution Members


Sketch Property

[image]

Revit 2011 API
Revolution..::.Sketch Property
Revolution Class See Also Send Feedback
Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sketch As Sketch
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketch of the Revolution.

See Also

Revolution Class


StartAngle Property

[image]

Revit 2011 API
Revolution..::.StartAngle Property
Revolution Class See Also Send Feedback
The start angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


RevolvedFace Class

[image]

Revit 2011 API
RevolvedFace Class
Members Example See Also Send Feedback
A revolved face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RevolvedFace : Face
Visual Basic (Declaration)
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revolved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = revolvedFace.Origin
        Dim axis As Autodesk.Revit.DB.XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As Autodesk.Revit.DB.XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.RevolvedFace

See Also

RevolvedFace Members


RevolvedFace Members

[image] [image]

Revit 2011 API
RevolvedFace Members
RevolvedFace Class Methods Properties See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
Curve | Profile curve of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radius of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


RevolvedFace Methods

[image] [image]

Revit 2011 API
RevolvedFace Methods
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class


Intersect Method

[image] [image]

Revit 2011 API
RevolvedFace..::.Intersect Method
RevolvedFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


IsInside Method

[image] [image]

Revit 2011 API
RevolvedFace..::.IsInside Method
RevolvedFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


RevolvedFace Properties

[image] [image]

Revit 2011 API
RevolvedFace Properties
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Axis | Axis of the surface.
Curve | Profile curve of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Origin | Origin of the surface.
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Radius | Radius of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


Axis Property

[image]

Revit 2011 API
RevolvedFace..::.Axis Property
RevolvedFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As XYZ
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

RevolvedFace Class


Curve Property

[image]

Revit 2011 API
RevolvedFace..::.Curve Property
RevolvedFace Class See Also Send Feedback
Profile curve of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

RevolvedFace Class


Origin Property

[image]

Revit 2011 API
RevolvedFace..::.Origin Property
RevolvedFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedFace Class


Radius Property

[image]

Revit 2011 API
RevolvedFace..::.Radius Property
RevolvedFace Class See Also Send Feedback
Radius of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Radius[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RevolvedFace Class


RoofBase Class

[image]

Revit 2011 API
RoofBase Class
Members See Also Send Feedback
Represents all kinds of Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoofBase : HostObject
Visual Basic (Declaration)
Public Class RoofBase _
    Inherits HostObject
Visual C++
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.RoofBase
Autodesk.Revit.DB..::.ExtrusionRoof
Autodesk.Revit.DB..::.FootPrintRoof

See Also

RoofBase Members


RoofBase Members

[image] [image]

Revit 2011 API
RoofBase Members
RoofBase Class Methods Properties See Also Send Feedback

The RoofBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType.
FasciaDepth | Retrieve or set the FasciaDepth.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoofBase Class


RoofBase Methods

[image] [image]

Revit 2011 API
RoofBase Methods
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofBase Class


RoofBase Properties

[image] [image]

Revit 2011 API
RoofBase Properties
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EaveCuts | Retrieve or set the EaveCutterType.
FasciaDepth | Retrieve or set the FasciaDepth.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RoofType | Retrieve or set the Type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoofBase Class


EaveCuts Property

[image]

Revit 2011 API
RoofBase..::.EaveCuts Property
RoofBase Class See Also Send Feedback
Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EaveCutterType EaveCuts { get; set; }
Visual Basic (Declaration)
Public Property EaveCuts As EaveCutterType
Visual C++
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}

See Also

RoofBase Class


FasciaDepth Property

[image]

Revit 2011 API
RoofBase..::.FasciaDepth Property
RoofBase Class See Also Send Feedback
Retrieve or set the FasciaDepth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FasciaDepth { get; set; }
Visual Basic (Declaration)
Public Property FasciaDepth As Double
Visual C++
public:
property double FasciaDepth {
    double get ();
    void set (double value);
}

Remarks

If the EaveCutterType is PlumbCut, this property doesn't make sense.

See Also

RoofBase Class


Parameter Property

[image] [image]

Revit 2011 API
RoofBase..::.Parameter Property
RoofBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoofBase Class
RoofBase Members


RoofType Property

[image]

Revit 2011 API
RoofBase..::.RoofType Property
RoofBase Class See Also Send Feedback
Retrieve or set the Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoofType RoofType { get; set; }
Visual Basic (Declaration)
Public Property RoofType As RoofType
Visual C++
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}

See Also

RoofBase Class


SlabShapeEditor Property

[image]

Revit 2011 API
RoofBase..::.SlabShapeEditor Property
RoofBase Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RoofBase Class


RoofType Class

[image]

Revit 2011 API
RoofType Class
Members See Also Send Feedback
Represents a specific type of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoofType : HostObjAttributes
Visual Basic (Declaration)
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.RoofType

See Also

RoofType Members


RoofType Members

[image] [image]

Revit 2011 API
RoofType Members
RoofType Class Methods Properties See Also Send Feedback

The RoofType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoofType Class


RoofType Methods

[image] [image]

Revit 2011 API
RoofType Methods
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofType Class


RoofType Properties

[image] [image]

Revit 2011 API
RoofType Properties
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoofType Class


Parameter Property

[image] [image]

Revit 2011 API
RoofType..::.Parameter Property
RoofType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoofType Class
RoofType Members


RoofTypeSet Class

[image]

Revit 2011 API
RoofTypeSet Class
Members See Also Send Feedback
A set that contains roof types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoofTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RoofTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoofTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.RoofTypeSet

See Also

RoofTypeSet Members


RoofTypeSet Members

[image] [image]

Revit 2011 API
RoofTypeSet Members
RoofTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSet type exposes the following members.

Constructors

Name | Description
RoofTypeSet | Initializes a new instance of the RoofTypeSet class

Methods

Name | Description
Clear | Removes every roof type from the set, rendering it empty.
Contains | Tests for the existence of a roof type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified roof type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified roof type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class


RoofTypeSet Constructor

[image]

Revit 2011 API
RoofTypeSet Constructor
RoofTypeSet Class See Also Send Feedback
Initializes a new instance of the RoofTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoofTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSet()

See Also

RoofTypeSet Class


RoofTypeSet Methods

[image] [image]

Revit 2011 API
RoofTypeSet Methods
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every roof type from the set, rendering it empty.
Contains | Tests for the existence of a roof type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified roof type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified roof type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSet Class


Clear Method

[image]

Revit 2011 API
RoofTypeSet..::.Clear Method
RoofTypeSet Class See Also Send Feedback
Removes every roof type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoofTypeSet Class


Contains Method

[image]

Revit 2011 API
RoofTypeSet..::.Contains Method
RoofTypeSet Class See Also Send Feedback
Tests for the existence of a roof type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.RoofType
The roof type to be searched for.

Return Value

The Contains method returns True if the roof type is within the set, otherwise False.

See Also

RoofTypeSet Class


Erase Method

[image]

Revit 2011 API
RoofTypeSet..::.Erase Method
RoofTypeSet Class See Also Send Feedback
Removes a specified roof type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
RoofTypeSet..::.ForwardIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoofTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
RoofTypeSet..::.GetEnumerator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RoofTypeSet Class


Insert Method

[image]

Revit 2011 API
RoofTypeSet..::.Insert Method
RoofTypeSet Class See Also Send Feedback
Insert the specified roof type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RoofType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.RoofType
The roof type to be inserted into the set.

Return Value

Returns whether the roof type was inserted into the set.

See Also

RoofTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
RoofTypeSet..::.ReverseIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoofTypeSet Class


RoofTypeSet Properties

[image] [image]

Revit 2011 API
RoofTypeSet Properties
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
RoofTypeSet..::.IsEmpty Property
RoofTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoofTypeSet Class


Size Property

[image]

Revit 2011 API
RoofTypeSet..::.Size Property
RoofTypeSet Class See Also Send Feedback
Returns the number of roof types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoofTypeSet Class


RoofTypeSetIterator Class

[image]

Revit 2011 API
RoofTypeSetIterator Class
Members See Also Send Feedback
An iterator to a roof type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RoofTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RoofTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoofTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.RoofTypeSetIterator

See Also

RoofTypeSetIterator Members


RoofTypeSetIterator Members

[image] [image]

Revit 2011 API
RoofTypeSetIterator Members
RoofTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Constructors

Name | Description
RoofTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Constructor

[image]

Revit 2011 API
RoofTypeSetIterator Constructor
RoofTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoofTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoofTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Methods

[image] [image]

Revit 2011 API
RoofTypeSetIterator Methods
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
RoofTypeSetIterator..::.MoveNext Method
RoofTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
RoofTypeSetIterator..::.Reset Method
RoofTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Properties

[image] [image]

Revit 2011 API
RoofTypeSetIterator Properties
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class


Current Property

[image]

Revit 2011 API
RoofTypeSetIterator..::.Current Property
RoofTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class


RuledFace Class

[image]

Revit 2011 API
RuledFace Class
Members Example See Also Send Feedback
A ruled face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RuledFace : Face
Visual Basic (Declaration)
Public Class RuledFace _
    Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

CopyC#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
CopyVB.NET
Private Sub GetRuledFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As Autodesk.Revit.DB.XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Face
Autodesk.Revit.DB..::.RuledFace

See Also

RuledFace Members


RuledFace Members

[image] [image]

Revit 2011 API
RuledFace Members
RuledFace Class Methods Properties See Also Send Feedback

The RuledFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Curve | Profile curves of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Point | Profile points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


RuledFace Methods

[image] [image]

Revit 2011 API
RuledFace Methods
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Methods

Name | Description
ComputeDerivatives | Returns the moving frame around the face at the specified parameters. (Inherited from Face.)
ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | Evaluates parameters on the face. (Inherited from Face.)
GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Overloaded. Calculates the intersection of the specified curve with this face.
IsInside | Overloaded. Indicates whether the specified point is within this face.
Project | Projects the specified point on this face. (Inherited from Face.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RuledFace Class


Intersect Method

[image] [image]

Revit 2011 API
RuledFace..::.Intersect Method
RuledFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

Name | Description
Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


IsInside Method

[image] [image]

Revit 2011 API
RuledFace..::.IsInside Method
RuledFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

Name | Description
IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


RuledFace Properties

[image] [image]

Revit 2011 API
RuledFace Properties
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Properties

Name | Description
Area | The area of this face. (Inherited from Face.)
Curve | Profile curves of the surface.
EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTwoSided | Determines if a face is two-sided (degenerate) (Inherited from Face.)
MaterialElement | Element describing the material from which this face is composed. (Inherited from Face.)
Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Point | Profile points of the surface.
Reference | Returns a stable reference to the face. (Inherited from Face.)
Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


Curve Property

[image]

Revit 2011 API
RuledFace..::.Curve Property
RuledFace Class See Also Send Feedback
Profile curves of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    index As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int index] {
    Curve^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RuledFace Class


Point Property

[image]

Revit 2011 API
RuledFace..::.Point Property
RuledFace Class See Also Send Feedback
Profile points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Point[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

RuledFace Class


SATExportOptions Class

[image]

Revit 2011 API
SATExportOptions Class
Members See Also Send Feedback
SAT Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SATExportOptions : CADExportOptions
Visual Basic (Declaration)
Public Class SATExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class SATExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.CADExportOptions
Autodesk.Revit.DB..::.SATExportOptions

See Also

SATExportOptions Members


SATExportOptions Members

[image] [image]

Revit 2011 API
SATExportOptions Members
SATExportOptions Class Constructors Methods See Also Send Feedback

The SATExportOptions type exposes the following members.

Constructors

Name | Description
SATExportOptions | Default constructor. Sets all options to their default values.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SATExportOptions Class


SATExportOptions Constructor

[image]

Revit 2011 API
SATExportOptions Constructor
SATExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SATExportOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SATExportOptions()

See Also

SATExportOptions Class


SATExportOptions Methods

[image] [image]

Revit 2011 API
SATExportOptions Methods
SATExportOptions Class See Also Send Feedback

The SATExportOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SATExportOptions Class


SectionType Enumeration

[image]

Revit 2011 API
SectionType Enumeration
See Also Send Feedback
Declares the section data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum SectionType
Visual Basic (Declaration)
Public Enumeration SectionType
Visual C++
public enum class SectionType

Members

Member name | Description
None |
Header |
Body |
Summary |
Footer |

See Also


ServiceType Enumeration

[image]

Revit 2011 API
ServiceType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ServiceType
Visual Basic (Declaration)
Public Enumeration ServiceType
Visual C++
public enum class ServiceType

Members

Member name | Description
kNoServiceType | Service Type is NoServiceType.
kCentralHeatingRadiators | Service Type is CentralHeatingRadiators.
kCentralHeatingConvectors | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiantFloor | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingHotAir | Service Type is CentralHeatingHotAir.
kOtherRoomHeater | Service Type is OtherRoomHeater.
kRadiantHeaterFlue | Service Type is RadiantHeaterFlue.
kRadiantHeaterNoFlue | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterMultiburner | Service Type is RadiantHeaterMultiburner.
kForcedConvectionHeaterFlue | Service Type is ForcedConvectionHeaterFlue.
kForcedConvectionHeaterNoFlue | Service Type is ForcedConvectionHeaterNoFlue.
kVAVSingleDuct | Service Type is VAVSingleDuct.
kVAVDualDuct | Service Type is VAVDualDuct.
kVAVIndoorPackagedCabinet | Service Type is VAVIndoorPackagedCabinet.
kVAVTerminalReheat | Service Type is VAVTerminalReheat.
kFanCoilSystem | Service Type is FanCoilSystem.
kInductionSystem | Service Type is InductionSystem.
kConstantVolumeFixedOA | Service Type is ConstantVolumeFixedOA.
kConstantVolumeVariableOA | Service Type is ConstantVolumeVariableOA.
kConstantVolumeTerminalReheat | Service Type is ConstantVolumeTerminalReheat.
kMultizoneHotDeckColdDeck | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeDualDuct | Service Type is ConstantVolumeDualDuct.
kRadiantCooledCeilings | Service Type is RadiantCooledCeilings.
kActiveChilledBeams | Service Type is ActiveChilledBeams.
kWaterLoopHeatPump | Service Type is WaterLoopHeatPump.
kVariableRefrigerantFlow | Service Type is VariableRefrigerantFlow.
kSplitSystemsWithNaturalVentilation | Service Type is SplitSystemsWithNaturalVentilation.
kSplitSystemsWithMechanicalVentilation | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithMechanicalVentilationWithCooling | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also


SetComparisonResult Enumeration

[image]

Revit 2011 API
SetComparisonResult Enumeration
See Also Send Feedback
An enumerated type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SetComparisonResult
Visual Basic (Declaration)
Public Enumeration SetComparisonResult
Visual C++
public enum class SetComparisonResult

Members

Member name | Description
LeftEmpty | The left set is empty and the right set is not.
RightEmpty | The right set is empty and the left set is not.
BothEmpty | Both sets are empty.
Disjoint | Both sets are not empty and don't overlap.
Overlap | The overlap of two sets is not empty and strict subset of both.
Subset | Both sets are not empty and the left set is strict subset of the right.
Superset | Both sets are not empty and the left set is strict superset of the right.
Equal | Two nonempty sets are equal.

See Also


Settings Class

[image]

Revit 2011 API
Settings Class
Members Example See Also Send Feedback
The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Settings : APIObject
Visual Basic (Declaration)
Public Class Settings _
    Inherits APIObject
Visual C++
public ref class Settings : public APIObject

Examples

CopyC#
// Get some of the settings information, inluding categories, Materials and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
prompt += "\nNumber of Materials: " + settings.Materials.Size;
prompt += "\nNumber of Fill Patterns: " + settings.FillPatterns.Size;
prompt += "\nNumber of Line Patterns: " + settings.LinePatterns.Size;

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get some of the settings information, inluding categories, Materials and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As [String] = "Setting information: "
prompt += vbLf & "Number of Categories: " + settings.Categories.Size
prompt += vbLf & "Number of Materials: " + settings.Materials.Size
prompt += vbLf & "Number of Fill Patterns: " + settings.FillPatterns.Size
prompt += vbLf & "Number of Line Patterns: " + settings.LinePatterns.Size

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Settings

See Also

Settings Members


Settings Members

[image] [image]

Revit 2011 API
Settings Members
Settings Class Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class


Settings Methods

[image] [image]

Revit 2011 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings Class


Settings Properties

[image] [image]

Revit 2011 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

Name | Description
Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
FillPatterns | Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
LinePatterns | Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.
Materials | Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.
TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class


Categories Property

[image]

Revit 2011 API
Settings..::.Categories Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Categories Categories { get; }
Visual Basic (Declaration)
Public ReadOnly Property Categories As Categories
Visual C++
public:
property Categories^ Categories {
    Categories^ get ();
}

See Also

Settings Class


ElectricalSetting Property

[image]

Revit 2011 API
Settings..::.ElectricalSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSetting ElectricalSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectricalSetting As ElectricalSetting
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class


FillPatterns Property

[image]

Revit 2011 API
Settings..::.FillPatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the FillPatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FillPatternSet FillPatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillPatterns As FillPatternSet
Visual C++
public:
property FillPatternSet^ FillPatterns {
    FillPatternSet^ get ();
}

See Also

Settings Class


LinePatterns Property

[image]

Revit 2011 API
Settings..::.LinePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the LinePatterns contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePatternSet LinePatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinePatterns As LinePatternSet
Visual C++
public:
property LinePatternSet^ LinePatterns {
    LinePatternSet^ get ();
}

See Also

Settings Class


Materials Property

[image]

Revit 2011 API
Settings..::.Materials Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the Materials contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Materials Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As Materials
Visual C++
public:
property Materials^ Materials {
    Materials^ get ();
}

See Also

Settings Class


TilePatterns Property

[image]

Revit 2011 API
Settings..::.TilePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to the TilePattern objects in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TilePatterns TilePatterns { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilePatterns As TilePatterns
Visual C++
public:
property TilePatterns^ TilePatterns {
    TilePatterns^ get ();
}

See Also

Settings Class


VolumeCalculationSetting Property

[image]

Revit 2011 API
Settings..::.VolumeCalculationSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VolumeCalculationSetting VolumeCalculationSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property VolumeCalculationSetting As VolumeCalculationSetting
Visual C++
public:
property VolumeCalculationSetting^ VolumeCalculationSetting {
    VolumeCalculationSetting^ get ();
}

See Also

Settings Class


SharedParameterApplicableRule Class

[image]

Revit 2011 API
SharedParameterApplicableRule Class
Members See Also Send Feedback
Tests whether an element supports a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SharedParameterApplicableRule : FilterRule
Visual Basic (Declaration)
Public Class SharedParameterApplicableRule _
    Inherits FilterRule
Visual C++
public ref class SharedParameterApplicableRule : public FilterRule

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.FilterRule
Autodesk.Revit.DB..::.SharedParameterApplicableRule

See Also

SharedParameterApplicableRule Members


SharedParameterApplicableRule Members

[image] [image]

Revit 2011 API
SharedParameterApplicableRule Members
SharedParameterApplicableRule Class Constructors Methods Properties See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Constructors

Name | Description
SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Constructor

[image]

Revit 2011 API
SharedParameterApplicableRule Constructor
SharedParameterApplicableRule Class See Also Send Feedback
Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SharedParameterApplicableRule(
    string parameterName
)
Visual Basic (Declaration)
Public Sub New ( _
    parameterName As String _
)
Visual C++
public:
SharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::.String
The name of the parameter that an element must support to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Methods

[image] [image]

Revit 2011 API
SharedParameterApplicableRule Methods
SharedParameterApplicableRule Class See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FilterRule.)
ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Properties

[image] [image]

Revit 2011 API
SharedParameterApplicableRule Properties
SharedParameterApplicableRule Class See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Properties

Name | Description
ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


ParameterName Property

[image]

Revit 2011 API
SharedParameterApplicableRule..::.ParameterName Property
SharedParameterApplicableRule Class See Also Send Feedback
The name of the parameter that an element must support to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string ParameterName { get; set; }
Visual Basic (Declaration)
Public Property ParameterName As String
Visual C++
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

See Also

SharedParameterApplicableRule Class


SiteLocation Class

[image]

Revit 2011 API
SiteLocation Class
Members Example See Also Send Feedback
Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SiteLocation : ElementType
Visual Basic (Declaration)
Public Class SiteLocation _
    Inherits ElementType
Visual C++
public ref class SiteLocation : public ElementType

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Examples

CopyC#
// Get the SiteLocation instance.
Autodesk.Revit.DB.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + "��";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + "��";
prompt += "\n\t" + "TimeZone: " + site.TimeZone;

// Give the user some information.
TaskDialog.Show("Revit",prompt);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
CopyVB.NET
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.DB.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const  angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As [String] = "Current project's Site location information:"
prompt += vbLf & vbTab + "Latitude: " + site.Latitude / angleRatio + "¡ã"
prompt += vbLf & vbTab + "Longitude: " + site.Longitude / angleRatio + "¡ã"
prompt += vbLf & vbTab + "TimeZone: " + site.TimeZone

' Give the user some information.
TaskDialog.Show("Revit", prompt)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.SiteLocation

See Also

SiteLocation Members


SiteLocation Members

[image] [image]

Revit 2011 API
SiteLocation Members
SiteLocation Class Methods Properties See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConvertFromProjectTime | Converts project time to UTC time.
ConvertToProjectTime | Converts local time or UTC time to project time.
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Latitude | The latitude of the site location.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | The longitude of the site location.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TimeZone | Time-zone that contains the site
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SiteLocation Class


SiteLocation Methods

[image] [image]

Revit 2011 API
SiteLocation Methods
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConvertFromProjectTime | Converts project time to UTC time.
ConvertToProjectTime | Converts local time or UTC time to project time.
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SiteLocation Class


ConvertFromProjectTime Method

[image]

Revit 2011 API
SiteLocation..::.ConvertFromProjectTime Method
SiteLocation Class See Also Send Feedback
Converts project time to UTC time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DateTime ConvertFromProjectTime(
    DateTime projectTime
)
Visual Basic (Declaration)
Public Function ConvertFromProjectTime ( _
    projectTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertFromProjectTime(
    DateTime projectTime
)

Parameters

projectTime
Type: System..::.DateTime
The project time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the projectTime's kind is not Unspecified.

See Also

SiteLocation Class


ConvertToProjectTime Method

[image]

Revit 2011 API
SiteLocation..::.ConvertToProjectTime Method
SiteLocation Class See Also Send Feedback
Converts local time or UTC time to project time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DateTime ConvertToProjectTime(
    DateTime inputTime
)
Visual Basic (Declaration)
Public Function ConvertToProjectTime ( _
    inputTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertToProjectTime(
    DateTime inputTime
)

Parameters

inputTime
Type: System..::.DateTime
The input local time or UTC time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the inputTime's kind is neither Local nor Utc.

See Also

SiteLocation Class


SiteLocation Properties

[image] [image]

Revit 2011 API
SiteLocation Properties
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Latitude | The latitude of the site location.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | The longitude of the site location.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TimeZone | Time-zone that contains the site
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SiteLocation Class


Latitude Property

[image]

Revit 2011 API
SiteLocation..::.Latitude Property
SiteLocation Class See Also Send Feedback
The latitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Latitude { get; set; }
Visual Basic (Declaration)
Public Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location. The value of this property is in radians between +PI/2 and -PI/2.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will not attempt to automatically adjust the time zone value to match the new Latitude value set. You can set the TimeZone property directly to the correct value if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value out of the permitted range.

See Also

SiteLocation Class


Longitude Property

[image]

Revit 2011 API
SiteLocation..::.Longitude Property
SiteLocation Class See Also Send Feedback
The longitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Longitude { get; set; }
Visual Basic (Declaration)
Public Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the longitude of the site location. The value of this property is in radians between +PI and -PI.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will not attempt to automatically adjust the time zone value to match the new Longitude value set. You can set the TimeZone property directly to the correct value if necessary.

See Also

SiteLocation Class


Parameter Property

[image] [image]

Revit 2011 API
SiteLocation..::.Parameter Property
SiteLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SiteLocation Class
SiteLocation Members


TimeZone Property

[image]

Revit 2011 API
SiteLocation..::.TimeZone Property
SiteLocation Class See Also Send Feedback
Time-zone that contains the site

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TimeZone { get; set; }
Visual Basic (Declaration)
Public Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

SiteLocation Class


Sketch Class

[image]

Revit 2011 API
Sketch Class
Members See Also Send Feedback
Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Sketch : SketchBase
Visual Basic (Declaration)
Public Class Sketch _
    Inherits SketchBase
Visual C++
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.Sketch

See Also

Sketch Members


Sketch Members

[image] [image]

Revit 2011 API
Sketch Members
Sketch Class Methods Properties See Also Send Feedback

The Sketch type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Returns the Profile of the Sketch.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Returns the Sketch Plane of the Sketch.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Sketch Class


Sketch Methods

[image] [image]

Revit 2011 API
Sketch Methods
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sketch Class


Sketch Properties

[image] [image]

Revit 2011 API
Sketch Properties
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Profile | Returns the Profile of the Sketch.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | Returns the Sketch Plane of the Sketch.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Sketch Class


Parameter Property

[image] [image]

Revit 2011 API
Sketch..::.Parameter Property
Sketch Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Sketch Class
Sketch Members


Profile Property

[image]

Revit 2011 API
Sketch..::.Profile Property
Sketch Class See Also Send Feedback
Returns the Profile of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray Profile { get; }
Visual Basic (Declaration)
Public ReadOnly Property Profile As CurveArrArray
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
}

Remarks

This property is used to retrieve the Profile of Sketch.

See Also

Sketch Class


SketchPlane Property

[image]

Revit 2011 API
Sketch..::.SketchPlane Property
Sketch Class See Also Send Feedback
Returns the Sketch Plane of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; }
Visual Basic (Declaration)
Public ReadOnly Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Remarks

This property is used to retrieve the Sketch Plane of Sketch.

See Also

Sketch Class


SketchBase Class

[image]

Revit 2011 API
SketchBase Class
Members See Also Send Feedback
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SketchBase : Element
Visual Basic (Declaration)
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SketchBase
Autodesk.Revit.DB..::.Path3d
Autodesk.Revit.DB..::.Sketch

See Also

SketchBase Members


SketchBase Members

[image] [image]

Revit 2011 API
SketchBase Members
SketchBase Class Methods Properties See Also Send Feedback

The SketchBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SketchBase Class


SketchBase Methods

[image] [image]

Revit 2011 API
SketchBase Methods
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchBase Class


SketchBase Properties

[image] [image]

Revit 2011 API
SketchBase Properties
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SketchBase Class


Parameter Property

[image] [image]

Revit 2011 API
SketchBase..::.Parameter Property
SketchBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SketchBase Class
SketchBase Members


SketchPlane Class

[image]

Revit 2011 API
SketchPlane Class
Members Example See Also Send Feedback
Represents a sketch plane or work plane within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SketchPlane : Element
Visual Basic (Declaration)
Public Class SketchPlane _
    Inherits Element
Visual C++
public ref class SketchPlane : public Element

Remarks

A SketchPlane object is used as an input to creation of sketch-referencing elements such as Model Curves or sketch-owning elements such as Generic Forms. The SketchPlane can be obtained from an existing element or created from a geometric plane or planar face. Note that the sketch plane element passed as input to create an element may not be the actual sketch plane assigned to that element; Revit may look for a geometrically equivalent plane to use, or may create a new one if the input plane is already used for other purposes. Some sketch planes (such as those obtained from detail curves) are suitable only for use in creating detail elements; they will be rejected when used for other element types.

Examples

CopyC#
public void ShowSketchPlane(SketchPlane sketchPlane)
{
    // get the information of the created sketch plane
    string information = "Sketch Plane: ";
    //get the corresponding Plane
    Autodesk.Revit.DB.Plane plane = sketchPlane.Plane;
    //show the plane's origin point
    information += "\norigin of the plane:  " + XYZToString(plane.Origin);
    //show the plane's normal vector
    information += "\nnormal of the plane:  " + XYZToString(plane.Normal);
    //show the plane's Xvec vector
    information += "\nXvec of the plane: (" + XYZToString(plane.XVec);
    //show the plane's Yvec vector
    information += "\nYvec of the plane: (" + XYZToString(plane.YVec);

    TaskDialog.Show("Revit",information);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub ShowSketchPlane(ByVal sketchPlane As Autodesk.Revit.DB.SketchPlane)
    ' get the information of the created sketch plane
    Dim information As String = "Sketch Plane: "
    'get the corresponding Plane
    Dim plane As Autodesk.Revit.DB.Plane = sketchPlane.Plane
    'show the plane's origin point
    information += vbLf & "origin of the plane:  " + XYZToString(plane.Origin)
    'show the plane's normal vector
    information += vbLf & "normal of the plane:  " + XYZToString(plane.Normal)
    'show the plane's Xvec vector
    information += vbLf & "Xvec of the plane: (" + XYZToString(plane.XVec)
    'show the plane's Yvec vector
    information += vbLf & "Yvec of the plane: (" + XYZToString(plane.YVec)

    TaskDialog.Show("Revit", information)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SketchPlane

See Also

SketchPlane Members


SketchPlane Members

[image] [image]

Revit 2011 API
SketchPlane Members
SketchPlane Class Methods Properties See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | Returns the corresponding Plane.
PlaneReference | Returns a reference to this element as a plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SketchPlane Class


SketchPlane Methods

[image] [image]

Revit 2011 API
SketchPlane Methods
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchPlane Class


SketchPlane Properties

[image] [image]

Revit 2011 API
SketchPlane Properties
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plane | Returns the corresponding Plane.
PlaneReference | Returns a reference to this element as a plane.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SketchPlane Class


IsSuitableForModelElements Property

[image]

Revit 2011 API
SketchPlane..::.IsSuitableForModelElements Property
SketchPlane Class See Also Send Feedback
Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSuitableForModelElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSuitableForModelElements As Boolean
Visual C++
public:
property bool IsSuitableForModelElements {
    bool get ();
}

Remarks

Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.

See Also

SketchPlane Class


Parameter Property

[image] [image]

Revit 2011 API
SketchPlane..::.Parameter Property
SketchPlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SketchPlane Class
SketchPlane Members


Plane Property

[image]

Revit 2011 API
SketchPlane..::.Plane Property
SketchPlane Class See Also Send Feedback
Returns the corresponding Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plane As Plane
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

Remarks

This property returns the plane upon which elements created with this sketch plane will lie.

See Also

SketchPlane Class


PlaneReference Property

[image]

Revit 2011 API
SketchPlane..::.PlaneReference Property
SketchPlane Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlaneReference As Reference
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

SketchPlane Class


SlabEdge Class

[image]

Revit 2011 API
SlabEdge Class
Members See Also Send Feedback
An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabEdge : HostedSweep
Visual Basic (Declaration)
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB..::.SlabEdge

See Also

SlabEdge Members


SlabEdge Members

[image] [image]

Revit 2011 API
SlabEdge Members
SlabEdge Class Methods Properties See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SlabEdge Class


SlabEdge Methods

[image] [image]

Revit 2011 API
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

SlabEdge Class


AddSegment Method

[image]

Revit 2011 API
SlabEdge..::.AddSegment Method
SlabEdge Class See Also Send Feedback
Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is nullNothingnullptra null reference (Nothing in Visual Basic). 2. Input targetRef is not nullNothingnullptra null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also

SlabEdge Class


SlabEdge Properties

[image] [image]

Revit 2011 API
SlabEdge Properties
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SlabEdge Class


Parameter Property

[image] [image]

Revit 2011 API
SlabEdge..::.Parameter Property
SlabEdge Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SlabEdge Class
SlabEdge Members


SlabEdgeType Property

[image]

Revit 2011 API
SlabEdge..::.SlabEdgeType Property
SlabEdge Class See Also Send Feedback
Retrieves/set an object that represents the type of the SlabEdge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdgeType SlabEdgeType { get; set; }
Visual Basic (Declaration)
Public Property SlabEdgeType As SlabEdgeType
Visual C++
public:
property SlabEdgeType^ SlabEdgeType {
    SlabEdgeType^ get ();
    void set (SlabEdgeType^ value);
}

See Also

SlabEdge Class


SlabEdgeType Class

[image]

Revit 2011 API
SlabEdgeType Class
Members See Also Send Feedback
An object that represents the slab edge type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabEdgeType : HostedSweepType
Visual Basic (Declaration)
Public Class SlabEdgeType _
    Inherits HostedSweepType
Visual C++
public ref class SlabEdgeType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB..::.SlabEdgeType

See Also

SlabEdgeType Members


SlabEdgeType Members

[image] [image]

Revit 2011 API
SlabEdgeType Members
SlabEdgeType Class Methods Properties See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SlabEdgeType Class


SlabEdgeType Methods

[image] [image]

Revit 2011 API
SlabEdgeType Methods
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeType Class


SlabEdgeType Properties

[image] [image]

Revit 2011 API
SlabEdgeType Properties
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SlabEdgeType Class


Parameter Property

[image] [image]

Revit 2011 API
SlabEdgeType..::.Parameter Property
SlabEdgeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SlabEdgeType Class
SlabEdgeType Members


SlabEdgeTypeSet Class

[image]

Revit 2011 API
SlabEdgeTypeSet Class
Members See Also Send Feedback
A set that contains slab edge types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabEdgeTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabEdgeTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabEdgeTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabEdgeTypeSet

See Also

SlabEdgeTypeSet Members


SlabEdgeTypeSet Members

[image] [image]

Revit 2011 API
SlabEdgeTypeSet Members
SlabEdgeTypeSet Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Constructors

Name | Description
SlabEdgeTypeSet | Initializes a new instance of the SlabEdgeTypeSet class

Methods

Name | Description
Clear | Removes every slab edge type from the set, rendering it empty.
Contains | Tests for the existence of a slab edge type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified slab edge type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified slab edge type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Constructor

[image]

Revit 2011 API
SlabEdgeTypeSet Constructor
SlabEdgeTypeSet Class See Also Send Feedback
Initializes a new instance of the SlabEdgeTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdgeTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSet()

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Methods

[image] [image]

Revit 2011 API
SlabEdgeTypeSet Methods
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every slab edge type from the set, rendering it empty.
Contains | Tests for the existence of a slab edge type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified slab edge type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified slab edge type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSet Class


Clear Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.Clear Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes every slab edge type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabEdgeTypeSet Class


Contains Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.Contains Method
SlabEdgeTypeSet Class See Also Send Feedback
Tests for the existence of a slab edge type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabEdgeType
The slab edge type to be searched for.

Return Value

The Contains method returns True if the slab edge type is within the set, otherwise False.

See Also

SlabEdgeTypeSet Class


Erase Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.Erase Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes a specified slab edge type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SlabEdgeType _
) As Integer
Visual C++
public:
virtual int Erase(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabEdgeType
The slab edge type to be erased.

Return Value

The number of slab edge types that were erased from the set.

See Also

SlabEdgeTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.ForwardIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SlabEdgeTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.GetEnumerator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabEdgeTypeSet Class


Insert Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.Insert Method
SlabEdgeTypeSet Class See Also Send Feedback
Insert the specified slab edge type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    SlabEdgeType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabEdgeType
The slab edge type to be inserted into the set.

Return Value

Returns whether the slab edge type was inserted into the set.

See Also

SlabEdgeTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
SlabEdgeTypeSet..::.ReverseIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Properties

[image] [image]

Revit 2011 API
SlabEdgeTypeSet Properties
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
SlabEdgeTypeSet..::.IsEmpty Property
SlabEdgeTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SlabEdgeTypeSet Class


Size Property

[image]

Revit 2011 API
SlabEdgeTypeSet..::.Size Property
SlabEdgeTypeSet Class See Also Send Feedback
Returns the number of slab edge types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSetIterator Class

[image]

Revit 2011 API
SlabEdgeTypeSetIterator Class
Members See Also Send Feedback
An iterator to a slab edge type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SlabEdgeTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabEdgeTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabEdgeTypeSetIterator

See Also

SlabEdgeTypeSetIterator Members


SlabEdgeTypeSetIterator Members

[image] [image]

Revit 2011 API
SlabEdgeTypeSetIterator Members
SlabEdgeTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Constructors

Name | Description
SlabEdgeTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Constructor

[image]

Revit 2011 API
SlabEdgeTypeSetIterator Constructor
SlabEdgeTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabEdgeTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabEdgeTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Methods

[image] [image]

Revit 2011 API
SlabEdgeTypeSetIterator Methods
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
SlabEdgeTypeSetIterator..::.MoveNext Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
SlabEdgeTypeSetIterator..::.Reset Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Properties

[image] [image]

Revit 2011 API
SlabEdgeTypeSetIterator Properties
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class


Current Property

[image]

Revit 2011 API
SlabEdgeTypeSetIterator..::.Current Property
SlabEdgeTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class


SlabShapeCrease Class

[image]

Revit 2011 API
SlabShapeCrease Class
Members See Also Send Feedback
A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabShapeCrease
Visual Basic (Declaration)
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SlabShapeCrease

See Also

SlabShapeCrease Members


SlabShapeCrease Members

[image] [image]

Revit 2011 API
SlabShapeCrease Members
SlabShapeCrease Class Methods Properties See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreaseType | The type of the crease.
Curve | The geometry of the crease.
EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


SlabShapeCrease Methods

[image] [image]

Revit 2011 API
SlabShapeCrease Methods
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCrease Class


SlabShapeCrease Properties

[image] [image]

Revit 2011 API
SlabShapeCrease Properties
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Properties

Name | Description
CreaseType | The type of the crease.
Curve | The geometry of the crease.
EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


CreaseType Property

[image]

Revit 2011 API
SlabShapeCrease..::.CreaseType Property
SlabShapeCrease Class See Also Send Feedback
The type of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeCreaseType CreaseType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreaseType As SlabShapeCreaseType
Visual C++
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}

See Also

SlabShapeCrease Class


Curve Property

[image]

Revit 2011 API
SlabShapeCrease..::.Curve Property
SlabShapeCrease Class See Also Send Feedback
The geometry of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

SlabShapeCrease Class


EndPoints Property

[image]

Revit 2011 API
SlabShapeCrease..::.EndPoints Property
SlabShapeCrease Class See Also Send Feedback
The vertices of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertexArray EndPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoints As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ EndPoints {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeCrease Class


SlabShapeCreaseArray Class

[image]

Revit 2011 API
SlabShapeCreaseArray Class
Members See Also Send Feedback
An array that can contain any number of creases used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabShapeCreaseArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabShapeCreaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabShapeCreaseArray

See Also

SlabShapeCreaseArray Members


SlabShapeCreaseArray Members

[image] [image]

Revit 2011 API
SlabShapeCreaseArray Members
SlabShapeCreaseArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Constructors

Name | Description
SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Constructor

[image]

Revit 2011 API
SlabShapeCreaseArray Constructor
SlabShapeCreaseArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeCreaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeCreaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArray()

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Methods

[image] [image]

Revit 2011 API
SlabShapeCreaseArray Methods
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArray Class


Append Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.Append Method
SlabShapeCreaseArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeCrease item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeCrease _
)
Visual C++
public:
virtual void Append(
    SlabShapeCrease^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabShapeCrease
The item to be added.

See Also

SlabShapeCreaseArray Class


Clear Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.Clear Method
SlabShapeCreaseArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeCreaseArray Class


ForwardIterator Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.ForwardIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


GetEnumerator Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.GetEnumerator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabShapeCreaseArray Class


Insert Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.Insert Method
SlabShapeCreaseArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeCrease, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeCrease^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabShapeCrease
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeCreaseArray Class


ReverseIterator Method

[image]

Revit 2011 API
SlabShapeCreaseArray..::.ReverseIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Properties

[image] [image]

Revit 2011 API
SlabShapeCreaseArray Properties
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


IsEmpty Property

[image]

Revit 2011 API
SlabShapeCreaseArray..::.IsEmpty Property
SlabShapeCreaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeCreaseArray Class


Item Property

[image]

Revit 2011 API
SlabShapeCreaseArray..::.Item Property
SlabShapeCreaseArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeCrease Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeCrease
Visual C++
public:
virtual property SlabShapeCrease^ Item[int index] {
    SlabShapeCrease^ get (int index);
    void set (int index, SlabShapeCrease^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeCreaseArray Class


Size Property

[image]

Revit 2011 API
SlabShapeCreaseArray..::.Size Property
SlabShapeCreaseArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArrayIterator Class

[image]

Revit 2011 API
SlabShapeCreaseArrayIterator Class
Members See Also Send Feedback
An iterator to an array of creases used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeCreaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabShapeCreaseArrayIterator

See Also

SlabShapeCreaseArrayIterator Members


SlabShapeCreaseArrayIterator Members

[image] [image]

Revit 2011 API
SlabShapeCreaseArrayIterator Members
SlabShapeCreaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Constructors

Name | Description
SlabShapeCreaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Constructor

[image]

Revit 2011 API
SlabShapeCreaseArrayIterator Constructor
SlabShapeCreaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeCreaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeCreaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Methods

[image] [image]

Revit 2011 API
SlabShapeCreaseArrayIterator Methods
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
SlabShapeCreaseArrayIterator..::.MoveNext Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


Reset Method

[image]

Revit 2011 API
SlabShapeCreaseArrayIterator..::.Reset Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Properties

[image] [image]

Revit 2011 API
SlabShapeCreaseArrayIterator Properties
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


Current Property

[image]

Revit 2011 API
SlabShapeCreaseArrayIterator..::.Current Property
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseType Enumeration

[image]

Revit 2011 API
SlabShapeCreaseType Enumeration
See Also Send Feedback
An enumerated type listing all Crease types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SlabShapeCreaseType
Visual Basic (Declaration)
Public Enumeration SlabShapeCreaseType
Visual C++
public enum class SlabShapeCreaseType

Members

Member name | Description
Invalid | The type of Crease is Invalid.
Boundary | The type of Crease is Boundary.
UserDrawn | The type of Crease is UserDrawn.
Auto | The type of Crease is Auto.

See Also


SlabShapeEditor Class

[image]

Revit 2011 API
SlabShapeEditor Class
Members See Also Send Feedback
An object used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabShapeEditor
Visual Basic (Declaration)
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

Remarks

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SlabShapeEditor

See Also

SlabShapeEditor Members


SlabShapeEditor Members

[image] [image]

Revit 2011 API
SlabShapeEditor Members
SlabShapeEditor Class Methods Properties See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEnabled | Identifies if the slab shape editing functionality is enabled.
SlabShapeCreases | All of the creases that can be edited.
SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class


SlabShapeEditor Methods

[image] [image]

Revit 2011 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

Name | Description
DrawPoint | Adds a point to the corresponding slab, roof or floor.
DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Enable | Enables the slab shape editing functionality.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ModifySubElement | Overloaded. Manipulates an entity on the corresponding slab, roof or floor.
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the un-modified state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeEditor Class


DrawPoint Method

[image]

Revit 2011 API
SlabShapeEditor..::.DrawPoint Method
SlabShapeEditor Class See Also Send Feedback
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic (Declaration)
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.DB..::.XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return nullNothingnullptra null reference (Nothing in Visual Basic). Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the location is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SlabShapeEditor Class


DrawSplitLine Method

[image]

Revit 2011 API
SlabShapeEditor..::.DrawSplitLine Method
SlabShapeEditor Class See Also Send Feedback
Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic (Declaration)
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
Type: Autodesk.Revit.DB..::.SlabShapeVertex
The vertex to start the split line.
endVertex
Type: Autodesk.Revit.DB..::.SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input vertex is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input vertex is invalid.

See Also

SlabShapeEditor Class


Enable Method

[image]

Revit 2011 API
SlabShapeEditor..::.Enable Method
SlabShapeEditor Class See Also Send Feedback
Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Enable()
Visual Basic (Declaration)
Public Sub Enable
Visual C++
public:
void Enable()

See Also

SlabShapeEditor Class


ModifySubElement Method

[image] [image]

Revit 2011 API
SlabShapeEditor..::.ModifySubElement Method
SlabShapeEditor Class See Also Send Feedback
Manipulates an entity on the corresponding slab, roof or floor.

Overload List

Name | Description
ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.

See Also

SlabShapeEditor Class
SlabShapeEditor Members


ModifySubElement Method (SlabShapeCrease, Double)

[image]

Revit 2011 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeCrease, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    crease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)

Parameters

crease
Type: Autodesk.Revit.DB..::.SlabShapeCrease
The crease.
offset
Type: System..::.Double
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the crease is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the crease is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


ModifySubElement Method (SlabShapeVertex, Double)

[image]

Revit 2011 API
SlabShapeEditor..::.ModifySubElement Method (SlabShapeVertex, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Visual Basic (Declaration)
Public Sub ModifySubElement ( _
    vertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)

Parameters

vertex
Type: Autodesk.Revit.DB..::.SlabShapeVertex
The vertex.
offset
Type: System..::.Double
The new value of the vertex offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the vertex is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the vertex is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


PickSupport Method

[image]

Revit 2011 API
SlabShapeEditor..::.PickSupport Method
SlabShapeEditor Class See Also Send Feedback
Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void PickSupport(
    Line gLine
)
Visual Basic (Declaration)
Public Sub PickSupport ( _
    gLine As Line _
)
Visual C++
public:
void PickSupport(
    Line^ gLine
)

Parameters

gLine
Type: Autodesk.Revit.DB..::.Line
A line from a support element such as a beam.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input line is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input line is invalid.

See Also

SlabShapeEditor Class


ResetSlabShape Method

[image]

Revit 2011 API
SlabShapeEditor..::.ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the un-modified state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ResetSlabShape()
Visual Basic (Declaration)
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    Selection choices = uidoc.Selection;
    ElementSet collection = choices.Elements;
    foreach (Autodesk.Revit.DB.Element elem in collection)
    {
        Floor floor = elem as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.SlabShapeEditor;
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
    Dim collection As ElementSet = choices.Elements
    For Each elem As Autodesk.Revit.DB.Element In collection
        Dim floor As Floor = TryCast(elem, Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.SlabShapeEditor
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class


SlabShapeEditor Properties

[image] [image]

Revit 2011 API
SlabShapeEditor Properties
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Properties

Name | Description
IsEnabled | Identifies if the slab shape editing functionality is enabled.
SlabShapeCreases | All of the creases that can be edited.
SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class


IsEnabled Property

[image]

Revit 2011 API
SlabShapeEditor..::.IsEnabled Property
SlabShapeEditor Class See Also Send Feedback
Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEnabled As Boolean
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

Remarks

If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.

See Also

SlabShapeEditor Class


SlabShapeCreases Property

[image]

Revit 2011 API
SlabShapeEditor..::.SlabShapeCreases Property
SlabShapeEditor Class See Also Send Feedback
All of the creases that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeCreaseArray SlabShapeCreases { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeCreases As SlabShapeCreaseArray
Visual C++
public:
property SlabShapeCreaseArray^ SlabShapeCreases {
    SlabShapeCreaseArray^ get ();
}

See Also

SlabShapeEditor Class


SlabShapeVertices Property

[image]

Revit 2011 API
SlabShapeEditor..::.SlabShapeVertices Property
SlabShapeEditor Class See Also Send Feedback
All of the vertices that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertexArray SlabShapeVertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
Visual C++
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeEditor Class


SlabShapeVertex Class

[image]

Revit 2011 API
SlabShapeVertex Class
Members See Also Send Feedback
A vertex used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabShapeVertex
Visual Basic (Declaration)
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SlabShapeVertex

See Also

SlabShapeVertex Members


SlabShapeVertex Members

[image] [image]

Revit 2011 API
SlabShapeVertex Members
SlabShapeVertex Class Methods Properties See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Position | The position of the vertex.
VertexType | The type of the vertex.

See Also

SlabShapeVertex Class


SlabShapeVertex Methods

[image] [image]

Revit 2011 API
SlabShapeVertex Methods
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertex Class


SlabShapeVertex Properties

[image] [image]

Revit 2011 API
SlabShapeVertex Properties
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Properties

Name | Description
Position | The position of the vertex.
VertexType | The type of the vertex.

See Also

SlabShapeVertex Class


Position Property

[image]

Revit 2011 API
SlabShapeVertex..::.Position Property
SlabShapeVertex Class See Also Send Feedback
The position of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As XYZ
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

SlabShapeVertex Class


VertexType Property

[image]

Revit 2011 API
SlabShapeVertex..::.VertexType Property
SlabShapeVertex Class See Also Send Feedback
The type of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertexType VertexType { get; }
Visual Basic (Declaration)
Public ReadOnly Property VertexType As SlabShapeVertexType
Visual C++
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}

See Also

SlabShapeVertex Class


SlabShapeVertexArray Class

[image]

Revit 2011 API
SlabShapeVertexArray Class
Members See Also Send Feedback
An array that can contain any number of vertices used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SlabShapeVertexArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SlabShapeVertexArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeVertexArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabShapeVertexArray

See Also

SlabShapeVertexArray Members


SlabShapeVertexArray Members

[image] [image]

Revit 2011 API
SlabShapeVertexArray Members
SlabShapeVertexArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Constructors

Name | Description
SlabShapeVertexArray | Initializes a new instance of the SlabShapeVertexArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Constructor

[image]

Revit 2011 API
SlabShapeVertexArray Constructor
SlabShapeVertexArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeVertexArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertexArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArray()

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Methods

[image] [image]

Revit 2011 API
SlabShapeVertexArray Methods
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArray Class


Append Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.Append Method
SlabShapeVertexArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeVertex item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SlabShapeVertex _
)
Visual C++
public:
virtual void Append(
    SlabShapeVertex^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabShapeVertex
The item to be added.

See Also

SlabShapeVertexArray Class


Clear Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.Clear Method
SlabShapeVertexArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeVertexArray Class


ForwardIterator Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.ForwardIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class


GetEnumerator Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.GetEnumerator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SlabShapeVertexArray Class


Insert Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.Insert Method
SlabShapeVertexArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SlabShapeVertex, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeVertex^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.SlabShapeVertex
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeVertexArray Class


ReverseIterator Method

[image]

Revit 2011 API
SlabShapeVertexArray..::.ReverseIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Properties

[image] [image]

Revit 2011 API
SlabShapeVertexArray Properties
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


IsEmpty Property

[image]

Revit 2011 API
SlabShapeVertexArray..::.IsEmpty Property
SlabShapeVertexArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeVertexArray Class


Item Property

[image]

Revit 2011 API
SlabShapeVertexArray..::.Item Property
SlabShapeVertexArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SlabShapeVertex Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeVertex
Visual C++
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeVertexArray Class


Size Property

[image]

Revit 2011 API
SlabShapeVertexArray..::.Size Property
SlabShapeVertexArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeVertexArray Class


SlabShapeVertexArrayIterator Class

[image]

Revit 2011 API
SlabShapeVertexArrayIterator Class
Members See Also Send Feedback
An iterator to an array of vertices used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SlabShapeVertexArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SlabShapeVertexArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SlabShapeVertexArrayIterator

See Also

SlabShapeVertexArrayIterator Members


SlabShapeVertexArrayIterator Members

[image] [image]

Revit 2011 API
SlabShapeVertexArrayIterator Members
SlabShapeVertexArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Constructors

Name | Description
SlabShapeVertexArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Constructor

[image]

Revit 2011 API
SlabShapeVertexArrayIterator Constructor
SlabShapeVertexArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SlabShapeVertexArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SlabShapeVertexArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Methods

[image] [image]

Revit 2011 API
SlabShapeVertexArrayIterator Methods
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
SlabShapeVertexArrayIterator..::.MoveNext Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


Reset Method

[image]

Revit 2011 API
SlabShapeVertexArrayIterator..::.Reset Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Properties

[image] [image]

Revit 2011 API
SlabShapeVertexArrayIterator Properties
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class


Current Property

[image]

Revit 2011 API
SlabShapeVertexArrayIterator..::.Current Property
SlabShapeVertexArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexType Enumeration

[image]

Revit 2011 API
SlabShapeVertexType Enumeration
See Also Send Feedback
An enumerated type listing all Vertex types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SlabShapeVertexType
Visual Basic (Declaration)
Public Enumeration SlabShapeVertexType
Visual C++
public enum class SlabShapeVertexType

Members

Member name | Description
Invalid | The type of Vertex is Invalid.
Corner | The type of Vertex is Corner.
Edge | The type of Vertex is Edge.
Interior | The type of Vertex is Interior.

See Also


SlantedOrVerticalColumnType Enumeration

[image]

Revit 2011 API
SlantedOrVerticalColumnType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SlantedOrVerticalColumnType
Visual Basic (Declaration)
Public Enumeration SlantedOrVerticalColumnType
Visual C++
public enum class SlantedOrVerticalColumnType

Members

Member name | Description
CT_Vertical |
CT_Angle |
CT_EndPoint |

See Also


Solid Class

[image]

Revit 2011 API
Solid Class
Members Example See Also Send Feedback
A 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Solid : GeometryObject
Visual Basic (Declaration)
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Application application, Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.DB.GeometryInstance instance = geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry.Objects)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                   foreach (XYZ ii in edge.Tessellate())
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(ByVal application As Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry.Objects
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Autodesk.Revit.DB.Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As Autodesk.Revit.DB.XYZ In mesh.Vertices
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Autodesk.Revit.DB.Edge In solid.Edges
                    For Each ii As Autodesk.Revit.DB.XYZ In edge.Tessellate()
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.GeometryObject
Autodesk.Revit.DB..::.Solid

See Also

Solid Members


Solid Members

[image] [image]

Revit 2011 API
Solid Members
Solid Class Methods Properties See Also Send Feedback

The Solid type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class


Solid Methods

[image] [image]

Revit 2011 API
Solid Methods
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Solid Class


Solid Properties

[image] [image]

Revit 2011 API
Solid Properties
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Properties

Name | Description
Edges | The edges that belong to the solid.
Faces | The faces that belong to the solid.
GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
SurfaceArea | Returns the total surface area of this solid.
Visibility | The visibility. (Inherited from GeometryObject.)
Volume | Returns the signed volume of this solid.

See Also

Solid Class


Edges Property

[image]

Revit 2011 API
Solid..::.Edges Property
Solid Class See Also Send Feedback
The edges that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EdgeArray Edges { get; }
Visual Basic (Declaration)
Public ReadOnly Property Edges As EdgeArray
Visual C++
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}

See Also

Solid Class


Faces Property

[image]

Revit 2011 API
Solid..::.Faces Property
Solid Class Example See Also Send Feedback
The faces that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FaceArray Faces { get; }
Visual Basic (Declaration)
Public ReadOnly Property Faces As FaceArray
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

Examples

CopyC#
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.DB.Options opt = new Options();
    Autodesk.Revit.DB.GeometryElement geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    TaskDialog.Show("Revit",faceInfo);
}
CopyVB.NET
Private Sub GetFacesAndEdges(ByVal wall As Wall)
    Dim faceInfo As [String] = ""

    Dim opt As Autodesk.Revit.DB.Options = New Autodesk.Revit.DB.Options()
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Autodesk.Revit.DB.Face In geomSolid.Faces
                System.Math.Max(System.Threading.Interlocked.Increment(faces), faces - 1)
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " + faces + vbLf
            faceInfo += "Total area: " + totalArea.ToString() + vbLf
            ' get wall's geometry edges
            For Each geomEdge As Autodesk.Revit.DB.Edge In geomSolid.Edges
            Next
        End If
    Next

    TaskDialog.Show("Revit", faceInfo)
End Sub

See Also

Solid Class


SurfaceArea Property

[image]

Revit 2011 API
Solid..::.SurfaceArea Property
Solid Class See Also Send Feedback
Returns the total surface area of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SurfaceArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property SurfaceArea As Double
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class


Volume Property

[image]

Revit 2011 API
Solid..::.Volume Property
Solid Class See Also Send Feedback
Returns the signed volume of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Calculates the solid volume by integrating tessellated representations of faces and edges. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class


SolidArray Class

[image]

Revit 2011 API
SolidArray Class
Members See Also Send Feedback
An array that contains solids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SolidArray : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class SolidArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SolidArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SolidArray

See Also

SolidArray Members


SolidArray Members

[image] [image]

Revit 2011 API
SolidArray Members
SolidArray Class Constructors Methods Properties See Also Send Feedback

The SolidArray type exposes the following members.

Constructors

Name | Description
SolidArray | Initializes a new instance of the SolidArray class

Methods

Name | Description
Append | Add the solid to the end of the array.
Clear | Removes every solid from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified solid into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a solid at a specified index within the array.
Size | Returns the number of solids that are in the array.

See Also

SolidArray Class


SolidArray Constructor

[image]

Revit 2011 API
SolidArray Constructor
SolidArray Class See Also Send Feedback
Initializes a new instance of the SolidArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SolidArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArray()

See Also

SolidArray Class


SolidArray Methods

[image] [image]

Revit 2011 API
SolidArray Methods
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Methods

Name | Description
Append | Add the solid to the end of the array.
Clear | Removes every solid from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified solid into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArray Class


Append Method

[image]

Revit 2011 API
SolidArray..::.Append Method
SolidArray Class See Also Send Feedback
Add the solid to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    Solid item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As Solid _
)
Visual C++
public:
virtual void Append(
    Solid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.Solid
The solid to be added.

See Also

SolidArray Class


Clear Method

[image]

Revit 2011 API
SolidArray..::.Clear Method
SolidArray Class See Also Send Feedback
Removes every solid from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SolidArray Class


ForwardIterator Method

[image]

Revit 2011 API
SolidArray..::.ForwardIterator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SolidArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SolidArray Class


GetEnumerator Method

[image]

Revit 2011 API
SolidArray..::.GetEnumerator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SolidArray Class


Insert Method

[image]

Revit 2011 API
SolidArray..::.Insert Method
SolidArray Class See Also Send Feedback
Insert the specified solid into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    Solid item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As Solid, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Solid^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.Solid
The solid to be inserted into the array.
index
Type: System..::.Int32
The solid will be inserted before this index.

Return Value

Returns whether the solid was inserted into the array.

See Also

SolidArray Class


ReverseIterator Method

[image]

Revit 2011 API
SolidArray..::.ReverseIterator Method
SolidArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SolidArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SolidArray Class


SolidArray Properties

[image] [image]

Revit 2011 API
SolidArray Properties
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a solid at a specified index within the array.
Size | Returns the number of solids that are in the array.

See Also

SolidArray Class


IsEmpty Property

[image]

Revit 2011 API
SolidArray..::.IsEmpty Property
SolidArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SolidArray Class


Item Property

[image]

Revit 2011 API
SolidArray..::.Item Property
SolidArray Class See Also Send Feedback
Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Solid Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As Solid
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Type: System..::.Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class


Size Property

[image]

Revit 2011 API
SolidArray..::.Size Property
SolidArray Class See Also Send Feedback
Returns the number of solids that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SolidArray Class


SolidArrayIterator Class

[image]

Revit 2011 API
SolidArrayIterator Class
Members See Also Send Feedback
An iterator to a solids array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SolidArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SolidArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SolidArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SolidArrayIterator

See Also

SolidArrayIterator Members


SolidArrayIterator Members

[image] [image]

Revit 2011 API
SolidArrayIterator Members
SolidArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Constructors

Name | Description
SolidArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class


SolidArrayIterator Constructor

[image]

Revit 2011 API
SolidArrayIterator Constructor
SolidArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SolidArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SolidArrayIterator Class


SolidArrayIterator Methods

[image] [image]

Revit 2011 API
SolidArrayIterator Methods
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
SolidArrayIterator..::.MoveNext Method
SolidArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SolidArrayIterator Class


Reset Method

[image]

Revit 2011 API
SolidArrayIterator..::.Reset Method
SolidArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SolidArrayIterator Class


SolidArrayIterator Properties

[image] [image]

Revit 2011 API
SolidArrayIterator Properties
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class


Current Property

[image]

Revit 2011 API
SolidArrayIterator..::.Current Property
SolidArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SolidArrayIterator Class


SolidGeometry Enumeration

[image]

Revit 2011 API
SolidGeometry Enumeration
See Also Send Feedback
An enumerated type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SolidGeometry
Visual Basic (Declaration)
Public Enumeration SolidGeometry
Visual C++
public enum class SolidGeometry

Members

Member name | Description
Polymesh | All visible solids are exported as polymesh.
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)

See Also


SolidSolidCutUtils Class

[image]

Revit 2011 API
SolidSolidCutUtils Class
Members See Also Send Feedback
These utilities are applicable for the generic forms, geometry combinations and family instances in editor situations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SolidSolidCutUtils : IDisposable
Visual Basic (Declaration)
Public Class SolidSolidCutUtils _
    Implements IDisposable
Visual C++
public ref class SolidSolidCutUtils : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SolidSolidCutUtils

See Also

SolidSolidCutUtils Members


SolidSolidCutUtils Members

[image] [image]

Revit 2011 API
SolidSolidCutUtils Members
SolidSolidCutUtils Class Methods See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids | Add the solid-solid cut for the two elements
CanElementCutElement | Verifies if the cutting element can add a solid cut to the cut element.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCuttingSolids | Get all the solids which cut the input element
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolidsBeingCut | Get all the solids which are cut by the input element
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is in an appropriate document.
RemoveCutBetweenSolids | Remove the solid-solid cut for the two elements (uncut)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class


SolidSolidCutUtils Methods

[image] [image]

Revit 2011 API
SolidSolidCutUtils Methods
SolidSolidCutUtils Class See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids | Add the solid-solid cut for the two elements
CanElementCutElement | Verifies if the cutting element can add a solid cut to the cut element.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCuttingSolids | Get all the solids which cut the input element
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolidsBeingCut | Get all the solids which are cut by the input element
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is in an appropriate document.
RemoveCutBetweenSolids | Remove the solid-solid cut for the two elements (uncut)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class


AddCutBetweenSolids Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.AddCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Add the solid-solid cut for the two elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddCutBetweenSolids(
    Document ADoc,
    Element SolidToBeCut,
    Element CuttingSolid
)
Visual Basic (Declaration)
Public Shared Sub AddCutBetweenSolids ( _
    ADoc As Document, _
    SolidToBeCut As Element, _
    CuttingSolid As Element _
)
Visual C++
public:
static void AddCutBetweenSolids(
    Document^ ADoc,
    Element^ SolidToBeCut,
    Element^ CuttingSolid
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document containing the two elements
SolidToBeCut
Type: Autodesk.Revit.DB..::.Element
The solid to be cut
CuttingSolid
Type: Autodesk.Revit.DB..::.Element
The cutting solid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element must be in a conceptual model, pattern based curtain panel, or adaptive component family -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Failed to add solid-solid cut for the two elements
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


CanElementCutElement Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.CanElementCutElement Method
SolidSolidCutUtils Class See Also Send Feedback
Verifies if the cutting element can add a solid cut to the cut element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CanElementCutElement(
    Element cuttingElement,
    Element cutElement,
    out CutFailureReason reason
)
Visual Basic (Declaration)
Public Shared Function CanElementCutElement ( _
    cuttingElement As Element, _
    cutElement As Element, _
    <OutAttribute> ByRef reason As CutFailureReason _
) As Boolean
Visual C++
public:
static bool CanElementCutElement(
    Element^ cuttingElement,
    Element^ cutElement,
    [OutAttribute] CutFailureReason% reason
)

Parameters

cuttingElement
Type: Autodesk.Revit.DB..::.Element
The cutting element.
cutElement
Type: Autodesk.Revit.DB..::.Element
The element to be cut.
reason
Type: Autodesk.Revit.DB..::.CutFailureReason %
The reason that the cutting element can not add a solid cut to the cut element.

Return Value

True if the cutting element can add a solid cut to the cut element, False if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


Dispose Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.Dispose Method
SolidSolidCutUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

SolidSolidCutUtils Class


GetCuttingSolids Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.GetCuttingSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Get all the solids which cut the input element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetCuttingSolids(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function GetCuttingSolids ( _
    Elem As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetCuttingSolids(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element

Return Value

All the solids which cut the input element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


GetSolidsBeingCut Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.GetSolidsBeingCut Method
SolidSolidCutUtils Class See Also Send Feedback
Get all the solids which are cut by the input element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetSolidsBeingCut(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function GetSolidsBeingCut ( _
    Elem As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetSolidsBeingCut(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element

Return Value

All the solids which are cut by the input element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


IsAllowedForSolidCut Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.IsAllowedForSolidCut Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is eligible for a solid-solid cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsAllowedForSolidCut(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function IsAllowedForSolidCut ( _
    Elem As Element _
) As Boolean
Visual C++
public:
static bool IsAllowedForSolidCut(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element
The solid to be cut or the cutting solid

Return Value

True if the input is validated False if not

Remarks

The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


IsElementFromAppropriateContext Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.IsElementFromAppropriateContext Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is in an appropriate document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsElementFromAppropriateContext(
    Element Elem
)
Visual Basic (Declaration)
Public Shared Function IsElementFromAppropriateContext ( _
    Elem As Element _
) As Boolean
Visual C++
public:
static bool IsElementFromAppropriateContext(
    Element^ Elem
)

Parameters

Elem
Type: Autodesk.Revit.DB..::.Element
The solid to be cut or the cutting solid

Return Value

True if the input is validated False if not

Remarks

The element must be in a conceptual model, pattern based curtain panel, or adaptive component family

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


RemoveCutBetweenSolids Method

[image]

Revit 2011 API
SolidSolidCutUtils..::.RemoveCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Remove the solid-solid cut for the two elements (uncut)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveCutBetweenSolids(
    Document ADoc,
    Element First,
    Element Second
)
Visual Basic (Declaration)
Public Shared Sub RemoveCutBetweenSolids ( _
    ADoc As Document, _
    First As Element, _
    Second As Element _
)
Visual C++
public:
static void RemoveCutBetweenSolids(
    Document^ ADoc,
    Element^ First,
    Element^ Second
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document containing the two elements
First
Type: Autodesk.Revit.DB..::.Element
The solid being cut or the cutting solid
Second
Type: Autodesk.Revit.DB..::.Element
The solid being cut or the cutting solid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


SpacingRule Class

[image]

Revit 2011 API
SpacingRule Class
Members See Also Send Feedback
A rule for specifying a set of equidistant, parallel gridlines within a region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpacingRule : APIObject
Visual Basic (Declaration)
Public Class SpacingRule _
    Inherits APIObject
Visual C++
public ref class SpacingRule : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SpacingRule

See Also

SpacingRule Members


SpacingRule Members

[image] [image]

Revit 2011 API
SpacingRule Members
SpacingRule Class Methods Properties See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLayoutFixedDistance | Set the Layout property to FixedDistance.
SetLayoutFixedNumber | Set the Layout property to FixedNumber.
SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
SetLayoutNone | Set the Layout property to None.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Distance | The exact distance between layout lines.
GridlinesRotation | An additional rotation to be applied to this set of grid lines.
HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Justification | The justification of the lines within the region.
Layout | A choice of several gridline layout rules.
Number | The exact number of lines in the region.
Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class


SpacingRule Methods

[image] [image]

Revit 2011 API
SpacingRule Methods
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetLayoutFixedDistance | Set the Layout property to FixedDistance.
SetLayoutFixedNumber | Set the Layout property to FixedNumber.
SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
SetLayoutNone | Set the Layout property to None.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpacingRule Class


SetLayoutFixedDistance Method

[image]

Revit 2011 API
SpacingRule..::.SetLayoutFixedDistance Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedDistance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutFixedDistance ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.DB..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to FixedDistance, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutFixedNumber Method

[image]

Revit 2011 API
SpacingRule..::.SetLayoutFixedNumber Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutFixedNumber ( _
    number As Integer, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

number
Type: System..::.Int32
just
Type: Autodesk.Revit.DB..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutMaximumSpacing Method

[image]

Revit 2011 API
SpacingRule..::.SetLayoutMaximumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutMaximumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.DB..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to MaximumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutMinimumSpacing Method

[image]

Revit 2011 API
SpacingRule..::.SetLayoutMinimumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MinimumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic (Declaration)
Public Sub SetLayoutMinimumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::.Double
just
Type: Autodesk.Revit.DB..::.SpacingRuleJustification
gridlinesRotation
Type: System..::.Double
offset
Type: System..::.Double

Remarks

When changing the Layout to MinimumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutNone Method

[image]

Revit 2011 API
SpacingRule..::.SetLayoutNone Method
SpacingRule Class See Also Send Feedback
Set the Layout property to None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutNone()
Visual Basic (Declaration)
Public Sub SetLayoutNone
Visual C++
public:
void SetLayoutNone()

Remarks

No internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


SpacingRule Properties

[image] [image]

Revit 2011 API
SpacingRule Properties
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Properties

Name | Description
BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Distance | The exact distance between layout lines.
GridlinesRotation | An additional rotation to be applied to this set of grid lines.
HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Justification | The justification of the lines within the region.
Layout | A choice of several gridline layout rules.
Number | The exact number of lines in the region.
Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class


BeltMeasurement Property

[image]

Revit 2011 API
SpacingRule..::.BeltMeasurement Property
SpacingRule Class See Also Send Feedback
On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BeltMeasurement { get; set; }
Visual Basic (Declaration)
Public Property BeltMeasurement As Double
Visual C++
public:
property double BeltMeasurement {
    double get ();
    void set (double value);
}

Remarks

On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.

See Also

SpacingRule Class


Distance Property

[image]

Revit 2011 API
SpacingRule..::.Distance Property
SpacingRule Class See Also Send Feedback
The exact distance between layout lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the Layout property is None or FixedNumber.

See Also

SpacingRule Class


GridlinesRotation Property

[image]

Revit 2011 API
SpacingRule..::.GridlinesRotation Property
SpacingRule Class See Also Send Feedback
An additional rotation to be applied to this set of grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GridlinesRotation { get; set; }
Visual Basic (Declaration)
Public Property GridlinesRotation As Double
Visual C++
public:
property double GridlinesRotation {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when angle is outside of the range ( -PI/2, PI/2 ).

See Also

SpacingRule Class


HasBeltMeasurement Property

[image]

Revit 2011 API
SpacingRule..::.HasBeltMeasurement Property
SpacingRule Class See Also Send Feedback
True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasBeltMeasurement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasBeltMeasurement As Boolean
Visual C++
public:
property bool HasBeltMeasurement {
    bool get ();
}

See Also

SpacingRule Class


Justification Property

[image]

Revit 2011 API
SpacingRule..::.Justification Property
SpacingRule Class See Also Send Feedback
The justification of the lines within the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpacingRuleJustification Justification { get; set; }
Visual Basic (Declaration)
Public Property Justification As SpacingRuleJustification
Visual C++
public:
property SpacingRuleJustification Justification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, FixedNumber, MaximumSpacing, or MinimumSpacing.

See Also

SpacingRule Class


Layout Property

[image]

Revit 2011 API
SpacingRule..::.Layout Property
SpacingRule Class See Also Send Feedback
A choice of several gridline layout rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpacingRuleLayout Layout { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layout As SpacingRuleLayout
Visual C++
public:
property SpacingRuleLayout Layout {
    SpacingRuleLayout get ();
}

Remarks

If "None" is chosen, no internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


Number Property

[image]

Revit 2011 API
SpacingRule..::.Number Property
SpacingRule Class See Also Send Feedback
The exact number of lines in the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Number { get; set; }
Visual Basic (Declaration)
Public Property Number As Integer
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

Remarks

This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.

See Also

SpacingRule Class


Offset Property

[image]

Revit 2011 API
SpacingRule..::.Offset Property
SpacingRule Class See Also Send Feedback
An additional offset applied to the first gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

Measured in feet. Must be between -30000' and 30000'.

See Also

SpacingRule Class


SpacingRuleJustification Enumeration

[image]

Revit 2011 API
SpacingRuleJustification Enumeration
See Also Send Feedback
Justification property of a spacing rule. See SpacingRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SpacingRuleJustification
Visual Basic (Declaration)
Public Enumeration SpacingRuleJustification
Visual C++
public enum class SpacingRuleJustification

Members

Member name | Description
Center |
Beginning |
End |

See Also


SpacingRuleLayout Enumeration

[image]

Revit 2011 API
SpacingRuleLayout Enumeration
See Also Send Feedback
Rules for laying out a series of equidistant parallel lines. See SpacingRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SpacingRuleLayout
Visual Basic (Declaration)
Public Enumeration SpacingRuleLayout
Visual C++
public enum class SpacingRuleLayout

Members

Member name | Description
None |
FixedDistance |
FixedNumber |
MaximumSpacing |
MinimumSpacing |

See Also


SpotDimension Class

[image]

Revit 2011 API
SpotDimension Class
Members Example See Also Send Feedback
An object that represents a spot dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpotDimension : Dimension
Visual Basic (Declaration)
Public Class SpotDimension _
    Inherits Dimension
Visual C++
public ref class SpotDimension : public Dimension

Examples

CopyC#
private void Getinfo_SpotDimension(SpotDimension spotDimension)
{
    string message = "SpotDimension's Location : ";
    Location location = spotDimension.Location;

    if (location is LocationPoint)
    {
        LocationPoint point = location as LocationPoint;

        message += "\n" + location.GetType().Name + " : ";
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")";
    }
    else
    {
        LocationCurve locCurve = location as LocationCurve;
        Curve curve = locCurve.Curve;
        message += "\n" + location.GetType().Name + " : ";
        message += "\nStart Point : " + "(" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        message += "\nEnd point : " + "(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_SpotDimension(ByVal spotDimension As SpotDimension)
    Dim message As String = "SpotDimension's Location : "
    Dim location As Location = spotDimension.Location

    If TypeOf location Is LocationPoint Then
        Dim point As LocationPoint = TryCast(location, LocationPoint)

        message += vbLf + location.[GetType]().Name + " : "
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")"
    Else
        Dim locCurve As LocationCurve = TryCast(location, LocationCurve)
        Dim curve As Curve = locCurve.Curve
        message += vbLf + location.[GetType]().Name + " : "
        message += vbLf & "Start Point : " + "(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        message += vbLf & "End point : " + "(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Dimension
Autodesk.Revit.DB..::.SpotDimension

See Also

SpotDimension Members


SpotDimension Members

[image] [image]

Revit 2011 API
SpotDimension Members
SpotDimension Class Methods Properties See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line. (Inherited from Dimension.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension. (Inherited from Dimension.)
DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Label | The family parameter label of the dimension. (Inherited from Dimension.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Segments | The segments in the dimension. (Inherited from Dimension.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpotDimensionType | The dimension style of this dimension.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension. (Inherited from Dimension.)
ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpotDimension Class


SpotDimension Methods

[image] [image]

Revit 2011 API
SpotDimension Methods
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimension Class


SpotDimension Properties

[image] [image]

Revit 2011 API
SpotDimension Properties
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Properties

Name | Description
AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | A curve that represents the dimension line. (Inherited from Dimension.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DimensionShape | The shape of this dimension. (Inherited from Dimension.)
DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Label | The family parameter label of the dimension. (Inherited from Dimension.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::.Location.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Retrieve or Change the name associated with the Dimension. (Inherited from Dimension.)
NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Segments | The segments in the dimension. (Inherited from Dimension.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpotDimensionType | The dimension style of this dimension.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Value | The value of the dimension. (Inherited from Dimension.)
ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpotDimension Class


Location Property

[image]

Revit 2011 API
SpotDimension..::.Location Property
SpotDimension Class See Also Send Feedback
Get a location point object. This is the location of the spot dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Location As Location
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

SpotDimension Class


Parameter Property

[image] [image]

Revit 2011 API
SpotDimension..::.Parameter Property
SpotDimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpotDimension Class
SpotDimension Members


SpotDimensionType Property

[image]

Revit 2011 API
SpotDimension..::.SpotDimensionType Property
SpotDimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimensionType SpotDimensionType { get; set; }
Visual Basic (Declaration)
Public Property SpotDimensionType As SpotDimensionType
Visual C++
public:
property SpotDimensionType^ SpotDimensionType {
    SpotDimensionType^ get ();
    void set (SpotDimensionType^ value);
}

See Also

SpotDimension Class


SpotDimensionType Class

[image]

Revit 2011 API
SpotDimensionType Class
Members See Also Send Feedback
An object that specifies the type of a spot dimension in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpotDimensionType : DimensionType
Visual Basic (Declaration)
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
public ref class SpotDimensionType : public DimensionType

Remarks

The types of a spot dimension can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.DimensionType
Autodesk.Revit.DB..::.SpotDimensionType

See Also

SpotDimensionType Members


SpotDimensionType Members

[image] [image]

Revit 2011 API
SpotDimensionType Members
SpotDimensionType Class Methods Properties See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpotDimensionType Class


SpotDimensionType Methods

[image] [image]

Revit 2011 API
SpotDimensionType Methods
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionType Class


SpotDimensionType Properties

[image] [image]

Revit 2011 API
SpotDimensionType Properties
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpotDimensionType Class


Parameter Property

[image] [image]

Revit 2011 API
SpotDimensionType..::.Parameter Property
SpotDimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpotDimensionType Class
SpotDimensionType Members


SpotDimensionTypeSet Class

[image]

Revit 2011 API
SpotDimensionTypeSet Class
Members See Also Send Feedback
A set that contains spotdimension types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpotDimensionTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SpotDimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpotDimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SpotDimensionTypeSet

See Also

SpotDimensionTypeSet Members


SpotDimensionTypeSet Members

[image] [image]

Revit 2011 API
SpotDimensionTypeSet Members
SpotDimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Constructors

Name | Description
SpotDimensionTypeSet | Initializes a new instance of the SpotDimensionTypeSet class

Methods

Name | Description
Clear | Removes every spotdimension type from the set, rendering it empty.
Contains | Tests for the existence of a spotdimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified spotdimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified spotdimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Constructor

[image]

Revit 2011 API
SpotDimensionTypeSet Constructor
SpotDimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the SpotDimensionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimensionTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSet()

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Methods

[image] [image]

Revit 2011 API
SpotDimensionTypeSet Methods
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every spotdimension type from the set, rendering it empty.
Contains | Tests for the existence of a spotdimension type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified spotdimension type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified spotdimension type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSet Class


Clear Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.Clear Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes every spotdimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpotDimensionTypeSet Class


Contains Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.Contains Method
SpotDimensionTypeSet Class See Also Send Feedback
Tests for the existence of a spotdimension type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SpotDimensionType
The spotdimension type to be searched for.

Return Value

The Contains method returns True if the spotdimension type is within the set, otherwise False.

See Also

SpotDimensionTypeSet Class


Erase Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.Erase Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes a specified spotdimension type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpotDimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SpotDimensionType
The spotdimension type to be erased.

Return Value

The number of spotdimension types that were erased from the set.

See Also

SpotDimensionTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.ForwardIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpotDimensionTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.GetEnumerator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpotDimensionTypeSet Class


Insert Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.Insert Method
SpotDimensionTypeSet Class See Also Send Feedback
Insert the specified spotdimension type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    SpotDimensionType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SpotDimensionType
The spotdimension type to be inserted into the set.

Return Value

Returns whether the spotdimension type was inserted into the set.

See Also

SpotDimensionTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
SpotDimensionTypeSet..::.ReverseIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Properties

[image] [image]

Revit 2011 API
SpotDimensionTypeSet Properties
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
SpotDimensionTypeSet..::.IsEmpty Property
SpotDimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpotDimensionTypeSet Class


Size Property

[image]

Revit 2011 API
SpotDimensionTypeSet..::.Size Property
SpotDimensionTypeSet Class See Also Send Feedback
Returns the number of spotdimension types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSetIterator Class

[image]

Revit 2011 API
SpotDimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a spotdimension type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SpotDimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpotDimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SpotDimensionTypeSetIterator

See Also

SpotDimensionTypeSetIterator Members


SpotDimensionTypeSetIterator Members

[image] [image]

Revit 2011 API
SpotDimensionTypeSetIterator Members
SpotDimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Constructors

Name | Description
SpotDimensionTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Constructor

[image]

Revit 2011 API
SpotDimensionTypeSetIterator Constructor
SpotDimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpotDimensionTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpotDimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Methods

[image] [image]

Revit 2011 API
SpotDimensionTypeSetIterator Methods
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
SpotDimensionTypeSetIterator..::.MoveNext Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
SpotDimensionTypeSetIterator..::.Reset Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Properties

[image] [image]

Revit 2011 API
SpotDimensionTypeSetIterator Properties
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class


Current Property

[image]

Revit 2011 API
SpotDimensionTypeSetIterator..::.Current Property
SpotDimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class


StickSymbolLocation Enumeration

[image]

Revit 2011 API
StickSymbolLocation Enumeration
See Also Send Feedback
Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum StickSymbolLocation
Visual Basic (Declaration)
Public Enumeration StickSymbolLocation
Visual C++
public enum class StickSymbolLocation

Members

Member name | Description
StickViewCenter |
StickViewTop |
StickViewBottom |
StickViewLocLine |

See Also


StorageType Enumeration

[image]

Revit 2011 API
StorageType Enumeration
See Also Send Feedback
An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum StorageType
Visual Basic (Declaration)
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
None | None represents an invalid storage type. This value should not be used.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internally in the form of an 8 byte floating point number.
String | The internal data will be stored in the form of a string of characters.
ElementId | The data type represents an element and is stored as the id of the element.

See Also


StructuralReleaseType Enumeration

[image]

Revit 2011 API
StructuralReleaseType Enumeration
See Also Send Feedback
Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum StructuralReleaseType
Visual Basic (Declaration)
Public Enumeration StructuralReleaseType
Visual C++
public enum class StructuralReleaseType

Members

Member name | Description
kFixed |
kPinned |
kBendingMoment |
kUserDefined |

See Also


SubTransaction Class

[image]

Revit 2011 API
SubTransaction Class
Members See Also Send Feedback
Sub-transactions are objects that allow controlling a subset of changes in a document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SubTransaction : IDisposable
Visual Basic (Declaration)
Public Class SubTransaction _
    Implements IDisposable
Visual C++
public ref class SubTransaction : IDisposable

Remarks

A Sub-transaction can only be active as a part of an open transaction. Sub-transactions may be nested inside each other, but with the restriction that every nested sub-transaction is entirely contained (open an closed) in the parent sub-transaction.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.SubTransaction

See Also

SubTransaction Members


SubTransaction Members

[image] [image]

Revit 2011 API
SubTransaction Members
SubTransaction Class Constructors Methods See Also Send Feedback

The SubTransaction type exposes the following members.

Constructors

Name | Description
SubTransaction | Instantiates a sub-transaction object

Methods

Name | Description
Commit | Commits all changes made to the model during the sub-transaction
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatus | Returns the current status of the sub-transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the sub-transaction has ended already
HasStarted | Determines whether the sub-transaction has been started yet
RollBack | Discards all changes made to the model during the sub-transaction
Start | Starts the sub-transaction
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class


SubTransaction Constructor

[image]

Revit 2011 API
SubTransaction Constructor
SubTransaction Class See Also Send Feedback
Instantiates a sub-transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SubTransaction(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SubTransaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this sub-transaction is going to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SubTransaction Class


SubTransaction Methods

[image] [image]

Revit 2011 API
SubTransaction Methods
SubTransaction Class See Also Send Feedback

The SubTransaction type exposes the following members.

Methods

Name | Description
Commit | Commits all changes made to the model during the sub-transaction
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatus | Returns the current status of the sub-transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the sub-transaction has ended already
HasStarted | Determines whether the sub-transaction has been started yet
RollBack | Discards all changes made to the model during the sub-transaction
Start | Starts the sub-transaction
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class


Commit Method

[image]

Revit 2011 API
SubTransaction..::.Commit Method
SubTransaction Class See Also Send Feedback
Commits all changes made to the model during the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus::Committed

Remarks

The changes are not permanently committed to the document yet. They will be committed only when the parent transaction is committed. If the transaction is rolled back, the changes committed here will be discarded too.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


Dispose Method

[image]

Revit 2011 API
SubTransaction..::.Dispose Method
SubTransaction Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

SubTransaction Class


GetStatus Method

[image]

Revit 2011 API
SubTransaction..::.GetStatus Method
SubTransaction Class See Also Send Feedback
Returns the current status of the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic (Declaration)
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

See Also

SubTransaction Class


HasEnded Method

[image]

Revit 2011 API
SubTransaction..::.HasEnded Method
SubTransaction Class See Also Send Feedback
Determines whether the sub-transaction has ended already

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic (Declaration)
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

See Also

SubTransaction Class


HasStarted Method

[image]

Revit 2011 API
SubTransaction..::.HasStarted Method
SubTransaction Class See Also Send Feedback
Determines whether the sub-transaction has been started yet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic (Declaration)
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

See Also

SubTransaction Class


RollBack Method

[image]

Revit 2011 API
SubTransaction..::.RollBack Method
SubTransaction Class See Also Send Feedback
Discards all changes made to the model during the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Remarks

The parent transaction (or a parent sub-transaction, if any) can still be committed, but the changes rolled back by this method will not be a part of the committed transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


Start Method

[image]

Revit 2011 API
SubTransaction..::.Start Method
SubTransaction Class See Also Send Feedback
Starts the sub-transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If started successfully, this method returns TransactionStatus::Started

Remarks

A sub-transaction can only be started in an open transaction. The sub-transaction must be closed (committed or rolled back) while still inside the open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished

See Also

SubTransaction Class


SunAndShadowSettings Class

[image]

Revit 2011 API
SunAndShadowSettings Class
Members See Also Send Feedback
The SunAndShadowSettings class represents the sun control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SunAndShadowSettings : Element
Visual Basic (Declaration)
Public Class SunAndShadowSettings _
    Inherits Element
Visual C++
public ref class SunAndShadowSettings : public Element

Remarks

The SunAndShadowSettings element represents the settings applied to a project or view regarding the position, dates, time intervals and other options for the sun control and solar studies. To differentiate between the project and view settings, test the ViewSpecific or OwnerViewId property. If the element is not view-specific this element represents a project-wide setting. If the element is associated to a view, this element represents a per view SunAndShadowSettings. When you create a new view, a new view-specific SunAndShadowSettings element is automatically created for it.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.SunAndShadowSettings

See Also

SunAndShadowSettings Members


SunAndShadowSettings Members

[image] [image]

Revit 2011 API
SunAndShadowSettings Members
SunAndShadowSettings Class Methods Properties See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

Name | Description
CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
GetActiveSunAndShadowSettings | Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsAfterStartDateAndTime | Checks whether the end date and time is valid.
IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsLevelValid | Checks whether the element represents a valid level.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndDateAndTime | Identifies the end date and time.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundPlaneHeight | Identifies the ground plane height.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
SharesSettings | Identifies whether settings a shared globally.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StartDateAndTime | Identifies the start or current date and time.
SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
TimeInterval | Identifies the time interval between animation frames.
TimeZone | Identifies the time zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Visibility in current view for a per-view SunAndShadowSettings element.

See Also

SunAndShadowSettings Class


SunAndShadowSettings Methods

[image] [image]

Revit 2011 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

Name | Description
CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
GetActiveSunAndShadowSettings | Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsAfterStartDateAndTime | Checks whether the end date and time is valid.
IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsLevelValid | Checks whether the element represents a valid level.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SunAndShadowSettings Class


CalculateTimeZone Method

[image]

Revit 2011 API
SunAndShadowSettings..::.CalculateTimeZone Method
SunAndShadowSettings Class See Also Send Feedback
Use Revit's utilities to calculate the time zone for a given longitude and latitude.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_UR2

Syntax

C#
public static double CalculateTimeZone(
    double latitude,
    double longitude
)
Visual Basic (Declaration)
Public Shared Function CalculateTimeZone ( _
    latitude As Double, _
    longitude As Double _
) As Double
Visual C++
public:
static double CalculateTimeZone(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::.Double
The latitude.
longitude
Type: System..::.Double
The longitude.

Return Value

The time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Remarks

For some latitude and longitude boundary cases, the time zone calculated may not be correct. The API offers the ability to adjust the time zone independent of Revit's calculations for situations where this happens.

See Also

SunAndShadowSettings Class


FitToModel Method

[image]

Revit 2011 API
SunAndShadowSettings..::.FitToModel Method
SunAndShadowSettings Class See Also Send Feedback
Adjust SunAndShadowSettings to fit around the current model geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void FitToModel()
Visual Basic (Declaration)
Public Sub FitToModel
Visual C++
public:
void FitToModel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class


GetActiveSunAndShadowSettings Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetActiveSunAndShadowSettings Method
SunAndShadowSettings Class See Also Send Feedback
Returns the currently SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static Element GetActiveSunAndShadowSettings(
    Document aDocument
)
Visual Basic (Declaration)
Public Shared Function GetActiveSunAndShadowSettings ( _
    aDocument As Document _
) As Element
Visual C++
public:
static Element^ GetActiveSunAndShadowSettings(
    Document^ aDocument
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

The active SunAndShadowSettings element for the supplied document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class


GetFrameAltitude Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetFrameAltitude Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the altitude of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetFrameAltitude(
    double frame
)
Visual Basic (Declaration)
Public Function GetFrameAltitude ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAltitude(
    double frame
)

Parameters

frame
Type: System..::.Double
Frame for which time is requested

Return Value

Altitude angle (radians)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetFrameAzimuth Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetFrameAzimuth Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the azimuth of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetFrameAzimuth(
    double frame
)
Visual Basic (Declaration)
Public Function GetFrameAzimuth ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAzimuth(
    double frame
)

Parameters

frame
Type: System..::.Double
Frame for which time is requested

Return Value

Azimuth angle (radians). This is measured counterclockwise from the X axis (East direction). Note that this is a different frame of reference than is used by Revit for the Lighting Study Azimuth value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetFrameTime Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetFrameTime Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for a given frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime GetFrameTime(
    double frame
)
Visual Basic (Declaration)
Public Function GetFrameTime ( _
    frame As Double _
) As DateTime
Visual C++
public:
DateTime GetFrameTime(
    double frame
)

Parameters

frame
Type: System..::.Double
Frame for which time is requested

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetMatchingPreset Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetMatchingPreset Method
SunAndShadowSettings Class See Also Send Feedback
Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetMatchingPreset()
Visual Basic (Declaration)
Public Function GetMatchingPreset As String
Visual C++
public:
String^ GetMatchingPreset()

Return Value

Name of the per-document SunAndShadowSettings that matches the view specific element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class


GetSunrise Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetSunrise Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime GetSunrise(
    DateTime date
)
Visual Basic (Declaration)
Public Function GetSunrise ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunrise(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date for which to determine sunrise time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunrise value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


GetSunset Method

[image]

Revit 2011 API
SunAndShadowSettings..::.GetSunset Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime GetSunset(
    DateTime date
)
Visual Basic (Declaration)
Public Function GetSunset ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunset(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
The date for which to determine sunset time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunset value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


IsAfterStartDateAndTime Method

[image]

Revit 2011 API
SunAndShadowSettings..::.IsAfterStartDateAndTime Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the end date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAfterStartDateAndTime(
    DateTime time
)
Visual Basic (Declaration)
Public Function IsAfterStartDateAndTime ( _
    time As DateTime _
) As Boolean
Visual C++
public:
bool IsAfterStartDateAndTime(
    DateTime time
)

Parameters

time
Type: System..::.DateTime
Date and time value

Return Value

True if the date and time is valid, false otherwise.

See Also

SunAndShadowSettings Class


IsBeforeEndDateAndTime Method

[image]

Revit 2011 API
SunAndShadowSettings..::.IsBeforeEndDateAndTime Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the start date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsBeforeEndDateAndTime(
    DateTime time
)
Visual Basic (Declaration)
Public Function IsBeforeEndDateAndTime ( _
    time As DateTime _
) As Boolean
Visual C++
public:
bool IsBeforeEndDateAndTime(
    DateTime time
)

Parameters

time
Type: System..::.DateTime
Date and time value

Return Value

True if the date and time is valid, false otherwise.

See Also

SunAndShadowSettings Class


IsFrameValid Method

[image]

Revit 2011 API
SunAndShadowSettings..::.IsFrameValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the frame is valid for the supplied SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsFrameValid(
    double frame
)
Visual Basic (Declaration)
Public Function IsFrameValid ( _
    frame As Double _
) As Boolean
Visual C++
public:
bool IsFrameValid(
    double frame
)

Parameters

frame
Type: System..::.Double
Frame value

Return Value

True if the frame is valid for the SunAndShadowSettings, false otherwise.

See Also

SunAndShadowSettings Class


IsLevelValid Method

[image]

Revit 2011 API
SunAndShadowSettings..::.IsLevelValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the element represents a valid level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsLevelValid(
    ElementId levelId
)
Visual Basic (Declaration)
Public Function IsLevelValid ( _
    levelId As ElementId _
) As Boolean
Visual C++
public:
bool IsLevelValid(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::.ElementId
Level element id.

Return Value

True if the element is a valid Level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class


IsTimeIntervalValid Method

[image]

Revit 2011 API
SunAndShadowSettings..::.IsTimeIntervalValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
Visual Basic (Declaration)
Public Function IsTimeIntervalValid ( _
    interval As SunStudyTimeInterval _
) As Boolean
Visual C++
public:
bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)

Parameters

interval
Type: Autodesk.Revit.DB..::.SunStudyTimeInterval
Time interval value.

Return Value

True if the time interval is valid for the current SunAndShadowType, false otherwise.

See Also

SunAndShadowSettings Class


SunAndShadowSettings Properties

[image] [image]

Revit 2011 API
SunAndShadowSettings Properties
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Properties

Name | Description
ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndDateAndTime | Identifies the end date and time.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundPlaneHeight | Identifies the ground plane height.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
SharesSettings | Identifies whether settings a shared globally.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StartDateAndTime | Identifies the start or current date and time.
SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
TimeInterval | Identifies the time interval between animation frames.
TimeZone | Identifies the time zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | Visibility in current view for a per-view SunAndShadowSettings element.

See Also

SunAndShadowSettings Class


ActiveFrame Property

[image]

Revit 2011 API
SunAndShadowSettings..::.ActiveFrame Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double ActiveFrame { get; set; }
Visual Basic (Declaration)
Public Property ActiveFrame As Double
Visual C++
public:
property double ActiveFrame {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: the frame value frame is not valid.

See Also

SunAndShadowSettings Class


ActiveFrameTime Property

[image]

Revit 2011 API
SunAndShadowSettings..::.ActiveFrameTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for the active frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime ActiveFrameTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveFrameTime As DateTime
Visual C++
public:
property DateTime ActiveFrameTime {
    DateTime get ();
}

Field Value

The date and time. The value will be in Coordinated Universal Time (UTC).

See Also

SunAndShadowSettings Class


Altitude Property

[image]

Revit 2011 API
SunAndShadowSettings..::.Altitude Property
SunAndShadowSettings Class See Also Send Feedback
Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Altitude { get; set; }
Visual Basic (Declaration)
Public Property Altitude As Double
Visual C++
public:
property double Altitude {
    double get ();
    void set (double value);
}

Field Value

Altitude angle (radians)

See Also

SunAndShadowSettings Class


Azimuth Property

[image]

Revit 2011 API
SunAndShadowSettings..::.Azimuth Property
SunAndShadowSettings Class See Also Send Feedback
Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Azimuth { get; set; }
Visual Basic (Declaration)
Public Property Azimuth As Double
Visual C++
public:
property double Azimuth {
    double get ();
    void set (double value);
}

Field Value

Azimuth angle (radians)

See Also

SunAndShadowSettings Class


EndDateAndTime Property

[image]

Revit 2011 API
SunAndShadowSettings..::.EndDateAndTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the end date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime EndDateAndTime { get; set; }
Visual Basic (Declaration)
Public Property EndDateAndTime As DateTime
Visual C++
public:
property DateTime EndDateAndTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.

Remarks

This property represents the end time for a single-day or multi-day study. The end date and time can be set for any study type, but is not always used. Note that Revit may ignore this value if the SunriseToSunset flag is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.

See Also

SunAndShadowSettings Class


GroundPlaneHeight Property

[image]

Revit 2011 API
SunAndShadowSettings..::.GroundPlaneHeight Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the ground plane height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GroundPlaneHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroundPlaneHeight As Double
Visual C++
public:
property double GroundPlaneHeight {
    double get ();
}

See Also

SunAndShadowSettings Class


Latitude Property

[image]

Revit 2011 API
SunAndShadowSettings..::.Latitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current latitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Latitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Latitude As Double
Visual C++
public:
property double Latitude {
    double get ();
}

See Also

SunAndShadowSettings Class


LevelId Property

[image]

Revit 2011 API
SunAndShadowSettings..::.LevelId Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId LevelId { get; set; }
Visual Basic (Declaration)
Public Property LevelId As ElementId
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: the element level is not a valid Level element.
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SunAndShadowSettings Class


Longitude Property

[image]

Revit 2011 API
SunAndShadowSettings..::.Longitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current longitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Longitude { get; }
Visual Basic (Declaration)
Public ReadOnly Property Longitude As Double
Visual C++
public:
property double Longitude {
    double get ();
}

See Also

SunAndShadowSettings Class


NumberOfFrames Property

[image]

Revit 2011 API
SunAndShadowSettings..::.NumberOfFrames Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the total number of animation frames for a single-day or multi-day study.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double NumberOfFrames { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfFrames As Double
Visual C++
public:
property double NumberOfFrames {
    double get ();
}

See Also

SunAndShadowSettings Class


Parameter Property

[image] [image]

Revit 2011 API
SunAndShadowSettings..::.Parameter Property
SunAndShadowSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SunAndShadowSettings Class
SunAndShadowSettings Members


ProjectLocationId Property

[image]

Revit 2011 API
SunAndShadowSettings..::.ProjectLocationId Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the ProjectLocation element used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ProjectLocationId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocationId As ElementId
Visual C++
public:
property ElementId^ ProjectLocationId {
    ElementId^ get ();
}

See Also

SunAndShadowSettings Class


ProjectLocationName Property

[image]

Revit 2011 API
SunAndShadowSettings..::.ProjectLocationName Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the name of the project location used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string ProjectLocationName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectLocationName As String
Visual C++
public:
property String^ ProjectLocationName {
    String^ get ();
}

See Also

SunAndShadowSettings Class


RelativeToView Property

[image]

Revit 2011 API
SunAndShadowSettings..::.RelativeToView Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool RelativeToView { get; set; }
Visual Basic (Declaration)
Public Property RelativeToView As Boolean
Visual C++
public:
property bool RelativeToView {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


SharesSettings Property

[image]

Revit 2011 API
SunAndShadowSettings..::.SharesSettings Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether settings a shared globally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool SharesSettings { get; set; }
Visual Basic (Declaration)
Public Property SharesSettings As Boolean
Visual C++
public:
property bool SharesSettings {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the per-view SunAndShadowSettings element shares global settings. Global settings are a special case that allows multiple views to be associated together in order that a change in one view affects that same change in other views. There cannot be multiple such groups, and a SunAndShadowSettings element is either a global setting or not.

See Also

SunAndShadowSettings Class


StartDateAndTime Property

[image]

Revit 2011 API
SunAndShadowSettings..::.StartDateAndTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the start or current date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public DateTime StartDateAndTime { get; set; }
Visual Basic (Declaration)
Public Property StartDateAndTime As DateTime
Visual C++
public:
property DateTime StartDateAndTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.

Remarks

This property represents the start time for a single-day or multi-day study, or the current time for a still sun study. Note that Revit may ignore this value if the SunriseToSunset flag is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.

See Also

SunAndShadowSettings Class


SunAndShadowType Property

[image]

Revit 2011 API
SunAndShadowSettings..::.SunAndShadowType Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the type of the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowType SunAndShadowType { get; set; }
Visual Basic (Declaration)
Public Property SunAndShadowType As SunAndShadowType
Visual C++
public:
property SunAndShadowType SunAndShadowType {
    SunAndShadowType get ();
    void set (SunAndShadowType value);
}

Remarks

There are no restrictions on setting the type, but do note that some properties are not relevant for certain types. For example, the property EndDateAndTime is not relevant for the type SunAndShadowType.StillImage. In this example (and elsewhere), the previous value for the property is remembered for when the type is reverted. If that property has not been set yet, default values will apply.

See Also

SunAndShadowSettings Class


SunriseToSunset Property

[image]

Revit 2011 API
SunAndShadowSettings..::.SunriseToSunset Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the current single day sun study is set to run from sunrise to sunset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool SunriseToSunset { get; set; }
Visual Basic (Declaration)
Public Property SunriseToSunset As Boolean
Visual C++
public:
property bool SunriseToSunset {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


TimeInterval Property

[image]

Revit 2011 API
SunAndShadowSettings..::.TimeInterval Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SunStudyTimeInterval TimeInterval { get; set; }
Visual Basic (Declaration)
Public Property TimeInterval As SunStudyTimeInterval
Visual C++
public:
property SunStudyTimeInterval TimeInterval {
    SunStudyTimeInterval get ();
    void set (SunStudyTimeInterval value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType.

See Also

SunAndShadowSettings Class


TimeZone Property

[image]

Revit 2011 API
SunAndShadowSettings..::.TimeZone Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double TimeZone { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeZone As Double
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

Identifies the time zone used by the SunAndShadowSettings element. This property indicates the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

SunAndShadowSettings Class


UsesDST Property

[image]

Revit 2011 API
SunAndShadowSettings..::.UsesDST Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is using daylight savings time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UsesDST { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsesDST As Boolean
Visual C++
public:
property bool UsesDST {
    bool get ();
}

See Also

SunAndShadowSettings Class


UsesGroundPlane Property

[image]

Revit 2011 API
SunAndShadowSettings..::.UsesGroundPlane Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element uses a ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UsesGroundPlane { get; set; }
Visual Basic (Declaration)
Public Property UsesGroundPlane As Boolean
Visual C++
public:
property bool UsesGroundPlane {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


Visible Property

[image]

Revit 2011 API
SunAndShadowSettings..::.Visible Property
SunAndShadowSettings Class See Also Send Feedback
Visibility in current view for a per-view SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

Visibility

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The element is not view specific (in which case visibility is not relevant) or if internally its view is not accessible.

See Also

SunAndShadowSettings Class


SunAndShadowType Enumeration

[image]

Revit 2011 API
SunAndShadowType Enumeration
See Also Send Feedback
Sun study type enum of SunAndShadowSettings.
Enum of sun study type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunAndShadowType
Visual Basic (Declaration)
Public Enumeration SunAndShadowType
Visual C++
public enum class SunAndShadowType

Members

Member name | Description
StillImage | Still image study type (single point in time).
OneDayStudy | Single day study type (time range over a specific day).
MultiDayStudy | Multi day study type (range over date and time).
Lighting | Lighting study type (fixed sun position regardless of date and time).

See Also


SunStudyTimeInterval Enumeration

[image]

Revit 2011 API
SunStudyTimeInterval Enumeration
See Also Send Feedback
Time interval enum for a single or multi-day sun study.
Enum of sun study time interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunStudyTimeInterval
Visual Basic (Declaration)
Public Enumeration SunStudyTimeInterval
Visual C++
public enum class SunStudyTimeInterval

Members

Member name | Description
Minutes15 | Interval occurs every 15 minutes.
Minutes30 | Interval occurs every 30 minutes.
Minutes45 | Interval occurs every 45 minutes.
Hour | Interval occurs every hour.
Day | Interval occurs every day.
Week | Interval occurs once a week.
Month | Interval occurs once a month.

See Also


SuspendUpdating Class

[image]

Revit 2011 API
SuspendUpdating Class
Members Example See Also Send Feedback
Temporarily delay Revit's automatic updating and consistency operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SuspendUpdating : APIObject
Visual Basic (Declaration)
Public Class SuspendUpdating _
    Inherits APIObject
Visual C++
public ref class SuspendUpdating : public APIObject

Remarks

Creating an instance of this object will cause Autodesk Revit to suspend certain updating and consistency operations, thereby enabling increased performance of large changes via the API. After the object is disposed, updating will take place if required. The object should be disposed explicitly using the Dispose method to ensure known points of consistency within your application. Note that while this object is active the Revit model data may be inconsistent hence values retrieved cannot necessarily be trusted. The object may be nested and the Nested property will return if such an object is already nested. During nesting the final updating will only happen when all SuspendUpdating objects are disposed. Currently suspend updating functionality works primarily with object transformation operations such as move and rotate. Following methods(properties) support SuspendUpdating:
  • Autodesk.Revit.DB.Document.Move
  • Autodesk.Revit.DB.Document.Rotate
  • Autodesk.Revit.DB.Document.Mirror
  • Autodesk.Revit.DB.Location.Move
  • Autodesk.Revit.DB.Location.Rotate
  • Autodesk.Revit.Creation.ItemFactoryBase.NewAnnotationSymbol
  • Autodesk.Revit.DB.FamilyInstance.flipHand
  • Autodesk.Revit.DB.FamilyInstance.flipFacing
  • Autodesk.Revit.DB.FamilyInstance.rotate
  • Autodesk.Revit.DB.FamilyInstance.FlipFromToRoom
  • Autodesk.Revit.DB.CurtainGridLine.Move
  • property Autodesk.Revit.DB.LocationPoint.Point.set
  • property Autodesk.Revit.DB.FamilyInstance.Symbol.set
  • property Autodesk.Revit.DB.FamilyInstance.StructuralUsage.set
  • property Autodesk.Revit.DB.Wall.WallType.set
  • property Autodesk.Revit.DB.TextNote.Coord.set
  • property Autodesk.Revit.DB.TextNote.Width.set
  • property Autodesk.Revit.DB.IndependentTag.TagHeadPosition.set
  • property Autodesk.Revit.DB.IndependentTag.LeaderElbow.set
  • property Autodesk.Revit.DB.IndependentTag.LeaderEnd.set
  • property Autodesk.Revit.DB.Leader.End.set
  • property Autodesk.Revit.DB.Leader.Elbow.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid1Justification.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid1Angle.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid1Offset.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid2Justification.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid2Angle.set
  • property Autodesk.Revit.DB.CurtainGrid.Grid2Offset.set

This class offers an option to suspend updating during parameter modifications (methods Autodesk.Revit.DB.Parameter.Set()).

Examples

CopyC#
public void MoveElements(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    Selection choices = uidoc.Selection;
    ElementSet collection = choices.Elements;
    // Using statement defines a scope at the end of which the suspandUpdating
    // object is disposed.
    using (SuspendUpdating aSuspendUpdating = new SuspendUpdating(document))
    {
        // Suspend these operations.
        foreach (FamilyInstance element in collection)
        {
            MoveRotateElement(document, element);
        }
    }
    // Move() operations only update when aSuspendUpdating and
    // bSuspendUpdating (in MoveRotateElement()) are disposed
}

private bool MoveRotateElement(Document document, Autodesk.Revit.DB.Element elem)
{
    // Operations suspended until SuspendUpdating object is disposed
    using (SuspendUpdating bSuspendUpdating = new SuspendUpdating(document))
    {
        // Move Element
        XYZ translation3D = new XYZ(0.0, 0.0, 0.0);
        bool successful1 = document.Move(elem, translation3D);

        // Rotate Element
        XYZ point1 = new XYZ(10, 20, 0);
        XYZ point2 = new XYZ(10, 20, 30);
        Line axis = document.Application.Create.NewLineUnbound(point1, point2);
        bool successful2 = document.Rotate(elem, axis, Math.PI / 3.0);

        return (successful1 && successful2);
    }
}
CopyVB.NET
Public Sub MoveElements(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
    Dim collection As ElementSet = choices.Elements
    ' Using statement defines a scope at the end of which the suspandUpdating
    ' object is disposed.
    Using aSuspendUpdating As New SuspendUpdating(document)
        ' Suspend these operations.
        For Each element As Autodesk.Revit.DB.FamilyInstance In collection
            MoveRotateElement(document, element)
        Next
    End Using
    ' Move() operations only update when aSuspendUpdating and
    ' bSuspendUpdating (in MoveRotateElement()) are disposed
End Sub

Private Function MoveRotateElement(ByVal document As Document, ByVal elem As Autodesk.Revit.DB.Element) As Boolean
    ' Operations suspended until SuspendUpdating object is disposed
    Using bSuspendUpdating As New SuspendUpdating(document)
        ' Move Element
        Dim translation3D As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim successful1 As Boolean = document.Move(elem, translation3D)

        ' Rotate Element
        Dim point1 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
        Dim point2 As New Autodesk.Revit.DB.XYZ(10, 20, 30)
        Dim axis As Line = document.Application.Create.NewLineUnbound(point1, point2)
        Dim successful2 As Boolean = document.Rotate(elem, axis, Math.PI / 3)

        Return (successful1 AndAlso successful2)
    End Using
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SuspendUpdating

See Also

SuspendUpdating Members


SuspendUpdating Members

[image] [image]

Revit 2011 API
SuspendUpdating Members
SuspendUpdating Class Constructors Methods Properties See Also Send Feedback

The SuspendUpdating type exposes the following members.

Constructors

Name | Description
SuspendUpdating | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Nested | A property that reports if updating has already been suspended before.

See Also

SuspendUpdating Class


SuspendUpdating Constructor

[image] [image]

Revit 2011 API
SuspendUpdating Constructor
SuspendUpdating Class See Also Send Feedback

Overload List

Name | Description
SuspendUpdating(Document) | Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.
SuspendUpdating(Document, Boolean) | Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.

See Also

SuspendUpdating Class
SuspendUpdating Members


SuspendUpdating Constructor (Document)

[image]

Revit 2011 API
SuspendUpdating Constructor (Document)
SuspendUpdating Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SuspendUpdating(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again. Suspension of updates during parameter set method calls will be enabled when using this constructor.

See Also

SuspendUpdating Class
SuspendUpdating Overload


SuspendUpdating Constructor (Document, Boolean)

[image]

Revit 2011 API
SuspendUpdating Constructor (Document, Boolean)
SuspendUpdating Class See Also Send Feedback
Creates a new instance of the SuspendUpdating object and begins suspension of consistency updates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SuspendUpdating(
    Document document,
    bool suspendForParameterSet
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    suspendForParameterSet As Boolean _
)
Visual C++
public:
SuspendUpdating(
    Document^ document,
    bool suspendForParameterSet
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which updating will be suspended.
suspendForParameterSet
Type: System..::.Boolean
True if the suspension of updates also should apply to the parameter set methods. False otherwise.

Remarks

During suspension of updating, consistency will not be maintained. When all SuspendUpdating objects have been disposed, Revit will make the document consistent again.

See Also

SuspendUpdating Class
SuspendUpdating Overload


SuspendUpdating Methods

[image] [image]

Revit 2011 API
SuspendUpdating Methods
SuspendUpdating Class See Also Send Feedback

The SuspendUpdating type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SuspendUpdating Class


SuspendUpdating Properties

[image] [image]

Revit 2011 API
SuspendUpdating Properties
SuspendUpdating Class See Also Send Feedback

The SuspendUpdating type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Nested | A property that reports if updating has already been suspended before.

See Also

SuspendUpdating Class


Nested Property

[image]

Revit 2011 API
SuspendUpdating..::.Nested Property
SuspendUpdating Class See Also Send Feedback
A property that reports if updating has already been suspended before.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Nested { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nested As Boolean
Visual C++
public:
property bool Nested {
    bool get ();
}

Remarks

This property can be used to detect that the SuspendUpdating object has been created during the lifetime of another SuspendUpdating object and hence the document will not be made consistent which this object is disposed.

See Also

SuspendUpdating Class


Sweep Class

[image]

Revit 2011 API
Sweep Class
Members See Also Send Feedback
A sweep solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Sweep : GenericForm
Visual Basic (Declaration)
Public Class Sweep _
    Inherits GenericForm
Visual C++
public ref class Sweep : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.Sweep

See Also

Sweep Members


Sweep Members

[image] [image]

Revit 2011 API
Sweep Members
Sweep Class Methods Properties See Also Send Feedback

The Sweep type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep Class


Sweep Methods

[image] [image]

Revit 2011 API
Sweep Methods
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sweep Class


Sweep Properties

[image] [image]

Revit 2011 API
Sweep Properties
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Path3d | The selected curves used for the sweep path.
PathSketch | The sketched path for the sweep.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProfileSketch | The profile sketch of the sweep.
ProfileSymbol | The family symbol profile details for the sweep.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

Sweep Class


IsTrajectorySegmentationEnabled Property

[image]

Revit 2011 API
Sweep..::.IsTrajectorySegmentationEnabled Property
Sweep Class See Also Send Feedback
The trajectory segmentation option for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsTrajectorySegmentationEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsTrajectorySegmentationEnabled As Boolean
Visual C++
public:
property bool IsTrajectorySegmentationEnabled {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to retrieve/set the trajectory segmentation state of the sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.

See Also

Sweep Class


MaxSegmentAngle Property

[image]

Revit 2011 API
Sweep..::.MaxSegmentAngle Property
Sweep Class See Also Send Feedback
The maximum segment angle of the sweep in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MaxSegmentAngle { get; set; }
Visual Basic (Declaration)
Public Property MaxSegmentAngle As Double
Visual C++
public:
property double MaxSegmentAngle {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve/set the maximum segment angle of the sweep. It is settable only when the trajectory segmentation is enabled.

See Also

Sweep Class


Parameter Property

[image] [image]

Revit 2011 API
Sweep..::.Parameter Property
Sweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Sweep Class
Sweep Members


Path3d Property

[image]

Revit 2011 API
Sweep..::.Path3d Property
Sweep Class See Also Send Feedback
The selected curves used for the sweep path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Path3d Path3d { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path3d As Path3d
Visual C++
public:
property Path3d^ Path3d {
    Path3d^ get ();
}

Remarks

If the sweep is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


PathSketch Property

[image]

Revit 2011 API
Sweep..::.PathSketch Property
Sweep Class See Also Send Feedback
The sketched path for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathSketch As Sketch
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the sweep is based on selected 3d curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSketch Property

[image]

Revit 2011 API
Sweep..::.ProfileSketch Property
Sweep Class See Also Send Feedback
The profile sketch of the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch ProfileSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSketch As Sketch
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

If the profile is not based on sketched curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSymbol Property

[image]

Revit 2011 API
Sweep..::.ProfileSymbol Property
Sweep Class See Also Send Feedback
The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile ProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the profile is not based on a profile family, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


SweepProfile Class

[image]

Revit 2011 API
SweepProfile Class
Members See Also Send Feedback
Represents a profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SweepProfile : APIObject
Visual Basic (Declaration)
Public Class SweepProfile _
    Inherits APIObject
Visual C++
public ref class SweepProfile : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SweepProfile
Autodesk.Revit.DB..::.CurveLoopsProfile
Autodesk.Revit.DB..::.FamilySymbolProfile

See Also

SweepProfile Members


SweepProfile Members

[image] [image]

Revit 2011 API
SweepProfile Members
SweepProfile Class Methods Properties See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweepProfile Methods

[image] [image]

Revit 2011 API
SweepProfile Methods
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweepProfile Class


SweepProfile Properties

[image] [image]

Revit 2011 API
SweepProfile Properties
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweptBlend Class

[image]

Revit 2011 API
SweptBlend Class
Members See Also Send Feedback
A swept blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SweptBlend : GenericForm
Visual Basic (Declaration)
Public Class SweptBlend _
    Inherits GenericForm
Visual C++
public ref class SweptBlend : public GenericForm

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CombinableElement
Autodesk.Revit.DB..::.GenericForm
Autodesk.Revit.DB..::.SweptBlend

See Also

SweptBlend Members


SweptBlend Members

[image] [image]

Revit 2011 API
SweptBlend Members
SweptBlend Class Methods Properties See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomProfileSymbol | The bottom family symbol profile of the swept blend.
BottomSketch | The bottom profile sketch of the swept blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathSketch | The sketched path for the swept blend.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SelectedPath | The selected curve used for the swept blend path.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopProfile | The curves which make up the top profile of the sketch.
TopProfileSymbol | The top family symbol profile of the swept blend.
TopSketch | The top profile sketch of the swept blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

SweptBlend Class


SweptBlend Methods

[image] [image]

Revit 2011 API
SweptBlend Methods
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweptBlend Class


GetVertexConnectionMap Method

[image]

Revit 2011 API
SweptBlend..::.GetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic (Declaration)
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

SweptBlend Class


SetVertexConnectionMap Method

[image]

Revit 2011 API
SweptBlend..::.SetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic (Declaration)
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::.VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the document failed to regenerate.

See Also

SweptBlend Class


SweptBlend Properties

[image] [image]

Revit 2011 API
SweptBlend Properties
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Properties

Name | Description
BottomProfile | The curves which make up the bottom profile of the sketch.
BottomProfileSymbol | The bottom family symbol profile of the swept blend.
BottomSketch | The bottom profile sketch of the swept blend.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get and Set the Name property (Inherited from GenericForm.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathSketch | The sketched path for the swept blend.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SelectedPath | The selected curve used for the swept blend path.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Subcategory | The subcategory. (Inherited from GenericForm.)
TopProfile | The curves which make up the top profile of the sketch.
TopProfileSymbol | The top family symbol profile of the swept blend.
TopSketch | The top profile sketch of the swept blend.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Visible | The visibility of the GenericForm. (Inherited from GenericForm.)

See Also

SweptBlend Class


BottomProfile Property

[image]

Revit 2011 API
SweptBlend..::.BottomProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class


BottomProfileSymbol Property

[image]

Revit 2011 API
SweptBlend..::.BottomProfileSymbol Property
SweptBlend Class See Also Send Feedback
The bottom family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile BottomProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ BottomProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the bottom profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


BottomSketch Property

[image]

Revit 2011 API
SweptBlend..::.BottomSketch Property
SweptBlend Class See Also Send Feedback
The bottom profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomSketch As Sketch
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

If the bottom profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


Parameter Property

[image] [image]

Revit 2011 API
SweptBlend..::.Parameter Property
SweptBlend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SweptBlend Class
SweptBlend Members


PathSketch Property

[image]

Revit 2011 API
SweptBlend..::.PathSketch Property
SweptBlend Class See Also Send Feedback
The sketched path for the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathSketch As Sketch
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the swept blend is based on selected 3d curve, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SelectedPath Property

[image]

Revit 2011 API
SweptBlend..::.SelectedPath Property
SweptBlend Class See Also Send Feedback
The selected curve used for the swept blend path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve SelectedPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedPath As Curve
Visual C++
public:
property Curve^ SelectedPath {
    Curve^ get ();
}

Remarks

If the swept blend is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopProfile Property

[image]

Revit 2011 API
SweptBlend..::.TopProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfile As CurveArrArray
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class


TopProfileSymbol Property

[image]

Revit 2011 API
SweptBlend..::.TopProfileSymbol Property
SweptBlend Class See Also Send Feedback
The top family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilySymbolProfile TopProfileSymbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopProfileSymbol As FamilySymbolProfile
Visual C++
public:
property FamilySymbolProfile^ TopProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the top profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopSketch Property

[image]

Revit 2011 API
SweptBlend..::.TopSketch Property
SweptBlend Class See Also Send Feedback
The top profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopSketch As Sketch
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

If the top profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SymbolicCurve Class

[image]

Revit 2011 API
SymbolicCurve Class
Members See Also Send Feedback
A curve that provides information but is not intended to represent actual geometry in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic (Declaration)
Public Class SymbolicCurve _
    Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Remarks

For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB..::.SymbolicCurve

See Also

SymbolicCurve Members


SymbolicCurve Members

[image] [image]

Revit 2011 API
SymbolicCurve Members
SymbolicCurve Class Methods Properties See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the symbolic curve.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the symbolic curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SymbolicCurve Class


SymbolicCurve Methods

[image] [image]

Revit 2011 API
SymbolicCurve Methods
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetVisibility | Gets the visibility for the symbolic curve.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVisibility | Sets the visibility for the symbolic curve.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurve Class


GetVisibility Method

[image]

Revit 2011 API
SymbolicCurve..::.GetVisibility Method
SymbolicCurve Class See Also Send Feedback
Gets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic (Declaration)
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the symbolic curve.

See Also

SymbolicCurve Class


SetVisibility Method

[image]

Revit 2011 API
SymbolicCurve..::.SetVisibility Method
SymbolicCurve Class See Also Send Feedback
Sets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic (Declaration)
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::.FamilyElementVisibility

Remarks

The visibility of the symbolic curve geometry can be changed for different detail levels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when visibility is not valid for symbolic curves.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class


SymbolicCurve Properties

[image] [image]

Revit 2011 API
SymbolicCurve Properties
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceType | Indicates the type of reference.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Subcategory | The subcategory.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SymbolicCurve Class


IsDrawnInForeground Property

[image]

Revit 2011 API
SymbolicCurve..::.IsDrawnInForeground Property
SymbolicCurve Class See Also Send Feedback
Indicates if this curve will be drawn in the foreground of the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDrawnInForeground { get; set; }
Visual Basic (Declaration)
Public Property IsDrawnInForeground As Boolean
Visual C++
public:
property bool IsDrawnInForeground {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed. Thrown when the value for this property cannot be changed.

See Also

SymbolicCurve Class


Parameter Property

[image] [image]

Revit 2011 API
SymbolicCurve..::.Parameter Property
SymbolicCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SymbolicCurve Class
SymbolicCurve Members


ReferenceType Property

[image]

Revit 2011 API
SymbolicCurve..::.ReferenceType Property
SymbolicCurve Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic (Declaration)
Public Property ReferenceType As ReferenceType
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class


Subcategory Property

[image]

Revit 2011 API
SymbolicCurve..::.Subcategory Property
SymbolicCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic (Declaration)
Public Property Subcategory As GraphicsStyle
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

SymbolicCurve Class


SymbolicCurveArray Class

[image]

Revit 2011 API
SymbolicCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SymbolicCurveArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SymbolicCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SymbolicCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SymbolicCurveArray

See Also

SymbolicCurveArray Members


SymbolicCurveArray Members

[image] [image]

Revit 2011 API
SymbolicCurveArray Members
SymbolicCurveArray Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Constructors

Name | Description
SymbolicCurveArray | Initializes a new instance of the SymbolicCurveArray class

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Constructor

[image]

Revit 2011 API
SymbolicCurveArray Constructor
SymbolicCurveArray Class See Also Send Feedback
Initializes a new instance of the SymbolicCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SymbolicCurveArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SymbolicCurveArray()

See Also

SymbolicCurveArray Class


SymbolicCurveArray Methods

[image] [image]

Revit 2011 API
SymbolicCurveArray Methods
SymbolicCurveArray Class See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Methods

Name | Description
Append | Add the model curve to the end of the array.
Clear | Removes every model curve from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified model curve into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurveArray Class


Append Method

[image]

Revit 2011 API
SymbolicCurveArray..::.Append Method
SymbolicCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    SymbolicCurve item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As SymbolicCurve _
)
Visual C++
public:
virtual void Append(
    SymbolicCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.SymbolicCurve
The model curve to be added.

See Also

SymbolicCurveArray Class


Clear Method

[image]

Revit 2011 API
SymbolicCurveArray..::.Clear Method
SymbolicCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SymbolicCurveArray Class


ForwardIterator Method

[image]

Revit 2011 API
SymbolicCurveArray..::.ForwardIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SymbolicCurveArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SymbolicCurveArray Class


GetEnumerator Method

[image]

Revit 2011 API
SymbolicCurveArray..::.GetEnumerator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SymbolicCurveArray Class


Insert Method

[image]

Revit 2011 API
SymbolicCurveArray..::.Insert Method
SymbolicCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    SymbolicCurve item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As SymbolicCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SymbolicCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.SymbolicCurve
The model curve to be inserted into the array.
index
Type: System..::.Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

SymbolicCurveArray Class


ReverseIterator Method

[image]

Revit 2011 API
SymbolicCurveArray..::.ReverseIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SymbolicCurveArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Properties

[image] [image]

Revit 2011 API
SymbolicCurveArray Properties
SymbolicCurveArray Class See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a model curve at a specified index within the array.
Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


IsEmpty Property

[image]

Revit 2011 API
SymbolicCurveArray..::.IsEmpty Property
SymbolicCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SymbolicCurveArray Class


Item Property

[image]

Revit 2011 API
SymbolicCurveArray..::.Item Property
SymbolicCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SymbolicCurve Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As SymbolicCurve
Visual C++
public:
virtual property SymbolicCurve^ Item[int index] {
    SymbolicCurve^ get (int index);
    void set (int index, SymbolicCurve^ value);
}

Parameters

index
Type: System..::.Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

SymbolicCurveArray Class


Size Property

[image]

Revit 2011 API
SymbolicCurveArray..::.Size Property
SymbolicCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SymbolicCurveArray Class


SymbolicCurveArrayIterator Class

[image]

Revit 2011 API
SymbolicCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SymbolicCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SymbolicCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SymbolicCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.SymbolicCurveArrayIterator

See Also

SymbolicCurveArrayIterator Members


SymbolicCurveArrayIterator Members

[image] [image]

Revit 2011 API
SymbolicCurveArrayIterator Members
SymbolicCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Constructors

Name | Description
SymbolicCurveArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Constructor

[image]

Revit 2011 API
SymbolicCurveArrayIterator Constructor
SymbolicCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SymbolicCurveArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SymbolicCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Methods

[image] [image]

Revit 2011 API
SymbolicCurveArrayIterator Methods
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurveArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
SymbolicCurveArrayIterator..::.MoveNext Method
SymbolicCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SymbolicCurveArrayIterator Class


Reset Method

[image]

Revit 2011 API
SymbolicCurveArrayIterator..::.Reset Method
SymbolicCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Properties

[image] [image]

Revit 2011 API
SymbolicCurveArrayIterator Properties
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


Current Property

[image]

Revit 2011 API
SymbolicCurveArrayIterator..::.Current Property
SymbolicCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SymbolicCurveArrayIterator Class


TableCellCalculatedValueData Class

[image]

Revit 2011 API
TableCellCalculatedValueData Class
Members See Also Send Feedback
The TableCellCalculatedValueData stores the data for calculated value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableCellCalculatedValueData : IDisposable
Visual Basic (Declaration)
Public Class TableCellCalculatedValueData _
    Implements IDisposable
Visual C++
public ref class TableCellCalculatedValueData : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableCellCalculatedValueData

See Also

TableCellCalculatedValueData Members


TableCellCalculatedValueData Members

[image] [image]

Revit 2011 API
TableCellCalculatedValueData Members
TableCellCalculatedValueData Class Methods See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName | Gets the name of the calculated value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCalculatedValueData Class


TableCellCalculatedValueData Methods

[image] [image]

Revit 2011 API
TableCellCalculatedValueData Methods
TableCellCalculatedValueData Class See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName | Gets the name of the calculated value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCalculatedValueData Class


Dispose Method

[image]

Revit 2011 API
TableCellCalculatedValueData..::.Dispose Method
TableCellCalculatedValueData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableCellCalculatedValueData Class


GetName Method

[image]

Revit 2011 API
TableCellCalculatedValueData..::.GetName Method
TableCellCalculatedValueData Class See Also Send Feedback
Gets the name of the calculated value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetName()
Visual Basic (Declaration)
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

TableCellCalculatedValueData Class


TableCellCombinedParameterData Class

[image]

Revit 2011 API
TableCellCombinedParameterData Class
Members See Also Send Feedback
The TableCellCombinedParameterData stores the data for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableCellCombinedParameterData : IDisposable
Visual Basic (Declaration)
Public Class TableCellCombinedParameterData _
    Implements IDisposable
Visual C++
public ref class TableCellCombinedParameterData : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableCellCombinedParameterData

See Also

TableCellCombinedParameterData Members


TableCellCombinedParameterData Members

[image] [image]

Revit 2011 API
TableCellCombinedParameterData Members
TableCellCombinedParameterData Class Methods Properties See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CategoryId | Category id for this parameter
ParamId | The parameter id
Prefix | The prefix for this parameter
SampleValue | The sample/example value for the parameter in text form
Separator | The separator for this parameter
Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Methods

[image] [image]

Revit 2011 API
TableCellCombinedParameterData Methods
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCombinedParameterData Class


Dispose Method

[image]

Revit 2011 API
TableCellCombinedParameterData..::.Dispose Method
TableCellCombinedParameterData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Properties

[image] [image]

Revit 2011 API
TableCellCombinedParameterData Properties
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Properties

Name | Description
CategoryId | Category id for this parameter
ParamId | The parameter id
Prefix | The prefix for this parameter
SampleValue | The sample/example value for the parameter in text form
Separator | The separator for this parameter
Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


CategoryId Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.CategoryId Property
TableCellCombinedParameterData Class See Also Send Feedback
Category id for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId CategoryId { get; set; }
Visual Basic (Declaration)
Public Property CategoryId As ElementId
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellCombinedParameterData Class


ParamId Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.ParamId Property
TableCellCombinedParameterData Class See Also Send Feedback
The parameter id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId ParamId { get; set; }
Visual Basic (Declaration)
Public Property ParamId As ElementId
Visual C++
public:
property ElementId^ ParamId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellCombinedParameterData Class


Prefix Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.Prefix Property
TableCellCombinedParameterData Class See Also Send Feedback
The prefix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Prefix { get; set; }
Visual Basic (Declaration)
Public Property Prefix As String
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

See Also

TableCellCombinedParameterData Class


SampleValue Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.SampleValue Property
TableCellCombinedParameterData Class See Also Send Feedback
The sample/example value for the parameter in text form

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string SampleValue { get; set; }
Visual Basic (Declaration)
Public Property SampleValue As String
Visual C++
public:
property String^ SampleValue {
    String^ get ();
    void set (String^ value);
}

See Also

TableCellCombinedParameterData Class


Separator Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.Separator Property
TableCellCombinedParameterData Class See Also Send Feedback
The separator for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Separator { get; set; }
Visual Basic (Declaration)
Public Property Separator As String
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

See Also

TableCellCombinedParameterData Class


Suffix Property

[image]

Revit 2011 API
TableCellCombinedParameterData..::.Suffix Property
TableCellCombinedParameterData Class See Also Send Feedback
The suffix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Suffix { get; set; }
Visual Basic (Declaration)
Public Property Suffix As String
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

See Also

TableCellCombinedParameterData Class


TableCellStyle Class

[image]

Revit 2011 API
TableCellStyle Class
Members See Also Send Feedback
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableCellStyle : IDisposable
Visual Basic (Declaration)
Public Class TableCellStyle _
    Implements IDisposable
Visual C++
public ref class TableCellStyle : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableCellStyle

See Also

TableCellStyle Members


TableCellStyle Members

[image] [image]

Revit 2011 API
TableCellStyle Members
TableCellStyle Class Constructors Methods Properties See Also Send Feedback

The TableCellStyle type exposes the following members.

Constructors

Name | Description
TableCellStyle | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackgroundColor | The back ground color of this cell.
BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
FontHorizontalAlignment | The horizontal alignment style of text font.
FontName | The font used for this style
FontVerticalAlignment | The vertical alignment style of text font.
IsEnabled | Gets or sets the status whether this cell is enabled.
IsFontBold | Gets or sets whether the text font is set to bold of this cell.
IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
IsReadOnly | Gets or sets whether this cell is read only.
TextColor | The text color of this cell.
TextOrientation | the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
TextSize | The text size.

See Also

TableCellStyle Class


TableCellStyle Constructor

[image] [image]

Revit 2011 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback

Overload List

Name | Description
TableCellStyle()()() | Initializes a new instance of the TableCellStyle class
TableCellStyle(TableCellStyle) | Initializes a new instance of the TableCellStyle class

See Also

TableCellStyle Class
TableCellStyle Members


TableCellStyle Constructor

[image]

Revit 2011 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback
Initializes a new instance of the TableCellStyle class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableCellStyle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableCellStyle()

See Also

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Constructor (TableCellStyle)

[image]

Revit 2011 API
TableCellStyle Constructor (TableCellStyle)
TableCellStyle Class See Also Send Feedback
Initializes a new instance of the TableCellStyle class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableCellStyle(
    TableCellStyle other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As TableCellStyle _
)
Visual C++
public:
TableCellStyle(
    TableCellStyle^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::.TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Methods

[image] [image]

Revit 2011 API
TableCellStyle Methods
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellStyle Class


Dispose Method

[image]

Revit 2011 API
TableCellStyle..::.Dispose Method
TableCellStyle Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableCellStyle Class


TableCellStyle Properties

[image] [image]

Revit 2011 API
TableCellStyle Properties
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Properties

Name | Description
BackgroundColor | The back ground color of this cell.
BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
FontHorizontalAlignment | The horizontal alignment style of text font.
FontName | The font used for this style
FontVerticalAlignment | The vertical alignment style of text font.
IsEnabled | Gets or sets the status whether this cell is enabled.
IsFontBold | Gets or sets whether the text font is set to bold of this cell.
IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
IsReadOnly | Gets or sets whether this cell is read only.
TextColor | The text color of this cell.
TextOrientation | the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
TextSize | The text size.

See Also

TableCellStyle Class


BackgroundColor Property

[image]

Revit 2011 API
TableCellStyle..::.BackgroundColor Property
TableCellStyle Class See Also Send Feedback
The back ground color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual C++
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

TableCellStyle Class


BorderBottomLineStyle Property

[image]

Revit 2011 API
TableCellStyle..::.BorderBottomLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the bottom line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderBottomLineStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderBottomLineStyle As ElementId
Visual C++
public:
property ElementId^ BorderBottomLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellStyle Class


BorderLeftLineStyle Property

[image]

Revit 2011 API
TableCellStyle..::.BorderLeftLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the left line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderLeftLineStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderLeftLineStyle As ElementId
Visual C++
public:
property ElementId^ BorderLeftLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellStyle Class


BorderRightLineStyle Property

[image]

Revit 2011 API
TableCellStyle..::.BorderRightLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the right line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderRightLineStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderRightLineStyle As ElementId
Visual C++
public:
property ElementId^ BorderRightLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellStyle Class


BorderTopLineStyle Property

[image]

Revit 2011 API
TableCellStyle..::.BorderTopLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the top line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderTopLineStyle { get; set; }
Visual Basic (Declaration)
Public Property BorderTopLineStyle As ElementId
Visual C++
public:
property ElementId^ BorderTopLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableCellStyle Class


FontHorizontalAlignment Property

[image]

Revit 2011 API
TableCellStyle..::.FontHorizontalAlignment Property
TableCellStyle Class See Also Send Feedback
The horizontal alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public HorizontalAlignmentStyle FontHorizontalAlignment { get; set; }
Visual Basic (Declaration)
Public Property FontHorizontalAlignment As HorizontalAlignmentStyle
Visual C++
public:
property HorizontalAlignmentStyle FontHorizontalAlignment {
    HorizontalAlignmentStyle get ();
    void set (HorizontalAlignmentStyle value);
}

Field Value

Alignment style.

See Also

TableCellStyle Class


FontName Property

[image]

Revit 2011 API
TableCellStyle..::.FontName Property
TableCellStyle Class See Also Send Feedback
The font used for this style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string FontName { get; set; }
Visual Basic (Declaration)
Public Property FontName As String
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}

See Also

TableCellStyle Class


FontVerticalAlignment Property

[image]

Revit 2011 API
TableCellStyle..::.FontVerticalAlignment Property
TableCellStyle Class See Also Send Feedback
The vertical alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VerticalAlignmentStyle FontVerticalAlignment { get; set; }
Visual Basic (Declaration)
Public Property FontVerticalAlignment As VerticalAlignmentStyle
Visual C++
public:
property VerticalAlignmentStyle FontVerticalAlignment {
    VerticalAlignmentStyle get ();
    void set (VerticalAlignmentStyle value);
}

Field Value

Alignment style.

See Also

TableCellStyle Class


IsEnabled Property

[image]

Revit 2011 API
TableCellStyle..::.IsEnabled Property
TableCellStyle Class See Also Send Feedback
Gets or sets the status whether this cell is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Field Value

true if this cell is enabled; otherwise false.

See Also

TableCellStyle Class


IsFontBold Property

[image]

Revit 2011 API
TableCellStyle..::.IsFontBold Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to bold of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFontBold { get; set; }
Visual Basic (Declaration)
Public Property IsFontBold As Boolean
Visual C++
public:
property bool IsFontBold {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is bold; otherwise false.

See Also

TableCellStyle Class


IsFontItalic Property

[image]

Revit 2011 API
TableCellStyle..::.IsFontItalic Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to italic of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFontItalic { get; set; }
Visual Basic (Declaration)
Public Property IsFontItalic As Boolean
Visual C++
public:
property bool IsFontItalic {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is italic; otherwise false.

See Also

TableCellStyle Class


IsFontUnderline Property

[image]

Revit 2011 API
TableCellStyle..::.IsFontUnderline Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to Underline of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFontUnderline { get; set; }
Visual Basic (Declaration)
Public Property IsFontUnderline As Boolean
Visual C++
public:
property bool IsFontUnderline {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is Underline; otherwise false.

See Also

TableCellStyle Class


IsInactivePhaseload Property

[image]

Revit 2011 API
TableCellStyle..::.IsInactivePhaseload Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether this is an inactive phase load cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInactivePhaseload { get; set; }
Visual Basic (Declaration)
Public Property IsInactivePhaseload As Boolean
Visual C++
public:
property bool IsInactivePhaseload {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is an inactive phase load cell; otherwise false.

See Also

TableCellStyle Class


IsReadOnly Property

[image]

Revit 2011 API
TableCellStyle..::.IsReadOnly Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether this cell is read only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if this cell is read only; otherwise false.

See Also

TableCellStyle Class


TextColor Property

[image]

Revit 2011 API
TableCellStyle..::.TextColor Property
TableCellStyle Class See Also Send Feedback
The text color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

TableCellStyle Class


TextOrientation Property

[image]

Revit 2011 API
TableCellStyle..::.TextOrientation Property
TableCellStyle Class See Also Send Feedback
the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TextOrientation { get; set; }
Visual Basic (Declaration)
Public Property TextOrientation As Integer
Visual C++
public:
property int TextOrientation {
    int get ();
    void set (int value);
}

See Also

TableCellStyle Class


TextSize Property

[image]

Revit 2011 API
TableCellStyle..::.TextSize Property
TableCellStyle Class See Also Send Feedback
The text size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TextSize { get; set; }
Visual Basic (Declaration)
Public Property TextSize As Double
Visual C++
public:
property double TextSize {
    double get ();
    void set (double value);
}

See Also

TableCellStyle Class


TableData Class

[image]

Revit 2011 API
TableData Class
Members See Also Send Feedback
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableData : IDisposable
Visual Basic (Declaration)
Public Class TableData _
    Implements IDisposable
Visual C++
public ref class TableData : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableData
Autodesk.Revit.DB.Electrical..::.PanelScheduleData

See Also

TableData Members


TableData Members

[image] [image]

Revit 2011 API
TableData Members
TableData Class Methods Properties See Also Send Feedback

The TableData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSectionData | Returns the section data array element at the specified index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks if this element is equal in value to the other element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NumberOfSections | Gets the number of items in section data array.
Width | Gets or sets the table width in feet
WidthInPixels | Gets the width of the panel schedule in pixels

See Also

TableData Class


TableData Methods

[image] [image]

Revit 2011 API
TableData Methods
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSectionData | Returns the section data array element at the specified index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks if this element is equal in value to the other element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableData Class


Dispose Method

[image]

Revit 2011 API
TableData..::.Dispose Method
TableData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableData Class


GetSectionData Method

[image]

Revit 2011 API
TableData..::.GetSectionData Method
TableData Class See Also Send Feedback
Returns the section data array element at the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    int nIndex
)
Visual Basic (Declaration)
Public Function GetSectionData ( _
    nIndex As Integer _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    int nIndex
)

Parameters

nIndex
Type: System..::.Int32
The index of section data array. If the index is out of the boundary of section data array, null is returned.

See Also

TableData Class


IsEqual Method

[image]

Revit 2011 API
TableData..::.IsEqual Method
TableData Class See Also Send Feedback
Checks if this element is equal in value to the other element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsEqual(
    TableData OtherElem
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    OtherElem As TableData _
) As Boolean
Visual C++
public:
bool IsEqual(
    TableData^ OtherElem
)

Parameters

OtherElem
Type: Autodesk.Revit.DB..::.TableData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableData Class


TableData Properties

[image] [image]

Revit 2011 API
TableData Properties
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Properties

Name | Description
NumberOfSections | Gets the number of items in section data array.
Width | Gets or sets the table width in feet
WidthInPixels | Gets the width of the panel schedule in pixels

See Also

TableData Class


NumberOfSections Property

[image]

Revit 2011 API
TableData..::.NumberOfSections Property
TableData Class See Also Send Feedback
Gets the number of items in section data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfSections { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSections As Integer
Visual C++
public:
property int NumberOfSections {
    int get ();
}

See Also

TableData Class


Width Property

[image]

Revit 2011 API
TableData..::.Width Property
TableData Class See Also Send Feedback
Gets or sets the table width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

TableData Class


WidthInPixels Property

[image]

Revit 2011 API
TableData..::.WidthInPixels Property
TableData Class See Also Send Feedback
Gets the width of the panel schedule in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int WidthInPixels { get; }
Visual Basic (Declaration)
Public ReadOnly Property WidthInPixels As Integer
Visual C++
public:
property int WidthInPixels {
    int get ();
}

See Also

TableData Class


TableMergedCell Class

[image]

Revit 2011 API
TableMergedCell Class
Members See Also Send Feedback
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TableMergedCell : IDisposable
Visual Basic (Declaration)
Public Class TableMergedCell _
    Implements IDisposable
Visual C++
public ref class TableMergedCell : IDisposable

Remarks

A TableMergedCell contains member variables that define the top-left and bottom-right row and column indexes of a table grid. A TableMergedCell object can be passed as a function parameter wherever a TableMergedCell can be passed.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableMergedCell

See Also

TableMergedCell Members


TableMergedCell Members

[image] [image]

Revit 2011 API
TableMergedCell Members
TableMergedCell Class Constructors Methods Properties See Also Send Feedback

The TableMergedCell type exposes the following members.

Constructors

Name | Description
TableMergedCell | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bottom | Specifies the row index of the bottom-right corner of a table grid.
Left | Specifies the column index of the top-left corner of a table grid.
Right | Specifies the column index of the bottom-right corner of a table grid.
Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


TableMergedCell Constructor

[image] [image]

Revit 2011 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback

Overload List

Name | Description
TableMergedCell()()() | Default constructor.
TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.

See Also

TableMergedCell Class
TableMergedCell Members


TableMergedCell Constructor

[image]

Revit 2011 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TableMergedCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableMergedCell()

See Also

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Constructor (Int32, Int32, Int32, Int32)

[image]

Revit 2011 API
TableMergedCell Constructor (Int32, Int32, Int32, Int32)
TableMergedCell Class See Also Send Feedback
Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
)
Visual C++
public:
TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::.Int32
Row index of the top-left of a table grid.
left
Type: System..::.Int32
Column index of the top-left of a table grid.
bottom
Type: System..::.Int32
Row index of the bottom-right of a table grid.
right
Type: System..::.Int32
Column index of the bottom-right of a table grid.

See Also

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Methods

[image] [image]

Revit 2011 API
TableMergedCell Methods
TableMergedCell Class See Also Send Feedback

The TableMergedCell type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableMergedCell Class


Dispose Method

[image]

Revit 2011 API
TableMergedCell..::.Dispose Method
TableMergedCell Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableMergedCell Class


TableMergedCell Properties

[image] [image]

Revit 2011 API
TableMergedCell Properties
TableMergedCell Class See Also Send Feedback

The TableMergedCell type exposes the following members.

Properties

Name | Description
Bottom | Specifies the row index of the bottom-right corner of a table grid.
Left | Specifies the column index of the top-left corner of a table grid.
Right | Specifies the column index of the bottom-right corner of a table grid.
Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


Bottom Property

[image]

Revit 2011 API
TableMergedCell..::.Bottom Property
TableMergedCell Class See Also Send Feedback
Specifies the row index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Integer
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Left Property

[image]

Revit 2011 API
TableMergedCell..::.Left Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Right Property

[image]

Revit 2011 API
TableMergedCell..::.Right Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Integer
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Top Property

[image]

Revit 2011 API
TableMergedCell..::.Top Property
TableMergedCell Class See Also Send Feedback
Specifies the row index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


TableSectionData Class

[image]

Revit 2011 API
TableSectionData Class
Members See Also Send Feedback
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableSectionData : IDisposable
Visual Basic (Declaration)
Public Class TableSectionData _
    Implements IDisposable
Visual C++
public ref class TableSectionData : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableSectionData

See Also

TableSectionData Members


TableSectionData Members

[image] [image]

Revit 2011 API
TableSectionData Members
TableSectionData Class Methods Properties See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellCalculatedValue | Overloaded.
GetCellCategoryId | Overloaded.
GetCellCombinedParameters | Overloaded.
GetCellParamId | Overloaded.
GetCellText | Returns a cell's text depending on its type
GetCellType | Overloaded.
GetColumnWidth | Returns a column's width
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMergedCell | Gets the whole merged cell that this cell is a part of.
GetRowHeight | Returns a row's height
GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
GetType | Gets the Type of the current instance. (Inherited from Object.)
MergeCells | Merges cells for the given area.
SetCellCalculatedValue | Overloaded.
SetCellCombinedParameters | Overloaded.
SetCellParamIdAndCategoryId | Overloaded.
SetCellStyle | Overloaded.
SetCellText | Sets a cell's style
SetCellType | Overloaded.
SetColumnWidth | Sets a column's width
SetMergedCell | Sets the merged cell that this cell is a part of.
SetRowHeight | Sets a row's height
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HideSection |
NeedsRefresh |
NumberOfColumns | Gets or sets the number of items in column data array.
NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


TableSectionData Methods

[image] [image]

Revit 2011 API
TableSectionData Methods
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellCalculatedValue | Overloaded.
GetCellCategoryId | Overloaded.
GetCellCombinedParameters | Overloaded.
GetCellParamId | Overloaded.
GetCellText | Returns a cell's text depending on its type
GetCellType | Overloaded.
GetColumnWidth | Returns a column's width
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMergedCell | Gets the whole merged cell that this cell is a part of.
GetRowHeight | Returns a row's height
GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
GetType | Gets the Type of the current instance. (Inherited from Object.)
MergeCells | Merges cells for the given area.
SetCellCalculatedValue | Overloaded.
SetCellCombinedParameters | Overloaded.
SetCellParamIdAndCategoryId | Overloaded.
SetCellStyle | Overloaded.
SetCellText | Sets a cell's style
SetCellType | Overloaded.
SetColumnWidth | Sets a column's width
SetMergedCell | Sets the merged cell that this cell is a part of.
SetRowHeight | Sets a row's height
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableSectionData Class


Dispose Method

[image]

Revit 2011 API
TableSectionData..::.Dispose Method
TableSectionData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TableSectionData Class


GetCellCalculatedValue Method

[image] [image]

Revit 2011 API
TableSectionData..::.GetCellCalculatedValue Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCalculatedValue Method (Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCalculatedValue Method (Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCalculatedValue ( _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCalculatedValue Method (Int32, Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCalculatedValue Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCategoryId Method

[image] [image]

Revit 2011 API
TableSectionData..::.GetCellCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

See Also

TableSectionData Class
TableSectionData Members


GetCellCategoryId Method (Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCategoryId Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's ParamId Associated with the paramId to find the correct element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetCellCategoryId(
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCategoryId ( _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCategoryId Method (Int32, Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCategoryId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetCellCategoryId(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCategoryId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCombinedParameters Method

[image] [image]

Revit 2011 API
TableSectionData..::.GetCellCombinedParameters Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCombinedParameters Method (Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCombinedParameters Method (Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCombinedParameters ( _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellCombinedParameters Method (Int32, Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellCombinedParameters Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellParamId Method

[image] [image]

Revit 2011 API
TableSectionData..::.GetCellParamId Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
GetCellParamId(Int32) | Returns a column's ParamId
GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

See Also

TableSectionData Class
TableSectionData Members


GetCellParamId Method (Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellParamId Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's ParamId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetCellParamId(
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellParamId ( _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellParamId(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellParamId Overload


GetCellParamId Method (Int32, Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellParamId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetCellParamId(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellParamId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellParamId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellParamId Overload


GetCellText Method

[image]

Revit 2011 API
TableSectionData..::.GetCellText Method
TableSectionData Class See Also Send Feedback
Returns a cell's text depending on its type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetCellText(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellText ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class


GetCellType Method

[image] [image]

Revit 2011 API
TableSectionData..::.GetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
GetCellType(Int32) | Returns a columns's cell type and if no type exists for this column, it would come from the section
GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

See Also

TableSectionData Class
TableSectionData Members


GetCellType Method (Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellType Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a columns's cell type and if no type exists for this column, it would come from the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CellType GetCellType(
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellType ( _
    nCol As Integer _
) As CellType
Visual C++
public:
CellType GetCellType(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellType Overload


GetCellType Method (Int32, Int32)

[image]

Revit 2011 API
TableSectionData..::.GetCellType Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CellType GetCellType(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellType ( _
    nRow As Integer, _
    nCol As Integer _
) As CellType
Visual C++
public:
CellType GetCellType(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class
GetCellType Overload


GetColumnWidth Method

[image]

Revit 2011 API
TableSectionData..::.GetColumnWidth Method
TableSectionData Class See Also Send Feedback
Returns a column's width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetColumnWidth(
    int nCol
)
Visual Basic (Declaration)
Public Function GetColumnWidth ( _
    nCol As Integer _
) As Integer
Visual C++
public:
int GetColumnWidth(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

TableSectionData Class


GetMergedCell Method

[image]

Revit 2011 API
TableSectionData..::.GetMergedCell Method
TableSectionData Class See Also Send Feedback
Gets the whole merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableMergedCell GetMergedCell(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetMergedCell ( _
    nRow As Integer, _
    nCol As Integer _
) As TableMergedCell
Visual C++
public:
TableMergedCell^ GetMergedCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class


GetRowHeight Method

[image]

Revit 2011 API
TableSectionData..::.GetRowHeight Method
TableSectionData Class See Also Send Feedback
Returns a row's height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetRowHeight(
    int nRow
)
Visual Basic (Declaration)
Public Function GetRowHeight ( _
    nRow As Integer _
) As Integer
Visual C++
public:
int GetRowHeight(
    int nRow
)

Parameters

nRow
Type: System..::.Int32

See Also

TableSectionData Class


GetTableCellStyle Method

[image]

Revit 2011 API
TableSectionData..::.GetTableCellStyle Method
TableSectionData Class See Also Send Feedback
Returns a cell's style and if no style exists for this cell, it would come from the column, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableCellStyle GetTableCellStyle(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetTableCellStyle ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellStyle
Visual C++
public:
TableCellStyle^ GetTableCellStyle(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableSectionData Class


MergeCells Method

[image]

Revit 2011 API
TableSectionData..::.MergeCells Method
TableSectionData Class See Also Send Feedback
Merges cells for the given area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void MergeCells(
    TableMergedCell mergedCell
)
Visual Basic (Declaration)
Public Sub MergeCells ( _
    mergedCell As TableMergedCell _
)
Visual C++
public:
void MergeCells(
    TableMergedCell^ mergedCell
)

Parameters

mergedCell
Type: Autodesk.Revit.DB..::.TableMergedCell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetCellCalculatedValue Method

[image] [image]

Revit 2011 API
TableSectionData..::.SetCellCalculatedValue Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell

See Also

TableSectionData Class
TableSectionData Members


SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)

[image]

Revit 2011 API
TableSectionData..::.SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic (Declaration)
Public Sub SetCellCalculatedValue ( _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nCol
Type: System..::.Int32
pCalcValue
Type: Autodesk.Revit.DB..::.TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)

[image]

Revit 2011 API
TableSectionData..::.SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic (Declaration)
Public Sub SetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
pCalcValue
Type: Autodesk.Revit.DB..::.TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCombinedParameters Method

[image] [image]

Revit 2011 API
TableSectionData..::.SetCellCombinedParameters Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
SetCellCombinedParameters(Int32, IList<(Of <(TableCellCombinedParameterData>)>)) | Allows the caller to set combined parameter for a specified column
SetCellCombinedParameters(Int32, Int32, IList<(Of <(TableCellCombinedParameterData>)>)) | Allows the caller to set combined parameter for a specified cell

See Also

TableSectionData Class
TableSectionData Members


SetCellCombinedParameters Method (Int32, IList(TableCellCombinedParameterData))

[image]

Revit 2011 API
TableSectionData..::.SetCellCombinedParameters Method (Int32, IList<(Of <(TableCellCombinedParameterData>)>))
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic (Declaration)
Public Sub SetCellCombinedParameters ( _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nCol
Type: System..::.Int32
paramData
Type: System.Collections.Generic..::.IList <(Of <( TableCellCombinedParameterData >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCombinedParameters Overload


SetCellCombinedParameters Method (Int32, Int32, IList(TableCellCombinedParameterData))

[image]

Revit 2011 API
TableSectionData..::.SetCellCombinedParameters Method (Int32, Int32, IList<(Of <(TableCellCombinedParameterData>)>))
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic (Declaration)
Public Sub SetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
paramData
Type: System.Collections.Generic..::.IList <(Of <( TableCellCombinedParameterData >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCombinedParameters Overload


SetCellParamIdAndCategoryId Method

[image] [image]

Revit 2011 API
TableSectionData..::.SetCellParamIdAndCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id

See Also

TableSectionData Class
TableSectionData Members


SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)

[image]

Revit 2011 API
TableSectionData..::.SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic (Declaration)
Public Sub SetCellParamIdAndCategoryId ( _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nCol
Type: System..::.Int32
paramId
Type: Autodesk.Revit.DB..::.ElementId
categoryId
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)

[image]

Revit 2011 API
TableSectionData..::.SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic (Declaration)
Public Sub SetCellParamIdAndCategoryId ( _
    nRow As Integer, _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
paramId
Type: Autodesk.Revit.DB..::.ElementId
categoryId
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellStyle Method

[image] [image]

Revit 2011 API
TableSectionData..::.SetCellStyle Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
SetCellStyle(TableCellStyle) | Sets a section's style
SetCellStyle(Int32, TableCellStyle) | Sets a columns's style
SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style

See Also

TableSectionData Class
TableSectionData Members


SetCellStyle Method (TableCellStyle)

[image]

Revit 2011 API
TableSectionData..::.SetCellStyle Method (TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a section's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellStyle(
    TableCellStyle Style
)
Visual Basic (Declaration)
Public Sub SetCellStyle ( _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    TableCellStyle^ Style
)

Parameters

Style
Type: Autodesk.Revit.DB..::.TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, TableCellStyle)

[image]

Revit 2011 API
TableSectionData..::.SetCellStyle Method (Int32, TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a columns's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellStyle(
    int nCol,
    TableCellStyle Style
)
Visual Basic (Declaration)
Public Sub SetCellStyle ( _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nCol,
    TableCellStyle^ Style
)

Parameters

nCol
Type: System..::.Int32
Style
Type: Autodesk.Revit.DB..::.TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, Int32, TableCellStyle)

[image]

Revit 2011 API
TableSectionData..::.SetCellStyle Method (Int32, Int32, TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle Style
)
Visual Basic (Declaration)
Public Sub SetCellStyle ( _
    nRow As Integer, _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle^ Style
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
Style
Type: Autodesk.Revit.DB..::.TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellText Method

[image]

Revit 2011 API
TableSectionData..::.SetCellText Method
TableSectionData Class See Also Send Feedback
Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellText(
    int nRow,
    int nCol,
    string text
)
Visual Basic (Declaration)
Public Sub SetCellText ( _
    nRow As Integer, _
    nCol As Integer, _
    text As String _
)
Visual C++
public:
void SetCellText(
    int nRow,
    int nCol,
    String^ text
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
text
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetCellType Method

[image] [image]

Revit 2011 API
TableSectionData..::.SetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

Name | Description
SetCellType(Int32, CellType) | Sets a columns's cell type
SetCellType(Int32, Int32, CellType) | Sets a cell's Type

See Also

TableSectionData Class
TableSectionData Members


SetCellType Method (Int32, CellType)

[image]

Revit 2011 API
TableSectionData..::.SetCellType Method (Int32, CellType)
TableSectionData Class See Also Send Feedback
Sets a columns's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellType(
    int nCol,
    CellType type
)
Visual Basic (Declaration)
Public Sub SetCellType ( _
    nCol As Integer, _
    type As CellType _
)
Visual C++
public:
void SetCellType(
    int nCol,
    CellType type
)

Parameters

nCol
Type: System..::.Int32
type
Type: Autodesk.Revit.DB..::.CellType

See Also

TableSectionData Class
SetCellType Overload


SetCellType Method (Int32, Int32, CellType)

[image]

Revit 2011 API
TableSectionData..::.SetCellType Method (Int32, Int32, CellType)
TableSectionData Class See Also Send Feedback
Sets a cell's Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetCellType(
    int nRow,
    int nCol,
    CellType type
)
Visual Basic (Declaration)
Public Sub SetCellType ( _
    nRow As Integer, _
    nCol As Integer, _
    type As CellType _
)
Visual C++
public:
void SetCellType(
    int nRow,
    int nCol,
    CellType type
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
type
Type: Autodesk.Revit.DB..::.CellType

See Also

TableSectionData Class
SetCellType Overload


SetColumnWidth Method

[image]

Revit 2011 API
TableSectionData..::.SetColumnWidth Method
TableSectionData Class See Also Send Feedback
Sets a column's width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetColumnWidth(
    int nCol,
    int width
)
Visual Basic (Declaration)
Public Sub SetColumnWidth ( _
    nCol As Integer, _
    width As Integer _
)
Visual C++
public:
void SetColumnWidth(
    int nCol,
    int width
)

Parameters

nCol
Type: System..::.Int32
width
Type: System..::.Int32

See Also

TableSectionData Class


SetMergedCell Method

[image]

Revit 2011 API
TableSectionData..::.SetMergedCell Method
TableSectionData Class See Also Send Feedback
Sets the merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell mergedCell
)
Visual Basic (Declaration)
Public Sub SetMergedCell ( _
    nRow As Integer, _
    nCol As Integer, _
    mergedCell As TableMergedCell _
)
Visual C++
public:
void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell^ mergedCell
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
mergedCell
Type: Autodesk.Revit.DB..::.TableMergedCell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetRowHeight Method

[image]

Revit 2011 API
TableSectionData..::.SetRowHeight Method
TableSectionData Class See Also Send Feedback
Sets a row's height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetRowHeight(
    int nRow,
    int height
)
Visual Basic (Declaration)
Public Sub SetRowHeight ( _
    nRow As Integer, _
    height As Integer _
)
Visual C++
public:
void SetRowHeight(
    int nRow,
    int height
)

Parameters

nRow
Type: System..::.Int32
height
Type: System..::.Int32

See Also

TableSectionData Class


TableSectionData Properties

[image] [image]

Revit 2011 API
TableSectionData Properties
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Properties

Name | Description
HideSection |
NeedsRefresh |
NumberOfColumns | Gets or sets the number of items in column data array.
NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


HideSection Property

[image]

Revit 2011 API
TableSectionData..::.HideSection Property
TableSectionData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HideSection { get; set; }
Visual Basic (Declaration)
Public Property HideSection As Boolean
Visual C++
public:
property bool HideSection {
    bool get ();
    void set (bool value);
}

See Also

TableSectionData Class


NeedsRefresh Property

[image]

Revit 2011 API
TableSectionData..::.NeedsRefresh Property
TableSectionData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool NeedsRefresh { get; set; }
Visual Basic (Declaration)
Public Property NeedsRefresh As Boolean
Visual C++
public:
property bool NeedsRefresh {
    bool get ();
    void set (bool value);
}

See Also

TableSectionData Class


NumberOfColumns Property

[image]

Revit 2011 API
TableSectionData..::.NumberOfColumns Property
TableSectionData Class See Also Send Feedback
Gets or sets the number of items in column data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfColumns { get; set; }
Visual Basic (Declaration)
Public Property NumberOfColumns As Integer
Visual C++
public:
property int NumberOfColumns {
    int get ();
    void set (int value);
}

See Also

TableSectionData Class


NumberOfRows Property

[image]

Revit 2011 API
TableSectionData..::.NumberOfRows Property
TableSectionData Class See Also Send Feedback
Gets or sets the number of items in row data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfRows { get; set; }
Visual Basic (Declaration)
Public Property NumberOfRows As Integer
Visual C++
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}

See Also

TableSectionData Class


TableView Class

[image]

Revit 2011 API
TableView Class
Members See Also Send Feedback
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TableView : View
Visual Basic (Declaration)
Public Class TableView _
    Inherits View
Visual C++
public ref class TableView : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.TableView
Autodesk.Revit.DB.Electrical..::.PanelScheduleView

See Also

TableView Members


TableView Members

[image] [image]

Revit 2011 API
TableView Members
TableView Class Methods Properties See Also Send Feedback

The TableView type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetAvailableParameterCategories | Get all available parameter categories.
GetAvailableParameters | Get available parameters for the specified category.
GetCalculatedValueName | Returns the calculated value name for template view
GetCalculatedValueText | Returns the calculated value text for instance view
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam |
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumColumnWidth | Gets the minimum column width
MinimumRowHeight | Gets the minimum row height
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
TargetId | the element id of the element that is being viewed
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

TableView Class


TableView Methods

[image] [image]

Revit 2011 API
TableView Methods
TableView Class See Also Send Feedback

The TableView type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetAvailableParameterCategories | Get all available parameter categories.
GetAvailableParameters | Get available parameters for the specified category.
GetCalculatedValueName | Returns the calculated value name for template view
GetCalculatedValueText | Returns the calculated value text for instance view
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam |
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

TableView Class


GetAvailableParameterCategories Method

[image]

Revit 2011 API
TableView..::.GetAvailableParameterCategories Method
TableView Class See Also Send Feedback
Get all available parameter categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<ElementId> GetAvailableParameterCategories(
    SectionType typeSection,
    int nLogRow
)
Visual Basic (Declaration)
Public Function GetAvailableParameterCategories ( _
    typeSection As SectionType, _
    nLogRow As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameterCategories(
    SectionType typeSection,
    int nLogRow
)

Parameters

typeSection
Type: Autodesk.Revit.DB..::.SectionType
nLogRow
Type: System..::.Int32

See Also

TableView Class


GetAvailableParameters Method

[image]

Revit 2011 API
TableView..::.GetAvailableParameters Method
TableView Class See Also Send Feedback
Get available parameters for the specified category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<ElementId> GetAvailableParameters(
    int categoryId
)
Visual Basic (Declaration)
Public Function GetAvailableParameters ( _
    categoryId As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameters(
    int categoryId
)

Parameters

categoryId
Type: System..::.Int32

See Also

TableView Class


GetCalculatedValueName Method

[image]

Revit 2011 API
TableView..::.GetCalculatedValueName Method
TableView Class See Also Send Feedback
Returns the calculated value name for template view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetCalculatedValueName(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCalculatedValueName ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueName(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableView Class


GetCalculatedValueText Method

[image]

Revit 2011 API
TableView..::.GetCalculatedValueText Method
TableView Class See Also Send Feedback
Returns the calculated value text for instance view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetCalculatedValueText(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCalculatedValueText ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueText(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableView Class


IsOkToEditParam Method

[image]

Revit 2011 API
TableView..::.IsOkToEditParam Method
TableView Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsOkToEditParam(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsOkToEditParam ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsOkToEditParam(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

TableView Class


Print Method

[image] [image]

Revit 2011 API
TableView..::.Print Method
TableView Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

TableView Class
TableView Members


TableView Properties

[image] [image]

Revit 2011 API
TableView Properties
TableView Class See Also Send Feedback

The TableView type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumColumnWidth | Gets the minimum column width
MinimumRowHeight | Gets the minimum row height
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
TargetId | the element id of the element that is being viewed
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

TableView Class


MinimumColumnWidth Property

[image]

Revit 2011 API
TableView..::.MinimumColumnWidth Property
TableView Class See Also Send Feedback
Gets the minimum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int MinimumColumnWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimumColumnWidth As Integer
Visual C++
public:
property int MinimumColumnWidth {
    int get ();
}

See Also

TableView Class


MinimumRowHeight Property

[image]

Revit 2011 API
TableView..::.MinimumRowHeight Property
TableView Class See Also Send Feedback
Gets the minimum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int MinimumRowHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinimumRowHeight As Integer
Visual C++
public:
property int MinimumRowHeight {
    int get ();
}

See Also

TableView Class


Parameter Property

[image] [image]

Revit 2011 API
TableView..::.Parameter Property
TableView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TableView Class
TableView Members


TargetId Property

[image]

Revit 2011 API
TableView..::.TargetId Property
TableView Class See Also Send Feedback
the element id of the element that is being viewed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId TargetId { get; set; }
Visual Basic (Declaration)
Public Property TargetId As ElementId
Visual C++
public:
property ElementId^ TargetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TableView Class


TagMode Enumeration

[image]

Revit 2011 API
TagMode Enumeration
See Also Send Feedback
An enumerated type listing Tag Mode when user adding tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TagMode
Visual Basic (Declaration)
Public Enumeration TagMode
Visual C++
public enum class TagMode

Members

Member name | Description
TM_ADDBY_CATEGORY | The Tag you add by Category.
TM_ADDBY_MULTICATEGORY | The Tag you add by Multi-Category.
TM_ADDBY_MATERIAL | The Tag you add by Material.

See Also


TagOrientation Enumeration

[image]

Revit 2011 API
TagOrientation Enumeration
See Also Send Feedback
An enumerated type listing Tag Orientation of the Independent Tag that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TagOrientation
Visual Basic (Declaration)
Public Enumeration TagOrientation
Visual C++
public enum class TagOrientation

Members

Member name | Description
TAG_HORIZONTAL | The Orientation of tag is Horizontal.
TAG_VERTICAL | The Orientation of tag is Vertical.

See Also


TextAlignFlags Enumeration

[image]

Revit 2011 API
TextAlignFlags Enumeration
See Also Send Feedback
An enumerated type listing all the Text align flags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TextAlignFlags
Visual Basic (Declaration)
Public Enumeration TextAlignFlags
Visual C++
public enum class TextAlignFlags

Members

Member name | Description
TEF_ALIGN_LEFT | Align text left
TEF_ALIGN_CENTER | Align text center
TEF_ALIGN_RIGHT | Align text right
TEF_ALIGN_TOP | Align text top
TEF_ALIGN_MIDDLE | Align text middle
TEF_ALIGN_BOTTOM | Align text bottom

See Also


TextAlignMask Enumeration

[image]

Revit 2011 API
TextAlignMask Enumeration
See Also Send Feedback
An enumerated type listing all the Text align mask.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TextAlignMask
Visual Basic (Declaration)
Public Enumeration TextAlignMask
Visual C++
public enum class TextAlignMask

Members

Member name | Description
horzAlignMask | The mask of the Text object being aligned in the horizontal direction.
vertAlignMask | The mask of the Text object being aligned in the vertical direction.

See Also


TextElement Class

[image]

Revit 2011 API
TextElement Class
Members See Also Send Feedback
Represents the TextElment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextElement : Element
Visual Basic (Declaration)
Public Class TextElement _
    Inherits Element
Visual C++
public ref class TextElement : public Element

Remarks

This class can be parent class of TextNote and other Text related classes.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.TextElement
Autodesk.Revit.DB..::.TextNote

See Also

TextElement Members


TextElement Members

[image] [image]

Revit 2011 API
TextElement Members
TextElement Class Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object.
Text | Get and set the content of the TextElement object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextElement Class


TextElement Methods

[image] [image]

Revit 2011 API
TextElement Methods
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElement Class


TextElement Properties

[image] [image]

Revit 2011 API
TextElement Properties
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object.
Text | Get and set the content of the TextElement object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextElement Class


Parameter Property

[image] [image]

Revit 2011 API
TextElement..::.Parameter Property
TextElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextElement Class
TextElement Members


Symbol Property

[image]

Revit 2011 API
TextElement..::.Symbol Property
TextElement Class See Also Send Feedback
Get the type of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextElementType Symbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbol As TextElementType
Visual C++
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}

Remarks

The user can call this property to get the related type.

See Also

TextElement Class


Text Property

[image]

Revit 2011 API
TextElement..::.Text Property
TextElement Class See Also Send Feedback
Get and set the content of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

The content of TextElement object can also be accessed through the Built-In parameter TEXT_TEXT.

See Also

TextElement Class


TextElementBackground Enumeration

[image]

Revit 2011 API
TextElementBackground Enumeration
See Also Send Feedback
An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TextElementBackground
Visual Basic (Declaration)
Public Enumeration TextElementBackground
Visual C++
public enum class TextElementBackground

Members

Member name | Description
TBGR_OPAQUE | The TextElement object is opaque.
TBGR_TRANSPARENT | The TextElement object is transparent.

See Also


TextElementType Class

[image]

Revit 2011 API
TextElementType Class
Members See Also Send Feedback
An object that represents a text style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextElementType : LineAndTextAttrSymbol
Visual Basic (Declaration)
Public Class TextElementType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class TextElementType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB..::.TextElementType
Autodesk.Revit.DB..::.TextNoteType

See Also

TextElementType Members


TextElementType Members

[image] [image]

Revit 2011 API
TextElementType Members
TextElementType Class Methods Properties See Also Send Feedback

The TextElementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextElementType Class


TextElementType Methods

[image] [image]

Revit 2011 API
TextElementType Methods
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElementType Class


TextElementType Properties

[image] [image]

Revit 2011 API
TextElementType Properties
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextElementType Class


Parameter Property

[image] [image]

Revit 2011 API
TextElementType..::.Parameter Property
TextElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextElementType Class
TextElementType Members


TextNote Class

[image]

Revit 2011 API
TextNote Class
Members See Also Send Feedback
Provides access to the TextNote object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextNote : TextElement
Visual Basic (Declaration)
Public Class TextNote _
    Inherits TextElement
Visual C++
public ref class TextNote : public TextElement

Remarks

The user can create TextNote object and change the internal property as Leaders and so on.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.TextElement
Autodesk.Revit.DB..::.TextNote

See Also

TextNote Members


TextNote Members

[image] [image]

Revit 2011 API
TextNote Members
TextNote Class Methods Properties See Also Send Feedback

The TextNote type exposes the following members.

Methods

Name | Description
AddLeader | Add a leader for the current TextNote object and return the new leader.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveLeaders | Remove all the leaders for the current TextNote object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Coord | Access the position of the TextNote object.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Leaders | Retrieves all the leaders belongs to the current TextNote object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
TextNoteType | Access the type of the TextNote object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | Access the width of the TextNote object.

See Also

TextNote Class


TextNote Methods

[image] [image]

Revit 2011 API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

Name | Description
AddLeader | Add a leader for the current TextNote object and return the new leader.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveLeaders | Remove all the leaders for the current TextNote object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNote Class


AddLeader Method

[image]

Revit 2011 API
TextNote..::.AddLeader Method
TextNote Class See Also Send Feedback
Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic (Declaration)
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes
)

Parameters

Type: Autodesk.Revit.DB..::.TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

TextNote Class


RemoveLeaders Method

[image]

Revit 2011 API
TextNote..::.RemoveLeaders Method
TextNote Class See Also Send Feedback
Remove all the leaders for the current TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveLeaders()
Visual Basic (Declaration)
Public Sub RemoveLeaders
Visual C++
public:
void RemoveLeaders()

Remarks

It is different to the method AddLeader, in which one Leader is added. Calling this method will remove all the leaders.

See Also

TextNote Class


TextNote Properties

[image] [image]

Revit 2011 API
TextNote Properties
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Coord | Access the position of the TextNote object.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Leaders | Retrieves all the leaders belongs to the current TextNote object.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
TextNoteType | Access the type of the TextNote object.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | Access the width of the TextNote object.

See Also

TextNote Class


Coord Property

[image]

Revit 2011 API
TextNote..::.Coord Property
TextNote Class See Also Send Feedback
Access the position of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Coord { get; set; }
Visual Basic (Declaration)
Public Property Coord As XYZ
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

With this method, the position of the TextNote object can be retrieved and changed.

See Also

TextNote Class


Leaders Property

[image]

Revit 2011 API
TextNote..::.Leaders Property
TextNote Class See Also Send Feedback
Retrieves all the leaders belongs to the current TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property Leaders As LeaderArray
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Remarks

This property is ReadOnly.

See Also

TextNote Class


Parameter Property

[image] [image]

Revit 2011 API
TextNote..::.Parameter Property
TextNote Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextNote Class
TextNote Members


TextNoteType Property

[image]

Revit 2011 API
TextNote..::.TextNoteType Property
TextNote Class See Also Send Feedback
Access the type of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteType TextNoteType { get; set; }
Visual Basic (Declaration)
Public Property TextNoteType As TextNoteType
Visual C++
public:
property TextNoteType^ TextNoteType {
    TextNoteType^ get ();
    void set (TextNoteType^ value);
}

Remarks

The type of the TextNote object can be retrieved or changed.

See Also

TextNote Class


Width Property

[image]

Revit 2011 API
TextNote..::.Width Property
TextNote Class See Also Send Feedback
Access the width of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

With this method, the width of the TextNote object can be retrieved and changed. The set method will calculate the real width of the TextNote. If the requested width is less than the real width, the real width will be set instead of the requested width.

See Also

TextNote Class


TextNoteLeaderStyles Enumeration

[image]

Revit 2011 API
TextNoteLeaderStyles Enumeration
See Also Send Feedback
An enumerated type listing all the Leader styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TextNoteLeaderStyles
Visual Basic (Declaration)
Public Enumeration TextNoteLeaderStyles
Visual C++
public enum class TextNoteLeaderStyles

Members

Member name | Description
LCS_NONE | No leader.
LCS_ONE_SEG_LINE | The leader only includes one line segment.
LCS_ONE_SEG_ARC | The leader is an arc.
LCS_TWO_SEG_LINE | The leader include two line segments.

See Also


TextNoteLeaderTypes Enumeration

[image]

Revit 2011 API
TextNoteLeaderTypes Enumeration
See Also Send Feedback
An enumerated type listing all the Leader types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TextNoteLeaderTypes
Visual Basic (Declaration)
Public Enumeration TextNoteLeaderTypes
Visual C++
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_STRAIGHT_L | The leader is put at the left of the Text object and in the straight style.
TNLT_STRAIGHT_R | The leader is put at the right of the Text object and in the straight style.
TNLT_ARC_L | The leader is put at the left of the Text object and in the arc style.
TNLT_ARC_R | The leader is put at the right of the Text object and in the arc style.

See Also


TextNoteType Class

[image]

Revit 2011 API
TextNoteType Class
Members See Also Send Feedback
An object that represents a text note style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextNoteType : TextElementType
Visual Basic (Declaration)
Public Class TextNoteType _
    Inherits TextElementType
Visual C++
public ref class TextNoteType : public TextElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.LineAndTextAttrSymbol
Autodesk.Revit.DB..::.TextElementType
Autodesk.Revit.DB..::.TextNoteType

See Also

TextNoteType Members


TextNoteType Members

[image] [image]

Revit 2011 API
TextNoteType Members
TextNoteType Class Methods Properties See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextNoteType Class


TextNoteType Methods

[image] [image]

Revit 2011 API
TextNoteType Methods
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteType Class


TextNoteType Properties

[image] [image]

Revit 2011 API
TextNoteType Properties
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TextNoteType Class


Parameter Property

[image] [image]

Revit 2011 API
TextNoteType..::.Parameter Property
TextNoteType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TextNoteType Class
TextNoteType Members


TextNoteTypeSet Class

[image]

Revit 2011 API
TextNoteTypeSet Class
Members See Also Send Feedback
A set that contains textnote types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextNoteTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TextNoteTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TextNoteTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.TextNoteTypeSet

See Also

TextNoteTypeSet Members


TextNoteTypeSet Members

[image] [image]

Revit 2011 API
TextNoteTypeSet Members
TextNoteTypeSet Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Constructors

Name | Description
TextNoteTypeSet | Initializes a new instance of the TextNoteTypeSet class

Methods

Name | Description
Clear | Removes every textnote type from the set, rendering it empty.
Contains | Tests for the existence of a textnote type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified textnote type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified textnote type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class


TextNoteTypeSet Constructor

[image]

Revit 2011 API
TextNoteTypeSet Constructor
TextNoteTypeSet Class See Also Send Feedback
Initializes a new instance of the TextNoteTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSet()

See Also

TextNoteTypeSet Class


TextNoteTypeSet Methods

[image] [image]

Revit 2011 API
TextNoteTypeSet Methods
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every textnote type from the set, rendering it empty.
Contains | Tests for the existence of a textnote type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified textnote type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified textnote type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSet Class


Clear Method

[image]

Revit 2011 API
TextNoteTypeSet..::.Clear Method
TextNoteTypeSet Class See Also Send Feedback
Removes every textnote type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TextNoteTypeSet Class


Contains Method

[image]

Revit 2011 API
TextNoteTypeSet..::.Contains Method
TextNoteTypeSet Class See Also Send Feedback
Tests for the existence of a textnote type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.TextNoteType
The textnote type to be searched for.

Return Value

The Contains method returns True if the textnote type is within the set, otherwise False.

See Also

TextNoteTypeSet Class


Erase Method

[image]

Revit 2011 API
TextNoteTypeSet..::.Erase Method
TextNoteTypeSet Class See Also Send Feedback
Removes a specified textnote type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TextNoteType _
) As Integer
Visual C++
public:
virtual int Erase(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.TextNoteType
The textnote type to be erased.

Return Value

The number of textnote types that were erased from the set.

See Also

TextNoteTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
TextNoteTypeSet..::.ForwardIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TextNoteTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
TextNoteTypeSet..::.GetEnumerator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TextNoteTypeSet Class


Insert Method

[image]

Revit 2011 API
TextNoteTypeSet..::.Insert Method
TextNoteTypeSet Class See Also Send Feedback
Insert the specified textnote type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    TextNoteType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.TextNoteType
The textnote type to be inserted into the set.

Return Value

Returns whether the textnote type was inserted into the set.

See Also

TextNoteTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
TextNoteTypeSet..::.ReverseIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TextNoteTypeSet Class


TextNoteTypeSet Properties

[image] [image]

Revit 2011 API
TextNoteTypeSet Properties
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
TextNoteTypeSet..::.IsEmpty Property
TextNoteTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TextNoteTypeSet Class


Size Property

[image]

Revit 2011 API
TextNoteTypeSet..::.Size Property
TextNoteTypeSet Class See Also Send Feedback
Returns the number of textnote types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TextNoteTypeSet Class


TextNoteTypeSetIterator Class

[image]

Revit 2011 API
TextNoteTypeSetIterator Class
Members See Also Send Feedback
An iterator to a textnote type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class TextNoteTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TextNoteTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TextNoteTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.TextNoteTypeSetIterator

See Also

TextNoteTypeSetIterator Members


TextNoteTypeSetIterator Members

[image] [image]

Revit 2011 API
TextNoteTypeSetIterator Members
TextNoteTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Constructors

Name | Description
TextNoteTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Constructor

[image]

Revit 2011 API
TextNoteTypeSetIterator Constructor
TextNoteTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TextNoteTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextNoteTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Methods

[image] [image]

Revit 2011 API
TextNoteTypeSetIterator Methods
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
TextNoteTypeSetIterator..::.MoveNext Method
TextNoteTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
TextNoteTypeSetIterator..::.Reset Method
TextNoteTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Properties

[image] [image]

Revit 2011 API
TextNoteTypeSetIterator Properties
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class


Current Property

[image]

Revit 2011 API
TextNoteTypeSetIterator..::.Current Property
TextNoteTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class


TilePattern Class

[image]

Revit 2011 API
TilePattern Class
Members See Also Send Feedback
An object representing a tile pattern that may be applied to a DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TilePattern : ElementType
Visual Basic (Declaration)
Public Class TilePattern _
    Inherits ElementType
Visual C++
public ref class TilePattern : public ElementType

Remarks

TilePatterns cannot be created. A fixed selection is built into each Conceptual Mass family. TilePatterns can be retrieved by key from the Revit::DB::Document::Settings::TilePatternTable object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.TilePattern

See Also

TilePattern Members


TilePattern Members

[image] [image]

Revit 2011 API
TilePattern Members
TilePattern Class Methods Properties See Also Send Feedback

The TilePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TilePatternType | The built-in system tile pattern specified by this object.
TilesPerSeedNode | Get the number of tiles located at each seed node.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TilePattern Class


TilePattern Methods

[image] [image]

Revit 2011 API
TilePattern Methods
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePattern Class


TilePattern Properties

[image] [image]

Revit 2011 API
TilePattern Properties
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TilePatternType | The built-in system tile pattern specified by this object.
TilesPerSeedNode | Get the number of tiles located at each seed node.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TilePattern Class


Parameter Property

[image] [image]

Revit 2011 API
TilePattern..::.Parameter Property
TilePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TilePattern Class
TilePattern Members


TilePatternType Property

[image]

Revit 2011 API
TilePattern..::.TilePatternType Property
TilePattern Class See Also Send Feedback
The built-in system tile pattern specified by this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TilePatternsBuiltIn TilePatternType { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilePatternType As TilePatternsBuiltIn
Visual C++
public:
property TilePatternsBuiltIn TilePatternType {
    TilePatternsBuiltIn get ();
}

See Also

TilePattern Class


TilesPerSeedNode Property

[image]

Revit 2011 API
TilePattern..::.TilesPerSeedNode Property
TilePattern Class See Also Send Feedback
Get the number of tiles located at each seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TilesPerSeedNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TilesPerSeedNode As Integer
Visual C++
public:
property int TilesPerSeedNode {
    int get ();
}

Remarks

Currently the number of tiles per seed node is always either 1 or 2.

See Also

TilePattern Class


TilePatterns Class

[image]

Revit 2011 API
TilePatterns Class
Members See Also Send Feedback
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TilePatterns : APIObject
Visual Basic (Declaration)
Public Class TilePatterns _
    Inherits APIObject
Visual C++
public ref class TilePatterns : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.TilePatterns

See Also

TilePatterns Members


TilePatterns Members

[image] [image]

Revit 2011 API
TilePatterns Members
TilePatterns Class Methods Properties See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTilePattern | Retrieve a TilePattern object from a built-in type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatterns Methods

[image] [image]

Revit 2011 API
TilePatterns Methods
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTilePattern | Retrieve a TilePattern object from a built-in type.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePatterns Class


GetTilePattern Method

[image]

Revit 2011 API
TilePatterns..::.GetTilePattern Method
TilePatterns Class See Also Send Feedback
Retrieve a TilePattern object from a built-in type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TilePattern GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
Visual Basic (Declaration)
Public Function GetTilePattern ( _
    tilePatternBuiltIn As TilePatternsBuiltIn _
) As TilePattern
Visual C++
public:
TilePattern^ GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)

Parameters

tilePatternBuiltIn
Type: Autodesk.Revit.DB..::.TilePatternsBuiltIn

Return Value

A TilePattern object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the document is not a Massing Family.

See Also

TilePatterns Class


TilePatterns Properties

[image] [image]

Revit 2011 API
TilePatterns Properties
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatternsBuiltIn Enumeration

[image]

Revit 2011 API
TilePatternsBuiltIn Enumeration
See Also Send Feedback
Revit's built-in tile patterns. See TilePattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TilePatternsBuiltIn
Visual Basic (Declaration)
Public Enumeration TilePatternsBuiltIn
Visual C++
public enum class TilePatternsBuiltIn

Members

Member name | Description
Rectangle |
Triangle_Bent |
Rhomboid |
Hexagon |
HalfStep |
ThirdStep |
TriangleCheckerboard_Bent |
RectangleCheckerboard |
RhomboidCheckerboard |
TriangleStep_Bent |
Arrows |
ZigZag |
Octagon |
OctagonRotate |
Triangle_Flat |
TriangleCheckerboard_Flat |

See Also


TopographySurface Class

[image]

Revit 2011 API
TopographySurface Class
Members See Also Send Feedback
An object that is used to represent a topography surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TopographySurface : Element
Visual Basic (Declaration)
Public Class TopographySurface _
    Inherits Element
Visual C++
public ref class TopographySurface : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.TopographySurface

See Also

TopographySurface Members


TopographySurface Members

[image] [image]

Revit 2011 API
TopographySurface Members
TopographySurface Class Methods Properties See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

Name | Description
AddPoints | Adds new points to a topography surface element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TopographySurface Class


TopographySurface Methods

[image] [image]

Revit 2011 API
TopographySurface Methods
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

Name | Description
AddPoints | Adds new points to a topography surface element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopographySurface Class


AddPoints Method

[image]

Revit 2011 API
TopographySurface..::.AddPoints Method
TopographySurface Class See Also Send Feedback
Adds new points to a topography surface element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddPoints(
    IList<XYZ> points
)
Visual Basic (Declaration)
Public Sub AddPoints ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
void AddPoints(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
An array of points for the topography surface.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the topography surface is invalid or regeneration fails.

See Also

TopographySurface Class


TopographySurface Properties

[image] [image]

Revit 2011 API
TopographySurface Properties
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TopographySurface Class


Parameter Property

[image] [image]

Revit 2011 API
TopographySurface..::.Parameter Property
TopographySurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TopographySurface Class
TopographySurface Members


Transaction Class

[image]

Revit 2011 API
Transaction Class
Members Example See Also Send Feedback
Transactions are context-like objects that guard any changes made to a Revit model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Transaction : IDisposable
Visual Basic (Declaration)
Public Class Transaction _
    Implements IDisposable
Visual C++
public ref class Transaction : IDisposable

Remarks

Any change to a document can only be made while there is an active transaction open for that document. Changes do not become a part of the model until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly (by the destructor). Only one transaction per document can be open at any given time.

Examples

CopyC#
// Get the document
Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;

// Create a geometry line in Revit application
XYZ Point1 = new XYZ(0, 0, 0);
XYZ Point2 = new XYZ(10, 0, 0);
XYZ Point3 = new XYZ(10, 10, 0);
XYZ Point4 = new XYZ(0, 10, 0);

// Transient Elements,so they are not managed by transactions
Line geomLine1 = application.Create.NewLine(Point1, Point2, true);
Line geomLine2 = application.Create.NewLine(Point4, Point3, true);
Line geomLine3 = application.Create.NewLine(Point1, Point4, true);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(0, 0, 1);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// non-transient elements,so they are grouped into transaction as atomic user actions
Transaction transaction = new Transaction(document);
if (transaction.Start("Create new curves") == TransactionStatus.Started)
{
    // Create a sketch plane in current document
    SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

    // Create a ModelLine element using the created geometry line and sketch plane
    ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
    ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
    ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

    TaskDialog taskDialog = new TaskDialog("Revit");
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback().";
    TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;
    taskDialog.CommonButtons = buttons;
    TaskDialogResult result = taskDialog.Show();

    if (TaskDialogResult.Ok == result)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
CopyVB.NET
' Get the document
Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document

' Create a geometry line in Revit application
Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
Dim Point3 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
Dim Point4 As New Autodesk.Revit.DB.XYZ(0, 10, 0)

' Transient Elements,so they are not managed by transactions
Dim geomLine1 As Line = application.Create.NewLine(Point1, Point2, True)
Dim geomLine2 As Line = application.Create.NewLine(Point4, Point3, True)
Dim geomLine3 As Line = application.Create.NewLine(Point1, Point4, True)

' Create a geometry plane in Revit application
Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.DB.XYZ(0, 0, 1)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

' non-transient elements,so they are grouped into transaction as atomic user actions
Dim transaction As New Transaction(document)
If transaction.Start("Create new curves") = TransactionStatus.Started Then
    ' Create a sketch plane in current document
    Dim sketch As SketchPlane = document.Create.NewSketchPlane(geomPlane)

    ' Create a ModelLine element using the created geometry line and sketch plane
    Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
    Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
    Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

    Dim taskDialog As New TaskDialog("Revit")
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback()."
    Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
    taskDialog.CommonButtons = buttons
    Dim result As TaskDialogResult = taskDialog.Show()

    If TaskDialogResult.Ok = result Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Transaction

See Also

Transaction Members


Transaction Members

[image] [image]

Revit 2011 API
Transaction Members
Transaction Class Constructors Methods See Also Send Feedback

The Transaction type exposes the following members.

Constructors

Name | Description
Transaction | Overloaded.

Methods

Name | Description
Commit | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureHandlingOptions | Returns the current failure handling options
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName | Returns the transaction's name
GetStatus | Returns the current status of the transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction has ended already
HasStarted | Determines whether the transaction has been started yet
RollBack | Overloaded.
SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back
SetName | Sets the transaction's name
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transaction Class


Transaction Constructor

[image] [image]

Revit 2011 API
Transaction Constructor
Transaction Class See Also Send Feedback

Overload List

Name | Description
Transaction(Document) | Instantiates an uninitialized transaction object
Transaction(Document, String) | Instantiates an uninitialized transaction object

See Also

Transaction Class
Transaction Members


Transaction Constructor (Document)

[image]

Revit 2011 API
Transaction Constructor (Document)
Transaction Class See Also Send Feedback
Instantiates an uninitialized transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transaction(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
Transaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this transaction is going to be used.

Remarks

The transaction does not start by creating a transaction object. The Start(String) method will need to be called in order to start this transaction. Because this constructor does not take a name, a name must be assigned later before or during the Start method. A transaction cannot start unless is has a valid (non-empty) name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload


Transaction Constructor (Document, String)

[image]

Revit 2011 API
Transaction Constructor (Document, String)
Transaction Class See Also Send Feedback
Instantiates an uninitialized transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transaction(
    Document document,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    name As String _
)
Visual C++
public:
Transaction(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document for which this transaction is going to be used.
name
Type: System..::.String
The name of the transaction. This name will appear in the undo menu once the transaction is successfully committed. The name must not be empty. The name can be reset later by either calling SetName(String) or by using the name argument in the Start(String) method.

Remarks

The transaction does not start by creating a transaction object. The Start method will need to be called in order to start this transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name argument is an empty string
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload


Transaction Methods

[image] [image]

Revit 2011 API
Transaction Methods
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Methods

Name | Description
Commit | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailureHandlingOptions | Returns the current failure handling options
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName | Returns the transaction's name
GetStatus | Returns the current status of the transaction
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction has ended already
HasStarted | Determines whether the transaction has been started yet
RollBack | Overloaded.
SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back
SetName | Sets the transaction's name
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transaction Class


Commit Method

[image] [image]

Revit 2011 API
Transaction..::.Commit Method
Transaction Class See Also Send Feedback

Overload List

Name | Description
Commit()()() | Commits all changes made to the model during the transaction
Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction

See Also

Transaction Class
Transaction Members


Commit Method

[image]

Revit 2011 API
Transaction..::.Commit Method
Transaction Class See Also Send Feedback
Commits all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus::Committed

Remarks

By committing a transaction, all changes made to the model during the transaction are accepted. A new undo item will appear in the Undo menu in Revit, which allows the user to undo the changes. The undo item will have this transaction's name. Commit may only be called for a transaction that has been started. (Use the GetStatus()()() method to check the current state.) Be aware that committing may fail or can be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was committed successfully. Only after a transaction is successfully committed (or rolled back as a result of handling transaction failures), it may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload


Commit Method (FailureHandlingOptions)

[image]

Revit 2011 API
Transaction..::.Commit Method (FailureHandlingOptions)
Transaction Class See Also Send Feedback
Commits all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Commit(
    FailureHandlingOptions options
)
Visual Basic (Declaration)
Public Function Commit ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus Commit(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

Return Value

If finished successfully, this method returns TransactionStatus::Committed

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Commit Overload


Dispose Method

[image]

Revit 2011 API
Transaction..::.Dispose Method
Transaction Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Transaction Class


GetFailureHandlingOptions Method

[image]

Revit 2011 API
Transaction..::.GetFailureHandlingOptions Method
Transaction Class See Also Send Feedback
Returns the current failure handling options

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FailureHandlingOptions GetFailureHandlingOptions()
Visual Basic (Declaration)
Public Function GetFailureHandlingOptions As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ GetFailureHandlingOptions()

See Also

Transaction Class


GetName Method

[image]

Revit 2011 API
Transaction..::.GetName Method
Transaction Class See Also Send Feedback
Returns the transaction's name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetName()
Visual Basic (Declaration)
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

Transaction Class


GetStatus Method

[image]

Revit 2011 API
Transaction..::.GetStatus Method
Transaction Class See Also Send Feedback
Returns the current status of the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic (Declaration)
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

See Also

Transaction Class


HasEnded Method

[image]

Revit 2011 API
Transaction..::.HasEnded Method
Transaction Class See Also Send Feedback
Determines whether the transaction has ended already

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasEnded()
Visual Basic (Declaration)
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Remarks

A transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a transaction has ended is by testing the current status (see GetStatus()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

Transaction Class


HasStarted Method

[image]

Revit 2011 API
Transaction..::.HasStarted Method
Transaction Class See Also Send Feedback
Determines whether the transaction has been started yet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasStarted()
Visual Basic (Declaration)
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Remarks

A transaction is considered being started after the Start method was called and until the transaction is either completely committed or rolled back. HasStarted may return True even after Commit (or RollBack) was called if the method returned the Pending status. A transaction can only be Started when HasStarted returns false.

See Also

Transaction Class


RollBack Method

[image] [image]

Revit 2011 API
Transaction..::.RollBack Method
Transaction Class See Also Send Feedback

Overload List

Name | Description
RollBack()()() | Rolls back all changes made to the model during the transaction
RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction

See Also

Transaction Class
Transaction Members


RollBack Method

[image]

Revit 2011 API
Transaction..::.RollBack Method
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Remarks

By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus()()() method to check the current state.) Be aware that committing may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is completed, the transaction may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
RollBack Overload


RollBack Method (FailureHandlingOptions)

[image]

Revit 2011 API
Transaction..::.RollBack Method (FailureHandlingOptions)
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus RollBack(
    FailureHandlingOptions options
)
Visual Basic (Declaration)
Public Function RollBack ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus RollBack(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

Return Value

If finished successfully, this method returns TransactionStatus::RolledBack

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
RollBack Overload


SetFailureHandlingOptions Method

[image]

Revit 2011 API
Transaction..::.SetFailureHandlingOptions Method
Transaction Class Example See Also Send Feedback
Sets options for handling failures to be used when the transaction is being committed or rolled back

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic (Declaration)
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::.FailureHandlingOptions

Remarks

Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, a transaction will reset the options to their default values.

Examples

CopyC#
Transaction t = new Transaction(doc);
t.Start("room");
FailureHandlingOptions failOpt = t.GetFailureHandlingOptions();
failOpt.SetFailuresPreprocessor(new RoomWarningSwallower());
t.SetFailureHandlingOptions(failOpt);

doc.Create.NewRoom(level, new UV(0, 0));
t.Commit();
CopyVB.NET
Dim t As New Transaction(doc)
t.Start("room")
Dim failOpt As Autodesk.Revit.DB.FailureHandlingOptions
failOpt = t.GetFailureHandlingOptions()
failOpt.SetFailuresPreprocessor(New RoomWarningSwallower())
t.SetFailureHandlingOptions(failOpt)

doc.Create.NewRoom(level, New Autodesk.Revit.DB.UV(0, 0))
t.Commit()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class


SetName Method

[image]

Revit 2011 API
Transaction..::.SetName Method
Transaction Class See Also Send Feedback
Sets the transaction's name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetName(
    string name
)
Visual Basic (Declaration)
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::.String

Remarks

A transaction needs a name to be assigned before it can be started. The name will appear in the Undo menu in Revit after a transaction is successfully committed. Another ways of setting the name is either during construction or during the Start(String) method. Even though a new name can be assigned at any time, it is not going to be used until the next time the Start method is invoked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name argument is an empty string
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class


Start Method

[image] [image]

Revit 2011 API
Transaction..::.Start Method
Transaction Class See Also Send Feedback

Overload List

Name | Description
Start()()() | Starts the transaction.
Start(String) | Starts the transaction.

See Also

Transaction Class
Transaction Members


Start Method

[image]

Revit 2011 API
Transaction..::.Start Method
Transaction Class See Also Send Feedback
Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Remarks

A transaction may be started only after if was instantiated or after it was successfully committed or rolled back. In order to start a transaction, it must have a name assigned. If the name was not specified when the transaction object was instantiated, it has to be set by calling the SetName(String) method. Be aware that every time a transaction starts, FailureHandlingOptions will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) prior committing or rolling back the transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It is either because another transaction started already and has not been completed yet, or if the document is in a state in which it cannot start a new transaction (e.g. during failure handling). -or- The transaction does not have a valid name assigned yet

See Also

Transaction Class
Start Overload


Start Method (String)

[image]

Revit 2011 API
Transaction..::.Start Method (String)
Transaction Class See Also Send Feedback
Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TransactionStatus Start(
    string name
)
Visual Basic (Declaration)
Public Function Start ( _
    name As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ name
)

Parameters

name
Type: System..::.String

Remarks

A transaction may be started only after if was instantiated or after it was successfully committed or rolled back. Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name argument is an empty string
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It is either because another transaction started already and has not been completed yet, or if the document is in a state in which it cannot start a new transaction (e.g. during failure handling).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Start Overload


TransactionGroup Class

[image]

Revit 2011 API
TransactionGroup Class
Members See Also Send Feedback
This class is introduced to group a set of transactions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TransactionGroup : IDisposable
Visual Basic (Declaration)
Public Class TransactionGroup _
    Implements IDisposable
Visual C++
public ref class TransactionGroup : IDisposable

Remarks

There are three ways to end a transaction group: commit, assimilate, and rollback It is necessary to end all transactions inside the group before ending it

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TransactionGroup

See Also

TransactionGroup Members


TransactionGroup Members

[image] [image]

Revit 2011 API
TransactionGroup Members
TransactionGroup Class Constructors Methods See Also Send Feedback

The TransactionGroup type exposes the following members.

Constructors

Name | Description
TransactionGroup | Overloaded.

Methods

Name | Description
Assimilate | Assimilates all inner transactions, merges them into a single one, and then commits it
Commit | Commits the transaction group
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName |
GetStatus | Gets the current status of the transaction group
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction group was ended or not
HasStarted | Determines whether the transaction group has ever been started or not
RollBack | Rolls back the transaction group and with it all inner transactions enclosing by this group
SetName | accessors for the transaction group name property
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionGroup Class


TransactionGroup Constructor

[image] [image]

Revit 2011 API
TransactionGroup Constructor
TransactionGroup Class See Also Send Feedback

Overload List

Name | Description
TransactionGroup(Document) | It constructs a transaction group object
TransactionGroup(Document, String) | It constructs a transaction group object

See Also

TransactionGroup Class
TransactionGroup Members


TransactionGroup Constructor (Document)

[image]

Revit 2011 API
TransactionGroup Constructor (Document)
TransactionGroup Class See Also Send Feedback
It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
TransactionGroup(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document in which the changes might be made

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Unable to instantiate a TransactionGroup within an open transaction
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Constructor (Document, String)

[image]

Revit 2011 API
TransactionGroup Constructor (Document, String)
TransactionGroup Class See Also Send Feedback
It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document,
    string transGroupName
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    transGroupName As String _
)
Visual C++
public:
TransactionGroup(
    Document^ document,
    String^ transGroupName
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document in which the changes might be made
transGroupName
Type: System..::.String
Name of the group When assimilate the group, all transactions inside the group will be merged into one undo menu item with the group's name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Unable to instantiate a TransactionGroup within an open transaction
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Methods

[image] [image]

Revit 2011 API
TransactionGroup Methods
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Methods

Name | Description
Assimilate | Assimilates all inner transactions, merges them into a single one, and then commits it
Commit | Commits the transaction group
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetName |
GetStatus | Gets the current status of the transaction group
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasEnded | Determines whether the transaction group was ended or not
HasStarted | Determines whether the transaction group has ever been started or not
RollBack | Rolls back the transaction group and with it all inner transactions enclosing by this group
SetName | accessors for the transaction group name property
Start | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionGroup Class


Assimilate Method

[image]

Revit 2011 API
TransactionGroup..::.Assimilate Method
TransactionGroup Class Example See Also Send Feedback
Assimilates all inner transactions, merges them into a single one, and then commits it

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Assimilate()
Visual Basic (Declaration)
Public Function Assimilate As TransactionStatus
Visual C++
public:
TransactionStatus Assimilate()

Remarks

The transactions inside this group will be merged as one single transaction (with the group's name as the transaction's name) User will not be able to undo/redo to the middle of the group, they can only undo/redo the entire group

Examples

CopyC#
TransactionStatus status = TransactionStatus.Uninitialized;
bool bAssimilate = true;
TransactionGroup transGroup = new TransactionGroup(document, "Group Change");
if (transGroup.Start() == TransactionStatus.Started)
{
    Transaction levelTransaction = new Transaction(document, "Add Level");
    try
    {
        if (levelTransaction.Start() == TransactionStatus.Started)
        {
            document.Create.NewLevel(25.0);
            levelTransaction.Commit();
        }
    }
    catch
    {
        // if either internal transaction fails, rollback group, too
        levelTransaction.RollBack();
        bAssimilate = false;
    }

    // if first transaction was successful, continue with next
    if (bAssimilate == true)
    {
        Transaction gridTransaction = new Transaction(document, "Add Grid");
        try
        {
            if (gridTransaction.Start() == TransactionStatus.Started)
            {
                XYZ Point1 = new XYZ(0, 0, 0);
                XYZ Point2 = new XYZ(10, 0, 0);

                Line gridLine = document.Application.Create.NewLine(Point1, Point2, true);
                document.Create.NewGrid(gridLine);
                gridTransaction.Commit();
            }
        }
        catch
        {
            // if either internal transaction fails, rollback group, too
            gridTransaction.RollBack();
            bAssimilate = false;
        }
    }

    // if both transactions are successful, assimilate the group
    if (bAssimilate == true)
    {
        status = transGroup.Assimilate();
    }
    else
    {
        status = transGroup.RollBack();
    }
}
CopyVB.NET
Dim status As TransactionStatus = TransactionStatus.Uninitialized
Dim bAssimilate As Boolean = True
Dim transGroup As New TransactionGroup(document, "Group Change")
If transGroup.Start() = TransactionStatus.Started Then
    Dim levelTransaction As New Transaction(document, "Add Level")
    Try
        If levelTransaction.Start() = TransactionStatus.Started Then
            document.Create.NewLevel(25)
            levelTransaction.Commit()
        End If
    Catch
        ' if either internal transaction fails, rollback group, too
        levelTransaction.RollBack()
        bAssimilate = False
    End Try

    ' if first transaction was successful, continue with next
    If bAssimilate = True Then
        Dim gridTransaction As New Transaction(document, "Add Grid")
        Try
            If gridTransaction.Start() = TransactionStatus.Started Then
                Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
                Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)

                Dim gridLine As Line = document.Application.Create.NewLine(Point1, Point2, True)
                document.Create.NewGrid(gridLine)
                gridTransaction.Commit()
            End If
        Catch
            ' if either internal transaction fails, rollback group, too
            gridTransaction.RollBack()
            bAssimilate = False
        End Try
    End If

    ' if both transactions are successful, assimilate the group
    If bAssimilate = True Then
        status = transGroup.Assimilate()
    Else
        status = transGroup.RollBack()
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class


Commit Method

[image]

Revit 2011 API
TransactionGroup..::.Commit Method
TransactionGroup Class See Also Send Feedback
Commits the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic (Declaration)
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Remarks

Using "commit" to end the transaction group User will be able to undo/redo to the middle of the group

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class


Dispose Method

[image]

Revit 2011 API
TransactionGroup..::.Dispose Method
TransactionGroup Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

TransactionGroup Class


GetName Method

[image]

Revit 2011 API
TransactionGroup..::.GetName Method
TransactionGroup Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GetName()
Visual Basic (Declaration)
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

TransactionGroup Class


GetStatus Method

[image]

Revit 2011 API
TransactionGroup..::.GetStatus Method
TransactionGroup Class See Also Send Feedback
Gets the current status of the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic (Declaration)
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

See Also

TransactionGroup Class


HasEnded Method

[image]

Revit 2011 API
TransactionGroup..::.HasEnded Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction group was ended or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic (Declaration)
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Remarks

A simple test of whether transaction group was either Committed/Assimilated or Rolled Back. This is basically a simple way of testing if the current status is either 'TransactionStatus::Committed' or 'TransactionStatus::RolledBack'

See Also

TransactionGroup Class


HasStarted Method

[image]

Revit 2011 API
TransactionGroup..::.HasStarted Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction group has ever been started or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic (Declaration)
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Remarks

A test whether a TransactionGroup object started a TransactionGroup at least once. This is set to TRUE after either single-phase construction or after 'start' was called in two-phase construction. Once set to TRUE, it remains TRUE until the object is destroyed.

See Also

TransactionGroup Class


RollBack Method

[image]

Revit 2011 API
TransactionGroup..::.RollBack Method
TransactionGroup Class See Also Send Feedback
Rolls back the transaction group and with it all inner transactions enclosing by this group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic (Declaration)
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Remarks

All transactions inside the transaction group will be rolled back

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The TransactionGroup is not in started status

See Also

TransactionGroup Class


SetName Method

[image]

Revit 2011 API
TransactionGroup..::.SetName Method
TransactionGroup Class See Also Send Feedback
accessors for the transaction group name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic (Declaration)
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class


Start Method

[image] [image]

Revit 2011 API
TransactionGroup..::.Start Method
TransactionGroup Class See Also Send Feedback

Overload List

Name | Description
Start()()() | Starts the transaction group
Start(String) | Starts the transaction group

See Also

TransactionGroup Class
TransactionGroup Members


Start Method

[image]

Revit 2011 API
TransactionGroup..::.Start Method
TransactionGroup Class See Also Send Feedback
Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic (Declaration)
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The TransactionGroup has already been started

See Also

TransactionGroup Class
Start Overload


Start Method (String)

[image]

Revit 2011 API
TransactionGroup..::.Start Method (String)
TransactionGroup Class See Also Send Feedback
Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start(
    string transGroupName
)
Visual Basic (Declaration)
Public Function Start ( _
    transGroupName As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ transGroupName
)

Parameters

transGroupName
Type: System..::.String
Name of the group When assimilate the group, all transactions inside the group will be merged into one undo menu item with the group's name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The TransactionGroup has already been started
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
Start Overload


TransactionStatus Enumeration

[image]

Revit 2011 API
TransactionStatus Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TransactionStatus
Visual Basic (Declaration)
Public Enumeration TransactionStatus
Visual C++
public enum class TransactionStatus

Members

Member name | Description
Uninitialized | initial value, the transaction has not been started yet in this status
Started | transaction has begun (until committed or rolled back)
RolledBack | rolled back (aborted)
Committed | simply committed, ended an empty transaction, flushed all, or undo is disabled
Pending | returned from error handling that took over managing the transaction
Error | error while committing or rolling back
Proceed | while still in error handling (internal status)

See Also


Transform Class

[image]

Revit 2011 API
Transform Class
Members Example See Also Send Feedback
A transformation of the affine 3-space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Transform : APIObject
Visual Basic (Declaration)
Public Class Transform _
    Inherits APIObject
Visual C++
public ref class Transform : public APIObject

Examples

CopyC#
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
CopyVB.NET
Public Shared Function TransformPoint(ByVal point As Autodesk.Revit.DB.XYZ, ByVal transform As Transform) As Autodesk.Revit.DB.XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As Autodesk.Revit.DB.XYZ = transform.Basis(0)
    Dim b1 As Autodesk.Revit.DB.XYZ = transform.Basis(1)
    Dim b2 As Autodesk.Revit.DB.XYZ = transform.Basis(2)
    Dim origin As Autodesk.Revit.DB.XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New Autodesk.Revit.DB.XYZ(xTemp, yTemp, zTemp)
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Transform

See Also

Transform Members


Transform Members

[image] [image]

Revit 2011 API
Transform Members
Transform Class Constructors Methods Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

Name | Description
Transform | The copy constructor.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

Properties

Name | Description
Basis | Defines the basis of the old coordinate system in the new coordinate system.
BasisX | The basis of the X axis of this transformation.
BasisY | The basis of the Y axis of this transformation.
BasisZ | The basis of the Z axis of this transformation.
Determinant | The determinant of this transformation.
HasReflection | The boolean value that indicates whether this transformation produces reflection.
Identity | The identity transformation.
Inverse | The inverse transformation of this transformation.
IsConformal | The boolean value that indicates whether this transformation is conformal.
IsIdentity | The boolean value that indicates whether this transformation is an identity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTranslation | The boolean value that indicates whether this transformation is a translation.
Origin | Defines the origin of the old coordinate system in the new coordinate system.
Reflection | The transformation that reflects about the specified plane.
Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Scale | The real number that represents the scale of the transformation.
Translation | The transformation that translates by the specified vector.

See Also

Transform Class


Transform Constructor

[image]

Revit 2011 API
Transform Constructor
Transform Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform(
    Transform source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As Transform _
)
Visual C++
public:
Transform(
    Transform^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.Transform

See Also

Transform Class


Transform Methods

[image] [image]

Revit 2011 API
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

Name | Description
AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Multiply | Multiplies this transformation by the specified transformation and returns the result.
OfPoint | Applies the transformation to the point and returns the result.
OfVector | Applies the transform to the vector
ScaleBasis | Scales the basis vectors of this transformation and returns the result.
ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class


AlmostEqual Method

[image]

Revit 2011 API
Transform..::.AlmostEqual Method
Transform Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic (Declaration)
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::.Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Multiply Method

[image]

Revit 2011 API
Transform..::.Multiply Method
Transform Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic (Declaration)
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::.Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Multiply Operator

[image]

Revit 2011 API
Transform..::.Multiply Operator
Transform Class See Also Send Feedback
Multiplies the two specified transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Transform operator *(
    Transform left,
    Transform right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As Transform, _
    right As Transform _
) As Transform
Visual C++
public:
static Transform^ operator *(
    Transform^ left,
    Transform^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::.Transform
The first transformation.
right
Type: Autodesk.Revit.DB..::.Transform
The second transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the handle of the first or second transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


OfPoint Method

[image]

Revit 2011 API
Transform..::.OfPoint Method
Transform Class See Also Send Feedback
Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ OfPoint(
    XYZ point
)
Visual Basic (Declaration)
Public Function OfPoint ( _
    point As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

See Also

Transform Class


OfVector Method

[image]

Revit 2011 API
Transform..::.OfVector Method
Transform Class See Also Send Feedback
Applies the transform to the vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic (Declaration)
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.DB..::.XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class


ScaleBasis Method

[image]

Revit 2011 API
Transform..::.ScaleBasis Method
Transform Class See Also Send Feedback
Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


ScaleBasisAndOrigin Method

[image]

Revit 2011 API
Transform..::.ScaleBasisAndOrigin Method
Transform Class See Also Send Feedback
Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform ScaleBasisAndOrigin(
    double scale
)
Visual Basic (Declaration)
Public Function ScaleBasisAndOrigin ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasisAndOrigin(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


Transform Properties

[image] [image]

Revit 2011 API
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

Name | Description
Basis | Defines the basis of the old coordinate system in the new coordinate system.
BasisX | The basis of the X axis of this transformation.
BasisY | The basis of the Y axis of this transformation.
BasisZ | The basis of the Z axis of this transformation.
Determinant | The determinant of this transformation.
HasReflection | The boolean value that indicates whether this transformation produces reflection.
Identity | The identity transformation.
Inverse | The inverse transformation of this transformation.
IsConformal | The boolean value that indicates whether this transformation is conformal.
IsIdentity | The boolean value that indicates whether this transformation is an identity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
IsTranslation | The boolean value that indicates whether this transformation is a translation.
Origin | Defines the origin of the old coordinate system in the new coordinate system.
Reflection | The transformation that reflects about the specified plane.
Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Scale | The real number that represents the scale of the transformation.
Translation | The transformation that translates by the specified vector.

See Also

Transform Class


Basis Property

[image]

Revit 2011 API
Transform..::.Basis Property
Transform Class See Also Send Feedback
Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Basis[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Property Basis ( _
    idx As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Type: System..::.Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisX Property

[image]

Revit 2011 API
Transform..::.BasisX Property
Transform Class See Also Send Feedback
The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic (Declaration)
Public Property BasisX As XYZ
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisY Property

[image]

Revit 2011 API
Transform..::.BasisY Property
Transform Class See Also Send Feedback
The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic (Declaration)
Public Property BasisY As XYZ
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisZ Property

[image]

Revit 2011 API
Transform..::.BasisZ Property
Transform Class See Also Send Feedback
The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ BasisZ { get; set; }
Visual Basic (Declaration)
Public Property BasisZ As XYZ
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Determinant Property

[image]

Revit 2011 API
Transform..::.Determinant Property
Transform Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Determinant { get; }
Visual Basic (Declaration)
Public ReadOnly Property Determinant As Double
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform Class


HasReflection Property

[image]

Revit 2011 API
Transform..::.HasReflection Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasReflection { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasReflection As Boolean
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.

See Also

Transform Class


Identity Property

[image]

Revit 2011 API
Transform..::.Identity Property
Transform Class See Also Send Feedback
The identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Transform Identity { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Identity As Transform
Visual C++
public:
static property Transform^ Identity {
    Transform^ get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


Inverse Property

[image]

Revit 2011 API
Transform..::.Inverse Property
Transform Class See Also Send Feedback
The inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Transform Inverse { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inverse As Transform
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class


IsConformal Property

[image]

Revit 2011 API
Transform..::.IsConformal Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsConformal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsConformal As Boolean
Visual C++
public:
property bool IsConformal {
    bool get ();
}

Remarks

This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.

See Also

Transform Class


IsIdentity Property

[image]

Revit 2011 API
Transform..::.IsIdentity Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsIdentity { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsIdentity As Boolean
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


IsTranslation Property

[image]

Revit 2011 API
Transform..::.IsTranslation Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsTranslation { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTranslation As Boolean
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform Class


Origin Property

[image]

Revit 2011 API
Transform..::.Origin Property
Transform Class See Also Send Feedback
Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Reflection Property

[image]

Revit 2011 API
Transform..::.Reflection Property
Transform Class Example See Also Send Feedback
The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Transform Reflection[
    Plane plane
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Type: Autodesk.Revit.DB..::.Plane
The plane to reflect about.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.get_Reflection(refPlane.Plane);

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(ByVal refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.Reflection(refPlane.Plane)

    Return mirTrans
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the handle of the plane is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Rotation Property

[image]

Revit 2011 API
Transform..::.Rotation Property
Transform Class See Also Send Feedback
The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Transform Rotation[
    XYZ origin,
    XYZ axis,
    double angle
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
The point to rotate about.
axis
Type: Autodesk.Revit.DB..::.XYZ
The axis vector to rotate about.
angle
Type: System..::.Double
The rotation angle in radians.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class


Scale Property

[image]

Revit 2011 API
Transform..::.Scale Property
Transform Class See Also Send Feedback
The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class


Translation Property

[image]

Revit 2011 API
Transform..::.Translation Property
Transform Class See Also Send Feedback
The transformation that translates by the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Transform Translation[
    XYZ vec
] { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Translation ( _
    vec As XYZ _
) As Transform
Visual C++
public:
static property Transform^ Translation[XYZ^ vec] {
    Transform^ get (XYZ^ vec);
}

Parameters

vec
Type: Autodesk.Revit.DB..::.XYZ
The translation vector.

See Also

Transform Class


TypeBinding Class

[image]

Revit 2011 API
TypeBinding Class
Members Example See Also Send Feedback
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TypeBinding : ElementBinding
Visual Basic (Declaration)
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Examples

CopyC#
public bool SetNewParameterToTypeWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    Definition myDefinition_CompanyName =
       myGroup.Definitions.Create("CompanyName", ParameterType.Text);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveUIDocument.Document.Settings.Categories.get_Item(
                                    BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Application.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      BuiltInParameterGroup.PG_TEXT);
    return typeBindOK;
}
CopyVB.NET
Public Function SetNewParameterToTypeWall(ByVal app As UIApplication, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' Create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

    ' Create a type definition
    Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create("CompanyName", ParameterType.Text)

    ' Create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
    ' Use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.DB.Category = app.ActiveUIDocument.Document.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an object of TypeBinding according to the Categories
    Dim typeBinding As TypeBinding = app.Application.Create.NewTypeBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

    ' Bind the definitions to the document
    Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, BuiltInParameterGroup.PG_TEXT)
    Return typeBindOK
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.Binding
Autodesk.Revit.DB..::.ElementBinding
Autodesk.Revit.DB..::.TypeBinding

See Also

TypeBinding Members


TypeBinding Members

[image] [image]

Revit 2011 API
TypeBinding Members
TypeBinding Class Constructors Methods Properties See Also Send Feedback

The TypeBinding type exposes the following members.

Constructors

Name | Description
TypeBinding | Overloaded.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


TypeBinding Constructor

[image] [image]

Revit 2011 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback

Overload List

Name | Description
TypeBinding()()() | Constructs an empty type binding.
TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

See Also

TypeBinding Class
TypeBinding Members


TypeBinding Constructor

[image]

Revit 2011 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback
Constructs an empty type binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TypeBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload


TypeBinding Constructor (CategorySet)

[image]

Revit 2011 API
TypeBinding Constructor (CategorySet)
TypeBinding Class See Also Send Feedback
Constructs a type binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TypeBinding(
    CategorySet categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
TypeBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit.DB..::.CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload


TypeBinding Methods

[image] [image]

Revit 2011 API
TypeBinding Methods
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeBinding Class


TypeBinding Properties

[image] [image]

Revit 2011 API
TypeBinding Properties
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Properties

Name | Description
Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


UnitGroup Enumeration

[image]

Revit 2011 API
UnitGroup Enumeration
See Also Send Feedback
An enumerated type listing Discipline of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum UnitGroup
Visual Basic (Declaration)
Public Enumeration UnitGroup
Visual C++
public enum class UnitGroup

Members

Member name | Description
UG_Common |
UG_Structural |
UG_HVAC |
UG_Electrical |
UG_Piping |

See Also


UnitSymbolType Enumeration

[image]

Revit 2011 API
UnitSymbolType Enumeration
See Also Send Feedback
An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum UnitSymbolType
Visual Basic (Declaration)
Public Enumeration UnitSymbolType
Visual C++
public enum class UnitSymbolType

Members

Member name | Description
UST_NONE |
UST_M |
UST_CM |
UST_MM |
UST_LF |
UST_FOOT_SINGLE_QUOTE |
UST_INCH_DOUBLE_QUOTE |
UST_ACRES |
UST_HECTARES |
UST_CY |
UST_SF |
UST_FT_SUP_2 |
UST_FT_CARET_2 |
UST_M_SUP_2 |
UST_M_CARET_2 |
UST_CF |
UST_FT_SUP_3 |
UST_FT_CARET_3 |
UST_M_SUP_3 |
UST_M_CARET_3 |
UST_DEGREE_SYMBOL |
UST_PERCENT_SIGN |
UST_IN_SUP_2 |
UST_IN_CARET_2 |
UST_CM_SUP_2 |
UST_CM_CARET_2 |
UST_MM_SUP_2 |
UST_MM_CARET_2 |
UST_IN_SUP_3 |
UST_IN_CARET_3 |
UST_CM_SUP_3 |
UST_CM_CARET_3 |
UST_MM_SUP_3 |
UST_MM_CARET_3 |
UST_L |
UST_GAL |
UST_KG_PER_CU_M |
UST_LB_MASS_PER_CU_FT |
UST_LBM_PER_CU_FT |
UST_LB_PER_CU_IN |
UST_LBM_PER_CU_IN |
UST_BTU |
UST_CAL |
UST_KCAL |
UST_JOULE |
UST_KWH |
UST_THERM |
UST_IN_WG_PER_100FT |
UST_PASCAL_PER_M |
UST_WATT |
UST_KILOWATT |
UST_BTU_PER_S |
UST_BTU_PER_H |
UST_CAL_PER_S |
UST_KCAL_PER_S |
UST_WATT_PER_SQ_FT |
UST_WATT_PER_SQ_M |
UST_IN_WG |
UST_PASCAL |
UST_KILOPASCAL |
UST_MEGAPASCAL |
UST_PSI |
UST_LB_PER_SQ_IN |
UST_PSIG |
UST_PSIA |
UST_LBF_PER_SQ_IN |
UST_IN_HG |
UST_MM_HG |
UST_ATM |
UST_BAR |
UST_DEGREE_F |
UST_DEGREE_C |
UST_KELVIN |
UST_DEGREE_R |
UST_FT_PER_MIN |
UST_FPM |
UST_M_PER_S |
UST_CM_PER_MIN |
UST_CU_FT_PER_MIN |
UST_CFM |
UST_L_PER_S |
UST_LPS |
UST_CU_M_PER_S |
UST_CMS |
UST_CU_M_PER_H |
UST_CMH |
UST_GAL_PER_MIN |
UST_GPM |
UST_USGPM |
UST_GAL_PER_H |
UST_GPH |
UST_USGPH |
UST_AMPERE |
UST_KILOAMPERE |
UST_MILLIAMPERE |
UST_VOLT |
UST_KILOVOLT |
UST_MILLIVOLT |
UST_HZ |
UST_CPS |
UST_LX |
UST_FC |
UST_FTC |
UST_FL |
UST_FL_LOWERCASE |
UST_FTL |
UST_CD_PER_SQ_M |
UST_CD |
UST_LM |
UST_VOLTAMPERE |
UST_KILOVOLTAMPERE |
UST_HP |
UST_N |
UST_DA_N |
UST_K_N |
UST_M_N |
UST_KIP |
UST_KGF |
UST_TF |
UST_LB |
UST_LBF |
UST_N_PER_M |
UST_DA_N_PER_M |
UST_K_N_PER_M |
UST_M_N_PER_M |
UST_KIP_PER_FT |
UST_KGF_PER_M |
UST_TF_PER_M |
UST_LB_PER_FT |
UST_LBF_PER_FT |
UST_N_PER_M_SUP_2 |
UST_DA_N_PER_M_SUP_2 |
UST_K_N_PER_M_SUP_2 |
UST_M_N_PER_M_SUP_2 |
UST_KSF |
UST_KIP_PER_SQ_FT |
UST_KGF_PER_M_SUP_2 |
UST_TF_PER_M_SUP_2 |
UST_PSF |
UST_LB_PER_SQ_FT |
UST_LBF_PER_SQ_FT |
UST_N_DASH_M |
UST_DA_N_DASH_M |
UST_K_N_DASH_M |
UST_M_N_DASH_M |
UST_KIP_DASH_FT |
UST_KGF_DASH_M |
UST_TF_DASH_M |
UST_LB_DASH_FT |
UST_LBF_DASH_FT |
UST_M_PER_K_N |
UST_FT_PER_KIP |
UST_M_SUP_2_PER_K_N |
UST_FT_SUP_2_PER_KIP |
UST_M_SUP_3_PER_K_N |
UST_FT_SUP_3_PER_KIP |
UST_INV_K_N |
UST_INV_KIP |
UST_FTH2O_PER_100FT |
UST_FT_OF_WATER_PER_100FT |
UST_FEET_OF_WATER_PER_100FT |
UST_FTH2O |
UST_FT_OF_WATER |
UST_FEET_OF_WATER |
UST_PA_S |
UST_LB_PER_FT_S |
UST_LBM_PER_FT_S |
UST_CP |
UST_FT_PER_S |
UST_FPS |
UST_KSI |
UST_KIP_PER_SQ_IN |
UST_KN_PER_M_SUP_3 |
UST_LB_FORCE_PER_CU_FT |
UST_LBF_PER_CU_FT |
UST_KIP_PER_IN_SUP_3 |
UST_INV_DEGREE_F |
UST_INV_DEGREE_C |
UST_N_DASH_M_PER_M |
UST_DA_N_DASH_M_PER_M |
UST_K_N_DASH_M_PER_M |
UST_M_N_DASH_M_PER_M |
UST_KIP_DASH_FT_PER_FT |
UST_KGF_DASH_M_PER_M |
UST_TF_DASH_M_PER_M |
UST_LB_DASH_FT_PER_FT |
UST_LBF_DASH_FT_PER_FT |
UST_LB_PER_FT_H |
UST_LBM_PER_FT_H |
UST_KIPS_PER_IN |
UST_KIPS_PER_CU_FT |
UST_KIP_FT_PER_DEGREE |
UST_K_N_M_PER_DEGREE |
UST_KIP_FT_PER_DEGREE_PER_FT |
UST_K_N_M_PER_DEGREE_PER_M |
UST_WATT_PER_SQ_M_K |
UST_BTU_PER_H_SQ_FT_DEGREE_F |
UST_CFM_PER_SQ_FT |
UST_CFM_PER_SF |
UST_LPS_PER_SQ_M |
UST_L_PER_S_SQ_M |
UST_COLON_10 |
UST_COLON_12 |
UST_SLOPE_DEGREE_SYMBOL |
UST_WATT_PER_CU_FT |
UST_WATT_PER_CU_M |
UST_BTU_PER_H_SQ_FT |
UST_BTU_PER_H_CU_FT |
UST_TON |
UST_CFM_PER_CU_FT |
UST_CFM_PER_CF |
UST_L_PER_S_CU_M |
UST_CFM_PER_TON |
UST_L_PER_S_KW |
UST_SQ_FT_PER_TON |
UST_SF_PER_TON |
UST_SQ_M_PER_KW |
UST_DOLLAR |
UST_EURO_SUFFIX |
UST_EURO_PREFIX |
UST_POUND |
UST_YEN |
UST_CHINESE_HONG_KONG_SAR |
UST_WON |
UST_SHEQEL |
UST_DONG |
UST_BAHT |
UST_KRONER |
UST_LM_PER_W |
UST_SF_PER_MBH |
UST_SF_PER_KBTU_PER_H |
UST_SQ_FT_PER_MBH |
UST_SQ_FT_PER_KBTU_PER_H |
UST_K_N_PER_CM_SUP_2 |
UST_N_PER_MM_SUP_2 |
UST_K_N_PER_MM_SUP_2 |

See Also


UnitType Enumeration

[image]

Revit 2011 API
UnitType Enumeration
See Also Send Feedback
An enumerated type listing all the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum UnitType
Visual Basic (Declaration)
Public Enumeration UnitType
Visual C++
public enum class UnitType

Members

Member name | Description
UT_Length |
UT_Area |
UT_Volume |
UT_Angle |
UT_Number |
UT_SheetLength |
UT_SiteAngle |
UT_HVAC_Density |
UT_HVAC_Energy |
UT_HVAC_Friction |
UT_HVAC_Power |
UT_HVAC_Power_Density |
UT_HVAC_Pressure |
UT_HVAC_Temperature |
UT_HVAC_Velocity |
UT_HVAC_Airflow |
UT_HVAC_DuctSize |
UT_HVAC_CrossSection |
UT_HVAC_HeatGain |
UT_Electrical_Current |
UT_Electrical_Potential |
UT_Electrical_Frequency |
UT_Electrical_Illuminance |
UT_Electrical_Luminous_Flux |
UT_Electrical_Power |
UT_HVAC_Roughness |
UT_Force |
UT_LinearForce |
UT_AreaForce |
UT_Moment |
UT_ForceScale |
UT_LinearForceScale |
UT_AreaForceScale |
UT_MomentScale |
UT_Electrical_Apparent_Power |
UT_Electrical_Power_Density |
UT_Piping_Density |
UT_Piping_Flow |
UT_Piping_Friction |
UT_Piping_Pressure |
UT_Piping_Temperature |
UT_Piping_Velocity |
UT_Piping_Viscosity |
UT_PipeSize |
UT_Piping_Roughness |
UT_Stress |
UT_UnitWeight |
UT_TemperalExp |
UT_LinearMoment |
UT_LinearMomentScale |
UT_ForcePerLength |
UT_ForceLengthPerAngle |
UT_LinearForcePerLength |
UT_LinearForceLengthPerAngle |
UT_AreaForcePerLength |
UT_Piping_Volume |
UT_HVAC_Viscosity |
UT_HVAC_CoefficientOfHeatTransfer |
UT_HVAC_Airflow_Density |
UT_Slope |
UT_HVAC_Cooling_Load |
UT_HVAC_Cooling_Load_Divided_By_Area |
UT_HVAC_Cooling_Load_Divided_By_Volume |
UT_HVAC_Heating_Load |
UT_HVAC_Heating_Load_Divided_By_Area |
UT_HVAC_Heating_Load_Divided_By_Volume |
UT_HVAC_Airflow_Divided_By_Volume |
UT_HVAC_Airflow_Divided_By_Cooling_Load |
UT_HVAC_Area_Divided_By_Cooling_Load |
UT_WireSize |
UT_HVAC_Slope |
UT_Piping_Slope |
UT_Currency |
UT_Electrical_Efficacy |
UT_Electrical_Wattage |
UT_Color_Temperature |
UT_DecSheetLength |
UT_Electrical_Luminous_Intensity |
UT_Electrical_Luminance |
UT_HVAC_Area_Divided_By_Heating_Load |
UT_HVAC_Factor |
UT_Electrical_Temperature |
UT_Electrical_CableTraySize |
UT_Electrical_ConduitSize |
UT_Reinforcement_Volume |
UT_Reinforcement_Length |
UT_Electrical_Demand_Factor |

See Also


UpdaterData Class

[image]

Revit 2011 API
UpdaterData Class
Members See Also Send Feedback
Service class that is passed to an Updater to prove access to update execution context

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class UpdaterData : IDisposable
Visual Basic (Declaration)
Public Class UpdaterData _
    Implements IDisposable
Visual C++
public ref class UpdaterData : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.UpdaterData

See Also

UpdaterData Members


UpdaterData Members

[image] [image]

Revit 2011 API
UpdaterData Members
UpdaterData Class Methods See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
GetDocument | Returns document associated with this UpdaterData
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterData Class


UpdaterData Methods

[image] [image]

Revit 2011 API
UpdaterData Methods
UpdaterData Class See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
GetDocument | Returns document associated with this UpdaterData
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterData Class


Dispose Method

[image]

Revit 2011 API
UpdaterData..::.Dispose Method
UpdaterData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

UpdaterData Class


GetAddedElementIds Method

[image]

Revit 2011 API
UpdaterData..::.GetAddedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic (Declaration)
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

Set of elements that were added to the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementAddition()

See Also

UpdaterData Class


GetDeletedElementIds Method

[image]

Revit 2011 API
UpdaterData..::.GetDeletedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetDeletedElementIds()
Visual Basic (Declaration)
Public Function GetDeletedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDeletedElementIds()

Return Value

Set of elements that were deleted from the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementDeletion()

See Also

UpdaterData Class


GetDocument Method

[image]

Revit 2011 API
UpdaterData..::.GetDocument Method
UpdaterData Class See Also Send Feedback
Returns document associated with this UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic (Declaration)
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

See Also

UpdaterData Class


GetModifiedElementIds Method

[image]

Revit 2011 API
UpdaterData..::.GetModifiedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetModifiedElementIds()
Visual Basic (Declaration)
Public Function GetModifiedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetModifiedElementIds()

Return Value

Set of elements that were modified in the document and triggered the call to execute() Note: This set only contains modified elements (i.e. it is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds()). It does not contain any elements that were added to or deleted from the document during the current transaction. Newly added/deleted elements will be reported by getAddedElementIds()/getDeletedElementIds(), even if they were also modified during the same transaction, but only if ChangeTypeElementAddition/Deletion is registered as a trigger for the current Updater. I.e. Element creation and modification in the same transaction is considered to be "creation" only. Newly created elements are not considered to be "modified" and are therefore not returned as part of getModifiedElementIds()

See Also

UpdaterData Class


IsChangeTriggered Method

[image]

Revit 2011 API
UpdaterData..::.IsChangeTriggered Method
UpdaterData Class See Also Send Feedback
Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsChangeTriggered(
    ElementId id,
    ChangeType type
)
Visual Basic (Declaration)
Public Function IsChangeTriggered ( _
    id As ElementId, _
    type As ChangeType _
) As Boolean
Visual C++
public:
bool IsChangeTriggered(
    ElementId^ id,
    ChangeType^ type
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
Id of element to check
type
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType to check

Return Value

True if ChangeType happened to specified element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterData Class


UpdaterId Class

[image]

Revit 2011 API
UpdaterId Class
Members See Also Send Feedback
A unique identifier of an Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class UpdaterId : IDisposable
Visual Basic (Declaration)
Public Class UpdaterId _
    Implements IDisposable
Visual C++
public ref class UpdaterId : IDisposable

Remarks

UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.UpdaterId

See Also

UpdaterId Members


UpdaterId Members

[image] [image]

Revit 2011 API
UpdaterId Members
UpdaterId Class Constructors Methods See Also Send Feedback

The UpdaterId type exposes the following members.

Constructors

Name | Description
UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddInId | AddInId of the UpdaterId
GetGUID | GUID value of the UpdaterId
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterId Class


UpdaterId Constructor

[image]

Revit 2011 API
UpdaterId Constructor
UpdaterId Class See Also Send Feedback
creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public UpdaterId(
    AddInId addInId,
    Guid val
)
Visual Basic (Declaration)
Public Sub New ( _
    addInId As AddInId, _
    val As Guid _
)
Visual C++
public:
UpdaterId(
    AddInId^ addInId,
    Guid val
)

Parameters

addInId
Type: Autodesk.Revit.DB..::.AddInId
Id of addin that registers an Updater
val
Type: System..::.Guid
a GUID identifying the Updater within addin

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterId Class


UpdaterId Methods

[image] [image]

Revit 2011 API
UpdaterId Methods
UpdaterId Class See Also Send Feedback

The UpdaterId type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddInId | AddInId of the UpdaterId
GetGUID | GUID value of the UpdaterId
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterId Class


Dispose Method

[image]

Revit 2011 API
UpdaterId..::.Dispose Method
UpdaterId Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

UpdaterId Class


GetAddInId Method

[image]

Revit 2011 API
UpdaterId..::.GetAddInId Method
UpdaterId Class See Also Send Feedback
AddInId of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AddInId GetAddInId()
Visual Basic (Declaration)
Public Function GetAddInId As AddInId
Visual C++
public:
AddInId^ GetAddInId()

See Also

UpdaterId Class


GetGUID Method

[image]

Revit 2011 API
UpdaterId..::.GetGUID Method
UpdaterId Class See Also Send Feedback
GUID value of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Guid GetGUID()
Visual Basic (Declaration)
Public Function GetGUID As Guid
Visual C++
public:
Guid GetGUID()

See Also

UpdaterId Class


UpdaterRegistry Class

[image]

Revit 2011 API
UpdaterRegistry Class
Members See Also Send Feedback
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class UpdaterRegistry : IDisposable
Visual Basic (Declaration)
Public Class UpdaterRegistry _
    Implements IDisposable
Visual C++
public ref class UpdaterRegistry : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.UpdaterRegistry

See Also

UpdaterRegistry Members


UpdaterRegistry Members

[image] [image]

Revit 2011 API
UpdaterRegistry Members
UpdaterRegistry Class Methods See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

Name | Description
AddTrigger | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUpdaterRegistered | Checks whether an updater with the given id is registered
RegisterUpdater | Overloaded.
RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class


UpdaterRegistry Methods

[image] [image]

Revit 2011 API
UpdaterRegistry Methods
UpdaterRegistry Class See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

Name | Description
AddTrigger | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUpdaterRegistered | Checks whether an updater with the given id is registered
RegisterUpdater | Overloaded.
RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class


AddTrigger Method

[image] [image]

Revit 2011 API
UpdaterRegistry..::.AddTrigger Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
AddTrigger(UpdaterId, Document, ICollection<(Of <(ElementId>)>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType

See Also

UpdaterRegistry Class
UpdaterRegistry Members


AddTrigger Method (UpdaterId, ElementFilter, ChangeType)

[image]

Revit 2011 API
UpdaterRegistry..::.AddTrigger Method (UpdaterId, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    ElementFilter filter,
    ChangeType change
)
Visual Basic (Declaration)
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater that trigger should be added to
filter
Type: Autodesk.Revit.DB..::.ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)

[image]

Revit 2011 API
UpdaterRegistry..::.AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document doc,
    ElementFilter filter,
    ChangeType change
)
Visual Basic (Declaration)
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    doc As Document, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ doc,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater that trigger should be added to
doc
Type: Autodesk.Revit.DB..::.Document
Document that elements in 'elements' are contained in
filter
Type: Autodesk.Revit.DB..::.ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ICollection(ElementId), ChangeType)

[image]

Revit 2011 API
UpdaterRegistry..::.AddTrigger Method (UpdaterId, Document, ICollection<(Of <(ElementId>)>), ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds a trigger to an updater with specified set of elements and ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document doc,
    ICollection<ElementId> elements,
    ChangeType change
)
Visual Basic (Declaration)
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    doc As Document, _
    elements As ICollection(Of ElementId), _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ doc,
    ICollection<ElementId^>^ elements,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater that trigger should be added to
doc
Type: Autodesk.Revit.DB..::.Document
Document that elements in 'elements' are contained in
elements
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
Set of elements which define this trigger
change
Type: Autodesk.Revit.DB..::.ChangeType
ChangeType associated with this trigger

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
AddTrigger Overload


Dispose Method

[image]

Revit 2011 API
UpdaterRegistry..::.Dispose Method
UpdaterRegistry Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

UpdaterRegistry Class


IsUpdaterRegistered Method

[image]

Revit 2011 API
UpdaterRegistry..::.IsUpdaterRegistered Method
UpdaterRegistry Class See Also Send Feedback
Checks whether an updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsUpdaterRegistered(
    UpdaterId id
)
Visual Basic (Declaration)
Public Shared Function IsUpdaterRegistered ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id to check in the registry

Return Value

Returns true if the updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


RegisterUpdater Method

[image] [image]

Revit 2011 API
UpdaterRegistry..::.RegisterUpdater Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
RegisterUpdater(IUpdater) | Registers an updater on an application level
RegisterUpdater(IUpdater, Document) | Registers the updater for the specified document

See Also

UpdaterRegistry Class
UpdaterRegistry Members


RegisterUpdater Method (IUpdater)

[image]

Revit 2011 API
UpdaterRegistry..::.RegisterUpdater Method (IUpdater)
UpdaterRegistry Class See Also Send Feedback
Registers an updater on an application level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater
)
Visual Basic (Declaration)
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater
)

Parameters

updater
Type: Autodesk.Revit.DB..::.IUpdater
Updater to be registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | updater's updaterId is not valid
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- updater is already registered on the application level
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Document)

[image]

Revit 2011 API
UpdaterRegistry..::.RegisterUpdater Method (IUpdater, Document)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document doc
)
Visual Basic (Declaration)
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    doc As Document _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ doc
)

Parameters

updater
Type: Autodesk.Revit.DB..::.IUpdater
Updater to be registered
doc
Type: Autodesk.Revit.DB..::.Document
Document for which this updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | updater's updaterId is not valid
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater is already registered for this document or on the application level -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RemoveAllTriggers Method

[image]

Revit 2011 API
UpdaterRegistry..::.RemoveAllTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveAllTriggers(
    UpdaterId id
)
Visual Basic (Declaration)
Public Shared Sub RemoveAllTriggers ( _
    id As UpdaterId _
)
Visual C++
public:
static void RemoveAllTriggers(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of specified updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


RemoveDocumentTriggers Method

[image]

Revit 2011 API
UpdaterRegistry..::.RemoveDocumentTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void RemoveDocumentTriggers(
    UpdaterId id,
    Document doc
)
Visual Basic (Declaration)
Public Shared Sub RemoveDocumentTriggers ( _
    id As UpdaterId, _
    doc As Document _
)
Visual C++
public:
static void RemoveDocumentTriggers(
    UpdaterId^ id,
    Document^ doc
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of specified updater
doc
Type: Autodesk.Revit.DB..::.Document
Document for which to remove triggers

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | updater's owner AddIn does not match currently active AddIn
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


SetExecutionOrder Method

[image]

Revit 2011 API
UpdaterRegistry..::.SetExecutionOrder Method
UpdaterRegistry Class See Also Send Feedback
Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void SetExecutionOrder(
    UpdaterId first,
    UpdaterId second
)
Visual Basic (Declaration)
Public Shared Sub SetExecutionOrder ( _
    first As UpdaterId, _
    second As UpdaterId _
)
Visual C++
public:
static void SetExecutionOrder(
    UpdaterId^ first,
    UpdaterId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::.UpdaterId
Id of first Updater
second
Type: Autodesk.Revit.DB..::.UpdaterId
Id of second Updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | The updaters do not report the same ChangePriority
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


UnregisterUpdater Method

[image]

Revit 2011 API
UpdaterRegistry..::.UnregisterUpdater Method
UpdaterRegistry Class See Also Send Feedback
Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void UnregisterUpdater(
    UpdaterId id
)
Visual Basic (Declaration)
Public Shared Sub UnregisterUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void UnregisterUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.UpdaterId
Id of updater to be removed

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Updater has not been registered -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


UV Class

[image]

Revit 2011 API
UV Class
Members See Also Send Feedback
Object representing coordinates in 2-dimensional space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class UV
Visual Basic (Declaration)
Public Class UV
Visual C++
public ref class UV

Remarks

Usually this means parameters on a surface. In actual use, it could be interpreted as either point or vector in 2-dimensional space.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.UV

See Also

UV Members


UV Members

[image] [image]

Revit 2011 API
UV Members
UV Class Constructors Methods Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

Name | Description
UV | Overloaded.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLength | The length of this 2-D vector.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

Name | Description
BasisU | The basis of the U axis.
BasisV | The basis of the V axis.
Item | Indexed access to coordinates.
U | Gets the first coordinate.
V | Gets the second coordinate.
Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class


UV Constructor

[image] [image]

Revit 2011 API
UV Constructor
UV Class See Also Send Feedback

Overload List

Name | Description
UV()()() | Creates a default UV with the values (0, 0).
UV(Double, Double) | Creates a UV with the supplied coordinates.

See Also

UV Class
UV Members


UV Constructor

[image]

Revit 2011 API
UV Constructor
UV Class See Also Send Feedback
Creates a default UV with the values (0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UV()

See Also

UV Class
UV Overload


UV Constructor (Double, Double)

[image]

Revit 2011 API
UV Constructor (Double, Double)
UV Class See Also Send Feedback
Creates a UV with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV(
    double u,
    double v
)
Visual Basic (Declaration)
Public Sub New ( _
    u As Double, _
    v As Double _
)
Visual C++
public:
UV(
    double u,
    double v
)

Parameters

u
Type: System..::.Double
The first coordinate.
v
Type: System..::.Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
UV Overload


UV Methods

[image] [image]

Revit 2011 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

Name | Description
Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Divide | Divides this 2-D vector by the specified value and returns the result.
DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLength | The length of this 2-D vector.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Negate | Negates this 2-D vector.
Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class


Add Method

[image]

Revit 2011 API
UV..::.Add Method
UV Class See Also Send Feedback
Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Add(
    UV source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Addition Operator

[image]

Revit 2011 API
UV..::.Addition Operator
UV Class See Also Send Feedback
Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::.UV
The first vector.
right
Type: Autodesk.Revit.DB..::.UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


AngleTo Method

[image]

Revit 2011 API
UV..::.AngleTo Method
UV Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AngleTo(
    UV source
)
Visual Basic (Declaration)
Public Function AngleTo ( _
    source As UV _
) As Double
Visual C++
public:
double AngleTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors in radians.

Remarks

The angle is measured counterclockwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


CrossProduct Method

[image]

Revit 2011 API
UV..::.CrossProduct Method
UV Class See Also Send Feedback
The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CrossProduct(
    UV source
)
Visual Basic (Declaration)
Public Function CrossProduct ( _
    source As UV _
) As Double
Visual C++
public:
double CrossProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is equivalent to the area of the parallelogram they span.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


DistanceTo Method

[image]

Revit 2011 API
UV..::.DistanceTo Method
UV Class See Also Send Feedback
Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DistanceTo(
    UV source
)
Visual Basic (Declaration)
Public Function DistanceTo ( _
    source As UV _
) As Double
Visual C++
public:
double DistanceTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Divide Method

[image]

Revit 2011 API
UV..::.Divide Method
UV Class See Also Send Feedback
Divides this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Divide(
    double value
)

Parameters

value
Type: System..::.Double
The value to divide this vector by.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is zero.

See Also

UV Class


Division Operator

[image]

Revit 2011 API
UV..::.Division Operator
UV Class See Also Send Feedback
Divides the specified 2-D vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator /(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator /(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::.UV
The value to divide the vector by.
value
Type: System..::.Double
The vector to divide by the value.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number or zero.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


DotProduct Method

[image]

Revit 2011 API
UV..::.DotProduct Method
UV Class See Also Send Feedback
The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DotProduct(
    UV source
)
Visual Basic (Declaration)
Public Function DotProduct ( _
    source As UV _
) As Double
Visual C++
public:
double DotProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


GetLength Method

[image]

Revit 2011 API
UV..::.GetLength Method
UV Class See Also Send Feedback
The length of this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetLength()
Visual Basic (Declaration)
Public Function GetLength As Double
Visual C++
public:
double GetLength()

Remarks

In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.

See Also

UV Class


IsAlmostEqualTo Method

[image] [image]

Revit 2011 API
UV..::.IsAlmostEqualTo Method
UV Class See Also Send Feedback

Overload List

Name | Description
IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

See Also

UV Class
UV Members


IsAlmostEqualTo Method (UV)

[image]

Revit 2011 API
UV..::.IsAlmostEqualTo Method (UV)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    UV source
)
Visual Basic (Declaration)
Public Function IsAlmostEqualTo ( _
    source As UV _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
IsAlmostEqualTo Overload


IsAlmostEqualTo Method (UV, Double)

[image]

Revit 2011 API
UV..::.IsAlmostEqualTo Method (UV, Double)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    UV source,
    double tolerance
)
Visual Basic (Declaration)
Public Function IsAlmostEqualTo ( _
    source As UV, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to compare with this vector.
tolerance
Type: System..::.Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when tolerance is less than 0.

See Also

UV Class
IsAlmostEqualTo Overload


IsUnitLength Method

[image]

Revit 2011 API
UV..::.IsUnitLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsUnitLength()
Visual Basic (Declaration)
Public Function IsUnitLength As Boolean
Visual C++
public:
bool IsUnitLength()

Remarks

A unit length vector has a length of one, and is considered normalized.

See Also

UV Class


IsZeroLength Method

[image]

Revit 2011 API
UV..::.IsZeroLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsZeroLength()
Visual Basic (Declaration)
Public Function IsZeroLength As Boolean
Visual C++
public:
bool IsZeroLength()

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

UV Class


Multiply Method

[image] [image]

Revit 2011 API
UV..::.Multiply Method
UV Class See Also Send Feedback

Overload List

Name | Description
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.

See Also

UV Class
UV Members


Multiply Operator

[image]

Revit 2011 API
UV..::.Multiply Operator
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator *(
    UV left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::.UV
The vector to multiply with the value.
value
Type: System..::.Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Multiply Operator

[image]

Revit 2011 API
UV..::.Multiply Operator
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator *(
    double value,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator *(
    double value,
    UV^ right
)

Parameters

value
Type: System..::.Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::.UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Multiply Method

[image]

Revit 2011 API
UV..::.Multiply Method
UV Class See Also Send Feedback
Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

UV Class


Negate Method

[image]

Revit 2011 API
UV..::.Negate Method
UV Class See Also Send Feedback
Negates this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Negate()
Visual Basic (Declaration)
Public Function Negate As UV
Visual C++
public:
UV^ Negate()

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

UV Class


Normalize Method

[image]

Revit 2011 API
UV..::.Normalize Method
UV Class See Also Send Feedback
Returns a new UV whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Normalize()
Visual Basic (Declaration)
Public Function Normalize As UV
Visual C++
public:
UV^ Normalize()

Return Value

The normalized UV or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

UV Class


Subtract Method

[image]

Revit 2011 API
UV..::.Subtract Method
UV Class See Also Send Feedback
Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public UV Subtract(
    UV source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Subtract(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV
The vector to subtract from this vector.

Return Value

The 2-D vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Subtraction Operator

[image]

Revit 2011 API
UV..::.Subtraction Operator
UV Class See Also Send Feedback
Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator -(
    UV left,
    UV right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::.UV
The first vector.
right
Type: Autodesk.Revit.DB..::.UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


ToString Method

[image]

Revit 2011 API
UV..::.ToString Method
UV Class See Also Send Feedback
Gets formatted string showing (U, V) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

UV Class


UnaryNegation Operator

[image]

Revit 2011 API
UV..::.UnaryNegation Operator
UV Class See Also Send Feedback
Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV operator -(
    UV source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.UV

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


UV Properties

[image] [image]

Revit 2011 API
UV Properties
UV Class See Also Send Feedback

The UV type exposes the following members.

Properties

Name | Description
BasisU | The basis of the U axis.
BasisV | The basis of the V axis.
Item | Indexed access to coordinates.
U | Gets the first coordinate.
V | Gets the second coordinate.
Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class


BasisU Property

[image]

Revit 2011 API
UV..::.BasisU Property
UV Class See Also Send Feedback
The basis of the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV BasisU { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisU As UV
Visual C++
public:
static property UV^ BasisU {
    UV^ get ();
}

Remarks

The basis of the U axis is the vector (1,0), the unit vector on the U axis.

See Also

UV Class


BasisV Property

[image]

Revit 2011 API
UV..::.BasisV Property
UV Class See Also Send Feedback
The basis of the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV BasisV { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisV As UV
Visual C++
public:
static property UV^ BasisV {
    UV^ get ();
}

Remarks

The basis of the V axis is the vector (0,1), the unit vector on the V axis.

See Also

UV Class


Item Property

[image]

Revit 2011 API
UV..::.Item Property
UV Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::.Int32
Use 0 for U and 1 for V.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when an attempt is made to access coordinates with an index that is larger than 1.

See Also

UV Class


U Property

[image]

Revit 2011 API
UV..::.U Property
UV Class See Also Send Feedback
Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double U { get; }
Visual Basic (Declaration)
Public ReadOnly Property U As Double
Visual C++
public:
property double U {
    double get ();
}

See Also

UV Class


V Property

[image]

Revit 2011 API
UV..::.V Property
UV Class See Also Send Feedback
Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double V { get; }
Visual Basic (Declaration)
Public ReadOnly Property V As Double
Visual C++
public:
property double V {
    double get ();
}

See Also

UV Class


Zero Property

[image]

Revit 2011 API
UV..::.Zero Property
UV Class See Also Send Feedback
The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static UV Zero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As UV
Visual C++
public:
static property UV^ Zero {
    UV^ get ();
}

Remarks

The zero vector is (0,0).

See Also

UV Class


VertexIndexPair Class

[image]

Revit 2011 API
VertexIndexPair Class
Members See Also Send Feedback
Represents a connection between vertices in the top and bottom profile of a blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VertexIndexPair
Visual Basic (Declaration)
Public Class VertexIndexPair
Visual C++
public ref class VertexIndexPair

Remarks

Use objects of this type in GetVertexConnectionMap()()(), SetVertexConnectionMap(VertexIndexPairArray), GetVertexConnectionMap()()() and SetVertexConnectionMap(VertexIndexPairArray) to get/set the vertex connection map.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.VertexIndexPair

See Also

VertexIndexPair Members


VertexIndexPair Members

[image] [image]

Revit 2011 API
VertexIndexPair Members
VertexIndexPair Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPair type exposes the following members.

Constructors

Name | Description
VertexIndexPair | Initializes a new instance of the VertexIndexPair class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bottom | The index of the vertex pair from the bottom profile.
Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


VertexIndexPair Constructor

[image]

Revit 2011 API
VertexIndexPair Constructor
VertexIndexPair Class See Also Send Feedback
Initializes a new instance of the VertexIndexPair class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic (Declaration)
Public Sub New ( _
    iTop As Integer, _
    iBottom As Integer _
)
Visual C++
public:
VertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::.Int32
iBottom
Type: System..::.Int32

See Also

VertexIndexPair Class


VertexIndexPair Methods

[image] [image]

Revit 2011 API
VertexIndexPair Methods
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPair Class


VertexIndexPair Properties

[image] [image]

Revit 2011 API
VertexIndexPair Properties
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Properties

Name | Description
Bottom | The index of the vertex pair from the bottom profile.
Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


Bottom Property

[image]

Revit 2011 API
VertexIndexPair..::.Bottom Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the bottom profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Integer
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


Top Property

[image]

Revit 2011 API
VertexIndexPair..::.Top Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the top profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


VertexIndexPairArray Class

[image]

Revit 2011 API
VertexIndexPairArray Class
Members See Also Send Feedback
An array that contains VertexIndex pairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VertexIndexPairArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class VertexIndexPairArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VertexIndexPairArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.VertexIndexPairArray

See Also

VertexIndexPairArray Members


VertexIndexPairArray Members

[image] [image]

Revit 2011 API
VertexIndexPairArray Members
VertexIndexPairArray Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Constructors

Name | Description
VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class

Methods

Name | Description
Append |
Clear | Removes every VertexIndex pair from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a VertexIndex pair at a specified index within the array.
Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class


VertexIndexPairArray Constructor

[image]

Revit 2011 API
VertexIndexPairArray Constructor
VertexIndexPairArray Class See Also Send Feedback
Initializes a new instance of the VertexIndexPairArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPairArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VertexIndexPairArray()

See Also

VertexIndexPairArray Class


VertexIndexPairArray Methods

[image] [image]

Revit 2011 API
VertexIndexPairArray Methods
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every VertexIndex pair from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArray Class


Append Method

[image]

Revit 2011 API
VertexIndexPairArray..::.Append Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    VertexIndexPair item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As VertexIndexPair _
)
Visual C++
public:
virtual void Append(
    VertexIndexPair^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.VertexIndexPair

See Also

VertexIndexPairArray Class


Clear Method

[image]

Revit 2011 API
VertexIndexPairArray..::.Clear Method
VertexIndexPairArray Class See Also Send Feedback
Removes every VertexIndex pair from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VertexIndexPairArray Class


ForwardIterator Method

[image]

Revit 2011 API
VertexIndexPairArray..::.ForwardIterator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

VertexIndexPairArray Class


GetEnumerator Method

[image]

Revit 2011 API
VertexIndexPairArray..::.GetEnumerator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

VertexIndexPairArray Class


Insert Method

[image]

Revit 2011 API
VertexIndexPairArray..::.Insert Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    VertexIndexPair item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As VertexIndexPair, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    VertexIndexPair^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::.VertexIndexPair
index
Type: System..::.Int32

See Also

VertexIndexPairArray Class


ReverseIterator Method

[image]

Revit 2011 API
VertexIndexPairArray..::.ReverseIterator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

VertexIndexPairArray Class


VertexIndexPairArray Properties

[image] [image]

Revit 2011 API
VertexIndexPairArray Properties
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a VertexIndex pair at a specified index within the array.
Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class


IsEmpty Property

[image]

Revit 2011 API
VertexIndexPairArray..::.IsEmpty Property
VertexIndexPairArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

VertexIndexPairArray Class


Item Property

[image]

Revit 2011 API
VertexIndexPairArray..::.Item Property
VertexIndexPairArray Class See Also Send Feedback
Gets or sets a VertexIndex pair at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual VertexIndexPair Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As VertexIndexPair
Visual C++
public:
virtual property VertexIndexPair^ Item[int index] {
    VertexIndexPair^ get (int index);
    void set (int index, VertexIndexPair^ value);
}

Parameters

index
Type: System..::.Int32
The index of the VertexIndex pair to be set or retrieved.

Return Value

Returns the VertexIndex pair at the specified index.

See Also

VertexIndexPairArray Class


Size Property

[image]

Revit 2011 API
VertexIndexPairArray..::.Size Property
VertexIndexPairArray Class See Also Send Feedback
Returns the number of VertexIndex pairs that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VertexIndexPairArray Class


VertexIndexPairArrayIterator Class

[image]

Revit 2011 API
VertexIndexPairArrayIterator Class
Members See Also Send Feedback
An iterator to an array of VertexIndex pairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class VertexIndexPairArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class VertexIndexPairArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VertexIndexPairArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.VertexIndexPairArrayIterator

See Also

VertexIndexPairArrayIterator Members


VertexIndexPairArrayIterator Members

[image] [image]

Revit 2011 API
VertexIndexPairArrayIterator Members
VertexIndexPairArrayIterator Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Constructors

Name | Description
VertexIndexPairArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Constructor

[image]

Revit 2011 API
VertexIndexPairArrayIterator Constructor
VertexIndexPairArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VertexIndexPairArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VertexIndexPairArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Methods

[image] [image]

Revit 2011 API
VertexIndexPairArrayIterator Methods
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArrayIterator Class


MoveNext Method

[image]

Revit 2011 API
VertexIndexPairArrayIterator..::.MoveNext Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


Reset Method

[image]

Revit 2011 API
VertexIndexPairArrayIterator..::.Reset Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Properties

[image] [image]

Revit 2011 API
VertexIndexPairArrayIterator Properties
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


Current Property

[image]

Revit 2011 API
VertexIndexPairArrayIterator..::.Current Property
VertexIndexPairArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


VerticalAlignmentStyle Enumeration

[image]

Revit 2011 API
VerticalAlignmentStyle Enumeration
See Also Send Feedback
Declares the vertical alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum VerticalAlignmentStyle
Visual Basic (Declaration)
Public Enumeration VerticalAlignmentStyle
Visual C++
public enum class VerticalAlignmentStyle

Members

Member name | Description
Top | Alignment to top
Middle | Alignment to middle
Bottom | Alignment to bottom

See Also


View Class

[image]

Revit 2011 API
View Class
Members Example See Also Send Feedback
Base class for all types of views in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class View : Element
Visual Basic (Declaration)
Public Class View _
    Inherits Element
Visual C++
public ref class View : public Element

Remarks

A view can display an image produced from a Revit model. Views can be graphical (e.g. plans, elevations, or 3D views) or textual (e.g. schedules). Views keep track of Elements that can be seen in them.

Examples

CopyC#
private void Getinfo_View(Autodesk.Revit.DB.View view)
{
    string message = "View: ";

    //get the name of the view
    message += "\nView name: " + view.ViewName;

    //The crop box sets display bounds of the view
    BoundingBoxXYZ cropBox = view.CropBox;
    XYZ max = cropBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = cropBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nCrop Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

   //get the origin of the screen
    XYZ origin = view.Origin;
    message += "\nOrigin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")";

    //The bounds of the view in paper space (in inches).
    BoundingBoxUV outline = view.Outline;
    UV maxUv = outline.Max; //Maximum coordinates (upper-right corner of the box).
    UV minUv = outline.Min; //Minimum coordinates (lower-left corner of the box).
    message += "\nOutline: ";
    message += "\nMaximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")";
    message += "\nMinimum coordinates: (" + minUv.U + ", " + minUv.V + ")";

    //The direction towards the right side of the screen
    XYZ rightDirection = view.RightDirection;
    message += "\nRight direction: (" + rightDirection.X + ", " +
                   rightDirection.Y + ", " + rightDirection.Z + ")";

    //The direction towards the top of the screen
    XYZ upDirection = view.UpDirection;
    message += "\nUp direction: (" + upDirection.X + ", " +
                   upDirection.Y + ", " + upDirection.Z + ")";

    //The direction towards the viewer
    XYZ viewDirection = view.ViewDirection;
    message += "\nView direction: (" + viewDirection.X + ", " +
                   viewDirection.Y + ", " + viewDirection.Z + ")";

    //The scale of the view
    message += "\nScale: " + view.Scale;
    // Scale is meaningless for Schedules
    if (view.ViewType != ViewType.Schedule)
    {
        int testScale = 5;
        //set the scale of the view
        view.Scale = testScale;
        message += "\nScale after set: " + view.Scale;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_View(ByVal view As Autodesk.Revit.DB.View)
    Dim message As String = "View: "

    'get the name of the view
    message += vbLf & "View name: " + view.ViewName

    'The crop box sets display bounds of the view
    Dim cropBox As BoundingBoxXYZ = view.CropBox
    Dim max As Autodesk.Revit.DB.XYZ = cropBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.DB.XYZ = cropBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Crop Box: "
    message += vbLf & "Maximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")"
    message += vbLf & "Minimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")"

    'get the origin of the screen
    Dim origin As Autodesk.Revit.DB.XYZ = view.Origin
    message += vbLf & "Origin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")"

    'The bounds of the view in paper space (in inches).
    Dim outline As BoundingBoxUV = view.Outline
    Dim maxUv As Autodesk.Revit.DB.UV = outline.Max
    'Maximum coordinates (upper-right corner of the box).
    Dim minUv As Autodesk.Revit.DB.UV = outline.Min
    'Minimum coordinates (lower-left corner of the box).
    message += vbLf & "Outline: "
    message += vbLf & "Maximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")"
    message += vbLf & "Minimum coordinates: (" + minUv.U + ", " + minUv.V + ")"

    'The direction towards the right side of the screen
    Dim rightDirection As Autodesk.Revit.DB.XYZ = view.RightDirection
    message += vbLf & "Right direction: (" + rightDirection.X + ", " + rightDirection.Y + ", " + rightDirection.Z + ")"

    'The direction towards the top of the screen
    Dim upDirection As Autodesk.Revit.DB.XYZ = view.UpDirection
    message += vbLf & "Up direction: (" + upDirection.X + ", " + upDirection.Y + ", " + upDirection.Z + ")"

    'The direction towards the viewer
    Dim viewDirection As Autodesk.Revit.DB.XYZ = view.ViewDirection
    message += vbLf & "View direction: (" + viewDirection.X + ", " + viewDirection.Y + ", " + viewDirection.Z + ")"

    'The scale of the view
    message += vbLf & "Scale: " + view.Scale
    ' Scale is meaningless for Schedules
    If view.ViewType <> Autodesk.Revit.DB.ViewType.Schedule Then
        Dim testScale As Integer = 5
        'set the scale of the view
        view.Scale = testScale
        message += vbLf & "Scale after set: " + view.Scale
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.TableView
Autodesk.Revit.DB..::.View3D
Autodesk.Revit.DB..::.ViewDrafting
Autodesk.Revit.DB..::.ViewPlan
Autodesk.Revit.DB..::.ViewSection
Autodesk.Revit.DB..::.ViewSheet

See Also

View Members


View Members

[image] [image]

Revit 2011 API
View Members
View Class Methods Properties See Also Send Feedback

The View type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view.
Hide | Sets the elements to be hidden in the view.
HideActiveWorkPlane | Hide the active work plane of the view.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view.
ShowActiveWorkPlane | Show the active work plane of the view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view.

See Also

View Class


View Methods

[image] [image]

Revit 2011 API
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view.
Hide | Sets the elements to be hidden in the view.
HideActiveWorkPlane | Hide the active work plane of the view.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view.
ShowActiveWorkPlane | Show the active work plane of the view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden.

See Also

View Class


ApplyTemplate Method

[image]

Revit 2011 API
View..::.ApplyTemplate Method
View Class See Also Send Feedback
Applies a view template to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ApplyTemplate(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub ApplyTemplate ( _
    viewTemplate As View _
)
Visual C++
public:
void ApplyTemplate(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::.View
View to be used as the template.

See Also

View Class


getVisibility Method

[image]

Revit 2011 API
View..::.getVisibility Method
View Class See Also Send Feedback
Checks if elements of the given category are set to be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool getVisibility(
    Category category
)
Visual Basic (Declaration)
Public Function getVisibility ( _
    category As Category _
) As Boolean
Visual C++
public:
bool getVisibility(
    Category^ category
)

Parameters

category
Type: Autodesk.Revit.DB..::.Category
The category.

See Also

View Class


Hide Method

[image]

Revit 2011 API
View..::.Hide Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Hide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Hide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Hide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents. To hide a group, obtain the elements in the group from Members, and hide these elements individually. To hide an array, obtain the groups in the array from OrigMembers and CopyMembers, then hide elements in the groups individually.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


HideActiveWorkPlane Method

[image]

Revit 2011 API
View..::.HideActiveWorkPlane Method
View Class See Also Send Feedback
Hide the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void HideActiveWorkPlane()
Visual Basic (Declaration)
Public Sub HideActiveWorkPlane
Visual C++
public:
void HideActiveWorkPlane()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.

See Also

View Class


Print Method

[image] [image]

Revit 2011 API
View..::.Print Method
View Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template.
Print(View) | Print this view with default print settings and specialized view template.
Print(Boolean) | Print this view with default print settings and view template.
Print(View, Boolean) | Print this view with current print settings and specialized view template.

See Also

View Class
View Members


Print Method

[image]

Revit 2011 API
View..::.Print Method
View Class See Also Send Feedback
Print this view with default print settings and default view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View)

[image]

Revit 2011 API
View..::.Print Method (View)
View Class See Also Send Feedback
Print this view with default print settings and specialized view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::.View
The view template which apply to the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (Boolean)

[image]

Revit 2011 API
View..::.Print Method (Boolean)
View Class See Also Send Feedback
Print this view with default print settings and view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View, Boolean)

[image]

Revit 2011 API
View..::.Print Method (View, Boolean)
View Class See Also Send Feedback
Print this view with current print settings and specialized view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::.View
The view template which apply to the view.
useCurrentPrintSettings
Type: System..::.Boolean
If true, print the view with the current print settings; otherwise with the print settings of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


setVisibility Method

[image]

Revit 2011 API
View..::.setVisibility Method
View Class See Also Send Feedback
Set if elements of the given category will be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void setVisibility(
    Category category,
    bool visible
)
Visual Basic (Declaration)
Public Sub setVisibility ( _
    category As Category, _
    visible As Boolean _
)
Visual C++
public:
void setVisibility(
    Category^ category,
    bool visible
)

Parameters

category
Type: Autodesk.Revit.DB..::.Category
The category.
visible
Type: System..::.Boolean
True to make elements of this category visible, false to make them invisible.

See Also

View Class


ShowActiveWorkPlane Method

[image]

Revit 2011 API
View..::.ShowActiveWorkPlane Method
View Class See Also Send Feedback
Show the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ShowActiveWorkPlane()
Visual Basic (Declaration)
Public Sub ShowActiveWorkPlane
Visual C++
public:
void ShowActiveWorkPlane()

Remarks

If this method is invoked while the current work plane is hidden, only the outline of the updated work plane will be shown immediately. The updated sketch plane will be shown fully after the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.

See Also

View Class


Unhide Method

[image]

Revit 2011 API
View..::.Unhide Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Unhide(
    ElementSet elemSet
)
Visual Basic (Declaration)
Public Sub Unhide ( _
    elemSet As ElementSet _
)
Visual C++
public:
void Unhide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit.DB..::.ElementSet
A set of elements to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


View Properties

[image] [image]

Revit 2011 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view.
CropBoxActive | Whether or not the Crop Box/Region is active for the view.
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
CutColorOverrideByElement | Override the cut lines' color by Element in this view.
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen.
Outline | The bounds of the view in paper space (in inches).
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
RightDirection | The direction towards the right side of the screen.
Scale | The scale of the view.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation.
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen.
ViewDirection | The direction towards the viewer.
ViewName | The name of the view.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view.

See Also

View Class


AnalysisDisplayStyleId Property

[image]

Revit 2011 API
View..::.AnalysisDisplayStyleId Property
View Class See Also Send Feedback
Element id of Analysis Display Style associated with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId AnalysisDisplayStyleId { get; set; }
Visual Basic (Declaration)
Public Property AnalysisDisplayStyleId As ElementId
Visual C++
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

View Class


CanBePrinted Property

[image]

Revit 2011 API
View..::.CanBePrinted Property
View Class See Also Send Feedback
Test whether the view can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CanBePrinted { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanBePrinted As Boolean
Visual C++
public:
property bool CanBePrinted {
    bool get ();
}

See Also

View Class


CropBox Property

[image]

Revit 2011 API
View..::.CropBox Property
View Class See Also Send Feedback
The crop box applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ CropBox { get; set; }
Visual Basic (Declaration)
Public Property CropBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the view is a template.

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user.

See Also

View Class


CropBoxActive Property

[image]

Revit 2011 API
View..::.CropBoxActive Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CropBoxActive { get; set; }
Visual Basic (Declaration)
Public Property CropBoxActive As Boolean
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the crop region modifies the graphical appearance of elements in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


CropBoxVisible Property

[image]

Revit 2011 API
View..::.CropBoxVisible Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is visible for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CropBoxVisible { get; set; }
Visual Basic (Declaration)
Public Property CropBoxVisible As Boolean
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


CutColorOverrideByElement Property

[image]

Revit 2011 API
View..::.CutColorOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' color by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color CutColorOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutColorOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Color
Visual C++
public:
property Color^ CutColorOverrideByElement[ICollection<ElementId^>^ ids] {
    Color^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, Color^ value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


CutLinePatternOverrideByElement Property

[image]

Revit 2011 API
View..::.CutLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' pattern by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePattern CutLinePatternOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutLinePatternOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As LinePattern
Visual C++
public:
property LinePattern^ CutLinePatternOverrideByElement[ICollection<ElementId^>^ ids] {
    LinePattern^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, LinePattern^ value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


CutLineWeightOverrideByElement Property

[image]

Revit 2011 API
View..::.CutLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int CutLineWeightOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property CutLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
Visual C++
public:
property int CutLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class


GenLevel Property

[image]

Revit 2011 API
View..::.GenLevel Property
View Class See Also Send Feedback
The level for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level GenLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property GenLevel As Level
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This will obtain the level for views related to levels, such as Plan Views. If this View is not generated by a level, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

View Class


IsTemplate Property

[image]

Revit 2011 API
View..::.IsTemplate Property
View Class See Also Send Feedback
Test whether the view is a view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsTemplate { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTemplate As Boolean
Visual C++
public:
property bool IsTemplate {
    bool get ();
}

See Also

View Class


Origin Property

[image]

Revit 2011 API
View..::.Origin Property
View Class See Also Send Feedback
Returns the origin of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the view is a template.

See Also

View Class


Outline Property

[image]

Revit 2011 API
View..::.Outline Property
View Class See Also Send Feedback
The bounds of the view in paper space (in inches).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxUV Outline { get; }
Visual Basic (Declaration)
Public ReadOnly Property Outline As BoundingBoxUV
Visual C++
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}

Remarks

Returns all zeros for empty views.

See Also

View Class


Parameter Property

[image] [image]

Revit 2011 API
View..::.Parameter Property
View Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

View Class
View Members


ProjColorOverrideByElement Property

[image]

Revit 2011 API
View..::.ProjColorOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' color by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Color ProjColorOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjColorOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Color
Visual C++
public:
property Color^ ProjColorOverrideByElement[ICollection<ElementId^>^ ids] {
    Color^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, Color^ value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


ProjLinePatternOverrideByElement Property

[image]

Revit 2011 API
View..::.ProjLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' pattern by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LinePattern ProjLinePatternOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjLinePatternOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As LinePattern
Visual C++
public:
property LinePattern^ ProjLinePatternOverrideByElement[ICollection<ElementId^>^ ids] {
    LinePattern^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, LinePattern^ value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


ProjLineWeightOverrideByElement Property

[image]

Revit 2011 API
View..::.ProjLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int ProjLineWeightOverrideByElement[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic (Declaration)
Public Property ProjLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
Visual C++
public:
property int ProjLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class


RightDirection Property

[image]

Revit 2011 API
View..::.RightDirection Property
View Class See Also Send Feedback
The direction towards the right side of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ RightDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightDirection As XYZ
Visual C++
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}

See Also

View Class


Scale Property

[image]

Revit 2011 API
View..::.Scale Property
View Class See Also Send Feedback
The scale of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Integer
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.

See Also

View Class


SketchPlane Property

[image]

Revit 2011 API
View..::.SketchPlane Property
View Class See Also Send Feedback
The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; set; }
Visual Basic (Declaration)
Public Property SketchPlane As SketchPlane
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Field Value

The sketch plane, or nullNothingnullptra null reference (Nothing in Visual Basic) for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.

Remarks

If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur.

See Also

View Class


SunAndShadowSettings Property

[image]

Revit 2011 API
View..::.SunAndShadowSettings Property
View Class See Also Send Feedback
The sun and shadow settings assigned to the view for shadow calculation and rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowSettings SunAndShadowSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property SunAndShadowSettings As SunAndShadowSettings
Visual C++
public:
property SunAndShadowSettings^ SunAndShadowSettings {
    SunAndShadowSettings^ get ();
}

Field Value

The sun and shadow settings, or null for views which don't allow this (such as schedules).

See Also

View Class


UpDirection Property

[image]

Revit 2011 API
View..::.UpDirection Property
View Class See Also Send Feedback
The direction towards the top of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpDirection As XYZ
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

View Class


ViewDirection Property

[image]

Revit 2011 API
View..::.ViewDirection Property
View Class See Also Send Feedback
The direction towards the viewer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ ViewDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewDirection As XYZ
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class


ViewName Property

[image]

Revit 2011 API
View..::.ViewName Property
View Class See Also Send Feedback
The name of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ViewName { get; set; }
Visual Basic (Declaration)
Public Property ViewName As String
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if the name provided already exists, or is invalid for this view.

See Also

View Class


ViewType Property

[image]

Revit 2011 API
View..::.ViewType Property
View Class Example See Also Send Feedback
The type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewType ViewType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewType As ViewType
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

Examples

CopyC#
public void GetViewType(Autodesk.Revit.DB.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case ViewType.Detail:
            prompt += "a detail view.";
            break;
        case ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case ViewType.Legend:
            prompt += "a legend view.";
            break;
        case ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case ViewType.Report:
            prompt += "a report view.";
            break;
        case ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case ViewType.Section:
            prompt += "a cross section view.";
            break;
        case ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub GetViewType(ByVal view As Autodesk.Revit.DB.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As [String] = "The view is "

    Select Case view.ViewType
        Case Autodesk.Revit.DB.ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Report
            prompt += "a report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

View Class


View3D Class

[image]

Revit 2011 API
View3D Class
Members Example See Also Send Feedback
A freely-oriented orthographic or perspective view of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class View3D : View
Visual Basic (Declaration)
Public Class View3D _
    Inherits View
Visual C++
public ref class View3D : public View

Examples

CopyC#
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";
    // The position of the camera.
    XYZ eyePosition = view3D.EyePosition;
    message += "\nCamera position: (" + eyePosition.X + ", " +
                eyePosition.Y + ", " + eyePosition.Z + ")";

    // Identifies whether this is a perspective view.
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective.";
    }

    // The section box of the 3D view cuts the model by its bounds.
    BoundingBoxXYZ sectionBox = view3D.SectionBox;
    XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nSection Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_View3D(ByVal view3D As View3D)
    Dim message As String = "View3D: "
    ' The position of the camera.
    Dim eyePosition As Autodesk.Revit.DB.XYZ = view3D.EyePosition
    message += vbLf & "Camera position: (" + eyePosition.X + ", " + eyePosition.Y + ", " + eyePosition.Z + ")"

    ' Identifies whether this is a perspective view.
    If view3D.IsPerspective Then
        message += vbLf & "The view is a perspective."
    End If

    ' The section box of the 3D view cuts the model by its bounds.
    Dim sectionBox As BoundingBoxXYZ = view3D.SectionBox
    Dim max As Autodesk.Revit.DB.XYZ = sectionBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.DB.XYZ = sectionBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Section Box: "
    message += vbLf & "Maximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")"
    message += vbLf & "Minimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.View3D

See Also

View3D Members


View3D Members

[image] [image]

Revit 2011 API
View3D Members
View3D Class Methods Properties See Also Send Feedback

The View3D type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EyePosition | The position of the camera.
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPerspective | Identifies whether this is a perspective view.
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SectionBox | The section box of the 3D view cuts the model by its bounds.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

View3D Class


View3D Methods

[image] [image]

Revit 2011 API
View3D Methods
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

View3D Class


Print Method

[image] [image]

Revit 2011 API
View3D..::.Print Method
View3D Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

View3D Class
View3D Members


View3D Properties

[image] [image]

Revit 2011 API
View3D Properties
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EyePosition | The position of the camera.
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPerspective | Identifies whether this is a perspective view.
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SectionBox | The section box of the 3D view cuts the model by its bounds.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

View3D Class


EyePosition Property

[image]

Revit 2011 API
View3D..::.EyePosition Property
View3D Class See Also Send Feedback
The position of the camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property EyePosition As XYZ
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The view is a template and does not have an eye position applied.

See Also

View3D Class


IsPerspective Property

[image]

Revit 2011 API
View3D..::.IsPerspective Property
View3D Class See Also Send Feedback
Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPerspective { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPerspective As Boolean
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The view is a template and does not have a perspective setting applied.

See Also

View3D Class


Parameter Property

[image] [image]

Revit 2011 API
View3D..::.Parameter Property
View3D Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

View3D Class
View3D Members


SectionBox Property

[image]

Revit 2011 API
View3D..::.SectionBox Property
View3D Class See Also Send Feedback
The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundingBoxXYZ SectionBox { get; set; }
Visual Basic (Declaration)
Public Property SectionBox As BoundingBoxXYZ
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in nullNothingnullptra null reference (Nothing in Visual Basic) or a disabled box. Individual bound enabled flags are currently ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when getting this property, if the view is a template and does not have a section box applied.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a section box applied.

See Also

View3D Class


ViewDrafting Class

[image]

Revit 2011 API
ViewDrafting Class
Members See Also Send Feedback
A drafting view allows the user to draw graphics without including them in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewDrafting : View
Visual Basic (Declaration)
Public Class ViewDrafting _
    Inherits View
Visual C++
public ref class ViewDrafting : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewDrafting

See Also

ViewDrafting Members


ViewDrafting Members

[image] [image]

Revit 2011 API
ViewDrafting Members
ViewDrafting Class Methods Properties See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting Class


ViewDrafting Methods

[image] [image]

Revit 2011 API
ViewDrafting Methods
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewDrafting Class


Print Method

[image] [image]

Revit 2011 API
ViewDrafting..::.Print Method
ViewDrafting Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewDrafting Class
ViewDrafting Members


ViewDrafting Properties

[image] [image]

Revit 2011 API
ViewDrafting Properties
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewDrafting Class


Parameter Property

[image] [image]

Revit 2011 API
ViewDrafting..::.Parameter Property
ViewDrafting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewDrafting Class
ViewDrafting Members


ViewPlan Class

[image]

Revit 2011 API
ViewPlan Class
Members See Also Send Feedback
A plan represents for floor plan or ceiling plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewPlan : View
Visual Basic (Declaration)
Public Class ViewPlan _
    Inherits View
Visual C++
public ref class ViewPlan : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewPlan

See Also

ViewPlan Members


ViewPlan Members

[image] [image]

Revit 2011 API
ViewPlan Members
ViewPlan Class Methods Properties See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
AreaScheme | The area scheme.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewPlan Class


ViewPlan Methods

[image] [image]

Revit 2011 API
ViewPlan Methods
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewPlan Class


Print Method

[image] [image]

Revit 2011 API
ViewPlan..::.Print Method
ViewPlan Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewPlan Class
ViewPlan Members


ViewPlan Properties

[image] [image]

Revit 2011 API
ViewPlan Properties
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
AreaScheme | The area scheme.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewPlan Class


AreaScheme Property

[image]

Revit 2011 API
ViewPlan..::.AreaScheme Property
ViewPlan Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaScheme As AreaScheme
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

Field Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if this plan view is not an area plan.

See Also

ViewPlan Class


Parameter Property

[image] [image]

Revit 2011 API
ViewPlan..::.Parameter Property
ViewPlan Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewPlan Class
ViewPlan Members


ViewPlanType Enumeration

[image]

Revit 2011 API
ViewPlanType Enumeration
See Also Send Feedback
An enumerated type listing plan view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ViewPlanType
Visual Basic (Declaration)
Public Enumeration ViewPlanType
Visual C++
public enum class ViewPlanType

Members

Member name | Description
FloorPlan | Floor plan view.
CeilingPlan | Reflected ceiling plan view.

See Also


ViewSection Class

[image]

Revit 2011 API
ViewSection Class
Members See Also Send Feedback
A section view cuts through the model to expose its interior structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSection : View
Visual Basic (Declaration)
Public Class ViewSection _
    Inherits View
Visual C++
public ref class ViewSection : public View

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewSection

See Also

ViewSection Members


ViewSection Members

[image] [image]

Revit 2011 API
ViewSection Members
ViewSection Class Methods Properties See Also Send Feedback

The ViewSection type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection Class


ViewSection Methods

[image] [image]

Revit 2011 API
ViewSection Methods
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Methods

Name | Description
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSection Class


Print Method

[image] [image]

Revit 2011 API
ViewSection..::.Print Method
ViewSection Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewSection Class
ViewSection Members


ViewSection Properties

[image] [image]

Revit 2011 API
ViewSection Properties
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSection Class


Parameter Property

[image] [image]

Revit 2011 API
ViewSection..::.Parameter Property
ViewSection Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSection Class
ViewSection Members


ViewSet Class

[image]

Revit 2011 API
ViewSet Class
Members See Also Send Feedback
A set that contains views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class ViewSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ViewSet

See Also

ViewSet Members


ViewSet Members

[image] [image]

Revit 2011 API
ViewSet Members
ViewSet Class Constructors Methods Properties See Also Send Feedback

The ViewSet type exposes the following members.

Constructors

Name | Description
ViewSet | Initializes a new instance of the ViewSet class

Methods

Name | Description
Clear | Removes every view from the set, rendering it empty.
Contains | Tests for the existence of a view within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified view from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified view into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of views that are in the set.

See Also

ViewSet Class


ViewSet Constructor

[image]

Revit 2011 API
ViewSet Constructor
ViewSet Class See Also Send Feedback
Initializes a new instance of the ViewSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSet()

See Also

ViewSet Class


ViewSet Methods

[image] [image]

Revit 2011 API
ViewSet Methods
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Methods

Name | Description
Clear | Removes every view from the set, rendering it empty.
Contains | Tests for the existence of a view within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified view from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified view into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSet Class


Clear Method

[image]

Revit 2011 API
ViewSet..::.Clear Method
ViewSet Class See Also Send Feedback
Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSet Class


Contains Method

[image]

Revit 2011 API
ViewSet..::.Contains Method
ViewSet Class See Also Send Feedback
Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Contains(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.View
The view to be searched for.

Return Value

The Contains method returns True if the view is within the set, otherwise False.

See Also

ViewSet Class


Erase Method

[image]

Revit 2011 API
ViewSet..::.Erase Method
ViewSet Class See Also Send Feedback
Removes a specified view from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As View _
) As Integer
Visual C++
public:
virtual int Erase(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.View
The view to be erased.

Return Value

The number of views that were erased from the set.

See Also

ViewSet Class


ForwardIterator Method

[image]

Revit 2011 API
ViewSet..::.ForwardIterator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class


GetEnumerator Method

[image]

Revit 2011 API
ViewSet..::.GetEnumerator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ViewSet Class


Insert Method

[image]

Revit 2011 API
ViewSet..::.Insert Method
ViewSet Class See Also Send Feedback
Insert the specified view into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    View item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Insert(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.View
The view to be inserted into the set.

Return Value

Returns whether the view was inserted into the set.

See Also

ViewSet Class


ReverseIterator Method

[image]

Revit 2011 API
ViewSet..::.ReverseIterator Method
ViewSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSet Class


ViewSet Properties

[image] [image]

Revit 2011 API
ViewSet Properties
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of views that are in the set.

See Also

ViewSet Class


IsEmpty Property

[image]

Revit 2011 API
ViewSet..::.IsEmpty Property
ViewSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSet Class


Size Property

[image]

Revit 2011 API
ViewSet..::.Size Property
ViewSet Class See Also Send Feedback
Returns the number of views that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSet Class


ViewSetIterator Class

[image]

Revit 2011 API
ViewSetIterator Class
Members See Also Send Feedback
An iterator to a view set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ViewSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ViewSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ViewSetIterator

See Also

ViewSetIterator Members


ViewSetIterator Members

[image] [image]

Revit 2011 API
ViewSetIterator Members
ViewSetIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSetIterator type exposes the following members.

Constructors

Name | Description
ViewSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class


ViewSetIterator Constructor

[image]

Revit 2011 API
ViewSetIterator Constructor
ViewSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSetIterator Class


ViewSetIterator Methods

[image] [image]

Revit 2011 API
ViewSetIterator Methods
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSetIterator Class


MoveNext Method

[image]

Revit 2011 API
ViewSetIterator..::.MoveNext Method
ViewSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSetIterator Class


Reset Method

[image]

Revit 2011 API
ViewSetIterator..::.Reset Method
ViewSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSetIterator Class


ViewSetIterator Properties

[image] [image]

Revit 2011 API
ViewSetIterator Properties
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class


Current Property

[image]

Revit 2011 API
ViewSetIterator..::.Current Property
ViewSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSetIterator Class


ViewSheet Class

[image]

Revit 2011 API
ViewSheet Class
Members Example See Also Send Feedback
A sheet is a view used to prepare a finished printout. It contains other views and a titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSheet : View
Visual Basic (Declaration)
Public Class ViewSheet _
    Inherits View
Visual C++
public ref class ViewSheet : public View

Examples

CopyC#
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ViewSet views = viewSheet.Views;
    message += "\nNumber of views in the sheet : " + views.Size;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ViewSheet(ByVal viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " + sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " + sheetNumber

    Dim views As ViewSet = viewSheet.Views
    message += vbLf & "Number of views in the sheet : " + views.Size

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.ViewSheet

See Also

ViewSheet Members


ViewSheet Members

[image] [image]

Revit 2011 API
ViewSheet Members
ViewSheet Class Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

Name | Description
AddView | Places view on the sheet at the given location.
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
CreatePlaceholder | Create a placeholder sheet in document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SheetNumber | Sheet number is unique in the document.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
Views | Returns the set of all views on the sheet.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet Class


ViewSheet Methods

[image] [image]

Revit 2011 API
ViewSheet Methods
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

Name | Description
AddView | Places view on the sheet at the given location.
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
CreatePlaceholder | Create a placeholder sheet in document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSheet Class


AddView Method

[image]

Revit 2011 API
ViewSheet..::.AddView Method
ViewSheet Class Example See Also Send Feedback
Places view on the sheet at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddView(
    View newView,
    UV location
)
Visual Basic (Declaration)
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
public:
void AddView(
    View^ newView,
    UV^ location
)

Parameters

newView
Type: Autodesk.Revit.DB..::.View
The view to be placed.
location
Type: Autodesk.Revit.DB..::.UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
private void PlaceViewOnSheet(Document document, ViewSheet viewSheet)
{
    //Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    //or the view is already placed on another sheet.
    //The lower left corner of the sheet has coordinates [0,0].
    //Empty views are not placed on the sheet but no exception occurs.

    //put a view into the sheet
    //the location of the view in the view sheet
   UV viewLocation = new UV(1.5, 1.5);
    //get a view form the view list
    Autodesk.Revit.DB.View tempView = document.ActiveView;
    if (null != tempView)
    {
        viewSheet.AddView(tempView, viewLocation);
        TaskDialog.Show("Revit","nAdd a view to the viewSheet successfully.");
    }
}
CopyVB.NET
Private Sub PlaceViewOnSheet(ByVal document As Document, ByVal viewSheet As ViewSheet)
    'Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    'or the view is already placed on another sheet.
    'The lower left corner of the sheet has coordinates [0,0].
    'Empty views are not placed on the sheet but no exception occurs.

    'put a view into the sheet
    'the location of the view in the view sheet
    Dim viewLocation As New Autodesk.Revit.DB.UV(1.5, 1.5)
    'get a view form the view list
    Dim tempView As Autodesk.Revit.DB.View = document.ActiveView
    If tempView IsNot Nothing Then
        viewSheet.AddView(tempView, viewLocation)
        TaskDialog.Show("Revit", "nAdd a view to the viewSheet successfully.")
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

ViewSheet Class


ConvertToRealSheet Method

[image]

Revit 2011 API
ViewSheet..::.ConvertToRealSheet Method
ViewSheet Class See Also Send Feedback
Convert a placeholder sheet to a real one with an optional titleblock

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ConvertToRealSheet(
    ElementId titleblockElementId
)
Visual Basic (Declaration)
Public Sub ConvertToRealSheet ( _
    titleblockElementId As ElementId _
)
Visual C++
public:
void ConvertToRealSheet(
    ElementId^ titleblockElementId
)

Parameters

titleblockElementId
Type: Autodesk.Revit.DB..::.ElementId
The element id of titleblock for the real sheet. If it is a nullptr or an invalid element id, no titleblock will be created.

Remarks

This method should only be called on a placeholder sheet, otherwise exception will occur.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | If titleblockElementId is a valid element id but not a titleblock symbol id.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If the method is not called on a placeholder sheet or the input titleblock could not be applied.

See Also

ViewSheet Class


CreatePlaceholder Method

[image]

Revit 2011 API
ViewSheet..::.CreatePlaceholder Method
ViewSheet Class See Also Send Feedback
Create a placeholder sheet in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static ViewSheet CreatePlaceholder(
    Document document
)
Visual Basic (Declaration)
Public Shared Function CreatePlaceholder ( _
    document As Document _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreatePlaceholder(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document in which the placeholder sheet will be created.

Remarks

Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.

See Also

ViewSheet Class


Print Method

[image] [image]

Revit 2011 API
ViewSheet..::.Print Method
ViewSheet Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members


ViewSheet Properties

[image] [image]

Revit 2011 API
ViewSheet Properties
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SheetNumber | Sheet number is unique in the document.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
Views | Returns the set of all views on the sheet.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

ViewSheet Class


IsPlaceholder Property

[image]

Revit 2011 API
ViewSheet..::.IsPlaceholder Property
ViewSheet Class See Also Send Feedback
Identifies whether or not the view sheet represents a placeholder sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPlaceholder { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPlaceholder As Boolean
Visual C++
public:
property bool IsPlaceholder {
    bool get ();
}

Remarks

Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.

See Also

ViewSheet Class


Parameter Property

[image] [image]

Revit 2011 API
ViewSheet..::.Parameter Property
ViewSheet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSheet Class
ViewSheet Members


SheetNumber Property

[image]

Revit 2011 API
ViewSheet..::.SheetNumber Property
ViewSheet Class See Also Send Feedback
Sheet number is unique in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string SheetNumber { get; set; }
Visual Basic (Declaration)
Public Property SheetNumber As String
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Remarks

Exception occurs when trying to set the value that is not unique.

See Also

ViewSheet Class


Views Property

[image]

Revit 2011 API
ViewSheet..::.Views Property
ViewSheet Class See Also Send Feedback
Returns the set of all views on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet Views { get; }
Visual Basic (Declaration)
Public ReadOnly Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

ViewSheet Class


ViewSheetSet Class

[image]

Revit 2011 API
ViewSheetSet Class
Members See Also Send Feedback
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSheetSet : Element,
    IViewSheetSet
Visual Basic (Declaration)
Public Class ViewSheetSet _
    Inherits Element _
    Implements IViewSheetSet
Visual C++
public ref class ViewSheetSet : public Element,
    IViewSheetSet

Remarks

For the in-session ViewSheetSet, see the class InSessionViewSheetSet.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ViewSheetSet

See Also

ViewSheetSet Members


ViewSheetSet Members

[image] [image]

Revit 2011 API
ViewSheetSet Members
ViewSheetSet Class Methods Properties See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The view sheet set name. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Views | The views.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ViewSheetSet Class


ViewSheetSet Methods

[image] [image]

Revit 2011 API
ViewSheetSet Methods
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSet Class


ViewSheetSet Properties

[image] [image]

Revit 2011 API
ViewSheetSet Properties
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The view sheet set name. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Views | The views.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ViewSheetSet Class


Name Property

[image]

Revit 2011 API
ViewSheetSet..::.Name Property
ViewSheetSet Class See Also Send Feedback
The view sheet set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic (Declaration)
Public Overrides Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to set the name. Instead, set the name with the Rename(String) method.

See Also

ViewSheetSet Class


Parameter Property

[image] [image]

Revit 2011 API
ViewSheetSet..::.Parameter Property
ViewSheetSet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ViewSheetSet Class
ViewSheetSet Members


Views Property

[image]

Revit 2011 API
ViewSheetSet..::.Views Property
ViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic (Declaration)
Public Overridable Property Views As ViewSet
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::.Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

ViewSheetSet Class


ViewSheetSets Class

[image]

Revit 2011 API
ViewSheetSets Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSheetSets : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ViewSheetSets _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSheetSets : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ViewSheetSets

See Also

ViewSheetSets Members


ViewSheetSets Members

[image] [image]

Revit 2011 API
ViewSheetSets Members
ViewSheetSets Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSets type exposes the following members.

Constructors

Name | Description
ViewSheetSets | Initializes a new instance of the ViewSheetSets class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class


ViewSheetSets Constructor

[image]

Revit 2011 API
ViewSheetSets Constructor
ViewSheetSets Class See Also Send Feedback
Initializes a new instance of the ViewSheetSets class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSheetSets()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSets()

See Also

ViewSheetSets Class


ViewSheetSets Methods

[image] [image]

Revit 2011 API
ViewSheetSets Methods
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSets Class


Clear Method

[image]

Revit 2011 API
ViewSheetSets..::.Clear Method
ViewSheetSets Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSheetSets Class


Contains Method

[image]

Revit 2011 API
ViewSheetSets..::.Contains Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ViewSheetSet

See Also

ViewSheetSets Class


Erase Method

[image]

Revit 2011 API
ViewSheetSets..::.Erase Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ViewSheetSet _
) As Integer
Visual C++
public:
virtual int Erase(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ViewSheetSet

See Also

ViewSheetSets Class


ForwardIterator Method

[image]

Revit 2011 API
ViewSheetSets..::.ForwardIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSheetSets Class


GetEnumerator Method

[image]

Revit 2011 API
ViewSheetSets..::.GetEnumerator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ViewSheetSets Class


Insert Method

[image]

Revit 2011 API
ViewSheetSets..::.Insert Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    ViewSheetSet item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.ViewSheetSet

See Also

ViewSheetSets Class


ReverseIterator Method

[image]

Revit 2011 API
ViewSheetSets..::.ReverseIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSheetSets Class


ViewSheetSets Properties

[image] [image]

Revit 2011 API
ViewSheetSets Properties
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class


IsEmpty Property

[image]

Revit 2011 API
ViewSheetSets..::.IsEmpty Property
ViewSheetSets Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSheetSets Class


Size Property

[image]

Revit 2011 API
ViewSheetSets..::.Size Property
ViewSheetSets Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSheetSets Class


ViewSheetSetsIterator Class

[image]

Revit 2011 API
ViewSheetSetsIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ViewSheetSetsIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ViewSheetSetsIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSheetSetsIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ViewSheetSetsIterator

See Also

ViewSheetSetsIterator Members


ViewSheetSetsIterator Members

[image] [image]

Revit 2011 API
ViewSheetSetsIterator Members
ViewSheetSetsIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Constructors

Name | Description
ViewSheetSetsIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Constructor

[image]

Revit 2011 API
ViewSheetSetsIterator Constructor
ViewSheetSetsIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSheetSetsIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewSheetSetsIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Methods

[image] [image]

Revit 2011 API
ViewSheetSetsIterator Methods
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetsIterator Class


MoveNext Method

[image]

Revit 2011 API
ViewSheetSetsIterator..::.MoveNext Method
ViewSheetSetsIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class


Reset Method

[image]

Revit 2011 API
ViewSheetSetsIterator..::.Reset Method
ViewSheetSetsIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Properties

[image] [image]

Revit 2011 API
ViewSheetSetsIterator Properties
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class


Current Property

[image]

Revit 2011 API
ViewSheetSetsIterator..::.Current Property
ViewSheetSetsIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class


ViewSheetSetting Class

[image]

Revit 2011 API
ViewSheetSetting Class
Members See Also Send Feedback
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewSheetSetting : APIObject
Visual Basic (Declaration)
Public Class ViewSheetSetting _
    Inherits APIObject
Visual C++
public ref class ViewSheetSetting : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ViewSheetSetting

See Also

ViewSheetSetting Members


ViewSheetSetting Members

[image] [image]

Revit 2011 API
ViewSheetSetting Members
ViewSheetSetting Class Methods Properties See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

Name | Description
Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current view sheet set.
Revert | Revert the current view sheet set.
Save | Save the changes for the current view sheet set.
SaveAs | Save the current view sheet set to another view sheet set with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AvailableViews | All views that can be printed.
CurrentViewSheetSet | The current view sheet set of PrintSetup.
InSession | The in-session view sheet set of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


ViewSheetSetting Methods

[image] [image]

Revit 2011 API
ViewSheetSetting Methods
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

Name | Description
Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Rename | Rename the current view sheet set.
Revert | Revert the current view sheet set.
Save | Save the changes for the current view sheet set.
SaveAs | Save the current view sheet set to another view sheet set with the specified name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetting Class


Delete Method

[image]

Revit 2011 API
ViewSheetSetting..::.Delete Method
ViewSheetSetting Class See Also Send Feedback
Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Delete()
Visual Basic (Declaration)
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise True.

Remarks

If the current view sheet set is In-Session, an InvalidOperationException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Rename Method

[image]

Revit 2011 API
ViewSheetSetting..::.Rename Method
ViewSheetSetting Class See Also Send Feedback
Rename the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic (Declaration)
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be renamed as.

Return Value

False if Rename operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


Revert Method

[image]

Revit 2011 API
ViewSheetSetting..::.Revert Method
ViewSheetSetting Class See Also Send Feedback
Revert the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Revert()
Visual Basic (Declaration)
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Save Method

[image]

Revit 2011 API
ViewSheetSetting..::.Save Method
ViewSheetSetting Class See Also Send Feedback
Save the changes for the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Save()
Visual Basic (Declaration)
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the current view sheet set is In-Session or the current view sheet set is unchanged.

See Also

ViewSheetSetting Class


SaveAs Method

[image]

Revit 2011 API
ViewSheetSetting..::.SaveAs Method
ViewSheetSetting Class See Also Send Feedback
Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic (Declaration)
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::.String
View sheet set name to be saved as.

Return Value

False if saveas operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


ViewSheetSetting Properties

[image] [image]

Revit 2011 API
ViewSheetSetting Properties
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Properties

Name | Description
AvailableViews | All views that can be printed.
CurrentViewSheetSet | The current view sheet set of PrintSetup.
InSession | The in-session view sheet set of Print Setup.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


AvailableViews Property

[image]

Revit 2011 API
ViewSheetSetting..::.AvailableViews Property
ViewSheetSetting Class See Also Send Feedback
All views that can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet AvailableViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableViews As ViewSet
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

Users can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class


CurrentViewSheetSet Property

[image]

Revit 2011 API
ViewSheetSetting..::.CurrentViewSheetSet Property
ViewSheetSetting Class See Also Send Feedback
The current view sheet set of PrintSetup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IViewSheetSet CurrentViewSheetSet { get; set; }
Visual Basic (Declaration)
Public Property CurrentViewSheetSet As IViewSheetSet
Visual C++
public:
property IViewSheetSet^ CurrentViewSheetSet {
    IViewSheetSet^ get ();
    void set (IViewSheetSet^ value);
}

See Also

ViewSheetSetting Class


InSession Property

[image]

Revit 2011 API
ViewSheetSetting..::.InSession Property
ViewSheetSetting Class See Also Send Feedback
The in-session view sheet set of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InSessionViewSheetSet InSession { get; }
Visual Basic (Declaration)
Public ReadOnly Property InSession As InSessionViewSheetSet
Visual C++
public:
property InSessionViewSheetSet^ InSession {
    InSessionViewSheetSet^ get ();
}

See Also

ViewSheetSetting Class


ViewType Enumeration

[image]

Revit 2011 API
ViewType Enumeration
See Also Send Feedback
An enumerated type listing available view types.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ViewType
Visual Basic (Declaration)
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Undefined | Undefined/unspecified type of view.
FloorPlan | Floor plan type of view.
CeilingPlan | Reflected ceiling plan type of view.
Elevation | Elevation type of view.
ThreeD | 3-D type of view.
Schedule | Schedule type of view.
DrawingSheet | Drawing sheet type of view.
Report | Report type of view.
DraftingView | Drafting type of view.
Legend | Legend type of view.
EngineeringPlan | Engineering Floor Plan type of view.
AreaPlan | Area plan type of view.
Section | Cross section type of view.
Detail | Detail type of view.
CostReport | Cost Report view.
LoadsReport | Loads Report view.
PresureLossReport | Pressure Loss Report view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
Walkthrough | Walk-Through type of 3D view.
Rendering | Rendering type of view.
Internal | Revit's internal type of view

See Also


VirtualPrinterType Enumeration

[image]

Revit 2011 API
VirtualPrinterType Enumeration
See Also Send Feedback
An enumerated to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum VirtualPrinterType
Visual Basic (Declaration)
Public Enumeration VirtualPrinterType
Visual C++
public enum class VirtualPrinterType

Members

Member name | Description
None | None.
AdobePDF | AdobePDF.
DWFWriter | DWFWriter.
XPSWriter | Microsoft XPS Document Writer.

See Also


Visibility Enumeration

[image]

Revit 2011 API
Visibility Enumeration
See Also Send Feedback
Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Visible | The geometry object is always visible. This type of geometry is always returned by Geometry[([(Options])])
Highlight | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by Geometry[([(Options])]) if IncludeNonVisibleObjects is true.
Contextual | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by Geometry[([(Options])]), even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Invisible | The geometry object is never visible. This type of geometry is never returned by Geometry[([(Options])]) but may be obtained by other API operations.

See Also


VolumeCalculationOptions Class

[image]

Revit 2011 API
VolumeCalculationOptions Class
Members See Also Send Feedback
This class provides access to options related to room volume and area computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VolumeCalculationOptions
Visual Basic (Declaration)
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.VolumeCalculationOptions

See Also

VolumeCalculationOptions Members


VolumeCalculationOptions Members

[image] [image]

Revit 2011 API
VolumeCalculationOptions Members
VolumeCalculationOptions Class Constructors Methods Properties See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Constructors

Name | Description
VolumeCalculationOptions | Creates a new instance of the volume calculation options.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Constructor

[image]

Revit 2011 API
VolumeCalculationOptions Constructor
VolumeCalculationOptions Class See Also Send Feedback
Creates a new instance of the volume calculation options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VolumeCalculationOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VolumeCalculationOptions()

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Methods

[image] [image]

Revit 2011 API
VolumeCalculationOptions Methods
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Properties

[image] [image]

Revit 2011 API
VolumeCalculationOptions Properties
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Properties

Name | Description
RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class


RoomAreaBoundaryLocation Property

[image]

Revit 2011 API
VolumeCalculationOptions..::.RoomAreaBoundaryLocation Property
VolumeCalculationOptions Class See Also Send Feedback
The location used to calculate area and volume from room boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundaryLocationType RoomAreaBoundaryLocation { get; set; }
Visual Basic (Declaration)
Public Property RoomAreaBoundaryLocation As BoundaryLocationType
Visual C++
public:
property BoundaryLocationType RoomAreaBoundaryLocation {
    BoundaryLocationType get ();
    void set (BoundaryLocationType value);
}

See Also

VolumeCalculationOptions Class


VolumeComputationEnable Property

[image]

Revit 2011 API
VolumeCalculationOptions..::.VolumeComputationEnable Property
VolumeCalculationOptions Class Example See Also Send Feedback
True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool VolumeComputationEnable { get; set; }
Visual Basic (Declaration)
Public Property VolumeComputationEnable As Boolean
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    VolumeCalculationOptions options = new VolumeCalculationOptions();
    options.VolumeComputationEnable = true;
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options;
    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimiter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    TaskDialog.Show("Revit",roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(ByVal doc As Document, ByVal room As Room)
    Dim roominfo As [String] = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    Dim options As New VolumeCalculationOptions()
    options.VolumeComputationEnable = True
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options
    roominfo += "Vol: " + room.Volume + vbLf
    roominfo += "Area: " + room.Area + vbLf
    roominfo += "Perimiter: " + room.Perimeter + vbLf
    roominfo += "Unbounded height: " + room.UnboundedHeight + vbLf
    TaskDialog.Show("Revit", roominfo)
End Sub

See Also

VolumeCalculationOptions Class


VolumeCalculationSetting Class

[image]

Revit 2011 API
VolumeCalculationSetting Class
Members See Also Send Feedback
This class provides access to settings related to room volume and area computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VolumeCalculationSetting
Visual Basic (Declaration)
Public Class VolumeCalculationSetting
Visual C++
public ref class VolumeCalculationSetting

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.VolumeCalculationSetting

See Also

VolumeCalculationSetting Members


VolumeCalculationSetting Members

[image] [image]

Revit 2011 API
VolumeCalculationSetting Members
VolumeCalculationSetting Class Methods Properties See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class


VolumeCalculationSetting Methods

[image] [image]

Revit 2011 API
VolumeCalculationSetting Methods
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationSetting Class


VolumeCalculationSetting Properties

[image] [image]

Revit 2011 API
VolumeCalculationSetting Properties
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Properties

Name | Description
VolumeCalculationOptions | Retrieve or change the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class


VolumeCalculationOptions Property

[image]

Revit 2011 API
VolumeCalculationSetting..::.VolumeCalculationOptions Property
VolumeCalculationSetting Class See Also Send Feedback
Retrieve or change the application settings related to automatic calculation of room volumes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VolumeCalculationOptions VolumeCalculationOptions { get; set; }
Visual Basic (Declaration)
Public Property VolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
property VolumeCalculationOptions^ VolumeCalculationOptions {
    VolumeCalculationOptions^ get ();
    void set (VolumeCalculationOptions^ value);
}

See Also

VolumeCalculationSetting Class


Wall Class

[image]

Revit 2011 API
Wall Class
Members Example See Also Send Feedback
Represents all of the different kinds of walls Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Wall : HostObject
Visual Basic (Declaration)
Public Class Wall _
    Inherits HostObject
Visual C++
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of walls in Revit.

Examples

CopyC#
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";
    // Get wall AnalyticalModel type
    AnalyticalModel model = wall.GetAnalyticalModel();
    if (null != model)
    {
        // For some situation(such as architecture wall or in building version),
        // this property may return null, but if it doesn't return null, it should
        // be AnalyticalModelWall.
        message += "\nWall AnalyticalModel type is : " + model;
    }

    wall.flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Wall(ByVal wall As Wall)
    Dim message As String = "Wall : "
    ' Get wall AnalyticalModel type
    Dim model As Autodesk.Revit.DB.Structure.AnalyticalModel = wall.GetAnalyticalModel()
    If model IsNot Nothing Then
        ' For some situation(such as architecture wall or in building version),
        ' this property may return null, but if it doesn't return null, it should
        ' be AnalyticalModelWall.
        message += vbLf & "Wall AnalyticalModel type is : " & model.ToString()
    End If

    wall.flip()
    message += vbLf & "If wall Flipped : " + wall.Flipped
    ' Get curve start point
    message += vbLf & "Wall orientation point is :(" + wall.Orientation.X + ", " + wall.Orientation.Y + ", " + wall.Orientation.Z + ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " + wall.StructuralUsage
    ' Get wall type name
    message += vbLf & "Wall type name is : " + wall.WallType.Name
    ' Get wall width
    message += vbLf & "Wall width is : " + wall.Width

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.Wall

See Also

Wall Members


Wall Members

[image] [image]

Revit 2011 API
Wall Members
Wall Class Methods Properties See Also Send Feedback

The Wall type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flip | The wall orientation will be flipped.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrid | Get the grid object of a curtain wall
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Flipped | Property to test whether the wall orientation is flipped.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Orientation | The normal vector projected from the exterior side of the wall.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class


Wall Methods

[image] [image]

Revit 2011 API
Wall Methods
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
flip | The wall orientation will be flipped.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wall Class


flip Method

[image]

Revit 2011 API
Wall..::.flip Method
Wall Class See Also Send Feedback
The wall orientation will be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void flip()
Visual Basic (Declaration)
Public Sub flip
Visual C++
public:
void flip()

See Also

Wall Class


Wall Properties

[image] [image]

Revit 2011 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurtainGrid | Get the grid object of a curtain wall
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Flipped | Property to test whether the wall orientation is flipped.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Orientation | The normal vector projected from the exterior side of the wall.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralUsage | The walls designated structural usage, such as bearing or non bearing.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WallType | Retrieve or change the type of the wall.
Width | Returns the overall thickness of the wall.

See Also

Wall Class


CurtainGrid Property

[image]

Revit 2011 API
Wall..::.CurtainGrid Property
Wall Class See Also Send Feedback
Get the grid object of a curtain wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurtainGrid CurtainGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurtainGrid As CurtainGrid
Visual C++
public:
property CurtainGrid^ CurtainGrid {
    CurtainGrid^ get ();
}

Remarks

This property is readonly.

See Also

Wall Class


Flipped Property

[image]

Revit 2011 API
Wall..::.Flipped Property
Wall Class See Also Send Feedback
Property to test whether the wall orientation is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Flipped { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flipped As Boolean
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

Wall Class


Orientation Property

[image]

Revit 2011 API
Wall..::.Orientation Property
Wall Class See Also Send Feedback
The normal vector projected from the exterior side of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Orientation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Orientation As XYZ
Visual C++
public:
property XYZ^ Orientation {
    XYZ^ get ();
}

See Also

Wall Class


Parameter Property

[image] [image]

Revit 2011 API
Wall..::.Parameter Property
Wall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Wall Class
Wall Members


StructuralUsage Property

[image]

Revit 2011 API
Wall..::.StructuralUsage Property
Wall Class See Also Send Feedback
The walls designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public StructuralWallUsage StructuralUsage { get; set; }
Visual Basic (Declaration)
Public Property StructuralUsage As StructuralWallUsage
Visual C++
public:
property StructuralWallUsage StructuralUsage {
    StructuralWallUsage get ();
    void set (StructuralWallUsage value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Wall Class


WallType Property

[image]

Revit 2011 API
Wall..::.WallType Property
Wall Class See Also Send Feedback
Retrieve or change the type of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WallType WallType { get; set; }
Visual Basic (Declaration)
Public Property WallType As WallType
Visual C++
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}

Remarks

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.

See Also

Wall Class


Width Property

[image]

Revit 2011 API
Wall..::.Width Property
Wall Class See Also Send Feedback
Returns the overall thickness of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

Wall Class


WallFunction Enumeration

[image]

Revit 2011 API
WallFunction Enumeration
See Also Send Feedback
Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum WallFunction
Visual Basic (Declaration)
Public Enumeration WallFunction
Visual C++
public enum class WallFunction

Members

Member name | Description
Interior |
Exterior |
Foundation |
Retaining |
Soffit |
Coreshaft |

See Also


WallKind Enumeration

[image]

Revit 2011 API
WallKind Enumeration
See Also Send Feedback
Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum WallKind
Visual Basic (Declaration)
Public Enumeration WallKind
Visual C++
public enum class WallKind

Members

Member name | Description
Unknown | The basic type is not known.
Basic | A standard wall.
Curtain | A curtain wall.
Stacked | A stacked wall of several wall types.

See Also


WallLocationLine Enumeration

[image]

Revit 2011 API
WallLocationLine Enumeration
See Also Send Feedback
This enumerated type represents the options for alignment of a wall's location line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum WallLocationLine
Visual Basic (Declaration)
Public Enumeration WallLocationLine
Visual C++
public enum class WallLocationLine

Members

Member name | Description
WallCenterline | The wall location line is aligned to the center of the wall.
CoreCenterline | The wall location line is aligned to the center of the core.
FinishFaceExterior | The wall location line is aligned to the exterior face of the wall.
FinishFaceInterior | The wall location line is aligned to the interior face of the wall.
CoreExterior | The wall location line is aligned to the exterior face of the core.
CoreInterior | The wall location line is aligned to the exterior face of the core.

See Also


WallType Class

[image]

Revit 2011 API
WallType Class
Members Example See Also Send Feedback
Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WallType : HostObjAttributes
Visual Basic (Declaration)
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Examples

CopyC#
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_WallType(ByVal wallType As WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " + wallType.Width.ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.WallType

See Also

WallType Members


WallType Members

[image] [image]

Revit 2011 API
WallType Members
WallType Class Methods Properties See Also Send Feedback

The WallType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Kind | Reports the nature of the wall
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | Returns the overall thickness of this type of wall.

See Also

WallType Class


WallType Methods

[image] [image]

Revit 2011 API
WallType Methods
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallType Class


WallType Properties

[image] [image]

Revit 2011 API
WallType Properties
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Kind | Reports the nature of the wall
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | Returns the overall thickness of this type of wall.

See Also

WallType Class


Kind Property

[image]

Revit 2011 API
WallType..::.Kind Property
WallType Class See Also Send Feedback
Reports the nature of the wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WallKind Kind { get; }
Visual Basic (Declaration)
Public ReadOnly Property Kind As WallKind
Visual C++
public:
property WallKind Kind {
    WallKind get ();
}

See Also

WallType Class


Parameter Property

[image] [image]

Revit 2011 API
WallType..::.Parameter Property
WallType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WallType Class
WallType Members


Width Property

[image]

Revit 2011 API
WallType..::.Width Property
WallType Class See Also Send Feedback
Returns the overall thickness of this type of wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

WallType Class


WallTypeSet Class

[image]

Revit 2011 API
WallTypeSet Class
Members See Also Send Feedback
A set that contains wall types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WallTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WallTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WallTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.WallTypeSet

See Also

WallTypeSet Members


WallTypeSet Members

[image] [image]

Revit 2011 API
WallTypeSet Members
WallTypeSet Class Constructors Methods Properties See Also Send Feedback

The WallTypeSet type exposes the following members.

Constructors

Name | Description
WallTypeSet | Initializes a new instance of the WallTypeSet class

Methods

Name | Description
Clear | Removes every wall type from the set, rendering it empty.
Contains | Tests for the existence of a wall type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wall type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wall type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class


WallTypeSet Constructor

[image]

Revit 2011 API
WallTypeSet Constructor
WallTypeSet Class See Also Send Feedback
Initializes a new instance of the WallTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WallTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSet()

See Also

WallTypeSet Class


WallTypeSet Methods

[image] [image]

Revit 2011 API
WallTypeSet Methods
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every wall type from the set, rendering it empty.
Contains | Tests for the existence of a wall type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wall type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wall type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSet Class


Clear Method

[image]

Revit 2011 API
WallTypeSet..::.Clear Method
WallTypeSet Class See Also Send Feedback
Removes every wall type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WallTypeSet Class


Contains Method

[image]

Revit 2011 API
WallTypeSet..::.Contains Method
WallTypeSet Class See Also Send Feedback
Tests for the existence of a wall type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.WallType
The wall type to be searched for.

Return Value

The Contains method returns True if the wall type is within the set, otherwise False.

See Also

WallTypeSet Class


Erase Method

[image]

Revit 2011 API
WallTypeSet..::.Erase Method
WallTypeSet Class See Also Send Feedback
Removes a specified wall type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WallType _
) As Integer
Visual C++
public:
virtual int Erase(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.WallType
The wall type to be erased.

Return Value

The number of wall types that were erased from the set.

See Also

WallTypeSet Class


ForwardIterator Method

[image]

Revit 2011 API
WallTypeSet..::.ForwardIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WallTypeSet Class


GetEnumerator Method

[image]

Revit 2011 API
WallTypeSet..::.GetEnumerator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WallTypeSet Class


Insert Method

[image]

Revit 2011 API
WallTypeSet..::.Insert Method
WallTypeSet Class See Also Send Feedback
Insert the specified wall type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    WallType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::.WallType
The wall type to be inserted into the set.

Return Value

Returns whether the wall type was inserted into the set.

See Also

WallTypeSet Class


ReverseIterator Method

[image]

Revit 2011 API
WallTypeSet..::.ReverseIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WallTypeSet Class


WallTypeSet Properties

[image] [image]

Revit 2011 API
WallTypeSet Properties
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class


IsEmpty Property

[image]

Revit 2011 API
WallTypeSet..::.IsEmpty Property
WallTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WallTypeSet Class


Size Property

[image]

Revit 2011 API
WallTypeSet..::.Size Property
WallTypeSet Class See Also Send Feedback
Returns the number of wall types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WallTypeSet Class


WallTypeSetIterator Class

[image]

Revit 2011 API
WallTypeSetIterator Class
Members See Also Send Feedback
An iterator to a wall type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WallTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WallTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WallTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.WallTypeSetIterator

See Also

WallTypeSetIterator Members


WallTypeSetIterator Members

[image] [image]

Revit 2011 API
WallTypeSetIterator Members
WallTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Constructors

Name | Description
WallTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class


WallTypeSetIterator Constructor

[image]

Revit 2011 API
WallTypeSetIterator Constructor
WallTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WallTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WallTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallTypeSetIterator Class


WallTypeSetIterator Methods

[image] [image]

Revit 2011 API
WallTypeSetIterator Methods
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSetIterator Class


MoveNext Method

[image]

Revit 2011 API
WallTypeSetIterator..::.MoveNext Method
WallTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class


Reset Method

[image]

Revit 2011 API
WallTypeSetIterator..::.Reset Method
WallTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WallTypeSetIterator Class


WallTypeSetIterator Properties

[image] [image]

Revit 2011 API
WallTypeSetIterator Properties
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class


Current Property

[image]

Revit 2011 API
WallTypeSetIterator..::.Current Property
WallTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class


XYZ Class

[image]

Revit 2011 API
XYZ Class
Members See Also Send Feedback
Object representing coordinates in 3-dimensional space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class XYZ
Visual Basic (Declaration)
Public Class XYZ
Visual C++
public ref class XYZ

Remarks

Usually this means a point or a vector in 3-dimensional space, depending on the actual use.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.XYZ

See Also

XYZ Members


XYZ Members

[image] [image]

Revit 2011 API
XYZ Members
XYZ Class Constructors Methods Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

Name | Description
XYZ | Overloaded.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this vector and the specified vector.
DistanceTo | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
DotProduct | The dot product of this vector and the specified vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLength | Gets the length of this vector.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value that indicates whether this vector is of unit length.
IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

Properties

Name | Description
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
Item | Indexed access to coordinates.
X | Gets the first coordinate.
Y | Gets the second coordinate.
Z | Gets the third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class


XYZ Constructor

[image] [image]

Revit 2011 API
XYZ Constructor
XYZ Class See Also Send Feedback

Overload List

Name | Description
XYZ()()() | Creates a default XYZ with the values (0, 0, 0).
XYZ(Double, Double, Double) | Creates an XYZ with the supplied coordinates.

See Also

XYZ Class
XYZ Members


XYZ Constructor

[image]

Revit 2011 API
XYZ Constructor
XYZ Class See Also Send Feedback
Creates a default XYZ with the values (0, 0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XYZ()

See Also

XYZ Class
XYZ Overload


XYZ Constructor (Double, Double, Double)

[image]

Revit 2011 API
XYZ Constructor (Double, Double, Double)
XYZ Class See Also Send Feedback
Creates an XYZ with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::.Double
The first coordinate.
y
Type: System..::.Double
The second coordinate.
z
Type: System..::.Double
The third coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
XYZ Overload


XYZ Methods

[image] [image]

Revit 2011 API
XYZ Methods
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Methods

Name | Description
Add | Adds the specified vector to this vector and returns the result.
AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
AngleTo | Returns the angle between this vector and the specified vector.
CrossProduct | The cross product of this vector and the specified vector.
DistanceTo | Returns the distance from this point to the specified point.
Divide | Divides this vector by the specified value and returns the result.
DotProduct | The dot product of this vector and the specified vector.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLength | Gets the length of this vector.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAlmostEqualTo | Overloaded.
IsUnitLength | The boolean value that indicates whether this vector is of unit length.
IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Multiply | Multiplies this vector by the specified value and returns the result.
Negate | Negates this vector.
Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Subtract | Subtracts the specified vector from this vector and returns the result.
ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::.ToString()()().)
TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply | Overloaded.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

See Also

XYZ Class


Add Method

[image]

Revit 2011 API
XYZ..::.Add Method
XYZ Class See Also Send Feedback
Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Add(
    XYZ source
)
Visual Basic (Declaration)
Public Function Add ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Add(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to add to this vector.

Return Value

The vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


Addition Operator

[image]

Revit 2011 API
XYZ..::.Addition Operator
XYZ Class See Also Send Feedback
Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::.XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::.XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


AngleOnPlaneTo Method

[image]

Revit 2011 API
XYZ..::.AngleOnPlaneTo Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AngleOnPlaneTo(
    XYZ right,
    XYZ normal
)
Visual Basic (Declaration)
Public Function AngleOnPlaneTo ( _
    right As XYZ, _
    normal As XYZ _
) As Double
Visual C++
public:
double AngleOnPlaneTo(
    XYZ^ right,
    XYZ^ normal
)

Parameters

right
Type: Autodesk.Revit.DB..::.XYZ
The specified vector.
normal
Type: Autodesk.Revit.DB..::.XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when right or normal is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


AngleTo Method

[image]

Revit 2011 API
XYZ..::.AngleTo Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AngleTo(
    XYZ source
)
Visual Basic (Declaration)
Public Function AngleTo ( _
    source As XYZ _
) As Double
Visual C++
public:
double AngleTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors in radians..

Remarks

The angle between the two vectors is measured in the plane spanned by them.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


CrossProduct Method

[image]

Revit 2011 API
XYZ..::.CrossProduct Method
XYZ Class See Also Send Feedback
The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ CrossProduct(
    XYZ source
)
Visual Basic (Declaration)
Public Function CrossProduct ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ CrossProduct(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to multiply with this vector.

Return Value

The vector equal to the cross product.

Remarks

The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


DistanceTo Method

[image]

Revit 2011 API
XYZ..::.DistanceTo Method
XYZ Class See Also Send Feedback
Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DistanceTo(
    XYZ source
)
Visual Basic (Declaration)
Public Function DistanceTo ( _
    source As XYZ _
) As Double
Visual C++
public:
double DistanceTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


Divide Method

[image]

Revit 2011 API
XYZ..::.Divide Method
XYZ Class See Also Send Feedback
Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Divide(
    double value
)

Parameters

value
Type: System..::.Double
The value to divide this vector by.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number or zero.

See Also

XYZ Class


Division Operator

[image]

Revit 2011 API
XYZ..::.Division Operator
XYZ Class See Also Send Feedback
Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator /(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator /(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::.XYZ
The value to divide the vector by.
value
Type: System..::.Double
The vector to divide by the value.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number or zero.

See Also

XYZ Class


DotProduct Method

[image]

Revit 2011 API
XYZ..::.DotProduct Method
XYZ Class See Also Send Feedback
The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DotProduct(
    XYZ source
)
Visual Basic (Declaration)
Public Function DotProduct ( _
    source As XYZ _
) As Double
Visual C++
public:
double DotProduct(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


GetLength Method

[image]

Revit 2011 API
XYZ..::.GetLength Method
XYZ Class See Also Send Feedback
Gets the length of this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetLength()
Visual Basic (Declaration)
Public Function GetLength As Double
Visual C++
public:
double GetLength()

Remarks

In 3-D Euclidean space, the length of the vector is the square root of the sum of the three coordinates squared.

See Also

XYZ Class


IsAlmostEqualTo Method

[image] [image]

Revit 2011 API
XYZ..::.IsAlmostEqualTo Method
XYZ Class See Also Send Feedback

Overload List

Name | Description
IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.

See Also

XYZ Class
XYZ Members


IsAlmostEqualTo Method (XYZ)

[image]

Revit 2011 API
XYZ..::.IsAlmostEqualTo Method (XYZ)
XYZ Class See Also Send Feedback
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source
)
Visual Basic (Declaration)
Public Function IsAlmostEqualTo ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class
IsAlmostEqualTo Overload


IsAlmostEqualTo Method (XYZ, Double)

[image]

Revit 2011 API
XYZ..::.IsAlmostEqualTo Method (XYZ, Double)
XYZ Class See Also Send Feedback
Determines whether 2 vectors are the same within the given tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source,
    double tolerance
)
Visual Basic (Declaration)
Public Function IsAlmostEqualTo ( _
    source As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to compare with this vector.
tolerance
Type: System..::.Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when tolerance is less than 0.

See Also

XYZ Class
IsAlmostEqualTo Overload


IsUnitLength Method

[image]

Revit 2011 API
XYZ..::.IsUnitLength Method
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsUnitLength()
Visual Basic (Declaration)
Public Function IsUnitLength As Boolean
Visual C++
public:
bool IsUnitLength()

Remarks

A unit length vector has a length of one, and is considered normalized.

See Also

XYZ Class


IsZeroLength Method

[image]

Revit 2011 API
XYZ..::.IsZeroLength Method
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsZeroLength()
Visual Basic (Declaration)
Public Function IsZeroLength As Boolean
Visual C++
public:
bool IsZeroLength()

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

XYZ Class


Multiply Method

[image] [image]

Revit 2011 API
XYZ..::.Multiply Method
XYZ Class See Also Send Feedback

Overload List

Name | Description
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.

See Also

XYZ Class
XYZ Members


Multiply Operator

[image]

Revit 2011 API
XYZ..::.Multiply Operator
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::.XYZ
The vector to multiply with the value.
value
Type: System..::.Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload


Multiply Operator

[image]

Revit 2011 API
XYZ..::.Multiply Operator
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)

Parameters

value
Type: System..::.Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::.XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload


Multiply Method

[image]

Revit 2011 API
XYZ..::.Multiply Method
XYZ Class See Also Send Feedback
Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply(
    double value
)

Parameters

value
Type: System..::.Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class


Negate Method

[image]

Revit 2011 API
XYZ..::.Negate Method
XYZ Class See Also Send Feedback
Negates this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Negate()
Visual Basic (Declaration)
Public Function Negate As XYZ
Visual C++
public:
XYZ^ Negate()

Return Value

The vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

XYZ Class


Normalize Method

[image]

Revit 2011 API
XYZ..::.Normalize Method
XYZ Class See Also Send Feedback
Returns a new XYZ whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Normalize()
Visual Basic (Declaration)
Public Function Normalize As XYZ
Visual C++
public:
XYZ^ Normalize()

Return Value

The normalized XYZ or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

XYZ Class


Subtract Method

[image]

Revit 2011 API
XYZ..::.Subtract Method
XYZ Class See Also Send Feedback
Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic (Declaration)
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


Subtraction Operator

[image]

Revit 2011 API
XYZ..::.Subtraction Operator
XYZ Class See Also Send Feedback
Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::.XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::.XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


ToString Method

[image]

Revit 2011 API
XYZ..::.ToString Method
XYZ Class See Also Send Feedback
Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

XYZ Class


TripleProduct Method

[image]

Revit 2011 API
XYZ..::.TripleProduct Method
XYZ Class See Also Send Feedback
The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Visual Basic (Declaration)
Public Function TripleProduct ( _
    middle As XYZ, _
    right As XYZ _
) As Double
Visual C++
public:
double TripleProduct(
    XYZ^ middle,
    XYZ^ right
)

Parameters

middle
Type: Autodesk.Revit.DB..::.XYZ
The second vector.
right
Type: Autodesk.Revit.DB..::.XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when middle or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


UnaryNegation Operator

[image]

Revit 2011 API
XYZ..::.UnaryNegation Operator
XYZ Class See Also Send Feedback
Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ source
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::.XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


XYZ Properties

[image] [image]

Revit 2011 API
XYZ Properties
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Properties

Name | Description
BasisX | The basis of the X axis.
BasisY | The basis of the Y axis.
BasisZ | The basis of the Z axis.
Item | Indexed access to coordinates.
X | Gets the first coordinate.
Y | Gets the second coordinate.
Z | Gets the third coordinate.
Zero | The coordinate origin or zero vector.

See Also

XYZ Class


BasisX Property

[image]

Revit 2011 API
XYZ..::.BasisX Property
XYZ Class See Also Send Feedback
The basis of the X axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ BasisX { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisX As XYZ
Visual C++
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}

Remarks

The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.

See Also

XYZ Class


BasisY Property

[image]

Revit 2011 API
XYZ..::.BasisY Property
XYZ Class See Also Send Feedback
The basis of the Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ BasisY { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisY As XYZ
Visual C++
public:
static property XYZ^ BasisY {
    XYZ^ get ();
}

Remarks

The basis of the Y axis is the vector (0,1,0), the unit vector on the Y axis.

See Also

XYZ Class


BasisZ Property

[image]

Revit 2011 API
XYZ..::.BasisZ Property
XYZ Class See Also Send Feedback
The basis of the Z axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ BasisZ { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BasisZ As XYZ
Visual C++
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}

Remarks

The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.

See Also

XYZ Class


Item Property

[image]

Revit 2011 API
XYZ..::.Item Property
XYZ Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::.Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.

See Also

XYZ Class


X Property

[image]

Revit 2011 API
XYZ..::.X Property
XYZ Class See Also Send Feedback
Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double X { get; }
Visual Basic (Declaration)
Public ReadOnly Property X As Double
Visual C++
public:
property double X {
    double get ();
}

See Also

XYZ Class


Y Property

[image]

Revit 2011 API
XYZ..::.Y Property
XYZ Class See Also Send Feedback
Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Y { get; }
Visual Basic (Declaration)
Public ReadOnly Property Y As Double
Visual C++
public:
property double Y {
    double get ();
}

See Also

XYZ Class


Z Property

[image]

Revit 2011 API
XYZ..::.Z Property
XYZ Class See Also Send Feedback
Gets the third coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Z { get; }
Visual Basic (Declaration)
Public ReadOnly Property Z As Double
Visual C++
public:
property double Z {
    double get ();
}

See Also

XYZ Class


Zero Property

[image]

Revit 2011 API
XYZ..::.Zero Property
XYZ Class See Also Send Feedback
The coordinate origin or zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static XYZ Zero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Zero As XYZ
Visual C++
public:
static property XYZ^ Zero {
    XYZ^ get ();
}

Remarks

The zero vector is (0,0,0).

See Also

XYZ Class


ZoomFitType Enumeration

[image]

Revit 2011 API
ZoomFitType Enumeration
See Also Send Feedback
This enum is used to define type of zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ZoomFitType
Visual Basic (Declaration)
Public Enumeration ZoomFitType
Visual C++
public enum class ZoomFitType

Members

Member name | Description
FitToPage | Fit the whole view into a specific image size.
Zoom | Calculate the size of the image using physical size of the view, zoom value and resolution.

See Also


ZoomType Enumeration

[image]

Revit 2011 API
ZoomType Enumeration
See Also Send Feedback
An enumerated type listing all Zoom types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ZoomType
Visual Basic (Declaration)
Public Enumeration ZoomType
Visual C++
public enum class ZoomType

Members

Member name | Description
FitToPage | The type of Zoom is Fit To Page.
Zoom | The type of Zoom is user defined.

See Also


Autodesk.Revit.DB.Analysis Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Analysis Namespace
Send Feedback

Classes

Class | Description
AnalysisDisplayColoredSurfaceSettings | Contains colored surface settings for analysis display style element.
AnalysisDisplayColorEntry | Contains one entry of intermediate colors in color settings for analysis display style.
AnalysisDisplayColorSettings | Contains color settings for analysis display style element.
AnalysisDisplayLegend |
AnalysisDisplayLegendSettings | Contains legend settings for analysis display style element.
AnalysisDisplayMarkersAndTextSettings | Contains markers and text settings for analysis display style element.
AnalysisDisplayStyle | Exposes API for manipulation of analysis display style.
ConceptualConstructionType | This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
ConceptualSurfaceType | This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
EnergyDataSettings | This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
FieldDomainPoints | Abstract base class for various classes of field domain points
FieldDomainPointsByParameter | Represents a set of one-dimensional point coordinates (defined usually on curve)
FieldDomainPointsByUV | Represents a set of two-dimensional point coordinates (defined usually on surface)
FieldDomainPointsByXYZ | Represents a set of three-dimensional point coordinates
FieldValues | Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
MassEnergyAnalyticalModel | This class associates a mass instance with an energy analytical model data and geometry.
MassGBXMLExportOptions | Options used when exporting a gbXML file from a mass model document.
MassLevelData | MassLevelData is a conceptual representation of an occupiable floor in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
MassSurfaceData | Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
MassZone | MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representions of individually heated and cooled sub-volumes of a building.
SpatialFieldManager | Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
ValueAtPoint | Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.

Enumerations

Enumeration | Description
AnalysisDisplayStyleColorSettingsType | Defines types for color settings of analysis display style.
AnalysisDisplayStyleMarkerType | Defines marker types for markers and text settings of analysis display style.
ConceptualConstructionFloorSlabType | ConceptualConstructionType values for Floors.
ConceptualConstructionOpeningType | ConceptualConstructionType values for Openings.
ConceptualConstructionRoofType | ConceptualConstructionType values for Roofs.
ConceptualConstructionShadeType | ConceptualConstructionType values for Shades.
ConceptualConstructionWallType | ConceptualConstructionType values for Walls.
ConceptualConstructionWindowSkylightType | ConceptualConstructionType values for Windows and Skylights
ConstructionType | This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.
gbXMLBuildingHVACSystem | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
gbXMLBuildingOperatingSchedule | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
gbXMLBuildingType | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
gbXMLConditionType | This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.
gbXMLExportComplexity | This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one “huge” opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
gbXMLServiceType | This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.
gbXMLSpaceType | This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.
HVACLoadConstructionClass |
HVACLoadLoadsReportType |
MassSurfaceDataMaterialType | Indicates how the visualization material for the MassSurfaceData is calculated.
MassSurfaceDataSource | Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.
MassZoneLevelCutState | The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.
MassZoneMaterialType | MassZone material type.


AnalysisDisplayColoredSurfaceSettings Class

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Class
Members Example See Also Send Feedback
Contains colored surface settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColoredSurfaceSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayColoredSurfaceSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColoredSurfaceSettings : IDisposable

Examples

CopyC#
AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings = new AnalysisDisplayColoredSurfaceSettings();
coloredSurfaceSettings.ShowGridLines = true;
CopyVB.NET
Dim coloredSurfaceSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColoredSurfaceSettings()
coloredSurfaceSettings.ShowGridLines = True

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings

See Also

AnalysisDisplayColoredSurfaceSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Members

[image] [image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Members
AnalysisDisplayColoredSurfaceSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayColoredSurfaceSettings | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two colored surface settings objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ShowGridLines | If set to true, show grid lines in the analysis display.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

[image] [image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Constructor
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

Overload List

Name | Description
AnalysisDisplayColoredSurfaceSettings()()() | Constructs a default instance of colored surface settings.
AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a copy of colored surface settings object.

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Constructor
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Constructs a default instance of colored surface settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings()

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor (AnalysisDisplayColoredSurfaceSettings)

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Constructor (AnalysisDisplayColoredSurfaceSettings)
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Constructs a copy of colored surface settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings
Colored surface settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Methods

[image] [image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Methods
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two colored surface settings objects.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings..::.Dispose Method
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings..::.IsEqual Method
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As AnalysisDisplayColoredSurfaceSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings
Colored surface settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Properties

[image] [image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings Properties
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Properties

Name | Description
ShowGridLines | If set to true, show grid lines in the analysis display.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowGridLines Property

[image]

Revit 2011 API
AnalysisDisplayColoredSurfaceSettings..::.ShowGridLines Property
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
If set to true, show grid lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowGridLines { get; set; }
Visual Basic (Declaration)
Public Property ShowGridLines As Boolean
Visual C++
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Class

[image]

Revit 2011 API
AnalysisDisplayColorEntry Class
Members See Also Send Feedback
Contains one entry of intermediate colors in color settings for analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColorEntry : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayColorEntry _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColorEntry : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorEntry

See Also

AnalysisDisplayColorEntry Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Members

[image] [image]

Revit 2011 API
AnalysisDisplayColorEntry Members
AnalysisDisplayColorEntry Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Constructors

Name | Description
AnalysisDisplayColorEntry | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Check if color entry has associated value.
IsEqual | Compare color entries.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Color associated with color entry.
Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

[image] [image]

Revit 2011 API
AnalysisDisplayColorEntry Constructor
AnalysisDisplayColorEntry Class See Also Send Feedback

Overload List

Name | Description
AnalysisDisplayColorEntry()()() | Initializes a new instance of the AnalysisDisplayColorEntry class
AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

[image]

Revit 2011 API
AnalysisDisplayColorEntry Constructor
AnalysisDisplayColorEntry Class See Also Send Feedback
Initializes a new instance of the AnalysisDisplayColorEntry class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalysisDisplayColorEntry()

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor (Color)

[image]

Revit 2011 API
AnalysisDisplayColorEntry Constructor (Color)
AnalysisDisplayColorEntry Class See Also Send Feedback
Constructs a color entry with no value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
AnalysisDisplayColorEntry(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::.Color
Color assigned to the entry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor (Color, Double)

[image]

Revit 2011 API
AnalysisDisplayColorEntry Constructor (Color, Double)
AnalysisDisplayColorEntry Class See Also Send Feedback
Constructs a color entry with a specific value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry(
    Color color,
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    value As Double _
)
Visual C++
public:
AnalysisDisplayColorEntry(
    Color^ color,
    double value
)

Parameters

color
Type: Autodesk.Revit.DB..::.Color
Color assigned to the entry.
value
Type: System..::.Double
Value assigned to the entry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Methods

[image] [image]

Revit 2011 API
AnalysisDisplayColorEntry Methods
AnalysisDisplayColorEntry Class See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasValue | Check if color entry has associated value.
IsEqual | Compare color entries.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
AnalysisDisplayColorEntry..::.Dispose Method
AnalysisDisplayColorEntry Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


HasValue Method

[image]

Revit 2011 API
AnalysisDisplayColorEntry..::.HasValue Method
AnalysisDisplayColorEntry Class See Also Send Feedback
Check if color entry has associated value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasValue()
Visual Basic (Declaration)
Public Function HasValue As Boolean
Visual C++
public:
bool HasValue()

Return Value

True if entry has a value associated with it, false otherwise.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2011 API
AnalysisDisplayColorEntry..::.IsEqual Method
AnalysisDisplayColorEntry Class See Also Send Feedback
Compare color entries.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColorEntry other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As AnalysisDisplayColorEntry _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColorEntry^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorEntry
Color entry to compare to.

Return Value

True if color entries are equal, false otherwise.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Properties

[image] [image]

Revit 2011 API
AnalysisDisplayColorEntry Properties
AnalysisDisplayColorEntry Class See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Properties

Name | Description
Color | Color associated with color entry.
Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Color Property

[image]

Revit 2011 API
AnalysisDisplayColorEntry..::.Color Property
AnalysisDisplayColorEntry Class See Also Send Feedback
Color associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Value Property

[image]

Revit 2011 API
AnalysisDisplayColorEntry..::.Value Property
AnalysisDisplayColorEntry Class See Also Send Feedback
Value associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Class

[image]

Revit 2011 API
AnalysisDisplayColorSettings Class
Members Example See Also Send Feedback
Contains color settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColorSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayColorSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColorSettings : IDisposable

Examples

CopyC#
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
Color orange = new Color(255, 205, 0);
Color purple = new Color(200, 0, 200);
colorSettings.MaxColor = orange;
colorSettings.MinColor = purple;
CopyVB.NET
Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
Dim orange As New Color(255, 205, 0)
Dim purple As New Color(200, 0, 200)
colorSettings.MaxColor = orange
colorSettings.MinColor = purple

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings

See Also

AnalysisDisplayColorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Members

[image] [image]

Revit 2011 API
AnalysisDisplayColorSettings Members
AnalysisDisplayColorSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayColorSettings | Overloaded.

Methods

Name | Description
AreIntermediateColorsValid | Verify intermediate color entries
Colors | Get number of colors, including min, max and intermediate.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two color settings objects.
SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorSettingsType | Stores type of color settings
MaxColor | Color assigned to the maximum value.
MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

[image] [image]

Revit 2011 API
AnalysisDisplayColorSettings Constructor
AnalysisDisplayColorSettings Class See Also Send Feedback

Overload List

Name | Description
AnalysisDisplayColorSettings()()() | Constructs a default instance of color settings.
AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs copy of a color settings object.

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

[image]

Revit 2011 API
AnalysisDisplayColorSettings Constructor
AnalysisDisplayColorSettings Class See Also Send Feedback
Constructs a default instance of color settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalysisDisplayColorSettings()

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor (AnalysisDisplayColorSettings)

[image]

Revit 2011 API
AnalysisDisplayColorSettings Constructor (AnalysisDisplayColorSettings)
AnalysisDisplayColorSettings Class See Also Send Feedback
Constructs copy of a color settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As AnalysisDisplayColorSettings _
)
Visual C++
public:
AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings
Color settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Methods

[image] [image]

Revit 2011 API
AnalysisDisplayColorSettings Methods
AnalysisDisplayColorSettings Class See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Methods

Name | Description
AreIntermediateColorsValid | Verify intermediate color entries
Colors | Get number of colors, including min, max and intermediate.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two color settings objects.
SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AreIntermediateColorsValid Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.AreIntermediateColorsValid Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Verify intermediate color entries

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic (Declaration)
Public Function AreIntermediateColorsValid ( _
    map As IList(Of AnalysisDisplayColorEntry) _
) As Boolean
Visual C++
public:
bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::.IList <(Of <( AnalysisDisplayColorEntry >)>)
Array of intermediate color entries.

Return Value

True if intermediate colors are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Colors Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.Colors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Get number of colors, including min, max and intermediate.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int Colors()
Visual Basic (Declaration)
Public Function Colors As Integer
Visual C++
public:
int Colors()

Return Value

Number of colors, including min, max and intermediate.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.Dispose Method
AnalysisDisplayColorSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetIntermediateColors Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.GetIntermediateColors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Get intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void GetIntermediateColors(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic (Declaration)
Public Sub GetIntermediateColors ( _
    map As IList(Of AnalysisDisplayColorEntry) _
)
Visual C++
public:
void GetIntermediateColors(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::.IList <(Of <( AnalysisDisplayColorEntry >)>)
Array of intermediate color entries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.IsEqual Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Compares two color settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColorSettings other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As AnalysisDisplayColorSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings
Color settings object to compare to.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetIntermediateColors Method

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.SetIntermediateColors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Set intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic (Declaration)
Public Sub SetIntermediateColors ( _
    map As IList(Of AnalysisDisplayColorEntry) _
)
Visual C++
public:
void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::.IList <(Of <( AnalysisDisplayColorEntry >)>)
Array of intermediate color entries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Properties

[image] [image]

Revit 2011 API
AnalysisDisplayColorSettings Properties
AnalysisDisplayColorSettings Class See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Properties

Name | Description
ColorSettingsType | Stores type of color settings
MaxColor | Color assigned to the maximum value.
MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


ColorSettingsType Property

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.ColorSettingsType Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Stores type of color settings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayStyleColorSettingsType ColorSettingsType { get; set; }
Visual Basic (Declaration)
Public Property ColorSettingsType As AnalysisDisplayStyleColorSettingsType
Visual C++
public:
property AnalysisDisplayStyleColorSettingsType ColorSettingsType {
    AnalysisDisplayStyleColorSettingsType get ();
    void set (AnalysisDisplayStyleColorSettingsType value);
}

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


MaxColor Property

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.MaxColor Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Color assigned to the maximum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Color MaxColor { get; set; }
Visual Basic (Declaration)
Public Property MaxColor As Color
Visual C++
public:
property Color^ MaxColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


MinColor Property

[image]

Revit 2011 API
AnalysisDisplayColorSettings..::.MinColor Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Color assigned to the minimum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Color MinColor { get; set; }
Visual Basic (Declaration)
Public Property MinColor As Color
Visual C++
public:
property Color^ MinColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Class

[image]

Revit 2011 API
AnalysisDisplayLegend Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayLegend : Element
Visual Basic (Declaration)
Public Class AnalysisDisplayLegend _
    Inherits Element
Visual C++
public ref class AnalysisDisplayLegend : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegend

See Also

AnalysisDisplayLegend Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Members

[image] [image]

Revit 2011 API
AnalysisDisplayLegend Members
AnalysisDisplayLegend Class Methods Properties See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height, in sheet size, of the legend's rectangle
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width, in sheet size, of the legend's rectangle

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Methods

[image] [image]

Revit 2011 API
AnalysisDisplayLegend Methods
AnalysisDisplayLegend Class See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Properties

[image] [image]

Revit 2011 API
AnalysisDisplayLegend Properties
AnalysisDisplayLegend Class See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height, in sheet size, of the legend's rectangle
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width, in sheet size, of the legend's rectangle

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


Height Property

[image]

Revit 2011 API
AnalysisDisplayLegend..::.Height Property
AnalysisDisplayLegend Class See Also Send Feedback
The height, in sheet size, of the legend's rectangle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
AnalysisDisplayLegend..::.Parameter Property
AnalysisDisplayLegend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnalysisDisplayLegend Class
AnalysisDisplayLegend Members
Autodesk.Revit.DB.Analysis Namespace


Width Property

[image]

Revit 2011 API
AnalysisDisplayLegend..::.Width Property
AnalysisDisplayLegend Class See Also Send Feedback
The width, in sheet size, of the legend's rectangle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Class

[image]

Revit 2011 API
AnalysisDisplayLegendSettings Class
Members Example See Also Send Feedback
Contains legend settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayLegendSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayLegendSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayLegendSettings : IDisposable

Examples

CopyC#
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.NumberOfSteps = 10;
legendSettings.Rounding = 0.05;
legendSettings.ShowDataDescription = false;
legendSettings.ShowLegend = true;

FilteredElementCollector collector2 = new FilteredElementCollector(doc);
ICollection<Element> elementCollection = collector2.OfClass(typeof(TextNoteType)).ToElements();
var textElements = from element in collector2 where element.Name == "LegendText" select element;
if (textElements.Count() > 0) // if LegendText exists, use it for this Display Style
{
    TextNoteType textType = textElements.Cast<TextNoteType>().ElementAt<TextNoteType>(0);
    legendSettings.SetTextTypeId(textType.Id, doc);
}
CopyVB.NET
Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
legendSettings.NumberOfSteps = 10
legendSettings.Rounding = 0.05
legendSettings.ShowDataDescription = False
legendSettings.ShowLegend = True

Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
textElements = From element In collector2 _
 Where element.Name = "LegendText" _
 Select element
If textElements.Count() > 0 Then
    ' if LegendText exists, use it for this Display Style
    Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
    legendSettings.SetTextTypeId(textType.Id, doc)
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings

See Also

AnalysisDisplayLegendSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Members

[image] [image]

Revit 2011 API
AnalysisDisplayLegendSettings Members
AnalysisDisplayLegendSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayLegendSettings | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two legend settings objects.
SetTextTypeId | Set element id of text associated with legend settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Rounding | Rounding increment for numeric values of analysis results.
ShowDataDescription | If set to true, data description is shown in the legend.
ShowDataName | If set to true, data name is shown in the legend.
ShowLegend | If set to true, legend is shown in the view.
ShowUnits | If set to true, units are shown in the legend.
TextTypeId | Element id of text associated with legend settings.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

[image] [image]

Revit 2011 API
AnalysisDisplayLegendSettings Constructor
AnalysisDisplayLegendSettings Class See Also Send Feedback

Overload List

Name | Description
AnalysisDisplayLegendSettings()()() | Constructs a default instance of legend settings.
AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a copy of legend settings object.

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

[image]

Revit 2011 API
AnalysisDisplayLegendSettings Constructor
AnalysisDisplayLegendSettings Class See Also Send Feedback
Constructs a default instance of legend settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalysisDisplayLegendSettings()

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor (AnalysisDisplayLegendSettings)

[image]

Revit 2011 API
AnalysisDisplayLegendSettings Constructor (AnalysisDisplayLegendSettings)
AnalysisDisplayLegendSettings Class See Also Send Feedback
Constructs a copy of legend settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As AnalysisDisplayLegendSettings _
)
Visual C++
public:
AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Methods

[image] [image]

Revit 2011 API
AnalysisDisplayLegendSettings Methods
AnalysisDisplayLegendSettings Class See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two legend settings objects.
SetTextTypeId | Set element id of text associated with legend settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.Dispose Method
AnalysisDisplayLegendSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.IsEqual Method
AnalysisDisplayLegendSettings Class See Also Send Feedback
Compares two legend settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayLegendSettings other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As AnalysisDisplayLegendSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayLegendSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings object to compare to.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetTextTypeId Method

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.SetTextTypeId Method
AnalysisDisplayLegendSettings Class See Also Send Feedback
Set element id of text associated with legend settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetTextTypeId(
    ElementId textTypeId,
    Document doc
)
Visual Basic (Declaration)
Public Sub SetTextTypeId ( _
    textTypeId As ElementId, _
    doc As Document _
)
Visual C++
public:
void SetTextTypeId(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::.ElementId
Element id of text to be associated with legend settings.
doc
Type: Autodesk.Revit.DB..::.Document
Document for which %textTypeId" is validated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | text type id textTypeId is invalid - it refers to either non-existent element or element of wrong type.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Properties

[image] [image]

Revit 2011 API
AnalysisDisplayLegendSettings Properties
AnalysisDisplayLegendSettings Class See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Properties

Name | Description
NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Rounding | Rounding increment for numeric values of analysis results.
ShowDataDescription | If set to true, data description is shown in the legend.
ShowDataName | If set to true, data name is shown in the legend.
ShowLegend | If set to true, legend is shown in the view.
ShowUnits | If set to true, units are shown in the legend.
TextTypeId | Element id of text associated with legend settings.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


NumberOfSteps Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.NumberOfSteps Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Number of steps (values between minimum and maximum) to be shown in legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int NumberOfSteps { get; set; }
Visual Basic (Declaration)
Public Property NumberOfSteps As Integer
Visual C++
public:
property int NumberOfSteps {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | When setting this property: numberOfSteps is negative or too large

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.Rounding Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Rounding increment for numeric values of analysis results.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowDataDescription Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.ShowDataDescription Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If set to true, data description is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowDataDescription { get; set; }
Visual Basic (Declaration)
Public Property ShowDataDescription As Boolean
Visual C++
public:
property bool ShowDataDescription {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowDataName Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.ShowDataName Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If set to true, data name is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowDataName { get; set; }
Visual Basic (Declaration)
Public Property ShowDataName As Boolean
Visual C++
public:
property bool ShowDataName {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowLegend Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.ShowLegend Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If set to true, legend is shown in the view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowLegend { get; set; }
Visual Basic (Declaration)
Public Property ShowLegend As Boolean
Visual C++
public:
property bool ShowLegend {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowUnits Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.ShowUnits Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If set to true, units are shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowUnits { get; set; }
Visual Basic (Declaration)
Public Property ShowUnits As Boolean
Visual C++
public:
property bool ShowUnits {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2011 API
AnalysisDisplayLegendSettings..::.TextTypeId Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Element id of text associated with legend settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId TextTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextTypeId As ElementId
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Class

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Class
Members See Also Send Feedback
Contains markers and text settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayMarkersAndTextSettings : IDisposable
Visual Basic (Declaration)
Public Class AnalysisDisplayMarkersAndTextSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings

See Also

AnalysisDisplayMarkersAndTextSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Members

[image] [image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Members
AnalysisDisplayMarkersAndTextSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors

Name | Description
AnalysisDisplayMarkersAndTextSettings | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two colored surface settings objects.
SetTextTypeId | Set element id of text associated with settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MarkerSize | Size of marker.
MarkerType | Type of marker to use in the analysis display.
Rounding | Increment to which numeric values of analysis results are to be rounded in legend.
ShowText | If set to true, show text in the analysis display.
TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

[image] [image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Constructor
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

Overload List

Name | Description
AnalysisDisplayMarkersAndTextSettings()()() | Constructs a default instance of markers and text settings.
AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a copy of markers and text settings object.

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Constructor
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Constructs a default instance of markers and text settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings()

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor (AnalysisDisplayMarkersAndTextSettings)

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Constructor (AnalysisDisplayMarkersAndTextSettings)
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Constructs a copy of markers and text settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As AnalysisDisplayMarkersAndTextSettings _
)
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings
Markers and text settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Methods

[image] [image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Methods
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Compares two colored surface settings objects.
SetTextTypeId | Set element id of text associated with settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.Dispose Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.IsEqual Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings other
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    other As AnalysisDisplayMarkersAndTextSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings
Markers and text settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetTextTypeId Method

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.SetTextTypeId Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Set element id of text associated with settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetTextTypeId(
    ElementId textTypeId,
    Document doc
)
Visual Basic (Declaration)
Public Sub SetTextTypeId ( _
    textTypeId As ElementId, _
    doc As Document _
)
Visual C++
public:
void SetTextTypeId(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::.ElementId
Element id of text to be associated with settings.
doc
Type: Autodesk.Revit.DB..::.Document
Document for which %textTypeId" is validated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | text type id textTypeId is invalid - it refers to either non-existent element or element of wrong type.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Properties

[image] [image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings Properties
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Properties

Name | Description
MarkerSize | Size of marker.
MarkerType | Type of marker to use in the analysis display.
Rounding | Increment to which numeric values of analysis results are to be rounded in legend.
ShowText | If set to true, show text in the analysis display.
TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


MarkerSize Property

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.MarkerSize Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Size of marker.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double MarkerSize { get; set; }
Visual Basic (Declaration)
Public Property MarkerSize As Double
Visual C++
public:
property double MarkerSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | When setting this property: markerSize is negative

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


MarkerType Property

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.MarkerType Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Type of marker to use in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayStyleMarkerType MarkerType { get; set; }
Visual Basic (Declaration)
Public Property MarkerType As AnalysisDisplayStyleMarkerType
Visual C++
public:
property AnalysisDisplayStyleMarkerType MarkerType {
    AnalysisDisplayStyleMarkerType get ();
    void set (AnalysisDisplayStyleMarkerType value);
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.Rounding Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Increment to which numeric values of analysis results are to be rounded in legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Double
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowText Property

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.ShowText Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
If set to true, show text in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowText { get; set; }
Visual Basic (Declaration)
Public Property ShowText As Boolean
Visual C++
public:
property bool ShowText {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2011 API
AnalysisDisplayMarkersAndTextSettings..::.TextTypeId Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId TextTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextTypeId As ElementId
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Class

[image]

Revit 2011 API
AnalysisDisplayStyle Class
Members Example See Also Send Feedback
Exposes API for manipulation of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayStyle : Element
Visual Basic (Declaration)
Public Class AnalysisDisplayStyle _
    Inherits Element
Visual C++
public ref class AnalysisDisplayStyle : public Element

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;

AnalysisDisplayStyle analysisDisplayStyle = null;
// Look for an existing analysis display style with a specific name
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
ICollection<Element> collection = collector1.OfClass(typeof(AnalysisDisplayStyle)).ToElements();
var displayStyle = from element in collection
                   where element.Name == "Display Style 1"
                   select element;

// If display style does not already exist in the document, create it
if (displayStyle.Count() == 0)
{
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings =
        new AnalysisDisplayColoredSurfaceSettings();
    coloredSurfaceSettings.ShowGridLines = true;

    AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
    Color orange = new Color(255, 205, 0);
    Color purple = new Color(200, 0, 200);
    colorSettings.MaxColor = orange;
    colorSettings.MinColor = purple;

    AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
    legendSettings.NumberOfSteps = 10;
    legendSettings.Rounding = 0.05;
    legendSettings.ShowDataDescription = false;
    legendSettings.ShowLegend = true;

    FilteredElementCollector collector2 = new FilteredElementCollector(doc);
    ICollection<Element> elementCollection =
        collector2.OfClass(typeof(TextNoteType)).ToElements();
    var textElements = from element in collector2
                       where element.Name == "LegendText"
                       select element;

    // if LegendText exists, use it for this Display Style
    if (textElements.Count() > 0)
    {
        TextNoteType textType =
            textElements.Cast<TextNoteType>().ElementAt<TextNoteType>(0);
        legendSettings.SetTextTypeId(textType.Id, doc);
    }
    analysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc,
        "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings);
}
else
{
    analysisDisplayStyle = displayStyle.Cast<AnalysisDisplayStyle>().ElementAt<AnalysisDisplayStyle>(0);
}

// now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle.Id;
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document

Dim analysisDisplayStyl As Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle = Nothing
' Look for an existing analysis display style with a specific name
Dim collector1 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector1.OfClass(GetType(Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)).ToElements()
Dim displayStyle As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
displayStyle = From element In collection _
 Where element.Name = "Display Style 1" _
 Select element

' If display style does not already exist in the document, create it
If displayStyle.Count() = 0 Then
    Dim coloredSurfaceSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColoredSurfaceSettings()
    coloredSurfaceSettings.ShowGridLines = True

    Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
    Dim orange As New Color(255, 205, 0)
    Dim purple As New Color(200, 0, 200)
    colorSettings.MaxColor = orange
    colorSettings.MinColor = purple

    Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
    legendSettings.NumberOfSteps = 10
    legendSettings.Rounding = 0.05
    legendSettings.ShowDataDescription = False
    legendSettings.ShowLegend = True

    Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
    Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
    Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
    textElements = From element In collector2 _
     Where element.Name = "LegendText" _
     Select element

    ' if LegendText exists, use it for this Display Style
    If textElements.Count() > 0 Then
        Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
        legendSettings.SetTextTypeId(textType.Id, doc)
    End If
    analysisDisplayStyl = Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings)
Else
    analysisDisplayStyl = displayStyle.Cast(Of Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)().ElementAt(0)
End If

' now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyl.Id

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.AnalysisDisplayStyle

See Also

AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Members

[image] [image]

Revit 2011 API
AnalysisDisplayStyle Members
AnalysisDisplayStyle Class Methods Properties See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateAnalysisDisplayStyle | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindByName | Finds analysis display style by name.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetColoredSurfaceSettings | Get colored surface settings object from the style.
GetColorSettings | Get color settings object from the style.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetElements | Returns set of all analysis display styles elements in the given document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegendSettings | Get legend settings object from the style.
GetMarkersAndTextSettings | Get markers and text settings object from the style.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
IsTextTypeIdValid | Verify if text type id is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetColoredSurfaceSettings | Set colored surface settings object for the style.
SetColorSettings | Set color settings object for the style.
SetLegendSettings | Set legend settings object for the style.
SetMarkersAndTextSettings | Set markers and text settings object for the style.
SetName | Set name of analysis display style element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Methods

[image] [image]

Revit 2011 API
AnalysisDisplayStyle Methods
AnalysisDisplayStyle Class See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateAnalysisDisplayStyle | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindByName | Finds analysis display style by name.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetColoredSurfaceSettings | Get colored surface settings object from the style.
GetColorSettings | Get color settings object from the style.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetElements | Returns set of all analysis display styles elements in the given document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegendSettings | Get legend settings object from the style.
GetMarkersAndTextSettings | Get markers and text settings object from the style.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
IsTextTypeIdValid | Verify if text type id is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetColoredSurfaceSettings | Set colored surface settings object for the style.
SetColorSettings | Set color settings object for the style.
SetLegendSettings | Set legend settings object for the style.
SetMarkersAndTextSettings | Set markers and text settings object for the style.
SetName | Set name of analysis display style element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method

[image] [image]

Revit 2011 API
AnalysisDisplayStyle..::.CreateAnalysisDisplayStyle Method
AnalysisDisplayStyle Class See Also Send Feedback

Overload List

Name | Description
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object for the given document.

See Also

AnalysisDisplayStyle Class
AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2011 API
AnalysisDisplayStyle..::.CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic (Declaration)
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document for which analysis display style object is created.
name
Type: System..::.String
Unique name of the analysis display style within the %document%.
coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings
Colored surface settings for the style to be created.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings
Color settings for the style to be created.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings for the style to be created.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2011 API
AnalysisDisplayStyle..::.CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic (Declaration)
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document for which analysis display style object is created.
name
Type: System..::.String
Unique name of the analysis display style within the %document%.
markersAndTextSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings
Markers and text settings for the style to be created.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings
Color settings for the style to be created.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings
Legend settings for the style to be created.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


FindByName Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.FindByName Method
AnalysisDisplayStyle Class See Also Send Feedback
Finds analysis display style by name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElementId FindByName(
    Document cda,
    string name
)
Visual Basic (Declaration)
Public Shared Function FindByName ( _
    cda As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindByName(
    Document^ cda,
    String^ name
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document in which to look for analysis display style element.
name
Type: System..::.String
Name of analysis display style to look for.

Return Value

Element id of the found analysis display style, invalidElementId if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetColoredSurfaceSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.GetColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get colored surface settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings GetColoredSurfaceSettings()
Visual Basic (Declaration)
Public Function GetColoredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings^ GetColoredSurfaceSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetColorSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.GetColorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get color settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings GetColorSettings()
Visual Basic (Declaration)
Public Function GetColorSettings As AnalysisDisplayColorSettings
Visual C++
public:
AnalysisDisplayColorSettings^ GetColorSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetElements Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.GetElements Method
AnalysisDisplayStyle Class See Also Send Feedback
Returns set of all analysis display styles elements in the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetElements(
    Document cda
)
Visual Basic (Declaration)
Public Shared Function GetElements ( _
    cda As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetElements(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document from which analysis display style elements are retrieved.

Return Value

All analysis display style elements existing in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetLegendSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.GetLegendSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get legend settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings GetLegendSettings()
Visual Basic (Declaration)
Public Function GetLegendSettings As AnalysisDisplayLegendSettings
Visual C++
public:
AnalysisDisplayLegendSettings^ GetLegendSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetMarkersAndTextSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.GetMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get markers and text settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings GetMarkersAndTextSettings()
Visual Basic (Declaration)
Public Function GetMarkersAndTextSettings As AnalysisDisplayMarkersAndTextSettings
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings^ GetMarkersAndTextSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


IsNameUnique Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.IsNameUnique Method
AnalysisDisplayStyle Class See Also Send Feedback
Verify the uniqueness of the name among all analysis display style elements of the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsNameUnique(
    Document cda,
    string name,
    AnalysisDisplayStyle excludedElement
)
Visual Basic (Declaration)
Public Shared Function IsNameUnique ( _
    cda As Document, _
    name As String, _
    excludedElement As AnalysisDisplayStyle _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
    Document^ cda,
    String^ name,
    AnalysisDisplayStyle^ excludedElement
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
Document in which name uniqueness is verified.
name
Type: System..::.String
Name to verify uniqueness of.
excludedElement
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).

Return Value

True if name is unique, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


IsTextTypeIdValid Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.IsTextTypeIdValid Method
AnalysisDisplayStyle Class See Also Send Feedback
Verify if text type id is valid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsTextTypeIdValid(
    ElementId textTypeId,
    Document doc
)
Visual Basic (Declaration)
Public Shared Function IsTextTypeIdValid ( _
    textTypeId As ElementId, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsTextTypeIdValid(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::.ElementId
Text type id to be validated.
doc
Type: Autodesk.Revit.DB..::.Document
Document for which %textTypeId" is validated.

Return Value

True if text type id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetColoredSurfaceSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.SetColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set colored surface settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings
)
Visual Basic (Declaration)
Public Sub SetColoredSurfaceSettings ( _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings
)

Parameters

coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColoredSurfaceSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | colored surface settings were not created with the object.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetColorSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.SetColorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set color settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetColorSettings(
    AnalysisDisplayColorSettings colorSettings
)
Visual Basic (Declaration)
Public Sub SetColorSettings ( _
    colorSettings As AnalysisDisplayColorSettings _
)
Visual C++
public:
void SetColorSettings(
    AnalysisDisplayColorSettings^ colorSettings
)

Parameters

colorSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayColorSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetLegendSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.SetLegendSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set legend settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetLegendSettings(
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic (Declaration)
Public Sub SetLegendSettings ( _
    legendSettings As AnalysisDisplayLegendSettings _
)
Visual C++
public:
void SetLegendSettings(
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

legendSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayLegendSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetMarkersAndTextSettings Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.SetMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set markers and text settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings
)
Visual Basic (Declaration)
Public Sub SetMarkersAndTextSettings ( _
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings _
)
Visual C++
public:
void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings
)

Parameters

markersAndTextSettings
Type: Autodesk.Revit.DB.Analysis..::.AnalysisDisplayMarkersAndTextSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | markers and text settings were not created with the object.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetName Method

[image]

Revit 2011 API
AnalysisDisplayStyle..::.SetName Method
AnalysisDisplayStyle Class See Also Send Feedback
Set name of analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic (Declaration)
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::.String
Analysis display style element name to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | name is not unique in document.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Properties

[image] [image]

Revit 2011 API
AnalysisDisplayStyle Properties
AnalysisDisplayStyle Class See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
AnalysisDisplayStyle..::.Parameter Property
AnalysisDisplayStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleColorSettingsType Enumeration

[image]

Revit 2011 API
AnalysisDisplayStyleColorSettingsType Enumeration
See Also Send Feedback
Defines types for color settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum AnalysisDisplayStyleColorSettingsType
Visual Basic (Declaration)
Public Enumeration AnalysisDisplayStyleColorSettingsType
Visual C++
public enum class AnalysisDisplayStyleColorSettingsType

Members

Member name | Description
GradientColor | Intermediate color entries and min/max color settings are used for calculation of color for values between two entries.
SolidColorRanges | Intermediate color entries and min/max color settings are treated as set of value ranges for which color is constant.

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleMarkerType Enumeration

[image]

Revit 2011 API
AnalysisDisplayStyleMarkerType Enumeration
See Also Send Feedback
Defines marker types for markers and text settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum AnalysisDisplayStyleMarkerType
Visual Basic (Declaration)
Public Enumeration AnalysisDisplayStyleMarkerType
Visual C++
public enum class AnalysisDisplayStyleMarkerType

Members

Member name | Description
Circle |
Square |
Triangle |

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionFloorSlabType Enumeration

[image]

Revit 2011 API
ConceptualConstructionFloorSlabType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionFloorSlabType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionFloorSlabType
Visual C++
public enum class ConceptualConstructionFloorSlabType

Members

Member name | Description
InvalidFloorSlabTypeConstruction | Invalid/not set Floor or Slab Type construction value
LightweightConstructionHighInsulation | Lightweight Consruction High Insulation Floor
LightweightConstructionTypicalInsulation | Lightweight Construction Typical Insulation Floor
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Floor
LightweightConstructionNoInsulationInterior | Lighweight Construction No Insulatoin Interior Floor
HighMassConstructionFrigidClimateSlabInsulation | High Mass Construction Frigid Climate Insulation Slab
HighMassConstructionColdClimateSlabInsulation | High Mass Construction Cold Climate Insulation Slab
HighMassConstructionTypicalNoInsulation | High Mass Construction Typical No Insulation Slab
NumFloorSlabTypeConstruction | Total number of Floor/Slab Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionOpeningType Enumeration

[image]

Revit 2011 API
ConceptualConstructionOpeningType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionOpeningType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionOpeningType
Visual C++
public enum class ConceptualConstructionOpeningType

Members

Member name | Description
InvalidOpeningTypeConstruction | Invalid value/not set Opening Type Construction
Air | Air Opening
NumOpeningTypeConstruction | Total Number of Opening Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionRoofType Enumeration

[image]

Revit 2011 API
ConceptualConstructionRoofType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Roofs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionRoofType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionRoofType
Visual C++
public enum class ConceptualConstructionRoofType

Members

Member name | Description
InvalidRoofTypeConstruction | Invalid value/not set Roof Type Construction value
HighInsulationCoolRoof | High Insulation Cool Roof
HighInsulationDarkRoof | High Insualtion Dark Roof
TypicalInsulationCoolRoof | Typical Insulation Cool Roof
TypicalInsulationDarkRoof | Typical Insulation Dark Roof
LowInsulationCoolRoof | Low Insulation Cool Roof
LowInsulationDarkRoof | Low Insulation Dark Roof
NoInsulationDarkRoof | No Insulation Dark Roof
NumRoofTypeConstruction | Total Number of Roof Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionShadeType Enumeration

[image]

Revit 2011 API
ConceptualConstructionShadeType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Shades.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionShadeType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionShadeType
Visual C++
public enum class ConceptualConstructionShadeType

Members

Member name | Description
InvalidShadeTypeConstruction | Invalid value/not set Shade Type Construction
BasicShade | Basic Shade
NumShadeTypeConstruction | Total Number of Shade Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Class

[image]

Revit 2011 API
ConceptualConstructionType Class
Members See Also Send Feedback
This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class ConceptualConstructionType : ElementType
Visual Basic (Declaration)
Public Class ConceptualConstructionType _
    Inherits ElementType
Visual C++
public ref class ConceptualConstructionType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Analysis..::.ConceptualConstructionType

See Also

ConceptualConstructionType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Members

[image] [image]

Revit 2011 API
ConceptualConstructionType Members
ConceptualConstructionType Class Methods Properties See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
CanHaveTypeAssigned
Identifies if the element can have a type assigned.
(Inherited from Element.)
ChangeTypeId
Changes type of the element.
(Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate
Duplicate this object.
(Inherited from ElementType.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
GetGBSId
Gets the Green Building Studio identifier associated with the construction.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
GetValidTypes
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
IsValidType
Checks if given type is valid for this element.
(Inherited from Element.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
MaterialId | Material used for visualization of this construction.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Methods

[image] [image]

Revit 2011 API
ConceptualConstructionType Methods
ConceptualConstructionType Class See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
CanHaveTypeAssigned
Identifies if the element can have a type assigned.
(Inherited from Element.)
ChangeTypeId
Changes type of the element.
(Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate
Duplicate this object.
(Inherited from ElementType.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
GetGBSId
Gets the Green Building Studio identifier associated with the construction.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
GetValidTypes
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
IsValidType
Checks if given type is valid for this element.
(Inherited from Element.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetAllConceptualConstructionsForCategory Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetAllConceptualConstructionsForCategory Method
ConceptualConstructionType Class See Also Send Feedback
Get all the ids of constructions applicable to the input massSubCategory

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
    Document ccda,
    ElementId massSubCategoryId
)
Visual Basic (Declaration)
Public Shared Function GetAllConceptualConstructionsForCategory ( _
    ccda As Document, _
    massSubCategoryId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllConceptualConstructionsForCategory(
    Document^ ccda,
    ElementId^ massSubCategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the mass subcategory.

Return Value

Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetFloorOrSlabConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetFloorOrSlabConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetFloorOrSlabConstructionType(
    Document ccda,
    ConceptualConstructionFloorSlabType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetFloorOrSlabConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionFloorSlabType _
) As ElementId
Visual C++
public:
static ElementId^ GetFloorOrSlabConstructionType(
    Document^ ccda,
    ConceptualConstructionFloorSlabType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionFloorSlabType
The ConceptualConstructionFloorSlabType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionFloorSlabType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetGBSId Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetGBSId Method
ConceptualConstructionType Class See Also Send Feedback
Gets the Green Building Studio identifier associated with the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public int GetGBSId(
    ElementId massSurfaceSubCategoryId
)
Visual Basic (Declaration)
Public Function GetGBSId ( _
    massSurfaceSubCategoryId As ElementId _
) As Integer
Visual C++
public:
int GetGBSId(
    ElementId^ massSurfaceSubCategoryId
)

Parameters

massSurfaceSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of a valid Mass subcategory of a MassSurfaceData.

Return Value

Returns the integer id used to represent the ConceptualConstructionType.

Remarks

Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetOpeningConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetOpeningConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetOpeningConstructionType(
    Document ccda,
    ConceptualConstructionOpeningType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetOpeningConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionOpeningType _
) As ElementId
Visual C++
public:
static ElementId^ GetOpeningConstructionType(
    Document^ ccda,
    ConceptualConstructionOpeningType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionOpeningType
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionOpeningType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetRoofConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetRoofConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetRoofConstructionType(
    Document ccda,
    ConceptualConstructionRoofType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetRoofConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionRoofType _
) As ElementId
Visual C++
public:
static ElementId^ GetRoofConstructionType(
    Document^ ccda,
    ConceptualConstructionRoofType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionRoofType
The ConceptualConstructionRoofType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionRoofType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetShadeConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetShadeConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetShadeConstructionType(
    Document ccda,
    ConceptualConstructionShadeType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetShadeConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionShadeType _
) As ElementId
Visual C++
public:
static ElementId^ GetShadeConstructionType(
    Document^ ccda,
    ConceptualConstructionShadeType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionShadeType
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionShadeType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetWallConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetWallConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetWallConstructionType(
    Document ccda,
    ConceptualConstructionWallType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetWallConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWallType _
) As ElementId
Visual C++
public:
static ElementId^ GetWallConstructionType(
    Document^ ccda,
    ConceptualConstructionWallType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionWallType
The ConceptualConstructionWallType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWallType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetWindowOrSkylightConstructionType Method

[image]

Revit 2011 API
ConceptualConstructionType..::.GetWindowOrSkylightConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetWindowOrSkylightConstructionType(
    Document ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)
Visual Basic (Declaration)
Public Shared Function GetWindowOrSkylightConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWindowSkylightType _
) As ElementId
Visual C++
public:
static ElementId^ GetWindowOrSkylightConstructionType(
    Document^ ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::.ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWindowSkylightType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionId Method

[image]

Revit 2011 API
ConceptualConstructionType..::.IsValidConceptualConstructionId Method
ConceptualConstructionType Class See Also Send Feedback
Indicates if the ElementId is an id of a ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidConceptualConstructionId(
    Document ccda,
    ElementId constructionTypeId
)
Visual Basic (Declaration)
Public Shared Function IsValidConceptualConstructionId ( _
    ccda As Document, _
    constructionTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionId(
    Document^ ccda,
    ElementId^ constructionTypeId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the ConceptualConstructionType.

Return Value

Returns true if is an id of a ConceptualConstructionType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionIdForCategory Method

[image]

Revit 2011 API
ConceptualConstructionType..::.IsValidConceptualConstructionIdForCategory Method
ConceptualConstructionType Class See Also Send Feedback
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidConceptualConstructionIdForCategory(
    Document ccda,
    ElementId constructionTypeId,
    ElementId massSubcategoryId
)
Visual Basic (Declaration)
Public Shared Function IsValidConceptualConstructionIdForCategory ( _
    ccda As Document, _
    constructionTypeId As ElementId, _
    massSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionIdForCategory(
    Document^ ccda,
    ElementId^ constructionTypeId,
    ElementId^ massSubcategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the ConceptualConstructionType.
massSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of the Mass subcategory.

Return Value

Returns true if valid, false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidSubcategoryForMassSurfaceDatas Method

[image]

Revit 2011 API
ConceptualConstructionType..::.IsValidSubcategoryForMassSurfaceDatas Method
ConceptualConstructionType Class See Also Send Feedback
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId massSubCategoryId
)
Visual Basic (Declaration)
Public Shared Function IsValidSubcategoryForMassSurfaceDatas ( _
    massSubCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId^ massSubCategoryId
)

Parameters

massSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The mass sub-category to be checked.

Return Value

True if the mass sub-category falls within the list, false otherwise.

Remarks

This excludes sub-categories which are not actually sub-categories that can be assigned to surfaces, such as OST_MassWallsAll for example.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidSurfaceSubcategoryForConstruction Method

[image]

Revit 2011 API
ConceptualConstructionType..::.IsValidSurfaceSubcategoryForConstruction Method
ConceptualConstructionType Class See Also Send Feedback
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsValidSurfaceSubcategoryForConstruction(
    ElementId massSurfaceSubcategoryId
)
Visual Basic (Declaration)
Public Function IsValidSurfaceSubcategoryForConstruction ( _
    massSurfaceSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidSurfaceSubcategoryForConstruction(
    ElementId^ massSurfaceSubcategoryId
)

Parameters

massSurfaceSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId
The ElementId of a Mass subcategory of a MassSurfaceData.

Return Value

Returns true if appropriate for the input subcategory, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Element massSurfaceSubcategoryId is not a valid subcategory value for MassSurfaceData.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Properties

[image] [image]

Revit 2011 API
ConceptualConstructionType Properties
ConceptualConstructionType Class See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
MaterialId | Material used for visualization of this construction.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceSubCategoryId Property

[image]

Revit 2011 API
ConceptualConstructionType..::.MassSurfaceSubCategoryId Property
ConceptualConstructionType Class See Also Send Feedback
The surface type subcategory element id associated with the ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MassSurfaceSubCategoryId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MassSurfaceSubCategoryId As ElementId
Visual C++
public:
property ElementId^ MassSurfaceSubCategoryId {
    ElementId^ get ();
}

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2011 API
ConceptualConstructionType..::.MaterialId Property
ConceptualConstructionType Class See Also Send Feedback
Material used for visualization of this construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic (Declaration)
Public Property MaterialId As ElementId
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
ConceptualConstructionType..::.Parameter Property
ConceptualConstructionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ConceptualConstructionType Class
ConceptualConstructionType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWallType Enumeration

[image]

Revit 2011 API
ConceptualConstructionWallType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionWallType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionWallType
Visual C++
public enum class ConceptualConstructionWallType

Members

Member name | Description
InvalidExteriorWallTypeConstruction | Invalid value/not set Roof Type Construction value
LightweightConstructionHighInsulation | Lightweight Construction High Insulation Wall
LightweightConstructionTypicalColdClimateInsulation | Lightweight Construction Typical Cold Climate Insulation Wall
LightweightConstructionTypicalMildClimateInsulation | Lightweight Construction Typical Mild Climate Insulation Wall
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Wall
LightweightConstructionNoInsulationInterior | Lightweight Construction No Insulation Interior Wall
HighMassConstructionHighInsulation | High Mass Construction High Insulation Wall
HighMassConstructionTypicalColdClimateInsulation | High Mass Construction Typical Cold Climate Insulation Wall
HighMassConstructionTypicalMildClimateInsulation | High Mass Construction Typical Mild Climate Insulation Wall
HighMassConstructionNoInsulationInterior | High Mass Construction No Insulation Interior Wall
NumWallTypeConstruction | Total Number of Wall Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWindowSkylightType Enumeration

[image]

Revit 2011 API
ConceptualConstructionWindowSkylightType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Windows and Skylights

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum ConceptualConstructionWindowSkylightType
Visual Basic (Declaration)
Public Enumeration ConceptualConstructionWindowSkylightType
Visual C++
public enum class ConceptualConstructionWindowSkylightType

Members

Member name | Description
InvalidWindowSkylightTypeConstruction | Invalid value/not set Window or Skylight Type Construction
SinglePaneClearNoCoating | Single Pane Clear No Coating Window or Skylight
SinglePaneTinted | Single Pane Tinted Window or Skylight
SinglePaneReflective | Single Pane Reflective Window or Skylight
DoublePaneClearNoCoating | Double Pane Clear No Coating Window or Skylight
DoublePaneTinted | Double Pane Tinted Window or Skylight
DoublePaneReflective | Double Pane Reflective Window or Skylight
DoublePaneClearLowEColdClimateHighSHGC | Double Pane Clear Low Energy Cold Climate High Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearLowEHotClimateLowSHGC | Double Pane Clear Low Energy Hot Climate Low Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearHighestPerformanceLowEHighVisTransLowSHGC | Double Pane Clear Highest Performance Low Window or Skylight
TriplePaneClearLowEHotOrColdClimate | Triple Pane Clear Low Energy Hot or Cold Climate Window or Skylight
QuadPaneClearLowEHotOrColdClimate | Quad Pane Clear Low Energy Hot Or Cold Climate Window or Skylight
NumWindowSkylightTypeConstruction | Total Number of Window or Skylight Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Class

[image]

Revit 2011 API
ConceptualSurfaceType Class
Members See Also Send Feedback
This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class ConceptualSurfaceType : IDisposable
Visual Basic (Declaration)
Public Class ConceptualSurfaceType _
    Implements IDisposable
Visual C++
public ref class ConceptualSurfaceType : IDisposable

Remarks

When Conceptual Energy Analysis is enabled in Revit Projects, massing faces will be assigned to the subcategories of Mass category that these ConceptualSurfaceType's are associated with. A default ConceptualConstructionType is associated with the ConceptualSurfaceType. This default ConceptualConstructionType is assigned to Mass faces with the corresponding subcategory. Changing the the default ConceptualConstructionType associated with the ConceptualSurfaceType will update the ConceptualConstruction type for all Mass faces of that subcategory which the user has not specifically provided an override value for.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.ConceptualSurfaceType

See Also

ConceptualSurfaceType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Members

[image] [image]

Revit 2011 API
ConceptualSurfaceType Members
ConceptualSurfaceType Class Methods Properties See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Methods

[image] [image]

Revit 2011 API
ConceptualSurfaceType Methods
ConceptualSurfaceType Class See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
ConceptualSurfaceType..::.Dispose Method
ConceptualSurfaceType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetAllMassSubCategoryIds Method

[image]

Revit 2011 API
ConceptualSurfaceType..::.GetAllMassSubCategoryIds Method
ConceptualSurfaceType Class See Also Send Feedback
Get all the mass subcategory ids for which there are ConceptualSurfaceType's.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<ElementId> GetAllMassSubCategoryIds()
Visual Basic (Declaration)
Public Shared Function GetAllMassSubCategoryIds As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllMassSubCategoryIds()

Return Value

Returns an array of element id of mass subcategories for which there are ConceptualSurfaceType's.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetByMassSubCategoryId Method

[image]

Revit 2011 API
ConceptualSurfaceType..::.GetByMassSubCategoryId Method
ConceptualSurfaceType Class See Also Send Feedback
Get the ConceptualSurfaceType by its mass subcategory id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ConceptualSurfaceType GetByMassSubCategoryId(
    Document cda,
    ElementId massSubCategoryId
)
Visual Basic (Declaration)
Public Shared Function GetByMassSubCategoryId ( _
    cda As Document, _
    massSubCategoryId As ElementId _
) As ConceptualSurfaceType
Visual C++
public:
static ConceptualSurfaceType^ GetByMassSubCategoryId(
    Document^ cda,
    ElementId^ massSubCategoryId
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The mass subcategory id to get the ConceptualSurfaceType for.

Return Value

Returns ConceptualSurfaceType associated with input id or NULL.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassWindow, OST_MassSkylights, or OST_MassOpening.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetConstructionTypeIds Method

[image]

Revit 2011 API
ConceptualSurfaceType..::.GetConstructionTypeIds Method
ConceptualSurfaceType Class See Also Send Feedback
The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ICollection<ElementId> GetConstructionTypeIds()
Visual Basic (Declaration)
Public Function GetConstructionTypeIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetConstructionTypeIds()

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Properties

[image] [image]

Revit 2011 API
ConceptualSurfaceType Properties
ConceptualSurfaceType Class See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Properties

Name | Description
DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


DefaultConstructionTypeId Property

[image]

Revit 2011 API
ConceptualSurfaceType..::.DefaultConstructionTypeId Property
ConceptualSurfaceType Class See Also Send Feedback
The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId DefaultConstructionTypeId { get; set; }
Visual Basic (Declaration)
Public Property DefaultConstructionTypeId As ElementId
Visual C++
public:
property ElementId^ DefaultConstructionTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


MassSubCategoryId Property

[image]

Revit 2011 API
ConceptualSurfaceType..::.MassSubCategoryId Property
ConceptualSurfaceType Class See Also Send Feedback
The mass subcategory id of the ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MassSubCategoryId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MassSubCategoryId As ElementId
Visual C++
public:
property ElementId^ MassSubCategoryId {
    ElementId^ get ();
}

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConstructionType Enumeration

[image]

Revit 2011 API
ConstructionType Enumeration
See Also Send Feedback
This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ConstructionType
Visual Basic (Declaration)
Public Enumeration ConstructionType
Visual C++
public enum class ConstructionType

Members

Member name | Description
ExteriorWall | An exterior wall surrounding the space
InteriorWall | An interior wall surrounding the space
Slab | A slab below the space
Roof | A roof over the space
Ceiling | A ceiling over the space
Floor | A floor below the space
Door | A door in a wall in the space
ExteriorWindow | A window in an exterior wall in the space
InteriorWindow | A window in an interior wall in the space
Skylight | A window in a roof in the space
NoOfConstructionTypes | The number of construction types

See Also

Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Class

[image]

Revit 2011 API
EnergyDataSettings Class
Members Example See Also Send Feedback
This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class EnergyDataSettings : IDisposable
Visual Basic (Declaration)
Public Class EnergyDataSettings _
    Implements IDisposable
Visual C++
public ref class EnergyDataSettings : IDisposable

Examples

CopyC#
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_EnergyData(ByVal document As Document)
    Dim energyData As Autodesk.Revit.DB.Analysis.EnergyDataSettings = Autodesk.Revit.DB.Analysis.EnergyDataSettings.GetFromDocument(document)

    If energyData IsNot Nothing Then
        Dim message As String = "energyData : "
        message += vbLf & "BuildingType : " + energyData.BuildingType
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.EnergyDataSettings

See Also

EnergyDataSettings Members
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Members

[image] [image]

Revit 2011 API
EnergyDataSettings Members
EnergyDataSettings Class Methods Properties See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Methods

Name | Description
CheckBuildingConstructionClass
Checks that the building construction class falls within an appropriate range.
CheckBuildingHVACSystem
Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule
Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType
Checks that the building type falls within an appropriate range.
CheckConstructionSetElement
Checks that the construction set ElementId is acceptable.
CheckExportCategory
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
  3. OST_Massing
CheckExportComplexity
Checks that the export complexity falls within an appropriate range.
CheckGroundPlane | Overloaded.
CheckProjectPhase
Checks that the input element is a project phase.
CheckProjectReportType
Checks that the project report type falls within an appropriate range.
CheckRangeOfMassZoneCoreOffset
Checks that the mass zone core offset is greater than or equal to zero.
CheckRangeOfPercentageGlazing
Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights
Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth
Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight
Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth
Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance
Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType
Checks that the service type falls within an appropriate range.
Dispose
EnableConceptualEnergyAnalyticalModel
Turns on functionality related to conceptual energy analysis.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetBuildingConstructionSetElementId
Id of the building construction set.
GetFromDocument
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDocumentUsingEnergyDataAnalyticalModel
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
SetCreateAnalyticalModel
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

Name | Description
BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
BuildingType | The type of building.
CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
GroundPlane | Id of level which represents ground level.
IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
OutsideAirChangesRatePerHour |
OutsideAirPerArea |
OutsideAirPerPerson |
PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the the building exterior wall surfaces which are covered by windows or other glazing.
PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
ProjectPhase | The project phase of the EnergyData information.
ProjectReportType | Report type: None, simple, standard, detailed
ServiceType | The type of heating or cooling system.
ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Methods

[image] [image]

Revit 2011 API
EnergyDataSettings Methods
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Methods

Name | Description
CheckBuildingConstructionClass
Checks that the building construction class falls within an appropriate range.
CheckBuildingHVACSystem
Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule
Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType
Checks that the building type falls within an appropriate range.
CheckConstructionSetElement
Checks that the construction set ElementId is acceptable.
CheckExportCategory
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
  3. OST_Massing
CheckExportComplexity
Checks that the export complexity falls within an appropriate range.
CheckGroundPlane | Overloaded.
CheckProjectPhase
Checks that the input element is a project phase.
CheckProjectReportType
Checks that the project report type falls within an appropriate range.
CheckRangeOfMassZoneCoreOffset
Checks that the mass zone core offset is greater than or equal to zero.
CheckRangeOfPercentageGlazing
Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights
Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth
Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight
Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth
Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance
Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType
Checks that the service type falls within an appropriate range.
Dispose
EnableConceptualEnergyAnalyticalModel
Turns on functionality related to conceptual energy analysis.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetBuildingConstructionSetElementId
Id of the building construction set.
GetFromDocument
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDocumentUsingEnergyDataAnalyticalModel
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
SetCreateAnalyticalModel
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingConstructionClass Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckBuildingConstructionClass Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building construction class falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)
Visual Basic (Declaration)
Public Shared Function CheckBuildingConstructionClass ( _
    buildingConstructionClass As HVACLoadConstructionClass _
) As Boolean
Visual C++
public:
static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)

Parameters

buildingConstructionClass
Type: Autodesk.Revit.DB.Analysis..::.HVACLoadConstructionClass
The building construction class to be checked.

Return Value

True if the building construction class falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingHVACSystem Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckBuildingHVACSystem Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building HVAC system falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)
Visual Basic (Declaration)
Public Shared Function CheckBuildingHVACSystem ( _
    buildingHVACSystem As gbXMLBuildingHVACSystem _
) As Boolean
Visual C++
public:
static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)

Parameters

buildingHVACSystem
Type: Autodesk.Revit.DB.Analysis..::.gbXMLBuildingHVACSystem
The building HVAC system to be checked.

Return Value

True if the building HVAC system falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingOperatingSchedule Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckBuildingOperatingSchedule Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building operating schedule falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
Visual Basic (Declaration)
Public Shared Function CheckBuildingOperatingSchedule ( _
    buildingOperatingSchedule As gbXMLBuildingOperatingSchedule _
) As Boolean
Visual C++
public:
static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)

Parameters

buildingOperatingSchedule
Type: Autodesk.Revit.DB.Analysis..::.gbXMLBuildingOperatingSchedule
The building operating schedule to be checked.

Return Value

True if the building operating schedule falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingType Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckBuildingType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)
Visual Basic (Declaration)
Public Shared Function CheckBuildingType ( _
    buildingType As gbXMLBuildingType _
) As Boolean
Visual C++
public:
static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)

Parameters

buildingType
Type: Autodesk.Revit.DB.Analysis..::.gbXMLBuildingType
The building type to be checked.

Return Value

True if the building type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckConstructionSetElement Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckConstructionSetElement Method
EnergyDataSettings Class See Also Send Feedback
Checks that the construction set ElementId is acceptable.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CheckConstructionSetElement(
    ElementId constructionSetElementId
)
Visual Basic (Declaration)
Public Function CheckConstructionSetElement ( _
    constructionSetElementId As ElementId _
) As Boolean
Visual C++
public:
bool CheckConstructionSetElement(
    ElementId^ constructionSetElementId
)

Parameters

constructionSetElementId
Type: Autodesk.Revit.DB..::.ElementId
The construction set ElementId to be checked.

Return Value

True if the construction set ElementId is a valid construction set element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckExportCategory Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckExportCategory Method
EnergyDataSettings Class See Also Send Feedback
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
  3. OST_Massing

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckExportCategory(
    ElementId exportCategoryId
)
Visual Basic (Declaration)
Public Shared Function CheckExportCategory ( _
    exportCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckExportCategory(
    ElementId^ exportCategoryId
)

Parameters

exportCategoryId
Type: Autodesk.Revit.DB..::.ElementId
The export category to be checked.

Return Value

True if the export category falls within the list, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckExportComplexity Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckExportComplexity Method
EnergyDataSettings Class See Also Send Feedback
Checks that the export complexity falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)
Visual Basic (Declaration)
Public Shared Function CheckExportComplexity ( _
    exportComplexity As gbXMLExportComplexity _
) As Boolean
Visual C++
public:
static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)

Parameters

exportComplexity
Type: Autodesk.Revit.DB.Analysis..::.gbXMLExportComplexity
The export complexity to be checked.

Return Value

True if the export complexity falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method

[image] [image]

Revit 2011 API
EnergyDataSettings..::.CheckGroundPlane Method
EnergyDataSettings Class See Also Send Feedback

Overload List

Name | Description
CheckGroundPlane(ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

See Also

EnergyDataSettings Class
EnergyDataSettings Members
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method (ElementId)

[image]

Revit 2011 API
EnergyDataSettings..::.CheckGroundPlane Method (ElementId)
EnergyDataSettings Class See Also Send Feedback
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CheckGroundPlane(
    ElementId groundPlaneId
)
Visual Basic (Declaration)
Public Function CheckGroundPlane ( _
    groundPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool CheckGroundPlane(
    ElementId^ groundPlaneId
)

Parameters

groundPlaneId
Type: Autodesk.Revit.DB..::.ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

True if the input element is a level or invalidElementId, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method (Document, ElementId)

[image]

Revit 2011 API
EnergyDataSettings..::.CheckGroundPlane Method (Document, ElementId)
EnergyDataSettings Class See Also Send Feedback
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckGroundPlane(
    Document ccda,
    ElementId groundPlaneId
)
Visual Basic (Declaration)
Public Shared Function CheckGroundPlane ( _
    ccda As Document, _
    groundPlaneId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckGroundPlane(
    Document^ ccda,
    ElementId^ groundPlaneId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The Document.
groundPlaneId
Type: Autodesk.Revit.DB..::.ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

True if the input element is a level or invalidElementId, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


CheckProjectPhase Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckProjectPhase Method
EnergyDataSettings Class See Also Send Feedback
Checks that the input element is a project phase.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CheckProjectPhase(
    ElementId projectPhaseId
)
Visual Basic (Declaration)
Public Function CheckProjectPhase ( _
    projectPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool CheckProjectPhase(
    ElementId^ projectPhaseId
)

Parameters

projectPhaseId
Type: Autodesk.Revit.DB..::.ElementId
The element to be checked.

Return Value

True if the input element is a project phase, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckProjectReportType Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckProjectReportType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the project report type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)
Visual Basic (Declaration)
Public Shared Function CheckProjectReportType ( _
    projectReportType As HVACLoadLoadsReportType _
) As Boolean
Visual C++
public:
static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)

Parameters

projectReportType
Type: Autodesk.Revit.DB.Analysis..::.HVACLoadLoadsReportType
The project report type to be checked.

Return Value

True if the project report type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfMassZoneCoreOffset Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfMassZoneCoreOffset Method
EnergyDataSettings Class See Also Send Feedback
Checks that the mass zone core offset is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfMassZoneCoreOffset(
    double massZoneCoreOffset
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfMassZoneCoreOffset ( _
    massZoneCoreOffset As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfMassZoneCoreOffset(
    double massZoneCoreOffset
)

Parameters

massZoneCoreOffset
Type: System..::.Double
The mass zone core offset to be checked. Should be greater than or equal to zero.

Return Value

True if the mass zone core offset is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfPercentageGlazing Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfPercentageGlazing Method
EnergyDataSettings Class See Also Send Feedback
Checks that the percentage glazing value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfPercentageGlazing ( _
    percentageGlazing As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)

Parameters

percentageGlazing
Type: System..::.Double
The percentage glazing to be checked.

Return Value

True if the percentage glazing value is between 0.00 and 0.95, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfPercentageSkylights Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfPercentageSkylights Method
EnergyDataSettings Class See Also Send Feedback
Checks that the percentage skylights value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfPercentageSkylights ( _
    percentageSkylights As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)

Parameters

percentageSkylights
Type: System..::.Double
The percentage skylights to be checked.

Return Value

True if the percentage skylights value is between 0.00 and 0.95, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfShadeDepth Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfShadeDepth Method
EnergyDataSettings Class See Also Send Feedback
Checks that the shade depth is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfShadeDepth(
    double shadeDepth
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfShadeDepth ( _
    shadeDepth As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfShadeDepth(
    double shadeDepth
)

Parameters

shadeDepth
Type: System..::.Double
The shade depth to be checked.

Return Value

True if the shade depth is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSillHeight Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfSillHeight Method
EnergyDataSettings Class See Also Send Feedback
Checks that the sill height is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSillHeight(
    double sillHeight
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfSillHeight ( _
    sillHeight As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSillHeight(
    double sillHeight
)

Parameters

sillHeight
Type: System..::.Double
The sill height to be checked.

Return Value

True if the sill height falls is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSkylightWidth Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfSkylightWidth Method
EnergyDataSettings Class See Also Send Feedback
Checks that the skylight width is greater than or equal to eight inches.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfSkylightWidth ( _
    skylightWidth As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)

Parameters

skylightWidth
Type: System..::.Double
The skylight width to be checked. Should be greater than or equal to eight inches.

Return Value

True if the skylight width is greater than or equal to eight inches, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSliverSpaceTolerance Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckRangeOfSliverSpaceTolerance Method
EnergyDataSettings Class See Also Send Feedback
Checks that the sliver space tolerance is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)
Visual Basic (Declaration)
Public Shared Function CheckRangeOfSliverSpaceTolerance ( _
    silverSpaceTolerance As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)

Parameters

silverSpaceTolerance
Type: System..::.Double
The sliver space tolerance to be checked.

Return Value

Returns true if the sliver space tolerance is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckServiceType Method

[image]

Revit 2011 API
EnergyDataSettings..::.CheckServiceType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool CheckServiceType(
    gbXMLServiceType serviceType
)
Visual Basic (Declaration)
Public Shared Function CheckServiceType ( _
    serviceType As gbXMLServiceType _
) As Boolean
Visual C++
public:
static bool CheckServiceType(
    gbXMLServiceType serviceType
)

Parameters

serviceType
Type: Autodesk.Revit.DB.Analysis..::.gbXMLServiceType
The service type to be checked.

Return Value

True if the service type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
EnergyDataSettings..::.Dispose Method
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnableConceptualEnergyAnalyticalModel Method

[image]

Revit 2011 API
EnergyDataSettings..::.EnableConceptualEnergyAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
Turns on functionality related to conceptual energy analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool EnableConceptualEnergyAnalyticalModel()
Visual Basic (Declaration)
Public Shared Function EnableConceptualEnergyAnalyticalModel As Boolean
Visual C++
public:
static bool EnableConceptualEnergyAnalyticalModel()

Return Value

Returns true if the Conceptual Energy Analytical model is turned on, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetBuildingConstructionSetElementId Method

[image]

Revit 2011 API
EnergyDataSettings..::.GetBuildingConstructionSetElementId Method
EnergyDataSettings Class See Also Send Feedback
Id of the building construction set.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetBuildingConstructionSetElementId(
    Document ccda
)
Visual Basic (Declaration)
Public Shared Function GetBuildingConstructionSetElementId ( _
    ccda As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetBuildingConstructionSetElementId(
    Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document

Return Value

Returns the id of the building construction set.

Remarks

The building construction set is the default project construction set used when spaces are not assigned a construction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetFromDocument Method

[image]

Revit 2011 API
EnergyDataSettings..::.GetFromDocument Method
EnergyDataSettings Class See Also Send Feedback
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static EnergyDataSettings GetFromDocument(
    Document cda
)
Visual Basic (Declaration)
Public Shared Function GetFromDocument ( _
    cda As Document _
) As EnergyDataSettings
Visual C++
public:
static EnergyDataSettings^ GetFromDocument(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

Returns the EnergyDataSettings element or NULL.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsDocumentUsingEnergyDataAnalyticalModel Method

[image]

Revit 2011 API
EnergyDataSettings..::.IsDocumentUsingEnergyDataAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document ccda
)
Visual Basic (Declaration)
Public Shared Function IsDocumentUsingEnergyDataAnalyticalModel ( _
    ccda As Document _
) As Boolean
Visual C++
public:
static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

Returns true if the Conceptual Energy Analytical Model is enabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetCreateAnalyticalModel Method

[image]

Revit 2011 API
EnergyDataSettings..::.SetCreateAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)
Visual Basic (Declaration)
Public Sub SetCreateAnalyticalModel ( _
    createAnalyticalModel As Boolean _
)
Visual C++
public:
void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)

Parameters

createAnalyticalModel
Type: System..::.Boolean
True to enable the Energy Analytical Model otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Properties

[image] [image]

Revit 2011 API
EnergyDataSettings Properties
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Properties

Name | Description
BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
BuildingType | The type of building.
CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
GroundPlane | Id of level which represents ground level.
IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
OutsideAirChangesRatePerHour |
OutsideAirPerArea |
OutsideAirPerPerson |
PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the the building exterior wall surfaces which are covered by windows or other glazing.
PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
ProjectPhase | The project phase of the EnergyData information.
ProjectReportType | Report type: None, simple, standard, detailed
ServiceType | The type of heating or cooling system.
ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingConstructionClass Property

[image]

Revit 2011 API
EnergyDataSettings..::.BuildingConstructionClass Property
EnergyDataSettings Class See Also Send Feedback
Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Visual Basic (Declaration)
Public Property BuildingConstructionClass As HVACLoadConstructionClass
Visual C++
public:
property HVACLoadConstructionClass BuildingConstructionClass {
    HVACLoadConstructionClass get ();
    void set (HVACLoadConstructionClass value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingHVACSystem Property

[image]

Revit 2011 API
EnergyDataSettings..::.BuildingHVACSystem Property
EnergyDataSettings Class See Also Send Feedback
The type of HVAC system used by the building for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingHVACSystem BuildingHVACSystem { get; set; }
Visual Basic (Declaration)
Public Property BuildingHVACSystem As gbXMLBuildingHVACSystem
Visual C++
public:
property gbXMLBuildingHVACSystem BuildingHVACSystem {
    gbXMLBuildingHVACSystem get ();
    void set (gbXMLBuildingHVACSystem value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingSchedule Property

[image]

Revit 2011 API
EnergyDataSettings..::.BuildingOperatingSchedule Property
EnergyDataSettings Class See Also Send Feedback
The operating schedule of the building used for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; }
Visual Basic (Declaration)
Public Property BuildingOperatingSchedule As gbXMLBuildingOperatingSchedule
Visual C++
public:
property gbXMLBuildingOperatingSchedule BuildingOperatingSchedule {
    gbXMLBuildingOperatingSchedule get ();
    void set (gbXMLBuildingOperatingSchedule value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingType Property

[image]

Revit 2011 API
EnergyDataSettings..::.BuildingType Property
EnergyDataSettings Class See Also Send Feedback
The type of building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingType BuildingType { get; set; }
Visual Basic (Declaration)
Public Property BuildingType As gbXMLBuildingType
Visual C++
public:
property gbXMLBuildingType BuildingType {
    gbXMLBuildingType get ();
    void set (gbXMLBuildingType value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CreateAnalyticalModel Property

[image]

Revit 2011 API
EnergyDataSettings..::.CreateAnalyticalModel Property
EnergyDataSettings Class See Also Send Feedback
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CreateAnalyticalModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreateAnalyticalModel As Boolean
Visual C++
public:
property bool CreateAnalyticalModel {
    bool get ();
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportCategory Property

[image]

Revit 2011 API
EnergyDataSettings..::.ExportCategory Property
EnergyDataSettings Class See Also Send Feedback
Value is a category indicating which discipline model will be used for GreenBuildingXML export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ExportCategory { get; set; }
Visual Basic (Declaration)
Public Property ExportCategory As ElementId
Visual C++
public:
property ElementId^ ExportCategory {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

OST_Rooms will use the architectural 3d rooms for export. OST_MEPSpaces will user the MEP 3d Spaces for export. OST_Massing will use the massing model geometries for export. invalidElementId if nothing has been set by the user.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportComplexity Property

[image]

Revit 2011 API
EnergyDataSettings..::.ExportComplexity Property
EnergyDataSettings Class See Also Send Feedback
Value determines Export Complexity for GreenBuildingXML detailed model export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public gbXMLExportComplexity ExportComplexity { get; set; }
Visual Basic (Declaration)
Public Property ExportComplexity As gbXMLExportComplexity
Visual C++
public:
property gbXMLExportComplexity ExportComplexity {
    gbXMLExportComplexity get ();
    void set (gbXMLExportComplexity value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportDefaults Property

[image]

Revit 2011 API
EnergyDataSettings..::.ExportDefaults Property
EnergyDataSettings Class See Also Send Feedback
Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ExportDefaults { get; set; }
Visual Basic (Declaration)
Public Property ExportDefaults As Boolean
Visual C++
public:
property bool ExportDefaults {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GroundPlane Property

[image]

Revit 2011 API
EnergyDataSettings..::.GroundPlane Property
EnergyDataSettings Class See Also Send Feedback
Id of level which represents ground level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GroundPlane { get; set; }
Visual Basic (Declaration)
Public Property GroundPlane As ElementId
Visual C++
public:
property ElementId^ GroundPlane {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The ground plane defines what is above and below ground for Conceptual Energy Analysis. The ground plane can optionally used for the rendering cast shadows.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportMullionsEnabled Property

[image]

Revit 2011 API
EnergyDataSettings..::.IsExportMullionsEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if mullions are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsExportMullionsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExportMullionsEnabled As Boolean
Visual C++
public:
property bool IsExportMullionsEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness, and offset.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportShadingSurfacesEnabled Property

[image]

Revit 2011 API
EnergyDataSettings..::.IsExportShadingSurfacesEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsExportShadingSurfacesEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean
Visual C++
public:
property bool IsExportShadingSurfacesEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. The method described by gbs/gbxml.org to calculate the shading surfaces is to take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements, and then the remaining surfaces are considered to be the shading surfaces.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportSimplifiedCurtainSystemsEnabled Property

[image]

Revit 2011 API
EnergyDataSettings..::.IsExportSimplifiedCurtainSystemsEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsExportSimplifiedCurtainSystemsEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExportSimplifiedCurtainSystemsEnabled As Boolean
Visual C++
public:
property bool IsExportSimplifiedCurtainSystemsEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. Curtain Walls and Curtain Systems are normally exported as multiple openings, panel by panel, while for energy analysis this can be more simply represented as a single glass surface as large as the entire curtain wall/system. Normally, a curtain wall with 50 panels would be exported as 50 openings. Often, exporting a single opening with the total curtain system area is more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsGlazingShaded Property

[image]

Revit 2011 API
EnergyDataSettings..::.IsGlazingShaded Property
EnergyDataSettings Class See Also Send Feedback
If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsGlazingShaded { get; set; }
Visual Basic (Declaration)
Public Property IsGlazingShaded As Boolean
Visual C++
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneCoreOffset Property

[image]

Revit 2011 API
EnergyDataSettings..::.MassZoneCoreOffset Property
EnergyDataSettings Class See Also Send Feedback
It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic (Declaration)
Public Property MassZoneCoreOffset As Double
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneDividePerimeter Property

[image]

Revit 2011 API
EnergyDataSettings..::.MassZoneDividePerimeter Property
EnergyDataSettings Class See Also Send Feedback
If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool MassZoneDividePerimeter { get; set; }
Visual Basic (Declaration)
Public Property MassZoneDividePerimeter As Boolean
Visual C++
public:
property bool MassZoneDividePerimeter {
    bool get ();
    void set (bool value);
}

Remarks

The quadrants will be True N, S, E, and W. The division of the quadrants will be along the axis of True NW to SE and True SW to NE. The intersection of the quadrants will be placed at the centroid of the zone. The purpose of the these divisions is to ensure that auto-generated zoning is appropriate for thermal loads generated by the relative position of the building to the sun path.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirChangesRatePerHour Property

[image]

Revit 2011 API
EnergyDataSettings..::.OutsideAirChangesRatePerHour Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirChangesRatePerHour { get; set; }
Visual Basic (Declaration)
Public Property OutsideAirChangesRatePerHour As Double
Visual C++
public:
property double OutsideAirChangesRatePerHour {
    double get ();
    void set (double value);
}

Remarks

Air Changes per hour is "unitless". It is a number. It is the number of times the air (the volume) interchanges in the room in one hour. This number is a format for expressing the requirement for airflow. The "flow" requirement for a room might be expressed, e.g., one room of 100 CF, and 3 Air Changes per Hour (ACH), would compute to 100 CF x 3 ACH / 60 min = 5 CFM.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirPerArea Property

[image]

Revit 2011 API
EnergyDataSettings..::.OutsideAirPerArea Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirPerArea { get; set; }
Visual Basic (Declaration)
Public Property OutsideAirPerArea As Double
Visual C++
public:
property double OutsideAirPerArea {
    double get ();
    void set (double value);
}

Remarks

Stored in cubic feet per hour per square foot.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirPerPerson Property

[image]

Revit 2011 API
EnergyDataSettings..::.OutsideAirPerPerson Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirPerPerson { get; set; }
Visual Basic (Declaration)
Public Property OutsideAirPerPerson As Double
Visual C++
public:
property double OutsideAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

Stored in cubic feet per hour.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


PercentageGlazing Property

[image]

Revit 2011 API
EnergyDataSettings..::.PercentageGlazing Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate percentage of the the building exterior wall surfaces which are covered by windows or other glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double PercentageGlazing { get; set; }
Visual Basic (Declaration)
Public Property PercentageGlazing As Double
Visual C++
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}

Remarks

This value is used to automatically model these glazed openings in massing instances for the Conceptual Energy Analytical Model.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


PercentageSkylights Property

[image]

Revit 2011 API
EnergyDataSettings..::.PercentageSkylights Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate percentage of the the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic (Declaration)
Public Property PercentageSkylights As Double
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

This value is used to automatically model the skylights in massing instances when the Energy Analytical model is being created.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ProjectPhase Property

[image]

Revit 2011 API
EnergyDataSettings..::.ProjectPhase Property
EnergyDataSettings Class See Also Send Feedback
The project phase of the EnergyData information.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ProjectPhase { get; set; }
Visual Basic (Declaration)
Public Property ProjectPhase As ElementId
Visual C++
public:
property ElementId^ ProjectPhase {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ProjectReportType Property

[image]

Revit 2011 API
EnergyDataSettings..::.ProjectReportType Property
EnergyDataSettings Class See Also Send Feedback
Report type: None, simple, standard, detailed

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public HVACLoadLoadsReportType ProjectReportType { get; set; }
Visual Basic (Declaration)
Public Property ProjectReportType As HVACLoadLoadsReportType
Visual C++
public:
property HVACLoadLoadsReportType ProjectReportType {
    HVACLoadLoadsReportType get ();
    void set (HVACLoadLoadsReportType value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ServiceType Property

[image]

Revit 2011 API
EnergyDataSettings..::.ServiceType Property
EnergyDataSettings Class See Also Send Feedback
The type of heating or cooling system.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public gbXMLServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As gbXMLServiceType
Visual C++
public:
property gbXMLServiceType ServiceType {
    gbXMLServiceType get ();
    void set (gbXMLServiceType value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShadeDepth Property

[image]

Revit 2011 API
EnergyDataSettings..::.ShadeDepth Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic (Declaration)
Public Property ShadeDepth As Double
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SillHeight Property

[image]

Revit 2011 API
EnergyDataSettings..::.SillHeight Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SillHeight { get; set; }
Visual Basic (Declaration)
Public Property SillHeight As Double
Visual C++
public:
property double SillHeight {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SkylightWidth Property

[image]

Revit 2011 API
EnergyDataSettings..::.SkylightWidth Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SkylightWidth { get; set; }
Visual Basic (Declaration)
Public Property SkylightWidth As Double
Visual C++
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SliverSpaceTolerance Property

[image]

Revit 2011 API
EnergyDataSettings..::.SliverSpaceTolerance Property
EnergyDataSettings Class See Also Send Feedback
Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SliverSpaceTolerance { get; set; }
Visual Basic (Declaration)
Public Property SliverSpaceTolerance As Double
Visual C++
public:
property double SliverSpaceTolerance {
    double get ();
    void set (double value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseAirChangesPerHour Property

[image]

Revit 2011 API
EnergyDataSettings..::.UseAirChangesPerHour Property
EnergyDataSettings Class See Also Send Feedback
True if user is specifying air changes per hour, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UseAirChangesPerHour { get; set; }
Visual Basic (Declaration)
Public Property UseAirChangesPerHour As Boolean
Visual C++
public:
property bool UseAirChangesPerHour {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseHeatingCredits Property

[image]

Revit 2011 API
EnergyDataSettings..::.UseHeatingCredits Property
EnergyDataSettings Class See Also Send Feedback
If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UseHeatingCredits { get; set; }
Visual Basic (Declaration)
Public Property UseHeatingCredits As Boolean
Visual C++
public:
property bool UseHeatingCredits {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseOutsideAirPerArea Property

[image]

Revit 2011 API
EnergyDataSettings..::.UseOutsideAirPerArea Property
EnergyDataSettings Class See Also Send Feedback
True is user is specifying outside air per area, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UseOutsideAirPerArea { get; set; }
Visual Basic (Declaration)
Public Property UseOutsideAirPerArea As Boolean
Visual C++
public:
property bool UseOutsideAirPerArea {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseOutsideAirPerPerson Property

[image]

Revit 2011 API
EnergyDataSettings..::.UseOutsideAirPerPerson Property
EnergyDataSettings Class See Also Send Feedback
True if user is specifying outside air per person, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UseOutsideAirPerPerson { get; set; }
Visual Basic (Declaration)
Public Property UseOutsideAirPerPerson As Boolean
Visual C++
public:
property bool UseOutsideAirPerPerson {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Class

[image]

Revit 2011 API
FieldDomainPoints Class
Members See Also Send Feedback
Abstract base class for various classes of field domain points

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPoints : IDisposable
Visual Basic (Declaration)
Public Class FieldDomainPoints _
    Implements IDisposable
Visual C++
public ref class FieldDomainPoints : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByParameter
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByUV
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByXYZ

See Also

FieldDomainPoints Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Members

[image] [image]

Revit 2011 API
FieldDomainPoints Members
FieldDomainPoints Class Methods See Also Send Feedback

The FieldDomainPoints type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Methods

[image] [image]

Revit 2011 API
FieldDomainPoints Methods
FieldDomainPoints Class See Also Send Feedback

The FieldDomainPoints type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
FieldDomainPoints..::.Dispose Method
FieldDomainPoints Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Class

[image]

Revit 2011 API
FieldDomainPointsByParameter Class
Members Example See Also Send Feedback
Represents a set of one-dimensional point coordinates (defined usually on curve)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByParameter : FieldDomainPoints
Visual Basic (Declaration)
Public Class FieldDomainPointsByParameter _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByParameter : public FieldDomainPoints

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (sfm == null)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}

ReferenceArray ra = new ReferenceArray();
Reference curveRef = uiDoc.Selection.PickObject(ObjectType.Element, "Select a curve");
ra.Append(curveRef);

foreach (Reference reference in ra)
{
    ModelCurve modelCurve = reference.Element as ModelCurve;
    Curve curve = modelCurve.GeometryCurve;
    if (curve == null)
    {
        TaskDialog.Show("Error", "Must select a curve");
        return Result.Cancelled;
    }
    else
    {
        int idx = sfm.AddSpatialFieldPrimitive(curve.Reference);

        IList<double> pts = new List<double>();

        double range = curve.get_EndParameter(1) - curve.get_EndParameter(0);
        double u = curve.get_EndParameter(0);
        for (int ii = 0; ii < 10; ii++)
        {
            pts.Add(u);
            u = u + range / 10;
        }

        FieldDomainPointsByParameter pnts = new FieldDomainPointsByParameter(pts);

        List<double> doubleList = new List<double>();
        IList<ValueAtPoint> valList = new List<ValueAtPoint>();
        double x = 0;
        while (valList.Count < pts.Count)
        //for (double x = 0; x < 1; x = x + 0.1)
        {
            doubleList.Clear();
            doubleList.Add(x * 10);
            valList.Add(new ValueAtPoint(doubleList));
            x = x + 0.1;
        }
        FieldValues vals = new FieldValues(valList);

        sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals);
    }
}
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As Autodesk.Revit.DB.Analysis.SpatialFieldManager = Autodesk.Revit.DB.Analysis.SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
    sfm = Autodesk.Revit.DB.Analysis.SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If

Dim ra As New ReferenceArray()
Dim curveRef As Reference = uiDoc.Selection.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Element, "Select a curve")
ra.Append(curveRef)

For Each reference As Reference In ra
    Dim modelCurve As ModelCurve = TryCast(reference.Element, ModelCurve)
    Dim curve As Curve = modelCurve.GeometryCurve
    If curve Is Nothing Then
        TaskDialog.Show("Error", "Must select a curve")
        Return Result.Cancelled
    Else
        Dim idx As Integer = sfm.AddSpatialFieldPrimitive(curve.Reference)

        Dim pts As IList(Of Double) = New List(Of Double)()

        Dim range As Double = curve.EndParameter(1) - curve.EndParameter(0)
        Dim u As Double = curve.EndParameter(0)
        Dim ii As Integer = 0
        While ii < 10
            pts.Add(u)
            u = u + range / 10
            System.Math.Max(System.Threading.Interlocked.Increment(ii), ii - 1)
        End While

        Dim pnts As New Autodesk.Revit.DB.Analysis.FieldDomainPointsByParameter(pts)

        Dim doubleList As New List(Of Double)()
        Dim valList As IList(Of Autodesk.Revit.DB.Analysis.ValueAtPoint) = New List(Of Autodesk.Revit.DB.Analysis.ValueAtPoint)()
        Dim x As Double = 0
        While valList.Count < pts.Count
            'for (double x = 0; x < 1; x = x + 0.1)
            doubleList.Clear()
            doubleList.Add(x * 10)
            valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))
            x = x + 0.1
        End While
        Dim vals As New Autodesk.Revit.DB.Analysis.FieldValues(valList)

        sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals)
    End If
Next

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByParameter

See Also

FieldDomainPointsByParameter Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Members

[image] [image]

Revit 2011 API
FieldDomainPointsByParameter Members
FieldDomainPointsByParameter Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByParameter type exposes the following members.

Constructors

Name | Description
FieldDomainPointsByParameter | Creates object from an array of one-dimensional point coordinates

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Constructor

[image]

Revit 2011 API
FieldDomainPointsByParameter Constructor
FieldDomainPointsByParameter Class See Also Send Feedback
Creates object from an array of one-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByParameter(
    IList<double> points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of Double) _
)
Visual C++
public:
FieldDomainPointsByParameter(
    IList<double>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( Double >)>)
Array of one-dimensional point coordinates representing domain points (using raw parameters when on a curve)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Methods

[image] [image]

Revit 2011 API
FieldDomainPointsByParameter Methods
FieldDomainPointsByParameter Class See Also Send Feedback

The FieldDomainPointsByParameter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Class

[image]

Revit 2011 API
FieldDomainPointsByUV Class
Members See Also Send Feedback
Represents a set of two-dimensional point coordinates (defined usually on surface)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByUV : FieldDomainPoints
Visual Basic (Declaration)
Public Class FieldDomainPointsByUV _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByUV : public FieldDomainPoints

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByUV

See Also

FieldDomainPointsByUV Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Members

[image] [image]

Revit 2011 API
FieldDomainPointsByUV Members
FieldDomainPointsByUV Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByUV type exposes the following members.

Constructors

Name | Description
FieldDomainPointsByUV | Overloaded.

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor

[image] [image]

Revit 2011 API
FieldDomainPointsByUV Constructor
FieldDomainPointsByUV Class See Also Send Feedback

Overload List

Name | Description
FieldDomainPointsByUV(IList<(Of <(UV>)>)) | Creates object from an array of two-dimensional point coordinates
FieldDomainPointsByUV(IList<(Of <(UV>)>), ICollection<(Of <(Double>)>), ICollection<(Of <(Double>)>)) | Creates object from an array of two-dimensional point coordinates

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor (IList(UV))

[image]

Revit 2011 API
FieldDomainPointsByUV Constructor (IList<(Of <(UV>)>))
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of UV) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( UV >)>)
Array of two-dimensional point coordinates representing domain points (usually on surface)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor (IList(UV), ICollection(Double), ICollection(Double))

[image]

Revit 2011 API
FieldDomainPointsByUV Constructor (IList<(Of <(UV>)>), ICollection<(Of <(Double>)>), ICollection<(Of <(Double>)>))
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points,
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of UV), _
    uCoordinates As ICollection(Of Double), _
    vCoordinates As ICollection(Of Double) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points,
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( UV >)>)
Array of two-dimensional point coordinates representing domain points (usually on surface)
uCoordinates
Type: System.Collections.Generic..::.ICollection <(Of <( Double >)>)
Set of u coordinates at which to draw grid lines on the surface
vCoordinates
Type: System.Collections.Generic..::.ICollection <(Of <( Double >)>)
Set of v coordinates at which to draw grid lines on the surface

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Methods

[image] [image]

Revit 2011 API
FieldDomainPointsByUV Methods
FieldDomainPointsByUV Class See Also Send Feedback

The FieldDomainPointsByUV type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


SetGridCoordinates Method

[image]

Revit 2011 API
FieldDomainPointsByUV..::.SetGridCoordinates Method
FieldDomainPointsByUV Class See Also Send Feedback
Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetGridCoordinates(
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Visual Basic (Declaration)
Public Sub SetGridCoordinates ( _
    uCoordinates As ICollection(Of Double), _
    vCoordinates As ICollection(Of Double) _
)
Visual C++
public:
void SetGridCoordinates(
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)

Parameters

uCoordinates
Type: System.Collections.Generic..::.ICollection <(Of <( Double >)>)
Set of u coordinates at which to draw grid lines
vCoordinates
Type: System.Collections.Generic..::.ICollection <(Of <( Double >)>)
Set of v coordinates at which to draw grid lines

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Class

[image]

Revit 2011 API
FieldDomainPointsByXYZ Class
Members See Also Send Feedback
Represents a set of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByXYZ : FieldDomainPoints
Visual Basic (Declaration)
Public Class FieldDomainPointsByXYZ _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByXYZ : public FieldDomainPoints

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Autodesk.Revit.DB.Analysis..::.FieldDomainPointsByXYZ

See Also

FieldDomainPointsByXYZ Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Members

[image] [image]

Revit 2011 API
FieldDomainPointsByXYZ Members
FieldDomainPointsByXYZ Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByXYZ type exposes the following members.

Constructors

Name | Description
FieldDomainPointsByXYZ | Creates object from an array of three-dimensional point coordinates

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Constructor

[image]

Revit 2011 API
FieldDomainPointsByXYZ Constructor
FieldDomainPointsByXYZ Class See Also Send Feedback
Creates object from an array of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByXYZ(
    IList<XYZ> points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
FieldDomainPointsByXYZ(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::.IList <(Of <( XYZ >)>)
Array of three-dimensional point coordinates representing domain points

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Methods

[image] [image]

Revit 2011 API
FieldDomainPointsByXYZ Methods
FieldDomainPointsByXYZ Class See Also Send Feedback

The FieldDomainPointsByXYZ type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from FieldDomainPoints.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Class

[image]

Revit 2011 API
FieldValues Class
Members See Also Send Feedback
Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FieldValues : IDisposable
Visual Basic (Declaration)
Public Class FieldValues _
    Implements IDisposable
Visual C++
public ref class FieldValues : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.FieldValues

See Also

FieldValues Members
Autodesk.Revit.DB.Analysis Namespace


FieldValues Members

[image] [image]

Revit 2011 API
FieldValues Members
FieldValues Class Constructors Methods See Also Send Feedback

The FieldValues type exposes the following members.

Constructors

Name | Description
FieldValues | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor

[image] [image]

Revit 2011 API
FieldValues Constructor
FieldValues Class See Also Send Feedback

Overload List

Name | Description
FieldValues(FieldValues) | Initializes a new instance of the FieldValues class
FieldValues(IList<(Of <(ValueAtPoint>)>)) | Creates object from an array of values for domain points

See Also

FieldValues Class
FieldValues Members
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (FieldValues)

[image]

Revit 2011 API
FieldValues Constructor (FieldValues)
FieldValues Class See Also Send Feedback
Initializes a new instance of the FieldValues class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldValues(
    FieldValues otherObject
)
Visual Basic (Declaration)
Public Sub New ( _
    otherObject As FieldValues _
)
Visual C++
public:
FieldValues(
    FieldValues^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::.FieldValues

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (IList(ValueAtPoint))

[image]

Revit 2011 API
FieldValues Constructor (IList<(Of <(ValueAtPoint>)>))
FieldValues Class See Also Send Feedback
Creates object from an array of values for domain points

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FieldValues(
    IList<ValueAtPoint> valueAtPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    valueAtPoint As IList(Of ValueAtPoint) _
)
Visual C++
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint
)

Parameters

valueAtPoint
Type: System.Collections.Generic..::.IList <(Of <( ValueAtPoint >)>)
Array of values, each corresponding to a domain point

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | valueAtPoint array contains members with different numbers of measurements
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Methods

[image] [image]

Revit 2011 API
FieldValues Methods
FieldValues Class See Also Send Feedback

The FieldValues type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
FieldValues..::.Dispose Method
FieldValues Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingHVACSystem Enumeration

[image]

Revit 2011 API
gbXMLBuildingHVACSystem Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum gbXMLBuildingHVACSystem
Visual Basic (Declaration)
Public Enumeration gbXMLBuildingHVACSystem
Visual C++
public enum class gbXMLBuildingHVACSystem

Members

Member name | Description
TwelveSEERSPointNineAFUESplitPackagedGasFiveToElevenTon |
ElevenPointThreeEERPackagedVAVEightyFourPointFourPercentBoilerHeating |
CentralVAVHWHeatChillerFivePointNinetySixCOPBoilersEightyFourPoint5Eff |
FourPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightFourPointFiveEff |
CentralVAVElectricResistanceHeatChillerFivePointNinetySixCOP |
TwelveSEERSevenPointSevenHSPFSplitPackagedHeatPump |
TwoPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightyFourPointFiveEff |
TwelveSEEREightPointThreeHSPFPackagedTerminalHeatPumpPTAC |
ResidentialSeventeenSEERNinePointSixHSPFSplitHPLessThanFivePointFiveTon |
UnderfloorAirDistribution |
ResidentialFourteenSEERPointNineAFUESplitPackagedGasLessThanFivePointFiveTon |
ResidentialFourteenSEEREightPointThreeHSPFSplitPackagedHeatPump |
NoOfHVACSystemEnums |

Remarks

This enumeration corresponds to the HVAC System attribute in gbXML and is used to specify the Building HVAC System.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingOperatingSchedule Enumeration

[image]

Revit 2011 API
gbXMLBuildingOperatingSchedule Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum gbXMLBuildingOperatingSchedule
Visual Basic (Declaration)
Public Enumeration gbXMLBuildingOperatingSchedule
Visual C++
public enum class gbXMLBuildingOperatingSchedule

Members

Member name | Description
DefaultOperatingSchedule |
TwentyFourHourSevenDayFacility |
TwentyFourHourHourSixDayFacility |
TwentyFourHourHourFiveDayFacility |
TwelveHourSevenDayFacility |
TwelveHourSixDayFacility |
TwelveHourFiveDayFacility |
KindergartenThruTwelveGradeSchool |
YearRoundSchool |
TheaterPerformingArts |
Worship |
NoOfOperatingScheduleEnums |

Remarks

This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the building operating schedule.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingType Enumeration

[image]

Revit 2011 API
gbXMLBuildingType Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the most predominant building use type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLBuildingType
Visual Basic (Declaration)
Public Enumeration gbXMLBuildingType
Visual C++
public enum class gbXMLBuildingType

Members

Member name | Description
NoBuildingType |
AutomotiveFacility |
ConventionCenter |
Courthouse |
DiningBarLoungeOrLeisure |
DiningCafeteriaFastFood |
DiningFamily |
Dormitory |
ExerciseCenter |
FireStation |
Gymnasium |
HospitalOrHealthcare |
Hotel |
Library |
Manufacturing |
Motel |
MotionPictureTheatre |
MultiFamily |
Museum |
Office |
ParkingGarage |
Penitentiary |
PerformingArtsTheater |
PoliceStation |
PostOffice |
ReligiousBuilding |
Retail |
SchoolOrUniversity |
SingleFamily |
SportsArena |
TownHall |
Transportation |
Warehouse |
Workshop |
NoOfBuildingTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLConditionType Enumeration

[image]

Revit 2011 API
gbXMLConditionType Enumeration
See Also Send Feedback
This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLConditionType
Visual Basic (Declaration)
Public Enumeration gbXMLConditionType
Visual C++
public enum class gbXMLConditionType

Members

Member name | Description
NoConditionType |
Heated |
Cooled |
HeatedAndCooled |
Unconditioned |
Vented |
NaturallyVentedOnly |
NoOfConditionTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLExportComplexity Enumeration

[image]

Revit 2011 API
gbXMLExportComplexity Enumeration
See Also Send Feedback
This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one “huge” opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLExportComplexity
Visual Basic (Declaration)
Public Enumeration gbXMLExportComplexity
Visual C++
public enum class gbXMLExportComplexity

Members

Member name | Description
Simple | Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. Using this enumeration, one "large" window/opening will be exported for a curtain wall/system
SimpleWithShadingSurfaces | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces
Complex | Using this enumeration, Curtain Walls and Curtain Systems will exported as several openings, panel by panel.
ComplexWithShadingSurfaces | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces.
ComplexWithMullionsAndShadingSurfaces | Using this enumeration, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on it's centerline, thickness and offset.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLServiceType Enumeration

[image]

Revit 2011 API
gbXMLServiceType Enumeration
See Also Send Feedback
This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLServiceType
Visual Basic (Declaration)
Public Enumeration gbXMLServiceType
Visual C++
public enum class gbXMLServiceType

Members

Member name | Description
NoServiceType |
CentralHeatingRadiators |
CentralHeatingConvectors |
CentralHeatingRadiantFloor |
CentralHeatingHotAir |
OtherRoomHeater |
RadiantHeaterFlue |
RadiantHeaterNoFlue |
RadiantHeaterMultiburner |
ForcedConvectionHeaterFlue |
ForcedConvectionHeaterNoFlue |
VAVSingleDuct |
VAVDualDuct |
VAVIndoorPackagedCabinet |
VAVTerminalReheat |
FanCoilSystem |
InductionSystem |
ConstantVolumeFixedOA |
ConstantVolumeVariableOA |
ConstantVolumeTerminalReheat |
MultizoneHotDeckColdDeck |
ConstantVolumeDualDuct |
RadiantCooledCeilings |
ActiveChilledBeams |
WaterLoopHeatPump |
VariableRefrigerantFlow |
SplitSystemsWithNaturalVentilation |
SplitSystemsWithMechanicalVentilation |
SplitSystemsWithMechanicalVentilationWithCooling |
NoOfServiceTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLSpaceType Enumeration

[image]

Revit 2011 API
gbXMLSpaceType Enumeration
See Also Send Feedback
This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLSpaceType
Visual Basic (Declaration)
Public Enumeration gbXMLSpaceType
Visual C++
public enum class gbXMLSpaceType

Members

Member name | Description
NoSpaceType |
ActiveStorage |
ActiveStorageHospitalOrHealthcare |
AirOrTrainOrBusBaggageArea |
AirportConcourse |
AtriumEachAdditionalFloor |
AtriumFirstThreeFloors |
AudienceOrSeatingAreaPenitentiary |
AudienceOrSeatingAreaExerciseCenter |
AudienceOrSeatingAreaGymnasium |
AudienceOrSeatingAreaSportsArena |
AudienceOrSeatingAreaConventionCenter |
AudienceOrSeatingAreaMotionPictureTheatre |
AudienceOrSeatingAreaPerformingArtsTheatre |
AudienceOrSeatingAreaReligious |
AudienceOrSeatingAreaPoliceOrFireStations |
AudienceOrSeatingAreaCourtHouse |
AudienceOrSeatingAreaAuditorium |
BankCustomerArea |
BankingActivityAreaOffice |
BarberAndBeautyParlor |
CardFileAndCataloguingLibrary |
ClassroomOrLectureOrTrainingPenitentiary |
ClassroomOrLectureOrTraining |
ComfinementCellsPenitentiary |
ComfinementCellsCourtHouse |
ConferenceMeetingOrMultipurpose |
CorridorOrTransition |
CorridorOrTransitionManufacturingFacility |
CorridorsWithPatientWaitingExamHospitalOrHealthcare |
CourtSportsAreaSportsArena |
CourtroomCourtHouse |
DepartmentStoreSalesAreaRetail |
DetailedManufacturingFacility |
DiningArea |
DiningAreaHotel |
DiningAreaFamilyDining |
DiningAreaLoungeOrLeisureDining |
DiningAreaMotel |
DiningAreaTransportation |
DiningAreaPenitentiary |
DiningAreaCivilServices |
DormitoryBedroom |
DormitoryStudyHall |
DressingOrLockerOrFittingRoomGymnasium |
DressingOrLockerOrFittingRoomCourtHouse |
DressingOrLockerOrFittingRoomPerformingArtsTheatre |
DressingOrLockerOrFittingRoomAuditorium |
DressingOrLockerOrFittingRoomExerciseCenter |
ElectricalOrMechanical |
ElevatorLobbies |
EmergencyHospitalOrHealthcare |
EquipmentRoomManufacturingFacility |
ExamOrTreatmentHospitalOrHealthcare |
ExerciseAreaExerciseCenter |
ExerciseAreaGymnasium |
ExhibitSpaceConventionCenter |
FellowshipHallReligiousBuildings |
FineMaterialWarehouse |
FineMerchandiseSalesAreaRetail |
FireStationEngineRoomPoliceOrFireStation |
FoodPreparation |
GarageServiceOrRepairAutomotiveFacility |
GeneralHighBayManufacturingFacility |
GeneralLowBayManufacturingFacility |
GeneralExhibitionMuseum |
HospitalNurseryHospitalOrHealthcare |
HospitalOrMedicalSuppliesHospitalOrHealthcare |
HospitalOrRadiologyHospitalOrHealthcare |
HotelOrConferenceCenterConferenceOrMeeting |
InactiveStorage |
JudgesChambersCourtHouse |
LaboratoryOffice |
LaundryIroningAndSorting |
LaundryWashingHospitalOrHealthcare |
LibraryAudioVisualLibraryAudioVisual |
LivingQuartersDormitory |
LivingQuartersMotel |
LivingQuartersHotel |
Lobby |
LobbyReligiousBuildings |
LobbyMotionPictureTheatre |
LobbyAuditorium |
LobbyPerformingArtsTheatre |
LobbyPostOffice |
LobbyHotel |
LoungeOrRecreation |
MallConcourseSalesAreaRetail |
MassMerchandisingSalesAreaRetail |
MediumOrBulkyMaterialWarehouse |
MerchandisingSalesAreaRetail |
MuseumAndGalleryStorage |
NurseStationHospitalOrHealthcare |
OfficeEnclosed |
OfficeOpenPlan |
OfficeCommonActivityAreasInactiveStorage |
OperatingRoomHospitalOrHealthcare |
OtherTelevisedPlayingAreaSportsArena |
ParkingAreaAttendantOnlyParkingGarage |
ParkingAreaPedestrianParkingGarage |
PatientRoomHospitalOrHealthcare |
PersonalServicesSalesAreaRetail |
PharmacyHospitalOrHealthcare |
PhysicalTherapyHospitalOrHealthcare |
PlayingAreaGymnasium |
Plenum |
PoliceStationLaboratoryPoliceOrFireStations |
PublicAndStaffLoungeHospitalOrHealthcare |
ReadingAreaLibrary |
ReceptionOrWaitingTransportation |
ReceptionOrWaitingMotel |
ReceptionOrWaitingHotel |
RecoveryHospitalOrHealthcare |
RestorationMuseum |
Restrooms |
RingSportsAreaSportsArena |
SleepingQuartersPoliceOrFireStation |
SortingAreaPostOffice |
SpecialtyStoreSalesAreaRetail |
StacksLibrary |
StairsInactive |
Stairway |
SupermarketSalesAreaRetail |
TerminalTicketCounterTransportation |
WorkshopWorkshop |
WorshipPulpitChoirReligious |
NoOfSpaceTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


HVACLoadConstructionClass Enumeration

[image]

Revit 2011 API
HVACLoadConstructionClass Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum HVACLoadConstructionClass
Visual Basic (Declaration)
Public Enumeration HVACLoadConstructionClass
Visual C++
public enum class HVACLoadConstructionClass

Members

Member name | Description
LooseConstruction | A loose construction has an infiltration level of approximately 0.076 cfm/sqft
MediumConstruction | A medium construction has an infiltration level of approximately 0.038 cfm/sqft
TightConstruction | A tight construction has an infiltration level of approximately 0.019 cfm/sqft
NoneConstruction | A none construction has an infiltration level of 0 cfm/sqft

See Also

Autodesk.Revit.DB.Analysis Namespace


HVACLoadLoadsReportType Enumeration

[image]

Revit 2011 API
HVACLoadLoadsReportType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum HVACLoadLoadsReportType
Visual Basic (Declaration)
Public Enumeration HVACLoadLoadsReportType
Visual C++
public enum class HVACLoadLoadsReportType

Members

Member name | Description
NoReport | No report
SimpleReport | A simple report with summaries
StandardReport | A standard report including zones and spaces
DetailedReport | A detailed report including orientation breakdowns

See Also

Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Class

[image]

Revit 2011 API
MassEnergyAnalyticalModel Class
Members See Also Send Feedback
This class associates a mass instance with an energy analytical model data and geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassEnergyAnalyticalModel : Element
Visual Basic (Declaration)
Public Class MassEnergyAnalyticalModel _
    Inherits Element
Visual C++
public ref class MassEnergyAnalyticalModel : public Element

Remarks

The geometry begins as a copy of its associated mass instance geometry and is modified according to the requirements of the energy analytical model. MassZones are created from the MassEnergyAnalyticalModel and MassLevelDatas associated with a common mass instance.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassEnergyAnalyticalModel

See Also

MassEnergyAnalyticalModel Members
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Members

[image] [image]

Revit 2011 API
MassEnergyAnalyticalModel Members
MassEnergyAnalyticalModel Class Methods Properties See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentEnergyAnalyticalModelFaceReference |
GetCoincidentMassZoneFaceReferences |
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassId | The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.
MassZoneCoreOffset | If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Methods

[image] [image]

Revit 2011 API
MassEnergyAnalyticalModel Methods
MassEnergyAnalyticalModel Class See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentEnergyAnalyticalModelFaceReference |
GetCoincidentMassZoneFaceReferences |
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentEnergyAnalyticalModelFaceReference Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetCoincidentEnergyAnalyticalModelFaceReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static Reference GetCoincidentEnergyAnalyticalModelFaceReference(
    Document document,
    Reference referenceToFace
)
Visual Basic (Declaration)
Public Shared Function GetCoincidentEnergyAnalyticalModelFaceReference ( _
    document As Document, _
    referenceToFace As Reference _
) As Reference
Visual C++
public:
static Reference^ GetCoincidentEnergyAnalyticalModelFaceReference(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Return Value

Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.

Remarks

The result is always a Reference to a Face. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentMassZoneFaceReferences Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetCoincidentMassZoneFaceReferences Method
MassEnergyAnalyticalModel Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static IList<Reference> GetCoincidentMassZoneFaceReferences(
    Document document,
    Reference referenceToFace
)
Visual Basic (Declaration)
Public Shared Function GetCoincidentMassZoneFaceReferences ( _
    document As Document, _
    referenceToFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetCoincidentMassZoneFaceReferences(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Return Value

Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetJoinedMassEnergyAnalyticalModelElementIds Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetJoinedMassEnergyAnalyticalModelElementIds Method
MassEnergyAnalyticalModel Class See Also Send Feedback
The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ICollection<ElementId> GetJoinedMassEnergyAnalyticalModelElementIds()
Visual Basic (Declaration)
Public Function GetJoinedMassEnergyAnalyticalModelElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetJoinedMassEnergyAnalyticalModelElementIds()

Return Value

ElementIds of other MassEnergyAnalyticalModels that are joined to this one.

Remarks

Joined MassEnergyAnalyticalModels are created off of mass instances that are joined and which both have MassLevelData's associated. Only MassEnergyAnalyticalModels which are joined will take each other into account when regenerating surface subcategories for their Faces. For example, if two MassEnergyAnalyticalModels were adjacent but not joined, both their touching faces would be treated as "Mass Exterior Wall", instead of "Mass Interior Wall". This situation (touching things not being joined) because mass instances, and as a result, corresponding MassEnergyAnalyticalModel's are automatically joined and only become unjoined if the user unjoins them.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassEnergyAnalyticalModelIdForMassInstance Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetMassEnergyAnalyticalModelIdForMassInstance Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static ElementId GetMassEnergyAnalyticalModelIdForMassInstance(
    Document document,
    ElementId massInstanceId
)
Visual Basic (Declaration)
Public Shared Function GetMassEnergyAnalyticalModelIdForMassInstance ( _
    document As Document, _
    massInstanceId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetMassEnergyAnalyticalModelIdForMassInstance(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::.ElementId
ElementId of a mass instance.

Return Value

ElementId of a MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassSurfaceDataIdForReference Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetMassSurfaceDataIdForReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the ElementId of the MassSurfaceData corresponding to the Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId GetMassSurfaceDataIdForReference(
    Reference reference
)
Visual Basic (Declaration)
Public Function GetMassSurfaceDataIdForReference ( _
    reference As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassSurfaceDataIdForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A Reference to a face of this MassEnergyAnalyticalModel.

Return Value

ElementId of a MassSurfaceData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassZoneIds Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetMassZoneIds Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ICollection<ElementId> GetMassZoneIds()
Visual Basic (Declaration)
Public Function GetMassZoneIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMassZoneIds()

Return Value

Returns the ElementIds of MassZones.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToAllFaces Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetReferencesToAllFaces Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToAllFaces()
Visual Basic (Declaration)
Public Function GetReferencesToAllFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllFaces()

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToAllShadingFaces Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetReferencesToAllShadingFaces Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToAllShadingFaces()
Visual Basic (Declaration)
Public Function GetReferencesToAllShadingFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllShadingFaces()

Return Value

Array of Reference to Faces that represent Mass Shades.

Remarks

Called out as a separate convenience method because often it is more useful to obtain information about non-shading faces from the zones, and only get information about shading faces from the MassEnergyAnalyticalModel.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetValidSurfaceCategoryIdsForReference Method

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.GetValidSurfaceCategoryIdsForReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback
The Mass surface subcategory ids that are appropriate values for the input Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<ElementId> GetValidSurfaceCategoryIdsForReference(
    Reference reference,
    out ElementId recommendedDefaultSubcategoryId
)
Visual Basic (Declaration)
Public Function GetValidSurfaceCategoryIdsForReference ( _
    reference As Reference, _
    <OutAttribute> ByRef recommendedDefaultSubcategoryId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetValidSurfaceCategoryIdsForReference(
    Reference^ reference,
    [OutAttribute] ElementId^% recommendedDefaultSubcategoryId
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A Reference to a Face of this MassEnergyAnalyticalModel.
recommendedDefaultSubcategoryId
Type: Autodesk.Revit.DB..::.ElementId %
The ElementId that is recommended as the default setting for this pick.

Return Value

Returns the ElementIds of appropriate values for input Reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Properties

[image] [image]

Revit 2011 API
MassEnergyAnalyticalModel Properties
MassEnergyAnalyticalModel Class See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassId | The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.
MassZoneCoreOffset | If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassId Property

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.MassId Property
MassEnergyAnalyticalModel Class See Also Send Feedback
The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MassId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MassId As ElementId
Visual C++
public:
property ElementId^ MassId {
    ElementId^ get ();
}

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneCoreOffset Property

[image]

Revit 2011 API
MassEnergyAnalyticalModel..::.MassZoneCoreOffset Property
MassEnergyAnalyticalModel Class See Also Send Feedback
If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic (Declaration)
Public Property MassZoneCoreOffset As Double
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

Remarks

The resulting "core" geometry created inside the mass instance solid geometry is offset inwards at each level intersecting the mass instance solid geometry by the value of the offset. This "core" geometry is automatically cut from its parent mass instance geometry in the MassEnergyAnalyticalModel.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
MassEnergyAnalyticalModel..::.Parameter Property
MassEnergyAnalyticalModel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
MassEnergyAnalyticalModel Members
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Class

[image]

Revit 2011 API
MassGBXMLExportOptions Class
Members See Also Send Feedback
Options used when exporting a gbXML file from a mass model document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassGBXMLExportOptions : IDisposable
Visual Basic (Declaration)
Public Class MassGBXMLExportOptions _
    Implements IDisposable
Visual C++
public ref class MassGBXMLExportOptions : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.MassGBXMLExportOptions

See Also

MassGBXMLExportOptions Members
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Members

[image] [image]

Revit 2011 API
MassGBXMLExportOptions Members
MassGBXMLExportOptions Class Constructors Methods See Also Send Feedback

The MassGBXMLExportOptions type exposes the following members.

Constructors

Name | Description
MassGBXMLExportOptions | Constructs a new instance of the options used to export a mass model to gbXML.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Constructor

[image]

Revit 2011 API
MassGBXMLExportOptions Constructor
MassGBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassGBXMLExportOptions(
    IList<ElementId> massZoneIds,
    IList<ElementId> massIds
)
Visual Basic (Declaration)
Public Sub New ( _
    massZoneIds As IList(Of ElementId), _
    massIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
    IList<ElementId^>^ massZoneIds,
    IList<ElementId^>^ massIds
)

Parameters

massZoneIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Indicates the mass zones to analyze in the exported gbXML.
massIds
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Methods

[image] [image]

Revit 2011 API
MassGBXMLExportOptions Methods
MassGBXMLExportOptions Class See Also Send Feedback

The MassGBXMLExportOptions type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
MassGBXMLExportOptions..::.Dispose Method
MassGBXMLExportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


GetMassIds Method

[image]

Revit 2011 API
MassGBXMLExportOptions..::.GetMassIds Method
MassGBXMLExportOptions Class See Also Send Feedback
Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<ElementId> GetMassIds()
Visual Basic (Declaration)
Public Function GetMassIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMassIds()

Return Value

The ids of the masses.

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


GetMassZoneIds Method

[image]

Revit 2011 API
MassGBXMLExportOptions..::.GetMassZoneIds Method
MassGBXMLExportOptions Class See Also Send Feedback
Gets a list of mass zones to analyze in the exported gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<ElementId> GetMassZoneIds()
Visual Basic (Declaration)
Public Function GetMassZoneIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMassZoneIds()

Return Value

The ids of the mass zone.

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Class

[image]

Revit 2011 API
MassLevelData Class
Members See Also Send Feedback
MassLevelData is a conceptual representation of an occupiable floor in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassLevelData : Element
Visual Basic (Declaration)
Public Class MassLevelData _
    Inherits Element
Visual C++
public ref class MassLevelData : public Element

Remarks

MassLevelData reports metrics, such as floor areas, related to conceptual space planning. MassLevelData contains information, such as ConceptualConstructionType, used as part of the Conceptual Energy Analytical model. The MassLevel data geometry is determined by combining all the geometry of a mass into a single geometry, and then taking the area of intersection with the level of the MassLevelData.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassLevelData

See Also

MassLevelData Members
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Members

[image] [image]

Revit 2011 API
MassLevelData Members
MassLevelData Class Methods Properties See Also Send Feedback

The MassLevelData type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if the MassLevelData has a geometrical representation. May not if the level does not intersect the mass geometry.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData.
ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | The ElementId of the level that the MassLevelData is associated with.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MaterialId | The ElementId of the visualization material used for the MassLevelData
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Name | A human readable name for the Element. (Inherited from Element.)
NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.
NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
NVolume | The volume of from the level of this MassLevelData to the next in the mass.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
OwningMassId | The ElementId of the mass that the MassLevelData is associated with.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Methods

[image] [image]

Revit 2011 API
MassLevelData Methods
MassLevelData Class See Also Send Feedback

The MassLevelData type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if the MassLevelData has a geometrical representation. May not if the level does not intersect the mass geometry.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsEmpty Method

[image]

Revit 2011 API
MassLevelData..::.IsEmpty Method
MassLevelData Class See Also Send Feedback
Indicates if the MassLevelData has a geometrical representation. May not if the level does not intersect the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsEmpty()
Visual Basic (Declaration)
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

Returns True if MassLevelData is dimensionless, False otherwise.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsMassFamilyInstance Method

[image]

Revit 2011 API
MassLevelData..::.IsMassFamilyInstance Method
MassLevelData Class See Also Send Feedback
Checks if the ElementId is a mass family instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public static bool IsMassFamilyInstance(
    Document document,
    ElementId id
)
Visual Basic (Declaration)
Public Shared Function IsMassFamilyInstance ( _
    document As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsMassFamilyInstance(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be checked.

Return Value

True if the ElementId is a mass family instance, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionTypeElement Method

[image]

Revit 2011 API
MassLevelData..::.IsValidConceptualConstructionTypeElement Method
MassLevelData Class See Also Send Feedback
Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsValidConceptualConstructionTypeElement(
    ElementId id
)
Visual Basic (Declaration)
Public Function IsValidConceptualConstructionTypeElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool IsValidConceptualConstructionTypeElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::.ElementId
The ElementId to be checked.

Return Value

True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.

Remarks

In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Properties

[image] [image]

Revit 2011 API
MassLevelData Properties
MassLevelData Class See Also Send Feedback

The MassLevelData type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData.
ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelId | The ElementId of the level that the MassLevelData is associated with.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MaterialId | The ElementId of the visualization material used for the MassLevelData
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Name | A human readable name for the Element. (Inherited from Element.)
NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.
NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
NVolume | The volume of from the level of this MassLevelData to the next in the mass.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
OwningMassId | The ElementId of the mass that the MassLevelData is associated with.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionId Property

[image]

Revit 2011 API
MassLevelData..::.ConceptualConstructionId Property
MassLevelData Class See Also Send Feedback
The ElementId of the conceptual construction associated with the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId ConceptualConstructionId { get; set; }
Visual Basic (Declaration)
Public Property ConceptualConstructionId As ElementId
Visual C++
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionIsByEnergyData Property

[image]

Revit 2011 API
MassLevelData..::.ConceptualConstructionIsByEnergyData Property
MassLevelData Class See Also Send Feedback
Indicates if the ConceptualConstructionType of the MassLevelData is synchronized with the EnergyDataSettings or if it overrides those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool ConceptualConstructionIsByEnergyData { get; set; }
Visual Basic (Declaration)
Public Property ConceptualConstructionIsByEnergyData As Boolean
Visual C++
public:
property bool ConceptualConstructionIsByEnergyData {
    bool get ();
    void set (bool value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


LevelId Property

[image]

Revit 2011 API
MassLevelData..::.LevelId Property
MassLevelData Class See Also Send Feedback
The ElementId of the level that the MassLevelData is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId LevelId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LevelId As ElementId
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2011 API
MassLevelData..::.MaterialId Property
MassLevelData Class See Also Send Feedback
The ElementId of the visualization material used for the MassLevelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic (Declaration)
Public Property MaterialId As ElementId
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2011 API
MassLevelData..::.MaterialType Property
MassLevelData Class See Also Send Feedback
Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic (Declaration)
Public Property MaterialType As MassSurfaceDataMaterialType
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NExteriorSurfaceArea Property

[image]

Revit 2011 API
MassLevelData..::.NExteriorSurfaceArea Property
MassLevelData Class See Also Send Feedback
The exterior surface area of the volume of the mass between the level of this MassLevelData to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double NExteriorSurfaceArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property NExteriorSurfaceArea As Double
Visual C++
public:
property double NExteriorSurfaceArea {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NLevelFafArea Property

[image]

Revit 2011 API
MassLevelData..::.NLevelFafArea Property
MassLevelData Class See Also Send Feedback
The surface area of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double NLevelFafArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property NLevelFafArea As Double
Visual C++
public:
property double NLevelFafArea {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NLevelPerimeter Property

[image]

Revit 2011 API
MassLevelData..::.NLevelPerimeter Property
MassLevelData Class See Also Send Feedback
The perimeter of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double NLevelPerimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property NLevelPerimeter As Double
Visual C++
public:
property double NLevelPerimeter {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NVolume Property

[image]

Revit 2011 API
MassLevelData..::.NVolume Property
MassLevelData Class See Also Send Feedback
The volume of from the level of this MassLevelData to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double NVolume { get; }
Visual Basic (Declaration)
Public ReadOnly Property NVolume As Double
Visual C++
public:
property double NVolume {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


OwningMassId Property

[image]

Revit 2011 API
MassLevelData..::.OwningMassId Property
MassLevelData Class See Also Send Feedback
The ElementId of the mass that the MassLevelData is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId OwningMassId { get; }
Visual Basic (Declaration)
Public ReadOnly Property OwningMassId As ElementId
Visual C++
public:
property ElementId^ OwningMassId {
    ElementId^ get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
MassLevelData..::.Parameter Property
MassLevelData Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MassLevelData Class
MassLevelData Members
Autodesk.Revit.DB.Analysis Namespace


StrUsage Property

[image]

Revit 2011 API
MassLevelData..::.StrUsage Property
MassLevelData Class See Also Send Feedback
A String which describes the usage or occupancy type of the level of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public string StrUsage { get; set; }
Visual Basic (Declaration)
Public Property StrUsage As String
Visual C++
public:
property String^ StrUsage {
    String^ get ();
    void set (String^ value);
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Class

[image]

Revit 2011 API
MassSurfaceData Class
Members See Also Send Feedback
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassSurfaceData : Element
Visual Basic (Declaration)
Public Class MassSurfaceData _
    Inherits Element
Visual C++
public ref class MassSurfaceData : public Element

Remarks

Properties stored in the MassSurfaceData can be used in regeneration by the MassEnergyAnalyticalModel. For example, faces of the MassEnergyAnalyticalModel take their material values from the settings in the MassSurfaceData.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassSurfaceData

See Also

MassSurfaceData Members
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Members

[image] [image]

Revit 2011 API
MassSurfaceData Members
MassSurfaceData Class Methods Properties See Also Send Feedback

The MassSurfaceData type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | Area of the references that the MassSurfaceData provides properties for.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
IsSlab | Indicates if a floor is a slab.
IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | material type of mass zone
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
ShadeDepth | How far any auto-generated shades should extend from the wall surface.
SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Methods

[image] [image]

Revit 2011 API
MassSurfaceData Methods
MassSurfaceData Class See Also Send Feedback

The MassSurfaceData type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


GetFaceReferences Method

[image]

Revit 2011 API
MassSurfaceData..::.GetFaceReferences Method
MassSurfaceData Class See Also Send Feedback
Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetFaceReferences()
Visual Basic (Declaration)
Public Function GetFaceReferences As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetFaceReferences()

Return Value

Returns an array of References to Faces that the MassSurfaceData provides properties for.

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Properties

[image] [image]

Revit 2011 API
MassSurfaceData Properties
MassSurfaceData Class See Also Send Feedback

The MassSurfaceData type exposes the following members.

Properties

Name | Description
Area | Area of the references that the MassSurfaceData provides properties for.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
IsSlab | Indicates if a floor is a slab.
IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | material type of mass zone
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
ShadeDepth | How far any auto-generated shades should extend from the wall surface.
SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


Area Property

[image]

Revit 2011 API
MassSurfaceData..::.Area Property
MassSurfaceData Class See Also Send Feedback
Area of the references that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

If it is used, should be greater than zero. Otherwise, it will be zero.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


CategoryIdForConceptualSurfaceType Property

[image]

Revit 2011 API
MassSurfaceData..::.CategoryIdForConceptualSurfaceType Property
MassSurfaceData Class See Also Send Feedback
Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId CategoryIdForConceptualSurfaceType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CategoryIdForConceptualSurfaceType As ElementId
Visual C++
public:
property ElementId^ CategoryIdForConceptualSurfaceType {
    ElementId^ get ();
}

Remarks

This value is determined by starting with the subcategory property and adjusting it according to properties such as "isSlab" or "isUnderground".

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionId Property

[image]

Revit 2011 API
MassSurfaceData..::.ConceptualConstructionId Property
MassSurfaceData Class See Also Send Feedback
The id of the conceptual construction associated with the reference surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId ConceptualConstructionId { get; set; }
Visual Basic (Declaration)
Public Property ConceptualConstructionId As ElementId
Visual C++
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsConceptualConstructionByEnergyData Property

[image]

Revit 2011 API
MassSurfaceData..::.IsConceptualConstructionByEnergyData Property
MassSurfaceData Class See Also Send Feedback
True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsConceptualConstructionByEnergyData { get; set; }
Visual Basic (Declaration)
Public Property IsConceptualConstructionByEnergyData As Boolean
Visual C++
public:
property bool IsConceptualConstructionByEnergyData {
    bool get ();
    void set (bool value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsGlazingShaded Property

[image]

Revit 2011 API
MassSurfaceData..::.IsGlazingShaded Property
MassSurfaceData Class See Also Send Feedback
Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsGlazingShaded { get; set; }
Visual Basic (Declaration)
Public Property IsGlazingShaded As Boolean
Visual C++
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsSlab Property

[image]

Revit 2011 API
MassSurfaceData..::.IsSlab Property
MassSurfaceData Class See Also Send Feedback
Indicates if a floor is a slab.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsSlab { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSlab As Boolean
Visual C++
public:
property bool IsSlab {
    bool get ();
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsUnderground Property

[image]

Revit 2011 API
MassSurfaceData..::.IsUnderground Property
MassSurfaceData Class See Also Send Feedback
Indicates if the roof, floor, slab, or wall surface reference is underground.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsUnderground { get; set; }
Visual Basic (Declaration)
Public Property IsUnderground As Boolean
Visual C++
public:
property bool IsUnderground {
    bool get ();
    void set (bool value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelDataId Property

[image]

Revit 2011 API
MassSurfaceData..::.MassLevelDataId Property
MassSurfaceData Class See Also Send Feedback
The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MassLevelDataId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MassLevelDataId As ElementId
Visual C++
public:
property ElementId^ MassLevelDataId {
    ElementId^ get ();
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2011 API
MassSurfaceData..::.MaterialId Property
MassSurfaceData Class See Also Send Feedback
The visualization material used for the surface for displaying the energy analytical model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic (Declaration)
Public Property MaterialId As ElementId
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2011 API
MassSurfaceData..::.MaterialType Property
MassSurfaceData Class See Also Send Feedback
material type of mass zone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic (Declaration)
Public Property MaterialType As MassSurfaceDataMaterialType
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
MassSurfaceData..::.Parameter Property
MassSurfaceData Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MassSurfaceData Class
MassSurfaceData Members
Autodesk.Revit.DB.Analysis Namespace


PercentageGlazing Property

[image]

Revit 2011 API
MassSurfaceData..::.PercentageGlazing Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double PercentageGlazing { get; set; }
Visual Basic (Declaration)
Public Property PercentageGlazing As Double
Visual C++
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the wall with windows is not guaranteed to match this value. It is a target.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


PercentageSkylights Property

[image]

Revit 2011 API
MassSurfaceData..::.PercentageSkylights Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic (Declaration)
Public Property PercentageSkylights As Double
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the roof with skylights is not guaranteed to match this value. It is a target.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ReferenceElementId Property

[image]

Revit 2011 API
MassSurfaceData..::.ReferenceElementId Property
MassSurfaceData Class See Also Send Feedback
The ElementId of the element whose face the MassSurfaceData primarily refers to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId ReferenceElementId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceElementId As ElementId
Visual C++
public:
property ElementId^ ReferenceElementId {
    ElementId^ get ();
}

Remarks

A MassSurfaceData may represent multiple faces from the same or different elements. This generally only happens if the faces are geometrically fully coincident and logically represent a single building object. "Interior walls" of the conceptual energy building model is a common example where two different faces may be represented by a single MassSurfaceData.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ShadeDepth Property

[image]

Revit 2011 API
MassSurfaceData..::.ShadeDepth Property
MassSurfaceData Class See Also Send Feedback
How far any auto-generated shades should extend from the wall surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic (Declaration)
Public Property ShadeDepth As Double
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SillHeight Property

[image]

Revit 2011 API
MassSurfaceData..::.SillHeight Property
MassSurfaceData Class See Also Send Feedback
The height above the level where the bottoms of auto-generated windows will be located.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double SillHeight { get; set; }
Visual Basic (Declaration)
Public Property SillHeight As Double
Visual C++
public:
property double SillHeight {
    double get ();
    void set (double value);
}

Remarks

Will be accurate unless the target glazing percentage cannot be achieved using this height. In that case, the sillHeight will be ignored and windows will be created below this height.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SkylightWidth Property

[image]

Revit 2011 API
MassSurfaceData..::.SkylightWidth Property
MassSurfaceData Class See Also Send Feedback
The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double SkylightWidth { get; set; }
Visual Basic (Declaration)
Public Property SkylightWidth As Double
Visual C++
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SurfaceDataSource Property

[image]

Revit 2011 API
MassSurfaceData..::.SurfaceDataSource Property
MassSurfaceData Class See Also Send Feedback
Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassSurfaceDataSource SurfaceDataSource { get; set; }
Visual Basic (Declaration)
Public Property SurfaceDataSource As MassSurfaceDataSource
Visual C++
public:
property MassSurfaceDataSource SurfaceDataSource {
    MassSurfaceDataSource get ();
    void set (MassSurfaceDataSource value);
}

Remarks

The Construction property is not governed by this setting and has a separate value to indicate if it is to be synchronized with EnergyDataSettings.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataMaterialType Enumeration

[image]

Revit 2011 API
MassSurfaceDataMaterialType Enumeration
See Also Send Feedback
Indicates how the visualization material for the MassSurfaceData is calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassSurfaceDataMaterialType
Visual Basic (Declaration)
Public Enumeration MassSurfaceDataMaterialType
Visual C++
public enum class MassSurfaceDataMaterialType

Members

Member name | Description
MaterialByConstruction | The visualization material for the MassSurfaceData will be taken from the material assigned to the ConceptualConstructionType which is assigned to the MassSurfaceData.
NormalMaterial | The visualization material for the MassSurfaceData will be taken from the material associated with the object style of the subcategory of the MassSurfaceData if the materialId is InvalidElementId, or the MassSurfaceData will use the specific material indicated by the materialId property if its value is an ElementId of a MaterialElement.

See Also

Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataSource Enumeration

[image]

Revit 2011 API
MassSurfaceDataSource Enumeration
See Also Send Feedback
Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassSurfaceDataSource
Visual Basic (Declaration)
Public Enumeration MassSurfaceDataSource
Visual C++
public enum class MassSurfaceDataSource

Members

Member name | Description
Invalid | This value indicates that the parameter has not been properly set.
EnergyData | Synchronize with the EnergyDataSettings.
Surface | Override the EnergyDataSettings values for the surface.

See Also

Autodesk.Revit.DB.Analysis Namespace


MassZone Class

[image]

Revit 2011 API
MassZone Class
Members See Also Send Feedback
MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representions of individually heated and cooled sub-volumes of a building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public class MassZone : Element
Visual Basic (Declaration)
Public Class MassZone _
    Inherits Element
Visual C++
public ref class MassZone : public Element

Remarks

MassZones are created by dividing a MassEnergyAnalyticalModel into pieces by intersecting MassLevelDatas associated with a Mass FamilyInstance with the geometries of the MassEnergyAnalyticalModel associated with the same Mass FamilyInstance.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.MassZone

See Also

MassZone Members
Autodesk.Revit.DB.Analysis Namespace


MassZone Members

[image] [image]

Revit 2011 API
MassZone Members
MassZone Class Methods Properties See Also Send Feedback

The MassZone type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConditionType | The gbXMLConditionType of the MassZone.
CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorArea | The floor area of the MassZone.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LowerLevelId | The bottom level defining the MassZone.
MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates how the material of MassZone faces is determined.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceType | The gbXMLSpaceType of the MassZone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLevelId | The upper level defining the MassZone.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | The volume of the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZone Methods

[image] [image]

Revit 2011 API
MassZone Methods
MassZone Class See Also Send Feedback

The MassZone type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentReferenceFromAdjacentZone Method

[image]

Revit 2011 API
MassZone..::.GetCoincidentReferenceFromAdjacentZone Method
MassZone Class See Also Send Feedback
This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public Reference GetCoincidentReferenceFromAdjacentZone(
    Reference referenceToZoneFace
)
Visual Basic (Declaration)
Public Function GetCoincidentReferenceFromAdjacentZone ( _
    referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetCoincidentReferenceFromAdjacentZone(
    Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB..::.Reference
Reference to face of MassZone.

Return Value

Reference to concident face of adjacent MassZone or NULL if there is no adjacent MassZone face Reference.

Remarks

The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetEquivalentReferenceFromMassOrLevel Method

[image]

Revit 2011 API
MassZone..::.GetEquivalentReferenceFromMassOrLevel Method
MassZone Class See Also Send Feedback
Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public Reference GetEquivalentReferenceFromMassOrLevel(
    Reference referenceToZoneFace
)
Visual Basic (Declaration)
Public Function GetEquivalentReferenceFromMassOrLevel ( _
    referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetEquivalentReferenceFromMassOrLevel(
    Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB..::.Reference
Reference to a face of the zone to get an equivalent reference for.

Return Value

Reference to MassEnergyAnalyticalModel or MassLevelData. Should only be NULL if there is an error in the MassEnergyAnalyticalModel data or the input is not a

Remarks

If the Reference is to a MassLevelData element, it means that the MassEnergyAnalyticalModel element did not have an exterior face for this MassZone face. For this case, the MassZone face was created as the cross-section of the MassEnergyAnalyticalModel geometry where it was intersected by the level of the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetMassDataElementIdForZoneFaceReference Method

[image]

Revit 2011 API
MassZone..::.GetMassDataElementIdForZoneFaceReference Method
MassZone Class See Also Send Feedback
MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId GetMassDataElementIdForZoneFaceReference(
    Reference referenceOfZone
)
Visual Basic (Declaration)
Public Function GetMassDataElementIdForZoneFaceReference ( _
    referenceOfZone As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassDataElementIdForZoneFaceReference(
    Reference^ referenceOfZone
)

Parameters

referenceOfZone
Type: Autodesk.Revit.DB..::.Reference
Reference to face of the MassZone to get data element for.

Return Value

Id of MassSurfaceData or MassLevelData element.

Remarks

This element will contain the properties associated with the MassEnergyAnalyticalModel face or MassLevelData that the MassZone Face is derived from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToEnergyAnalysisFaces Method

[image]

Revit 2011 API
MassZone..::.GetReferencesToEnergyAnalysisFaces Method
MassZone Class See Also Send Feedback
Used to get References to all the faces of the MassZone that are used for Energy Analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public IList<Reference> GetReferencesToEnergyAnalysisFaces()
Visual Basic (Declaration)
Public Function GetReferencesToEnergyAnalysisFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToEnergyAnalysisFaces()

Return Value

Array of References to faces of MassZone.

Remarks

These are the faces and face regions that are typically visible to the user when MassZones are displayed. There are other faces in the MassZone geometry that are not visible and not used for EnergyAnalysis. The results are always references to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports them as REFERENCE_TYPE_NONE.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


IsEmpty Method

[image]

Revit 2011 API
MassZone..::.IsEmpty Method
MassZone Class See Also Send Feedback
Indicates if MassZone has no geometry. Such zones should not be shown to the user.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsEmpty()
Visual Basic (Declaration)
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

Returns True if MassZone has no geometry.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZone Properties

[image] [image]

Revit 2011 API
MassZone Properties
MassZone Class See Also Send Feedback

The MassZone type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConditionType | The gbXMLConditionType of the MassZone.
CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorArea | The floor area of the MassZone.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
LowerLevelId | The bottom level defining the MassZone.
MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Indicates how the material of MassZone faces is determined.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceType | The gbXMLSpaceType of the MassZone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLevelId | The upper level defining the MassZone.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | The volume of the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


ConditionType Property

[image]

Revit 2011 API
MassZone..::.ConditionType Property
MassZone Class See Also Send Feedback
The gbXMLConditionType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public gbXMLConditionType ConditionType { get; set; }
Visual Basic (Declaration)
Public Property ConditionType As gbXMLConditionType
Visual C++
public:
property gbXMLConditionType ConditionType {
    gbXMLConditionType get ();
    void set (gbXMLConditionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The condition type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


CutByLowerLevel Property

[image]

Revit 2011 API
MassZone..::.CutByLowerLevel Property
MassZone Class See Also Send Feedback
Indicates the relationship between the MassZone and its lower level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassZoneLevelCutState CutByLowerLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property CutByLowerLevel As MassZoneLevelCutState
Visual C++
public:
property MassZoneLevelCutState CutByLowerLevel {
    MassZoneLevelCutState get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


CutByUpperLevel Property

[image]

Revit 2011 API
MassZone..::.CutByUpperLevel Property
MassZone Class See Also Send Feedback
Indicates the relationship between the MassZone and its upper level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassZoneLevelCutState CutByUpperLevel { get; }
Visual Basic (Declaration)
Public ReadOnly Property CutByUpperLevel As MassZoneLevelCutState
Visual C++
public:
property MassZoneLevelCutState CutByUpperLevel {
    MassZoneLevelCutState get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


FloorArea Property

[image]

Revit 2011 API
MassZone..::.FloorArea Property
MassZone Class See Also Send Feedback
The floor area of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double FloorArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property FloorArea As Double
Visual C++
public:
property double FloorArea {
    double get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


IsZoneOccupiable Property

[image]

Revit 2011 API
MassZone..::.IsZoneOccupiable Property
MassZone Class See Also Send Feedback
A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public bool IsZoneOccupiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsZoneOccupiable As Boolean
Visual C++
public:
property bool IsZoneOccupiable {
    bool get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


LowerLevelId Property

[image]

Revit 2011 API
MassZone..::.LowerLevelId Property
MassZone Class See Also Send Feedback
The bottom level defining the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId LowerLevelId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LowerLevelId As ElementId
Visual C++
public:
property ElementId^ LowerLevelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModelId Property

[image]

Revit 2011 API
MassZone..::.MassEnergyAnalyticalModelId Property
MassZone Class See Also Send Feedback
The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MassEnergyAnalyticalModelId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MassEnergyAnalyticalModelId As ElementId
Visual C++
public:
property ElementId^ MassEnergyAnalyticalModelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2011 API
MassZone..::.MaterialId Property
MassZone Class See Also Send Feedback
The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic (Declaration)
Public Property MaterialId As ElementId
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2011 API
MassZone..::.MaterialType Property
MassZone Class See Also Send Feedback
Indicates how the material of MassZone faces is determined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public MassZoneMaterialType MaterialType { get; set; }
Visual Basic (Declaration)
Public Property MaterialType As MassZoneMaterialType
Visual C++
public:
property MassZoneMaterialType MaterialType {
    MassZoneMaterialType get ();
    void set (MassZoneMaterialType value);
}

Remarks

The material of the MassZone faced will be determined in the following ways based on the material type. MassZoneMaterialTypeMaterialBySurfaceType: Each MassZone face will use the material defined by the object style of the subcategory of the Element returned by getMassDataElementIdForZoneFaceReference(..). MassZoneMaterialTypeNormalMaterial: If the materialId is InvalidElementId, then the material defined by the object style of the MassZone subcategory will be used for all faces of the MassZone. MassZoneMaterialTypeNormalMaterial: If the materialId is the id of a Material element, that material id will be used for all faces fo the MassZone.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
MassZone..::.Parameter Property
MassZone Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MassZone Class
MassZone Members
Autodesk.Revit.DB.Analysis Namespace


SpaceType Property

[image]

Revit 2011 API
MassZone..::.SpaceType Property
MassZone Class See Also Send Feedback
The gbXMLSpaceType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public gbXMLSpaceType SpaceType { get; set; }
Visual Basic (Declaration)
Public Property SpaceType As gbXMLSpaceType
Visual C++
public:
property gbXMLSpaceType SpaceType {
    gbXMLSpaceType get ();
    void set (gbXMLSpaceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The space type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


UpperLevelId Property

[image]

Revit 2011 API
MassZone..::.UpperLevelId Property
MassZone Class See Also Send Feedback
The upper level defining the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public ElementId UpperLevelId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpperLevelId As ElementId
Visual C++
public:
property ElementId^ UpperLevelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


Volume Property

[image]

Revit 2011 API
MassZone..::.Volume Property
MassZone Class See Also Send Feedback
The volume of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneLevelCutState Enumeration

[image]

Revit 2011 API
MassZoneLevelCutState Enumeration
See Also Send Feedback
The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassZoneLevelCutState
Visual Basic (Declaration)
Public Enumeration MassZoneLevelCutState
Visual C++
public enum class MassZoneLevelCutState

Members

Member name | Description
NotCut |
Cut |
NotCutButCoincident |

See Also

Autodesk.Revit.DB.Analysis Namespace


MassZoneMaterialType Enumeration

[image]

Revit 2011 API
MassZoneMaterialType Enumeration
See Also Send Feedback
MassZone material type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011_Subscription_Advantage_Pack

Syntax

C#
public enum MassZoneMaterialType
Visual Basic (Declaration)
Public Enumeration MassZoneMaterialType
Visual C++
public enum class MassZoneMaterialType

Members

Member name | Description
MaterialBySurfaceType | Material for a given face of a MassZone comes from the category of the face of the MassEnergyAnalyticalModel that the MassZone face is created from.
NormalMaterial | If materialId is InvalidElementId, all faces of the MassZone will use the material from the MassZone category object style. If materialId is a valid material, all faces of the MassZone will use that specific material.

Remarks

Indicates how MassZone material is calculated.

See Also

Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Class

[image]

Revit 2011 API
SpatialFieldManager Class
Members Example See Also Send Feedback
Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SpatialFieldManager : Element
Visual Basic (Declaration)
Public Class SpatialFieldManager _
    Inherits Element
Visual C++
public ref class SpatialFieldManager : public Element

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (null == sfm)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}
Reference reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face");
int idx = sfm.AddSpatialFieldPrimitive(reference);

Face face = reference.GeometryObject as Face;

IList<UV> uvPts = new List<UV>();
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;
uvPts.Add(new UV(min.U,min.V));
uvPts.Add(new UV(max.U,max.V));

FieldDomainPointsByUV pnts = new FieldDomainPointsByUV(uvPts);

List<double> doubleList = new List<double>();
IList<ValueAtPoint> valList = new List<ValueAtPoint>();
doubleList.Add(0);
valList.Add(new ValueAtPoint(doubleList));
doubleList.Clear();
doubleList.Add(10);
valList.Add(new ValueAtPoint(doubleList));

FieldValues vals = new FieldValues(valList);

sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals);
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As Autodesk.Revit.DB.Analysis.SpatialFieldManager = Autodesk.Revit.DB.Analysis.SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
    sfm = Autodesk.Revit.DB.Analysis.SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If
Dim reference As Reference = uiDoc.Selection.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Face, "Select a face")
Dim idx As Integer = sfm.AddSpatialFieldPrimitive(reference)

Dim face As Autodesk.Revit.DB.Face = TryCast(reference.GeometryObject, Autodesk.Revit.DB.Face)

Dim uvPts As IList(Of Autodesk.Revit.DB.UV) = New List(Of Autodesk.Revit.DB.UV)()
Dim bb As BoundingBoxUV = face.GetBoundingBox()
Dim min As Autodesk.Revit.DB.UV = bb.Min
Dim max As Autodesk.Revit.DB.UV = bb.Max
uvPts.Add(New Autodesk.Revit.DB.UV(min.U, min.V))
uvPts.Add(New Autodesk.Revit.DB.UV(max.U, max.V))

Dim pnts As New Autodesk.Revit.DB.Analysis.FieldDomainPointsByUV(uvPts)

Dim doubleList As New List(Of Double)()
Dim valList As IList(Of Autodesk.Revit.DB.Analysis.ValueAtPoint) = New List(Of Autodesk.Revit.DB.Analysis.ValueAtPoint)()
doubleList.Add(0)
valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))
doubleList.Clear()
doubleList.Add(10)
valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))

Dim vals As New Autodesk.Revit.DB.Analysis.FieldValues(valList)

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Analysis..::.SpatialFieldManager

See Also

SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Members

[image] [image]

Revit 2011 API
SpatialFieldManager Members
SpatialFieldManager Class Methods Properties See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

Name | Description
AddSpatialFieldPrimitive | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Clear | Clear all analysis results managed by this manager object
CreateSpatialFieldManager | Factory method - creates manager object for the given view
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegend | Returns legend element or NULL
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpatialFieldPrimitive | Removes analysis results container (primitive) identified by the unique index
SetMeasurementNames | sets Names for all measurements
SetUnits | Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurrentMeasurement | Stores the currently displayed measurement
CurrentUnits | Stores the index in the array of applicable units
Description | description of the data
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfMeasurements | Stores the total number of measurements
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UseRangeForAllResults | Governs how minimum and maximum values (the data range) are calculated.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Methods

[image] [image]

Revit 2011 API
SpatialFieldManager Methods
SpatialFieldManager Class See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

Name | Description
AddSpatialFieldPrimitive | Overloaded.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Clear | Clear all analysis results managed by this manager object
CreateSpatialFieldManager | Factory method - creates manager object for the given view
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLegend | Returns legend element or NULL
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpatialFieldPrimitive | Removes analysis results container (primitive) identified by the unique index
SetMeasurementNames | sets Names for all measurements
SetUnits | Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method

[image] [image]

Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback

Overload List

Name | Description
AddSpatialFieldPrimitive()()() | Creates empty analysis results container (primitive) not associated with any geometry element
AddSpatialFieldPrimitive(Reference) | Creates empty analysis results container (primitive) associated with reference
AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results container (primitive) associated with a curve and a transform.
AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results container (primitive) associated with a face and a transform.

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method

[image]

Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) not associated with any geometry element

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive()
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive As Integer
Visual C++
public:
int AddSpatialFieldPrimitive()

Return Value

Unique index of primitive for future references

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Reference)

[image]

Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Reference)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with reference

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Reference reference
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    reference As Reference _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
Reference pointing to the curve or face to be associated with the primitive

Return Value

Unique index of primitive for future references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | reference points to neither face nor curve
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Curve, Transform)

[image]

Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Curve, Transform)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with a curve and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Curve curve,
    Transform trf
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    curve As Curve, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Curve^ curve,
    Transform^ trf
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
Curve to be associated with the primitive. %curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference; otherwise the other overload of the method must be used (taking "reference" as the input)
trf
Type: Autodesk.Revit.DB..::.Transform
Conformal Transform to be applied to %curve%.

Return Value

Unique index of primitive for future references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | trf is not conformal
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Face, Transform)

[image]

Revit 2011 API
SpatialFieldManager..::.AddSpatialFieldPrimitive Method (Face, Transform)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results container (primitive) associated with a face and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Face face,
    Transform trf
)
Visual Basic (Declaration)
Public Function AddSpatialFieldPrimitive ( _
    face As Face, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Face^ face,
    Transform^ trf
)

Parameters

face
Type: Autodesk.Revit.DB..::.Face
Face to be associated with the primitive
trf
Type: Autodesk.Revit.DB..::.Transform
Conformal Transform to be applied to %face%

Return Value

Unique index of primitive for future references

Remarks

This method accepts a reference to a model face, and a transform to be applied to that face, allowing the display of analytical results on faces which are not strictly a part of the Revit model.

This method should not be used if the transform is the identity transform, i.e. the intent is to display results on a face which is part of the Revit model. In that case, use the overload of this method which accepts a reference.

If the input face is from the geometry of a symbol, the face will be considered to be in the location specified by it's symbol geometry. If your intention is to transform the face relative to its location in the instance, your input transform must consist of the instance's transform left multiplied by the extra transform to get the results you expect.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | trf is not conformal
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


Clear Method

[image]

Revit 2011 API
SpatialFieldManager..::.Clear Method
SpatialFieldManager Class See Also Send Feedback
Clear all analysis results managed by this manager object

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


CreateSpatialFieldManager Method

[image]

Revit 2011 API
SpatialFieldManager..::.CreateSpatialFieldManager Method
SpatialFieldManager Class See Also Send Feedback
Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager CreateSpatialFieldManager(
    View view,
    int numberOfMeasurements
)
Visual Basic (Declaration)
Public Shared Function CreateSpatialFieldManager ( _
    view As View, _
    numberOfMeasurements As Integer _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ CreateSpatialFieldManager(
    View^ view,
    int numberOfMeasurements
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
View for which manager object is created or retrieved
numberOfMeasurements
Type: System..::.Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

Manager object for the view passed in the argument

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | numberOfMeasurements is less than one
Autodesk.Revit.Exceptions..::.InvalidOperationException | view is not allowed to display analysis results or a manager object for this view already exists
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetLegend Method

[image]

Revit 2011 API
SpatialFieldManager..::.GetLegend Method
SpatialFieldManager Class See Also Send Feedback
Returns legend element or NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegend GetLegend()
Visual Basic (Declaration)
Public Function GetLegend As AnalysisDisplayLegend
Visual C++
public:
AnalysisDisplayLegend^ GetLegend()

Return Value

The legend element or NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetSpatialFieldManager Method

[image]

Revit 2011 API
SpatialFieldManager..::.GetSpatialFieldManager Method
SpatialFieldManager Class See Also Send Feedback
Retrieves manager object for the given view or returns NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager GetSpatialFieldManager(
    View view
)
Visual Basic (Declaration)
Public Shared Function GetSpatialFieldManager ( _
    view As View _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ GetSpatialFieldManager(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
View for which manager object is retrieved

Return Value

Manager object for the view passed in the argument

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


RemoveSpatialFieldPrimitive Method

[image]

Revit 2011 API
SpatialFieldManager..::.RemoveSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Removes analysis results container (primitive) identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void RemoveSpatialFieldPrimitive(
    int idx
)
Visual Basic (Declaration)
Public Sub RemoveSpatialFieldPrimitive ( _
    idx As Integer _
)
Visual C++
public:
void RemoveSpatialFieldPrimitive(
    int idx
)

Parameters

idx
Type: System..::.Int32
Unique index identifying the primitive

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | idx refers to non-existent primitive

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetMeasurementNames Method

[image]

Revit 2011 API
SpatialFieldManager..::.SetMeasurementNames Method
SpatialFieldManager Class See Also Send Feedback
sets Names for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetMeasurementNames(
    IList<string> measurementNames
)
Visual Basic (Declaration)
Public Sub SetMeasurementNames ( _
    measurementNames As IList(Of String) _
)
Visual C++
public:
void SetMeasurementNames(
    IList<String^>^ measurementNames
)

Parameters

measurementNames
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
Array of measurement names. All names in the array must be unique. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | measurementNames contains duplicate names or its lengths is not equal to the number of measurements set during creation of SpatialFieldManager
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetUnits Method

[image]

Revit 2011 API
SpatialFieldManager..::.SetUnits Method
SpatialFieldManager Class See Also Send Feedback
Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Visual Basic (Declaration)
Public Sub SetUnits ( _
    names As IList(Of String), _
    multipliers As IList(Of Double) _
)
Visual C++
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)

Parameters

names
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
Unit names for all units (e.g., "Lb" and "Kg")
multipliers
Type: System.Collections.Generic..::.IList <(Of <( Double >)>)
Numerical coefficients mapped to unit names; they are used to adjust measurement values for display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | names contains duplicate or empty names, or its lengths is zero -or- multipliers contains non-positive numbers, or its lengths is not equal to the length of names
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


UpdateSpatialFieldPrimitive Method

[image]

Revit 2011 API
SpatialFieldManager..::.UpdateSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Populates analysis results data (or replaces the existing data) in the existing container (primitive) identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues
)
Visual Basic (Declaration)
Public Sub UpdateSpatialFieldPrimitive ( _
    idx As Integer, _
    fieldDomainPoints As FieldDomainPoints, _
    fieldValues As FieldValues _
)
Visual C++
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues
)

Parameters

idx
Type: System..::.Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis..::.FieldDomainPoints
Set of domain points. If %fieldDomainPoints% is NULL only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis..::.FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints and fieldValues have inconsistent number of points
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Properties

[image] [image]

Revit 2011 API
SpatialFieldManager Properties
SpatialFieldManager Class See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CurrentMeasurement | Stores the currently displayed measurement
CurrentUnits | Stores the index in the array of applicable units
Description | description of the data
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfMeasurements | Stores the total number of measurements
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UseRangeForAllResults | Governs how minimum and maximum values (the data range) are calculated.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


CurrentMeasurement Property

[image]

Revit 2011 API
SpatialFieldManager..::.CurrentMeasurement Property
SpatialFieldManager Class See Also Send Feedback
Stores the currently displayed measurement

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int CurrentMeasurement { get; set; }
Visual Basic (Declaration)
Public Property CurrentMeasurement As Integer
Visual C++
public:
property int CurrentMeasurement {
    int get ();
    void set (int value);
}

Remarks

Must be in the range from 0 to (numberOfMeasurements - 1)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: measurement is not in the range from 0 to (number of measurements - 1)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


CurrentUnits Property

[image]

Revit 2011 API
SpatialFieldManager..::.CurrentUnits Property
SpatialFieldManager Class See Also Send Feedback
Stores the index in the array of applicable units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int CurrentUnits { get; set; }
Visual Basic (Declaration)
Public Property CurrentUnits As Integer
Visual C++
public:
property int CurrentUnits {
    int get ();
    void set (int value);
}

Remarks

Must be in the range from 0 to (number of applicable units - 1)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: currentUnits is not in the range from 0 to (number of applicable units - 1)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


Description Property

[image]

Revit 2011 API
SpatialFieldManager..::.Description Property
SpatialFieldManager Class See Also Send Feedback
description of the data

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


NumberOfMeasurements Property

[image]

Revit 2011 API
SpatialFieldManager..::.NumberOfMeasurements Property
SpatialFieldManager Class See Also Send Feedback
Stores the total number of measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int NumberOfMeasurements { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfMeasurements As Integer
Visual C++
public:
property int NumberOfMeasurements {
    int get ();
}

Remarks

This number defines the length of value arrays in ValueAtPoint objects

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2011 API
SpatialFieldManager..::.Parameter Property
SpatialFieldManager Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


UseRangeForAllResults Property

[image]

Revit 2011 API
SpatialFieldManager..::.UseRangeForAllResults Property
SpatialFieldManager Class See Also Send Feedback
Governs how minimum and maximum values (the data range) are calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UseRangeForAllResults { get; set; }
Visual Basic (Declaration)
Public Property UseRangeForAllResults As Boolean
Visual C++
public:
property bool UseRangeForAllResults {
    bool get ();
    void set (bool value);
}

Remarks

If true the data range is calculated from all results. Otherwise the data range is calculated from the current measurement only.

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Class

[image]

Revit 2011 API
ValueAtPoint Class
Members See Also Send Feedback
Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ValueAtPoint : IDisposable
Visual Basic (Declaration)
Public Class ValueAtPoint _
    Implements IDisposable
Visual C++
public ref class ValueAtPoint : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Analysis..::.ValueAtPoint

See Also

ValueAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Members

[image] [image]

Revit 2011 API
ValueAtPoint Members
ValueAtPoint Class Constructors Methods See Also Send Feedback

The ValueAtPoint type exposes the following members.

Constructors

Name | Description
ValueAtPoint | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor

[image] [image]

Revit 2011 API
ValueAtPoint Constructor
ValueAtPoint Class See Also Send Feedback

Overload List

Name | Description
ValueAtPoint(ValueAtPoint) | Initializes a new instance of the ValueAtPoint class
ValueAtPoint(IList<(Of <(Double>)>)) | Creates object from an array of values

See Also

ValueAtPoint Class
ValueAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor (ValueAtPoint)

[image]

Revit 2011 API
ValueAtPoint Constructor (ValueAtPoint)
ValueAtPoint Class See Also Send Feedback
Initializes a new instance of the ValueAtPoint class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ValueAtPoint(
    ValueAtPoint otherObject
)
Visual Basic (Declaration)
Public Sub New ( _
    otherObject As ValueAtPoint _
)
Visual C++
public:
ValueAtPoint(
    ValueAtPoint^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::.ValueAtPoint

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor (IList(Double))

[image]

Revit 2011 API
ValueAtPoint Constructor (IList<(Of <(Double>)>))
ValueAtPoint Class See Also Send Feedback
Creates object from an array of values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ValueAtPoint(
    IList<double> values
)
Visual Basic (Declaration)
Public Sub New ( _
    values As IList(Of Double) _
)
Visual C++
public:
ValueAtPoint(
    IList<double>^ values
)

Parameters

values
Type: System.Collections.Generic..::.IList <(Of <( Double >)>)
Array of values, each corresponding to "measurement"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Methods

[image] [image]

Revit 2011 API
ValueAtPoint Methods
ValueAtPoint Class See Also Send Feedback

The ValueAtPoint type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2011 API
ValueAtPoint..::.Dispose Method
ValueAtPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


Autodesk.Revit.DB.Architecture Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Architecture Namespace
Send Feedback

Classes

Class | Description
BoundarySegment | An object that represents a segment of a room boundary.
BoundarySegmentArray | An array that contains boundary segments.
BoundarySegmentArrayArray | An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator | An iterator to a boundary segment array.
Fascia | An object that represents a fascia within the Autodesk Revit project.
FasciaType | An object that represents the fascia type in Autodesk Revit.
FasciaTypeSet | A set that contains fascia types.
FasciaTypeSetIterator | An iterator to a fascia type set.
Gutter | An object that represents a gutter within the Autodesk Revit project.
GutterType | An object that represents the gutter type in Autodesk Revit.
GutterTypeSet | A set that contains gutter types.
GutterTypeSetIterator | An iterator to a gutter type set.
Room | Provides access to the room topology in Autodesk Revit.
RoomFilter | A filter used to match rooms.
RoomTag | Provides access to the room tag in Autodesk Revit.
RoomTagFilter | A filter used to match room tags.
RoomTagType | An object that represents a Room Tag type.
RoomTagTypeSet | A set that contains room tag types.
RoomTagTypeSetIterator | An iterator to a room tag type set.

Enumerations

Enumeration | Description
BoundaryLocationType | An enumerated type listing the options for volume computation in Autodesk Revit.


BoundaryLocationType Enumeration

[image]

Revit 2011 API
BoundaryLocationType Enumeration
See Also Send Feedback
An enumerated type listing the options for volume computation in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BoundaryLocationType
Visual Basic (Declaration)
Public Enumeration BoundaryLocationType
Visual C++
public enum class BoundaryLocationType

Members

Member name | Description
WallFinish | Room area is computed at wall finish.
WallCenter | Room area is computed at wall center.
WallCoreLayer | Room area is computed at wall core layer.
WallCoreCenter | Room area is computed at wall core center.

See Also

Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Class

[image]

Revit 2011 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
    if (room.Boundary != null)
    {
        string message = "BoundarySegment";
        foreach (Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray in room.Boundary)
        {
           foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                message += "\nCurve start point:(" + boundarySegment.Curve.get_EndPoint(0).X + ","
                               + boundarySegment.Curve.get_EndPoint(0).Y + "," +
                              boundarySegment.Curve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.get_EndPoint(1).X + ","
                     + boundarySegment.Curve.get_EndPoint(1).Y + "," +
                     boundarySegment.Curve.get_EndPoint(1).Z + ")";
                // Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName;
                // Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name;
            }
        }
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(ByVal room As Room)
    If room.Boundary IsNot Nothing Then
        Dim message As String = "BoundarySegment"
        For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
            For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                ' Get curve start point
                message += vbLf & "Curve start point:(" + boundarySegment.Curve.EndPoint(0).X + "," + boundarySegment.Curve.EndPoint(0).Y + "," + boundarySegment.Curve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.EndPoint(1).X + "," + boundarySegment.Curve.EndPoint(1).Y + "," + boundarySegment.Curve.EndPoint(1).Z + ")"
                ' Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName
                ' Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name
            Next
        Next
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Members

[image] [image]

Revit 2011 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this room.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Methods

[image] [image]

Revit 2011 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Properties

[image] [image]

Revit 2011 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this room.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Curve Property

[image]

Revit 2011 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Document Property

[image]

Revit 2011 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Element Property

[image]

Revit 2011 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific room.

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Class

[image]

Revit 2011 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Constructor

[image]

Revit 2011 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Append Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Item Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2011 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment array into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Append Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::.Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Item Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Fascia Class

[image]

Revit 2011 API
Fascia Class
Members See Also Send Feedback
An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Fascia : HostedSweep
Visual Basic (Declaration)
Public Class Fascia _
    Inherits HostedSweep
Visual C++
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB.Architecture..::.Fascia

See Also

Fascia Members
Autodesk.Revit.DB.Architecture Namespace


Fascia Members

[image] [image]

Revit 2011 API
Fascia Members
Fascia Class Methods Properties See Also Send Feedback

The Fascia type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the fascia. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FasciaType | Retrieves/set an object that represents the type of the Fascia.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Fascia Methods

[image] [image]

Revit 2011 API
Fascia Methods
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the fascia. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


AddSegment Method

[image]

Revit 2011 API
Fascia..::.AddSegment Method
Fascia Class See Also Send Feedback
Add segments to the fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is nullNothingnullptra null reference (Nothing in Visual Basic). 2. Input targetRef is not nullNothingnullptra null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the fascia. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Other fascia's horizontal edges

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Fascia Properties

[image] [image]

Revit 2011 API
Fascia Properties
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FasciaType | Retrieves/set an object that represents the type of the Fascia.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Property

[image]

Revit 2011 API
Fascia..::.FasciaType Property
Fascia Class See Also Send Feedback
Retrieves/set an object that represents the type of the Fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FasciaType FasciaType { get; set; }
Visual Basic (Declaration)
Public Property FasciaType As FasciaType
Visual C++
public:
property FasciaType^ FasciaType {
    FasciaType^ get ();
    void set (FasciaType^ value);
}

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
Fascia..::.Parameter Property
Fascia Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Fascia Class
Fascia Members
Autodesk.Revit.DB.Architecture Namespace


FasciaType Class

[image]

Revit 2011 API
FasciaType Class
Members See Also Send Feedback
An object that represents the fascia type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FasciaType : HostedSweepType
Visual Basic (Declaration)
Public Class FasciaType _
    Inherits HostedSweepType
Visual C++
public ref class FasciaType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB.Architecture..::.FasciaType

See Also

FasciaType Members
Autodesk.Revit.DB.Architecture Namespace


FasciaType Members

[image] [image]

Revit 2011 API
FasciaType Members
FasciaType Class Methods Properties See Also Send Feedback

The FasciaType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Methods

[image] [image]

Revit 2011 API
FasciaType Methods
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Properties

[image] [image]

Revit 2011 API
FasciaType Properties
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
FasciaType..::.Parameter Property
FasciaType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FasciaType Class
FasciaType Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Class

[image]

Revit 2011 API
FasciaTypeSet Class
Members See Also Send Feedback
A set that contains fascia types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FasciaTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class FasciaTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FasciaTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.FasciaTypeSet

See Also

FasciaTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Members

[image] [image]

Revit 2011 API
FasciaTypeSet Members
FasciaTypeSet Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Constructors

Name | Description
FasciaTypeSet | Initializes a new instance of the FasciaTypeSet class

Methods

Name | Description
Clear | Removes every fascia type from the set, rendering it empty.
Contains | Tests for the existence of a fascia type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fascia type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fascia type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Constructor

[image]

Revit 2011 API
FasciaTypeSet Constructor
FasciaTypeSet Class See Also Send Feedback
Initializes a new instance of the FasciaTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FasciaTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSet()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Methods

[image] [image]

Revit 2011 API
FasciaTypeSet Methods
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every fascia type from the set, rendering it empty.
Contains | Tests for the existence of a fascia type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified fascia type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified fascia type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2011 API
FasciaTypeSet..::.Clear Method
FasciaTypeSet Class See Also Send Feedback
Removes every fascia type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2011 API
FasciaTypeSet..::.Contains Method
FasciaTypeSet Class See Also Send Feedback
Tests for the existence of a fascia type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The fascia type to be searched for.

Return Value

The Contains method returns True if the fascia type is within the set, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2011 API
FasciaTypeSet..::.Erase Method
FasciaTypeSet Class See Also Send Feedback
Removes a specified fascia type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As FasciaType _
) As Integer
Visual C++
public:
virtual int Erase(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The fascia type to be erased.

Return Value

The number of fascia types that were erased from the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2011 API
FasciaTypeSet..::.ForwardIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2011 API
FasciaTypeSet..::.GetEnumerator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2011 API
FasciaTypeSet..::.Insert Method
FasciaTypeSet Class See Also Send Feedback
Insert the specified fascia type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    FasciaType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.FasciaType
The fascia type to be inserted into the set.

Return Value

Returns whether the fascia type was inserted into the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2011 API
FasciaTypeSet..::.ReverseIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Properties

[image] [image]

Revit 2011 API
FasciaTypeSet Properties
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2011 API
FasciaTypeSet..::.IsEmpty Property
FasciaTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2011 API
FasciaTypeSet..::.Size Property
FasciaTypeSet Class See Also Send Feedback
Returns the number of fascia types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Class

[image]

Revit 2011 API
FasciaTypeSetIterator Class
Members See Also Send Feedback
An iterator to a fascia type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class FasciaTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class FasciaTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FasciaTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.FasciaTypeSetIterator

See Also

FasciaTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Members

[image] [image]

Revit 2011 API
FasciaTypeSetIterator Members
FasciaTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Constructors

Name | Description
FasciaTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Constructor

[image]

Revit 2011 API
FasciaTypeSetIterator Constructor
FasciaTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FasciaTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FasciaTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Methods

[image] [image]

Revit 2011 API
FasciaTypeSetIterator Methods
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2011 API
FasciaTypeSetIterator..::.MoveNext Method
FasciaTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2011 API
FasciaTypeSetIterator..::.Reset Method
FasciaTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Properties

[image] [image]

Revit 2011 API
FasciaTypeSetIterator Properties
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2011 API
FasciaTypeSetIterator..::.Current Property
FasciaTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Class

[image]

Revit 2011 API
Gutter Class
Members See Also Send Feedback
An object that represents a gutter within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Gutter : HostedSweep
Visual Basic (Declaration)
Public Class Gutter _
    Inherits HostedSweep
Visual C++
public ref class Gutter : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.HostedSweep
Autodesk.Revit.DB.Architecture..::.Gutter

See Also

Gutter Members
Autodesk.Revit.DB.Architecture Namespace


Gutter Members

[image] [image]

Revit 2011 API
Gutter Members
Gutter Class Methods Properties See Also Send Feedback

The Gutter type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the gutter. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
GutterType | Retrieves/set an object that represents the type of the Gutter.
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Methods

[image] [image]

Revit 2011 API
Gutter Methods
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Methods

Name | Description
AddSegment | Add segments to the gutter. (Overrides HostedSweep..::.AddSegment(Reference).)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


AddSegment Method

[image]

Revit 2011 API
Gutter..::.AddSegment Method
Gutter Class See Also Send Feedback
Add segments to the gutter.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic (Declaration)
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::.Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
Autodesk.Revit.Exceptions..::.InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Properties

[image] [image]

Revit 2011 API
Gutter Properties
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Properties

Name | Description
Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
GutterType | Retrieves/set an object that represents the type of the Gutter.
HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Property

[image]

Revit 2011 API
Gutter..::.GutterType Property
Gutter Class See Also Send Feedback
Retrieves/set an object that represents the type of the Gutter.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GutterType GutterType { get; set; }
Visual Basic (Declaration)
Public Property GutterType As GutterType
Visual C++
public:
property GutterType^ GutterType {
    GutterType^ get ();
    void set (GutterType^ value);
}

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
Gutter..::.Parameter Property
Gutter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Gutter Class
Gutter Members
Autodesk.Revit.DB.Architecture Namespace


GutterType Class

[image]

Revit 2011 API
GutterType Class
Members See Also Send Feedback
An object that represents the gutter type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GutterType : HostedSweepType
Visual Basic (Declaration)
Public Class GutterType _
    Inherits HostedSweepType
Visual C++
public ref class GutterType : public HostedSweepType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.HostObjAttributes
Autodesk.Revit.DB..::.HostedSweepType
Autodesk.Revit.DB.Architecture..::.GutterType

See Also

GutterType Members
Autodesk.Revit.DB.Architecture Namespace


GutterType Members

[image] [image]

Revit 2011 API
GutterType Members
GutterType Class Methods Properties See Also Send Feedback

The GutterType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Methods

[image] [image]

Revit 2011 API
GutterType Methods
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Properties

[image] [image]

Revit 2011 API
GutterType Properties
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
GutterType..::.Parameter Property
GutterType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

GutterType Class
GutterType Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Class

[image]

Revit 2011 API
GutterTypeSet Class
Members See Also Send Feedback
A set that contains gutter types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GutterTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GutterTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GutterTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.GutterTypeSet

See Also

GutterTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Members

[image] [image]

Revit 2011 API
GutterTypeSet Members
GutterTypeSet Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSet type exposes the following members.

Constructors

Name | Description
GutterTypeSet | Initializes a new instance of the GutterTypeSet class

Methods

Name | Description
Clear | Removes every gutter type from the set, rendering it empty.
Contains | Tests for the existence of a gutter type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified gutter type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified gutter type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Constructor

[image]

Revit 2011 API
GutterTypeSet Constructor
GutterTypeSet Class See Also Send Feedback
Initializes a new instance of the GutterTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GutterTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSet()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Methods

[image] [image]

Revit 2011 API
GutterTypeSet Methods
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every gutter type from the set, rendering it empty.
Contains | Tests for the existence of a gutter type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified gutter type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified gutter type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2011 API
GutterTypeSet..::.Clear Method
GutterTypeSet Class See Also Send Feedback
Removes every gutter type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2011 API
GutterTypeSet..::.Contains Method
GutterTypeSet Class See Also Send Feedback
Tests for the existence of a gutter type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The gutter type to be searched for.

Return Value

The Contains method returns True if the gutter type is within the set, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2011 API
GutterTypeSet..::.Erase Method
GutterTypeSet Class See Also Send Feedback
Removes a specified gutter type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GutterType _
) As Integer
Visual C++
public:
virtual int Erase(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The gutter type to be erased.

Return Value

The number of gutter types that were erased from the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2011 API
GutterTypeSet..::.ForwardIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2011 API
GutterTypeSet..::.GetEnumerator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2011 API
GutterTypeSet..::.Insert Method
GutterTypeSet Class See Also Send Feedback
Insert the specified gutter type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    GutterType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.GutterType
The gutter type to be inserted into the set.

Return Value

Returns whether the gutter type was inserted into the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2011 API
GutterTypeSet..::.ReverseIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Properties

[image] [image]

Revit 2011 API
GutterTypeSet Properties
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2011 API
GutterTypeSet..::.IsEmpty Property
GutterTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2011 API
GutterTypeSet..::.Size Property
GutterTypeSet Class See Also Send Feedback
Returns the number of gutter types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Class

[image]

Revit 2011 API
GutterTypeSetIterator Class
Members See Also Send Feedback
An iterator to a gutter type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GutterTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GutterTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GutterTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.GutterTypeSetIterator

See Also

GutterTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Members

[image] [image]

Revit 2011 API
GutterTypeSetIterator Members
GutterTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Constructors

Name | Description
GutterTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Constructor

[image]

Revit 2011 API
GutterTypeSetIterator Constructor
GutterTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GutterTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GutterTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Methods

[image] [image]

Revit 2011 API
GutterTypeSetIterator Methods
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2011 API
GutterTypeSetIterator..::.MoveNext Method
GutterTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2011 API
GutterTypeSetIterator..::.Reset Method
GutterTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Properties

[image] [image]

Revit 2011 API
GutterTypeSetIterator Properties
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2011 API
GutterTypeSetIterator..::.Current Property
GutterTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Room Class

[image]

Revit 2011 API
Room Class
Members Example See Also Send Feedback
Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Room : Enclosure
Visual Basic (Declaration)
Public Class Room _
    Inherits Enclosure
Visual C++
public ref class Room : public Enclosure

Remarks

The room object can be queried for its boundary for use in space planning tools.

Examples

CopyC#
private void Getinfo_Room(Room room)
{
    string message = "Room: ";

    //get the name of the room
    message += "\nRoom Name: " + room.Name;

    //get the room position
    LocationPoint location = room.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoom position: " + XYZToString(point);

    //get the room number
    message += "\nRoom number: " + room.Number;

    //get the boundary segment of the room
    if (null != room.Boundary)  //the room may not be bound
    {
        if (0 != room.Boundary.Size)
        {
            message += "\nBoundarySegment of the room: ";
            foreach (Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray in room.Boundary)
            {
               foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
                {
                    // Get curve start point
                    XYZ start = boundarySegment.Curve.get_EndPoint(0);
                    message += "\nCurve start point: " + XYZToString(start);
                    // Get curve end point
                    XYZ end = boundarySegment.Curve.get_EndPoint(1);
                    message += " Curve end point: " + XYZToString(end);

                    // Show the boundary elements
                    message += "\nBoundary element id: " + boundarySegment.Element.Id.IntegerValue;
                }
            }
        }
    }

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Room(ByVal room As Room)
    Dim message As String = "Room: "

    'get the name of the room
    message += vbLf & "Room Name: " + room.Name

    'get the room position
    Dim location As LocationPoint = TryCast(room.Location, LocationPoint)
    Dim point As Autodesk.Revit.DB.XYZ = location.Point
    message += vbLf & "Room position: " + XYZToString(point)

    'get the room number
    message += vbLf & "Room number: " + room.Number

    'get the boundary segment of the room
    If room.Boundary IsNot Nothing Then
        'the room may not be bound
        If 0 <> room.Boundary.Size Then
            message += vbLf & "BoundarySegment of the room: "
            For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
                For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                    ' Get curve start point
                    Dim start As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(0)
                    message += vbLf & "Curve start point: " + XYZToString(start)
                    ' Get curve end point
                    Dim [end] As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(1)
                    message += " Curve end point: " + XYZToString([end])

                    ' Show the boundary elements
                    message += vbLf & "Boundary element id: " + boundarySegment.Element.Id.IntegerValue
                Next
            Next
        End If
    End If

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB.Architecture..::.Room

See Also

Room Members
Autodesk.Revit.DB.Architecture Namespace


Room Members

[image] [image]

Revit 2011 API
Room Members
Room Class Methods Properties See Also Send Feedback

The Room type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsPointInRoom | Determines if a point lies within the volume of the room.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Properties

Name | Description
Area | The area. (Inherited from Enclosure.)
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClosedShell | Return the closedShell of the Room.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LimitOffset | Get or Set the Limit Offset of the Room.
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UnboundedHeight | Get the Unbounded Height of the Room.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Room.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Room Methods

[image] [image]

Revit 2011 API
Room Methods
Room Class See Also Send Feedback

The Room type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsPointInRoom | Determines if a point lies within the volume of the room.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


IsPointInRoom Method

[image]

Revit 2011 API
Room..::.IsPointInRoom Method
Room Class See Also Send Feedback
Determines if a point lies within the volume of the room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPointInRoom(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInRoom ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInRoom(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | The coordinates of the point is not a number.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Unplace Method

[image]

Revit 2011 API
Room..::.Unplace Method
Room Class See Also Send Feedback
Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Unplace()
Visual Basic (Declaration)
Public Sub Unplace
Visual C++
public:
void Unplace()

Remarks

Note that current room is changed to unplaced and all corresponding rooms which in other group instance are deleted when in group edit mode.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Room Properties

[image] [image]

Revit 2011 API
Room Properties
Room Class See Also Send Feedback

The Room type exposes the following members.

Properties

Name | Description
Area | The area. (Inherited from Enclosure.)
BaseOffset | Get or Set the Base Offset of the Room.
Boundary | Returns the boundary of the room.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ClosedShell | Return the closedShell of the Room.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LimitOffset | Get or Set the Limit Offset of the Room.
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UnboundedHeight | Get the Unbounded Height of the Room.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Room.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


BaseOffset Property

[image]

Revit 2011 API
Room..::.BaseOffset Property
Room Class See Also Send Feedback
Get or Set the Base Offset of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Boundary Property

[image]

Revit 2011 API
Room..::.Boundary Property
Room Class See Also Send Feedback
Returns the boundary of the room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the room. Each room may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Room.BoundarySegment object for more details about the segments that make up the room topology.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


ClosedShell Property

[image]

Revit 2011 API
Room..::.ClosedShell Property
Room Class See Also Send Feedback
Return the closedShell of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement ClosedShell { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As GeometryElement
Visual C++
public:
property GeometryElement^ ClosedShell {
    GeometryElement^ get ();
}

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


LimitOffset Property

[image]

Revit 2011 API
Room..::.LimitOffset Property
Room Class See Also Send Feedback
Get or Set the Limit Offset of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
Room..::.Parameter Property
Room Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Room Class
Room Members
Autodesk.Revit.DB.Architecture Namespace


UnboundedHeight Property

[image]

Revit 2011 API
Room..::.UnboundedHeight Property
Room Class See Also Send Feedback
Get the Unbounded Height of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


UpperLimit Property

[image]

Revit 2011 API
Room..::.UpperLimit Property
Room Class See Also Send Feedback
Get or Set the Upper Limit of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Volume Property

[image]

Revit 2011 API
Room..::.Volume Property
Room Class See Also Send Feedback
Get the Volume of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Class

[image]

Revit 2011 API
RoomFilter Class
Members Example See Also Send Feedback
A filter used to match rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class RoomFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class RoomFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
// supported by those methods.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
' supported by those methods.
Dim filter As New Autodesk.Revit.DB.Architecture.RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim rooms As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Architecture..::.RoomFilter

See Also

RoomFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Members

[image] [image]

Revit 2011 API
RoomFilter Members
RoomFilter Class Constructors Methods Properties See Also Send Feedback

The RoomFilter type exposes the following members.

Constructors

Name | Description
RoomFilter | Constructs a filter which matches only rooms.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Constructor

[image]

Revit 2011 API
RoomFilter Constructor
RoomFilter Class See Also Send Feedback
Constructs a filter which matches only rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomFilter()

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Methods

[image] [image]

Revit 2011 API
RoomFilter Methods
RoomFilter Class See Also Send Feedback

The RoomFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Properties

[image] [image]

Revit 2011 API
RoomFilter Properties
RoomFilter Class See Also Send Feedback

The RoomFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Class

[image]

Revit 2011 API
RoomTag Class
Members Example See Also Send Feedback
Provides access to the room tag in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomTag : EnclosureTag
Visual Basic (Declaration)
Public Class RoomTag _
    Inherits EnclosureTag
Visual C++
public ref class RoomTag : public EnclosureTag

Examples

CopyC#
private void Getinfo_RoomTag(RoomTag roomTag)
{
    string message = "Room Tag : ";
    //get the location of the roomtag
    LocationPoint location = roomTag.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoomTag location: (" + point.X + ", " +
                   point.Y + ", " + point.Z + ")";

    //get the name of the roomTag
    message += "\nName: " + roomTag.Name;

    //get the room that the tag is associated with
    Room room = roomTag.Room;
    message += "\nThe number of the room is : " + room.Number;

    //get the view in which the tag is placed
    Autodesk.Revit.DB.View view = roomTag.View;
    if (null != view)
    {
        message += "\nView Name: " + view.Name;
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_RoomTag(ByVal roomTag As Autodesk.Revit.DB.Architecture.RoomTag)
    Dim message As String = "Room Tag : "
    'get the location of the roomtag
    Dim location As LocationPoint = TryCast(roomTag.Location, LocationPoint)
    Dim point As Autodesk.Revit.DB.XYZ = location.Point
    message += vbLf & "RoomTag location: (" + point.X + ", " + point.Y + ", " + point.Z + ")"

    'get the name of the roomTag
    message += vbLf & "Name: " + roomTag.Name

    'get the room that the tag is associated with
    Dim room As Room = roomTag.Room
    message += vbLf & "The number of the room is : " + room.Number

    'get the view in which the tag is placed
    Dim view As Autodesk.Revit.DB.View = roomTag.View
    If view IsNot Nothing Then
        message += vbLf & "View Name: " + view.Name
    End If
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB.Architecture..::.RoomTag

See Also

RoomTag Members
Autodesk.Revit.DB.Architecture Namespace


RoomTag Members

[image] [image]

Revit 2011 API
RoomTag Members
RoomTag Class Methods Properties See Also Send Feedback

The RoomTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | The room that the tag is associated with.
RoomTagType | The tag type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Methods

[image] [image]

Revit 2011 API
RoomTag Methods
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Properties

[image] [image]

Revit 2011 API
RoomTag Properties
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Room | The room that the tag is associated with.
RoomTagType | The tag type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
RoomTag..::.Parameter Property
RoomTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoomTag Class
RoomTag Members
Autodesk.Revit.DB.Architecture Namespace


Room Property

[image]

Revit 2011 API
RoomTag..::.Room Property
RoomTag Class See Also Send Feedback
The room that the tag is associated with.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

In rare cases, the tag may not be associated to a room. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Property

[image]

Revit 2011 API
RoomTag..::.RoomTagType Property
RoomTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTagType RoomTagType { get; set; }
Visual Basic (Declaration)
Public Property RoomTagType As RoomTagType
Visual C++
public:
property RoomTagType^ RoomTagType {
    RoomTagType^ get ();
    void set (RoomTagType^ value);
}

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Class

[image]

Revit 2011 API
RoomTagFilter Class
Members See Also Send Feedback
A filter used to match room tags.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomTagFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class RoomTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class RoomTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Architecture..::.RoomTagFilter

See Also

RoomTagFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Members

[image] [image]

Revit 2011 API
RoomTagFilter Members
RoomTagFilter Class Constructors Methods Properties See Also Send Feedback

The RoomTagFilter type exposes the following members.

Constructors

Name | Description
RoomTagFilter | Constructs a filter which matches only rooms.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Constructor

[image]

Revit 2011 API
RoomTagFilter Constructor
RoomTagFilter Class See Also Send Feedback
Constructs a filter which matches only rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTagFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagFilter()

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Methods

[image] [image]

Revit 2011 API
RoomTagFilter Methods
RoomTagFilter Class See Also Send Feedback

The RoomTagFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Properties

[image] [image]

Revit 2011 API
RoomTagFilter Properties
RoomTagFilter Class See Also Send Feedback

The RoomTagFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Class

[image]

Revit 2011 API
RoomTagType Class
Members See Also Send Feedback
An object that represents a Room Tag type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomTagType : FamilySymbol
Visual Basic (Declaration)
Public Class RoomTagType _
    Inherits FamilySymbol
Visual C++
public ref class RoomTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB.Architecture..::.RoomTagType

See Also

RoomTagType Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Members

[image] [image]

Revit 2011 API
RoomTagType Members
RoomTagType Class Methods Properties See Also Send Feedback

The RoomTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Methods

[image] [image]

Revit 2011 API
RoomTagType Methods
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Properties

[image] [image]

Revit 2011 API
RoomTagType Properties
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2011 API
RoomTagType..::.Parameter Property
RoomTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RoomTagType Class
RoomTagType Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Class

[image]

Revit 2011 API
RoomTagTypeSet Class
Members See Also Send Feedback
A set that contains room tag types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RoomTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RoomTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoomTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSet

See Also

RoomTagTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Members

[image] [image]

Revit 2011 API
RoomTagTypeSet Members
RoomTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Constructors

Name | Description
RoomTagTypeSet | Initializes a new instance of the RoomTagTypeSet class

Methods

Name | Description
Clear | Removes every room tag type from the set, rendering it empty.
Contains | Tests for the existence of a room tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified room tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified room tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Constructor

[image]

Revit 2011 API
RoomTagTypeSet Constructor
RoomTagTypeSet Class See Also Send Feedback
Initializes a new instance of the RoomTagTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSet()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Methods

[image] [image]

Revit 2011 API
RoomTagTypeSet Methods
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every room tag type from the set, rendering it empty.
Contains | Tests for the existence of a room tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified room tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified room tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2011 API
RoomTagTypeSet..::.Clear Method
RoomTagTypeSet Class See Also Send Feedback
Removes every room tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2011 API
RoomTagTypeSet..::.Contains Method
RoomTagTypeSet Class See Also Send Feedback
Tests for the existence of a room tag type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.RoomTagType
The room tag type to be searched for.

Return Value

The Contains method returns True if the room tag type is within the set, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2011 API
RoomTagTypeSet..::.Erase Method
RoomTagTypeSet Class See Also Send Feedback
Removes a specified room tag type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RoomTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.RoomTagType
The room tag type to be erased.

Return Value

The number of room tag types that were erased from the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2011 API
RoomTagTypeSet..::.ForwardIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2011 API
RoomTagTypeSet..::.GetEnumerator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2011 API
RoomTagTypeSet..::.Insert Method
RoomTagTypeSet Class See Also Send Feedback
Insert the specified room tag type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RoomTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::.RoomTagType
The room tag type to be inserted into the set.

Return Value

Returns whether the room tag type was inserted into the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2011 API
RoomTagTypeSet..::.ReverseIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Properties

[image] [image]

Revit 2011 API
RoomTagTypeSet Properties
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2011 API
RoomTagTypeSet..::.IsEmpty Property
RoomTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2011 API
RoomTagTypeSet..::.Size Property
RoomTagTypeSet Class See Also Send Feedback
Returns the number of room tag types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Class

[image]

Revit 2011 API
RoomTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a room tag type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RoomTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RoomTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoomTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Architecture..::.RoomTagTypeSetIterator

See Also

RoomTagTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Members

[image] [image]

Revit 2011 API
RoomTagTypeSetIterator Members
RoomTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
RoomTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Constructor

[image]

Revit 2011 API
RoomTagTypeSetIterator Constructor
RoomTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RoomTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoomTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Methods

[image] [image]

Revit 2011 API
RoomTagTypeSetIterator Methods
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2011 API
RoomTagTypeSetIterator..::.MoveNext Method
RoomTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2011 API
RoomTagTypeSetIterator..::.Reset Method
RoomTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Properties

[image] [image]

Revit 2011 API
RoomTagTypeSetIterator Properties
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2011 API
RoomTagTypeSetIterator..::.Current Property
RoomTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Autodesk.Revit.DB.Electrical Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Electrical Namespace
Send Feedback

Classes

Class | Description
CableTray | This class represents a cable tray in Autodesk Revit.
CableTrayConduitBase | The CableTrayConduitBase class is implemented as the base class for cable tray or conduit
CableTrayConduitRunBase | The base class for a cable tray or conduit run in Autodesk Revit.
CableTrayRun | This class represents a cable tray run in Autodesk Revit.
CableTrayType | This class represents a cable tray type in Autodesk Revit.
Conduit | This class represents a conduit in Autodesk Revit.
ConduitRun | This class represents a conduit run in Autodesk Revit.
ConduitType | This class represents a conduit type in Autodesk Revit.
CorrectionFactor | Represents electrical correction factor information.
CorrectionFactorSet | A set that contains correction factors.
CorrectionFactorSetIterator | An iterator to a correction factor set.
DistributionSysType | Represents a specific type of distribution system.
DistributionSysTypeSet | A set that contains DistributionSys types.
DistributionSysTypeSetIterator | An iterator to a DistributionSys type set.
ElectricalConnector | An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.
ElectricalDemandFactorDefinition | The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.
ElectricalDemandFactorValue | This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.
ElectricalEquipment | Provides access to the Electrical Equipment in Autodesk Revit MEP.
ElectricalLoadClassification | The ElectricalLoadClassification class represents a serialized version of an instance of load classification.
ElectricalSetting | An object that represents electrical information within the Autodesk Revit project.
ElectricalSystem | Provides access to the Electrical System in Autodesk Revit MEP.
ElectricalSystemSet | A set that can contain any type of object.
ElectricalSystemSetIterator | An iterator to a set.
GroundConductorSize | Represents electrical ground conductor size definition information.
GroundConductorSizeSet | A set that contains GroundConductorSizes.
GroundConductorSizeSetIterator | An iterator to a GroundConductorSize set.
InsulationType | Represents electrical insulation type definition information.
InsulationTypeSet |
InsulationTypeSetIterator |
LightingDevice | Provides access to the Lighting Device in Autodesk Revit MEP.
LightingFixture | Provides access to the Lighting Fixture in Autodesk Revit MEP.
PanelScheduleData | The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule
PanelScheduleSheetInstance | The class represents an instance of a panel schedule placed on sheet.
PanelScheduleTemplate | The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.
PanelScheduleView | An instance of a panel schedule view.
TemperatureRatingType | Represents temperature rating type definition information.
TemperatureRatingTypeSet |
TemperatureRatingTypeSetIterator |
VoltageType | Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
VoltageTypeSet | A set that contains voltage types.
VoltageTypeSetIterator | An iterator to a voltage type set.
Wire | An object to represent electrical wire in Revit MEP product.
WireConduitType | Represents a specific conduit type of wire type.
WireConduitTypeSet |
WireConduitTypeSetIterator |
WireMaterialType | Represents electrical wire material type definition information of wire type.
WireMaterialTypeSet |
WireMaterialTypeSetIterator |
WireSet | A set that can contain any type of object.
WireSetIterator | An iterator to a set.
WireSize | Represents specific electrical wire size information.
WireSizeSet | A set that contains wire sizes.
WireSizeSetIterator | An iterator to a wire size set.
WireType | Represents a specific wire type.
WireTypeSet |
WireTypeSetIterator |

Enumerations

Enumeration | Description
BaseLoadOn | An enumerated type listing all the possible power load use types for a space object.
CableTrayShape | Shape types enum of cable tray
CircuitType | An enumerated type listing all the possible circuit types.
ElectricalDemandFactorDefinitionData |
ElectricalDemandFactorRule | This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.
ElectricalLoadClassificationData | This enum is used by the ElectricalLoadClassification class as additional data whenever data members changed. It is used as the additional data when the atom corresponding to each data member is touched.
ElectricalLoadClassificationSpace | This enum is used by the ElectricalLoadClassification to specify the load class for use with spaces.
ElectricalPhase | An enumerated type to specify whether the electrical system is single phase or three phase.
ElectricalPhaseConfiguration | An enumerated type to specify the electrical phase configuration.
ElectricalSystemType | An enumerated type listing all the possible electrical system types for an electrical connector object.
LoadClassification | An enumerated type to list all demand factor classifications.
LoadClassificationType | An enumerated type listing all the possible load classification types for a connector object.
NeutralMode | An enumerated type to list the neutral mode for wire type.
PanelConfiguration | This enum declares the configuration for given panel schedule type.
PanelSchedulePhaseLoadType | Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule
PanelScheduleType | This enum declares the panel schedule type.
PowerFactorStateType | An enumerated type listing all the possible power factor state types for a connector object.
WiringType | An enumerated type to list all wiring types.


BaseLoadOn Enumeration

[image]

Revit 2011 API
BaseLoadOn Enumeration
See Also Send Feedback
An enumerated type listing all the possible power load use types for a space object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum BaseLoadOn
Visual Basic (Declaration)
Public Enumeration BaseLoadOn
Visual C++
public enum class BaseLoadOn

Members

Member name | Description
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.

See Also

Autodesk.Revit.DB.Electrical Namespace


CableTray Class

[image]

Revit 2011 API
CableTray Class
Members See Also Send Feedback
This class represents a cable tray in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTray : CableTrayConduitBase
Visual Basic (Declaration)
Public Class CableTray _
    Inherits CableTrayConduitBase
Visual C++
public ref class CableTray : public CableTrayConduitBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.CableTray

See Also

CableTray Members
Autodesk.Revit.DB.Electrical Namespace


CableTray Members

[image] [image]

Revit 2011 API
CableTray Members
CableTray Class Methods Properties See Also Send Feedback

The CableTray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of cable tray.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetShapeType | Returns the shape type for the cable tray.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidCableTrayType | Identifies if a cable tray type is valid.
IsValidRungSpace | Identifies if the input rung space is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting (Inherited from CableTrayConduitBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RungSpace |
RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTray Methods

[image] [image]

Revit 2011 API
CableTray Methods
CableTray Class See Also Send Feedback

The CableTray type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of cable tray.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetShapeType | Returns the shape type for the cable tray.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidCableTrayType | Identifies if a cable tray type is valid.
IsValidRungSpace | Identifies if the input rung space is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting (Inherited from CableTrayConduitBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
CableTray..::.Create Method
CableTray Class See Also Send Feedback
Creates a new instance of cable tray.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static CableTray Create(
    Document document,
    ElementId cabletrayType,
    XYZ startPoint,
    XYZ endPoint,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    cabletrayType As ElementId, _
    startPoint As XYZ, _
    endPoint As XYZ, _
    levelId As ElementId _
) As CableTray
Visual C++
public:
static CableTray^ Create(
    Document^ document,
    ElementId^ cabletrayType,
    XYZ^ startPoint,
    XYZ^ endPoint,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
cabletrayType
Type: Autodesk.Revit.DB..::.ElementId
The cable tray type. This must be a cable tray type accepted by isValidCableTrayType(). If the input cable tray type is InvalidElementId, the default cable tray type from the document will be used.
startPoint
Type: Autodesk.Revit.DB..::.XYZ
The start point of the cable tray location line.
endPoint
Type: Autodesk.Revit.DB..::.XYZ
The end point of the cable tray location line.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The element id of the level which this cable tray based. If the input level id is invalidElementId = -1, the nearest level will be used.

Return Value

The newly created cable tray.

Remarks

This method will regenerate the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | This cable tray type is invalid. -or- This level id is invalid. -or- This two end points are invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit MEP.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


GetShapeType Method

[image]

Revit 2011 API
CableTray..::.GetShapeType Method
CableTray Class See Also Send Feedback
Returns the shape type for the cable tray.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CableTrayShape GetShapeType()
Visual Basic (Declaration)
Public Function GetShapeType As CableTrayShape
Visual C++
public:
CableTrayShape GetShapeType()

Return Value

The shape type.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


IsValidCableTrayType Method

[image]

Revit 2011 API
CableTray..::.IsValidCableTrayType Method
CableTray Class See Also Send Feedback
Identifies if a cable tray type is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool IsValidCableTrayType(
    Document document,
    ElementId cabletrayType
)
Visual Basic (Declaration)
Public Shared Function IsValidCableTrayType ( _
    document As Document, _
    cabletrayType As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCableTrayType(
    Document^ document,
    ElementId^ cabletrayType
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
cabletrayType
Type: Autodesk.Revit.DB..::.ElementId
The cable tray type.

Return Value

True if the cable tray type is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


IsValidRungSpace Method

[image]

Revit 2011 API
CableTray..::.IsValidRungSpace Method
CableTray Class See Also Send Feedback
Identifies if the input rung space is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsValidRungSpace(
    double rungSpace
)
Visual Basic (Declaration)
Public Function IsValidRungSpace ( _
    rungSpace As Double _
) As Boolean
Visual C++
public:
bool IsValidRungSpace(
    double rungSpace
)

Parameters

rungSpace
Type: System..::.Double
The rung space to check.

Return Value

True if the value is acceptable, false otherwise.

Remarks

rung space should be at least equal to or larger than rang width which is 1 inch.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTray Properties

[image] [image]

Revit 2011 API
CableTray Properties
CableTray Class See Also Send Feedback

The CableTray type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RungSpace |
RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
CableTray..::.Parameter Property
CableTray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CableTray Class
CableTray Members
Autodesk.Revit.DB.Electrical Namespace


RungSpace Property

[image]

Revit 2011 API
CableTray..::.RungSpace Property
CableTray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double RungSpace { get; set; }
Visual Basic (Declaration)
Public Property RungSpace As Double
Visual C++
public:
property double RungSpace {
    double get ();
    void set (double value);
}

Remarks

Distance between two rungs for the ladder cable tray. This should be positive.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Class

[image]

Revit 2011 API
CableTrayConduitBase Class
Members See Also Send Feedback
The CableTrayConduitBase class is implemented as the base class for cable tray or conduit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayConduitBase : MEPCurve
Visual Basic (Declaration)
Public Class CableTrayConduitBase _
    Inherits MEPCurve
Visual C++
public ref class CableTrayConduitBase : public MEPCurve

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.CableTray
Autodesk.Revit.DB.Electrical..::.Conduit

See Also

CableTrayConduitBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Members

[image] [image]

Revit 2011 API
CableTrayConduitBase Members
CableTrayConduitBase Class Methods Properties See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidEndPoints | Identifies if two end points are valid.
IsValidLevelId | Identifies if a level id is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RunId | The id of the run to which this element belongs.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Methods

[image] [image]

Revit 2011 API
CableTrayConduitBase Methods
CableTrayConduitBase Class See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidEndPoints | Identifies if two end points are valid.
IsValidLevelId | Identifies if a level id is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsValidEndPoints Method

[image]

Revit 2011 API
CableTrayConduitBase..::.IsValidEndPoints Method
CableTrayConduitBase Class See Also Send Feedback
Identifies if two end points are valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool IsValidEndPoints(
    XYZ startPoint,
    XYZ endPoint
)
Visual Basic (Declaration)
Public Shared Function IsValidEndPoints ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Boolean
Visual C++
public:
static bool IsValidEndPoints(
    XYZ^ startPoint,
    XYZ^ endPoint
)

Parameters

startPoint
Type: Autodesk.Revit.DB..::.XYZ
The start point of the location line.
endPoint
Type: Autodesk.Revit.DB..::.XYZ
The end point of the location line.

Return Value

True if the two end points are valid, false otherwise.

Remarks

The two points should not be too close.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsValidLevelId Method

[image]

Revit 2011 API
CableTrayConduitBase..::.IsValidLevelId Method
CableTrayConduitBase Class See Also Send Feedback
Identifies if a level id is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool IsValidLevelId(
    Document document,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Function IsValidLevelId ( _
    document As Document, _
    levelId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidLevelId(
    Document^ document,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The level id.

Return Value

True if the level id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Method

[image]

Revit 2011 API
CableTrayConduitBase..::.IsWithFitting Method
CableTrayConduitBase Class See Also Send Feedback
Return whether its cable tray/conduit type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWithFitting()
Visual Basic (Declaration)
Public Function IsWithFitting As Boolean
Visual C++
public:
bool IsWithFitting()

Return Value

return true if its type is with fitting type.

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Properties

[image] [image]

Revit 2011 API
CableTrayConduitBase Properties
CableTrayConduitBase Class See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RunId | The id of the run to which this element belongs.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
CableTrayConduitBase..::.Parameter Property
CableTrayConduitBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CableTrayConduitBase Class
CableTrayConduitBase Members
Autodesk.Revit.DB.Electrical Namespace


RunId Property

[image]

Revit 2011 API
CableTrayConduitBase..::.RunId Property
CableTrayConduitBase Class See Also Send Feedback
The id of the run to which this element belongs.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId RunId { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunId As ElementId
Visual C++
public:
property ElementId^ RunId {
    ElementId^ get ();
}

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Class

[image]

Revit 2011 API
CableTrayConduitRunBase Class
Members See Also Send Feedback
The base class for a cable tray or conduit run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayConduitRunBase : Element
Visual Basic (Declaration)
Public Class CableTrayConduitRunBase _
    Inherits Element
Visual C++
public ref class CableTrayConduitRunBase : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.CableTrayRun
Autodesk.Revit.DB.Electrical..::.ConduitRun

See Also

CableTrayConduitRunBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Members

[image] [image]

Revit 2011 API
CableTrayConduitRunBase Members
CableTrayConduitRunBase Class Methods Properties See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Methods

[image] [image]

Revit 2011 API
CableTrayConduitRunBase Methods
CableTrayConduitRunBase Class See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Properties

[image] [image]

Revit 2011 API
CableTrayConduitRunBase Properties
CableTrayConduitRunBase Class See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


Length Property

[image]

Revit 2011 API
CableTrayConduitRunBase..::.Length Property
CableTrayConduitRunBase Class See Also Send Feedback
The length of the whole (cable tray or conduit) run

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
CableTrayConduitRunBase..::.Parameter Property
CableTrayConduitRunBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
CableTrayConduitRunBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Class

[image]

Revit 2011 API
CableTrayRun Class
Members See Also Send Feedback
This class represents a cable tray run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayRun : CableTrayConduitRunBase
Visual Basic (Declaration)
Public Class CableTrayRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class CableTrayRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a cable tray run. A cable tray run contains connected straight cable tray segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.CableTrayRun

See Also

CableTrayRun Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Members

[image] [image]

Revit 2011 API
CableTrayRun Members
CableTrayRun Class Methods Properties See Also Send Feedback

The CableTrayRun type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run (Inherited from CableTrayConduitRunBase.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Methods

[image] [image]

Revit 2011 API
CableTrayRun Methods
CableTrayRun Class See Also Send Feedback

The CableTrayRun type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Properties

[image] [image]

Revit 2011 API
CableTrayRun Properties
CableTrayRun Class See Also Send Feedback

The CableTrayRun type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run (Inherited from CableTrayConduitRunBase.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
CableTrayRun..::.Parameter Property
CableTrayRun Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CableTrayRun Class
CableTrayRun Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayShape Enumeration

[image]

Revit 2011 API
CableTrayShape Enumeration
See Also Send Feedback
Shape types enum of cable tray
Enum of cable tray shape

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CableTrayShape
Visual Basic (Declaration)
Public Enumeration CableTrayShape
Visual C++
public enum class CableTrayShape

Members

Member name | Description
Invalid | Invalid cable tray shape.
Channel | Channel cable tray shape.
Ladder | Ladder cable tray shape.

See Also

Autodesk.Revit.DB.Electrical Namespace


CableTrayType Class

[image]

Revit 2011 API
CableTrayType Class
Members See Also Send Feedback
This class represents a cable tray type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CableTrayType : MEPCurveType
Visual Basic (Declaration)
Public Class CableTrayType _
    Inherits MEPCurveType
Visual C++
public ref class CableTrayType : public MEPCurveType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Electrical..::.CableTrayType

See Also

CableTrayType Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Members

[image] [image]

Revit 2011 API
CableTrayType Members
CableTrayType Class Methods Properties See Also Send Feedback

The CableTrayType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidBendMultiplier | Identifies if the input bend multiplier is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BendMultiplier | Bend multiplier.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsWithFitting | Whether this cable tray type is with fitting
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
ShapeType | Shape of this cable tray type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Methods

[image] [image]

Revit 2011 API
CableTrayType Methods
CableTrayType Class See Also Send Feedback

The CableTrayType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidBendMultiplier | Identifies if the input bend multiplier is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


IsValidBendMultiplier Method

[image]

Revit 2011 API
CableTrayType..::.IsValidBendMultiplier Method
CableTrayType Class See Also Send Feedback
Identifies if the input bend multiplier is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsValidBendMultiplier(
    double bendMultiplier
)
Visual Basic (Declaration)
Public Function IsValidBendMultiplier ( _
    bendMultiplier As Double _
) As Boolean
Visual C++
public:
bool IsValidBendMultiplier(
    double bendMultiplier
)

Parameters

bendMultiplier
Type: System..::.Double
The bend multiplier to check.

Return Value

True if the value is acceptable, false otherwise.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Properties

[image] [image]

Revit 2011 API
CableTrayType Properties
CableTrayType Class See Also Send Feedback

The CableTrayType type exposes the following members.

Properties

Name | Description
BendMultiplier | Bend multiplier.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsWithFitting | Whether this cable tray type is with fitting
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
ShapeType | Shape of this cable tray type.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


BendMultiplier Property

[image]

Revit 2011 API
CableTrayType..::.BendMultiplier Property
CableTrayType Class See Also Send Feedback
Bend multiplier.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BendMultiplier { get; set; }
Visual Basic (Declaration)
Public Property BendMultiplier As Double
Visual C++
public:
property double BendMultiplier {
    double get ();
    void set (double value);
}

Remarks

This should be positive and less than 3000.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Property

[image]

Revit 2011 API
CableTrayType..::.IsWithFitting Property
CableTrayType Class See Also Send Feedback
Whether this cable tray type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWithFitting { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWithFitting As Boolean
Visual C++
public:
property bool IsWithFitting {
    bool get ();
}

Remarks

True if this cable tray type is with fitting type.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
CableTrayType..::.Parameter Property
CableTrayType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

CableTrayType Class
CableTrayType Members
Autodesk.Revit.DB.Electrical Namespace


ShapeType Property

[image]

Revit 2011 API
CableTrayType..::.ShapeType Property
CableTrayType Class See Also Send Feedback
Shape of this cable tray type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CableTrayShape ShapeType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeType As CableTrayShape
Visual C++
public:
property CableTrayShape ShapeType {
    CableTrayShape get ();
}

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CircuitType Enumeration

[image]

Revit 2011 API
CircuitType Enumeration
See Also Send Feedback
An enumerated type listing all the possible circuit types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum CircuitType
Visual Basic (Declaration)
Public Enumeration CircuitType
Visual C++
public enum class CircuitType

Members

Member name | Description
Circuit | Circuit type is circuit.
Spare | Circuit type is spare.
Space | Circuit type is space.

See Also

Autodesk.Revit.DB.Electrical Namespace


Conduit Class

[image]

Revit 2011 API
Conduit Class
Members See Also Send Feedback
This class represents a conduit in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Conduit : CableTrayConduitBase
Visual Basic (Declaration)
Public Class Conduit _
    Inherits CableTrayConduitBase
Visual C++
public ref class Conduit : public CableTrayConduitBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Electrical..::.CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::.Conduit

See Also

Conduit Members
Autodesk.Revit.DB.Electrical Namespace


Conduit Members

[image] [image]

Revit 2011 API
Conduit Members
Conduit Class Methods Properties See Also Send Feedback

The Conduit type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of conduit.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidConduitType | Identifies if a conduit type is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting (Inherited from CableTrayConduitBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Methods

[image] [image]

Revit 2011 API
Conduit Methods
Conduit Class See Also Send Feedback

The Conduit type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of conduit.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidConduitType | Identifies if a conduit type is valid.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
IsWithFitting | Return whether its cable tray/conduit type is with fitting (Inherited from CableTrayConduitBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
Conduit..::.Create Method
Conduit Class See Also Send Feedback
Creates a new instance of conduit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static Conduit Create(
    Document document,
    ElementId conduitType,
    XYZ startPoint,
    XYZ endPoint,
    ElementId levelId
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    conduitType As ElementId, _
    startPoint As XYZ, _
    endPoint As XYZ, _
    levelId As ElementId _
) As Conduit
Visual C++
public:
static Conduit^ Create(
    Document^ document,
    ElementId^ conduitType,
    XYZ^ startPoint,
    XYZ^ endPoint,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
conduitType
Type: Autodesk.Revit.DB..::.ElementId
The conduit type. This must be a conduit type accepted by isValidConduitType(). If the input conduit type is InvalidElementId, the default conduit type from the document will be used.
startPoint
Type: Autodesk.Revit.DB..::.XYZ
The start point of the conduit location line.
endPoint
Type: Autodesk.Revit.DB..::.XYZ
The end point of the conduit location line.
levelId
Type: Autodesk.Revit.DB..::.ElementId
The element id of the level which this conduit based. If the input level id is invalidElementId = -1, the nearest level will be used.

Return Value

The newly created conduit.

Remarks

This method will regenerate the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | This conduit type is invalid. -or- This level id is invalid. -or- This two end points are invalid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit MEP.

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


IsValidConduitType Method

[image]

Revit 2011 API
Conduit..::.IsValidConduitType Method
Conduit Class See Also Send Feedback
Identifies if a conduit type is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool IsValidConduitType(
    Document document,
    ElementId conduitType
)
Visual Basic (Declaration)
Public Shared Function IsValidConduitType ( _
    document As Document, _
    conduitType As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConduitType(
    Document^ document,
    ElementId^ conduitType
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document.
conduitType
Type: Autodesk.Revit.DB..::.ElementId
The conduit type.

Return Value

True if the conduit type is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Properties

[image] [image]

Revit 2011 API
Conduit Properties
Conduit Class See Also Send Feedback

The Conduit type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
Conduit..::.Parameter Property
Conduit Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Conduit Class
Conduit Members
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Class

[image]

Revit 2011 API
ConduitRun Class
Members See Also Send Feedback
This class represents a conduit run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConduitRun : CableTrayConduitRunBase
Visual Basic (Declaration)
Public Class ConduitRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class ConduitRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a conduit run. A conduit run contains connected straight conduit segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::.ConduitRun

See Also

ConduitRun Members
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Members

[image] [image]

Revit 2011 API
ConduitRun Members
ConduitRun Class Methods Properties See Also Send Feedback

The ConduitRun type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run (Inherited from CableTrayConduitRunBase.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Methods

[image] [image]

Revit 2011 API
ConduitRun Methods
ConduitRun Class See Also Send Feedback

The ConduitRun type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Properties

[image] [image]

Revit 2011 API
ConduitRun Properties
ConduitRun Class See Also Send Feedback

The ConduitRun type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Length | The length of the whole (cable tray or conduit) run (Inherited from CableTrayConduitRunBase.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ConduitRun..::.Parameter Property
ConduitRun Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ConduitRun Class
ConduitRun Members
Autodesk.Revit.DB.Electrical Namespace


ConduitType Class

[image]

Revit 2011 API
ConduitType Class
Members See Also Send Feedback
This class represents a conduit type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ConduitType : MEPCurveType
Visual Basic (Declaration)
Public Class ConduitType _
    Inherits MEPCurveType
Visual C++
public ref class ConduitType : public MEPCurveType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Electrical..::.ConduitType

See Also

ConduitType Members
Autodesk.Revit.DB.Electrical Namespace


ConduitType Members

[image] [image]

Revit 2011 API
ConduitType Members
ConduitType Class Methods Properties See Also Send Feedback

The ConduitType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsWithFitting | Whether this conduit type is with fitting
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


ConduitType Methods

[image] [image]

Revit 2011 API
ConduitType Methods
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


ConduitType Properties

[image] [image]

Revit 2011 API
ConduitType Properties
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsWithFitting | Whether this conduit type is with fitting
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Property

[image]

Revit 2011 API
ConduitType..::.IsWithFitting Property
ConduitType Class See Also Send Feedback
Whether this conduit type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWithFitting { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWithFitting As Boolean
Visual C++
public:
property bool IsWithFitting {
    bool get ();
}

Remarks

True if this conduit type is with fitting type.

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ConduitType..::.Parameter Property
ConduitType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ConduitType Class
ConduitType Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Class

[image]

Revit 2011 API
CorrectionFactor Class
Members See Also Send Feedback
Represents electrical correction factor information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CorrectionFactor : APIObject
Visual Basic (Declaration)
Public Class CorrectionFactor _
    Inherits APIObject
Visual C++
public ref class CorrectionFactor : public APIObject

Remarks

Correction factor is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.CorrectionFactor

See Also

CorrectionFactor Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Members

[image] [image]

Revit 2011 API
CorrectionFactor Members
CorrectionFactor Class Methods Properties See Also Send Feedback

The CorrectionFactor type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factor | Get factor value of wire correction factor.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Methods

[image] [image]

Revit 2011 API
CorrectionFactor Methods
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Properties

[image] [image]

Revit 2011 API
CorrectionFactor Properties
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Properties

Name | Description
Factor | Get factor value of wire correction factor.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


Factor Property

[image]

Revit 2011 API
CorrectionFactor..::.Factor Property
CorrectionFactor Class See Also Send Feedback
Get factor value of wire correction factor.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Factor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Factor As Double
Visual C++
public:
property double Factor {
    double get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


Temperature Property

[image]

Revit 2011 API
CorrectionFactor..::.Temperature Property
CorrectionFactor Class See Also Send Feedback
Get temperature which is used for specifying correction factor.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public long Temperature { get; }
Visual Basic (Declaration)
Public ReadOnly Property Temperature As Long
Visual C++
public:
property long long Temperature {
    long long get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Class

[image]

Revit 2011 API
CorrectionFactorSet Class
Members See Also Send Feedback
A set that contains correction factors.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class CorrectionFactorSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class CorrectionFactorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CorrectionFactorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSet

See Also

CorrectionFactorSet Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Members

[image] [image]

Revit 2011 API
CorrectionFactorSet Members
CorrectionFactorSet Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Constructors

Name | Description
CorrectionFactorSet | Initializes a new instance of the CorrectionFactorSet class

Methods

Name | Description
Clear | Removes every correction factor from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Constructor

[image]

Revit 2011 API
CorrectionFactorSet Constructor
CorrectionFactorSet Class See Also Send Feedback
Initializes a new instance of the CorrectionFactorSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CorrectionFactorSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSet()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Methods

[image] [image]

Revit 2011 API
CorrectionFactorSet Methods
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Methods

Name | Description
Clear | Removes every correction factor from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
CorrectionFactorSet..::.Clear Method
CorrectionFactorSet Class See Also Send Feedback
Removes every correction factor from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
CorrectionFactorSet..::.Contains Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
CorrectionFactorSet..::.Erase Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As CorrectionFactor _
) As Integer
Visual C++
public:
virtual int Erase(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
CorrectionFactorSet..::.ForwardIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
CorrectionFactorSet..::.GetEnumerator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
CorrectionFactorSet..::.Insert Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    CorrectionFactor item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
CorrectionFactorSet..::.ReverseIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Properties

[image] [image]

Revit 2011 API
CorrectionFactorSet Properties
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
CorrectionFactorSet..::.IsEmpty Property
CorrectionFactorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
CorrectionFactorSet..::.Size Property
CorrectionFactorSet Class See Also Send Feedback
Returns the number of correction factors that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Class

[image]

Revit 2011 API
CorrectionFactorSetIterator Class
Members See Also Send Feedback
An iterator to a correction factor set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class CorrectionFactorSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class CorrectionFactorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CorrectionFactorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.CorrectionFactorSetIterator

See Also

CorrectionFactorSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Members

[image] [image]

Revit 2011 API
CorrectionFactorSetIterator Members
CorrectionFactorSetIterator Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Constructors

Name | Description
CorrectionFactorSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Constructor

[image]

Revit 2011 API
CorrectionFactorSetIterator Constructor
CorrectionFactorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CorrectionFactorSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CorrectionFactorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Methods

[image] [image]

Revit 2011 API
CorrectionFactorSetIterator Methods
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
CorrectionFactorSetIterator..::.MoveNext Method
CorrectionFactorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
CorrectionFactorSetIterator..::.Reset Method
CorrectionFactorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Properties

[image] [image]

Revit 2011 API
CorrectionFactorSetIterator Properties
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
CorrectionFactorSetIterator..::.Current Property
CorrectionFactorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Class

[image]

Revit 2011 API
DistributionSysType Class
Members See Also Send Feedback
Represents a specific type of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DistributionSysType : ElementType
Visual Basic (Declaration)
Public Class DistributionSysType _
    Inherits ElementType
Visual C++
public ref class DistributionSysType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.DistributionSysType

See Also

DistributionSysType Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Members

[image] [image]

Revit 2011 API
DistributionSysType Members
DistributionSysType Class Methods Properties See Also Send Feedback

The DistributionSysType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Get the value which indicates whether this distribution system is in service now.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
NumWires | Get or set number of wires of distribution system.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
VoltageLineToGround | Get or set line to ground voltage of distribution system type.
VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Methods

[image] [image]

Revit 2011 API
DistributionSysType Methods
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Properties

[image] [image]

Revit 2011 API
DistributionSysType Properties
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Get the value which indicates whether this distribution system is in service now.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
NumWires | Get or set number of wires of distribution system.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
VoltageLineToGround | Get or set line to ground voltage of distribution system type.
VoltageLineToLine | Get or set line to line voltage type of distribution system type.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalPhase Property

[image]

Revit 2011 API
DistributionSysType..::.ElectricalPhase Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase (single, triple or undefined) of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalPhase ElectricalPhase { get; set; }
Visual Basic (Declaration)
Public Property ElectricalPhase As ElectricalPhase
Visual C++
public:
property ElectricalPhase ElectricalPhase {
    ElectricalPhase get ();
    void set (ElectricalPhase value);
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalPhaseConfiguration Property

[image]

Revit 2011 API
DistributionSysType..::.ElectricalPhaseConfiguration Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase configuration (Y, delta or undefined) of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalPhaseConfiguration ElectricalPhaseConfiguration { get; set; }
Visual Basic (Declaration)
Public Property ElectricalPhaseConfiguration As ElectricalPhaseConfiguration
Visual C++
public:
property ElectricalPhaseConfiguration ElectricalPhaseConfiguration {
    ElectricalPhaseConfiguration get ();
    void set (ElectricalPhaseConfiguration value);
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
DistributionSysType..::.IsInUse Property
DistributionSysType Class See Also Send Feedback
Get the value which indicates whether this distribution system is in service now.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


NumWires Property

[image]

Revit 2011 API
DistributionSysType..::.NumWires Property
DistributionSysType Class See Also Send Feedback
Get or set number of wires of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumWires { get; set; }
Visual Basic (Declaration)
Public Property NumWires As Integer
Visual C++
public:
property int NumWires {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | While assign a negative value to NumWires.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
DistributionSysType..::.Parameter Property
DistributionSysType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DistributionSysType Class
DistributionSysType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageLineToGround Property

[image]

Revit 2011 API
DistributionSysType..::.VoltageLineToGround Property
DistributionSysType Class See Also Send Feedback
Get or set line to ground voltage of distribution system type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageType VoltageLineToGround { get; set; }
Visual Basic (Declaration)
Public Property VoltageLineToGround As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToGround {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageLineToLine Property

[image]

Revit 2011 API
DistributionSysType..::.VoltageLineToLine Property
DistributionSysType Class See Also Send Feedback
Get or set line to line voltage type of distribution system type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageType VoltageLineToLine { get; set; }
Visual Basic (Declaration)
Public Property VoltageLineToLine As VoltageType
Visual C++
public:
property VoltageType^ VoltageLineToLine {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Class

[image]

Revit 2011 API
DistributionSysTypeSet Class
Members See Also Send Feedback
A set that contains DistributionSys types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DistributionSysTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class DistributionSysTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DistributionSysTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSet

See Also

DistributionSysTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Members

[image] [image]

Revit 2011 API
DistributionSysTypeSet Members
DistributionSysTypeSet Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Constructors

Name | Description
DistributionSysTypeSet | Initializes a new instance of the DistributionSysTypeSet class

Methods

Name | Description
Clear | Removes every DistributionSys type from the set, rendering it empty.
Contains | Tests for the existence of a DistributionSys type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified DistributionSys type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified DistributionSys type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Constructor

[image]

Revit 2011 API
DistributionSysTypeSet Constructor
DistributionSysTypeSet Class See Also Send Feedback
Initializes a new instance of the DistributionSysTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSet()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Methods

[image] [image]

Revit 2011 API
DistributionSysTypeSet Methods
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every DistributionSys type from the set, rendering it empty.
Contains | Tests for the existence of a DistributionSys type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified DistributionSys type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified DistributionSys type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.Clear Method
DistributionSysTypeSet Class See Also Send Feedback
Removes every DistributionSys type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.Contains Method
DistributionSysTypeSet Class See Also Send Feedback
Tests for the existence of a DistributionSys type within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.DistributionSysType
The DistributionSys type to be searched for.

Return Value

The Contains method returns True if the DistributionSys type is within the set, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.Erase Method
DistributionSysTypeSet Class See Also Send Feedback
Removes a specified DistributionSys type from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As DistributionSysType _
) As Integer
Visual C++
public:
virtual int Erase(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.DistributionSysType
The DistributionSys type to be erased.

Return Value

The number of DistributionSys types that were erased from the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.ForwardIterator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.GetEnumerator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.Insert Method
DistributionSysTypeSet Class See Also Send Feedback
Insert the specified DistributionSys type into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    DistributionSysType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.DistributionSysType
The DistributionSys type to be inserted into the set.

Return Value

Returns whether the DistributionSys type was inserted into the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
DistributionSysTypeSet..::.ReverseIterator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Properties

[image] [image]

Revit 2011 API
DistributionSysTypeSet Properties
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
DistributionSysTypeSet..::.IsEmpty Property
DistributionSysTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
DistributionSysTypeSet..::.Size Property
DistributionSysTypeSet Class See Also Send Feedback
Returns the number of DistributionSys types that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Class

[image]

Revit 2011 API
DistributionSysTypeSetIterator Class
Members See Also Send Feedback
An iterator to a DistributionSys type set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DistributionSysTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class DistributionSysTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DistributionSysTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.DistributionSysTypeSetIterator

See Also

DistributionSysTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Members

[image] [image]

Revit 2011 API
DistributionSysTypeSetIterator Members
DistributionSysTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Constructors

Name | Description
DistributionSysTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Constructor

[image]

Revit 2011 API
DistributionSysTypeSetIterator Constructor
DistributionSysTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistributionSysTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Methods

[image] [image]

Revit 2011 API
DistributionSysTypeSetIterator Methods
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
DistributionSysTypeSetIterator..::.MoveNext Method
DistributionSysTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
DistributionSysTypeSetIterator..::.Reset Method
DistributionSysTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Properties

[image] [image]

Revit 2011 API
DistributionSysTypeSetIterator Properties
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
DistributionSysTypeSetIterator..::.Current Property
DistributionSysTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Class

[image]

Revit 2011 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class ElectricalConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class ElectricalConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Electrical connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Electrical..::.ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Members

[image] [image]

Revit 2011 API
ElectricalConnector Members
ElectricalConnector Class Methods Properties See Also Send Feedback

The ElectricalConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign an electrical connector as a primary electrical connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Indicates if the connector is primary or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Methods

[image] [image]

Revit 2011 API
ElectricalConnector Methods
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign an electrical connector as a primary electrical connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


AssignAsPrimary Method

[image]

Revit 2011 API
ElectricalConnector..::.AssignAsPrimary Method
ElectricalConnector Class See Also Send Feedback
Assign an electrical connector as a primary electrical connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this electrical connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Properties

[image] [image]

Revit 2011 API
ElectricalConnector Properties
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Indicates if the connector is primary or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


CoordinateSystem Property

[image]

Revit 2011 API
ElectricalConnector..::.CoordinateSystem Property
ElectricalConnector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

This property is used to retrieve the coordinate system of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Domain Property

[image]

Revit 2011 API
ElectricalConnector..::.Domain Property
ElectricalConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Height Property

[image]

Revit 2011 API
ElectricalConnector..::.Height Property
ElectricalConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


IsPrimary Property

[image]

Revit 2011 API
ElectricalConnector..::.IsPrimary Property
ElectricalConnector Class See Also Send Feedback
Indicates if the connector is primary or not.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Origin Property

[image]

Revit 2011 API
ElectricalConnector..::.Origin Property
ElectricalConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ElectricalConnector..::.Parameter Property
ElectricalConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalConnector Class
ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace


Radius Property

[image]

Revit 2011 API
ElectricalConnector..::.Radius Property
ElectricalConnector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Shape Property

[image]

Revit 2011 API
ElectricalConnector..::.Shape Property
ElectricalConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


SystemType Property

[image]

Revit 2011 API
ElectricalConnector..::.SystemType Property
ElectricalConnector Class See Also Send Feedback
The system type of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
    void set (ElectricalSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the system type is out of the permitted range of values.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Width Property

[image]

Revit 2011 API
ElectricalConnector..::.Width Property
ElectricalConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

no shape for electrical connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because electrical connectors don't have a shape.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Class

[image]

Revit 2011 API
ElectricalDemandFactorDefinition Class
Members See Also Send Feedback
The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElectricalDemandFactorDefinition : Element
Visual Basic (Declaration)
Public Class ElectricalDemandFactorDefinition _
    Inherits Element
Visual C++
public ref class ElectricalDemandFactorDefinition : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorDefinition

See Also

ElectricalDemandFactorDefinition Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Members

[image] [image]

Revit 2011 API
ElectricalDemandFactorDefinition Members
ElectricalDemandFactorDefinition Class Constructors Methods Properties See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Constructors

Name | Description
ElectricalDemandFactorDefinition | Initializes a new instance of the ElectricalDemandFactorDefinition class

Methods

Name | Description
AddValue | Adds a value to the value set for this demand factor definition
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ClearValues | Clears all the values stored for this demand factor definition.
Create | Creates a new instance of a demand factor definition.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetValues | Provides access to the value set stored with this demand factor definition
GetValuesCount | Returns the number of values in the set.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveValue | Removes a value to the value set for this demand factor definition
SetValues | Sets the value set to the demand factor definition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdditionalLoad | Additional load to be included during demand load calculation.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeAdditionalLoad | Should the additional load (if set) be included in demand load calculations.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RuleType | The rule type for this demand factor definition.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Constructor

[image]

Revit 2011 API
ElectricalDemandFactorDefinition Constructor
ElectricalDemandFactorDefinition Class See Also Send Feedback
Initializes a new instance of the ElectricalDemandFactorDefinition class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorDefinition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalDemandFactorDefinition()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Methods

[image] [image]

Revit 2011 API
ElectricalDemandFactorDefinition Methods
ElectricalDemandFactorDefinition Class See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Methods

Name | Description
AddValue | Adds a value to the value set for this demand factor definition
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
ClearValues | Clears all the values stored for this demand factor definition.
Create | Creates a new instance of a demand factor definition.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
GetValues | Provides access to the value set stored with this demand factor definition
GetValuesCount | Returns the number of values in the set.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveValue | Removes a value to the value set for this demand factor definition
SetValues | Sets the value set to the demand factor definition.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


AddValue Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.AddValue Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Adds a value to the value set for this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddValue(
    ElectricalDemandFactorValue dfValue
)
Visual Basic (Declaration)
Public Sub AddValue ( _
    dfValue As ElectricalDemandFactorValue _
)
Visual C++
public:
void AddValue(
    ElectricalDemandFactorValue^ dfValue
)

Parameters

dfValue
Type: Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorValue
Value to add to the set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ClearValues Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.ClearValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Clears all the values stored for this demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void ClearValues()
Visual Basic (Declaration)
Public Sub ClearValues
Visual C++
public:
void ClearValues()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.Create Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Creates a new instance of a demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElectricalDemandFactorDefinition Create(
    Document ADoc,
    string strName
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    ADoc As Document, _
    strName As String _
) As ElectricalDemandFactorDefinition
Visual C++
public:
static ElectricalDemandFactorDefinition^ Create(
    Document^ ADoc,
    String^ strName
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document where the element will be created and added.
strName
Type: System..::.String
The name of the electrical demand factor definition to be created.

Return Value

The newly created demand factor definition element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetApplicableDemandFactor Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.GetApplicableDemandFactor Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
This method will return the applicable demand factor for the specified number of devices or load.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetApplicableDemandFactor(
    double numberOrLoad
)
Visual Basic (Declaration)
Public Function GetApplicableDemandFactor ( _
    numberOrLoad As Double _
) As Double
Visual C++
public:
double GetApplicableDemandFactor(
    double numberOrLoad
)

Parameters

numberOrLoad
Type: System..::.Double
The number of devices or load for which the demand factor should be looked up.

Return Value

The applicable demand factor.

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetValues Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.GetValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Provides access to the value set stored with this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElectricalDemandFactorValue> GetValues()
Visual Basic (Declaration)
Public Function GetValues As ICollection(Of ElectricalDemandFactorValue)
Visual C++
public:
ICollection<ElectricalDemandFactorValue^>^ GetValues()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetValuesCount Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.GetValuesCount Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Returns the number of values in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public int GetValuesCount()
Visual Basic (Declaration)
Public Function GetValuesCount As Integer
Visual C++
public:
int GetValuesCount()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


RemoveValue Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.RemoveValue Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Removes a value to the value set for this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void RemoveValue(
    ElectricalDemandFactorValue dfValue
)
Visual Basic (Declaration)
Public Sub RemoveValue ( _
    dfValue As ElectricalDemandFactorValue _
)
Visual C++
public:
void RemoveValue(
    ElectricalDemandFactorValue^ dfValue
)

Parameters

dfValue
Type: Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorValue
Value to remove from the set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


SetValues Method

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.SetValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Sets the value set to the demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetValues(
    ICollection<ElectricalDemandFactorValue> values
)
Visual Basic (Declaration)
Public Sub SetValues ( _
    values As ICollection(Of ElectricalDemandFactorValue) _
)
Visual C++
public:
void SetValues(
    ICollection<ElectricalDemandFactorValue^>^ values
)

Parameters

values
Type: System.Collections.Generic..::.ICollection <(Of <( ElectricalDemandFactorValue >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Properties

[image] [image]

Revit 2011 API
ElectricalDemandFactorDefinition Properties
ElectricalDemandFactorDefinition Class See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Properties

Name | Description
AdditionalLoad | Additional load to be included during demand load calculation.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeAdditionalLoad | Should the additional load (if set) be included in demand load calculations.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RuleType | The rule type for this demand factor definition.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


AdditionalLoad Property

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.AdditionalLoad Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Additional load to be included during demand load calculation.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AdditionalLoad { get; set; }
Visual Basic (Declaration)
Public Property AdditionalLoad As Double
Visual C++
public:
property double AdditionalLoad {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


IncludeAdditionalLoad Property

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.IncludeAdditionalLoad Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Should the additional load (if set) be included in demand load calculations.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IncludeAdditionalLoad { get; set; }
Visual Basic (Declaration)
Public Property IncludeAdditionalLoad As Boolean
Visual C++
public:
property bool IncludeAdditionalLoad {
    bool get ();
    void set (bool value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.Parameter Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
ElectricalDemandFactorDefinition Members
Autodesk.Revit.DB.Electrical Namespace


RuleType Property

[image]

Revit 2011 API
ElectricalDemandFactorDefinition..::.RuleType Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
The rule type for this demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorRule RuleType { get; set; }
Visual Basic (Declaration)
Public Property RuleType As ElectricalDemandFactorRule
Visual C++
public:
property ElectricalDemandFactorRule RuleType {
    ElectricalDemandFactorRule get ();
    void set (ElectricalDemandFactorRule value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinitionData Enumeration

[image]

Revit 2011 API
ElectricalDemandFactorDefinitionData Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum ElectricalDemandFactorDefinitionData
Visual Basic (Declaration)
Public Enumeration ElectricalDemandFactorDefinitionData
Visual C++
public enum class ElectricalDemandFactorDefinitionData

Members

Member name | Description
Name |
AdditionalLoad |
IncludeAdditionalLoad |
RuleType |
DefinitionValues |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorRule Enumeration

[image]

Revit 2011 API
ElectricalDemandFactorRule Enumeration
See Also Send Feedback
This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalDemandFactorRule
Visual Basic (Declaration)
Public Enumeration ElectricalDemandFactorRule
Visual C++
public enum class ElectricalDemandFactorRule

Members

Member name | Description
Constant | This rule will apply a constant demand factor to the loads, regardless of values. It will also be the default for any newly created demand factor, and the default used if a demand factor cannot be found for a load classification.
QuantityTable | This rule will apply the demand factor for the total quantity of attached objects to a panel. It is purely a look-up table. For example, the user can specify that 0 to 2 objects get 100% and 2 to 4 objects get 85% and so on.
LoadTable | This rule will apply the demand factor for the total load of attached objects to a panel. It is purely a look-up table. For example, if there are 5000 kVA, the user can specify 125% value is applied. If there are 20,000 kVA, the user can specify 100% value is applied.
QuantityTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the first two (largest) items will have a 125% demand factor applied and the remaining items will have a 75% factor applied.
LoadTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the 3000kVA will have a 100% demand factor applied, the next 9000 will have a 35% factor applied, and the remaining items will have a 25% factor applied.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Class

[image]

Revit 2011 API
ElectricalDemandFactorValue Class
Members See Also Send Feedback
This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElectricalDemandFactorValue : IDisposable
Visual Basic (Declaration)
Public Class ElectricalDemandFactorValue _
    Implements IDisposable
Visual C++
public ref class ElectricalDemandFactorValue : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Electrical..::.ElectricalDemandFactorValue

See Also

ElectricalDemandFactorValue Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Members

[image] [image]

Revit 2011 API
ElectricalDemandFactorValue Members
ElectricalDemandFactorValue Class Constructors Methods Properties See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Constructors

Name | Description
ElectricalDemandFactorValue | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetMaxRangeToUnlimited | Sets the max range on the value to unlimited
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factor | The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.
MaxRange | The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.
MinRange | The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor

[image] [image]

Revit 2011 API
ElectricalDemandFactorValue Constructor
ElectricalDemandFactorValue Class See Also Send Feedback

Overload List

Name | Description
ElectricalDemandFactorValue()()() | Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0
ElectricalDemandFactorValue(Double, Double, Double) | Constructor. Initializes factor, minimum range and maximum range to values passed in.

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor

[image]

Revit 2011 API
ElectricalDemandFactorValue Constructor
ElectricalDemandFactorValue Class See Also Send Feedback
Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalDemandFactorValue()

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Overload
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor (Double, Double, Double)

[image]

Revit 2011 API
ElectricalDemandFactorValue Constructor (Double, Double, Double)
ElectricalDemandFactorValue Class See Also Send Feedback
Constructor. Initializes factor, minimum range and maximum range to values passed in.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorValue(
    double minRange,
    double maxRange,
    double factor
)
Visual Basic (Declaration)
Public Sub New ( _
    minRange As Double, _
    maxRange As Double, _
    factor As Double _
)
Visual C++
public:
ElectricalDemandFactorValue(
    double minRange,
    double maxRange,
    double factor
)

Parameters

minRange
Type: System..::.Double
maxRange
Type: System..::.Double
factor
Type: System..::.Double

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Overload
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Methods

[image] [image]

Revit 2011 API
ElectricalDemandFactorValue Methods
ElectricalDemandFactorValue Class See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetMaxRangeToUnlimited | Sets the max range on the value to unlimited
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


Dispose Method

[image]

Revit 2011 API
ElectricalDemandFactorValue..::.Dispose Method
ElectricalDemandFactorValue Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


SetMaxRangeToUnlimited Method

[image]

Revit 2011 API
ElectricalDemandFactorValue..::.SetMaxRangeToUnlimited Method
ElectricalDemandFactorValue Class See Also Send Feedback
Sets the max range on the value to unlimited

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetMaxRangeToUnlimited()
Visual Basic (Declaration)
Public Sub SetMaxRangeToUnlimited
Visual C++
public:
void SetMaxRangeToUnlimited()

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Properties

[image] [image]

Revit 2011 API
ElectricalDemandFactorValue Properties
ElectricalDemandFactorValue Class See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Properties

Name | Description
Factor | The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.
MaxRange | The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.
MinRange | The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


Factor Property

[image]

Revit 2011 API
ElectricalDemandFactorValue..::.Factor Property
ElectricalDemandFactorValue Class See Also Send Feedback
The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Factor { get; set; }
Visual Basic (Declaration)
Public Property Factor As Double
Visual C++
public:
property double Factor {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


MaxRange Property

[image]

Revit 2011 API
ElectricalDemandFactorValue..::.MaxRange Property
ElectricalDemandFactorValue Class See Also Send Feedback
The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double MaxRange { get; set; }
Visual Basic (Declaration)
Public Property MaxRange As Double
Visual C++
public:
property double MaxRange {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


MinRange Property

[image]

Revit 2011 API
ElectricalDemandFactorValue..::.MinRange Property
ElectricalDemandFactorValue Class See Also Send Feedback
The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double MinRange { get; set; }
Visual Basic (Declaration)
Public Property MinRange As Double
Visual C++
public:
property double MinRange {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Class

[image]

Revit 2011 API
ElectricalEquipment Class
Members See Also Send Feedback
Provides access to the Electrical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalEquipment : MEPModel
Visual Basic (Declaration)
Public Class ElectricalEquipment _
    Inherits MEPModel
Visual C++
public ref class ElectricalEquipment : public MEPModel

Remarks

The Electrical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.ElectricalEquipment

See Also

ElectricalEquipment Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Members

[image] [image]

Revit 2011 API
ElectricalEquipment Members
ElectricalEquipment Class Methods Properties See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
DistributionSystem | get or set the Distribution System for the Electrical Equipment.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Methods

[image] [image]

Revit 2011 API
ElectricalEquipment Methods
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Properties

[image] [image]

Revit 2011 API
ElectricalEquipment Properties
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
DistributionSystem | get or set the Distribution System for the Electrical Equipment.
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSystem Property

[image]

Revit 2011 API
ElectricalEquipment..::.DistributionSystem Property
ElectricalEquipment Class See Also Send Feedback
get or set the Distribution System for the Electrical Equipment.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysType DistributionSystem { get; set; }
Visual Basic (Declaration)
Public Property DistributionSystem As DistributionSysType
Visual C++
public:
property DistributionSysType^ DistributionSystem {
    DistributionSysType^ get ();
    void set (DistributionSysType^ value);
}

Remarks

This property returns a Distribution System which is assigned to the Electrical Equipment. If there are no Distribution System assigned to this Electrical Equipment, this property will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Class

[image]

Revit 2011 API
ElectricalLoadClassification Class
Members See Also Send Feedback
The ElectricalLoadClassification class represents a serialized version of an instance of load classification.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ElectricalLoadClassification : Element
Visual Basic (Declaration)
Public Class ElectricalLoadClassification _
    Inherits Element
Visual C++
public ref class ElectricalLoadClassification : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.ElectricalLoadClassification

See Also

ElectricalLoadClassification Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Members

[image] [image]

Revit 2011 API
ElectricalLoadClassification Members
ElectricalLoadClassification Class Methods Properties See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of load classification and adds it to the document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DemandFactorId | The demand factor definition this load classification element uses.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Motor | Indicates if this load classification is to be used for motors.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceLoadClass |
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Methods

[image] [image]

Revit 2011 API
ElectricalLoadClassification Methods
ElectricalLoadClassification Class See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of load classification and adds it to the document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
ElectricalLoadClassification..::.Create Method
ElectricalLoadClassification Class See Also Send Feedback
Creates a new instance of load classification and adds it to the document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static ElectricalLoadClassification Create(
    Document ADoc,
    string strName
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    ADoc As Document, _
    strName As String _
) As ElectricalLoadClassification
Visual C++
public:
static ElectricalLoadClassification^ Create(
    Document^ ADoc,
    String^ strName
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
The document where the element will be created and added.
strName
Type: System..::.String
The name of the electrical load classification to be created.

Return Value

The newly created load classification element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Properties

[image] [image]

Revit 2011 API
ElectricalLoadClassification Properties
ElectricalLoadClassification Class See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DemandFactorId | The demand factor definition this load classification element uses.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Motor | Indicates if this load classification is to be used for motors.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceLoadClass |
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


DemandFactorId Property

[image]

Revit 2011 API
ElectricalLoadClassification..::.DemandFactorId Property
ElectricalLoadClassification Class See Also Send Feedback
The demand factor definition this load classification element uses.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId DemandFactorId { get; set; }
Visual Basic (Declaration)
Public Property DemandFactorId As ElementId
Visual C++
public:
property ElementId^ DemandFactorId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Motor Property

[image]

Revit 2011 API
ElectricalLoadClassification..::.Motor Property
ElectricalLoadClassification Class See Also Send Feedback
Indicates if this load classification is to be used for motors.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Motor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Motor As Boolean
Visual C++
public:
property bool Motor {
    bool get ();
}

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ElectricalLoadClassification..::.Parameter Property
ElectricalLoadClassification Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
ElectricalLoadClassification Members
Autodesk.Revit.DB.Electrical Namespace


SpaceLoadClass Property

[image]

Revit 2011 API
ElectricalLoadClassification..::.SpaceLoadClass Property
ElectricalLoadClassification Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElectricalLoadClassificationSpace SpaceLoadClass { get; set; }
Visual Basic (Declaration)
Public Property SpaceLoadClass As ElectricalLoadClassificationSpace
Visual C++
public:
property ElectricalLoadClassificationSpace SpaceLoadClass {
    ElectricalLoadClassificationSpace get ();
    void set (ElectricalLoadClassificationSpace value);
}

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassificationData Enumeration

[image]

Revit 2011 API
ElectricalLoadClassificationData Enumeration
See Also Send Feedback
This enum is used by the ElectricalLoadClassification class as additional data whenever data members changed. It is used as the additional data when the atom corresponding to each data member is touched.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalLoadClassificationData
Visual Basic (Declaration)
Public Enumeration ElectricalLoadClassificationData
Visual C++
public enum class ElectricalLoadClassificationData

Members

Member name | Description
Name |
SpaceLoadClass |
DemandFactor |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassificationSpace Enumeration

[image]

Revit 2011 API
ElectricalLoadClassificationSpace Enumeration
See Also Send Feedback
This enum is used by the ElectricalLoadClassification to specify the load class for use with spaces.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalLoadClassificationSpace
Visual Basic (Declaration)
Public Enumeration ElectricalLoadClassificationSpace
Visual C++
public enum class ElectricalLoadClassificationSpace

Members

Member name | Description
None |
Lighting |
Power |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalPhase Enumeration

[image]

Revit 2011 API
ElectricalPhase Enumeration
See Also Send Feedback
An enumerated type to specify whether the electrical system is single phase or three phase.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ElectricalPhase
Visual Basic (Declaration)
Public Enumeration ElectricalPhase
Visual C++
public enum class ElectricalPhase

Members

Member name | Description
SinglePhase | Electrical phase is single phase.
ThreePhase | Electrical phase is three phase.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalPhaseConfiguration Enumeration

[image]

Revit 2011 API
ElectricalPhaseConfiguration Enumeration
See Also Send Feedback
An enumerated type to specify the electrical phase configuration.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ElectricalPhaseConfiguration
Visual Basic (Declaration)
Public Enumeration ElectricalPhaseConfiguration
Visual C++
public enum class ElectricalPhaseConfiguration

Members

Member name | Description
Undefined | Electrical phase configuration is undefined.
Wye | Electrical phase configuration is Y.
Delta | Electrical phase configuration is delta.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Class

[image]

Revit 2011 API
ElectricalSetting Class
Members See Also Send Feedback
An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalSetting : APIObject
Visual Basic (Declaration)
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Members

[image] [image]

Revit 2011 API
ElectricalSetting Members
ElectricalSetting Class Methods Properties See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DistributionSysTypes | Get all distribution system types of the project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
VoltageTypes | Get all voltage type definitions information of the project.
WireConduitTypes | Get electrical conduit types information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Methods

[image] [image]

Revit 2011 API
ElectricalSetting Methods
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

Name | Description
AddDistributionSysType | Add a new distribution system type to project.
AddVoltageType | Add a new type definition of voltage into project.
AddWireMaterialType | Add a new type of wire material.
AddWireType | Add a new wire type to project.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveDistributionSysType | Remove an existing distribution system type from the project.
RemoveVoltageType | Remove the voltage type from project.
RemoveWireMaterialType | Remove the wire material type from project.
RemoveWireType | Remove wire type definition from project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddDistributionSysType Method

[image]

Revit 2011 API
ElectricalSetting..::.AddDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Add a new distribution system type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic (Declaration)
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType(
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
Type: System..::.String
The name of new added distribution system type
phase
Type: Autodesk.Revit.DB.Electrical..::.ElectricalPhase
Single or three phase this type is
phaseConfig
Type: Autodesk.Revit.DB.Electrical..::.ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Type: System..::.Int32
Wire number of this distribution system
volLineToLine
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
Type of line to line voltage in this system
volLineToGround
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The name can't be nullNothingnullptra null reference (Nothing in Visual Basic), empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddVoltageType Method

[image]

Revit 2011 API
ElectricalSetting..::.AddVoltageType Method
ElectricalSetting Class See Also Send Feedback
Add a new type definition of voltage into project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageType AddVoltageType(
    string name,
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Function AddVoltageType ( _
    name As String, _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
) As VoltageType
Visual C++
public:
VoltageType^ AddVoltageType(
    String^ name,
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

name
Type: System..::.String
Specify voltage type name
actualValue
Type: System..::.Double
Specify actual value of voltage type.
minValue
Type: System..::.Double
Specify acceptable minimum value of the voltage type.
maxValue
Type: System..::.Double
Specify acceptable maximum value of the voltage type.

Return Value

New added voltage type object.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddWireMaterialType Method

[image]

Revit 2011 API
ElectricalSetting..::.AddWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Add a new type of wire material.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialType AddWireMaterialType(
    string name,
    WireMaterialType baseMaterial
)
Visual Basic (Declaration)
Public Function AddWireMaterialType ( _
    name As String, _
    baseMaterial As WireMaterialType _
) As WireMaterialType
Visual C++
public:
WireMaterialType^ AddWireMaterialType(
    String^ name,
    WireMaterialType^ baseMaterial
)

Parameters

name
Type: System..::.String
Name of new material type.
baseMaterial
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

New added wire material type object.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddWireType Method

[image]

Revit 2011 API
ElectricalSetting..::.AddWireType Method
ElectricalSetting Class See Also Send Feedback
Add a new wire type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    NeutralMode neutralMode,
    WireConduitType conduit
)
Visual Basic (Declaration)
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As NeutralMode, _
    conduit As WireConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType(
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    NeutralMode neutralMode,
    WireConduitType^ conduit
)

Parameters

name
Type: System..::.String
Name of the new wire type.
materialType
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType
Wire material of new wire type.
temperatureRating
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType
Temperature rating type information of new wire type.
insulation
Type: Autodesk.Revit.DB.Electrical..::.InsulationType
Insulation of new wire type.
maxSize
Type: Autodesk.Revit.DB.Electrical..::.WireSize
Max wire size of new wire type.
neutralMultiplier
Type: System..::.Double
Neutral multiplier of new wire type.
neutralRequired
Type: System..::.Boolean
Specify whether neutral point is required.
neutralMode
Type: Autodesk.Revit.DB.Electrical..::.NeutralMode
Specify neutral mode.
conduit
Type: Autodesk.Revit.DB.Electrical..::.WireConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Parameter of temperatureRating should be retrieved from parameter of materialType, and params such as insulation, maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to be failed.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveDistributionSysType Method

[image]

Revit 2011 API
ElectricalSetting..::.RemoveDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic (Declaration)
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
Type: Autodesk.Revit.DB.Electrical..::.DistributionSysType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveVoltageType Method

[image]

Revit 2011 API
ElectricalSetting..::.RemoveVoltageType Method
ElectricalSetting Class See Also Send Feedback
Remove the voltage type from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveVoltageType(
    VoltageType voltageType
)
Visual Basic (Declaration)
Public Sub RemoveVoltageType ( _
    voltageType As VoltageType _
)
Visual C++
public:
void RemoveVoltageType(
    VoltageType^ voltageType
)

Parameters

voltageType
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
Specify the voltage type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Voltage type can be removed only if it isn't in service with any distribution systems.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireMaterialType Method

[image]

Revit 2011 API
ElectricalSetting..::.RemoveWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Remove the wire material type from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveWireMaterialType(
    WireMaterialType materialType
)
Visual Basic (Declaration)
Public Sub RemoveWireMaterialType ( _
    materialType As WireMaterialType _
)
Visual C++
public:
void RemoveWireMaterialType(
    WireMaterialType^ materialType
)

Parameters

materialType
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType
The wire material type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Wire material type can be removed only if it is not currently assigned to any wire type, and the last one wire material type can't be removed, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireType Method

[image]

Revit 2011 API
ElectricalSetting..::.RemoveWireType Method
ElectricalSetting Class See Also Send Feedback
Remove wire type definition from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveWireType(
    WireType wireType
)
Visual Basic (Declaration)
Public Sub RemoveWireType ( _
    wireType As WireType _
)
Visual C++
public:
void RemoveWireType(
    WireType^ wireType
)

Parameters

wireType
Type: Autodesk.Revit.DB.Electrical..::.WireType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Wire type can be removed only if it is not used, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Properties

[image] [image]

Revit 2011 API
ElectricalSetting Properties
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Properties

Name | Description
DistributionSysTypes | Get all distribution system types of the project.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
VoltageTypes | Get all voltage type definitions information of the project.
WireConduitTypes | Get electrical conduit types information of the project.
WireMaterialTypes | Get electrical wire material types information of the project.
WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypes Property

[image]

Revit 2011 API
ElectricalSetting..::.DistributionSysTypes Property
ElectricalSetting Class See Also Send Feedback
Get all distribution system types of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DistributionSysTypeSet DistributionSysTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistributionSysTypes As DistributionSysTypeSet
Visual C++
public:
property DistributionSysTypeSet^ DistributionSysTypes {
    DistributionSysTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypes Property

[image]

Revit 2011 API
ElectricalSetting..::.VoltageTypes Property
ElectricalSetting Class See Also Send Feedback
Get all voltage type definitions information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageTypeSet VoltageTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property VoltageTypes As VoltageTypeSet
Visual C++
public:
property VoltageTypeSet^ VoltageTypes {
    VoltageTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypes Property

[image]

Revit 2011 API
ElectricalSetting..::.WireConduitTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical conduit types information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireConduitTypeSet WireConduitTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireConduitTypes As WireConduitTypeSet
Visual C++
public:
property WireConduitTypeSet^ WireConduitTypes {
    WireConduitTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypes Property

[image]

Revit 2011 API
ElectricalSetting..::.WireMaterialTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical wire material types information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialTypeSet WireMaterialTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireMaterialTypes As WireMaterialTypeSet
Visual C++
public:
property WireMaterialTypeSet^ WireMaterialTypes {
    WireMaterialTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireTypes Property

[image]

Revit 2011 API
ElectricalSetting..::.WireTypes Property
ElectricalSetting Class See Also Send Feedback
Get all wire type definition information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireTypeSet WireTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireTypes As WireTypeSet
Visual C++
public:
property WireTypeSet^ WireTypes {
    WireTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Class

[image]

Revit 2011 API
ElectricalSystem Class
Members See Also Send Feedback
Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic (Declaration)
Public Class ElectricalSystem _
    Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Electrical..::.ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Members

[image] [image]

Revit 2011 API
ElectricalSystem Members
ElectricalSystem Class Methods Properties See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
ApparentLoad | Returns the ApparentLoad value of the Electrical System.
ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
BalancedLoad | Reports whether the BalancedLoad is on or off.
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CircuitNumber | Returns the CircuitNumber of the Electrical System.
CircuitType | Get the circuit type of the Electrical System.
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Length | Returns the Length value of the Electrical System.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassifications | Returns the LoadClassifications used in the Electrical System.
LoadName | Get/Set the LoadName of the Electrical System.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of the Electrical System. (Overrides Element..::.Name.)
NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
PanelName | Returns the Panel name of the Electrical System.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PolesNumber | Returns the Poles Number of the Electrical System.
PowerFactor | Returns the PowerFactor value of the Electrical System.
PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Rating | Get/Set the Rating value of the Electrical System.
RunsNumber | Returns the Runs Number of the Electrical System.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | Returns the Electrical System Type of the Electrical System.
TrueCurrent | Returns the TrueCurrent value of the Electrical System.
TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
TrueLoad | Returns the TrueLoad value of the Electrical System.
TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Voltage | Returns the Voltage value of the Electrical System.
VoltageDrop | Returns the VoltageDrop value of the Electrical System.
WireSizeString | Returns the WireSize as a String of the Electrical System.
WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Methods

[image] [image]

Revit 2011 API
ElectricalSystem Methods
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
AddToCircuit | Add a set of exist components to the Electrical System.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DisconnectPanel | Disconnect the panel for the Electrical System.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewWires | Create a bunch of wires for the electrical system.
Remove | Remove elements from system. (Inherited from MEPSystem.)
RemoveFromCircuit | remove a set of exist components from the Electrical System.
SelectPanel | Set the panel for the Electrical System.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


AddToCircuit Method

[image]

Revit 2011 API
ElectricalSystem..::.AddToCircuit Method
ElectricalSystem Class See Also Send Feedback
Add a set of exist components to the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AddToCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Function AddToCircuit ( _
    components As ElementSet _
) As Boolean
Visual C++
public:
bool AddToCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit.DB..::.ElementSet
The components added to the electrical system.

Return Value

If successful, all the components will add to the system. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Remarks

This method will only function with the Autodesk Revit MEP application.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


DisconnectPanel Method

[image]

Revit 2011 API
ElectricalSystem..::.DisconnectPanel Method
ElectricalSystem Class See Also Send Feedback
Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DisconnectPanel()
Visual Basic (Declaration)
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the panel parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the panel cannot be disconnected for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


NewWires Method

[image]

Revit 2011 API
ElectricalSystem..::.NewWires Method
ElectricalSystem Class See Also Send Feedback
Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic (Declaration)
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires(
    View^ view,
    WiringType wiringType
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view in which the wire is to be visible.
wiringType
Type: Autodesk.Revit.DB.Electrical..::.WiringType
Specify the wiring type(Arc or Chamfer) that is to be applied to all new created wires.

Return Value

New created wires

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | This method can just only be used to created a bunch of wires according to specific pairs of elements, so if there exists a nullNothingnullptra null reference (Nothing in Visual Basic) element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


RemoveFromCircuit Method

[image]

Revit 2011 API
ElectricalSystem..::.RemoveFromCircuit Method
ElectricalSystem Class See Also Send Feedback
remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveFromCircuit(
    ElementSet components
)
Visual Basic (Declaration)
Public Sub RemoveFromCircuit ( _
    components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit.DB..::.ElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the components parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the components cannot be removed from the system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


SelectPanel Method

[image]

Revit 2011 API
ElectricalSystem..::.SelectPanel Method
ElectricalSystem Class See Also Send Feedback
Set the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic (Declaration)
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel(
    FamilyInstance^ panel
)

Parameters

panel
Type: Autodesk.Revit.DB..::.FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the panel parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Properties

[image] [image]

Revit 2011 API
ElectricalSystem Properties
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Properties

Name | Description
ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
ApparentLoad | Returns the ApparentLoad value of the Electrical System.
ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
BalancedLoad | Reports whether the BalancedLoad is on or off.
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CircuitNumber | Returns the CircuitNumber of the Electrical System.
CircuitType | Get the circuit type of the Electrical System.
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Length | Returns the Length value of the Electrical System.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadClassifications | Returns the LoadClassifications used in the Electrical System.
LoadName | Get/Set the LoadName of the Electrical System.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns the Name of the Electrical System. (Overrides Element..::.Name.)
NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
PanelName | Returns the Panel name of the Electrical System.
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PolesNumber | Returns the Poles Number of the Electrical System.
PowerFactor | Returns the PowerFactor value of the Electrical System.
PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Rating | Get/Set the Rating value of the Electrical System.
RunsNumber | Returns the Runs Number of the Electrical System.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | Returns the Electrical System Type of the Electrical System.
TrueCurrent | Returns the TrueCurrent value of the Electrical System.
TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
TrueLoad | Returns the TrueLoad value of the Electrical System.
TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Voltage | Returns the Voltage value of the Electrical System.
VoltageDrop | Returns the VoltageDrop value of the Electrical System.
WireSizeString | Returns the WireSize as a String of the Electrical System.
WireType | Get/Set the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrent Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrent value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentCurrent { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrent As Double
Visual C++
public:
property double ApparentCurrent {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseA Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentCurrentPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseA As Double
Visual C++
public:
property double ApparentCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseB Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentCurrentPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseB As Double
Visual C++
public:
property double ApparentCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseC Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentCurrentPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentCurrentPhaseC As Double
Visual C++
public:
property double ApparentCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoad Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoad value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoad As Double
Visual C++
public:
property double ApparentLoad {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseA Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentLoadPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseA As Double
Visual C++
public:
property double ApparentLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseB Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentLoadPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseB As Double
Visual C++
public:
property double ApparentLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseC Property

[image]

Revit 2011 API
ElectricalSystem..::.ApparentLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ApparentLoadPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApparentLoadPhaseC As Double
Visual C++
public:
property double ApparentLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


BalancedLoad Property

[image]

Revit 2011 API
ElectricalSystem..::.BalancedLoad Property
ElectricalSystem Class See Also Send Feedback
Reports whether the BalancedLoad is on or off.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool BalancedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property BalancedLoad As Boolean
Visual C++
public:
property bool BalancedLoad {
    bool get ();
}

Remarks

This property is used to retrieve the BalancedLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


CircuitNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.CircuitNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the CircuitNumber of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string CircuitNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property CircuitNumber As String
Visual C++
public:
property String^ CircuitNumber {
    String^ get ();
}

Remarks

This property is used to retrieve the CircuitNumber of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


CircuitType Property

[image]

Revit 2011 API
ElectricalSystem..::.CircuitType Property
ElectricalSystem Class See Also Send Feedback
Get the circuit type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CircuitType CircuitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CircuitType As CircuitType
Visual C++
public:
property CircuitType CircuitType {
    CircuitType get ();
}

Remarks

This read-only property is used to retrieve the circuit type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorsNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.GroundConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the GroundConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GroundConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorsNumber As Integer
Visual C++
public:
property int GroundConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the GroundConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


HotConductorsNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.HotConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the HotConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int HotConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property HotConductorsNumber As Integer
Visual C++
public:
property int HotConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the HotConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Length Property

[image]

Revit 2011 API
ElectricalSystem..::.Length Property
ElectricalSystem Class See Also Send Feedback
Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the length cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


LoadClassifications Property

[image]

Revit 2011 API
ElectricalSystem..::.LoadClassifications Property
ElectricalSystem Class See Also Send Feedback
Returns the LoadClassifications used in the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LoadClassifications { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadClassifications As String
Visual C++
public:
property String^ LoadClassifications {
    String^ get ();
}

Remarks

This property is used to retrieve the LoadClassifications of the Electrical System. There may be one or more load classification in use in which case they will be semi-colon delimited.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


LoadName Property

[image]

Revit 2011 API
ElectricalSystem..::.LoadName Property
ElectricalSystem Class See Also Send Feedback
Get/Set the LoadName of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LoadName { get; set; }
Visual Basic (Declaration)
Public Property LoadName As String
Visual C++
public:
property String^ LoadName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to retrieve the LoadName of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2011 API
ElectricalSystem..::.Name Property
ElectricalSystem Class See Also Send Feedback
Returns the Name of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Remarks

This property is used to get or set the Name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


NeutralConductorsNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.NeutralConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the NeutralConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NeutralConductorsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property NeutralConductorsNumber As Integer
Visual C++
public:
property int NeutralConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the NeutralConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PanelName Property

[image]

Revit 2011 API
ElectricalSystem..::.PanelName Property
ElectricalSystem Class See Also Send Feedback
Returns the Panel name of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PanelName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelName As String
Visual C++
public:
property String^ PanelName {
    String^ get ();
}

Remarks

This property is used to retrieve the Panel name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
ElectricalSystem..::.Parameter Property
ElectricalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

ElectricalSystem Class
ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace


PolesNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.PolesNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Poles Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int PolesNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PolesNumber As Integer
Visual C++
public:
property int PolesNumber {
    int get ();
}

Remarks

This property is used to retrieve the Poles Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PowerFactor Property

[image]

Revit 2011 API
ElectricalSystem..::.PowerFactor Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactor value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double PowerFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property PowerFactor As Double
Visual C++
public:
property double PowerFactor {
    double get ();
}

Remarks

This property is used to retrieve the PowerFactor value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PowerFactorState Property

[image]

Revit 2011 API
ElectricalSystem..::.PowerFactorState Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactorState type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PowerFactorStateType PowerFactorState { get; }
Visual Basic (Declaration)
Public ReadOnly Property PowerFactorState As PowerFactorStateType
Visual C++
public:
property PowerFactorStateType PowerFactorState {
    PowerFactorStateType get ();
}

Remarks

This property is used to retrieve the PowerFactorState type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Rating Property

[image]

Revit 2011 API
ElectricalSystem..::.Rating Property
ElectricalSystem Class See Also Send Feedback
Get/Set the Rating value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Rating { get; set; }
Visual Basic (Declaration)
Public Property Rating As Double
Visual C++
public:
property double Rating {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the Rating value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


RunsNumber Property

[image]

Revit 2011 API
ElectricalSystem..::.RunsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Runs Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int RunsNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsNumber As Integer
Visual C++
public:
property int RunsNumber {
    int get ();
}

Remarks

This property is used to retrieve the Runs Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


SystemType Property

[image]

Revit 2011 API
ElectricalSystem..::.SystemType Property
ElectricalSystem Class See Also Send Feedback
Returns the Electrical System Type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As ElectricalSystemType
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
}

Remarks

This property is used to retrieve the Electrical System Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrent Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrent value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueCurrent { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrent As Double
Visual C++
public:
property double TrueCurrent {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseA Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueCurrentPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseA As Double
Visual C++
public:
property double TrueCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseB Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueCurrentPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseB As Double
Visual C++
public:
property double TrueCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseC Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueCurrentPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueCurrentPhaseC As Double
Visual C++
public:
property double TrueCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoad Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoad value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoad As Double
Visual C++
public:
property double TrueLoad {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseA Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueLoadPhaseA { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseA As Double
Visual C++
public:
property double TrueLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseB Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueLoadPhaseB { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseB As Double
Visual C++
public:
property double TrueLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseC Property

[image]

Revit 2011 API
ElectricalSystem..::.TrueLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double TrueLoadPhaseC { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrueLoadPhaseC As Double
Visual C++
public:
property double TrueLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Voltage Property

[image]

Revit 2011 API
ElectricalSystem..::.Voltage Property
ElectricalSystem Class See Also Send Feedback
Returns the Voltage value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Voltage { get; }
Visual Basic (Declaration)
Public ReadOnly Property Voltage As Double
Visual C++
public:
property double Voltage {
    double get ();
}

Remarks

This property is used to retrieve the Voltage value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


VoltageDrop Property

[image]

Revit 2011 API
ElectricalSystem..::.VoltageDrop Property
ElectricalSystem Class See Also Send Feedback
Returns the VoltageDrop value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double VoltageDrop { get; }
Visual Basic (Declaration)
Public ReadOnly Property VoltageDrop As Double
Visual C++
public:
property double VoltageDrop {
    double get ();
}

Remarks

This property is used to retrieve the VoltageDrop value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the voltage drop cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeString Property

[image]

Revit 2011 API
ElectricalSystem..::.WireSizeString Property
ElectricalSystem Class See Also Send Feedback
Returns the WireSize as a String of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string WireSizeString { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireSizeString As String
Visual C++
public:
property String^ WireSizeString {
    String^ get ();
}

Remarks

This property is used to retrieve the WireSize String of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


WireType Property

[image]

Revit 2011 API
ElectricalSystem..::.WireType Property
ElectricalSystem Class See Also Send Feedback
Get/Set the wire type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireType WireType { get; set; }
Visual Basic (Declaration)
Public Property WireType As WireType
Visual C++
public:
property WireType^ WireType {
    WireType^ get ();
    void set (WireType^ value);
}

Remarks

This property is used to retrieve the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Class

[image]

Revit 2011 API
ElectricalSystemSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ElectricalSystemSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ElectricalSystemSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElectricalSystemSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSet

See Also

ElectricalSystemSet Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Members

[image] [image]

Revit 2011 API
ElectricalSystemSet Members
ElectricalSystemSet Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Constructors

Name | Description
ElectricalSystemSet | Initializes a new instance of the ElectricalSystemSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Constructor

[image]

Revit 2011 API
ElectricalSystemSet Constructor
ElectricalSystemSet Class See Also Send Feedback
Initializes a new instance of the ElectricalSystemSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSet()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Methods

[image] [image]

Revit 2011 API
ElectricalSystemSet Methods
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
ElectricalSystemSet..::.Clear Method
ElectricalSystemSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
ElectricalSystemSet..::.Contains Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
ElectricalSystemSet..::.Erase Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As ElectricalSystem _
) As Integer
Visual C++
public:
virtual int Erase(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
ElectricalSystemSet..::.ForwardIterator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
ElectricalSystemSet..::.GetEnumerator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
ElectricalSystemSet..::.Insert Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    ElectricalSystem item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
ElectricalSystemSet..::.ReverseIterator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Properties

[image] [image]

Revit 2011 API
ElectricalSystemSet Properties
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
ElectricalSystemSet..::.IsEmpty Property
ElectricalSystemSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
ElectricalSystemSet..::.Size Property
ElectricalSystemSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Class

[image]

Revit 2011 API
ElectricalSystemSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ElectricalSystemSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ElectricalSystemSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElectricalSystemSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.ElectricalSystemSetIterator

See Also

ElectricalSystemSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Members

[image] [image]

Revit 2011 API
ElectricalSystemSetIterator Members
ElectricalSystemSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Constructors

Name | Description
ElectricalSystemSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Constructor

[image]

Revit 2011 API
ElectricalSystemSetIterator Constructor
ElectricalSystemSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystemSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElectricalSystemSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Methods

[image] [image]

Revit 2011 API
ElectricalSystemSetIterator Methods
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
ElectricalSystemSetIterator..::.MoveNext Method
ElectricalSystemSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
ElectricalSystemSetIterator..::.Reset Method
ElectricalSystemSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Properties

[image] [image]

Revit 2011 API
ElectricalSystemSetIterator Properties
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
ElectricalSystemSetIterator..::.Current Property
ElectricalSystemSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemType Enumeration

[image]

Revit 2011 API
ElectricalSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible electrical system types for an electrical connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ElectricalSystemType
Visual Basic (Declaration)
Public Enumeration ElectricalSystemType
Visual C++
public enum class ElectricalSystemType

Members

Member name | Description
UndefinedSystemType | Unknown system type
Data | Electrical System Type is Data.
PowerCircuit | Electrical System Type is PowerCircuit.
Telephone | Electrical System Type is Telephone.
Security | Electrical System Type is Security.
FireAlarm | Electrical System Type is FireAlarm.
NurseCall | Electrical System Type is NurseCall.
Controls | Electrical System Type is Controls.
Communication | Electrical System Type is Communication.
PowerBalanced | Electrical System Type is PowerBalanced.
PowerUnBalanced | Electrical System Type is PowerUnBalanced.

See Also

Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Class

[image]

Revit 2011 API
GroundConductorSize Class
Members See Also Send Feedback
Represents electrical ground conductor size definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GroundConductorSize : APIObject
Visual Basic (Declaration)
Public Class GroundConductorSize _
    Inherits APIObject
Visual C++
public ref class GroundConductorSize : public APIObject

Remarks

Ground conductor size is defined based on corresponding wire material type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.GroundConductorSize

See Also

GroundConductorSize Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Members

[image] [image]

Revit 2011 API
GroundConductorSize Members
GroundConductorSize Class Methods Properties See Also Send Feedback

The GroundConductorSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
ConductorSize | Get conductor size corresponding to specific ampacity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Methods

[image] [image]

Revit 2011 API
GroundConductorSize Methods
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Properties

[image] [image]

Revit 2011 API
GroundConductorSize Properties
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Properties

Name | Description
Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
ConductorSize | Get conductor size corresponding to specific ampacity.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


Ampacity Property

[image]

Revit 2011 API
GroundConductorSize..::.Ampacity Property
GroundConductorSize Class See Also Send Feedback
Get ampacity which is used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


ConductorSize Property

[image]

Revit 2011 API
GroundConductorSize..::.ConductorSize Property
GroundConductorSize Class See Also Send Feedback
Get conductor size corresponding to specific ampacity.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ConductorSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConductorSize As String
Visual C++
public:
property String^ ConductorSize {
    String^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


MaterialBelongTo Property

[image]

Revit 2011 API
GroundConductorSize..::.MaterialBelongTo Property
GroundConductorSize Class See Also Send Feedback
Get the material type which include this ground conductor size information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialType MaterialBelongTo { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialBelongTo As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialBelongTo {
    WireMaterialType^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Class

[image]

Revit 2011 API
GroundConductorSizeSet Class
Members See Also Send Feedback
A set that contains GroundConductorSizes.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class GroundConductorSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class GroundConductorSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroundConductorSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSet

See Also

GroundConductorSizeSet Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Members

[image] [image]

Revit 2011 API
GroundConductorSizeSet Members
GroundConductorSizeSet Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Constructors

Name | Description
GroundConductorSizeSet | Initializes a new instance of the GroundConductorSizeSet class

Methods

Name | Description
Clear | Removes every GroundConductorSize from the set, rendering it empty.
Contains | Tests for the existence of a GroundConductorSize within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GroundConductorSize from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified GroundConductorSize into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Constructor

[image]

Revit 2011 API
GroundConductorSizeSet Constructor
GroundConductorSizeSet Class See Also Send Feedback
Initializes a new instance of the GroundConductorSizeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroundConductorSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSet()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Methods

[image] [image]

Revit 2011 API
GroundConductorSizeSet Methods
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every GroundConductorSize from the set, rendering it empty.
Contains | Tests for the existence of a GroundConductorSize within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified GroundConductorSize from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified GroundConductorSize into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.Clear Method
GroundConductorSizeSet Class See Also Send Feedback
Removes every GroundConductorSize from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.Contains Method
GroundConductorSizeSet Class See Also Send Feedback
Tests for the existence of a GroundConductorSize within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.GroundConductorSize
The GroundConductorSize to be searched for.

Return Value

The Contains method returns True if the GroundConductorSize is within the set, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.Erase Method
GroundConductorSizeSet Class See Also Send Feedback
Removes a specified GroundConductorSize from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As GroundConductorSize _
) As Integer
Visual C++
public:
virtual int Erase(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.GroundConductorSize
The GroundConductorSize to be erased.

Return Value

The number of GroundConductorSizes that were erased from the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.ForwardIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.GetEnumerator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.Insert Method
GroundConductorSizeSet Class See Also Send Feedback
Insert the specified GroundConductorSize into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    GroundConductorSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.GroundConductorSize
The GroundConductorSize to be inserted into the set.

Return Value

Returns whether the GroundConductorSize was inserted into the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
GroundConductorSizeSet..::.ReverseIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Properties

[image] [image]

Revit 2011 API
GroundConductorSizeSet Properties
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
GroundConductorSizeSet..::.IsEmpty Property
GroundConductorSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
GroundConductorSizeSet..::.Size Property
GroundConductorSizeSet Class See Also Send Feedback
Returns the number of GroundConductorSizes that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Class

[image]

Revit 2011 API
GroundConductorSizeSetIterator Class
Members See Also Send Feedback
An iterator to a GroundConductorSize set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class GroundConductorSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class GroundConductorSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroundConductorSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.GroundConductorSizeSetIterator

See Also

GroundConductorSizeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Members

[image] [image]

Revit 2011 API
GroundConductorSizeSetIterator Members
GroundConductorSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Constructors

Name | Description
GroundConductorSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Constructor

[image]

Revit 2011 API
GroundConductorSizeSetIterator Constructor
GroundConductorSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroundConductorSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroundConductorSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Methods

[image] [image]

Revit 2011 API
GroundConductorSizeSetIterator Methods
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
GroundConductorSizeSetIterator..::.MoveNext Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
GroundConductorSizeSetIterator..::.Reset Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Properties

[image] [image]

Revit 2011 API
GroundConductorSizeSetIterator Properties
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
GroundConductorSizeSetIterator..::.Current Property
GroundConductorSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Class

[image]

Revit 2011 API
InsulationType Class
Members See Also Send Feedback
Represents electrical insulation type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InsulationType : ElementType
Visual Basic (Declaration)
Public Class InsulationType _
    Inherits ElementType
Visual C++
public ref class InsulationType : public ElementType

Remarks

Insulation type is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.InsulationType

See Also

InsulationType Members
Autodesk.Revit.DB.Electrical Namespace


InsulationType Members

[image] [image]

Revit 2011 API
InsulationType Members
InsulationType Class Methods Properties See Also Send Feedback

The InsulationType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the insulation type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of Insulation type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Methods

[image] [image]

Revit 2011 API
InsulationType Methods
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Properties

[image] [image]

Revit 2011 API
InsulationType Properties
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the insulation type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of Insulation type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
InsulationType..::.IsInUse Property
InsulationType Class See Also Send Feedback
Indicate whether the insulation type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2011 API
InsulationType..::.Name Property
InsulationType Class See Also Send Feedback
Get name of Insulation type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Set name can't be supported.

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
InsulationType..::.Parameter Property
InsulationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

InsulationType Class
InsulationType Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Class

[image]

Revit 2011 API
InsulationTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class InsulationTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class InsulationTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InsulationTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.InsulationTypeSet

See Also

InsulationTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Members

[image] [image]

Revit 2011 API
InsulationTypeSet Members
InsulationTypeSet Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Constructors

Name | Description
InsulationTypeSet | Initializes a new instance of the InsulationTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Constructor

[image]

Revit 2011 API
InsulationTypeSet Constructor
InsulationTypeSet Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InsulationTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSet()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Methods

[image] [image]

Revit 2011 API
InsulationTypeSet Methods
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
InsulationTypeSet..::.Clear Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
InsulationTypeSet..::.Contains Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
InsulationTypeSet..::.Erase Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As InsulationType _
) As Integer
Visual C++
public:
virtual int Erase(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
InsulationTypeSet..::.ForwardIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ForwardIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
InsulationTypeSet..::.GetEnumerator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
InsulationTypeSet..::.Insert Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    InsulationType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
InsulationTypeSet..::.ReverseIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ReverseIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Properties

[image] [image]

Revit 2011 API
InsulationTypeSet Properties
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
InsulationTypeSet..::.IsEmpty Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
InsulationTypeSet..::.Size Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Class

[image]

Revit 2011 API
InsulationTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class InsulationTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class InsulationTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InsulationTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.InsulationTypeSetIterator

See Also

InsulationTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Members

[image] [image]

Revit 2011 API
InsulationTypeSetIterator Members
InsulationTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Constructors

Name | Description
InsulationTypeSetIterator | Initializes a new instance of the InsulationTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Constructor

[image]

Revit 2011 API
InsulationTypeSetIterator Constructor
InsulationTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InsulationTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InsulationTypeSetIterator()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Methods

[image] [image]

Revit 2011 API
InsulationTypeSetIterator Methods
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
InsulationTypeSetIterator..::.MoveNext Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
InsulationTypeSetIterator..::.Reset Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Properties

[image] [image]

Revit 2011 API
InsulationTypeSetIterator Properties
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
InsulationTypeSetIterator..::.Current Property
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Class

[image]

Revit 2011 API
LightingDevice Class
Members See Also Send Feedback
Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic (Declaration)
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Members

[image] [image]

Revit 2011 API
LightingDevice Members
LightingDevice Class Methods Properties See Also Send Feedback

The LightingDevice type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Methods

[image] [image]

Revit 2011 API
LightingDevice Methods
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Properties

[image] [image]

Revit 2011 API
LightingDevice Properties
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Class

[image]

Revit 2011 API
LightingFixture Class
Members See Also Send Feedback
Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LightingFixture : MEPModel
Visual Basic (Declaration)
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Electrical..::.LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Members

[image] [image]

Revit 2011 API
LightingFixture Members
LightingFixture Class Methods Properties See Also Send Feedback

The LightingFixture type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Methods

[image] [image]

Revit 2011 API
LightingFixture Methods
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Properties

[image] [image]

Revit 2011 API
LightingFixture Properties
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LoadClassification Enumeration

[image]

Revit 2011 API
LoadClassification Enumeration
See Also Send Feedback
An enumerated type to list all demand factor classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum LoadClassification
Visual Basic (Declaration)
Public Enumeration LoadClassification
Visual C++
public enum class LoadClassification

Members

Member name | Description
Undefined | Load classification is undefined.
Power | Load classification is power.
Lighting | Load classification is lighting.
Hvac | Load classification is HVAC.

See Also

Autodesk.Revit.DB.Electrical Namespace


LoadClassificationType Enumeration

[image]

Revit 2011 API
LoadClassificationType Enumeration
See Also Send Feedback
An enumerated type listing all the possible load classification types for a connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum LoadClassificationType
Visual Basic (Declaration)
Public Enumeration LoadClassificationType
Visual C++
public enum class LoadClassificationType

Members

Member name | Description
Other | Load Classification Type is Other.
Power | Load Classification Type is Power.
Lighting | Load Classification Type is Lighting.
HVAC | Load Classification Type is HVAC.

See Also

Autodesk.Revit.DB.Electrical Namespace


NeutralMode Enumeration

[image]

Revit 2011 API
NeutralMode Enumeration
See Also Send Feedback
An enumerated type to list the neutral mode for wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum NeutralMode
Visual Basic (Declaration)
Public Enumeration NeutralMode
Visual C++
public enum class NeutralMode

Members

Member name | Description
HotConductorSize | Neutral Mode is HotConductorSize.
UnbalancedCurrent | Neutral Mode is UnbalancedCurrent.

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelConfiguration Enumeration

[image]

Revit 2011 API
PanelConfiguration Enumeration
See Also Send Feedback
This enum declares the configuration for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum PanelConfiguration
Visual Basic (Declaration)
Public Enumeration PanelConfiguration
Visual C++
public enum class PanelConfiguration

Members

Member name | Description
OneColumn | Circuits are numbered top-to-bottom in one single column.
TwoColumnsCircuitsAcross | Circuits are numbered left-to-right. The odd circuits down the left side, even circuits down the right side.
TwoColumnsCircuitsDown | Circuits are numbered top-to-bottom in one single column. First circuits down the left side, then the right side.

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Class

[image]

Revit 2011 API
PanelScheduleData Class
Members See Also Send Feedback
The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PanelScheduleData : TableData
Visual Basic (Declaration)
Public Class PanelScheduleData _
    Inherits TableData
Visual C++
public ref class PanelScheduleData : public TableData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.TableData
Autodesk.Revit.DB.Electrical..::.PanelScheduleData

See Also

PanelScheduleData Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Members

[image] [image]

Revit 2011 API
PanelScheduleData Members
PanelScheduleData Class Methods Properties See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

Name | Description
AddLoadClassification | add a Load Classification Id to the array of Load Classifications.
Dispose | (Inherited from TableData.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassifications | get an array of the load classifications associated with this panel schedule
GetNumberOfCircuitRows | returns the number of rows in the circuit table
GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
IsSymmetric | returns if this panel schedule is symmetric
RemoveLoadClassification | remove a Load Classification Id from the array of Load Classifications
SetLoadClassifications | sets the Load Classifications associated with this panel schedule
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCircuitTableForInstance | redraw the circuit table for the given panel with the given parameter updates
UpdateCircuitTableForTemplate | redraw the circuit table for a template with the given parameter updates
UpdateIsSectionHidden | update if this section is hidden or not
UpdateLoadSummary | update the load summary section
UpdateVerticalHeadersInSection | set if this header should have vertical text

Properties

Name | Description
BodyShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)
BorderAroundSchedule | places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
BorderAroundSections | places a border (GraphicStyle element) around each section, visible only on the instance and sheet
IsFooterSectionHidden | true if the user wishes to hide the footer section setting this value must go through the appropriate update function
IsHeaderSectionHidden | true if the user wishes to hide the header section setting this value must go through the appropriate update function
IsPanelSinglePhase | Identifies if the panel is single phase. If true, the panel is single phase. If false, the panel is 3-phase.
IsSummarySectionHidden | true if the user wishes to hide the summary section setting this value must go through the appropriate update function
IsThirdPhaseHidden | true if the user wishes to hide the 3rd phase column of a single phase panel
NumberOfSections | Gets the number of items in section data array. (Inherited from TableData.)
NumberOfSlots | number of slots in the panel schedule setting this value must go through the appropriate update function
PanelConfiguration | gets panel configuration of given panel schedule type.
PhaseLoadType | this property determines the layout of the phase load columns setting this value must go through the updateCircuitTable function
ScheduleType |
ShowCircuitNumberOnOneRowForMultiphaseCircuits | shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise only applicable to two column formats
ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise only applicable to one column formats
SummaryShowsGroups | show groups of load classifications in the load summary section
SummaryShowsOnlyConnectedLoads | show only the connected load classifications in the summary section
SummaryShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)
Width | Gets or sets the table width in feet (Inherited from TableData.)
WidthInPixels | Gets the width of the panel schedule in pixels (Inherited from TableData.)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Methods

[image] [image]

Revit 2011 API
PanelScheduleData Methods
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

Name | Description
AddLoadClassification | add a Load Classification Id to the array of Load Classifications.
Dispose | (Inherited from TableData.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassifications | get an array of the load classifications associated with this panel schedule
GetNumberOfCircuitRows | returns the number of rows in the circuit table
GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
IsSymmetric | returns if this panel schedule is symmetric
RemoveLoadClassification | remove a Load Classification Id from the array of Load Classifications
SetLoadClassifications | sets the Load Classifications associated with this panel schedule
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCircuitTableForInstance | redraw the circuit table for the given panel with the given parameter updates
UpdateCircuitTableForTemplate | redraw the circuit table for a template with the given parameter updates
UpdateIsSectionHidden | update if this section is hidden or not
UpdateLoadSummary | update the load summary section
UpdateVerticalHeadersInSection | set if this header should have vertical text

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


AddLoadClassification Method

[image]

Revit 2011 API
PanelScheduleData..::.AddLoadClassification Method
PanelScheduleData Class See Also Send Feedback
add a Load Classification Id to the array of Load Classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AddLoadClassification(
    ElementId loadClassficationId
)
Visual Basic (Declaration)
Public Function AddLoadClassification ( _
    loadClassficationId As ElementId _
) As Boolean
Visual C++
public:
bool AddLoadClassification(
    ElementId^ loadClassficationId
)

Parameters

loadClassficationId
Type: Autodesk.Revit.DB..::.ElementId

Return Value

true if success; false if the given Id has already existed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassifications Method

[image]

Revit 2011 API
PanelScheduleData..::.GetLoadClassifications Method
PanelScheduleData Class See Also Send Feedback
get an array of the load classifications associated with this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<ElementId> GetLoadClassifications()
Visual Basic (Declaration)
Public Function GetLoadClassifications As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetLoadClassifications()

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


GetNumberOfCircuitRows Method

[image]

Revit 2011 API
PanelScheduleData..::.GetNumberOfCircuitRows Method
PanelScheduleData Class See Also Send Feedback
returns the number of rows in the circuit table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetNumberOfCircuitRows()
Visual Basic (Declaration)
Public Function GetNumberOfCircuitRows As Integer
Visual C++
public:
int GetNumberOfCircuitRows()

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsSymmetric Method

[image]

Revit 2011 API
PanelScheduleData..::.IsSymmetric Method
PanelScheduleData Class See Also Send Feedback
returns if this panel schedule is symmetric

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSymmetric()
Visual Basic (Declaration)
Public Function IsSymmetric As Boolean
Visual C++
public:
bool IsSymmetric()

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


RemoveLoadClassification Method

[image]

Revit 2011 API
PanelScheduleData..::.RemoveLoadClassification Method
PanelScheduleData Class See Also Send Feedback
remove a Load Classification Id from the array of Load Classifications

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveLoadClassification(
    int nIndex
)
Visual Basic (Declaration)
Public Sub RemoveLoadClassification ( _
    nIndex As Integer _
)
Visual C++
public:
void RemoveLoadClassification(
    int nIndex
)

Parameters

nIndex
Type: System..::.Int32

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SetLoadClassifications Method

[image]

Revit 2011 API
PanelScheduleData..::.SetLoadClassifications Method
PanelScheduleData Class See Also Send Feedback
sets the Load Classifications associated with this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLoadClassifications(
    IList<ElementId> loadClassificaions
)
Visual Basic (Declaration)
Public Sub SetLoadClassifications ( _
    loadClassificaions As IList(Of ElementId) _
)
Visual C++
public:
void SetLoadClassifications(
    IList<ElementId^>^ loadClassificaions
)

Parameters

loadClassificaions
Type: System.Collections.Generic..::.IList <(Of <( ElementId >)>)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateCircuitTableForInstance Method

[image]

Revit 2011 API
PanelScheduleData..::.UpdateCircuitTableForInstance Method
PanelScheduleData Class See Also Send Feedback
redraw the circuit table for the given panel with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateCircuitTableForInstance(
    FamilyInstance pPanel
)
Visual Basic (Declaration)
Public Sub UpdateCircuitTableForInstance ( _
    pPanel As FamilyInstance _
)
Visual C++
public:
void UpdateCircuitTableForInstance(
    FamilyInstance^ pPanel
)

Parameters

pPanel
Type: Autodesk.Revit.DB..::.FamilyInstance
the panel that this circuit table is being drawn for

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateCircuitTableForTemplate Method

[image]

Revit 2011 API
PanelScheduleData..::.UpdateCircuitTableForTemplate Method
PanelScheduleData Class See Also Send Feedback
redraw the circuit table for a template with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots
)
Visual Basic (Declaration)
Public Sub UpdateCircuitTableForTemplate ( _
    newType As PanelSchedulePhaseLoadType, _
    nNumSlots As Integer _
)
Visual C++
public:
void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots
)

Parameters

newType
Type: Autodesk.Revit.DB.Electrical..::.PanelSchedulePhaseLoadType
the new phase load type of the circuit table
nNumSlots
Type: System..::.Int32
the number of circuit slots

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateIsSectionHidden Method

[image]

Revit 2011 API
PanelScheduleData..::.UpdateIsSectionHidden Method
PanelScheduleData Class See Also Send Feedback
update if this section is hidden or not

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateIsSectionHidden(
    SectionType sectionType,
    bool bHide
)
Visual Basic (Declaration)
Public Sub UpdateIsSectionHidden ( _
    sectionType As SectionType, _
    bHide As Boolean _
)
Visual C++
public:
void UpdateIsSectionHidden(
    SectionType sectionType,
    bool bHide
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
bHide
Type: System..::.Boolean

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateLoadSummary Method

[image]

Revit 2011 API
PanelScheduleData..::.UpdateLoadSummary Method
PanelScheduleData Class See Also Send Feedback
update the load summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateLoadSummary()
Visual Basic (Declaration)
Public Sub UpdateLoadSummary
Visual C++
public:
void UpdateLoadSummary()

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateVerticalHeadersInSection Method

[image]

Revit 2011 API
PanelScheduleData..::.UpdateVerticalHeadersInSection Method
PanelScheduleData Class See Also Send Feedback
set if this header should have vertical text

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void UpdateVerticalHeadersInSection(
    SectionType sectionType,
    bool bVertical
)
Visual Basic (Declaration)
Public Sub UpdateVerticalHeadersInSection ( _
    sectionType As SectionType, _
    bVertical As Boolean _
)
Visual C++
public:
void UpdateVerticalHeadersInSection(
    SectionType sectionType,
    bool bVertical
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
bVertical
Type: System..::.Boolean

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Properties

[image] [image]

Revit 2011 API
PanelScheduleData Properties
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Properties

Name | Description
BodyShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)
BorderAroundSchedule | places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
BorderAroundSections | places a border (GraphicStyle element) around each section, visible only on the instance and sheet
IsFooterSectionHidden | true if the user wishes to hide the footer section setting this value must go through the appropriate update function
IsHeaderSectionHidden | true if the user wishes to hide the header section setting this value must go through the appropriate update function
IsPanelSinglePhase | Identifies if the panel is single phase. If true, the panel is single phase. If false, the panel is 3-phase.
IsSummarySectionHidden | true if the user wishes to hide the summary section setting this value must go through the appropriate update function
IsThirdPhaseHidden | true if the user wishes to hide the 3rd phase column of a single phase panel
NumberOfSections | Gets the number of items in section data array. (Inherited from TableData.)
NumberOfSlots | number of slots in the panel schedule setting this value must go through the appropriate update function
PanelConfiguration | gets panel configuration of given panel schedule type.
PhaseLoadType | this property determines the layout of the phase load columns setting this value must go through the updateCircuitTable function
ScheduleType |
ShowCircuitNumberOnOneRowForMultiphaseCircuits | shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise only applicable to two column formats
ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise only applicable to one column formats
SummaryShowsGroups | show groups of load classifications in the load summary section
SummaryShowsOnlyConnectedLoads | show only the connected load classifications in the summary section
SummaryShowsVerticalHeaders | setting this value must go through the appropriate update function (updateVerticalHeadersInSection)
Width | Gets or sets the table width in feet (Inherited from TableData.)
WidthInPixels | Gets the width of the panel schedule in pixels (Inherited from TableData.)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BodyShowsVerticalHeaders Property

[image]

Revit 2011 API
PanelScheduleData..::.BodyShowsVerticalHeaders Property
PanelScheduleData Class See Also Send Feedback
setting this value must go through the appropriate update function (updateVerticalHeadersInSection)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool BodyShowsVerticalHeaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property BodyShowsVerticalHeaders As Boolean
Visual C++
public:
property bool BodyShowsVerticalHeaders {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BorderAroundSchedule Property

[image]

Revit 2011 API
PanelScheduleData..::.BorderAroundSchedule Property
PanelScheduleData Class See Also Send Feedback
places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderAroundSchedule { get; set; }
Visual Basic (Declaration)
Public Property BorderAroundSchedule As ElementId
Visual C++
public:
property ElementId^ BorderAroundSchedule {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BorderAroundSections Property

[image]

Revit 2011 API
PanelScheduleData..::.BorderAroundSections Property
PanelScheduleData Class See Also Send Feedback
places a border (GraphicStyle element) around each section, visible only on the instance and sheet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId BorderAroundSections { get; set; }
Visual Basic (Declaration)
Public Property BorderAroundSections As ElementId
Visual C++
public:
property ElementId^ BorderAroundSections {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsFooterSectionHidden Property

[image]

Revit 2011 API
PanelScheduleData..::.IsFooterSectionHidden Property
PanelScheduleData Class See Also Send Feedback
true if the user wishes to hide the footer section setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsFooterSectionHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFooterSectionHidden As Boolean
Visual C++
public:
property bool IsFooterSectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsHeaderSectionHidden Property

[image]

Revit 2011 API
PanelScheduleData..::.IsHeaderSectionHidden Property
PanelScheduleData Class See Also Send Feedback
true if the user wishes to hide the header section setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsHeaderSectionHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHeaderSectionHidden As Boolean
Visual C++
public:
property bool IsHeaderSectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsPanelSinglePhase Property

[image]

Revit 2011 API
PanelScheduleData..::.IsPanelSinglePhase Property
PanelScheduleData Class See Also Send Feedback
Identifies if the panel is single phase. If true, the panel is single phase. If false, the panel is 3-phase.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPanelSinglePhase { get; set; }
Visual Basic (Declaration)
Public Property IsPanelSinglePhase As Boolean
Visual C++
public:
property bool IsPanelSinglePhase {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsSummarySectionHidden Property

[image]

Revit 2011 API
PanelScheduleData..::.IsSummarySectionHidden Property
PanelScheduleData Class See Also Send Feedback
true if the user wishes to hide the summary section setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSummarySectionHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSummarySectionHidden As Boolean
Visual C++
public:
property bool IsSummarySectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsThirdPhaseHidden Property

[image]

Revit 2011 API
PanelScheduleData..::.IsThirdPhaseHidden Property
PanelScheduleData Class See Also Send Feedback
true if the user wishes to hide the 3rd phase column of a single phase panel

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsThirdPhaseHidden { get; set; }
Visual Basic (Declaration)
Public Property IsThirdPhaseHidden As Boolean
Visual C++
public:
property bool IsThirdPhaseHidden {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


NumberOfSlots Property

[image]

Revit 2011 API
PanelScheduleData..::.NumberOfSlots Property
PanelScheduleData Class See Also Send Feedback
number of slots in the panel schedule setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfSlots { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSlots As Integer
Visual C++
public:
property int NumberOfSlots {
    int get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelConfiguration Property

[image]

Revit 2011 API
PanelScheduleData..::.PanelConfiguration Property
PanelScheduleData Class See Also Send Feedback
gets panel configuration of given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelConfiguration PanelConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property PanelConfiguration As PanelConfiguration
Visual C++
public:
property PanelConfiguration PanelConfiguration {
    PanelConfiguration get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PhaseLoadType Property

[image]

Revit 2011 API
PanelScheduleData..::.PhaseLoadType Property
PanelScheduleData Class See Also Send Feedback
this property determines the layout of the phase load columns setting this value must go through the updateCircuitTable function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelSchedulePhaseLoadType PhaseLoadType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhaseLoadType As PanelSchedulePhaseLoadType
Visual C++
public:
property PanelSchedulePhaseLoadType PhaseLoadType {
    PanelSchedulePhaseLoadType get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ScheduleType Property

[image]

Revit 2011 API
PanelScheduleData..::.ScheduleType Property
PanelScheduleData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelScheduleType ScheduleType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScheduleType As PanelScheduleType
Visual C++
public:
property PanelScheduleType ScheduleType {
    PanelScheduleType get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ShowCircuitNumberOnOneRowForMultiphaseCircuits Property

[image]

Revit 2011 API
PanelScheduleData..::.ShowCircuitNumberOnOneRowForMultiphaseCircuits Property
PanelScheduleData Class See Also Send Feedback
shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise only applicable to two column formats

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ShowCircuitNumberOnOneRowForMultiphaseCircuits { get; set; }
Visual Basic (Declaration)
Public Property ShowCircuitNumberOnOneRowForMultiphaseCircuits As Boolean
Visual C++
public:
property bool ShowCircuitNumberOnOneRowForMultiphaseCircuits {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ShowMultipleRowsForMultiphaseCircuits Property

[image]

Revit 2011 API
PanelScheduleData..::.ShowMultipleRowsForMultiphaseCircuits Property
PanelScheduleData Class See Also Send Feedback
shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise only applicable to one column formats

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ShowMultipleRowsForMultiphaseCircuits { get; set; }
Visual Basic (Declaration)
Public Property ShowMultipleRowsForMultiphaseCircuits As Boolean
Visual C++
public:
property bool ShowMultipleRowsForMultiphaseCircuits {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsGroups Property

[image]

Revit 2011 API
PanelScheduleData..::.SummaryShowsGroups Property
PanelScheduleData Class See Also Send Feedback
show groups of load classifications in the load summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SummaryShowsGroups { get; set; }
Visual Basic (Declaration)
Public Property SummaryShowsGroups As Boolean
Visual C++
public:
property bool SummaryShowsGroups {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsOnlyConnectedLoads Property

[image]

Revit 2011 API
PanelScheduleData..::.SummaryShowsOnlyConnectedLoads Property
PanelScheduleData Class See Also Send Feedback
show only the connected load classifications in the summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SummaryShowsOnlyConnectedLoads { get; set; }
Visual Basic (Declaration)
Public Property SummaryShowsOnlyConnectedLoads As Boolean
Visual C++
public:
property bool SummaryShowsOnlyConnectedLoads {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsVerticalHeaders Property

[image]

Revit 2011 API
PanelScheduleData..::.SummaryShowsVerticalHeaders Property
PanelScheduleData Class See Also Send Feedback
setting this value must go through the appropriate update function (updateVerticalHeadersInSection)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SummaryShowsVerticalHeaders { get; }
Visual Basic (Declaration)
Public ReadOnly Property SummaryShowsVerticalHeaders As Boolean
Visual C++
public:
property bool SummaryShowsVerticalHeaders {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelSchedulePhaseLoadType Enumeration

[image]

Revit 2011 API
PanelSchedulePhaseLoadType Enumeration
See Also Send Feedback
Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum PanelSchedulePhaseLoadType
Visual Basic (Declaration)
Public Enumeration PanelSchedulePhaseLoadType
Visual C++
public enum class PanelSchedulePhaseLoadType

Members

Member name | Description
NoLoadInformation | No load information
LoadsByPhaseInSplitColumns | | Ckt | A | B | C | Ckt | | 1 | 100 | 200 | x | x | x | x | 2 |
MirroredPhaseColumns | | Ckt | A | B | C | A | B | C | Ckt | | 1 | 100 | x | x | 200 | x | x | 2 |
LoadsByPhaseInSharedColumns | | Ckt | A | B | C | Ckt | | 1 | 100/200 | x | x | 2 |
LoadsByPhase | | Ckt | A | B | C | Ckt | | 1 | 100 | x | x | | | | 200 | x | x | 2 |
TotalLoadOnlyPerCircuit | | Ckt | Load | | 1 | 100 | | 2 | 200 |
SeperatePhaseLoadsPerCircuit | | Ckt | A | B | C | | 1 | 100 | 0 | 0 | | 2 | 200 | 0 | 0 |

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Class

[image]

Revit 2011 API
PanelScheduleSheetInstance Class
Members See Also Send Feedback
The class represents an instance of a panel schedule placed on sheet.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class PanelScheduleSheetInstance : Element
Visual Basic (Declaration)
Public Class PanelScheduleSheetInstance _
    Inherits Element
Visual C++
public ref class PanelScheduleSheetInstance : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.PanelScheduleSheetInstance

See Also

PanelScheduleSheetInstance Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Members

[image] [image]

Revit 2011 API
PanelScheduleSheetInstance Members
PanelScheduleSheetInstance Class Methods Properties See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of panel schedule on sheet and adds it to the document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSchedule | Gets the panel schedule view.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The sheet instance offset in drawing sheet coordinates.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ScheduleId | The panel schedule id.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Methods

[image] [image]

Revit 2011 API
PanelScheduleSheetInstance Methods
PanelScheduleSheetInstance Class See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new instance of panel schedule on sheet and adds it to the document.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetSchedule | Gets the panel schedule view.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
PanelScheduleSheetInstance..::.Create Method
PanelScheduleSheetInstance Class See Also Send Feedback
Creates a new instance of panel schedule on sheet and adds it to the document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static PanelScheduleSheetInstance Create(
    Document ADoc,
    ElementId scheduleId,
    View DBView
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    ADoc As Document, _
    scheduleId As ElementId, _
    DBView As View _
) As PanelScheduleSheetInstance
Visual C++
public:
static PanelScheduleSheetInstance^ Create(
    Document^ ADoc,
    ElementId^ scheduleId,
    View^ DBView
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
scheduleId
Type: Autodesk.Revit.DB..::.ElementId
DBView
Type: Autodesk.Revit.DB..::.View

Return Value

The newly created panel schedule sheet instance element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


GetSchedule Method

[image]

Revit 2011 API
PanelScheduleSheetInstance..::.GetSchedule Method
PanelScheduleSheetInstance Class See Also Send Feedback
Gets the panel schedule view.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public PanelScheduleView GetSchedule()
Visual Basic (Declaration)
Public Function GetSchedule As PanelScheduleView
Visual C++
public:
PanelScheduleView^ GetSchedule()

Return Value

The panel schedule view element.

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Properties

[image] [image]

Revit 2011 API
PanelScheduleSheetInstance Properties
PanelScheduleSheetInstance Class See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The sheet instance offset in drawing sheet coordinates.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ScheduleId | The panel schedule id.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Origin Property

[image]

Revit 2011 API
PanelScheduleSheetInstance..::.Origin Property
PanelScheduleSheetInstance Class See Also Send Feedback
The sheet instance offset in drawing sheet coordinates.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As XYZ
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
PanelScheduleSheetInstance..::.Parameter Property
PanelScheduleSheetInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
PanelScheduleSheetInstance Members
Autodesk.Revit.DB.Electrical Namespace


ScheduleId Property

[image]

Revit 2011 API
PanelScheduleSheetInstance..::.ScheduleId Property
PanelScheduleSheetInstance Class See Also Send Feedback
The panel schedule id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId ScheduleId { get; set; }
Visual Basic (Declaration)
Public Property ScheduleId As ElementId
Visual C++
public:
property ElementId^ ScheduleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Class

[image]

Revit 2011 API
PanelScheduleTemplate Class
Members See Also Send Feedback
The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PanelScheduleTemplate : Element
Visual Basic (Declaration)
Public Class PanelScheduleTemplate _
    Inherits Element
Visual C++
public ref class PanelScheduleTemplate : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate

See Also

PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Members

[image] [image]

Revit 2011 API
PanelScheduleTemplate Members
PanelScheduleTemplate Class Methods Properties See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CopyFrom | Copies all values from other element to this object.
Create | Creates a new instance of a panel schedule template.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanelScheduleType | Returns the panel schedule type.
GetSectionData | ONLY call this function when you WILL change the section data object
GetTableData | ONLY call this function when you WILL change the table data object
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HasSameType | Checks if given template has the same panel schedule type with this template.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
IsValidType | Overloaded.
SetTableData | Assigns table data to this template
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
IsDefault | Checks to see if this is default template for the given panel schedule type.
IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Methods

[image] [image]

Revit 2011 API
PanelScheduleTemplate Methods
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CopyFrom | Copies all values from other element to this object.
Create | Creates a new instance of a panel schedule template.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanelScheduleType | Returns the panel schedule type.
GetSectionData | ONLY call this function when you WILL change the section data object
GetTableData | ONLY call this function when you WILL change the table data object
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
HasSameType | Checks if given template has the same panel schedule type with this template.
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
IsValidType | Overloaded.
SetTableData | Assigns table data to this template
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


CopyFrom Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.CopyFrom Method
PanelScheduleTemplate Class See Also Send Feedback
Copies all values from other element to this object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void CopyFrom(
    PanelScheduleTemplate otherElem
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    otherElem As PanelScheduleTemplate _
)
Visual C++
public:
void CopyFrom(
    PanelScheduleTemplate^ otherElem
)

Parameters

otherElem
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate
The element being copied from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The given template otherElem has different type of this element.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.Create Method
PanelScheduleTemplate Class See Also Send Feedback
Creates a new instance of a panel schedule template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static PanelScheduleTemplate Create(
    Document document,
    PanelScheduleType type,
    PanelConfiguration config,
    string strName
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    document As Document, _
    type As PanelScheduleType, _
    config As PanelConfiguration, _
    strName As String _
) As PanelScheduleTemplate
Visual C++
public:
static PanelScheduleTemplate^ Create(
    Document^ document,
    PanelScheduleType type,
    PanelConfiguration config,
    String^ strName
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
The document where the element will be created and added.
type
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleType
The panel schedule type.
config
Type: Autodesk.Revit.DB.Electrical..::.PanelConfiguration
The panel configuration type.
strName
Type: System..::.String
The name of the panel schedule template to be created.

Return Value

The newly created panel schedule template element.

Remarks

If the given name has already been used by existing panel schedule templates, a unique name will be used for the newly created template.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | The type is not valid for this element. -or- The config is not valid for panel schedule type type of this template.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetPanelScheduleType Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.GetPanelScheduleType Method
PanelScheduleTemplate Class See Also Send Feedback
Returns the panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelScheduleType GetPanelScheduleType()
Visual Basic (Declaration)
Public Function GetPanelScheduleType As PanelScheduleType
Visual C++
public:
PanelScheduleType GetPanelScheduleType()

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetSectionData Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.GetSectionData Method
PanelScheduleTemplate Class See Also Send Feedback
ONLY call this function when you WILL change the section data object

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    SectionType sectionType
)
Visual Basic (Declaration)
Public Function GetSectionData ( _
    sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetTableData Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.GetTableData Method
PanelScheduleTemplate Class See Also Send Feedback
ONLY call this function when you WILL change the table data object

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelScheduleData GetTableData()
Visual Basic (Declaration)
Public Function GetTableData As PanelScheduleData
Visual C++
public:
PanelScheduleData^ GetTableData()

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


HasSameType Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.HasSameType Method
PanelScheduleTemplate Class See Also Send Feedback
Checks if given template has the same panel schedule type with this template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasSameType(
    PanelScheduleTemplate otherTemplate
)
Visual Basic (Declaration)
Public Function HasSameType ( _
    otherTemplate As PanelScheduleTemplate _
) As Boolean
Visual C++
public:
bool HasSameType(
    PanelScheduleTemplate^ otherTemplate
)

Parameters

otherTemplate
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleTemplate
The given template to check.

Return Value

True if the given template has the same panel schedule type with this template, false otherwise.

Remarks

The panel schedule type is the enum type of PanelScheduleType class (Branch, switchboard, data etc.)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsValidPanelConfiguration Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsValidPanelConfiguration Method
PanelScheduleTemplate Class See Also Send Feedback
Checks if given panel configuration is valid for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)
Visual Basic (Declaration)
Public Shared Function IsValidPanelConfiguration ( _
    scheduleType As PanelScheduleType, _
    configuration As PanelConfiguration _
) As Boolean
Visual C++
public:
static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)

Parameters

scheduleType
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleType
The panel schedule type.
configuration
Type: Autodesk.Revit.DB.Electrical..::.PanelConfiguration
The given configuration to check.

Return Value

True if panel schedule template can have a valid configuration assigned, false otherwise.

Remarks

If the panel schedule type is branch panel, the valid panel configurations are:
PanelConfiguration::Enum::OneColumn
PanelConfiguration::Enum::TwoColumnsCircuitsAcross
PanelConfiguration::Enum::TwoColumnsCircuitsDown
If the panel schedule type is switchboard or data panel, the valid panel configuration is:
PanelConfiguration::Enum::OneColumn

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsValidType Method

[image] [image]

Revit 2011 API
PanelScheduleTemplate..::.IsValidType Method
PanelScheduleTemplate Class See Also Send Feedback

Overload List

Name | Description
IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.

See Also

PanelScheduleTemplate Class
PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


IsValidType Method (PanelScheduleType)

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsValidType Method (PanelScheduleType)
PanelScheduleTemplate Class See Also Send Feedback
Checks if given type is valid for this panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidType(
    PanelScheduleType panelScheduleType
)
Visual Basic (Declaration)
Public Shared Function IsValidType ( _
    panelScheduleType As PanelScheduleType _
) As Boolean
Visual C++
public:
static bool IsValidType(
    PanelScheduleType panelScheduleType
)

Parameters

panelScheduleType
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleType
The given type to check.

Return Value

True if panel schedule template can have a type assigned and this type is valid for this element, false otherwise.

Remarks

A type is valid for a panel schedule template element if it is defined by the PanelScheduleType class. Note: PanelScheduleType::Enum::Unknown is not a valid type, it is used for initializing the variable of the PanelScheduleType::Enum.

See Also

PanelScheduleTemplate Class
IsValidType Overload
Autodesk.Revit.DB.Electrical Namespace


SetTableData Method

[image]

Revit 2011 API
PanelScheduleTemplate..::.SetTableData Method
PanelScheduleTemplate Class See Also Send Feedback
Assigns table data to this template

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetTableData(
    PanelScheduleData Data
)
Visual Basic (Declaration)
Public Sub SetTableData ( _
    Data As PanelScheduleData _
)
Visual C++
public:
void SetTableData(
    PanelScheduleData^ Data
)

Parameters

Data
Type: Autodesk.Revit.DB.Electrical..::.PanelScheduleData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Properties

[image] [image]

Revit 2011 API
PanelScheduleTemplate Properties
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
IsDefault | Checks to see if this is default template for the given panel schedule type.
IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsBranchPanelSchedule Property

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsBranchPanelSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is branch panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsBranchPanelSchedule { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBranchPanelSchedule As Boolean
Visual C++
public:
property bool IsBranchPanelSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsDataPanelSchedule Property

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsDataPanelSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is data panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDataPanelSchedule { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDataPanelSchedule As Boolean
Visual C++
public:
property bool IsDataPanelSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsDefault Property

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsDefault Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this is default template for the given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDefault { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDefault As Boolean
Visual C++
public:
property bool IsDefault {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsSwitchboardSchedule Property

[image]

Revit 2011 API
PanelScheduleTemplate..::.IsSwitchboardSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is switchboard schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSwitchboardSchedule { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSwitchboardSchedule As Boolean
Visual C++
public:
property bool IsSwitchboardSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
PanelScheduleTemplate..::.Parameter Property
PanelScheduleTemplate Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleType Enumeration

[image]

Revit 2011 API
PanelScheduleType Enumeration
See Also Send Feedback
This enum declares the panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum PanelScheduleType
Visual Basic (Declaration)
Public Enumeration PanelScheduleType
Visual C++
public enum class PanelScheduleType

Members

Member name | Description
Unknown | Unknown panel schedule
Branch | Branch panel schedule
Switchboard | Switchboard schedule
Data | Data panel schedule

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Class

[image]

Revit 2011 API
PanelScheduleView Class
Members See Also Send Feedback
An instance of a panel schedule view.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PanelScheduleView : TableView
Visual Basic (Declaration)
Public Class PanelScheduleView _
    Inherits TableView
Visual C++
public ref class PanelScheduleView : public TableView

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.View
Autodesk.Revit.DB..::.TableView
Autodesk.Revit.DB.Electrical..::.PanelScheduleView

See Also

PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Members

[image] [image]

Revit 2011 API
PanelScheduleView Members
PanelScheduleView Class Methods Properties See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

Name | Description
AddFontId | adds a unique combination of font name, size, and color within the table view to the font table
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateInstanceView | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GenerateInstanceFromTemplate | actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetApparentLoad | get the apparent load for the given phase for the given slotted circuit
GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
GetAvailableParameters | Get available parameters for the specified category. (Inherited from TableView.)
GetCalculatedValueName | Returns the calculated value name for template view (Inherited from TableView.)
GetCalculatedValueText | Returns the calculated value text for instance view (Inherited from TableView.)
GetCellText | gets the cell's text based on its type Row Number in the Section Column Number in the Section
GetCircuitByCell | gets the circuit element for the given slot number Row Number of the Body Section Column Number of the Body Section
GetCircuitIdByCell | gets the circuit id for the given slot number Row Number Column Number
GetCombinedParamValue | Returns the combined parameter text for instance view Row Number of the Section Column Number of the Section
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFontId | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassificationConnectedCurrent | get the Total Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationConnectedLoad | get the Total Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandCurrent | get the Demand Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandFactor | get the Demand Factor for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandLoad | get the Demand Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationId | get the id of the associated LC at the given row Row number of Load Summary Section
GetLoadClassificationName | get the name of the Load Classification at the given row/col Row Number of the Load Summary Section Column number of Load Summary Section
GetLoadClassificationParamValue | Gets the load classification parameter value. Row Number of the Load Summary Section Column number of Load Summary Section
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanel | get the panel for this view
GetParamValue | gets the cell's text based on its type Row Number of the Section Column Number of the Section
GetSectionData | gets section data that can be written to
GetSlotNumberByCell | gets the slot number in the circuit table Row Number Column Number
GetTableData | gets table data that can be written to
GetTemplate | get the template for this view (to set the template, you must go through generateInstanceFromTemplate)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsCellInPhaseLoads | is this cell in the phase loads Row Number Column Number
IsColumnInLoadSummary | is this column in the load summary
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam | (Inherited from TableView.)
IsPanelScheduleTemplate | returns true if this is a panel schedule template, false if it is an instance
IsRowInCircuitTable | is this row in the circuit table
IsSlotGrouped | is the slot in a group? (0 = no, >0 = the group number)
IsSlotLocked | is the circuit slot in this cell locked?
IsSpace | is the selected cell space? Row Number Column Number
IsSpare | is the circuit spare? Circuit Table Row Number Circuit Table Column Number
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
SetParamValue | sets the text for the given cell, returns true if successful, false otherwise Row Number of the Section Column Number of the Section
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumColumnWidth | Gets the minimum column width (Inherited from TableView.)
MinimumRowHeight | Gets the minimum row height (Inherited from TableView.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
TargetId | the element id of the element that is being viewed (Inherited from TableView.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Methods

[image] [image]

Revit 2011 API
PanelScheduleView Methods
PanelScheduleView Class See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

Name | Description
AddFontId | adds a unique combination of font name, size, and color within the table view to the font table
ApplyTemplate | Applies a view template to the view. (Inherited from View.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
CreateInstanceView | Overloaded.
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GenerateInstanceFromTemplate | actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetApparentLoad | get the apparent load for the given phase for the given slotted circuit
GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
GetAvailableParameters | Get available parameters for the specified category. (Inherited from TableView.)
GetCalculatedValueName | Returns the calculated value name for template view (Inherited from TableView.)
GetCalculatedValueText | Returns the calculated value text for instance view (Inherited from TableView.)
GetCellText | gets the cell's text based on its type Row Number in the Section Column Number in the Section
GetCircuitByCell | gets the circuit element for the given slot number Row Number of the Body Section Column Number of the Body Section
GetCircuitIdByCell | gets the circuit id for the given slot number Row Number Column Number
GetCombinedParamValue | Returns the combined parameter text for instance view Row Number of the Section Column Number of the Section
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFontId | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLoadClassificationConnectedCurrent | get the Total Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationConnectedLoad | get the Total Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandCurrent | get the Demand Current for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandFactor | get the Demand Factor for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationDemandLoad | get the Demand Load for given LC Row number of Load Summary Section Column number of Load Summary Section
GetLoadClassificationId | get the id of the associated LC at the given row Row number of Load Summary Section
GetLoadClassificationName | get the name of the Load Classification at the given row/col Row Number of the Load Summary Section Column number of Load Summary Section
GetLoadClassificationParamValue | Gets the load classification parameter value. Row Number of the Load Summary Section Column number of Load Summary Section
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPanel | get the panel for this view
GetParamValue | gets the cell's text based on its type Row Number of the Section Column Number of the Section
GetSectionData | gets section data that can be written to
GetSlotNumberByCell | gets the slot number in the circuit table Row Number Column Number
GetTableData | gets table data that can be written to
GetTemplate | get the template for this view (to set the template, you must go through generateInstanceFromTemplate)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Hide | Sets the elements to be hidden in the view. (Inherited from View.)
HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
IsCellInPhaseLoads | is this cell in the phase loads Row Number Column Number
IsColumnInLoadSummary | is this column in the load summary
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsOkToEditParam | (Inherited from TableView.)
IsPanelScheduleTemplate | returns true if this is a panel schedule template, false if it is an instance
IsRowInCircuitTable | is this row in the circuit table
IsSlotGrouped | is the slot in a group? (0 = no, >0 = the group number)
IsSlotLocked | is the circuit slot in this cell locked?
IsSpace | is the selected cell space? Row Number Column Number
IsSpare | is the circuit spare? Circuit Table Row Number Circuit Table Column Number
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Print | Overloaded. Print this view.
RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
SetParamValue | sets the text for the given cell, returns true if successful, false otherwise Row Number of the Section Column Number of the Section
setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unhide | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


AddFontId Method

[image]

Revit 2011 API
PanelScheduleView..::.AddFontId Method
PanelScheduleView Class See Also Send Feedback
adds a unique combination of font name, size, and color within the table view to the font table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId AddFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic (Declaration)
Public Function AddFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ AddFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::.String
fontSize
Type: System..::.Double
fontColor
Type: Autodesk.Revit.DB..::.Color

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method

[image] [image]

Revit 2011 API
PanelScheduleView..::.CreateInstanceView Method
PanelScheduleView Class See Also Send Feedback

Overload List

Name | Description
CreateInstanceView(Document, ElementId) | allows revit to create a new instance of this view (using default template)
CreateInstanceView(Document, ElementId, ElementId) | allows revit to create a new instance of this view (using specific template)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method (Document, ElementId)

[image]

Revit 2011 API
PanelScheduleView..::.CreateInstanceView Method (Document, ElementId)
PanelScheduleView Class See Also Send Feedback
allows revit to create a new instance of this view (using default template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static PanelScheduleView CreateInstanceView(
    Document ADoc,
    ElementId panelId
)
Visual Basic (Declaration)
Public Shared Function CreateInstanceView ( _
    ADoc As Document, _
    panelId As ElementId _
) As PanelScheduleView
Visual C++
public:
static PanelScheduleView^ CreateInstanceView(
    Document^ ADoc,
    ElementId^ panelId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
panelId
Type: Autodesk.Revit.DB..::.ElementId
Element id of the electrical panel element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
CreateInstanceView Overload
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method (Document, ElementId, ElementId)

[image]

Revit 2011 API
PanelScheduleView..::.CreateInstanceView Method (Document, ElementId, ElementId)
PanelScheduleView Class See Also Send Feedback
allows revit to create a new instance of this view (using specific template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static PanelScheduleView CreateInstanceView(
    Document ADoc,
    ElementId templateId,
    ElementId panelId
)
Visual Basic (Declaration)
Public Shared Function CreateInstanceView ( _
    ADoc As Document, _
    templateId As ElementId, _
    panelId As ElementId _
) As PanelScheduleView
Visual C++
public:
static PanelScheduleView^ CreateInstanceView(
    Document^ ADoc,
    ElementId^ templateId,
    ElementId^ panelId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document
templateId
Type: Autodesk.Revit.DB..::.ElementId
panelId
Type: Autodesk.Revit.DB..::.ElementId
Element id of the electrical panel element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
CreateInstanceView Overload
Autodesk.Revit.DB.Electrical Namespace


GenerateInstanceFromTemplate Method

[image]

Revit 2011 API
PanelScheduleView..::.GenerateInstanceFromTemplate Method
PanelScheduleView Class See Also Send Feedback
actually assigns the data from the template to the instance also performs any tasks specific to the instance (3rd phase, borders, etc)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void GenerateInstanceFromTemplate(
    ElementId templateId
)
Visual Basic (Declaration)
Public Sub GenerateInstanceFromTemplate ( _
    templateId As ElementId _
)
Visual C++
public:
void GenerateInstanceFromTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetApparentLoad Method

[image]

Revit 2011 API
PanelScheduleView..::.GetApparentLoad Method
PanelScheduleView Class See Also Send Feedback
get the apparent load for the given phase for the given slotted circuit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetApparentLoad(
    ElementId circuitId,
    ElementId apparentLoadParam
)
Visual Basic (Declaration)
Public Function GetApparentLoad ( _
    circuitId As ElementId, _
    apparentLoadParam As ElementId _
) As Double
Visual C++
public:
double GetApparentLoad(
    ElementId^ circuitId,
    ElementId^ apparentLoadParam
)

Parameters

circuitId
Type: Autodesk.Revit.DB..::.ElementId
apparentLoadParam
Type: Autodesk.Revit.DB..::.ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCellText Method

[image]

Revit 2011 API
PanelScheduleView..::.GetCellText Method
PanelScheduleView Class See Also Send Feedback
gets the cell's text based on its type Row Number in the Section Column Number in the Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCellText ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCircuitByCell Method

[image]

Revit 2011 API
PanelScheduleView..::.GetCircuitByCell Method
PanelScheduleView Class See Also Send Feedback
gets the circuit element for the given slot number Row Number of the Body Section Column Number of the Body Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElectricalSystem GetCircuitByCell(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCircuitByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ GetCircuitByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCircuitIdByCell Method

[image]

Revit 2011 API
PanelScheduleView..::.GetCircuitIdByCell Method
PanelScheduleView Class See Also Send Feedback
gets the circuit id for the given slot number Row Number Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetCircuitIdByCell(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCircuitIdByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCircuitIdByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCombinedParamValue Method

[image]

Revit 2011 API
PanelScheduleView..::.GetCombinedParamValue Method
PanelScheduleView Class See Also Send Feedback
Returns the combined parameter text for instance view Row Number of the Section Column Number of the Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetCombinedParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetCombinedParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCombinedParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method

[image] [image]

Revit 2011 API
PanelScheduleView..::.GetFontId Method
PanelScheduleView Class See Also Send Feedback

Overload List

Name | Description
GetFontId(SectionType, Int32, Int32) | gets the font id for the given cell Row Number Column Number
GetFontId(String, Double, Color) | gets the font id for the combination of font name, size, and color

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method (SectionType, Int32, Int32)

[image]

Revit 2011 API
PanelScheduleView..::.GetFontId Method (SectionType, Int32, Int32)
PanelScheduleView Class See Also Send Feedback
gets the font id for the given cell Row Number Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetFontId(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetFontId ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method (String, Double, Color)

[image]

Revit 2011 API
PanelScheduleView..::.GetFontId Method (String, Double, Color)
PanelScheduleView Class See Also Send Feedback
gets the font id for the combination of font name, size, and color

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic (Declaration)
Public Function GetFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::.String
fontSize
Type: System..::.Double
fontColor
Type: Autodesk.Revit.DB..::.Color

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationConnectedCurrent Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationConnectedCurrent Method
PanelScheduleView Class See Also Send Feedback
get the Total Current for given LC Row number of Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationConnectedCurrent(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationConnectedCurrent ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationConnectedCurrent(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationConnectedLoad Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationConnectedLoad Method
PanelScheduleView Class See Also Send Feedback
get the Total Load for given LC Row number of Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationConnectedLoad(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationConnectedLoad ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationConnectedLoad(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandCurrent Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationDemandCurrent Method
PanelScheduleView Class See Also Send Feedback
get the Demand Current for given LC Row number of Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationDemandCurrent(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationDemandCurrent ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandCurrent(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandFactor Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationDemandFactor Method
PanelScheduleView Class See Also Send Feedback
get the Demand Factor for given LC Row number of Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationDemandFactor(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationDemandFactor ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandFactor(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandLoad Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationDemandLoad Method
PanelScheduleView Class See Also Send Feedback
get the Demand Load for given LC Row number of Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationDemandLoad(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationDemandLoad ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandLoad(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationId Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationId Method
PanelScheduleView Class See Also Send Feedback
get the id of the associated LC at the given row Row number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetLoadClassificationId(
    int nRow
)
Visual Basic (Declaration)
Public Function GetLoadClassificationId ( _
    nRow As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetLoadClassificationId(
    int nRow
)

Parameters

nRow
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationName Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationName Method
PanelScheduleView Class See Also Send Feedback
get the name of the Load Classification at the given row/col Row Number of the Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationName(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationName ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationName(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationParamValue Method

[image]

Revit 2011 API
PanelScheduleView..::.GetLoadClassificationParamValue Method
PanelScheduleView Class See Also Send Feedback
Gets the load classification parameter value. Row Number of the Load Summary Section Column number of Load Summary Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetLoadClassificationParamValue(
    ElementId parameterId,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetLoadClassificationParamValue ( _
    parameterId As ElementId, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationParamValue(
    ElementId^ parameterId,
    int nRow,
    int nCol
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::.ElementId
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetPanel Method

[image]

Revit 2011 API
PanelScheduleView..::.GetPanel Method
PanelScheduleView Class See Also Send Feedback
get the panel for this view

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetPanel()
Visual Basic (Declaration)
Public Function GetPanel As ElementId
Visual C++
public:
ElementId^ GetPanel()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetParamValue Method

[image]

Revit 2011 API
PanelScheduleView..::.GetParamValue Method
PanelScheduleView Class See Also Send Feedback
gets the cell's text based on its type Row Number of the Section Column Number of the Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSectionData Method

[image]

Revit 2011 API
PanelScheduleView..::.GetSectionData Method
PanelScheduleView Class See Also Send Feedback
gets section data that can be written to

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    SectionType sectionType
)
Visual Basic (Declaration)
Public Function GetSectionData ( _
    sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSlotNumberByCell Method

[image]

Revit 2011 API
PanelScheduleView..::.GetSlotNumberByCell Method
PanelScheduleView Class See Also Send Feedback
gets the slot number in the circuit table Row Number Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GetSlotNumberByCell(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function GetSlotNumberByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As Integer
Visual C++
public:
int GetSlotNumberByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetTableData Method

[image]

Revit 2011 API
PanelScheduleView..::.GetTableData Method
PanelScheduleView Class See Also Send Feedback
gets table data that can be written to

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PanelScheduleData GetTableData()
Visual Basic (Declaration)
Public Function GetTableData As PanelScheduleData
Visual C++
public:
PanelScheduleData^ GetTableData()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetTemplate Method

[image]

Revit 2011 API
PanelScheduleView..::.GetTemplate Method
PanelScheduleView Class See Also Send Feedback
get the template for this view (to set the template, you must go through generateInstanceFromTemplate)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId GetTemplate()
Visual Basic (Declaration)
Public Function GetTemplate As ElementId
Visual C++
public:
ElementId^ GetTemplate()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsCellInPhaseLoads Method

[image]

Revit 2011 API
PanelScheduleView..::.IsCellInPhaseLoads Method
PanelScheduleView Class See Also Send Feedback
is this cell in the phase loads Row Number Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsCellInPhaseLoads(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsCellInPhaseLoads ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsCellInPhaseLoads(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsColumnInLoadSummary Method

[image]

Revit 2011 API
PanelScheduleView..::.IsColumnInLoadSummary Method
PanelScheduleView Class See Also Send Feedback
is this column in the load summary

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsColumnInLoadSummary(
    int nCol
)
Visual Basic (Declaration)
Public Function IsColumnInLoadSummary ( _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsColumnInLoadSummary(
    int nCol
)

Parameters

nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsPanelScheduleTemplate Method

[image]

Revit 2011 API
PanelScheduleView..::.IsPanelScheduleTemplate Method
PanelScheduleView Class See Also Send Feedback
returns true if this is a panel schedule template, false if it is an instance

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPanelScheduleTemplate()
Visual Basic (Declaration)
Public Function IsPanelScheduleTemplate As Boolean
Visual C++
public:
bool IsPanelScheduleTemplate()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsRowInCircuitTable Method

[image]

Revit 2011 API
PanelScheduleView..::.IsRowInCircuitTable Method
PanelScheduleView Class See Also Send Feedback
is this row in the circuit table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsRowInCircuitTable(
    int nRow
)
Visual Basic (Declaration)
Public Function IsRowInCircuitTable ( _
    nRow As Integer _
) As Boolean
Visual C++
public:
bool IsRowInCircuitTable(
    int nRow
)

Parameters

nRow
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSlotGrouped Method

[image]

Revit 2011 API
PanelScheduleView..::.IsSlotGrouped Method
PanelScheduleView Class See Also Send Feedback
is the slot in a group? (0 = no, >0 = the group number)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int IsSlotGrouped(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsSlotGrouped ( _
    nRow As Integer, _
    nCol As Integer _
) As Integer
Visual C++
public:
int IsSlotGrouped(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSlotLocked Method

[image]

Revit 2011 API
PanelScheduleView..::.IsSlotLocked Method
PanelScheduleView Class See Also Send Feedback
is the circuit slot in this cell locked?

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSlotLocked(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsSlotLocked ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSlotLocked(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSpace Method

[image]

Revit 2011 API
PanelScheduleView..::.IsSpace Method
PanelScheduleView Class See Also Send Feedback
is the selected cell space? Row Number Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSpace(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsSpace ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSpace(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSpare Method

[image]

Revit 2011 API
PanelScheduleView..::.IsSpare Method
PanelScheduleView Class See Also Send Feedback
is the circuit spare? Circuit Table Row Number Circuit Table Column Number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSpare(
    int nRow,
    int nCol
)
Visual Basic (Declaration)
Public Function IsSpare ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSpare(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::.Int32
nCol
Type: System..::.Int32

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


Print Method

[image] [image]

Revit 2011 API
PanelScheduleView..::.Print Method
PanelScheduleView Class See Also Send Feedback
Print this view.

Overload List

Name | Description
Print()()() | Print this view with default print settings and default view template. (Inherited from View.)
Print(View) | Print this view with default print settings and specialized view template. (Inherited from View.)
Print(Boolean) | Print this view with default print settings and view template. (Inherited from View.)
Print(View, Boolean) | Print this view with current print settings and specialized view template. (Inherited from View.)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


RefreshAllFontIds Method

[image]

Revit 2011 API
PanelScheduleView..::.RefreshAllFontIds Method
PanelScheduleView Class See Also Send Feedback
Clean all existing font ids and create all font ids based on the table cell styles

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RefreshAllFontIds()
Visual Basic (Declaration)
Public Sub RefreshAllFontIds
Visual C++
public:
void RefreshAllFontIds()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


SetParamValue Method

[image]

Revit 2011 API
PanelScheduleView..::.SetParamValue Method
PanelScheduleView Class See Also Send Feedback
sets the text for the given cell, returns true if successful, false otherwise Row Number of the Section Column Number of the Section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    string sValue
)
Visual Basic (Declaration)
Public Function SetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer, _
    sValue As String _
) As Boolean
Visual C++
public:
bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    String^ sValue
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::.SectionType
nRow
Type: System..::.Int32
nCol
Type: System..::.Int32
sValue
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Properties

[image] [image]

Revit 2011 API
PanelScheduleView Properties
PanelScheduleView Class See Also Send Feedback

The PanelScheduleView type exposes the following members.

Properties

Name | Description
AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CropBox | The crop box applied to the view. (Inherited from View.)
CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
GenLevel | The level for the view. (Inherited from View.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsTemplate | Test whether the view is a view template. (Inherited from View.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MinimumColumnWidth | Gets the minimum column width (Inherited from TableView.)
MinimumRowHeight | Gets the minimum row height (Inherited from TableView.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | Returns the origin of the screen. (Inherited from View.)
Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Scale | The scale of the view. (Inherited from View.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
TargetId | the element id of the element that is being viewed (Inherited from TableView.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpDirection | The direction towards the top of the screen. (Inherited from View.)
ViewDirection | The direction towards the viewer. (Inherited from View.)
ViewName | The name of the view. (Inherited from View.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
ViewType | The type of the view. (Inherited from View.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
PanelScheduleView..::.Parameter Property
PanelScheduleView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


PowerFactorStateType Enumeration

[image]

Revit 2011 API
PowerFactorStateType Enumeration
See Also Send Feedback
An enumerated type listing all the possible power factor state types for a connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PowerFactorStateType
Visual Basic (Declaration)
Public Enumeration PowerFactorStateType
Visual C++
public enum class PowerFactorStateType

Members

Member name | Description
Leading | Power FactorState Type is Leading.
Lagging | Power FactorState Type is Lagging.

See Also

Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Class

[image]

Revit 2011 API
TemperatureRatingType Class
Members See Also Send Feedback
Represents temperature rating type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TemperatureRatingType : ElementType
Visual Basic (Declaration)
Public Class TemperatureRatingType _
    Inherits ElementType
Visual C++
public ref class TemperatureRatingType : public ElementType

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type information such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Members

[image] [image]

Revit 2011 API
TemperatureRatingType Members
TemperatureRatingType Class Methods Properties See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Methods

[image] [image]

Revit 2011 API
TemperatureRatingType Methods
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Methods

Name | Description
AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
AddInsulationType | Add a new kind of insulation type into this temperature rating type.
AddWireSize | Add a new kind of wire size type into this temperature rating type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
RemoveWireSize | Remove an existing wire size type from this temperature rating type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddCorrectionFactor Method

[image]

Revit 2011 API
TemperatureRatingType..::.AddCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
    long temperature,
    double factor
)
Visual Basic (Declaration)
Public Function AddCorrectionFactor ( _
    temperature As Long, _
    factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor(
    long long temperature,
    double factor
)

Parameters

temperature
Type: System..::.Int64
Temperature of correction factor to be added.
factor
Type: System..::.Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddInsulationType Method

[image]

Revit 2011 API
TemperatureRatingType..::.AddInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of insulation type into this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InsulationType AddInsulationType(
    string name
)
Visual Basic (Declaration)
Public Function AddInsulationType ( _
    name As String _
) As InsulationType
Visual C++
public:
InsulationType^ AddInsulationType(
    String^ name
)

Parameters

name
Type: System..::.String
Name of insulation type symbol to be constructed and added.

Return Value

Constructed insulation type instance.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddWireSize Method

[image]

Revit 2011 API
TemperatureRatingType..::.AddWireSize Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSize AddWireSize(
    string size,
    long ampacity,
    double diameter
)
Visual Basic (Declaration)
Public Function AddWireSize ( _
    size As String, _
    ampacity As Long, _
    diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize(
    String^ size,
    long long ampacity,
    double diameter
)

Parameters

size
Type: System..::.String
Size of wire size.
ampacity
Type: System..::.Int64
Ampacity of wire size to be added.
diameter
Type: System..::.Double
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveCorrectionFactor Method

[image]

Revit 2011 API
TemperatureRatingType..::.RemoveCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing correction factor from this temperature rating type in Revit MEP project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveCorrectionFactor(
    CorrectionFactor correctionFactor
)
Visual Basic (Declaration)
Public Sub RemoveCorrectionFactor ( _
    correctionFactor As CorrectionFactor _
)
Visual C++
public:
void RemoveCorrectionFactor(
    CorrectionFactor^ correctionFactor
)

Parameters

correctionFactor
Type: Autodesk.Revit.DB.Electrical..::.CorrectionFactor
The correction factor to be removed.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveInsulationType Method

[image]

Revit 2011 API
TemperatureRatingType..::.RemoveInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic (Declaration)
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType(
    InsulationType^ insulationType
)

Parameters

insulationType
Type: Autodesk.Revit.DB.Electrical..::.InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireSize Method

[image]

Revit 2011 API
TemperatureRatingType..::.RemoveWireSize Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing wire size type from this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveWireSize(
    WireSize wireSize
)
Visual Basic (Declaration)
Public Sub RemoveWireSize ( _
    wireSize As WireSize _
)
Visual C++
public:
void RemoveWireSize(
    WireSize^ wireSize
)

Parameters

wireSize
Type: Autodesk.Revit.DB.Electrical..::.WireSize
The wire size type to be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Properties

[image] [image]

Revit 2011 API
TemperatureRatingType Properties
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
IsInUse | Indicate whether the temperature rating type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaterialType | Get the material type information which this temperature rating type belongs to.
Name | Get name of temperature rating type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactors Property

[image]

Revit 2011 API
TemperatureRatingType..::.CorrectionFactors Property
TemperatureRatingType Class See Also Send Feedback
Get all correction factors defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CorrectionFactorSet CorrectionFactors { get; }
Visual Basic (Declaration)
Public ReadOnly Property CorrectionFactors As CorrectionFactorSet
Visual C++
public:
property CorrectionFactorSet^ CorrectionFactors {
    CorrectionFactorSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypes Property

[image]

Revit 2011 API
TemperatureRatingType..::.InsulationTypes Property
TemperatureRatingType Class See Also Send Feedback
Get all insulation types defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InsulationTypeSet InsulationTypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property InsulationTypes As InsulationTypeSet
Visual C++
public:
property InsulationTypeSet^ InsulationTypes {
    InsulationTypeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
TemperatureRatingType..::.IsInUse Property
TemperatureRatingType Class See Also Send Feedback
Indicate whether the temperature rating type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


MaterialType Property

[image]

Revit 2011 API
TemperatureRatingType..::.MaterialType Property
TemperatureRatingType Class See Also Send Feedback
Get the material type information which this temperature rating type belongs to.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialType MaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialType As WireMaterialType
Visual C++
public:
property WireMaterialType^ MaterialType {
    WireMaterialType^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2011 API
TemperatureRatingType..::.Name Property
TemperatureRatingType Class See Also Send Feedback
Get name of temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Set name can't be supported.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
TemperatureRatingType..::.Parameter Property
TemperatureRatingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TemperatureRatingType Class
TemperatureRatingType Members
Autodesk.Revit.DB.Electrical Namespace


WireSizes Property

[image]

Revit 2011 API
TemperatureRatingType..::.WireSizes Property
TemperatureRatingType Class See Also Send Feedback
Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSizeSet WireSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property WireSizes As WireSizeSet
Visual C++
public:
property WireSizeSet^ WireSizes {
    WireSizeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Class

[image]

Revit 2011 API
TemperatureRatingTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TemperatureRatingTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TemperatureRatingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TemperatureRatingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSet

See Also

TemperatureRatingTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Members

[image] [image]

Revit 2011 API
TemperatureRatingTypeSet Members
TemperatureRatingTypeSet Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Constructors

Name | Description
TemperatureRatingTypeSet | Initializes a new instance of the TemperatureRatingTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Constructor

[image]

Revit 2011 API
TemperatureRatingTypeSet Constructor
TemperatureRatingTypeSet Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TemperatureRatingTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSet()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Methods

[image] [image]

Revit 2011 API
TemperatureRatingTypeSet Methods
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.Clear Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.Contains Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.Erase Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TemperatureRatingType _
) As Integer
Visual C++
public:
virtual int Erase(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.ForwardIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ForwardIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.GetEnumerator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.Insert Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    TemperatureRatingType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.ReverseIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ReverseIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Properties

[image] [image]

Revit 2011 API
TemperatureRatingTypeSet Properties
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.IsEmpty Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
TemperatureRatingTypeSet..::.Size Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Class

[image]

Revit 2011 API
TemperatureRatingTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TemperatureRatingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.TemperatureRatingTypeSetIterator

See Also

TemperatureRatingTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Members

[image] [image]

Revit 2011 API
TemperatureRatingTypeSetIterator Members
TemperatureRatingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Constructors

Name | Description
TemperatureRatingTypeSetIterator | Initializes a new instance of the TemperatureRatingTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Constructor

[image]

Revit 2011 API
TemperatureRatingTypeSetIterator Constructor
TemperatureRatingTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TemperatureRatingTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemperatureRatingTypeSetIterator()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Methods

[image] [image]

Revit 2011 API
TemperatureRatingTypeSetIterator Methods
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
TemperatureRatingTypeSetIterator..::.MoveNext Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
TemperatureRatingTypeSetIterator..::.Reset Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Properties

[image] [image]

Revit 2011 API
TemperatureRatingTypeSetIterator Properties
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
TemperatureRatingTypeSetIterator..::.Current Property
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Class

[image]

Revit 2011 API
VoltageType Class
Members See Also Send Feedback
Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VoltageType : ElementType
Visual Basic (Declaration)
Public Class VoltageType _
    Inherits ElementType
Visual C++
public ref class VoltageType : public ElementType

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.VoltageType

See Also

VoltageType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageType Members

[image] [image]

Revit 2011 API
VoltageType Members
VoltageType Class Methods Properties See Also Send Feedback

The VoltageType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Methods

[image] [image]

Revit 2011 API
VoltageType Methods
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


SetVoltageValue Method

[image]

Revit 2011 API
VoltageType..::.SetVoltageValue Method
VoltageType Class See Also Send Feedback
Assign new values to modify voltage type, all of the unit are volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic (Declaration)
Public Sub SetVoltageValue ( _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
)
Visual C++
public:
void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

actualValue
Type: System..::.Double
minValue
Type: System..::.Double
maxValue
Type: System..::.Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Actual value can't be more than minValue or less than maxValue, and all of them can't be negative, otherwise the exception will be thrown.

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Properties

[image] [image]

Revit 2011 API
VoltageType Properties
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Properties

Name | Description
ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


ActualValue Property

[image]

Revit 2011 API
VoltageType..::.ActualValue Property
VoltageType Class See Also Send Feedback
Get actual voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualValue As Double
Visual C++
public:
property double ActualValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
VoltageType..::.IsInUse Property
VoltageType Class See Also Send Feedback
Indicates whether this voltage type is in service now, such as by other distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


MaxValue Property

[image]

Revit 2011 API
VoltageType..::.MaxValue Property
VoltageType Class See Also Send Feedback
Get upper boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MaxValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxValue As Double
Visual C++
public:
property double MaxValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


MinValue Property

[image]

Revit 2011 API
VoltageType..::.MinValue Property
VoltageType Class See Also Send Feedback
Get lower boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MinValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinValue As Double
Visual C++
public:
property double MinValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
VoltageType..::.Parameter Property
VoltageType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

VoltageType Class
VoltageType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Class

[image]

Revit 2011 API
VoltageTypeSet Class
Members See Also Send Feedback
A set that contains voltage types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class VoltageTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class VoltageTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VoltageTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.VoltageTypeSet

See Also

VoltageTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Members

[image] [image]

Revit 2011 API
VoltageTypeSet Members
VoltageTypeSet Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Constructors

Name | Description
VoltageTypeSet | Initializes a new instance of the VoltageTypeSet class

Methods

Name | Description
Clear | Removes every voltage type from the set, rendering it empty.
Contains | Tests for the existence of a voltage type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified voltage type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified voltage type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Constructor

[image]

Revit 2011 API
VoltageTypeSet Constructor
VoltageTypeSet Class See Also Send Feedback
Initializes a new instance of the VoltageTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSet()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Methods

[image] [image]

Revit 2011 API
VoltageTypeSet Methods
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every voltage type from the set, rendering it empty.
Contains | Tests for the existence of a voltage type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified voltage type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified voltage type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
VoltageTypeSet..::.Clear Method
VoltageTypeSet Class See Also Send Feedback
Removes every voltage type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
VoltageTypeSet..::.Contains Method
VoltageTypeSet Class See Also Send Feedback
Tests for the existence of a voltage type within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
The voltage type to be searched for.

Return Value

The Contains method returns True if the voltage type is within the set, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
VoltageTypeSet..::.Erase Method
VoltageTypeSet Class See Also Send Feedback
Removes a specified voltage type from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As VoltageType _
) As Integer
Visual C++
public:
virtual int Erase(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
The voltage type to be erased.

Return Value

The number of voltage types that were erased from the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
VoltageTypeSet..::.ForwardIterator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
VoltageTypeSet..::.GetEnumerator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
VoltageTypeSet..::.Insert Method
VoltageTypeSet Class See Also Send Feedback
Insert the specified voltage type into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    VoltageType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.VoltageType
The voltage type to be inserted into the set.

Return Value

Returns whether the voltage type was inserted into the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
VoltageTypeSet..::.ReverseIterator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Properties

[image] [image]

Revit 2011 API
VoltageTypeSet Properties
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
VoltageTypeSet..::.IsEmpty Property
VoltageTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
VoltageTypeSet..::.Size Property
VoltageTypeSet Class See Also Send Feedback
Returns the number of voltage types that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Class

[image]

Revit 2011 API
VoltageTypeSetIterator Class
Members See Also Send Feedback
An iterator to a voltage type set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class VoltageTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class VoltageTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VoltageTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.VoltageTypeSetIterator

See Also

VoltageTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Members

[image] [image]

Revit 2011 API
VoltageTypeSetIterator Members
VoltageTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Constructors

Name | Description
VoltageTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Constructor

[image]

Revit 2011 API
VoltageTypeSetIterator Constructor
VoltageTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public VoltageTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoltageTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Methods

[image] [image]

Revit 2011 API
VoltageTypeSetIterator Methods
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
VoltageTypeSetIterator..::.MoveNext Method
VoltageTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
VoltageTypeSetIterator..::.Reset Method
VoltageTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Properties

[image] [image]

Revit 2011 API
VoltageTypeSetIterator Properties
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
VoltageTypeSetIterator..::.Current Property
VoltageTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Wire Class

[image]

Revit 2011 API
Wire Class
Members See Also Send Feedback
An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Wire : HostObject
Visual Basic (Declaration)
Public Class Wire _
    Inherits HostObject
Visual C++
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB.Electrical..::.Wire

See Also

Wire Members
Autodesk.Revit.DB.Electrical Namespace


Wire Members

[image] [image]

Revit 2011 API
Wire Members
Wire Class Methods Properties See Also Send Feedback

The Wire type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Get connector manager of the wire.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorNum | The ground conductor number. Its default value is zero after created.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Wire Methods

[image] [image]

Revit 2011 API
Wire Methods
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Wire Properties

[image] [image]

Revit 2011 API
Wire Properties
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Get connector manager of the wire.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorNum | The ground conductor number. Its default value is zero after created.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WiringType | Get or set wiring type(Arc or chamfer) for the wire.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


ConnectorManager Property

[image]

Revit 2011 API
Wire..::.ConnectorManager Property
Wire Class See Also Send Feedback
Get connector manager of the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectorManager As ConnectorManager
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorNum Property

[image]

Revit 2011 API
Wire..::.GroundConductorNum Property
Wire Class See Also Send Feedback
The ground conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int GroundConductorNum { get; set; }
Visual Basic (Declaration)
Public Property GroundConductorNum As Integer
Visual C++
public:
property int GroundConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


HotConductorNum Property

[image]

Revit 2011 API
Wire..::.HotConductorNum Property
Wire Class See Also Send Feedback
Get or set hot conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int HotConductorNum { get; set; }
Visual Basic (Declaration)
Public Property HotConductorNum As Integer
Visual C++
public:
property int HotConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


NeutralConductorNum Property

[image]

Revit 2011 API
Wire..::.NeutralConductorNum Property
Wire Class See Also Send Feedback
The neutral conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NeutralConductorNum { get; set; }
Visual Basic (Declaration)
Public Property NeutralConductorNum As Integer
Visual C++
public:
property int NeutralConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
Wire..::.Parameter Property
Wire Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Wire Class
Wire Members
Autodesk.Revit.DB.Electrical Namespace


WiringType Property

[image]

Revit 2011 API
Wire..::.WiringType Property
Wire Class See Also Send Feedback
Get or set wiring type(Arc or chamfer) for the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WiringType WiringType { get; set; }
Visual Basic (Declaration)
Public Property WiringType As WiringType
Visual C++
public:
property WiringType WiringType {
    WiringType get ();
    void set (WiringType value);
}

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Class

[image]

Revit 2011 API
WireConduitType Class
Members See Also Send Feedback
Represents a specific conduit type of wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireConduitType : APIObject
Visual Basic (Declaration)
Public Class WireConduitType _
    Inherits APIObject
Visual C++
public ref class WireConduitType : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireConduitType

See Also

WireConduitType Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Members

[image] [image]

Revit 2011 API
WireConduitType Members
WireConduitType Class Methods Properties See Also Send Feedback

The WireConduitType type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name |

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Methods

[image] [image]

Revit 2011 API
WireConduitType Methods
WireConduitType Class See Also Send Feedback

The WireConduitType type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Properties

[image] [image]

Revit 2011 API
WireConduitType Properties
WireConduitType Class See Also Send Feedback

The WireConduitType type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name |

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2011 API
WireConduitType..::.Name Property
WireConduitType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Class

[image]

Revit 2011 API
WireConduitTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireConduitTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireConduitTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireConduitTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSet

See Also

WireConduitTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Members

[image] [image]

Revit 2011 API
WireConduitTypeSet Members
WireConduitTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Constructors

Name | Description
WireConduitTypeSet | Initializes a new instance of the WireConduitTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Constructor

[image]

Revit 2011 API
WireConduitTypeSet Constructor
WireConduitTypeSet Class See Also Send Feedback
Initializes a new instance of the WireConduitTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireConduitTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireConduitTypeSet()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Methods

[image] [image]

Revit 2011 API
WireConduitTypeSet Methods
WireConduitTypeSet Class See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
WireConduitTypeSet..::.Clear Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
WireConduitTypeSet..::.Contains Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    WireConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireConduitType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
WireConduitTypeSet..::.Erase Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    WireConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireConduitType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
WireConduitTypeSet..::.ForwardIterator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireConduitTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireConduitTypeSetIterator
Visual C++
public:
virtual WireConduitTypeSetIterator^ ForwardIterator()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
WireConduitTypeSet..::.GetEnumerator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
WireConduitTypeSet..::.Insert Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    WireConduitType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireConduitType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
WireConduitTypeSet..::.ReverseIterator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireConduitTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireConduitTypeSetIterator
Visual C++
public:
virtual WireConduitTypeSetIterator^ ReverseIterator()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Properties

[image] [image]

Revit 2011 API
WireConduitTypeSet Properties
WireConduitTypeSet Class See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
WireConduitTypeSet..::.IsEmpty Property
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireConduitTypeSet..::.Size Property
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Class

[image]

Revit 2011 API
WireConduitTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WireConduitTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireConduitTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireConduitTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireConduitTypeSetIterator

See Also

WireConduitTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Members

[image] [image]

Revit 2011 API
WireConduitTypeSetIterator Members
WireConduitTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Constructors

Name | Description
WireConduitTypeSetIterator | Initializes a new instance of the WireConduitTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Constructor

[image]

Revit 2011 API
WireConduitTypeSetIterator Constructor
WireConduitTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireConduitTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireConduitTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireConduitTypeSetIterator()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Methods

[image] [image]

Revit 2011 API
WireConduitTypeSetIterator Methods
WireConduitTypeSetIterator Class See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
WireConduitTypeSetIterator..::.MoveNext Method
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
WireConduitTypeSetIterator..::.Reset Method
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Properties

[image] [image]

Revit 2011 API
WireConduitTypeSetIterator Properties
WireConduitTypeSetIterator Class See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
WireConduitTypeSetIterator..::.Current Property
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Class

[image]

Revit 2011 API
WireMaterialType Class
Members See Also Send Feedback
Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireMaterialType : ElementType
Visual Basic (Declaration)
Public Class WireMaterialType _
    Inherits ElementType
Visual C++
public ref class WireMaterialType : public ElementType

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Members

[image] [image]

Revit 2011 API
WireMaterialType Members
WireMaterialType Class Methods Properties See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the wire material type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of wire material type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Methods

[image] [image]

Revit 2011 API
WireMaterialType Methods
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

Name | Description
AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
AddTemperatureRatingType | Add a new temperature rating type into material type.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


AddGroundConductorSize Method

[image]

Revit 2011 API
WireMaterialType..::.AddGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Add new electrical ground conductor size type into this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroundConductorSize AddGroundConductorSize(
    long ampacity,
    string size
)
Visual Basic (Declaration)
Public Function AddGroundConductorSize ( _
    ampacity As Long, _
    size As String _
) As GroundConductorSize
Visual C++
public:
GroundConductorSize^ AddGroundConductorSize(
    long long ampacity,
    String^ size
)

Parameters

ampacity
Type: System..::.Int64
Ampacity of ground conductor size to be added.
size
Type: System..::.String
Size of ground conductor size to be added.

Return Value

New added ground conductor size.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


AddTemperatureRatingType Method

[image]

Revit 2011 API
WireMaterialType..::.AddTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic (Declaration)
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType(
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
Type: System..::.String
Name of temperature type to be added.
baseOn
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveGroundConductorSize Method

[image]

Revit 2011 API
WireMaterialType..::.RemoveGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Remove an existing ground conductor size from this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveGroundConductorSize(
    GroundConductorSize grdConductorSize
)
Visual Basic (Declaration)
Public Sub RemoveGroundConductorSize ( _
    grdConductorSize As GroundConductorSize _
)
Visual C++
public:
void RemoveGroundConductorSize(
    GroundConductorSize^ grdConductorSize
)

Parameters

grdConductorSize
Type: Autodesk.Revit.DB.Electrical..::.GroundConductorSize
The ground size type to be removed.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveTemperatureRatingType Method

[image]

Revit 2011 API
WireMaterialType..::.RemoveTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic (Declaration)
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType(
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
Type: Autodesk.Revit.DB.Electrical..::.TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Properties

[image] [image]

Revit 2011 API
WireMaterialType Properties
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsInUse | Indicate whether the wire material type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get name of wire material type. (Overrides ElementType..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizes Property

[image]

Revit 2011 API
WireMaterialType..::.GroundConductorSizes Property
WireMaterialType Class See Also Send Feedback
Get all ground conductor size types defined in this wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GroundConductorSizeSet GroundConductorSizes { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroundConductorSizes As GroundConductorSizeSet
Visual C++
public:
property GroundConductorSizeSet^ GroundConductorSizes {
    GroundConductorSizeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
WireMaterialType..::.IsInUse Property
WireMaterialType Class See Also Send Feedback
Indicate whether the wire material type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2011 API
WireMaterialType..::.Name Property
WireMaterialType Class See Also Send Feedback
Get name of wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Set name can't be supported.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
WireMaterialType..::.Parameter Property
WireMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WireMaterialType Class
WireMaterialType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatings Property

[image]

Revit 2011 API
WireMaterialType..::.TemperatureRatings Property
WireMaterialType Class See Also Send Feedback
Get all temperature rating type definitions defined in this wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TemperatureRatingTypeSet TemperatureRatings { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemperatureRatings As TemperatureRatingTypeSet
Visual C++
public:
property TemperatureRatingTypeSet^ TemperatureRatings {
    TemperatureRatingTypeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Class

[image]

Revit 2011 API
WireMaterialTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireMaterialTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireMaterialTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireMaterialTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSet

See Also

WireMaterialTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Members

[image] [image]

Revit 2011 API
WireMaterialTypeSet Members
WireMaterialTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Constructors

Name | Description
WireMaterialTypeSet | Initializes a new instance of the WireMaterialTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Constructor

[image]

Revit 2011 API
WireMaterialTypeSet Constructor
WireMaterialTypeSet Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSet()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Methods

[image] [image]

Revit 2011 API
WireMaterialTypeSet Methods
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.Clear Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.Contains Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.Erase Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireMaterialType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.ForwardIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ForwardIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.GetEnumerator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.Insert Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    WireMaterialType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
WireMaterialTypeSet..::.ReverseIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ReverseIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Properties

[image] [image]

Revit 2011 API
WireMaterialTypeSet Properties
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
WireMaterialTypeSet..::.IsEmpty Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireMaterialTypeSet..::.Size Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Class

[image]

Revit 2011 API
WireMaterialTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WireMaterialTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireMaterialTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireMaterialTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireMaterialTypeSetIterator

See Also

WireMaterialTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Members

[image] [image]

Revit 2011 API
WireMaterialTypeSetIterator Members
WireMaterialTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Constructors

Name | Description
WireMaterialTypeSetIterator | Initializes a new instance of the WireMaterialTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Constructor

[image]

Revit 2011 API
WireMaterialTypeSetIterator Constructor
WireMaterialTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireMaterialTypeSetIterator()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Methods

[image] [image]

Revit 2011 API
WireMaterialTypeSetIterator Methods
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
WireMaterialTypeSetIterator..::.MoveNext Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
WireMaterialTypeSetIterator..::.Reset Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Properties

[image] [image]

Revit 2011 API
WireMaterialTypeSetIterator Properties
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
WireMaterialTypeSetIterator..::.Current Property
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Class

[image]

Revit 2011 API
WireSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class WireSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireSet

See Also

WireSet Members
Autodesk.Revit.DB.Electrical Namespace


WireSet Members

[image] [image]

Revit 2011 API
WireSet Members
WireSet Class Constructors Methods Properties See Also Send Feedback

The WireSet type exposes the following members.

Constructors

Name | Description
WireSet | Initializes a new instance of the WireSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Constructor

[image]

Revit 2011 API
WireSet Constructor
WireSet Class See Also Send Feedback
Initializes a new instance of the WireSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSet()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Methods

[image] [image]

Revit 2011 API
WireSet Methods
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
WireSet..::.Clear Method
WireSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
WireSet..::.Contains Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
WireSet..::.Erase Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Wire _
) As Integer
Visual C++
public:
virtual int Erase(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
WireSet..::.ForwardIterator Method
WireSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
WireSet..::.GetEnumerator Method
WireSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
WireSet..::.Insert Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Wire item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
WireSet..::.ReverseIterator Method
WireSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Properties

[image] [image]

Revit 2011 API
WireSet Properties
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
WireSet..::.IsEmpty Property
WireSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireSet..::.Size Property
WireSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Class

[image]

Revit 2011 API
WireSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WireSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireSetIterator

See Also

WireSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Members

[image] [image]

Revit 2011 API
WireSetIterator Members
WireSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSetIterator type exposes the following members.

Constructors

Name | Description
WireSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Constructor

[image]

Revit 2011 API
WireSetIterator Constructor
WireSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Methods

[image] [image]

Revit 2011 API
WireSetIterator Methods
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
WireSetIterator..::.MoveNext Method
WireSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
WireSetIterator..::.Reset Method
WireSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Properties

[image] [image]

Revit 2011 API
WireSetIterator Properties
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
WireSetIterator..::.Current Property
WireSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Class

[image]

Revit 2011 API
WireSize Class
Members See Also Send Feedback
Represents specific electrical wire size information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireSize : APIObject
Visual Basic (Declaration)
Public Class WireSize _
    Inherits APIObject
Visual C++
public ref class WireSize : public APIObject

Remarks

Wire size is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireSize

See Also

WireSize Members
Autodesk.Revit.DB.Electrical Namespace


WireSize Members

[image] [image]

Revit 2011 API
WireSize Members
WireSize Class Methods Properties See Also Send Feedback

The WireSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Diameter | Get diameter of wire.
InUse | Get or set whether the size can be used in sizing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Methods

[image] [image]

Revit 2011 API
WireSize Methods
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Properties

[image] [image]

Revit 2011 API
WireSize Properties
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Properties

Name | Description
Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Diameter | Get diameter of wire.
InUse | Get or set whether the size can be used in sizing.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Ampacity Property

[image]

Revit 2011 API
WireSize..::.Ampacity Property
WireSize Class See Also Send Feedback
Get ampacity which be used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ampacity As Long
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Diameter Property

[image]

Revit 2011 API
WireSize..::.Diameter Property
WireSize Class See Also Send Feedback
Get diameter of wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Diameter As Double
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


InUse Property

[image]

Revit 2011 API
WireSize..::.InUse Property
WireSize Class See Also Send Feedback
Get or set whether the size can be used in sizing.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool InUse { get; set; }
Visual Basic (Declaration)
Public Property InUse As Boolean
Visual C++
public:
property bool InUse {
    bool get ();
    void set (bool value);
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireSize..::.Size Property
WireSize Class See Also Send Feedback
Get size symbol of wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As String
Visual C++
public:
property String^ Size {
    String^ get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Class

[image]

Revit 2011 API
WireSizeSet Class
Members See Also Send Feedback
A set that contains wire sizes.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireSizeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireSizeSet

See Also

WireSizeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Members

[image] [image]

Revit 2011 API
WireSizeSet Members
WireSizeSet Class Constructors Methods Properties See Also Send Feedback

The WireSizeSet type exposes the following members.

Constructors

Name | Description
WireSizeSet | Initializes a new instance of the WireSizeSet class

Methods

Name | Description
Clear | Removes every wire size from the set, rendering it empty.
Contains | Tests for the existence of a wire size within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wire size from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wire size into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Constructor

[image]

Revit 2011 API
WireSizeSet Constructor
WireSizeSet Class See Also Send Feedback
Initializes a new instance of the WireSizeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSizeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSet()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Methods

[image] [image]

Revit 2011 API
WireSizeSet Methods
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every wire size from the set, rendering it empty.
Contains | Tests for the existence of a wire size within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified wire size from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified wire size into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
WireSizeSet..::.Clear Method
WireSizeSet Class See Also Send Feedback
Removes every wire size from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
WireSizeSet..::.Contains Method
WireSizeSet Class See Also Send Feedback
Tests for the existence of a wire size within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireSize
The wire size to be searched for.

Return Value

The Contains method returns True if the wire size is within the set, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
WireSizeSet..::.Erase Method
WireSizeSet Class See Also Send Feedback
Removes a specified wire size from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireSize _
) As Integer
Visual C++
public:
virtual int Erase(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireSize
The wire size to be erased.

Return Value

The number of wire sizes that were erased from the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
WireSizeSet..::.ForwardIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
WireSizeSet..::.GetEnumerator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
WireSizeSet..::.Insert Method
WireSizeSet Class See Also Send Feedback
Insert the specified wire size into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    WireSize item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireSize
The wire size to be inserted into the set.

Return Value

Returns whether the wire size was inserted into the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
WireSizeSet..::.ReverseIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Properties

[image] [image]

Revit 2011 API
WireSizeSet Properties
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
WireSizeSet..::.IsEmpty Property
WireSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireSizeSet..::.Size Property
WireSizeSet Class See Also Send Feedback
Returns the number of wire sizes that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Class

[image]

Revit 2011 API
WireSizeSetIterator Class
Members See Also Send Feedback
An iterator to a wire size set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WireSizeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireSizeSetIterator

See Also

WireSizeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Members

[image] [image]

Revit 2011 API
WireSizeSetIterator Members
WireSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Constructors

Name | Description
WireSizeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Constructor

[image]

Revit 2011 API
WireSizeSetIterator Constructor
WireSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSizeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Methods

[image] [image]

Revit 2011 API
WireSizeSetIterator Methods
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
WireSizeSetIterator..::.MoveNext Method
WireSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
WireSizeSetIterator..::.Reset Method
WireSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Properties

[image] [image]

Revit 2011 API
WireSizeSetIterator Properties
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
WireSizeSetIterator..::.Current Property
WireSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireType Class

[image]

Revit 2011 API
WireType Class
Members See Also Send Feedback
Represents a specific wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireType : ElementType
Visual Basic (Declaration)
Public Class WireType _
    Inherits ElementType
Visual C++
public ref class WireType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Electrical..::.WireType

See Also

WireType Members
Autodesk.Revit.DB.Electrical Namespace


WireType Members

[image] [image]

Revit 2011 API
WireType Members
WireType Class Methods Properties See Also Send Feedback

The WireType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Conduit | The conduit type of the wire type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Insulation | The insulation type.
IsInUse | Indicates whether the wire type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSize | The max size of the wire type.
Name | Set the name for the ElementType. (Inherited from ElementType.)
NeutralMultiplier | The neutral multiplier type of the wire type.
NeutralRequired | Whether or not the neutral point is required.
NeutralSize | The maximum neutral size of the wire type.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRating | The temperature rating type of the wire type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WireMaterial | The material type of the wire type.

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireType Methods

[image] [image]

Revit 2011 API
WireType Methods
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireType Properties

[image] [image]

Revit 2011 API
WireType Properties
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Conduit | The conduit type of the wire type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Insulation | The insulation type.
IsInUse | Indicates whether the wire type is in use.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSize | The max size of the wire type.
Name | Set the name for the ElementType. (Inherited from ElementType.)
NeutralMultiplier | The neutral multiplier type of the wire type.
NeutralRequired | Whether or not the neutral point is required.
NeutralSize | The maximum neutral size of the wire type.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TemperatureRating | The temperature rating type of the wire type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
WireMaterial | The material type of the wire type.

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Property

[image]

Revit 2011 API
WireType..::.Conduit Property
WireType Class See Also Send Feedback
The conduit type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireConduitType Conduit { get; set; }
Visual Basic (Declaration)
Public Property Conduit As WireConduitType
Visual C++
public:
property WireConduitType^ Conduit {
    WireConduitType^ get ();
    void set (WireConduitType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Insulation Property

[image]

Revit 2011 API
WireType..::.Insulation Property
WireType Class See Also Send Feedback
The insulation type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public InsulationType Insulation { get; set; }
Visual Basic (Declaration)
Public Property Insulation As InsulationType
Visual C++
public:
property InsulationType^ Insulation {
    InsulationType^ get ();
    void set (InsulationType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2011 API
WireType..::.IsInUse Property
WireType Class See Also Send Feedback
Indicates whether the wire type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInUse As Boolean
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


MaxSize Property

[image]

Revit 2011 API
WireType..::.MaxSize Property
WireType Class See Also Send Feedback
The max size of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireSize MaxSize { get; set; }
Visual Basic (Declaration)
Public Property MaxSize As WireSize
Visual C++
public:
property WireSize^ MaxSize {
    WireSize^ get ();
    void set (WireSize^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralMultiplier Property

[image]

Revit 2011 API
WireType..::.NeutralMultiplier Property
WireType Class See Also Send Feedback
The neutral multiplier type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double NeutralMultiplier { get; set; }
Visual Basic (Declaration)
Public Property NeutralMultiplier As Double
Visual C++
public:
property double NeutralMultiplier {
    double get ();
    void set (double value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralRequired Property

[image]

Revit 2011 API
WireType..::.NeutralRequired Property
WireType Class See Also Send Feedback
Whether or not the neutral point is required.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool NeutralRequired { get; set; }
Visual Basic (Declaration)
Public Property NeutralRequired As Boolean
Visual C++
public:
property bool NeutralRequired {
    bool get ();
    void set (bool value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralSize Property

[image]

Revit 2011 API
WireType..::.NeutralSize Property
WireType Class See Also Send Feedback
The maximum neutral size of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public NeutralMode NeutralSize { get; set; }
Visual Basic (Declaration)
Public Property NeutralSize As NeutralMode
Visual C++
public:
property NeutralMode NeutralSize {
    NeutralMode get ();
    void set (NeutralMode value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2011 API
WireType..::.Parameter Property
WireType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

WireType Class
WireType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRating Property

[image]

Revit 2011 API
WireType..::.TemperatureRating Property
WireType Class See Also Send Feedback
The temperature rating type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TemperatureRatingType TemperatureRating { get; set; }
Visual Basic (Declaration)
Public Property TemperatureRating As TemperatureRatingType
Visual C++
public:
property TemperatureRatingType^ TemperatureRating {
    TemperatureRatingType^ get ();
    void set (TemperatureRatingType^ value);
}

Remarks

Should retrieved from relevant WireMaterial object.

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterial Property

[image]

Revit 2011 API
WireType..::.WireMaterial Property
WireType Class See Also Send Feedback
The material type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireMaterialType WireMaterial { get; set; }
Visual Basic (Declaration)
Public Property WireMaterial As WireMaterialType
Visual C++
public:
property WireMaterialType^ WireMaterial {
    WireMaterialType^ get ();
    void set (WireMaterialType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Class

[image]

Revit 2011 API
WireTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class WireTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class WireTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireTypeSet

See Also

WireTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Members

[image] [image]

Revit 2011 API
WireTypeSet Members
WireTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireTypeSet type exposes the following members.

Constructors

Name | Description
WireTypeSet | Initializes a new instance of the WireTypeSet class

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Constructor

[image]

Revit 2011 API
WireTypeSet Constructor
WireTypeSet Class See Also Send Feedback
Initializes a new instance of the WireTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSet()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Methods

[image] [image]

Revit 2011 API
WireTypeSet Methods
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Methods

Name | Description
Clear |
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2011 API
WireTypeSet..::.Clear Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2011 API
WireTypeSet..::.Contains Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2011 API
WireTypeSet..::.Erase Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As WireType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2011 API
WireTypeSet..::.ForwardIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ForwardIterator()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2011 API
WireTypeSet..::.GetEnumerator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2011 API
WireTypeSet..::.Insert Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    WireType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::.WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2011 API
WireTypeSet..::.ReverseIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ReverseIterator()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Properties

[image] [image]

Revit 2011 API
WireTypeSet Properties
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size |

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2011 API
WireTypeSet..::.IsEmpty Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2011 API
WireTypeSet..::.Size Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Class

[image]

Revit 2011 API
WireTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class WireTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class WireTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Electrical..::.WireTypeSetIterator

See Also

WireTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Members

[image] [image]

Revit 2011 API
WireTypeSetIterator Members
WireTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Constructors

Name | Description
WireTypeSetIterator | Initializes a new instance of the WireTypeSetIterator class

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Constructor

[image]

Revit 2011 API
WireTypeSetIterator Constructor
WireTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public WireTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WireTypeSetIterator()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Methods

[image] [image]

Revit 2011 API
WireTypeSetIterator Methods
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2011 API
WireTypeSetIterator..::.MoveNext Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::.MoveNext()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2011 API
WireTypeSetIterator..::.Reset Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Properties

[image] [image]

Revit 2011 API
WireTypeSetIterator Properties
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Properties

Name | Description
Current |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2011 API
WireTypeSetIterator..::.Current Property
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WiringType Enumeration

[image]

Revit 2011 API
WiringType Enumeration
See Also Send Feedback
An enumerated type to list all wiring types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum WiringType
Visual Basic (Declaration)
Public Enumeration WiringType
Visual C++
public enum class WiringType

Members

Member name | Description
Arc | Arc wiring is used to indicate wiring that is concealed within walls, ceilings, or floors.
Chamfer | Chamfered wiring can be used to indicate wiring that is exposed.

See Also

Autodesk.Revit.DB.Electrical Namespace


Autodesk.Revit.DB.Events Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Events Namespace
Send Feedback

Classes

Class | Description
DocumentChangedEventArgs | The event arguments used by the DocumentChanged event.
DocumentClosedEventArgs | The event arguments used by the DocumentClosed event.
DocumentClosingEventArgs | The event arguments used by the DocumentClosing event.
DocumentCreatedEventArgs | The event arguments used by the DocumentCreated event.
DocumentCreatingEventArgs | The event arguments used by the DocumentCreating event.
DocumentOpenedEventArgs | The event arguments used by the DocumentOpened event.
DocumentOpeningEventArgs | The event arguments used by the DocumentOpening event.
DocumentPrintedEventArgs | The event arguments used by the DocumentPrinted event.
DocumentPrintingEventArgs | The event arguments used by the DocumentPrinting event.
DocumentSavedAsEventArgs | The event arguments used by the DocumentSavedAs event.
DocumentSavedEventArgs | The event arguments used by the DocumentSaved event.
DocumentSavingAsEventArgs | The event arguments used by the DocumentSavingAs event.
DocumentSavingEventArgs | The event arguments used by the DocumentSaving event.
DocumentSynchronizedWithCentralEventArgs | The event arguments used by the DocumentSynchronizedWithCentral event.
DocumentSynchronizingWithCentralEventArgs | The event arguments used by the DocumentSynchronizingWithCentral event.
FailuresProcessingEventArgs | The event arguments used by the FailuresProcessing event.
FileExportedEventArgs | The event arguments used by the FileExported event.
FileExportingEventArgs | The event arguments used by the FileExporting event.
FileImportedEventArgs | The event arguments used by the FileImported event.
FileImportingEventArgs | The event arguments used by the FileImporting event.
PostDocEventArgs | The class is used as base class for arguments of any post-event that is associated to a particular Document.
PostEventArgs | The class is used as a base class for arguments of any post-event.
PreDocEventArgs | The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.
PreEventArgs | The class is used as a base class for the arguments for any pre-event.
RevitAPIEventArgs | The class is used as base class for all event argument classes.
RevitAPIPostEventArgs | The class is used as a base class for arguments of any post-event.
RevitAPIPreEventArgs | The class is used as a base class for the arguments for any pre-event.
RevitAPISingleEventArgs | The class is used as a base class for arguments of any single-event.
RevitEventArgs | The class is used as base class for all event argument classes.
SynchronizeWithCentralOptions | Options for save to central.
ViewPrintedEventArgs | The event arguments used by ViewPrinted event.
ViewPrintingEventArgs | The event arguments used by the ViewPrinting event.

Enumerations

Enumeration | Description
EventStatus | Describes the status of an action which triggered a post event.
RevitAPIEventStatus | Describes the status of an action which triggered a post event.
UndoOperation | The operation associated with DocumentChanged event


DocumentChangedEventArgs Class

[image]

Revit 2011 API
DocumentChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentChanged event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class DocumentChangedEventArgs : RevitAPISingleEventArgs
Visual Basic (Declaration)
Public Class DocumentChangedEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class DocumentChangedEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::.DocumentChangedEventArgs

See Also

DocumentChangedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Members

[image] [image]

Revit 2011 API
DocumentChangedEventArgs Members
DocumentChangedEventArgs Class Methods Properties See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document
GetDeletedElementIds | Returns set of elements that were deleted from the document
GetDocument | Returns document associated with this event
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified
GetTransactionNames | Returns names of the transactions associated with this event
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Operation | The operation associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentChangedEventArgs Methods
DocumentChangedEventArgs Class See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAddedElementIds | Returns set of elements newly added to the document
GetDeletedElementIds | Returns set of elements that were deleted from the document
GetDocument | Returns document associated with this event
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModifiedElementIds | Returns set of elements that were modified
GetTransactionNames | Returns names of the transactions associated with this event
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetAddedElementIds Method

[image]

Revit 2011 API
DocumentChangedEventArgs..::.GetAddedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements newly added to the document

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic (Declaration)
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

The set of ElementId for elements newly added to the document

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetDeletedElementIds Method

[image]

Revit 2011 API
DocumentChangedEventArgs..::.GetDeletedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements that were deleted from the document

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetDeletedElementIds()
Visual Basic (Declaration)
Public Function GetDeletedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDeletedElementIds()

Return Value

The set of ElementId for elements that were deleted from the document

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetDocument Method

[image]

Revit 2011 API
DocumentChangedEventArgs..::.GetDocument Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns document associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic (Declaration)
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

The document associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetModifiedElementIds Method

[image]

Revit 2011 API
DocumentChangedEventArgs..::.GetModifiedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements that were modified

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetModifiedElementIds()
Visual Basic (Declaration)
Public Function GetModifiedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetModifiedElementIds()

Return Value

The set of ElementId for elements that were modified

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetTransactionNames Method

[image]

Revit 2011 API
DocumentChangedEventArgs..::.GetTransactionNames Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns names of the transactions associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<string> GetTransactionNames()
Visual Basic (Declaration)
Public Function GetTransactionNames As IList(Of String)
Visual C++
public:
IList<String^>^ GetTransactionNames()

Return Value

The names of the transactions associated with this event

Remarks

Typically, there will be only one name in the array, because document changes mostly involve just one transaction

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentChangedEventArgs Properties
DocumentChangedEventArgs Class See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Properties

Name | Description
Operation | The operation associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Operation Property

[image]

Revit 2011 API
DocumentChangedEventArgs..::.Operation Property
DocumentChangedEventArgs Class See Also Send Feedback
The operation associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public UndoOperation Operation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Operation As UndoOperation
Visual C++
public:
property UndoOperation Operation {
    UndoOperation get ();
}

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Class

[image]

Revit 2011 API
DocumentClosedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosed event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentClosedEventArgs : PostEventArgs
Visual Basic (Declaration)
Public Class DocumentClosedEventArgs _
    Inherits PostEventArgs
Visual C++
public ref class DocumentClosedEventArgs : public PostEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.DocumentClosedEventArgs

See Also

DocumentClosedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Members

[image] [image]

Revit 2011 API
DocumentClosedEventArgs Members
DocumentClosedEventArgs Class Methods Properties See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentId | Id of the document that has just been closed.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentClosedEventArgs Methods
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentClosedEventArgs Properties
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentId | Id of the document that has just been closed.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentId Property

[image]

Revit 2011 API
DocumentClosedEventArgs..::.DocumentId Property
DocumentClosedEventArgs Class See Also Send Feedback
Id of the document that has just been closed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosing event which preceded it.

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Class

[image]

Revit 2011 API
DocumentClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosing event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentClosingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentClosingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentClosingEventArgs : public PreDocEventArgs

Remarks

This event is cancellable, except when it is raised when the Revit application is closing.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentClosingEventArgs

See Also

DocumentClosingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Members

[image] [image]

Revit 2011 API
DocumentClosingEventArgs Members
DocumentClosingEventArgs Class Methods Properties See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Methods

[image] [image]

Revit 2011 API
DocumentClosingEventArgs Methods
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Properties

[image] [image]

Revit 2011 API
DocumentClosingEventArgs Properties
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentId Property

[image]

Revit 2011 API
DocumentClosingEventArgs..::.DocumentId Property
DocumentClosingEventArgs Class See Also Send Feedback
Id of the document that is about to be closed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosed event which follows.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Class

[image]

Revit 2011 API
DocumentCreatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreated event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentCreatedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentCreatedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentCreatedEventArgs : public PostDocEventArgs

Remarks

The newly created document is supplied in these arguments.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentCreatedEventArgs

See Also

DocumentCreatedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Members

[image] [image]

Revit 2011 API
DocumentCreatedEventArgs Members
DocumentCreatedEventArgs Class Methods Properties See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentCreatedEventArgs Methods
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentCreatedEventArgs Properties
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Class

[image]

Revit 2011 API
DocumentCreatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreating event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentCreatingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DocumentCreatingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DocumentCreatingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.DocumentCreatingEventArgs

See Also

DocumentCreatingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Members

[image] [image]

Revit 2011 API
DocumentCreatingEventArgs Members
DocumentCreatingEventArgs Class Methods Properties See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Methods

[image] [image]

Revit 2011 API
DocumentCreatingEventArgs Methods
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Properties

[image] [image]

Revit 2011 API
DocumentCreatingEventArgs Properties
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentType Property

[image]

Revit 2011 API
DocumentCreatingEventArgs..::.DocumentType Property
DocumentCreatingEventArgs Class See Also Send Feedback
Type of the document which is about to be created, e.g. Project or Template.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Template Property

[image]

Revit 2011 API
DocumentCreatingEventArgs..::.Template Property
DocumentCreatingEventArgs Class See Also Send Feedback
The template file path to be used for creating the new document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Template { get; }
Visual Basic (Declaration)
Public ReadOnly Property Template As String
Visual C++
public:
property String^ Template {
    String^ get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Class

[image]

Revit 2011 API
DocumentOpenedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpened event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentOpenedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentOpenedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentOpenedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentOpenedEventArgs

See Also

DocumentOpenedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Members

[image] [image]

Revit 2011 API
DocumentOpenedEventArgs Members
DocumentOpenedEventArgs Class Methods Properties See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentOpenedEventArgs Methods
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentOpenedEventArgs Properties
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Class

[image]

Revit 2011 API
DocumentOpeningEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpening event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentOpeningEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DocumentOpeningEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DocumentOpeningEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.DocumentOpeningEventArgs

See Also

DocumentOpeningEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Members

[image] [image]

Revit 2011 API
DocumentOpeningEventArgs Members
DocumentOpeningEventArgs Class Methods Properties See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document, e.g. Project or Template.
PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Methods

[image] [image]

Revit 2011 API
DocumentOpeningEventArgs Methods
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Properties

[image] [image]

Revit 2011 API
DocumentOpeningEventArgs Properties
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DocumentType | Type of the document, e.g. Project or Template.
PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentType Property

[image]

Revit 2011 API
DocumentOpeningEventArgs..::.DocumentType Property
DocumentOpeningEventArgs Class See Also Send Feedback
Type of the document, e.g. Project or Template.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


PathName Property

[image]

Revit 2011 API
DocumentOpeningEventArgs..::.PathName Property
DocumentOpeningEventArgs Class See Also Send Feedback
Path of the document to be opened.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Class

[image]

Revit 2011 API
DocumentPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinted event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentPrintedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentPrintedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentPrintedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentPrintedEventArgs

See Also

DocumentPrintedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Members

[image] [image]

Revit 2011 API
DocumentPrintedEventArgs Members
DocumentPrintedEventArgs Class Methods Properties See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
FailedViews | Views that failed to print (if any).
PrintedViews | Views that printed successfully.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentPrintedEventArgs Methods
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentPrintedEventArgs Properties
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
FailedViews | Views that failed to print (if any).
PrintedViews | Views that printed successfully.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FailedViews Property

[image]

Revit 2011 API
DocumentPrintedEventArgs..::.FailedViews Property
DocumentPrintedEventArgs Class See Also Send Feedback
Views that failed to print (if any).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet FailedViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property FailedViews As ViewSet
Visual C++
public:
property ViewSet^ FailedViews {
    ViewSet^ get ();
}

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


PrintedViews Property

[image]

Revit 2011 API
DocumentPrintedEventArgs..::.PrintedViews Property
DocumentPrintedEventArgs Class See Also Send Feedback
Views that printed successfully.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet PrintedViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintedViews As ViewSet
Visual C++
public:
property ViewSet^ PrintedViews {
    ViewSet^ get ();
}

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Class

[image]

Revit 2011 API
DocumentPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentPrintingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentPrintingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentPrintingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentPrintingEventArgs

See Also

DocumentPrintingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Members

[image] [image]

Revit 2011 API
DocumentPrintingEventArgs Members
DocumentPrintingEventArgs Class Methods Properties See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Settings | Print Settings of current project.
Views | Set of views to be printed.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Methods

[image] [image]

Revit 2011 API
DocumentPrintingEventArgs Methods
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Properties

[image] [image]

Revit 2011 API
DocumentPrintingEventArgs Properties
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Settings | Print Settings of current project.
Views | Set of views to be printed.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Settings Property

[image]

Revit 2011 API
DocumentPrintingEventArgs..::.Settings Property
DocumentPrintingEventArgs Class See Also Send Feedback
Print Settings of current project.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IPrintSetting Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As IPrintSetting
Visual C++
public:
property IPrintSetting^ Settings {
    IPrintSetting^ get ();
}

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Views Property

[image]

Revit 2011 API
DocumentPrintingEventArgs..::.Views Property
DocumentPrintingEventArgs Class See Also Send Feedback
Set of views to be printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ViewSet Views { get; }
Visual Basic (Declaration)
Public ReadOnly Property Views As ViewSet
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Class

[image]

Revit 2011 API
DocumentSavedAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavedAs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSavedAsEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavedAsEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSavedAsEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavedAsEventArgs

See Also

DocumentSavedAsEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Members

[image] [image]

Revit 2011 API
DocumentSavedAsEventArgs Members
DocumentSavedAsEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
IsSavedAsMasterFile | Indicates whether the document is saved as master file.
OriginalPath | Original path of the document.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSavedAsEventArgs Methods
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSavedAsEventArgs Properties
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
IsSavedAsMasterFile | Indicates whether the document is saved as master file.
OriginalPath | Original path of the document.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsSavedAsMasterFile Property

[image]

Revit 2011 API
DocumentSavedAsEventArgs..::.IsSavedAsMasterFile Property
DocumentSavedAsEventArgs Class See Also Send Feedback
Indicates whether the document is saved as master file.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSavedAsMasterFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSavedAsMasterFile As Boolean
Visual C++
public:
property bool IsSavedAsMasterFile {
    bool get ();
}

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


OriginalPath Property

[image]

Revit 2011 API
DocumentSavedAsEventArgs..::.OriginalPath Property
DocumentSavedAsEventArgs Class See Also Send Feedback
Original path of the document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string OriginalPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property OriginalPath As String
Visual C++
public:
property String^ OriginalPath {
    String^ get ();
}

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Class

[image]

Revit 2011 API
DocumentSavedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaved event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSavedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSavedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavedEventArgs

See Also

DocumentSavedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Members

[image] [image]

Revit 2011 API
DocumentSavedEventArgs Members
DocumentSavedEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSavedEventArgs Methods
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSavedEventArgs Properties
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Class

[image]

Revit 2011 API
DocumentSavingAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavingAs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSavingAsEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavingAsEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSavingAsEventArgs : public PreDocEventArgs

Remarks

This event is cancellable, except when it is raised when the Revit application is closing.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingAsEventArgs

See Also

DocumentSavingAsEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Members

[image] [image]

Revit 2011 API
DocumentSavingAsEventArgs Members
DocumentSavingAsEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSavingAsEventArgs Methods
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSavingAsEventArgs Properties
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsSavingAsMasterFile Property

[image]

Revit 2011 API
DocumentSavingAsEventArgs..::.IsSavingAsMasterFile Property
DocumentSavingAsEventArgs Class See Also Send Feedback
Indicates whether the document is to be saved as master file.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsSavingAsMasterFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSavingAsMasterFile As Boolean
Visual C++
public:
property bool IsSavingAsMasterFile {
    bool get ();
}

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


PathName Property

[image]

Revit 2011 API
DocumentSavingAsEventArgs..::.PathName Property
DocumentSavingAsEventArgs Class See Also Send Feedback
Target path to which the document is to be saved.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathName As String
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Class

[image]

Revit 2011 API
DocumentSavingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaving event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSavingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSavingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSavingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingEventArgs

See Also

DocumentSavingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Members

[image] [image]

Revit 2011 API
DocumentSavingEventArgs Members
DocumentSavingEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSavingEventArgs Methods
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSavingEventArgs Properties
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Class

[image]

Revit 2011 API
DocumentSynchronizedWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizedWithCentral event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSynchronizedWithCentralEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSynchronizedWithCentralEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class DocumentSynchronizedWithCentralEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSynchronizedWithCentralEventArgs

See Also

DocumentSynchronizedWithCentralEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Members

[image] [image]

Revit 2011 API
DocumentSynchronizedWithCentralEventArgs Members
DocumentSynchronizedWithCentralEventArgs Class Methods Properties See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSynchronizedWithCentralEventArgs Methods
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSynchronizedWithCentralEventArgs Properties
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Class

[image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizingWithCentral event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DocumentSynchronizingWithCentralEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class DocumentSynchronizingWithCentralEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class DocumentSynchronizingWithCentralEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentSynchronizingWithCentralEventArgs

See Also

DocumentSynchronizingWithCentralEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Members

[image] [image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs Members
DocumentSynchronizingWithCentralEventArgs Class Methods Properties See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Comments | User's comments for synchronization.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Location | Full path of the central file which is to be synchronized.
Options | User's options associated with a the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Methods

[image] [image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs Methods
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Properties

[image] [image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs Properties
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Comments | User's comments for synchronization.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Location | Full path of the central file which is to be synchronized.
Options | User's options associated with a the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Comments Property

[image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs..::.Comments Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's comments for synchronization.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Comments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Comments As String
Visual C++
public:
property String^ Comments {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Location Property

[image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs..::.Location Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
Full path of the central file which is to be synchronized.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Options Property

[image]

Revit 2011 API
DocumentSynchronizingWithCentralEventArgs..::.Options Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's options associated with a the synchronization operation.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SynchronizeWithCentralOptions Options { get; }
Visual Basic (Declaration)
Public ReadOnly Property Options As SynchronizeWithCentralOptions
Visual C++
public:
property SynchronizeWithCentralOptions^ Options {
    SynchronizeWithCentralOptions^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


EventStatus Enumeration

[image]

Revit 2011 API
EventStatus Enumeration
See Also Send Feedback
Describes the status of an action which triggered a post event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum EventStatus
Visual Basic (Declaration)
Public Enumeration EventStatus
Visual C++
public enum class EventStatus

Members

Member name | Description
Failed | The action that triggered this event failed.
Succeeded | The action that triggered this event succeeded.
Cancelled | The action that triggered this event was cancelled by an event handler from the pre-event for the action.

See Also

Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Class

[image]

Revit 2011 API
FailuresProcessingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FailuresProcessing event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FailuresProcessingEventArgs : RevitAPISingleEventArgs
Visual Basic (Declaration)
Public Class FailuresProcessingEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class FailuresProcessingEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::.FailuresProcessingEventArgs

See Also

FailuresProcessingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Members

[image] [image]

Revit 2011 API
FailuresProcessingEventArgs Members
FailuresProcessingEventArgs Class Methods See Also Send Feedback

The FailuresProcessingEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailuresAccessor | Provides access to the failure information in the document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProcessingResult | Retrieves current status of the failures processing result.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
SetProcessingResult | Sets the result of the failures processing.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Methods

[image] [image]

Revit 2011 API
FailuresProcessingEventArgs Methods
FailuresProcessingEventArgs Class See Also Send Feedback

The FailuresProcessingEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetFailuresAccessor | Provides access to the failure information in the document.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProcessingResult | Retrieves current status of the failures processing result.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
SetProcessingResult | Sets the result of the failures processing.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetFailuresAccessor Method

[image]

Revit 2011 API
FailuresProcessingEventArgs..::.GetFailuresAccessor Method
FailuresProcessingEventArgs Class See Also Send Feedback
Provides access to the failure information in the document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailuresAccessor GetFailuresAccessor()
Visual Basic (Declaration)
Public Function GetFailuresAccessor As FailuresAccessor
Visual C++
public:
FailuresAccessor^ GetFailuresAccessor()

Return Value

The accessor to the failures in the document.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetProcessingResult Method

[image]

Revit 2011 API
FailuresProcessingEventArgs..::.GetProcessingResult Method
FailuresProcessingEventArgs Class See Also Send Feedback
Retrieves current status of the failures processing result.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FailureProcessingResult GetProcessingResult()
Visual Basic (Declaration)
Public Function GetProcessingResult As FailureProcessingResult
Visual C++
public:
FailureProcessingResult GetProcessingResult()

Return Value

The current failures processing result.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


SetProcessingResult Method

[image]

Revit 2011 API
FailuresProcessingEventArgs..::.SetProcessingResult Method
FailuresProcessingEventArgs Class See Also Send Feedback
Sets the result of the failures processing.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetProcessingResult(
    FailureProcessingResult result
)
Visual Basic (Declaration)
Public Sub SetProcessingResult ( _
    result As FailureProcessingResult _
)
Visual C++
public:
void SetProcessingResult(
    FailureProcessingResult result
)

Parameters

result
Type: Autodesk.Revit.DB..::.FailureProcessingResult
The result.

Remarks

Setting this result may not affect the outcome if other observers of the event are invoked after this one. The most prohibitive result set by all handlers will be used.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Class

[image]

Revit 2011 API
FileExportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExported event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FileExportedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class FileExportedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class FileExportedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.FileExportedEventArgs

See Also

FileExportedEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Members

[image] [image]

Revit 2011 API
FileExportedEventArgs Members
FileExportedEventArgs Class Methods Properties See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | Target path for the exported file (or files).
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Methods

[image] [image]

Revit 2011 API
FileExportedEventArgs Methods
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Properties

[image] [image]

Revit 2011 API
FileExportedEventArgs Properties
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | Target path for the exported file (or files).
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2011 API
FileExportedEventArgs..::.Format Property
FileExportedEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2011 API
FileExportedEventArgs..::.Path Property
FileExportedEventArgs Class See Also Send Feedback
Target path for the exported file (or files).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

In some cases the path represents only the target directory or a template name. Such cases include batch export when more than one file is exported as one event.

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Class

[image]

Revit 2011 API
FileExportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExporting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FileExportingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class FileExportingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class FileExportingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.FileExportingEventArgs

See Also

FileExportingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Members

[image] [image]

Revit 2011 API
FileExportingEventArgs Members
FileExportingEventArgs Class Methods Properties See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Methods

[image] [image]

Revit 2011 API
FileExportingEventArgs Methods
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Properties

[image] [image]

Revit 2011 API
FileExportingEventArgs Properties
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the export format, e.g. DWG or image.
Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2011 API
FileExportingEventArgs..::.Format Property
FileExportingEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2011 API
FileExportingEventArgs..::.Path Property
FileExportingEventArgs Class See Also Send Feedback
The target path for the export.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

When several files are exported at the same time, 'Path' property will just report the directory instead of those full file names.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Class

[image]

Revit 2011 API
FileImportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImported event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FileImportedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class FileImportedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class FileImportedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.FileImportedEventArgs

See Also

FileImportedEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Members

[image] [image]

Revit 2011 API
FileImportedEventArgs Members
FileImportedEventArgs Class Methods Properties See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
ImportedInstance | The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.
Path | Path of the source file that was imported.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Methods

[image] [image]

Revit 2011 API
FileImportedEventArgs Methods
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Properties

[image] [image]

Revit 2011 API
FileImportedEventArgs Properties
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
ImportedInstance | The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.
Path | Path of the source file that was imported.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2011 API
FileImportedEventArgs..::.Format Property
FileImportedEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ImportedInstance Property

[image]

Revit 2011 API
FileImportedEventArgs..::.ImportedInstance Property
FileImportedEventArgs Class See Also Send Feedback
The instance of the element that represents the imported object(s) after a successful import. It could be used for further manipulating of that instance.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element ImportedInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImportedInstance As Element
Visual C++
public:
property Element^ ImportedInstance {
    Element^ get ();
}

Remarks

This property is nullNothingnullptra null reference (Nothing in Visual Basic) when the event is invoked due to import of GBXML and Inventor files.

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2011 API
FileImportedEventArgs..::.Path Property
FileImportedEventArgs Class See Also Send Feedback
Path of the source file that was imported.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Class

[image]

Revit 2011 API
FileImportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImporting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FileImportingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class FileImportingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class FileImportingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.FileImportingEventArgs

See Also

FileImportingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Members

[image] [image]

Revit 2011 API
FileImportingEventArgs Members
FileImportingEventArgs Class Methods Properties See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Methods

[image] [image]

Revit 2011 API
FileImportingEventArgs Methods
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Properties

[image] [image]

Revit 2011 API
FileImportingEventArgs Properties
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Format | Identifies the import format, e.g. DWG or image.
Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2011 API
FileImportingEventArgs..::.Format Property
FileImportingEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As ImportExportFileFormat
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2011 API
FileImportingEventArgs..::.Path Property
FileImportingEventArgs Class See Also Send Feedback
Path of the source file which is about to be imported.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Path { get; }
Visual Basic (Declaration)
Public ReadOnly Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Class

[image]

Revit 2011 API
PostDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for arguments of any post-event that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PostDocEventArgs : PostEventArgs
Visual Basic (Declaration)
Public Class PostDocEventArgs _
    Inherits PostEventArgs
Visual C++
public ref class PostDocEventArgs : public PostEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentCreatedEventArgs
Autodesk.Revit.DB.Events..::.DocumentOpenedEventArgs
Autodesk.Revit.DB.Events..::.DocumentPrintedEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavedAsEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavedEventArgs
Autodesk.Revit.DB.Events..::.DocumentSynchronizedWithCentralEventArgs
Autodesk.Revit.DB.Events..::.FileExportedEventArgs
Autodesk.Revit.DB.Events..::.FileImportedEventArgs
Autodesk.Revit.DB.Events..::.ViewPrintedEventArgs
Autodesk.Revit.UI.Events..::.ViewActivatedEventArgs

See Also

PostDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Members

[image] [image]

Revit 2011 API
PostDocEventArgs Members
PostDocEventArgs Class Methods Properties See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Methods

[image] [image]

Revit 2011 API
PostDocEventArgs Methods
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Properties

[image] [image]

Revit 2011 API
PostDocEventArgs Properties
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2011 API
PostDocEventArgs..::.Document Property
PostDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Class

[image]

Revit 2011 API
PostEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any post-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PostEventArgs : RevitEventArgs
Visual Basic (Declaration)
Public Class PostEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PostEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.DocumentClosedEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs

See Also

PostEventArgs Members
Autodesk.Revit.DB.Events Namespace


PostEventArgs Members

[image] [image]

Revit 2011 API
PostEventArgs Members
PostEventArgs Class Methods Properties See Also Send Feedback

The PostEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Methods

[image] [image]

Revit 2011 API
PostEventArgs Methods
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Properties

[image] [image]

Revit 2011 API
PostEventArgs Properties
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


Status Property

[image]

Revit 2011 API
PostEventArgs..::.Status Property
PostEventArgs Class See Also Send Feedback
Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public EventStatus Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As EventStatus
Visual C++
public:
property EventStatus Status {
    EventStatus get ();
}

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Class

[image]

Revit 2011 API
PreDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class PreDocEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.DocumentClosingEventArgs
Autodesk.Revit.DB.Events..::.DocumentPrintingEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingAsEventArgs
Autodesk.Revit.DB.Events..::.DocumentSavingEventArgs
Autodesk.Revit.DB.Events..::.DocumentSynchronizingWithCentralEventArgs
Autodesk.Revit.DB.Events..::.FileExportingEventArgs
Autodesk.Revit.DB.Events..::.FileImportingEventArgs
Autodesk.Revit.DB.Events..::.ViewPrintingEventArgs
Autodesk.Revit.UI.Events..::.ViewActivatingEventArgs

See Also

PreDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Members

[image] [image]

Revit 2011 API
PreDocEventArgs Members
PreDocEventArgs Class Methods Properties See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Methods

[image] [image]

Revit 2011 API
PreDocEventArgs Methods
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Properties

[image] [image]

Revit 2011 API
PreDocEventArgs Properties
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2011 API
PreDocEventArgs..::.Document Property
PreDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Class

[image]

Revit 2011 API
PreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PreEventArgs : RevitEventArgs
Visual Basic (Declaration)
Public Class PreEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PreEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.DocumentCreatingEventArgs
Autodesk.Revit.DB.Events..::.DocumentOpeningEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.UI.Events..::.ApplicationClosingEventArgs
Autodesk.Revit.UI.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::.IdlingEventArgs

See Also

PreEventArgs Members
Autodesk.Revit.DB.Events Namespace


PreEventArgs Members

[image] [image]

Revit 2011 API
PreEventArgs Members
PreEventArgs Class Methods Properties See Also Send Feedback

The PreEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Methods

[image] [image]

Revit 2011 API
PreEventArgs Methods
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Properties

[image] [image]

Revit 2011 API
PreEventArgs Properties
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Class

[image]

Revit 2011 API
RevitAPIEventArgs Class
Members See Also Send Feedback
The class is used as base class for all event argument classes.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIEventArgs : EventArgs,
    IDisposable
Visual Basic (Declaration)
Public Class RevitAPIEventArgs _
    Inherits EventArgs _
    Implements IDisposable
Visual C++
public ref class RevitAPIEventArgs : public EventArgs,
    IDisposable

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::.RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::.RevitAPISingleEventArgs

See Also

RevitAPIEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Members

[image] [image]

Revit 2011 API
RevitAPIEventArgs Members
RevitAPIEventArgs Class Methods See Also Send Feedback

The RevitAPIEventArgs type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate.
IsCancelled | Indicates whether the event is being cancelled.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Methods

[image] [image]

Revit 2011 API
RevitAPIEventArgs Methods
RevitAPIEventArgs Class See Also Send Feedback

The RevitAPIEventArgs type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate.
IsCancelled | Indicates whether the event is being cancelled.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


Dispose Method

[image]

Revit 2011 API
RevitAPIEventArgs..::.Dispose Method
RevitAPIEventArgs Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsCancellable Method

[image]

Revit 2011 API
RevitAPIEventArgs..::.IsCancellable Method
RevitAPIEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsCancellable()
Visual Basic (Declaration)
Public Function IsCancellable As Boolean
Visual C++
public:
bool IsCancellable()

Remarks

If IsCancellable() returns true, event delegates may cancel the command that was announced by the event. To do so, a delegate may call the Cancel() method if it is available. Typically, single-events and post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsCancelled Method

[image]

Revit 2011 API
RevitAPIEventArgs..::.IsCancelled Method
RevitAPIEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsCancelled()
Visual Basic (Declaration)
Public Function IsCancelled As Boolean
Visual C++
public:
bool IsCancelled()

Remarks

If the event is cancellable and an event delegate wishes to cancel the event, it may call the Cancel() method if it is available for a particular event's arguments.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventStatus Enumeration

[image]

Revit 2011 API
RevitAPIEventStatus Enumeration
See Also Send Feedback
Describes the status of an action which triggered a post event.
Describes the status of an action which triggered a post event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum RevitAPIEventStatus
Visual Basic (Declaration)
Public Enumeration RevitAPIEventStatus
Visual C++
public enum class RevitAPIEventStatus

Members

Member name | Description
Failed | The action that triggered this event failed .
Succeeded | The action that triggered this event succeeded.
Cancelled | The action that triggered this event was cancelled by an event handler from the pre-event for the action.

See Also

Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Class

[image]

Revit 2011 API
RevitAPIPostEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any post-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPostEventArgs : RevitAPIEventArgs
Visual Basic (Declaration)
Public Class RevitAPIPostEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPostEventArgs : public RevitAPIEventArgs

Remarks

A post-event is the event raised after execution of the process that was related with the event.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPIPostEventArgs

See Also

RevitAPIPostEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Members

[image] [image]

Revit 2011 API
RevitAPIPostEventArgs Members
RevitAPIPostEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Methods

[image] [image]

Revit 2011 API
RevitAPIPostEventArgs Methods
RevitAPIPostEventArgs Class See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Properties

[image] [image]

Revit 2011 API
RevitAPIPostEventArgs Properties
RevitAPIPostEventArgs Class See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Properties

Name | Description
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


Status Property

[image]

Revit 2011 API
RevitAPIPostEventArgs..::.Status Property
RevitAPIPostEventArgs Class See Also Send Feedback
Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public RevitAPIEventStatus Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As RevitAPIEventStatus
Visual C++
public:
property RevitAPIEventStatus Status {
    RevitAPIEventStatus get ();
}

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Class

[image]

Revit 2011 API
RevitAPIPreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPreEventArgs : RevitAPIEventArgs
Visual Basic (Declaration)
Public Class RevitAPIPreEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPreEventArgs : public RevitAPIEventArgs

Remarks

A pre-event is the event raised before executing the process that was related with the event.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPIPreEventArgs

See Also

RevitAPIPreEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Members

[image] [image]

Revit 2011 API
RevitAPIPreEventArgs Members
RevitAPIPreEventArgs Class Methods See Also Send Feedback

The RevitAPIPreEventArgs type exposes the following members.

Methods

Name | Description
Cancel | When the event is cancellable, may call the Cancel() method to cancel it.
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Methods

[image] [image]

Revit 2011 API
RevitAPIPreEventArgs Methods
RevitAPIPreEventArgs Class See Also Send Feedback

The RevitAPIPreEventArgs type exposes the following members.

Methods

Name | Description
Cancel | When the event is cancellable, may call the Cancel() method to cancel it.
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancel Method

[image]

Revit 2011 API
RevitAPIPreEventArgs..::.Cancel Method
RevitAPIPreEventArgs Class See Also Send Feedback
When the event is cancellable, may call the Cancel() method to cancel it.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

Not every event is cancellable. Whether or not an event may be cancelled is indicated by IsCancellable() method.

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Class

[image]

Revit 2011 API
RevitAPISingleEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any single-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RevitAPISingleEventArgs : RevitAPIEventArgs
Visual Basic (Declaration)
Public Class RevitAPISingleEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPISingleEventArgs : public RevitAPIEventArgs

Remarks

A single event is an event that is not directly related to another event, meaning that there is no corresponding pre-event or post-event surrounding a single event.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitAPIEventArgs
Autodesk.Revit.DB.Events..::.RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::.DocumentChangedEventArgs
Autodesk.Revit.DB.Events..::.FailuresProcessingEventArgs

See Also

RevitAPISingleEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Members

[image] [image]

Revit 2011 API
RevitAPISingleEventArgs Members
RevitAPISingleEventArgs Class Methods See Also Send Feedback

The RevitAPISingleEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPISingleEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Methods

[image] [image]

Revit 2011 API
RevitAPISingleEventArgs Methods
RevitAPISingleEventArgs Class See Also Send Feedback

The RevitAPISingleEventArgs type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from RevitAPIEventArgs.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPISingleEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Class

[image]

Revit 2011 API
RevitEventArgs Class
Members See Also Send Feedback
The class is used as base class for all event argument classes.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RevitEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RevitEventArgs _
    Inherits EventArgs
Visual C++
public ref class RevitEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs

See Also

RevitEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Members

[image] [image]

Revit 2011 API
RevitEventArgs Members
RevitEventArgs Class Methods Properties See Also Send Feedback

The RevitEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Methods

[image] [image]

Revit 2011 API
RevitEventArgs Methods
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Properties

[image] [image]

Revit 2011 API
RevitEventArgs Properties
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancel Property

[image]

Revit 2011 API
RevitEventArgs..::.Cancel Property
RevitEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Cancel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Cancel As Boolean
Visual C++
public:
virtual property bool Cancel {
    bool get ();
    void set (bool value);
}

Remarks

If an event delegate wishes to cancel the event, it should set the value of this property to True. Not every event is cancellable. Whether or not an event may be cancelled is indicated by the value of 'Cancellable' property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown if an event delegate attempts to cancel a non-cancellable event.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancellable Property

[image]

Revit 2011 API
RevitEventArgs..::.Cancellable Property
RevitEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Cancellable { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Cancellable As Boolean
Visual C++
public:
virtual property bool Cancellable {
    bool get ();
}

Remarks

If 'Cancellable' is true, event delegates may cancel the command that was announced by the event. To do so, a delegate would set the 'Cancel' property to True. Typically, post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Class

[image]

Revit 2011 API
SynchronizeWithCentralOptions Class
Members See Also Send Feedback
Options for save to central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SynchronizeWithCentralOptions
Visual Basic (Declaration)
Public Class SynchronizeWithCentralOptions
Visual C++
public ref class SynchronizeWithCentralOptions

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Events..::.SynchronizeWithCentralOptions

See Also

SynchronizeWithCentralOptions Members
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Members

[image] [image]

Revit 2011 API
SynchronizeWithCentralOptions Members
SynchronizeWithCentralOptions Class Methods Properties See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Methods

[image] [image]

Revit 2011 API
SynchronizeWithCentralOptions Methods
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Properties

[image] [image]

Revit 2011 API
SynchronizeWithCentralOptions Properties
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Properties

Name | Description
CompactCentralFile | Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.
RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


CompactCentralFile Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.CompactCentralFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should compact the central file while synchronizing with central. This option reduces the size of the central file but many increase the time it takes to perform the save.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CompactCentralFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompactCentralFile As Boolean
Visual C++
public:
property bool CompactCentralFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishBorrowedElements Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.RelinquishBorrowedElements Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish borrowed elements after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RelinquishBorrowedElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishBorrowedElements As Boolean
Visual C++
public:
property bool RelinquishBorrowedElements {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishFamilyWorksets Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.RelinquishFamilyWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Family worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RelinquishFamilyWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishFamilyWorksets As Boolean
Visual C++
public:
property bool RelinquishFamilyWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishProjectStandardWorksets Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.RelinquishProjectStandardWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RelinquishProjectStandardWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishProjectStandardWorksets As Boolean
Visual C++
public:
property bool RelinquishProjectStandardWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishUserCreatedWorksets Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.RelinquishUserCreatedWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish user-created worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RelinquishUserCreatedWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishUserCreatedWorksets As Boolean
Visual C++
public:
property bool RelinquishUserCreatedWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishViewWorksets Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.RelinquishViewWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish View worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RelinquishViewWorksets { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelinquishViewWorksets As Boolean
Visual C++
public:
property bool RelinquishViewWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SaveLocalFile Property

[image]

Revit 2011 API
SynchronizeWithCentralOptions..::.SaveLocalFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should save the local file before and after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SaveLocalFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property SaveLocalFile As Boolean
Visual C++
public:
property bool SaveLocalFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


UndoOperation Enumeration

[image]

Revit 2011 API
UndoOperation Enumeration
See Also Send Feedback
The operation associated with DocumentChanged event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum UndoOperation
Visual Basic (Declaration)
Public Enumeration UndoOperation
Visual C++
public enum class UndoOperation

Members

Member name | Description
TransactionCommitted | A transaction was committed
TransactionRolledBack | A transaction was rolled back
TransactionGroupRolledBack | A transaction group was rolled back
TransactionUndone | A transaction was undone
TransactionRedone | A transaction was redone

See Also

Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Class

[image]

Revit 2011 API
ViewPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by ViewPrinted event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewPrintedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class ViewPrintedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class ViewPrintedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.DB.Events..::.ViewPrintedEventArgs

See Also

ViewPrintedEventArgs Members
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Members

[image] [image]

Revit 2011 API
ViewPrintedEventArgs Members
ViewPrintedEventArgs Class Methods Properties See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Methods

[image] [image]

Revit 2011 API
ViewPrintedEventArgs Methods
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Properties

[image] [image]

Revit 2011 API
ViewPrintedEventArgs Properties
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | View that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Index Property

[image]

Revit 2011 API
ViewPrintedEventArgs..::.Index Property
ViewPrintedEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


TotalViews Property

[image]

Revit 2011 API
ViewPrintedEventArgs..::.TotalViews Property
ViewPrintedEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TotalViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalViews As Integer
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


View Property

[image]

Revit 2011 API
ViewPrintedEventArgs..::.View Property
ViewPrintedEventArgs Class See Also Send Feedback
View that was printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Class

[image]

Revit 2011 API
ViewPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewPrinting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewPrintingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class ViewPrintingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class ViewPrintingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.DB.Events..::.ViewPrintingEventArgs

See Also

ViewPrintingEventArgs Members
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Members

[image] [image]

Revit 2011 API
ViewPrintingEventArgs Members
ViewPrintingEventArgs Class Methods Properties See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Methods

[image] [image]

Revit 2011 API
ViewPrintingEventArgs Methods
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Properties

[image] [image]

Revit 2011 API
ViewPrintingEventArgs Properties
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Index | When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.
Settings | Print Settings of current project.
TotalViews | When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.
View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Index Property

[image]

Revit 2011 API
ViewPrintingEventArgs..::.Index Property
ViewPrintingEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the index of this view in the entire set. The value is 0-based.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Settings Property

[image]

Revit 2011 API
ViewPrintingEventArgs..::.Settings Property
ViewPrintingEventArgs Class See Also Send Feedback
Print Settings of current project.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IPrintSetting Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As IPrintSetting
Visual C++
public:
property IPrintSetting^ Settings {
    IPrintSetting^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


TotalViews Property

[image]

Revit 2011 API
ViewPrintingEventArgs..::.TotalViews Property
ViewPrintingEventArgs Class See Also Send Feedback
When the view is being printed as a part of a view-set, the value of this property indicates the number of all views in the set.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TotalViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalViews As Integer
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


View Property

[image]

Revit 2011 API
ViewPrintingEventArgs..::.View Property
ViewPrintingEventArgs Class See Also Send Feedback
The view to be printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Autodesk.Revit.DB.Mechanical Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Mechanical Namespace
Send Feedback

Classes

Class | Description
BoundarySegment | An object that represents a segment of an area boundary.
BoundarySegmentArray | An array that contains boundary segments.
BoundarySegmentArrayArray | An array that contains boundary segment arrays.
BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
BoundarySegmentArrayIterator | An iterator to a boundary segment array.
Duct | A duct in the Autodesk Revit MEP product.
DuctConnector | A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.
DuctType | A duct type in the Autodesk Revit MEP product.
FlexDuct | A flex duct in the Autodesk Revit MEP product.
FlexDuctType | A flex duct type in the Autodesk Revit MEP product.
MechanicalEquipment | Provides access to the Mechanical Equipment in Autodesk Revit MEP.
MechanicalFitting | A mechanical fitting in the Autodesk Revit MEP product.
MechanicalSystem | A mechanical system in the Autodesk Revit MEP product.
MEPBuildingConstruction | Construction definition for Project Information.
MEPBuildingConstructionSet | A set that contains MEPBuildingConstructions.
MEPBuildingConstructionSetIterator | An iterator to a MEPBuildingConstruction set.
MEPSpaceConstruction | Construction definition for Space.
Space | Provides access to the space topology in Autodesk Revit.
SpaceFilter | A filter used to match spaces.
SpaceSet | A set that can contain any type of object.
SpaceSetIterator | An iterator to a set.
SpaceTag | Provides access to the space tag in Autodesk Revit.
SpaceTagFilter | A filter used to match space tags.
SpaceTagType | An object that represents a Space Tag style.
SpaceTagTypeSet | A set that contains space tag types.
SpaceTagTypeSetIterator | An iterator to a space tag type set.
Zone | Provides access to the Zone Element in Autodesk Revit.

Enumerations

Enumeration | Description
ConditionType | An enumerated type listing all the possible condition types for a space object.
DuctFlowConfigurationType | An enumerated type listing all duct flow configuration types for a connector.
DuctLossMethodType | An enumerated type listing all duct loss calculation methods for a connector.
DuctSystemType | An enumerated type listing all the possible duct system types for a duct connector object.
OccupancyUnit | An enumerated type listing the occupancy unit of measure for a space object.
ReturnAirflowType | An enumerated type listing all the possible return airflow types for a space object.
SpaceType | An enumerated type listing all the possible space types for a space object.


BoundarySegment Class

[image]

Revit 2011 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic (Declaration)
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Members

[image] [image]

Revit 2011 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Methods

[image] [image]

Revit 2011 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Properties

[image] [image]

Revit 2011 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

Name | Description
Curve | Get the curve that is formed by the element that defines the edge of this area.
Document | Provides the document in which the element that created this segment resides.
Element | Retrieve the element that is responsible for producing this boundary segment.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Curve Property

[image]

Revit 2011 API
BoundarySegment..::.Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Document Property

[image]

Revit 2011 API
BoundarySegment..::.Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Element Property

[image]

Revit 2011 API
BoundarySegment..::.Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Class

[image]

Revit 2011 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Constructor

[image]

Revit 2011 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment to the end of the array.
Clear | Removes every boundary segment from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified boundary segment into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Append Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2011 API
BoundarySegmentArray..::.Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::.Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArray..::.ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment at a specified index within the array.
Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArray..::.IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Item Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegment Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2011 API
BoundarySegmentArray..::.Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2011 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

Name | Description
Append | Add the boundary segment array to the end of the array.
Clear | Removes every boundary segment array from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Append Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArray
index
Type: System..::.Int32

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets a boundary segment array at a specified index within the array.
Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Item Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual BoundarySegmentArray Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::.Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2011 API
BoundarySegmentArrayArray..::.Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayArrayIterator..::.Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2011 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

Name | Description
BoundarySegmentArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2011 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2011 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2011 API
BoundarySegmentArrayIterator..::.Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


ConditionType Enumeration

[image]

Revit 2011 API
ConditionType Enumeration
See Also Send Feedback
An enumerated type listing all the possible condition types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ConditionType
Visual Basic (Declaration)
Public Enumeration ConditionType
Visual C++
public enum class ConditionType

Members

Member name | Description
Heated | Condition Type is Heated.
Cooled | Condition Type is Cooled.
HeatedAndCooled | Condition Type is HeatedAndCooled.
Unconditioned | Condition Type is Unconditioned.
Vented | Condition Type is Vented.
NaturallyVentedOnly | Condition Type is NaturallyVentedOnly.
NoOfConditionTypes | Condition Type is NoOfConditionTypes.

See Also

Autodesk.Revit.DB.Mechanical Namespace


Duct Class

[image]

Revit 2011 API
Duct Class
Members See Also Send Feedback
A duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Duct : MEPCurve
Visual Basic (Declaration)
Public Class Duct _
    Inherits MEPCurve
Visual C++
public ref class Duct : public MEPCurve

Remarks

The duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Mechanical..::.Duct

See Also

Duct Members
Autodesk.Revit.DB.Mechanical Namespace


Duct Members

[image] [image]

Revit 2011 API
Duct Members
Duct Class Methods Properties See Also Send Feedback

The Duct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctType | The duct type of this duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Duct Methods

[image] [image]

Revit 2011 API
Duct Methods
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Duct Properties

[image] [image]

Revit 2011 API
Duct Properties
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctType | The duct type of this duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Property

[image]

Revit 2011 API
Duct..::.DuctType Property
Duct Class See Also Send Feedback
The duct type of this duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctType DuctType { get; set; }
Visual Basic (Declaration)
Public Property DuctType As DuctType
Visual C++
public:
property DuctType^ DuctType {
    DuctType^ get ();
    void set (DuctType^ value);
}

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
Duct..::.Parameter Property
Duct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Duct Class
Duct Members
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Class

[image]

Revit 2011 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DuctConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class DuctConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class DuctConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Duct connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Mechanical..::.DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Members

[image] [image]

Revit 2011 API
DuctConnector Members
DuctConnector Class Methods Properties See Also Send Feedback

The DuctConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a duct connector as a primary duct connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector within the family.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked duct connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | the radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the duct connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Methods

[image] [image]

Revit 2011 API
DuctConnector Methods
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a duct connector as a primary duct connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


AssignAsPrimary Method

[image]

Revit 2011 API
DuctConnector..::.AssignAsPrimary Method
DuctConnector Class See Also Send Feedback
Assign a duct connector as a primary duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this duct connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Properties

[image] [image]

Revit 2011 API
DuctConnector Properties
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector within the family.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked duct connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | the radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the duct connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


CoordinateSystem Property

[image]

Revit 2011 API
DuctConnector..::.CoordinateSystem Property
DuctConnector Class See Also Send Feedback
The coordinate system of the connector within the family.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Domain Property

[image]

Revit 2011 API
DuctConnector..::.Domain Property
DuctConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

The domain of a duct connector is always DomainHvac.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Height Property

[image]

Revit 2011 API
DuctConnector..::.Height Property
DuctConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


IsPrimary Property

[image]

Revit 2011 API
DuctConnector..::.IsPrimary Property
DuctConnector Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


LinkedConnector Property

[image]

Revit 2011 API
DuctConnector..::.LinkedConnector Property
DuctConnector Class See Also Send Feedback
The linked duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As DuctConnector
Visual C++
public:
property DuctConnector^ LinkedConnector {
    DuctConnector^ get ();
    void set (DuctConnector^ value);
}

Remarks

Get this property to acquire the current linked duct connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another duct connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Origin Property

[image]

Revit 2011 API
DuctConnector..::.Origin Property
DuctConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
DuctConnector..::.Parameter Property
DuctConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DuctConnector Class
DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace


Radius Property

[image]

Revit 2011 API
DuctConnector..::.Radius Property
DuctConnector Class See Also Send Feedback
the radius of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not circular.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Shape Property

[image]

Revit 2011 API
DuctConnector..::.Shape Property
DuctConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


SystemType Property

[image]

Revit 2011 API
DuctConnector..::.SystemType Property
DuctConnector Class See Also Send Feedback
The system type of the duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As DuctSystemType
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
    void set (DuctSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Width Property

[image]

Revit 2011 API
DuctConnector..::.Width Property
DuctConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctFlowConfigurationType Enumeration

[image]

Revit 2011 API
DuctFlowConfigurationType Enumeration
See Also Send Feedback
An enumerated type listing all duct flow configuration types for a connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DuctFlowConfigurationType
Visual Basic (Declaration)
Public Enumeration DuctFlowConfigurationType
Visual C++
public enum class DuctFlowConfigurationType

Members

Member name | Description
Calculated | Duct flow configuration is calculated.
Preset | Duct flow configuration is preset.
System | Duct flow configuration depends on system.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctLossMethodType Enumeration

[image]

Revit 2011 API
DuctLossMethodType Enumeration
See Also Send Feedback
An enumerated type listing all duct loss calculation methods for a connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DuctLossMethodType
Visual Basic (Declaration)
Public Enumeration DuctLossMethodType
Visual C++
public enum class DuctLossMethodType

Members

Member name | Description
NotDefined | Duct loss method is undefined.
SpecificLoss | Duct loss method is specified.
Coefficient | Duct loss method depends on the loss coefficient.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctSystemType Enumeration

[image]

Revit 2011 API
DuctSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible duct system types for a duct connector object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum DuctSystemType
Visual Basic (Declaration)
Public Enumeration DuctSystemType
Visual C++
public enum class DuctSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type
SupplyAir | Duct System Type is SupplyAir.
ReturnAir | Duct System Type is ReturnAir.
ExhaustAir | Duct System Type is ExhaustAir.
OtherAir | Duct System Type is OtherAir.
Fitting | Duct System Type is Fitting.
Global | Duct System Type is Global.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctType Class

[image]

Revit 2011 API
DuctType Class
Members See Also Send Feedback
A duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class DuctType : MEPCurveType
Visual Basic (Declaration)
Public Class DuctType _
    Inherits MEPCurveType
Visual C++
public ref class DuctType : public MEPCurveType

Remarks

The duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Mechanical..::.DuctType

See Also

DuctType Members
Autodesk.Revit.DB.Mechanical Namespace


DuctType Members

[image] [image]

Revit 2011 API
DuctType Members
DuctType Class Methods Properties See Also Send Feedback

The DuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Methods

[image] [image]

Revit 2011 API
DuctType Methods
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Properties

[image] [image]

Revit 2011 API
DuctType Properties
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
DuctType..::.Parameter Property
DuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

DuctType Class
DuctType Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Class

[image]

Revit 2011 API
FlexDuct Class
Members See Also Send Feedback
A flex duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexDuct : MEPCurve
Visual Basic (Declaration)
Public Class FlexDuct _
    Inherits MEPCurve
Visual C++
public ref class FlexDuct : public MEPCurve

Remarks

The flex duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Mechanical..::.FlexDuct

See Also

FlexDuct Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Members

[image] [image]

Revit 2011 API
FlexDuct Members
FlexDuct Class Methods Properties See Also Send Feedback

The FlexDuct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexDuctType | The flex duct type of this flex duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex duct.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Methods

[image] [image]

Revit 2011 API
FlexDuct Methods
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Properties

[image] [image]

Revit 2011 API
FlexDuct Properties
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexDuctType | The flex duct type of this flex duct.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex duct.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Property

[image]

Revit 2011 API
FlexDuct..::.FlexDuctType Property
FlexDuct Class See Also Send Feedback
The flex duct type of this flex duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexDuctType FlexDuctType { get; set; }
Visual Basic (Declaration)
Public Property FlexDuctType As FlexDuctType
Visual C++
public:
property FlexDuctType^ FlexDuctType {
    FlexDuctType^ get ();
    void set (FlexDuctType^ value);
}

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
FlexDuct..::.Parameter Property
FlexDuct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexDuct Class
FlexDuct Members
Autodesk.Revit.DB.Mechanical Namespace


Points Property

[image]

Revit 2011 API
FlexDuct..::.Points Property
FlexDuct Class See Also Send Feedback
The points of the flex duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic (Declaration)
Public Property Points As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex duct, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Class

[image]

Revit 2011 API
FlexDuctType Class
Members See Also Send Feedback
A flex duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexDuctType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexDuctType _
    Inherits MEPCurveType
Visual C++
public ref class FlexDuctType : public MEPCurveType

Remarks

The flex duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Mechanical..::.FlexDuctType

See Also

FlexDuctType Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Members

[image] [image]

Revit 2011 API
FlexDuctType Members
FlexDuctType Class Methods Properties See Also Send Feedback

The FlexDuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Methods

[image] [image]

Revit 2011 API
FlexDuctType Methods
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Properties

[image] [image]

Revit 2011 API
FlexDuctType Properties
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
FlexDuctType..::.Parameter Property
FlexDuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexDuctType Class
FlexDuctType Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Class

[image]

Revit 2011 API
MechanicalEquipment Class
Members See Also Send Feedback
Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalEquipment : MEPModel
Visual Basic (Declaration)
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Mechanical..::.MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Members

[image] [image]

Revit 2011 API
MechanicalEquipment Members
MechanicalEquipment Class Methods Properties See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Methods

[image] [image]

Revit 2011 API
MechanicalEquipment Methods
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Properties

[image] [image]

Revit 2011 API
MechanicalEquipment Properties
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Class

[image]

Revit 2011 API
MechanicalFitting Class
Members See Also Send Feedback
A mechanical fitting in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalFitting : MEPModel
Visual Basic (Declaration)
Public Class MechanicalFitting _
    Inherits MEPModel
Visual C++
public ref class MechanicalFitting : public MEPModel

Remarks

The mechanical fitting is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.MEPModel
Autodesk.Revit.DB.Mechanical..::.MechanicalFitting

See Also

MechanicalFitting Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Members

[image] [image]

Revit 2011 API
MechanicalFitting Members
MechanicalFitting Class Methods Properties See Also Send Feedback

The MechanicalFitting type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Methods

[image] [image]

Revit 2011 API
MechanicalFitting Methods
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Properties

[image] [image]

Revit 2011 API
MechanicalFitting Properties
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Properties

Name | Description
ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


PartType Property

[image]

Revit 2011 API
MechanicalFitting..::.PartType Property
MechanicalFitting Class See Also Send Feedback
The part type of the mechanical fitting.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PartType PartType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartType As PartType
Visual C++
public:
property PartType PartType {
    PartType get ();
}

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Class

[image]

Revit 2011 API
MechanicalSystem Class
Members See Also Send Feedback
A mechanical system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MechanicalSystem : MEPSystem
Visual Basic (Declaration)
Public Class MechanicalSystem _
    Inherits MEPSystem
Visual C++
public ref class MechanicalSystem : public MEPSystem

Remarks

The mechanical system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Mechanical..::.MechanicalSystem

See Also

MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Members

[image] [image]

Revit 2011 API
MechanicalSystem Members
MechanicalSystem Class Methods Properties See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctNetwork | The ducts and fittings contained within the system.
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this duct system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Methods

[image] [image]

Revit 2011 API
MechanicalSystem Methods
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Properties

[image] [image]

Revit 2011 API
MechanicalSystem Properties
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
DuctNetwork | The ducts and fittings contained within the system.
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this duct system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


BaseEquipmentConnector Property

[image]

Revit 2011 API
MechanicalSystem..::.BaseEquipmentConnector Property
MechanicalSystem Class See Also Send Feedback
The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Assigning nullNothingnullptra null reference (Nothing in Visual Basic) to the base equipment connector will disconnect the base equipment from the system.

Remarks

Setting this property will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


DuctNetwork Property

[image]

Revit 2011 API
MechanicalSystem..::.DuctNetwork Property
MechanicalSystem Class See Also Send Feedback
The ducts and fittings contained within the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet DuctNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuctNetwork As ElementSet
Visual C++
public:
property ElementSet^ DuctNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include terminals or equipments, the ducts and fittings are returned in no particular order.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


Flow Property

[image]

Revit 2011 API
MechanicalSystem..::.Flow Property
MechanicalSystem Class See Also Send Feedback
The system flow.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the flow can't be computed, which means the system is not well connected.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


IsWellConnected Property

[image]

Revit 2011 API
MechanicalSystem..::.IsWellConnected Property
MechanicalSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWellConnected As Boolean
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
MechanicalSystem..::.Parameter Property
MechanicalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MechanicalSystem Class
MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


StaticPressure Property

[image]

Revit 2011 API
MechanicalSystem..::.StaticPressure Property
MechanicalSystem Class See Also Send Feedback
The system static pressure.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StaticPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property StaticPressure As Double
Visual C++
public:
property double StaticPressure {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the static pressure can't be computed, which means the system is not well connected.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


SystemType Property

[image]

Revit 2011 API
MechanicalSystem..::.SystemType Property
MechanicalSystem Class See Also Send Feedback
The type of this duct system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As DuctSystemType
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
}

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Class

[image]

Revit 2011 API
MEPBuildingConstruction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPBuildingConstruction : ElementType
Visual Basic (Declaration)
Public Class MEPBuildingConstruction _
    Inherits ElementType
Visual C++
public ref class MEPBuildingConstruction : public ElementType

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction

See Also

MEPBuildingConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Members

[image] [image]

Revit 2011 API
MEPBuildingConstruction Members
MEPBuildingConstruction Class Methods Properties See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetBuildingConstruction | Gets the current Building Construction from the project information.
GetConstructions | Gets all the Building Constructions corresponding to the specific Construction type.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetBuildingConstruction | Sets the Building Construction of the Project Information.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Obsolete. Gets or Sets the Building Construction of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Constructions | Obsolete. Gets all the Building Constructions according to the specific Construction type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Methods

[image] [image]

Revit 2011 API
MEPBuildingConstruction Methods
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetBuildingConstruction | Gets the current Building Construction from the project information.
GetConstructions | Gets all the Building Constructions corresponding to the specific Construction type.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetBuildingConstruction | Sets the Building Construction of the Project Information.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


GetBuildingConstruction Method

[image]

Revit 2011 API
MEPBuildingConstruction..::.GetBuildingConstruction Method
MEPBuildingConstruction Class See Also Send Feedback
Gets the current Building Construction from the project information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Construction GetBuildingConstruction(
    ConstructionType constructionType
)
Visual Basic (Declaration)
Public Function GetBuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
public:
Construction^ GetBuildingConstruction(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::.ConstructionType
The Construction Type of Building Construction.

Return Value

The Building Construction of the Project Information.

Remarks

This function is used to get the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


GetConstructions Method

[image]

Revit 2011 API
MEPBuildingConstruction..::.GetConstructions Method
MEPBuildingConstruction Class See Also Send Feedback
Gets all the Building Constructions corresponding to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<Construction> GetConstructions(
    ConstructionType constructionType
)
Visual Basic (Declaration)
Public Function GetConstructions ( _
    constructionType As ConstructionType _
) As ICollection(Of Construction)
Visual C++
public:
ICollection<Construction^>^ GetConstructions(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::.ConstructionType
The Construction Type of Building Construction.

Return Value

A collection containing Building constructions matching the construction type.

Remarks

This function is used to get the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


SetBuildingConstruction Method

[image]

Revit 2011 API
MEPBuildingConstruction..::.SetBuildingConstruction Method
MEPBuildingConstruction Class See Also Send Feedback
Sets the Building Construction of the Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetBuildingConstruction(
    ConstructionType constructionType,
    Construction buildingConstruction
)
Visual Basic (Declaration)
Public Sub SetBuildingConstruction ( _
    constructionType As ConstructionType, _
    buildingConstruction As Construction _
)
Visual C++
public:
void SetBuildingConstruction(
    ConstructionType constructionType,
    Construction^ buildingConstruction
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::.ConstructionType
The Construction Type of Building Construction.
buildingConstruction
Type: Autodesk.Revit.DB..::.Construction
The Building Construction to be set.

Remarks

This function is used to set the Building Construction of the Project Information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | buildingConstruction is NULL.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Sets construction type to an invalid value. - or - Can not set construction type.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Properties

[image] [image]

Revit 2011 API
MEPBuildingConstruction Properties
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
BuildingConstruction | Obsolete. Gets or Sets the Building Construction of the Project Information.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Constructions | Obsolete. Gets all the Building Constructions according to the specific Construction type.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


BuildingConstruction Property

[image]

Revit 2011 API
MEPBuildingConstruction..::.BuildingConstruction Property
MEPBuildingConstruction Class See Also Send Feedback
Gets or Sets the Building Construction of the Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")]
public Construction BuildingConstruction[
    ConstructionType constructionType
] { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")> _
Public Property BuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
[ObsoleteAttribute(L"Use MEPBuildingConstruction.GetBuidingConstruction() or MEPBuildingConstruction.SetBuidingConstruction() instead.")]
public:
property Construction^ BuildingConstruction[ConstructionType constructionType] {
    Construction^ get (ConstructionType constructionType);
    void set (ConstructionType constructionType, Construction^ value);
}

Parameters

constructionType
Type: Autodesk.Revit.DB..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


Constructions Property

[image]

Revit 2011 API
MEPBuildingConstruction..::.Constructions Property
MEPBuildingConstruction Class See Also Send Feedback
Gets all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use MEPBuildingConstruction.GetConstructions() instead.")]
public Set Constructions[
    ConstructionType constructionType
] { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use MEPBuildingConstruction.GetConstructions() instead.")> _
Public ReadOnly Property Constructions ( _
    constructionType As ConstructionType _
) As Set
Visual C++
[ObsoleteAttribute(L"Use MEPBuildingConstruction.GetConstructions() instead.")]
public:
property Set^ Constructions[ConstructionType constructionType] {
    Set^ get (ConstructionType constructionType);
}

Parameters

constructionType
Type: Autodesk.Revit.DB..::.ConstructionType
The Construction Type to be set the Building Construction.

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
MEPBuildingConstruction..::.Parameter Property
MEPBuildingConstruction Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
MEPBuildingConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Class

[image]

Revit 2011 API
MEPBuildingConstructionSet Class
Members See Also Send Feedback
A set that contains MEPBuildingConstructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPBuildingConstructionSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class MEPBuildingConstructionSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MEPBuildingConstructionSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSet

See Also

MEPBuildingConstructionSet Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Members

[image] [image]

Revit 2011 API
MEPBuildingConstructionSet Members
MEPBuildingConstructionSet Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Constructors

Name | Description
MEPBuildingConstructionSet | Initializes a new instance of the MEPBuildingConstructionSet class

Methods

Name | Description
Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified MEPBuildingConstruction from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified MEPBuildingConstruction into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Constructor

[image]

Revit 2011 API
MEPBuildingConstructionSet Constructor
MEPBuildingConstructionSet Class See Also Send Feedback
Initializes a new instance of the MEPBuildingConstructionSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstructionSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSet()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Methods

[image] [image]

Revit 2011 API
MEPBuildingConstructionSet Methods
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Methods

Name | Description
Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified MEPBuildingConstruction from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified MEPBuildingConstruction into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.Clear Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes every MEPBuildingConstruction from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.Contains Method
MEPBuildingConstructionSet Class See Also Send Feedback
Tests for the existence of a MEPBuildingConstruction within the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
The MEPBuildingConstruction to be searched for.

Return Value

The Contains method returns True if the MEPBuildingConstruction is within the set, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.Erase Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes a specified MEPBuildingConstruction from the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As MEPBuildingConstruction _
) As Integer
Visual C++
public:
virtual int Erase(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
The MEPBuildingConstruction to be erased.

Return Value

The number of MEPBuildingConstructions that were erased from the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.ForwardIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.GetEnumerator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.Insert Method
MEPBuildingConstructionSet Class See Also Send Feedback
Insert the specified MEPBuildingConstruction into the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    MEPBuildingConstruction item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
The MEPBuildingConstruction to be inserted into the set.

Return Value

Returns whether the MEPBuildingConstruction was inserted into the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.ReverseIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Properties

[image] [image]

Revit 2011 API
MEPBuildingConstructionSet Properties
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.IsEmpty Property
MEPBuildingConstructionSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2011 API
MEPBuildingConstructionSet..::.Size Property
MEPBuildingConstructionSet Class See Also Send Feedback
Returns the number of MEPBuildingConstructions that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Class

[image]

Revit 2011 API
MEPBuildingConstructionSetIterator Class
Members See Also Send Feedback
An iterator to a MEPBuildingConstruction set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class MEPBuildingConstructionSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstructionSetIterator

See Also

MEPBuildingConstructionSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Members

[image] [image]

Revit 2011 API
MEPBuildingConstructionSetIterator Members
MEPBuildingConstructionSetIterator Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Constructors

Name | Description
MEPBuildingConstructionSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Constructor

[image]

Revit 2011 API
MEPBuildingConstructionSetIterator Constructor
MEPBuildingConstructionSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstructionSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MEPBuildingConstructionSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Methods

[image] [image]

Revit 2011 API
MEPBuildingConstructionSetIterator Methods
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2011 API
MEPBuildingConstructionSetIterator..::.MoveNext Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2011 API
MEPBuildingConstructionSetIterator..::.Reset Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Properties

[image] [image]

Revit 2011 API
MEPBuildingConstructionSetIterator Properties
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2011 API
MEPBuildingConstructionSetIterator..::.Current Property
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Class

[image]

Revit 2011 API
MEPSpaceConstruction Class
Members See Also Send Feedback
Construction definition for Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class MEPSpaceConstruction
Visual Basic (Declaration)
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Mechanical..::.MEPSpaceConstruction

See Also

MEPSpaceConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Members

[image] [image]

Revit 2011 API
MEPSpaceConstruction Members
MEPSpaceConstruction Class Methods Properties See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Methods

Name | Description
DeleteConstruction | Remove an existing construction from Space constructions.
DuplicateConstruction | Create a new construction for Space constructions.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewConstruction | Create a new construction for Space constructions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Methods

[image] [image]

Revit 2011 API
MEPSpaceConstruction Methods
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Methods

Name | Description
DeleteConstruction | Remove an existing construction from Space constructions.
DuplicateConstruction | Create a new construction for Space constructions.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
NewConstruction | Create a new construction for Space constructions.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


DeleteConstruction Method

[image]

Revit 2011 API
MEPSpaceConstruction..::.DeleteConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Remove an existing construction from Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DeleteConstruction(
    MEPBuildingConstruction pCurrentConstruction
)
Visual Basic (Declaration)
Public Sub DeleteConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction _
)
Visual C++
public:
void DeleteConstruction(
    MEPBuildingConstruction^ pCurrentConstruction
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
The Construction will be deleted.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


DuplicateConstruction Method

[image]

Revit 2011 API
MEPSpaceConstruction..::.DuplicateConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic (Declaration)
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction(
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.DB.Mechanical..::.MEPBuildingConstruction
The existing construction to be duplicated.
pName
Type: System..::.String
The name of the new construction.

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


NewConstruction Method

[image]

Revit 2011 API
MEPSpaceConstruction..::.NewConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstruction NewConstruction(
    string pName
)
Visual Basic (Declaration)
Public Function NewConstruction ( _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ NewConstruction(
    String^ pName
)

Parameters

pName
Type: System..::.String
The name of the new Construction.

Remarks

If the name is same as an existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Properties

[image] [image]

Revit 2011 API
MEPSpaceConstruction Properties
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Properties

Name | Description
CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


CurrentConstruction Property

[image]

Revit 2011 API
MEPSpaceConstruction..::.CurrentConstruction Property
MEPSpaceConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstruction CurrentConstruction { get; set; }
Visual Basic (Declaration)
Public Property CurrentConstruction As MEPBuildingConstruction
Visual C++
public:
property MEPBuildingConstruction^ CurrentConstruction {
    MEPBuildingConstruction^ get ();
    void set (MEPBuildingConstruction^ value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceConstructions Property

[image]

Revit 2011 API
MEPSpaceConstruction..::.SpaceConstructions Property
MEPSpaceConstruction Class See Also Send Feedback
Return all the Space constructions of current space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPBuildingConstructionSet SpaceConstructions { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstructions As MEPBuildingConstructionSet
Visual C++
public:
property MEPBuildingConstructionSet^ SpaceConstructions {
    MEPBuildingConstructionSet^ get ();
}

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


OccupancyUnit Enumeration

[image]

Revit 2011 API
OccupancyUnit Enumeration
See Also Send Feedback
An enumerated type listing the occupancy unit of measure for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum OccupancyUnit
Visual Basic (Declaration)
Public Enumeration OccupancyUnit
Visual C++
public enum class OccupancyUnit

Members

Member name | Description
UseDefaultValues | OccupancyUnit is UseDefaultValues.
NumberOfPeople | OccupancyUnit is NumberOfPeople.
AreaPerPerson | OccupancyUnit is AreaPerPerson.

See Also

Autodesk.Revit.DB.Mechanical Namespace


ReturnAirflowType Enumeration

[image]

Revit 2011 API
ReturnAirflowType Enumeration
See Also Send Feedback
An enumerated type listing all the possible return airflow types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ReturnAirflowType
Visual Basic (Declaration)
Public Enumeration ReturnAirflowType
Visual C++
public enum class ReturnAirflowType

Members

Member name | Description
Specified | Return Airflow Type is Specified.
SpecifiedSupplyAirflow | Return Airflow Type is SpecifiedSupplyAirflow.
CalculatedSupplyAirflow | Return Airflow Type is CalculatedSupplyAirflow.
ActualSupplyAirflow | Return Airflow Type is ActualSupplyAirflow.

See Also

Autodesk.Revit.DB.Mechanical Namespace


Space Class

[image]

Revit 2011 API
Space Class
Members See Also Send Feedback
Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Space : Enclosure
Visual Basic (Declaration)
Public Class Space _
    Inherits Enclosure
Visual C++
public ref class Space : public Enclosure

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.Enclosure
Autodesk.Revit.DB.Mechanical..::.Space

See Also

Space Members
Autodesk.Revit.DB.Mechanical Namespace


Space Members

[image] [image]

Revit 2011 API
Space Members
Space Class Methods Properties See Also Send Feedback

The Space type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsPointInSpace | Determines if a point lies within the volume of the Space.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Area | The area. (Inherited from Enclosure.)
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorReflectance | Get or set the Floor Reflectance of the Space.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
NumberofPeople | Get the Number of People of the Space.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Space.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Space Methods

[image] [image]

Revit 2011 API
Space Methods
Space Class See Also Send Feedback

The Space type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsPointInSpace | Determines if a point lies within the volume of the Space.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


IsPointInSpace Method

[image]

Revit 2011 API
Space..::.IsPointInSpace Method
Space Class See Also Send Feedback
Determines if a point lies within the volume of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPointInSpace(
    XYZ point
)
Visual Basic (Declaration)
Public Function IsPointInSpace ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInSpace(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::.XYZ
Point to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | The coordinates of the point is not a number.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Space Properties

[image] [image]

Revit 2011 API
Space Properties
Space Class See Also Send Feedback

The Space type exposes the following members.

Properties

Name | Description
ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
ActualLightingLoad | Get the Actual Lighting Load of the Space.
ActualOtherLoad | Get or set the Actual Other Load of the Space.
ActualPowerLoad | Get the Actual Power Load of the Space.
ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Area | The area. (Inherited from Enclosure.)
AreaperPerson | Get the Area per Person of the Space.
AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
BaseOffset | Get or Set the Base Offset of the Space.
Boundary | Returns the boundary of the Space.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
ClosedShell | Return the closedShell of the space.
ConditionType | Get or set the Condition type of the Space.
DesignCoolingLoad | Get the Design Cooling Load of the Space.
DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
DesignHeatingLoad | Get the Design Heating Load of the Space.
DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
DesignLightingLoad | Get or set the Design Lighting Load of the Space.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
DesignPowerLoad | Get or set the Design Power Load of the Space.
DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FloorReflectance | Get or set the Floor Reflectance of the Space.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
LimitOffset | Get or Set the Limit Offset of the Space.
Location | The location of the element. (Inherited from Enclosure.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Enclosure.)
Number | The number. (Inherited from Enclosure.)
NumberofPeople | Get the Number of People of the Space.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OccupancyUnit | Get the Occupancy Unit of the Space.
Occupiable | Reports whether this zone is Occupiable or not.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | The perimeter. (Inherited from Enclosure.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Plenum | Reports whether this zone is Plenum or not.
PowerLoadUnit | Get or Set the Power Load Unit of the Space.
ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Room | Return the Room of the space.
SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
SpaceConstruction | Get the Space Construction of the Space.
SpaceType | Get or set the Space type of the Space.
UnboundedHeight | Get the Unbounded Height of the Space.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UpperLimit | Get or Set the Upper Limit of the Space.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Space.
WallReflectance | Get or set the Wall Reflectance of the Space.
Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualExhaustAirflow Property

[image]

Revit 2011 API
Space..::.ActualExhaustAirflow Property
Space Class See Also Send Feedback
Get the Actual Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualExhaustAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualExhaustAirflow As Double
Visual C++
public:
property double ActualExhaustAirflow {
    double get ();
}

Remarks

This property is used to get the Actual Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualHVACLoad Property

[image]

Revit 2011 API
Space..::.ActualHVACLoad Property
Space Class See Also Send Feedback
Get or set the Actual HVAC Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualHVACLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualHVACLoad As Double
Visual C++
public:
property double ActualHVACLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual HVAC Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualLightingLoad Property

[image]

Revit 2011 API
Space..::.ActualLightingLoad Property
Space Class See Also Send Feedback
Get the Actual Lighting Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualLightingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualLightingLoad As Double
Visual C++
public:
property double ActualLightingLoad {
    double get ();
}

Remarks

This property is used to get the Actual Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualOtherLoad Property

[image]

Revit 2011 API
Space..::.ActualOtherLoad Property
Space Class See Also Send Feedback
Get or set the Actual Other Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualOtherLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualOtherLoad As Double
Visual C++
public:
property double ActualOtherLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual Other Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualPowerLoad Property

[image]

Revit 2011 API
Space..::.ActualPowerLoad Property
Space Class See Also Send Feedback
Get the Actual Power Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualPowerLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualPowerLoad As Double
Visual C++
public:
property double ActualPowerLoad {
    double get ();
}

Remarks

This property is used to get the Actual Power Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualReturnAirflow Property

[image]

Revit 2011 API
Space..::.ActualReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Return Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualReturnAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualReturnAirflow As Double
Visual C++
public:
property double ActualReturnAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualSupplyAirflow Property

[image]

Revit 2011 API
Space..::.ActualSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ActualSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualSupplyAirflow As Double
Visual C++
public:
property double ActualSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


AreaperPerson Property

[image]

Revit 2011 API
Space..::.AreaperPerson Property
Space Class See Also Send Feedback
Get the Area per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AreaperPerson { get; set; }
Visual Basic (Declaration)
Public Property AreaperPerson As Double
Visual C++
public:
property double AreaperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Area per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


AverageEstimatedIllumination Property

[image]

Revit 2011 API
Space..::.AverageEstimatedIllumination Property
Space Class See Also Send Feedback
Get the Average Estimated Illumination of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double AverageEstimatedIllumination { get; }
Visual Basic (Declaration)
Public ReadOnly Property AverageEstimatedIllumination As Double
Visual C++
public:
property double AverageEstimatedIllumination {
    double get ();
}

Remarks

This property is used to get the Average Estimated Illumination of the Space. (Unit: fc)

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


BaseOffset Property

[image]

Revit 2011 API
Space..::.BaseOffset Property
Space Class See Also Send Feedback
Get or Set the Base Offset of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic (Declaration)
Public Property BaseOffset As Double
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Boundary Property

[image]

Revit 2011 API
Space..::.Boundary Property
Space Class See Also Send Feedback
Returns the boundary of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BoundarySegmentArrayArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As BoundarySegmentArrayArray
Visual C++
public:
property BoundarySegmentArrayArray^ Boundary {
    BoundarySegmentArrayArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Space. Each Space may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Space.BoundarySegment object for more details about the segments that make up the Space topology.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedCoolingLoad Property

[image]

Revit 2011 API
Space..::.CalculatedCoolingLoad Property
Space Class See Also Send Feedback
Get the Calculated Cooling Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedHeatingLoad Property

[image]

Revit 2011 API
Space..::.CalculatedHeatingLoad Property
Space Class See Also Send Feedback
Get the Calculated Heating Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2011 API
Space..::.CalculatedSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Calculated Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Calculated Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CeilingReflectance Property

[image]

Revit 2011 API
Space..::.CeilingReflectance Property
Space Class See Also Send Feedback
Get or set the Ceiling Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CeilingReflectance { get; set; }
Visual Basic (Declaration)
Public Property CeilingReflectance As Double
Visual C++
public:
property double CeilingReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Ceiling Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ClosedShell Property

[image]

Revit 2011 API
Space..::.ClosedShell Property
Space Class See Also Send Feedback
Return the closedShell of the space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public GeometryElement ClosedShell { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClosedShell As GeometryElement
Visual C++
public:
property GeometryElement^ ClosedShell {
    GeometryElement^ get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ConditionType Property

[image]

Revit 2011 API
Space..::.ConditionType Property
Space Class See Also Send Feedback
Get or set the Condition type of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ConditionType ConditionType { get; set; }
Visual Basic (Declaration)
Public Property ConditionType As ConditionType
Visual C++
public:
property ConditionType ConditionType {
    ConditionType get ();
    void set (ConditionType value);
}

Remarks

This property is used to get or set the Condition type of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignCoolingLoad Property

[image]

Revit 2011 API
Space..::.DesignCoolingLoad Property
Space Class See Also Send Feedback
Get the Design Cooling Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignCoolingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignCoolingLoad As Double
Visual C++
public:
property double DesignCoolingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignExhaustAirflow Property

[image]

Revit 2011 API
Space..::.DesignExhaustAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignExhaustAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignExhaustAirflow As Double
Visual C++
public:
property double DesignExhaustAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignHeatingLoad Property

[image]

Revit 2011 API
Space..::.DesignHeatingLoad Property
Space Class See Also Send Feedback
Get the Design Heating Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignHeatingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignHeatingLoad As Double
Visual C++
public:
property double DesignHeatingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignHVACLoadperArea Property

[image]

Revit 2011 API
Space..::.DesignHVACLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design HVAC Load per Area of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignHVACLoadperArea { get; set; }
Visual Basic (Declaration)
Public Property DesignHVACLoadperArea As Double
Visual C++
public:
property double DesignHVACLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design HVAC Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignLightingLoad Property

[image]

Revit 2011 API
Space..::.DesignLightingLoad Property
Space Class See Also Send Feedback
Get or set the Design Lighting Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignLightingLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignLightingLoad As Double
Visual C++
public:
property double DesignLightingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignOtherLoadperArea Property

[image]

Revit 2011 API
Space..::.DesignOtherLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design Other Load per Area of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignOtherLoadperArea { get; set; }
Visual Basic (Declaration)
Public Property DesignOtherLoadperArea As Double
Visual C++
public:
property double DesignOtherLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Other Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignPowerLoad Property

[image]

Revit 2011 API
Space..::.DesignPowerLoad Property
Space Class See Also Send Feedback
Get or set the Design Power Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignPowerLoad { get; set; }
Visual Basic (Declaration)
Public Property DesignPowerLoad As Double
Visual C++
public:
property double DesignPowerLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Power Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignReturnAirflow Property

[image]

Revit 2011 API
Space..::.DesignReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Return Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignReturnAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignReturnAirflow As Double
Visual C++
public:
property double DesignReturnAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignSupplyAirflow Property

[image]

Revit 2011 API
Space..::.DesignSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DesignSupplyAirflow { get; set; }
Visual Basic (Declaration)
Public Property DesignSupplyAirflow As Double
Visual C++
public:
property double DesignSupplyAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


FloorReflectance Property

[image]

Revit 2011 API
Space..::.FloorReflectance Property
Space Class See Also Send Feedback
Get or set the Floor Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FloorReflectance { get; set; }
Visual Basic (Declaration)
Public Property FloorReflectance As Double
Visual C++
public:
property double FloorReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Floor Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LatentHeatGainperPerson Property

[image]

Revit 2011 API
Space..::.LatentHeatGainperPerson Property
Space Class See Also Send Feedback
Get or set the Latent Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double LatentHeatGainperPerson { get; set; }
Visual Basic (Declaration)
Public Property LatentHeatGainperPerson As Double
Visual C++
public:
property double LatentHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Latent Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LightingCalculationWorkplane Property

[image]

Revit 2011 API
Space..::.LightingCalculationWorkplane Property
Space Class See Also Send Feedback
Get the Lighting Calculation Workplane of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double LightingCalculationWorkplane { get; set; }
Visual Basic (Declaration)
Public Property LightingCalculationWorkplane As Double
Visual C++
public:
property double LightingCalculationWorkplane {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Lighting Calculation Workplane (Unit: feet) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LightingLoadUnit Property

[image]

Revit 2011 API
Space..::.LightingLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Lighting Load Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BaseLoadOn LightingLoadUnit { get; set; }
Visual Basic (Declaration)
Public Property LightingLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn LightingLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Lighting Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LimitOffset Property

[image]

Revit 2011 API
Space..::.LimitOffset Property
Space Class See Also Send Feedback
Get or Set the Limit Offset of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic (Declaration)
Public Property LimitOffset As Double
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


NumberofPeople Property

[image]

Revit 2011 API
Space..::.NumberofPeople Property
Space Class See Also Send Feedback
Get the Number of People of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double NumberofPeople { get; set; }
Visual Basic (Declaration)
Public Property NumberofPeople As Double
Visual C++
public:
property double NumberofPeople {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Number of People of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


OccupancyUnit Property

[image]

Revit 2011 API
Space..::.OccupancyUnit Property
Space Class See Also Send Feedback
Get the Occupancy Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public OccupancyUnit OccupancyUnit { get; set; }
Visual Basic (Declaration)
Public Property OccupancyUnit As OccupancyUnit
Visual C++
public:
property OccupancyUnit OccupancyUnit {
    OccupancyUnit get ();
    void set (OccupancyUnit value);
}

Remarks

This property is used to get the Occupancy Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Occupiable Property

[image]

Revit 2011 API
Space..::.Occupiable Property
Space Class See Also Send Feedback
Reports whether this zone is Occupiable or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Occupiable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Occupiable As Boolean
Visual C++
public:
property bool Occupiable {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
Space..::.Parameter Property
Space Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Space Class
Space Members
Autodesk.Revit.DB.Mechanical Namespace


Plenum Property

[image]

Revit 2011 API
Space..::.Plenum Property
Space Class See Also Send Feedback
Reports whether this zone is Plenum or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Plenum { get; }
Visual Basic (Declaration)
Public ReadOnly Property Plenum As Boolean
Visual C++
public:
property bool Plenum {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


PowerLoadUnit Property

[image]

Revit 2011 API
Space..::.PowerLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Power Load Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BaseLoadOn PowerLoadUnit { get; set; }
Visual Basic (Declaration)
Public Property PowerLoadUnit As BaseLoadOn
Visual C++
public:
property BaseLoadOn PowerLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Power Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ReturnAirflow Property

[image]

Revit 2011 API
Space..::.ReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Return type of Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ReturnAirflowType ReturnAirflow { get; set; }
Visual Basic (Declaration)
Public Property ReturnAirflow As ReturnAirflowType
Visual C++
public:
property ReturnAirflowType ReturnAirflow {
    ReturnAirflowType get ();
    void set (ReturnAirflowType value);
}

Remarks

This property is used to get or set the Return type of Supply Airflow of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Room Property

[image]

Revit 2011 API
Space..::.Room Property
Space Class See Also Send Feedback
Return the Room of the space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic (Declaration)
Public ReadOnly Property Room As Room
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SensibleHeatGainperPerson Property

[image]

Revit 2011 API
Space..::.SensibleHeatGainperPerson Property
Space Class See Also Send Feedback
Get the Sensible Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SensibleHeatGainperPerson { get; set; }
Visual Basic (Declaration)
Public Property SensibleHeatGainperPerson As Double
Visual C++
public:
property double SensibleHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Sensible Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceCavityRatio Property

[image]

Revit 2011 API
Space..::.SpaceCavityRatio Property
Space Class See Also Send Feedback
Get the Space Cavity Ratio of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double SpaceCavityRatio { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceCavityRatio As Double
Visual C++
public:
property double SpaceCavityRatio {
    double get ();
}

Remarks

This property is used to get the Space Cavity Ratio of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceConstruction Property

[image]

Revit 2011 API
Space..::.SpaceConstruction Property
Space Class See Also Send Feedback
Get the Space Construction of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public MEPSpaceConstruction SpaceConstruction { get; }
Visual Basic (Declaration)
Public ReadOnly Property SpaceConstruction As MEPSpaceConstruction
Visual C++
public:
property MEPSpaceConstruction^ SpaceConstruction {
    MEPSpaceConstruction^ get ();
}

Remarks

This property is used to get the Space Construction of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceType Property

[image]

Revit 2011 API
Space..::.SpaceType Property
Space Class See Also Send Feedback
Get or set the Space type of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceType SpaceType { get; set; }
Visual Basic (Declaration)
Public Property SpaceType As SpaceType
Visual C++
public:
property SpaceType SpaceType {
    SpaceType get ();
    void set (SpaceType value);
}

Remarks

This property is used to get or set the Space type of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


UnboundedHeight Property

[image]

Revit 2011 API
Space..::.UnboundedHeight Property
Space Class See Also Send Feedback
Get the Unbounded Height of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnboundedHeight As Double
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


UpperLimit Property

[image]

Revit 2011 API
Space..::.UpperLimit Property
Space Class See Also Send Feedback
Get or Set the Upper Limit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic (Declaration)
Public Property UpperLimit As Level
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Volume Property

[image]

Revit 2011 API
Space..::.Volume Property
Space Class See Also Send Feedback
Get the Volume of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


WallReflectance Property

[image]

Revit 2011 API
Space..::.WallReflectance Property
Space Class See Also Send Feedback
Get or set the Wall Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double WallReflectance { get; set; }
Visual Basic (Declaration)
Public Property WallReflectance As Double
Visual C++
public:
property double WallReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Wall Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Property

[image]

Revit 2011 API
Space..::.Zone Property
Space Class See Also Send Feedback
Reports this space belong to which Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Zone Zone { get; }
Visual Basic (Declaration)
Public ReadOnly Property Zone As Zone
Visual C++
public:
property Zone^ Zone {
    Zone^ get ();
}

Remarks

This property is used to retrieve the host zone of this space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Class

[image]

Revit 2011 API
SpaceFilter Class
Members See Also Send Feedback
A filter used to match spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class SpaceFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class SpaceFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Mechanical..::.SpaceFilter

See Also

SpaceFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Members

[image] [image]

Revit 2011 API
SpaceFilter Members
SpaceFilter Class Constructors Methods Properties See Also Send Feedback

The SpaceFilter type exposes the following members.

Constructors

Name | Description
SpaceFilter | Constructs a filter which matches only spaces.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Constructor

[image]

Revit 2011 API
SpaceFilter Constructor
SpaceFilter Class See Also Send Feedback
Constructs a filter which matches only spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceFilter()

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Methods

[image] [image]

Revit 2011 API
SpaceFilter Methods
SpaceFilter Class See Also Send Feedback

The SpaceFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Properties

[image] [image]

Revit 2011 API
SpaceFilter Properties
SpaceFilter Class See Also Send Feedback

The SpaceFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Class

[image]

Revit 2011 API
SpaceSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class SpaceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.SpaceSet

See Also

SpaceSet Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Members

[image] [image]

Revit 2011 API
SpaceSet Members
SpaceSet Class Constructors Methods Properties See Also Send Feedback

The SpaceSet type exposes the following members.

Constructors

Name | Description
SpaceSet | Initializes a new instance of the SpaceSet class

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Constructor

[image]

Revit 2011 API
SpaceSet Constructor
SpaceSet Class See Also Send Feedback
Initializes a new instance of the SpaceSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSet()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Methods

[image] [image]

Revit 2011 API
SpaceSet Methods
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Methods

Name | Description
Clear | Removes every item from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2011 API
SpaceSet..::.Clear Method
SpaceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2011 API
SpaceSet..::.Contains Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2011 API
SpaceSet..::.Erase Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Space _
) As Integer
Visual C++
public:
virtual int Erase(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2011 API
SpaceSet..::.ForwardIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpaceSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2011 API
SpaceSet..::.GetEnumerator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2011 API
SpaceSet..::.Insert Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Space item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2011 API
SpaceSet..::.ReverseIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpaceSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Properties

[image] [image]

Revit 2011 API
SpaceSet Properties
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2011 API
SpaceSet..::.IsEmpty Property
SpaceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2011 API
SpaceSet..::.Size Property
SpaceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Class

[image]

Revit 2011 API
SpaceSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SpaceSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpaceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.SpaceSetIterator

See Also

SpaceSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Members

[image] [image]

Revit 2011 API
SpaceSetIterator Members
SpaceSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Constructors

Name | Description
SpaceSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Constructor

[image]

Revit 2011 API
SpaceSetIterator Constructor
SpaceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Methods

[image] [image]

Revit 2011 API
SpaceSetIterator Methods
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2011 API
SpaceSetIterator..::.MoveNext Method
SpaceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2011 API
SpaceSetIterator..::.Reset Method
SpaceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Properties

[image] [image]

Revit 2011 API
SpaceSetIterator Properties
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2011 API
SpaceSetIterator..::.Current Property
SpaceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Class

[image]

Revit 2011 API
SpaceTag Class
Members See Also Send Feedback
Provides access to the space tag in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceTag : EnclosureTag
Visual Basic (Declaration)
Public Class SpaceTag _
    Inherits EnclosureTag
Visual C++
public ref class SpaceTag : public EnclosureTag

Remarks

The space Tag object can be queried for space information.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.EnclosureTag
Autodesk.Revit.DB.Mechanical..::.SpaceTag

See Also

SpaceTag Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Members

[image] [image]

Revit 2011 API
SpaceTag Members
SpaceTag Class Methods Properties See Also Send Feedback

The SpaceTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | The space that the tag is associated with.
SpaceTagType | The tag type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Methods

[image] [image]

Revit 2011 API
SpaceTag Methods
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Properties

[image] [image]

Revit 2011 API
SpaceTag Properties
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HasLeader | Identifies if a leader is displayed for the tag. (Inherited from EnclosureTag.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | The location of the tag. (Inherited from EnclosureTag.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | The name associated with the tag. (Inherited from EnclosureTag.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Space | The space that the tag is associated with.
SpaceTagType | The tag type.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
View | The view in which the tag was placed. (Inherited from EnclosureTag.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
SpaceTag..::.Parameter Property
SpaceTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpaceTag Class
SpaceTag Members
Autodesk.Revit.DB.Mechanical Namespace


Space Property

[image]

Revit 2011 API
SpaceTag..::.Space Property
SpaceTag Class See Also Send Feedback
The space that the tag is associated with.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic (Declaration)
Public ReadOnly Property Space As Space
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

In rare cases, the tag may not be associated to a space. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Property

[image]

Revit 2011 API
SpaceTag..::.SpaceTagType Property
SpaceTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTagType SpaceTagType { get; set; }
Visual Basic (Declaration)
Public Property SpaceTagType As SpaceTagType
Visual C++
public:
property SpaceTagType^ SpaceTagType {
    SpaceTagType^ get ();
    void set (SpaceTagType^ value);
}

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Class

[image]

Revit 2011 API
SpaceTagFilter Class
Members See Also Send Feedback
A filter used to match space tags.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceTagFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class SpaceTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class SpaceTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Mechanical..::.SpaceTagFilter

See Also

SpaceTagFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Members

[image] [image]

Revit 2011 API
SpaceTagFilter Members
SpaceTagFilter Class Constructors Methods Properties See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Constructors

Name | Description
SpaceTagFilter | Constructs a filter which matches only spaces.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Constructor

[image]

Revit 2011 API
SpaceTagFilter Constructor
SpaceTagFilter Class See Also Send Feedback
Constructs a filter which matches only spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTagFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagFilter()

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Methods

[image] [image]

Revit 2011 API
SpaceTagFilter Methods
SpaceTagFilter Class See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Properties

[image] [image]

Revit 2011 API
SpaceTagFilter Properties
SpaceTagFilter Class See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Class

[image]

Revit 2011 API
SpaceTagType Class
Members See Also Send Feedback
An object that represents a Space Tag style.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceTagType : FamilySymbol
Visual Basic (Declaration)
Public Class SpaceTagType _
    Inherits FamilySymbol
Visual C++
public ref class SpaceTagType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB.Mechanical..::.SpaceTagType

See Also

SpaceTagType Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Members

[image] [image]

Revit 2011 API
SpaceTagType Members
SpaceTagType Class Methods Properties See Also Send Feedback

The SpaceTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Methods

[image] [image]

Revit 2011 API
SpaceTagType Methods
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Properties

[image] [image]

Revit 2011 API
SpaceTagType Properties
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
SpaceTagType..::.Parameter Property
SpaceTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

SpaceTagType Class
SpaceTagType Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Class

[image]

Revit 2011 API
SpaceTagTypeSet Class
Members See Also Send Feedback
A set that contains space tag types.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class SpaceTagTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class SpaceTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSet

See Also

SpaceTagTypeSet Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Members

[image] [image]

Revit 2011 API
SpaceTagTypeSet Members
SpaceTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Constructors

Name | Description
SpaceTagTypeSet | Initializes a new instance of the SpaceTagTypeSet class

Methods

Name | Description
Clear | Removes every space tag type from the set, rendering it empty.
Contains | Tests for the existence of a space tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified space tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified space tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Constructor

[image]

Revit 2011 API
SpaceTagTypeSet Constructor
SpaceTagTypeSet Class See Also Send Feedback
Initializes a new instance of the SpaceTagTypeSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTagTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSet()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Methods

[image] [image]

Revit 2011 API
SpaceTagTypeSet Methods
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every space tag type from the set, rendering it empty.
Contains | Tests for the existence of a space tag type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified space tag type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified space tag type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.Clear Method
SpaceTagTypeSet Class See Also Send Feedback
Removes every space tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.Contains Method
SpaceTagTypeSet Class See Also Send Feedback
Tests for the existence of a space tag type within the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.SpaceTagType
The space tag type to be searched for.

Return Value

The Contains method returns True if the space tag type is within the set, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.Erase Method
SpaceTagTypeSet Class See Also Send Feedback
Removes a specified space tag type from the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As SpaceTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.SpaceTagType
The space tag type to be erased.

Return Value

The number of space tag types that were erased from the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.ForwardIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.GetEnumerator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.Insert Method
SpaceTagTypeSet Class See Also Send Feedback
Insert the specified space tag type into the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    SpaceTagType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::.SpaceTagType
The space tag type to be inserted into the set.

Return Value

Returns whether the space tag type was inserted into the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2011 API
SpaceTagTypeSet..::.ReverseIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Properties

[image] [image]

Revit 2011 API
SpaceTagTypeSet Properties
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2011 API
SpaceTagTypeSet..::.IsEmpty Property
SpaceTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2011 API
SpaceTagTypeSet..::.Size Property
SpaceTagTypeSet Class See Also Send Feedback
Returns the number of space tag types that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Class

[image]

Revit 2011 API
SpaceTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a space tag type set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class SpaceTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class SpaceTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Mechanical..::.SpaceTagTypeSetIterator

See Also

SpaceTagTypeSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Members

[image] [image]

Revit 2011 API
SpaceTagTypeSetIterator Members
SpaceTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Constructors

Name | Description
SpaceTagTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Constructor

[image]

Revit 2011 API
SpaceTagTypeSetIterator Constructor
SpaceTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceTagTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpaceTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Methods

[image] [image]

Revit 2011 API
SpaceTagTypeSetIterator Methods
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2011 API
SpaceTagTypeSetIterator..::.MoveNext Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2011 API
SpaceTagTypeSetIterator..::.Reset Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Properties

[image] [image]

Revit 2011 API
SpaceTagTypeSetIterator Properties
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2011 API
SpaceTagTypeSetIterator..::.Current Property
SpaceTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceType Enumeration

[image]

Revit 2011 API
SpaceType Enumeration
See Also Send Feedback
An enumerated type listing all the possible space types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SpaceType
Visual Basic (Declaration)
Public Enumeration SpaceType
Visual C++
public enum class SpaceType

Members

Member name | Description
NoSpaceType | Space Type is NoSpaceType.
kActiveStorage | Space Type is ActiveStorage.
kActiveStorageHospitalOrHealthcare | Space Type is ActiveStorageHospitalOrHealthcare.
kAirOrTrainOrBusBaggageArea | Space Type is AirOrTrainOrBusBaggageArea.
kAirportConcourse | Space Type is AirportConcourse.
kAtriumEachAdditionalFloor | Space Type is AtriumEachAdditionalFloor.
kAtriumFirstThreeFloors | Space Type is AtriumFirstThreeFloors.
kAudienceOrSeatingAreaPenitentiary | Space Type is AudienceOrSeatingAreaPenitentiary.
kAudienceOrSeatingAreaExerciseCenter | Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaGymnasium | Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaSportsArena | Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaConventionCenter | Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaMotionPictureTheatre | Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaPerformingArtsTheatre | Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaReligious | Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPoliceOrFireStations | Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaCourtHouse | Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaAuditorium | Space Type is AudienceOrSeatingAreaAuditorium.
kBankCustomerArea | Space Type is BankCustomerArea.
kBankingActivityAreaOffice | Space Type is BankingActivityAreaOffice.
kBarberAndBeautyParlor | Space Type is BarberAndBeautyParlor.
kCardFileAndCataloguingLibrary | Space Type is CardFileAndCataloguingLibrary.
kClassroomOrLectureOrTrainingPenitentiary | Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kClassroomOrLectureOrTraining | Space Type is ClassroomOrLectureOrTraining.
kComfinementCellsPenitentiary | Space Type is ComfinementCellsPenitentiary.
kComfinementCellsCourtHouse | Space Type is ComfinementCellsCourtHouse.
kConferenceMeetingOrMultipurpose | Space Type is ConferenceMeetingOrMultipurpose.
kCorridorOrTransition | Space Type is CorridorOrTransition.
kCorridorOrTransitionManufacturingFacility | Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCourtSportsAreaSportsArena | Space Type is CourtSportsAreaSportsArena.
kCourtroomCourtHouse | Space Type is CourtroomCourtHouse.
kDepartmentStoreSalesAreaRetail | Space Type is DepartmentStoreSalesAreaRetail.
kDetailedManufacturingFacility | Space Type is DetailedManufacturingFacility.
kDiningArea | Space Type is DiningArea.
kDiningAreaHotel | Space Type is DiningAreaHotel.
kDiningAreaFamilyDining | Space Type is DiningAreaFamilyDining.
kDiningAreaLoungeOrLeisureDining | Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaMotel | Space Type is DiningAreaMotel.
kDiningAreaTransportation | Space Type is DiningAreaTransportation.
kDiningAreaPenitentiary | Space Type is DiningAreaPenitentiary.
kDiningAreaCivilServices | Space Type is DiningAreaCivilServices.
kDormitoryBedroom | Space Type is DormitoryBedroom.
kDormitoryStudyHall | Space Type is DormitoryStudyHall.
kDressingOrLockerOrFittingRoomGymnasium | Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDressingOrLockerOrFittingRoomCourtHouse | Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomAuditorium | Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomExerciseCenter | Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kElectricalOrMechanical | Space Type is ElectricalOrMechanical.
kElevatorLobbies | Space Type is ElevatorLobbies.
kEmergencyHospitalOrHealthcare | Space Type is EmergencyHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Space Type is EquipmentRoomManufacturingFacility.
kExamOrTreatmentHospitalOrHealthcare | Space Type is ExamOrTreatmentHospitalOrHealthcare.
kExerciseAreaExerciseCenter | Space Type is ExerciseAreaExerciseCenter.
kExerciseAreaGymnasium | Space Type is ExerciseAreaGymnasium.
kExhibitSpaceConventionCenter | Space Type is ExhibitSpaceConventionCenter.
kFellowshipHallReligiousBuildings | Space Type is FellowshipHallReligiousBuildings.
kFineMaterialWarehouse | Space Type is FineMaterialWarehouse.
kFineMerchandiseSalesAreaRetail | Space Type is FineMerchandiseSalesAreaRetail.
kFireStationEngineRoomPoliceOrFireStation | Space Type is FireStationEngineRoomPoliceOrFireStation.
kFoodPreparation | Space Type is FoodPreparation.
kGarageServiceOrRepairAutomotiveFacility | Space Type is GarageServiceOrRepairAutomotiveFacility.
kGeneralHighBayManufacturingFacility | Space Type is GeneralHighBayManufacturingFacility.
kGeneralLowBayManufacturingFacility | Space Type is GeneralLowBayManufacturingFacility.
kGeneralExhibitionMuseum | Space Type is GeneralExhibitionMuseum.
kHospitalNurseryHospitalOrHealthcare | Space Type is HospitalNurseryHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalOrRadiologyHospitalOrHealthcare | Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHotelOrConferenceCenterConferenceOrMeeting | Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kInactiveStorage | Space Type is InactiveStorage.
kJudgesChambersCourtHouse | Space Type is JudgesChambersCourtHouse.
kLaboratoryOffice | Space Type is LaboratoryOffice.
kLaundryIroningAndSorting | Space Type is LaundryIroningAndSorting.
kLaundryWashingHospitalOrHealthcare | Space Type is LaundryWashingHospitalOrHealthcare.
kLibraryAudioVisualLibraryAudioVisual | Space Type is LibraryAudioVisualLibraryAudioVisual.
kLivingQuartersDormitory | Space Type is LivingQuartersDormitory.
kLivingQuartersMotel | Space Type is LivingQuartersMotel.
kLivingQuartersHotel | Space Type is LivingQuartersHotel.
kLobby | Space Type is Lobby.
kLobbyReligiousBuildings | Space Type is LobbyReligiousBuildings.
kLobbyMotionPictureTheatre | Space Type is LobbyMotionPictureTheatre.
kLobbyAuditorium | Space Type is LobbyAuditorium.
kLobbyPerformingArtsTheatre | Space Type is LobbyPerformingArtsTheatre.
kLobbyPostOffice | Space Type is LobbyPostOffice.
kLobbyHotel | Space Type is LobbyHotel.
kLoungeOrRecreation | Space Type is LoungeOrRecreation.
kMallConcourseSalesAreaRetail | Space Type is MallConcourseSalesAreaRetail.
kMassMerchandisingSalesAreaRetail | Space Type is MassMerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Space Type is MediumOrBulkyMaterialWarehouse.
kMerchandisingSalesAreaRetail | Space Type is MerchandisingSalesAreaRetail.
kMuseumAndGalleryStorage | Space Type is MuseumAndGalleryStorage.
kNurseStationHospitalOrHealthcare | Space Type is NurseStationHospitalOrHealthcare.
kOfficeEnclosed | Space Type is OfficeEnclosed.
kOfficeOpenPlan | Space Type is OfficeOpenPlan.
kOfficeCommonActivityAreasInactiveStorage | Space Type is OfficeCommonActivityAreasInactiveStorage.
kOperatingRoomHospitalOrHealthcare | Space Type is OperatingRoomHospitalOrHealthcare.
kOtherTelevisedPlayingAreaSportsArena | Space Type is OtherTelevisedPlayingAreaSportsArena.
kParkingAreaAttendantOnlyParkingGarage | Space Type is ParkingAreaAttendantOnlyParkingGarage.
kParkingAreaPedestrianParkingGarage | Space Type is ParkingAreaPedestrianParkingGarage.
kPatientRoomHospitalOrHealthcare | Space Type is PatientRoomHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Space Type is PersonalServicesSalesAreaRetail.
kPharmacyHospitalOrHealthcare | Space Type is PharmacyHospitalOrHealthcare.
kPhysicalTherapyHospitalOrHealthcare | Space Type is PhysicalTherapyHospitalOrHealthcare.
kPlayingAreaGymnasium | Space Type is PlayingAreaGymnasium.
kPlenum | Space Type is Plenum.
kPoliceStationLaboratoryPoliceOrFireStations | Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPublicAndStaffLoungeHospitalOrHealthcare | Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kReadingAreaLibrary | Space Type is ReadingAreaLibrary.
kReceptionOrWaitingTransportation | Space Type is ReceptionOrWaitingTransportation.
kReceptionOrWaitingMotel | Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingHotel | Space Type is ReceptionOrWaitingHotel.
kRecoveryHospitalOrHealthcare | Space Type is RecoveryHospitalOrHealthcare.
kRestorationMuseum | Space Type is RestorationMuseum.
kRestrooms | Space Type is Restrooms.
kRingSportsAreaSportsArena | Space Type is RingSportsAreaSportsArena.
kSleepingQuartersPoliceOrFireStation | Space Type is SleepingQuartersPoliceOrFireStation.
kSortingAreaPostOffice | Space Type is SortingAreaPostOffice.
kSpecialtyStoreSalesAreaRetail | Space Type is SpecialtyStoreSalesAreaRetail.
kStacksLibrary | Space Type is StacksLibrary.
kStairsInactive | Space Type is StairsInactive.
kStairway | Space Type is Stairway.
kSupermarketSalesAreaRetail | Space Type is SupermarketSalesAreaRetail.
kTerminalTicketCounterTransportation | Space Type is TerminalTicketCounterTransportation.
kWorkshopWorkshop | Space Type is WorkshopWorkshop.
kWorshipPulpitChoirReligious | Space Type is WorshipPulpitChoirReligious.
kNoOfSpaceTypes | Space Type is NoOfSpaceTypes.

See Also

Autodesk.Revit.DB.Mechanical Namespace


Zone Class

[image]

Revit 2011 API
Zone Class
Members See Also Send Feedback
Provides access to the Zone Element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Zone : Element
Visual Basic (Declaration)
Public Class Zone _
    Inherits Element
Visual C++
public ref class Zone : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object is only available in Revit MEP.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Mechanical..::.Zone

See Also

Zone Members
Autodesk.Revit.DB.Mechanical Namespace


Zone Members

[image] [image]

Revit 2011 API
Zone Members
Zone Class Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpaces | Remove a set of existing spaces to the current Zone element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultZone | Reports whether this zone is default or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ServiceType | Get or set the Service Type of the Zone.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Spaces | Get the Spaces of the Zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Methods

[image] [image]

Revit 2011 API
Zone Methods
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Methods

Name | Description
AddSpaces | Add a set of existing spaces to Zone element.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveSpaces | Remove a set of existing spaces to the current Zone element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


AddSpaces Method

[image]

Revit 2011 API
Zone..::.AddSpaces Method
Zone Class See Also Send Feedback
Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool AddSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function AddSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.DB.Mechanical..::.SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input spaces cannot be added to current zone element.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


RemoveSpaces Method

[image]

Revit 2011 API
Zone..::.RemoveSpaces Method
Zone Class See Also Send Feedback
Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool RemoveSpaces(
    SpaceSet spaces
)
Visual Basic (Declaration)
Public Function RemoveSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool RemoveSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.DB.Mechanical..::.SpaceSet
The spaces which want to delete from the current zone element.

Return Value

If successful the current zone element will remove a set of input spaces, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the input spaces cannot be deleted from current zone element.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Properties

[image] [image]

Revit 2011 API
Zone Properties
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Properties

Name | Description
Area | Get the Area of the Zone.
Boundary | Returns the boundary of the Zone.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GrossArea | Get the Gross Area of the Zone.
GrossVolume | Get the Gross Volume of the Zone.
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
HeatingSetPoint | Get or set the Heating Set Point of the Zone.
HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultZone | Reports whether this zone is default or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Get or Set the Name of the Zone. (Overrides Element..::.Name.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Perimeter | Get the Perimeter of the Zone.
Phase | Get the Phase of the Zone.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
ServiceType | Get or set the Service Type of the Zone.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Spaces | Get the Spaces of the Zone.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Volume | Get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Area Property

[image]

Revit 2011 API
Zone..::.Area Property
Zone Class See Also Send Feedback
Get the Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Boundary Property

[image]

Revit 2011 API
Zone..::.Boundary Property
Zone Class See Also Send Feedback
Returns the boundary of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Boundary { get; }
Visual Basic (Declaration)
Public ReadOnly Property Boundary As CurveArray
Visual C++
public:
property CurveArray^ Boundary {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Zone. Each Zone may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more details about the segments that make up the Zone topology.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedCoolingLoad Property

[image]

Revit 2011 API
Zone..::.CalculatedCoolingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Cooling Load of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedCoolingLoad As Double
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedHeatingLoad Property

[image]

Revit 2011 API
Zone..::.CalculatedHeatingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Heating Load of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedHeatingLoad As Double
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2011 API
Zone..::.CalculatedSupplyAirflow Property
Zone Class See Also Send Feedback
Get the Calculated Supply Airflow of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedSupplyAirflow As Double
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get the Calculated Supply Airflow (Unit: Airflow ) of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CoolingAirTemperature Property

[image]

Revit 2011 API
Zone..::.CoolingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Cooling Air Temperature of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CoolingAirTemperature { get; set; }
Visual Basic (Declaration)
Public Property CoolingAirTemperature As Double
Visual C++
public:
property double CoolingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CoolingSetPoint Property

[image]

Revit 2011 API
Zone..::.CoolingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Cooling Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CoolingSetPoint { get; set; }
Visual Basic (Declaration)
Public Property CoolingSetPoint As Double
Visual C++
public:
property double CoolingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


DehumidificationSetPoint Property

[image]

Revit 2011 API
Zone..::.DehumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the DeHumidification Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double DehumidificationSetPoint { get; set; }
Visual Basic (Declaration)
Public Property DehumidificationSetPoint As Double
Visual C++
public:
property double DehumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the DeHumidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


GrossArea Property

[image]

Revit 2011 API
Zone..::.GrossArea Property
Zone Class See Also Send Feedback
Get the Gross Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GrossArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property GrossArea As Double
Visual C++
public:
property double GrossArea {
    double get ();
}

Remarks

This property is used to get the Gross Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


GrossVolume Property

[image]

Revit 2011 API
Zone..::.GrossVolume Property
Zone Class See Also Send Feedback
Get the Gross Volume of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GrossVolume { get; }
Visual Basic (Declaration)
Public ReadOnly Property GrossVolume As Double
Visual C++
public:
property double GrossVolume {
    double get ();
}

Remarks

This property is used to get the Gross Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HeatingAirTemperature Property

[image]

Revit 2011 API
Zone..::.HeatingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Heating Air Temperature of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double HeatingAirTemperature { get; set; }
Visual Basic (Declaration)
Public Property HeatingAirTemperature As Double
Visual C++
public:
property double HeatingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HeatingSetPoint Property

[image]

Revit 2011 API
Zone..::.HeatingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Heating Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double HeatingSetPoint { get; set; }
Visual Basic (Declaration)
Public Property HeatingSetPoint As Double
Visual C++
public:
property double HeatingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HumidificationSetPoint Property

[image]

Revit 2011 API
Zone..::.HumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the Humidification Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double HumidificationSetPoint { get; set; }
Visual Basic (Declaration)
Public Property HumidificationSetPoint As Double
Visual C++
public:
property double HumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Humidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


IsDefaultZone Property

[image]

Revit 2011 API
Zone..::.IsDefaultZone Property
Zone Class See Also Send Feedback
Reports whether this zone is default or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsDefaultZone { get; set; }
Visual Basic (Declaration)
Public Property IsDefaultZone As Boolean
Visual C++
public:
property bool IsDefaultZone {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used to set the current zone as the default zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Name Property

[image]

Revit 2011 API
Zone..::.Name Property
Zone Class See Also Send Feedback
Get or Set the Name of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutDoorAirPerArea Property

[image]

Revit 2011 API
Zone..::.OutDoorAirPerArea Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double OutDoorAirPerArea { get; set; }
Visual Basic (Declaration)
Public Property OutDoorAirPerArea As Double
Visual C++
public:
property double OutDoorAirPerArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutDoorAirPerPerson Property

[image]

Revit 2011 API
Zone..::.OutDoorAirPerPerson Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Person of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double OutDoorAirPerPerson { get; set; }
Visual Basic (Declaration)
Public Property OutDoorAirPerPerson As Double
Visual C++
public:
property double OutDoorAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Out DoorAir Per Person of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutdoorAirRatePerAirChangesPerHour Property

[image]

Revit 2011 API
Zone..::.OutdoorAirRatePerAirChangesPerHour Property
Zone Class See Also Send Feedback
Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double OutdoorAirRatePerAirChangesPerHour { get; set; }
Visual Basic (Declaration)
Public Property OutdoorAirRatePerAirChangesPerHour As Double
Visual C++
public:
property double OutdoorAirRatePerAirChangesPerHour {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2011 API
Zone..::.Parameter Property
Zone Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Zone Class
Zone Members
Autodesk.Revit.DB.Mechanical Namespace


Perimeter Property

[image]

Revit 2011 API
Zone..::.Perimeter Property
Zone Class See Also Send Feedback
Get the Perimeter of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Perimeter As Double
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Phase Property

[image]

Revit 2011 API
Zone..::.Phase Property
Zone Class See Also Send Feedback
Get the Phase of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic (Declaration)
Public ReadOnly Property Phase As Phase
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

Remarks

This property is used to get the Phase of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


ServiceType Property

[image]

Revit 2011 API
Zone..::.ServiceType Property
Zone Class See Also Send Feedback
Get or set the Service Type of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As ServiceType
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Service Type of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Spaces Property

[image]

Revit 2011 API
Zone..::.Spaces Property
Zone Class See Also Send Feedback
Get the Spaces of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public SpaceSet Spaces { get; }
Visual Basic (Declaration)
Public ReadOnly Property Spaces As SpaceSet
Visual C++
public:
property SpaceSet^ Spaces {
    SpaceSet^ get ();
}

Remarks

This property is used to get the Spaces of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Volume Property

[image]

Revit 2011 API
Zone..::.Volume Property
Zone Class See Also Send Feedback
Get the Volume of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic (Declaration)
Public ReadOnly Property Volume As Double
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Autodesk.Revit.DB.Plumbing Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Plumbing Namespace
Send Feedback

Classes

Class | Description
FlexPipe | A flex pipe in the Autodesk Revit MEP product.
FlexPipeType | A flex pipe type in the Autodesk Revit MEP product.
FluidType | A fluid type symbol in the Autodesk Revit MEP product.
Pipe | A pipe in the Autodesk Revit MEP product.
PipeConnectionType | A pipe connection type in the Autodesk Revit MEP product.
PipeConnector | A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.
PipeMaterialType | A pipe material type in the Autodesk Revit MEP product.
PipeScheduleType | A pipe schedule type in the Autodesk Revit MEP product.
PipeType | A pipe type in the Autodesk Revit MEP product.
PipingSystem | A piping system in the Autodesk Revit MEP product.

Enumerations

Enumeration | Description
PipeFlowConfigurationType | An enumerated type listing all pipe flow configuration types for a connector
PipeFlowState | An enumerated type listing all the pipe flow states for a pipe.
PipeLossMethodType | An enumerated type listing all pipe loss method types for a connector
PipeSystemType | An enumerated type listing all the possible pipe system types for a connector object.


FlexPipe Class

[image]

Revit 2011 API
FlexPipe Class
Members See Also Send Feedback
A flex pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexPipe : MEPCurve
Visual Basic (Declaration)
Public Class FlexPipe _
    Inherits MEPCurve
Visual C++
public ref class FlexPipe : public MEPCurve

Remarks

The flex pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Plumbing..::.FlexPipe

See Also

FlexPipe Members
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Members

[image] [image]

Revit 2011 API
FlexPipe Members
FlexPipe Class Methods Properties See Also Send Feedback

The FlexPipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexPipeType | The flex pipe type of this flex pipe.
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Methods

[image] [image]

Revit 2011 API
FlexPipe Methods
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Properties

[image] [image]

Revit 2011 API
FlexPipe Properties
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlexPipeType | The flex pipe type of this flex pipe.
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Points | The points of the flex pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Property

[image]

Revit 2011 API
FlexPipe..::.FlexPipeType Property
FlexPipe Class See Also Send Feedback
The flex pipe type of this flex pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FlexPipeType FlexPipeType { get; set; }
Visual Basic (Declaration)
Public Property FlexPipeType As FlexPipeType
Visual C++
public:
property FlexPipeType^ FlexPipeType {
    FlexPipeType^ get ();
    void set (FlexPipeType^ value);
}

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlowState Property

[image]

Revit 2011 API
FlexPipe..::.FlowState Property
FlexPipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlowState As PipeFlowState
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
FlexPipe..::.Parameter Property
FlexPipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexPipe Class
FlexPipe Members
Autodesk.Revit.DB.Plumbing Namespace


Points Property

[image]

Revit 2011 API
FlexPipe..::.Points Property
FlexPipe Class See Also Send Feedback
The points of the flex pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic (Declaration)
Public Property Points As IList(Of XYZ)
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex pipe, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Class

[image]

Revit 2011 API
FlexPipeType Class
Members See Also Send Feedback
A flex pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FlexPipeType : MEPCurveType
Visual Basic (Declaration)
Public Class FlexPipeType _
    Inherits MEPCurveType
Visual C++
public ref class FlexPipeType : public MEPCurveType

Remarks

The flex pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Plumbing..::.FlexPipeType

See Also

FlexPipeType Members
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Members

[image] [image]

Revit 2011 API
FlexPipeType Members
FlexPipeType Class Methods Properties See Also Send Feedback

The FlexPipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Methods

[image] [image]

Revit 2011 API
FlexPipeType Methods
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Properties

[image] [image]

Revit 2011 API
FlexPipeType Properties
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the MEP curve type. (Inherited from MEPCurveType.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
FlexPipeType..::.Parameter Property
FlexPipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FlexPipeType Class
FlexPipeType Members
Autodesk.Revit.DB.Plumbing Namespace


FluidType Class

[image]

Revit 2011 API
FluidType Class
Members See Also Send Feedback
A fluid type symbol in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class FluidType : ElementType
Visual Basic (Declaration)
Public Class FluidType _
    Inherits ElementType
Visual C++
public ref class FluidType : public ElementType

Remarks

The object type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Plumbing..::.FluidType

See Also

FluidType Members
Autodesk.Revit.DB.Plumbing Namespace


FluidType Members

[image] [image]

Revit 2011 API
FluidType Members
FluidType Class Methods Properties See Also Send Feedback

The FluidType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Methods

[image] [image]

Revit 2011 API
FluidType Methods
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Properties

[image] [image]

Revit 2011 API
FluidType Properties
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
FluidType..::.Parameter Property
FluidType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

FluidType Class
FluidType Members
Autodesk.Revit.DB.Plumbing Namespace


Pipe Class

[image]

Revit 2011 API
Pipe Class
Members See Also Send Feedback
A pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Pipe : MEPCurve
Visual Basic (Declaration)
Public Class Pipe _
    Inherits MEPCurve
Visual C++
public ref class Pipe : public MEPCurve

Remarks

The pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.HostObject
Autodesk.Revit.DB..::.MEPCurve
Autodesk.Revit.DB.Plumbing..::.Pipe

See Also

Pipe Members
Autodesk.Revit.DB.Plumbing Namespace


Pipe Members

[image] [image]

Revit 2011 API
Pipe Members
Pipe Class Methods Properties See Also Send Feedback

The Pipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipeType | The pipe type of this pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Pipe Methods

[image] [image]

Revit 2011 API
Pipe Methods
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Pipe Properties

[image] [image]

Revit 2011 API
Pipe Properties
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
FlowState | The flow state of the pipe.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the MEP curve. (Inherited from MEPCurve.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipeType | The pipe type of this pipe.
ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the MEP curve. (Inherited from MEPCurve.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlowState Property

[image]

Revit 2011 API
Pipe..::.FlowState Property
Pipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic (Declaration)
Public ReadOnly Property FlowState As PipeFlowState
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
Pipe..::.Parameter Property
Pipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Pipe Class
Pipe Members
Autodesk.Revit.DB.Plumbing Namespace


PipeType Property

[image]

Revit 2011 API
Pipe..::.PipeType Property
Pipe Class See Also Send Feedback
The pipe type of this pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeType PipeType { get; set; }
Visual Basic (Declaration)
Public Property PipeType As PipeType
Visual C++
public:
property PipeType^ PipeType {
    PipeType^ get ();
    void set (PipeType^ value);
}

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Class

[image]

Revit 2011 API
PipeConnectionType Class
Members See Also Send Feedback
A pipe connection type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeConnectionType : ElementType
Visual Basic (Declaration)
Public Class PipeConnectionType _
    Inherits ElementType
Visual C++
public ref class PipeConnectionType : public ElementType

Remarks

The pipe connection type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Plumbing..::.PipeConnectionType

See Also

PipeConnectionType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Members

[image] [image]

Revit 2011 API
PipeConnectionType Members
PipeConnectionType Class Methods Properties See Also Send Feedback

The PipeConnectionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Methods

[image] [image]

Revit 2011 API
PipeConnectionType Methods
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Properties

[image] [image]

Revit 2011 API
PipeConnectionType Properties
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipeConnectionType..::.Parameter Property
PipeConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeConnectionType Class
PipeConnectionType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Class

[image]

Revit 2011 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeConnector : ConnectorElement,
    IConnector
Visual Basic (Declaration)
Public Class PipeConnector _
    Inherits ConnectorElement _
    Implements IConnector
Visual C++
public ref class PipeConnector : public ConnectorElement,
    IConnector

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Pipe connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ConnectorElement
Autodesk.Revit.DB.Plumbing..::.PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Members

[image] [image]

Revit 2011 API
PipeConnector Members
PipeConnector Class Methods Properties See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a pipe connector as a primary pipe connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked pipe connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the pipe connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Methods

[image] [image]

Revit 2011 API
PipeConnector Methods
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

Name | Description
AssignAsPrimary | Assign a pipe connector as a primary pipe connector.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


AssignAsPrimary Method

[image]

Revit 2011 API
PipeConnector..::.AssignAsPrimary Method
PipeConnector Class See Also Send Feedback
Assign a pipe connector as a primary pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic (Declaration)
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this pipe connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Properties

[image] [image]

Revit 2011 API
PipeConnector Properties
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoordinateSystem | The coordinate system of the connector.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Domain | The domain of the connector.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | The height of the connector.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsPrimary | Identifies if this is the primary connector in the family.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LinkedConnector | The linked pipe connector.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
Origin | The location of the connector in family document.
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Radius | The radius of the connector.
Shape | The shape of the connector.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SystemType | The system type of the pipe connector.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Width | The width of the connector.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


CoordinateSystem Property

[image]

Revit 2011 API
PipeConnector..::.CoordinateSystem Property
PipeConnector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CoordinateSystem As Transform
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::.CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Domain Property

[image]

Revit 2011 API
PipeConnector..::.Domain Property
PipeConnector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Domain As Domain
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::.Domain

Remarks

This property is used to retrieve the domain of the connector.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Height Property

[image]

Revit 2011 API
PipeConnector..::.Height Property
PipeConnector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Height As Double
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::.Height

Remarks

shape for pipe connector is round.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


IsPrimary Property

[image]

Revit 2011 API
PipeConnector..::.IsPrimary Property
PipeConnector Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


LinkedConnector Property

[image]

Revit 2011 API
PipeConnector..::.LinkedConnector Property
PipeConnector Class See Also Send Feedback
The linked pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeConnector LinkedConnector { get; set; }
Visual Basic (Declaration)
Public Property LinkedConnector As PipeConnector
Visual C++
public:
property PipeConnector^ LinkedConnector {
    PipeConnector^ get ();
    void set (PipeConnector^ value);
}

Remarks

Get this property to acquire the current linked pipe connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another pipe connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Origin Property

[image]

Revit 2011 API
PipeConnector..::.Origin Property
PipeConnector Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Origin As XYZ
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::.Origin

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipeConnector..::.Parameter Property
PipeConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeConnector Class
PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace


Radius Property

[image]

Revit 2011 API
PipeConnector..::.Radius Property
PipeConnector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Radius As Double
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::.Radius

Remarks

A pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Shape Property

[image]

Revit 2011 API
PipeConnector..::.Shape Property
PipeConnector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shape As ConnectorProfileType
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::.Shape

Remarks

A pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


SystemType Property

[image]

Revit 2011 API
PipeConnector..::.SystemType Property
PipeConnector Class See Also Send Feedback
The system type of the pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; set; }
Visual Basic (Declaration)
Public Property SystemType As PipeSystemType
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
    void set (PipeSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Width Property

[image]

Revit 2011 API
PipeConnector..::.Width Property
PipeConnector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Width As Double
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::.Width

Remarks

shape for pipe connector is round.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Always thrown because pipe connector's shape is always round.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeFlowConfigurationType Enumeration

[image]

Revit 2011 API
PipeFlowConfigurationType Enumeration
See Also Send Feedback
An enumerated type listing all pipe flow configuration types for a connector

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeFlowConfigurationType
Visual Basic (Declaration)
Public Enumeration PipeFlowConfigurationType
Visual C++
public enum class PipeFlowConfigurationType

Members

Member name | Description
Calculated | pipe flow configuration is calculated.
Preset | pipe flow configuration is Preset.
System | pipe flow configuration depends on system.
Demand | pipe flow configuration depends on demand.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeFlowState Enumeration

[image]

Revit 2011 API
PipeFlowState Enumeration
See Also Send Feedback
An enumerated type listing all the pipe flow states for a pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeFlowState
Visual Basic (Declaration)
Public Enumeration PipeFlowState
Visual C++
public enum class PipeFlowState

Members

Member name | Description
LaminarState | The flow state is Laminar.
TransitionState | The flow state is Transition.
TurbulentState | The flow state is Turbulent.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeLossMethodType Enumeration

[image]

Revit 2011 API
PipeLossMethodType Enumeration
See Also Send Feedback
An enumerated type listing all pipe loss method types for a connector

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeLossMethodType
Visual Basic (Declaration)
Public Enumeration PipeLossMethodType
Visual C++
public enum class PipeLossMethodType

Members

Member name | Description
NotDefined | pipe loss method is undefined.
Table | pipe loss method is depend on the coefficient from table.
SpecificLoss | pipe loss method is specified.
Coefficient | pipe loss method depend on coefficient.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Class

[image]

Revit 2011 API
PipeMaterialType Class
Members See Also Send Feedback
A pipe material type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeMaterialType : ElementType
Visual Basic (Declaration)
Public Class PipeMaterialType _
    Inherits ElementType
Visual C++
public ref class PipeMaterialType : public ElementType

Remarks

The pipe material type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Plumbing..::.PipeMaterialType

See Also

PipeMaterialType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Members

[image] [image]

Revit 2011 API
PipeMaterialType Members
PipeMaterialType Class Methods Properties See Also Send Feedback

The PipeMaterialType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Methods

[image] [image]

Revit 2011 API
PipeMaterialType Methods
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Properties

[image] [image]

Revit 2011 API
PipeMaterialType Properties
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipeMaterialType..::.Parameter Property
PipeMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeMaterialType Class
PipeMaterialType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Class

[image]

Revit 2011 API
PipeScheduleType Class
Members See Also Send Feedback
A pipe schedule type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeScheduleType : ElementType
Visual Basic (Declaration)
Public Class PipeScheduleType _
    Inherits ElementType
Visual C++
public ref class PipeScheduleType : public ElementType

Remarks

The pipe schedule type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Plumbing..::.PipeScheduleType

See Also

PipeScheduleType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Members

[image] [image]

Revit 2011 API
PipeScheduleType Members
PipeScheduleType Class Methods Properties See Also Send Feedback

The PipeScheduleType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Methods

[image] [image]

Revit 2011 API
PipeScheduleType Methods
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Properties

[image] [image]

Revit 2011 API
PipeScheduleType Properties
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipeScheduleType..::.Parameter Property
PipeScheduleType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeScheduleType Class
PipeScheduleType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeSystemType Enumeration

[image]

Revit 2011 API
PipeSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible pipe system types for a connector object.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum PipeSystemType
Visual Basic (Declaration)
Public Enumeration PipeSystemType
Visual C++
public enum class PipeSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type
SupplyHydronic | Pipe System Type is SupplyHydronic.
ReturnHydronic | Pipe System Type is ReturnHydronic.
Sanitary | Pipe System Type is Sanitary.
DomesticHotWater | Pipe System Type is DomesticHotWater.
DomesticColdWater | Pipe System Type is DomesticColdWater.
OtherPipe | Pipe System Type is OtherPipe.
FireProtectWet | Pipe System Type is FireProtectWet.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectOther | Pipe System Type is FireProtectOther.
Fitting | Pipe System Type is Fitting.
Global | Pipe System Type is Global.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeType Class

[image]

Revit 2011 API
PipeType Class
Members See Also Send Feedback
A pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipeType : MEPCurveType
Visual Basic (Declaration)
Public Class PipeType _
    Inherits MEPCurveType
Visual C++
public ref class PipeType : public MEPCurveType

Remarks

The pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.MEPCurveType
Autodesk.Revit.DB.Plumbing..::.PipeType

See Also

PipeType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeType Members

[image] [image]

Revit 2011 API
PipeType Members
PipeType Class Methods Properties See Also Send Feedback

The PipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | The material type of the pipe type.
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeType Methods

[image] [image]

Revit 2011 API
PipeType Methods
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeType Properties

[image] [image]

Revit 2011 API
PipeType Properties
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Class | The schedule type of the pipe type.
ConnectionType | The connection type of the pipe type.
Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Material | The material type of the pipe type.
Materials | Get all materials present in the element. (Inherited from Element.)
MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Roughness | The roughness of the pipe type. (Overrides MEPCurveType..::.Roughness.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Class Property

[image]

Revit 2011 API
PipeType..::.Class Property
PipeType Class See Also Send Feedback
The schedule type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeScheduleType Class { get; }
Visual Basic (Declaration)
Public ReadOnly Property Class As PipeScheduleType
Visual C++
public:
property PipeScheduleType^ Class {
    PipeScheduleType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


ConnectionType Property

[image]

Revit 2011 API
PipeType..::.ConnectionType Property
PipeType Class See Also Send Feedback
The connection type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeConnectionType ConnectionType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionType As PipeConnectionType
Visual C++
public:
property PipeConnectionType^ ConnectionType {
    PipeConnectionType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Material Property

[image]

Revit 2011 API
PipeType..::.Material Property
PipeType Class See Also Send Feedback
The material type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeMaterialType Material { get; }
Visual Basic (Declaration)
Public ReadOnly Property Material As PipeMaterialType
Visual C++
public:
property PipeMaterialType^ Material {
    PipeMaterialType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipeType..::.Parameter Property
PipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipeType Class
PipeType Members
Autodesk.Revit.DB.Plumbing Namespace


Roughness Property

[image]

Revit 2011 API
PipeType..::.Roughness Property
PipeType Class See Also Send Feedback
The roughness of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override double Roughness { set; }
Visual Basic (Declaration)
Public Overrides WriteOnly Property Roughness As Double
Visual C++
public:
virtual property double Roughness {
    void set (double value) override;
}

Remarks

set for this property will always throw an exception.

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Class

[image]

Revit 2011 API
PipingSystem Class
Members See Also Send Feedback
A piping system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PipingSystem : MEPSystem
Visual Basic (Declaration)
Public Class PipingSystem _
    Inherits MEPSystem
Visual C++
public ref class PipingSystem : public MEPSystem

Remarks

The piping system element is only available in Autodesk Revit MEP product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.MEPSystem
Autodesk.Revit.DB.Plumbing..::.PipingSystem

See Also

PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Members

[image] [image]

Revit 2011 API
PipingSystem Members
PipingSystem Class Methods Properties See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipingNetwork | Pipes and fittings which are contained in this system.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this piping system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Methods

[image] [image]

Revit 2011 API
PipingSystem Methods
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

Name | Description
Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
Remove | Remove elements from system. (Inherited from MEPSystem.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Properties

[image] [image]

Revit 2011 API
PipingSystem Properties
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Properties

Name | Description
BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Flow | The system flow.
FluidDensity | The system fluid density.
FluidTemperature | The system fluid temperature.
FluidType | The system fluid type.
FluidViscosity | The system fluid viscosity.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
IsWellConnected | Indicates if the system is well connected or not.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
PipingNetwork | Pipes and fittings which are contained in this system.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StaticPressure | The system static pressure.
SystemType | The type of this piping system.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


BaseEquipmentConnector Property

[image]

Revit 2011 API
PipingSystem..::.BaseEquipmentConnector Property
PipingSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic (Declaration)
Public Property BaseEquipmentConnector As Connector
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Setting this property to nullNothingnullptra null reference (Nothing in Visual Basic) will disconnect base equipment from system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the set operation failed.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Flow Property

[image]

Revit 2011 API
PipingSystem..::.Flow Property
PipingSystem Class See Also Send Feedback
The system flow.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flow As Double
Visual C++
public:
property double Flow {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Throw when the flow is not computed because the system is not well connected.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


FluidDensity Property

[image]

Revit 2011 API
PipingSystem..::.FluidDensity Property
PipingSystem Class See Also Send Feedback
The system fluid density.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FluidDensity { get; }
Visual Basic (Declaration)
Public ReadOnly Property FluidDensity As Double
Visual C++
public:
property double FluidDensity {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Property

[image]

Revit 2011 API
PipingSystem..::.FluidTemperature Property
PipingSystem Class See Also Send Feedback
The system fluid temperature.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FluidTemperature { get; set; }
Visual Basic (Declaration)
Public Property FluidTemperature As Double
Visual C++
public:
property double FluidTemperature {
    double get ();
    void set (double value);
}

Remarks

Only a fixed set of possible fluid temperatures are permitted by Revit MEP for each system fluid type. Setting this property will map to the nearest appropriate value used internally for the system fluid type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when assigning a value which is not a valid positive number.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Property

[image]

Revit 2011 API
PipingSystem..::.FluidType Property
PipingSystem Class See Also Send Feedback
The system fluid type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FluidType FluidType { get; set; }
Visual Basic (Declaration)
Public Property FluidType As FluidType
Visual C++
public:
property FluidType^ FluidType {
    FluidType^ get ();
    void set (FluidType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when assigning nullNothingnullptra null reference (Nothing in Visual Basic) to fluid type.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


FluidViscosity Property

[image]

Revit 2011 API
PipingSystem..::.FluidViscosity Property
PipingSystem Class See Also Send Feedback
The system fluid viscosity.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double FluidViscosity { get; }
Visual Basic (Declaration)
Public ReadOnly Property FluidViscosity As Double
Visual C++
public:
property double FluidViscosity {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


IsWellConnected Property

[image]

Revit 2011 API
PipingSystem..::.IsWellConnected Property
PipingSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWellConnected As Boolean
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2011 API
PipingSystem..::.Parameter Property
PipingSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PipingSystem Class
PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


PipingNetwork Property

[image]

Revit 2011 API
PipingSystem..::.PipingNetwork Property
PipingSystem Class See Also Send Feedback
Pipes and fittings which are contained in this system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementSet PipingNetwork { get; }
Visual Basic (Declaration)
Public ReadOnly Property PipingNetwork As ElementSet
Visual C++
public:
property ElementSet^ PipingNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include mechanical equipment elements. The pipes and fittings are not returned in any particular order.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


StaticPressure Property

[image]

Revit 2011 API
PipingSystem..::.StaticPressure Property
PipingSystem Class See Also Send Feedback
The system static pressure.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StaticPressure { get; }
Visual Basic (Declaration)
Public ReadOnly Property StaticPressure As Double
Visual C++
public:
property double StaticPressure {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Throw when the static pressure is not computed because the system is not well connected.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


SystemType Property

[image]

Revit 2011 API
PipingSystem..::.SystemType Property
PipingSystem Class See Also Send Feedback
The type of this piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemType As PipeSystemType
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Autodesk.Revit.DB.Structure Namespace

[image]

Revit 2011 API
Autodesk.Revit.DB.Structure Namespace
Send Feedback

Classes

Class | Description
AbbreviationItem |
AnalyticalConsistencyChecking |
AnalyticalModel | AnalyticalModel represents the Analytical Model portion of a given Structural Element.
AnalyticalModelSelector | Defines a portion of an Analytical Model for an Element.
AnalyticalModelSketchComponent | This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.
AnalyticalModelSupport | Represents one support for an Element, in the realm of the Analytical Model.
AnalyticalModelSweptProfile | Represents an extruded profile swept along a driving curve.
AnalyticalSupportChecking |
AreaLoad | An object that represents a force applied across an area.
AreaLoadType | An object that represents a Load type.
AreaLoadTypeSet | A set that contains areaload types.
AreaLoadTypeSetIterator | An iterator to a areaload type set.
AreaReinforcement | An object that represents an Area Reinforcement within the Autodesk Revit project.
AreaReinforcementCurve | An object that specifies the type of a floor in Autodesk Revit.
AreaReinforcementType | An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
BarDescription | An object that represents an Area Reinforcement within the Autodesk Revit project.
FamilyStructuralMaterialTypeFilter | A filter used to match families that have the given structural material type.
LineLoad | An object that represents a force/moment applied in a linear manner.
LineLoadType | An object that represents a Load type.
LineLoadTypeSet | A set that contains lineload types.
LineLoadTypeSetIterator | An iterator to a lineload type set.
LoadBase | The LoadBase object is the base class for all load objects within the Autodesk Revit API.
LoadCase | This object represents a load case within the project.
LoadCaseArray | An array that contains load case objects.
LoadCaseArrayIterator | An iterator to an load case array.
LoadCaseSet | A set that contains load cases.
LoadCaseSetIterator | An iterator to a load case set.
LoadCombination | An object that represents a load combination.
LoadCombinationArray | An array that can contain any type of object.
LoadCombinationArrayIterator | An iterator to a array.
LoadNature | A structural Load nature object.
LoadTypeBase | An object that represents a Load type.
LoadTypeBaseSet | A set that contains load type bases.
LoadTypeBaseSetIterator | An iterator to a load type base set.
LoadUsage | This object represents a load case within the project.
LoadUsageArray | An array that contains load usage objects.
LoadUsageArrayIterator | An iterator to an load usage array.
PathReinforcement | An object that represents an Path Reinforcement within the Autodesk Revit project.
PathReinforcementType | An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
PointLoad | An object that represents a force/moment applied to a single point.
PointLoadType | An object that represents a Load type.
PointLoadTypeSet | A set that contains pointload types.
PointLoadTypeSetIterator | An iterator to a pointload type set.
Rebar | Represents a rebar element in Autodesk Revit.
RebarBarType | A Rebar type object that is used in the generation of Rebar
RebarBarTypeSet | A set that contains RebarBar types.
RebarBarTypeSetIterator | An iterator to a RebarBar type set.
RebarCoverType | A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.
RebarCoverTypeSet | A set that contains RebarCover types.
RebarCoverTypeSetIterator | An iterator to a RebarCover type set.
RebarHookType | A Rebar Hook type object that is used in the generation of Rebar.
RebarHookTypeSet | A set that contains RebarHook types.
RebarHookTypeSetIterator | An iterator to a RebarHook type set.
RebarHostData | Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.
RebarShape | RebarShape specifies the shape type for a Rebar instance.
RebarShapeDefinition | A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.
RebarShapeDefinitionByArc | Definition of a shape whose size and position can determined by a single arc.
RebarShapeDefinitionBySegments | Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
RebarShapeSet | An set that contains rebar shapes.
RebarShapeSetIterator | An iterator to a rebar shape set.
StructuralConnectionType |
StructuralInstanceUsageFilter | A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.
StructuralMaterialTypeFilter | A filter used to match family instances that have the given structural material type.
StructuralSettings | Provides access to project-wide structural settings.
StructuralWallUsageFilter | A filter used to match walls that have the given structural wall usage.
Truss | Represents all kinds of Trusses.
TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
TrussType | Represents a specific type of truss.
TrussTypeSet | A set that contains Truss types.
TrussTypeSetIterator | An iterator to a Truss type set.

Enumerations

Enumeration | Description
AnalyticalCurveSelector | Specifies which portion of an Analytical Curve is of interest.
AnalyticalCurveType | Identifies what type of Analytical Model curves should be extracted.
AnalyticalDirection | Specifies a direction for manipulating analytical model.
AnalyticalProjectionType | Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements
AnalyticalRigidLinksOption | Specifies how Rigid Links will be made for the Analytical Model.
AnalyticalSupportPriority | Defines how "highly" another Element is giving support for one Element.
AnalyticalSupportType | Indicates what kind of support another Element provides -- Point, Surface, or Curve.
AnalyzeAs | Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.
BoundaryConditionsType | This enum declares type of BoundaryConditions.
BracePlanRepresentation | The possible representations for braces in plan views.
RebarHookOrientation | Orientation of a rebar hook relative to the path of the Rebar Shape.
RebarLayoutRule | The rule for how the rebars in rebar set are laid out
RebarShapeArcReferenceType | A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.
RebarShapeBendAngle | A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
RebarShapeDefinitionByArcType | A RebarShapeDefinitionByArc takes one of three forms.
RebarStyle | Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
SlabFoundationType | SlabFoundation type.
StructuralConnectionApplyTo |
StructuralInstanceUsage | Represents the structural usage of a family instance.
StructuralMaterialType | Represents the structural material type.
StructuralType | Represents the structural type of a family instance.
StructuralWallUsage | Represents the structural usage of a wall.
TranslationRotationValue | Values for BoundaryConditions Translation and Rotation parameters.
TrussChordLocation | This enumerated type represents the options for the Truss Chord Location.
TrussCurveType | Types of curves created in truss families.
TrussMemberType | Indicates the "kind" of a truss member.


AbbreviationItem Class

[image]

Revit 2011 API
AbbreviationItem Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AbbreviationItem : IDisposable
Visual Basic (Declaration)
Public Class AbbreviationItem _
    Implements IDisposable
Visual C++
public ref class AbbreviationItem : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AbbreviationItem

See Also

AbbreviationItem Members
Autodesk.Revit.DB.Structure Namespace


AbbreviationItem Members

[image] [image]

Revit 2011 API
AbbreviationItem Members
AbbreviationItem Class Methods See Also Send Feedback

The AbbreviationItem type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AbbreviationItem Class
Autodesk.Revit.DB.Structure Namespace


AbbreviationItem Methods

[image] [image]

Revit 2011 API
AbbreviationItem Methods
AbbreviationItem Class See Also Send Feedback

The AbbreviationItem type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AbbreviationItem Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AbbreviationItem..::.Dispose Method
AbbreviationItem Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AbbreviationItem Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Class

[image]

Revit 2011 API
AnalyticalConsistencyChecking Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AnalyticalConsistencyChecking : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalConsistencyChecking _
    Implements IDisposable
Visual C++
public ref class AnalyticalConsistencyChecking : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalConsistencyChecking

See Also

AnalyticalConsistencyChecking Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Members

[image] [image]

Revit 2011 API
AnalyticalConsistencyChecking Members
AnalyticalConsistencyChecking Class Methods See Also Send Feedback

The AnalyticalConsistencyChecking type exposes the following members.

Methods

Name | Description
CheckAnalyticalConsistency | Checks consistency of the Analytical Model.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Methods

[image] [image]

Revit 2011 API
AnalyticalConsistencyChecking Methods
AnalyticalConsistencyChecking Class See Also Send Feedback

The AnalyticalConsistencyChecking type exposes the following members.

Methods

Name | Description
CheckAnalyticalConsistency | Checks consistency of the Analytical Model.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


CheckAnalyticalConsistency Method

[image]

Revit 2011 API
AnalyticalConsistencyChecking..::.CheckAnalyticalConsistency Method
AnalyticalConsistencyChecking Class See Also Send Feedback
Checks consistency of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool CheckAnalyticalConsistency(
    Document document
)
Visual Basic (Declaration)
Public Shared Function CheckAnalyticalConsistency ( _
    document As Document _
) As Boolean
Visual C++
public:
static bool CheckAnalyticalConsistency(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document in which to perform consistency checks.

Return Value

True if run succeeded, false otherwise.

Remarks

Existence of inconsistencies will not affect the return value. If inconsistencies are found, Revit will post warnings regarding those inconsistencies. This should be run from within a transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalConsistencyChecking..::.Dispose Method
AnalyticalConsistencyChecking Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalCurveSelector Enumeration

[image]

Revit 2011 API
AnalyticalCurveSelector Enumeration
See Also Send Feedback
Specifies which portion of an Analytical Curve is of interest.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalCurveSelector
Visual Basic (Declaration)
Public Enumeration AnalyticalCurveSelector
Visual C++
public enum class AnalyticalCurveSelector

Members

Member name | Description
StartPoint | Start of curve (corresponds to param = 0).
EndPoint | End of curve (corresponds to param = 1).
WholeCurve | Entire curve.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalCurveType Enumeration

[image]

Revit 2011 API
AnalyticalCurveType Enumeration
See Also Send Feedback
Identifies what type of Analytical Model curves should be extracted.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalCurveType
Visual Basic (Declaration)
Public Enumeration AnalyticalCurveType
Visual C++
public enum class AnalyticalCurveType

Members

Member name | Description
RawCurves | Base Analytical Model curves generated.
RigidLinkHead | Rigid Link at end 0 (head) of the Beam.
RigidLinkTail | Rigid Link at end 1 (tail) of the Beam.
ActiveCurves | Curves displayed on screen (not including Rigid Links).
ApproximatedCurves | Curves approximated using linear segments.
AllRigidLinks | All Rigid Link curves. Rigid Link at end 0 (head) will be in the first entry. Rigid Link at end 1 (tail) will be in the last entry.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalDirection Enumeration

[image]

Revit 2011 API
AnalyticalDirection Enumeration
See Also Send Feedback
Specifies a direction for manipulating analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalDirection
Visual Basic (Declaration)
Public Enumeration AnalyticalDirection
Visual C++
public enum class AnalyticalDirection

Members

Member name | Description
Vertical | Change in vertical direction only.
VerticalTop | Vertical change, for top of Element's analytical model.
VerticalBottom | Vertical change, for bottom of Element's analytical model.
Horizontal | Change in horizontal direction only (no elevation change).
HorizontalStart | Horizontal change, corresponding to start of Curve Driver.
HorizontalEnd | Horizontal change, corresponding to end of Curve Driver.
Any | Any change, including vertical and horizontal.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Class

[image]

Revit 2011 API
AnalyticalModel Class
Members See Also Send Feedback
AnalyticalModel represents the Analytical Model portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModel : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModel _
    Implements IDisposable
Visual C++
public ref class AnalyticalModel : IDisposable

Remarks

AnalyticalModel is made up of the following information:
  • Curves, representing the graphical representation of the Element with respect to analysis.
  • Support Information.
  • Adjustment Information, both Manual and Automatic.
  • Parameter Information, including projection, hard points, approximation, and rigid links.
  • Analytical Offset.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModel

See Also

AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Members

[image] [image]

Revit 2011 API
AnalyticalModel Members
AnalyticalModel Class Methods Properties See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

Name | Description
Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
CanApproximate | Indicates whether Analytical Model can be approximated or not.
CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
CanDisableAutoDetect | Indicates whether or not Analytical Auto-detect can be disabled programmatically
CanHaveRigidLinks | Indicates whether Analytical Model supports Rigid Links.
CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
CanUseHardPoints | Indicates whether Analytical Model can use Hard Points.
Dispose |
Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
EnableAutoDetect | Enable or disable Analytical Auto-detect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
GetAnalyticalOffset | Retrieves Analytical Offset in the case where the user can do that.
GetAnalyticalProjectionDatumPlane | Retrieves analytical model projection information for a specific direction.
GetAnalyticalProjectionType | This retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
GetApproximationDeviation | Retrieves amount by which approximation is made.
GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
GetCurve | This returns the single curve of the Analytical Model, if it is only one curve.
GetCurves | Retrieves all curves for the Analytical Model of a given type.
GetElementId | Retrieves Element Id of the Analytical Model.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
GetPoint | Retrieves point of the Analytical Model.
GetReference | Returns a reference to a given curve within the analytical model.
GetRigidLink | Returns rigid link curve corresponding to selector.
GetSweptProfile | Retrieves the swept profile information for Analytical Model.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasRigidLinksWith | Indicates whether Analytical Model has Rigid Links with specified element.
HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
IsApproximated | Indicates whether Analytical Model is approximated or not.
IsAutoDetectEnabled | Reports whether or not Analytical Auto-detect for the given direction is enabled.
IsElementFullySupported | Indicates whether Analytical Model is fully supported.
IsEnabled | Reports whether the Analytical Model is enabled or disabled.
IsManuallyAdjusted | Indicates whether or not the Analytical Model has been manually adjusted by the user.
IsSingleCurve | This indicates whether the Analytical Model can be expressed as a single curve.
IsSinglePoint | This indicates whether the Analytical Model can be expressed as a single point.
IsValidAnalyticalProjectionType | Indicates whether a given Analytical Projection Type is valid for the given Analytical Direction.
IsValidDatumPlaneForProjection | Indicates whether a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
IsValidDirectionForAutoDetect | Tests whether or not the supplied direction is valid for Analytical Auto-detect.
IsValidDirectionForProjection | This indicates whether the input direction is valid for Analytical Model projection.
IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
IsValidRigidLinksOption | Indicates whether Rigid Links option is valid for the Analytical Model.
IsValidSelector | This indicates whether the input selector is valid for the Analytical Model.
ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
SetAnalyticalOffset | Sets Analytical Offset in the case where the user can do that.
SetAnalyticalProjectionDatumPlane | Sets analytical model projection to a Datum Plane.
SetAnalyticalProjectionType | Sets the analytical model projection to a preset value.
SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
SetApproximationDeviation | Adjusts the amount by which approximation is made.
SetUsesHardPoints | Sets Hard Points for the Analytical Model.
SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

Properties

Name | Description
RigidLinksOption | Indicates whether parameters indicate if Rigid Links should be formed.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Methods

[image] [image]

Revit 2011 API
AnalyticalModel Methods
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

Name | Description
Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
CanApproximate | Indicates whether Analytical Model can be approximated or not.
CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
CanDisableAutoDetect | Indicates whether or not Analytical Auto-detect can be disabled programmatically
CanHaveRigidLinks | Indicates whether Analytical Model supports Rigid Links.
CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
CanUseHardPoints | Indicates whether Analytical Model can use Hard Points.
Dispose |
Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
EnableAutoDetect | Enable or disable Analytical Auto-detect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
GetAnalyticalOffset | Retrieves Analytical Offset in the case where the user can do that.
GetAnalyticalProjectionDatumPlane | Retrieves analytical model projection information for a specific direction.
GetAnalyticalProjectionType | This retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
GetApproximationDeviation | Retrieves amount by which approximation is made.
GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
GetCurve | This returns the single curve of the Analytical Model, if it is only one curve.
GetCurves | Retrieves all curves for the Analytical Model of a given type.
GetElementId | Retrieves Element Id of the Analytical Model.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
GetPoint | Retrieves point of the Analytical Model.
GetReference | Returns a reference to a given curve within the analytical model.
GetRigidLink | Returns rigid link curve corresponding to selector.
GetSweptProfile | Retrieves the swept profile information for Analytical Model.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasRigidLinksWith | Indicates whether Analytical Model has Rigid Links with specified element.
HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
IsApproximated | Indicates whether Analytical Model is approximated or not.
IsAutoDetectEnabled | Reports whether or not Analytical Auto-detect for the given direction is enabled.
IsElementFullySupported | Indicates whether Analytical Model is fully supported.
IsEnabled | Reports whether the Analytical Model is enabled or disabled.
IsManuallyAdjusted | Indicates whether or not the Analytical Model has been manually adjusted by the user.
IsSingleCurve | This indicates whether the Analytical Model can be expressed as a single curve.
IsSinglePoint | This indicates whether the Analytical Model can be expressed as a single point.
IsValidAnalyticalProjectionType | Indicates whether a given Analytical Projection Type is valid for the given Analytical Direction.
IsValidDatumPlaneForProjection | Indicates whether a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
IsValidDirectionForAutoDetect | Tests whether or not the supplied direction is valid for Analytical Auto-detect.
IsValidDirectionForProjection | This indicates whether the input direction is valid for Analytical Model projection.
IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
IsValidRigidLinksOption | Indicates whether Rigid Links option is valid for the Analytical Model.
IsValidSelector | This indicates whether the input selector is valid for the Analytical Model.
ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
SetAnalyticalOffset | Sets Analytical Offset in the case where the user can do that.
SetAnalyticalProjectionDatumPlane | Sets analytical model projection to a Datum Plane.
SetAnalyticalProjectionType | Sets the analytical model projection to a preset value.
SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
SetApproximationDeviation | Adjusts the amount by which approximation is made.
SetUsesHardPoints | Sets Hard Points for the Analytical Model.
SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Approximate Method

[image]

Revit 2011 API
AnalyticalModel..::.Approximate Method
AnalyticalModel Class See Also Send Feedback
Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Approximate(
    bool enableApproximation
)
Visual Basic (Declaration)
Public Sub Approximate ( _
    enableApproximation As Boolean _
)
Visual C++
public:
void Approximate(
    bool enableApproximation
)

Parameters

enableApproximation
Type: System..::.Boolean
Enable/disable approximated function.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support approximation.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanApproximate Method

[image]

Revit 2011 API
AnalyticalModel..::.CanApproximate Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model can be approximated or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanApproximate()
Visual Basic (Declaration)
Public Function CanApproximate As Boolean
Visual C++
public:
bool CanApproximate()

Return Value

True if Analytical Model can be approximated; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanDisable Method

[image]

Revit 2011 API
AnalyticalModel..::.CanDisable Method
AnalyticalModel Class See Also Send Feedback
Reports whether the user can enable or disable the Analytical Model programmatically.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanDisable()
Visual Basic (Declaration)
Public Function CanDisable As Boolean
Visual C++
public:
bool CanDisable()

Return Value

True if one can enable/disable the Analytical Model, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanDisableAutoDetect Method

[image]

Revit 2011 API
AnalyticalModel..::.CanDisableAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Indicates whether or not Analytical Auto-detect can be disabled programmatically

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanDisableAutoDetect(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function CanDisableAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool CanDisableAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
direction in which to test whether Analytical Auto-detect can be disabled

Return Value

true if Analytical Auto-detect can be disabled, false otherwise

Remarks

This exists because certain Elements can have Auto-detect enabled (e.g., a Structural Wall), but the disabling of Auto-detect is undefined. This is because Auto-detect is actually a setting in the Analytical Projection parameter, and changing this value from Auto-detect is not well defined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanHaveRigidLinks Method

[image]

Revit 2011 API
AnalyticalModel..::.CanHaveRigidLinks Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model supports Rigid Links.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveRigidLinks()
Visual Basic (Declaration)
Public Function CanHaveRigidLinks As Boolean
Visual C++
public:
bool CanHaveRigidLinks()

Return Value

True if Analytical Model supports Rigid Links; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanSetAnalyticalOffset Method

[image]

Revit 2011 API
AnalyticalModel..::.CanSetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Determines whether the Analytical Model Offset can be changed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanSetAnalyticalOffset()
Visual Basic (Declaration)
Public Function CanSetAnalyticalOffset As Boolean
Visual C++
public:
bool CanSetAnalyticalOffset()

Return Value

True if user can set Analytical Model offset, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanUseHardPoints Method

[image]

Revit 2011 API
AnalyticalModel..::.CanUseHardPoints Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model can use Hard Points.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool CanUseHardPoints()
Visual Basic (Declaration)
Public Function CanUseHardPoints As Boolean
Visual C++
public:
bool CanUseHardPoints()

Return Value

True if Analytical Model can use Hard Points, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalModel..::.Dispose Method
AnalyticalModel Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Enable Method

[image]

Revit 2011 API
AnalyticalModel..::.Enable Method
AnalyticalModel Class See Also Send Feedback
Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void Enable(
    bool enable
)
Visual Basic (Declaration)
Public Sub Enable ( _
    enable As Boolean _
)
Visual C++
public:
void Enable(
    bool enable
)

Parameters

enable
Type: System..::.Boolean
Enable (true) or disable (false) Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


EnableAutoDetect Method

[image]

Revit 2011 API
AnalyticalModel..::.EnableAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Enable or disable Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)
Visual Basic (Declaration)
Public Sub EnableAutoDetect ( _
    direction As AnalyticalDirection, _
    enabled As Boolean _
)
Visual C++
public:
void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
direction in which to enable Analytical Auto-detect
enabled
Type: System..::.Boolean
turn Analytical Auto-detect on (true) or off (false)

Remarks

It is possible to enable Analytical Auto-detect for one direction, and have it disabled for another direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel cannot disable Auto-detect for direction

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalModelSketchComponents Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyticalModelSketchComponents Method
AnalyticalModel Class See Also Send Feedback
Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSketchComponent> GetAnalyticalModelSketchComponents()
Visual Basic (Declaration)
Public Function GetAnalyticalModelSketchComponents As IList(Of AnalyticalModelSketchComponent)
Visual C++
public:
IList<AnalyticalModelSketchComponent^>^ GetAnalyticalModelSketchComponents()

Return Value

If the Analytical Model supports Sketch-based adjustment of the Analytical Model, then this will return an array of AnalyticalModelSketchComponents. Otherwise, it will return an empty array.

Remarks

The AnalyticalModelSketchComponent abstraction is necessary for the those Elements (currently only Slab) consisting of a Sketch, and each Sketch line has the potential to have Analytical Model specific items associated with it. These Analytical Model artifacts are components of the Slab, not of the individual curves (which have no Analytical Model). This form results in writable AnalyticalModelSketchComponents.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalModelSupports Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyticalModelSupports Method
AnalyticalModel Class See Also Send Feedback
Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSupport> GetAnalyticalModelSupports()
Visual Basic (Declaration)
Public Function GetAnalyticalModelSupports As IList(Of AnalyticalModelSupport)
Visual C++
public:
IList<AnalyticalModelSupport^>^ GetAnalyticalModelSupports()

Return Value

Array of AnalyticalModelSupport objects, each one representing a support.

Remarks

If an Element is not supported by anything, the array returned should be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalOffset Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ GetAnalyticalOffset()
Visual Basic (Declaration)
Public Function GetAnalyticalOffset As XYZ
Visual C++
public:
XYZ^ GetAnalyticalOffset()

Return Value

Offset of Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Retrieves analytical model projection information for a specific direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
This retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionType ( _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction of projection.

Return Value

Indicates whether the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyzeAs Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAnalyzeAs Method
AnalyticalModel Class See Also Send Feedback
Returns value of Analyze As parameter for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyzeAs GetAnalyzeAs()
Visual Basic (Declaration)
Public Function GetAnalyzeAs As AnalyzeAs
Visual C++
public:
AnalyzeAs GetAnalyzeAs()

Return Value

AnalyzeAs enumeration, indicating how Analytical Model is analyzed.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetApproximationDeviation Method

[image]

Revit 2011 API
AnalyticalModel..::.GetApproximationDeviation Method
AnalyticalModel Class See Also Send Feedback
Retrieves amount by which approximation is made.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double GetApproximationDeviation()
Visual Basic (Declaration)
Public Function GetApproximationDeviation As Double
Visual C++
public:
double GetApproximationDeviation()

Return Value

Maximum distance from approximated line to curve. If approximation does not make sense, then this will be 0.0.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAutoDetectMatchedElements Method

[image]

Revit 2011 API
AnalyticalModel..::.GetAutoDetectMatchedElements Method
AnalyticalModel Class See Also Send Feedback
Retrieves other Element Ids that this Element is Auto-detecting against.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAutoDetectMatchedElements(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function GetAutoDetectMatchedElements ( _
    direction As AnalyticalDirection _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAutoDetectMatchedElements(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Analytical Auto-detect is being done.

Return Value

A set of Element Ids against which this Element is Auto-detecting. The set may be empty if this Element is not Auto-detecting against anything.

Remarks

An empty set is a valid return value. It just means that this Element is not Auto-detecting against any other Elements in the given direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetCurve Method

[image]

Revit 2011 API
AnalyticalModel..::.GetCurve Method
AnalyticalModel Class Example See Also Send Feedback
This returns the single curve of the Analytical Model, if it is only one curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Curve GetCurve()
Visual Basic (Declaration)
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

Single curve of the Analytical Model.

Examples

CopyC#
public void GetColumnCurve(FamilyInstance familyInst)
{
    // get AnalyticalModel from structural column
    if (familyInst.StructuralType == StructuralType.Column)
    {
        AnalyticalModel modelColumn = familyInst.GetAnalyticalModel();
        // column should be represented by a single curve
        if (modelColumn.IsSingleCurve() == true)
        {
            Curve columnCurve = modelColumn.GetCurve();
        }
    }
}
CopyVB.NET
Public Sub GetColumnCurve(ByVal familyInst As Autodesk.Revit.DB.FamilyInstance)
    ' get AnalyticalModel from structural column
    If familyInst.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Column Then
        Dim modelColumn As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
        ' column should be represented by a single curve
        If modelColumn.IsSingleCurve() = True Then
            Dim columnCurve As Curve = modelColumn.GetCurve()
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel contains more than one single curve.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetCurves Method

[image]

Revit 2011 API
AnalyticalModel..::.GetCurves Method
AnalyticalModel Class See Also Send Feedback
Retrieves all curves for the Analytical Model of a given type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<Curve> GetCurves(
    AnalyticalCurveType curveType
)
Visual Basic (Declaration)
Public Function GetCurves ( _
    curveType As AnalyticalCurveType _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurves(
    AnalyticalCurveType curveType
)

Parameters

curveType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveType
Which curve type should be returned.

Return Value

An array of curves representing analytical model.

Remarks

If the analytical model contains no curves of the given type, then the returned array may be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetElementId Method

[image]

Revit 2011 API
AnalyticalModel..::.GetElementId Method
AnalyticalModel Class See Also Send Feedback
Retrieves Element Id of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetElementId()
Visual Basic (Declaration)
Public Function GetElementId As ElementId
Visual C++
public:
ElementId^ GetElementId()

Return Value

Element Id for Analytical Model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetManualAdjustmentMatchedElements Method

[image]

Revit 2011 API
AnalyticalModel..::.GetManualAdjustmentMatchedElements Method
AnalyticalModel Class See Also Send Feedback
Retrieves other Element Ids against which the Analytical Model has been adjusted.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetManualAdjustmentMatchedElements()
Visual Basic (Declaration)
Public Function GetManualAdjustmentMatchedElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetManualAdjustmentMatchedElements()

Return Value

Set of Element Ids, representing those Elements against which the Analytical Model has been adjusted. The set may be empty if Analytical Model is not participating in locked Manual Analytical Adjustment.

Remarks

This is only meaningful for locked Manual Analytical Adjustment. When operating unlocked, the Analytical Model is offset by a certain amount, not against a given Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetPoint Method

[image]

Revit 2011 API
AnalyticalModel..::.GetPoint Method
AnalyticalModel Class Example See Also Send Feedback
Retrieves point of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ GetPoint()
Visual Basic (Declaration)
Public Function GetPoint As XYZ
Visual C++
public:
XYZ^ GetPoint()

Return Value

Point of the Analytical Model.

Examples

CopyC#
// retrieve and iterate current selected element
UIDocument uidoc = commandData.Application.ActiveUIDocument;
ElementSet selection = uidoc.Selection.Elements;
foreach (Element e in selection)
{
    // if the element is structural footing
    FamilyInstance familyInst = e as FamilyInstance;
    if (null != familyInst && familyInst.StructuralType == StructuralType.Footing)
    {
        AnalyticalModel model = familyInst.GetAnalyticalModel();
        // structural footing should be expressable as a single point
        if (model.IsSinglePoint() == true)
        {
            XYZ analyticalLocationPoint = model.GetPoint();
        }
    }
}
CopyVB.NET
' retrieve and iterate current selected element
Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
Dim selection As ElementSet = uidoc.Selection.Elements
For Each e As Autodesk.Revit.DB.Element In selection
    ' if the element is structural footing
    Dim familyInst As Autodesk.Revit.DB.FamilyInstance = TryCast(e, Autodesk.Revit.DB.FamilyInstance)
    If familyInst IsNot Nothing AndAlso familyInst.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Footing Then
        Dim model As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
        ' structural footing should be expressable as a single point
        If model.IsSinglePoint() = True Then
            Dim analyticalLocationPoint As Autodesk.Revit.DB.XYZ = model.GetPoint()
        End If
    End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel cannot be expressed as a single point.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetReference Method

[image]

Revit 2011 API
AnalyticalModel..::.GetReference Method
AnalyticalModel Class See Also Send Feedback
Returns a reference to a given curve within the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Reference GetReference(
    AnalyticalModelSelector selector
)
Visual Basic (Declaration)
Public Function GetReference ( _
    selector As AnalyticalModelSelector _
) As Reference
Visual C++
public:
Reference^ GetReference(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalModelSelector
Specifies where in the analytical model the reference lies.

Return Value

Requested reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | selector is not valid for this AnalyticalModel.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetRigidLink Method

[image]

Revit 2011 API
AnalyticalModel..::.GetRigidLink Method
AnalyticalModel Class See Also Send Feedback
Returns rigid link curve corresponding to selector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Curve GetRigidLink(
    AnalyticalModelSelector selector
)
Visual Basic (Declaration)
Public Function GetRigidLink ( _
    selector As AnalyticalModelSelector _
) As Curve
Visual C++
public:
Curve^ GetRigidLink(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalModelSelector
Identifies from which end of the analytical model to get the Rigid Link.

Return Value

Rigid link satisfying selector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | selector is not valid for this AnalyticalModel. -or- Thrown if selector identifies a whole curve instead of just an endpoint. This is because this only returns one curve, and an entire analytical curve may have any number of rigid links.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetSweptProfile Method

[image]

Revit 2011 API
AnalyticalModel..::.GetSweptProfile Method
AnalyticalModel Class See Also Send Feedback
Retrieves the swept profile information for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSweptProfile GetSweptProfile()
Visual Basic (Declaration)
Public Function GetSweptProfile As AnalyticalModelSweptProfile
Visual C++
public:
AnalyticalModelSweptProfile^ GetSweptProfile()

Return Value

The swept profile information for the Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel does not support a swept profile representation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasRigidLinksWith Method

[image]

Revit 2011 API
AnalyticalModel..::.HasRigidLinksWith Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model has Rigid Links with specified element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasRigidLinksWith(
    ElementId neighborId
)
Visual Basic (Declaration)
Public Function HasRigidLinksWith ( _
    neighborId As ElementId _
) As Boolean
Visual C++
public:
bool HasRigidLinksWith(
    ElementId^ neighborId
)

Parameters

neighborId
Type: Autodesk.Revit.DB..::.ElementId
neighboring Element, to which Rigid Links may exist.

Return Value

true if Rigid Links exist, false otherwise.

Remarks

This is bidirectional, so this can be used to see if Rigid Links exist from Column to Beam.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasSweptProfile Method

[image]

Revit 2011 API
AnalyticalModel..::.HasSweptProfile Method
AnalyticalModel Class See Also Send Feedback
Indicates if this Element's Analytical Model can be represented as a swept profile.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool HasSweptProfile()
Visual Basic (Declaration)
Public Function HasSweptProfile As Boolean
Visual C++
public:
bool HasSweptProfile()

Return Value

True if the Analytical Model can be represented as a swept profile, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsAnalyzeAsValid Method

[image]

Revit 2011 API
AnalyticalModel..::.IsAnalyzeAsValid Method
AnalyticalModel Class See Also Send Feedback
Determines if the given Analyze As parameter is valid for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)
Visual Basic (Declaration)
Public Function IsAnalyzeAsValid ( _
    analyzeAs As AnalyzeAs _
) As Boolean
Visual C++
public:
bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::.AnalyzeAs
Indicates how Analytical Model is analyzed.

Return Value

True if valid; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsApproximated Method

[image]

Revit 2011 API
AnalyticalModel..::.IsApproximated Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model is approximated or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsApproximated()
Visual Basic (Declaration)
Public Function IsApproximated As Boolean
Visual C++
public:
bool IsApproximated()

Return Value

True if the Analytical Model is approximated, false otherwise. False if approximation is meaningless for Analytical Model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsAutoDetectEnabled Method

[image]

Revit 2011 API
AnalyticalModel..::.IsAutoDetectEnabled Method
AnalyticalModel Class See Also Send Feedback
Reports whether or not Analytical Auto-detect for the given direction is enabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsAutoDetectEnabled ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Auto-detect behavior may be enabled.

Return Value

True if enabled in the given direction, false otherwise.

Remarks

Just because Auto-detect is enabled in one direction, that does not mean that it is enabled in a different direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsElementFullySupported Method

[image]

Revit 2011 API
AnalyticalModel..::.IsElementFullySupported Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Analytical Model is fully supported.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsElementFullySupported()
Visual Basic (Declaration)
Public Function IsElementFullySupported As Boolean
Visual C++
public:
bool IsElementFullySupported()

Return Value

True if Analytical Model is fully supported, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsEnabled Method

[image]

Revit 2011 API
AnalyticalModel..::.IsEnabled Method
AnalyticalModel Class See Also Send Feedback
Reports whether the Analytical Model is enabled or disabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsEnabled()
Visual Basic (Declaration)
Public Function IsEnabled As Boolean
Visual C++
public:
bool IsEnabled()

Return Value

True if Analytical Model is enabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsManuallyAdjusted Method

[image]

Revit 2011 API
AnalyticalModel..::.IsManuallyAdjusted Method
AnalyticalModel Class See Also Send Feedback
Indicates whether or not the Analytical Model has been manually adjusted by the user.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsManuallyAdjusted()
Visual Basic (Declaration)
Public Function IsManuallyAdjusted As Boolean
Visual C++
public:
bool IsManuallyAdjusted()

Return Value

True if user has manually adjusted the Analytical Model; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsSingleCurve Method

[image]

Revit 2011 API
AnalyticalModel..::.IsSingleCurve Method
AnalyticalModel Class See Also Send Feedback
This indicates whether the Analytical Model can be expressed as a single curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSingleCurve()
Visual Basic (Declaration)
Public Function IsSingleCurve As Boolean
Visual C++
public:
bool IsSingleCurve()

Return Value

True if Analytical Model can be expressed as a single curve, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsSinglePoint Method

[image]

Revit 2011 API
AnalyticalModel..::.IsSinglePoint Method
AnalyticalModel Class See Also Send Feedback
This indicates whether the Analytical Model can be expressed as a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSinglePoint()
Visual Basic (Declaration)
Public Function IsSinglePoint As Boolean
Visual C++
public:
bool IsSinglePoint()

Return Value

True if Analytical Model can be expressed as a single point, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates whether a given Analytical Projection Type is valid for the given Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Function IsValidAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Identifies Analytical Projection Type for Analytical Model Projection.

Return Value

True if Analytical Projection Type is valid; false otherwise. False if direction does not satisfy isValidDirectionForProjection().

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDatumPlaneForProjection Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidDatumPlaneForProjection Method
AnalyticalModel Class See Also Send Feedback
Indicates whether a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic (Declaration)
Public Function IsValidDatumPlaneForProjection ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction of analytical model projection.
datumPlaneId
Type: Autodesk.Revit.DB..::.ElementId
Datum Plane to which analytical model is projected.

Return Value

True if Datum Plane is valid, false otherwise.

Remarks

Validity of a Datum Plane for analytical projection is not only Element-specific, but also context-specific. For instance, two different Beams may have two different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDirectionForAutoDetect Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidDirectionForAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Tests whether or not the supplied direction is valid for Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidDirectionForAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which Auto-detect behavior may be valid.

Return Value

True if direction is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDirectionForProjection Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidDirectionForProjection Method
AnalyticalModel Class See Also Send Feedback
This indicates whether the input direction is valid for Analytical Model projection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidDirectionForProjection ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which the Analytical Model may be projected.

Return Value

True if AnalyticalDirection is valid for Element, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidForManualAdjustment Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidForManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Indicates if the identified reference is acceptable for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidForManualAdjustment(
    Reference reference
)
Visual Basic (Declaration)
Public Function IsValidForManualAdjustment ( _
    reference As Reference _
) As Boolean
Visual C++
public:
bool IsValidForManualAdjustment(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
Reference that will be examined.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful to determine if a reference is acceptable for Manual Analytical Adjustment in general. This looks briefly at the reference, without looking at the specific context.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidManualAdjustmentSource Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidManualAdjustmentSource Method
AnalyticalModel Class See Also Send Feedback
Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentSource(
    Reference source,
    AnalyticalDirection adjustmentDirection
)
Visual Basic (Declaration)
Public Function IsValidManualAdjustmentSource ( _
    source As Reference, _
    adjustmentDirection As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentSource(
    Reference^ source,
    AnalyticalDirection adjustmentDirection
)

Parameters

source
Type: Autodesk.Revit.DB..::.Reference
Reference to be examined.
adjustmentDirection
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which adjustment will occur.

Return Value

True if reference can be used as source; false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for usage as a "Source". In other words, if the reference identifies an Analytical Model portion that can be adjusted by the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidManualAdjustmentTarget Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidManualAdjustmentTarget Method
AnalyticalModel Class See Also Send Feedback
Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentTarget(
    Reference target,
    Reference source,
    AnalyticalDirection direction
)
Visual Basic (Declaration)
Public Function IsValidManualAdjustmentTarget ( _
    target As Reference, _
    source As Reference, _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentTarget(
    Reference^ target,
    Reference^ source,
    AnalyticalDirection direction
)

Parameters

target
Type: Autodesk.Revit.DB..::.Reference
Identifies target reference.
source
Type: Autodesk.Revit.DB..::.Reference
Identifies source reference. This is necessary to avoid illegal conditions. For instance if Element A is manually adjusted against Element B, Element B cannot in general be adjusted against Element A.
direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which source Element can be adjusted against target Element.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for a target. In other words, if the reference identifies an Analytical Model portion that can be adjusted against.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidRigidLinksOption Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidRigidLinksOption Method
AnalyticalModel Class See Also Send Feedback
Indicates whether Rigid Links option is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)
Visual Basic (Declaration)
Public Function IsValidRigidLinksOption ( _
    rigidLinksOption As AnalyticalRigidLinksOption _
) As Boolean
Visual C++
public:
bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)

Parameters

rigidLinksOption
Type: Autodesk.Revit.DB.Structure..::.AnalyticalRigidLinksOption
Rigid Links option to validate.

Return Value

True if option is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidSelector Method

[image]

Revit 2011 API
AnalyticalModel..::.IsValidSelector Method
AnalyticalModel Class See Also Send Feedback
This indicates whether the input selector is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidSelector(
    AnalyticalModelSelector selector
)
Visual Basic (Declaration)
Public Function IsValidSelector ( _
    selector As AnalyticalModelSelector _
) As Boolean
Visual C++
public:
bool IsValidSelector(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalModelSelector
Identifies a portion of the analytical model geometry.

Return Value

True if selector is valid for this Analytical Model, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


ManuallyAdjust Method

[image]

Revit 2011 API
AnalyticalModel..::.ManuallyAdjust Method
AnalyticalModel Class See Also Send Feedback
Perform Manual Analytical Adjustment on analytical model, with respect to another Element

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ManuallyAdjust(
    Reference source,
    Reference target,
    bool lock
)
Visual Basic (Declaration)
Public Function ManuallyAdjust ( _
    source As Reference, _
    target As Reference, _
    lock As Boolean _
) As Boolean
Visual C++
public:
bool ManuallyAdjust(
    Reference^ source,
    Reference^ target,
    bool lock
)

Parameters

source
Type: Autodesk.Revit.DB..::.Reference
Which part of Analytical Model needs to change.
target
Type: Autodesk.Revit.DB..::.Reference
Which part of another Analytical Model change should be made against.
lock
Type: System..::.Boolean
Whether adjustment should be locked or unlocked.

Return Value

Indicates the successful completion of the Manual Analytical Adjustment operation. True if source Element was adjusted successfully, false otherwise.

Remarks

If the Manual Analytical Adjustment is locked, then the Source Analytical Model will update itself whenever the Target Analytical Model changes.If the Manual Analytical Adjustment is not locked, then the Source Analytical Model will remain at a given offset, not following the target. Success, in this context, is achieved when the Source adjusts itself against the Target. Additionally, this requires an open transaction on the current document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown if source cannot be used as source reference, or if target cannot be used as target reference.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


ResetManualAdjustment Method

[image]

Revit 2011 API
AnalyticalModel..::.ResetManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Resets all manual adjustments performed by the user onto the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ResetManualAdjustment()
Visual Basic (Declaration)
Public Function ResetManualAdjustment As Boolean
Visual C++
public:
bool ResetManualAdjustment()

Return Value

Indicates the successful reset of all manual adjustment. True if reset succeeds, false otherwise.

Remarks

This resets all manual adjustment. Therefore, if Analytical Offset is applicable, that will reset as well. Success, in this context, is achieved only when the Source resets itself to its original position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalOffset Method

[image]

Revit 2011 API
AnalyticalModel..::.SetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Sets Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalOffset(
    XYZ offset
)
Visual Basic (Declaration)
Public Sub SetAnalyticalOffset ( _
    offset As XYZ _
)
Visual C++
public:
void SetAnalyticalOffset(
    XYZ^ offset
)

Parameters

offset
Type: Autodesk.Revit.DB..::.XYZ
Offset for the entire Analytical Model.

Remarks

This is different than Manual Analytical Adjustment, in that it is a basic offset that applies to the entire Analytical Model at once. Additionally, it is set in a different manner than Manual Analytical Adjustment, since it does not depend on another Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This AnalyticalModel does not support offset.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method

[image]

Revit 2011 API
AnalyticalModel..::.SetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Sets analytical model projection to a Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::.ElementId
Datum Plane to which analytical model may be projected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModel..::.SetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::.AnalyticalDirection
Direction to project Analytical Model.
projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Preset value for Analytical Model projection.

Remarks

This should be used if setting the analytical model projection to something other than a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the direction

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyzeAs Method

[image]

Revit 2011 API
AnalyticalModel..::.SetAnalyzeAs Method
AnalyticalModel Class See Also Send Feedback
Sets value of Analyze As parameter for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)
Visual Basic (Declaration)
Public Sub SetAnalyzeAs ( _
    analyzeAs As AnalyzeAs _
)
Visual C++
public:
void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::.AnalyzeAs
Indicates how Analytical Model is analyzed .

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | analyzeAs is invalid for analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetApproximationDeviation Method

[image]

Revit 2011 API
AnalyticalModel..::.SetApproximationDeviation Method
AnalyticalModel Class See Also Send Feedback
Adjusts the amount by which approximation is made.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetApproximationDeviation(
    double deviation
)
Visual Basic (Declaration)
Public Sub SetApproximationDeviation ( _
    deviation As Double _
)
Visual C++
public:
void SetApproximationDeviation(
    double deviation
)

Parameters

deviation
Type: System..::.Double
Maximum distance from line to actual curve

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel does not support approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetUsesHardPoints Method

[image]

Revit 2011 API
AnalyticalModel..::.SetUsesHardPoints Method
AnalyticalModel Class See Also Send Feedback
Sets Hard Points for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUsesHardPoints(
    bool hardPoints
)
Visual Basic (Declaration)
Public Sub SetUsesHardPoints ( _
    hardPoints As Boolean _
)
Visual C++
public:
void SetUsesHardPoints(
    bool hardPoints
)

Parameters

hardPoints
Type: System..::.Boolean
Enable/disable Hard Points (true = enable).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | This AnalyticalModel cannot use Hard Points.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SupportsManualAdjustment Method

[image]

Revit 2011 API
AnalyticalModel..::.SupportsManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Element supports Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool SupportsManualAdjustment()
Visual Basic (Declaration)
Public Function SupportsManualAdjustment As Boolean
Visual C++
public:
bool SupportsManualAdjustment()

Return Value

True if Manual Adjustment is possible, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


UsesHardPoints Method

[image]

Revit 2011 API
AnalyticalModel..::.UsesHardPoints Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Analytical Model is using Hard Points during approximation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool UsesHardPoints()
Visual Basic (Declaration)
Public Function UsesHardPoints As Boolean
Visual C++
public:
bool UsesHardPoints()

Return Value

True if Hard Points are being used, false otherwise. False if Hard Points are meaningless for Analytical Model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Properties

[image] [image]

Revit 2011 API
AnalyticalModel Properties
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Properties

Name | Description
RigidLinksOption | Indicates whether parameters indicate if Rigid Links should be formed.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


RigidLinksOption Property

[image]

Revit 2011 API
AnalyticalModel..::.RigidLinksOption Property
AnalyticalModel Class See Also Send Feedback
Indicates whether parameters indicate if Rigid Links should be formed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalRigidLinksOption RigidLinksOption { get; set; }
Visual Basic (Declaration)
Public Property RigidLinksOption As AnalyticalRigidLinksOption
Visual C++
public:
property AnalyticalRigidLinksOption RigidLinksOption {
    AnalyticalRigidLinksOption get ();
    void set (AnalyticalRigidLinksOption value);
}

Field Value

For Structural Beams:
  • Enabled: rigid links will be formed, overriding Structural Column setting.
  • Disabled: rigid links will not be formed, overriding Structural Column setting.
  • FromColumn: rigid links may be formed, depending on Structural Column setting.
For Structural Columns:
  • Enabled: rigid links will be formed, unless Structural Beam setting overrides.
  • Disabled: rigid links will not be formed, unless Structural Beam setting overrides.
If rigid links are not applicable to this Analytical Model, this will return Disabled.

Remarks

Rigid Links are the result of an interaction between neighboring Structural Columns and Structural Beams

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: rigidLinksOption is not valid for this Analytical Model.
Autodesk.Revit.Exceptions..::.InvalidOperationException | When setting this property: This AnalyticalModel does not support Rigid Links.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Class

[image]

Revit 2011 API
AnalyticalModelSelector Class
Members Example See Also Send Feedback
Defines a portion of an Analytical Model for an Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSelector : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModelSelector _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSelector : IDisposable

Remarks

This is used to identify the portion of an analytical model of interest to a client. To identify the portion of the analytical model, the client must identify the curve in question, by using one of the following:
  • The specific curve within the analytical model.
  • The index of the curve within the analytical model.
If a specific part of that curve is of interest, the client needs to identify that by specifying one of the following:
  • The start of the curve.
  • The end of the curve.
  • The entire curve. This is the default behavior, so this does not need specifying.

Examples

CopyC#
public bool GetReferenceData(FamilyInstance familyInst)
{
    AnalyticalModel analyticalModelFrame = familyInst.GetAnalyticalModel();
    Curve analyticalCurve = analyticalModelFrame.GetCurve();
    if (null != analyticalCurve)
    {
        // test the stable reference to the curve.
        AnalyticalModelSelector amSelector = new AnalyticalModelSelector(analyticalCurve);
        amSelector.CurveSelector = AnalyticalCurveSelector.WholeCurve;
        Reference curveReference = analyticalModelFrame.GetReference(amSelector);

        // test the stable reference to the start point of the curve
        amSelector.CurveSelector = AnalyticalCurveSelector.StartPoint;
        Reference startPointReference = analyticalModelFrame.GetReference(amSelector);

        // test the stable reference to the start point of the curve
        amSelector.CurveSelector = AnalyticalCurveSelector.EndPoint;
        Reference endPointReference = analyticalModelFrame.GetReference(amSelector);
    }

    return true;
}
CopyVB.NET
Public Function GetReferenceData(ByVal familyInst As Autodesk.Revit.DB.FamilyInstance) As Boolean
    Dim analyticalModelFrame As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
    Dim analyticalCurve As Curve = analyticalModelFrame.GetCurve()
    If analyticalCurve IsNot Nothing Then
        ' test the stable reference to the curve.
        Dim amSelector As New Autodesk.Revit.DB.Structure.AnalyticalModelSelector(analyticalCurve)
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.WholeCurve
        Dim curveReference As Reference = analyticalModelFrame.GetReference(amSelector)

        ' test the stable reference to the start point of the curve
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.StartPoint
        Dim startPointReference As Reference = analyticalModelFrame.GetReference(amSelector)

        ' test the stable reference to the start point of the curve
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.EndPoint
        Dim endPointReference As Reference = analyticalModelFrame.GetReference(amSelector)
    End If

    Return True
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModelSelector

See Also

AnalyticalModelSelector Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Members

[image] [image]

Revit 2011 API
AnalyticalModelSelector Members
AnalyticalModelSelector Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Constructors

Name | Description
AnalyticalModelSelector | Overloaded.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidIndex | Indicates whether index is valid in array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor

[image] [image]

Revit 2011 API
AnalyticalModelSelector Constructor
AnalyticalModelSelector Class See Also Send Feedback

Overload List

Name | Description
AnalyticalModelSelector()()() | Creates a selector for the analytical model geometry.
AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve.
AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry.
AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.
AnalyticalModelSelector(IList<(Of <(Curve>)>), Int32) | Creates a selector based on a specific analytical curve.
AnalyticalModelSelector(IList<(Of <(Curve>)>), Int32, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor

[image]

Revit 2011 API
AnalyticalModelSelector Constructor
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnalyticalModelSelector()

Remarks

This version is useful for single-curve or single-point analytical models. Additionally, this only acts with respect to the entire curve or point.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (Curve)

[image]

Revit 2011 API
AnalyticalModelSelector Constructor (Curve)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve upon which this selector acts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (AnalyticalCurveSelector)

[image]

Revit 2011 API
AnalyticalModelSelector Constructor (AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic (Declaration)
Public Sub New ( _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)

Parameters

inCurveSelector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveSelector
Portion of the analytical curve in which the client has interest.

Remarks

This version is useful for single-curve or single-point analytical models.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)

[image]

Revit 2011 API
AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve,
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic (Declaration)
Public Sub New ( _
    curve As Curve, _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve,
    AnalyticalCurveSelector inCurveSelector
)

Parameters

curve
Type: Autodesk.Revit.DB..::.Curve
The curve upon which this selector acts.
inCurveSelector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (IList(Curve), Int32)

[image]

Revit 2011 API
AnalyticalModelSelector Constructor (IList<(Of <(Curve>)>), Int32)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    IList<Curve> curves,
    int index
)
Visual Basic (Declaration)
Public Sub New ( _
    curves As IList(Of Curve), _
    index As Integer _
)
Visual C++
public:
AnalyticalModelSelector(
    IList<Curve^>^ curves,
    int index
)

Parameters

curves
Type: System.Collections.Generic..::.IList <(Of <( Curve >)>)
The analytical model curves containing the curve of interest.
index
Type: System..::.Int32
Index of the curve of interest (from within the array of curves).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | index is not a valid item within curves.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (IList(Curve), Int32, AnalyticalCurveSelector)

[image]

Revit 2011 API
AnalyticalModelSelector Constructor (IList<(Of <(Curve>)>), Int32, AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    IList<Curve> curves,
    int index,
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic (Declaration)
Public Sub New ( _
    curves As IList(Of Curve), _
    index As Integer, _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    IList<Curve^>^ curves,
    int index,
    AnalyticalCurveSelector inCurveSelector
)

Parameters

curves
Type: System.Collections.Generic..::.IList <(Of <( Curve >)>)
Analytical Model curves, extracted from analytical model.
index
Type: System..::.Int32
Index of the curve of interest (from within the array of curves).
inCurveSelector
Type: Autodesk.Revit.DB.Structure..::.AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | index is not a valid item within curves.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Methods

[image] [image]

Revit 2011 API
AnalyticalModelSelector Methods
AnalyticalModelSelector Class See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidIndex | Indicates whether index is valid in array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalModelSelector..::.Dispose Method
AnalyticalModelSelector Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


IsValidIndex Method

[image]

Revit 2011 API
AnalyticalModelSelector..::.IsValidIndex Method
AnalyticalModelSelector Class See Also Send Feedback
Indicates whether index is valid in array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidIndex(
    IList<Curve> curves,
    int index
)
Visual Basic (Declaration)
Public Function IsValidIndex ( _
    curves As IList(Of Curve), _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsValidIndex(
    IList<Curve^>^ curves,
    int index
)

Parameters

curves
Type: System.Collections.Generic..::.IList <(Of <( Curve >)>)
The analytical model curves.
index
Type: System..::.Int32
The index to check for validity.

Return Value

True if index is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Properties

[image] [image]

Revit 2011 API
AnalyticalModelSelector Properties
AnalyticalModelSelector Class See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Properties

Name | Description
CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


CurveSelector Property

[image]

Revit 2011 API
AnalyticalModelSelector..::.CurveSelector Property
AnalyticalModelSelector Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalCurveSelector CurveSelector { get; set; }
Visual Basic (Declaration)
Public Property CurveSelector As AnalyticalCurveSelector
Visual C++
public:
property AnalyticalCurveSelector CurveSelector {
    AnalyticalCurveSelector get ();
    void set (AnalyticalCurveSelector value);
}

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Class

[image]

Revit 2011 API
AnalyticalModelSketchComponent Class
Members See Also Send Feedback
This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSketchComponent : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModelSketchComponent _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSketchComponent : IDisposable

Remarks

This may or may not be a simple one-to-one mapping to ElementIds. For instance, one Element may be defined by multiple Curve Elements within a Sketch. But another Element may not have that designation, and the individual curves are not defined by any other Elements within a document.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModelSketchComponent

See Also

AnalyticalModelSketchComponent Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Members

[image] [image]

Revit 2011 API
AnalyticalModelSketchComponent Members
AnalyticalModelSketchComponent Class Methods See Also Send Feedback

The AnalyticalModelSketchComponent type exposes the following members.

Methods

Name | Description
Dispose |
EnableAutoDetect | Enables Auto-detect on Sketch Component.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Methods

[image] [image]

Revit 2011 API
AnalyticalModelSketchComponent Methods
AnalyticalModelSketchComponent Class See Also Send Feedback

The AnalyticalModelSketchComponent type exposes the following members.

Methods

Name | Description
Dispose |
EnableAutoDetect | Enables Auto-detect on Sketch Component.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.Dispose Method
AnalyticalModelSketchComponent Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


EnableAutoDetect Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.EnableAutoDetect Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Enables Auto-detect on Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void EnableAutoDetect()
Visual Basic (Declaration)
Public Sub EnableAutoDetect
Visual C++
public:
void EnableAutoDetect()

Remarks

To disable Auto-detect on Sketch Component, another method (SetAnalyticalProjectionType) must be used

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.GetAnalyticalProjectionDatumPlane Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves Datum Plane ElementId for Analytical Projection

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane()
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionDatumPlane As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane()

Return Value

Represents Datum used for Analytical Projection, if Analytical Projection Type indicates that a Datum Plane is to be used. Otherwise, invalidElementId is returned.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.GetAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves Analytical Projection Type preset for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType()
Visual Basic (Declaration)
Public Function GetAnalyticalProjectionType As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType()

Return Value

Indicates whether Analytical Projection is at a preset, or refers to a Datum.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAutoDetectMatchedElements Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.GetAutoDetectMatchedElements Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves ElementIds that Sketch Component is Auto-detecting against.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAutoDetectMatchedElements()
Visual Basic (Declaration)
Public Function GetAutoDetectMatchedElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAutoDetectMatchedElements()

Return Value

Set of ElementIds that Sketch Component is auto-detecting against.

Remarks

An empty set indicates that the Sketch Component is just not Auto-detecting against anything.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetComponentElementId Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.GetComponentElementId Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves ElementId of Sketch Component, if such an operation makes sense.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetComponentElementId()
Visual Basic (Declaration)
Public Function GetComponentElementId As ElementId
Visual C++
public:
ElementId^ GetComponentElementId()

Return Value

ElementId of Sketch Component. If the operation does not make sense (perhaps because the Sketch abstraction does not translate one-to-one to ElementIds), then this will return invalidElementId.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsAutoDetectEnabled Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.IsAutoDetectEnabled Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Auto-detect is enabled on the given Sketch component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsAutoDetectEnabled()
Visual Basic (Declaration)
Public Function IsAutoDetectEnabled As Boolean
Visual C++
public:
bool IsAutoDetectEnabled()

Return Value

True if Auto-detect is enabled, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.IsValidAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Analytical Projection Type is valid for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Function IsValidAnalyticalProjectionType ( _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Analytical Projection Type preset to test for validity.

Return Value

True is projection type is valid, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsValidDatumPlaneForProjection Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.IsValidDatumPlaneForProjection Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDatumPlaneForProjection(
    ElementId datumPlaneId
)
Visual Basic (Declaration)
Public Function IsValidDatumPlaneForProjection ( _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDatumPlaneForProjection(
    ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB..::.ElementId
ElementId identifying Datum Plane.

Return Value

True if Datum Plane is valid; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.SetAnalyticalProjectionDatumPlane Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Analytical Projection to supplied Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    ElementId datumPlaneId
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionDatumPlane ( _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB..::.ElementId
Identifies Datum Plane ElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | datumPlaneId is not valid for this Sketch Component.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method

[image]

Revit 2011 API
AnalyticalModelSketchComponent..::.SetAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Analytical Projection to the supplied Analytical Projection Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)
Visual Basic (Declaration)
Public Sub SetAnalyticalProjectionType ( _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::.AnalyticalProjectionType
Analytical Projection Type to which the Analytical Model should project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | projectionType is not valid for this Sketch component.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Class

[image]

Revit 2011 API
AnalyticalModelSupport Class
Members See Also Send Feedback
Represents one support for an Element, in the realm of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSupport : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModelSupport _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSupport : IDisposable

Remarks

Analytical Support has been defined as if and how an Element is supported, by looking at the Analytical Models of Elements. There are different priorities of support, and different types of support. Additionally, even though an Element has supports, it may not be fully supported.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModelSupport

See Also

AnalyticalModelSupport Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Members

[image] [image]

Revit 2011 API
AnalyticalModelSupport Members
AnalyticalModelSupport Class Methods See Also Send Feedback

The AnalyticalModelSupport type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurve | Retrieves the curve providing support.
GetFace | Retrieves surface providing support,
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPoint | Retrieves the point providing support.
GetPriority | Retrieves the priority of the support provided.
GetSupportingElement | Retrieves the actual Element Id providing support.
GetSupportType | Gets the type of support provided.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Methods

[image] [image]

Revit 2011 API
AnalyticalModelSupport Methods
AnalyticalModelSupport Class See Also Send Feedback

The AnalyticalModelSupport type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCurve | Retrieves the curve providing support.
GetFace | Retrieves surface providing support,
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPoint | Retrieves the point providing support.
GetPriority | Retrieves the priority of the support provided.
GetSupportingElement | Retrieves the actual Element Id providing support.
GetSupportType | Gets the type of support provided.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.Dispose Method
AnalyticalModelSupport Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetCurve Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetCurve Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the curve providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Curve GetCurve()
Visual Basic (Declaration)
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

Represents the curve providing support, if the Support Type is Curve Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when the Support Type is not Curve Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetFace Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetFace Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves surface providing support,

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Face GetFace()
Visual Basic (Declaration)
Public Function GetFace As Face
Visual C++
public:
Face^ GetFace()

Return Value

Surface representing the surface providing support, if the Support Type is Surface Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when the Support Type is not Surface Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetPoint Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetPoint Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the point providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public XYZ GetPoint()
Visual Basic (Declaration)
Public Function GetPoint As XYZ
Visual C++
public:
XYZ^ GetPoint()

Return Value

Represents the point providing support, if the Support Type is Point Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | Thrown when the Support Type is not Point Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetPriority Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetPriority Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the priority of the support provided.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalSupportPriority GetPriority()
Visual Basic (Declaration)
Public Function GetPriority As AnalyticalSupportPriority
Visual C++
public:
AnalyticalSupportPriority GetPriority()

Return Value

Indicates the support priority, as determined by Analytical Support Checking

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetSupportingElement Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetSupportingElement Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the actual Element Id providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetSupportingElement()
Visual Basic (Declaration)
Public Function GetSupportingElement As ElementId
Visual C++
public:
ElementId^ GetSupportingElement()

Return Value

Represents Element that provides support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetSupportType Method

[image]

Revit 2011 API
AnalyticalModelSupport..::.GetSupportType Method
AnalyticalModelSupport Class See Also Send Feedback
Gets the type of support provided.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AnalyticalSupportType GetSupportType()
Visual Basic (Declaration)
Public Function GetSupportType As AnalyticalSupportType
Visual C++
public:
AnalyticalSupportType GetSupportType()

Return Value

Indicates type of support provided.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Class

[image]

Revit 2011 API
AnalyticalModelSweptProfile Class
Members See Also Send Feedback
Represents an extruded profile swept along a driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSweptProfile : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalModelSweptProfile _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSweptProfile : IDisposable

Remarks

Elements such as beams may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the Element.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalModelSweptProfile

See Also

AnalyticalModelSweptProfile Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Members

[image] [image]

Revit 2011 API
AnalyticalModelSweptProfile Members
AnalyticalModelSweptProfile Class Methods Properties See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Methods

[image] [image]

Revit 2011 API
AnalyticalModelSweptProfile Methods
AnalyticalModelSweptProfile Class See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalModelSweptProfile..::.Dispose Method
AnalyticalModelSweptProfile Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


GetDrivingCurve Method

[image]

Revit 2011 API
AnalyticalModelSweptProfile..::.GetDrivingCurve Method
AnalyticalModelSweptProfile Class See Also Send Feedback
Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Curve GetDrivingCurve()
Visual Basic (Declaration)
Public Function GetDrivingCurve As Curve
Visual C++
public:
Curve^ GetDrivingCurve()

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the actual sweep is from the ends of the curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


GetSweptProfile Method

[image]

Revit 2011 API
AnalyticalModelSweptProfile..::.GetSweptProfile Method
AnalyticalModelSweptProfile Class See Also Send Feedback
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Profile GetSweptProfile()
Visual Basic (Declaration)
Public Function GetSweptProfile As Profile
Visual C++
public:
Profile^ GetSweptProfile()

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Properties

[image] [image]

Revit 2011 API
AnalyticalModelSweptProfile Properties
AnalyticalModelSweptProfile Class See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Properties

Name | Description
EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


EndSetBack Property

[image]

Revit 2011 API
AnalyticalModelSweptProfile..::.EndSetBack Property
AnalyticalModelSweptProfile Class See Also Send Feedback
The distance from the end of the driving curve to the point where the sweep actually ends.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double EndSetBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndSetBack As Double
Visual C++
public:
property double EndSetBack {
    double get ();
}

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


StartSetBack Property

[image]

Revit 2011 API
AnalyticalModelSweptProfile..::.StartSetBack Property
AnalyticalModelSweptProfile Class See Also Send Feedback
The distance from the start of the driving curve to the point where the sweep actually begins.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double StartSetBack { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartSetBack As Double
Visual C++
public:
property double StartSetBack {
    double get ();
}

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalProjectionType Enumeration

[image]

Revit 2011 API
AnalyticalProjectionType Enumeration
See Also Send Feedback
Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalProjectionType
Visual Basic (Declaration)
Public Enumeration AnalyticalProjectionType
Visual C++
public enum class AnalyticalProjectionType

Members

Member name | Description
Top | Vertically, on top of physical model.
Center | Vertically, center of physical model.
Bottom | Vertically, bottom of physical model.
SideOne | Horizontally, corresponds to first side (e.g., interior).
SideTwo | Horizontally, corresponds to second side (e.g., exterior).
AutoDetect | Auto-detect projections for analytical model.
Invalid | Set to a bad setting. Should only be set at this very rarely (i.e., at initial creation).
SketchCurve | For sketch-based analytical models.
DatumPlane | Use a Datum Plane for projection (e.g., Grid, Level).
NotApplicable | None of the other projection types apply.
Default | Element-specific default value.
CenterOfCore | Center of wall core.
LocationLine | Location Line.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalRigidLinksOption Enumeration

[image]

Revit 2011 API
AnalyticalRigidLinksOption Enumeration
See Also Send Feedback
Specifies how Rigid Links will be made for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalRigidLinksOption
Visual Basic (Declaration)
Public Enumeration AnalyticalRigidLinksOption
Visual C++
public enum class AnalyticalRigidLinksOption

Members

Member name | Description
Enabled | For a structural column, enables rigid link formation, unless the neighboring structural beam overrides the setting. For a structural beam, enables rigid link formation, overriding the neighboring structural column's setting.
Disabled | For a structural column, this disables rigid Link formation, unless the neighboring structural beam overrides the setting. For a structural beam, this disables rigid Link formation, overriding the neighboring structural column's setting.
FromColumn | For a structural beam, this indicates that the structural column setting should be used to determine rigid link formation. This value is not applicable to structural columns.

Remarks

Rigid Links are curves connecting neighboring Structural Beams and Structural Columns.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Class

[image]

Revit 2011 API
AnalyticalSupportChecking Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AnalyticalSupportChecking : IDisposable
Visual Basic (Declaration)
Public Class AnalyticalSupportChecking _
    Implements IDisposable
Visual C++
public ref class AnalyticalSupportChecking : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.AnalyticalSupportChecking

See Also

AnalyticalSupportChecking Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Members

[image] [image]

Revit 2011 API
AnalyticalSupportChecking Members
AnalyticalSupportChecking Class Methods See Also Send Feedback

The AnalyticalSupportChecking type exposes the following members.

Methods

Name | Description
CheckMemberSupports | Check if the document contains unsupported Structural Elements.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Methods

[image] [image]

Revit 2011 API
AnalyticalSupportChecking Methods
AnalyticalSupportChecking Class See Also Send Feedback

The AnalyticalSupportChecking type exposes the following members.

Methods

Name | Description
CheckMemberSupports | Check if the document contains unsupported Structural Elements.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


CheckMemberSupports Method

[image]

Revit 2011 API
AnalyticalSupportChecking..::.CheckMemberSupports Method
AnalyticalSupportChecking Class See Also Send Feedback
Check if the document contains unsupported Structural Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static bool CheckMemberSupports(
    Document document,
    string progressIndicatorText
)
Visual Basic (Declaration)
Public Shared Function CheckMemberSupports ( _
    document As Document, _
    progressIndicatorText As String _
) As Boolean
Visual C++
public:
static bool CheckMemberSupports(
    Document^ document,
    String^ progressIndicatorText
)

Parameters

document
Type: Autodesk.Revit.DB..::.Document
Document in which to perform Analytical Support Check.
progressIndicatorText
Type: System..::.String
Text to display on progress indicator.

Return Value

True if the support check succeeded, false otherwise.

Remarks

Existence of unsupported Elements will not affect the return value. Reporting of unsupported Structural Elements will be done via Warnings. This should be run from within a transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
AnalyticalSupportChecking..::.Dispose Method
AnalyticalSupportChecking Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportPriority Enumeration

[image]

Revit 2011 API
AnalyticalSupportPriority Enumeration
See Also Send Feedback
Defines how "highly" another Element is giving support for one Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalSupportPriority
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportPriority
Visual C++
public enum class AnalyticalSupportPriority

Members

Member name | Description
UnknownPriority | Priority has not been determined.
HighestPriority |
SecondHighestPriority |
ThirdHighestPriority |
FourthHigestPriority |

Remarks

For instance, a Column may be a higher priority for a Beam than another Beam. This is useful to find the best supports for a given Element.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportType Enumeration

[image]

Revit 2011 API
AnalyticalSupportType Enumeration
See Also Send Feedback
Indicates what kind of support another Element provides -- Point, Surface, or Curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyticalSupportType
Visual Basic (Declaration)
Public Enumeration AnalyticalSupportType
Visual C++
public enum class AnalyticalSupportType

Members

Member name | Description
UnknownSupport | Support has not been determined.
PointSupport | Support at just one point.
CurveSupport | Support along a curve.
SurfaceSupport | Support along a surface.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyzeAs Enumeration

[image]

Revit 2011 API
AnalyzeAs Enumeration
See Also Send Feedback
Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AnalyzeAs
Visual Basic (Declaration)
Public Enumeration AnalyzeAs
Visual C++
public enum class AnalyzeAs

Members

Member name | Description
Hanger | A hanging Element.
Gravity | Interpreted as Gravity (support going down).
Lateral | Interpreted as Lateral (support going across).
Slab | Floor interpreted as Slab.
Mat | Floor interpreted as Mat Foundation, or general foundation.
SlabOnGrade | Floor interpreted as Slab on a Grade.
NotForAnalysis | Element is not for Analysis.
NotApplicable | Analyze As is not applicable.

See Also

Autodesk.Revit.DB.Structure Namespace


AreaLoad Class

[image]

Revit 2011 API
AreaLoad Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaLoad : LoadBase
Visual Basic (Declaration)
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
public ref class AreaLoad : public LoadBase

Examples

CopyC#
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.Force1.X + ", "
        + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.Force2.X + ", "
        + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.Force3.X + ", "
        + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")";

    // Get loop number
    message += "\nLoop number is :" + areaLoad.NumLoops;
    for (int i = 0; i < areaLoad.NumLoops; i++)
    {
        // Get curve number
        message += "\nCurve number is : " + areaLoad.get_NumCurves(i);
        for (int j = 0; j < areaLoad.get_NumCurves(i); j++)
        {
            Autodesk.Revit.DB.Curve curve = areaLoad.get_Curve(i, j);
            // Get curve start point
            message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
                + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
        }
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.get_RefPoint(k).X + ", "
            + areaLoad.get_RefPoint(k).Y + ", " + areaLoad.get_RefPoint(k).Z + ")";
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaLoad(ByVal areaLoad As Autodesk.Revit.DB.Structure.AreaLoad)
    Dim message As String = "AreaLoad Force : "
    ' Get areaload force1 position
    message += vbLf & "AreaLoad Force1 position :(" + areaLoad.Force1.X + ", " + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")"
    ' Get areaload force2 position
    message += vbLf & "AreaLoad Force2 position :(" + areaLoad.Force2.X + ", " + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")"
    ' Get areaload force3 position
    message += vbLf & "AreaLoad Force3 position :(" + areaLoad.Force3.X + ", " + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")"

    ' Get loop number
    message += vbLf & "Loop number is :" + areaLoad.NumLoops
    Dim i As Integer = 0
    While i < areaLoad.NumLoops
        ' Get curve number
        message += vbLf & "Curve number is : " + areaLoad.NumCurves(i)
        Dim j As Integer = 0
        While j < areaLoad.NumCurves(i)
            Dim curve As Autodesk.Revit.DB.Curve = areaLoad.Curve(i, j)
            ' Get curve start point
            message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
        End While
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Get ref points information
    Dim k As Integer = 0
    While k < areaLoad.NumRefPoints
        ' Get areaload Ref point
        message += vbLf & "AreaLoad Ref point :(" + areaLoad.RefPoint(k).X + ", " + areaLoad.RefPoint(k).Y + ", " + areaLoad.RefPoint(k).Z + ")"
        System.Math.Max(System.Threading.Interlocked.Increment(k), k - 1)
    End While
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.DB.Structure Namespace


AreaLoad Members

[image] [image]

Revit 2011 API
AreaLoad Members
AreaLoad Class Methods Properties See Also Send Feedback

The AreaLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to one of the points for the area load.
Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves within a geometric loop that defines the area.
NumLoops | Returns the number of geometric curve loops that define the area.
NumRefPoints | Returns the total number of reference points for the area load.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RefPoint | Retrieve the physical location of the reference point.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoad Methods

[image] [image]

Revit 2011 API
AreaLoad Methods
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoad Properties

[image] [image]

Revit 2011 API
AreaLoad Properties
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the geometric curve within a geometric loop that defines the area.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to one of the points for the area load.
Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumCurves | Returns the number of curves within a geometric loop that defines the area.
NumLoops | Returns the number of geometric curve loops that define the area.
NumRefPoints | Returns the total number of reference points for the area load.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RefPoint | Retrieve the physical location of the reference point.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Curve Property

[image]

Revit 2011 API
AreaLoad..::.Curve Property
AreaLoad Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve[
    int loopIndex,
    int curveIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve ( _
    loopIndex As Integer, _
    curveIndex As Integer _
) As Curve
Visual C++
public:
property Curve^ Curve[int loopIndex, int curveIndex] {
    Curve^ get (int loopIndex, int curveIndex);
}

Parameters

loopIndex
Type: System..::.Int32
The index of the geometric loop.
curveIndex
Type: System..::.Int32
The index curve within the loop.

Remarks

The loop index should be between 0 and less than NumLoops. The curve index should be between 0 and less than NumCurves(loopIndex).

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2011 API
AreaLoad..::.Force Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints. The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force1 Property

[image]

Revit 2011 API
AreaLoad..::.Force1 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 1 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force2 Property

[image]

Revit 2011 API
AreaLoad..::.Force2 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 2 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force3 Property

[image]

Revit 2011 API
AreaLoad..::.Force3 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 3 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force3 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force3 As XYZ
Visual C++
public:
property XYZ^ Force3 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumCurves Property

[image]

Revit 2011 API
AreaLoad..::.NumCurves Property
AreaLoad Class See Also Send Feedback
Returns the number of curves within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumCurves[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumCurves ( _
    index As Integer _
) As Integer
Visual C++
public:
property int NumCurves[int index] {
    int get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the geometric loop.

Remarks

The index should be between 0 and less than NumLoops.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumLoops Property

[image]

Revit 2011 API
AreaLoad..::.NumLoops Property
AreaLoad Class See Also Send Feedback
Returns the number of geometric curve loops that define the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumLoops { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumLoops As Integer
Visual C++
public:
property int NumLoops {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumRefPoints Property

[image]

Revit 2011 API
AreaLoad..::.NumRefPoints Property
AreaLoad Class See Also Send Feedback
Returns the total number of reference points for the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumRefPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumRefPoints As Integer
Visual C++
public:
property int NumRefPoints {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
AreaLoad..::.Parameter Property
AreaLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaLoad Class
AreaLoad Members
Autodesk.Revit.DB.Structure Namespace


RefPoint Property

[image]

Revit 2011 API
AreaLoad..::.RefPoint Property
AreaLoad Class See Also Send Feedback
Retrieve the physical location of the reference point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ RefPoint[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property RefPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ RefPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Class

[image]

Revit 2011 API
AreaLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class AreaLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class AreaLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.LoadTypeBase
Autodesk.Revit.DB.Structure..::.AreaLoadType

See Also

AreaLoadType Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Members

[image] [image]

Revit 2011 API
AreaLoadType Members
AreaLoadType Class Methods Properties See Also Send Feedback

The AreaLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Methods

[image] [image]

Revit 2011 API
AreaLoadType Methods
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Properties

[image] [image]

Revit 2011 API
AreaLoadType Properties
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
AreaLoadType..::.Parameter Property
AreaLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaLoadType Class
AreaLoadType Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Class

[image]

Revit 2011 API
AreaLoadTypeSet Class
Members See Also Send Feedback
A set that contains areaload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class AreaLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSet

See Also

AreaLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Members

[image] [image]

Revit 2011 API
AreaLoadTypeSet Members
AreaLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Constructors

Name | Description
AreaLoadTypeSet | Initializes a new instance of the AreaLoadTypeSet class

Methods

Name | Description
Clear | Removes every areaload type from the set, rendering it empty.
Contains | Tests for the existence of a areaload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areaload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areaload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Constructor

[image]

Revit 2011 API
AreaLoadTypeSet Constructor
AreaLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSet()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Methods

[image] [image]

Revit 2011 API
AreaLoadTypeSet Methods
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every areaload type from the set, rendering it empty.
Contains | Tests for the existence of a areaload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified areaload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified areaload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.Clear Method
AreaLoadTypeSet Class See Also Send Feedback
Removes every areaload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.Contains Method
AreaLoadTypeSet Class See Also Send Feedback
Tests for the existence of a areaload type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The areaload type to be searched for.

Return Value

The Contains method returns True if the areaload type is within the set, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.Erase Method
AreaLoadTypeSet Class See Also Send Feedback
Removes a specified areaload type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As AreaLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The areaload type to be erased.

Return Value

The number of areaload types that were erased from the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.ForwardIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.GetEnumerator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.Insert Method
AreaLoadTypeSet Class See Also Send Feedback
Insert the specified areaload type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.AreaLoadType
The areaload type to be inserted into the set.

Return Value

Returns whether the areaload type was inserted into the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
AreaLoadTypeSet..::.ReverseIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Properties

[image] [image]

Revit 2011 API
AreaLoadTypeSet Properties
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
AreaLoadTypeSet..::.IsEmpty Property
AreaLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
AreaLoadTypeSet..::.Size Property
AreaLoadTypeSet Class See Also Send Feedback
Returns the number of areaload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Class

[image]

Revit 2011 API
AreaLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areaload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class AreaLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AreaLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.AreaLoadTypeSetIterator

See Also

AreaLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Members

[image] [image]

Revit 2011 API
AreaLoadTypeSetIterator Members
AreaLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
AreaLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Constructor

[image]

Revit 2011 API
AreaLoadTypeSetIterator Constructor
AreaLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Methods

[image] [image]

Revit 2011 API
AreaLoadTypeSetIterator Methods
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
AreaLoadTypeSetIterator..::.MoveNext Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
AreaLoadTypeSetIterator..::.Reset Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Properties

[image] [image]

Revit 2011 API
AreaLoadTypeSetIterator Properties
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
AreaLoadTypeSetIterator..::.Current Property
AreaLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Class

[image]

Revit 2011 API
AreaReinforcement Class
Members Example See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaReinforcement : Element
Visual Basic (Declaration)
Public Class AreaReinforcement _
    Inherits Element
Visual C++
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    message += "\nNumber of distinct bar shapes : " + areaReinforcement.NumBarDescriptions;

    for (int i = 0; i < areaReinforcement.NumBarDescriptions; i++)
    {
        message += "\nBar Description " + i;
        message += "\n\tBar count : " +
                          areaReinforcement.get_BarDescription(i).Count;
        message += "\n\tBar type name : " +
                          areaReinforcement.get_BarDescription(i).BarType.Name;
        message += "\n\tBar layer index : " +
                          areaReinforcement.get_BarDescription(i).Layer;
        message += "\n\tBar length : " +
                          areaReinforcement.get_BarDescription(i).Length;
    }

    // Show the AreaReinforcement Curves information
    message += "\nArea Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves.";

    foreach (Autodesk.Revit.DB.Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve reinCurve = ii as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
        XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcement(ByVal areaReinforcement As Autodesk.Revit.DB.Structure.AreaReinforcement)
    Dim message As String = "AreaReinforcement : "

    ' Show the AreaReinforcement Type information
    'message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    ' Show the AreaReinforcement bar information
    message += vbLf & "Number of distinct bar shapes : " + areaReinforcement.NumBarDescriptions

    Dim i As Integer = 0
    While i < areaReinforcement.NumBarDescriptions
        message += vbLf & "Bar Description " + i
        message += vbLf & vbTab & "Bar count : " + areaReinforcement.BarDescription(i).Count
        message += vbLf & vbTab & "Bar type name : " + areaReinforcement.BarDescription(i).BarType.Name
        message += vbLf & vbTab & "Bar layer index : " + areaReinforcement.BarDescription(i).Layer
        message += vbLf & vbTab & "Bar length : " + areaReinforcement.BarDescription(i).Length
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Show the AreaReinforcement Curves information
    message += vbLf & "Area Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves."

    For Each ii As Autodesk.Revit.DB.Element In areaReinforcement.Curves
        Dim reinCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If reinCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = reinCurve.Curve
        ' get the location curve
        Dim start As Autodesk.Revit.DB.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.DB.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += vbLf & "Curve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")"
        message += vbLf & "       End point (" + [end].X + ", " + [end].Y + ", " + [end].Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Members

[image] [image]

Revit 2011 API
AreaReinforcement Members
AreaReinforcement Class Methods Properties See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaReinforcementType | Retrieves the type of the Area Reinforcement.
BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Methods

[image] [image]

Revit 2011 API
AreaReinforcement Methods
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Properties

[image] [image]

Revit 2011 API
AreaReinforcement Properties
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Properties

Name | Description
AreaReinforcementType | Retrieves the type of the Area Reinforcement.
BarDescription | Retrieves the Bar Table property of an Area Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Area Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Property

[image]

Revit 2011 API
AreaReinforcement..::.AreaReinforcementType Property
AreaReinforcement Class See Also Send Feedback
Retrieves the type of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AreaReinforcementType AreaReinforcementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaReinforcementType As AreaReinforcementType
Visual C++
public:
property AreaReinforcementType^ AreaReinforcementType {
    AreaReinforcementType^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Property

[image]

Revit 2011 API
AreaReinforcement..::.BarDescription Property
AreaReinforcement Class See Also Send Feedback
Retrieves the Bar Table property of an Area Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BarDescription BarDescription[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of a Bar Description.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2011 API
AreaReinforcement..::.Curves Property
AreaReinforcement Class See Also Send Feedback
Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2011 API
AreaReinforcement..::.Direction Property
AreaReinforcement Class See Also Send Feedback
Retrieve or change the Major Direction of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic (Declaration)
Public ReadOnly Property Direction As XYZ
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


NumBarDescriptions Property

[image]

Revit 2011 API
AreaReinforcement..::.NumBarDescriptions Property
AreaReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumBarDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
AreaReinforcement..::.Parameter Property
AreaReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcement Class
AreaReinforcement Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Class

[image]

Revit 2011 API
AreaReinforcementCurve Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaReinforcementCurve : CurveElement
Visual Basic (Declaration)
Public Class AreaReinforcementCurve _
    Inherits CurveElement
Visual C++
public ref class AreaReinforcementCurve : public CurveElement

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_AreaReinforcementCurve(AreaReinforcement areaReinforcement)
{
    string message = "Area Reinforcement Curves : ";

    // Get area reinforcement curves by iterating the Curves property
    foreach (Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve areaReinforcementCurve = ii as AreaReinforcementCurve;
        if (null == areaReinforcementCurve)
        {
            continue;
        }
        Autodesk.Revit.DB.Curve curve = areaReinforcementCurve.Curve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                       + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "\nCurve end point:(" + curve.get_EndPoint(1).X + ", "
                       + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcementCurve(ByVal areaReinforcement As Autodesk.Revit.DB.Structure.AreaReinforcement)
    Dim message As String = "Area Reinforcement Curves : "

    ' Get area reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.DB.Element In areaReinforcement.Curves
        Dim areaReinforcementCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If areaReinforcementCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Autodesk.Revit.DB.Curve = areaReinforcementCurve.Curve

        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += vbLf & "Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.CurveElement
Autodesk.Revit.DB.Structure..::.AreaReinforcementCurve

See Also

AreaReinforcementCurve Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Members

[image] [image]

Revit 2011 API
AreaReinforcementCurve Members
AreaReinforcementCurve Class Methods Properties See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Methods

[image] [image]

Revit 2011 API
AreaReinforcementCurve Methods
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Properties

[image] [image]

Revit 2011 API
AreaReinforcementCurve Properties
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
CurveElementType | The curve element type. (Inherited from CurveElement.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LineStyle | The line style of this curve element. (Inherited from CurveElement.)
LineStyles | All available line styles. (Inherited from CurveElement.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


Curve Property

[image]

Revit 2011 API
AreaReinforcementCurve..::.Curve Property
AreaReinforcementCurve Class See Also Send Feedback
Returns the 3D curve forming part of the boundary of an Area Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curve As Curve
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
AreaReinforcementCurve..::.Parameter Property
AreaReinforcementCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
AreaReinforcementCurve Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Class

[image]

Revit 2011 API
AreaReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AreaReinforcementType : ElementType
Visual Basic (Declaration)
Public Class AreaReinforcementType _
    Inherits ElementType
Visual C++
public ref class AreaReinforcementType : public ElementType

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.AreaReinforcementType

See Also

AreaReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Members

[image] [image]

Revit 2011 API
AreaReinforcementType Members
AreaReinforcementType Class Methods Properties See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Methods

[image] [image]

Revit 2011 API
AreaReinforcementType Methods
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Properties

[image] [image]

Revit 2011 API
AreaReinforcementType Properties
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
AreaReinforcementType..::.Parameter Property
AreaReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

AreaReinforcementType Class
AreaReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


BarDescription Class

[image]

Revit 2011 API
BarDescription Class
Members See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class BarDescription : APIObject
Visual Basic (Declaration)
Public Class BarDescription _
    Inherits APIObject
Visual C++
public ref class BarDescription : public APIObject

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.BarDescription

See Also

BarDescription Members
Autodesk.Revit.DB.Structure Namespace


BarDescription Members

[image] [image]

Revit 2011 API
BarDescription Members
BarDescription Class Methods Properties See Also Send Feedback

The BarDescription type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Methods

[image] [image]

Revit 2011 API
BarDescription Methods
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Properties

[image] [image]

Revit 2011 API
BarDescription Properties
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Properties

Name | Description
BarType | Retrieves the Rebar Bar Type property of a Bar Description.
Count | Retrieves the number of bars of this shape.
HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.
HookType | Retrieves the Rebar Hook Type property of a Bar Description.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Layer | Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarType Property

[image]

Revit 2011 API
BarDescription..::.BarType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Bar Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarType BarType { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Count Property

[image]

Revit 2011 API
BarDescription..::.Count Property
BarDescription Class See Also Send Feedback
Retrieves the number of bars of this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


HooksInSameDirection Property

[image]

Revit 2011 API
BarDescription..::.HooksInSameDirection Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hooks In Same Direction property of a Bar Description. If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HooksInSameDirection { get; }
Visual Basic (Declaration)
Public ReadOnly Property HooksInSameDirection As Boolean
Visual C++
public:
property bool HooksInSameDirection {
    bool get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


HookType Property

[image]

Revit 2011 API
BarDescription..::.HookType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookType HookType[
    int end
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::.Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Layer Property

[image]

Revit 2011 API
BarDescription..::.Layer Property
BarDescription Class See Also Send Feedback
Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Layer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layer As Integer
Visual C++
public:
property int Layer {
    int get ();
}

Remarks

For floors, layer 0 is Top Major; layer 1 is Top Minor; layer 2 is Bottom Major; layer 3 is Bottom Minor. For walls, layer 0 is Front Major; layer 1 is Front Minor; layer 2 is Back Major; layer 3 is Back Minor.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Length Property

[image]

Revit 2011 API
BarDescription..::.Length Property
BarDescription Class See Also Send Feedback
Retrieves the length of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionsType Enumeration

[image]

Revit 2011 API
BoundaryConditionsType Enumeration
See Also Send Feedback
This enum declares type of BoundaryConditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum BoundaryConditionsType
Visual Basic (Declaration)
Public Enumeration BoundaryConditionsType
Visual C++
public enum class BoundaryConditionsType

Members

Member name | Description
Nothing | Invalid type
Point | Point Boundary Conditions
Line | Line Boundary Conditions
Area | Area Boundary Conditions

See Also

Autodesk.Revit.DB.Structure Namespace


BracePlanRepresentation Enumeration

[image]

Revit 2011 API
BracePlanRepresentation Enumeration
See Also Send Feedback
The possible representations for braces in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum BracePlanRepresentation
Visual Basic (Declaration)
Public Enumeration BracePlanRepresentation
Visual C++
public enum class BracePlanRepresentation

Members

Member name | Description
ParallelLine | Braces are represented by a parallel line.
LineWithAngle | Braces are represented by a line with angle.

See Also

Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Class

[image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Class
Members Example See Also Send Feedback
A filter used to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class FamilyStructuralMaterialTypeFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class FamilyStructuralMaterialTypeFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class FamilyStructuralMaterialTypeFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use FamilyStructuralMaterialType filter to find families whose material type is Wood
FamilyStructuralMaterialTypeFilter filter = new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> woodFamiles = collector.WherePasses(filter).ToElements();

// Find families are not Wood: Use inverted filter to match families
FamilyStructuralMaterialTypeFilter notWoodFilter =
    new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notWoodFamilies = collector.WherePasses(notWoodFilter).ToElements();
CopyVB.NET
' Use FamilyStructuralMaterialType filter to find families whose material type is Wood
Dim filter As New Autodesk.Revit.DB.Structure.FamilyStructuralMaterialTypeFilter(Autodesk.Revit.DB.Structure.StructuralMaterialType.Wood)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim woodFamiles As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find families are not Wood: Use inverted filter to match families
Dim notWoodFilter As New Autodesk.Revit.DB.Structure.FamilyStructuralMaterialTypeFilter(Autodesk.Revit.DB.Structure.StructuralMaterialType.Wood, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notWoodFamilies As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notWoodFilter).ToElements()

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.FamilyStructuralMaterialTypeFilter

See Also

FamilyStructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Members

[image] [image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Members
FamilyStructuralMaterialTypeFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Constructors

Name | Description
FamilyStructuralMaterialTypeFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralMaterialType | The family structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor

[image] [image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Constructor
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

Name | Description
FamilyStructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match families that have the given structural material type.
FamilyStructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)

[image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)

[image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.
inverted
Type: System..::.Boolean
True if the filter should match all families which are not of the given structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Methods

[image] [image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Methods
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Properties

[image] [image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter Properties
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralMaterialType | The family structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Property

[image]

Revit 2011 API
FamilyStructuralMaterialTypeFilter..::.StructuralMaterialType Property
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
The family structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


LineLoad Class

[image]

Revit 2011 API
LineLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LineLoad : LoadBase
Visual Basic (Declaration)
Public Class LineLoad _
    Inherits LoadBase
Visual C++
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Examples

CopyC#
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.Force1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.Force2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.Moment1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.Moment2));

     //Whether the load is projected or not
     if (lineLoad.ProjectedLoad)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (0 != lineLoad.UniformLoad)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     TaskDialog.Show("Revit",information.ToString());
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
CopyVB.NET
Private Sub LineLoadInformation(ByVal lineLoad As Autodesk.Revit.DB.Structure.LineLoad)
    Dim information As New StringBuilder("Line Load: ")

    ' Get the load case name
    information.Append(vbLf & "Load case for load: " + lineLoad.LoadCaseName)

    'Get the three dimensional force applied to the start point and end point of the line load.
    information.Append(vbLf & "Force at the start of this line load: " + XYZToString(lineLoad.Force1))
    information.Append(vbLf & "Force at the end of this line load: " + XYZToString(lineLoad.Force2))

    'Get the three dimensional location of the start point and end point for the line load.
    information.Append(vbLf & "Start point of this line load: " + XYZToString(lineLoad.StartPoint))
    information.Append(vbLf & "End Point of this line load: " + XYZToString(lineLoad.EndPoint))

    'Get the three dimensional moment applied to the start point and end point of the line load.
    information.Append(vbLf & "Moment at the start of this line load: " + XYZToString(lineLoad.Moment1))
    information.Append(vbLf & "Moment at the end of this line load: " + XYZToString(lineLoad.Moment2))

    'Whether the load is projected or not
    If lineLoad.ProjectedLoad Then
        information.Append(vbLf & "This line load is projected.")
    Else
        information.Append(vbLf & "This line load is not projected")
    End If

    'Report if the load is uniform
    If 0 <> lineLoad.UniformLoad Then
        information.Append(vbLf & "This load is uniform.")
    Else
        information.Append(vbLf & "This load is not uniform.")
    End If

    'show information of lineload in a MessageBox.
    TaskDialog.Show("Revit", information.ToString())
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.LineLoad

See Also

LineLoad Members
Autodesk.Revit.DB.Structure Namespace


LineLoad Members

[image] [image]

Revit 2011 API
LineLoad Members
LineLoad Class Methods Properties See Also Send Feedback

The LineLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndPoint | Returns the three dimensional location of the end point for the line load.
Force | Returns the three dimensional force applied to one of the points for the line load.
Force1 | Returns the three dimensional force applied to the start point of the line load.
Force2 | Returns the three dimensional force applied to the end point of the line load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment applied to one of the points for the line load.
Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional location of one of the points for the line load.
ProjectedLoad | Returns whether the load is projected or not.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StartPoint | Returns the three dimensional location of the start point for the line load.
UniformLoad | Report if the load is uniform.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoad Methods

[image] [image]

Revit 2011 API
LineLoad Methods
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoad Properties

[image] [image]

Revit 2011 API
LineLoad Properties
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
EndPoint | Returns the three dimensional location of the end point for the line load.
Force | Returns the three dimensional force applied to one of the points for the line load.
Force1 | Returns the three dimensional force applied to the start point of the line load.
Force2 | Returns the three dimensional force applied to the end point of the line load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment applied to one of the points for the line load.
Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional location of one of the points for the line load.
ProjectedLoad | Returns whether the load is projected or not.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StartPoint | Returns the three dimensional location of the start point for the line load.
UniformLoad | Report if the load is uniform.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


EndPoint Property

[image]

Revit 2011 API
LineLoad..::.EndPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the end point for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As XYZ
Visual C++
public:
property XYZ^ EndPoint {
    XYZ^ get ();
}

Remarks

The location of the end point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2011 API
LineLoad..::.Force Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force1 Property

[image]

Revit 2011 API
LineLoad..::.Force1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the start point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force1 As XYZ
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force2 Property

[image]

Revit 2011 API
LineLoad..::.Force2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the end point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force2 As XYZ
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment Property

[image]

Revit 2011 API
LineLoad..::.Moment Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Moment[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Moment[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment1 Property

[image]

Revit 2011 API
LineLoad..::.Moment1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the start point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Moment1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment1 As XYZ
Visual C++
public:
property XYZ^ Moment1 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment2 Property

[image]

Revit 2011 API
LineLoad..::.Moment2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the end point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Moment2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment2 As XYZ
Visual C++
public:
property XYZ^ Moment2 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LineLoad..::.Parameter Property
LineLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineLoad Class
LineLoad Members
Autodesk.Revit.DB.Structure Namespace


Point Property

[image]

Revit 2011 API
LineLoad..::.Point Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Point[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The location of the point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


ProjectedLoad Property

[image]

Revit 2011 API
LineLoad..::.ProjectedLoad Property
LineLoad Class See Also Send Feedback
Returns whether the load is projected or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool ProjectedLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectedLoad As Boolean
Visual C++
public:
property bool ProjectedLoad {
    bool get ();
}

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


StartPoint Property

[image]

Revit 2011 API
LineLoad..::.StartPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the start point for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As XYZ
Visual C++
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}

Remarks

The location of the start point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


UniformLoad Property

[image]

Revit 2011 API
LineLoad..::.UniformLoad Property
LineLoad Class See Also Send Feedback
Report if the load is uniform.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int UniformLoad { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniformLoad As Integer
Visual C++
public:
property int UniformLoad {
    int get ();
}

Remarks

This property will return True is the line load is uniform, i.e. the load is that same across the entire line.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Class

[image]

Revit 2011 API
LineLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LineLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class LineLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class LineLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.LoadTypeBase
Autodesk.Revit.DB.Structure..::.LineLoadType

See Also

LineLoadType Members
Autodesk.Revit.DB.Structure Namespace


LineLoadType Members

[image] [image]

Revit 2011 API
LineLoadType Members
LineLoadType Class Methods Properties See Also Send Feedback

The LineLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Methods

[image] [image]

Revit 2011 API
LineLoadType Methods
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Properties

[image] [image]

Revit 2011 API
LineLoadType Properties
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LineLoadType..::.Parameter Property
LineLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LineLoadType Class
LineLoadType Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Class

[image]

Revit 2011 API
LineLoadTypeSet Class
Members See Also Send Feedback
A set that contains lineload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LineLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LineLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LineLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LineLoadTypeSet

See Also

LineLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Members

[image] [image]

Revit 2011 API
LineLoadTypeSet Members
LineLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Constructors

Name | Description
LineLoadTypeSet | Initializes a new instance of the LineLoadTypeSet class

Methods

Name | Description
Clear | Removes every lineload type from the set, rendering it empty.
Contains | Tests for the existence of a lineload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified lineload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified lineload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Constructor

[image]

Revit 2011 API
LineLoadTypeSet Constructor
LineLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the LineLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSet()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Methods

[image] [image]

Revit 2011 API
LineLoadTypeSet Methods
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every lineload type from the set, rendering it empty.
Contains | Tests for the existence of a lineload type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified lineload type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified lineload type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LineLoadTypeSet..::.Clear Method
LineLoadTypeSet Class See Also Send Feedback
Removes every lineload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
LineLoadTypeSet..::.Contains Method
LineLoadTypeSet Class See Also Send Feedback
Tests for the existence of a lineload type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The lineload type to be searched for.

Return Value

The Contains method returns True if the lineload type is within the set, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
LineLoadTypeSet..::.Erase Method
LineLoadTypeSet Class See Also Send Feedback
Removes a specified lineload type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LineLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The lineload type to be erased.

Return Value

The number of lineload types that were erased from the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LineLoadTypeSet..::.ForwardIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LineLoadTypeSet..::.GetEnumerator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LineLoadTypeSet..::.Insert Method
LineLoadTypeSet Class See Also Send Feedback
Insert the specified lineload type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    LineLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LineLoadType
The lineload type to be inserted into the set.

Return Value

Returns whether the lineload type was inserted into the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LineLoadTypeSet..::.ReverseIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Properties

[image] [image]

Revit 2011 API
LineLoadTypeSet Properties
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LineLoadTypeSet..::.IsEmpty Property
LineLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LineLoadTypeSet..::.Size Property
LineLoadTypeSet Class See Also Send Feedback
Returns the number of lineload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Class

[image]

Revit 2011 API
LineLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a lineload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LineLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LineLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LineLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LineLoadTypeSetIterator

See Also

LineLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Members

[image] [image]

Revit 2011 API
LineLoadTypeSetIterator Members
LineLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
LineLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Constructor

[image]

Revit 2011 API
LineLoadTypeSetIterator Constructor
LineLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LineLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Methods

[image] [image]

Revit 2011 API
LineLoadTypeSetIterator Methods
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LineLoadTypeSetIterator..::.MoveNext Method
LineLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LineLoadTypeSetIterator..::.Reset Method
LineLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Properties

[image] [image]

Revit 2011 API
LineLoadTypeSetIterator Properties
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LineLoadTypeSetIterator..::.Current Property
LineLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Class

[image]

Revit 2011 API
LoadBase Class
Members Example See Also Send Feedback
The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadBase : Element
Visual Basic (Declaration)
Public Class LoadBase _
    Inherits Element
Visual C++
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Examples

CopyC#
private void LoadBaseInformation(LoadBase loadBase)
{
    string message = "LoadBase data for line load: ";
    //Get the name of the load case to which this load belongs
    message += "\nLoad case name: " + loadBase.LoadCaseName;

    //Get the name of the category to which this load belongs
    message += "\nLoad category name: " + loadBase.LoadCategoryName;

    //A string representing the nature of the load
    message += "\nLoad nature name: " + loadBase.LoadNatureName;

    //show the load base information in the messagebox
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub LoadBaseInformation(ByVal loadBase As Autodesk.Revit.DB.Structure.LoadBase)
    Dim message As String = "LoadBase data for line load: "
    'Get the name of the load case to which this load belongs
    message += vbLf & "Load case name: " + loadBase.LoadCaseName

    'Get the name of the category to which this load belongs
    message += vbLf & "Load category name: " + loadBase.LoadCategoryName

    'A string representing the nature of the load
    message += vbLf & "Load nature name: " + loadBase.LoadNatureName

    'show the load base information in the messagebox
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.AreaLoad
Autodesk.Revit.DB.Structure..::.LineLoad
Autodesk.Revit.DB.Structure..::.PointLoad

See Also

LoadBase Members
Autodesk.Revit.DB.Structure Namespace


LoadBase Members

[image] [image]

Revit 2011 API
LoadBase Members
LoadBase Class Methods Properties See Also Send Feedback

The LoadBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs.
LoadCategoryName | The name of the category to which this load belongs.
LoadNatureName | A string representing the nature of the load.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Methods

[image] [image]

Revit 2011 API
LoadBase Methods
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Properties

[image] [image]

Revit 2011 API
LoadBase Properties
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs.
LoadCategoryName | The name of the category to which this load belongs.
LoadNatureName | A string representing the nature of the load.
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


HostElement Property

[image]

Revit 2011 API
LoadBase..::.HostElement Property
LoadBase Class See Also Send Feedback
The host element for the load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostElement As Element
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

Field Value

If the load is host-based this is the host element. Otherwise this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseName Property

[image]

Revit 2011 API
LoadBase..::.LoadCaseName Property
LoadBase Class See Also Send Feedback
The name of the load case to which this load belongs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LoadCaseName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadCaseName As String
Visual C++
public:
property String^ LoadCaseName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadCategoryName Property

[image]

Revit 2011 API
LoadBase..::.LoadCategoryName Property
LoadBase Class See Also Send Feedback
The name of the category to which this load belongs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LoadCategoryName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadCategoryName As String
Visual C++
public:
property String^ LoadCategoryName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadNatureName Property

[image]

Revit 2011 API
LoadBase..::.LoadNatureName Property
LoadBase Class See Also Send Feedback
A string representing the nature of the load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LoadNatureName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadNatureName As String
Visual C++
public:
property String^ LoadNatureName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadBase..::.Parameter Property
LoadBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadBase Class
LoadBase Members
Autodesk.Revit.DB.Structure Namespace


LoadCase Class

[image]

Revit 2011 API
LoadCase Class
Members Example See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadCase : Element
Visual Basic (Declaration)
Public Class LoadCase _
    Inherits Element
Visual C++
public ref class LoadCase : public Element

Examples

CopyC#
private void LoadCaseInfomation(Document document, LoadCase loadCase)
{
    string loadCaseNumber;   //Store the load cases number
    StringBuilder information = new StringBuilder(10);

    // first get all the load case categories in a list
    List<Category> loadCaseCategories = new List<Category>();
    GetLoadCaseCategories(document, ref loadCaseCategories);

    //get the load case name
    information.Append("\nCase Name: " + loadCase.Name);

    //get the number of the load case
    Parameter caseNumber = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NUMBER);
    if (null == caseNumber)
    {
        loadCaseNumber = "";
    }
    else
    {
        loadCaseNumber = caseNumber.AsInteger().ToString();
    }
    information.Append("\nCase Number: " + loadCaseNumber);

    //get the category of the load case
    Parameter caseCategoryid = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_CATEGORY);
    Autodesk.Revit.DB.ElementId loadCaseCategoryId = caseCategoryid.AsElementId();

    information.Append("\nCategory: " + GetCategoryName(loadCaseCategoryId, loadCaseCategories));

    //get the nature of load case
    Parameter caseNatureId = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NATURE);
    Autodesk.Revit.DB.ElementId loadCaseNatureId = caseNatureId.AsElementId();
    LoadNature loadNature = document.get_Element(loadCaseNatureId) as LoadNature;
    information.Append("\nNature: " + loadNature.Name + "\n");

    //show the information to the user
    TaskDialog.Show("Revit",information.ToString());
}

private void GetLoadCaseCategories(Document document, ref List<Category> loadCaseCategories)
{
    //get all the categories of load cases
    Categories categories = document.Settings.Categories;
    Category caseCategory = categories.get_Item(BuiltInCategory.OST_LoadCases);
    CategoryNameMap categoryNameMap = caseCategory.SubCategories;
    System.Collections.IEnumerator iter = categoryNameMap.GetEnumerator();
    iter.Reset();
    while (iter.MoveNext())
    {
        Category temp = iter.Current as Category;
        if (null != temp)
        {
            loadCaseCategories.Add(temp);
        }
    }
}

/// <summary>
/// Get the category name according to the load case category id.
/// </summary>
private string GetCategoryName(Autodesk.Revit.DB.ElementId loadCaseCategoryId, List<Category> loadCaseCategories)
{
    string categoryName = "";

    foreach (Category category in loadCaseCategories)
    {
        if (category.Id.Equals(loadCaseCategoryId))
        {
            categoryName = category.Name;
            break;
        }
    }
    return categoryName;
}
CopyVB.NET
Private Sub LoadCaseInfomation(ByVal document As Document, ByVal loadCase As LoadCase)
    Dim loadCaseNumber As String
    'Store the load cases number
    Dim information As New StringBuilder(10)

    ' first get all the load case categories in a list
    Dim loadCaseCategories As New List(Of Autodesk.Revit.DB.Category)()
    GetLoadCaseCategories(document, loadCaseCategories)

    'get the load case name
    information.Append(vbLf & "Case Name: " + loadCase.Name)

    'get the number of the load case
    Dim caseNumber As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NUMBER)
    If caseNumber Is Nothing Then
        loadCaseNumber = ""
    Else
        loadCaseNumber = caseNumber.AsInteger().ToString()
    End If
    information.Append(vbLf & "Case Number: " + loadCaseNumber)

    'get the category of the load case
    Dim caseCategoryid As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_CATEGORY)
    Dim loadCaseCategoryId As Autodesk.Revit.DB.ElementId = caseCategoryid.AsElementId()

    information.Append(vbLf & "Category: " + GetCategoryName(loadCaseCategoryId, loadCaseCategories))

    'get the nature of load case
    Dim caseNatureId As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NATURE)
    Dim loadCaseNatureId As Autodesk.Revit.DB.ElementId = caseNatureId.AsElementId()
    Dim loadNature As LoadNature = TryCast(document.Element(loadCaseNatureId), LoadNature)
    information.Append(vbLf & "Nature: " + loadNature.Name + vbLf)

    'show the information to the user
    TaskDialog.Show("Revit", information.ToString())
End Sub

Private Sub GetLoadCaseCategories(ByVal document As Document, ByRef loadCaseCategories As List(Of Autodesk.Revit.DB.Category))
    'get all the categories of load cases
    Dim categories As Categories = document.Settings.Categories
    Dim caseCategory As Autodesk.Revit.DB.Category = categories.Item(BuiltInCategory.OST_LoadCases)
    Dim categoryNameMap As CategoryNameMap = caseCategory.SubCategories
    Dim iter As System.Collections.IEnumerator = categoryNameMap.GetEnumerator()
    iter.Reset()
    While iter.MoveNext()
        Dim temp As Autodesk.Revit.DB.Category = TryCast(iter.Current, Autodesk.Revit.DB.Category)
        If temp IsNot Nothing Then
            loadCaseCategories.Add(temp)
        End If
    End While
End Sub

' <summary>
' Get the category name according to the load case category id.
' </summary>
Private Function GetCategoryName(ByVal loadCaseCategoryId As Autodesk.Revit.DB.ElementId, ByVal loadCaseCategories As List(Of Autodesk.Revit.DB.Category)) As String
    Dim categoryName As String = ""

    For Each category As Autodesk.Revit.DB.Category In loadCaseCategories
        If category.Id.Equals(loadCaseCategoryId) Then
            categoryName = category.Name
            Exit For
        End If
    Next
    Return categoryName
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadCase

See Also

LoadCase Members
Autodesk.Revit.DB.Structure Namespace


LoadCase Members

[image] [image]

Revit 2011 API
LoadCase Members
LoadCase Class Methods Properties See Also Send Feedback

The LoadCase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


LoadCase Methods

[image] [image]

Revit 2011 API
LoadCase Methods
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


LoadCase Properties

[image] [image]

Revit 2011 API
LoadCase Properties
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadCase..::.Parameter Property
LoadCase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadCase Class
LoadCase Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Class

[image]

Revit 2011 API
LoadCaseArray Class
Members See Also Send Feedback
An array that contains load case objects.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadCaseArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCaseArray

See Also

LoadCaseArray Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Members

[image] [image]

Revit 2011 API
LoadCaseArray Members
LoadCaseArray Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArray type exposes the following members.

Constructors

Name | Description
LoadCaseArray | Initializes a new instance of the LoadCaseArray class

Methods

Name | Description
Append | Add the load case to the end of the array.
Clear | Removes every load case from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load case at a specified index within the array.
Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Constructor

[image]

Revit 2011 API
LoadCaseArray Constructor
LoadCaseArray Class See Also Send Feedback
Initializes a new instance of the LoadCaseArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCaseArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArray()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Methods

[image] [image]

Revit 2011 API
LoadCaseArray Methods
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Methods

Name | Description
Append | Add the load case to the end of the array.
Clear | Removes every load case from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2011 API
LoadCaseArray..::.Append Method
LoadCaseArray Class See Also Send Feedback
Add the load case to the end of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCase _
)
Visual C++
public:
virtual void Append(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCase
The load case to be added.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LoadCaseArray..::.Clear Method
LoadCaseArray Class See Also Send Feedback
Removes every load case from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LoadCaseArray..::.ForwardIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LoadCaseArray..::.GetEnumerator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LoadCaseArray..::.Insert Method
LoadCaseArray Class See Also Send Feedback
Insert the specified load case into the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCase item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCase
The load case to be inserted into the array.
index
Type: System..::.Int32
The load case will be inserted before this index.

Return Value

Returns whether the load case was inserted into the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LoadCaseArray..::.ReverseIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Properties

[image] [image]

Revit 2011 API
LoadCaseArray Properties
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load case at a specified index within the array.
Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LoadCaseArray..::.IsEmpty Property
LoadCaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2011 API
LoadCaseArray..::.Item Property
LoadCaseArray Class See Also Send Feedback
Gets or sets an load case at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCase Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCase
Visual C++
public:
virtual property LoadCase^ Item[int index] {
    LoadCase^ get (int index);
    void set (int index, LoadCase^ value);
}

Parameters

index
Type: System..::.Int32
The index of the load case to be set or retrieved.

Return Value

Returns the load case at the specified index.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LoadCaseArray..::.Size Property
LoadCaseArray Class See Also Send Feedback
Returns the number of load cases that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Class

[image]

Revit 2011 API
LoadCaseArrayIterator Class
Members See Also Send Feedback
An iterator to an load case array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LoadCaseArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCaseArrayIterator

See Also

LoadCaseArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Members

[image] [image]

Revit 2011 API
LoadCaseArrayIterator Members
LoadCaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Constructors

Name | Description
LoadCaseArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Constructor

[image]

Revit 2011 API
LoadCaseArrayIterator Constructor
LoadCaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCaseArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Methods

[image] [image]

Revit 2011 API
LoadCaseArrayIterator Methods
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LoadCaseArrayIterator..::.MoveNext Method
LoadCaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LoadCaseArrayIterator..::.Reset Method
LoadCaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Properties

[image] [image]

Revit 2011 API
LoadCaseArrayIterator Properties
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LoadCaseArrayIterator..::.Current Property
LoadCaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Class

[image]

Revit 2011 API
LoadCaseSet Class
Members See Also Send Feedback
A set that contains load cases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadCaseSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCaseSet

See Also

LoadCaseSet Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Members

[image] [image]

Revit 2011 API
LoadCaseSet Members
LoadCaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSet type exposes the following members.

Constructors

Name | Description
LoadCaseSet | Initializes a new instance of the LoadCaseSet class

Methods

Name | Description
Clear | Removes every load case from the set, rendering it empty.
Contains | Tests for the existence of a load case within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load case from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Constructor

[image]

Revit 2011 API
LoadCaseSet Constructor
LoadCaseSet Class See Also Send Feedback
Initializes a new instance of the LoadCaseSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSet()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Methods

[image] [image]

Revit 2011 API
LoadCaseSet Methods
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Methods

Name | Description
Clear | Removes every load case from the set, rendering it empty.
Contains | Tests for the existence of a load case within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load case from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load case into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LoadCaseSet..::.Clear Method
LoadCaseSet Class See Also Send Feedback
Removes every load case from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
LoadCaseSet..::.Contains Method
LoadCaseSet Class See Also Send Feedback
Tests for the existence of a load case within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCase
The load case to be searched for.

Return Value

The Contains method returns True if the load case is within the set, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
LoadCaseSet..::.Erase Method
LoadCaseSet Class See Also Send Feedback
Removes a specified load case from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadCase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCase
The load case to be erased.

Return Value

The number of load cases that were erased from the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LoadCaseSet..::.ForwardIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LoadCaseSet..::.GetEnumerator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LoadCaseSet..::.Insert Method
LoadCaseSet Class See Also Send Feedback
Insert the specified load case into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadCase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCase
The load case to be inserted into the set.

Return Value

Returns whether the load case was inserted into the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LoadCaseSet..::.ReverseIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Properties

[image] [image]

Revit 2011 API
LoadCaseSet Properties
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LoadCaseSet..::.IsEmpty Property
LoadCaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LoadCaseSet..::.Size Property
LoadCaseSet Class See Also Send Feedback
Returns the number of load cases that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Class

[image]

Revit 2011 API
LoadCaseSetIterator Class
Members See Also Send Feedback
An iterator to a load case set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LoadCaseSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCaseSetIterator

See Also

LoadCaseSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Members

[image] [image]

Revit 2011 API
LoadCaseSetIterator Members
LoadCaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Constructors

Name | Description
LoadCaseSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Constructor

[image]

Revit 2011 API
LoadCaseSetIterator Constructor
LoadCaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Methods

[image] [image]

Revit 2011 API
LoadCaseSetIterator Methods
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LoadCaseSetIterator..::.MoveNext Method
LoadCaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LoadCaseSetIterator..::.Reset Method
LoadCaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Properties

[image] [image]

Revit 2011 API
LoadCaseSetIterator Properties
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LoadCaseSetIterator..::.Current Property
LoadCaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Class

[image]

Revit 2011 API
LoadCombination Class
Members Example See Also Send Feedback
An object that represents a load combination.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadCombination : Element
Visual Basic (Declaration)
Public Class LoadCombination _
    Inherits Element
Visual C++
public ref class LoadCombination : public Element

Examples

CopyC#
private void CombinationInformation(LoadCombination loadCombination)
{
    StringBuilder information = new StringBuilder();

    //Get the string with Load Combination Name or empty string
    information.Append("\n\nCombination Name: " + loadCombination.Name);

    //Get the string with Load Combination State
    information.Append("\nCombination state: " + loadCombination.CombinationState);

    //Load Combination State index or 0
    information.Append("\nState index : " + loadCombination.CombinationStateIndex.ToString());

    //Get the string with Load Combination Type
    information.Append("\nCombination type: " + loadCombination.CombinationType);

    //Get Load Combination Type index or 0
    information.Append("\nType index: " + loadCombination.CombinationTypeIndex.ToString());

    //Get the number of Load Combination Components
    int componentsNumber = loadCombination.NumberOfComponents;
    information.Append("\nComponents number: " + componentsNumber.ToString());
    for (int j = 0; j < componentsNumber; j++)
    {
        double factor = loadCombination.get_Factor(j);
        string caseName = loadCombination.get_CombinationCaseName(j);
        information.Append("\nCase name[" + j.ToString() + "]: " + caseName + "  factor: " +
                              factor.ToString());
    }

    //return the number of usage in the combination
    int usageNumber = loadCombination.NumberOfUsages;
    information.Append("\nNumber of usages: " + usageNumber + "\nUsage names: ");
    //get each usage name
    for (int i = 0; i < usageNumber; i++)
    {
        information.Append(loadCombination.get_UsageName(i) + "  ");
    }

    TaskDialog.Show("Revit",information.ToString());
}
CopyVB.NET
Private Sub CombinationInformation(ByVal loadCombination As LoadCombination)
    Dim information As New StringBuilder()

    'Get the string with Load Combination Name or empty string
    information.Append(vbLf & vbLf & "Combination Name: " + loadCombination.Name)

    'Get the string with Load Combination State
    information.Append(vbLf & "Combination state: " + loadCombination.CombinationState)

    'Load Combination State index or 0
    information.Append(vbLf & "State index : " + loadCombination.CombinationStateIndex.ToString())

    'Get the string with Load Combination Type
    information.Append(vbLf & "Combination type: " + loadCombination.CombinationType)

    'Get Load Combination Type index or 0
    information.Append(vbLf & "Type index: " + loadCombination.CombinationTypeIndex.ToString())

    'Get the number of Load Combination Components
    Dim componentsNumber As Integer = loadCombination.NumberOfComponents
    information.Append(vbLf & "Components number: " + componentsNumber.ToString())
    Dim j As Integer = 0
    While j < componentsNumber
        Dim factor As Double = loadCombination.Factor(j)
        Dim caseName As String = loadCombination.CombinationCaseName(j)
        information.Append(vbLf & "Case name[" + j.ToString() + "]: " + caseName + "  factor: " + factor.ToString())
        System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
    End While

    'return the number of usage in the combination
    Dim usageNumber As Integer = loadCombination.NumberOfUsages
    information.Append(vbLf & "Number of usages: " + usageNumber + vbLf & "Usage names: ")
    'get each usage name
    Dim i As Integer = 0
    While i < usageNumber
        information.Append(loadCombination.UsageName(i) + "  ")
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    TaskDialog.Show("Revit", information.ToString())
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.DB.Structure Namespace


LoadCombination Members

[image] [image]

Revit 2011 API
LoadCombination Members
LoadCombination Class Methods Properties See Also Send Feedback

The LoadCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CombinationCaseName | Returns load combination case name.
CombinationNatureName | Returns load combination nature name of load case element.
CombinationState | Returns load combination state.
CombinationStateIndex | Returns the index in predefined load combination state array {}.
CombinationType | Returns load combination type.
CombinationTypeIndex | Returns the index in predefined load combination type array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Factor | Returns factor value.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns load combination name.
NumberOfComponents | Returns number of factors.
NumberOfUsages | Returns number of usages.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsageName | Returns usage value.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Methods

[image] [image]

Revit 2011 API
LoadCombination Methods
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Properties

[image] [image]

Revit 2011 API
LoadCombination Properties
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CombinationCaseName | Returns load combination case name.
CombinationNatureName | Returns load combination nature name of load case element.
CombinationState | Returns load combination state.
CombinationStateIndex | Returns the index in predefined load combination state array {}.
CombinationType | Returns load combination type.
CombinationTypeIndex | Returns the index in predefined load combination type array.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Factor | Returns factor value.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Returns load combination name.
NumberOfComponents | Returns number of factors.
NumberOfUsages | Returns number of usages.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
UsageName | Returns usage value.
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationCaseName Property

[image]

Revit 2011 API
LoadCombination..::.CombinationCaseName Property
LoadCombination Class See Also Send Feedback
Returns load combination case name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string CombinationCaseName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationCaseName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationCaseName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of load case.

Remarks

The index should be not less then 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationNatureName Property

[image]

Revit 2011 API
LoadCombination..::.CombinationNatureName Property
LoadCombination Class See Also Send Feedback
Returns load combination nature name of load case element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string CombinationNatureName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationNatureName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ CombinationNatureName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of load case.

Remarks

The index should be not less 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationState Property

[image]

Revit 2011 API
LoadCombination..::.CombinationState Property
LoadCombination Class See Also Send Feedback
Returns load combination state.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string CombinationState { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationState As String
Visual C++
public:
property String^ CombinationState {
    String^ get ();
}

Remarks

The state should be "Serviceability" or "Ultimate".

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationStateIndex Property

[image]

Revit 2011 API
LoadCombination..::.CombinationStateIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination state array {}.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int CombinationStateIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationStateIndex As Integer
Visual C++
public:
property int CombinationStateIndex {
    int get ();
}

Remarks

The index should be 0 ("Serviceability") or 1 ("Ultimate").

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationType Property

[image]

Revit 2011 API
LoadCombination..::.CombinationType Property
LoadCombination Class See Also Send Feedback
Returns load combination type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string CombinationType { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationType As String
Visual C++
public:
property String^ CombinationType {
    String^ get ();
}

Remarks

The type should be "Combination" or "Envelope".

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationTypeIndex Property

[image]

Revit 2011 API
LoadCombination..::.CombinationTypeIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination type array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int CombinationTypeIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CombinationTypeIndex As Integer
Visual C++
public:
property int CombinationTypeIndex {
    int get ();
}

Remarks

The index should be 0 ("Combination") or 1 ("Envelope").

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Factor Property

[image]

Revit 2011 API
LoadCombination..::.Factor Property
LoadCombination Class See Also Send Feedback
Returns factor value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Factor[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Factor ( _
    index As Integer _
) As Double
Visual C++
public:
property double Factor[int index] {
    double get (int index);
}

Parameters

index
Type: System..::.Int32
The index of factor in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Name Property

[image]

Revit 2011 API
LoadCombination..::.Name Property
LoadCombination Class See Also Send Feedback
Returns load combination name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


NumberOfComponents Property

[image]

Revit 2011 API
LoadCombination..::.NumberOfComponents Property
LoadCombination Class See Also Send Feedback
Returns number of factors.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfComponents { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfComponents As Integer
Visual C++
public:
property int NumberOfComponents {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


NumberOfUsages Property

[image]

Revit 2011 API
LoadCombination..::.NumberOfUsages Property
LoadCombination Class See Also Send Feedback
Returns number of usages.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfUsages { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUsages As Integer
Visual C++
public:
property int NumberOfUsages {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadCombination..::.Parameter Property
LoadCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadCombination Class
LoadCombination Members
Autodesk.Revit.DB.Structure Namespace


UsageName Property

[image]

Revit 2011 API
LoadCombination..::.UsageName Property
LoadCombination Class See Also Send Feedback
Returns usage value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string UsageName[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsageName ( _
    index As Integer _
) As String
Visual C++
public:
property String^ UsageName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::.Int32
The index of usage in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Class

[image]

Revit 2011 API
LoadCombinationArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadCombinationArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadCombinationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCombinationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCombinationArray

See Also

LoadCombinationArray Members
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Members

[image] [image]

Revit 2011 API
LoadCombinationArray Members
LoadCombinationArray Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Constructors

Name | Description
LoadCombinationArray | Initializes a new instance of the LoadCombinationArray class

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Constructor

[image]

Revit 2011 API
LoadCombinationArray Constructor
LoadCombinationArray Class See Also Send Feedback
Initializes a new instance of the LoadCombinationArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCombinationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArray()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Methods

[image] [image]

Revit 2011 API
LoadCombinationArray Methods
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Methods

Name | Description
Append |
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2011 API
LoadCombinationArray..::.Append Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    LoadCombination item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadCombination _
)
Visual C++
public:
virtual void Append(
    LoadCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCombination

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LoadCombinationArray..::.Clear Method
LoadCombinationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LoadCombinationArray..::.ForwardIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LoadCombinationArray..::.GetEnumerator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LoadCombinationArray..::.Insert Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCombination item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadCombination, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCombination^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadCombination
index
Type: System..::.Int32

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LoadCombinationArray..::.ReverseIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Properties

[image] [image]

Revit 2011 API
LoadCombinationArray Properties
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LoadCombinationArray..::.IsEmpty Property
LoadCombinationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2011 API
LoadCombinationArray..::.Item Property
LoadCombinationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadCombination Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadCombination
Visual C++
public:
virtual property LoadCombination^ Item[int index] {
    LoadCombination^ get (int index);
    void set (int index, LoadCombination^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LoadCombinationArray..::.Size Property
LoadCombinationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Class

[image]

Revit 2011 API
LoadCombinationArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LoadCombinationArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadCombinationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCombinationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadCombinationArrayIterator

See Also

LoadCombinationArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Members

[image] [image]

Revit 2011 API
LoadCombinationArrayIterator Members
LoadCombinationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Constructors

Name | Description
LoadCombinationArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Constructor

[image]

Revit 2011 API
LoadCombinationArrayIterator Constructor
LoadCombinationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadCombinationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadCombinationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Methods

[image] [image]

Revit 2011 API
LoadCombinationArrayIterator Methods
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LoadCombinationArrayIterator..::.MoveNext Method
LoadCombinationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LoadCombinationArrayIterator..::.Reset Method
LoadCombinationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Properties

[image] [image]

Revit 2011 API
LoadCombinationArrayIterator Properties
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LoadCombinationArrayIterator..::.Current Property
LoadCombinationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Class

[image]

Revit 2011 API
LoadNature Class
Members See Also Send Feedback
A structural Load nature object.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadNature : Element
Visual Basic (Declaration)
Public Class LoadNature _
    Inherits Element
Visual C++
public ref class LoadNature : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadNature

See Also

LoadNature Members
Autodesk.Revit.DB.Structure Namespace


LoadNature Members

[image] [image]

Revit 2011 API
LoadNature Members
LoadNature Class Methods Properties See Also Send Feedback

The LoadNature type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Methods

[image] [image]

Revit 2011 API
LoadNature Methods
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Properties

[image] [image]

Revit 2011 API
LoadNature Properties
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadNature..::.Parameter Property
LoadNature Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadNature Class
LoadNature Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Class

[image]

Revit 2011 API
LoadTypeBase Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadTypeBase : ElementType
Visual Basic (Declaration)
Public Class LoadTypeBase _
    Inherits ElementType
Visual C++
public ref class LoadTypeBase : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.LoadTypeBase
Autodesk.Revit.DB.Structure..::.AreaLoadType
Autodesk.Revit.DB.Structure..::.LineLoadType
Autodesk.Revit.DB.Structure..::.PointLoadType

See Also

LoadTypeBase Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Members

[image] [image]

Revit 2011 API
LoadTypeBase Members
LoadTypeBase Class Methods Properties See Also Send Feedback

The LoadTypeBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Methods

[image] [image]

Revit 2011 API
LoadTypeBase Methods
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Properties

[image] [image]

Revit 2011 API
LoadTypeBase Properties
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadTypeBase..::.Parameter Property
LoadTypeBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadTypeBase Class
LoadTypeBase Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Class

[image]

Revit 2011 API
LoadTypeBaseSet Class
Members See Also Send Feedback
A set that contains load type bases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadTypeBaseSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadTypeBaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadTypeBaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSet

See Also

LoadTypeBaseSet Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Members

[image] [image]

Revit 2011 API
LoadTypeBaseSet Members
LoadTypeBaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Constructors

Name | Description
LoadTypeBaseSet | Initializes a new instance of the LoadTypeBaseSet class

Methods

Name | Description
Clear | Removes every load type base from the set, rendering it empty.
Contains | Tests for the existence of a load type base within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load type base from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load type base into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Constructor

[image]

Revit 2011 API
LoadTypeBaseSet Constructor
LoadTypeBaseSet Class See Also Send Feedback
Initializes a new instance of the LoadTypeBaseSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadTypeBaseSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSet()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Methods

[image] [image]

Revit 2011 API
LoadTypeBaseSet Methods
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Methods

Name | Description
Clear | Removes every load type base from the set, rendering it empty.
Contains | Tests for the existence of a load type base within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified load type base from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load type base into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.Clear Method
LoadTypeBaseSet Class See Also Send Feedback
Removes every load type base from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.Contains Method
LoadTypeBaseSet Class See Also Send Feedback
Tests for the existence of a load type base within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadTypeBase
The load type base to be searched for.

Return Value

The Contains method returns True if the load type base is within the set, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.Erase Method
LoadTypeBaseSet Class See Also Send Feedback
Removes a specified load type base from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As LoadTypeBase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadTypeBase
The load type base to be erased.

Return Value

The number of load type bases that were erased from the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.ForwardIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.GetEnumerator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.Insert Method
LoadTypeBaseSet Class See Also Send Feedback
Insert the specified load type base into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadTypeBase item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadTypeBase
The load type base to be inserted into the set.

Return Value

Returns whether the load type base was inserted into the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LoadTypeBaseSet..::.ReverseIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Properties

[image] [image]

Revit 2011 API
LoadTypeBaseSet Properties
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LoadTypeBaseSet..::.IsEmpty Property
LoadTypeBaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LoadTypeBaseSet..::.Size Property
LoadTypeBaseSet Class See Also Send Feedback
Returns the number of load type bases that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Class

[image]

Revit 2011 API
LoadTypeBaseSetIterator Class
Members See Also Send Feedback
An iterator to a load type base set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LoadTypeBaseSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadTypeBaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadTypeBaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadTypeBaseSetIterator

See Also

LoadTypeBaseSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Members

[image] [image]

Revit 2011 API
LoadTypeBaseSetIterator Members
LoadTypeBaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Constructors

Name | Description
LoadTypeBaseSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Constructor

[image]

Revit 2011 API
LoadTypeBaseSetIterator Constructor
LoadTypeBaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadTypeBaseSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadTypeBaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Methods

[image] [image]

Revit 2011 API
LoadTypeBaseSetIterator Methods
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LoadTypeBaseSetIterator..::.MoveNext Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LoadTypeBaseSetIterator..::.Reset Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Properties

[image] [image]

Revit 2011 API
LoadTypeBaseSetIterator Properties
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LoadTypeBaseSetIterator..::.Current Property
LoadTypeBaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Class

[image]

Revit 2011 API
LoadUsage Class
Members See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadUsage : Element
Visual Basic (Declaration)
Public Class LoadUsage _
    Inherits Element
Visual C++
public ref class LoadUsage : public Element

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadUsage

See Also

LoadUsage Members
Autodesk.Revit.DB.Structure Namespace


LoadUsage Members

[image] [image]

Revit 2011 API
LoadUsage Members
LoadUsage Class Methods Properties See Also Send Feedback

The LoadUsage type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Methods

[image] [image]

Revit 2011 API
LoadUsage Methods
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Properties

[image] [image]

Revit 2011 API
LoadUsage Properties
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
LoadUsage..::.Parameter Property
LoadUsage Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

LoadUsage Class
LoadUsage Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Class

[image]

Revit 2011 API
LoadUsageArray Class
Members See Also Send Feedback
An array that contains load usage objects.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class LoadUsageArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class LoadUsageArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadUsageArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadUsageArray

See Also

LoadUsageArray Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Members

[image] [image]

Revit 2011 API
LoadUsageArray Members
LoadUsageArray Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArray type exposes the following members.

Constructors

Name | Description
LoadUsageArray | Initializes a new instance of the LoadUsageArray class

Methods

Name | Description
Append | Add the load usage to the end of the array.
Clear | Removes every load usage from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load usage into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load usage at a specified index within the array.
Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Constructor

[image]

Revit 2011 API
LoadUsageArray Constructor
LoadUsageArray Class See Also Send Feedback
Initializes a new instance of the LoadUsageArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadUsageArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArray()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Methods

[image] [image]

Revit 2011 API
LoadUsageArray Methods
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Methods

Name | Description
Append | Add the load usage to the end of the array.
Clear | Removes every load usage from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified load usage into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2011 API
LoadUsageArray..::.Append Method
LoadUsageArray Class See Also Send Feedback
Add the load usage to the end of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    LoadUsage item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As LoadUsage _
)
Visual C++
public:
virtual void Append(
    LoadUsage^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadUsage
The load usage to be added.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
LoadUsageArray..::.Clear Method
LoadUsageArray Class See Also Send Feedback
Removes every load usage from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
LoadUsageArray..::.ForwardIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
LoadUsageArray..::.GetEnumerator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
LoadUsageArray..::.Insert Method
LoadUsageArray Class See Also Send Feedback
Insert the specified load usage into the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    LoadUsage item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As LoadUsage, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadUsage^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.LoadUsage
The load usage to be inserted into the array.
index
Type: System..::.Int32
The load usage will be inserted before this index.

Return Value

Returns whether the load usage was inserted into the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
LoadUsageArray..::.ReverseIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Properties

[image] [image]

Revit 2011 API
LoadUsageArray Properties
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an load usage at a specified index within the array.
Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
LoadUsageArray..::.IsEmpty Property
LoadUsageArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2011 API
LoadUsageArray..::.Item Property
LoadUsageArray Class See Also Send Feedback
Gets or sets an load usage at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual LoadUsage Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As LoadUsage
Visual C++
public:
virtual property LoadUsage^ Item[int index] {
    LoadUsage^ get (int index);
    void set (int index, LoadUsage^ value);
}

Parameters

index
Type: System..::.Int32
The index of the load usage to be set or retrieved.

Return Value

Returns the load usage at the specified index.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
LoadUsageArray..::.Size Property
LoadUsageArray Class See Also Send Feedback
Returns the number of load usages that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Class

[image]

Revit 2011 API
LoadUsageArrayIterator Class
Members See Also Send Feedback
An iterator to an load usage array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class LoadUsageArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class LoadUsageArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadUsageArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.LoadUsageArrayIterator

See Also

LoadUsageArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Members

[image] [image]

Revit 2011 API
LoadUsageArrayIterator Members
LoadUsageArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Constructors

Name | Description
LoadUsageArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Constructor

[image]

Revit 2011 API
LoadUsageArrayIterator Constructor
LoadUsageArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public LoadUsageArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadUsageArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Methods

[image] [image]

Revit 2011 API
LoadUsageArrayIterator Methods
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
LoadUsageArrayIterator..::.MoveNext Method
LoadUsageArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
LoadUsageArrayIterator..::.Reset Method
LoadUsageArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Properties

[image] [image]

Revit 2011 API
LoadUsageArrayIterator Properties
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
LoadUsageArrayIterator..::.Current Property
LoadUsageArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Class

[image]

Revit 2011 API
PathReinforcement Class
Members Example See Also Send Feedback
An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PathReinforcement : Element
Visual Basic (Declaration)
Public Class PathReinforcement _
    Inherits Element
Visual C++
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
private void Getinfo_PathReinforcement(PathReinforcement pathReinforcement)
{
    string message = "PathReinforcement : ";

    // Show the NumBarDescriptions property
    message += "\nNumber of distinct bar shapes : " + pathReinforcement.NumBarDescriptions;
    for (int i = 0; i < pathReinforcement.NumBarDescriptions; i++)
    {
       BarDescription description = pathReinforcement.get_BarDescription(i);
       message += "\nBar count : " + description.Count;
       message += "\nBar type name : " + description.BarType.Name;
       message += "\nBar layer : " + description.Layer;
       message += "\nBar length : " + description.Length;
    }

    // Show the PathReinforcement Curves information
    message += "\nPath Reinforcement has " + pathReinforcement.Curves.Size + " path curves.";
    foreach (Autodesk.Revit.DB.Element ii in pathReinforcement.Curves)
    {
       ModelCurve pathCurve = ii as ModelCurve;
       if (null == pathCurve)
       {
          continue;
       }
       Curve curve = pathCurve.GeometryCurve;   // get the location curve
       XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
       XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
       message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
       message += "   End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_PathReinforcement(ByVal pathReinforcement As Autodesk.Revit.DB.Structure.PathReinforcement)
    Dim message As String = "PathReinforcement : "

    ' Show the NumBarDescriptions property
    message += vbLf & "Number of distinct bar shapes : " + pathReinforcement.NumBarDescriptions
    Dim i As Integer = 0
    While i < pathReinforcement.NumBarDescriptions
        Dim description As BarDescription = pathReinforcement.BarDescription(i)
        message += vbLf & "Bar count : " + description.Count
        message += vbLf & "Bar type name : " + description.BarType.Name
        message += vbLf & "Bar layer : " + description.Layer
        message += vbLf & "Bar length : " + description.Length
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Show the PathReinforcement Curves information
    message += vbLf & "Path Reinforcement has " + pathReinforcement.Curves.Size + " path curves."
    For Each ii As Autodesk.Revit.DB.Element In pathReinforcement.Curves
        Dim pathCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = pathCurve.GeometryCurve
        ' get the location curve
        Dim start As Autodesk.Revit.DB.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.DB.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += vbLf & "Curve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")"
        message += "   End point (" + [end].X + ", " + [end].Y + ", " + [end].Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Members

[image] [image]

Revit 2011 API
PathReinforcement Members
PathReinforcement Class Methods Properties See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathReinforcementType | Retrieves the type of the Path Reinforcement.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Methods

[image] [image]

Revit 2011 API
PathReinforcement Methods
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Properties

[image] [image]

Revit 2011 API
PathReinforcement Properties
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Properties

Name | Description
BarDescription | Retrieves the Bar Table property of an Path Reinforcement element.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Retrieves the array of curves forming the boundary of the Path Reinforcement.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | A human readable name for the Element. (Inherited from Element.)
NumBarDescriptions | Retrieves the number of distinct bar shapes.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PathReinforcementType | Retrieves the type of the Path Reinforcement.
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Property

[image]

Revit 2011 API
PathReinforcement..::.BarDescription Property
PathReinforcement Class See Also Send Feedback
Retrieves the Bar Table property of an Path Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public BarDescription BarDescription[
    int idx
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
Visual C++
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::.Int32
Index of a Bar Description.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2011 API
PathReinforcement..::.Curves Property
PathReinforcement Class Example See Also Send Feedback
Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As ElementArray
Visual C++
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

Examples

CopyC#
private void Getinfo_PathReinforcementCurve(PathReinforcement pathReinforcement)
{
    string message = "Path Reinforcement Curves : ";

    // Get path reinforcement curves by iterating the Curves property
    foreach (Autodesk.Revit.DB.Element ii in pathReinforcement.Curves)
    {
        ModelCurve pathReinforcementCurve = ii as ModelCurve;
        if (null == pathReinforcementCurve)
        {
            continue;
        }

        Autodesk.Revit.DB.Curve curve = pathReinforcementCurve.GeometryCurve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";

    }
    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Private Sub Getinfo_PathReinforcementCurve(ByVal pathReinforcement As Autodesk.Revit.DB.Structure.PathReinforcement)
    Dim message As String = "Path Reinforcement Curves : "

    ' Get path reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.DB.Element In pathReinforcement.Curves
        Dim pathReinforcementCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathReinforcementCurve Is Nothing Then
            Continue For
        End If

        Dim curve As Autodesk.Revit.DB.Curve = pathReinforcementCurve.GeometryCurve

        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point

        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next
    TaskDialog.Show("Revit", message)

End Sub

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


NumBarDescriptions Property

[image]

Revit 2011 API
PathReinforcement..::.NumBarDescriptions Property
PathReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumBarDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumBarDescriptions As Integer
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
PathReinforcement..::.Parameter Property
PathReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PathReinforcement Class
PathReinforcement Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Property

[image]

Revit 2011 API
PathReinforcement..::.PathReinforcementType Property
PathReinforcement Class See Also Send Feedback
Retrieves the type of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PathReinforcementType PathReinforcementType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathReinforcementType As PathReinforcementType
Visual C++
public:
property PathReinforcementType^ PathReinforcementType {
    PathReinforcementType^ get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Class

[image]

Revit 2011 API
PathReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PathReinforcementType : ElementType
Visual Basic (Declaration)
Public Class PathReinforcementType _
    Inherits ElementType
Visual C++
public ref class PathReinforcementType : public ElementType

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.PathReinforcementType

See Also

PathReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Members

[image] [image]

Revit 2011 API
PathReinforcementType Members
PathReinforcementType Class Methods Properties See Also Send Feedback

The PathReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Methods

[image] [image]

Revit 2011 API
PathReinforcementType Methods
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Properties

[image] [image]

Revit 2011 API
PathReinforcementType Properties
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
PathReinforcementType..::.Parameter Property
PathReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PathReinforcementType Class
PathReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


PointLoad Class

[image]

Revit 2011 API
PointLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointLoad : LoadBase
Visual Basic (Declaration)
Public Class PointLoad _
    Inherits LoadBase
Visual C++
public ref class PointLoad : public LoadBase

Examples

CopyC#
private void Getinfo_PointLoad(PointLoad pointLoad)
{
    string message = "Point Load :";

    // Get the load case name
    message += "\nLoad case for load: " + pointLoad.LoadCaseName;

    //get the three dimensional force applied to the point load
    message += "\nForce: (" + pointLoad.Force.X + ", " +
             pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")";

    //get the three dimensional moment application to the point load
    message += "\nMoment: (" + pointLoad.Moment.X + ", " +
             pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")";

    //get the three dimensional coordinates of point load
    message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
             pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_PointLoad(ByVal pointLoad As Autodesk.Revit.DB.Structure.PointLoad)
    Dim message As String = "Point Load :"

    ' Get the load case name
    message += vbLf & "Load case for load: " + pointLoad.LoadCaseName

    'get the three dimensional force applied to the point load
    message += vbLf & "Force: (" + pointLoad.Force.X + ", " + pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")"

    'get the three dimensional moment application to the point load
    message += vbLf & "Moment: (" + pointLoad.Moment.X + ", " + pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")"

    'get the three dimensional coordinates of point load
    message += vbLf & "Point load location: (" + pointLoad.Point.X + ", " + pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.LoadBase
Autodesk.Revit.DB.Structure..::.PointLoad

See Also

PointLoad Members
Autodesk.Revit.DB.Structure Namespace


PointLoad Members

[image] [image]

Revit 2011 API
PointLoad Members
PointLoad Class Methods Properties See Also Send Feedback

The PointLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to the point load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment application to the point load.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional coordinates of point load.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoad Methods

[image] [image]

Revit 2011 API
PointLoad Methods
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoad Properties

[image] [image]

Revit 2011 API
PointLoad Properties
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Force | Returns the three dimensional force applied to the point load.
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HostElement | The host element for the load. (Inherited from LoadBase.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Moment | Returns the three dimensional moment application to the point load.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Point | Returns the three dimensional coordinates of point load.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2011 API
PointLoad..::.Force Property
PointLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Force { get; }
Visual Basic (Declaration)
Public ReadOnly Property Force As XYZ
Visual C++
public:
property XYZ^ Force {
    XYZ^ get ();
}

Remarks

The force is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment Property

[image]

Revit 2011 API
PointLoad..::.Moment Property
PointLoad Class See Also Send Feedback
Returns the three dimensional moment application to the point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Moment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Moment As XYZ
Visual C++
public:
property XYZ^ Moment {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
PointLoad..::.Parameter Property
PointLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PointLoad Class
PointLoad Members
Autodesk.Revit.DB.Structure Namespace


Point Property

[image]

Revit 2011 API
PointLoad..::.Point Property
PointLoad Class See Also Send Feedback
Returns the three dimensional coordinates of point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As XYZ
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

The location is measured in decimal feet.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Class

[image]

Revit 2011 API
PointLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointLoadType : LoadTypeBase
Visual Basic (Declaration)
Public Class PointLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class PointLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.LoadTypeBase
Autodesk.Revit.DB.Structure..::.PointLoadType

See Also

PointLoadType Members
Autodesk.Revit.DB.Structure Namespace


PointLoadType Members

[image] [image]

Revit 2011 API
PointLoadType Members
PointLoadType Class Methods Properties See Also Send Feedback

The PointLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Methods

[image] [image]

Revit 2011 API
PointLoadType Methods
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Properties

[image] [image]

Revit 2011 API
PointLoadType Properties
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
PointLoadType..::.Parameter Property
PointLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

PointLoadType Class
PointLoadType Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Class

[image]

Revit 2011 API
PointLoadTypeSet Class
Members See Also Send Feedback
A set that contains pointload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class PointLoadTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class PointLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PointLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.PointLoadTypeSet

See Also

PointLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Members

[image] [image]

Revit 2011 API
PointLoadTypeSet Members
PointLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Constructors

Name | Description
PointLoadTypeSet | Initializes a new instance of the PointLoadTypeSet class

Methods

Name | Description
Clear | Removes every pointload type from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Constructor

[image]

Revit 2011 API
PointLoadTypeSet Constructor
PointLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the PointLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointLoadTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSet()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Methods

[image] [image]

Revit 2011 API
PointLoadTypeSet Methods
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every pointload type from the set, rendering it empty.
Contains |
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase |
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
PointLoadTypeSet..::.Clear Method
PointLoadTypeSet Class See Also Send Feedback
Removes every pointload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
PointLoadTypeSet..::.Contains Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
PointLoadTypeSet..::.Erase Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As PointLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
PointLoadTypeSet..::.ForwardIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
PointLoadTypeSet..::.GetEnumerator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
PointLoadTypeSet..::.Insert Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    PointLoadType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
PointLoadTypeSet..::.ReverseIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Properties

[image] [image]

Revit 2011 API
PointLoadTypeSet Properties
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
PointLoadTypeSet..::.IsEmpty Property
PointLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
PointLoadTypeSet..::.Size Property
PointLoadTypeSet Class See Also Send Feedback
Returns the number of pointload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Class

[image]

Revit 2011 API
PointLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a pointload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class PointLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class PointLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PointLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.PointLoadTypeSetIterator

See Also

PointLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Members

[image] [image]

Revit 2011 API
PointLoadTypeSetIterator Members
PointLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Constructors

Name | Description
PointLoadTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Constructor

[image]

Revit 2011 API
PointLoadTypeSetIterator Constructor
PointLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public PointLoadTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Methods

[image] [image]

Revit 2011 API
PointLoadTypeSetIterator Methods
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
PointLoadTypeSetIterator..::.MoveNext Method
PointLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
PointLoadTypeSetIterator..::.Reset Method
PointLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Properties

[image] [image]

Revit 2011 API
PointLoadTypeSetIterator Properties
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
PointLoadTypeSetIterator..::.Current Property
PointLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Rebar Class

[image]

Revit 2011 API
Rebar Class
Members Example See Also Send Feedback
Represents a rebar element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Rebar : Element
Visual Basic (Declaration)
Public Class Rebar _
    Inherits Element
Visual C++
public ref class Rebar : public Element

Examples

CopyC#
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bar type of the rebar
    message += "\nBar Type: " + rebar.BarType.Name;

    //get the curve information
    CurveArray curves = rebar.Curves;
    message += "\n\nThe Curves property has " + curves.Size + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Host) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.Host.Id.IntegerValue;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_Rebar(ByVal rebar As Autodesk.Revit.DB.Structure.Rebar)
    Dim message As String = "Rebar: "
    'get the bar type of the rebar
    message += vbLf & "Bar Type: " + rebar.BarType.Name

    'get the curve information
    Dim curves As CurveArray = rebar.Curves
    message += vbLf & vbLf & "The Curves property has " + curves.Size + " curves:"
    For Each curve As Curve In curves
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next

    'get the host element of the rebar
    If rebar.Host IsNot Nothing Then
        'maybe some rebars don't have host
        message += vbLf & vbLf & "The host element ID : " + rebar.Host.Id.IntegerValue
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.Rebar

See Also

Rebar Members
Autodesk.Revit.DB.Structure Namespace


Rebar Members

[image] [image]

Revit 2011 API
Rebar Members
Rebar Class Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ArrayLength | Identifies the distribution path length of rebar set.
BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
BarType | Return the type of the rebar.
BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | For a spiral, the overall height.
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeFirstBar | Identifies if the first bar in rebar set is shown.
IncludeLastBar | Identifies if the last bar in rebar set is shown.
IsShownInFrontOfGeometryInView | Obsolete. Control placement of the rebar graphics in the viewing planes.
LayoutRule | Identifies the layout rule of rebar set.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfBarPositions | Identifies the number of bar positions in rebar set.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Quantity | Identifies the number of bars in rebar set.
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Rebar Methods

[image] [image]

Revit 2011 API
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ScaleToBox | Move and resize the bar to fit within a specified box.
ScaleToBoxForSpiral | Move and resize a spiral instance to fit within a specified box.
SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IsSolidInView Method

[image]

Revit 2011 API
Rebar..::.IsSolidInView Method
Rebar Class See Also Send Feedback
Checks if this rebar element is shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSolidInView(
    View3D view
)
Visual Basic (Declaration)
Public Function IsSolidInView ( _
    view As View3D _
) As Boolean
Visual C++
public:
bool IsSolidInView(
    View3D^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::.View3D
The 3D view element

Return Value

True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IsUnobscuredInView Method

[image]

Revit 2011 API
Rebar..::.IsUnobscuredInView Method
Rebar Class See Also Send Feedback
Checks if this rebar element is shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsUnobscuredInView(
    View view
)
Visual Basic (Declaration)
Public Function IsUnobscuredInView ( _
    view As View _
) As Boolean
Visual C++
public:
bool IsUnobscuredInView(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view element

Return Value

True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ScaleToBox Method

[image]

Revit 2011 API
Rebar..::.ScaleToBox Method
Rebar Class See Also Send Feedback
Move and resize the bar to fit within a specified box.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ScaleToBox(
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic (Declaration)
Public Sub ScaleToBox ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
)
Visual C++
public:
void ScaleToBox(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ScaleToBoxForSpiral Method

[image]

Revit 2011 API
Rebar..::.ScaleToBoxForSpiral Method
Rebar Class See Also Send Feedback
Move and resize a spiral instance to fit within a specified box.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void ScaleToBoxForSpiral(
    XYZ origin,
    XYZ xVec,
    XYZ yVec,
    double height
)
Visual Basic (Declaration)
Public Sub ScaleToBoxForSpiral ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ, _
    height As Double _
)
Visual C++
public:
void ScaleToBoxForSpiral(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec,
    double height
)

Parameters

origin
Type: Autodesk.Revit.DB..::.XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::.XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.
height
Type: System..::.Double
New value for the Height parameter.

Remarks

The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The circle at one end of the spiral is inscribed in this rectangle. The other end of the spiral is placed in the parallel plane at distance given by height, in the direction of xVec cross yVec.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsFixedNumber Method

[image]

Revit 2011 API
Rebar..::.SetLayoutAsFixedNumber Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to FixedNumber.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsFixedNumber(
    int numberOfBarPositions,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsFixedNumber ( _
    numberOfBarPositions As Integer, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsFixedNumber(
    int numberOfBarPositions,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

numberOfBarPositions
Type: System..::.Int32
The number of bar positions in rebar set
arrayLength
Type: System..::.Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to FixedNumber, you must also simultaneously set NumberOfBarPositions, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 100000. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsMaximumSpacing Method

[image]

Revit 2011 API
Rebar..::.SetLayoutAsMaximumSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to MaximumSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsMaximumSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsMaximumSpacing ( _
    spacing As Double, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsMaximumSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

spacing
Type: System..::.Double
The maximum spacing between rebar in rebar set
arrayLength
Type: System..::.Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to MaximumSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsMinimumClearSpacing Method

[image]

Revit 2011 API
Rebar..::.SetLayoutAsMinimumClearSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to MinimumClearSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsMinimumClearSpacing ( _
    spacing As Double, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

spacing
Type: System..::.Double
The maximum spacing between rebar in rebar set
arrayLength
Type: System..::.Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to MinimumClearSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsNumberWithSpacing Method

[image]

Revit 2011 API
Rebar..::.SetLayoutAsNumberWithSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to NumberWithSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic (Declaration)
Public Sub SetLayoutAsNumberWithSpacing ( _
    numberOfBarPositions As Integer, _
    spacing As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

numberOfBarPositions
Type: System..::.Int32
The number of bar positions in rebar set
spacing
Type: System..::.Double
The maximum spacing between rebar in rebar set
barsOnNormalSide
Type: System..::.Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::.Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::.Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions, Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | The rebar is an instance of a spiral shape and does not support layouts.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 100000. -or- The spacing isn't bigger than 0.0.
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsSingle Method

[image]

Revit 2011 API
Rebar..::.SetLayoutAsSingle Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to Single.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetLayoutAsSingle()
Visual Basic (Declaration)
Public Sub SetLayoutAsSingle
Visual C++
public:
void SetLayoutAsSingle()

Remarks

Only one bar will remain, which is at the position of rebar plane

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetSolidInView Method

[image]

Revit 2011 API
Rebar..::.SetSolidInView Method
Rebar Class See Also Send Feedback
Sets this rebar element to be shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetSolidInView(
    View3D view,
    bool solid
)
Visual Basic (Declaration)
Public Sub SetSolidInView ( _
    view As View3D, _
    solid As Boolean _
)
Visual C++
public:
void SetSolidInView(
    View3D^ view,
    bool solid
)

Parameters

view
Type: Autodesk.Revit.DB..::.View3D
The 3D view element
solid
Type: System..::.Boolean
True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetUnobscuredInView Method

[image]

Revit 2011 API
Rebar..::.SetUnobscuredInView Method
Rebar Class See Also Send Feedback
Sets this rebar element to be shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetUnobscuredInView(
    View view,
    bool unobscured
)
Visual Basic (Declaration)
Public Sub SetUnobscuredInView ( _
    view As View, _
    unobscured As Boolean _
)
Visual C++
public:
void SetUnobscuredInView(
    View^ view,
    bool unobscured
)

Parameters

view
Type: Autodesk.Revit.DB..::.View
The view element
unobscured
Type: System..::.Boolean
True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element doesn't have valid visibility data.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Rebar Properties

[image] [image]

Revit 2011 API
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

Name | Description
ArrayLength | Identifies the distribution path length of rebar set.
BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
BarType | Return the type of the rebar.
BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | The centerline of the Rebar.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
DistributionPath | For Rebar with an array layout, return the distribution path (a line).
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Height | For a spiral, the overall height.
Host | The element that contains the rebar.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
IncludeFirstBar | Identifies if the first bar in rebar set is shown.
IncludeLastBar | Identifies if the last bar in rebar set is shown.
IsShownInFrontOfGeometryInView | Obsolete. Control placement of the rebar graphics in the viewing planes.
LayoutRule | Identifies the layout rule of rebar set.
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Name | A human readable name for the Element. (Inherited from Element.)
NumberOfBarPositions | Identifies the number of bar positions in rebar set.
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Quantity | Identifies the number of bars in rebar set.
RebarShape | Get/Set the RebarShape associated with the Rebar.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ArrayLength Property

[image]

Revit 2011 API
Rebar..::.ArrayLength Property
Rebar Class See Also Send Feedback
Identifies the distribution path length of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double ArrayLength { get; set; }
Visual Basic (Declaration)
Public Property ArrayLength As Double
Visual C++
public:
property double ArrayLength {
    double get ();
    void set (double value);
}

Field Value

The distribution path length of rebar set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BarsOnNormalSide Property

[image]

Revit 2011 API
Rebar..::.BarsOnNormalSide Property
Rebar Class See Also Send Feedback
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool BarsOnNormalSide { get; set; }
Visual Basic (Declaration)
Public Property BarsOnNormalSide As Boolean
Visual C++
public:
property bool BarsOnNormalSide {
    bool get ();
    void set (bool value);
}

Field Value

True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BarType Property

[image]

Revit 2011 API
Rebar..::.BarType Property
Rebar Class See Also Send Feedback
Return the type of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarType BarType { get; set; }
Visual Basic (Declaration)
Public Property BarType As RebarBarType
Visual C++
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
    void set (RebarBarType^ value);
}

Remarks

Returns a RebarBarType element that defines bar diameter and bend radius for the rebar.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BaseFinishingTurns Property

[image]

Revit 2011 API
Rebar..::.BaseFinishingTurns Property
Rebar Class See Also Send Feedback
For a spiral, the number of finishing turns at the lower end of the spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int BaseFinishingTurns { get; set; }
Visual Basic (Declaration)
Public Property BaseFinishingTurns As Integer
Visual C++
public:
property int BaseFinishingTurns {
    int get ();
    void set (int value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2011 API
Rebar..::.Curves Property
Rebar Class See Also Send Feedback
The centerline of the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Remarks

These curves represent the centerline of the rebar, including the hooks and bends. They are the curves shown in Revit views at the coarse detail level.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


DistributionPath Property

[image]

Revit 2011 API
Rebar..::.DistributionPath Property
Rebar Class See Also Send Feedback
For Rebar with an array layout, return the distribution path (a line).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Curve DistributionPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property DistributionPath As Curve
Visual C++
public:
property Curve^ DistributionPath {
    Curve^ get ();
}

Remarks

This creates a new curve.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Height Property

[image]

Revit 2011 API
Rebar..::.Height Property
Rebar Class See Also Send Feedback
For a spiral, the overall height.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: height must be positive.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Host Property

[image]

Revit 2011 API
Rebar..::.Host Property
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Element Host { get; set; }
Visual Basic (Declaration)
Public Property Host As Element
Visual C++
public:
property Element^ Host {
    Element^ get ();
    void set (Element^ value);
}

Remarks

Returns the Autodesk Revit element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IncludeFirstBar Property

[image]

Revit 2011 API
Rebar..::.IncludeFirstBar Property
Rebar Class See Also Send Feedback
Identifies if the first bar in rebar set is shown.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IncludeFirstBar { get; set; }
Visual Basic (Declaration)
Public Property IncludeFirstBar As Boolean
Visual C++
public:
property bool IncludeFirstBar {
    bool get ();
    void set (bool value);
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IncludeLastBar Property

[image]

Revit 2011 API
Rebar..::.IncludeLastBar Property
Rebar Class See Also Send Feedback
Identifies if the last bar in rebar set is shown.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool IncludeLastBar { get; set; }
Visual Basic (Declaration)
Public Property IncludeLastBar As Boolean
Visual C++
public:
property bool IncludeLastBar {
    bool get ();
    void set (bool value);
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IsShownInFrontOfGeometryInView Property

[image]

Revit 2011 API
Rebar..::.IsShownInFrontOfGeometryInView Property
Rebar Class See Also Send Feedback
Control placement of the rebar graphics in the viewing planes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("Use IsUnobscuredInView()/SetUnobscuredInView() instead.")]
public bool IsShownInFrontOfGeometryInView[
    View dbView
] { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use IsUnobscuredInView()/SetUnobscuredInView() instead.")> _
Public Property IsShownInFrontOfGeometryInView ( _
    dbView As View _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use IsUnobscuredInView()/SetUnobscuredInView() instead.")]
public:
property bool IsShownInFrontOfGeometryInView[View^ dbView] {
    bool get (View^ dbView);
    void set (View^ dbView, bool value);
}

Parameters

dbView
Type: Autodesk.Revit.DB..::.View

Remarks

Control whether the graphics are shown in front of the geometry in a view.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


LayoutRule Property

[image]

Revit 2011 API
Rebar..::.LayoutRule Property
Rebar Class See Also Send Feedback
Identifies the layout rule of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarLayoutRule LayoutRule { get; }
Visual Basic (Declaration)
Public ReadOnly Property LayoutRule As RebarLayoutRule
Visual C++
public:
property RebarLayoutRule LayoutRule {
    RebarLayoutRule get ();
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


MaxSpacing Property

[image]

Revit 2011 API
Rebar..::.MaxSpacing Property
Rebar Class See Also Send Feedback
Identifies the maximum spacing between rebar in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MaxSpacing { get; set; }
Visual Basic (Declaration)
Public Property MaxSpacing As Double
Visual C++
public:
property double MaxSpacing {
    double get ();
    void set (double value);
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


NumberOfBarPositions Property

[image]

Revit 2011 API
Rebar..::.NumberOfBarPositions Property
Rebar Class See Also Send Feedback
Identifies the number of bar positions in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfBarPositions { get; set; }
Visual Basic (Declaration)
Public Property NumberOfBarPositions As Integer
Visual C++
public:
property int NumberOfBarPositions {
    int get ();
    void set (int value);
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
Rebar..::.Parameter Property
Rebar Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Rebar Class
Rebar Members
Autodesk.Revit.DB.Structure Namespace


Pitch Property

[image]

Revit 2011 API
Rebar..::.Pitch Property
Rebar Class See Also Send Feedback
For a spiral, the pitch, or vertical distance traveled in one rotation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Pitch { get; set; }
Visual Basic (Declaration)
Public Property Pitch As Double
Visual C++
public:
property double Pitch {
    double get ();
    void set (double value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: pitch must be positive.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Quantity Property

[image]

Revit 2011 API
Rebar..::.Quantity Property
Rebar Class See Also Send Feedback
Identifies the number of bars in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Quantity { get; }
Visual Basic (Declaration)
Public ReadOnly Property Quantity As Integer
Visual C++
public:
property int Quantity {
    int get ();
}

Field Value

The number of bars in rebar set.

Remarks

Quantity is equal to NumberOfBarPositions if IncludeFirstBar and IncludeLastBar are set. If any end bars are excluded, they are not counted in the Quantity.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Property

[image]

Revit 2011 API
Rebar..::.RebarShape Property
Rebar Class See Also Send Feedback
Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShape RebarShape { get; set; }
Visual Basic (Declaration)
Public Property RebarShape As RebarShape
Visual C++
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


TopFinishingTurns Property

[image]

Revit 2011 API
Rebar..::.TopFinishingTurns Property
Rebar Class See Also Send Feedback
For a spiral, the number of finishing turns at the upper end of the spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int TopFinishingTurns { get; set; }
Visual Basic (Declaration)
Public Property TopFinishingTurns As Integer
Visual C++
public:
property int TopFinishingTurns {
    int get ();
    void set (int value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | The rebar is not an instance of a spiral shape.
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100.
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Class

[image]

Revit 2011 API
RebarBarType Class
Members See Also Send Feedback
A Rebar type object that is used in the generation of Rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarBarType : ElementType
Visual Basic (Declaration)
Public Class RebarBarType _
    Inherits ElementType
Visual C++
public ref class RebarBarType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.DB.Structure Namespace


RebarBarType Members

[image] [image]

Revit 2011 API
RebarBarType Members
RebarBarType Class Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new RebarBarType object
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHookLength | Identifies the hook length for a hook type
GetHookOffsetLength | Identifies the hook offset length for a hook type
GetHookPermission | Identifies if a hook type is permitted for this bar type
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
SetHookLength | Identifies the hook length for a hook type
SetHookOffsetLength | Identifies the hook offset length for a hook type
SetHookPermission | Identifies if a hook type is permitted for this bar type
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarDiameter | Defines bar diameter of rebar
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaximumBendRadius | Defines maximum bend radius of rebar
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Methods

[image] [image]

Revit 2011 API
RebarBarType Methods
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Creates a new RebarBarType object
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHookLength | Identifies the hook length for a hook type
GetHookOffsetLength | Identifies the hook offset length for a hook type
GetHookPermission | Identifies if a hook type is permitted for this bar type
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
SetHookLength | Identifies the hook length for a hook type
SetHookOffsetLength | Identifies the hook offset length for a hook type
SetHookPermission | Identifies if a hook type is permitted for this bar type
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2011 API
RebarBarType..::.Create Method
RebarBarType Class See Also Send Feedback
Creates a new RebarBarType object

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static RebarBarType Create(
    Document ADoc
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    ADoc As Document _
) As RebarBarType
Visual C++
public:
static RebarBarType^ Create(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::.Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetAutoCalcHookLengths Method

[image]

Revit 2011 API
RebarBarType..::.GetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool GetAutoCalcHookLengths(
    ElementId hookId
)
Visual Basic (Declaration)
Public Function GetAutoCalcHookLengths ( _
    hookId As ElementId _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type

Return Value

True if the hook lengths are automatically calculated, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookLength Method

[image]

Revit 2011 API
RebarBarType..::.GetHookLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetHookLength(
    ElementId hookId
)
Visual Basic (Declaration)
Public Function GetHookLength ( _
    hookId As ElementId _
) As Double
Visual C++
public:
double GetHookLength(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type

Return Value

The hook length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook length will be returned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookOffsetLength Method

[image]

Revit 2011 API
RebarBarType..::.GetHookOffsetLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double GetHookOffsetLength(
    ElementId hookId
)
Visual Basic (Declaration)
Public Function GetHookOffsetLength ( _
    hookId As ElementId _
) As Double
Visual C++
public:
double GetHookOffsetLength(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type

Return Value

The hook offset length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook offset length will be returned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length -or- The element hookId does not exist in the document containing this RebarBarType -or- the hook specified by id hookId doesn't have valid default offset length
Autodesk.Revit.Exceptions..::.InvalidOperationException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited. -or- hookId is a member of a loaded family. -or- hookId is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.ModificationForbiddenException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this RebarBarType is being loaded, or is in the midst of another sensitive process. -or- This RebarBarType is an internal element, such as a component of a loaded family or a group type. -or- The document containing this RebarBarType is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This RebarBarType is a member of a group or sketch, and the document is not currently editing the group or sketch.
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException | The document containing this RebarBarType has no open transaction.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookPermission Method

[image]

Revit 2011 API
RebarBarType..::.GetHookPermission Method
RebarBarType Class See Also Send Feedback
Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool GetHookPermission(
    ElementId hookId
)
Visual Basic (Declaration)
Public Function GetHookPermission ( _
    hookId As ElementId _
) As Boolean
Visual C++
public:
bool GetHookPermission(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type

Return Value

True if the hook type is permitted for this bar type, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetAutoCalcHookLengths Method

[image]

Revit 2011 API
RebarBarType..::.SetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetAutoCalcHookLengths(
    ElementId hookId,
    bool autoCalculated
)
Visual Basic (Declaration)
Public Sub SetAutoCalcHookLengths ( _
    hookId As ElementId, _
    autoCalculated As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
    ElementId^ hookId,
    bool autoCalculated
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
autoCalculated
Type: System..::.Boolean
True if the hook lengths should be automatically calculated, otherwise false When it is false, default hook length and default hook offset length will be reported

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookLength Method

[image]

Revit 2011 API
RebarBarType..::.SetHookLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetHookLength(
    ElementId hookId,
    double hookLength
)
Visual Basic (Declaration)
Public Sub SetHookLength ( _
    hookId As ElementId, _
    hookLength As Double _
)
Visual C++
public:
void SetHookLength(
    ElementId^ hookId,
    double hookLength
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
hookLength
Type: System..::.Double
The hook length for a hook type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookOffsetLength Method

[image]

Revit 2011 API
RebarBarType..::.SetHookOffsetLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetHookOffsetLength(
    ElementId hookId,
    double newLength
)
Visual Basic (Declaration)
Public Sub SetHookOffsetLength ( _
    hookId As ElementId, _
    newLength As Double _
)
Visual C++
public:
void SetHookOffsetLength(
    ElementId^ hookId,
    double newLength
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
newLength
Type: System..::.Double
The hook offset length for a hook type

Remarks

AutoCalcHookLengths is ignored when this property is set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookPermission Method

[image]

Revit 2011 API
RebarBarType..::.SetHookPermission Method
RebarBarType Class See Also Send Feedback
Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetHookPermission(
    ElementId hookId,
    bool permission
)
Visual Basic (Declaration)
Public Sub SetHookPermission ( _
    hookId As ElementId, _
    permission As Boolean _
)
Visual C++
public:
void SetHookPermission(
    ElementId^ hookId,
    bool permission
)

Parameters

hookId
Type: Autodesk.Revit.DB..::.ElementId
id of the hook type
permission
Type: System..::.Boolean
True if the hook type should be permitted for this bar type, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Properties

[image] [image]

Revit 2011 API
RebarBarType Properties
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Properties

Name | Description
BarDiameter | Defines bar diameter of rebar
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
MaximumBendRadius | Defines maximum bend radius of rebar
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


BarDiameter Property

[image]

Revit 2011 API
RebarBarType..::.BarDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar diameter of rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double BarDiameter { get; set; }
Visual Basic (Declaration)
Public Property BarDiameter As Double
Visual C++
public:
property double BarDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar diameter of rebar

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bar diameter barDiam is not positive or bigger than the smallest value of 1.0, standard bend diameter, standard hook bend diameter and stirrup/tie bend diameter
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


MaximumBendRadius Property

[image]

Revit 2011 API
RebarBarType..::.MaximumBendRadius Property
RebarBarType Class See Also Send Feedback
Defines maximum bend radius of rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double MaximumBendRadius { get; set; }
Visual Basic (Declaration)
Public Property MaximumBendRadius As Double
Visual C++
public:
property double MaximumBendRadius {
    double get ();
    void set (double value);
}

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
RebarBarType..::.Parameter Property
RebarBarType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarBarType Class
RebarBarType Members
Autodesk.Revit.DB.Structure Namespace


StandardBendDiameter Property

[image]

Revit 2011 API
RebarBarType..::.StandardBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StandardBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StandardBendDiameter As Double
Visual C++
public:
property double StandardBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter standardBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


StandardHookBendDiameter Property

[image]

Revit 2011 API
RebarBarType..::.StandardHookBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines hook bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StandardHookBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StandardHookBendDiameter As Double
Visual C++
public:
property double StandardHookBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The hook bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter standardHookBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


StirrupTieBendDiameter Property

[image]

Revit 2011 API
RebarBarType..::.StirrupTieBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar and hook bend diameter for rebar whose style is stirrup/tie

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double StirrupTieBendDiameter { get; set; }
Visual Basic (Declaration)
Public Property StirrupTieBendDiameter As Double
Visual C++
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar and hook bend diameter for rebar whose style is stirrup/tie

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | When setting this property: the bend diameter stirrupTieBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::.IncorrectProductException | When setting this property: The application isn't Autodesk Revit Structure.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Class

[image]

Revit 2011 API
RebarBarTypeSet Class
Members See Also Send Feedback
A set that contains RebarBar types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarBarTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarBarTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarBarTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarBarTypeSet

See Also

RebarBarTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Members

[image] [image]

Revit 2011 API
RebarBarTypeSet Members
RebarBarTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Constructors

Name | Description
RebarBarTypeSet | Initializes a new instance of the RebarBarTypeSet class

Methods

Name | Description
Clear | Removes every RebarBar type from the set, rendering it empty.
Contains | Tests for the existence of a RebarBar type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarBar type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarBar type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Constructor

[image]

Revit 2011 API
RebarBarTypeSet Constructor
RebarBarTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarBarTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSet()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Methods

[image] [image]

Revit 2011 API
RebarBarTypeSet Methods
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarBar type from the set, rendering it empty.
Contains | Tests for the existence of a RebarBar type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarBar type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarBar type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
RebarBarTypeSet..::.Clear Method
RebarBarTypeSet Class See Also Send Feedback
Removes every RebarBar type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
RebarBarTypeSet..::.Contains Method
RebarBarTypeSet Class See Also Send Feedback
Tests for the existence of a RebarBar type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The RebarBar type to be searched for.

Return Value

The Contains method returns True if the RebarBar type is within the set, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
RebarBarTypeSet..::.Erase Method
RebarBarTypeSet Class See Also Send Feedback
Removes a specified RebarBar type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarBarType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The RebarBar type to be erased.

Return Value

The number of RebarBar types that were erased from the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
RebarBarTypeSet..::.ForwardIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
RebarBarTypeSet..::.GetEnumerator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
RebarBarTypeSet..::.Insert Method
RebarBarTypeSet Class See Also Send Feedback
Insert the specified RebarBar type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarBarType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
The RebarBar type to be inserted into the set.

Return Value

Returns whether the RebarBar type was inserted into the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
RebarBarTypeSet..::.ReverseIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Properties

[image] [image]

Revit 2011 API
RebarBarTypeSet Properties
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
RebarBarTypeSet..::.IsEmpty Property
RebarBarTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
RebarBarTypeSet..::.Size Property
RebarBarTypeSet Class See Also Send Feedback
Returns the number of RebarBar types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Class

[image]

Revit 2011 API
RebarBarTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarBar type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RebarBarTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarBarTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarBarTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarBarTypeSetIterator

See Also

RebarBarTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Members

[image] [image]

Revit 2011 API
RebarBarTypeSetIterator Members
RebarBarTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarBarTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Constructor

[image]

Revit 2011 API
RebarBarTypeSetIterator Constructor
RebarBarTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarBarTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarBarTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Methods

[image] [image]

Revit 2011 API
RebarBarTypeSetIterator Methods
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
RebarBarTypeSetIterator..::.MoveNext Method
RebarBarTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
RebarBarTypeSetIterator..::.Reset Method
RebarBarTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Properties

[image] [image]

Revit 2011 API
RebarBarTypeSetIterator Properties
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
RebarBarTypeSetIterator..::.Current Property
RebarBarTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Class

[image]

Revit 2011 API
RebarCoverType Class
Members See Also Send Feedback
A Rebar Cover setting. This element functions as a name-value pair for Rebar Cover Settings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarCoverType : ElementType
Visual Basic (Declaration)
Public Class RebarCoverType _
    Inherits ElementType
Visual C++
public ref class RebarCoverType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.RebarCoverType

See Also

RebarCoverType Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Members

[image] [image]

Revit 2011 API
RebarCoverType Members
RebarCoverType Class Methods Properties See Also Send Feedback

The RebarCoverType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoverDistance | A distance that can be used as a concrete cover value in a document.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Methods

[image] [image]

Revit 2011 API
RebarCoverType Methods
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Properties

[image] [image]

Revit 2011 API
RebarCoverType Properties
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
CoverDistance | A distance that can be used as a concrete cover value in a document.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


CoverDistance Property

[image]

Revit 2011 API
RebarCoverType..::.CoverDistance Property
RebarCoverType Class See Also Send Feedback
A distance that can be used as a concrete cover value in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double CoverDistance { get; set; }
Visual Basic (Declaration)
Public Property CoverDistance As Double
Visual C++
public:
property double CoverDistance {
    double get ();
    void set (double value);
}

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
RebarCoverType..::.Parameter Property
RebarCoverType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarCoverType Class
RebarCoverType Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Class

[image]

Revit 2011 API
RebarCoverTypeSet Class
Members See Also Send Feedback
A set that contains RebarCover types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarCoverTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarCoverTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarCoverTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSet

See Also

RebarCoverTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Members

[image] [image]

Revit 2011 API
RebarCoverTypeSet Members
RebarCoverTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Constructors

Name | Description
RebarCoverTypeSet | Initializes a new instance of the RebarCoverTypeSet class

Methods

Name | Description
Clear | Removes every RebarCover type from the set, rendering it empty.
Contains | Tests for the existence of a RebarCover type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarCover type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarCover type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Constructor

[image]

Revit 2011 API
RebarCoverTypeSet Constructor
RebarCoverTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarCoverTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSet()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Methods

[image] [image]

Revit 2011 API
RebarCoverTypeSet Methods
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarCover type from the set, rendering it empty.
Contains | Tests for the existence of a RebarCover type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarCover type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarCover type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.Clear Method
RebarCoverTypeSet Class See Also Send Feedback
Removes every RebarCover type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.Contains Method
RebarCoverTypeSet Class See Also Send Feedback
Tests for the existence of a RebarCover type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarCoverType
The RebarCover type to be searched for.

Return Value

The Contains method returns True if the RebarCover type is within the set, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.Erase Method
RebarCoverTypeSet Class See Also Send Feedback
Removes a specified RebarCover type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarCoverType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarCoverType
The RebarCover type to be erased.

Return Value

The number of RebarCover types that were erased from the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.ForwardIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.GetEnumerator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.Insert Method
RebarCoverTypeSet Class See Also Send Feedback
Insert the specified RebarCover type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarCoverType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarCoverType
The RebarCover type to be inserted into the set.

Return Value

Returns whether the RebarCover type was inserted into the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
RebarCoverTypeSet..::.ReverseIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Properties

[image] [image]

Revit 2011 API
RebarCoverTypeSet Properties
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
RebarCoverTypeSet..::.IsEmpty Property
RebarCoverTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
RebarCoverTypeSet..::.Size Property
RebarCoverTypeSet Class See Also Send Feedback
Returns the number of RebarCover types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Class

[image]

Revit 2011 API
RebarCoverTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarCover type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RebarCoverTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarCoverTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarCoverTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarCoverTypeSetIterator

See Also

RebarCoverTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Members

[image] [image]

Revit 2011 API
RebarCoverTypeSetIterator Members
RebarCoverTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarCoverTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Constructor

[image]

Revit 2011 API
RebarCoverTypeSetIterator Constructor
RebarCoverTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarCoverTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Methods

[image] [image]

Revit 2011 API
RebarCoverTypeSetIterator Methods
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
RebarCoverTypeSetIterator..::.MoveNext Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
RebarCoverTypeSetIterator..::.Reset Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Properties

[image] [image]

Revit 2011 API
RebarCoverTypeSetIterator Properties
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
RebarCoverTypeSetIterator..::.Current Property
RebarCoverTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookOrientation Enumeration

[image]

Revit 2011 API
RebarHookOrientation Enumeration
See Also Send Feedback
Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarHookOrientation
Visual Basic (Declaration)
Public Enumeration RebarHookOrientation
Visual C++
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.DB.Structure Namespace


RebarHookType Class

[image]

Revit 2011 API
RebarHookType Class
Members See Also Send Feedback
A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarHookType : ElementType
Visual Basic (Declaration)
Public Class RebarHookType _
    Inherits ElementType
Visual C++
public ref class RebarHookType : public ElementType

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are contained within parameters that are accessible from this object. REBAR_HOOK_ANGLE - angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, REBAR_HOOK_LINE_LEN_FACTOR - a multiplier used to compute the length of the straight segment of the hook. The Length is computed as the bar diameter * the multiplier.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.DB.Structure Namespace


RebarHookType Members

[image] [image]

Revit 2011 API
RebarHookType Members
RebarHookType Class Methods Properties See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


RebarHookType Methods

[image] [image]

Revit 2011 API
RebarHookType Methods
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


RebarHookType Properties

[image] [image]

Revit 2011 API
RebarHookType Properties
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
RebarHookType..::.Parameter Property
RebarHookType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarHookType Class
RebarHookType Members
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Class

[image]

Revit 2011 API
RebarHookTypeSet Class
Members See Also Send Feedback
A set that contains RebarHook types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarHookTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarHookTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarHookTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarHookTypeSet

See Also

RebarHookTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Members

[image] [image]

Revit 2011 API
RebarHookTypeSet Members
RebarHookTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Constructors

Name | Description
RebarHookTypeSet | Initializes a new instance of the RebarHookTypeSet class

Methods

Name | Description
Clear | Removes every RebarHook type from the set, rendering it empty.
Contains | Tests for the existence of a RebarHook type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarHook type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarHook type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Constructor

[image]

Revit 2011 API
RebarHookTypeSet Constructor
RebarHookTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarHookTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSet()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Methods

[image] [image]

Revit 2011 API
RebarHookTypeSet Methods
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every RebarHook type from the set, rendering it empty.
Contains | Tests for the existence of a RebarHook type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified RebarHook type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified RebarHook type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
RebarHookTypeSet..::.Clear Method
RebarHookTypeSet Class See Also Send Feedback
Removes every RebarHook type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
RebarHookTypeSet..::.Contains Method
RebarHookTypeSet Class See Also Send Feedback
Tests for the existence of a RebarHook type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The RebarHook type to be searched for.

Return Value

The Contains method returns True if the RebarHook type is within the set, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
RebarHookTypeSet..::.Erase Method
RebarHookTypeSet Class See Also Send Feedback
Removes a specified RebarHook type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarHookType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The RebarHook type to be erased.

Return Value

The number of RebarHook types that were erased from the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
RebarHookTypeSet..::.ForwardIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
RebarHookTypeSet..::.GetEnumerator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
RebarHookTypeSet..::.Insert Method
RebarHookTypeSet Class See Also Send Feedback
Insert the specified RebarHook type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarHookType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarHookType
The RebarHook type to be inserted into the set.

Return Value

Returns whether the RebarHook type was inserted into the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
RebarHookTypeSet..::.ReverseIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Properties

[image] [image]

Revit 2011 API
RebarHookTypeSet Properties
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
RebarHookTypeSet..::.IsEmpty Property
RebarHookTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
RebarHookTypeSet..::.Size Property
RebarHookTypeSet Class See Also Send Feedback
Returns the number of RebarHook types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Class

[image]

Revit 2011 API
RebarHookTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarHook type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RebarHookTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarHookTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarHookTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarHookTypeSetIterator

See Also

RebarHookTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Members

[image] [image]

Revit 2011 API
RebarHookTypeSetIterator Members
RebarHookTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Constructors

Name | Description
RebarHookTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Constructor

[image]

Revit 2011 API
RebarHookTypeSetIterator Constructor
RebarHookTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarHookTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Methods

[image] [image]

Revit 2011 API
RebarHookTypeSetIterator Methods
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
RebarHookTypeSetIterator..::.MoveNext Method
RebarHookTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
RebarHookTypeSetIterator..::.Reset Method
RebarHookTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Properties

[image] [image]

Revit 2011 API
RebarHookTypeSetIterator Properties
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
RebarHookTypeSetIterator..::.Current Property
RebarHookTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHostData Class

[image]

Revit 2011 API
RebarHostData Class
Members See Also Send Feedback
Interface to rebar-specific data stored in each valid rebar host element. The cover parameters listed below are an alternative interface to the CoverType property. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host: CLEAR_COVER_EXTERIOR (walls only) CLEAR_COVER_INTERIOR (walls only) CLEAR_COVER_OTHER (all hosts except in-place families and stairs) CLEAR_COVER (in-place families and stairs) CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs) CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs) RebarHostData can only be created by the factory function "getRebarHostData()" applied to an element that can be a rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarHostData : APIObject
Visual Basic (Declaration)
Public Class RebarHostData _
    Inherits APIObject
Visual C++
public ref class RebarHostData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.DB.Structure Namespace


RebarHostData Members

[image] [image]

Revit 2011 API
RebarHostData Members
RebarHostData Class Methods Properties See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasCoverTypeForReference | Checks whether the reference has an associated cover.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CoverType | Gets the RebarCoverType associated with a face of the element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


RebarHostData Methods

[image] [image]

Revit 2011 API
RebarHostData Methods
RebarHostData Class See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
getRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasCoverTypeForReference | Checks whether the reference has an associated cover.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


getRebarHostData Method

[image]

Revit 2011 API
RebarHostData..::.getRebarHostData Method
RebarHostData Class See Also Send Feedback
Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static RebarHostData getRebarHostData(
    Element host
)
Visual Basic (Declaration)
Public Shared Function getRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ getRebarHostData(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit.DB..::.Element
An element to host rebar.

Return Value

A RebarHostData object or nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) for elements that cannot ever be rebar hosts, such as levels.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


HasCoverTypeForReference Method

[image]

Revit 2011 API
RebarHostData..::.HasCoverTypeForReference Method
RebarHostData Class See Also Send Feedback
Checks whether the reference has an associated cover.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool HasCoverTypeForReference(
    Reference face
)
Visual Basic (Declaration)
Public Function HasCoverTypeForReference ( _
    face As Reference _
) As Boolean
Visual C++
public:
bool HasCoverTypeForReference(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
Reference to a geometrical face of the host element.

Return Value

True if the face has an associated RebarCoverType; false if it does not.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


RebarHostData Properties

[image] [image]

Revit 2011 API
RebarHostData Properties
RebarHostData Class See Also Send Feedback

The RebarHostData type exposes the following members.

Properties

Name | Description
CoverType | Gets the RebarCoverType associated with a face of the element.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Valid | Returns whether the element is a valid rebar host.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


CoverType Property

[image]

Revit 2011 API
RebarHostData..::.CoverType Property
RebarHostData Class See Also Send Feedback
Gets the RebarCoverType associated with a face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarCoverType CoverType[
    Reference face
] { get; set; }
Visual Basic (Declaration)
Public Property CoverType ( _
    face As Reference _
) As RebarCoverType
Visual C++
public:
property RebarCoverType^ CoverType[Reference^ face] {
    RebarCoverType^ get (Reference^ face);
    void set (Reference^ face, RebarCoverType^ value);
}

Parameters

face
Type: Autodesk.Revit.DB..::.Reference
Reference to a geometrical face of the host element.

Remarks

Only certain references have associated covers. The reference must be a face. Further, certain faces do not have covers, such as the top face of a beam that is joined to a slab, and the treads and risers of Stairs.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


Valid Property

[image]

Revit 2011 API
RebarHostData..::.Valid Property
RebarHostData Class See Also Send Feedback
Returns whether the element is a valid rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Valid { get; }
Visual Basic (Declaration)
Public ReadOnly Property Valid As Boolean
Visual C++
public:
property bool Valid {
    bool get ();
}

Remarks

If getRebarHostData() returns an invalid RebarHostData, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if getRebarHostData() returns nullNothingnullptra null reference (Nothing in Visual Basic), the element cannot be made into a rebar host.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


RebarLayoutRule Enumeration

[image]

Revit 2011 API
RebarLayoutRule Enumeration
See Also Send Feedback
The rule for how the rebars in rebar set are laid out

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarLayoutRule
Visual Basic (Declaration)
Public Enumeration RebarLayoutRule
Visual C++
public enum class RebarLayoutRule

Members

Member name | Description
Single | It is a single rebar and not a rebar set.
FixedNumber | The spacing between the rebar is adjustable, but the number of bars is constant based on input.
MaximumSpacing | The maximum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set.
NumberWithSpacing | Both the spacing between rebar and the number of rebar are constant based on input.
MinimumClearSpacing | The minimum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set. This spacing is maintained even if the rebar size changes.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShape Class

[image]

Revit 2011 API
RebarShape Class
Members See Also Send Feedback
RebarShape specifies the shape type for a Rebar instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShape : ElementType
Visual Basic (Declaration)
Public Class RebarShape _
    Inherits ElementType
Visual C++
public ref class RebarShape : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.RebarShape

See Also

RebarShape Members
Autodesk.Revit.DB.Structure Namespace


RebarShape Members

[image] [image]

Revit 2011 API
RebarShape Members
RebarShape Class Methods Properties See Also Send Feedback

The RebarShape type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Definition | Get the shape definition object associated with this shape.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Methods

[image] [image]

Revit 2011 API
RebarShape Methods
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
NewDefinitionByArc | Create a shape definition by arc, and associate it with this shape.
NewDefinitionBySegments | Create a shape definition by segments, and associate it with this shape.
SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetAllowed Method

[image]

Revit 2011 API
RebarShape..::.GetAllowed Method
RebarShape Class See Also Send Feedback
Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool GetAllowed(
    RebarBarType barType
)
Visual Basic (Declaration)
Public Function GetAllowed ( _
    barType As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
A bar type in the same document as this shape.

Return Value

True if this shape may be combined with this barType.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetAllRebarShapeParameters Method

[image]

Revit 2011 API
RebarShape..::.GetAllRebarShapeParameters Method
RebarShape Class See Also Send Feedback
List all shape parameters used by all the existing RebarShapes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static DefinitionsBase GetAllRebarShapeParameters(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As DefinitionsBase
Visual C++
public:
static DefinitionsBase^ GetAllRebarShapeParameters(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
A Revit document.

Return Value

A list of parameters.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetCurvesForBrowser Method

[image]

Revit 2011 API
RebarShape..::.GetCurvesForBrowser Method
RebarShape Class See Also Send Feedback
Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray GetCurvesForBrowser()
Visual Basic (Declaration)
Public Function GetCurvesForBrowser As CurveArray
Visual C++
public:
CurveArray^ GetCurvesForBrowser()

Return Value

An array of curves representing the shape with its default parameters.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


NewDefinitionByArc Method

[image]

Revit 2011 API
RebarShape..::.NewDefinitionByArc Method
RebarShape Class See Also Send Feedback
Create a shape definition by arc, and associate it with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionByArc NewDefinitionByArc()
Visual Basic (Declaration)
Public Function NewDefinitionByArc As RebarShapeDefinitionByArc
Visual C++
public:
RebarShapeDefinitionByArc^ NewDefinitionByArc()

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


NewDefinitionBySegments Method

[image]

Revit 2011 API
RebarShape..::.NewDefinitionBySegments Method
RebarShape Class See Also Send Feedback
Create a shape definition by segments, and associate it with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionBySegments NewDefinitionBySegments(
    int numSegments
)
Visual Basic (Declaration)
Public Function NewDefinitionBySegments ( _
    numSegments As Integer _
) As RebarShapeDefinitionBySegments
Visual C++
public:
RebarShapeDefinitionBySegments^ NewDefinitionBySegments(
    int numSegments
)

Parameters

numSegments
Type: System..::.Int32
The number of straight segments in the shape definition. This cannot be changed after the definition object is created.

Remarks

The returned value of this function and the returned value from Definition::get() are references to the same object.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SetAllowed Method

[image]

Revit 2011 API
RebarShape..::.SetAllowed Method
RebarShape Class See Also Send Feedback
Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic (Declaration)
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed(
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::.RebarBarType
A bar type in the same document as this shape.
allowed
Type: System..::.Boolean
Whether this shape may be combined with barType.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Properties

[image] [image]

Revit 2011 API
RebarShape Properties
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Definition | Get the shape definition object associated with this shape.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
HookAngle | Get and set the hook angle.
HookOrientation | Get and set the hook orientation.
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
RebarStyle | Access the rebar style.
SameShapeIgnoringHooks | Test whether two shapes have equivalent definitions.
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


Definition Property

[image]

Revit 2011 API
RebarShape..::.Definition Property
RebarShape Class See Also Send Feedback
Get the shape definition object associated with this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinition Definition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Definition As RebarShapeDefinition
Visual C++
public:
property RebarShapeDefinition^ Definition {
    RebarShapeDefinition^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) until one of the factory methods (e.g. NewDefinitionBySegments()) is called.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


HookAngle Property

[image]

Revit 2011 API
RebarShape..::.HookAngle Property
RebarShape Class See Also Send Feedback
Get and set the hook angle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int HookAngle[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
property int HookAngle[int index] {
    int get (int index);
    void set (int index, int value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

The hook angle is expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


HookOrientation Property

[image]

Revit 2011 API
RebarShape..::.HookOrientation Property
RebarShape Class See Also Send Feedback
Get and set the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarHookOrientation HookOrientation[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property HookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
property RebarHookOrientation HookOrientation[int index] {
    RebarHookOrientation get (int index);
    void set (int index, RebarHookOrientation value);
}

Parameters

index
Type: System..::.Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Orientation is 1 for the left side of the shape or -1 for the right side. For arc-driven shapes, 1 is for the inside of the arc, -1 for the outside.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
RebarShape..::.Parameter Property
RebarShape Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

RebarShape Class
RebarShape Members
Autodesk.Revit.DB.Structure Namespace


RebarStyle Property

[image]

Revit 2011 API
RebarShape..::.RebarStyle Property
RebarShape Class See Also Send Feedback
Access the rebar style.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarStyle RebarStyle { get; set; }
Visual Basic (Declaration)
Public Property RebarStyle As RebarStyle
Visual C++
public:
property RebarStyle RebarStyle {
    RebarStyle get ();
    void set (RebarStyle value);
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SameShapeIgnoringHooks Property

[image]

Revit 2011 API
RebarShape..::.SameShapeIgnoringHooks Property
RebarShape Class See Also Send Feedback
Test whether two shapes have equivalent definitions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SameShapeIgnoringHooks[
    RebarShape otherShape
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property SameShapeIgnoringHooks ( _
    otherShape As RebarShape _
) As Boolean
Visual C++
public:
property bool SameShapeIgnoringHooks[RebarShape^ otherShape] {
    bool get (RebarShape^ otherShape);
}

Parameters

otherShape
Type: Autodesk.Revit.DB.Structure..::.RebarShape
Another shape to be compared to this one.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SimpleArc Property

[image]

Revit 2011 API
RebarShape..::.SimpleArc Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single arc, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SimpleArc { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimpleArc As Boolean
Visual C++
public:
property bool SimpleArc {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SimpleLine Property

[image]

Revit 2011 API
RebarShape..::.SimpleLine Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single straight segment, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool SimpleLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property SimpleLine As Boolean
Visual C++
public:
property bool SimpleLine {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeArcReferenceType Enumeration

[image]

Revit 2011 API
RebarShapeArcReferenceType Enumeration
See Also Send Feedback
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account, by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarShapeArcReferenceType
Visual Basic (Declaration)
Public Enumeration RebarShapeArcReferenceType
Visual C++
public enum class RebarShapeArcReferenceType

Members

Member name | Description
Internal | Measure to the interior of the bend.
Centerline | Measure to the centerline of the bar.
External | Measure to the exterior of the bend.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeBendAngle Enumeration

[image]

Revit 2011 API
RebarShapeBendAngle Enumeration
See Also Send Feedback
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarShapeBendAngle
Visual Basic (Declaration)
Public Enumeration RebarShapeBendAngle
Visual C++
public enum class RebarShapeBendAngle

Members

Member name | Description
Acute | The angle is less than 90 degrees.
Right | The angle is 90 degrees.
Obtuse | The angle is between 90 and 180 degrees.
Reversal | The angle is 180 degrees; the bar bends back on itself.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Class

[image]

Revit 2011 API
RebarShapeDefinition Class
Members See Also Send Feedback
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition. The definition object is created by one of the factory methods on RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinition : APIObject
Visual Basic (Declaration)
Public Class RebarShapeDefinition _
    Inherits APIObject
Visual C++
public ref class RebarShapeDefinition : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinition Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Members

[image] [image]

Revit 2011 API
RebarShapeDefinition Members
RebarShapeDefinition Class Methods Properties See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Methods

[image] [image]

Revit 2011 API
RebarShapeDefinition Methods
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

Name | Description
AddFormulaParameter | Add a formula-driven parameter to the shape definition.
AddParameter | Add a parameter to the shape definition.
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


AddFormulaParameter Method

[image]

Revit 2011 API
RebarShapeDefinition..::.AddFormulaParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter AddFormulaParameter(
    ExternalDefinition param,
    string formula
)
Visual Basic (Declaration)
Public Function AddFormulaParameter ( _
    param As ExternalDefinition, _
    formula As String _
) As Parameter
Visual C++
public:
Parameter^ AddFormulaParameter(
    ExternalDefinition^ param,
    String^ formula
)

Parameters

param
Type: Autodesk.Revit.DB..::.ExternalDefinition
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
formula
Type: System..::.String

Return Value

The new formula-driven shape parameter.

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


AddParameter Method

[image]

Revit 2011 API
RebarShapeDefinition..::.AddParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public Parameter AddParameter(
    ExternalDefinition param,
    double defaultValue
)
Visual Basic (Declaration)
Public Function AddParameter ( _
    param As ExternalDefinition, _
    defaultValue As Double _
) As Parameter
Visual C++
public:
Parameter^ AddParameter(
    ExternalDefinition^ param,
    double defaultValue
)

Parameters

param
Type: Autodesk.Revit.DB..::.ExternalDefinition
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
defaultValue
Type: System..::.Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.

Remarks

Shape parameters must be shared parameters and have value type double. A parameter must be added with AddParameter() before it can be used to drive the shape with the various AddConstraint() functions. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


CheckDefaultParameterValues Method

[image]

Revit 2011 API
RebarShapeDefinition..::.CheckDefaultParameterValues Method
RebarShapeDefinition Class See Also Send Feedback
Check that the shape can be solved with the default parameter values.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)
Visual Basic (Declaration)
Public Function CheckDefaultParameterValues ( _
    bendRadius As Double, _
    barDiam As Double _
) As Boolean
Visual C++
public:
bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiam
)

Parameters

bendRadius
Type: System..::.Double
A value for the Bend Radius parameter. Zero is allowed.
barDiam
Type: System..::.Double
A value for the Bar Diameter parameter. Zero is allowed.

Return Value

True if the rebar can be solved with the default parameter values and the given bend radius and bar diameter; false if it cannot.

Remarks

This function runs the rebar solver with the default parameter values. If it fails (returns false), rebar instances of this shape will not work. This may be from the default parameters being inconsistent, or from some error in the shape definition. The solver requires a specific bend radius and bar diameter, and the result depends on these values, but in practice they usually do not affect the result of this function as long as they are small. It is legal to pass 0.0 for both arguments. The definition must be Complete in order for this function to succeed. This function can be called before or after Commit().

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


Commit Method

[image]

Revit 2011 API
RebarShapeDefinition..::.Commit Method
RebarShapeDefinition Class See Also Send Feedback
Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit()

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Properties

[image] [image]

Revit 2011 API
RebarShapeDefinition Properties
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


Complete Property

[image]

Revit 2011 API
RebarShapeDefinition..::.Complete Property
RebarShapeDefinition Class See Also Send Feedback
Report whether the shape definition is fully constrained.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Complete { get; }
Visual Basic (Declaration)
Public ReadOnly Property Complete As Boolean
Visual C++
public:
property bool Complete {
    bool get ();
}

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Class

[image]

Revit 2011 API
RebarShapeDefinitionByArc Class
Members See Also Send Feedback
Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Members

[image] [image]

Revit 2011 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Methods Properties See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Methods

[image] [image]

Revit 2011 API
RebarShapeDefinitionByArc Methods
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

Name | Description
AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
AddConstraintRadius | Specify a parameter to drive the radius of the shape.
AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintArcLength Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintArcLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintArcLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintArcLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintArcLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintChordLength Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintChordLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintChordLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintChordLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintChordLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The chord length is measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintCircumference Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintCircumference Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the circumference of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintCircumference(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintCircumference ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintCircumference(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.DB.Structure..::.RebarShapeArcReferenceType
Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintDiameter Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintDiameter Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintDiameter(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintDiameter ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.DB.Structure..::.RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintRadius Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintRadius Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the radius of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintRadius(
    Parameter param,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic (Declaration)
Public Sub AddConstraintRadius ( _
    param As Parameter, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintRadius(
    Parameter^ param,
    RebarShapeArcReferenceType arcRefType
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
arcRefType
Type: Autodesk.Revit.DB.Structure..::.RebarShapeArcReferenceType
Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintSagittaLength Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.AddConstraintSagittaLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintSagittaLength(
    Parameter param
)
Visual Basic (Declaration)
Public Sub AddConstraintSagittaLength ( _
    param As Parameter _
)
Visual C++
public:
void AddConstraintSagittaLength(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

The sagitta will be measured on the centerline of the bar.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


SetArcTypeSpiral Method

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.SetArcTypeSpiral Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Set the RebarShapeDefinitionByArc.Type property to Spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)
Visual Basic (Declaration)
Public Sub SetArcTypeSpiral ( _
    height As Double, _
    pitch As Double, _
    baseFinishingTurns As Integer, _
    topFinishingTurns As Integer _
)
Visual C++
public:
void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)

Parameters

height
Type: System..::.Double
The height of the spiral (assuming the spiral is vertical).
pitch
Type: System..::.Double
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns
Type: System..::.Int32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns
Type: System..::.Int32
The number of finishing turns at the upper end of the spiral.

Remarks

In order to create a spiral definition, you must provide default values for the spiral-specific parameters.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Properties

[image] [image]

Revit 2011 API
RebarShapeDefinitionByArc Properties
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


Type Property

[image]

Revit 2011 API
RebarShapeDefinitionByArc..::.Type Property
RebarShapeDefinitionByArc Class See Also Send Feedback
Among those rebar shapes defined by an arc, specify which kind.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeDefinitionByArcType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As RebarShapeDefinitionByArcType
Visual C++
public:
property RebarShapeDefinitionByArcType Type {
    RebarShapeDefinitionByArcType get ();
    void set (RebarShapeDefinitionByArcType value);
}

Remarks

This property may be explicitly set to Arc or LappedCircle. But to set the property to Spiral, you must call SetArcTypeSpiral() and provide default values for the height, pitch, and finishing turns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | When setting this property: The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArcType Enumeration

[image]

Revit 2011 API
RebarShapeDefinitionByArcType Enumeration
See Also Send Feedback
A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarShapeDefinitionByArcType
Visual Basic (Declaration)
Public Enumeration RebarShapeDefinitionByArcType
Visual C++
public enum class RebarShapeDefinitionByArcType

Members

Member name | Description
Arc | An arc, subtending an angle less than 360 degrees.
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Spiral | A helical bar. The extent of the helix is determined by the Rebar properties Height and Pitch.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Class

[image]

Revit 2011 API
RebarShapeDefinitionBySegments Class
Members See Also Send Feedback
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeDefinitionBySegments : RebarShapeDefinition
Visual Basic (Declaration)
Public Class RebarShapeDefinitionBySegments _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition

Remarks

The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (n-1). Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are: (1) A fixed direction together with a parallel length constraint; (2) A parallel length constraint plus another length constraint parallel to the x-axis or y-axis; (3) A parallel length constraint plus length constraints parallel to both the x-axis and y-axis. Multiple constraints may be driven by the same parameter, even on the same segment. Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment. A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter. A 180-degree bend is described by introducing an extra segment in between the two straight segments, tangent to the midpoint of the bend.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeDefinition
Autodesk.Revit.DB.Structure..::.RebarShapeDefinitionBySegments

See Also

RebarShapeDefinitionBySegments Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Members

[image] [image]

Revit 2011 API
RebarShapeDefinitionBySegments Members
RebarShapeDefinitionBySegments Class Methods Properties See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfSegments | The number of straight segments in this shape.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Methods

[image] [image]

Revit 2011 API
RebarShapeDefinitionBySegments Methods
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

Name | Description
AddBendDefaultRadius | Specify a default-radius bend.
AddBendVariableRadius | Specify a variable-radius bend.
AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Commit | Commit the shape definition. Commit will fail with an InvalidOperationException unless the definition is complete. The RebarShape will not appear in the document until it is committed. (Inherited from RebarShapeDefinition.)
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
RemoveParameterFromSegment | Remove constraints from a segment.
SetSegmentAs180DegreeBend | Overloaded. Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.
SetSegmentFixedDirection | Fix the direction of a segment.
SetSegmentVariableDirection | Remove the fixed direction from a segment.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddBendDefaultRadius Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddBendDefaultRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a default-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic (Declaration)
Public Sub AddBendDefaultRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddBendVariableRadius Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddBendVariableRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a variable-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter radiusParam,
    bool measureIncludingBarThickness
)
Visual Basic (Declaration)
Public Sub AddBendVariableRadius ( _
    iSegmentFollowingBend As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    radiusParam As Parameter, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius(
    int iSegmentFollowingBend,
    int turn,
    RebarShapeBendAngle angle,
    Parameter^ radiusParam,
    bool measureIncludingBarThickness
)

Parameters

iSegmentFollowingBend
Type: System..::.Int32
Index of the segment after the bend (1 to NumberOfSegments - 1).
turn
Type: System..::.Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::.RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
radiusParam
Type: Autodesk.Revit.DB..::.Parameter
A parameter defining the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureIncludingBarThickness
Type: System..::.Boolean
If false, the radius is measured to the inside of the bend; if false, it is measured to the outside.

Remarks

You must add a bend between each two segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintParallelToSegment Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddConstraintParallelToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Constrain the length of a segment by parameterizing its length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    Parameter param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment(
    int iSegment,
    Parameter^ param,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintToSegment Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddConstraintToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Add a constraint that helps determine the length of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic (Declaration)
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment(
    int iSegment,
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Type: System..::.Int32
Legal values are 1 and -1. For a fixed-direction segment, this value is ignored. For a variable-direction segment, this value is combined with the constraint length (the nonnegative value associated with 'param') to determine the direction of the segment. For example, a segment whose direction vector lies in the upper-right quadrant of the plane, and whose x-axis projected length is A and whose y-axis projected length is B, could be created by calling: AddConstraintToSegment(iSegment, paramA, 1.0, 0.0, 1, ...) AddConstraintToSegment(iSegment, paramB, 0.0, 1.0, -1, ...)
measureToOutsideOfBend0
Type: System..::.Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::.Boolean
Choose between two possibilities for the second reference of the length dimension.

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionBendToBend Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionBendToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionBendToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionBendToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment.
iEnd0
Type: System..::.Int32
End (0 or 1) of the first segment.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionSegmentToBend Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToBend ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment, which must be perpendicular to the constraint direction.
iSegment1
Type: System..::.Int32
Index of the second segment.
iEnd1
Type: System..::.Int32
End (0 or 1) of the second segment.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionSegmentToSegment Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.AddListeningDimensionSegmentToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    Parameter param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic (Declaration)
Public Sub AddListeningDimensionSegmentToSegment ( _
    param As Parameter, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment(
    Parameter^ param,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
constraintDirCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::.Int32
Index of the first segment (0 to NumberOfSegments - 1).
iSegment1
Type: System..::.Int32
Index of the second segment (0 to NumberOfSegments - 1).

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RemoveParameterFromSegment Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.RemoveParameterFromSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove constraints from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    Parameter param
)
Visual Basic (Declaration)
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    param As Parameter _
)
Visual C++
public:
void RemoveParameterFromSegment(
    int iSegment,
    Parameter^ param
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
param
Type: Autodesk.Revit.DB..::.Parameter
The parameter. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method

[image] [image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend.

Overload List

Name | Description
SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
SetSegmentAs180DegreeBend(Int32, Parameter, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

See Also

RebarShapeDefinitionBySegments Class
RebarShapeDefinitionBySegments Members
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method (Int32)

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentAs180DegreeBend Method (Int32, Parameter, Boolean)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter radiusParam,
    bool measureToOutsideOfBend
)
Visual Basic (Declaration)
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    radiusParam As Parameter, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment,
    Parameter^ radiusParam,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
radiusParam
Type: Autodesk.Revit.DB..::.Parameter
A parameter to define the radius. To obtain this
object, the following calls are required:
Application.OpenSharedParameterFile();
Parameters.DefinitionFile.Groups.get_Item() or .Create(); and
Parameters.DefinitionGroup.Definitions.get_Item() or .Create().
measureToOutsideOfBend
Type: System..::.Boolean
Choose between two possibilities for the references of the length dimension. If false, the references is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace


SetSegmentFixedDirection Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentFixedDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Fix the direction of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic (Declaration)
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX
Type: System..::.Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY
Type: System..::.Double
The y-coordinate of a 2D vector specifying the segment direction.

Remarks

The centerline of the segment will be constrained to be parallel to the vector. The line must have at least one constraint.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


SetSegmentVariableDirection Method

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.SetSegmentVariableDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic (Declaration)
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection(
    int iSegment
)

Parameters

iSegment
Type: System..::.Int32
Index of the segment (0 to NumberOfSegments - 1).

Remarks

The segment's angle will be allowed to vary, with a range of 90 degrees. The line must have at least two constraints.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Properties

[image] [image]

Revit 2011 API
RebarShapeDefinitionBySegments Properties
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Properties

Name | Description
Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
NumberOfSegments | The number of straight segments in this shape.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


NumberOfSegments Property

[image]

Revit 2011 API
RebarShapeDefinitionBySegments..::.NumberOfSegments Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
The number of straight segments in this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfSegments As Integer
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Class

[image]

Revit 2011 API
RebarShapeSet Class
Members See Also Send Feedback
An set that contains rebar shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class RebarShapeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class RebarShapeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarShapeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeSet

See Also

RebarShapeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Members

[image] [image]

Revit 2011 API
RebarShapeSet Members
RebarShapeSet Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSet type exposes the following members.

Constructors

Name | Description
RebarShapeSet | Initializes a new instance of the RebarShapeSet class

Methods

Name | Description
Clear | Removes every rebar shape from the set, rendering it empty.
Contains | Tests for the existence of a rebar shape within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified rebar shape from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified rebar shape into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Constructor

[image]

Revit 2011 API
RebarShapeSet Constructor
RebarShapeSet Class See Also Send Feedback
Initializes a new instance of the RebarShapeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSet()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Methods

[image] [image]

Revit 2011 API
RebarShapeSet Methods
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every rebar shape from the set, rendering it empty.
Contains | Tests for the existence of a rebar shape within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified rebar shape from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified rebar shape into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
RebarShapeSet..::.Clear Method
RebarShapeSet Class See Also Send Feedback
Removes every rebar shape from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
RebarShapeSet..::.Contains Method
RebarShapeSet Class See Also Send Feedback
Tests for the existence of a rebar shape within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarShape
The rebar shape to be searched for.

Return Value

The Contains method returns True if the rebar shape is within the set, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
RebarShapeSet..::.Erase Method
RebarShapeSet Class See Also Send Feedback
Removes a specified rebar shape from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As RebarShape _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarShape
The rebar shape to be erased.

Return Value

The number of rebar shapes that were erased from the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
RebarShapeSet..::.ForwardIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
RebarShapeSet..::.GetEnumerator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
RebarShapeSet..::.Insert Method
RebarShapeSet Class See Also Send Feedback
Insert the specified rebar shape into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarShape item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.RebarShape
The rebar shape to be inserted into the set.

Return Value

Returns whether the rebar shape was inserted into the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
RebarShapeSet..::.ReverseIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Properties

[image] [image]

Revit 2011 API
RebarShapeSet Properties
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
RebarShapeSet..::.IsEmpty Property
RebarShapeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
RebarShapeSet..::.Size Property
RebarShapeSet Class See Also Send Feedback
Returns the number of rebar shapes that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Class

[image]

Revit 2011 API
RebarShapeSetIterator Class
Members See Also Send Feedback
An iterator to a rebar shape set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class RebarShapeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class RebarShapeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarShapeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.RebarShapeSetIterator

See Also

RebarShapeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Members

[image] [image]

Revit 2011 API
RebarShapeSetIterator Members
RebarShapeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Constructors

Name | Description
RebarShapeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Constructor

[image]

Revit 2011 API
RebarShapeSetIterator Constructor
RebarShapeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public RebarShapeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RebarShapeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Methods

[image] [image]

Revit 2011 API
RebarShapeSetIterator Methods
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
RebarShapeSetIterator..::.MoveNext Method
RebarShapeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
RebarShapeSetIterator..::.Reset Method
RebarShapeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Properties

[image] [image]

Revit 2011 API
RebarShapeSetIterator Properties
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
RebarShapeSetIterator..::.Current Property
RebarShapeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarStyle Enumeration

[image]

Revit 2011 API
RebarStyle Enumeration
See Also Send Feedback
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RebarStyle
Visual Basic (Declaration)
Public Enumeration RebarStyle
Visual C++
public enum class RebarStyle

Members

Member name | Description
Standard | A standard or longitudinal bar.
StirrupTie | A stirrup or tie bar.

See Also

Autodesk.Revit.DB.Structure Namespace


SlabFoundationType Enumeration

[image]

Revit 2011 API
SlabFoundationType Enumeration
See Also Send Feedback
SlabFoundation type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum SlabFoundationType
Visual Basic (Declaration)
Public Enumeration SlabFoundationType
Visual C++
public enum class SlabFoundationType

Members

Member name | Description
Slab | SlabFoundationType is Slab.
SlabFoundation | SlabFoundationType is SlabFoundation.
SlabOnGrade | SlabFoundationType is SlabOnGrade.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralConnectionApplyTo Enumeration

[image]

Revit 2011 API
StructuralConnectionApplyTo Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum StructuralConnectionApplyTo
Visual Basic (Declaration)
Public Enumeration StructuralConnectionApplyTo
Visual C++
public enum class StructuralConnectionApplyTo

Members

Member name | Description
BeamsAndBraces | Designate a StructuralConnectionType to apply to beams and braces.
ColumnTop | Designate a StructuralConnectionType to apply to the top of a column.
ColumnBase | Designate a StructuralConnectionType to apply to the base of a column.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Class

[image]

Revit 2011 API
StructuralConnectionType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralConnectionType : ElementType
Visual Basic (Declaration)
Public Class StructuralConnectionType _
    Inherits ElementType
Visual C++
public ref class StructuralConnectionType : public ElementType

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB.Structure..::.StructuralConnectionType

See Also

StructuralConnectionType Members
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Members

[image] [image]

Revit 2011 API
StructuralConnectionType Members
StructuralConnectionType Class Methods Properties See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllStructuralConnectionTypeIds | Collects the ids of all StructuralConnectionTypes in the document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidFamilySymbolId | Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Properties

Name | Description
ApplyTo | Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Methods

[image] [image]

Revit 2011 API
StructuralConnectionType Methods
StructuralConnectionType Class See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Create | Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllStructuralConnectionTypeIds | Collects the ids of all StructuralConnectionTypes in the document.
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
SetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidFamilySymbolId | Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2011 API
StructuralConnectionType..::.Create Method
StructuralConnectionType Class See Also Send Feedback
Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static StructuralConnectionType Create(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    string name,
    ElementId familySymbolId
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    name As String, _
    familySymbolId As ElementId _
) As StructuralConnectionType
Visual C++
public:
static StructuralConnectionType^ Create(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    String^ name,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
applyTo
Type: Autodesk.Revit.DB.Structure..::.StructuralConnectionApplyTo
Specify which type of member this connection type can be applied to.
name
Type: System..::.String
A name for the connection type. It must be unique within the document.
familySymbolId
Type: Autodesk.Revit.DB..::.ElementId
The id of an annotation FamilySymbol. InvalidElementId is allowed. Otherwise, the FamilySymbol must be in the category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo argument.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to applyTo.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


GetAllStructuralConnectionTypeIds Method

[image]

Revit 2011 API
StructuralConnectionType..::.GetAllStructuralConnectionTypeIds Method
StructuralConnectionType Class See Also Send Feedback
Collects the ids of all StructuralConnectionTypes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static void GetAllStructuralConnectionTypeIds(
    Document cda,
    out ICollection<ElementId> ids
)
Visual Basic (Declaration)
Public Shared Sub GetAllStructuralConnectionTypeIds ( _
    cda As Document, _
    <OutAttribute> ByRef ids As ICollection(Of ElementId) _
)
Visual C++
public:
static void GetAllStructuralConnectionTypeIds(
    Document^ cda,
    [OutAttribute] ICollection<ElementId^>^% ids
)

Parameters

cda
Type: Autodesk.Revit.DB..::.Document
ids
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>) %

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


GetFamilySymbolId Method

[image]

Revit 2011 API
StructuralConnectionType..::.GetFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
FamilySymbol of the annotation to use for this connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId GetFamilySymbolId()
Visual Basic (Declaration)
Public Function GetFamilySymbolId As ElementId
Visual C++
public:
ElementId^ GetFamilySymbolId()

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


SetFamilySymbolId Method

[image]

Revit 2011 API
StructuralConnectionType..::.SetFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
FamilySymbol of the annotation to use for this connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void SetFamilySymbolId(
    ElementId familySymbolId
)
Visual Basic (Declaration)
Public Sub SetFamilySymbolId ( _
    familySymbolId As ElementId _
)
Visual C++
public:
void SetFamilySymbolId(
    ElementId^ familySymbolId
)

Parameters

familySymbolId
Type: Autodesk.Revit.DB..::.ElementId

Remarks

The FamilySymbol must be of category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to this type's applyTo property.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


ValidFamilySymbolId Method

[image]

Revit 2011 API
StructuralConnectionType..::.ValidFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static bool ValidFamilySymbolId(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    ElementId familySymbolId
)
Visual Basic (Declaration)
Public Shared Function ValidFamilySymbolId ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    familySymbolId As ElementId _
) As Boolean
Visual C++
public:
static bool ValidFamilySymbolId(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
applyTo
Type: Autodesk.Revit.DB.Structure..::.StructuralConnectionApplyTo
familySymbolId
Type: Autodesk.Revit.DB..::.ElementId

Return Value

True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Connection Symbols" (OST_StructConnectionSymbols) with its "Apply To" parameter set to match the applyTo property. Returns false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Properties

[image] [image]

Revit 2011 API
StructuralConnectionType Properties
StructuralConnectionType Class See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Properties

Name | Description
ApplyTo | Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


ApplyTo Property

[image]

Revit 2011 API
StructuralConnectionType..::.ApplyTo Property
StructuralConnectionType Class See Also Send Feedback
Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralConnectionApplyTo ApplyTo { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplyTo As StructuralConnectionApplyTo
Visual C++
public:
property StructuralConnectionApplyTo ApplyTo {
    StructuralConnectionApplyTo get ();
}

Remarks

The property cannot be changed. Create a new StructuralConnectionType if a different value is needed.

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
StructuralConnectionType..::.Parameter Property
StructuralConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

StructuralConnectionType Class
StructuralConnectionType Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsage Enumeration

[image]

Revit 2011 API
StructuralInstanceUsage Enumeration
See Also Send Feedback
Represents the structural usage of a family instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralInstanceUsage
Visual Basic (Declaration)
Public Enumeration StructuralInstanceUsage
Visual C++
public enum class StructuralInstanceUsage

Members

Member name | Description
Undefined | indicates automatic
Wall | Structural usage is as wall.
Column | Structural usage is as column.
Girder | Structural usage is as girder.
Joist | Structural usage is as joist.
Purlin | Structural usage is as purlin.
Other | Structural usage is as "other".
Brace | Structural usage is as brace.
HorizontalBracing | Structural usage is as horizontal bracing.
KickerBracing | Structural usage is as kicker bracing.
Automatic | Structural usage is automatic.
TrussChord | Structural usage is as truss chord.
TrussWeb | Structural usage is as truss web.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Class

[image]

Revit 2011 API
StructuralInstanceUsageFilter Class
Members See Also Send Feedback
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralInstanceUsageFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class StructuralInstanceUsageFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralInstanceUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.StructuralInstanceUsageFilter

See Also

StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Members

[image] [image]

Revit 2011 API
StructuralInstanceUsageFilter Members
StructuralInstanceUsageFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Constructors

Name | Description
StructuralInstanceUsageFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralUsage | The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor

[image] [image]

Revit 2011 API
StructuralInstanceUsageFilter Constructor
StructuralInstanceUsageFilter Class See Also Send Feedback

Overload List

Name | Description
StructuralInstanceUsageFilter(StructuralInstanceUsage) | Constructs a new instance of a filter to match structural family instances (typically columns,beams or braces) of the given structural usage.
StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) | Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage)

[image]

Revit 2011 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match structural family instances (typically columns,beams or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::.StructuralInstanceUsage
The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)

[image]

Revit 2011 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::.StructuralInstanceUsage
The structural usage to match.
inverted
Type: System..::.Boolean
True if the filter should match all family instances which are not of the given structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Methods

[image] [image]

Revit 2011 API
StructuralInstanceUsageFilter Methods
StructuralInstanceUsageFilter Class See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Properties

[image] [image]

Revit 2011 API
StructuralInstanceUsageFilter Properties
StructuralInstanceUsageFilter Class See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralUsage | The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralUsage Property

[image]

Revit 2011 API
StructuralInstanceUsageFilter..::.StructuralUsage Property
StructuralInstanceUsageFilter Class See Also Send Feedback
The family instance structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralUsage As StructuralInstanceUsage
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
}

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Enumeration

[image]

Revit 2011 API
StructuralMaterialType Enumeration
See Also Send Feedback
Represents the structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralMaterialType
Visual Basic (Declaration)
Public Enumeration StructuralMaterialType
Visual C++
public enum class StructuralMaterialType

Members

Member name | Description
Undefined | Structural material type is undefined.
Steel | Structural material type is steel.
Concrete | Structural material type is concrete.
Wood | Structural material type is wood.
Other | Structural material type is other.
PrecastConcrete | Structural material type is precast concrete.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Class

[image]

Revit 2011 API
StructuralMaterialTypeFilter Class
Members See Also Send Feedback
A filter used to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralMaterialTypeFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class StructuralMaterialTypeFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralMaterialTypeFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.StructuralMaterialTypeFilter

See Also

StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Members

[image] [image]

Revit 2011 API
StructuralMaterialTypeFilter Members
StructuralMaterialTypeFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Constructors

Name | Description
StructuralMaterialTypeFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralMaterialType | The structural material type.

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor

[image] [image]

Revit 2011 API
StructuralMaterialTypeFilter Constructor
StructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

Name | Description
StructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match family instances that have the given structural material type.
StructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor (StructuralMaterialType)

[image]

Revit 2011 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType)
StructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)

[image]

Revit 2011 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
StructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::.StructuralMaterialType
The structural material type to match.
inverted
Type: System..::.Boolean
True if the filter should match all family instances which are not of the given structural material type.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Methods

[image] [image]

Revit 2011 API
StructuralMaterialTypeFilter Methods
StructuralMaterialTypeFilter Class See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Properties

[image] [image]

Revit 2011 API
StructuralMaterialTypeFilter Properties
StructuralMaterialTypeFilter Class See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralMaterialType | The structural material type.

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Property

[image]

Revit 2011 API
StructuralMaterialTypeFilter..::.StructuralMaterialType Property
StructuralMaterialTypeFilter Class See Also Send Feedback
The structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Class

[image]

Revit 2011 API
StructuralSettings Class
Members See Also Send Feedback
Provides access to project-wide structural settings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralSettings : IDisposable
Visual Basic (Declaration)
Public Class StructuralSettings _
    Implements IDisposable
Visual C++
public ref class StructuralSettings : IDisposable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.StructuralSettings

See Also

StructuralSettings Members
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Members

[image] [image]

Revit 2011 API
StructuralSettings Members
StructuralSettings Class Methods Properties See Also Send Feedback

The StructuralSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStructuralSettings | Obtains the StructuralSettings object for the specified project document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
AnalyticalModelCheckZeroAreaOrLength | Whether to check that analytical model has zero area or length.
AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
ShowBraceAbove | Whether to show brace symbols above beams in plan views.
ShowBraceBelow | Whether to show brace symbols below beams in plan views.
SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Methods

[image] [image]

Revit 2011 API
StructuralSettings Methods
StructuralSettings Class See Also Send Feedback

The StructuralSettings type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStructuralSettings | Obtains the StructuralSettings object for the specified project document.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2011 API
StructuralSettings..::.Dispose Method
StructuralSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


GetStructuralSettings Method

[image]

Revit 2011 API
StructuralSettings..::.GetStructuralSettings Method
StructuralSettings Class See Also Send Feedback
Obtains the StructuralSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static StructuralSettings GetStructuralSettings(
    Document doc
)
Visual Basic (Declaration)
Public Shared Function GetStructuralSettings ( _
    doc As Document _
) As StructuralSettings
Visual C++
public:
static StructuralSettings^ GetStructuralSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::.Document
The document.

Return Value

The StructuralSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | doc is a family and does not support Structural Settings.
Autodesk.Revit.Exceptions..::.ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::.IncorrectProductException | The application isn't Autodesk Revit Structure.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Properties

[image] [image]

Revit 2011 API
StructuralSettings Properties
StructuralSettings Class See Also Send Feedback

The StructuralSettings type exposes the following members.

Properties

Name | Description
AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
AnalyticalModelCheckZeroAreaOrLength | Whether to check that analytical model has zero area or length.
AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
ShowBraceAbove | Whether to show brace symbols above beams in plan views.
ShowBraceBelow | Whether to show brace symbols below beams in plan views.
SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAdjustmentTolerance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelAdjustmentTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for the analytical adjustment distance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelAdjustmentTolerance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelAdjustmentTolerance As Double
Visual C++
public:
property double AnalyticalModelAdjustmentTolerance {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAutoCheckConsistency Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelAutoCheckConsistency Property
StructuralSettings Class See Also Send Feedback
Whether to check automatically for consistency between the analytical and physical models.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelAutoCheckConsistency { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelAutoCheckConsistency As Boolean
Visual C++
public:
property bool AnalyticalModelAutoCheckConsistency {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAutoCheckMemberSupports Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelAutoCheckMemberSupports Property
StructuralSettings Class See Also Send Feedback
Whether to check automatically for member supports.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelAutoCheckMemberSupports { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelAutoCheckMemberSupports As Boolean
Visual C++
public:
property bool AnalyticalModelAutoCheckMemberSupports {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckAdjustment Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckAdjustment Property
StructuralSettings Class See Also Send Feedback
Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckAdjustment { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckAdjustment As Boolean
Visual C++
public:
property bool AnalyticalModelCheckAdjustment {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckBeamSlabDistance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckBeamSlabDistance Property
StructuralSettings Class See Also Send Feedback
Whether to check the analytical model distance between beam and slab for a level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckBeamSlabDistance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckBeamSlabDistance As Boolean
Visual C++
public:
property bool AnalyticalModelCheckBeamSlabDistance {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckCircularReferences Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckCircularReferences Property
StructuralSettings Class See Also Send Feedback
Whether to check member supports for circular references.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckCircularReferences { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckCircularReferences As Boolean
Visual C++
public:
property bool AnalyticalModelCheckCircularReferences {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckDiscrepancy Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckDiscrepancy Property
StructuralSettings Class See Also Send Feedback
Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckDiscrepancy { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckDiscrepancy As Boolean
Visual C++
public:
property bool AnalyticalModelCheckDiscrepancy {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckInstability Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckInstability Property
StructuralSettings Class See Also Send Feedback
Whether to check for possible instability based on release conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckInstability { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckInstability As Boolean
Visual C++
public:
property bool AnalyticalModelCheckInstability {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckSupportDistance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckSupportDistance Property
StructuralSettings Class See Also Send Feedback
Check that joins in the physical model are consistent with proximity in the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckSupportDistance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckSupportDistance As Boolean
Visual C++
public:
property bool AnalyticalModelCheckSupportDistance {
    bool get ();
    void set (bool value);
}

Remarks

When this check is enabled, a warning will be given for physically joined members whose analytical curves are more than a certain distance apart. The distance is given by the AnalyticalModelSupportDistanceTolerance property.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckZeroAreaOrLength Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelCheckZeroAreaOrLength Property
StructuralSettings Class See Also Send Feedback
Whether to check that analytical model has zero area or length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckZeroAreaOrLength { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelCheckZeroAreaOrLength As Boolean
Visual C++
public:
property bool AnalyticalModelCheckZeroAreaOrLength {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelDiscrepancyTolerance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelDiscrepancyTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for the analytical-to-physical model distance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelDiscrepancyTolerance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelDiscrepancyTolerance As Double
Visual C++
public:
property double AnalyticalModelDiscrepancyTolerance {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelHorizontalAutofixTolerance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelHorizontalAutofixTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for horizontal auto-detect for the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelHorizontalAutofixTolerance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelHorizontalAutofixTolerance As Double
Visual C++
public:
property double AnalyticalModelHorizontalAutofixTolerance {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupportDistanceTolerance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelSupportDistanceTolerance Property
StructuralSettings Class See Also Send Feedback
The maximum distance between two structural elements, where analytical model support rules still apply.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelSupportDistanceTolerance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelSupportDistanceTolerance As Double
Visual C++
public:
property double AnalyticalModelSupportDistanceTolerance {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelVerticalAutofixTolerance Property

[image]

Revit 2011 API
StructuralSettings..::.AnalyticalModelVerticalAutofixTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for vertical auto-detect for the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelVerticalAutofixTolerance { get; set; }
Visual Basic (Declaration)
Public Property AnalyticalModelVerticalAutofixTolerance As Double
Visual C++
public:
property double AnalyticalModelVerticalAutofixTolerance {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionAreaAndLineSymbolSpacing Property

[image]

Revit 2011 API
StructuralSettings..::.BoundaryConditionAreaAndLineSymbolSpacing Property
StructuralSettings Class See Also Send Feedback
Symbol spacing for boundary conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double BoundaryConditionAreaAndLineSymbolSpacing { get; set; }
Visual Basic (Declaration)
Public Property BoundaryConditionAreaAndLineSymbolSpacing As Double
Visual C++
public:
property double BoundaryConditionAreaAndLineSymbolSpacing {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolFixed Property

[image]

Revit 2011 API
StructuralSettings..::.BoundaryConditionFamilySymbolFixed Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a fixed boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolFixed { get; set; }
Visual Basic (Declaration)
Public Property BoundaryConditionFamilySymbolFixed As ElementId
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolFixed {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolPinned Property

[image]

Revit 2011 API
StructuralSettings..::.BoundaryConditionFamilySymbolPinned Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a pinned boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolPinned { get; set; }
Visual Basic (Declaration)
Public Property BoundaryConditionFamilySymbolPinned As ElementId
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolPinned {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolRoller Property

[image]

Revit 2011 API
StructuralSettings..::.BoundaryConditionFamilySymbolRoller Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a roller boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolRoller { get; set; }
Visual Basic (Declaration)
Public Property BoundaryConditionFamilySymbolRoller As ElementId
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolRoller {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolUserDefined Property

[image]

Revit 2011 API
StructuralSettings..::.BoundaryConditionFamilySymbolUserDefined Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a user-defined boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolUserDefined { get; set; }
Visual Basic (Declaration)
Public Property BoundaryConditionFamilySymbolUserDefined As ElementId
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolUserDefined {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceAboveSymbol Property

[image]

Revit 2011 API
StructuralSettings..::.BraceAboveSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a brace above a beam in plan view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BraceAboveSymbol { get; set; }
Visual Basic (Declaration)
Public Property BraceAboveSymbol As ElementId
Visual C++
public:
property ElementId^ BraceAboveSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceBelowSymbol Property

[image]

Revit 2011 API
StructuralSettings..::.BraceBelowSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a brace below a beam in plan view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId BraceBelowSymbol { get; set; }
Visual Basic (Declaration)
Public Property BraceBelowSymbol As ElementId
Visual C++
public:
property ElementId^ BraceBelowSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceParallelLineOffset Property

[image]

Revit 2011 API
StructuralSettings..::.BraceParallelLineOffset Property
StructuralSettings Class See Also Send Feedback
The distance by which brace symbols in plan views will be offset.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double BraceParallelLineOffset { get; set; }
Visual Basic (Declaration)
Public Property BraceParallelLineOffset As Double
Visual C++
public:
property double BraceParallelLineOffset {
    double get ();
    void set (double value);
}

Remarks

Applies only when BracePlanRepresentation is set to ParallelLine.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


KickerBraceSymbol Property

[image]

Revit 2011 API
StructuralSettings..::.KickerBraceSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a kicker brace.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ElementId KickerBraceSymbol { get; set; }
Visual Basic (Declaration)
Public Property KickerBraceSymbol As ElementId
Visual C++
public:
property ElementId^ KickerBraceSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


ShowBraceAbove Property

[image]

Revit 2011 API
StructuralSettings..::.ShowBraceAbove Property
StructuralSettings Class See Also Send Feedback
Whether to show brace symbols above beams in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowBraceAbove { get; set; }
Visual Basic (Declaration)
Public Property ShowBraceAbove As Boolean
Visual C++
public:
property bool ShowBraceAbove {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


ShowBraceBelow Property

[image]

Revit 2011 API
StructuralSettings..::.ShowBraceBelow Property
StructuralSettings Class See Also Send Feedback
Whether to show brace symbols below beams in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowBraceBelow { get; set; }
Visual Basic (Declaration)
Public Property ShowBraceBelow As Boolean
Visual C++
public:
property bool ShowBraceBelow {
    bool get ();
    void set (bool value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForBeamAndTruss Property

[image]

Revit 2011 API
StructuralSettings..::.SymbolicCutbackForBeamAndTruss Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all beams and trusses.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForBeamAndTruss { get; set; }
Visual Basic (Declaration)
Public Property SymbolicCutbackForBeamAndTruss As Double
Visual C++
public:
property double SymbolicCutbackForBeamAndTruss {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForBrace Property

[image]

Revit 2011 API
StructuralSettings..::.SymbolicCutbackForBrace Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all braces.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForBrace { get; set; }
Visual Basic (Declaration)
Public Property SymbolicCutbackForBrace As Double
Visual C++
public:
property double SymbolicCutbackForBrace {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForColumn Property

[image]

Revit 2011 API
StructuralSettings..::.SymbolicCutbackForColumn Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForColumn { get; set; }
Visual Basic (Declaration)
Public Property SymbolicCutbackForColumn As Double
Visual C++
public:
property double SymbolicCutbackForColumn {
    double get ();
    void set (double value);
}

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralType Enumeration

[image]

Revit 2011 API
StructuralType Enumeration
See Also Send Feedback
Represents the structural type of a family instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum StructuralType
Visual Basic (Declaration)
Public Enumeration StructuralType
Visual C++
public enum class StructuralType

Members

Member name | Description
NonStructural | Non-Structural
Beam | Structural Beam
Brace | Structural Brace
Column | Structural Column
Footing | Structural Footing
UnknownFraming | Unknown Framing

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralWallUsage Enumeration

[image]

Revit 2011 API
StructuralWallUsage Enumeration
See Also Send Feedback
Represents the structural usage of a wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralWallUsage
Visual Basic (Declaration)
Public Enumeration StructuralWallUsage
Visual C++
public enum class StructuralWallUsage

Members

Member name | Description
NonBearing | Structural usage is non-bearing.
Bearing | Structural usage is bearing.
Shear | Structural usage is shear.
Combined | Structural usage is combined.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Class

[image]

Revit 2011 API
StructuralWallUsageFilter Class
Members See Also Send Feedback
A filter used to match walls that have the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class StructuralWallUsageFilter : ElementSlowFilter
Visual Basic (Declaration)
Public Class StructuralWallUsageFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralWallUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.ElementFilter
Autodesk.Revit.DB..::.ElementSlowFilter
Autodesk.Revit.DB.Structure..::.StructuralWallUsageFilter

See Also

StructuralWallUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Members

[image] [image]

Revit 2011 API
StructuralWallUsageFilter Members
StructuralWallUsageFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Constructors

Name | Description
StructuralWallUsageFilter | Overloaded.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralWallUsage | The wall structural usage.

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor

[image] [image]

Revit 2011 API
StructuralWallUsageFilter Constructor
StructuralWallUsageFilter Class See Also Send Feedback

Overload List

Name | Description
StructuralWallUsageFilter(StructuralWallUsage) | Constructs a new instance of a filter to match walls that have the given structural wall usage.
StructuralWallUsageFilter(StructuralWallUsage, Boolean) | Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor (StructuralWallUsage)

[image]

Revit 2011 API
StructuralWallUsageFilter Constructor (StructuralWallUsage)
StructuralWallUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match walls that have the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralWallUsage As StructuralWallUsage _
)
Visual C++
public:
StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage
)

Parameters

structuralWallUsage
Type: Autodesk.Revit.DB.Structure..::.StructuralWallUsage
The wall structural usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)

[image]

Revit 2011 API
StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)
StructuralWallUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)
Visual Basic (Declaration)
Public Sub New ( _
    structuralWallUsage As StructuralWallUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)

Parameters

structuralWallUsage
Type: Autodesk.Revit.DB.Structure..::.StructuralWallUsage
The structural usage to match.
inverted
Type: System..::.Boolean
True if the filter should match all walls which are not of the given structural wall usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Methods

[image] [image]

Revit 2011 API
StructuralWallUsageFilter Methods
StructuralWallUsageFilter Class See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ElementFilter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Properties

[image] [image]

Revit 2011 API
StructuralWallUsageFilter Properties
StructuralWallUsageFilter Class See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Properties

Name | Description
Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
StructuralWallUsage | The wall structural usage.

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsage Property

[image]

Revit 2011 API
StructuralWallUsageFilter..::.StructuralWallUsage Property
StructuralWallUsageFilter Class See Also Send Feedback
The wall structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsage StructuralWallUsage { get; }
Visual Basic (Declaration)
Public ReadOnly Property StructuralWallUsage As StructuralWallUsage
Visual C++
public:
property StructuralWallUsage StructuralWallUsage {
    StructuralWallUsage get ();
}

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


TranslationRotationValue Enumeration

[image]

Revit 2011 API
TranslationRotationValue Enumeration
See Also Send Feedback
Values for BoundaryConditions Translation and Rotation parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TranslationRotationValue
Visual Basic (Declaration)
Public Enumeration TranslationRotationValue
Visual C++
public enum class TranslationRotationValue

Members

Member name | Description
Fixed | TranslationRotationValue is Fixed.
Release | TranslationRotationValue is Release.
Spring | TranslationRotationValue is Spring.

See Also

Autodesk.Revit.DB.Structure Namespace


Truss Class

[image]

Revit 2011 API
Truss Class
Members See Also Send Feedback
Represents all kinds of Trusses.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Truss : Element
Visual Basic (Declaration)
Public Class Truss _
    Inherits Element
Visual C++
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB.Structure..::.Truss

See Also

Truss Members
Autodesk.Revit.DB.Structure Namespace


Truss Members

[image] [image]

Revit 2011 API
Truss Members
Truss Class Methods Properties See Also Send Feedback

The Truss type exposes the following members.

Methods

Name | Description
AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DetachChord | Detach a truss's specific chord from the element to which it is attached.
Dispose | (Inherited from Element.)
DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Get all the truss curves.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Get all the members of truss.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TrussType | Retrieve/set an object that represents the type of the truss.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Truss Methods

[image] [image]

Revit 2011 API
Truss Methods
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Methods

Name | Description
AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
DetachChord | Detach a truss's specific chord from the element to which it is attached.
Dispose | (Inherited from Element.)
DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetTrussMemberInfo | Query if a given element is a member of a truss,its lock status and its usage,etc.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
RemoveProfile | Remove the profile of a truss.
SetProfile | Add or modify the profile of a truss.
TogglePinMember | Pin/Unpin a truss member.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


AttachChord Method

[image]

Revit 2011 API
Truss..::.AttachChord Method
Truss Class See Also Send Feedback
Attach a truss's specific chord to a specified element, the element should be a roof or floor.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void AttachChord(
    Element attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)
Visual Basic (Declaration)
Public Sub AttachChord ( _
    attachToElement As Element, _
    location As TrussChordLocation, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachChord(
    Element^ attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)

Parameters

attachToElement
Type: Autodesk.Revit.DB..::.Element
The element to which the truss's chord will attach. The element should be a roof or floor.
location
Type: Autodesk.Revit.DB.Structure..::.TrussChordLocation
The chord need to be attached.
forceRemoveSketch
Type: System..::.Boolean
Whether to detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


DetachChord Method

[image]

Revit 2011 API
Truss..::.DetachChord Method
Truss Class See Also Send Feedback
Detach a truss's specific chord from the element to which it is attached.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void DetachChord(
    TrussChordLocation location
)
Visual Basic (Declaration)
Public Sub DetachChord ( _
    location As TrussChordLocation _
)
Visual C++
public:
void DetachChord(
    TrussChordLocation location
)

Parameters

location
Type: Autodesk.Revit.DB.Structure..::.TrussChordLocation
The chord.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


DropTruss Method

[image]

Revit 2011 API
Truss..::.DropTruss Method
Truss Class See Also Send Feedback
Drop truss Family, it will disassociate all members from the truss and delete the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static void DropTruss(
    Truss truss
)
Visual Basic (Declaration)
Public Shared Sub DropTruss ( _
    truss As Truss _
)
Visual C++
public:
static void DropTruss(
    Truss^ truss
)

Parameters

truss
Type: Autodesk.Revit.DB.Structure..::.Truss
The truss to be dropped.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


GetTrussMemberInfo Method

[image]

Revit 2011 API
Truss..::.GetTrussMemberInfo Method
Truss Class See Also Send Feedback
Query if a given element is a member of a truss,its lock status and its usage,etc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ElementId elemId
)
Visual Basic (Declaration)
Public Function GetTrussMemberInfo ( _
    elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::.ElementId
The querying element.

Return Value

A struct TrussMemberInfo that contains the querying element's host truss,whether lock to the truss,usage type,etc.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


RemoveProfile Method

[image]

Revit 2011 API
Truss..::.RemoveProfile Method
Truss Class See Also Send Feedback
Remove the profile of a truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void RemoveProfile()
Visual Basic (Declaration)
Public Sub RemoveProfile
Visual C++
public:
void RemoveProfile()

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


SetProfile Method

[image]

Revit 2011 API
Truss..::.SetProfile Method
Truss Class See Also Send Feedback
Add or modify the profile of a truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic (Declaration)
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile(
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
Type: Autodesk.Revit.DB..::.CurveArray
The curves serving as top chords of the truss.
bottomChords
Type: Autodesk.Revit.DB..::.CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


TogglePinMember Method

[image]

Revit 2011 API
Truss..::.TogglePinMember Method
Truss Class See Also Send Feedback
Pin/Unpin a truss member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public void TogglePinMember(
    ElementId elemId
)
Visual Basic (Declaration)
Public Sub TogglePinMember ( _
    elemId As ElementId _
)
Visual C++
public:
void TogglePinMember(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::.ElementId
The member element is going to pin/unpin.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Truss Properties

[image] [image]

Revit 2011 API
Truss Properties
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Curves | Get all the truss curves.
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Members | Get all the members of truss.
Name | A human readable name for the Element. (Inherited from Element.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
TrussType | Retrieve/set an object that represents the type of the truss.
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2011 API
Truss..::.Curves Property
Truss Class See Also Send Feedback
Get all the truss curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic (Declaration)
Public ReadOnly Property Curves As CurveArray
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

The Curves property returns a CurveArray that contains all the truss curves.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Members Property

[image]

Revit 2011 API
Truss..::.Members Property
Truss Class See Also Send Feedback
Get all the members of truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ICollection<ElementId> Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As ICollection(Of ElementId)
Visual C++
public:
property ICollection<ElementId^>^ Members {
    ICollection<ElementId^>^ get ();
}

Return Value

The Members property returns an ElementIdSet that contains all the member Ids of truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
Truss..::.Parameter Property
Truss Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

Truss Class
Truss Members
Autodesk.Revit.DB.Structure Namespace


TrussType Property

[image]

Revit 2011 API
Truss..::.TrussType Property
Truss Class See Also Send Feedback
Retrieve/set an object that represents the type of the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussType TrussType { get; set; }
Visual Basic (Declaration)
Public Property TrussType As TrussType
Visual C++
public:
property TrussType^ TrussType {
    TrussType^ get ();
    void set (TrussType^ value);
}

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


TrussChordLocation Enumeration

[image]

Revit 2011 API
TrussChordLocation Enumeration
See Also Send Feedback
This enumerated type represents the options for the Truss Chord Location.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TrussChordLocation
Visual Basic (Declaration)
Public Enumeration TrussChordLocation
Visual C++
public enum class TrussChordLocation

Members

Member name | Description
Bottom | The bottom chord of the Truss.
Top | The top chord of the Truss.

See Also

Autodesk.Revit.DB.Structure Namespace


TrussCurveType Enumeration

[image]

Revit 2011 API
TrussCurveType Enumeration
See Also Send Feedback
Types of curves created in truss families.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TrussCurveType
Visual Basic (Declaration)
Public Enumeration TrussCurveType
Visual C++
public enum class TrussCurveType

Members

Member name | Description
NonTrussCurve |
TopChord |
BottomChord |
Web |

See Also

Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Class

[image]

Revit 2011 API
TrussMemberInfo Class
Members See Also Send Feedback
Provides access to the information of a truss member in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TrussMemberInfo
Visual Basic (Declaration)
Public Class TrussMemberInfo
Visual C++
public ref class TrussMemberInfo

Remarks

A struct TrussMemberInfo that contains an element's host truss,whether lock to the truss,usage type,etc.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB.Structure..::.TrussMemberInfo

See Also

TrussMemberInfo Members
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Members

[image] [image]

Revit 2011 API
TrussMemberInfo Members
TrussMemberInfo Class Constructors Methods Properties See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Constructors

Name | Description
TrussMemberInfo | For Internal Use Only.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
hostTrussId | The host truss' Autodesk::Revit::DB::ElementId^ of the member.
lockedToTruss | Whether the member locked to the host truss.
memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Constructor

[image]

Revit 2011 API
TrussMemberInfo Constructor
TrussMemberInfo Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussMemberInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussMemberInfo()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Methods

[image] [image]

Revit 2011 API
TrussMemberInfo Methods
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Properties

[image] [image]

Revit 2011 API
TrussMemberInfo Properties
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Properties

Name | Description
hostTrussId | The host truss' Autodesk::Revit::DB::ElementId^ of the member.
lockedToTruss | Whether the member locked to the host truss.
memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


hostTrussId Property

[image]

Revit 2011 API
TrussMemberInfo..::.hostTrussId Property
TrussMemberInfo Class See Also Send Feedback
The host truss' Autodesk::Revit::DB::ElementId^ of the member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public ElementId hostTrussId { get; set; }
Visual Basic (Declaration)
Public Property hostTrussId As ElementId
Visual C++
public:
property ElementId^ hostTrussId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


lockedToTruss Property

[image]

Revit 2011 API
TrussMemberInfo..::.lockedToTruss Property
TrussMemberInfo Class See Also Send Feedback
Whether the member locked to the host truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool lockedToTruss { get; set; }
Visual Basic (Declaration)
Public Property lockedToTruss As Boolean
Visual C++
public:
property bool lockedToTruss {
    bool get ();
    void set (bool value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


memberTypeKey Property

[image]

Revit 2011 API
TrussMemberInfo..::.memberTypeKey Property
TrussMemberInfo Class See Also Send Feedback
Kind of the member in the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussMemberType memberTypeKey { get; set; }
Visual Basic (Declaration)
Public Property memberTypeKey As TrussMemberType
Visual C++
public:
property TrussMemberType memberTypeKey {
    TrussMemberType get ();
    void set (TrussMemberType value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberType Enumeration

[image]

Revit 2011 API
TrussMemberType Enumeration
See Also Send Feedback
Indicates the "kind" of a truss member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum TrussMemberType
Visual Basic (Declaration)
Public Enumeration TrussMemberType
Visual C++
public enum class TrussMemberType

Members

Member name | Description
ETK_Unknown | Unknown element type.
ETK_TrussTopChord | Truss top chord.
ETK_TrussBottomChord | Truss bottom chord.
ETK_TrussVertWeb | Truss VertWeb.
ETK_TrussDiagWeb | Truss DiagWeb.

See Also

Autodesk.Revit.DB.Structure Namespace


TrussType Class

[image]

Revit 2011 API
TrussType Class
Members See Also Send Feedback
Represents a specific type of truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TrussType : FamilySymbol
Visual Basic (Declaration)
Public Class TrussType _
    Inherits FamilySymbol
Visual C++
public ref class TrussType : public FamilySymbol

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.Element
Autodesk.Revit.DB..::.ElementType
Autodesk.Revit.DB..::.InsertableObject
Autodesk.Revit.DB..::.FamilySymbol
Autodesk.Revit.DB.Structure..::.TrussType

See Also

TrussType Members
Autodesk.Revit.DB.Structure Namespace


TrussType Members

[image] [image]

Revit 2011 API
TrussType Members
TrussType Class Methods Properties See Also Send Feedback

The TrussType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


TrussType Methods

[image] [image]

Revit 2011 API
TrussType Methods
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Methods

Name | Description
CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element.)
ChangeTypeId | Changes type of the element. (Inherited from Element.)
Dispose | (Inherited from Element.)
Duplicate | Duplicate this object. (Inherited from ElementType.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element.)
IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
IsValidType | Checks if given type is valid for this element. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


TrussType Properties

[image] [image]

Revit 2011 API
TrussType Properties
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Properties

Name | Description
BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Document | Returns the Document in which the Element resides. (Inherited from Element.)
Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Materials | Get all materials present in the element. (Inherited from Element.)
Name | Set the name for the ElementType. (Inherited from ElementType.)
ObjectType | Obsolete. Returns the instance type of this object. (Inherited from Element.)
OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Parameter | Overloaded. Retrieves a parameter from the element given an identifier.
Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
PhaseCreated | An object representing the phase when the element is created. (Inherited from Element.)
PhaseDemolished | An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
SimilarObjectTypes | Obsolete. Returns the types being similar to the current instance. (Inherited from Element.)
StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2011 API
TrussType..::.Parameter Property
TrussType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

Name | Description
Parameter[([(BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Parameter[([(Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Parameter[([(Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Parameter[([(String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)

See Also

TrussType Class
TrussType Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Class

[image]

Revit 2011 API
TrussTypeSet Class
Members See Also Send Feedback
A set that contains Truss types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class TrussTypeSet : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class TrussTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TrussTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.TrussTypeSet

See Also

TrussTypeSet Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Members

[image] [image]

Revit 2011 API
TrussTypeSet Members
TrussTypeSet Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSet type exposes the following members.

Constructors

Name | Description
TrussTypeSet | Initializes a new instance of the TrussTypeSet class

Methods

Name | Description
Clear | Removes every Truss type from the set, rendering it empty.
Contains | Tests for the existence of a Truss type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified Truss type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified Truss type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Constructor

[image]

Revit 2011 API
TrussTypeSet Constructor
TrussTypeSet Class See Also Send Feedback
Initializes a new instance of the TrussTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussTypeSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSet()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Methods

[image] [image]

Revit 2011 API
TrussTypeSet Methods
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Methods

Name | Description
Clear | Removes every Truss type from the set, rendering it empty.
Contains | Tests for the existence of a Truss type within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified Truss type from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified Truss type into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2011 API
TrussTypeSet..::.Clear Method
TrussTypeSet Class See Also Send Feedback
Removes every Truss type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2011 API
TrussTypeSet..::.Contains Method
TrussTypeSet Class See Also Send Feedback
Tests for the existence of a Truss type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.TrussType
The Truss type to be searched for.

Return Value

The Contains method returns True if the Truss type is within the set, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2011 API
TrussTypeSet..::.Erase Method
TrussTypeSet Class See Also Send Feedback
Removes a specified Truss type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As TrussType _
) As Integer
Visual C++
public:
virtual int Erase(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.TrussType
The Truss type to be erased.

Return Value

The number of Truss types that were erased from the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2011 API
TrussTypeSet..::.ForwardIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2011 API
TrussTypeSet..::.GetEnumerator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2011 API
TrussTypeSet..::.Insert Method
TrussTypeSet Class See Also Send Feedback
Insert the specified Truss type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    TrussType item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::.TrussType
The Truss type to be inserted into the set.

Return Value

Returns whether the Truss type was inserted into the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2011 API
TrussTypeSet..::.ReverseIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Properties

[image] [image]

Revit 2011 API
TrussTypeSet Properties
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2011 API
TrussTypeSet..::.IsEmpty Property
TrussTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2011 API
TrussTypeSet..::.Size Property
TrussTypeSet Class See Also Send Feedback
Returns the number of Truss types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Class

[image]

Revit 2011 API
TrussTypeSetIterator Class
Members See Also Send Feedback
An iterator to a Truss type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class TrussTypeSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class TrussTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TrussTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB.Structure..::.TrussTypeSetIterator

See Also

TrussTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Members

[image] [image]

Revit 2011 API
TrussTypeSetIterator Members
TrussTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Constructors

Name | Description
TrussTypeSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Constructor

[image]

Revit 2011 API
TrussTypeSetIterator Constructor
TrussTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public TrussTypeSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrussTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Methods

[image] [image]

Revit 2011 API
TrussTypeSetIterator Methods
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2011 API
TrussTypeSetIterator..::.MoveNext Method
TrussTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2011 API
TrussTypeSetIterator..::.Reset Method
TrussTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Properties

[image] [image]

Revit 2011 API
TrussTypeSetIterator Properties
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2011 API
TrussTypeSetIterator..::.Current Property
TrussTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Autodesk.Revit.Exceptions Namespace

[image]

Revit 2011 API
Autodesk.Revit.Exceptions Namespace
Send Feedback

Classes

Class | Description
ApplicationException | The exception that is thrown when a non-fatal application error occurs.
ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.
ArgumentNullException | The exception that is thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed to a method that does not accept it as a valid argument.
ArgumentOutOfRangeException | The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.
ArgumentsInconsistentException | The exception that is thrown when each individual argument is OK, but a joint constraint is violated.
AutoJoinFailedException | The exception that is thrown when an autojoin operation failed.
DirectoryNotFoundException | The exception that is thrown when the specified directory could not be found.
FamilyContextException | The exception that is thrown when an operation is invalid in the current family document, because of the type of family.
FileAccessException | The exception that is thrown when the specified file could not be accessed, e.g. read-only, locked by the OS etc.
FileArgumentNotFoundException | The exception that is thrown when a method received a filename as an argument and requires it to exist as a precondition.
FileNotFoundException | The exception that is thrown when the specified file could not be found.
ForbiddenForDynamicUpdateException | The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
FunctionId | The information of a function throwing an exception.
InapplicableDataException | The exception that is thrown when attempting to access a piece of data that is structurally not part of an object at the moment.
IncorrectProductException | The exception that is thrown when the function cannot execute in the current product. The exception specifies which product(s) would let the operation succeed.
InternalException | The exception that is thrown when an issue in the Revit code resulted in an unexpected error.
InvalidDataStreamException | The exception that is thrown when the reading or saving operation failed due to parsing error.
InvalidLicenseException | The exception that is thrown when an operation is denied by the license manager, e.g. save from demo mode.
InvalidObjectException | The exception that is thrown when referencing an [native] object that either no longer exists whose creation was undone (by rolling a transaction back).
InvalidOperationException | The exception that is thrown when a method call is invalid for the object's current state.
InvalidPathArgumentException | The exception that is thrown when a method received a pathname as an argument, but the pathname is illegal: too long, invalid characters, etc.
IOException | The exception that is thrown when an I/O error occurs.
ModificationForbiddenException | The exception that is thrown by the undo transaction framework when a modification operation is not allowed.
ModificationOutsideTransactionException | The exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.
ObjectAccessException | The exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.
OperationCanceledException | The exception that is thrown when an operation is unexpectedly cancelled.
RegenerationFailedException | The exception that is thrown when a regeneration operation failed.


ApplicationException Class

[image]

Revit 2011 API
ApplicationException Class
Members See Also Send Feedback
The exception that is thrown when a non-fatal application error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ApplicationException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ApplicationException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ApplicationException : public Exception

Remarks

This class is the base class of all Revit specified exceptions.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.InternalException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.OperationCanceledException

See Also

ApplicationException Members
Autodesk.Revit.Exceptions Namespace


ApplicationException Members

[image] [image]

Revit 2011 API
ApplicationException Members
ApplicationException Class Methods Properties See Also Send Feedback

The ApplicationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ApplicationException Methods

[image] [image]

Revit 2011 API
ApplicationException Methods
ApplicationException Class See Also Send Feedback

The ApplicationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ApplicationException..::.GetObjectData Method
ApplicationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ApplicationException Properties

[image] [image]

Revit 2011 API
ApplicationException Properties
ApplicationException Class See Also Send Feedback

The ApplicationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


FunctionId Property

[image]

Revit 2011 API
ApplicationException..::.FunctionId Property
ApplicationException Class See Also Send Feedback
The information of the function throwing the exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public FunctionId FunctionId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FunctionId As FunctionId
Visual C++
public:
property FunctionId^ FunctionId {
    FunctionId^ get ();
}

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Class

[image]

Revit 2011 API
ArgumentException Class
Members See Also Send Feedback
The exception that is thrown when one of the arguments provided to a method is not valid.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ArgumentException : public ApplicationException

Remarks

This is the base class for exceptions that are thrown while validating the arguments to a function.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentNullException
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException
Autodesk.Revit.Exceptions..::.FileArgumentNotFoundException
Autodesk.Revit.Exceptions..::.InvalidPathArgumentException

See Also

ArgumentException Members
Autodesk.Revit.Exceptions Namespace


ArgumentException Members

[image] [image]

Revit 2011 API
ArgumentException Members
ArgumentException Class Methods Properties See Also Send Feedback

The ArgumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Overrides Exception..::.Message.)
ParamName | Gets the name of the parameter that causes this exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Methods

[image] [image]

Revit 2011 API
ArgumentException Methods
ArgumentException Class See Also Send Feedback

The ArgumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ArgumentException..::.GetObjectData Method
ArgumentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Properties

[image] [image]

Revit 2011 API
ArgumentException Properties
ArgumentException Class See Also Send Feedback

The ArgumentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Overrides Exception..::.Message.)
ParamName | Gets the name of the parameter that causes this exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


Message Property

[image]

Revit 2011 API
ArgumentException..::.Message Property
ArgumentException Class See Also Send Feedback
Gets the error message and the parameter name, or only the error message if no parameter name is set.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override string Message { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::.Message

Remarks

The text of Message should completely describe the error and should, when possible, explain how to correct it.

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ParamName Property

[image]

Revit 2011 API
ArgumentException..::.ParamName Property
ArgumentException Class See Also Send Feedback
Gets the name of the parameter that causes this exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string ParamName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParamName As String
Visual C++
public:
property String^ ParamName {
    String^ get ();
}

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Class

[image]

Revit 2011 API
ArgumentNullException Class
Members See Also Send Feedback
The exception that is thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed to a method that does not accept it as a valid argument.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentNullException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentNullException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentNullException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentNullException

See Also

ArgumentNullException Members
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Members

[image] [image]

Revit 2011 API
ArgumentNullException Members
ArgumentNullException Class Methods Properties See Also Send Feedback

The ArgumentNullException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Methods

[image] [image]

Revit 2011 API
ArgumentNullException Methods
ArgumentNullException Class See Also Send Feedback

The ArgumentNullException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ArgumentNullException..::.GetObjectData Method
ArgumentNullException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Properties

[image] [image]

Revit 2011 API
ArgumentNullException Properties
ArgumentNullException Class See Also Send Feedback

The ArgumentNullException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Class

[image]

Revit 2011 API
ArgumentOutOfRangeException Class
Members See Also Send Feedback
The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentOutOfRangeException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentOutOfRangeException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentOutOfRangeException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException

See Also

ArgumentOutOfRangeException Members
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Members

[image] [image]

Revit 2011 API
ArgumentOutOfRangeException Members
ArgumentOutOfRangeException Class Methods Properties See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Methods

[image] [image]

Revit 2011 API
ArgumentOutOfRangeException Methods
ArgumentOutOfRangeException Class See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ArgumentOutOfRangeException..::.GetObjectData Method
ArgumentOutOfRangeException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Properties

[image] [image]

Revit 2011 API
ArgumentOutOfRangeException Properties
ArgumentOutOfRangeException Class See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Class

[image]

Revit 2011 API
ArgumentsInconsistentException Class
Members See Also Send Feedback
The exception that is thrown when each individual argument is OK, but a joint constraint is violated.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentsInconsistentException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArgumentsInconsistentException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentsInconsistentException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.ArgumentsInconsistentException

See Also

ArgumentsInconsistentException Members
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Members

[image] [image]

Revit 2011 API
ArgumentsInconsistentException Members
ArgumentsInconsistentException Class Methods Properties See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Methods

[image] [image]

Revit 2011 API
ArgumentsInconsistentException Methods
ArgumentsInconsistentException Class See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ArgumentsInconsistentException..::.GetObjectData Method
ArgumentsInconsistentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Properties

[image] [image]

Revit 2011 API
ArgumentsInconsistentException Properties
ArgumentsInconsistentException Class See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Class

[image]

Revit 2011 API
AutoJoinFailedException Class
Members See Also Send Feedback
The exception that is thrown when an autojoin operation failed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class AutoJoinFailedException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AutoJoinFailedException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class AutoJoinFailedException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.AutoJoinFailedException

See Also

AutoJoinFailedException Members
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Members

[image] [image]

Revit 2011 API
AutoJoinFailedException Members
AutoJoinFailedException Class Methods Properties See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Methods

[image] [image]

Revit 2011 API
AutoJoinFailedException Methods
AutoJoinFailedException Class See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
AutoJoinFailedException..::.GetObjectData Method
AutoJoinFailedException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Properties

[image] [image]

Revit 2011 API
AutoJoinFailedException Properties
AutoJoinFailedException Class See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Class

[image]

Revit 2011 API
DirectoryNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the specified directory could not be found.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class DirectoryNotFoundException : IOException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DirectoryNotFoundException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class DirectoryNotFoundException : public IOException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.DirectoryNotFoundException

See Also

DirectoryNotFoundException Members
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Members

[image] [image]

Revit 2011 API
DirectoryNotFoundException Members
DirectoryNotFoundException Class Methods Properties See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Methods

[image] [image]

Revit 2011 API
DirectoryNotFoundException Methods
DirectoryNotFoundException Class See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
DirectoryNotFoundException..::.GetObjectData Method
DirectoryNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Properties

[image] [image]

Revit 2011 API
DirectoryNotFoundException Properties
DirectoryNotFoundException Class See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Class

[image]

Revit 2011 API
FamilyContextException Class
Members See Also Send Feedback
The exception that is thrown when an operation is invalid in the current family document, because of the type of family.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class FamilyContextException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FamilyContextException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class FamilyContextException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.FamilyContextException

See Also

FamilyContextException Members
Autodesk.Revit.Exceptions Namespace


FamilyContextException Members

[image] [image]

Revit 2011 API
FamilyContextException Members
FamilyContextException Class Methods Properties See Also Send Feedback

The FamilyContextException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Methods

[image] [image]

Revit 2011 API
FamilyContextException Methods
FamilyContextException Class See Also Send Feedback

The FamilyContextException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
FamilyContextException..::.GetObjectData Method
FamilyContextException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Properties

[image] [image]

Revit 2011 API
FamilyContextException Properties
FamilyContextException Class See Also Send Feedback

The FamilyContextException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Class

[image]

Revit 2011 API
FileAccessException Class
Members See Also Send Feedback
The exception that is thrown when the specified file could not be accessed, e.g. read-only, locked by the OS etc.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileAccessException : IOException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FileAccessException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class FileAccessException : public IOException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.FileAccessException

See Also

FileAccessException Members
Autodesk.Revit.Exceptions Namespace


FileAccessException Members

[image] [image]

Revit 2011 API
FileAccessException Members
FileAccessException Class Methods Properties See Also Send Feedback

The FileAccessException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Methods

[image] [image]

Revit 2011 API
FileAccessException Methods
FileAccessException Class See Also Send Feedback

The FileAccessException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
FileAccessException..::.GetObjectData Method
FileAccessException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Properties

[image] [image]

Revit 2011 API
FileAccessException Properties
FileAccessException Class See Also Send Feedback

The FileAccessException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Class

[image]

Revit 2011 API
FileArgumentNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when a method received a filename as an argument and requires it to exist as a precondition.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileArgumentNotFoundException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FileArgumentNotFoundException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class FileArgumentNotFoundException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.FileArgumentNotFoundException

See Also

FileArgumentNotFoundException Members
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Members

[image] [image]

Revit 2011 API
FileArgumentNotFoundException Members
FileArgumentNotFoundException Class Methods Properties See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Methods

[image] [image]

Revit 2011 API
FileArgumentNotFoundException Methods
FileArgumentNotFoundException Class See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
FileArgumentNotFoundException..::.GetObjectData Method
FileArgumentNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Properties

[image] [image]

Revit 2011 API
FileArgumentNotFoundException Properties
FileArgumentNotFoundException Class See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Class

[image]

Revit 2011 API
FileNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the specified file could not be found.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileNotFoundException : IOException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FileNotFoundException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class FileNotFoundException : public IOException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.FileNotFoundException

See Also

FileNotFoundException Members
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Members

[image] [image]

Revit 2011 API
FileNotFoundException Members
FileNotFoundException Class Methods Properties See Also Send Feedback

The FileNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Methods

[image] [image]

Revit 2011 API
FileNotFoundException Methods
FileNotFoundException Class See Also Send Feedback

The FileNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
FileNotFoundException..::.GetObjectData Method
FileNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Properties

[image] [image]

Revit 2011 API
FileNotFoundException Properties
FileNotFoundException Class See Also Send Feedback

The FileNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Class

[image]

Revit 2011 API
ForbiddenForDynamicUpdateException Class
Members See Also Send Feedback
The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ForbiddenForDynamicUpdateException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ForbiddenForDynamicUpdateException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ForbiddenForDynamicUpdateException : public InvalidOperationException

Remarks

Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException

See Also

ForbiddenForDynamicUpdateException Members
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Members

[image] [image]

Revit 2011 API
ForbiddenForDynamicUpdateException Members
ForbiddenForDynamicUpdateException Class Methods Properties See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Methods

[image] [image]

Revit 2011 API
ForbiddenForDynamicUpdateException Methods
ForbiddenForDynamicUpdateException Class See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ForbiddenForDynamicUpdateException..::.GetObjectData Method
ForbiddenForDynamicUpdateException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Properties

[image] [image]

Revit 2011 API
ForbiddenForDynamicUpdateException Properties
ForbiddenForDynamicUpdateException Class See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


FunctionId Class

[image]

Revit 2011 API
FunctionId Class
Members See Also Send Feedback
The information of a function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class FunctionId : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FunctionId _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class FunctionId : ISerializable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.Exceptions..::.FunctionId

See Also

FunctionId Members
Autodesk.Revit.Exceptions Namespace


FunctionId Members

[image] [image]

Revit 2011 API
FunctionId Members
FunctionId Class Methods Properties See Also Send Feedback

The FunctionId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
File | The name of the file including the function throwing an exception.
Function | The name of the function throwing an exception.
Line | The line number of the function throwing an exception.

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


FunctionId Methods

[image] [image]

Revit 2011 API
FunctionId Methods
FunctionId Class See Also Send Feedback

The FunctionId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
FunctionId..::.GetObjectData Method
FunctionId Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


FunctionId Properties

[image] [image]

Revit 2011 API
FunctionId Properties
FunctionId Class See Also Send Feedback

The FunctionId type exposes the following members.

Properties

Name | Description
File | The name of the file including the function throwing an exception.
Function | The name of the function throwing an exception.
Line | The line number of the function throwing an exception.

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


File Property

[image]

Revit 2011 API
FunctionId..::.File Property
FunctionId Class See Also Send Feedback
The name of the file including the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string File { get; }
Visual Basic (Declaration)
Public ReadOnly Property File As String
Visual C++
public:
property String^ File {
    String^ get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


Function Property

[image]

Revit 2011 API
FunctionId..::.Function Property
FunctionId Class See Also Send Feedback
The name of the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Function { get; }
Visual Basic (Declaration)
Public ReadOnly Property Function As String
Visual C++
public:
property String^ Function {
    String^ get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


Line Property

[image]

Revit 2011 API
FunctionId..::.Line Property
FunctionId Class See Also Send Feedback
The line number of the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As Integer
Visual C++
public:
property int Line {
    int get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Class

[image]

Revit 2011 API
InapplicableDataException Class
Members See Also Send Feedback
The exception that is thrown when attempting to access a piece of data that is structurally not part of an object at the moment.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InapplicableDataException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InapplicableDataException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InapplicableDataException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.InapplicableDataException

See Also

InapplicableDataException Members
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Members

[image] [image]

Revit 2011 API
InapplicableDataException Members
InapplicableDataException Class Methods Properties See Also Send Feedback

The InapplicableDataException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Methods

[image] [image]

Revit 2011 API
InapplicableDataException Methods
InapplicableDataException Class See Also Send Feedback

The InapplicableDataException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InapplicableDataException..::.GetObjectData Method
InapplicableDataException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Properties

[image] [image]

Revit 2011 API
InapplicableDataException Properties
InapplicableDataException Class See Also Send Feedback

The InapplicableDataException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


IncorrectProductException Class

[image]

Revit 2011 API
IncorrectProductException Class
Members See Also Send Feedback
The exception that is thrown when the function cannot execute in the current product. The exception specifies which product(s) would let the operation succeed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class IncorrectProductException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IncorrectProductException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class IncorrectProductException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.IncorrectProductException

See Also

IncorrectProductException Members
Autodesk.Revit.Exceptions Namespace


IncorrectProductException Members

[image] [image]

Revit 2011 API
IncorrectProductException Members
IncorrectProductException Class Methods Properties See Also Send Feedback

The IncorrectProductException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IncorrectProductException Class
Autodesk.Revit.Exceptions Namespace


IncorrectProductException Methods

[image] [image]

Revit 2011 API
IncorrectProductException Methods
IncorrectProductException Class See Also Send Feedback

The IncorrectProductException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IncorrectProductException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
IncorrectProductException..::.GetObjectData Method
IncorrectProductException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

IncorrectProductException Class
Autodesk.Revit.Exceptions Namespace


IncorrectProductException Properties

[image] [image]

Revit 2011 API
IncorrectProductException Properties
IncorrectProductException Class See Also Send Feedback

The IncorrectProductException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IncorrectProductException Class
Autodesk.Revit.Exceptions Namespace


InternalException Class

[image]

Revit 2011 API
InternalException Class
Members See Also Send Feedback
The exception that is thrown when an issue in the Revit code resulted in an unexpected error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InternalException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InternalException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InternalException : public ApplicationException

Remarks

Please contact Autodesk Developer Support with the information about what led to this exception.

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InternalException

See Also

InternalException Members
Autodesk.Revit.Exceptions Namespace


InternalException Members

[image] [image]

Revit 2011 API
InternalException Members
InternalException Class Methods Properties See Also Send Feedback

The InternalException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InternalException Methods

[image] [image]

Revit 2011 API
InternalException Methods
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InternalException..::.GetObjectData Method
InternalException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InternalException Properties

[image] [image]

Revit 2011 API
InternalException Properties
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Class

[image]

Revit 2011 API
InvalidDataStreamException Class
Members See Also Send Feedback
The exception that is thrown when the reading or saving operation failed due to parsing error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidDataStreamException : IOException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidDataStreamException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class InvalidDataStreamException : public IOException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.InvalidDataStreamException

See Also

InvalidDataStreamException Members
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Members

[image] [image]

Revit 2011 API
InvalidDataStreamException Members
InvalidDataStreamException Class Methods Properties See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Methods

[image] [image]

Revit 2011 API
InvalidDataStreamException Methods
InvalidDataStreamException Class See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InvalidDataStreamException..::.GetObjectData Method
InvalidDataStreamException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Properties

[image] [image]

Revit 2011 API
InvalidDataStreamException Properties
InvalidDataStreamException Class See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Class

[image]

Revit 2011 API
InvalidLicenseException Class
Members See Also Send Feedback
The exception that is thrown when an operation is denied by the license manager, e.g. save from demo mode.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidLicenseException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidLicenseException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidLicenseException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.InvalidLicenseException

See Also

InvalidLicenseException Members
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Members

[image] [image]

Revit 2011 API
InvalidLicenseException Members
InvalidLicenseException Class Methods Properties See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Methods

[image] [image]

Revit 2011 API
InvalidLicenseException Methods
InvalidLicenseException Class See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InvalidLicenseException..::.GetObjectData Method
InvalidLicenseException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Properties

[image] [image]

Revit 2011 API
InvalidLicenseException Properties
InvalidLicenseException Class See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Class

[image]

Revit 2011 API
InvalidObjectException Class
Members See Also Send Feedback
The exception that is thrown when referencing an [native] object that either no longer exists whose creation was undone (by rolling a transaction back).

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidObjectException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidObjectException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidObjectException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.InvalidObjectException

See Also

InvalidObjectException Members
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Members

[image] [image]

Revit 2011 API
InvalidObjectException Members
InvalidObjectException Class Methods Properties See Also Send Feedback

The InvalidObjectException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Methods

[image] [image]

Revit 2011 API
InvalidObjectException Methods
InvalidObjectException Class See Also Send Feedback

The InvalidObjectException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InvalidObjectException..::.GetObjectData Method
InvalidObjectException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Properties

[image] [image]

Revit 2011 API
InvalidObjectException Properties
InvalidObjectException Class See Also Send Feedback

The InvalidObjectException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Class

[image]

Revit 2011 API
InvalidOperationException Class
Members See Also Send Feedback
The exception that is thrown when a method call is invalid for the object's current state.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidOperationException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidOperationException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InvalidOperationException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.AutoJoinFailedException
Autodesk.Revit.Exceptions..::.FamilyContextException
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException
Autodesk.Revit.Exceptions..::.InapplicableDataException
Autodesk.Revit.Exceptions..::.IncorrectProductException
Autodesk.Revit.Exceptions..::.InvalidLicenseException
Autodesk.Revit.Exceptions..::.InvalidObjectException
Autodesk.Revit.Exceptions..::.ModificationForbiddenException
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException
Autodesk.Revit.Exceptions..::.ObjectAccessException
Autodesk.Revit.Exceptions..::.RegenerationFailedException

See Also

InvalidOperationException Members
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Members

[image] [image]

Revit 2011 API
InvalidOperationException Members
InvalidOperationException Class Methods Properties See Also Send Feedback

The InvalidOperationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Methods

[image] [image]

Revit 2011 API
InvalidOperationException Methods
InvalidOperationException Class See Also Send Feedback

The InvalidOperationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InvalidOperationException..::.GetObjectData Method
InvalidOperationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Properties

[image] [image]

Revit 2011 API
InvalidOperationException Properties
InvalidOperationException Class See Also Send Feedback

The InvalidOperationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Class

[image]

Revit 2011 API
InvalidPathArgumentException Class
Members See Also Send Feedback
The exception that is thrown when a method received a pathname as an argument, but the pathname is illegal: too long, invalid characters, etc.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidPathArgumentException : ArgumentException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidPathArgumentException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class InvalidPathArgumentException : public ArgumentException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.ArgumentException
Autodesk.Revit.Exceptions..::.InvalidPathArgumentException

See Also

InvalidPathArgumentException Members
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Members

[image] [image]

Revit 2011 API
InvalidPathArgumentException Members
InvalidPathArgumentException Class Methods Properties See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Methods

[image] [image]

Revit 2011 API
InvalidPathArgumentException Methods
InvalidPathArgumentException Class See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
InvalidPathArgumentException..::.GetObjectData Method
InvalidPathArgumentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Properties

[image] [image]

Revit 2011 API
InvalidPathArgumentException Properties
InvalidPathArgumentException Class See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


IOException Class

[image]

Revit 2011 API
IOException Class
Members See Also Send Feedback
The exception that is thrown when an I/O error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class IOException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IOException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class IOException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.IOException
Autodesk.Revit.Exceptions..::.DirectoryNotFoundException
Autodesk.Revit.Exceptions..::.FileAccessException
Autodesk.Revit.Exceptions..::.FileNotFoundException
Autodesk.Revit.Exceptions..::.InvalidDataStreamException

See Also

IOException Members
Autodesk.Revit.Exceptions Namespace


IOException Members

[image] [image]

Revit 2011 API
IOException Members
IOException Class Methods Properties See Also Send Feedback

The IOException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


IOException Methods

[image] [image]

Revit 2011 API
IOException Methods
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
IOException..::.GetObjectData Method
IOException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


IOException Properties

[image] [image]

Revit 2011 API
IOException Properties
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Class

[image]

Revit 2011 API
ModificationForbiddenException Class
Members See Also Send Feedback
The exception that is thrown by the undo transaction framework when a modification operation is not allowed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationForbiddenException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ModificationForbiddenException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationForbiddenException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ModificationForbiddenException

See Also

ModificationForbiddenException Members
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Members

[image] [image]

Revit 2011 API
ModificationForbiddenException Members
ModificationForbiddenException Class Methods Properties See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Methods

[image] [image]

Revit 2011 API
ModificationForbiddenException Methods
ModificationForbiddenException Class See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ModificationForbiddenException..::.GetObjectData Method
ModificationForbiddenException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Properties

[image] [image]

Revit 2011 API
ModificationForbiddenException Properties
ModificationForbiddenException Class See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Class

[image]

Revit 2011 API
ModificationOutsideTransactionException Class
Members See Also Send Feedback
The exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationOutsideTransactionException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ModificationOutsideTransactionException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationOutsideTransactionException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ModificationOutsideTransactionException

See Also

ModificationOutsideTransactionException Members
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Members

[image] [image]

Revit 2011 API
ModificationOutsideTransactionException Members
ModificationOutsideTransactionException Class Methods Properties See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Methods

[image] [image]

Revit 2011 API
ModificationOutsideTransactionException Methods
ModificationOutsideTransactionException Class See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ModificationOutsideTransactionException..::.GetObjectData Method
ModificationOutsideTransactionException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Properties

[image] [image]

Revit 2011 API
ModificationOutsideTransactionException Properties
ModificationOutsideTransactionException Class See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Class

[image]

Revit 2011 API
ObjectAccessException Class
Members See Also Send Feedback
The exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class ObjectAccessException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ObjectAccessException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ObjectAccessException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.ObjectAccessException

See Also

ObjectAccessException Members
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Members

[image] [image]

Revit 2011 API
ObjectAccessException Members
ObjectAccessException Class Methods Properties See Also Send Feedback

The ObjectAccessException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Methods

[image] [image]

Revit 2011 API
ObjectAccessException Methods
ObjectAccessException Class See Also Send Feedback

The ObjectAccessException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
ObjectAccessException..::.GetObjectData Method
ObjectAccessException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Properties

[image] [image]

Revit 2011 API
ObjectAccessException Properties
ObjectAccessException Class See Also Send Feedback

The ObjectAccessException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Class

[image]

Revit 2011 API
OperationCanceledException Class
Members See Also Send Feedback
The exception that is thrown when an operation is unexpectedly cancelled.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class OperationCanceledException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OperationCanceledException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class OperationCanceledException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.OperationCanceledException

See Also

OperationCanceledException Members
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Members

[image] [image]

Revit 2011 API
OperationCanceledException Members
OperationCanceledException Class Methods Properties See Also Send Feedback

The OperationCanceledException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Methods

[image] [image]

Revit 2011 API
OperationCanceledException Methods
OperationCanceledException Class See Also Send Feedback

The OperationCanceledException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
OperationCanceledException..::.GetObjectData Method
OperationCanceledException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Properties

[image] [image]

Revit 2011 API
OperationCanceledException Properties
OperationCanceledException Class See Also Send Feedback

The OperationCanceledException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Class

[image]

Revit 2011 API
RegenerationFailedException Class
Members See Also Send Feedback
The exception that is thrown when a regeneration operation failed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
[SerializableAttribute]
public class RegenerationFailedException : InvalidOperationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class RegenerationFailedException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class RegenerationFailedException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
Autodesk.Revit.Exceptions..::.ApplicationException
Autodesk.Revit.Exceptions..::.InvalidOperationException
Autodesk.Revit.Exceptions..::.RegenerationFailedException

See Also

RegenerationFailedException Members
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Members

[image] [image]

Revit 2011 API
RegenerationFailedException Members
RegenerationFailedException Class Methods Properties See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Methods

[image] [image]

Revit 2011 API
RegenerationFailedException Methods
RegenerationFailedException Class See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2011 API
RegenerationFailedException..::.GetObjectData Method
RegenerationFailedException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Properties

[image] [image]

Revit 2011 API
RegenerationFailedException Properties
RegenerationFailedException Class See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


Autodesk.Revit.UI Namespace

[image]

Revit 2011 API
Autodesk.Revit.UI Namespace
Send Feedback

Classes

Class | Description
ButtonData | Base class used to contain information necessary to construct a button in the Ribbon.
ComboBox | This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
ComboBoxData | This class contains information necessary to construct a combo box in the Ribbon.
ComboBoxMember | This class represents an item in the drop-down list of a ComboBox.
ComboBoxMemberData | This class contains information necessary to construct a ComboBoxMember.
ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
ExternalCommandData | A class contains reference to Application and View which are needed by external command.
PulldownButton | The PulldownButton object represents a button with a drop-down list on RibbonPanel.
PulldownButtonData | This class contains information necessary to construct a pulldown button in the Ribbon.
PushButton | The PushButton object represents an button on a RibbonPanel.
PushButtonData | This class contains information necessary to construct a push button in the Ribbon.
RadioButtonGroup | Represents a group of related buttons in the Ribbon.
RadioButtonGroupData | This class contains information necessary to construct a ribbon gallery in the Ribbon.
RibbonButton | This class is the base class of PushButton and PulldownButton.
RibbonItem | The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
RibbonItemData | Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
RibbonPanel | Represents a panel added by an External Application or External Command into the Add-Ins tab.
SplitButton | The SplitButton object represents a button with a clickable button appearing above a pulldown.
SplitButtonData | This class contains information necessary to construct a split button in the Ribbon.
TaskDialog | A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.
TextBox | The TextBox object represents text-based control that allows the user to enter text.
TextBoxData | This class contains information necessary to construct a text box in the Ribbon.
ToggleButton | The ToggleButton object represents a button that has been added to a RadioButtonGroup.
ToggleButtonData | This class contains information necessary to construct a toggle button in a RadioButtonGroup.
UIApplication | Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, and the active document.
UIControlledApplication | Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
UIDocument | An object that represents an Autodesk Revit project opened in the Revit user interface.

Interfaces

Interface | Description
IExternalApplication | An interface that when support provides additional applications within Autodesk Revit implemented by external applications.
IExternalCommand | An interface that should be implemented to provide the implementation for a Revit add-in External Command.
IExternalCommandAvailability | An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.

Enumerations

Enumeration | Description
Result | Informs Autodesk Revit of the status of your application after execution.
RibbonItemType | An enumerated type listing all the toolbar item styles.
Tab | An enumerated type listing static tabs which support addition of panels via the API.
TaskDialogCommandLinkId | Enum to specify the Id of CommandLink.
TaskDialogCommonButtons | A enumerated type containing the standard buttons available for Task Dialogs.
TaskDialogIcon | Standard icons to be used in the task dialog.
TaskDialogResult | Enum to specify the task dialog result.


ButtonData Class

[image]

Revit 2011 API
ButtonData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ButtonData : RibbonItemData
Visual Basic (Declaration)
Public Class ButtonData _
    Inherits RibbonItemData
Visual C++
public ref class ButtonData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PulldownButtonData
Autodesk.Revit.UI..::.PushButtonData

See Also

ButtonData Members
Autodesk.Revit.UI Namespace


ButtonData Members

[image] [image]

Revit 2011 API
ButtonData Members
ButtonData Class Methods Properties See Also Send Feedback

The ButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the button.
LargeImage | The large image of the button.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ButtonData Methods

[image] [image]

Revit 2011 API
ButtonData Methods
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ButtonData Properties

[image] [image]

Revit 2011 API
ButtonData Properties
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Properties

Name | Description
Image | The image of the button.
LargeImage | The large image of the button.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
ButtonData..::.Image Property
ButtonData Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set, or if it is promoted to the Quick Access Toolbar. The best size is 16 x 16 pixels; if larger, the image will NOT be adjusted to fit the toolbar button.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


LargeImage Property

[image]

Revit 2011 API
ButtonData..::.LargeImage Property
ButtonData Class See Also Send Feedback
The large image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown on a push button added to a pulldown button. The best size is 32 x 32 pixels; if larger, the image will be adjusted to fit the button.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


Text Property

[image]

Revit 2011 API
ButtonData..::.Text Property
ButtonData Class See Also Send Feedback
The user-visible text of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ComboBox Class

[image]

Revit 2011 API
ComboBox Class
Members See Also Send Feedback
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ComboBox : RibbonItem
Visual Basic (Declaration)
Public Class ComboBox _
    Inherits RibbonItem
Visual C++
public ref class ComboBox : public RibbonItem

Remarks

The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.ComboBox

See Also

ComboBox Members
Autodesk.Revit.UI Namespace


ComboBox Members

[image] [image]

Revit 2011 API
ComboBox Members
ComboBox Class Methods Properties Events See Also Send Feedback

The ComboBox type exposes the following members.

Methods

Name | Description
AddItem | Adds a new item to the ComboBox.
AddItems | Adds a new items to the ComboBox.
AddSeparator | Adds a separator to the drop-down list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets or sets the current checked ComboBox member of the ComboBox.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image shown on the ComboBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

Events

Name | Description
CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Methods

[image] [image]

Revit 2011 API
ComboBox Methods
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Methods

Name | Description
AddItem | Adds a new item to the ComboBox.
AddItems | Adds a new items to the ComboBox.
AddSeparator | Adds a separator to the drop-down list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2011 API
ComboBox..::.AddItem Method
ComboBox Class See Also Send Feedback
Adds a new item to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMember AddItem(
    ComboBoxMemberData memberData
)
Visual Basic (Declaration)
Public Function AddItem ( _
    memberData As ComboBoxMemberData _
) As ComboBoxMember
Visual C++
public:
ComboBoxMember^ AddItem(
    ComboBoxMemberData^ memberData
)

Parameters

memberData
Type: Autodesk.Revit.UI..::.ComboBoxMemberData
An object containing the data needed to construct the ComboBoxMember.

Return Value

The newly added ComboBoxMember.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when memberData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when button with memberData.Name already exists in the drop-down list.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddItems Method

[image]

Revit 2011 API
ComboBox..::.AddItems Method
ComboBox Class See Also Send Feedback
Adds a new items to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ComboBoxMember> AddItems(
    IList<ComboBoxMemberData> memberData
)
Visual Basic (Declaration)
Public Function AddItems ( _
    memberData As IList(Of ComboBoxMemberData) _
) As IList(Of ComboBoxMember)
Visual C++
public:
IList<ComboBoxMember^>^ AddItems(
    IList<ComboBoxMemberData^>^ memberData
)

Parameters

memberData
Type: System.Collections.Generic..::.IList <(Of <( ComboBoxMemberData >)>)
An object list containing the data needed to construct the ComboBoxMember.

Return Value

The newly added ComboBoxMembers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when memberData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when button with memberData.Name already exists in the drop-down list.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2011 API
ComboBox..::.AddSeparator Method
ComboBox Class See Also Send Feedback
Adds a separator to the drop-down list.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddSeparator()
Visual Basic (Declaration)
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator will be added below the last added member.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2011 API
ComboBox..::.GetItems Method
ComboBox Class See Also Send Feedback
Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ComboBoxMember> GetItems()
Visual Basic (Declaration)
Public Function GetItems As IList(Of ComboBoxMember)
Visual C++
public:
IList<ComboBoxMember^>^ GetItems()

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Properties

[image] [image]

Revit 2011 API
ComboBox Properties
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Properties

Name | Description
Current | Gets or sets the current checked ComboBox member of the ComboBox.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image shown on the ComboBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2011 API
ComboBox..::.Current Property
ComboBox Class See Also Send Feedback
Gets or sets the current checked ComboBox member of the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMember Current { get; set; }
Visual Basic (Declaration)
Public Property Current As ComboBoxMember
Visual C++
public:
property ComboBoxMember^ Current {
    ComboBoxMember^ get ();
    void set (ComboBoxMember^ value);
}

Remarks

The default value is the first ComboBox member added to the ComboBox.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set this property to a button not in this ComboBox.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
ComboBox..::.Image Property
ComboBox Class See Also Send Feedback
The image shown on the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Events

[image] [image]

Revit 2011 API
ComboBox Events
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Events

Name | Description
CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


CurrentChanged Event

[image]

Revit 2011 API
ComboBox..::.CurrentChanged Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the current item of the ComboBox is changed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ComboBoxCurrentChangedEventArgs> CurrentChanged
Visual Basic (Declaration)
Public Event CurrentChanged As EventHandler(Of ComboBoxCurrentChangedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxCurrentChangedEventArgs^>^ CurrentChanged {
    void add (EventHandler<ComboBoxCurrentChangedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxCurrentChangedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


DropDownClosed Event

[image]

Revit 2011 API
ComboBox..::.DropDownClosed Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the drop-down of the ComboBox is closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ComboBoxDropDownClosedEventArgs> DropDownClosed
Visual Basic (Declaration)
Public Event DropDownClosed As EventHandler(Of ComboBoxDropDownClosedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxDropDownClosedEventArgs^>^ DropDownClosed {
    void add (EventHandler<ComboBoxDropDownClosedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxDropDownClosedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


DropDownOpened Event

[image]

Revit 2011 API
ComboBox..::.DropDownOpened Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ComboBoxDropDownOpenedEventArgs> DropDownOpened
Visual Basic (Declaration)
Public Event DropDownOpened As EventHandler(Of ComboBoxDropDownOpenedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxDropDownOpenedEventArgs^>^ DropDownOpened {
    void add (EventHandler<ComboBoxDropDownOpenedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxDropDownOpenedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBoxData Class

[image]

Revit 2011 API
ComboBoxData Class
Members See Also Send Feedback
This class contains information necessary to construct a combo box in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxData : RibbonItemData
Visual Basic (Declaration)
Public Class ComboBoxData _
    Inherits RibbonItemData
Visual C++
public ref class ComboBoxData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ComboBoxData

See Also

ComboBoxData Members
Autodesk.Revit.UI Namespace


ComboBoxData Members

[image] [image]

Revit 2011 API
ComboBoxData Members
ComboBoxData Class Constructors Methods Properties See Also Send Feedback

The ComboBoxData type exposes the following members.

Constructors

Name | Description
ComboBoxData | Constructs a new instance of ComboBoxData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image shown on the ComboBox.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Constructor

[image]

Revit 2011 API
ComboBoxData Constructor
ComboBoxData Class See Also Send Feedback
Constructs a new instance of ComboBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ComboBoxData(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ComboBoxData(
    String^ name
)

Parameters

name
Type: System..::.String
The internal name of the ComboBoxMember.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for name.

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Methods

[image] [image]

Revit 2011 API
ComboBoxData Methods
ComboBoxData Class See Also Send Feedback

The ComboBoxData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Properties

[image] [image]

Revit 2011 API
ComboBoxData Properties
ComboBoxData Class See Also Send Feedback

The ComboBoxData type exposes the following members.

Properties

Name | Description
Image | The image shown on the ComboBox.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
ComboBoxData..::.Image Property
ComboBoxData Class See Also Send Feedback
The image shown on the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxMember Class

[image]

Revit 2011 API
ComboBoxMember Class
Members See Also Send Feedback
This class represents an item in the drop-down list of a ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxMember : RibbonItem
Visual Basic (Declaration)
Public Class ComboBoxMember _
    Inherits RibbonItem
Visual C++
public ref class ComboBoxMember : public RibbonItem

Remarks

Note that a ComboBoxMember will not show an individual tool tip. Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.ComboBoxMember

See Also

ComboBoxMember Members
Autodesk.Revit.UI Namespace


ComboBoxMember Members

[image] [image]

Revit 2011 API
ComboBoxMember Members
ComboBoxMember Class Methods Properties See Also Send Feedback

The ComboBoxMember type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
GroupName | The group to which the ComboBoxMember is assigned.
Image | The image shown on the ComboBoxMember.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMember Methods

[image] [image]

Revit 2011 API
ComboBoxMember Methods
ComboBoxMember Class See Also Send Feedback

The ComboBoxMember type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMember Properties

[image] [image]

Revit 2011 API
ComboBoxMember Properties
ComboBoxMember Class See Also Send Feedback

The ComboBoxMember type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
GroupName | The group to which the ComboBoxMember is assigned.
Image | The image shown on the ComboBoxMember.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


GroupName Property

[image]

Revit 2011 API
ComboBoxMember..::.GroupName Property
ComboBoxMember Class See Also Send Feedback
The group to which the ComboBoxMember is assigned.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GroupName { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
}

Remarks

If set, the ComboBoxMember appears under a group header in the ComboBox. If nullNothingnullptra null reference (Nothing in Visual Basic), the ComboBoxMember is not a member of any group. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
ComboBoxMember..::.Image Property
ComboBoxMember Class See Also Send Feedback
The image shown on the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Class

[image]

Revit 2011 API
ComboBoxMemberData Class
Members See Also Send Feedback
This class contains information necessary to construct a ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxMemberData : RibbonItemData
Visual Basic (Declaration)
Public Class ComboBoxMemberData _
    Inherits RibbonItemData
Visual C++
public ref class ComboBoxMemberData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ComboBoxMemberData

See Also

ComboBoxMemberData Members
Autodesk.Revit.UI Namespace


ComboBoxMemberData Members

[image] [image]

Revit 2011 API
ComboBoxMemberData Members
ComboBoxMemberData Class Constructors Methods Properties See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Constructors

Name | Description
ComboBoxMemberData | Constructs a new instance of ComboBoxMemberData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GroupName | Gets or sets a group name for the ComboBoxMember.
Image | The image shown on the ComboBoxMember.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the ComboBoxMember.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Constructor

[image]

Revit 2011 API
ComboBoxMemberData Constructor
ComboBoxMemberData Class See Also Send Feedback
Constructs a new instance of ComboBoxMemberData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMemberData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
ComboBoxMemberData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the ComboBoxMember.
text
Type: System..::.String
The user visible text seen on the item.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Methods

[image] [image]

Revit 2011 API
ComboBoxMemberData Methods
ComboBoxMemberData Class See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Properties

[image] [image]

Revit 2011 API
ComboBoxMemberData Properties
ComboBoxMemberData Class See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Properties

Name | Description
GroupName | Gets or sets a group name for the ComboBoxMember.
Image | The image shown on the ComboBoxMember.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the ComboBoxMember.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


GroupName Property

[image]

Revit 2011 API
ComboBoxMemberData..::.GroupName Property
ComboBoxMemberData Class See Also Send Feedback
Gets or sets a group name for the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

Remarks

The GroupName is used to group the items and also appears in the group header. All ComboBoxMembers assigned to the same group will be grouped in the ComboBox. There will be a header that shows the name. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
ComboBoxMemberData..::.Image Property
ComboBoxMemberData Class See Also Send Feedback
The image shown on the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item when the item is added to a ComboBox. The best size is 16 x 16 pixels.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


Text Property

[image]

Revit 2011 API
ComboBoxMemberData..::.Text Property
ComboBoxMemberData Class See Also Send Feedback
The user-visible text of the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Class

[image]

Revit 2011 API
ExternalApplicationArray Class
Members See Also Send Feedback
An array that can contain any number of IExternalApplication objects.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExternalApplicationArray : APIObject,
    IEnumerable
Visual Basic (Declaration)
Public Class ExternalApplicationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ExternalApplicationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI..::.ExternalApplicationArray

See Also

ExternalApplicationArray Members
Autodesk.Revit.UI Namespace


ExternalApplicationArray Members

[image] [image]

Revit 2011 API
ExternalApplicationArray Members
ExternalApplicationArray Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Constructors

Name | Description
ExternalApplicationArray | Initializes a new instance of the ExternalApplicationArray class

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Constructor

[image]

Revit 2011 API
ExternalApplicationArray Constructor
ExternalApplicationArray Class See Also Send Feedback
Initializes a new instance of the ExternalApplicationArray class

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ExternalApplicationArray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArray()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Methods

[image] [image]

Revit 2011 API
ExternalApplicationArray Methods
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Methods

Name | Description
Append | Add the item to the end of the array.
Clear | Removes every item from the array, rendering it empty.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForwardIterator | Retrieve a forward moving iterator to the array.
GetEnumerator | Retrieve a forward moving iterator to the array.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified item into the array.
ReverseIterator | Retrieve a backward moving iterator to the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Append Method

[image]

Revit 2011 API
ExternalApplicationArray..::.Append Method
ExternalApplicationArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Append(
    IExternalApplication item
)
Visual Basic (Declaration)
Public Overridable Sub Append ( _
    item As IExternalApplication _
)
Visual C++
public:
virtual void Append(
    IExternalApplication^ item
)

Parameters

item
Type: Autodesk.Revit.UI..::.IExternalApplication
The item to be added.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Clear Method

[image]

Revit 2011 API
ExternalApplicationArray..::.Clear Method
ExternalApplicationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ForwardIterator Method

[image]

Revit 2011 API
ExternalApplicationArray..::.ForwardIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


GetEnumerator Method

[image]

Revit 2011 API
ExternalApplicationArray..::.GetEnumerator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Insert Method

[image]

Revit 2011 API
ExternalApplicationArray..::.Insert Method
ExternalApplicationArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Insert(
    IExternalApplication item,
    int index
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    item As IExternalApplication, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IExternalApplication^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.UI..::.IExternalApplication
The item to be inserted into the array.
index
Type: System..::.Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ReverseIterator Method

[image]

Revit 2011 API
ExternalApplicationArray..::.ReverseIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Properties

[image] [image]

Revit 2011 API
ExternalApplicationArray Properties
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the array is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Gets or sets an item at a specified index within the array.
Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


IsEmpty Property

[image]

Revit 2011 API
ExternalApplicationArray..::.IsEmpty Property
ExternalApplicationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Item Property

[image]

Revit 2011 API
ExternalApplicationArray..::.Item Property
ExternalApplicationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IExternalApplication Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Property Item ( _
    index As Integer _
) As IExternalApplication
Visual C++
public:
virtual property IExternalApplication^ Item[int index] {
    IExternalApplication^ get (int index);
    void set (int index, IExternalApplication^ value);
}

Parameters

index
Type: System..::.Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Size Property

[image]

Revit 2011 API
ExternalApplicationArray..::.Size Property
ExternalApplicationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Class

[image]

Revit 2011 API
ExternalApplicationArrayIterator Class
Members See Also Send Feedback
An iterator to an array of IExternalApplication objects..

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ExternalApplicationArrayIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class ExternalApplicationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ExternalApplicationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI..::.ExternalApplicationArrayIterator

See Also

ExternalApplicationArrayIterator Members
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Members

[image] [image]

Revit 2011 API
ExternalApplicationArrayIterator Members
ExternalApplicationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Constructors

Name | Description
ExternalApplicationArrayIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Constructor

[image]

Revit 2011 API
ExternalApplicationArrayIterator Constructor
ExternalApplicationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ExternalApplicationArrayIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExternalApplicationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Methods

[image] [image]

Revit 2011 API
ExternalApplicationArrayIterator Methods
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the array.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


MoveNext Method

[image]

Revit 2011 API
ExternalApplicationArrayIterator..::.MoveNext Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


Reset Method

[image]

Revit 2011 API
ExternalApplicationArrayIterator..::.Reset Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Properties

[image] [image]

Revit 2011 API
ExternalApplicationArrayIterator Properties
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2011 API
ExternalApplicationArrayIterator..::.Current Property
ExternalApplicationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalCommandData Class

[image]

Revit 2011 API
ExternalCommandData Class
Members See Also Send Feedback
A class contains reference to Application and View which are needed by external command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ExternalCommandData : APIObject
Visual Basic (Declaration)
Public Class ExternalCommandData _
    Inherits APIObject
Visual C++
public ref class ExternalCommandData : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI..::.ExternalCommandData

See Also

ExternalCommandData Members
Autodesk.Revit.UI Namespace


ExternalCommandData Members

[image] [image]

Revit 2011 API
ExternalCommandData Members
ExternalCommandData Class Methods Properties See Also Send Feedback

The ExternalCommandData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | Retrieves an object that represents the current Application for external command.
Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


ExternalCommandData Methods

[image] [image]

Revit 2011 API
ExternalCommandData Methods
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


ExternalCommandData Properties

[image] [image]

Revit 2011 API
ExternalCommandData Properties
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Properties

Name | Description
Application | Retrieves an object that represents the current Application for external command.
Data | A data map that can be used to read and write data to the Autodesk Revit journal file.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2011 API
ExternalCommandData..::.Application Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the current Application for external command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIApplication Application { get; set; }
Visual Basic (Declaration)
Public Property Application As UIApplication
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
    void set (UIApplication^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


Data Property

[image]

Revit 2011 API
ExternalCommandData..::.Data Property
ExternalCommandData Class Example See Also Send Feedback
A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public StringStringMap Data { get; set; }
Visual Basic (Declaration)
Public Property Data As StringStringMap
Visual C++
public:
property StringStringMap^ Data {
    StringStringMap^ get ();
    void set (StringStringMap^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

Examples

CopyC#
void WriteJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.Data;
    dataMap.Clear();

    // Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit");
    dataMap.Insert("Information", "This is an example.");
    dataMap.Insert("Greeting", "Hello Everyone.");
}

/// <summary>
/// This sample shows how to get data from journal file.
/// </summary>
void ReadJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.Data;

    // Begin to get the support data.
    String prompt = "Name: " + dataMap.get_Item("Name");
    prompt += "\nInformation: " + dataMap.get_Item("Information");
    prompt += "\nGreeting: " + dataMap.get_Item("Greeting");

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Sub WriteJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data
    dataMap.Clear()

    ' Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit")
    dataMap.Insert("Information", "This is an example.")
    dataMap.Insert("Greeting", "Hello Everyone.")
End Sub

' <summary>
' This sample shows how to get data from journal file.
' </summary>
Sub ReadJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data

    ' Begin to get the support data.
    Dim prompt As [String] = "Name: " + dataMap.Item("Name")
    prompt += vbLf & "Information: " + dataMap.Item("Information")
    prompt += vbLf & "Greeting: " + dataMap.Item("Greeting")

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


View Property

[image]

Revit 2011 API
ExternalCommandData..::.View Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the View external command work on.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic (Declaration)
Public Property View As View
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


IExternalApplication Interface

[image]

Revit 2011 API
IExternalApplication Interface
Members See Also Send Feedback
An interface that when support provides additional applications within Autodesk Revit implemented by external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IExternalApplication
Visual Basic (Declaration)
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

Remarks

To add an external application to Autodesk Revit the developer should implement an object that supports the IExternalApplication interface.

See Also

IExternalApplication Members
Autodesk.Revit.UI Namespace


IExternalApplication Members

[image] [image]

Revit 2011 API
IExternalApplication Members
IExternalApplication Interface Methods See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

Name | Description
OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


IExternalApplication Methods

[image] [image]

Revit 2011 API
IExternalApplication Methods
IExternalApplication Interface See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

Name | Description
OnShutdown | Provide an interface for the user to do some extra work when Revit closes.
OnStartup | Provide an interface for the user to do some extra work when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


OnShutdown Method

[image]

Revit 2011 API
IExternalApplication..::.OnShutdown Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit closes.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
Result OnShutdown(
    UIControlledApplication application
)
Visual Basic (Declaration)
Function OnShutdown ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnShutdown(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::.UIControlledApplication
The application is being shut down.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an external application, the task within OnShutdown will be executed when Revit closes.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


OnStartup Method

[image]

Revit 2011 API
IExternalApplication..::.OnStartup Method
IExternalApplication Interface See Also Send Feedback
Provide an interface for the user to do some extra work when Revit starts.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
Result OnStartup(
    UIControlledApplication application
)
Visual Basic (Declaration)
Function OnStartup ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnStartup(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::.UIControlledApplication
The application is being started.

Return Value

Indicates if the external application completes its work successfully.

Remarks

If the user implements the interface for an external application, the task within OnStartup will be executed when Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


IExternalCommand Interface

[image]

Revit 2011 API
IExternalCommand Interface
Members Example See Also Send Feedback
An interface that should be implemented to provide the implementation for a Revit add-in External Command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IExternalCommand
Visual Basic (Declaration)
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

Examples

CopyC#
public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
    ref string message, ElementSet elements)
{
    try
    {
        Document doc = commandData.Application.ActiveUIDocument.Document;
        UIDocument uidoc = commandData.Application.ActiveUIDocument;
        // Delete selected elements
        ICollection<Autodesk.Revit.DB.ElementId> ids =
            doc.Delete(uidoc.Selection.Elements);

        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent =
           ("Click Yes to return Succeeded. Selected members will be deleted.\n" +
           "Click No to return Failed.  Selected members will not be deleted.\n" +
           "Click Cancel to return Cancelled.  Selected members will not be deleted.");
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes |
            TaskDialogCommonButtons.No | TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult taskDialogResult = taskDialog.Show();

        if (taskDialogResult == TaskDialogResult.Yes)
        {
            return Autodesk.Revit.UI.Result.Succeeded;
        }
        else if (taskDialogResult == TaskDialogResult.No)
        {
            elements = uidoc.Selection.Elements;
            message = "Failed to delete selection.";
            return Autodesk.Revit.UI.Result.Failed;
        }
        else
        {
            return Autodesk.Revit.UI.Result.Cancelled;
        }
    }
    catch
    {
        message = "Unexpected Exception thrown.";
        return Autodesk.Revit.UI.Result.Failed;
    }

}
CopyVB.NET
Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result _
        Implements IExternalCommand.Execute
    Try
        Dim doc As Document = commandData.Application.ActiveUIDocument.Document
        Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
        ' Delete selected elements
        Dim ids As ICollection(Of Autodesk.Revit.DB.ElementId) = doc.Delete(uidoc.Selection.Elements)

        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = ("Click Yes to return Succeeded. Selected members will be deleted." & vbLf + "Click No to return Failed.  Selected members will not be deleted." & vbLf + "Click Cancel to return Cancelled.  Selected members will not be deleted.")
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim taskDialogResult As TaskDialogResult = taskDialog.Show()

        If taskDialogResult = taskDialogResult.Yes Then
            Return Autodesk.Revit.UI.Result.Succeeded
        ElseIf taskDialogResult = taskDialogResult.No Then
            elements = uidoc.Selection.Elements
            message = "Failed to delete selection."
            Return Autodesk.Revit.UI.Result.Failed
        Else
            Return Autodesk.Revit.UI.Result.Cancelled
        End If
    Catch
        message = "Unexpected Exception thrown."
        Return Autodesk.Revit.UI.Result.Failed
    End Try

End Function

See Also

IExternalCommand Members
Autodesk.Revit.UI Namespace


IExternalCommand Members

[image] [image]

Revit 2011 API
IExternalCommand Members
IExternalCommand Interface Methods See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

Name | Description
Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


IExternalCommand Methods

[image] [image]

Revit 2011 API
IExternalCommand Methods
IExternalCommand Interface See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

Name | Description
Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


Execute Method

[image]

Revit 2011 API
IExternalCommand..::.Execute Method
IExternalCommand Interface See Also Send Feedback
Overload this method to implement and external command within Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
Result Execute(
    ExternalCommandData commandData,
    out string message,
    ElementSet elements
)
Visual Basic (Declaration)
Function Execute ( _
    commandData As ExternalCommandData, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> elements As ElementSet _
) As Result
Visual C++
Result Execute(
    ExternalCommandData^ commandData,
    [InAttribute] [OutAttribute] String^% message,
    [InAttribute] [OutAttribute] ElementSet^ elements
)

Parameters

commandData
Type: Autodesk.Revit.UI..::.ExternalCommandData
An ExternalCommandData object which contains reference to Application and View needed by external command.
message
Type: System..::.String %
Error message can be returned by external command. This will be displayed only if the command status was "Failed". There is a limit of 1023 characters for this message; strings longer than this will be truncated.
elements
Type: Autodesk.Revit.DB..::.ElementSet
Element set indicating problem elements to display in the failure dialog. This will be used only if the command status was "Failed".

Return Value

The result indicates if the execution fails, succeeds, or was canceled by user. If it does not succeed, Revit will undo any changes made by the external command.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Interface

[image]

Revit 2011 API
IExternalCommandAvailability Interface
Members Example See Also Send Feedback
An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IExternalCommandAvailability
Visual Basic (Declaration)
Public Interface IExternalCommandAvailability
Visual C++
public interface class IExternalCommandAvailability

Remarks

This interface should share the same assembly with add-in External Command.

Examples

CopyC#
public class SampleAccessibilityCheck : IExternalCommandAvailability
{
    public bool IsCommandAvailable(Autodesk.Revit.UI.UIApplication applicationData,
        CategorySet selectedCategories)
    {
        // Allow button click if there is no active selection
        if (selectedCategories.IsEmpty)
            return true;
        // Allow button click if there is at least one wall selected
        foreach (Category c in selectedCategories)
        {
            if (c.Id.IntegerValue == (int)BuiltInCategory.OST_Walls)
                return true;
        }
        return false;
    }
}
CopyVB.NET
Public Class SampleAccessibilityCheck
    Implements IExternalCommandAvailability
    Public Function IsCommandAvailable(ByVal applicationData As Autodesk.Revit.UI.UIApplication, _
                                       ByVal selectedCategories As CategorySet) As Boolean _
                                       Implements IExternalCommandAvailability.IsCommandAvailable
        ' Allow button click if there is no active selection
        If selectedCategories.IsEmpty Then
            Return True
        End If
        ' Allow button click if there is at least one wall selected
        For Each c As Category In selectedCategories
            If c.Id.IntegerValue = DirectCast(BuiltInCategory.OST_Walls, Integer) Then
                Return True
            End If
        Next
        Return False
    End Function
End Class

See Also

IExternalCommandAvailability Members
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Members

[image] [image]

Revit 2011 API
IExternalCommandAvailability Members
IExternalCommandAvailability Interface Methods See Also Send Feedback

The IExternalCommandAvailability type exposes the following members.

Methods

Name | Description
IsCommandAvailable | Implement this method to provide control over whether your external command is enabled or disabled.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Methods

[image] [image]

Revit 2011 API
IExternalCommandAvailability Methods
IExternalCommandAvailability Interface See Also Send Feedback

The IExternalCommandAvailability type exposes the following members.

Methods

Name | Description
IsCommandAvailable | Implement this method to provide control over whether your external command is enabled or disabled.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


IsCommandAvailable Method

[image]

Revit 2011 API
IExternalCommandAvailability..::.IsCommandAvailable Method
IExternalCommandAvailability Interface See Also Send Feedback
Implement this method to provide control over whether your external command is enabled or disabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
bool IsCommandAvailable(
    UIApplication applicationData,
    CategorySet selectedCategories
)
Visual Basic (Declaration)
Function IsCommandAvailable ( _
    applicationData As UIApplication, _
    selectedCategories As CategorySet _
) As Boolean
Visual C++
bool IsCommandAvailable(
    UIApplication^ applicationData,
    CategorySet^ selectedCategories
)

Parameters

applicationData
Type: Autodesk.Revit.UI..::.UIApplication
An ApplicationServices.Application object which contains reference to Application needed by external command.
selectedCategories
Type: Autodesk.Revit.DB..::.CategorySet
An list of categories of the elements which have been selected in Revit in the active document, or an empty set if no elements are selected or there is no active document.

Return Value

Indicates whether Revit should enable or disable the corresponding external command.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


PulldownButton Class

[image]

Revit 2011 API
PulldownButton Class
Members See Also Send Feedback
The PulldownButton object represents a button with a drop-down list on RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class PulldownButton : RibbonButton
Visual Basic (Declaration)
Public Class PulldownButton _
    Inherits RibbonButton
Visual C++
public ref class PulldownButton : public RibbonButton

Remarks

Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PulldownButton
Autodesk.Revit.UI..::.SplitButton

See Also

PulldownButton Members
Autodesk.Revit.UI Namespace


PulldownButton Members

[image] [image]

Revit 2011 API
PulldownButton Members
PulldownButton Class Methods Properties See Also Send Feedback

The PulldownButton type exposes the following members.

Methods

Name | Description
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
AddSeparator | Adds a separator to the drop-down list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of buttons assigned to the pulldown button.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButton Methods

[image] [image]

Revit 2011 API
PulldownButton Methods
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Methods

Name | Description
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
AddSeparator | Adds a separator to the drop-down list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of buttons assigned to the pulldown button.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


AddPushButton Method

[image]

Revit 2011 API
PulldownButton..::.AddPushButton Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public PushButton AddPushButton(
    PushButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddPushButton ( _
    buttonData As PushButtonData _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    PushButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit.UI..::.PushButtonData
An object containing the data needed to construct the pushbutton.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when button with buttonData.Name already exists in the button.

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2011 API
PulldownButton..::.AddSeparator Method
PulldownButton Class See Also Send Feedback
Adds a separator to the drop-down list.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddSeparator()
Visual Basic (Declaration)
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator will appear just below the last added PushButton.

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2011 API
PulldownButton..::.GetItems Method
PulldownButton Class See Also Send Feedback
Gets a copy of the collection of buttons assigned to the pulldown button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<PushButton> GetItems()
Visual Basic (Declaration)
Public Function GetItems As IList(Of PushButton)
Visual C++
public:
IList<PushButton^>^ GetItems()

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButton Properties

[image] [image]

Revit 2011 API
PulldownButton Properties
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButtonData Class

[image]

Revit 2011 API
PulldownButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a pulldown button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class PulldownButtonData : ButtonData
Visual Basic (Declaration)
Public Class PulldownButtonData _
    Inherits ButtonData
Visual C++
public ref class PulldownButtonData : public ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PulldownButtonData
Autodesk.Revit.UI..::.SplitButtonData

See Also

PulldownButtonData Members
Autodesk.Revit.UI Namespace


PulldownButtonData Members

[image] [image]

Revit 2011 API
PulldownButtonData Members
PulldownButtonData Class Constructors Methods Properties See Also Send Feedback

The PulldownButtonData type exposes the following members.

Constructors

Name | Description
PulldownButtonData | Constructs a new instance of PulldownButtonData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Constructor

[image]

Revit 2011 API
PulldownButtonData Constructor
PulldownButtonData Class See Also Send Feedback
Constructs a new instance of PulldownButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public PulldownButtonData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
PulldownButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Methods

[image] [image]

Revit 2011 API
PulldownButtonData Methods
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Properties

[image] [image]

Revit 2011 API
PulldownButtonData Properties
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PushButton Class

[image]

Revit 2011 API
PushButton Class
Members Example See Also Send Feedback
The PushButton object represents an button on a RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class PushButton : RibbonButton
Visual Basic (Declaration)
Public Class PushButton _
    Inherits RibbonButton
Visual C++
public ref class PushButton : public RibbonButton

Remarks

Use of this class is not supported in Revit VSTA.

Examples

CopyC#
private void AddPushButton(RibbonPanel panel)
{
    PushButton pushButton = panel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    pushButton.ToolTip = "Say Hello World";
    // Set the large image shown on button
    pushButton.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
}
CopyVB.NET
Private Sub AddPushButton(ByVal panel As RibbonPanel)
    Dim pushButton As PushButton = TryCast(panel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    pushButton.ToolTip = "Say Hello World"
    ' Set the large image shown on button
    pushButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"))
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PushButton
Autodesk.Revit.UI..::.ToggleButton

See Also

PushButton Members
Autodesk.Revit.UI Namespace


PushButton Members

[image] [image]

Revit 2011 API
PushButton Members
PushButton Class Methods Properties See Also Send Feedback

The PushButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button.
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButton Methods

[image] [image]

Revit 2011 API
PushButton Methods
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButton Properties

[image] [image]

Revit 2011 API
PushButton Properties
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
ClassName | The name of the class containing the implementation for the command.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


AssemblyName Property

[image]

Revit 2011 API
PushButton..::.AssemblyName Property
PushButton Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


AvailabilityClassName Property

[image]

Revit 2011 API
PushButton..::.AvailabilityClassName Property
PushButton Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this push button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic (Declaration)
Public Property AvailabilityClassName As String
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


ClassName Property

[image]

Revit 2011 API
PushButton..::.ClassName Property
PushButton Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButtonData Class

[image]

Revit 2011 API
PushButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a push button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class PushButtonData : ButtonData
Visual Basic (Declaration)
Public Class PushButtonData _
    Inherits ButtonData
Visual C++
public ref class PushButtonData : public ButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PushButtonData
Autodesk.Revit.UI..::.ToggleButtonData

See Also

PushButtonData Members
Autodesk.Revit.UI Namespace


PushButtonData Members

[image] [image]

Revit 2011 API
PushButtonData Members
PushButtonData Class Constructors Methods Properties See Also Send Feedback

The PushButtonData type exposes the following members.

Constructors

Name | Description
PushButtonData | Constructs a new instance of PushButtonData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button.
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
ClassName | The name of the class containing the implementation for the command.
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Constructor

[image]

Revit 2011 API
PushButtonData Constructor
PushButtonData Class See Also Send Feedback
Constructs a new instance of PushButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public PushButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
PushButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String
The user visible text seen on the new button.
assemblyName
Type: System..::.String
The assembly path of the button.
className
Type: System..::.String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Methods

[image] [image]

Revit 2011 API
PushButtonData Methods
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Properties

[image] [image]

Revit 2011 API
PushButtonData Properties
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button.
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
ClassName | The name of the class containing the implementation for the command.
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


AssemblyName Property

[image]

Revit 2011 API
PushButtonData..::.AssemblyName Property
PushButtonData Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


AvailabilityClassName Property

[image]

Revit 2011 API
PushButtonData..::.AvailabilityClassName Property
PushButtonData Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this push button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic (Declaration)
Public Property AvailabilityClassName As String
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


ClassName Property

[image]

Revit 2011 API
PushButtonData..::.ClassName Property
PushButtonData Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Class

[image]

Revit 2011 API
RadioButtonGroup Class
Members Example See Also Send Feedback
Represents a group of related buttons in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RadioButtonGroup : RibbonItem
Visual Basic (Declaration)
Public Class RadioButtonGroup _
    Inherits RibbonItem
Visual C++
public ref class RadioButtonGroup : public RibbonItem

Remarks

This class contains a collection of ToggleButtons. Only one of the ToggleButtons will appear active at a given time. When a different button is clicked in the UI the current ToggleButton will be changed, and the ToggleButton's external command will be invoked. Use of this class is not supported in Revit VSTA.

Examples

CopyC#
private void AddRadioGroup(RibbonPanel panel)
{
    // add radio button group
    RadioButtonGroupData radioData = new RadioButtonGroupData("radioGroup");
    RadioButtonGroup radioButtonGroup = panel.AddItem(radioData) as RadioButtonGroup;

    // create toggle buttons and add to radio button group
    ToggleButtonData tb1 = new ToggleButtonData("toggleButton1", "Red");
    tb1.ToolTip = "Red Option";
    tb1.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    ToggleButtonData tb2 = new ToggleButtonData("toggleButton2", "Green");
    tb2.ToolTip = "Green Option";
    tb2.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));
    ToggleButtonData tb3 = new ToggleButtonData("toggleButton3", "Blue");
    tb3.ToolTip = "Blue Option";
    tb3.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    radioButtonGroup.AddItem(tb1);
    radioButtonGroup.AddItem(tb2);
    radioButtonGroup.AddItem(tb3);
}
CopyVB.NET
Private Sub AddRadioGroup(ByVal panel As RibbonPanel)
    ' add radio button group
    Dim radioData As New RadioButtonGroupData("radioGroup")
    Dim radioButtonGroup As RadioButtonGroup = TryCast(panel.AddItem(radioData), RadioButtonGroup)

    ' create toggle buttons and add to radio button group
    Dim tb1 As New ToggleButtonData("toggleButton1", "Red")
    tb1.ToolTip = "Red Option"
    tb1.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim tb2 As New ToggleButtonData("toggleButton2", "Green")
    tb2.ToolTip = "Green Option"
    tb2.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))
    Dim tb3 As New ToggleButtonData("toggleButton3", "Blue")
    tb3.ToolTip = "Blue Option"
    tb3.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    radioButtonGroup.AddItem(tb1)
    radioButtonGroup.AddItem(tb2)
    radioButtonGroup.AddItem(tb3)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RadioButtonGroup

See Also

RadioButtonGroup Members
Autodesk.Revit.UI Namespace


RadioButtonGroup Members

[image] [image]

Revit 2011 API
RadioButtonGroup Members
RadioButtonGroup Class Methods Properties See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Methods

Name | Description
AddItem | Adds a new ToggleButton to the RadioButtonGroup.
AddItems | Adds new ToggleButtons to the RadioButtonGroup.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Methods

[image] [image]

Revit 2011 API
RadioButtonGroup Methods
RadioButtonGroup Class See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Methods

Name | Description
AddItem | Adds a new ToggleButton to the RadioButtonGroup.
AddItems | Adds new ToggleButtons to the RadioButtonGroup.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2011 API
RadioButtonGroup..::.AddItem Method
RadioButtonGroup Class See Also Send Feedback
Adds a new ToggleButton to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ToggleButton AddItem(
    ToggleButtonData buttonData
)
Visual Basic (Declaration)
Public Function AddItem ( _
    buttonData As ToggleButtonData _
) As ToggleButton
Visual C++
public:
ToggleButton^ AddItem(
    ToggleButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit.UI..::.ToggleButtonData
An object containing the data needed to construct the ToggleButton.

Return Value

The newly added ToggleButton.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when button with buttonData.Name already exists in the group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


AddItems Method

[image]

Revit 2011 API
RadioButtonGroup..::.AddItems Method
RadioButtonGroup Class See Also Send Feedback
Adds new ToggleButtons to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ToggleButton> AddItems(
    IList<ToggleButtonData> buttonData
)
Visual Basic (Declaration)
Public Function AddItems ( _
    buttonData As IList(Of ToggleButtonData) _
) As IList(Of ToggleButton)
Visual C++
public:
IList<ToggleButton^>^ AddItems(
    IList<ToggleButtonData^>^ buttonData
)

Parameters

buttonData
Type: System.Collections.Generic..::.IList <(Of <( ToggleButtonData >)>)
A list of objects containing the data needed to construct the ToggleButtons.

Return Value

The newly added ToggleButtons.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when button with buttonData.Name already exists in the group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2011 API
RadioButtonGroup..::.GetItems Method
RadioButtonGroup Class See Also Send Feedback
Gets the collection of ToggleButtons assigned to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<ToggleButton> GetItems()
Visual Basic (Declaration)
Public Function GetItems As IList(Of ToggleButton)
Visual C++
public:
IList<ToggleButton^>^ GetItems()

Remarks

This is a copy of all the ToggleButtons assigned to this group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Properties

[image] [image]

Revit 2011 API
RadioButtonGroup Properties
RadioButtonGroup Class See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Properties

Name | Description
Current | Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2011 API
RadioButtonGroup..::.Current Property
RadioButtonGroup Class See Also Send Feedback
Gets or sets the current checked ToggleButton of the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ToggleButton Current { get; set; }
Visual Basic (Declaration)
Public Property Current As ToggleButton
Visual C++
public:
property ToggleButton^ Current {
    ToggleButton^ get ();
    void set (ToggleButton^ value);
}

Remarks

The default value is the first ToggleButton added to the group. When using this property to set the current ToggleButton, the external command of that button will not be called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set this property to a button not in this group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Class

[image]

Revit 2011 API
RadioButtonGroupData Class
Members See Also Send Feedback
This class contains information necessary to construct a ribbon gallery in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class RadioButtonGroupData : RibbonItemData
Visual Basic (Declaration)
Public Class RadioButtonGroupData _
    Inherits RibbonItemData
Visual C++
public ref class RadioButtonGroupData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.RadioButtonGroupData

See Also

RadioButtonGroupData Members
Autodesk.Revit.UI Namespace


RadioButtonGroupData Members

[image] [image]

Revit 2011 API
RadioButtonGroupData Members
RadioButtonGroupData Class Constructors Methods Properties See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Constructors

Name | Description
RadioButtonGroupData | Constructs a new instance of RadioButtonGroupData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Constructor

[image]

Revit 2011 API
RadioButtonGroupData Constructor
RadioButtonGroupData Class See Also Send Feedback
Constructs a new instance of RadioButtonGroupData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public RadioButtonGroupData(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
RadioButtonGroupData(
    String^ name
)

Parameters

name
Type: System..::.String
The internal name of the RadioButtonGroup.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for name.

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Methods

[image] [image]

Revit 2011 API
RadioButtonGroupData Methods
RadioButtonGroupData Class See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Properties

[image] [image]

Revit 2011 API
RadioButtonGroupData Properties
RadioButtonGroupData Class See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Properties

Name | Description
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


Result Enumeration

[image]

Revit 2011 API
Result Enumeration
See Also Send Feedback
Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public enum Result
Visual Basic (Declaration)
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Failed | The external application was unable to complete its task.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Cancelled | Signifies that the external application is cancelled.

See Also

Autodesk.Revit.UI Namespace


RibbonButton Class

[image]

Revit 2011 API
RibbonButton Class
Members See Also Send Feedback
This class is the base class of PushButton and PulldownButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonButton : RibbonItem
Visual Basic (Declaration)
Public Class RibbonButton _
    Inherits RibbonItem
Visual C++
public ref class RibbonButton : public RibbonItem

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PulldownButton
Autodesk.Revit.UI..::.PushButton

See Also

RibbonButton Members
Autodesk.Revit.UI Namespace


RibbonButton Members

[image] [image]

Revit 2011 API
RibbonButton Members
RibbonButton Class Methods Properties See Also Send Feedback

The RibbonButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonButton Methods

[image] [image]

Revit 2011 API
RibbonButton Methods
RibbonButton Class See Also Send Feedback

The RibbonButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonButton Properties

[image] [image]

Revit 2011 API
RibbonButton Properties
RibbonButton Class See Also Send Feedback

The RibbonButton type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button.
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
RibbonButton..::.Image Property
RibbonButton Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set or if it is promoted to the Quick Access Toolbar. The image should be 16 x 16 pixels. If the image is larger it will NOT be adjusted to fit the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


LargeImage Property

[image]

Revit 2011 API
RibbonButton..::.LargeImage Property
RibbonButton Class See Also Send Feedback
The large image shown on the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic (Declaration)
Public Property LargeImage As ImageSource
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown if the button is added to a pulldown button. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonItem Class

[image]

Revit 2011 API
RibbonItem Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItem
Visual Basic (Declaration)
Public Class RibbonItem
Visual C++
public ref class RibbonItem

Remarks

This class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.ComboBox
Autodesk.Revit.UI..::.ComboBoxMember
Autodesk.Revit.UI..::.RadioButtonGroup
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.TextBox

See Also

RibbonItem Members
Autodesk.Revit.UI Namespace


RibbonItem Members

[image] [image]

Revit 2011 API
RibbonItem Members
RibbonItem Class Methods Properties See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled.
ItemText | Gets or sets the text displayed on the item.
ItemType | Gets the item type.
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip
Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItem Methods

[image] [image]

Revit 2011 API
RibbonItem Methods
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Equals Method

[image]

Revit 2011 API
RibbonItem..::.Equals Method
RibbonItem Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another panel object.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItem Properties

[image] [image]

Revit 2011 API
RibbonItem Properties
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled.
ItemText | Gets or sets the text displayed on the item.
ItemType | Gets the item type.
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip
Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Enabled Property

[image]

Revit 2011 API
RibbonItem..::.Enabled Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is enabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the item cannot be clicked, and the item's appearance changes. The Image and Text assigned to the item appear grayed out. If the relevant external command cannot be executed, setting Enabled to true won't have an effect. The push button will be disabled when there is no active document unless availability class of that button returns true.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ItemText Property

[image]

Revit 2011 API
RibbonItem..::.ItemText Property
RibbonItem Class See Also Send Feedback
Gets or sets the text displayed on the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic (Declaration)
Public Overridable Property ItemText As String
Visual C++
public:
virtual property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text can be changed at run time. nullNothingnullptra null reference (Nothing in Visual Basic) or empty string is not allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the text to empty or to the string contains "%".
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the text to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ItemType Property

[image]

Revit 2011 API
RibbonItem..::.ItemType Property
RibbonItem Class See Also Send Feedback
Gets the item type.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public RibbonItemType ItemType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemType As RibbonItemType
Visual C++
public:
property RibbonItemType ItemType {
    RibbonItemType get ();
}

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


LongDescription Property

[image]

Revit 2011 API
RibbonItem..::.LongDescription Property
RibbonItem Class See Also Send Feedback
Long description of the command tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string LongDescription { get; set; }
Visual Basic (Declaration)
Public Property LongDescription As String
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

It will be used as part of the button's extended tooltip. This tooltip is shown when the mouse hovers over the command for a long amount of time. You can split the text of this option into multiple paragraphs by placing <p> tags around each paragraph. Optional. If neither of this property and TooltipImage is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2011 API
RibbonItem..::.Name Property
RibbonItem Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the text to empty or to the string contains "%".

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ToolTip Property

[image]

Revit 2011 API
RibbonItem..::.ToolTip Property
RibbonItem Class See Also Send Feedback
The description that appears as a ToolTip for the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the item. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ToolTipImage Property

[image]

Revit 2011 API
RibbonItem..::.ToolTipImage Property
RibbonItem Class See Also Send Feedback
The image to show as a part of the button extended tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource ToolTipImage { get; set; }
Visual Basic (Declaration)
Public Property ToolTipImage As ImageSource
Visual C++
public:
property ImageSource^ ToolTipImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

It is shown when the mouse hovers over the command for a longer amount of time. Optional. If neither of this property and LongDescription is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Visible Property

[image]

Revit 2011 API
RibbonItem..::.Visible Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is visible.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

When the Visible property is set to false, the item won't be displayed on Ribbon.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItemData Class

[image]

Revit 2011 API
RibbonItemData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a RibbonItem in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItemData
Visual Basic (Declaration)
Public Class RibbonItemData
Visual C++
public ref class RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.ComboBoxData
Autodesk.Revit.UI..::.ComboBoxMemberData
Autodesk.Revit.UI..::.RadioButtonGroupData
Autodesk.Revit.UI..::.TextBoxData

See Also

RibbonItemData Members
Autodesk.Revit.UI Namespace


RibbonItemData Members

[image] [image]

Revit 2011 API
RibbonItemData Members
RibbonItemData Class Methods Properties See Also Send Feedback

The RibbonItemData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemData Methods

[image] [image]

Revit 2011 API
RibbonItemData Methods
RibbonItemData Class See Also Send Feedback

The RibbonItemData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemData Properties

[image] [image]

Revit 2011 API
RibbonItemData Properties
RibbonItemData Class See Also Send Feedback

The RibbonItemData type exposes the following members.

Properties

Name | Description
LongDescription | Long description of the command tooltip
Name | The name of the item.
ToolTip | The description that appears as a ToolTip for the item.
ToolTipImage | The image to show as a part of the button extended tooltip

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


LongDescription Property

[image]

Revit 2011 API
RibbonItemData..::.LongDescription Property
RibbonItemData Class See Also Send Feedback
Long description of the command tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string LongDescription { get; set; }
Visual Basic (Declaration)
Public Property LongDescription As String
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

It will be used as part of the button's extended tooltip. This tooltip is shown when the mouse hovers over the command for a long amount of time. You can split the text of this option into multiple paragraphs by placing <p> tags around each paragraph. Optional. If neither of this property and TooltipImage is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2011 API
RibbonItemData..::.Name Property
RibbonItemData Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


ToolTip Property

[image]

Revit 2011 API
RibbonItemData..::.ToolTip Property
RibbonItemData Class See Also Send Feedback
The description that appears as a ToolTip for the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the item. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


ToolTipImage Property

[image]

Revit 2011 API
RibbonItemData..::.ToolTipImage Property
RibbonItemData Class See Also Send Feedback
The image to show as a part of the button extended tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ImageSource ToolTipImage { get; set; }
Visual Basic (Declaration)
Public Property ToolTipImage As ImageSource
Visual C++
public:
property ImageSource^ ToolTipImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

It is shown when the mouse hovers over the command for a longer amount of time. Optional. If neither of this property and LongDescription is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemType Enumeration

[image]

Revit 2011 API
RibbonItemType Enumeration
See Also Send Feedback
An enumerated type listing all the toolbar item styles.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public enum RibbonItemType
Visual Basic (Declaration)
Public Enumeration RibbonItemType
Visual C++
public enum class RibbonItemType

Members

Member name | Description
PushButton | A standard button with text and image.
PulldownButton | A button with a pull-down menu list.
SplitButton | A split button with a default button and a pull-down menu list.
ToggleButton | A standard button that can be added to RadioButtonGroup.
RadioButtonGroup | An item that contains a collection of RibbonToggleButton items.
ComboBoxMember | An item in the drop-down list of a ComboBox.
ComboBox | A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
TextBox | A text-based control that allows the user to enter text.

See Also

Autodesk.Revit.UI Namespace


RibbonPanel Class

[image]

Revit 2011 API
RibbonPanel Class
Members Example See Also Send Feedback
Represents a panel added by an External Application or External Command into the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonPanel
Visual Basic (Declaration)
Public Class RibbonPanel
Visual C++
public ref class RibbonPanel

Remarks

The Panel class provides read and write access to the RibbonItems contained in the panel. Use of this class is not supported in Revit VSTA.

Examples

CopyC#
public Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel �NewRibbonPanel"
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";
    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("Hello Button",
        "Hello Button", assembly, "Hello.HelloButton")) as PushButton;

    // create bitmap image for button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);

    // assign bitmap to button
    pushButton.LargeImage = largeImage;

    // assign a small bitmap to button which is used if command
    // is moved to Quick Access Toolbar
    Uri uriSmallImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png");
    BitmapImage smallImage = new BitmapImage(uriSmallImage);

    // assign small image to button
    pushButton.Image = smallImage;

    // add a vertical separator bar to the panel
    ribbonPanel.AddSeparator();

    // define 3 new buttons to be added as stacked buttons
    PushButtonData buttonRed = new PushButtonData ("Hello Red", "Hello Red",
        assembly, "Hello.HelloRed");
    buttonRed.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    PushButtonData buttonBlue = new PushButtonData("Hello Blue", "Hello Blue",
        assembly, "Hello.HelloBlue");
    buttonBlue.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    PushButtonData buttonGreen = new PushButtonData("Hello Green", "Hello Green",
        assembly, "Hello.HelloGreen");
    buttonGreen.Image =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));

    // add 3 stacked buttons to the panel
    ribbonPanel.AddStackedItems(buttonRed, buttonBlue, buttonGreen);

    // add a pull-down button to the panel
    PulldownButton pulldownButton = ribbonPanel.AddItem(new PulldownButtonData("Hello",
        "Hello 123")) as PulldownButton;
    pulldownButton.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Hello.bmp"));

    // add some menu items to the pull-down button and assign bitmaps to them
    PushButton buttonOne = pulldownButton.AddPushButton(new PushButtonData("Hello One",
        "Hello 123", assembly, "Hello.HelloOne"));
    buttonOne.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));
    PushButton buttonTwo = pulldownButton.AddPushButton(new PushButtonData("Hello Two",
        "Hello 123", assembly, "Hello.HelloTwo"));
    buttonTwo.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));
    PushButton buttonThree = pulldownButton.AddPushButton(new PushButtonData("Hello Three",
        "Hello 123", assembly, "Hello.HelloThree"));
    buttonThree.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));

    return Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel "NewRibbonPanel"
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"
    Dim pushButton As PushButton = TryCast(ribbonPanel.AddItem(New PushButtonData("Hello Button", "Hello Button", assembly, "Hello.HelloButton")), PushButton)

    ' create bitmap image for button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)

    ' assign bitmap to button
    pushButton.LargeImage = largeImage

    ' assign a small bitmap to button which is used if command
    ' is moved to Quick Access Toolbar
    Dim uriSmallImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png")
    Dim smallImage As New BitmapImage(uriSmallImage)

    ' assign small image to button
    pushButton.Image = smallImage

    ' add a vertical separator bar to the panel
    ribbonPanel.AddSeparator()

    ' define 3 new buttons to be added as stacked buttons
    Dim buttonRed As New PushButtonData("Hello Red", "Hello Red", assembly, "Hello.HelloRed")
    buttonRed.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim buttonBlue As New PushButtonData("Hello Blue", "Hello Blue", assembly, "Hello.HelloBlue")
    buttonBlue.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    Dim buttonGreen As New PushButtonData("Hello Green", "Hello Green", assembly, "Hello.HelloGreen")
    buttonGreen.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))

    ' add 3 stacked buttons to the panel
    ribbonPanel.AddStackedItems(buttonRed, buttonBlue, buttonGreen)

    ' add a pull-down button to the panel
    Dim pulldownButton As PulldownButton = TryCast(ribbonPanel.AddItem(New PulldownButtonData("Hello", "Hello 123")), PulldownButton)
    pulldownButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Hello.bmp"))

    ' add some menu items to the pull-down button and assign bitmaps to them
    Dim buttonOne As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello One", "Hello 123", assembly, "Hello.HelloOne"))
    buttonOne.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\One.bmp"))
    Dim buttonTwo As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello Two", "Hello 123", assembly, "Hello.HelloTwo"))
    buttonTwo.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Two.bmp"))
    Dim buttonThree As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello Three", "Hello 123", assembly, "Hello.HelloThree"))
    buttonThree.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Three.bmp"))

    Return Result.Succeeded
End Function

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonPanel

See Also

RibbonPanel Members
Autodesk.Revit.UI Namespace


RibbonPanel Members

[image] [image]

Revit 2011 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddItem | Adds a Ribbon item to the panel.
AddSeparator | Adds a new Separator to the panel.
AddSlideOut | Adds a slideout to the current panel.
AddStackedItems | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


RibbonPanel Methods

[image] [image]

Revit 2011 API
RibbonPanel Methods
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

Name | Description
AddItem | Adds a Ribbon item to the panel.
AddSeparator | Adds a new Separator to the panel.
AddSlideOut | Adds a slideout to the current panel.
AddStackedItems | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2011 API
RibbonPanel..::.AddItem Method
RibbonPanel Class See Also Send Feedback
Adds a Ribbon item to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public RibbonItem AddItem(
    RibbonItemData itemData
)
Visual Basic (Declaration)
Public Function AddItem ( _
    itemData As RibbonItemData _
) As RibbonItem
Visual C++
public:
RibbonItem^ AddItem(
    RibbonItemData^ itemData
)

Parameters

itemData
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the new item.

Return Value

The added Ribbon item.

Remarks

The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in. The new item may be created as a large-size vertical control in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when itemData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2011 API
RibbonPanel..::.AddSeparator Method
RibbonPanel Class See Also Send Feedback
Adds a new Separator to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void AddSeparator()
Visual Basic (Declaration)
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator won't be shown if there are no items already added to the panel.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddSlideOut Method

[image]

Revit 2011 API
RibbonPanel..::.AddSlideOut Method
RibbonPanel Class Example See Also Send Feedback
Adds a slideout to the current panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddSlideOut()
Visual Basic (Declaration)
Public Sub AddSlideOut
Visual C++
public:
void AddSlideOut()

Remarks

The slideout part of the panel can be shown by clicking on the arrow at the bottom of the panel. After calling AddSlideOut(), any subsequent calls to add new items will add the new item(s) to the slideout. The slideout part of the panel will be shown only if items are added after this call.

Examples

CopyC#
private static void AddSlideOut(RibbonPanel panel)
{
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";

    panel.AddSlideOut();

    // create some controls for the slide out
    PushButtonData b1 = new PushButtonData("ButtonName1", "Button 1",
        assembly, "Hello.HelloButton");
    b1.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
    PushButtonData b2 = new PushButtonData("ButtonName2", "Button 2",
        assembly, "Hello.HelloTwo");
    b2.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png"));

    // items added after call to AddSlideOut() are added to slide-out automatically
    panel.AddItem(b1);
    panel.AddItem(b2);
}
CopyVB.NET
Private Shared Sub AddSlideOut(ByVal panel As RibbonPanel)
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"

    panel.AddSlideOut()

    ' create some controls for the slide out
    Dim b1 As New PushButtonData("ButtonName1", "Button 1", assembly, "Hello.HelloButton")
    b1.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"))
    Dim b2 As New PushButtonData("ButtonName2", "Button 2", assembly, "Hello.HelloTwo")
    b2.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png"))

    ' items added after call to AddSlideOut() are added to slide-out automatically
    panel.AddItem(b1)
    panel.AddItem(b2)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when a slide out panel is already added.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddStackedItems Method

[image] [image]

Revit 2011 API
RibbonPanel..::.AddStackedItems Method
RibbonPanel Class See Also Send Feedback

Overload List

Name | Description
AddStackedItems(RibbonItemData, RibbonItemData) | Adds two stacked items to the panel.
AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) | Adds three stacked items to the panel.

See Also

RibbonPanel Class
RibbonPanel Members
Autodesk.Revit.UI Namespace


AddStackedItems Method (RibbonItemData, RibbonItemData)

[image]

Revit 2011 API
RibbonPanel..::.AddStackedItems Method (RibbonItemData, RibbonItemData)
RibbonPanel Class See Also Send Feedback
Adds two stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
    RibbonItemData item1,
    RibbonItemData item2
)
Visual Basic (Declaration)
Public Function AddStackedItems ( _
    item1 As RibbonItemData, _
    item2 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
    RibbonItemData^ item1,
    RibbonItemData^ item2
)

Parameters

item1
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when item1 or item2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an item with the item1.Name or item2.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
AddStackedItems Overload
Autodesk.Revit.UI Namespace


AddStackedItems Method (RibbonItemData, RibbonItemData, RibbonItemData)

[image]

Revit 2011 API
RibbonPanel..::.AddStackedItems Method (RibbonItemData, RibbonItemData, RibbonItemData)
RibbonPanel Class See Also Send Feedback
Adds three stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
    RibbonItemData item1,
    RibbonItemData item2,
    RibbonItemData item3
)
Visual Basic (Declaration)
Public Function AddStackedItems ( _
    item1 As RibbonItemData, _
    item2 As RibbonItemData, _
    item3 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
    RibbonItemData^ item1,
    RibbonItemData^ item2,
    RibbonItemData^ item3
)

Parameters

item1
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item3
Type: Autodesk.Revit.UI..::.RibbonItemData
Data containing information about the third item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when item1, item2 or item3 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an item with item1.Name or item2.Name or item3.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
AddStackedItems Overload
Autodesk.Revit.UI Namespace


Equals Method

[image]

Revit 2011 API
RibbonPanel..::.Equals Method
RibbonPanel Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Another panel object.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2011 API
RibbonPanel..::.GetItems Method
RibbonPanel Class See Also Send Feedback
Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<RibbonItem> GetItems()
Visual Basic (Declaration)
Public Function GetItems As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ GetItems()

Remarks

This method gets the items assigned to the RibbonPanel.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


RibbonPanel Properties

[image] [image]

Revit 2011 API
RibbonPanel Properties
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Name | Gets or sets the name of the RibbonPanel.
Title | Gets or sets the text of the RibbonPanel.
Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Enabled Property

[image]

Revit 2011 API
RibbonPanel..::.Enabled Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

True if the panel allows interaction, false if the panel disallows interaction with all the controls it contains.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2011 API
RibbonPanel..::.Name Property
RibbonPanel Class See Also Send Feedback
Gets or sets the name of the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name will be displayed on the panel if the Text is not set.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Title Property

[image]

Revit 2011 API
RibbonPanel..::.Title Property
RibbonPanel Class See Also Send Feedback
Gets or sets the text of the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

If this property is not set, the default value is its Name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the title contains angle bracket.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Visible Property

[image]

Revit 2011 API
RibbonPanel..::.Visible Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel is displayed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

True if the RibbonPanel is displayed; otherwise, false. The default is true.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


SplitButton Class

[image]

Revit 2011 API
SplitButton Class
Members Example See Also Send Feedback
The SplitButton object represents a button with a clickable button appearing above a pulldown.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SplitButton : PulldownButton
Visual Basic (Declaration)
Public Class SplitButton _
    Inherits PulldownButton
Visual C++
public ref class SplitButton : public PulldownButton

Remarks

Use of this class is not supported in Revit VSTA.

Examples

CopyC#
private void AddSplitButton(RibbonPanel panel)
{
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";

    // create push buttons for split button drop down
    PushButtonData bOne = new PushButtonData("ButtonNameA", "Option One",
        assembly, "Hello.HelloOne");
    bOne.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));

    PushButtonData bTwo = new PushButtonData("ButtonNameB", "Option Two",
        assembly, "Hello.HelloTwo");
    bTwo.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));

    PushButtonData bThree = new PushButtonData("ButtonNameC", "Option Three",
        assembly, "Hello.HelloThree");
    bThree.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));

    SplitButtonData sb1 = new SplitButtonData("splitButton1", "Split");
    SplitButton sb = panel.AddItem(sb1) as SplitButton;
    sb.AddPushButton(bOne);
    sb.AddPushButton(bTwo);
    sb.AddPushButton(bThree);
}
CopyVB.NET
Private Sub AddSplitButton(ByVal panel As RibbonPanel)
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"

    ' create push buttons for split button drop down
    Dim bOne As New PushButtonData("ButtonNameA", "Option One", assembly, "Hello.HelloOne")
    bOne.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\One.bmp"))

    Dim bTwo As New PushButtonData("ButtonNameB", "Option Two", assembly, "Hello.HelloTwo")
    bTwo.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Two.bmp"))

    Dim bThree As New PushButtonData("ButtonNameC", "Option Three", assembly, "Hello.HelloThree")
    bThree.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Three.bmp"))

    Dim sb1 As New SplitButtonData("splitButton1", "Split")
    Dim sb As SplitButton = TryCast(panel.AddItem(sb1), SplitButton)
    sb.AddPushButton(bOne)
    sb.AddPushButton(bTwo)
    sb.AddPushButton(bThree)
End Sub

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PulldownButton
Autodesk.Revit.UI..::.SplitButton

See Also

SplitButton Members
Autodesk.Revit.UI Namespace


SplitButton Members

[image] [image]

Revit 2011 API
SplitButton Members
SplitButton Class Methods Properties See Also Send Feedback

The SplitButton type exposes the following members.

Methods

Name | Description
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton.)
AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentButton | Gets or sets the current PushButton of the SplitButton.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButton Methods

[image] [image]

Revit 2011 API
SplitButton Methods
SplitButton Class See Also Send Feedback

The SplitButton type exposes the following members.

Methods

Name | Description
AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton.)
AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButton Properties

[image] [image]

Revit 2011 API
SplitButton Properties
SplitButton Class See Also Send Feedback

The SplitButton type exposes the following members.

Properties

Name | Description
CurrentButton | Gets or sets the current PushButton of the SplitButton.
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


CurrentButton Property

[image]

Revit 2011 API
SplitButton..::.CurrentButton Property
SplitButton Class See Also Send Feedback
Gets or sets the current PushButton of the SplitButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public PushButton CurrentButton { get; set; }
Visual Basic (Declaration)
Public Property CurrentButton As PushButton
Visual C++
public:
property PushButton^ CurrentButton {
    PushButton^ get ();
    void set (PushButton^ value);
}

Remarks

This property is applicable only if IsSynchronizedWithCurrentItem is true. The default value of this property will be the first enabled PushButton in the drop down list after the SplitButton is shown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when trying to set the CurrentButton to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when trying to set the CurrentButton to a button which is not in current drop-down list.
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when trying to set the CurrentButton if IsSynchronizedWithCurrentItem is false.

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


IsSynchronizedWithCurrentItem Property

[image]

Revit 2011 API
SplitButton..::.IsSynchronizedWithCurrentItem Property
SplitButton Class See Also Send Feedback
Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool IsSynchronizedWithCurrentItem { get; set; }
Visual Basic (Declaration)
Public Property IsSynchronizedWithCurrentItem As Boolean
Visual C++
public:
property bool IsSynchronizedWithCurrentItem {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true the SplitButton uses the current PushButton's properties to display the image, text, tooltip, etc. and executes the current item when clicked. If it is false the first listed PushButton in the GetItems() return is shown, and executes this PushButton when clicked. If it is false the items in drop down list can only be executed by opening the drop down list and clicking an item in the list. The default value is true.

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButtonData Class

[image]

Revit 2011 API
SplitButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a split button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class SplitButtonData : PulldownButtonData
Visual Basic (Declaration)
Public Class SplitButtonData _
    Inherits PulldownButtonData
Visual C++
public ref class SplitButtonData : public PulldownButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PulldownButtonData
Autodesk.Revit.UI..::.SplitButtonData

See Also

SplitButtonData Members
Autodesk.Revit.UI Namespace


SplitButtonData Members

[image] [image]

Revit 2011 API
SplitButtonData Members
SplitButtonData Class Constructors Methods Properties See Also Send Feedback

The SplitButtonData type exposes the following members.

Constructors

Name | Description
SplitButtonData | Constructs a new instance of SplitButtonData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Constructor

[image]

Revit 2011 API
SplitButtonData Constructor
SplitButtonData Class See Also Send Feedback
Constructs a new instance of SplitButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public SplitButtonData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
SplitButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String

Remarks

This text will be displayed on the button if drop-down is empty. If sub-items are added, then the split button will display the current PushButton's text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Methods

[image] [image]

Revit 2011 API
SplitButtonData Methods
SplitButtonData Class See Also Send Feedback

The SplitButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Properties

[image] [image]

Revit 2011 API
SplitButtonData Properties
SplitButtonData Class See Also Send Feedback

The SplitButtonData type exposes the following members.

Properties

Name | Description
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


Tab Enumeration

[image]

Revit 2011 API
Tab Enumeration
See Also Send Feedback
An enumerated type listing static tabs which support addition of panels via the API.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public enum Tab
Visual Basic (Declaration)
Public Enumeration Tab
Visual C++
public enum class Tab

Members

Member name | Description
AddIns | The Add-Ins tab.
Analyze | The Analyze tab.

See Also

Autodesk.Revit.UI Namespace


TaskDialog Class

[image]

Revit 2011 API
TaskDialog Class
Members Example See Also Send Feedback
A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TaskDialog : APIObject
Visual Basic (Declaration)
Public Class TaskDialog _
    Inherits APIObject
Visual C++
public ref class TaskDialog : public APIObject

Remarks

There are two ways to create and show a task dialog to the user. The first option is to construct the TaskDialog, set its properties individually, and use the instance method Show() to show it to the user. The second is to use one of the static Show() methods to construct and show the dialog in one step. When you use the static methods only a subset of the options can be specified.

Please follow Revit standards to create task dialogs. The standards are listed in the remarks of each property or method.

Examples

CopyC#
// Get the application and document from external command data.
Application app = commandData.Application.Application;
Document activeDoc = commandData.Application.ActiveUIDocument.Document;

// Creates a Revit task dialog to communicate information to the user.
TaskDialog mainDialog = new TaskDialog("Hello, Revit!");
mainDialog.MainInstruction = "Hello, Revit!";
mainDialog.MainContent =
    "This sample shows how to use a Revit task dialog to communicate with the user."
    + "The command links below open additional task dialogs with more information.";

// Add commmandLink options to task dialog
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink1,
                          "View information about the Revit installation");
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink2,
                          "View information about the active document");

// Set common buttons and default button. If no CommonButton or CommandLink is added,
// task dialog will show a Close button by default
mainDialog.CommonButtons = TaskDialogCommonButtons.Close;
mainDialog.DefaultButton = TaskDialogResult.Close;

// Set footer text. Footer text is usually used to link to the help document.
mainDialog.FooterText =
    "<a href=\"http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=2484975 \">"
    + "Click here for the Revit API Developer Center</a>";

TaskDialogResult tResult = mainDialog.Show();

// If the user clicks the first command link, a simple Task Dialog
// with only a Close button shows information about the Revit installation.
if (TaskDialogResult.CommandLink1 == tResult)
{
    TaskDialog dialog_CommandLink1 = new TaskDialog("Revit Build Information");
    dialog_CommandLink1.MainInstruction =
        "Revit Version Name is: " + app.VersionName + "\n"
        + "Revit Version Number is: " + app.VersionNumber + "\n"
        + "Revit Version Build is: " + app.VersionBuild;

    dialog_CommandLink1.Show();

}

// If the user clicks the second command link, a simple Task Dialog
// created by static method shows information about the active document
else if (TaskDialogResult.CommandLink2 == tResult)
{
    TaskDialog.Show("Active Document Inforamtion",
        "Active document: " + activeDoc.Title + "\n"
        + "Active view name: " + activeDoc.ActiveView.Name);
}
CopyVB.NET
' Get the application and document from external command data.
Dim app As Application = commandData.Application.Application
Dim activeDoc As Document = commandData.Application.ActiveUIDocument.Document

' Creates a Revit task dialog to communicate information to the user.
Dim mainDialog As New TaskDialog("Hello, Revit!")
mainDialog.MainInstruction = "Hello, Revit!"
mainDialog.MainContent = "This sample shows how to use a Revit task dialog to communicate with the user." + "The command links below open additional task dialogs with more information."

' Add commmandLink options to task dialog
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink1, "View information about the Revit installation")
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink2, "View information about the active document")

' Set common buttons and default button. If no CommonButton or CommandLink is added,
' task dialog will show a Close button by default
mainDialog.CommonButtons = TaskDialogCommonButtons.Close
mainDialog.DefaultButton = TaskDialogResult.Close

' Set footer text. Footer text is usually used to link to the help document.
mainDialog.FooterText = "<a href=""http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=2484975 "">" + "Click here for the Revit API Developer Center</a>"

Dim tResult As TaskDialogResult = mainDialog.Show()

' If the user clicks the first command link, a simple Task Dialog
' with only a Close button shows information about the Revit installation.
If TaskDialogResult.CommandLink1 = tResult Then
    Dim dialog_CommandLink1 As New TaskDialog("Revit Build Information")
    dialog_CommandLink1.MainInstruction = "Revit Version Name is: " + app.VersionName + vbLf + "Revit Version Number is: " + app.VersionNumber + vbLf + "Revit Version Build is: " + app.VersionBuild

    dialog_CommandLink1.Show()

    ' If the user clicks the second command link, a simple Task Dialog
    ' created by static method shows information about the active document
ElseIf TaskDialogResult.CommandLink2 = tResult Then
    TaskDialog.Show("Active Document Inforamtion", "Active document: " + activeDoc.Title + vbLf + "Active view name: " + activeDoc.ActiveView.Name)
End If

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI..::.TaskDialog

See Also

TaskDialog Members
Autodesk.Revit.UI Namespace


TaskDialog Members

[image] [image]

Revit 2011 API
TaskDialog Members
TaskDialog Class Constructors Methods Properties See Also Send Feedback

The TaskDialog type exposes the following members.

Constructors

Name | Description
TaskDialog | Creates a task dialog with title.

Methods

Name | Description
AddCommandLink | Overloaded. Adds a CommandLink to the TaskDialog.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Show | Overloaded. Shows a task dialog.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WasVerificationChecked | Gets the status of the verification checkbox.

Properties

Name | Description
AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
CommonButtons | The push buttons displayed in the task dialog.
DefaultButton | The default button for the dialog.
ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
FooterText | FooterText is used in the footer area of the task dialog.
Id | The Id of the task dialog.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MainContent | MainContent is the smaller text that appears just below the main instructions.
MainIcon | The icon shown in the task dialog.
MainInstruction | The large primary text that appears at the top of a task dialog.
Title | Title of the task dialog.
TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Constructor

[image]

Revit 2011 API
TaskDialog Constructor
TaskDialog Class See Also Send Feedback
Creates a task dialog with title.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialog(
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String _
)
Visual C++
public:
TaskDialog(
    String^ title
)

Parameters

title
Type: System..::.String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when title is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when title is an empty string.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Methods

[image] [image]

Revit 2011 API
TaskDialog Methods
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Methods

Name | Description
AddCommandLink | Overloaded. Adds a CommandLink to the TaskDialog.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Show | Overloaded. Shows a task dialog.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WasVerificationChecked | Gets the status of the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


AddCommandLink Method

[image] [image]

Revit 2011 API
TaskDialog..::.AddCommandLink Method
TaskDialog Class See Also Send Feedback
Adds a CommandLink to the TaskDialog.

Overload List

Name | Description
AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.

See Also

TaskDialog Class
TaskDialog Members
Autodesk.Revit.UI Namespace


AddCommandLink Method (TaskDialogCommandLinkId, String)

[image]

Revit 2011 API
TaskDialog..::.AddCommandLink Method (TaskDialogCommandLinkId, String)
TaskDialog Class See Also Send Feedback
Adds a CommandLink associated to the given id, displaying the indicating main content.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddCommandLink(
    TaskDialogCommandLinkId id,
    string mainContent
)
Visual Basic (Declaration)
Public Sub AddCommandLink ( _
    id As TaskDialogCommandLinkId, _
    mainContent As String _
)
Visual C++
public:
void AddCommandLink(
    TaskDialogCommandLinkId id,
    String^ mainContent
)

Parameters

id
Type: Autodesk.Revit.UI..::.TaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
mainContent
Type: System..::.String
The main content of the CommandLink.

Remarks

Parameter mainContent cannot contain newlines.

If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.

CommandLinks will always be shown in the dialog in the order of their ids.

See Also

TaskDialog Class
AddCommandLink Overload
Autodesk.Revit.UI Namespace


AddCommandLink Method (TaskDialogCommandLinkId, String, String)

[image]

Revit 2011 API
TaskDialog..::.AddCommandLink Method (TaskDialogCommandLinkId, String, String)
TaskDialog Class See Also Send Feedback
Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public void AddCommandLink(
    TaskDialogCommandLinkId id,
    string mainContent,
    string supportingContent
)
Visual Basic (Declaration)
Public Sub AddCommandLink ( _
    id As TaskDialogCommandLinkId, _
    mainContent As String, _
    supportingContent As String _
)
Visual C++
public:
void AddCommandLink(
    TaskDialogCommandLinkId id,
    String^ mainContent,
    String^ supportingContent
)

Parameters

id
Type: Autodesk.Revit.UI..::.TaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
mainContent
Type: System..::.String
The main content of the CommandLink.
supportingContent
Type: System..::.String
The main content of the CommandLink.

Remarks

Parameter mainContent cannot contain newlines.

If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.

CommandLinks will always be shown in the dialog in the order of their ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when mainContent is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when mainContent is an empty string.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when the mainContent contains newline characters.

See Also

TaskDialog Class
AddCommandLink Overload
Autodesk.Revit.UI Namespace


Show Method

[image] [image]

Revit 2011 API
TaskDialog..::.Show Method
TaskDialog Class See Also Send Feedback
Shows a task dialog.

Overload List

Name | Description
Show()()() | Shows the task dialog.
Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.

See Also

TaskDialog Class
TaskDialog Members
Autodesk.Revit.UI Namespace


Show Method

[image]

Revit 2011 API
TaskDialog..::.Show Method
TaskDialog Class See Also Send Feedback
Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult Show()
Visual Basic (Declaration)
Public Function Show As TaskDialogResult
Visual C++
public:
TaskDialogResult Show()

Return Value

The user's response to the task dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the task dialog is shown out of main thread of Revit.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String)

[image]

Revit 2011 API
TaskDialog..::.Show Method (String, String)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction and a Close button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction
)
Visual Basic (Declaration)
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction
)

Parameters

title
Type: System..::.String
The title of the task dialog.
mainInstruction
Type: System..::.String
The main instruction of the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String, TaskDialogCommonButtons)

[image]

Revit 2011 API
TaskDialog..::.Show Method (String, String, TaskDialogCommonButtons)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction and common buttons.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction,
    TaskDialogCommonButtons buttons
)
Visual Basic (Declaration)
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String, _
    buttons As TaskDialogCommonButtons _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction,
    TaskDialogCommonButtons buttons
)

Parameters

title
Type: System..::.String
The title of the task dialog.
mainInstruction
Type: System..::.String
The main instruction of the task dialog.
buttons
Type: Autodesk.Revit.UI..::.TaskDialogCommonButtons
The common buttons to be shown the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String, TaskDialogCommonButtons, TaskDialogResult)

[image]

Revit 2011 API
TaskDialog..::.Show Method (String, String, TaskDialogCommonButtons, TaskDialogResult)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction, common buttons and default buttons.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction,
    TaskDialogCommonButtons buttons,
    TaskDialogResult defaultButton
)
Visual Basic (Declaration)
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String, _
    buttons As TaskDialogCommonButtons, _
    defaultButton As TaskDialogResult _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction,
    TaskDialogCommonButtons buttons,
    TaskDialogResult defaultButton
)

Parameters

title
Type: System..::.String
The title of the task dialog.
mainInstruction
Type: System..::.String
The main instruction of the task dialog.
buttons
Type: Autodesk.Revit.UI..::.TaskDialogCommonButtons
The common buttons to be shown the task dialog.
defaultButton
Type: Autodesk.Revit.UI..::.TaskDialogResult
The default button of the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


WasVerificationChecked Method

[image]

Revit 2011 API
TaskDialog..::.WasVerificationChecked Method
TaskDialog Class See Also Send Feedback
Gets the status of the verification checkbox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool WasVerificationChecked()
Visual Basic (Declaration)
Public Function WasVerificationChecked As Boolean
Visual C++
public:
bool WasVerificationChecked()

Return Value

Whether the verification checkbox is checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the task dialog does not have verification checkbox or the task dialog is not shown yet.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Properties

[image] [image]

Revit 2011 API
TaskDialog Properties
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Properties

Name | Description
AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
CommonButtons | The push buttons displayed in the task dialog.
DefaultButton | The default button for the dialog.
ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
FooterText | FooterText is used in the footer area of the task dialog.
Id | The Id of the task dialog.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
MainContent | MainContent is the smaller text that appears just below the main instructions.
MainIcon | The icon shown in the task dialog.
MainInstruction | The large primary text that appears at the top of a task dialog.
Title | Title of the task dialog.
TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


AllowCancellation Property

[image]

Revit 2011 API
TaskDialog..::.AllowCancellation Property
TaskDialog Class See Also Send Feedback
Whether the task dialog can be cancelled if no cancel button is specified.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool AllowCancellation { get; set; }
Visual Basic (Declaration)
Public Property AllowCancellation As Boolean
Visual C++
public:
property bool AllowCancellation {
    bool get ();
    void set (bool value);
}

Remarks

The default value is true. If there is a cancel button in the task dialog, the it always can be cancelled.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


CommonButtons Property

[image]

Revit 2011 API
TaskDialog..::.CommonButtons Property
TaskDialog Class See Also Send Feedback
The push buttons displayed in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogCommonButtons CommonButtons { get; set; }
Visual Basic (Declaration)
Public Property CommonButtons As TaskDialogCommonButtons
Visual C++
public:
property TaskDialogCommonButtons CommonButtons {
    TaskDialogCommonButtons get ();
    void set (TaskDialogCommonButtons value);
}

Remarks

If no common button or CommandLink is added to the task dialog, the dialog will contain the Close common button by default.

Revit task dialogs are following these conventions for commit button usage:

  • Use a single Close button instead of a single OK button on informational messages.
  • Use a question at the end of the Main Instruction with a Yes/No combo (or Yes/No/Cancel) instead of OK/Cancel. This should work 99% of the time. For example: “Are you sure you want to overwrite the file?” and use Yes/No buttons.
  • Do not customize the button names unless there is a very good reason to do so. For example, “Are you sure you want to save the file?” would use Yes/No buttons and not Save/No or Save/Cancel.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


DefaultButton Property

[image]

Revit 2011 API
TaskDialog..::.DefaultButton Property
TaskDialog Class See Also Send Feedback
The default button for the dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult DefaultButton { get; set; }
Visual Basic (Declaration)
Public Property DefaultButton As TaskDialogResult
Visual C++
public:
property TaskDialogResult DefaultButton {
    TaskDialogResult get ();
    void set (TaskDialogResult value);
}

Remarks

If DefaultButton is TaskDialogResult.None or its value does not correspond to any CommonButton or CommandLink in the dialog, then the first button in the dialog will be the default.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


ExpandedContent Property

[image]

Revit 2011 API
TaskDialog..::.ExpandedContent Property
TaskDialog Class See Also Send Feedback
ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string ExpandedContent { get; set; }
Visual Basic (Declaration)
Public Property ExpandedContent As String
Visual C++
public:
property String^ ExpandedContent {
    String^ get ();
    void set (String^ value);
}

Remarks

If added to a dialog, a Show/Hide toggle button displays at the bottom of the task dialog. The Expanded Content is hidden by default. This area is used when even more information needs to be relayed to the user than space allows. It is rarely used, but can be used for showing technical information passed through in a variable, for example back-end error information, lists of files, etc. Variable information should always be introduced with a lead-in sentence.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


FooterText Property

[image]

Revit 2011 API
TaskDialog..::.FooterText Property
TaskDialog Class See Also Send Feedback
FooterText is used in the footer area of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string FooterText { get; set; }
Visual Basic (Declaration)
Public Property FooterText As String
Visual C++
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


Id Property

[image]

Revit 2011 API
TaskDialog..::.Id Property
TaskDialog Class See Also Send Feedback
The Id of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Remarks

Id is used as TaskDialogShowingEventArgs.DialogId for DialogBoxShowing events.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainContent Property

[image]

Revit 2011 API
TaskDialog..::.MainContent Property
TaskDialog Class See Also Send Feedback
MainContent is the smaller text that appears just below the main instructions.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string MainContent { get; set; }
Visual Basic (Declaration)
Public Property MainContent As String
Visual C++
public:
property String^ MainContent {
    String^ get ();
    void set (String^ value);
}

Remarks

The Main Content is optional. It should be used to give further explanation to the user, such as how to correct the problem or work around the situation. It displays in a smaller black font below the main instructions. Follow these guidelines:
  • Text should be clear and jargon free.
  • Main content should not simply restate the main instructions in a different way, they should contain additional information that builds upon or reinforces the main instructions.
  • Main content should be written in sentence format (normal capitalization and punctuation).
  • Address the user directly as “you” when needed.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainIcon Property

[image]

Revit 2011 API
TaskDialog..::.MainIcon Property
TaskDialog Class See Also Send Feedback
The icon shown in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TaskDialogIcon MainIcon { get; set; }
Visual Basic (Declaration)
Public Property MainIcon As TaskDialogIcon
Visual C++
public:
property TaskDialogIcon MainIcon {
    TaskDialogIcon get ();
    void set (TaskDialogIcon value);
}

Remarks

There is no icon by default.

Task dialogs in Revit rarely use icons, to reduce the visual clutter shown to the user. Only one icon can be used in the task dialog, the Warning (!) icon, and it should be used only when there is a risk of data loss or significant time lost. If there is no data loss or time lost as a possible result of the message, do not use the icon.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainInstruction Property

[image]

Revit 2011 API
TaskDialog..::.MainInstruction Property
TaskDialog Class See Also Send Feedback
The large primary text that appears at the top of a task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string MainInstruction { get; set; }
Visual Basic (Declaration)
Public Property MainInstruction As String
Visual C++
public:
property String^ MainInstruction {
    String^ get ();
    void set (String^ value);
}

Remarks

It should concisely sum up the problem or situation that is causing the message to display. Follow these guidelines:

  • Every task dialog includes a main instruction.
  • Text should not exceed three lines.
  • Text should use plain language and be jargon free.
  • Main instructions should be written in sentence format – normal capitalization and punctuation.
  • Address the user directly as “you” when appropriate.
  • When presented with multiple command link options the standard final line for the main instructions should be, "What do you want to do?”

Revit will automatically break lines to make the message fit well. "\n" also breaks down to the next line. For a paragraph break, use "\n\n".

Hyperlinks added to the main instructions will not be enabled when the dialog is shown on Vista.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


Title Property

[image]

Revit 2011 API
TaskDialog..::.Title Property
TaskDialog Class See Also Send Feedback
Title of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

Titles of task dialogs should be unique. Do not reuse the same title for multiple task dialogs.

Newline characters are not allowed in Title.

When the dialogs is shown, Revit will put “External Command Name –“ or “External Application –“ in the front of the value by default. Examples:

  • Plug-in Name – No Rooms to Calculate
  • Plug-in Name – Invalid Value for Length
You can suppress it by setting TitleAutoPrefix to false.

Titles should describe the nature of the problem or state the situation that currently exists. The title tells the user why they are getting the message, not what they are supposed to do.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when setting the value to an empty string or string contains newline characters.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TitleAutoPrefix Property

[image]

Revit 2011 API
TaskDialog..::.TitleAutoPrefix Property
TaskDialog Class See Also Send Feedback
Whether the TaskDialog's title will automatically have the add-in name added as a prefix.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool TitleAutoPrefix { get; set; }
Visual Basic (Declaration)
Public Property TitleAutoPrefix As Boolean
Visual C++
public:
property bool TitleAutoPrefix {
    bool get ();
    void set (bool value);
}

Remarks

The default value is true.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


VerificationText Property

[image]

Revit 2011 API
TaskDialog..::.VerificationText Property
TaskDialog Class See Also Send Feedback
VerificationText is used to label the verification checkbox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string VerificationText { get; set; }
Visual Basic (Declaration)
Public Property VerificationText As String
Visual C++
public:
property String^ VerificationText {
    String^ get ();
    void set (String^ value);
}

Remarks

If VerificationText is set, a checkbox with the text will be shown. You can get the response of checkbox by checking the return value of the WasVerificationChecked() method.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialogCommandLinkId Enumeration

[image]

Revit 2011 API
TaskDialogCommandLinkId Enumeration
See Also Send Feedback
Enum to specify the Id of CommandLink.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogCommandLinkId
Visual Basic (Declaration)
Public Enumeration TaskDialogCommandLinkId
Visual C++
public enum class TaskDialogCommandLinkId

Members

Member name | Description
CommandLink1 | CommandLink1.
CommandLink2 | CommandLink2.
CommandLink3 | CommandLink3.
CommandLink4 | CommandLink4.

See Also

Autodesk.Revit.UI Namespace


TaskDialogCommonButtons Enumeration

[image]

Revit 2011 API
TaskDialogCommonButtons Enumeration
See Also Send Feedback
A enumerated type containing the standard buttons available for Task Dialogs.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
[FlagsAttribute]
public enum TaskDialogCommonButtons
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration TaskDialogCommonButtons
Visual C++
[FlagsAttribute]
public enum class TaskDialogCommonButtons

Members

Member name | Description
None | No common button.
Ok | Ok button.
Yes | Yes button.
No | No button.
Cancel | Cancel button.
Retry | Retry button.
Close | Close button.

See Also

Autodesk.Revit.UI Namespace


TaskDialogIcon Enumeration

[image]

Revit 2011 API
TaskDialogIcon Enumeration
See Also Send Feedback
Standard icons to be used in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogIcon
Visual Basic (Declaration)
Public Enumeration TaskDialogIcon
Visual C++
public enum class TaskDialogIcon

Members

Member name | Description
TaskDialogIconNone | No icon.
TaskDialogIconWarning | Warning icon.

See Also

Autodesk.Revit.UI Namespace


TaskDialogResult Enumeration

[image]

Revit 2011 API
TaskDialogResult Enumeration
See Also Send Feedback
Enum to specify the task dialog result.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogResult
Visual Basic (Declaration)
Public Enumeration TaskDialogResult
Visual C++
public enum class TaskDialogResult

Members

Member name | Description
None | Nothing is returned from the task dialog.
Ok | The return value for TaskDialogCommonButtons.Ok.
Cancel | The return value for TaskDialogCommonButtons.Cancel or the task dialog is cancelled by ESC, Alt+F4 or the X close button.
Retry | The return value for TaskDialogCommonButtons.Retry.
Yes | The return value for TaskDialogCommonButtons.Yes.
No | The return value for TaskDialogCommonButtons.No.
Close | The return value for TaskDialogCommonButtons.Close.
CommandLink1 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink1.
CommandLink2 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink2.
CommandLink3 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink3.
CommandLink4 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink4.

See Also

Autodesk.Revit.UI Namespace


TextBox Class

[image]

Revit 2011 API
TextBox Class
Members See Also Send Feedback
The TextBox object represents text-based control that allows the user to enter text.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TextBox : RibbonItem
Visual Basic (Declaration)
Public Class TextBox _
    Inherits RibbonItem
Visual C++
public ref class TextBox : public RibbonItem

Remarks

The ItemText property inherited from RibbonItem has no effect. The text entered in the TextBox is edited by the UI user is accepted only if the user presses the Enter key or click the image button when ShowImageAsButton is true. If the user clicks off of this component without pressing Enter or click the image button; then the text will be reverted to the previous value. Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.TextBox

See Also

TextBox Members
Autodesk.Revit.UI Namespace


TextBox Members

[image] [image]

Revit 2011 API
TextBox Members
TextBox Class Methods Properties Events See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the TextBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
PromptText | The prompt text for the text box.
SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Value | The object that supplies the text value.
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Width | Gets or sets the width of the TextBox.

Events

Name | Description
EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Methods

[image] [image]

Revit 2011 API
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Properties

[image] [image]

Revit 2011 API
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the TextBox.
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
PromptText | The prompt text for the text box.
SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Value | The object that supplies the text value.
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Width | Gets or sets the width of the TextBox.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
TextBox..::.Image Property
TextBox Class See Also Send Feedback
The image of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


PromptText Property

[image]

Revit 2011 API
TextBox..::.PromptText Property
TextBox Class See Also Send Feedback
The prompt text for the text box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public string PromptText { get; set; }
Visual Basic (Declaration)
Public Property PromptText As String
Visual C++
public:
property String^ PromptText {
    String^ get ();
    void set (String^ value);
}

Remarks

Prompt text is displayed when the text box is empty and does not have keyboard focus. This text is displayed in italics. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

TextBox Class
Autodesk.Revit.UI Namespace


SelectTextOnFocus Property

[image]

Revit 2011 API
TextBox..::.SelectTextOnFocus Property
TextBox Class See Also Send Feedback
A value that indicates if the text is selected when the text box gains focus.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool SelectTextOnFocus { get; set; }
Visual Basic (Declaration)
Public Property SelectTextOnFocus As Boolean
Visual C++
public:
property bool SelectTextOnFocus {
    bool get ();
    void set (bool value);
}

Remarks

If the value is true all the text in the text box will be selected when the text box gets keyboard focus. If it is false the text is not selected. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


ShowImageAsButton Property

[image]

Revit 2011 API
TextBox..::.ShowImageAsButton Property
TextBox Class See Also Send Feedback
Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public bool ShowImageAsButton { get; set; }
Visual Basic (Declaration)
Public Property ShowImageAsButton As Boolean
Visual C++
public:
property bool ShowImageAsButton {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true, the image will shown as a button inside the textbox. Clicking this button will trigger the EnterPressed event. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Value Property

[image]

Revit 2011 API
TextBox..::.Value Property
TextBox Class See Also Send Feedback
The object that supplies the text value.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Remarks

The value assigned to the TextBox can be a String or any other data type. If the type is not a String the TextBox will display the return of the ToString() method. When the text is edited in the UI, the type of Value will always be String.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Width Property

[image]

Revit 2011 API
TextBox..::.Width Property
TextBox Class See Also Send Feedback
Gets or sets the width of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

The value for this property must be positive and cannot be Infinity. This value is interpreted in device-independent units (1/96th inch) measurement device-independent units. The default value is 200.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Events

[image] [image]

Revit 2011 API
TextBox Events
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Events

Name | Description
EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


EnterPressed Event

[image]

Revit 2011 API
TextBox..::.EnterPressed Event
TextBox Class See Also Send Feedback
Subscribe to this event to be notified when the Enter button is pressed in the text box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<TextBoxEnterPressedEventArgs> EnterPressed
Visual Basic (Declaration)
Public Event EnterPressed As EventHandler(Of TextBoxEnterPressedEventArgs)
Visual C++
public:
 event EventHandler<TextBoxEnterPressedEventArgs^>^ EnterPressed {
    void add (EventHandler<TextBoxEnterPressedEventArgs^>^ value);
    void remove (EventHandler<TextBoxEnterPressedEventArgs^>^ value);
}

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBoxData Class

[image]

Revit 2011 API
TextBoxData Class
Members See Also Send Feedback
This class contains information necessary to construct a text box in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class TextBoxData : RibbonItemData
Visual Basic (Declaration)
Public Class TextBoxData _
    Inherits RibbonItemData
Visual C++
public ref class TextBoxData : public RibbonItemData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.TextBoxData

See Also

TextBoxData Members
Autodesk.Revit.UI Namespace


TextBoxData Members

[image] [image]

Revit 2011 API
TextBoxData Members
TextBoxData Class Constructors Methods Properties See Also Send Feedback

The TextBoxData type exposes the following members.

Constructors

Name | Description
TextBoxData | Constructs a new instance of TextBoxData.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | The image of the TextBox.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Constructor

[image]

Revit 2011 API
TextBoxData Constructor
TextBoxData Class See Also Send Feedback
Constructs a new instance of TextBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public TextBoxData(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
TextBoxData(
    String^ name
)

Parameters

name
Type: System..::.String
The internal name of the TextBoxData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for name.

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Methods

[image] [image]

Revit 2011 API
TextBoxData Methods
TextBoxData Class See Also Send Feedback

The TextBoxData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Properties

[image] [image]

Revit 2011 API
TextBoxData Properties
TextBoxData Class See Also Send Feedback

The TextBoxData type exposes the following members.

Properties

Name | Description
Image | The image of the TextBox.
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2011 API
TextBoxData..::.Image Property
TextBoxData Class See Also Send Feedback
The image of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic (Declaration)
Public Property Image As ImageSource
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


ToggleButton Class

[image]

Revit 2011 API
ToggleButton Class
Members See Also Send Feedback
The ToggleButton object represents a button that has been added to a RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ToggleButton : PushButton
Visual Basic (Declaration)
Public Class ToggleButton _
    Inherits PushButton
Visual C++
public ref class ToggleButton : public PushButton

Remarks

Use of this class is not supported in Revit VSTA.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItem
Autodesk.Revit.UI..::.RibbonButton
Autodesk.Revit.UI..::.PushButton
Autodesk.Revit.UI..::.ToggleButton

See Also

ToggleButton Members
Autodesk.Revit.UI Namespace


ToggleButton Members

[image] [image]

Revit 2011 API
ToggleButton Members
ToggleButton Class Methods Properties See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButton.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButton.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButton.)
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButton Methods

[image] [image]

Revit 2011 API
ToggleButton Methods
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButton Properties

[image] [image]

Revit 2011 API
ToggleButton Properties
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButton.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButton.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButton.)
Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Image | The image of the button. (Inherited from RibbonButton.)
ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
ItemType | Gets the item type. (Inherited from RibbonItem.)
LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItem.)
Name | The name of the item. (Inherited from RibbonItem.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem.)
Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButtonData Class

[image]

Revit 2011 API
ToggleButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a toggle button in a RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class ToggleButtonData : PushButtonData
Visual Basic (Declaration)
Public Class ToggleButtonData _
    Inherits PushButtonData
Visual C++
public ref class ToggleButtonData : public PushButtonData

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.RibbonItemData
Autodesk.Revit.UI..::.ButtonData
Autodesk.Revit.UI..::.PushButtonData
Autodesk.Revit.UI..::.ToggleButtonData

See Also

ToggleButtonData Members
Autodesk.Revit.UI Namespace


ToggleButtonData Members

[image] [image]

Revit 2011 API
ToggleButtonData Members
ToggleButtonData Class Constructors Methods Properties See Also Send Feedback

The ToggleButtonData type exposes the following members.

Constructors

Name | Description
ToggleButtonData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor

[image] [image]

Revit 2011 API
ToggleButtonData Constructor
ToggleButtonData Class See Also Send Feedback

Overload List

Name | Description
ToggleButtonData(String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.
ToggleButtonData(String, String, String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.

See Also

ToggleButtonData Class
ToggleButtonData Members
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor (String, String)

[image]

Revit 2011 API
ToggleButtonData Constructor (String, String)
ToggleButtonData Class See Also Send Feedback
Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ToggleButtonData(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
ToggleButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String
The user visible text seen on the new button.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ToggleButtonData Class
ToggleButtonData Overload
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor (String, String, String, String)

[image]

Revit 2011 API
ToggleButtonData Constructor (String, String, String, String)
ToggleButtonData Class See Also Send Feedback
Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ToggleButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
ToggleButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::.String
The internal name of the new button.
text
Type: System..::.String
The user visible text seen on the new button.
assemblyName
Type: System..::.String
The assembly path of the button.
className
Type: System..::.String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ToggleButtonData Class
ToggleButtonData Overload
Autodesk.Revit.UI Namespace


ToggleButtonData Methods

[image] [image]

Revit 2011 API
ToggleButtonData Methods
ToggleButtonData Class See Also Send Feedback

The ToggleButtonData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


ToggleButtonData Properties

[image] [image]

Revit 2011 API
ToggleButtonData Properties
ToggleButtonData Class See Also Send Feedback

The ToggleButtonData type exposes the following members.

Properties

Name | Description
AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Image | The image of the button. (Inherited from ButtonData.)
LargeImage | The large image of the button. (Inherited from ButtonData.)
LongDescription | Long description of the command tooltip (Inherited from RibbonItemData.)
Name | The name of the item. (Inherited from RibbonItemData.)
Text | The user-visible text of the button. (Inherited from ButtonData.)
ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


UIApplication Class

[image]

Revit 2011 API
UIApplication Class
Members See Also Send Feedback
Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, and the active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class UIApplication : IDisposable
Visual Basic (Declaration)
Public Class UIApplication _
    Implements IDisposable
Visual C++
public ref class UIApplication : IDisposable

Remarks

You can access documents from the database level Application object, obtained from the Application property. If you have an instance of the database level Application object, you can construct a UIApplication from it.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.UIApplication

See Also

UIApplication Members
Autodesk.Revit.UI Namespace


UIApplication Members

[image] [image]

Revit 2011 API
UIApplication Members
UIApplication Class Constructors Methods Properties Events See Also Send Feedback

The UIApplication type exposes the following members.

Constructors

Name | Description
UIApplication | Use a database level Application to construct a UI-level Application.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Constructor

[image]

Revit 2011 API
UIApplication Constructor
UIApplication Class See Also Send Feedback
Use a database level Application to construct a UI-level Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIApplication(
    Application pApplication
)
Visual Basic (Declaration)
Public Sub New ( _
    pApplication As Application _
)
Visual C++
public:
UIApplication(
    Application^ pApplication
)

Parameters

pApplication
Type: Autodesk.Revit.ApplicationServices..::.Application

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Methods

[image] [image]

Revit 2011 API
UIApplication Methods
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2011 API
UIApplication..::.CreateRibbonPanel Method
UIApplication Class See Also Send Feedback

Overload List

Name | Description
CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2011 API
UIApplication..::.CreateRibbonPanel Method (String)
UIApplication Class Example See Also Send Feedback
Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in VSTA.

Examples

CopyC#
public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;

    return Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    'the add-in application “HelloWorld” will be triggered when button is pushed

    Dim pushButton As PushButton = TryCast(ribbonPanel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    ' Set the large image shown on button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)
    pushButton.LargeImage = largeImage

    Return Result.Succeeded
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created.

See Also

UIApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2011 API
UIApplication..::.CreateRibbonPanel Method (Tab, String)
UIApplication Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

UIApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2011 API
UIApplication..::.Dispose Method
UIApplication Class See Also Send Feedback

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image] [image]

Revit 2011 API
UIApplication..::.GetRibbonPanels Method
UIApplication Class See Also Send Feedback

Overload List

Name | Description
GetRibbonPanels()()() | Get all the custom Panels on Add-Ins tab of Revit.
GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image]

Revit 2011 API
UIApplication..::.GetRibbonPanels Method
UIApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in VSTA.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2011 API
UIApplication..::.GetRibbonPanels Method (Tab)
UIApplication Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic (Declaration)
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in VSTA.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


UIApplication Properties

[image] [image]

Revit 2011 API
UIApplication Properties
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ActiveAddInId Property

[image]

Revit 2011 API
UIApplication..::.ActiveAddInId Property
UIApplication Class See Also Send Feedback
Get current active external application or external command id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveAddInId As AddInId
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ActiveUIDocument Property

[image]

Revit 2011 API
UIApplication..::.ActiveUIDocument Property
UIApplication Class See Also Send Feedback
Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual UIDocument ActiveUIDocument { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument
Visual C++
public:
virtual property UIDocument^ ActiveUIDocument {
    UIDocument^ get ();
}

Remarks

External API commands can access this property in read-only mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to modify the property.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2011 API
UIApplication..::.Application Property
UIApplication Class See Also Send Feedback
Returns the database level Application represented by this UI level Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DrawingAreaExtents Property

[image]

Revit 2011 API
UIApplication..::.DrawingAreaExtents Property
UIApplication Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of drawing area.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Rectangle DrawingAreaExtents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property DrawingAreaExtents As Rectangle
Visual C++
public:
virtual property Rectangle^ DrawingAreaExtents {
    Rectangle^ get ();
}

Remarks

The drawing area of the Revit window displays views (and sheets and schedules) of the current project. The size of drawing area restricts the max size of the view windows. If there is no project opened, null will be returned.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


LoadedApplications Property

[image]

Revit 2011 API
UIApplication..::.LoadedApplications Property
UIApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


MainWindowExtents Property

[image]

Revit 2011 API
UIApplication..::.MainWindowExtents Property
UIApplication Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of Revit main window.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Rectangle MainWindowExtents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property MainWindowExtents As Rectangle
Visual C++
public:
virtual property Rectangle^ MainWindowExtents {
    Rectangle^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Events

[image] [image]

Revit 2011 API
UIApplication Events
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ApplicationClosing Event

[image]

Revit 2011 API
UIApplication..::.ApplicationClosing Event
UIApplication Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

No document may be modified at the time of the event.

The sender object of this event is Application object.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DialogBoxShowing Event

[image]

Revit 2011 API
UIApplication..::.DialogBoxShowing Event
UIApplication Class Example See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DialogBoxShowing : IExternalApplication
{
    // Implement the OnStartup method to register events when Revit starts.
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.DialogBoxShowing +=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // Implement this method to unregister the subscribed events when Revit exits.
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
        application.DialogBoxShowing -=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // The DialogBoxShowing event handler, which allow you to
    // do some work before the dialog shows
    void AppDialogShowing(object sender, DialogBoxShowingEventArgs args)
    {
        // Get the help id of the showing dialog
        int dialogId = args.HelpId;

        // Format the prompt information string
        String promptInfo = "A Revit dialog will be opened.\n";
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + "\n";
        promptInfo += "If you don't want the dialog to open, please press cancel button";

        // Show the prompt message, and allow the user to close the dialog directly.
        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent = promptInfo;
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok |
                                            TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult result = taskDialog.Show();
        if (TaskDialogResult.Cancel == result)
        {
            // Do not show the Revit dialog
            args.OverrideResult(1);
        }
        else
        {
            // Continue to show the Revit dialog
            args.OverrideResult(0);
        }
    }
}
CopyVB.NET
Public Class Application_DialogBoxShowing
    Implements IExternalApplication
    ' Implement the OnStartup method to register events when Revit starts.
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' Implement this method to unregister the subscribed events when Revit exits.
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' The DialogBoxShowing event handler, which allow you to
    ' do some work before the dialog shows
    Sub AppDialogShowing(ByVal sender As Object, ByVal args As Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs)
        ' Get the help id of the showing dialog
        Dim dialogId As Integer = args.HelpId

        ' Format the prompt information string
        Dim promptInfo As [String] = "A Revit dialog will be opened." & vbLf
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + vbLf
        promptInfo += "If you don't want the dialog to open, please press cancel button"

        ' Show the prompt message, and allow the user to close the dialog directly.
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = promptInfo
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()
        If TaskDialogResult.Cancel = result Then
            ' Do not show the Revit dialog
            args.OverrideResult(1)
        Else
            ' Continue to show the Revit dialog
            args.OverrideResult(0)
        End If
    End Sub
End Class

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


Idling Event

[image]

Revit 2011 API
UIApplication..::.Idling Event
UIApplication Class See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic (Declaration)
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

Event is not cancellable.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ViewActivated Event

[image]

Revit 2011 API
UIApplication..::.ViewActivated Event
UIApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ViewActivating Event

[image]

Revit 2011 API
UIApplication..::.ViewActivating Event
UIApplication Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Class

[image]

Revit 2011 API
UIControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit user interface, providing access to UI customization methods and events.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class UIControlledApplication
Visual Basic (Declaration)
Public Class UIControlledApplication
Visual C++
public ref class UIControlledApplication

Remarks

This class does not provide access to documents because it is provided to you through the ExternalApplication OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents. You can work with documents by getting them from the UIApplication class; that class is obtained from events and ExternalCommand callbacks.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.UIControlledApplication

See Also

UIControlledApplication Members
Autodesk.Revit.UI Namespace


UIControlledApplication Members

[image] [image]

Revit 2011 API
UIControlledApplication Members
UIControlledApplication Class Methods Properties Events See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
LoadedApplications | Returns an array of successfully loaded external applications.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Methods

[image] [image]

Revit 2011 API
UIControlledApplication Methods
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2011 API
UIControlledApplication..::.CreateRibbonPanel Method
UIControlledApplication Class See Also Send Feedback

Overload List

Name | Description
CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.

See Also

UIControlledApplication Class
UIControlledApplication Members
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2011 API
UIControlledApplication..::.CreateRibbonPanel Method (String)
UIControlledApplication Class See Also Send Feedback
Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created.

See Also

UIControlledApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2011 API
UIControlledApplication..::.CreateRibbonPanel Method (Tab, String)
UIControlledApplication Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

UIControlledApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image] [image]

Revit 2011 API
UIControlledApplication..::.GetRibbonPanels Method
UIControlledApplication Class See Also Send Feedback

Overload List

Name | Description
GetRibbonPanels()()() | Get all the custom Panels on Add-Ins tab of Revit.
GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.

See Also

UIControlledApplication Class
UIControlledApplication Members
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image]

Revit 2011 API
UIControlledApplication..::.GetRibbonPanels Method
UIControlledApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in VSTA.

See Also

UIControlledApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2011 API
UIControlledApplication..::.GetRibbonPanels Method (Tab)
UIControlledApplication Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic (Declaration)
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in VSTA.

See Also

UIControlledApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


UIControlledApplication Properties

[image] [image]

Revit 2011 API
UIControlledApplication Properties
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
LoadedApplications | Returns an array of successfully loaded external applications.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ActiveAddInId Property

[image]

Revit 2011 API
UIControlledApplication..::.ActiveAddInId Property
UIControlledApplication Class See Also Send Feedback
Get current active external application or external command id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveAddInId As AddInId
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ControlledApplication Property

[image]

Revit 2011 API
UIControlledApplication..::.ControlledApplication Property
UIControlledApplication Class See Also Send Feedback
Returns the database level ControlledApplication represented by this UI-level ControlledApplication.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ControlledApplication ControlledApplication { get; }
Visual Basic (Declaration)
Public ReadOnly Property ControlledApplication As ControlledApplication
Visual C++
public:
property ControlledApplication^ ControlledApplication {
    ControlledApplication^ get ();
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


LoadedApplications Property

[image]

Revit 2011 API
UIControlledApplication..::.LoadedApplications Property
UIControlledApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Events

[image] [image]

Revit 2011 API
UIControlledApplication Events
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ApplicationClosing Event

[image]

Revit 2011 API
UIControlledApplication..::.ApplicationClosing Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

No document may be modified at the time of the event.

The sender object of this event is Application object.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


DialogBoxShowing Event

[image]

Revit 2011 API
UIControlledApplication..::.DialogBoxShowing Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


Idling Event

[image]

Revit 2011 API
UIControlledApplication..::.Idling Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic (Declaration)
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

Event is not cancellable.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ViewActivated Event

[image]

Revit 2011 API
UIControlledApplication..::.ViewActivated Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ViewActivating Event

[image]

Revit 2011 API
UIControlledApplication..::.ViewActivating Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIDocument Class

[image]

Revit 2011 API
UIDocument Class
Members See Also Send Feedback
An object that represents an Autodesk Revit project opened in the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class UIDocument : IDisposable
Visual Basic (Declaration)
Public Class UIDocument _
    Implements IDisposable
Visual C++
public ref class UIDocument : IDisposable

Remarks

This class represents a document opened in the user interface and therefore offers interfaces to work with settings and operations in the UI (for example, the active selection). Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the UIApplication object.

Obtain the database level Document (which contains interfaces not related to the UI) via the Document property. If you have a database level Document and need to access it from the UI, you can construct a new UIDocument from that object (the document must be open and visible in the UI to allow the methods to work successfully).

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.UI..::.UIDocument

See Also

UIDocument Members
Autodesk.Revit.UI Namespace


UIDocument Members

[image] [image]

Revit 2011 API
UIDocument Members
UIDocument Class Constructors Methods Properties See Also Send Feedback

The UIDocument type exposes the following members.

Constructors

Name | Description
UIDocument | Use a database level Document to construct a UI-level Document.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


UIDocument Constructor

[image]

Revit 2011 API
UIDocument Constructor
UIDocument Class See Also Send Feedback
Use a database level Document to construct a UI-level Document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIDocument(
    Document pDocument
)
Visual Basic (Declaration)
Public Sub New ( _
    pDocument As Document _
)
Visual C++
public:
UIDocument(
    Document^ pDocument
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::.Document

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


UIDocument Methods

[image] [image]

Revit 2011 API
UIDocument Methods
UIDocument Class See Also Send Feedback

The UIDocument type exposes the following members.

Methods

Name | Description
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2011 API
UIDocument..::.Dispose Method
UIDocument Class See Also Send Feedback

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


PromptForFamilyInstancePlacement Method

[image]

Revit 2011 API
UIDocument..::.PromptForFamilyInstancePlacement Method
UIDocument Class See Also Send Feedback
Prompts the user to place instances of the specified FamilySymbol.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void PromptForFamilyInstancePlacement(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Sub PromptForFamilyInstancePlacement ( _
    familySymbol As FamilySymbol _
)
Visual C++
public:
void PromptForFamilyInstancePlacement(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::.FamilySymbol
The FamilySymbol.

Remarks

This method opens its own transaction, so it's not permitted to be invoked in an active transaction. In a single invocation, the user can place multiple instances of the input family type until they finish the placement (with Cancel or ESC or a click elsewhere in the UI). The user will not be permitted to change the type to be placed. Users are not permitted to change the active view during this placement operation (the operation will be completed).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this API method is invoked in an active transaction, or this document is not active, or this is a family document and the instances of this family symbol can not exist in the current family, or this family symbol has no command to create instance, or the command to create instance is disabled in active view.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


RefreshActiveView Method

[image]

Revit 2011 API
UIDocument..::.RefreshActiveView Method
UIDocument Class See Also Send Feedback
Refresh the display of the active view in the active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void RefreshActiveView()
Visual Basic (Declaration)
Public Sub RefreshActiveView
Visual C++
public:
void RefreshActiveView()

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


ShowElements Method

[image] [image]

Revit 2011 API
UIDocument..::.ShowElements Method
UIDocument Class See Also Send Feedback
Shows one or more elements by zoom to fit.

Overload List

Name | Description
ShowElements(Element) | Shows the element by zoom to fit.
ShowElements(ElementId) | Shows the element by zoom to fit.
ShowElements(ElementSet) | Shows the elements by zoom to fit.
ShowElements(ICollection<(Of <(ElementId>)>)) | Shows the elements by zoom to fit.

See Also

UIDocument Class
UIDocument Members
Autodesk.Revit.UI Namespace


ShowElements Method (Element)

[image]

Revit 2011 API
UIDocument..::.ShowElements Method (Element)
UIDocument Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
Element that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ElementId)

[image]

Revit 2011 API
UIDocument..::.ShowElements Method (ElementId)
UIDocument Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ElementId elementId
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementId As ElementId _
)
Visual C++
public:
void ShowElements(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
Element id that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ElementSet)

[image]

Revit 2011 API
UIDocument..::.ShowElements Method (ElementSet)
UIDocument Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
The set of elements that will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ICollection(ElementId))

[image]

Revit 2011 API
UIDocument..::.ShowElements Method (ICollection<(Of <(ElementId>)>))
UIDocument Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void ShowElements(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


UIDocument Properties

[image] [image]

Revit 2011 API
UIDocument Properties
UIDocument Class See Also Send Feedback

The UIDocument type exposes the following members.

Properties

Name | Description
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2011 API
UIDocument..::.Application Property
UIDocument Class See Also Send Feedback
Retrieves an object that represents the current Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As UIApplication
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Document Property

[image]

Revit 2011 API
UIDocument..::.Document Property
UIDocument Class See Also Send Feedback
Returns the database level document represented by this UI-level document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Selection Property

[image]

Revit 2011 API
UIDocument..::.Selection Property
UIDocument Class See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Autodesk.Revit.UI.Events Namespace

[image]

Revit 2011 API
Autodesk.Revit.UI.Events Namespace
Send Feedback

Classes

Class | Description
ApplicationClosingEventArgs | The event arguments used by the ApplicationClosing event.
ComboBoxCurrentChangedEventArgs | The event arguments used by ComboBox's CurrentChanged event.
ComboBoxDropDownClosedEventArgs | The event arguments used by ComboBox's DropDownClosed event.
ComboBoxDropDownOpenedEventArgs | The event arguments used by ComboBox's DropDownOpened event.
DialogBoxData | An object that is passed to your application when a dialog is displayed in Revit.
DialogBoxShowingEventArgs | The base class for the event arguments used by the DialogBoxShowing event.
IdlingEventArgs | The event arguments used by the Idling event.
MessageBoxData | An object that represents a simple message box that prompts the user for some action.
MessageBoxShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.
RibbonItemEventArgs | The base class of the RibbonItem event arguments which have UIApplication property.
TaskDialogShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.
TextBoxEnterPressedEventArgs | The event arguments used by TextBox's EnterPressed event.
ViewActivatedEventArgs | The event arguments used by the ViewActivated event.
ViewActivatingEventArgs | The event arguments used by the ViewActivating event.


ApplicationClosingEventArgs Class

[image]

Revit 2011 API
ApplicationClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ApplicationClosing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ApplicationClosingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class ApplicationClosingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class ApplicationClosingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.UI.Events..::.ApplicationClosingEventArgs

See Also

ApplicationClosingEventArgs Members
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Members

[image] [image]

Revit 2011 API
ApplicationClosingEventArgs Members
ApplicationClosingEventArgs Class Methods Properties See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Methods

[image] [image]

Revit 2011 API
ApplicationClosingEventArgs Methods
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Properties

[image] [image]

Revit 2011 API
ApplicationClosingEventArgs Properties
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Class

[image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's CurrentChanged event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ComboBoxCurrentChangedEventArgs : RibbonItemEventArgs
Visual Basic (Declaration)
Public Class ComboBoxCurrentChangedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxCurrentChangedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxCurrentChangedEventArgs

See Also

ComboBoxCurrentChangedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Members

[image] [image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs Members
ComboBoxCurrentChangedEventArgs Class Methods Properties See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)
NewValue | The current item for the ComboBox after the change.
OldValue | The current item for the ComboBox before the change.

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Methods

[image] [image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs Methods
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Properties

[image] [image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs Properties
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)
NewValue | The current item for the ComboBox after the change.
OldValue | The current item for the ComboBox before the change.

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


NewValue Property

[image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs..::.NewValue Property
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback
The current item for the ComboBox after the change.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ComboBoxMember NewValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewValue As ComboBoxMember
Visual C++
public:
property ComboBoxMember^ NewValue {
    ComboBoxMember^ get ();
}

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


OldValue Property

[image]

Revit 2011 API
ComboBoxCurrentChangedEventArgs..::.OldValue Property
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback
The current item for the ComboBox before the change.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ComboBoxMember OldValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldValue As ComboBoxMember
Visual C++
public:
property ComboBoxMember^ OldValue {
    ComboBoxMember^ get ();
}

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Class

[image]

Revit 2011 API
ComboBoxDropDownClosedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's DropDownClosed event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ComboBoxDropDownClosedEventArgs : RibbonItemEventArgs
Visual Basic (Declaration)
Public Class ComboBoxDropDownClosedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxDropDownClosedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownClosedEventArgs

See Also

ComboBoxDropDownClosedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Members

[image] [image]

Revit 2011 API
ComboBoxDropDownClosedEventArgs Members
ComboBoxDropDownClosedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Constructors

Name | Description
ComboBoxDropDownClosedEventArgs | Initializes a new instance of the ComboBoxDropDownClosedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Constructor

[image]

Revit 2011 API
ComboBoxDropDownClosedEventArgs Constructor
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback
Initializes a new instance of the ComboBoxDropDownClosedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ComboBoxDropDownClosedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComboBoxDropDownClosedEventArgs()

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Methods

[image] [image]

Revit 2011 API
ComboBoxDropDownClosedEventArgs Methods
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Properties

[image] [image]

Revit 2011 API
ComboBoxDropDownClosedEventArgs Properties
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Class

[image]

Revit 2011 API
ComboBoxDropDownOpenedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's DropDownOpened event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ComboBoxDropDownOpenedEventArgs : RibbonItemEventArgs
Visual Basic (Declaration)
Public Class ComboBoxDropDownOpenedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxDropDownOpenedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownOpenedEventArgs

See Also

ComboBoxDropDownOpenedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Members

[image] [image]

Revit 2011 API
ComboBoxDropDownOpenedEventArgs Members
ComboBoxDropDownOpenedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Constructors

Name | Description
ComboBoxDropDownOpenedEventArgs | Initializes a new instance of the ComboBoxDropDownOpenedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Constructor

[image]

Revit 2011 API
ComboBoxDropDownOpenedEventArgs Constructor
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback
Initializes a new instance of the ComboBoxDropDownOpenedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ComboBoxDropDownOpenedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComboBoxDropDownOpenedEventArgs()

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Methods

[image] [image]

Revit 2011 API
ComboBoxDropDownOpenedEventArgs Methods
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Properties

[image] [image]

Revit 2011 API
ComboBoxDropDownOpenedEventArgs Properties
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Class

[image]

Revit 2011 API
DialogBoxData Class
Members See Also Send Feedback
An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic (Declaration)
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI.Events..::.DialogBoxData
Autodesk.Revit.UI.Events..::.MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.UI.Events Namespace


DialogBoxData Members

[image] [image]

Revit 2011 API
DialogBoxData Members
DialogBoxData Class Methods Properties See Also Send Feedback

The DialogBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HelpId | An ID that represents the dialog that has been displayed.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Methods

[image] [image]

Revit 2011 API
DialogBoxData Methods
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


OverrideResult Method

[image]

Revit 2011 API
DialogBoxData..::.OverrideResult Method
DialogBoxData Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::.Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Properties

[image] [image]

Revit 2011 API
DialogBoxData Properties
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Properties

Name | Description
HelpId | An ID that represents the dialog that has been displayed.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


HelpId Property

[image]

Revit 2011 API
DialogBoxData..::.HelpId Property
DialogBoxData Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpId As Integer
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Class

[image]

Revit 2011 API
DialogBoxShowingEventArgs Class
Members See Also Send Feedback
The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class DialogBoxShowingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class DialogBoxShowingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public PreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.UI.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::.MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events..::.TaskDialogShowingEventArgs

See Also

DialogBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Members

[image] [image]

Revit 2011 API
DialogBoxShowingEventArgs Members
DialogBoxShowingEventArgs Class Methods Properties See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Methods

[image] [image]

Revit 2011 API
DialogBoxShowingEventArgs Methods
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


OverrideResult Method

[image]

Revit 2011 API
DialogBoxShowingEventArgs..::.OverrideResult Method
DialogBoxShowingEventArgs Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic (Declaration)
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::.Int32
The result code you wish the Revit dialog to return.

Return Value

True if the result code was accepted.

Remarks

The range of valid result values depends on the type of dialog as follows:
  1. DialogBox: Any non-zero value will cause a dialog to be dismissed.
  2. MessageBox: Standard Message Box IDs, such as IDOK and IDCANCEL, are accepted. For all possible IDs, refer to the Windows API documentation. The ID used must be relevant to the buttons in a message box.
  3. TaskDialog: Standard Message Box IDs and Revit Custom IDs are accepted, depending on the buttons used in a dialog. Standard buttons, such as OK and Cancel, have standard IDs described in Windows API documentation. Buttons with custom text have custom IDs with incremental values starting at 1001 for the left-most or top-most button in a task dialog.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Properties

[image] [image]

Revit 2011 API
DialogBoxShowingEventArgs Properties
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


HelpId Property

[image]

Revit 2011 API
DialogBoxShowingEventArgs..::.HelpId Property
DialogBoxShowingEventArgs Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpId As Integer
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Class

[image]

Revit 2011 API
IdlingEventArgs Class
Members See Also Send Feedback
The event arguments used by the Idling event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class IdlingEventArgs : PreEventArgs
Visual Basic (Declaration)
Public Class IdlingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class IdlingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.UI.Events..::.IdlingEventArgs

See Also

IdlingEventArgs Members
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Members

[image] [image]

Revit 2011 API
IdlingEventArgs Members
IdlingEventArgs Class Methods Properties See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Methods

[image] [image]

Revit 2011 API
IdlingEventArgs Methods
IdlingEventArgs Class See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Properties

[image] [image]

Revit 2011 API
IdlingEventArgs Properties
IdlingEventArgs Class See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Class

[image]

Revit 2011 API
MessageBoxData Class
Members See Also Send Feedback
An object that represents a simple message box that prompts the user for some action.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class MessageBoxData : DialogBoxData
Visual Basic (Declaration)
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI.Events..::.DialogBoxData
Autodesk.Revit.UI.Events..::.MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.UI.Events Namespace


MessageBoxData Members

[image] [image]

Revit 2011 API
MessageBoxData Members
MessageBoxData Class Methods Properties See Also Send Feedback

The MessageBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DialogType | An integer that describes the standard windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Methods

[image] [image]

Revit 2011 API
MessageBoxData Methods
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Properties

[image] [image]

Revit 2011 API
MessageBoxData Properties
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Properties

Name | Description
DialogType | An integer that describes the standard windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogType Property

[image]

Revit 2011 API
MessageBoxData..::.DialogType Property
MessageBoxData Class See Also Send Feedback
An integer that describes the standard windows type of the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogType As Integer
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2011 API
MessageBoxData..::.Message Property
MessageBoxData Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Class

[image]

Revit 2011 API
MessageBoxShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class MessageBoxShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a simple message box is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.UI.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::.MessageBoxShowingEventArgs

See Also

MessageBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Members

[image] [image]

Revit 2011 API
MessageBoxShowingEventArgs Members
MessageBoxShowingEventArgs Class Methods Properties See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogType | An integer that describes the standard Windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Methods

[image] [image]

Revit 2011 API
MessageBoxShowingEventArgs Methods
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Properties

[image] [image]

Revit 2011 API
MessageBoxShowingEventArgs Properties
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogType | An integer that describes the standard Windows type of the dialog box.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogType Property

[image]

Revit 2011 API
MessageBoxShowingEventArgs..::.DialogType Property
MessageBoxShowingEventArgs Class See Also Send Feedback
An integer that describes the standard Windows type of the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogType As Integer
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2011 API
MessageBoxShowingEventArgs..::.Message Property
MessageBoxShowingEventArgs Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Class

[image]

Revit 2011 API
RibbonItemEventArgs Class
Members See Also Send Feedback
The base class of the RibbonItem event arguments which have UIApplication property.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class RibbonItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RibbonItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class RibbonItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events..::.ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events..::.TextBoxEnterPressedEventArgs

See Also

RibbonItemEventArgs Members
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Members

[image] [image]

Revit 2011 API
RibbonItemEventArgs Members
RibbonItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Constructors

Name | Description
RibbonItemEventArgs | Initializes a new instance of the RibbonItemEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | The current UIApplication.

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Constructor

[image]

Revit 2011 API
RibbonItemEventArgs Constructor
RibbonItemEventArgs Class See Also Send Feedback
Initializes a new instance of the RibbonItemEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public RibbonItemEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RibbonItemEventArgs()

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Methods

[image] [image]

Revit 2011 API
RibbonItemEventArgs Methods
RibbonItemEventArgs Class See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Properties

[image] [image]

Revit 2011 API
RibbonItemEventArgs Properties
RibbonItemEventArgs Class See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Properties

Name | Description
Application | The current UIApplication.

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


Application Property

[image]

Revit 2011 API
RibbonItemEventArgs..::.Application Property
RibbonItemEventArgs Class See Also Send Feedback
The current UIApplication.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As UIApplication
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Class

[image]

Revit 2011 API
TaskDialogShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic (Declaration)
Public Class TaskDialogShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.UI.Events..::.DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::.TaskDialogShowingEventArgs

See Also

TaskDialogShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Members

[image] [image]

Revit 2011 API
TaskDialogShowingEventArgs Members
TaskDialogShowingEventArgs Class Methods Properties See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogId | String ID associated with the task dialog.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Methods

[image] [image]

Revit 2011 API
TaskDialogShowingEventArgs Methods
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Properties

[image] [image]

Revit 2011 API
TaskDialogShowingEventArgs Properties
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
DialogId | String ID associated with the task dialog.
HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogId Property

[image]

Revit 2011 API
TaskDialogShowingEventArgs..::.DialogId Property
TaskDialogShowingEventArgs Class See Also Send Feedback
String ID associated with the task dialog.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string DialogId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogId As String
Visual C++
public:
property String^ DialogId {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2011 API
TaskDialogShowingEventArgs..::.Message Property
TaskDialogShowingEventArgs Class See Also Send Feedback
The message provided by the task dialog.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Class

[image]

Revit 2011 API
TextBoxEnterPressedEventArgs Class
Members See Also Send Feedback
The event arguments used by TextBox's EnterPressed event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class TextBoxEnterPressedEventArgs : RibbonItemEventArgs
Visual Basic (Declaration)
Public Class TextBoxEnterPressedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class TextBoxEnterPressedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.UI.Events..::.RibbonItemEventArgs
Autodesk.Revit.UI.Events..::.TextBoxEnterPressedEventArgs

See Also

TextBoxEnterPressedEventArgs Members
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Members

[image] [image]

Revit 2011 API
TextBoxEnterPressedEventArgs Members
TextBoxEnterPressedEventArgs Class Constructors Methods Properties See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Constructors

Name | Description
TextBoxEnterPressedEventArgs | Initializes a new instance of the TextBoxEnterPressedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Constructor

[image]

Revit 2011 API
TextBoxEnterPressedEventArgs Constructor
TextBoxEnterPressedEventArgs Class See Also Send Feedback
Initializes a new instance of the TextBoxEnterPressedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public TextBoxEnterPressedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxEnterPressedEventArgs()

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Methods

[image] [image]

Revit 2011 API
TextBoxEnterPressedEventArgs Methods
TextBoxEnterPressedEventArgs Class See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Properties

[image] [image]

Revit 2011 API
TextBoxEnterPressedEventArgs Properties
TextBoxEnterPressedEventArgs Class See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Properties

Name | Description
Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Class

[image]

Revit 2011 API
ViewActivatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivated event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewActivatedEventArgs : PostDocEventArgs
Visual Basic (Declaration)
Public Class ViewActivatedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class ViewActivatedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PostEventArgs
Autodesk.Revit.DB.Events..::.PostDocEventArgs
Autodesk.Revit.UI.Events..::.ViewActivatedEventArgs

See Also

ViewActivatedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Members

[image] [image]

Revit 2011 API
ViewActivatedEventArgs Members
ViewActivatedEventArgs Class Methods Properties See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that has just become active.
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
PreviousActiveView | The previously active view.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Methods

[image] [image]

Revit 2011 API
ViewActivatedEventArgs Methods
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Properties

[image] [image]

Revit 2011 API
ViewActivatedEventArgs Properties
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that has just become active.
Document | The document associated with the event. (Inherited from PostDocEventArgs.)
PreviousActiveView | The previously active view.
Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


CurrentActiveView Property

[image]

Revit 2011 API
ViewActivatedEventArgs..::.CurrentActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The view that has just become active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentActiveView As View
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


PreviousActiveView Property

[image]

Revit 2011 API
ViewActivatedEventArgs..::.PreviousActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The previously active view.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public View PreviousActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousActiveView As View
Visual C++
public:
property View^ PreviousActiveView {
    View^ get ();
}

Remarks

May be nullNothingnullptra null reference (Nothing in Visual Basic) if there was no previously active view.

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Class

[image]

Revit 2011 API
ViewActivatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivating event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class ViewActivatingEventArgs : PreDocEventArgs
Visual Basic (Declaration)
Public Class ViewActivatingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class ViewActivatingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Autodesk.Revit.DB.Events..::.RevitEventArgs
Autodesk.Revit.DB.Events..::.PreEventArgs
Autodesk.Revit.DB.Events..::.PreDocEventArgs
Autodesk.Revit.UI.Events..::.ViewActivatingEventArgs

See Also

ViewActivatingEventArgs Members
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Members

[image] [image]

Revit 2011 API
ViewActivatingEventArgs Members
ViewActivatingEventArgs Class Methods Properties See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that is currently active.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Methods

[image] [image]

Revit 2011 API
ViewActivatingEventArgs Methods
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Properties

[image] [image]

Revit 2011 API
ViewActivatingEventArgs Properties
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
CurrentActiveView | The view that is currently active.
Document | The document associated with the event. (Inherited from PreDocEventArgs.)
NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


CurrentActiveView Property

[image]

Revit 2011 API
ViewActivatingEventArgs..::.CurrentActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is currently active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentActiveView As View
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

Remarks

May be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no currently active view.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


NewActiveView Property

[image]

Revit 2011 API
ViewActivatingEventArgs..::.NewActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is going to become active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public View NewActiveView { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewActiveView As View
Visual C++
public:
property View^ NewActiveView {
    View^ get ();
}

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Autodesk.Revit.UI.Selection Namespace

[image]

Revit 2011 API
Autodesk.Revit.UI.Selection Namespace
Send Feedback

Classes

Class | Description
Selection | Contains the current user selection of elements within the project.
SelElementSet | This class contains the current user selection of elements within the project.

Interfaces

Interface | Description
ISelectionFilter | An interface that provides the ability to filter objects during a selection operation.

Enumerations

Enumeration | Description
ObjectSnapTypes | This enumerated type contains object snap types allowed to be set during PickPoint operations.
ObjectType | This enumerated type contains object types allowed to be selected during selection operations.


ISelectionFilter Interface

[image]

Revit 2011 API
ISelectionFilter Interface
Members Example See Also Send Feedback
An interface that provides the ability to filter objects during a selection operation.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public interface ISelectionFilter
Visual Basic (Declaration)
Public Interface ISelectionFilter
Visual C++
public interface class ISelectionFilter

Examples

CopyC#
public static IList<Element> GetManyRefByRectangle(UIDocument doc)
{
    ReferenceArray ra = new ReferenceArray();
    ISelectionFilter selFilter = new MassSelectionFilter();
    IList<Element> eList = doc.Selection.PickElementsByRectangle(selFilter,
        "Select multiple faces") as IList<Element>;
    return eList;
}

public class MassSelectionFilter : ISelectionFilter
{
    public bool AllowElement(Element element)
    {
        if (element.Category.Name == "Mass")
        {
            return true;
        }
        return false;
    }

    public bool AllowReference(Reference refer, XYZ point)
    {
        return false;
    }
}
CopyVB.NET
Public Shared Function GetManyRefByRectangle(ByVal doc As UIDocument) As IList(Of Autodesk.Revit.DB.Element)
    Dim ra As New ReferenceArray()
    Dim selFilter As ISelectionFilter = New MassSelectionFilter()
    Dim eList As IList(Of Autodesk.Revit.DB.Element) = TryCast(doc.Selection.PickElementsByRectangle(selFilter, "Select multiple faces"), IList(Of Autodesk.Revit.DB.Element))
    Return eList
End Function

Public Class MassSelectionFilter
    Implements ISelectionFilter
    Public Function AllowElement(ByVal element As Autodesk.Revit.DB.Element) As Boolean Implements ISelectionFilter.AllowElement
        If element.Category.Name = "Mass" Then
            Return True
        End If
        Return False
    End Function

    Public Function AllowReference(ByVal refer As Reference, ByVal point As Autodesk.Revit.DB.XYZ) As Boolean Implements ISelectionFilter.AllowReference
        Return False
    End Function
End Class

See Also

ISelectionFilter Members
Autodesk.Revit.UI.Selection Namespace


ISelectionFilter Members

[image] [image]

Revit 2011 API
ISelectionFilter Members
ISelectionFilter Interface Methods See Also Send Feedback

The ISelectionFilter type exposes the following members.

Methods

Name | Description
AllowElement | Override this pre-filter method to specify if the element should be permitted to be selected.
AllowReference | Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


ISelectionFilter Methods

[image] [image]

Revit 2011 API
ISelectionFilter Methods
ISelectionFilter Interface See Also Send Feedback

The ISelectionFilter type exposes the following members.

Methods

Name | Description
AllowElement | Override this pre-filter method to specify if the element should be permitted to be selected.
AllowReference | Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


AllowElement Method

[image]

Revit 2011 API
ISelectionFilter..::.AllowElement Method
ISelectionFilter Interface See Also Send Feedback
Override this pre-filter method to specify if the element should be permitted to be selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
bool AllowElement(
    Element elem
)
Visual Basic (Declaration)
Function AllowElement ( _
    elem As Element _
) As Boolean
Visual C++
bool AllowElement(
    Element^ elem
)

Parameters

elem
Type: Autodesk.Revit.DB..::.Element
A candidate element in selection operation.

Return Value

Return true to allow the user to select this candidate element. Return false to prevent selection of this element.

Remarks

If an exception is thrown from this method, the element will not be permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


AllowReference Method

[image]

Revit 2011 API
ISelectionFilter..::.AllowReference Method
ISelectionFilter Interface See Also Send Feedback
Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
bool AllowReference(
    Reference reference,
    XYZ position
)
Visual Basic (Declaration)
Function AllowReference ( _
    reference As Reference, _
    position As XYZ _
) As Boolean
Visual C++
bool AllowReference(
    Reference^ reference,
    XYZ^ position
)

Parameters

reference
Type: Autodesk.Revit.DB..::.Reference
A candidate reference in selection operation.
position
Type: Autodesk.Revit.DB..::.XYZ
The 3D position of the mouse on the candidate reference.

Return Value

Return true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.

Remarks

If an exception is thrown from this method, the element will not be permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


ObjectSnapTypes Enumeration

[image]

Revit 2011 API
ObjectSnapTypes Enumeration
See Also Send Feedback
This enumerated type contains object snap types allowed to be set during PickPoint operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
[FlagsAttribute]
public enum ObjectSnapTypes
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ObjectSnapTypes
Visual C++
[FlagsAttribute]
public enum class ObjectSnapTypes

Members

Member name | Description
None | Snaps to nothing.
Endpoints | Snaps to the endpoint of an element or component.
Midpoints | Snaps to the midpoint of an element or component.
Nearest | Snaps to the nearest element or component.
WorkPlaneGrid | Snaps to a work plane grid.
Intersections | Snaps to intersections.
Centers | Snaps to the center of an arc.
Perpendicular | Snaps to perpendicular elements or components.
Tangents | Snaps tangent to an arc.
Quadrants | Snaps to quadrant points. For arcs, jump snaps are enabled.
Points | Snaps to site points.

See Also

Autodesk.Revit.UI.Selection Namespace


ObjectType Enumeration

[image]

Revit 2011 API
ObjectType Enumeration
See Also Send Feedback
This enumerated type contains object types allowed to be selected during selection operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public enum ObjectType
Visual Basic (Declaration)
Public Enumeration ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
Nothing | Nothing.
Element | Whole element.
PointOnElement | Any point on an element (on a face or curve).
Edge | Any model edge.
Face | Any face.

See Also

Autodesk.Revit.UI.Selection Namespace


Selection Class

[image]

Revit 2011 API
Selection Class
Members Example See Also Send Feedback
Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class Selection : APIObject
Visual Basic (Declaration)
Public Class Selection _
    Inherits APIObject
Visual C++
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(TransactionMode.ReadOnly)]
[Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)]
public class Document_Selection : IExternalCommand
{
    public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
        ref string message, ElementSet elements)
    {
        try
        {
            // Select some elements in Revit before invoking this command

            // Get the handle of current document.
            UIDocument uidoc = commandData.Application.ActiveUIDocument;

            // Get the element selection of current document.
            Selection selection = uidoc.Selection;
            ElementSet collection = selection.Elements;

            if (0 == collection.Size)
            {
                // If no elements selected.
                TaskDialog.Show("Revit","You haven't selected any elements.");
            }
            else
            {
                String info = "Ids of selected elements in the document are: ";
                foreach (Element elem in collection)
                {
                   info += "\n\t" + elem.Id.IntegerValue;
                }

                TaskDialog.Show("Revit",info);
            }
        }
        catch (Exception e)
        {
            message = e.Message;
            return Autodesk.Revit.UI.Result.Failed;
        }

        return Autodesk.Revit.UI.Result.Succeeded;
    }
    /// </ExampleMethod>
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(TransactionMode.[ReadOnly])> _
<Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)> _
Public Class Document_Selection
    Implements IExternalCommand
    Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result Implements IExternalCommand.Execute
        Try
            ' Select some elements in Revit before invoking this command

            ' Get the handle of current document.
            Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument

            ' Get the element selection of current document.
            Dim selection As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
            Dim collection As ElementSet = selection.Elements

            If 0 = collection.Size Then
                ' If no elements selected.
                TaskDialog.Show("Revit", "You haven't selected any elements.")
            Else
                Dim info As [String] = "Ids of selected elements in the document are: "
                For Each elem As Autodesk.Revit.DB.Element In collection
                    info += vbLf & vbTab + elem.Id.IntegerValue
                Next

                TaskDialog.Show("Revit", info)
            End If
        Catch e As Exception
            message = e.Message
            Return Autodesk.Revit.UI.Result.Failed
        End Try

        Return Autodesk.Revit.UI.Result.Succeeded
    End Function
    ' </ExampleMethod>
End Class

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.UI.Selection..::.Selection

See Also

Selection Members
Autodesk.Revit.UI.Selection Namespace


Selection Members

[image] [image]

Revit 2011 API
Selection Members
Selection Class Methods Properties See Also Send Feedback

The Selection type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickElementsByRectangle | Overloaded. Prompts the user to select multiple elements by drawing a rectangle.
PickObject | Overloaded. Prompts the user to select one object.
PickObjects | Overloaded. Prompts the user to select multiple objects.
PickOne | Obsolete. Allows the user to select one element.
PickPoint | Overloaded. Prompts the user to pick a point on the active work plane.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Obsolete. Allows the user to select elements by a rectangle.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | Obsolete. The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


Selection Methods

[image] [image]

Revit 2011 API
Selection Methods
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
PickElementsByRectangle | Overloaded. Prompts the user to select multiple elements by drawing a rectangle.
PickObject | Overloaded. Prompts the user to select one object.
PickObjects | Overloaded. Prompts the user to select multiple objects.
PickOne | Obsolete. Allows the user to select one element.
PickPoint | Overloaded. Prompts the user to pick a point on the active work plane.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WindowSelect | Obsolete. Allows the user to select elements by a rectangle.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method

[image] [image]

Revit 2011 API
Selection..::.PickElementsByRectangle Method
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle.

Overload List

Name | Description
PickElementsByRectangle()()() | Prompts the user to select multiple elements by drawing a rectangle.
PickElementsByRectangle(ISelectionFilter) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.
PickElementsByRectangle(String) | Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.
PickElementsByRectangle(ISelectionFilter, String) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method

[image]

Revit 2011 API
Selection..::.PickElementsByRectangle Method
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle()
Visual Basic (Declaration)
Public Function PickElementsByRectangle As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle()

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (ISelectionFilter)

[image]

Revit 2011 API
Selection..::.PickElementsByRectangle Method (ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    ISelectionFilter pSelFilter
)
Visual Basic (Declaration)
Public Function PickElementsByRectangle ( _
    pSelFilter As ISelectionFilter _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    ISelectionFilter^ pSelFilter
)

Parameters

pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (String)

[image]

Revit 2011 API
Selection..::.PickElementsByRectangle Method (String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickElementsByRectangle ( _
    statusPrompt As String _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    String^ statusPrompt
)

Parameters

statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
int selectionCount = choices.Elements.Size;
// Choose objects from Revit.
IList<Element> hasPickSome = choices.PickElementsByRectangle("Select by rectangle");
if (hasPickSome.Count > 0)
{
    int newSelectionCount = choices.Elements.Size;
    string prompt = string.Format("{0} elements added to Selection.",
        newSelectionCount - selectionCount);
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Dim selectionCount As Integer = choices.Elements.Size
' Choose objects from Revit.
Dim hasPickSome As IList(Of Autodesk.Revit.DB.Element) = choices.PickElementsByRectangle("Select by rectangle")
If hasPickSome.Count > 0 Then
    Dim newSelectionCount As Integer = choices.Elements.Size
    Dim prompt As String = String.Format("{0} elements added to Selection.", newSelectionCount - selectionCount)
    TaskDialog.Show("Revit", prompt)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (ISelectionFilter, String)

[image]

Revit 2011 API
Selection..::.PickElementsByRectangle Method (ISelectionFilter, String)
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickElementsByRectangle ( _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method

[image] [image]

Revit 2011 API
Selection..::.PickObject Method
Selection Class See Also Send Feedback
Prompts the user to select one object.

Overload List

Name | Description
PickObject(ObjectType) | Prompts the user to select one object.
PickObject(ObjectType, ISelectionFilter) | Prompts the user to select one object which passes a custom filter.
PickObject(ObjectType, String) | Prompts the user to select one object while showing a custom status prompt string.
PickObject(ObjectType, ISelectionFilter, String) | Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType)

[image]

Revit 2011 API
Selection..::.PickObject Method (ObjectType)
Selection Class Example See Also Send Feedback
Prompts the user to select one object.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType
)
Visual Basic (Declaration)
Public Function PickObject ( _
    objectType As ObjectType _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
Selection choices = uidoc.Selection;
 // Pick one object from Revit.
 Reference hasPickOne = choices.PickObject(ObjectType.Element);
 if (hasPickOne != null)
 {
     TaskDialog.Show("Revit", "One element added to Selection.");
 }
CopyVB.NET
Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
' Pick one object from Revit.
Dim hasPickOne As Reference = choices.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Element)
If hasPickOne IsNot Nothing Then
    TaskDialog.Show("Revit", "One element added to Selection.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancels this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, ISelectionFilter)

[image]

Revit 2011 API
Selection..::.PickObject Method (ObjectType, ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select one object which passes a custom filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    ISelectionFilter pSelFilter
)
Visual Basic (Declaration)
Public Function PickObject ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, String)

[image]

Revit 2011 API
Selection..::.PickObject Method (ObjectType, String)
Selection Class See Also Send Feedback
Prompts the user to select one object while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObject ( _
    objectType As ObjectType, _
    statusPrompt As String _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, ISelectionFilter, String)

[image]

Revit 2011 API
Selection..::.PickObject Method (ObjectType, ISelectionFilter, String)
Selection Class See Also Send Feedback
Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObject ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method

[image] [image]

Revit 2011 API
Selection..::.PickObjects Method
Selection Class See Also Send Feedback
Prompts the user to select multiple objects.

Overload List

Name | Description
PickObjects(ObjectType) | Prompts the user to select multiple objects.
PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <(Reference>)>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType)

[image]

Revit 2011 API
Selection..::.PickObjects Method (ObjectType)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter)

[image]

Revit 2011 API
Selection..::.PickObjects Method (ObjectType, ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects which pass a customer filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, String)

[image]

Revit 2011 API
Selection..::.PickObjects Method (ObjectType, String)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType, _
    statusPrompt As String _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

>

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter, String)

[image]

Revit 2011 API
Selection..::.PickObjects Method (ObjectType, ISelectionFilter, String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.
statusPrompt
Type: System..::.String
The message shown on the status bar.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
public void SelectPlanarFaces(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    ISelectionFilter selFilter = new PlanarFacesSelectionFilter();
    IList<Reference> faces =
        uidoc.Selection.PickObjects(ObjectType.Face, selFilter, "Select multiple planar faces");
}

public class PlanarFacesSelectionFilter : ISelectionFilter
{
    public bool AllowElement(Element element)
    {
        return true;
    }

    public bool AllowReference(Reference refer, XYZ point)
    {
        if (refer.GeometryObject is PlanarFace)
        {
            return true;
        }

        return false;
    }
}
CopyVB.NET
Public Sub SelectPlanarFaces(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim selFilter As ISelectionFilter = New PlanarFacesSelectionFilter()
    Dim faces As IList(Of Reference) = uidoc.Selection.PickObjects(Autodesk.Revit.UI.Selection.ObjectType.Face, selFilter, "Select multiple planar faces")
End Sub

Public Class PlanarFacesSelectionFilter
    Implements ISelectionFilter
    Public Function AllowElement(ByVal element As Autodesk.Revit.DB.Element) As Boolean Implements ISelectionFilter.AllowElement
        Return True
    End Function

    Public Function AllowReference(ByVal refer As Reference, ByVal point As Autodesk.Revit.DB.XYZ) As Boolean Implements ISelectionFilter.AllowReference
        If TypeOf refer.GeometryObject Is PlanarFace Then
            Return True
        End If

        Return False
    End Function
End Class

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter, String, IList(Reference))

[image]

Revit 2011 API
Selection..::.PickObjects Method (ObjectType, ISelectionFilter, String, IList<(Of <(Reference>)>))
Selection Class See Also Send Feedback
Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt,
    IList<Reference> pPreSelected
)
Visual Basic (Declaration)
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String, _
    pPreSelected As IList(Of Reference) _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt,
    IList<Reference^>^ pPreSelected
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::.ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::.ISelectionFilter
The selection filter.
statusPrompt
Type: System..::.String
The message shown on the status bar.
pPreSelected
Type: System.Collections.Generic..::.IList <(Of <( Reference >)>)
The previously selected set of objects.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

The previously selected set of objects will be highlighted.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when the Revit user cancelled this operation. Thrown when pPreSelected references has objects that are not the type of objectType. Thrown when objectType is PointOnElement which is not supported for selection involving preselected items.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickOne Method

[image]

Revit 2011 API
Selection..::.PickOne Method
Selection Class See Also Send Feedback
Allows the user to select one element.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickObject instead.")]
public bool PickOne()
Visual Basic (Declaration)
<ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickObject instead.")> _
Public Function PickOne As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated and will be excluded in future release. Use PickObject instead.")]
public:
bool PickOne()

Return Value

True if the user selected an element, false if the user selected elsewhere in the UI

Remarks

Note that the Revit user will not be allowed to select items in the Revit user interface except for Revit elements. This restriction also prevents users from closing the active document or the Revit application.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


PickPoint Method

[image] [image]

Revit 2011 API
Selection..::.PickPoint Method
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane.

Overload List

Name | Description
PickPoint()()() | Prompts the user to pick a point on the active work plane.
PickPoint(ObjectSnapTypes) | Prompts the user to pick a point on the active work plane using specified snap settings.
PickPoint(String) | Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
PickPoint(ObjectSnapTypes, String) | Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickPoint Method

[image]

Revit 2011 API
Selection..::.PickPoint Method
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ PickPoint()
Visual Basic (Declaration)
Public Function PickPoint As XYZ
Visual C++
public:
XYZ^ PickPoint()

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (ObjectSnapTypes)

[image]

Revit 2011 API
Selection..::.PickPoint Method (ObjectSnapTypes)
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane using specified snap settings.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ PickPoint(
    ObjectSnapTypes snapSettings
)
Visual Basic (Declaration)
Public Function PickPoint ( _
    snapSettings As ObjectSnapTypes _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    ObjectSnapTypes snapSettings
)

Parameters

snapSettings
Type: Autodesk.Revit.UI.Selection..::.ObjectSnapTypes
Specifies the object snap types for this pick. Multiple object snap types can be combined with "|"

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (String)

[image]

Revit 2011 API
Selection..::.PickPoint Method (String)
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ PickPoint(
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickPoint ( _
    statusPrompt As String _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    String^ statusPrompt
)

Parameters

statusPrompt
Type: System..::.String
Specifies the message shown on the status bar.

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (ObjectSnapTypes, String)

[image]

Revit 2011 API
Selection..::.PickPoint Method (ObjectSnapTypes, String)
Selection Class Example See Also Send Feedback
Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public XYZ PickPoint(
    ObjectSnapTypes snapSettings,
    string statusPrompt
)
Visual Basic (Declaration)
Public Function PickPoint ( _
    snapSettings As ObjectSnapTypes, _
    statusPrompt As String _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    ObjectSnapTypes snapSettings,
    String^ statusPrompt
)

Parameters

snapSettings
Type: Autodesk.Revit.UI.Selection..::.ObjectSnapTypes
Specifies the object snap types for this pick. Multiple object snap types can be combined with "|"
statusPrompt
Type: System..::.String
Specifies the message shown on the status bar.

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
public void PickPoint(UIDocument uidoc)
{
    ObjectSnapTypes snapTypes = ObjectSnapTypes.Endpoints | ObjectSnapTypes.Intersections;
    XYZ point = uidoc.Selection.PickPoint(snapTypes, "Select an end point or intersection");

    string strCoords = "Selected point is " + point.ToString();

    TaskDialog.Show("Revit", strCoords);
}
CopyVB.NET
Public Sub PickPoint(ByVal uidoc As UIDocument)
    Dim snapTypes As ObjectSnapTypes = ObjectSnapTypes.Endpoints Or ObjectSnapTypes.Intersections
    Dim point As Autodesk.Revit.DB.XYZ = uidoc.Selection.PickPoint(snapTypes, "Select an end point or intersection")

    Dim strCoords As String = "Selected point is " + point.ToString()

    TaskDialog.Show("Revit", strCoords)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | Thrown when the argument statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


WindowSelect Method

[image]

Revit 2011 API
Selection..::.WindowSelect Method
Selection Class See Also Send Feedback
Allows the user to select elements by a rectangle.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")]
public bool WindowSelect()
Visual Basic (Declaration)
<ObsoleteAttribute("This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")> _
Public Function WindowSelect As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated and will be excluded in future release. Use PickElementsByRectangle instead.")]
public:
bool WindowSelect()

Return Value

True if the user selected one or more elements, false if the user selected elsewhere in the UI

Remarks

Note that the Revit user will not be allowed to select items in the Revit user interface except for Revit elements. This restriction also prevents users from closing the active document or the Revit application.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.OperationCanceledException | Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::.ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


Selection Properties

[image] [image]

Revit 2011 API
Selection Properties
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Properties

Name | Description
Elements | The elements that are currently selected.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
StatusbarTip | Obsolete. The message displayed in the status bar tip when prompting the user to make a selection.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


Elements Property

[image]

Revit 2011 API
Selection..::.Elements Property
Selection Class Example See Also Send Feedback
The elements that are currently selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public SelElementSet Elements { get; set; }
Visual Basic (Declaration)
Public Property Elements As SelElementSet
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The set of elements that are actively selected.

Remarks

This set will contain the results after the user makes selections due to a PickOne or WindowSelect call.

Examples

CopyC#
private void ChangeSelection(Document document)
{
    // Get selected elements form current document.
    UIDocument uidoc = new UIDocument(document);
    Autodesk.Revit.UI.Selection.SelElementSet collection = uidoc.Selection.Elements;

    // Display current number of selected elements
    TaskDialog.Show("Revit","Number of selected elements: " + collection.Size.ToString());

    //Create a new SelElementSet
    SelElementSet newSelectedElementSet = SelElementSet.Create();

    // Add wall into the created element set.
    foreach (Autodesk.Revit.DB.Element elements in collection)
    {
        if (elements is Wall)
        {
            newSelectedElementSet.Add(elements);
        }
    }

    // Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet;

    // Give the user some information.
    if (0 != newSelectedElementSet.Size)
    {
        TaskDialog.Show("Revit",uidoc.Selection.Elements.Size.ToString() + " Walls are selected!");
    }
    else
    {
        TaskDialog.Show("Revit","No Walls have been selected!");
    }
}
CopyVB.NET
Private Sub ChangeSelection(ByVal document As Document)
    ' Get selected elements form current document.
    Dim uidoc As New UIDocument(document)
    Dim collection As Autodesk.Revit.UI.Selection.SelElementSet = uidoc.Selection.Elements

    ' Display current number of selected elements
    TaskDialog.Show("Revit", "Number of selected elements: " + collection.Size.ToString())

    'Create a new SelElementSet
    Dim newSelectedElementSet As SelElementSet = SelElementSet.Create()

    ' Add wall into the created element set.
    For Each elements As Autodesk.Revit.DB.Element In collection
        If TypeOf elements Is Wall Then
            newSelectedElementSet.Add(elements)
        End If
    Next

    ' Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet

    ' Give the user some information.
    If 0 <> newSelectedElementSet.Size Then
        TaskDialog.Show("Revit", uidoc.Selection.Elements.Size.ToString() + " Walls are selected!")
    Else
        TaskDialog.Show("Revit", "No Walls have been selected!")
    End If
End Sub

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


StatusbarTip Property

[image]

Revit 2011 API
Selection..::.StatusbarTip Property
Selection Class See Also Send Feedback
The message displayed in the status bar tip when prompting the user to make a selection.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated and will be excluded in future release.")]
public string StatusbarTip { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("This method is deprecated and will be excluded in future release.")> _
Public Property StatusbarTip As String
Visual C++
[ObsoleteAttribute(L"This method is deprecated and will be excluded in future release.")]
public:
property String^ StatusbarTip {
    String^ get ();
    void set (String^ value);
}

Field Value

The message is displayed in the status bar at the bottom of the Autodesk Revit UI.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Class

[image]

Revit 2011 API
SelElementSet Class
Members See Also Send Feedback
This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public class SelElementSet : ElementSet
Visual Basic (Declaration)
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
public ref class SelElementSet : public ElementSet

Remarks

Add or Remove elements from the selected element set. The elements in the set will be highlighted as selected elements in the UI.

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.DB..::.ElementSet
Autodesk.Revit.UI.Selection..::.SelElementSet

See Also

SelElementSet Members
Autodesk.Revit.UI.Selection Namespace


SelElementSet Members

[image] [image]

Revit 2011 API
SelElementSet Members
SelElementSet Class Methods Properties See Also Send Feedback

The SelElementSet type exposes the following members.

Methods

Name | Description
Add | Add an element into the selected element set.
Clear | Clear the selected element set. (Overrides ElementSet..::.Clear()()().)
Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Create | Creates a new instance of a set specifically for holding selected elements.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Remove an element from the selected element set. (Overrides ElementSet..::.Erase(Element).)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Remove | Remove an element from the selected element set.
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Methods

[image] [image]

Revit 2011 API
SelElementSet Methods
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Methods

Name | Description
Add | Add an element into the selected element set.
Clear | Clear the selected element set. (Overrides ElementSet..::.Clear()()().)
Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
Create | Creates a new instance of a set specifically for holding selected elements.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Remove an element from the selected element set. (Overrides ElementSet..::.Erase(Element).)
ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Remove | Remove an element from the selected element set.
ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Add Method

[image]

Revit 2011 API
SelElementSet..::.Add Method
SelElementSet Class See Also Send Feedback
Add an element into the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Add(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    element As Element _
)
Visual C++
public:
virtual void Add(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to be added.

Remarks

This function will add the specified element to the selected element set, just like the element is picked from the UI.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Clear Method

[image]

Revit 2011 API
SelElementSet..::.Clear Method
SelElementSet Class See Also Send Feedback
Clear the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public override void Clear()
Visual Basic (Declaration)
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

All the elements in the selected element set will be removed and no element will be highlighted after the operation.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Create Method

[image]

Revit 2011 API
SelElementSet..::.Create Method
SelElementSet Class See Also Send Feedback
Creates a new instance of a set specifically for holding selected elements.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public static SelElementSet Create()
Visual Basic (Declaration)
Public Shared Function Create As SelElementSet
Visual C++
public:
static SelElementSet^ Create()

Return Value

Returns a new Element Set.

Remarks

If the user wants to change the selected Element with the API, the instance SelElementSet must be created to do the operation of Add and Remove.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Erase Method

[image]

Revit 2011 API
SelElementSet..::.Erase Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public override int Erase(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function Erase ( _
    element As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ element
) override

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to be removed.

Return Value

Returns count of the elements to be erased from the selected element set.

Remarks

This function will do same task as Remove.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Remove Method

[image]

Revit 2011 API
SelElementSet..::.Remove Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Remove(
    Element element
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    element As Element _
)
Visual C++
public:
virtual void Remove(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
The element to be removed.

Remarks

This function will remove the specified from the selected element set, just like de-select it from the UI.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Properties

[image] [image]

Revit 2011 API
SelElementSet Properties
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Autodesk.Revit.Utility Namespace

[image]

Revit 2011 API
Autodesk.Revit.Utility Namespace
Send Feedback

Classes

Class | Description
Asset |
AssetProperties | A set of asset properties.
AssetProperty |
AssetPropertyBoolean |
AssetPropertyDistance |
AssetPropertyDouble |
AssetPropertyDoubleArray2d |
AssetPropertyDoubleArray3d |
AssetPropertyDoubleArray4d |
AssetPropertyDoubleMatrix44 |
AssetPropertyEnum |
AssetPropertyFloat |
AssetPropertyInteger |
AssetPropertyReference |
AssetPropertyString |
AssetPropertyTime |
AssetSet | A set that contains assets.
AssetSetIterator | An iterator to a asset set.

Enumerations

Enumeration | Description
AssetPropertyType | An enumerated to list AssetProperty Types in Revit.
AssetType | An enumerated to list Asset Types in Revit.


Asset Class

[image]

Revit 2011 API
Asset Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class Asset : AssetProperties
Visual Basic (Declaration)
Public Class Asset _
    Inherits AssetProperties
Visual C++
public ref class Asset : public AssetProperties

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.Asset

See Also

Asset Members
Autodesk.Revit.Utility Namespace


Asset Members

[image] [image]

Revit 2011 API
Asset Members
Asset Class Methods Properties See Also Send Feedback

The Asset type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Methods

[image] [image]

Revit 2011 API
Asset Methods
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Properties

[image] [image]

Revit 2011 API
Asset Properties
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Properties

Name | Description
AssetType | Get the object's AssetPropertyType
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
LibraryName | Get the library name
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Title | Get the asset's title
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetType Property

[image]

Revit 2011 API
Asset..::.AssetType Property
Asset Class See Also Send Feedback
Get the object's AssetPropertyType

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetType AssetType { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssetType As AssetType
Visual C++
public:
property AssetType AssetType {
    AssetType get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2011 API
Asset..::.Item Property
Asset Class See Also Send Feedback
Gets a property by an identifier.

Overload List

Name | Description
Item[([(Int32])]) | (Inherited from AssetProperties.)
Item[([(String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)

See Also

Asset Class
Asset Members
Autodesk.Revit.Utility Namespace


LibraryName Property

[image]

Revit 2011 API
Asset..::.LibraryName Property
Asset Class See Also Send Feedback
Get the library name

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string LibraryName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LibraryName As String
Visual C++
public:
property String^ LibraryName {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Title Property

[image]

Revit 2011 API
Asset..::.Title Property
Asset Class See Also Send Feedback
Get the asset's title

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetProperties Class

[image]

Revit 2011 API
AssetProperties Class
Members See Also Send Feedback
A set of asset properties.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetProperties : AssetProperty
Visual Basic (Declaration)
Public Class AssetProperties _
    Inherits AssetProperty
Visual C++
public ref class AssetProperties : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.Asset

See Also

AssetProperties Members
Autodesk.Revit.Utility Namespace


AssetProperties Members

[image] [image]

Revit 2011 API
AssetProperties Members
AssetProperties Class Methods Properties See Also Send Feedback

The AssetProperties type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object.
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Methods

[image] [image]

Revit 2011 API
AssetProperties Methods
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Properties

[image] [image]

Revit 2011 API
AssetProperties Properties
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Item | Overloaded. Gets a property by an identifier.
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Size | Gets the number of the AssetProperty(s) in the object.
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2011 API
AssetProperties..::.Item Property
AssetProperties Class See Also Send Feedback
Gets a property by an identifier.

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) | Gets the one property that the current object contains with the given name.

See Also

AssetProperties Class
AssetProperties Members
Autodesk.Revit.Utility Namespace


Item Property (Int32)

[image]

Revit 2011 API
AssetProperties..::.Item Property (Int32)
AssetProperties Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetProperty this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[int index] {
    AssetProperty^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Item Property (String)

[image]

Revit 2011 API
AssetProperties..::.Item Property (String)
AssetProperties Class See Also Send Feedback
Gets the one property that the current object contains with the given name.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetProperty this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As AssetProperty
Visual C++
public:
property AssetProperty^ default[String^ name] {
    AssetProperty^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2011 API
AssetProperties..::.Size Property
AssetProperties Class See Also Send Feedback
Gets the number of the AssetProperty(s) in the object.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
}

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperty Class

[image]

Revit 2011 API
AssetProperty Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetProperty : APIObject
Visual Basic (Declaration)
Public Class AssetProperty _
    Inherits APIObject
Visual C++
public ref class AssetProperty : public APIObject

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetProperties
Autodesk.Revit.Utility..::.AssetPropertyBoolean
Autodesk.Revit.Utility..::.AssetPropertyDistance
Autodesk.Revit.Utility..::.AssetPropertyDouble
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray2d
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray3d
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray4d
Autodesk.Revit.Utility..::.AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility..::.AssetPropertyEnum
Autodesk.Revit.Utility..::.AssetPropertyFloat
Autodesk.Revit.Utility..::.AssetPropertyInteger
Autodesk.Revit.Utility..::.AssetPropertyReference
Autodesk.Revit.Utility..::.AssetPropertyString
Autodesk.Revit.Utility..::.AssetPropertyTime

See Also

AssetProperty Members
Autodesk.Revit.Utility Namespace


AssetProperty Members

[image] [image]

Revit 2011 API
AssetProperty Members
AssetProperty Class Methods Properties See Also Send Feedback

The AssetProperty type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Get the name of the AssetProperty
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty
Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Methods

[image] [image]

Revit 2011 API
AssetProperty Methods
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Get the name of the AssetProperty
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


GetTypeName Method

[image]

Revit 2011 API
AssetProperty..::.GetTypeName Method
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic (Declaration)
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName(
    AssetPropertyType type
)

Parameters

type
Type: Autodesk.Revit.Utility..::.AssetPropertyType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentException | Thrown when type is AssetPropertyType::APT_Unknown or AssetPropertyType::APT_Last.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Properties

[image] [image]

Revit 2011 API
AssetProperty Properties
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty
Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Name Property

[image]

Revit 2011 API
AssetProperty..::.Name Property
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Type Property

[image]

Revit 2011 API
AssetProperty..::.Type Property
AssetProperty Class See Also Send Feedback
Returns the Type of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AssetPropertyType Type { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Type As AssetPropertyType
Visual C++
public:
virtual property AssetPropertyType Type {
    AssetPropertyType get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Class

[image]

Revit 2011 API
AssetPropertyBoolean Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyBoolean : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyBoolean _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyBoolean : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyBoolean

See Also

AssetPropertyBoolean Members
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Members

[image] [image]

Revit 2011 API
AssetPropertyBoolean Members
AssetPropertyBoolean Class Methods Properties See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Methods

[image] [image]

Revit 2011 API
AssetPropertyBoolean Methods
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Properties

[image] [image]

Revit 2011 API
AssetPropertyBoolean Properties
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyBoolean..::.Value Property
AssetPropertyBoolean Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public bool Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Boolean
Visual C++
public:
property bool Value {
    bool get ();
}

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Class

[image]

Revit 2011 API
AssetPropertyDistance Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDistance : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDistance _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDistance : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDistance

See Also

AssetPropertyDistance Members
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Members

[image] [image]

Revit 2011 API
AssetPropertyDistance Members
AssetPropertyDistance Class Methods Properties See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DisplayUnitType |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Methods

[image] [image]

Revit 2011 API
AssetPropertyDistance Methods
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Properties

[image] [image]

Revit 2011 API
AssetPropertyDistance Properties
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Properties

Name | Description
DisplayUnitType |
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


DisplayUnitType Property

[image]

Revit 2011 API
AssetPropertyDistance..::.DisplayUnitType Property
AssetPropertyDistance Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayUnitType As DisplayUnitType
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDistance..::.Value Property
AssetPropertyDistance Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Class

[image]

Revit 2011 API
AssetPropertyDouble Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDouble : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDouble _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDouble : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDouble

See Also

AssetPropertyDouble Members
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Members

[image] [image]

Revit 2011 API
AssetPropertyDouble Members
AssetPropertyDouble Class Methods Properties See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Methods

[image] [image]

Revit 2011 API
AssetPropertyDouble Methods
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Properties

[image] [image]

Revit 2011 API
AssetPropertyDouble Properties
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDouble..::.Value Property
AssetPropertyDouble Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Class

[image]

Revit 2011 API
AssetPropertyDoubleArray2d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray2d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray2d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray2d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray2d

See Also

AssetPropertyDoubleArray2d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Members

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray2d Members
AssetPropertyDoubleArray2d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Methods

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray2d Methods
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Properties

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray2d Properties
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDoubleArray2d..::.Value Property
AssetPropertyDoubleArray2d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Class

[image]

Revit 2011 API
AssetPropertyDoubleArray3d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray3d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray3d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray3d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray3d

See Also

AssetPropertyDoubleArray3d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Members

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray3d Members
AssetPropertyDoubleArray3d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Methods

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray3d Methods
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Properties

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray3d Properties
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDoubleArray3d..::.Value Property
AssetPropertyDoubleArray3d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Class

[image]

Revit 2011 API
AssetPropertyDoubleArray4d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray4d : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleArray4d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray4d : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleArray4d

See Also

AssetPropertyDoubleArray4d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Members

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray4d Members
AssetPropertyDoubleArray4d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Methods

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray4d Methods
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Properties

[image] [image]

Revit 2011 API
AssetPropertyDoubleArray4d Properties
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDoubleArray4d..::.Value Property
AssetPropertyDoubleArray4d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Class

[image]

Revit 2011 API
AssetPropertyDoubleMatrix44 Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyDoubleMatrix44 : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyDoubleMatrix44 _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleMatrix44 : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyDoubleMatrix44

See Also

AssetPropertyDoubleMatrix44 Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Members

[image] [image]

Revit 2011 API
AssetPropertyDoubleMatrix44 Members
AssetPropertyDoubleMatrix44 Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Methods

[image] [image]

Revit 2011 API
AssetPropertyDoubleMatrix44 Methods
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Properties

[image] [image]

Revit 2011 API
AssetPropertyDoubleMatrix44 Properties
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyDoubleMatrix44..::.Value Property
AssetPropertyDoubleMatrix44 Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DoubleArray
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Class

[image]

Revit 2011 API
AssetPropertyEnum Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyEnum : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyEnum _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyEnum : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyEnum

See Also

AssetPropertyEnum Members
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Members

[image] [image]

Revit 2011 API
AssetPropertyEnum Members
AssetPropertyEnum Class Methods Properties See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Methods

[image] [image]

Revit 2011 API
AssetPropertyEnum Methods
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Properties

[image] [image]

Revit 2011 API
AssetPropertyEnum Properties
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyEnum..::.Value Property
AssetPropertyEnum Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Class

[image]

Revit 2011 API
AssetPropertyFloat Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyFloat : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyFloat _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyFloat : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyFloat

See Also

AssetPropertyFloat Members
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Members

[image] [image]

Revit 2011 API
AssetPropertyFloat Members
AssetPropertyFloat Class Methods Properties See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Methods

[image] [image]

Revit 2011 API
AssetPropertyFloat Methods
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Properties

[image] [image]

Revit 2011 API
AssetPropertyFloat Properties
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyFloat..::.Value Property
AssetPropertyFloat Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public float Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Single
Visual C++
public:
property float Value {
    float get ();
}

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Class

[image]

Revit 2011 API
AssetPropertyInteger Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyInteger : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyInteger _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyInteger : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyInteger

See Also

AssetPropertyInteger Members
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Members

[image] [image]

Revit 2011 API
AssetPropertyInteger Members
AssetPropertyInteger Class Methods Properties See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Methods

[image] [image]

Revit 2011 API
AssetPropertyInteger Methods
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Properties

[image] [image]

Revit 2011 API
AssetPropertyInteger Properties
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyInteger..::.Value Property
AssetPropertyInteger Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Class

[image]

Revit 2011 API
AssetPropertyReference Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyReference : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyReference _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyReference : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyReference

See Also

AssetPropertyReference Members
Autodesk.Revit.Utility Namespace


AssetPropertyReference Members

[image] [image]

Revit 2011 API
AssetPropertyReference Members
AssetPropertyReference Class Methods Properties See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Methods

[image] [image]

Revit 2011 API
AssetPropertyReference Methods
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Properties

[image] [image]

Revit 2011 API
AssetPropertyReference Properties
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Class

[image]

Revit 2011 API
AssetPropertyString Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyString : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyString _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyString : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyString

See Also

AssetPropertyString Members
Autodesk.Revit.Utility Namespace


AssetPropertyString Members

[image] [image]

Revit 2011 API
AssetPropertyString Members
AssetPropertyString Class Methods Properties See Also Send Feedback

The AssetPropertyString type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Methods

[image] [image]

Revit 2011 API
AssetPropertyString Methods
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Properties

[image] [image]

Revit 2011 API
AssetPropertyString Properties
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyString..::.Value Property
AssetPropertyString Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Class

[image]

Revit 2011 API
AssetPropertyTime Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetPropertyTime : AssetProperty
Visual Basic (Declaration)
Public Class AssetPropertyTime _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyTime : public AssetProperty

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetProperty
Autodesk.Revit.Utility..::.AssetPropertyTime

See Also

AssetPropertyTime Members
Autodesk.Revit.Utility Namespace


AssetPropertyTime Members

[image] [image]

Revit 2011 API
AssetPropertyTime Members
AssetPropertyTime Class Methods Properties See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Methods

[image] [image]

Revit 2011 API
AssetPropertyTime Methods
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Properties

[image] [image]

Revit 2011 API
AssetPropertyTime Properties
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Properties

Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Name | Get the name of the AssetProperty (Inherited from AssetProperty.)
Type | Returns the Type of the AssetProperty (Inherited from AssetProperty.)
Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2011 API
AssetPropertyTime..::.Value Property
AssetPropertyTime Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public DateTime Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As DateTime
Visual C++
public:
property DateTime Value {
    DateTime get ();
}

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyType Enumeration

[image]

Revit 2011 API
AssetPropertyType Enumeration
See Also Send Feedback
An enumerated to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AssetPropertyType
Visual Basic (Declaration)
Public Enumeration AssetPropertyType
Visual C++
public enum class AssetPropertyType

Members

Member name | Description
APT_Unknown |
APT_Properties |
APT_Boolean |
APT_Enum |
APT_Integer |
APT_Float |
APT_Double | AssetPropertyDouble.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_String |
APT_Time |
APT_Distance |
APT_Asset |
APT_Reference |
APT_Last |

See Also

Autodesk.Revit.Utility Namespace


AssetSet Class

[image]

Revit 2011 API
AssetSet Class
Members See Also Send Feedback
A set that contains assets.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public class AssetSet : APIObject, IEnumerable
Visual Basic (Declaration)
Public Class AssetSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AssetSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetSet

See Also

AssetSet Members
Autodesk.Revit.Utility Namespace


AssetSet Members

[image] [image]

Revit 2011 API
AssetSet Members
AssetSet Class Constructors Methods Properties See Also Send Feedback

The AssetSet type exposes the following members.

Constructors

Name | Description
AssetSet | Initializes a new instance of the AssetSet class

Methods

Name | Description
Clear | Removes every asset from the set, rendering it empty.
Contains | Tests for the existence of a asset within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified asset from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified asset into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Constructor

[image]

Revit 2011 API
AssetSet Constructor
AssetSet Class See Also Send Feedback
Initializes a new instance of the AssetSet class

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSet()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Methods

[image] [image]

Revit 2011 API
AssetSet Methods
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Methods

Name | Description
Clear | Removes every asset from the set, rendering it empty.
Contains | Tests for the existence of a asset within the set.
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Erase | Removes a specified asset from the set.
ForwardIterator | Retrieve a forward moving iterator to the set.
GetEnumerator | Retrieve a forward moving iterator to the set.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Insert the specified asset into the set.
ReverseIterator | Retrieve a backward moving iterator to the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Clear Method

[image]

Revit 2011 API
AssetSet..::.Clear Method
AssetSet Class See Also Send Feedback
Removes every asset from the set, rendering it empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic (Declaration)
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Contains Method

[image]

Revit 2011 API
AssetSet..::.Contains Method
AssetSet Class See Also Send Feedback
Tests for the existence of a asset within the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Contains(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be searched for.

Return Value

The Contains method returns True if the asset is within the set, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Erase Method

[image]

Revit 2011 API
AssetSet..::.Erase Method
AssetSet Class See Also Send Feedback
Removes a specified asset from the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Erase(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Erase ( _
    item As Asset _
) As Integer
Visual C++
public:
virtual int Erase(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be erased.

Return Value

The number of assets that were erased from the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ForwardIterator Method

[image]

Revit 2011 API
AssetSet..::.ForwardIterator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AssetSetIterator ForwardIterator()
Visual Basic (Declaration)
Public Overridable Function ForwardIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


GetEnumerator Method

[image]

Revit 2011 API
AssetSet..::.GetEnumerator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Insert Method

[image]

Revit 2011 API
AssetSet..::.Insert Method
AssetSet Class See Also Send Feedback
Insert the specified asset into the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool Insert(
    Asset item
)
Visual Basic (Declaration)
Public Overridable Function Insert ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::.Asset
The asset to be inserted into the set.

Return Value

Returns whether the asset was inserted into the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ReverseIterator Method

[image]

Revit 2011 API
AssetSet..::.ReverseIterator Method
AssetSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual AssetSetIterator ReverseIterator()
Visual Basic (Declaration)
Public Overridable Function ReverseIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Properties

[image] [image]

Revit 2011 API
AssetSet Properties
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Properties

Name | Description
IsEmpty | Test to see if the set is empty.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


IsEmpty Property

[image]

Revit 2011 API
AssetSet..::.IsEmpty Property
AssetSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEmpty As Boolean
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2011 API
AssetSet..::.Size Property
AssetSet Class See Also Send Feedback
Returns the number of assets that are in the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Class

[image]

Revit 2011 API
AssetSetIterator Class
Members See Also Send Feedback
An iterator to a asset set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class AssetSetIterator : APIObject,
    IEnumerator
Visual Basic (Declaration)
Public MustInherit Class AssetSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AssetSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.DB..::.APIObject
Autodesk.Revit.Utility..::.AssetSetIterator

See Also

AssetSetIterator Members
Autodesk.Revit.Utility Namespace


AssetSetIterator Members

[image] [image]

Revit 2011 API
AssetSetIterator Members
AssetSetIterator Class Constructors Methods Properties See Also Send Feedback

The AssetSetIterator type exposes the following members.

Constructors

Name | Description
AssetSetIterator | For Internal Use Only.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Constructor

[image]

Revit 2011 API
AssetSetIterator Constructor
AssetSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public AssetSetIterator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AssetSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Methods

[image] [image]

Revit 2011 API
AssetSetIterator Methods
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Methods

Name | Description
Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MoveNext | Move the iterator one item forward.
Reset | Bring the iterator back to the start of the set.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


MoveNext Method

[image]

Revit 2011 API
AssetSetIterator..::.MoveNext Method
AssetSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic (Declaration)
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::.MoveNext()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Reset Method

[image]

Revit 2011 API
AssetSetIterator..::.Reset Method
AssetSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::.Reset()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Properties

[image] [image]

Revit 2011 API
AssetSetIterator Properties
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Properties

Name | Description
Current | Retrieves the item that is the current focus of the iterator.
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Current Property

[image]

Revit 2011 API
AssetSetIterator..::.Current Property
AssetSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::.Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetType Enumeration

[image]

Revit 2011 API
AssetType Enumeration
See Also Send Feedback
An enumerated to list Asset Types in Revit.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2011.0.0.0

Syntax

C#
public enum AssetType
Visual Basic (Declaration)
Public Enumeration AssetType
Visual C++
public enum class AssetType

Members

Member name | Description
Appearance |

See Also

Autodesk.Revit.Utility Namespace


Autodesk.Revit.VSTA Namespace

[image]

Revit 2011 API
Autodesk.Revit.VSTA Namespace
Send Feedback

Classes

Class | Description
AddInIdAttribute | The custom AddInId attribute for VSTA macros use only.
ApplicationEntryPoint | For Revit VSTA use only.
DocumentEntryPoint | For Revit VSTA use only.

Interfaces

Interface | Description
IEntryPoint |


AddInIdAttribute Class

[image]

Revit 2011 API
AddInIdAttribute Class
Members See Also Send Feedback
The custom AddInId attribute for VSTA macros use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public class AddInIdAttribute : Attribute
Visual Basic (Declaration)
Public Class AddInIdAttribute _
    Inherits Attribute
Visual C++
public ref class AddInIdAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Autodesk.Revit.VSTA..::.AddInIdAttribute

See Also

AddInIdAttribute Members
Autodesk.Revit.VSTA Namespace


AddInIdAttribute Members

[image] [image]

Revit 2011 API
AddInIdAttribute Members
AddInIdAttribute Class Constructors Methods Properties See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Constructors

Name | Description
AddInIdAttribute | Constructs a new AddInIdAttribute.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Value | AddInId guid value.

See Also

AddInIdAttribute Class
Autodesk.Revit.VSTA Namespace


AddInIdAttribute Constructor

[image]

Revit 2011 API
AddInIdAttribute Constructor
AddInIdAttribute Class See Also Send Feedback
Constructs a new AddInIdAttribute.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public AddInIdAttribute(
    string addInIdStr
)
Visual Basic (Declaration)
Public Sub New ( _
    addInIdStr As String _
)
Visual C++
public:
AddInIdAttribute(
    String^ addInIdStr
)

Parameters

addInIdStr
Type: System..::.String

See Also

AddInIdAttribute Class
Autodesk.Revit.VSTA Namespace


AddInIdAttribute Methods

[image] [image]

Revit 2011 API
AddInIdAttribute Methods
AddInIdAttribute Class See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInIdAttribute Class
Autodesk.Revit.VSTA Namespace


AddInIdAttribute Properties

[image] [image]

Revit 2011 API
AddInIdAttribute Properties
AddInIdAttribute Class See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Value | AddInId guid value.

See Also

AddInIdAttribute Class
Autodesk.Revit.VSTA Namespace


Value Property

[image]

Revit 2011 API
AddInIdAttribute..::.Value Property
AddInIdAttribute Class See Also Send Feedback
AddInId guid value.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0
Since: 2011

Syntax

C#
public ValueType Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As ValueType
Visual C++
public:
property ValueType^ Value {
    ValueType^ get ();
}

See Also

AddInIdAttribute Class
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Class

[image]

Revit 2011 API
ApplicationEntryPoint Class
Members See Also Send Feedback
For Revit VSTA use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class ApplicationEntryPoint : IEntryPoint
Visual Basic (Declaration)
Public MustInherit Class ApplicationEntryPoint _
    Implements IEntryPoint
Visual C++
public ref class ApplicationEntryPoint abstract : IEntryPoint

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.VSTA..::.ApplicationEntryPoint

See Also

ApplicationEntryPoint Members
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Members

[image] [image]

Revit 2011 API
ApplicationEntryPoint Members
ApplicationEntryPoint Class Constructors Methods Properties Events See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Constructors

Name | Description
ApplicationEntryPoint | Initializes a new instance of the ApplicationEntryPoint class

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FinishInitializationEO | For Revit VSTA internal use only.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
AddinFolder | The full path to the Revit VSTA module.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Constructor

[image]

Revit 2011 API
ApplicationEntryPoint Constructor
ApplicationEntryPoint Class See Also Send Feedback
Initializes a new instance of the ApplicationEntryPoint class

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public ApplicationEntryPoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationEntryPoint()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Methods

[image] [image]

Revit 2011 API
ApplicationEntryPoint Methods
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Methods

Name | Description
CreateRibbonPanel | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FinishInitializationEO | For Revit VSTA internal use only.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRibbonPanels | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2011 API
ApplicationEntryPoint..::.CreateRibbonPanel Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

Name | Description
CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.VSTA Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2011 API
ApplicationEntryPoint..::.CreateRibbonPanel Method (String)
ApplicationEntryPoint Class See Also Send Feedback
Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created.

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.VSTA Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2011 API
ApplicationEntryPoint..::.CreateRibbonPanel Method (Tab, String)
ApplicationEntryPoint Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic (Declaration)
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::.String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in VSTA.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::.ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::.InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.VSTA Namespace


FinishInitializationEO Method

[image]

Revit 2011 API
ApplicationEntryPoint..::.FinishInitializationEO Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void FinishInitializationEO()
Visual Basic (Declaration)
Public Sub FinishInitializationEO
Visual C++
public:
virtual void FinishInitializationEO() sealed

Implements

IEntryPoint..::.FinishInitialization()()()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


GetRibbonPanels Method

[image] [image]

Revit 2011 API
ApplicationEntryPoint..::.GetRibbonPanels Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

Name | Description
GetRibbonPanels()()() | Get all the custom Panels on Add-Ins tab of Revit.
GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.VSTA Namespace


GetRibbonPanels Method

[image]

Revit 2011 API
ApplicationEntryPoint..::.GetRibbonPanels Method
ApplicationEntryPoint Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic (Declaration)
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in VSTA.

See Also

ApplicationEntryPoint Class
GetRibbonPanels Overload
Autodesk.Revit.VSTA Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2011 API
ApplicationEntryPoint..::.GetRibbonPanels Method (Tab)
ApplicationEntryPoint Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic (Declaration)
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::.Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in VSTA.

See Also

ApplicationEntryPoint Class
GetRibbonPanels Overload
Autodesk.Revit.VSTA Namespace


Initialize Method

[image]

Revit 2011 API
ApplicationEntryPoint..::.Initialize Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
public:
virtual void Initialize(
    Object^ obj,
    String^ addinFolder
) sealed

Parameters

obj
Type: System..::.Object
addinFolder
Type: System..::.String

Implements

IEntryPoint..::.Initialize(Object, String)

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


OnShutdownEO Method

[image]

Revit 2011 API
ApplicationEntryPoint..::.OnShutdownEO Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void OnShutdownEO()
Visual Basic (Declaration)
Public Sub OnShutdownEO
Visual C++
public:
virtual void OnShutdownEO() sealed

Implements

IEntryPoint..::.OnShutdown()()()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Properties

[image] [image]

Revit 2011 API
ApplicationEntryPoint Properties
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Properties

Name | Description
ActiveAddInId | Get current active external application or external command id.
ActiveUIDocument | Provides access to an object that represents the currently active project.
AddinFolder | The full path to the Revit VSTA module.
Application | Returns the database level Application represented by this UI level Application.
DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
LoadedApplications | Returns an array of successfully loaded external applications.
MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ActiveAddInId Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.ActiveAddInId Property
ApplicationEntryPoint Class See Also Send Feedback
Get current active external application or external command id.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveAddInId As AddInId
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ActiveUIDocument Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.ActiveUIDocument Property
ApplicationEntryPoint Class See Also Send Feedback
Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual UIDocument ActiveUIDocument { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument
Visual C++
public:
virtual property UIDocument^ ActiveUIDocument {
    UIDocument^ get ();
}

Remarks

External API commands can access this property in read-only mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when attempting to modify the property.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


AddinFolder Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.AddinFolder Property
ApplicationEntryPoint Class See Also Send Feedback
The full path to the Revit VSTA module.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AddinFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddinFolder As String
Visual C++
public:
virtual property String^ AddinFolder {
    String^ get () sealed;
}

Implements

IEntryPoint..::.AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the VSTA module is loaded in such a way to make that result unreliable.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


Application Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.Application Property
ApplicationEntryPoint Class See Also Send Feedback
Returns the database level Application represented by this UI level Application.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As Application
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


DrawingAreaExtents Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.DrawingAreaExtents Property
ApplicationEntryPoint Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of drawing area.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Rectangle DrawingAreaExtents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property DrawingAreaExtents As Rectangle
Visual C++
public:
virtual property Rectangle^ DrawingAreaExtents {
    Rectangle^ get ();
}

Remarks

The drawing area of the Revit window displays views (and sheets and schedules) of the current project. The size of drawing area restricts the max size of the view windows. If there is no project opened, null will be returned.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


LoadedApplications Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.LoadedApplications Property
ApplicationEntryPoint Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


MainWindowExtents Property

[image]

Revit 2011 API
ApplicationEntryPoint..::.MainWindowExtents Property
ApplicationEntryPoint Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of Revit main window.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public virtual Rectangle MainWindowExtents { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property MainWindowExtents As Rectangle
Visual C++
public:
virtual property Rectangle^ MainWindowExtents {
    Rectangle^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ApplicationEntryPoint Events

[image] [image]

Revit 2011 API
ApplicationEntryPoint Events
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Events

Name | Description
ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ApplicationClosing Event

[image]

Revit 2011 API
ApplicationEntryPoint..::.ApplicationClosing Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic (Declaration)
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

No document may be modified at the time of the event.

The sender object of this event is Application object.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


DialogBoxShowing Event

[image]

Revit 2011 API
ApplicationEntryPoint..::.DialogBoxShowing Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic (Declaration)
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


Idling Event

[image]

Revit 2011 API
ApplicationEntryPoint..::.Idling Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic (Declaration)
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

Event is not cancellable.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ViewActivated Event

[image]

Revit 2011 API
ApplicationEntryPoint..::.ViewActivated Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic (Declaration)
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


ViewActivating Event

[image]

Revit 2011 API
ApplicationEntryPoint..::.ViewActivating Event
ApplicationEntryPoint Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic (Declaration)
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()() and similar overloads.
  • Save()()() and similar overloads.
  • SaveAs()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.VSTA Namespace


DocumentEntryPoint Class

[image]

Revit 2011 API
DocumentEntryPoint Class
Members See Also Send Feedback
For Revit VSTA use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public abstract class DocumentEntryPoint : IEntryPoint
Visual Basic (Declaration)
Public MustInherit Class DocumentEntryPoint _
    Implements IEntryPoint
Visual C++
public ref class DocumentEntryPoint abstract : IEntryPoint

Inheritance Hierarchy

System..::.Object
Autodesk.Revit.VSTA..::.DocumentEntryPoint

See Also

DocumentEntryPoint Members
Autodesk.Revit.VSTA Namespace


DocumentEntryPoint Members

[image] [image]

Revit 2011 API
DocumentEntryPoint Members
DocumentEntryPoint Class Constructors Methods Properties See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Constructors

Name | Description
DocumentEntryPoint | Initializes a new instance of the DocumentEntryPoint class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FinishInitializationEO | For Revit VSTA internal use only.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddinFolder | The full path to the Revit VSTA module.
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


DocumentEntryPoint Constructor

[image]

Revit 2011 API
DocumentEntryPoint Constructor
DocumentEntryPoint Class See Also Send Feedback
Initializes a new instance of the DocumentEntryPoint class

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public DocumentEntryPoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentEntryPoint()

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


DocumentEntryPoint Methods

[image] [image]

Revit 2011 API
DocumentEntryPoint Methods
DocumentEntryPoint Class See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FinishInitializationEO | For Revit VSTA internal use only.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | For Revit VSTA internal use only.
OnShutdownEO | For Revit VSTA internal use only.
PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
RefreshActiveView | Refresh the display of the active view in the active document.
ShowElements | Overloaded. Shows one or more elements by zoom to fit.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


FinishInitializationEO Method

[image]

Revit 2011 API
DocumentEntryPoint..::.FinishInitializationEO Method
DocumentEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void FinishInitializationEO()
Visual Basic (Declaration)
Public Sub FinishInitializationEO
Visual C++
public:
virtual void FinishInitializationEO() sealed

Implements

IEntryPoint..::.FinishInitialization()()()

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


Initialize Method

[image]

Revit 2011 API
DocumentEntryPoint..::.Initialize Method
DocumentEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
public:
virtual void Initialize(
    Object^ obj,
    String^ addinFolder
) sealed

Parameters

obj
Type: System..::.Object
addinFolder
Type: System..::.String

Implements

IEntryPoint..::.Initialize(Object, String)

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


OnShutdownEO Method

[image]

Revit 2011 API
DocumentEntryPoint..::.OnShutdownEO Method
DocumentEntryPoint Class See Also Send Feedback
For Revit VSTA internal use only.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void OnShutdownEO()
Visual Basic (Declaration)
Public Sub OnShutdownEO
Visual C++
public:
virtual void OnShutdownEO() sealed

Implements

IEntryPoint..::.OnShutdown()()()

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


PromptForFamilyInstancePlacement Method

[image]

Revit 2011 API
DocumentEntryPoint..::.PromptForFamilyInstancePlacement Method
DocumentEntryPoint Class See Also Send Feedback
Prompts the user to place instances of the specified FamilySymbol.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void PromptForFamilyInstancePlacement(
    FamilySymbol familySymbol
)
Visual Basic (Declaration)
Public Sub PromptForFamilyInstancePlacement ( _
    familySymbol As FamilySymbol _
)
Visual C++
public:
void PromptForFamilyInstancePlacement(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::.FamilySymbol
The FamilySymbol.

Remarks

This method opens its own transaction, so it's not permitted to be invoked in an active transaction. In a single invocation, the user can place multiple instances of the input family type until they finish the placement (with Cancel or ESC or a click elsewhere in the UI). The user will not be permitted to change the type to be placed. Users are not permitted to change the active view during this placement operation (the operation will be completed).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::.InvalidOperationException | Thrown when this API method is invoked in an active transaction, or this document is not active, or this is a family document and the instances of this family symbol can not exist in the current family, or this family symbol has no command to create instance, or the command to create instance is disabled in active view.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


RefreshActiveView Method

[image]

Revit 2011 API
DocumentEntryPoint..::.RefreshActiveView Method
DocumentEntryPoint Class See Also Send Feedback
Refresh the display of the active view in the active document.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void RefreshActiveView()
Visual Basic (Declaration)
Public Sub RefreshActiveView
Visual C++
public:
void RefreshActiveView()

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


ShowElements Method

[image] [image]

Revit 2011 API
DocumentEntryPoint..::.ShowElements Method
DocumentEntryPoint Class See Also Send Feedback
Shows one or more elements by zoom to fit.

Overload List

Name | Description
ShowElements(Element) | Shows the element by zoom to fit.
ShowElements(ElementId) | Shows the element by zoom to fit.
ShowElements(ElementSet) | Shows the elements by zoom to fit.
ShowElements(ICollection<(Of <(ElementId>)>)) | Shows the elements by zoom to fit.

See Also

DocumentEntryPoint Class
DocumentEntryPoint Members
Autodesk.Revit.VSTA Namespace


ShowElements Method (Element)

[image]

Revit 2011 API
DocumentEntryPoint..::.ShowElements Method (Element)
DocumentEntryPoint Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::.Element
Element that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.VSTA Namespace


ShowElements Method (ElementId)

[image]

Revit 2011 API
DocumentEntryPoint..::.ShowElements Method (ElementId)
DocumentEntryPoint Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ElementId elementId
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementId As ElementId _
)
Visual C++
public:
void ShowElements(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::.ElementId
Element id that will be shown.

Remarks

Places the element in the center of screen by moving the view.

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.VSTA Namespace


ShowElements Method (ElementSet)

[image]

Revit 2011 API
DocumentEntryPoint..::.ShowElements Method (ElementSet)
DocumentEntryPoint Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::.ElementSet
The set of elements that will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.VSTA Namespace


ShowElements Method (ICollection(ElementId))

[image]

Revit 2011 API
DocumentEntryPoint..::.ShowElements Method (ICollection<(Of <(ElementId>)>))
DocumentEntryPoint Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public void ShowElements(
    ICollection<ElementId> elementIds
)
Visual Basic (Declaration)
Public Sub ShowElements ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void ShowElements(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::.ICollection <(Of <( ElementId >)>)
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.VSTA Namespace


DocumentEntryPoint Properties

[image] [image]

Revit 2011 API
DocumentEntryPoint Properties
DocumentEntryPoint Class See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Properties

Name | Description
AddinFolder | The full path to the Revit VSTA module.
Application | Retrieves an object that represents the current Application.
Document | Returns the database level document represented by this UI-level document.
Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


AddinFolder Property

[image]

Revit 2011 API
DocumentEntryPoint..::.AddinFolder Property
DocumentEntryPoint Class See Also Send Feedback
The full path to the Revit VSTA module.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public string AddinFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddinFolder As String
Visual C++
public:
virtual property String^ AddinFolder {
    String^ get () sealed;
}

Implements

IEntryPoint..::.AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the VSTA module is loaded in such a way to make that result unreliable.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


Application Property

[image]

Revit 2011 API
DocumentEntryPoint..::.Application Property
DocumentEntryPoint Class See Also Send Feedback
Retrieves an object that represents the current Application.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic (Declaration)
Public ReadOnly Property Application As UIApplication
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


Document Property

[image]

Revit 2011 API
DocumentEntryPoint..::.Document Property
DocumentEntryPoint Class See Also Send Feedback
Returns the database level document represented by this UI-level document.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


Selection Property

[image]

Revit 2011 API
DocumentEntryPoint..::.Selection Property
DocumentEntryPoint Class See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As Selection
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

See Also

DocumentEntryPoint Class
Autodesk.Revit.VSTA Namespace


IEntryPoint Interface

[image]

Revit 2011 API
IEntryPoint Interface
Members See Also Send Feedback

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
public interface IEntryPoint
Visual Basic (Declaration)
Public Interface IEntryPoint
Visual C++
public interface class IEntryPoint

See Also

IEntryPoint Members
Autodesk.Revit.VSTA Namespace


IEntryPoint Members

[image] [image]

Revit 2011 API
IEntryPoint Members
IEntryPoint Interface Methods Properties See Also Send Feedback

The IEntryPoint type exposes the following members.

Methods

Name | Description
FinishInitialization |
Initialize |
OnShutdown |

Properties

Name | Description
AddinFolder |

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


IEntryPoint Methods

[image] [image]

Revit 2011 API
IEntryPoint Methods
IEntryPoint Interface See Also Send Feedback

The IEntryPoint type exposes the following members.

Methods

Name | Description
FinishInitialization |
Initialize |
OnShutdown |

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


FinishInitialization Method

[image]

Revit 2011 API
IEntryPoint..::.FinishInitialization Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
void FinishInitialization()
Visual Basic (Declaration)
Sub FinishInitialization
Visual C++
void FinishInitialization()

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


Initialize Method

[image]

Revit 2011 API
IEntryPoint..::.Initialize Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic (Declaration)
Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
void Initialize(
    Object^ obj,
    String^ addinFolder
)

Parameters

obj
Type: System..::.Object
addinFolder
Type: System..::.String

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


OnShutdown Method

[image]

Revit 2011 API
IEntryPoint..::.OnShutdown Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
void OnShutdown()
Visual Basic (Declaration)
Sub OnShutdown
Visual C++
void OnShutdown()

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


IEntryPoint Properties

[image] [image]

Revit 2011 API
IEntryPoint Properties
IEntryPoint Interface See Also Send Feedback

The IEntryPoint type exposes the following members.

Properties

Name | Description
AddinFolder |

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


AddinFolder Property

[image]

Revit 2011 API
IEntryPoint..::.AddinFolder Property
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.VSTA
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2011.0.0.0

Syntax

C#
string AddinFolder { get; }
Visual Basic (Declaration)
ReadOnly Property AddinFolder As String
Visual C++
property String^ AddinFolder {
    String^ get ();
}

See Also

IEntryPoint Interface
Autodesk.Revit.VSTA Namespace


Major renovations to the Revit API

Autodesk is using the 2011 Release to position the Revit API for significant future growth. In order to ensure that as the API grows, the interfaces created during this expansion can remain stable for a significant period of time, there are some quite significant up-front changes being made to the existing API.

Changes to the Revit API namespaces

The Revit API namespaces have been changed to be more consistent and more suitable to expansion. In previous releases, API classes were split along the lines of functionality and Revit vertical product, which led to confusion about where classes which were Elements or Symbols belonged if they were specific to one vertical. In the new namespace structure, there is a primary division into three sets of namespaces:

  • Autodesk.Revit.ApplicationServices - contains classes accessing settings and options for the main Revit application
  • Autodesk.Revit.DB - contains classes accessing data from the Revit file
  • Autodesk.Revit.UI - contains classes accessing or customizing the Revit user interface

Within these main namespaces there are subdivisions based on discipline, e.g.:

  • Autodesk.Revit.DB.Architecture
  • Autodesk.Revit.DB.Structure
  • Autodesk.Revit.DB.Mechanical
  • Autodesk.Revit.DB.Electrical
  • Autodesk.Revit.DB.Plumbing

Classes which are useful in more than one discipline are placed in the Autodesk.Revit.DB main namespace.

Less commonly used classes, like event arguments, are also placed in subordinate namespaces, e.g.:

  • Autodesk.Revit.DB.Events
  • Autodesk.Revit.UI.Events

As a result of the rearrangement of the namespaces, a few classes have been modified more drastically than simply being moved to new namespaces:

  • Autodesk.Revit.Geometry.Element has been renamed to Autodesk.Revit.DB.GeometryElement to avoid a naming conflict.
  • Autodesk.Revit.Geometry.Instance has been renamed to Autodesk.Revit.DB.GeometryInstance to avoid a naming conflict.
  • Autodesk.Revit.Structural.Enums.Material has been replaced by the Autodesk.Revit.DB.Structure.StructuralMaterialType enum.
  • Autodesk.Revit.Options.Application has been removed. The properties accessible from this class have been moved into Autodesk.Revit.ApplicationServices.Application.

To obtain a full list mapping the changes from the Revit 2010 API, see the document Revit 2011 API Namespace Remapping.xlsx in the Software Development Kit install.

Split of Revit API DLL

The Revit API has been split into two DLLs. The new DLLs are:

  • RevitAPI.dll - which now contains only methods used to access Revit's application, documents, elements, and parameters at the database level.
  • RevitAPIUI.dll - which contains all API interfaces related to manipulation and customization of the Revit user interface, including:

o    IExternalCommand and External Command related interfaces

o    IExternalApplication and related interfaces

o    Selection

o    RibbonPanel, RibbonItem and subclasses

o    TaskDialogs

In order to facilitate access to application and document level interfaces from both DLLs, the Application and Document classes have also split into two:

  • Autodesk.Revit.UI.UIApplication - provides access to UI-level interfaces for the application, including the ability to add RibbonPanels to the user interface, and the ability to obtain the active document in the user interface.
  • Autodesk.Revit.ApplicationServices.Application - provides access to all other application level properties.
  • Autodesk.Revit.UI.UIDocument - provides access to UI-level interfaces for the document, such as the contents of the selection and the ability to prompt the user to make selections and pick points
  • Autodesk.Revit.DB.Document - provides access to all other document level properties

The ExternalCommandData interface now provides access to the UIApplication object as well as the active view. From the active UIApplication object you can obtain the active UI document. You can also construct the UIApplication from the Application object, and the UIDocument from the DB level document at any time.

New classes for XYZ, UV, and ElementId

New classes have been introduced for the basic XYZ, UV and ElementId classes used in the API. These classes are:

  • Autodesk.Revit.DB.XYZ
  • Autodesk.Revit.DB.UV
  • Autodesk.Revit.DB.ElementId

These new classes provide a more consistent and complete interface, operate more quickly by having their implementation be entirely in managed code, and are immutable thus making them more suitable for use as properties. The following table summarizes the old and new methods for the XYZ and UV classes:

Old XYZ/UV member | New XYZ/UV member | Notes
AlmostEqual() | IsAlmostEqualTo() |
Angle() | AngleTo() |
AngleAround() | AngleOnPlaneTo() |
Cross() | CrossProduct() |
Distance() | DistanceTo() |
Dot() | DotProduct() |
Basis | N/A | Use BasisX, BasisY, BasisZ as required
IsNormalized | IsUnitLength() |
IsZero | IsZeroLength() |
Item | Item | Property is now read-only
Length | GetLength() |
Normalized | Normalize() |
X | X | Property is now read-only
Y | Y | Property is now read-only
Z | Z | Property is now read-only

All Revit API methods accepting or returning these types have been converted to the new classes.

In addition, the collections for these types have been removed. Methods which used to take dedicated Revit collections now take equivalent .NET collection interfaces containing these types:

  • Autodesk.Revit.ElementIdSet \-> ICollection<Autodesk.Revit.DB.ElementId>
  • Autodesk.Revit.Geometry.XYZArray \-> IList<Autodesk.Revit.DB.XYZ>
  • Autodesk.Revit.Geometry.UVArray \-> IList<Autodesk.Revit.DB.UV>

The major impact to existing code is the replacement of the collections, and the changes to the classes designed to make them immutable. Code which previously change the coordinates of an XYZ via setting XYZ.X, XYZ.Y, and/or XYZ.Z, now should construct a new XYZ with the desired coordinates.

One further impact is the fact that ElementId is now a class, instead of a struct, and should not be passed with "ref" in C# or "ByRef" in VB.NET.

Replacement for Symbol and properties that access types

The Symbol class has been renamed to ElementType.

The properties that access types from Elements have been replaced:

Old property | New interfaces | Notes
Element.ObjectType | Element.GetTypeId(), Element.ChangeTypeId() | ChangeTypeId() returns the id of a new element; in rare cases, changing the element type will result in deletion of the current element. Static versions which operate on sets of elements are also supplied.
Element.SimilarObjectTypes | Element.GetValidTypes() |

New transaction interfaces

New interfaces have been added to the API related to Transactions. These interfaces will provide a more comprehensive set of options for managing changes being made to the Revit document.

At this time, the new transaction interfaces are not compatible with the automatically-opened transactions created around ExternalCommand callbacks and VSTA macros. So, Autodesk recommends that you not use these interfaces until compatible changes have been made to those frameworks. In order to experiment with the new interfaces, a document needs to be opened or created while in an external command. In the new document, either the old transaction interfaces or the new ones can be used, as long as they are not used together in the same document.

There are three main classes among the new interfaces plus a few supporting classes. The main classes represent three different (but related) transaction contexts.

Transaction -- a context required in order to make any changes to a Revit model. Only one transaction can be open at a time; nesting is not allowed. Each transaction must have a name, which will be listed on the Undo menu in Revit once a transaction is successfully submitted.

SubTransaction -- can be used to enclose a set of model modifying commands. Sub-transactions are optional. They are not required in order to modify the model. They are a convenience tool to allow logical splitting of larger tasks into smaller ones. Sub-transaction can only be created within an already opened transaction and must be closed (either committed or rolled back) before the transaction is closed (committed or rolled back). Unlike transactions, sub-transaction may be nested, but any nested sub-transaction must be closed before the enclosing sub-transaction is closed. Sub-transactions do not have name, for they do not appear on the Undo menu in Revit.

Transaction group -- allows grouping together several independent transactions, which gives the owner of a group an opportunity to treat many transactions at once. When a transaction group is to be closed, it can be rolled back, which means that all already submitted transactions will be rolled back at once. If not rolled back, a group can be either submitted or assimilated. In the former case, all submitted transactions (within the group) will be left as they were. In the later case, transactions within the group will be merged together into one single transaction that will bear the group's name. A transaction group can only be started when there is no transaction open yet, and must be closed only after all enclosed transactions are closed (rolled back or committed). Transaction groups can be nested, but any nested group must be closed before the enclosing group is closed. Transaction groups are optional. They are not required in order to make modifications to a model.

All three transaction objects share some common methods:

Start | Will start the context.
Commit | Ends the context and commits all changes to the document.
RollBack | Ends the context and discards all changes to the document.
GetStatus | Returns the current status of a transaction object

Besides having the GetStatus returning the current status, both Commit and RollBack methods also return a status indicating whether or not the method was successful. Available status values include:

Uninitialized | The initial value after object is instantiated; the context has not started yet
Started | Set after a transaction object successfully started (Start method was called)
Committed | Set after a transaction object successfully committed (Commit method was called)
RolledBack | Set after a transaction object successfully rolled back (RollBack method was called)
Pending | Set after transaction object was attempted to be either submitted or rolled back, but due to failures that process could not be finished yet and is waiting for the end-user’s response (in a modeless dialog). Once the failure processing is finished, the status will be automatically updated (to either Committed or RolledBack status).

The new Transaction interfaces replace the old APIs:

  • Document.BeginTransaction()
  • Document.EndTransaction()
  • Document.AbortTransaction()

which have been removed from the API.

Refactored Document properties related to transactions

Two existing properties have been re-implemented to better complement the changes in the transaction framework:

  • Document.IsReadOnly

Indicates that a document is – either temporarily or permanently - in read-only state. If it is read-only, it would mean that new transactions may not be started in that document, thus no modification could be made to the model.

  • Document.IsModifiable

Indicates whether a document is or is not currently modifiable. A document is not modifiable if either there is no transaction currently open or when some temporary state lock modification for a certain operation. Taken from another perspective, a transaction may be started only when document is not yet modifiable, but is also not read-only.

Transactions in events

All events have been changed to no longer automatically open transactions like they originally did in earlier releases. As a result of this new policy, the document will not be modified during an event unless one of the event’s handlers modifies it by making changes inside a transaction. A transaction may be opened by either the event handler if there is no transaction already opened (sometimes when the event is invoked, there is already a trasnaction open). If an event handler opens a transaction it is required that it will also close it (commit it or roll it back), otherwise all eventual changes will be discarded.

Please be aware that modifying the active document is not permitted during some events (e.g. the DocumentClosing event). If an event handler attempts to make modifications during such an event, an exception will be thrown. The event documentation indicates whether or not the event is read-only.

New ExternalCommand and ExternalApplication registration mechanism

The Revit API now offers the ability to register API applications via a .addin manifest file.

Manifest files will be read automatically by Revit when they are places in one of two locations on a user's system:

  • In a non-user specific location in "application data"

o    For Windows XP - C:\Documents and Settings\All Users\Application Data\Autodesk\Revit\Addins\2011\

o    For Vista/Windows 7 - C:\ProgramData\Autodesk\Revit\Addins\2011\

  • In a user specific location in "application data"

o    For Windows XP - C:\Documents and Settings\<user>\Application Data\Autodesk\Revit\Addins\2011\

o    For Vista/Windows 7 - C:\Users\<user>\AppData\Roaming\Autodesk\Revit\Addins\2011\

All files named .addin in these locations will be read and processed by Revit during startup.

A basic file adding one ExternalCommand looks like this:

<?xml version="1.0" encoding="utf-8" standalone="no"?>

<RevitAddIns>

   <AddIn Type="Command">

      <Assembly>c:\MyProgram\MyProgram.dll</Assembly>

      <AddInId>76eb700a-2c85-4888-a78d-31429ecae9ed</AddInId>

      <FullClassName>Revit.Samples.SampleCommand</FullClassName>

      <Text>Sample command</Text>

      <VisibilityMode>NotVisibleInFamily</VisibilityMode>

      <VisibilityMode>NotVisibleInMEP</VisibilityMode>

      <AvailabilityClassName>Revit.Samples.SampleAccessibilityCheck</AvailabilityClassName>

      <LongDescription>

         <p>This is the long description for my command.</p>

         </p/>

         <p>This is another descriptive paragraph, with notes about how to use the command properly.</p>

      </LongDescription>

      <TooltipImage>c:\MyProgram\Autodesk.jpg</TooltipImage>

      <LargeImage>c:\MyProgram\MyProgramIcon.png</LargeImage>

   </AddIn>

</RevitAddIns>

A basic file adding one ExternalApplication looks like this:

<?xml version="1.0" encoding="utf-8" standalone="no"?>

<RevitAddIns>

   <AddIn Type="Application">

      <Name>SampleApplication</Name>

      <Assembly>c:\MyProgram\MyProgram.dll</Assembly>

      <AddInId>604B1052-F742-4951-8576-C261D1993107</AddInId>

      <FullClassName>Revit.Samples.SampleApplication</FullClassName>

   </AddIn>

</RevitAddIns>

Multiple AddIn elements may be provided in a single manifest file.

The new mechanism currently offers the following XML tags:

Tag | Description
Assembly | The full path to the add-in assembly file. Required for all ExternalCommands and ExternalApplications.
FullClassName | The full name of the class in the assembly file which implements IExternalCommand or IExternalApplication. Required for all ExternalCommands and ExternalApplications.
ClientId | A GUID which represents the id of this particular application. ClientIds must be unique for a given session of Revit. Autodesk recommends you generate a unique GUID for each registered application or command. Required for all ExternalCommands and ExternalApplications. The property UIApplication.ActiveAddInId provides programmatic access to this value, if required.
Name | The name of application. Required; for ExternalApplications only.
Text | The name of the button. Optional; use this tag for ExternalCommands only. The default is "External Tool".
Description | Short description of the command, will be used as the button tooltip. Optional; use this tag for ExternalCommands only. The default is a tooltip with just the command text.
VisibilityMode | Provides the ability to specify if the command is visible in project documents, family documents, or no document at all. Also provides the ability to specify the discipline(s) where the command should be visible. Multiple values may be set for this option. Optional; use this tag for ExternalCommands only. The default is to display the command in all modes and disciplines, including when there is no active document. Previously written external commands which need to run against the active document should either be modified to ensure that the code deals with invocation of the command when there is no active document, or apply the NotVisibleWhenNoActiveDocument mode.
AvailabilityClassName | The full name of the class in the assembly file which implemented IExternalCommandAvailability. This class allows the command button to be selectively grayed out depending on context. Optional; use this tag for ExternalCommands only. The default is a command that is available whenever it is visible.
LargeImage | The path to the icon to use for the button in the External Tools pulldown menu. The icon should be 32 x 32 pixels for best results. Optional; use this tag for ExternalCommands only. The default is to show a button without an icon.
LongDescription | Long description of the command, will be used as part of the button's extended tooltip. This tooltip is shown when the mouse hovers over the command for a long amount of time. You can split the text of this option into multiple paragraphs by placing <p> tags around each paragraph. Optional; use this tag for ExternalCommands only. If neither of this property and TooltipImage are supplied, the button will not have an extended tooltip.
TooltipImage | The path to an image file to show as a part of the button extended tooltip, shown when the mouse hovers over the command for a longer amount of time. Optional; use this tag for ExternalCommands only. If neither of this property and TooltipImage are supplied, the button will not have an extended tooltip.
LanguageType | Localization setting for Text, Description, LargeImage, LongDescription, and TooltipImage of external tools buttons. Revit will load the resource values from the specified language resource dll. The value can be one of the eleven languages supported by Revit. If no LanguageType is specified, the language resource which the current session of Revit is using will be automatically loaded. For more details see the section on Localization.

The Revit.ini registration mechanism remains in place for the 2011 release but will be removed in the future. The Revit.ini mechanism does not offer any of the new capabilities listed above. In addition, because Dynamic Model Update registration requires a valid AddInId, updaters may not be registered from applications declared in Revit.ini.

Localization

You can let Revit localize the user-visible resources of an external command button (including Text, large icon image, long and short descriptions and tooltip image). You will need to create a .NET Satellite DLL which contains the strings, images, and icons for the button. Then change the values of the tags in the .addin file to correspond to the names of resources in the Satellite dll, but prepended with the @character. So the tag:

<Text>Extension Manager</Text>

Becomes

<Text>@ExtensionText</Text>

where ExtensionText is the name of the resource found in the Satellite DLL.

The Satellite DLLs are expected to be in a directory with the name of the language of the language-culture, such as en or en-US. The directory should be located in the directory that contains the add-in assembly. See http://msdn.microsoft.com/en-us/library/sb6a8618.aspx to create managed Satellite DLLs.

You can force Revit to use a particular language resource DLL, regardless of the language of the Revit session, by specifying the language and culture explicitly with a LanguageType tag. For example:

<LanguageType>English_USA</LanguageType>

would force Revit to always load the values from the en-US Satellite DLL and to ignore the current Revit language and culture settings when considering the localizable members of the external command manifest file.

Revit supports the 11 languages defined in the Autodesk.Revit.ApplicationServices.LanguageType enumerated type: English_USA, German, Spanish, French, Italian, Dutch, Chinese_Simplified, Chinese_Traditional, Japanese, Korean, and Russian.

External Command Accessibility

The interface

  • IExternalCommandAvailability

allows you control over whether or not an external command button may be pressed. The IsCommandAvailable interface method passes the application and a set of categories matching the categories of selected items in Revit to your implementation. The typical use would be to check the selected categories to see if they meet the criteria for your command to be run.

In this example accessibility check allows a button to be clicked when there is no active selection, or when at least one wall is selected:

public class SampleAccessibilityCheck : IExternalCommandAvailability

{

    public bool IsCommandAvailable(Autodesk.Revit.ApplicationServices.Application applicationData, CategorySet selectedCategories)

    {

        // Allow button click if there is no active selection

        if (selectedCategories.IsEmpty)

            return true;

        // Allow button click if there is at least one wall selected

        foreach (Category c in selectedCategories)

        {

            if (c.Id.IntegerValue == (int)BuiltInCategory.OST_Walls)

                return true;

        }

        return false;

    }

}

External Command and External Application registration utility

The .NET utility DLL RevitAddInUtility.dll offers a dedicated API capable of reading, writing and modifying Revit Add-In manifest files. It is intended for use from product installers and scripts. Consult the API documentation in the RevitAddInUtility.chm help file in the SDK installation folder.

Here are some code snippets showing use of the RevitAddInUtility API.

First, creating a new .addin manifest file which contains one external command and one external application:

//create a new addin manifest

RevitAddInManifest Manifest = new RevitAddInManifest();

//create an external command

RevitAddInCommand command1 = new RevitAddInCommand("full path\\assemblyName.dll", Guid.NewGuid(), "namespace.className");

command1.Description = "description";

command1.Text = "display text";

//this command only visible in Revit MEP, Structure, and only visible in Project document or when no document at all

command1.VisibilityMode = VisibilityMode.NotVisibleInArchitecture | VisibilityMode.NotVisibleInFamily;

//create an external application

RevitAddInApplication application1 = new RevitAddInApplication("appName", "full path\\assemblyName.dll", Guid.NewGuid(), "namespace.className");

//add both command(s) and application(s) into manifest

Manifest.AddInCommands.Add(command1);

Manifest.AddInApplications.Add(application1);

//save manifest to a file

RevitProduct revitProduct1 = RevitProductUtility.GetAllInstalledRevitProducts()[0];

Manifest.SaveAs(revitProduct1.AllUsersAddInFolder + "\\RevitAddInUtilitySample.addin");

Second, reading from an existing addin file:

RevitProduct revitProduct1 = RevitProductUtility.GetAllInstalledRevitProducts()[0];

RevitAddInManifest revitAddInManifest = Autodesk.RevitAddIns.AddInManifestUtility.GetRevitAddInManifest(

           revitProduct1.AllUsersAddInFolder + "\\RevitAddInUtilitySample.addin");

Attributes for configuring ExternalCommand and ExternalApplication behavior

Transaction mode

The custom attribute Autodesk.Revit.Attributes.TransactionMode should be applied to your implementation class of the IExternalCommand interface to control transaction behavior for external command. There is no default for this option. You must apply it to legacy application classes to allow your application to function in Revit 2011.

This mode controls how the API framework expects transactions to be used when the command is invoked. There are three supported values:

  1. TransactionMode.Automatic - The API framework will create a transaction on the active document before the external command is executed and the transaction will be committed or rolled back after the command is completed (based upon the return value of the ExternalCommand callback). This means that command code cannot create and start its own Transactions, but it can create SubTransactions as required during the implementation of the command. The command must report its success or failure status via the Result return value.
  2. TransactionMode.Manual - The API framework will not create a transaction (but it will create an outer group to roll back all changes if the external command returns a failure status). Instead, you may use combinations of Transactions, SubTransactions, and TransactionGroups as you please. You will have to follow all rules regarding use of transactions and related classes. You will have to give your transaction(s) names, which will then appear in the Undo menu. Revit will check that all transactions (also groups and sub-transactions) are properly closed upon return from an external command. If not, it will discard all changes made to the model.
  3. TransactionMode.ReadOnly - No transaction (nor group) will be created, and no transaction may be created for the lifetime of the command. The External command may use methods that only read from the model, but not methods that write anything to it. Exceptions will be thrown if the command either tries to start a transaction (or group) or attempts to write to the model.

In all three modes, the TransactionMode applies only to the active document. You may open other documents during the course of the command, and you may have complete control over the creation and use of Transactions, SubTransactions, and TransactionGroups on those other documents (even in ReadOnly mode).

For example, to set an external command to use automatic transaction mode:

[Regeneration(RegenerationOption.Manual)]

[Transaction(TransactionMode.Automatic)]

public class Command : IExternalCommand

{

    public Autodesk.Revit.IExternalCommand.Result Execute(Autodesk.Revit.ExternalCommandData commandData,

                                                          ref string message,

                                                          Autodesk.Revit.ElementSet elements)

    {

        // Command implementation, which modifies the active document directly and no need to

        // start/commit any transactions.

    }

}

Regeneration option

The custom attribute Autodesk.Revit.Attributes.RegenerationAttribute should be applied to your implementation class of the IExternalCommand interface and IExternalApplication interface to control the regeneration behavior for the external command and external application. There is no default for this option. You must apply it to legacy application classes to allow your application to function in Revit 2011.

This mode controls whether or not the API framework automatically regenerates after every model modification. There are two supported values:

  1. RegenerationOption.Automatic - The API framework will regenerate after every model level change (equivalent behavior with Revit 2010 and earlier). Regeneration and update can be suspended using SuspendUpdating for some operations, but in general the performance of multiple modifications within the same file will be slower than RegenerationOption.Manual. This mode is provided for behavioral equivalence with Revit 2010 and earlier; it is obsolete and will be removed in a future release.
  2. RegenerationOption.Manual - The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.

For example, to set an external command to use manual regeneration mode:

[Regeneration(RegenerationOption.Manual)]

[Transaction(TransactionMode.Automatic)]

public class Command : IExternalCommand

{

    public Autodesk.Revit.IExternalCommand.Result Execute(Autodesk.Revit.ExternalCommandData commandData,

                                                          ref string message,

                                                          Autodesk.Revit.ElementSet elements)

    {

        // Command implementation, which modifies the document and calls regeneration APIs when

        // needed.

    }

}

To set an external application to use automatic mode

[Regeneration(RegenerationOption.Automatic)]

public class Application : IExternalApplication

{

    public Autodesk.Revit.UI.Result OnStartup(ControlledApplication application)

    {

        // OnStartup implementation

    }

    public Autodesk.Revit.UI.Result OnShutdown(ControlledApplication  application)

    {

      // OnShutdown implementation

    }

}

The regeneration mode used for code executed during events and updater callbacks will be the same mode applied to the ExternalApplication or ExternalCommand during which the event or updater was registered.

Manual regeneration and update

  • Document.Regenerate
  • Document.AutoJoinElements

These new methods have been added to allow an application running in manual regeneration mode to update the elements in the Revit document at any time.

Journaling mode

The custom attribute Autodesk.Revit.Attributes.JournalingAttribute can optionally be applied to your implementation class of the {{IExternalCommand}}interface to control the journaling behavior during the external command execution session.

  • JournalMode.UsingCommandData

Uses the “StringStringMap” supplied in the command data. Hides all Revit journal entries in between the external command invocation and the StringStringMap entry. Commands which invoke the Revit UI for selection or for responses to task dialogs may not replay correctly.

  • JournalMode.NoCommandData

Does not write contents of the ExternalCommandData.Data map to the Revit journal. But does allow Revit API calls to write to the journal as needed. This option should allow commands which invoke the Revit UI for selection or for responses to task dialogs to replay correctly.

New element iteration interfaces

New interfaces have been added to the API to permit iteration of elements and element ids. These new interfaces have been designed to provide a more flexible and usable interface for a variety of applications, while being completely implemented in native Revit code to provide the best possible performance.

Existing element iteration routines have been replaced, including:

  • Document.Elements (all versions of this property)
  • ElementIterator
  • Filter and all subclasses of it
  • Application.Create.Filter
  • Classes and properties related to the ParameterFilter:

o    CriteriaFilterType

o    Document.FilterTypeSupported

o    FilterCriterion

o    ParameterStorage

The new element iteration interfaces offer several enhanced capabilities from their predecessors:

  • The ability to iterate and filter elements from a document, or only elements from an arbitrary list of element ids, or elements visible in a view (replacing View.Elements)
  • The ability to clearly identify filters which are designed for best performance ("Quick Filters"), which do not expand the element in memory when evaluating whether the element passes the filter
  • The ability to use chained shortcuts which automatically apply commonly used filters, e.g.

FilteredElementCollector collector = new FilteredElementCollector(document);

// Finds all walls in a certain design option

ICollection<ElementId> walls = collector.OfClass(typeof(Wall))

                                        .ContainedInDesignOption(myDesignOptionId)

                                        .ToElementIds();

  • The ability to logically group more than two filters.
  • The ability to match derived types automatically when using the type filter and type filter shortcut.
  • The ability to iterate elements from all design options or from any specific design option.
  • The ability to use foreach on the collector element, and to use the class with LINQ queries. This is due to the connection between the collector class and System.Collections.Generic.IEnumerable<Element>. Note that because the ElementFilters and the shortcut methods offered by this class process elements in native code before their managed wrappers are generated, better performance will be obtained by using as many native filters as possible on the collector before attempting to process the results using LINQ queries.

FilteredElementCollector collector = new FilteredElementCollector(m_doc);

// First apply a built-in filter to minimize the number of elements processed by LINQ

collector.WherePasses(new ElementCategoryFilter(BuiltInCategory.OST_Levels));

var levelElements = from element in collector

                    where element.Name == "Level 1"

                    select element;  // LINQ query to find level with name == "Level 1"

Level level1 = levelElements.Cast<Level>().ElementAt<Level>(0);

Detailed information on the new element iteration interfaces can be found in the document "Element iteration APIs" in the SDK.

Note that there are a few behavioral changes in the new iteration mechanism when compared to the old:

  • View templates were previously returned as Element. They are now returned as the correct View subclass (ViewPlan, View3d, etc). You can identify these using the new View.IsTemplate property.
  • Previous element iteration methods only returned elements of the main model, the active design option, and primary design options of each option set. Elements of design options which were not active and not primary were excluded. In the new iteration API, by default, design option membership is no longer considered when iterating elements. In order to find the same elements which were iterated in the 2010 API, you should use the following filters combined using 'OR':

o    An ElementDesignOptionFilter with id = InvalidElementId, to match all elements not associated to a design option.

o    An ElementDesignOptionFilter with id = DesignOption.GetActiveDesignOptionId(), to match elements in the active design option.

o    A PrimaryDesignOptionMemberFilter, to match all elements in primary design options.

Replacement for View.Elements

The property View.Elements has been removed and replaced with a constructor for FilteredElementCollector taking a document and view id. This allows you to use filtering and LINQ queries against the elements visible in a given view.

Replacement for 3 structural enums

The enumerated types

  • Autodesk.Revit.Structural.Enums.InstanceUsage
  • Autodesk.Revit.Structural.Enums.Material
  • Autodesk.Revit.Structural.Enums.WallUsage

have been replaced with new enums:

  • Autodesk.Revit.DB.Structure.StructuralInstanceUsage
  • Autodesk.Revit.DB.Structure.StructuralMaterialType
  • Autodesk.Revit.DB.Structure.StructuralWallUsage

Some of the names of the members have changed.

Replacement for AnalyticalModel

The class hierarchy for accessing the structural analytical model has been replaced. The new class hierarchy offers a more streamlined interface and more capabilities to read data and modify analytical model settings.

The following AnalyticalModel subclasses have been removed:

  • AnalyticalModel3D
  • AnalyticalModelFloor
  • AnalyticalModelFrame
  • AnalyticalModelLocation
  • AnalyticalModelWall

Access the data you used to find on those subclasses on the base AnalyticalModel class, as follows:

Old property | Found on | New method | Notes
.Curve | AnalyticalModelFrame | GetCurves() | If analytical model was approximated, .Curve would have previously returned non-approximated analytical model. Now GetCurves() will return approximated analytical model when analytical model is approximated. GetCurve() is a shortcut method returning the single curve.
.Curves | AnalyticalModel3D, AnalyticalModelFloor, AnalyticalModelFrame, AnalyticalModelLocation, AnalyticalModelWall | GetCurves() | AnalyticalCurveType.ActiveCurves will return the analytical model displayed by Revit. Most of the time, this is what is desired.
.Point | AnalyticalModelLocation | GetPoint() | GetCurves() can also be called, the return will be a single curve of almost 0-length containing the point.
.Profile | AnalyticalModelFrame | GetSweptProfile() |
.RigidLink | AnalyticalModelFrame | GetCurves(AnalyticalCurveType.RigidLinkHead) or GetCurves(AnalyticalCurveType.RigidLinkTail) | AnalyticalCurveType.RigidLinkHead retrieves the Rigid Link at the end, and AnalyticalCurveType.RigidLinkTail retrieves the Rigid Link at the start.
.SupportData | AnalyticalModel3D, AnalyticalModelFloor, AnalyticalModelFrame, AnalyticalModelLocation, AnalyticalModelWall | GetAnalyticalModelSupports() |

Note that the curves returned from these new methods will not have their Reference properties set, and cannot be used for the properties like Curve.EndPointReference. Instead, you can obtain References to the curves and their endpoints through construction of an AnalyticalModelSelector object containing the necessary information.

The AnalyticalModel class offers new methods to access other Analytical Model properties, such as:

  • Adjustment information, both manual and automatic
  • Parameter information, including projection, hard points, approximation, and rigid links
  • Analytical offset

The AnalyticalModelProfile class has been replaced by the AnalyticalModelSweptProfile class, which offers similar contents to the original class.

The AnalyticalSupportData and AnalyticalSupportInfo classes have been replaced by collections of AnalyticalModelSupport objects. This new class offers the same information offered by AnalyticalSupportInfo, plus:

  • The support priority
  • The curve, point, and face providing support

The new AnalyticalSupportChecking interface offers the ability to run the check for unsupported structural elements. The new AnalyticalConsistencyChecking interface offers the ability to run a consistency check for the Analytical Model.

The results of both checks are added to the document as warnings.

Access the AnalyticalModel through the method GetAnalyticalModel() on Element. This replaces the AnalyticalModel property of Wall, Floor, ContFooting and FamilyInstance.

The integer values of the enumerated type AnalyticalSupportType have changed. They no longer match the values returned for the built-in parameter BOUNDARY_CONDITIONS_TYPE, use the members of the enum BoundaryConditionsType instead.

Replacement for gbXMLParamElem

The new class EnergyDataSettings replaces the gbXMLParamElem class. The members of the old class can be accessed via properties in the new class as follows:

gbXMLParamElem property | EnergyDataSettings property
BuildingConstruction | ConstructionSetElementId
BuildingService | ServiceType
BuildingType | BuildingType
ExportComplexity | ExportComplexity
GroundPlane | GroundPlane
PostalCode | This is not supported in the new interface as the property has been removed from the element stored within Revit. It was removed because the data often conflicted with other settings provided during gbXML export.
ProjectLocation | This data is not supplied; it was always the same as Document.ActiveProjectLocation
ProjectPhase | ProjectPhase

Revit exceptions

All Revit API methods have been changed to throw subclasses of Autodesk.Revit.Exceptions.ApplicationException. Some Revit exceptions, such as

  • ArgumentException
  • InvalidOperationException
  • FileNotFoundException

closely mirror the corresponding .NET System exception types. However, some of them have subclasses which are unique to Revit, e.g.

  • AutoJoinFailedException
  • RegenerationFailedException
  • ModificationOutsideTransactionException

In addition, there is a special exception type called InternalException, which represents a failure path which was not anticipated. Exceptions of this type carry extra diagnostic information which can be passed back to Autodesk for diagnosis.

Removed deprecated events

The pre-Revit 2010 events:

  • Application.OnDocumentSaved
  • Application.OnDocumentSavedAs
  • Application.OnDocumentOpened
  • Application.OnDocumentClosed
  • Application.OnDocumentNewed
  • Application.OnDialogBox
  • Document.OnSaveAs
  • Document.OnSave
  • Document.OnClose

have been removed from the API. To replace these, use the replacement events in both Revit External Applications and VSTA macros.

Changes to VSTA

There are many changes to the VSTA framework:

  1. Revit VSTA no longer depends on the proxy DLL. Macros are now written referencing RevitAPI.dll and RevitAPIUI.dll directly. This allows macros access to the full features of the Revit API, including generic methods, all events and other methods missing from the proxy previously. Module templates have been updated accordingly, and the references will be added automatically when upgrading macros from previous releases.
  2. The entry point classes ThisApplication and ThisDocument have been adjusted to the direct reference of the API classes. They also now represent UIApplication and UIDocument (instead of Application and Document).
  3. The Transaction and Regeneration attributes must be applied to the ThisApplication and ThisDocument class. Their meanings for VSTA are same as for external commands. Module templates have been updated with default assignments, but upgraded modules must have these added manually.
  • A special AddInId attribute can be added to modules. This allows VSTA macros to work with updaters. When new modules are created this attributes is automatically generated with a random Guid.
  • The Module_Startup methods are now executed at the time when the module is first loaded (as the Revit application starts for Application-level macros, and as the document is loaded for document-level macros).
  4. No transactions may be opended in the Module_Startup and Module_Shutdown methods.

New modules created in Revit 2011 should be "ready to code" - all framework changes have been incorporated into the templates.

Upgraded macros and modules will need to be adjusted to the framework changes mentioned above, as well as all of the API changes (namespace changes, modified APIs).

Major enhancements to the Revit API

Dynamic Model Update

Dynamic model update offers the ability for a Revit API application to modify the Revit model as a reaction to changes happening in the model. This facility is offered through implementation of updaters. The updater interface offers the ability to implement a method that is informed of the scope of changes that triggered the update.

In order to "subscribe" an updater to the right set of changes, the updater should be assigned one or more update triggers. Update triggers are combinations of "Change Scope" and "Change Type". Change Scope may be either an explicit list of element ids in a document, or an implicit list of elements communicated via an ElementFilter. Change Type represents one of an available list of possible changes, including element addition, deletion, and modification of geometry, parameters, or any property of the element.

Elements changed event

The new event

  • Application.DocumentChanged

is raised after every transaction gets committed, undone, or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the Dynamic Model Update framework.

Failure API

There are two capabilities offered by the new failure API:

  1. The ability to define and post failures from within API code when a user-visible problem has occurred.
  2. The ability to respond to failures posted by Revit and by API code through code in your application.

This section offers a high level overview of both capabilities; more detail about the failures API is provided in the "Failure API" document in the Revit API help file.

As a part of exposing these new capabilities, all overloads accepting "PostedErrors" have been removed from the API.

Failure posting

If you are using the failure posting mechanism to report your problem, all you need to do is:

  1. If you are creating a new failure not already existing in Revit, define the new failure and register it in the FailureDefinitionRegistry during the OnStartup() call of your ExternalApplication (new failures must be registered at Revit startup)
  2. Find the failure definition id, either from the BuiltInFailures classes or from your pre-registered custom failure using the class related to FailureDefinition
  3. Post a failure to a document that has a problem - using the classes related to FailureMessage to set options and details related to the failure

Failure handling

Normally posted failures are processed by Revit's standard failure resolution UI at the end of transaction. The user is presented information and options in the UI to deal with the failures.

However, if your operation (or set of operations) on the document requires some special treatment for certain errors (or even all possible errors), you can customize failure resolution. Custom failure resolution can be supplied:

  • For a given transaction using the interface IFailuresPreprocessor.
  • For all possible errors using the FailuresProcessing event.

Finally, the API offers the ability to completely replace the standard failure processing user interface using the interface IFailuresProcessor.

Select element(s), point(s) on element(s), face(s) or edge(s)

  • Selection.PickObject
  • Selection.PickObjects

New methods have been added to prompt the user to select items from the Revit model. When using the new selection methods from your application you can:

  • Allow users to make one or multiple selections
  • Allow users to make multiple selections via box select
  • Provide a custom status prompt to direct the user what to select
  • Provide a custom selection filter (Autodesk.Revit.UI.ISelectionFilter) to accept only those items which your application supports
  • Provide a list of preselected items which will be selected and highlighted when the selection activity starts
  • Reference(Element) - This new constructor allows you to obtain a Reference for an Element; it can be useful when adding preselected elements to the PickObjects() call.

Pick point on the view active workplane

  • Selection.PickPoint()

New methods have been added to prompt the user to pick a point on the view active workplane. When using these methods you have the option of overriding the user's default snap settings and providing a custom status prompt to direct the user what to pick. The method returns an XYZ location corresponding to the user's pick.

For 2D and 3D views, you can set the active workplane via the new setter property for View.SketchPlane. This allows you to control the plane used for calls to the PickPoint() method.

For 2D views where the active workplane cannot be changed, such as drafting and sheet views, the method picks a point in the default coordinate system of the view.

Additional options for Ribbon customization

There are new Ribbon components supported via the Ribbon API:

  • SplitButton - a pulldown button with a default pushbutton attached
  • RadioGroup - a set of ToggleButtons, where only one of the set can be active at a time
  • ComboBox - a pulldown containing a set of selectable items, which can be grouped optionally
  • TextBox - an input field for users to enter text
  • SlideOut panel - an extra panel can optionally slide down from a Ribbon panel; this panel can contain any of the standard Ribbon components

For ComboBox and TextBox, events are included; these events call your API code when the component is changed by the user.

The new property:

  • RibbonItem.Visible

provides control over whether a particular item is visible.

The new properties:

  • RibbonItem.LongDescription
  • RibbonItem.ToolTipImage

allow you to set up an extended tooltip for the Ribbon item. This tooltip can display a longer set of text, and/or a single image.

The new property:

  • PushButton.AvailabilityClassName

allows assignment of an availability class to controlled whether or not the button is available, similar to the option provided for ExternalCommands registered by manifest.

There is also a new option supported for PulldownButton - a separator can now be added between buttons this component.

There is also a new option to add custom panels to the Analyze tab in Revit as well as the Add-Ins tab, via a new overload of Application.CreateRibbonPanel().

As a result of these enhancements, some pre-existing APIs have changed:

  • RibbonPanel.AddButton(), RibbonPanel.AddPulldownButton(), and RibbonPanel.AddPushButton() have been replaced with RibbonPanel.AddItem()
  • RibbonPanel.AddStackedButtons() overloads have been replaced with RibbonPanel.AddStackedItems() overloads
  • Property RibbonPanel.Items has been replaced with method RibbonPanel.GetItems()
  • Property PulldownButton.Items has been replaced with method PulldownButton.GetItems()
  • Method PulldownButton.AddItem() has been removed. Use PulldownButton.AddPushButton() for this operation.
  • Methods have been removed. Use RibbonPanel.AddItem() for this operation.
  • RibbonPanel.AddToPulldown() has been removed. Use PulldownButton.AddItem() for this operation.
  • PulldownButton.AddPushButton() has been removed. Use PulldownButton.AddItem() for this operation.

Create and display Revit-style Task Dialogs

The API now offers the ability to create and display Revit-style Task Dialogs. It is intended to provide capabilities similar to System.Windows.Forms.MessageBox with a Revit look-and-feel such as:

Construct an instance of the class:

  • Autodesk.Revit.UI.TaskDialog

and use the members of that class to set the instructions, detailed text, icons, buttons and command links to be displayed in the task dialog. Then display the dialog using the Show() method. After the user responds to the dialog by clicking one of the buttons or links, the Show() method returns an identifier indicating the user's preferred choice.

There are also shortcut static Show() methods on this class providing a quick way to show simple task dialogs.

Idling event

The new event

  • UIApplication.Idling

is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button. The event allows changes to a document if a new transaction is opened.

Because this event is invoked between user actions in the Revit UI, if the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

Sun and shadows settings element

The SunAndShadowSettings class represents the settings applied to a project or view regarding the position, dates, time intervals and other options for the sun control and solar studies. Obtain the SunAndShadowSettings for a particular view from the View.SunAndShadowSettings property. Obtain the SunAndShadowSettings for the project from SunAndShadowSettings.GetActiveSunAndShadowSettingsId().

MEP Electrical API

Demand factor and load classifications

The property

  • ElectricalSystem.LoadClassification

has been replaced with a new property

  • ElectricalSystem.LoadClassifications

The new property returns a semicolon-delimited string listing the load classifications assigned to the system. Load classifications are now an element and can be found through regular element iteration.

The class

  • DemandFactor

was replaced by

  • ElectricalDemandFactorDefinition.

The method

  • ElectricalSetting.GetDemandFactor()

has been replaced by

  • ElectricalLoadClassification.DemandFactorId

which returns the id of the ElectricalDemandFactorDefinition element assigned to the load classification.

Panel schedules

A new comprehensive API has been introduced to support access to Panel Schedules and their contents. The major classes exposed by this API are:

  • TableView - represents a view that shows a table.
  • TableData - holds most of the data that describe the style of the rows, columns, and cells in a table.
  • TableSectionData - holds row, column and cell data for a TableData instance.
  • PanelScheduleView - represents a view that shows a panel schedule.
  • PanelScheduleData - holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule.
  • PanelScheduleTemplate - represents a branch panel, a switchboard or a data panel template.
  • PanelScheduleSheetInstance - represents an instance of a panel schedule placed on sheet.

Cable tray and conduit

New classes and elements have been added to the API related to Cable Tray and Conduit elements. The major classes introduced by this API are:

  • CableTrayConduitBase - the base class for cable trays and conduits.
  • CableTrayConduitRunBase - the base class for cable tray and conduit runs.
  • CableTray - a cable tray instance.
  • CableTrayType - a cable tray type.
  • CableTrayRun - a cable tray run.
  • Conduit - a conduit instance.
  • ConduitType - a conduit type.
  • ConduitRun - a conduit run.

The previously existing API classes

  • ConduitType
  • ConduitTypeSet

have been renamed to

  • WireConduitType
  • WireConduitTypeSet

as a result of the introduction of the new conduit elements.

Analysis Visualization Framework

This new functionality creates a mechanism for external analysis applications to easily display the results of their computation as 3D data in the Revit model. Note that the results data is transient; it is stored only in the model for the duration of the current Revit session.

The SpatialFieldManager class is used to create, delete, and modify the "containers" in which the analysis results are stored.

The FieldDomainPoints sub-classes indicate the points where analysis results are computed.

The FieldValues class contains the values for each domain point. Each domain point can have multiple values, each for a separate "measurement" at this point. For example, if a solar calculation is being done for every day of the year, each point would have 365 corresponding values.

The code below assigns results for two data points on a surface:

SpatialFieldManager sfm = SpatialFieldManager.CreateSpatialFieldManager(view,1);

Reference reference = doc.Selection.PickObject(ObjectType.Face, "Select a face");

int idx = sfm.AddSpatialFieldPrimitive(reference);

Face face = reference.GeometryObject as Face;

IList<UV> uvPts = new List<UV>();

uvPts.Add(new UV(0, 0));

uvPts.Add(new UV(0.1, 0.1));

FieldDomainPointsByUV pnts = new FieldDomainPointsByUV(uvPts);

List<double> doubleList = new List<double>();

IList<ValueAtPoint> valList = new List<ValueAtPoint>();

doubleList.Add(0);

valList.Add(new ValueAtPoint(doubleList));

doubleList.Clear();

doubleList.Add(10);

valList.Add(new ValueAtPoint(doubleList));

FieldValues vals = new FieldValues(valList);

sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals);

Small enhancements & API interface changes

Family & massing API enhancements

Rehost a form

The overloaded methods

  • Form.Rehost()

rehost a form to a new edge, face, curve, or sketch plane.

Obtain the location of point placement references from a family

The methods

  • FamilySymbol.GetFamilyPointPlacementReferences()
  • FamilyInstance.GetFamilyPointPlacementReferences()

provide information about the location and geometry of point placement references in the loaded family symbol or placed family instance. These points are found in Panel families and flexible components.

Associate array dimension to label in families

The property

  • BaseArray.Label

associates the number of members of the array with a family parameter.

A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. The property can also unbind a labeled family parameter.

Dissociate label from dimension in families

The property

  • Dimension.Label

can be set to null to dissociate a dimension from a label parameter.

Rename and replace a family parameter

The method

  • FamilyManager.RenameParameter()

allows you to rename a Family parameter.

The overloaded methods

  • FamilyManager.ReplaceParameter()

allow you to replace a Family parameter with a new shared parameter, or a shared parameter with a new Family parameter.

Reporting parameters

The property

  • FamilyParameter.IsReporting

identifies if the parameter is a reporting parameter. If true, the parameter is associated to a dimension value and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.

The methods

  • FamilyManager.MakeReporting()
  • FamilyManager.MakeNonReporting()

change a family parameter to be reporting or non-reporting.

Place 2D family types on views

A new overload

  • ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, View)

has been added to support placement of 2D families in target views. This can be used for placement of detail components, annotation symbols, and titleblocks into their target views.

Prompt user to interactively place a family type

The method

  • UIDocument.PromptForFamilyInstancePlacement()

prompts the user to place one or more instances of a particular FamilySymbol.

Use IFamilyLoadOptions to override behavior when loading family or family symbol from disk

New overloads for

  • Document.LoadFamily()
  • Document.LoadFamilySymbol()

have been added. These overloads accept IFamilyLoadOptions as an argument, allowing your application to automatically respond to the prompts Revit typically shows the user when reloading a family which already exists in a document. These new overloads apply when loading a family or a family symbol from a file on disk.

Extract PartAtom from loaded family

The method

  • Family.ExtractPartAtom()

writes a PartAtom file describing the loaded family to a specified file on disk.

FamilyHostingBehavior

The enum FamilyHostingBehavior represents the type of host a family expects. The value for a particular family can be obtained from the family's BuiltInParameter.FAMILY_HOSTING_BEHAVIOR parameter.

FamilyInstance.Host property improved

The property

  • FamilyInstance.Host

will now return the host element of face-hosted family instances. Previously it returned null.

Convert family to be face host based

The method

  • FamilyUtils.ConvertFamilyToFaceHostBased()

converts a family to be face host based.

Extract id of a family parameter

The new property

  • FamilyParameter.Id

extracts the id of a FamilyParameter as an ElementId. When you have a shared or family parameter, this Id is needed in order to use the parameter from an ElementParameterFilter during element iteration and as a ParameterChange for an updater. When you have a built-in parameter, the integer value of the id is the same as the integer value of the BuiltInParameter enumeration.

API for solid/solid cut

The static methods in the class

  • SolidSolidCutUtils

expose the ability to add and remove new solid/solid cuts, and to inquire if an element is used in solid/solid cut in a family.

Additional DividedSurface API

Some additional methods have been added to the DividedSurface class and provide access to intersection references:

  • DividedSurface.GetAllIntersectionElements()
  • DividedSurface.AddIntersectionElement()
  • DividedSurface.RemoveIntersectionElement()
  • DividedSurface.RemoveAllIntersectionElements()
  • DividedSurface.CanBeIntersectionElement()

View API changes

NewViewPlan input change

The method

  • Autodesk.Revit.Creation.Document.NewViewPlan()

now accepts a ViewPlanType enum, which contains only those view types which can be created by the method.

Refresh active view

The method

  • Document.RefreshActiveView()

refreshes the display of the active view during the execution of your command so users can see incremental updates to their model. As in the past, Revit will automatically redraw the view after the command completes.

View.IsTemplate

This property identifies if an instance of the View class represents an instance view (which users see in the project browser and graphics window) or a template view.

Save image to new view

The new method

  • Document.SaveToProjectAsImage()

saves the graphics shown in the current view to a rendering view in the document.

API for placeholder sheets

The method

  • ViewSheet.CreatePlaceholder()

creates a placeholder sheet in the document. Placeholder sheets represent sheets stored outside of the Revit model,

but which should be organized along with the Revit sheets.

The property

  • ViewSheet.IsPlaceholder

identifies if a sheet is a placeholder sheet or not.

Import, export and print changes

Import DWG as link

The method

  • Document.Link()

imports a DWG into the document as a link.

Identify if import instance is linked

The property

  • ImportInstance.IsLinked

identifies if an import instance element is a link to an external file.

Print API changes

The property

  • PrintSetup.CurrentPrintSetting

has been changed to an IPrintSetting. This interface may represent a PrintSetting element, or an InSessionPrintSetting object representing the In-session print settings for Revit printing.

The property

  • PrintSetup.InSessionPrintSetting

has been added to return the In-session print settings object. The in-session print settings will no longer returned in the collection of elements from the property

  • Document.PrintSettings

The event arguments for the event

  • Document.DocumentPrinting

has been changed to return an IPrintSetting object as well.

The property

  • ViewSheetSetting.CurrentViewSheetSet

has been changed to an IViewSheetSet. This interface may represent a ViewSheetSet element, or an InSessionViewSheetSet object representing the In-session view sheet set for Revit printing.

The property

  • ViewSheetSetting.InSessionViewSheetSet

has been added to return the In-session view sheet set object. The in-session view sheet set will no longer returned in the collection of elements from the property

  • Document.ViewSheetSets

Export option for color mode

The new property

  • ACADExportOptions.Colors

allows the option of exporting colors matching the AutoCAD Color Index colors, or as 24-bit true color RGB values.

Export model to IFC

The new method

  • Document.Export(string, string, IFCExportOptions)

exports the document to the Industry Standard Classes (IFC) format.

Export model to DXF

The new method

  • Document.Export(string, string, ViewSet, DXFExportOptions)

exports the document or set of selected views to the DXF format.

Export model to SAT

The new method

  • Document.Export(string, string, ViewSet, DXFExportOptions)

exports the document or set of selected views to the SAT format.

Export image

The new method

  • Document.ExportImage()

exports the graphics shown in one or more views to image file(s).

Extract image of an ElementType

The new method

  • ElementType.GetPreviewImage()

extracts the preview image of an Element Type. This image is similar to what is seen in the Revit UI when selecting the type of an element. You can specify the size of the image in pixels.

Updated DWF and DWFX export methods

The four 2010 Document.Export methods for exporting of DWF-2D, DWF-3D, DWFX-2D and DWFX-3D files were consolidated into just two methods, one for exporting to DWF format, another to DWFX format. The corresponding export options classes are:

  • DWFExportOptions
  • DWFXExportOptions

Both methods can export both 2D views as well as 3D views in one call.

Export id

The static method

  • ExportUtils.GetExportId()

retrieves the GUID representing an element in DWF and IFC export. This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used instead.

Parameter API changes

ParameterFilterElement

Provides access to filter elements associated to views. You can access and modify the categories associated to a filter and the rules associated to a filter. You can also create new filters using an input list of categories and rules.

Rules are organized in a hierarchy based on parameter value type:

  • FilterIntegerRule - applies to integer and enumerated type parameters.
  • FilterDoubleRule - applies to double type parameters.
  • FilterElementIdRule - applies to ElementId type parameters.
  • FilterStringRule - applies to String type parameters.

Rules are associated to evaluators and value providers.

Evaluators are classes which determine how to evaluate the rule based on the value of the parameter and the value set in the rule. There are two hierarchies of evaluators:

  • FilterStringRuleEvaluator - applies to FilterStringRule rules, offers options for equality, begins with, ends with, contains, greater than, and less than evaluations.
  • FilterNumericRuleEvaluator - applies to other rule types, offers options for equality, greater than, and less than.

At this time, the hierarchy of evaluators is not extendable in the API.

Value providers determine how the value is obtained for the evaluation. In this release, there is only one value provider available: ParameterValueProvider.

Extract GUID from a Parameter

The new properties

  • Parameter.IsShared
  • Parameter.GUID

identify if a given parameter is a shared parameter, and if it is, extract its GUID.

Extract id of a parameter

The new property

  • Parameter.Id

extracts the id of a parameter as an ElementId. When you have a shared or family parameter, this Id is needed in order to use the parameter from an ElementParameterFilter during element iteration and as a ParameterChange for an updater. When you have a built-in parameter, the integer value of the id is the same as the integer value of the BuiltInParameter enumeration.

SuspendUpdating applies to Parameter.Set

SuspendUpdating performance improvements now apply to Parameter.Set by default. By using the new constructor for SuspendUpdating which takes a boolean suspendForParameterSet, you can turn off this option.

The performance benefits of this can be extremely significant (95-99% improvement in speed) if you are setting instance parameters on family instances (where the instance parameters are defined in the family itself, and not added to the instances via shared parameters). For most other applications of Parameter.Set this will likely have no visible performance benefit.

Note that SuspendUpdating applies only to RegenerationMode.Manual.

Alignment and ItemFactoryBase.NewAlignment() method

The Alignment element subclass has been removed. NewAlignment() and element iteration will now return alignments as Dimension elements.

DimensionType - access to the dimension style

The property

  • DimensionType.StyleType

identifies the style to which the dimension type can be applied, e.g. linear, angular, radial, etc.

Create sloped wall on mass face

The method

  • FaceWall.Create()

creates a new instance of a face wall on the sloped face of a mass.

Face.GetBoundingBox() method

This new method returns a BoundingBoxUV with the extents of the parameterization of the face.

NewFootPrintRoof() input

The method

  • Autodesk.Revit.Creation.Document.NewFootPrintRoof()

has been changed. It now outputs an array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Floor slope and elevation

The slope and elevation at a point on floor's surface can be found using the methods:

  • Floor.GetVerticalProjectionPoint()
  • Floor.GetNormalAtVerticalProjectionPoint()

Converting between Model Curves and Detail/Symbolic Curves

The Revit API offers new utilities to convert model curves to and from detail curves or symbolic curves.

  • Document.ConvertModelToDetailCurves()
  • Document.ConvertDetailToModelCurves()
  • Document.ConvertModelToSymbolicCurves()
  • Document.ConvertSymbolicToModelCurves()

In all these methods, the original curves are deleted. If the curves do not lie in the appropriate plane for their target curve type, they will be projected to the target plane.

CurveElement type

The new property

  • CurveElement.CurveElementType

identifies if a particular curve is a model curve, detail curve, symbolic curve, reference line, room, area or space separation line, insulation detail curve, repeating detail profile line, or revision cloud line.

Shared base classes for Room, Space, Area and their tags

The new classes Enclosure and EnclosureTag act as shared base classes for rooms, spaces, and areas, and room tags, space tags, and area tags, respectively. Some shared functionality from the derived classes has been moved into the base classes. There are some minor impacts to the previous API interfaces:

  1. The RoomTag, SpaceTag, AreaTag property Leader has been renamed to HasLeader
  2. The Room and Space properties Area and Perimeter have been moved to the base class, thus granting access to these properties for the Area class as well.

View-specific elements

The new properties

  • Element.ViewSpecific
  • Element.OwnerViewId

identify if the element is owned by a particular view (for example, a Detail Curve is owned by the drafting view in which it is drawn), and which view is the owner. These properties align with the ElementOwnerViewFilter which can be used in Element iteration.

Monitoring elements

The new functions

  • Element.IsMonitoringLinkElement()
  • Element.IsMonitoringLocalElement()
  • Element.GetMonitoredLinkElementIds()
  • Element.GetMonitoredLocalElementIds()

indicate whether an element is monitoring any elements in the local document or in linked files.

Design Options

The new static function

  • DesignOption.GetActiveDesignOptionId()

returns the id of the active design option within the document.

The new property

  • DesignOption.IsPrimary

identifies if the design option is the primary option within its owning design option set.

Family template path

The property

  • Application.FamilyTemplatePath

provides the default path for family template files.

Write comments to the Revit Journal File

The method

  • Application.WriteJournalComment()

allows the API application to write comments to the Revit Journal file for diagnostic, testing, and other purposes.

Window extents

The properties

· UIApplication.MainWindowExtents

· UIApplication.DrawingAreaExtents

provide access to the outer coordinates of the Revit window and drawing area, in pixels. An application can use these value to correctly locate its own UI relative to the Revit UI.

City.WeatherStation

The new property

  • City.WeatherStation

provides an identifier for the nearest weather station.

Labels matching commonly used enumerated type values

The new class LabelUtils provides methods to obtain the user-visible label corresponding to certain enum values. These routines obtain the label corresponding to the name in the current Revit language. Support is offered for:

  • BuiltInParameter
  • BuiltInParameterGroup
  • ParameterType
  • UnitType
  • DisplayUnitType
  • gbXMLBuildingType

Keyboard shortcut support for API buttons

API buttons found on the Ribbon can be assigned a keyboard shortcut. Buttons created by applications registered using manifest files now use an id based on their application id and button name to provide a unique identifier for the button. The keyboard shortcut will be maintained even if the order of registration of API applications changes.

MEP API

Validation in ElectricalSystem properties

The properties

  • ElectricalSystem.Length
  • ElectricalSystem.VoltageDrop

now throw an InvalidOperationException when the value cannot be computed (instead of returning 0).

WireMaterialType, InsulationType, TemperatureRatingType

These methods now inherit from ElementType.

DuctConnector, PipeConnector, ElectricalConnector

The methods now inherit from a new common base class, ConnectorElement.

Structural API

NewTruss() in Revit Architecture

The Autodesk.Revit.Creation.Document.NewTruss method(), which was previously only enabled in Revit Structure, is now also enabled in Revit Architecture.

Truss - attach and detach chord

The methods

  • Truss.AttachTopChord
  • Truss.DetachTopChord

have been replaced by methods

  • Truss.AttachChord
  • Truss.DetachChord

supporting both top and bottom chords as inputs.

Drop truss and beam systems

The new methods

  • Truss.DropTruss()
  • BeamSystem.DropBeamSystem()

delete the parent collection elements after disassociating their constituent members.

Rebar API changes

The new methods

  • Autodesk.Revit.Creation.Document.NewRebarBarType()
  • Autodesk.Revit.Creation.Document.NewRebarHookType()
  • Autodesk.Revit.Creation.Document.NewRebarCoverType()

allow creation of new instances of these elements.

The RebarBarType class has a new interface. (Formerly some properties were available through parameters only.)

  • BarDiameter
  • StandardBendDiameter
  • StandardHookBendDiameter (new property for 2011)
  • StirrupTieBendDiameter
  • MaximumBendRadius
  • GetHookPermission() / SetHookPermission()
  • GetAutoCalcHookLengths() / SetAutoCalcHookLengths()
  • GetHookLength() / SetHookLength()
  • GetHookOffsetLength() / SetHookOffsetLength()

The Rebar class has two new properties, includeFirstBar and includeLastBar, which allow suppression of the end bars in a rebar array.

Rebar also has a new interface to its Array functionality. (Formerly these properties were available through parameters only.)

  • LayoutRule: (read-only) Array layout rule.
  • SetLayoutAsSingle() / SetLayoutAsFixedNumber() / SetLayoutAsMaximumSpacing() / SetLayoutAsNumberWithSpacing() / SetLayoutAsMinimumClearSpacing(): Change the array layout rule. Note that the layout rule interacts with several other properties; to avoid confusion, the SetLayout methods require you to specify values for these other properties.
  • ArrayLength: Array length.
  • NumberOfBarPositions: Number of bar positions in the array. The actual number may be 1 or 2 fewer and is given by getQuantity().
  • MaxSpacing: maxium spacing.
  • Quantity: (read-only) Number of bars in the array, equal to getNumberOfBarPositions() minus the number of end bars suppressed with includeFirstBar / includeLastBar.
  • BarsOnNormalSide: flip the array with respect to the start plane.

The method SetLayoutRuleWithoutExaminingHost() has been removed in favor of the new setLayoutRuleAs...() methods.

The methods:

  • Rebar.IsUnobscuredInView()
  • Rebar.SetUnobscuredInView()
  • Rebar.IsSolidInView()
  • Rebar.SetSolidInView()

control the visibility of the Rebar in the indicated view.

New Rebar properties and methods have been introduced to work with spiral rebar:

  • Rebar.Height
  • Rebar.Pitch
  • Rebar.BaseFinishingTurns
  • Rebar.TopFinishingTurns
  • Rebar.ScaleToBoxForSpiral()
  • RebarShapeDefinitionByArc.SetArcTypeSpiral()

Finally, HostedSweep elements are now valid for the Rebar.Host property.

Structural Settings

The class StructuralSettings provides access to many of the values shown in the Revit Structural Settings dialog box:

  • Symbolic Cutback distances
  • Brace symbols
  • Analytical model settings
  • Boundary conditions settings

To obtain the StructuralSettings for a given document, use the static method:

  • StructuralSettings.GetStructuralSettings(Document)

Some items in the Revit Structural Settings dialog box are not accessed through StructuralSettings in the API:

  • Connection Types are individual elements of type StructuralConnectionType that are part of the document.
  • Load cases are individual elements of type LoadCase that are part of the document.

Rigid link built-in parameter change

The built-in parameter id STRUCTURAL_ANALYTICAL_RIGID_LINK has been replaced with

STRUCTURAL_ANALYTICAL_COLUMN_RIGID_LINK and STRUCTURAL_ANALYTICAL_BEAM_RIGID_LINK.

You can also access the value of this parameter for a given element via the AnalyticalModel.RigidLinksOption property.

BoundaryConditions type

A new enum BoundaryConditionsType has been introduced. The values of this enum match the values of the built-in parameter id BOUNDARY_CONDITIONS_TYPE.


Major enhancements to the Revit API in the Subscription Advantage Pack

Conceptual Energy Analysis API

APIs provided for this capability are usable only in sessions with licensed access to the Revit 2011 Subscription Advantage Pack

The new classes in the Autodesk.Revit.DB.Analysis namespace:

  • ConceptualConstructionType
  • ConceptualSurfaceType
  • MassEnergyAnalyticalModel
  • MassLevelData
  • MassSurfaceData
  • MassZone

provide access to the elements and objects created by Revit to perform energy analyses on conceptual design models.

The method

  • Document.Export(string,string,MassGBXMLExportOptions)

supports export of a gBXML file containing conceptual energy analysis elements (mass elements) only.

Small enhancements & API interface changes in this web release

City TimeZone

The new static method

  • SunAndShadowSettings.CalculateTimeZone()

provides direct access to the results of a time zone calculation for a given longitude and latitude.

The City class has been adjusted to return more accurate TimeZone values than previous.

Note that the properties

  • SiteLocation.Latitude
  • SiteLocation.Longitude

do not adjust the time zone of the site location according to these calculations, but you can make this change directly with by setting the TimeZone property.

Document preview

The new method

  • Document.GetDocumentPreviewSettings

gets the settings related to the stored document preview image for a given document. It returns a DocumentPreviewSettings object, whose members include:

  • DocumentPreviewSettings.PreviewViewId - the id of the view to use for the preview
  • DocumentPreviewSettings.ForceViewUpdate() - sets the document to update the view before saving (useful when the document is never displayed)